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Introduction

LVhen professional Web designers want to build a Web site, they
nearly always pick Dreamweaver. With more than 80 percent of all

designers using it, Dreamweaver is definitely the top dual-platform (PC and
Mac) Web design software application on the market today.

What makes Dreamweaver so great is the combo WYSIWYG (What You See
Is What You Get) coding interface that allows you to build HTML files con-

taining text, graphics, and other media, all the while seeing the page layout
and its code as you create pages in Dreamweaver’s Design and Code views.

Dreamweaver accurately generates all the HTML, CSS, and JavaScript source
code needed for Web developers to create HTML- and XHTML-compliant
Web pages. No more sweating intricate coding issues such as merging

table cells, creating rollover effects, and applying CSS to text. In addition,
Dreamweaver integrates well with Fireworks, for roundtrip graphic editing,
and Contribute CS4, for Web site maintenance and the publishing of content
changes by a nondesigner.

Dreamweaver CS4 enhancements include a better coding environment, inte-
grated support for JavaScript, CSS, server-side scripting, and accessibility
standards-compliant code. You'll also find improved dynamic content cre-
ation tools for connecting to databases, such as MySQL, and working with

a variety of scripting technologies including PHP, ASP, JSP, ASP.NET, and
ColdFusion. In addition, you can easily integrate XML content with both XSL
and the Spry framework for Ajax. The program contains all the tools you
need to streamline page development, and many of the tools are customiz-
able through the Preferences dialog box.

Use Dreamweaver CS4 All-in-One For Dummies as your complete guide to the
exciting world of Web design.

About This Book

This is a reference book, which means you can jump around from chapter
to chapter reading whatever section you want as the need arises. Don’t feel
locked into the idea of reading the book from cover to cover. In fact, think of
each minibook as its own little reference zone where each zone is split into
chapters about performing specific tasks in Dreamweaver CS4.
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Conventions Used in This Book

Everything you find in this book is written so you don’t have to wade
through complicated technical help files or have to commit anything to
memory. To keep things simple, you’ll find detailed, step-by-step, easy-to-
follow instructions. When more technical information is needed to clarify
a particular process, it’s often set apart from the main text in sidebars or
noted in the margins with a Technical Stuff icon.

The bottom line is that we want to make you comfortable with Dreamweaver
CS4 and hope that you’ll continue to use this book frequently and consider it
the main resource of your Web-design library.

Conventions Used in This Book

To help with new terms and concepts, the following typographical rules or
conventions are used in this book:

4+ New terms: New terms are set apart with italics. For example:

Dreamweaver CS4 comes with the commonly used JavaScripts,
which it refers to as behaviors, ready to insert into your pages from
the Behaviors panel.

4+ Placeholder text: Text that is a placeholder is set in italic. For example,

in the phrase

Type username here
username is a placeholder for your actual username, so it is set in italic.

Code samples: We include short code samples in monospaced text
within the paragraph, like this: <img src"logo.gif">. We set longer
code samples apart from the text, like this:

<frameset rows="780,*” cols="*" frameborder=""NO"
border="0" framespacing=""0"">
<frame src="top.html” name="topFrame” scrolling="NO"
noresize title="topFrame”>

For the times when we want to draw your attention to particular parts of
code samples, we indicate the important parts in bold, as in this exam-
ple: <div id="sidebar"></div>.

Reader entry: Anything you need to type is in boldface.

Cross-platform: Whenever PCs and Macs have different shortcuts, we
include both the Windows equivalent (right-click) and the Mac equiva-
lent (Control+click).

Web addresses: Web addresses are set apart in monofont, such as www.
adobe. com.
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What You Don’t Have to Read

You don’t have to read any part of this book that doesn’t interest you. For exam-
ple, if you never intend to use Fireworks, skip that chapter! And if you see a side-
bar that covers more technical information than you care to know, pass it by. The
main thing is that you know what is available and only read what is useful to you.

Assumptions About You

With only a general idea of the kinds of people who will buy this book, we
must make certain broad assumptions about all our readers to write this
book with enough specificity for each of you. Therefore, we assume that
you’re a human being living on planet Earth who knows how to operate a
computer and visit Web sites on the Internet, and has a desire to create Web
sites using Dreamweaver. Beyond that, we presume no prior knowledge of
Web design, HTML, JavaScript, CSS, or Dreamweaver.

How This Book Is Organized

This book is divided into nine minibooks, each of which is further divided
into relevant chapters organized by topic. Each minibook relates to the most
important concepts in Dreamweaver.

Book I: Getting Started

Begin your trip into the world of Web design with a look around the
Dreamweaver workspace and a review of site design. Then find out how to
create and manage sites in Dreamweaver — an important step that enables
you to take full advantage of Dreamweaver’s automated features.

Book II: Mastering the Basics

Book Il shows you everything you need to know to create new documents;
add and format text on a page; insert graphics and create rollover buttons;
convert text and graphics into clickable links to other Web pages; add
movies, sound, and other media files to your pages; add tables for organizing
content; and build fantastic forms for collecting data from visitors.

Book I11: Working Like the Pros

Book IIl walks you through the process of styling your pages with Cascading
Style Sheets (CSS), building sites using Dreamweaver templates, and using
Library items. You also find out about using server-side includes, creating
and using code snippets, and recording and saving custom commands with
the History panel. The final chapter in this minibook contains information on
using Dreamweaver with Fireworks for roundtrip image optimization.
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How This Book Is Organized

Book 1V: Energizing Your Site

When you’re ready to add more zing and pizzazz to your pages, turn to
Book IV. Here you find out how to work with layers instead of tables, create
opportunities for visitor interactivity by adding JavaScript behaviors to
objects on your pages, work with Spry effects and Spry widgets, and design
pages built with frames. The final chapter in this minibook shows you all
about the benefits of XHTML and how to configure Dreamweaver to write
XHTML-compliant code.

Book U: Publishing Your Site

Book V shows you how to run Dreamweaver’s reports and use other tools to
test and fix any errors before you publish your site. You also find out how to
select and set up a remote connection to your host server and transfer files
to the remote site.

Book Vl: Working Collaboratively

Adobe’s Contribute CS4 is a software program that allows nondesigners to
edit and update content on live Web pages through a special interface — all
without needing to know any HTML or Dreamweaver. Book VI contains infor-
mation on setting up, connecting to, and managing a Contribute site.

Book VII: Building Web Applications

This minibook discusses how to select and add Web and application servers
along with how to configure, edit, and delete database connections. When
working with databases, troubleshooting problems is important, so we also
discuss resolving permission problems, database connection issues, and
error messages.

Book VIIl: Making Pages Dynamic

In this minibook, you find out how to define data sources and make them
available for use in your dynamic pages. We also show you how to add
simple dynamic data to your Web pages, as well as create HTML tables for
your recordsets, navigate through your recordsets, and dynamically control
them. In addition, you discover how to test the functionality of your dynamic
site by using Dreamweaver’s Live Data view. This minibook also includes a
chapter on working with ColdFusion components, adding Web services to
your site, and putting custom server behaviors to work.

Book IX: Developing Applications Rapidly

Book IX shows you how to build master and detail pages, search and results
pages, and record insert, update, and delete pages. We also get into more
complicated territory, such as calling ASP command objects, working with
JSP prepared statements, and using stored procedures. Finally, you find out
how to restrict site access.
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Icons Used in This Book
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To make your experience with the book easier, you’ll find a handful of icons
in the margins of the book to indicate particular points of interest.

Tip icons alert you to interesting techniques or hints that can save you time
and effort.

The Remember icon is a friendly cue about things to keep in mind when per-
forming certain tasks or important information that can benefit you in under-
standing how Dreamweaver works.

Any time you see the Warning icon, watch out! Paragraphs marked with this
icon include important information that will help you avoid common design
mistakes and steer clear of trouble.

Occasionally we include some technical information that, while interesting
to some, is not essential reading for everyone. Nevertheless, consider at
least glancing at the text marked with the Technical Stuff icon just in case it
applies to your situation.

Where to Go from Here

Read through the Table of Contents to find what interests you. Otherwise,
consider the following jumping-off topics:

4+ For an overview of Dreamweaver in general and the new features in
Dreamweaver CS4 in particular, go to Book 1.

4+ For information about working with text, graphics, and links, read Book II.

<+

For information on using Cascading Style Sheets, see Book III.

4+ To discover how to work with layers, use JavaScript behaviors, and
work with Spry framework widgets, see Book IV.

For information on publishing your site, see Book V.
For details about working collaboratively with a team, see Book VI.
For instructions on building Web applications, go to Book VII.

To build dynamic Web pages, read Book VIII.

4+ e+

For information on rapid application development, see Book IX.

Beyond this book there are loads of valuable Dreamweaver resources on
the Internet to help you build Web sites. The following is a sample of some
useful sites you’ll find out there:
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Adobe Resources
Dreamweaver Support Center: www . adobe . com/support/dreamweaver/

Dreamweaver Exchange: www.adobe . com/cfusion/exchange/index.
cfm?event=productHome&exc=3&loc=en_us

Author Resources
Luckychair: www . luckychair.com

Standards, Guidelines, and Initiatives
World Wide Web Consortium (W3C): www.w3 .org

Web Accessibility Initiative: www.w3 . org/WATI/

Dreamweaver Extensions

Project Seven: www.projectseven.com
Hot Dreamweaver Fever: www . hotdreamweaver . com
Kaosweaver: www . kaosweaver . com

Web Developer Resources

Web Monkey: www . webmonkey . com

W3 Schools: www.w3schools.com

JavaScript Resources
Dynamic Drive DHTML Scripts: www . dynamicdrive.com

EarthWeb JavaScripts: http://webdeveloper.earthweb.com/webjs/
JavaScript Source: http://javascript.internet.com

CSS Resources
W3C’s CSS: www.w3 .org/Style/CSS/

CSS Zen Garden: www . csszengarden. com

Sitepoint CSS Reference: http://reference.sitepoint.com/css
W3Schools CSS Tutorial: http://w3schools.com/css/default.asp
CSS Beauty: www . cssbeauty. com

Free CSS Templates: www. freecsstemplates.org
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Chapter 1: Cruising Around the
Dreamweaver CS4 Workspace

In This Chapter

v Getting to know the Dreamweaver workspace
+ Understanding the panels and Properties inspector
1~ Setting Dreamweaver preferences

v+~ Finding help in the Help files, tutorials, and Reference panel

A basic understanding of the Dreamweaver workspace can greatly assist
you with using the program. If you're familiar with Dreamweaver but
new to Dreamweaver CS4, use this chapter as a review of the workspace
basics.

This chapter provides a general overview of the workspace and Document
window, a review of the panels and Properties inspector, a quick look at set-
ting preferences, and tips on how and where to find Dreamweaver help.

Choosing a Workspace Layout

When launching Dreamweaver for the very first time, the program automati-
cally opens and displays the newly updated default Designer layout. After
the program is open, you can switch to any of the other available layout
options through Dreamweaver’s Window=>Workspace Layout menu, or by
clicking on the new Workspace Switcher menu button on the workspace’s
Application bar.

With the release of CS4 (which uses the new OS Widget Library (OWL)
interface that is darker gray and more angular than prior versions of
Dreamweaver), the workspace options are now nearly identical for both
Windows and Macintosh platforms. The only slight differences include the
location of the main menu, some keyboard shortcuts, the order and place-
ment of items on the new Application bar, and an integrated workspace area
for the Mac that completely hides the desktop, as indicated in Table 1-1.



Choosing a Workspace Layout

Tabhle 1-1

Windows versus Mac Workspace Differences

Description

Windows

Macintosh

Location and order of
contents on the new
Application Bar

At the top of the
application window,
includes an App
icon, Workspace
Switcher button,
Main Menus,

App Controls
(Layout Widget,
Site Control, Web
Widget, Workspace
Switcher, and Ul

At the top of the
application window,
includes an App icon,
Workspace Switcher
button, App Controls
(Layout Widget, Site
Control, Web Widget,
Workspace Switcher,
and Ul Search Field),
and left-aligned 0S
Window Controls

Search Field), and
right-aligned 0S
Window Controls

Still located at the
top of the Main
monitor

Moved to inside the
Application Bar

Location of Main Menu

Integrated workspace Yes Yes
with no desktop visibility

With this new integrated workspace, all Dreamweaver users, regardless of
platform, now have equal access to the same workspace layouts! Here’s a
closer look at each of the different layout options:

4+ App Developer: Select this layout to have the Databases, Bindings,
Behaviors, Files, Assets, and Snippets panels docked on the left with the
Document window displaying in the center and no Properties inspector.

4+ App Developer Plus: Select this layout to have the App Developer
panels mentioned above docked on the left, the Document window set
to Split Code view in the center, the Properties inspector below the
code, and the iconic view of the Insert, CSS Styles, and AP Elements
panels docked along the right. Click the double arrows at the top of the
panel dock to expand and collapse the panel as needed.

4+ Classic: This layout most closely mirrors the default Designer layout
setup from previous CS versions of Dreamweaver. The right edge of
the screen displays the docked panels, while the rest of the workspace
is composed of the Insert panel across the top, the Document window
in Split Code view below that, and the Properties inspector along the
bottom. In all other CS4 layouts, the Insert panel opens inside at the top
of the dock area. Remember, all the panels can be docked and undocked
(free floating) giving you the flexibility of setting up your workspace to
your liking.
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4+ Coder: Select this layout to have the Files, Assets, and Snippets
panel groups display on the left — similar to Macromedia HomeSite,
Macromedia ColdFusion Studio, and other programming software
applications — with the Document window display in Code view in the
center of the screen.

4 Coder Plus: Identical to the Coder but also includes the iconic view of
the Insert, CSS Styles, and AP Elements panels docked along the right.

4+ Designer: Select this layout to have the Insert, CSS Styles, AP Elements,
Files, and Assets panels docked on the right with the Document window
in Split code view in the center, and the Properties inspector along the
bottom.

4+ Designer Compact: Select this layout to have the iconic Insert, CSS
Styles, AP Elements, Files, and Assets panels docked along the right,
with the Document window in Split code view in the center, and the
Properties inspector along the bottom.

4+ Dual Screen: Select this layout if you have a secondary monitor to the
left or right of your primary monitor. Initially the panel dock displays on
the left monitor while the Document window and code view display on
the right; however, you can customize this setup if you prefer working
with a different configuration.

<P Each of these workspace layouts are designed to assist you with particular
tasks. Choose an Application Developer layout if you’ll be developing appli-
cations, select a Coder option if you’ll be working only with code, select a
Designer layout if you’ll be working with the WYSIWYG editor (Design view)
and Code editor, pick the Classic option if you're already a Dreamweaver
user but not ready to start using the new Designer layout, and when working
with two monitors, choose the Dual Screen layout. If you're still unsure of
which one to use, we recommend you select the Designer option.

Getting to Know the Dreamweaver Workspace

As most Dreamweaver users are designers, we’ll explore the workspace
using the Designer layout, which consists of the Application bar at the top of
the screen, the Document window in the center, the panel dock and panels
on the right, and the Properties inspector along the bottom, as shown in
Figure 1-1 for Windows and Figure 1-2 for Macintosh. All of these elements
work together to assist you with adding and modifying the content in an
open document.
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Figure 1-1:
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Designview  Properties inspector Document window Files panel

Status bar Panel dock Panel group

You find these elements in the Dreamweaver workspace:

4+ Welcome Screen: When you launch Dreamweaver, the Welcome Screen,

which is automatically enabled, appears in the open workspace area
any time no files are open. The Welcome Screen (shown in Figure 1-3)
contains quick links to create new documents and open recent files, and
provides Web links to the Dreamweaver Exchange and to a library of
Adobe training videos. In addition, you'll find links to “Getting Started”
and “New Features” both of which will be helpful for new users and
users seeking quick details about what’s new in CS4.

Hide and show the Welcome Screen by adjusting the Show Welcome
Screen check box in the General category of the Preferences dialog box.
(See “Setting Dreamweaver Preferences,” later in the chapter, for more
on the Preferences dialog box.)
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4+ Application bar: The Application bar layout differs slightly between

Windows and Mac platforms (see Figures 1-1 and 1-2), but their contents
are the same. The bar includes the Dreamweaver logo, a Layout menu
for selecting different code and design views, an Extend Dreamweaver
button for accessing the Dreamweaver Exchange, a site button for
quickly managing new and editing existing Dreamweaver sites (see Book
I, Chapter 3), and a Workspace layout menu for toggling between the dif-
ferent workspace layout options.

Insert panel: The Insert panel has been moved from its bar position at
the top of the Document window to its own panel at the top of the panel
dock. The Insert panel displays a variety of buttons for quickly adding
objects such as images and tables into an open file. You can find a more
in-depth description of it in the “Using the Insert panel” section, later in
the chapter.

Document window: This window shows the active document as you
create and edit it. View the document in Code, Split (half code/half
design), or Design view.

Document toolbar: This toolbar is located at the top of every open
document just beneath the document’s title tab. The toolbar includes
the Code, Split, and Design view buttons as well as quick links for other
features like the new Live View and Live Code settings. For more on the
different buttons and icons, check out the “Document toolbar” section,
later in this chapter.

Coding toolbar: This toolbar, which adds special quick-coding buttons
to the left edge of the Code view area, are particularly useful to program-
mers. Shortcut buttons include options to collapse and expand lines

of code, add or remove line numbers and comment tags, and highlight
invalid code, among several others. Toggle this toolbar on and off by
choosing View=>Toolbars=Coding. Remember, the Coding toolbar is vis-
ible only in Code or Split view.

Standard toolbar: This toolbar has shortcut links to common tasks from
the File and Edit menus such as New, Open, Browse in Bridge, Save, Save
All, Print, Cut, Copy, Paste, Undo, and Redo. To toggle this toolbar on
and off, choose View=>Toolbars=>Standard.

Style Rendering toolbar: This toolbar has shortcut buttons to show
how a design would look using different media types, presuming the
page uses CSS (Cascading Style Sheets) specific to those media types.
For instance, the <body> tag may have different CSS attributes for
handheld devices, such as a BlackBerry, versus screen media, such as a
browser. The right-most button on this toolbar toggles CSS on and off in
Design view. To view this toolbar, which appears in the open Document
window below the Document toolbar, choose View=>Toolbars=>Style
Rendering.
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To find out more about CSS in general, see Book Ill, Chapter 1. To find Book |
out more about CSS for media in particular, visit the World Wide Web
Consortium at www.w3 .org/TR/CSS21/media.html.
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4+ Properties inspector: The properties inspector is docked under the doc-
ument window at the bottom of the screen. The contents of this inspec-
tor change according to the object or text selected in your document.
Select an object in Design or Code view, and then add or change proper-
ties in the Properties inspector. See “Using the Properties inspector,”
later in this chapter, for a more detailed description of its capabilities.
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4 Files panel: Use the Files panel, located at the bottom of the panel dock,
to access and manage all your site files and folders. For a more in-depth
description of this panel, page ahead to “Working with the Files panel,”
later in this chapter.

4+ Tag selector: This status bar area is at the bottom of the open Document
window. Here you see the hierarchy of tags around a selection or wher-
ever you have placed the insertion point on the page. Click any tag in
the Tag selector to quickly select that tag and its contents. This tool is
extremely handy when adding CSS to objects in a document.

4+ Panel groups: Within the panel dock, related panels are combined
together into a single panel group with individual tabs. A more in-depth
description follows later in the chapter in the section “Accessing panels
and panel groups.”

Exploring the Document Window

The Document window is made up of several parts, some of which are
always visible, whereas others can be toggled on and off. The following sec-
tion describes features of the Document window including the Document tab
bar, the Document toolbar, the rulers, grids, and guides, and the status bar.

Document tab bar

The Document tab bar is located directly under the Application bar and
displays the document filename tab and path of an open file. When multiple
files are open, the tabs of every open file display from left to right inside

the tab bar. If you'd prefer to see the documents in a particular order, you
can drag and drop them into the desired position. When space permits, the
blank area to the right of the tab(s) is used to display the local path of the
currently active open document. When multiple files are open and there isn’t
room enough to display the local path of the open file, hovering your mouse
over the document’s filename tab reveals the local path.
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Figure 1-4:
The
Document
toolbar.
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Document toolbar

The Document toolbar (shown in Figure 1-4), located at the top of every
open document, just below the Application and Document tab bars displays
options and details associated with the active document.

Code Design Live File View Validate
view view Code Management Options Markup
| J’Cnda|j§plit ‘;il’:)&sign ﬂ.uvewew|v' H || Tie: [untited Document 1§, & ELL =Y 52 =] Check Page ‘
Code and Design  Live Title Preview/Debug Visual Check Browser
view View in Browser Aids  Compatibility

The Document toolbar has buttons that display different views of your page,
as well as quick links for other features such as adding a page title and pre-
viewing the page in a browser. When you hover your mouse over each of
them, a handy tool tip appears giving you the button’s name and function.
Click the buttons to select options from their submenus:

4+ Code view: Use this setting to hand-code and edit HTML, JavaScript,
server-side coding (for example, PHP, ASP, or CFML), and other code
in the open Document window. The code is colored for easier develop-
ment, but you can change that as well if you are visually impaired or
just prefer a certain color palette The default display font for text inside
Code view is 9-pt Courier, but you can change it in the Fonts category of
Dreamweaver’s Preferences.

4+ Design view: This WYSIWYG (What You See Is What You Get) editor dis-
plays a visual rendering of all the code contained between the <body>
tags of the open document. Manipulate text and other objects in this
view by selecting, editing, and applying properties to the content.
Although similar to what you see in a browser window, this view cannot
display many interactive code elements, such as links or JavaScript, so
be sure to test the page in a browser or use the Live View button.

4+ Split view: The best of both worlds, use Split view to simultaneously see
both Design and Code views in the open Document window. Resize the
two panes by clicking and dragging the divider bar between them.

Note: If the contents of an open document exceed the visible area of the
workspace in any of the three views above, scroll bars appear to help
you scroll to the hidden areas of the page.

Four additional layout options are available, but these are only acces-
sible through the Layout menu button on the Application bar:
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Split Code view: Use Split Code view to simultaneously see two different
Code views of the same open document. Both panes can be resized by
clicking and dragging the divider bar between them.

Design View on Top: Code view can sit on the top or bottom of the
screen. To change the Code view position from the default loca-

tion above the Design view to below it, select this option from the
Application bar Layout menu or click the View Options button on the
Document toolbar and select Design View on Top.

Split Vertically: Both the Split Code and the Code and Design views can
have their horizontally split panels converted to vertically split panels
by selecting the Split Vertically option from the Application bar Layout
menu.

Design View on Left: After you choose Split, the code in Code and
Design view appears on the left whereas Design view appears on the
right side of the Document window. To flip the code view to the right
side of the Document window, select Design View on Left from the
Application bar Layout menu.

Live View: New in CS4, this option allows you to see your code, along
with any dynamic content, /ive in Design view by choosing Viewr>Live
View. To help with troubleshooting display issues, use the options from
the Live View menu to freeze or disable JavaScript, disable plug-ins,
switch between a Testing Server for Document Source or Local Files for
Document links, and access and modify the HTTP Request settings.

Live Code: When Live View is enabled, click the Live Code button to
select objects in Design view and quickly identify the corresponding
code.

For more information about working with live data in Live View and Live
Code, and planning dynamic pages, see Book VIIIL

Title: Enter a title for your page here, which displays in the browser’s
title bar. You may also type a title directly into the code.

For open documents that have been edited but not saved, Dreamweaver
adds an asterisk next to the filename in the Document filename tab as a
visual reminder of the document’s unsaved status. Save the document,
and the asterisk goes away.

File Management: Select a function from the file management drop-
down list.

Preview/Debug in Browser: Preview or debug the open file in any
browser listed in the drop-down list. Add browsers through the
Preferences dialog box.

Server Debug: Click here to see a report of the page to help with debug-
ging in ColdFusion. This button only appears when a managed site uses
a ColdFusion test server.
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4+ Refresh Design View: Refresh the document’s Design view after making
changes in Code view. Code view changes don’t automatically appear in
Design view unless you save the file, press F5, or click this button.

4+ View Options: The View Options menu offers settings for turning on and
off the grid, rulers, guides, and header bar, among other options. Here
you can also flip the position of Design view from top to bottom with the
Split view.

4 Visual Aids: The Visual Aids menu lets you toggle on and off various
tools to assist you with page layout including CSS Layout Box Model,
CSS Layout Outlines, Table Borders, and Invisible Elements, among
others.

4+ Validate Markup: Click this button to validate code within the current
file, current site, or selected files. You can validate markup against doc-
types selected in the Validator category of Dreamweaver’s Preferences,
and results can include the display of errors, warnings, and messages.

4+ Check Page: This tool checks the open file for cross-browser compatibil-
ity. The Results panel displays the errors, if any.

Rulers

Rulers, which appear along the top and left edges of the Document window,
are great tools to assist you with the measurement and placement of objects
in your document. Rulers can display in pixels, inches, or centimeters. The
ruler’s X/Y coordinates, which represent the 0/0 measurement mark for the
horizontal and vertical axes and are located by default at the top-left edge

of the file, can be moved to any location in the open Document window by
clicking and dragging the origin square at the top-left edge of the rulers,

and then releasing the origin point anywhere inside the visible Document
window. The X/Y coordinates then jump to 0/0 at that new position. To
reset the X/Y coordinates to the default location at the top-left edge of the
Document window, choose View=>Rulerst>Reset Origin. Toggle rulers on and
off by choosing Viewr>Rulers=>Show.

Grids

Use the grid to assist with laying out content in Design view. Because the
grid lines extend in regular intervals through the entire document, from left
to right and from top to bottom, you can use them as guides for exact posi-
tioning of objects in your document, as shown in Figure 1-5. For best align-
ment, turn on the Snap to Grid option by choosing View=>Grid=>Snap to Grid.
Control the grid settings, such as grid coloring and spacing, with the Grid
Settings dialog box by choosing Viewr>Gride>Grid Settings. Hide and show
grids by choosing View=>Grid=>Show Grid.



Figure 1-5:
Use the
ruler,
guides, and
grids in
Design view
to assist
you with the
placement
of objects.
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Guides

Guides are horizontal and vertical guide lines that you can drag into the
open Document window to assist you with the measurement and place-
ment of objects. For example, you may want to place the top-left edge of a
layer at exactly 150 pixels in from the left edge of the Document window. A
guide placed at the 150-pixel vertical mark with the Snap to Guide option
enabled would allow you to snap the layer to the guide at that position.
Dreamweaver’s guides work like the guides in Adobe Photoshop and
llustrator; they are visible on-screen in the work environment but aren’t vis-
ible in print or on a Web page.

To create guides, first turn the rulers on (as described in the earlier sec-
tion “Rulers™) and then click and drag guides out from the top and left
ruler bars. When the guide is in the desired position, release the guide
onto the document. Lock or unlock guides as needed for easy reposition-
ing or quick removal by dragging the guide back onto the ruler bar. Choose
View>Guides=>Snap to Guides to have elements snap to guides when posi-
tioning objects, such as layers, inside the Document window. Quickly hide
and show guides by choosing Viewr>Guides=>Show Guides.

Status bar

Dreamweaver’s Status bar (shown in Figure 1-6) includes many handy fea-
tures. The Tag selector is on the bottom-left edge of the Document window
and allows for easy tag and tag content selection. On the bottom-right edge,
the status bar shows the current size (in pixels) of the Document window,
as well as a file size and estimated file opening time reflecting the file pref-
erences for projected site visitors. For example, an open document may
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Figure 1-6:
The Status
bar.

display 760 x 420 and 27K/4 sec, meaning that the current page is optimized
for a monitor with a resolution set to 800 x 600, has a 27K file size, and would
take 4 seconds to load in a browser on a computer using a 56K modem.
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You can resize the Document window to a predetermined size to approxi-
mate the inside of a browser window for testing purposes. On the Download
Size/Download Time drop-down list, select a window size or choose the Edit
Sizes option to create and save custom size settings.

In addition, the status bar includes magnification tools to assist you with
editing page content:

4+ Select tool: Use the Select tool to select content in the Document
window. This is the default tool for selecting objects in your file in
Design view. For example, single-click an image to select it with the
Select tool.

4+ Hand tool: Use the Hand tool in conjunction with a Zoom view to move
the section of the page you're viewing in the Document window. For
example, at 1600% view, the Hand tool allows you to reposition what you
see in the Document window at that magnification.

4 Zoom tool: The Zoom tool allows you to zoom in and out of the Design
view window. Select the tool and click in the Document window to zoom
into the page. Press Alt (Windows) or Option (Mac) and click again to
zoom out. Double-click the Zoom tool button to return to 100% view.

4+ Set Magnification menu: The Magnification menu displays Zoom set-
tings in percentages from 6% to 6400%. Select a preset magnification
view from the drop-down list or type a number in the percentage field
and click Enter (Windows) or Return (Mac) to view the page with a
custom magnification.

Understanding the Panels and Properties Inspector

Dreamweaver uses panels to help you organize, select from, and modify con-
tent, as well as provide access to common features and functions. The main
panels are the Insert panel, Files panel, and the Properties inspector. With
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the exception of the Properties inspector, all panels are located inside the
panel dock area, either individually or inside a panel group. You can, how-
ever, open, resize, reposition, undock, redock, and close any of the panels
and panel groups as desired.

The Panel dock

The dock is a fixed rectangular area at the left and/or right edge of the work-
space (depending on your selected layout) that contains the currently open
panels and panel groups. Each dock can be shown in expanded or collapsed
mode by clicking on the double-arrows in dark gray bar at the top of the dock.

4+ Expanded mode: When the dock is expanded, the individual panels can
either be individually expanded (showing the panel’s contents) or col-
lapsed (showing just the panel’s tab).

4+ Collapsed mode: When the dock is collapsed, the panels appear in
iconic mode with just an icon and panel name.

All panels have common features making them easy to understand:

4+ Options menu: Each panel has an Options menu at the top-right corner
of the panel. Use the Options menus to access panel-specific tasks.

4+ Expand/Collapse: Double-click the panel tab to expand and collapse the
panel or panel group window.

4+ Repositioning: Reposition panels by clicking and dragging on the panel
tab. Panels can be reordered within a panel group, repositioned inside
and outside of panel groups within the dock, and moved outside the
dock to become free-floating panels.

4+ Resizing: To resize the height of docked panels, place your cursor on
top of the divider line between two panels. When the cursor turns into
a double-sided arrow, click and drag to resize the panels. To resize
undocked panels, place your cursor at any edge of the panel window.
When the cursor turns into a double-sided arrow, click and drag to
resize the panel.

Accessing panels and panel groups

Dreamweaver has many panels to help you get the job done, most of which
you can open and close via the Window menu.

Panel groups are sets of related panels combined together as separate
tabbed layers on a single panel, either inside or outside the dock. Access
each panel by clicking the tab at the top of the panel group. For example, the
CSS panel group displays both the CSS Styles and the AP Elements panels;

to see the AP Elements panel in that panel group’s window, click the AP
Elements tab.
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Figure 1-7:
The Insert
panel.

Create new and modify existing panel groups by dragging and dropping
panels into their new locations as desired. Expand and collapse panel
groups by double-clicking on any of the tabs in the group. If docked to the
right or left side of the Dreamweaver workspace, you can undock panels or
entire panel groups by clicking on tab of a panel or on the gray unused area
next to the panel tabs within a panel group, and dragging the panel or panel
group to the new location, either inside or outside the dock.

When rearranging panels outside of the dock, panels can sometimes get hidden
behind each other. If a panel marked as open on the Window menu seems to
have disappeared, try choosing Window=>Workspace Layout=>Reset to neatly
rearrange the open panels and closed any hidden and free-floating panels.

Using the Insert panel

The Insert panel (shown in Figure 1-7) has gray buttons for adding common
objects, such as tables, images, and media, into an open document. As you
hover your mouse over the buttons, the colors on them become visible. If
you’d prefer to see color icons instead, select the Color Icons option from
the Insert panel’s options menu. Each button, when pressed, automatically
adds the correct code to your page for the object or action selected. For
instance, to insert an image, click the image icon (and select the desired
graphic) and the appropriate HTML code is added to your page, as in <img
src="logo.gif">. Though adding objects this way is fast and easy, you
can also add the same objects to your page using the Insert menu.

INSERT

Common ¥ %\
B & E -
B TE- &

]

3

[
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By default, the Insert panel displays the icons and labels for each of the
options within the different available categories, such as Common, Layout,
or Data. You can also choose to display the icons without the labels by
selecting Hide Labels from the panel’s category dropdown menu. Expand
and collapse the Insert panel into and out of tab mode by double-clicking the
panel’s tab. The panel also has an Options menu at the top-right edge, from
which you can hide and show labels and access help files.

To add any of the objects or assets in the Insert panel to an open document,
select one of the categories (Common, Layout, Forms, and so on) and then
do one of the following:



Figure 1-8:
When an
image is
selected,
the Proper-
ties inspec-
tor displays
options

for adding
image
properties.
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4+ Click a button to insert the object.

4 Click the down arrow on a button and select an option from the button’s
dropdown menu.

Some of the buttons insert an object (or perform an action) automatically,
whereas others open object- or action-specific dialog boxes prompting you
to select a file or add attributes or parameters to the object or action. When
inserting objects from the Insert panel into Code view instead of Design
view, you may also encounter the Tag editor. In that case, enter the appro-
priate information and click OK to add the object to your page.

Using the Properties inspector

The Properties inspector is the panel to use for adding formatting and other
attributes or properties to selected objects in your document.

The most versatile of all the panels, the Properties inspector’s contents
change according to the object or text selected in Code or Design view. For
instance, when text is selected on your document, the Properties inspector
displays options for adding properties to text; when a graphic is selected,
the inspector displays options for adding properties to images, as shown in
Figure 1-8. This works for most object selections; the main thing to remem-
ber is that you must select the desired object or content before adding
properties.

PROPERTIES ||
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Working with the Files panel

Use the Files panel to manage (organize, select, and open) all your site files
and folders, view both remote and local file listings, access other files on
your hard drive, and manage sites within Dreamweaver.
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Rather than relying upon your Explorer window (Windows) or Finder (Mac)
to find and open files, create a “managed site” (see Book I, Chapter 3) for
each project you work on in Dreamweaver and use the Files panel to locate
and open all of your site files; your life will be much easier when you central-
ize this task to the Files panel.

The Files panel displays in its collapsed mode in the Designer workspace, and
when displaying a “managed” site, it lists all the files and folders of the speci-
fied directory. You can also expand the panel into two panes to show both
local and remote site views in one window; see the following list for details.

At the top of the Files panel, two drop-down menus assist you with site man-
agement tasks. These two menus, Site Management and Site View, are shown
in Figure 1-9. Here’s the lowdown on these menus:

Site Site
management  view

FILES g&}a =
I Dw 54 E[ Local view (%
Clo ¢ ¢ |5

Local Files J Size] Typ

Figure 1-9:
The Files
panel.

EID site -DW C54 (C:l00.., Fold:
- images Fold:
~ T index.himl 1KE Firef

[
{2 1localibems selected totaling

A

4+ Site Management: This menu lists all the managed sites you’'ve created
in Dreamweaver. A site becomes managed when you define a folder on
your local computer for the HTML files of a specific project, and tell
Dreamweaver where to find that folder. You need to create a managed
site for each project you work on in Dreamweaver. To create a new man-
aged site, scroll down to the bottom of this menu and select Manage
Sites to open the Manage Sites dialog box. For more information on cre-
ating a managed site, see Book I, Chapter 3.

4+ Site View: When the Files panel is collapsed, use the Site View menu to
toggle among four views:

¢ Local: Select this view to see the file structure of the local man-
aged site. You may also use this view to see both local and remote
sites with the Files panel split into two panes. Use the Expand/
Collapse button to toggle between viewing one and two panes. By
default, the local site appears in the right pane and the remote site
appears in the left, but you can modify this in the Site category of
Dreamweaver’s Preferences if you’d prefer having the local pane
appear on the left, like many older FTP programs do.
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e Remote: Select this view to see the file structure of the remote Book |
site. A remote site is a version of your local site sitting on a hosting
server accessible from the internet. You must set up a remote site in
advance to see the remote site files.
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e Testing: This view shows a directory listing of both the testing server
and local site files. You must set up a testing server in advance to see
the testing server site.

¢ Repository: This feature is used when Dreamweaver is setup to use
Subversion, a version control application. Selecting this options
invokes the Version Control context menu, inside which files can be
compared, viewed, and reverted.
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Beneath the drop-down lists are a series of helpful buttons to aid with
transferring files to and from a remote server. Book V, Chapter 4 covers
these buttons, which are Connect/Disconnect, Refresh, Get Files, Put Files,
Check Out Files, Check In Files, and Expand/Collapse.

Use the Files panel Options menu to create new files and folders by choosing
Filec>New File or File>New Folder. New files and folders automatically are
added to the bottom of the Files panel with the name untitled for easy renam-
ing. To use the Files panel to quickly open a file, double-click a filename or
drag and drop a file into the workspace.

In addition to the features-rich Options menu at the top of the panel, the
bottom of the Files panel has a Log button to open the background file activ-
ity log, and a status bar, which displays important file data for individual
selected files, such as title, creation date and time, and file size.

Customizing the Workspace

The Dreamweaver workspace is highly customizable, so you can create a
work environment that best meets your needs and then save the layout for
future use. The panels, for instance, are docked to their respective locations,
but you can reposition and resize them by clicking and dragging them by
their tabs. When you create and save a custom layout, all the panel loca-
tions, groupings, sizes, and expanded/collapsed states are saved along with
the Document window and application window sizes and positions.

Here’s how to work with a custom layout:

4+ To save a custom layout, choose Window=>Workspace Layout->New
Workspace. Give your layout a name and click OK.

4 To open and use a saved layout, choose Window=>Workspace Layout
and then select the layout name.
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4+ To rename a saved layout, choose Window=>Workspace Layout>Manage
Workspaces, select the layout from the listing in the Manage Workspace
Layouts dialog box, and click the Rename button.

4+ To delete a selected layout, choose Window=>Workspace
Layout>Manage Workspaces, select the layout from the listing in the
Manage Workspace Layouts dialog box, and click the Delete button.

4+ To revert a layout to its default settings and arrangement, choose
Window=>Workspace Layoutr>Reset.

Setting Dreamweaver Preferences

You can modify many settings in Dreamweaver’s Preferences dialog
box to further customize your workspace and workflow. To access
the Preferences dialog box, choose Edit=>Preferences (Windows) or
Dreamweaver=~Preferences (Mac).

The Preferences dialog box offers several categories for customization.
Select a category from the list on the left to reveal that category’s prefer-
ence settings on the right side of the dialog box. Figure 1-10 shows the
Preferences dialog box with the General category selected.

Preferences
Category General R
General
Py Dacument aptions: [7] Show Welcome Screen
Coge Coloring [CIReopen documents on startup
Code Format
Code Hints [#] Warn when opening read-only fies
Code Rewriting 5
Copyipaste Enable Related Files )
55 Styles Update links when maving fles: | Prompt |
Fil= Compare
——— File Types | Editors Editing options: /] shaw dialag when inserting abjects
) i [IEnable double-byte inline input
Fi gure 1-10: Invisible Elements Stitch to plain paragraph after heading
. Hew Document
U se th e Preview in Browser [ Allows multiple consecutive spaces
Site %
Status Bar Use <strong> and <em: in place of <b> and <ix
P refe rences validator ‘Warn when placing editable regions within <p> or <hl>-<hé> tags
Centering: () Use <div> tag () Use <center tag
dialog box Masimun uaber of history stopst | 50
to customize Spelling dictionary: | English (American) v
weaver.

Many of the category settings can stay as they are. In some instances,
however, you may choose to modify the settings to improve your work
experience. You can find entries throughout this book that reference the
Preferences settings and suggest ways to customize specific categories.
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Finding Help Book

We all need help from time to time and the best place to find it (for
Dreamweaver, at least) is through the options inside the Help menu. There
you find links that open special dialog boxes or browser windows revealing a
variety of help topics. Read about these topics in more detail in the following
sections.
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To find help for a specific Dreamweaver feature, click the Help button, which
looks like a little question mark, found in most dialog boxes and panels.
Upon clicking the button, the Adobe Help Viewer window opens to display
information for the most closely related topic. For instance, to find out more
about setting properties on graphic files, select an image inserted in a docu-
ment and then click the Help button in the Properties inspector. The Help
Viewer window opens automatically to a Setting Image Properties page.
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Using Dreamweaver Help (F1)

The most resourceful link on the Help menu by far is Dreamweaver Help,
which launches the Dreamweaver C54 Resources Web site where you can
search for help by topic or any keyword. In addition to being extremely thor-
ough and helpful, most results also contain quick links to related topics as
well as related online resources such as tutorials and videos.

You must have a live Internet connection to access the online help files,
which can be launched by choosing Help=>Dreamweaver Help, by pressing
F1, or by visiting http://help.adobe.com/en_US/Dreamweaver/10.0_
Using/index.html.

Search the Help files by selecting a category along the left and drilling down
into the topic area you want to learn more about. When you select a topic on
the left, the details of the topic will appear on the right side of the window.
You can also search for specific topics by typing keywords into the Search
field. Results are listed by order of relevance. You may then select the topic
that most matches your query to view the results of your search. In addition,
when viewing a topic, use the navigation buttons to go forward and back-
ward within the topic area.

Working with the Reference panel

The Reference panel displays reference information for all the markup lan-
guages, programming languages, accessibility standards, and CSS you can
use when building your Web site.

Open this panel by choosing Help=>Reference. The panel opens as a tab
within the Results panel, alongside other helpful tools, such as Search and
Validation, that are covered in later chapters. Select a book from the panel’s
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Book drop-down list to display information from that reference book, as
shown in Figure 1-11. Each entry contains descriptions and examples of the
styles, tags, and objects in your code.

COMPATIBILITY | LiNK CHECKER. | SITEREPORTS, | FIPLOG | SERVERDEBUG

Book: | OREILLY Javascript Reference: | object: | document v |[body ]
t - . ~
Figure 1-11: [~ e 4 Do
Fead:

Selecta i e

reference ta the body object defined by the body element within the document. This property is used as a gatewsy to the | =
Body o roparties,

reference i
bOOk' document.body. leftMargin = 15;
To reference a specific tag, keyword, or attribute in Code view, do one of the
following:
4+ Right-click (Windows) or Control+click (Mac) the item and choose
Reference from the context menu.
4 Place the insertion point in a tag, keyword, or attribute and press F1.
A\

If the reference contains an example you want to copy and paste into
another document, select it from the Reference panel and copy it using the
context or Options menu in the panel.

Uisiting the Dreamweaver Support Center

Several of the Help menu links launch browser windows for online Adobe
Support for Dreamweaver users. The entire Adobe Web site gets updated
regularly and includes tips, updates, examples, and detailed information on
advanced topics, so check the site often.

To help you find specific destinations within Adobe’s online Help Resource
Center, Dreamweaver provides quick access to the following locations
through the Help menu:

4+ Spry Framework Help: This option launches the Spry Framework for
Ajax online developers guide.

4+ ColdFusion Help: This option launches the Adobe ColdFusion online
documentation.

4+ Dreamweaver Exchange: Go to the Dreamweaver Exchange page

where you can search for, purchase, and download free Dreamweaver
extensions.

4 Manage Extensions: Launch the Dreamweaver Extension Manager for

help installing, removing, and submitting extensions to/from the Adobe
Exchange.
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Dreamweaver Support Center: Launch the Dreamweaver Support
Center Web page for searching the Adobe Dreamweaver Knowledge
Base, located at www.adobe . com/support/dreamweaver/

CSS Advisor: Launch the CSS Advisor section of the Adobe Developer
Connection Web site, where you'll find detailed information on all things
CSS including browser compatibility, solutions and workarounds to
common display issues, and comments from the Adobe community.

Adobe Online Forums: Open a page providing access to several Adobe
Web-based and newsreader-based online forums, where you can talk
with other Dreamweaver users about Dreamweaver topics and technical
issues.

Adobe Training: Launch the Adobe Training & Certification Web page
detailing authorized training and certification programs. Adobe offers
self-paced and instructor-led courses, books, links to authorized contin-
ued learning facilities, and details about professional certification
programs.

Registration: Connect to the Internet to register your product online.

Updates: Automatically connect to www.adobe . com to check for soft-
ware updates.

Adobe Product Improvement Program: Sign up for Adobe’s Product
Improvement program where, with your permission, Adobe automati-
cally receives information about your usage to help with improving
future versions of the software.
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Chapter 2: Planning and Designing
Your Site

In This Chapter

v~ Figuring out who your audience is
v~ Taking a look at the site design
1~ Adding graphics to your design

putting a Web site on the Internet involves more than figuring out how
to build Web pages. Creating a site that people actually use requires
careful planning and design, based on site visitors’ expectations and your
(or your client’s) Web site goals.

Planning a good Web site involves conducting market research, defining
business needs, making decisions about Web-based technology, discuss-

ing search engine optimization and accessibility, gathering and organizing
content, setting a budget and signing contracts, purchasing a hosting plan,
and designing and optimizing graphics. Discussing all these topics in detail
is beyond the scope of this book; instead, this chapter focuses on a few key
aspects of Web design that you need to think about. If you want more in-
depth information on Web design, check out Sue Jenkins’s Web design book,
Web Design: The L Line, The Express Line to Learning (Wiley).

Whether designing a site for yourself, your company, or freelance clients,
the overall planning and design process is relatively the same. This chapter
discusses knowing your audience, reviewing design considerations, and
designing a successful site.

Understanding the Web Design Workflow

Building a Web site has a logical workflow. The different stages of the Web
design workflow are as follows:

Define > Design > Build > Test > Launch

Each stage requires cooperation from all parties involved — including the
client, designers, and programmers — because each is responsible for dif-
ferent parts of the process. Table 2-1 shows who should be involved with
each step of the workflow process.
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Knowing Your Audience

Table 2-1 Web Design Workflow

Define Design Build Test Launch

Typically, the client provides content, the designer (you) creates the design
and builds the site, the programmer adds dynamic functionality, everyone
gets involved in testing, and finally, the site gets published to the Internet.

Knowing Your Audience

The ultimate aim of a Web site is to meet the audience’s needs and, at

the same time, achieve the client’s mission. Both the client and you (the
designer) need to have knowledge of the target market, an understanding of
the demographics of the target audience, and a good overview of the exist-
ing online competition.

Defining the client’s expectations

Use the client’s mission statement as a starting point to define its goals for
the Web site. If the client doesn’t have a mission statement, you need to ask
some questions to help define the goals. For example, what does the client
hope to achieve with the Web site? Here are some goals the client may have
for the site:

4+ Provide information to current and potential customers

4+ Generate leads

4+ Sell products and services

4+ Provide information to the general public
When defining the Web site goals, consider the three most important
aspects about the business that make it unique and beneficial to customers.
The look of the site should be largely determined by the industry and Web

site needs, and the organization of the site should be defined by the content
being delivered.

Exploring the audience’s expectations

Market research is one of the best ways to determine site visitors’ expecta-
tions. Here’s the information you need to assemble:

4 The target demographic.

4+ The target visitors’ Web browsing habits. Determine whether they are
seeking products, information, or a consultation, or have information to
share with others.
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4+ The target visitor’s bandwidth capabilities. Not all Internet users have Book |
access to high speed Internet, especially visitors from across the globe. Chapter 2
If this is a consideration, a fast-loading Web page will be one of your

main priorities. g
2.
4 The target visitor’s Internet browsing equipment. Some of your visi- El )
tors may want to view your site on mobile devices in addition to using a E
an Internet browser, which means you may need to develop separate gc:
mobile content or mobile-ready Web pages. Ss

(%)

4 The amount of money they have available to spend on the client’s prod- )

ucts or services.

4+ Whether the target audience prefers to purchase online or shop in a
bricks-and-mortar store.

Collecting this information can help you determine the design direction,
layout, and structure of the site. For instance, if the site is aimed at a world-
wide audience, you may need to consider language and cultural issues.

<P You can find Web sites for every conceivable industry in the world, so a
good place to start the design process when creating a new Web site is to
review what’s already on the Internet. Do a general online search for com-
panies in the same industry world- or country-wide. Then do additional
searches for competition in the same general geographic region, such as
statewide, countywide, and citywide. Think about design, usability, budget,
timeframe, and technical issues. Look at the competitors’ sites and take
notes about what works and what doesn’t with regard to content and layout.

After gathering data about competitors’ sites, draw diagrams and design
ideas, write copy, and make a list of key points that the site should address.
You may even want to generate a preliminary site map of all the sections of
your new site based on your research of competitor’s sites, client feedback,
and so on. A clear understanding of the target audience helps define the
site’s organization and structure.

Examining Issues That Impact the Site Design

When you’re designing a Web site, whether for yourself or for a client, keep
in mind these three main components to any Web project:

4+ Time: Decide when you can deliver the job.

4+ Cost: Determine how much the project is going to cost.

4 Scope: Determine what you hope to achieve.

Most projects begin with some kind of specific limitations with regard to
these project components. One frequent limitation has to do with budget; a
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client may specify that they hope to pay a particular fee for a new Web site
that achieves the defined scope and is delivered by a specific time. Although
that may be an ideal goal, achieving all three components of the Web project
may not be feasible. For example, if a project needs to be delivered in a short
time frame, the project fee may need to increase, or if the client only has X
dollars to pay for the project, only parts of the scope may be met. Obviously,
the three Web project components have a strong dependency between
them; if the project fee, time frame, and scope are in synch, all three can

be achieved. However, if limits are placed on any one of the components, a
compromise may need to be reached.

When you’re considering the best way to transmit a message on a Web site,
you need to take into account several site design considerations, includ-
ing design, usability, accessibility, copyright, budget, and technicality. For
instance, is the new site selling a product or service, is it a nonprofit orga-
nization, or is it a personal Web site? Decide whether the new site will be

a brochureware site (a print brochure in Web format), or if it will have any
dynamic functionality for gathering information, selling products, or provid-
ing password-protected content.

Before beginning any Web project, spend some time reflecting on the follow-
ing site concepts:

4+ Design: The visual design of the page is the most important aspect of the
site. Not only does the look help communicate the information contained
on the page, but it also says a lot about the client, the product or service
being sold, the professionalism of the person (or team) who designed it,
and the site owner’s level of professionalism and competence.

The design itself should be simple with a clear navigation plan. The
navigation scheme and company logo or other identifying icon should
appear on every page in the same general location, allowing easy access
to the home page at all times. You want visitors to move through the
site easily and find what they’re looking for as quickly as possible.

Programs such as Adobe Photoshop have a ton of neat features for
designing graphics and integrating into a Web site. However, sometimes
beginners get carried away and lose focus on the overall design in favor
of showing off the fancy effects they have learned. For instance, there is
no need for text with a drop shadow, inner bevel, inner glow, outer glow,
and a gradient overlay. The same applies to Adobe Flash; it’s great you
can create animations and buttons that fade on mouse up and mouse
down, but if a visitor can’t figure out how to navigate the Web site, the
design will suffer.

4+ Usability: Consider in advance how users will interact with the pages
and the Web site as a whole. Is the site easy to understand and navigate?
Can users access information quickly and is it formatted logically in an
easy-to-read way? You need to clearly define the main idea of each page.
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Keep text short and to the point and include links and graphics relevant
to the rest of the site. Above all, proofread the site for spelling errors
and double-check links. If you have the time, consider asking another
designer, a friend, or family member for their quick feedback about
usability issues. Often times they may be able to point out something
obvious you have missed or attempt to use a feature differently than you
had imagined.

Accessibility: Making a site accessible to people with visual, audi-

tory, motor, and other disabilities has implications for a site’s design.
Consider adding text navigation links instead of (or in addition to)
graphical links for visitors with browsers that don’t support graphics or
visitors using disability software such as speech readers and text view-
ers. Dreamweaver has tools that let you author accessible content. See
the “Designing Web sites with accessibility” sidebar in this chapter for
more information about accessibility issues.

Perhaps Ed Tittel, author of HTML, XHTML, & CSS For Dummies (Wiley),
said it best on his book’s companion Web site (www.edtittel.com
/html4dée/index.php?option=com_content&view=article&id=
73:web-site-accessibility&catid=31:general&Itemid=41): “If
you have a small vanity site and simply don’t care about making its
content accessible to those with reading or vision impairments, then
perhaps site accessibility doesn’t matter . . . to you. But for any kind of
site that may eventually wish to reach a broader audience, or whose
sponsor wants to attract government business at any level (most cities,
counties, states, and the feds all require their vendors to offer acces-
sible sites to users of their products or services), accessibility isn’t an
option — it’s a mandate.”

Copyright: Make sure that any graphics, text, music, video, and other
media you add to the site is original or legally licensed to avoid copy-
right infringement. In other words, assume everything online is copy-
righted unless otherwise stated.

Budget: You need to know the budget defined for the project so you
can appropriately allocate time to designing and building, and possibly
even maintaining, the site. Extra costs may also be incurred for hosting,
training, and other Web site needs. Plan, too, for the cost of the project
changing scope due to revision requests by the client. Changes can also
affect the timeline, so be sure to build in extra time as a cushion for the
unexpected. This happens all too often so be prepared for hourly cost
increases and/or contract addendums.

Technical: You have many technical considerations when designing and
building a Web site that affect how visitors experience the site, includ-
ing the browsers and operating systems the site supports, whether the
site will use any dynamic functionality, and whether the site requires a
secure server for data protection. For instance, information collected
from visitors needs to be kept secure and protected.

Book |
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Also, the coding and database for the dynamic functionality, if any,
depends on the Web server type (linux/unix servers use PHP/mySQL
and Microsoft servers use .NET and SQL databases) so designers and
developers need to plan accordingly.

Before building the site, you need to decide upon other issues that affect the
overall design of the site, including monitor resolution, browser optimiza-
tion, and breadth of content. We discuss these issues in detail in the sec-
tions that follow.

Monitor resolution

When visitors come to your Web site, how much of the Web site design they
see in their browsers is somewhat determined by the elements within their
browser, like the address bar, navigation buttons, status bar, and scroll
bars, and their monitor resolution setting. Monitor resolutions can be set
anywhere from 600 x 400 to 2560 x 2048. The smaller the numbers, the larger
the site appears in the monitor display; the larger the numbers, the smaller
the site appears.

Currently, most monitors come with a factory preset resolution of 1024 x 768
or higher. Nevertheless, because you have no control over what monitor res-
olutions visitors will have, consider doing some advanced market research
to find out who your audience will be, and what monitor resolution they’re
likely to have. This information helps you determine the ultimate width of
your Web site design. For a few years, the standard was to design a Web site
for a monitor set to 800 x 600 resolution. However because less than 10%

of all Internet traffic uses that resolution anymore, the new standard is to
design for monitors optimized for 1024 x 768 and higher resolution settings.
That said, because a design at 1024 x 768 pixels would be too wide to fit in

a browser window with the aforementioned browser widgets, the design
would need to be a little smaller — about 955 x 600 pixels — to fit without
invoking horizontal scrollbars.

For a great discussion about designing for multiple screen sizes, check out
the whitepaper titled “Screen Size Matters” by Catalyst Group Design at
www.catalystgroupdesign.com/cofactors/upload/catalyst_
resolution_whitepaper.pdf.



Examining Issues That Impact the Site Design

37

Designing Web sites with accessibility

When designing Web sites, you need to con-
sider whether the audience will include people
with visual and other disabilities. If so, you
should add accessibility features, such asimage
labels and keyboard shortcuts, to your site.
Dreamweaver has the tools that let you author
accessible content that complies with govern-
ment guidelines. In addition, Dreamweaver sup-
ports designers who need accessibility features
themselves to create accessible sites.

Toturnon Accessibility featuresin Dreamweaver,
which prompts you to add Accessibility tags and
attributes to objects when they are inserted onto
a page, follow these steps:

1. Choose Edit=>Preferences (Windows) or
Dreamweaverc>Preferences (Mac).

The Preferences dialog box opens.

2. Choose the Accessibility category on the
left to reveal the accessibility options on
the right.

3. Nextto the Show Attributes When Inserting
option, choose the content that you want to
be prompted for.

For example, to always be prompted to add
accessibility tags or attributes to images
inserted on a page, select the Images
option.

4. For Web designers with disabilities who are
using Dreamweaver to create Web pages,
consider the following options:

Enable the Keep Focus option to access
an accessibility panel after you open it.
This is a good option for Web designers
using screen readers who need acces-
sibility settings to create Web pages in
Dreamweaver.

Consider disabling the Off-Screen Rendering
option if using a screen reader. This option
is turned on by default but may cause con-
flicts for designers using screen readers.

5. Click OK to accept the new preferences.

In addition to these accessibility features,
Dreamweaver comes with several sample Web
page designs that comply to accessibility stan-
dards. To access these sample designs, choose
File>New to open the New Document dialog
box, and choose an accessible page design
from the Blank Page category.

If you do use accessibility settings on your Web
pages, be sure to run an accessibility report to
test your page or site against the government's
Section 508 guidelines as part of the testing
process prior to publishing your site. See Book
V, Chapter 1 for more about testing.

To find out more about Accessibility initiatives,
visit the Web sites for both the World Wide
Web Consortium Web Accessibility Initiative
(www.w3 .org/wai) and Section 508 of
the Federal Rehabilitation Act (www.sec
tion508.gov).
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Browser optimization

Another issue to consider is browser optimization. Taking a look at browser
trends can give you insight into important design considerations, such as
layout size and CSS (Cascading Style Sheets) support. For example, currently
the most popular browser is Internet Explorer (IE), the most used operating
system is Windows XP, and the most common monitor display setting is 1024
X 768.

The W3 Schools Web site lists browser and operating system usage statis-
tics on a monthly basis dating back to 2003. Examples are shown in Tables
2-2 and 2-3. For the most current browser optimization statistics, visit www.
w3schools.com/browsers/browsers_stats.asp.

Table 2-2 Browser Usage Statistics
2008 IE7 IE6 IE5 Firefox Mozilla Safari Opera
June  27.0%  265% 05% 41.0% 0.5% 2.6% 1.7%
Table 2-3 Operating System Usage Statistics
2008 Win- Win- Win- Win- Win- Linux Mac
dows dows dows dows dows
XP 2000 98 Vista 2003
June 74.6% 2.6% 0.2% 10.0% 1.9% 37%  4.8%

In a perfect world all Web sites would function flawlessly on all browsers,
however this rarely happens without significant effort. There most definitely
are subtle differences to how a Web site is interpreted by different browsers
from the things like the actual layout and placement of images and text, font
sizes, or even the functionality of forms. This fact is extremely frustrating for
beginners and seasoned designers, but underlines the importance of proper
testing, validation, checking compatibility and accessibility. Remember to
design and test for the majority of your audience; although it would be nice
if the Web site works on all browsers, spending three months past your
deadline fixing bugs on a Web site for some random non-name browsers
with .05% of the browser market isn’t an effective use or your time.

Content

Before building a Web site, you (or your client) need to create and gather
content and other site assets. Content gathering includes writing text and
creating or licensing image, sound, and video files. It’s important to gather
these assets in advance so that you don’t have to stop site development
repeatedly to create or find any missing content.
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Gathering content is a big undertaking, even for the smallest sites, so unless
you're also being compensated by your client as the project/content manager,
this process should be the client’s sole responsibility before the project begins;
otherwise, you may be blamed for significant delays, even though you’re not
the one holding up the project. Before you sign contracts, make sure you rein-
force the idea that it’s the client’s responsibility to gather the content before
you start the project timeclock. Trust us: You’ll be glad you did.

After you’'ve gathered the content, organize everything electronically in a
place that’s easily accessible when it comes time to build the site. For exam-
ple, you may decide to create a folder on your computer called Websites,
and in that folder create a subfolder for the client. Inside the client’s folder,
you may create several additional subfolders for all the different assets, as
shown in Figure 2-1.

() Websites (3 et & [ Dlientk: & Text Content
(22 client B [E Client A Images
12D client ¢ (2 client A Sound & video

Planning the Site Layout

You can save time by planning and designing the site layout before working
in Dreamweaver. A consistent layout and design helps create a good user
experience. Site layout applies to the look of all the pages on the site, as well
as how the pages are logically arranged and how they interact with each
other. This phase is where you're creating the site’s architecture, or
structure.

With regard to the layout of the pages themselves, consider designing a
mock-up that has fixed as well as editable areas. Dreamweaver allows you
to create templates and library items for page layouts and elements that are
consistent on every page. For instance, the navigation element may be at
the top of every page, with an area for subnavigation on the left margin, and
page-specific content in the center of the page below the navigation.

As you create the design, think about the site visitors’ experience:

4+ Visitors should be able to move from page to page with ease. Therefore,
navigation should be consistent throughout the site.

4 Visitors should know where they are inside the site and how to return
to the home page. Use indexes and subnavigation to assist visitors with
finding information. Also provide a method for contacting the company
in case a visitor wants to communicate with the company.
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Planning the Site Layout

After you gather and organize your data, you may want to create some
HTML wireframe pages to help organize the site’s structure. A wireframe is a
tree diagram or flowchart of a Web site that includes all its pages. Each wire-
frame indicates links between pages but doesn’t typically include any refer-
ence to the design of the site or the content on any of the specific pages. You
can create additional wireframes for the individual pages to assist with the
organization of content on the page, in advance of having real content.

To create a wireframe for your Web site, consider using a graphics program
such as Adobe Illustrator or Adobe Photoshop, or a diagramming program
such as Microsoft Visio. In addition to labeling each page on the wireframe,
these programs have the tools you need to customize the diagram with
graphic elements, color, text, specific fonts, and other information.

To find out more about wireframes, check out the SitePoint article by Matt
Beach at www.sitepoint.com/article/wire-frame-your-site.

After creating a wireframe and prior to building the site in Dreamweaver,
you may also want to create a mock-up or comp of the site design on paper
or in a graphics program such as Adobe Photoshop, Adobe Illustrator, or
Adobe Fireworks. A key benefit to designing a mock-up in a graphics pro-
gram is that after the client approves the mock-up, you can use it to generate
many if not all of the graphics.

A mock-up differs from a wireframe in that the mock-up is a design of the site
that contains all the graphical information for the Web site layout including
company identity, navigation, headers, text, and other graphics. In other
words, the mock-up should have all the elements the client has requested
for the site. For instance, clients may tell you that they “want the logo on

the top of the page, the navigation below that, an area for links to frequently
accessed pages, and a section for a photo gallery.” In response to these
needs, you plan the layout of the page and the site. Then you show the
mock-up to the client to make sure the design meets their needs.

Both the creation of the mockup and the wireframe/sitemap are critical ele-
ments to planning a successful Web site. Giving the client the opportunity to
see the design (mockup) and the site structure (wireframe/sitemap) before
the site gets built provides both parties with the opportunities to hash out
ideas and agree upon the final design. The designer then has a good under-
standing of the Web site project and the exact design the client is expecting
so there are no misunderstandings later on.
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Designing and Optimizing Graphics 4 ]

After the design is finalized, the next step is to slice and optimize graphics.
Slicing and optimizing describe the process of dividing a large flat mock-up
into individual pieces, or graphics, that are then compressed into GIF, JPEG,
or PNG graphics and reassembled on the Web page, much like the pieces of

a puzzle.

The number of graphics overall should be limited to ensure the page loads
quickly in a browser. If you're considering rollover button functionality and
other interactive features on the site, create the graphics for these elements
at this stage of the process, in advance of optimization.

Before adding graphics to Web pages, you need to compress them, because
in their native format (PSD, PDF, Al, EPS, TIFF, and so on), the file sizes are

much too large to download over the Internet.

When compressing images for the Web, you can choose from three graph-
ics formats: GIF, JPEG, and PNG, as shown in Table 2-4. Web browsers

have widely supported GIF (Graphics Interchange Format) and JPEG

(Joint Photographic Experts Group) for years: however, the PNG (Portable
Network Graphic) has more recently gained in popularity and is now also
widely supported. Nonetheless, due to some browser incapability issues,
you may still want to be careful when using PNG files. For example, IE6 inter-
prets transparent PNG files into a wonderful shade of baby blue!

Each format uses a different compression format to crunch data and create
smaller file sizes. With all formats, the compression goal is to achieve the

best image quality possible while reducing the file size. Fortunately, because
the Web displays images at low resolution (72 ppi or pixels per inch), most of
the loss in image quality from the compression is hard to see on screen.

Table 2-4 Graphics File Formats

Format Is Best For What It Supports

GIF Images with large flat areas Maximum of 256 colors (8-hit);
of color both animation and back-

ground transparency

JPEG Photographs and graphics Millions of colors (24-bit), but
with lots of color and gradient not animation or transparency
blends

PNG Recommended for replacing PNG-8, maximum of 256 colors

GIFs by the W3C, supports
images with large flat areas of
color

(8-bit); PNG-24, millions of
colors (48-hit); background
transparency, but not
animation
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Use an image-compression program such as Adobe Fireworks or an old copy
of Adobe ImageReady (CS2 and earlier), or the built-in compression engine
within Adobe Photoshop or Adobe Illustrator as of CS3, to optimize the
images. Most applications allow you to slice, optimize, and export graphic
files and HTML. Other compression programs and plug-ins are also available,
such as Spinwave (www . spinwave. com), BoxTop (www.boxtopsoft.com),
and Equilibrium’s Debabelizer (www.equilibrium. com).

Whichever program you choose, be sure to consult the program’s Help files
for further instruction on image sizing and optimization.



Chapter 3: Creating and Managing
Sites

In This Chapter

+ Understanding how Web sites are put together
+~ Setting up a managed site the basic way
1~ Setting up a managed site with the advanced method

1~ Keeping track of multiple sites

A Web site is a group of pages that are linked together and share
common features such as design, content, and purpose. Dreamweaver
enables you to organize all the pages and assets of your site in one conve-
nient location. To take advantage of Dreamweaver’s great site-management
features, such as uploading files and managing links among many others,
first you need to create a managed site in Dreamweaver. When managing
your site, you'll likely adopt a general Web site structure and opt for either a
root-level or document-level organization for your files.

In this chapter, you find out how to create a managed Web site, gain an
understanding of root-level and document-level site organization, review
the settings in the Site Definition dialog box, and discover how easy it is to
manage multiple sites in Dreamweaver.

Understanding General Web Site Structure

Before you manage your first Dreamweaver Web site, you need to be familiar
with the general Web site structure and have a basic understanding of the dif-
ferent types of root level organization, as discussed in the sections that follow.

Web site structure

Web sites typically consist of two or three basic parts:

4+ The local folder: This folder, also called the local root folder, holds all the
files, images, and other assets of a managed site. The root level, simply
put, is the top level or starting point a browser uses for finding objects
within a Web site. The local folder typically sits somewhere on your com-
puter’s hard drive, though it may also be on a mapped drive or network
server. Wherever it resides, you must specify the location of the local
root folder in the Site Definition dialog box (see Book V, Chapter 3).
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4 The remote folder: This folder is where you publish your site, typi-
cally on a remote Web server. For example, when you purchase a Web
hosting plan, you're essentially renting a parking space for your Web
site in the virtual parking lot of the Internet. That space is on the host’s
remote Web server. You'll be transferring files to the remote folder
from the local folder to ensure the published Web site is functional and
up to date. You can choose from many options when you’re setting up
the remote folder. See Book V, Chapter 3 for more info on setting up a
remote folder.

4 The testing server folder: This folder is where Dreamweaver processes
dynamic data to create dynamic content and connect with a database
while you create and test your site. Your testing server can be on the
local computer, a development or staging server, or a production server.
We don’t recommend that you use the remote folder for the testing
server folder because you can run into some problems. See Book VII,
Chapter 1 to set up your testing server.

Root-level organization

After deciding on the general Web site structure for your site, the next step
is to determine how to organize and link the files to one another relative to
the root (top-level) folder.

Each page on a Web site has its own unique address or URL (Uniform
Resource Locator), such as http: //www.adobe.com/products/dream
weaver/index.html. When you make a local link (a link from one file to
another on the same site), however, you don’t generally need to specify the
entire URL of the file you're linking to. Instead, you just need to set the rela-
tive path, which is the path from the current file or the site’s root folder to
the linked file. For instance, to link from an about.html page to a contact.
html page, both of which sit at the root level of a URL, the local link code
would look like this: <a href="contact.html">Contact Us</a>.

You can use three types of link paths:

4+ Document-relative paths: This type of link specifies the path and name
of the document being linked to, such as about.html or photogallery/
MollySurfing.html. The general idea behind document-relative paths is
that you don’t need to add the absolute (full) URL including http:// for
them to work because all the files being linked to reside either at the
root level or inside a subfolder of the local root folder.

Using the Pacific Surf site structure shown in Figure 3-1 to create a
document-relative path to a file inside a subfolder at the root level, add
a forward slash after the folder name containing the file you want to link
to, as in the path

photogallery/MollySurfing.html
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This path tells the browser to move down a level in the folder hier-
archy, from the root level into the photogallery folder to find a file
called MollySurfing.html. If you were then to add a text link from the
MollySurfing.html page to the about.html page, you’d add two periods
and a slash (. . /) before the filename, as in . . /about .html. The .. tells
the browser to move up a level in the folder hierarchy. Table 3-1 shows
different folder scenarios which might help you understand the path
structure a little better.
Table 3-1 Linking Explained
Link FromA To B Link example
From index.html to about.html about.html
From about.html to MollySurfing.html /photogallery/MollySurfing.html
From MollySurfing.html to KimAndJeff.html KimAndJeff.html
From MollySurfing.html to contact.html ./contact.htm|
\sg,N\BER Be sure to save new files before creating document-relative paths to
& ensure that the path is saved correctly. Otherwise, you may see a tem-

porary path starting with £ile:// in the code until the file gets saved

and Dreamweaver can update all the temporary paths to relative paths.

4+ Site root-relative paths: Links using site root-relative paths display the

path and name of the document being linked to, but they direct the
browser to begin searching for the path by starting at the root level of
the site. To indicate this, you include a forward slash before the first
folder or filename in the link code, as in the following two examples:

/contact.html
/services/widgets.html

The forward slash stands for the site’s root folder. Use these paths
for large sites sitting on several servers, a site that has multiple hosts,
or sites that use server-side includes (SSIs), as described in Book III,
Chapter 3.

4+ Absolute paths: An absolute path is the full URL to the linked document,

as in

http://www.example.com/services/widgets.html
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You must use absolute paths for files that sit on other servers, such as a
link to purchase a specific For Dummies book from Amazon.com or a link
that takes you to a particular page on a blog site. Using absolute paths is
somewhat discouraged for local site pages because links on files moved
from one domain name or folder location to another get broken. So
unless you have a particular reason for using absolute paths, try to use
document-relative paths for local links whenever possible.

Setting Up a Site with a Wizard

Figure 3-2:
The Manage
Sites dia-
log box.

Setting up a managed site simply means defining a local site on your computer
so that Dreamweaver knows where to save documents and find files related to
that site. You’ll want to create a managed site for each project that you work
on so that you can open and edit site-specific files from the Files panel. Always
try to define or manage a site before you start development to ensure the site
takes advantage of Dreamweaver’s great site management features, such as
sitewide filename change support and the sitewide link checker.

Dreamweaver provides you with two easy ways to create a managed

site. The Basic method uses a wizard with step-by-step prompts, and the
Advanced method lets you manually set all the local, remote, and test-
ing folder settings as well as other category options. If you’re new to
Dreamweaver, we encourage you to use the wizard. If you'd rather go the
advanced route, check out the later section, “Setting Up a Site Using the
Advanced Method,” for details.

To set up a Dreamweaver site using the wizard, follow these steps:

1. Choose Site->Manage Sites.

You can also launch the wizard by selecting Manage Sites from the Site
Management drop-down list in the Files panel. To bypass the Manage Sites
dialog box completely, select Site>New Site and skip ahead to step 3.

The Manage Sites dialog box opens, as shown in Figure 3-2.

Manage Sites

Drearmweawer for Dummies ‘A

Edit..

Duplicate

=
Remave
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Import, ..
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Figure 3-3:
The first
screen of
the Basic
Wizard.

Setting Up a Site with a Wizard 4 /

2. Click New, and then from the drop-down list that appears, select Site.

The Site Definition dialog box opens.
3. Select the Basic tab.

Figure 3-3 shows the Basic Wizard. The wizard walks you through the

steps for setting up a new site.

Site Definition for Dreamweaver

Basic | Advanced

Site Definition

Editing Files Testing Files Sharing Files

A site, in Dreamweaver, is a collection of files and Folders that corresponds to a website on a
server,

what would vou like to name vour site?
Dreamweaver

Example: mySite

What is the HTTP Address {URL) of vour site?
http:/f
Example: http:/ i, myHost.comfmySite

IF you want ta work directly on the server using FTP or RDS, vou should create an FTP or RDS
server connection, Working directly on the server does not allow you to perform sitewide
operations like link checking or site reports,

Mext = H Cancel H Help

4. Provide a name for your site and enter the site’s HTTP Address (URL);

then click the Next button.

The name you enter here is totally arbitrary and can be anything

you like to help remind you what the file is called on your local com-
puter. For instance, you may want to name the site after the client,

such as Acme Widgets, or when the client name is really long (such as
Dreamweaver For Dummies All-in-One Desk Reference For Dummies) use

an abbreviation, such as DFDAIO.

5. Decide whether you want to work with a server technology:

¢ No, I do not want to use a server technology: Select this option and

click Next.

* Yes, I want to use a server technology: Select a server technology

from the drop-down list and click Next.

Book |
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Setting Up a Site with a Wizard

10.

11.

If you're unsure of whether you need this or not, click No for now. You
can always come back later and add server information. For more infor-
mation about choosing and setting up server technology, turn to Book V,
Chapter 3.

Choose whether to edit local copies of your files before uploading or
work directly on the server using a local network. In addition, specify
the location on your computer where the files for this site will be
stored (this site’s local root folder). Click Next.

Though it is an option here, we do not recommend that you work or edit
directly on the server, as this means you’d be changing your live Web
site without testing. This is a terrible idea for beginners and experts
alike.

Dreamweaver may attempt to fill in the location on your computer
based on the site name you used in Step 1. If this is not what you want,
click the folder icon next to the text field to browse for and select the
correct folder on your local computer.

Select a method of connection to your remote server. The bottom half
of this screen changes to match the method you select. Click Next.

For example, if you plan on connecting using Local/Network settings,
enter the path to the folder on the server where the files will be stored.

For a complete explanation of each of these options, see Book V,
Chapter 3.

If you selected a remote server option, choose whether to enable the
Check In/Out feature for this site. Click Next.

When this option is enabled, only one person at a time can check files
out. You must also select a method for how Dreamweaver handles files
upon check-out and enter your name and e-mail address.

A summary of the site settings appears, for your review, as shown in
Figure 3-4.

Use the Back button to return to a previous screen if you need to make
any changes.

Click the Done button to accept the settings and close the Basic
Wizard.

Click the Done button in the Manage Sites dialog box.

The Manage Sites dialog box closes, and the newly defined site in
Dreamweaver opens, displaying all the existing files, if any, in the root
folder in the Files panel.
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Site Definition for Dreameaver Book |
Basic | Advanced | chapter 3

Site Definition

‘our site has the follawing settings:

Local info:
Site Mame: Dreameaver
Local Root Folder: C:YDocuments and Settings'Administrator Ceskioph DWW C54 HTMLY

Remote info:
Access: Tll set this up later,
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Testing server:
Access: Il set this up later.

‘our sike can be Further configured using the Advanced Tab.

Figure 3-4:
Review your
settings and
click Done
to accept
them. <Back | [__pone [ Cancel [ _teb

\‘&N\BEB If your server or work computer is not backed up regularly, seriously con-

& sider making a local backup copy of your site before you modify it each time.
Having backups is a great practice, one that can serve you well when mis-

takes are made, data gets lost, or you need to revert to a previous version.

Setting Up a Site Using the Advanced Method

If you're an experienced designer, you'll probably want to use the Advanced
tab of the Site Definition dialog box to specify managed-site settings. To start
working quickly, you can set up just the local folder for now; you can return
to the Site Definition dialog box at any time to add remote and testing folder
information. That said, if you already have all the information you need to
set up your site, entering everything at once may be easier.

\‘&N\BEB Technically, it’s only necessary to fill out the Local Info category to begin
& building a site and the Remote Info category if you also intend to use
Dreamweaver to upload your site to a remote server. You can complete the
remaining categories as needed. We discuss how to set up a remote server
in Book V, Chapter 3.
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Figure 3-5:
The
Advanced
Site
Definition
options.

To get your site up and running locally, follow these steps:

1. Choose Siter>New Site.

The Site Definition dialog box opens.

2. Select the Advanced tab.

The Advanced tab of the Site Definition dialog box appears, as shown in
Figure 3-5.

Site Definition for Dreamweaver

Basic | Adwanced

Category Local Info

Lacal Info

Remate Info 2 .

okl Sy Site name! | Dreamweayer

Version Control x
Cloaking Local root Folder: | C:iDocuments and Settingstadministrator|#y Doo i)
Design Motes

File igw Columns Default images folder: =
Contribute

Templates Links relative to: (2) Document () Site root

Spry
HTTP address: | http:/f

This address is used For site relative links, and for
the Link Checker to detect HTTP links that refer to
your own sike

Case-sensitive links: [] Use case-sensitive link checking
Cache: [#]Enable cache

The cache maintains file and asset information in
the site, This speeds up the Asset panel, link
management, and Site Map features,

[a]4 || Cancel H Help

3. In the Site Name field, enter the name of your site.

Picking a name that matches the name of the client or indicates your
site’s purpose is best, such as ABC Company or My Blog.

4. Verify that the Local Root Folder field points to a directory in your

local Web root directory.

To keep your files organized, add the myblog folder (\myblog\), for
example, onto the end of your Web root so that all files related to this
site are in their own Web-accessible folder. This isn’t required, but it
keeps you from having a mess of unrelated files in your Web root.

5. Leave the Default Images Folder field blank.

Because this is a new site, there is no folder created yet to store all your
images inside of. You can either create that folder now, or add one later
after the site is managed. Most images folders are named images or img.
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Changing the link path

By default, Dreamweaver uses the document-
relative path for links. If you would rather use
site root-relative paths for links, you need to
modify the Local Info settings during the site-
management process. To change from the
default document-relative path setting to site
root-relative paths, follow these steps:

1. Choose Sitec>Manage Sites.
The Manage Sites dialog box opens.

2. Double-click the site you want to modify
from the list.

The Site Definition dialog box opens.

3. Click the Advanced tab at the top of the
dialog box.

4. Inthe Local Info category, change the Links
relative to setting from Document to Site
Root.

This step doesn’t change the paths of existing
links, but does apply to any new links created
in Dreamweaver.

When using site root-relative paths, the pages
don’t appear when you preview the files in
a browser. Browsers don’t recognize site
roots — servers do. To preview the paths in
a browser while working in Dreamweaver,
choose EditcoPreferences (Windows) or
Dreamweaver=>Preferences (Mac) to open
the Preferences dialog box. Then select the
Preview Using Temporary File option in the
Preview in Browser category.

6. Select Document as the Links Relative To setting.

This option builds links in your sites that reference other files by their
positions relative to the active file. It allows you to easily move your site

to a different directory.

7. In the HTTP Address field, type http://localhost/directoryname, where
directoryname is the directory in your local Web root directory from

Step 5.

For example, if you're using the directory recipe under your Web root,

enter http://localhost/myblog.

8. Leave the Use Case-Sensitive Link Checking check box unchecked.

This option tells Dreamweaver not to worry about the case of names in links.

9. Leave the Enable Cache check box selected.

This option speeds up working with files in Dreamweaver.
10. Click OK in the Site Definition dialog box.
11. Click the Done button in the Manage Sites dialog box.

Your site opens, displaying all the existing files (if any) in the root folder

in the Files panel.

The following sections describe the other categories, in case you're filling

them in.

Book |
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Remote Info

After specifying the local folder, fill in the Remote Info category informa-
tion. The remote folder is the place to store files for collaboration, testing,
production, and deployment. If the Web server is running on your local com-
puter, you don’t need to set up the remote folder as long as the specified
local folder points to the same file. See Book V, Chapter 3 for more info on
setting up a remote folder.

Testing Server

In the Testing Server category, specify the location where you want your
dynamic pages processed. In other words, this folder is an alternative loca-
tion where you can test your files on a server with an identical database
setup, without having to deploy the files to the live site while they’re still
under development. The testing server can be on your local computer, or on
a staging, development, or production server. Check out Book VII, Chapter 1
if you need to set up a testing server.

Uersion Control

The Version Control category is where you can setup remote access to

a server running Subversion software inside which the site’s files can be
viewed, compared, and reverted to previous versions of the site. If you're
not using Subversion software for version control, ignore this setting.
Otherwise, see Book V, Chapter 3 for details on Version Control set up.

Cloaking

Cloaking prevents specified files and folders from being included in a vari-
ety of site operations, such as site file synchronization between local and
remote servers. For example, you may want to cloak large movie files or
Design Notes folders from being uploaded each time you update site files to
the remote server. For more details on how to enable site cloaking, see Book
V, Chapter 3.

Design Notes

Dreamweaver lets you create and share Design Notes about site files, which
are then stored in a separate location. Enable this feature when communicat-
ing within a design team or workgroup about a shared managed site. You
can attach Design Notes to documents, templates, images, Flash movies,
ActiveX controls, and applets. Refer to Book VI, Chapter 1 for details on
Design Notes.
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File View Columns Book |

In the expanded Files panel, Dreamweaver displays file and folder details Chapter 3
in columns next to the filenames. You can customize which file and folder
details show up there by making changes to the File View Columns category.
For instance, you can hide and show, add and delete, reorder, share, and
rename column settings. Find out more about defining File View Columns in
Book VI, Chapter 1.
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Contribute

When creating a site for use with Adobe Contribute software, you

must enable Contribute compatibility before administering the site in
Dreamweaver. The Contribute category allows you to enter Administration
settings. See Book VI, Chapters 2 and 3 for the lowdown on using
Dreamweaver with Adobe Contribute.

Templates

By default, the Template Updating option is set to not rewrite document
relative paths. To turn this feature off, deselect the check box here. To learn
more about the joys of working with Templates, turn to Book III, Chapter 2.

Spry

If desired, you could specify the folder location for Spry assets. However, by
default a folder named SpryAssets is preset to drop into the local root folder
if and when any Spry assets are used on the site. Don’t change this unless
you really know what you’re doing. You can learn more about working with
Spry in Book IV, Chapter 2.

Managing Multiple Sites

Because you create a new managed site for each project you work on in
Dreamweaver, keeping track of all your sites is relatively easy. You can view
a list of all your managed sites as follows:

4+ Files panel: The Files panel lists the files from a selected managed site.
To change from viewing one site’s files to another site’s files, select the
desired site by choosing it from the list of managed sites.

4+ Manage Sites dialog box: Choose Sitec>Manage Sites to open the Manage
Sites dialog box. Select your desired site from the list and click the Done
button to switch to the selected site and see that site’s files listed in the
Files panel. You may briefly see the Opening Site and Uploading Site
Cache dialog boxes as Dreamweaver opens the selected site.
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Duplicating sites

Create exact duplicate copies of any existing defined site by clicking the
Duplicate button in the Manage Sites dialog box. Dreamweaver copies all the
settings and creates the new site with the same filename appended with the
word copy. For example, if duplicating a site called Company ABC, the name
of the new duplicate managed site would be Company ABC copy until you
rename it.

This doesn’t copy the actual files. It just creates a new site setting within
Dreamweaver, which you can then modify. Often, you'll also want to dupli-
cate the local folder and all its files so you have a new copy to work on in
Dreamweaver.

Exporting and importing sites

Dreamweaver allows you to save and reopen sites as XML files using the
Import and Export buttons. In other words, you'll export a site with all its
settings as an XML file and then import the site with the same settings later,
either on the same machine or on another machine. This method is handy to get
anew computer up and running with all the sites you’re currently managing.

Exporting sites
To save a site as an XML file, follow these steps:
1. Choose Site->Manage Sites to open the Manage Sites dialog box.
2. Select one or more sites and click the Export button.
Use Control+click (Windows) or 88+click (Mac) to select multiple files.
3. Browse to, select, and save the location for the export of each site.

The exported file gets saved as an XML file with the .ste file extension.

Importing sites
To import previously exported XML files back into Dreamweaver, follow
these steps:

1. Choose Siter>Manage Sites to open the Manage Sites dialog box.
2. Click the Import button.

3. Browse to and select one or more sites with the .ste file extension for
importing.

Use Control+click (Windows) or 88+click (Mac) to select multiple files.
4. Click Open to begin the importing process.

The Manage Sites dialog box lists the site name when the import process
is complete.
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Removing sites from the managed-sites list

When removing sites, keep in mind that sites listed in the Manage Sites
dialog box are merely pointers to the location of files on the specified com-
puter and not the actual files and folders themselves. Therefore, removing
a site from the managed-sites list removes only the location information
Dreamweaver needs to work on the files in the specified site.

As a backup, before you remove a managed site from the listing, you may
want to export the site using the Export steps mentioned above. That
way you'll have a copy handy should you ever need to import it into
Dreamweaver.

To remove your site from Dreamweaver, select your site from the Manage
Sites dialog box and click the Remove button. Dreamweaver gives you the
You cannot undo this action message. Don’t be unnerved; if you accidentally
delete a managed site from the list, you can just re-create it.

Book |
Chapter 3
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Chapter 1: Creating Documents

In This Chapter

v Creating a new document
v~ Saving files

v~ Setting page properties
v+ Importing data

C‘eating documents is the basis for everything you'’ll do for the Web.
Dreamweaver provides several ways to create them, several types of
new documents to choose from, and even several premade “design files” to
use as starting points for your own designs.

This chapter explores document types, document creation, document
saving, and document opening. You also discover how to set page
properties, work with invisible page elements, and import Word and Excel
files (Windows only).

Creating a New Document

In Dreamweaver CS4, as in Dreamweaver MX, MX 2004, and 8, the default
Welcome Screen appears in the workspace when you launch the program.
The Welcome Screen allows you to open existing files from a list of the

nine most recent documents, create new files by file type (such as HTML,
CSS, or PHP), jump directly to the Site Definition dialog box to manage a new
site, and launch a browser to watch the top featured videos from Adobe.
com. If you don’t see the Welcome Screen when you launch the program,
you can enable it by following the steps in the “Enabling the Welcome
Screen” sidebar.

When the Welcome Screen is visible (shown in Figure 1-1), the quickest

way to create a new blank document is to click one of the file types in the
Create New column. Click the HTML link, for instance, and a new untitled
Document window opens, complete with basic HTML structural code, ready
for adding content and saving with a filename and extension.

To create a new document, follow these steps:

1. Choose FilecoNew to launch the New Document window, shown in
Figure 1-2.
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This dialog box is divided into various columns to assist you with select-
ing the desired file type, such as a blank page or page from template.

In this chapter, we discuss the blank, sample, and other page options;
Book III, Chapter 2 shows you how to work with templates.

create.

In the column on the left, select the type of document you want to

The default document type is set to Blank Page.
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. In the Page Type column, select the desired document type, such as

HTML or CSS.

Take some time to explore the different layout options, when applicable,
in each category. Dreamweaver supplies you with a nice group of blank
documents and sample design files to use as a starting point for your
own projects. For example, the Blank Page category for the HTML page
type has several prewritten code layout options for you to choose from.
You'll also find several CSS color schemes in the CSS Style Sheet folder
of the Page from Sample category, each filled with preset colors,

fonts, and sizes for you to use as is or as a starting point for further
development.

Beginners may want to select one of the preset layout options that
include prewritten HTML and CSS layouts as a starting point to custom-
izing the code. Then, later, as you get more familiar with Dreamweaver,
it will be easier to create blank HTML pages and write your own CSS.

. (Optional) To set default document preferences for all new docu-

ments (such as document type, file extension, and encoding) click
the Preferences button at the bottom of the New Document window.
When finished, click OK to close the Preferences Window and con-
tinue setting options for your new document.

The Get More Content link at the bottom of the New Document dialog
box takes you to Adobe’s Exchange Web site where, after you register,
you can download more design files and plug-ins to enhance your copy
of Dreamweaver. (See Book IV, Chapter 2 for more on the Dreamweaver
Exchange.)

. Select an option from the DocType (DTD) drop-down list.

The default document type is currently XHTML 1.0 Transitional, but
you can also choose from any of the other options available in the drop-
down list including the HTML 4.01 Transitional DTD.

When a DTD is specified here, Dreamweaver automatically writes the
DTD code at the top of your new document above the opening <html>
tag, and at times may append the <html> tag itself, like this:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://

www.w3.0org/TR/xhtmll/DTD/xhtmll-transitional.dtd">
<html xmlns="http://www.w3.0rg/1999/xhtml">

If you're unsure of which one to pick, either leave the setting at XHTML
1.0 Transitional for XHTML or select the HTML 4.01 Transitional option
for HTML. For a more detailed discussion of XHTML, turn to Book IV,
Chapter 4.

. After you make all your selections from the New Document window,

click the Create button.

The new file opens in the Document window.

Book 11
Chapter 1
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Saving Documents

Enabling the Welcome Screen

You can enable and disable the Welcome
Screen through Dreamweaver’s Preferences.
To turn on the Welcome Screen (after disabling
it by checking the Don't Show Again box at the
bottom of the Welcome Screen), follow these
steps:

1. Choose Edit=>Preferences (Windows) or
Dreamweaverc>Preferences (Mac).

The Preferences dialog box opens.

Saving Documents

When saving a document, give the file a unique name with the appropriate
file extension and save it to the root level of the managed site folder.

\\3

2. Selectthe General Category to reveal gen-
eral category options.

3. Select the Show Welcome Screen check
box in the Document Options area on the
right. Then click OK.

Dreamweaver displays the Welcome
Screen in the center of the workspace.

To save a new file, follow these steps:

1. Choose File>Save.

The Save As dialog box opens.

Be sure you select Filem>Save and not File=>Save As. The Save com-
mand automatically prefills the file name with the proper extension
(untitled.html) whereas the Save As command leaves the extension
off (untitled), forcing you to remember to add it in. If you do forget,
Dreamweaver should add the extension to your file name for you.

2. In the Save As dialog box, navigate to the folder where you want to

save the new file.

Remember to save your file in a managed Dreamweaver site. If you
haven’t managed your site yet, turn to Book I, Chapter 3.

3. Type the name of your file in the File Name text box.

When naming the file, consider using all lowercase letters and avoid
using special characters such as ii or 6, spaces, or punctuation, such

as periods or slashes. Though filenames can be any length in Windows,
keep filenames under 29 characters in length to avoid Mac OS issues (31
characters is the published Mac character length recommendation).
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Changing the default file extensions

In versions of Dreamweaver earlier than 1. Choose Edit=>Preferences (Windows) or
Dreamweaver 8, the default extensions for Dreamweaverc>oPreferences (Mac) to
all document types were listed in an external launch the Preferences dialog box.

XML file. To change the default extension, you

had to manually open the XML file and edit the 2 Pl e Dleigniiz g gaieery o i

code by hand. Thankfully, since Dreamweaver (5

8, you may now change the default HTML file 3. On the right, change the preferences as Book Il
extension right in the Preferences dialog box. needed for default document, extension, Chapter 1
(To change any of the other document type document type definition (DTD), and encod-

file extensions — though you'll probably never ing.

need to do so — you still open the XML file.) 4. Click 0K when you're done

To edit the default document type and

) The new default file extensions work
preferences, follow these steps:

immediately for all newly created documents.

syuawnao( buneas)

‘X&N\BER By default, Dreamweaver assigns a default file extension to your untitled

& document, which for HTML files can be either .html or .htm (see the
“Changing the default file extensions” sidebar for instructions on setting
the default file extension). Regardless of which extension you choose to
work with, be consistent and use the same extension throughout your
entire Web site. The extension on the filename ensures the files display
correctly in a browser window. If needed, choose a different file type
from the Save as Type drop-down list.

4. Click Save.

After the file has been named and saved, you can continue saving new
changes to the file by choosing File>Save. This overwrites the previ-
ously saved version with the same file name.

After you initially save your document, you have some additional options
when saving it in the future. For instance, you can save a copy of the file,
save several files at once, or revert to a previous version of the file, as
described in the following sections.

Saving a copy of a file

You can save changes to documents after the initial save with their existing
name and location, thereby overwriting the previous version of that file. You
can also save a file as a copy using the Save As command.

To save a copy of the file using Save As, follow these steps:
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1. Choose FileSave As.
The Save As dialog box opens.

2. In the Save As dialog box, navigate to the folder where you want to
save a copy of the file.

You can save a copy of the file with the same or different filename in
a new folder, or save a copy of the file with a different filename in the
same folder.

3. Enter a different filename in the File Name text box.
4. Click Save.

Saving multiple documents at once

Another saving command that can often come in handy is Save All. This com-
mand saves all the open documents in the workspace with one command.

To save all the open files at once, choose Filer>Save All. If any open docu-

ments are unsaved, the Save As dialog box opens for each unsaved file. For

each unsaved file, enter filenames with file extensions and navigate to the
< folder you want to save the file to. Then click the Save button.

If Save All is a function you intend to perform often, create a custom key-

board shortcut for the Save All command! See Book III, Chapter 4 for details.

Reverting to a previous version of a file

Inevitably, a time comes when you need to revert to the last saved version

of a file. During each work session, Dreamweaver allows you to revert to the
previously saved version, whether that’s the state the file was in when you
opened it, or the state the file was in three minutes ago when you saved your
updates.

Follow these steps to refer to the previous version of a file:

1. Choose File>Revert.

A dialog box opens and asks if you want to discard any changes you’'ve
made to the current file and revert to the previous version.

If your Revert command is grayed out, you may have already saved the
file with any updates, so there is nothing to revert to. If you haven’t
saved yet, however, the Revert option is selectable.

2. Click Yes to revert; click No to cancel.

WMBER
é‘,\‘& This function works only during the current Dreamweaver session. When
you close Dreamweaver and restart it, you can no longer revert to a previous

version of a file.
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Opening Existing Files

After creating, saving, and closing a file, you can reopen it at any time for
editing in Dreamweaver. Furthermore, you can open any existing Web page
or text-based file in Dreamweaver, even when it was created in another
program. Other file types you can open in Dreamweaver include JavaScript
(.js), CSS (.css), XML (.xml), and text files (.txt). However, you can’t open
Word (.doc) files directly in Dreamweaver.

Here’s how to open an existing file:

1. Choose Filec>Open. Book I

The Open dialog box appears. Chapter 1

2. Navigate to and click the file you want to open.
3. Click Open.

The file opens in the Document window. With HTML files, you can
choose Code, Split, or Design view for editing purposes. However, by
default, JavaScript, CSS, and text files open in Code view. (See Book |,
Chapter 1 for more on these views.)

syuawnao( buneas)

You can also open files by double-clicking the file in the Files panel or
by pressing Ctrl+O (Windows) or 38+0 (Mac) to launch the Open dialog
box where you can navigate to and open a file.

<P If the file you open is a Microsoft Word file that’s been saved as a Microsoft
Word HTML file, you need to clean up the Microsoft markup. Choose
Commands=>Clean Up Word HTML to have Dreamweaver remove all the
unnecessary Microsoft markup. For more information, check out Book V,
Chapter 2.

Setting Page Properties

Dreamweaver lets you set the page formatting properties for a single page in
the Page Properties dialog box (see Figure 1-3). Formatting options include
setting the page’s default appearance (font family, size, color, background
color, background image, and so on) and margin spacing; define CSS link
styles and headings; enter the page title, DTD, and other encoding options,
and specify a tracing image. Any page can have its own property settings,
and you can modify these settings at any time.

In Dreamweaver CS4, page properties settings are added to the page as
either inline HTML formatting tags or as CSS (Cascading Style Sheet) markup
in the head area of the page. To find out more about CSS, turn to Book III,
Chapter 1.
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Figure 1-3:
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To access the Page Properties dialog box from any open document, use one
of the following methods:

4+ Click the Page Properties button in the Properties inspector.

4 Press Ctrl+J (Windows) or 3+J (Mac).

4+ Choose Modify=>Page Properties.
After you open the Page Properties dialog box, select the layout and
formatting properties that you need from the Appearance (CSS), Appearance

(HTML), Links (CSS), Headings (CSS), Title/Encoding, and Tracing Image
categories.

Understanding Invisible Page Elements

NG/
Q\“\ H

When certain HTML code, such as JavaScript or comment tags, needs to

be in the body of the page even though it shouldn’t be displayed in the
browser, Dreamweaver hides that code in Design view with little yellow
icons called invisible elements. That way, rather than seeing an entire
swatch of JavaScript code in Design view, Dreamweaver inserts the invisible
element to show where the code sits in Code view. Grab the invisibles by
their icons if you need to move, edit, or delete them.

By default, about half the available invisible elements are enabled and
appear in Design view when you choose Viewr>Visual Aids=Invisible
Elements. A check mark next to Invisible Elements means it’s turned on,;
without the check, the Visual Aid is turned off.

You may notice that content in Design view shifts slightly when the
invisible elements appear. Therefore, for precision with layout, you may
need to toggle the invisibles on and off; if you prefer to leave them on,
preview your page in a browser often to test the accuracy of the layout.
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Use the settings in the Preferences dialog box to further control which
invisible elements appear in Design view. For instance, you may want to
show an invisible icon for named anchors but not line breaks. Table 1-1
provides a brief description of all the invisible elements.

To change the Invisible Elements preferences, follow these steps:

1. Choose Edit=>Preferences (Windows) or Dreamweaver->Preferences
Mac).
The Preferences dialog box opens.

2. Click the Invisible Elements category.

On the right side of the dialog box, as shown in Figure 1-4, you see a list
of invisible elements.

Preferences
Categary Invisible Elements
General
25;;?;"& Show: <l [¥]Named anchers
Code Caloring &2 Oscripts
i 14 (7 comments
e o Clinebods
— SS csmss \; Ecllent-swde image maps
- s 23 [FlEmbedded styles
Flgure 1-4: FénTsyp e a Hiddenfnrm;&\ds
The ;L%E:E{:giments T3 [@IForm delimiter
Lat ) [Jancher points for AP elements
Preferences | [z 43 Dliecher poins o aigned demerts
H :. fwa’ SR [V]wisual Server Markup Tags (ASP, CFML, ...}
dlaloq bOX e A [Cnonvisual Server Markup Tags (ASP, CFML, .0
with the [[css display: none
fan Shiow dynamic text as: | {Recordset Field} v
|Er: visi b l f Server-Side includes: [] Show contents of included File
ements
options.
3. Place a check mark next to the name of each invisible you want to
show on your pages in Design view.
4. Click OK.
Your changes take effect immediately. Modify these settings at any time by
reopening the Preferences dialog box.
<P You can add some invisibles, like comments or named anchors, to your

document with the buttons on the Common area of the Insert panel. With
the invisible element selected in Design view, you can edit its contents
in the Properties inspector.

Book 11
Chapter 1
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Tabhle 1-1

Invisible Elements

Invisible Element

What Its Yellow Icon Hides in the Code

Named Anchors

Marks the spot where each named anchor (a name="")
sits in the code.

Scripts

Marks the spot where JavaScript or VBScript sits in the
body part of the file. The invisible element spans from the
opening to closing <script> tags and includes the entire
contents of the script. Edit the content of the scriptin Code
view and change the language, source, and type in the
Properties inspector by selecting the invisible elementicon
in Design view. Note: Script invisibles don't appear for inline
JavaScript or JavaScript URLs.

Comments

Marks where you find HTML comments. Edit the comments
in the Properties inspector by selecting the invisible element
icon in Design view.

Line Breaks

Shows icons for every line break (<br>or<br />)inthe
code. Select the invisible element icon to move or delete the
break.

Client-Side Image
Maps

Marks the spot of each client-side image map in the code.

Embedded Styles

Marks the spot where CSS is embedded in the body of the
file rather than in the head of the file or in an external CSS.
Technically, <style> tags should only be in the head,
although Dreamweaver lets you manually put them in the
body.

Hidden Form
Fields

Shows anicon for every instance of a hidden form field with
the type attribute "hidden".

Form Delimiter

This invisible element appears as part of the <form> tag
and displays in Design view as a red dotted border to show
where you can insert form elements. This feature is a good
one to leave on, as you must insert form fields inside the
dotted line for the form to work properly.

Anchor Points for
AP Elements

Shows an icon to visually represent each AP element (layer)
in the file. You can position the AP element itself anywhere
on the page, while the icon typically sits at the top-left
corner. Click the AP element icon to see the AP element’s
contents.

Anchor Points for
Aligned Elements

Marks the spot where code can have the align attribute,
including tables, images, plug-ins, and applets.

Visual Server
Markup Tags
and Non-Visual
Server Markup
Tags

These invisibles mark the spot where server markup tags,
such as ASP and ColdFusion, sitin the code even though
they don't display in the Document window.
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Invisible Element What Its Yellow Icon Hides in the Code

CSS Display: Shows the location of page content that has been hidden
none with the CSS property, display: none, in any linked or
embedded CSS file.
Show Dynamic This option shows dynamic text in the format of
Text As {Recordset:Field}. To prevent long values from distorting
page formatting, change the display setting here to {}.
Server-Side When enabled, this option makes pages show the contents
Includes of any SSlinclude file(s).
Book Il
Chapter 1

Importing Tabular Data Files

Tabular data files are delimited text files containing records that are
separated or delimited by a specified character, such as a tab or comma,
that doesn’t appear in the data. You can create delimited text files with most
spreadsheet and database programs such as Microsoft Excel and Access.

syuawnao( buneas)

After you convert an Excel or database file into a delimited text file, you
can import it into a Web page with Dreamweaver. During the import
process, you select the delimiter type that you originally used to separate
the data. The delimiter is used to separate data into individual table cells.
This gives you a new level of control over your imported data that wasn’t
available before!

To import a tabular data file, follow these steps:

1. Choose Filec>Import=>Import Tabular Data.
The Import Tabular Data dialog box opens, shown in Figure 1-5.
2. Browse to and select the file to import.

3. From the Delimiter drop-down list, choose the delimiter type used
when the file was saved.

Select from Colon, Comma, Semicolon, Tab, and Other. If Other, enter
the character that was used as the delimiter.

4. (Optional) Enter other settings as desired to format the table that will
hold the imported data.

5. Click OK.

After importing, save your page and edit the imported data as you need.
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Figure 1-5:
The Import
Tabular
Data dialog
box.
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Importing Word and Excel Files (Windows Only)

Windows users can import Word and Excel files right into any new or
existing Dreamweaver page. During the import process, Dreamweaver
automatically strips the Microsoft files of unnecessary code including style
formatting and converts the content into HTML code. The only cautionary
restriction is that the file must be smaller than 300K after importing.

Figure 1-6:
Importa
Word file
with the
Import Word
Document
dialog box.

Follow these steps to import the entire contents of a Word or Excel file:

1. Choose File=>Import and then choose either Word or Excel.

2. In the Import File dialog box, browse for and select the file to open
and click Open to begin the import.

Figure 1-6 shows the Import Word Document dialog box.

If your computer alerts you that the server is busy and that the action
cannot be completed because another program is busy, click the Switch
To or Retry button to correct the problem and import the file.

Import Word Document
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&gN\BEI? 3. Edit the imported data as you need.
&

You're making changes in the new document and not altering the
original Microsoft file.

4. Choose File>Save.

To include only part of a Microsoft file and preserve formatting, paste the
portion of the file you want directly in the Web document.

Book 11
Chapter 1

syuawnao( buneas)



72 Book 11: Mastering the Basics



Chapter 2: Working with Text

In This Chapter

v Adding, editing, and removing text

v~ Inserting text with the Paste and Paste Special commands
v~ Using the Properties inspector

»” Creating inline style sheets

v Creating bulleted and numbered lists

1 Searching with Find and Replace

A dding text to your pages in HTML is as easy as typing in a word
processing document or text editor. You can insert, change, or delete
text, as well as style, order, and structure it. You can even paste text from
another file into an open Dreamweaver Document window.

Text is the keystone of all Web pages. In fact, a Web page is simply a text file
(that may also contain other objects, such as images and tables) that uses a
set of HTML tags and CSS markup to describe to a browser how to format
and display the text. Use text to describe a company’s products or services,
provide contact information, make important facts and figures available to
visitors, tell stories, and more. In addition, text on a Web page is searchable
by search engines, which means what you add to a page should be easy to
read and understand.

This chapter covers everything you need to know about working with

text including adding, editing, and removing copy; using the Properties
inspector to create inline CSS; making lists; and using the Find and Replace
tool for robust text and code editing.

Adding Text

You can type text directly into the Document window in either Design or
Code view. To begin adding text in Design view, open any new or existing
document and place your cursor at the point where you want to add the
text; then, begin typing. In Code view, you can add text straight to the code
anywhere inside the opening and closing <body> tags, including inside table
cells, <div> tags, and <span> tags.
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ég‘l\BEli In Design view, when you select a word, sentence, or paragraph, the
<

corresponding code also gets selected in Code view, and when you select
content in Code view, that content also gets selected in Design view.
You can switch freely between typing text in Design and Code views.

As you add text to your page and leave your mouse hovering over the
workspace in Design or Code view, you may notice a small square gray icon
with a ship’s steering wheel appear. This is the icon for the Code Navigator
tool, which pops up to provide you with quick access to the CSS rules and
other code sources that affect your selection (or the content near your
cursor when no selection is active). To find out more about the Code
Navigator, see Book IIl, Chapter 1.

Editing Text

To edit text, select the text you want to edit and start typing. By selecting
the text first, you automatically overwrite the text in the selection when you
type. Make a selection by double-clicking a word to select the whole word,
or triple-clicking a word to select an entire block of text.

When selecting with a triple-click in Design view, only the copy gets selected.
However, when triple-clicking in Code view, both the content and the
content’s HTML container tags get selected.

<P If, however, the content between any two tags includes any unnecessary
breaks in the text (not including <br> or <p> breaks), the triple-click in
Code view only selects a single line rather than the entire content block
between the two tags. If that happens, clean up the code by removing any
unnecessary spacing between characters and try the triple-click again.

Text containers include <body>, <p>, <h1> through <h6>, <div>, <span>,
<td>, and <1i> among others. If a paragraph of text is contained inside a
paragraph tag, the opening and closing <p> tags aren’t selected along with
the text in Design view, but they are selected in Code view, as shown in the
following examples.

When triple-clicking a word inside a paragraph in Design view:
Hot cross buns! Hot cross buns! One a penny two a penny - Hot cross buns!

When triple-clicking a word inside a paragraph in Code view with no
unnecessary breaks in the content:

<p>Hot cross buns! Hot cross buns! One a penny two a penny - Hot cross buns!</p>

When triple-clicking a word inside a paragraph in Code view with an
unnecessary break in the content, in this case the break is after the second
instance of the word buns!:

<p>Hot cross buns! Hot cross buns!
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Removing Text

Figure 2-1:
Set
formatting
preferences
for pasted
text.

To remove text, select it and delete it by pressing Delete or Backspace on
the keyboard or by choosing Edit=>Clear or Edit=>Cut from the main menu to
clear or cut the selection. The keyboard shortcut for the Cut command is
Ctrl+X (Windows) or 8+X (Mac)Pasting Text from Another File

When pasting data into Dreamweaver from a Word document, Web site, or
other word processing file, Dreamweaver often preserves that document’s
formatting when you use the regular Paste command. Formatting, including
font face, size, and alignment, transfers to the file with the copied text. If you
want to preserve formatting, choose Copy=Paste.

On the other hand, if you want to have some control over how the pasted
copy gets formatted, follow these steps:

1. Copy the text you want to paste and then choose Copy=>Paste Special.
The Paste Special dialog box opens, as shown in Figure 2-1.
2. Select one of the following paste options:

e Text only: Paste the copied text as unformatted text. Any
formatting attributes copied from the original source file, including
line and paragraph breaks, bold or italics, font size, and font
color, is stripped.

¢ Text with structure: Paste the copied text with its existing paragraph
structure, including line and paragraph breaks, lists, and tables. Its
formatting attributes, such as bold or italics, are not included.

¢ Text with structure plus basic formatting: Paste the copied text with
pre-existing structure and HTML formatting, including paragraphs,
line breaks, and tables, and basic text markup using tags such as
<hl>, <strong>, <em>, and <hr>.

¢ Text with structure plus full formatting: Paste the copied text into
Dreamweaver with all its original structure, HTML formatting, and
pre-existing internal CSS data. This option does not include the
copying of styles that come from sources external to the copied file,
such as an external CSS file, or from any programs that don’t allow
style information to be copied to the Clipboard.

Paste Special
Paste as;
() Text only
() Text with struckure {paragraphs, lists, tables, etc,)
() Text with structure plus basic Formatting (hold; italic) ol
—~ ielp

() Text with structure plus Full Formatting (baold, italic, styles)

Clean up Word paragraph spacing

Paste Preferences. ..

Book 11
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A\

3. Check the Retain Line Breaks option.

Enable this option to keep pre-existing line breaks, or disable this option
to remove the unwanted line breaks that some applications add at the
ends of each line of text. This option is not available for the Text Only
option. Note: If this option is grayed out, click the Paste Preferences
button to edit the default settings in the Copy/Paste category of the
Preferences dialog box.

4. Check the Clean Up Word Paragraph Spacing option.

Enable this option when using the Text with Structure and Text with
Structure plus Basic Formatting options to remove extra spaces between
paragraphs in the pasted text.

5. Click OK.

The copied text is pasted into your document with the selected settings.

The paste preferences you select in the Paste Special dialog box remain in
effect until you change them, so feel free to change them as often as needed.

Setting Text Properties in the Properties Inspector

Figure 2-2:
The
Properties
inspector
displays
HTML
formatting
options for
selected
text.

The Properties inspector is context specific, so when you're adding text to
the page, it displays options for formatting and linking text. The Properties
inspector has two different tabs or views; one for HTML and one for CSS. To
toggle between the two tabs, click the HTML or CSS button at the left edge of
the panel.

Within the HTML tab, as shown in Figure 2-2, you can specify font format
such as Paragraph or H1, add bold or italics tags, set a CSS class or ID,
create lists, indent or outdent text, and enter hyperlink information. These
settings, or styles, are applied immediately to selected content, and you can
change them at any time.

Unordered list— —Ordered list

Italic | | Text Outdent
HTML button Bold Text Indent
PROPERTIES |
HTML Format | Mone v Class | None v = Title
() ID | None v Link, v @ Target
CSS button Point to File— “Browse for File



Figure 2-3:
The
Properties
inspector
also
displays
CSS
formatting
options
when text is
selected.
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In the CSS tab, shown in Figure 2-3, settings include specifying a targeted
rule, selecting the font family, size, and color, adding bold or italics, and set-
ting font alignment. You can also quickly access a CSS rule in the CSS Styles
panel for any selected content by clicking the CSS Panel button, and edit that
rule, if desired, by clicking the Edit Rule button.

When you add Bold or Italic formatting by clicking the B or I button in the
Properties inspector, Dreamweaver writes the newer standards-compliant
<strong> and <em> (for emphasis) tags into the code instead of the former
<b> and <i> tags. This is because <b> and <i> are formatting tags,
whereas <strong> and <em> are structural tags. Both tags format text, but
structural tags can also provide clues about the text’s importance that can
help improve search engine rankings by emphasizing important keywords or
phrases as well as complying with Web accessibility guidelines to improve
the way screen readers interpret text on a page with speech inflections.
Though browsers still support the old <b> and <i> tags, we recommend you
only use the newer <strong> and <em> tags.

HTML button

PHOPERTIES |

HTML Targeted Rule | <Mew C55 Rule> ~|  Fant | Default Font ~| B

css Edit Rule Sige |Mone (v ]

CSS button

HTML Properties Inspector

Here’s an overview of the text options in the Properties inspector when the
HTML tab is selected:

4+ Format lets you choose the paragraph style that’s applied to the
selected text. Styles include none, paragraph <p>, preformatted <pre>,
or headings <h1> through <h6>.

4+ ID lets you select an ID from any linked or internal CSS style sheet. An ID
identifies the contents of a tag pair with a unique name, which can then
be formatted and positioned with CSS.

Book Il
Chapter 2
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<+

+ 4

Class shows a list of custom styles on the internal and/or attached
external CSS, if any. Select and apply a style by name, remove a style
attribute by selecting None, or launch dialog boxes to rename a style or
attach an external style sheet to the open document. When no style

is applied, the drop-down list appears blank or says None, and when
multiple styles are applied, the drop-down list is blank.

Bold adds the <strong> tags around selected text to emphasize the
selection with boldness.

Italic adds the <em> tags around selected text to emphasize the
selection with italics.

Link adds hypertext links to selected text or graphics. To add a link,
select the text or graphic in either Design or Code view and do one of
the following:

e Type the URL or filename of the link in the Link text field.
e C(Click the folder button to browse for and select a file by name.

¢ (Click and drag the Point to File button onto the name of the file in the
Files panel. Release the button, and Dreamweaver writes the filename
in the Link text field for you. This is a great feature that both saves
time and helps you avoid typos!

¢ Drag and drop a file from the Files panel into the Link text box.

To create a text or image link before you know what the final URL or
filename will be, enter # or javascript:; in the Link text box.

Unordered List converts the selected text into a bulleted list.
Ordered List converts the selected text into a numbered list.

Text Outdent and Indent uniformly apply indenting and outdenting to
lists and blocks of text inside container tags such as <p>. Click the
Indent and Outdent buttons in the Properties inspector to add and
remove margin spacing evenly around the selected text. You can also
apply indents and outdents from the main menu or the context menu.
Indenting regular text adds the <blockguote> tag around a selection,
while outdenting removes the tag. By contrast, clicking the Indent and
Outdent buttons with list text creates sublists using <ol> or <ul> and
<1i> list tags. You can then format your multitiered lists with CSS to
apply font styles and control margin spacing.

Indenting with the <blockquote> tag typically adds about 40 pixels of
uniform padding on the left and right margins and a little extra white
space above and below. For better control over your content, consider
using CSS to create a custom style that indents your content without the
need for <blockquote> tags.

Title adds a title attribute to a selected hyperlink for enhanced accessi-
bility for visitors using assistive devices. Titles also can be used to
improve search engine listings and rankings.
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4+ Target specifies where the linked page opens, whether in the same
browser window, another browser window, or a frame inside a frameset.
Without adding a target, the default setting is to open the linked page in
the same browser window. Choose _blank to display the linked page in a
new browser window, _self to open it in the same browser window,
_parent to open the file in the parent frameset or the same frame as the
link, or _top to open the file in the full browser, breaking any pre-existing
frames. (Though frames aren’t a best practice in web design anymore,
you can learn more about using frames, see Book IV, Chapter 3). The
Target option appears grayed out until you activate it by entering a link
in the Link field.

4+ List Item allows you to specify a list type from a dialog box. For unor- Book II
dered lists, choose a list style of circle, disc, or square. For ordered lists, Chapter 2
choose from numbers (1, 2, 3), upper (I, II, IIl) or lowercase (i, ii, iii)
roman numerals, and upper (A, B, C) or lowercase (a, b, ¢) letters. The
list item button remains grayed out until you create a list on your page
and place your cursor anywhere inside, but not selecting, part of the list.

4+ Page Properties opens the Page Properties dialog box, from which you
can modify the properties of the currently open page, including the
default font face, size, and color, background color, and margin spacing.
(See Book I, Chapter 1 for details on the Page Properties dialog box.)

1Xa] ynm Bunjiopp

CSS Properties Inspector

When the CSS tab on Properties inspector is selected, use the following text
formatting options:

4+ Targeted Rule lists options in the drop-down menu for adding a
new rule, and applying a CSS class, or removing a CSS class from
selected text:

e New CSS Rule: Select to launch the New CSS Rule dialog box.

¢ New Inline Style: Select to add inline CSS style formatting to selected
text using the options within the Properties inspector.

e Remove Class: Select to strip CSS styles applied to selected text.

¢ Custom Style: Select a custom style by its name from the list to apply
the desired custom class style to selected text.

4+ Edit Rule launches the CSS Rule Definition dialog box for the CSS style
applied to selected text (or the CSS style applied to text surrounding
the current location of your cursor), inside which you may make
adjustments to that CSS style.

4+ CSS Panel opens or expands the CSS Styles panel when it is unopened
or collapsed in the panel dock area.
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4+ Font shows a list of font sets to choose from to apply to the selected
text. In a font set, if the first font is unavailable on the visitor’s com-
puter, the second font is used for onscreen display. If the second font
is unavailable, the third font is used, and so on. When you select a font
set, the New CSS rule dialog box will open so you can create your own
custom class, tag, or ID style with the “font-family” style to your style
sheet, as in “font-family: “Arial Black”, Gadget, sans-serif;”.

4+ Bold launches the New CSS Rule dialog box so you can create your own
custom class, tag, or ID style with the “font-weight: bold;” style to your
style sheet.

4+ Italic launches the New CSS Rule dialog box so you can create your own
custom class, tag, or ID style with the “font-style: italic;” style to your
style sheet.

4+ Left, Center, Right, and Justify Align launches the New CSS Rule
dialog box so you can create your own custom class, tag, or ID style
with the “text-align: left”, “text-align: right”, “text-align: center”, or “text-
align: justify” style to your style sheet. The custom style will then be

automatically applied to your selection.

4 Size launches the New CSS Rule dialog box so you can create your own
custom class, tag, or ID style with the “font-size: n unit;” style to your
style sheet, as in “font-size: 36px;” which will automatically be applied to
your selection. The size can be set in pixels (px), points (pt), inches (in),
centimeters (cm), millimeters (mm), picas (pc), ems (em), exs (ex), or
percentages (%). Because fonts render uniformly on both platforms
when specified in pixels, pixels are currently the preferred measure for
specifying precise font sizes. Alternately, percentages and ems are also
popular proportional sizing units.

Table 2-1 lists descriptions for all the acceptable units of measure.
Enter an exact number and unit, or select from preset sizes ranging from
xx-small to xx-large.

4+ Text Color turns the selected text to the specified RGB color by
launching the New CSS Rule dialog box so you can create your own
custom class, tag, or ID style with the “color: #hexvalue” style to
your style sheet. The custom style will then be automatically applied
to your selection. To select a hexadecimal color, type a color name,
such as aqua into the text field next to the Text Color box, or enter a
hexadecimal number, such as #000000 for black. Click the Text Color
box to pick a color from the Web-safe color palette or the System Color
Picker (it’s the rainbow colored circle button at the top of the Web-safe
color palette).

4+ Page Properties opens the Page Properties dialog box, from which you
can modify the CSS properties of the currently open page, including the
default font face, size, and color, background color, and margin spacing
in the Appearance (CSS), Appearance (HTML), Links (CSS), and
Headings (CSS) categories. (See Book II, Chapter 1 for details on the
Page Properties dialog box.)
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Table 2-1 Units of Measure

Unit of Description

Measure

px Pixels.

pt Points. One point is equal to '/ inch.

pc Picas. A pica is equal to 12 points.

% Percentage.

in Inches.

cm Centimeters. Book Il

mm Millimeters. Chapter 2

em A proportional unit of measure that equals the point size of the s
current font. For example, if the current font is 10 point, 1.2 em is =]
equal to 12 points. E

(7=}

ex A proportional unit of measure that equals half the point size of s
the current font. For example, if the current font is 10 point, 1.2 ex =3
is equal to 6 points. g

Creating Inline Styles

By default, Dreamweaver writes internal or external CSS instead of HTML to
add text formatting to your pages (see Book III, Chapter 1 for a full discus-
sion of Cascading Style Sheets).

However, you can add inline CSS styles using the New Inline Style Targeted
Rule on the CSS area of the Properties inspector, which writes code similar
to this:

<p style="font-family: Georgia, 'Times New Roman', Times, serif">This is how a
sentence gets marked up with an inline style.</p>

For inline CSS style markup, set the Targeted Rule to New Inline Style, and
use the Properties inspector’s font, size, color, bold, italic, list, and align
fields to add inline formatting to the page (as described in the preceding sec-
tion). Then, if you need to add list formatting, indenting, outdenting, or a
link, you can toggle to the HTML side of the Properties inspector to that
information. For example, bold linked text looks like this:

<a href="http://www.google.com"><strong>Google</strong></a>
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Hexadecimal numbers and the Web-safe palette

Colors on a Web page, whether used to format
page properties, text, table cells, or other
objects, display in a browser by using special
color codes called hexadecimal numbers.
These numbers are actually a set of three
hexadecimal number pairs where each digit in
a pair represents a value for red, green, and
blue, as in #RRGGBB. A number symbol (#)
always precedes the six digits when they
appear in the HTML or CSS code, and each
digit can have a value from 0—F (0-9 and A-F),
as in #CC33FF. On the 0-F scale, 0 has a null
value and F has the highest value of 15. The big-
gest value for any of the RGB pairs is FF, which
is equal to 255 in the normal decimal system.
This means, for example, that a value of #00FF00
yields the highest amount of green possible.

Web-safe colors refer to the 216 colors that
can accurately display in Web browsers on
both Mac and PC computers with 8-bit moni-
tors. These browser-safe colors use only the
following hexadecimal values: 00, 33, 66, 99, CC,
and FF. In addition to using the hexadecimal

values, you can also specify Web-safe colors
using a color name, such as cornflowerblue,
crimson, or plum.

To make specifying a color in Dreamweaver
easy, clickinthe Text Color box in the Properties
inspector to choose a color from the Web-safe
palette or the System Color Picker, or if you
happen to know it, type the hex value or name
of the color.

You can find a listing of all the acceptable
color names along with a swatch with their
color and hexadecimal equivalents at www .
w3schools.com/html/html_
colornames.asp.

Of course, these days — with monitors capable
of rendering millions of colors — using a Web-
safe color is no longer the critical issue it was
in the early days of the internet. Nonetheless,
knowing about the Web-safe palette and
understanding how to use it can really help you
to use color successfully on the Web.

When choosing a font, select one that is available for any site visitor
(whether using Mac OS or Windows). Here’s an acceptable list of fonts to
choose from when specifying the font face for your HTML text:

Arial Verdana Helvetica Times
Times New Courier Courier New Georgia
Roman
Geneva PalatinoPalatino

LinotypeTahoma
Trebuchet Serif Sans-serif

For additional information about browser-safe fonts in general and a
thorough list of fonts that come preinstalled in Windows and Macintosh
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computers, check out www.websitenotes.com/websitenotes-37-2004
1220BrowserSafeFonts.html or www.ampsoft.net/webdesign-1/
WindowsMacFonts.html.

To help further with font selection, Dreamweaver allows you to select font
sets to style your text. Font sets are lists of fonts that browsers read and

use to display text. The browser looks for the first font listed in the set and
renders the page using that font face. If the first font listed is unavailable, the
browser searches for the next font in the list, and so on. Most font sets end
with either serif or sans-serif, which are standard to all computers. A typical
font set is Arial, Helvetica, Sans-serif. The benefit of using font sets instead of
a single font is that if a single font is not found on the computer viewing the
page, the text on that page displays with the browser’s default font face.
With a font set, you have more control over which fonts are tried — and
hopefully used — to display the text on the page.

To set the default font face, size, and color for an entire Web site, create an
external Cascading Style Sheet, as described in Book IIl, Chapter 1.

Inserting Special Characters

\\3

From time to time, you may need to access special characters such as © or
® or i1 when typing text in the Document window. Although you could look
up the HTML code for the appropriate character and then type it in Code
view, Dreamweaver lets you choose many of the commonly used symbols
found in other programs. All special characters are represented in HTML
with a name or number. Dreamweaver calls each of these an entity. For
instance, you can code the copyright symbol with &copy; or &#169;.

If you need to use the greater- and less-than brackets in your text and don’t
want HTML to interpret them as tags, use the entity symbols: &gt ; for
greater than (>) and &1t ; for less than (<).

To add a special character to an open file, follow these steps:

1. Place your cursor in the position you want to add the special character.

Single-click in Design view or Code view to place the insertion point in
the right position.

2. Choose Insert->HTML=>Special Characters. Then from the flyout menu,
choose from the list of commonly used special characters.

3. If you don’t see the character you want to use, choose Other at the
very bottom of the flyout menu.

The Insert Other Character dialog box, shown in Figure 2-4, appears.

Book 11
Chapter 2

1Xa] ynm Bunjiopp



8 ﬂ Creating Lists

Insert Other Character
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4. Select the character you want and click OK to insert that character.
A\

You can also copy and paste the HTML code from the Insert field at the
top of the Special Characters dialog box. For instance, the HTML code
for the Euro currency sign is &#8364;.

For a great list of commonly used unicode symbols, see www.w3schools.
com/tags/ref_entities.asp.

Creating Lists

Lists are classified as either unordered or ordered:

4+ Unordered: A bullet precedes all the list items. The style of the bullet

can be a bullet (a solid circle), a circle (a hollow disc), or a small square.
Dreamweaver only lets you choose a bullet or a square, however, so to
use the circle style, you need to modify the code by hand.

<ul type="disc|circle|square">
Ordered: The list type can be Numbered (1, 2, 3), Roman Uppercase

(1, 11, 1IT), Roman Lowercase (i, ii, iii), Alphabet Uppercase (A, B, C), or
Alphabet Lowercase (a, b, c).

<ol type="Ala|I|i|1">
In addition to the number type, ordered lists can have a starting value
different than 1. For example, to start an ordered list using Alphabet

uppercase at the letter J, add the start value of 10 (J is the 10th letter) to
the <ol> tag:

<ol type="A" start="10">

To add a start value to a list item <11i> tag instead of the ordered list
<ol> tag, use the value attribute instead of the start attribute:

<1li value="10">
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If you don’t specify a list type, the default unordered list is bulleted with

a solid circle, and the default ordered list is numbered (1, 2, 3). To learn
how to customize the look of your bulleted lists with custom graphics and
formatting, turn to Book IIl, Chapter 1.

To convert selected text into list format, follow these steps:

1. Select the text you want to convert to a list.

You can also type your first entry, convert it to a list format, and then
continue adding items. Dreamweaver automatically continues to format
your list.

2. Click the Unordered or Ordered List button in the HTML area of the
Properties inspector.

The Unordered List button looks like a bulleted list, and the Ordered
List button looks like a numbered list (refer to Figure 2-2).

3. Deselect the text by clicking the cursor inside any of the list items.

When the list is deselected, the List ltem button becomes active in the
Properties inspector.

4. Click the List Item button in the Properties inspector.
The List Properties dialog box opens.
5. Select a list type.
6. Click OK to close the List Properties dialog box.
To change the list type of an existing list, place your cursor anywhere inside
the list and choose another list type from the List Properties dialog box. You
can also convert unordered lists into ordered lists, and vice versa. The list

buttons in the Properties inspector are toggle buttons allowing you to add
and remove list formatting to selected text as needed.

Editing with the Find and Replace Tool

The Find and Replace dialog box is a powerful editing tool. For example,

you could use the Find and Replace Tool to search for all instances of a
copyright date of ‘2008’ and replace them with ‘2009’. Use this feature to find
and replace text or source code in a selection, in an open document, for a
specified folder, or for the currently managed site. This is a great tool for
replacing filenames, stripping out unnecessary tags, adding or removing

site root-relative path formatting, and replacing entire blocks of code with
other content.

The following sections explain how to search for specific tags and attributes,
search for text in specific tags, save and reuse search strings, and search
using regular expressions.

Book 11
Chapter 2
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Searching for tags and attributes

The most common use of the Find and Replace tool is to search for and
modify specific tags and attributes. For example, you may need to find all
instances of the old <font> tag and strip them from the code, or you may
need to find all occurrences of the word Principle and replace them with the
word Principal. Whatever your need, the general find and replace method is
the same. The differences are where you're searching, what you’re searching
for, and what you want to do with the results when you find them.

Follow these steps to search for specific tags or attributes:
1. Open the file you want to search in, or select the document or folder
you want to search in the Files panel.
2. Choose Edit=>Find and Replace.
The Find and Replace dialog box opens, as shown in Figure 2-5.

3. Select the files to be searched from the Find In drop-down list. These
are your options:

¢ Selected Text searches only in text selected in the open document.
e Current Document searches the open file.

¢ Open Documents searches any file that’s open in the workspace.

¢ Folder searches only in the specified folder.

¢ Selected Files in Site searches only the files and folders selected in
the Files panel.

¢ Entire Current Local Site searches an entire local or remote site.
4. Select a search type from the Search drop-down list.
¢ Source Code searches for specific HTML code or tags.

¢ Text searches for specific words or word combinations ignoring
HTML. For example, searching for the perfect car would
match both the perfect car and the <strong>perfect

</strong>car.

—
Figure 2-5: &% Find and Replace o=
Find and Find in: | Current Document + | Untitled Document
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R Find:
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Text (Advanced) searches for specific text inside or outside of tags.
For instance, searching for apple pie and specifying Inside

Tag and the <b> tag would only find the first instance of the words
apple pie:lwanted to eat <b>apple pie</b> for breakfast but my
mother told me I had to wait until dinner. Who made her the apple pie
rule queen?

Specific Tag searches for specific tags, their attributes, and those
attribute values, such as all <td> tags with align set to bottom: <td
align="bottom">.

To search for a Return character, add line breaks in the search query by
pressing Shift+Enter (Win) or Shift+Return (Mac). Just be sure to turn off
the Ignore White Space option if regular expressions are not part of the
search. Doing so ensures the search finds a Return and not a <br> or
<p> tag.

5. Enter additional options as needed to further define the search:

Match Case matches upper and lowercase letters as defined. For
example, if you search for Chocolate Cake, you won't find
chocolate cake.

Ignore Whitespace reads any white space except <p> and <br> tags
as a single space for the purposes of matching items in your search.
With the option turned on, me and you would match me and you
andme and you, but not meandyou. This option is not available
when using regular expressions, so if you use them, you need to
write the expression to ignore white space.

Match Whole Word searches for text matching a whole word or
phrase, similar to the regular expression search for strings starting
and ending with \b.

Use Regular Expression forces specific characters and strings like
\b or ? to be interpreted as regular expression operators. See the
upcoming section “Using regular expressions in your searches” for
more information on regular expressions.

When starting a search from within Code view, Dreamweaver may let
you know that it’s synchronizing views before beginning the search. If
that happens, click OK to continue.

6. Search for your text by clicking the appropriate button:

Find Next jumps from each found instance to the next, and if search-
ing in multiple documents, jumps from one document to the next.

Find All opens the Results panel and displays search results.

Replace replaces your search criteria with your replacement text in
the To field. Click Find Next to move to the next instance.

Replace All finds all instances of your search criteria and replaces
them with your replacement text in the To field.
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Figure 2-6:
Search for
attributes

in specific
tags.

You can’t undo these commands, so be sure to perform a backup of
your files prior to replacing all, or just be really, really careful that
you're replacing what you want to be replacing.

7. Click the Close button when finished.

Press F3 (Windows) or 38+G (Mac) to search for the same criteria again

without launching the Find and Replace dialog box.

You can also click the “Save Report” icon (the disk) on the search
results panel and save the results as an XML file, which you can drag
into Microsoft Excel and view a nice chart. This is handy for showing
bosses and clients how many text items were replaced.

Searching for text in specific tags
When searching in code for specific tags, you may find including attributes
is helpful as a way to narrow the search. Dreamweaver lets you search
not only for specific tags, but also for the attributes of those tags and the
attribute values, as shown in Figure 2-6.

& Find and Replace =)
Find in: | Current Document + | Untitled Document: Find Mext
Search: | Specific Tag |% || ima i) = < Find &ll

[=] | without Attribute w||at ~
Replace
Action: | et Attribute v | ak vl T v| [ Beplaceal
Options: [ Match case [#] 1grore whitespace:
[IMatch whale ward [Juse regular expression

For instance, to ensure all your images have alt attributes for W3
accessibility compliance, you may need to search for all the <img> tags
without alt attributes. You can set parameters to add the attribute
with an empty value (alt="") by leaving the To field blank.

To search for text in specific tags, follow Steps 1 through 3 from the
previous section and continue with these steps:

1. From the Search drop-down list, select Specific Tag.

2. Click the plus (+) button to add a tag modifier (optional):

¢ With Attribute lets you specify the attribute type and attribute value

of the tag to be a match.

e Without Attribute lets you specify that a particular attribute is not in

the search to be considered a match.
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Containing lets you specify either text or a tag that must be present
in the specific tag to be a match.

Not Containing lets you specify that certain text or a tag must not be
in the first tag to be a match.

Inside Tag lets you specify that a tag must be found inside the first
tag to be a match.

Not Inside Tag lets you specify that a tag must not be found inside
the first tag to be a match.

Note: When the search does not need any tag modifiers, click the minus
(=) button to remove any pre-existing tag modifiers.

3. To further limit the search, repeat Step 2.

4. If replacing content, choose an action from the Action menu and input
additional information as prompted:

Replace Tag & Contents prompts you to enter Replace With informa-
tion for the new tag and contents.

Replace Contents Only prompts you to enter Replace With informa-
tion for the contents of the specified tag.

Remove Tag & Contents removes the selected tag and everything in
between.

Strip Tag will completely remove specified tags but not their
content.

Change Tag prompts you to select another tag type from a
drop-down list.

Set Attribute lets you select a tag and specify its attribute, if any.

Remove Attribute prompts you to select an attribute to be removed
from the specified tag.

Add Before Start Tag lets you enter data to add before the specified
start tag.

Add After End Tag lets you enter data to add after the specified
end tag.

Add After Start Tag lets you enter data to add after the specified
start tag.

Add Before End Tag lets you enter data to add before the specified
end tag.

5. Search for your text by clicking the appropriate button:

Find All opens the Results panel and displays search results.

Find Next jumps from each found instance to the next, and if search-
ing in multiple documents, jumps from one document to the next.
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¢ Replace replaces your search criteria with your replacement text in
the To field. Click Find Next to move to the next instance.

¢ Replace All finds all instances of your search criteria and replaces
them with your replacement text in the To field.

6. Click the Close button to exit the Find and Replace dialog box.

Saving and reusing searches

When creating complex search parameters, you may need to reuse a search
in the future. To save a search to reuse later, enter the desired search
options and click the Save Query icon, which looks like a floppy disk and is
located near the Find Next button. When prompted, name the search with
the .dwr file extension, browse to the location where you want to save the
search, and click Save.

To use a saved search, launch the Find and Replace dialog box and click the
Load Query icon, which looks like an open folder with a page being filed
inside it. In the Load query dialog box, navigate to the folder where you
saved the search, select it, and click Open. After it’s loaded, click any of the
Find or Replace buttons.

Using reqular expressions in your searches

Regular expressions are patterns made up of letter, symbol, and number
combinations used in searches to help narrow search terms. Dreamweaver
allows for use of regular expressions in your searches if you want to use
them. Common regular expression characters include the following:

4+ /d: Matches a single digit between 0 and 9.

4+ 7:Matches at the start of the line.

4 /b: Matches at a word boundary.
For example, to compile a search for a specific e-mail address (info@
companyname . com) in the entire Web site, your search criteria is the
following:

4+ Look for the specific tag, in this case, <a>.

4+ The tag must contain text including the regular expression, in this case,
~info.

4+ Replace the text with the e-mail address.

Take a look at Figure 2-7 to see this search.



Figure 2-7:
Search
using
regular
expressions.
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o Find and Replace =
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Search: | Specific Tag |l a v = Find &ll

[#] (=] | Containing || Text w | ~infa
Action: |Replace Tag & Contents | % | ey, | [Javadcript encrypted email address goes here] Replace Al
Options: [_]Match case [#]1grore whitespace:
[IMatch whole ward [use regular expression

\\J

To find out more about regular expressions, visit www.regular-
expressions.info/ or see the “Introduction to Regular Expressions
in Dreamweaver” article on the Dreamweaver Developer Center Web
site at www.adobe.com/devnet/dreamweaver/articles/regular__
expressions.html.
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Chapter 3: Inserting Graphics

In This Chapter

v+~ Inserting, editing, deleting, and moving images
1~ Setting image attributes

+~ Adding interactive elements, such as rollover images and image maps

G\raphics give a Web page personality. They help create the look and
feel that represents the product, service, company, or person the Web
site is for. Graphics are great for navigation buttons, logos, photographs,
icons, buttons, background images, illustrations, and more.

For Web sites, you’re limited to certain types of graphics. The three main
types of graphics supported by most browsers are GIF (pronounced JIF, like
the peanut butter, though some people say GIF with a hard G as in gate),
PNG (pronounced Ping), and JPEG or JPG (pronounced J-peg). Each format
takes high-resolution images and compresses the data to keep file sizes
smaller than their high-resolution counterparts. Because most browsers can
only support 72 pixels per inch for on-screen display, you need to reduce
your Web graphics to 72 pixels per inch. Fortunately, what is lost in resolu-
tion is made up for in reduced file sizes.

When optimizing your images for the Web, GIF and PNG-8 files are best used
for graphics with large, flat areas of color with a maximum of 256 colors,
while JPEGs and PNG-24s support millions of colors and are best used for
photographs and images with gradients. While the PNG-24 file format is far
superior to the PNG-8 format, PNG-24 files are not yet fully supported by
Internet browsers. As such, this chapter limits discussion of PNG files to the
PNG-8 format.

This chapter presumes your graphics are optimized in the GIF, PNG-8, or
JPG format and are ready to insert into your Web page. Besides inserting
images, you find out how to edit, delete, and move graphics, set image
attributes such as borders, create rollover buttons and image maps,
build an image-based navigation bar, and work with graphics and HTML
generated in Adobe Fireworks.
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Inserting Images in Your Web Page

As with many features of Dreamweaver, you have several ways to add
images to a Web page. Oftentimes, the insertion method you choose is
simply determined by where the mouse happens to be on-screen. For
instance, if your mouse is closest to the Files panel, you’ll probably insert
the image from there.

QQ,N\BEB Before you begin adding images to your Web page, be sure you save all your
& graphics into an images folder at the root level of your managed Web site. If
the folder doesn’t exist yet, create it so you can place all your graphic files
inside it. Organizing your graphics into a common folder can help you keep
track of files as the site grows.

When inserting your images, whatever method you choose, Dreamweaver
automatically writes the code for you, including the path where the image is.
If the image is outside the managed site folder, Dreamweaver may prompt
you to copy the graphic file into the current managed site. Furthermore,
whenever the Select Image Source dialog box appears, you can select File
System to pick a graphic from a folder, or choose Data Source to specify a
dynamic image source.

Using the Insert panel

The easiest way to insert images is by using the Images pull-down menu on
the Common category of the Insert panel. The pull-down menu remembers
the last button selected and displays that button’s icon, but by default, the
Image button appears. To insert an image, follow these steps:

1. Click the Insert Image menu button in the Common category of the
Insert panel and select the Image button.

The Image button looks like a little tree in a grassy field.

When the button on the menu displays the image type you need, you
can click it to insert a graphic. Otherwise, use the pull-down menu to
select the type of image you want to insert.

The Select Image Source dialog box opens (shown in Figure 3-1) where
you can navigate to and select the graphic you want to insert. The
dialog box has a panel to display the files by name and a preview area
including an image preview, image dimensions, format, size, and
probable loading time.

2. Select the image you want to insert and click OK.

The image appears on the page.
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insert. Preview images
If you have Accessibility options activated in Dreamweaver’s Preferences,
the Image Tag Accessibility Attributes dialog box appears to add accessibil-
ity attributes for Alternate text and a long description. Enter one or both
accessibility attributes. At the minimum, it’s highly recommended that you
add Alternate text to describe the image in 50 characters or less. The Alt
attribute you enter is read by browser screen-reader software used by the
visually impaired. For the long description, enter a filename or URL to a page
that has a longer description of that image. Then click OK. To bypass
Accessibility options and insert the image, click Cancel. To discover more
about designing Web sites with accessibility, see Book I, Chapter 2.

A\

You can also drag and drop the Image button from the Insert panel into the
open file in either Design or Code view. Believe it or not, you can even drag
and drop an image from the desktop into an open Dreamweaver document.

When working in an unsaved file, Dreamweaver writes a file: /// reference
to the image, but converts that reference to the document-relative path
upon saving the file. For instance, before saving your file, the image path
may look like this:

<img src="file:///C|/Documents and Settings/Administrator/My Documents/ Clients/
ClientX_HTML/images/logo.gif" width="200" height="200" alt="logo" />

But after saving the file, the path may look like this:

<img src="images/logo.gif" width="200" height="200" alt="logo" />
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Figure 3-2:
The Assets
panel
displays
images.

Uqu the Insert menu

Use the Insert menu as an alternate method of inserting images. Choose
Insert=>Image to insert an image. As with the Insert panel method described
in the preceding section, navigate to and pick the image to insert from the
Select Image Source dialog box.

Using the Assets panel

To use the Assets panel to insert images, you must define your site first (see
Book 1, Chapter 3 for details) and make sure you’ve placed all the optimized
graphics for the site into an images folder at the root level of the managed
site. After defining the site, click the Images button located at the top-left
corner of the Assets panel (as shown in Figure 3-2) to see a list of images.
The Assets panel has a preview window that shows a thumbnail of any
selected graphic file in the managed site. Beneath the preview window,
graphics are listed alphabetically by name and also show file dimensions in
pixels, file size in KB, file type (GIF, PNG, JPG, and so on), and the full path
and filename of the image.

To insert an image from the Assets panel, select the image and do one of the
following:

4 C(lick the Insert button at the bottom of the panel.

4+ Drag and drop the image into the page at the desired location.

Images button Preview window
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Insert button

Using the Files panel

To add images to an open document from the Files panel, simply select,
drag, and drop the chosen image into the desired location on the page. If
you have Accessibility preferences enabled, the Image Tag Accessibility
Attribute dialog box opens and prompts you to enter accessibility attributes
for the image. Enter those values and click OK, or click Cancel to bypass
accessibility options and insert the image without the Alt and Long
Description attributes.



Using an Image Placeholder When a Graphic Isn’t Ready 9 /

Editing, Deleting, and Moving Inserted Images

After you insert the image, you can do many things with it:

4+ Edit: Select the image to modify any of the image attributes or replace
the image with another image in the Properties inspector. For the
lowdown on modifying image attributes, see the section “Setting Image
Attributes with the Properties Inspector,” later in the chapter.

4+ Delete: Select the image and press Delete or Backspace, or choose
Edite>Clear or Edit=>Cut.

4 Move: In Design view, drag the image to its new location and release the
mouse button. You can also cut and paste the image in both Design and
Code views.

Using an Image Placeholder
When a Graphic Isn’t Ready

WMBER
@"&
&

Figure 3-3:
Set Image
Placeholder
attributes.

Placeholder images are great to use if you know you need graphics in parts
of your layout but the graphics aren’t ready yet. Placeholder images can be
any size in pixels, and the width and height attributes display in the center
of the placeholder image itself.

Image placeholders don’t display in browser windows and are intended for
use in the Dreamweaver environment only. Therefore, before launching a
Web page or site, be sure to replace any image placeholders with the desired
GIF, PNG, or JPEG files.

To insert a placeholder image, follow these steps:
1. Select the Image Placeholder option from the Image drop-down menu

in the Common category of the Insert panel.

The button has an image of two tiny squares overlapping; one has a
picture of a tree on it and the other has a big grayed out X.

You can also choose Insert>Image Objects=>Image Placeholder.

The Image Placeholder dialog box opens, as shown in Figure 3-3.

Image Placeholder
Mame:  submit
weth 150 Heghti 30
Color: M| #236557

Alternate bext:  Sign Me Up!
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2. Enter the placeholder image attributes: Name, Width, Height, Color,
and Alternate Text. The Name field is used to create both name and id
attributes, which will be used later for identifying the graphic with
CSS and JavaScript.

The color attribute should either match the surrounding layout or the
predominant color of the graphic, because code for this color attribute
will be added to your placeholder image and it will not be removed
when you replace the placeholder with the real image. If the color is a
contrasting color, and you don’t remove the style code manually after
inserting the real image, site visitors may see that contrasting color
momentarily as the image loads in their browser. Here’s an example of
placeholder code:

<img name=portrait” src="" width="300" height="200" alt=""
style="background-color: #00FF997>

To choose a color, click the button to the right of Color and choose your
color from the pop-up palette. The hexadecimal number then appears in
the text box to the right. You can also type a color name, such as green,
or enter a hexadecimal number, such as #£f9933. (See Book II, Chapter 2
for more about using hexadecimal numbers.)

In Figure 3-3, the placeholder name is submit, the width is 150, the
height is 30, the color is #286987, and the Alternate text is Sign Me
Up!

3. Click OK.
The placeholder image is inserted on the page.

In Code view, you see the following HTML for the example:

<img src="" alt="Sign Me Up!" name="submit" width="150" height="30"
id="submit" style="background-color: #266984" />

Figure 3-4 shows how this image looks in Design view. The image
placeholder displays the name, dimensions, and color you input in the
dialog box.

When you’re ready to replace the placeholder image with the real image,
double-click the placeholder image in Design view to open the Select Image
Source dialog box, select the replacement image, and click the OK button.
The name, 14, background color, and alt attributes from the place-
holder image remain, while the source of the image and its width and height
get updated with the new file name.
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Setting Image Attributes with the Properties Inspector

Figure 3-5:
The
Properties
inspector
displays
fields to
add image
attributes.

After you insert an image into your document, you’ll want to add other
markup and possibly style attributes to the image. Most of the attributes can
be added to the image through the Properties inspector, including applying
any custom CSS styles you may have already created or intend to create.
(See Book III, Chapter 1 for the lowdown on creating style sheets.)

Suppose, for example, you insert an image called 1ogo.gif into a Web
page. Select the image to apply attributes. As shown in Figure 3-5, a thumb-
nail of the image displays in the top left of the Properties inspector, along
with the file size in K, width and height sizes, image source, ID, and Alternate
text. If your Properties Inspector also displays a Photoshop or Fireworks
icon in the Edit area, you can click that icon to open the selected graphic in
that program for editing.

Thumbnail Image Optimize Sharpen
in
ID File size Photoshop Resample
PROPERTIES | ==
__@ dmage, 4K~y 1q2 Sre | images{logo.of o Lak ~ Class None | v @
ir) H 201 Link. gy Ede & @
Map V Space Target Border | 1 = A
—k xlj T? HSpace Original Gy Aian |Defauk | 1v .
Pointer | Oval Polygon Crop

Hotspot | Hotspot Hotspot )
Brightness/Contrast

Rectangular Hotspot

If you can’t see all the image properties shown in Figure 3-5, click the
expander arrow in the bottom-right corner of the Properties inspector.

Naming your images

First and foremost, it’s a good idea to name all your images so you can
quickly apply Dreamweaver behaviors, JavaScript, CSS, and/or VBScript to
them later. To name your images, select the graphic and enter a name in the
Name field of the Properties inspector (refer to Figure 3-5).

Specifying the width and height of images

By default, when images are inserted onto a page, Dreamweaver reads image
dimensions, writes them into the code in pixels, and displays them in the W
and H fields of the Properties inspector. Although Dreamweaver inserts
dimensions in pixels, you can adjust the dimensions to percentages. When
specifying sizes in percentages, be sure to add the % symbol after the
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number, as in 80%. In the example image, the logo graphic is 192 x 201
pixels. If the image gets resized, the new image dimensions appear in the
W and H fields.

Resizing and resetting images

Resize images by either dragging the resize handles located on the left,
bottom, and bottom-left corners of the selected image or by entering new
image dimensions in the W and H fields on the Properties inspector. Once an
image is stretched or scrunched beyond its normal size, the Reset Size
button appears between the W and H fields in the Properties inspector and
the W and H values appear in bold. To revert to an image’s normal size, click
the Reset Size button.

It’s a good idea — especially if you're scaling up — to create new graphics
with an external image-editing program rather than resize them in
Dreamweaver. Inserting correctly sized images reduces browser download
time as well as helps to maintain the integrity of the image as it appears
elsewhere on the site.

Adding vertical or horizontal padding

To push the edges of a graphic away from surrounding text, you may want to
add padding to your images. In the past, designers would use the V Space
and H Space HTML markup fields to add uniform vertical or horizontal
padding. For vertical padding above and below the image, enter pixels in the
V Space field. For horizontal padding on the left and right sides of the image,
enter pixels in the H Space field.

A better method of adding padding to images is to use CSS, especially
because it allows you to apply non-uniform padding around an image, such
as padding on just the top and left sides. See Book IlI, Chapter 1 to learn
more about CSS.

Adding image links

The Properties inspector has a Link field to enter the filename or full path of
a page or document the graphic can link to. To add a link to an image, select
the image and enter the filename and/or path, including file extension, in the
Link field. For alternate link options and detailed instructions on linking, see
Book II, Chapter 4.

Adjusting targets

When an image contains a link, the Target field becomes active to set the
browser frame or browser window into which the linked file should load.
When unspecified, the default target for all links is _self£. In other words,
when you click a link in a browser window, the linked document opens in the
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same browser window. If that’s what you want to happen when clicking the
link, leave the Target field blank. Otherwise, to specify that the link opens a
new window for displaying the linked page, select _blank from the Target
drop-down list. (You can read more on setting link targets in Book II,
Chapter 4.)

Specifying the original file

The Original field allows you to specify the location and filename of the
original file used to create the optimized Web graphic. Once specified, you
can quickly edit that file in the image editor you specify in the External
Editors preferences by clicking the Edit application icon next to the Link
field. See the “Using the image-editing buttons” section below to find out
more about editing web graphics in Dreamweaver.

Adding image borders

By default, images with no links have no borders, but they can have black
borders of any pixel width using HTML markup. Images with links have a
border that takes on the properties of text links. For example, if the default
text link color is blue, a linked image has a blue border.

Although adding an HTML border may seem like a great advantage, the
major drawback to it is that you can’t choose a different border color
through the Properties inspector. (Similar to Henry Ford and his Model-T:
“You can buy it in any color, as long as it’s black.”) Technically, the border
color can be the same color as surrounding text color, so you could control
the border color with the old <font> tag if for some reason you don’t want
to use CSS, as in the following example:

<p><font color="#CC0066">This text is pink, which means the image will have the
same border color. <img src="images/logo.gif" width="192" height="201"
border="1"></font></p>

The major browsers don’t consistently support this method, so be sure to
test it if you intend to use it.

Although you could add a simple HTML border on your images by entering a
number for the width of the border in the Border field in the Properties
inspector, a better method is to create a custom CSS style. CSS borders can
be any color or thickness, one of a handful of different styles, and applied to
any or all of the image’s four sides. Turn to Book IIl, Chapter 1 to redefine
tags and create custom styles in Cascading Style Sheets.

Providing Alternate text

When accessibility features are enabled in Dreamweaver’s Preferences, you
can add accessibility attributes to your images as you insert them onto your
pages. However, when the accessibility features are disabled, be sure to
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Figure 3-6:
Image
alignment
options.

add these attributes manually to your images through the Properties inspec-
tor before publishing the Web site. The two most important accessibility
attributes for images are Alternate text and a Long Description. Alternate
text, or Alt text, is useful for site visitors who use text-only browsers, have
their browsers set to manually download images, or use speech synthesizer
software to read the descriptions of the image. In some browsers, Alt text
appears in place of the images when images are downloading and when the
mouse pointer hovers over an image. Furthermore, some search engines use
Alt text to help determine site ranking by presuming the words used in Alt
text are more relevant and important than text found in <meta> tags.

You can make Alt text as brief as one word or as long as a paragraph, though
you should enter a complete, meaningful sentence rather than a list of key-
words. If you want to provide a longer description for your image, you can
also include a Long Description attribute that links to a separate Web page
containing the longer description. The code for an image with both Alternate
text and a Long Description looks something like this:

<img src="images/brooklynbridge.jpg" alt="The Brooklyn Bridge" width="400"
height="300" border="10" longdesc="bridge.html" />

Aligning images

You can align selected images in two different ways, one using HTML
markup, and the other using CSS, which is the more modern, standards-
compliant, W3C (World Wide Web Consortium) recommended practice.

4+ HTML: Wrap elements — such as text — around the image: Select an
option from the Properties inspector Align drop-down list (shown in
Figure 3-6). When no alignment is specified, the default alignment is Left.
This alignment method adds the align attribute to the <img> tag.

4+ CSS: Make images float to the left or right of text or other objects on
the page: Apply a custom style to an image by selecting the style by
name from the Class drop-down list (shown in Figure 3-6).

Defaulk
ly|Baseline
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iddle
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Ahsolute Middle
Absolute Bottom
Left
Border Right %

Align | Left £

Al

Edit

With CSS, each style can have multiple properties, or rules. For example, you
can create a style that adds a 1-pixel border, 5 pixels of padding, and right
alignment to an image:
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<style type="text/css">
<!--
.alignright {
padding: 5px;
border: 1lpx solid #000033;
clear: right;
float: right;
}

-=>
</style>

Using the image-editing buttons

Dreamweaver has seven tools for editing images without the need to launch
an external image editor. You can use these editing tools on any GIF or JPEG
file inserted on a page. The following seven image-editing tools are located
under the Alt field in the Properties inspector whenever you select an image
on a page in Design or Code view (refer to Figure 3-5):

4+ Edit: Launches the default image-editing program. Specify an image
editor in the File Types/Editors category of the Preferences dialog
box. Choose Edit=>Preferences (Windows) or Dreamweaverw>
Preferences (Mac).

4+ Edit Image Settings: Launches the Image Preview dialog box, inside
which you can make several simple adjustments to the selected
image. The dialog box has two tabs, Options and File. In the Options
tab, you can adjust the image format and quality; add image smoothing,
progressive browser display, and sharpening color edges; set a matte
color; remove unused colors, crop down the image, and view RGB
values for the image showing in the preview window. Essentially, the
dialog box works like a mini Web graphics optimization program. In the
File tab, you can adjust the image scale and export area.

4+ Update from Original: When the original file that was used to create the
optimized graphic is specified in the original field of the Properties
inspector, you can click this button to make adjustments to the selected
image using the original source file instead of the optimized graphic.

4+ Crop: Allows you to crop the graphic. Clicking this button opens an alert
dialog box that warns you about the permanence of any changes you
make. Click OK in the alert dialog box to continue. Cropping handles
then appear around the image that allow you to crop the image. Press
Enter (Windows) or Return (Mac) to accept the cropping.

4+ Resample: Allows you to resample a resized image to improve the qual-
ity of the image at the new size. This feature appears only after you
resize an image. Try, though, to keep resampling to a minimum (espe-
cially resampling up) as this process can degrade the quality of the
image. If you really need a graphic at a different size, create a new
graphic in an image-editing program.
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4+ Brightness/Contrast: Allows you to adjust the brightness and contrast of
the image. Like the Crop tool, clicking the Brightness/Contrast button
opens an alert dialog box that warns you about the permanence of any
changes you make to the image. Click OK in the dialog box to continue
and a Brightness/Contrast dialog box appears. Move the sliders in the
dialog box to the left or the right to increase or decrease the brightness
and contrast. Click OK to accept the new settings or Cancel to close the
Brightness/Contrast dialog box without changes.

4+ Sharpen: Adjusts the overall image contrast and edge pixel clarity.
The Sharpening dialog box uses a sliding scale of 0-10 to adjust the
image sharpness; the higher the number, the more intense the image’s
definition or sharpness.

Creating Interactive Images
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Besides inserting the occasional static graphic here and there on a Web
page, Dreamweaver greatly simplifies the process of adding interactive
image options on a Web page, including creating rollover images, image
maps, and navigation bars, and adding Fireworks HTML to an existing
Web page.

The following sections discuss these interactive techniques. All the
interactive image buttons are accessible from the Common category of the
Insert panel, as shown in Figure 3-7.

Image button

INSERT [§

Adding rollover images

Rollover images are graphics that change to a different image in a browser
window when a visitor moves the mouse over the image. To make a rollover
button, you need two graphics — one for the normal state and one for the
over state — that are exactly the same pixel width and height but that look
different enough that a visitor will notice the rollover effect.
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Dreamweaver lets you create rollover images by inserting JavaScript into the
code that tells a browser to display one image for the normal state and
another image for the mouseover state.

Before creating your rollover images in Dreamweaver, optimize the graphics
for both normal and rollover states and place, give them similar names, such
as nav01.gif and nav01l-over.gif, and save them in an images folder at the root
level of your managed site. Make sure both images have the same image
dimensions in pixels so that the over state image does not get distorted
during mouseover.

To create rollover images, follow these steps:

1.

Place the insertion point in the Document window where you want
the rollover image to go.

The spot you click in the Document window is where the rollover image
will appear on the page.

Click the Image button in the Common category of the Insert
panel and choose Rollover Image from its drop-down list (refer
to Figure 3-7).

Or choose Insert>Image Objects>Rollover Image.
The Insert Rollover Image dialog box opens, as shown in Figure 3-8.

Enter an image name, browse to and select the graphics to use for
both the original and rollover images, add Alternate text, and a
filename or URL for a link to another file.

By default, the Preload Rollover Image option is enabled. This option
adds JavaScript to the page that tells the browser to preload this
graphic into the browser’s cache as the page is loading. When this
happens, the over state graphic is ready to appear by the time a visitor
places the mouse on the rollover graphic’s normal state.

Click OK.

Dreamweaver inserts the original image and writes all the JavaScript
necessary to perform the rollover function. JavaScript is attached to the
<img>, <head>, and <body> tags.

Insert Rollover Image
Image name: | conkact
Original image: | imagesfcontact.gif
Rallover image: | imagesfcontact-over.gif
Preload rollover image
Alrernate kext: | Contact Us
“hen clicked, Go ko URL: | contact. html
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To preview or test JavaScript behaviors in Design view, click the Live View
button on the Document toolbar, or choose File=>Preview in Browser to test
the rollover effect in a browser. You can tell the rollover effect is working
properly by positioning the mouse over the rollover button.

Creating image maps

An image map is an image that has shaped regions or hotspots defined

by pixel coordinates in the code that can have a behavior (such as a hyper-
link) assigned to it. When a visitor clicks the hotspot, an action occurs

(for example, another page opens). Hotspots can be rectangular, oval, or
polygonal in shape. The following example shows how image maps are
defined in the code for a hotspot in the shape of a circle:

<img src="images/logo.gif" width="192" height="201" border="1"
usemap="#Mapl"><map name="Mapl" id="Mapl"><area shape="circle"
coords="97,98,75" href="#">

Images can have multiple hotspots as well as multiple behaviors assigned to
a hotspot. For instance, you may have a photograph of a map of the United
States and want to turn each state’s shape into a unique hotspot linking to
information elsewhere on the site specific to that state. (See Book IV,
Chapter 2 for more on behaviors.)

You can draw hotspots on a selected image using the Rectangular Hotspot,
Oval Hotspot, and Polygon Hotspot tools in the Properties inspector beneath
the image thumbnail (refer to Figure 3-5). You can adjust the hotspot border
with another tool, the Pointer Hotspot.

Here’s how to create a hotspot on a graphic:

1. Select the image in Design view.

By selecting the image in Design view, you activate the image hotspot
options in the Properties inspector.

2. In the Properties inspector, enter a name for the image map in the
Map field.

If unspecified, image maps get assigned a default name such as Map1,
Map2, Map3, and so on. If creating multiple image maps in the same
document, definitely use separate map names for each.

3. Select a hotspot tool and draw a hotspot shape on the image:

¢ Rectangular: Drag and release the mouse to create an enclosed
rectangular shape.

¢ Oval: Drag and release the mouse to create an enclosed oval shape.

¢ Polygon: Create a non-uniform polygonal shape by selecting this tool
and clicking the image multiple times to insert anchor points for the
hotspot shape. Click the pointer tool to finish the shape.
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Create
image map
hotspots
with the
hotspot
tools and
assign
behaviors to
hotspots.

Creating Interactive Images 107

To select these hotspot tools, click one of the buttons in the bottom-left
corner of the Properties inspector (see Figure 3-9).

Use the Pointer Hotspot tool to select the hotspot and assign 1ink,
target, and alt attributes.

When the hotspot is selected, the Properties inspector displays fields
for assigning a link, link target, and Alternate text to the hotspot. You
can also adjust the anchor points of the hotspot shape with the Pointer
Hotspot tool.

Deselect the hotspot and/or image by clicking away from the image
with the Pointer Hotspot tool in Design view.

Figure 3-9 shows an image with a hotspot.

To continue adding hotspots on the same image, select another
hotspot tool and repeat Steps 2 through 5.
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Inserting a navigation bar with images

Creating a simple vertical or horizontal navigation bar in Dreamweaver has
never been easier. From the Insert Navigation Bar dialog box (Insert=>Image
Objects>Navigation Bar), you can specify and organize all the nav bar
elements at the same time.

Follow these steps to create and insert a navigation bar with images:

1. Click the Image button in the Common category of the Insert
panel and choose Navigation Bar from its drop-down list (refer
to Figure 3-7).
Or choose Insert~>Image Objects>Navigation Bar.
The Insert Navigation Bar dialog box opens, as shown in Figure 3-10.
Insert ion Bar
#= i
Nav bar elemerts: [inmamedl
Figure 3-10:
Create a O
custom Up miage:
graphic ()
navigation S i
bar with Alternate text:
the Insert when clicked, Go to LRL: in [ Man window ¥
. . options: (/] Preload images
Nawgatlon [ Show "Down image” nitially
Bar dlaloQ Insert: | Horizontally v Use tables
box.
2. For the first rollover graphic on the navigation bar, enter the

following information:
¢ Element Name: Enter the name of the button.

¢ Up Image: Select an image for the button’s normal up (nonclicked)
state.

¢ Over Image: Select an image for the button’s mouseover state.

¢ Down Image (optional): Select an image for the button’s down state,
which appears when a visitor clicks the button.

e Alternate Text: Enter a text description for the button, such as
About Us or Contact us for more information. Alternate text
displays as the images are downloading and is read aloud by any
screen-reader software used by the visually impaired. It may also
appear in some browsers as pop-up text when the cursor is placed
over the graphic.
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e When Clicked, Go to URL: Select the page that is the target of the
button.

3. Select any other options you need.

4. To add additional rollover buttons to the navigation bar, click the Add
Item (+) button and repeat Steps 1 through 3.

5. To remove a button from the navigation bar, click the Remove Item (-)
button.

6. To reorder the navigation bar elements, select a button name from the
Nav Bar Elements listing and click the Move Item Up In List and Move

Item Down In List arrows to reposition the element in the list. e

7. When you're satisfied with the navigation bar, click OK. Chapter 3

Dreamweaver inserts the new navigation bar (see Figure 3-11) and all
attending JavaScript. The navigation bar, essentially, is a single row or
column table with a series of hyperlinking rollover buttons in each cell.

Navigation bar

saiydesg Buipasu)

| DESIGNER v | — & x

EN_ File Edit Wiew Insert Modify Format | Commands  Site  Window  Help

navbar.him [}

Lua|cade ‘j spl g Desian ||| £ Live View |v |

Title: | Untitled Docum

Common ¥ W =&
EFEs-4 BH
0 - - |[B- &

ABOUT ‘ RE&GHRCES! CONTACT |

[y 52 <body onload= ~ (JESSSTRABEIE 1a6 inspecToR [Ie]
< "M preloadnages (' inages/nav_0l-over.gif','inages/nav_02-over.gif','inages/nav_03-over.gif')"> Adrbutes | Behavies | Tsg <img>
60 <table horder="0" cellpadding="0" cellsparing="0">
~ 61 Lerx { - - -
) 2 <td»<a href="ebout,html” target="_top” onclick="M nbGroup('dom’, 'groupl', 'shout!,',1)" ehvoncick  Z3 et Nav Bar Image
o onmousenver="MM_nhGroup('over', 'ahout','images/nav_0l-over.gif','',1)" ormouseouts= <A> onMouseOLE &3 Set Nav Bar Inage
E "M nbGroup | 'out')"><ing sre="images/nav 0l.gif"” alt="About” neme="shout” width="62" height="24" <A> onouse... 5 Set Nav Bar Image
* border="0" id="about” onloads="" e/ Tl
53 <td»<a href="resources.htal” targec="_top” onclicks
<« MM _nbGroup | 'dowm', 'groupl', 'resources','',1)" onmousenwvers

! nbGroup ('over','resources','images/nav_0Z-over.gif','',1)" onmouseo
/mav_02 " a "Resources” name="resources” widrh="83" heigh!

Group{'out!)"><ing

1o Faes [ |

" harder="0"

Figure 3-11: z

ces” o - st ———
o tds<a hr ontact.html”™ target="_top” onclick="MM nbGroup('dewn', groupl','contact','',1)" E!Dw_cs4_ |se| |Local view v |
Create i ormousenver ="M _nhGroup( 'over','contact','inages/nav_03-over.gif','',1}" onuouseouts [P ‘ 0@ o | =
. ] “MM nbGroup [ out')"><ing src="images/nav_03.gif"” alt="COBTACt” name="CONtact” width="73" height= = S
horizontal "24" border="0" id="contact” onload="" /5</av</td> el [ size[Typ
0| 65 P |23 site- oW cS4(CDo... Folde
or vertical 66  </tables images Folde
67  </hody> L = about.hkrl 2KE Firef
L:3 </htul> |n bzed.html SKE Firef
navigation y
. = imagemap html 1KE Firef
ba rs W|th <bady> stable> <tr> <td> <a> <imo#resources>| | & |§7% G [100% 777 x 128+ 5K/ 1 sec| Unicode (UTF-3) | index.html 1KB Firef
PROPERTIES |} = MywordFile. doc 20KE Micrc
your own ey mags, 1K g an Stc imageshav_Uz.af €35 Al | Resources [v]  Closs|mbone  [w @ Wt ) bAred
= o = E{) b testess 1KB Casc.
custom ID|resowees || H|24 Lk resources htmi oo P P
W Space Target | _top | Border [0 NE O A

raphics. £ — ]
grapnics X OO  Hspas Oriary £ Al |Dofaut v - @ Featy




110 Creating Interactive Images

\\3

Figure 3-12:
Insert
Fireworks
HTML.

Only one navigation bar can exist at a time on any one page, but it can be
modified if you need to add, edit, or remove a rollover button. To make
adjustments to an existing navigation bar, do one of the following to open
the Modify Navigation Bar dialog box:

4+ Click the Navigation Bar button on the Common area of the Insert panel.

4+ Select the navigation bar in the Document window and choose
Modify=>Navigation Bar.

Inserting Fireworks HTML

Fireworks lets you create, slice, and optimize images for the Web, and
because it’s an Adobe program, it integrates beautifully with Dreamweaver.
One of the main things you can do with Fireworks is create a page layout and
then export the file as an HTML page including images and rollover effects.
After you export the file, you can import it into Dreamweaver. Dreamweaver
lets you quickly add design elements, such as animated rollovers, pop-up
menus, and other images, generated by Fireworks into an open document.
Fireworks has an export command that lets you specify which Dreamweaver
managed site folder to place the code into so you can easily import the code
into Dreamweaver when you're ready.

To import Fireworks content into an open Dreamweaver document, follow
these steps:

1. Click in the page to place the insertion point where you want to add
the Fireworks HTML.

2. Click the Image button in the Common category of the Insert panel
and choose Fireworks HTML from its drop-down list (refer to
Figure 3-7).

You can also choose Inserte>Interactive Images=>Fireworks HTML.
The Insert Fireworks HTML dialog box opens, as shown in Figure 3-12.
3. Browse to and select the Fireworks HTML file that you want to import.

To have Dreamweaver delete the Fireworks HTML after inserting it on
your page, click the Delete File After Insertion check box.

Insert Fireworks HTML

. e
Fireworks HTML file: Browse...
Cancel

Options: ] pelste file after insertion
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4. Click OK.

Dreamweaver imports the HTML, graphics, and any associated
JavaScript to support rollover effects and other interactivity.

For more on using Dreamweaver with Fireworks, see Book III, Chapter 5.
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Chapter h: Making Links with Text
and Images

In This Chapter

»» Making links with text

+* Making links with images

1 Creating e-mail links

v Editing and deleting links

+ Hand-coding with the Tag Chooser

LVeb pages become a Web site when they are joined together by
hyperlinks. Hyperlinks (often called just links) convert nearly any

content — including text or graphics — into clickable pointers that lead the
site visitor through other pages on a site, winding through text and graphics
along the way.

Links can point to another Web page on the same site, another page on a
different Web site, a section of the same or another page, PDF, Word or
PowerPoint document, graphic, sound file, movie, Zip or SIT file, or down-
loadable software. They can open a blank e-mail message with the recipi-
ent’s address already in place, or they can be temporary placeholders for
behaviors and scripts to attach to.

You can add, edit, or remove links from a page at any stage of the site build-
ing process. Though they look like working links inside of the Dreamweaver
Document window, they don’t work when you click them there, so be sure to
launch a browser window by pressing F12 (Window) or Option+F12 (Mac) or
click the Live View button to test the functionality and accuracy of your links.

This chapter takes an in-depth look at the different kinds of links that you
can create in Dreamweaver.
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Understanding Hyperlinks

Figure 4-1:
The
Properties
inspector
helps you
add links.

You can create four types of hyperlinks in Dreamweaver:

4+ Regular: Links pages together by converting content, including text and
graphics, into hyperlinks.

4+ E-mail: Launches a computer’s default e-mail program and prompts the
site visitor to send e-mail to the e-mail address in the link.

4+ Named anchor: Takes the site visitor to a link location embedded on
the same page as the link or to an anchor link location embedded on
another page.

4 Temporary: There are two kinds of temporary links, called null and
script links that convert selected content into undefined links for adding
detailed link information or behaviors at a later time.

Before adding links, be sure you understand the difference between
document-relative, absolute, and site root-relative paths as the link syntax
varies slightly depending on the path type. Turn to Book I, Chapter 3 for a
general discussion about paths.

One of the fastest ways to add links to your page is to select some text,
graphic, or object on the page and enter the link information in the Link
field in the Properties inspector. Type the link by entering the filename or
full URL, including http: // and the file extension. After you enter the link,
the Target field becomes activated. Then, you can select a target for the link
(see the “Setting Link Targets” section in this chapter).

In the HTML view of the Properties inspector, there are two buttons (shown
in Figure 4-1) to the right of the Link text that also allow you to add links to
any selected text, graphic, or object on the page. Both methods are faster
and more accurate (since there’s no typing involved) ways of linking files:

Link field Point to File

Link. f {’3 E|]

Targek

Target field Folder

4+ Folder: Click the folder button to open the Select File dialog box.
Browse to and select the file you want to link to, and then click OK and
Dreamweaver writes the link of the filename into the Link field. Enter any
target information in the Target field.
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4+ Point to File: Click this button and drag the pointer icon to a file listed
in the Files panel. Release the mouse when the cursor is on top of the
desired file and Dreamweaver writes the link of the filename into the
Link field. Enter your target information in the Target field. The Point to
File button also works for selecting named anchors on a page.

“&N\BEH
& To test a link, you must launch a browser window. Here’s how to open a
browser to test your link:

4+ To preview an open page, press F12 (Windows) or Option+F12 (Mac)
to launch your primary browser or press Control+F12 (Windows) or
Command+F12 (Mac) to launch your secondary browser (see Book V,
Chapter 1 to specify a primary and secondary browser). The currently
open document opens in a browser window.

Book Il
Chapter 4

4+ To preview a file listed in the Files panel, right-click (Windows) or
Control+click (Mac) the file, choose Preview in Browser, and choose the
browser type from the list.

To open a locally linked file inside Dreamweaver, either highlight the link in
the Dreamweaver document window and choose Modify=>Open Linked Page,
or press Ctrl (Windows) or 38 (Mac) and double-click the link to open the
linked document in Dreamweaver’s Document window.

safew| pue )xa|
yum syury bunjey

All links use the <a> tag plus one or two different attributes to convert
selected text or graphics into links. The next few sections give separate
descriptions and examples of the four link types.

Creating Text Links

You can create text links from a word, phrase, sentence, paragraph, or even
an entire page worth of text. The link code surrounds a selection of text and
converts it into a clickable hyperlink. Text links use the <a> tag with the
href attribute. The href attribute stands for Hypertext REFerence, and the
attribute points either to a file at the root level of the defined site or to an
external Web page by including the http:// and full path to that page. The
target attributes, which tell the browser whether to open the link in the
same or another browser window, also go inside the opening <a> tag.

This example link opens the Google home page in a new window:
<a href="http://www.google.com" target="_blank">Search on Google</a>

This example opens an About page in the same browser window:

<a href="about.html" target="_self">About Us</a>
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Figure 4-2:
Complete
these fields
to create

a text
hyperlink.

To create a text link, follow these steps:

1. Choose Insert=>Hyperlink or click the Hyperlink button on the
Common category of the Insert panel, which looks like a chain link.

The Hyperlink dialog box opens, as shown in Figure 4-2.

Hyperlink

Texk:

Link:
Target:
Title:
Access key:
Tab indes:

Co]
ma
.

2. Enter the following information in the dialog box:

Text: Enter the text you want to make into a link, such as Learn More
or Contact Us.

Link: Type the path and filename of the linked page. If the linked
page is on the same site, enter only the filename, such as contact.
html. However, if the linked page is external to the current site, enter
the full URL including the http://, as in http://www.dummies.com.

Target: By default, linked pages automatically open in the same
browser window. To override this setting, select _blank to have
the link open in a different browser window. See the “Setting Link
Targets” section for more about other target settings.

Title: Add a description for the link. The title appears as a tool tip
in some browsers when a visitor mouses over the link. In addition,
it can both improve visitor accessibility and assist in better search
engine indexing and ranking.

Access Key: Add a one-letter keyboard equivalent that the visitor can
use in combination with the Tab key to select the link in the browser.
Once selected, the visitor can press Enter (Windows) or Return
(Mac) to visit that linked page.

Tab Index: Add a number for the tab order of this link, relative to
other links on the page. The tab order, which defines the order of
accessible elements on a page using the Tab key, begins at the top
of the browser window and moves downward from left to right, as
when reading a book.
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3. Click OK.

Dreamweaver adds the link to the page.

Making Image Links

WMBER
@&
&

Image links work the same way text links do, but instead of surrounding text,
the link code surrounds an image.

Here’s an example of a link to visit Google using a GIF file:

<a href="http://www.google.com" target="_blank"><img src="images/googlelogo.
gif"></a>

Here’s an example of a link to a page at the root level of a defined site using
an About Us graphic:

<a href="about.html"><img src="images/aboutus.gif"></a>

To create an image link, select the image on the page in Design view and
type the filename or path of the linked page into the Link field in the
Properties inspector. If desired, add a link target to define where the linked
page will open.

When you add a link to an image, the borders around the image become
hyperlinks. To remove the link border from your linked image, set the
border property on the Properties Inspector to 0.

You can also create an image link the same way you create a text link. See
the previous section to find out how to do so.

Inserting E-Mail Links

E-mail links, when clicked in a browser window, tell the site visitor’s com-
puter to launch the computer’s default e-mail program, open a blank e-mail
message window, and populate the Send To field with the e-mail address in
the link. E-mail links use the <a> tag with the href attribute just like text
links do, but instead of listing the // before the filename, an e-mail link uses
themailto: attribute before the e-mail address (mailto: is a URL just like
http:// is), like this:

<a href="mailto:me@example.com">me@example.com</a>

Book Il
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To create a standard HTML e-mail link, follow these steps:

1. Choose Insert->E-mail Link to launch the E-mail Link dialog box.

Or, in the Common category of the Insert panel, click the E-mail Link
button, which looks like an envelope.

In the Text field, enter the text that will appear in the browser

window as linked text, such as Contact Us or contact@company.com.
In the E-Mail field, enter the e-mail address for the link, such as

contact@company.com.

3. Click OK.

Dreamweaver writes the e-mail link code into the page.

Adding an e-mail address to a Web page using this type of HTML e-mail link

makes the e-mail address vulnerable to spam bots and spam spiders that
crawl the Web in search of anything that has the me@example. com format
or for links containing the mailto: attribute. For encryption ideas, check
out the nearby sidebar “Encrypting e-mail addresses” or search online to
find more about e-mail encryption.

Encrypting e-mail addresses

E-mail addresses are very vulnerable to being
harvested by spam-gathering software and
then sold to zillions of spam lists. To better pro-
tect your e-mail address, encrypt your e-mail
address or use some other form of hiding the
e-mail address so it can't be electronically har-
vested or easily obtained.

Try these suggestions for hiding or encrypting
e-mail links on Web pages:

e Encrypt your e-mail address with a
JavaScript encryption software applica-
tion. Several freeware and shareware ver-
sions are available, including Email Riddler
at www.dynamicdrive.com/email
riddler/; do asearch for Email Address
Encryptor to find others.

¢ Enter your e-mail address in Code view
using URL code entities for all the special
characters. For example, me@example.
com becomes me%40example%2Ecom.

Visit the W3Schools Web site (www .
w3schools.com/tags/ref_
urlencode. asp)to convert your e-mail
address into URL unicode.

Include your e-mail address on the page but
don't turn it into a link. Your e-mail address
is still vulnerable, but less so than as a stan-
dard e-mail link.

For a great article about e-mail harvesters and
the countermeasures you can take to fight
them, read Tim Williams's take on e-mail at
www.U.arizona.edu/~trw/spam/
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Creating Named Anchor Links

Named anchor links are great for creating links that jump to another location
on the same page, or to a specific part of another page within the same web-
site. Use named anchor links for FAQ lists, Table of Contents, Indexes, Back

to Top links, and other page elements where internal linking would be useful.

Creating a named anchor requires two steps:

1. Lay down and name the anchor in the spot you want to link to.

2. Make a link that points to the named anchor you just laid down. Book i
00

Say you have a page with two FAQs and you want to list the questions at the )

top of the page and the answers in sequence below the questions. The text
on your page may look something like this:
1. Question

2. Question
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1st Question Answer
Answer to question. Answer to question. Answer to question. Answer to
question. Answer to question.

2nd Question Answer
Answer to question. Answer to question. Answer to question. Answer to
question. Answer to question.

To link each question to its answer, you create a named anchor right before
each answer and then link to it. This type of link is called a named anchor
because it uses the name attribute of the <a> tag. You'll notice, however,
that the code for named anchors includes both name and id attributes:

<a name="Q1l" id="Ql"></a>

The name and id attributes have the same values so that they share the
same domain value space, which means you could use either one when spec-
ifying the link to the anchor. For example, you can create an anchor using
the name attribute, as the following example shows:

<a name="Q1">1st Question Answer</a>

or turn another element into an anchor using the 14 attribute, as this exam-
ple shows:

<hl id="Q1">1st Question Answer</hl>

Once the anchor is laid down, the link to the anchor is the same:

<a href="#Q1">Go to question 1 answer </a>
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Dreamweaver tries to simplify the process by including both name and id
attributes in the code whenever you create a named anchor.

The following sections cover the two-step process for creating a named
anchor.

Step 1: Lay down the named anchor

Remember to create your page with all the text before creating the named
anchors. Then lay down your anchors at each of the destination points. For
example, in a FAQ list, you want to place the anchors right before the text
for each answer in the list.

To lay down a named anchor, follow these steps:

1. Click the Named Anchor button, which looks like a golden anchor,
in the Common category of the Insert panel or choose Insertz=>Named
Anchor.

The Named Anchor dialog box appears, as shown in Figure 4-3.

Figure 4-3: Named Anchor
The Named | ancher name:
Anchor
dialog box.
2. Enter a name for your anchor and click OK.
Try not to use any spaces or funny characters in your anchor names,
and do not put any anchors inside a layer.
In Design view, your named anchor displays as a little yellow invisible
element to mark where the named anchor sits in the code.
<P If you don’t see the invisible element in Design view, be sure the

Invisible Elements Visual Aids option is enabled in the Document
window and that the invisible elements in the Preferences dialog box
are set to show named anchors. To see visual aids, choose View>Visual
Aids=>Invisible Elements.

Step 2: Link to the named anchor

Creating the link to the named anchor uses the href attribute just like stan-
dard text and image links, but it has one unique twist: Instead of linking to a
filename or URL, the link name attribute is preceded by a number symbol (#)
to tell the browser to look for the named anchor on the same page, like this:

<p><a href="#Q1">1. Question</a></p>
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To create a link to a named anchor, do one of the following:

4 Select the text that will become the link, and in the Link field of the
Properties inspector, type the number symbol (#) followed by the
anchor name, as in #Q1. Alternately, you can use the Point to File fea-
ture in the Properties Inspector to point to the named anchor.

4 Select the text that will become the link, and choose Insert=>Hyperlink,
which opens the Hyperlink dialog box (refer to Figure 4-2), from which
you can select the named anchor from the Link drop-down list. (See the
previous section “Creating Text Links” for details.)

<P You can also use named anchor links when linking from one page to another
by typing the number symbol (#) followed by the anchor name after the
name of the file being linked to. For example, if you want a visitor to click a
link in one page and go right to a particular section of another page, your
link may look something like this:

<a href="contact.html#wholesale">Learn more about Wholesale Pricing</a>

In this example, the visitor is taken to a named anchor destination called
wholesale within the page called contact.html.

Creating Temporary Links

The most common types of links are the links you create to other files and
named anchors, but you can add other link types to a page:

4 Script: These links call JavaScript functions or run JavaScript code to
provide information to the site visitor without having to leave the page,
such as when a JavaScript alert box opens. JavaScript links can also do
other page processing duties, such as form validation, when the visitor
interacts in some way with the page, like clicking a particular button.
For an excellent tutorial on JavaScript, go to www.w3schools.com/js/
default.asp.

4 Null: These empty links don’t go anywhere but still treat the text or
object like a link. Once created, you can use null links to attach behav-
iors to the text and objects on the page. (You can find more about
behaviors in Book IV, Chapter 2.)

To create a script link, follow these steps:

1. Select the text, graphic, or object in Design view.

2. Enter javascript: (the word javascript followed by a colon) into the
Link field in the Properties inspector, followed by a JavaScript or
function call.
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For instance, to create a JavaScript link that closes the currently open
browser window, type the following text in the Link field:

javascript:parent.close() ;

The script for the link appears in the code like this:

This is a <a href="javascript:parent.close();">Close</a> link.

where the JavaScript code appears between double quote marks as a
value of the href attribute. If you need to include double quote marks
as part of your script, be sure to add escape marks before your double
quotes, as \"This link goes to the home page\".

To create a null link, do one of the following:

4+ Select the text, graphic, or object in Design view and enter javascript:;
(the word javascript followed by a colon, followed by a semicolon) into
the Link field in the Properties inspector.

4 Select the text or graphic and enter a number symbol (#) in the Link
field in the Properties inspector.

Some browsers jump to the top of the page when a number sign is used as a
null link; therefore, the JavaScript null link is preferred.

Whenever you're ready to convert the temporary link into a permanent link,
replace the temporary link with the appropriate filename or URL.

Setting Link Targets

After adding a link to text or a graphic, you can assign a target in the Target
field of the Properties inspector. The target defines where the linked file
opens, whether in a specific frame of a frameset, the same browser window,
or a new browser window. When unspecified, the linked page typically
opens in the same browser window. For further details see the Setting Text
Properties with the Properties Inspector section in Book II, Chapter 2.

Editing and Deleting Links

Links aren’t set in stone after you create them; you can edit and even delete
them at any time you see fit. You can even edit all instances of a single link
used on several pages of your site at the same time.



Figure 4-4:
The Change
Link
Sitewide
dialog box.
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Editing links
To edit a link after inserting it into your page, select the link — whether it’s a
text, graphic, or object link — and then do either of the following:

4+ Edit or replace the link text using the Property inspector.
4+ Choose Modify=>Change Link. The Select File dialog box opens, allowing

you to search for and select another file for the link.

Dreamweaver has a great feature that allows you to change a link through-
out an entire managed site (for instance, change the August newsletter link
to a September newsletter link). To do this, follow these steps:

1. Select a file in the Files panel and then choose Site<>Change Link
Sitewide.

The Change Link Sitewide dialog box opens, as shown in Figure 4-4, with
the filename you selected in the Change All Links To box.

Chanye Link Sitewide (Site - DW CS4)

Change all links ko: “
faugust. kel

D
Inita links to:
o

Iseptember. html

2. Enter the new filename in the Into Links To box and click OK.

The Update Files dialog box appears showing a list of files that will be
changed.

3. Click the Update button to convert all those links in the site. Click the
Don’t Update button if you change your mind.

Deleting links

To delete an existing link, do one of the following:
4+ Select the link text, graphic, or object and remove the link attributes
from the Link field in the Properties inspector.
4+ Select the link text, graphic, or object and choose Modify=>Remove Link.

4+ Delete the opening and closing link tag code by hand in Code view.

Book 11
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Using the Tag Chooser

Figure 4-5:
Find and
insert
specific
markup
language
tags with
the Tag
Chooser
dialog box.

The Tag Chooser is a special place you can go to find and insert tags on your
page. The Tag Chooser bills itself as “A collection of Markup Language Tags.”
That’s because, in addition to all the HTML tags, the Tag Chooser contains
tags for several other markup languages including CFML, ASP, JSP, ASP.NET,
PHP, and WML. You'll learn more about how to use these correctly in Books
VII, VIII, and IX.

What’s more, each language is housed in its own tag library folder and has its
tags categorized into logical subfolders to help you find the right tag. For exam-
ple, if you're looking for a tag to add an iframe, or inline frame, to your page,
you’d open the HTML Tags Language folder, and search for the tag in the Page
Elements category, as shown in Figure 4-5. When you select a tag in the panel
on the right side of the dialog box, the Tag Info panel at the bottom of the dialog
box reveals tag reference information such as syntax and tag usage.

8w Tag Chooser
E I3 Markup Language Tags ™| |la |

[ applet r
=} J HTML tags ares

[# B3 Page Camposition basound

= ‘B3 Page Elements embed

[ B2 Farmatting and Layaut | | (T

W3 Formatting and Layou frame

[+~ Lists img

[#--B8 Forms mailo

[¥-M2 Tables Mk,

- ME  Scripting QSE‘E‘;EE
FH-I3) CFML tags param (Applet) '
DF=  ASD NET bane ™| |lparam fobiect) o

[=___Taglnte s

<IFRAME> _

<IFRAME. . . </ IFRAME> HTM
An ifzame element creates an inline frame within the natural flow of a docur
frame iz a rectangular space into which you may load any other HTML docur
dynamically write content to the space). If you assian a value to the name at
elernent, you may supply that name 25 the value of a tazges sttribute of a,
elernent that lets you define a target for s destination or returned docurner|¥

< i >

To use the Tag Chooser, follow these steps:

1. Choose Insert=>Tag.

The Tag Chooser dialog box opens, as shown in Figure 4-5. This dialog
box provides access to all the tags in a variety of markup languages.

2. Select the language folder you want to use in the left pane of the

dialog box and navigate to that folder’s subcategories to find the type
of tag to insert.

Expand folders as needed to narrow down the tag search.



Figure 4-6:
Enter tag
details in
the Tag
Editor.

3.
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Search the right pane for the specific tag you want to insert.

Tags in each subcategory are listed in the right pane of the dialog box,
and descriptions for each tag appear in the bottom panel of the dialog
box, below the button that says Tag Info. If you don’t see the description
panel, click the Tag Info button so that it’s arrow points downward.

To insert a tag on your page, select the tag and click the Insert button,
or simply double-click on the tag name.

If the tag is listed in the right pane with angle brackets surrounding it
(such as <u></u>), it’s inserted in your document. All other tags, how-
ever, need additional information.

If the tag needs more information, the Tag Editor dialog box opens.
Figure 4-6 shows an example of the Tag editor set to insert properties for
the <iframe> tag.

Tay Editor - iframe

General iframe - General
Browser Specific

Style Sheet/Accessibility
Source: Browse. ..
Alternate Content ‘:]

Mame:
‘width:
Height:
Margin width:
Margin height:
alignment: |&
Scrolling: ;auto (deFau\t.) ~

Show borders

I Taginfo

5.

Enter the tag and attribute details.

The Tag editor is context specific, meaning it displays all the property
fields available for the selected tag. If you're unsure of what to add in
any field, leave it blank for now because you can always edit the tag
through the Properties inspector at a later time.

If the Tag editor displays multiple categories, such as General, Browser
Specific, and Style Sheet/Accessibility, look at those category options
and add any tag attributes as desired.

Click OK in the Tag editor.
The selected tag is inserted onto your page.

To add more tags to your page, repeat Steps 2 through 6. Otherwise,
click the Close button to close the Tag Chooser.
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Coding Links by Hand

If you happen to know the HTML markup syntax, by all means feel free to

hand-code your links. Simply go right into Code view and type away. Just be

sure you remember to close your link tags with the closing </a> tag. Table
4-1 shows examples of the link types.

Table 4-1

Sample Links

Link Type

Link Example

Hyperlink with text, including
target attribute and link to
file on same site

<a href="about.html" target="_
self"> About Us</a>

Hyperlink with text, including
target attribute and full
path of link

<a href="http://www.google.com"
target="_blank">Google</a>

Hyperlink with graphic,
including target attribute
and link to file on same site

<a href="about.html" target="_
self"><img src="images/about.
gif"></a>

Hyperlink with graphic,
including target attribute
and full path of link

<a href="http://www.google.
com" target="_blank"><img src=
"images/google.jpg"></a>

E-mail link

<a href="mailto:me@example.
com">me@example.com</a>

Named anchor

<a name="anchorl"
id="anchorl"></a> (Anchor laid down)
<a href="#anchorl">Go to Anchor
1</a> (Linkto anchor)

Named anchor laid down that
includes a target attribute
and the full path to a link

<a name="anchorl" id="anchorl"
href="http://www.example.
com">Link to the home page</a>




Chapter 5: Adding Flash, Movies,
Sound, and Move

In This Chapter
v Adding Flash SWFs
v~ Adding FlashPaper and Flash Video (FLV)

v~ Inserting Shockwave movies, Java applets, and ActiveX controls

1 Working with Netscape Navigator plug-ins

+ Adding other video and sound

ou've probably seen Web sites that include Flash intros, MPEG videos,
MP3 songs, QuickTime movies, and other various kinds of sound and

video plug-ins. Dreamweaver makes it easy to insert these media clips,
adjust the attributes that determine how the media displays on a Web page,
and, if applicable, change how the user can interact with it.

This chapter shows you how to add Flash, movies, sound, and other media
types to a Web page. You also find a brief discussion about acceptable
sound file formats and the differences between linking and embedding video
and sounds.

Flash Elements You Can Add to Your Web Site

Your basic Flash movie uses the most common SWF file format, but you can
add other Flash elements to your Web pages. Before you begin adding them,
however, you need to understand the subtle differences between the differ-

ent Flash file formats:

<+

<+

fla, or Flash files, are Flash movies. These are the original, editable
source files for creating SWF files.

.swf files (pronounced swiff) are compressed, portable versions of .fla
files that you can preview in Dreamweaver and play in browsers. Flash
buttons and Flash text also use SWF files. These files are not editable as
the original FLA files are.

.swt are Flash template files that allow you to change information in
SWF files. For example, a button created in Flash might use SWT files to
let you generate multiple buttons with different text.
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Adobe’s Dreamweaver Exchange has many button templates available
for download at www.adobe.com/cfusion/exchange/ us. After you
download them from the Web site, save the templates into your com-
puter’s Dreamweaver/Configuration/Flash Objects/Flash Buttons folder.

4+ .swc are Flash element files or special SWF files that make customizable
Rich Internet applications.

4+ flv, or Flash video files, play movies that have encoded audio and video
data that allows the free Flash player to play them. For example, a
Windows Media or QuickTime video could be encoded with special soft-
ware into FLV files for viewing in a Flash player. Flash’s Video Encoder,
which is integrated with Flash (www.adobe . com), and Sorensen Squeeze
(www . sorensonmedia.com) are two recommended encoders. To dis-
cover more about the process of encoding videos, visit www . adobe.
com/devnet/video/.

To add Flash movies, Flash video, and FlashPaper to your site, you must first
create the SWF, FLV, and FlashPaper files in Flash.

Flash is a great tool, but beginners should be aware that it can be misused on
the Web. Before you add Flash movies to your Web site, do a little research to
become aware of both the benefits (animation, sound, interactivity) and the
drawbacks (search engines ignore Flash movies so it’s not good for SEO; many
Web visitors dislike Flash; beginners tend to overuse it) of Flash.

Inserting Flash Movies (SWFs)

Inserting Flash movies into your Web page in Dreamweaver is a simple two-
step process. Before you can insert a Flash movie in Dreamweaver, however,
you must first create the movie in the Flash program and save it as an SWF
file. Check out Adobe Flash For Dummies (Wiley) by Finkelstein and Leete if
you need help preparing your Flash movie.

Adding a Flash movie to your page

To add a Flash movie (SWF) to a Web page, follow these steps:
1. Place your cursor where you want the Flash movie to appear on your
Web page.
2. Choose Insertr>Mediac>Flash.

You can also click the Media button in the Common category of the
Insert panel and select Flash from its drop-down list.

The Select File dialog box opens.

3. Select the Flash SWF movie file you want to insert on the page and
click OK.
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Note: If you enabled Accessibility options in Preferences, the Object Tag
Accessibility Attributes dialog box appears prompting you to add a title,
access (shortcut) key, and tab index number to the SWF file. Enter those
attributes and click OK or click Cancel to add the SWF file without the
Accessibility attributes.

Dreamweaver embeds the movie with all the Flash HTML code needed for
the movie to play in most major browsers by including the <object> tag for
Microsoft ActiveX controls, hidden comments to identify the different parts
of the code, and HTML that prompts visitors using browsers with older ver-
sions of the Flash player to download the current version. The code, as in
the following example, shows how an SWF file called flashsample.swf would
be embedded on a page:

<object id="FlashID" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"

width="550" height="250">

<param name="movie" value="flashsample.swf" />

<!-- Next object tag is for non-IE browsers. So hide it from IE using IECC. -->

<!--[if !IE]>-->

<object type="application/x-shockwave-flash" data="flashsample.swf" width="550"
height="250">
<l--<![endif]-->
<param name="quality" value="high" />
<param name="wmode" value="opaque" />
<param name="swfversion" value="8.0.35.0" />
<!-- This param tag prompts users with Flash Player 6.0 r65 and higher to
download the latest version of Flash Player. Delete it if you don't want

users to see the prompt. -->
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<!-- The browser displays the following alternative content for users with
Flash Player 6.0 and older. -->
<div>

<h4>Content on this page requires a newer version of Adobe Flash Player.</
hd>

<p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.
adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get
Adobe Flash player" width="112" height="33" /></a></p>
</div>
<!--[1if IIE]>-->
</object>
<l--<![endif]-->
</object>
<script type="text/javascript">
<l--
swfobject.registerObject ("FlashID") ;
//==>
</script>

Dreamweaver displays the embedded Flash movie on the page in Design
view as a gray placeholder box with a tabbed blue outline (see Figure 5-1).
The tab displays the file format (swf), file name, and an eye icon that toggles
visibility between the movie and the download information visitors without
Flash installed will see. The Document window doesn’t automatically pre-
view the Flash movie; however, you can preview it both inside and outside of
Dreamweaver.
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To preview the Flash movie, select the Flash movie in Design view and do
one of the following:

4 Click the Play button in the Properties inspector. Click Stop to stop the
preview.

4 Click the Live View button on the Document bar to watch the movie, as you

would in a browser window. Click Live View again to stop the preview.

4+ Press F12 to preview the movie in a browser window.

Setting Flash movie attributes

After inserting the movie onto the page, select the Flash placeholder in
Design view and use the Properties inspector to set the movie attributes.

If you don’t see all the movie properties, click the expander arrow in the

bottom-right corner of the Properties inspector.

4+ Flash ID: Input the movie ID. The default name is FlashID.

4+ Loop: If you check this option, your SWF movie plays continuously in
the browser; leave it unchecked, and your movie plays once and then
stops. Note: If the movie itself contains a loop, it will play continuously
regardless of whether the Loop option is checked or unchecked.
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Autoplay: Starts playing the movie automatically when the page loads in
a browser window. This option is on by default.

W and H: The size should automatically match the size of the movie;
however, you may change it by entering different values here.

V Space and H Space: Set white space in pixels above and below, and on
both sides, left and right, of the movie.

File: Specifies the path of the Flash .swf file. Browse for and select the
file using the folder button, Point to File pointer, or type in the path.

Src: Specifies the location of the original Flash .fla file used to create the
.swf file. Browse for and select the file using the folder button, Point to
File pointer, or type in the path to the desired file.

Quality: This setting deals with anti-aliasing, or smoothing, of the movie
during playback. The higher the setting, the smoother the movie, but
also the potentially slower the movie displays. By contrast, low set-
tings load faster but look less crisp. Auto Low and High options improve
appearance or emphasize quality, respectively.

Scale: Determines how the movie fits into the pixel sizes displayed in
the W and H text boxes:

¢ Default (Show all): The entire movie displays at 100 percent.

¢ No Border: Maintains the original movie dimension aspect ratio but
fits the movie, without borders, into the sizes set in the W and H text
boxes, which means that any parts of the movie that extend beyond
the W and H settings are cut off.

¢ Exact Fit: Squishes the movie into the specified dimensions, regard-
less of the original size of the movie.

4+ Align: Sets the alignment of the movie relative to the page.

4 Wmode: Sets the Wmode for the SWF file in the browser window, which

helps prevent conflicts with DHTML page elements like Spry widget.
Choose from any of the following:

e Window: Forces the SWF on top of all page elements.

¢ Opaque: The default setting, allows DHTML elements to flow on top
of the SWF.

e Transparent: Forces DHTML elements to appear behind the SWF.
This is often a problem when combining Flash with DHTML menus.
If you're menu falls behind the Flash movie, switch the Wmode to
Opaque or Window.

4+ Bg Color: Adds a background color behind the movie. This color dis-

plays only if and when the movie is not playing.
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4+ Edit: Provides access to the source FLA file for the SWF movie when
Flash is loaded on the same computer. If no Flash application is
detected, this button is disabled.

4+ Reset Size: This button only appears next to the W and H fields when
the original size of the SWF file has been modified. Click to revert the
SWF file to its original movie size.

<+

Play/Stop: Starts and stops movie previews within Design view.

4+ Parameters: Opens a dialog box where you can enter more parameters
for the movie if the movie has been created to accept these parameters.

4+ Class: Applies CSS to a movie, such as styles with border, positioning in
the browser, or alignment attributes.

Inserting FlashPaper

Figure 5-2:
The Insert
Flash Paper
dialog box.

Adobe’s (formerly Macromedia) FlashPaper software converts any print-
able document, such as a Word or Excel file, into either a FlashPaper SWF
file or PDF (Portable Document Format) file. Like PDFs, anyone can open
FlashPaper SWFs in a browser; unlike PDFs, anyone can view FlashPaper
online without needing to link to another file or open another browser
window. FlashPaper also allows a user to see all the pages in the document,
as well as zoom in and out, search, and print.

For more information on FlashPaper, see the Adobe Web site at www .
adobe.com/products/flashpaper/.

To insert a FlashPaper document in your Web page, follow these steps:
1. Open a document and place the insertion point where you want the
FlashPaper to appear.
2. Choose Insert->Mediar>FlashPaper.

You can also choose the FlashPaper button from the Media drop-down
list in the Common category of the Insert panel.

The Insert FlashPaper dialog box appears, as shown in Figure 5-2.

Insert FlashPaper
(o]
Source: Browse. ..
Height: widkhs =
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3. In the Source field, select a FlashPaper document.

4. Set the width and height of the FlashPaper object in pixels.
FlashPaper scales the document to fit the width and height.

5. Click OK to insert the FlashPaper on your page.

The Flash object appears on the page as a gray placeholder box. To set
additional attributes for the FlashPaper object (which are the same as
other Flash elements as described earlier in this chapter), select it and
enter attributes in the Properties inspector.

To preview the FlashPaper object and test the functionality of the Book Il
FlashPaper toolbar, select the FlashPaper placeholder and click the Play Chapter 5
button in the Properties inspector. Click Stop to stop the preview. You can
also preview the file in Dreamweaver by pressing the Live View button on
the Document toolbar, or by pressing F12 to preview the document in a
browser window.

alo
pue ‘punog ‘saInop|
‘ysey4 uippy

Inserting Flash Video

Flash video is different from a regular Flash movie in that a Flash video uses
the FLV file format and allows you to add prerecorded video to a Web page
in a format that most visitors can view with the free Adobe Flash player. A
Flash movie, by comparison, is more of a limited animation clip delivered on
the Web using the SWF file format.

Flash videos start as captured video, which can be in many formats, includ-
ing Avid Xpress DV, Adobe After Effects, Apple QuickTimePro, and Apple
Final Cut Pro. Once captured, the video gets encoded into the Flash Video
format (FLV). You can then decide on a delivery mechanism and add the
video to your Web site.

You need to acquire the video and encode it into the FLV format, or at least
obtain the FLV files prior to adding them to your site. Once a Flash video has
been encoded, you can add it to your page using the Dreamweaver Insert
Flash Video command. This tool enables you to add Flash video to your
pages without using the Flash program, and it enables browsers to play the
inserted Flash video with playback controls.

Find out more about Flash video from the Adobe Learning Guide, including
tips on encoding video with Flash CS4 and other programs, at www . adobe.
com/devnet/flash/articles/video_guide.html.

When inserting the video, you can select two options for the video type:
Progressive Download and Streaming. The decisions you make for inserting
Flash video vary slightly depending on which type you choose:
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Figure 5-3:
The Insert
FLV dialog
box set to
Progressive
Download
Video.

4+ Progressive Download Video downloads the FLV file to the user’s com-
puter and plays it there. The benefit of FLV is that the video starts to

play during the download.

4+ Streaming Video streams the Flash video and plays it in the browser
window. Streaming video typically buffers for a few seconds before
playback to help the playback be smooth rather than bumpy. Streaming
also requires the file to be served by your own Flash Media Server or a
hosted server running Flash Video Streaming Services.

These types of streaming servers aren’t common to most basic servers, so
be sure to check with your Webhost for recommendations.

To insert Flash video using the Progressive Download Video type, follow

these steps:

1. Open a document and place the insertion point where you want the

Flash video to appear.

2. Choose Insert>Media>FLV.

You can also click the Media: FLV button in the Common area of the

Insert panel.

The Insert FLV dialog box appears, as shown in Figure 5-3.

Insert FLV

wideo type: | Progressive Download Yideo ~

(Enter the relative or absolute path of the FLY file)
Skin; | Clear Skin 1 {min width: 140) B3
> L b
“idth: Constrain Detect Size
Height: Total with skin:
[ auto play
[ auto rewind

@ To see the video, preview the page in browser,

Lo

3. Select Progressive Download Video as the video type.

4. Set the following options:
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e URL: Enter the relative or absolute path of the FLV file. Or click the
Browse button to choose a FLV file. For absolute paths, type the
complete URL including http://, as in http: //www.mySampleSite.
com/video. £lv. If you're using a Mac, you must use an absolute
path when FLV files sit more than two levels up from the HTML file
the video is inserted on.

Note: The FLV files must contain metadata in order to work properly
as a video player. Many encoders automatically add metadata to the
FLV files, but some do not.

e Skin: Select an appearance for the video player from the Skin drop-
down list. A preview window displays an approximation of how each

option looks. Book Il

Chapter 5

e Width and Height: Enter a dimension in pixels for both the width
and height of the FLV file. Click the Detect Size button to have
Dreamweaver attempt to automatically read the FLV file dimensions;
if the dimensions are unreadable, manually enter W and H sizes.
The Total with Skin dimensions displayed after the dimensions are
detected represent the total W and H of the FLV file plus the W and H
of the chosen skin.
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¢ Constrain: This option is enabled by default and ensures that the
aspect ratio between the width and height of the FLV movie is
maintained.

¢ Auto Play: Enable this option to have the video begin playing as
soon as the Web page loads in the browser window.

e Auto Rewind: Enable this option to have the video playback return
to the start position when the video reaches the end.

5. Click OK to close the dialog box and insert the Flash video on
your page.

Along with the appropriate code for inserting the FLV file, the code also
includes version detection that prompts visitors to download a newer
version of the free Adobe Flash Player, should their browser’s version
be out of date.

A video SWF file and SWF skin are created to play the video in a browser.
These files are added to the same directory as the HTML file the video
has been inserted in. In the example shown in Figure 5-4, these files are
called Clear_Skin_3.swf and FLVPLayer_Progressive.swt.

<MBER You must also upload these skin files to your server for the video to play
properly. Dreamweaver automatically uploads these files as dependents
during the FTP as long as you agree to upload dependent files during the
upload process
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Figure 5-4:
The
Properties
inspector for
Progressive
Download
Video.
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After inserting the FLV, you can modify some of the Flash video settings,
such as Auto Play, Auto Rewind, and the Skin, in the Properties inspector
(see Figure 5-4).

To insert Flash video using the Streaming Video type, follow these steps:

1.

2.

Open a document and place the insertion point where you want the

Flash video to appear.
Choose Insert>Media~FLV.

You can also click the Media: FLV button in the Common area of the

Insert panel.

The Insert FLV dialog box appears, as shown in Figure 5-5.

Select Streaming Video as the video type.

Set the following options:

e Server URI: Enter the server, application, and instance names in
the form, as in rtmp://www.mySite.com/application_name/

instance_name.

e Skin: Select an appearance for the video player from the Skin drop-
down list. A preview window displays an approximation of how each

option looks.



Figure 5-5:

The Insert
FLV dialog
box for
Streaming
Video.
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Insert FLV

wideo type! | Streaming Yideo w Ok

Server URL:

Stream name:

Skin:

“idth:
Height:

Buffer time:

e

(Enter the server name, app name, and instance name:
&.0., rtmp: fimyserver fmyapp/myinstance)

Clear Skin 1 {min width; 1403 iv3

L || Ll

Constrain Diebect Size

Tatal with skin:
[ Live video Faed
[ aute play
[ auto rewind

o seconds

@ To see the video, preview the page in browser.
ou will also need to upload required files. Show reguired Files...

Width and Height: Enter a dimension in pixels for both the width
and height of the FLV file. Click the Detect Size button to have
Dreamweaver attempt to automatically read the FLV file dimensions;
if the dimensions are unreadable, manually enter W and H sizes.

The Total with Skin dimensions displayed after the dimensions are
detected represent the total W and H of the FLV file plus the W and H
of the chosen skin.

Constrain: This option is enabled by default and ensures that the aspect
ratio between the width and height of the FLV movie is maintained.

Live Video Feed: Enable this option only when the video feed is live.
When live, the player plays a live video streamed from the server.
The name in the Stream Name text box is the name of the live video
feed. Because a viewer can’t manipulate live video, only the volume
control appears on the skin. Furthermore, the Auto Play and Auto
Rewind options are also inoperable with live video.

Auto Play: Enable this option to have the video begin playing as
soon as the Web page loads in the browser window.

Auto Rewind: Enable this option to have the video playback return
to the start position when the video reaches the end.

Buffer Time: This is the time it takes, in seconds, before the video
begins to play in a browser. By default, the buffer is set to 0, but you
can increase the number of seconds to have the player pause before
the video begins to play, which may be helpful for sites that have
occasional bandwidth issues when visitor traffic is high. When Auto
Play is enabled, however, the buffer time is ignored.
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5. Click OK to close the dialog box and insert the Flash video on your page.

Along with the appropriate code for inserting the FLV file, Dreamweaver
includes version detection markup that prompts visitors to download

a newer version of the free Adobe Flash Player, should their browser’s
version be out of date.

A video SWF file and SWF skin are also created to play the video in a
browser. You must upload the SWF files to your Web server and the ASC
file to the Flash Communication Server for the video to play properly.
Dreamweaver automatically uploads these files as dependents when
transferring files with FTP as long as you agree to upload dependent files
during the upload process.

Flash videos may require different players depending on which codec the
video was created with. For more information about Flash video, visit the
Flash Developer Center at www.adobe.com/devnet/flash/ and read the
Flash Video with Dreamweaver tutorial by Jen deHaan at www . adobe . com/
devnet/flash/articles/flv_tutorial.html.

Adding Shockwave Movies, Java Applets,
and ActiveX Controls

In Dreamweaver, you can add Shockwave movies, Java applets, ActiveX con-
trols, and other sound and video files to any open, saved file. If the object
you want to add is not one of these types, use a Netscape Navigator plug-in
instead (as described in the section “Adding Netscape Navigator Plug-ins,”
later in the chapter). You need to prepare these objects in advance before
inserting them on your page. Table 5-1 describes the type of objects you can

add to your Web page.
Table 5-1 Media Types
Media Type Description
Shockwave Movie Adobe’s standard for interactive multimedia files on the

Web, typically created from compressed Adobe Director
files. Shockwave movies download fast and can display in
browsers with the appropriate free Shockwave player.

Java Applet Lightweight applications (applets) generated with the
Java programming language that are inserted onto Web
pages.

ActiveX Control Formerly called OLE controls, these media files are reus-

able components that behave like Netscape browser
plug-ins. They run only in Windows versions of Internet
Explorer. You can assign these controls additional attri-
butes and parameters in Dreamweaver.
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Media Type Description

QuickTime Movie A movie format created with Apple’s QuickTime program
that can include video, audio, and other bitstreams, such
as images and animations.

Netscape A plug-in, or helper application, that allows a Netscape

Navigator Plug-in Navigator browser to display multimedia content (audio,
video, animation, virtual reality, and 3D objects) in a range
of file formats. Plug-ins include RealPlayer, QuickTime,
and MP3 files, among many others.

Follow these steps to insert a media object:

1. Choose Insert=>Media and select the desired media type (Shockwave,
Applet, ActiveX, or Plug-in) from the submenu.

Or click the Media button in the Common category of the Insert panel to
select the media type from its drop-down list.

The Select File dialog box appears.

2. Browse to and select a source file, and set any parameters for the
media file.

For the lowdown on adding parameters for media files, see the nearby
sidebar “Controlling media objects with parameters.”

To insert a media placeholder and bypass having to select a source file
or set any preferences (though the Tag Accessibility dialog box may still
pop up when Accessibility features are enabled), press and hold Control
(Windows) or Option (Mac) while inserting the media object. For exam-
ple, to insert a placeholder for a plug-in without selecting the plug-in file,
press and hold Control or Option and choose Insert=>Mediac>Plug-in, or
click the Plug-in button in the Media drop-down list in the Common cat-
egory of the Insert panel.

3. Click OK to insert the media.

If you've enabled Accessibility options in Preferences, the object’s Tag
Accessibility Attributes dialog box appears prompting you to add a title,
shortcut (access) key, and tab index options to the media file. Enter
those attributes and click OK, or click Cancel to add the media file or
placeholder without the Accessibility attributes.

Setting Shockwave movie properties

Shockwave movies, which are compressed multimedia files created with
Adobe Director, are embedded into a page in a similar fashion and have the
same options as Flash files. Though often confused with Flash files, they are
not Flash.
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Figure 5-6:
Set
properties
for a Java
applet.

To specify the properties for Shockwave movies, select the movie place-
holder in Design view and apply attributes to it from the Properties inspec-
tor. See the earlier section “Setting Flash movie attributes” for a description
of each property.

Setting Java applet properties

You can also add Java applets to HTML files with Dreamweaver. Java (not
to be confused with JavaScript, a scripting language) is a programming lan-
guage that creates applets, or little applications.

After inserting the applet on the page, select the applet placeholder and set
the applet attributes in the Properties inspector (see Figure 5-6):

PROPERTIES |
2 Applet name: W32 Code  myapplet.class =3 Align | Default s| Class| None v
myapplet H 32 Base  applet) Alt applet/myapplet.gil | ()

¥ space

Hispace

+

Applet Name: Enter the applet name in the text box.

<+

W and H: Set the width and height of the applet in pixels.

4+ V Space and H Space: Set white space in pixels above and below, and on
both sides, of the applet.

4+ Code: When you select the applet, this field gets filled in automatically.
To change the Java applet source file, click the folder button or type a
different filename.

4+ Base: If you selected a file in the Code field, the location or path of the
applet displays in this box.

+

Align: Set the alignment on the applet relative to the page.

4+ Alt: Set alternative content and specify a graphic file that displays if the
user’s browser doesn’t support Java applets or has Java disabled. You
can also insert Alt text instead of a graphic. When you add an image, the
<img> tag gets inserted between the opening and closing <applet>
tags. To specify both an image and Alt text, insert the image first, and
then add the alt attribute to the <img> tag in Code view:
<applet code="myapplet.class" codebase="applet/" width="32" height="32">
<img src="applet/myapplet.gif" width="32" height="32" alt="Spinning
Counter" />
</applet>
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4+ Class: Apply CSS to an applet.

4+ Parameters: Click the Parameters button to enter more parameters for
the applet. See the upcoming sidebar “Controlling media objects with
MBER parameters” for more info about setting parameters.
X\
Q
< If you don’t see all these properties, click the expander arrow in the bottom-
right corner of the Properties inspector.

Setting ActiveX control properties

Formerly known as OLE controls, ActiveX controls are mini-applications that
behave like browser plug-ins and can be reused as often as you need. The
ActiveX object lets you add attributes and parameters for an ActiveX control
in a user’s browser.

Controlling media objects with parameters

With most media objects, the Properties you do add, the process for adding them is the
inspector includes a Parameters button when  same.

you're specifying properties for that media
object. Parameters are special values for
Shockwave movies, Java applets, ActiveX
controls, Netscape Navigator plug-ins, and 1. Select the media file placeholder in Design
Flash SWF files. These values are attached to view.

the <object>, <embed>, and <applet>
tags in the code, and usually set specific attri-
butes for the type of media object being added
to the page. For instance, a Shockwave movie The Parameters dialog box opens, shown in
can have a URL parameter that is part of the the following figure.

<embed> tag as the following line of code 3
shows (where swURL is the name and file-
name . html is the value of the parameter):

To add parameters to media objects, follow
these steps:

2. Click the Parameters button in the
Properties inspector.

. Enter a value for the parameter. Click the
plus (+) button to add a parameter or the
minus (—) button to remove a parameter.

<embed src="swmovie.dcr" height="100" 4 E h inthe P
B R P . Enterthe parameter name in the Parameter

html"> column and the value in the Value column.

To find out what attributes you can add to an 9 Repeat steps 3 and 4 to add or remove
object, see the documentation for the media parameters as needed.
object you’re inserting. Whatever parameters

(continued)
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(continued)
6. Toreorderthe parameters, clickthe upand  You can also view the assigned attributes of any
down arrow buttons. selected media object by viewing the Attributes
. , . tab of the Tag Inspector panel. There you can
7. Click OK when you're done setting all the add, edit, and delete attributes like src, width,
parameters. .
and height.
Parameters
BE S[a)
Parameter Walue
JING/
&

Figure 5-7:
Set
properties
for the
ActiveX
control.

ActiveX controls run on Windows with Internet Explorer, but not on IE on a
Mac or in any Netscape browser, so use them with consideration.

Select the ActiveX control placeholder in Design view, and set the attri-

butes of the <object> tag and the parameters of the ActiveX control in the
Properties inspector (see Figure 5-7).

PROPERTIES |

> Activex W 32 | CassiD ~ Align | Defaut | Class| pone ~
0k :

Hspace D Data Altimg

4 ActiveX: Enter the name of the ActiveX media file in the ActiveX text box

in the top-left corner of the Properties inspector. The name assists with
scripting the object.

4+ W and H: Set the width and height of the object in pixels.

4+ V Space and H Space: Set white space in pixels above and below, and on
both sides, of the object.
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4+ ClassID: Select a value from the drop-down list or type a value for the
ClassID, such as RealPlayer or Shockwave for Flash. This field identifies
the control to the browser. If the browser can'’t find the ActiveX control
specified, it tries to download it from the URL listed in the Base field.

4+ Embed: Activate the Netscape Navigator plug-in equivalent of the
ActiveX control using the <embed> tag within the <object> tag.
ActiveX property values assigned in Dreamweaver are applied to their
Netscape Navigator plug-in equivalents.

4+ Src: If you enabled the Embed option, type or browse to and select the
data file for a Netscape Navigator plug-in. If you don’t specify a filename,
Dreamweaver attempts to find the value using the other ActiveX properties.

4+ Base: Identify the URL with the ActiveX control. If the control is not
already installed on the user’s computer, IE prompts the user to down-
load it. Without the proper ActiveX control installed, the browser can’t
display the object.

4+ ID: Set the ID for the ActiveX control to load. If you don’t have informa-
tion for this parameter, leave this field blank.

4+ Data: Set the data file for the object to load in the browser. Some
ActiveX controls, such as RealPlayer, don’t use this parameter. Leave
the field blank if you don’t have information for this parameter.

4+ Alt Img: Specify a graphic file to display if the user’s browser doesn’t
support the <object> tag. The Embed option must be unchecked to
use this feature.

<+

Align: Set the alignment of the object relative to the page.

+

Class: Apply CSS to an object.

4+ Parameters: Click this button to enter more parameters for the ActiveX
control. See the sidebar “Controlling media objects with parameters” for
more info about setting parameters.

Adding Netscape Navigator Plug-ins

Typical plug-ins for Netscape Navigator (the precursor to Firefox and other
non-IE browsers) include QuickTime movies, RealPlayer content, and MP3s.
If you want to insert an object that is not a Flash, Shockwave, applet, or
ActiveX object, try inserting it on your page with the Netscape Navigator
plug-in. You can create your own content or get it from another source, and
then use Dreamweaver to insert the file into your HTML page. To insert a
Netscape Navigator plug-in, follow the steps in the earlier section “Adding
Shockwave Movies, Java Applets, and ActiveX Controls” and choose the
Plug-in option in Step 1.
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Figure 5-8:
Set
properties
for the
plug-in.

A\

Setting Netscape Navigator plug-in properties
After adding the Netscape Navigator plug-in object, select the plug-in place-

holder in Design view and set its properties in the Properties inspector (see
Figure 5-8). Here are your options:

PROPERTIES |

S Plugin W3z src =3 Align | Default +| Class | None v

250 ——
H 32 | PlgURL o Py ]

&

4 Plug-in ID/Name: Enter the name in the Plug-in text box in the top-left
corner of the Properties inspector.

4+ W and H: Set the width and height of the plug-in object in pixels.

4+ Vspace and H space: Set white space in pixels above and below, and on
both sides, of the plug-in object.

4+ Src: If you selected a source file for the plug-in when you inserted it, this
field is already filled in. If not, identify the source data file of the plug-in
by typing the filename or click the folder button to browse to and select
the file.

4+ PIg URL: Specify the URL where users can download this plug-in. If the
user’s computer doesn’t have the plug-in, the browser downloads it
from this URL.

Border: Add a black border, in pixels, around the entire plug-in.
Align: Set the alignment of the object relative to the page.
Class: Apply CSS to an object.

.+ 4+

Parameters: Click the Parameters button to enter more parameters
for the Netscape Navigator plug-in. See the sidebar “Controlling media
objects with parameters” for more info about setting parameters.

Playing Netscape Navigator plug-ins

Dreamweaver lets you preview movies and animations that use Netscape
Navigator plug-ins (but not ActiveX controls) in Design view. As long as
you've installed the appropriate plug-ins, you can play previews of all the
plug-ins at once or play them separately.

Be sure to also test the plug-ins in as many browsers as possible to ensure
your site visitors have the most consistent experience viewing them. A fan-
tastic online testing site is www.browsershots.org.
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Here’s how to preview movies and animations with Netscape Navigator
plug-ins:

4+ To preview a single movie or animation: Select a media file inserted
on the page and click the Play button in the Properties inspector. The
media file plays in Design view.

Or choose ViewtoPlug-ins=>Play.

4+ To preview all the media files on a single document: Choose Views>
Plug-ins=>Play All. All the media files on the same page play. Alternately,
you can try to preview the plug-ins by clicking the Live View button on

he D Ibar.
the Document toolbar Book Il

4+ To stop playing the media files: Click the Stop button in the Properties Chapter 5
inspector. For multiple media files, you can also choose Viewr>Plug-
insw>Stop All For Live View previews, click the Live View button again to
toggle out of Live View.

If for some reason the plug-in content does not play in the Document
window, try the following troubleshooting tips:
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4 Be sure the plug-in is installed on the test computer and that the plug-in
content is compatible with the plug-in version installed. For instance, if
a movie runs with QuickTime V7, but only the QuickTime V5 player is
installed, the movie won'’t play.

4+ Open the Configuration/Plug-ins/UnsupportedPlug-ins.txt file in a text
editor to see if the plug-in is listed. This file automatically adds problem-
atic plug-ins to the list.

4 Check the computer to see if enough memory is allocated to run the
file. Many plug-ins need an extra 2 to 5SMB of memory just to run! That
said, most modern operating systems don’t use memory allocation, so
this issue may be more applicable for Mac 0S9, Windows 95, and earlier
operating systems.

Acceptable Sound File Formats

There are several common sound file formats, each with their own set of
benefits and drawbacks. Here are the most common file formats:

4+ .mp3 (Motion Picture Experts Group Audio, or MPEG-Audio Layer-3):
This sound file compresses files so they are much smaller in size. The
quality is very good — even close to CD quality if recorded and com-
pressed in the right way. One of the great things about this format is the
ability to stream data so the user doesn’t have to wait for the entire file
to download before listening to it. Most podcasts are MP3 or ACC.
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One possible drawback is the overall file size, which can get pretty
big, making download times on a dialup connection seem impossible.
The user’s computer must have helper applications, such as iTunes,
QuickTime, RealPlayer, or Windows Media Player, to play MP3 files.

4+ .qt, .qtm, .mov, or QuickTime: This format is great because it can con-
tain both sound and video. Developed by Apple, it’s the default sound/
video player for Macintosh computers. PCs can play QuickTime files too,
but the user needs to download and install the free QuickTime player
first. The encoding formats supported by QuickTime include JPEG,
MPEG, and Cinepak.

4 .ra, .ram, .rpm, or Real Audio: Like MP3s, this format allows for stream-
ing audio data. It also compresses files, but into even smaller file sizes
than MP3s. Visitors would need to download and install the RealPlayer
application to play these files. That said, Real Audio is on the decline so
you might want to shy away from using Real Audio.

4+ .wav (Waveform Extension): These files have good sound, are widely
supported by browsers, and don’t need any special plug-ins to play.
They tend to have very large file sizes, so sound clips need to be small
enough to add to Web pages. Most computers allow you to record your
own WAV files in some way with a microphone.

4+ .midi or .mid (Musical Instrument Digital Interface): These files are
intended for instrumental music only. Small files can provide long sound
clips, too. The sound quality, however, is dependent on the sound card
on the user’s computer. Like WAV files, most browsers support MIDI
files and they don’t require special plug-ins. The biggest drawback to
MIDI files is that you can’t easily record with them; they must be synthe-
sized using specific software and hardware.

4+ .aif (Audio Interchange File Format, or AIFF): Like the WAV format,
these sound files have good sound, are supported by most browsers,
and don’t need plug-ins to play. AIFF files can be recorded to CDs and
tapes using a microphone through your computer, but because of their
large file sizes, sound clips need to be small enough to add to Web
pages.
o If you come across another file format that you want to use on your Web
page, check with the format creator’s technical help files to find out about
browser support.

Adding Other Uideo and Sound to a Page

Dreamweaver supports adding sound to a Web page. There are many types
of sound files and formats, such as .wav, RealPlayer, and .mp3, as described
in the preceding section.
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Before you decide on a format and how to add the sound to your page, con-
sider the audience, the file size, the sound quality, and the different ways
browsers support these files because different browsers handle sound files
very differently. If you're trying to create a consistent experience for your
visitors — regardless of their browser type — consider adding the sound

to a Flash SWF file rather than having it linked or embedded to the page.
Ultimately, testing the sound and video files in multiple browsers is the best
way to decide what to add and how to add it.

Linking versus embedding video

You can link or embed your prepared video files (non-Flash) to a Web page,
depending on the video format and preferred method of display. That means
you can set up the video to download to the user’s desktop, or embed it in
the page so it streams in the browser while downloading.

Follow these steps to link or embed a short video in your page:

1. Add the video clip to your site folder.
Video clips often use the MPEG or AVI file format.
2. Link or embed the clip to your page by doing one of the following:

¢ Linking: Type the text you want to appear on your page (such as
Download Video), select that text, and in the File text field in the
Properties inspector, type the video filename with extension, or click
the folder button to browse for and select the video file.

¢ Embedding: Follow the steps in the earlier section, “Adding
Shockwave Movies, Java Applets, and ActiveX Controls.”

Streaming video requires that the user’s computer has a helper
application, such as RealMedia, Windows Media, or QuickTime, for
the video to play.

Be sure to upload the video file to the server along with the file it’s linked to
so the site visitor can download or watch the video.

Linking versus embedding sound

Linking to a sound file is the best way to add sound to a Web page because it
allows users to decide for themselves whether they want to listen to the file
in advance of hearing it.

Embedding sound, by contrast, adds the sound directly into a Web page so
it plays automatically, as long as the user’s computer has the right plug-in.
Embedded files can play background music, for instance. Sound plug-ins
often embed volume control as well as On/Mute control.

Book 11
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Although both methods are possible, the more widely used practice is to
embed sound in a Flash file, which avoids the need for visitors to download
a bunch of different plug-ins.

Linking to a sound file

To add a link to a sound file on a Web page, follow these steps:

1. Select the image or text you want to use as the link to the audio file.

2. In the Properties inspector, type the filename in the Link text box, or
click the folder button to browse for and select the audio file you want
to use.

Be sure to upload the sound file to the server along with the file it’s linked to
so the site visitor can access the sound file. This method makes the sound
file available to the widest audience.

Embedding a sound file

To embed a sound file on a Web page, follow these steps:
1. In Design view, place the insertion point on the page where you want
to embed the file.
2. Choose Insert->Media->Plug-in.

Or click the Media button in the Common category of the Insert panel
and choose Plug-in from its drop-down list.

The Select File dialog box appears.
3. Browse to and select the sound file you want to insert.
4. Click OK to insert the sound file.
After inserting the sound object, select the sound placeholder object in
Design view and enter values in the attribute fields in the Properties inspec-

tor. The Width and Height values, for example, determine the size of the
audio controls displayed in the browser window.

Be sure to upload the sound file to the server along with the file it’s embed-
ded in so the site visitor can hear and play the sound file.

Launching a Media External Editor

Dreamweaver allows you to launch many external editors for a variety
of media types if you need to edit those media files while working within
Dreamweaver. For example, you can launch Fireworks to modify GIF files,



Figure 5-9:
The File
Types/
Editors Pre-
ferences.
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Photoshop to modify JPG files, and oXygen or Altova XMLSpy to modify XML
files. Launching an external editor from within Dreamweaver to edit most
media types is a simple process that requires only a few simple steps.

First, you need to associate the media file type with the editor on your com-
puter. To so do, follow these steps:

1. Choose Edit=>Preferences (Windows) or Dreamweaver= Preferences
(Mac) and then choose the File Types/Editors category in the
Preferences dialog box, as shown in Figure 5-9.

Preferences
Category File Types | Editors
General
Accessiility ;
AP Elements ©penin code view: | js .asa .c55 .05 .config Jnc bt a5 .asc.ast vb htaccess htpasswd
Code Coloring
Code Format External code editor: Browse...
Code Hints
Code Rewriting Reload medified files: | Prompt v
CopyfPasts 2
€55 Styles Save on launch: | Prompt »
File Campare
File Types | Editors Firewarks: | C:\Program Files\MacromedialFireworks 8\Fireworks.exe Browse..,
Fants
il * &)=
Ivisible Elements @ ) HakeBrimary
N Dditiert Extensions a| | Edtors
Preview in Browser
Ste Bng Firgworks (Primary)
Status Bar -af Phatoshop
Validator P9 ipe dpeg
psd
fla
v
aiff aif aifc
“mpg mpeg =

2. Select the file extension in the Extensions panel to see any associated
editors in the Editors panel.

For example, in Figure 5-9, the .png extension is associated with the
Fireworks editor, which is also the primary editor.

3. If needed, add or change extension types by clicking the plus (+) or
minus (-) button. To make an editor the primary editor, click the Make
Primary button.

4. When you finish, click OK to save your changes.

After you establish the file types/editor preferences, double-click the media
file in the Files panel to start the external media editor. The primary editor
associated with that media type opens.

If you'd prefer to occasionally not use the primary editor to edit the media
file, right-click (Windows) or Control+click (Mac) the media file from the
Files panel or from within Design view and choose Open With or Edit With
from the context menu.
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Chapter 6: Organizing Data with
Tables

In This Chapter

v Creating tables

v+~ Using table visual aids

1 Formatting tables and table cells
1 Adding content to table cells

v+ Importing tabular data

Wth the increasing popularity of CSS layout and CSS best practices,
table-based Web sites are becoming less and less common. Most

Web designers have switched to a CSS layout model, which is widely recog-
nized as being more flexible than table-based layout. (See Book IV, Chapter
1 to learn more about layers-based Web sites.)

That said, tables themselves are still a great way to organize tabular data
and other content, like a listing of store locations or detailed product infor-
mation, in a visually pleasing way. HTML tables can have as many rows and
columns as needed, and additional tables can be nested inside other table
cells ad infinitum for more complex layouts. Tables are made up of one or
more rows, and each row has one or more cells. The cells make up columns,
and though the columns are not explicitly defined in HTML, Dreamweaver
allows you to manipulate rows, columns, and cells.

As far as styling goes, tables can have borders, background colors, back-
ground images, and be aligned relative to the page. Their individual table
cells can also have similar attributes. Furthermore, table content can
include text, graphics, links, movies, sound, and other plug-ins, and each of
those can have their own formatting or style attributes.

This chapter guides you through the process of inserting, editing, and delet-
ing tables, formatting and adding content to them, plus some general tips
for using tables to improve the overall look and feel of a page.
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Creating Tables

Figure 6-1:
Use tables
to organize
content
within a
page.

Though creating Web page layouts with CSS and AP Elements, or layers, is
the preferred method of design these days, you can still use tables for laying
out and organizing other content. It’s also important to understand how
tables have been used in the past for layout, as you may someday inherit a
Web site built with a tables-based layout and need to convert it to layers, or
at the very least edit the content within it.

To add a table to your page, simply insert the table in an open file in the
Dreamweaver Document window and format the table and content inside the
cells according to a predetermined design or your own personal aesthetic.
For instance, you can create a table that organizes UPS second-day air ship-
ping rates by state and number of units sold. (see Figure 6-1).

UPS 2nd Day Air

STATE :UNITS 1 2z 3 &+ ) & x 8 ke ic 1l CASK
oT, MY $12: $15° 4£18i$20501¢2550:  $28% $31% $33% $34:$36.50:438 5D§§4D 50
C, NH,
= $131  $16162050 424500 $281 £300  $34:$37.50: 38504050 $43:  $45
c, OH,
i $14° $18:60350;  £281  $321£3550:441 508 $441  £461 50,50 £52,50:455,50

i, GA, -
L, IN,
a1 5C. $16:$21,50:  $281 $34 440,50  $441$51500455.500  $58%  $631$66,50470.50

L, 18,
5, MIN,
M0, ND,
WL $18:$25.50:435.50;  $43 $52.50  $59:£68.500 $741  £781¢8450  $91i6097.50

WE, T $19 $27:536.500  $45:$55.50: 461 72 $78 $82 $90:$96,50¢ $104

Ca, co,
D, KM,
1, OR,
jia wvi £21.508 £28it3m S0 £47 1856500 G631 £74:  £801¢R450C  £03i£07.50: £106

When your table contains a lot of text, it’s best to fix the width of the table
cell to a readable size, usually 500 pixels wide or less. To contain text
inside a fixed area of the page, insert a fixed-width table with one row and
one column and paste the content inside the table cell. When opened in a
browser window, the text then wraps inside the cell boundaries instead of
expanding and collapsing with the edges of the browser window.

In the Layout category of the Insert panel, shown in Figure 6-2, you can
choose from two layout modes when working with tables:

4+ Standard: By default, Dreamweaver uses Standard mode, which shows
tables as a grid of rows and columns.

4+ Expanded: For even easier editing, try using the Expanded mode, which
adds temporary cell padding and cell spacing for more precise selections.



Figure 6-2:
The Layout
category of
the Insert
panel.
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To switch layout modes, click the desired Layout mode button in the
Layout category of the Insert panel. You can also switch modes by choosing
Viewr>Table Mode and then selecting a layout mode option from the submenu.

In the following sections, you find out how to insert a basic table in your
Web page.

Inserting a basic table in your page

To create a basic table in Dreamweaver, follow these steps:

1. Place your cursor where you want the table to appear on the page.
2. Choose Insert->Table.

You can also click the Table button on the Layout category of the Insert
panel.

The Table dialog box appears, as shown in Figure 6-3.
3. Specify the following attributes for the new table:

¢ Rows and Columns: Enter the number of rows and columns for your
table.

e Table Width: Enter a fixed width in pixels or a percentage width
between 1 and 100 percent.

¢ Border Thickness: Enter the size, in pixels, for the table border. If
left blank, the border displays as if it was set to 1 pixel. To remove a
border completely, set the thickness to 0.

Book
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¢ Cell Padding: Enter a number in pixels to increase the space
between the cell’s walls and its contents. If left blank, the cell pad-
ding displays as if it was set to 1 pixel. To remove cell padding com-
pletely, set the size to 0.

¢ Cell Spacing: Enter a number in pixels to increase the walls of the table
between the cells. If left blank, the cell spacing displays as if it was set to
2 pixels. To remove cell spacing completely, set the size to 0.

4. (Optional) Choose a header for the table.

The content in header rows or columns format differently than content
in other table cells. In addition, screen readers identify the content in
header rows or columns differently to assist visually impaired visitors in
understanding the content in the table.

5. In the Accessibility area, fill in the following fields:

e Caption: This is a title for the table, which appears outside of the
table, directly on top of the first table row.

e Summary: Add a description for your table. This information is
added to the opening Table tag and hidden from view in a browser,
but is read by screen readers.

6. When you finish, click OK to create your table.
Dreamweaver adds the table to your page with the specified settings.
7. Add content to your table cells.

You can insert text, graphics, media, and other files in a table cell —
anything that can exist on a page can also be placed and formatted in a
table cell. For details, see the “Inserting Text and Images in Table Cells”
and “Formatting Individual Table Cells” sections.
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\4
<~ After inserting the table, you can also nest tables inside the table’s individ-

ual cells. To nest a table inside a table cell, place your cursor inside the table
cell and repeat Steps 2 through 7.

Turning On Table Visual Aids

Creating tables can sometimes be a tricky business, so Dreamweaver cre-
ated some interesting visual aids. They help you select table cells, columns,
and rows, edit the tables themselves, and view table attributes such as cell

widths in pixels or percentages. Book Il

Chapter 6
By default, the visual aids for tables should already be on; however, you can

toggle them on and off by choosing Viewr>Visual Aids=>Table Widths and/or
Viewr>Visual Aidse>Table Borders. You see a check mark when the aids are
enabled, and no check mark when they’re turned off. You can also turn Visual
Aids on and off through the Visual Aids menu of any open Document window.
Figure 6-4 shows an example of a table with and without Table Visual Aids.
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When Table Visual Aids are turned on, Dreamweaver shows a table header
menu, which displays table widths and column widths when the table is
selected or the cursor is somewhere inside the table. Next to the widths you
see tiny green arrows that, when clicked, quickly access a few of the table-
related commands.

If two numbers are specified for the width dimensions, check the HTML
code to ensure that the column widths add up to the total table width. For
instance, one column’s width may be set to 100 pixels, but after adding a
long sentence or large graphic, the cell stretches to 300 pixels. The first
number (100) is the HTML-specified cell width, and the number in parenthe-
ses (300) is the visual width as displayed on-screen. Fix the table dimensions
in the code by clicking the table header menu and selecting Make All Widths
Consistent. Then preview the page in a browser window (F12 (Windows) or
Option+F12 (Mac)) to test for visual accuracy.

Formatting Tables with the Properties Inspector

WBER
‘x&
&

After creating a table, you can set formatting options for the whole table, or
for specified rows, columns, or cells, in the Properties inspector.

To select a table to format it, do one of the following:

4+ Click on the table’s outer edge.

4+ With your cursor anywhere inside of the table, click the table tag on the
Quick Tag Editor bar at the bottom of the Document window.

When a table is selected, selection handles appear on the right-center,
bottom-center, and bottom-right corners of the table, and the Properties
inspector displays table formatting options, as shown in Figure 6-5.

Table formatting attributes are totally optional. Use them in any combina-
tion to format tables in harmony with the data contained in them and the
overall look of the Web site design. When adding formatting to a table, keep
in mind that cell formatting takes precedence over row formatting, which
takes precedence over table formatting. In other words, a cell with a back-
ground color displays that color in the browser even if the row or entire
table has a different background color attribute.

Also keep in mind that most of the decorative table styling should be applied
with CSS. You can apply those custom CSS styles along with other formatting
using the Properties inspector.



Figure 6-5:
The
Properties
inspector
shows table
formatting
options
when a
table is
selected.
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Selection handles

The Properties inspector includes these table formatting options:

Table ID: Input the table name. IDs are now used instead of name
attributes for easier assignment of CSS, Dreamweaver behaviors, and
JavaScript events. You don’t need to name all your tables, but adding
Table IDs to each of your tables is a more Web standards compliant way
of coding, and it also helps you keep better track of them when you do.

Rows and Cols: Change the numbers in the Rows and Cols fields to
adjust the table rows and columns accordingly (see the “Adding Rows
and Columns to a Table” section).

W: Adjust the width of the table in pixels or percentages. Widths are
generally specified for tables automatically, while the height field is typi-
cally left blank so that the overall height is determined by the contents
of the table. When specifying dimensions in percentages, the width is
relative to the open browser window or containing cell. For instance,
W=80% (or in the code view, width="80%") means the table expands to
80 percent of the open browser window, or 80 percent of a containing
cell if the table is nested inside another table.
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4+ Border: Add a border to the outer edges of a table. By default, the
Border field is blank. Enter any number from 0 to 750. Borders without a
P\ border color attribute appear beveled.

For better borders, create a custom CSS style. See Book Ill, Chapter 1 to
learn more about Cascading Style Sheets.

4+ Class: Apply a custom style from an internal or external CSS to style
tables or table cells with background colors, borders, and background
images, among other things.

To gain further control over the look of your tables, consider adding cell
padding, cell spacing, and cell alignment attributes:

4+ The CellPad field adds uniform spacing in pixels inside all the cells in a
table, padding cell contents away from the cell walls.

4+ The CellSpace field adds uniform spacing in pixels to the walls of the
cells in the table.

4+ The Align field determines where the table sits relative to other content
on the page. The browser determines the default alignment, but most
browsers have the default set to Left. To ensure the table aligns prop-
erly, select Left, Center, and Right from the drop-down list.

By default, the CellPad and CellSpace fields are blank, which has the equiva-
lent of 2 pixels, respectively. To remove the default spacing attributes, enter
0 in both fields.

Merging and Splitting Rows and Columns

Editing rows and columns in Dreamweaver is a dream come true! Adobe has
made splitting and merging cells so easy that you might never want to go
back to hand-coding your tables (although hand-editing tables after they’re
built can often be faster than editing through the Properties inspector and
Design view).

It’s important to understand what’s happening to the code when you split

or merge cells. For example, when merging two cells in a row into one cell,
the two cells are combined by making the first cell span across two columns,
using the colspan attribute in the <td> tag:

<table width="300" border="1">
<tr>
<td colspan="2">Merged Cells</td>
</tr>
<tr>
<td>Bottom Left</td>
<td>Bottom Right</td>
</tr>
</table>



Figure 6-6:
Before and
after views
of a merged
row and

a merged
column.
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By contrast, when merging two cells in a column, those cells actually span
across two rows, this time using the rowspan attribute in the <td> tag:

<table width="300" border="1">
<tr>
<td rowspan="2">Merged Cells</td>
<td>Right Top</td>
</tr>
<tr>
<td>Right Bottom</td>
</tr>
</table>

Figure 6-6 shows examples of what a merged row and a merged column look
like in Design view, compared to normal tables with no merged cells.

mergetables.html % 10
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<hody > [<table | & [&% Q [100% ~|534 % 360%| 2K [ 1 sec| Unicode (UTF-8)

Seems simple enough, but this process can get very confusing the more
complex your tables get. Imagine having to figure it out and code it by hand!
Thankfully, Dreamweaver handles all this merging and splitting with ease —
in fact, Dreamweaver makes everything about designing Websites a breeze
by giving you the option of working in either Code or Design views. In the
past, people had to actually code everything by hand! The following sections
explore ways to split and merge cells as well as add rows and columns.

You can merge or split any number of cells using buttons on the Properties
inspector. For instance, you may want to select all the cells in a particular
row and merge them into one wide cell, or take one cell somewhere in the
table and split it into three cells.
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Figure 6-7:
The Split
Cell dialog
box.

If you forget which button is which (merge or split) in the Properties inspec-
tor, hover your cursor over the button to read the tool tip description.
Merge says Merges selected cells using spans and Split says Splits cell into
rows or columns. The merge button has two boxes that look like they are
being combined or pushed together, whereas the split button has two boxes
being pushed away or separated from one another.

Merging cells

To perform a merge, follow these steps:
1. Select the cells that you want to combine by clicking and dragging
across several cells.

Selected cells must be contiguous, or touching, as well as evenly
matched horizontally and vertically (in the shape of a rectangle) for the
merge to work. If the selection is unbalanced in some way, the merge
button is grayed out. As long as the merge button is active, the merge
can take place with the selection.

2. Click the Merge Selected Cells button in the lower-left corner of the
Properties inspector.

Dreamweaver merges the selected cells into a single cell.

To remove a merge, place your cursor inside a single cell and do one of the
following:

4+ Choose Modify=>Tablem>Decrease Row Span to merge the selected cell
into the cell below it.

4+ Choose Modify=>Tabler>Decrease Column Span to merge the selected
cell into the cell to the right of it.

Splitting a cell
To split a cell, follow these steps:
1. Place the cursor inside the cell you want to split.
2. Click the Split cell button in the Properties inspector.
You can also choose Modify=>Tabler>Split Cell.
The Split Cell dialog box opens, shown in Figure 6-7.

Split Cell
Split cell inka: () Rows
) Columns
Mumber of rows: | 2 =

Help
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3. Select Rows or Columns as the Split Cell Into type and enter a number
for the split in the Number Of field.

4. When you’re finished, click OK.

Dreamweaver splits the cell.

Setting Table Width and Heights

NG/
‘Q‘“\ '

When first creating a table, the overall size of the table is determined by the
pixels or percentages settings in the width field. Both pixels and percentage
settings split cells and rows evenly but without adding exact pixel dimensions
into the W field for each row or column. The reason for this is that most table
cells use their contents to determine their size. However, sometimes you need
to fix a table, table row, table column, or table cell’s dimensions.

When the need arises, select an entire row or column, or place your cursor
inside any cell to modify the dimensions of the cells, and then enter width
attributes in pixels or percentages in the Properties inspector.

Alternately, you can specify the exact width and height of a table, table row,
column, or cell using Cascading Style Sheets.

Take care when manually entering W cell sizes to your cells because if the
math doesn’t add up right, the table may not display accurately in a browser
window. Therefore, be sure each row or column adds up to 100 percent or
the total amount of pixels specified for the table. For example, in a table with
two columns that is 200 pixels wide, check to see that the total cell width
equals 200 (100 pixels wide each). Unequal columns can be any size as long
as they equal 200, as in the following code where 85 is the width for the first
column and 115 is the width for the second column:

<table width="200" border="1" cellpadding="5">
<tr>
<td width="85" rowspan="2">Coffee</td>
<td width="115">Regular</td>
</tr>
<tr>
<td>Decaffeinated</td>
</tr>
</table>

Adding Rows and Columus to a Table

When adding rows and columns, all the contents in each of the cells are
duplicated right along with the new row or column.
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Adding a row

To quickly add a row to a table:

4+ To add a row above a certain row, place your cursor inside a cell and

choose Insert=>Table Objectse>Insert Row Above. You can also insert a
row above a selected cell by clicking the Insert Row Above button in the
Layout category of the Insert panel.

To add a row below a certain row, place your cursor inside a cell and
choose Insert=>Table Objectse>Insert Row Below. You can also insert a
row below a selected cell by clicking the Insert Row Below button in the
Layout category of the Insert panel.

Adding a column

To quickly add a column to a table:

4+ To add a column to the left of a certain column, place your cursor inside

a cell and choose Inserte>Table ObjectseInsert Column to the Left. You
can also insert a column to the left of a selected cell by clicking the Insert
Column to the Left button in the Layout category of the Insert panel.

To add a column to the right of a certain column, place your cursor
inside a cell and choose Insert>Table Objects=>Insert Column to the
Right. You can also insert a column to the right of a selected cell by
clicking the Insert Column to the Right button in the Layout category of
the Insert panel.

Adding multiple rows or columns

When adding columns, the rightmost column gets duplicated and added to
the right edge of the table. When adding rows, the bottom row gets dupli-
cated and added to the bottom of the table.

To add multiple rows or columns, place your cursor inside the cell next to
where you want to add the rows or columns, and follow these steps:

1. Choose Modify=>Table>Insert Rows or Columns.

The Insert Rows or Columns dialog box opens, shown in Figure 6-8.

Figure 6-8:
The Insert
Rows or
Columns
dialog box.

Number of rows: | 1

Insert Rows or Columns
) Columns

R

where: () Above the Selection

(%) Below the Selection Help




Formatting Individual Table Cells 163

2. Select either the Rows or Columns option button, enter the number of
rows or columns that you want to insert, and select either the Above
the Selection or the Below the Selection option button.

3. When you finish setting the options, click OK.

Dreamweaver inserts the specified number of rows or columns into your
table.

Deleting rows and columns

Delete rows and columns quickly with any of these methods:
4+ Place your cursor inside a cell of the row or column to be deleted and
choose Modify=>Table=>Delete Column or Delete Row.

4 Select an entire row or column and press Ctrl+X (Windows) or 38+X
(Mac), or choose Edit=>Cut.

4 Select an entire row or column and click the Delete or Backspace key.

Inserting Text and Images in Table Cells

3

Add text and graphics to table cells just as you’d add them to a page. Click
inside the cell and begin typing to add text or use the Insert panel to add an
image (see Book I, Chapter 3). Insert other media to table cells in the same
way by browsing for and selecting the media that you want to insert.

You can also paste contents from other sources — such as a word process-
ing document — into a cell. Apply text and graphics formatting attributes
with the Properties inspector or with the help of CSS. (See Book Ill, Chapter
1 for more on CSS.)

Formatting Individual Table Cells

In addition to standard text formatting options, the cells themselves can
have specific formatting attributes, which are slightly different from format-
ting options for an entire table. If you don’t see cell formatting options in
the Properties inspector, click the down expander arrow in the bottom-right
corner to reveal the cell’s formatting area.

Format several cells at once or one at a time depending on your needs using
any of these formatting options in the Properties inspector (see Figure 6-9):
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Figure 6-9:
Set cell
properties.

PROPERTIES |

HIML Farmat |None ~|  Qass | None v| Bz =i
35 1D | Mone v Link ] o5 Target
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1 3E  vert|pefaul [v| B Header []

4+ Horz and Vert: Stands for Horizontal and Vertical alignment options
for any cell, row, or column. The default horizontal alignment is Left for
regular cells and Center for header cells. Horizontal alignment options
include Left, Center, and Right. Vertical alignment options include Top,
Middle, Bottom, and Baseline. Both dimensions also have a Default
option, which aligns the contents of the cells left and center.

4+ W and H: Set the width and height for an entire selection. Enter dimen-
sions in pixels or percentages. Or, for more control, use CSS to set the
dimensions of individual cells.

4+ No Wrap: Forces text or other content in that cell to not wrap, thereby
pushing out the cell walls and adjusting the cell sizes if the content
extends beyond the cell’s specified size. Use this feature for addresses
or other information that needs to be all on one line.

4+ Header: Turns any regular cell into a header cell by converting the <td>
tag into a <th> tag. Table headers have preset formatting attributes to
help set their content apart from the rest of the content in the table.
Headers are typically only used on the top row or left column of a table.

4+ Bg Color: Sets the background color of a cell or set of selected cells.
Background cell colors sit on top of, or hide, a table background color. To
specify a background color, click the color picker icon and select a color
or enter the hexadecimal number preceded with a # (number sign) in the
Bg Color field, as in #FF3300. If you forget to add the # before the hex
value, the color may not appear in different browsers. Alternately, you can
use CSS to style your cells with background colors, borders, and images.

Changing Table Measurements
from Pixels to Percentages

Another great feature Dreamweaver provides when working with tables is
the ability to convert a table’s measurements from pixels to percentages,
and vice versa. This is especially useful when you want the flexibility of
adjusting a table with percentages but need to convert to fixed pixel widths
before publishing.

To change table measurements from pixels to percentages (or vice versa),
select the entire table and choose a convert option from the submenu when you
select Modify=>Table. Or, for even faster conversions, use the table property
conversion buttons located in the Properties inspector, as shown in Figure 6-10.



Figure 6-10:
The table
property
conversion
buttons.
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A description of each is provided in the following list:

4+ Clear Column Widths: Completely removes any width attributes from
column cells in the entire table.

4+ Convert Table Widths to Pixels: Converts all table widths from percent-
ages to fixed pixels.

4 Convert Table Widths to Percent: Converts all table widths from fixed
pixels to percentages.

4+ Clear Row Heights: Completely removes any width attributes from row
cells in the entire table.

4+ Convert Table Heights to Pixels: Converts all table heights from per-
centages to fixed pixels.

4+ Convert Table Heights to Percent: Converts all table heights from fixed
pixels to percentages.

Importing Tabular Data

Dreamweaver now swiftly imports tabular data saved as tab delimited .txt
files and converts it into HTML tables! This is great news to anyone who’s
ever tried to paste table data from Microsoft Excel or Access into an HTML
page. Windows users can import Excel files directly into Dreamweaver
(FileImport=>Excel Document) or import tabular data as described below.
Mac users, however, can’t import Excel files into Dreamweaver, and must
therefore (for now) use the Import Tabular Data command.

To insert tabular data, choose File> Import~>Tabular Data. The Import
Tabular data dialog box opens, where you can enter the filename of the tab
delimited data file, set the delimiter type, and perform other table format-
ting. Turn to Book II, Chapter 1 for more info about importing tables.
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Sorting Information in a Table

Q‘“\NG!

Figure 6-11:
Select table
sorting
options.

Another great Dreamweaver table tool is the Sort Table command. Though
normally you’d sort your data prior to inputting it in a table in Dreamweaver,
you may want to improve the order of the information in your table after
populating the table cells. Use this sort command to sort your alphabetical
or numerical table data in either an ascending or descending order, such as
alphabetizing a list of client names or store addresses, or ordering a list of
items by their unique ID numbers.

Because Dreamweaver can only sort data along a single column of data,

this feature does not work on tables with colspan or rowspan attributes.
Therefore, you should perform this task before you merge or split any cells
in your table. The sorting command physically changes the order of the con-
tent in your tables.

With the table filled with your data selected, follow these steps to sort the
information in the table:

1. Choose Commands->Sort Table.
The Sort Table dialog box, shown in Figure 6-11, opens.

Sort Table

Sort by: | Column 1 v 2
Order: | Alphabetically ~ | Ascending hd Apply
Cancel

Then by:
Help

Order: | Alphabetically || Ascending »

Options: [ sort includes the first row
[ Sort header rows
[ sort facter rows

=] Keep all row colors the same after the sort has been completed

2. In the Sort By drop-down list, select which column you want to sort by.

For example, if your table has two columns, select either Column 1 or
Column 2.

3. In the two Order drop-down lists, choose whether you want to sort the
column alphabetically or numerically and in ascending (A to Z or 1 to
100) or descending (Z to A or 100 to 1) order.

To alphabetize a list, select Alphabetically and Ascending to sort your
data from A to Z.
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4. In the Then By list, choose another column number for a secondary
sort, or leave the field blank.

This option offers a second level of organization for your sort. For exam-
ple, you may want to sort a list of names by last name and then by first
name.

5. In the Options area, further refine your results:

¢ Sort Includes the First Row: Select this option if your table doesn’t
include headings, so the first row of data gets included in the sort. If
your table does include headings, leave this option disabled.

¢ Sort Header Rows: This option sorts all the rows in the table’s
thead, separate from the sorting of the data in the rest of the table.
To find out about the <thead> tag, open the Reference panel by
choosing Help=>Reference.

¢ Sort Footer Rows: This option sorts all the rows in the table’s tfoot,
separate from the sorting of the data in the rest of the table. To find
out about the <t foot> tag, open the Reference panel by choosing
Helpr>Reference.

¢ Keep All Row Colors the Same After the Sort Has Been Completed:
Select this option to have any row attributes stay with the data after
the sort. This option doesn’t work well with tables formatted with
alternating row colors; rather, this feature is best for tables that have
row attributes specific to the content in each row.

6. To see the sorting results before committing to them, click the Apply
button. If you’re satisfied with the result, click OK. Or to exit without
sorting, click Cancel.

@ If you like the new ordering, save the changes to the table.
b\
If you want to immediately revert the table contents to the order it was in
prior to the sort command, choose Edit=>Undo Sort Table.

Working with Tables Created by Other Programs

If you want to harness the power of another program to do much of the table
organization for you — especially with regard to graphics — several Web
optimization programs can help you convert your graphic layouts from flat-
tened artwork or layered files to a tables-based or CSS-layers-based HTML
file with sliced graphic images in each of the table cells or layers. Most
notable are ImageReady (which is being phased out by Adobe in favor of
using the built-in Save For Web & Devices dialog box inside Photoshop and
lllustrator) and Fireworks, but other programs do essentially the same thing.
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<P

In fact, there are now several Web services, like MarkUpNow.com and
psd2html.com that, for a modest fee, gladly convert your flat artwork into
standards-compliant, cross-browser compatible, valid page layouts com-
plete with optimized graphics, XHTML, CSS, and sometimes JavaScript!

When using an optimization program yourself, you’ll probably use a slice
tool to cut the graphic into slices, which in turn get converted into individ-
ual GIF, PNG, or JPEG files upon optimization. Many of these programs also
allow you to add JavaScript behaviors to the slices including rollover button
behavior, animation, and graphical styles or effects. After all these extras
have been applied to the slices in the optimization program, all the slices (or
selected slices) can be optimized and converted into HTML and CSS-ready
files. Typical options for exporting optimized graphics from an optimization
program include HTML and Images, Images only, CSS Layers, and HTML
only. After the optimization process is complete, you can bring the HTML
files and graphics into Dreamweaver for further editing.

For ImageReady-or Fireworks generated HTML files, which typically include
an index.html page and an attending images folder, move or copy these files
to a logical location on the local computer. Many Web designers organize
their Web files into one master folder containing separate HTML folders for
each Web site, as in the following example:

Hard Drive/Clients/ClientA/A_HTML
Hard Drive/Clients/ClientB/B_HTML
Hard Drive/Clients/ClientC/C_HTML

After the exported files are in the appropriate folder on your computer,
define (manage) a new Dreamweaver site, as described in Book I, Chapter 3.
Taking this step is essential to ensuring that you have access to all of
Dreamweaver’s managed-site tools. From within the managed site, open the
individual ImageReady- or Fireworks-generated HTML files and apply further
formatting, links, and so on.

Using Fireworks-generated HTML is slightly different and more sophisti-
cated than ImageReady and other optimization programs. For more about
Fireworks HTML and how to use it in Dreamweaver, see Book IIl, Chapter 5.



Chapter 7: Building Fabulous
Forms

In This Chapter

v Putting together a form
v+~ Adding fields to your form
1 Performing form validation with JavaScript

1 Performing form validation with Spry assets

F)rms are a great tool for collecting information from site visitors. Forms
allow users to request information, send comments and questions, sign
up for services or newsletters, fill out an online application, or enter pay-
ment information for purchasing products or services.

Before building a form for your Web page, spend some time figuring out
what data you need to collect and consider how to organize that data logi-
cally so your form is easy to understand and navigate. As a best practice, try
to keep the form length down and only request information that you really
need. Otherwise, you risk people leaving the page.

Forms, by default, are not secure documents. If you need your forms to be
secure — a must if you're collecting confidential personal information such
as a credit card or password — speak to your host provider about pur-
chasing an SSL (Secure Sockets Layer) digital security certificate of some
kind. SSL encrypts data and provides secure connections for e-commerce
and communication so your site visitors can feel confident that their per-
sonal information is protected and safe. VeriSign (www.verisign.com),
GeoTrust (www.geotrust.com), and Thawte (www. thawte.com) are the
most popular SSL encryption certificates.

Another option is using a third-party online credit card processing service,
such as PayPal or Authorize.net, which, for a minimal transaction fee, takes
on the risks of liability that comes with credit card processing.

You can do many other things to make your forms secure, such as creat-
ing a secure login script, using cookies, and creating XForms with XML, but
that falls a little beyond the scope of this book. To find out more about Web
security in general, visit the VeriSign, GeoTrust, and Thawte Web sites. For
more on XForms, visit the W3C (www.w3 .org/TR/xforms) and W3Schools
(www.w3schools.com/xforms/default.asp) Web sites.
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In this chapter, you find out how to create fabulous forms, validate them with
JavaScript, and submit them to your server for processing.

Organizing Data in Your Form

Figure 7-1:
A sample
form
requesting
billing
information.

Although you can’t nest forms inside other forms, you can have multiple
forms on a page, if needed. To organize your form data, use tables, line
breaks, paragraph breaks, and CSS formatting, just as you would anywhere
else on the page to make the form collection fields and labels look good.

One of the best ways to organize your form is to use a table. (See Book II,
Chapter 6 for the lowdown on creating tables.) Although you can build your
form in any order, it’s often easier to add all your form labels first before
adding form fields. For instance, in a two column, multi-row table, enter form
labels for name, address, city, state, ZIP, phone, e-mail, and so on down the
left column of cells, and then add all the form fields down the right column.
By labeling all the form fields, the users know what information to input or
select from. Figure 7-1 shows a simple form requesting billing information to
make a purchase.
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For more complex data collection needs, feel free to nest tables within tables
to further help with organization. For instance, you may have a section of
the form that describes an event as well as listing the event’s location and
date. If the data needs to be broken up into categories, it may benefit from
being organized inside a nested table.

Creating a Fabulous HTML Form

3

This section describes how to create an HTML form. If you want to use
Dreamweaver to make dynamic Web forms, turn to Book VIII, Chapter 4 for
more information.

When creating a form, you start by adding the <form> tag to an open docu-
ment. If you forget the <form> tag, Dreamweaver prompts you to add it
when you insert your first form field. Nevertheless, inserting the <form> tag
yourself before you build your form is a good habit to get into.

When a visitor enters information into your form and clicks the Submit
button, the data needs to go somewhere for processing. In most cases, that
somewhere is a server-side script or program, so be sure to check with your
host provider about what their Web server can handle so you choose the
correct scripting language. Forms are often processed with ASP, PHP, CGI,
and ColdFusion scripts. The script or program then processes the data and
responds by returning information back to the user, performing an action
based on the form’s instruction (like sending the user to a Thank You page),
or sending an e-mail directly to a specified e-mail recipient. Host providers
often have a forms processing method available as part of your hosting pack-
age, so be sure to check with your host provider for details and instructions.

To create a form and link it to a script, follow these steps:

1. Place the cursor where you want the form to appear on the page.
2. Choose Insert~>Form+>Form.

You can also click the Form button (which looks like a little square with
a dotted red outline) in the Forms category of the Insert panel.

In Design view, the <form> tag appears on your page as a dotted red
line in the shape of a large rectangle. In Code view, the inserted form tag
looks like this:

<form name="forml" method="post" action=""></form>

If you don’t see the dotted red line, which Dreamweaver considers an
invisible element that appears in Design view but doesn’t show up in the
browser, choose Viewr>Visual Aids and check that invisible elements are
enabled.

After you create the <form> tag, the Properties inspector displays the
form formatting options, as shown in Figure 7-2.
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3. Give your form a unique name by typing it in the Form ID text box in
the Properties inspector.
Names are important if you plan to add JavaScript or VBScript to control
the form in some way. If you forget to name the form, or don’t need to
add scripting, Dreamweaver uses the formn syntax to name your forms,
where n is equal to the number of each form that is added to a page,
such as id=form?2.
4. In the Action field, click the folder button to browse to and select the
script or file that will process the collected data in the form.
If the script is on the server, type the path to that script. For example,
many forms use CGI scripts located inside a CGI folder on the server, like
this script where the name email.pl should be replaced with the actual
name of your script filename:
<form name="forml" method="post" action="cgi-bin/email.pl"></form>
By default, the form field is inserted with the following information:
&QN\BE/? <form name="forml" method="post" action=""></form>
&

The CGI script is something that your host provider or system adminis-
trator provides you.

5. Choose a method for transmitting collected form data to the server
from the Method drop-down list:

¢ Default uses the browser’s default setting to send the data. Because
the default is usually — but not always — the GET method, it’s better
to specify GET or POST rather than using the default.
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e GET adds the value of the collected data to the URL requesting the
page, making this URL bookmarkable, and therefore vulnerable
to hackers. Also, because URLs can only have a maximum of 8192
characters, this method is not useful for long forms. GET is best for
repeatable, stateless form applications.

e POST hides the form data inside the HTTP request, preventing the
collected data page from being bookmarked. The data, however, is
not encrypted (it’s also vulnerable to hackers), so be sure to use a
secure connection to a secure server, especially if you're collecting
personal information such as credit cards, usernames, and pass-
words.

6. (Optional) In the Enctype drop-down list, choose the MIME encoding cﬁ:(’:‘e:z
type of the data being sent to the server. i

By default, this field is blank. Select application/x-www-form- o

urlencode as the default type for the POST method, or when adding =

a file-upload field to a form, select the multipart/form-data MIME o3

type. 3 3

U=

If you're unsure of what to select here, leave the field blank and check %

with your host provider or system administrator for assistance. Z

7. Set the target browser location for any returned data or documents in
the Target drop-down list:

e _blank: Display the returned document or data in a new browser
window.

e _self: Display the returned data in the same window.
e _top: Use the current open window even if other windows are open.

e _parent: Use the parent window of the current file.

You have now completed the preliminary steps for adding a form to your
page. The dotted red line marks the boundaries of your form. Within this
border, you can add form objects, such as text fields, check boxes, radio but-
tons, lists, menus, and so on, as described in the next section. If you plan to
organize your form objects inside a table, now is the time to add the table to
your page. (See Book II, Chapter 6 for details on creating tables.)

Adding and Labeling Form Fields

Dreamweaver calls all the form input fields form objects. These are what
you use to collect data from the site visitor. The following sections provide
descriptions for adding each of the form objects to your form and custom-
izing them with their respective property setting options.
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Text fields

Use text fields to collect text or numerical data, such as a name, address,
telephone number, e-mail address, or password.

Inserting a text field

To insert a text field in your page, follow these steps:

1. Place your cursor inside the form area on your page where you want
to insert a text field.

For example, if you've already inserted form tags and created a table
inside the form tags with labels to indicate the data you will be collect-
ing in the form, place your cursor in the table cell (next to the cell con-
taining the first form label) where you intend to insert the first text field.

If you haven’t yet created a form, see the earlier section, “Creating a
Fabulous HTML Form.”

2. Choose Insert=>Form=Text Field.

You can also click the Text Field button in the Forms category of the
Insert panel.

If form accessibility preferences are turned on, the Input Tag Accessi-
bility Attributes dialog box opens, prompting you to enter accessibility
attributes to the form field. Complete the dialog box and click OK to
insert the image or press Cancel to insert the field without accessibility
attributes.

3. In the TextField box in the Properties inspector, enter a name/ID for
the text box.

All text fields need a unique name for the form to work properly. Names
can contain numbers and letters as well as the underscore character,
but can’t include any spaces or special characters. Figure 7-3 shows an
example of a form layout including the form tag (red dotted outline),
form labels (Name, Address, Phone, and so on), and form fields to col-
lect data. The Properties inspector shows the properties for the Address
field, as shown in Figure 7-3.

This text field name is the variable that stores the value of the field
(which is the data the user inputs), and is sent to the server for pro-
cessing. For example, a text field with the name Address and corre-
sponding input by a user of 123 Main St.may be returned to you as
Address=123 Main St.
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4. In the Type area, indicate whether you want the text field to be a
single-line, multi-line, or password field:

¢ Single Line uses the <input> tag with the type=text attribute.

e Multi Line creates multi-line text input fields. Multi-line fields use the
<textarea> tag with the cols attribute for character width and the
rows attribute for number of lines.

¢ Password, which uses the <input> tag with the type=password
attribute, makes asterisks or bullets appear when typing inside the
form field in a browser. The data, however, is not encrypted. To
provide encryption, talk to your host provider about buying an SSL
certificate.

Figure 7-4 shows examples of the three types of text fields.
S\r.ugle hr.|e
Figure 7_4: Single line
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5. In the Char Width box, enter the maximum number of characters that
you want displayed in the text field.

This determines the width of the text input field. Additional characters
may be accepted, but not displayed, depending on the value entered in
the Max Chars field. Controlling the width of an input field with CSS is
better than inputting a number here in the HTML code because different
browsers interpret this attribute in different ways.

6. In the Max Chars field, enter the maximum number of characters that
can be entered into the text field.

This is especially useful for limiting phone numbers to ten digits, ZIP
codes to five digits, or other data that requires a limited number of char-
acters. If a visitor enters more characters than defined by this field, the
browser tells the computer to make an alert sound.

7. In the Num Lines box (for multi-line only), the height is determined by
the number of lines entered here, such as 4 for a multi-line text field
that is four lines high.

8. (Optional) In the Init Val box, enter any text that should appear inside
the form object when the page loads.

This text can then be replaced with information from the user.

9. (Optional) From the Class drop-down list, choose a CSS to apply to the
form object.

For example, you may have created a custom CSS for all your text input
fields. Choose the style from the menu to apply it.

Inserting a text area

A text area object is exactly the same as a text field object set to multi-line,
only you don’t need to set the Multi-line type in the Properties inspector
yourself. Like the text field object, the text area object has fields for you to
specify character width and number of lines as well as entering any initial
value text to appear inside the field when the page loads and setting the
wrap preferences, as described in the preceding section.

Hidden fields

For times when you need to hide information from the site visitor while pro-
viding information about the form to the server during form processing, or
for when you want to store information entered by a user, add hidden fields
to your form. For example, you can use a hidden field to specify an e-mail
address or subject with an input name and value such as the following:

<input name="recipient" type="hidden" id="recipient" value="contact@example.com">
<input name="subject" type="hidden" id="subject" value="usercomments">
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To insert a hidden field in your form, open your document and follow these
steps:

1.

Place your cursor inside the form area on your page where you want
to insert a hidden field.

Hidden fields are typically placed right after the opening <form> tag.

If you haven’t yet created a form, see the earlier section, “Creating a
Fabulous HTML Form.”

Choose Insert~>Form=>Hidden Field.

You can also click the Hidden Field button in the Forms category of the
Insert panel.

The Properties inspector, shown in Figure 7-5, shows the properties for
the hidden field.
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3.

In the HiddenField box in the Properties inspector, enter a name/ID
for the field.

The name/ID labels the hidden field, such as Redirect, Recipient,
Subject, or Title.

4. In the Value field, enter a sentence, e-mail address, URL, or other

information.
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The following are examples of hidden fields, including type (hidden)
name, and value:
<input type="hidden" name="Redirect" value="http://www.example.com/
thankyou.html">

<input type="hidden" name="Recipient" value="info@example.com">
<input type="hidden" name="Subject" value="Brochure Request">

Check boxes

Check box fields allow users to specify multiple responses when presented
with a single question. You can add as many check boxes to the form as you
want to support the question being asked. Figure 7-6 shows an example with
four check boxes.
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To insert a check box in your form, follow these steps:
1. Place your cursor inside the form area on your page where you want
to insert a check box.

If you haven’t yet created a form, see the earlier section, “Creating a
Fabulous HTML Form.”

2. Choose Insert>Form=>Checkbox.

You can also click the Checkbox button in the Forms category of the
Insert panel.
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3. In the Properties inspector, enter a name for the check box in the
Checkbox Name field and a value in the Checked Value field.

When listing multiple questions with check boxes on a form, be sure to give
each check box set a unique name to identify it within the form. The name
must not have any spaces or special characters in it, but the checked value
can contain letters, numbers, and spaces, as in the following:
<input name="chkGrapes" type="checkbox" value="Likes grapes"
checked="checked"> Grapes
<input name="chkBanana" type="checkbox" value="Likes bananas"

checked="checked"> Bananas
<input name="chkApple" type="checkbox" value="Likes apples"> Apples

4. Select the initial state of the check box to be either checked or
unchecked.

5. Repeat Steps 2 through 4 to insert additional check boxes.

Another way of adding checkboxes to your forms is to use the Checkbox Group
button, which launches a dialog box to build an entire check box group rather
than making buttons one at a time. All the same rules apply to check box groups
as to check box buttons with the added benefit of having Dreamweaver write
<label> tags for you to identify the text associated with the check box button.
When you launch the Checkbox Group dialog box, simply enter labels and
values for each button, name the group, and select a layout type.

To insert a check box group in your form, follow these steps:
1. Place your cursor inside the form area on your page where you want

to insert a check box group.

If you haven’t yet created a form, see the earlier section, “Creating a
Fabulous HTML Form.”

2. Choose Insert->Form=>Checkbox Group.

You can also click the Checkbox Group button in the Forms category of
the Insert panel.

The Checkbox Group dialog box opens (see Figure 7-7).

3. In the Checkbox Group dialog box, enter a name for the Checkbox
button Group in the Name field.

The group name identifies all the buttons as belonging to the same
group and adds the same name attribute (such as name="magazines")
to each button.

4. In the Label column, type a label for each check box button in the
group.
Each item in the list represents a button in the check box group.

To add new buttons, click the plus (+) button. To remove any buttons,
select the item to be removed from the list and click the minus (-)
button.
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To reorder the buttons listed in the group, select a button from the list
and click the up or down arrows.

5. In the Value column, type a checked value for each check box button
in the group.
The checked value represents the value that is submitted as the
selected choice for this radio group, such as a particular magazine.

6. Choose Line Breaks or Table as the layout option for the checkbox
group.

The buttons that are inserted onto your page can be separated by line
breaks or by table cells.

7. Click OK to insert the check box group on the page.

8. Select one (or more) of the buttons in the group to be checked by
default by entering the initial state as checked in the Properties
inspector.

Use the Properties inspector to make further adjustments to the check
box buttons in the group.

Radio buttons

Radio button fields allow users to specify either/or choices when presented
with a question. You can have as many radio buttons as you want for any
question, but the user can only select one answer.

Inserting radio buttons one at a time

To insert a radio button in your form, follow these steps:
1. Place your cursor inside the form area on your page where you want
to insert a radio button.

If you haven’t yet created a form, see the earlier section, “Creating a
Fabulous HTML Form.”
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2. Choose InsertvForm=>Radio Button.

You can also click the Radio Button icon in the Forms category of the
Insert panel.

3. In the Properties inspector, enter a name for the radio button in the
Radio Button field and enter a value in the Checked Value field.

\sg,N\BER A group of radio buttons must have the same name but different values

& to make the selection mutually exclusive. Therefore, provide the same
name to each radio button in your list and add a word in the Checked
Value field to match the question being asked. You should also set one
of the radio button’s initial state value to checked. For instance, if asking
people to choose their preference for beef, chicken, or vegetarian, the Book Il
name for each radio button would be meal and the value for each is Chapter 7
equal to the individual meal choice, and if they fail to make a selection

on their own, they’ll get beef, as in the following example: =
<input type="radio" name="meal" value="beef" checked="checked"> - E‘
<input type="radio" name="meal" value="chicken"> ea
<input type="radio" name="meal" value="vegetarian"> |0
U=
=
Figure 7-8 shows how to configure the radio buttons using the Properties S
. &
inspector.
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4. Select an option to set the initial state of the radio button to checked
or unchecked.

The radio button doesn’t actually show a check mark; rather, it displays
with a small dot in the center to indicate that it’s been checked (selected).
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Figure 7-9:
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5. Repeat Steps 2 through 4 to insert additional radio buttons.

Make sure that radio buttons are always used in sets of two or more.

Then be sure to only check one radio button as checked by default; if
you specify more than one button with a checked value, it can create
problems with data collection.

Inserting a group of radio buttons

The Radio Group button launches a helpful dialog box to help build an
entire radio group all at once rather than creating a group of buttons one
button at a time. In a group, only one option can be selected, whereas with
individual buttons you could theoretically select them all. Selecting multiple
buttons defeats the purpose because radio buttons are intended to be used
as either/or selection fields. All the same rules apply to radio groups as to
radio buttons with the added benefit of having Dreamweaver write <label>
tags for you to identify the text associated with the radio button. When you
launch the Radio Group dialog box, simply enter labels and values for each
button, name the group, and select a layout type.

To insert a radio group in your form, follow these steps:
1. Place your cursor inside the form area on your page where you want
to insert a radio group.

If you haven’t yet created a form, see the earlier section, “Creating a
Fabulous HTML Form.”

2. Choose Insert->Form=>Radio Group.
You can also click the panel.

The Radio Group dialog box opens (see Figure 7-9).
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3. In the Radio Group dialog box, enter a name for the radio button Group.

The group name identifies all the buttons as belonging to the same
group and adds the same name attribute (such as name="dessert") to
each button.
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4. In the Label column, type a label for each radio button in the group.
Each item in the list represents a radio button in the radio group.

To add new buttons, click the plus (+) button. To remove any buttons,
select the item to be removed from the list and click the minus (-)
button.

To reorder the buttons listed in the group, select a button from the list
and click the up or down arrows.

5. In the Value column, type a checked value for each radio button in
the group.

The checked value represents the value that is submitted as the
selected choice for this radio group.

6. Choose Line Breaks or Table as the layout option for the radio group.
The buttons can be separated by line breaks or by table cells.
7. Click OK to insert the radio group on the page.

8. Select one of the buttons in the group to be checked by default by
entering the initial state as checked in the Properties inspector.

Use the Properties inspector to make further adjustments to the radio
buttons in the group.

Lists and menus

The List/Menu form object creates both list and menu type form fields. Use
this object to provide a list or menu that allows users to make a selection
within the form, such as a state or country.

To insert a list or menu in your form, follow these steps:

1. Place your cursor inside the form area on your page where you want
to insert a List/Menu object.

If you haven’t yet created a form, see the earlier section, “Creating a
Fabulous HTML Form.”

2. Choose InsertoForm=>List/Menu.

You can also click the List/Menu button in the Forms category of the
Insert panel.

If you enabled Accessibility features, the Input Tag Accessibility
Attributes dialog box opens. Complete the dialog box and click OK to
insert the List/Menu object or press Cancel to insert the field without
accessibility attributes.

3. Click the List Values button in the Properties inspector.

The List Values dialog box opens. You use this dialog box to add labels
and values to your list or menu (see Figure 7-10).
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Figure 7-10:
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e Item Label: This text appears as a selection in the list.

To add new list items, click the plus (+) button. To remove any items
from the list, select the item to be removed and click the minus (-)
button. To sort items, select an item from the list and click the up or
down arrow.

e Value: This value is returned with the collected data when the item
is selected, as in CA for California.

After you add all the items to your list, click OK to close the List
Values dialog box.

4. With the list/menu object still selected, select a list Type in the
Properties inspector.

Choose List to make a drop-down list or Menu to make a box that dis-
plays the options to choose from.

5. In the Height box (for List type only), enter a number to represent the
number of lines to be displayed in the list.

If the contents of the box exceed the box height, scroll bars appear.

6. (Optional) Click the Allow Multiple Selections option to allow users to
Shift-click when making multiple selections from the list or menu.

7. In the Initially Selected field, select any one item in the list/menu to
display as the initial item, such as Select a State.

Jump menus

Use jump menus to create a list of items that a visitor can select from, and
once selected tell the browser to jump to another page or URL. Jump menus
automatically add the necessary JavaScript behaviors required to instruct
the browser to go to another page. This type of menu can be a useful tool for
quick navigation on a Web site.

To find out how to set up a jump menu, see Book IV, Chapter 2.
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Image fields
The Image Field option inserts an image into the form, for times you may
prefer to use your own graphic for a Submit button or other form input field.

<MBER
é'é
Images in forms become clickable Submit buttons by default, unless you
apply a different JavaScript to the image.
To add an image field to your form, follow these steps:
1. Place your cursor inside the form area on your page where you want
to insert an image field.
If you haven’t yet created a form, see the earlier section, “Creating a
Fabulous HTML Form.”
2. Choose Insert->Form=>Image Field.
You can also click the Image Field button in the Forms category of the
Insert panel.
The Select Image Source dialog box appears.
3. Browse to and select the image you want to add to the form.
If you enabled Accessibility features, the Input Tag Accessibility
Attributes dialog box opens. Complete the dialog box and click OK to
insert the image or press Cancel to insert the field without accessibility
attributes.
The image is inserted onto your page, as shown in Figure 7-11.
dfd_forms.hml % T
ofcoe [ < spie | [ oeson || #[uve view |+ | Tile: | Unttied Document o,
A 5 A g r
M— e
Title
campany
*Address:;
Address 21
City
......... g B
L *Zip Code:
¥ Country if outside U.$. 1| United States e
*Day Phone: HEnt
*Email}
e T i
. Please send me :a-'@' Vs Ho ™
Figure 7-11: RIS
With the
Image Field | :
form object, body> <Form#ExampleContact > <table> <tr> <td.body> <lbel> [<input#submit>| | & &9 C4 [100% | 777 x 496+ 28K 4 s WeslemEump;an
PROPERTIES | =|
yOU canuse ImageField, 2K St images/submit.jpg D) Align | Default [v] Coss/body |w @
your own bt A Sgn ve L &

graphics.

Book Il
Chapter 7

Suuo4
snojnqey Buipjing



186 Adding and Labeling Form Fields

4. In the Alt field in the Properties inspector, enter Alternate text for the
image.

Typically, the text in the Alt field mirrors the text on the button graphic.

5. (Optional) From the Align drop-down list, select an alignment option
for the graphic.

Alignment options include Default, Top, Middle, Bottom, Left, and Right.

6. (Optional) From the Class drop-down list, choose a CSS style to apply
to the form object.

For example, you may have created a custom CSS style for all your text
input fields. Choose the style from the menu to apply it.

7. In the ImageField field, enter Submit or Reset to use the image as a
Submit or Reset button.

Alternatively, you can give your button a unique name to use the button
with a JavaScript behavior. For example, you can create a button that,
when a visitor presses it, runs a script to launch a pop-up window.

File upload fields

Add afile field to your form when you want to allow visitors to search for a
file on their own computers and upload it to the server. When adding a file
field, Dreamweaver inserts a text field with a Browse button next to it.

To use a file field on a Web page, you must make sure your server has a
server-side script that can accept this type of data submission. File fields
require the POST method for transmitting files from the browser to the
server. Select enctype="multipart/form-data" as the encryption type
for the form. The data is posted to the address in the form’s action field; you
can use a regular HTTP URL as the value as long as your application has the
right server permissions to be able to write files accepted this way.

Be sure to test this feature in your target browsers before publishing the page,
as the file field displays very differently in different browsers: Safari, Internet
Explorer, Opera, and Firefox all have very unique ideas about how to handle this
field, including how much space they take up and what words are displayed.

To insert a file field in your form, follow these steps:
1. Place your cursor inside the form area on your page where you want

to insert a file field.

If you haven’t yet created a form, see the earlier section, “Creating a
Fabulous HTML Form.”

2. Choose Insert=>Form=File Field.

You can also click the File Field button in the Forms category of the
Insert panel.
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If you enabled Accessibility features, the Input Tag Accessibility
Attributes dialog box opens. Complete the dialog box and click OK to
insert the file field, or press Cancel to insert the field without accessibil-
ity attributes.

3. In the Properties inspector, enter the following attributes:
e FileField Name: Enter the name for the file field.

e Char Width: Enter a number of characters to set the width of the
file field.

e Max Chars: Enter the maximum number of characters that a visitor
can enter into the file field.

e Class: If you've created a custom CSS style to format this field,
select it by name from the Class drop-down list.

Buttons

Add a form button to your form for visitors to click when they’re ready to
submit data or trigger other form processing operations. Typical form but-
tons are labeled as Submit, Reset, or Send, but you can create buttons with
other labels that perform other tasks such as calculating shipping charges
based on a user’s geographical zone.

To create a button, follow these steps:
1. Place your cursor inside the form area on your page where you want

to insert a form button.

If you haven’t yet created a form, see the earlier section, “Creating a
Fabulous HTML Form.”

2. Choose Insert=>Form=Button.

You can also click the Button icon in the Forms category of the Insert
panel.

If you enabled Accessibility features, the Input Tag Accessibility
Attributes dialog box opens. Complete the dialog box and click OK to
insert the button, or press Cancel to insert the button without accessi-
bility attributes.

The Properties inspector shows the properties for the button, as shown
in Figure 7-12.

3. In the Button Name field in the Properties inspector, enter a name for
your button.

4. In the Value field, enter the text to appear on the button face.

For instance, if you want a button that says Join Mailing List, type Join
Mailing List.
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5. (Optional) From the Class drop-down list, select a custom CSS style to
apply to the button.

6. Choose an action from the Action field:

e Submit: This default form button type submits the collected data to
a script or processing application on the server. Submit buttons can
have any label as long as the Action type in the Properties inspector
is set to Submit.

¢ Reset: A Reset form button clears the form fields by returning the
form to its original state. You can label reset buttons with any text.
Choose the Action type in the Properties inspector to reset the form.

e None: A third option creates a button with customized text that you
can attach a behavior to, such as a Go button for a jump menu. Select
None as the Action type in the Properties inspector and apply a
JavaScript behavior using the Behaviors panel (see Book IV, Chapter
2 for more about behaviors).

Label tags

The <1label> tag is used for enhancing accessibility attributes. When the
<label> tag wraps around another form item, not only can screen-reader
software read the label, but a focus rectangle surrounds both the label and
form field in some browsers, which allows the user to click anywhere inside
the text and form field area to select it. This grouping is especially helpful
when using radio buttons and check boxes!
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If you label your objects without the <label> tags, the label isn’t associated
with the form object, as in the following sample code:

<input name="Dessert" type="radio" value="Apple" checked="checked" />Apple
Crumble

With the <label> tags, however, the label is associated with the form
object, as in the following:

<label><input name="Dessert" type="radio" value="Apple" checked="checked" />Apple
Crumble</label>

If you've enabled Accessibility preferences, the Input Tag Accessibility
Attributes dialog box automatically appears any time you insert a form
object on your page. There you can wrap your object with the <1abel> tag.

To insert a <label> tag in your form after you add objects to your form,
follow these steps:

1. Place your cursor inside the form area on your page where you want
to insert a <label> tag.

If you haven’t yet created a form, see the earlier section, “Creating a
Fabulous HTML Form.”

2. Choose Insert=>Form=>Label Field.

You can also click the Label Field button in the Forms category of the
Insert panel.

The <label> tag is inserted into your page code, as shown in
Figure 7-13.

If you're adding a <label> tag to an existing form object, such as a check
box or radio button, check the code to ensure that the label for the form
object sits between the opening and closing <1abel> tags.

Fieldset tags

A <fieldset> tagis used as a container for other form objects. Use
fieldsets to define multiple fields into logical groups within the form. For
instance, one fieldset may include text input fields for name and e-mail infor-
mation, and another fieldset may include username and password informa-
tion (see Figure 7-14).
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You can use the <legend> tag with the <fieldset> tag to label each field
set, as in the following example:

<form method="post" action="...">
<fieldset>
<h2>

<legend>Contact Information</legend>
</h2>
<label>
Name :
<input name="name" type="text" id="name" />
</label>
<br />
<label>Email:
<input name="email" type="text" id="email" />
</label>
</fieldset></form>

These tags create a very interesting look in a browser. Figure 7-15 shows
how the example appears in Firefox on a PC.

‘& Fieldset and Legend Demo - Mozilla Firefox ==
File Edit Yiew History Bookmarks Tools Help

— Contact Information

Mame
Emenl

— Username and Password Information

Tser MName:
Password:

To insert <fieldset> and <legend> tags, follow these steps:
1. Open a file containing a form in which you want to insert <field-
set> and <legend> tags.

If you haven’t yet created a form, see the earlier section, “Creating a
Fabulous HTML Form.”

2. Select all the form elements that you want to group inside the
<fieldset> tags.

3. Choose Insert->Form=Fieldset.

You can also click the Fieldset button in the Forms category of the Insert
panel.

The Fieldset dialog box opens.
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4. In the Fieldset dialog box, enter a name for the legend and click OK.

The legend is like a heading for the objects grouped inside the <field-
set> tags.

Dreamweaver wraps the selected content with <fieldset> and
<legend> tags. After the <fieldset> and <legend> tags have been
added to your code, you can style the content with CSS.

As an alternative to the legend and fieldset tags, consider using div tags and
CSS, which provide greater control for spacing, margins, background, colors,
fonts, and so on.

Validating a Form with JavaScript

If you've ever filled out a form and gotten a pop-up message back from

your browser that says you filled out the form incorrectly or that you
missed entering data in a field, you’'ve witnessed form validation in action.
Validation can be performed dynamically with PHP, ASP, JSP, or ColdFusion
code. However, for most non-dynamic sites, a simple JavaScript Validate
Form action does the trick.

The Validate Form behavior cross-checks all the fields against the validation
rules you specify to ensure that the user entered the data correctly. This
way, you can check the form on the client side for completion and accuracy
before the server collects the data.

You can attach validation events to as many fields in the form as you want. A
couple of validation events are
4+ onBlur: Validates individual fields as the form is being completed

4 onSubmit: Reviews the entire form input data all at once
To validate a form with the Validate Form action, follow these steps:
1. To validate the entire form, select the form’s <form> tag, or to vali-

date an individual field, select that form object.

2. Open the Behaviors panel (which is technically a tab on the Tag
Inspector panel) by choosing Window=>Behaviors.

3. Click the plus (+) button in the Behaviors panel and choose Validate
Form from the Add Behavior pop-up menu.

The Validate Form dialog box opens, as shown in Figure 7-16, showing a
list of all the named fields in your form.
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4. Select a form input field from the Named Fields listing, and then
choose a setting for it:

¢ Value Required: Enable this option when the field must contain data
of some kind, rather than stay blank.

¢ Accept Anything: If this option is selected, the selected field must
also be set to Required so that a user can input any type of data into
the form field.

¢ Accept Email Address: Select this option to have the validation
script verify that the field contains the @ symbol.

e Accept Number: Select this option to have the validation script
check that this field contains numbers only.

e Accept Number From/To: When this option is selected, you can
specify a range for acceptable numbers.

When validating the entire form, you must set a value and accept an
option for each field in the form.

5. Repeat Step 4 for every form input field in your form.
6. Click OK.

Dreamweaver adds the Form Validation JavaScript code to the <form>

and <head> tags. When validating an entire form, the onSubmit validation
event automatically displays next to the Validate Form Events menu in the
Behaviors panel. If validating only a single field, the default validation event
is either onBlur or onChange.

Validating a Form with Spry Assets

Like JavaScript validation, Spry validation is another cool new way to vali-
date your forms, only this way uses the more advanced tools in the Spry
framework. The Spry framework, which you find out more about in Book IV,
Chapter 2, is a library of JavaScript that helps Web designers with a basic
understanding of HTML, CSS, and JavaScript build XLM rich Web pages that
provide more interactive experiences for site visitors.
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Spry validation form fields, or widgets, include the Text Field, Textarea,
Checkbox, Select (Menu), Password, Confirm, and Radio Group. To use
these widgets, you need to insert the Spry fields into your form instead of
inserting the regular HTML form field tags. After you've inserted these Spry
fields, you’ll customize how each field validates data, and if desired, modify
the look and feel of how the field appears in the browser, as all of the Spry
Validation widgets are styled with an external CSS file (such as SpryAssets/
SpryValidationTextField.css) that is automatically added to the root level
of your managed site when you insert the first Spry Validation form field.

In addition to the CSS file, an adjoining JavaScript file is also added to your
managed site (such as SpryAssets/SpryValidationTextField.js).

To get the most use out of the Spry Validation form fields you need a

firm understanding of HTML, CSS, and JavaScript. Spry widgets are more
advanced Dreamweaver tools intended for the experienced Dreamweaver
user. As such, the following information includes general guidelines

for using the Spry Validation tools. For detailed online help and infor-
mation about working with Spry Validation, see help.adobe.com/
en_US/Dreamweaver/10.0_Using/WS2442184F-3DF4-4240-96AF-
CC6D792E2A62a.html.

All of the Spry Validation widgets are located at the bottom of the Forms cat-
egory of the Insert panel, as shown in Figure 7-17.
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All of the Spry Validation fields can be inserted in the same way. What

is different about each of them is how they are styled and the kind of
interactive opportunities they offer to site visitors. For example, with the
Spry Validation Text field, visitors can be prompted to enter the correct
date format and see an error message (“Invalid format” or “The value is
required”) when the format entered does not match the formatting hint you
provided or no input is made to the field, as shown in Figure 7-18.

Figure 7-18:
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QNING/ As you insert each of the Spry Validation fields, Dreamweaver saves a linked
N SpryAssets CSS and JavaScript file into your managed site. These files must
be uploaded to the server along with the page(s) using the Spry Validation
fields for the Spry Validation form fields to function properly in a browser.

To insert any of the Spry Validation Fields into your page, follow these steps:

1. Place your cursor inside the area in your form where you want to
insert a Spry Validation Field.

2. Click the desired Spry Validation Field button on the Forms category
of the Insert panel.

If the Input Tag Accessibility Attributes dialog box opens, complete the
fields and click OK.

The selected Spry Validation Field is automatically added to the page

in the specified location. The Spry Validation form fields look like their
regular HTML form field counterparts, except the Spry versions are sur-
rounded by a blue outline and tab that identifies the form field as a Spry
Validation form field.
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5.

6.

You can also insert any of the Spry Validation form fields by selecting
Insert>Spry=> and then choosing the desired option from the submenu.

Select the new Spry Validation field in Design view to customize the
field in the Properties inspector.

Like the normal form field, you can set parameters for the Validation
field with the Properties inspector.

Select the Validation field’s tab to set the validation Type and Format
in the Properties inspector.

When you click the Validation field’s tab, a different set of information
appears in the Properties inspector. You'll need to set the correct type
and format to match the data you intend to collect from site visitors,
such as a phone number, currency, dates, or credit card information.

For a complete listing of Types and Formats, see help.adobe.com/
en_US/Dreamweaver/10.0_Using/WS455A2B6C-8E96-4879-8195-
4B47394B9BA3a.html.

Specify when the validation event will occur.

Select Blur, Change, and/or Submit. Select as many as you like, or dis-
able them all.

e Blur: The field validates when the user clicks outside the field.

¢ Change: The field validates while the user enters text inside the
field.

e submit: The field validates when the user submits the form.
Set other options as required by the Validation field.

For example, when you select the Spry Validation Text Field tab, other
options include setting the minimum and maximum number of characters,
min and max values, whether to display preview widget states, change
required status of a field, create a hint, or block invalid characters.

After the Spry Validation field is inserted and its properties are set in the
Properties inspector, the field’s style and error message (if any) can be cus-
tomized in the CSS. Finding the right field can be a bit tricky on your own, so
be sure to consult the online help files to ensure you're editing the correct
CSS style.

To find the correct CSS and learn more about advanced styling, go to www.
adobe.com/go/learn_dw_spryselect_custom.
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Chapter 1: Looking Good with
Cascading Style Sheets (CSS)

In This Chapter

v+~ Understanding Cascading Style Sheets

v Creating internal and external style sheets
1 Creating new CSS styles

1 Editing, renaming, and deleting styles

1 Attaching Design Time Style Sheets

v Using the Code Navigator

Cascading Style Sheets (CSS) are a recommended standard from the
World Wide Web Consortium (W3C) to provide Web designers with
more control over the layout and appearance of HTML and XML files.
Cascading Style Sheets perform a similar function as formatted text in a
word processor. You can set default formatting for particular styles such as
paragraphs and headings. You can also create your own custom styles for
text, graphics, tables, and more, plus create styles that control the format
and position of block-level assets like margins and borders.

With CSS, you can control things like

4+ Fonts, font sizes, font styles, and font colors
Line spacing and letter spacing

Margins, padding, indenting, and outdenting
Background images and colors

Border style, width, and color

List and link formatting

Size, alignment, positioning, and visibility of elements on the page

YER IR SR R

Page breaks, filters, and cursor visual effects

Dreamweaver CS4 formats text with Cascading Style Sheets (CSS) as the
default text styling method (instead of HTML tags), as CSS has been imple-
mented in all modern browsers including Microsoft Internet Explorer, Safari,
Firefox, Opera, Netscape Navigator, and Mozilla.
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You'll enjoy these benefits with CSS:

4+ Style sheets separate content from the style and formatting information.

4 Style sheets simplify HTML code and file size (because all the styling
information is contained in one location — either the head of the file
or in an external style sheet — rather than inline with the text) without
compromising the structure of the content.

<+

Style sheets give you more control over the presentation of your pages.

4+ Using style sheets means your HTML files have faster download times
across multiple browsers.

4+ You have a centralized location for the Web site design, so you can
change an entire site’s look by changing just one file.

4+ Site visitors with disabilities have better access to pages using CSS.

4+ Older browsers can still view pages.

This chapter presents an overview of Cascading Style Sheets, including the
difference between internal, external, and inline style sheets. You discover
the three general types of styles and how to create, edit, rename, and delete
your own CSS using the Dreamweaver CSS Styles panel. You also find a full
explanation of the categories of the CSS Rule Definition dialog box, plus
when and how to use Design Time CSS.

Understanding Cascading Style Sheets (CSS)

In the early days of the Internet, how the content looked was largely the
work of specialized formatting tags used inside the HTML code, such as
<font face="Arial" size="2">, which would instruct a browser to dis-
play the text in a specific font (Arial) and size (2). With the advent of HTML 4
in late 1997, however — which began supporting Cascading Style Sheets and
scripting, among other great enhancements — most formatting is now writ-
ten with style sheets, either inside the HTML document itself or outside the
document in an external style sheet file.

Cascading Style Sheets (CSS) separate form from content by taking control
over the appearance of the text through specification of font style, font

size, text color, and alignment, as well as positioning and additional format-
ting attributes for other elements such as images, tables, layers (called AP
Elements in Dreamweaver), and forms. HTML can now primarily be used for
organizing content, whereas the external CSS typically has all the formatting
and positioning instructions.
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One of the great benefits of separating form from content with CSS style
sheets is that when you need to make formatting changes, rather than modi-
fying the style attributes inside the HTML code for every page, you only
need to edit the CSS file. As you find out in the following sections, CSS code
can be placed in any of three locations: inline with the HTML, internal in the
head of your HTML file, or as an external file that is linked to all the pages on
your site. External CSS is the preferred method of professional Web design-
ers because it is the most organized and flexible way to format content.

For example, a sentence using the old <font> tag with face, size, and color
attributes looks like this:

<p><font="Verdana, Arial, Helvetica" size="2" color="#990000">Do an Internet
search to find the best restaurants in your neighborhood.</font></p>

In comparison, using a style sheet that defines a custom style called .restau-
rants with attributes of Verdana, 12px, #990000 looks like this:

<style type="text/css">

<!l--

.restaurants {
font-family: Verdana, Arial, Helvetica, sans-serif;
font-size: 12px;
color: #990000;

}

-=>
</style>

and when applied to the same sentence, the sentence code simply looks like
this:

<p class=""restaurants">Do an Internet search to find the best restaurants in
your neighborhood.</p>

When you place the CSS in an external file, you can simply upload the
revised CSS to the hosting server to change the look of your entire site.
By contrast, when HTML styles are used and you want to make a site wide
change, all the pages on the site must be modified before uploading to the
server.

Another great feature about CSS is that style sheets allow you to somewhat
control what site visitors see when they visit your page regardless of the
platform they are browsing in. Like the old HTML tags, CSS styles override
default browser font face and font size settings, but in a much cleaner way.
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Exploring Different Style Sheet Types

\\3

Figure 1-1:
The HTML
formatting
options

in the
Properties
inspector.

Dreamweaver CS4 uses CSS, rather than HTML tags, as the default method
for editing text. If you like, you can still use HTML tags for styling your text
by applying attributes to selected content through the HTML tab on the
Properties inspector, or of course, by hand editing the code with the old
HTML tags. The trend, however, is to use CSS.

You can place your style sheet information in three different locations, rela-
tive to the HTML code, that allow it to work properly:

4+ Inside the document. You can create an internal style sheet through the
CSS Styles panel and automatically add styles in between the <head>
tags of the document through the CSS tab of the Properties inspector.

4+ Outside the file in a separate CSS file. You can create an external style
sheet through the CSS Styles panel and then link it to your document.

4 Inline, putting the CSS markup right next to the HTML. You need to
know the proper syntax to add inline CSS so you can manually type the
style code in the HTML.

You can use all three style sheet types (internal, external, and inline) in com-
bination with one another. For instance, you may have some internal styles
and an external style sheet linked to the same document, plus an inline style
or two throughout the code. You may even use multiple style sheets on a
page or in an entire site, if it suits your needs. Just remember that whatever
styles are closest to the content typically (though not always) take prece-
dence over styles that are farther away.

Internal styles

After adding text to a Web document, you can apply certain styling attri-
butes to your text with the formatting options on the HTML and CSS tabs of
the Properties inspector. The options on the HTML tab add HTML markup
to your code, and the options on the CSS tab add CSS markup to either the
head area of your open document or to an external style sheet. Figure 1-1
shows the HTML tab options and Figure 1-2 shows the formatting settings on
the CSS tab.

PROPERTIES |

HTML Format |None w| s none v| B 5 =i emas
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Page Properties.
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Figure 1-2:
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. HTML Targeted Rule | body » Fort | Default Font v B I EEEESE
formatting

css 55 Panel Sige |None  |w Q
tabinthe

Properties
inspector.

The HTML Properties inspector settings add formatting tags to the HTML code:

Format ID

Class Link

Bold (Strong) Italic (Em)

Unordered List Ordered List
Indent/Outdent List Item

The CSS Properties inspector settings add CSS markup to either the <head>
of the open page or to an external CSS file:

Targeted Rule Font

Bold Italic

Font Size Font Color

Align (Left/Center/Right/Justified)

QNING/ As you may have noticed, both tabs on the Properties inspector include a
Y Page Properties button, which applies CSS formatting only to the currently
active page. If you're new to CSS, ignore this button for now and concentrate
on figuring out how to apply CSS to your pages through the CSS Styles panel.

Any time you use the CSS properties, Dreamweaver automatically writes the
style sheet code to either your HTML, right before the closing <head> tag of
the page or to an external style sheet, which can be a new blank CSS file that
you create on the fly, or an existing CSS file that you specify before adding a
new style rule to it.

<P One major benefit of using CSS is that you can build your own master CSS
file and then use it again and again on each project, customizing the fonts,
colors, styles, and so on, to match the each project’s design. See http://
www.crucialwebhost.com/blog/master-stylesheet-the-most-
useful-css-technique/ for a great example of this.

When adding internal CSS to the file, for example, if you select the Arial font
from the Font drop-down menu in the CSS Properties inspector, you are
prompted to create a custom CSS style, such as .saleprice, or specify the
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HTML tag that will be redefined with the new font, such as the <p> tag for all
paragraphs. After you create the new style, the following style sheet code is
added to your HTML document between the <head> tags:

<style type="text/css">

<!--

.saleprice {font-family: Arial, Helvetica, sans-serif}
-=>

</style>

The style sheet markup begins and ends with the <style> tag. Nested
between those are opening and closing comment tags (<!-- and -->),
which comment out (hide) the style attributes so that older browsers don’t
display them as text in the body of the page. Comment tags are used to
insert text in your code that isn’t displayed in a browser. Between the com-
ment tags is where the style attributes go.

Styles you apply with the CSS Properties inspector use the unique names you
provide for them, such as .saleprice and . sidebarheader. Between the
comment tags, you can list as many styles as you need to style the page. Each
time you style content with the CSS Properties inspector, you are prompted to
add a new custom style to the internal or external style sheet. After your new
custom styles are added to the internal or external style sheet, the Targeted
Rule menu in the Properties inspector (refer to Figure 1-2) displays those
styles by name and preview. You can also apply your custom CSS styles to
selected content using the Class menu on the HTML Properties inspector.

When adding internal CSS styles to the open document, be aware that those
internal CSS styles only alter the contents on that particular page. To use a
single style sheet for multiple pages on a Web site, you must create an exter-
nal style sheet, described next.

External styles

External styles refer to style descriptions saved in a single separate, external
file with the .css file extension. External style sheets are often named after
the company or project they’'re used with, or with some acronym or abbrevi-
ation relative to the Web site, such as monkey.css for a site about monkeys,
although some designers simply refer to their CSS files as style.css so that
every project uses the same naming convention.

The external style sheet needs to link to the HTML pages using a special
line of code. When the link is present and the page is displayed in a browser
window, the browser interprets and displays the page’s contents using the
external style sheet information. You place the link to the external style
sheet inside the <head> tag of the document with the href attribute refer-
encing the location and filename of the CSS, as in this example:

<link href="monkey.css" rel="stylesheet" type="text/css" />
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External style sheet styles use the same syntax and formatting as inter-

nal style sheets to define styles with one tiny exception: The styles in an
external style sheet do not need to be surrounded by the <style> and
<!--comment--> tags that internal styles require. Furthermore — and this
is what makes external style sheets so powerful — external style sheets are
best when working with a multipage Web site because a single external style
sheet can control the formatting for all the pages on the site. For example,

if you need to change the style attributes of all the Heading 1s (<h1>) site-
wide, you only need to modify the one external style sheet to make all the
pages conform to the new style definitions!

Inline styles

Occasionally, you may need to add an inline style to a document rather than
using internal or external style sheets. For example, if you're creating an
HTML e-mail, you might use tables instead of CSS layers, but still use inline
styles for text formatting because many e-mail programs prefer to interpret
HTML tags over CSS for layout and positioning. What’s more, when the style
data is inline with the content, a visitor can also read the mail offline and
view it styled as you intended.

Inline style descriptions are written inside the code, surrounding the
selected text, oftentimes appending whatever existing tag is closest to the
content to be styled, or by adding a <span> tag with the style attribute, as in
the following two examples:

<p style="font-size: 12px; color: #990000; ">Inline styles are "in line" with the
text.</p>

<p>This example uses the span tag to selectively apply a <span style="font-size:
12px; color: #990000; ">custom style</span> to selected text.</p>

To add an inline style to your page, follow these steps:

1. Select the word or words you’d like to apply an inline style to.
For example, you may want to style the words ‘On Sale Now!".

2. On the CSS Properties inspector, select <inline style> from the New
Rule section of the Targeted Rule menu.

Essentially, you'll be formatting the style tag attribute in a similar way
to how the old <font> tag used to be coded.

3. Apply the desired font, size, and color attributes to the selected text,
as well as bold, italics, and alignment settings, if desired.

When the inline style is applied to an entire paragraph, the style markup
is added to the opening <p> tag, like this:

<p style="font-family: Georgia, 'Times New Roman', Times, serif; font-weight:
bold; color: #F63; font-size: 16px;">0On Sale Now!</p>
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Working with the CSS Styles Panel

When the inline style is applied to a single word or selection of words
inside a paragraph, the style markup surrounds the selected text using
the <span> tag, like this:

<p>We have thousands of products <span style="font-family: Georgia,
Roman', Times, serif; font-size: 16px; font-weight: bold; color:
Sale Now!</span></p>

'Times New
#F63; ">0n

Working with the CSS Styles Panel

Figure 1-3:
The CSS
Styles panel
in All and
Current
modes.

Use the CSS Styles panel to create and manage your internal and external
style sheets. If the panel is not visible, open it by choosing Window=>CSS
Styles. Though applying styles is typically done through the Properties
inspector, we strongly recommend using the CSS Styles panel instead of the
Properties inspector for creating and editing all your CSS.

The Dreamweaver CS4 CSS Styles panel has many enhancements from ver-
sions prior to CS3, including multiple panes. Resize panes by clicking and

dragging the divider line between the panes up or down until they are the
size you want.

Two buttons appear at the top of the panel: All and Current, as shown in
Figure 1-3, each of which display different views of the CSS Styles panel. The
following sections discuss these views in detail.

css sTvLes | AREEVES css sTvLEs [[ARELENEN TaG TN = |
All |Current Al ‘Current
All Rules Summary for Selection
= <stylex Fant-Family Georgia, "Times Mew Ro. ..
bady color #C0O3
P Fant-size 12px
-highlight font-weight bold
LS About "font-weight"
color W #coz -
Farit-Farily Georgia, "Times New Ra,., Fank-weight is defined in rule *p" in
Font-size 12px centeredcss.html,
fonk-weight bald
Add Property Properties for "p"
colar W #cos ~
Font-Family izeorgia, "Times Mew...
font-size 12px
Font-weight bold
Add Property e
52 Aet+ @8 & T = Ay @8 o

All mode

Click the All button and the CSS Styles panel splits into two panes:

4+ All Rules: The top pane displays a list of all the styles attached to, or
contained inside of, the currently selected open document.

4+ Properties: Select a style in the top pane, and the bottom pane displays
its specific attributes. You can quickly make a change to an existing
property or add more properties by clicking the Add Property link.
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Current mode
Click the Current button and the CSS Styles panel divides into three panes:

4+ Summary for Selection: The top pane shows an attributes summary of
the currently selected style. Properties display in order of specificity.
Class styles have higher specificity than tag selectors.

4+ About/Rules: You can toggle this area to display data in two views by
clicking the buttons on the top-right edge of the section’s title bar. The
left About button displays information about a selected property (such
as Color is defined in an inline style attribute in index.html), whereas
the right Rules button shows the style name and the tag in the code the
selected style is applied to (such as <.onsale> <span> or <inline
style> <p>).

4+ Properties: The bottom pane displays the attributes of the selected style
in an editable format. Make a change to a property or add more proper-
ties by clicking the Add Property link.

CSS Styles panel viewing buttons

The bottom edge of the CSS Styles panel (as shown in Figure 1-4) displays
buttons that are shared by both All and Current views and allow you to
select from different viewing and editing options.

Figure 1-4:

These Attach Style Sheet  Edit Rule

buttons | |

display [== Bzt eh 2

viewing | |

and editing New CSS Rule  Delete CSS Rule
options.

The panel’s bottom right edge displays four buttons:

4+ Attach Style Sheet launches the Attach External Style Sheet dialog box
to select an external style sheet to link to or import to the current file, as
well as to specify the desired media type(s) the attached CSS should be
associated with.

4+ New CSS Rule opens the New CSS Rule dialog box for naming, choosing
a selector type, and specifying the location for the new style rule.

4+ Edit Rule opens the CSS Rule definition dialog box when a style is
selected in the CSS Styles panel.
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4+ Delete CSS Rule permanently removes a selected rule or property from
the CSS Styles panel, as well as any formatting from elements to which it
was applied. It doesn’t, however, delete references in the HTML markup
to that style.

The panel’s bottom left edge displays three buttons that change how the list-
ing in the Properties pane of the panel are displayed:

4+ Show Category View splits CSS properties into nine categories: Font,
Background, Block, Border, Box, List, Positioning, Extensions, and
Tables, Content, Quotes. Each category’s properties are displayed in
expandable list format. You can expand and collapse the list by clicking
the plus (+) or minus (=) button next to the category name. Properties in
each category are listed alphabetically with set properties sorted on top
in blue text.

4+ Show List View shows CSS properties in descending alphabetical order
with set properties in blue text at the top of the list.

4+ Show Only Set Properties shows only set properties. This is the default
view.

In all the CSS Styles panel views, any set properties display in blue text while
the rest appear in black text unless they are irrelevant properties (when the
rule is not inherited by the style or is overridden by another style), which
display with a red strikethrough line. In addition, irrelevant rules contain
explanatory pop-up messages that you can see when you hover your mouse
over the rule.

Understanding CSS Style Types

All Cascading Style Sheet rules are written in two-part syntax consisting of
the selector and the declaration:

4+ The selector is the name of the style, which could be a tag like <p> or
<hl>, or a custom name, such as . tableheader.

4+ The declaration specifies all the style’s elements, such as font face, size,
color, and so on. Rules can contain multiple declarations as long as each
is separated by a semicolon (;) as shown in the example below.

Here’s an example of a CSS rule where p is the selector and everything inside
the curly brackets ({}) is the declaration:

p {

font-family: Verdana, Arial, Helvetica, sans-serif;
font-size: 12px;

color: #993300;

}
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Notice that the declarations themselves have two parts separated by a colon
(:): the property (such as color) and the value (such as #993300). In the
rule for p in the preceding example, a style has been defined for all <p> tags,
meaning that all content in the document between any pair of opening and
closing <p> tags displays as Verdana, 12px, and #993300 (which is the hexa-
decimal code for a deep brick red color). (To find out more about hex colors,
see Book II, Chapter 2.)

The cascading part of Cascading Style Sheets refers to the capability of
adding multiple style declarations to the same rule as well as applying mul-
tiple rules to the same elements. For instance, you can have one rule define
the style of text and another rule define the margin and line spacing around
it. In a greater sense, however, the term refers to the ability to use multiple
style sheets and multiple style inheritances in a cascading way that deter-
mines which styles take precedence over the others. To find out more about
CSS cascading rules, see the About.com article on CSS types at webdesign.
about.com/od/css/f/blcssfagcascade.htm.

In addition to hand coding, Dreamweaver provides you with two different
ways to create CSS styles for your documents:

4+ Properties inspector: As we mentioned previously, you can automati-
cally create and add internal, externally linked, or inline styles to your
page when styling selected content using the CSS Properties inspector.

4 CSS Styles panel: Using the CSS Styles panel (as described in the section
“Adding a Style to a New or Existing Style Sheet”) you can add internal
or external styles to your files by accessing the full library of style prop-
erties inside the CSS Rule Definition dialog box.

Before you begin creating your styles, you need to be familiar with the dif-
ferent style types. You can create four general types of styles using the CSS
Styles panel: Custom styles, ID styles, Tag redefines, and Compound CSS
selectors. Each type modifies different parts of the HTML, as described in
the following sections.

Custom styles (Class)

If you want to selectively style content, use custom styles. For instance, in
the sentence, “When collecting seashells, remember to bring a bucket or
other container with you,” you could create a custom style for the word sea-
shells. That custom style might look something like this:

.seashells {
font-family: Verdana, Arial, Helvetica, sans-serif;
font-size: 12px;
color: #3366CC;
font-style: italic;
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\‘\gN\BEI? Custom style names, whether placed on internal or external style sheets,

& must have a period (.) before the style name to display properly in a
browser window. Dreamweaver lists, in preview form, all custom styles in
the Targeted Rule and Class drop-down lists in the Properties inspector.

To apply the custom style to a document, select the content in Design view,
and select the custom style from the Targeted Rule or Class drop-down lists
in the Properties inspector. Dreamweaver modifies the selection by sur-
rounding it with the <span> tag with the designated class attribute, as the
following example shows:
<p>When collecting <span class="seashells">seashells</span> remember to bring a
bucket or other container with you.</p>
Figure 1-5 shows how this sentence looks in Design and Code views.
‘ SUE v | -8 X
customclass.html % | 2 =
| Lofcode | 25 spit | g pesian || | ¢ [uve view v | +ie| | Title: | Untiled Document 1. &
TWhen collecting seashells, remember to bring a bucket or other container with you
0 * <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http: /Swww. w3 org/TR/xhtnl 1/DTD/xhtnll-transitional. dtd™> teatrriis
2 <html xmlns="htep: //wow, w3, org/1999 /xhtul™>
3 cheads [ A [curent
% 4 <meta hotp-equiv="Content-Type” content="text/html; charset=utf-8" /» All Rules
?;\‘ & <titlerUntitled Document</title> El <styler
o | B <style cypesTtext/oss"> T e
¥ 7
8  .seashells {
“w®| 9 font-family: Verdana, Geneva, sans-serif:
|
— ig" 12 calor: faaém,- ’ 2":’*‘3'"“ ;E’d;g;é;i”“a' SR
H =1 } -5ize %
Figure 1-5: |« = e e
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1D styles (1ID)

Use the ID styles to create custom styles that are automatically applied to
any object on the page with the ID matching the ID style name.
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To illustrate, say you have an AP Element (layer) filled with a listing of dif-
ferent models of low-flow showerheads, like the one shown in Figure 1-6. If
you then give the table an ID attribute of “showerheads”, using the syntax
id="showerheads", and create a style using the syntax #showerheads,
that ID style is automatically applied to the table. As long as the ID style
name is proceeded with the number symbol (#), the style is automatically
applied to the object with a matching ID. This is different from CSS styles,
which must be hand-applied to selections using the Targeted Rule or Class
menu on the Properties inspector.

Dw Fie Edt view Dsert Modfy Format Commancs  Site Window  Help | - @y &~ | DESIGNER v | — & *

<body>

<div id="showerheads™>
<h3>Jet-Strean Low-Flow Showerheads</h3>
<ulz

<lizInstitutional - E-102</11>
<lizClassic - E-202</1i>
<li>Freedom - E-302</1i>

£S5 STYLES

<lizlibervy - E-422</1i> | A ICU"E"!\
<livlawnry - E-622</11 Al Rules
</ul> = |[E <style»
)i —#showerheads
</body>
</htuls L
¥ | nropartias for"ishowarhaads"
background-color  [] #BFEBFF
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El t S0
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— = : = B = listmenu.html 17,
Overflow | Clip: L R =
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it B & | §2  File activity complete, Log. E-'

Here’s an example how an ID style is written in the CSS:

#showerheads {
font-family: Georgia, "Times New Roman", Times, serif;
background-color: #BFEBFF;
border: 1lpx solid #039;
position: absolute;
width: 330px;
height: 180px;
z-index: 1;
left: 50px;
top: 50px;
padding: 10px;
}
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And here is what the HTML markup would look like:

<div id="showerheads">
<h3>Jet-Stream Low-Flow Showerheads</h3>
<ul>
<li>Institutional - E-102</1i>
<li>Classic - E-202</1i>
<li>Freedom - E-302</1i>
<li>Liberty - E-422</1i>
<li>Luxury - E-622</1li>
</ul>
</div>

CSS tag redefines

You can use tag redefine CSS styles, created with the CSS Styles panel, to
modify the preformatted look of existing HTML tags, such as the <p>, <h1>,
and <td> tags. For example, the Heading 1 tag (<h1>) is preformatted to be
large and bold, using whatever font styles the browser’s default H1 setting
are set to display it in. By redefining the tag in the CSS, you can force con-
tent styled with the <h1> tag to display with your chosen style attributes,
such as 36 pixels, Verdana, navy blue, and bold:

hl {
font-family: Verdana, Arial, Helvetica, sans-serif;
font-size: 36px;
color: #000033;
font-weight: bold;
}

Whatever properties or tags you don’t redefine in the CSS, however, remain
set at the browser defaults.

Compound styles

Compound styles are like the muscles of CSS, where you can create some really
amazing layout and formatting styles. The only drawback is that compound
styles can seem a bit complicated for the beginner. The W3C (www.w3 . org/
TR/REC-CSS1) has technical definitions of all the things you can achieve with
CSS and these advanced selectors, but if you're new to CSS, these instructions
may be difficult to understand. For a more basic breakdown, try reading the
Advanced Selectors article by Ross Shannon on the HTMLSource Web site at
www .yourhtmlsource.com/stylesheets/advancedselectors.html.

The most common use of the Compound selector type is to modify the color
of links. The default link color for browsers is royal blue, and the default
visited link color is purple. If those colors don’t blend well with the colors of
your Web site, create custom link colors with the Compound style type.

What’s more, in addition to changing the link and visited link colors, style
sheets allow you to add two additional link states to your links:

4+ The hover state, for when you mouse over the link.

4+ The active state, for when you actually click the link.
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The order in which you create these link states is important. Create the
normal link state first, and then the visited state, and then the hover and
active states. A different order may cause the links to not work properly.
If you have trouble remembering the order, try using the mnemonic “LoVe
HAte” for Link, Visited, Hover, Active.

When added to a style sheet, the following code changes the link color for
each of the states using a hexadecimal value for the color:

a:link {

color: #990000;
}
a:visited {

color: #££0000;
}
a:hover {

color: #6600cc;
}
a:active {

color: #000000;
}

Use any hexadecimal color needed to match your design. In addition to the
text color, you can also modify the text decoration (the type of underline
attribute the link has), background color (behind the text), font weight
(bold), and other style attributes in the CSS Styles panel.

The second most common usage for the Compound selector type is for
creating styles that are either combinations of tags or tags that are nested
inside of other tags. Tag combinations are for times when you need to create
a style that you’ll apply to multiple tags, such as the <body>, <th>, and
<td> tags:

body, th, td {
margin: 0px;
padding: 0px;
font-family: Verdana, Arial, Helvetica, sans-serif;
font-size: 10px;
color: #99ffff;
font-weight: bold;
}

Nested compound tag styles are used when you want to apply a style to a
very specific part of a page. For example, in the following code, the selector
name applies to all <td> elements that are within any <tr> elements that
are within any <html> elements with id "showerheads". In other words,
this style is only applied to content inside of cells inside of a table with the
id="showerheads":

#showerheads tr td {
font-family: Georgia, "Times New Roman", Times, serif;
font-weight: bold;
color: #393;

Book IlI

[x]
=
o
=
-
@
-
-

($SJ) s19ays
ajhyg buipeases
yum poor) bunjooq



2 74 Adding a Style to a New or Existing Style Sheet

Other great resources for finding more about CSS and compound selectors
include the following:

www.w3schools.com/css/
http://reference.sitepoint.com/css
www.csszengarden. com/
www.meyerweb.com/eric/css/
www.htmlhelp.com/reference/css/

Adding a Style to a New or Existing Style Sheet

Figure 1-7:
Create a
new CSS
rule (style).

To create an internal or external style sheet, you start by defining a style.
You can create a custom style, tag redefine, or compound style (all of which
are described in the preceding section) using the CSS Styles panel.

Open your HTML document and follow these steps to add a style to a new or
existing style sheet:

1. Click the New CSS Rule button at the bottom of the CSS Styles panel.
You can also choose Format=>CSS Stylesc>oNew.

The New CSS Rule dialog box opens, as shown in Figure 1-7.

New CSS Rule
Selector Type:
(55 rule apply to your HTML according ko a contextual selector bype, -

Class {can apply ko any HTML element) »

Selector Name:

Choose or enter a name for your selector,

Rule Definition:

Choose where your rule will be defined.

{This document only) -v
Help

2. Choose a selector type from the following options:

¢ (Class creates a custom style that can be applied to any content such
as a word, phrase, sentence, graphic, or layer.

¢ ID creates a style for tags with specific ID attributes.

¢ Tag redefines the look of an existing tag, such as <p> and <h1>.
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e Compound selectors style links, combinations of tags, and nested

tags. They can also be used to create styles using combinators, attri-
bute selectors, pseudoclasses, and pseudoelements.

3. For the Selector Name, depending on the selector type you choose in
Step 3, do one of the following:

¢ (Class (can apply to any HTML element): Enter a name for your new

style in the Selector Name text box with a period (.) before the style
name, as in .discount.

Class names must begin with a period and can have any combination
of numbers and letters, but no spaces or other special characters.
Fortunately, if you forget to enter the period before the style name,
Dreamweaver automatically enters it for you. This, however, is not
foolproof; if your style doesn’t display in a browser, check the CSS to
see if the period is missing before the class name.

ID (applies to only one HTML element): Enter the ID of the element
you’d like to style in the Name text box, as in #showerheads.

AfteryouenteranlID,anyobjectwiththesamelDisautomaticallystyled
with this CSS rule.

Tag (redefines and HTML element): Enter an HTML tag in the Tag
text box or select the tag that your style redefines from the Tag drop-
down list, such as <h1>, <table>, or <p>.

Compound (based on your selection): Select a pseudoclass selector
from the drop-down menu for redefining the different link styles from
the Selector drop-down list, or type the HTML tag, the combination
of tags separated by commas, or the nested tag sequence of the new
style in the Selector Name text box.

For example, typing #showerheads tr td creates a style that would
automatically apply to any content inside of a table cell inside an ele-
ment with the ID "showerheads", typing body,th,td creates a style
that automatically applies to multiple tags, and typing or selecting
a:link, a:visited, a:active, or a:hover creates a style that redefines
one of four link state styles. If you know how to create the more
advanced compound selector styles, type the proper syntax for that
compound selector style into the Style text box.

After you've typed in a name for your selector, a description appears
in the description box below the Selector Name field.

This selector name applies your rule to all <td> elements that are
within any <tr> elements that are within any HTML elements with
the ID "showerheads".

To understand these style descriptions more readily, be sure to click
the More Specific button below the description area.
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Figure 1-8:
Choose
style
attributes
when
creating a
new style.

4. Under Rule Definition, choose one of the following options to specify
the location of the new style information:

¢ Choose (New Style Sheet File) to create a new external style sheet.

¢ Choose (This Document Only) to create an internal style sheet.

¢ Choose the filename of any existing external CSS file, if available,

from the drop-down list.

5. If you chose to add the new style to a new style sheet in Step 4, the
Save Style Sheet File As dialog box appears. Enter a name for your

new CSS and click OK to save it to the specified directory. Then skip
ahead to Step 7.

Be sure to name your new CSS with the .css file extension and save it to

the root level of your currently managed site. Upon closing this dialog
box, Dreamweaver automatically opens the CSS Rule Definition dialog
box for defining the new style.

6. Click OK to close the New CSS Rule dialog box.

The CSS Rule Definition dialog box appears, as shown in Figure 1-8.

CS5 Rule Definiti

for

le in ple.css

Cateqory
Twpe
Background
Block,

Box

Border

List
Positioning
Extensions

Type

Eont-Farmily:
Font-gize:
Fonk-style:

Line-height;

'.v Font-yeeight: »
Fork-variant:

Font-transform:

Font-decoration: [_] underline Color: D
Coverline
[line-through
[blink.
[Jnone

Help I [ OK I { Cancel

Depending on your selection in Step 3, the title bar in the CSS Rule
Definition dialog box may display slightly different text. For instance, if
adding a style to an existing CSS, the title bar reads CSS Rule Definition
for .example in example.css.

. Enter the style information for the new style, in any combination of

categories.

When you select a category from the listing on the left, the right side

of the panel changes to support that category’s options. The upcoming
section “Exploring the CSS Rule Definition Dialog Box” covers all the cat-
egory options in this dialog box.
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To preview before committing to the style settings, click the Apply
button. Don’t feel pressured to get the style to look exactly right during
the creation process, as you can easily edit the styles at any time (see
the “Editing a CSS Style” section, later in this chapter).

. Click OK.

The new style is added to the style sheet and displays in the CSS Styles
panel. To cancel out of the New CSS Rule dialog box without adding a
style, click the Cancel button.

. Repeat Steps 1 through 8 to create additional styles in the same inter-

nal or external CSS.

You can add as many styles as you want to the CSS, and you can create
both internal and external styles at any time. For greatest ease of use,
we recommend that you create a single external CSS file and place all of
your style rules there. That way, you can use a single style sheet for an

entire Web site!

Attaching a Style Sheet to Vour Document

Figure 1-9:
Attach an
external
CSStoa

page.

You can attach an existing style sheet to your document at any stage of
development. It can be a fully realized style sheet or a blank one that you
build as you style your document; for the purposes of attaching the style
sheet, its contents don’t matter so long as the file is created and saved in
advance with the .css file extension.

If you have an existing external style sheet (perhaps a copy of one used on
another project or one provided by another member of your team) or want

to use one of Dreamweaver’s sample style sheets, save it to the local root
folder of your currently managed site or in a folder at the root level of that
site. Then follow these steps:

1. Open the CSS Styles panel and click the Attach Style Sheet button at
the bottom of the panel (refer to Figure 1-4).

The Attach External Style Sheet dialog box opens, as shown in Figure 1-9.

Attach External Style Sheet
File/URL: | eample.css w|
Add as: (5) Link
O Impart

Media: |l

‘fou may also enter a comma-separated list of media types,

Dreamweaver has sample stvle sheets to get you started. Help
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\\3

. In the File/URL field, enter the name of the existing style sheet or click

the Browse button to navigate to and select the existing style sheet.

Dreamweaver has several sample style sheets you can use either as-is
or as a starting point for customizing your own style sheet. To use one
of the existing style sheets, click the Sample Style Sheets link inside
the dialog box. The Sample Style Sheets dialog box opens from which
you can preview and select a style sheet from the listing. Click OK and
Dreamweaver instantly attaches that selected style sheet to your page.

. In the Add As field, choose the Link or Import radio button.

Link: Choose the Link option to add the CSS as an external file, where a
line of link code containing the CSS file you specified is inserted into the
head of the page:

<link href="example.css" rel="stylesheet" type="text/css">

Import: Choose the Import option to add a special @import link to the
CSS internally, in the head area of the page:

<style type="text/css">

<l--

@import url ("example.css");

-——>

</style>

Both options link to external CSS files; however, the second method is
less reliable with older browsers than the first, so when linking, choose
the Link radio button, or simply include both methods in the code.

. In the Media field, either select an option from the drop-down list or

leave this field blank.

Media types refer to the different types of devices or media a user can
view your page with — such as a screen device (like a browser), a hand-
held device (like a BlackBerry), or a printer. Choose a media type from
the drop-down list to identify the linked CSS as being the one to use
when that device is used to view the page.

To enter multiple media types at once, separate each type with a
comma, as in screen, printer, handheld.

To find out more about CSS for media, visit the World Wide Web
Consortium at www.w3 .org/TR/CSS21/media.html.

. Click the Preview button to see how the CSS will change the appear-

ance of your document.

. Click OK to attach the CSS to your document.

The CSS Styles panel displays the newly attached external style sheet.
To tell the difference between internal and external styles, look for the
word <style> or the name of the external CSS; Internal styles display in
a list below a <style> tag, whereas external style sheets display below
the CSS filename.
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Applying a Custom Class Style

A\

Figure 1-10:
Apply
custom
styles with
the Class
menu.

You can apply custom styles you've created in your internal or external
style sheets to any selected asset in an open document. For example, you
may want certain words in a sentence to stand out from the rest of the text
or style graphics with uniform styling attributes. Before applying a custom
style, create the style with the CSS Styles panel (see the preceding section).

To apply a custom style to your document, follow these steps:

1. Select the content to be styled in either Design or Code view.

To assist in selecting an exact tag, select the tag in the tag selector bar
at the bottom left edge of the Document window.

2. Using the Properties inspector, select the custom style from the
Targeted Rule or Class drop-down list.

The Targeted Rule and Class menus both list the custom styles by name,
but the Class menu also shows a preview of style names (as shown in
Figure 1-10), making them easier to recognize.

PROPERTIES |

HTML Format | None v|  doass [ special v B r £ 2E THe

2 | il
& T

css 10 | None v Link. f Target

=] cel Horz |Defaulk |+ | W nowrap [] B [ Page Properties..

[0 3B vert|pefault [v| H Header []

Dreamweaver styles your selection by either adding the <span> tag
with your custom class around your selection, or by appending an exist-
ing tag with the new custom class:

<p>Applying <span class="special">custom</span> styles is easy!</p>
<p class="special">Applying custom styles is easy!</p>

To remove a custom style from a selection, select the text or object in
Design view and choose None from the top of the Class drop-down list in
the HTML tab of the Properties inspector. In the CSS tab of the Properties
inspector, you can remove a custom style from a selection by choosing
<remove class> from the Targeted Rule drop-down list. (See Figure 1-2.)
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Editing a CSS Style

Editing styles in the CSS Styles panel is as easy as creating a new style.
Essentially you're changing the style attributes in the same dialog box you
used to initially create the style in. You can use either Current or All mode to
enter the style changes.

Editing in All mode

To edit a CSS style with the CSS Styles panel in All mode, open your HTML
document and follow these steps:
1. Click the All button at the top of the panel.

A list of style rules used on the entire document displays in the All Rules
pane, whether internal or external.

2. Select the style that needs editing.

Now you have two options: You can edit that style’s properties directly
in the Properties pane at the bottom of the panel, or you can reopen the
Rule Definition dialog box, inside which you can make adjustments to
the selected style. To use the dialog box, proceed to Step 3.

3. Click the Edit Rule button at the bottom of the panel (refer to
Figure 1-4).

The CSS Rule Definition dialog box opens, identifying the style and loca-
tion by name, such as CSS Rule Definition for .example in example.css.

<P You can also reopen the CSS Rule Definition dialog box by
¢ Double-clicking the style name in the CSS Styles panel.

¢ Right-clicking (Windows) or Control+clicking (Mac) the style name
and selecting Edit from the context menu.

e (Clicking the Edit Rule button on the CSS Properties inspector.
4. Edit the style information as needed in any of the style categories.

The upcoming section “Exploring the CSS Rule Definition Dialog Box”
covers the different options in this dialog box.

To preview before committing to the edited style settings, click the
Apply button.

5. Click OK.

The edited style with its new style attributes displays in the CSS Styles
panel. To cancel out of the New CSS Rule Definition dialog box without
modifying the style, click the Cancel button.
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Editing in Current mode

To edit a CSS style with the CSS Styles panel in Current mode, follow these
steps:

1. Click the Current button at the top of the panel.
A summary of style properties for any currently selected style displays.

2. Select a text element or other asset on the page to view its style prop-
erties.

The CSS Styles panel shows the summary for the current selection
including detailed information about the style location and editable style
properties.

3. To edit any of the style’s properties, select a rule in the Summary pane
and edit those properties directly in the Properties pane at the bottom
of the panel.

Or you can double-click the rule in the Summary pane to enter changes
in the CSS Rule Definition dialog box. This option is only available if
you’'ve enabled the Edit Using CSS Dialog setting in the CSS Styles cat-
egory of Dreamweaver’s Preferences.

The upcoming section “Exploring the CSS Rule Definition Dialog Box”
covers the different options in this dialog box. Book IlI
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To preview before committing to the settings, click the Apply button.
4. Click OK.

The edited style with its new style attributes displays in the CSS Styles
panel. To cancel out of the New CSS Rule Definition dialog box without
modifying the style, click the Cancel button.
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You can also edit your styles by hand in Code view.

Adding properties to a CSS style

Add properties to any existing CSS style at any time by following these steps:
1. Choose a rule in the All Rules pane in All mode or pick a property in
the Summary section of Current mode.
2. Do one of the following:

e (Click the Show Only Set Properties button and then click the Add
Properties link in the Properties pane.

¢ C(lick either the Show Category View or Show List View button, and
fill in the new property value next to the property you want to add.
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You can also add properties to an existing style at any time by hand coding
in Code view, or by selecting the rule in All mode and reopening the CSS Rule
Definition dialog box by double-clicking the Edit Rule button at the bottom of
the CSS Styles panel.

Deleting a CSS Style

Sometimes you create a style and then never use it. To help clear the CSS
file of unnecessary style information — which also keeps the overall file size
low — delete any unused styles from your style sheet before publishing your
site.

To delete a style from a style sheet listed in the CSS Styles panel, follow
these steps:

1. Click the All button at the top of the panel.

A list of style rules used on the entire document displays, whether inter-
nal or external.

2. Select the style you want to delete.

3. Click the Delete CSS Rule button at the bottom of the panel (refer to
Figure 1-4).

You can also right-click (Windows) or Control+click (Mac) the style
name and choose Delete from the context menu.

If you feel comfortable doing so, you can also delete internal styles from
your document or external styles from an external CSS file in Code view.

<MBER Removing styles by either method only removes the style from the CSS, not
from within the HTML code. To remove the application of a removed style
from HTML, use the Find and Replace dialog box to search the entire site for
that style attribute. For details about using the Find and Replace dialog box
to remove specified content, see Book II, Chapter 2.

Exploring the CSS Rule Definition Dialog Box

With the CSS Rule Definition dialog box, Adobe has created a simple user
interface to create, test, and apply styles. The dialog box includes several cate-
gories of style rules that you can add in any combination, including style rules
for type, background, block, box, border, list, positioning, and extensions.

To use the dialog box, first select a category from the left side of the panel.
Then choose styling options from the right side of the panel. The right side
of the panel’s options are determined by the category you select on the left.
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<® As a general rule, when entering individual values to rules with Top, Bottom,
Left, and Right fields, enter 0 or None for sides that should not contain
values. Doing so improves the chances of different browsers rendering your
styles consistently.
Type properties
Use the Type category (shown in Figure 1-11) to create specific font attri-
butes and type styles. In addition to the font face, you can customize the
font size, line height, style, decoration, and weight, among other settings.
CSS Hule definition for .special
Category Type
Type
Backaround Font-famiy: v
ngde, Fant-size: | Fant-weight: v
;i;;tiomng Font-style: - Fort-variant: v|
Extensions ¥ = e
Line-height: | Font-transform: ~
_— Font-decoration: [_]underline Color: E
Figure 1-11: [overine
Create text Dline through
styles with E:':n';
the Type
category
settings. (o J[ conel J[ omots
“&N\BEB Npt all browsers support all the type properties, and some elements appear
& differently on a Mac than they do on a PC, so be sure to test the CSS styles in

all your target browsers on both platforms before publishing your site. This
gives you the opportunity to select different style attributes for your styles if
needed.

The following rules are available in the Type category:

4+ Font-family: Select a Web-safe font family from the drop-down list or
type the name of the Web-safe font or font set you want to use. Default
sets include cross-platform—compatible fonts such as “Verdana, Arial,
Helvetica, Sans-serif”.

To create your own custom font sets, select the Edit Font List option
from the bottom of the drop-down list. The Edit Font List dialog box
opens, wherein you create new lists from available system fonts. (For
more of a discussion on font sets, see Book I, Chapter 2.)
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4+ Font-size: Choose from preset font sizes ranging from 9 to 36 from the
drop-down list or type a number in the size field. Specify font size in px
(pixels), pc (picas), pt (points), in (inches), mm (millimeters), cm (cen-
timeters), (ems), (exs), or % (percentage). Although using pixels is gen-
erally recommended over points (the primary unit for print design) to
ensure uniform display on both Macs and PCs, due to a resizing issue in
Internet Explorer, many CSS tutorials now suggest you use ems for font
sizes instead. Additionally, when font sizes are set to ems, they resize
correctly if the browser’s default text size setting is changed. Resizing
will not occur if the fonts are set to pixels.

4+ Fontstyle: Select normal (the default), italic, or oblique as the font style.
The oblique style is similar to italic, only it typically refers to a sans-serif
font that’s tilted about 12 degrees before being adjusted to improve the
font’s appearance.

4+ Line-height: This setting, also called leading, sets the text line height
from baseline to baseline. Choose Normal to use the automatically calcu-
lated standard ratio of font size to line height, or enter a number value in
pixels, points, in, cm, mm, picas, ems, exs, or %.

4+ Font-decoration: The following options are available for text decoration:

e underline: Adds an underline to the selected text. This setting is the
default for links.

e overline: Adds an overline to the selected text. The overline looks
just like an underline, only it’s above the characters rather than
below them. It’s a strange-looking style, to be sure, so try not to use
it for styling links unless you know your audience is sharp enough to
figure it out.

¢ line-through: Adds a line-through, or strikethrough, effect to the
selected text.

¢ blink: Makes the text blink, or flash, in the browser window. (This
setting is not a recommended practice and happens to be very
annoying to site visitors, so don’t use it.)

¢ none: Removes all decorative formatting, including underlines on
links. This setting is the default for normal text.

4+ Font-weight: The default font weight is normal, but you may specify
the amount of boldness using other font weight options including bold,
bolder, lighter, and bold settings in increments of 100 from 100 to 900,
where normal is equal to 400 and bold is equal to 700.

4+ Font-variant: Select normal or small caps. Normal refers to the default
font variance of upper and lowercase figures. A small caps setting con-
verts text to display in small caps.

4+ Fonttransform: Options include capitalize, uppercase, lowercase,
and none. For example, selecting uppercase changes the display from
normal upper and lowercase lettering to all uppercase letters.



Figure 1-12:
Add custom
background
properties
to your
styles.

Exploring the CSS Rule Definition Dialog Box 225

4+ Color: Select a color from the Web-safe palette or system color picker
(the circle at the top right edge of the popup palette). You can also
type the hexadecimal code into this field; just remember to include
the number symbol (#) before the hex number, as in #990033 or
#903 (which is shorthand when the characters in each pair match: 99
becomes 9, 00 becomes 0, and 33 becomes 3), so the color renders prop-
erly in the browser.

Background properties

The Background category’s rules (see Figure 1-12) define the background
settings of various elements on a document. For example, you can add a
background color to a page, a table cell, a layer, or selected text.

CSS Rule definition for .special
Category Background
Type
Background 5 .
Hlock Barkground-rolor: D
Box .
Barder Barkground-image: | | Browse..
List
Positioning Background-repeat: »
Extensions
Background-attachment: ~
Background-position (X): v
Background-position (¥): ~
o) (e ) (aueh

The following rules are available in the Background category:

4+ Background-color: Apply a background color to the body of the page,
text, tables, table cells, layers, and more. Select a background color from
the Web-safe palette or system color picker, or type the hexadecimal
code along with the number symbol (#) before the hex number (as in
#990033), so the color renders properly in the browser.

4+ Background-image: Type a filename or browse to and select the loca-
tion and filename of an image. You can apply background images to the
body of the page, text, a table, table cell, or layer.

4+ Background-repeat: Instruct the browser how to display the back-
ground image. By default, background images automatically repeat, or
tile, both vertically and horizontally unless otherwise specified:

* no-repeat: Displays the background image once, without any hori-
zontal or vertical repeating.
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e repeat: Mirrors the default setting of continuous horizontal and
vertical repeating of a normal background image.

* repeat-x: Forces the specified background image to tile hori-
zontally only. Images are cut off at the borders to fit the element’s
dimensions.

e repeat-y: Forces the specified background image to tile vertically
only. Images are cut off at the borders to fit the element’s dimensions.

4+ Background-attachment: Choose how the background image interacts
with content above it:

e fixed: Treats the background image as if it is immovably fixed to
the background of the browser, while text and other assets on the
page scroll past or over it.

® scroll: Adds the background image to the page so that text and
other assets on the page scroll along with it.

¢ inherit: Inherits the fixed or scroll rule from a parent asset, such
as a table cell inside a table. This option doesn’t display in the
attachment field in Dreamweaver, but you can type it in the text box.
(In fact, the inherit option can be ascribed to every property, includ-
ing the repeat and font-size properties.)

Browsers inconsistently support these features, so use them with
caution.

4+ Background-position (X): Determine where in the browser window
the background image begins its horizontal display or repeat. Enter
positioning settings for Left, Center, or Right, or type your own value in
pixels, points, in, cm, mm, picas, ems, exs, or %.

4+ Background-position (Y): Determine where in the browser window the
background image begins its vertical display or repeat. Add positioning
settings for Top, Center, or Bottom, or type your own value in pixels,
points, in, cm, mm, picas, ems, exs, or %.

<P To center a single image inside the browser window, create a style for the
<body> tag and set the Horizontal and Vertical alignment to center in con-
junction with a fixed, non-repeating, background attachment. In the follow-
ing example, a file called logo.gif is used as the single, centered background
image:

<style type="text/css">

<l--

body {
background-attachment: fixed;
background-image: url (images/logo.gif);
background-repeat: no-repeat;
background-position: center;

}

-——>

</style>
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Block properties

The Block rules (shown in Figure 1-13) control the space and alignment of
styled tags and attributes. Elements that Dreamweaver treats as CSS layout
blocks include

CSS Rule definition for .special
Category Block.
Type 1
giil;ground \Word-spacing: v
Box T
EBorder Letter-spacing: R
List
Positioning Vertical-align: £
Extensions
Texk-align: v
Text-indent:
Figure 1'13: White-space: R
Add Style Display: v
properties
to set
spacing and
alignment. ok ] [ cancel ] [ apely
4+ <div> tags assigned with absolute or relative positions
4 <form> and <table> tags
4+ Images assigned with absolute or relative positions
4 Tags using the display:block style
4+ Paragraphs assigned with absolute or relative positions
<P You can view CSS layout block properties such as layout outlines, back-

grounds, and box models with Dreamweaver’s Visual Aids. To toggle the vis-
ibility of these properties on and off, choose Viewr>Visual Aids and then pick
the visual aid you want from the submenu.

The following rules are available in the Block category:

<+

Wordspacing: Select or enter a numerical value in pixels, points, in, cm,
mm, picas, ems, exs, or % to evenly control the space between individ-
ual words. Both positive and negative values are acceptable.

Letterspacing: Evenly increase or decrease space between letters and
characters by adding positive or negative numerical values in pixels,
points, in, cm, mm, picas, ems, exs, or %. Be aware that these settings
override text justification. Internet Explorer 4 and up and Netscape
Navigator 6 and up support this rule.
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+

+

Vertical-align: Choose Baseline, Sub, Super, Top, Text-top, Middle,
Bottom, Text-bottom, or Value to enter a value in pixels, points, in,

cm, mm, picas, ems, exs, or %. Preview these alignments in a browser
window (except for any in an <img> tag) to see their effect (press F12 in
Windows or Shift-F12 on a Mac).

Text-align: Choose Left, Right, Center, or Justify.

Text-indent: Enter a text indent numerical value in pixels, points, in, cm,
mm, picas, ems, exs, or % to set the rule for indenting the first line of
text. Indent sizes may be positive or negative values.

White-space: Determine how white space inside a block element
displays:

¢ Normal: Collapses any white space.
¢ Pre: Leaves the white space as it was coded.

e Nowrap: Wraps text only when the code contains the line break
<br> tags. Netscape Navigator and Internet Explorer 5.5 and later
support this rule.

Display: Determines whether the element displays in the browser at all,
and if so, how. You may, for instance, want to use one of these settings
to turn off a style attribute in a CSS for print media:

¢ none: Completely turns off, or hides, the display of the styled
element.

e inline: Displays the element inline with other elements, typically
inside the current block.

¢ block: Forces an element to display as a block.

¢ list-item: Displays elements as a list item with bullets, similar to the
<ul> and <ol> tags.

¢ run-in: Forces a block box following a run-in box to become an inline
box of the block box. Only Opera 5 and later and Internet Explorer 5
for Macs currently support this feature.

e compact: Styles a box of content in such a way that subsequent
block boxes display to its left side when room permits. Though a bit
buggy, this feature is currently supported by Opera 5 and 7. (For a
visual illustration of this feature, see www.quirksmode.org/css/
display.html#compact.)

e marker: Add a marker setting to format content inside a marker box,
such as adding numbers or graphics to a list or special notations to
styled content.

¢ table: Displays elements as a table. Nested elements display as table-
row and table-cell, as they appear if contained in typical <tr> and
<td> tags. Other table display settings include inline-table, table-
row-group, table-header-group, table-footer-group, table-row, table-
column-group, table-column, table-cell, and table-caption.
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For more details regarding block display properties, visit the W3C Web site at

www.w3.org/TR/REC-CSS2/visuren.html#display-prop
www.w3.org/TR/REC-CSS2/generate.html#markers
www.w3.org/TR/REC-CSS2/tables.html#value-def-table-column

Box properties

The Box rules (shown in Figure 1-14) define tags and attributes that control
the position of assets in the document. Box rules apply to individual sides of
the styled asset when adding margin and padding values.

CS5S Rule definition for .special
Cateqory B
Type
Fackaround widch: | v Fioat: v
gg:dar Height: » Clear: e
List Padding Marigin
E:i:rlwns?;gs Same for all Same for all
Top: 2wl Top: v
- Right: Right:
Flgure 1-1 4: Bottom: Boktom:
Create Left: Left:
styles to set
the position
of page
content. ok | [ concd ][ apoy
A\\S
Check the Same for All check box to have uniform (four-sided) box
settings.
B . .
‘3&&“ Er Unless you have other rules for other sides of an asset, when entering
<

individual values to rules with Top, Bottom, Left, and Right fields, enter 0 or
None for sides that don’t contain values.

The following rules are available in the Box category:

4+ Width/Height: Select Auto or enter a value in pixels, points, in, cm, mm,
picas, ems, exs, or %. Auto adjusts the layer’s size to fit the area of the
layer’s contents, while a fixed value expands the layer to a fixed size.
Note that the width refers to the space inside the padding, except in
Internet Explorer, which is buggy.
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4+ Float: When you float an object (like an image, paragraph, div, or list),

it is turned into a block-level element that can then be positioned left or
right, relative to the current line. Choose Left, Right, or None to control
the position of the element that in turn controls the direction in which
other objects float or flow around an object.

Clear: Choose Left, Right, Both, or None to control the side of an

asset that does not allow AP Elements to sit next to them. When an AP
Element appears on the side specified with a clear setting, the asset with
the clear setting gets bumped to the area below it.

Padding: Adds space between the content of an element and its border
or inner margin, such as a word inside of a table cell. Enter individual
padding values in pixels, points, in, cm, mm, picas, ems, exs, or % to the
Top, Right, Bottom, and Left sides of the styled element. Deselect the
Same for All box to adjust sides individually.

Margin: Adds space between the border of an asset and other nearby
assets, as with the area surrounding a sentence or the margin space on

the outer edge of the browser window. Add individual margin values
in pixels, points, in, cm, mm, picas, ems, exs, or % to the Top, Right,

Bottom, and Left sides of the styled asset. Deselect the Same for All box

to adjust sides individually.

Border properties

Use the Border rules (shown in Figure 1-15) to define the style, width, and
color for border features around styled content.

CSS Rule definition for .special
Category Border
Type 1
giii‘;m“”d Style width Color
Eiox Same For all Same For all Same for all
Bord I
L|:E ” Top: |l 2 D
Positioning
— | |EXtENSIONS Right; o
Figure 1-15: —
Create L I
custom
border
styles with
the Border
category. eln o [ coned | [ _epn
3

Check the Same for All check box to create uniform border settings, or
uncheck it to adjust the sides individually.



Figure 1-16:
Create
custom list
styles with
the List
category.
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The following rules are available in the Border category:

4+ Style: Add border styles to your assets using the following settings:
None, Dotted, Dashed, Solid, Double, Groove, Ridge, Inset, or Outset.
Preview the styles in Live View, or in a browser window (press F12
or Shift+F12) as Dreamweaver does not display this attribute in the
Document window.

4 Width: Enter border thickness as Thin, Medium, or Thick, or enter a
value in pixels, points, in, cm, mm, picas, ems, exs, or % to the Top,
Right, Bottom, and Left fields.

4+ Color: Select a border color from the Web-safe palette or system color
picker, or type the hexadecimal code along with the number symbol (#)
before the hex number, as in #990033, so the color renders properly in
the browser.

List properties

Lists in HTML can be numbered or bulleted, and when styling lists with CSS,
both list types can have different style options than HTML alone provides
for. With CSS, for instance, you can use a custom designed image in place of
the default bullet types. Figure 1-16 shows the List category. You can also set
the position of the bullet image relative to the list item text.

CSS Hule definition for .special
Category List.
Type
i d
B;E(l;grnun List-style-type: 54|
B
Border List-style-image: ~ || Browse...
List
Positioning List-style-Position: |
Extensions
o) Caw ) Cam

The following rules are available in the List category:

4+ List-style-type: If creating bulleted lists, select from Disc, Circle, or
Square as the list type. If creating numbered lists, choose from Decimal,
Lower-roman, Upper-roman, Lower-alpha, Upper, Alpha, or None.
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4+ List-style-image: Type the filename and location of the graphic, or
browse to and select the graphic to be used as the bullet image.

4+ List-style-Position: Determine how the list item text interacts with the
list item’s bullet or number.

e Qutside: Forces the text to indent and wrap around the bullet/
number.

¢ Inside: Wraps the text along the left margin.

Positioning properties

Use the Positioning rules (shown in Figure 1-17) to modify the tag or selected
text into a layer. For example, you can control an AP Element layer or an
image’s position within the browser window using positioning rules.

CSS Rule definition for .special
Cateqory Positioning
Type 1
g;iigm””d Posttion: v Visibiliby: v
Box T T
Border Width: e Z-Index: v
List 7 L
Plgsltlomng Height: il Creerflov ~
— Extensions Placement Clip
. Top: & Topt v
Figure 1-17: : 2
Right: » Right: ~
Choose : :
. Bottom: v Bottom: ~
options for = -
. Left: b2 Left: ~
setting the a :
position of a
AP Element
or |mage Help OK I [ Cancel I [ Apply

The following rules are available in the Positioning category:

4+ Position: Using the coordinates entered in the Placement boxes, deter-
mine positioning of the layer or tag relative to the browser window:

¢ Absolute: Positioning is relative to the top-left corner of the browser.
¢ Fixed: Positioning is fixed to the top-left corner of the browser.

¢ Relative: Positioning is relative to the styled object’s position in the

text flow of the file. You must preview this effect in a browser (press
F12 or Shift-F12).

e Static: Similar to Relative, Static positioning puts the styled object at
its location in the text flow, causing elements to stack vertically. This
option is the default position of elements when no type is selected.

4 Width: Select Auto or enter a width value in pixels, points, in, cm, mm,
picas, ems, exs, or %. Auto sets the layer’s size to fit the width of the lay-
er’s contents, whereas a fixed value holds the width open to a fixed size.
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4+ Height: Select Auto or enter a height value in pixels, points, in, cm, mm,

picas, ems, exs, or %. Auto sets the layer’s size to fit the height of the lay-
er’s contents, whereas a fixed value holds the height open to a fixed size.

Visibility: Choose Inherit, Visible, or Hidden to set the initial display set-
tings of the layer:

¢ Inherit: Forces the layer to inherit the visibility property of the lay-
er’s parent. If no parent exists, the layer is visible.

e Visible: Displays the layer’s contents, regardless of a parent’s visibil-
ity value.

¢ Hidden: Hides the layer’s contents, regardless of a parent’s visibility
value.

Z-Index: Determine the styled layer’s stacking order relative to the
browser window:

¢ Auto: Gets the next available z-index number
¢ Inherit: Inherits a parent’s z-index

You can also manually enter a specific number. The lower the number,
the closer to the background; the higher the number, the closer to the
viewer. Layers can have both positive and negative values.

You can also change the z-index number of AP Elements quickly through
the AP Elements panel.

Overflow: Specify how the browser handles the content in a CSS layer or
AP Element that exceed the boundaries of the box the layer sits in:

¢ Visible: Increase the layer’s size (usually its height attribute first,
then its width) so that all the layer’s contents are visible.

e Hidden: Maintain the width and height settings of the layer’s original
size and cuts off, or clips from view, any content that exceeds this size.

¢ Scroll: Add scroll bars to the layer regardless of whether the content
fits or exceeds the layer’s size. You must preview this option in Live
View or in a browser window (press F12 or Shift+F12), as it doesn’t
display in the Dreamweaver workspace. Furthermore, this feature
only works in browsers that support the feature, such as Internet
Explorer and Netscape Navigator 6.0 and up.

e Auto: Add scroll bars automatically if the contents of the layer
exceed the layer’s width and height. You must also preview this
option in Live View or in a browser window (press F12 or Shift+F12)
because it doesn’t display in the Dreamweaver workspace.

Placement: Set the exact size and position of the block element.
Browsers then rely on the Type setting for interpreting the location. Be
aware that sizes may be overridden if content exceeds the block ele-
ment’s size. The default units for size and position are pixels, but for CSS
layers, you can also use points, in, cm, mm, picas, ems, exs, or % to the
Top, Right, Bottom, and Left sides of the layer.
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Figure 1-18:
Add visual
effects and
page breaks
to your files.

4 Clip: Set the visible area of the layer relative to the layer’s top-left
edge. Besides clipping content, the clipped area can be accessed with
JavaScript to manipulate the values and thereby create special effects
like wipes that hide or reveal content on absolutely positioned layers.
Enter clip region dimensions in pixels, points, in, cm, mm, picas, ems,
exs, or % to the Top, Right, Bottom, and Left sides of the layer.

Extensions properties

Extensions apply forced page breaks and unusual visual effects including
pointer styles to your documents. Most browsers don’t yet support many of
these extensions, but support may be forthcoming in the next few years, so
be sure to test extensively before publishing them on your site. In fact, there
are many more options in this category than display inside the CSS Rule
Definition dialog box. To view all of the options in the Extensions category,
click the Show Category View button at the bottom of the CSS Styles panel
and expand the Extensions category in the Properties pane. Figure 1-18
shows the Extensions category.

CS5S Rule definition for .special

Cateqory
Type
Background
Block

Box

Border

List
Pasitioning
Extensions

Extensions

Page-break-before:

Page-break-after:

Cursor:

Filter:

Page break

Wisual effect

Help

ok | [ cancel | [ Aol

The following style attributes are available in the Extensions category of the
CSS Rule Definition dialog box:

4+ Page-break-before/Page-break-after: Forces a page break during the
printing process before or after an asset styled with this option. For
instance, you may want to force a page break after every instance of a
particular image on the Web page styled with this feature. Enter auto,
always, left, or right in the Before and After fields. Though this feature is
not supported by any 4.0 browser, most 6.0 and 8.0 browsers do support
this feature.
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4 Cursor: Select a different cursor that displays when the pointer mouses

over an object controlled by the style. Cool effects include crosshair,
text, wait, default, help, e-resize, ne-resize, n-resize, nw-resize, w-resize,
sw-resize, s-resize, se-resize, and auto. Internet Explorer 4.0 and up and

Netscape Navigator 6 and up support these effects.

4+ Filter: Apply several special-effect filters, such as drop shadow and

glow, to styled asset. Remember to test the setting in multiple browsers

before publishing (press F12 or Shift+F12).

Renaming CSS Styles

Figure 1-19:
Rename
custom
styles.

Dreamweaver CS4 streamlines the process of renaming custom styles. In
the past, you’d have to change the name in the style sheet and update all
the instances of the style name on all the pages of the site for the name
change to be complete. Now, you can edit the name in one location and
Dreamweaver handles all the sitewide updates.

To rename a custom (class) CSS style, follow these steps:
1. From the Properties inspector, choose Rename from the Style

drop-down list.

Or, in the CSS Styles panel, select the style name and choose Rename
from the panel Options menu.

The Rename Style dialog box opens, as shown in Figure 1-19.

=]
Rename style: | special F

MNew name: Cancel

Rename Style

2. Select the style you want to rename from the list of available styles in
the Rename Style drop-down list and enter the new name in the New

Name field.

Be sure not to use any spaces or special characters in the new filename.

3. Click OK.

When the style is on an internal CSS, the change takes place automati-
cally and the Results panel opens showing you all instances of the
edited style name. When the style is on an external CSS, however,

Dreamweaver alerts you of this and offers to fix the name change in all

documents sitewide using the Find & Replace dialog box.
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4. Click the Yes button to change the style name in all documents, the No

button to change the name on the style sheet only without updating
the site, or the Cancel button to stop the name change process.

When you click Yes, the Find and Replace dialog box appears.

If you clicked Yes in Step 4, the Find and Replace dialog box opens,
ready to make the global update.

Dreamweaver auto-populates the Find and Replace dialog box with the
appropriate settings to fix the name change, but you must decide where
the updates should occur. Select Current Document, Open Documents,
Folder, Selected Files in Site, or Entire Current Local Site.

Click the Replace All button.

The Results panel opens to display the results.

Exporting Internal Styles to an External Style Sheet

You can export internal styles to an external style sheet in Dreamweaver in a
couple of ways. For example, you may have started a new project using one
of the provided Dreamweaver HTML/CSS Layouts, which places CSS styling
and positioning rules in the head of the page, and are ready to relocate the
CSS to an external file. The first way is to cut the styles from the internal
style sheet in Code view, and then paste them into an external style sheet.
The second way uses the CSS Styles panel, requires no hand coding, and is
as fast as clicking a few buttons!

A\\S

To export internal styles to an external style sheet, follow these steps:

1.

Click the All button at the top of the CSS Styles panel.

A list of all the style rules used on the entire document displays, includ-
ing internal and external styles.

Below the All button, select all the styles under the <style> tag in the
All Rules section.

To select them all, click on the top style first, and then Shift+Click on the
bottom style. All the contents of the internal style sheet are selected.

Select the option to Move CSS Rules from the CSS Styles panel options
menu.

The Move To External Style Sheet dialog box appears.

You can also select the Move CSS Rules option from the CSS Styles panel
Context menu by right-clicking or Control-clicking on one of the selected
styles.

Move the selected styles to an existing or new style sheet:
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Move to existing: Select an existing CSS file from the drop-down menu
or by clicking the Browse button.

Move to new style sheet: Enter a filename for the new, exported CSS file,
or select an existing CSS file from the drop-down menu or by clicking the
Browser button.

5. Click OK to save the exported file.

Name the file and save it into the existing managed site or navigate to
and select another folder to save the new CSS file into.

6. Remove the internal style tags from the page.

With the <style> tag still selected in the CSS Styles panel, click the
Delete Embedded Style Sheet (trash) button at the bottom of the panel
(refer to Figure 1-4).

7. If you moved the internal styles to a new external style sheet, you
need to attach the new CSS to your HTML file. Click the Attach Style
Sheet button at the bottom of the panel to add a link to the new exter-
nal CSS.

Enter the File/URL of the new CSS, click the Add as Link or Import radio
button, enter a media type, and click OK. Dreamweaver adds the link or
@import code to attach the selected CSS to the open document.
The CSS Styles panel now lists the name of the newly linked external CSS. ookl
Continue using the new external CSS by adding new styles and editing exist-
ing styles as needed.
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<P To move styles from within Code view, select the style(s) you'd like to move
to an external CSS file and click the Move or Convert CSS button on the
Coding toolbar. This opens the Move to External Style Sheet dialog box as
described previously.
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Converting Inline Styles to CSS Rules

From time to time, you may want or need to convert an inline style into a
normal CSS rule and place that new rule into an internal or external CSS file.
For example, an inline style like this:

<p>Life is <span style="font-family: Georgia, 'Times New Roman', Times, serif;
font-size: 16px; font-weight: bold; color: #F63;">sweet!</span></p>

can be converted into a regular CSS rule with the custom class name, .sweet,
like this:

.sweet {
font-family: Georgia, 'Times New Roman', Times, serif;
font-size: 16px;
font-weight: bold;
color: #F63;
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The sentence above could then be simply written as

<p>Life is <span class="sweet'">sweet!</span></p>
To convert an inline style to a CSS rule, follow these steps:

1. Select or place your cursor inside of the code of the object styled with
an inline style, and select Format=>CSS Styles=>Convert Inline Style to
CSS Rule.

The Convert Inline CSS dialog box appears, as shown in Figure 1-20.

You can also access this dialog box by selecting the same option from
the context menu when right-clicking (Windows) or Control-clicking on
the object in Design view. In Code view, access the dialog box by click-
ing the Move or Convert CSS button on the Coding toolbar.

Convert Inline CSS

Convert to: | A new C55 selector || #showerheads tr td
Figure 1-20: o .
COgnVert Create rule in
.. () Style shest: | example.css | Birase.
inline CSS to s

The head of this document

CSS Rules.

2. Select one of the following options from the Convert to drop-down
menu:

¢ A new CSS class: Creates a new custom class style. Be sure to use
the syntax . stylename with a period before the name of the style.

¢ All span tags: Creates a new style that redefines the <span> tag. As
this method redefines a tag that has many uses besides selectively
applying custom styles and inline styles, this is NOT a recommended
option.

¢ A new CSS selector: Creates a style that is automatically applied to
any object with a matching ID attribute. Be sure to use the syntax
#stylename with a number symbol (#) before the name of the style.

3. Enter a name for your converted CSS style in the field to the right of
your Convert to selection.

4. In the Create rule in area, select a new location for the converted
style:

Style sheet: Select an existing CSS file from the drop-down menu or by
clicking the Browse button.

The head of this document: Select this option to move the converted
inline style to the internal style sheet in the head of the document.
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5. Click OK to complete the conversion.

The newly converted inline style is now applied to the same selection
but as a CSS rule on an internal or external CSS file.

Using Design Time Style Sheets

<MBER

Figure 1-21:
Add multiple
CSSto the

workspace.

Design Time Style Sheets allow you to view, edit, and hide multiple style
sheets while working on a document in Design view. Though most sites use
only one external CSS file, you may need multiple style sheets if you're devel-
oping two different versions of the same Web site — one for Windows and
one for Macintosh-only site visitors, or you might want to develop two differ-
ent CSS files, — one for on screen and one for the print.

This multiple style sheet option is only enabled within Dreamweaver’s
Design view to assist you with editing style sheets. In a browser window,
however, only the style sheet that is actually attached inside the document
appears to style the page.

Follow these steps to set up Design Time Style Sheets:

1. Choose Format->CSS Styles-Design-time from the main menu.

The Design Time Style Sheets dialog box appears, as shown in Figure 1-21.

Design-Time Style Sheets
o)
Shows only at design time:
+ =

Hide at design time:

2. In the dialog box, add the settings to hide or show selected style
sheets:

¢ Show a style sheet: Click the plus (+) button above the Show Only at
Design Time field. Browse to and select the style sheet from the Select
File dialog box. Repeat to add additional style sheets as needed.

¢ Hide a style sheet: Click the plus (+) button above the Hide at Design
Time field. Browse to and select the style sheet from the Select File
dialog box. Repeat to add additional style sheets as you need.
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¢ Remove a style sheet: Select the style sheet you want to remove in
either category and click the minus (-) button above that category.

3. Click OK to close the dialog box.

The CSS Styles panel updates to reflect the new style sheet settings, with
hidden or design indicators to show each style sheet’s design-time status.

Using the Code Navigator

New in Dreamweaver CS4 is a feature called the Code Navigator which, when
put into action, opens a popup window, like the one shown in Figure 1-22,
that lets you view and access the CSS code related to a selection or the area
surrounding your cursor.

Luckychair is a web design, graphic desig {#land illustration studio. Established in

1997 —at the dawn of the internet revolutigi — alvac_on designing
g % ~ "~ |Clickiindicator to bring up the Code Navigator.
clean and effective customized communicarro OTaTTO oT DO es5es,

corporations, non-profits, and entrepreneurs all across the United States.

Qur clients come from a wide array of industries including communications,
education, the arts, bakeries, finance, healthcare, teaching, fund-raising, law,
design, fashion, fine art, photography, and travel.

Flgure 1-22: Luckychair is a web design, graphic design ~n- issessinn condin Ecenbljshed in
The Code 1997—at the dawn of the internet revoluti T cssdemo.html ligning

. clean and effective customized communica .example
Nawgator corporations, non-profits, and entreprene! .bluebg l 5.

popup Our clients come from a wide array of indy Al+cick toshow  []Dsable i mdicator i,
WindOW education, the aris, bakeries, finance, healthcare, teaching, fund-raising, law,
: design, fashion, fine art, photography, and travel.

You can access the Code Navigator in any of the following ways:

4+ Alt-click (Windows) or Option-click (Mac) on an element: This method
is the default method for opening the Code Navigator popup window.

4 Click the Code Navigator icon in Design View: When you select an
object, or let your cursor rest for a moment somewhere on the page, the
Code Navigator icon appears. Click the icon to open the popup window.

4 Click the Code Navigator button in Code View: To access the Code
Navigator icon in Code view, click the Show Code Navigator button on
the Coding toolbar.

4+ Select View=>Code Navigator: This option (near the bottom of the View
N3 menu) opens the Code Navigator popup window.

The Navigator icon can be turned on and off by clicking the Disable
button inside the popup window.
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After the popup window appears, you can hover your mouse over any of the
CSS styles listed to view the complete style, with all its selectors and decla-
rations. This can be helpful if you're trying to find the hex value of a color or
a font used on a particular word or sentence.

To edit a style listed in the popup window, click it and the corresponding
CSS code appears both in code view and inside the CSS Styles panel, so you
can quickly view and edit it if desired. All changes to the CSS are live, so
adjusting the style in code view is the same as adjusting the style in the CSS
Styles panel and (nearly) all changes appear immediately on your page in
Design view.

To test any changes you make to the CSS, click the Live View button or
launch a browser window by clicking the Preview/Debug in Browser button
on the Document toolbar.

Use the Code Navigator in conjunction with Live View or Live Code view to
quickly view and edit related relevant code and files.

In addition to displaying CSS code, the Code Navigator also displays related
documents when launching the Code Navigator on objects using JavaScript
and Server-Side Includes. Related files might include a Dreamweaver tem-
plate (DWT files), a library file (LBI files), a CSS file, an external JavaScript
file, an iframe source file, or an external SSI (SHTML, CFML, PHP, ASP, ASPX,
and so on).
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Chapter 1

($SJ) s19ays
ajhyg buipeases
yum poor) bunjooq



2402  Book I1I: Looking Good with Cascading Style Sheets (CSS)



Chapter 2: Building Sites with
Templates

In This Chapter

v Creating a template

+ Creating editable template regions
+ Nesting templates

1 Creating a template-based document

v+~ Editing templates and the pages that use them

Dreamweaver has created a quick and easy way to manage the look of
your Web site with a master file process called Templates. You can
unify the overall design of your Web site into one file, called a template, and
then use that file as the basis for creating all the other pages on your site.

Templates enable you to control which parts of the template-based pages
on your site can be edited and which parts remain fixed across all the pages
on a site:

4+ The editable regions on a template are defined areas for specific parts
of a Web document that have different content on each page of the
site, such as the page header, the body of the page, or a subnavigation
element. You need to define and name each editable region in the tem-
plate. This helps you keep track of the content that should be placed
inside it when you create template-based documents.

For example, the body editable region on the template-based Contact
page would display detailed contact information and the body editable
region on the template-based About page would display detailed infor-
mation about the company.

4+ The uneditable areas of a template, by contrast, are the parts of the
layout and design that are constant throughout the Web site. You don’t
need to define uneditable areas in the template as you do with editable
regions; only editable regions in template-based pages are editable.

For example, your navigation and company logo placement should be
in the same location from page to page throughout the site; these areas
would be uneditable on any template-based pages. Uneditable areas are
a particularly useful tool when you work in a team with other designers,
writers, and Web developers.
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You discover the true beauty and power of Dreamweaver templates when
you need to update part of your master layout or design (that means chang-
ing any of the uneditable areas of the template). Instead of having to individ-
ually modify those elements on each of the pages on your managed site, you
need to update only the template, and Dreamweaver automatically updates
those elements on all the pages that utilize that template!

You can apply templates to blank or existing documents, and if you change
your mind after applying a template to a page, you can simply detach it.

You can also remove template markup or export a page without template
markup. After editing a template, Dreamweaver can selectively update

pages that use the template or update code inside the entire managed site.
Furthermore, from within a page created from a template, you can modify
editable tag attributes such as image source or width. One of the most amaz-
ing functions of templates, however, is that you can completely modify the
entire look of a Web site without having to redo the content, just by attach-
ing a different template to the page!

When you publish your site, you don’t need to upload templates to

the remote server because they do not affect site functionality. Rather,
Dreamweaver uses them as a local tool to help you control the code for
common areas on all the pages that use the template file. What you do need
to upload to the remote server are all the pages created from the template.

This chapter gives you the lowdown on templates and why they’re such a
powerful tool, especially for small-to-medium-sized Web sites. You also find
detailed instructions for creating, using, editing, and deleting templates.

If you are building a larger site or a site that uses dynamic functionality,
other solutions may work better, such as server-side includes (see Book III,
Chapter 3) or building a dynamic site using a database and a programming
language such as ASP, JSP, PHP, or ColdFusion.

Creating a Template

You can create a template from an existing HTML, Adobe ColdFusion, or
Microsoft ASP document, or you can build a template from scratch with a
new, untitled, blank template file. After creating the file, you can add edit-
able regions to the template, as described in the later section “Working with
Editable Regions.” You can also add Design Notes to the file (see Book VI,
Chapter 1 for details), as well as modify the default highlighting and code
colors in the Preferences dialog box (skip ahead to the “Creating editable
regions” section).
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In the process of creating a template, Dreamweaver marks up the document
code with special Dreamweaver template comment tags that identify the
document as a template and define the various areas of the template. The
first template comment tag is inserted right after the opening HTML tag, as
in the following example:

<!-- InstanceBegin template=1/Templates/mytemplate.dwti -->

Additional template comment tags, such as the ones that mark the begin-
ning and ending of editable regions, are inserted throughout the file to assist
Dreamweaver with sitewide editing.

Dreamweaver templates use a series of comment tag markup code to
define areas of the template as editable or uneditable. Although it’s
not necessary that you know what these tags mean or even how they
work to use templates, you can learn more about these on Adobe’s
Web site at help.adobe.com/en_US/Dreamweaver/10.0_Using/
WScbb6b82af5544594822510a94ae8d65-7a79%a.html.

Converting an HTML page into a template

You can convert any existing HTML page into a template. However, we sug-
gest taking the time to create a page with the design layout you want to use
for the entire Web site. Design a master HTML page: Add the text and graph-
ics, enter alternate text tags to images, create hyperlinks where needed,
assign JavaScript rollover button behaviors, add text formatting with
Cascading Style Sheets, check for spelling mistakes, and include any other
media and dynamic settings necessary on the page.

Test this master HTML page in multiple browsers for link accuracy, layout
consistency, and dynamic functionality to ensure the new template you
create from this master page doesn’t contain any errors.

After you're sure the master HTML page is fully functional, open the page in
the Dreamweaver workspace window and follow these steps to convert the
file into a Dreamweaver template:

1. Choose File>Save as Template.

Be sure to choose Save as Template rather than Save from the File menu.

You can also click the Templates button on the Common category of the
Insert panel and select Make Template from the Templates drop-down
list to begin the conversion process.

The Save as Template dialog box appears (see Figure 2-1).
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Save As Template
. Site: D C54 v
Flgure 21 Existing templates: | (no templates) IE
Save your
template
file with
a unlque Descripkion:
name. Save as: | mytemplate Help
2. From the Site drop-down menu, select a site from the list of all your
managed sites into which the new template will be saved.
When creating a template in a managed site, that site’s name should
automatically be selected.
3. In the Description field, enter a short description.
The description displays in the Description field of the New from
Template dialog box when creating a new template-based page.
4. In the Save As field, enter a name for the template.
For simplicity, name the template after the project or client and use all
lowercase letters with no spaces or special characters, as in xyzcompany.
5. Click the Save button. When prompted to update links, click the Yes
button.
If you click the No button, the links and paths no longer function properly.
Dreamweaver creates a Templates folder in the Files panel and places
the newly created template file inside that folder, which means the tem-
plate’s location relative to the other files on the site has changed; it’s
now inside a folder at the root level.
WBER
q}g" Leave the template files inside the Templates folder and do not store
& - : . .
any non-template files there. This helps you avoid causing errors to tem-
plate paths.
6. To create an editable region, select the content on the template and

choose Insert~>Template Objects— Editable Region. Enter a name for
the editable region and click OK.

Each editable region can contain any asset or combination of items such
as a word or block of text, a graphic, a table cell, or even an entire table.
Dreamweaver prompts you to name each editable area. Name them using
a descriptive term to define their purpose, such as header, bodytext, or
storephoto. When naming editable regions, use single or conjoined words
written in all lowercase letters without spaces or any special characters.

For a more in-depth discussion of editable regions, see “Working with
Editable Regions,” later in this chapter.
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Using server scripts in templates

Of necessity, some server scripts must be
added to the document code above and below
the opening and closing <htm1> tags. When
server scripts are placed inside templates,
however, Dreamweaver may not always copy
the script code — or subsequent changes
made to it — to pages generated using a par-
ticular template, and that could cause signifi-
cant server errors when scripts in the body of
a template-based document depend on these
“outside HTML" scripts.

Though Dreamweaver warns you about changing
outside HTML scripts, you can avoid the problem

altogether by adding the following code to the
<head> area of the template:

<!-- TemplateInfo
codeOutsideHTMLIsLocked="true”

-—>

The addition of this line of code to the head of
the template forces Dreamweaver to copy any
changes to scripts outside the <htm1> tags to
documents based on that template.

Keep in mind that adding this code removes the
ability to edit these scripts in the template-based
documents. Therefore, you can either edit the
scripts in the template or edit them individually
in the template-based documents, but not both.

7. Save and close the template.

Template files automatically are saved in the Templates folder with the
.dwt file extension; when opened in the Dreamweaver workspace, they
display the word <<Template>> in the title bar.

Creating a new template from scratch

To create a new, blank template into which you add all the necessary con-
tent, follow these steps:

1. Choose Filec>New to open the New Document window, which is shown
in Figure 2-2.

2. To create a new, untitled template page, select Blank Template from
the Category list and a template type, such as HTML Template, from
the Template Type list.

3. Click the Create button.

The new template page opens as an untitled, unsaved template file
inside the Dreamweaver workspace.

4. Add content to the new template.
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New Document

@ Blark Page
@ Blank Template
'-ib Pags from Template

Template Type: Layout:
ASP JavsSeript template
ASP YEScript template
5P MET C# template
5P HET VE template
ColdFusion template
HTML template

<none ~
1 colurnn elastic, centered
1 column elastic, centered, header and
1 column fixed, centered
1 column fixed, centered, header and f
1 1 colurn liquid, certered =ojprevieyt
1 column liquid, centered, header and f

5P template
2 colurn elastic, left sidebar

VDT Bt

,_] PHP template s Jastic, left sidebar, haad
3, column slastic left sidsbar, header
Figure 2-2: Sk Page from Sample 2 column elastic, right sidebar
C 2 calumn efastic, right sidebar, header
reate , Other 2 column fixed, left sidebar
2 coln ised, ek sidebar, header an| | DYEeMWeaver template document
anew 2 coluran iced, right sidebar
2 column fixed, right sidebar, header &
tem p | ate 2 colurnn hybrid, left sidebar
) 2 column frybrid, left sidebar, header 2 | DacType: XHTML 1.0 Transkional |
using the 2 column hybrid, right sidebar
2 colurin hybrid, right sidebar, header
Bl an k 2 colurin liquid, left sidebar s -
2 column liquid, left sidebar, header an
Tem p| ate 2 calurn liquid, right sidebar v
>
category.
<P When adding content to the template, pay attention to the document-

relative links and paths in the Properties inspector (see Book I, Chapter
3 for details). A correct path includes code that points from the
Templates folder to the linked document and appends the link with

the appropriate document-relative code, such as . . /contact.html
instead of contact.html. For best results, use the Point to File or
Folder buttons in the Properties inspector to ensure the links are cor-
rect.

To create an editable region, select the content in the template and
then choose Insert=>Template Objects=>Editable Region. Enter a name
for the editable region and click OK.

Read the upcoming section “Working with Editable Regions” for instruc-
tions on all the editable template region types.

Choose File>Save As Template.
The Save As Template dialog box opens (see Figure 2-3).

Save As Template

Figure 2-3:
Enter
template
details in
this dialog
box.

Ezxisting templates: Imyte'mplaﬁe

Site: | DWW CS4

SaveE

]
| Cancel

Description: | Master file For DFD Project

Save as! FﬂrDummias|

Help.
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7. From the Site drop-down list, select a managed site to save the new
file into.

8. (Optional) Add a description for the template.

The description displays in the Preview area of the New Document
window.

9. In the Save As field, provide the template with an appropriate file-
name. Then click Save.

Use all lowercase letters with no spaces or special characters for the
template name, as in abcwidgets.

Template files automatically are saved in the Templates folder with
the .dwt file extension; when opened in the Dreamweaver workspace
window, they display the word <<Template>> in the title bar.

Working with Editable Regions

WMBER
‘g'c
&

The editable regions are the parts of a template that are unlocked, or edit-
able, in a template-based page. These editable regions are perfect for areas
that are specific to the page’s purpose. For instance, each page may have its
own header graphic, text, and subnavigation areas.

Each editable region can contain any element or combination of elements
such as a block of text, a graphic, and a table. Although you may create as
many editable regions as you want, each template should have at least one
editable region.

Editable regions are the most basic form of editable areas on a template. In
addition to these, you can also create optional editable regions, repeating
regions and repeating tables, and editable tag attributes, as described later
in this chapter.

Creating editable regions

To create an editable region on a template, follow these steps:

1. Select the contents in the template file that you want to set as an edit-
able region.

For example, select a header graphic that displays the name of the page
in a special font (as shown in Figure 2-4). Or, rather than selecting con-
tent, place the insertion point at the point on the page where you want
to insert an editable area.
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Turn this header graphic into an editable region.
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When creating editable regions that include tables and layers (AP
Elements), pay attention to the source code of your selection. For exam-
ple, when you select the <td> tag and convert it into an editable region,
that editable region includes both the table cell and its contents. By con-
trast, when you make only the contents of a cell into an editable region,
only the contents of the cell become editable and any formatting associ-
ated with the table cell itself remains uneditable. Likewise, when creating
editable areas with layers, when you select a <div> tag along with the
layer’s contents, the layer’s positioning and contents are editable. But if
you select and convert only the contents of a layer into an editable region,
only the contents are editable and the layer’s position remains fixed.

Choose Insert~>Template ObjectsoEditable Region.

You can also click the Templates button on the Common category of the
Insert panel and choose Editable Region from the drop-down list.

The New Editable Region dialog box opens, as shown in Figure 2-5.



Figure 2-5:
Name
editable
template
regions.
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New Editable Region
Name!  Header
This region will be editable in documents
based on this template,

3. Enter a name for the new editable region.

Name editable areas using a descriptive term such as header, phone, or
headshot, using single or conjoined words written in all lowercase let-
ters without any spaces or other special characters.

4. Click OK.

Dreamweaver converts your selection into an editable region by adding tem-
plate markup comment tags in Code view. These editable content regions
begin and end with the following code:

<!-- TemplateBeginEditable> ... <!-- TemplateEndEditable -->

The space between the template markup indicates areas that remain edit-
able in template-based documents. Take care, however, not to modify the
template markup when working in Code view, as Dreamweaver uses this
markup to manage template updates.

In Design view, editable regions on a template are defined by a blue rect-
angular outline, topped by a tab labeled with the name you just provided,
surrounding the selection for the new editable region (see Figure 2-6). The
blue color is Dreamweaver’s preset editable region color, which you can
change in the Highlighting category of the Preferences dialog box. Choose
Edito>Preferences (Windows) or Dreamweaver=>Preferences (Mac).

Editable regions in pages created from templates are shown with the same
blue label and outline, clearly marking where content can be edited.

Removing editable regions

From time to time, you may need to remove an editable region from your
template. For example, because nested editable regions are not allowed in
Dreamweaver, you may decide to enlarge or reduce the size of an existing
editable region to better define the editable areas on the template, which
requires you to delete an existing region before defining a new area.

sajejdwa]
yum sayg Buipjing



252 Working with Editable Regions

Figure 2-6:
Editable
regions are
defined by a
blue outline
and tab
label.
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To remove an editable region from a template, follow these steps:

1. Open the template in the Dreamweaver workspace window.

2. Select the region by clicking the blue tab in the upper-left corner of
the editable region.

Or place your cursor inside the editable region you want to delete so
that Dreamweaver knows which code you want to remove.

3. Choose Modify=>Templates> Remove Template Markup.

Dreamweaver instantly removes the template markup for that editable
region, including the code in Code view and the blue outlines in Design
view. The content in that region isn’t deleted on the template. However,
for template-based files, you need to resolve the issue of where to place
any content that used to be in the removed region, which we talk about
in the next section.

Renaming editable regions

If you accidentally misspell an editable region label, you can remove and then
reapply the editable region with the correct spelling. But for simple name
changes to an editable region, Dreamweaver has an even better solution:



Figure 2-7:
Use the
Quick Tag
Editor to edit
code.

A\
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Select the region you want to rename by clicking the blue tab in the

For example, suppose you have an editable region called email that you

The Quick Tag Editor opens, shown in Figure 2-7, where you adjust the

If you prefer, you can also modify the code directly in Code view.

An even quicker method for renaming the editable template region on a
template is to select the editable region by clicking the editable region’s

1. Open the template in the Dreamweaver workspace window.
2.
upper-left corner of the editable region.
want to rename as address.
3. Choose Modify=>Quick Tag Editor.
code.
[ T N - o
- Dhone Namber Edit tag: i> TemplateBeginEditable name="pmail
e Phone {M
The code in the Quick Tag Editor looks something like this:
<!-- TemplateBeginEditable name="email" -->
4. Type the new editable region name in the area in quotes.
Using the same example, change email to address:
<!-- TemplateBeginEditable name="address" -->
blue tab and changing the name in the Properties inspector.
5. Choose Filez>Save to save the template.
Dreamweaver opens the Update Template Files dialog box.
6.

Click the Update button to update all the template-based files in the
managed site.

We don’t recommend clicking the Don’t Update button as it updates
only the template file, but not any of the template-based files.

Dreamweaver launches the Inconsistent Region Names dialog box,
shown in Figure 2-8, to map any new region names to any old region
locations. If you fail to map the regions, content in the old region name
area may be discarded on pages using the template.
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Figure 2-8:
Use the
Inconsistent
Regions
Names
dialog box
to map old
editable
region
names

to new
editable
regions.

Inconsistent Region Names
Select a new region For the content from repeating region contacts,
Name |Resolved
=l Editable regions
email Mot resolved>
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Help ;5;3;:?'%‘1) L oK
name [%
phone
7. In the Name column under Editable Regions, select the old edit-
able region name. Then choose the new region name from the Move
Content to New Region drop-down list.
After selecting the new region name, you see the new region name listed
under the Resolved column of the dialog box.
8. Continue mapping remaining regions, if you need.
9. Click OK.
Dreamweaver automatically closes the Inconsistent Region Names
dialog box and finishes the region renaming process by updating all the
pages on the site that use the template you just modified.
10. Click the Close button on the Update Pages dialog box.

The process of changing the region name is complete. If you have any
files open that use the template you just modified, save the files before
closing them to accept the most recent changes.

Exporting a site without any template markup

In addition to removing or renaming editable regions, Dreamweaver can export
an entire Web site full of template-based files to another folder without any
template markup. The exported file can even be in XML format if you like. One
benefit of removing the markup is that the file sizes may be slightly smaller.
Furthermore, when you export an XML version, the XML file is transportable as
well as easily importable back into Dreamweaver and other applications.

To export a site without any template code, follow these steps:

1.

Choose Modify=>Templates=>Export without Markup.

The Export Site without Template Markup dialog box opens, as shown in
Figure 2-9.
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Figure 2-9:
Export
template-
based Web
files without
template
markup.

Export Site Without Template Markup
Choose a folder to export the site inta.

Keep template data files

Extract only changed files

2. In the Folder field, choose a destination folder outside of the current
managed site.

3. To save an XML version of exported template-based documents, check
the Keep Template Data Files check box. To update changes to files
that have already been exported, check the Extract Only Changed
Files check box.

XML (eXtensible Markup Language) is a simple text format that is used
to describe data for electronic publishing and exchanging data on

the Web. Visit the W3.org (www.w3 . org/xML) and W3Schools (www .
w3schools.com/xml/xml_whatis.asp) Web sites to discover more
about XML.

4. Click OK.

Creating Optional and Optional Editable Regions

Use optional regions on a template for content such as graphics or text that
may or may not be needed on every template-based page. For example, you
can create an optional region for a Back to Top link that can be either visible

or hidden, depending on the length of the text placed on the page above it. By
using optional regions, you let the users of template-based files decide whether
they want to include the optional region in the pages they’re adding content to.

Within optional regions, you can also set values for template parameters
(such as true/false operations) and make conditional statements (such as

if . . . else statements) that can later be edited in the template-based
file. Dreamweaver adds template comment tags to the page code for the new
optional region in two locations. In the head, you see something like this:

<!-- TemplateParam name="saleImage" type="boolean" value="true" -->

Then in the code, where the optional region appears, you see additional
comment tags like this:

<!-- TemplateBeginIf cond="saleImage" -->
<p><img src="/images/onsale.gif" width="100" height="23"> </p>
<!-- TemplateEndIf -->
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Figure 2-10:
Use this
dialog box
to specify
optional
regions
within a
template.

Similar to regular optional regions, optional editable regions are also controlled
by the template user from within the template-based page, but have the added
feature of allowing the template user to edit the optional region’s contents.

Creating optional regions

To create an optional region, follow these steps:

1. Open the template in the Dreamweaver workspace window.
2. Select the content that you want to set as the optional region.
3. Choose Insert->Template Objects=>Optional Region.

You can also click the Templates button on the Common category of the
Insert panel and choose Optional Region from the drop-down list.

The New Optional Region dialog box opens, as shown in Figure 2-10.

New Optional Region
Biasic Advanced
: :
Mame: | OptionalRegioni
Show by default

4. On the Basic tab, enter a name for the new optional region and enable
or disable the Show by Default option.

When Show by Default is enabled, the new optional region appears on
the template-based page; when disabled, the optional region is hidden
on the template-based page.

5. (Optional) On the Advanced tab, enter additional parameters or
expressions for the region:

¢ Use Parameter: Select this option to choose an existing parameter
from the drop-down list that the selected content should be linked to.

¢ Enter Expression: Choose this option to write your own template
expressions for controlling whether the region is visible or hidden by
default, such as the expression COUNTRY=='United States'.

Use parameters to control the display of the optional region or expres-
sions to define conditional statements, suchas if . . . else state-
ments or true/false operations. Regions can have a default setting of
either show or hide.
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Figure 2-11:
Specify
optional
editable
regions
within a
template.

0.
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Click OK.

The new optional region is inserted onto the template.

Creating optional editable regions

To create an optional editable region, follow these steps:

1.
2.

Open the template in the Dreamweaver workspace window.

Click your cursor inside the template file where you want to insert the
optional editable region.

Insert the optional editable region before inserting the content into the
region: You can’t wrap an editable region around a selection.

Choose Insert~>Template Objects>Editable Optional Region.

You can also click the Templates button on the Common category of the
Insert panel and choose Editable Optional Region from the drop-down
list.

The New Optional Editable Region dialog box opens.
On the Basic tab, enter a name for the new optional editable region.

(Optional) Click the Advanced tab (shown in Figure 2-11) to add other
options such as parameters for conditional statements or expressions.

Hew Optional Region

Select an existing parameter, or enter an expression ko determine whether
the region is visible. Cancel

Eiasic Advanced
Ok
() Use parameter; <Mone> | Help

() Enter expression:

OptionalRegionl

Far example: LANGUAGE=="English'

6.

See Step 5 in the preceding section for details on setting parameters and
entering expressions.

Click OK.

Modifying optional regions
After you add an optional editable region to a template, you can modify its
settings, including whether the region is hidden or showing.
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Creating Repeating Regions

To modify an optional region, follow these steps:

Open a template-based document in the workspace window.

Inside the Document window, do one of the following to open the
Optional Region dialog box:

¢ Design view: Click the template tab of the optional region you want
to edit.

e Code view: Click the comment tag of the optional region you want to
edit.

Click the Edit button in the Properties inspector.
The New Optional Region dialog box opens (refer to Figure 2-10).

. Make any desired changes to the optional region.

Click OK when you finish making changes.

Creating Repeating Regions

Repeating regions in a template are wonderful to use when you have consis-
tent content areas that repeat, such as rows in a table, but are unsure as to
how many sections any particular page may need. With a repeating region, the
number of sections can be controlled from within the template-based page,
whereas the overall layout and design is still controlled by the template.

Figure 2-12:
Click these
buttons to
manage
the content
inside the
repeating
region.

For example, Figure 2-12 shows a repeating table that lists all of ABC
Company’s store locations by name, phone number, and address. From
inside the template-based page, the template user can add, delete, and reor-
der table rows by clicking the repeating region buttons.

Add new row Move row down

Repeat: contacts

Address

Phone Number

store:

phone

Jur Main Stare

Hoo-555-1212

Hz3 Main Strest

store
Covwntown Store

phone
Bo0-555-2121

address

56 Front Street

store

[Alaterfront Store

phone
Bo0-555-3233

address

780 Water Street

Stoke
larehonse Store

phone
H00-555-5555

address
15 Market Blvd.

store
DCorporate Head|

ua.

ters

phone
Hoo-555-2323

address

Hooo Capital Ave,

Delete row Move row up

Adjust table rows with the repeating region buttons:

4+ Add a new row: Click the plus (+) button.
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4+ Delete a row: Place your cursor inside an editable area in the row you
want to remove and click the minus (=) button at the top of the table.

4+ Move an entry up or down: Place your cursor inside an editable area on
the row you want to adjust and click the Up or Down arrow buttons at
the top of the table.

You can also choose Modify=>Templates and choose a repeating entry or
move position option from the submenu.

You can add two kinds of repeating regions to a template file: repeating
regions and repeating tables. Although repeating regions are mostly used for
tables, you can use them for other things as well, such as a product detail
layout including text and graphics. If you need a region’s contents to be
editable, create a regular editable region from that content: The repeating
regions themselves are not editable.

Creating repeating regions
To create a repeating region, follow these steps:

1. Open the template in the Dreamweaver workspace window.

2. Place the cursor where you want to insert the new repeating region.

3. To add the repeating region, choose Insert->Template Objects—>
Repeating Region.

You can also click the Templates button on the Common category of the
Insert panel and choose Repeating Region from the drop-down list.

The New Repeating Region dialog box opens.
4. Enter a name for the new repeating template region.

When naming repeating template regions, use single or conjoined words
written in all lowercase letters without spaces or any special characters.

5. Click OK.

Dreamweaver inserts the new repeating region into the template.

Creating repeating tables

Use a repeating table for making editable areas with repeating rows. You can
also set table attributes and pick which consecutive rows within the table
repeat.

Follow these steps to create a repeating table:

1. Open the template in the Dreamweaver workspace window.

2. Place your cursor inside the file where you want to insert the table.
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Figure 2-13:
Add a
repeating
table to your
template.

3. Choose Insert->Template Objects=>Repeating Table.

You can also click the Templates button on the Common category of

the Insert panel and choose Repeating Table from the drop-down list to

open the dialog box.

The Insert Repeating Table dialog box opens, shown in Figure 2-13.

Insert Repeating Table

Cell padding: | 0

Help

Raws: 3
Columns: | 3 Cell spacing: | O
Width: | 75 Percent | v

Border: 3
Repeat rows of the table:
Starting row: 1 Ending row: | 1

Region name: RepeatRegion

4. Specify the following attributes for the new repeating table:

¢ Rows and Columns: Enter the number of rows and columns for the

repeating table.

e Cell Padding: Enter a number in pixels to increase the space

between the cell’s walls and its contents. If left blank, the cell pad-
ding displays as if it were set to 1 pixel. To remove cell padding com-

pletely, set the size to 0.

¢ Cell Spacing: Enter a number in pixels to increase the walls of the
repeating table between the cells. If left blank, the cell spacing dis-
plays as if it were set to 2 pixels. To remove cell spacing completely,

set the size to 0.

e Width: Enter a number to set the fixed width of the repeating table in

pixels or enter a percentage width between 1 and 100 percent.

¢ Border: Enter the number in pixels for the table border. If left blank,
the border displays as if it were set to 1 pixel. To remove a border

completely, set the border size to 0.

¢ Starting Row: Enter the row number that begins the repeating region

within the repeating table.

¢ Ending Row: Enter the row number that marks the end of the repeat-

ing region within the repeating table.

¢ Region Name: Specify a name for the repeating region within the
repeating table.

5. Click OK.

The repeating table is inserted into your template.
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Add alternating row background colors

After (and only after) you insert a repeat-
ing table in your template, you can add some
template markup to create alternate table row
background colors in your template-based
pages. The markup is added to the first repeat-
ing region <tr> tag in the template, inside
Code view:

<tr bgcolor="@@(_index & 1 ? '#FFFFFF'
'#FFFFCC')@@">

You can change the #FFFFFF (white) and
#FFFFCC (pale yellow) hexadecimal values
of the alternating rows in the sample code to
any other colors to match your particular Web
design color scheme. The main thing is that the
syntax is correct and the code is placed in the
right part of your template.

The following example shows the template’s
repeating table code with repeating regions
and alternating background row colors (see
the figure):

<table width="600" border="1"
cellpadding="3" cellspacing="0"
bordercolor="#666666">

<tr><th>First Name</th><th>Last Name</
th><th>Telephone</th></tr>

<!-- TemplateBeginRepeat name="contacts”
-—>

<tr bgcolor="@@(_index & 1 ? '#FFFFFF' :
'"#FFFFCC')@E">

<td> <!-- TemplateBeginEditable
name="firstname” --> firstname
<!-- TemplateEndEditable -->

</td>

<td> <!-- TemplateBeginEditable
name="lastname” --> lastname
<!-- TemplateEndEditable -->

</td>

<td> <!-- TemplateBeginEditable
name="telephone” --> telephone
<!-- TemplateEndEditable -->

</td>

</tr>

<!-- TemplateEndRepeat -->
</table>

After you add this line of code to the repeating
table on your template, any new rows added
to the repeating region on the table in the
template-based page use the alternating row
colors you specified in the code.

. "
Repeat: contacts  +|=[7|+|

store phane
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Creating Editable Tag Attributes

Editable tag attributes let you create unlocked tag attributes in a template,
which can be modified from within the template-based page. For instance, a
table may be locked into the page design, but with editable tag attributes, its
width or border thickness may be set by the template user. Set as many edit-
able tag attributes in the template as you want. Attributes can include text,
Boolean (true/false), URL, and color data types.
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Figure 2-14:
Specify
editable tag
attributes
in your
templates.

To create an editable tag attribute, follow these steps:

1. Open the template in the Dreamweaver workspace window.

2. Select the tag of the object you want to add an editable tag
attribute to.

3. Choose Modify=>Templates=>Make Attribute Editable.
The Editable Tag Attributes dialog box opens, as shown in Figure 2-14.

Default:

Editable Tag Attributes
haose which attributes of this IMG tag should
be editable.

Attribute: | SRC v
Make attribute editabls
Label: | src
Type: | Text v

« fimages/header,gif

To change the value of this attribute in a page
based on this template, choose Madify =
Template Properties.

To change whether it is editable, use the "Make
Attribute Editable” command again.

4. Enter details for the attribute you want to make editable:

Attribute: If the attribute you want to make editable is listed in the
drop-down list, select it. If the attribute is not listed, click the Add
button to enter the name of the new attribute.

Make Attribute Editable: Enable this feature to make the attribute
editable. After you enable this field, the remaining fields in the dialog
box become active.

Label: Type a unique name for the attribute to help identify its pur-
pose, such as tableBorder or buttonSrc.

Type: Choose a value from the drop-down list that helps set the attri-
bute’s editability. Your options include the following:

Text: Text values allow you to type a text value to edit the tag attri-
bute. For example, you can use text to define the value (left, right, or
center) of the align attribute.

URL: Select this option to add a link to an object, such as the path to
the source file of a graphic.

Color: Choose this option to select a color from the color palette.

True/False: Select this option to change the value of an attribute
from true to false, or vice versa.



Figure 2-15:
Editable tag
attributes
can be
modified in
template-
based files.

Creating Editable Tag Attributes 2 63

e Number: Select this option if you want to type a number for the
value of an attribute, such as when you want to change the border
attribute of an image.

e Default: This field shows the value of the selected object’s current
attribute. Type a new initial value for the parameter in the template-
based file.

5. If creating multiple editable tag attributes for the selected tag, repeat
Steps 2 through 4 until you’ve set all the editable tag attributes.

6. Click OK to accept the settings.

Each editable tag attribute adds template parameters to the code
whereby the initial value of the attribute is set in the template and the
parameter can be changed from within the template-based document.

Changing editable tag attributes
in template-based files

To modify an editable tag attribute from within a template-based document,
open the file in the Dreamweaver workspace window and do the following:

1. Choose Modify->Template Properties.

The Template Properties dialog box opens, as shown in Figure 2-15.

Template Properties

IMame |¥alue *

sre . fimagesiheader. gif Cancel
width 229

HiEl

Help

srct | . fimages/header.gif

[ sl rested templates ta control this

2. Select the editable tag attribute to modify from the Name column.

The bottom half of the dialog box updates to display the corresponding
attribute editing options.

3. Modify the selected editable tag attribute.
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For instance, if one of the attributes allowed the value of the background
color of the page to be modified, the bottom of the dialog box displays a
Background Color Picker field for selecting a new background color.

4. 1f modifying multiple editable tag attributes at once, repeat Steps 2
and 3.

5. Click OK.

Resetting an editable tag attribute to uneditable

To change an editable tag attribute to an uneditable one, open the template
and follow these steps:

1. Select the editable tag in Code view.

Selecting the tag makes the editable attribute for this tag automatically
display in the Attribute field of the Editable Tag Attributes dialog box.

2. Choose Modify->Templates>Make Attribute Editable.
The Editable Tag Attributes dialog box opens (refer to Figure 2-14).

3. Deselect the Make Attribute Editable check box next to the attributes
you want to disable and click OK.

4. Save the template and update all the template-based files.

Building Nested Templates

Nested templates are templates whose design layouts and editable areas

are based on another template file. A nested template is created when a
template-based file is modified and then resaved as a new template file

with new editable regions. For example, you can create a nested template
that contains specific layout elements, such as a real-estate listing Web site
where the detail information for each listing shares the same layout yet the
overall page layout and design instructions come from the original template.

To make nested templates quickly, begin the creation process with a new
template-based document that uses the base template you intend to modify.

Creating nested templates

To create a nested template, follow these steps:

1. Create a template-based document from the base (original) template.

Choose Filew>New and click the Page from Template button in the New
Document dialog box. Select the managed site from the Site listing, then
select the template that you want to use, and click the Create button in
the dialog box. A new template-based document opens in the workspace
window.
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The nesting feature doesn’t work if you attempt to create a new template
from an existing template file. You must create the nested template from
a template-based document.

Choose Filer>Save as Template.

You can also click the Templates button on the Common category of the
Insert panel and choose Make Nested Template from the drop-down list.

The Save As Template dialog box opens.
Name the new nested template and click OK.
Add content and new editable regions to the nested template.

For example, a new nested area can contain a table layout with an image,
a header graphic, and a nested table for displaying content. For details
on creating an editable region, see “Working with Editable Regions,” ear-
lier in the chapter.

When you finish making changes, save the file before creating
template-based pages from the new nested template.

Modifying nested templates

By default, the base template passes along any editable regions to the nested
template. To convert an editable region passed through from a base tem-
plate to a nested template into an uneditable region, you need to add some
markup to the nested template.

To prevent an editable region from being passed to the nested template,
follow these steps:

1.
2.

Open the nested template in the Dreamweaver workspace.
In Code view, add the following code to the editable region code:
@@ ( " " ) @@

Add this code anywhere between the template markup tags: <! --
InstanceBeginEditable --> <!-- InstanceEndEditable -->

For example, code would change from

<td><!-- InstanceBeginEditable name="Address" -->
Address 1
<!-- InstanceEndEditable --></td>

to this:
<td><!-- InstanceBeginEditable name="Address" -->
@@(" ")e@e@ Address 1

<!-- InstanceEndEditable --></td>
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Figure 2-16:
In Design
view,
uneditable
regions

in nested
templates
display

a small
expression
icon.

Blocked editable regions inside nested templates display with a little expres-
sion marker inside their boundaries, as shown in Figure 2-16. In Design view,
they also display with an orange highlighting color around the region, com-
pared to the blue used to identify regular editable regions.

Expressionicon
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£3 nested template-based
. padge.</p>

16

. w

Template:base
EditRegiond

EditableRegion]

EditRegion2
L8] This area will not be editable in
the nested template-based page

EditRegion3

EditRegion3

ceieditable> <p> 100% 234

WMBER
@ﬁ
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Although nested templates look nearly identical to base templates, they do
not necessarily share common areas when edits are made to the base tem-
plate. For example, if you add a sentence to a noneditable region on the
base template, that content doesn’t pass through or appear on the nested
template.

Creating a New Document from a Template

After you create a template and set all the editable regions needed inside it,
you can begin building the Web site with pages generated from the template.

Create a new template-based page by following these steps:

1. Choose Filec>)New to open the New Document dialog box.

2. Click the Page from Template button to select the template by site and
template name.



Figure 2-17:
The
Template
tabin
Design
view.

Figure 2-18:
The locked
symbol.
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Editing Templates and Updating Pages

Be sure that the Update Page When Template Changes check box is
checked. Then click the Create button. The new template-based page
opens in the Document window.

Choose Filer>Save to save the new template-based file to the local root
folder of the managed site.

The file is saved as a regular HTML file based on a Dreamweaver tem-
plate. As shown in Figure 2-17, template-based pages are quickly identifi-
able by the yellow highlighted rectangle displaying around the inside of
the entire document, topped by a yellow Template: filename tab at the
top right edge of the page.

Template tab

EE0 |?UU |?5
bl v 4y

Template:ForDummies [**

4.

Add page-specific content to the editable areas of the page.
Add text, graphics, tables, and other elements as you need.

Locked uneditable regions are easily identifiable by the mouse pointer
changing into the locked region pointer (see Figure 2-18).

For Parents
For Teachers

: [main

S re—
I Repeat: contal
i |fstors

{ |[Pur Main

Continue building all the pages for the Web site in a similar fashion until
your site is complete, fully tested, and ready for uploading.

Editing Templates and Updating Pages

Whenever you modify and save a template, Dreamweaver not only rec-
ognizes that the template has changed, but also gives you the option to
automatically update all the documents on the local managed site that were
created with that template. If you’d rather selectively update template-based
documents, Dreamweaver provides a method for that as well.
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Figure 2-19:
Dream-
weaver
automates
the
template-
based page
updating
process.

Modifying a template and updating
all the pages that use it

You can update a template in Dreamweaver whenever you want and then
apply the changes to all the files based on that template. For example, sup-
pose that you want to change the name of one of the main navigation links
(for example, changing “Buy” to “Order”) on all the template-based pages
on your site. To make the change, open the template that you used to
create the template-based pages and modify the link and any other content
that may need changing. When you save the template with these changes,
Dreamweaver then updates all the pages created with that template.

To edit a template and update all the pages that use the template, follow
these steps:

1. Open an existing template by double-clicking the template file listed
inside the Templates folder in the Files panel.

You can also select the template from the Templates folder in the Files
panel and choose Filec>Open from the Files panel Options menu.

2. Make any changes to the template.

As long as the template file is open in the Dreamweaver workspace,
you can perform multiple undos from the History panel or choose
Edit=>Undo.

3. Choose File=>Save.

Dreamweaver recognizes any changes made to a template and opens the
Update Template Files dialog box (shown in Figure 2-19), which prompts
you to let the program automatically update all pages that use the template.

Update Template Files

Update all files based on this template? Update:
pagel.html -
pageZ.html Don't Update

4. To update any pages that use this template, click the Update button.

When the update is complete, the Update Template Files dialog box
displays a status log to confirm how many files were examined and
updated. Dreamweaver actually hard-codes the changes into all the files
that use the template. You can now confidently upload all the changed
documents to the remote server.
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Another automatic feature Dreamweaver performs when saving changes

to templates is syntax checking to ensure that any expression or template
parameter added in Code view is accurate. If the syntax is bad, Dreamweaver
displays an error message with a reference to the line of code containing

the error. You can manually check template syntax at any time by choosing
Modify=>Templates=>Check Template Syntax.

Although you can edit regular pages in Contribute, you must edit templates
in Dreamweaver. For more information about working with Contribute sites,
turn to Book VL.

Selectively updating pages with the

most recent version of the template

If you make edits to a template but don’t want to apply them to all the pages
based on it, such as when you add a template to your site from an external
source or edit the template in another program, you can manually update
the pages. This is also how you can make modifications to a template before
committing to updating all the pages on the site, as long as you click No to
the Dreamweaver prompt that asks if you want to update all the files that
use that template. You can use two methods to selectively update template-
based pages.

To update a single template-based document, follow these steps:

1. Open the template-based document in the workspace window.
2. Choose Modify->Templates->Update Current Page.

The current page updates to reflect the most recent version of the tem-
plate file upon which it is based.

3. Choose FilerSave to save the open page.
You must save the page to save the updates.
You can update multiple template-based documents — an entire site or just
the files that are attached to the specified template — at once by following
these steps:
1. Choose Modify->Templates->Update Pages.
The Update Pages dialog box opens.
2. Choose one of the following options:

¢ Update the entire site: Select Entire Site from the Look In drop-down
list; select your site from the second drop-down list.

e Update pages with a specific template: Select Files that Use from the
Look In drop-down list; select the Dreamweaver template .dwt file
that you want to use to perform the update.

sajejdwa]
yum sayg Buipjing



270 Applying Templates to Pages

Click the Start button to begin the update.

The Update Pages dialog box performs the update. To see the status log,
click the Show Log check box. Updates are immediate.

When you finish your update, click Close to close the dialog box.

Applying Templates to Pages

You can selectively apply templates to pages open in the Document window
with the Assets panel, regardless of whether you previously applied the
template.

To apply a template to a new, open document from the Assets panel:

4 Click the Templates button along the left margin of the Assets panel,

<+

select the template from the list, and click the Apply button at the
bottom of the panel.

Click the Templates button along the left margin of the Assets panel,
then drag and drop the template file into the open Document window.

If you want to apply a template to a document that currently uses a different
template, follow these steps:

1.
2.

Open the document in the Dreamweaver workspace.
Choose Modify~> Templates=>Apply Template to Page.
The Select Template dialog box opens.

Choose a site from the list of managed sites and a template from the
list of available templates in that site.

Click the Select button in the dialog box.
The Inconsistent Region Names dialog box opens.

Map the editable regions from the old template to the new template.
In the Name column under Editable Regions, select the old edit-
able region name. Then choose the new region name from the Move
Content to New Region drop-down list.

This tells Dreamweaver which editable regions in the new template
the content from the old template’s editable areas should go into. For
instance, the old template may have two editable regions called body
and head, whereas the new template has two regions called main and
header. Select and match those regions from the old template to the
regions on the new template so the content on the existing page moves
to the specified region of the new template.
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If you do not properly map the regions from the old template to the new
one when prompted, the information in those regions will not be copied
as the new template is applied.

When regions in the old and new templates have the same names,
content in those editable regions are automatically matched up. If all
regions match up, the mapping process happens automatically.

6. Choose Filer>Save to save the updated page.

For an alternate method, create a new template-based page, and transfer
content (by copying and pasting) from the editable regions on the original
file to the editable regions on the new template-based page.

Detaching Templates from Pages

Why would you want to detach a template? You may need a page that looks
like the rest of the site but is not controlled by the template, or perhaps a
particular page needs to be significantly different from the rest of the site,
and modifying a template-based page is easier than building the new page
from scratch. Or maybe you want to quickly remove all the editable regions
and other template markup on a page rather than having to selectively
remove the restrictive code. Whatever your reason, the detachment process
is fairly simple.

To detach a template from a page, follow these steps:

1. Open the document in the Dreamweaver workspace.
2. Choose Modify->Templates=>Detach from Template.

All the template-specific markup is removed from the file, making any
formerly uneditable areas in the code fully editable again.

3. Save the file.

<MBER After you detach the template from the page, you can reattach it by choos-
ing Modify=>Templates>Apply Template to Page. Additionally, you can reat-
tach the template by undoing the detachment through the History panel as
long as you keep the document open (see Book Ill, Chapter 4 for more on
the History panel). However, after you save and close the file, you have to
reattach the template manually.

Managing Templates

Use the Assets panel for renaming and deleting any of your existing tem-
plates. To display the list of templates, click the Templates button along the
left margin of the Assets panel (see Figure 2-20).
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Renaming a template

Should you ever need to rename a template, Dreamweaver can automate the
name change across all the files in the managed site.

To rename a template in the Assets panel, follow these steps:

1. From the Templates listing in the Assets panel, click to select the tem-
plate name that you want to change.

Make sure that the template file you're renaming is not open. You can
also rename the template from the Files panel.

filename.

Click the filename again so the text becomes selectable; type a new

If you accidentally double-click and open the template for editing, try the
single-click, pause, single-click method again on the template filename.

Press Enter (Windows) or Return (Mac) to complete the name change.

Dreamweaver prompts you to update all the template-based documents

that use this f

ile.

4. Click the Update button to update all the template-based files.

Deleting a template file

At the end of a project, you may need to delete a template file that wasn’t

used on the site:

1. From the templates listing in the Assets panel, click to select the tem-
plate that you want to delete.
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2. Click the Delete button at the bottom of the Assets panel.
After clicking the button, you're prompted to confirm the deletion.

\NG/
é““ When deleting files, remember that after they’re gone, your files are gone for
good. If you think you may need the file in the future, make a backup of the

entire managed site before making the deletion.

Documents based on a deleted template are not automatically detached
from it; rather, they keep their existing format, including editable regions. If
you need to, you can convert template-based files into regular HTML files by
choosing Modify=>Templates>Detach from Template.
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Chapter 3: Using Library Items
and Server-Side Includes

In This Chapter

v Creating library items
+ Managing and editing library items
v+~ Creating server-side includes (SSIs)

v~ Inserting and editing SSIs

Dreamweaver provides you with two different ways of creating reusable
assets for your Web pages: library items and server-side includes. You
can add both to documents, templates, and template-based pages, and both
can contain any content that normally goes in the body of the page. Here’s a
closer look at the two options:

4+ Library items: These special files contain content of your choice that
you can insert onto multiple Web pages, yet manage the contents of in
one location. After it is inserted on a page, the library item content gets
hard-coded into the HTML surrounded by special Dreamweaver library
item comment tags. Any time you edit the library item’s contents, all the
pages that contain the library files are automatically updated. Library
items are great for subnavigation, data tables, copyright notices, and
other common page elements that need frequent editing.

4+ Server-side include (SS)) files: Like library items, SSIs are special files
containing specific content that you can add to multiple Web pages and
update in one centralized location. The main difference from library
items, however, is that SSI content isn’t hard-coded into the HTML file
it’s inserted into; instead, SSI files are saved as external HTML files and
are then linked — similar to CSS — to a file. When the page is viewed in
a browser, the browser finds the external SSI file and displays that con-
tent as if it were naturally coded into the page. Use SSIs for sections of
Web pages that need frequent or constant editing on larger Web sites,
such as a navigation item, daily menu, or class schedule.

This chapter shows you how to create, use, and edit library items and
server-side includes.
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Introducing Library Items

If you're familiar with Dreamweaver’s templates (discussed in Book III,
Chapter 2), library items work in a similar way. Whereas templates are the
master documents from which you create new documents, library items are
simply master page elements (such as navigation menus, tables, and images)
containing whatever content you desire. You can use them as many times as
you want without the need for rewriting the code each time. Library items
are typically placed inside templates or used as stand-alone master elements
in regular or template-based pages.

To understand more plainly how library items work, think of the original/
duplicate relationship of a rubber stamp. Your rubber stamp has the original
design, and when you ink it up, you can stamp it to make as many copies of
that stamp’s design as you like. Similarly, with library items you create the
original library item, save it, and then insert a copy of it when and where you
need it on your Web pages.

Creating Library Items

Create library items from any selected content in the body of your page,
including text, graphics, forms, tables, media, and JavaScript. If the selected
content has images or other linked items, those items must stay in their
original locations for the library item to work properly.

When your library items include Dreamweaver JavaScript behaviors (which
let visitors interact in some way with your Web page), Dreamweaver also
copies the element and its event handler (an action that specifies when the
event occurs, such as onMouseOver) to the library item file. Then, when
you insert that library item into another document, Dreamweaver automati-
cally adds the necessary JavaScript functions into the <head> area of the
file so the copied library item containing the behavior works in the new file.
By contrast, when hand-coding JavaScript behaviors, be sure to use the
Call JavaScript behavior as part of the library item to execute the code; the
behavior allows you to set a function or line of script to execute when a par-
ticular event happens in the browser. (See Book IV, Chapter 2 for more on
behaviors.)

Here are some general guidelines of when to use library items:

4+ Your Web site is small (less than 30 pages).
4+ You manage the site yourself.

4+ You expect to make periodic changes to the library items or you antici-
pate the library item content may need altering in the future.
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4 You understand that making edits to the library items requires a rewrit-
ing of all the pages on your site that use those library items, which
therefore means you must upload all the updated files to your server
before site visitors can view those changes.

4+ Your Web host doesn’t support server-side includes.
4+ Every bit of processor speed is important to you (pages with SSIs take a
little longer to load in a browser than pages containing library items).

Here are some good uses for library items:

4+ Footers
4+ Navigation elements

4+ Parts of your page/site that may require periodic updating and appear
on multiple pages, such as product tag lines, sponsorship listings, and
contact information.

4+ Copyright notices

One great use for a library item is a copyright notice at the foot of a page,
such as: Copyright 2008. All rights reserved. It uses the current year now, but
come January 1st, you need to update the year. Fortunately, when you're
ready to make the date change, you need to update only the original library
item while Dreamweaver updates all the pages that use the library item with
the new code.

Creating a selection-based library item

Follow these steps to create a library item based on content you've created:

1. In the Files panel, click the Assets tab and then click the Library
button in the left margin of the Assets panel.

The Library options appear in the Assets panel (see Figure 3-1).
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2.

In Code or Design view of an open document, select the content you
want to convert into a library item.

Library items can contain text, graphics, links, tables, JavaScript, Flash
movies, and other HTML code elements.

In the copyright example, select the copyright sentence in your docu-
ment such as: Copyright 2008. All rights reserved.

Click the New Library Item button in the Assets panel.

You can also choose Modify=>Library=>Add Object to Library to create a
new library item.

Dreamweaver converts your selected code into a library item with the
Ibi file extension, and then creates a Library folder and puts your newly
created library item there.

You know your code converted properly to a library item because it
displays in your page, in Design and Code views, as a block of code with
pale yellow highlighting.

Give your new library item a descriptive name, such as copyright, and
press Enter (Windows) or Return (Mac).

By default, new library items are called untitled.lbi until you rename
them in the Assets panel. See the later section, “Renaming library items”
for more on this.

Creating an empty library item

For times when you know you need a library item on your site but don’t
have the content for it yet — such as when a client still needs to send you
approved text — you can create and use an empty library item. You can edit
the library item when the content becomes available.

You can create an empty library item for editing at a later time by following
these steps:

1.

2.

In the Files panel, click the Assets tab and then click the Library
button in the left margin of the Assets panel.

Click the New Library Item button at the bottom of the panel.

A new untitled library item is added to the Library folder. Make sure
nothing is selected in the Document window before doing so; otherwise,
the selected content is converted into a library item. That means if you
have a library item selected on the page, it becomes duplicated.

Give your new library item a descriptive name and press Enter
(Windows) or Return (Mac).

You can now add the library item to your pages and edit the content at
any time.
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Changing library highlighting preferences

You can change the highlighting color and the highlight color with the color picker or type
visibility of the highlighting of library items in the the hexadecimal value in the text box.

AT RETEes CERg) 2% 4. Click Show to see the highlighted library
To alter the highlight color, follow these steps: color in your documents or deselect the

1. Choose Edit=>Preferences (Windows) or LS R 89 O s Ll el it

Dreamweaver=>Preferences (Mac) to open 5. Click OK.

the Preferences dialog box. To see library item highlight colors in your doc-

2. Choose the Highlighting category onthe left  uments, choose Viewr>Visual Aids=>Invisible
side of the dialog box. Elements. Toggle on and off the display of

3. On the right side of the panel, click the eyt el g,

Library Items color box to choose a new

Inserting a Library Item in Your Document

When you insert a library item in a document, the entire contents of that B

. : . . . ook Ill
library item are added to the page along with library item markup tags, as
shown in the following example:
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<!-- #BeginLibraryItem "/Library/copyright.lbi" -->&copy; Copyright 2008. All
rights reserved.<!-- #EndLibraryItem -->

Follow these steps to insert a library item on a page:

1. Place your cursor inside the open document where you want to insert
the library item.
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Setting the insertion point determines the location of the library item.
For example, if you want to insert a library item that’s a copyright
notice, place your cursor at the foot of a page.

2. Open the Library area of the Assets panel by clicking the Assets tab in
the Files panel and clicking the Library button at the left edge of the
panel.

The Library button looks like an open book.
3. Select the library item that you want to insert.

The Library area of the Assets panel contains a list of all available
library items for the currently managed site. If you have created library
items but do not see them in this listing, click the blue Refresh button at
the bottom of the Assets panel.
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4. Click the Insert button in the Library area of the Assets panel.

You can also drag and drop the library item from the Library area of the
Assets panel into your open document.

Notice that when you insert your library item, Dreamweaver writes opening
and closing comment tags along with your library item contents, as shown in
Figure 3-2.

72 library.html (===

M 9 <pr<emrHere is an example of normal code:<brl -~

= 10 </en>&copy; Copyright 2005, All rights

11 reserved. </p>

12 <pr<enrHere iz an example of Library Item code:</em><br>
<!-- #BeginlibraryTten "/Library/copyright.lhi™ -

13 &C0py: Copyright Z00&. All rights reserved. <!--
#EndLibraryltem --=</pk

14 <p3{&nhsp:{/1:>

15 <p> ™

b
s

3 Here is an example of rormal coda:

@ Copyright 2008 All rights reserved

il

Here iz an example of Library ftem code:
© Copyright 2008, All rights reserved.

P
=
i3

|ne

<hodys |<p| | & | O [100% «~|477x201v 1K/ 1sec Western European

NG/
S

If you want to insert the contents of a library item onto a page without the
library item markup, press Ctrl (Windows) or Option (Mac) while dragging
the item onto the document from the Assets panel. The content becomes
disconnected from the library source so the library item doesn’t control the
content.

Using library items sounds so easy that you may be wondering why you
wouldn’t use them. The main complaint about library items is this: Because
the library items are hard-coded into your pages, when you edit them, any
pages on your site that contain them must be updated with the new code
and subsequently uploaded to your server before site visitors can see those
changes. When your site has a lot of pages, the time the uploading process
takes to complete is a major consideration. This is especially an issue when
your site uses the Check In/Check Out system. Furthermore, updating library
items alters the Last Modified time of each file, making it more difficult for
you to track when a file’s unique content was actually last changed.
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Editing and Managing Library Items

3

After you successfully create a library item, you can edit it any time. You can
then apply those changes to a single page, the entire site, or all the files that
use the library item.

In addition to regular content updates, you may occasionally need to per-
form other management tasks such as renaming, deleting, detaching, dupli-
cating, or re-creating a library item.

Editing library items

Follow these steps to edit a library item:

1. In the Files panel, click the Assets tab and click the Library button in
the left margin of the Assets panel.

2. Select the library item that you want to edit.

If you're unsure what the library item is named, look in the preview pane
of the Library area of the Assets panel to see a thumbnail of the library
item.

3. Click the Edit button on the bottom of the Library area of the Assets
panel to open the library item in the Dreamweaver workspace
window.

You can also open the library item into its own Document window by
selecting the library item in Design or Code view and clicking the Edit
button in the Properties inspector.

4. Edit the library item and save the changes by choosing File->Save.

Because library items are hard-coded into your pages, Dreamweaver
prompts you to update all the pages that contain that item.

5. Click OK if you want Dreamweaver to find all the instances of the
original library item code on any pages on your site and update it to
match the changes you just made.

If you happen to skip this updating prompt, manually perform updates
by choosing Modify=>Library and the item you want to update.

Updating documents and sites that use library items
After editing a library item, you may want to manually update the files that
use it. You can update a single page from within that document, your entire
site, or all the files that use a particular library item.

To update a library item in the open document, choose Modify~Library=
Update Current Page.
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To update an entire site or all files using a specific library item, follow these
steps after you edit the library item:

1. Choose Modify=>Library->Update Pages.
The Update Pages dialog box opens, as shown in Figure 3-3.

ow Update Pages =

Look in; |Files That Use.|~ | copyright

Update: []Library items
[ Templates Help

Show log  Done

—
Status:
Figure 3-3: Updating C:iDocuments and Settings\Administrator| Deskkop\DW C54 HTML]
U d t Cone.

p ate files examined: 1

. . files updated: 0
library items Files which ceuild nat be updated: 0

. tokal tme: (0:00:00)
on an entire
site.

2. Select an option from the Look In drop-down list, depending on what
you want to do:

e Update the library item sitewide: Select Entire Site, and in the right
drop-down list, select the name of the site.

e Update the library item in all files: Select Files That Use, and in the
right drop-down list, select the library item name.

3. Check to see that Library Items is checked as an Update option.
4. Click the Start button to begin the update process.

Select the Show Log check box to view a status log of the update pro-
cess. There you find a record of the number of files on the site that were
examined and updated, plus any files that Dreamweaver was unable to
update.

5. When you finish, click Close.

Renaming library items

You can easily rename library items in the Library area of the Assets panel

of a managed site, and it’s recommended you perform your library name

o WING/ changes from within Dreamweaver.

S Renaming a library item outside of Dreamweaver breaks the library links to
the documents that use them.
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To rename a library item, follow these steps:

1.

2.

In the Files panel, click the Assets tab and click the Library button in
the left margin of the Assets panel.

Select the library item you want to rename.

If you're unsure of the library item’s current name, look in the preview
pane of the Library area of the Assets panel to see a thumbnail of the
library item.

Click the library item name again, so that the text becomes editable,
and type the new name.

If you accidentally double-click and open the library item for editing, try the
single-click, pause, single-click method again on the library item filename.

After entering the new name, press Enter (Windows) or Return (Mac)
to complete the name change.

Dreamweaver opens the Update Files dialog box.
Click the Update button.

Dreamweaver automatically updates all the documents in the managed
site that use this library item. To prevent Dreamweaver from performing
the automatic update, click the Don’t Update button. For example, you
may want to delay if you intend on changing multiple library files on a site.

Deleting library items

To help keep your library items organized while developing your site, delete
any unused or unnecessary library items from the Library area of the Assets
panel by following these steps:

1.

2.

In the Files panel, click the Assets tab and click the Library button in
the left margin of the Assets panel.

Select the library item that you want to delete.

If you're unsure of the name of the library item you want to delete, select
an item from the list and look in the preview pane to see a thumbnail of
the selected item.

To permanently delete the library item from the library, press the
Delete key on your keyboard and confirm the deletion.

You can also click the Delete button at the bottom of the Assets panel
and confirm the deletion.

This deletion process permanently removes the library item from the
library, although it doesn’t delete instances of that item from the con-
tents of any documents that used it. Therefore, delete your library items
with care.
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Detaching library items

After you insert a library item into a document, you can’t edit an individual
instance of it unless you break the link between the library item and the
document by detaching it and converting the library item into editable
text. Then, when you update the original library item after an instance

is detached, the detached instance doesn’t update along with the other
instances of the library item.

You may want to detach an instance of a library item from its source for
many reasons:

4+ You need to modify a significant portion of the library item on a single
page.

4+ You've only used the library item on a single page.

4+ You want to insert a library item created for another site. You insert
it on a page, detach it to break the links to that other site, and then re-
create the link within the currently managed site.

To detach a library item and convert it into editable text, follow these steps:

1. Select the library item in the document that you want to convert.
2. Click the Detach from Original button in the Properties inspector.

Dreamweaver alerts you that making the item editable prevents it from
receiving updates from the original library item.

3. Click OK.

The selected library item then loses its library item highlighting and
markup to become normal, editable text.

“&N\BER To modify library items that contain Dreamweaver behaviors, you must

& detach the library item from its source to make the behavior editable. After
editing the behavior, use the updated content to create a new library item or
use it as a replacement for its previous version.

Copying a library item from one site to another

To use an existing library item on one Web site in another managed site,
follow these steps:
1. In the Files panel, click the Assets tab and click the Library button.

2. From the list of Library items that appears, select the library item that
you want to duplicate.
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3. To make a copy inside another managed site, choose Copy to Site from
the Options menu in the Assets panel and select the desired managed
site by name from the submenu.

Dreamweaver copies the duplicate into the selected managed site. If the

new site does not already have a Library folder, Dreamweaver creates
one and places the copied library item into it.

Re-creating library items

Occasionally, you delete a library item from the Library area of the Assets
panel even though instances of it still remain throughout the site. If you want
the library item back to control modifications made to all the instances, you
must re-create it.

Here’s how to re-create a library item:
1. In an open document, select the instance of the library item that you
need to re-create.

2. Click the Recreate button in the Properties inspector.

A new library item is added to the Library area of the Assets panel. If a
library item already exists there with the same name, Dreamweaver asks
if you want to overwrite the existing file. Click OK to proceed. Book IlI
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A master copy of the re-created library item is inserted into the Library
folder.

Understanding Server-Side Includes

If you understand how to create and use library items (as described ear-

lier in the chapter), you can quickly grasp the concept behind server-

side includes (SSIs). Like library items, SSIs can be composed of HTML,
JavaScript, or graphics. But unlike library items, they have no opening and
closing comment tags surrounding the code and the content of the SSI is not
hard-coded into your Web page. Rather, a simple line of code is added to
your page that points to the external SSI file on your server, like this:
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<!--#include file="serversideinclude.html" -->

Only the reference to, and not the contents of, the SSI file are part of the
include instructions.

An SSl is an external HTML file that a server adds to the page it’s inserted
on when a browser requests that page from the server. The server then pro-
cesses the include instructions and delivers a document that replaces the
SSI statement code with the content of the SSI file.
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When making the decision to use SSI, keep these points in mind:

4+ Servers process, or parse, pages with SSIs differently than regular HTML

documents, and that may put more demand on a server’s processor,
which in turn could lead to slower page serving for all the pages on your
entire site.

When you preview the file with the include instructions in a browser
locally (before testing it on a live server), your browser doesn’t parse
the SSI, in which case you may not see the include content on the page.

To solve this issue, Dreamweaver lets you preview documents in Design
view exactly as they’ll appear on a server. Furthermore, by checking the
Preview Using Temporary File option in the Preview in Browser category
of Dreamweaver’s Preferences dialog box, you can create a temporary
copy of the file for preview and testing that displays the SSI in your local
browser by mimicking how the file would behave on a server.

The SSI markup syntax must match the type of Web server the files are
being displayed on. Some servers are configured to examine all files to
see if they have server-side includes, whereas other servers examine
only files with the .shtml, .shtm, or .inc file extension.

Your particular server may require that you rename all files containing
SSIs with the .shtml, .shtm, or .inc file extension. For example, you may
need to rename a file with an SSI named menu.html to menu.shtml to
manifest the include properly. Check with your system administrator or
host provider to see whether you're required to change the file exten-
sion for documents with SSIs.

The bottom line is that you should test files containing SSIs on a server before
publishing them on the Internet, just in case the host server isn’t configured to
display them properly or you need to modify your code to support them.

Creating and Inserting Server-Side Includes

Like a regular HTML file, a server-side include file (an example of which is
shown in Figure 3-4) is composed of the content you want to include on
another page, and should be saved with the .html or .htm file extension.
What it shouldn’t contain, however, are any <doctype>, <meta>, or open-
ing or closing <html>, <head>, <title>, or <body> tags in the code. This
is because the SSl is included on another page that already has those HTML
tags. Figure 3-5 demonstrates how an SSI file is included in the code of
another document.
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. copyright.html ==
[y| 1 &comy: Copyright 2005. ALl rights reserved. |
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If any one or more of the following general guidelines apply, you may want to

use server-side includes:

+*
*
+*
+
+

+

Your Web site is large (more than 30 pages).

Two or more people manage the site from different locations.
You have site content that needs frequent editing.

You are confident your host provider supports SSIs.

Your clients want to update part of the site regularly, and they under-
stand and can write the SSI content in HTML themselves.

You have a client who doesn’t have Dreamweaver and can’t take advan-
tage of library items.

You love the fact that you only have to upload the SSI files to the server
when their content changes, rather than uploading all the files that con-
tain them, as you must do for library items.

Your site is database driven (ASP, JSP, PHP, CFML). Although your site
does not need to have a database to use SSIs, if it does, that alone is a
big enough reason to consider using SSIs.

You've tested your server and are confident that the SSIs work.

Book IlI
Chapter 3
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Here are some good uses for SSIs:

4+ Footers
Copyright notices
Navigation elements

Jump menus

¢+ 4+

Parts of your page/site that may require periodic updating, such as class
schedules, course descriptions, news items, and so on

+

Parts of your site that require regular updates, such as a menu or event
listing

If you're uncertain whether a library item or server-side include is best

for your projects, consider this general rule: If the site is small, use library
items. If the site is large and needs regular updates to certain parts of the
content, your server supports them, and you don’t mind the ever-so-slightly
slower page opening times, use SSIs.

Creating a server-side include

One fast way to create an SSI file is to first build the content in a normal
Dreamweaver HTML file, and then copy the content from that file and paste
it into an empty document that doesn’t contain any HTML markup.

Presuming you've already created a document with the content for the SSI,
follow these instructions to convert that content into a server-side include file:
1. Open the document that has the content for the SSI file.
2. Select the content and choose Edit=>Copy.

The copied content is temporarily placed in your computer’s Clipboard.
Close that file without saving the changes.

3. Choose Filec>New to open a new Blank Page HTML document in the
Dreamweaver workspace window.

4. In Code view, choose Edit=>Select All to select all the code in the file,
and press the Delete or Backspace key on your keyboard.

Be sure the entire document is empty of all code before proceeding.

5. With your cursor still in Code view of the empty file, choose Edit>
Paste to paste the copied content from the original file.

6. Save the new SSI file with an appropriate filename and the .html or
.htm file extension.

If you plan on having several SSI files on the same Web site, consider
saving all the SSI files into one folder at the site’s root level for better
organization of the SSI files.
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You can now insert the SSI file into another file, as described in the next section.

Inserting a server-side include

Dreamweaver writes the appropriate syntax into your code when you use
the built-in SSI command. Insert your server-side include files into regular
documents, dynamic documents, templates, or template-based files.

To insert an SSI into a page, follow these steps:

1. Open the document that you want to add the SSI to.
2. Click the cursor where you want the SSI to display.
Use either Design or Code view.
3. Choose Insert->Server-Side Include.
The Select File dialog box opens.
4. Browse to and select the SSI .html file.

If you've saved your SSI files into a separate folder, navigate to that
folder and select the appropriate SSI file.

5. Click OK.

Dreamweaver adds the appropriate SSI code to your document, as Book llI
shown in the following example where the SSI file, called copyright.html,
is located in a folder called ssi:
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<!--#include file="/ssi/copyright.html" -->

6. Select the newly inserted SSI in Design view, and then choose File or
Virtual as the include type in the Properties inspector.

You can choose from two SSI types: File or Virtual. Depending on the type
of server you have, you may need to replace the word file with virtual

in the include instructions. Apache servers typically use the Virtual set-
ting (this is the Dreamweaver default), whereas File is the standard for
Microsoft Internet Information Server (IIS). If you're not sure which one to
choose, try the first one, and if that doesn’t work, try the second, or better
yet, ask your host provider or system administrator for guidance.
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When the server runs IIS software, ask your host provider or system
administrator about installing special software if you include a file in a
folder above the current folder in the site root folder hierarchy.

If your server uses another kind of software besides Apache or IIS, check
with your host provider or system administrator for which SSI type to use.

Dreamweaver immediately displays the include file’s content in Design
view, such as

© Copyright 2008. All rights reserved.
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while showing include instruction markup in Code view, such as

<!--#include file="/ssi/copyright.html" -->

7. Save the file that contains the newly inserted SSI with the .html or
.shtml file extension as instructed by your system administrator or
host provider.

The include file itself doesn’t need any particular extension. However,
if you want the include file to also include another sub-file, you need
to save the include file as an .shtml file (or whatever extension type
enables server-side includes on your server).

8. Upload the SSI files and any documents containing SSI to your remote
host server.

If you saved the SSI files into a local folder, be sure to upload the same
folder structure to the server so the links to the SSI files match.

<P To change to a different SSI file after inserting one on a page, select the
server-side include in the open file and click the folder button next to the

Filename field in the Properties inspector to browse for and choose a new
SSI file.

The SSIs now render seamlessly in the browser window. If the SSI files do not
display in the browser, you need to convert your Web site linking system to

use site root-relative linking, as the next section describes.

Document versus root-relative links

When working with SSls, their mere existence
on some Web servers may require site root-
relative linking rather than document-relative
linking. In other words, you may need to add a
forward slash before the SSI filename such as
the following:

Document-Relative:

<!--#include file="ssi/serversideinclude.
html" -->

Site Root-Relative:

<!--#include file="/ssi/
serversideinclude.html" -->

The forward slash at the start of the path,
before the folder or filename, tells the browser
viewing the site to use the root level as the
starting point for locating files on the server.

Speak with your system administrator or host
provider to find out if and how they support SSls
before building your pages with them. If you do
ultimately choose to use server-side includes,
test them on your server to ensure they’ll dis-
play properly before publishing the entire site.

For further information about relative links and
site organization, see Book I, Chapter 2.
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Editing Server-Side Includes
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Edit a server-side include file just as you would any other HTML document
by opening the file in the Dreamweaver workspace, making changes, saving
it, and uploading the changed SSI file to the host server.

To open the file for editing in the Dreamweaver workspace window, double-
click the SSI file from its location in the Files panel. You can also select the
SSI content in Design or Code view of the page it’s inserted on and click the
Edit button in the Properties inspector, or simply double-click the SSI con-
tent in Design view.

Within Dreamweaver’s Design view, edits to the SSI file appear immediately
in the files containing them, but for site visitors to see the changes in a
browser window, you must upload the updated SSI file to the host server.
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Chapter 4: Creating Code Snippets
and History Panel Commands

In This Chapter

v+~ Understanding snippets

v+~ Using Dreamweaver’s snippets

+* Making your own snippets

v Editing, deleting, and managing snippets
v Working with the History panel

v Creating History panel commands

f you build a lot of Web sites, you know that you’ll use certain elements

over and over again, but each time you need them, you either have to
recall a particular command or, more likely, copy and paste the code con-
taining the content you want to reuse. Knowing that is not the most efficient
way to work, Dreamweaver created a solution called Code Snippets that,
after they’re created, become available to you across all of your managed
sites. Snippets are valuable timesavers that every Dreamweaver user should
discover and take advantage of.

Don’t confuse snippets with library items or SSIs (which we cover in Book
IlI, Chapter 3). Snippets are intended to be used as either shortcuts for
inserting a single instance of content on a page or as a way of quickly modi-
fying selected content in a file.

Similar in theory to Microsoft’s macros or Adobe’s Actions, Code Snippets
are a fantastic way to automate some of your repetitive tasks and make
your job easier. They are composed of bits of code or content that you can
save, edit, use, and reuse as often as you want on any Web site you happen
to be working on. Dreamweaver even comes with a great set of prewritten,
logically categorized, ready-to-use snippets. You can find them sitting in the
Snippets panel (which you open by choosing Window=>Snippets).

Other terrific timesaving tools are the temporary and permanent custom
commands you can create with the Dreamweaver History panel (which you
open by choosing Window=>History). Record and save any series of steps —
such as select, bold, deselect — to play again and again at a later time.
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In this chapter, you find out how to create, insert, edit, and delete Snippets,
as well as organize them in folders to share with your workmates. This chap-
ter also covers how to record and play History panel commands.

Understanding What Snippets Do

The best snippets are the ones that save you time or at least limit the work you
need to perform so you don’t have to retype anything, such as the following:

4+ Code including HTML, JavaScript, ASP, JSP, PHP, and even CFML
(ColdFusion Markup Language).

4+ Text that you use often. For instance, you may like to add a copyright
notice such as © 2008 All rights reserved at the foot of your pages.

4+ Navigation tables with bullets and text that have temporary links already
applied to each navigation word so all you need to do after inserting the
snippet on your page is type the real navigation names and links.

4+ JavaScript information, such as the Set Text of Status Bar JavaScript
behavior, or perhaps opening and closing comment tags.

There are two basic types of snippets:

4+ Wrap snippets insert code before and after any selected content on the
page, such as adding <span> tags around a selected line of text, as in

<span>This sentence is wrapped with span tags .</span>

4+ Block snippets simply drop in the snippet content after the insertion
point on the page, such as a line of code with JavaScript to display the
current date.

Using Dreamweaver’s Snippets

Dreamweaver comes with a great set of preset snippets already categorized
into files for Comments, Footers, Form Elements, JavaScript, Meta, Navigation,
Text, and ~Legacy. Open the Snippets panel by choosing Window=>Snippets to
review Dreamweaver’s snippets folders, as shown in Figure 4-1.

Each folder includes a list of snippets organized alphabetically by name. To

preview each snippet for how it will appear on the page, select it and look in
the preview pane of the Snippets panel. To read a description of the snippet
and review the code that it uses, click the Edit Snippet button at the bottom
of the panel to open the Snippet dialog box.

To use a block snippet, place an insertion point inside an open document,
select the snippet from the Snippets panel, and click the Insert button at the
bottom of the panel. You can also drag and drop the snippet from the panel
into an open document, as you would an image or any other media file.



Figure 4-1:
The
Snippets
panel.
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To use a wrap snippet, select the content in Design view that the snippet will
wrap around, select the snippet in the Snippets panel, and click the Insert
button at the bottom of the panel.

You can find several good Web sites — including the Adobe Web site —
to exchange snippets with other designers and programmers. Search for
Dreamweaver snippets or Snippets exchange. Then, when you download
new snippets or create your own, you can file them in any of the existing
Dreamweaver snippets folders or create new folders and file them there.

Creating Code Snippets

\\J

To create a Code Snippet, you must first begin by knowing what you want to
turn into a snippet. Think about what can save you time, such as a snippet to
create a time/date stamp, or the types of content you frequently use, such as
copyright notices or meta tag information.

Snippets can be as simple or as complex as you need them to be. The fol-
lowing sections show you how to create four types of snippets from scratch:
text, JavaScript, wrap, and graphic.

To download copies of the snippets described in this chapter, visit www .
luckychair.com/downloads.html.

Creating a text snippet

Say you work with lots of artists and have a standard copyright notice you
want to use regarding their work being displayed online. By creating a code
snippet, you never have to type that copyright notice again, save for adding
the correct artist name and company information after inserting the snippet
into your page.

Book llI

[x]
=
D
=
-
(-]
=
L]

SpuBWWOY) [3uey
Aio)siy pue sjaddiug
apo? bunear



2 96 Creating Code Snippets

Follow these steps to insert a text snippet on your Web page:

1. Choose Windowr>Snippets to open the Snippets panel.
2. Click the New Snippet button (refer to Figure 4-1).
The Snippet dialog box opens.
&Q,N\BER 3. Type a name for the snippet in the Name text box.
< Snippet names can’t contain characters that are invalid in filenames,
such as slashes (/ or \), special characters, or double quotes (").

In Figure 4-2, the snippet is named Artist Copyright Notice.

Snippet
Name: | Artist Copyright Statement
Description: | Inserts standard copyright statement For artists, IE
Snippet type: ) Wrap selection () Insert black.
Insert code: | All arbwork Featured on THIS WEBSITE is copyrighted
material and may not be reproduced, downloaded, or
used in any other Format, on any other product,
without permission from THIS COMPANY and the artist,
——
Figure 4-2:
Enter your
snippet
details.
Preview type: () Design () Code

4. Write a text description for the snippet in the Description text box.

For a copyright notice, your description may look like this: Inserts
standard copyright statement for artists.

5. Select Insert Block as the snippet type.

The Insert Block type is best for snippets containing content only. By
contrast, the Wrap Selection type surrounds or wraps around your
selected content, which is especially helpful for applying links, scripts,
special formatting, and navigation.

6. Add the code in the Insert Code text box.
Here’s what to type for the Copyright example:

All artwork featured on THIS WEBSITE is copyrighted material and may not
be reproduced, downloaded, or used in any other format, on any other
product, without permission from THIS COMPANY and the artist.



Figure 4-3:
The snippet
shows

up inthe
Document
window
after
insertion.
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7. Pick a preview type: Design or Code.

The Code preview type shows the code in the preview pane of the
Snippets panel. To see how graphics contained in your snippet may
appear, choose Design view.

8. Click OK when you’re done.
Your new snippet appears in the Snippets panel.
To use your new snippet, open an HTML page and, in either Design or Code

view, click anywhere on the page to create an insertion point with your
cursor.

Select the new snippet from the Snippets panel and click the Insert button or
double-click the Snippet name to quickly insert the snippet onto your page.
The snippet appears on your page, as shown in Figure 4-3.
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Creating a JavaScript snippet

A lot of great free JavaScripts snippets are available on the Internet for use
on a Web page that aren’t built into the Dreamweaver interface (turn to Book
IV, Chapter 2 to find out about JavaScript). You can find many useful free
JavaScripts on the following sites:
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www . dynamicdrive.com/
www.Jjavascript.com/
javascript.internet.com/

www . javascriptkit.com/cutpastejava.shtml
www.Jjava-scripts.net/

www.Jjavafile.com/
webdeveloper.earthweb.com/webjs/
www.Jjavascriptsearch.com/

Regularly used JavaScripts make great Code Snippets. Besides saving you
valuable time, one of the greatest advantages to using JavaScript snippets is
that you needn’t understand the JavaScript code to use them. The following
are some great examples of JavaScript that you can easily convert into reus-
able Code Snippets:

<+

R

Time/date stamps and clock scripts
Customizable menu navigation scripts
Game scripts

Password-protection scripts

Text and status bar effects scripts

Image effects and slide show scripts

Follow these steps to make a JavaScript snippet:

~

2.

Open the Snippets panel by choosing Window=>Snippets.

Click the New Snippet button at the bottom of the Snippets panel
(refer to Figure 4-1).

The Snippet dialog box opens.
Type a name for the snippet in the Name text box.

Suppose, for example, you want to create a snippet with JavaScript that
displays the document’s last modified date starting with the words,
This document was last modified on:.In the Name text box,
type something like This document was last modified on: (Date) for the
name.

Write a text description for the snippet in the Description text box.

You may also want to include instructions about how to use the snip-
pet. For example, you can note to insert the snippet in the <head>, not
the <body> tag and that the snippet is only supported by particular
browser versions.

Choose Insert Block for the snippet type.

JavaScript is code that modifies the behavior of your content, so you
always choose Insert Block as the type rather than Wrap.

Insert the code in the Insert Code text box.
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The following JavaScript example inserts the current date into your
Web page. If using CSS for styling your page, disregard the <b> and
<font> tags. You can also customize the script to display something
else besides This document was last modified on: before the
date by modifying the line of code that says document .write ("This
document was last modified on: ");.Type this data:

<p><font face="arial, helvetica" size="1"><b>

<SCRIPT LANGUAGE="JavaScript">

function initArray() {

this.length = initArray.arguments.length

for (var i = 0; 1 < this.length; i++)

this[i+1] = initArray.arguments[i] }

var DOWArray = new initArray("Sunday", "Monday", "Tuesday", "Wednesday", "Thu

rsday", "Friday", "Saturday") ;
var MOYArray = new initArray("January", "February", "March", "April", "May","
June", "July", "August", "September", "October", "November", "December") ;

var LastModDate = new Date(document.lastModified) ;

document .write("This document was last modified on: ");

document .write (DOWArray [ (LastModDate.getDay ()+1)1, ", ");

document .write (MOYArray[ (LastModDate.getMonth()+1)]," ");

document .write(LastModDate.getDate(),", ",2008);

document .write(".");

</SCRIPT></b></font></p>

The final output looks something like this:

This document was last modified on: Monday, September 8, 2008

7. Pick Code as the Preview Type.

The Code preview type shows you the code in the preview pane of the
Snippet panel.

8. Click OK when you’re done.

To test your new snippet, click anywhere on any open page in Design view
to create an insertion point with your cursor and double-click the snippet in
the Snippets panel.

When snippets containing JavaScript are inserted on a page, Dreamweaver’s
Design view may either indicate you have JavaScript code on your page by
displaying an invisible element icon, or you may see nothing at all in Design
view, though you see the newly inserted code in Code view in both cases.
Browsers, by contrast, display the JavaScript as it’s meant to display and
function. Therefore, for testing purposes, be sure to press F12 (or Shift+F12)
to launch your primary browser to see how the JavaScript snippet looks.

To turn on the yellow script invisible element, choose Edit=>Preferences
(Windows) or Dreamweavert>Preferences (Mac) to launch Dreamweaver’s
Preferences dialog box. Select Invisible Elements from the Category list on
the left and then select the Scripts option. Upon clicking OK, Dreamweaver
indicates with the invisible element icon in Design view that you have
JavaScript on your page.
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Figure 4-4 shows how the icon looks as well as how the snippet actually
appears in a browser.
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Creating a snippet with the wrap option

The wrap option allows you to write opening and closing tags that surround
whatever code or content is selected on your page. Wrap snippets are
especially helpful for applying links, scripts, special formatting, and naviga-
tion. For instance, you may want to create a snippet that quickly adds a link
around selected text, such as <a href="#">1ink</a>. To create a snippet
with the wrap option, follow these steps:

1. Open the Snippets panel by choosing Window->Snippets.
The Snippets panel appears.

2. Click the New Snippets button (refer to Figure 4-1).
The Snippets dialog box appears.

3. Type a name for the snippet in the Name text box.

Say, for example, that you want to generate a snippet that superscripts
text, such as on 42nd Street. In the Name text box, type Superscript.
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4. Write a text description for the snippet in the Description text box.
In this example, type something like this for the description: This snip-
pet will Superscript any selected content using the <sup></sup> tags.
5. Choose Wrap Selection as the Snippet type.
Use this type because the code in your snippet will surround or wrap
around your selected content. When selecting the Wrap Selection type,
notice that the dialog box changes from displaying one box for code
input to displaying two boxes, as shown in Figure 4-5.
Snippet
Mame: | Superscript
Description: | This snippet will Superscript any selecked content using the @
«<sup = <fsup> tags.
Snippet type: (3 Wrap selection () Insert block.
Insert before: | <sup>
Figure 4-5:
Enter your
snippetin .
the Insert Insert after: | «jsup>
Before and
Insert After
boxes' Preview type: () Design () Code
6. Add the appropriate code to the Insert Before box.
To create a superscript snippet, type the following:
<sup>
7. Add the appropriate code to the Insert After box.
To continue creating the superscript snippet, type the following:
</sup>
8. Pick Code as the Preview Type.
Because wrap snippets typically have no graphics, select Code as the
preview type to see code in the preview pane of the Snippet panel.
9. Click OK when you’re done.

The wrap snippet is inserted in your Web page (see Figure 4-6).
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Figure 4-6:
Wrap
snippets
are useful
for super-
scripts.
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10 </body>
11  </html>
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Applying wrap snippets is a little different than block type snippets because
if you want the code to wrap around the content, you must select the copy
on your page that you want to apply the snippet to before you insert the
snippet code. Using the 42nd Street example, highlight the nd in Design
view first, and then insert the snippet. Because this snippet contains

simple HTML tags, Dreamweaver’s Design view renders and displays the
superscript code for you, without the need to launch a browser to see it.
Alternately, you don’t have to apply wrap tags to existing text; you could
insert the wrap snippet on the page first and then add content between the
tags at a later time.

Creating a snippet with graphics

Good uses for graphic snippets include

4+ Special symbol graphics: Create a graphic with a stylized ™ or other
symbol in a particular font.

4+ Animated GIFs: Design an animated graphic, such as a flashing NEW
graphic, to add next to special entries on your site.

4+ Reusable page elements: Build reusable elements with For Placement
Only (FPO) text and graphics, such as a sidebar subnavigation area.

Snippets with graphics work the same as snippets with text and JavaScript, but
with one added benefit when you choose Design as the Preview Type in the
Snippet dialog box. Like the Design or Code views you see when editing a page
in Dreamweaver, the Snippets panel has a little preview pane above the named
list of snippets. Selecting Design as the preview type in the Snippet dialog box
makes Dreamweaver render the code in the preview pane as it would in Design
view (see Figure 4-7). By contrast, if you select Code as the preview type,
Dreamweaver shows the code of the snippet in the preview pane.
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Adding keyboard shortcuts to play snippets

You can easily and quickly customize keyboard
shortcuts to run any of your snippets with key
commands using Dreamweaver's Keyboard
Shortcut Editor. You can also create, remove,
and edit shortcuts at any time.

To create custom keyboard shortcuts for your
snippets, follow these steps:

1.

Choose Edit->Keyhoard Shortcuts (Win-
dows) or Dreamweaver->Keyboard
Shortcuts (Mac).

The Keyboard Shortcuts dialog box
appears.

. Create a duplicate of the default

Macromedia Standard shortcut set by
clicking the Duplicate button. Name your
duplicate set.

Making a duplicate set ensures that you
can always go back to the factory default
settings in the future if you need to.

. Select Snippets from the Commands drop-

down list to see a list of your custom snip-
pets along with the standard snippets.

4. Navigate through the list to find the snippet
you want to assign a keyboard shortcut to.

5. Click the plus (+) button to add a shortcut.

6. Place your cursor in the Press Key field and
press the combination of shortcut keys.

Be careful not to use a key combina-
tion reserved for programs other than
Dreamweaver, such as F11, F12, or 88+H on
a Mac, or Option+R on Windows.

Be sure to press all the keys at once,
such as Ctrl+Alt+Shift+9 (Windows) or
38+0pt+Shift+9 (Mac). Dreamweaver dis-
plays alerts for any shortcut key combos
that are already assigned to another func-
tion within the program so you won't acci-
dentally overwrite one of the presets. Feel
free, though, to overwrite a preset if you
find it useful.

1. Click OK when done.
Your new shortcut works immediately.

To see all the existing keyboard shortcuts at a
glance, export a copy by clicking the Export Set
As HTML button inside the dialog box.
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If you do not see your image rendered in the preview pane in the Snippets
panel, you may need to edit your snippet code to use site root-relative link-
ing for the graphic instead of the default document-relative link.

Here’s an example of a document-relative image link:

<p><img src="images/trademark.gif" width="87" height="87" border="1"></p>

To make the image link site-root relative, you must add a forward slash (/)
before the graphic source folder, like this:

<p><img src="/images/trademark.gif" width="87" height="87" border="1"></p>

You may also need to add the forward slash (/) to any HREF links in your
graphic snippets, as in this site root-relative link example:

<a href="/about.html">about</a>

For a thorough discussion about site root-relative versus document-relative
linking, see Book I, Chapter 3 on root level organization.

Working with Snippets

Snippets are easy to edit and delete and easy to file and manage. You can
even share snippets with your coworkers.

Sharing snippets

If you want to share your custom snippets with other members of your work
team, you can easily copy them from one computer to another. Here’s how
to share Code Snippets:

1. Find and copy them from the Configuration/Snippets folder inside of
the Dreamweaver application folder.

You can find and copy the snippet files (.CSN format) outside of the
Dreamweaver application using the Windows File Manager or Mac
Finder.

2. Paste them into a shared folder on your computer/network or e-mail
them to your co-workers.

3. Have the other team members copy the snippet files to their
Configuration/Snippets folders in their Dreamweaver application folders.

After they're in place, the snippets are ready to use.
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You should be able to find your custom snippets in the Adobe Dreamweaver
Configuration folder, but that folder can actually be in a few different places
on your computer, depending on your platform. See Danilo Celic’s blog entry
at www . communitymx.com/blog/index.cfm?newsid=27 for possible
locations on both a Mac and a PC. To see your custom snippets, you may
need to try adjusting the Application Data (Windows) or Application Support
(Mac) folder properties to view both hidden and read-only files.

<P If you're interested in a faster method for sharing your custom snippets
with others, visit Massimo Foti’s Web site at www.massimocorner.com,
where you can download his free Dreamweaver Snippets Import/Export 1.0
Extension (click the Utilities link under Dreamweaver Extensions). Install
the extension with Adobe’s Extension Manager (see Book IV, Chapter 2 for
instructions on using the Manager). After they’re installed, the tool lets you
import and export snippets straight from the Snippets panel.

Editing snippets

After you create a snippet, you'll probably rarely need to edit it. However, some
snippets may contain specific dates or graphics that need occasional updating
or editing. Additionally, you may want to create a new version of an existing
snippet. In any case, editing a code snippet is simple and straightforward.

To edit a snippet, follow these steps: Book Il
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1. Select the snippet from the Snippets panel and click the Edit Snippet
button at the bottom of the panel.

The Snippet dialog box appears.
2. Make any desired changes to the snippet.

3. When finished, click OK and the new changes are ready to use.
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Deleting snippets
To delete a Code Snippet quickly and permanently, select the snippet from
the Snippets panel and then either click the Remove button (refer to Figure
4-1) or press the Delete key.
CMBER . . oo ,
Dreamweaver always displays an alert dialog box asking if you're sure you
want to delete that particular snippet, giving you a chance to cancel the
command if you change your mind about deleting it.

Managing snippets

One of the cool things about the Snippets panel is that you can create folders
to manage your snippets into logical categories. Moving snippets around the
Snippets panel, from folder to folder, is as easy as dragging and dropping.
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Creating History Panel Commands

If you want to create a new folder for your snippets, follow these steps:
1. Click the New Snippet Folder button at the bottom of the Snippets
panel.

2. Type a name for the new folder and then press Enter (Windows) or
Return (Mac).

If you don’t name it, the folder is called “untitled” by default, but you can
always change the name later.

Rename and delete folders as needed. To delete a folder, select it and click
the Delete button at the bottom of the Snippets panel.

Creating History Panel Commands
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The History panel is one of those panels that many Dreamweaver users don’t
take full advantage of. When a document is open in the Dreamweaver work-
space, the History panel records all the actions you make in the file up to a
certain number of steps (specified in the General category of the Preferences
dialog box). Keep in mind that after you save and close the document, the
history steps associated with the file go away; when you reopen the file, a
new history is created.

Through the History panel, you can take multiple steps backwards with the
use of the panel’s slider as well as copy and paste steps to use on the cur-
rent or other open documents. In addition to using the History panel to undo
and redo steps, you can also record your own custom actions and save them
as reusable, playable commands to automate repetitive actions.

Working with the History Panel

To view the panel, choose Windowr>History or press Shift+F10. As you work,
notice how the panel records each step you make. For example, when you
type text, a typing layer displays the copy you just entered. When you apply
bold to your text, an Apply Bold layer appears in the panel. Each action cre-
ates a new action layer in the panel, as shown in Figure 4-8.

To undo a single step in your document, drag the slider in the History panel
up a layer in the list (or choose Edit=>Undo). To undo multiple steps, simply
drag the slider to the desired step in the History panel or click to the left of

the path next to the slider to scroll automatically to that step. After undoing
a single step or multiple steps, any subsequent new actions erase and over-
write previous actions.

Although it’s not advised, you can erase the history list for a document by
right-clicking (Windows) or Control+clicking (Mac) the History panel and
choosing Clear History. After clearing the history in this manner, you can’t
undo any steps in your document.



Figure 4-8:
The History
panel.
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ATyping: Type a sentence inside a table

% Backspace
ATyplng: make it bold and italic.

B apply Bold
=3 I apply Ttalic

Record

Recording commands

To record and save a command, be sure the panel is open before you per-
form the actions you want to save. After you perform the actions, you can
record and save them.

Keep these points in mind when recording actions:

<+

+

Use the arrow keys instead of the mouse to move the insertion point in
the document. You can also use the arrow keys plus Shift to make or
extend a selection. Mouse movements aren’t saved and are identified in
the History panel with a black divider line between the steps.

Other actions are also unrepeatable, such as dragging an asset from one
place on the page to another. These types of steps display a small red X
next to the action layer in the History panel.

Follow these steps to record and save a command:

1.

2.

Open the History panel by choosing Window=>History.
Press Shift+F10 to quickly open the panel.

Edit your document.

The History panel records all your actions as individual steps.
In the History panel, select the step you want to record.

To select multiple steps, Shift+click to select consecutive steps;
Ctrl+click (Windows) or 8-+click (Mac) to select or deselect non-
consecutive steps.

Click the Save Selected Steps as a Command button at the bottom of
the panel.

The Save As Command dialog box appears, prompting you to enter a
name for the new command.
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Figure 4-9:
Select the
command
you created
from the
Commands
menu.

5. Name the new command.

Name your commands using simple descriptive titles, such as Bold «
Italic.

6. Click OK.

The new command appears by name at the bottom of the Commands
menu.

You can also make a temporary command by clicking the Copy Selected
Steps to the Clipboard button at the bottom of the panel after selecting a
series of steps. The steps are temporarily stored on the Clipboard for easy
pasting into any open document in Design view.

New commands are saved as JavaScript or HTML files in the Dreamweaver/
Configuration/Commands folder.

Playing commands

Playing a saved command is as easy as choosing it by name from the
Commands menu. For example, if you create a Bold and Italic command
that bolds and italicizes a selection, select some text on your document and
then choose Commands="Bold and Italic to play the command, as shown in
Figure 4-9.

Commands | Site  Window  Help | B~ $v &~

Start Recording Ctrl+Shift+X

Edit Command List...
Get More Commandls...
Get AIR Extension...
Manage Extensions...

Check Spelling Shift+F7
Apply Source Formatting
Clean Up XHTML...

Clean Up Word HTML...
Externalize JavaScript...

Create Web Photo Album...
Sort Table...
Insert Mark of the Weh

Bold and ltalic I

More options are available when playing commands with the History panel.
You may repeat the last step, repeat a series of consecutive or touching
steps, or repeat a series of nonconsecutive steps:
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4+ Repeat a single step: Select a step in the History panel and click the
Replay button. Or choose Edit=>Redo (Action).

4+ Repeat a series of consecutive steps: Select the steps in the History
panel and click the Replay button.

A\\S

To select multiple steps, either drag from one step to another or click
the first step and Shift+click the last step. Whichever steps are high-
lighted are the ones that play.

4+ Repeat a series of non-consecutive steps: Select a step in the History
panel and Ctrl+click (Windows) or 8+click (Mac) to select other steps;
then click the Replay button. Steps replay in the order they appear in
the History panel.

4+ Deselect a selected step: Ctrl+click (Windows) or 88 +click (Mac) the step.

You can also copy and paste steps from one open document to another, as
each file has its own history of steps. Simply select the steps and click the
Copy Steps button in the History panel. Then choose Edit=>Paste in the new
document to paste the steps.

If you paste selected steps into a text editor (like Notepad or TextEdit), Code
view, or the Code inspector, you may notice that the pasted information
appears as JavaScript, which can be really useful for learning to write your
own Dreamweaver scripts. For example, the copied command to insert and Book llI
resize an image is this:
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<img src="image23.gif" width="100" height="46" />

This line appears in a text editor as a bit of JavaScript like this:

dw.getDocumentDOM () .insertHTML ('<img src=\"image23.gif\">"', false);
dw.getDocumentDOM () .resizeSelection('100', '46');
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Renaming and deleting commands

After saving a new command, you can rename or delete it.
To rename a command:

1. Choose Commands—~FEdit Command List.
2. Select the command in the list and enter a new name.
3. Click the Close button.

To delete a command:

1. Choose Commands~>Edit Command List.
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2. Select the command in the list and click the Delete button.

Clicking the Delete button permanently removes the command from the

Commands menu.

3. Click the Close button.

Recording commands with the Commands menu

Another way to record temporary commands
is to use the Commands menu instead of the
History panel. Temporary commands stay on
the Commands menu and you can play them
on any open document as long as you have
Dreamweaver open. Temporary commands
disappear when you do one of the following:

+* You close Dreamweaver. The temporary
command is erased.

+* You record a new temporary command.
The new command takes the place of the
old command.

To record a temporary command:

1. Choose Commands=>Start Recording
before performing the steps you want to

copy.
You can also begin the recording process

by pressing Ctrl+Shift+X (Windows) or
38+ Shift+X (Mac).

2. Perform the steps.

Whenever possible, press the arrow keys
instead of moving the mouse to reposition
the cursor during the recording process.

3. When finished, choose Commands=>Stop
Recording.

To play back a temporary command, choose
Commands=>Play Recorded Command.

You can also begin the playback process
by pressing Ctrl+Shift+R (Windows) or
88+Shift+R (Mac).

To save a temporary command into a perma-
nent command with the History panel:

1. Choose Commands=>Play Recorded
Command.

The command plays and displays a new
Run Command step at the bottom of the
History panel.

2. Select the new Run Command step in
the History panel and click the Save As
Command button.

The Save As Command dialog box opens.

3. Name the command and click OK to
save it.

The command now appears at the bottom
of the Commands menu.

Click the Get More Commands link on
the Command menu to launch Adobe’s
Dreamweaver Exchange to browse for and
download additional commands.




Chapter 5: Integrating
Dreamweaver with Fireworks

In This Chapter

+» Working with Fireworks

1 Setting launch-and-edit preferences

v~ Inserting Fireworks images

1 Making changes to your Fireworks images and tables
+ Image optimizing in Fireworks

v~ Inserting, pasting, and updating Fireworks HTML

Dreamweaver is tightly integrated with Adobe Fireworks, a Web image
creation, editing, and optimization program. Fireworks lets you create
animations, pop-up menus, and rollover buttons (buttons that change in
appearance when you mouse over them); optimize your graphics (reduce
the file size while preserving image quality to improve download times in

a browser); and export graphics, HTML, and JavaScript code to an HTML
editor like Dreamweaver — all without needing to know a lick of code.

When used together, Fireworks and Dreamweaver provide you with a
smooth process for editing, optimizing, and exporting graphics into HTML
pages. This process, called roundtrip editing, enables you to make seam-

less updates to your Fireworks graphic and HTML files while working in
Dreamweaver. The code stays accurate to preserve links and other function-
ality such as rollover behaviors.

During the roundtrip editing process, Fireworks creates special Design Notes
about all the graphics and HTML exported to Dreamweaver. The Notes,
which are generated during the graphic export process, are sent from
Fireworks into Dreamweaver, store references to the Web-ready images
(GIF, JPEG, HTML), and enable Dreamweaver to quickly locate them and the
Fireworks source files (PNG) they were created from. In addition, the Design
Notes often include information about the export process itself, such as the
location of JavaScript data within the HTML files and details such as roll-
over capabilities and hotspots about the graphics inside of table cells.

To be fair, Fireworks is not a prerequisite for creating or designing Web
sites, so please don’t feel that you must run out and buy Fireworks to suc-
cessfully build a Web site; it’s entirely possible to build an entire Web site
without using Fireworks or any of its features. Many designers actually
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prefer to use other design, illustration, and Web graphic optimization pro-
grams, such as Photoshop, Illustrator, or an old copy of ImageReady CS2 to
create their Web graphics. What Fireworks is required for, however, are all
the features described in this chapter.

To download a free 30-day trial version of Fireworks, go to www.adobe.
com/products/fireworks/.

This chapter presumes that you already own and know how to use Fireworks
but need help using it together with Dreamweaver. Here you find out how

to insert Fireworks images, edit images and tables, optimize your images in
Fireworks, and add and edit Fireworks HTML in Dreamweaver.

Preparing to Work with Dreamweaver and Fireworks

Before you begin a roundtrip editing process, you must enable a few settings
within Fireworks and Dreamweaver to ensure the smoothest possible inte-
gration between the programs. Specifically, you must configure your launch-
and-edit preferences in Fireworks, and optimize Dreamweaver for working
with Fireworks by adding Fireworks as a primary image editor.

Setting Fireworks launch-and-edit preferences

If you use Fireworks to create and edit images, by default Fireworks exports
those images from a source PNG (Portable Network Graphics) file. PNG is an
image compression file format that allows for the exporting of Web graphics
with the highest image quality and a relatively small file size. A source PNG
file is a master file that Fireworks uses to generate Web-ready graphics.

When creating graphics in Fireworks, be sure to store the PNG source files
in a different place on your computer than the Web graphics generated from
them so you don’t accidentally alter them.

By default, when you edit a Fireworks image within Dreamweaver, Fireworks
launches and automatically reopens the source PNG file. This is the
Fireworks default launch-and-edit preference. You can also set the prefer-
ences in Fireworks to either have Dreamweaver open and directly edit the
inserted graphics (which is not a good choice because Dreamweaver is not
an image editing or optimization application) or have Fireworks open and
use the inserted Web-ready image for editing instead of the image’s source
PNG file (which is not good either because the original source PNG always
generates better quality Web graphics than an already optimized Web
graphic).

You should note that Dreamweaver only recognizes these launch-and-edit
preferences when certain conditions apply:



Figure 5-1:
Choose
launch-
and-edit
preferences
in Fireworks.
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4+ You must specifically open and optimize images that include the right
Design Notes path to the source PNG file. You can ensure you're using
the right Design Notes path to the source PNG by selecting the Always
Use Source PNG option for the launch-and-edit preference (see the next

section).

4+ The image can’t be a part of a Fireworks table. Fireworks tables use
a series of images with the HTML code. You must always open the
source PNG file inside Fireworks to edit any of the graphics from within

Dreamweaver.

To set Fireworks’ launch-and-edit preferences, follow these steps:

1. Choose Edit->Preferences (Windows) or Fireworks->Preferences (Mac)
to open the Fireworks Preferences dialog box.

2. Click the Launch and Edit option in the Category listing on the left

side of the dialog box.

After this option is selected, the Launch and Edit options appear on the
right side of the panel, as shown in Figure 5-1.

Preferences

Category Launch and Edit

General

Edit

Guides and Grids

Type

Photoshop Import/Open
Launch and Edit
Plug-Ins

‘When editing from external application:
sk When Launching

Wwhen optimizing Fram external application:

Always Use Source PHNG

Help

3. Set the Launch and Edit preference options for editing and optimiz-
ing Fireworks images to be exported to external applications such as
Dreamweaver. Select one of the following options in each of the drop-

down lists:

¢ Always Use Source PNG: (Recommended) This setting enables
Fireworks to open the PNG file defined in Design Notes as the
source for the externally placed graphics. When edits are made to
the source PNG, all those changes are automatically updated in the

exported or placed Web graphic.
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¢ Never Use Source PNG: This option tells Fireworks to open the
placed graphic for editing, even if a source PNG file is available.
Changes to the graphic are permanent and appear in the placed
graphic. The source PNG file stays the same.

¢ Ask When Launching: If you want to use both methods intermit-
tently, select this option to choose the PNG file or the placed graphic
on a case-by-case basis.

4. When you finish, click OK to save your changes.

Optimizing Dreamweaver for use with Fireworks

Make the following changes to optimize Dreamweaver for use with
Fireworks.

Enable Design Notes
Verify that the managed site you're creating or using has Design Notes
enabled. This is the default site setting in Dreamweaver.

1. Choose Site->Manage Sites.

2. Select your site and click the Edit button in the Manage Sites
dialog box.

3. Click the Advanced tab in the Site Definition dialog box.

4. Choose Design Notes from the Category list and verify that the
Maintain Design Notes option is enabled.

If you want to share Design Notes with others on your team, also enable
the Upload Design Notes for Sharing option.

Add Fireworks as an image editor

In the Dreamweaver Preferences dialog box, set Fireworks as the primary
external image editor for selected graphics files. This enables Fireworks to
be the editor that automatically launches for editing your placed graphics
files. For example, you may want to launch Fireworks as the primary editor
for GIF and PNG files, and another application for editing JPEG files.

To add Fireworks as an image editor, follow these steps:

1. Choose Edit=>Preferences (Windows) or Dreamweaver=>Preferences
Mac).

The Dreamweaver Preferences dialog box appears.



Figure 5-2:
Add
Fireworks
as the
primary
image editor
in Dream-
weaver's
Preferences.
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2. In the File Types/Editors category, as shown in Figure 5-2, click the
plus (+) button to add Fireworks (and any other applications you want
to include) as an editor for any of the graphic extensions.

Preferences
Catagory File Types | Editors
General
Aoty Openin code view: | 45 asa .35 .5 config inc £t a5 .asc .asr .ub htaccess hepasswd
Code Coloring
Code Format External cods editor: m—
Code Hints
Code Rewrting Reload madiied files: |Prompt v
CopyPaste
55 Styles Save on launch: |Prompt v
File Compare
il Types | Editars Fireworks: | CriProaram Fireworks C:
Fants
o o * Hz
Y ants. ®E= ®E= Make Primary
Hewd pditiert Extensions a| | Edtars
Preview in Browser
Ste -prg Photoshap
Status Bar af Fireworks10 (Primary)
Valdator ipg e Jpeg
psd
Fla
way
aiff & .aifc
mp3
.mpg .mpeg ~

Dreamweaver doesn’t automatically detect that you have Fireworks
installed so you must enter the path to the Fireworks application in the
Fireworks text box.

3. To make Fireworks the primary editor for any selected extension on
the left, select Fireworks from the list of editors on the right and click
the Make Primary button.

For example, after adding Fireworks to the list in Step 2, select it and
click the Make Primary button. The Fireworks application name has
(Primary) appended to it.

4. Click OK when you’re finished.

Save all your Fireworks files in the same site folder

Save all your Fireworks PNG source and Web-ready files in the same
Dreamweaver site folder. This ensures that everyone in a workgroup can
easily find and edit all the source files for the site.

Export Fireworks image files to the same site folder

Exporting Web graphics from Fireworks into a Dreamweaver site folder
ensures that Design Notes are integrated and up-to-date. Fireworks creates a
Notes folder for the Design Notes, which Dreamweaver uses to update code
and graphics.

Book IlI
Chapter 5

sylomaily
Yum 1aneamuweai(

buneibiaju|



3 76 Using Fireworks Images in Dreamweaver

Using Fireworks Images in Dreamweaver

When you’re ready to insert Fireworks images into your Dreamweaver docu-
ment, you can do so two ways. The first way is to place exported Fireworks
graphics directly into a file by choosing Insert=>Image in Dreamweaver. The
other way is to design images in Fireworks to replace Dreamweaver image
placeholders.

Inserting a Fireworks image in
a Dreamweaver document

When you've designed, saved, and exported your graphics from Fireworks,
you’re ready to import those exported graphics into a Dreamweaver document.
If you need help creating, saving, and exporting Fireworks graphics, refer to the
Fireworks Help files or download a copy of the Fireworks manual from Adobe at
www . adobe . com/support/documentation/en/fireworks/.

Follow these steps to insert an exported Fireworks image into a
Dreamweaver file:

1. In Dreamweaver, click inside the document where you want the image
to go and choose Insert=>Image.

Or, on the Common category of the Insert panel, click and drag the
Image button into the open document.

The Select Image Source dialog box opens.

2. Browse to and select the exported Fireworks image and click OK
(Windows) or Open (Mac) to complete the insertion.

If you select an image from outside the Dreamweaver local managed site
folder, a message appears asking if you want Dreamweaver to copy the
file into the root folder of the managed Dreamweaver site. Click Yes.

Now you can easily edit your images in Fireworks using the roundtrip edit-
ing feature, as described in “Editing Images in Fireworks Tables,” later in the
chapter.

Replacing an image placeholder
with a Fireworks graphic

In Dreamweaver, you can create image placeholders that set aside space for
graphics that haven’t been created yet. (See Book II, Chapter 3 for details
on creating image placeholders.) With roundtrip editing, you can select an
individual image placeholder in Dreamweaver and use Fireworks to create a
graphic to replace it.
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Using Fireworks Images in Dreamweaver

Before beginning the roundtrip editing process, be sure that you specify
Fireworks as the image editor for .png files (as described in “Optimizing
Dreamweaver for Use with Fireworks,” earlier in the chapter) and create all
the image placeholders in a Dreamweaver document.

Follow these steps to replace a Dreamweaver image placeholder with a
Fireworks image:

1. In your Dreamweaver document, select the image placeholder (see
Figure 5-3) that you want to replace.
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The Create button

2. Click the Create button in the Properties inspector to launch Fireworks.

Fireworks opens the selected image placeholder in Editing from
Dreamweaver mode.

3. In Fireworks, design the replacement image.

Fireworks detects image placeholder settings from Dreamweaver, such
as image width and height, alternate text, and image ID, as well as links,
text alignment settings, and JavaScript behaviors, and uses these settings
as the basis for the replacement graphic. Therefore, you may just see an
empty white canvas instead of an exact replica of the placeholder image.
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Links assigned to image placeholders in Dreamweaver are maintained
but are not visible inside Fireworks. Therefore, if you add a new link
or hotspot from within Fireworks, the original Dreamweaver link is
still there. However, if you cut a slice from the image in Fireworks, the
Dreamweaver link is deleted when the image gets updated.

<P

4. In the Fireworks Optimize panel, select an image optimization setting,
such as JPG, PNG, or GIF.

Select JPG for photographs or images with lots of gradient blends, and
select GIF or PNG for images with large flat areas of color.

5. Select FilecoExport to export a copy of the optimized graphic into the
Dreamweaver managed site.

If you haven’t managed a site in Dreamweaver yet, quickly transfer over
to Dreamweaver and create a managed site before proceeding.

6. When you finish designing the image (see Figure 5-4), click the Done
button at the top of the image document window to save the original
PNG file for future editing.

The Done button
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Fireworks launches the Save As dialog box, prompting you to save the
PNG file.

Browse to and select the root folder of your managed Dreamweaver
site as the location to save the PNG file.

Or, better yet, save the PNG file into a different location so that you can
keep track of the original file separate from the optimized graphics you
create from it.

Enter a name in the File Name text box.

If you previously named the image in Dreamweaver when creating the
image placeholder, the File Name text box is already filled in with that
name.

Click the Save button to save the PNG file.
The Export dialog box opens.

From the Export dialog box, select the Dreamweaver site folder
for the Save In option.

You'll be saving an optimized version of the file here.

Enter a name in the Name text box.

Again, the PNG filename is in the Name text box.

Choose a graphic type from the Save as Type drop-down list.

Select the file type (GIF or JPEG) or the type of file you're exporting,
such as HTML and Images, Images Only, or HTML Only.

Click the Save or Export button to save the optimized file.

The replacement image PNG file is saved, Fireworks gets minimized,
and you return to Dreamweaver, where the exported Web-ready file
(or Fireworks table) has replaced the image placeholder, as shown in
Figure 5-5.

Repeat these steps for each Dreamweaver image placeholder you want to
replace. If a replacement graphic file needs further editing, select the image
in Dreamweaver and click the Edit button in the Properties inspector, as
described in the next section, “Editing Images in Fireworks Tables.”
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Editing Images in Fireworks Tables

Fireworks tables are Fireworks-generated navigation bars, pop-up menus,
and sliced images, which have nothing to do with traditional HTML tables.

WBER Before editing any images containing Fireworks tables, be sure you've set
up Fireworks launch-and-edit preferences and optimized Dreamweaver for
use with Fireworks (refer to the “Preparing to Work with Dreamweaver and
Fireworks” section, earlier in this chapter).

Then, if you want to edit a Fireworks image in your Dreamweaver document,
you can either have Dreamweaver launch Fireworks to edit it there or use
the limited image editing tools (crop, resample, brightness and contrast, and
sharpen) to edit your image within Dreamweaver.

When editing images or image slices (graphics that are cut into smaller pieces)
that are part of a Fireworks table, Dreamweaver opens Fireworks automati-
cally, which in turn opens the source PNG file for the entire Fireworks table.

When editing images that are part of a Fireworks table, you can edit the
entire table as long as the <! --fw table-->comment tag is visible in
the HTML code. That comment gets automatically inserted whenever the
source PNG gets exported from Fireworks to a Dreamweaver site using the
Dreamweaver Style HTML and Images setting.



Figure 5-6:
The source
PNG file for
the entire
table gets
launched in
Fireworks.
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To edit Fireworks images placed in Dreamweaver files, follow these steps:

1. In Dreamweaver, select the image or image slice in the open docu-
ment that you want to edit.

The Properties inspector identifies the selected graphic as a Fireworks
image or Fireworks table right below the Properties inspector tab, along
with the name of the source PNG file.

2. Click the Edit button in the Properties inspector to launch Fireworks.
Fireworks opens the source PNG file for editing (see Figure 5-6). If
Fireworks can’t find the source PNG file, it prompts you to find it. If the
source file is missing, you can use the inserted image as the source for
the edits.

d Fle Edit Wiew Select Modify Text Commands Fiters Window Hep | Jf Q EXPANDED MODE ~ | = & %

= fhols 0 B B@e% =. Baas
Bl fireworkstest.png x e
Select | Original | ElPreview [T12.p FHaup | | O Page1 a0 o et Dt I

[x % e =

F\V \GIF—L: Matte: | ]

R |webzte  [v| colors: | 216 [w

Bitmap lossi [0 |w Dither: | 100% v

\' i‘ Mo Transparency [v]

& &

o &

Vector T < Ty - 4

S Three > B Sert: | Hone ] [Rebuid_]

AT Four - Yy el al

W 4 Sl

Web [Normal——[w] opacity| 100 | v]
(£ @[ |v = webtayer alelr
= |[=] =] slice

Colors =] | e

24 =] | Slice 3
s R = Slice

gzli'i Er ¥ [ Layer1 o

“’Vie: GR(ENED) [ 1 4 [ sooxse0 [100% . EF | path

g g |orroreres BB : = [ Jowme 1

oo ([ ke Type! | Foreground Image: [~ || W oren ibd

3.
4. When finished, click the Done button.
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In Fireworks, edit the source PNG file.

Fireworks saves the changes to the PNG file, exports the updated
graphic (or HTML with images), and returns to Dreamweaver, where the
updated image or table appears in the open document.
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Optimizing Your Images in Fireworks

Figure 5-7:
Use the
Image
Preview
optimization
dialog box
to change
optimization
settings of
Fireworks
images
placedin
Dream-
weaver
files.

Before you add Fireworks images to your Dreamweaver document, you
should optimize those images for use on the Web. By optimizing your
images, you reduce the amount of time the user’s browser takes to down-
load and display the images. By optimizing images in Fireworks, you can

4+ Reduce the image file size while maintaining image quality

4+ Change the file format of the Web-ready image

4 Adjust color depth and other format-specific options to control file size

After inserting your images into a Dreamweaver document, you can still
make changes to those images using a special Image Preview dialog box.

To change settings for Fireworks images placed in Dreamweaver, follow
these steps:

1. In Dreamweaver, select the image you want to optimize from an open
document and choose Commands=>Optimize Image.

If the placed image in the document has a source PNG file, Fireworks
uses that file. However, if that source file cannot be found, Fireworks
may prompt you to locate the source PNG file.

The Image Preview dialog box opens, as shown in Figure 5-7.
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2. On the Options tab, change the optimization settings to support the
selected file format:

¢ Format: Select a file format for the optimized graphic. Choose from
GIF, JPEG, PNG-8, PNG-24, or PNG-32.

¢ Palette: (GIFs and PNGs only) Choose a color palette for the graphic.
Options include Adaptive, Web Adaptive, Web 216, Exact, Windows
and Macintosh, Grayscale, Black and White, Uniform, and Custom.

¢ Loss: (GIFs only) Add a loss setting to compress GIF files for smaller
file sizes. The higher the number, the smaller the file, but the greater
the potential loss of image quality.

¢ Dither: (GIFs and PNGs only) Enable the dithering option to control
how colors not in the selected palette are approximated using colors
within the palette.

¢ Transparency: (GIFs and PNGs only) Choose a transparency setting.

¢ Quality: (JPEGs only) Adjust the quality setting to control the loss of
image quality during compression. Higher numbers produce better
quality images with larger file sizes.

¢ Smoothing: (JPEGs only) Enable a smoothing setting to blur hard
edges in the graphic and reduce file size. Higher numbers reduce file
size but can distort the quality of the image. Book Il

e Matte: Select a matte color for graphic to match the color of the page EhaRiES

the graphic or object will be on top of.
3. On the File tab, edit the scale and export area of the graphic file.

To modify the size of the image, adjust the Scale field in percentages or
type the exact pixels in the Width and Height fields.

To optimize and export only part of the selected graphic, enter X and Y
coordinates relative to the original graphic dimensions as well as W and
H sizes.

4. Click the Update button when finished.

S)IoMally
Y}IM Janeamwealq
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The updated image exports with any new settings. Exporting includes
updating the placed GIF or JPEG file in Dreamweaver, as well as the
source PNG file.

If the image format has changed, Dreamweaver’s link checker prompts
you to verify the graphic’s link references. For instance, if you changed
the format of a graphic called submit.jpg from JPEG to GIF, click OK and
all references to submit.jpg are converted to submit.gif.
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Using Fireworks HTML in Dreamweaver

You can quickly insert Fireworks-generated HTML (including all graphics,
formatting, and JavaScript behaviors) into a Dreamweaver document. This
roundtrip feature lets you design Web elements in Fireworks and add them
to new or existing Dreamweaver files. Or as an alternative, you can simply
copy and paste your HTML code from Fireworks to Dreamweaver. Either
method allows you to design in Fireworks. For example, you can create a
navigation bar with a series of buttons, each of which has JavaScript rollover
functionality including a hyperlink to another page.

Inserting Fireworks HTML in
a Dreamweaver document

After you design your Web elements in Fireworks, inserting the element into
your Web page is a two-step process: You must export the HTML into a man-
aged Dreamweaver site and then insert it on your Dreamweaver page.

Follow these steps to export the Fireworks HTML into Dreamweaver:

1. Select Filec>Export.
The Export dialog box opens.

2. Enter a filename for the exported HTML file, choose the Dreamweaver
site folder as the Save in destination for the file, and select other
options relative to the Export command.

Select the desired export, HTML, and slices settings, such as HTML and
Images, Export HTML File, and Export Slices.

3. Click the Export button to complete the export process.

After you export the Fireworks HTML into a Dreamweaver site folder, follow
these steps to insert the exported HTML into a Dreamweaver document:

1. In Dreamweaver, click your cursor inside the document where you
want to insert the Fireworks HTML code.
2. Choose Insert~>Image Objects->Fireworks HTML.

You can also click the Insert Fireworks HTML button on the Common
category of the Insert panel.

The Insert Fireworks HTML dialog box appears.
3. Browse to and select the exported Fireworks HTML file.

4. (Optional) Check the Delete File After Insertion option if you want to
delete the original files after the Fireworks HTML is inserted into the
Dreamweaver file.
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If the original Fireworks HTML is on a network drive, however, it’s
immediately deleted. This setting does not affect source PNG files

associated with the HTML.
Click OK.

Dreamweaver inserts the Fireworks HTML into the Dreamweaver file
(see Figure 5-8). This insertion process includes HTML code, graphic

images, slices, and JavaScript.
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Pasting Fireworks HTML in
a Dreamweaver document

As an alternative to using the Insert Fireworks HTML command from the pre-
vious section, you can also copy and paste the Fireworks-generated HTML

code directly inside a Dreamweaver file.

To copy and paste Fireworks HTML into a Dreamweaver document, follow

these steps:

1. In Fireworks, choose Edit->Copy HTML Code.

Fireworks presumes you intend to copy the entire file, so unless you want
to copy only a part of the graphic, you don’t need to select anything.
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The Copy HTML Code Wizard dialog box opens.

2. Use the wizard to walk through the process of exporting Fireworks
HTML and images. Click the Next button to proceed through each step

in the wizard.

¢ Screen 1: Select an HTML or XHTML style for the copied HTML, such

as Dreamweaver XHTML.

Screen 2: Enter a base filename for the copied graphic slices. For
example, if the graphic is for a logo for ABC company, the base file-
name might be abclogo. Click the Optional HTML settings button to
specify additional settings for HTML output.

Screen 3: Click the Browse button to select a destination for the
copied HTML code. Typically this is the root folder of your managed
Dreamweaver site.

Screen 4: Click the Finish button. Web-ready images export to the
destination folder, and the HTML code copies to your computer’s

Clipboard.

3. In Dreamweaver, click your cursor inside the document where you
want to paste the HTML code and choose Edit~>Paste Fireworks HTML.

The copied Fireworks HTML and any associated JavaScript code are
pasted into the Dreamweaver file. At the same time, links to the images
inside the pasted code are updated to match the freshly exported

Fireworks images in the Dreamweaver site folder.

Updating Fireworks HTML in
a Dreamweaver Document

To edit Fireworks HTML files inserted in Dreamweaver documents from
within Fireworks and without launching Dreamweaver, try the Fireworks
Update HTML command. This command lets you make changes to source
PNG files in Fireworks and automatically update exported HTML and image
files placed in Dreamweaver, even if Dreamweaver isn’t running.

Follow these steps to update any Fireworks HTML you have in your

Dreamweaver document:

1. In Fireworks, open the source PNG file for the Fireworks HTML that

you want to edit.
Make any edits to the source PNG file that you need.
2. Choose FileSave.

You must save your changes before moving on to the next step.
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3. Choose File>Update HTML.

In the Locate HTML File dialog box that opens, browse to and select the
Dreamweaver folder containing the HTML file that needs updating.

4. Select the file to be updated and click the Open button.

The Update HTML dialog box opens, where you can choose whether to
replace images and associated HTML or only update images. Make your
selection and click OK.

5. In the Select Images Folder dialog box, select the folder in the
Dreamweaver site where you want to place the updated image files,
and click Select (Windows) or Choose (Mac).

The updated Fireworks HTML and images, including any associated
JavaScript code, are saved into the Dreamweaver file.

Should Fireworks be unable to find a matching HTML file to update, you
have the option of inserting new HTML into the chosen Dreamweaver file.
Any JavaScript associated with the HTML is added into the document code
appropriately.

Editing Fireworks Pop-Up Menus

NG/
v%

A pop-up menu is a navigation menu that temporarily appears in a browser
window when the user makes a specific mouse action. If you've created
any pop-up menus in Fireworks 8 or later, you can now edit them either
directly in Dreamweaver or use Fireworks roundtrip editing. If you created
your pop-up menu in earlier versions of Fireworks, you have to edit it in
Dreamweaver.

If you make changes to your Fireworks pop-up menus directly in
Dreamweaver and then subsequently make changes to them in Fireworks,
you lose all your previous edits to the menus except for text changes.

To avoid this, always create your menus in Fireworks first and then use
Dreamweaver exclusively to customize the menus. However, if you prefer
to do the menu editing in Fireworks, do not edit them in Dreamweaver at all
and instead exclusively use the roundtrip editing feature.

Roundtrip pop-up menu editing
(Fireworks 8 and later)

If you want to edit a pop-up menu that you created with Fireworks 8 or later,
you can do roundtrip editing of the pop-up menu:

1. In Dreamweaver, select the graphic in the Fireworks table that con-
tains the Fireworks pop-up menu, and click the Edit button in the
Properties inspector.
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Fireworks launches and opens the source PNG file for the pop-up menu.

In Fireworks, select the slice in the table that has the pop-up menu
you want to edit and choose Modify~>Pop-up Menu~Edit Pop-up
Menu.

The Fireworks Pop-up Menu Editor opens.
Adjust the menu content, appearance, and position.

When you finish, click the Done button in the Pop-up Menu Editor to
close the dialog box, and click the Done button on the Fireworks tool-
bar to save the changes to the menu.

The edited menu is updated in Dreamweaver.

Pop-up menu editing (Fireworks MX 2004

and earlier)

If you want to edit a pop-up menu you built with Fireworks MX 2004 or
earlier, you can’t use Fireworks’ roundtrip editing. Instead, you must use
Dreamweaver to edit the menu.

To edit pop-up menus created with Fireworks MX 2004 or earlier, follow
these steps:

1.

2.

In Dreamweaver, select the image or hotspot that triggers the pop-up
menu.

In the Behaviors panel (choose Windowr>Behaviors), double-click the
Show Pop-up Menu icon from the Actions list.

The Show Pop-up Menu dialog box opens where you can edit the menu.
Note: The Show Pop-up Menu is a deprecated JavaScript behavior for
Dreamweaver CS4, which means it is supported but no longer recom-
mended as a method for creating popup menus.

If needed, add, change, or rearrange menu items.

Click OK to save the changes.



Chapter 6: Dreamweaver Cross-
Application Integration

In This Chapter

+» Working with Flash

v+~ Inserting Photoshop images

1 Accessing and using the Bridge
1 Integrating with Device Central

v~ Getting the most out of Dreamweaver and AIR

Besides enabling you to add Fireworks images with JavaScript and
HTML to your Dreamweaver pages, Dreamweaver provides cross-
application integration with several other software programs as well,
including Flash, Photoshop, Bridge, Device Central, and AIR. Whether you
currently use these applications or have never even heard of some of them,
this chapter provides you with a general overview of how each of them
work with Dreamweaver.

In this chapter, you find out how to work with Flash to launch and edit
source FLA files from any inserted SWF; insert and optimize Photoshop
graphics into Dreamweaver using the Copy/Paste and Smart Object work-
flows; edit both the optimized graphics as well as the original source PSD
file; access and use Bridge to browse, find, organize, preview, and insert
images into Dreamweaver; preview your Web content for mobile devices in
Device Central; find tips on creating mobile Web content; and discover how
to set up Dreamweaver to use Adobe AlR.

Working with Adobe Flash

Similar to the Fireworks workflow, Dreamweaver allows you to easily launch
and edit the source FLA files for any SWF files inserted onto your Web
pages and then return the updated file back to Dreamweaver. To do this,

all you need to do is have Flash installed on your computer and configure
Dreamweaver to be the primary editor of SWF files.
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Figure 6-1:
Set Flash as
the Primary
editor for
.swf, .swt,
and .spl file
extensions.

To make Flash the primary editor of FLA and SWF files, follow these steps:

1. Choose Edit->Preferences (Windows) or Fireworks->Preferences (Mac)
to open Dreamweaver’s Preferences dialog box.

2. In the File Types/Editors category, as shown in Figure 6-1, select the
.swi, .swt, .spl extension group under the Extensions listing. Under the
Editors heading, select Flash, and then click the Make Primary button.
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By default, the FlashPlayer is set to be the primary editor associated
with these files. By setting Flash as the primary editor, you can launch
Flash from the Properties inspector to edit the FLA files associated with
the SWF files inserted on your pages.

3. Repeat Step 2 for any additional Flash file extensions you want Flash
be the primary editor for.

For example, you may want to add the .flv extension to the list and set
Flash as the primary editor for those.

4. Click OK when you’re finished.

To launch Flash as the editor for the original source FLA files associated
with the SWF files inserted on your file, make sure the SWF file is saved
somewhere inside your managed site, open the file containing the SWF, and
then select the SWF file in your document window. After you've selected it,
input the path to the source FLA file in the Flash SRC field on the Properties
inspector and click the Flash Edit button. If Flash can’t find the source file,
you are prompted to find it. Additionally, if you're using the Check In/Check
Out feature in the Files panel and the SWF or FLA files are locked, you may
need to check out the SWF file before the file can be edited.
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After you save the updated FLA file in Flash, the edited version of the SWF
is re-exported to your document and Flash closes. You can also send the
updated SWF file back to Dreamweaver without closing Flash by selecting
Filec>Update for Dreamweaver.

Inserting and Optimizing Photoshop Graphics

WMBER
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If you don’t own Fireworks but do have Photoshop, you'll be amazed at how
well Photoshop integrates with Dreamweaver. You can use two different
workflows when working with Photoshop and Dreamweaver, depending on
your specific needs.

First, you can now use Dreamweaver to optimize your PSD files into Web
graphics (GIF, PNG, and JPEG). When you insert the PSD file, Dreamweaver
adds a Smart Object to the file, which links directly back to the original file if
you need to make any edits to the optimized graphic.

Both Fireworks and Photoshop can be installed on the same computer and
used for different Dreamweaver image editing tasks. To have Photoshop
be the primary image editing program for particular file types, open
Dreamweaver’s Preferences and, in the File Types/Editors category, add
Photoshop as the image editor for the desired file types.

Second, you can paste parts of or all of a layered or sliced Photoshop file
into any Web page in Dreamweaver. Technically, the pasted graphics are not
connected to the originals for round trip (from Photoshop to Dreamweaver,
and back again) editing like you can do in Fireworks, nor are they connected
to the original PSD file like Smart Objects are, but if you need to modify any
graphics pasted into Dreamweaver in this way, you can easily go back into
Photoshop to do your edits and then re-copy and paste the graphics back
into Dreamweaver.

The Smart Objects workflow

A Smart Object is an image that has been placed from one Adobe application
to another, retaining all of its original application’s qualities. Smart Objects
are linked to the original file in case they need to be altered. With Photoshop
and Dreamweaver, the Smart Object workflow is the preferred method of
using Dreamweaver to add optimized graphics to your Dreamweaver files.

In Dreamweaver, you can easily tell that a particular graphic is a Smart
Object by the Smart Object icon that appears in the top left corner of the
Smart Object image, as illustrated in Figure 6-2.
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If at any time the original PSD file is edited after a Smart Object linked to
it has been placed into your Dreamweaver file, Dreamweaver detects the
change and makes one of the green arrows of the Smart Object icon turn
red. You can then select the Smart Object graphic in Dreamweaver and
easily update the graphic by pressing the Update from Original button in
the Properties inspector. You can also update one or more Smart Objects at
once through the Assets panel by selecting the image and choosing Update
from Original from the Asset panel options menu.
Smart Objects can also be resized, cropped, resampled, sharpened, and have
their brightness and contrast adjusted using the buttons on the Properties
inspector. For details about using these tools, see Book I, Chapter 3.

ng‘“\NG! To keep their design files separate from their Web files, most designers save

the Photoshop PSD files that are used to create the SmartObjects outside

of the managed Dreamweaver site. To make the editing process go more
smoothly, you could put a copy of the PSD file at the root level of your man-
aged site. However, if you do, be sure to cloak the PSD file so that the graph-
ics are not uploaded to the server when publishing your site. (See Book V,
Chapter III to learn more about cloaking.)

To place a Photoshop Smart Object into Dreamweaver, follow these steps:

1. You can insert your Smart Object in either of the following two ways:

e Drag and drop the desired Photoshop PSD file from the Files panel
into the Design view area of your open Dreamweaver document.

¢ Select Insert>Image and select the Photoshop PSD file.
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Either of these actions launches Dreamweaver’s Image Preview dialog
box, seen in Figure 6-3.
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2. Select the desired file format and optimization settings in the

Options tab.

Format: Select a file format for the optimized graphic. Choose from GIF,
JPEG, PNG-8, PNG-24, or PNG-32.

The file format you select determines how the rest of the dialog box
looks. For instance, the JPG format offers different optimization settings
than the PNG and GIF formats.

GIF and PNG settings:

e Palette: Choose a color palette for the graphic. Options include
Adaptive, Web Adaptive, Web 216, Exact, Windows and Macintosh,
Grayscale, Black and White, Uniform, and Custom.

¢ Loss: Add a loss setting to compress GIF files for smaller file sizes.
The higher the number, the smaller the file, but the greater the
potential loss of image quality.

e Number of Colors: Select the number of colors in your image from 2

to 256.

¢ Dither: Enable the dithering option to control how colors not in the
selected palette are approximated using colors within the palette.
Adjust the amount of dithering from 0-100% using the dithering

menu.

Book IlI
Chapter 6

uoneihaju|
uonealddy-ssoi9
laneamuwealq



33 4 Inserting and Optimizing Photoshop Graphics

Transparency: Choose a transparency setting of either No, Index (for
GIF), or Alpha (for PNG-8).

Matte: Select a matte color for graphic to match the color of the page
the graphic or object will be sitting on top of.

Remove Unused Colors: Removes unused colors from the graphic,
thereby making the file size smaller.

Interlaced Browser Display: (GIFs and PNG-8 only) Makes the image
load in multiple passes in the browser window, showing a low resolu-
tion image first and progressively improving the image until it is fully
cached in the browser.

Optimize to Size: Launches a wizard that allows you to optimize
the graphic based on a desired file size in kilobytes (Kb). File size is
reduced by making adjustments to the number of colors and dither-
ing setting.

JPEG settings:

Quality: Adjust the quality setting to control the loss of image qual-
ity during compression. Higher numbers produce better quality
images with larger file sizes.

Smoothing: Enable a smoothing setting to blur hard edges in the
graphic and reduce file size. Higher numbers reduce file size but can
distort the quality of the image.

Progressive Browser Display: Makes the image load in multiple
passes in the browser window, showing a low resolution image first
and progressively improving the image until it is fully cached in the
browser.

Sharpen Color Edges: (JPEGs only) When enabled, this option pro-
vides a sharper image quality. Sharpen Color Edges is on by default.

Matte: Select a matte color for graphic to match the color of the page
the graphic or object will be sitting on top of.

Remove Unused Colors: Removes unused colors from the graphic,
thereby making the file size smaller.

Optimize to Size: Launches a wizard that allows you to optimize
the graphic based on a desired file size in kilobytes (Kb). File size is
reduced by making adjustments to the number of colors and dither-
ing setting.

3. (Optional) On the File tab, edit the scale and export area of the pasted
graphic.

To modify the size of the image, adjust the Scale field in percentages or
type the exact pixels in the Width and Height fields.

To optimize and export only part of the selected graphic, enter X and Y
coordinates relative to the original graphic dimensions as well as W and
H sizes.
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4. Click the OK button to save the optimized graphic.
Dreamweaver opens the Save Web Image dialog box.

5. In the Save Web Image dialog box, select a destination and filename
for your optimized graphic, and click the Save button.

For example, when working in a managed site in Dreamweaver, you
might select the images folder sitting at the root level of your managed
site as the location to save your images into. The name of the file is
totally up to you, although you should try to name your graphics after
their purpose so that they’ll be easy to identify as you use them, such as
nav_01.gif, onsalenow.jpg, or closeup.png.

When Accessibility options are enabled for images, you’ll be prompted

to add Alt text for your Smart Object image in the Image Tag Accessibility
Attributes dialog box. Either add the information and click the OK button,
or click the Cancel button to add the image without Alt text.

Editing the Smart Object’s Optimization Settings

To edit the optimization settings of a placed Smart Object image, select the
image and click the Edit Image Settings button on the Properties inspector.
This relaunches the Image Preview dialog box, inside which you can non-
destructively adjust the optimization settings based on the original source
PSD file. When you're finished adjusting these settings, save the updated
optimized graphic and Dreamweaver overwrites the original optimized
graphic with the new one.

Editing the Smart Object’s Original PSD

To edit the original Photoshop PSD file linked to your Smart Object from
within Dreamweaver, select the Smart Object in Design view of your open
document and click the Edit button on the Properties inspector. When

you are finished making changes to the Photoshop file, save the file in
Photoshop. Upon returning to Dreamweaver, reselect the Smart Object and
click the Update from Original button on the Properties inspector.

To watch a video tutorial about using Photoshop to create Smart Objects
when inserting PSD files into Dreamweaver, go to www . adobe.com/go/
vid0200.

The Copy/Paste workflow

To create an optimized graphic without inserting a Smart Object, you can
use the Copy/Paste workflow. As mentioned previously, with this method, no
Smart Object is created, which means there is no link to the original source
Photoshop file. Therefore, to edit an image on your page that has been opti-
mized in this fashion, you must reopen the original file in Photoshop and
repeat the following steps to replace the current optimized graphic with a
new one.

Book IlI
Chapter 6
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Any time you use the Copy/Paste workflow, Dreamweaver automatically
adds Design Notes to your file that include image information such as the
location of the source Photoshop file. To find out more about Design Notes,
turn to Book VI, Chapter 1.

When you’re ready to copy and paste your work from Photoshop into
Dreamweaver, follow these steps:

1. In Photoshop, select the slices or layers (or make a selection with
any of the selection tools) and copy them by selecting Edit=>Copy
(for slices or a selection on a single layer) or Edit=>Copy Merged (for
selected layers or multi-layer selections).

If you're selecting slices, use the Edit Slice tool; when selecting layers,
use the layers panel to Shift+Ctrl+click (Windows) or Shift+88+click
(Mac) the thumbnails of the desired layers; for selections, use any of the
marquee or magic wand selection tools.

2. Switch over to Dreamweaver and select Edit->Paste.
Dreamweaver’s Image Preview dialog box opens (see Figure 6-3).

3. Select the desired optimization, scale, and export settings in the
Options and File tabs of the dialog box.

Refer to the previous section “The Smart Object Workflow” for details on
these settings.

4. Click the OK button to save the optimized graphic.
Dreamweaver opens the Save Web Image dialog box.

5. In the Save Web Image dialog box, select a destination and filename
for your optimized graphic and click the Save button.

If you are prompted to do so, enter in an Image description to add the
alt attribute to your optimized image when Dreamweaver inserts it
onto your Web page. Otherwise, the image is inserted onto your page
without it; you can always add or edit the Alt attribute to the selected
image on the Properties inspector.

Editing the pasted optimized graphic’s original PSD
If you need to make changes to a pasted optimized graphic after it has been
added to your Dreamweaver page, repeat the preceding steps, making sure
to save the updated graphic with the same filename into the same location in
your managed site so that the new version overwrites the old version.
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You can launch the original source PSD file in Photoshop from the pasted
image in Dreamweaver if you first set Photoshop to be the default editor for
that file extension in Dreamweaver’s File/Types category of the Preferences
dialog box, and then select the graphic and enter the path to the original
Photoshop file in the Properties inspector. After you’'ve done that, you

can select the graphic in Design view and then click the Edit button on the
Properties inspector, which in turn opens the original file in Photoshop.
When you are finished making changes to the Photoshop file, save the file in
Photoshop, and then repeat the Copy/Paste workflow steps above to create
a new optimized graphic for Dreamweaver. If you save the new graphic with
the same name as the old file, the new graphic replaces the old one.

Reoptimizing the pasted optimized graphic

To edit the optimization settings of an optimized image that you've added
to your page using the Copy/Paste workflow, select the image and click the
Edit Image Settings button on the Properties inspector. This relaunches the
Image Preview dialog box, inside which you can non-destructively adjust the
optimization settings based on the original source PSD file. When you're fin-
ished, save the updated optimized graphic and Dreamweaver overwrites the
original optimized graphic with the new one.

\3
P To watch a video about the Copy/Paste workflow between different Adobe
programs like Photoshop and Dreamweaver, go to www.adobe . com/go/ Book Il1
vid0193. Bl

Accessing and Using Adobe’s Bridge

Adobe Bridge is simply one of the best cross-platform file browsing pro-
grams for finding, organizing, and previewing your files — both Adobe

and non-Adobe — for all your Web, print, video, and audio projects. As an
Adobe application, Bridge can be launched from any Creative Suite pro-
gram (except Acrobat 8) or as a standalone application from where you can
select a file and launch any Adobe Creative Suite program that supports the
selected file’s format.
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Use Bridge, as seen here in Figure 6-4, with Dreamweaver to preview, sort,
and search for files, add meta data, and insert selected files into your docu-
ments. You can also do automated tasks like batch renaming, as well as
manage your digital photographs and stock art.
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To watch an Adobe video on the Adobe Bridge Web workflow, go to www.
adobe.com/designcenter/video_workshop/?id=vid0192.

Launching Bridge from Dreamweaver

Launch Bridge from within Dreamweaver in any of the following ways:

4+ Select File>Browse in Bridge.

4+ Launch Bridge using the keyboard shortcut, Ctrl+Alt+O (Windows) or
8 +Option+0O (Macintosh).

4 Click the Bridge icon on the Standard Document toolbar. If hidden,
select Viewr>Toolbarst>Standard to make the Standard toolbar visible.

Launching Dreamweaver from Bridge

To launch Dreamweaver from within Bridge, select File=>Open With=>Adobe
Dreamweaver, or select a file and then right-click (Windows) or Control+
click (Macintosh) it to open the context menu, from which you may select
Open With=>Adobe Dreamweaver.
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Inserting a file from Bridge
After you’ve launched Bridge, you can select and insert a file into the loca-
tion of your cursor in Dreamweaver’s Design view by one of two methods:

4+ Drag and drop the selected file(s) from Bridge into your open Web
document.

4+ Select a single file and choose Filem>Place In Dreamweaver.

If the selected file is not already in your managed site’s root folder or images
folder, Dreamweaver prompts you to put a copy of the selected file in there.
When inserting Web-ready graphics like GIF, PNG, and JPG files, you may
also be prompted to add image tag accessibility attributes for your newly
inserted file.

Integrating Your Files with Device Central

\3

With Device Central, Dreamweaver users can now preview how their files
will appear in a selection of different mobile devices. Within Device Central,
which uses the Opera browser’s Small Screen Rendering system, you can see
how your mobile content looks on a small screen and test whether CSS and
other Web page markup is coded correctly.

To begin previewing your Web content for mobile devices, open the file in

Dreamweaver and select FilecoPreview in Browser=Device Central, or click
the Preview/Debug in Browser button on the Document toolbar and select

the option to Preview in Device Central.

After Device Central launches, as shown in Figure 6-5, your Web page
displays inside the Emulator tab, where you can review your file as well as
choose other devices listed in the Device Sets or Online Library panes.

One popular device, the Apple iphone, is unfortunately not available within
Device Central, but you can test for that online at www. iphonetester. com.

Book IlI
Chapter 6
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Tips for creating mobile content

Creating and designing mobile content is a elements on your mobile content pages, be sure
bit different than creating content for normal to insert the following two lines of code into
Web pages. For example, although individual your pages for accurate CSS and JavaScript
mobile devices may support certain HTML rendering:

features, the Opera Small-Screen Rendering
does not support certain elements including
frames, pop-up browser windows, and cer-
tain font styles such as underlines, overlines,
strikethroughs, blinking, and marquees. Also,
images must be made smaller than normal to
render without skewing in the smaller device
window. Try, too, to keep fonts, colors, and
styles to a minimum, while making sure to use
CSS or HTML to set width and height attributes  For even more design tips and information about
for images as well as adding alt attributes creating mobile content, see www.adobe.
for all your images. Lastly, when using Spry com/go/learn_cs_mobilewiki_en.

<link href="SpryAccordion.
css" media="screen"
rel="stylesheet"
type="text/css"/>

<link href="SpryAccordion2.
css" media="handheld"
rel="stylesheet"
type="text/css"/>
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For instruction and details about using Device Central, visit http://1live
docs.adobe.com/en_US/DeviceCentral/l.1l/index.html.

Setting Up Dreamweaver to Use Adobe AIR

Adobe AIR is a relatively new cross-operating system software application
that lets users develop and deploy multiplatform Rich Internet Applications
(RIAs) to the desktop using Flash, Flex, HTML, JavaScript, and Ajax. What
makes AIR so powerful is that you can create these RIAs in a familiar envi-
ronment. So in Dreamweaver, for instance, you could build an application
using HTML, JavaScript, CSS, and Spry Widgets (Ajax).

To use an AIR application, you simply run it and interact with it on their
desktop like your other native desktop applications. Even better, these
applications work on Mac, PC, and Linux platforms, providing consistent and
predictable performance to users. In essence, AIR helps you deliver desktop
applications to end users without worrying about cross-platform develop-
ment requirements or performance issues.

Using Adobe AIR requires two things: First, you have to download and install
the Adobe AIR authoring application. Second, you have to download and
install the Adobe AIR extension for Dreamweaver, which lets you package

and preview your AIR applications from within Dreamweaver. Book i

Chapter 6

You can download the latest version of the free AIR application and the
Adobe AIR SDK at www.adobe.com/products/air/tools/ajax/, which
gives you the tools you need to build and deploy the AIR applications.

After that, you must install the Adobe AIR extension for Dreamweaver to
begin using Dreamweaver to package and preview your Adobe AIR applica-
tions within Dreamweaver.
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Follow these steps to download and install the Adobe AIR Extension for
Dreamweaver:

1. Download the Adobe AIR extension for Dreamweaver to your desktop.

The link to download the extension can be found on Adobe’s Tools for
AIR and Ajax Web page at www . adobe.com/products/air/tools/
ajax/.

The extension is provided in MXP format for easy installation using
Adobe’s Extension Manager software. Make sure you select the AIR and
not the AIR SDK file.

2. Double-click the MXP file to launch the Extension Manager.
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3

This both opens the Extension Manager and begins the installation pro-
cess of the MXP file. Follow the on-screen prompts to accept the terms
of the extension installation disclaimer. When finished, the Extension
Manager notifies you that the extension has been successfully installed.

3. Exit and then restart Dreamweaver CS4.

The extension is fully functional only after you restart Dreamweaver.

After the AIR application and extension have been installed, you can begin
using Dreamweaver to package and preview AIR applications by selecting
Sitec>Create AIR File.

For instructions on using the Dreamweaver AIR extension, see
http://livedocs.adobe.com/air/1l/devappshtml/help.
html?content=AIR_extension_1.html.

To find out more about Developing Adobe AIR applications with HTML and
Ajax, try the following Web sites:

www . adobe.com/go/learn_air_html_en

www .adobe.com/products/air/tools/ajax/

www . adobe.com/support/documentation/en/air/#html-ajax

http://1livedocs.adobe.com/air/1/devappshtml /help.
html?content=splash.html

http://help.adobe.com/en_US/AIR/1.1/devappshtml/

To date, nearly 200 Adobe AIR applications are available to download and
use for free. Applications include such tools as the BrandGopher (a domain
name research tool), Shrink O’Matic (an image batch resizer), and Timeloc
(a desktop tool that tracks your time on various projects). You can find
these applications and more on the Adobe AIR Marketplace Web site at www .
adobe.com/cfusion/exchange/index.cfm?event=productHome&exc
=24&loc=en_us.
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