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Introduction

to see people who have just enough basic knowledge to work in

a sophisticated program such as Excel waste inordinate amounts
of time doing their work “the hard way” because they don’t really know
how to go about harnessing the program’s features. This book is a vehi-
cle for taking that next step into efficient use of Microsoft Excel, a program
about which I have written a great deal and am naturally very partial. It
is my sincere hope that it helps you become not only more competent in
Excel but also much more confident in your ability to use rather than be
used by it.

F ew things are more disappointing to me as a software trainer than

Saving Time with This Book

The Timesaving Techniques For Dummies books focus on high-payoff tech-
niques that save you time, either on the spot or somewhere down the
road. These books get to the point in a hurry, with step-by-step instruc-
tions to pace you through the tasks you need to do, without any of the
fluff you don’t want. I've identified more than 60 techniques that Excel
users need to know to make the most of their time. In addition, each
technique includes lots of figures that make following along a breeze.
Decide for yourself how to use this book: Read it from cover to cover

if you like or skip right to the technique that interests you the most.

In Excel Timesaving Techniques For Dummies, you can find out how to

v Tame time-consuming tasks: Because | demystify the inner workings
of Excel for you, letting you in on more than 60 tips and tricks along
the way, you can spend more time on creating great results and less
time on fiddling with a feature so that it works correctly.

v Take your skills up a notch: You're already familiar with the basics
of using Excel. Now this book takes you to the next level, helping you
become an even savvier Excel user.



2 Introduction

v Customize Excel to meet your needs: Spending
some upfront time customizing Excel so that it
works faster, more reliably, and more like how
you work on a daily basis can save you time
(and aggravation) later.

v Automate repetitive tasks: This book shows
you how to lighten your work load by taking
fewer steps to do everyday tasks, especially
those involving data entry and formatting in
the worksheet.

Foolish Assumptions

I'm only going to make one foolish assumption about
you and that is that you use Microsoft Excel in your
work or studies at the basic level. If pushed, I further
guess that you aren’t particularly interested in know-
ing Excel at an expert level but are terribly motivated
to find out how to do the stuff you need to get done
more efficiently. If that’s the case, then this is defi-
nitely the book for you. Fortunately, even if you hap-
pen to be one of those users who’s highly motivated
to become the company’s resident spreadsheet
guru, you've still come to the right place.

As far as your hardware and software go, I'm assum-
ing that you already have a version of Excel between
Excel 97 and 2003 (the latest) installed on your
computer and that you’re using a standard instal-
lation running on a version of Windows between
Windows 95 and Windows XP or Windows 2000.
Although the figures in this book all show Excel 2003
happily running on Windows XP, it makes no differ-
ence to most of the written instructions if you're
using an earlier version of Excel on an earlier ver-
sion of Windows.

What’s In This Book

Excel Timesaving Techniques For Dummies is divided
into nine parts that contain loosely related tech-
niques for working smarter and faster. That way,

you can go after the procedures in the particular
part of the book that really interest you at the time,
putting all the rest of the tips and tricks aside until
you need to have a look at them. In case you're the
least bit curious, here’s the lowdown on each part
and the types of techniques you can expect to find
there.

Part I: Making Excel Work Your Way

These techniques enable you to cut through the
Excel screen clutter and get the program to work
and look the way you want it. Find out how to cus-
tomize everything from the Excel screen display to
the pull-down menus and toolbars. You also find out
how to streamline program startup and save time
by knowing exactly where you saved the spread-
sheet you worked on the day before.

Part ll: Quick Worksheet Creation Tricks

The techniques in this part are dedicated to showing
you more efficient ways not only to build your spread-
sheets but also to make them more accurate. Here
you find out how to quickly navigate the worksheet,
make proficient cell selections, and do data entry
like the pros. In addition, you find out how to ensure
accurate entries with Excel’s data validation and
Text to Speech features.

Part Ill: Handy Ways to Format and Present
Worksheet Data

This part contains the techniques that you need

to easily and quickly make the data in your work-
sheet its most presentable. Here you find out how
to instantly format tables of data through a com-
bination of tips and tricks. You also find out how to
create and apply custom number formats and select
the alignment features best suited to the particular
data you're working with. Finally, you find out how
to quickly conjure up charts and graphs that can
demonstrate trends and analyses otherwise hidden
in the data itself.



Part IV: Worksheet Formula Timesavers

The techniques in this part are devoted to enabling
you to create efficient and well-formed formulas in
your Excel spreadsheets. Here you find out how to
accurately copy formulas using all types of cell ref-
erences, greatly speed up table creation through
the use of array formulas, and document formulas
through the sagacious use of range names. As if this
weren’t enough, you also find out how to create for-
mulas that trap Excel error values and prevent them
from spreading far and wide throughout the spread-
sheet and, in the event that they do succeed in get-
ting out, how to trace their source and eliminate
them on the spot.

Part V: Worksheet Editing Timesavers

The techniques in this part center on how to make
efficient editing changes in a completed spread-
sheet. Knowing these techniques can save you
oodles of time if you're among the more common
worksheet users who spend a majority of the time
adding to and updating existing company work-
books. Here you find out how to quickly find the
workbook you want to edit, control the Excel screen
display so you can see what you're editing at all
times, use the editing tips and tricks of the pros,
as well as consolidate data from several worksheets
and subtotal their data without even breaking a
sweat.

Part VI: Tips for Printing, Sharing,
and Reviewing Workbooks

Tops among the techniques in this part is the first
one on spreadsheet security and how to protect
your sensitive data from unwarranted opening or
edits without ending up being locked out of the file
yourself. Here you also find out how to produce flaw-
less printed reports, share Excel data with the other
programs you run, share your workbook files on a
local network, and send your files out to coworkers
and clients for a formal review.
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Part VII: Streamlining Data Listing
and Data Analysis

This part is dedicated to skillful means for turning
great quantities of raw data into usable information.
Here you find techniques for organizing, searching,
sorting, and filtering the data you keep. You are also
introduced to what-if analysis and data summation
in all its glory in the form of data tables, scenarios,
goal seeking, and those wonderful pivot tables and
pivot charts.

Part VIII: Internet-Related Timesavers

The techniques in this part give you the inside track
on sharing Excel data on the World Wide Web. Here
you find out how to instantly convert your Excel
worksheet data and charts into HTML documents
ready to publish to your Web pages either on the
Internet or your company’s intranet. You also find
out how to easily import data from Web pages
directly into Excel where you can manipulate the
data to your heart’s content and how to add hyper-
links to your worksheets to make any kind of jump
you need, from one worksheet to another in the
same workbook all the way to any address on the
Internet.

Part IX: The Scary (Or Fun) Stuff

This last part contains a potpourri of techniques,
some of which are thrown in for the fun of it and oth-
ers that you may at first perceive to be somewhat of
a stretch. (I don’t actually include techniques here
that you really need to apprehensive of.) Among the
fun techniques, you find out how to use Excel 2003
lists (which are a real delight and are so easy they
almost create themselves), how to do worksheet
data entry and issue Excel commands with the power
of your voice, and how to spruce up the look of your
spreadsheets with art images (both those you draw
and others you import).

Among the less instantly comfortable techniques
in this part are creating lookup formulas that return
data from schedules and other data tables, creating
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entered in the wrong case or which you need to com- pay extra attention to; otherwise, you'll be
bine, setting up queries to the corporate database sorry. | reserve this icon for those times when
that return data to the Excel worksheet, using macros you can lose data and otherwise mess up your
to automate all those repetitive tasks, and creating spreadsheet.
custom functions for instantly performing specialized
calculations not covered by any of Excel’s built-in T This icon denotes some extra tip or trick tidbit
functions. that can end up saving you even more time,

& especially when used in tandem with the

general points being made in the current

text formulas that manipulate text entries that were This icon denotes a tidbit that you ought to

Icons Used in this Book technique.

[ have strategically placed the following icons

throughout all 61 techniques in this bogz)k. Their Wh ere to Go f tom Her e

purpose is to get you to pay close attention to

something I'm saying, and each has its own way The question of where to go from here couldn’t be

of doing that. simpler: Head off to read the great Rich Tennant car-

toons at the beginning of each of the nine parts, of

This icon denotes some really cool information course. Which part and technique you jump into
(in my humble opinion) that, if you pay partic- after that is a matter of personal interest and need.
ular attention to, will pay off by making your Just don’t forget to have fun while discovering how
work more enjoyable or productive (or both). to work smarter and faster in Excel.

This icon denotes a tidbit that you ought to
pay extra attention to; otherwise, you may end
up taking a detour that wastes valuable time.
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Save Time By

v~ Switching in and out of
Full Screen view

v Customizing sheet and
workbook settings

v~ Saving your custom
settings in a workbook
template

Customizing the
Excel Screen
Display

is a busy place. Filled with all kinds of buttons and bars, it’s a

wonder that there’s any place left for entering your precious
spreadsheet data. Therefore, the first technique that any dedicated Excel
user needs to know is how to control the look and feel of the Excel dis-

play screen.

What can I say? The Excel program window (shown in Figure 1-1)

[=] Microsoft Excel - Bookl =i
{E] File Edit View Insert Format Tools Data Window Help Adohe PDF Type aquestion for b+ o & X
N EH SR LR Do E ] 00 o e =10 =| B I |BEXEM|S % %83
Al - o
; _‘\_i B | ¢ | b | E | F | 6 | H T~ : Getting Started v x
2 ®|®|a
3] o; 3
4 + 1 Office Online
&
6 | * Connect to Micrasaft Office Online
7 * Get the latest news about using Excel

* Automatically update this kst From the web

L
9
10
EED Search for:
12
13 Example: "Print more than one copy™
14
15 Open
16 bask e
--% Wide columns. it
19 571311 pg cnk.ds
T Excel TST page count.xis
i | More...
2
23

| ) Creats s new workbaok..,

~

|

TEQ@DNRB 3ROMYS 1w

* Figure 1-1: Is it Grand Central Station? No, just the Excel program screen.
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Here you find out how to max out the worksheet dis-
play so that you access as many cells and as much
of your spreadsheet data as possible, thus saving
you from having to waste a lot of your precious time
just scrolling up and down and back and forth to
view the cells you need to work with. You also find
out how to customize the display so that it repre-
sents more the type of spreadsheets you create and
then how to save these custom display settings in
worksheet templates that enable you to immediately
utilize all these settings in new workbooks you gen-
erate from them.

Standard Display Settings

Controlling the Excel display screen includes not
only hiding unwanted toolbars that surround the
worksheet but also modifying the sheet’s look and
feel. Each time you launch Excel, the program opens
a new workbook whose sheets use a whole bunch
of standard display settings.

These standard settings consist of the following:

v Three blank worksheets each identified by their
own sheet tabs.

v 256 columns in each sheet with a standard width
of 8.43 characters (64 pixels) and labeled with a
column header using letters (A through IV).

V¥ 65,536 rows in each sheet with a standard row
height of 12.75 points (17 pixels) and labeled
with a row header (1 through 65536).

v Gridlines demarcating the edge of each sheet’s
columns and rows and thereby displaying the
outline of each worksheet cell.

Switching to Full Screen

The fastest and simplest way to remove the screen
clutter caused by the Excel toolbars and thereby

maximize the number of cells displayed on your
screen is by switching to Full Screen view (Vieww
Full Screen). As soon as you choose this command,
Excel temporarily hides any open toolbars. The pro-
gram also gets rid of the Formula bar at the top and
the sheet tabs, the horizontal scroll bar, and the pro-
gram’s Status bar at the bottom, leaving only the
Worksheet menu bar, column and row headers,
vertical scroll bar, and Windows taskbar surround-
ing the blank worksheet cells (see Figure 1-2).

In Full Screen view, Excel displays a floating Full
Screen toolbar in the lower-right corner of the
screen. To switch back into normal screen view,
simply click the toolbar’s Close Full Screen button.
Excel closes the Full Screen toolbar and restores
all the missing toolbars.
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¢ Figure 1-2: Maximizing the worksheet real estate in Full
Screen view.

Working without the benefit of the Formula bar is fine
as long as all you're doing is entering scads of spread-
sheet data or checking up on your data entries. If,
however, you're doing more than this kind of simple
data entry and editing, you’ll probably need to have
the Formula bar displayed on the screen. To display
the Formula bar while Excel is in Full Screen view,
follow these steps:



1. Choose Tool=>Options.
2. Select the View tab in the Options dialog box.

3. Select the Formula Bar check box and then
click OK to close the Options dialog box.

After displaying the Formula bar when the program
is in Full Screen view, it continues to appear on the
screen as you switch in and out of Full Screen view.
If you decide that you don’t need the Formula bar on
the screen in Full Screen view, deselect the Formula
Bar check box in Step 3 of the preceding steps.

Auto-hiding the Windows taskbar gives you
a little more worksheet real estate. Just right-
click the Start button and choose Properties to
open the Taskbar and Start Menu Properties
dialog box. Click the Taskbar button in this
dialog box and then select the Auto-Hide the
Taskbar check box and click OK. After that,
Windows keeps the taskbar hidden until you
position the mouse pointer somewhere along
the bottom of the screen. As soon as you
move the mouse pointer out of this area,
Windows hides the taskbar again.

Customizing the Worksheet
Display

Excel offers all sorts of ways to customize the appear-
ance of the worksheet display. Here’s a sampling of
what you can do:

v Modify the width of some or all the columns and
rows in any of the three worksheets.

v C(Change the number of sheets in the workbook.

1 Control whether the worksheet gridlines that
define the boundaries of each cell are hidden or
displayed and determine the color used when
they are shown on-screen.

Customizing the Worksheet Display 9

Setting a new standard column width

If you're working on a spreadsheet that almost uni-
versally requires a different standard column width
(usually one wider than the 8.43 characters or 64
pixels standard), you can easily set a default width
for every column in the worksheet:

1. Choose Format=>Column=>Standard Width.

Excel opens the Standard Width dialog box,
shown in Figure 1-3.

Standard Width

standard column width:

[ (8] 4 ][ Cancel ]

¢ Figure 1-3: Designating a new standard width for the
columns in a worksheet.

2. Enter the new width in characters (between
0 and 255) in the Standard Column Width
text box.

Setting a column width to O is the equivalent
of hiding the column in the worksheet by
choosing Format=>Column=>Hide. You can

use this technique to hide columns you use
in calculating certain worksheet formulas but
don’t necessarily want printed as part of the
final spreadsheet. However, if you enter O
here as the new standard width, you hide

all the columns in the worksheet, making it
impossible to add, edit, or print data in any
of its cells!

3. Click OK to close the Standard Width
dialog box.

Changing the value in the Standard Width dialog box
changes the default column width for all the columns
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in only the active worksheet. Using this command
has no effect on the width of columns that you man-
ually resized or resized with the AutoFit feature.

If you want to change the default column
width for all the worksheets in your workbook,
select all the sheets (by Ctrl+clicking their
sheet tabs or right-clicking the tab of the
active sheet and then clicking Select All Sheets
on the shortcut menu) before you open the
Standard Width dialog box and set a new
default value.

Setting a new standard row height

Note that Excel doesn’t provide an equivalent com-
mand for setting a new default height for all the rows
in a worksheet. This is probably because the program
automatically adjusts the height of the row to accom-
modate the data that you enter in its columns. If
you're creating a spreadsheet where you would
benefit by having a new standard row height (pre-
sumably, a taller one), you can set all the rows

in the worksheet to a new height by using this
work-around:

1. Click a letter in the Column header.

Clicking a column letter in the Column header
selects all the rows in that column in the
worksheet.

2. Choose Format->Row=>Height.

Excel opens the Row Height dialog box, shown
in Figure 1-4.

Row Height

Row height:

4 ][ Cancel ]

* Figure 1-4: Designating a new row height for all the
selected rows in a worksheet.

3. Enter the new row height in characters
(between 0 and 255) in the Row Height
text box.

Setting the row height to 0 is the equivalent of
hiding the row in the worksheet by choosing
Format=>Rowr>Hide. You can use this technique

to hide rows you use in calculating worksheet
formulas but don’t necessarily want to appear
in the printout. However, if you enter 0 here
when all the rows of the worksheet are selected,
standard width, you hide all the rows in the
entire worksheet, making it impossible to add,
edit, or print data in any of its cells!

4. Click the OK button to close the Row Height
dialog box.

Excel changes the height of all the rows in the
worksheet.

To remove the cell selection from all the rows in the
column whose heading you clicked, click any single
cell with the mouse pointer.

Modifying the number of sheets in a workbook

In the olden days of Excel, when the program first
started supporting the use of more than one work-
sheet in a single spreadsheet file, the program auto-
matically provided each new workbook that you
opened in the program with 17 blank worksheets.
In the more recent versions of Excel (all those in the
2000 series), the program default has been lowered
to a much more modest three sheets in every new
workbook. For some users, 17 was far too many
sheets for their modest spreadsheet needs, and for
others, three sheets are far too few for the types

of complex spreadsheets they routinely create.

Although Excel makes it easy to insert new work-
sheets in a workbook (you simply choose Insert
Worksheet to pop a new one in), if you find yourself
having to manually add new sheets to many of the
new workbooks you start, you should probably mod-
ify the default number of sheets that Excel adds to
all new workbooks:



1. Choose Tools->Options to open the Options dia-
log box.

2. Select the General tab in the Options dialog box.

3. Enter a new value between 1 and 255 in the
Sheets in a New Workbook text box or select
this value with the box’s spinner buttons; then
click OK.

After changing the value in the Sheets in a New
Workbook text box, Excel adds that number of
sheets to any new workbook you create.

Customizing the worksheet gridlines

When creating a standard spreadsheet application
such as the standard profit and loss statement and
balance sheet, the worksheet gridlines that are auto-
matically displayed in all new worksheets provide

a much needed background with which to visually
align the data. In other, more nonstandard applica-
tions such as online forms and presentations with
embedded charts, gridlines not only are often con-
fusing to the eye but actually interfere with the pres-
entation of the information the sheet contains.

To give the heave-ho to a worksheet’s gridlines in
the current worksheet, follow these steps:

1. Choose Tools=>Options to open the Options dia-
log box.

2. Select the View tab in the Options dialog box.

3. Deselect the Gridlines check box and then
click OK.

Turning off gridlines in a worksheet display
has no effect on whether or not the gridlines
appear on paper when the sheet is printed.

To prevent Excel from adding gridlines to a
printed report, the Gridlines check box on the
Sheet tab in the Page Setup dialog box (Filer>
Page Setup) must not be selected before you
send the sheet to the printer. You check this in
print preview.

Saving Custom Display Settings ’ ’

When you display the column and row gridlines on
the screen, Excel uses your Windows desktop set-
tings to determine what color to assign the gridlines
(usually, they appear in light blue). If you want to
assign a new, perhaps bolder, color to the gridlines,
follow these steps:

1. Choose Tools>Options to open the Options
dialog box.

2. Select the View tab in the Options dialog box.

3. Select the Gridlines Color drop-down list box,
select the new color in the pop-up color palette,
and click OK.

When you select a new color for the gridlines,
it doesn’t just affect how the gridlines appear
on your screen. Excel also uses this color in

printing the gridlines in a worksheet when the
Gridlines check box is selected on the Sheet
tab in the Page Setup dialog box.

Saving Custom Display Settings

While it’s all well and good that Excel gives you plenty
of choices for customizing its screen display, it sure
would be a waste of time if you had to manually
modify all the various screen settings each time you
started working on a new workbook. Fortunately,
you can save your custom display settings as an
Excel template, and then any time you need to gener-
ate a new spreadsheet that uses those settings, you
can do so simply by opening the template.

Creating a template

To create an Excel template with your custom dis-
play settings, follow these steps:

1. Launch Excel and then manually make all the
changes to the display settings that you want
saved in the new template.
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When making changes to display settings for
a template, select the settings that you find
yourself manually changing over and over
again (such as inserting an additional work-
sheet, removing the gridlines, and selecting a
new standard column width). When entering
display values (such a new default column
width or row height), select the value.

2. Choose Filec>Save or click the Save button
on the Standard toolbar to open the Save As
dialog box.

3. From the Save as Type drop-down list, choose
Template (*.xIt), as shown in Figure 1-5.

My Recent
Documents
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My Documents

58
My Computer
;9)] File pame: g Gridines| ~ Save
My Metwark = L
Places Save 85 bype! | Template (* oty ~

Save As 28
Save ) Templates vl @ Q@ X Ty B toos -
; =] wide columns. <

* Figure 1-5: Selecting Template (.xIt) as the file type for
saving a new worksheet template.

4., Highlight the temporary filename (Bookl,
Book2, and so on) in the File Name combo
box (be sure you don’t select the .x1t filename
extension) and then type in a descriptive name
for the new template.

When replacing the temporary filename with
one of your own, pick a brief name that
describes the new settings, such as 15 Wide
Col, No Gridlines, or 4-Sht Book. Be aware
that when you generate a workbook from the
template you're creating, Excel uses the main

filename in the workbook’s temporary file-
name as in 15 Wide Col1, No Gridlines2, and
4-Sht Book3.

5. Click Save to close the Save As dialog box and
save your settings in the new template file.

Using a template

To use your template to generate a new workbook
with your custom display settings, follow these
steps:

1. If the template is currently open, close it by
choosing File=>Close on the menu bar or by
pressing Ctrl+W.

You must close a new template file before you
can generate files from it.

2. Choose Filec>’New to open the New Workbook
task pane.

To use your new template, don’t click the New
6 button on the Standard toolbar or press the
keystroke shortcut Ctrl+N. Doing so automati-

cally opens a new workbook using the Excel
out-of-the-box settings, giving you no oppor-
tunity to generate the new book from any
other template. Choose Filer>New on the
menu bar instead.

3. Select the On My Computer link under the
Templates section of the New Workbook
task pane.

The Templates dialog box opens.
4., Double-click the name of the template you want

to use, or click its name and then click OK.

Excel opens up a new blank workbook from the tem-
plate file, using all the custom display settings that
you saved as part of it.
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Save Time By

v+~ Displaying full toolbars
and menus

v~ Customizing toolbars and
menus

v~ Creating your own menus

v Adding macros and links
to toolbars and menus

down menus. Taking the time to get the Excel toolbars (especially

the Standard and Formatting toolbars that Excel automatically
displays whenever you launch the program) and the pull-down menus
the way you want them saves you valuable time when creating and edit-
ing your spreadsheets. (Just think about how many times you access
their buttons and menu items in a single work session, and you’ll under-
stand why.)

This technique centers on customizing the Excel toolbars and pull-

Excel makes it easy to customize the position, behavior, and even content
of its many toolbars and pull-down menus. This customization includes
placing the Standard and Formatting toolbars on two separate rows,
always displaying full pull-down menus, and customizing the buttons
and command options found on the built-in bars and menus as well as
those found on the bars and menus you build on your own.

Showing the Toolbars and Menus
in All Their Glory

Excel tries to save valuable screen space by automatically placing the
Standard and Formatting toolbars on the same row at the top of the
screen. This is fine except for when you’re using one a smaller monitor
in a relatively low screen resolution (such as 800 x 600 or 1024 x 768)
where it’s impossible to have all the buttons on either toolbar display
at the same time and where you're often forced to waste time in clicking
the Toolbar Options button to have access to options that are currently
hidden.
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To ensure that all the buttons on both the Standard
and Formatting toolbars are always displayed, follow
these steps:

1. Choose View=>Toolbars->Customize to open the
Customize dialog box.

2. Select the Options tab in the Customize dialog
box, as shown in Figure 2-1.

3. Select the Show Standard and Formatting
Toolbars on Two Rows check box and then
click the Close button.

Customize 2

Toolbars | Commands

Perzonalized Manus and Toolbats
Show Standard and Farmatting toolbars on bwo rows
[ alhways show Full menus

Shiow Full menus after a shork delay

I Reset menu and toolbar usage data

Other
|:| Large icons
List Fonk names in their Font
Show ScreenTips on toolbars

Meny animations: | {3ystern default) |

Close E

* Figure 2-1: Forcing Excel to display the Standard and
Formatting toolbars on two rows.

To get Excel to display all of a menu’s options
the moment you open it, select the Always
Show Full Menus check box on the Options
tab of the Customize dialog box. This stops
the program from shortchanging you on how
many options you see when you first open a
particular menu. (Menus don’t show all their
options until the menus are open for several
moments — moments that often seem like a
lifetime.)

Toolbars and Menus
Made to Order

When the software engineers at Microsoft put
together the Excel toolbars and menus, they tried
to select the buttons and options that most users
need most of the time. Of course, you may very well
not be “most users” when it comes to using Excel
and wish that they had included command options
that currently aren’t there and left out others that
you rarely use.

The good news is that you can easily make the pro-
gram more efficient by customizing any of the existing
toolbars and pull-down menus so that they consist of
just the options you use in the order in which you’d
like to see them.

To customize a built-in Excel toolbar, you follow
these steps:

1. Choose Viewr>Toolbars->Customize to open
the Customize dialog box.

2. [If the toolbar you want to customize is not
already displayed on the screen, select the
Toolbars tab in the Customize dialog box
and then select that toolbar’s check box.

3. To add a new button to the toolbar now
displayed, select the Commands tab in the
Customize dialog box and then select the
desired command category in the Categories
list box. Scroll to the command’s icon in the
Commands list box and then drag the icon
from the Customize dialog box to its new
place on the toolbar.

You can release the mouse button as soon as
the box with the + (plus) appears on the mouse
pointer. Excel indicates where the new button
will be inserted on the toolbar by displaying
the bold I-beam-type indicator on the toolbar.



4. To delete a button from the toolbar, drag its
button from the toolbar, and then when the
box with the X in it appears at the mouse
pointer, release the mouse button.

5. To rearrange the buttons on the toolbar, drag
the button icon to its new position on the bar
(indicated by the bold I-beam-type indicator).

6. To add a vertical separator bar that groups the
buttons, locate the button in front of which the
separator will be inserted and then drag that
button slightly to the right. As soon as you
release the mouse button, the separator bar
appears.

To remove a vertical separator, drag the button
that the separator is directly in front of to the
left until the bar disappears.

7. After you finish customizing the toolbar, click
the Close button to close the dialog box and
return the functionality to the toolbars and
menus.

The steps for customizing one of Excel’s pull-down
menus are the same as those for customizing a tool-
bar, except that after opening the Customize dialog
box and selecting the Commands tab, you must
choose the name of the menu you want to customize.
The steps for adding commands, deleting menu items,
and rearranging them on a particular menu are the
same as those for doing these things to a toolbar:
just keep in mind that the bold, I-beam-type indica-
tor shows you where the command you add will be
inserted on the pull-down menu.

B Commands dialog box (see Figure 2-2) to
quickly add, delete, or modify the order of
the buttons on any Excel toolbar or items on
any of its pull-down menus. To open this dia-
log box, click the Rearrange Commands but-
ton on the Commands tab of the Customize

dialog box.

2 You can use the controls in the Rearrange
E)

&
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¢ Figure 2-2: The Rearrange Commands dialog box makes

it easy to add, delete, or reorder the options
on Excel toolbars and menus.

To customize a menu or toolbar in the Rearrange
Commands dialog box, follow these steps:

1.

If you’re customizing a pull-down menu, click
the Menu Bar option button and then select the
pull-down menu name in its drop-down list
box. If you’re customizing a toolbar, click the
Toolbar option button and then select the tool-
bar name in its drop-down list box.

Excel displays all the menu items or toolbar
buttons for the menu or toolbar you selected
in their current order.

To add an item or button, click the menu item
or button in front of which you want to insert
the new button and then click the Add button.
In the Add Command dialog box that appears,
select the option you want added and click OK.

To delete an item or button, select it in the
Rearrange Commands dialog box and then
click the Delete button.
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4., To modify the position of an item or button,
select it in the Rearrange Commands dialog
box and then click the Move Up or Move Down
button until the item or button appears in
the desired position.

5. After you finish customizing your menu or tool-
bar, click the Close button in the Rearrange
Commands dialog box and then click the Close
button in the Customize dialog box.

A Toolbar and Menu
of Your Own

Sometimes it makes more sense to create your own
toolbar or pull-down menu rather than fool around
customizing the ones that come with Excel. By build-
ing your own custom toolbar or menu, you can bring
together just the commands that you normally rely
on. For example, you can concoct a Calculation tool-
bar or pull-down menu that contains only the options
that you frequently use in building your spreadsheet
formulas.

To create a custom toolbar, follow these steps:

1. Choose Viewr>Toolbars->Customize to open the
Customize dialog box.

2. Click the Toolbars tab and then click the New
button to open the New Toolbar dialog box,
shown in Figure 2-3.

New Toolbar

Toolbar name:

Cuskom 1

Ok ][ Canicel ]

* Figure 2-3: You name your new custom toolbar in the
New Toolbar dialog box.

3. Enter your name for the custom toolbar in the
Toolbar Name text box and then click OK.

Excel adds the custom toolbar’s name to the
Toolbars list box in the Customize dialog box
and displays a blank floating toolbar that shows
only the first few letters of its name.

4. To add a tool to the new toolbar, select the
Commands tab in the Customize dialog box,
click the desired command category in the
Categories list box, scroll to the command’s
icon in the Commands list box, and then drag
the command’s icon from the Customize dia-
log box to the new toolbar.

Excel automatically expands the toolbar to
accommodate the buttons you add.

5. Repeat Step 4 until you have added all the tools
you want to appear on your new toolbar.

6. If you want to group the buttons on the new
toolbar, locate the buttons in front of which
you want the separators to appear and then
drag the buttons slightly to the right.

You can also reposition the buttons you add
to a new toolbar simply by dragging them to
their places.

7. When you have the new toolbar exactly the way
you want it, click the Close button to close the
Customize dialog box.

After creating a custom toolbar, be sure to test out its
buttons by clicking them at the appropriate moments
in building or editing your spreadsheet (not all Excel
commands can be executed on a blank worksheet).

The process for creating a custom menu is the same
as for a toolbar except that to start the custom menu,
you select the New Menu item at the bottom of the
Commands tab of the Customize dialog box. Then
you drag this New Menu item from the Customize
dialog box to the place where you want it to appear
on the Excel menu bar. To rename the menu to some-
thing besides New Menu, right-click New Menu on the
Excel menu bar and choose Name from the shortcut
menu. Then replace New Menu with the new name
you've chosen.
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If you want to assign a hot key to the name When you select the Macros category, the

you give your hew custom menu, type an Commands list box gives you a choice between
ampersand (&) immediately in front of the a Custom Menu Item and a Custom Button.

letter in the menu name. (Just make sure that

it isn't already assigned to one of the other Customize e

items on the same menu.)

Toolbars Optians |

To add an item to your new menu, drag the com- To add a command to a toolbar: select a category and drag the
mand from the Customize dialog box to the tab carmarl nUE of b dialogibox to toalbor

Cakeqgaries: Comrnangs:
under the menu. (Don’t release the mouse button it
. s | Window and Help i Custam Menu Itkem
until the bold, I-beam-type indicator appears on the Drawing
tab and the box with the plus sign (+) appears next gﬁtafg:gpes - CEEEE N |
to the mouse pointer.) Removing and repositioning Web
items on your custom menu is no different from mak- EELT::.I i
ing these types of modifications to a standard pull- |Macras
Built-in Menus
wn menu.
do ent ey Meri 2

Rearrange Commands. ..

Adding Macros and Links
to Toolbars and Menus

Built-in commands are not the only things you can

add to the toolbars and pull-down menus you cus- * Figure 2-4: The Macros category contains two choices:
tomize or create from scratch. You can also add Custom Menu Iltem and Custom Button.
macros you've recorded and hyperlinks to particular

documents, folders, and even favorite Web sites. To 4. Drag the Custom Button (with the Happy Face
do this, you attach the macro or link to a custom icon) and drop it into position on the toolbar
button that you add to a toolbar or to a custom from which you want to be able to run the
menu item that you add to a pull-down menu. macro or select the hyperlink.

5. Right-click the Custom Button you just added
to the toolbar and then click either the Assign
Hyperlink=>Open item (to attach a hyperlink to
it) or the Assign Macro item (to attach a macro

1. Choose View=>Toolbars-=>Customize to open the to if) on the shortcut menu, shown in Figure 2-5.
Customize dialog box.

To attach a macro or hyperlink to a custom button
that you add to a toolbar, follow these steps:

If you choose Assign Hyperlink=>Open, Excel

2. [Ifthe toolbar to which you want to add the opens the standard Assign Hyperlink dialog box
custom button is not already open, select the where you can select an existing file or Web page
Toolbars tab and then select the toolbar’s or e-mail address to link to. If you choose Assign
check box to display it in the Excel screen. Macro, the program opens the Assign Macro dia-

3. Select the Commands tab and then select log box where you can select the macro to run

Macros near the bottom of the Categories list when the button is clicked.

box, as shown in Figure 2-4.
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6. Select the link to the hyperlink’s destination in
the Assign Hyperlink dialog box or the macro
to run in the Assign Macro dialog box; then
click OK.

Reset

Delete

Name: &Custom Button

Copy Button Image
Paste Button Image
Reset Button Image
Edit Button Image...
Change Button Image »

Default Style

Text Only {Always)
Text Only {in Menus)
Image and Text

Begin a Group

Assign Hyperlink 3
Assign Macro...

* Figure 2-5: Select the Assign Hyperlink or Assign Macro
item to attach a link or macro to the new
button.

7. To select a new icon for the button, right-click
the custom button and choose Change Button
Image. From the icon pop-up palette that
appears, choose the new icon you want to use.

You can use the Button Editor — which you
can open by selecting Edit Button Image on
the button’s shortcut menu — to modify the
icon that you choose on the Change Button
Image’s icon palette. This editor lets you make
pixel-by-pixel changes to the image, either by
erasing pixels or by painting with new colors.

8. Click the Close button in the Customize dia-
log box.

The process for assigning a hyperlink or macro to a
menu item is almost the same, except that you select
Custom Menu Item in the Macros category on the
Commands tab of the Customize dialog box. Then
you drag this Custom Menu Item to the place on the
pull-down menu where you want it to appear. Next,
you assign either a hyperlink or macro to it by right-
clicking the Custom Menu Item on its pull-down
menu and then choosing either Assign Hyperlink=>
Open or Assign Macro on its shortcut menu.

After assigning the link or macro, you will want to
rename the menu item. To do this, right-click Custom
Menu Item on its pull-down menu and then click the
Name option and replace Custom Menu Item with a
name of your own. If you want to assign a hotkey to
one of the characters in the new name, be sure to
type an ampersand (&) immediately in front of the
character in the custom menu name that you want
to so designate.
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Save Time By

v~ Creating a workspace
with all the spreadsheets
you're working on

v+~ Opening the workspace
when Excel launches

is really just a special file that keeps a record of all the workbooks

open at the time you save the workspace, as well as all the work-
books’ screen attributes — things like window sizes and arrangement,
screen magnification, and any other display settings in use at the time.
(See Technique 1 for details.) Workspaces are real timesavers because
they enable you to immediately resume work the next day on whatever
workbooks you had open the day before. All you have to do is open the
workspace file, and Excel does all the heavy lifting: opening the individ-
ual workbooks and arranging their windows and setting up the screen
attributes so they’re in the same condition you left them in.

ﬁ n Excel workspace (sometimes known as an arranged workspace)

When you’re involved with a particularly complex spreadsheet project
that requires you to work with the same workbook files over the course
of several work sessions, you can save even more time by having Excel
automatically open the workspace file when you launch the program.
That way, you have all the spreadsheets open and arranged so that
you're ready to go the moment you start working with Excel.

Saving Your Workspace

Creating a workspace is literally as simple as choosing Filew>

Save Workspace, naming the workspace file, and selecting a place

in which to save the new workspace file (which is automatically
given the filename extension .x1w) in the Save Workspace dialog
box, shown in Figure 3-1. The hard part is actually opening the work-
books you want to work with in the workspace and arranging their
windows and display settings the way you want them prior to saving
this workspace file. But then, this is the stuff that you have to do
anyway to be able to work with more than one Excel workbook

at a time.
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Save Workspace 28
Q@ ¥ Cu B tools -

Save in: (L) My Documents CARE

L) 7464-7 Win¥pse2
e |[)574272 ExcelTST
My Recent | |Z)My eBooks
Documents )My Tcons
= LMy Library
Lj ﬂMy’ Music
Desktop 124y Pictures
My Received Files

2,
£

LMy Videos
%resume‘ 2l
My Documnents

8
Py Computer
o)
My Metwark
Places Save asbYPe! | workspaces (*.xdw) &

File pame: resume. < ¥ Save

Cancel

¢ Figure 3-1: Saving the information about the current
work environment in a new workspace file.

To re-create the workspace environment, all you
have to do is open the workspace file. When looking
for the workspace file in the Open dialog box (Filew>
Open), remember that workspace files use the . x1w
(for Excel workspace) file extension rather than the
normal .x1s filename extension.

To have the workspace in your next Excel
work session exactly the way you left it at the
close of business, don’t save the workspace file

until after you have saved all your changes to
the open Excel workbooks and are ready to
exit Excel.

g

7 If you've already created the workspace file in
(ﬂ a previous work session and want to save any

display changes to it under the same filename,
choose Filer>Save Workspace and then click
Save in the Save Workspace dialog box. When
Excel displays an alert dialog box warning you
that you're about to replace the existing file,
just click Yes to save your changes to the same
workspace file.

Opening a Workspace Whenever
Excel Launches

When you know that you'’ll be using a particular
workspace for some time in your Excel work, you
can speed up the process of setting up your work
environment by having Excel automatically open
the workspace file when you launch the program.
The process for doing this is twofold: You need to
designate a folder on your computer as the alter-
nate startup folder, and then you have to save the
workspace file in that folder.

Any Excel file that you save in the XLSTART
folder provided by Microsoft (and saved in the
C:\Program Files\Microsoft O0ffice\0fficell
folder when you’re using Excel 2003) automati-
cally opens when you launch the program.

Excel enables you to designate an alternate
folder (which you must create with Windows
Explorer) for automatic startup. | recommend
saving the workspace file you want automati-
cally opened in the alternate startup folder
that you specify because no matter where you
put this folder it just has to be easier to find
than Microsoft’s XLSTART folder!

To designate a folder (which you’ve already created
on your system with Windows Explorer) as the alter-
nate startup folder, follow these few steps:

1. Choose Tools=>Options and then select the
General tab in the Options dialog box.

2. Select the At Startup, Open All Files In text box
and then enter the path to the folder where
you’re going to save your workspace file.



Opening a Workspace Whenever Excel Launches 2 ’

Unfortunately, Excel doesn’t provide a Browse
button here that enables you to locate this folder
visually, so you have to tough it out and type the
folder’s pathname in this text box. Remember
that the pathname consists of the drive letter
followed by a colon and the names of all the
subfolders separated by backslashes, as in
C:\XL A1t Start shown in Figure 3-2.

3. Click OK to close the Options dialog box.

Options @
Color International Save Errar Checking Spelling Security
Wi Calculation Edit General Transition Custom Lists Chart

Settings

[ prompt for workbook properties
[ Provide Feedback with sound

[ zoam an rall with InteliMause

[CIR1CI reference style
[ 1gnore other applications
Function toaltips

Recently used File list: |4 %1 entries
[ ‘Wb Options... ] [ Service Options...
Sheets in new workbook: |5 A
£l
Standard Font: Arial v| Sie: (10 v

Default file location: Ci\Documents and Settings\GregiMy Documents

At starkup, open all files in: il Alk Start

User name: Greg Harvey

{ ]34 %J [ Cancel ]

¢ Figure 3-2: Designating the alternate startup folder in the
Options dialog box.

After you designate your alternate startup folder,
follow these steps to save the workspace file that
you want Excel to automatically open on startup:

1. Choose File>Save Workspace to open the Save
Workspace dialog box.

2. From the Save In drop-down list box, select the
folder you designated as the alternate startup
folder, as shown in Figure 3-3.

Save Workspace &
¥ @ -3 X CyE Tk -

Save i 1 ¥L Alk start
A
£

My Recent
Dacuments

Deskkop

My Documents

8
My Computer
;Ll File niame: resume. b Save
My Netwark. = 4
Places Save as bype: | workspaces (*.xh) |

* Figure 3-3: Saving the workspace file in the alternate
startup folder in the Save Workspace
dialog box.

3. Click Save to close the Save Workspace dialog
box.

After you save the workspace file in your Excel alter-
nate startup folder, each time you start Excel the
program opens the file and uses its information to
load your workbook files, arrange their windows,
and invoke their display settings.

When you finish your work with the workbooks
opened in the workspace and no longer want to
see them every time you launch Excel, you need
to move the workspace file out of the alternate
startup folder into another folder on your hard
disk, or, if you're really sure that you have no need
for the workspace, you can delete it by moving it
into the Windows Recycle Bin.
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v Changing the default file
location

v~ Saving each new file with
summary information

v Changing the
AutoRecover settings

file only to discover later that you haven’t the foggiest idea where

on your great big humongous hard disk you saved it. Excel tries
to guard against this type of aggravation by automatically saving every
new workbook in the My Documents folder. Many times, however, saving
all the different types of workbooks you create in the same generic My
Documents folder on your local disk just isn’t practical. This is especially
true in a network environment where spreadsheets are not normally
saved locally.

Nothing is as frustrating as knowing that you’ve saved a workbook

This technique concentrates on ways you can minimize the annoyance
of not knowing where you saved a new workbook file. These include
changing the default folder from the generic My Documents to a more
specific folder and setting up the Save command so that you're auto-
matically prompted to fill in summary information on the new workbook
file. Although the latter procedure does not itself guard against saving a
new workbook in the wrong folder, it does help you more quickly and
easily find the file if you forget where you saved it.

The final procedure in this technique covers the use of the AutoRecover
feature to guard against losing unsaved data if Excel becomes unrespon-
sive and needs to be shut down or your computer experiences a sudden
shutdown that prevents you from manually saving your edits. By setting
AutoRecover to a comfortable interval, you can be assured of losing as
few worksheet edits as possible in such an event. You can also set the
folder location where Excel saves your recovered workbook.



Modifying the Default
File Location

If your Excel work habits are anything like mine,
you tend to find yourself at certain times having

to build several workbooks of the same type (time
cards, financial statements, expense reports, and
so on) that all need to be saved in the same folder.
For those times, you can streamline this process
and guard against saving the new workbook in the
wrong location by changing the default file location.
That way, when you first save the workbook, you
don’t have to bother with changing the folder, and
you don’t have to worry about saving the workbook
in an unintended place.

To change the default file folder location to a folder
that you've already created with Windows Explorer,
follow these steps:

1. Choose Tool=>Options to open the Options dia-
log box.

2. Select the General tab in the Options folder.

3. In the Default File Location text box, enter the
pathname to the folder you want as the default,
as shown in Figure 4-1.

This assumes that you've planned ahead and
already used Windows Explorer to create such
a folder.

The pathname consists of the drive letter
followed by a colon and the names of all
subfolders separated by backslashes, as in

C:\Accounting\Expenses.

4. Click OK to close the Options dialog box.

After changing the default file location in the Options
dialog box, the next time you open the Save As dialog
box (shown in Figure 4-2) to save a new workbook
(by choosing Filem>Save, clicking the Save button on
the Standard toolbar, or pressing Ctrl+S), the name

Modifying the Default File Location 2 3

of the folder at the end of the new pathname appears
in the Save In drop-down list box. (If you want to
check that the path to this folder is correct, select
the Save In drop-down list to display it.) Then all
you have to do to complete the save operation is

to edit the temporary filename and click Save.

Options 2]
Color International Save Error Checking Speliing Security
Wiew Calculation Edit General Transition Cushom Lists Chart
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Default file location: CihAccounting|\Expenses
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User name: Greg Harvey
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* Figure 4-1: To change where Excel automatically saves its
files, enter the pathname in the Default File
Location text box.
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* Figure 4-2: After designating a new default file location,
Excel automatically selects that folder for all
new files you save.
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Don't forget to change the Default File Location
@ on the General tab of the Options dialog box
when you finish creating all the files that should

be saved in that location. Otherwise, you'll end
up saving files that don’t belong there, defeat-
ing the purpose of modifying this location in
the first place.

Saving New Files with
Summary Information

Even if you never mess up and save a new workbook
in the wrong folder, you might as well admit that even-
tually you'll end up forgetting where you intentionally
put some of them. This next procedure can go a long
way in helping you quickly find and open any work-
book that you've temporarily misplaced, regardless
of the reason.

Microsoft programs such as Word and Excel 2003
enable you to save summary information on every
document you create as part of the document’s file
properties (see Figure 4-3). (You can display the prop-
erties by choosing Filec>Properties.) This summary
information can include data such as the document’s
title, subject, author, company, category, keywords,
and comments. The great thing about this summary
information is that it’s searchable from the Excel File
Search task pane (Filec>File Search), so you can use
whatever summary data you know about a lost work-
book to find and open it. (See Technique 31 for
details.)

The bad thing is that Excel doesn’t automatically
prompt you to enter this summary information
when you first save the file, so more likely than not,
you don’t end up entering the facts and keywords
that may some day prove vital to your being able
to locate and reopen the file. Fortunately, you can
change this situation so that Excel automatically
displays the Properties dialog box and selects its
Summary tab every time you save a new workbook
file. (This dialog box appears after you designate the
folder and filename and click the Save button in the
Save As dialog box.)

[ Sy
Excel TST page count.zls Properties
meneral | Summary | Statistics | Contents | Custom
Title:
Subject: Page Count
Author: Greq Harvey
Managet:
Company: | Mind Ower Media, Inc,
Category: Dummies Books
Keywords: | Time Saving Technigues
Cormments:
Hyperlink,
base:
|:| Save preview picture
Ok N l Cancel

¢ Figure 4-3: You can use the data entered on the
Summary tab of the File Properties dialog
box in searching for misplaced workbooks.

To get this going, you follow these simple steps:

1. Choose Tools->Options to open the Option dia-
log box.

2. Select the General tab and then select the
Prompt for Workbook Properties check box, as
shown in Figure 4-4.

3. Click OK to close the Options dialog box.

When entering summary data for new work-
books, get in the habit of assigning standard
general data to the Subject or Category fields
(such as Invoice or Expense Report) along with
information specific to the spreadsheet in the
Title and Keywords fields. That way, you can
narrow down the field to files of a certain type
even if you don't have specifics on the file.
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* Figure 4-4: Setting up Excel to automatically display the
Summary tab of the Options dialog box when
you first save a file.

Changing the AutoRecover
Settings

The AutoRecover feature is turned on when you
install Excel so that every ten minutes the program
automatically saves any editing changes made since
the workbook was last saved. The program saves all
the edits you've made since the last AutoRecover
save in a special document-recovery backup file
located in the folder designated as the AutoRecover
save location. Then if your computer experiences
some sort of power failure or Excel unexpectedly
goes comatose on you (a very rare occurrence but
not completely unheard of) before you can save the
workbook yourself, you can open this recovery
backup file and use it instead of the original file.

AutoRecover doesn’t operate on a new work-
book that you've never manually saved with
File>Save, so be sure to save your new work-

book before you enter a bunch of formulas
and data in it, or you could end up losing
it all.

Changing the AutoRecover Settings 2 5

If you're not comfortable with the ten-minute
AutoRecover save interval, you can shorten or
lengthen it. For some users, this interval is too long
because they would never want to have to reenter
ten minutes worth of data. For others, it’s too short
because it seems like Excel’s always interrupting
their work by saving their data changes. To modify
the AutoRecover settings, follow these steps:

1. Choose Tools>Options to open the Options dia-
log box.

2. Select the Save tab to display the AutoRecover
settings for the program, as shown in Figure 4-5.

Options B[]
Wiew Calculation Edit General Transition Custam Lists Chart
Color International |i Error Checking Spelling Security

Settings
Save AutoRecover info every: 10 - minutes

AutoRecover save location: Ci\Documents and Settings\Greglspplication DatalM

Warkbook options
[[] Disable AuoRecover

OK Cancel

* Figure 4-5: Access the Save tab of the Options dialog
box to modify the program’s AutoRecover
settings.

3. To modify the AutoRecover save interval, enter
the new time value (between 1 and 120) in the
Minutes text box or use the spinner buttons to
select it.

4. To select a new folder into which to save recov-
ery backup files, select the AutoRecover Save
Location text box and then enter the pathname
for this new folder.

Normally, you don’t have to worry about this
folder location because the Document Recovery
task pane (discussed later in this section) finds
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the backup file for you and enables you to com-
pare the recovered file to the original and, if you
so desire, replace the original with the recovered
version.

5. Click OK to close the Options dialog box and
put your new settings into effect.

Select the Disable AutoRecover check box on
the Save tab of the Options dialog box at your
own peril. In disabling this feature, you run the
risk of losing all your data should you have a
software or hardware mishap before you take

the time to manually save the file.

If your software freezes up or your computer
crashes when the AutoRecover feature is enabled
and in use during a work session, the next time you
launch Excel, the program displays the Document
Recovery task pane. This pane identifies both the

original and recovered versions of the workbook file.

You can open the recovered version (by clicking its
button and then selecting Open on its pop-up menu)

to see how much of the data was recovered. If you
decide that you want to retain the recovered version
of the file and replace the original version, choose
Filec>Save and choose Yes in the alert dialog box
that warns you that you’re about to replace the
existing file.

If you know that you want to replace the origi-
nal with the recovered version, you don’t have
to bother with opening the recovered file. Just
click the drop-down button for the file marked
[Recovered] and select Save As on the pop-up
menu. If you don’t want to replace the original,
be sure to enter a new filename in the Save As
dialog box.

In the odd event that you want to discard the recov-
ered version and retain only the original (and pre-
sumably less complete) version of the file, simply
click the Close button in Document Recovery task
pane and then select the No (Remove These Files. |
Have Saved the Files I Need) option button in the
alert dialog box that appears.
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Tailoring Excel’s
Error Checking
to Vour Needs

that formula errors, the bane of all spreadsheets, are inevitable.

Whenever Excel cannot successfully calculate one of your formu-
las according to its internal rules, the program returns an error value to
its cell, indicated by the error name in all caps punctuated by a number
sign at the beginning (#) and an exclamation point (!) or question mark
(7 at the end, as in #VALUE!, #NAME?, and #DIV/0!, to name but a few.

ﬁ nyone with any experience building Excel worksheets knows

Not only are these error values ugly as sin, but they also tend to propa-
gate themselves all over the worksheet, spreading to all formulas that
refer to the cells that contain them. (See Techniques 31 and 32 for tips
on how to stop error values from spreading all over the place and elimi-
nate them from the worksheet.)

In an attempt to help you identify what in the blazes has caused your
formula to go haywire and return an error value rather than the result
you wanted, Excel now adds error indicators to cells. These indicators
appear as tiny green triangles in the upper-left corner of the cells con-
taining the error values, as shown in Figure 5-1. When you position the
mouse pointer over an error indicator, a Smart Tab icon (the exclama-
tion point in a diamond) appears with a ToolTip containing an explana-
tion of the problem.

| % Micresaft Excel - Typ Formula Ermors.xis
Edit View [nsent Format Tools Data Window Help  Adabe PDF
walabl el s o =i Biw-B 4 EWE S % 80 R
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¢ Figure 5-1: Errors, errors everywhere and indicators telling you what’s wrong
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When you’re new to Excel, the ToolTips connected
to the error indicators are a godsend because they
reinforce the rules and start to make sense of those
largely inexplicable error values. As you become a
more experienced user, they lose their luster and
can become downright annoying (obscuring data
you want to see and otherwise getting in your way
as you inadvertently pass the mouse pointer over
them).

Fortunately, Excel makes it easy to control when
error indicators appear in cells containing error
values. You can also temporarily suppress the dis-
play of all error indicators in the worksheet. As part
of this technique on cleaning up the error indicators
in your worksheet, I give you tips on temporarily
suppressing the display of those unsightly error
values both on-screen and in your printouts.

Modifying the Error Checking
Settings

The Error Checking tab of the Options dialog box
(Tools=>Options), shown in Figure 5-2, contains a list
of check-box options that correspond to conditions
in which Excel adds an error indicator to a cell. Note
that in this list, only the first check box option has to
do with actual error values in the cells. All the other
options have to do with conditions that might be
problematic to the spreadsheet even though they
don’t result in blatant error values.

Here is the entire list of Error Checking options:

v Evaluates to Error Value: Adds error indicators
to cells whose formulas return error values and
includes ToolTips that try to explain the reason
for the particular error value.

v Text Date with 2 Digit Years: Adds an error indi-
cator to cells that contain two-digit dates entered
as text, as in '89 or ’76.

v Number Stored as Text: Adds an error indicator
to cells that contain numbers entered as text, as
in '1123 or '45.67.

Technique 5: Tailoring Excel’s Error Checking to Vour Needs

v Inconsistent Formula in Region: Adds an error
indicator to any cells containing formulas whose
structures don’t match the prevailing pattern in
the rest of those in a particular table.

v Formula Omits Cells in Region: Adds an error
indicator to any cells containing formulas that
don’t refer to cells within a particular table when
most of the others do.

v+ Unlocked Cells Containing Formulas: Adds an
error indicator to any unlocked cells containing
formulas (you can unlock cells by pressing Ctrl+1,
clicking the Protection tab, and deselecting the
Locked check box).

v Formulas Referring to Empty Cells: Adds an
error indicator to any cells containing formulas
referring to empty cells. (This is the only Error
Checking option not selected by default.)

v List Data Validation Error: Adds an error indica-
tor to cells that contains entries that don’t follow
the data validation condition applied to them.

Options 2%

Cuskam Lists Chart

Transition

Wit Caloulation Edit General

Caolor International Save Spelling Security
Settings
Enable background error checking

Ertor Indicator Color: | Automatic | »

Reset Ignored Errars

Rules
Ewvaluates to errar value
Text date with 2 digit vears
Mumber stored as kext
Inconsistent formula in region
Formula omits cells in region
Unlocked cells containing Formulas
[ Farmulas referring to emply cells
List data validation error

¢ Figure 5-2: The Error Checking options enable you to
modify when error indicators appear.

As you can see from the list of Error Checking
options, error indicators often don’t represent
an error per se but simply an anomaly in the
prevailing pattern. If you're not particularly



concerned about inconsistencies in your spread-
sheets, you can simply deselect their check box
options to prevent Excel from cluttering the work-
sheet with these types of indicators.

Don't disable the Evaluates to Error Value
option unless you're a real spreadsheet ace
who can immediately tell what’s causing a

formula to return an error value. You'll be
cheating yourself out of the ToolTip info
telling you what’s wrong so you can quickly
eliminate the error.

You can make the error indicators more or less
prominent in the worksheet by selecting a new
color for their triangles on the Error Indicator
Color pop-up palette.

Suppressing All Error Indicators

When you're dealing with a worksheet that for what-
ever reason is riddled with error values and their
attendant error indicators, you can get rid of the
indicators in one fell swoop by following these
simple steps:

1. Choose Tools~>Options.

2. Select the Error Checking tab in the Options
dialog box.

3. Deselect the Enable Background Error
Checking box and then click OK.

As soon as you close the Options dialog box, Excel
temporarily removes all the error indicators from
the entire worksheet. To restore them, all you have
to do is open the Error Checking tab of the Options
dialog box and then select the Enable Background
Error Checking box again.

Suppressing the display of the error indicators
@ has no effect on the display of error values in
the worksheet. To do that, you either have to

fix the problem or use one of the techniques
in the following section for hiding their display.

Hiding Ervor Ualues On-Screen and in Print 2 9

Hiding Error Values On-Screen
and in Print

Sometimes, you’ll want to suppress the display of
those nasty-looking error values in a worksheet until
you get all the data entered that you need to make
all the error values really disappear. (Error values
running throughout the worksheet can tend to make
the client a little nervous.) When it comes to sup-
pressing their display, you have a couple choices:

v You can nip them in the bud so to speak by
building formulas that suppress the display
and trap any possible errors before they
spread anywhere else in the worksheet
(see Technique 28 for details).

You use the Conditional Formatting feature
to blank them out.

Follow these steps to use the Conditional Formatting
feature:

1. Select the cell or range of cells containing the
error values you want to blank out.

2. Choose Format->Conditional Formatting.

3. Click the drop-down button in the box that
reads Cell Value Is and select Formula Is
from its pop-up menu.

4., Type =ISERROR( in the text box to the right.

5. Reselect the cell or range of cells containing
the error values you want blanked out or type
their addresses.

If you want to drag through the cells to select
this range but the Conditional Formatting dia-
log box gets in the way, minimize the dialog
box by clicking its Condense button (the one
with the tiny worksheet icon).

6. Type) to close the parentheses for the
ISERROR function.
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7. Click the Format button to open the Format
Cells dialog box.

8. On the Font tab, click the Color drop-down but-
ton and then select the white square on the
pop-up palette that appears. (The white square
is at the intersection of the very last column
and row of the upper palette.) Then click OK.

When you close the Format Cells dialog box, the
Conditional Formatting dialog box resembles the
one shown in Figure 5-3.

9. Click OK to close the Conditional Formatting
dialog box.
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* Figure 5-3: Setting up a conditional format to blank out
the display of error values in a range.

As soon as you click OK, Excel replaces all the error
values in the cell or cell range you selected with
white, effectively blanking out their error value
results without disturbing their formulas.

If all you want to do is suppress the display of error

values in a printout of the worksheet, you don’t have
to go to all that trouble of first blanking out their dis-
play by setting up a conditional format. All you have
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to do is follow these simple steps prior to sending
the worksheet to the printer:

1. Choose Filer>Page Setup to open the Page Setup
dialog box.

2. On the Sheet tab, click the Cell Errors As drop-
down button to open its drop-down list, shown
in Figure 5-4.

Page Setup 3%
Page Margins | Header_,!’Footer Shest |
Print: titles - -
Rows ko repeat at bop:
Columns to repeat at left;

Print

[ &ridlines [ raw and column headings
[ Black and white  Comments: {Mane) ™
[ Draft gualicy ; i =
Cell errors as: displayed
Page order

(%) Down, then over
() Over, then down

[ Ok ]l Cancel ]

¢ Figure 5-4: Replacing the error values in the printout of
a worksheet with blanks, N/A, or dashes.

3. From the drop-down list, select <blank>, -
(dashes), or #N/A (the Not Available value)
to replace the default value displayed in
the Cell Errors As box.

4., Click OK to close the Page Setup dialog box
or click Print if you’re ready to print your
worksheet.

Click the Print Preview button rather than the
Print button if you want to make sure that all
the error values are really gone from the print-
out before you send the job to the printer.



Utilizing Excel’s
Editing Settings

Technique

Save Time By

~ Selecting new cell
pointer directions

+* Dumping AutoComplete
v~ Using cell drag-and-drop
v~ Direct editing in cells

(shown in Figure 6-1), offer a wide array of editing options, most of

which are selected by default and seldom, if ever, need changing.
Therefore, instead of focusing solely on how to change these options to
suit your work habits, this technique also covers how to more efficiently
use of a few them when modifying your spreadsheets.

Excel’s Edit settings, found on the Edit tab of the Options dialog box

This technique begins by covering how and when to change the direction
in which the cell pointer moves when you press Enter and then gives you
the lowdown on why you might want to disable the AutoComplete fea-
ture. You then discover how to efficiently use Excel’s drag-and-drop edit-
ing (and when it’s best to stick with the old cut-and-paste standby). The
technique concludes by giving you pointers on when to edit a cell’s con-
tents directly in the cell and when to rely on the old tried-and-true cell
editing on the Excel Formula bar.

Options ]|
Calar Inkernation Save Errar Checking Spelling Security
View Caloulation | General Transition Custom Lists Chart

Settings
Edit directly in cel Extend data range formats and formulas
Allow cell drag and drop Enable automatic percent entry
Alert before averwriting cells Show Paste Options buttons
Maove selection after Enter Show Insert Options buttons
Direction: Down |+
[ Fixed decimal

Places:

Cut, copy, and sork objects with cells
Ask to update automatic links
Provide feedback with Animation
Enable AutoComplete For cell values

¢ Figure 6-1: The Edit settings offer a wide array of editing options that seldom
need changing.
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Putting the Cell Pointer
in the Right Direction

As you’re probably well aware, Excel attempts to
make the drudgery of data entry in the worksheet’s
cells as efficient as possible by setting it up so that
the program automatically moves the cell pointer
down one cell in the same column when you finish
what you're doing and press Enter. (Of course, you
can always click the Enter button on the Formula
bar to complete an entry or edit rather than press
the Enter key.)

What you may not be aware of is that you can easily
alter the behavior of the Enter key so that it moves
the cell pointer in another direction or doesn’t move
the cell pointer at all. To change the direction that the
cell pointer moves when you press Enter, open the
Edit tab of the Options dialog box and select any of
the following options in the Direction drop-down list
box to replace the default Down option:

v Right to move the cell pointer to the cell in the
next column to the right in the same row

v Up to move the cell pointer to the cell in the row
immediately above in the same column

v Left to move the cell pointer to the cell in the
previous column to the left in the same row

To prevent Excel from moving the cell pointer out
of the current cell when you press Enter, deselect
the Move Selection After Enter check box on the
Edit tab.

The best reason for changing the direction that the
cell pointer moves upon pressing Enter is when you
find yourself editing a data list or table of spread-
sheet data in that particular direction. Here are a
few examples:

v Ifyou find that you’re editing the entries across
the rows of a table from left to right (the direc-
tion we read), you would select Right as the
Direction option.

v If you're doing the editing across the rows of a
table from right to left (a direction I tend to favor
due to my left-handiness), you would select Left
as the Direction option.

v If you were editing the columns of an Excel data
list (also known by the misnomer, database) from
the last record (at times, the most recent record)
at the bottom upwards towards the first record,
it would make perfect sense for you to select Up
as the Direction option.

The only reason I ever disable the Move Selection
After Enter check box is to keep the cell pointer sta-
tionary is when I need to enter master formulas in
blank cells that I intend to copy down the column
or across the row with the AutoFill feature. In that
situation, [ don’t want Excel to move the cell pointer
off of the master formula when I press Enter to com-
plete its entry, and I also don’t want to interrupt the
entry sequence by having to click the Enter button
on the Formula bar.

Completely Turned Off
to AutoComplete

I'm sure that the Microsoft engineers who invented
the AutoComplete feature for the Office suite of pro-
grams must have thought they had come up with the
slickest thing since sliced bread. However, I find this
feature particularly noxious when entering spread-
sheet data because | seldom need to enter the same
entry several times in the same column or row of

a table. (And if [ do run into this situation, I have
enough sense to use the AutoFill feature to copy the
repeated entry down the column or across the row.)

As aresult, I find it much better for my health
(especially my blood pressure) to disable the
Enable AutoComplete for Cell Values option imme-
diately after installing Excel. Therefore, I suggest
that you live a little longer as well and stop reading
this book long enough to disable this editing option
on your copy of Excel as well. (It’s easy to do: Just
deselect its check box on the Edit tab of the Options
dialog box.)



Doing the Drag-and-Drop Thing

Drag-and-drop editing in the worksheet is great

as long as you never disable the Alert before
Overwriting Cells option — which appears imme-
diately beneath the Allow Cell Drag and Drop option
on the Edit tab of the Options dialog box. Otherwise,
you can too easily obliterate parts of your spread-
sheet by replacing data you don’t want disturbed
with the data you’re moving. At least when the Alert
before Overwriting Cells option is enabled, you get
a warning that you’re about to mess up and replace
data that you might need. Of course, if you do mess
up and end up replacing entries with the data you're
moving or copying (see the warning on copying with
drag-and-drop that follows), you can always puts
things back to right by using the Undo feature
(Ctrl+Z).

When you hold down the Ctrl key to copy
(rather than move) the cell selection with drag-
and-drop, Excel doesn’t display the Replace

Contents alert box — the one that still gives
you the chance to abort the procedure even
after you release the mouse button.

Please make room for me

Drag-and-drop spreadsheet editing is most effective
when you not only need to move or copy a range

of cells to a new (blank) place in the worksheet but
also want to insert the cells into an existing table

of data. To do this kind of insert moving or copying,
you must hold down the Shift key as you drag the
cell selection to its new position. Excel indicates
where the selected data will be inserted at the time
you drop it by displaying an I-beam-type indicator
in front of the mouse pointer:

v When the [-beam pointer runs horizontally
between rows, you know that the selection
will be inserted as a new row in the existing
table of data.

v When it runs vertically between columns, you
know that the selection will be inserted as new
column in the table.
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Figures 6-2 and 6-3 illustrate this kind of insertion
when moving a cell range with drag-and-drop. In
Figure 6-2, | selected the cell range A12:R12 (note
that many columns are hidden) in preparation for
moving it up a row so that it comes in between the
Rock and Jazz rows without overwriting any existing
data. This figure shows the heavy insertion I-beam
indicating where the selected range will be inserted
when [ release the mouse button.
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¢ Figure 6-2: Getting ready to move data in between
existing rows of a table.

Figure 6-3 shows the worksheet after releasing the
mouse button. As you can see, Excel inserts the
selected range into row 11 while at the same time
moving the Jazz cassette sales data down to row 12.

When drag-and-drop flops

Drag-and-drop provides a simple, easy, and, above
all, direct way of editing the contents of a worksheet.
It does, however, have a big limitation: It’s only good
when you have direct screen access to both the
source range and destination range. This doesn’t
mean that you have to be able to see both ranges at
the same time on the screen (although that’s always
nice). It does mean that you have to be able to go
between the two ranges — either by scrolling to
them on the same worksheet or by moving between
two windows that you've created on the screen.
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¢ Figure 6-3: The worksheet after moving the selected data
in the table.

For example, you can’t use drag-and-drop to move or
copy a range of cells from one worksheet to another
in the same workbook unless you’ve taken the time
to set up separate windows for the sheets before-
hand. And unless you have other reasons for setting
up the windows, using drag-and-drop to make the
move or copy just wastes valuable time.

In such a case, using the standard cut-and-paste
method to make the move or copy is much more
efficient. After cutting or copying the cell selection
to the Clipboard (Ctrl+X or Ctrl+C, respectively),
click the new sheet and select the first cell in the
range in which you want the data moved or copied,
and then press Enter to complete the procedure.
(You can also press Ctrl+V to do this.)

Doing Direct Cell Editing

Direct cell editing offers you an alternative to editing
the data or formula you've entered into a cell on the
Formula bar above the sheet’s work area. To directly
edit the contents of a cell, you double-click the cell —
or press F2 — to place the Insertion point in its con-
tents, and then you edit its characters as you would
on the Formula bar (or in a Word document). When
you finish modifying the cell’s contents, you complete

Technique 6: Utilizing Excel’s Editing Settings

the edit by pressing the Enter key or by clicking the
Enter button on the Formula bar (the button with
the green check mark). To bail on the edit and
restore the original contents, press Esc.

Pressing F2 to direct edit always positions
the Insertion point at the very end of the cell
entry. When you double-click the cell, Excel
places the Insertion point as close as possible
to the position of the white cross in that cell.

The question inevitably arises as to when it’s more
efficient to edit a cell entry directly versus editing it
on the Formula bar. For me, this decision depends
upon the length of the cell entry and its position in
the spreadsheet. When dealing with really long and
complex formulas in a cell (like the one shown in
Figure 6-4), editing them directly in the cell can end
up obscuring the cells in the surrounding region to
the right and below the cell, which is okay unless
you need to refer to these cells in your edit. In such
a case, you would find it much more beneficial to
edit the cell’s formula on the Formula bar. This leaves
most of the worksheet unconcealed except at the
very top where the multiple lines for the Formula
bar obscure the column header and the first rows
of the sheet, as shown in Figure 6-5.
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¢ Figure 6-4: Editing a really long formula like this one in
its cell obscures any data in cells in the region
to its right.



Doing Direct Cell Editing

35

[
() Elle Edit View  [nso

Format T Data Window [elp  Adala PDF J
el il BBl BB BB Sttt E
Moons = W & =SUMISprat Dist CiniS13 0] Trauma Cir 813, Hubbard Dog Goedies 813, 7-0-0 Hot Tubs1813, Porgie
| | Pugdng Pies™®13.H,DLD Clock RepainB13, Be-Peep Pei Detect. 1813, Siman Pie Shoppes 8130

| 1 IMother Goose Erﬂ.,'.“

2 rarber i) [rumber 1 1
| 3 |Revenues 6681450 78

4 |Costs and Revenues
| 5 | Equpmarnt £82,387.00

6 | Rent 1,767 925 88
| 7 | Fersonnel 4645279
| 8 | Manlenance B16.404 82

9 | Marketing and Sales #92,856 08
| 10| General and Admnstrabve: 219,925 60

11 Tatal Costs and Expenses 4,245 950 1

12

13 | Cperating Income {loss)

14
| 15 Cther Income

16 | Interest Incoma 218,420 6O
| 17 |Cthar 103,769.00

18 | Tatal Cther Incorme (axpenses) 322.199.60

19|
| 20 |income (loss) before Taxes 275770047 | “
i 4w Total tracome { Sprat Dt Ol 38 Trauma Ot Hubbrd Dog Goodkef RL0-0 Mot Tuke /1< | ] |

¢ Figure 6-5: Editing a really long formula on the
Formula bar leaves most of the work-
sheet unconcealed.



Streamlining Excel
Program Startup

Technique

Save Time By

v Adding an Excel desktop
shortcut

+* Adding Excel to the Quick
Launch toolbar

v Pinning Excel to the
Start menu

v~ Launching Excel on
Windows startup

Excel program. Although the procedures outlined in this technique

may seem really simple, when you think about how many times
you launch Excel even in a week’s time, let alone a month'’s, I think you’ll
agree that they’re worth their weight in gold.

I ucky Technique 7 is all about quick-and-easy ways to launch the

In this technique, all the ways for streamlining the Excel startup are
designed so that you never have to go through that clumsy Starte>

All Program Filese>Microsoft Officec>Microsoft Office Excel 2003 routine
(the Microsoft engineer that came up with that one should be ashamed of
himself)! The most obvious way to completely avoid this utterly Byzantine
command sequence is to put the Excel program icon at your fingertips,
either by placing it on the desktop as a shortcut or as an icon on the
Windows taskbar or Start menu. And if all you ever seem to do on your
computer is run Excel, you can even go the final step of having Windows
automatically launch the program as part of the computer startup
procedure.

Excel Desktop Shortcut

The most basic procedure for putting the Excel startup at your fingertips
is to put an Excel shortcut icon pointing to the Excel program’s executable
file on your computer’s desktop. To do this, follow these steps:

1. Click the Start button on the Windows taskbar and then select
Search on the Start menu.

Select the All Files and Folders link in the Search Companion task
pane.

Type excel.exe in the All or Part of the File Name text box and then
click the Search button.

N W N

.

Right-click EXCEL.EXE in the main pane of the Search Results dialog
box and then choose Send To->Desktop (Create Shortcut) from the
file’s shortcut menu, as shown in Figure 7-1.
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* Figure 7-1: Creating a desktop shortcut for the Excel
program file in the Search Results dia-
log box.

5. Click the Close button in the upper-right corner
of the Search Results dialog box to close it.

As soon as you close the Search Results dialog box,
you will see that Windows has added a Microsoft
Office Excel 2003 desktop shortcut. (See Figure 7-2.)
You can, if you wish, rename this icon to something
more manageable — such as Excel 2003 — by right-
clicking the icon and then deleting the redundant
Microsoft Officepart.
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¢ Figure 7-2: The Microsoft Excel 2003 shortcut icon.

To launch Excel from your computer’s desktop, sim-
ply double-click the (Microsoft Office) Excel 2003
desktop shortcut icon.
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Adding Excel to the Quick Launch Toolbar

Adding Excel to the Quick
Launch Toolbar

The only problem with launching Excel from a desk-
top shortcut is that you have to have access to the
Windows desktop in order to use it. This means that
you can’t use it to launch Excel when, for example,
you’re working in another application full screen
such as Microsoft Word or PowerPoint.

To be able to launch Excel without accessing the
Windows desktop, you can add your Excel desktop
shortcut to the Windows Quick Launch toolbar. This
toolbar resides to the immediate right of the Start
button on the Windows taskbar and is readily avail-
able at all times.

If the Quick Launch toolbar doesn’t appear
after the Start button on your Windows

taskbar, its display is turned off. To turn
it back on, right-click the taskbar, select
Properties and then select the Show Quick
Launch check box on the Taskbar tab of the
Taskbar and Start Menu Properties dialog box
before you click OK.

To add your Excel desktop shortcut to the Quick
Launch toolbar, follow these few steps:

1. Display the Windows desktop by clicking the
Show Desktop button on the Quick Launch tool-
bar (if the desktop is not already displayed).

If the Quick Launch toolbar isn’t displayed on
your computer’s taskbar, display it by right-
clicking on a blank area on the taskbar and
then choosing Toolbars=>Quick Launch.

2. Drag the Excel desktop shortcut icon to the
place on the Quick Launch toolbar where
you want it to appear.

Excel indicates the place where the Excel icon
will be inserted by displaying a heavy, I-beam-
type pointer in between the existing buttons on
the Quick Launch toolbar.
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3. Release the mouse button to create a new Excel
button on the Quick Launch toolbar, as shown
in Figure 7-3.

- JENC

* Figure 7-3: The Quick Launch toolbar after adding the
Excel desktop shortcut to it.

You don't have to double-click the Excel but-
ton that you add to the Quick Launch toolbar
to launch Excel. You only need to click it once,

just as you would any of the buttons on the
numerous Excel toolbars.

You may have to enlarge the Quick Launch
toolbar to display all its icons. To do this, posi-
tion the mouse pointer on the right edge of
the bar (marked by a double line of dots) and
drag the double-headed arrow pointer until
all the icons are shown. If the double-headed
arrow pointer doesn’t appear, the taskbar is
locked. Right-click the taskbar and then clear
the Lock the Taskbar item on the pop-up
menu to unlock it. After enlarging the Quick
Launch toolbar to display all its icons, you can
once again lock the taskbar by selecting this
item.

Pinning Excel to the Start Menu

What if you're one of those users who never display
the Quick Launch toolbar on the Windows taskbar
because you don’t want to waste all that precious
taskbar real estate on a few crummy launch buttons?
Well, for you, [ suggest making Excel a permanent
part of the Start menu. That way, you can always
launch Excel by clicking the Start button (something
you can’t remove from the Windows taskbar) or by
pressing Ctrl+Esc and then selecting the Microsoft
Office Excel 2003 menu item on the Start menu.

Technique 7: Streamlining Excel Program Startup

To make Microsoft Office Excel 2003 a permanent
item on your computer’s Start menu, follow these
steps:

1. Launch Excel and then immediately close its
program window.

You must manually start Excel in order to add
its menu item to the Recently Opened section

of the Start menu. To launch Excel, double-click
the Excel desktop shortcut or click the Excel
button on the Quick Launch toolbar. If you have
neither, you have to do this by choosing Start=>
All Programs=Microsoft Office>Microsoft Office
Excel 2003. (Doing that should give you a real
incentive to complete the rest of these steps!)

2. Click the Start button on the Windows taskbar
or press Ctrl+Esc to open the Start menu.

3. Right-click the Microsoft Excel 2003 item on the
Start menu and then choose the Pin to Start
Menu option, as shown in Figure 7-4.

4. Click anywhere outside the Start menu or press
Esc to close the menu.

If a Microsoft Excel 2003 item doesn’t appear
on your Start menu after following these steps,
the Number of Programs on Start Menu option

has been set to 0. Right-click the taskbar and
then select Properties. Next, select the Start
Menu tab in the Taskbar and Start Menu
Properties dialog box and then click the
Customize button. Finally, enter a value greater
than 0 (and not more than 30) in the Number
of Programs on the Start menu text box
before you select OK.

After pinning Microsoft Excel 2003 to the Start menu,
you can always launch Excel by clicking the Start but-
ton on the taskbar (or by pressing Ctrl+Esc) and then
selecting this menu. This menu item now appears in
the permanent programs section of the Start menu
(which is the top-left portion of the menu) along
with the other permanent programs, including your
Internet and e-mail applications.
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Launching Excel on
Windows Startup

For you real hardcore Excel users, the only real solu-
tion to the Excel launch problem is to have Windows
automatically launch Excel for you every time you
start your computer! The procedure is easy: All you
have to do is drag the Microsoft Office Excel 2003
menu item from the Microsoft Office submenu to

the Startup submenu:

Launching Excel on Windows Startup 3 9

1. Click the Start button on Windows taskbar or
press Ctrl+Esc to open the Start menu.

2. Choose All Programs=>Microsoft Office to open
the submenu.

3. Drag the Microsoft Office Excel 2003 menu item
from this submenu to the Startup menu on the
All Programs menu.

4. Drop the Microsoft Office Excel 2003 menu
item anywhere on the Startup submenu, as
shown in Figure 7-5.
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After moving Microsoft Office Excel 2003 to the
Windows Startup menu, Windows launches the
program every time you start or restart Windows.

To stop having Excel launch every time you
start your computer, drag the Microsoft Office
Excel 2003 item back to its original home on
the Microsoft Office submenu.
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Save Time By
v Installing add-ins

v Using the add-ins
included with Excel

v~ Finding add-ins online

basic features of Excel. Most of the add-in programs created for Excel

offer you some kind of specialized function or group of functions
that extend Excel’s computational abilities. For example, Excel includes
an Analysis ToolPak that gives you immediate access to some fifteen
additional sophisticated statistical functions, including such things as
Anova, Covariance, F-Test: Two-Sample for Variances, Fourier Analysis,
Histogram, Rank and Percentile, t-Test, and z-Test, among others. It also
includes a Conditional Sum Wizard, Lookup Wizard, and Solver Add-in
that you can use to perform other types of analysis.

Excel add-in programs provide a quick-and-easy way to extend the

As part of the Excel program, Microsoft offers you a group of spread-
sheet-type add-ins that you can start using right away. In addition, you
can search the Microsoft Web site for additional add-ins that you can
download for free as well as a number of other third-party Web sites
where you can purchase the Excel add-ins for download.

Installing Add-ins

Before you can use any add-in program, the add-in must be installed in the
proper folder on your hard drive, and then you must select the add-in in
the Excel Add-Ins dialog box. Excel add-in programs are saved in a special
file format identified with the . XLA (for Excel Add-in) filename extension.
These XLA files are normally saved inside the Library folder (sometimes
in their own subfolders) that is located in the Officell folder. The path to
this folder on most computers is C:\Program Files\Microsoft Office\
Officell\Library.

After an add-in program is installed in the Library folder, its name then
appears in the Add-Ins dialog box, which you open by choosing Toolsw>
Add-Ins. To activate an add-in program (and thereby put it into the com-
puter’s memory), select the check box in front of its name in the Add-Ins
dialog box (see Figure 8-1), and then click OK.
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* Figure 8-1: Activating add-in programs that have already
been installed on your computer.

If you ever copy an XLA add-in program to a folder
other than the Library folder in the Officell folder,
its name won’t appear in the Add-Ins dialog box.
You can, however, activate the add-in by clicking
the Browse button in the Add-Ins dialog box to
navigate to the add-in file and then clicking OK.

Using the Built-in Add-ins

You can start enhancing the power of Excel right
away by making use of the add-in programs Microsoft
provides as part of Excel. The add-ins that Microsoft
make available for your use include

v Analysis ToolPak: Adds extra financial, statisti-
cal, and engineering functions to Excel’s pool
of built-in functions. To access these functions
(and get help on using them), choose Tools=>
Data Analysis after activating this add-in.

v Analysis ToolPak VBA: Enables VBA program-
mers to publish their own financial, statistical,
and engineering functions for Excel.

Using the Built-in Add-ins 4 ’

v Conditional Sum Wizard: Helps you set up formu-
las that sum data only when the data meets the
criteria you specify. To use this wizard, choose
Tools>Conditional Sum after activating this
add-in.

v Euro Currency Tools: Enables you to format
worksheet values as euro currency and adds a
EUROCONVERT function for converting other
currencies into euros. To access these tools,
choose Tools>Euro Conversion after activating
this add-in.

v Internet Assistant VBA: Enables VBA program-
mers to publish Excel data to the Web.

v Lookup Wizard: Helps you set up formulas that
return data from an Excel list by using known
data in that list. (See Technique 57 for details.)

v Solver Add-In: Calculates solutions to what-if
scenarios based on cells that both adjust and
constrain the range of values.

The first time you activate any of the add-ins included
with Excel, the program immediately displays an alert
dialog box telling you that the add-in is not currently
installed and asking you if you want to install it. All
the add-ins included as part of Excel show up in the
list box in the Add-Ins dialog box but don’t actually
take up disk space until you're ready to use them.
Select Yes in this alert dialog box to install the add-
ins selected in this list. Keep in mind that Excel
needs to access your Office CD-ROM or its files on
your network in order to install any of these
included add-in programs.

To save computer memory (RAM) that may be
needed for doing calculations in the workbook
you’re editing, you can deactivate any of the add-in
programs that you're not currently using. Just open
the Add-Ins dialog box, deselect the check box in
front of the add-in program’s name, and click OK.

Deactivating an add-in does not uninstall the
@ program; it only removes the add-in from the
computer's RAM memory. If you deactivate

add-ins to save memory, remember to open
the Add-Ins dialog box and activate them
when you again need access to their functions.
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Getting Online Add-ins

The add-ins that Microsoft includes as part of the
Excel program aren’t the only ones that you can lay
your hands on. You can find additional free Excel
add-ins on the Microsoft Office Web site, and many
third-party vendors sell Excel add-ins that you can
often purchase online and then immediately down-
load onto your hard drive.

To locate free Excel add-ins from Microsoft, go
online to the Office Web site at

office.microsoft.com

You can get to this Web page quickly
from within Excel by choosing Help=>
Microsoft Office Online.

Once there, click the Excel link, enter add-ins as

the search text in the Search text box, and click Go.
Doing this brings up a Web page similar to Figure 8-2,
listing pages of free add-ins that you can download
and use with your version of Excel. (Note that add-
ins are very version-specific, so be sure that you
only download those that are compatible with the
version of Excel that you're using.)
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Technique 8: Saving Time with Excel Add-ins

To find third-party vendors and get information on
their add-ins, launch your Web browser and then do a
search for Excel add-ins. This brings up a Web page
full of links to various outfits that make and sell all
types of Excel add-ins, as shown in Figure 8-3. Note
that many of these sites offer specialized templates
and Excel training along with their add-ins.
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World Wide Web.

Even before you do this Web search, you may want
to pay a visit to the Macro Systems Web site at www.
add-ins.com (see Figure 8-4). Macro Systems offers
a wide variety of Excel add-ins, sold both in collec-
tions and as single items. The Macro Systems add-
ins are divided into categories that include Time
Saving Add-ins, Charting Add-ins, Data Related Add-
ins, Financial Add-ins, and so on.

When visiting the Macro Systems Web site, be
sure to download its free add-in, Time Saving
Microsoft Excel Solutions. This online book is in
the Microsoft help file format and is chocked
full of hints on how to work smarter and faster.
To get this book, scroll down the Add-ins.com
home page until you see the Free Add-ins sec-
tion and then click the Free Downloadable
Book link.
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Navigating the
Worksheet

Technigiie Ma Snap

Save Time By

v~ Saving the cell pointer
where you need to work
next

v~ Zipping to the end of a
table, sheet, or workbook

+* Using Go To

v Zooming out on the
worksheet

through column after column or row after row of data and blank

cells to find the place in your spreadsheet where you need to con-
tinue entering data or make some editing changes. In my Excel training
classes, I make it a real point to thoroughly cover the most efficient ways
to navigate the spreadsheet. Here, in this technique, I give the same tips
and tricks for getting where you need to go as quickly as possible.

Nothing is quite as time-consuming and tedious as having to scroll

g Technique 10 on making the most efficient cell selections are proba-
bly the most important timesavers in this part of the book; so,

listen up!

z This technique on effectively navigating the spreadsheet and
@

&

Saving the Cell Pointer’s Position

Many Excel users forget the simple fact that the program always saves
the cell pointer’s current position in the workbook as part of the file. This
means that when you’re working on a spreadsheet over a period of sev-
eral days, you want to make sure that at the end of your work session
you set yourself up in the workbook so you're immediately ready to go
the next time you open the workbook file.

To do this, I always make a conscious effort to position the cell pointer in
the cell at the beginning of the range where I will continue working the
next time I open the spreadsheet. Then I save the workbook file one last
time before exiting the Excel program. That way, the next time [ work on
the spreadsheet, I'm ready to resume entering the remaining data or to
continue making my edits without having to waste any time scrolling or
finding that position.
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Going Direct

As even the most novice of Excel users is well aware,
a worksheet covers an awfully big area of which only
the smallest bit is ever displayed on-screen at any
one time. Many times when making editing changes
to a particularly large worksheet or in an especially
complex workbook (that is, whose data is flung
across several worksheets), you have to move
directly to the place you need to go. This can involve
moving from one end of a table or list of data to the
other, from one cell range to the next, or even from
one sheet to the next. Scrolling through the columns
and rows of any given sheet or clicking sheet tab
after sheet tab to find your place in these kinds of
spreadsheets is just plain inefficient.

Leaping through data ranges and
hopping over blanks

This first procedure enables you to

v Leap from end to end in a long table or list of
data.

v Hop from the end of one occupied cell range to
the next over all the blanks in between.

How this works is that if the cell pointer is located
on a blank cell and you hold down Ctrl as you press
an arrow key, the cell pointer jumps to the next cell
in the direction of the arrow key that contains any
type of entry. (You can also do this by pressing the
End key and an arrow key — the only difference here
is that you have to release the End key before you
press Enter.) Alternately, if the cell pointer is located
on a cell that has some sort of entry and you press
Ctrl plus an arrow key (or End, arrow key), the cell
pointer jumps in the direction of the arrow to the
last cell containing an entry followed by a blank cell.

Figures 9-1 through 9-4 illustrate this kind of blank-
to-occupied, occupied-to-occupied leapfrogging. In
Figure 9-1, the cell pointer is in cell A2, a blank cell.

Technique 9: Navigating the Worksheet in a Snap

When I press Ctrl+!, the cell pointer just jumps
down three rows to cell A5, the first occupied cell
below it (see Figure 9-2).
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¢ Figure 9-1: Starting in the cell pointer in blank cell A2
and moving downward by pressing Ctrl+!.
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¢ Figure 9-2: The cell pointer jumps down to A5 — the first
occupied cell after the blanks in that column.

However, when I press Ctrl+| a second time (see
Figure 9-3), the program jumps the cell pointer down
to cell A9 because this is the last occupied cell



before the blank cell in A10. When I press Ctrl+|
again, Excel jumps the cell pointer down to cell A16
(see Figure 9-4), the first occupied cell after the
blanks in that column.
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« Figure 9-3: Pressing Ctrl+l again moves the cell pointer
down to A9 — the first occupied cell before a

blank.
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« Figure 9-4: Pressing Ctrl+l again moves the cell pointer
down to A16 — the first occupied cell after
the blanks.

Going Direct 4 9

In navigating the sample worksheet shown in
Figures 9-1 through 9-4, I could go on in this
manner — leaping from one occupied cell to the
next and hopping over all the blanks in between.

Of course, if you happen to be in the very last occu-
pied cell in a particular column or row and then use
the Ctrl+arrow key combination again, Excel jumps
to the very last worksheet cell in that direction in
that column or row (that is, column IV when you
press Ctrl+—, column A when you press Ctrl+«, row
65536 when you press Ctrl+!, and row 1 when you
press Ctrl+T).

Before inserting new rows or columns in a
worksheet with which you're not totally famil-
iar, press Ctrl plus the appropriate arrow key
to make sure that no hidden data ranges will
be split by your insertion. If the cell pointer
shoots to the very first or last column or row
of the sheet, you know the way is clear.

Going right to the last cell in a sheet

When you’re building a new spreadsheet that has
only one table in it, you can use the keystroke short-
cut Ctrl+End to zip right to the last cell in the sheet.
This keystroke shortcut jumps you right to the end
of the occupied regions in your worksheet, enabling
you to identify open areas in the sheet where you
can build new tables and lists of data.

Understand, however, that the last cell of a work-
sheet can be, and often is, itself blank. This is
because Excel defines the last cell in any given work-
sheet as the one that lies at the intersection of the
last occupied row and column and considers a row
or column to be occupied if any of its cells have data
in them.

As Figure 9-5 illustrates, the last cell of the sheet is
blank whenever you’ve made any entries in the last
occupied column even when your data entries don’t
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yet extend down to the last occupied row. The last
cell also is blank if you’ve made any entries in the

last occupied row of the sheet but haven’t made it
all across to the last occupied column.

Whereas the last cell that Excel takes you
to when you press Ctrl+End constantly
changes when you expand the data ranges in

the sheet, the first cell the program takes you
to when you press Ctrl+Home is always A1 of
whatever sheet is active.
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Zipping through the sheets

It’s bad enough trying to find your place in a spread-
sheet containing data spread all over a single work-
sheet, but it’s even worse when you're dealing with a
spreadsheet whose data is parsed out over several
worksheets. (Dealing with more than two worksheets
can be a real nightmare.) Nevertheless, many spread-
sheets benefit greatly from a multisheet layout —
especially those that consolidate data from many
time periods or that contain schedules of data that
are used as lookup tables referred to by formulas in
the main sheet.

Technique 9: Navigating the Worksheet in a Snap

To help you get quickly to the sheet you need in a
spreadsheet that utilizes many sheets (more than
the default three), you can rely on the Sheet Tab
scrolling buttons (see Figure 9-6) to bring the work-
sheet you want to work with into view so you can
activate it:

v C(lick the Next Group button to bring the next
group of sheet tabs into view in the area between
the Sheet Tab scrolling buttons and the horizon-
tal scroll bar.

v C(lick the Last Tab button to bring the last group
with the book’s final sheet tab into view in this
area.

First tab

Next group

[« v wh Total Income { Sprat Diet Ctr. { J&3 Trauma Ctr. / Hubbard Dog Goodies £

Last tab

Previous group

¢ Figure 9-6: Using the Sheet Tab scrolling buttons to scroll
through the sheets of a workbook.

You can display more sheet tabs by decreasing
the size of the horizontal scroll bar; just posi-
tion the mouse pointer at the beginning of the
horizontal scroll bar and then, when the
pointer takes the shape of a split double-
headed arrow, drag to the right.

Don't forget that scrolling a sheet tab into
view is not the same as selecting it: You still
need to click the sheet tab to activate the

sheet.

If you don’t need to make a big jump between the
sheets in your workbook, you can move quickly from
sheet to sheet by pressing the Ctrl+Page Down and
Ctrl+Page Up keystroke shortcuts. Press Ctrl+Page



Down to activate the next sheet in the workbook,
and press Ctrl+Page Up to activate the previous one.
The great thing about these keystroke combinations
is that they not only bring the sheet tab into view
but also automatically activate the sheet at the same
time!

A Little Go To Magic

[ find that a lot of users forget that the Excel Go To
feature is a great way to go directly to a particular
cell range in the spreadsheet. This is probably
because many users don’t bother to assign names to
their cell ranges — see Technique 26 for details —
which is really what makes using Go To worthwhile.

To use the Go To dialog box, follow these steps:

1. Press F5 or Ctrl+G (or choose Edit->Go To).

Excel opens a Go To dialog box similar to the one
shown in Figure 9-7.

2. Enter the address of the cell you want to go to
(such as E150 or AB20) in the Reference text
box, or if your spreadsheet contains range
names, select the name of the range in the
Go To list box. Then click OK.

If you enter a cell address, Excel positions the
cell pointer in that cell. If you select a range
name, the program selects all the cells in the
range, making the first cell in that range the
active one.

After you use the Go To feature to jump to a particu-
lar cell or cell range, the Reference text box shows
the address of the active cell from which you
jumped. This means that if you decide that you want
to return to the cell you originally came from, all you
have to do is press F5 (or Ctrl+G) and then immedi-
ately press Enter — you don’t even need to take time
to examine the contents of the Go To dialog box.

A Little Go To Magic 5 ’
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* Figure 9-7: Using the Go To dialog box to jump directly
to a new cell in the worksheet.

After you use the Go To feature to return to the
cell that marked your original starting point, the
Reference text box shows the address of the cell or
range that you originally jumped to. This means
that, if you change your mind yet again and decide
that you want to revisit the cell or range you origi-
nally jumped to, you can do so by pressing F5 (or
Ctrl+G) and then immediately pressing Enter.

You can, in fact, bounce back and forth from source
to destination and then from destination back to
source with F5, Enter, F5, Enter, as long as you need
to compare and go back and forth between the two
regions of the spreadsheet. And whenever you need
to head over to a new region, just enter a new cell
address in the Reference text box or select a new
range name for it.

B range names is that Excel whisks you back
and forth not only between separate regions
in the same worksheet but also between

regions on separate worksheets.

Z The great thing about using Go To with cell
-

&
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Zooming Out to Get
the Big Picture

The last procedure for finding your desired place in
a worksheet and getting there is a visual one. Here
are the general steps you follow:

1. Use the Zoom feature to zoom out on the work-
sheet until you can see the cell range or embed-
ded chart you want to work with.

2. Click somewhere in the range or chart to set
the cell pointer in it.

3. Use the Zoom feature to zoom in on the new
region so you can read and work with its data.

Figures 9-8 and 9-9 illustrate how you can make this
work. First, | zoomed out on the work by setting the
magnification to 15% of normal (by entering 15 into
Zoom button’s text box on the Standard toolbar). As
you see in Figure 9-8, doing this made all the data in
the table in the initial cell range A1:R15 completely
illegible while at the same time revealing the loca-
tion of two additional items on the worksheet — an
embedded chart in the cell range J92:P112 and
another table of data in the cell range R92:AJ104.

To get directly to the table in the range R92:AJ104
and be able to edit its data, I clicked the cell pointer
on cell U104 while the sheet was still in 15% magnifi-
cation. Then I increased the magnification back to
normal (by selecting 100% in the Zoom button’s pop-
up menu on the Standard toolbar), as shown in
Figure 9-9.

After hunting a cell range in this manner,

| immediately assign a name to the range

(see Technique 26) so that afterwards | can
return to the range with the Go To feature
(see “A Little Go To Magic,” earlier in this tech-
nique, for details).

Technique 9: Navigating the Worksheet in a Snap
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¢ Figure 9-8: Zooming out to 15% magnification reveals
the location of a second table of data and an
embedded chart.
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¢ Figure 9-9: Resetting the cell pointer and zooming back
to 100% magnification.



Making the Most
Efficient Cell

Tethnigiie  Selections

Save Time By

v~ Selecting ranges with
AutoSelect

v~ Selecting ranges with
GoTo

v~ Selecting entire columns,
rows, or sheets

formed worksheet task, knowing how to efficiently select ranges of

cells in the spreadsheet can go a long way toward making you a
truly effective worker. Cell selection, while rudimentary, is still very
important to taking a lot of the drudgery out of spreadsheet work. After
all, selecting cells is the thing you have to do before you can assign new
formatting and alignment; move, copy, or reorient the data; and print spe-
cific parts of the spreadsheet.

B ecause cell selection is one of the most basic and regularly per-

Before going over some of the fancier and more grandiose procedures
for selecting cells in a worksheet, you might want to review the two
basic procedures for using a mouse to select single cell ranges in the
worksheet:

v Click the first cell in the range and then drag the thick, white-cross
pointer to the last cell.

v C(lick the first cell in the range, and then hold down the Shift key as
you click the last cell you want to select (a procedure known as
Shift+clicking).

To select multiple, nonadjacent cell selections at a time (also known as a
noncontiguous cell selection), you follow these steps:

1. Select the first cell range with your mouse as usual.

2. Hold down the Ctrl key as you use your mouse to select the second
range.

When you hold down the Ctrl key as you start to select the second
range, Excel does not deselect the first range — as it normally
would — so this first range continues to be highlighted (shaded)
in the worksheet, as shown in Figure 10-1.

3. Repeat Step 2 as needed to select all additional ranges that need to
be included in the noncontiguous cell selection and then release
both the Ctrl key and the mouse button at the same time.
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* Figure 10-1: Selecting two cell ranges as part of a
noncontiguous cell selection.

Keep in mind that you can also use the keyboard to
select cell ranges. After moving the cell pointer to
the first cell in the range, hold down the Shift key as
you press the appropriate cursor key (an arrow key
or Page Up or Page Down). Holding down the Shift
key anchors the cell range on the first cell and
enables the program to extend the range when you
press a cursor key. If you find holding down the Shift
key too tiring, you can anchor the cell range on the
current cell by pressing F8 — that puts the program
into EXT (Extend) mode.
When selecting a range of cells that contain
e («a sequential data via the keyboard, you can

) really save time by combining the Ctrl+arrow
key trick to hop from one end of a table of
data to the other with the Shift key. By press-
ing Ctrl+Shift+arrow key, Excel selects from
the current cell all the way to the last occupied
cell in the arrow’s direction in one fell swoop.

To select a noncontiguous range with the keyboard,
you follow these steps:

1. Position the cell pointer in the first cell of the
first range to select, press F8 to put the pro-
gram in EXT mode, and then select the range
with the cursor keys.

2. Press Shift+F8 to switch the program into ADD
mode and then move the cell pointer to the
first cell of the second range you want to select.

3. Press F8 again to switch back into EXT mode
and then select this second range with the cur-
sor keys.

Technique 10: Making the Most Efficient Cell Selections

4. Repeat Steps 2 and 3 until you select all the
ranges you want included in the noncontiguous
cell selection.

AutoSelect at Vour Service

AutoSelect is a great timesaving feature that enables
you to select an entire table of data as a single cell
selection in a couple of double-clicks of the mouse.
To use AutoSelect to select your table, follow these
few steps:

1. Position the mouse pointer in the first cell in
the table of data you want to select.

Note that for this procedure to work, the columns
and rows of the table must not contain blanks.

2. Position the mouse pointer somewhere along
the bottom border of the cell pointer and then,
when the mouse pointer changes to an arrow-
head pointing to crisscrossed double-headed
arrows (as shown in Figure 10-2), hold down
the Shift key and double-click the mouse.
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¢ Figure 10-2: Getting ready to select the first column of
the table.

If you forget to hold down the Shift key before
you double-click, the cell pointer just jumps to
the last occupied cell in the column without
extending the cell selection.



3. Position the mouse pointer somewhere along
the right edge of the current cell selection and
then, when the mouse pointer changes to an
arrowhead pointing to crisscrossed double-
headed arrows — as shown in Figure 10-3 —
hold down the Shift key and double-click the
mouse a second time.
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¢ Figure 10-3: Extending the cell selection down the first
column of the table with AutoSelect.

After you double-click the right edge of the first
cell selection (while holding down the Shift key
to extend it), Excel extends the cell selection to
include all the columns of data in the table, stop-
ping automatically at the first blank row in the
worksheet (see Figure 10-4).
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* Figure 10-4: Extending the cell selection across the table
with AutoSelect.

Go To It and Select It

In Technique 9, I outline how you can use Excel’s
Go To feature to jump instantly to anywhere in the
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current worksheet. At that time, I also suggest that
you go out of your way and give names to the cell
ranges (as outlined in Technique 26) that you rou-
tinely use in a spreadsheet.

One reason why I keep harping about this is because
giving names to cell ranges enables you to use the
Go To feature to instantly select the entire range
whenever you need to refer to it. (This little tidbit is
worth its weight in gold when it comes to a cell
range in a spreadsheet that you routinely need to
print out.) For example, in the table of data shown in
the cell range B3:E8 shown in Figure 10-5, I assigned
five range names:

v data_table to the cell range B3:ES8 to select the
entire table of data

v first_col to the cell range B3:B8 to select only the
first column of data

v second_col to the cell range C3:C8 to select just
the second column of data

v third_col to the cell range D3:D8 to select just
the third column of data

v fourth_col to the cell range E3:E8 to select only
the last column of data
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* Figure 10-5: Selecting a cell range by choosing its range
name in the Go To dialog box.
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After assigning the range names, selecting the entire
table of data (for printing or for formatting) from
anywhere in the workbook (I don’t have to be on the
same worksheet), takes only two steps:

1. Press F5 or Ctrl+G to open the Go To dialog box.

2. Select the range name you want (data_table,
for example) in the Go To list box and then
click OK.

Note that although using the Go To feature to select
named cell ranges is by far the easiest way to do it,
you can use this feature to select a range of cells by
entering the address of the first and last cell in the
range in the Go To dialog box as follows:

1. PressF5 or Ctrl+G, and then enter the address
of the first cell in the range to be selected in
the Reference text box and click OK.

2. Press F8 to switch Excel into EXT (Extend)
mode.

3. PressF5 or Ctrl+G, and then enter the address
of the last cell in the range to be selected in the
Reference text box and click OK.

4. Press F8 to switch Excel out of EXT mode and
back into Ready mode.

Don't forget the last step of this Go To proce-
dure, or you'll really think Excel has gone
haywire when any move you make in the

worksheet continues to highlight intervening
cells.

Going for the Big Selections

In addition to being able to select single and multiple
cell ranges in a worksheet, you also need to be
aware of some tricks for quickly making big selec-
tions, including selecting entire columns, rows, and,
yes, even the entire worksheet. Table 10-1 gives you
an overview of this very handy information.

TaBLE 10-1: SELecTING ComPLETE CoLumns, Rows,

AND SHEETS

To Select This

Do This

Current worksheet

All worksheets in the
workbook

Sequential worksheets

Nonsequential worksheets

Single column

Sequential columns

Nonsequential columns

Single row

Sequential rows

Nonsequential rows

Press Ctrl+A or click the
square formed by the inter-
section of the column and
row headers.

Right-click the tab of the
active worksheet and then
choose Select All Sheets.

Click the tab of the first sheet
and then hold down the Shift

key as you click the tab of the
last worksheet to select.

Click the tab of the first sheet
and then hold down the Ctrl
key as you click the tabs of
the other worksheets to
select.

Click the letter of the column
in the column header.

Click the first column’s letter
in the column header. Then
drag through the letters of
the other columns to the left
or right, or press Shift+— or
Shift+«.

Click the first column’s letter
in the column header and
then hold down the Ctrl key
as you click the letters of the
other columns.

Click the row’s number in the
row header.

Click the first row’s number in
the row header. Then drag
through the other numbers of
the other rows up or down, or
press Shift+! or Shift+T.

Click the first row’s number in
the row header and then hold
down the Ctrl key as you click
the numbers of the other
rOWS.
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When you select multiple worksheets, Excel
goes into Group mode (indicated by [Group]
after the filename on the title bar). In Group
mode, all the data entry, formatting, and edit-
ing you do in the active sheet is simultane-
ously performed in the other selected sheets
as well.



Speeding Through
Long Data Entries

Teéhnique  With AutoCorrect

Save Time By
v~ Setting your AutoCorrect
options

v~ Turning off the hyperlinks
to Internet and network
paths

+* Modifying the smart tag
settings

entry in a spreadsheet. It anticipates what you enter and, if neces-

sary, corrects it or converts it into special types of data such as
live hyperlinks and smart tags — data recognized as being of a particular
kind, such as Wall Street financial symbols and personal names. The
AutoCorrect feature in Excel encompasses three areas:

ﬁ utoCorrect is Excel’s attempt to save you time when doing data

v AutoCorrect: Automatically corrects common spelling errors when-
ever you make them in cell entries

v AutoFormat As You Type: Automatically turns Web addresses and net-
work paths into live hyperlinks and expands data lists when you add a
new record to them

v Smart Tags: Enables you to control all the smart tag settings, including
checking the workbook for data that Excel identifies as a type of smart
tag, controlling the appearance of the Smart Tag indicator in the work-
sheet cells, looking online for more smart tag applications, and making
the smart tags identified in your spreadsheet a permanent part of the
workbook file by embedding them in it

Setting the Correct AutoCorrect Settings

The AutoCorrect options can save you a great deal of spell-checking time,
especially if you go to the trouble of adding your own common typos to
the ones that the feature is already set to take care of. When you first
open the AutoCorrect dialog box (Tools=>AutoCorrect Options) and
select its AutoCorrect tab (see Figure 11-1), Excel activates all the check
box settings that dispose of many common typing errors such as typing
with the Caps Lock key on or failing to capitalize the days of the week or
the beginning of a sentence.
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¢ Figure 11-1: Entering new replacements for the
AutoCorrect feature.

The program also selects the Replace Text As You
Type check box that activates all the automatic cor-
rections contained in the list box below. If you don’t
want to use one of these readymade corrections
(such as automatically turning three periods in a
row into a real live ellipsis), simply select the entry
in the list box and then click the Delete button to get
rid of it.

If you have a tendency to make a certain typo that’s
not already included on the list, you can add it by
entering the typo in the Replace text box and the
automatic replacement in the With text box and then
clicking Add.

7 If you have certain abbreviations that shouldn’t
B («@ be capitalized or special terms with more than
& one capital letter at the beginning that you

routinely use in your spreadsheets, instead of
deactivating the AutoCorrect settings that oth-
erwise change them, use the Exceptions but-
ton to add the particular abbreviations or
terms to either the lists of First Letter or INitial
CAps exceptions that the program then leaves
alone.
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Losing the Links

Losing the Links

Excel has this nasty tendency to automatically turn
any cell entry that looks like a Web address, an
e-mail address, or a path to a network folder into a
live hyperlink. If you then click this link (even by
accident), Excel attempts to open the Web page,
e-mail message program, or Windows Explorer with
the network folder. Now, this is not good, because
you can end up online (especially if your computer
is connected to the Internet as part of its network or
uses some sort of wireless connection) when all you
intended to do was click a cell to select it!

Fortunately, you can stop Excel from making all
these addresses hot by taking these steps:

1. Choose Tools>AutoCorrect Options to open the
AutoCorrect dialog box.
2. Select the AutoFormat As You Type tab.

3. Deselect the Internet and Network Paths with
Hyperlinks check box (as shown in Figure 11-2)
and then click OK.

AutoCorrect 2JEd

AukoCaorreck | AutoFormat As You Type | Smart Tags

Replace as you bype

[CiInkernet and network paths with hvperlinks
apply as vou wark

Include new rows and colurmns in list

| ak, %J I Cancel ]

¢ Figure 11-2: Turning off the automatic hyperlinks setting.
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If you have a worksheet that already contains
hot links and you want to deactivate them,
you need to right-click each link and choose
Remove Hyperlink from the menu that
appears.

Taming the Smart Tags

Depending upon the type of work you do with Excel,
the Smart Tags feature may appear to you to be
either one of the most brilliant or one of the most
useless program features. The way smart tags work
in Microsoft Office applications such as Word and
Excel is that the programs scan their documents
looking for particular types of entries (called recog-
nizers) to which it can affix a specific type of smart
tag program. For example, Excel comes with three
smart tag programs, one for dealing with dates,
another for dealing with financial symbols used by
Wall Street, and a third for dealing with personal
names:

v The Date smart tag program enables you to open
your Microsoft Outlook calendar right to the
date contained in the cell (assuming the date is
one that the calendar program covers).

v The Financial Symbol smart tag program enables
you to get an online stock quote for the company
in question from MSN Money.

v The Person Name smart tag program enables
you to add people to your Outlook Contacts list,
send an e-mail message to them, or schedule a
meeting with them.

When Excel identifies an entry for a particular smart
tag program, it inserts a Smart Tag indicator in the
lower-right corner of its cell — the indicator initially
appears as a small purple triangle. To select one of
the actions offered by a particular smart tag pro-
gram, position the mouse pointer over its smart tag
indicator and then position the mouse pointer over

Technique 11: Speeding Through Long Data Entries with AutoCorrect

the Smart Tag Actions button (the one with the i
enclosed in a circle) that appears to the right of the
indicator and click its drop-down button.

If smart tags sound like something that would only
complicate your life unnecessarily, you simply need
to make sure that the smart tags option is turned off.
To do this, select the Smart Tags tab in the
AutoCorrect dialog box (Tools=>AutoCorrect
Options), and then make sure that the Label Data
with Smart Tags check box is deselected before you
click OK.

If, however, smart tags seem like something that
might well enhance your work, you do just the
opposite:

1. On the Smart Tags tab of the AutoCorrect dia-
log box, select the Label Data with Smart Tags
check box, and then in the Recognizers list
box, select the check boxes for the smart tag
programs you want to activate. (See Figure 11-3.)

AutoCorrect 2%

AutoCorrect | AukoFormat As You Type | SMart Tags

Excel can recognize certain bypes of data in wour workbooks, For each
recognized bype, there are actions vou can perform with that data,

%Label data with smart tags

Recognizers:
[[] Date (Smart tag lists)
Financial Symbol {Smatt tag lisks)
Persan Mame (Outlaok e-mail recipients)

[ Check Warkbook, .. ] | Mate Smatt Tags...

Shows smart kags as | Indicator and Button | s

[CIEmbed smatt tags in this warkbook

[ Ok, J [ Cancel

¢ Figure 11-3: Modifying the smart tag settings.



If you want to suppress the appearance of the
smart tag indicators in the recognized cells,
choose None or Button Only from the Show
Smart Tags As drop-down list.

Taming the Smart Tags 6 ’

If you want to be able to save smart tags as part
of the workbook file, select the Embed Smart
Tags in This Workbook check box.

When you're finished making your selections,
click OK.



Data Entry Tricks

Technique

Save Time By

v~ Entering the same value
in multiple cells

v~ Constraining entries to a
single range

+* Working in Group mode

tasks you do, is also often one of the most tedious. The tips in this

technique (especially when coupled with those in Techniques 13,
14, and 15) are designed to take some of the drudgery out of doing data
entry by helping you work more efficiently and, at the same time, more
accurately.

I et’s face it: Data entry, while one of the most important spreadsheet

These tips include

v Taking advantage of Excel’s ability to enter the same entry in multiple
cells or cell ranges in one operation.

v Constraining data entry to a preselected cell range. (This one applies
only when you're creating a standard table of data and you know
beforehand how many columns and rows it takes up.)

v Doing simultaneous data entry in multiple worksheets of the same
workbook by working in Group mode. (This one applies only to
spreadsheets that use multiple worksheets, all of which share a com-
mon layout and data.)

Making the Same Entry in Many Places

Many spreadsheets use the same column or row headings — even the
same values — over and over again. When you know ahead of time that
you need to enter the same label or value in many cells in the same work-
sheet, you can do this by following these simple steps:

1. Select all the cells and cell ranges that require the same entry as a
noncontiguous cell selection. (See Technique 10 if you need help
doing this.)

2. Type the label or value into the active cell of the noncontiguous cell
selection.



Pause for a second after entering the data in the
active cell and resist the natural temptation to
complete this entry by pressing the Enter key or
clicking the Enter box on the Formula bar.
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3. Press Ctrl+Enter to complete the data entry,
entering it in every cell in the noncontiguous
cell selection.

The third and last step in this procedure is crit-
ical to entering the data in all the selected cells
rather than in just the active one.

Figures 12-1 and 12-2 illustrate how this procedure
works. In Figure 12-1, I need to enter Rock as the first
music category for both CDs and Cassettes in cells
A4 and A10. To make this entry at the same time in
both cells, I first select them as a noncontiguous cell
selection and then type Rock into the active cell A10.

= MicrosoR Excel - CG Media Sales - Sales 200421
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8 |Total CD Sales $0.00 $0.00 $0.00 $0.00
9 |Casseites

100 |Rock
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14 Total Casette Sales §0.00 $0.00 $0.00 $0.00
15 |Total Sales §0.00 $0.00 $0.00 $0.00
16

17

18

¢ Figure 12-1: Getting ready to make the same entry in the
two selected cells by pressing Ctrl+Enter.

To complete the data entry in both cells A4 and A10,
[ must remember to press Ctrl+Enter rather than just
press the Enter key alone or click the Enter button
on the Formula bar. Figure 12-2 shows the worksheet
after I press Ctrl+Enter to insert Rock in both cells
A4 and A10.
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* Figure 12-2: The worksheet after entering the same
category entry in both selected cells in one
operation.

Before collapsing the cell selection containing
the same entry, apply any formatting common
to the entries. In my example, | indented both
Rock category entries by clicking the Increase
Indent button on the Formatting toolbar
before dispensing with the noncontiguous cell
selection.

Putting the Wraps
on the Data Entry

One of the most efficient ways to enter data into a
new table in your spreadsheet is to preselect the
range with the blank cells where you need to enter
the data before you start doing any data entry. The
reason that preselecting the blank cell range works
so well is that in so doing, you constrain the cell
pointer to that range — provided you press only the
keystrokes shown in Table 12-1 to complete the data
entries and to move the cell pointer within the
range. This frees you from having to pay any atten-
tion to repositioning the cell pointer when entering
the table data. That way, you can keep all your atten-
tion where it should be on the printed copy from
which you're taking the data.
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TaBLE 12-1: KEYSTROKES FOR IVIOVING WITHIN A SELECTED
CeLL RANGE

When You Press This The Cell Pointer Moves Here

Enter Down each row and then right
across the remaining columns of
the selected range. (Moves one
column to the right, same as Tab
when the selection consists of a

single row.)

Shift+Enter Up each row and then left across
the remaining columns of the
selected range. (Moves one column
to the left when the selection con-

sists of a single row.)

Tab To the next column right and then
to the beginning of the next row
down in the selected range. (Moves
down one row when the selection
consists of a single column, same
as Enter.)

Shift+Tab To the next column left and then to
the beginning of the row above in
the selected range. (Moves up one
row when the selection consists of
a single column, same as

Shift+Enter.)

From one corner to the next corner
of the selected range, in a clock-
wise direction.

Ctrl+period (.)

When entering data in a preselected range,
you must not press an arrow key to complete
any of the entries, or you'll end up collapsing

the cell selection at the same time you put the
new entry in the current cell.

Figures 12-3 and 12-4 illustrate how doing data entry
in a preselected cell range works. In these figures,
I'm constructing a simple table that will list the sales
prices for furniture in the upcoming spring sale.

In Figure 12-3, I have reached the end of the data
entry for the second row of the table — the one con-
taining the column headings — and I'm just about to

enter the last column heading Sales Price in cell E3.
To get to this point, I've already entered the table
heading in A2 (the first cell of the selected cell
range) by pressing the Enter key. Doing so reposi-
tioned the pointer down one row in cell A3. I then
completed each column heading entry in cells A3,
B3, C3, and D4 across row 3 by pressing the Tab key,
which automatically advances the cell pointer one
column to the right upon data entry completion.
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¢ Figure 12-3: Entering column headings across the row
with Tab in the preselected cell range A2:E9.

When I press Tab again to insert the Sales Price col-
umn heading in cell E3 — the last column of the
selected cell range — Excel automatically advances
the cell pointer down one row to cell A4 (see Figure
12-4), the first column of the selected range.
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* Figure 12-4: Sales table after entering the last column
heading in E3 and pressing Tab.

At this point, I want to switch the direction of my
data entry, preferring to enter the Code numbers
down each column by pressing Enter (instead of



Tab) to complete their entries. When I reach cell A9
in the last row of the cell selection and press Enter
to complete its entry, Excel automatically advances
the cell pointer to B2 — the top row of the next col-
umn. After pressing the Enter key twice to move
down this row to the blank cell in B4, I'm all set to
enter the description of the piece given the Code
Number 12-305 (it’s a 36-inch round table).

[ continue along in this manner entering the furni-
ture descriptions down the rest of column B, the
retail prices down column C, and the discount per-
centages down column D. After that, to complete
the table, I click E4 (which collapses the cell selec-
tion to just that cell) and enter the master formula
that calculates the spring sale price (using the
table’s retail price and discount amount), which

[ then copy down the rest of the column using
AutoFill. (See Technique 13.)

Let’s Do It as a Group!

When you select more than one worksheet at a time
(see Technique 10), Excel goes into what is called
Group mode (indicated by the appearance of
[Group] after the filename on the title bar of the
Excel window). When the program is in Group mode,
any entry you make in the active worksheet is also
made in all the other selected sheets.

You can put this Group feature to good use when
building spreadsheets that naturally use multiple
worksheets and which require the same entries in
the same cells of each sheet. For example, suppose
you’re creating a spreadsheet that tracks sales over
the 12 months of the current fiscal year and you
want to put each of the 12 monthly sales tables on a
separate worksheet (because this makes it so much
easier to consolidate their data when you want to
create a table showing the total annual sales). Each
table requires the same row and column headings
and will occupy the same region of cells on its sheet.

Let’s Do It as a Group! 65

Rather than enter all the column and row headings
for the initial sales table on the first worksheet and
then copy these headings to the other 11 worksheets,
a quicker way is to select all 12 worksheets, and then
just by entering the headings in the active worksheet,
you’re also entering them in all the other selected
sheets.

Figure 12-5 illustrates how this works. To begin this
new workbook, I added nine additional worksheets
to the default three. Next, I selected all 12 sheets
(by right-clicking the tab of Sheet1, the active sheet,
and then selecting Select All Sheets on its shortcut
menu). This puts the program into Group mode so
that the common worksheet title and all row head-
ings that you see in this figure are not only entered
into cell B1 and the range A3:A14 in Sheet1 but in all
the other 11 selected sheets as well.

| %] Microsaft Excal - Hookl |Group] .
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Ready
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* Figure 12-5: Entering the same column and row headings
in each of the selected sheets in Group
mode.

Figure 12-6 confirms the fact that Group editing really
works. (I swear no special effects were used in the
taking of this screen shot.) For this figure, I clicked
the tab for Sheet10. Doing this not only immediately
deselected all the other sheets and switched the pro-
gram out of Group mode but instantly revealed that
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this worksheet contains exactly the same headings
that [ entered in Sheetl. (Refer to Figure 12-5.) The
only difference between the two screen shots is that,
before taking Figure 12-6, I had the good sense to
stop and save the workbook so that there was no
danger that I could lose this data and have to go
through this Group editing procedure again.

Selecting another worksheet while in Group
mode immediately deselects all but the new
active worksheet and switches you back into

normal, single-sheet editing mode. Therefore,
don’t stop to check the entries on another
sheet until you've completed all the common
data entry, at which time you can ungroup the
sheets (by right-clicking a sheet tab in the
group and selecting Ungroup Sheets). Then
select the individual sheets to display their
data by selecting their sheet tabs.
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* Figure 12-6: Sheet10 now contains the same entries that |
made in Sheet1 (refer to Figure 12-5) thanks
to Group editing.



Speeding Up Data
Entry with AutoFill

Technique

Save Time By

v~ Filling in commonly used
series

v~ Filling with different
increments

v~ Creating custom fill lists

handy that you wonder how you ever got along without it. Excel’s

AutoFill feature is that kind of spreadsheet innovation for me.
Here, for once, is some Microsoft Intelli-sense that actually does make
some sense because it is a real timesaver.

O nce in a blue moon, a software feature comes along that’s so

With AutoFill, you can fill out a sequential series of entries (such as
months of the year or days of the week) across a row or up or down a
column simply by entering the first entry in the series and then dragging
the cell pointer by its Fill handle — the tiny black square that appears in
the lower-right corner of the active cell. In addition, you can have Excel
increment the entries in the series by values other than just one (be it
one day, one month, or one number). And as if that isn’t enough, Excel
also enables you to create your own custom fill lists that tell Excel how
to fill in a list whenever you enter one of its unique members and then go
for the Fill handle.

All three of these procedures are covered in this technique on AutoFill,
which is undoubtedly one of my favorite Excel features.

You also use this same AutoFill feature to extend formulas in the

tables in your spreadsheet. When using AutoFill to copy formulas, the
feature naturally adjusts its cell references instead of generating a
sequential series — see Technique 24 for details.

Getting Your Fill of AutoFill

Straight out of the box, AutoFill is about as versatile and easy to use as
any Excel feature can be. Table 13-1 shows the kinds of initial entries you
can make — with examples of the kind of series that they generate —
when you drag the Fill handle across or down new cells. As you can see
from the examples shown in this table, Excel can create a fairly wide
array of sequential date and time series as well as some highly individual
ones (for item and code numbers), all of which don’t require you to cus-
tomize the feature whatsoever.
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TaBLE 13-1: SAMPLES OF SERIES YOU CAN GENERATE

wiTH AuToFiLL

Initial Value Series Created by AutoFill in the Next

Three Cells
September October, November, December
Sep Oct, Nov, Dec
Monday Tuesday, Wednesday, Thursday
Fri Sat, Sun, Mon
3/13/1999 3/14/1999, 3/15/1999, 3/16/1999
4-Jan 5-Jan, 6-Jan, 7-Jan
Dec-04 Jan-05, Feb-05, Mar-05
8:00 AM 9:00 AM, 10:00 AM, 11:00 AM
11:03 12:03, 13:03, 14:03
Quarter 1 Quarter 2, Quarter 3, Quarter 4
Qtr4 Qtr1,Qtr 2,Qtr 3
Q2 Q3,Q4, Q1
40 Mill Road 41 Mill Road, 42 Mill Road,

43 Mill Road
’00945 ’00946, '00947,°00948
L17-800 L17-801, L17-802, L17-803

When you drag the Fill handle over the next
- («a cell, you can tell right away what kind of

sequential series your initial entry will gener-
ate. The ToolTip trailing the mouse pointer
shows you right away the next item in the
sequence that Excel is creating.

Figures 13-1 and 13-2 illustrate the use of the AutoFill
feature to generate a sequential series from an initial
entry. In Figure 13-1, | entered January into cell A2
and then dragged the Fill handle down column A
until I reached cell A13. Note that Excel displays a
ToolTip next to the black cross pointer, which indi-
cates that dragging down to cell A13 takes me from
January through July and September all the way to
the month of December.
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* Figure 13-1: Using AutoFill to generate the series of
months from an initial January entry in
cell A2.

Figure 13-2 shows the new worksheet with the 12-
month series after I released the mouse button.
Notice the appearance of the AutoFill Options but-
ton to the right of the Fill handle.
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* Figure 13-2: Series of months created after dragging the
Fill handle down to cell A13 and releasing
the mouse button.



The AutoFill Options button gives you access
to menu options that enable you to convert a
series in the fill range into copies of the initial

value (and vice versa to convert copies into a
filled series) as well as to fill the range with for-
matting only or to fill the series without copy-
ing the formatting of the initial cell. To suppress
the display of this button, deselect the Show
Paste Options check box on the Edit tab of the
Options dialog box (Tools=>Options).

Using AutoFill to generate a sequentially
numbered series

As you may have noticed in the last two examples in
Table 13-1, in initial entries that mix numbers and
text — as in 40 Mill Road — or entries whose num-
bers are entered as labels rather than values — as in
’00945 or L17-800 — Excel is really good at identify-
ing what number to increment.

As a result, you'd probably expect Excel to be an ace
when it comes to generating a sequentially num-
bered series such as 1, 2, 3, 4, and the like (useful in
numbering your data list records so that you can
refer to them and sort them by record number).
Unfortunately, AutoFill falls flat on its face (can a
software feature have a face?) when it comes to
doing this. To prove it, all you have to do is enter the
number 1 in any blank cell and then drag the Fill
handle over just a few blank cells in columns to the
right or below to prove this point: Instead of generat-
ing the simplest of sequentially numbered series
(1,2,3,4...), Excel just stupidly copies the number
1 to all the cells you drag through.

Fortunately, Excel does provide a way to force
AutoFill (however reluctantly) to create a sequential
series from an initial value rather than just copying
it everyplace you drag the Fill handle. The only prob-
lem is that it requires the use of the Ctrl key, which
is used in other mouse operations (cell drag-and-
drop, for instance) to switch to making a copy of the
selected cells or objects. In this case, however,
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Getting Your Fill of AutoFill

depressing the Ctrl key as you drag the Fill handle
prevents Excel from copying the number and forces
it to generate a true sequentially numbered series.

If you, like me, routinely forget to hold down
the Ctrl key and therefore end up with the
same number copied into a range of cells,
select Fill Series on the pop-up menu attached
to the AutoFill Options button (which auto-
matically appears on the cell pointer’s Fill han-
dle as soon as you release the mouse button)
to convert the copies into a bona-fide humeric
sequence, as shown in Figure 13-3.
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* Figure 13-3: Converting a range filled with copies of the
same number into a sequential series.

Copying an entry instead of filling in a series

You can also use the Ctrl key to force Excel to copy
an initial entry in the cell range you drag through in
those situations where Excel would otherwise use
the entry as the starting point for generating a
sequential series. Here, the association of the Ctrl
key with copying in drag-and-drop operations makes
perfect sense (reinforced by the appearance of a tiny
plus sign that appears above and to the right of the
black cross mouse pointer).

Figure 13-4 illustrates how you can force Excel to
copy an initial entry in a cell range rather than use it
to generate a new series. In this new worksheet, |
entered the column heading Module 5 in cell A2. To
copy this heading across row 2 to the cell range
B2:D2 (rather than generate the series Module 5,
Module 6, Module 7, and Module 8), [ hold down the
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Ctrl key as I drag the Fill handle through this range.
Note the presence of the plus sign above the black
cross mouse pointer, here correctly indicating that
Excel will make a copy rather than generate a series.
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¢ Figure 13-4: Pressing Ctrl while dragging the Fill handle
to force Excel to make copies rather than
generate a series.

You don't have to press the Ctrl key before
you drag the range of cells. You can convert a
filled range into copies of the initial cell value
by pressing Ctrl after you've selected the fill
range as long as it's before you release the
mouse button. After that, you have to click the
AutoFill Options button and select Copy Cells
on its pop-up menu to make this conversion.

Incrementally Speaking

As you may have noticed, whenever Excel gener-
ates a series from an initial entry, it automatically
increases the series by an increment of one (be it

by one day, one month, one hour, one minute, one
widget, you name it). Fortunately, the AutoFill feature
is very teachable so that you aren’t stuck with always
generating a series that increases the base value by
one. As long as you provide at least two entries that
exemplify how many units Excel is to increase (or
decrease) the entries in the series, you can generate
series with almost any kind of increments.

Figure 13-5 illustrates how you generate a series that
uses an increment other than one unit. In this exam-
ple, the increment is three, so Excel generates a
series that enters every third monthbeginnig with
June. To do this, I have to enter two samples: Jun in
cell A2 and Sep in cell B2. (This gives Excel the idea

to increment the months by three units rather than
one.) With that out of the way, [ select both cells A2
and B2 and then drag the Fill handle to the right to
cell D2. As you can see from the ToolTip that
appears to the left of the black cross pointer in this
figure, Excel will enter Mar in cell D2. If I release the
mouse button at this point, Excel will generate the
series Jun, Sep, Dec, Mar in the cell range A2:D2.
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¢ Figure 13-5: Generating a series that uses every third
month as its increment.

Well, what about a sequential series that decreases
rather than increases (in other words, one that uses
a negative increment)? To generate this kind of
series with AutoFill, all you have to do is enter the
larger value in the first cell of the range to be filled,
the smaller value (the one that exemplifies the nega-
tive increment) in the next cell (either in the cell in
the column to the right if you want to generate the
series across the row or in the row below if you want
to generate it down the column). Select both cells —
the one with the entry showing the starting value
and the next one showing the amount of decrease —
and then drag the Fill handle to extend the series as
far as you want to go.

For example, suppose | want to create a numerical
series going down column A — starting in cell A2 with
a value of 1000 — that decreases by 100 units in each
cell below. To generate this decreasing series, you
enter 1000 in cell A2 and 900 in cell A3. Then select
the range A2:A3 before you drag the Fill handle down
the rows of the column. Excel then enters 800 in cell
A4, 700 in cell A5, 600 in cell A6, and so on. (Note
that when you select the cells that demonstrate the
increment to use, Excel knows right away that you
want to generate a series, even when your entries
are purely numerical.)
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Excel is quite capable of generating a new series on
its own when the initial entry in the series (or first
two entries, when using an increment besides one)
contains a numerical component that it can increase
or decrease. However, to have the program generate
a series containing no numerical elements (such as
the days of the week: Monday, Tuesday, Wednesday,
and so on), Excel needs to know beforehand all the
items in the series and their order.

To do this, you create a custom list. When creating a
custom list, you can have Excel generate it from a
cell range in a worksheet that already contains the
items, or you can enter the items manually. | suggest
that you have Excel create a new list from existing
entries in the spreadsheet whenever possible. That
way, you have a chance to proof the entries in the
worksheet before you turn them into a custom list.

To create a custom list from existing worksheet
entries, follow these steps:

1. Enter the entries for the custom list in their
proper sequence down a column or across a
row of the active worksheet.

2. Select the cell range containing the entries for
the custom list.

3. Choose Tools=>Options to open the Options
dialog box and then select the Custom Lists tab.

When you open the Custom Lists tab after select-
ing the cell range with these entries, this cell
range (in absolute values) appears in the Import
List from Cells text box. If this range is not cor-
rect or you forgot to select it before opening the
Options dialog box, click in this text box and
then select the range in the worksheet. (Excel
automatically collapses the Options dialog box
as you drag through the cells.)

4, Click the Import button.

As soon as you click Import, Excel adds the list
to the Custom Lists pane on the left and displays
all its entries in the List Entries pane on the
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right, as shown in Figure 13-6. You can then edit
the individual entries in the List Entries box if
necessary. (This is where you would type the
entries for a new list that you create from
scratch before clicking the Add button.)

5. Click OK to close the Options dialog box.

After creating a custom list, you can then generate
the list across any row or up or down any column
simply by entering the initial entry in a cell and then
dragging the Fill handle in one of the four directions.
Figure 13-7 illustrates how this works. Here, I gener-
ated the custom list of cities created earlier from a
range of cell entries (refer to Figure 13-6) in a new
worksheet by entering the first city (Seattle) in cell
A2 and then dragging the Fill handle to cell F2.
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¢ Figure 13-6: Creating a custom AutofFill list from a range
of existing entries.
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* Figure 13-7: Generating the series of cities across row 2.



Ensuring Accurate
Data Entries with

Teéhnique  Data Validation

Save Time By

1~ Setting up data validation
criteria

v~ Creating input messages

v~ Using error alerts

run, great timesaving feature that Excel calls data validation. You

use this nifty feature to prevent the users of your spreadsheets
from ever getting a chance to enter the wrong type of data entry or a
type that’s not on your list (when dealing with labels) or within a tolera-
ble range (when dealing with numbers) in critical cells of its worksheets.

This technique acquaints you with a very versatile and, in the long

Not only can you restrict the types of data entries that you or any other
spreadsheet user can make, you can also add input messages to your val-
idated cells that indicate what types of entries are permissible there. As
if this weren’t enough, you can also tag the validated cells with error
alerts that flash an alert symbol along with a custom message indicating
the data entry rules for the current cell!

Only the Valid Need Apply

The heart and soul of the data validation feature is the Settings tab of the
Data Validation dialog box (Data=>Validation). The Settings tab, shown in
Figure 14-1, is where you specify the criteria under which Excel considers
any data entry made in the current cell to be kosher.

The first control on the Settings tab is the Allow drop-down list box. By
default, this box is set to Any Value to allow you to do any type of data
entry in the current cell. To change all that anything-goes stuff by making
only a certain type of entry permissible, select one of the other Allow
options:

v Whole Number restricts data entry to a whole number that is equal to,
greater than, less than, or within a range of numbers that you then
specify.

v Decimal restricts data entry to a decimal number that is equal to,
greater than, less than, or within a range of values that you then
specify.



Data Validation

Input Message || Error Alert

Walidation criteria

Allaw:

| Any walue »
Data:

[ QoK ] [ Cancel I
¢ Figure 14-1: The Settings tab of the Data Validation
dialog box is where you set the validation
criteria.

v List restricts data entry to one of the items on a
list (whose items must already have been entered
in a range of cells in the worksheet). When using
this Allow option, Excel enables you to create
an in-cell drop-down list (with its very own tiny
drop-down button) from which you or your users
can select the entry.

v Date restricts data entry to a date that is equal
to, before, after, or within a range of dates that
you then specify.

v Time restricts data entry to a time that is equal
to, before, after, or within a range of times that
you then specify.

v Text Length restricts data entry to a number of
characters that is equal to, greater than, less
than, or within a range of numbers that you then
specify.

v Custom restricts data entry to the parameters
specified by a Logical formula (one that evalu-
ates to TRUE for allowable entries or FALSE for
invalid ones) that’s already been entered into a
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cell of the worksheet to which you then refer.
(See Technique 15 for an example of data valida-
tion using the Custom setting.)

By default, all data validation settings regard
blank cells as valid. If you want to prevent
users from leaving a cell blank, while at the
same time making their entries conform to
your other data validation criteria, clear the
Ignore Blank check box on the Settings tab.

Data entries from a list

Enabling users to do data entry by selecting the data
from an in-cell drop-down list is one of the most pop-
ular uses for the data validation feature. Not only
does this type of data validation prevent users from
selecting an invalid entry, but it also enables them to
make a correct entry without having to do any typing.

Figures 14-2 and 14-3 illustrate how you would use
the data validation List setting to create an in-

cell drop-down list. In Figure 14-2, I started a new
worksheet by entering a list of cities in cell range
J2:J7 (with the help of the AutoFill feature — see
Technique 13). This list represents the only valid
entries for the City column of my new Account Rep
Assignments table.
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* Figure 14-2: Setting up a list of valid city entries for the
new table of account rep assignments.
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To use the data validation List setting to restrict the
data entry in this new table to any of the cities on
this list, [ then followed these steps:

1. Position the cell pointer in the first blank cell
to use this data validation setting (B3 in this
example).

2. Choose Datar>Validation to open the Data
Validation dialog box with the Settings tab
selected.

3. Select List in the Allow drop-down list box.

4. Putthe Insertion point in the Source text box
and then drag through the range of cells con-
taining the list of valid entries (J3:J7 in this
case).

Because Excel automatically selects the In-cell
Dropdown check box, the program will add a
drop-down button that reveals this list of cities
whenever the user selects the cell.

To force users to select one of the cities —
making it invalid to leave the cell blank — clear
the Ignore Blank check box.

5. Click OK to close the Data Validation dialog box.

After the Data Validation dialog box closes, Excel
adds a drop-down button to the right side of the cur-
rent cell. To select one of the cities on the list from
its menu, click this button and then click the name of
the city to enter in cell B3, as shown in Figure 14-3.
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* Figure 14-3: Selecting a city from the cell’s new
drop-down list.

Copying data validation settings

After assigning your data validation criteria to a par-
ticular cell, you can then copy these criteria to all
the cells in the vicinity that need to use the same
restrictions. To do this, you follow these steps:

1. Copy the cell with the data validation to the
Clipboard.
(Choose Edit=>Copy or press Ctrl+C.)

2. Select the cell range into which to copy the
data validation criteria.

3. Choose Edit->Paste Special or to open the Paste
Special dialog box.

4, Click the Validation option button (see
Figure 14-4) and click OK.
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Select destination and press ENTER. or choose Paste

column with Paste Special.

For example, to copy the data validation criteria that
cause the cell to display the cities drop-down list
box from the original cell B3 down the column to

the range B4:B15, I copied the contents of B3 to the
Clipboard and then selected the range B4:B15. Next,
[ opened the Paste Special dialog box, clicked the
Validation option button, and clicked OK. As a result,



all the cells from B3 down B15 use the same data val-
idation criteria. When you put the cell pointer in any
of those cells, a drop-down button appears on the
right side of the cell. When clicked, this button
reveals the city drop-down list.

Finding cells using data validation

Most data validation settings that you assign to cells
are invisible. (Okay, the List setting may be the
exception here, but even the List setting is invisible
when the cell pointer isn’t in the cell.) To help you
locate the cells in the active worksheet that use
some sort of data validation criteria, you can use the
Go To feature to find (and select) them:

1. Press F5 or Ctrl+G to open the Go To dialog box.

2. Click the Special button to open the Go To
Special dialog box.

3. Click the Data Validation option button and
click OK, as shown in Figure 14-5.

o "y
Go To Special
Seleck
() Comments () Row differences
() Constants {3 Column differences
) Formulas () Precedents

() Dependents

{3 Last cell
{3 Blanks ) Yisible cells only
() Current region () Conditional formats

() Current array

() Objects

(=) all

L) Same

| (0] %J I Cancel

¢ Figure 14-5: Finding all the cells in the worksheet that use
data validation.
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Because the All option button underneath the
Data Validation option is automatically selected
by default, Excel selects all the cells and cell
ranges in the worksheet that have some type of
data validation criteria assigned to them.

4. Use the Enter or Tab key to move the cell
pointer around the selection from cell to cell
and from cell range to cell range.

5. To find out what type of data validation a par-
ticular cell in the selected range uses, choose
Datac>Validation and check out its criteria on
the Settings tab.

types of data validation settings, you can find
all the cells that use the same criteria. To do so,
position the cell pointer in a cell that you know
uses the criteria you want to find, open the

Go To Special dialog box, click both the

Data Validation and Same option buttons,

and click OK.

2 In a spreadsheet that uses many different
E)

Information Please!

The only problem with data validation is that
because it’s invisible to spreadsheet users, many
times the only way they know they’ve hit a cell that
uses it is when they try to make what the cell now
considers an invalid entry. When anybody tries to
complete an entry with text or a value that is ver-
boten in the cell, Excel beeps at them and then dis-
plays an alert dialog box with the following
unhelpful message:

The value you entered is not valid.
A user has restricted the value that can
be entered into this cell.

The user can then click the Retry button and try to
put something in the cell that Excel does find accept-
able, or he or she can click the Cancel button and
forget the whole thing.
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To give users a fighting chance at rectifying their
error by making an acceptable entry in the cell, I
heavily suggest (actually, 'm begging you on bended
knee) that you assign an input message to the cell
explaining to the poor user what kind of entry is now
valid. To do this, open the Data Validation dialog

box (Dataw>Validation) and then click the Input
Message tab.

There, you can enter a title for the message in the
Title text box (this appears in bold at the top of the
text box displaying the input message) as well as the
explanatory message text you want displayed in the
Input Message list box, as shown in Figure 14-6.

Data Validation

Settings | Input Message | Error Alert

Shows input message when cell is selected
when cell is selected, show this input message:
Title:
‘Whiole Mumber Input
Input message:
Please enter a number between 5 and 15,

oy Lo

* Figure 14-6: Adding an input message explaining to the
user the data validation settings in effect in
cell A2.

Figure 14-7 shows you how the input message
explaining the data validation settings in cell A2
(see Figure 14-6) appears when the cell pointer is in
this cell. Now, there’s no excuse for the user not
knowing what entries are allowed in this cell.
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¢ Figure 14-7: Text box with input message that appears
when the user selects cell A2.

Warnings to Make Them Wary

As the old saying goes, “You can lead a horse to
water, but you can’t make him drink.” Sometimes,
flashing an input message just isn’t enough to keep
users on the right path. (The numb nuts go ahead
and still try to enter forbidden data.) If you're in dan-
ger of this happening, it’s time to bring out the heavy
artillery by adding an error alert message as well.
(You can always forgo the input message and just
add the error alert message letting users know
exactly what kind of behavior will and won’t be toler-
ated in that cell.)

To add an error alert message that appears when-
ever the user tries to make an entry that violates the
cell’s data validation criteria, open the Data
Validation dialog box and select the Error Alert tab,
shown in Figure 14-8. The settings on this tab enable
you to

v Select a type of indicator to display in the alert
dialog box (Stop, Warning, or Information) from
the Styles drop-down list box.

v Enter atitle for the warning in the Title text box
(which appears in bold in the title bar of the cus-
tom alert dialog box).

v Type the text of the message in the Error
Message list box (which appears in the body of
the alert dialog box).



Data Validation

Settings 1 Input Message

Iv Show error alert after invalid data is entered
When user enters invalid data, show this error alert:

Skyles Title:

[stop | [THIS ENTRY 15 YERBGTEN!

N Error message:
Entry must be na less than 5 and no greater
than 15,
Also, no decimal places are allowed:
Only whole numbers please!

Clear All ok Cancel

L

* Figure 14-8: Adding a warning message that appears in
place of the standard alert dialog box.

Don't select the Warning or Information type
of error alert message unless you want it to be
possible for your users to sidestep the valida-

tion settings and enter invalid data in the cell.
(The Warning type allows this with its Yes but-
ton and the Information type with its OK but-
ton.) Only the default Stop type prevents users
from going ahead and making invalid entries
in the cell.
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After adding an error alert message, whenever the
user tries to enter something outside the bounds set
by the cell’s data validation settings, Excels beeps at
them and then displays your custom error alert dia-
log box. Figure 14-9 shows you how the custom error
alert dialog box (defined in Figure 14-8) appears
when you try to enter an invalid number (in this
case, any whole number less than 5 or greater than
15 or any decimal number at all). When this Stop
type of error alert appears, your users have two
choices:

v Click Retry to have another go at entering the
data (in hopes that the user can get it right this
time).

v Click Cancel to clear the aberrant entry from the
cell (and thus forget about the whole thing).

THIS ENTRY IS VERBOTEN!

Also, no decimal places are allowed:

@ Entry must be no less than 5 and no greater than 15,
Only whole numbers please!

Canicel

* Figure 14-9: Custom alert dialog box that appears when
the user attempts to make an invalid entry.




All Aboard the
Numerical Entry

Technique Express!

Save Time By

v~ Using the numerical
keypad

v~ Fixing your decimal
places

+” Restricting data entry to
numbers only

because they don’t get there by magic, it behooves you to know all

the tricks of the trade for entering them as efficiently as possible.
The first trick is the most obvious — use your computer’s 10-key pad (or
the equivalent thereof) to make all your numerical entries. The second
trick is to let Excel set the decimal places in your numerical entries that
all use a set number of places (that way, you can concentrate on just
entering the correct digits). The third trick is not to allow any errant text
entries into a cell range that should only contain numbers.

Numbers, numbers, numbers. Spreadsheets are full of them, and

Taking Advantage of the Numeric Keypad

Seeing that pressing the Enter key automatically advances the cell
pointer to a new cell in the next row down — conveniently getting you in
place for your next entry — I don’t see that you have any excuse for not
entering ranges of numerical entries from your keyboard’s numeric key-
pad. (After all, your keypad does have an Enter key nearby even if it’s
embedded in the standard keyboard, as is the case on almost all lap-
tops.) When it comes to entering spreadsheet numbers with any speed,
using the number keys along the top row of the standard QWERTY key-
board just doesn’t cut it.

Unfortunately, the numeric keypad on your computer is not really the
equivalent of the old adding machine’s 10-key number pad. On the com-
puter keyboard, the keypad mostly does double-duty with other keys
(cursor keys when the pad stands apart from the standard keyboard, and
other letter and punctuation keys when it’'s embedded within the key-
board itself).

As a result of this double functioning, you have to engage the numeric
keypad in Excel by pressing the Num Lock key before you can use the
pad to enter your spreadsheet numbers. This locks in the number func-
tion and simultaneously locks out the secondary cursor or letter-key
function. (Excel lets you know when the number function is engaged by
displaying the NUM indicator on the status bar.)



tus bar before using the numeric keypad. That
way, you save yourself from a lot of wasted
time and unnecessary aggravation that comes
from entering errant letters and punctuation in
it or from having the cell pointer move off the
cell.

If you're using a laptop computer, you may
@ have to do more than just engage Num Lock
to produce humbers from your embedded

numeric keypad. Some laptops also make you
hold down a special Fn (Function) key to acti-
vate the numeric pad.

z Always look for the NUM indicator on the sta-
<

&

Putting the Decimal Places
at Your Service

Remember to use the Fixed Decimal setting when
you need to do heavy-duty numerical data entry in a
spreadsheet. When you turn on this setting, Excel
automatically enters a decimal point using the num-
ber of decimal spaces you specify for numeric
entries. This speeds up your numeric data entry
enormously (especially when you’re doing the data
entry from the keyboard’s numeric keypad) because
you no longer have to take time to type the period
for the decimal point (you just type digits and press
Enter).

To toggle on the Fixed Decimal setting, follow these
steps:

1. Choose Tools->Options to open the Options
dialog box.

2. On the Edit tab, select the Fixed Decimal check
box, as shown in Figure 15-1.

The moment you activate the Fixed Decimal
check box, the Places text box below and to its
right becomes available.

3. Specify the number of decimal places that you
want Excel to fix in all the numbers you enter.
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Settings

Edit directly in cell
Allaw cell drag and drap

Alert before overwriting cells
Move selection after Enter

Extend data range formats and Formulas
Enable automatic percent entry

Show Paste Options buktons
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Direction: Down |
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Places: P
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* Figure 15-1: Fixing the number of decimal places in all
numerical entries.

By default, the Places text box selects 2 as the
number of decimal places to fix in your numbers
(which makes sense given that much numeric
data entry represents financial figures in dollars
and cents). To modify the number of decimal
places, enter a new value in the Places text box
(between -300 and 300) or use its spinner but-
tons to select it.

4. Click OK to close the Options dialog box.

[ Enter a negative number in the Places text
(«a box to have Excel pad the digits you type with
trailing zeros equal to this number’s absolute
value. For example, enter -2 in the Places text
box to have all your entries automatically
increased by a factor of 100. (For example, if
you type 789, Excel enters 78900 in the cell.)

é

Excel lets you know when the Fixed Decimal setting
is turned on by displaying FIX on the far right of the
Status bar. While this setting is active, the only time
you have to be concerned with decimal points is

when the numbers you're entering don’t conform to
the number of decimal places you set. For example,
if you use the two-decimal-place default for entering
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financial figures in the worksheet, you enter all stan-
dard dollar-and-cents numbers simply by typing
their digits. (For example, you enter the value
$150.24 into a cell by typing the digits 15024 and
then pressing Enter — don’t you dare take time to
type a dollar sign.)

When, however, you come upon a whole dollar
amount that has zero cents and therefore doesn’t
really require any decimal places (they’re purely
optional), you have to make a choice. Either you can
tell Excel where to put the decimal place or end up
entering extra trailing zeros. Suppose that you need
to enter the value $200.00 and the Fixed Decimal set-
ting with the default two decimal places in turned
on. If you type 200 in the current cell, Excel reduces
it to 2 when you press Enter. To get the program to
put 200 in the cell, either you have to type 200 and
then press the period (.) key before Enter, or you
have to type 20000 (which looks nothing like the
value $200.00).

Don't forget to turn off the Fixed Decimal set-
ting (by clearing its check box on the Edit tab
of the Options dialog box) as soon as you fin-

ish with your numeric data entry marathon.
Otherwise, you or a coworker may be com-
pletely thrown off when Excel stubbornly
refuses to enter your numbers as you type
them!

Number Please!

When it comes to numerical data entry, efficiency is
key — but not if it comes at the expense of accuracy.
This procedure covers a way that you can use the
data validation feature (see Technique 14 for details)
to make it impossible for users to enter anything but
numerical entries in a cell range. The downside of
adding this type of data entry safeguard is that it can
possibly stop the flow of your data entry cold. The
upside is that you don’t have to worry about errant
punctuation and letter keystrokes converting cell
entries into text that later spawns error values in for-
mulas that reference those cells.

Technique 15: All Aboard the Numerical Entry Express!

To ensure numerical data entry, you need to use
Excel’s ISNUMBER function in a formula as part of a
Custom type of data validation setting. ISNUMBER is
an Information-type function that returns a logical
TRUE value when its argument is numerical and a
logical FALSE value when it’s not numerical. This
function uses the following syntax:

=ISNUMBER(value)

Whenever the ISNUMBER function returns a TRUE
value as a part of a Custom-type data validation set-
ting, Excel finds the data entry to be valid and allows
the data entry. However, whenever the function
returns a FALSE value, the program finds the entry to
be invalid and rejects the data entry.

Figures 15-2 through 15-4 illustrate how you set up
this type of numerical data validation for a cell range
in your spreadsheet. For this example, [ want to
inoculate the cell range C4:E9 with this type of pro-
tection. This range contains all the numerical values
in my little sales table.

[ start this process by selecting cell C4, the first cell
of the range to be protected. It’s here that I define
the numerical data validation that I then copy with
Paste Special to the rest of the range:

1. Choose Data~>Validation to open the Data
Validation dialog box.

2. On the Settings tab, select Custom in the Allow
drop-down list.

3. In the Formula text box, type =ISNUMBER (and
then click cell C4 to enter it as the argument
before typing a close parenthesis [)] to close off
the function. (See Figure 15-2))

For this data validation setting, you don’t need to
add an input message. (Here, you already know
what kind of entry you intend to make.) All you
need to add is a custom error alert message that
helps the user identify the nature of his or her
error.

4. Select the Error Alert tab.
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* Figure 15-2: Setting up a custom validation formula that
rejects anything but numerical entries.

5. Leave the default Stop style selected, enter a
heading for the message’s title in the Title text
box, and enter the text for the message in the
Error Message list box. (See Figure 15-3.)

6. Click OK to close the Data Validation
dialog box.

Before copying the Custom data validation setting to
other cells in the range, you need to test it out and
make sure that it’s truly bulletproof when it comes
to text entries. Figure 15-4 shows you what hap-
pened when I tried to enter my name in cell C4.
When testing the cell, be sure to try entering all man-
ner of numerical entries (whole numbers, decimal
numbers, negative numbers, and zero). Also try to
sneak a value in as text in the cell (as you might do
when entering zip codes and the like) by prefacing
the digits with an apostrophe ().

When you’re convinced that your data validation
setting is airtight, you can copy the setting to all
the other cells in the range where you intend to do
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Number Please!

numerical data entry. To do this, you first copy the
cell with the original data validation setting to the
Clipboard (Ctrl+C) and then select the cell range
(C4:E9 in my example). Finally, you click the
Validation option button in the Paste Special dialog
box (Edit=>Paste Special) and then click OK.

Data Validation

Settings_ In_|_:-ut Messa_ge

Show error alert after invalid data is entered
When user enters invalid data, show this error alert;
Style: Title:

|stop || [HUMEER PLEASE!

Q

Error message:

Verify entry bo ensure that it's purely
| nurnerical
Check for stray lettes and punctuation.

[ Ok N[ Cancel
L

¢ Figure 15-3: Adding an error alert to the numeric custom
data validation setting.
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* Figure 15-4: lllegal text entry foiled by the numeric
custom data validation settings.



Verifying Entries
with Text to Speech

Technique

Save Time By

v~ Using Speak on Enter as
you make data entries

v~ Having the computer read
back entries in a cell
range

v~ Selecting the perfect
voice and speed

help you through the drudgery of checking and verifying the accu-

racy of your data entries. By using Text to Speech, you can have
your computer read out loud your data entries either as you make them
or afterwards. As you listen to the computer read the data entries, you
can check the hard copy from which they came to ensure that you
haven’t made any typos. If you notice a discrepancy between a spoken
data entry and what’s on the paper copy, you can stop Text to Speech
and make the necessary corrections before continuing with the reading.

Excel includes a powerful feature known as Text to Speech that can

To use the Text to Speech feature, your computer must be equipped with
a sound card and have access to speakers or headphones (minimal
requirements that I'll bet every computer that can run Excel 2003 can
easily meet). Note that you can use Text to Speech without having
installed and set up Excel’s Speech Recognition feature for entering data
entries by voice and issuing voice commands.

“Can You Hear Me Now?"”

To use the Text to Speech feature, choose Tools=>Speech=>Show Text to
Speech Toolbar. If the Text to Speech feature isn’t already installed on
your computer, Excel asks if you want to install this feature. You then
follow the prompts to install this feature. (Make sure that you have the
Office 11 CD-ROM handy when you do this or make sure that you can
provide the Windows Installer with the path to the Office program files
on your network.) When Text to Speech is installed, Excel displays the
Text to Speech toolbar, shown in Figure 16-1.
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* Figure 16-1: Use the tools on the Text to Speech toolbar
to verify the data entries you make.

Speak on Enter

One of the most effective ways to use Text to Speech
is its Speak on Enter mode. When you click the
Speak on Enter button on the Text to Speech toolbar,
the Text to Speech feature reads every data entry
you make back to you. (The program actually says
the words, “Cells will now be spoken on Enter,” the
moment you click this button.)

When the program is in this speaking mode, the Text
to Speech feature speaks every data entry you com-
plete. Note that, in the world of Excel, “complete” in
this case means you've either pressed the Enter key
or pressed a cursor-movement key such as an arrow
key, Tab, or Page Down. The feature does not speak
the entry if you complete it by clicking the Enter
button on the Formula bar.

Note that the Speak on Enter button is a toggle; you
turn off this speaking mode by clicking the button a
second time. When you click the button to turn
Speak on Enter mode off, Text to Speech says,
“Turn off Speak on Enter.”

Reading by columns and rows

Text to Speech is not just useful when entering new
data in your spreadsheet. You can also use it to ver-
ify the accuracy of ranges that have already been
entered into a worksheet. To have the program read
back the entries in a cell range, follow these steps:
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1. Position the cell pointer in the first cell of the
range whose values you want to verify with
Text to Speech.

2. If the Text to Speech toolbar is not displayed in
Excel, choose Tools=>Speechr>Show Text to
Speech Toolbar.

3. Click the Speak Cells button (the first one) in
the Text to Speech toolbar.

As soon as you click this button, Excel automati-
cally selects all the cells it can identify as a single
range in the region around the cell pointer. It
then starts reading the entries out loud across
the rows of the range as it moves down the
columns.

4. (Optional) To change Text to Speech’s direction
from across rows to up and down columns,
click the By Columns button.

If you catch a mistake, click the Speak Cells button
to temporarily halt the reading of the rest of the
range and then move the cell pointer to the appro-
priate cell and edit its contents. To resume reading
the remaining cells in the range, click the Speak Cells
button again.

Don't use the arrow keys to move the cell
pointer, or you'll collapse the cell selection,
reducing it from the current range down to

the current cell. Instead use Tab, Shift+Tab,
Enter, or Shift+Enter to move the cell pointer
and to complete the cell edit. (Refer to Table
12-1 for more on using Tab, Shift+Tab, Enter,
or Shift+Enter to move the cell pointer.)

When Excel reaches the last cell in the selected
range and reads its contents, Text to Speech auto-
matically stops and takes the program out of Speak
Cells mode. If you want to turn off Text to Speech
before it reaches the last cell, click the Stop
Speaking button.
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Modifying the Text
to Speech Settings

When using Text to Speech, you can modify the
speaking voice used as well as the speed at which
the program reads your data entries. To change
these Text to Speech settings, follow these steps:

1. Click the Start button on the Windows taskbar
and then select Control Panel.

2. Ifyou’re in Category view, click the Sounds,
Speech, and Audio Devices link and then click
the Speech link. Otherwise, in Classic view,
double-click the Speech icon.

3. Select the Text to Speech tab in the Speech
Properties dialog box. (See Figure 16-2.)

Speech Properties 2]

Speech Fecogniion | Text ToSpesch

2 2: *r'ou can control the voice properties, speed, and other options for
2%{ text-to-speech translation

Woice selection

LH Michas! ™

Usze the following text ta preview the voice:

|Y0u have selected LH Michael as the computer's default voice.

“oice speed
3
Slowy Marmal Fast
[ Ok J I Cancel ] I Apply ‘

¢ Figure 16-2: Selecting the voice and specifying the speed
for Text to Speech.

4. Select the name of the voice that you want to
use from the Voice Selection drop-down list.

You can select LH Michael, LH Michelle, or
Microsoft Sam as the voice. LH stands for Lerned
and Hauspie (the creator of Michael’s and
Michelle’s voices). To me, LH Michael sounds
like the voice used by the eminent physicist,
Stephen Hawking, and LH Michelle sounds like
the female equivalent of that voice. And
Microsoft Sam sounds like the voice of HAL 9000
in Stanley Kubrick’s 2001: A Space Odyssey, when
Dave was disconnecting his memory circuits!

5. Select the Use the Following Text to Preview
the Voice text box and then edit the text that
you want the voice to say to you.

For example, when previewing the Microsoft Sam
voice, you can enter the text whether “I'm afraid

Dave. Dave, I'm afraid,” to see whether you think
this voice sounds like HAL 9000 as well.

6. Click the Preview Voice button to have the
voice that you selected read back the text
shown in the Use the Following Text to Preview
the Voice text box.

7. If you want to adjust the voice speed, drag the
Voice Speed slider toward Slow or Fast to either
slow down the speaking or speed it up.

After adjusting the speed, be sure to click the
Preview Voice button again to make sure that
you haven’t slowed or sped up the rate of speak-
ing too much.

If you drag the slider toward Slow when the
Microsoft Sam voice is selected, you definitely
have a dead ringer for HAL 9000 in his famous
disconnection scene.

8. Click OK to close the Speech Properties dialog
box and then click the Close button in the
Sounds, Speech, and Audio Devices window to
close it.
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Instant Range
Formatting

Technique

Save Time By

v Applying an AutoFormat
to your table of data

v~ Using the Format Painter
to copy a format

v~ Cutting and pasting
formats

building a new spreadsheet, you don’t stop to take the time to

assign formats to the data entries you make (by typing dollar
signs, commas, and the like). Instead, you enter all the raw data and then
assign the required formatting to the various cell ranges.

R ight after data entry comes formatting. As I hope you know, when

When formatting cells in a standard table of data, you can usually rely on
the AutoFormat feature to apply the various types of formatting to all the
different elements in one fast-and-easy operation. When formatting indi-
vidual ranges of cells that aren’t part of a standard table of data, you can
use Excel’s handy-dandy Format Painter to quickly copy an existing format
to unformatted ranges that need it. Finally, you can preformat a blank cell
range by copying just the formatting assigned to any formatted cell and
pasting that formatting into the cell range.

Head-to-Toe Table Formatting
with AutoFormat

Using Excel’s AutoFormat feature to format a table of data is a real no-
brainer. Simply position the cell pointer in any cell of the table and
choose Format=>AutoFormat to open the AutoFormat dialog box, shown
in Figure 17-1. Excel then automatically selects all the cells in the table
(including the one with the table’s title). All you have to do is select the
table format in the AutoFormat dialog box that you want to apply to the
selected range and then click OK.

The list box in the AutoFormat dialog box offers 16 distinct table formats
from which you can choose. Excel gives descriptive names to these table
formats, which are arranged by category in two columns in this list box.
At the very bottom of the list box, you find a None table format that you
can select to remove any previously selected table formatting from the
selected range.
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to the table in the cell range A2:E9, it formats the
table and column headings and the financial data in
columns C, D, and E, as well as widens columns B
through E using its AutoFit feature. Unfortunately,
the program misapplied the Currency and Comma
Style number formats to the Discount data in the
range D4:D9. Because AutoFormat couldn’t tell that
these numbers represent percentages and not dol-
lars and cents, I still need to apply the Percent Style
number format to this range.

. Fugure 17-1: Selecting the table format to apply to the
selected table of data.

When choosing the table format to apply to the cell
range containing your data, use the thumbnails of
the different formats as a guide. These thumbnails
attempt to show what alignment, attributes (such as
bold or italics), number formatting, borders, and
patterns will be applied to the selected cell range.
Also, all the table formats (except for None) auto-
matically widen the columns and heighten the rows
of the table as needed to display all the data after
applying these various attributes to their cells.

The None table format removes all formatting
from the cells of the table, including any attrib-
utes manually assigned to individual cells or

cell ranges prior to applying table formats with
AutoFormat. Selecting None does not, however,
restore column widths that Excel changed as
part of previously selecting one of the other
table formats.

Figure 17-2 shows how the furniture sales price table
(shown selected in Figure 17-1) appears after applying
the Accounting 1 table format to its cells. As you can
see in this figure, when Excel applies this formatting

(=] Mi ft Excel - Spring sale-uf.xls
- :ed] File Edit View Insert Format Tools Data Window Help Adg
E S =T VE TN T R -1
- e Spnng Sale Fumniture Prices
BROED NN DA s A ] B C D E F
1
2 |Spring Shle Furniture Prices
3 |Code Descrlptson Retail Price.  Discoun! Sales Price
4 512-305 36-inch round table % 125000 § 025 § 93750
5 i12-240 72-inch dining table 1,400.00 0.25 1.050.00
6 [14-356  Hutch 2,500,00 025 187500
7 |10-234 Side chair 350.00 0.15 297 .50
8 213-033 Arm chair 500.00 0.15 42500
9 |13-240  Armair 1,750.00 025 131240
10
11

¢ Figure 17-2: Furniture sales price table automatically
formatted with the Accounting 1 table
format.

Excel makes it easy to customize any of its 16 built-in
table formats:

1. Click the Options button in the AutoFormat dia-
log box.

The dialog box expands to display individual
check box format options in the Formats to
Apply area along the bottom.

2. To customize a particular table format, select
its thumbnail in the AutoFormat list box and
then clear all the individual format check
boxes in the Formats to Apply area that you
don’t want to use.

For example, in Figure 17-3 | selected Classic 3
table format and then removed its borders by
clearing the Border check box in the Formats to
Apply area.
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¢ Figure 17-3: Customizing a table format by limiting which
formats it applies.

Getting Artistic with
the Format Painter

AutoFormat is perfect for those times when you have
a discrete table of data that needs formatting and you
want to use one of its prefab table formats through-
out. For the other times when you just need to apply
a few different attributes to a cell range or two, seri-
ously consider using the Format Painter to get the job
done. As the name implies, the Format Painter enables
you to copy the formatting from one prototypical cell
to all the others that you drag through — in essence
painting them with all its attributes.

Oh that all painting were as easy as painting with
the Format Painter! The steps for copying a cell’s
formatting are as simple as can be:

89

Getting Artistic with the Format Painter

1. Select the cell that already contains the format-
ting that you want to copy.

This cell can be manually formatted with several
different attributes such a new cell alignment,
font attribute, and number format.

2. Click the Format Painter button on the Standard
toolbar (the one with the paintbrush icon).

After you click the Format Painter button, Excel
displays a marquee in the cell pointer in the cur-
rent cell, and a paintbrush icon appears next to
the white cross mouse pointer, as shown in

Figure 17-4.
%] Microsoft Excel - Spring sale.uf.xls
4] File Edit View Inset Format Tools Data Window Help Add
ARG WS TP NN W TR, R[] [ AR N6 e ]|
: el =10 Bzl |mEERES % o 8 E
" e R —
A B C 0 E F

1

2 |Spring Sale Furniture Prices

3 |Code  Description Retail Price Discount  Sales Price

4 [12.305 Fe-inch round table  § 125000 25%1% 9370

5 12240  72inch dining table 140000 caA025 105000

B |14-356  Hutch 2 500.00 025 187500

7 [10-234  Side chair 35000 015 297 50

B [13.003  Asm chair 500.00 0.15 42500

9 13240 Amoir 1,750.00 0.3 13280

0]

1

¢ Figure 17-4: Using the Format Painter to copy all the
formatting applied to a cell.

3. Drag through the cells to which you want to
apply the same formatting as in the current
cell.

When you release the mouse button, Excel applies
all the formatting in the prototype cell to the range
you selected with the Format Painter mouse pointer.
Figure 17-5 illustrates this: Here, I copied the Percent
Style number format plus the bold and italics attrib-
utes applied to cell D4 to this range by dragging
through the cell range D5:D9 with the Format Painter
mouse pointer.
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¢ Figure 17-5: Cell range D5:D9 after using the Format
Painter to copy all the formatting applied
to cell D4.

To format more than one range, double-click
e («a the Format Painter button instead of single-

clicking it. That way, the Format Painter stays
engaged until you next click the Format Painter
button to disengage it. In between, you can
use the mouse pointer to paint through as
many cells and cell ranges as your little heart
desires.

Although the Format Painter makes copying from
one cell to another range a real breeze, copying for-
mats is not its only claim to fame. You can also use
the Format Painter to copy column widths in a work-
sheet. To do this, you click the letter of the column
whose width you want to copy in the column header
and then double-click the Format Painter button to
engage it. Finally, click or drag through the letters of
the columns that need to be the same width and
then click the Format Painter to disengage it.

As if this weren’t enough, you can also use the
Format Painter to copy the attributes of one graphic
object (such as a piece of WordArt, an AutoShape, a
Clip Art image, or a graphics file inserted into the
worksheet — see Technique 56) to other objects of
the same type.

For example, suppose that you insert a photo into a
worksheet and then edit that photo with the More
Contrast and Less Brightness buttons in the Picture
toolbar. After a bit, you add another photo to the

sheet with the same exposure problems. You can
then use the Format Painter to copy the contrast
and brightness settings applied to the first photo
onto the second one. All you do is click the edited
photo to select it, click the Format Painter button,
and then click the second unedited photo. Excel
then immediately copies the same contrast and
brightness exposure settings to it.

Cutting and Pasting
Formats Only

As I'm sure you’re aware, whenever you move or copy
formatted cells from one part of the worksheet to
another, Excel automatically copies the formatting
along with the cell contents. What you may not be
aware of is that you can copy just the formatting
applied to a cell or cell range and — leaving behind
the contents — paste that formatting into a new
range.

The range into which you copy the formatting can
be blank or can contain cell entries. If the range is
blank, all cell entries that you make there take on the
copied formatting. If the range already contains cell
entries, the copied formatting is immediately applied
to them, replacing any existing formatting.

To copy just the formatting from a cell or cell range
to a new place in the worksheet, follow these steps:

1. Select the cell or range that contains the for-
matting you want to copy.

2. Choose Edit>Copy or press Ctrl+C to copy the
cells to the Clipboard.

Excel copies both the cell contents and the for-
matting in the selected cell(s) to the Windows
Clipboard.

3. Select the cell or cell range into which you
want to copy the formatting now residing on
the Windows Clipboard.
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4. Choose Edit->Paste Special to open the Paste Paste Special A % |
Special dialog box. Paste
" all ™ Yalidation
Be sure you don’t choose Edit=>Paste instead " Formulas (" &l except borders
of Edit=>Paste Special. Otherwise, Excel will  yalues ™~ Column widths
plunk down not only the formatting but the ; ! " Formulas and number Formaks
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5. Click the Formats option button in the Paste
area of the Paste Special dialog box (shown in [~ Skip blanks [~ Transpose

Figure 17-6) and then click OK button.
| a4 Cancel
L2k

Excel closes the Paste Special dialog box and imme-
diately applies all the formatting applied to the origi-
nal cell or cell range and copied to the Clipboard

to the cell range that’s currently selected in the
worksheet.

* Figure 17-6: Using the Formats option in the Paste Special
dialog box to paste only the formatting on
the Clipboard.



Style Formatting
Magic

Technique

Save Time By
v~ Using the built-in styles

v~ Creating and using
custom styles

v~ Copying custom styles
from one workbook to
the next

hen it comes to looks, everyone wants to be in style. When it
Wcomes to getting your worksheets to look their best, you can

facilitate their formatting by using Excel’s styles. Styles are per-
fect for applying standard formatting to many cell ranges across the
spreadsheet. What makes them so great is that should you need to tweak
their formatting a bit, you simply make the changes to the style itself and
those changes are instantly updated in every cell to which that style is
applied.

Excel styles can regulate any of the following formatting attributes in
acell:

v Number to determine which number format is used. (If the cell con-
tains a text entry, the Number aspect of the style is ignored.)

v Alignment to determine what kind of horizontal and vertical text align-
ment, text control (wrap text or shrink to fit), or text direction is used.

v Font to determine what font, font style, font size, attributes (underline,
strikethrough, superscript, or subscript), or font color is used.

v Border to determine what kind of border (including line style and
color), if any, is used.

v Patterns to determine what kind of cell shading, if any, is used.

v Protection to determine the status (on or off) of the Locked and
Hidden cell protection attributes.

This technique gives you vital information on how to use and customize
the six predefined styles that are immediately available to you in any
workbook you open as well as how to create your own custom styles.
Finally, you find out how to copy your favorite custom styles from one
workbook to another so that you don’t have to waste time reinventing a
style.



Styling

Each Excel workbook you open comes with six pre-
defined styles. The Normal style is the default style
applied to every cell of every new workbook. Figure
18-1 shows you the Style dialog box (Format=>Style)
displaying the different formatting attributes that the
Normal style uses. Keep in mind that anytime you
manually apply new formatting attributes to a cell,
either with the buttons on the Formatting toolbar or
the options in the Format Cells dialog box (Ctrl+1),
these attributes are applied to the basic settings in
effect from the cell’s current style. If any of these
manually selected attributes conflict with attributes
set by the current style, they override and replace
them.

Style
Style name: -
Style includes
Cancel
v Mumber General
Madify. .
[+ Alignment General, Bokkom Aligned #
v Eont Arial 10
Iv Border Mo Borders
v Patterns Ma Shading Merge...
[+ Protection  Locked

* Figure 18-1: The Normal style is automatically applied to
all the cells in a new workbook.

The other predefined styles — Comma, Comma (0),
Currency, Currency (0), and Percent — are all used
to format cells containing numeric values with the
most common number formats. As such, their par-
ticular styles define only a new Number setting —
these styles don’t change the Alignment, Font, Border,
Patterns, or Protection settings. When you apply any
of these styles, they replace the General number for-
mat set by the Normal style with that of their own.
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Applying predefined styles in a spreadsheet

You can always apply any of the predefined styles

to a cell selection by opening the Style dialog box
(Format=Style), selecting the name of the style to
apply in the Style Name drop-down list box, and then
clicking OK. But Excel offers a much more direct pro-
cedure when applying the Comma, Comma (0),
Currency, Currency (0), and Percent styles.

To apply these styles, select the cells to be format-
ted and then click the appropriate button(s) on the
Formatting toolbar, shown in Figure 18-2. In the case
of the Comma, Currency, and Percent styles, all you
have to do is click the corresponding toolbar but-
tons. In the case of the Currency (0), which doesn’t
display any decimal places, you need to first click
the Currency Style button (which displays two deci-
mal places) and then click the Decrease Decimal but-
tontwo times (which takes the decimal places away).
Likewise, when you want to apply the Comma (0)
style to a cell selection, you click the Comma Style
button and then click the Decrease Decimal button
twice to remove its two decimal places.

Comma Style

Currency Style Decrease Decimal

Percent Style

Increase Decimal

* Figure 18-2: Applying the Currency, Percent, and Comma
styles from the Formatting toolbar.

] To be able to select any style from a drop-down
B> (@’S‘I

list on the Formatting toolbar (see Figure 18-3),
customize this toolbar by adding the com-
mand that displays a Style drop-down list box.
This command is located in the Format cate-
gories on the Commands tab. (See Technique
2 for details on customizing toolbars.)

&
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¢ Figure 18-3: The Formatting toolbar after customizing it
by adding a Style drop-down list box.

Customizing predefined styles

Excel makes it a snap to customize any of its six pre-
defined styles. Of the six, most users end up cus-
tomizing the Normal style in order to quickly and
easily make basic formatting changes to all the cells
of a new workbook. For example, suppose your com-
pany prefers to use Times New Roman 12 point as
the default font and font size for all its spreadsheets.
To accomplish this in a new workbook, you would
modify the Normal style using the following steps:

1. Open a new workbook and then Choose
Format=>Style to open the Style dialog box.

2. Select Modify to open the Format Cells dialog
box, shown in Figure 18-4.

Format Cells B[%]

I.D.Ii-;nrnent ] Fant ] Barder ] Patterns Protection]

Category: Sample

General

Mumnber

Currency

Accounting General Format cells have no
Date specific number Format.,
Tirne

Percentage

Fraction

Scientkific

Text

Special

Cuskam J

Ok | Cancel

¢ Figure 18-4: Customize the style by making changes to
its attributes in the Format Cells dialog box.

3. On the Font tab, select Times New Roman in
the Font list box and 12 in the Size list box and
then click OK.

4. Click OK in the Style dialog box to close this
dialog box and put the new attributes in effect.

After changing the font and font size for the Normal
font, all the cells in the blank workbook now use
Times New Roman 12-point type instead of the usual
Arial 10 point.

Modifications that you make to a predefined
@ style such as Normal are saved as part of the
current workbook file. However, these changes

don't carry over to new workbook files; they
continue to open with the original, unmodified
styles. To make use of your customized styles,
you need to copy them into the new work-
book. (For more on copying styles, see the
“Merging Styles from One Book into Another”
section, later in this technique.)

Creating Styles of Your Own

Excel makes it extremely easy to create new styles
for your spreadsheet. When creating a new style,
you can either

v Build it by modifying the attributes of one of
the predefined styles. You select the basic style
in the Style dialog box and then make all the
necessary changes to the number format, font,
alignment, borders, shading, and protection
attributes in the Format Cells dialog box (see the
preceding section, “Customizing predefined
styles”) required by the new style.

v Create it from an example cell. To create a style
by example, you choose a sample cell (which
should contain a typical data entry) and then for-
mat it with all the attributes (number format,
font, alignment, borders, shading, and protec-
tion) that you want used in the new style.



I personally favor the second method because it
enables me to see how the new attributes for the
new style actually affect the appearance of typical
data in the sample cell before I create it. To see how
this works, follow along with the steps for creating a
new Title Style for instantly formatting the headings
for tables of data in a new spreadsheet:

1. Select a cell to use as the sample cell in a new
workbook, make a typical data entry in it, and
then manually format the cell with all the
attributes you want the new style to assign.

To format the cell with the desired attributes,
use the buttons on the Formatting toolbar or the
controls in the Format Cells dialog box (Ctrl+1).

2. Choose Formatr>Style to open the Style
dialog box.

3. Select the Style Name text box and replace
Normal with the unique name you want to give
the new style, as shown in Figure 18-5.

As soon as you begin typing in the new style
name, the Style Includes area in the Style dialog
box changes to a Style Includes (By Example)
area that lists all the attributes that your new
style will use.
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* Figure 18-5: Creating a new style from a sample
formatted cell.
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4. Click OK to close the Style dialog box and com-
plete the creation of your new style.

After creating a new style, you can apply its format-
ting to a cell selection (single range or noncontigu-
ous selection) in the worksheet by opening the Style
dialog box (Format=>Style), selecting the name of the
style in the Style Name drop-down list box, and click-
ing OK. Of course, you can make applying a style a
heck of a lot easier by adding a Style drop-down list
box to the Formatting toolbar. (See Technique 2 for
details on customizing Excel toolbars.)

] If you create a custom style that you rely on all
e («a the time, consider assigning it to a button that
& you add either to the Formatting toolbar or to
some custom toolbar. That way, you can format
a cell selection with the style by clicking its
button. To do this, create a keystroke macro
that selects the custom style (see Technique
60) and then assign this macro to a Custom
button and add this button to one of the tool-
bars (see Technique 2).

Merging Styles from One
Book into Another

The only problem with styles as far [ can see is that
they are available only in the workbook in which you
create them. To get around this, you need to know
how to copy custom styles (as well as any prede-
fined styles that you've customized) into a new
workbook file. To accomplish this type of style
merge, follow these straightforward steps:

1. If the new spreadsheet into which you want to
copy existing styles has not yet been saved,
make a data entry in one of its cells.

Doing this prevents Excel from closing the
unsaved workbook the moment you open the
workbook with the styles you want to merge.
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Open the existing workbook (Ctrl+0O) contain-
ing the styles you want to use in your new
spreadsheet.

Switch back to the blank workbook making this
spreadsheet active.

You can do this either by clicking its button on
the Windows taskbar or by selecting it at the bot-
tom of the Window pull-down menu.

Choose Format->Style to open the Style
dialog box.

Click the Merge button near the bottom of the
Style dialog box to open the Merge Styles dia-
log box.

Select the name of the open workbook file that
contains the styles you want copied into your
new workbook, as shown in Figure 18-6.

Merge Styles =]

Merge stvles From:
Title stvle-Mormal THR-12.xls J

[

(0.4 [T: | Cancel |

¢ Figure 18-6: Merging styles from another open

workbook.

If the open workbook you selected contains mod-
ifications to the predefined styles (which also
exist in the new workbook), an alert dialog box
appears asking you to confirm the merging of
styles that have the same names.

7. If the confirmation alert dialog box appears,
click Yes to have the predefined styles in the
active workbook overwritten or No to prevent
them from being copied into the new work-
book. If this confirmation dialog box does not
appear, click OK in the Merge Styles dialog box
to close it.

8. Click OK in the Style dialog box to close it and
return to the active spreadsheet.

9. Switch back to the workbook whose styles you
just merged and then close it (Ctrl+W).

After merging styles from an open workbook, you
have immediate access to all the styles that you
copied in your new spreadsheet.

want available in all workbooks of a certain
type (such as invoices or balance sheets),
merge those styles into a new workbook and
then save the workbook as an Excel template
file. (See Technique 1) When you generate
new spreadsheets from this template, they will
automatically contain your custom styles.

2 If you have a bunch of custom styles that you
<}

&



Controlling When
Certain Formats

Technigite Are Used

Save Time By

v~ Using conditional format-
ting to flag significant
data entries

v~ Using conditional format-
ting to flag bad entries or
formula flub-ups

tells the program to format a cell range in one way when the range

contains one type of data entry and in a completely different man-
ner when it doesn’t. Conditional formatting can go a long way in helping
you keep tabs on very significant or potentially disastrous conditions
that crop up in your spreadsheet.

Excel includes a nifty little feature called conditional formatting that

Most of the time, you apply conditional formatting to cells that contain
formulas whose evaluated values are key in the spreadsheet (such as
subtotals or grand totals). Applying conditional formatting to these cells
can help you flag any potential errors that result from goof-ups made in
the input cells referenced in the formulas. You can also use conditional
formatting to flag unexpected formula results, such as totals that exceed
your wildest expectations as well as totals that are way below your most
pessimistic projections.

This technique looks at ways you can use conditional formatting to alert
yourself when certain key values change in your spreadsheet (for better
or worse). It begins by looking at how you can use conditional formatting
to select one type of cell format when normal conditions exist in the cell
and another special formatting when some sort of abnormal condition
crops up. You also find out how to use conditional formatting to warn
you when certain kinds of errors have crept into the spreadsheet.

Formats to Suit Every Condition

Conditional formatting enables you to set up two types of criteria that
determine when the program applies the conditional formatting you
designate:
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v Cell Value Is: Compares the value (constant) you
specify in the Conditional Formatting dialog box
against the value entered in the cell. When Excel
compares this constant to the cell value and the
criteria you specify for them is met (is between,
equal to, greater than, less than, greater than or
equal to, or less than or equal to), Excel applies
the conditional formatting to the cell. When the
condition is not met, Excel uses the regular for-
matting applied to the cell.

v Formula Is: Evaluates the logical formula you
enter in the Conditional Formatting dialog box.
When this formula evaluates to TRUE, Excel
applies the conditional formatting you define to
the cell. When the formula evaluates to FALSE,
Excel applies the regular formatting to the cell.

When you want to be warned when a cell contains a
particular value or exceeds or falls below a certain
number, the Cell Value Is type of conditional format-

ting is the way to go. To get an idea of how you would

use this type of conditional formatting, follow along
with the steps for displaying the entry in a cell in red
with bold and strikethrough whenever it contains a
negative value:

1. Position the cell pointer in the cell where you
want to apply conditional formatting.

2. Choose Format->Conditional Formatting to
open the Conditional Formatting dialog box,
shown in Figure 19-1.

When Excel opens this dialog box, the Cell Value
Is option is automatically selected along with
Between as the comparison operator.

Conditional Formatting

Condition 1
[Celliialiets v | [between = |

Preview of format to use
when condition i true:

= o | =
| Eormat...

Add == | Delete. .. | [s]4 Cancel

Mo Format Set

* Figure 19-1: The Conditional Formatting dialog box when
you first open it.

3. Select Less Than in the second drop-down list
box (the one that now contains Between).

4. Press Tab to select the last text box and then
type 0, as shown in Figure 19-2.

After setting up the condition for the special for-
matting, you must specify what formatting attrib-
utes to use. The Font attributes that you can set
for conditional formatting are limited to font
style, underlining, strikethrough, and color. For
this example, I turn on strikethrough and bold
and select red as the font color.

Conditional Formatting

Condition 1

Cell Yalue Is ﬂ |\essthan ﬂ |D\ E

‘ Format...

Add »x | Delete, .. | [o]:4 Cancel |

¢ Figure 19-2: The Conditional Formatting dialog box after
specifying the first condition.

Preview of format to use

when condition is true: Ma Farmat Set

5. Click the Format button in the Conditional
Formatting dialog box to open the Format Cells
dialog box.

6. On the Font, Border, and Patterns tabs, select
the attributes to be used when the condition is
true. When you're finished selecting your
attributes, click OK. (See Figure 19-3.)

When you close the Format Cells dialog box, the
Conditional Formatting dialog box shows your
first condition along with a preview of the for-
matting that Excel will apply when the condition
is true. At this point, you can either add another
condition (see the next section, “When two con-
ditions are better than one”), or if you need only
the one condition — as is the case here — you
can close the dialog box.

7. Click OK to close the Conditional Formatting
dialog box and put the conditional formatting
into effect in the current cell.



Format Cells =&
Fant ] Border l Patterns]
Font style:
| [Bold |
p Regul
i = ‘ R
Biald
iy | |pddmaic = =l
Undetline: Coalors
Preview

For Conditional Formatting you can set Font Skyle,
Underline, Colar, and Strikethrough,

Clear
oK & | Cancel |

* Figure 19-3: Selecting the attributes for the first condition
in the Format Cells dialog box.

Figure 19-4 shows how the conditional formatting
assigned to cell C4 at the top of the Retail Price col-
umn of the Spring Sales table appears when it kicks
in. For this figure, [ intentionally entered -1200 in the
cell rather than the correct 1200 figure (negative val-
ues make no sense in this price column). Because
this cell now contains a value less than zero (that is,
a negative value), the conditional formatting kicks in
(because the basic condition is true), and as a result,
the red, boldface, and strikethrough attributes are
added to the regular cell formatting.

[ MicrosoR Exccal - Spring sale.xts

i4] File Edit View Insert Format Tools Data Window Help Ad

HIR N NN L 100% = é?"”"' v 10 x
L B e 1300 i i
A B e b | E | F

1

2 :Spnng Sale Furniture Prices

3 |Code Description Retail Price Discount Sales Price

4112305  3inch round tsble [{ionoml 5% @0000)

5 [12-240 F2-inch dining table 1,400.00 1 25% 105000
B 114-356  Hutch 2,500.00 25% 187500
7 [10-234  Side chair 350,00 15% 297 80
B [13003  Am chair 500.00 15% 425,00
9 113240 Ammoir 175000 2% 131250

10]
1

¢ Figure 19-4: Table displaying the conditional formatting
when a negative value is entered in the cell.
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Formats to Suit Every Condition

To copy the conditional formatting you see applied
to cell C4 down to the other cells in the Retail Price
column (you don’t want to have to pay to have cus-
tomers take any of your furniture), follow these steps:

1. Copy cell C4 to the Clipboard (Ctrl+C) and then
select the cell range C5:C9.

2. Choose Edit~>Paste Special to open the Paste
Special dialog box.

3. Select the Formats option button and then
click OK.

Excel then pastes the conditional formatting for cell
C4 to all the other Retail Price cells, so they will also
alert you with the same kind of in-your-face formatting
should any errant negative entries come their way.

When two conditions are hetter than one

When setting up conditional formatting for a cell,
you’re not limited to a single condition. You can set
up several conditions, each with its own unique
attributes that are used when its particular condi-
tion is true. Most of the time, you find that two con-
ditions are completely adequate to cover all the
possible contingencies.

To set up a second condition in the Conditional
Formatting dialog box (Format=>Conditional
Formatting), you click the Add button after defining
the first condition and the formatting to use when
this condition is true. Clicking this button expands
the Conditional Formatting dialog box by adding a
Condition 2 area with identical controls for defining
the second condition and the formatting that it
applies.

Figure 19-5 illustrates how this works. For this figure,
I added a second condition to cell C4 in the Spring
Sales table. It adds bold to the font and garish yellow
shading to the cell if it ever contains a value above
1,250. Now, Excel not only alerts me with red, bold,
and strikethrough type if the value in cell C4 is
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negative but also alerts me with bold type and bright
yellow shading if the value exceeds 1,250.

Conditional Formatting

Condition 1-

Cell value Is j |Iess than j o i

Preview of format to use AaBhCo¥yZz Format

when condition is true: =
Condition 2

Cell Walue Is j |greater than j ‘ 1250

Preview of Format to use AaBbCcYyZz

when condition i true: ¥

Add >x | Delete... |

Ok QJ Cancel ‘

* Figure 19-5: Adding a second condition that applies a
different formatting when the value is
above 1,250.

Finding cells with conditional formatting

Excel makes it easy to locate and select the cells in
your worksheet that use conditional formatting. This
makes it quick work of finding particular conditional
formatting that you want to reuse by copying to
other parts of the spreadsheet.

Open the Go To dialog box (F5 or Ctrl+G) and then
click the Special button. Excel opens the Go To
Special dialog box (see Figure 19-6) where you select
the Conditional Formats option button and then
click OK.

Excel then selects all the cells in the worksheet that
contain some type of conditional formatting. You can
use the Enter or Tab key or Shift+Enter or Shift+Tab
keys to move from one selected cell to another
throughout all the ranges.

To save time and select only the cells that con-

- («a tain a certain type of conditional formatting,

& position the cell pointer in a cell that uses the
type you want to locate. Then open the Go To
Special dialog box, select both the Conditional
Formatting option button and the Same option
button, and click OK. (See Figure 19-6.)

Technique 19: Controlling When Certain Formats Are Used

(Go To Special

Select

(" Comments (" Row differences

(" Constants (" Column differences

" Formulas (" Precedents
[+ (" Dependents
¥ {
[+ i
[+ " Lask cell
(" Blanks " Visible cells only

(" Current region ™ iC

(" Data validation
(" Objects * al
" Same

¢ Figure 19-6: Selecting the cells in the worksheet that use
conditional formatting.

(" Current array

Cancel

Making Your Outstanding
Errors Stand Out

Although conditional formatting is most useful for
alerting you to anomalies that crop up in your
spreadsheet data, you can also use it to warn you
when certain types of errors crop up that aren’t
related to errors in the formulas themselves. For
example, you can use conditional formatting to flag
errors in a typical sales table — one that totals the
columns and rows of figures to ensure that the sum
of the column subtotals and the sum of the row
subtotals are always equal to the grand total at the
intersection of the two.

Note that the only way the subtotals wouldn’t equal
the grand total is when you or a coworker acciden-
tally deletes or replaces one of the SUM formulas
that calculate a column’s or row’s subtotal. If you



don’t protect your formulas against this type of unin-
tentional editing (as I suggest in Technique 38), you
can at least set up this type of conditional formatting
to notify you if such an error occurs.

Figure 19-7 illustrates a situation where you could
apply this type of conditional formatting. Here, you
have a typical table of data that calculates the subto-
tals and grand total of the quarterly sales for a
bunch of different stores. E12 contains the formula
that returns the grand total (by summing the row
subtotals in the cell range E3:E11).

To alert me if this sum of the row subtotals ever
becomes unequal to the sum of the column totals (in
the cell range B12:D12), I set up conditional format-
ting for this grand-total cell E12. In the Conditional
Formatting dialog box, I select Formula Is as the
type and then enter the following formula in the
accompanying text box:

=SUM($B$12:$D$12)<>SUM($ES3:$E$11)

As for the formatting to be applied when the inequal-
ity set up by this formula is true, I go with bold and
red as the font attributes and bright yellow shading
for the cell background. That way, if cell E12 ever
lights up like a Christmas tree with this garish for-
matting, [ know right away that some knucklehead
(probably me) has gone and messed up one of the
SUM formulas that calculates the column and row
subtotals.

Figure 19-8 shows you how this conditional format-
ting appears in cell E12 when just such a thing
occurs. For this figure, I intentionally replaced the

Making Your Outstanding Errors Stand Out
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SUM formula in cell C12 with 0. As a result, the total
for cell range B12:D12 no longer is equal to that of
the cell range E3:E11, and the conditional formatting
is immediately applied to cell E12.

[ Micronal Exeal  MGE 2000 0T dy.xh
2 File Edit View [nsot Foomat Tooks Data Window lelp  Adebe PDF T > * - X
RN BENIE RS o I T A § o | v A
Of Tolal = & =SUMESEN]
A 1 ] 1] E | F —

Mothar Gongs Enterprises - 2004 Salas
dan Fab [

3 Llack Sprat Diet Centers

5| Rub-a-Dub-Dub Hot Tubs and Spas

1
2
3
4
5 |Mother Hutibard Dog Goodies
6
7_(Gooegin Porgie Pudding Pis
(] Cloc!

Hickory, Dickory_ Dock Clos
9 |Little Bo-Peep Pet Datactives
10 | Simpla Simon Pis Shoppes
11 inck Ea Menbla Candlashicks
| 12 Total

13
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15
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17
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Pz}
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ﬁlc;'ﬂv» 9:05 4

¢ Figure 19-7: Table where the sum of the column subtotals
should always equal the sum of the row

subtotals.
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* Figure 19-8: Conditional formatting applied to the grand
total cell when the inequality condition is
true.
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formats
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to toolbars

v+~ Using euro currency
formats

the values in your spreadsheets easy to decipher for anyone who

uses them. For those times when the program doesn’t hand you a
ready-made number format that fits the bill, you can quickly customize
one of the existing formats to suit your needs.

Excel includes a wide variety of number formats designed to make

This technique covers how to create custom number formats for your
spreadsheets and how to assign them to Excel custom styles and tool-
bars for easy access. This technique also covers how to use the Euro
Currency add-in to format currency expressed in euros.

Creating Custom Number Formats

The easiest way to create a custom number format is to format a sample
number with the built-in number format whose attributes most closely
match the ones you want in the new custom format. Continue by opening
the Format Cells dialog box (Ctrl+1), selecting the Custom category on the
Number tab to display the built-in format’s codes, and then building the
custom number format by editing its number format codes, as necessary.

Excel’s number formats can consist of up to four sections:

v First section specifies how to format positive numbers
v Second section specifies how to format negative numbers
v Third section specifies how to format zeros

v Fourth section specifies how to format text

Each part of the format is separated by semicolons (;). If a particular for-
mat doesn’t specify formatting for negative numbers or zeros, Excel for-
mats them like it does positive numbers. If the format doesn’t specify
what to do with text, text is formatted as it normally is with the default,
Normal format. Table 20-1 shows the codes you’d use in the various sec-
tions of the custom number format you’re creating.
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Creating Custom Number Formats

TasLE 20-1: NumBER FormAT CoDES

Code What It Signifies
# Digit placeholder that displays only significant digits and does not display insignificant zeros so that
{HHHE . 4 displays 2450.48 as 2450. 5 in the cell.
0 (zero) Digit placeholder that displays insignificant zeros if a number has fewer digits than the number of places in

\ (backslash)
* (asterisk)

"text"

%

. (period)
, (comma)

()

E-,E+ e-, et

_ (underscore)

mm
mmm

mmmm

dd
ddd
dddd
Yy
Yyyy

the format so that the code #. 00 displays 4.5 as 4 .50 in the cell.

Digit placeholder that adds spaces for insignificant zeros on either side of the decimal point to align num-
bers on the decimal point so the code 0. ?? ensures that 10.5 and 12.75 line up because the program pads
10.5 with an extra space.

Displays the character that immediately follows as text.
Repeats the character that immediately follows to fill the column width.

Displays whatever text you enclose in the double quotes as text. Note that the following characters do
not have to be enclosed in quotes: $,-, +,/, (,), ;, |, *, &, ¢ (open single quote),  (close single quote), ~, {, },
=, <, >, and a space.

Text placeholder. By itself, it converts whatever number is entered in the cell into a text entry. When fol-
lowed by text enclosed in quotation marks, it appends that text onto the number so that the format code
@" estimate" appends the word estimate to each number.

Percentage that adds a percent sign at the end of the number to indicate that its value is a multiple of a
hundred.

Decimal point.
Thousands separator.

Enclosing the code for the negative numbers in the second section of the format displays negative num-
bers in parentheses as (4.50) instead of -4.50. Add a hyphen (-) to negative fo rmat code to have a nega-
tive number preceded by a minus sign.

Converts number into scientific notation.

Inserts space equal in width to the character that immediately follows, as in _) to pad values with a space
equal to the close parenthesis.

When not following the h or hh code, inserts the month as a number without leading zeros, as in 7-4-05.
Inserts the month as a number with leading zeros, as in 07-4-05.

Inserts the month as a three-letter abbreviation, as in Jan, Feb, Mar, and so on.

Inserts the full name of the month, as in January, February, March, and so on.

Inserts the date as a number without leading zeros, as in 4-1-04.

Inserts the date as a number with leading zeros, as in 4-02-04.

Inserts the day of the week with a three-letter abbreviation, as in Mon, Tue, or Wed.

Inserts the full day of the week, as in Monday, Tuesday, or Wednesday.

Inserts the last two digits of the year, as in 2-15-05.

Inserts all four digits of the year, as in 2-15-2005.

(continued)
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TaBLE 20-1 (continued)

When immediately following the h or hh code, inserts the number of minutes without leading zeros (0-59),

Inserts the number of seconds with leading zeros (00-59), as in 5:05: 07. For fractions of a second, use a

Inserts AM or PM after time numbers depending upon whether the time is before or after noon, as in 10:15

Specifies the font color for the section of the format as specified by the color name, as in [BLACK], [BLUE],
[CYAN], [GREEN], [MAGENTA], [RED], [WHITE], or [YELLOW]. Note that [Color] must precede the other
codes in the section, as in [RED] (#,#0) in the negative section, to have negative values displayed in red

Code What It Signifies
h Inserts the number of the hour without leading zeros, as in 9: 15.
hh Inserts the number of the hour with leading zeros, as in 09:15.
m

asin 5:5.
mm Inserts the number of the minutes with leading zeros (00-59), as in 5: 05.
S Inserts the number of seconds without leading zeros (0-59), as in 5:05:7.
SS

format that includes fractions such as h:mm:ss.00.
[1] Displays hours greater than 24 and minutes or seconds greater than 60.
AM/PM

PM. (Otherwise Excel formats the time using a 24-hour clock as in 22:15.)
[Color]

and enclosed in parentheses.
[Colorn]

Specifies a font color for the section of the format as specified by a number (n) between 1 and 56. Note that
this [Colorn] code must precede all other code in the section.

When defining custom formats for currency, you enter
the currency signifier, as in $ for dollars, § (Alt+0163)
for pounds, ¥ (Alt+0165) for yen, and € (Alt+0128)
for euros. Use a comma () to indicate the presence of
the thousands separator and a period (.) to indicate

To get an idea of how you create your own custom
number format, follow these steps for building a
format that displays your financial values in the
spreadsheet like you do when writing a check, as
in 1,234 and 56/100 dollars:

the decimal point. When defining custom date for-
mats, you can separate the parts of the date with 1. Enter 1234.56 in a blank cell of the current

either a hyphen (-) or a slash (/). When defining time
formats, you separate each part with a colon (:).

To find out the keystroke numeric code that
inserts special characters such as the cent

worksheet to create a sample amount and make
sure that this cell is current.

2. Choose Format->Cells (Ctrl+1) to open the
Format Cells dialog box, shown in Figure 20-1.

symbol or degree symbol into a custom 3. On the Number tab, select Fraction in the

format, open the Character Map program
(Start=>All Programsc>Accessoriest>System

Category list box and then scroll down the
Type list and select As Hundredths (30/100).

Tools=>Character Map) and then select the

characters. Windows displays the Alt+key-
stroke combination, if one exists, in the lower

right of the Character Map dialog box. To use

this numeric code, enter the code from the
numeric keypad while holding down the
Alt key.

The Sample area now shows the number in the
current cell as 1234 56/100.

Select Custom in the Category list box.

The Type text box now contains the code #
?7/00, your starting point for creating your
custom format.



5. Position the Insertion point at the very begin-
ning of the Type list box and then type # ##.

The Type text box now contains the code #, ##
?7/00, and the sample reads 1,234 56/100. Now,
all you have to do is add the stock text and
between the whole and fractional digits and the
dollars text at the end.

6. Position the Insertion point after the last pound
sign (#) and then type “ (open quote), press the
spacebar, type and, and then type “ (close
quote).

The Type text box now contains the code #, #H"
and"??/00, and the sample reads 1,234 and
56/100.

7. Position the Insertion point at the very end of
the code (after the last 0) and type “ (open
quote), press the spacebar to insert a space,
type dollars, and then type “ (close quote).

The Type text box now contains the code #, fHH}"
and"??/00" dollars", and the sample reads
1,234 and 56/100 dollars, as shown in

Figure 20-2.

Format Cells B3 =]

Numberl alignment ] Fank ] Border ] Patterns Protection]
Cakegory: Sample

General 1234.56

MNumber

Currency

Accounting General format cells have no
Date specific number Format,

Time

Percentage

Fraction

scientfic [

Text

Special
Cuskom J

oK | Cancel |

* Figure 20-1: Selecting the Fraction category to apply a
close format to the base number.
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Format Cells EE
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Currency Tvpe:

Accounting [#, " and" 72/100" dalars"

Drate

Tirne Genatal -

Percentage u]

Fraction 0.00

Scientific #8820

Texk #,&40.00

Special EX-ZRAEX X))

Cuskan J #,#40_[Red](#, 200 ﬂ

Delete
Twpe the number Format code, using one of the existing codes as a starting
point.
K Cancel
L

* Figure 20-2: The Number tab of the Format Cells dialog
box showing the custom number format
codes.

8. Click OK to close the Format Cells dialog box
and apply the new custom format to the cur-
rent cell in the worksheet.

When you close the Format Cells dialog box, Excel
applies the custom format to the 1234.56 sample
number in the current cell. To apply this custom for-
mat to other cells in the worksheet, you need to
select the cells, open the Number tab of the Format
Cells dialog box, select Custom in the Category list
box, select the #,#HH" and"?2/00" dollars" code at
the very bottom of the Type list box, and click OK.

Custom formats that conditionally format entries

You can use Excel’s number format codes to create
custom number formats that do conditional format-
ting (much like the conditional formatting feature
discussed in Technique 19). To create a conditional
format, you set up the condition inside square brack-
ets using the same comparative operators (=, >, <,
>=, <=, and <>) as you do in simple formulas.
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For example, you can create a conditional custom
format that displays a cent sign (¢) after all values
that are less than a dollar and displays a normal dol-
lar sign and two decimal places for all values over or
equal to one dollar. To do so, open the Number tab
of the Format Cells dialog box, select the Custom
number category on the Number tab, and enter the
following code in the Type text box:

[<17.00¢;$0.00

In this conditional format, when the number in the cell
is less than 1, the program adds the cent sign (¢) to
the decimal number showing two places. Otherwise,
when the number is 1 or any number greater, the
program uses the second part of the conditional for-
mat (after the semicolon), which adds the dollar sign
($) and two decimal places to the number.

When creating conditional custom formats, you're not
limited to two formats: the one used when the condi-
tion is true and the other when it’s false. You can, in
fact, create up to three formats: one format used when
the first condition is true, a second format when the
second is true, and a third format for all other cases.

For example, say that you want to create a condi-
tional format that applies the General number format
using a red font when a number is less than 1, blue
when its value is greater than 100, and default black
when its value is anywhere in between. To do so,
open the Format Cells dialog box, select the Custom
number category on the Number tab, and enter the
following number codes in the Type text box:

[REDI[<1]General;[BLUEI[>100]General;General

In this conditional custom number format, the font
color red is assigned to any values below 1, and blue
is assigned to any values higher than 100. The default,
black color is assigned to all other values (that is, any
number between 1 and 100).

Custom formats that hide certain entries

Because Excel number formats consist of four sections
(one each for positive numbers, negative numbers,

Technique 20: Customizing Number Formats

zeros, and text) that determine how specific types of
entries are formatted, you can easily create custom
formats that hide a particular type of entry by leaving
its section blank.

For example, to create a number format that hides
the contents of a cell only when it contains text,
open the Format Cells dialog box, select the Custom
number category on the Number tab, and enter the
following number codes in the Type text box:

_(* #£,4HF0.00_) 5 _(* (3,44+0.00);0;

In this custom number format, Excel applies the
standard Comma style formatting to positive and
negative numbers, while at the same time displays 0
for cells that contain zero. However, because I failed
to add a number format code in the fourth section
(after the third semicolon), Excel hides any text
entry.

To create a custom format that does just the oppo-
site — that is, hides all numbers and displays only
text — you simply enter two semicolons with no
number format codes whatsoever:

sy

In this custom number format, the two semicolons
delineate three of the possible four sections: the pos-
itive number before the first semicolon, the negative
number immediately following the first semicolon,
and the zero section of the format immediately fol-
lowing the second semicolon. However, because all
three sections are empty, Excel hides the display of
positive, negative, and zero values, displaying only
text entries. If you want to create a custom format
that hides the display of all entries in a cell, just add
the third semicolon to these other two with no codes
(and no spaces) as in:

PP

Because all four sections of the number format are
now delineated and empty, Excel suppresses the dis-
play of all types of entries in the cells to which this
custom number format is applied.



Assigning Custom Number Formats to Styles and Toolbars

Assigning Custom Number
Formats to Styles and Toolbars

Frankly, the only problem with custom number for-
mats is that they’re just not that easy to use. To
apply them to a cell selection, you have to open the
Number tab of the Format Cells (Ctrl+1) dialog box,
select Custom in the Category list box, and then find
the darned number format codes in the Type list box
containing that long listing of codes.

To make your custom number formats much more
accessible, [ suggest that, at the very least, you assign
the custom number formats to styles that you can
then select from the Style dialog box (or Style drop-
down list if you follow my advice and add this little
gem to the Formatting toolbar or one of your own
design — refer to Figure 18-3 in Technique 18).

To hitch one of your custom number formats to a
new style, follow these steps:

1. Apply the custom number format you want
to assign to a style to a sample entry in your
worksheet.

To do this, select the cell, open the Number tab
of the Format Cells dialog box (Ctrl+1), select
Custom in the Category list box, select the for-
mat’s codes in the Type list box, and click OK.

2. Choose Formatr>Style to open the Style
dialog box.

3. Enter the new name for your style in the Style
Name text box.

When you type the new style name, the Style dia-
log box displays the number codes for the cus-
tom number format in the Style Includes (By
Example) area, as shown in Figure 20-3.

4. Click OK to close the Style dialog box.

Be sure to save your worksheet after assigning
your custom number formats to new styles.
Keep in mind that styles are saved only as part
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of the current workbook. To use these styles
and their custom number formats in other
workbooks you build, you have to merge the
styles into them. (See Technique 18 for more
on merging styles.)
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* Figure 20-3: Assigning a custom number format to a new
style.

If you start using a custom number format on a fre-
quent basis, you may want to do more than just
assign the format to a style that you can apply from
the Style dialog box or drop-down list box that you
add to a toolbar. You can add the style to a button
that you add to the Formatting toolbar or a toolbar
of your own design.

To add a style that applies a number format to a but-
ton, follow these three steps:

1. Assign the custom number format to a custom
style (as described in the preceding steps).

2. Record a keystroke macro (see Technique 60)
that selects that style.

3. Assign the keystroke macro to a custom button
on one of your toolbars. (See Technique 2.)

To see how easy this is, follow along with the steps
for assigning a custom number format — one that
hides all types of entries in a cell — to a new button
on my Custom Formats toolbar (a toolbar of my own
design):
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1.

Create the custom number format that hides all
types of entries. To do so, open the Number tab
of the Format Cells dialog box, select Custom in
the Category list box, enter ;;; in the Type text
box, and click OK. (See Figure 20-4.)

Format Cells (23
Mumnber l Alignment ] Font ] Border ] Patterns ] Protection l
Cakegary: Sample
General
Murbeer
CUrrEncy Type:

Accounting ||
Date o
Timne General -
Percentage u]
Fraction 0.00
Scientific #,880
Texk #,##0.00
Special #8200 04, 420)
Custom J #0880 [Red](#,#x0) ﬂ
Delete
Type the number Format code, using one of the existing codes as a starting
poink.
414 [:‘ | Cancel

¢ Figure 20-4: Creating the custom number format that

2.

hides all types of cell entries.

Assign the new custom format to a new style by
choosing Format->Style, entering All Hidden

in the Style Name text box, and clicking OK.
(See Figure 20-5.)

Begin recording a keystroke macro that selects
this new All Hidden style. To do so, choose
Toolsc>Macro->Record New Macro, enter
All_hidden in the Macro Name text box, select
Personal Macro Workbook in the Store Macro
In drop-down list box, and click OK. (See
Figure 20-6.)

To finish recording the macro, choose
Format->Style, select All Hidden in the Style
Name drop-down list box, click OK, and then
click the Stop button in the Stop Recording
toolbar.
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Style
Style name:  [all Hidden| | ok ) |
Style Includes (By Example)
Cancel
[v Mumber o
Modify. .
Iv alignment General, Boktom Aligned #
v Font frial 10 add
v Border Mo Borders
¥ Patterns Mo Shading Merge. ..
Iv Protection  Locked

¢ Figure 20-5: Assigning the custom number format to a

new style called All Hidden.

Record Macro

Macra name:
|l _hidder]

Shortcut key:
Y

Descripkion:

Macro recorded 6/20/2004 by Greg Harvey

Skore macro in:
|Personal Macro Workbook -

0K Cancel
LaY

* Figure 20-6: Recording a keystroke macro All_hidden

5.

that selects the All Hidden style.

Choose Viewr>Toolbars->Customize to open the
Customize dialog box. If the toolbar to which
you want to add the custom button isn’t
already visible, click the Toolbars tab and
select this toolbar’s check box.

Click the Commands tab, select the Macros in
Categories list box, and then drag the custom
button from the Customize dialog box to the
desired position on the toolbar, as shown in
Figure 20-7.

Assign the keystroke macro to the custom but-
ton by right-clicking on the button and then
selecting Assign Macro on its shortcut menu.
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¢ Figure 20-7: Adding a custom button to the Custom
Formats toolbar to which to assign the
All_hidden macro.

8. Select the All_hidden macro in the Macro Name
list box and click OK, as shown in Figure 20-8.
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¢ Figure 20-8: Assigning the All_hidden macro to the
custom button.

Q. (Optional) Change the button image and button
name (see Technique 2) and then click the
Close button in the Customize dialog box.
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Applying Euro Currency Formats

After you close the Customize dialog box, you can
test your new button. Select a cell that contains
some sort of data entry and then click the All Hidden
button on your toolbar. The entry should immedi-
ately disappear from the cell (while still being visible
on the Formula bar). To redisplay the cell entry,
apply another format, such as General, to it.

The All Hidden button will work in any work-
sheet that you build provided that you merge
the All Hidden style into the new workbook

before clicking the button. If you don’t do the
merge, you'll get a Run-time error ‘450" when
you click the button; Excel is caught running a
macro that tries to apply a style that doesn’t
yet exist in the new file!

Applying Euro Currency
Formats

Before leaving the subject of custom number formats,
there’s one more custom number format that I want
you to be aware of. This is the Euro Currency number
format that is supplied as part of the Euro Currency
Tools add-in program that comes with Excel. This
add-in is heaven sent if you deal with currency from
the countries in the European Union that have
recently adopted the euro as their basic currency.

When you activate this add-in (see Technique 8),
Excel adds a Euro button to the Formatting toolbar
that automatically formats your cell selection with the
euro currency symbol (€) and two decimal places. In
addition to this formatting button, the add-in also pro-
vides you with a EuroValue toolbar (see Figure 20-9)
that you can use to convert the euro currency values
to the former currency of a particular member coun-
try and a member’s former currency into euros. To
make this type of conversion, all you have to do is
click the appropriate conversion on its drop-down
list.
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* Figure 20-9: Use the EuroValue toolbar to convert euro
currency to and from a member’s pre-euro
currency.

The conversion options on this drop-down list make
extensive use of the three-letter ISO codes that refer
to particular countries and their former currencies
within the union. (Refer to Table 20-2 to decode
these abbreviations.)

In addition to the EuroValue toolbar, the Euro
Currency Tools add-in attaches a Euro Conversion
command to the Tools pull-down menu. Selecting
this command opens a Euro Conversion dialog box
that also enables you to convert from one euro mem-
ber currency to another.

TaBLE 20-2: Euro Conversion ISO Cobes

I1SO Code Country/Region Unit of Currency
ATS Austria Schilling

BEF Belgium Franc

EUR Euro member state Euro

FIM Finland Markka

FRF France Franc

DEM Germany Deutsche mark
GRD Greece Drachma

IEP Ireland Pound

ITL Italy Lira

LUF Luxembourg Franc

NLG Netherlands Guilder

PTE Portugal Escudo

ESP Spain Peseta




Dazzling
Alignments for

Téechitique  Data Entries

Save Time By

v~ Using unusual horizontal
and vertical alignments

v~ Indenting data entries

v~ Wrapping text within
cells

v+~ Centering an entry across
cells

Right, and Merge and Center buttons are all you need to put your

spreadsheet’s data entries into good order. You should, however,
keep in mind that Excel has much more to offer than these four standard
formatting buttons when it comes to properly aligning and orienting your
data.

Most of the time, the Formatting toolbar’s Align Left, Center, Align

Using these other less standard alignment options can often go a long way
towards making the tables in your spreadsheet read better by enabling you
to keep their data more compact in their columns. More importantly, they
can save you from later having to waste time dealing with paging problems
caused by tables that unnecessarily split across more than one page of
the report.

This technique looks at several of these less standard alignment options
that you can apply to both text and numeric entries in the tables in your
spreadsheets. It also covers text options that enable you to efficiently
format long text entries such as the titles and column and row headings
for your tables.

Line Me Up

The Alignment tab of the Format Cells dialog box (opened by pressing
Ctrl+1 — see Figure 21-1) contains four sections with options that enable
you to control the positioning of the data entries in their cells:

v Text Alignment to change the horizontal and vertical alignment of the
entries in their cells. In addition to the normal left, center, and right
horizontal alignment, you have a choice between using left or right
indent, filling the cell with the characters in the entry, justifying the
characters to fill the width of the cell, and centering the entry across a
selection of cells.

Vertical alignment options include aligning the entries with the top edge
of the cells, bottom edge, or centered between the two edges. Or you
can wrap the entry on different lines that are either justified between
the top and bottom cell edges or evenly distributed between the two.
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v Orientation to reorient the data entries by rotat-
ing up or down the angle of the baseline that their
characters rest on or by setting the entries so the
characters appear one over the other in a single
thin column.

v Text Control to wrap the text in the entries on as
many lines as needed to stay within the current
column width (thereby automatically increasing
the row heights), reduce the font size of the
entries so that they fit on one line within their
current column widths, or to merge the current
cell selection into one large cell within which the
entry on the leftmost cell is aligned.

v Rightto-Left to change the normal left-to-right
reading order of the characters to right to left, as
required when using a language such as Hebrew
or Arabic whose characters are read in that order.

Indenting data entries

Normally when it comes to horizontal alignment,
Excel either automatically sets the first character of
the entry flush with the left edge of the cell (the left
alignment default for all text entries) or the last char-
acter of the entry flush with the right edge (the right
alignment default for all numeric entries). If you cen-
ter a data entry (by clicking the Center button on the
Formatting toolbar), Excel attempts to make the
space between the left edge and the first character
in the entry equal to the space between the last
character and the right edge.

Instead of relying on centering to set off particular
entries in a worksheet, many times you can just
indent the entries from the left edge to set them off
from the others. For example, Figure 21-2 shows a
sales table that contains sales figures for three kinds
of recording media: CDs, cassette tapes, and LPs.
Each of these three groups has it own subheadings
that list the same four music categories (Rock, Jazz,
Classical, and Other). You can improve the legibility
of the row headings for this table by indenting these
category subheadings.
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* Figure 21-1: Use the options on the Alignment tab of the
Format Cells dialog box to select unusual
alignments.
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¢ Figure 21-2: Sales table showing the breakdown of sales
by media and category.
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To do this, you could just select all the ranges with
the subheadings as a single cell selection and then
click the Increase Indent button on the Formatting



toolbar. However, if you want to indent the headings
more than a single character (which is the default
when you click the Increase Indent button), you're
better off doing this from the Alignment tab of the
Format Cells dialog box.

Figure 21-2 shows you how. Select the Alignment tab
in the Format Cells dialog box (Ctrl+1). Select Left
(Indent) in the Horizontal drop-down list, select 2 in
the Indent text box (either by typing 2 or selecting it
with the spinner buttons), and click OK. Figure 21-3
shows you the results. Here, | have indented the cell
ranges A4:A7, A10:A13, and A:16:A:19 two characters
in one operation.
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7 Cther 890.00 110577 1,360.10 3,384.87
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10|  Rock 450,00 960,00 980,38 | 2,907.38

1] Jaz 1,20000 122400 124848 367248

12} Classical 350.00 357.00 3644 107114
13| Other 750,00 765,00 78030 2,295.30
14 |Total Casele Sales  $3,250.00 $3,315.00  $3,361.30  $0,946.30
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* Figure 21-3: Sales table after indenting each row category
subheadings two characters.

Using nonstandard vertical alignment

By default, Excel vertically aligns the baseline of all
your data entries with the bottom edges of their
cells. In certain cases, you can improve the look of
the spreadsheet by increasing the height of rows by
using other vertical alignment options. When you
select the Top or Center vertical alignment options,
you often have to manually increase the height of
the rows before you can see the effect that these
options have on the vertical positioning of the data
entries. When you select the Justify option or the
Distributed vertical alignment option, Excel automat-
ically increases the height of the rows as needed to
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Line Me Up

wrap the text onto several different lines in order to
maintain the current column widths.

Figure 21-4 illustrates this situation. For this figure, |
applied the Justify Vertical alignment option to cell
Al — the cell containing the spreadsheet title. (Refer
to Figure 21-3 to see how this title originally looked
when its long text entry spilled over into the blank
columns B, C, and D to the right.) After applying this
vertical alignment option, Excel wraps the title onto
four separate lines. The program does this by auto-
matically increasing the height of line 1 from 15.75
characters (21 pixels) to 63 characters (84 pixels)
while at the same time leaving the width of column
at 20.14 characters (146 pixels).
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7 | Other 20000 110577 136010 336487
i | Total CO Sales $426400 $524477 $645101 31595973

L
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* Figure 21-4: Applying the Justify Vertical alignment option
to cell A1 with the long spreadsheet title.

Instead of using a blank row to separate your
table titles from the first row of data, apply the
Top or Center Vertical alignment option to the
cells with the titles and then manually increase
the height of their rows. If you don't want to
change the vertical alignment of the titles, you
create a sense of vertical space simply by
increasing the height of the first row of data.

Rotating text entries

Long column headings tend to inflate the width of
the individual columns in order to display all their
characters. These are the leading culprits in making
tables of data much wider than they need to be —
often preventing an otherwise manageable table
from fitting on the page when printed. Instead of
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widening the columns just to display long headings,
you can often keep those column widths down to a
reasonable size simply by rotating their column
headings. You’d be surprised how much real estate
you can save by rotating column headings up even
as little as 45 degrees.

Figures 21-5 and 21-6 illustrate how this rotating-col-
umn-headings trick can save on overall table width.
In Figure 21-5, you see the column headings for the
production schedule right before rotating their base-
lines up (technically counterclockwise) by 60
degrees. As you can partially see in columns H, I,
and J, displaying the headings for these columns
makes them much wider than they really need to be.
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¢ Figure 21-5: Getting set to rotate the column headings
45 degrees counterclockwise.

To make this project schedule more compact with-
out having to shorten the text for the column head-
ings, | simply use the Orientation control on the
Alignment tab of the Format Cells dialog box to
rotate the headings up 60 degrees. Figure 21-6 shows
the same schedule after rotating the column head-
ings and then choosing Format=Column= AutoFit
Selection. As you can see in this figure, rotating
these headings up and then narrowing the column
widths really compact this table.
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¢ Figure 21-6: Schedule after rotating the column headings
up to narrow their columns.

To squeeze columns down to one character
wide for forms that just use check boxes,
rotate the column headings 90 degrees coun-
terclockwise or select the orientation wherein
the characters appear one over the other. (To
do the latter, select the Alignment tab of the
Format Cells dialog box and click the sample
that shows the word Text with the characters
aligned this way.)

Getting Your Text under Control

The Alignment tab on the Format Cells dialog box
provides you with three methods for managing the
text entries in your spreadsheet. The first two con-
trols are specifically designed to manage extra-long
text entries so that they fit within a column width
that’s considerably narrower than would otherwise
be required to display all the text. The last method
enables you to center a text heading over several
columns as you might want to do with a title for a
table of data.

Making text wrap within a cell

When you want to maintain a set column width by
wrapping long text entries in a cell selection onto



several lines, select the Wrap Text check box in the
Text Control section of the Alignment tab. You can
use this control to break up a long table heading that
would normally spill over several blank columns so
that all its text fits within the current column width
set for the data in rows below. You can also use it to
effectively control long column headings that would
otherwise force you to widen the columns of data
much more than is necessary to just display their
numerical entries.

Figures 21-7 and 21-8 illustrate this kind of situation
and solution. Figure 21-7 shows a sales table whose
column headings are extra long. They’re so long in
fact that it would require widening their columns
way beyond what is necessary just to display the
financial data.
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* Figure 21-7: Sales table with really long column headings
whose text needs to be wrapped.

To remedy this situation and make this table much
more compact, follow these steps:

1. Select the columns that contain the long col-
umn headings.

In this example, I selected the letters B through J
in the column header.

2. Manually narrow the selected columns to the
width necessary for displaying the data entries.

For this example, with the help of the Width
ScreenTip, I narrowed the selected columns to a
width of 12.86 characters (95 pixels) by dragging
the right border of one of the selected columns.
(Here, narrowing one column automatically nar-
rows all the other selected columns.) Doing this,
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Getting Your Text under Control

of course, truncates the long column headings in
the second row.

3. Select the range of cells with the long column
headings that you want wrapped to the new
narrower column widths.

For this example, | selected the cell range B2:J2.

4. Open the Format Cells dialog box (Ctrl+1),
select the Alignment tab, select the Wrap Text
check box, and click OK.

Figure 21-8 shows the results of this operation. Excel
automatically wraps the column headings so that
they’re entirely displayed within the current column
widths. At the same time, the program automatically
increases the height of row 2 to accommodate these
wrapped lines of text.
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* Figure 21-8: Sales table after wrapping the column
headings to display on several lines in the
narrower columns.

Shrinking the text to fit within a cell

The second way of getting long text entries to fit
within a certain cell width is to shrink their text
down to size with the Shrink to Fit check box option.
This option is a lot less successful than Wrap Text
because Excel often ends up shrinking your text
entries so much that they’re illegible without the use
of a magnifying glass. (See Figure 21-9 for a prime
example of this.)

Reserve the Shrink to Fit option to those text
entries that almost fit within the current col-
umn width to guard against reducing them so

much that they’re no longer legible.
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* Figure 21-9: Sales table after making the column
headings illegible by shrinking them to fit
the various column widths.

Centering a heading across columns

The Merged Cells check box on the Alignment tab of
the Format Cells dialog box enables you to mesh
together separate cells of a single range to create a
mega cell. The purpose for doing this is so you can
change the horizontal or vertical alignment of its
data entry with regard to the new mega cell’s bor-
ders. (The data can be either a text or numeric entry
as long it was made in the first cell of the erstwhile
separate cell range.)

Because your purpose in merging a cell range into a
mega cell often is to be able to center a heading
within it so that the heading spans several columns,
the Formatting toolbar contains a Merge and Center
button. By clicking this button, you combine two dif-
ferent controls on the Alignment tab of the Format
Cells dialog box:

Technique 21: Dazzling Alignments for Data Entries

v The Center option in the Horizontal drop-down
list box in the Text Alignment section

v The Merge Cells check box option in the Text
Control section

Figure 21-10 illustrates the most common use for the
Merge and Center button. Here, I have centered the
spreadsheet title entered into cell Al over columns
A through I by first selecting the cell range Al:I1 and
then clicking the Merge and Center button on the
Formatting toolbar.
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¢ Figure 21-10: Sales table after centering the spreadsheet
title across columns A:l.

The Merge and Center button is a toggle
@ switch. The first time you click it, Excel merges
the selected cells and centers the text within it.

The second time you click it with the merged
cell selected, the program restores the cells
that were merged into one and returns the
text entry to its original alignment.



Charting Data
in a Snap

Technique

Save Time By

v~ Creating an instant chart
on a new chart sheet

v~ Making efficient use of
the Chart Wizard

graphic form using one of Excel’s chart formats. By representing

the numbers in your spreadsheet in graphic form, users can spot
trends and anomalies in the data much more quickly than when perusing
the raw figures (no matter how well you’ve formatted them).

O ne of the most effective ways to present your worksheet data is in

Excel makes it a snap to turn the tables of data in your spreadsheets into
vibrant, inspiring charts. When charting data, you can either create the
chart on its separate chart sheet or embed the chart as a graphic object
on one of the regular worksheets in the workbook. If you choose to
embed the chart as a graphic object, you can then modify the chart’s size
and position as you would a photo or piece of clip art that you add to the
worksheet. You can also easily print the chart along with its substantiat-
ing data in a report. If you create a chart on a separate chart sheet, you
can easily print the chart on a separate page of your report without hav-
ing to worry about fitting it in with surrounding data.

Instant Charts

If you want your data graphed on a separate chart sheet, you can do this
in as little as one keystroke, two tops. If you're dealing with a table of
data where you want all the data graphed, you simply position the cell
pointer somewhere in the table of data and press F11. If, however, you're
dealing with a table of data that includes numbers you don’t want graphed
(subtotals or grand totals in the table), you need to take the extra step
of selecting the range of cells to be graphed (column and row headings
including the numbers to be represented) before you press F11.

Figures 22-1 and 22-2 illustrate just how incredibly quick and easy it is to
generate a chart on its own sheet. Figure 22-1 shows a production sched-
ule of projected units to be produced in the last nine months of the calen-
dar year (April through December) arranged by part number. When I first
open the workbook with the cell pointer automatically saved in cell Al, I
just press F11 to graph this table of data.
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¢ Figure 22-1: Data table with production schedule
arranged by part number.

Figure 22-2 shows you the result of pressing F11.
As you can see, Excel instantly creates a clustered
column chart on its own chart sheet using the rows
of data in the production schedule as the data
series. This chart sheet is named Chartl and is
placed in front of all the other worksheets in the
workbook.
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¢ Figure 22-2: Clustered column chart created from
production schedule on its own chart sheet.

Because I didn’t preselect the range of data to be
graphed, Excel automatically selects all the rows of
data in the table and represents them as the differ-
ent data series in the chart. This includes the last
row — the one containing the monthly subtotals.

(In the column chart, these totals are represented
by the last data series — the tallest bars in each
monthly category.)

To prevent Excel from graphing the subtotals row, all
I needed to do was to select the cell range A2:J6
before I pressed F11. To eliminate this total data
series and have Excel redraw the chart without it, |
just click any one of the columns representing indi-
vidual data points of this total data series and then
press the Delete key. Figure 22-3 shows you the col-
umn chart after eliminating the totals data series
from the chart.
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* Figure 22-3: Clustered column chart after deleting the
totals data series.

After making sure that you have just the data you
want represented in the chart, you can get down

to the business of enhancing it. Because Excel auto-
matically displays the Chart toolbar (shown in
Figure 22-4), you can use its buttons to make many
of these chart improvements. For those options that
are not readily available from the Chart toolbar, look
to the options on the Chart pull-down menu — which
is automatically added to the Excel menu bar when-
ever you make a chart sheet active or select an
embedded chart on a regular worksheet.
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* Figure 22-4: Use the buttons on the Chart toolbar to
enhance the basic chart.

Typical enhancements that you can make to your
new chart include

v Change the orientation of the data series in the
chart. By default, Excel generates the data series
in the chart from the rows of data. To generate
the data series from the columns of data, click
the By Column button on the Chart toolbar.

v Change the chart type. By default, Excel repre-
sents the data as a Clustered Column chart. To
select a new chart type, click the Chart Type drop-
down button and then select the new chart type
from the pop-up palette. If this palette doesn’t
have the chart type you want, choose Chart=
Chart Type to open the Chart Type dialog box
containing all the chart types supported by Excel
as well as any custom chart types you create. (See
Technique 23 for more on custom chart types.)

v Add chart titles. By default, the new chart has no
titles. To add titles, choose Chart=>Chart Options
and then enter the Chart title, the Category (X)
axis title, and the Value (Y) axis title as needed.

v Format the chart titles and headings. To do this,
select the chart object you want to format (Chart
Title, Category Axis Title, Value Axis Title, and
so on) in the Chart Objects drop-down list box
and then click the Format - button on the Chart
toolbar.

v Add a data table to the chart that displays the
graphed data beneath the chart itself. Click the
Data Table button on the Chart toolbar.

119

Chart Wizard Magic

Figure 22-5 shows you the same chart as originally
shown in Figure 22-3 after changing the chart type
from the default Clustered Column type to a
Clustered Bar chart. In addition, | added a data table
to the chart to show the underlying values repre-
sented in the chart.

If you decide that you'd like to convert your
fully enhanced chart to an embedded chart,
choose Chartr>Location, select the As Object
In option button in the Chart Location dialog
box — along with the worksheet in which to
embed it in the As Object In drop-down list
box — and click OK. Excel then converts the
chart into a graphic object and adds it to the
original worksheet and at the same time
deletes the chart sheet.
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* Figure 22-5: Changing the chart type to Clustered Bar
and making suggested enhan