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Introduction

M acromedia has always been known as a leading-edge design company.
Since it introduced Director more than a decade ago, Macromedia

has shrewdly developed products (like Fireworks and Dreamweaver) and
acquired products (such as Flash and FreeHand) geared toward turning
artists into developers. With its acquisition of Allaire, Macromedia added

a powerful technology platform to its suite of design-oriented products.
Macromedia Studio MX 2004 represents the natural evolution and integra-
tion of the Macromedia products into a single set of Web development tools.
The result? We've worked in Web development since its inception, and we
can honestly say that there’s never been a product that is as user friendly,
powerful, and complete as Macromedia Studio MX 2004.

About This Book

Macromedia Studio MX 2004 All-in-One Desk Reference For Dummies (we know,
it’s a mouthful) is designed to be a hands-on, easy-to-understand guide to the
features in all the Macromedia Studio products. The no-nonsense approach is
designed to help you begin to build Web sites by covering the basics in a clear
and concise fashion. The way we see it, you’ve got things to do, and reading a
book, even a clever one, takes up valuable time. The faster we can help you
do something or answer a question, the better.

How to Use This Book

You can use this book in a few different ways:

4+ As areference: If you already have a Web site and use Macromedia
Studio, this book can be a handy refresher for that thing you couldn’t
quite remember how to do. Whether it’s exporting graphics to
Macromedia Flash from FreeHand, or the right syntax for a query
in ColdFusion, use this book to fill in those gaps that we all have . . .
especially as we get older.

4 To guide you through building a Web site: Several authors contributed
to the creation of this book. All of us have a wealth of experience in the
process of building Web sites. In this book, we’ve tried to impart as
much of our collective knowledge about the processes and pitfalls of
building Web sites using these tools as we can.
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Three Presumptuous Assumptions

4 To learn about the tools: In this All-in-One Desk Reference, each mini-
book has at most 150 pages to cover a product or topic, which means
that we get right to the point and make the topics covered easy to
understand. We believe that this approach makes figuring out these
products easier.

Three Presumptuous Assumptions

Before you dive in to the book, we thought we should give you some advance

warning of our expectations. We know, you’re the audience, so we shouldn’t
be presuming anything! But, just so you know where we’re coming from, here
are our three basic assumptions about you, the reader:

4 You're in a hurry. Frankly, if you wanted a more in-depth book, you’d
have picked up a regular For Dummies book on one or all of these prod-
ucts. Hence the no-nonsense, get it done, and keep on moving approach
you’re gonna see inside this book.

4 You know something about Web development. This isn’t a book where
we're going to spend a lot of time talking about HTML and how it works.
So you won'’t find a chapter anywhere in this book titled, “What the
Internet Is and How It Works.”

4+ You'll experiment on your own. The approach here is to give you
quick, useful examples of how things work across all these products. In
some cases, the examples can be fairly sophisticated. In most cases,
though, it’s the basics. Our hope is that you’ll take those basic examples
and build your own, more complex ones on top of that, according to the
complexity of your site.

Macintosh versus Windows

Macromedia Studio is both a Windows and a Macintosh product. In this book,
you see us use the Windows commands, and the figures are all showing
Windows XP. The reason we chose to use the Windows version is because
the ColdFusion MX 6.1 Developer Edition is included on the Windows version,
but not the Macintosh version of the product. If you are using Macromedia
Studio on the Mac, you can still do everything in Book VI if you're using
ColdFusion at your place of business or if your Internet Service Provider (ISP)
supports ColdFusion.

In general, you can convert between Windows (PC) and Macintosh key com-
mands by using the following equivalencies:
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4 The Ctrl key on a PC is equivalent to the Cmd (38) key on a Mac.
4 The Alt key on a PC is equivalent to the Option key on a Mac.
4+ The Enter key on a PC is equivalent to the Return key on a Mac.

How This Book Is Organized

Like all the All-in-One Desk References, this book’s chapters are organized
into minibooks. Most of the minibooks revolve around products, but one is
geared toward the Web development process. The following sections
describe each minibook in more detail.

Book I: An Introduction to Building Web Sites

Before we jump into the products in the Macromedia Studio suite, we want
to frame the conversation around how Web sites get built: things to con-
sider, organizing yourself, and so on. This minibook walks you through how
to figure out what it is you're really building, and how you should go about
preparing to build it.

Book II: Dreamweaver MX 2004

Dreamweaver MX 2004 is the crux of any Web development effort with
Macromedia Studio, so naturally, this is a good place to start. In this mini-
book, you get a hands-on look at how you can use Dreamweaver to create
and manage your Web sites, whether they’re more design-oriented (with
Macromedia Flash) or technology-driven (with ColdFusion).

Book 11I: Fireworks MX 2004

Whereas Dreamweaver is the tool that helps you manage your Web site,
Fireworks MX 2004 is designed to spur your creative vision. This minibook
shows you how to use the variety of tools in this impressive program to
bring the look and feel of your site to life. It also shows you how to use
Fireworks in conjunction with the other Macromedia Studio products (such
as Macromedia Flash) effectively.

Book 1U: FreeHand MX

This is the minibook for the true illustrators. Whether the final product is a

Flash-based or a traditional HTML-based site, FreeHand MX gives designers

the tools they need to create compelling imagery. In this minibook, you find

out how to turn your ideas into working graphical art to be used in a variety
of Web applications.
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Icons Used in This Book

Book U: Macromedia Flash MX 2004

Macromedia Flash MX 2004 is probably the most exciting of the Macromedia
products. Macromedia Flash delivers animation, sound, and interactivity to
the Web like no other product ever has. If you’ve ever wanted to find out
how to use this tool to add some new zeal to your Web site, then this is the
minibook for you!

Book VI: ColdFusion MX 6.1 Developer Edition

ColdFusion, once left for dead by many in the industry, now appears well
poised to lead mainstream Web development into the dynamic content
arena. In this minibook, you too can find out just how easy it is to use
ColdFusion to create dynamic Web sites.

Book VII: Contribute 2

In this minibook, we introduce you to the newest member of the Macromedia
family, Contribute 2. Designed as a collaborative tool that turns your hard
development work into an easy interface for non-techies to update and pub-
lish content to the Web, Contribute puts the power of building Web sites in
the hands of the people you work with. In this minibook, you find everything
you need to know to get you and your collaborators up and running with
Contribute in no time flat.

Icons Used in This Book

A\

<MBER

%,

WING/

%,

Along the way, when there’s something of interest to point out, we toss in
one of the icons you see in the left margins. When you see one, slow down
for a moment to check it out to see what’s up!

If there’s a way to make something easier, or a more commonly accepted
way of doing something, we tell you about it. This is the icon to look for!

When we really want to reinforce something, we throw in a Remember icon.

Pitfall ahead! That’s what this icon is all about. If something could cause
trouble, we let you know.
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Because we love technology, you have to forgive us for geeking out every
now and then. When we do, though, we let you know with this icon.

This icon highlights new features in the Macromedia Studio MX 2004 suite of
products.

Where to Go from Here

If you've read this far, then you may actually be a candidate for reading this
book cover to cover! From here, we suggest you dive right in to whatever
section you’'re most interested in. Remember, all these minibooks are self-
contained and don’t require you to read the others. So have at it. It’s buffet
time, and your plate needs fillin’ up!



0 Macromedia Studio MX 2004 All-in-One Desk Reference For Dummies



Book |

An Introduction to
Building Web Sites

The 5th Wave By Rich Tennant

Tiovd of Jurgle ~wheve futuve in that?”



Contents at a Glance
Chapter 1: Why Build a Web Site?

Chapter 2: Developing Web Content

Chapter 3: Choosing the Right Tools for the Job
Chapter 4: Best Practices for Web Development

17
23
31




Chapter 1: Why Build a Web Site?

In This Chapter

+ Exploring the reasons that Web sites get built

v+ Finding your place on the Web
+* Understanding what drives people to the Web
+~ Investigating common types of Web sites

v Getting ready to build a Web site

So you want to build a Web site? Well, congratulations! If you're read-
ing this book, then you’ve probably already purchased a copy of
Macromedia Studio MX 2004, and you're ready to dive right in. Macromedia
Studio is a fantastic tool that enables you to create a wide array of content
and graphics to deploy on a Web site that is dynamic and easy to maintain.

But software isn’t all you need in order to create a wonderful Web site. It
also takes creativity, a good eye, a well-thought-out plan, and some serious
soul searching about why you want to undertake this endeavor in the first
place. This chapter offers some insight into how sites get built, why they are
created, and who they are aimed at. So grab your pen and paper and get
ready to jot down your own ideas about the great site that you want to
build.

Understanding Why People Build Web Sites

In the early days of the Internet, all Web sites generally looked the same and
served similar functions. Back then, an average Web site could be described
as a big online book with linked pages. In short, in its infancy, the Internet
was not all that interesting graphically and was severely lacking in interac-
tive sophistication.

All that has changed. Today’s Internet is a dynamic amalgam of text, graph-
ics, interactive tools, commerce, and communication. If you are part of a
business, an association, the government, or an academic institution,
chances are a Web site supports some or all of the mission of the group. But
not every venture requires a Web site, which naturally leads to the question,
“Why build a Web site?” Most organizations and individuals establish a pres-
ence on the Internet for one or more of the following reasons:
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Figure 1-1:
A common
product and
service style
Web site.

¢+ 4

To sell a product or service directly online, as shown in Figure 1-1
To provide information or tools
To provide an extension of — or support for — products and services

To find other organizations or people to work in a particular area of
interest

4 To introduce and promote an organization and its mission

4 To remain competitive with other organizations that are already on the

Internet

To promote community development by bringing groups of people
together around ideas, people, or causes, either online or in person

To share artwork, writing, or photographs

&' 115 Inc. . Microsoft Intemet Explorer S x|
r

Fils

Q- QO M @G Pomes Srrecin G @ (- 155 ) B
vt ) g (s 41 cemberme g batln et v:b ris * @seon F

Edit View Fovorites Tooks Help

@

EE e s

Finding Your Place on the Web

Before you begin to think about the kind of site you're going to build (either
for yourself or for your organization), you should consider each of the fol-
lowing questions carefully. Doing so can help you target your site to an
appropriate audience and prepare yourself for the work ahead.
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4+ Consider your content:

e What is the content going to be on your site? Is it unique?

How often will you be updating this content?

e Are there any other sites that already do what you want to do? If so,

how will you differentiate your site?

Consider the early explosion of sites during the dot-com boom. At one
point, more than five pet sites were all trying to hawk their wares to
users. Only one survived, and that was because it was a traditional
retailer first. Market saturation is a sure way to spell doom for your ven-
ture, so be sure to check out the competition first!

4 Select a format and interface:

In what formats will your content be delivered? Will you just use text
and graphics, or will you also need animation and/or forms that
respond to user input?

What are the technical requirements needed to view your content?
Will users need a video or audio player or plug-in? For example, to
view a Flash animation, users need the Macromedia Flash Player
plug-in.

4+ Know your audience:

What audience or audiences are you trying to reach with this content?
Do they need or want it?
[s there any other place they can get this content already?

What are the demographics and technical capabilities of this
audience?

If your site has more than one audience, are there differences
between them and do they need the content delivered differently? If
so, you will want to take advantage of ColdFusion’s dynamic script-
ing language to deliver different content to different audiences.

4+ Manage your workload:

e How much time and effort are you willing to give in order to support

this site?

e Are other people working on the site with you?

e Who’s going to create the graphical design for the site? Of course, if

it’s you, you've got powerful tools at your disposal with Macromedia
Studio MX 2004.

e Are there any deadlines you need to keep in mind when developing

your site?
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These questions have no right or wrong answers. Instead, they’re designed
to help you formulate an idea of where you're going when you’re building a
site. Frankly, if you’re building a personal site, then these questions are moot
to some degree because you can build whatever you want and it may not
matter whether someone else can read it or see it. Of course, if you're think-
ing about selling your new products on the Web, then these questions can be
critical to your overall business success, not just your Web site’s success.
For example, if you find that a number of other sites have similar products or
a similar focus to what you had in mind for your site, you may consider not
building a site at all or changing the focus of the products you are selling.

What Drives People to the Web

What kinds of services, you may be wondering, are people looking for on the
Internet? Six years ago, the Internet was largely a research medium, meaning
that people would hit the Internet to try to find information about something
fairly academic or obscure. This is not surprising, given that universities
were the first groups to start putting their content online.

Today, the number of reasons people head to the Internet has grown dra-
matically, and includes the following:
4 To research, compare, and purchase products

4+ To find and interact with other people (business colleagues, friends,
romantic interests)

4 To get daily news and information delivered in real time

4 To search for and find information about any topic or organization of
interest

4 To deliver and promote their own messages and products to others on
the Web

4+ To watch or listen to events, online and otherwise, delivered in a variety
of audio and video formats

<+

To educate themselves via online classes and enrollment in universities

<+

To play games and entertain themselves

4 To complete all sorts of personal and professional tasks that can now be
done securely online, such as online banking, personal finance, invest-
ing, tax submission, travel, donating, and procurement

These items run the gamut of professional and personal, and they cross
demographic lines. What is common among most online users, though, is that
they begin their online usage with a focused purpose, and that focus then
bleeds over into surfing for things that interest them throughout the Web.
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Choosing the Right Type of Web Site

For all its diversity in content, the Internet really doesn’t have that many dif-
ferent types of Web sites. Why do so many Web sites look alike? The main
reason is that people want their sites to be easy to use, free (or close to it),
and similar to other sites they’ve seen or experienced. This has resulted in
the emergence of some standard types of Web sites. A number of compo-
nents for these sites can be found in ColdFusion. Where applicable, we've
noted it in the following list. The most common types of sites include:

4 The Product Site: The most common type of site. Generally, the site
offers some basic information about a company, its products, staff
members, perhaps a product demo, and a way to contact the organiza-
tion to get more information. Examples of this kind of site would be
www.symantec.com, wew.amf.com, and www.nadelectronics.com.

4 The Commerce Site: A storefront on the Internet. Whether it’s a single
company that carries just their own specialized products or a retailer that
sells a wide array of products, these sites are geared towards purchasing
products and offering accessories to complement those products. An
example of this kind of site would be www.macys . com. ColdFusion offers
tools that can help you to add a shopping cart, a search function, and
more to your site easily.

4+ The Portal Site: A site that aggregates content from a wide variety of
sources. Portal sites tend to be rich in content and links but short on
graphics. The idea is to provide users with a launching pad to other
destinations on the Internet, though in recent years, many of these
portals are adding features to try to keep their users on their own site.
An example of this kind of site is www.yahoo. com. ColdFusion includes
robust search capabilities that enable you to have more content-rich
sites that are easily indexed and searched.

4+ The News Site: A site that, in general, mirrors an offline counterpart,
such as ABC News. These sites provide a lot of the same information
as their offline counterparts through the use of text, video, audio, and
graphics, and also provide services geared towards the online audience,
such as chat sessions, newsletters, and personalized content. An exam-
ple of this kind of site would be www.cnn.com. ColdFusion includes
tools for adding chat to your site as well.

4+ The Application Site: A type of site that offers perhaps the greatest
diversity of all the sites. Application sites are geared towards a specific
purpose, such as banking, investing, automobile purchasing, travel plan-
ning, photo galleries, event planning, or online greetings. Some of the
commonalities among these sites include user accounts, password pro-
tection, and the widespread use of e-mail campaigns to try to keep users
coming back. Examples of this kind of site include www.egreetings.com,
www.imotors.com, and www.bankofamerica.com.
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4+ The Personal Site: Personal sites also offer a great deal of variety in
their design and function. Personal sites usually include some of the
designer’s work, opinions, and rants; links to other sites; and pictures.
Examples of this kind of site would be www. Toungeboy.com and
www. katswindow.net.

Macromedia Studio MX' 2004:
Your Ally in Development

After you’ve answered a number of the questions in the “Finding Your Place
on the Web” section, you may be wondering how you’re going to build your
grand Web site. Well, don’t fret. With Macromedia Studio, you have the most
complete, user-friendly, and popular development suite on the market. Even
though professionals use these products all the time, the programs in the
Macromedia Studio suite are truly designed for the first-time Web developer.
With an array of tutorials, wizards, and interfaces that keep you as distant
from the code as you want to be, Macromedia Studio makes the Herculean
task of building powerful Web applications seem like just another project.

The goal with Macromedia Studio is to help you, the developer, build com-
pelling and powerful Web sites in the shortest amount of time, while simulta-
neously helping you alleviate cost and resource issues common to Web
development. Macromedia Studio includes several tools to help make this
happen:

4+ Dreamweaver MX 2004: The premier tool for easily building Web pages.
In recent versions, it has been combined with ColdFusion to make devel-
oping dynamic Web applications much easier.

4+ Fireworks MX 2004: A leading tool for the graphical development of a
site. Fireworks helps you design the look and feel of your site, as well as
prepare the graphics for inclusion in an HTML or CFML file.

4 Macromedia Flash MX 2004: The world’s most popular tool for adding
animation and sound to Web sites. Macromedia Flash will truly change
the way any site works.

4+ FreeHand MX: The Web developer’s best friend for creating illustrations
for Fireworks and Macromedia Flash.

4 ColdFusion MX 6.1 Developer Edition: Give yourself the powerful tools
to add databases, e-mail servers, and other dynamic elements to your
site. ColdFusion allows you to take control of one of the most powerful —
but also easy to learn — scripting languages for the development of com-
pelling Web applications.
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Contribute 2: Collaborate with others and take all the development
hassle out of building (and maintaining) Web sites with Contribute.
Using this tool in combination with Dreamweaver will help you design
Web sites in such a way that just about anyone in your organization
who can use a word processing program will be able to add and modify
content on the site.

Before You Start: Things to Know

Hopefully, all this information hasn’t scared you into dropping this book and
deciding to open a lemonade stand instead. This last section is just a quick
check of some things you should be aware of before you jump into this ven-
ture called Web development:

<+

<+

Plan ahead. Building a Web site always takes longer than you think, so
give yourself more time than you originally planned for!

Get organized. Remember to categorize your content and use those
categories as the initial architecture for your site when you’re doing the
user interface design.

Always do the user interface design before the graphics design. The
user interface design specifies how your site will work, while the graphi-
cal design is the look and feel. If you do the graphics before the architec-
ture is done, you'll likely end up redoing a lot of your design after you’ve
figured out how your site is going to work.

Not all browsers are the same. Internet Explorer and Netscape
Navigator are the two most common browsers, and in recent versions,
they’ve adopted the same standards. But there are still quirky differ-
ences between the two browsers, and you have to check your work on
both browsers.

Not all platforms are the same. If only they were! Explorer and Navigator
work slightly differently on the Mac, in Windows, and in Unix. If you're
developing on the PC, find a friend or a graphic designer with a Mac

and check your work on her system as well. Dreamweaver also includes
some tools to help you verify whether your site will work the way you
hope it does on a variety of platforms.

Learn from sites you like. If you like the way a page looks — but can’t
imagine how such a design could have been translated to the Web —
you can view the source code in your browser to see how the page was
constructed. Seeing how other people have coded their pages can spur
you on to create your own unique designs.
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Lots of stuff can be had for free. The Web is filled with geeks like us
who have made all sorts of crazy applications, like chat engines, bulletin
boards, and even wholesale applications. A lot of them can be had for
free or something close to it. This is where sites like www.google.com
and www.downTload.com can be your friends.

Old content equals a dead site. You have to be prepared to update your
site on a semi-regular basis. When content is stale, people will notice,
and they will stop coming.

If you build it, tell someone. It’s one thing to build a site. Site-search
spiders will eventually find you, but if you really want to be seen, then
you really need to promote yourself. When you’re done building,
remember, it’s time to start promoting.

Don’t be afraid to ask. Building sites can be fun, but it can be especially
frustrating if you can’t figure out how to do something. Well, here’s a
secret: Developers like to talk about what they do. So if you're stuck, try
finding a user group or searching the Web for an answer to your ques-
tion. Someone may have come across the problem before, and if they
haven’t, then there are plenty of resources for the asking. Macromedia
is also very good about supporting these kinds of groups, so you can
always check out its Web site at www.macromedia. com for listings of
developer resources.



Chapter 2: Developing
Web Content

In This Chapter

v+ Developing content: An overview

v~ Categorizing Web content
+ Organizing your content
v+ Creating your content

v+ Prepping your content for the Web

One of the things you find out when you do Web development for a living
is that the Internet is all about repetition. No matter how many sites
you build, the discussion always begins with “So, what’s the content gonna
be for this site?” Usually, the response is a blank stare. Companies, organiza-
tions, and individuals usually come to the conclusion that they need a Web
site long before they’ve thought about what should be on that site.

Some basic rules of content development are common to all Web sites. This
chapter gives you the basics to consider as you're doing perhaps the most
important part of building your Web site: contemplating, designing, and cre-
ating your content.

Developing Content: A Four-Step Process

Developing your content strategy can be the best part of building a Web site
because it’s the one time you can sit around a table with your fellow col-
leagues (or your trusty pet, if you're building a personal site) and truly be
creative about the kinds of things you want on your Web site. When you’re
in the throes of development, you may find yourself uttering: “Remember
when we thought this was a good idea!”

Content development follows a fairly structured course in the modern world
of Web design. It usually includes the following four basic steps:

1. Brainstorm the types of information that you want to include on your
Web site.

2. Put that information into categories that make sense for the type of Web
site you're building and the way you want users to interact with the site.
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3. Gather and create the content for the site.

4. Prepare your content for the Web.

A great temptation is to just start building a site the moment something cool
comes along, be it an idea, a graphic, or even words. The reason to do all
this planning before even cracking any HTML code in Dreamweaver or gen-
erating any graphics in Fireworks is to make sure that you don’t get too far
down the path of development and suddenly find yourself backed into a
corner, trying to put content where it doesn’t really belong.

Choosing and Organizing Content

You may be wondering just what, exactly, is considered content. Here’s a
little content quiz consisting of three simple yes or no questions:

1. Is a mailing list sign-up form, as shown in Figure 2-1, considered content?
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2. Is a downloadable file considered content?

3. Is a picture of a product, or even of your pet ferret, considered content?

The answer to all these questions is yes. In practical terms, every single
thing you put on a Web site is considered content.
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Classifying common types of Web content

The fact that everything is content doesn’t really help you get your site
organized. Thankfully, while anything can be content, things tend to show
up on Web sites in some pretty common formats.

As you begin to think about what you want to put on your Web site, you
should also consider the different forms that you want that content to take.
To give you a kick-start, Table 2-1 includes the most common forms of con-
tent and the data that makes up that content.

Table 2-1 Common Types of Web Site Content

Content Type Data Commonly Associated with This Type of Content

Graphics GIF and JPEG files

Documents Word, Excel, PowerPoint, and Adobe Acrobat (PDF) files

Text HTML text

Audio WAV, AIFF, MP3, Real Audio, and Windows Media files

Video QuickTime, Real Video, and Windows Video

Plug-Ins Flash animations, QuickTime VR, IPIX, and other tools that allow
users to view video and graphic content beyond what basic HTML
can support

Forms Elements within HTML designed either to submit information or to

return targeted content back to a user’s browser

Categorizing your content

In addition to organizing your content by its file type, assigning meaningful
categories to your content makes developing your site infinitely easier. You
can organize your content in any way that makes logical sense for the site
you're building. Most of the time, a single piece of content can be catego-
rized in more than one way, so don’t worry about limiting yourself to just
one classification method.

The following list includes some of the most common ways to categorize
content:

4+ Organizing by concept: This varies from site to site, but this method
entails organizing your site by the major thematic elements, as defined
by the content that you’re going to be putting up. An example of this is
organizing a company site around the various products it offers.

4+ Classifying by function: Functions are things you can do on a site and
can serve as organizing principles for your site. For example, a financial
services company may categorize its content around a series of investing
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and banking tools. In fact, that financial services company may choose
to categorize its content not only by the tools on the site (functions) but
also by the various products it offers (concepts), which demonstrates
that there’s more than one way to slice content.

Categorizing by logical steps: Some sites dispense with the notion of
concepts or functions altogether and focus on tasks that get something
done. Online auto sites, for example, like to walk visitors through a series
of steps to find the car they’re looking for, offering related content at
appropriate points along the way.

Sorting by topics or keywords: Sites with a diverse array of content
tend to offer users a couple of ways of getting at information. Keywords
(topics) are a common way to associate content with more than one
area of interest. For example, a music store may organize its site by con-
cepts such as instruments, sheet music, and accessories, and sort the
content by topics such as pianos, drums, guitars, amplifiers, and flutes,
to name just a few.

Arranging hierarchically: This method of categorization assumes
that some content elements are more important than others, which

is reflected in how the content is displayed on the site. Hierarchy is
often used in conjunction with another categorization scheme. To go
back to the banking example for a moment, imagine that you've got
your portfolio online. Usually, your portfolio is organized by concept
or function, as well as by hierarchy. The portfolio is given more promi-
nence than the other products the bank sells, because the folks at the
bank know that the content in the portfolio is more important to

the user.

Grouping by type: As noted in the previous section, content type is
the other major way to categorize content. On a number of media sites,
such as the ABC News site (www.abcnews . com), you can easily find all
the video content in a single location, in addition to being able to get
your news by feature area.

Creating Content for the Web

If you've got the right tools, creating content for the Web is a breeze. And
because you've got a copy of Macromedia Studio MX 2004, you’ve already
got a host of tools that can help you create all sorts of content for your site.
To recap, here is a list of some of the content you can create with the prod-
ucts in the Macromedia Studio suite:

4+ Fireworks MX 2004: Create quality photorealistic graphics that can be

used in Dreamweaver or Macromedia Flash.
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4+ Dreamweaver MX 2004: Create pages from basic HTML to complete Book |
database driven applications, as well as use the publishing tools to help Chapter 2
you maintain your site.

4 FreeHand MX: Make illustrations that can be used to create the look
and feel of your Web site or your Flash movie.

4 Macromedia Flash MX 2004: Create animations that bring your site
to life.
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4 ColdFusion MX 6.1 Developer Edition: Create dynamic, database-
driven applications.

4 Contribute 2: Have non-technical colleagues add and modify content on
the site in both the development and maintenance phases of the Web
site’s life.

In addition to these tools, you’ll find that other non-Macromedia software
tools can be essential to generating and managing content:

4+ Microsoft Word: Word is the most common word processor in the
world for a reason. When you’re creating text for Web sites, there’s still
no better tool out there than Word for quickly and easily creating text.

4 Adobe Acrobat: The Acrobat PDF format has become the downloadable
document format of choice in the Web world. If you're going to develop
large, professionally-designed text- and image-heavy documents for the
Web, then investing in the full version of Adobe Acrobat is worth the
money. PDF files ensure that your documents will always have the same
look and feel, regardless of what browser or platform users may have.
Offering PDF files for download will also make your users happy
because they only need to download the free Adobe Acrobat Reader to
read your PDF documents.

4+ Microsoft Excel: As a spreadsheet, Excel can serve two very useful pur-
poses. It can help you manage your content by providing you with a
nice tool to manage your categorized data. With Excel, you can also
save data in CSV format, which is the most common data format for
importing into a database. So, for example, if you are providing your
users with a list of the names and addresses of people in your associa-
tion, then you might consider providing the information in CSV format,
so that users can import the contact information directly into their own
address book.

4 Microsoft Access (or equivalent): Access is a database. If you create an
e-commerce site, you'll find that your product data is best kept in a
database, rather than in plain text. Access is the most commonly avail-
able database (though not necessarily the most robust), and is easily
compatible with ColdFusion.
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Prepping Content for the Web

When preparing your content for delivery to the Web, here are a few handy
tips to keep in mind:

4+ Have a plan: If you haven’t gone through the process of content devel-

opment outlined previously in this chapter, your content is likely to be
disorganized. Be sure you have an overview of your content, as well as
an outline that shows all the various formats that your content will take
and how you’re choosing to categorize it.

Choose the right format: Take a long, hard look at your content. Are
you using the right format for certain types of content? Are your graph-
ics in acceptable formats, such as GIF and JPEG? Are your downloadable
items in PDF format? Be sure you're using the commonly accepted Web
file formats, and if you're not, be sure to create some text to explain why
you’re not using standard formats.

Be consistent: The Web relies on developers being at least somewhat con-
sistent. So if you have a product data sheet available in PDF format, make
sure that your other documents are in PDF format. Similarly, try to stick
to the same audio and video formats. That way, when people get to your
site, they’ll know what to expect, and they’re not likely to get frustrated.

Make your content more easily digestible: One last thing to keep in
mind: Just because you've written the Great American Novel and you
want to put it on the Web doesn’t mean that you should just put the
whole thing up in one huge piece. The Web is made to deliver content in
small chunks, and the best sites give viewers the facts first, and then let
people delve deeper at their leisure. Remember, people are busy, and
they may just need to get the facts quickly. For you as the developer,
this means creating highlights, summaries, thumbnails, or charts that
provide an introduction or an overview to your core content.



Chapter 3: Choosing the
Right Tools for the Job

In This Chapter

+ Developing a Web site with Dreamweaver

v+ Using Fireworks for design

1 Creating illustrations with FreeHand

v+~ Animating with Macromedia Flash

v Using ColdFusion to add dynamic content

+ Maintaining your site with Contribute

ou've probably heard that old saying, “A craftsman never blames his

tools.” Nowhere is that saying more appropriate than with Macromedia
Studio MX 2004. With six incredibly powerful tools at your fingertips, you
can create compelling and dynamic sites in no time flat.

Of course, even though a craftsman never blames his (or her) tools, a crafts-
man does need to know which tools to use for a given job, and sometimes,
in the world of Web development, that’s not always so clear. This chapter is
designed to clarify this issue by highlighting the do’s and don’ts of each of
the Macromedia Studio products.
¥ If you're already familiar with the products in Macromedia Studio, then
just take a gander at the following section and then head right to Book I,
Chapter 4.

Before You Begin: When Not to Use
Macromedia Studio MX 2004

Although you certainly can use Macromedia Studio for every bit of your site
development, some things are better done outside the tool suite:

4+ Content development and management: This is the process of develop-
ing the written content for the site, as well as managing the collection
and status of each piece of content on the site. Products like Microsoft
Word, WordPerfect, Microsoft Excel, and Microsoft Access are more
appropriate tools for this job.
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4+ Project management: This is the process of managing the steps of
the project from start to finish, as well as where and how to allocate
resources to the project. You may want to use Microsoft Project or
Microsoft Excel to manage your project.

Using Dreamweaver MX 2004 for Web Development

A\

No matter how graphic intensive or dynamic you want your site to be, you’ll
always come back to the fact that you have to build your Web site with
something. In Macromedia Studio, Dreamweaver is the Web development
workhorse. You can use Dreamweaver, shown in Figure 3-1, for a host of
practical Web development tasks:

4 Create and edit HTML or ColdFusion Markup Language code (or code
using ASP, JSP, and the like).

4+ Create “Sites” — a confusing Dreamweaver term that means a place
either locally on your computer or on a remote server where you keep
all the content for your Web site. When your content is in a
Dreamweaver Site, you can set up page templates and run various
reports on your site content.

4+ Upload all your Web pages from your local computer to a Web server on
the Internet that houses your site.

4+ Set up connections between your Web site and a database to make the
site dynamic.

4 Preview your work using Macromedia’s Preview in Browser tools before
you publish it on the Web.

4+ Review code for errors and badly formed code.

The best way to think of Dreamweaver is as the glue that binds your site
together. Other Macromedia products like Macromedia Flash and Fireworks
help to add flair and pizzazz to your site, but to actually include the files
that these applications produce in your site requires the HTML and publish-
ing tools that only Dreamweaver offers.

Ultimately, most of your content ends up in an HTML or CFML (ColdFusion)
page (or, depending on your server technology, an ASP, JSP, or other kind
of page), so if you don’t have Microsoft Word or WordPerfect, Dreamweaver
can also be used to create content as you would in a word processing
program.



Figure 3-1:
Use Dream-
weaver for
many Web
develop-
ment tasks.
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Designing with Fireworks MX 2004

Fireworks is easily the most versatile of all the tools in Macromedia Studio.
As shown in Figure 3-2, Fireworks is primarily geared towards creating the
graphical design of your site. With Fireworks, you can accomplish the fol-
lowing tasks:

<+

<+

Create graphical elements that make up the look and feel of your site by
using the Fireworks text and editing tools.

Apply filters that create photo-quality effects for the imagery in your
site.

Manipulate text to be used in graphical elements.

Use layers to manage the depth and positioning of elements on the
screen during your graphics development.

Slice up your page design into multiple images in preparation for inte-
gration into HTML using Dreamweaver.

Use tools to optimize the size and color of images on your site.
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These are just the core elements of Fireworks. In addition to being a power-
ful graphics development tool, Fireworks also incorporates elements of
FreeHand, Dreamweaver, and even Macromedia Flash, providing you with
additional functionality, such as the following:

<+
+

*
the scripting language JavaScript.

Creating vector images that can be used in Macromedia Flash animations.
Creating basic animations and publishing your images as a Flash movie.

Creating image rollovers that are common to most sites nowadays using

Generating the HTML to accompany your sliced images. Within the Web

layer in Fireworks, you can divide an image into multiple pieces, each of
which is called a slice. (See Book IlI, Chapter 6 for more information

about slices.)

All told, you can use Fireworks for a variety of development tasks.

IMtustrating with FreeHand MX

At first glance, with the flexibility of Fireworks, you may think that FreeHand
MX is the odd man out in Macromedia Studio. Not true! Although many of the



Figure 3-3:
FreeHand
in action.
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tools are identical to those you find in Fireworks, FreeHand offers illustrators
and Flash animation developers a greater degree of control and integration in
their work.

Some of the things that distinguish FreeHand (shown in Figure 3-3) from
Fireworks include the following:

4+ A wider array of line art creation and manipulation tools

4 Greater control of styles

4 Better color management tools

4+ Increased integration with Macromedia Flash

4 More import and export options
These distinctions may seem a bit subtle, and to some degree, they are.
However, when you get down to the nuts and bolts of building Macromedia
Flash animations, for example, you’ll see that FreeHand provides nearly

seamless integration with the product, offering you a more diverse palette
for developing compelling animations.
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Creating Animation with Macromedia Flash MX 2004

Figure 3-4:
Macromedia
Flash
changes
the way

you think
about a site.

After you've got a few Web sites under your belt, you may find that HTML
and graphics alone seem lifeless. Sure, they’re necessary, but soon you’ll
begin to wonder what else you can do to add some pizzazz to your sites.
That’s where Macromedia Flash comes in. Macromedia Flash enables you
to add animation, sound, and interactivity to your site.

Macromedia Flash, shown in Figure 3-4, can radically change the way your
site works. Macromedia Flash allows you to create a more compelling user
experience. Gone are the boundaries created by HTML and limited graphics.
Although you still need help from the other Macromedia Studio products,
you can think of Macromedia Flash as an entirely new development platform
for building your site.

In order to view the Flash movies you create, visitors to your site will need
to have the Flash plug-in installed in their browser. Luckily, almost everyone
with a standard graphical Web browser like Internet Explorer, Netscape
Navigator, or Safari has some version of the Flash plug-in installed.
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Creating a Dynamic Site with ColdFusion Book

Chapter 3

MX 6.1 Developer Edition o
° =

Static HTML only gets you so far with Web development. After you’ve built s §

that first-generation site, you may soon find that your Web site development §:,§

needs have grown and you require more out of your development tools. What ==

do we mean by more? Well, imagine you want to do any of the following: bl ;

5

4+ Customize the content of a site based on how a visitor got there.
4 Personalize the site by letting users choose their own content.

4 Open a store on the Internet with a host of product information con-
tained in databases.

4+ Create interactivity in your site through the use of forms.

All these items go beyond what Dreamweaver or Macromedia Flash can pro-
vide as development tools. After you hit this proverbial Web development
wall, it’s time to turn to ColdFusion, which provides the following tools:

4+ A custom scripting language that enables you to query databases, create
and test variables, and extend the functionality of your site through the
use of specific ColdFusion tags and functions. For more information
about ColdFusion’s scripting language, be sure to check out Book VI.

4 An application server (a program on a computer that serves a specific
function) that reads the custom scripting language and turns it into HTML
that people can see in their browser.

4 An administrative component that enables you to configure all the dif-
ferent elements of your site, such as databases, virtual directories, log
files that capture site tracking information, and e-mail features.

Managing Your Site with Contribute 2

By adding Contribute 2 to the Macromedia Studio family, Macromedia pro-
vides developers with a new tool to help them manage the content on their
sites. Designed for the lay person, Contribute allows you to manage a handful
of Web development tasks quickly and easily, including:

4 Creating and editing Web pages on a site

4 Adding images and links to a page

4 Creating tables and text

4 Publishing pages to a Web site
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Now, you may be thinking that sounds an awful lot like what you do with
Dreamweaver. In fact, Contribute, in a nutshell, is a tool that allows users to
accomplish Dreamweaver-like tasks without jeopardizing any of the underly-
ing code structure of a Web site. That goes for both site development and
site maintenance.

During the development phase, if your site has many pages that share an
identical design but need different content, the HTML developer can create
a Dreamweaver template of the design, and non-technical colleagues can
create multiple pages based on the template using Contribute, each page
with its own content but all with a protected common layout.

When the site is up and running, Contribute allows people with no knowl-
edge of HTML to make changes to content on the site. And built-in safe-
guards prevent two (or more) people from making changes to the same page
at the same time.



Chapter 4: Best Practices
for Web Development

In This Chapter

v+ Understanding the basic steps of development
v~ Setting your site requirements

v+ Ensuring a smooth Web site build

v Testing your site

v+ Involving the right people at the right time

Fe late-night, caffeine-fueled, build-it-as-you-go model of Web development
was fine when the industry was just getting started. However, Web devel-
opment today is a more standardized practice and is subject to repeatable
processes, just like other areas of software development. The result of the
growing maturity in the industry is a set of “best practices” for Web develop-
ment. Think of a best practice as an industry-accepted, commonly-agreed-upon
way of performing a task or set of tasks.

Certainly, you can still build a Web site in more than one way. Best practices
are designed just to give you some guidance in the following areas:

4 Ensuring that the site is easy to build and easier to maintain

4 Helping you avoid doing unnecessary work on a site

4+ Confirming that your Web site is built according to industry standards
4+ Making certain that you have the right people involved in the site devel-

opment at the right time

Each of the sections of this chapter deals with a common aspect of Web
development and provides you with the key points for making that part of
the development run smoothly:.

You should be aware that these tips and suggestions are not absolutes.
Every site is a bit different, but you can use this chapter as a checklist guide
for the kinds of things you can do. Your site may require more or less atten-
tion depending on your requirements.
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Additionally, this chapter is limited to the general best practices for devel-
oping sites. Each of the chapters within Book Il through Book VII covers the
best way to perform operations with each of the individual Macromedia
Studio MX 2004 products.

Following the Best Path of Development

The early days of Web sites saw a wide variety of methods and approaches to
development, but today most common types of Web sites follow an accepted
path from start to finish. Building a Web site takes six basic steps. The details
within each step can be specific to the type of site you're building — product
site, e-commerce site, and so on — but the basic steps remain the same.

Step one: Develop a site concept

Before you can build a site, you must have a mission and purpose for it. This
process involves asking yourself and your colleagues a number of questions
about whom you're trying to reach and why. Book [, Chapter 1 includes
more information on this process.

Step two: Define your requirements

After you’'ve decided what your site is all about, you need to come up with
some basic requirements for the site. Requirements are the minimum stan-
dards that the site must conform to. These requirements break out along
the following categories:

4+ Feature requirements: The basic set of site features and what those fea-
tures need to accomplish.

4 Technical requirements: The minimum technical specifications for the
site. Table 4-1 includes the common technical requirements for Web sites.

4+ Design requirements: The aesthetic and accessibility requirements for
the site. Design requirements may include things such as using the
proper corporate colors, and accessibility requirements generally
include things like adding a text-only version of a site so that it can be
read by text readers (browsers designed for the visually impaired).

Table 4-1 Common Technical Requirements for Web Sites
Requirement Best Practice Option

Screen resolution 800 x 600 pixels

Minimum browser support Internet Explorer 5.0 and Netscape Navigator 6
Use of Web safe colors only No longer required, as almost all monitors can

display 16-bit color
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Requirement Best Practice Option
Minimum connection speed 56 kilobits per second (Kbps)
File extensions Should still conform to the standard “dot and

three characters” (.htm, .cfm, .asp, .jsp)
where possible

Style sheets (Yes or No) Yes
Dynamic HTML (Yes or No) Yes
Web phone and PDA accessibility No
Database of choice Microsoft SQL Server

Step three: Generate content

During this step, you work to generate the various types of text, images, and
so on that will make up the content of your site. Book I, Chapter 2 covers the
details of generating content for Web sites.

Step four: Design the site

This step covers four different aspects of design, and in general, they follow
this sequence:

1. Complete the feature design.

In the second step of Web site development, you set out the requirements
for features on the site. Here, you get down to the nitty-gritty and design
exactly how those features will work. For example, if you want to collect
mailing list information, you need to articulate precisely how the informa-
tion is captured, what kind of response is sent to a user, and where the
captured information goes.

2. Work through the user interface design.

The user interface design is the way the site works, minus the aesthet-
ics. It includes the composition of pages, the structure and look of the
content, and it applies the logic of the feature design above.

3. Consider the graphics design.

After the feature and user interface design are complete, your site is
ready for the aesthetics. You may want to create graphics for logos,
icons, navigation, sidebars, backgrounds, and other site elements.

4. Complete the technical design of the site.

Truth be told, you can do the technical design after you complete the
user interface design, but usually it ends up being the last design step.
You must design the technical components that enable all the features
of the site to be realized.

Book |
Chapter 4
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Following the Best Path of Development

Step five: Build the site

After you’ve completed the design step, you're ready to start building the
site. This includes generating all the code, supporting databases, generating
HTML, and posting content. Building the site can take weeks, and you
should keep a number of basic rules of development in mind when building
your site. Here are the most critical ones:

<+

Work internally. Don’t do all your development work on the site for
everyone to see. Be sure to work on the site either internally (on your
corporate network or your personal machine) or on a different URL
than the final address. This way you can make all the mistakes you like
and the real world isn’t likely to see them.

Go wide, then deep. A good strategy is to always build the structure of
the site first, including the navigation, and then fill it in with the content
within individual sections. Figure 4-1 shows the navigational structure
of a typical site, with primary navigation running across the top and
secondary navigation running down the left. Primary navigation allows
visitors to get to the main sections of the site, while secondary naviga-
tion allows visitors to “drill down” to specific pages in the section.

Centralize your images. Centralizing your images makes finding images
and generating the proper code that much easier. The norm is to include
all images in a folder called images at the root level of your site.
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4+ Whenever possible, use relative paths. Using a relative path simply Book |
means that your links from one file to another within your site — HTML Chapter 4
files, images, PDFs, and so on — are relative to the location of the file

you're currently working on. This makes changing links and moving =
things around in folders that much easier. Dreamweaver defaults to &a
using relative paths. An absolute path (for example, http://www. ‘3 5
mysite.com/section/page.htm) includes the site’s URL, which is [Ty
not only cumbersome but also difficult to use during development. -§ 5
4+ Keep filenames simple. Always keep your filenames in lowercase letters, E g

and don’t include spaces in filenames, folder names, or URLs. This
ensures that no matter what type of Web server your site is hosted

on — Windows, Macintosh, or Unix — the files can be read by any Web
browser.

4 Use folders to segment your content. This provides your site with a
structure that makes finding and managing your content and code
easier.

4 Always comment your code. Commenting code is a common software
development practice. As you're writing your code, you add comments
next to major features and functions so that someone else can under-
stand your work if you're not there to explain it to them. Browsers
ignore comments when displaying the page (but you can see com-
ments, if they’re in the code, by using your browser’s View Source
command). If the code is logically laid out with comments, managing
it is much easier. Figure 4-2 shows what commented code looks like in
Dreamweaver MX 2004. HTML comments always appear in this format:
<!-- comment here -->.JavaScript, ColdFusion, and other types of
Web code each have their own comment conventions.
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4+ Do everything you can to protect your applications. Hacking is serious
business, and the last thing you want to have happen is for your site to
be compromised. Here are just some of the things you can do to ensure
that your site is designed with security in mind:

e Always use digital certificates when sending users private information
over the Internet. A digital certificate is a secure, encrypted digital key
that ensures that only the user’s Web browser and the server that
issued the key can see the data being transmitted back and forth. You
can find out more about digital certificates at www.verisign.com.

e If you're doing e-commerce, don’t use Microsoft Access. Access isn’t
nearly as secure as Microsoft’s SQL Server.

e Never query a database directly for a user’s private information, such
as username, password, or credit card numbers. With SQL, you can use
stored procedures to query a database and mask the code from poten-
tial hackers. While stored procedures are outside the scope of this
book, you can read more about them in Anthony T. Mann’s Microsoft
SQL Server 2000 For Dummies, published by Wiley Publishing, Inc.

e Always try to build your applications in three tiers. A three-tiered
application, the concept of which is shown in Figure 4-3, ensures
that the business logic for your site is separate from your display
code and your database logic. This is more secure, and it makes
changing components of your Web application easier because of the
modular nature of a three-tiered application.

In the three-tiered model, the Web browser can only talk to an inter-
mediary application or object (sometimes called a COM object) and
can only pass a finite set of variables to this intermediary. In turn,
the intermediary negotiates with the data layer to retrieve only the
specified information, which it passes back to the display layer. This
ensures that the end user can’t directly connect to the data layer.

4 Set up a mechanism for sharing files. When you’re working on the same
files with more than one person, set up a convention for sharing the files,
so as to avoid overwriting each other’s work. Dreamweaver comes with
some source control tools that help in this process, as does Contribute,
but you may not want to rely just on their built-in protections. You
should have an agreed-upon procedure for working on the same files.

Step six: Test and deploy your site

Before you can launch your site, you need to test it. Although test plans
vary depending upon the sophistication of the site, here are four good
things you should do when testing your site:
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Tier one Visual display layer (what the user sees)
Component layer
(includes the business
Tier two rules and logic for
communication with the
display layer and the

data layer)
Figure 4-3:
The three- Data layer
tiered (houses
model of Tier three business
develop- critical
ment. information)

4 Check your site on multiple browsers. Testing your site on various cur-
rent and previous versions of browsers ensures that it works for the
largest possible number of users. You should also check on different
platforms as well (PC and Mac at the least).

® You can get old versions of the Netscape browser at http://wp.

netscape.com/download/archive.html?cp=dowarc and old versions
of Internet Explorer at www.oldversion.com/program.php?n=msie.
You can find a wide variety of old versions of many browsers at
http://browsers.evolt.org.

4+ Try your site with different Web connections of varying download
speeds. If you're building your site at work, you may have a very fast
Internet connection. Try viewing and navigating your site using a dial-up
56 Kbps connection to see how well your site loads at that speed. If
pages load within a few seconds, then your site is in good shape.
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3

Getting the Right People at the Right Time

4 Test all of your forms and features. Walk through each form, again
preferably on multiple browsers and operating systems, to ensure that
all your tools and forms work properly.

4+ Enlist your friends and colleagues as site testers. The more people that
look at your site, the better. You're probably too close to the site by the
time you’ve finished it anyway, and fresh eyes can see things you can’t.
Also, other people are likely to give you good feedback on structure and
ease of use.

After you've finished testing your site, which generally takes at least a week,
you should give yourself at least another week to fix any problems you’ve
found during the testing phase.

When you’re ready to roll out your site, a good idea is to do a soft launch
first. A soft launch is when you launch a site but don’t really tell anyone
about it. People who already know something about you or may be looking
for your site will start to check it out and may provide you with some addi-
tional feedback. But you won'’t be faced with a big barrage of people, and
you’ll have a chance to troubleshoot anything you may have overlooked in
making the jump from working on a site internally to having a site out there
live for the real world.

Getting the Right People at the Right Time

If you're building a site on your own, then you are always the right person at
the right time. In most cases, however, you're building a site with a group of
people. Some of these people are site builders, and others are around to
approve content and give general direction. Keeping all the parts moving
smoothly can be tricky. The following sections help you get the right people
on board at the right time.

Building a team

Just how big is this project you’re working on? How much money do you
have to spend? When do you need it done? The answers to these three ques-
tions let you know just how big of a team you may need to build to complete
your site. If you plan to assemble an internal team to build your site, these
are the roles that you absolutely need:

4 Producer: Perhaps this is you. The producer (sometimes also referred
to as a Project Manager) manages all the resources of the project, inter-
nal and external. This means keeping the master budget and schedule,
and providing all the resources with their tasks and deadlines. Largely
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overlooked, the producer is the conduit that keeps the project moving
from start to finish.

Programmer: Programmers come in all shapes and sizes. Some can
only do HTML, while others are adept at building all sorts of software
applications. If you've got a smaller project, you should only need one
programmer (who might also go by the title Engineer or Integrator), but
if your project is larger, you should consider having an integrator for
lower-level HTML coding and a senior programmer for more complex
coding tasks.

Designers: Again, if you're building a smaller site, you can probably get
away with having a designer who does both user interface design and
graphical design. Alternatively, as the producer, you're probably quali-
fied to handle the user interface duties as well as fill the feature design
role. The larger the site, the more you’d want to look at separate spe-
cialists for user interface and graphical design.

Content Specialists: Generating content is always overlooked in build-
ing a team. Whether you have a contract writer or someone internal to
your organization who is good at collecting and synthesizing data, it’s
always a good idea to have someone around dedicated to developing
content for the site.

Quality Assurance: Someone’s gotta test the site, and as we mention
previously, you're probably not the ideal person to do it. The best
testers are meticulous, accountant-types who like to poke and prod at

things and find holes. A lot of times, this function can be contracted out.

Approvers: Unless you're building the site for yourself, then you're
probably accountable to someone. Those would be your approvers, and
yes, they’re an essential part of the team, because ultimately, they are
the ones who give you the yea or nay on whether your site gets up on
the Internet!
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If you were to contract out these resources through a single firm or through
a variety of independent contractors, you'd still be looking for each of these

skill sets. The method of employment doesn’t really matter, though it’s

worth noting that it’s generally cheaper to contract the resources yourself.
Firms, on the other hand, offer complete teams, tried-and-true processes,
and an existing code base (prewritten and tested code) that you don’t gen-

erally get when you build an internal team from scratch.
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Involving the right people at the right time

Knowing when to get people involved can be tricky. Ideally, you’d want
everyone there all the time, but that can get expensive, so you want to get
people on board at the right time for the right tasks. Table 4-2 includes
many of the key milestones in a Web development project and who you
really need to have involved during those parts of the process.

Table 4-2 When to Involve People in the Web Development Process

Key Milestone Who's Involved

Site Conceptualization Everyone

Requirements Gathering Producer, Designers, Programmers, and Approvers

Generating Content Producer, Content Specialists, User Interface Designers,
and occasionally Graphic Designers and Programmers

Feature Design Producer, User Interface Designer, and Programmers

User Interface Design Producer and User Interface Designer

Graphic Design Producer, Graphic Designer, Programmers, and Approvers

Build Phase Everyone

Test and Deploy Producer, Quality Assurance, Programmers, Approvers,

and occasionally Designers
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Chapter 1: Introduction to
Dreamweaver MX 2004

In This Chapter

1+ Exploring the new Dreamweaver MX 2004 interface

v Choosing between Design view and Code view

» Choosing among Standard, Expanded Table, and Layout modes
v+~ Examining your site with the Files panel

v+ Exploring toolbar buttons

v+~ Using panels and inspectors

1 Getting help

If you're looking for a Web design tool that’s both easy enough for begin-
ners and sophisticated enough for Web design gurus, you’'ve come to the
right place. Dreamweaver MX 2004 from Macromedia is a powerful program
that enables you to create almost any type of Web page. This chapter covers
the Dreamweaver basics and introduces you to some of the program’s
essential tools.

Dreamweaver is the industry standard for Web site design and production.
Whether you’re interested in creating a site for fun, such as an online photo
album or a site devoted to one of your hobbies, or for business, such as an
online store, Dreamweaver’s flexible interface provides simultaneous graphi-
cal and HTML editing. In other words, using Dreamweaver, you can not only
lay out pages like an artist, you can also fine-tune the associated code like a
programmer. Additionally, Dreamweaver’s built-in FTP features enable you
to upload your site to the Web in a snap, so that you can share your master-
pieces with the world.

Exploring the New Dreamweaver MX 2004 Interface

With Dreamweaver MX, Macromedia integrated ColdFusion and HomeSite
into one single, powerful interface, though you had the choice of working
with that new interface or with the old Dreamweaver 4 interface (or,

in Macromedia parlance, workspace). With Dreamweaver MX 2004,
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Figure 1-1:
The
Workspace
Setup dialog
box appears
when you
start Dream-
weaver for
the first
time.
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Macromedia dropped the Dreamweaver 4 workspace and allows you to
choose from only two versions of the Dreamweaver workspace: Designer
style and HomeSite/Coder-Style.

Selecting a workspace on start-up

When you start Dreamweaver for the first time, you're asked to choose the
way you want your workspace set up, as shown in Figure 1-1. You have two
options:
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4 Designer: The WYSIWYG (What You See Is What You Get) interface,
which shows the page you are working on much like it would be in a
Web browser. This style is more appropriate for Web design novices
working on basic HTML pages.

4+ HomeSite/Coder-Style: The style that shows the page you are working
on as an editable text document, which is appropriate for experienced
coders and for pages on which you’re editing ColdFusion Markup
Language (CFML) or other dynamic code.

You can switch between the two styles, or even combine them, at the click
of a button. See the “Introducing the Document Window” section, later in
this chapter, for details.

Introducing the new Start page

After you've selected a workspace, when you launch Dreamweaver by
double-clicking its icon on the desktop or by selecting it from the Windows
Start menu, you'll see something new to Dreamweaver: a Start page, as
shown in Figure 1-2. The Start page allows you to perform the following
tasks with a single click of your mouse:
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Figure 1-2:
The Start
Page gives
you one-
click access
to a variety
of options.

Exploring the New Dreamweaver MX 2004 Interface 45

4+ Open pages you've recently edited: Simply click the file name of the
page you want to open.

4+ Create a new page in one of seven formats: Simply click the type of
page you want to create, from basic HTML to ColdFusion (CFML) to CSS
(Cascading Style Sheet).

4 Create a new Dreamweaver Site: Click the Dreamweaver Site icon (in
the Create New column) to open the Site Definition wizard, which guides
you through the process of setting up the directory location, FTP infor-
mation, server technology (if applicable), and more for your Web site.
See Book II, Chapter 3 for details on Dreamweaver Sites.

4 Create a new page based on Dreamweaver’s built-in samples: Click an
option in the Create from Samples column to open the New Document
dialog box and choose from the preset formatting options for that type
of page.

The Start page also gives you fast access to a quick tour and set of tutorials
for Dreamweaver, and to Macromedia’s Dreamweaver Exchange page, where
you can find lots of nifty widgets that extend Dreamweaver’s capabilities.

If you find the Start page incompatible with your working methods, you can
prevent it from appearing in the future by selecting the Don’t Show Again
check box at the lower-left corner of the page.

o Macromedia Dresrmusver MY 7001
File Edit View Iosert Bodify Text Commands Site Window Help

gy & Rescent Item Creale New Create fron Sagkes =y ot ': Localviem 0]

P e L & e TS5 Srle Sty .
W sefimglae bas @ Codfeun i Fromeets LA R N
o Welengine Me - P Domgre (O35}
W perusmalforresmay s @ A levaSarge i Page Ceugre
1 e @ A et 3 Page Desigre (Accembie] o

@ ARNTCE

@ AWMTH Extomd :“"

& W Drimninr Eitanon s

s

FR="1
%, Deaammeaey e
e

i

i!

eesD00OO0OODOD
i

. * Tabn i LBk D OF Cviimsiponsl it thl GGt O OF Debirwebins el b
| + L o (zoamemaver taand b twveg, e and techa, soecal it s and Imdentim
i eabithe o maada o ndndRHe

Book

Chapter 1

002 XIN
laneamuweaiq
0} uonanposu|



46 Introducing the Document Window

Introducing the Document Window

Figure 1-3:
The Design
view
approx-
imates what
your page
looks like
inaWeb
browser.

Your primary workspace in Dreamweaver is the Document window, which
appears automatically when you open a page in Dreamweaver. In the
Document window, you construct your individual Web pages using panels
and dialog boxes to format your work. The three primary views in
Dreamweaver are as follows:

4+ Design view: The graphical view of your document, as shown in
Figure 1-3. You can select this view by choosing View=>Design.

4 Code view: This view shows the underlying code of your document. You
can select this view by choosing Viewr>Code.

4+ Split view: As you may expect, this is a split screen view that includes
both the Code and Design windows. You can select this view by choos-
ing View=>Code and Design.

You can toggle between these views easily at any time by clicking their cor-
responding buttons at the top left of the Document window.

Code View button

Code and Design View button  Design View button
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Choosing among Standard, Expanded Table, and Layout Modes 4 7

P When you have several documents open in a site, you can select which doc-
ument you want to work on by clicking the document’s name at the top of
the Dreamweaver Document window. You can also click the Site tab in the
Files panel to work on an entire site.

The Insert bar sits directly underneath Dreamweaver’s main menu. It gives
you quick access to eight sets of buttons you can use to insert everything
from tables to Flash movies to form elements in your page. To select one of
the eight categories, click the Insert bar’s name (Common, Layout, and so
on) and choose a new category from the drop-down list.

Book Il

Choosing among Standard, Expanded Chapter 1
Table, and Layout Modes

You can view content in your Document window using the Standard mode,
the Expanded Table mode, or the Layout mode. The Standard mode is the
default (Figure 1-3 shows a page in Standard mode, with the Insert bar set to
Common). The Expanded Table mode makes it easier for you to select
tables and cells (though if you want to resize the table or row or column,
you need to do so in Standard mode). The Expanded Table mode is most
useful for editing existing tables. The Layout mode provides a simpler inter-
face for drawing and editing tables and table cells.

002 XIN
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Two special tools are available only when working in Layout mode: the Draw
Layout Cell button and the Draw Layout Table button. A table created with
the Draw Layout Table tool is shown in Figure 1-4. Both of these tools can
help you generate tables or table cells quickly and easily in Dreamweaver,
and are described in more detail in Book II, Chapter 2.

To change to the Layout mode, select the Layout Insert bar at the top left of
the Document window and click the Layout Mode button, or choose Viewr>
Table Moder>Layout Mode, or use the keyboard shortcut Ctrl+F6. When
you’re in Layout mode, press Ctrl+F6 or click the Layout Mode button to
return to Standard mode.

To change to Expanded Table mode, select the Layout Insert bar at the top
left of the Document window and click the Expanded Table Mode button at
the top of the Document window, or choose Viewr>Table Moder>Expanded
Table Mode, or use the keyboard shortcut F6. When you're in Expanded
Table mode, press F6 or click the Expanded Table Mode button to return to
Standard mode. Note: The Expanded Table mode is not available in the Code
View.
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Examining Your Site with the Files Panel
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Examining Your Site with the Files Panel

Dreamweaver offers Web developers the opportunity to work on individual
files that make up a Web site, as well as to manage their entire Web site, all
through the Dreamweaver interface. This concept is called, not surprisingly,
a Site; to avoid confusion, we call them Dreamweaver Sites. Dreamweaver
Sites can include the following elements:

4+ HTML, CFM, ASP, and other files that make up the code of the site
4 Graphics, such as GIF and JPEG files
4 Documents, such as PDF files and DOC files

4+ Directories (folders that might contain any of the above)

Dreamweaver Sites are initially viewable within the Files panel (which is
open by default; if the Files panel is not open, you can open it by pressing
F8). To expand the Files panel so it fills your screen, or to collapse the panel
back to panel size, click the Expand/Collapse button (the icon of the two-
row, two-column box with an arrow in the middle, at the right of the panel).

The Web site management tools for Dreamweaver Sites are designed to give
you total control over the way in which your Web site is built and main-
tained from your local computer. The key features of the Dreamweaver Site
tools include:
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Asset management tools that help you manage all the files that make up
your site. For example, these tools keep track of all your files and the
links between files. Anytime you move a file, the tools will change the
related links in other files.

Basic source control to ensure that files don’t get overwritten. These
tools lock files so that when you’re working on a particular file, others
on your team can’t edit that same file.

Publishing tools that allow you to use FTP to upload the content from
your site locally to the remote server where the site is housed.

Utilities that create site maps, check links, check the HTML code, and
run reports on who’s been working on what.

Dreamweaver Sites are covered in more detail in Book II, Chapter 3.

Exploring Toolbar Buttons

Dreamweaver provides you with a number of useful view buttons (shown in
Figure 1-5 and Figure 1-6) that you can use to see different views of your site
or to perform various functions. You can easily switch among views to
examine your site in different ways. Each Dreamweaver view offers special-
ized menus and tools to help you perform your work in that view. Certain
views are available for an individual document or page, whereas other views

are

available for the entire site. At any time while you work, you can choose

to preview your site in target Web browsers, which enables you to see your

site

from the user’s perspective.

Refresh button

Get File(s) button

Put File(s) button

Figure 1-5:
The Files tab
of the Files
panel
includes
useful
buttons.
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Figure 1-6:
The buttons
at the top
of the
Document
window.

Figure 1-5 shows the following site-related buttons from the Files panel:
4 Connect to Remote Host button: Connects your local computer and your
Web host, allowing you to transfer files between the two computers.

4+ Refresh button: Refreshes the panel’s view of files in the site if you've
made a change to file names or file structures outside of Dreamweaver
while the program was open.

4 Get File(s) button: Downloads (retrieves) documents and files from the

host.
4 Put File(s) button: Uploads (sends) documents and files to the host.
4 Check Out File(s) button: Locks files for editing by a single individual.

4 Check In button: Replaces files on the server and makes them available
for editing by unlocking them.

4+ Expand/Collapse button: Makes the Site tab full-screen with remote and
local files side-by-side.

Preview/Debug in Browser

File Management | Refresh

| 2] Cote | =35t [ L3 0w | i s a7 M B C O I

- =

Check Browser Support View Options

Show Design View
Show Code and Design View

Show Code View

Figure 1-6 shows the following document-related buttons from the top of the
Document window:

4+ Show Code View button: Enables you to view the HTML page code full-
screen.

4 Show Split View button: Allows you to view the HTML page code and
the Document window at the same time.

4 Show Design View button: Enables you to view the Document window
full-screen.

4 Check Browser Support button: Allows you to run a check on your
code for browser compatibility.
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4+ File Management button: Click and then select Get to retrieve files from
the Web site host or select Put to send files to the host.

4 Preview/Debug in Browser button: Click and select to preview or
debug in your browser(s).

4 Refresh button: Reloads your page so changes to the code are reflected
in the Design view.

4+ View Options button: Click to select options (such as Word Wrap in Code
View and the Ruler in Design view) to assist you in viewing your page.

Some of these items may be unavailable, depending on what view you're in
and what you have selected in a document or panel.

Using Panels and Inspectors

2004

You can use Dreamweaver panels and inspectors to enter details about all
aspects of your Web site. These interfaces offer areas where you can add
and format page features, set up navigation and behaviors, and manage the
workflow of building your site.

Understanding the role of panels

A panel typically provides information about all instances of a particular
page feature. For example, the Layers panel lists information about all the
layers on the current page.

The Tag Inspector panel gives you easy access to various properties and
behaviors specific to what object you have selected on your page. The Tag
Inspector panel updates continually, depending on what you have selected
on your page (if you have nothing selected on the page, the panel displays
properties and behaviors of the whole page itself, as shown in Figure 1-7).
Note that the Tag Inspector panel’s name reflects the tag being inspected.

To switch among tabs in a panel, just click the tab names.

Figure 1-7:

The Tag
Inspector
panel with
general
page
properties
displayed.
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Getting Help

You can dock, expand, and collapse panels. See the section on customizing
your work environment in Book Ill, Chapter 1 for information on working
with panels.

Working with the Properties panel

The Properties panel, like the Tag Inspector panel, changes based on the
individual document object you have selected on your page and contains
details on attributes of the object. For example, selecting text on a page
opens the Text Property inspector in the Properties panel, where you can
format the size, font, color, link, and other attributes of the text. (Figure 1-4
shows the Properties panel with a Layout Table selected.) To make certain
that the Properties panel is shown below the Document window, choose
Window=>Properties.

The Properties panel has a small down arrow in the lower-right corner,
called an Expander button. Click the button to enlarge the Properties panel
to view additional formatting options. In an expanded Properties panel, click
the small up arrow in the lower-right corner to collapse the panel.

Getting Help

Dreamweaver offers a variety of tools to help you find the answer to virtu-
ally any question you have about the program. The Help tools provide basic
information for beginners, as well as advanced references detailing HTML
and JavaScript code.

You can get help by clicking the Help button — the small question mark —
in the top-right corner of some panels. Similarly, you can open the Options
menu in the top-right corner of any panel and select Help from the list.

You can also access help by using the Help menu located on the main menu.
Just choose Help and then select one of the following options:

4+ Getting Started and Tutorials: Gives you quick access to basic informa-
tion to get you up and running quickly, as well as to step-by-step tutori-
als where you can learn by doing.

4+ Using Dreamweaver: Provides definitions and itemized steps in per-
forming routine Dreamweaver tasks. It contains Help Contents, Index,
and Search categories.

4+ Using ColdFusion: Provides information about coding dynamic sites
using ColdFusion technology.
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4+ Reference: Opens the Reference tab of the Code panel offering a
dictionary-style reference on CSS, HTML, Accessibility requirements,
Sitespring tags, and JavaScript. You can also access the Reference tab
of the Code panel by clicking the Reference button in the Document
window.

4+ Extensions: Provides assistance in performing more advanced
Dreamweaver tasks, especially tasks involving the integration of adjunct
programs, such as Macromedia Flash, with Dreamweaver. This help
option contains nitty-gritty information about application programming
interfaces (APIs) — specific software interfaces that allow you to
integrate Dreamweaver with databases, the C and Java programming

languages, and much more. Book Il
. . Chapter 1
4+ Dreamweaver Support Center, and Macromedia Online Forums:

Connects you to the Web, where you can find constantly updated infor-
mation on working with Dreamweaver, answers to Frequently Asked
Questions, and program extensions. You can also join a developer’s
forum, where you can chat with other Dreamweaver users to get (and
give) help.
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Chapter 2: Creating Basic
Web Pages

In This Chapter

v Setting ruler and grid options in the Document window

+ Creating and opening pages
v~ Establishing page properties
+* Working with text

1+ Working with images

v+ Adding links

v Working with tables

v Previewing your work

rle most significant (and, fortunately, the easiest) process in building a Web
site is creating the individual pages that convey the site’s content. Even if
you plan on creating an ultra-hip site chock full of animation and interactive
forms, you spend the vast majority of your site-building effort constructing
basic Web pages comprised of words and images. This chapter shows you how
to set up, color, and name individual Web pages. You also discover how to add
basic elements, such as text, graphics, and tables, to your pages.

Setting Ruler and Grid Options
in the Document Window

Dreamweaver offers you complete control over how you work in the
Document window by providing two guide tools — rulers and a grid — to
help you lay out your work accurately. You can customize a variety of guide
tool attributes, such as ruler increments and grid snapping, to suit your per-
sonal preferences and speed Web page development.

Here’s a brief look at all your options with rulers and grids:

4 Turning rulers on and off: Using rulers — both horizontal and vertical —
in the Document window can help you measure and position page ele-
ments. Toggle the rulers on and off by choosing View=>Rulers=>Show or
by pressing Ctrl+Alt+R.
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4 Moving and resetting the origin: By default, the origin, or (0,0)

coordinate, of a Dreamweaver ruler is set to the upper-left corner of
the Document window. You can reposition it to any coordinate in the
Document window by clicking the origin cross hairs and dragging them
to new coordinates, which can be useful if you want to use the rulers to
position elements of a table whose upper-left corner doesn’t sit at (0,0)
in the Document window. Reset the origin to its default position by
choosing View=>Rulerst>Reset Origin.

4+ Changing ruler measurement units: You can change the ruler’s measur-

ing increment by choosing Viewr>Rulers and then choosing Pixels,
Inches, or Centimeters.

4 Viewing the grid: Dreamweaver provides a Document Window grid

that can assist you in visually positioning and aligning page elements.
You can toggle the grid on and off by choosing View=>Grid=>Show Grid
or by using the keyboard shortcut Ctrl+Alt+G. The grid is shown in
Figure 2-1.

4 Activating and deactivating grid snapping: The Document window grid

offers a snapping feature that causes a layer or Layout table/cell to
automatically align precisely with the snap-to points you define, which
can be useful when you draw, resize, or move a layer (see Book I,
Chapter 5 for the skinny on layers). You can toggle grid snapping on and
off by choosing View=>Grid=>Snap to Grid.
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Adjusting page size

When you design Web pages, you must con-
sider how your target audiences will view them.
People looking at your page may view it at any
number of screen resolutions from 640 x 430 to
1024 x 768 or beyond. Your audience may even
view your pages using WebTV, with a resolution
of 544 x 376. Because pages appear differently
at different resolutions, Dreamweaver offers
you the ability to build your pages for a variety of
monitor resolutions. The higher the resolution,
the larger the workspace in your Document
window.

If you want to size your pages, you must be in the
Design workspace, and your Document window
can't be maximized in the integrated workspace.
To size your pages, click the Window Size
Indicator (the height by width numbers and
downward-pointing arrow at the bottom right of
the Document window) and select a standard
size — for example, 640 x 480 — from the drop-
down list. (The Selecting Edit Sizes option on the
drop-down list allows you to specify any height
and width dimensions you want.)

\\3

You can adjust how the grid appears in the Document window in the Grid
Settings dialog box. To do so, open the Grid Settings dialog box by choosing

View=>Grid=>Grid Settings and change any (or all) of the attributes that
appear. When you finish, click the Apply button to view the effect of your
changes. Click OK to accept the changes and close the dialog box.

Creating and Opening Pages

You have several ways to create a new page in Dreamweaver:

4 On the Start page, scan through the Create New column and click the
type of page you want to create from scratch.

4 On the Start page, click one of the options in the Create from Samples
column to open the New Document dialog box and make a new page
with many common settings precoded.

4 Choose FilewNew or use the keyboard shortcut Ctrl+N, which opens the

New Document dialog box, from which you can create pages from

scratch or from templates.

To open an existing page, do any of the following:

4 On the Start page, click the name of the page in the Open Recent column.

4+ Double-click the page’s filename in the Files tab of the Files panel.

4+ Choose File=>Open or use the keyboard shortcut Ctrl+O, which opens

the Open dialog box, which you can use to browse to the page you want

to open.
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Establishing Page Properties

Figure 2-2:
The Page

Properties
dialog box.

The Page Properties dialog box provides you with control over how several
key page properties appear, including the title of the page, page background
color, link colors, and page margins. Selections apply only to the current
page, not to the entire site. Open a Page Properties dialog box similar to the
one shown in Figure 2-2 by choosing Modify->Page Properties or by pressing
Ctrl+J. Then make changes to any of the following in each of the five cate-
gories (Appearance, Links, Headings, Title/Encoding, and Tracing Image):
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4+ Page Font, Font Size, Text Color, Background Color, Background
Image: Choose a font or set of fonts from the Page Font drop-down list;
add a style (bold or italic) if desired. Click the Color box next to each
property and pick a color from the Web safe color palette that appears,
or enter a hexadecimal color code directly in any Color Code text field.
You can also customize your own colors by selecting the color wheel
and entering either RGB values or Hue, Saturation, and Luminosity
values, as shown in Figure 2-3. For more information about using colors
for the Web, see Book IIl, Chapter 2. Book III, Chapter 3 includes infor-
mation on how to use the color picker to select colors in both
Dreamweaver and Fireworks. For Background image, click the Browse
button to locate the image file that you want to appear as the Document
window background. If the image is smaller than the available back-
ground area, the image is tiled (repeated in a checkerboard fashion, like
floor tiles) to fill the background.

Even if you choose to use a background image, select a complementary
background color — the color shows while the background image is
downloading.



Figure 2-3:
The color
picker.

Establishing Page Properties 59

=
dl

Color

Banic colon:
ErEFEraNm
HrmFEFEER
ERNEENEN
EiEEEEEn
EEEEEEEN
EeEmEErE

Cunaces ooliens

4 Left Margin, Right Margin, Top Margin, and Bottom Margin: Enter
a number (in pixels) in these text fields to set up margins that affect
how your page appears in modern browsers. Enter a whole number
for the number of pixels of buffer space you want between the left,
right, top, and bottom edges of your document and the content of the
document.

<+

Link Font and Size, Color for Links, Rollover Links, Visited Links, and
Active Links: Choose a font or set of fonts from the drop-down list; add
a style (bold or italic) if desired. Click the Color box next to each prop-
erty and pick a color from the Web safe color palette that appears, or
enter a hexadecimal color code directly in any Color Code text field.
You can also customize your own colors (see the preceding point on
Text Color).

Underline Style: Select an option from the drop-down list.

Heading Font, Sizes, and Colors: Choose a font or set of fonts from the
drop-down list; add a style (bold or italic) if desired. For as many of the
six standard HTML heading levels as necessary, select a font size. If you
choose a numeric value, the unit-of-measurement drop-down list to the
right becomes active so you can select an option. Click the Color box
next to each heading and pick a color from the Web safe color palette
that appears, or enter a hexadecimal color code directly in any Color
Code text field. You can also customize your own colors (see the pre-
ceding point on Text Color).

Title/Encoding: Enter a page title in the text field. This title appears
in the title bar area of the window both during construction in
Dreamweaver and when the page is viewed in a Web browser. Select
an Encoding format if your site requires the use of non-Western fonts
(Japanese or Cyrillic, for example). If your site is in English, you can
leave the setting at the default, Western European.

Book
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4+ Tracing Image: Click the Browse button to locate the image file you
want to use as a guide for laying out your Web page in the Document
window. This feature is handy for developers who prefer to mock up
a portion of their Web page design in a graphics program and then
re-create that design in their Web pages. Tracing images appear in
Dreamweaver only as a pattern to help guide you in creating an
actual Web page; the tracing image never appears on the finished
Web page.

4+ Image Transparency: Drag the slider to adjust the visibility level of the
tracing image. At 0 percent, the tracing image is invisible; at 100 per-
cent, the image is completely opaque.

Click the Apply button to view the effect of any property you change. Click
OK to accept your changes and close the Page Properties dialog box.

Working with Text

As we mention in Book II, Chapter 1, Dreamweaver has three different design
views: Design, Code, and Split (Code and Design). The following sections
apply when you’re working in the Design view or Split view of Dreamweaver.
In these views, you can enter and manipulate text on a Web page in
Dreamweaver by using similar procedures to those you use when working
with a word-processing document.

Adding, editing, and deleting text

To enter text on a page, click in the Document window and begin typing.
Your mouse pointer appears as a blinking cursor that moves along with the
text you enter. When you reach the end of a line, the text automatically
wraps to the next line. Dreamweaver automatically adds the associated
code for your new text in the HTML for the page.

To delete text from a page, in the Document window, select the chunk that
you want to delete and press Backspace or Delete on your keyboard.

You can also modify how text appears on a page by editing its font, size,
color, alignment, and other attributes. To modify text in the Document
window, click and drag to select the text you want to modify. The Properties
panel loads the Text Property inspector, as shown in Figure 2-4 (the Tag
Inspector panel also reflects the selection). If the Text Property inspector is
not open, choose Window=>Properties to open it. In the Text Property
inspector, modify any of the following properties:



Figure 2-4:
The
Properties
panel with
the Text
Inspector
loaded.
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Format: From the Format drop-down list, select a default text style.
Heading 1 is the largest style and Heading 6 is the smallest, but none

of the headings correlates with a specific pixel size unless you set it to
do so. Select Paragraph for the basic body text of your pages. Select
Preformatted if you want spaces, tabs, and new lines in a paragraph to
show up in a browser (ordinarily, when you add multiple spaces in a row
or tabs to your HTML — this is particularly obvious in the Dreamweaver
document’s Code view — they appear as single spaces in a browser).

Font: Select a font face from the Font drop-down list. Browsers show
your text formatted as the first font in your selection that resides on the
user’s computer. Choosing Edit Font List allows you to add additional
fonts you may have installed on your computer to the Font drop-down
list. Most computers will have standard fonts like Arial and Helvetica
and won’t have less common fonts like, say, Univers or Futura.

Style: Dreamweaver has been updated to work better with CSS styles.
Styles defined within the document or in a linked stylesheet will be
available from the Style drop-down list. You can also use the drop-down
list to attach a stylesheet and create and edit styles.

Size: Select a font size from the Size drop-down list. The options include
none (choosing this option displays text in the default size), specific
numbers, generic sizes XX-small to XX-large, and relative sizes Smaller
and Larger. If you select a number, the unit-of-measurement drop-down
list becomes available so that you can specify what the font size
number refers to (pixels, ems, and so on).

Color: Click the color box and select a text color from the Web safe
color palette that appears. Alternatively, you may enter a hexa-
decima color code directly in any color code text field. (To set the
default text color for a page, check out the “Establishing Page
Properties” section, earlier in this chapter.)

Bold or Italic: Click the Bold button to make your selected text appear
in bold. Click the Italic button to italicize your selected text. You can
click either button or both.

Alignment: Click an alignment button to align your text. Choices are
Left, Center, Right, and Justify.

Book Il
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Figure 2-5:
The line
helps you
see which
file you're
choosing.

4+ Link: Type a URL in this field to transform selected text into a hypertext
link. You can also use the Point to File tool to link to a file. To link to a
file using this tool, just follow these steps:

1. Open the Files panel by choosing Windowr>Files or by pressing F8.

2. Open the Explorer to the folder location that includes the file you
want to link to by selecting the collapsing menu squares.

Alternatively, skip to Step 3 and hover your cursor over the folder
that contains the file; the folder will expand so you can select the file
within.

3. Click and hold the Point to File button in the Text Property inspec-
tor and drag the pointer to the file you want to link to. Release the
mouse button when the pointer is over the file.

The Point to File button looks like a compass without the needle or a
clock face without hands or numbers. It’s located to the right of the
Links field.

When you’re dragging the button, a line appears from the origin
point to your cursor, as shown in Figure 2-5.

After you let go of the mouse button, the link to the file appears in
the Link text field. If you select the Link drop-down list, it shows you
your recent links as well.
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4+ Target: If you are linking the selected text, you can specify how the
linked page will open when the user clicks the link by selecting one of
the following options from the drop-down list:

e Dblank: Opens the link in a new window.

e parent: Opens the link in the parent of the currently opened
window. If the window with the link in it is not in a frame, the linked
page opens in the same window as the link. If the link is in a frame,
the linked window will open in the parent frame or in the parent
window of the frame with the link. See Book II, Chapter 4 for more
information about frames.

e _self:Opens the link in the currently opened window; this is the Book Il
default target. Chapter 2

e _top: Opens the link in the top-level window, replacing frames, if any:.

4 List: Click the Unordered List button next to the Target field to trans-
form text into an unordered (bulleted) list; click the Ordered List button
to transform text into an ordered (numbered) list.

4+ Placement: Click the Text Outdent button you find next to the Ordered
List button to outdent (decrease the indent) the selected text; click the
Text Indent button to indent the selected text. If you outdent an item in
a bulleted or numbered list, the item will no longer be a list item.

safied qapy
oiseg buneai)

Inserting a line break

When you want to start a new line in a word-processing program, you press
the Enter key. If you press Enter in Dreamweaver, you create a paragraph
break, which starts a new paragraph, creating a blank space between para-
graphs. If you want to start a new line directly under another line of text
and without the big space between lines, you need to insert a line break. In
Dreamweaver, you create a line break by choosing Insert> HTML=>Special
Characters=Line Break or by pressing Shift+Enter. Alternatively, you may
click the Insert Line Break button from the HTML category of the Insert bar.
Dreamweaver places the cursor at the start of the next line and inserts the
line break HTML code.

Working with Images

Aside from entering text, manipulating images on a Web page is probably the
most common Dreamweaver function you perform. You can add or delete an
image and modify its properties to create an aesthetically pleasing layout
that effectively conveys the information you want to deliver to the user.



64 Working with Images

A\\S

Figure 2-6:
Selectan
image.

To see how to place an image on the background of your page, check out the
“Establishing Page Properties” section, earlier in this chapter.

Inserting an image

To insert an image on a page, follow these steps:

1. Choose Insert->Image.

Alternatively, you can click the Insert Image button in the Common cate-
gory of the Insert bar.

. In the Select Image Source dialog box that appears (shown in Figure

2-6), click the image you want to insert.

If the image is outside the folder that holds your HTML document, use
the Look In drop-down list to browse to the file you want.

. Click OK to insert the image.

Note: Every image you want to include on a Web page should reside
within the root folder of the current site (typically, you should have
your HTML files in the site root folder — the master folder that holds
everything on your site — and all your images in an images folder that’s
also in the site’s root folder). If you attempt to insert an image from
another location, Dreamweaver asks whether you want to copy the
image to the current site root folder. Click Yes. In the Copy File As dialog
box, you can enter a new name for the image in the File Name text field,
or you can accept the current name and click the Save button.
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Always be sure you have saved your HTML file at least once before you
insert an image into it. If your file isn’t saved, Dreamweaver won’t know
where to place the image in relation to the file. After you've saved the file in
a particular folder, the location is known and Dreamweaver can include the
correct relative location of the image.

Put a check in the Preview Images check box at the bottom of the Select
Image Source dialog box to view a thumbnail of the image before you select
it for insertion. The preview area also tells you the size of the image and the
expected download time.

Deleting or moving an image

To delete an image from a page, click the image in the Document window
and press the Delete key on your keyboard.

If you want to move the image from one place on the page to another, you
can click the image in the Document window, press Ctrl+X to cut the image,
click the spot on the page where you want to move the image, and press
Ctrl+V to paste the image. You can also move an image by clicking and drag-
ging it to a new location.

Modifying an image
You can modify how an image appears on a page by editing its size and
alignment, adding a border, and changing other attributes.

To modify an image, click the image in the Document window to select it. If
the Image Property inspector does not appear, choose Window=>Properties
to open it.

To see all the options the Image Property inspector offers, click the down
arrow in the bottom right-hand corner of the Image Property inspector.
(Clicking the up arrow displays fewer options.)

You can do any of the following things to modify the way an image appears:

4+ Resize the image: Click and drag a sizing handle to change the dimen-
sions of the image. To resize the image maintaining the same propor-
tions, hold down the Shift key as you drag a sizing handle. You can also
resize the image by typing new pixel dimensions in the W and H text
fields in the Image Property inspector. Click the Resample button to
conform the resized image to the new dimensions (otherwise resizing in
Dreamweaver changes the dimensions in which the browser draws the
image, but leaves the image file itself untouched — and image quality
will suffer when the browser resizes the image). If you want the resized
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image to look its best, you may be better off resizing the image in
Fireworks, because Fireworks gives you more control over the resizing
process. To edit the image in Fireworks, select the image and click the
Fireworks button in the Edit section of the Properties panel.

Align the image: In the Image Property inspector, click an alignment
button to position the image on the page (or within a cell if the image is
located in a table cell). Alignment button choices are Left, Center, and
Right. To align an image with special word wrapping, select one of the
alignment options, which are detailed in Table 2-1, from the Align drop-
down list that appears when you position your image near a bunch of
text.

Add a border to the image: In the Image Property inspector, enter a
number in the Border text field to add a border of that thickness to the
image. Border thickness is measured in pixels.

Pad an image with spaces: In the Image Property inspector, enter a
number in pixels in the V Space (V for vertical) text field for the space
you want to appear between the top and bottom of the image and other
page elements; then enter a number in pixels in the H Space (H for hori-
zontal) text field for the space you want to appear between the image
and page elements on either side of the image.

Make the image a link: In the Image Property inspector, enter a URL in
the Link text field.

Specify alternative text for the image: In the Image Property inspector,
enter alternative text in the Alt text field. (Specifying alternative text
ensures that when viewers’ browsers don’t — or can’t — display the
image, some meaningful text appears instead, and also serves as an
alternative for sight-impaired visitors to your page.)

Name the image: In the Image Property inspector, enter a name in the
text field next to the thumbnail image. (Naming an image is important if
you want to refer to that image using a behavior or scripting language,
such as JavaScript, but is otherwise unnecessary.)

Edit the image: In the Image Property inspector, click the Edit button.

Dreamweaver allows you to optimize, crop, resample an image, adjust
its brightness and contrast, and sharpen it by using the buttons in the
Edit section of the Image Property inspector. If you want the most con-
trol over the process of editing the image, click the Fireworks button to
open the image in Fireworks. You'll have the choice of working directly
with the image or opening the source file the image came from. In most
cases, you maintain the highest image quality by manipulating the pre-
optimized source version of the image and then exporting it as a new
GIF or JPEG. If you don’t see the Fireworks icon in the Edit section of the
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Properties panel when you select an image, you may have to set it (or
another program) as your primary image editor. See Book I, Chapter 8
for instructions on making Fireworks your primary image editor.

4+ Change the image file: In the Image Property inspector, enter a different
filename in the Src text field (or click the File Folder button to browse
for image files).

4 Add an image map: In Dreamweaver, you can add multiple hyperlinked
hotspots to images to create an image map. In the bottom left of the
Image Property inspector, you see an arrow pointer and some image
tools (a rectangle, circle, and free form hotspot creator). With these
tools, you can create hotspots on your images, and you can specify the
following for each hotspot:

e The link location for the hotspot
e The target window for the link

e The alternate text for the hotspot

Table 2-1 Aligning an Image in Relation to Text

Alignment Option Effect on Image and Text Wrapping

Default Same as Bottom alignment

Baseline Same as Bottom alignment

Top Aligns the image top with the highest other inline element
Middle Aligns the image middle with the text baseline

Bottom Aligns the image bottom with the text baseline

Text Top Aligns the image top with the text top

Absolute Middle Aligns the image middle with the text middle

Absolute Bottom Aligns the image bottom with the bottom of the text descenders
Left Aligns the image flush left

Right Aligns the image flush right

Working with Links

Linking your page to other Web pages enables you to direct visitors to
related content on the Web. To insert a link, you must specify an image or
some text to serve as the link; you must also specify the link location to
which you want to send your visitors. The link can go to a page within your
site or to a page elsewhere on the Web.
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Inserting a link

To insert a link on a page, follow these steps:

1. Select the text or image you want to make into a link.

Doing so opens the Property inspector for your text or image. If the
Property inspector does not appear, choose Window=>Properties to
open it.

2. In the Link area of the Property inspector, enter the destination URL
of the link (text or image) that you created in Step 1.

The URL you specify can be any valid URL, for example, a Web page
within your own site (somePage.html), a page on the Web (http://
www.someSite.com/somePage.html), or even an e-mail address
(mailto:somebody@somewhere.com).

Alternatively, you may click the File Folder button you see in the
Property inspector to display the Select File dialog box. After you
browse your computer using the Select File dialog box and select a
file, click OK to make that file the target of a link.

To create an e-mail link quickly, click anywhere in your document and choose

Insert>Email Link. Specifying the same value for the Text and E-mail fields

that appear allows folks who haven’t configured their Web browsers to handle

e-mail automatically to see the e-mail address on the page. Then, they can
copy and paste the e-mail address information into their e-mail program of
choice.

Deleting a link

To delete a link from text or an image, without deleting the text or image
itself, follow these steps:
1. Select the text or image you want to remove the link from.

The Property inspector for your text or image opens. If the Property
inspector doesn’t appear, choose Windowr>Properties to open it.

2. In the Property inspector, delete the URL from the Link text field.

Note that if you delete a linked image or linked text from a page, the link
gets deleted along with the text or image.

Using named anchors

When you want to create a navigational link that connects users not only to

a page, but also to a specific location on the page, you need to create a
named anchor. Named anchors are frequently used for jumping to exact
positions within a large block of text so that users don’t have to scroll
through paragraph after paragraph to find the information they need.
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Setting up named anchors is especially useful when creating links from a
directory or a table of contents to the content it presents.

Inserting a named anchor
Place an anchor anywhere on your Web page as follows:

1. In the Document window, click at the position you want to insert the
named anchor.

2. Click the Named Anchor button on the Common category of the
Insert bar or choose Insert~-> Named Anchor.

The Named Anchor dialog box appears, as shown in Figure 2-7. If the
Insert bar is set to a different category, click and hold the category
name and select Common from the drop-down list.

3. Type a name in the Anchor Name text field.
4. Click OK.

Figure 2-7: u

The Named Anchar name: (=)
Anchor _Comet |
dialog box. L]

It’s a good idea to insert the named anchor tag slightly above the actual
position where you want the link to target. Doing so gives your targeted con-
tent a little padding on top. Otherwise, the top of your image or your first
line of text appears flush with the top of the browser window.

A\

Linking to a named anchor

To link to a named anchor, follow the procedure outlined in the “Inserting a
link” section, earlier in this chapter, with the following modifications:

4+ Linking to a named anchor on the current page: In the Link text field
of the Property inspector, type a pound sign (#) followed by the anchor
name.

4+ Linking to a named anchor on a different page: In the Link text field of
the Property inspector, type the page’s URL followed by a pound sign
and then the anchor name.
@‘“\NG!
S Be sure not to include any spaces in the names of anchors. These may not
be read by the various Web browsers.
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Working with Tables

You can position objects (such as text blocks, images, or animations) rela-
tive to each other on a page in two basic ways:

4+ Using tables: A time-honored Web tradition for page layout, tables are
grids of cells defined by columns and rows. Cells can have set sizes and
alignments and may contain anything you can put on a Web page,
including other tables.

4+ Using layers: Layers can be positioned precisely, and in Dreamweaver,
layers are in some ways easier to use than tables. For instructions on
how to lay out your Web page with layers, see Book I, Chapter 5.

Adding a table to a Web page can help you lay out page elements more easily
in the Document window. Tables consist of as many holding areas, or cells,

as you want, and you can place virtually any Web element, such as text or an
image, into a cell. Cells are organized horizontally into rows and vertically
into columns. Dreamweaver provides you with complete control over the size,
position, color, and other attributes of your table. And you can edit these
attributes at any time via the Table Property inspector.

Inserting a table

To insert a table into a Web page, just follow these steps:

1. Click in the document where you want the table to go.

2. Choose Insert->Table or use the keyboard shortcut Ctrl+Alt+T, or
click the Table button in the Common category of the Insert bar.

The Insert Table dialog box appears, as shown in Figure 2-8. If the Insert
bar is set to a different category, click and hold the category name and
select Common from the drop-down list.

3. Enter the number of rows and columns you want the table to have in
the corresponding Rows and Columns fields.

You can always add or remove rows or columns later.
4. Use the Table Width field to set a width for the table.

The width can be either a set number of pixels or a percentage of the
area that bounds the table (the page itself, or, if the table is nested in a
cell, that cell).

5. In the Border Thickness field, enter a number for how many pixels
thick you want the border of your table to be.

If you don’t want the table border to show (which you probably don't if
you’re using the table for page layout purposes), enter 0 (zero).
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6. In the Cell Padding field, enter a whole number for the amount of

10.

pixels you want between the border of the cell and the text or object
inside the cell.

The cell padding applies to the top, bottom, left, and right of the inside
of each and every cell.

In the Cell Spacing field, enter a number for the amount of pixels you
want between the cells.

The cell spacing applies to the whole table; you can’t have different cell
spacing for individual rows or columns.

If your table has a header row or header column (or both), click the
button (None, Left, Top, or Both) that represents the header structure
of your table.

The text in a header row has special formatting, which you can define in
a stylesheet. If you're creating a table for layout purposes, you won’t
want a header row or column, so make sure None is selected.

In the Accessibility section of the Insert Table dialog box, enter a cap-
tion and summary for the table if you need to describe the table for a
sight-impaired audience.

If you're making the table for page layout purposes, leave these blank.
Click OK.

The Insert Table dialog box disappears, and the empty table appears in
your document.
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An empty table is shown in Figure 2-9. To enter data into the table, just click
on an individual cell and enter the content you want in that cell. You can
modify any of the table’s attributes by selecting the table and changing the
attributes in the Properties inspector or the Tag Inspector panel.
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Deleting a table

To delete a table from a page, click the border of the table to select it and
then press the Backspace or Delete key. Dreamweaver removes the table
from your page and deletes the associated code in the HTML for the page.
Naturally, everything that was in the table is also deleted from the page.

Using layout tables

The use of tables is central to the traditional way of building great Web pages
(for information on laying out pages with layers, see Book II, Chapter 5). What
happens, though, when you want to put an image right smack in the middle of
a page, or when you want to have one column of information along the right
side of the page, and a square text block at the bottom of the page? You can
nest tables, which involves building new tables inside of cells of other tables.
This is the tried and true method for a lot of developers, but creating nested
tables is complicated and not at all fun, especially with complex pages.

Thankfully, Dreamweaver offers an easy way to work with complex tables
called layout tables. With a layout table, you tell Dreamweaver where you



Figure 2-10:
Drawing a
layout table.
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want to put something on the screen, and the program generates all the
required table work to make it happen.

To create a layout table, just follow these steps:

1.

Click the Layout view button in the Layout category on the Insert bar.

If the Insert bar is set to a different category, click and hold the category
name and select Layout from the drop-down list.

Click the Layout Table button (just to the right of the Layout view
button).

Click and drag the cross hair to create the layout table of your choice.

A light green table appears, as shown in Figure 2-10, with the dimen-
sions you gave it.

To create individual cells within that table, click the Draw Layout Cell
button to the right of the Layout Table button and draw a cell any-
where within the table.

If you create a layout cell outside a layout table, Dreamweaver will
create both the cell and the table to support it. Note that you cannot
draw a new cell that overlaps an existing cell in the table.

Layout Table

Layout view | Draw Layout Cell
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Previewing Your Work

If you create a layout cell, you can immediately edit the cell you created.
However, if you create a layout table, you either have to switch back to
Standard view to edit the single cell of that table or create a layout cell
within the table before you can edit the table.

Storing information in table cells

After you insert a table on a page, you can add or delete elements, such as
text and images, in the table cells:

4 Adding an image to a cell: To add an image to a table cell, click in a table
cell and choose Insert=>Image. Browse and select an image you want to
add to the cell, and then click OK. (For more information on inserting
images, flip to the “Inserting an image” section, earlier in this chapter.)

4+ Adding text to a cell: To add text to a table cell, click to position the
cursor in a table cell and type the text you want placed inside the cell.

4 Deleting an image from a cell: To delete an image from a table cell,
select the image and press Backspace or Delete.

4 Deleting text from a cell: To delete text from a table cell, select the text
and press Backspace or Delete.

Previewing Your Work

Whether you're working in Code view or Design view, at some point you’ll
want to see the page as visitors to your site will see it: in a browser such as
Internet Explorer or Netscape Navigator. If you have two or more browsers
on your computer, you can preview your page in any of the browsers —
without leaving Dreamweaver — by using the Preview in Browser feature.

To preview your page in your primary browser, choose Filer>Preview in
Browserw> Browser Name or use the keyboard shortcut F12. The keyboard
shortcut for previewing in your secondary browser is Shift+F12.



Chapter 3: Creating and Using
Dreamweaver Sites

In This Chapter

v~ Defining a site in Dreamweaver MX 2004
+» Whipping up your first site

v+~ Establishing a remote connection

v Using advanced site options

+ Publishing and maintaining your site

v+~ Using source control

D reamweaver MX 2004 can be used to create many different kinds of
Web pages. During the course of building a Web site, you’ll add pages,
graphics, links, and all sorts of related information into a single location to
be posted eventually to a Web server on the Internet. After your site is com-
plete, you’ll probably want to make updates and fixes. Heck, you may even
be making more than one site at the same time!

To help facilitate management of your Web site (or sites), Dreamweaver
offers a suite of site management tools. These tools are collectively called a
Dreamweaver Site. This chapter explores how you can use these tools to
manage your Web site more easily.

Defining a Site in Dreamweaver MX' 2004

Figure 3-1 shows a typical relationship between where you build your Web
site (your desktop) and where the site actually lives on the Internet (a Web
server). Dreamweaver Sites facilitate getting all the correct information
from your desktop to the Web server and generally make the Web page
creation process easier. Specifically, a Dreamweaver Site enables you to do
the following:

4+ Move files seamlessly back and forth between your local machine and
your Web server

4+ Keep all your site files in a single location
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Figure 3-1:
The desktop
in relation to
the Web
server.

4+ Generate pages for your site based on templates that you create

4+ Run reports on the pages in your site to check links, page load, and
other key functions

4+ Use source- and version-control to manage who works on what files and
when they do it, which can prevent team members from accidentally
overwriting each other’s work when building or maintaining a site
collaboratively

Internet

Your Desktp Web Server

A

WWW
Copy

Creating Your First Site

Earlier versions of Dreamweaver required every Web page you created or
edited to be part of a Dreamweaver Site. With Dreamweaver MX 2004,
Macromedia has removed that often-cumbersome requirement. Nevertheless,
if you're working with a set of files regularly in Dreamweaver, or if you're man-
aging several sites, you're likely to find using Dreamweaver Sites an efficient
way of working.

You can create a site in Dreamweaver manually or by using a wizard, as the
following sections describe.

Creating a site manually

This section shows you how to create a Dreamweaver Site manually. The fol-
lowing steps walk you through inputting the minimum amount of information
that you need to enter to create your site. However, you can choose from a
number of other options, and they are covered in the “Using Advanced Site
Options” section, later in this chapter.



Figure 3-2:
Defining
your site.

Creating Your First Site ‘7

To create a basic site manually, follow these steps:

1. Choose Site->Manage Sites.

The Manage Sites dialog box appears. You can also open the Manage
Sites dialog box by choosing Manage Sites from the drop-down list in
the Files panel that shows the current site.

2. Click the New button.
A pop-up menu appears with the choices Site and FTP & RDS Server.
3. Select Site.

The Site Definition dialog box appears, open to the Advanced tab by
default. The Local Info options, shown in Figure 3-2, appear by default.
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4. Set the options for your site by filling out each of the following pieces
of information:

¢ Site Name: Choose a name that you can remember easily and that
applies to the function of the site.

¢ Local Root Folder: This is the location on your hard drive where you
want to store the files that make up your site. Again, you should title
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Creating Your First Site

the folder something intuitive and easy to remember. If you want to
browse for a folder, just click the folder icon to the right of the text
field.

Refresh Local File List Automatically: When this option is selected,
Dreamweaver refreshes the list of files in your site every time you
copy a file into the site. The option is selected by default.

Default Images Folder: This is the standard directory for images
used on your site. Dreamweaver adds images here when you copy
image files into your site. A good practice is to name this folder
images (if your site is going to be hosted on a UNIX-based server, you
need to be consistent about using upper- and lowercase letters in file-
names and links to those files from your site). If you want to browse
for the directory, just click the folder icon next to the text field.

HTTP Address: This is the URL of your Web site. Dreamweaver uses
this to verify that links in your site are working properly.

Enable Cache: Selecting this option speeds up Dreamweaver’s site
management tools and is required for the Assets panel to work. See
your documentation for information about using the Assets panel.

. Click OK to create the site.

Dreamweaver creates a folder for your site if it doesn’t exist on your hard
drive, but it doesn’t create the images directory within that folder. Thus, it’s
always a good idea to create your folders on the hard drive first, and then
create your site.

Creating a site using a wizard

You may think that using a wizard to create a site is easier, which is true if
you're creating a complex site. However, if you're creating a simple site (one
that you’ll be working on by yourself and that doesn’t employ a server tech-
nology or testing server, for example) the manual route is the way to go.

To use the wizard, follow these steps:

1. Choose Siter>Manage Sites.

The Manage Sites dialog box appears.
. Click the New button.

A pop-up menu appears with the choices Site and FTP & RDS Server.
. Select Site.

The Site Definition dialog box appears, open to the Advanced tab by
default. (It just so happens that the Advanced tab has all the stuff
for defining your site manually, whereas the Basic tab holds the Site
Definition wizard.)



Figure 3-3:
Step one of
the wizard.
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Click the Basic tab to access the wizard, as shown in Figure 3-3.

Enter a name for your site in the appropriate text field, and then click
Next.

The Editing Files, Part 2 page of the wizard appears.

If your site is going to be dynamic, choose a server technology to
process Web pages before they’re sent to the user, and then click Next.

Select a technology by selecting the Yes radio button and selecting your
Web serving technology from the drop-down list. Dreamweaver provides
you with several server options, including several flavors of ASP, plus
JSP, PHP, and (of course) ColdFusion. If you're not using a server
technology, select the No radio button.

In the new page that appears, choose how you want to edit your files,
and then click Next.

If you have selected to use a server technology on the Editing Files, Part 2
page, then on the Editing Files, Part 3 page you get the Dynamic options
shown in Table 3-1; if you’re not using a server technology, you get the
Static options. Click the radio button next to the option you want to
choose.
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Table 3-1 Site Editing Options

Option Description Dynamic  Static
Option Option

Edit and Test Locally Allows you to edit your files Yes No

and test them locally using
ColdFusion (or other
technology) as your Web

server.
Edit Locally, Then Upload to In this mode, you edit the files ~ Yes Yes
Remote Testing Server (Edit on your computer, and then
Local Copies on Your Machine, manually upload them using
Then Upload to Server When Dreamweaver's FTP tools to
Ready) move the files to a remote

server.
Edit Directly on (Remote Testing)  This option allows you to edit ~ Yes Yes
Server Using Local Network files directly on a volume

on your internal network.

8. In the new page that appears, configure your testing environment,
and then click Next.

Based on the editing and testing methodology you chose in Step 7, you
are asked to configure your testing environment. Here are the various
options:

Edit and Test Locally: For this method, you are asked to provide the
local URL for testing. Usually, this is http://Tocalhost/folder,
where folder is the name of the root folder of your site.

In order to ensure that this method works properly, always make
sure that you create your site within the directory for http://
localhost on your hard drive. For most Windows 2000 or XP
computers, this location is C: \inetpub\wwwroot\ by default.

Edit Locally, Then Upload to Remote Testing Server: If you select
this route, click Next to see a page where you can select a method of
connecting to the remote location for your site. Your options are
Local/Network, FTP, RDS (Remote Development Services, used in
conjunction with ColdFusion), and the always popular, “I'll set this
up later.” Figure 3-4 shows the Local/Network option.

Edit Directly on (Remote Testing) Server Using Local Network: If
you’ve chosen this option, then you are asked for the URL of the
remote server, as shown in Figure 3-5, so that Dreamweaver knows
where to look to test your site. If you want to edit directly on the
remote testing server using FTP or RDS, click the Create an FTP or
RDS server connection text link on the first page of the wizard.
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Setting Up a Remote Connection

9. In the new page that appears, configure your file sharing options and
click Next.

Dreamweaver includes options for source control, which you can use to
prevent team members from overwriting each others’ work when col-
laborating. You can choose to enable it here by selecting the Yes radio
button. File sharing is discussed in more detail in the section, “Using
Source Control,” later in this chapter.

10. Review your settings and click Done to set up your site.

The Site Definition dialog box closes. Click Done to close the Manage
Sites dialog box.

Setting Up a Remote Connection

After you create your site, either by using the wizard or by setting it up man-
ually, it’s a good idea to get connected to the place where the remote ver-
sion of your site (the one users will access via the World Wide Web) will live.
Dreamweaver can connect to a remote server in a variety of ways. The route
you choose depends largely on how you plan to build and maintain your
site. You have essentially three different scenarios:

4+ Creating and testing your site solely on your own computer: For exam-
ple, this may be the case if you’re building your site for someone else, say
a client. Here the remote server is your computer — not all that remote!

4 Creating your site on your computer, but testing it somewhere else:
This is the most common situation. Dreamweaver has three different
delivery options for this scenario: FTP, Remote Development Services
(RDS), and local network connection.

4 Creating and testing your site on a remote machine: In this case, the
options are the same as in the previous bullet. The only difference is
that when you're editing, you’re editing files directly on the remote loca-
tion, leaving nothing on your local machine.

In many cases, your remote location is at an externally hosted Internet
Service Provider (ISP). If you've got an account set up with an ISP, make sure
to get the following information, which is required for Dreamweaver to set
up a connection to your remote Web server:

4 An IP address or a URL to be used when posting your files

4+ A folder on the remote server where you are supposed to keep your site
files

4 A username for your account

4+ A password for your account



Figure 3-6:
The
Manage
Sites
dialog box.
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To set up a remote connection, follow these steps:

1. Choose Site->Manage Sites to bring up the Manage Sites dialog box,
shown in Figure 3-6.
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2. Select your site from the list on the left, and then click the Edit
button.

The Site Definition dialog box appears, open to the Advanced tab.
3. From the Category list on the left, select Remote Info.

Along the right side of the dialog box, the Local Info options are
replaced with the Remote Info options. If you haven’t set up a connec-
tion previously, all you see is the Access drop-down list.

4. Select an option from the Access drop-down list.
You can choose from several Access options in this list, including:
e FTP: The industry standard File Transfer Protocol.

e Local/Network: A location on your local (meaning office, home
office, and so on) network.

e RDS: ColdFusion’s Remote Development Services allows secure
remote access to files within a ColdFusion application server.

¢ SourceSafe Database: SourceSafe is Microsoft’s version control
application, which helps prevent the accidental overwriting of
files when you're collaborating with others to build the site. With
Dreamweaver, you can integrate SourceSafe and use it for your
version control.

e WebDAV: This stands for Web-based Distributed Authoring and
Versioning. Like SourceSafe, it’s a standard for version control
and is used with Web servers like Apache Web Server and
Microsoft’s IIS.
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Figure 3-7:
Setting your
Firewall
preferences.

5. Fill out the appropriate information for the connection type you
selected.

Leave the source control settings alone for the moment, which are
described in the “Using Source Control” section, later in this chapter.
The following list describes the information needed for each connection
type:

e FTP: In addition to the four items we note at the beginning of this
section (host, folder, username, and password), you also need to
select the Passive FTP check box if you plan to use Passive FTP
(required for some servers). If there’s a firewall you need to work
through, you can click the Firewall Settings button to set the Firewall
preferences in the dialog box that appears, as shown in Figure 3-7.
Select the Use Secure FTP (SFTP) check box if you want to use
encrypted secure logins (again, not likely). After you've added the
necessary settings, you're able to connect to your ISP.
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If you select Automatically Upload Files to Server on Save,
Dreamweaver will automatically make a connection to the remote
server and upload your file each time you save it.

Select the Enable File Check In and Check Out option if you're work-
ing in a collaborative environment and you want to ensure that other
team members can’t work on a file at the same time you’re working
on it. If you select this option, you need to add information that will
identify you to your collaborators.

¢ Local/Network: Here, you only need to specify the location of the
remote folder on the network or a local drive, which you can enter



Figure 3-8:
The
Configure
RDS Server
dialog box.
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manually or by clicking the folder icon to browse the network for the
folder location. You can also select the Refresh check box if you’d
like the list of files on your site to be automatically refreshed when a
new file is added.

e RDS: If you select RDS from the drop-down list, you need to click the
Settings button next to the list to configure the RDS connection, as
shown in Figure 3-8. To configure RDS, you need a host name (IP
address or URL), port number (the default is 80), the directory of
the site on the host, a username, and a password. If you don’t want
the password saved, then deselect the Save check box.
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¢ SourceSafe: As with RDS, with SourceSafe you have to click the
Settings button next to the drop-down list. Then you specify the
location of the SourceSafe Database Path (a path to an . ini file,
usually on a network volume), the name of the project, a username,
and a password. If you don’t want the password saved, then deselect
the Save check box.

e WebDAV: With WebDAV, you must also click the Settings button next
to the drop-down list to configure the connection. You need the URL
of the connection, a username, a password, and an e-mail address. If
you don’t want the password saved, then deselect the Save check box.

6. Click OK to put the changes into effect.

Using Advanced Site Options

If you used the wizard to create your site, you may have been struck by the
array of questions asked. That’s because you can configure a number of
advanced settings with Dreamweaver. Most of them you’re not likely to
need, but just in case, we describe them in the following sections. You can
access all these options by selecting the name of the item in the Category
list of the Site Definition dialog box (refer to Figure 3-2).
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Testing your server

Select Testing Server from the Category list on the Advanced tab of the Site
Definition dialog box to access the options for setting up your testing server.
If you're building a dynamic site, you need to have a Web server running
that can process the pages and render them as HTML. (For more on how
this is accomplished, see Book VI, Chapter 3.) To specify a Web serving
technology, do the following:

1. Select a Web server from the Server Model drop-down list, as shown
in Figure 3-9.

You have several options here, but if you're working within the
Macromedia model, your selection is probably going to be ColdFusion.

Soroer mooel:  Coltifenion e

accoss: D8 ™

Figure 3-9:
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2. Select an Access type.

You can choose FTP or Local/Network. If you chose RDS on the Remote
Info screen, you see an RDS option here as well. Choosing any of them
provides additional fields for you to fill out, as specified for each Access
type in the “Setting Up a Remote Connection” section, earlier in this
chapter. Choose None if you don’t want to use a testing server.

3. Click OK to save your settings.
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Cloaking

Cloaking is a handy and appropriately named feature in Dreamweaver Sites.
When enabled, cloaking allows you to hide different file types or folders
from Dreamweaver’s site tools. This can be especially helpful if you keep
your raw asset files (your source Fireworks PNGs, Flash FLAs, and so on)

in the same directory as the site itself, but you don’t want the files uploaded
or downloaded, included in reports, or otherwise touched by various
Dreamweaver operations. To engage this feature, click the Advanced tab of
the Site Definition dialog box and select Cloaking from the Category list on
the left. Then select the Enable Cloaking check box, as well as the Cloak
Files Ending With check box, and add the file extensions for the file types
you want to mask. See the online Help files for more details.

Using Design Notes

Design Notes aren’t really necessary unless you’re working on your site
collaboratively in Dreamweaver with other people. Then, Design Notes can
be especially helpful. For example, you can use Design Notes to let others
know the status of a given file. To engage Design Notes, click the Advanced
tab of the Site Definition dialog box, select Design Notes from the Category
list on the left, and then simply select the Maintain Design Notes check box.
If you want to move the notes to the server when the site is published, so
that other team members can access them, select the Upload Design Notes
for Sharing check box.

Setting up a site map

If you select Site Map Layout in the Category list in the Site Definition dialog
box, you can set up the specifics of how you’d like your site’s Site Map to
look. You can specify the following:

4 The home page for the site map, which can be different from the home
page (index.htm) of the site

4 The number and width of the columns of the map

4 The labels for the site map icons

4 Whether or not to display items marked hidden

4+ Whether or not to display dependent files

Selecting columns for the File view

For the File view, shown in Figure 3-10, you have six built-in columns to
choose from: Name, Notes, Size, Type, Modified, and Checked Out By.
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Figure 3-10:
The File
view.

However, you can also add and remove your own columns by clicking the
(+) and (-) buttons, respectively. For a column you create, you can also
specify the following:

4 The column name

4+ The column’s Design Note association, if its contents relate to a specific
Design Note

<+

The text alignment for the column

4 The option to show or not show the column in the File view (Note: The
Name column cannot be hidden or moved.)

4 Whether or not to share the column so other workers on the site can
see it (Note: You must have Maintain Design Notes checked to share a
column.)

Enabling Contribute compatibility

To enable compatibility with Contribute 2, click the Advanced tab of the Site
Definition dialog box and select Contribute from the Category list on the left.
Select the Enable Contribute Compatibility check box if you plan to have
people maintain your site using Contribute. Selecting this option allows you to
perform many administrative functions related to Contribute. (For example,
you can send Connection Keys based on your Dreamweaver Site setups.)
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Publishing Your Site

Publishing Your Site

After you’'ve set up a remote site in a Dreamweaver Site, publishing your site
is a snap. To publish your site to a remote server, just follow these steps:

Figure 3-11:
Remote and
local sites.

1.

2.

If the Files panel isn’t already open, open it by choosing Windowr>
Files or by pressing F8.

On the File tab, click the Expand/Collapse button (the button on the
far right of the toolbar) to switch to File view mode.

This brings up the File view shown in Figure 3-11.

If you haven’t connected to the remote server since you launched
Dreamweaver most recently, click the Connection button at the left of
the Files panel toolbar to establish a connection with the remote
server.

Select a file and click the Put button on the toolbar (upward pointing
blue arrow) to copy a file from the local server to the remote server
or the Get button (downward pointing green arrow) to copy a file
from the remote server to the local server.

If you're copying files for the first time, simply select the site’s root
folder and click the Put button. To copy files from the Local to Remote
servers, or vice versa, you can also simply click and drag the elements
from local to remote, or vice versa. If you use this method, be careful
to place files in the correct folders.
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90 Maintaining Your Site

If you ever want to see what’s going on behind the scenes when you’re copy-
ing those files, just click the FTP button in the toolbar in File view. The
Results panel appears/expands and shows you the remote connections
being set and all the commands for the files being sent (the File view col-
lapses back to the Files panel as well).

Maintaining Your Site

Figure 3-12:
The Reports
dialog box.

After your site is built, you want to make sure that it’s running at peak effi-
ciency. To help in this effort, Dreamweaver offers some valuable tools that
can help you keep on top of the wide array of items that go into keeping
your site running smoothly. We describe the two basic types of tools,
reports and link checkers, in detail in the following sections.

Running reports

Reports encapsulate information about various aspects of your site at the
time the reports are run, giving you a snapshot of things, such as which files
on your site are currently being worked on by different team members,
whether all the images on a selected page have Alt tags, and more. To run a
report in Dreamweaver, just follow these steps:

1. Choose Site->Reports.

The Reports dialog box, shown in Figure 3-12, appears.

Cancsil
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2. Choose what you want to run the report against.

You can choose to run a report on the currently selected document, the
entire site, selected files in the site, or a folder within the site. Select one
of these options from the Report On drop-down list.
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3. Select the reports you want to run by selecting the check box next to
their names.

You can run nine possible reports, across two categories:

¢ Checked Out By: This report tells you what files in source control
are currently being used by different members of the team. If you
want the report to show only which files are currently checked out
by a particular team member, click the Report Settings button at the
bottom of the dialog box while the report is selected and add an
individual’s name to the text field in the Checked Out By dialog box
that pops up.

* Design Notes: This report prints out all the Design Notes associated Book Il
with files on the site. To filter your results via the Design Notes Chapter 3
dialog box, shown in Figure 3-13, click the Report Settings button oo
while the Design Notes report is selected. ﬁ §

¢ Recently Modified: This report shows which files have been modi- E E
fied within parameters you set by clicking the Report Settings button § 2
and specifying in the Recently Modified dialog box. ) :
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¢ Combinable Nested Font Tags: This report details locations in the
code where overlapping Font tags could be merged. For example, if
you change the size of a block of text, your code might contain
something like this:

<FONT face="Arial"><FONT size="2">Some
text.</FONT></FONT>

When it could and should be
<FONT face="Arial" size="2">Some text.</FONT>
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Figure 3-14:
The Results
panel.

¢ Accessibility: If you run this report, the site files are scanned to find
places where the code is not ADA (Americans with Disabilities Act)
compliant. For more information about accessibility, browse to the
W3C Web Accessibility Initiative pages at www.w3.0org/WAI/
Resources/.

e Missing Alt Text: This report looks for images to make sure they
have Alt text (see the section on modifying an image in Book I,
Chapter 2 for a little info on Alt text).

¢ Redundant Nested Tags: This report searches the code for locations
where extra tags can be eliminated.

¢ Removable Empty Tags: If you're working in Design mode and moving
lots of things around, sometimes the underlying code can be left with
lingering, empty tags. This tool finds those empty tags.

¢ Untitled Documents: This report searches for pages that may have a
filename but don’t have a title.

4. Click OK to run the reports.

The results appear in the Site Reports tab of the Results panel, as
shown in Figure 3-14.
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Checking links

In addition to the reports that help clean up your code, Dreamweaver can
also check the links on your site. To run the Link Check report, choose
Siter>Check Links Sitewide or press Shift+F8. You see the results in the Link
Checker tab in the Results panel. The report shows broken links, external
links, and orphaned files.

Using Source Control

Source control allows team members to check out a document in your site,
thereby locking it and making it uneditable by others until the team member
who checked it out checks it back in again. This process is intended to
ensure that files don’t get overwritten accidentally and that data doesn’t get
lost during the development process.
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In most large-scale software development projects, where you've got multi-
tudes of people working on a single code-base, source control is critical. If

your site requires that more than three people work on the same pages and
code, you should consider taking advantage of this feature in Dreamweaver.

To set up source control, do the following:

1.
2.

3.

4.

Choose Siter>Manage Sites, select your site, and then click the Edit
button to open the Site Definition dialog box.

Click the Advanced tab if it’s not already open and select Remote Info
from the Category list on the left.

Set your source control options at the bottom of the screen.

When you enable file check in and check out, the following options
become available:

¢ Check out files automatically when you open a document within the
site

e Provide your name and e-mail address for site reporting and infor-
mational purposes

You must have selected an Access option on the Remote Info screen
before you can get the Check In/Check Out options to show up at the
bottom of the page. See the “Setting Up a Remote Connection” section,
earlier in this chapter, for more information about Access options.

Click OK to save your settings.

To work with a file after you've enabled source control, right-click the file
from the Files panel and select one of the following options:

4
*

<+

Get: Retrieves the most recent version of the file and copies it locally.

Check Out: Makes your local version the only editable version of a docu-
ment and ensures that others can’t open and save the file.

Put: Copies the local version of your file to the remote location.

Check In: Puts your local version of the file on the server and unlocks it
so that others can check it out and work on it if need be.

Book Il
Chapter 3
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Chapter 4: Punching Up Your
Pages with Forms and Frames

In This Chapter

v Incorporating forms into your Web page

v+ Structuring your pages with frames

' wo of the more popular Web page features, forms and frames, are also
two of the most advanced features. You use them in your Web pages to
serve the following functions:

4+ Forms: Enable you to gather information and feedback from the users
who visit your Web pages. Forms can consist of text fields, buttons,
check boxes, radio buttons, and drop-down lists, which enable the user
to enter information or to choose among options you present.

4+ Frames: Enable you to construct sophisticated navigational schemes for
your Web site. Frames are actually separate Web pages that are parti-
tioned off so that two or more can be displayed in the same browser
window at the same time. For example, one frame may be a navigational
page consisting of a list of links to other pages; that frame remains in
place in its portion of the browser window even when the user clicks a
link to display a different Web page in the other frame.

In this chapter, you see how to work with these powerful features in
Dreamweaver MX 2004.

Incorporating Forms into Web Pages

Forms on the Web serve the same purpose as the paper-based forms you
fill out — they provide a structured format for gathering specific informa-
tion. The difference is that Web-based forms usually require less time for
keyboard-savvy users to fill out (and using Web-based forms also saves a
few trees otherwise destined for a paper mill).

Dreamweaver offers you a number of handy tools for creating Web-based
forms that you can easily include on your Web pages. You can incorporate
everything from text fields to radio buttons, and you can create surveys,
gather user data, and conduct e-commerce.
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Figure 4-1:
The dashed
lines mean
you've
created a
form!

Incorporating Forms into Web Pages

Creating Web-based forms requires two steps:

1. Creating the form that users see and interact with, which we demon-
strate how to do using Dreamweaver in this chapter.

2. Creating the processing program that accepts and processes form
input, which we cover in more detail in Book VI, Chapter 4.

Adding a form
Before you can insert specific form objects, such as check boxes, on your

Web page, you must first add a form to the page so that the appropriate
code is added to the HTML.

To add a form to a page, click in the Document window where you want to
add the form and choose Insert=>Forme>Form or click the Form button from
the Forms category on the Insert bar. (If the Insert bar is set to a different
category, click and hold the category name and select Common from the
drop-down list.)

Dreamweaver adds the form to the page as indicated by the red dashed
lines and also adds the associated form tag to your HTML page code, as
shown in Figure 4-1. You can now insert form objects inside the red dashed
lines of the form.
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If you attempt to add a form object without first adding a form, a dialog box
appears, asking whether you want to add a form tag. Click Yes to add both
the form tag and the object to your page.

Specifying form properties

A form has six properties that you can set using the Form Property inspec-
tor: Form Name, Action, Method, Enctype, Target, and Class. Click the form
to open the Form Property inspector. (If the Property inspector does not
appear, open it by choosing Window=>Properties.) Then specify the follow-
ing properties:

4 Form Name: Enter an alphanumeric name in the empty text field (the
name should start with a letter, but it can be made up of both letters
and numbers). The advantage of naming your form is that you can use
the name to reference the form in a scripting language that you use to
retrieve, store, and manipulate the form data.

4 Action: Enter the URL of the application document/file that processes
the form data. Alternatively, you can browse to the location by clicking
the folder and making a selection in the Select File dialog box.

You can select the following three common actions:

e Enter the URL of a ColdFusion page that evaluates the form after it’s
been submitted.

e Enter the JavaScript program that runs after the user submits the
form. The action appears as follows:

javascript:function()
Here, function refers to the name of your form-handling function.

e Enter amailto: address where the form data goes after the user
clicks the Submit button. Amailto: address appears similar to the
following:

mailto:gruntworker@formhandling.com

4 Method: Select a method from the drop-down list for how the form data
passes to the processing entity that you specified in the Action field.
Choices are Default, GET, and POST. (Default and GET are the same.)
GET sends the form data by appending it to the URL that the Action
specifies. POST sends the form data as a separate entity. GET limits the
amount of data that can pass along, but POST does not.

In other words, if you were to choose GET, the URL sent to the server
might look something like http://www.server.com/coldfusionpage.
cfm&bowlingballcolor=blue, with the form data stuck onto the end.
If you were to choose POST instead, the URL would just look something
like http://www.server.com/coldfusionpage.cfm.
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Most of the time, whether you choose GET or POST doesn’t really make
a difference. However, there are times when you may want to choose
one over the other. For example, for security purposes, you may not
want information, such as a credit card number, ever being shown in a
browser’s history. And if the user might choose to bookmark the URL,
whether or not to have all of the form data appear could affect your
decision. If the form data included secure user information (such as the
credit card example), then you probably wouldn’t want to have the form
data appear. However, if the form data includes search criteria, the user
might want to bookmark the URL complete with the search parameters.

Data received at the specified mailto: address is not formatted for
easy reading: It appears as strings of code with the form data embedded
within it. This may depend on the encoding option, which we are about
to discuss.

Enctype: This is an optional attribute. For enctype, your choices are
application/x-www-form-urlencoded (the default), and multipart/
form-data. application/x-www-form-urlencoded replaces all blank
characters in the text with a plus sign (+), and other non-printing char-
acters with symbols and numbers. This is often necessary for the server
to interpret the information it is receiving — for example, when you've
used the GET method, the browser would not be able to process a URL
with blank spaces in it. Multipart/form-data does not do this conver-
sion, but instead transfers the information as a compound MIME docu-
ment. Multipart/form-data is the method that must be used if you are
using an <INPUT TYPE="file"> element in the form. Instead of either
of these two options, you can type in text/plain, which will also send the
data unencoded; however, this is not a W3C standard.

Target: This is also an optional attribute. If you do not specify a target,
the server will assume that you want any information that is sent back
to the browser (the URL of the response page, for example) sent to the
same window or frame that your original form is in. If you wish the form
submission’s results to appear in a different frame or window, you must
specify the name of the target window in this attribute.

Class: You can apply a CSS (Cascading Style Sheet) class to the form as
a whole and to some form elements in order to control how those form
elements appear in a browser. For example, you can specify the color of
a text field by assigning it a style. This attribute is also optional. For
details on using CSS style sheets, take a look at Cascading Style Sheets
For Dummies, by Damon Dean (published by Wiley Publishing, Inc.).

Labeling form objects

Dreamweaver enables you to provide descriptors for form objects and
provide the user with directions about how to complete the information
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requested for each option. To add descriptors to form objects, simply posi-
tion your cursor in the form and begin typing. Then insert the form object
you want.

Using text fields
Text fields are blank text boxes that you can insert in your form to hold

alphanumeric information that the user types. You can set up a text field to
hold a single line of text, multiple lines of text, or a password, as follows:

4 Single line: Provides space for the user to enter a single word or short
phrase of text.

4 Multi line: Provides space for the user to enter a longer string of text.
Appropriate for a comment box.

4+ Password: Provides space for the user to enter a password. An asterisk
or other placeholder appears in the text field for each character that the
user types.

To add a text field, follow these steps:

1. In the Document window, click where you want to add the text field
and choose Insert>Form=>Text Field, or click the Insert Text Field
button on the Form category of the Insert bar.

If the Insert bar is set to a different category, click and hold the category
name and select Form from the drop-down list.

Dreamweaver adds a text field to your form, and a Text Field Property
inspector appears. If the Text Field Property inspector does not appear,
choose Windowr>Properties to open the inspector.

2. Fill in the following fields of the Text Field Property inspector to
define the parameters of the text field:

¢ TextField name: Enter a name in the empty field. The field is refer-
enced by this name in the HTML page code.

e Char Width: Enter a whole number for the approximate visible
width of the field. (The width is approximate because text charac-
ters in your form are displayed differently according to users’
browser settings.)

e Max Chars: (Applies to Single line and Password fields only.) Enter
a whole number to indicate the maximum number of characters that
the user can enter in the field. Max Chars can be different from Char
Width.

e Num Lines: (Applies to Multi line fields only.) This specifies the
height, in lines, of the form element, and may be affected by the set-
ting for Wrap (see below).
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e Type: Select a radio button for Single line, Multi line, or Password.

¢ Init Val: (Optional) Enter an alphanumeric word or phrase that occu-
pies the text field when the user first encounters the field. Users
can enter their own information over the Init Val. If you leave this
attribute blank, the user will see a standard empty text field.

e Wrap: (Applies to Multi line fields only.) Select an option for text
wrapping from the drop-down list. Options consist of Default, Off,
Virtual, or Physical. Default and Off are the same and do not wrap
text until the user presses the Enter key. The Virtual option wraps
text on the user’s screen but not when the form is submitted. The
Physical option wraps text both on the user’s screen and when the
form is submitted.

¢ (Class: (Optional) You may assign a CSS class to a text field to affect
the appearance of the field or the text within it. For details on using
CSS style sheets, look up Cascading Style Sheets For Dummies, by
Damon Dean (published by Wiley Publishing, Inc.).

Setting up buttons

After a user enters data into a form, the user must then perform some sort
of task to transmit the data from his or her computer to another computer
that can process the information. Dreamweaver offers you three buttons
you can use to activate your form: Submit Form, Reset Form, and None:

4 Submit Form: After the user clicks this button, the form data scoots off
to another computer based on the specified action. (You see how to set
the action of a form in the “Specifying form properties” section, earlier
in this chapter.)

4+ Reset Form: After the user clicks this button, it erases all data entered
into the form, resetting each form field to its initial value.

4+ None: After the user clicks this button, it executes the programming
function that the Web designer assigned to it (for example, performs a
mathematical calculation or sends the user to a different URL).

Follow these steps to insert a button into your form:

1. Click where you want to add the button in the Document window and
choose Insert->Formr>Button, or click Insert Button on the Form cate-
gory of the Insert bar.

If the Insert bar is set to a different category, click and hold the category
name and select Form from the drop-down list.

Dreamweaver adds a button to your form and the Button Property
inspector becomes visible. If the Button Property inspector does not
appear, choose Windowr>Properties to open the inspector.
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Form
elements.
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2. Fill in the following fields of the Button Property inspector to define
the parameters of the button:

¢ Button name: Enter a name in the empty text field. This name identi-
fies the button in the HTML code.

e Label: Enter the text that you want to appear on the button.

e Action: Select a radio button to indicate the function of the button.
Choices consist of Submit form, Reset form, and None.

¢ (lass: (Optional) You can assign a CSS style to affect the button’s
appearance (color, width, and the like).

You can create a graphical Submit button — a button created from a small
image — by choosing Insert>Formr>Image Field or by clicking the Image
Field button in the Form category of the Insert bar. Then browse to the
image file in your site or type the path to and name of the image file directly
into the File Name field.

Adding other form elements

In addition to the text fields and buttons, you can add a variety of form ele-
ments that help your users give you information. Figure 4-2 shows some of
the useful form elements you can add to your forms. To insert any of the ele-
ments you see in Figure 4-2, follow these steps:

Image Field File Field
Jump Menu Label
formm ¥ O~ @E = l' &) [ - ™ -

Create Form

Text Field

Hidden Field

List Menu Button Field Set

Radio Group

Radio Button

Text Area Check Box

1. Position your cursor in the area of the Document window where you
want to add the element.

2. Click the appropriate button in the Form category of the Insert bar (see
Figure 4-2), or choose Insert=>Form Objects=>Desired Form Element.

If the Insert bar is set to a different category, click and hold the category
name and select Form from the drop-down list.
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Dreamweaver adds the element to your form, and the appropriate
inspector appears. (If the appropriate inspector does not appear, open
it by choosing Windows=>Properties.)

3. Fill in the fields of the inspector.

If you're adding a radio group, jump menu, or image, a dialog box will
pop up and ask you for additional information. Fill in your choices for
each of these.

4. Click OK to apply your selections and close the dialog box.

Structuring Pages with Frames

A\

Frames are divisions of a Web page that enable you to load information inde-
pendently into distinct regions of the browser window. Frames are useful if
you want to display certain information on-screen while changing other
information. You frequently see three-frame pages on the Web — the top
frame shows the site’s title graphic, the left frame shows the navigation bar,
and the large body frame changes to show the content that you select.

A special HTML page called a frameset defines the structure and formatting
of frames on your Web page. As you work with frames, be aware that you
must always save the frameset page to lay out the size, position, and bor-
ders of your frames, along with the content that you want to display in each
frame. And keep in mind that different browsers may draw the frames
slightly differently, even if you specify exact pixel dimensions.

Adding frames

You can add a frame to a frameless Document window or to an existing
frame within the Document window. Adding a frame to an existing frame
divides the existing frame into two or more regions.

To add a frame, click the Document window or existing frame in the area
where you want to add the frame. Then click the Frames button in the Form
category of the Insert bar and choose from the list of options that pops up.
You can also get to an equivalent list (the same options, some with slightly
different names, and no icons) by choosing Insert=>"HTML=>Frames=>Frame
Option, where Frame Option is one of the choices detailed in Table 4-1.

Table 4-1 Options for Creating Frames
Frame Option What It Does

Left Creates a vertical frame down the left side
Right Creates a vertical frame down the right side

Top Creates a horizontal frame across the top
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Frame Option

What It Does

Bottom

Creates a horizontal frame across the bottom

Bottom and Nested Left

Splits the page in two — top and bottom — and creates a left
frame in the top frame

Bottom and Nested Right

Splits the page in two — top and bottom — and creates a right
frame in the top frame

Left and Nested Bottom

Splits the page in two — right and left — and creates a bottom
frame in the right frame

Right and Nested Bottom

Splits the page in two — right and left — and creates a bottom
frame in the left frame

Top and Bottom

Creates three frames

Left and Nested Top

Splits the page in two — right and left — and creates a top
frame in the right frame

Right and Nested Top

Splits the page in two — right and left — and creates a top
frame in the left frame

Top and Nested Left

Splits the page in two — top and bottom — and creates a left
frame in the bottom frame

Top and Nested Right

Splits the page in two — top and bottom — and creates a right
frame in the bottom frame

A third method of adding a frame is to drag the outer border of the current
frame, or Alt+click in the inner border. You can then follow the steps in the
next section to modify this new frame.

Modifying frames

You use the Frame Property inspector to select the source page that appears
in a frame. You also use the Frame Property inspector to format the appear-
ance of an individual frame. To modify a frame, follow these steps:

1. If the Properties panel is not already open, open it by choosing
Window=>Properties or by using the keyboard shortcut Ctrl+F3.

2. In the Frames panel, Alt+click the frame that you want to modify the

attributes of.

Note: You can’t simply click a frame to open its associated Frame
Property inspector. If you click a frame, you’re actually clicking the
source page that resides in the frame — a process identical to clicking
in the Document window for that page. To select a specific frame, press
the Alt key and click in the frame. You see the Frame Property inspector
for an individual frame, and the selected frame is marked with a dashed
line, as shown in Figure 4-3.

A Frame Property inspector appears for the selected frame. If the
inspector doesn’t appear, open it by choosing Window=>Properties.
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Figure 4-3:
Alt+click a
frame to
selectit and
see the
Frame
Property
inspector.
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3. In the Frame Property inspector or the Attributes tab of the Tag

Inspector panel, enter a name for your frame in the Frame Name text
field.

This name is the name by which the frame is referenced in the Frames
panel, target drop-down lists, and the HTML page code. The frame name
must start with a letter, and you should not use hyphens, spaces, or peri-
ods. You should also avoid using JavaScript-reserved names, such as
top. Although these words and symbols may be accepted, if you are
using any scripting (JavaScript, VBScript) to manipulate your frames,
the results may be inconsistent or wrong. It’s a good idea to get into the
habit of avoiding these words and characters. Word separation can be
indicated by capitalization, and underscore characters can also be used.

In the Src text field, enter the name of the source page whose content
you intend to display in the frame.

Alternatively, you can click the Src folder and browse to select the
source page.

Select a scrolling option for your selected frame from the Scroll drop-
down list. The options are as follows:

¢ Yes: Adds scroll bars to the frame, whether they’re needed or not.

¢ No: Doesn’t add scroll bars to the frame, even if a scroll bar is
needed to display the entire frame.
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¢ Auto: Places one or more scroll bars in the frame if the frame con-
tents exceed the frame boundaries.

¢ Default: Places one or more scroll bars in the frame, depending on
the user’s browser settings.

6. Select the No Resize check box if you don’t want the user to be able
to resize the frame.

If you do want the user to be able to resize the frame, leave the check
box deselected.

7. Format the frame border appearance by selecting a choice from the

Borders drop-down list: Book Il

¢ Yes: Creates a three-dimensional look for the borders. (This doesn’t Chapter 4
work in all browsers.)

e No: Creates a single-color flat look for the borders, or if No is
selected for each of the frames in a frameset, no border appears.

e Default: Enables the user’s browser to set how borders appear.

dn Buiyoung

8. Select a border color for the frame by clicking the Border Color
swatch and selecting a color from the Color palette that appears.

sawel4 pue suuo4
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Alternatively, you can enter a hexadecimal color code in the Border
Color text field. This doesn’t work in all browsers and is optional. If your
frames don’t have borders, then the border color will not apply.

9. Enter a number in pixels in the Margin Width and the Margin Height
text fields.

Margin Width specifies the horizontal standoff space between the frame
content and the frame border. Margin Height specifies the vertical
standoff space between the frame content and the frame border. This

is in addition to any values that the page called into the frame already
has assigned.

Deleting frames

To delete a frame, select the frame border and drag it to the edge of the
parent frame or to the edge of the Document window — whichever is closer.
If you only have two frames on the page, this action will result in a frameset
with only one page in it.

Saving frames

Saving a frame means that you're saving the HTML page from which the
source content of the frame originates. To save a frame, follow these steps:

1. Select the frame by clicking in it.

2. Choose File>Save Frame.
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3. The first time you save the frame, enter a name in the File Name text
field of the Save As dialog box that appears, and then click the Save
button.

Future saves require that you complete only Steps 1 and 2.

Saving framesets

Saving a frameset means saving the layout of frame positions, frame names,
and border formatting on a page. Keep in mind that you must save individ-
ual frames to save the content contained in those frames. To save a frame-
set, follow these steps:
1. Select the frameset by clicking one of its borders.
2. Choose Filer>Save Frameset.
Note: This will not work if the frameset is nested.

3. The first time you save the frameset, enter a name in the File Name
text field of the Save As dialog box that appears, and then click Save.

Future saves require that you complete only Steps 1 and 2.
If you have made changes to individual frames — not just the frameset —

since your last save, Dreamweaver asks if you want to save individual
frames. Make sure that you do so.

Setting no-frames content

Text-based browsers and many older browsers frequently don’t support
frames and can’t correctly display pages that you create by using frames.

To help ensure that the maximum number of users can view your page cor-
rectly, Dreamweaver offers you a method for building no-frames pages as
companions to your frame-enabled pages. To create a no-frames page for
your current frameset, follow these steps:

1. Choose Modify-~>Frameset>Edit NoFrames Content.

A blank, NoFrames Content page appears in the Document window and
replaces your frame-enabled page, as shown in Figure 4-4.

2. On the NoFrames Content page, insert the content that you want to
appear in NoFrames browsers.

This content can include text, images, and other page elements.

3. Return to your frame-enabled page by choosing Modify->Frameset->
Edit NoFrames Content.



Figure 4-4:
An

alternative
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page.
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Targeting content

You can set up a two-frame frameset in which you use the left frame for navi-
gation and the main frame to display any link that the user clicks in the navi-
gation frame. Simply set up the link to target the main frame as the location

where you want the selected HTML page to open.
Set up a target by following these steps:

1. Select the text or image that you want to act as a link.

Doing so opens the associated Property inspector. If the inspector doesn’t

appear, open it by choosing Window=>Properties.

2. In the Link field, enter the name of the HTML source page that will
appear in the frame.

Alternatively, you can click the Link folder and browse to select the
source page.

3. From the Target drop-down list, select the target frame where the link

is to appear.

All available targets are listed in the drop-down list, as shown in
Figure 4-5. These targets include the names of all frames that you set
up and also the following system-wide targets:

Book Il
Chapter 4

sawel4 pue suloq
yum sabed inop
dn Buiyaunyg



108 Structuring Pages with Frames

Figure 4-5:
Selecta
target frame
for the link.
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_bTlank: Opens a new browser window and shows the link in that
window. The current window remains open.

_parent: Opens the link in a window that replaces the frameset
containing the current page.

_self: Opens the link in the current frame. The linked page replaces
the page in the current frame. If you want the link to open in the
current frame, you can select _self, or you can leave the Target
area in the Property inspector empty.

_top: Opens the link in a window that replaces the outermost frame-
set of the current page. (Same as _parent, unless you're using
nested framesets.)

Targeting can work in more complicated framesets using the same basic
process. Whichever frame you target is the one that will update when the
user clicks a link targeting that frame.



Chapter 5: Laying Out Pages
with Layers

In This Chapter

v+~ Adding, selecting, and deleting a layer
+~ Placing objects in a layer
+ Changing layer properties

+~ Nesting layers

T) lay out the content of your Web page precisely, you can use tables
(see Book II, Chapter 2), or you can use the latest and greatest layout
aid: layers. You can think of layers in Dreamweaver MX 2004 as separate
pieces of transparent paper that you fill with content (images, text, and so
on) and shuffle, stack, position, and overlap until your Web page looks
exactly the way you want.

Dreamweaver layers use a now common companion to HTML called
Cascading Style Sheets (CSS) in order to place your content anywhere

on the screen. However, you should be aware that Cascading Style Sheets
are only supported in Internet Explorer and Netscape Navigator versions
above 4.0. For more information about Cascading Style Sheets, check out
Cascading Style Sheets For Dummies, by Damon Dean (published by Wiley
Publishing, Inc.).

Before you begin working with layers, you may find it useful to have the
Design panel open to the Layers tab. To do this, choose Windowr>Layers,
or if you're in hurry, simply press F2.

Adding a Layer

Adding a layer to the workspace of your Document window, shown in
Figure 5-1, can be done using one of the following two methods:



110 Selecting a Layer

anreeaval ayens ayers =g

File Edit Wiew lnset Modity Test Commands  Site Window  Help )

omen BWEHAEEH-H-BQB-P ad )

v hent* - & deckuaion

LalCode | G| oo Tk Lo Ooe 2Re oMl i T

i u.:: By
e
- -
. " ey -
[ e T
) Comonte ] Loesivew )
hC|8 e ¥a|n
- - - FETTT
¢ D mage
2B wie
L .
Figure 5-1: Loy > <cheiirem WG 42T o B L :
Adding a 7 rosaaties B -
il [ R |
Document — — i n .
window. 1 . N A =

b Realts 1 local dama velected tataing 115D byt

4 Choose Insert=>Layout Objects=>Layer. If there is nothing on the page
already, as in this case, a new layer appears in the upper-left corner of
your Document window.

4 Click the Draw Layer button (just to the left of the Standard button)
on the Layout category of the Insert bar. (If the Insert bar is not set to
the Layout category, click the category name and choose Layout from
the drop-down list.) Position the cross hair cursor anywhere in your
Document window and click and drag until the layer obtains the dimen-
sions you want. Release the mouse button.

® If you set a layer’s visibility to Hidden, it may be invisible in the Document

window. To see it, simply click the name of the layer in the Layers tab of the
Design panel. Now you can see the layer, even though its visibility remains
set to Hidden. See the “Changing the visibility of a layer” section, later in
this chapter, for details on Visibility settings.

Selecting a Layer

Selecting a layer enables you to identify which layer you want to affect when
executing a layer operation, such as moving or naming the layer. Use any of
the following methods to select a layer:
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4 In the Document window, click on the boundary of the layer. (Your
cursor will turn into a four-pointed arrow when you place it over a
layer boundary.)

4 In the Document window, click anywhere inside the layer while holding
down the Shift key. (Note: This won’t work if the insertion point is
already inside the layer you want to select.)

4+ In the Layers tab of the Design panel, click the name of the layer.

Selection handles appear on the boundary of the layer to indicate that you
have selected it.

Deleting a Layer

A\

Deleting a layer removes the layer, the layer’s contents, and the layer
marker from the Document window. To delete a layer, select the layer and
press the Delete or Backspace key.

Don’t delete a layer if you want to remove it from one page and add it to
another. Instead, cut the layer by choosing Edit>Cut. Open the page where
you want to add the layer and choose Edit>Paste.

Placing Objects in a Layer

To add an object to a layer, click inside the layer and follow the normal pro-
cedure for adding the object. For instance, add text to a layer by clicking
inside the layer and typing text; add other objects to a layer by clicking
inside the layer and choosing Insert> Object, where Object is the name of the
item you want to add to the layer.

Changing Layer Properties

You can change lots of properties of layers, including:

4 Background: You can add a background image or color to a layer.

4+ Name: Naming a layer can help you keep track of objects on a complex
page, and is necessary if you want to apply Behaviors to the layer.

4+ Alignment: You can align layers with each other.

4+ Visibility: Layers (and the objects on them) can be visible or invisible.
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4+ Position: Layers can be nested inside other layers; they can also be
stacked in different orders.

4 Size: You can change the layer’s height and width.

4+ Location: You can move a layer to any location on a page.

We show you how to edit each of these layer properties in the following
sections.

Including a background image or color in a layer

By default, an unnested layer does not have a color or background image,
and will just display what lies beneath it, as if it were transparent. (A nested
child layer, if it’s empty, will show the color or background image of its
parent. For more about nested layers, see the section, “Nesting Layers,”
later in this chapter.)

You can change the background of any layer by adding a background image
or color as follows:

1. Select the layer that you want to change the background of.

If the Layer Property inspector does not appear, open it by choosing
Window=>Properties.

2. In the Layer Property inspector, change one of the following:

¢ Bg Image: Click the folder to the right of the text field and browse to
select a background image from the Select Image Source dialog box
that appears. Click the Select button to accept your image choice
and close the dialog box. The path to and name of the background
image appear in the Bg Image field, and the image is added to the
background of the layer. Figure 5-2 shows a layer with a background
image.

e Bg Color: Click the color box (the little gray box with an arrow on it)
and select a color from the color palette that appears. Alternatively,
you can enter a hexadecimal number for a color in the Bg Color field.
The new color appears in the background of the selected layer.

Naming a layer

The first layer you add to a page is automatically named Layer1; the second
layer you add is named Layer2; and so on. You can change these default
number names to other names that help you more easily distinguish layers
when working with HTML and examining layers with the Layer Property
inspector or Layers tab of the Design panel.
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To name a layer using the Layers tab of the Design panel, follow these steps:
1. If the Layers tab of the Design panel is not already visible, choose
Window=>Layers or use the keyboard shortcut F2.
2. Double-click the Name column for the layer whose name you want to
change.
The current name is selected.
3. Enter a new name for the layer.
P Get in the habit of appropriately naming your layers as soon as you create

them. The name BlueprintimageMap helps you remember a layer’s content
much better than Layerl5. Remember that layer names cannot contain

spaces.

Aligning layers

Aligning layers with each other can help you precisely lay out visual content
in the Document window. You can align the top, left side, right side, or

bottom of layers.
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Figure 5-3:
Setting your
default
preferences
for layers.

To align layers, select the layers you want to align by pressing and holding
the Shift key, and then clicking each layer in the Document window. Choose
Modify=>Align and choose one of the following options from the submenu:

<+

<+

Left: Assigns the x-coordinate of the last selected layer to all selected
layers.

Right: Aligns the right side of all selected layers with the right side of
the last selected layer.

Top: Assigns the y-coordinate of the last selected layer to all selected
layers.

Bottom: Aligns the bottom of all selected layers with the bottom of the
last selected layer.

Make Same Width: Gives all the layers the same width as the last
selected layer.

Make Same Height: Gives all the layers the same height as the last
selected layer.

Changing the visibility of a layer

You

can specify whether a layer is visible or hidden when a Web page loads —

first appears in the user’s browser window — and as a result of specific
actions by the user. Visibility can change as many times as you want. Visibility
options consist of the following:

*

Default: The layer’s initial visibility is the default setting, which is visi-
ble. To edit layer default settings, choose Edit=>Preferences and the
Preferences dialog box (see Figure 5-3) appears, displaying the layer
default settings that you can change.

Shatus B
Ak

Lyt

BathQround image: [
Bt (] ot s ot it @ e
R0 tity: [7]




Changing Layer Properties 115

4+ Inherit: For a nested layer, the layer’s initial visibility is the same as the
visibility of its parent. For an unnested layer, selecting the inherit option
causes the layer to appear as visible.

4 Visible: The layer’s initial visibility setting is visible.
4 Hidden: The layer’s initial visibility is hidden.

You can use either the Layer Property inspector or the Layers tab of the
Design panel to set layer visibility. By setting layer visibility, you can create
scripts that cause images to appear (or disappear) in response to user inter-
action. For example, you can create an image of a widget that appears on a
Web page after a user clicks a link marked, Click here to see our top-of-the-

line widget!

To set the initial visibility of a layer via the Layer Property inspector, select
the layer in the Document window to open the Layer Property inspector. If
the inspector does not appear, open it by choosing Window=>Properties.
Choose a visibility option from the Vis drop-down list.

Layering layers: Setting the z-index

The z-index of a layer indicates the layer’s position in a stack of multiple
layers. Z-indices are useful when you have a handful of layers — some con-
taining transparent portions, some of different sizes — stacked one on top of
the other. Changing the z-index of your layers lets you “shuffle” the layers —
much as you shuffle a deck of cards — to create interesting visual effects.

Z-indices are measured in whole numbers and do not have to be
consecutive — for instance, you can have three layers with z-indices of

1, 3, and 7, respectively. The layer with the largest z-index sits on top of

the layer stack, and the layer with the smallest z-index sits on the bottom
of the layer stack. Layers with larger z-indices obscure those with smaller
z-indices. You can change the z-index of a layer in either the Layer Property
inspector or the Layers tab of the Design panel.

To assign the z-index of a layer by using the Layer Property inspector, follow
these steps:
1. Select the layer to open the Layer Property inspector.

If the Layer Property inspector does not appear, open it by choosing
Windowr>Properties.

2. Enter a new number in the Z-Index field of the Layer Property
inspector.
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Figure 5-4:
Changing
the z-index
of the layer
named
“SuppText.”

To assign the z-index of a layer using the Layers tab of the Design panel,
follow these steps:

1. If the Layers tab of the Design panel is not already visible, choose
Windowr>Layers or use the keyboard shortcut F2.

2. Click the Z column for the layer whose z-index you want to change.
The current z-index is selected.

3. Enter a new z-index for the layer.

The new number appears in the Z column for the selected layer, as
shown in Figure 5-4.

4. Click anywhere outside the Z column or press the Enter key.

Note that you can have multiple layers at the same z-index.
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To assign relative z-indices to layers by reordering layers in the Layers tab
of the Design panel, follow these steps:

1. Open the Layers tab of the Design panel by choosing Window->Layers
or by using the keyboard shortcut F2.

The Layers tab lists layers in order of descending z-index. Nested layers
are listed in descending order within their parent layer.

2. Click the name of a layer for which you want to change the z-index.

3. Drag the layer name into a new list position and release the mouse
button.

As you drag, the selected layer is indicated by a thick line.

Figure 5-5 shows the effect of changing a z-index. In the top image, the z-index
of the bowling pins is higher than the starry background image. As a result,
the bowling pins are on top. Conversely, in the bottom image, the starry back-
ground image has the higher z-index value, and as a result, it’s on top of the
bowling pins. Dreamweaver reorders the list in the Layers tab and renumbers
layer z-indices to reflect your change. Also, Dreamweaver updates the associ-
ated code for the layers’ z-indices in the HTML source code for your page.



Figure 5-5:
The effect
of changing
z-indices.
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Because you don’t have to number the z-index of layers consecutively, con-
sider leaving gaps between indices, in case you later want to add new layers
into the middle of the stack. For instance, use only even numbers for your
indices so that you can easily sandwich a layer with an odd-numbered
z-index in between.

Moving a layer
You may want to move a layer to another location in the Document window
or to a position relative to the grid or to other objects.

To move a layer, select the layer in the Document window and then reposi-
tion your selection by using one of the following three methods:

4 Click and drag the layer to a new location and release the mouse button.

4 Press the arrow keys you find on the numeric keypad on your keyboard
to nudge the layer up, down, left, or right one pixel at a time. If you hold
down the Shift key, every press of an arrow key moves the layer by
10 pixels.
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\\3

4+ In the Layer Property inspector, enter a new value in the T (top) and L
(left) fields to indicate the pixel coordinates of the layer’s top-left
corner.

When moving layers, you can choose to enable or prevent layer overlap,
depending on how you want the final image montage to appear. You enable
or prevent layer overlap by selecting or deselecting the Prevent Overlaps
check box in the Layers tab of the Design panel.

Resizing a layer
Resizing a layer means changing its height and width dimensions. To resize
a layer, select the layer and perform one of the following tasks:

4+ Click and drag a selection handle — one of the large dots on the layer
boundary — until the layer obtains the dimensions you desire.

4 In the Layer Property inspector, enter a new width in pixels at the W
field and a new height in pixels at the H field. If the Layer Property
inspector does not appear, open it by choosing Window=>Properties.

You can change the height and width dimensions of multiple layers at the
same time as follows:

1. Press and hold the Shift key while selecting each layer you want to
resize.

If the Multiple Layers Property inspector does not appear, open it by
choosing Window=>Properties.

2. In the Multiple Layers Property inspector, enter a new width in pixels
in the W field and a new height in pixels in the H field.

Nesting Layers

A nested layer is a layer that has all of its HTML code lying within another
layer. The nested layer is often referred to as a child layer, whereas the layer
on which it depends is called the parent layer. A child layer can be drawn
completely inside its parent (as shown in Figure 5-6), in an intersecting
arrangement with its parent, or completely unattached to its parent,
depending on the effect you want to achieve. A nested layer inherits the
same visibility of its parent and moves with the parent when the parent
layer is repositioned in the Document window. Some versions of Netscape
have issues with nested layers, so try to avoid using them if there is a sim-
pler way to accomplish the same thing.



Figure 5-6:
Alayer
nested in
another
layer.

119

Nesting Layers

o Macramedia Dreamwesver MX 7000 [l ayers Demo (demosite Tayers himi7)] Sy x|
File Edit View Insert Modify Text Commands Site Window Help
Layout ¥ Fl B B sntes | bpnded e [T ] : G- 83 "
" - ) T — -
2l Coe | sl | oy | THie: L Deme ue cm FEET ]
- Text 4
- = by 2
| | | | | . I-m 1
. | B
- Applcames
i W Tag <> "
J JET) tehaiers | Roberant 35 |
a8 )
\ = Gereral
g
[ €55/ Accessiblity
L
e L stegorieed
" e L3
[ s |
ctiodvs <o <dFLite> 747301 » 13 [ 2oec _J] 1D Domente ey (Localviem 1y
S Fropartine - EX-AER X -
\ P [ -
|:-‘:-_'] Laym © L e | W INex Pindex | 55 e . D g teme ) ?“ : l:”"::
use vl 1/ | o 2% o et v Bggske | @ rudeches
Cverllawr raagen  w | O L R : m::
' 8 no >
» Gty Bindy

Enabling nesting

To create nested layers in the Document window, you must first enable nest-

ing. To do so, follow these steps:

1. Choose Edit->Preferences to open the Preferences dialog box or use

the keyboard shortcut Ctrl+U.

Select the Nesting check box.

R N S

tab of the Design panel.

In the Preferences dialog box, select Layers in the Category area.

Click OK to close the Preferences dialog box.

In the Document window, choose Windowr>Layers to open the Layers

6. In the Layers tab, make sure that the Prevent Overlaps option is

deselected.

Creating a new nested layer

Use either of these methods to draw a nested layer after enabling nesting:

4+ Click inside an existing layer and choose Insert=>Layout Objectst>Layer.
A child layer of default size appears inside the parent layer.
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4 Select Layout Tools=>Draw Layer in the Layout category of the Insert
bar. Then click and drag your mouse in the parent layer, releasing the
mouse button when the layer has reached the dimensions you desire.

If the dimensions of the parent layer are smaller than the dimensions of the
child layer, the child layer will exceed the boundaries of the parent.

Nesting an existing layer
To change the nesting of an existing layer, follow these steps:
1. Open the Layers tab of the Design panel by choosing Windowr>Layers
or using the keyboard shortcut F2.

2. In the Layers tab of the Design panel, press and hold the Ctrl key
while using the mouse to click and drag the intended child layer on
top of its new parent.

The child is in the correct position when you see a box appear around
the name of its intended parent layer.

3. Release the mouse button.
The new child-parent relationship is shown in the Layers tab of the
Design panel.

Dreamweaver draws the new child layer and updates the associated code
for changed layer-nesting in the HTML source code for your page.

Collapsing or expanding your view in the Layers tab

You can change how you view the names of nested layers in the Layers tab
of the Design panel by collapsing or expanding your view:

4+ To collapse your view: Click the minus sign (<) in front of a parent layer.
Names of nested child layers for that parent are hidden.

4+ To expand your view: Click the plus sign (+) in front of a parent layer.
Names of nested child layers appear underneath that parent layer.



Chapter 6: Using ColdFusion
MX 6.1 Developer Edition in
Dreamweaver MX 2004

In This Chapter

v+~ Exploring how ColdFusion is integrated into Dreamweaver
v Using the Tag Editor and the Insert panel

v+ Viewing database connections

v+~ Using the Bindings tabs to get dynamic data

v~ Taking a brief look at Server behaviors and components

0 ne of the biggest changes that came with the previous version of

Macromedia Studio was the integration of ColdFusion MX into
Dreamweaver MX. For years, the two products had a symbiotic relationship,
and as a result, their integration was an exceptionally smooth one.
Dreamweaver was always better than ColdFusion as a graphical HTML
editor. ColdFusion and its sister product, Macromedia HomeSite, were the
better choices for the HTML editor who preferred a coder-friendly interface.
This chapter provides the lowdown on the features in Dreamweaver that
bring ColdFusion to life.

M This chapter only covers the ColdFusion features that are available in

Dreamweaver. For a complete run-down of ColdFusion and how it works,

check out Book VL.

Understanding the Integration of
ColdFusion and Dreamweaver

Before the MX version, Dreamweaver was largely geared toward the basics
of HTML editing, such as creating and editing tables, graphics placement,
text editing, and some basic site management tools. With the integration of
ColdFusion, Dreamweaver became more robust, with a host of features that
could make your site more dynamic.
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Before Dreamweaver MX arrived, ColdFusion was made up of three
components:

4+ A Web-based application server that read HTML and ColdFusion code
and generated HTML for a browser to view.

4 A scripting language that enabled users to perform a number of
dynamic functions, such as querying databases and personalizing Web
pages based on user input.

4 A stand-alone development tool (ColdFusion Studio) that was used to
create ColdFusion code and manage some parts of the application
server.

In the previous version of Dreamweaver, ColdFusion Studio was simply
integrated into the Dreamweaver interface. This resulted in a single
product that incorporates both the WYSIWYG (What You See Is What
You Get) interface that Dreamweaver users are accustomed to and the
more developer-friendly ColdFusion Studio code environment. The other
elements of ColdFusion remained largely the same.

In Dreamweaver, you can find ColdFusion features in the following areas:

4 Code view: Select Code view by choosing Viewr>Code. This is the devel-
opment view that was traditionally associated with ColdFusion Studio.
Figure 6-1 shows both the view from ColdFusion Studio 5 and the Code
view in Dreamweaver MX 2004. You can see that a lot of the physical
features look the same.

4+ Insert bar: If you've used the previous version of Dreamweaver, you'll
notice a major interface change in the Insert function in Dreamweaver
MX 2004. In the previous version, there was an Insert panel that utilized
tabs to jump from section to section. In Dreamweaver MX 2004, when
you click the name at the far left on the Insert bar, a listing of all the
available sections (what Macromedia calls “categories”) pops up. Scroll
up or down and select a name to see the buttons in that category of the
Insert bar. You find ColdFusion-specific functions in the Common, CFML,
and Application categories.

4+ Application panel: To bring up the Application panel, choose Window,
and then any of the following: Database, Bindings, Server Behaviors,
or Components. This brings up the Application panel with the appropri-
ate tab selected. Within the Application panel, you can configure data-
bases, set up links to your remote site, and create ColdFusion
components.
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12 4 Using Features on the Insert Bar

4 Code panel: The Code panel, not to be confused with Code view, pro-
vides some valuable reference information about your code. (The Code
panel is shown in Figure 6-2.) You can bring up the panel by choosing
either Snippets or Reference from the Window menu:

¢ Snippets tab: With the Snippets tab, you can create reusable chunks
(snippets) of code.

¢ Reference tab: The Reference tab gives you access to O’Reilly’s ref-
erence guides to HTML, Javascript, and more, as well as guides to
ColdFusion, ASP, and JSP.
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Figure 6-2: T2
The Code -
panel. < >
=8 Fa
P In previous versions of Dreamweaver, Code view also included a

Tag Inspector, which reviewed the quality of your HTML code. That function
is still there, though in Dreamweaver MX 2004, this feature has been given its
own floating panel. You can still get to it by selecting Windowr>Code
Inspector.

Using Features on the Insert Bar

When you have a ColdFusion page open, the Insert bar gives you access to a
number of ColdFusion features, and using those ColdFusion features is
pretty straightforward. Almost all the features include a Help button to
explain to you precisely what the feature does.

To insert a ColdFusion feature, you follow these steps:
1. Select the category in the Insert bar for the element you want to

insert.

You can choose from three ColdFusion categories: Common, CFML
(ColdFusion Markup Language), and Application. The other categories
are for regular Dreamweaver features.



Figure 6-3:
The Cfquery
dialog box.
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2. Click the icon of the feature you want to insert.

If the feature has parameters that need to be set, a dialog box will
appear that allows you to set all the parameters for the selected feature.
Figure 6-3 shows a dialog box for a Cfquery tag (with Cfquery, you can
retrieve information from a database). For more information on how to
use all these features, check out Book VI.
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If you move your mouse over an icon and keep it there, the name of the
feature appears over the icon, allowing you to see what function that
icon serves.

3. Enter all the pertinent information in the dialog box for the element
that you selected in Step 2.

Again, the information you must enter varies, depending on which tags
or elements you selected.

4. Click OK to insert the element.

In Dreamweaver MX 2004, the ColdFusion commands have been consolidated
from five tabs in the Insert panel to just three categories on the Insert bar.
The Common category includes a Tag Chooser button, from which you can
select ColdFusion CFML tags. Beyond that, all the ColdFusion features are
either in the CFML or the Application categories on the Insert bar.

The CFML category includes access to the largest number of CFML tags and
functions. Note that the last two icons on this category are entitled Flow
and Advanced. This is where buttons from the old CFML Flow and CFML
Advanced tabs landed. If you click these icons, you get pop-up menus,
shown in Figure 6-4, which reveal a number of other functions that you can
include in your documents. Here’s a complete listing of the buttons in the
CFML category:
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Figure 6-4:
The Flow
and
Advanced
pop-up
menus.
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I:': More Tags
4+ Server variables: Creates server variables
4+ cfquery: Creates a <CFQUERY> tag
4 cfoutput: Creates a <CFOUTPUT> tag
4+ cfinsert: Creates a <CFINSERT> tag
4+ cfupdate: Creates a <CFUPDATE> tag
4 cfinclude: Creates a <CFINCLUDE> tag
4 cflocation: Creates a <CFLOCATION> tag
4+ cfset: Sets the value of a variable
4+ cfparam: Creates a parameter
4 Comment: Creates the comment arrows
4 Surround with #: Surrounds the selected text with # signs
4+ cfscript: Creates a <CFSCRIPT> tag into which you can put ColdFusion

Script

Click the Flow icon to access to the following features:

<+

RIS

cftry: Creates a <CFTRY> tag
cfcatch: Creates a <CFCATCH> tag
cfthrow: Creates a <CFTHROW> tag
cflock: Creates a <CFLOCK> tag
cfswitch: Creates a <CFSWITCH> tag
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cfcase: Creates a <CFCASE> tag

cfdefaultcase: Creates a <CFDEFAULTCASE> tag
cfif: Creates a <CFIF> tag

cfelse: Creates a <CFELSE> tag

cfelseif: Creates a <CFELSEIF> tag

cfloop: Creates a <CFLOOP> tag

cfbreak: Creates a <CFBREAK> tag

Click the Advanced icon to access the following features:

<+

R IR IR IR R R R R R TR R R A e

+ 4+

cfcookie: Enables you to specify the parameters of creating a cookie
cfcontent: Enables you to specify how to create a content tag
ctheader: Enables you to specify the parameters of creating a header
ColdFusion Page Encoding: Sets your page encoding information
cfapplication: Enables you to specify your application parameters
cferror: Specifies error information

cfdirectory: Allows you to work with directories (create, delete, list,
and so on)

cffile: Enables you to work with files (create, append, write, and so on)
cfmail: Specifies how to send mail through ColdFusion

cfpop: Specifies how to send messages through a POP server

cfhttp: Specifies how to make an HTTP request

cfhttpparam: Specifies how to set parameters for an HTTP request
cfldap: Specifies how you can access an LDAP store

cfftp: Specifies how to make an FTP request

cfsearch: Builds you an interface to Verity to make searches

cfindex: Builds you an interface to index a Verity search collection

cfimport: Allows you to import a custom CF tag library or a JSP tag
library

cfmodule: Allows you to specify a module
cfobject: Enables you to call a component
cfchart: Specifies how to use ColdFusion’s charting features

More Tags: Brings up the Tag Chooser dialog box

Book Il
Chapter 6
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Figure 6-5 shows the Application category of the Insert bar in Dreamweaver,
which allows you to access the following ColdFusion features:

Figure 6-5:
Getting
atthe Apphcaton v (5 @ L - | - B E- 0N &
Application

features.

4+ Recordset: Allows you to connect to a database and retrieve data from
that database and creates the <CFQUERY > tag for you

4 Stored Procedure: Allows you to execute a stored procedure against an
SQL database and specify parameters to be passed as part of that call

4+ Dynamic Data: Creates either dynamic text or a table, or populates vari-
ous form elements with data from a database

4+ Repeated Region: Enables you to create a repeated region

4+ Show Region: Enables you to show or not show a specific area of content
based on a set of criteria

4+ Recordset Paging: Creates dynamic page-scrolling arrows for a
recordset

<+

Display Record Count: Shows how many records you have from a
given query — first, last, and total number

Master Detail Page Set: Creates a master detail page
Insert Record: Creates a form to insert a database record
Update Record: Creates a form to update a database record

Delete Record: Creates a form to delete a database record

AR R R

User Authentication: Provides a series of tools to log a user in or out,
or to restrict access to a page

Editing a Tag

After you've inserted a tag into your ColdFusion code, you may need to edit
that tag. You can edit the code directly, or you can use the Tag Editor, which
provides a cleaner way to see all the parameters for your tag. (NVote: Not all
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tags have this option. If you don’t see Edit Tag in Step 3, then you know the
tag you're working with doesn’t support this feature.) To use the Tag Editor,
follow these steps:

1. If necessary, switch to the Code view in the Document window by
choosing View=>Code.

2. Place your cursor anywhere in the opening tag you want to edit.
3. Right-click and choose Edit Tag from the contextual menu.
The Edit Tag dialog box appears.

4. Change the value in the dialog box, and then click OK to update

the tag. Book Il

Chapter 6
The value changes, depending on which tag you're editing.

Getting Data from a Database

You can set up a database connection using the ColdFusion Administrator,
as described in Book VI, Chapter 6. Using the Dreamweaver interface, how-
ever, you can look directly into a database to see the tables and columns
that make up a database when you're in Code view. More importantly, you
can then easily add those tables and columns to your ColdFusion code
simply by dragging them onto the screen. Here’s how:

uonip3 1adojanaq
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1. Open the Application panel to the Databases tab by choosing
Window=>Database.

You see a list of the databases on your testing server. For this example,
we use the Companylnfo database, one of the sample databases that
comes with ColdFusion.

2. Click the plus (+) button next to the CompanyInfo database.

This shows you the views, tables, and stored procedures for the
database.

3. Expand the Employee table by clicking the plus (+) buttons next to
the first Tables and then the Employee table.

All the columns in the table should now be visible, as shown in Figure 6-6.

4. Click and drag the LastName column from the panel onto the work
area.

You see that this adds the column name to the work area.
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Figure 6-6:
The
Employee
table.

NG/
Q‘“\ !

For the feature described in the previous steps to work, you need to have an
active testing server configured, and you need to know the Remote Data
Services password for your testing server. Check out Book VI, Chapter 2 for
more information.

Now, by itself, this doesn’t really accomplish a whole lot. All you've really
done is drag a column name onto your work area. To really see it in action,
try adding the following code text to your page, in between the <BODY> tags:

<CFQUERY name="DatabaseTest" datasource="CompanyInfo">
select LastName from Employee
</CFQUERY>

<CFOUTPUT query="DatabaseTest">
#lastnameff<BR>
</CFOUTPUT>

Now, press the F12 key to preview the page in a Web browser, and you see a
whole list of last names, as shown in Figure 6-7. If you’d like, try adding
some other fields in the code between select and from, making sure that
the fields are all separated by commas. If you then add the field name to
CFOUTPUT, surrounded by pound signs (#), you see those fields displayed as
well. For more information on accessing data from a database using
ColdFusion, check out Book VI, Chapter 3.
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Figure 6-7:

Getting last
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a database.
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Using the Bindings Tab

The Bindings tab of the Application panel provides another interface to data
sources, and for someone unaccustomed to working with ColdFusion, it is an
easy way to begin to understand CFML. Binding, in the Dreamweaver vernac-
ular, is just a link between the page and some other datasource that provides
data to the page. With this interface, you can build the same query we used
in the example in the previous section, “Getting Data from a Database,” as
follows:

1. Press Ctrl+N; in the New Page dialog box that appears, select
Dynamic Page and ColdFusion, and then click the Create button.
This creates a new ColdFusion document.

2. Save the document into a site that has a remote server configured to
see the sample ColdFusion databases.

3. Switch to the Bindings tab by choosing Window+>Bindings.

4. Click the plus (+) button and select Recordset (Query) from the drop-
down list.

The Recordset dialog box, shown in Figure 6-8, appears.

5. Type a name, such as DatabaseTest, into the Name field.
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6. Select Companylnfo from the Data Source drop-down list.

10.

11.

You may also need to input the username and password for the testing
server. If you configured the remote testing server, then you should
know the username and password. If not, then you may need to check
with your organization’s database administrator.

Select the Employee table from the Table drop-down list.

Select the radio button labeled Selected from the Columns option,
and choose LastName from the scroll list (it will show up when you
select the radio button).

Leave the Filter and Sort fields set to None.

These two tools, which you should try as you get more comfortable
with using the Bindings tab, allow you to further refine and sort the data
from the Employee table.

Click OK to add the Binding.

Dreamweaver adds a new record in the Bindings tab and the following
code to the Code view:

<CFQUERY name="DatabaseTest" datasource="CompanyInfo">
SELECT LastName FROM Employee
</CFQUERY>

This code tells the server to get all the last names from the Employee
table in the Companylnfo database. When the page is read, this query
retrieves the data and makes it available to be output.

To make the last names output when the page is loaded, click and
drag the LastName lightning bolt icon from the Bindings tab on the
Application panel to the Document window.
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Dreamweaver creates the following code and adds it to your workspace:

<CFOUTPUT query="DatabaseTest">
{#fDatabaseTest.LastName
</CFOUTPUT>

This tells ColdFusion to display the LastNames (all of them) when the
page is loaded.

12. Press F12 to preview the page.

When the page loads, you'll notice that the names are output one right

after another without anything in between them. You can add a line

break (<BR>) or a comma after #fDatabaseTest.LastNamef, and

ColdFusion will add the comma or line break after every record. Book If

Chapter 6

Queries are only one kind of Binding that Dreamweaver supports. You can
see all the others when you click the plus (+) button on the Bindings tab. As
you become more familiar with ColdFusion, you’ll no doubt want to use
some of these other kinds of Bindings, notably the Stored Procedure and the
Form, Session, Client, and Application variables.
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Introducing Server Behaviors and Components

The Server Behavior and Components tabs in the Application panel are
similar in both design and concept to the Bindings panel. The following
sections cover them only cursorily, because to use these tools to their

fullest extent, you need an advanced working knowledge of ColdFusion
and code development.

Understanding server behaviors

Server behaviors are code elements that make a request to the ColdFusion
Server and receive some sort of data in return. If that sounds similar to the
preceding Bindings example, it is! You can do that Recordset example from
the earlier section, “Using the Bindings Tab,” in the Server Behaviors tab.
However, a number of more advanced server behaviors are beyond simple
queries that you can do from this tab. Table 6-1 describes each of the server
behaviors that Dreamweaver offers.

Table 6-1 Server Behaviors

Name Function

Recordset Makes a query to a data source

Stored Procedure Passes information to a Stored Procedure
CFParam Builds a <CFPARAM> tag

(continued)
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Table 6-1 (continued)

Name Function

Repeat Region Allows you to create a repeated region

Recordset Paging Creates forward, backward, first, and last links for a recordset

Show Region Shows a region of content based on preset conditions

Display Record Count Displays the record count for a recordset

Dynamic Text Displays dynamic text based on a query

Insert Record Inserts a record through a form

Update Record Updates a record through a form

Delete Record Deletes a record through a form

Dynamic Form Elements  Creates form elements based on a corresponding query and
recordset

User Authentication Creates all the code necessary to add user authentication to
a site

Considering components

Components are reusable bits of ColdFusion code that can be used through-
out your Dreamweaver Site. Dreamweaver comes with a number of sample
components to show you how they work. In practical terms, though, you
create your own components based on the needs of your site.

Suppose that you're building a site that sells boxes online, and you have a
tool that calculates the volume of the various types of boxes that you sell.
Because it’s used globally by the site, this tool shouldn’t be repeated in
every single ColdFusion page. Instead, it should be in an area where all
pages can access it and just pass along the value obtained by performing a
calculation. If you built it as a component, this calculator could be accessed
anywhere, and if there are ever any changes to the tool (say you changed
from cubic feet to cubic meters), you'd only need to make the change once,
instead of many times.

The Components tab provides developers with a framework for building
these kinds of tools. From this tab, you can specify the following for a new
component:

4 General information about the component (such as its name and where
it’s located)

<+

Properties of the component (queries, arrays, strings, and so on)

<+

The functions associated with the component

4 The arguments (data) the component will accept from another page or
form



Chapter 7: Advanced Web Page
Design Techniques

In This Chapter

v Creating hotspots

v+ Adding Flash text and button rollovers

v+~ Adding a rollover behavior to an image
+ Creating a navigation bar

v~ Inserting audio and video into your pages
v+~ Using templates

v Validating your code

In previous chapters of Book II, we focus on providing a good working
knowledge of Dreamweaver MX 2004. Now we need to spend some time
looking at the more advanced uses of Dreamweaver in Web development. In
this chapter, we show you how to make images a bit more striking and how
you can bring some other multimedia elements to life.

Creating Clickable Image Maps with Hotspots

You can designate certain areas of an image as hotspots — active areas that
a user can click to open a link to another Web page or activate some other
behavior. Hotspots can be shaped like rectangles, circles, or polygons (irreg-
ular objects). The coordinates of the hotspots are grouped into chunks of
HTML code called image maps.

Creating a hotspot

Check out Figure 7-1. It shows a typical navigation bar for a site as a single
JPEG image. The following procedure shows you how to create an image
map for part of that image by adding hotspots:

1. Select the image to which you want to add a hotspot.

The Image Property inspector appears. If the bottom half of the Image
Property inspector is not visible, click the Expander button, which is
the down arrow in the bottom-right corner.
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Figure 7-1:
Atypical
JPEG | 0 show  Accessories  Cloning 4
navigation

image.

2. In the Map area of the Image Property inspector, click the Hotspot
button for the shape you want to draw.

You can choose a rectangle, a circle, or a polygon. Your mouse pointer
becomes a cross hair cursor when you move it over the image.

3. Draw the hotspot according to the shape you select:

¢ Circle or rectangle: Click your cross hair cursor on the image and
drag diagonally to create a hotspot. Release the mouse button
when the hotspot reaches your desired dimensions. The area you
draw is highlighted light blue, and the Hotspot Property inspector
appears.

¢ Polygon: Click your cross hair cursor on the image once for each
point. The area you draw is highlighted light blue, and the Hotspot
Property inspector appears.

4. In the Hotspot Property inspector, supply the following information:
e Map: Enter a unique name for the image map.

¢ Link: Enter a URL or the name of an HTML file you want to open
when the user clicks the hotspot. Alternatively, you can click the
folder icon and browse to select the link from your files. Note:
Completing this field is optional. Instead, you may choose to attach
a behavior to the hotspot.

e Behaviors: To attach a behavior other than a link to the hotspot,
open the Behaviors tab of the Tag panel by choosing Window=>
Behaviors or by using the keyboard shortcut Shift+F3. Then click the
Add (+) button in the Behaviors panel, which opens a pop-up menu
of available behaviors, including Check Plugin, Play Sound, Popup
Message, Preload Images, and many others. Choose a behavior from
the pop-up menu, complete the information in the dialog box that
appears for your selected behavior, and click OK.

e Target: Complete this field if you entered a link in the Link field, and
you want the link to open in a window or frame other than the one
you’re linking from. Click the arrow and select from the drop-down
list a target window where you want your selected link to appear.
You can select from the following choices: _blank (opens the link
in a new window), _parent (opens the link in the parent of the
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currently opened window; if the currently opened window was
opened from another frame, the link will open in that frame), _self
(the default; opens the link in the currently opened window; not
selecting a Target produces the same effect), and _top (opens the
link in the top-level window, replacing frames, if any). If you have
created frames, you can also select a frame name from this list. (See
Book II, Chapter 4 for more information about frames.)

e Alt: Enter the text you want to show when the user moves the
mouse pointer over the hotspot. Alt text also makes information
about the hotspot accessible to vision-impaired users.

Modifying a hotspot

If you need to change the size or shape of a hotspot after you've created it,
or you need to change the link, target, or Alt information for the hotspot,
use the following procedure to edit the hotspot:

1. On an image in the Document window, click the hotspot you want to
modify.

The Hotspot Property inspector appears. If the inspector does not
appear, open it by choosing Window=>Properties.

2. Edit the Link, Target, or Alt information you want to change in the
Hotspot Property inspector.

3. If you want to reshape or resize the hotspot, select the Arrow tool in
the Hotspot Property inspector, and then click any handle of the
selected hotspot and drag the handle to a new location.

4. If you want to reposition the hotspot, select the Arrow tool in the
Hotspot Property inspector, and then click anywhere within the
hotspot and drag it to a new location.

5. You can delete a hotspot by selecting it and pressing the Delete key
on your keyboard.

Adding Flash Text Rollovers

A text rollover is text that changes color when users move their mouse
pointer over it. (One color appears to “roll over” to the next color.) One way
to create text rollovers in Dreamweaver is by adding Flash text to your
pages, as described in the following section.

Flash text and Flash buttons are so called because Dreamweaver implements
these features using the same code that Macromedia Flash MX 2004 (the ani-
mation program included in the Macromedia Studio MX 2004 suite) uses.
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Adding Flash text

To add hyperlinked Flash text that changes color when users roll their
mouse over it, follow these steps:

1. Click in the Document window where you want to add Flash text.

2. Choose Insert->Mediar>Flash Text.

Your page must be saved before you can insert Flash text. If the page
hasn’t been saved at least once, an alert pops up to remind you to save
the page so you can insert the Flash text.

3. In the Insert Flash Text dialog box, shown in Figure 7-2, select a font
from the Font drop-down list.

Insert Flash Towt | |
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dialog box.

4. Enter a point size for your text in the Size text field.

5. 1f you want, you can also format the text.

You can click the Bold button and/or Italics button. You can also click
an alignment button. Alignment choices are Left, Center, and Right.

6. Select a Color (initial color) and a Rollover Color (color the text
changes to when users move their mouse pointer over it) by clicking
the color swatch in each area and selecting a color from the color
palette that appears.

7. Enter your text in the Text field. Select the Show Font option if you

want to view the characters in the Text field in your selected font.
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8. In the Link field, enter a URL or the name of the page you want to
appear when the user clicks the Flash text.

Alternatively, you can click the Browse button to select a page from
your files.

9. In the Target area, click the arrow and select from the drop-down list
a target window where the linked page will appear.

If you have created frames, you can select a frame name from this list,
or you can select from the following choices:

e _blank: Opens the link in a new window.
e parent: Opens the link in the parent of the currently opened window.

e self:Opens the link in the currently opened window; this is the
default. Leaving the Target area empty produces the same result.

e _top: Opens the link in the top-level window, replacing frames, if any.

10. Select a Background color by clicking the Bg Color swatch and select-
ing a color from the color palette that appears, or type in a hexadeci-
mal number.

Your Flash text appears over the background color you choose.

11. Enter a name for your Flash text component in the Save As field or
click the Browse button to select a name from your files.

You must save Flash text with an . swf extension.

12. Click OK to create your Flash text and close the dialog box.

P To preview the rollover effect of your Flash text, select the Flash object in
the Document window to open the Flash Text Property inspector. In the
Property inspector, click the Play button to view your Flash text as it will
appear in the browser window. Click the Stop button when you’re done.

Changing Flash text

You can change an existing Flash text object by simply double-clicking the
object in the Document window, or by clicking the object, and then clicking
the Edit button in the Property inspector. Doing so opens the Insert Flash
Text dialog box, where you can change various attributes of the object as we
describe in the previous section.

Adding Flash Button Rollovers

Buttons that change appearance when users move their mouse pointer over
them — called button rollovers — are so popular that Dreamweaver gives
you a way to create them quickly and easily as Flash movies. To find out
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how to create button rollovers using images and behaviors instead of Flash
button rollovers, see the “Inserting Image Rollovers” section, later in this
chapter. (Book IlI, Chapter 5 describes how to make rollovers in Fireworks
MX 2004 using images and behaviors.)

Adding a Flash button

To add a Flash button, follow these steps:

1.
2.

Click in the Document window where you want to add a Flash button.

Choose Insert->Media=>Flash Button to open the Insert Flash Button
dialog box, as shown in Figure 7-3.

Your page must be saved before you can insert a Flash button. If the
page hasn’t been saved at least once, an alert pops up to remind you to
save the page so you can insert the Flash button.
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3. In the Insert Flash Button dialog box, scroll through the button selec-
tions in the Style list and click to select a style.
You can preview the style in the Sample area of the dialog box — just
point to the sample with your mouse to see the Flash button in action.
P You can get new Flash buttons on the Macromedia Dreamweaver MX 2004

Web site by clicking the Get More Styles button in the Insert Flash Button
dialog box. A Web page on Macromedia’s site opens in your browser.
Select the Flash Media option from the Categories drop-down list and
scroll through the results as needed.
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4. If your selected button has a placeholder for text, enter the text that
you want to appear on the button in the Button Text field.

Text centers within the button automatically. Button size is fixed, though,
so you must make sure your text is brief enough to fit on the button.

5. Select a font for your Flash button text from the Font drop-down list.

S

Enter a point size for your text in the Size field.

7. In the Link field, enter a URL or the name for the page that you want
to appear when the user clicks the Flash button.

Alternatively, you can click the Browse button to select a page from
your files.

8. From the Target drop-down list, select a target window where the
linked page will appear.

If you have created frames, you can select a frame name from this list,
or you can select from the following choices:

e Dblank: Opens the link in a new window.

e parent: Opens the link in the parent of the currently opened
window.

e _self:Opens the link in the currently opened window; this is the
default. Leaving the Target area empty produces the same result.

e _top: Opens the link in the top-level window, replacing frames,
if any.
9. Select a Background color by clicking the Bg Color swatch and select-
ing a color from the color palette that appears.

Alternatively, you can enter a hexadecimal color code in the Bg Color
field.

Your Flash button displays with the background color you select.

10. Enter a name for your Flash button in the Save As field or click the
Browse button to select a name from your files.

The Flash button filename requires an . swf extension. Dreamweaver
will add the extension automatically if you don’t enter it.

11. Click OK to create your Flash button and close the dialog box.

To see what a Flash button looks like in action, select the button in the
Document window to open the Flash Button Property inspector. In the
Property inspector, click the Play button to view your Flash button as it
appears in the browser window. Click the Stop button when you finish.

sanbiuyaa) ubisaq
abed qap
pasueapy
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Changing a Flash button

To change an existing Flash button object, simply double-click the object in
the Document window, or click the object, and then click the Edit button in
the Property inspector. Doing so opens the Insert Flash Button dialog box,
where you can change your button as we describe in the previous section.

Inserting Image Rollovers
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An image rollover (often just referred to as a rollover) is a behavior that
changes an image whenever users move their mouse pointer over the
image. Rollovers add interactivity to a Web page by helping users to see
what parts of the page are links to other Web pages.

A rollover is actually two images — one for normal display on a page (the
original image) and one that is slightly modified for display when the image
is rolled over (the rollover image). You can modify an image by changing
the color or position, adding a glow or a shadow, or you can add another
graphic — such as a dog changing from sleeping to wide-awake. For a
rollover to work best, the normal and rollover states of the image should
share the same width and height.

As with all images, you can’t create the original image or the rollover image
directly in Dreamweaver; you must use an image-editing program, such as
Fireworks, to generate the images.

Insert a rollover by following these steps:

1. Click inside the Document window where you want to insert the
image rollover.

2. On the Common category of the Insert bar, click and hold the Image
button and select Rollover Image from the pop-up menu.

The Insert Rollover Image dialog box appears, as shown in Figure 7-4.
Alternatively, you can select Insert=>Image Objects=>Rollover Image.

3. In the Insert Rollover Image dialog box, enter a unique name for the
rollover in the Image Name field, making sure there are no spaces in
the name.

The rollover is referred to by this name in the HTML page code. Keep
in mind that this rollover name refers to the combined original image/
rollover image pair.

4. Enter the name of the original image file in the Original Image field
or click the Browse button to select an image from your files.

The original image appears on the page when the user’s mouse pointer
is not over the image.
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5. Enter the name of the rollover image file in the Rollover Image field
or click the Browse button to select an image from your files.

The rollover image appears on the page when the user’s mouse pointer
is over the image.

6. Select the Preload Rollover Image check box.

This feature makes the rollover action appear without delay to users as
they move the mouse pointer over the original image. It is selected by
default.

7. Enter Alternate text for the image to make it accessible to vision-
impaired visitors to your site.

This step is optional but recommended.

8. If you want to make the rollover image a link, enter a URL of the page
in the When Clicked, Go to URL text field.

Alternatively, you can click the Browse button to select a page from
your files.

9. Click OK to accept your choices and close the dialog box.

To check the rollover, preview your page in a browser by choosing Filer>
Preview in Browser or by clicking the Preview in Browser button, and then
use your mouse to point to the original image. You can also press F12 to
preview in the default preview browser. If you haven’t set a default preview
browser, you will have to do so using the Preview in Browser category in
Dreamweaver’s Preferences dialog box. See Dreamweaver’s help documenta-
tion for details.

Setting Up a Navigation Bar

A navigation bar is a group of buttons that users can access to move
throughout your Web site. Buttons within a navigation bar may present
users with options, such as moving backwards, moving forwards, returning
to the home page, or jumping to specific pages within the site.
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Each button in a navigation bar possesses properties similar to a rollover in
that the button changes state — or appears differently — based on where
the user is positioning the mouse pointer. However, a navigation bar button
can possess as many as four different states:

4+ Up: The original state of the button

4 Over: How the button appears when a user moves their mouse pointer
over it

<+

Down: How the button appears as a user is clicking it

4 Over While Down: How the button appears when the user moves
their mouse pointer over it after clicking it and arriving on the page it
represents

A navigation bar differs from individual rollovers in that clicking a naviga-
tion bar button in the Down state causes all other buttons in the bar to
revert to the Up state.

To create a navigation bar, just follow these steps:

1. Select the Navigation Bar button from the Common category of the
Insert bar or choose Insert>Image Objects->Navigation Bar.

Whichever method you choose, the Insert Navigation Bar dialog box
appears, as shown in Figure 7-5.
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2. In the Insert Navigation Bar dialog box, enter a name for the first
button in the Element Name field.

The new button appears in the Nav Bar Elements field. Don’t use spaces
in the naming of any of these elements.
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10.

11.

12.

Setting Up a Navigation Bar ’45

For each state of the button — Up Image, Over Image, Down Image,
and Over While Down Image — enter the name of the image file that
you want to use in the associated field.

Alternatively, you can click the Browse button for each field and select
an image from your files. You must supply the Up Image. All other states
are optional and can be left blank.

You don’t need to use all four navigation bar button states — creating
only Up and Down states works just fine.

Enter Alternate text for the image to make it accessible to vision-
impaired visitors to your site.

This step is optional but recommended.

In the When Clicked, Go to URL text field, enter a URL or the name for
the page you want to appear when the user clicks the navigation bar
button.

Alternatively, you can click the Browse button to select a page from
your files.

From the In drop-down list, select a target window where you want
the linked page to appear.

If you aren’t using frames, the only option is to use the Main window.
Click the Add Item (+) button to add another navigation bar button.
Repeat Steps 2 through 6 to format the new button.

Note: You can remove any button already created by clicking its name in
the Nav Bar Elements field and clicking the Remove Item (-) button. You
can also reorder the sequence of the buttons as they will appear on the
page by clicking a button name in the Nav Bar Elements field and click-
ing the up or down arrow button.

In the Options area, select the Preload Images check box if you want the
rollover effects to appear without delay when the user triggers them.

To set the current button to appear in the Down state when the user
first sees the navigation bar (which you might do to indicate the cur-
rent page is the one represented by the button), select the Show
“Down Image” Initially check box in the Options area.

The Over While Down state works in combination with this option.

Select Horizontally or Vertically from the Insert drop-down list to
position the navigation bar horizontally or vertically.

To set up the button images in a table format, select the Use Tables
check box.

This option is checked by default.
Click OK to accept your choices and close the dialog box.
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To check the navigation bar, you must preview your page in a browser.
Choose Filew>Preview in Browser or click the Preview in Browser button and
use your mouse to point to the buttons.

To change elements of an existing navigation bar, choose Modify=>Navigation
Bar. The Modify Navigation Bar dialog box is nearly identical to the Insert
Navigation Bar dialog box shown in Figure 7-5, except that you can no longer
change the orientation of the bar or access the Use Tables check box.

Adding Audio and Uideo to Your Pages
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You have two basic options, which are described in detail in the following
sections, for adding downloadable audio and video to your Web pages:

4+ Embedding: You can embed an audio or video file to display a playback
console on a Web page that users can use to play, rewind, and fast-
forward the media file. (You can also embed an audio file and make it
invisible to create a background audio effect.)

Users must have an appropriate plug-in installed on their machines to
play the embedded audio or video file. To ensure maximum compatibility,
you may wish to use SWFs to present audio and video.

4+ Linking: You can link to an audio or video file to give users the choice of
whether or not to view that media file.

Keep in mind that most audio and video files are large — large enough that
many folks impatiently click the Stop button on their browsers before a Web
page chock-full of audio or video effects has a chance to finish loading. Keep
the following basic rules in mind to help you use audio and video effectively
in your Web pages:

4 Use audio and video only when plain text just won’t do.

4+ Keep your audio and video clips as short (and corresponding file sizes
as small) as possible.

Embedding an audio or video clip
You can embed an audio or video file by following these steps:

1. In the Document window, click the location in your page where you
want to add an embedded audio or video file.



Figure 7-6:
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Click and hold the Media button in the Media category of the Insert bar
and select Plugin from the pop-up menu, or choose Insert->Media=>
Plugin.

The Select File dialog box, shown in Figure 7-6, appears.

Select File o
Seboct bie e Rers (<) Flie oyitem Shas and Serve

C) Data sousest
Look s | o =ik O F (A

Al svaktn - § want my mumsy,=p3

File rvivnnr rreibe 1 mant sy Sumey =od [ o |

Filescflyee: &Pl w Cancel

UL

modia/vveke - | wart sy musmy =p ¥ anarmgmen:

A\

3. In the File Name field in the Select File dialog box, enter the path or

browse to the audio or video file that you want to embed and click OK.

If the file is outside your current root directory, Dreamweaver asks
whether you want to copy the file to your site’s root directory. Click Yes.

In the Plugin Property inspector, size the Plugin placeholder to any
dimensions you prefer.

You can either enter a width and height in the W and H text fields in the
Plugin Property inspector, or you can drag a handle on the placeholder
to manually resize.

Test in all your target browsers (the browsers your users are likely to
view your site with) to ensure that users can view all the audio playback
controls or video area and controls.

You can click the Play button in the Plugin Property inspector to play your
media file without previewing your page in a browser.

Embedding background music

Embedding background music (music that plays automatically after the user
opens a page) in your page can be controversial because users may be
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unpleasantly surprised by audio when they are expecting silence, and
because users have no way to turn off the music from within the browser. If
you still want to embed background music in your page, follow these steps:

1.

9.

In the Document window, click the location in your page where you
want to add an embedded audio file.

This should be an out-of-the-way location, like the bottom of your page,
so the embedded audio doesn’t create an awkward space in your design.

Click and hold the Media button in the Media category of the Insert
bar and select Plugin from the pop-up menu, or choose Insert=>
Media~>Plugin.

The Select File dialog box appears.

In the File Name field in the Select File dialog box, enter the path to
the audio file that you want to embed and click OK.

If the file is outside your current root directory, Dreamweaver asks
whether you want to copy the file to your site root. Click Yes.

Enter a width and height of 2 in the W and H text fields in the Plugin
Property inspector.

Click the Parameters button to open the Parameters dialog box.

In the Parameters dialog box, click the Add (+) button to add a new
parameter.

Click in the Parameter column and type hidden.

Type true in the Value column.

Steps 7 and 8 hide the audio playback controls.

Click OK to complete the process and close the dialog box.

Linking to an audio or video clip

A simple and relatively trouble-free way to include audio and video clips on
a Web page is to link the page to an audio or video file. Users can click the
link if they want to hear or watch the clip. This selection opens a player out-
side the browser where the user can control playback.

You follow the same steps to create a link to an audio or video file that
resides in your root folder as you do to create a link to a Web page (see
Book II, Chapter 2); the only difference is that you specify a media file
instead of a URL for the link.
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Adding Other Media

Figure 7-7:
Your
embedded
media
options.

Dreamweaver enables you to easily insert a number of other multimedia for-
mats into your Web pages, including ActiveX, Java Applets, Macromedia
Flash, and Shockwave. After inserting any of these media formats, you can
set the control and playback features of the media in the Parameters dialog
box. Additionally, you can fine-tune the media action on your page by using
the Behaviors panel to create triggering actions that cause the media to
play, stop, and execute other functions.

Follow these directions to insert other media:

1. In the Document window, click the location in your page where you
want to add a multimedia file.

2. Click and hold the Media button in the Common category of the
Insert bar to view all the object types that you can insert, as shown
in Figure 7-7, and select the icon of the type of media file you want
to insert.

Alternatively, you can choose Inserte>MediawMedia Type, where Media
Type is the type of media file you want to insert.
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The Select File dialog box appears.

¢ For Applet, Macromedia Flash, and Shockwave files: In the File
Name field in the Select File dialog box, enter the path to the media
and click OK. Your file is inserted, and the associated Property
inspector appears. You can change the selected file in the Plugin
Property inspector by typing a new name in the File text field or by
browsing in the File folder to select a file (for Applets, use the Code
text field). Select the Embed check box if you want Netscape
Navigator users to have access to the Applet.

e For ActiveX: An ActiveX placeholder is inserted, and the ActiveX
Property inspector appears. Enter the name of the ActiveX object
you want to play in the Class ID text field. Select the Embed check
box if you want Netscape Navigator users to have access to the
ActiveX object.

3. In the Property inspector for your selected media, enter dimensions
in the W and H text fields to size the Media placeholder to any dimen-
sions you choose.

4. In the Property inspector for your selected media, click the
Parameters button to open the Parameters dialog box, where you can
add parameters (like width, height, loop, and autoplay) appropriate
to the selected media type.

Using Dreamweaver MX' 2004 Templates

Dreamweaver comes with many built-in layouts that you can use to create
pages or Dreamweaver templates quickly. The layouts are predesigned pages
with placeholder content. Make a new page from a layout, replace the place-
holder content with real content, and voila — a professionally designed page!

To create a new page based on a built-in layout, just follow these steps:

1. Choose File=>New.
The New Document dialog box appears.
2. Select Table Based Layouts in the Category list on the left.

The Table Based Layouts appear in the middle column. Click any one to
see a preview in the Preview area, as shown in Figure 7-8.

3. When you’ve found the layout you want, select the Document option
in the lower-right corner and click the Create button.

An untitled HTML page opens in the Document window, with place-
holder content that you can replace with real content.



Figure 7-8:
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If you wanted to create your own template based on the built-in layout,
you could select the Template option in the lower-right corner of the
New Document dialog box.
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You don’t have to use a built-in layout to create a Dreamweaver template:
You can make a Dreamweaver template based on any Web page. One cool
thing about Dreamweaver templates is that if you make a whole bunch of
pages based on a template, you can change the template and all the pages
based on it will be updated to match the template automatically. Another
cool thing is that you can make a template that other people can use in com-
bination with either Dreamweaver or Contribute 2 to create new pages that
conform to the template’s design.

To create a Dreamweaver template based on an existing HTML page, just
follow these steps:
1. Choose File->New.
The New Document dialog box appears, with the General tab selected.

2. Select Basic Page from the Category list on the left, and then select
HTML Template from the list of Basic Pages that appear in the middle.

You can also select Template Page from the Category list and choose
HTML Template from the Template Page list that appears in the middle.

3. Create your page layout.

By default, nothing in the design of pages based on your template is
editable. You must create editable regions in order to make a useful
template.
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4.

Click a table cell or other part of your layout that you want users to
be able to fill with content and select Insert~>Template Objects—>
Editable Region, or use the keyboard shortcut Ctrl+Alt+V.

The New Editable Region dialog box appears. If you have a placeholder
image already in the layout, you can right-click the image and choose
Templatest>New Editable Region from the contextual menu that pops up,
or you can select the image and use the keyboard shortcut Ctrl+Alt+V.

Name the region and click OK.

You can use the default name Dreamweaver gives to the region, but it’s
better if you name the region to reflect the content that will go into it
(for example, name the region Product Description). Figure 7-9 shows a
template with three editable regions. Editable regions are bound by a
light blue box with region name at the top left.
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6. Repeat Steps 4 and 5 until you have made editable regions out of all
the areas of the page that you want to be editable in new pages based
on the template.
és‘Q,\I\B’Eli'

& Anything inside an editable region can be replaced in a page based on
the template; anything outside the editable regions is locked and can’t
be changed in pages based on the template.

7. Choose File>Save.
The Save As Template dialog box appears.
8. Choose the site the template belongs to from the drop-down list, enter

a name for the template in the Save As field, and click the Save button.

The template will now be available to anyone who has access to the
Dreamweaver site, either through Dreamweaver or with Contribute.



Figure 7-10:
Creating a
new page
based on a
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You may turn any existing page into a template. Choose Filer>Save as
Template when the page is open. If you try to close the template without
having created editable regions (as described in the previous steps),
Dreamweaver gives you a warning message saying that the template does
not contain any editable regions. Click OK to close the warning dialog box,
create the editable regions in your template, and choose Filer>Save to save
your template.

To create an HTML page based on an existing user-created template, follow
these steps:

1. Click the Templates icon in the Assets tab of the File panel. All avail-
able templates for the selected site appear.

If the Files panel is closed, select Windowr>Assets or use the keyboard
shortcut F11.

2. Right-click the template you want to create the new page from and
choose New from Template, as shown in Figure 7-10.

The page opens as an HTML page in the Document window.
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Figure 7-11:
The
Templates
tab of the
New
Document
dialog box.

You can also create an HTML page based on a user-created template by
choosing Filew>)New and choosing the template from the Templates tab of
the New Document dialog box. (When you select the Templates tab, the
dialog box’s title bar changes to read New from Template and the Templates
options appear, as shown in Figure 7-11.)
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Validating Your Code

Dreamweaver MX 2004 has a built-in code validator. The validator checks
your HTML for errors (for example, unclosed <TD> tags, or tags with invalid
attributes, such as <FONT width=113>). If you work exclusively in Design
view, you may never need to use the validator. If you work in Code view,
though, and you are creating long, complex pages, you may find it worth-
while to run the validator.

To validate your code (unless it’'s XML), select Filer>Check Pager>Validate
Markup. The Results panel opens and shows a list of warnings for any faults
in the code.

To validate XML code, select Filer>Check Pager>Validate as XML. Because
XML has stricter requirements for well-formed code, you should take advan-
tage of Dreamweaver’s built-in validator if you're writing XML.



Chapter 8: Integrating
Dreamweaver MX 2004 with
Other Macromedia Products

In This Chapter

v~ Integrating Dreamweaver with Fireworks

v~ Integrating Dreamweaver with Macromedia Flash
v Integrating Dreamweaver with ColdFusion

v~ Integrating Dreamweaver with FreeHand

v Integrating Dreamweaver with Contribute

Wth the release of the Macromedia Studio MX 2004 suite,
Macromedia brought Fireworks MX 2004, Macromedia Flash MX
2004, Dreamweaver MX 2004, ColdFusion MX 6.1 Developer Edition, and
FreeHand MX closer together than ever before. Macromedia Studio MX 2004
also adds Contribute 2 to the mix. The applications in the suite have
complementary — and in some cases overlapping — capabilities.

In order to take advantage of Dreamweaver’s integration with Fireworks and
Macromedia Flash, you need to make sure Design Notes are enabled. Design
Notes are Macromedia Studio’s way of tracking changes and establishing
links between exported files (such as GIFs or JPEGs) and their source files
(Fireworks PNG files, for example).

By default, Design Notes are enabled when you establish a new site. If you
disabled them and wish to re-enable them, just follow these steps:
1. In Dreamweaver, choose Siter>Manage Sites.
The Manage Sites dialog box appears.
2. Select the site by clicking it.
If you have a site open already, that site is already selected.
3. Click the Edit button.

The Site Definition dialog box opens.
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4. If the Site Definition dialog box opens with the Basic tab selected,
click the Advanced tab.

The Advanced options appear.
5. Select Design Notes in the Category list.
The Design Notes options appear.
6. Select the Maintain Design Notes check box, as shown in Figure 8-1.

The Maintain Design Notes option is selected by default, but it can be
toggled on and off in the Site Definition dialog box.

7. If you're working on the site with others, make sure the Upload
Design Notes for Sharing check box is selected.

The Upload Design Notes for Sharing option uploads your Design Notes
so that other people working on the site can have access to them. If
you’re the only person working on a site, you should deselect this
option to speed file transfers.

8. Click OK.

Disabling Design Notes is simple: Just follow the preceding steps, but in
Step 6, deselect the Maintain Design Notes check box.
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With Design Notes enabled, you can move seamlessly back and forth between
Dreamweaver and the other applications in the Macromedia Studio suite.

Integrating Dreamweaver with Fireworks

Fireworks is a Web design tool and Dreamweaver is an HTML editor, so you
may expect that the two applications complement each other well. In fact,
the two programs make a dynamite tag team.

The phrase Roundtrip HTML refers to the basic interaction between Fireworks
and Dreamweaver. Essentially, if you generate your HTML in Fireworks and Book Il
edit the code in Dreamweaver, Fireworks recognizes the changes you make in Chapter 8
Dreamweaver. That goes for links, image maps, behaviors shared by both pro-
grams, and edited HTML text. If you make radical changes to the overall
design of the page in Dreamweaver, however, Fireworks may not be able to
reconcile the HTML with the Fireworks PNG source file. In those cases,
Fireworks will write over your changed code with new code.
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In order to take advantage of Roundtrip HMTL, you need to establish a few
settings, both in Dreamweaver and in Fireworks. In Dreamweaver, you need
to define a local site (see Book II, Chapter 3) and make Fireworks your pri-
mary image-editing application. To find out how, read the next section.

Making Fireworks your primary image editor

If you installed Dreamweaver along with the rest of Macromedia Studio,
Fireworks is your primary image-editing application by default. However, if
you changed that default setting, here’s how to return to the setting of
Fireworks as your primary image-editing application:

1. In Dreamweaver, choose Edit->Preferences or use the keyboard
shortcut Ctrl+U.
The Preferences dialog box appears.

2. Select File Types / Editors in the Category list.

The File Types / Editors options appear in the Preferences dialog box, as
shown in Figure 8-2.

3. Select the .png extension in the Extensions list.
The extension is highlighted.
4. Click the plus (+) button over the Editors list.

If Fireworks is already listed in the Editors list, you don’t need to click
the plus (+) button.



158 Integrating Dreamweaver with Fireworks

Figure 8-2:
The Dream-
weaver
Preferences
dialog box.
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