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Introduction

p roject management has been around as long as there have been people
coming together trying to get things done. Some ancient fellow with a
lot of ambition probably took the lead as the very first project manager. He
carved diagrams in stone tablets to help his team members understand his
strategy and actually talked to them to communicate progress (no e-mail in
those days!). Unlike you, this early project manager had no senior manage-
ment to report to, no formal budget, and no cubicle, but the fundamental
spirit of a project was there.

Over the years, project management has evolved into a sophisticated disci-
pline that involves standardized methodologies and techniques. Project man-
agers have a toolkit that includes detailed analyses and projections, tools to
track time and money, and highly visual reports to impress management.
Project management software — which has been around only about 25 years
or so — has brought a new face and functionality to project management that
would have left our ancient project managers speechless.

About This Book

Microsoft Office Project 2007, the most recent version of the world’s most
popular project management software, provides a treasure trove of function-
ality; it makes the features of your average word processing software look
like child’s play in comparison.

All that functionality can be wonderful, but if you've never used project
management software, those features can also be a bit overwhelming. One
key to making the leap from your traditional project management methods
to project management software is to understand how its features relate to
what you do every day as a project manager. Another is to get a book like
this one that tells you all about Project’s features and how to use them. Even
if you have used project management software or Project itself before, this
book offers a wealth of advice and information on Project 2007 features that
can help you get productive right away.

In Microsoft Office Project 2007 All-in-One Desk Reference For Dummies, our
goal is to help you explore all that Project offers, providing information on
relevant project management concepts in handy modules (called minibooks)
while also offering specific procedures to build and track your Project plans.
But more importantly, we offer advice on how to make all these features and
procedures mesh with what you already know as a project manager to make
the transition easier.
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How This Book Is Organized

This book is organized into digestible chunks of chapters contained in ten
minibooks. Each minibook covers an important topic you need in order to
use Project, such as basic project management concepts, resources, and
tracking. If you’re new to Project, you might want to read each book in
sequence, but if you've used Project before, you can simply refer to the mini-
book that you need at the moment.

In addition, we include case studies throughout this book to help you see how
Project works in action. Files that go along with those case studies are on the
book’s companion Web site, located at www . dummies.com/go/project
2007aiofd.

The following sections offer a quick synopsis of what each book contains.

Book I: Project Management

This book gives you a firm grounding in project management concepts and
the Microsoft Project 2007 environment. You discover what typical tasks go
into a project, as well as how using Project to manage your tasks and
resources can save you time and money. Finally, in Chapter 5, we explore
what’s new in Project 2007, particularly some neat features such as Change
Highlighting and Task Drivers.

Book 1I: Project Basics

Some of the basic building blocks of Project include the overall structure of a
project plan, which we discuss in Chapter 1, and the tasks that make up that
plan. It’s in this minibook that you create your first task and explore the
many views Project offers to help you review and analyze your project data.
In Chapter 4, we cover calendars, very important tools in building your pro-
ject’s timing. Finally, in Chapter 5, we explore Project’s help system so you
can use it to find topics of interest easily.

Book 111: Getting Your Plan in Order

This is the minibook where you explore the outline structure of a Project
plan, made up of summary tasks and subtasks, and how to assign outline
codes. Chapter 3 introduces you to the work breakdown structure (WBS)
code, used by many organizations to uniquely identify tasks in a project
plan. Finally, in Chapter 4 you discover the ins and outs of inserting and link-
ing projects so that a task within one project can represent the timing of
another project.
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Book 1V: Establishing Task Timing

Task timing is determined by a number of factors, several of which are
reviewed in the chapters of this minibook. Chapter 1 explores the basics of
timing. Chapter 2 provides an introduction to what drives task timing, includ-
ing the start and finish dates of a project and the setting for how Project
schedules tasks. In Chapter 3, you explore dependencies, timing relationships
between tasks that control their timing in relation to each other. Finally,
Chapter 4 deals with constraints, settings such as Start No Later Than that
force a task’s timing in some fashion.

Book U: Working with Resources and Costs

Resources are the people, equipment, and materials that you use to get
things done on your project. There are various kinds of resources, which you
discover in Chapter 1, “Creating Resources.” Chapter 2 shows you how
resources relate to costs in your project. Chapter 3 is where you discover
how to assign resources you've created to tasks in your project. The last
chapter in this minibook explores how Project totals up costs resulting from
resource assignments.

Book VI: Communicating Project Information

When you input data about tasks and resources into Project, it returns a
wealth of information about your schedule and costs. In this minibook, you
look more closely at all the views Project offers for reviewing that informa-
tion, as well as tables of data you can display in those views and even cus-
tomize. This minibook ends with two chapters about reporting, one covering
traditional Project reports and one covering a Visual Reports feature that’s
new in Project 2007.

Book VII: Resolving Problems in Your Plan

When you have created a Project plan, before you put it into action it’s a
good idea to review it and fix any problems. In this minibook, we introduce
filters and groups that help you spot trends and problems. Chapter 2 helps
you through several methods for resolving resource conflicts, which might
include resources who are overbooked at some point during the life of your
project or whose assignments are causing delays in your schedule. Chapters
3 and 4 show you how to spot and resolve problems with timing in your proj-
ect, including how you can use Project to help you convince your manage-
ment that you need more time to get everything done.
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Book VIII: Tracking

The project has started, tasks are being worked on, resource costs are tallying
up. Now comes the tracking phase, when you set a baseline against which you
can record progress. In this minibook, we discuss recording actual activity on
tasks and reviewing what that activity is doing to your budget.

Book IX: Advanced Project Topics

Project is a very sophisticated piece of software, and it provides you with
several more advanced tools to make your life easier. Book IX is where you
find out how to customize the interface that Project shows you and the look
of the various elements in your project plan. You also discover how to use
macros to automate procedures and how to both import and export data in
Project.

Book X: The Basics of Project Server

Project Professional can be used in conjunction with Project Server to create
an enterprise-wide project management solution. Chapter 1 of this book
gives you an overview of Project used with Project Server. Chapters 2
through 4 approach enterprise project management using Project and
Project Server from the perspective of the Project Server administrator, the
project manager, and the project team member.

Glossary

Project management and Project itself involve a lot (and we mean a lot) of
terms and acronyms that you need to know to input and analyze data. This
glossary is a good place to go when an unfamiliar word or string of letters
pops up.

Conventions Used in This Book

We use a few conventions in this book that you ought to know about.

Web site addresses, or URLs, and other items such as filenames are highlighted
like this: www.microsoft.comand IAmAFile.mpp.

Menu commands are given in the order in which you select them; for example,
Choose Tools=>Resource Sharing=>Share Resources.

Options in dialog boxes use initial caps even if they aren’t capitalized on
your screen. This makes it easier for you to identify them in sentences. For
example, what appears as “Show summary tasks” in the Options dialog box
appears as Show Summary Tasks in our chapters.
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Foolish Assumptions

We've made some assumptions in writing this book. First, we’ve assumed
that you are computer literate — that you've used software and know what a
menu and dialog box are. We assume you know how to use a mouse to select
objects and text. We assume you have good file management skills and know
that you should keep copies of your files and save frequently.

We have not assumed that you have used Project before, though you might
have used a previous version and simply want to find out more about some
area of it.

We haven’t assumed that you manage multimillion dollar projects; whether
you deal with small projects or large projects, the information and concepts
in this book help you manage them better.

In case you're new to project management, we've provided the first minibook
to give you a grounding in some key project management concepts.

Icons Used in This Book

\\3

Putting little pictures in the margins of tech books to call your attention to
certain types of information has become a standard, and For Dummies books
use the neatest little pictures around. Here’s what they mean:

Tips are the advice columns of computer books. They offer wise advice from
those of us who have been in the Project trenches, a bit more information
about a topic under discussion, or a different way to achieve some results.

Remember icons offer a relevant fact or reminder of a key concept. These
juicy tidbits are likely to be useful to you repeatedly, so don’t forget them.

Warning icons alert you to potential problems, so don’t ignore them. If you
don’t take the advice in warnings, you might end up with lost data, a faulty
project plan, or a really bad day.

This icon marks Project information that goes beyond the basics.

Throughout this book, we have included case studies that help you envision
how Project works in a real world (well, a pretend real world) setting. The
files for these case studies are also included on the companion Web site
(www . dummies.com/go/project2007aiofd).
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Where to Go from Here

If you know a bit about Project and want to explore some aspect of it further,
just jump to the relevant book and have at it. If you want to start by checking
out what’s new in Project 2007, Book I, Chapter 5 is the place to go. If you
need to start from square one, start with Chapter 1 of Book I and work your
way through each minibook to get a logically organized introduction to all
that project management with Project has to offer.

Wherever you dive in, you’ll find what you need to make your experience
with Project more productive.
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Chapter 1: A Project Management
Overview

In This Chapter

v+~ Examining the project life cycle
v+ Looking at project roles
v~ Understanding the triple constraint, critical path, and slack

v Exploring the basics of resource management

M icrosoft Project 2007 is a wonderful tool for managing projects.
However, a tool is only as good as the person wielding it. Understanding
how Project fits in the context of a typical project is important to using it
successfully.

In this chapter, we look at what occurs during the life of a project and how
Microsoft Project fits within that life cycle; the typical roles in a project and
how people in each of those roles might interact with Project; and some
basic project management concepts.

The Life of a Project

You handle projects day in and day out. Some take a few hours to complete,
such as that shed you built in your yard last Saturday. Others might take
years from beginning to end to complete the work and reach your goals.
However, most projects that you handle will have several things in common.

So, just what is a project?

Microsoft Project has certain features that help you deal with all the elements
of a typical project. So what is a typical project? All projects have

4 An overall goal

4+ A project manager

4 Individual tasks to be performed

+

Timing for those tasks to be completed (such as three hours, three
days, or three months)

+

Timing relationships between those tasks (For example, you can’t
launch a space shuttle until you fill it with fuel.)
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Figure 1-1:
A Project
planin its
early phase
of develop-
ment.

4+ Resources (people, equipment, facilities, and supplies, for example) to
accomplish the work

4+ A budget (the costs associated with the people, equipment, facilities, and
supplies)

Project management is simply the process of managing all the elements of a
project, whether that project is large or small.

Taking a closer look at the project life cycle

You can typically expect to work through several phases of a project, and in
each phase, you'll perform different activities in Microsoft Project. Projects
typically break down into the following phases:

1. Planning: Whether it takes hours, days, or months, this is a very impor-
tant phase. This is when you identify your goal or goals (see Chapter 2
of this minibook for more about this process), get management support
for the project, and line up your internal and external resources, includ-
ing people, facilities, equipment, and so on. In Project you can start to
sketch out your Project plan by adding tasks that, at this point, might or
might not have timing (see Figure 1-1) and entering information about
resources that you'll use.
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Figure 1-2:
Timing built
into the
workflow of
tasks.
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The Life of a Project

2. Finalizing the plan: After you've gathered all your resources and thought
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through the steps of your project in the planning phase, it’s time to dot
your i’s and cross your f's so you're ready to launch the project. In Project,
this means making sure all the logical timing relationships between tasks
have been accounted for (see Figure 1-2), all the cost information for
resources is correct, and that you resolve any resource conflicts. (An exam-
ple of a resource conflict is when one person is booked to work 16 hours in
one day, for example.) This is also the time to present your final plan to
management and get their approval. (Project’s reporting capabilities come
in handy here.) When your plan is approved, you save a baseline project
against which you can track actual progress after your project begins.

See Book IV for information about task timing, Book VII about resolving
problems in your plan, and Book VIII, Chapter 1 for information about
setting a baseline.
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Figure 1-3:
Timesheet is
an easy-to-
use time-
reporting
feature.

3. Launching the project: With an approved plan in hand, you can officially

launch the project. Make sure your entire team has information about
individual responsibilities and that you’'ve set up channels of communi-
cation either online, using printed reports, or through regular in-person
meetings. Also make sure you have set up reporting mechanisms for
your team members to report their work hours on tasks and progress.
Be sure to instruct your team in how to use those mechanisms, such as
the Timesheet feature built into Project Web Access (see Figure 1-3). See
Book X, Chapter 4 for more about this.
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4. Tracking and revising your plan: When your team starts working on
tasks and reporting progress, you or somebody you designate has to
track that progress in Project. With information on tasks and resource
time added into your project plan, you'll find that actual work is likely to
differ from your projections. When that happens, you might have to
make adjustments to the remainder of your plan to meet your deadline,
budget limits, or goals. You can also use Project’s reporting capabilities
(see Figure 1-4) to keep your management, clients, and other project
stakeholders current on the status of your project. See Book VIII for
details about tracking activity on a project.

5. Ending the project and debriefing: If you've established a clear set of

goals and deliverables, you’ll know when the project is over. When that
moment comes, your job isn’t quite finished. It’s important that you send
out final reports or accountings to management and clients, thank your
team members for their efforts and communicate with them about the
project’s success, and hold a meeting to debrief the team about the proj-
ect so you can learn from both your failures and successes along the way.
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Projects are driven by people, and just as everybody on a sports team plays
a particular role, everybody in a project has unique responsibilities. From
the project manager to the folks who do work on tasks and even the client or
customer who will benefit from the final results, you need to understand
how each person in your project fits in. What does a project manager do?

A project manager could be described as somebody who knows how to wear
many hats. A project manager is a scheduler, a budget maker, a facilitator of
communications, a resolver of conflicts, a troubleshooter, a counselor, and
much, much more.

A project manager isn’t always the highest authority in a project; often, that
role belongs to the project manager’s own manager, up to and including
members of senior management. Rather, the project manager is the person
on the front lines who puts together a plan, gathers resources, makes sure
that the tasks in the project happen, and records project activity in Project.

Ideally, a project manager should have some experience in managing people
and processes and to some degree should be familiar with the type of work
that resources will be asked to perform.
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Getting a Few Project Management Concepts under Vour Belt

A project manager supervises these essential pieces of a project:

4+ The project plan or schedule: This is what you create with Microsoft

Project. It includes the estimated steps and associated timing and costs
involved in reaching the project goal.

Resources: Managing resources involves assigning resources and track-
ing their activities on the project as well as resolving resource conflicts
and building consensus. This part of the job also involves managing the
use of nonhuman resources, such as materials and equipment.

4+ Communication with the project team, management, and customers:

Communicating the project’s status to everyone who has a legitimate
stake in its success (stakeholders) is a key responsibility.

As a project manager, it’s your job to keep all stakeholders informed, get
appropriate approvals, and involve the right people at the right time.

Stakeholders of all types

In addition to a project manager and the resources who perform tasks, others
will have an interest in the project and its outcome. In project management
parlance, anybody involved in a project is considered a stakeholder.

4+ The person who champions (and has the ultimate responsibility for) a

project is the project sponsor. This person usually belongs to higher-up
management and should support the project manager by helping to get
key approvals, providing input on larger organizational priorities, and
obtaining funding from management.

Although a project manager might work for a project sponsor, the project
often also has a customer for whom the end product is produced. That
customer can be outside the project manager’s own company or within.
A customer generally gets final approval of the deliverables of a project
and pays the costs of a project.

A project might have a whole slew of additional stakeholders in the form
of vendors, contractors, or consultants who will work on the project
along with internal resources.

Getting a Few Project Management
Concepts under Your Belt

As you work with Microsoft Project, you’ll deal with all-important timing
details to try to make your deadline. You need to understand some concepts
behind scheduling in order to make intelligent choices as you build a Project
plan.
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The dreaded triple constraint

You've seen the signs at the copy store or the auto repair place: “You can
have it fast, cheap, or right; pick two.” That, good friend, is the triple con-
straint of project management in a nutshell.

In a project, you have timing, resources (which are essentially costs), and
the quality of the product or service you want to produce at the end of the
project. Microsoft Project helps you to manage the resources and timing of
your project. Still, the quality of your project is often affected directly by
how well you manage these other two elements. If you add time, costs
increase because resources are working longer hours at a certain wage. If
you take away resources, you save money, but this can affect quality.

Creating a balance among time, money, and quality is the juggling act you
will perform throughout the life of a project. Project offers the following
tools to help you do this:

4+ Change Highlighting helps you see how one change (say, in timing)
affects other aspects (such as cost). See Book I, Chapter 5 for more
about Change Highlighting.

4+ Resource leveling is a calculation that moves your schedule out to
free up overtaxed resources. Of course, in this case you sacrifice time,
but with less-stressed resources, you probably improve the quality of
your outcome. See Book VII, Chapter 2 to discover how to use this
handy feature.

4+ You can set priorities on tasks so that you can keep tabs on changes
that occur on tasks that ensure quality (for example, quality testing or
QA tasks).

Keeping on track: Critical path and slack

If you look at all the tasks in a project, you find a series of tasks that, if
delayed, would delay the project. This is called the critical path. The simplest
example of a critical path is a project with two tasks, one of which takes two
weeks to complete and one of which takes one week to complete. If those
tasks can happen simultaneously, the longer path is on the critical path, but
the shorter task could be delayed several days and not delay the end date of
the project. If the shorter task is delayed, say, eight days, it then becomes the
critical task in the project.

Staying aware of what the critical path of your project is at any point in time
(and it will shift around, trust us) is vital to staying on schedule. Project pro-
vides filters and reports that help you spot your critical path easily (see
Figure 1-5).
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Tasks that aren’t on the critical path in your project have some slack — that
is, some time that they could be delayed without delaying the entire project.
Ideally, every task in your project should have slack because things can
come up that you never expected (shortages of vital materials, asteroid
strikes, or management turnover that places you in an entirely different
department). It’s up to you to build slack into your schedule as you build in
task timing in Project (see Book IV for more about how to do this).

See Book VII, Chapter 4 for more about working with slack.

Using tried-and-true methodologies

Microsoft Project incorporates some scheduling and tracking tools that are
the result of many years of developing project management methods. A few
of these are worth noting:

4+ A Gantt chart (shown in Gantt Chart view in Figure 1-6, which is the main
view of Project), shows you a spreadsheet with columns of data along
with a graphical representation of the tasks in the project arranged along
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a horizontal timeline. By using the data in the columns (such as task
name, start date, finish date, and resources assigned to tasks), you can
understand the parameters of each task and see its timing in the graphi-
cal area. Being able to view all this information on one page helps you
understand what’s happening in your project in terms of time and costs.
If you're a history buff, you’ll be interested to hear that the Gantt chart
was created in 1910 by Henry Gantt, a mechanical engineer, and the idea
was first published in The Engineering Magazine.

See Book II, Chapter 3 for more about working with and changing Project
views.

The Network Diagram (also called a logic diagram), shown in Figure 1-7,
is essentially the Microsoft version of a PERT chart. PERT (Program
FEvaluation and Review Technique) was developed during the construction
of the Polaris submarine in the 1950s. This mostly graphical representa-
tion of the tasks in your project reflects the flow of work in your project
rather than the literal timing of tasks. This view helps you to see how one
task flows into another and to get a sense of where you are — not so much
in time, but rather in terms of the work you have to accomplish.

Book |
Chapter 1
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Resource Management Basics

If you asked us to do so, we could write an entire book about resource
management. This is one of the most important skills a project manager
can acquire because resources are the way things get accomplished in any
project. But we have much more to cover, so here’s the ten-cent tour of
resource management.

How Project sees resources

Resource management consists of using your resources wisely. This involves
not only managing people, but also strategically selecting the right resource
and making the right assignments.

In Microsoft Project, resources are also the method used to accrue costs.
Resources, in Project’s terms, can be people, equipment, facilities that you
rent, or fixed costs such as a consultant’s fee or an airplane ticket; in short, a
resource is anything or anybody you use to perform the tasks in your project.

All resources have a defined amount of availability. You might have to ensure
that there is enough material on hand to complete a task, that a meeting
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room is available when you need it, that an in-demand piece of scientific test-
ing equipment isn’t offline, or that a key human resource isn’t on vacation or

assigned to another project.

What it takes to manage people

When dealing with human resources, a good project manager can do the

following:

4+ Find the right resource for the job, taking into account skill level and cost.

4+ Provide any required training for resources.

4+ Assign the resource a reasonable workload, which sometimes means
negotiating with other project managers for that person’s time.

4+ Stay alert for shifts in the schedule that cause the resource to be

overbooked.

4+ Make adjustments during the life of the project that keep all resources

most productive.

In Project, tools are available, such as a resource graph (traditionally called a
histogram) and the resource usage chart (shown in Figure 1-8), to help you

track resource workload. You can see how overbooked the Systems Analyst is.

Project allows you to assign codes for resources that you can use to desig-
nate skill levels or abilities so that finding the right resource for each job is

as simple as performing a search.

Do | always need resources?

Resources in Project are there to accrue costs
and to help you monitor overbooked resources,
which might cause delays in your schedule.
Some project managers choose not to assign
resources to tasks in Project if those resources
have no associated cost and their time doesn't
need to be tracked. For example, if an
administrative assistant does some work for the

department that includes project work, but
nobody allocates his or her time to the project
budget, there’s no need to assign that person to
individual tasks. If you use a meeting room but
there is no charge to use it and the hours you
use it don't need to be tracked for any reason,
you don’t need to create, assign, or track such a
resource.

Book |
Chapter 1
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P It’s especially hard to anticipate resource assignments in a lengthy project
because it’s difficult to know who will be available a year or two from now.
To deal with that, consider creating generic resources, such as “Engineer,”
and fill in the appropriate individual’s information later in the project.



Chapter 2: The Ins and Quts
of Using Project

In This Chapter

v+~ Exploring what you need to put into Project
v+ Understanding tasks, timing, and resources
v Using tracking to update a project

v Getting useful reports out of Project

Welcome to the world of computerized project management with
Microsoft Project. If you've never used project management software,
you're stepping into a whole new era of project management. You'll be leav-
ing the world of the handwritten to-do list and entering a world teeming with
hi-tech calculations and sophisticated project data.

Everything you ever did with handwritten to-do lists, word processors, and
spreadsheets all magically comes together in Project. However, the transition
into computerized project management doesn’t happen in seconds. First you
need a basic understanding of what project management software can do,
what it demands of you, and what results it can provide.

If you've used previous versions of Project, this little overview can help you
refresh your memory as well as ease you into a few of the new features of
Project 2007.

The Basics of Computerized Project Management

If you've scanned this book’s Table of Contents, you're probably shaking
your head and saying, “Boy, handwritten to-do lists look pretty good right
now. Beats having to key in tons of data about tasks, schedules, and
resources,” right?

Well, you're right and wrong about that. You do have to enter a lot of infor-
mation into Project to get the benefit of its features. But after you provide
Project with some data, you can also get a lot out of it.
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Making the leap to Project

“So,” you ask, “what exactly can Project do for me?” The following list
describes the payoff that you get for investing time to understand and use
Project to manage your work.

With Project, you enjoy the following benefits:

4+ Automatic calculations: Project automatically calculates costs and
timing for you based on your input. This gives you an instant snapshot
of your status at any point during your project. See Book VII for more
about automatic versus manual calculations.

4+ Ability to try out what-if scenarios: You can quickly have Project recal-
culate what-if scenarios to solve resource conflicts, get your costs within
budget, or meet your final deadline.

4+ Views and reports: Project offers views and reports that, with the click
of a button, make a wealth of information available to you and those you
report to. No more manually building a report on total-costs-to-date to
meet a last-minute request from your boss. If she wants to know total-
costs-to-date, you can just print your Tracking Gantt view with the
Tracking table displayed. See Book VI for information about reporting.

4+ Templates: You can use built-in templates to get a head start on your proj-
ect. Project templates are prebuilt plans for a typical business project,
such as commercial construction, an engineering project, a new product
rollout, software development, or an office move (see Figure 2-1 for an
example). See Book II, Chapter 1 for more about using templates.

You're likely to do similar types of projects all the time. After you create
one project, make it a custom template for future projects. See Book II,
Chapter 1 for information about how to save a file as a template.

4+ Resource management: You can create resources for your project based
on information that already exists in your Outlook Address Book. Your
company could create one set of resources and give access to them to
every project manager in the company. This not only saves you time in
building resources from scratch, but it also helps you track resource
time across multiple projects. See Book V for more about working with
resources.

4+ Calculation of project data: A number of tools in Project employ com-
plex algorithms (that we couldn’t even begin to explain) to help you
resolve problems or view data, such as leveling resource assignments to
solve resource conflicts, filtering tasks by various criteria, and calculat-
ing in dollars (or francs, or whatever) the value of work performed to
date. See Book V, Chapter 4 for information about how Project calculates
costs, and Book VII, Chapter 1 to discover how filters help you focus on
certain types of information in your project.
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Connecting with your team online

You can hop onto the Internet and communicate with your project team by
using Project collaboration features. In fact, using Project 2007 you can enter
the world of Enterprise Project Management (EPM), where it becomes possi-
ble for you to easily share ideas, information, and documents across your
entire enterprise.

You can do a number of useful activities online; for example, Project allows
you to request updates on a task’s progress from team members via e-mail.
You can post documents to a SharePoint site and ask for team input. You can
even publish your project on the Web so those without Project can view it.

The Professional version of Project includes Project Server and Project Web
Access, which enable many of the workgroup collaboration features in
Project. With these tools, you can take advantage of an online project center
and resource center with areas for discussions, progress tracking, document
exchange, and more.

Book X looks at how to take advantage of the enterprise-wide features of
Project Server and Project Web Access.

Book |
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What You Have to Put Into Project

Project can give a lot back, but it depends on the information you put in to
produce its calculations, reports, and so on.

Though there are a few other pieces of information you can provide to
Project, by far the two biggest chunks of data it requires of you are the tasks,
or steps, to be completed to reach your project goal and the resources you
will use to accomplish those tasks.

Tasks and their timing

A task is simply one of those items you used to scribble on your handwritten
to-do lists, such as Write final report or Apply for permits. Tasks are typically
organized into phases (appropriate stages) in Project, arranged in an outline-
like structure, as you can see in the project shown in Figure 2-2.

The length of tasks (their duration) and the sequence of tasks together create
the timeline for your project. Project allows you to create that sequence by
building in timing relationships among tasks.
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Figure 2-3:
A project
broken up
into phases.
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Mastering tasks

A task can be as broad or as detailed as you like. For example, you can
create a single task to research your competition, or you can create a project
phase that consists of a summary task and various subtasks below it (see
Figure 2-3).

In a project phase involving researching your competition, the summary task
might be Competitive Research, which includes the subtasks Researching
Online Business Databases, Assembling Company Annual Reports, and
Reviewing Competitive Product Lines.

A project can have as many tasks and as many phases as you like. You simply
use the outlining structure in Project to indent various levels of tasks. The
more deeply indented in an outline a task is, the more detailed the task.
However, don’t overdo it: If you're tallying up task 2,503, consider whether you
need to make your project less granular or start to break up this behemoth
into a few smaller projects.
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One handy thing about Project’s outlining structure is that you can roll up all
the timing and cost data from the subtasks within your phases into summary-
level tasks. Three sequential subtasks that take two days each to complete
and cost you $500 apiece result in a summary task that spans six days and
costs $1,500. You can view your project at various levels of detail. If you view
only summary tasks, you get automatic tallies of timing and costs, and if you
display deeper levels of detail, you get an accounting of every last dime and
minute in your project.

For more about organizing your tasks and outlining, see Book III.

It’s all in the timing

They say that timing is everything: Knowing when to sell that hi-tech stock,
buying real estate before the boom hits, and finding the best time to pop the
question come to mind. The importance of timing applies to Project tasks, as
well. Almost all tasks have timing — referred to as duration. Duration is
simply the amount of time it takes to complete the task.

The only tasks without duration are called milestones. A milestone is a task
of zero duration; in essence, it simply marks a moment in time that you need
to account for in your Project outline. Typical milestones are the approval of
a proposal and an assembly line startup. Figure 2-4 shows a project with sev-
eral important milestones, indicated by a diamond-shaped icon.

k‘&N\BER Unfortunately, you can’t ask Project to come up with accurate durations: You
& assign duration based on your own experience and judgment. Does printing
a product package take three days or three weeks? Will getting senior man-
agement approval take a day or a month? (Don’t forget to pad this task in
proportion to how many of those senior types have to buy in.) Project can’t
come up with these estimates: You have to provide facts, figures, and edu-
cated guesses to build your Project schedule. After you enter that informa-
tion, though, Project can do some wonderful things to help you maintain
your schedule and monitor your progress.

How tasks depend on each other

One very important determining factor in how long your project will take
involves the concept of dependencies, or the timing relationships among
tasks. If you have a schedule that includes ten 2-day tasks that all begin at
the same time, your entire project will take as long as the longest task, which
in this case is two days (see Figure 2-5). However, after you define and imple-
ment timing relationships among tasks, ten 2-day tasks could take as long as
20 days to accomplish.
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Figure 2-6:
This
schedule
includes
tasks with
both timing
and
dependen-
cies.

Here’s how this works. On the simplest level, if each of ten 2-day tasks hap-
pens in sequence — that is, each task can’t begin until the task before it is
completed — it will take 20 days to complete them. But dependencies are
often more complex. For example, one task might begin only after another is
finished, but another task can start halfway through the preceding task. The
second task cannot start until a week after the first task is finished. Only
after you start to assign these relationships can you begin to see a project’s
timing as related not just to each task’s duration but also to the specific
ways in which the tasks relate to each other.

Here are some examples of dependencies:
4 You can’t begin to use a new piece of equipment until you train people in
how to use it.

4+ You must wait for a nuclear reactor to get online before you can begin to
generate energy.

4 You can't start to ship a new food product until the FDA approves it.
Figure 2-6 shows a project plan where each task’s duration and the depend-

encies among tasks have been established. Note the resulting overall timing
of the project.

You can find out more about the fine art of managing dependencies in Book IV,
Chapter 3.
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Built-in constraints count, too

There's one other thing you should know about
the timing of tasks: In addition to applying
dependencies to tasks, you can apply con-
straints. For example, say you don't want to start
shipping your new toy until you get the ad for it
in your Christmas catalog, so you set a depend-
ency between those two events. You can also
set a constraint which says that you must start

manufacturing the toys no later than November
3. In this case, if you don't make the catalog
deadline, the product will still ship on November
3; that task won't be allowed to slip its constraint
because of this dependency relationship.

You can find out more about constraints in Book
IV, Chapter 4.

Lining up resources

When you're new to Project, it’s easy to get a bit confused about what a
resource is. Resources aren’t just people: A resource can be a piece of equip-
ment you rent, a meeting room that you have to pay an hourly fee to use, or
a box of nails or a software program you have to buy. Essentially, a resource
is anything or anybody you need to get your tasks done, and though they
don’t always have costs associated with them, they usually do. Resource
costs are, in fact, how Project accounts for your project budget.

Project allows for three kinds of resources: work resources, material
resources, and cost resources. A work resource is charged by how many
hours or days the resource (often human) works on a task. A material
resource, such as baking supplies or steel, is charged by a per-use cost or by
a unit of measurement (such as pounds of flour or tons of steel). A cost
resource has a set cost, such as a conference fee of $250; this fee doesn’t
vary by how much time you spend at the conference, nor by how many
events you attend.

Some resources, typically people, perform their work according to a working
calendar (see Figure 2-7). Say the calendar includes 5 workdays in a working
week. If a person works an 8-hour day and you assign him to a task that takes
24 hours to complete, that person has to put in 3 workdays to complete the
task. In comparison, someone with a 12-hour workday takes only 2 days to
complete the same task.

In addition to establishing the workdays in a typical week, you can set working
and nonworking days for your human resources to accommodate variations
such as 4-day weeks or shift work.

Book |
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Figure 2-7:
Aresource’s
working
calendar. o e
<® You can set different rates for resources, such as a standard hourly rate and

an overtime rate. You can even indicate that the resource rate changes at
certain times of the year over the life of the project. Project applies the
appropriate rate based on each resource’s calendar and work assigned. For
more about resources and costs, see Book V.

Resource assignments have an impact on both the cost of your project and
its timing. In addition, several views in Project let you see information about
resources and how their assignment to tasks affects your project. Figure 2-8
shows you the Resource Sheet, which has columns of information about
resources and their costs.

Here’s another important thing you should know about resources: They tend
to have schedule conflicts. When assigned resources become overallocated
for their available work time because they’re assigned to too many tasks at
once, Project will alert you to the fact.

For example, if you assign one poor guy to three 8-hour tasks that must all
happen on the same day — and in the same eight hours — Project has fea-
tures that do everything but jump up on your desk and whistle Dixie to
alert you to the conflict (see Figure 2-9). Happily, Project also provides
tools that help you resolve those conflicts, which are covered in Book VII,
Chapter 2.
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Figure 2-9:
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Keeping a Project on Track

Figure 2-10:
Actual
activity
displayed
againsta
baseline.

Projects aren’t set in stone: They typically go through a lot of changes over
their lifetime. Tasks run late, costs go over budget, and sometimes the whole
scope of your deliverables changes. That’s why Project’s capability to make
changes to your project data on the fly is so useful. And the ability to track
those changes against your original plan can be invaluable.

After you complete your original plan, build all your tasks, give them dura-
tions and dependencies, and assign all your resources and costs, you set a
baseline. A baseline is a snapshot of your project at the moment you feel
your plan is final and you’re ready to get started on that first task.

Because Project saves both sets of data in a single schedule, after you set a
baseline and record actual activity on your tasks, you can then compare that
actual activity against your baseline (see Figure 2-10).

The recording of actual activity in a project is called tracking. Tracking activ-
ity in your project involves recording the actual timing of tasks and the time
that your resources spend on those tasks, as well as entering any actual
material costs that accrue. You can then display Project views that show you
how far off you are at any time (compared with your baseline) in terms of
the actual timing of tasks and cost of your project.
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Keeping Others in the Loop

Tracking allows you to make adjustments when you see that your schedule
or costs are getting out of hand. In addition, when you track activity to date,
you can easily generate reports that help you show your bosses the status of
your project.

Keeping Others in the Loop

Figure 2-11:
Study
resource
hours by
task with the
graphical
Task Usage
view.

One of the big payoffs for entering all that information about tasks and
resources into Project is the ability it offers you to share that information in
reports. Reports help you document progress, beg for additional funding, or
even motivate your team members by showing them all they’ve accomplished.

Project offers a wealth of reporting options to help you view your project and
communicate your progress to your project team, clients, and management.

You can generate predesigned reports based on information in your sched-
ule or simply print any of the views you can display in Project. Project 2007
offers a set of Basic Reports and a new feature called Visual Reports.

You must have the Microsoft .NET Framework installed, which is free and
downloadable from www.microsoft.com/downloads, in order to use
Visual Reports.

Figures 2-11 and 2-12 show you just two of the reporting options available in
Project.
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Chapter 3: Just What Tasks
Should You Include?

In This Chapter

v Determining your business need

v Writing a goal statement

1~ Establishing your project’s scope

1 Writing a scope statement

v Deciding on project phases

v Choosing how detailed your tasks should be

+ Determining when a phase is a project

One of the trickiest parts of putting your project down on paper (or in a
computer file) is knowing exactly what tasks to include in it. Too much
detail and you’ll spend more time creating tasks than getting the work of
your project done. Too broad a vision and you might miss crucial tasks
because nobody defined them along the way.

Some useful tools that are available to project managers can help them focus
their projects at the outset to lay a foundation for eventual success. These
tools include establishing a clear-cut goal and defining the scope of your proj-
ect. After you've taken these steps, you can start to outline the various phases
of your project and begin to fill in the tasks you need to get to your goal.

In this chapter, we walk you through setting your project goal and scope,
including writing a goal statement and a scope statement. Then, we take a
look at some general rules that help you make choices about building your
project phases.

First Things First: Define the Business Need

Good project management practice requires that you start at the beginning,
considering what business need your project is fulfilling. Before you begin a
project to upgrade your computer network at a branch office, you should be
sure that your company will continue to invest in that division and won’t be
downsizing the staff that will use the network. You should be sure the tech-
nology you're installing today will meet the technology needs of the staff in
the future.
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Target Practice: Project Goal Setting

Too often in companies, projects are launched without anybody considering
the greater organizational goals. One good way to ensure that there’s a match is
to get senior management buy-in up front. If your senior management folks
have a cohesive vision of the short- and long-term goals of the company, it’s
their job to put a stamp of approval on your project goals within that context.
(If your senior management doesn’t have a cohesive vision, we can’t help you.)

Don’t assume your managers have given approval because you copied them
on a memo about the project launch. Get approval, get it in writing, and file it
away.

In looking at the overall fit of your project in your organization, consider factors
such as

4 Future budget and cash flow issues: Does the cost of your project fit in
with overall budgetary constraints?

4+ Risk tolerance: For example, is your company being conservative or
aggressive in its growth projections, and does your project fit within risk
parameters?

4+ Target customer base: Will your project meet the needs of internal or
external customers, or is your company intending to target new sets of
customers in the future?

Another good idea is to measure your project’s goal against your company’s
mission statement. If the fit isn’t good, your project might be doomed to fail.
For example, if your company’s mission statement includes the phrase “to
service a small, select clientele with high-quality products” and your project
is to launch a Web site offering low-priced products to a wide customer base,
think again!

Target Practice: Project Goal Setting

You can’t hit a target if you don’t know what it looks like. Similarly, you can’t
possibly reach your project’s goal if you don’t know what it is. When you
understand how your project fits in with the broader company direction, it’s
time to really pin down your goal.

“But,” you say, “I know exactly what my goal is, because my boss told me.”
However, a set of deliverables isn’t necessarily a goal.

On first consideration, you might say the goal of expanding the railroad west-
ward in the United States was to enable a train to go from coast to coast. But
was it? Perhaps the goal of those railroad barons was not to get a train to go
cross country, but to open up opportunities for commerce in the West.

It’s time to put the same kind of thought to your project’s goal.
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Getting your goal straight

Say your project involves training new employees in a new software system.
Your goal in training them on this software could be to

4+ Make employees more productive in their jobs.
4+ Enable employees to better serve customers.

4+ Create a prototype program with reduced training costs that can be
used to reduce overall training costs across the company.

4+ Increase employee retention by providing useful on-the-job skills.

These goals suggest different priorities as well as different measurements for
gauging the degree to which your project has succeeded in meeting its goal.

How, exactly, do you go about determining your goal? First, go back to the
person who asked you to take on the project and grill him or her about what’s
expected of this project. Should the training have a measurable impact on job
performance, customer satisfaction, employee retention, or cost of delivery?

The answer you get might be that the project should do all of these things.
But think about whether that’s realistic and whether one of these goals
should be paramount in guiding you and your project team. If overall training-
program cost reduction is the biggest goal factor, for example, employee pro-
ductivity might have to take a back seat when you’re making choices along
the way. If customer satisfaction is the real goal, training costs might have to
be adjusted accordingly.

Writing a goal statement

After you get more specifics about your project’s goal, it’s a good idea to put
your goal in writing in a goal statement.

A goal statement outlines why you’re doing this project and what you hope to
accomplish at the end. You don’t get down to specific deliverables and
parameters in a goal statement (you tackle that in the next section on the
project’s scope). For now focus on the why and the desired result.

Here are a few sample goal statements:

4+ The goal of the project is to upgrade the shopping cart feature on our Web
site to be easier to use so we can increase online sales by 25 percent.

4+ Our goal is to reduce human resource workload by 10 percent by offer-
ing self-service information on job benefits on the company intranet.

Using the example of a training project, consider for a moment what such a
project might involve. Are you supposed to write new training materials, hire
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staff to deliver classes, analyze the training’s effectiveness, update training
materials as needed, and promote the training internally? In that case, the
scope of your project involves managing the entire creation, delivery, and
maintenance of a training program.

Or is your goal to simply create the training materials? Or should your focus
be limited to launching the new training, including promoting it to manage-
ment and staff? These goals indicate very different projects, each with its
own set of deliverables, tasks, resources, schedule, and costs. Writing a goal
statement helps you focus on such a project from the outset.

Taking a Look at Your Project’s Scope

When you understand your goal, you can begin to define the specific param-
eters of the project. This is often referred to as a project’s scope.

A scope is not a goal

Though some confuse them, a goal is not a definition of scope. Here’s how
they differ. Take a look again at this goal statement from the previous section:

The goal of the project is to upgrade the shopping cart feature on our Web
site to be easier to use so we can increase online sales by 25 percent.

A scope statement for this same project might look something like this:

This project will involve all the steps involved to design and implement a
new shopping cart feature (but does not include maintaining or refining it
once launched). The cost of the project will not exceed $25,000 and imple-
mentation must be completed before October 1 to accommodate holiday
sales traffic. The new shopping cart feature should help to increase sales
by allowing customers more options to review their orders, give them
more frequent opportunities to shop for more items after they have added
a product to the cart, and allow them to save their cart contents and
come back to complete the sale at a future date. The new feature must
function on our existing Web technology infrastructure.

Writing a scope statement

Scope statements define both what a project will involve and what it will not
involve. In our example here, the scope statement specifies that the main-
tenance and refining of the shopping cart feature, once launched, will be
handled by some other project team.

You typically get into specifics about the project budget, timeframe, and
deliverables in a scope statement. You shouldn’t include every single detail,
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but you should have enough information that a project team can understand
the most important parameters of the project. Together, a goal statement
and a scope statement are two valuable tools for focusing yourself and your
team and keeping you on track as you proceed.

If you take the next logical step in pinning down your project at the outset,
at this point you would create what'’s called a project charter. This would
include specifying a project name, getting authorization in writing to begin
the project as of a certain date and to draw on a specified budget, creating
a list of responsibilities, and having those with an interest in the project
(called stakeholders) sign off giving you authority to run the project. You
can use your goal and scope statements to help you obtain the various
pieces of your project charter.

Breaking Your Project into Phases

How does all this goal and scope analysis relate to Project? We're glad you
asked.

When you start a new project schedule in Project, one of the first things you
will do is begin to enter individual tasks. Knowing your goal and scope helps
you to identify the steps you should be performing to accomplish them.

Thinking things through

Before you create your first task, you should probably begin to think
beyond the scope of your project to more detailed project parameters.
These parameters help you determine what tasks to include in your project.

For example, you might consider

4+ Deliverables: These are tangible products, services, or results that
you’ll produce during your project. Somewhere in your project should
be tasks that reflect the delivery of each deliverable.

4+ Key Dates: In addition to the project end date, do you have to meet
other key dates along the way? A rough timeline might help you figure
out the general order of tasks.

4+ Completion Criteria: How will you know when you’re done? Do you start
up the new service and that’s it, or do you have to test it for a week
before your job is done? Knowing your completion criteria gives your
team something specific to aim for and helps you create the last phase
of your project.

4+ Expectations: Knowing what you expect from your team, management,
and yourself can help you identify some tasks. If you expect your team
to hold a quarterly debriefing meeting and submit a progress report, you
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Figure 3-1:
Phases form
the upper
level of your
project
outline.

might include such a task in your project. If you expect management to
sign off on a prototype, a task such as Prototype Approval is logical.

4+ Potential Risks: I[dentifying potential problem areas can help you build
in some checks and balances to help avoid or minimize them. For exam-
ple, you may create tasks that contain terms such as Q&A, Testing,
Review, Debrief, and Revise to monitor or fix problems along the way.

’ a
It’s just a phase
Many people prefer to start at the upper level of detail in the project by

defining the major phases. Within each phase are the detailed tasks that are
essentially steps to complete the phase.

Figure 3-1 shows the major phases of a Web site implementation project. With
the scope of your project in mind, be sure you know what your last phase is;
in the earlier example of adding a shopping cart feature, the last phase might
be to hand off the project to a team that will handle the maintenance and
refinement of the feature after it’s implemented.

Book Il covers specifics about how to organize a project into major phases
and subtasks.
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Choosing how granular to make your tasks

When you have the major phases of your project in place, you can begin to
add tasks. People who are new to project management or to Project some-
times overdo it at this stage, creating a task for just about every activity they
can imagine. Others don’t put down enough detail to ensure that all require-
ments for the project are met. So how much detail is enough?

We wish we could tell you it’s a science, but it’s not. However, here’s
some guidance about how to identify tasks. You should include tasks that
indicate

4+ The start of a phase: For example, the first step in hiring a vendor might
be to send out a request for proposal.

4+ Key milestones: These can be points in time such as approvals, completed
reviews, or confirmation of a deliverable. Milestones help you measure
your achievements in a project.

4 Action steps that must be completed before a next step can occur: If
you have to obtain a permit before you can begin to build a house, don’t
skip the permit task!

You don’t have to include steps that are either too detailed or not project
specific, such as

4 Tasks that your team members should keep track of themselves as they
manage their own time to produce a result (it’s the result you need to
track)

4+ Everyday work tasks such as frequent staff meetings, refilling the copy
machine with paper, or booking travel arrangements

Figure 3-2 shows a project outline for a marketing project. This schedule is
too general to be very useful.

Figure 3-3 shows a project that has way too much detail. You would spend all
day every day tracking the progress on such tiny tasks.

Book

Chapter 3

£8pNjou| noA pynoys

sysej Jeypp isnp



42 Breaking Your Project into Phases

Figure 3-2:
With no
specific
steps, this
projectisn’t
very useful.
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Figure 3-4 shows a much better level of task detail, with enough tasks to keep
track of progress and be sure all bases are covered, without micromanaging
people or activities.

As you work on projects using Project, you will get better and better at
defining the level of task detail you should create. One good rule is to not
create more tasks than you have the means or the time to track in your
Project schedule.
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Chapter 4: Exploring the Project
Environment

In This Chapter

+ Looking at menus and toolbars
v+~ Navigating Project

v+~ Exploring Project views

v Modifying views

v Displaying various tables of data
v Displaying task panes

1 Working with Project Guide

In 2007, Microsoft launched a dramatically new interface for selected
products in the Microsoft Office family, of which Microsoft Project is a
part. However, Microsoft Project wasn’t one of the Office family products to
get this new interface-lift, so it sports a very similar look to the previous
edition, based on menus and toolbars that are familiar to most folks.

In this chapter, you get a glimpse of Project 2007 menus and tools, as well
as the various views that make up Project. These views offer you different
perspectives on data that can help you manage your projects efficiently. In
addition, Project Guide offers a wizardlike interface that can walk you
through the development of a new project. Finally, task panes such as New
Project allow you to work with handy sets of tools to complete certain
activities.

This chapter helps to familiarize you with all that the Project environment
has to offer.

Exploring Menus and Toolbars in Project

Menus and toolbars have been the way to get work done in software for the
last several years. Here’s a quick overview of the menus and toolbars that
Project 2007 offers.



46 Exploring Menus and Toolbars in Project

Menu basics

If you've ever used a computer, you know what a menu is. Menus such as the
one shown in Figure 4-1 contain sets of commands that might perform a
function or display a dialog box.

In Project 2007 menus, tool icons are displayed to the left of any command
that has a corresponding tool. Also, in the View menu, a check mark appears
to the left of any items that are currently displayed in the view, such as Gantt
Chart, or the View bar (which you read more about later). Some menu com-
mands also display keyboard shortcuts (such as Ctrl+X) to their right.
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Figure 4-1: p
The Edit
menu of
Project

Corresponding tool icons

If you use Project Standard, you have ten menus available to you, as
described in Table 4-1.

Table 4-1 Overview of Project Menus

Menu Purpose Typical Commands

File Common file operations Save, Open, Print, Send to
Edit Modify project entries Cut, Copy, Paste, Clear, Go To

View Switch or customize views Calendar, Gantt Chart, Toolbars
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Figure 4-2:
Tools for
working
with
resources
are all
together on
this toolbar.

Exploring Menus and Toolbars in Project 4 7

Menu Purpose Typical Commands

Insert Insert objects, resources, or tasks New Resource, Project, Drawing

Format Modify the format of project elements  Font, Bar, Timescale, Text Styles

Tools Perform various operations Resource Sharing, Tracking,
Spelling

Project Make overall project settings Sort, Filtered for, Outline, WBS

Report Generate reports for your project Visual Report, Reports

Window Organize display New Window, Arrange All, Hide

Help Access the Project Help system Microsoft Office Project Help,

Microsoft Office Online

If you use Project Professional, you also have a Collaborate menu available,
which lets you interact with others via Project Web Access or a SharePoint
site. Book X explores these collaborative capabilities in more detail.

Displaying and using toolbars

Toolbars (which vary slightly depending on the version of Project you're work-
ing with) are simply another way of invoking commands. You can display sev-
eral built-in toolbars in Project 2007, such as the Resource Management
toolbar shown in Figure 4-2.

’ EE i | 8 NewResourceFrom~ & & S | F T -

Follow these steps to display or hide a toolbar:

1. Right-click in the toolbar area.

2. In the list of toolbars that appears, click the one you want to display.
The toolbar appears near the top of the screen.

3. To hide a toolbar, right-click the toolbar area.

4. In the list of toolbars that appears, click a selected toolbar to deselect it.
The toolbar is hidden.
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To save space on your screen, you might want to show toolbars on one row
instead of two. To do this, click the arrow at the far right of a toolbar and
choose Show Buttons On One Row from the list of commands that appears.

Navigating Project

Figure 4-3:
When
displayed,
the View bar
is located
along the
leftin every
Project
view.

Project 2007 offers a wealth of views that provide different perspectives on
your project. Throughout this book, we advise you on which view to display
to get certain types of work done most efficiently. But first things first: Here
we tell you the basics about how to display and change views.

Getting to a view

You can move from one view to another in Project by using the View bar or
the View menu. The View bar runs along the far left side of every view, as
shown in Figure 4-3. Simply click any view icon there to display that view.

View bar
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Figure 4-4:
Dozens of
views are
available for
display in
Project.
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If the View bar doesn’t appear on your screen, choose View=>View Bar to dis-
play it.

Eight commonly used views are already displayed on the View bar: Calendar,
Gantt Chart, Network Diagram, Task Usage, Tracking Gantt, Resource Graph,
Resource Sheet, and Resource Usage. In addition to these views, you might

want to use any of the few dozen other views available. To display views not
shown on the View bar, follow these steps:

1. Click the arrow at the bottom of the View bar to scroll down to the
bottom.

2. Click the More Views icon.
The More Views dialog box appears, as shown in Figure 4-4.

You can also access the More Views dialog box by choosing Viewr>More
Views.

i

More Views
Views:
|Bar Rollun
Calendar
Descriptve Network Diagram
| Gatt Chiart
|Leveling Gantt
Milestone Date Rollup
Milestone Rollup
Multiple Baselines Gantt
Network Diagram
| Relationship Diagram

=
(1]
=

Edit....

|| copy...

‘ Organizer.,

Cangcel

g

3. Use the scroll bar to locate the view you want.

4. Select the view you want and click Apply.

Scrolling to get a better view

The simplest views, such as Calendar view, have a single pane with horizontal
and vertical scroll bars. Other views, such as Resource Usage view (see Figure
4-5), sport two panes. Each pane has its own horizontal scroll bar, but they
share the vertical scroll bar, so the panes move up and down together.

In views with two panes, the pane on the left is referred to as the sheet. This
is a spreadsheetlike interface that contains columns of information. The pane
located on the right of this view is called the chart. The chart uses bars, sym-
bols, and lines to represent each task in your project and the dependency
relationships among them.
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At the top of the chart area is the timescale. This tool is used as a scale
against which you can interpret the timing of the taskbars. To see your plan
in greater or lesser timing detail, you can modify the time units used in the
timescale. For example, you can look at your tasks in detail over hours or in
a broader overview in weeks or months. Figure 4-6 shows a two-pane view
with a sheet, chart, and timescale.
3

See the “Changing the timescale” section, later in this chapter, to find out
how to change the time increments displayed in the timescale.

You can click and drag the horizontal scroll bars in either pane to view
additional columns or additional time periods in any pane that includes a
timescale. Timescale panes cover the life of the project; in longer projects,
you can find yourself scrolling through years of time.

Use these different methods to work with horizontal scroll bars:

4 Click the scroll box and drag it until you reach the location in the
pane that you want to look at. When you click and drag the scroll box
to move through a timescale display, the date display indicates where
you are at any time in your scrolling calendar. Release the mouse button
when the date display matches the date you want to view.



Figure 4-6:
The sheet,
chart, and
timescale of
Gantt Chart
view.
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4 Click to the left or right of the horizontal scroll box to move one page
at a time. Note that a page in this instance is controlled to some extent
by how you resize a given pane. For example, with a timescale pane and
a timescale set to weeks, you move one week at a time. In a sheet pane
displaying three columns, you move to the next (or preceding) column.

Click the right or left arrow at either end of a scroll bar to move in

smaller increments. With a sheet pane, you move about one-half column
per click. In a timescale view with weeks displayed, you move about one

day at a time.
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Jumping to a particular point in time
To reach a specific timeframe in your Project plan, you can also use the Go

To command on the Edit menu. In the Go To dialog box, you can enter one of
two criteria to find a task:

4+ A task date you select from a drop-down calendar.

4+ A task ID, which is assigned automatically when you create tasks. This
number provides a unique identifier for tasks in the plan. See Book III for
more about the structure and organization of tasks in a project.
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Finding Another View

You can also click the Go To Selected Task tool (or press Ctrl+Shift+F5) to
scroll the timescale to show the taskbar for a selected task in the sheet pane.

You can use the View=>Zoom command to change the timescale that is dis-
played in the Chart pane. For example, you can show a week of tasks or the
entire project.

Finding Another Uiew

Views are a way to organize information in the software so that you can find
useful information in logical ways. A typical Project plan contains a lot of
data. The many views offer you a way to examine logical subsets of data. You
need these many views because, if an average spreadsheet document is as
complex as a calculator, your average Project plan is more like a souped up
master computer that tracks and controls our national debt.

For example, in a typical Project plan, you can find data about the following:

4+ Resources: The resource name, resource type, rate per hour, overtime
rate, assignments, department, cost per use, and more

4 Tasks: The task name, duration, start and finish dates, assigned
resources, costs, constraints, and dependencies, for example

4+ Project timing and progress: Several types of calendars, project start
and finish dates, percentage of tasks completed, resource hours spent,
baseline information, critical path information, and more

4+ Financial information: Earned value, time and cost variance, and pro-
jected costs for uncompleted work, for example

You might mostly work in two or three views, but still, finding out how to use
the many Project views to enter, edit, look at, and analyze Project data is an
important basic Project skill. When you know what’s available and how to
display it, you can pick and choose what you need.

For more about modifying the format of elements displayed in a view, see
Book VI, Chapter 1.

A popular view: Gantt Chart

Gantt Chart view is like your comfortable neighborhood hangout, the cafe
where most people end up and like to linger. It’s the view that appears first
when you open a new project. This view, shown in Figure 4-7, is a combina-
tion of spreadsheet data and a graphical representation of tasks. Gantt Chart
view is popular because it offers a wealth of information in one place.
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Gantt Chart view is one of those two-sided views, so it has two major sec-
tions: the sheet pane and the chart pane.

Gantt charts were first developed by engineer Henry L. Gantt in 1917 to deal
with production-control projects in manufacturing. Today they’re used in all
kinds of industries to organize all kinds of projects.

Following the (work)flow: Network Diagram view

Network Diagram view, which is shown in Figure 4-8, is a more visual repre-
sentation of data. The organization of information in this view represents the
workflow in your project with a series of task boxes.

Lines run between these boxes to reflect the sequence of tasks as well as
dependency relationships between them (see Book IV, Chapter 3 for more
about dependency relationships).

In Network Diagram view, the earlier tasks are on the left, and later tasks and
subtasks are to the right. Tasks that happen in the same timeframe are
aligned vertically above each other. Tasks with an X through them have been
marked as complete.
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Figure 4-8:
Network
Diagram
view puts
important
task
information
in a visual
context.

More history: Traditionally called a PERT chart, this method of diagramming
workflow was developed by the United States Navy in the 1950s to help build
the Polaris submarine, a pretty hefty project by anybody’s standards.

Note that there is no timescale in this view. That’s because the view isn’t
used to see specific timing but rather to see the general order and flow of
tasks in your project. However, you can set up task boxes to hold specific
timing information about each task, such as the start date, finish date, and
duration. (Customizing the information in the task boxes is described in
Book VI, Chapter 2.

Controlling time with Calendar view

Look at just about any workplace in the world and you’ll find a calendar.
Calendars are one of the most familiar tools for managing our time, and
therefore, logically, Calendar view is one of the many views offered in
Project. Calendar view, as shown in Figure 4-9, resembles your wall calendar,
representing each week of the month as a row on the calendar.

Calendar view can be set up to display from one to six weeks (or more, by
using a Custom setting in the Zoom dialog box). Calendar view sports a
timescale, which you can change to show a 7-day or 5-day week. If you dis-
play a 5-day week, shading indicates working and nonworking days based on
the base or resource calendar you've selected.
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Changing Views

The array of views in Project is impressive, but consider this: Every one of
those views can be customized to show a variety of information. Given this,
the possible view variations become astronomical.

For example, you can choose to show different columns of information in
spreadsheets, different labels on the task boxes in Network Diagram boxes
or taskbars in Gantt Chart view, or different sets of data in graph views. You
can modify the size of panes in certain views and adjust the timescale to
reflect different time periods in your project.

This flexibility helps you focus on different aspects at various times over the
life of your project. If you're having a problem with costs, for example, you
might take a look at Resource Usage view and insert several columns of cost
information, such as resource rates and total actual costs. If your project is
taking a lot — we mean a lot — more time than you expected, you might
want to display Tracking Gantt view and look at a bunch of columns with
timing and dependency data or examine the project’s critical path in the
chart pane. If you need to display more of the sheet area so that you can
read columns without having to scroll, you can do that, too.

This is the section where you find out how to show a variety of information
in each view.
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Changing Views

These sections cover some of the most-often used views in Project, but
many more views are available. As you work through specific elements of
Project in this book, keep an eye out for views that are useful for certain
types of project management activities.

Modifying view panes

Several views besides Gantt Chart view also include two panes. These include
Task Usage, Tracking Gantt, and Resource Usage views. You can modify the
information that you see in the sheet pane as well as the scale for timing in the
chart pane. You can also display information near taskbars in the chart pane.

Resizing a pane

In views that include more than one pane, you can reduce or enlarge the size
of each pane. This allows you to see more information in one area, to suit
your focus at the time.

The overall area taken up by the two panes is constant, so when you enlarge
one pane, you reduce the size of the other.

Follow these steps to change the size of a pane in a view:

1. Place your cursor over the edge of a pane.

2. When you see a cursor that’s a line with two arrows (one pointing left
and one pointing right), click and drag.

e Dragging to the left enlarges the pane on the right.
e Dragging to the right enlarges the pane on the left.
3. Release the mouse button.

The panes are resized.

Note that if you display the Project Guide or another task pane, such as New
Project, Project automatically resizes the sheet and chart panes to accom-
modate the additional pane.

Project Guide and the View bar take up valuable on-screen space, so a quick
way to see more of any of the project information in any view is to hide the
Project Guide or View bar. The Project Guide toolbar includes a Hide/Show
Guide button that you can click to hide or display it. Choose Vieww>View Bar
to turn the View bar on and off.

Changing the timescale

At times during the life of your project, you might want to focus on the
details or switch to the big picture. The ability to modify the timescale to
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display your plan in larger or smaller time increments is a handy feature to Book |
help you get the focus you need. Chapter 4

A timescale consists of a possible total of three tiers, as you can see in Figure
4-10. You can use them to display different time increments. For example, the
top tier could mark off months, whereas the middle tier could mark off weeks,
and the bottom tier could mark off days. This variety of detail lets you easily
observe overall task length as well as points in time during the life of the task.
You can use all three tiers, only the middle tier, or the middle and bottom tiers.
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You can customize the timescale in several ways. You can

4+ Modify the units of time and the alignment of each tier.

4 Include tick lines to mark the beginning of each increment on the
timescale.

4 Include nonworking time on the timescale. For example, if you include
an indication of nonworking time on a project for which weekends are
nonworking, Saturdays and Sundays are indicated by a shaded area in
the display, which can help you visually differentiate between weeks.

4+ Display text labels near taskbars. Labels can be placed above, below,
inside, or to the left or right of the taskbars.

4+ Change what data is included in text labels.

(= Mictosoft Project - New Product Launch = & =]
4] Fle Edit View Inset Formet Tools Brojsct Report Window Help 3 QUESHON ) hei -8 x
DS Sid Ba -1 B =858 @ i o# 4 # = Shows Al -0 -8B U 4
|@  |TaskName _ May207 .
[idar 25, 07 [Aprg, 7 [ARr 15,07, [Apr22, 17 Aprs, 07 T
g [SISIM[TIWITIE]S (TIF]S|S[WITIWITIFIS|S[WITIWITIF]S S [WTWITIE[S|SWTIWTIE]S]:
0 I' New Product Launch 5
i@ Read the note for an ex) oqn
z = New Product Launch =
E = Phase 1 - Planning —
B Identify the launc i i ing, Marketing, Sales,Product Support,Field Service,Product Manager
| Deterrine saies 1| | Product Manager
B Define launch go Product Manager
i =l Determine part| |
B identify chanr| Marketing
N [dentify retail Marketing
10 Identify online. Marketing
=| K =/ Establish Laumi —
Az | Mentiy budge) | &-roguet manager
13 aotan launch Product Manager
7 Flanning COMPLE
18 = Phase 2 - Initiation
— 6 & Kickoff product k| | Product Manager
| = Marketing
Figure 4-10: [ Define creati Product Manager
19 = Prepare Me ]
The 2 Review ol o Market
. = Define pre T iarketi
timescale z e i
2 Define sal
allows you 24 Define infs ﬁ
to view time 2 VR :
% = Engineering | |
from several ol i produc i
) = Manufactiring
perspec- R Prepare forv
. ET = Sales
tives. ] v — &l




58 Changing Views

\\J

Figure 4-11:
The Time-
scale dialog
box allows
you to
customize
the time-
scale.

Especially in projects where you display many columns of data and a lengthy
schedule, a taskbar can be placed far to the right of the sheet pane data,
making it hard to track which task the taskbar is associated with. In that
case, it can be useful to include information, such as the task name or start
date, alongside the taskbar to help you read your plan more easily.

To modify the timescale, follow these steps:

1. Right-click the timescale in any view that contains one and then
choose Timescale.

The Timescale dialog box appears. (See Figure 4-11.)

p
Timescale

Top Tier l Bottom Tier I Mon-working tirme I

Middle tier formatting

Units:  |Months - Label: |January 2002 j ¥ Use fiscal year

Count: |1 j align:  [Left A4 W Tick lines

Timescale options

Show: |TWD tiers (Middle, Bottom) j Size:| 100 :I % ¥ Scale separator

Freview

| June 2004 [ July 2004 | August 200
T2[15]18]21 [24127]30] 2 | 5 | 8 [11]14]17 [20[23]26129] 2 | 5 | 8 [11[14]17]20/23]26 /29 1 |4 |7 11

Help oK | Cancel

2. Click a tier tab and select styles for Units, Label, and Align.
3. Set the count.

For example, if your Units choice is weeks and you change the Count
option to 2, the timescale appears in two-week increments.

4. If you don’t want to display a certain tier, select One Tier or Two Tiers
from the Show drop-down list (under the Timescale Options section).

5. 1f you want Project to use fiscal year notation in the timescale, select
the Use Fiscal Year check box.

For example, if your 2006 fiscal year begins July 1, 2006, 2007 is used on
all months in the fiscal year. The fiscal year is set in the Options dialog
box on the Calendar tab.

6. To show marks at the beginning of each unit of time, select the Tick
Lines check box.
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Figure 4-12:
You can
select any
one of a
number of
columns to
insert.
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7. Repeat Steps 2-6 for each tier you want to modify.
8. Click the Non-Working Time tab.
9. In the Draw options, select the one you prefer.

Your choices are to have the shaded area for nonworking time appear
behind or in front of taskbars or just not appear.

10. In the Color or Pattern list, select different options for the shading
format.

11. Click the Calendar setting and select a different calendar to base the
timescale on.

You can find out more about calendar choices in Book II, Chapter 4.
12. Click OK to save your new settings, which apply only to the timescale
for the currently displayed view.

You can use the Size setting on the three tier tabs to shrink the display pro-
portionately to get more information on your screen or the printed page.

Choosing to display different columns

Each spreadsheet view has certain default columns of data that are stored in
something called fables, which are described in the next section. In addition
to displaying predefined tables of columns, you can also modify any spread-
sheet table to display any columns you like.

Follow this procedure to show selected columns of data:

1. Right-click the column heading area and then choose Insert Column.

The Column Definition dialog box appears, as shown in Figure 4-12.

Column Definition
Field name: [ |

Tite:

Align fide: [Center E!
Align datz: \P.Eh[ {3

Width; w8 V| Header Taxt Wragping

gestit | [ ook | [ cameel |

2. In the Field Name list, select the field that contains the information
you want to include.

3. If you want to enter a different title for the field, type it in the Title box.

The title in the current view appears in the column heading for this field.

Book |
Chapter 4
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Zooming in and out

One way to modify your display for any Project
view is to use the Zoom In and Zoom Qut but-
tons on the Standard toolbar. This feature
shows you a longer or shorter period of time in
your project without you changing the timescale
settings. When you need to see several years at
a time in your project, for example, click Zoom

Out several times until you fit as many months
or years as you like in the view. You can also
choose View>Zoom and specify periods of time
to display in the Zoom dialog box, or even
choose to have the entire project appear on-
screen.

4. Use the Align Title, Align Data, and Width options to modify the

column format.

5. Click OK to insert the column.

a\\J

To hide a column, right-click its heading in the sheet pane and then choose

Hide Column.

Changing tables

In any view with a sheet pane, such as Gantt Chart view, you can change
what information is shown in the sheet by using tables. Tables are preset

combinations of columns of data. Displaying the appropriate table helps you

deal with certain tasks, such as using the Tracking table for recording activ-
ity on tasks or the Entry table for entering new task information.

You can easily display a different table by following these steps:

1. Choose View=>Table.

2. Select a table (such as Entry or Cosf) from the submenu that appears.

3. To view more tables, click More Tables from the submenu.
4. Click a table and then click Apply.

The columns for the selected table are displayed.

SMBER
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You can also customize the column display for any table by displaying or

hiding individual columns of data one by one. (See Book VI, Chapter 2 for

more about customizing tables.)




Figure 4-13:
The New
Project task
pane offers
various
options for
getting
started.

Displaying and Hiding Project Guide o1

Displaying task panes
Project 2007 has a couple of task panes. Task panes display a side panel of
tools and text boxes you can use to work on a particular type of task.

A New Project task pane (see Figure 4-13) displays when you choose File=>
New, and a Document Management task pane appears when you choose
ToolsDocument Management, for example.

MNew Froject X
AN
HNew

1 Blank Project

=) From existing project..

Templates
Search anline for:

"2 Templates on Office Onins

||_:. On computer, .,

= On Web sites,

Recently used templates

Marketing Campaign Flanning
Mew Business
Mew Product Launch
Hame Move

Displaying and Hiding Project Guide

Project Guide is a special task pane that offers you a great way to get a new
project going. It walks you through a series of steps that ask you to enter
certain project information. Based on your choices and entries, Project
Guide then takes care of the creation of various aspects of your project, such
as tasks and resources.

Book II, Chapter 4 provides detailed information about using Project Guide.

Book |
Chapter 4
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To display or hide Project Guide:

1. If the Project Guide toolbar isn’t showing, right-click the toolbar area
and choose Project Guide from the menu that appears.
2. Click the Show/Hide Project Guide icon to the far left of the toolbar.

The Tasks pane appears (see Figure 4-14).
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Chapter 5: What's New
in Project 2007

In This Chapter

v+ Understanding the different versions of Project 2007

v+~ Using the Multiple Undo feature

v Turning on Change Highlighting

v~ Identifying task drivers

v~ Appreciating the value of Visual Reports and report templates
1 Making use of Cost resources

v Defining and tracking budgets

If you're one of those people who have to be in on anything new, or if you
used Project 2003 and need a heads up about what new features in
Project 2007 are worth checking out, this chapter is for you.

In this chapter, we offer a rundown of the various versions of Project 2007 that
are available to help you choose the right one for your needs. We also provide
an overview of new features, including Multiple Undo, Change Highlighting,
task drivers, Visual Reports, Cost resources, and budget tracking. Each of
these features will make your Project experience a little more fruitful.

Each of these features is covered in more detail in individual chapters
throughout this book. Check the index to find additional coverage!

Exploring the Many Versions of Project

A\

Microsoft has, for some time, offered several different versions of Project
based essentially on the size of your organization and projects. Project 2007
is no exception, with two individual user packages and what Microsoft calls
the EPM, or Enterprise Project Management Solution.

Enterprise Project Management simply means project management that
takes place in an organization that is large enough to have departmental and
geographical boundaries across which people must work on projects.
Collaborative tools, most of which are hosted online on a company intranet
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or the Internet using Microsoft SharePoint, are vital for enterprises. Book X
covers Enterprise Project Management in more detail.

Here’s the rundown of Project products available to you, starting with the
two individual user offerings:

4+ Project Standard is the meat and potatoes version of Project, with lots of
the core functionality, but some of the fancier features are omitted.
These core tools help you manage schedules and resources, but with less
ability to share your project information with others. The product inte-
grates well with Microsoft Office 2007 products such as Excel and Word.

4+ Project Professional 2007 contains all that Standard does but adds
some collaborative tools for sharing resources and information with
others. Professional is integrated with Microsoft Office Project Server
2007; when your IT person sets this up, you can keep folks updated and
keep your project updated by using Project Web Access tools.

4+ Enterprise Project Management (EPM) Solution helps an entire organi-
zation manage a portfolio or projects and standardize their project
practices. This solution requires that you own several products, includ-
ing Project Professional, Project Server, Project Server Client Access,
and more. At this level, your organization is probably working directly
with a Microsoft salesperson to buy licenses for these many products,
and your IT people have to get involved to set the whole thing up.

Getting out of Hot Water with Multiple Undo

Multiple Undo has been a requested feature in Project for years. Though an
undo feature sounds simple, it can have a lot of value when working with a
project because individual changes to timing in your project plan can cause
hundreds of changes in a large schedule. For that reason, undoing several
actions in a row in Project was a major technology challenge.

Many project managers find that the ability to try out different scenarios
that involve several changes to a project is extremely useful. In the past, you
had to do an action and then undo it, then do the next action and undo it,
and so on, which is time-consuming and doesn’t really enable you to see
cumulative effects.

With Multiple Undo, you can try out several changes and then undo the whole
list of changes or a portion of them at once. Because you often want to try out
several changes when finalizing or making adjustments to a project — for
example, changing the timing of a set of tasks — Multiple Undo can be very
handy.
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Figure 5-1:
Undo more
than one
task,
sequentially.
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Be aware that you have to undo all changes in order. For example, if you
made six changes and you want to undo the fourth change, you have to
undo changes four through six.

Here’s how to undo more than one change:
1. Make all the changes you want to your schedule but don’t save the

schedule yet.

2. Click the down arrow to the right of the Undo icon on the Standard
toolbar.

You see a list of changes you’ve made (see Figure 5-1), starting with the
most recent action at the top.

3. Click the change you want to undo.

That change and all others you performed subsequent to it are
undone.
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Spotting Changes with Change Highlighting

Spotting Changes with Change Highlighting
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Figure 5-2:
Change
Highlighting
lets you see
just what
effect your
changes will
have.

You can use the brand-new Change Highlighting feature to see how the
changes you make affect your project. When you turn on Change Highlighting
and take any action that changes your project’s schedule, a highlight appears
on every task that has been affected (see Figure 5-2). Because it’s easy to miss
how a single change can impact dozens of other tasks, Change Highlighting
provides a visual clue to help you avoid surprises down the road.

You can toggle this feature on and off by choosing Viewr>Show Change
Highlighting/Hide Change Highlighting.

Change Highlighting shows you only the results of the last change you made
and works only on changes that have an impact on the timing of tasks in
your schedule.

(=] rosolt Project - New Business ==
4] Ble Edit View Inset Format Jools Project Beport Window Help o stion faj he - a8 x
) e Bl s A 9. B =g 56 @ ;,4$=§§mwv Artal -8 - B £ U = |
d Tasks - (Resources - Track - FReport - _
Identify operating cost slements
@  Tasklame Duration Siart Fish  [Prode (L |JonZ8. 07 _|Fens, 07 — [Fep11,07 -
DR || Ol e it I | i bW .| WIT[F[S S[M{TW[T[F S (S| T W7 F[S | EIMTWIT[F[H
o = New Business 127 days Mon 1/1/07 Tue 6/26/07 :
T = Phase 1 - Strategic Flan 26 days Mon /107 Mon 246107 =)
z = seff-Assessment 4days Mon 14107 Thu 1iai07
3 Define business visian 1 day Mon 1117 Mon 11107
4 dentity avaiable skils, informaton * 2 d0ys Tue 12007 Wed 16307, 2
7 Decide whether ta procesd 1 day ThuAT T AT 4
& = Define the Opportunity 12 days Fr1si07 Mon 4izzi07
7 Research the market and competii | day FASAT ST S
B Interview owners of similar busine 7 oays Mon /BT Tue UIENT 7
T8 entify nesded resources 2days Wed 1M7/07  Thu 118107 8 isorPeers
10 I Wenty operaing costekments | 2oays FriiNa7 Mon 1220079 boountsnt
n = Evaluate Business Approach 4days Tue 12307 Fri 126007 —_—
12 Define new entty requirements 1 day Jue 3107 Tue1/237 10 - Manager
T dentify on-going business purcha: 1 day Wald 2407 Wed V2407 12 Manager
T3 Research franchise possivilties | day. Thu 125007 Thua/2507 13 Manager
15 Summarize business approaches 1 day FrllBMT  Fri /28007 14 b=
16 = Evaluate Potential Risks and Rew: 7 days Wed 1724107 Thu 2407
ok Assess market iz and stabilfy 2 days Wed 1407 Thu 125007 12 bi‘u's nets advisar
8 Estimate the compettion | day. Friv2si07 Fridi2s7 17 - advisor
19 Assess nested resource avaiabi 2days Mon 12807 Tus 1/30/07 18 3 Business advisor
B Evaluate realistic mitial market shal 1 day Wed 131107 | Wed 121007 19 Business advisor
21| Datermine financial requirements 2 days Mon 112807 Tire 1430007 15 Business advisor
23 Review personal suttabilty | day Wed 1/31/07  Wed 1/31/07| 21 ¢
= Evaluate iniial proftabiity 1 day The2HAT  TWIANT 22
2 | Reviw and modify the strategic plan 20ays Frialziny  Won 20T 23,20
25 Canfirm decision o proceed 0 days Mon 2507 Mo 2/5/07 24 L&
% = Phase 2 - Define the Business Oppor. 27 days Tue 2607 Vied 314107 =
27 - Define the Market 13 days Tue 206007 Thu 22207 i
= Access avaiable nformation i day Tue2Bil7  Tus N7 25 i &5 Business advisor
= Create market analysis plan 2 days Wed 27T Tho2BNT 28 i [Gihﬁiness advisor -
“id ! # ST s 1 | =y |
Ready




Knowing What's Driving Your Tasks 67

Book |
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When you create a task such as Print Brochure in a project, several factors

might affect its timing. It might have a constraint causing it to start no later s

than a certain date or a dependency relationship with the earlier task, 5? s

Design Brochure. A new feature called Task Drivers helps you understand all '§' prs

the settings that are affecting the timing of a task. § ?
(=]

~ -

=

The Task Drivers feature helps you recognize the many possible settings that
might affect your tasks, which can include

4 Actual Start Date or Assignments: You've entered an actual start date,
or you have made a resource assignment to a task and the resource isn’t

available.

4+ Leveling Delay: If you turned on leveling to deal with resource overallo-
cations, it might have caused a delay on a task.

4+ Constraints: You apply a constraint to a task, such as forcing it to finish
on a certain date.

4+ Summary Tasks: Summary tasks’ timings are driven by the timing of
their child tasks or subtasks.

4+ Dependency Relationships: A predecessor task can cause changes in a
task’s timing.

To display task driver information, follow these steps:

1. Scroll to the task in your project that you want to review.

2. Click the Task Drivers icon on the Standard toolbar. (It looks like a
taskbar with an arrow and question mark above it.)

The Task Drivers pane appears (see Figure 5-3), explaining the various
conditions driving a task’s timing.

3. Click another task to display its drivers.
4. Click the Close button in the Task Drivers pane to close it when you’re
done.

See Book IV, Chapter 1 for more about how task drivers can help you fine-
tune task timing in your project.
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Figure 5-3:
The Task
Drivers
pane shows
you the
influences
on your
task’s
timing.
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Making Reports More Visual

Many people swear by PivotTable reports in Excel and Visio because they
allow you to compare data from a variety of perspectives. Pivot tables offer
perspectives that are especially useful for data analysis. If you're a PivotTable
fan, you'll be glad to know that the same capability has come to Project 2007
in the form of Visual Reports. Pivot tables allow you to view data from a vari-
ety of perspectives beyond the standard Project report capabilities.

The Visual Reports feature allows you to select the fields you want to
view and compare and to modify your reports in a variety of ways (see
Figure 5-4).

Project offers six categories of Visual Reports as well as custom reports that
you can build yourself. Some of these categories are based on timephased
data (that is, data distributed over time, such as allocations of resource time
or costs).



Figure 5-4:
Visual
Reports
allow you to
choose
among
several
fields to
display.
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Visual Report categories include

+

See

Task Usage: Based on timephased data for tasks, this category of report
gives you a peek at information such as cash flow and earned value over
time.

Resource Usage: Based on timephased resource data, these reports
include cash flow, resource availability, resource costs, and resource
work data.

Assignment Usage: Also based on timephased data, this category of
reports provides information in areas such as baseline versus actual
costs and baseline versus actual work.

Task Summary, Resource Summary, and Assignment Summary: These
three categories of reports provide diagram views of a variety of work
and cost data and are not based on timephased data.

Book VI, Chapter 4 for in-depth information about working with Visual

Reports.

6—1
i+

Ciliioard 5 Form Aliarmant fiumber

a9~ = adrs1 [Compatibility WMode] - Microsoft Excel

Home | Insert Page layout  Formulas Data Review  View Adddns

i
&

2 e
B pormat~ || 2= Fijer
el Editing

4 4% v Chartl - Resource Ussge- “J W

Resource Work Availability Report

u Mwerk

5000

4500

4000

3000

5 2500
EH

2000

1500

2008 2007

-

Ready

(B e

Book |
Chapter 5

£002193l01d
u1 Map SJey



70 A New Resource: Cost

A New Resource: Cost

Figure 5-5:
Choose the
type of
resource
you need in
the Task
Information
dialog box.

If you've used Project in earlier versions, you worked with material and work
resources. Material resources might include tons of steel or yards of fabric;
the units of these resources have an associated cost and the more units you
use, the more it costs you. Work resources are typically people who get paid
so much per hour that they put in on a task; the more hours they work, the
more it hits your budget.

In Project 2007, there’s a new resource in town called the Cost resource. Cost
resources have a set cost associated with them that you create in the Task
Information dialog box, which displays when you double-click a task name in
any view (see Figure 5-5). Unlike material resources that affect your budget
by the number of units you use and work resources whose hourly costs tally
up dollars, Cost resources have a fixed cost that you assign.

Task Information ==

General 1 Predecessors Resources Advanced Notes 1 Custom Fields ]
Name: |1d;nh'fy operating cost elements | puration: |2d | [C]Estmated
Besources:

| Conference fee -

| Resource Name Units Cost

Business advisor 100% §0.00

Peers 100% $0.00

Conference fee [ $250.00

Help | | OK | Cancel

Here’s an example of how you would use Cost resources: Say you're manag-
ing a construction project to build 20 cottages. Each cottage requires a build-
ing permit with a cost of $250. You can create a Cost resource called Permit
and assign it to each of the 20 subprojects in your overall project. No matter
how long each cottage takes to build or how many resources work on them,
your permit cost remains the same. (That is, unless you run over the allotted
time allowed by the permits for building and final inspection on each of the
cottages, in which case you’d better have a Penalty Cost resource ready to
apply!)

See Book V, Chapter 1 for more about various resource types.
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Working with Budgets

Figure 5-6:
Creating a
budget
resource.

In Project 2007, budget resources can help you track your budget against
your actual costs.

You can specify a resou rce as a budget resource by selecting the Budget
check box in the Resource Information dialog box, which displays when you
double-click a resource name in a view such as Resource Sheet (see Figure
5-6). You then assign these resources to the project’s single summary task. For
example, you might create a budget resource called Travel Budget and associ-
ate costs with it. You can then assign this resource to the project summary
task so that it’s applicable to the entire project.

Resource Information =]

General Sosts Motes Custom Fields

[Travel Budgst | mitiale: i

Resource name:

|77 - — ™ Gfﬁg:ll # = B o

Code:

Typs: \\.\liu_rk =

¥ Budgett

Change Working Time ... |

| | scaneeh. |

Using budget resources, you can display fields that allow you to compare
your budgeted cost with your planned cost. (Unfortunately, there’s often a
difference.)

For example, you might have $10,000 budgeted for travel, and in creating
your individual tasks you might have applied $11,450 in costs for individual
business trips associated with the project. The budget setting can help you
compare these amounts as you add and delete resources to or from various
tasks.

If you assign a budget resource, you can then view budgeted work at any
time by displaying the Budget Work field. Note that this field reflects only
material and work resource costs.
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Chapter 1: Building a Project Plan

In This Chapter

+* Opening a new, blank project

+ Opening project templates

v Opening a schedule based on an existing project
+~ Entering basic project information

v Saving projects

Wlen you're ready to begin your first project using Microsoft Project
2007, you start by opening a file. You can use a blank template or get

a head start by opening a template that includes sample tasks for a certain
category of project.

After you open a project, your first step is to enter certain global project
information, such as the scheduling method for the project. Finally, you
should know how to save and close a project so that it’s ready for you to
work on it another day.

In this chapter, you get going with the creation of your very first Project
schedule.

Creating That First Project

You can create a new project in three ways: You can open a new, blank proj-
ect; open a project template that contains sample tasks; or open a project
based on an existing project. In the following sections, you get a feel for the
pros and cons of each method.

Starting from scratch

If you want a clean slate to work with when you begin a new project, open-
ing a blank template is your best bet. You can start building your new proj-
ect directly in this blank schedule, which contains no tasks, resources, or
other settings except default project settings. Starting a project from the
blank template requires you to do more work inputting information, but if
your project is somewhat unique, this might be the best way to go.
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Whenever you open Project 2007, you see a blank project file on-screen along
with the Project Guide task pane. You can also open a new, blank project
schedule at any time by choosing File=>"New and then clicking the Blank
Project link in the New Project task pane (see Figure 1-1).

<® Project Guide can help you build a project. Project Guide reminds you of the
typical steps you should take in entering project, task, and resource data.
Discover more about this method of creating tasks in Chapter 5 of this
minibook.

Getting a head start with templates

You don’t have to start from scratch if your project is typical of those in your
industry, because Microsoft provides some convenient project templates to
get you going. These include projects by type: for example, an engineering
project or office move. Templates include many tasks appropriate to your
project to save you time and help you to think through your plan when you
are new to Project.

[ Wicrosoft Project - Project! = = =]
i) File Edit View Inset Formst Tools Project Report Window Help Type a question for he A x
NEH &RV EBR I = No Graup QA FEe,

o P F = Show~  Arial ~ 8 All Tasks v Ve s

i [Tasks| - Resources - Track - Report - _
@ Drasks | @  [TaskName Duration Start - »;\m‘.?cm_mms ?Trvnsffu\?u'vlT\Fls 2?;A1\5i-‘|]\3¢\t|F\s ;\mzlzT -

Plan and schedule your

project’s tasks by clicking an |:!
itern below. Clicking an item

displays tools and instructions

for completing that step,

Set a date to schedule from
Define general working times
List the tasks in the praject
Grganize tasks into phases
Schedule tasks

Link to or attach more task
infarmation

Add columns of custom
infarmation

Set deadlines and constrain
tasks

After planning your tasks, you
can go to the Resources area |
to build yaur project's tearn

and assian peaple to tasks,

Figure 1-1:
The New
Project task
pane with

a blank
schedule
open. : : il ; ; 5]

Ready
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Figure 1-2 shows the Project Office template. Templates typically contain
sample tasks broken down into logical phases, with task durations and
dependencies in place. The templates from Microsoft sometimes include
generic resources, but you can create your own resources as well as use,
edit, or delete the ones provided.

You can open a template from the New Project task pane. To do so, follow
these steps:

1. Choose FilecoNew.
The New Project task pane appears, as shown in Figure 1-3.

. . Book I
2. Click the On Computer link. Chapter 1
The Templates dialog box opens. You can also use the On Web Sites link

and the Templates on Office Online link to access online templates.

3. Click the Project Templates tab, which is shown in Figure 1-4.
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Figure 1-3:
Opena
template
from the
New Project
task pane.

Creating That First Project

== es

] Ble Edit View Insed Format Jools Project  Report Window  Help Tye & AUEEtEn Ty heir a8 x
NSH 847 4L ad . 0. B i@ [ o] 52 @  MNoGraup < WS E e
# % 4 = % Show- Aral ~ 10 All Tasks
E] Tesks' - Resources - Track - Repot +
: New Praject v x |a S T T - e e R e
e
Hew 58 | =/ Risk Assessment 9 days Fi7i3 |
1 Blark Progect 58 ‘ Perform risk assess 1wk FriTH3
([=) Front esasting project... 8 | Evaluate risk asses. Iays Fri7/20
Templates : ’ 5:7 = | Prepare contingenc 1day Weu 7125
Search orfine fors B2 | Risk assessment cc 0 days’ Thu 7726
LB = = Monitoring 11.5 days Thu 726, |
Tamplates on Gffice Grine B | Prepare project revi 1 day| Th 7728
[, Crbicomputer., 6 | Conduct project rev 4hrs Fi 72T
] O Y sitesin, % | Create reports for ¢ 2days Mon 7220
O & | Viork to miigate it 2 days Wed 8r1
Profect Offica 88 | Assst with allocati 2days| Fri B2
Ne Product Lo 6| Freezelrelease proj 2days Tue BT
Office Move: 70 | Establish change m 1 day Thu 8/
Develan Skils Needs - Hiring Plan - B Freeze/release proj 1gay Frigi0
T Mantoring complete 0 days’ Fri /g
| = Historical/Archival 13 days Mon 813
B Establsh project archiv 1wk Mon 8413
7 | Establish lessons lsam 1wk Mon 820
7 | I4anage project archive 3days Hon 8727
T } Historical compiets. 0 days Wed 829
78| = Post Implementation Re 13 days Thu 830,
| Obtain user fesdback 3 days Thu 828
CHl Evaluate lessons kearnt 1wk Tue sl |
Bt | Modify tems as necess 1wk Tue 9111
82 | Post implementation rev 0 days Man 817
8 | Project Office template con 0 days Mon 817

Ready

Figure 1-4:
Business
and
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templates,
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Home
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included
here.

| General | Project Templates |

L :_'j i L’s.._m

EmEa

| ¥

Commerdal Customer Customer |E ! G
Construction  Feedba...  ServiceRa... | I
{
I
Develop Skils  Electronic Engineering  Evaluating
Needs - Hiri... Governm... Offshoring... Preview riat aveiiahie,
=,
External Finance antd Financdial Home Move
Techric, Arcounting .. SErvic...
[ N - N = =
| Tempiates on Office Online. | ok | | concel

4. Click a template to display a preview.
5. When you find the template you want to use, click OK.

The template opens in Microsoft Project document format (MPP). You
can then save the file with a new name. You can also delete tasks, move
them around, or add tasks as necessary for your project.
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After you open a template, be sure to check its project information
(choose Projecte>Project Information) to make sure that the Start Date
and Calendar options are set as you want. See the next section for more
about this.

If you modify a template and want to use that set of tasks again for future

\\3
projects, consider saving the file as a custom template. Just choose Filer>
Save As and then select Template in the Save As Type list. You might also
consider having organizational templates that are saved on your network or
in a shared folder for other project managers to access.

<® If you have an existing project with similarities to a new project but you neg-

lected to save it as a template, you can simply open the existing Project file,
save it with a new name, and voila — you have a head start on building your
new plan.

Making Global Project Settings

When you start a new project and find yourself staring at that blank project
schedule, a logical first step is to enter some general project information.
This information mostly affects the general timing of your project.

Entering settings

To enter general project information, choose Project=>Project Information.
The Project Information dialog box appears, as shown in Figure 1-5.

Figure 1-5:

Use the

PrOjECt Project Information for 'Project Office”
Information | S=rtde= (WA Tl curentdate: [Wed 4 =
dialog box B or 5147/ ] smwedsm [NA =
for some Scheduie from; | ProjctSfartDate [=]  calendsn [standard  [4]
basic | e e
project _—— e
settings.

Here’s what you can do in this dialog box:

4+ Use the Start Date setting to specify the start date for the project. If
you'’re not sure when the project will start, set the start date about a
month from today. Then, after you build some tasks and have a better
handle on the entire length of your project, you can come back and set a
real start date. Project automatically recalculates all dates when you do.

Book I
Chapter 1
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\NG/
S

Use the Finish Date setting to specify the finish date for the project.
Especially if you have a drop-dead date (an attention-getting term!)
beyond which the project cannot wander and still reach completion, you
can set the finish date. In such a case, be sure to look at the next setting
in this list — and change it accordingly.

Schedule from the start or finish of the project. Most projects work
forward from the start date. However, if you have an absolute drop-
dead date for the end of your project (for example, if you're organizing
a sports event that must occur on New Year’s Day next year), you might
want to set the finish date and then work backward to fit all your tasks
into the allotted length of time. If you change this setting to Project
Finish Date, the Finish Date field becomes available.

Set the current date. You can fill in the current date according to your
computer calendar. Or, you can choose another date if you like, but that
usually doesn’t make much sense unless you're in a different time zone
from where the project will occur.

Set a status date. By default, no status date is set for the project. You
use a status date when you're tracking the progress of your project at
regular intervals. If you set a status date, your computer assumes that
any activity you record in your project is being tracked as of this date.
You can find out more about settings for tracking in Book VIII.

Set the working calendar for your project. You have three choices:
Standard, Night Shift, and 24 Hours. Base your choice on the working
habits of your organization. For example, if your company uses resources
in three shifts per day — a total of 24 hours of straight working time —
and all those shifts would contribute work to your project, choose

24 Hours. If you use a day shift and a night shift, choose Night Shift. If
you work a standard 8-hour day, choose Standard. (Most projects use a
standard calendar with a typical 8-hour workday:.)

Calendars can be a little complex. A project calendar that you set in this
dialog box indicates what the usual workday is at your company, but
you can set up individual calendars for each task you create. The Task
calendar then takes precedence over the project calendar. See Book II,
Chapter 4 for more about Task calendars.

Assign a priority to your project. Assigning a priority can be especially
useful if you use the same resources across several projects and want to
use the Resource Leveling feature. With your priorities set on all projects,
Project tools can then automatically reallocate resources. A priority of 1
would cause Resource Leveling to assume it is just fine to delay a task,
where a priority of 1000 would cause Resource Leveling to avoid moving
such a task at any cost.
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Figure 1-6:
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You can also create custom project information fields for your organization
in the Enterprise Custom Fields section of this dialog box. For example, you
might want a field that explains which department in the company is running
the project.

Click the Statistics button in this dialog box to get an overview of your project,
as shown in Figure 1-6.

Project Statistics for ‘Financial Service Offering Launch’ ==l

Start

Finish

Current

Mon 1/1/07

Wed 4/4/07

Baseline

NA

NA

Actual

MNA

Variance

od

Duration

Work

Cost

Current

68d?

Baseline

od?

Actual

Remaining
Percent complete:
Duration: 0%

68d?

Work: 0%

\\J

You need to enter much more information in addition to general project
information and tasks in order to build a complete project, as you discover
in the next few chapters. However, entering general project information is a
logical starting point.

Using start and finish dates

It’s important at this point to give you some advice about how to use start and
finish dates in Project. Many people new to project management software
attempt to use it like a paper-based schedule, pinning down every known date,
setting the start and finish dates while still in the planning stages.

However, one of the most useful aspects of Project is that it can show you
what a shift in timing does to your project instantly. If you nail down specific
dates, you have to go in and reset them whenever a change occurs. This is
true on the task level, where making settings that force a task to happen on a
certain day undermines the abilities of Project to move tasks based on their
timing relationships. For example, suppose you build in a relationship that
says you can’t send out the brochure until you receive the brochure from
the printer. If the printer is late, the ship date of the brochure moves out
automatically, providing you with valuable real-world information.

Setting the start or finish date of a project while still in the planning stage can
have similar issues. If you don’t really know the very day things can start

Book |
Chapter 1
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Figure 1-7:
Setting a
start date in
this project
reveals the
finish date
in the
summary
task.

rolling, you don’t have to set a start date until you're further along in your
planning. You can still observe the overall length of time it will take for the
project to run its course. Then when you have better information about a real
start date or you want to propose a few different start dates and see the
results in your schedule (see Figure 1-7), use the Start Date setting to do so.

One final word of advice: It usually makes sense to set a start date or a finish
date, but you cannot set both. By setting a start date, the tasks and timing
relationships you create reveal to you what a realistic finish date will be. If
you don’t like the results, make changes to tasks, relationships between
them, or resource assignments to tighten things up. (See Book VIII for more
about how to do this.) Setting a finish date lets you see when you must start
(or have already started) by to complete your project on time.

Conversely, if you decide to schedule back from a finish date, don’t set the
start date as well. Setting a drop-dead finish date and creating your tasks
then lets you see exactly when you have to start (or when you should have
started) to realistically complete your project (see Figure 1-8). Again, when
you see what Project shows you about your start date, you can adjust your
tasks if necessary to obtain a start date you can live with.
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Save That Project!

A\

You can save a project just as easily as you do in any other software, or you
can save a Project Workspace. You can also save a project in various other
file formats. Here’s the lowdown on how you save all the work you’ve done.

Saving a project
To save a Project file that you haven’t saved before, follow these steps:
1. Choose File>Save As.

2. Use the Save In drop-down list at the top (see Figure 1-9) to locate the
folder where you want to save the file; then click to select it.

3. In the File Name text box, type a name for the project.
4. Click Save.

It’s a good idea to create a folder for your project either on your local hard
drive or on your company network where you save in one place not only
your Project files but also supporting documents, e-mails, and other items.
You can create a new folder from within the Save As dialog box by clicking
the New Folder button.
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| Save As
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Saving in other formats

As with most software, Project allows you to save a file in other formats.
When in the Save As dialog box, use the Save as Type field to choose one of
these other formats:

4+ Project 2000-2003: If you want to share this file with folks who have an
earlier version of Project, this could be a logical format to save in.

4+ Template: To create a template from a file, save in the Template format.

4+ Excel: There are two options here: You can save a project as an Excel
Workbook or an Excel PivotTable. If you want to share your data in
Excel, choose one of these formats.

4+ Text, CSV: Text saves your file in formats that don’t include a lot of
formatting bells and whistles. When you choose these formats or any
Excel formats (see previous bullet), an Export Wizard appears to help
you choose which fields of data will export and how to export.

4 XML: This is similar to the MPV format in older versions of Project, in that
it allows you to exchange data with programs other than Project 2007.
XML stands for Extensible Markup Language, and is used especially over
the World Wide Web to deliver structured data in a consistent format.
o You can save a file to a workspace. A project in a workspace offers an easy
way for members to access and work on related files in one central location.
Just choose Filem>Save as Workspace to do so.



Chapter 2: Creating That First Task

In This Chapter

v Exploring the information you can enter about a task
v Using Gantt Chart view to enter task information

v Entering details in the Task Information dialog box
v+ Importing tasks from Outlook

v+ Importing tasks from Excel

v~ Linking to a task in another project

Tisks are the essential building blocks of any project. They’re like the items
on your old-fashioned to-do list for your project. When you create a task,
you build in the What, When, Who, and Where information of your plan.

But tasks serve other roles. For example, resources work on a project when
you assign them to tasks. The timing of tasks and the relationships between
them form the overall schedule for your project. By tracking the activity on
tasks, you can see the progress of your project over time.

You can create tasks in a few different ways: by typing information in the
sheet area of Gantt Chart view (or any other view that displays information
in columns) or by using the Task Information dialog box. You can also
import tasks from Outlook or Excel. You can even use a hyperlink to create a
task in your project that represents data in another project.

In this chapter, you find out all about the various ways to create tasks,
entering task basics in the process.

Tackling Task Basics

\\3

Before you can start to build tasks, you have to identify the individual steps
required to complete your project. When you know what steps you need to
take to accomplish your project goal, you can create each of those steps as
individual tasks in Project.

Chapter 1 in this minibook gives you a lot of advice about how to figure out
which tasks to include in your project and how to identify your project
scope and goal.
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In a longer project, you might find that your tasks number in the hundreds
or even thousands. As you create tasks, you might find it useful to organize
those tasks in a logical way by creating phases consisting of summary tasks
with subtasks below them. This structure is essentially Project’s version of
an outline (see Figure 2-1). For example, you might have a summary task
named Product Brochure with three subtasks: Design Brochure, Write and
Approve Copy, and Print Brochure. It’s up to you to decide how much detail
each phase of your project requires.

You can find out how to organize tasks into outlines in Book Ill, Chapter 2. All
you have to focus on in this chapter is how to create tasks.

Identifying what makes up a task

Creating a task is a bit more complicated than writing an item on a to-do list.
Think of each task in your project as a record — like a database record that
lists a person’s name, address, e-mail, and birthday. In a similar way, a task
in Project contains data about that task: not only a task name but also other
vital data about how that task fits into your project.
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To create a task, you enter information such as

4+ Task name

4 Task duration

4+ Task type

4 Task priority

4+ Constraints for scheduling the task
At a basic level, all you have to do to create a task is enter a task name.
However, a task record can contain much more information than that. You

can add all task information up front or, if you haven’t obtained or figured
out all the task settings, enter more and more data over time.

What task settings control

You have to make some choices when you create tasks, which we don’t go into
detail about here because our goal in this chapter is to simply have you create
a task. However, you see several task settings in the Task Information dialog
box that you use in this chapter (see Figure 2-2), so we briefly address them.

Task Information
Genera| Predecessors | Aesources advanced Notes Custom Fields |
Mame: 'Cﬂ“dm finzl quality review: | Duration: |2d =| [ Estimated
Percent complete: | 0% = Pririty; | 500 :
Dates
Start: [Tue 8/13/07 — 5] Frish: [WedSfizn7 ~ld

| Hide task bar
_ | Roll up Gantt bar to summary

| oHga | o | [ cane

Some settings, such as task type (fixed duration) and priority (none), can
often be left at default settings. Others, such as task duration (how long the
task will take to complete), almost always require some input from you.
Book IV provides details about how to make each task setting and how they
drive task timing.

For now, remember that pretty much everything that you enter about a task
(except the task name and resources assigned to the task) involves how the
task timing is controlled. Several of these settings work in combination, with

Book I
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Project performing complex algorithms to set the timing of the task accord-
ing to the value of each setting. Other elements, such as the task finish date,
don’t determine timing but rather cause Project to display a symbol in the
Indicator column (the column to the right of the task number column with a
small blue circle containing an i at the top) to alert you when a task has
moved beyond its estimated finish date.

You can also specify a unique Task calendar in the Task Information dialog
box; calendars are covered in Chapter 4 of this minibook.

The Many Different Ways to Create a Task

A\

You can create a task by entering a name for it. You can fill in the details of
task duration and task type, for example, at the same time or later.

However detailed you want to get in your task settings, you can create tasks
by using a few different methods:

4+ Enter task data in a Gantt Chart view sheet pane.
4+ Enter data in a Task Information dialog box.
4+ Import tasks from Excel or Outlook.

4+ Link to a task in another project.

Creating a task in Gantt Chart view

Many people who work on lengthy projects find that entering all task names
in the sheet pane of Gantt Chart view is the quickest and easiest way to go.
You can actually use any view that includes columns of data, such as Task
Usage or Tracking Gantt.

You don’t have to use a spreadsheet view to enter a new task, though it is
perhaps the quickest way to create tasks. You can also enter a new task in
Network Diagram or Calendar view by displaying the view and choosing
Insert=>New Task. A new task box or calendar entry opens and is ready for you
to type a task name. However, in Resource views, the New Task command isn’t
available to you on the Insert menu at all.

Follow these simple steps to enter a task in Gantt Chart view:

1. In the Task Name column, click a blank cell.
2. Type a task name.

You can edit what you type by clicking in the entry box above the sheet
and pressing the Backspace or Delete key to clear characters (see Figure
2-3). You can also click the X and check mark buttons to the left of the
entry box to clear or accept your entry.
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Figure 2-3:

You can

clearor

accept text

in the entry |

field. ; N
3. Press the down-arrow key to move to the next cell in the column and

then type the next task name.

QNBER : : :

Y When you move to the next cell, Project automatically assigns a sequen-
tial task number in the far-left column. This number is a handy way to
identify tasks in larger schedules.

4. Repeat Step 3 until you enter all task names.
Q&N\BEB You can display other columns in Gantt Chart view to quickly enter addi-

& tional task information, such as duration, type, start date, and finish date.
To display additional columns, right-click any column heading, choose
Insert Column, and then select the column you want to display from the

P Field Name list.

Try displaying the Entry table (choose Viewr>Tablec>Entry). This table
offers the most common task information columns.

Going the Task Information dialog box route

Dialog boxes offer the advantage of a centralized information form that
allows you to make more than one entry or setting at a time. The form also
serves to remind you about all the possible settings you have at your dis-
posal. If this approach appeals to you, consider using the Task Information
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dialog box to enter task information. A series of tabs in this dialog box con-
tain all the information that can possibly exist about a task.

Follow these steps to create a task by using the Task Information dialog box:

1. In the Task Name column, double-click a blank cell.

The Task Information dialog box appears, as shown in Figure 2-4. The
General and Advanced tabs in this dialog box contain various timing
settings for the task.

Task Information

Gerneral Predecessors
Mame: '_WFEKSIB-HTt
Percent complete:
Dates

Startr |

Bl Hide task bar

H| Rall up Ganttbar to summary

Resolurces Advanced

— —
R - U

Notes
Duration:

Priority: |

Clstom Felds ]

=1 |H|Estmatad

e

Figure 2-4:
Determine
various task
timing
settings
here. Help | _| | cancel
2. In the Name field, type a task name.
3. Click OK to save the new task.
The task name appears in Gantt Chart view in the cell you clicked in
Step 1.
4. Press the down-arrow key to move to the next cell.
5. Repeat Steps 2-4 to add as many tasks as you like.
<® Try to keep the task names in your project both descriptive and unique so

you and others reviewing your project don’t get confused. However, if you
can’t make all the names unique (for example, you want to have three tasks
in three different phases named Hire Staff), you can use the automatically
assigned task number or the work breakdown structure (WBS) code (see
Book III, Chapter 3 for more about WBS) to identify tasks. These numbers are
always unique for each task.
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Importing tasks from Outlook

Just as you might start roughing out a project with a handwritten to-do list,
you might start thinking about your project as a series of simple to-do tasks
that you enter in Outlook. When that list of tasks becomes the basis of a
project, you don’t have to lose the list and start from scratch. Microsoft pro-
vides an easy-to-use import feature that puts the tasks you create in Outlook
into Project.

When you bring data in from one application to another, you use something
called import-mapping. For example, you can map a spreadsheet field labeled
Staff to the field labeled Resources in Project. The Project import-mapping
feature allows you to map fields in a file created in another application to
fields in Project to import data. However, the import-mapping process can be
tedious at best and confusing at worst. The Import Outlook Tasks feature in
Project is essentially an import map that’s preset to work with mapping
Outlook task fields to Project task fields.

Follow these steps to import Outlook tasks into Project:

1. Open the plan that you want to insert tasks into or open a new project
(choose Filec>New).

2. Choose Tools>Import Outlook Tasks.

The Import Outlook Tasks dialog box appears, as shown in Figure 2-5.

Import Outlook Tasks

Select Al I Clear al |

Help OF I Cancel |

3. Select the options for the tasks you want to import or click Select All
to import all Outlook tasks.
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By default, Outlook keeps tasks in a Tasks folder. Selecting the check box
for the Folder: Tasks item is another way to select all tasks in Outlook.

4. Click OK.

The tasks are imported and appear at the end of your list of tasks with
Change Highlighting applied (see Figure 2-6).

When you import tasks from Outlook, the task name, task duration, and any
task notes are brought over. If a task in Outlook has no duration, Project cre-
ates the task with an estimated one-day time frame.

Project 2007 can integrate your schedule in various ways with Outlook via
Project Web Access. See Book X, Chapter 4 for more information about this.

Getting your tasks from Excel

If you're a devoted Excel fan, you might like to create your task list for a proj-
ect in Excel. At some point, when you’re ready to move that list into Project,
you'll be glad to hear that Microsoft has provided the Project Plan template
that makes the process simple. You can open this template, located in the
Microsoft Office template 1033 folder, from within Excel.
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The template provides four Excel worksheets, as shown in Figure 2-7. You
can enter information about tasks, resources, and resource assignments on
three of them and then easily export that data from Excel to Project.

Follow these steps to use this template:

1. In Excel, open the template called ProjPlan.

2. Fill in information about tasks, resources, and dates in the appropri-
ate columns on the appropriate worksheets and then save the file.

3. Open Project and choose File->Open.
The Open dialog box appears.

4. Locate the ProjPlan file you just saved and then click Open.
The Import Wizard appears.

5. Click Next to begin the wizard.

6. Choose the second option, Project Excel Template, for the format of
the data you’re importing. Then click Next.
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Figure 2-8:
Choosing
how to
import the
file.

7. On the next wizard screen (see Figure 2-8), choose the method for
importing the file.

You can import the file As a New Project, to Append the Data to the
Active Project, or to Merge the Data into the Active Project. If you
choose the third option, you have to create a merge key that delineates
how the data should merge with existing tasks.

Import Wizard - Import Mode ==

How do you want to import this file?

@ As a new project
") Append the data to the active project

) Merge the data into the active project

Help ‘ < Back ‘ Mext > Finich | Cancel |

8. Click Next and then click Finish.

The project appears with whatever tasks, resources, and assignment
information you entered in a project plan format.

Creating a task that represents another project

When you and your co-project managers handle a lot of projects, it’s often
useful to create a task in one project that represents the timing of the sum of
tasks in another project. For example, if you're driving the network installa-
tion project, having a task that indicates the completion of your new office
building construction can be very helpful.

To accomplish this, you can insert a hyperlink in a project outline. This cre-
ates a task that not only reflects the overall timing of another project, but
also provides a handy way to quickly open the other project from within
yours, assuming it’s available on your company network or intranet. After
you create the task, you can move it around in your project and even create
timing relationships, called dependencies, to it (see Book IV, Chapter 3 for
more about dependency relationships).
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To insert a hyperlink to another Project file in your project, follow these
steps:

1. Click to select the blank task name cell where you want the hyper-
linked task to appear.
2. Choose Insert>Hyperlink.

The Insert Hyperlink dialog box appears, as shown in Figure 2-9.
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Project AIO
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3. In the Text to Display box, type a name for the hyperlinked file.

Make sure that this text indicates what information is being summarized.
4. In the Link To area, click the Existing File or Web Page icon.

You can link to a document, an e-mail address, or a Web page.

5. In the Look In list, locate and select the file to which you want to
insert a hyperlink.

6. Click OK.

The link text is inserted, and a hyperlink symbol appears in the Indicator
field (see Figure 2-10). You can simply click that link symbol to open the
other file.

If you need to, use the Indent and Outdent tools on the Formatting toolbar
(arrows pointing to the left and right, respectively) to place tasks at the
appropriate level in your project. You can find out more about how to organ-
ize tasks into outlines in Book IIl, Chapter 2.
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Chapter 3: Exploring Task Views

In This Chapter

v Getting an overview of views

1+ Choosing the best view for your needs
v Displaying combination views

1+ Exploring various task views

1 Making use of resource views

v Discovering great views for tracking progress

In real estate, they say a view is worth thousands. In Project, the right
view could easily help save you thousands. That’s because views are the
way you get at all the valuable data you need to keep your project on track
and within budget.

Essentially views in Project provide you with different perspectives on your
Project plan. Some help you focus on resources. Others help you get your
tasks in line. There are views that make data entry quick and easy, and
others that help you track progress on your project.

In Book I, Chapter 4 we discuss the three most commonly used views —
Gantt Chart, Network Diagram, and Calendar. In this chapter, we go deeper
into views, showing you some of the more esoteric but very useful views
Project makes available to you.

A View for Every Need

Think about it: After you enter all the project, task, and resource data for a
big project of, say, 1,000 tasks, you've created a powerful database of infor-
mation. Add to that, Project automatically performs complex calculations on
that data to make information about schedules, costs, dependencies, and
more available, and you have a huge chunk of data at your disposal. The
way you get at that data is through views.
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A View for Every Need

Many people spend the majority of their time in Gantt Chart view (see
Figure 3-1), which is fine. Gantt Chart view provides columns of data in a
variety of tables that you can display and modify, as well as a graphical
depiction of your task timing.

But Project has a great deal more to offer, namely 25 different built-in
views. Some views let you examine your data in unique ways that might
help you spot problems or opportunities. Some, such as Milestone Rollup
(see Figure 3-2), summarize information; others enable you to enter data
you can’t enter elsewhere. Still others, such as Multiple Baselines Gantt,
can display several saved baselines side by side, or let you view sets of
data that you can find in other views.

Book I, Chapter 4 is where you can find steps for changing from one view to
another and for making basic modifications to views such as displaying dif-
ferent tables of columns in the sheet pane and modifying the timescale in
chart panes. Book VI offers some more-advanced advice on using views to
communicate information about your project.
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Finding Just the Right Uiew for You
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Figure 3-3:
Selecta
view to
display.

The view you need is likely to depend on what you're trying to accomplish
with your Project plan at the moment. Some views are useful in building your
task list, whereas others work well for entering resource data. Certain views
are wonderful for resolving problems or tracking data. How do you know
which view will work best? Here are some guidelines to help you out.

First, Project offers a few different types of views. To see the entire list, you
can click the More Views icon at the bottom of the View bar. This displays
the More Views dialog box shown in Figure 3-3.

‘More Views =
Views:
|Bar Rollun - | ‘ e ..
| Calendar | —
| Descriptive Network Diagram = Lo
| Detall Gantt B | ‘L‘
| Gantt Chart =
| Leveling Gantt ‘ Copy... ‘
| Milestone Date Rallup ‘ ‘
|Milestone Rollup Crganizer..,
JENES Gantt i —_—
| Network Diagram |
|Relatioriship Diagram |
fsterGs | caneciag

Book Il
Chapter 3

SM3IA
yse] buuojdxgy



100

Discovering Various Task Views

Scanning this list, you can see views that include the term Resource or Task
in their names, which gives you a clue what they’re about. Beyond that,
views fall into one of these categories:

4+ Graph views such as Resource Graph present information in a visual

way. If you want a quick impression of what’s going on or of a trend,
rather than the detailed numbers, a graph view might be for you.

Chart views such as Gantt Chart view include a sheet pane and a chart
pane. The sheet includes columns of data, whereas the chart displays a
graphical representation of that data.

Combination views quite logically combine two views, displaying them
one above the other. If you need to analyze one set of data, such as infor-
mation about tasks, along with another set of data, such as information
about resources, a combination view might fit the bill.

Beyond understanding the basic types of views, the best way to find the
ones that are useful to you is to look at them and see what each has to
offer.

Discovering Various Task Views

Most views contain some information about tasks; even resource views
might offer resource data listed by task. However, some views are useful for
working with task data. Here’s a quick survey of some interesting task
views:

4+ Task Details, shown in Figure 3-4, is a handy view for reviewing task

essentials. Though much of this information is available on the various
tabs of the Task Information dialog box, this view offers both a one-page
summary of the most important settings and an option to open the
dialog box for changing those settings.

Task Entry is a combination view (see Figure 3-5). Gantt Chart view is
shown on top, and the Task Details view is shown on the bottom. This is
a great way to be able to review detailed task settings alongside your
entire project plan to see how that task fits in the larger scheme of
things.
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Figure 3-6:
Task Usage
view.
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4 Task Usage, shown in Figure 3-6, is a useful view for spotting the amount

of work going on in your project task by task over a period of time such
as a week or month. This overview of work hours can help you spot
potential work bottlenecks, slow times when it might be a good idea to
make better use of resource downtime, and times when resources might
be overworked.

4+ You may have used Network Diagram view, but Descriptive Network

Diagram view adds information about whether a task is critical or non-
critical (that is, whether the task can be delayed without delaying the
overall deadline of the project).

4+ Relationship Diagram is a simple graphical view that shows you each

task in your project, one by one, with all the dependency relationships
to each task shown in a simple diagram with the type of relationship
noted next to each task (see Figure 3-7).
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What Resource UViews Tell You

Resource information also pops up in many views, but some resource-specific
views could help you manage your resources more effectively. Here are a few
to consider:

4+ Resource Graph view (see Figure 3-8) offers a visual way to review work-
load, resource by resource. You can easily spot when resources are over-
booked by looking at the peak units (often this is 100%) and the bars
that show when a resource is booked over peak time.

4 Resource Allocation is a combination view (see Figure 3-9) that allows you
to view all the tasks to which a resource is assigned, both as a work hours
listing at the top and a Gantt chart with task bars on the bottom. This
helps you see both workload and task timing within your schedule, simul-
taneously, so you can resolve resource conflicts or fine-tune assignments.

4 Resource Form view (see Figure 3-10), like the Task Entry view, is a sum-
mary of all of a resource’s settings on a single page. Use this view to
review resource assignments, calendars, and rates of pay. It’s a one-page
alternative to the various tabs of the Resource Information dialog box.

4+ Resource Sheet (see Figure 3-11) is a great view for entering resource
information, including the type of resource, maximum units of work,
standard and overtime rates, cost, and calendar.
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The Best Views for Tracking Progress on Your Project

Figure 3-12:
Leveling
Gantt view
helps you
figure out
your
resource
challenges.

After you save a baseline copy of your project plan, you can begin to track
progress against that baseline. Tracking usually involves a combination of
two things: entering information about actual versus planned activity, and
finding ways to resolve problems that occur with your schedule and
resources. Several views work very well for helping you to track and make
changes to your plan.

Turn to Book VIII for a wealth of information about tracking activity on your
projects.

4+ Leveling Gantt view (see Figure 3-12) allows you to see what delays lev-
eling has caused in your schedule if you use Project’s Resource Leveling
feature (a calculation you can apply to delay tasks to avoid resource
overallocations) to work out resource issues.
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Figure 3-13:
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If you find that delays due to Resource Leveling are unacceptable, you
can turn it off and use other methods to solve resource problems. See
Book VII, Chapter 2 for more about this.

4+ Tracking Gantt (see Figure 3-13) is a great place to go to enter actual
start and end dates for your tasks and to mark tasks as finished in the
columns of the sheet area. You can then view your tracked activity
against the baseline by looking at the taskbars in the chart pane.

4 Multiple Baselines Gantt (Figure 3-14) is useful if you've had occasion
to save several baselines over the life of your project. This can occur
when serious changes to your project come up — for example, if you
have to stop your project midway because of a materials shortage and
start it up again months later. By setting a new baseline, you're track-
ing against an iteration of your plan that makes sense against future
actual activity. This view displays, side by side, all baselines you have
saved in your project so you can see (or explain) how things changed
overtime.
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Figure 3-14:

Multiple
Baselines
Gantt view
helps you
see where
you've
come from.
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Displaying Combination Views

Looking at two views side by side (or more accurately, one on top of the
other on your computer screen) can be useful when you’re comparing two
aspects of your project. That’s where combination views come in.

For example, you might display Network Diagram view along with Gantt
Chart view to get columns of data about your tasks and a graphic represen-
tation of project workflow. You can also display a combination view and then
print the view, packing lots of data into your printout.

To display a combination view, follow these steps:

1. Display the first view you want to use by using the View bar or View
menu.

2. Choose Window=>Split.
A second copy of the currently displayed view appears.

3. Click within the view you want to change.
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4. Click the view you want in the View bar. Alternatively, choose View>
More Views, select the other view from the list of views, and click OK

to apply it.
The combination view is displayed (see Figure 3-15).
A\ . . - . .
If the second view you want to display is listed on the View bar, a quicker
method for displaying it is to display the first view and then press the Shift
key and click the View icon.
To remove the bottom view at any time, choose Windowr>Remove Split or
click on the line dividing the panes and drag down to close the bottom pane.
You can also change the views that appear by simply clicking another view
in the View bar; it replaces the active view in the combination view.
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Chapter 4: Working with Calendars

In This Chapter

v+ Exploring the Base, Project, Resource, and Task calendars
1+ Understanding how calendars work together

1~ Setting calendar options, working times

v Creating the Project calendar

v+ Using Project Guide to make calendar settings

v+ Working with Task calendars

v Using Resource calendars

1 Creating your own calendar templates

+ Copying calendars to another project

rme: There’s never enough of it, so using what you’ve got wisely can
make the difference between a successful project and a disaster. In
Microsoft Project, one of your most useful tools for getting your project
timing right is calendars. Calendars allow you to define working and non-
working time, such as your average workday or workweek, and specify
exceptions such as holidays.

It’s not difficult to define your company’s typical workday, whether every-
body works from 9 to 5 or particular jobs call for people to work from mid-
night to 8 a.m. Project 2007 calendars allow you to set standards for typical
working time and then allow for variation. But to make life interesting,
Project 2007 has several types of calendars you have to deal with.

The Big 4: Base, Project, Resource, and Task Calendars

Mastering the four calendars in Project 2007 takes a little time. However,
understanding how calendars work in Project 2007 is essential to mastering
the software. You schedule tasks and assign resources based on the calendar
settings that you make. The costs accumulated by resource work hours won’t
be accurate if you don’t understand your calendar settings from the get-go.
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Because the use of the term “project” can get confusing as it refers to the soft-
ware, your project plan, and one of the calendar types (the Project calendar),
we need to explain the terminology we use in this chapter. We use Project
2007 when referring to the software itself, Project calendar when referring to
the calendar settings in the software, and just plain old project when talking
about your project plan or schedule.

How calendars work

Project 2007 has four calendars that you have to deal with. Each takes prece-
dence over others in a very specific way, which we cover in the next section.

The four Project calendars are

<+

<+

+

Base calendar: This is the calendar template that all other calendars are
built on top of. Three Base calendars are available: Standard, 24 Hours,
and Night Shift.

Not everybody in a company works the same schedule, and not every
task can be performed in the same eight-hour workday. To deal with the
variations in schedules that occur in most workforces, Project, Resource,
and Task calendars can be set to use one of three Base calendar templates
built into Project 2007.

The three Base calendar templates are as follows:

e Standard: The default setting. It sets a working day as 8 a.m.-5 p.m.
with an hour for lunch and a five-day, Monday-Friday workweek.

e 24 Hours: Allows work to go on around the clock every day of the
week.

e Night Shift: Sets Sunday as a nonworking day, three shifts Tuesday
through Friday, two shifts on Saturday, and one on Monday. Working
times for a Night Shift calendar are shown in Figure 4-1.

The legend in Figure 4-1 explains how different hours are shaded to help
you identify them in the calendar display.

You can modify the three Base calendar templates and create new tem-
plates from them. See the section “Creating Your Own Custom Calendar
Template,” later in this chapter.

Project calendar: This is the default calendar for scheduling. This is
where you choose which Base calendar template this particular project
should use.

Resource calendar: This combines the Base calendar settings with any
exceptions (nonworking times) that you set for a particular resource.

Task calendar: This is where you can set exceptions for a particular task.
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When you create tasks and assign resources to work on them, Project 2007
has to base that work on a timing standard. For example, if you say that a
task should be completed in one workday, you also have to tell Project that a
workday means 8 hours (or 12 hours or whatever). That’s why you have to
set up a standard workday in your Project calendar.
In a similar way, suppose that you assign a resource to put in two weeks of
work on a task in a company that uses a standard five-day workweek. If that
resource is part-time and their calendar is set for a standard three-day work-
week, the two weeks of work put in by that resource defer to the timing of
the Resource calendar for a total of only six workdays.

gg‘“\NG! Several variables affect the timing of tasks in Project. Some settings you

make when you create a task can also have an effect on resource time. A two-
week, effort-driven task isn’t complete until its resources have put in two
weeks (according to the Project or Task calendar) of effort. You can set other
tasks to finish in two weeks no matter how much effort has been expended.
Find out more about settings, such as the effort-driven setting, in Book IV,
Chapter 2.

Book I
Chapter 4
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How does one calendar relate to another?

By default, all calendars in your project are controlled by the Project calendar
setting. However, when you change a Task or Resource calendar (this type of
change is referred to as an exception), it’s important that you understand
which setting takes precedence.

Here’s how this precedence works:

4+ With no other settings made, the Base calendar template you select for
the Project calendar when you first create the project controls the work-
ing times and days of all tasks and resources.

4+ If you make changes in the working hours for a resource assigned to a
task, those settings take precedence over the Project calendar for that
resource and the Task calendar. Likewise, if you assign a different Base
calendar for a task, that calendar takes precedence over the Project cal-
endar for that task.

4+ If you apply one calendar to a resource and a different calendar to a task
that the resource is assigned to, Project 2007 uses only common hours
to schedule the resource. For example, if the Task calendar allows work
from 8 a.m.-5 p.m. and the Resource calendar allows work from 6 a.m.—
2 p.m., the resource works from 8 a.m.-2 p.m., which is the only period
the calendars have in common.

4+ You can set a task to ignore Resource calendar settings by opening the
Task Information dialog box (double-click the task name in Gantt Chart
view) and selecting the Scheduling Ignores Resource Calendars check box
on the Advanced tab. (This setting isn’t available if the Task calendar is
set to None.) You might select this setting if you know that all resources
are required to be involved in a task, such as a quarterly company meet-
ing, regardless of their usual work hours.

Understanding Calendar Options and Working Times

Just when you thought you were beginning to get a handle on calendars, we
throw two more timing elements at you — calendar options and working
times. These aren’t that hard to grasp, so just hang in there!

You use calendar options to change the standards for a working day, week,
and year. For example, if you set a Project calendar to Standard (by default,
8 a.m.-5 p.m., five days a week), the Calendar tab of the Options dialog box
is where you can designate which five days are working days or modify the
working hours to 9 a.m.—6 p.m.

You use working time to adjust the time available for work on a particular
date or days. Suppose you make a change to the calendar options so that
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you have 8-hour days and 32-hour workweeks. You should also check your
working time and be sure that you specify that three days of the seven-day
week should be nonworking to jibe with the 32-hour week. If you want to set
a certain date, such as your company offsite meeting day, as nonworking for
your project, you can do that with the working time settings.

<® If you use Project Server to implement enterprise-wide project management,
you can make settings in the Enterprise Global Template. This template sets
the working time for all projects across your company. See Book X, Chapter 2
for more about the Enterprise Global template.

Setting calendar options Book I

When you make changes to a Resource or Task calendar, you simply adjust the Chapter 4
times that a resource is available to work or the time during which a task can
occur. You don’t change the length of a typical workday for your company. A
day is still eight hours long if that’s the Project calendar setting, even if you
say that a task that takes place on that day uses the 24-hour Base calendar
template.

siepuajes
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To change the length of a typical workday to ten hours rather than eight, for
example, use the Calendar tab of the Options dialog box.

Follow these steps to modify the calendar options:

1. Choose Tools=>Options.
The Options dialog box appears.

2. Click the Calendar tab, as shown in Figure 4-2.

\3
P You can also display these settings by clicking the Options button in the

Change Working Time dialog box. Read about the settings there in the
following section.

3. From the Week Starts On drop-down list, select a day.

4. To modify the start of your fiscal year, select the month you want
from the Fiscal Year Starts In drop-down list.

5. To change the working hours for a typical day, type new times in the

\BER Default Start Time and Default End Time fields.

\}

S If you change the Default Start Time or Default End Time setting, you
should also change the corresponding working times. See the following

section to discover how to do this.

6. Modify the Hours Per Day, Hours Per Week, and Days Per Month
fields as needed.

7. Click OK to save the settings.
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<® If your company uses the settings you specified in the previous steps for

most projects, you can click the Set As Default button on the Calendar tab of
the Options dialog box. Then, whenever you create a new project, these are
set by default.

Making exceptions

If you want to change the available working hours for a particular day (for
example to take the day before a holiday off), you use the working time set-
tings. For example, if you want the day before Christmas to be a half day, you
can modify the working time settings for that day; then any resources
assigned to a task on this date put in only one-half day of work. You also use
these settings to specify global working and nonworking days to match the
calendar options settings.

Here’s how to change working times:

1. Choose Tools>Change Working Time.
The Change Working Time dialog box appears, as shown in Figure 4-3.

2. In the Click On a Day to See Its Working Times calendar section, click
the day you want to change.

3. Click the Exceptions tab to display it; then click a blank row and type
a name for the exception.
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4. Click the Details button.
The Details dialog box for this calendar appears (see Figure 4-4).

5. Select either the Nonworking or Working Times radio button.

Change Warking Time
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6. Enter a time range in the From and To fields.

P If you want to set nonconsecutive hours (for example, to allow for work-
ing mornings, taking a lunch break, and then including afternoons), you
can. Simple enter two or more sets of numbers in the time range fields,
suchas 8to 12 and 1to 5.

7. Select a recurrence pattern and then set an interval in the Every X field.

For example, if you select Weekly and click the arrows to set the interval
field to 3, this pattern recurs every three weeks.

8. Set the range of recurrence.

You can do this step by entering Start and End By dates or by selecting
the End After radio button and setting the number of occurrences there.

9. Click OK twice to close the dialog boxes and save your changes.

\P
) Use the Nondefault Work Week legend item in the Change Working Time
dialog box (refer to Figure 4-3) to specify a working time that varies from the

working time established by the Base calendar template for this calendar.

Getting the Project Calendar Set Up

The first calendar that you should set up for your project is the Project cal-
endar, which sets up overall defaults. You set the Project calendar in the
Project Information dialog box (shown in Figure 4-5). You can display this
dialog box by choosing Project=>Project Information.

Figure 4-5:
Your choice [Project information for ‘Direct marketing program’ =
of calendars Start date: Mon 7/3/08 [7] cumentdater [Thu#/507 e
includes Firiish date; I (] Stotusdate;  [NA &
one of these Schedule from: ‘|;FU]|':"ZL_5'E|TT.[-)E|.|E — B Calendar: |Eﬁ E]
three Base T

| Help | | statisties:.. | |
calendar —
templates.

Here are the settings that you can make in the Project Information dialog box:

4+ Calendar: Select the Base calendar template to use for the Project calendar
from this drop-down list. We list this setting first because it’s the only one
you have to deal with when you start a new project.
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4+ Start Date and Finish Date: You might want to wait to set these dates
until you build in most of your tasks and resources. Then, when you
really know when you can start work, set the start date and let Project
2007 calculate the finish date based on your tasks’ timing and dependen-
cies. See more about these settings in Book IV, Chapter 1.

4 Schedule From: You can choose to have tasks scheduled backward from
the finish date or forward from the start date. Most folks go forward
from the start date.

4+ Current Date: By default, this setting matches your computer clock
setting. However, you can change this so that it doesn’t match your
computer clock setting. Changing this date is useful for looking at
what-if scenarios or for tracking progress as of a certain date in the
past.

4+ Status Date: You typically set this to the current date to track progress
on your project. When tracking, you usually want to see the status of
your project as of now, so you don’t really need to deal with this setting.
However if you want to track as of the end of a fiscal period or another
timeframe, you can change this to track the status of your tasks as of
any other date.

4+ Priority: This field is useful if your organization has many projects and
you create links among them. If you use a tool such as Resource Leveling
to resolve conflicts (see Book VII, Chapter 2 for more about this topic), it
can consider this project’s priority setting when making its calculations
about what to delay and what to keep on track.

Letting Project Guide Make Calendar Settings For Vou

Project Guide includes a useful Calendar Wizard that can help you set both
calendar options and working time settings. This guided procedure can be
very useful when you’re new to Project.

Follow these steps to make calendar options and Project calendar settings
using this wizard:

1. If Project Guide isn’t already visible, you can display it at any time by
choosing Viewr>Toolbars~>Project Guide.

If the Project Guide toolbar is displayed and you want to hide it, you can
click the Show/Hide Project Guide button on the Project Guide toolbar
to hide it.

2. Click the Task button if the task pane isn’t already displayed.

3. Click the Define General Working Times item listed in the Project
Guide task pane.

The Preview Working Time calendar appears, as shown in Figure 4-6.

Book
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From the Select a Calendar Template drop-down list, select the Base
calendar that you want your project to use.

The Calendar setting offers the three Base calendar templates: Standard,
Night Shift, and 24 Hours, as described in the “How calendars work” sec-
tion, earlier in this chapter; if you or an administrator has created any
custom calendars, they are also listed here.

Click the Continue to Step 2 option at the bottom of the Project Guide
pane.

The task pane contents change to show check boxes for each day of the
week (see Figure 4-7). If you want to change the working days in your
calendar for this project, click to select or deselect any day.

Click the Continue to Step 3 option, and then click Change Working
Time in the task pane.

The Change Working Time dialog box, described in the preceding section,
appears. Refer to that section to find out about changes you can make
here.

Click OK to close the Change Working Time dialog box and then click
the Continue to Step 4 option.
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8. Use the three text boxes that appear in the task pane to change the
Hours Per Day, Hours Per Week, and Days Per Month settings, if you
want.
9. Click the Continue to Step 5 option.
A message appears in the task pane to say that the Project calendar is
now set. If you want to work with other calendars at this point, you can
click the Define Additional Calendars option.
10. Click Save and Finish.
<P When you choose a Base calendar template, it sets the typical working time

for your company. If a few resources on your project work the night shift

but the majority of your resources work a standard workday, you might want
to choose the Base calendar template that applies to the majority of your
resources (in this case, Standard). You can make changes to specific Resource
and Task calendars later (see the next two sections).

Making Changes to Task Calendars

You can set a Task calendar to use a different Base calendar template than
the one you selected for the Project calendar. When you change a Task calen-
dar, it takes precedence over the Project calendar for that task.
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Suppose that you select the Standard calendar template for a project and a
24 Hours Task calendar template. If you then specify that the task has a dura-
tion of one day, it’s a 24-hour day. But remember, Resource calendar settings
take precedence over the Task calendar!

To modify settings for a Task calendar, follow these steps:

1. Double-click the task name.
The Task Information dialog box appears.
2. Click the Advanced tab.

3. From the Calendar drop-down list, choose a different Base calendar,
as shown in Figure 4-8.

Task Information
General Predecessors Assairces advanced | fotes Custom Fields |
Mame: ':[d-enn'F_v z:I-Emngrap-l'v'ic n‘v"'argelmaricet 1 Curation: d _ | Estimated
Copstrain task
Deadine: :“A E— = EI
Figure 4_8: Constraint type: .f\s Soon As Possible . _13 Constraint date: |MA _Izl
You can Task typet Fixed Units  [z] iefurtdriven
a pply any Of Calendar; o : | Schedling ignores resolres mElendars
the three s code: atc ————
ca Ie nd ar Earmied value method: | % Complete _E
'[ypeS tO | Mark task as milestonz
tasks in your
project. [ e | o | [ cancel
4. Click OK to save your new calendar setting.
é‘g\v\afﬁ
If a resource assigned to this task has a modified calendar, that resource

Re

works only during the specific hours that the Task calendar and Resource
calendar have in common.

Setting Up Resource Calendars

Even the most productive resources have only so many hours in a day to
work. When you have to deal with variations in resource schedules, you can
modify Resource calendars.
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Calendars for different types of resources

Remember that projects can have three types of resource: Work, Material,
and Cost, which you can read more about in Book V. For now, you should
know that only one resource type — the Work resource — has its own calen-
dar. That’s because Material resources are charged not by time worked but
rather by units used, and a Cost resource gets assigned a set cost that also
doesn’t relate to the amount of time worked on a task.

You can change the Base calendar template for each Work resource and set

specific dates as working or nonworking. These exceptions take precedence
over your Project and Task calendars, and control when a specific resource

can work.

We have one word of caution about modifying Resource calendars: Unless a
resource truly has a unique working schedule, don’t change its Base calen-
dar template. For example, if a resource usually works a day shift but works
a night shift for only a few days during the life of the project, don’t change
that resource’s Base calendar template to Night Shift. If one person works
from 10 a.m.-7 p.m. because the company allows him to, you probably don’t
have to vary his schedule from the typical 8-to-5 work schedule that’s set in
the Project calendar because he puts in eight hours a day like everyone else.
Unless your project deals with the most detailed level of time, where hours
and not days are the typical units of measure for tasks, making these types
of changes is more work than it’s worth.

If you are trying to use a resource that is part of an enterprise pool, you will
need permission to make changes to a resource. See Book 10, Chapter 3 for
more about this topic.

Making changes to Resource calendars

To modify a resource’s calendar settings, follow these steps:
1. Display a view that includes a resource column, such as the Resource
Sheet.

Just click the view in the View bar. Book I, Chapter 4 covers how to dis-
play different views.

2. Double-click a resource name.
The Resource Information dialog box appears.

3. Click the Change Working Time button to display the Change Working
Time dialog box, shown in Figure 4-9.

The Exceptions and Work Weeks tabs have settings identical to the ones
in the Change Working Time dialog box for tasks, but changes made here
affect this resource rather than the task.
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4. In the Click On a Day to See Its Working Times calendar section, click
the day that you want to change.
5. Click the Work Weeks tab to display it; then click a blank row and
enter a name for the exception.
6. Click the Details button.
The Details dialog box for this calendar appears (see Figure 4-10).
7. Select either the Nonworking or the Working Times radio button.
8. Enter a time range in the From and To fields.
Q‘&N\BEH
& If you want to set nonconsecutive hours (for example, to build in a lunch

break), you have to put two or more sets of numbers here, such as 8 to
12 and 1 to 5.

9. Select a recurrence pattern and then set an interval in the Every X box.

For example, if you choose Daily and click the arrows to set the interval
field to 3, this pattern recurs every three days.

10. Set the range of recurrence.

You can do this by entering Start and End By dates or selecting the End
After radio button and setting the number of occurrences.

11. Click OK twice to close the dialog boxes and save your changes.
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Resources can work overtime even if their calendars say that their regular
hours are, say, 8 to 5, but you have to tell Project 2007 to schedule overtime
work. You can also set a different rate to be charged for overtime work for
that resource. To find out more about overtime, see Book V, Chapter 3.

Creating Your Own Custom Calendar Template

What do you do if you’ve got a very unique situation, calendar-wise?
Although Project 2007’s three Base calendar templates probably cover most
working situations, you might want to create your own calendar template.
For example, if your project involves a telemarketing initiative and most
project resources work six hours, from 4 p.m.-10 p.m. (that’s when they all
call us!), it might be useful to create a new calendar template and give it a
name like Telemarketers.

You can save some time when creating a custom template by starting with
the existing Base calendar that most closely fits your needs. Then modify it
as you like by making changes to the working times and calendar options
(see the section “Understanding Calendar Options and Working Times,” ear-
lier in this chapter) to make sure that they’re in agreement. After you create
a new calendar template, it’s then available for you to use when setting up
any of the other three calendar types: Project, Task, and Resource.

Because the Project calendar is the basis of your entire project, it should
represent the most common working schedule in your project. If only some
resources in your project work odd hours, change the Resource calendars
and not the Project calendar.
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Follow these steps to create a new calendar template:

1. Choose Tools>Change Working Time.
The Change Working Time dialog box appears.
2. Click the Create New Calendar button.

The Create New Base Calendar dialog box appears, as shown in Figure 4-11.

Figure 4-11: (Creata ew Base Calendar
Start your Name: [CompPEammaE =
new Create mew base calendar
calendar @ Mske acopyof |Stenderd 7|z| calendar
here. | oK | ‘ Cancel
. In the Name box, type a unique name for the new calendar.
. Select either the Create New Base Calendar or the Make a Copy Of X
Calendar radio button. Then select an existing Base calendar from the
list to base your calendar template on.
P In Step 4, if you choose Create New Base Calendar, Project creates a

copy of the Standard calendar with a new name. If you choose Make a
Copy Of and select 24 Hours or Night Shift, your new calendar is based
on that choice. Whichever you choose, it’s your starting point, and you
can make changes to make the calendar unique after making this choice.

. Click OK to return to the Change Working Time dialog box.

Now you can make changes to the working time for the new calendar
template.

. Click Options.

The Options dialog box appears with the Calendar tab displayed.

7. Make changes to the start of the week or year, the start and end times

for a workday, and the hour or day settings.

8. Click OK twice to save the new calendar settings.

Sharing Calendars with Other Projects

You can make a calendar available for all projects in two ways:

4 Set a calendar as the default for all new projects by making that

choice in the Change Working Time dialog box.
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4 Make calendars from one project available for use in another project.

\P
) This second method is especially useful when you want to share calen-

dars with other project managers in your company and don’t want to
change your own default calendar.

To copy a calendar from one project to another, follow this procedure:

1. Open the project to which you want to copy a calendar.
2. Choose Tools=>Organizer.

The Organizer dialog box appears.
Book Il

3. Click the Calendars tab, as shown in Figure 4-12. Chapter 4
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4. From the Calendars Available In drop-down list (lower left), select the
Project 2007 file that contains the calendar you want to copy.

5. In the Calendars Available In drop-down list (lower right), choose
whether you want to make the calendar available in another currently
open project or the Global template.

6. In the list on the left, click the calendar you want to copy and then
click the Copy button.

The calendar is copied to the current project.

7. If you want to give the calendar a different name, click the Rename
button, type a new name in the Rename dialog box that appears, and
then click OK.

8. Close the Organizer by clicking the close button (the X) in the upper-

QP right corner.

Here are a few pointers about copying calendars from project to project:
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4+ Make sure that the name you give the calendar is descriptive.
Providing an appropriate name helps you remember the calendar’s gen-
eral parameters.

4+ If your company has standard calendars, try having one resource
create and disseminate them. If ten versions of a management calendar
float around and you grab the wrong one, it can cause problems.

4 Put the project manager’s initials in each calendar template name you
create. That way, you know which ones you created.



Chapter 5: Getting Help

In This Chapter

v Using Microsoft Office Project Help
1+ Getting help online
+* Running Diagnostics when Project is sick

v Using Project Guide to get started

M icrosoft Office Project 2007 is a complex product that offers a wealth
of functionality. But all that functionality comes at a price: It’s not
always perfectly obvious how the many tools at your disposal work or how
to find the information about your project that you need.

That’s where Project’s Help feature comes in. In Project Help, you can look
up information or get answers to questions; go online and tap into a wider
range of information and advice; run Diagnostics that tell you what to do if
you’re having problems with the Project software; or let a guide take you
through the process of creating a project.

Entering the Universe of Project Help

Because you probably use software day in and day out, you probably have
used a Help feature before. Though they all have similarities, they all are
slightly different, as well. Project 2007 Help relies heavily on online
resources, though it also contains a built-in knowledge base of help topics,
accessed through a Table of Contents.

Here’s a rundown of the type of help you can find in Project 2007 when you
click the Help icon on the Standard toolbar. As you can see from this list,
you have several ways to get to help in Project:

4+ Microsoft Office Project Help: This option displays the full Help feature
with a Browse feature, Table of Contents, and a Search field.

4+ Microsoft Office Online: Because Project is part of the Office family of
products, this link to the Office Online Assistance Center is provided.

4 Microsoft Office Diagnostics: This option automatically identifies
errors and tries to correct them. Use it if you have serious problems
using the software (for example, if the software continually shuts down
or displays error messages).
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\P
) One helpful option not accessed from the Help menu, Project Guide, offers
step-by-step guidance to help you build a new project (see the last section of
this chapter for more about Project Guide).

Exploring Microsoft Office Project Help

Though this portion of Help sports some new features and a look that differs
from Project 2003, it offers similar functionality. Essentially you can click on
the links in the Browse Project Help list to display articles of information,

locate a help topic in a Table of Contents, or use a search tool to search the
Help knowledge base.

Click the Help menu and choose the Microsoft Office Project Help option, or
simply click the Microsoft Office Project Help button on the Standard toolbar
to display the window shown in Figure 5-1.
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Browsing topics
Home in the Microsoft Office Project Help window consists of a list of topics

labeled Browse Project Help (refer to Figure 5-1). By clicking a topic, you can
drill down to articles of information related to a major topic.

For example, if you click a topic such as Estimating Task Durations, you see a
further list of subtopics like the one shown in Figure 5-2.

By clicking one of these subtopics, you can display an article about the
topic, which often includes step-by-step instructions (see Figure 5-3). Here
are a few guidelines for getting the most out of these subtopics:

Book II

4 A blue arrow pointing to the right indicates that additional detail is Chapter 5
hidden there. Click the arrow to display the information.

4+ A word formatted in color displays a further explanation or definition of o

the term when you click it. -y

=

4+ To show every definition and any hidden text, click the Show All icon at ‘;

the top of the page. _%

4+ In longer articles, take advantage of the Top of Page and In This Article
links to move quickly around the information.
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Figure 5-3:
Help articles
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You have many ways to gather information to estimate durations. However, most of these methods dont allow you the flexibility of analyzing best-case and worst-case scenarios. A
Program, Evaluation, and Review Technique (PERT) analysis gives you this flexibility.

~ Aboutthe PERT analysis
¥ Perform a PERT analysis by using the default weights for duration estimates
¥ Perform a PERT analysis by changing the way Project weights duration estimates

You can perform a basic PERT analysis to estimate atask's duration. After you specify the optimistic. pessimistic, and expected durations of the tasks in your schedule, Project
calculates aweighted average of the three durations. You can also use these durations separatelyto determine a shortest, longest, and mostlikely project end date

After you assign duration amounts to all three types, you can look at your schedule based solely on the opimistic, pessimistic, or expected duration. You can also have Project
calculate a single duration based on the weights for each of the types and the duration values thatyou entered

You can perform a PERT analysis in two ways

= Use the default weights for duration estimates if you think that the expected duration estimate is more likely than either the optimistic or pessimistic estimate, and you think.
the latter two estimates are equally likely.

= Change the waythat Project weights duration estimates if you think that your optimistic, expected, and pessimistic durations have probabilities of occurring that are different
from the default probabilities of 1 out of 5, 4 out of 6, and 1 out of 6, respectively

Using the Table of Contents

When you display the Help window (click the Microsoft Office Project Help
button on the Standard toolbar), note the set of tools at the top. One of
these, shaped like a little blue book, is the Show Table of Contents button.
When you click this button, a pane opens on the left of the window that
shows a list of all Help topics. You can click a book icon to the left of a major
topic to display its subtopics (see Figure 5-4).

The topics and subtopics listed in the Table of Contents are the same as
those listed in the Browse Project Help section to the right of this pane.
However, by displaying the Table of Contents, you can display all subtopics
in a single list, rather than going to a new window to view each set of
subtopics as you do when you use the Browse feature. This capability might
help you spot the subtopic you need more easily.

Searching for Help

You can search for help in two ways. One method is to simply enter a ques-
tion in the Ask a Question box on the Project page and press Enter (see
Figure 5-5). This brings up the Help window with suggested topic matches.
Click a topic to view it.
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\

Microsoft advises that searches with two to seven words in them get the
best results. So avoid using single words and avoid getting too wordy!

The second place to search from is within the Microsoft Office Project Help
window. Enter words or a question in the Search box located there (refer to
Figure 5-5) and then click Search. Again, results appear, and you can browse
through them or click one to read the related article.

Going Online to Find the Answer

If you want a broader universe of answers to explore and to be sure you
have the most up-to-date help information, it’s time to leave the knowledge
database built into Project and wander around the Internet. When you take
this trip through the Microsoft Office Online command in the Help menu,
you end up at the Microsoft Office Online site shown in Figure 5-6. Here you
find downloadable clip art, templates, training, and advice.
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When you go to the Microsoft Office Online site, follow these steps to get
help with Project:
1. Click the Products tab.
2. Click the Project link in the list of desktop products on the left.
The Microsoft Office Project 2007 page appears (see Figure 5-7).

At this point, you find a variety of links that offer you options, which
might change slightly over time, but which might include

e Getting help on specific tasks such as creating a new task
e Taking an online test drive of product features

e Exploring advice via the Ask the Experts feature that enables you to
communicate with the Project community

¢ Running Project training courses (see Figure 5-8) and demos

e (Clicking a Product Support link that takes you to how-to and
troubleshooting articles

3. When you’re done working online, simply click the Close button to
close your browser and return to Project.

& OO o Page MG asoR O Onine TWnaows TR e EXpIoreT = s
) - [ g . i 1033.25px <[4 ] |[ Gooate P~

A a - ] = i
e ‘{‘; Project Home Page - Microsoft Office Online - v v |5k Page v (] Tools =

* United Stotes (change)

Clay vicear :
( = SJ.O'H'ICE Onllne Sign in to My Office Online (What's

Home | Products | HelpandHowto = Downloads | ClipArt = Templates Microsoft Office Live

this?) | Signin

4 Microsoft Office Project . o 7 T b
o R S = ] [ [ Jumpstart your caresr L"J free
e o <o AN [ =l 8 - =
Hightghts Microsoft Certfication | Offcs downlosds

1 Home s Products
»Project Home

roduct Information Microsoft Office Project 2007

>Top 10 Benefits

) Brush up on Office
Meet your learring go: 07 wi
templates, training cot nd

| .c . = l = S
|| e ] Project 2007 demos from Office Online,
»Try Now ' A b =
| »Buy Now i P e pofect Stay informed by controling your project work, schedide, w1 Frad e raking thatsnglifonyan il
g 1 and finance ly commi project data.
h Help and How-to E Get st

Microsoft®
Business
Certification

for Project

uick start : o
e Q.h e Turning ordinary
il - What's new in the Microsof ST
s Office EPM Solution? ;‘;ki ”_‘fn’
- Enterprise Project By eyl ce performers,
Learn how your project is p
| Menagement soiuton rmiicha ol
| otz Lo - Overvien of project cost
»Project Portfoiio Server to commorty asked information X

« Link tasks within your
project

Internet | Protected Mode: On #100% ~

Book Il
Chapter 5

djay Human



73 0 Running Diagnostics

o o et Explorsr ———————— 7
A~

01033.25p = 4] & [ Gooate

Mo Bl v ® o age v GiTecl v |

o ‘i-) Training Home Page - Microsoft Office Online

= Lmited Stz (cange)

936??@ Online

Home Products. Help and How-1o ODownloads  Clip At Templates Micrasoft Office Live

‘@Trilmﬂg \:_Sea_n_h_g‘__\ :B Listzn in 15 Offie= J oz

Training

[y rE——

s e |
Other Training Learn Office with self-paced training courses and more 7 Microsoft Office Certification
raining and 15 ;-—{: = e

Demes - § D=
Micrasafi Leernmg - 245 ' it
g e pemos

» Ofiics Websis - Getour R5S Fesds for Training and Demos * Bernmea Migasoft Busi

Training Sit= Helg

- r -

GetCertified on Office
System

ke a Skils
Asgezzment

Third-Party Training

*Courses

Flgure 5-8. s ppie Bullets, numbers, and lists 2R Nyt
A free e bl base T you to stz ssfer
Support and
. =2y s
Onlme FE:: acs - Browse Training by Product
.. ,“;;' S My Products | 2007 Office System. | Office 2003
»5end Lis Vour
tralnlng Comments
course. Additional Resources Create your list of products to find the right - &
— |11500cE iCrOSOM cOTUen-USWOHdWIdeldeTault 35pX W — (3 @ Intenet | Protected Hods: On R0 -

Running Diagnostics

Sometimes the problem isn’t that you can’t figure out how to do something
in Project; sometimes the problem is that Project itself isn’t working cor-
rectly. When that happens, you can run Diagnostics, which test your com-
puter to see why you might be experiencing crashes while using Project.

Diagnostics check for a few possible problems, including those caused by

4 Hard drive errors
4+ Conflicting Office programs

4 Missing updated service packs for Office that might correct bugs or
errors

4+ Memory

“&N\BEH
& Running Diagnostics can take about 15 minutes, so be prepared to take a
break from your work. Also, it’s a good precaution to close all other pro-

grams while running Diagnostics.
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You can follow these steps to use Diagnostics:

1. Choose Help=>Microsoft Office Diagnostics.
2. In the dialog box that appears, click Continue.

The Start Diagnostics dialog box shown in Figure 5-9 appears.

@ Microsoft Office Diagnostics =&

Start Diagnostics

[T8 Chescforwonnsolutions  Status: Readytorun
@ Memory Diagnastic Status: Ready torun
Ml Compatbility Disgnestic Status: Ready torun
@l Disk Diagnostic Status: Ready torun
_ﬂ Setup Diagnostic Status:  Ready torun

nD.iagnogﬁgrjll Cancel |

What will disomnstics do?

3. Click Run Diagnostics.

The tests run and display progress and results. When the tests are
complete, a window might appear telling you whether any repairs
were made.

4. Click the Detailed Results link to get more information about the
repairs.

Putting Project Guide to Work

Project Guide is a wizard-like tool that helps step you through the process of
building a project. If you've never used project management software (or
Project itself), you might find it helpful to run through Project Guide when
you’re faced with a new project. Project Guide helps you work through the
entire life of your project, helping you to enter task information at the start,
add resources, track the project, and even generate your final report.

Where Project Guide can lead you

Project Guide is divided into four sections: Tasks, Resources, Track, and
Report. Within each of those categories are ten or so links for you to click to

Book I
Chapter 5

djay human
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initiate an action. When you do so, you might have to choose a variety of
subactions, depending on what you need to do to create your particular
project.

To know how to make intelligent choices in Project Guide, you need some
basic understanding of how a project is built, which we provide starting in
this minibook. Our advice is to walk with us through many of the steps in
this book and then use Project Guide to practice building your first project.
Then you make intelligent choices about how to use the various options
Project Guide offers.

Getting to work with Project Guide

A Project Guide toolbar displays by default as the bottommost of the tool-
bars at the top of your Project screen (see Figure 5-10). The toolbar includes
an icon you click to show or hide Project Guide, so if Project Guide doesn’t
appear on the left side of your screen, just click the Show/Hide Project Guide
button.

5l Tasks - PResources -~ Track - Report - -

To use the Project Guide, you click a category on the Project Guide toolbar
(such as Tasks) and then click a link in the drop-down list of items (such as
List the Tasks in the Project). This displays additional information in the
Project Guide pane (see Figure 5-11) asking you to enter data or choose or
accept a setting and move through a series of screens. When you finish
working through one set of screens, you return to the Project Guide pane
and can click another task or category to proceed.

Microsoft laid out these categories and tasks in the logical order in which
you should tackle them to build most projects. Therefore it’s a good idea,
when you start to use Project Guide, to just click the categories and the
tasks within them in sequence. Each item serves to remind you of all the
things you should consider (and even a few things you might have forgotten
you need to do), even if you choose to skip a few steps here and there for
your particular project.
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Chapter 1: Organizing the
Structure of a Project Plan

In This Chapter

v+ Understanding a project’s outline structure
v Promoting and demoting tasks

+ Reorganizing the outline

Fere’s nothing stopping you from creating a project schedule that
simply lists your tasks and subsequently creating links that identify
which tasks depend on other tasks. But, if you take advantage of Project’s
outlining capabilities, you establish additional visual cues that help you
easily identify related tasks and help you organize both your project and
your thoughts.

Project provides several ways to organize tasks in the schedule; in this
chapter, you work with the basic ways Project can outline tasks in a
schedule.

A To-Do List . . . or a Project Schedule?

If you simply type tasks into a project schedule, you end up with a schedule
that looks just like a to-do list. Even when you later add dependencies, the
titles of the tasks still look just like a to-do list (see Figure 1-1).

Although there’s nothing wrong with a to-do list, an organized to-do list is
typically more useful. From an organized to-do list, you can get a sense of
which tasks are related to other tasks by simply looking at the list. Using the
outlining features available in Project, you can look at the table portion (the
spreadsheet-like interface in the left pane that contains columns of informa-
tion) of Gantt Chart view to identify related tasks without looking at the
chart portion (the right pane) of the view to study dependencies (see

Figure 1-2).
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Building an outline

So, how do you actually go about building an organized outline? No hard and
fast rules exist, so just use the approach that works best for you:

4+ Some people like to list all the major headings first and then fill in more
detailed information below each major heading.

4+ Other people like to list everything they can think of and then focus on
sorting those items in orderly and logical groups.

4 Still other people work on one phase at a time, listing its major heading
and then the tasks associated with it.

4 And then there’s the group of people who use combinations of all of
these methods.

“Tve got a little list . . .”

One of the major questions facing a project manager is, “What should |
include and what should I exclude?” A sketchy project schedule has holes
that can threaten the integrity of the schedule, leaving you late on delivery
and overbudget. A schedule filled with excessive detail can make you lose
focus of the project’s purpose.

When you’re making that list of tasks to include in your project, help your-
self focus by defining both the goal and the scope of your project. Lack of a
clearly defined goal and scope is among the top five reasons that projects
fail. So, don’t set yourself and your project up for failure; before you dive
into entering data in a project management software package, settle the mat-
ters of goal and scope for your project.

To identify your goal, ask yourself, “What will my project achieve? What will
have changed when I complete my project?” Will you, for example, have put
on a conference, built a building, or trained a staff?

To define the scope of your project, ask yourself questions like these:

4+ What is my project’s budget?

4+ Who will be affected by my project — my entire company, the IT depart-
ment, or my workgroup in Human Resources?

4+ How many people will work on or have input into my project?

4+ Does my project have a deadline date and, if so, what is it?

For more on a project’s scope and goal, see Book I, Chapter 3.
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A typical project outline

Whether you're writing a paper or preparing a project schedule, an outline is
an outline. It contains higher-level headings that summarize the topics of the
lower-level headings below. Yep, just like your English teacher taught you.

If you look closely at the project outline shown back in Figure 1-2, you notice
that it organizes the tasks into three levels, and each level represents a col-
lection of tasks that you can consider a phase of your project. A task that
has other tasks indented below it is called a summary task, and the indented
tasks are called subtasks. Summary tasks appear in boldface type, and you
can easily identify them because a plus sign (+) or a minus sign (-) appears
beside the task name. When you see a plus sign beside a summary task, its
subtasks are hidden. The subtasks are visible when a minus sign appears
beside the summary task name.

You can have just about as many levels of detail as you want in a schedule,
but before you get “level-happy,” consider that tracking a very detailed proj-
ect can be difficult. In addition, if you find yourself building a project sched-
ule with four, five, or six levels, you might actually be building several
projects. When you find yourself with many levels, you might want to con-
sider taking a group of tasks and turning it into a separate project, with a
separate project manager. By dividing that many-level project into several
smaller projects, managing the projects should be easier. And, even if the
phases relate and seem to be part of the same project, you can still break
them into separate projects and then consolidate the smaller projects when
you need to view the big picture.

You can read more about consolidating projects in Chapter 4 of this
minibook.

Summary tasks are special

A summary task isn’t one to which you assign resources to accomplish; it’s a
placeholder task in Project that you can use to get a feel, at a glance, for the
duration and cost of a set of tasks — a phase — of your project.

In addition to appearing in boldface type, a summary task has no duration,
start date, or finish date of its own. Instead, the duration, start date, and
finish date of the summary task all summarize the information of the sub-
tasks indented below the summary task. And, by default, Project changes the
appearance of the bar in the chart portion of Gantt Chart view to a solid
black bar with downward-pointing arrows at the beginning and ending dates
of the period covered by the subtasks that the summary task summarizes.



Figure 1-3:
A summary
task
summarizes
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information
shown for

its subtasks.
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In Figure 1-3, the Select a Location summary task is expected to take 18 days
to complete, and 18 days is the sum of the durations of the subtasks shown
below Select a Location. The start date and finish date for the summary task
are, respectively, the start date of the earliest subtask and the end date of
the latest subtask.
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In addition to summarizing duration information, a summary task, by default,
has no cost of its own. However, you can assign a cost to a summary task
by assigning a resource to the summary task. The cost of a summary task
includes the cost of the resource you assigned to it plus the cost of the sub-
tasks below it.

The most special task of them all —
the project summary task

Ideally, you'd like one more summary task — one for the entire project. This
is called the project summary task. Take the easy way to achieve this and let
Project insert the project summary task for you. Follow these steps:
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Figure 1-4:
You can
change
the name
Project
assigns

to the
summary
task by
editing the
Task Name.
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1. Choose Tools=>Options.

2. Click the View tab.

3. Click Show Project Summary Task.
4. Click OK.

Project adds, on Row 0, a summary task at the top of your schedule,
naming the task with the name you assigned to the file in which you
saved your schedule. I like the name of the project summary task to
match the project name, and that’s what happens by default if [ name
the file using the project name.

(Optional) Change the name of the project summary task and press
Enter.

If, however, you prefer to name the file something different than the proj-
ect name and you want the summary task to reflect the project name, no
problem. Just edit the Task Name of the summary task by clicking in the
Task Name column and pressing F2. Then type a new name and press
Enter. In Figure 1-4, you see a project file with a name that’s different
from the project’s summary task name.

[
a

by Show | [Frel

X! Talerk Show For the Fundraiser
@ [TaskName Duration Start Oct1,'06 ; Oct 15, 06 Oct 22,'08 Oct 28, 08 -
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[o]
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Confirm the date with the hal Gdays  Mon 1080
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= Identify performers 80 days | Mon 102210 > =
Prepare acts 16 wks | Mon 1020 -
Hire & guest performer 14 days| Thu 107261 =
= Advertise 80 days Thu 102610
Prepare mailer Sdays  Thu10726M : —
Prepare flyer Zdays Thu 107261
Ml flyer and mailer Ty Thu1172m
Selltickets 16wks Thu 101260
] Show Odays  Sun 27250
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\3
P Although you might think that setting the option to display the project sum-

mary task applies to all projects, it doesn’t. If you want to display a project
summary task, you need to set this option in each project file you create.

Creating Structure in the Schedule

After you identify the tasks that you want to include in the outline, you can
add structure to the outline — and obtain peace of mind — by grouping the
tasks into phases of your project and establishing summary tasks for each
phase. Adding structure enables you to easily identify, at a glance, related
tasks, helping you organize both your project and your thoughts.

Selecting tasks

Many of the activities involved in adding structure to your outline require
that you select a task. You can use any of the techniques in Table 1-1 to
select tasks, depending on what you want to select.

Table 1-1 Selecting Tasks
To Select This . . . Do This . . .
A single task Click its Gantt bar or its ID number. Book Il
Several contiguous tasks Select the first task. Then hold down Shift and click the last Chapter1
task that you want to select.
Several noncontiguous tasks Hold down Ctrl as you click the ID numbers or Gantt bars of w2
the tasks that you want to select. 225
@ S S,
ELE
-3
o« « =
Promoting and demoting tasks =58

. You use the Indent and Outdent buttons on the Formatting toolbar in Project
to create an outline of summary tasks and subtasks. Select the task you want
to indent or outdent and then click the appropriate button. To indent or out-
dent several tasks, select all of the tasks and then click the appropriate button.

When you indent a task, Project makes that task a subtask of the task that
precedes it in the Task Name column, and that preceding task becomes a
summary task. Outdenting a task moves the task to a higher level in the out-
line and can change the status of a summary task to a task or subtask if you
outdent the only subtask of a summary task.

In Figure 1-5, Select a Location is a summary task and Select a Date is a sub-
task of the Select a Location summary task. To change Select a Location from
a summary task to a regular task, we would need to outdent the task that
appears immediately below the summary task, eliminating both the concep-
tual and visual status of the summary task.
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Figure 1-5:
To change
any
summary
taskto a
regular task,
outdent the
task that
appears on
the line
below it.
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Expanding and collapsing the outline

Outlining is the tool of choice for organizing your thoughts. In writing,
outlining helps you identify major topics and topics subordinate to the
major topics. You not only identify what you want to write about, but you
also identify an order in which to write. Also, you can easily focus on one
area of the outline.

Outlining in software products adds some delightful capabilities. In Project,
you can hide all tasks except the most major ones — the ones at the left
edge of the outline. You also can display the subtasks of only one major
heading. Or you can hide all subtasks but display the major headings of your
choice. To take advantage of these delightful capabilities, you need only to
have indented some tasks, creating summary tasks and subtasks.

You can use outlining to help you focus your attention. You might want to
display only summary tasks for a project while talking to your boss. During a
meeting, you might want to collapse all portions of the outline except the
portion being discussed in the meeting. You also can close most of the out-
line so that you can easily jump to a later phase in the project without scroll-
ing endlessly.
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Figure 1-6:
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For any summary task, you can use the Show Subtasks and the Hide
Subtasks buttons on the Formatting toolbar to expand or collapse the out-
line. Select a summary task and click the appropriate button. If a plus sign
(+) appears beside a summary task, Project has collapsed that portion of the
outline and hidden the subtasks below the summary task. If a minus sign (-)
appears beside a summary task, Project expands that portion of the outline
and displays the subtasks of that summary task. In Figure 1-6, we’ve col-
lapsed the entire schedule except the subtasks below the Identify
Performers summary task.

In addition to the Show Subtasks and Hide Subtasks buttons on the
Formatting toolbar, you can click the plus and minus symbols beside the
name of each summary task to collapse or expand that portion of the
outline.

You also can use the Show button to control which levels of tasks appear as
you view the schedule. When you click the Show button, Project displays a

list, as shown in Figure 1-7; choose the outline level to display. For example,
display Outline Level 1 to see only the highest level tasks in the schedule.
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Figure 1-7:
Select an
outline level
to display.
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You can choose the All Subtasks command from the Show list to display all

tasks in your schedule.

So, What Happens When You Reorganize the Outline?

You can easily reorganize a schedule after you initially set it up. You can add,

delete, move, and copy tasks.

Adding tasks

As you created your list of tasks, you might not have thought about adding
tasks that serve as summary tasks. Or, you might have simply forgotten a
task. No worries — you can easily add a task. To add a task, follow these

steps:

1. Position the cell pointer on the task that should appear below the new
task you intend to insert and then press the Insert key.

Project inserts a blank row in the sheet pane (see Figure 1-8), renumber-
ing the rows of the tasks that fall below the new row.



Figure 1-8:
Inserting
ataskis
simple.
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2. Type a title for the task and, if you're creating a new task for the
project, supply a duration.

If you're creating a summary task for a phase, you can skip entering the
duration because Project calculates the summary task’s duration as the
sum of the durations of its subtasks.

3. Press Enter to finish the process.

For more on setting up any task as a summary task, read the section
“Promoting and demoting tasks,” earlier in this chapter.

Deleting tasks

It happens — you set up a task and then realize that you don’t need it. You
can easily delete it by following these steps:

1. Select the task by using any of the techniques described earlier in this
chapter and press the Delete key.

Because deleting a summary task has ranging effects, Project displays a
dialog box after you press the Delete key to confirm that you really want
to delete the summary task and all of its subtasks (see Figure 1-9).
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NG/
Q\“\ 4

Figure 1-9:
If you delete
a summary
task, you
also delete
all of its
subtasks.

Figure 1-10:
Use this
dialog box
to create a
task that
occurs at
regular
intervals.

If you delete a summary task, Project also deletes all of the summary
task’s subtasks. Make sure this is what you really want to do before
deleting any summary tasks.

2. Select Continue or Cancel and then click OK.

If you choose to continue, Project deletes the task.

Planning Wizard

=

‘advertise' is a summary task, Deleting it will delete all its subtasks as well.

“fou can;

@ Continue, Delete 'Advertise’ and its

subbasks.:

“iCancel, Don't delete any tasks,

| OK | ‘ Cancel

| [ teb

[T pon't tell me about this again,

“Doing it over and over again . . .”

You might need to include tasks in your project that occur at some regular
interval — what Project calls a recurring task. For example, perhaps you need
to review some work daily. You can avoid the drudge of setting up these
tasks and let Project set them up for you. Use the Recurring Task feature by
following these steps:

1. Select the task that you want to appear below the recurring task.

2. Choose Insert=>Recurring Task to open the Recurring Task
Information dialog box, as shown in Figure 1-10.

Recurring Task Information

Task Mame: |Checkt\ckat sales

Duratjon: |1d |

Recurrence patkern

9! Daily Every i:l _1| days
1 Weekly
@ workdays
! Monthly
Yeatly
Range of recurrence
Start:  [Mon 10/30/06 [x] @ endafter:
@ End by:

Calendar For scheduling this kask
iZalepdar: !L\@DEW :

Help |

Scheduling ignores resourc

[73 __| OCCUrrences

wedzfior 1]

Jendars

O | Cancel |
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3. Type a name for the recurring task.

™

. Set the task duration in the Duration field.

5. Set the pattern for the occurrence of the task by selecting one of the
Recurrence Pattern option buttons: Daily, Weekly, Monthly, or Yearly.

Depending on the recurrence that you select, the timing settings to the
right of the control buttons change. Figure 1-10 shows daily settings.

6. Select the appropriate settings for the recurrence frequency.

If you choose Weekly, place a check mark next to the day(s) of the week
on which you want the task to occur. If you choose Monthly, select either
the date of each month or the day, such as the third Wednesday. If you
choose Yearly, select a specific date or a day, such as the second
Thursday in March.

7. In the Range of Recurrence section, set the period during which the
task should recur by entering Start and End After or End By dates.

8. Click OK.

Project creates the appropriate number of tasks above the task you selected
in Step 1 and displays them as subtasks under a summary task with the
name that you supplied in Step 2. In Figure 1-11, you can see the recurring
daily task we created; the symbol in the Indicators column identifies the task
as a recurring task. If you hover the cursor over the Indicators column,
Project displays the number of times the task occurs between its start and
end dates. When you expand the task, you see that Project adds the number
of the occurrence to the task name of each recurring task.

Moving tasks

Moving tasks and subtasks isn’t a difficult proposition; you just need to be
aware of the effects that moving summary and subtasks can have on the
schedule’s outline:

4+ When you move a summary task, its subtasks move with it. To move a
summary task only (without moving any of its subtasks), you must first
promote all its subtasks so that the summary task is no longer a sum-
mary task.

4+ If you move a task at the highest level of the outline to a new location
just below a task with subtasks, Project demotes the task that you move.

4+ If you move a subtask so that it appears below a task at the highest level
of the outline, Project promotes the subtask that you move.

To move tasks in an outline, you can drag and drop or you can cut and paste.
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El = Advertise 80 days Thu 104908
10 Prepare mailer Sdays  Thu 101906
1 Prepare flyer Zdays|  Thu 104906
12 Mail flyer and mailer Tday  Thu10/26M6
13 Sell tickets 16 whks Thu 10M 306
14 # Check ticket sales 73days  Mon 1030106 [=="==":=] [==="='=] [ oo o= o [===="7
88 [ Show Odays Sun 2/2507
—
Figure 1-11:
Project uses
an indicator
to identify a
recurring |
task. : ik 5T
Read:
Moving by dragging
You can easily move a task by dragging it to a new location using these
steps:
1. Display a view that contains a table, such as Gantt Chart view.
2. Select the task(s) you want to move using any of the techniques
P described in the preceding section.

If you select a summary task, Project automatically selects its subtasks
for the move.

3. In the row number column, drag the task to the place in the task list
where you want it to appear.

A gray line appears, identifying the place where the task will appear (see
Figure 1-12).

4. When the gray line appears where you want the task to appear,
release your mouse button.

Project moves the task from its original location to the new one; you can
change the task’s level in the outline by indenting or outdenting it.
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If you're not dealing with a lot of tasks in a project schedule, dragging works
well. But, if your project contains lots of tasks, dragging to find the target
location can be difficult; and, if you're like us, you run the risk of accidentally
releasing that mouse button earlier than you intended (we can be clumsy
with the mouse). So, consider using the Cut and Paste tools on the Standard
toolbar to move your tasks. Follow these steps:

1. Display a view that contains a table, such as Gantt Chart view.

2. Select the task(s) you want to move using any of the techniques
described earlier in this chapter.

3. Click the Cut tool on the Standard toolbar.

Project removes the task from the outline and places the task informa-
tion on the Windows Clipboard. If you selected a summary task, Project
asks whether you really want to remove the summary task and all its
subtasks.

4. Scroll to the place in the task list where you want the task to appear.

5. Click the task that appears below the place where you want the task
you’re moving to appear.
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6. Click the Paste tool.

Using the information stored on the Windows Clipboard, Project dis-

plays the task(s) you cut in the new location.

You might need to adjust the task’s position in the outline by using the

Copying tasks in a schedule is a simple matter. To copy a single task, follow
the steps in the preceding section, but select the Copy tool in Step 3 instead

SMBER
&@
Indent and Outdent buttons.
Copying tasks
(S1UDY of the Cut tool.

Planning for a regular meeting

Company: A law firm with more than 75 employ-
ees that depends on word-processing software

Project: Upgrade the word-processing soft-
ware on all computers in the firm to Word 2007

Challenge: Meet regularly to monitor team
progress during the planning phase of the project

Because the law firm depends on word pro-
cessing, migrating to a new word-processing
package is a huge project. To effectively
manage the project, the project manager has
set up a separate project for the planning
phase. The project manager is concerned about
communication during the planning phase,
which will impact all other phases. During the
planning phase, several resources will be per-
forming a variety of tasks. Existing hardware
and operating systems must be identified and
assessed to ensure that they can support the
new software. Existing documents and tem-
plates must be evaluated and assessed to
determine which will be converted, which will
be used “as-is,” and which will be redone.
Compatibility issues must be examined with
other software used by the firm and by other

firms with which the firm interacts. Potential
customization issues need to be identified.
Network, browser, and Internet profiles need to
be established. Security and Training needs
must be addressed.

Because the findings of one team member can
affect the analysis of other team members, the
project manager has decided to include weekly
meetings in the project plan during the planning
phase to exchange findings. The meetings will
be held every Thursday, and team members can
place this meeting on their calendars.

Solution: To include this weekly meeting in the
project schedule, the project manager sets up
a recurring task that will last over the life of the
planning phase of the project, which is pro-
jected to last approximately 53 days, as shown
in the duration column for the summary task in
the figure. The project manager uses the sum-
mary task bar of the Planning phase to identify
the starting and ending dates of the Planning
phase, determining that the phase is scheduled
to begin on December 26, 2006 and end on
March 8, 2007.
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If you open the project file for this case study the recurring task. You also can double-click
on our book’s Web site, you can hover the the summary task for the recurring task to view
cursor over the Indicators column to see the the settings we used to create this weekly
information stored about each occurrence of recurring task.

Suppose, though, that you have a series of tasks that you need to repeat in
the outline. For example, when planning to install new software company-
wide, you typically set up test environments that mirror the conditions
under which the new software will run, and then you test the software
repeatedly. So, the test plan portion of your project plan might include tasks
like Run Test Case, Record Results, Revise Test Case, Rerun The Test, and
Record Revision Case Results for each test case you devise. Instead of typing
these tasks repeatedly, you could enter them once and then use the Fill
handle — a small black square that appears in the lower-right corner of a
selected cell — to copy them repeatedly. When all the repeated tasks appear
in the project plan, you can simply insert summary tasks that represent each
of the test cases and therefore distinguish the groups of repeated tasks from
each other.
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Figure 1-13:
Take
advantage
of the fill
handle to
copy tasks
that repeat.

The Fill handle copies tasks into a contiguous range. If the range already con-
tains information, using the Fill handle to copy overwrites the existing infor-
mation. To avoid this problem, insert blank rows in the project before using
the Fill handle. Select the task that you want to appear beneath the new row
and press the Insert key on your keyboard. To insert several blank rows, select
the number of rows that you want to insert before pressing the Insert key.

To copy a contiguous group of repeated tasks using the Fill handle, follow

these steps:

1. Select the tasks by using any of the techniques described earlier in

this chapter.

If you include both the task name and the duration in the selection,
Project copies both the task name and the duration.

2. Place the mouse pointer over the Fill handle in the lower-right corner
of the selection.

The mouse pointer changes to a plus sign (+).

3. Drag the fill handle down until you have selected the group of rows
that you want to contain the repetitive tasks (see Figure 1-13).

Fill handle
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Figure 1-14:
The tasks
you
selected
appearin
the range
you
selected
using the fill
handle.
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4. Release the mouse button when you have selected the rows you want
to fill.

Project copies the tasks into the selected range (see Figure 1-14).

f§

1 File

a

@ > 4 =

Microsoft Project - 030110.mpp
Edit  View

DEHd SR T %%

Insert Farmat

Show - | Arial

Task Name

R
R
R
[
R
[
R
[
R
R
R
[
R
[
R
R
R
R
R
R
R
R

o

Run test case:

Tools

< M)

ion

Project Report Collaborate  Wind

Start

Man 171507
Tue 111607
ed 11707
han 1722007
Tue 172307
han 171507
Man 171507
han 171507
Man 171507
Man 171507
Man 171507
han 171507
Man 171507
han 171507
Man 171507
Man 171507
Man 171507
Man 171507
Man 171507
han 171507
Man 171507
han 171507
Man 171507

Finish

Mon 1/507

Tue 1407

Fri 197
Man 122107
Tue 12307
Wan 141507
Wan 14507
Wed 14707
Wan 14507
Wan 141507
Man 14507
Wan 141507
Wed 147107
Wan 141507
Won 14507
Wan 141507
Waon 14507
Wed 11707
Wan 14507
Wan 141507
Wan 145107
Wan 141507
Wed 147107

ow Help
= & Mo Group R FE@
Al Tasks -
n7, 07 Jan 14,07 Jan 21, 07 Jan 28, 07 Feb 4,07 -
M T WIT [F ]SS [T T F[S[SM[TWITIF[S[SM[T[WIT[F[S[S[M]TWIT]F

“Eﬁﬂﬂﬂﬂﬂﬂﬁnlﬁﬂﬂnﬂﬁ

L

Q%

Book I
Chapter 1

o2
= =Q
e
@ S S,
O E N
—_, - =
-
Ngg.—h
=ﬂ’g



162 ook 111: Getting Your Plan in Order



Chapter 2: Assigning Outline
Codes to Tasks

In This Chapter

v+ Understanding outline numbers
v Assigning outline numbers

+ Understanding outline codes

v Creating customized outline codes

v Adjusting outline codes and renumbering

ou have a couple of options that you can consider if you want to assign

outline numbers to the tasks in your schedule. In addition to the WBS
(work breakdown structure) codes described in Chapter 3 of this minibook,
you can use automatic outline numbering, or you can use outline field codes.

Make the choice between outline numbers and outline codes based on
whether you want the value to remain static when you make changes to the
project’s outline structure. When you use outline numbers, Project automat-
ically updates the numbers if you change your project’s outline structure.
When you use outline codes, Project doesn’t make any changes to the value
when you change your project’s outline structure.

Understanding Outline Numbers

Project can assign outline numbers to the tasks in your schedule based on
the task’s level in the outline; the outline numbers help you identify, visually,
each task’s hierarchical position in the outline. In addition, you can easily
and clearly refer to tasks by using their outline number.

Project uses an outline numbering system that’s similar to the numbering
system you find in most legal documents. You usually find a whole number
preceding each major heading in a legal document. Headings subordinate to
the major heading are numbered with the major heading’s whole number, a
period, and then a subordinate paragraph number. So, the first paragraph
under the first major heading is numbered 1.1, and the second paragraph
under the first major heading is numbered 1.2.
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By default, Project uses the same numbering scheme, assigning whole num-
bers to tasks that aren’t indented at all. Subtasks are assigned outline num-
bers based on what task they fall under and how many times they are
indented from the left edge of the outline.

Letting Project Assign Outline Numbers

Figure 2-1:
When
Project
assigns
outline
numbers,
each task's
number
reflects its
level in the
outline.

You can let Project assign outline numbers that identify each task’s level in
the outline, as shown in Figure 2-1. Project adds a number that you can’t edit
to the task’s name. Like the legal numbering scheme described in the previ-
ous section, Project assigns whole numbers to the tasks at the left edge of
the outline, which are tasks at the top level of the outline. To each subtask of
a task at the left edge of the outline, Project assigns the whole number, fol-
lowed by a period, and then a sequential number for each subtask. Project
continues to follow this pattern for any subtasks that appear beneath other
subtasks. So, in Figure 2-1, the tasks at the left edge of the outline — the
highest level in the outline — display numbers 1, 2, 3, and 4. Below Select a
Location, which is Task 1, each subtask displays a number that includes its
parent number and a sequential number for its place in the outline. The Sell
Tickets task, with outline number 3.4, is the fourth subtask under the third
top-level task.
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Figure 2-2:
Use the
Show
Outline
Number
check box
to add
outline
numbers to
task names.
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Understanding Outline Codes

To display outline numbers, follow these steps:

1. Choose Tools=>Options to display the Options dialog box.

2. Click the View tab.

3. Select the Show Outline Number check box in the Outline Options sec-

tion (see Figure 2-2).

Options
Save Interface Security
Schedule Calculation Spelling
Wiem General Edit
Default view: | Gantt Chart El
Calendar type: | Gregorian Calendar Ei
Date format; | Maon 1)28/02 El

Show
[7] 5tatus bar [¥] 5croll bars
[V] Windows in Taskbar [¥] Enttry bar
7| Bars and shapes in Gantt views in 3-0

Cross project linking options for '030201.mpp'

7| Show esternal successors

[7] Show external predecessors
Currency options For ‘030201 mpp'
L$7J Decimal digits: ﬁ]
B [ coreney [up
Outline optians For '030201.mpp’

7] Indent

Symbol:

Placement;

[¥] show outiine symbol

[¥] Shows summary tasks

‘ Help

M

] Shows links between projects dislog box on open

Automatically accept new exte

3| data

o] |

Collahorate:
Calendar

[¥] OLE links indicators

7] Project screentips

[¥] Show project summary task

Cancel

4. Click OK.

Understanding Outline Codes

When you use the technique described in the preceding section to assign
outline numbers, you can’t edit the outline numbers. You must simply
accept the outline numbers Project assigns.

Suppose, though, that you want to assign codes to your tasks that reflect the
way your organization does business. For example, you might have devel-
oped accounting codes that use an outline format and you want to assign
these codes to each task. You can use a custom outline code field to create
your accounting codes and assign them to each task.
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Project’s automatic outline codes and custom outline codes aren’t mutually
exclusive — you can assign both to your tasks. They differ in that you can
control the appearance of custom outline codes but not the appearance of
Project’s automatic outline numbers. In addition, outline codes aren’t tied to
the hierarchical structure of your project like outline numbers are but can be
set up to use a hierarchical structure that you define. And, outline numbers
and outline codes behave differently when you move a task.

Designing Your Own Outline Numbers

\\3

You can enter outline code information in an ad hoc manner, but most
people create a list of valid outline codes so that the outline codes assigned
are meaningful and consistent.

Although outline codes aren’t dependent on the structure of your project
outline, they do work in a hierarchical fashion — hence the name outline
code. However, you define the hierarchy by defining codes at the highest
level — we’'ll call that Level 1 — and then additional codes at various subor-
dinate levels — Level 2, Level 3, and so on. Level 2 codes would appear sub-
ordinate to Level 1, Level 3 subordinate to Level 2, and so on.

Defining a custom outline code is a three-part process:

1. You select an outline code to customize. Project contains ten outline
code fields that you can customize for a variety of purposes.

2. You set up a code mask that defines the size and content of each por-
tion of the code. The code mask defines the appearance of the code, and
when you define the code mask, you can use numbers, uppercase let-
ters, lowercase letters, or characters (a combination of letters and
numbers).

3. You set up a lookup table for the outline code. The lookup table con-
tains the valid values for the outline code that you can assign to tasks.
By using a lookup table to assign outline code values, you ensure that
the outline code values you use are both valid and consistent.

Although Project won’t limit you, try not to get carried away defining subor-
dinate levels of outline codes; stacking codes deeply makes them harder
to use.

Selecting an outline code to define

To complete the first part of the process of defining an outline code, follow
these steps to select an outline code to define:

1. Choose Tools—>Customizer>Fields.



Figure 2-3:
Use this
dialog box
to define
the type of
custom field
you want

to set up.
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Project displays the Custom Fields dialog box (see Figure 2-3).

Custom Fields ==
Field

@ Task I Resource Project Type:

Figld

Qutline Codel
Qutline Codez
Qutline Code3
Outline Codet
Outline Codes
Qutline Codes
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Duratian

[ Rereme.. | [ Dpelete | |acdFisidto Erterprise. .

| Import Field...

Custom attributes

None (@

Lookup. .. |

Calculation For task and group summary rows
T —

Caleulation For assignment rows

Formula. ..

Use Farmula

Mone ) Rall down urless manually entersd

Values to display

al Indicatars. .

OF ‘ | Cancel

Figure 2-4:
Renaming
the outline
code makes
it easier

for you to
remember
its purpose.

2. Open the Type drop-down list and select Outline Code.
3. Select an Outline Code from the Field section to customize.

4. Click the Rename button and type the new name (see Figure 2-4).

Rename Field ==

Mew name For 'Outline Codet';

[Account Cadel ]

| Ok ‘ | Cancel

5. Click OK to redisplay the Custom Fields dialog box.

Continue reading the next section to define a code mask for the outline code.
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Defining the code mask

We didn’t ask you to close the dialog box in the previous section because
you haven’t finished the process of defining an outline code. When you use a
code mask, you define the format of the code — the number of characters in
each part of the code, and whether the characters are numbers, letters, or a
combination. To define the code mask, follow these steps:

1. Click the Lookup button.

Project displays the Edit Lookup Table dialog box. In Figure 2-5, we've
collapsed the dialog box so that you can focus on the pertinent part at
this point — the code mask.

Figure 2-5:
Use the
options in
this dialog
box to
define the
allowable
lookup
codes.

Figure 2-6:
The Code
Mask
Definition
dialog box.

Edit Lookup Table for Account Code ==
|3 Code mask {optional)

‘fou can edit the mask for the laokup table, |
including adding ar deleting levels,
Code preview: | ¥

Edit Mask.. |

[+ Lookup table
(1| Display order for lookup table
l+]

[+ Data entry options

| Help l Import Lookup Table. . | | Close |

2. To define a mask for the lookup table, click the plus sign (+) beside
Code Mask.

The plus sign changes to a minus sign (-) and displays the top portion of
the Edit Lookup Table dialog box.

3. Click the Edit Mask button.

Project displays the Code Mask Definition dialog box, shown in Figure 2-6.
As you define the code mask, Project displays filler characters in the Code
Preview box.

Code Mask Definition for Account Code [ExH|
Code preview: [aan.11 ‘

Code mask:
| Mumbers -
Level Sequence Length Sepatator

1 Uppercase Letters 3

| Help [o]4 1 | Zancel
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4. Click the first blank row in the Sequence column to display a drop-
down arrow and select the type of character that you want to use for
the first part of the outline code.

If you choose Characters, Project initially displays asterisks for that
part of the code mask in the Code Preview box, indicating that you can
replace those asterisks with any characters that you want when you
define values in the Lookup Table.

5. Click the first blank row in the Length column and then specify a
length for that portion of the outline code.

6. Click in the first blank row of the Separator column and select a char-
acter to separate the parts of your WBS code.

You can choose a period (.), dash (-), plus (+), slash (/), or type any
character that isn’t a number or a letter (such as =).

7. Repeat Steps 4 through 6 for each level you want to define in your out-
line code.

8. Click OK to redisplay the Edit Lookup Table dialog box.

In the next section, you see how to create valid values that can appear as the
task’s outline code.

Defining values for the lookup table

Finally, to complete the process of defining an outline code, define a list of
acceptable entries to use when assigning the outline code to tasks in the
project. Follow these steps with the Edit Lookup Table dialog box still open:

1. Click the plus sign beside Lookup Table.

Project expands the Edit Lookup Table dialog box so that you can define
lookup table values (see Figure 2-7).

2. On Row 1 of the Value column, type a permissible value for the first
level of your outline code — think of it as Level 1 — and press Enter.

You can optionally type an explanation of the value in the Description
column.

3. On the next line, type an outline code for the second level that is per-
missible under Level 1 and press Enter.

4. Move the pointer back into the row in which you typed a Level 2 out-
line code and click the Indent button (the right arrow) at the top of
the dialog box to indent the value.

5. On subsequent lines, type other acceptable Level 2 values.
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Edit Lookup Tahble for Account Code ==
(2] Code mask {optional)

*fou can edit the mask for the lookup table,
including adding or deleting levels,

Code preview! i.‘n.\.i 11

[=] Lookup table

(%] ] @] B B [¢] (3] [+] [=] [

[¥] Display indenting in lookup table

| Use a value from the table as the default entry For the Field

Edit Mask. .. |

Walug Description
= HRD Human Resources Deparkment

= ACC Accounting

Set Default (Click. button after selecting a walue above)

6. If you need a Level 3 outline code under a Level 2 outline code, simply

type the code on a blank line below the Level 2 outline code, press
Enter, move the pointer back to the line on which you just typed the

. To supply another Level 1 code, type the code on a blank line, place

the pointer on the code’s row, and click the Outdent button (the left
arrow) as many times as necessary, depending on the last code that

button at the top of the dialog box. And, if a code becomes invalid at
some later date, reopen this dialog box, highlight the code, and click the

Figure 2_7: |£] Display order for lookup table
Define 4] Data entry options
lookup table
Values. | Help Import Lookup Table. ., | | Clase ]
code and click the Indent button.
w 7
you entered.
= If you forget to include a code, highlight the code that you want to
= appear below the code that you’ll add, and then click the Insert Row
Delete Row button.
<® You can click the plus sign beside Display Order for Lookup Table to

control the order in which lookup table codes appears. Similarly, you
can click the plus sign beside Data Entry Options to allow users to add
codes to the lookup table or to force entry of only Level 1 codes. In both
cases, when you click the plus sign, it changes to a minus sign and dis-
plays your options.
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8. Click Close to redisplay the Custom Fields dialog box.

9. Click OK to save your outline code settings.

Entering outline codes

After you define an outline code, you need to insert a column in a table to
display outline codes. Follow these steps:
1. Display a view that includes a table, such as Gantt Chart view.

2. Right-click the name of the column that you want to appear to the
right of the column that will display the outline code.

3. Choose Insert Column from the shortcut menu that appears.

The Column Definition dialog box appears (see Figure 2-8).

Column Definition =
Field name: B
Title: | |
glign title: | Center [+]
Align data: [Right EI
Width: 1_10 | [ 7] Header Text Wrapping

st | [ ok | [ canel |

4. From the Field Name list, select the outline code you customized.

After you open the list, you can type the first letter of the name you
assigned to the outline code to see the first choice in the list that begins
with that letter.

5. Click OK.

Project displays a column for the outline code you customized. No
codes appear in the column yet because you need to use the lookup list
that you defined to assign a code to each task.

6. Enter values in the custom outline code column by clicking in the out-
line code column.

Project displays a list box arrow.

7. Open the list to display the entries from the lookup table and select a
code (see Figure 2-9).
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Outline Numbers and Codes and Renumbering

What happens to outline numbers and outline codes when you move tasks?
Insert new tasks? Delete tasks? Well, that depends.

If you're using the outline numbers, Project renumbers affected outline num-
bers automatically if you move a task, insert a new task, or delete a task. In
Figure 2-10, we’ve hidden all the subtasks except for those in the Select a
Location phase. When we switch the first two subtasks, Project automati-
cally renumbers them, as you can see in Figure 2-11. We also added a new
task — cleverly named New Task — just above the Review and Sign Contract
task. Project renumbered the Review and Sign Contract task from 1.4 to 1.5
to accommodate the new task’s number, 1.4, and place in the outline.

Although Project automatically renumbers outline numbers, Project doesn'’t
automatically renumber outline codes when you move tasks, insert new
tasks, or delete tasks. Outline codes are static values you assign. Although
you can create a hierarchical structure for an outline code, Project doesn’t
read the outline codes as values that can be sorted in any particular order.
Further, Project doesn’t associate the outline codes with the level of the task
in your project schedule outline. So, Project doesn’t renumber outline codes
when you make structural changes to the tasks in your outline.
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In Figure 2-12, we’ve displayed the customized outline code we created ear-
lier in this chapter. In Figure 2-13, we’ve once again switched the first two
tasks and added a new task above Review and Sign Contract. As you can see,
the outline codes assigned to each task stayed with the task, and the new
task has no outline code assigned automatically.

Use outline numbers if you want Project to automatically update the num-
bers based on changes to your project’s outline structure. Use outline codes
if you want the value you assign to the task to remain static, regardless of
the changes you make to your project’s outline structure.

For a combination approach, consider using WBS codes; you can read about
them in the next chapter of this minibook.

(= Microsoft Project - 030212.mpp =
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Chapter 3: Using WBS Coding

In This Chapter

v+ Understanding WBS codes
1 Creating WBS codes

v Creating a WBS chart

v Customizing WBS codes

1 Understanding WBS codes and renumbering

Like outline numbers and codes, WBS codes provide a way to number
tasks in a project; the structure of the WBS code helps the reader iden-
tify the phase of the project in which the task occurs. You can use WBS
codes instead of or in addition to outline numbers and outline codes.

WABS stands for work breakdown structure. WBS codes were originally devel-
oped by the United States defense establishment to help identify tasks in a
project based on the phase in which the task occurs. So, you can use WBS
codes as another way to organize tasks in a project. In this chapter, you
explore Project’s support for WBS codes.

What's a WBS Code?

The United States defense establishment designed a numbering system,
reminiscent of the paragraph numbering used in legal documents, to help a
person viewing a list of project tasks quickly and easily identify the phase in
which the task occurs and its relationship to other tasks in the phase. When
working with the government, unique WBS codes are often assigned to each
task in a project, and the tasks are often referred to by their WBS codes.

In Figure 3-1, you see a common view of a WBS chart, which probably
reminds you of a company organization chart. Notice how each task’s WBS
code identifies the phase in which it occurs and the phase’s hierarchical
relationship in the project; for example, the third task in the first phase of
the project has a WBS code of 1.3.

Although Project doesn’t produce a WBS chart picture, you can assign WBS
codes to the tasks in your project.



178 Creating WBS Codes

Figure 3-1:
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Creating WBS Codes

You don’t have to create WBS codes; you can use the default codes that
Project assigns to your tasks. Project assigns WBS codes based on a task’s
position in the outline structure. So, you start by setting up your outline so
that it displays the summary task and subtasks with which you want to
work, as described in Chapter 1 of this minibook. Then follow these steps
to display the WBS codes that Project has already assigned to each task:

1. Display a view that includes a table, like Gantt Chart view.

2. Right-click the name of the column that you want to appear to the
right of the column that will display WBS codes.

3. Select Insert Column from the shortcut menu that appears.
The Column Definition dialog box appears (see Figure 3-2).
4. From the Field Name drop-down list, select WBS.

After you open the list, you can type a W to see the first choice in the list
that begins with W.

5. Click OK.

Project displays WBS codes for each task in the WBS column, as shown
in Figure 3-3. The WBS code that Project assigns to each task is based on
the task’s level in the outline; tasks at the highest level of the outline
have whole numbers for WBS codes.
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Creating a WBS Chart

Project doesn’t contain a view of your project as a WBS chart, but you can
create a WBS chart from your project data in two ways:
4+ Using Visio, as we describe in this section

4+ Using WBS Chart Pro, a software add-on that takes Project files and cre-
ates WBS charts
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Visit www.criticaltools.com to find out more about WBS Chart Pro.

To use Visio to create a WBS chart from Project data, you need Visio 2007
installed on your computer. You create a WBS chart using the visual reports
in Project, which are new to Project 2007. To create a WBS chart with Project
data in Visio, you create a visual report that contains the information you
want to view in Visio. In Visio, you make some modifications to display WBS
numbers. Follow these steps to create a Visio report in Project, send the
data to Visio, and modify the Visio report to display WBS numbers:

1. Open the project for which you want to create the WBS chart.
The project doesn’t need to display WBS codes.
2. Choose Report->Visual Reports.
The Visual Reports — Create Report window appears (see Figure 3-4).

3. On the All tab, click a report to use as a foundation for your template;
for this example, we chose Task Status Report (US).

4. Click the View button.

Visio opens on your computer, displaying the visual report you selected
using the data found in the project you opened in Step 1. The WBS num-
bers don’t appear by default.
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5. Right-click any graphic on the Visio report and choose Datar>Edit Data
Graphic (see Figure 3-5).

Visio displays the Edit Data Graphic dialog box (see Figure 3-6).

6. Click New Item and choose Text.

Visio displays the New Text dialog box (see Figure 3-7).
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We displayed more tasks in the project by selecting both tasks (using
Ctrl+Click) at the bottom of the Visio diagram and then clicking Tasks in the
Add Category section on the left side of the Visio screen.

If you use custom WBS codes and you’ve assigned them to tasks so that they
don’t match the hierarchical structure of your project, the Visio report won’t
be a true WBS chart; it will display your custom WBS codes but it will pres-
ent the report hierarchically using Project’s built-in WBS codes, which do
match the hierarchical structure of your project.

Customizing WBS Codes

By default, Project assigns WBS codes using numbers only, and it bases the
assigned number on each task’s position in the project schedule’s outline.
Project assigns whole numbers to the tasks at the left edge of the outline,
which are tasks at the top level of the outline. To each subtask of a task at
the left edge of the outline, Project assigns the whole number, followed by a
period, and then a sequential number for each subtask. Project continues to
follow this pattern for any subtasks that appear beneath other subtasks.

You can think of the whole number as identifying a phase of the project;
tasks within that phase start with the phase’s whole number followed by a
period and a sequential number. So, the third task in the second phase of the
project would have the number 2.3.

Often, those default numbers work just fine. However, you might find yourself
in a situation where you want to modify the appearance of the WBS code to
incorporate information that’s meaningful to you and your client. For exam-
ple, you might want to include the project name or a client number as a
prefix for the WBS code. Further, you might want to include letters in the
WBS code along with numbers, as does the project shown in Figure 3-9.

You can customize the WBS codes that Project assigns by establishing your
own code mask, the code mask defines the appearance of the code. When you
define the code mask, you define the length of the code. You can use any or
all of the types of information listed in Table 3-1.

Table 3-1 WBS Code Mask Elements

Code Mask Element Displays

Numbers (ordered) Numbers in sequential order
Uppercase Letters (ordered) Capital letters in alphabetical order
Lowercase Letters (ordered) Lowercase letters in alphabetical order

Characters (unordered) Numbers or letters in no order

Buipog sgm buisn



18 4 Customizing WBS Codes

(= Microsoft Project - 030306.mpp =R
2] File Edit View Inset Format Tools Project Report Collaborate Window Help Type & question for help -8 x
DS @RV %E5@BS 9- | bl %= & | NoGroup - AT E@
¥ P 4+ = ¥y Show~ | Aral - = | All Tasks T Ve | 2
a WBS Task Name Durstion  J5. | Dec17,'06 | Dec 24, 06 Dec 31,'06 Jan7, 07 .
WWITIF S S [M[T [T [F 5[5 [M[T [T [F 5[5 [M[TWT[F[5[5[M[T W]
o C102- = Microsoft Office 2007 Deployment 159 days =
1 C1021 = Envisioning 1 days o
2 10241 A Sumimarize current information wworker tools 2day: - Stakeholders
3 c1021.8 Idertify corporate desktop vision concerms (for = 2oy Stakeholders
4 C102-1.C Determine project scope (for example, early adop 3 dlay: Stakeholders
s C1021.0 Determing major milestones 1 day Project Manager.
& C1021E Secure executive sponsorship 3 day: - Project M
7 1021 F Envisioning complete ddays i g
& C102-2 + Assembie Project Teams, Define Roles 6 days .
19 C102-3 = Planning 51 days
Fi g ure 3_9: 20 C102-3.A = Identify t_:o?xistenne S(-rfne-gies - 5 days
21 C102.3.81 = Identify interoperability issues within th 1 day
C ustom ize d 2 Cl02-341a Ientity suites 1 s
2 C102341k Identity versions 1 day
WB S C Od es 24 102382 Ickertity iteroperabity issues with the organt 3yt
. 25 C102343 ertity interoperakbilty issues with third-party 2days
can display ® STTRTYY it ESE ETE UAE S Dy
27 C102:38 +! Identify Migration Strategies 25.5 days
more ERES C102:3C ¥ Identify Desktop Operating Systems 4days
infO rm atl on C=I=3 €102-3.0 * Idem?fy Cnnﬁgumlrinnsﬂcuslnmiznlinrns ] 16 days
56 C102.3€ #l Identify Collaboration Platform Consideratic 10 days =
th an just the 60 CA02-3F ! Identify ing Platform Consi i 27.5 days o
, 65 C102:3.6 # Identify Technical Requirements for Deploy 5.5 days
tas k S 100 C1023H + Plan Security 6 days
. . 104 1023 ¥ Define Distribution Strategies 2days
hierarchical 12 €102-3.) + Sperify Custom Package Configurations 115 days
P H 131 C1023K +I Develop Training Strategy 12 days
pOSItIOn In 136 c102:3L + Identify Test Scenarios 5 days
th e p rO]' e Ct 143 C102-3M Planning complete 0 dlays
! 144 €102-4 = Deployment 90 days ~
outline. i nn s oot Sl T
Read

The first three elements are fairly self-explanatory, but the last element,
Characters (unordered), deserves a little more attention. If you include
Characters (unordered) in your code mask, Project initially displays aster-
isks for that part of the code mask, and you can replace those asterisks with
any characters that you want. For example, suppose that you use a mask of
Numbers (ordered) with a length of one, Characters (unordered) with a
length of 3. For any second-level task, you can enter any three characters
that you want for the second part of the WBS code. In this example, when
you enter a second-level task, you initially see a WBS of 1.***. However, you
can change it to something like 1.x%7.

To create your own custom WBS codes, follow these steps:

1. Choose Project=>WBS=>Define Code.
‘&QN\BEB Project displays the WBS Code Definition dialog box (see Figure 3-10).
&
<

The Code preview box shows you the format of the WBS code that you're
designing as you design it, so it appears blank until you make selections.

2. In the Project Code Prefix box, type a prefix that you want to appear
at the beginning of all WBS codes.

For example, you might want to use the initials of the project name or a
client number.



Figure 3-10:
Use the
WBS Code
Definition
dialog box
to define the
appearance
of the

WBS code.
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3. Click the first blank row in the Sequence column to display a drop-

down arrow and select the type of character that you want to use for

the first part of the WBS code.

4. Click the first blank row in the Length column and then specify a
length for that portion of the WBS code.
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You can type a number, choose Any, or choose a number between 1 and 10.
If you choose 3 for the first level of your WBS code, the WBS code for all
tasks in the first phase of your project begins with your project code
prefix followed by 001, and the WBS code for all tasks in the second phase

of your project begins with your project code prefix followed by 002.

Choosing Any, the default choice, is a safe bet because Project then
automatically expands the WBS code to accommodate the task’s posi-
tion in the outline.

In case you care, | tested the number 100, and Project accepted it. But
using a 100-digit number in a WBS code isn’t particularly practical.

5. Click in the first blank row of the Separator column and select a char-

acter to separate the parts of your WBS code.

You can choose a period (.), dash (=), plus (+), or slash (/), or you can
type any character that isn’t a number or a letter (such as =).

6. Repeat Steps 3 through 5 for each level in your outline.

7. Click OK to save your customized WBS code.

You might have noticed that the two boxes at the bottom of the WBS Code

Definition dialog box in Figure 3-10 were both checked. Project selects these
boxes by default; leaving them selected ensures that new tasks you insert in

the project are assigned WBS codes and that all WBS codes are unique.

When might WBS codes not be unique? If you insert a subproject, it’s possi-

ble that the subproject might contain WBS codes that duplicate those that
already exist in your project.

Read more about inserting subprojects in Book 4 of this minibook.
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WBS Codes and Renumbering

What happens to WBS codes when you move tasks? Insert new tasks? Delete

tasks? Well, that depends.

If you're using the default WBS codes that Project inserts (that is, if you haven’t
customized WBS codes), Project renumbers affected WBS codes automati-
cally if you move a task, insert a new task, or delete a task. In Figure 3-11,
we’ve hidden all the subtasks except for those in Phase 1. When we switch
the first two subtasks, Project automatically renumbers them, as you can see

in Figure 3-12.

If, however, you use a custom code mask for WBS codes, Project doesn’t
automatically renumber the subtasks. In Figure 3-13, we customized the WBS
codes for the same project shown in Figure 3-11. We made sure that both
check boxes at the bottom of the WBS Code Definition dialog box were
selected to ensure that Project would generate a new WBS code for any new
task we insert and that the WBS code would be unique.
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Figure 3-14:
Project
doesn't
auto-
matically
renumber
tasks that
use
customized
WBS codes
when you
change the
project
outline.

In Figure 3-14, we once again switched the first two subtasks. As you can see,
the WBS codes appear to be out of sequential order; Project lists the task
with WBS code C102-1.B before the task with WBS code C102-1.A.

We also inserted a new subtask before the first subtask; notice that its WBS
code of C102-1.G is unique, but again, out of sequential order.

Project uses this behavior with custom WBS codes because there are cir-
cumstances under which you don’t want to renumber the WBS codes in
your project. However, for those times when you do want to renumber WBS
codes, you can. Choose Project>WBS>Renumber. Project displays the WBS
Renumber dialog box, shown in Figure 3-15. Click OK, and Project renumbers
the WBS codes in the project schedule.
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WES Renumber

Fenumber WES codes Far:

Selected tasks

@ Entire project

If you want to renumber the WBS codes for only some tasks, select those
tasks before you open the WBS Renumber dialog box. Project then offers you
the option of renumbering only the selected tasks or the entire project.
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Chapter 4: Linking and
Consolidating Projects

In This Chapter

v~ Linking projects

v+~ Consolidating projects

+ Understanding consolidation and dependencies

v Viewing a consolidated project

v Following the critical path in a consolidated project

v Using a resource pool

In this chapter, we look at different ways to link and insert projects. For
example, you can include a link in a project to backup documentation

stored in an Excel spreadsheet, or you can create several project files that
cover different phases of the same project and then consolidate them to

look at the big picture. As you read about these techniques, you also see

how they can affect the structure of your project.

Connecting Projects with Hyperlinks

You can link one project to another by using a hyperlink. A hyperlink enables
you to jump from the currently displayed document to another document
on your hard drive, a computer network, or the Internet — useful when, for
example, you'd like your Project schedule to reference some backup infor-
mation stored in a Word document, an Excel spreadsheet, or even another
Project file.

Creating a hyperlink

When you insert a hyperlink in a project schedule, you can link an existing
task to another project or create a new task that you can use to represent
the timing or costs of another project. The hyperlink contains information
about the physical location of the other Project file, but it doesn’t contain
any of the timing or cost information, so you have to add that information to
the task formed by the hyperlink.
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To create a hyperlink to another Project file, follow these steps:

1. Select a blank cell in the Task Name column where you want the
hyperlinked task to appear.

2. Choose Insert->Hyperlink or click the Insert Hyperlink button on the

Standard toolbar.
The Insert Hyperlink dialog box appears (see Figure 4-1).
'Insert Hyperlink |
Link_tu:_ : Tesk o digplay; Word 2007 Deployment Planning phase ‘ SereenTip... ‘
IL| Lok fn: Project 510 Data Files =] @ [&ll=E
Existing Filz or e ——————— — sl P —
\Weh Page 124 subproectt.mon - ‘ Bookmark.. |
%gi;i?rt ﬂ% subproject?,mpn e_e—
B2 Talant shiow, csv
Plg::i#Th'\s | &=l Talent show, mpp
Dioeurment Browsed | Task Usags.cub
Figure 41 P R e i
Use thIS Cfeate Mew | R 51 Word 2007 Deplayment - Flanning Phase.mpp
. acumer| s ‘ord eployment - Planning Phase.<ml
d|alog bOX il t [ il | Word 2007 Deployment - PI a Fi bl =
to set up the Address: Ward 2007 Deployment - Planning Phass mpp [_:]
hyper“nk E-mail Address i — ! |m
3. In the Text to Display box, type text that represents the hyperlinked file.
This text should explain to viewers what they’ll see if they click the link.
4. In the Link To area on the left, select the Existing File or Web Page
option.
5. Use the Look In drop-down list to select the file or Web page to which
you want to link.
6. Click OK.
Project inserts the hyperlink. A hyperlink icon, like the one shown in
Figure 4-2, appears in the Indicator field to the left of the selected task.
When you move the mouse pointer over the icon and pause, Project displays
a ScreenTip containing the text you supplied in Step 3. If you click the hyper-
link icon in the Indicators column, Project opens the file associated with the
hyperlink.
A\

To remove a hyperlink, right-click the task for which you created the link and
then choose Hyperlink=>Remove Hyperlink. No warning appears; Project
simply removes the hyperlink.



Figure 4-2:
When a task
contains a
hyperlink,
you see the
hyperlink
icon in the
Indicator
field.
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Hyperlink icon
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What happened? My hyperlinks don’t work

Typ
link

ically, when a hyperlink doesn’t work, the file to which you created the
no longer exists in the location you specified when you created the link,

which can happen for two reasons:

+

+

The linked file was deleted. If the file has been deleted, you can’t link to
it any longer.

The linked file was moved to a new location. Here’s some good news:
You can avoid hyperlinks that don’t work because files moved. To pre-
vent such a calamity, simply use relative addressing whenever possible
when you create hyperlinks. For example, g: \project .mpp is an
absolute address. If your server drive changes from G: to H:, the link
won’t work. However, if you use \ \servername\share\project .mpp,
a relative address, your server drive can change from G: to any other
letter, and the relative address to your server will still work.

Book I
Chapter 4

sjaaloid
Bunepijosuo?
pue Bunjur



794 Connecting Projects with Hyperlinks

Figure 4-3:
Using the
Hyperlink
table gives
you easy
access to
hyperlink
information
ata glance.

Editing hyperlinks

If you create a lot of hyperlinks, using the Project ScreenTip that appears
when you hover the mouse pointer over each link to review hyperlink infor-
mation can be tedious. You might find it easier to display hyperlinks in one
of Project’s built-in tables by following these steps:

1. Begin in any view that includes a table, such as Gantt Chart view.
2. Choose Viewr>TableoHyperlink.
The Hyperlink table shown in Figure 4-3 displays columns of information

relevant to any links that you’ve created for your project.

You can edit the hyperlink by using the Edit Hyperlink dialog box. Right-click
the link and choose Hyperlink=>Edit Hyperlink to reopen the dialog box
(shown previously in Figure 4-1) and make changes.
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Moving or copying hyperlinks

If the information in the hyperlinked file becomes pertinent to a different
task or more than one task, you can move or copy the hyperlink from one
task to another by using the Hyperlink table. Follow these steps:

1. Select the hyperlink cell by clicking its task name and then using the
right-arrow key to select the hyperlink cell.

Clicking a cell in the Hyperlink, Address, or SubAddress column of a task
containing a hyperlink activates the link.

2. Press the Shift key and the right-arrow key to also select the address
and, if appropriate, the subaddress of the hyperlink.

3. Do one of the following:

e To move the link: Click the Cut button on the Standard toolbar, click
the hyperlink cell next to the task where you want to move the link,
and then click the Paste button.

e To copy the link: Click the Copy button, click the hyperlink cell next
to the task where you want to place a copy of the link, and then click
the Paste button.

Consolidating Projects

Sometimes you have a really complex project to manage, and although you
can expand and collapse the outline for the schedule, you feel you’d work
better if you could just focus on one piece with no other distractions —
including collapsed portions of the outline. Setting up separate projects for
each phase would help you focus, but what do you do about dependencies
across phases? And resource allocations?

The answer: Use consolidation.

What is consolidation?

Consolidating is a useful way to break a complex project down into smaller
projects — referred to as subprojects — and then combine the smaller projects
into one large project when you need to look at the big picture. Consolidating
projects can help you manage the following situations:
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4+ A project might be so complex that breaking it into smaller pieces can
help you to organize it. You can use consolidation to combine the sub-
projects to view the big picture.

4+ Suppose that you have tasks in a project that are managed by different
people and those tasks are interdependent. By creating subprojects and
using consolidation techniques, you can allow independent project man-
agement and still create the correct dependencies between the schedules
of the various subprojects and assign the necessary resources.

4+ If you use the same resources for several projects, you can consoli-
date those projects so that you can level the resources and avoid
overallocations — and surprises.

See Book VII, Chapter 2 for more information on handling resource
overallocations.

When you use Project’s consolidation features, you create subprojects that
contain the tasks that constitute one portion of your project, and you save
the subproject as a separate project file. You assign resources and set up
each subproject with links and constraints, just as if you were working with
the entire project.

While working in the consolidated project, you can focus on any portion of
the project. Subprojects appear as summary tasks in the consolidated proj-
ect, and you can use Project’s outlining tools to hide all tasks that are associ-
ated with any subproject. You can view, print, and change information for
any subproject, just as if you were working with a single project. Figure 4-4
shows you a consolidated project.

You can review outlining techniques in Chapter 1 of this minibook. And, the
numbering techniques described in Chapters 2 and 3 of this minibook also
apply to consolidated projects and their subprojects.

Best of all, when you work in a consolidated project file, you have the option
to save changes you make to any subproject to that subproject’s source file.
Similarly, if you open the subproject file and make changes, Project asks
whether you want to update the consolidated project file. So, you don’t have
to face the nightmare of recording changes twice; Project tracks all the
changes for you, and Project updates the consolidated file if you want it to.

Do | need to use consolidation?

“My company uses Project Server with Project Professional. Do I need to
read this section?” you ask. Although Project Server can provide Project
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Figure 4-4:
A con-
solidated
project
looks just
like any
other proj-
ect with
summary
tasks and
subtasks.

Consolidating Projects 197

Professional users with much of the information you can get from consoli-
dating, Project Server can’t show you one critical path (the series of tasks in
your project that must happen on time for the project to meet its final dead-
line) across a consolidated project. In the section “The Critical Path in a
Consolidated Project,” later in this chapter, you see how consolidation
affects the critical path. So, even Project Professional users have a reason
to use consolidation.

In Book X, you can read about Project Server, a product used in conjunction
with Project Professional in environments that manage many projects using
the same set of resources. Project Server provides your organization with a
database in which all projects are stored. Users with the proper credentials
and a browser can use Project Web Access, a browser-based interface, to
view and work with projects stored in the Project Server database.

When you use consolidation, you also want to use resource pooling,
covered later in this chapter in the section “Sharing Resources Using a
Resource Pool,” to assign the same resources across projects and avoid
overallocations.
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A\

Show =

Creating subprojects

It doesn’t really matter when, in the project schedule setup process, you
decide to use consolidation. For example, you might realize right away that
the project is too large to handle in a traditional way; in this case, start by
saving each phase of the project as a subproject file.

If you discover that consolidation would work for you after you start work-
ing on a project, no problem. Suppose, for example, that you're working on
setting up a project plan to migrate your organization to Word 2007, and
then management decides to also migrate to Excel 2007 and Outlook 2007 at
the same time. Adding these two software packages to the upgrade process
changes the scope of the project and adds tasks and dependencies that
didn’t exist previously. In this case, you can easily break the original project
down into subprojects and create additional subprojects to accommodate
the new tasks.

If you decide to use consolidation at the outset, create separate Microsoft
Project files for various portions of the project that will serve as subprojects
when you consolidate. Set up each subproject file so that it’s independently
complete and create any necessary links within each subproject file.

If you start a project and then find that you want to use consolidation, you
can create subprojects by following these steps:
1. Save your original project file.

2. Select all the tasks that you want to save in your first subproject file
(see Figure 4-5).

Use the Show button on the Formatting toolbar to display only Outline
Level 1 headings. Then select the heading for the set of tasks you want to
save in a subproject; Project selects the heading and all of its subtasks.

3. Click the Copy button.

™

. Click the New button to start a new project.
5. If necessary, click Blank Project in the New Project task pane.
Project displays the Project Information dialog box (see Figure 4-6).

If Project doesn’t automatically display the Project Information dialog
box when you start a new project, choose Projectr>Project Information
to display it.

6. Establish basic information for the subproject, such as the start date
and scheduling method.
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[= Wicrosoft Project - Microsoft Office 2007 deployment.mpp e |
] File Edit View Insert Format Tools Project Report Collaborate Window Help Type a question for help @ X
DEH &RV $8ad9- = bl o | Mo Sroue TRy @@,
o P F = Showr = Arial > 8 = AllTasks v Ve | 9y s
a8 [Taskhame Duration Start |Dec 17,08 [Dec 24,08 Dec 31,06 Jand, &
TIF[S[SMITWITIF[S [SMITWIT[F[S [S[M[TW]T[F[S[STM[
0 & = Microsoft Office 2007 Deployment 159 days  Mon 12/11/06
1 + Envisioning 11 days Mon 1241/06 -
+ Assemble Project Teams, Define Roles 6 days Thu 1221706 —ﬁ
1a # Planning 51 days Fri1229/06 &
142 + Deployment 90 days Mon 34207
241 * Post.Implementation Review 4 days Mon 7607
247 Micrasoft Office 2007 deployment complete Odays Thu 7907
—
Figure 4-5:
In your
original
project file,
select the
tasks you
want to
includeina
subproject. ; P 7]
Read
Project Information for "Office 2007 deploymentsubproject!.mpp’ ==l
Start date: [Man 12/11/06 [=]  Currentdate: [FriL/13/07 =
Finish date: fj Statusdate:  |[NA :
T e 1.1 ]
Schedule from; | Project Start Date | coendar: [standard E'
T — all tasks beqin as soon as possible. Priority! [s00 =]
Flgure 4'6: Enterprise Custom Fields
In this -
dialog box,
establish
basic
information
for the
SprrOIECt' Help | | Statiskics. .. OF, | | Cancel
A\

To make the Project Information dialog box appear each time you start a
new project, choose Tools=>Options, click the General tab, and select
the Prompt for Project Info for New Projects check box.
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) 7. Click the Paste button.

gMBER

Figure 4-7:
Project
displays the
set of tasks
you copied
from your
original
projectin a
new file.

Project pastes the information you copied from the original project into
the new Project file (see Figure 4-7).

8. Save the subproject and close it.

9. Repeat Steps 2 through 5 until you’ve saved several separate files that
contain portions of your original project.

In our example, we included the last Outline Level 1 heading, a milestone
to mark the end of the project, in our last subproject file. So, we created
five subproject files from the original file shown in Figure 4-5.

10. Close the original file.

You're now ready to edit each subproject file that you create to make it an
independently complete project. For example, establish task durations and
dependencies and assign resources in each subproject file. Don’t worry about
connecting tasks in one subproject to another; you can use the techniques in
the following sections to consolidate the subprojects and link them together.

= Microsoft Project - Office 2007 deploymentsubprojectl. mpp = Jle [
2] File Edit View Insert Format Tools Project Report Collaborate Wiindow Help Tyt a question for hielp -8 X
NS $AV %GRS 9 -0 (85 5w Nocrouw A FE@,

@ % 4 = Xy Show~ | Aral -8 - B L U

= = | AllTasks - W A o

a  Taskhame Durstion Start Finish Dec 3, '06 Dec 10, '06 | Dec 17, '06 Dec 24, '06 Dec 31, '06 -
STM]T [WIT[F[S|SIM[TWIT[F[S [S[M[TWT[F[5[5[M[T MW[TF[55[M[T W[T]F]S
[ )

[J= envisiening |10 days Mon 12411106 Fri12i22106
Summerize currertinfe|  2dlays| Mon 1211106 Tue 122108
Identify corporate desk. 2 days| Wed 121306 Thu 124416
Determine project scop,  3days|  Fri12MS06 Tue 124906
Determine major milestc| 1 cay Ved 12720006 Wed 1220106
Secure executive spor 2days Thu122106  Fri12/22/06

Stakeholders
Stakeholders

Stakeholders

NI A I )

Project Manager,Stakeholders
Ervisioning complete Odays  Fri122206  Fri122206 & 122
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Figure 4-8:
You can
easily iden-
tify inserted
projects
from the
special icon
that appears
in the
Indicator
field.
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Creating a consolidated project

To consolidate subprojects, you insert them into another project file; being
the clever folks we are, we call that project file the consolidated project file.
Each subproject that you insert appears as a summary task in the consolidated
project file, and Project calculates inserted projects like summary tasks.

An icon in the Indicator field identifies an inserted project (see Figure 4-8).

You might notice, in Figure 4-8, that the task numbers appear a bit odd. Project
assigns the equivalent of a project number to each inserted project, with task
numbers following that run sequentially for each inserted project. So, the
summary task for the first inserted project appears on Row 1, followed by its
first task, also assigned a row number of 1. After Task 7, the last task in the
first inserted project in Figure 4-8, the summary task for the second inserted
project appears on what seems to be Row 2, but it’s actually the inserted
project’s project number. The tasks of the second inserted project follow,
beginning again with Row 1 for the first task of the second inserted project.

= Microsoft Project - consolidated1.mpp B
] File Edit View Insert Formst Tools Project Report Collaborate Window Help Type a question for help -8 x
DNEH&EQ/AV L8R AR W) 2| ‘S & | No Group QA FEe
& P o = Show~ | Arial -0 - B 7 U0 E= Bl Tasks - Ve A b

a Task Name Duration 3 |Dec10,'08 |Dec17,'08 | Dec 24,'08 | Dec 31,'08 |Jan7,07
WIT[F[S[S[M[T[wI[T[F[S|[S[M[TW[T[F[sS[M[TW[T[F[S|S[M[TWT[F[S[S[M[TM™[T
1 lﬂ_l = N#firn 00T danl Laroject! 10 days —_—_— :
1 4] This Inserted project is 10 days —_—e———
embedded from 'C:\Users\Elaine
2 Marmel Documernts\Project AIO  [worker took 2 days Stakeholders
3 Data Files\Office 2007 nconcerns | 2 days
4 deployment ubprolect LoD, | onvie oo 3 davs Stakeholders
5 Determine major milestones 1 day Project
3 Secure execulive sponsorship 2days Project Manager,Stakeholders
7 Enwisioning complete Odays &
2 ) = Office 2007 deploymentsubprojec? 4.5 days i
1 = Assemble Project Teams, Define Roles | 45 days —
2 Assign/define project manager 1 day @
a Assignfdefine datakiase administrator dhrs tajadt Manager
4 Assignfiefine deployment administrator 4hrs brojdct Manager
5 Assignfdefine desktop ackninistrator dhrs Gi-Badject Manager
G Assignfiefine intranetintemet administratar 4 frs G
7 Assignitefine browser administrator ahrs "B broject Manager
& Assignidefine netrvark admiristrator dhrs Bl Project Manager
a Assignfdefing testiaa lead 4hrs Project Manager
10 Assign/define user sducationAraining lead 4hrs aPr ject Manager
11 Assemble project teams, define roles comp 0 cays > 1208
« » v
Read:
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A\

Figure 4-9:

The Insert
Project
dialog box
looks and
works like
the Open

dialog box.

To insert a project, follow these steps:
1. Start a new project or open the project you want to use as the consoli-
dated project.
2. Switch to Gantt Chart view.

3. Click in the row of the Task Name column where you want the
inserted project to begin.

When you insert a project, Project places the project immediately above
the selected row. So, if your consolidated project already contains tasks,
click the task in the Task Name column that you want to appear below
the subproject.

4. Choose Insert->Project.
Project displays the Insert Project dialog box (see Figure 4-9).

[i=/ Insert Project ==
— ]
@v-w‘ b Elaine Marmel b Documents b Project AIO Data Files .|~,H;=- h o

| Organize - ew Folder
Name B Date modified  Type 2

=i Microsoft Windows Server 2003 deployme...  1/12/2007 7116 .. Micrasoft Offic

| Documests 2 Microsoft Windows ¥P deployment plan-n.. 1/12/2007 6:47 ..  Micrasoft Offic,
sl RecentPlaces ] Microsaft Ward 2007 deployment.mpp 3/82007 412 PM  Microsoft Offic,
B Deskiop ElNew product plan.mpp 3162007 8:05 .. Micrasoft Offic,
More 5 E2l] Office 2007 deployment-subprojectL.mpp 17192007 9:32 Micrasoft Offic.
2] Office 2007 deployment-subproject2.mpp 1/19/2007 9:31 Micrasoft Offic.
Folders v & office 2007 deployment-subprojectS.mpp 1/13/2007 833 .. Microsatt Offic,
&ty Shapes . & office 2007 deployment-subprojectdmpp 192007 8:33 . Micrasoft Offic,
My Wirtual Machines ] Office 2007 deployment-subprojectS.mpp  1/13/2007 838 .. Microsoft Offic _
5 Peschtres Company Dita Eoutlinelinking. mpp 119/2007 121, Microsoft Offic,
R ] Reparts.mpp 673072006 8:48 Microsoft Offic.
Project AIO Case Study files !i'i]Repmtsl.mpp 7142006 456 PM  Micrasoft Offic.
ERanarte 3003 man AIANAIANG RrdR Micracntt (e
Project AIO Data Files = || i v

— opec. | Link to project
File name: Dffice 2007 deployment subproject!. mpp + [ Microsalt Project Files [mpp ~ |
Tools v | Imset || [ Cancel |

Link to Project check box

5. Navigate to the folder that contains the project that you want to insert.
6. Highlight the file that you want to insert.
7. Click the Insert button.

Project inserts the selected file into the open project. The inserted sub-
project file appears as a summary task, and its subtasks are hidden (see
Figure 4-10).
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(= Microsoft Project - ProjectZ (=R
] File Edit View Insert Format Tools Project Report Collaborate Window Help Type a question for help @ X
NEE B3R 6B 9-0- 8 =56 E 0SB | Ncow Ry E2@L

o P o = Show~ | Arial > - B J O = E = AlTasks 7 0= A

Office 2007 deplaymert-subproject]
ec 31, 10F &

a Task Name Duration Start Dec 3,'08 Dec 10,'06 Dec 17,06 Dec 24,06 D
STMIT WITIF [S[SIMIT BT IF [S[SMIT WITF[S[S[MIT T [F[S[S[M]T [
P ——eees

1 |& [¥ Office 2007 deploymentsubproject! | 10 days on 12/11/06 Fri

Figure 4-10:
Inserted
projects
appear as
summary
tasks, with
subtasks
hidden.

When you insert a project, you have a couple of options you can set:

4 By default, a check mark appears in the Link to Project check box (refer
to Figure 4-9). When the projects are linked, Project retains all of the
information stored in the inserted file, including the information you
provided in the Project Information dialog box (the information you set
concerning how to calculate the project schedule). If you remove the
check mark, Project doesn’t connect the inserted project to its source
project. You don’t see the icon in the Indicators column, and Project
ignores the information you stored in the subproject’s Project Information
dialog box. If you make changes to the subproject while working in the
consolidated project file, Project doesn’t prompt you to update the
inserted project’s source file.

4 The Insert button has a drop-down arrow beside it. If you click that
button, you can choose either Insert or Insert Read-Only. If you choose
Insert Read-Only from the Insert drop-down menu, Project still treats the
subproject as an inserted project for purposes of calculating the project
schedule, but if you make changes to the subproject in the consolidated
file, Project doesn’t let you save the changes to the subproject file.
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Figure 4-11:
Update links
for inserted
projects
from the
Advanced
tab of the
Inserted
Project
Information
dialog box.

Because linking the files makes updating easy, why wouldn’t you want to link
the files? Well, you might want to create a consolidated file just so you can
generate a report quickly.

The link you create when you insert a project works like any link that you
create between two files in the Windows environment. For example, if you
rename the subproject file or move it to a different folder, the link won’t
work anymore unless you update it. To update a link, display the consoli-
dated project in Gantt Chart view and double-click the inserted project.
Project displays the Inserted Project Information dialog box for the inserted
project; this dialog box is the equivalent of the Task Information dialog box
for any task (see Figure 4-11).

Inserted Project Information ==

izeneral I Predecessars I Resources ;ﬂH'\JSr‘iEé'd"f ] Motes ] Custom Fields I

Hame: iroff\ca 2007 deployment-subprajectz | Duration: [4.5 days|=| Estimated

Source project

[ Link to project: | CtiUserstElaing MarmeliDocumentsiProjerct AT Data Fils | Browse, .. |

[T Read only

Help Project Information... | | Ok ] | Cancel

In addition to using the Browse button to navigate to the new location for an
inserted project, you can unlink subprojects from their source files by
removing the check mark from the Link to Project check box.

If you attempt to expand the outline of an inserted project in a consolidated
project file and the inserted project’s location isn’t valid any longer, Project
automatically displays a dialog box that looks like the Open dialog box. Use
this dialog box to navigate to the new location of the file and click OK after
you finish. This process also re-establishes the link between the files.

Inserted projects and the outline

You can hide or show tasks of a subproject in the consolidated project file
the same way you hide or show tasks in any project file. Click the outline
symbol — the plus or minus sign next to the task name — of the inserted
project’s summary task.
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You can insert projects at any level in the project outline, and the outline
level assigned to the inserted project depends on the level of the tasks

above and below the inserted project in the consolidated project.
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A shortcut to consolidate projects

Company: Medium-sized company with more
than 75 employees.

Project: Upgrade all computers from Office
2003 to Office 2007.

Challenge: To monitor overall progress on a
project being managed by several different
managers.

In this situation, when several different people
within the organization will be managing differ-
ent phases of a large project, each manager
will want to create and manage a project
schedule for his or her phase of the project.
However, dependencies exist between phases,
so viewing the “big picture” is just as important
as managing the phases. The company wants
to be able to quickly and easily produce a con-
solidated project for analysis.

Solution: There's a quick and easy way to con-
solidate projects, but to make sure that the sub-
projects appear in the correct order when you
consolidate, naming the subproject files
becomes important. To take advantage of this
shortcut, name your subprojects with a number
at the end that represents the order in which it
should appear when you consolidate. For
example, name the first phase Subproject1, the
second phase Subproject2, and so on.

Then use this very cool shortcut to create a
consolidated project:

1. Open all the subprojects that you want to
consolidate.

2. Choose Window=>New Window.

Project opens the New Window dialog box
shown in the figure.

New Window ==

Projects:

|Office 2007 deployment-subpraject].mon
| Office 2007 deployment-subproject2.mpp
| Office 2007 deployment-subpraject3.mpp
| Office 2007 deployment-subprojects. mpp
| Office 2007 deployment-subprojectS.mpp

view: | Gantt Chart =

| Ok | | Cancel |

3. Press and hold down Ctrl as you click
each project that you want to consolidate.

4. Click OK.

Project creates a new consolidated project that
contains the projects that you selected in the
New Window dialog box. Project inserts the
subprojects as linked files into the consolidated
project file in the order in which the subprojects
appear in the New Window dialog box, so naming
the subprojects as we describe sets the order
in which they consolidate. On this book’s Web
site, you'll find five subproject files: 0Of fice
2007 deployment-subprojectl .mpp
through office 2007 deployment-
subproject5.mpp. Open all five subpro-
jects in any order, select some or all of them,
and see the results. And, using this approach,
any changes made to any subproject update
the consolidated project file and vice versa.
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Figure 4-12:
When we
inserted
Subproject?,
we selected
the Secure
Executive
Sponsorship
task.

When you insert a project, you select the task that you want to appear below
the inserted project. Project assigns the outline level of the inserted project
at the same level in the outline as either of the following:

4 The selected task
4 The task above the selected task

In most cases, Project inserts the project at the same outline level as the
task above the selected task. But there’s one exception (isn’t there always at
least one?): If the task above the selected task is at the same outline level

or outdented farther than the selected task, the inserted project appears in
the outline at the same level as the selected task, not the task above the
selected task.

To really get a handle on this behavior, compare Figures 4-12, 4-13, and 4-14.
In Figure 4-12, we selected the Secure Executive Sponsorship task when we
inserted Subproject2. This subproject appears at the same outline level as
the Determine Major Milestones task, the task above the selected task.

[ Microsoft Project - outlinelinking.mpp = o ]
B File Edit View Inset Format Tools Project Report Collaborate Window Help Type a question for help -8 X
NEE ERT 4B S 9 08 =568 E0DB Moo R AT,

w P 4+ = Ey Showr Arial U - B J U EE=EE Ak -V

Office 2007 deployment-subproject2

8 TaskName Duration St '08 Dec 10,'08 | Dec 17,06 | Dec 24, 08 Dec 31,06 Jan
TIW[TIF[S|SM[TW[T[F[S|S[M[TW[T[F[S|[SM[TWI[T[F[S[SM[TW[T[F[S|SM
1 &) = Office 2007 deploymentsubproject! 4.5 days on 12 = - =
1 = Envisioning 14.5 days Mon 1 = = )
2 Summarize current information warker ook 2ctays| Mon 1 = stekeholders
3 = Identify corporate desktop vision con: 12.5 days Wed 1 o )
& Determine project scope (for example, ¢ 3 cays Wed 1 @ Stakeholders
5 Determine major milestones 1 ciay| Won 1 Project Manager,Stakeholders
E | + Office 2007 deployment-subpr4.5 days on 12 —_—
7 Secure execulive sponsorship 2days| Tued i
& Erwisioning complete Otays | Wetl 1 & 1200
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Figure 4-13:
When we
inserted
Subproject2,
we col-
lapsed the
Identify
Corporate
Desktop
Vision task
and selected
the Secure
Executive
Sponsorship
task.
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In Figure 4-13, we collapsed the Identify Corporate Desktop Vision task,
selected the Secure Executive Sponsorship task, and then inserted
Subproject2. Although the Identify Corporate Desktop Vision task contains
indented subtasks, they’re hidden, so Project inserts the subproject at the
same level as the Identify Corporate Desktop Vision task, which is the task
above the selected task.

In Figure 4-14, we selected the Determine Project Scope task when we
inserted Subproject2. This subproject appears at the same outline level as
the Determine Project Scope task we initially selected because the task
above it is outdented farther than the selected task.

To produce a consolidated project in which the inserted projects line up
at the highest outline level, make sure that you collapse the preceding
inserted project so that you can’t see its tasks when you insert the next
subproject.

[E=EEE S

-8 X

=] Wicrosoft Project - outlinelinking.mpp
& File Edit View Insert Fornst Tools Project Report Collaborste Window Help

Type 3 question for help

NEH &RQV &R T (90 -8 45da L] B | Nosouw - RAFE@
o P o = Show~ | Arial -1 - I U |= = = | AiTasks T M= A
Office 2007 deployment-subpraject2
a  [Teskname Duretion st |08 Dec 10,'08 Dec7,'06 Dec 24,08 Dec 31,08 Jan &
TWT[F[S[SM[TW[T[F[S[S[M[TW[T[F[S[SM[TW[T[F[S[S[M[TW[T[F[S|SM

1 W& = Office 2007 deploymentsubproject! 4.5 days on 12 ', 7
1 = Envisioning 145 days Mon 1 o i
2 Summarize current information warker togk 2 days | Mon 1 Stakeholders
3 + Identify corporate desktop vision coni 4 days Wed 1 — =
s & | + Office 2007 deployment.subprojef4.5 days on 12 | P—
7 Secure execulive sponsorship 2days Tuel -
B

Enwisioning complete 0cays| Wed 1 & 1220
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Figure 4-14:
When we
inserted
Subproject?,
we selected
the
Determine
Project
Scope task.

(= Microsoft Project - outlinelinking.mpp =R
B4 File Edit View Insert Format Tools Project Report Collaborate Méindow Help Type & question for help @ x
NEH &Y %R d - 85 bl = B | NoGroup R T E6

@ 5 4+ = %y Showr | Arial = = AllTasks -V A

Office 2007 deployment-subproject2

@ |Taskhame Durstion ot 108 Dec 10,'06 Dec17,'06 Dec 24, D6 Dec 31,'06 Jan i a
TIWIT[F 5[5 M[TWIT[F[5|5]M[TT[F[5[5[M[T W[T[F 5|5 [M[T [T[F[5|5M
T = Office 2007 deploymentsubproject! 4.5 days on 12 o P
1 = Envisioning 145 days Mon 1 = =
2 Summerize current information warker took | 2 clays | on 1 = Stokeholdors
3 = Identify corporate desktop vision con: 12.5 days Wed 1 & 7
& | * Office 2007 deployment-subpr{4.5 days on 12 ——
H Detenming project sCope (for example, ¢ 3 ciays Wed 1 G Stakeholders
3 Determine major milestones 1 day| Mon1 Project Manager,Stakeholders
7 Secure execulive spansorshin 2cays Tuet GEIPIniecl:Mannger,SiakEhnld(‘rs
g Envisioning complete Odays Wed 1 & 1220
“ 3 « i

Figure 4-15:
The Planning
Wizard
dialog box
appears
when you
cuta
subproject
summary
task.

Moving subprojects within a consolidated project

You can easily move subprojects around in the consolidated project by fol-
lowing these steps:
1. Select the row of the summary task for the subproject.
2. Click the Cut tool on the Standard toolbar.
Project opens the Planning Wizard dialog box (see Figure 4-15).

Planning Wizard ==

'Office 2007 deployment-subprojectZ’ is a summary task, Deleting it will delete all
its subtasks as well,

“fou can;

@ Continue. Delete 'OFfice 2007 deployment-subproject2’ and
its subtasks,

i Cancel, Don't delete any tasks,

oK J ‘ Cancel | ‘ Help

[l pon't tell me about this again.
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3. Select the Continue option.
4. Click OK.

The summary task that represents the subproject disappears, along with
all of its subordinate tasks.

5. Select the row you want to appear below the last task of the subproject.
6. Click the Paste button on the Standard toolbar.

Project reinserts the subproject at its new location, immediately above
the row you selected in Step 5.

Dependencies in Consolidated Projects

A\

=]

Like tasks in any project, tasks in a consolidated project depend on other
tasks in the project. Most likely, a task within one phase of the project
depends on a task in another phase of the project. Essentially, you need to
create dependencies that reflect how you work, even if the dependencies
cross phases that you've divided into subprojects, which isn’t a problem.

Creating dependencies across projects

You find out about dependencies in great detail in Book IV, Chapter 3. So, in
this section, we focus on showing you how to create dependencies across
subprojects.

In Project, you can create the same four types of dependencies between
subprojects as you can create between tasks: finish-to-start, start-to-start,
finish-to-finish, and start-to-finish. And, you can add lag or lead time to links
between subprojects, just like you can to links between tasks.

Create a consolidated project and then follow these steps to link a task
stored in one subproject to a task stored in another subproject:

1. Click Gantt Chart on the View bar.

2. Select the tasks that you want to link (see Figure 4-16).

To select noncontiguous tasks, press and hold down Ctrl as you click
each task name.

3. Click the Link Tasks button on the Standard toolbar.

Project creates a finish-to-start link line between the two tasks.

In the consolidated project, the link line between tasks across subprojects
looks just any other link line. Things look normal.
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Link line
=/ Microsoft Project - consolidated1.mpp = = &
&) File  Edit View Insert Fowmat Tools Project Report Collaborate  Window Help Type 3 question for help -8 X
DEH 87 § @ 9-0- 8 =45 = B NeGrawp - ® QT Ee

o » ow = Show~ | Arial -8 - B I O = | AllTasks = W=
Assignjdefine project manager
@ [TaskName Ouwetion | _|Dec3,'08 Dec 0,08 Dec17,'08 Dec 24,06 Dec 31,06 Ja s
| [S[S[M[T WIT[F[S[SM[T[T[F[S[S[M[T W[T[F[S|S[M[TW][T[F[S[S[M[T MW[T[F[S[S
] = Office 2007 deploymentsubprojectl 8 days I —
= Envisioning 8 days ———
Summarize currert information worker took 2 days Stakeholdgrs
= Identify corporate desktop vision coni 4 days 1—.
Determine project scope (for xample, e 3 days —Stakpholders
Determine mejor miestones: 1 day Project Manaper,Stakeholders
Secure executive spansorship Zdays agl
0days ezl
] = Office 2007 deploymentsubprojeciz 4.5 days P—
] - Assemble Project Teams, Define Roles | 4.5 days P—
[ Lssigriteting project manager ] 1oey 3
Assignideting detabase administrator 4hrs {iect Manager
Assignitefing deployment administrator anrs %Jnj& et Manager
Assignidefing deskiop sdministrator 4hrs Gi-Praject Manager
Assignideting intranetintemet soministraton 4 hrs i
Assignidefine browser admiistrator 4hrs @ Hroject Manager
Assignidefing network administrator 4his "B Project Manager
— Assignidefing testiad lead 4hrs i Proiect Manager
Assignidefing user educationtraining lead 4hrs 7 ;lw ject Manager
Flg ure 4_1 6: Assemble project teams, define roles comp. 0 days @ 12729
You can link
a task in one
subproject
to a task in
another
subproject. Fil =

But, in either of the subproject files, an external task appears. You can iden-

tify an external task because both its task name and Gantt bar are light gray

(see Figure 4-17). If you point at the bar in Gantt Chart view, Project displays
information about the task, including the fact that it is an external task. If you
double-click the task name of the external task, Project opens the subproject
to which the external task is linked.

From a subproject file, you can create an external link to another subproject
file using the Predecessors field on the Entry table of Gantt Chart view (see
Figure 4-18).



Figure 4-17:
Project
identifies
external
tasks when
you point the
mouse at the
Gantt bar of
an external
task.
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[=" Microsoft Project - Office 2007 deployment.subproject!.mpp

& Fle Edit View Insert Format Jools Project Report Collaborate Window Help
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In the Predecessors field, type a path to the subproject file and ID number
of the task to which you want to link. Separate the path to the location of
the subproject file from the ID number of the task with a backslash (\).

In Figure 4-18, the Assign/Define Project Manager task, which is Task 3

in a subproject file named Office 2007 Deployment-Subproject2.
MMP, is linked to the Envisioning Complete task, which is Task 7 in a sub-
project file called 0Office 2007 Deployment-Subprojectl.MPP.

You can see the complete pathname of a linked task in the Entry bar

(just below the toolbars) when you select the task’s information in the

Predecessors column.
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Figure 4-18:
You can also
create
external
links from
subproject
files.

Entry bar
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Changing cross-project dependencies

After you link tasks across subprojects, you might need to change informa-
tion about the link. For example, you might want to add lag time or assign a
different type of dependency.

You can modify a link between tasks in different subprojects from the sub-
project or from the consolidated project using pretty much the same tech-
nique. About the only advantage to working in the subproject is that you can
change the path to the subproject.

In the consolidated project, double-click the line that links the two tasks (see
Figure 4-19). In the subproject, double-click the line that links an internal
task to the external task (see Figure 4-20). In both cases, Project displays the
Task Dependency dialog box.
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As you can see, the two versions of the dialog box differ slightly. In both
versions, you can use the Type list box to change the type of link and the
Lag box to change the amount of lag time between the linked tasks. If you

work from within the subproject, you can update the path of the link, but if
you work from within the consolidated project, you can’t update the path of
the link.

Saving a consolidated project

You don’t need to save consolidated project files unless you want them,
because you can easily re-create the consolidated project file. But, as you’d
expect, Project prompts you to save a consolidate project when you close it.
No problem; choose Yes or No as appropriate. But, because the project
you're closing is a consolidated project, Project’s behavior changes slightly.
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When you close the consolidated project, Project first asks whether you
want to save the consolidated project. Whether you save the consolidated
project doesn’t change Project’s behavior; Project next asks whether you
want to save changes that you made to inserted projects (see Figure 4-21).

Figure 4-21:
When you
close a

consolidated
p roj ect, Microsoft Office Project

Proj ectas kS ‘9' D you want to save changes bo "OFfice 2007 deplayment-subpraject mpp'?
whether you s

want to save | wes || Westosl | | [ | | metsal || icancel
changes that

you made

to each

subproject.
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The Critical Path in a Consolidated Project

Project treats a subproject file like any other Project file; when you close a
subproject, Project asks whether you want to save changes to the file.

Here’s a cool thing: If you save the changes to the subprojects — even if you
don’t save the consolidated project — Project saves external tasks, such as
the one that you saw previously in Figure 4-18, in the subproject files.

The Critical Path in a Consolidated Project

Figure 4-22:
By default,
Project
treats
inserted
projects like
summary
tasks, and
you see only
one critical
path for the
consolidated
project.

In a regular project, Project automatically calculates the critical path (the
series of tasks in your project that must happen on time for the project to
meet its final deadline) for the entire project using the late finish date of
the project to make calculations. And, by default, when you consolidate
projects, Project calculates inserted projects like summary tasks and calcu-
lates the critical path by using the finish date of the consolidated project
to show you the overall critical path across all the projects. This behavior
can make subprojects look like they don’t have critical paths of their own.
In Figure 4-22, the critical path has a hatched pattern and is driven by
Subtask 7 in Subproject2.

1= Microsoft Project - 030422.mpp
& File
DEH @AV %R 9 -6 0 =5

SRS

Edit View Inset Format Tools Project Report Collborste Window Help -8 x

= & NoGroup

P AT B0,

¥® % 4 = Xg show~ | Arial - 10 - All Tasks xR .

Jan 14,07 | Jan 28, '07 Feb 4,07 Feb 11,'07

a  Taskhame Jan 7, Jan 21,07
TIF[S[S[M[TWI[T[F[S|S[M[TW[T[F[S[S[M[TW[T[F[S|S[M[T M[T[F[s[S[M[TW[T[F[s|s[M[TM[T[F
=

Duration

o I;Ii Critical Path 11 days = 0%
e = Subproject! 8 days P

1 Subtask 1 2days 0%

7 Sublask 2 Fdays C)b_nsgl

3 Subtask 3 Zdays ™

4 Sublask 4 G days e ]

2 & = Subproject? 11 days > T 0%
1 Subtask S 2days 0%

2 Subtask 6 Sdays C)b %

3 Subtask 7 11 tiays % ) 0%
4 Subtask & 1 day oLl

Book I
Chapter 4

sjaaloid
Bunepijosuo?
pue Bupjury



216 1he critical Path in a Consolidated Project

Figure 4-23:

Critical
paths

appearin a
consolidated
project for

each

inserted

project.

But suppose that you want to see each subproject’s critical path while view-
ing the consolidated project. No problem.

Although you might be tempted to turn on the Project setting to view multi-
ple critical paths while working in the consolidated project, you probably
won’t see any change to the project. Why? Because multiple critical paths
apply only to tasks that are owned by the project, and a consolidated project
doesn’t own the tasks of the subprojects you insert — the subprojects own
those tasks.

To view the critical path of each inserted project, tell Project to stop treating
subprojects as summary tasks. If you do, Project uses the late finish dates
that the subprojects pass along to the consolidated project to determine

the critical path, and you're likely to see each subproject’s critical path.
When you turn off this setting, you see critical paths in the consolidated
project as they appear in each subproject. In Figure 4-23, the critical path for
Subprojectl is driven by Subtask1, Subtask2, and Subtask3, and the critical
path for Subproject2 is driven by Subtask?.
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To view a critical path for each subproject in a consolidated project, follow
these steps:
1. Open the consolidated project.
2. Choose Tools->Options.
The Options dialog box appears.
3. Click the Calculation tab.

4. Deselect the Inserted Projects Are Calculated Like Summary Tasks
check box (see Figure 4-24).
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5. Click OK.

Critical paths for each subproject appear in the consolidated project.
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Sharing Resources Using a Resource Pool

If you work in an environment in which several project managers use the
same set of resources on multiple projects, a resource pool can be useful.

A resource pool is pretty much what its name implies: a set of resources
that are available to any project. When you set up a resource pool in Project,
you can open it and view resource assignments across all projects using

the pool.

The resource pooling techniques we describe in the following sections apply
more to Project Standard users than Project Professional users who also use
Project Server. Project Professional users using Project Server can use the
Enterprise Resource Pool in Project Server to accomplish the same things
that resource pooling does.

Creating a resource pool

To use resource pooling, you need a project that contains all the available
resources you intend to share. To really be effective, we suggest that you
include all available resources in the resource pool, even if you intend to
share resources across two projects and use only some of those resources.
By including all your resources in the resource pool, you eliminate the need
to create several resource pools and to keep straight which ones contain
which resources.

You create a resource pool by simply setting up the resources in a Project
file and then saving that Project file. The Project file doesn’t have to contain
tasks, but if it does, that won’t affect anything. To keep things clean and
avoid confusion, we recommend that you create a Project file that contains
only resources and no tasks. To get details on setting up resources, See
Book V, Chapter 1.

Sharing resources

If you intend to share the resources in the resource pool, don’t bother to set
up any resources in your project. Instead, connect your project to the proj-
ect file that contains the resource pool by following these steps:
1. Open the project that serves as the resource pool file.
Ours is cleverly named resource pool.mpp.
2. Open the project that will share resources.

Both projects appear on the Windows taskbar.
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3. Choose Tools->Resource Sharing=>Share Resources.

Project displays the Share Resources dialog box (see Figure 4-25).
4. Select the Use Resources option.
5. Open the From drop-down list to select the resource pool project.

You can choose any open project when you identify the resource pool.
So, if you have any projects open besides the resource pool project and
the project that will share resources, those additional projects appear
as candidates for the resource pool project when you open the From

list box.
6. Select an option to tell Project how to handle calendar conflicts.
If you select the Pool Takes Precedence option, the Resource calendars
in the resource pool file take precedence when conflicts arise. If you
select the Sharer Takes Precedence option, the Resource calendars in
the file that’s sharing resources take precedence over the Resource cal-
endars in the resource pool file when conflicts arise.
7. Click OK.
Figul’e 4-25: Share Resources == Book IlI
USe thIS Resources For "Windows Vista Upgrade.mpp' Chapter 4
dislogbox | e
to connect From: |resource pool.mpp B

your project
to the
resource
pool.

NG/
&>

On conflict with calendar or resource information
@ Pool takes precedence
Sharer takes precedence

‘ Help ‘ [ ok 1 | Cancel

If you switch to Resource Sheet view of the project that you just set up to
share resources, Project displays all the resources that appear in the

resource pool file. And, although those resources appear to be in your proj-

ect file, they aren’t until you actually make an assignment.

If you ignored our advice and set up resources in a project that you then
set up to share resources, the resource pool resources appear along with

any resources that you set up in your project file, which could cause some

confusion.
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Figure 4-26:
The Open
Resource
Pool
Information
dialog box
helps you
work in your
project file
that shares
resources.

You can now continue working in your project, or you can save your project
and close it. You can also close the resource pool file.

Opening a project

Okay, you saved and closed your file that shares resources and now you
want to open it again. You open this file the same way that you open any file,
but you might be wondering whether you need to open the resource pool file
first. The answer, in a word, is no. Instead, when you open a file that you
have set up to share resources, Project displays the Open Resource Pool
Information dialog box (see Figure 4-26).

Open Resource Pool Information ==

This file shares resources from a resource pool. What do you want to do?

“fou can;

@ Open resource pool ko see assignments across all sharer files.:

“ Do not open other files,

OK ‘ ‘ Cancel | ‘ Help

So, which option do you choose? When you select the Open Resource Pool
to See Assignments Across All Sharer Files option, Project opens your file
and the resource pool, but the resource pool opens as a read-only file. If you
make changes that involve resources, you need to update the resource pool
to reflect the changes — you can read more about updating the resource
pool in the next section.

The “read-only” thing happens so that multiple users can work with the
resource pool file simultaneously.

If you select the Do Not Open Other Files option, Project opens only your
file. If you haven’t previously assigned resources and you check Resource
Sheet view, you don’t see any resources — remember, they are stored in the
resource pool. When Resource Sheet view is blank, you can’t make any
changes involving resources to your project.



Figure 4-27:
Use the
Update
Resource
Pool com-
mand to
store
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changes in
your project
while the
resource
pool file is
open.
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When in doubt, choose the first option to open the resource pool.

Updating the resource pool

Remember, letting multiple project managers working in different projects
share a finite set of resources is the whole idea behind the resource pool.
While you're working, if you change resource information, you need to
update the resource pool file so that others who are using the resource pool
have the most up-to-date information.

To update the resource pool, it has to be open. Choose Tools=>Resource
Sharing=>Update Resource Pool (see Figure 4-27).

“But the Update Resource Pool command isn’t available,” you say. That hap-
pens when you open your project file but you choose not to also open the
resource pool. And, you lose your changes if you save and close your file
and then reopen it along with the resource pool. So, to get around the prob-
lem, click the Open tool on the Standard toolbar to open the resource pool
file. Project then displays the dialog box you see in Figure 4-28.
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Figure 4-28:
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If you select the first option, Project opens the resource pool file so that you
can update it with the changes you made to your project, and others can
continue to use the resource pool. (The second and third options in the
Open Resource Pool dialog box are discussed in the next section.)
If you forget to update the resource pool after you make a change in your
project that affects the resource pool, Project displays a message, shown in
Figure 4-29, when you save your project. If you click OK, Project updates the
resource pool for you.
Figure 4-29: | Microsoft Office Project E=
PrOj e Ct Update resource poal ta reflect changes For all the open sharer projects?
rem | nds yo u ‘When updating the u_uul file, Project will save the resource pool that is in memory. This copy reflects the changes
_ for all the sharer projects that you have open in memory.
to u pd ate \_9] Ta only save some of the sharer project changes, vou will first need to close those sharer files that you don't wish
the resource = to have reflected in the update to the resource pool file, and then update the resource poal.
To save the resource pool, dick CK.
pool when
yO u save To cancel the resource poal save operation, click Cancel.
your project. [Lox ] [ coneal |

Viewing resource assignments
when you share resources

If you're sharing resources, it’s important to monitor resource allocations,
and the resource pool makes that task easy.
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Figure 4-30:
When you
open the
resource
pool and
choose the
third option,
Project
creates a
consolidated
file that
includes all
projects
using the
resource
pool.
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Use the Open tool on the Standard toolbar to open the resource pool file.
Project displays the Open Resource Pool dialog box shown previously in
Figure 4-28.

To get a good handle on resource assignments across projects, choose the
third option. Project opens the resource pool file and creates a consolidated
project that includes all the files that are sharing the resource pool file.
Switch to the consolidated file by using the Windows taskbar or the Window
menu in Project (see Figure 4-30). You can make updates, and other users
can work at the same time in the files that share the resource pool; other
users see updates you make as you work.

Choose Viewr>Resource Usage to review the resource assignments.
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You might be wondering what the second option in the Open Resource Pool
dialog box does. If you want to update cost or availability information, the
second option lets you open the resource pool and make those changes.
However, others won’t be able to update the pool with new information; that
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Figure 4-31:
Use this
dialog box to
disconnect a
project from
the resource
pool.

is, when they choose Toolsw>Resource Sharing, the Update Resource Pool
command you saw in Figure 4-27 isn’t available until you close the resource
pool. If Project prompts you to save any of the files that share the resource
pool, save them.

Stop sharing resources
You don’t have to continue to use the resource pool after you connect a proj-
ect file to it. You can disable the resource pool for your project if you follow
these steps:

1. Open the project that you want to disconnect from the resource pool.

When prompted, you can open the resource pool or not — it doesn’t
matter.

2. Choose Tools->Resource Sharing->Share Resources.

Project displays the Share Resources dialog box (see Figure 4-31).

Share Resources ==
Resources f
9@ilse
Use resources

Wista Upgrade. mpp'
55

From: |resource pool.mpp B

On conflict with calendar or resource information
@ Pool takes precedence
) Sharer takes precedence

| Help | Ok ] | Cancel

3. Select the Use Own Resources option.

Project displays a message, asking you to confirm that you want your
project to now use its own resources instead of the resource pool.

4. Click Yes.
Project redisplays the Share Resources dialog box.
5. Click OK.

Project closes the Share Resources dialog box and your project now
must use its own resources.

Do you want to disable the resource pool in general? No problem. You don'’t
need to open each file and disable resource sharing. Follow these steps to
disable the resource pool file:
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1. Click the Open tool on the Standard toolbar and open the resource
pool file the same way that you would open any file.

Project displays the Open Resource Pool box (refer to Figure 4-28).

2. Choose either the middle option or the last option.

Either option works because both options open the resource pool as a

read-write file.

3. Choose Tools->Resource Sharing->Share Resources.

Project displays the Share Resources dialog box (see Figure 4-32).

Share Resources
‘resource pool.mpp' is a pool

Sharing links:

=

Ci\UsersiElaine MarmehDocuments|Project AID Data Files\Windows Yista Upgrade "

CillsersiElaine M

larmelRocumentsiProiect AIO Data Files\1522.mon_

I Cpen | | Cpen Al | | EBreak Link.

Figure 4-32:

The Share
Resources
dialog box.

|| Open files read only

On conflick with calendar or resource information:

@ Pool takes precedence
Sharer takes precedence

| | Cancel

A\

\NG/
S

4. Select the project(s) that you want to exclude from the resource pool.

Press and hold Ctrl as you click to select multiple noncontiguous proj-
ects or press and hold Shift as you click the first and last projects to

select contiguous projects.

If you choose to break the links of all files to the resource pool
and other project managers use the pool, you could become a very
unpopular person. Make sure you select files for which you have

responsibility.

o

Click the Break Link button.

Project closes the Share Resources dialog box and disconnects all the
projects you selected from the resource pool.

6. Save the resource pool file.

Book I
Chapter 4
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Chapter 1: Looking at Timing

In This Chapter

+ Understanding what drives timing
v Using scheduling from start or finish dates
v Understanding the nature of backward scheduling

1+ Saving time

A fter you have created tasks, given them durations, added dependen-
cies, and designated any constraints, you have effectively set up the
timing for your project. At this point, it’s important to take a look at the
timing information Project is returning to you and what it means for your
project’s overall schedule.

In this chapter, we sit back and take a look at timing, review what drives
timing, and look at the options available for scheduling.

Understanding What Drives Timing

Consider the way your typical day goes. The timing of all the tasks you per-
form, all the errands you run, and all the work you get done is affected by a
number of factors. It’s not just the times you set up to get to work, run to a
doctor’s appointment, or have dinner that drives your day’s timing. Your
schedule is also affected by whether your partner showed up to help you
prepare dinner, whether your co-worker finished the draft of the report you
were supposed to finalize, and whether you got a late start because your
alarm clock didn’t go off.

The timing of tasks in a Project plan also isn’t determined by a single factor,
but by a combination of factors.

Timing factors

Timing of tasks in a Project schedule might be influenced by several things,
including

4+ A task duration you specify (for example, 3 days)
4+ The start or finish date of the project



2 3 0 Understanding What Drives Timing

Dependencies with other tasks that must be started or completed before

this task can begin or finish (see Figure 1-1)

Constraints that you have set such as starting on a certain date or finish-

ing no sooner than a certain date

Leveling feature
*

Resource availability, especially if you have turned on the Resource

Project, Task, and Resource calendars

One other point you should understand is that Project assigns weight to the
various timing influences in a complex calculation to set final task timing. So,
for example, a constraint that a task must start on a certain date takes prece-
dence over dependencies with other tasks. A Resource calendar takes prece-
dence over the project calendar in determining when a task can take place.

You have some control over the rules of precedence that Project follows. For
example, you can make task dependencies override the more inflexible con-
straints that you have set for tasks. In the Tools menu, click Options, and
then click the Schedule tab. In the Scheduling options section, deselect the
Tasks Will Always Honor Their Constraint Dates check box.
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] Fle Edit View Inset Format Tools Projeet Report Window Help \ -8 %
) e Rl e -8 - ST - Z|® ¥ 4 = Show- Aml i = MR T o 2
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T3 @ |TaskName Durstion (108 |Jan7, 2 # . |Feb s, 07 1Fa
| TIW[T[F[S|S[M[T|W[T|[F[S|SIM]TWT[F[S S|M[TW[T|F[S|S[M[TW[T[F|S|SIM[T|WTIF[S[%
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3 Receive notics to proce 2 days G.C. general management
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\P
) You can also cause Project to ignore Resource calendars by selecting the

Ignore Resource Calendars setting on the Advanced tab of a task information
dialog box.

Your first look at your project’s timing

If you've left the start date for your project at the default, it stays set at

the current day (whatever date it was when you first created your project).
We suggest you leave this setting (which you find in the Project Information
dialog box) alone while entering the details of your project plan. When you’ve
made all the settings for your tasks, you can see how long completing your
project will take either by looking at a project summary task which summa-
rizes all the timing of your tasks in one line item, or by looking at the start
date of the first task and finish date of the last task.

You can read more about creating a project summary task in Book V, Chapter 4.

If, for example, your project is starting today and today is March 1, and your
overall project duration is six months, you can figure that if you started
today you would be done around August 31, depending somewhat on holi-
days, working days, and so on. If you then calculate that the work on the
project won'’t actually start till you get your plan approved and get funding,
which could take about a month, you can figure that you’ll actually get done
closer to the end of September.

At this point, you can really begin to see whether your schedule is going to
fit your timing needs. You can start to play around with setting different start
dates (see the next section for more about this process) or tweaking any of
the timing factors in the previous list to try to shorten your schedule to
meet a more aggressive deadline (see Book VII, Chapters 3 and 4 for more
about the process of finalizing your schedule).

P Project 2007 has a feature called Task Drivers. This feature allows you to

open a pane that displays all the drivers for a selected task. Book VII,

Chapter 2 goes into detail about using task drivers. Book IV

Chapter 1

Scheduling Backwards or Forwards

When you’re content that your project plan is complete and you’re ready to
begin work, that’s the moment when you freeze your plan in time by setting
either a start date or a finish date, which is dealt with in Book VII. For now,
it’s important that you understand how Project schedules tasks so you can
understand the timing information it shows you.

fuun] je hunjoo
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How scheduling works

One reason using Project is a lot handier than entering tasks on your calen-
dar or to-do list is that Project works with your built-in scheduling logic to
make your plan flexible. So, if you change your project start date or add a
new task, Project automatically adjusts your schedule. That’s why you should
avoid putting in specific constraints on tasks, but instead let them start as
soon as possible. If you set a specific date and things change, you just have
to manually change all those set dates, just as you had to do when you
worked with a calendar program.

In most cases, people schedule from the beginning of a project so that all the
task timing flows from the beginning date of the schedule. After you build all
your tasks, Project in effect tells you when the project will finish, based on
your start date.

However, in some cases, the finish date is such a driving factor (think of a
project such as planning an event for the opening day of fishing season) that
scheduling from the finish makes the most sense. Scheduling from the finish
is one way to let Project tell you when you have to start to get things done
by a certain date.

Here are the three settings in the Project Information dialog box (see Figure 1-2)
that you need to understand regarding scheduling:

4+ Set the start date for the project. When you set the start date for your
project, the first task in the project (assuming it’s set at the default con-
straint of as soon as possible) starts on that date, with all subsequent
task timing being driven by all the timing factors Project takes into
account. Project automatically recalculates all dates when you select
this setting.

4 Set the finish date for the project. You can set the finish date. This option
is especially handy if you have a drop-dead date beyond which the proj-
ect cannot wander and still reach completion. In such a case, be sure to
look at the next setting in this list — and change it accordingly.

4 Schedule from the start or finish of the project. If you change this
setting to Project Finish Date, the Finish Date field becomes available.
All tasks occur by default as late as possible in the schedule. This is
sometimes referred to as backward scheduling of backward estimating.

Praject Information for 'C ial Construction’
Figure 1-2; | s=rteets:  (Mnddns ] curetdater [Ven 207 =i
The Project | Emeshdater  [isisic [ stmsdate: [ =
Information Schiedule from: ‘I;ro]_eét_siﬁltfiz;ne— B Calendsr: [Standard -izl
dialog box. [T e
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Figure 1-3:
Quickly
viewing task
constraints
in Gantt
Chart view.
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A word of warning about backward scheduling

If you leave the default setting in the Project Information dialog box to sched-
ule from the start date, all tasks you create have the As Soon As Possible

(ASAP) constraint. If you change this setting to schedule from the finish date,
all tasks you create have the As Late As Possible (ALAP) constraint applied.

Here’s where this gets tricky. If you don’t change this setting at the outset,
create your schedule, and then change to the Schedule from Finish of Project
setting, tasks you already created stay set at ASAP and tasks you create sub-
sequent to changing the setting are created with the ALAP setting.

This situation causes ASAP tasks to start only when you enter an actual start
date, which can cause some unnecessary down times (or slack) in your
schedule. For that reason, you must modify this one setting before you even
begin to enter information for your project. However, you can wait to set the
actual start or finish date till your project planning is complete.

If you find out after the fact that you have to use backward scheduling, you
have to go in and change the ASAP setting on tasks manually. However, you
can display the Constraint Type column in any Gantt Chart view table (see

Figure 1-3) to speed up your changes, or you can even create a macro to go
down this column changing all settings in sequence. See Book IX, Chapter 3
for more about using macros.
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Surviving Schedule Shock

Most people panic when they first see the length of the schedule they’'ve
created in Project. But take a step back for a moment. If you have entered
correct information about your tasks, dependencies, and resources, what
Project tells you should be realistic, if a bit frightening.

The first thing you should do upon seeing the total duration of your sched-
ule is go back and make sure you were accurate in the information you gave
Project. Check dependencies and constraints to see whether they’re really
logical. Is Resource Leveling on and therefore pushing tasks out to accom-

modate resource schedules? (See Figure 1-4 and 1-5, which show the total

duration of a project with Resource Leveling turned on and turned off.) Did
you move a task in your schedule in such a way that a former dependency

no longer makes sense?

A timing case study

Company: A large Canadian pharmaceutical
company.

Project: Direct marketing campaign for a new
drug launch.

Challenge: Make sure that the launch of the
marketing campaign happens as soon as the
drug has been approved for sale.

This project involves the creation and delivery
of e-mail, regular mail, and telemarketing cam-
paigns to educate doctors about the release of
a new drug product for the treatment of hyper-
tension.

The key to the timing of this large direct-mar-
keting campaign is the final approval of the drug
by the Canadian government. The project man-
ager wants to ensure that much of the work is
done so she can move quickly on the final push.

The following factors need to be considered
here:

v Itis probably logical to schedule this proj-
ect from the start, because the finish date
is not set yet and won’t be set until later in
the project when the drug is approved.

v~ Tasks should therefore, for the most part,
use the ASAP constraint.

v The task of actually launching the cam-
paign should have a dependency such that
it cannot start until an approval task is
complete.

v The project manager has to judge how
much time, effort, and money should be put
in before the company is absolutely sure
the drug will be approved. He might there-
fore build in checkpoints at the end of each
phase to get formal internal approval for
proceeding.




Solution: One tactic the project manager could
use is to break up the projectinto two parts, the
first one including all the tasks that can be per-
formed before the launch, and the second part
including the tasks that are part of the launch,
as shown in this figure. That way, she won't
delay the first part of the project because of
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constraints or dependencies in the second. She
can also anticipate how long from the approval
it will take to complete the launch by looking at
the duration of that second project. As soon as
the launch is approved, she can set the start
date of that second project and get going.
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See Book VII for more about Resource Leveling and how it affects your
project.

It’s part of your role as project manager to take that second swing at your
schedule to make it more realistic and still fit your needs. In Book VII, we go
into the various techniques you can use to resolve problems in your sched-
ule and tighten up that timing.

Book IV
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Chapter 2: Defining What
Drives Task Timing

In This Chapter

v Understanding task types

v+~ Entering task duration

1~ Stopping and starting tasks

1~ Setting start and finish dates

v~ Splitting tasks

v+ Working with effort-driven tasks

Fle timing of tasks is at the heart of all projects. Task timing in Microsoft
Project is driven by a combination of factors, which is what this entire
minibook is about. In this chapter, we explore some of the basic settings you
can make when creating tasks that have an effect on timing.

First, you choose a task type that specifies what affects a task’s timing, such
as whether the task has a fixed duration or a duration that changes based
on how much work has been accomplished. You can enter a duration for
each task, which is simply the length of time you think it will take to com-
plete the task. You can also enter a start date or finish date, or you can even
insert a pause in the middle of the task. Finally, the Effort Driven setting has
to do with how the work performed on a task affects its timing.

Be sure to also take a look at Book I, Chapter 4 to brush up on Project,
Resource, and Task calendars. See Chapters 3 and 4 in this minibook to
discover how dependencies and task constraints further determine the
timing of tasks.

Finding Just the Right Task Type

When you perform a task, the time it takes to complete it might be a set time
(for example, when you take a test in school, it might end in 30 minutes
whether you’re done or not), or the task might not finish until all the work

is done. What constitutes a finished task varies slightly depending on the
task type.
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The big three: Task types

Task types define the relationship that balances a task’s duration, the work
required to complete the task, and resource availability. This is known as the
golden triangle.

Before you begin to enter task durations, you need to be aware of the three
task types. These types have an effect on how Project schedules the work of
a task.

Essentially, your choice of task type determines which element of the task
doesn’t vary when you make changes to the task:

4+ Fixed Units: This is the default task type. With this task type, when you
assign resources to a task with a certain number of units (hours of work
expressed as a percentage of the working day), the resources’ assign-
ments don’t change even if you change the duration of the task and the
work amount.

4+ Fixed Duration: This task type takes a set amount of time to complete,
no matter how many resources you add to the mix. For example, a test
on a substance that requires that you leave the test running for 24 hours
has a fixed duration even if you add 20 scientists to oversee the test.

4+ Fixed Work: The number of resource hours assigned to the task deter-
mines its length. If you set the duration of a Fixed Work task at 40 hours,
for example, and you assign two resources to work 20 hours each (simul-
taneously) at units of 100 percent, the task will be completed in 20 hours.
If you take away one of those resources, the single resource must put in
40 hours at units of 100 percent to complete the task. Understanding
how the choice of task type causes your task timing or resource assign-
ments to fluctuate is an important part of creating an efficient project.

Be sure to review Book V, Chapter 3 for information about assigning
resources to tasks to get the full picture of how resource assignments can
affect task length.

Specifying task type
After you figure out what type of task you're dealing with, setting the task
type is simple to do through the Task Information dialog box.

Follow these steps to set the task type:
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1. Double-click a task.
The Task Information dialog box appears.

2. Click the Advanced tab, if necessary, to display it (see Figure 2-1).

Task [nformation
General Predecessars Resolirces advanced | Motes Custom Fislds |
Name: :"Brocjhuled_esign Durafion; ) _ | Estimat=d
Cr.vnsn-a'u; task . : .
Deadline: .: - i El
Cansiraint type: -7 —- 7|3 Constraint date: |zl

Task typs: |8l Effort driven

Calendar:

E"’fi_fi Eu.r:a.hon [Bl| Scheduling ignores resolres mElendars

WES code: Fixed Work

— Earriad valus method: I =1
Figure 2_1: | Mark task a5 milestonz
Set the task
type here. [ ien ok [ caner |
3. Choose one of the three choices from the Task Type list (see the list of
choices in the preceding section).
4. Click OK.
\\3

You can also display the Type column in a Gantt Chart sheet and make this
setting there.

Task types in practice

Your selection of task type — in combination with a setting that determines
whether a task is effort driven, which is covered at the end of this chapter —
has an effect on the timing of your tasks relative to your resource assignments.

Essentially, task types control what remains constant in a task when you add
or remove work resources to it after making the initial resource assignment.
Although this whole work and duration and resource assignment percentage
calculation can be complicated, you need to understand it if you want
Project to accurately determine task durations in your plan according to
resource assignments.

Book IV
Chapter 2
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Here’s what happens when you’re working with different task types in your
project:

<+

<+

The default task type is fixed units. With a fixed-units task, the task
duration you enter and the resource effort (work) assigned to that task
jointly determine the timing of the task. With this task type, the assign-
ment units you specify for your resources don’t change even if the
number of hours required to complete the task shrinks or grows.

With a fixed-units task, if you increase the duration of Task A from two to
three days, your resources will continue to work on it at the assigned
units for the specified duration; Project increases the Work amount
accordingly. When you add or take away resources, Project changes the
task duration accordingly, based on the assignment units you specify.

The fixed-work task type takes a specified number of work units to
be completed. A one-day task requires eight hours to be completed
(assuming a Standard calendar). This type of task changes its duration
in response to the number of resource units you assign.

With a fixed-work task, resource assignments may change in response to
a work change. For example, suppose Task A takes four days to complete
when one person is assigned; with a fixed-work task, the same task takes
only two days when two people are assigned. Project doesn’t modify the
hours of work required to complete the task, but it does modify resource
assignment units to complete that work within the specified timeframe.
Thus, if you up the duration of Task A, resource assignment units shrink
in response. If you reduce the time to complete Task A, resource assign-
ments increase to complete the unchanged amount of work hours in

less time.

A fixed-duration task doesn’t vary its length, no matter what resource
assignments you make. Suppose that Task A takes four days. If you
assign additional resources or remove resources, the task still takes four
days, but the resource-assignment units will change.

Figure 2-2 shows the same task with the three different types specified. Each

task was created with a four-day duration and one resource at 100 percent.
Then an additional resource was added at 100 percent. Note the resulting
change — or lack of change — with each type. The fixed-duration task
didn’t change duration but did reduce resource assignments. The fixed-units
task kept resource assignments constant at 100 percent — but reduced the
task duration. The fixed-work task was accomplished faster, and the work

(32 hours) stayed constant.
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Task Duration

Project can produce some wonderful calculations and reports, but it can’t
tell you how long each task in your project will take. That’s up to each proj-
ect manager to figure out.

Estimating the duration of tasks isn’t a science. A task’s duration is usually
based on your experience with similar tasks and your knowledge of the
specifics of your project.

If you often do projects with similar tasks, consider saving a copy of your
schedule as a template that you can use in the future. Using this template
will save you the effort of re-estimating durations every time you start a sim-
ilar project. Find out about working with templates in Book I, Chapter 1.

Determining the right duration

Most tasks in a project have a duration, whether it’s ten minutes or ten months
or anything in between. (For milestone tasks, which have no duration, see
the next section.)

Book IV
Chapter 2
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Deciding how finely to break down your tasks can affect how efficiently you're
able to track progress on those tasks: Tasks that linger over an entire year are
probably too broad, and a schedule full of tasks that take ten minutes each
will force you to track progress 24 hours a day just to keep up with them.

For example, if your project is to run a half-day event, getting to the level of
ten-minute tasks might make sense, although more from a planning perspec-
tive than a tracking perspective. In most projects, however, such finely
detailed timing doesn’t make sense because it defeats the point of all the
tracking and reporting features of Project.

On the flip side, creating a 12-month-long task suggests that you might be
defining your project too broadly to accurately keep track of all that can
happen in a year. How do you track your progress every week, in a meaning-
ful way, on a task that will take 12 months to complete? Is the task 1.5 percent
complete in the first week, and how useful is that information? Consider
breaking up tasks that linger longer than a few weeks into smaller tasks.

The Project Management Institute provides a suggestion that task durations
range from 4 to 80 hours, as a rule of thumb.

Entering duration

Whatever your best guess at a task’s duration is, Project makes it easy to
add it to your task. As with all task information, you can enter a duration in a
Gantt Chart sheet or in the Task Information dialog box.

Follow these steps to enter a duration by using the Task Information
dialog box:

1. Double-click a task to display the Task Information dialog box.

2. If necessary, click the General tab to display it (refer to Figure 2-1).

3. In the Duration box, use the spinner arrows to increase or decrease
the duration.

4. If the current duration units aren’t appropriate (for example, days
when you want hours), type a new duration in the Duration box.

New tasks are created with an estimated duration of one day unless you
change the duration. You can use the following abbreviations for various
time units:

¢ m: Minutes

e h:Hours



Don’t assume that changing the start and finish dates of a task changes
its duration, because it doesn’t. You have to manually change the dura-

Setting Task Duration

tion; if you don’t, your project plan won’t be what you intend it to be.

¢ d:Days
* w: Weeks
@“‘N . ¢ mo. Months
S
5. Click OK to accept the duration setting.
\\3

If you're not sure about the timing of a particular task and want to let people

know the duration is just a guess, or if you need a way to search for such

tasks and enter more solid timing when you have better information, select

the Estimated check box on the General tab of the Task Information dialog
box. Then apply a filter for tasks with estimated durations (see Book VII,

Chapter 1 for more about using filters). Tasks for which you have not set any
duration will be considered estimated by default and you will see a question

mark by their durations in the Duration field.

Working with tasks with no duration: Milestones

We mention in the preceding section that almost all tasks have durations;
the exception is a milestone — a task with no duration. Milestones are per-

haps less like tasks than they are like signposts that mark moments in time.
Examples of milestones are the approval of a new product design (although

the deliberations to make that decision might have taken months) and the
completion of a network installation.

243

What does priority do to timing?

One other tool on the General tab of the Task
Information dialog box is the Priority field. You
might think establishing task priority might have
an impact on timing, but think again.

Setting a high or low priority on your task doesn’t
influence timing of the task at all. In fact, this
field is essentially there to help you enter your
own ranking of the importance of tasks in your
project. You can use that ranking to filter tasks
by priority or to display a priority column in a

view with a sheet area so you can scan tasks
that have high importance and stay abreast of
major shifts in your schedule. Though not part
of the timing calculation Project uses, it can be
a useful tool for flagging your own priorities in
a project.

You can use the Priority field either in the Task
Information dialog box or in a column on a
sheet pane to set a priority from 0 (lowest) to
1000 (highest).

Book IV
Chapter 2
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Some people include tasks such as Design Complete or Testing Complete at
the end of each phase of their projects. They can then create timing relation-
ships to the moment of completion (for example, allowing production of a
drug to proceed after the testing and approval is complete). Such milestones
also alert you and your team members to a moment of progress in your proj-
ect that can help to keep the team motivated.

New tasks are created with an estimated duration of one day unless you
enter a duration. To create a milestone, you indicate that the task has zero
duration. The quickest way to do that is to simply type 0 in the Duration
column in Gantt Chart view. Or, you can perform these steps:

1. Double-click a task to open the Task Information dialog box.
2. Click the Advanced tab.
3. Set the Duration to 0.
Project marks the Mark Task as Milestone check box.
4. Click OK.

When you return to Gantt Chart view, the milestone is designated with a
black diamond shape rather than a taskbar.

They keep showing up: Recurring tasks

Some tasks occur again and again in projects. For example, attending a
monthly project debriefing or generating a quarterly project report is con-
sidered a recurring task.

No one wants to create all the tasks for the monthly debriefing in a project
that will take a year to complete. Instead, you can designate the recurrence,
and Project automatically creates the 12 tasks for you.

Here’s how you create a recurring task:

1. Choose Insert->Recurring Task.
The Recurring Task Information dialog box appears, as shown in Figure 2-3.
2. In the Task Name box, type a name for the task.

3. In the Duration box, click the spinner arrows to set a duration or type

P a duration, such as 10d for 10 days.

You can read about the abbreviations you can use for units of duration —
such as d for days — in the earlier section, “Setting Task Duration.”
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N Recurring Task Information
Figure 2-3: i s "3 -
When you ToskMame: |StsffMectinn =~ | Ouration: |1d i
enter this Rw:n‘:e = -
. ) = Remrevery |1 : week(s) on:
information, @ Weeky —
PrO]eCt Manthly ~|Sunday Monday || Tussday || Wednesday
creates Yearly | Thursday [~ | Friday | Baturday
Range of recurrence
multlple Start: \M_cnjjﬂ? E] \Endafter: [0 | ogaurrences
occurrences SEdby:  [TUE07 =
Of a task Calendar for scheduling this task
automat- Caleqdars [More HEd|
ically. Hem | [ox | [ cameet |
4. Select a recurrence pattern by selecting the Daily, Weekly, Monthly,
or Yearly option.
What you select here provides different options for the rest of the recur-
rence pattern.
. Depending on the selections offered to you, make choices for the rest
of the pattern.
For example, if you select the Weekly option, you must choose a Recur
Every X Week(s) On setting, and then choose one or more days such as
Wednesday and Friday. Or, if you select Monthly, you must specify which
day of every month the task will recur.
. In the Range of Recurrence area, type a date in the Start box. Then
select and fill in either the End After or End By option.
For example, you might start on January 1 and end after 12 occurrences
to create a task that occurs every month for a year.
7. Click OK to save the recurring task.
P If your settings cause a task to fall on a nonworking day (for example, if you
choose to meet on the eighth day of every month and the eighth day is a
Sunday in one of those months), a dialog box appears, asking you how to
handle this situation. You can choose not to create the task, or you can let
Project adjust the task to fall on the next working day in that period.
\\3

When you’re ready to assign resources to a recurring task, you have to
assign them to each incidence of the recurring task in Gantt Chart view; the
Recurring Task Information dialog box doesn’t have a Resources tab.

Book IV
Chapter 2
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Starting and Pausing Tasks

A\

When most people start using Project, one of the first things they try to do is
enter a start date for every task in their project. This is largely a matter of
habit: You always include dates when you write up a to-do list, right?

The problem is that setting every task in your project in stone from the get-go
means you're missing out on one of the great strengths of project management
software: the capability to schedule tasks for you according to sometimes-
complex combinations of factors, such as dependencies between tasks and
task constraints. When you allow Project to determine the start date of a
task, you enable it to give you a realistic picture of your project’s schedule.
You also allow it to make adjustments automatically when changes occur.

To retain this flexibility, enter a task duration and don’t enter a start date for
the task. That task will then start by default as soon as possible after the
project start date you set in the Project Information dialog box, based on any
dependencies you set up between tasks.

In general, you establish a task’s start date with dependencies (which you
hear more about in the next chapter). You look for something in the project
that would dictate its timing; for example, if you don’t want construction to
begin until you obtain permits, set a dependency between the permits task
and the construction task in such a way that construction can’t start before
the permit task ends.

Certain tasks, however, must start on a specific date. Examples are a holiday
sale, an annual meeting, or the start of the baseball season.

Project sets the finish date of a task based on when that task starts as well
as the task duration. If a task must finish on a certain date, however, you can
set a finish date and let Project determine the start date.

Entering the task start date

Setting a start date or a finish date for a task applies a kind of “soft” con-
straint on it that can override dependency relationships or other timing fac-
tors. A Must Start/Finish On task constraint, discussed in Chapter 4 of this
minibook, is the way to force a task to start or end on a certain day. In many
cases you do not have to set a start or finish date at all because the project
start date and task dependencies will set the logical timing of the task for
you. If you determine, however, that a particular task must begin or end on a
set date no matter what, you can enter a specific start or finish date.
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Setting the start or finish date is simple. To enter a start or finish date for a
task, simply follow these steps:

1. Double-click a task.

The Task Information dialog box appears.
2. Click the General tab if it’s not already displayed; refer to Figure 2-1.
3. Click the arrow on the Start or Finish box.

A calendar appears.

4. Click a date to select it or click the forward or backward arrow to
move to a different month and select a date.

If the current date is the date you want, use the shortcut of clicking the
Today button on the drop-down calendar.

5. Click OK.

Note that setting a start date isn’t quite as strong a factor in how Project
determines timing as applying the Must Start On constraint. You can find out
more about how constraints work in Chapter 4 of this minibook.

Taking a break: Splitting tasks

Did you ever start something — building that garden shed, for example —
and find that you just had to drop everything before you were done and go
do something else?

It’s the same in projects. Sometimes tasks start, and then you have to put
them on hold until they can start again later (for example, if you experience
a work shutdown due to labor negotiations). Or, perhaps you can anticipate
a delay in the course of a task and want to structure it that way when you
create it. In that case, you can use Project’s Split Task feature to split a task
so that a second or third portion starts at a later date, with no activity in
between. You can place as many splits in a task as you like.

Follow these steps to split a task:

1. Click the Split Task button on the Standard toolbar (it looks like a
little taskbar with a jagged cut down the middle).

A box appears, as shown in Figure 2-4. The box provides a readout to
guide you as you set the start date for the continuation of the task.

Book IV
Chapter 2
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2. Click the task at the date where you want to split the task and then
drag until the box contains the date on which you want the task to
begin again.
3. Release the mouse button.
The task is split.
<® You can rejoin a split task by placing your cursor over the taskbar until the
move cursor appears. Then click the split taskbar and drag it back to join
with the other portion of the taskbar. If you need to, zoom out to make it
easier for you to maneuver the pieces of the taskbar.
égN\BEI? Don’t use the split-task approach to put an artificial hold on a task until
& some other task is complete. Suppose that you start testing a product but

then have to wait for final approval before finalizing the test results. In that
case, you should create a Testing task, a Final Approval milestone, and a
Finalize Test Results task, and then you must create dependency relation-
ships among them. That way, if one task runs late, your final task shifts along
with it instead of being set in stone (as a split task is).
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Understanding Effort-Driven Tasks

Project’s complex calculation of work, task duration, and assignment units
involves not only task types and task durations, but also the Effort Driven
setting. This setting, which is on by default when you create a new task,
relates to the impact that work done on a task has on task durations.

How effort-driven tasks work

When you hear the word effort in Project, you can equate it with work. When
you create a task, by default it is effort driven, which means that if you adjust
resource assignments, the duration might change, but the number of hours
of effort (work) you need to put in to complete the task stays the same.
When you add or delete a resource on an effort-driven task, work is spread
around equally among resources.

With the Effort Driven setting active, if you add resources to a task, Project
distributes the specified work equally among them and might change the task
duration according to the total resource effort, depending on the task type.

Suppose that you have a two-day task to install modular furniture in a new
office. With one resource assigned to the task, working 8 hours a day, it
will take 16 hours to complete the work (two 8-hour days). If you assign a
second resource, the task no longer takes two days because the hours of
effort required will be completed more quickly by the two people working
simultaneously — in this case, in one 8-hour period.

An example of a task that isn’t effort driven is attending a three-day workshop.
No matter how many people attend or how many people are present, the
workshop still takes three days to complete. With the Effort Driven setting
turned off on a task, no matter how much effort your resources put in, the
task won’t be completed sooner.

When effort rules timing Book IV

With all three task types, by default Project makes each task effort driven. Chapter 2
You can turn off the Effort Driven setting if you choose the fixed-duration or
fixed-units task type. With the fixed-work task type selected, the Effort Driven
setting isn’t only turned on automatically, but in fact it can’t be turned off.

Follow these steps to change the settings for an effort-driven task:

1. Double-click a task.

Bunwiy yse] saauqg
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The Task Information dialog box appears.
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2. Click the Advanced tab, as shown in Figure 2-5.
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3. To turn off the Effort Driven setting, select the Effort Driven check
box to remove the check mark.
The Effort Driven setting is on by default.
4. Click OK to save the new setting.
<® If you want to see the effect an Effort Driven setting makes on the timing of

your task, display a Gantt chart and add an Effort Driven column in the table.
Change the setting and view how start/finish dates and the taskbar length

are affected.



Chapter 3: Adding Dependencies

In This Chapter

v+ Exploring how dependency links affect timing

v Discovering the different kinds of dependency relationships
v~ Allowing for lag and lead time

v~ Establishing dependency links

+ Reflecting the timing of external tasks in your project

1 Viewing dependencies in Gantt Chart and Network Diagram views

If you create 100 tasks and don’t change their default settings, they all
start as soon as possible after the project start date. In the absence of
timing relationships, called dependencies, all those tasks not only start on
the project start date, but they occur simultaneously. That means that a
project consisting of 100 tasks takes exactly as long to complete as the
longest task.

Of course, that’s not a very realistic scenario for a project. Typically, tasks
don’t happen at the same time. It might be impossible for certain activities to
happen before others are complete, or you might not have the resources to
perform two tasks at once. For that reason, you have to incorporate timing
relationships that spread those tasks out through the life of your project.

Why Dependencies Are Needed

The reality is that tasks in a project can’t all start at the same time. To reflect
that reality in a Project plan, you have to build in a timing logic. You build that
logic into your plan by setting dependency links between tasks. Dependencies
are timing relationships between tasks (for example, when one task can’t start
before you complete another, or one task can’t end before another task ends).

Dependencies can be driven by

4+ The nature of the tasks: You can’t mail a brochure, for example, until
it’s printed.

4+ A lack of available resources: Your CEO can’t give new product launch
keynote speeches in two cities simultaneously.
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Understanding Dependencies
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In Chapter 2 of this minibook, we tell you that you shouldn’t set task start
dates very often because projects are fluid — that is, they change and grow —
and if you set every date in stone, those dates have to be manually adjusted
if a change occurs. If, instead, you build in timing logic rather than assign
specific dates, Project can reflect changes by adjusting your project auto-
matically based on that logic.

With the right dependencies in place in Project, if the Receipt of Training
Materials task is delayed by a week, for example, the dependent task of Start
Training moves out a week automatically. When you note a change in the
timing of one task while you're tracking activity in your plan, Project makes
adjustments accordingly.

The alternative to building in dependencies is to go in and manually change

the start date of just about every task in your schedule every time a task runs
late. Given the way things change in a typical project, not using dependencies
will leave you with many late nights at the office and a disaster in the making.

Identifying the players in a dependency relationship

A task in a dependency relationship is either a predecessor or a successor.
You might think the predecessor comes first and the successor follows, and
that is usually true. However, two tasks with a timing relationship will be a
predecessor-successor pair, even if the timing of the two tasks overlaps or
they’re set to happen concurrently.

Figure 3-1 shows you how the taskbars in Gantt Chart view graphically
depict the predecessors and successors in dependency relationships.
Notice how taskbars fall before or after another task in the relationship or
when a task starts during the life of another task. Also notice the lines drawn
between tasks: These lines indicate dependency links.

Generally speaking, you set dependencies between one task and another but
not between a task and a summary task. If you set a dependency to a sum-
mary task and the specific action that had to be complete before your task
could start finishes early, you may introduce unneeded delay in your schedule.

When to set a dependency and when
to leave well enough alone

We want to offer one very important piece of advice about dependencies:
You can have more than one dependency link to a task, but don’t overthink
this. Many people who are new to Project make the mistake of building every
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Figure 3-1:
In this view,
dependency
relationships
are shown
by the lines
between
taskbars.
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logical timing relationship that could exist. If your project timing changes or
the dependencies have to be modified (for example, to shorten a schedule),
you’re stuck with changing the huge web of dependencies, which can easily
get out of hand.

For example, say that you have to complete the tasks of designing and printing
a brochure before you can mail it. You could set up a dependency between
designing and mailing, designing and printing, and printing and mailing, but
why bother? If you set up a dependency between designing and printing, set
a dependency between printing and mailing that ensures that you can’t mail
the brochure before it’s designed.

If you use a dependency to delay a task and then change the resources
assigned to the task, you've built in a false delay. There is another and
perhaps better method than dependencies to prevent resources from
working on two tasks simultaneously: You can set the availability for
resources and assign them to tasks. You can then use tools such as Resource
Leveling, which forces one task to be delayed if there are resource conflicts.
See Book VII, Chapter 2 for more about how resource conflicts affect task
timing.
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25 4 Understanding Dependencies

Figure 3-2:
The finish-
to-start
relationship
between
two tasks.

All types of dependencies

You can establish four types of dependency links: finish-to-start, start-to-
finish, start-to-start, and finish-to-finish. Using these types efficiently can
help you to build a tightly structured timing logic into your schedule that
can help keep your project moving along.

In Book IV, Chapter 4 we cover task constraints. These settings and task pri-
orities work in concert with dependencies to determine the ultimate timing
of tasks in your project.

Here are the four dependency types:

4 Finish-to-start: A finish-to-start dependency is the most common type
of dependency link. In this relationship, the predecessor task must be
completed before the successor task can start. When you create a
dependency, the default setting is finish-to-start.

An example of a finish-to-start dependency is when you must complete
the Write Annual Report task before you can begin the Send Out Annual
Report task. Figure 3-2 shows two tasks with the finish-to-start relation-
ship indicated by a successor taskbar that starts where the predecessor
taskbar leaves off. When one task ends, the other begins.
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4+ Start-to-finish: In a start-to-finish dependency, the successor task can
finish only after the predecessor task has started. If the predecessor
task is delayed, the successor task can'’t finish.

Suppose that you're planning the opening of a new theater building.

You might start selling tickets for the theater’s first production while

the building is being built, and you don’t want to stop selling tickets
until opening night. So, the predecessor task is Theater Building Complete
(a milestone or task of no duration), and the successor task is Sell Tickets
for Opening Night. If the theater isn’t ready on time, you can keep selling
tickets. When the theater is ready to go, the ticket windows close, and
that task can finish. Break a leg!

4+ Start-to-start: Start-to-start means what it says: Two tasks exist in a
parallel relationship and therefore start simultaneously. For example,
even though posters and invitations for your blockbuster event are
being created by different designers, you might want to ensure that you
send the posters and invitations to the printer at the same time for cost
efficiency.

Figure 3-3 shows the start-to-start relationship between the two tasks.
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4+ Finish-to-finish: Finish-to-finish means that (you guessed it) two tasks
must finish at the same time.

Suppose that you're preparing an advertisement for your adventure-travel
company. You have to obtain photographs of travel destinations and
have the ad copy laid out. You need both items in hand before you can
forward the ad to travel magazines. If you set a finish-to-finish depend-
ency between these two tasks, you allow both tasks the greatest length
of time to be completed. (Why have the photos been sitting around for
four weeks, for example, when the copy isn’t ready?) However, keep in
mind that if one task finishes late, they both finish late.

More complex dependencies: Lag and lead time

Dependencies can be more complex than simply establishing the four types
of dependency links we describe in the preceding section. You can use lag
time or lead time to fine-tune your timing relationships in the following ways:

4+ Lag time occurs when you add time to the start or finish of a predeces-
sor task; lag time causes a gap in timing.

4+ Lead time is created when you subtract time from the start or finish of
the predecessor task; lead time causes an overlap between two tasks.

You might use lag time to reflect that a task such as Run Focus Group might
have to wait a week or two after you distribute sample materials to the
group members so that they have time to study them. On the other hand,
you could use lead time to allow one task to begin part way through another
task. For example, you could begin to train people on new equipment when
only half of the new pieces of equipment have been received.

See the Case Study at the end of this chapter for a study of the use of lag and
lead time in a sample project.

Setting Dependencies

Establishing dependency relationships is easy to do. You simply create a
dependency, make settings to select the dependency type, and build in any
lag or lead time.

What’s more complex is understanding how each type of dependency affects
your plan when your project starts and you begin to record actual activity
that resources perform on individual tasks.

This section provides guidance on establishing dependencies and under-
standing more about how they function in a real-world project.



Figure 3-4:
This box lets
you know
when your
cursor is
resting over
the task to
which you
want to link.
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Setting up dependency links

When you create a dependency, by default, it’s a finish-to-start relationship:
One task must finish before another can start. If your situation calls for that
kind of simple scenario, you can set a dependency between two tasks by

using a simple click-and-drag method, and you’re done.

To establish a simple finish-to-start link, follow these steps:

1. Display Gantt Chart view and make sure that the two tasks you want

to link are visible.

You might have to collapse some tasks in your project or use the Zoom
command on the View menu to fit more tasks on your screen.

2. Move your cursor over a taskbar until it changes to a four-headed arrow.

3. Click the predecessor taskbar and drag your cursor to the successor

taskbar.

As you drag, a box appears, as shown in Figure 3-4, and your cursor
changes to the shape of a little chain link.

4. When the readout indicates the task number you want to link to,
release your mouse button.
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) You can also use the following method to establish a finish-to-start relationship
between two tasks: Click the predecessor task, press Ctrl, click the successor
task, and then click the Link Tasks button on the Standard toolbar.
If you have to refine your dependency after you create a dependency link,
you can edit that link to change the dependency type or to build in lag or
lead time.
To establish a link in the Task Information dialog box or to modify an existing
relationship, make note of the task ID number (you can find it in the far-left
shaded column in the Gantt Chart sheet pane) of the predecessor task and
then follow these steps:
1. Double-click the successor task.
The Task Information dialog box appears.
2. Click the Predecessors tab, shown in Figure 3-5.
On this tab, you can build as many dependency relationships as you like.
Task Information ==
General Predecessors Resources Advanced Notes Custom Fields ]
Name: |fi_e-\;|e_war;|];-a_|g-ncsﬁoé5ts | puration: i-la’__?i [7] Estimated
Predecessors:
.. 58 -
jin] Task Name Type Lag
EIB Crgznization Internal Communications and Training Complet: Finish-to-Start (Fs) od
65 Customer Relationship Management Complete Finish-to-Start (FS) od
72 Regional /Global/Country Business Models Complete Finish-to-Start (FS) od
Figure 3-5:
Build
dependency £
relationships
here. Help | OK | | Cancel

3. In the ID field, type a task ID number for the predecessor task.
Alternatively, you can select the task from the Name drop-down list.

4. Press Tab.

The task name and the default finish-to-start dependency type with 0d
(no days, the default unit of time) of lag time are entered automatically.

5. Click the Type field and click the arrow to display the dependency
types and then click the appropriate dependency for your situation.



s

Figure 3-6:
The more
complex the
project and
its timing
relation-
ships, the
more lines
you see.

Setting Dependencies 259

6. If you want to add lag or lead time, click the Lag field and use the
spinner arrows to set the amount of time.

Click up to a positive number for lag time or down to a negative number
for lead time.

7. Repeat Steps 3-6 to establish additional dependency relationships.
8. When you're finished, click OK to save the dependencies.

The Gantt chart displays your dependencies with lines and arrows, as
shown in the project displayed in Figure 3-6.

Most dependency links exist between tasks that are close to each other in
your schedule. However, sometimes dependencies exist between tasks that
are weeks or months apart. In that case, the click-and-drag method can be
difficult to use. For this type of situation, you can use the successor task’s
Task Information dialog box to create the relationship by entering the prede-
cessor task ID number or name and by defining the lag or lead time in the
appropriate fields.
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Connecting to other projects
with external dependencies

Few projects in organizations exist in a vacuum. Many times, another project
you’re managing or another project going on somewhere else in your organi-
zation affects your project. Perhaps you share resources or equipment with
others, or perhaps the timing of tasks in other projects affects the timing of
tasks in yours.

If your project is to launch a Web site, you might have to create a depend-
ency from your Launch Web Site task to the New Product Release task in
someone else’s project so you're sure you can offer the new product line on
the Web site.

To deal with this cross-project coordination, you can create a hyperlinked
task that represents the timing of the other project (or of a particular task in
the other project). Enter a start date and duration for the external task as a
task in your project. You can then create dependencies between that task
and other tasks in your project to connect your activities to the external
timing. Use the hyperlink to jump quickly to the other project whenever you
want to update your timing information. (See Book IlI, Chapter 4 for informa-
tion about hyperlinking tasks in projects.)

You can also insert an entire project and add a link to it so that updates to
the other file are reflected in your plan automatically.

Things change: Deleting dependencies

Over the life of a project, you're likely to find that timing relationships among
tasks change. For example, sometimes you no longer need a dependency you
created to avoid resource conflicts because of a shift in resources or overall
project timing.

When you need to get rid of a dependency, you can undo what you did in
either Gantt Chart view or the Task Information dialog box.

With Gantt Chart view displayed, follow these steps:

1. Select the two tasks whose dependency you want to delete.
e For two adjacent tasks: Click and drag to select their ID numbers.

e For nonadjacent tasks: Click one task, press and hold the Ctrl key, and
then click a nonadjacent task.

2. Click the Unlink Tasks button on the Standard toolbar (it looks like a
chain link with a break in the middle).
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Be careful when you use this method: If you click a single task and then click
the Unlink Tasks button, all dependency relationships for that task are

removed.

To remove dependency relationships in the Task Information dialog box,

here’s the drill:

1. Double-click a successor task name.

The Task Information dialog box appears.

2. Click the Predecessors tab to display it.

3. Click the Type box for the dependency that you want to delete.

A list of dependency types appears, as shown in Figure 3-7.

Task Information

General Predecessors Resources Advanced ] Notes

=

1 Custom Fields ]

MName: |Rewew campaign concepts

| puraton: [2d?

2| [¥|estmated

Predecessors:
#|y/]| Finish-to-Start (FS)
i) Task Name
58 Organization Internal Communications and Training Complet

Type
Finish-to-Start (FS)

65 Customer Relationship Management Complete

Finish-to-Start (FS)

Figure 3-7:
You can use
this tab to
create and
delete
dependency
links.

72 Regional {Global/Country Business Models Complete

Finish-to-Start (FS)

Finish-to-Start {FS)
Start-to-Start (S5)
Finish-to-Finish {FF)
Start-to-Finish (SF)
Nore)

e)

[ oo |

| | Cancel

4. Select None.
5. Click OK to save the change.

The dependency line on the Gantt chart is gone. The next time you open
that Task Information dialog box, you find that the dependency is no

longer listed there.

If you turn on the Change Highlighting feature, you can see how making this
kind of change to dependencies affects your schedule. To turn on Change
Highlighting, choose View=>Show Change Highlighting. Any tasks affected by
subsequently adding or deleting a dependency have either their start or
finish date column highlighted in the spreadsheet pane, depending on which

date was affected.
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Visualizing Task Dependencies
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Being able to get a look at the dependency structure in your project can be
very useful, especially when you’re trying to solve a problem or refine the
details in your project to save time or money.

Project provides several ways to view dependencies in your project. This
involves displaying various views that represent dependencies by using text
to describe them or lines that run between graphical representations of
tasks.

You might have already seen the dependency link lines that appear in the
Gantt chart (refer to Figure 3-6). Another great way to see the flow of depend-
encies is in Network Diagram view. This workflow view uses similar lines and
arrows to reveal dependency relationships, but it allows you to get a differ-
ent perspective on them.

You can also display the Task Drivers pane (choose Project=>Task Drivers) to
see a list of everything in the schedule that’s driving the timing of a selected
task. For more about the Task Drivers feature, see Book I, Chapter 5.

Figure 3-8 depicts a Network Diagram view of an IT project. Notice that each
task is represented by a node that contains data about the task. Between the
nodes run lines that represent dependency relationships among the tasks.
Although you can’t see the effect in this black-and-white image, any task
dependency links on the critical path are displayed in red by default, and
noncritical tasks are displayed in blue. (Critical-path tasks have no slack:
They can’t be delayed without delaying the entire project.)

One way to help you remember what’s going on with dependencies in Network
Diagram view is to edit the layout to show link labels. Here are the steps to
do this:

1. Right-click anywhere outside the task nodes.
2. Choose Layout.
3. Select the Show Link Labels check box.

A code, such as FS for finish-to-start, is displayed to explain the type of
dependency that each dependency line represents, as shown in Figure 3-8.

You can also display a view that contains columns to view by task ID
number, successors or predecessors for each task, or the dependencies

for a task. You can do this in any view with a sheet area, such as Gantt Chart
view. Figure 3-9 shows a Gantt Chart view for an engineering project with
Predecessors and Successors columns displayed.
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Training new staff efficiently

Company: Large science museum.

Project: Staff and train a new set of volunteer
docents to give museum tours.

Challenge: Organize training as quickly as pos-
sible to handle upcoming peak season. In the
first version of this plan there was a finish-to-
start relationship between the two tasks Locate
Recruits and Train Recruits. That meant that no
training could begin until the last docent recruit
was on board. With this dependency in place,
the project couldn't meet the required deadline.

Solution: To get some docents trained and
working more quickly, the project manager
decided to incorporate a week of lead time —
that s, allow the training of the earliest hires to
start before all the recruits are hired. To do this,
he essentially deducted time from the finish-to-
start relationship between Locate Recruits
and Train Recruits. This change allows the
training to start a week before the finish of the
Locate Recruits predecessor, as shown in this
figure.
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Another way to achieve this would be to break
the recruiting and training into two pieces. To do
this, you could have two recruiting and two train-
ing tasks. Say you have to recruit ten people.
The first task could be Recruit Half of Docents
and the second task Recruit Second Half of
Docents. Create finish-to-start relationships

Visualizing Task Dependencies

between the first recruiting task and the first
training task; then create the same relationship
between the second recruiting task and a
second training task. If there's a delay in hiring
the second set of docents, the first half of the
docents can still proceed with their training.

205

These columns also include a notation of any type of dependency other than

the default finish-to-start type and any lead or lag time using percentages
or lengths of time. For example, 71SS+50% is a start-to-start link to task 71,

with lag time set so that the successor task begins halfway through the pred-
ecessor task. Similarly, 71SS+2 days is a start-to-start link to task 71, with lag

time set so that the successor task begins two days after the predecessor

task starts.

\\3

Note that you can also edit the contents of Network Diagram nodes to
include predecessor and successor data.
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Chapter 4: Working with
Constraints and Deadlines

In This Chapter

+ Looking at how constraints control timing

v+ Understanding different constraint types

1~ Assigning constraints

v Understanding constraints in combination with dependencies

v~ Setting a deadline

an you build a project, each task in it gains its timing from a variety
of influences with a sometimes-complex set of priorities. You may
give a task a specific start date, set dependency relationships that drive the
task’s timing, or even set up a project calendar that dictates how much work
can go on in a given day or week.

In addition to all these influences and more, you can apply constraints to
individual tasks. A constraint is a restriction that you place on a task to control
when it can start or finish. In combination with other factors, a constraint
can be a powerful force for determining the timing of your tasks and project.

Deadlines, on the other hand, are more informational and are used to alert
you when you’re running late, but they don’t control the timing of tasks in
any real sense.

Beginning with the Start and Finish Dates

Every task has a start date and a finish date. You can set fixed start or finish
dates, or (and this is the preferred method) you can let Project schedule
them based on several criteria. In the absence of a fixed start or finish date,
Project schedules a task based on the task duration, calendars (including
the Project calendar and assigned Resource calendars), dependencies with
predecessor and successor tasks, constraints applied to predecessor and
successor tasks, and a task’s own calendar and constraints.



268 Understanding How Constraints Work

Brush up on calendar settings in Book I, Chapter 4, and on dependencies in
Chapter 3 of this minibook.

The weight that Project gives each of these factors is a rather complex thing
to understand, and frankly, it’s not going to help you that much. Rather than
dissect the complex algorithm Project uses, what you should know is that
the more you change default settings to apply constraints, set a fixed start
date, or modify each task’s calendar, the more settings you have to track
down when a problem occurs. That’s one reason why you should use con-
straints sparingly and only when absolutely necessary (more about when
that might be shortly).

So how, exactly, does a task constraint work? We're glad you asked. . ..

Understanding How Constraints Work

Figure 4-1:
The Project
Information
dialog box.

Though constraints are only one of the criteria used to establish task timing,
when Project performs calculations to try to save you time in a project that’s
running late, it considers constraints to be the most sacred timing settings.
For example, if you set a constraint that a task must finish on a certain date,
Project doesn’t do anything to change that date when recalculating timing of
tasks in your project.

Default constraints

When you create a task, depending on the scheduling method that you
set in the Project Information dialog box shown in Figure 4-1 (see Book II,
Chapter 1 for more about scheduling methods), you can apply two default
constraints:

4+ If you’re scheduling your project to be calculated from the start date,
the As Soon As Possible constraint is selected by default. In other
words, the task starts as soon as the project starts, assuming that no
dependencies with other tasks exist that would delay its start.

If you’re scheduling your project to be calculated from the finish date,
the As Late As Possible (ALAP) constraint is applied by default. In this
case, the task occurs as late as it possibly can while still meeting the
finish date of the entire project.

Project Information for 'Science Museum Office Move'
Start date: Tion 11/07. - [=] Curentdate; [Mon4/2/07 I
Firfish date: [T &2 ] sowsdse:  [NA =
Schedule from: ﬁro]r:ct%iﬁrt |E)E|LE —— B Calendar: i'svaF.Eé.rE'7 = — 7E

|
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You can create a task by clicking and dragging within the chart area in Gantt
Chart view. When you create a task using this method, Project applies the
Start No Earlier Than constraint if you have set up your project to schedule
from the start date. If you're using the finish date scheduling method, such a
task has the Start No Later Than constraint applied.

Constraint types

Table 4-1 lists all the constraints and an explanation of their effects on your
task’s timing.

Table 4-1 Task Constraints
Constraint Effect
As Late As Possible The task occurs as late as possible in your schedule, based on

dependencies and the project finish date.

As Soon As Possible The default setting; the task starts as early in the schedule as
possible based on dependencies and the project start date.

Finish No Earlier Than  The end of the task can’t occur any earlier than the date you specify.

Finish No Later Than The end of the task can't occur any later than the date you specify.

Must Finish On The task must finish on an absolute date.

Must Start On The task must start on an absolute date.

Start No Earlier Than ~ The task can't start any earlier than the date you specify.

Start No Later Than The task can't start any later than the date you specify.

Flexible versus inflexible constraints

It’s helpful to understand that the constraints Project offers fall into two cat-
egories: flexible and inflexible (also known as soft and hard constraints).

Flexible constraints allow Project to move the task start and end dates based
on other factors in the project such as dependencies with other tasks that
are delayed. A typical flexible constraint is As Soon As Possible. A task could
start, for example, as soon as possible when all other elements (such as the
project start date, dependency relationships, and assigned Resource calen-
dars) are satisfied. Flexible constraints include

4+ As Soon As Possible

4+ As Late As Possible

4+ Finish No Earlier Than

4 Finish No Later Than

4+ Start No Earlier Than

4 Start No Later Than

Book IV
Chapter 4
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3

An inflexible constraint never allows the start or end date (depending on the
constraint) to be moved because it essentially sets that date in stone.
Inflexible constraints include:

4 Must Finish On
4 Must Start On

Constraints and dependencies

Most tasks have some dependency relationships with other tasks. When a
dependency is in place, it’s important that you know how constraints affect
a task. Here’s one example.

If you create a task called Wire House and another task called Wiring
Inspection, you might put a finish-to-start dependency between them so
that the inspection can’t happen until the wiring is complete. If the wiring is
completed early, the inspection could happen earlier. If the wiring task runs
late, the inspection task is pushed back.

But if you know that inspections are done every two weeks on Thursdays
and you really want the inspection to occur in a certain week of the project,
you might decide to put a Must Start On constraint to force the inspection
task to happen in the week you want wiring to be complete. If you set that
constraint, here’s what happens:

If the wiring finishes two weeks early, your schedule shows that you have to
sit around for two weeks until the inflexible Must Start On constraint date
rolls around. If you don’t notice the problem and manually move the inspec-
tion up by removing the constraint, that could cost you valuable time in
your schedule.

If you're late on the predecessor task when you track the earlier start date,
Project displays a Planning Wizard dialog box like the one shown in Figure 4-2.
This warning notes that the pushing back of the predecessor task causes a
conflict with a successor task that cannot move. At this point, you can choose
to cancel the tracking activity or allow the conflict. If you allow the conflict,
the successor task falls behind the predecessor task (see Figure 4-3).

Instead of setting the Must Start On constraint, consider using a deadline
(see “Setting a Deadline,” later in this chapter) to flag the date you think the
inspection should happen. If the deadline passes and the inspection hasn’t
happened, Project displays an indicator in the Indicator field for that task,
alerting you to the fact that you’re running late. By not using the constraint if
the earlier task finishes ahead of schedule, the inspection task is allowed to
move up, saving you time overall.
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Establishing Constraints

You can set only one constraint for a task. Setting a constraint involves
selecting the type of constraint you want in the Task Information dialog box.
Some constraints work together with a date you choose. For example, if you
want a task to start no later than a certain date, you need to select a date by
which the task must start. Other settings, like As Soon As Possible, work off
a different date — in this case, the start date you set for the whole project or
any dependency relationships you set up with other tasks. (See Chapter 3 of
this minibook for more about dependency relationships.)

To set a task constraint, follow these steps:

1. Double-click a task.

The Task Information dialog box appears.
2. Click the Advanced tab (see Figure 4-4).

3. Select a constraint from the Constraint Type list.

4. If the constraint requires a date, select one from the Constraint

Date list.
5. Click OK to save the settings.

Book IV
Chapter 4
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Figure 4-4:
The Task
Information
dialog box,
Advanced
tab.

Task [nformation
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Setting a Deadline

Strictly speaking, deadlines aren’t constraints (although the setting for the
deadline is in the Constraint Task area of the Task Information dialog box, on
the Advanced tab). Deadlines differ from constraints in that they don’t force
the timing of your tasks in any sense.

If you set a deadline, it simply causes Project to display a symbol in the
Indicator column if the task has run past the deadline to alert you so that
you can panic (we mean, take appropriate action). Using a deadline is often
preferable to setting an inflexible constraint because a deadline allows a task
to shift with other changes in your schedule, yet keeps you aware when
you’re going to miss a target date.

To set a deadline, follow these steps:

1. Double-click a task.
The Task Information dialog box appears.
2. Click the Advanced tab.

3. Click the arrow in the Deadline field to display a calendar (see
Figure 4-5), and then select a date.

If necessary, use the forward or backward arrow to move to a different
month.

4. Click OK to save the deadline setting.



Figure 4-5:
The

Deadline
field
calendar.
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Figure 4-6:
Entering a
deadline in
Gantt Chart
view.

You can also display a deadline column in your Gantt Chart sheet pane (see
Figure 4-6) to enter the deadline or to show yourself and others what your
targeted deadline date is.
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Waiting till the last minute

Company: Home office of a large retail clothing
chain.

Project: Office move.

Challenge: Training employees on the new phone
system should happen as late as possible in the
move so they can begin working on a day-to-day
basis, with minimal down time, with the phones
in their new office space right after training.

The main office of a company that runs dozens
of retail clothing stores is moving to new office
space. The staff in the office includes the cus-
tomer support group that provides support via
phone and e-mail. Part of the move involves
installing a new phone system with some
sophisticated features, and the staff needs

training to use those features.

The project manager has been charged by the
VP of Operations with arranging the training on
the phone system to occur as close as possible
to the end of the project — the last milestone
task named “Move Complete.” This ensures
that employees are trained in the phone system
no more than a day before they move into the
new offices and begin to use the system.

Solution: To achieve this result, the project
manager applies an As Late As Possible con-
straint to the training task and then creates a
finish-to-start dependency between it and the
Move Complete task. With these settings, the
task appears just before the move-in but no
earlier, as shown here.
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Chapter 1: Creating Resources

In This Chapter

v+ Discovering resources

v Understanding resource types

v Estimating resource requirements

1+~ Entering resource information

v Using the Resource Information dialog box

+* Working with consolidated resources

Projects typically involve people to get the work done. Projects also use
equipment and materials. Those people, equipment, and materials are
your project resources.

Resources are the means by which Project adds up the costs in your plan.
For example, when you assign a resource to work for ten hours on a task
and give that resource an hourly rate of $30, you've just added a $300 cost
to your project.

Because resources affect timing and costs, they’re an important element of
Project. Many tools are available to help you create resources, make settings
for how and when they’ll work, assign them to tasks, manage their costs,
and manipulate their workload. The first step in working with resources is
to create them in Project and enter certain information about them. That’s
what this chapter is all about.

What Exactly Is a Resource?

It’s natural to think of a resource as a person. After all, companies have
human resources who work on projects, right? Well, people are indeed a
frequently used project resource, but they’re not the only type of resource.
Resources can also be equipment that you rent or buy (such as a truck), as
well as materials (such as paper clips or scrap iron).

You can even create resources that represent facilities you have to rent by
the hour, such as a laboratory or a meeting space, or travel costs. For exam-
ple, you could create a resource named Conference and assign it a unit cost
of $900, which covers the average cost for attending a professional confer-
ence, including airfare, hotel, and the conference fee.
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Here are some typical and not-so-typical project resources:

<+

Lab technicians

Trade show booth

Office supplies

Offsite meeting facility
Administrative assistants
Rocket fuel

Consultant fees

Service call

Computer software
Printing services

Web designer

IR IR SRR IR R R et

Prototype design

Essentially, a resource is anything or anyone who adds to the bottom line
cost of your project or whose time or involvement you need to track.

All Kinds of Resources

A\

Typically after you create and organize the tasks in your project, the next
step is to create resources. Before you start creating resources, however,
you should understand how they affect not only your project costs, but also
the timing of tasks.

Understanding resources

The key to understanding resources is to realize that costs in Project are
accumulated by assigning resources. If you want to account for costs in your
project — such as a person putting in hours of work on a task, materials that
you have to buy to make a product, or your monthly office space rent — you
have to create resources and assign them to one or more tasks. When you
do, you can see the resulting costs in the Total Cost column of the Gantt
Chart spreadsheet, as shown in Figure 1-1.

You can create resources with no associated costs. You might do that so you
can track only that resource’s time. Some people use Project strictly as a
scheduling tool, so watching the time people are spending on tasks is their
only interest, not what the time is costing. That’s okay as long as you know
that if you don’t assign costs to resources, you get no cost or budget infor-
mation back from Project.
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Total Cost column
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One other way to add costs to a project is to use a fixed cost. Fixed costs
aren’t assigned through resources because they don’t accumulate costs by
hours of work or units used. Instead, a fixed cost is a set cost applied directly
to individual tasks. If a cost isn’t task specific — such as a flat $10,000 con-
sulting fee to a firm that’s advising you on a project — you can create and
assign a fixed cost to a task. (For more on fixed costs, see Chapter 2 in this
minibook.)

After you create the resources, you need to manage the workflow for any
resource that has limited time availability for your project. You can track the
time being used for any type of resource with limited availability by creating
resources that are available so many hours per day and so many days per
week. For example, one person might be available to work on your project
50 percent of the time, or 20 hours in a 40 hour workweek, whereas another
might be available full-time (40 hours). A supercomputer might be available
to your project only 10 hours a week, or you might be able to book a meeting
room for only an hour a day.

saaunosay bunealy
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Figure 1-2:
You can see
total hours
on the
project by
resource
and an
itemization
of the hours
assigned
task by task
for that
resource.

When you assign limited-availability resources to your project, you can then
use various views, reports, and tools to see whether any resource is over-
booked at any point during your project. You can also see whether people
are sitting idle when you might be able to make use of them on another task.
You can even account for resources that work on multiple projects across
your organization and make sure that they’re being used efficiently.

See Chapter 3 in this minibook and Book IlI, Chapter 4 for more about
resources used in multiple projects.

Views such as Resource Usage view (as shown in Figure 1-2) help you visual-
ize resource working time in your project.

Resource types: Work, Material, and Cost

The number of resources you assign to work on a task usually has an effect
on the duration of that task. Think about it: If you have a certain number of
hours of work to do but few people to do that work, a typical task takes
longer to finish than if you had all the resources in the world.
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The task type determines whether a task’s duration changes based on the
number of resources assigned to it. See Book IV to explore more about tasks
and timing.

Although people and things come in all shapes and sizes, only three types of
resources exist as far as Project is concerned:

4+ Work resources are typically (but not always) people. They can’t be
depleted but can be reassigned. Their costs are associated with the
amount of work time they put in, usually at an hourly rate or a cost per
use. Work resources are assigned to tasks based on a Working Time cal-
endar (as shown in Figure 1-3), where you specify their working and non-
working hours. You can select one of three base calendars and then
modify specific working hours.

A typical Work resource is a person working eight hours a day at a
standard rate of $20 per hour and an overtime rate of $30 per hour.
Another example of a Work resource is a meeting facility available only
eight hours a day at an hourly rate. Even though it’s not a person, the
meeting facility would probably be created as a working resource
because it has limited “working” hours.
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The number of hours a resource can work is determined by the calen-
dars. The three kinds of calendars are Project, Task, and Resource.
Calendars, their settings, and how those settings interact are discussed
at some length in Book I, Chapter 4.

4+ Material resources can have an hourly rate or a unit cost, and they also
have an unlimited working time. This type of resource has no calendar,
no overtime, and you make no settings for working and nonworking time.

A typical Material resource is any material — such as steel, rubber,
paper, chairs, or shoes — assigned to a task with an associated unit
cost. For example, a resource called Books with a unit price of $12.95,
assigned to a task called Computer Training at ten units, accrues a cost
of $129.50 to the task. Another example of a material cost is anyone per-
forming a service for a fee in a situation where working time isn’t an
issue. A facilitator who runs an offsite meeting for a fee of $1,000, but
whose working calendar and time aren’t your concern, could be created
as a Material resource with a unit cost of $1,000.

4+ Cost resources have a set cost associated with them. Calendars and
units of work or unit costs have nothing to do with the amount such
resources deduct from the bottom line of your project.

An example of a Cost resource is a consultant working for a set fee.
The cost to set up your network might be $25,000, for example, and
wouldn’t change based on the time it took to set up the network or the
volume of hours or units used.

Estimating your resource requirements

You usually can use a calculation to estimate how much of a Material resource
you need to complete a task: In most cases, you can calculate the number of
pounds of sugar, tons of steel, yards of fabric, and so on based on previous
projects and industry standards. But how do you know how much effort it
will take on the part of Work resources to complete the tasks in your project?

As with many aspects of information you put into a Project plan, this judg-
ment rests to a great degree on your own experience with similar tasks and
resources. One approach is to start with an educated guess at how long it
might take you to complete such a task, and then factor in variables for an
individual resource. Consider the following guidelines:

4+ Consider skill levels. A less skilled or inexperienced resource is likely to
take more time to finish something.

4+ Look to the past. Look at previous projects and tasks. If you've tracked
people’s time, you can probably see how much effort was required to
complete various types of tasks on other projects and draw parallels to
your project. If you've worked with a particular resource before, check
your notes about his or her performance and use that as a guide.
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4+ Go to the source. Ask the resources themselves how long they think it
will take. Then add 10 percent to that time in case the resources were
being overly optimistic!

Committed versus proposed resources

Last time you asked somebody whether he was available to work on your
project, did you get a half-hearted, “Well, maybe, if | have time, if my man-
ager says it’s okay, if it falls on a Leap Year . ..”? You may well ask: So is that
resource available or not? You can’t always be positive about a resource’s
commitment in the planning stages of your project. How can Project help?
Project has the capability to designate a resource as either proposed or
committed. You can use the Booking Type field in the Resource Information
dialog box to make this setting.

What does this setting do? Well, it’s pretty much a field you can use to keep
track of resource status. If you're not quite sure about a resource’s commit-
ment to your project, you call that resource proposed. Then you can display
the Booking Type column in a resource view (such as the Resource Sheet)
and keep track of resources you might have to firm up as you get closer to
finalizing your project plan.

Creating Resources
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Creating a resource in Project essentially involves filling out a form with
some vital statistics about the resource. On the Resource Information form,
you enter information such as the resource name, rate per hour or cost per
use, and availability. You can also enter optional information. Entering a
resource’s e-mail address helps you stay in touch, and entering a setting
such as proposed (see the previous section) gives you a field you can search
or filter to locate certain resources by those criteria.

You can create a resource to represent an individual person; a thing such as
a telescope used for scientific study; a generic resource (that is, a skill set
with no person attached, such as Assistant or Engineer); and even a group of
several resources that work together.

Creating one resource at a time

Whether your resource is a person, a piece of equipment, or a material, you
can begin to create these individual resources by entering information in the
Resource Information dialog box.

Another method for entering resource information is to display Resource
Sheet view and enter information in the columns included there for each
individual resource. This is often a faster way to enter information about
several resources one after the other.

saaunosay bunealy
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Figure 1-4:
These four
tabs can
hold a
wealth of
information
about any
resource.

When you create a resource, you must, at a minimum, type the Resource
Name. You can also include as much information as you want on the several
tabs of the Resource Information dialog box. Some people prefer to create

all the resources first and deal with details such as contact and cost informa-
tion at a later stage.

They say the devil is in the details! If you create resources with only bare-bones
information, be sure to go back later in your planning to add the details.

The details, such as rate per hour or working time settings, can make the
difference between an accurate schedule and one that bears no resemblance
to reality.

Note that to create a resource using the Resource Information dialog box,
which allows you access to every single detail of a resource, you have to
first display a view that includes a Resource Name column. Follow these
steps to create a resource via the Resource Information dialog box:

1. Click Resource Sheet view on the View bar.

2. Double-click a blank Resource Name cell.

The Resource Information dialog box appears, as shown in Figure 1-4.

Resaurce Information ==
General ] S Notes Custom Fields
Resource name: M : _. Tnitials: e ==
|__ | Grous: il
Code: _7 |
Type: L e
| Help =5 oK | |, canesl, |

3. In the Resource Name text box, type a name.
4. In the Initials box, type an abbreviation or initials for the resource.

These shorthand versions of the names can be displayed in the
Resource Initials column and can be a useful reference if you have many
resources assigned to a task. If you don’t enter anything here, the first
letter of the resource name is inserted when you save the resource.



A\

Creating Resources 285

5. From the Type drop-down list, select Work, Material, or Cost.

The settings available to you differ slightly depending on what you
choose. For example, a Material resource won’t have the Email box avail-
able, and a Work or Cost resource won'’t have the Material Label box
available.

6. Continue to enter any information you want to include for the resource.
That information might include
e Email: Just what it seems
e Group: A department, division, or workgroup, for example
e (Code: Such as a cost center code
® Material Label: For example, pounds for food coloring or tons for steel

If you enter information in the Group text box, you can then use filters,
sorting features, and the Group feature to look at sets of resources. See
Book VII, Chapter 1 for more about filtering and working with groups.

7. Click OK to save the new resource.

If you use Project Server (a feature that you can use along with Project
Professional for online collaboration, covered in Book X), the Resource
Information dialog box will include a Workgroup field. You or the administra-
tor who sets up your enterprise-wide resource pool can choose the Microsoft
Project Server option in the Workgroup field. You can also use the Windows
Account option in the Resource Information dialog box to specify how you’ll
communicate with the team. See Book X, Chapter 2 for more about enter-
prise resources.

Identifying resources you don’t know

In the planning stages of a project, you might find that all your resources
aren’t identified. Sometimes even well into the project, you don’t know what
resource you’ll be using; you know only that you need a resource with a cer-
tain skill set to complete upcoming tasks. In that case, you might be better
off creating some generic resources.

If you want to create a generic resource, you should give it a name that
describes its skill, such as Engineer, or Designer, or even Meeting Space

(as opposed to a specific resource named Conference Room B). Then, in the
Resource Information dialog box, be sure to select the Generic check box.

You can display a column titled Group to identify these resources (see
Figure 1-5). You can then create a resource filter to find resources with a
Generic entry in the Group column when it’s time to update these resources
with more specific information.

saaunosay bunealy
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Figure 1-5:
Identifying
generic
resources in
your project.

No formula takes the Generic setting into account in recalculating your sched-
ule based on resource availability. However, many people find this setting
useful in long-range planning and in situations where they aren’t responsible
for specific resource assignments (for example, if you have to assign a tem-
porary worker to a task when the specific individual will be chosen by the
temp agency).

Resources that work in groups

Although you probably have little use for a chain gang in your project, it
exemplifies the principle of a resource that represents multiple resources.
Rather than assigning people one by one to some tasks, you want to assign a
group of people who typically work together. Being able to make one assign-
ment of a consolidated resource rather than several separate resources and
assignments can be a timesaver in larger projects.

Here’s an example of a consolidated resource: Suppose that you're managing
a project to get a new office site up and running. You have four office planners
of equal skill at your disposal, so you create a resource named Office Planners.
You can assign Office Planners to a task at 400 percent (see Figure 1-6) and

have all four planners working at once. Or you can assign the Office Planners
resource to work on a task at 100 percent, thereby assigning one resource to it.
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Resource Information
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See Chapter 3 in this minibook for making resource assignments such as
the 400 percent maximum units assignment mentioned in the preceding
example.

There is no special setting to designate a multiple resource: However, you
might want to include some indication of the number of resources in the
resource name. For example, you could name your planner resource Four
Office Planners (if you know the office planner group consists of four people)
or Office Planner Group. What really defines this type of resource is the maxi-
mum assignment units; 400 percent would indicate four resources in the
group each working 100 percent of the time.

Resource management: An art, not a science

When you start creating resources, you almost
immediately have to start managing them.
Here's the nickel tour of the art of managing the
people who will make your project happen.

Conflict resolutionis a necessary skill for project
managers. It involves creating an environment
of cooperation and respect, building consensus
(agreement) among team members, and encour-
aging honest communication.

As a project manager, you can set up well-
designed communications tools (such as frequent
status meetings or reports) so people stay in
touch throughout your project. You can also make
a point of staying alert to conflict — and nipping
itinthe bud. (A conflictignored only festers and
becomes something worse.) Try to keep the focus
of any project discussions on the project goal,
and not on personalities. See Book I, Chapter 1
for more about project management concepts.

saaunosay bunealy
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In Book VI, Chapters 3 and 4, we tell you all about designing and generating
reports in Project that help you keep your resources informed. Book X also
offers some ways to help resources communicate clearly with each other in an
online enterprise environment, which can help you avoid misunderstandings.



Chapter 2: Understanding Costs

In This Chapter

v+ Understanding how costs accrue
v~ Establishing Work resource rates
v Specifying unit costs

+ Adding fixed costs

1~ Allowing for overtime

1~ Estimating resource availability

Fese days, not much in life is free — and if you use Project to track
costs, there’s no such thing as a free resource. That’s because Project
uses resources assigned to tasks as a way of calculating most of the costs
accruing to your project.

When you create a resource, you specify a Work resource rate (by default,
this rate is tallied up per hour) or a per-use cost for a Material resource.
You can also create Cost resources; that is, a set cost that you can apply to
a task that isn’t calculated using a per-use or hourly rate. An example of a
Cost resource is a fee for your trade show booth.

Other factors can come into play in determining your project costs, such as
how many hours a day a resource is available to work and overtime rates.
As you tally your bottom line, all these settings come together to put you
over or under budget.

In this chapter, you explore the relationship between resources and costs.
You find out how to set resource standard and overtime rates, create fixed
costs, and set the availability of resources on individual tasks in your project.

Accruing Costs All Over the Place

Project helps you to account for costs on your various tasks with a combi-
nation of costs per hour, costs per unit, and fixed costs. Before you begin to
assign cost information to your resources, it’s important to understand how
these cost calculations work.
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Tallying costs

The best way to understand how costs add up in your project is to look at an
example. Jane Doe (that’s not her real name) is managing a project involving
the building of a new candy-packaging plant. Jane has created a task called
Install Candy Mixers. Here are the costs Jane anticipates for that task and
how they add up:

4+ About ten person-hours of effort to do the installation

The ten hours of effort will be expended by Work resources. The total
cost for the ten hours is a calculation: 10 x the resource rate. If the
resource rate is $20, this cost totals $200. If two resources work on the
task, one at a rate of $20 and one at a rate of $30, then (by default)
Project splits the ten hours of effort between them, and the resulting
cost is $250.

4+ A fixed cost of $500 paid to the mixer manufacturer to oversee the
installation and train workers on the machine

The fixed cost of $500 for a fee to the manufacturer is created as a Cost
resource. When you assign this resource to a task, you enter a cost for
that resource on that task. This cost won’t change based on the number
of resources or the time involved.

4+ Twenty pounds of ingredients to test the mixers

The cost for 20 pounds of sugar for the test candy is calculated as 20 x
the unit cost of the ingredients. If the unit cost is $2, this cost is $40.

And that’s how costs are assigned and how they add up on your projects.

Not all resources have associated costs. For example, if you want your vice
president (VP) to review status reports on your project but your company
doesn’t require that the VP’s time be charged to your project, you can
simply use her resource assignment to remind you about the need for the
VP’s availability on a particular day or week.

Your project has two main perspectives on your budget: one perspective

at the moment you freeze your original plan (a baseline plan) and one
perspective of the ongoing picture of actual costs that comes from the
activity and material usage you record as your project moves along.

You record a certain amount of work effort on tasks, and tasks with
resources assigned to them then run up costs based on the effort expended
or units of materials used.

The sound of costs hitting the bottom line

Wouldn't it be nice if you could choose when all your costs hit your pocket
book? Well, in Project, you can choose when your costs hit your budget.
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You can set up resources to accrue costs at the start or end of the task that
they’re associated with or to be prorated throughout the life of the task.

So, if a three-month-long task begins April 1, a $90 Cost resource could be
added to your actual costs to date on day 1, on day 90, or at $1 per day until
the end of the task.

Now, this isn’t exactly a realistic reflection of when you have to pay for
costs, because most bills come due 30-60 days after they arrive, long after
the task is finished. It's more a factor of when you want that cost to show up
for the purposes of tracking costs and reporting expenses on your project.

Assigning Costs to Resources
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You have to do your homework before you can assign resources to tasks.
Most projects involve a combination of the three cost types: Cost, Work, and
Material. That means that you have to find out the fixed costs as well as the
hourly or unit rates for all your resources.

In the early stages of your project planning, you might not be able to find out
exactly what a particular cost will be or know every resource’s rates. If you
have to, build the resource or fixed cost with your best estimate. That way,
at least some cost will be reflected in your plan, and you can go back to
enter more accurate information as soon as you know it. Don’t worry;
Project updates everything when you enter a change.

Use a field in your Resource Sheet, such as Code, to designate resources for
whom you have estimated rates or costs. Then apply a filter or display the
column so you can easily go back to those tasks and update the estimates as
your plan progresses.

Fived costs you can count on

Maybe you have to pay a huge fee to a design company to redesign your
product logo, including all your collateral marketing materials. Or perhaps
you have to buy yourself a $2,000 laptop so you can manage your oil explo-
ration project with three drilling sites in different states when you’re on the
road. Whatever it is, it’s a cost that won’t change no matter how many hours
the task goes on or how many people work on the task. It has no unit cost or
rate per hour. It’s a fixed cost.

You can specify fixed costs by creating a resource with a Cost type. Every time
you assign the resource to a task, you specify the cost associated with it.

You can also simply enter a fixed cost associated with a task without having
to create and assign a Cost resource to it. To do so, you can use the Cost
Table in any view with a spreadsheet pane, such as Gantt Chart view.

Book V
Chapter 2
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MBER
4.3“ Tables are preset column combinations that make entering certain informa-

tion in a sheet pane easier. See Book VI, Chapter 2 for more about customiz-
ing tables.

Follow these steps to view the Cost Table and enter a fixed cost for a task:

1. Display the project in Gantt Chart view (click Gantt Chart in the
View bar).

2. Choose ViewroTabler>Cost.
The table of columns appears, as shown in Figure 2-1.

3. Click the Fixed Cost column for the task to which you want to assign
the cost and then enter the amount.

Cost Table
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You can enter only one fixed-cost amount for a task by using the Fixed Cost
column. You can total your fixed costs and enter that number here, but in
that case, you should also enter a task note where you can itemize fixed
costs if you have more than one. The option if you have a lot of fixed costs is
creating fixed Cost resources and assigning them to the task one by one.

Note also that the default fixed-cost accrual method is prorated. If you prefer
to have your fixed costs hit your budget at the start or end of a task, use the
Fixed Cost Accrual column in this table to select another option.

Paying per hour

Whether a resource gets minimum wage or charges a hefty billable hourly
rate every time you make a phone call, most people get paid something per
hour. To represent most people involved in your project, you create Work
resources and charge them to your project with a specific hourly rate.

After you set a resource hourly rate and enter an estimate of how many
hours that person will work on each task that he’s assigned to, Project totals
the cost of using that resource on your project. These estimates form the
budget for your project in the planning stage.

When you track actual effort expended on tasks, a calculation of actual
effort x the hourly rate returns your actual costs.

By comparing estimated costs and actual costs, you get an ongoing picture
of whether your project is financially on track. See Book VIII for more about
tracking costs in a project.

To set resource rates per hour, follow these steps:
1. Display Resource Sheet view by clicking the Resource Sheet item in

the View bar (see Figure 2-2).

2. Click the Std. Rate column for the resource to which you want to
assign a cost.

3. Type a dollar amount.

If you're entering a rate for a unit other than hours, type a slash (/) and
then the unit (for example, minute or month).

4. Press Enter.

The entry is saved.

Book V
Chapter 2
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Figure 2-2:
Entering a
resource
rate in
Resource
Sheet view.
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Setting alternative rates

Note that you can also make cost-rate entries in the Resource Information
dialog box (to get to this dialog box display a view with a Resource Name
column such as Resource Sheet view and double-click the resource name).
The Costs tab of this dialog box, which is shown in Figure 2-3, offers a
Standard Rate, an Overtime Rate, and a Per Use Cost.

Even more options for setting rates are available in the Resource Information
dialog box; five tabs labeled A through E allow you to enter several different
rates for any resource during different time periods of your project. Tab A is
the default rate, but by using the Effective Date column in the other tabs to
specify the start date of a new rate, a resource could work for several
months at one rate and then start working at a different rate on a preset
date. This helps you account for periodic raises or seasonal shifts in rates
(for example, paying a premium for construction resources in months with
better weather when they are more in demand).



Figure 2-3:
You can set
several
rates for a
resource.
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Resource Information ==
General Costs Notes Custom Fields
Resource Name: | Gerald Peterson |
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The cost-per-use scenatio

Project allows you to enter a cost per use. With a cost-per-use scenario you
assign a cost for a single unit (per yard, ton, or gallon, for example), and
assign so many units to each task. Project calculates the cost based on the
number of units x the cost per use.

Technically speaking, you can have a cost per use for either a Work or
Material resource. You could, for example, have a consultant who costs $500
per use (that is, each time you use her to consult on a task, you get hit with a
$500 fee). More commonly, you use a cost per use for a Material resource
such as steel or sugar.

To assign a cost per use, follow these steps:

1. Display Resource Sheet view.

2. Click the Cost/Use column for the resource you want to set and then
type an amount for the per-use cost.

3. Click the Material Label column for that resource and then type a unit
name (such as Tons, as shown in Figure 2-4).

4. Press Enter to accept your entry.

Book V
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Figure 2-4:
Entering a
cost per use.
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Note that you can use the Resource Information dialog box to enter up to
five per-use costs with effective dates. You might do this to deal with fluctua-
tions in unit cost because of inflation or seasonal variations over the life of
your project.

Oops . . . you're into overtime!

Overtime is a fact of working life for many people: It can be helpful for those
who earn it but hard on the project manager paying and tracking it. If you
have resources that shift into time and a half after so many working hours,
Project makes it easy for you to enter an overtime rate for them. With the
rate in place, overtime automatically kicks in when that resource’s calendar
indicates that her regular day is over but her task assignment still has her
working.

For example, a resource with a standard eight-hour-day calendar who puts
in ten hours on a one-day task is charged by Project with eight hours at the
standard rate and two hours at the overtime rate.
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To enter an overtime rate for a resource, follow this procedure: Book V
Chapter 2
1. Display Resource Sheet view.

2. Click the Ovt. Rate column for the resource.
3. Type an amount (see Figure 2-5).

4. Press Enter.
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The entry is saved.
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Chapter 3: Assigning
Resources to Tasks

In This Chapter

v Locating just the right resource

1 Assigning resources to tasks

1 Choosing the percentage of availability
v~ Applying a contour setting

v Creating a resource pool

v+ Modifying resource working time

1+ Communicating assignments to your team

5) you've created dozens of resources available to work on your project.
Now you must find the right resources for each task and assign them.
It’s important that you understand how to make those assignments and how
they affect the timing of tasks and ultimately your entire project.

Sometimes you need to finesse resource assignments to make them work.
For example, you might find that assigning resources as groups rather than
one by one saves you time. In other cases, you might want to tell Project
when resources put in different amounts of effort over the life of a task to
avoid resource overallocations. Finally, you might need to modify the time
that a resource puts in on any task.

In this chapter, you discover the vagaries of assigning resources to tasks,
and even how to let your resources know their assignments.

Locating the Right Resource for the Job

If you were coaching a basketball team, you probably wouldn’t bring in just
anybody in the fourth quarter with one minute to go to sink the winning
basket. It has to be Reggie or nobody. In projects, sometimes the same prin-
ciple is true, and you have to have a specific person for a task.

However, if just about anybody with a certain skill level (or a certain rate
per hour or the availability) will work, you can use Project features to find
the right resource and make sure he or she has enough time to take on just
one more task.
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Figure 3-1:
Searching
combines
looking for
some ele-
mentina
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field that
meets a
certain
criterion.

Finding resources

You've probably used the Find feature in other software to find a word or
phrase or number. Project’s Find feature is all that plus a bag of potato chips.
After all, Project’s Find feature can find you anything from a corporate jet to
a person.

You can use Project’s Find feature to look for resources with a wide variety of
criteria. You might search for resources who are assigned certain pay rates
or who come from a particular workgroup. You can search for resources by
their initials, their maximum assignment units, their standard or overtime
rate, and so on.

For example, you might need to find a resource whose standard rate is less
than $50. Or you might want to find someone who can put in extra hours on
a task, so you search for any resource whose maximum units are greater than
100 percent. (In other words, the resource can put in a longer-than-usual day
before he or she is considered overallocated.)

Perhaps you need to find a Material resource that consists of a metal alloy
measured in tons, but you can’t remember the exact name of the alloy. In that
case, you can search for resources whose material label includes the word
tons and locate the resource you need.

To use the Find feature with resources, first display any resource view and
then follow these steps to find resources in Project:
1. Choose Edit-=>Find.
The Find dialog box appears, as shown in Figure 3-1.
2. In the Find What text box, type the text you want to find.

For example, type 50 if you want to search for a resource with a stan-
dard rate of $50, or laboratory if you want to find a resource whose
material label contains that word.

Find e |
Find yihat: | Accountant
Look in feld: E-|' Teso -\.-DI"THIHS_ E E

Search:

I Find Mext | | Replaces | || Close |
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. From the Look in Field drop-down list, select the name of the field you

want to search in.

For example, to search for resources that have a maximum unit assignment
percentage of more than 100 percent, choose the Max Units field here.

. From the Test drop-down list, select a criterion.

For maximum units of more than 100 percent, for example, this choice
would be Is Greater Than. There are a total of eleven criteria, such as
contains, equals, is less than, is within, and does not contain.

. (Optional) If you prefer to search backward from your current location

(that is, the currently selected cell in the task list) instead of forward,
select Up from the Search drop-down list.

6. (Optional) If you want to match the case of the text, select the Match

Case check box.

7. To begin the search, click Find Next.

8. Continue to click Find Next until you find the instance you're

looking for.

You can also use the Find feature to find and replace an entry. For example, if
your Human Resources department (HR) changes its name to Human Capital
Management (HCM), you can take these steps:

1.
2.

Search the Group field for the code HR.

In the Replace dialog box that appears, click the Replace button, and
type the letters HCM, as shown in Figure 3-2.

3. Click the Replace button to replace each instance one by one or click
the Replace All button to replace every instance of that entry in that
field, wherever it occurs in your project.

Replace ==

Find tihat: HR - - i

Replace with: L= - )

Laakin field: Gap =] Test: |contars |

Searchs [pown  [w] TMatch case

| Replace | | Replceal | [ Endvext | | Close
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Creating custom fields

When you assign resources to tasks, it’s often important to take a person’s
skill set into account. If you absolutely have to have someone who can

type 110 words a minute, it would be handy to have a way to locate such a
keyboard wizard. If a person with less skill or experience could work on a
particular task (and save you money because he or she has a lower rate per
hour), wouldn't it be nice to be able to find such resources easily?

Project doesn’t include a Skill field, but it does allow you to add fields of
your own called custom fields. After you create them, you can use these
fields for anything, but one great way to use them is to code your resources
by skill level. You can use a rating system such as A, B, and C, or use terms
such as Exp for an experienced worker and Beg for a beginning-level worker.

Consider using custom fields for information about tasks, as well. You can
create a field to identify tasks that require your boss’s input, tasks that
involve another department’s approval, or tasks that have to have their
results reviewed by your legal department, for example.

Here’s how to add a custom field:

1. Choose Tools->Customizer>Fields.

2. Click a field name.

3. Click Rename.

4. In the Rename Field dialog box, type a name for the field.
5. Click OK twice to save the change.

You can now go to any view with a sheet pane, right-click the column head-
ings, and choose Insert Column. In the Column Definition dialog box that
appears, choose the newly named field and click OK to display it.

After you create a custom field, you can enter whatever you like in this
column for each resource in your project. Then you can search for specific
entries in that field by using the Find feature, or you can turn on a filter to
display only resources with a certain skill level in that field. (Read more
about filters in Book VII, Chapter 1.)

Some organizations designate enterprise-wide custom fields for certain com-
pany information such as an accounting code or a vendor rating. If you have
a project administrator who’s in charge of these enterprise-wide standards,
check with him or her before you choose to modify a locally saved custom
text field.
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Acquiring the right resources Bookv
If you find the right resources for your tasks, the task of resource manage- apret
ment becomes much easier. But how do you know who will work best on a
given task?

What makes a good resource choice is a combination of factors. The right
resource for a task is somebody who has
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Bulubissy

4+ The right skills for the task at hand (or who is trainable, if training is
included in your budget)

4+ Enough time available to complete the task according to your schedule

4+ The ability to commit to the project (which sometimes involves getting
not only the resources but also their manager’s buy-in)

4+ A cost that fits in your budget

Although the preceding list covers some basics, it’s important that you con-
sider other details, such as whether the resource is set up to communicate
with the project team and whether the technology to communicate and
share documents is available (see Book X for more about this). Also, give
some thought to how well each resource you choose will work as part of the
team and whether the resource is considered dependable.

In Project, you have several ways to flag and find resources, categorizing
them by skill or other criteria:

4 Use the Resource Notes area to record information about a resource’s
skills and abilities. Then use the Find feature to search note fields for
words such as highly skilled, dependable, and trainable.

4+ Use the Code field in the Resource Information dialog box to rank
resources by skill, cost, or ability to work well with others.

4+ Create Custom Fields for resources to note specific skills and search for
resources by those skills.

SMBER
SO Sometimes it’s worthwhile to consider using a less experienced, cheaper
resource to save money. However, if you do, just be sure to factor in the time

and money needed to train or mentor that resource.

Keeping resource workload balanced

Another important part of resource management is managing the assignment
of resources so that nobody is excessively overbooked. Although occasional
overtime is expected of most workers, constant overtime causes people to
burn out and work to suffer.
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Figure 3-3:
Resource
Graph view
shows
resource
assignments
and helps
you see
problem
times in
your project.

Also keep in mind that a less skilled worker takes longer to perform a task
than a skilled worker. Take that into account when scheduling the time a
resource might need to complete his or her work.

The following techniques can help you stay aware of resource workload
when working with Project:

<+

<+
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Keep an eye on your Project plan. Various tools such as Resource Graph
view (as shown in Figure 3-3) allow you to spot overbooking on tasks.

Track the workload of individual resources. When tracking activity on
tasks, you will receive an account from resources (see Book VIII for infor-
mation on tracking) about the actual time they’re spending on tasks.
Notice the people who have to constantly put in overtime to keep their
heads above water, and keep an eye on those who are falling behind.

Talk to people. That’s right. This isn’t a feature of Project, so stop look-
ing for the Talk to People button. It’s an old-fashioned communications
device that works amazingly well. Check in with resources often and ask
whether things are going well — and don’t forget to ask whether your
human resources are running on empty. Then help those who are over-
worked by modifying your schedule or adding other resources to help.

[N —
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After you've located the right resources, assigning resources to tasks is just
the software equivalent of filling out paperwork. However, it’s useful to
understand a few things before you begin making assignments.

First, it’s important that you understand how resource assignments affect
task timing. That knowledge helps you to understand how to handle assign-
ment units, which differ slightly between Work resources and Material
resources.

Finally, you can use a couple of methods to assign resources to tasks.

Of course, you have to create resources before you can assign them, so
make sure you've covered that by reading Chapter 1 of this minibook.

How resources affect task timing

For a fixed-unit or fixed-work task type, the addition or removal of resources
assigned to the task has an impact on the time it takes to complete the task.
In essence, the old saying that “two heads are better than one” might be
modified to “two heads are faster than one.”

Here’s an example: Suppose that one person is assigned to the Clean Up
task, which should take four hours of effort. Two people assigned to the
Clean Up task will finish the job in two hours because two hours are being
worked by each resource simultaneously, which achieves four hours of effort
in half the time.

One big word of warning here: Assigning additional people to tasks doesn’t
always cut work time down proportionately even though that’s how Project
calculates it. When you have more people, you have more meetings, more
memos, some duplicated effort, personality conflicts, and so on. If you

add more resources to a task, you might consider upping the amount of
effort required to complete that task to account for inevitable workgroup
inefficiencies.

Determining Work, Matevial, and
Cost resource assignment units

You assign Work resources, which are typically people, to a task by using a
percentage: for example, 100 percent, 50 percent, or 150 percent. When you
assign a resource at a percentage, the assignment is based on the Resource
calendar.

Book V
Chapter 3
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A resource with a Standard calendar will put in eight hours a day if you assign
it at 100 percent assignment units. Theoretically, a resource with a 24-hour
calendar will work a grueling 24 hours a day at 100 percent (and quit the
next day) or 12 hours at 50 percent. (If such a resource were not a human
but a machine in your plant, such an assignment might work just fine.)

A Material resource is assigned in units such as gallons, consulting sessions,
yards, or tons. When you assign a Material resource to a task, you designate
how many units of that resource will go to that task.

Note that Work resource units are part of the entire work-unit-duration calcu-
lation that can cause Work resource assignments to change task durations.

A Cost resource is one that incurs a certain cost every time you assign it. For
example, if you create a Cost resource called Permit Fee and assign a cost of
$100, every time you assign a permit fee to a task, it is assigned at $100.

Making assignments

You have four ways to make resource assignments in Project. You can select
resources from the Resources tab of the Task Information dialog box, enter
resource information in the Resource column in the Entry table (displayed in
Gantt Chart view), split the window and use the Resources and Predecessors
form in a pane, or use the Assign Resources dialog box.

Which method you use depends to some extent on your own preferences,
but generally speaking, here are some parameters for using each:

4+ Use the Resource Column to assign a default 100 percent assignment.
If you want to assign a different percentage, don’t use this method.

4+ Use the Assign Resources dialog box if you want to replace one resource
with another (a handy Replace feature is available in this dialog box) or
if you want to filter the list of available resources by a criterion (for exam-
ple, resources with a rate or unit cost of less than a specified amount).
This dialog box is very useful for making multiple resource assignments.

4+ Work in the Task Information dialog box if you want to have task details
(such as task type or the constraints contained on other tabs of this
dialog box) handy when you make assignments.

Choosing resources in the Resource column

You can add resources in a Resource column, whether you access it from
Gantt Chart view or Tracking Gantt view. (See Book I, Chapter 4 for informa-
tion about displaying additional columns or tables of columns in views.)
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Figure 3-4:
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1. Display Gantt Chart view by clicking it on the View bar.
2. Choose Viewr>Table>Entry.

Vour Assignment Is . . .

Follow these steps to assign resources at a default percentage:

307

Even though it lists tasks in its sheet pane and can even display a Resource
column, you can’t use Task Usage view to add resource assignments.

3. Click in the Resource Names column for the task on which you want

to make a resource assignment.

An arrow appears at the end of the cell.

4. Click the arrow to display a list of resources.

5. Click the resource you want to assign.

The resource name appears in the Resource column, assigned at

100 percent.

1. Click a task to select it.
2. Click the Assign Resources button on the Standard toolbar.

The Assign Resources dialog box appears, as shown in Figure 3-4.

Using the Assign Resources dialog box
To assign a Work or Material resource to a task, you can select a task and
then use the Assign Resources dialog box to make assignments. To do so,
follow these steps:

Assign Resources

Task: Research the market and competitian
|:| Resource fist oplions

Resources from New Business

Banker

Resource Name Units Cost
¥ Business Adyisor 100% 50,00

Accountant

Eanker

Government Agency

Information Services

Lawyer

Manager

Owniers

Peers

Hold down Ctrl and dick to select multiple resources

You can create assignments at the default level and then change the assign-
ment units later by opening the Task Information dialog box and making the
change on the Resources tab.

Book V
Chapter 3

$)se] 0) Sa2IN0Say
Bulubissy



308 Vour Assignment Is . . .

\\3

3. Click a resource to select it and then click the Assign button.

A check mark appears next to the assigned resource in the Resource
Name column.

4. Click the Units column for the resource you just assigned.

If it’s a Work resource, the default assignment of 100% appears. If it’s a
Material resource, the default is one unit.

5. Specify a percentage of assignment units for the resource.

Click the spinner arrows in the box to increase or decrease the setting.
For a Work resource, change the percentage units in 50-percent incre-
ments by clicking the arrows; or, you can simply type a percentage. For a
Material resource, use the spinner arrows in the Units column to increase
or decrease the unit assignment; or, you can type a number of units.

6. Repeat Steps 3-5 to add all resources.

7. (Optional) If you want to replace one resource with another, click an
assigned resource (indicated with a check mark), click Replace, select
another name on the list, set its units, and click OK.

8. Click Close to save all the assignments.
You can also open the Assign Resources dialog box from the Resource
Management toolbar. This toolbar offers handy tools for adding resources

to your project, from sources such as your Outlook Address Book, and tools
for managing overallocated resources.

Adding assignments in the Task Information dialog box
You can assign resources on the Resources tab of any Task Information

dialog box by following these steps:
1. Double-click a task name in Gantt Chart view.
The Task Information dialog box appears.
2. Click the Resources tab to display it.

3. Click in a blank Resource Name box and then click the arrow that
appears at the right side of the box.

A drop-down list of resources appears.

4. Click the resource you want to assign.
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5. Click the Units column and use the spinner arrows to set an assign-
ment percentage.

6. Repeat Steps 3-5 to assign additional resources.

7. Click OK.

If you're assigning a Material resource, the Units default is a single unit. (For
example, if your units are pounds, the default assignment is 1 1b.) Use the
spinner arrows in the Unit field to assign additional material units.

Contours set the level of work

When you make a Work resource assignment, Project spreads the work evenly
over the life of the task. Even if work effort isn’t identical every single day, if
it averages out across the life of the task, this default setting is probably fine.

However, there are times, especially on longer tasks, that it’s useful to spec-
ify that more work goes on at some point in the task. This can help you free
up resources that have a conflict with another task, for example.

To deal with a variable workload, you can modify the level of work that goes
on during the life of the task — called a work contour — so that more work
takes place near the beginning, middle, or end of the task.

Look at an example: Suppose that you know that the people assigned to set
up a new enterprise-computing database will have to spend some time up
front studying the software manuals and customizing templates before they
can begin to make measurable progress on the task. In this case, you might
use a late-peaking contour. Or, if you know that people are likely to put in a
lot of work up front on a survey and then sit back and wait for the results to
come in, you might choose an early peaking contour.

Using a different contour on a particular resource’s task assignment could
free up that resource to work on a second task that occurs during the life of
the first task. This can help you resolve a resource conflict.

The contour you select will have slightly different effects depending on the
task type, some of which can throw your schedule entirely out of whack.
This is a complex equation not worth your while to try to analyze. My advice
is to simply try a different contour and see whether it solves your problem
and doesn’t make too dramatic a change to your task duration or other
resource assignments.
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To set a task’s contour, follow these steps:

1. Display Task Usage view.
This view shows resource assignments by task.
2. Double-click a resource.

The Assignment Information dialog box appears, as shown in Figure 3-5.

Assi Information
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resource
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3. From the Work Contour drop-down list, select one of the preset
patterns.
The default choice is Flat, with work spread out evenly throughout the
task. Other options include the self-explanatory Backloaded and
Frontloaded; Early Peak and Late Peak with spike of work in the first or
last half of the project, respectively; Double Peak, which ups the work-
load twice over the life of the task; and the Bell and Turtle Curves, which
you can visualize by thinking of their namesakes.
4. Click OK to save the setting.
A symbol for the contour pattern is displayed in the Indicator field for
the resource.
P If none of the contour patterns fits your situation, you can manually

modify a resource’s work. You do this by changing the number of hours
the resource puts in day by day on a task in Task Usage view. Remember
that if you do this painstaking manual work to deal with resource avail-
ability, if tasks shift timing you may have to undo all this and redo it all
over again.

Before you save a contour setting, make sure your modifications add up to
the number of hours you want the resource to work, or you could inadver-
tently change the resource’s assignment.



Making Sure of Availability 311

P Resource Allocation view is useful for reviewing resource assignments at Book V
this stage. This view provides a side-by-side comparison between a single Chapter 3
resource’s workload and all the tasks going on during a particular time
period in your project.

Making Sure of Availability

By default, a resource is assigned to a task at 100 percent availability, but you
can modify that if you know a resource will be assigned to several tasks and
is likely to put in only part of that person’s time over the course of a task.
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How you assign availability is important to managing your resources suc-
cessfully. Consider that many Project features that deal with resources help
you to spot resource overallocation. Ouverallocation is a calculation involving
the resource’s calendar and availability that tells you when a resource is
overbooked on one or more tasks.

Here’s an example: Charlie Ruiz is a graphic designer who works a standard,
eight-hour day based on his calendar. Charlie is assigned to the Create Design
Budget task at 50 percent of his availability and to the Create Design Specs
task — which occurs at the same time as the budget task — at 100 percent
of his availability. Charlie is now working at 150 percent of his availability, or
12 hours per day. Charlie is definitely overallocated, and one way to solve
that is to make sure you've dealt with availability correctly.

Setting availability

Availability is easier to estimate for some resources than for others. A man-
ager isn’t likely to give an entire day over to any single task because he has
to deal with all the people who report to him, or he has to sign authorizations,
go to meetings concerning various projects, work on budgets, and so on.
With a production worker, it might be simpler to pin down availability to a
single task: If one manufacturing job is going through the line for three days
and one person is working on the line all that time, it’s closer to the mark to
say that he or she is working on that task full-time.

One big mistake that new users of Project make is to microthink availability.
Of course, no one actually spends eight hours every day on a single task in
one project. People spend part of their days reading e-mail about company
holidays, chatting with co-workers, and blogging about their latest vacations.
A resource might spend seven hours on a task one day but only three the
next. Don’t get hung up on a day-by-day resource schedule in estimating
availability. If over the life of a task the person is pretty much devoted to it,
100 percent availability is a good setting. If that person puts in only, say, five
days of work on a ten-day task, that’s 50 percent availability whether she
works four hours per day for ten days or five full days at any point.
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<« The Availability setting exists to help you spot overbooking of a resource
who might work on multiple tasks at the same time in a project schedule.
To set resource availability, follow these steps:
1. Display Resource Sheet view.
2. Double-click a resource.
The General tab of the Resource Information dialog box appears, as
shown in Figure 3-6.
Resource Information
General Costs Notes Custom Fields
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4/af2007 3/31/2007 - [ 50%
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3. In the Units column (in the Resource Availability area), either click
the arrows to raise or lower the availability in 50-percent increments
or type a number.
The most common entry here (the default entry) is 100% for a single
resource working full-time on the task.
4. Click OK to save the setting.
\\J

Here’s an example of how you might use the Units column for assignments;
type 33 for a resource available one-third of the time, or 400% for a pool of
four resources all available full-time.

When resources appear and disappear

In addition to being available only a certain percentage of the time on any
task or project, a resource might be available for only a certain period of
time during the life of the task or project.
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On the other hand, you might have a resource that’s available half-time for
the first few days of the project and then full-time for the rest of the project.

In either case, you can enter a date range in the Available From and Available
To columns of the Resource Availability area in the Resource Information
dialog box (refer to Figure 3-6) to specify the variations in the resource’s
availability.

Sharing Resources

gMBER
>

Most organizations have several projects going on simultaneously. Sometimes
a project, such as managing company acquisitions, is the only project of its
type happening in a company. Others, such as setting up PR campaigns in

an advertising company, will happen at the same time as several other
similar projects and draw on many of the same resources, such as market
researchers and copywriters.

If your organization has projects of a similar nature going on at the same time,
creating centralized resources is useful. This can save you time because you
don’t have to create resources again and again for each project. It can also
help you to track resources across projects.

You can also pull existing resources from a company address book or your
own Address Book in Outlook. See Book IX, Chapter 4 for information about
importing information into Project.

This collection of enterprise resources is called a resource pool. By using a
resource pool, you can save everybody the time of re-creating the same
resources again and again.

Don’t confuse a resource pool with enterprise resources, which require that
you have Project 2007 Professional, Project Server 2007, and Microsoft Office
Project Web Access set up. With all this in place (see Book X for more about
enterprise projects), you can track and assign resources across an entire
enterprise. A resource pool, on the other hand, is simply a list of resources,
saved on your company server, that several people can assign to projects.

A resource pool saves everybody the trouble of creating these resources
again and again in their individual projects.

Both individual and consolidated resources can be created in a blank project
as a resource pool and saved to an accessible location on your company
server. Then any project manager can call on those resources for his or her
own projects; those projects are then referred to as sharer files because they
share resources with the resource pool. For example, if you have a pool of
maintenance people that everyone in your manufacturing company assigns

Book V
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Figure 3-7:
When many
people pull
on the same
resources in
a company,
sharing
resources
becomes a
good idea.

to projects, create a project called Resource Pools and then create all your
enterprise resources in this project. Or you could create a resource called CEO
and let all the people managing projects that require the CEO’s involvement
assign him or her from that central location. Then use the resource-sharing
tools in Project to assign these resources to your plan.

When anyone makes resource assignments in a sharer file, that information
is also saved in the resource pool file. Then anyone can use that file to look
at resource allocations across all projects in the organization.

To access a resource that’s available to your entire organization, follow this
procedure:

1. Choose Tools>Resource Sharing=>Share Resources.

The Share Resources dialog box appears, as shown in Figure 3-7.

Share Resources
Resources for 'C:\, . \Project plan for mew business.mpt’
'@ Lisz gWn resources
Lise resources
Erom: -E)lrgc_t_h'larkg_hn_g Program El
Qn confilct with calendar or resource mformation
@ Pool takes precedence
Sharer takes precedence

[ el | Foe | | cansel

2. Specify the resources for the project.

If you want to specify that a project will use only its own resources

(the default), select the Use Own Resources option. If you want to share
resources, select the Use Resources option and then choose a project in
the From list.

3. Specify what Project should do when a conflicting resource setting,
such as a different calendar setting in the shared resources and your
project, exists.

If your project’s setting should take precedence, select the Sharer Takes
Precedence option. If you want the pool setting to rule, select Pool Takes
Precedence.

4. Click OK to complete the process.

All resources in the specified resource pool are added to your own pro-
ject’s resource list, ready to be assigned to tasks.
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After you add a shared resource to your project, you should periodically
update shared resource information. You want to do this in case the person
who maintains those shared resources has made a change, such as upping
the resource’s rate per hour. To do this, choose Tools=>Resource Sharing=
Refresh Resource Pool.

If you combine separate projects into one master project at any point,
Project allows you to have duplicate resources. But be careful: If you link the
combined projects and then delete a duplicate resource in the master proj-
ect, it’s deleted in the subproject, as well.

If you share resources across an enterprise, see Book X, Chapter 2 for more
about how to set these up.

When Do My Resources Work?

\NG/
&

In Book II, Chapter 4, we cover calendars, including Project, Task, and Resource
calendars. Now that you're in the thick of working with resources, take a
closer look at how Resource calendars work.

First, be aware that Resource calendar settings take precedence over your
Project and Task calendar settings. You create your Resource calendar based
on a base calendar template that can be Standard, Night Shift, or 24 Hours.
(You can also create custom calendars.)

4+ Standard is a typical 9-to-5 workday and five-day workweek.

4+ Night Shift is an eight-hour workday, scheduled between 11 p.m. and
8 a.m., with an hour off for a meal, from Monday through Friday.

4+ The 24 Hours base calendar shows just what it says: 24 hours per day, 7
days per week.

After you specify a base template for your Resource calendar, you can specify
working hours, such as 9 a.m. to 12 p.m. and 1 p.m. to 5 p.m. for a standard
eight-hour day, or 8 a.m. to 12 p.m. and 1 p.m. to 4 p.m. for a variation on
that eight-hour day. Finally, you can select specific days when a resource
isn’t available (for example, when someone will be on vacation, at an offsite
conference, or busy on another project) and mark him or her as nonworking.

Avoid micromanaging nonworking time for your resources because that
could drive you crazy. For example, if someone is taking off half a day to go
to the dentist, it’s probably not necessary to set that half day as nonworking,
because you figure the resource will make up the time on the task overall.
However, if a resource is taking a two-week vacation or a three-month sab-
batical, it’s probably a good idea to modify that resource’s Working Time
calendar.

Book V
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Figure 3-8:
The legend
on the left
explains
how non-
working and
working
days appear.

To make changes to the Resource calendar and available working times, you
can click the Change Working Time button on the General tab of the Resource
Information dialog box. The Change Working Time dialog box opens (see
Figure 3-8).
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To make changes to a resource’s calendar, follow these steps:

1. Display the Resource Sheet.

2. Double-click a resource name.
The Resource Information dialog box appears.

3. Click the Change Working Time button on the General tab.
The Change Working Time dialog box opens.

4. In the Base Calendar box, select a base calendar.

5. If there will be an exception to the default base calendar hours, enter
the Name, Start, and Finish for the exception on the Exceptions tab.
Then click the Details button.

The Details for Exception’ dialog box opens (see Figure 3-9).
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6. Select a day. Then click in the From and To boxes and type new times.
Note that to build in a break or lunch hour, you must enter two sets of
numbers.
7. Click OK when you’re finished and then click OK twice more to close
the remaining dialog boxes.
<® To change a day to nonworking time, select it in the Change Working Times

dialog box and click the Details button. Click the Set Day(s) to These Specific
Working Times radio button and then clear any working times from the From
and To fields and click OK. To change all instances of a particular day (for
example, all Wednesdays) as nonworking, choose the day in the Details
dialog box and then click Set Days to Nonworking Times and click OK.

E-mailing an Assignment to Your Team

After you work out all your resource assignments on paper, see whether
your ideas will work for your resources’ schedules.

Of course, you should check to see who is available for your project. And
because things can change in the time it takes to work out your plan and
make assignments, make sure that your resources are committed to you
before you commit yourself to a final plan.

Book V
Chapter 3
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Figure 3-10:
Use this
dialog box to
specify who
will receive
your note.

If you use Project Server and Project Web Access with Project, you can use
collaborative tools to publish assignments to a server, where people can
review them and accept or decline. For more on Project Web Access, see
Book X, Chapter 3.

You can send your entire project plan to resources as an e-mail attachment
or just send selected tasks. You can also generate a resource assignment
report and send that to people so that they can review their assignments
in detail.

E-mail can be a very useful tool for any project manager. You can use it to

communicate throughout the life of your project and to send your project
plan for review at various stages. One of those stages is the point at which
you want your resources to commit to their task assignments.

You can send your project as an e-mail attachment or as a schedule note,
which is an e-mail with only updated tasks attached; you might send a
schedule note after the project has started when you change or make a new
assignment. You also have the choice of sending an entire plan or just
selected tasks from it.

To send a project as an e-mail attachment, follow these steps:

1. Choose Filec>Send To->Mail Recipient (as Attachment).
An e-mail form is displayed.
2. Fill in a subject and your e-mail message.

3. Click Send to send the message.
If you want to send a schedule note, follow these steps:

1. Choose File->Send To->Mail Recipient (as Schedule Note).
The Send Schedule Note dialog box, as shown in Figure 3-10, appears.

Send Schedule Note
Address message to
7| Project manager
f Resources

For: Entire project @1 Selected Resources

Attach
| Fiie
| 7] Picture of Selectsd Resources
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2. Choose any intended recipients of the message from among Project
Manager, Resources, and Contacts.

3. Select either Entire Project or Selected Resources to specify what to
include in the schedule note.

4. In the Attach area, select what to attach to the e-mail message.

If you select the File option, Project attaches the entire file. If you
instead select the Picture of Selected Resources option, Project attaches
a bitmap picture of the selected tasks in the view you had active when
you started the Send procedure.

Note: If you were in a Resource view when you began this process, this
option reads Picture of Selected Resources, and the resources you had
selected are sent.

5. Click OK.
An e-mail form is displayed.
6. Fill in a subject and your e-mail message.
7. Click Send to send the message.
\3
P To help you make sure that e-mails to resources on your project arrived, set

your e-mail program to provide return receipts when messages are received
or read. Check your e-mail client help program to find out how to do this.
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Chapter 4: Tallying Costs

In This Chapter

 Reviewing what affects costs

v Determining how Project calculates costs
v Viewing cost data

v Customizing cost fields

v Creating a project summary task

A fter you've created and assigned some resources to your project, you
begin to see your costs mount up at the summary task level. Under-
standing what affects those costs, how Project calculates those costs, and
what cost information Project makes available helps you to understand what
constitutes your Project budget.

In this chapter, we provide a good grounding in the hows and whys of costs
and your Project plan.

How Vour Settings Affect Vour Budget

In Chapters 2 and 3 of this minibook, you explore costs and assigning
resources to tasks. To help round out this discussion of costs, you should
review all the factors that drive costs. In addition to a resource cost per
hour and a resource base calendar and availability, you assign resources to
tasks at certain percentages. Project uses all these factors to calculate the
cost of a resource assigned to a task. (See the next section to understand
how those calculations work.)

Here’s the real beauty of entering information in Project: After you make set-
tings for your resources, Project does the work of tallying and showing total
costs to you in views, such as the Cost Table of Gantt Chart view shown in
Figure 4-1.
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Figure 4-1:
Total costs
atthe
summary-
task level
giveyoua
quick idea
of your total
budget and
costs in
this table.
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For example, suppose you want to assign a production worker to a task.

Here are the specifics:

Base calendar: Night Shift (8 hours, 6 days per week, between 11 p.m.

and 8 a.m.)

Cost per hour: $20
Overtime cost: $30

Availability: 100 percent

Assigned to a two-day task: 50 percent

What’s the cost of this resource? Here’s how it works: Two days at half-time
availability based on an 8-hour calendar is a total of 8 hours (4 hours per
day). The resource incurs no overtime, so the cost is 8 x $20, or $160.

Change one setting for the same resource, and see what you get:

Assigned to a two-day task: 150 percent

Now the resource is working 12 hours per day (150 percent of 8 hours) over
2 days. With 16 total hours at the standard rate ($20) and 8 hours of over-
time ($30), this person costs $560.
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How Project Calculates Costs

While you enter resource information and assign resources to tasks, Project
is busy making calculations that can shift around task timing and resource
workload in your plan. These calculations relate to how Project updates
tasks, determines the critical path, and calculates earned value. You can, to
some extent, control how Project goes about making these calculations.

<® FEarned value is a calculation that occurs after you have begun your project
and recorded actual work on it. It’s essentially the value of work completed.
A task with $1,000 of costs has an earned value of $750 when the task is 75
percent complete. See Book VIII, Chapter 3 for more about earned value.
Letting Project calculate or doing it yourself?
By default, Project performs calculations automatically. When you make a
change to your plan, Project recalculates totals, the critical path, and so on
without you having to do a thing. However, you can change that default set-
ting and have Project wait for you to initiate calculations manually. You make
this setting on the Calculation tab of the Options dialog box (Tools=>Options).
Figure 4-2 shows the settings available there.
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If you change the Calculation mode to Manual, you must either press F9, or
click the Calculate Now button in this dialog box any time you want Project
to perform all its calculations. You also have the choice of affecting All Open
Projects or only the Active Project.

So why would you choose to use manual calculation? One reason might be
that you want to make a lot of changes and not have Project take the milli-
seconds required to recalculate between each change, slowing down your
entry work. You can put things on Manual, make all your changes, and then
use the Calculate Now button to make all the changes at once.

In addition, even with Change Highlighting on it’s not always easy to spot all
the items that have been recalculated when you make a series of changes.
So, it might be easier to make all the changes in Manual mode, print your
Gantt Chart view, and then recalculate and compare the two. This approach
shows you the cumulative calculations that occurred when all your changes
were made so you can see whether you're happy with the revised plan. (This
feature is especially useful for trying out what-if scenarios.)

In Project 2007, you can also take advantage of the Multiple Undo feature.
This means you can leave your calculations on automatic, make changes,
and then undo them, thereby undoing the calculations in sequence. For
more on Multiple Undo, see Book VII, Chapter 2.

Earned-value options

What do the settings you can make to the earned-value calculation do to
your project? To understand that, start by looking at Figure 4-3, which shows
you the options offered when you click the Earned Value button on the
Calculation tab of the Options dialog box.
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The Default Task Earned Value Method setting provides two choices: Book V
Chapter 4
4+ % Complete: This setting calculates earned value using the percent com-
plete that you record on each task. This assumes that for a task that’s
halfway complete, half the work hours have been used.

4+ Physical % Complete: Use this setting if you want to enter a percent of
completion that isn’t based on a straight percent-complete calculation.
For example, if you have a four-week task to complete a mail survey, 50
percent of the effort might happen in the first 25 percent of the duration
of the project: designing, printing, and mailing the survey. Nothing hap-
pens for two weeks while you wait for responses, and then there’s a
flurry of activity when the responses come back. So a straight calcula-
tion that 50 percent of the task is completed 50 percent of the way
through wouldn’t be accurate. If your projects have a lot of tasks like
this, you might consider changing your settings to use this method.
Then, you can display the Physical % Complete column in your Gantt
Chart sheet pane and enter what you consider more accurate percent-
complete information for each task.

s)s09 Buidjjer

The second setting in the Earned Value dialog box is the Baseline for Earned
Value Calculations drop-down list. As we mention earlier, earned value is the
value of work completed, expressed in dollars, according to the baseline: A
$2,000 task at 50 percent complete (for example) has a $1,000 earned value
of work performed. Therefore, the baseline against which you calculate this
value is hugely important. Choose any of the 11 possible baselines you might
have saved in your project here. After you make these two choices, click
Close to close the Earned Value dialog box.

You should explore one more option in the Options dialog box that concerns
earned-value calculations. The Edits to Total Task % Complete Will Be Spread
to the Status Date option, which isn’t selected by default, affects how Project
distributes changes in your schedule. If you leave this option deselected, cal-
culations go to the end of the duration of tasks in progress, rather than up to
the status date or the current date. If you select this option, calculations
spread changes across your plan up to the status date or the current date,
and no further. Selecting this choice helps you see changes to your project
in increments of time, rather than across the life of tasks in progress.

A\
Our advice is to leave the Edits to Total Task % option not selected for the
most accurate reflection of progress on your project.

Examining Cost Data

After you assign all your resources to tasks and set all your fixed costs, it’s
time for sticker shock. Project will tally all those costs and show you the proj-
ect’s budget. First you have to look at your bottom line, which Project lets
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you do from several perspectives. Then you might have to get out a sharp
knife and trim those costs down.

Viewing cost information

Several views give you a good idea of what your project will cost and where
those costs are coming from:

4+ Gantt Chart view with the Cost Table displayed shows you total cost by
task and a fixed cost column. Several of the columns in this table come
in handy when you begin to track spending on your project and need to
compare actual costs to projected costs.

4+ Network Diagram view can also display the Cost Table, showing you a
neat snapshot of each task’s costs within its own task box (see Figure 4-4).

4+ Resource Sheet view helps you to review the hourly and overtime rates
of resources currently assigned to your project.

4+ Try using filters to display the highest-priced tasks in your project, a
logical place to start trimming your budget. (See Book VII, Chapter 1
for information about using filters.)
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Customizing cost fields
When you display the Cost Table with fields, such as the Standard Resource
Rate, you can click in any cost column and enter a rate for each resource. A
neat shortcut is to customize those fields with a lookup table.

327

Examining Cost Data

A lookup table allows you to create a drop-down list of values in a field to
select from. So, if your company has a few standard hourly rates or per-use
costs for materials, customizing these fields can make your information
entry faster and also help prevent data-entry mistakes that can occur when

you enter all rates manually.

To customize a field, follow these steps:

1. Display a table with the column you want to customize.

You display tables by choosing Viewr>Table and selecting one from the

list that appears.

2. Right-click the column heading and choose Customize Fields from the
shortcut menu that appears.

The Custom Fields dialog box appears, as shown in Figure 4-5.
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3. Click the Lookup button.

The Edit Lookup Table dialog box appears, as shown in Figure 4-6.

Book V
Chapter 4
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4. Enter a value (if you're filling in a cost field, this is a dollar amount) in

the Value column.

5. Enter a description (for example, plant worker or engineer for the cate-
gory of resource charged at this rate) in the Description column.

6. Repeat Steps 4 and 5 to enter additional values for this field.

7. If you want to restrict the field to accept only the values in this list,
make sure the Data Entry option Allow Additional Items to be Entered

into the Fields check box is not selected.

You might have to click the plus symbol to the left of Data Entry Options

to see this check box.

8. Click a radio button to select an order for the list (you might have to
click the plus sign to the left of Display Order for Lookup Table to see

these options):

e By Row Number: Lists the items as you've listed them in this

dialog box

e Ascending: Lists them in ascending value order, lowest value first

® Descending: Lists them in descending value order with the highest

value first

9. Click Close and then click OK to save the list and close all dialog

boxes.
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A good view to use if you want to see all of a resource’s work assignment
information is Resource Allocation view. You can display it by clicking the
Resource Allocation View button on the Resource Management toolbar, or
you can select it from the More Views dialog box.

The Value of a Project Summary Task

Figure 4-7:
The highest-
level task in
the outline
with all
tasks
indented
below itis
the project
summary
task.

Just as a ship can have only one captain, only one task can summarize all
other tasks in each project. We strongly suggest that you create a project
summary task, which represents the highest (least detailed) level of informa-
tion and is often simply the title of the project, such as New Product Rollout
or Space Shuttle Launch.

A project summary task is created when every task in the project falls under
it in the outline, as shown in Figure 4-7. You can see in the figure that all proj-
ect phase summary tasks are subordinate to the project summary task.

See Book IIl, Chapter 1 for more about the outline structure of a project plan.

Project summary task
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Task

Company: A medium-sized capital venture
company.

Project: Planning for an office move.

Challenge: The project manager has to budget
the cost of an office move. He wants a way to
track the entire budgeted cost for moving
against several individual costs that are tally-
ing up as he adds resources to individual tasks.

Solution: The project manager can specify a
resource as a budget resource by selecting the
Budget check box in the Resource Information
dialog box, shown in the following figure. He
can then assign these resources to the proj-
ect’s single summary task. Using budget
resources, he can display fields that allow him

Working with budgets

to compare budgeted work with planned work.
(Believe us, there’s often a difference.) For
example, he might have $10,000 budgeted for
mover time, and he might have planned to use
$11,450 of resource work for the move. The
budget setting can help him compare these
amounts as you add and delete resources from
various tasks.

If you assign a budget resource, you can use
Task Usage view or Resource Usage view to
enter a work amount for that resource. You can
view budgeted work by displaying the Budget
Work field. Note that this field reflects only
Material and Work resource type costs. You
can use the Budget Cost field to view the bud-
geted amount for Cost resource types.

Resource Information
General
Resource pame: [Maver Time Budget

Notes Custom Fields
_: Initials: -M
| Graup: |

Code: i

Type: 'Effﬁ—!"_l‘?;'m

7| Budget

| | cancel
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The highest-level headline in an outline reflects the sum of all the items
below it. The project summary task rolls up all the actual data from other
tasks into one line item. Thus, the project summary task’s duration reflects
the duration of the entire project. From a cost angle, the project summary
task’s total cost reflects the total costs for the entire project. Being able to
see your total bottom line costs at a glance is one of the things that make a
summary task so useful.

The length of your summary task can be a bit confusing. Remember that the
summary task duration is the difference between the earliest task start date
and latest task end date. However, nonworking days aren’t counted in the
summary task duration. The length of the summary task, therefore, equals
the number of days of work over the course of the subtasks, not the number
of calendar days between the start of the first task and end of the last.

Not everyone uses project summary tasks. You can simply create tasks
that summarize tasks within project phases — with subphases and sub-
tasks below them — and not create a project summary task. However,
there are two good reasons for creating a project summary task:

4+ You can quickly view totals for both time and money for the project at
a glance in the columns of data in Gantt Chart view and other views.

4+ You can place a link to your project summary task in another project
so that all data for one project is reflected in another. For example, if
you create five schedules for new product launches in your company,
you can easily create a master schedule for all company product launches
by linking to the project summary tasks in each of the projects.

As you build your project, you can easily create a project summary task
yourself by simply indenting other tasks beneath it. But if you neglect to do
this till later in your planning, you can use a Project feature to generate this
summary task automatically at any time — even after you build all the
phases of your project.

To have Project automatically create a project summary task, follow these
steps:
1. Choose Tools=>Options.
The Options dialog box appears.
2. Click the View tab to display it (see Figure 4-8).
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Options
Interface Saaurity
Schedule l Caloulation Speling 55vE
View General Edit Caleridar

Default Gew: éﬁan@gt_ E
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Figure 4-8:
The View
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dialog box. [t | [Coe ] (sl

3. Select the Show Project Summary Task check box.
4. Click OK to insert the Project Summary task.
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Chapter 1: Working with Views

In This Chapter

v+ Understanding views

1 Changing the default view

v Adding views to the View bar and the View menu
v Sorting, filtering, and grouping tasks in views

v Displaying a combination view

1 Creating a view

v Creating a combination view

v~ Printing views

Mzw is the term Project uses to describe a way for you to look at proj-
ect information; a view offers you a perspective of your project. As the
project manager, you're actually going to want to look at your project from
many different perspectives, and Project contains a wealth of views to
accommodate you. If you can’t find what you want using one of the built-in
views, you can always create your own view. Project also lets you sort, filter,
and group information in views, which helps you focus on different issues.

Network Diagram view and Calendar view behave a little differently than all
the other Project views; you can customize these two views using tech-
niques described in Book IX, Chapter 2.

What'’s a View?

When it comes to looking at the information in your project, you're going to
want to look at it in a variety of ways so you can focus on particular issues.
For example, you’ll want to view the tasks in your project without concern
for the resources assigned to the tasks. Then you're going to want to focus
on the resource assignments for the project. Also, you’ll find that you want
to look at different information concerning tasks; for example, you might
want to look at baseline information, and then you might want to review
task costs. Similarly, you’ll want to look at different types of information for
resources.

Of course, you can try to look at all the information using only one view, but
that would result in confusion instead of clarity. So, Project provides 28
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Figure 1-1:
Relationship
Diagram
viewis a
chart view.

built-in views to let you look at your project from a variety of perspectives. If
one of these built-in views doesn’t meet your needs, you can create your
own view.

Book II, Chapter 3 contains a lot of really good information that should help
you decide what view to use, depending on the circumstances.

You can classify the views in Project into three types:

4+ Chart or graph views
4 Form views
4 Table or sheet views

Chart or graph views present information by using pictures. Relationship
Diagram view, shown in Figure 1-1, is a chart view.

Form views present information the same way that a paper form presents
information. A form displays information about a single item (or task) in
your project. The Task Form shown in Figure 1-2 is a form view.

=] Wiccosaft Praject  Microsoft Office 2007 deploymentmpp =S
4 Hle Edit View Insst Fomnat Tosls Project Report Collaborte Window Help Tyrse 3 austiarani el -ax
QS 6T o & - 2 B

Al Tasks — =
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21 Identtfy
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Figure 1-2:
Task Form
view is a
typical form
view. B 3
Read
Table or sheet views present information in rows and columns, similar to the
way that a spreadsheet program presents information. Resource Sheet view,
shown in Figure 1-3, is a table view. Each row of the table contains all the
information about one resource in your project, and each column represents
QP a field that identifies the information that you're storing about the resource.
Shortcut menus are available in many views; right-click anyplace on the view
to see a shortcut menu.
QQ,“\BER Each table view actually comprises a variety of tables, and you can easily
& switch to any of these variations. In Chapter 2 of this minibook, you find out

more about tables.

Finally, Project contains combination views, like the Task Entry view shown
in Figure 1-4, that combine two of the types of views just described. In a com-
bination view, one view appears in the top half of the screen while another
appears in the bottom half. Later in this chapter, you discover how to work
with combination views.
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Microsoft Project - 060103.mpp
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Making a View Handy to Display

Selecting the Startup View

Figure 1-5:
The View
tab of the
Options
dialog box.

By default, the first view you see when you open Project is Gantt Chart view.
But suppose, after working in Project awhile, that you discover you really
work most in Task Usage view. Can you make that view appear when you
open Project? Yes. Follow these steps:

1. Choose Tools=>Options.
2. Click the View tab shown in Figure 1-5.

Options ==
Save l Interface Security
Schedule Zalculation Speling ollaborate
View General Edit Calendar

Default views: I k- ]
Bar Raollup -

Calendar type:
Calendar
Date format: | Descriptive Network Diagram
Show |Dekail Gantt:
[7] Status bar  [reaii nart [V] OLE links indicators
i Leveling Gantt fand
| Windows in T4 mjlestone Date Rallup [¥IProject screentips

[¥]Bars and shag Milestone Rallup

Multiple: Baselines Gantt

Metwork Diagrarm

] Showe externd Relationship Diagram

Resource Allacation %

Cross project linkir

g box on open

[¥] show extern

al data

Currency options for '060103.mpp’

B J Decimal digis: [2 ‘J
| -
r— A —

Gutline options for ‘060103, mpp'

Symbal;

Placement:

[¥] tndent name [7] Show autline symbol [] show project summary task

[ Show outline number [¥] Show summary kasks

Help ‘ (o] 4 ] | Zancel

3. In the Default View drop down list, click the view you want to use as
your default view.

4. Click OK.

Project displays the view you select the next time you open Project.

Making a View Handy to Display

Even though you can select a default view, you probably have several views
that you use regularly, and you want an easy way to display those views. You
can easily add those views to the View menu or the View bar that can appear
down the left side of the Project window (see Figure 1-6).
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& Displaying the View bar is a matter of personal preference; the View bar

appears when you choose View>View Bar. When you hide the View bar, the
name of the current view appears on a thin bar at the left edge of the view.

Suppose that you've taken a real liking to Relationship Diagram view
because you like its visual presentation of predecessor and successor tasks.
To easily display it by adding it to the View menu and the View bar, follow
these steps:

1. Choose Viewr>More Views.

The More Views dialog box appears (see Figure 1-7).

- M Vi =5
Figure 1-7: V.m, —
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Select the Mekwork Diagram bl Mew. .
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access from Task Details Form

Task Entry

this dialog Task Form
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2. Click the view you want to add in the Views list.
3. Click Edit.

The View Definition dialog box appears (see Figure 1-8).
4. Select the Show in Menu check box.

View Definition in ‘Microsoft Office 2007 depl... =5

Mame: | Relationship Ciagram |

Figure 1-8: S re—
|n the V|eW Creen: |ea lonsnip Liagram I
Definition o —i
) Mo Group
S:!l;g :)ho‘;(' Filter: |F\II Tasks E!
Show in
Menu
check box. Help QK | | Cancel
5. Click OK.
The view you selected appears on the View menu and the View bar.
A\

You can remove any views you seldom use from the View menu and the View
bar. To remove a view from the View menu and the View bar, repeat this pro-
cedure but deselect the Show in Menu check box.

Sorting Tasks in a View

Different people find different techniques work well when they’re trying to
organize large sets of information. And, planning a project can be an exercise
in organizing large sets of information.

Sorting tasks in your project schedule is one technique you can use to organ-
ize a project’s information to help you focus on particular aspects of the
project. You can sort a project from most views in almost any way that you
want. For example, in Gantt Chart view, Project automatically sorts tasks by
ID (see Figure 1-9). But you might find it easier to view your project informa-
tion if you sort by cost. Choose Project=>Sort=>By Cost, and Project reorders
Gantt Chart view so that tasks are ordered by cost, and row numbers
become nonsequential (see Figure 1-10).
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Figure 1-11:
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field.

Filtering a View 343

The five most common sort keys appear when you choose Project=>Sort, but
if you choose the Sort By command at the bottom of the submenu, the Sort
dialog box appears (see Figure 1-11). From this dialog box, you can select
from a wide variety of fields on which to sort your project. And, you can set
up three sort keys so that Project can break any “ties” it finds while sorting.
For example, if Project finds a tie at the first level, it uses the second sort
that you specify to break the tie. Project uses the third sort key to break ties
at the second level.

Sort =
Sork by [T]
S | st
[ | @ i:cendng

Descending [m‘
= [ )
| El @) Ascending

Help

(") Descending
Then by

| IZI @ Ascending
") Descending

[“]Permanently renumber basks
[#]keep outline structure

Using the check boxes at the bottom of the dialog box, you can make your
sort choices permanent by reassigning Task IDs, and you can choose to
retain the outline structure of the project.

Filtering a View

Filtering is another technique you can use to help you focus on a particular
aspect of your project. When you filter, you specify criteria, and Project
either limits the information that appears in the view or highlights the infor-
mation that meets the criteria. For example, you can view only the tasks
assigned to a certain resource, or you can highlight the tasks on the critical
path of your project.

The filters available to you in a particular view are dependent on the view’s
primary purpose. For example, Gantt Chart view is primarily a task-oriented
view, so you can apply task-related filters to the view. On the other hand, the
Resource Sheet is a resource-oriented view, so the only filters available to
you are resource filters. Table 1-1 lists alphabetically each task filter and the
information Project displays when you apply one of these filters. Table 1-2
lists similar information for the available resource filters.
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Table 1-1 Task Filters

Filter Purpose

All Tasks Displays all the tasks in your project.

Completed Tasks Displays all finished tasks.

Confirmed Displays the tasks on which specified resources have
agreed to work.

Cost Greater Than Displays the tasks that exceed the cost you specify.

Cost Overbudget Calculated filter that displays all tasks with a cost that
exceeds the baseline cost.

Created After Displays all tasks that you created in your project on or
after the specified date.

Critical Displays all tasks on the critical path.

Date Range Interactive filter that prompts you for two dates and then

displays all tasks that start after the earlier date and
finish before the later date.

In Progress Tasks

Displays all tasks that have started but haven't finished.

Incomplete Tasks

Displays all tasks that haven't finished.

Late/Overbudget Tasks

Assigned To

Prompts you to specify a resource. Then Project
displays tasks that meet either of two conditions: the
tasks assigned to that resource that exceed the budget
you allocated for them, or the tasks that haven't finished
yet and will finish after the baseline finish date. Note
that completed tasks don't appear when you apply this
filter, even if they’re completed after the baseline finish
date.

Linked Fields

Displays tasks to which you have linked text from other
programs.

Milestones

Displays only milestones.

Resource Group

Displays the tasks that are assigned to resources that
belong to the group you specify.

Should Start By

Prompts you for a date and then displays all tasks not
yet begun that should have started by that date.

Should Start/Finish By

Prompts you for two dates: a start date and a finish date.
Then Project uses the filter to display those tasks that
haven't started by the start date and those tasks that
haven't finished by the finish date.

Slipped/Late Progress

Displays two types of tasks: those that have slipped
behind their baseline scheduled finish date and those
that aren’t progressing on schedule.

Slipping Tasks

Displays all tasks that are behind schedule.

Summary Tasks

Displays all tasks that have subtasks grouped below
them.
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Filter Purpose

Task Range Shows all tasks that have ID numbers within the range
that you provide.

Tasks with Attachments Displays tasks that have objects attached or a note in

the Notes box.

Tasks with Deadlines

Displays all tasks to which you have assigned deadline
dates.

Tasks with Estimated Durations Displays all tasks to which you have assigned an esti-

mated duration.

Tasks with Fixed Dates

Displays all tasks that have an actual start date and
tasks to which you assign some constraint other than As
Soon As Possible.

Tasks/Assignments with Overtime  Displays the tasks or assignments that have overtime.

Top Level Tasks

Displays the highest-level summary tasks.

Unconfirmed

Displays the tasks on which specified resources have
not agreed to work.

Unstarted Tasks

Displays tasks that haven't started.

Update Needed

Displays tasks that have changes, such as revised start
and finish dates or resource reassignments, and that
need to be sent to resources for update or confirmation.

Using Resource

Displays all tasks that use the resource that you specify.

Using Resource in Date Range Displays the tasks that are assigned to a specified

resource that start after the first date you specify and
finish before the second date you specify.

Work Overbudget Displays all tasks with scheduled work greater than
baseline work.

Table 1-2 Resource Filters

Filter Purpose

All Resources

Displays all the resources in your project.

Confirmed Assignments

Available only in Resource Usage view; displays only those
tasks for which a resource has confirmed the assignment.

Cost Greater Than Displays the resources that exceed the cost that you specify.

Cost Overbudget Calculated filter that displays all resources with a cost that
exceeds the baseline cost.

Date Range Interactive filter that prompts you for two dates and then dis-
plays all tasks and resources with assignments that start after
the earlier date and finish before the later date.

Group Prompts you for a group and then displays all resources that

belong to that group.

(continued)
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Table 1-2 (continued)

Filter

Purpose

In Progress Assignments

Displays all tasks that have started but haven't finished.

Linked Fields

Displays resources to which you have linked text from other
programs.

Overallocated Resources

Displays all resources that are scheduled to do more work than
they have the capacity to do.

Resource Range

Acts as an interactive filter that prompts you for a range of ID
numbers and then displays all resources within that range.

Resources with
Attachments

Displays resources that have objects attached or a note in the
Notes box.

Resources/Assignments

Displays the resources or assignments that have overtime.

Should Start By

Prompts you for a date and then displays all tasks and
resources with assignments not yet begun that should have
started by that date.

Should Start/Finish By

Prompts you for two dates: a start date and a finish date. Then
Project uses the filter to display those tasks or assignments that
haven't started by the start date and those tasks or assignments
that haven't finished by the finish date.

Slipped/Late Progress

Displays two types of resources: those that have slipped behind
their baseline scheduled finish date and those that aren’t pro-
gressing on schedule.

Slipping Assignments

Displays all resources with uncompleted tasks that are behind
schedule because the tasks have been delayed from the origi-
nal baseline plan.

Unconfirmed
Assignments

Displays the assignments for which requested resources
haven't yet agreed to work.

Unstarted Assignments

Displays confirmed assignments that haven't yet started.

Work Complete

Displays resources that have completed all their assigned
tasks.

Work Incomplete

Displays all resources with baseline work greater than sched-
uled work.

Work Overbudget

Displays all resources with scheduled work greater than base-
line work.

Applying a filter to a view

Because you can apply task filters to task views only and resource filters to
resource views only, the filters you can select depend on the view that you
display before starting these steps:

1. Display the view that you want to filter.
2. Choose Project=>Filtered For.
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Project displays a list of the most commonly used filters.
3. Choose the filter that you want to apply.

Project applies the filter you selected.

*§S’RBEH
& You can quickly determine that Project is filtering information by looking at
the ID column. The ID numbers for hidden tasks or resources don’t appear.
To apply a filter that doesn’t appear on the list or to apply a highlighting
filter, follow these steps:
1. Display the view that you want to filter.
2. Choose Project=>Filtered For~>More Filters.
Project displays the More Filters window (see Figure 1-12).
More Filters ==
Eilters: @ Task Resource
[l Tasks - | lew, |
T — Campleted Tasks
Figure 1-12: | S ueboiper | e ]
Created After...
You can use Ched =
the More %&'2’;5&??::5 [‘crosrizer... |
F| |te rs I[;tgdozirlggdgat Tasks Assigned Ta... | Help |
W|nd0W to I\Nn!ffvtonrrl:acsheck
apply' We”, Resource Group, .. i
more fllters Highlight: | ‘ Apply. | ‘ Cancel
3. Select a filter name from the list.
4. Click Apply to apply the filter or click Highlight to apply a highlight-
ing filter.
If the filter that you want to apply requires additional information, such
as a date range, type the information Project requests.
5. Click OK.
Project applies the filter.
If you highlight tasks or resources that meet the criteria, Project displays the
information that meets the criteria in blue.
A\

To turn off a filter, choose Project>Filtered For. Then choose All Tasks or All
Resources, as appropriate for the filtered view.
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Creating custom filters

Yes, you guessed it: You can create a new filter or modify an existing filter.
Because creating and editing a filter are very similar activities, follow these
steps to edit an existing filter, and after the steps, we tell you the changes to
make to create a new filter:
1. Display the view that you want to filter.
2. Choose Project->Filtered For=>More Filters.
Project opens the More Filters window.
3. Highlight the filter that you want to modify.
4. Click the Copy button.
Project displays the Filter Definition dialog box (see Figure 1-13).

Filter Definition in 060103.mpp* ==
Name: iCﬂpy of In Progress Tasks | ] Show in menu
Filer:
|| Cuk Row | Copy Row | Paste Row Insert Row | | Delete Row
Andfor Field Mame | Test | Value(s) -
Figure 1-13: -Actua\ Start does not equal NA
Use thS And: Actual Finish equals Hk
| 1
dialog box
to edit an .
eXiStin g || Shaw ;'e\ated SUMMALY Fows
fllter’ Help [s]'4 ‘ ‘ Cancel
V?‘“\NG! Any changes that you make to a filter are permanent. For this reason, we
S suggest that you click the Copy button to make a copy of a filter that you

want to modify, rather than clicking the Edit button to edit the original
filter.

5. Click in the Name box and type a new name for your filter.
6. Click in the Field Name column.

Project displays a list box arrow to the right of the field.
7. Select a field from the list.

8. Click in the Test column and select a comparison operator from the
list.

9. Click in the Value(s) column and supply a filtering value.

10. Repeat Steps 6 through 9 for each criterion that you want to create.
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Also supply an And/Or operator if you supply additional criteria.

If you use “And,” Project displays information only if the task or
resource meets all criteria. If you use “Or,” the filter displays information
if a task or resource meets any of the criteria.

11. Click OK.
Project redisplays the More Filters window.
12. Click Apply.

Project closes the More Filters window and applies the filter.

To create a new filter, click the New button in Step 4 above. In the Filter
Definition dialog box, the name Filter 1 appears in the Name box and no
information appears at the bottom of the box. Type a name for the new filter
and enter some filtering criteria using the techniques described in Steps 5-10.
To have your new filter appear in the Filtered For list, select the Show in
Menu check box.

Each line that appears in the Filter Definition dialog box is called a statement.
To have Project evaluate certain statements together, but separate from
other statements in your filter, group the statements into a set of criteria by
leaving a blank line between sets of criteria. On the blank line, select either
operator in the And/Or field.

If your filter contains three or more statements within one criteria group,
Project evaluates all And statements before evaluating Or statements. Across
groups, Project evaluates And statements in the order in which they appear.

Using AutoFilters

AutoFilters are a way to filter information on any table view by selecting a
value for any table column directly on the table. When you turn on Auto-
Filters, Project displays a list box arrow at the right edge of each column
heading (see Figure 1-14). You can turn on AutoFilters by clicking the
AutoFilters button on the Formatting toolbar.

When you click an arrow, Project displays a list of values available for that
column. When you select a value, Project filters the information in the table
to display only those tasks that meet the filter’s criteria. In Figure 1-13, we fil-
tered by a Finish Date of This Week, and Project displayed only those tasks
scheduled to finish during the current week. First, notice that the task num-
bers are no longer in numerical order. Then look at the timescale in the
Gantt Chart portion of the window; you can see that all the tasks end within
a short window of time.
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Figure 1-14:
When you

turn on
AutoFilters,
Project
displays list
box arrows
beside each
column

heading.
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Project displays the column heading by which you're filtering in blue,
whereas other column heading titles are black — the difference is difficult to
see in this black-and-white book.

If you decide that you really like AutoFilters, you can have Project display
them automatically for each new project you create. Follow these steps:

~—

. Choose Tools=>Options.
2. Click the General tab.

3. Select the Set AutoFilter On For New Projects check box (see
Figure 1-15).

4. Click OK.

The next time you create a new project, AutoFilter list box arrows auto-
matically appear.
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Grouping Information

Grouping is a variation on sorting and filtering. When you use grouping in
Project, you tell Project to group tasks based on criteria you select. Grouping
differs from sorting because grouping doesn’t assign an order to the tasks or
hide any tasks from view.

Using a predefined group

You can group tasks in a variety of predefined ways, but the predefined
groups are based on the type of view; that is, the available predefined groups
differ, depending on whether you start in a task view or a resource view. To
group tasks based on whether they’re on the critical path, follow these
steps:

1. Display a task view that you want to use to group tasks.

2. Choose Project=>Group By.

Project displays a list of predefined groups (see Figure 1-16). By default,
Project doesn’t group tasks, so No Group is selected.
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Selecta
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You also can open the Group By list on the Standard toolbar.
3. Click the group that you want to apply.
In this example, we chose Critical.
When you establish groups, Project adds headings for each group in yellow
highlighting that you can’t see in this black-and-white book; in Figure 1-17,
we’ve grouped the tasks based on whether they’re critical in the project.
A\

To turn off grouping, choose Project=>Group By. Then choose No Group.
Alternatively, select No Group from the Group By list on the Standard
toolbar.

Grouping and usage view's

If you start in a usage view, you also can group on assignment fields. In the
steps that follow, we started working from Resource Usage view, where you
have the option of grouping by assignment or by resource. If you start work-
ing from Task Usage view, the names of some of the options change to refer
to tasks instead of resources. In addition, you have the choice of grouping by
assignment or by task.



Grouping Information

353

T Microsoft Project - Talent show.mpp e |
Eile Edit View Insert Format Tools Project Report Collaborate Window Help Type a question for help -8 X
NEH &R Y @ T 9 - 25 BE 2@ Critical FRAF|E @
. ok = 1 Show~ (8 B o Al Tasks v Ve | 9y s
8 [TaskName Duration Start Finish Predece: F Ny 12,'08 | Mav 19,08 | Moy 26, '05 -
WT[F[S[S[M[T M]T[F[S|S[M[T W[T[F[S[S[M[TMW][T[F[
DEI Critical: Ho Tddays Tue MA406  Sun 202507 = =
& Hire @ guest performer lddays  Tue MAH0E Fri121m6 52 s
10 Prepare mailer Sdays tlon 1244106 Fri12/8/06 &
11 Prepare fhyer 2days Mon 124406 Tue 12/5/06 &
12 Pl fhyer and mailer 1 dary Mon 1241106 Mon 1241106 10
14 E Show Odays Sun 272507 Sun 272507
B Critical: Yes 106 days Mon 10.2/08 Sun 22507
2 Select 2 date Sdays Mon 1042106 Fri 10806
3 Select a hall 13 days Mon 10/006  Wed 1072506 2
4 Confirm the date with the hall Fdays Thu 10/26/06 Mon 10/30/06 3
5 Review and sign contract 10 days Tue 10/31106 Mon 1113106 4
7 Prepare acts 15 wks Tue 111406 Sun 272507 12
13 Selltickets 15 wks Tue 111 4106 Sun 2/2507 |5
—
Figure 1-17:
You can
group tasks
based on
whether
.
they're !
critical. ; i oy
Read
Follow these steps to group by assignment in a usage view:
. . . .
1. Display either Task Usage view or Resource Usage view.
. .
2. Choose Project=>Group By=>Customize Group By.
The Customize Group By dialog box appears (see Figure 1-18).
Customize Group By [Ex=|
aroup by the Following fields:
[ Name -
Field Mame Field Type Order F
| Group By MName ~ i Task Ascending
| Then By Outline Number Assignment Ascending
| Then By
Then By -
[¥] aroup assignments, not tasks
— Group by setting for Mame
Font: |Ar\a| & pt, Bold | Eant

Figure 1-18:
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dialog box
to group by
assignment
fields.

Cell background: ||:| Yellow

Pattern:

Define Group Inkervals...
Show summary tasks

Save.., Reset
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3. Select the fields by which you want to group.
4. Select the Group Assignments, Not Tasks check box.

5. In the Field Type column, select whether to group by assignment or
by task.

6. Click OK.

Project groups the usage view by assignments (see Figure 1-19).

=] Microsoft Project - New product plan.mpp
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DEH &RV RBF9-0-8|= ‘= B | Custom Group F R T E@

+ — g Show- [aial Iz -|®» r o = AllTasks z = A
| [askhane. el gmsnm 44 [ Sundfl | SunéAs | Sundms I: [ w52 | SunsM | Sun
| nome: amirm decision to continue commerciaiization pragrom Cost - §2,880.00
B § Commercialization Stage Cost
Bl 5.2 Commercialization Analysis Cost
E1 525 Affirm decision to continue commercialization program | cogt | $2,580.00
Nianagement Cost $1,52000
Project Manager Cost $1,350.00
E] Hame: Analyze the competition Cost
B2 Preliminary Investigation $tage Cost |
E 2.4 Analyze the competition Cost
Marhsting Cost
E] Hame: Assess manufacturing capabilities Cost
B2 Preliminary Investigation Stage cost |
2.6 Assess manufacturing capabilities ot
Product Exnglnsering Cost
Manutacturing Engineer Cost
El Hame: Assign jalizati i ibility and |
E 4 Pilot Stage: Cost
© 4.4 Trial Analysis Cost
Bl 44.7 Assign commercialization leadership responsibility and res | cost
Management cost |
Praject Manager Cost
Flg ure 1 _1 9: [El Hamne: Assign pilot stage resources Cost
El 4 Pilot Stage Cost
Onausa ge 144 Assign pilot stage resources ot |
. Management Cost
view, you Project Manaer Cost
E] Hame: Assign resources to development stage plan Cost
can O 3 Development Stage cost
group by B 3.4 Assign resources to development stage plin Cost
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Do-it-yourself groups
As you might suspect, you're not limited to using the groups that come pre-
defined with Project; you can create your own groups. Follow these steps:
1. Display the view that you want to use to group tasks.
2. Choose Project=>Group By->More Groups.
Project displays the More Groups dialog box (see Figure 1-20).
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3. Select the Task option button or the Resource option button, depend-

&N\Bfg ing on the type of group you want to create.
< . , . .

< Project doesn’t let you apply a task grouping to a resource view or a

resource grouping to a task view.
4. Select a group name from the list.
5. Click Copy.
Project displays the Group Definition dialog box (see Figure 1-21), which
NG/ contains a copy of the settings of the group you selected in Step 4.
QUING!

& Because any changes that you make to a group are permanent, we sug-
gest that you make a copy of a group and modify the copy instead of
editing the original group.

Group Definition in 'New product plan.mpp* ==
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| Field Mame Field Type Order
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— Then By
Then By g
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6. Assign a name to the group that you’re creating.
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A\

Figure 1-22:
From this
dialog box,
identify the
intervals at
which you
want
Project to
group the
fields.

Select the Show in Menu check box if you want the group to appear on
the Group By menu.

An ampersand (&) in the group name indicates that you can type the
letter to the right of the ampersand to select the group from a menu.

7. Open the Field Name list box and select a field on which you want
Project to group.

8. In the Order column, choose Ascending or Descending.

You can select a font for the grouping title information and change the
cell background and the pattern that Project displays for the field. You
also can include summary tasks in the grouping by selecting the Show
Summary Tasks check box.

9. Click the Define Group Intervals button.
Project displays the Define Group Interval dialog box (see Figure 1-22).

Define Group Intenval ==
Figld name: Cost

Eroup on:
Stark at:

Group interval: |

10. Set the grouping intervals that Project uses.
11. Click OK.
Project redisplays the Group Definition dialog box.
12. Click OK.
Project saves your choices and redisplays the More Groups window.

13. Click Apply to apply the group you just defined or click Close.

Using Combination Views

In addition to the 28 views that exist in Project, you can create combination
views, where Project splits the screen horizontally and displays one view in
the top pane and another in the bottom pane. In fact, Task Entry view, shown
in Figure 1-23, is a combination view by default.
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When you work in a combination view, the bottom pane displays the infor-
mation about the task or resource you select in the top pane. So, click a task
or resource in the top pane to select it; then, click the bottom pane to make
it the active pane and make changes to the task or resource as needed.
N\

The name of the view appears in a bar that runs down the left side of the
screen; the active pane’s bar is darker than the inactive pane’s bar.

You can easily display a combination view by following these steps:

1. Display the first view you want to see by using the View bar or View
menu.

2. Choose Windows>Split.

Project splits the window (see Figure 1-24), displaying either Task Form
view or Resource Form view in the bottom pane.

Project selects the appropriate form for the bottom pane based on the
view in the top pane. If the view in the top pane is a task view, Project
displays Task Form view in the bottom pane. Similarly, if a resource view
appears in the top pane, Project displays Resource Form view in the
bottom pane.
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3. Click anywhere in the bottom pane.

4. Choose Viewr>More Views.

The More Views dialog box appears (see Figure 1-25).
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[ copy..
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5. Click Apply.

The view you selected appears in the bottom pane.
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Shortcut to display a combination view

Are you the type of person who prefers to
avoid menus? Here's a quick and easy way to
create a combination view. Move your pointer
to the split bar, which is in the lower-right
corner of the Project window, just below the
vertical scroll bar. When the pointer becomes

two horizontal lines with arrows, the way it
appears in the figure, double-click. Or, you can
also drag the split bar toward the top of your
screen. You can return to a single view by
double-clicking the split bar again.
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Split bar mouse pointer

While you work in a combination view, Project assumes you want to con-

tinue working in a combination view. So, if you switch views, Project displays

the view you select in whichever pane was active at the time you made the
switch.

To return to viewing only one view on-screen, choose Window=>Remove
Split. Project hides the view in the bottom pane and fills the screen with the
view that appears in the top pane.

Book VI
Chapter 1

SMaIp
yum Bunpiop
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Customizing a View

Suppose that you work regularly in the default Gantt Chart view, but you find
that you really want to see the Baseline table instead of the Entry table the
majority of the time that you use Gantt Chart view. You can change the
default table that Project displays for the view each time you display the
view. You also can change the grouping and filtering displayed with the view.
For example, if you know you always want tasks grouped as complete and
incomplete, you can assign that grouping to the view. Or, if you know you
want to view only critical tasks, you can assign that filtering to the view.

You can approach this process from two perspectives:

4+ You can make changes to one of the default views in Project and save
those changes so that they appear each time you select that default
view.

4+ You can make a copy of a default view, give it a name that describes
what it shows, and then make the changes to the copy.

We prefer the second approach for the following reasons:

4+ The default views continue to display the information designed by the
folks who wrote the program — and they tend to be folks who consider
what most people need most of the time.

4+ You can create several versions of the same view and use the appropri-
ate version when needed. For example, you might want to be able to
quickly view both the default Gantt Chart view and a version of Gantt
Chart view that uses the Baseline table. If you assign your new version
to the View menu and View bar, you can quickly switch between the two
versions of Gantt Chart view.

4+ If you don’t assign the views to the View menu or View bar, you can
quickly and easily find the version of the view that you want to use,
because you've given it a name that is meaningful to you.

So, in the steps that follow, we show you a hybrid process that you can use
to create a new view by making changes to a copy of an existing view:
1. Choose ViewcoMore Views.
The More Views dialog box appears.
2. Click the view you want to change.
3. Click Copy.
The View Definition dialog box appears (see Figure 1-26).
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4. Type a name for the new view in the Name box.

Choose a name that describes the information that you’ll show in the ci‘;:':e‘:u

view.

You can include an ampersand (&) in the name to identify the letter to

the right of the ampersand as the letter you can press on your keyboard g

to select the view from the View menu. Be careful not to select any of the s=

letters that Project already uses on the View menu: C, G, D, K, N, A, S, U, % a

M, O,B, T, V,H, and Z. “g
-

5. If the view you copied permits, select a table from the Table list box.
6. From the Group list box, select a group to apply to the view.

7. From the Filter list box, select a filter to apply to the view.

A\

If you apply a filter, you can have Project highlight filtered tasks without
hiding tasks that don’t meet the filter criteria. Select the Highlight Filter
check box at the bottom of the View Definition dialog box.

8. Select the Show in Menu check box to add the view to the View menu
and the View bar.

9. Click OK.
Project adds the view to the list in the More Views window.
10. Click Apply to use the view.

Project displays the open project using the view you just created.

Creating a New Combination View

Suppose that you find yourself setting up the same combination view over
and over, and you think to yourself, “This would be so much easier if [ could
just select my personalized combination view from the View menu or the
View bar.” Well, you can, if you follow these steps to create a new view:

1. Choose View>More Views.

The More Views dialog box appears.
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2. Click New.
The Define New View dialog box appears (see Figure 1-27).

Figure 1-27:
Whenyou | Define New View =
create a :
new view, 1 Single view
you can
create a
single or

cong1bination | Help | l oK | | Cancel
view.

-

3. Select the Combination View option and click OK.

The View Definition dialog box appears (see Figure 1-28).

Figure 1-28: | View Definition in "Microsoft Word 2007 deploy... =5
U.se this Mame: !Gantt,l'ReIatinnship Didagran |
dialog box -
to selectthe | Wiews displaved:
views you Top:  |Gantt Chart [=]
Wa ntto Bokbom: !_Relatinnship Diagram El
include -
inthe || Shawy in ey
combination | ————

. Help I | | Cancel |
view. —

4. Type a name for the new view in the Name text box.

Choose a name that describes the information that you’ll show in the
view.

You can include an ampersand (&) in the name to identify the letter to
the right of the ampersand as the letter you can press on your keyboard
to select the view from the View menu. Be careful not to select any of the
letters that Project already uses on the View menu: C, G, D, K, N, A, S, U,
M, O,B, T, V,H, and Z.

5. From the Top list box, select the view you want Project to display in
the top pane of the combination view.
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6. From the Bottom list, select the view you want Project to display in
the bottom pane of the combination view.

7. Click the Show in Menu check box.
8. Click OK.

Project adds the view to the list in the More Views window.
9. Click Apply to use the view.

Project displays the open project using the combination view you just

created.
Book VI
o « « Chapter 1
Printing Your Project
Project contains many reports that you can print that format the information s
in your project in a variety of ways. However, many times, you simply want < e
to print what you’re looking at on-screen. Well, here’s some good news: You @ E-
can print any view of your project. 5 ‘;
=

If you're printing a sheet view, the number of columns that you see on-screen
determines the number of columns that print. If your project view doesn’t fit

on one page, Project prints down first and then across; that is, the entire left

side of your project prints before the right side prints.

;:ll:j To print a particular view, display that view on-screen. Then click the Print
=~ button on the Standard toolbar to print using default settings.

And what are the default settings? They appear in two dialog boxes that
appear if you don’t use the Print button.

» | You can also preview before printing by clicking the Print Preview button on
“% the Standard toolbar.

Choose Filec>Print to open the Print dialog box. From the Print dialog box,
shown in Figure 1-29, you can
4+ Select a printer to use.
Specify the number of copies you print.
Select pages to print.

Specify portions of the timescale to print.

¢+ 4+

Indicate whether Project should recognize and use manual page
breaks.
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< When you save the project file, Project saves the settings that you make in
the Print dialog box.
The Page Setup dialog box controls a wide variety of print settings for a view.
You can display the dialog box by choosing File>Page Setup. From the Page
tab, shown in Figure 1-30, you can set orientation and scaling. Using scaling,
you might be able to fit the printed text onto one page.
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ERQQEE l Margins I Header 1 Footer Legend ] View 1
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—_—
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Page Setup
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N\

Suppose that your project is ten pages long, but you intend to print only
pages 5 and 6. Typically, you want to number those pages as 1 and 2. To do
that, enter 1 in the First Page Number box.

From the Margins tab, shown in Figure 1-31, you can change the margins for
your printed text and specify whether a border should appear.
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Views and pagination

Project automatically inserts page breaks in a
view based on the amount of information in the
view and the paper size you select. However,
sometimes you might want to insert a manual
page break. For example, you might want to
insert a manual page break to start each sum-

mary task and its subtasks on a new page.

You can insert manual page breaks by follow-

ing these steps:

1.

2.

Select the task (or resource) that should
appear at the top of a new page.

Choose Insert->Page Break.

Projectinserts a manual page break, which
appears as a dotted line in the view.
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