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Welcome to the world of Microsoft Excel, the most popular and power-
ful spreadsheet program in the world. You may ask: “What is a
spreadsheet program?” A spreadsheet program is a computer program that
features a huge grid designed to display data in rows and columns. You can
use it to perform mathematical, logical, and other types of operations on the
data you enter. You can sort the data, enhance it, and manipulate it in a
plethora of ways — including creating powerful charts and graphs from it.
Whether you need a list of names and addresses or a document to calculate
next year’s sales revenue based on prior year’s performance, Excel is the
application you want to use.

About This Book

This book provides the tools you need to successfully tackle the potentially
overwhelming challenge of learning to use Microsoft Excel. In this book, you
learn how to create spreadsheets; however, what you do with them is totally
up to you. Your imagination is the only limit!

Why You Need This Book

Time is of the essence, and most of us don’t have the time to do a lot of
reading. We just need to get a task done effectively and efficiently. This book
is full of concise, easy-to-understand steps designed to get you quickly up
and running with Excel. It takes you directly to the steps for a desired task
without all the jibber-jabber that is often included in other books.

Even if you've used Excel in the past, Excel 2007 brings many new features
and major changes to existing features. This book helps ease the transition
from the previous Excel version.

| “*troduction

Conventions used
in this book

= When you should type something, | put it in
bold typeface.

w= For menu commands, | use the => symbol to
separate menu options. For example, the
directions “Choose Insertc>llustrations=>
Picture” is saying, “Click the Insert tab and
then from the lllustrations group, click the
Picture option.”

= [n some figures, you see circled items. This is
done to help you locate items mentioned or
referred to in the text.

This icon points out tips and helpful sug-
gestions related to the current task.
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Excel 2007 Just the Steps For Dummies

How This Book Is Organized

This book is divided into 25 different chapters broken into 6
convenient parts:

Part I: Putting Excel to Work

In Chapter 1, you uncover the basics of working with Excel
files, such as opening, closing, and saving files. In Chapter 2,
you work with entering the different types of data into Excel
worksheets, and in Chapter 3, you create various types of
formulas and functions to perform worksheet calculations.
Chapter 4 shows you how to protect your work with Excel’s
security features.

Part 11: Sprucing Up Your Spreadsheets

Chapters 5 and 6 both show you how to dress up the data
you enter into a worksheet using data alignment, formatting
values, fonts, colors, and cell borders. In Chapter 7, you work
with graphics such as arrows and clip art. Then, in Chapter 8,
you begin to use workbooks consisting of multiple work-
sheets, hyperlinks, and cross references.

Part I11: Viewing Data in Different Ways

This part, in four different chapters, shows how you can mod-
ify the way Excel displays certain workbook options on your
screen. Chapter 9 illustrates changing the worksheet views. In
Chapter 10, you sort your data to make it easier to locate par-
ticular pieces of information. Chapter 11 enables you to cre-
ate charts to display your data in a superb graphic manner.

Finally, in Chapter 12, you work with the different output
methods, including printing and e-mailing your worksheets.

Part 1V: Analyzing Data with Excel

Use these chapters to effectively analyze all the data you
input into a worksheet. In Chapters 13, 14, and 15, you work
with Excel Outlines, Filters, and Pivot Tables. Chapters 16 and
17 show some of the time-saving data-entry tools included
with Excel.

Part U: Utilizing Excel with Other
People and Applications

Chapters 18 through 21 are all about sharing: sharing
Excel with others by using Excel’s collaboration features, or
sharing Excel with Microsoft Office applications such as
Word, PowerPoint, and Access.

Part UI: Practical Applications for Excel

Go to these chapters to save yourself time with a gorgeous
organization chart (Chapter 22), a commission calculation
worksheet (Chapter 23), or a medical-expense-tracking
worksheet (Chapter 24). Chapter 25 helps you plan for your
future. You can use Excel to chart the path to purchase a
house, pay off your debts, and save for college or retirement.

Back cover: Using Excel Shortcut Keys

This helpful appendix shows you many shortcut keys that
make access to Excel functions faster and easier.
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Putting Excel
to Work

The 5th Wave By Rich Tennant

No, that’s not the icon for Fxcel, it’s the icon
£orFxcuse, the database of reasons why you

haven’t learned the other programs in Otfice.”
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Working with
Excel Files

In this book, you discover the new Excel interface that provides you with
the right tools at the right time. In most Windows programs, you see
menus and toolbars from which you select your options. Now you discover
the new Excel interface that provides you with the right tools at the right
time. Instead of the traditional look, Excel now provides tabs with icon-and
button-laden tabs on the Ribbon containing your favorite Excel features.
Galleries and themes are also a new addition to Excel, helping you maintain
consistency and style in workbook appearance. The Office Quick Access
toolbar, which is now the only toolbar, provides fast and easy access to basic
file functions. You discover later in this chapter how you can customize the
Quick Access toolbar.

Throughout the course of this book, you discover methods to use Excel as a
spreadsheet, of course; but you also discover how to use it as a database, a
calculator, a planner, and even a graphic illustrator. You start with the basics
and work into the more advanced Excel actions.

In this chapter you:
m= Open and close the Excel program
m= Open, close, and save Excel workbooks

w= Explore the Excel screen including customizing it to make it even
faster and easier to use.

m= Use workbook properties to better manage your files.

m=  Set Excel default file locations, which saves you time and frustration
when you open and save your workbooks.

| “%ap’fer
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= Close Excel 7
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Chapter 1: Working with Excel Files

Open and Explore Excel

1.

Choose Start=>All Programs=>Microsoft Office>
Microsoft Office Excel. The Microsoft Excel program
begins with a new, blank workbook displayed like the
one shown in Figure 1-1, ready for you to enter data.

The icon at the top-left of the screen is called the Office
Button. As you hover your mouse over it, a description
of the Office Button functions appears.

©)

Pause your mouse over any of the three icons next to
the Office Button. By default, the Quick Access toolbar
functions include Save, Undo, and Redo.

When you click the Office Button, Excel displays a list of opfions.
Click the Office Button to close the menu if you don’t want fo make
a selection at this time.

Hover your mouse over the tabs, or task-oriented portions,

of the Ribbon and a description of a tab’s feature appears.
The tabs are broken down into subsections called groups.

The Home tab includes the Clipboard, Font, Alignment,
Number, Styles, Cells, and Editing groups.

Click the Insert tab. The Ribbon changes to reflect
options pertaining to Insert. Groups include Shapes,
Tables, Illustrations, Charts, Links, and Text.

On the Home tab, click the down arrow under Format
As Table. A Gallery of table styles appears. (Click the
arrow again to close the Gallery.)

On the Home tab, clicking the Dialog Box Launcher on
the bottom-right of the Font group opens a related dia-
log box. (See Figure 1-2.) In this example, the Format
Cells dialog box opens.

Click the Cancel button to dlose a dialog box without making any
changes.
oy o 7
boom e (@ By S 2 g gy
oy BERCE- A EEREEE g n ={ M|+ oA o8
@
e —— =i
e L e
Figure 1-1: A blank Excel workbook, which Excel calls Book1.
o
s (@ e By e 2 g gy
7 mru A EBBERE - g 3 e M|+ oA o8
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Figure 1-2: Click a Dialog Box Launch icon to display a relevant dialog box.
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Close Excel

Select Commands with the Keyboard

1.

If appropriate for the command you intend to use, place
the insertion point in the proper word or paragraph.

Press Alt on the keyboard. Shortcut letters and numbers
appear on the Ribbon. See Figure 1-3.

s Numbers control commands on the Quick Access toolbar.

Press a letter to select a tab on the Ribbon; for this
example, press P. Excel displays the appropriate tab
and letters for each command on that tab.

Press a letter or letters to select a command. Excel dis-
plays options for the command you selected.

Press a letter or use the arrow keys on the keyboard to
select an option. Excel performs the command you
selected, applying the option you choose.

Press the Esc key to step the key controls back one step.

Press F6 to change the focus of the program, switching between the
document, the status bar, and the Ribbon.

Close Excel

1.

2.

Choose Office Button= Exit Excel, as you see in Figure 1-4.

s Optionally, Click the Close button (x).

Click Yes or No if prompted to save your workbook.
(See “Save a Workbook” later in this chapter.)

Optionally, choose Office c>Close. The current workbook closes, but the
Excel program remains open.

figure 1-3: Use the keyboard o select Ribbon commands.

Recent Documents

1 applisnces

2] Eeeed Optern || 3 Egt Bxcel
Figure 1-4: Closing Excel releases the program
from your computer memory.
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Chapter 1: Working with Excel Files

Customize the Quick Access Toolbar

1.

Right-click any tool or group title you want to add to
the Quick Access toolbar. A menu appears.

Choose Add to Quick Access Toolbar. The tool or group
icon appears on the Quick Access bar.

Right-click an icon on the Quick Access toolbar. A menu
appears.

Choose Remove from Quick Access Toolbar. The
selected item disappears from the Quick Access toolbar.

Right-click the Quick Access toolbar and select
Customize the Quick Access Toolbar. The Excel Options
dialog box, seen in Figure 1-5, appears.

Open the Choose Commands From drop-down menu
and select a tab name. Excel displays a list of available
features.

Select a feature and click the Add button. The selected
feature appears on the right panel. Click OK.

Change Status Bar Indicators

1.

2.

3.

Right-click anywhere along the status bar at the
bottom of the window. Excel opens the Status Bar
Configuration menu.

To activate an inactive feature, click it. This automati-
cally adds a check mark and displays the feature’s status.
In Figure 1-6, the Caps Lock feature is on, and now the
status bar shows the Caps Lock status.

To deactivate any active feature, click it.

Excal Optism L= ]

Figure 1-5: You can select any Excel options to add to the Quick Access toolbar.
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Figure 1-6: Customize what you see along the Excel status bar.
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Save a Workbook

Create a New Excel File

Click the Office Button.

Choose New. The New Workbook dialog box opens.
(See Figure 1-7.)

Click Blank Workbook.

Click the Create button. Excel creates a blank workbook
based on the default template.

See Chapter 8, “Changing Worksheet Views,” for more information
about Excel templates.

Optionally, press Ctrl+N to create a new workbook without opening
the New Workbook dialog box.

Save a Workbook

1.

Choose Office Button>Save or click the Save button on
the Quick Access toolbar. The Save As dialog box
appears, as shown in Figure 1-8.

s The Save As dialog box only appears the first time you save a file.

By default, Excel saves your files in the My Documents
folder. If you want to save your file in a different folder,
select that folder from the Save In drop-down list.

In the File Name text box, type a descriptive name for
the file.

Click the Save button. Excel saves the workbook in the
location with the name you specified.

Filenames cannot contain asterisk, slash, blackslash, or question mark
characters.

# || Monthly family budget

WA AR LY

[
2 Office Online

Infeacive: Excel 3007 1n Extel 2007 enmmand
reference guide

Figure 1-7: Excel names each new workbook incrementally such as
Workbook 2 or Workhook 3.

U]

[ moste | s Carcel

Figure 1-8: Choose a folder and filename for your Excel workbook.
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Chapter 1: Working with Excel Files

Save a Workbook in a
Different Format

1.

Choose Office Buttont>Save As. The Save As dialog box
appears.

Select the folder where you want to save the file from
the Save In drop-down list.

In the File Name text box, type a descriptive name for
the file.

Open the Save As Type drop-down menu. A list of file
formats appears.

Choose one of the 26 different file formats. Files saved in
the Excel 2007 format have a .xIsx extension, whereas files
created in earlier versions of Excel have a xIs extension.

Click Save. Depending on the format you choose,
Excel may prompt you for additional information.

Open an Existing Excel File

1.

10

Choose Office Button=>Open. The Open dialog box,
seen in Figure 1-10, appears.

If necessary, select the appropriate folder from the Look
In drop-down list. Then select the file you want to open.

Open the Files of Type drop-down menu to display files saved in
other formats.

Click the Open button. The workbook appears in the
Excel workspace, ready for you to edit.

If the file you open was created in a previous version of Excel, the words
Compatibility Mode appear on the fitle bar next to the document name.

Surneary Phader of ocaurencet

Minar loss of fidelity v

7] Chedc compatbiity when siving i moridook.

== Ce ]
Figure 1-9: Excel warns you of compatibility
conflicts.
LA
Lo L) My Dt A X -
e || @ @ & & & @

- 8 & 9 & = & a

Figure 1-10: Open a previously created Excel file.

Excel displays recently used files on the right side of the Office Button
menu. Click any listed filename to quickly open it.
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Rename a File

Rename a File

1.

Open Excel, but not the file you want to rename.
Choose Office Button>Open. The Open or Save As
dialog box appears.

Optionally, choose Office Button=>Save As and confinue os described.

If necessary, click the Look In list and navigate to the
folder containing the file you want to delete.

Right-click the file. Do not double-click the file because
double-clicking the file opens it.

Choose Rename from the shortcut menu. (See
Figure 1-11.) The original filename becomes
highlighted.

Type the new file name. Filenames cannot contain aster-
isk, slash, blackslash, or question mark characters.

Press Enter when you are finished typing.

Click the Cancel button to close the Open dialog box.

Gpen L
Lok L) My bonummts | @0 XuD-
Diogcumens ; . y R CR &) =)

Dbt Uoduer woed  meoroaien  wosk [REMENL]  wescods

L 8 Y L8 9 9

™ Wems  Sokggem  olbg  Caes  Dwes Sgtslsgean

Y B oY H B G

ESTMATES Moty My Naeben . g chart

[ | ]

Figure 1-11: Change the name of an existing Excel workbook.
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Chapter 1: Working with Excel Files

Delete a File

1.

Open Excel, but not the file you want to delete. Choose
Office Button>Open or OfficerdSave As. Either the
Open or Save As dialog box appears.

If necessary, click the Look In list and navigate to the
folder containing the file you want to delete.

Right-click on the unwanted file. Do not double-click
the file.

Choose Delete from the shortcut menu. (See Figure 1-12.)
A confirmation message appears.

Click Yes. Excel deletes the file.

Click the Cancel button to close the Open or Save As
dialog box.

Set the Default File Locations

1.

12

Click the Office Button and click Excel Options. (It's
located at the bottom of the Office list.) The Excel
Options dialog box opens.

From the options on the left side of the dialog box,
click the Save category. You see the options shown in
Figure 1-13.

In the Default file location, enter the data path to the
place where you want to save most of your files. Click
OK.

By default, Excel saves your files in the My Documents folder stored
on your local hard drive, but your company may have another loca-
tion where it wants you fo keep most of your Excel files. An exam-
ple might be GACOMPANY DOCUMENTS\DIANE

To override the default file location, you can click the Look In list when
saving or opening a file and choose a location different from the default
location.

Confitm File Dalete =]

a0 " 0 send 'Car Sl

z/
=)

[ e [ %

Figure 1-12: Delete unwanted files through
the Open or Save As dialog box.
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Figure 1-13: Customize fo determine where Excel stores your workbooks.
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View Workbook Properties

Specify Workbook Properties

1.

Click the Office Button and click Prepare. A list of
options appears.

Click Properties. The Document Information Panel
appears.

Enter identifying information such as the author’s
name, subject, or a list of keywords. See Figure 1-14.

Excel automatically adds statistical information such as the work-
book’s original creation date, the last time it was printed or modi-
fied, and the workbook size.

Click the Close box to close the Document Information
Panel.

View Workbook Properties

1.

Choose Office Button=>Open. The Open dialog box
appears.

If necessary, click the Look In list and navigate to the
folder containing the file you want to delete.

Click the Views button drop-down arrow to display a
Views shortcut menu or click the Views button itself to
cycle through the available views.

Choose Properties. The Open window splits into two
panels like the ones you see in Figure 1-15.

Click a file name. Excel displays the workbook proper-
ties in the right panel.

Click OK to open the file or Cancel to close the Open
dialog box.
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Figure 1-14: Enter information fo identify your workbook.
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Chapter 1: Working with Excel Files
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Entering Spreadsheet
Data | "*\opfer

E xcel is a huge grid made up of columns and rows. If you've used previ-
ous versions of Microsoft Excel, you know the new spreadsheet is larger
than ever. A single worksheet now contains 16,384 columns (stretching
from column A to column XFD) and 1,048,576 rows.

You enter three types of data in the cells: Get ready to...
w= Labels are traditionally descriptive pieces of information such as w= Change the Active Cell 16
names, months, or other identifying statistics, and they usually
include alphabetic characters. »= Undo Data Entry 18
w=» Values are generally raw numbers or dates. w= Enter, Edit, or Delete Cell Data ................. 17
w=» Formulas are instructions for Excel to perform calculations. e Select Cells 19
In the first part of this chapter, I show you how to easily enter labels and "= Move, Copy and Paste Data ............... 20
values into your wo_rksh_eet. But, alas, human beings sometimeg make mis- w= Transpose Data 2
takes or change their minds. So I also show you how to delete incorrect
entries, duplicate data, or move it to another area of the worksheet. You even w= Extend a Series with AutoFill ......ooveoe...... 21
discover an Excel feature that prevents worksheet cells from accepting incor-
rect data. = Name and Use a Range of Cells ................ 22
w= Manage Range Names ............cccoocovee.... 23
= \alidate Data Entry 24
w= Enter Data in Validated Cells ..................... 25
w= Locate Cells with Data Validation................ 25
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Chapter 2: Entering Spreadsheet Data

Change the Active Cell

16

1.

Open a spreadsheet in Excel. The formula bar displays
the active cell location. Columns display the letters from
A to XFD and rows display numbers from 1 to 1048576.
A cell address is the intersection of a column and a row
such as D23 or AB205.

Move the focus to an adjacent cell with one the follow-
ing techniques:

e Down: Press the Enter key or the down arrow key.
e Up: Press the up arrow key.

e Right: Press the right arrow key

o Left: Press the left arrow key.

To move to a cell farther away, use one of these
techniques:

e (Click the mouse pointer on any cell to move the
active cell location to that cell. You can use the scroll
bars to see more of the worksheet. In Figure 2-1, the
cell focus is in cell E10.

¢ Choose Home @ Editing=>Find & Select®>Go To.
The Go To dialog box displays, as shown in Figure 2-2.
In the Reference box, enter the address of the cell you
want to make active and then click OK.

s Press the F5 key to display the Go To dialog box.

e Press Ctrl + Home. Excel jumps to cell Al.

e Press Ctrl + End. Excel jumps to the lower-right cell
of the worksheet.

e Press Ctrl + PageDown or Ctrl + PageUp. Excel
moves to the next or previous worksheet in the

workbook.
L (5]
] TR g
ey ) $ % ¢
. g BRI w-E -A- ET A RE & C - |
& T
o —
Wil Sheet] - Shaw heets Fd i | jf
& @ [h O3 s =) .

Figure 2-1: A black border surrounds the active cell.

o Ta 2[%]
GO b

[ ] [ ][ e ]

Figure 2-2: Specify a cell
address in the Go To box.
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Enter Cell Data

Enter Cell Data

Type the label or value in the desired cell.

Press Enter. The data is entered into the current cell and
Excel makes the next cell down active. (See Figure 2-3.)
How Excel aligns the data depends on what it is:

To enter a value as a label, type an apostrophe before the value.

e Label: Excel aligns the data to the left side of the cell.
If the descriptive information is too wide to fit, Excel
extends that data past the cell width if the next cell is
blank. If the next cell is not blank, Excel displays only
enough text to fit the display width. Widening the
column displays additional text.

e Whole value: If the data is a whole value such as 34 or
5763, Excel aligns the data to the right side of the cell.

e Value with a decimal: If the data is a decimal value,
Excel aligns the data to the right side of the cell, includ-
ing the decimal point, with the exception of a trailing
0. For example, in Figure 2-4, if you enter 246.75, then
246.75 displays; if you enter 246.70, however, 246.7
displays. (See Chapter 5 to change the display appear-
ance, column width, and alignment of your data.)

If a value displays as scientific notation or number sign, it means
the value is too long fo fif into the cell. You need to widen the col-
umn width.

¢ Date: If you enter a date, such 12/3, Dec 3, or 3 Dec,
Excel automatically returns 03-Dec in the cell, but the
formula bar displays 12/03/2006. Figure 2-4 also
illustrates an example of date entry. See Chapter 5 to
change the date format.

a9 ;
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Figure 2-3: Enter labels or values into a cell.
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Figure 2-4: Entering values.
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Chapter 2: Entering Spreadsheet Data

Undo Data Entry

1.

Enter text into a spreadsheet.

2. To undo any actions or correct any mistakes you make

when entering data, perform one of the following:
e Choose Undo from the Quick Access toolbar.
e Press Ctrl+Z.

Keep repeating your favorite undo method until you're
back where you want to be.

To undo several steps at once, click the arrow on the
Undo icon and select the step from which you want to
begin the Undo action. (See Figure 2-5.)

Edit or Delete Cell Data

1.

18

To delete the entire contents of a cell, use one of the fol-
lowing methods:

¢ Choose HomeEditing=>Clear.

e Press the Delete key.

To edit the cell contents, use one of these methods:

e Delete the contents and retype new cell information.

e Press F2 and edit the cell contents from the
formula bar.

e Double-click the cell contents and edit the cell con-
tents from the cell. (See Figure 2-6.)

Figure 2-5: Select the steps
you want fo reverse.

ORY [RATING DATE

Indiana 246.75 16-Sep
Ilingis 174
Ohio 246.7
Kentucky 211.349
Michigan 238

Figure 2-6: Edit cell contents without
having to start over.

To repeat your last action, click the Redo icon on the Quick Access tool-
bar or press Ctrl+Y. You can’t repeat some actions, however.

If you clear the wrong cell, use the Undo command.
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Select Multiple Cells

Select Multiple Cells

1. Click the first cell in the group you want to select.

2. Depending on the cells you want to select, perform one
of the following actions.

To select sequential cells, hold down the Shift key and
select the last cell you want. All cells in the selected area
are highlighted, with the exception of the first cell.
(Don't worry; it's selected, too.) Figure 2-7 shows a
sequential area selected from cell B4 to cell F15.
Notice the black border surrounding the selected area.

To select nonsequential cells, hold down the Ctrl key
and click each additional cell you want to select.
Figure 2-8 shows the nonsequential cells A4, C7,
and E4 through E9 selected.

To select a single entire column, click a column
heading.

To select multiple columns, drag across multiple col-
umn headings.

To select a single entire row, click the row number.

To select multiple rows, drag across multiple row
numbers.

To select the entire worksheet, click the small gray
box located to the left of column A and above row 1.
Optionally, you can select all cells in a worksheet by
pressing Ctrl + A

When making nonsequential cell selections, you can indude entire
rows and entire columns along with individual cells or groups of cells.

4 TERRITORY RATING DATE
5 indiana 24675 16-Sep|
. 174

17
19

21

b shesty

Figure 2-8: Non-sequential cells selected.

Click any nonselected cell to clear the selection.

Optionally, click and drag the mouse over a group of cells to select o

sequential area.

TEAM LinG
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Chapter 2: Entering Spreadsheet Data

Copy and Paste Data

Select the area of data you want to copy.

Choose Homew>Copy. A marquee (which looks like
marching ants) surrounds the cells (see Figure 2-9).

Click the cell to which you want to copy the selected area.

Choose Homer>Paste. The selected cells are pasted into
the new location.

Paste the cells into another location or press Esc to can-
cel the marquee.

(hoose Homer>Cut and then Homer>Paste to move (instead of
duplicate) the selected cells to a different location.

Optionally, press Cirl+C to copy the selected cells; Cirl+X to cut the
selected cells, or Cirl+V fo paste the selected cells.

Transpose Data

20

Select the cells you want to transpose.

Choose Homer>Copy.

The Transpose feature will not work if you choose Cut instead of Copy.

Click the cell where you want the transposed cells to
begin.

On the Home tab of the Ribbon, click the down arrow
below Paste. A menu of options appears.

Choose Transpose. As you see in Figure 2-10, Excel
copies the selected cells into the new area, transposing
rows into columns or columns into rows.

= T £
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Figure 2-9: Marching ants form around a copied area.
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Figure 2-10: Reverse the flow of data by transposing cells.
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Extend a Series with AutoFill

Extend a Series with AutoFill

1.

Type the first cell of data with data such as a day or
month, such as Wednesday or September. AutoFill works
with days of the week, months of the year, or yearly
quarters such as 2nd Qtr. You can enter the entire word
or you can enter the abbreviated form (Wed or Sep).

Press Enter.

Position the mouse pointer on the small black box at
the lower-right corner of the data cell. Your mouse
pointer turns into a small black cross. (See Figure 2-11.)

To AutoFill a series of numbers, enter two values in fwo adjacent
cells, such as 1 and 2 or 5 and 10. Select hoth cells, and then use
the AutoFill box fo highlight cells. Excel continues the series as 3, 4,
5,0r 5,10, 15, and so forth.

Drag the small black box across the cells you want to
fill. You can drag the cells up, down, left, or right.

Release the mouse. Excel fills in the selected cells with a
continuation of your data. Figure 2-12 shows how Excel
fills in the cells with the rest of the days of the week.

If you use AutoFill on a single value or a text word, Excel duplicates
it. For example, if you use AutoFill on a cell with the word Apple,
all filled cells contain Apple.

To quickly use the AutoFill, highlight the cell that has the data and
the cells you want to fill and then double-click the fill-handle.

Chapter 10 includes instructions for creating your own customized
list. Autofill can enter lists you often use, such as sales rep names
or product types.

@.@, @.

ngure 2-11: The AutoFill

handle.
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Figure 2-12: Using AutoFill for days of the week.
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Chapter 2: Entering Spreadsheet Data

Name a Range of Cells

1. After selecting the cells you want to name, click
Formulas=>Named Cellss>Name a Range. The New
Name dialog box appears. (See Figure 2-13.)

2. In the Name text box, type up to a 255-character name
for the range. Range names are not case-sensitive; how-
ever, range names must follow these conventions:

o The first character must be a letter, an underscore, or
a backslash.

e No spaces are allowed in a range name.

e Do not use a name that is the same as a cell address.
For example, you can’t name a range AB32.

3. Click OK.
Optionally, enter a range name into the Name box located o the
left end of the Formula bar. You can jump quickly to a named range

by clicking the down arrow in the Name box and selecting the
range name.

Use Named Ranges

1. Click the down arrow in the Name box. A list of named

ranges appears. (See Figure 2-14.)

2. Select the range name you want to access. Excel high-
lights the named cells.

Optionally, choose Homer>Editing=>Find & Select=>Go To. Double-
click on the range name you want to access.

22
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Figure 2-14: Quickly locate

an area by using a range name.

Figure 2-13: For faster formula entry, use range names.
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Manage Range Names

Manage Range Names

1.

Choose Formulase>Named Cellss>Name Manager.
The Name Manager dialog box, shown in Figure 2-15,
appears.

Excel automatically adds tables to the Name Manager. See Chapters
6 and 10 for more on working with tables.

Select one of the following options.

e Click the New button, which displays the New Name
dialog box in which you can enter a range name and
enter the cell location it refers to.

Instead of typing the range cell locations, click the Collapse butfon,
which moves aside the New Name dialog box. You can then use your
mouse to select the desired cells. Press Enfer or dlick the Collapse
button again to return fo the New Name dialog box.

e Click an existing range name and then click the Edit
button, which displays the Edit Name dialog box
shown in Figure 2-16. Use this dialog box to change
the range name or the range cell location reference.

e (Click an existing range name and then click the Delete
button. A confirmation message appears, making sure

you want to delete the range name.

If you have a lot of range names, you can dlick the Filter button and
elect to display only the items meefing selected criteria.

Click the Close button to close the Name Manager dia-
log box.

| Hame Manager ey

[ty | [ - ]
Mamn Fenfers To Seope Commant
v wEeetIMFRASFET  Wirkibook
TE... =ShestlMEJA4ELD  Workbook
CIndl..  =ShestiMORE DR Workbook

DATE
BATING
TERRITORY

Befers tac

Closn |
Figure 2-15: Use the Name Manager fo add, edit, or
delete range names.
Edit Name [2[%]
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3 | Concel

Figure 2-16: Edit a range name and
cell location.
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Chapter 2: Entering Spreadsheet Data

Validate Data Entry

24

1.

Select the cell or cells you want Excel to validate. Next,
choose DatarvData Tools=>Validation. The Data
Validation dialog box displays.

In the Settings tab, open the Allow drop-down list and
choose the type of validation, such as:

e Values such as Whole Number or Decimal, where you
specify the upper and lower limits of allowable data
values.

e Lists such as a list you define, a range of cells in
the existing worksheet, or a named range. (See
Figure 2-17.)

e Dates or Times, where you specify ranges or limita-
tions such as greater than or less than or even a spe-
cific date.

e Text Length, where the number of characters in the
data must be within the limits that you specify.

If necessary, display the Data drop-down list and select
criteria such as Between, Greater Than, and so on.

Select criteria such as maximum and minimum values,
or specify a data location. Enter values or cell addresses.
Precede a value with an equal sign (=) to specify a range
name.

From the Input Message tab, optionally enter a comment
to display whenever someone clicks the validated cell.

On the Error Alert tab, choose from the Style drop-down
list whether Excel warns you or completely stops you
from entering an invalid entry. (See Figure 2-18.)

Click OK.

Data Validation (O[]
Settirgs Irgas Message | Ermor Adet
B

Lt =] [l 1grere blank
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Figure 2-17: Create a list of acceptable
options or select one from the worksheet.
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Figure 2-18: Determine the action to take
when an invalid data enfry occurs.

When creating a list, if you want the available choices to appear when
the cell is selected, make sure to select the In-Cell drop-down check box.

On the Error Alert tab of the Data Validation dialog box, you can cus-
tomize the error message Excel displays if an invalid entry is entered.
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Locate Cells with Data Validation

Enter Data in Validated Cells

Indiana ERROR U

1. Click a cell that has a validation requirement.

DR

Coeor ] [comet | [Lewe |

Type data into the cell.

P Enter. O f two thi h :
ress Taier. Lone of tWo Tings Happens Figure 2-19: Entering data into validated cells.
e [f the data meets the validation rules, Excel accepts

the entry and moves to the next cell down.

™
o [f the data does not meet the validation rules, Excel e T e B
. . . 1 % v g
displays an error message similar to the one you see ey BruE oA EEREREH a3

in Figure 2-19.

4. Depending on the setting you selected on the Error Alert :
tab in the Data Evaluation dialog box, choose an option:

e Stop: Choose Retry or Cancel :

e Warning: Choose Yes or No or Cancel

e Information: Choose OK or Cancel 12

Locate Cells with Data Validation

1. To have Excel highlight all cells that have data validation, S s A0 - l

select one of the following methods (see Figure 2-20): Figure 2-20: Locating cells with data-validation restrictions.

¢ Choose Homer Editing=>Find & Select=>Data
Validation.

¢ Choose Homer>Editing=>Find & Select>Go To Special.
Select the Data Validation option, choose All, and
then click OK.

2. Click any cell to deselect the highlighted cells.
To remove data validation, choose Datac>Data Toolse>Data
Validation. From the Data Validation dialog box, click the Clear All
button and then click the OK button.
TEAM LinG
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Building Formulas

Fis chapter is all about the math. With Excel, you can create formulas to
perform calculations. The calculations can be simple, such as adding 2
plus 3, or they can be extremely complex, such as those used to calculate
depreciation. But don’t despair; you don't have to do most of the work.
Excel includes more than 335 built-in calculations, which are called
functions, in 11 different categories. Functions contain arguments, which
appear in parentheses following the function’s name. The arguments are the
details you provide to Excel to indicate which numbers to calculate in the
function. Some functions require several arguments to function correctly,
but again I say, don’t worry; Excel contains a Function Wizard to walk you
through the entire process.

The primary tasks in this chapter include:
w= Creating simple and complex formulas by typing them into a cell.
m=  Analyzing data with Excel’s time-saving functions.

w=  Creating cell ranges separated by colons for a sequential cell selection
or by commas to list specific cell locations.

»= FEvaluating formula errors and locating a cell’s precedents and
dependents.

| “*\apter

Getready to. ..

= (reate Simple Formulas ..........cccoooooeeenne... 28
w= (reate Compound Formuls........................ 29
= Add Numbers with AutoSum ..................... 30
w= Find an Average Value .........cccccceceeerreerene. 30
= Copy and Edit Formulas ...........cooeveeeenn.... 31
w= Define an Absolute Formula ..................... 32
= Copy Values Using Paste Specidl ................ 32
= Build a Formula with

the Function Wizard 33
w= Generate an IF Statement Formula ............ 34
w= Troubleshoot Formula Errors ...................... 35

= |dentify Formula Precedents
and Dependents 36
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Chapter 3: Building Formulas

Create Simple Formulas
with Operators

1.

28

Enter values in two different cells; remember, however,
formulas do not need to reference cell addresses. They
can contain actual numbers.

In the cell where you want to perform the calculation
for the two values, type an equal sign (=). All Excel for-
mulas begin with an equal sign.

Click or type the first cell address or type the first value
you want to include in the formula. In the example in
Figure 3-1, I'm adding two cell references (B5 and B6)
together.

s Excel displays a color border that surrounds the cell reference you
enter.

Type an operator. Operators can include:
e The plus sign (+)

e The minus sign (-)

e The asterisk (*) to multiply

e The slash (/) to divide

e The percentage symbol (%)

e The exponentiation symbol (*)

Type the second cell address or the second value you
want to include in the formula.

Press Enter and Excel displays the results of the calcula-
tion in the selected cell. (See Figure 3-2.)

s The formula bar at the top displays the actual formula.

Formulas can have multiple references. For example, =B5+B6+B6+B8
is a legitimate formula. Formulas with mulfiple operators are called

compound formulas.

= S o7
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Figure 3-2: A simple formula.



Create Compound Formulas

Create Compound Formulas

1
2.
3.
4
5.

Type values in three or more different cells.
Select the cell where you want the formula.

Type the equal sign and then the first cell reference.

Type the first operator and then the second cell reference.

Type the second operator and then the third cell reference.

Compound formulas are not limited to three references, and you
can use cell references multiple times in a compound formula.

Press Enter. Excel displays the results of the calculation
in the selected cell. The actual formula appears in the
formula bar. (See Figure 3-3.)

If you were paying atfention in your high school algebra class, you
might remember the Rule of Priorities. In a compound formula,
Excel calculates multiplication and division before it calculates addi-
tion and subtraction. This means that you must indude parentheses
for any portion of a formula you want calculated first. As an exam-
ple, in Figure 3-4, you see that the formula 3+5*2 gives a
result of 1.3, but (3+5) *2 gives a result of 1.6.

You can indude range names in formulos such as =D23 *
CommissionRate where a specfic cell is named
CommissionRate. See Chapter 2 about using range
names.

Compound formulas can have mulfiple combinations in parentheses
and can contain any combination of operators and references. A for-
mula might read ( (B5+C5) /2) *SalesTax. This
formula adds B5 and C'5, divides that result by 2, and then mul-
tiplies that result fimes the value in the cell named SalesTax.

A great tool to review formulas is the capability to display the actual for-
mula in the worksheet rather than the formula result. Choose Formulas=>
Formula Auditing=>Show Formulas. Click the Show Formulas button
again to return to the formula result.

& @
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Figure 3-3: A compound formula.

Figure 3-4: The Rule of Priorifies

in action.

TEAM LinG

29



Chapter 3: Building Formulas

Add Numbers with AutoSum

Click the cell beneath a sequential list of values.

Click Formulas=Function Library=>AutoSum. Excel
places a marquee (marching ants) around the cells
directly above the current cell. (See Figure 3-5.)

Press the Enter key to display the sum total of the
selected cells.

Find an Average Value

1.

30

After selecting the cell beneath a sequential list of val-
ues, click the arrow beneath the AutoSum button. Excel
displays a list of calculation options, including (see
Figure 3-6):

e Average. Calculated by adding a group of numbers
and then dividing by the count of those numbers.

e Count Numbers. Counts the number of cells in a
specified range that contain numbers.

® Max. Determines the highest value in a specified range.

¢ Min. Determines the lowest value in a specified range.

Choose Average. A marquee appears around the group
of cells. Highlight a different group of cells if necessary.

Press Enter. The selected cell displays the average value
of the cell group.

12 |EXPENSES

Figure 3-5: Using the AutoSum function.

Figure 3-6: Selecting
the Average function.

If the cells directly above the current cell have no values, Excel selects
the cells directly to the left of the current cell. If you want to add a group

@ of different cells, highlight them.

The formula bar displays the formula beginning with the equal sign and
the word SUM. The selected cells appear in parentheses, the first and
last cells separated by a colon.
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Edit a Formula

Copy Formulas with AutoFill

1.

Position the mouse on the AutoFill box in the lower-
right corner of a cell with a formula. Make sure the
mouse pointer turns into a black cross.

Click and drag the AutoFill box to include the cells to
which you want to copy the formula. (See Figure 3-7.)
The AutoFill method of copying formulas is helpful if
you're copying a formula to surrounding cells.

Copied formulas are slightly different than the originals because of
the relative change in position. For example, if the formula in cell
D23 is B23+C23 and you copy the formula to the next cell
down, to cell D24, Excel automatically changes the formula to
B24+C24. If you do not want the copied formula to change,
you must make the originating formula an absolute formula (see
the “Define an Absolute Formula” section lafer in this chapter).

Edit a Formula

1.

Double-click the cell containing the formula you want
to edit. The cell expands to show the formula instead of
the result. (See Figure 3-8.)

Optionally, press the F2 key to expand the formula so you can edit if.

Use the arrow keys to navigate to the character you want
to change.

Using the Backspace key, delete any unwanted characters
and type any additional characters.

Press Enter.

Press the Delete key to delete the entire formula and start over.

7800
3300

9

10| TOTA

5 a5 5 P P
[Croama] + ]

F-i-gure 3-7: Using AutoFill to duplicate a formula.

F-i-gure 3-8: Edit a formula.
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Chapter 3: Building Formulas

Define an Absolute Formula

1.

To prevent a formula from changing a cell reference
as you copy it to a different location, you lock in an
absolute cell reference using one of these methods:

e Lock in a cell location: Type a dollar sign in front
of both the column reference and the row reference
(as in $C$2). If the original formula in cell F5 is
=E5*$C$2, and you copy the formula to cell F6, the
copied formula reads E6*=$C$2 instead of E6*C3,
which is how it would read were it not absolute. (See
Figure 3-9.)

e Lock in the row or column location only: Type a
dollar sign in front of the column reference ($C2)
or in front of the row reference (C$2).

Copy the formula, as needed, to other locations. Notice
that the absolute cell reference in the original formula
remains unchanged in the copied formulas.

Copy Values Using Paste Special

32

1.

Select a cell (or group of cells) containing a formula and
then choose Homer>Clipboard>Copy. A marquee
appears around the selected cell.

Select the cell where you want the answer; then click the
arrow under the Paste button on the Home tab.

Choose Paste Special. The Paste Special dialog box,
shown in Figure 3-10, appears.

Select the Values option.

Click OK.

Rl TE T T T [ET——

Figure 3-9: A formula containing an absolute reference.
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Figure 3-10: Paste only the value, not
the formula with the Paste Special feature.
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Build a Formula with the Function Wizard

Build a Formula with
the Function Wizard

L.
2.

10.

Select the cell where you want to enter a function.

Click Insert Function, which is the icon located in the
lower-right corner of the Function Library group on the
Formulas tab. The Insert Function dialog box appears.

Select a function category from the Or Select a Category
drop-down list. (See Figure 3-11.)

To make the functions easier to locate, Excel separates them info
categories including Financial, Date, Math & Trig, Stafistical, Lookup
and Ref, Database, Text, Logical, Information, and — new to Excel
2007 — the Engineering and Cube categories. For example, the
Sum function is in the Math category, while the Average, Count,
Max, and Min are Statistical functions. Functions that calculate a
payment value are considered Financial functions.

Select a function name from the Select a Function list. A
brief description of the function and its arguments
appears under the list of function names.

Click OK. The Function Arguments dialog box displays.
The contents of this dialog box depend on the function
you've selected. Figure 3-12 shows the PMT function
that calculates a loan payment based on constant pay-
ments and interest.

Type the first argument amount or cell reference or click
the cell in the worksheet. If you click the cell, Excel
places a marquee around the selected cell.

Press Tab to move to the next argument.
Type or select the second argument.
Repeat Steps 7 and 8 for each necessary argument.

Click OK. Excel calculates the result.

Arguments in bold type are required. Those in normal type are optional.

ot Function (3]%]
gaarch for & Runction:

Tyge albwied descriphion of whal you veank 1o do ared then clek o |
o L J

©n select a gakngery: | Fnareid

a[<]

" : et Rieceraly ]
et afunction  |g
A YIELD IFmancl ’
COLPRICE [iste s T
COLYIELD Math i Trig
stansticsl
PPMT Lok & Rebrrsn
PRICE st s
PRICEDISC Tk e
Lol
PMT(ratenper sl s marion
Cakdstes the parmelErgeee ing el & constant
Iekerest rate,

I | |

Figure 3-11: Select from more than 335
built-in functions.

o I w—
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Figure 3-12: Specifying arguments for the PMT function.
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Chapter 3: Building Formulas

Genera te an IF Statement Formu,a Argumems in an IF statement can (l|SO Comﬂin formUI(]S.
1. Select a cell where you want to show the formula result.
A B C D E
2. Type the equal sign and then the word IF. 1
2 Loan amount 5 225,000
] 3 Monthly interest rate 0.52%
3- Type an Open parentheSIS ( 4 Num::n?roleé\-'r:enis 360
4. Begin the first argument by referencing the cell you want st st s 1sm50]
to check. For example, if you want to check whether cell 7 _ S — il
B10 is greater than 100, type B10. 2 Can | afford this? If{B5<B10,"VES | CAN","NO | CAN'T"]
10 My payment limit ._Q_l_thQﬂ
5. Type an operator such as equal to (=), greater than (>), 11
or less than (<). Figure 3-13: Entering IF statement arguments.
6. Type the value or cell reference you want to compare - _
against. BE - Jo | =IF(B5<B10,"YES | CAN","NO | CANT")
A B C D E
7. Type a comma to begin the second argument. - —— T
8. Type what you want Excel to do if the first argument is Rt o seriins 30
true. If you want Excel to display a value or cell value, pifometomont 3 13030
type the value or cell reference; but if you want Excel to ?
display text, enclose the text in quotation marks. (See Bl on  ttord this?
Figure 3—13.) 1-.r| My payment limit S 1,000.00
11
9. Type a comma to begin the third and final argument. Figure 3-14: The results of a statement that was NOT TRUE.

10. Type what you want Excel to do if the first argument is
not true. As before, type the value, cell reference, or text
you want Excel to display.

11. Press the Enter key. Excel displays the results of the
analysis in the selected cell. In Figure 3-14, you see the
result of NO I CAN'T in cell B8 because the payment
amount was not less than the limit.

34
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Troubleshoot Formula Errors

Troubleshoot Formula Errors

1.

Choose Formulasw>Formula Auditing=Error Checking.
If Excel finds potential formula errors in your worksheet,
it jumps to the cell containing the error and displays the
Error Checking dialog box shown in Figure 3-15. If the
worksheet contains no errors, Excel displays a message
box saying the error-checking is complete. Here are just
a few of the error types Excel might locate:

e DIV/0!: Divide by zero error. This error means the
formula is trying to divide by either an empty cell or
one with a value of zero. Make sure all cells referenced
in the division have a value other than zero in them.

e #VALUE!: This means the formula references an
invalid cell address. For example, text is in a cell
where the formula is expecting to find a value. You
might also see this error if you delete a value in a cell
that was used in a formula. Locate and correct the
invalid cell reference.

e NAME#: This occurs when Excel doesn’t recognize text
in a formula, perhaps because of a misspelling of a
range name. Make sure the name actually exists and
is spelled correctly. Also verify the spelling of the
function name.

e Circular: This means that the formula in a cell is
referring to itself. Locate the circular reference and
edit the formula so it does not include itself. Figure
3-16 shows a circular reference.

e Number Stored as Text: This means a cell
contains what looks like a value, but the content is
stored as text. Verify that you did intend to store the
value as a text entry.

Etror Chacking e

Erree in coll I

\pdate Feemuda to indude Celt |

=SUNEDET}
Formuin (ks Adiacont Cels L ielp o the erce ]
]
Eckt i Fprmuda e
e Casen) e

Figure 3-15: Let Excel find potential formula errors.
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Figure 3-16: Circular References: Where a formula refers to its own cell address.
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Chapter 3: Building Formulas

4.

e Formula Omits Adjacent Cells: This
means a formula refers to a group of cells that have
numbers adjacent to it. Study the formula to make
sure you didn’t forget to include additional cell refer-
ences in the formula.

Perform one of the following steps, depending on the
error type:

e (Click in the cell and edit the formula as needed. Click
Resume when you are finished.

e Click Ignore Error to jump to the next potential
problem.

e Click an option, if available, to allow the Error
Checking dialog box to assist you with repairing
the problem.

Click Next to review the next problem area. When
the error-check process is complete, Excel displays a
message box.

Click OK.

Identify Formula Precedents
and Dependents

36

1.

Select a cell that contains a formula or one that is refer-
enced in one or more formulas.

Choose Formulas=>Formula Auditing=>Trace Precedents
or Trace Dependents. Excel displays one or more blue
arrows pointing out either precedents or, as shown in
Figure 3-18, dependents.

Click Remove Arrows. The blue arrows disappear.

Formulas Data Review View
4 Lookup & Reference - .g A2 Define Name ~ %32 Trace Preced ﬂ
b Math & Trig - — P wla <2 Trace Depend=n SRR ==
Py . Mame . N Watch
fif More Functions - Manager B Creste from Selection . Remove Arows ~ (&) Window
Defined Names Formula Auditing
o .
Figure 3-17: Show formulas instead of resulis.
73537
B C (V] E F G H I
January February March  April May Jjune  TOTALS

13458 14938 16582 14428 16013 17774 93191
66250 BL626 FHMS 7RG B7497—= 458751

11810 13100 14551 12659 14052 15597 B1778
750 800 900 900 775 825 5040
7600 B436 9363 8146 9042 10037 22624
3900 0 3800 1] 3900 o 11700
5 25 25 5 15 5 150

103793 M10935 126947 107171 122633 131755 703234

Figure 3-18: Tracer arrows indicate formula precedents or dependents.

To help you determine the nature or origin of the problem, some error
messages have a Show Calculation Steps button to display the logic
behind the formula.

Another great troubleshooting tool is the capability to display the actual
formula, instead of the result, in the worksheet. Choose
Formulas=>Formula Auditing=>Show Formulas. Click the same button
again fo return to the formula result. (See Figure 3-17.)

Dependent cells are those that are referred fo by a formula in another
cell. Precedent cells are those that contain formulas that refer fo other
cells.
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Protecting Excel Data
I “*\apter

W)rksheets often contain numerical information that is confidential in
nature, such as financial or payroll data. In today’s world of elec-
tronic snooping, it's up to you to protect your work against prying eyes.
Fortunately, Excel provides a large number of security tools such as password
protection, hiding sensitive worksheet areas, or locking data against
unwanted changes.

This chapter is about the security concerns surrounding Excel workbooks. I'll

show you many distinctive protection methods including how to: Get reqdy to...

** Hide all or selected areas of a workbook w= Quickly Hide an Open Workbook............... 38

= Specify that users can view a file but not modify it w=> Make a File Read-Only 18

" Restrict the access to designated worksheet ranges w= Open a File as Read-Only .......ccooee......... 39

»= Mark a file as final to protect it from changes .

. _ w= Mark a Workbook as Findl ........................ 39

m=  Assign passwords to open or modify a workbook Hide and Unhide R 16l 10
Iy

m= Remove private data from a workbook before sending it on to others. gt L
w= Unlock Cells 40
w= Protect Worksheets 41
w= Restrict User Data Entry .........coovvvveeneee. 42
w= Enter Data in a Restricted Area ... 43
w= [nspect for Private Information .................. 43
w= Hide Cell Formulas 44
= Assign a File Password ...........cccooeeeeveeenne. 44
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Chapter 4: Protecting Excel Data

Ouickly Hide an Open Workbook

1.

3
4.

Choose ViewroHide. Excel hides the current workbook,
leaving the Excel program open and visible. If you have
another workbook open, you see that workbook, but
not the hidden workbook.

Choose Viewr>Unhide. Excel displays the Unhide
dialog box listing all hidden workbooks, as you see in
Figure 4-1.

Select the workbook you want to unhide.
Click OK.

Make a File Read-Only

1.

38

Choose Office Buttont>Save As. The Save As dialog box
opens.

Optionally, select a file location from the Save-in drop-
down list.

Enter a filename.
Click the Tools button. A drop-down menu appears.

Choose General Options. The General Options dialog
box, shown in Figure 4-2, appears.

Click the Read-Only Recommended option.
Click OK.
Click Save.

Figure 4-1: Hidden workbooks do not even appear on
the Windows taskbar.

i ] e |

Figure 4-2: Protect aguinst accidental changes by making a file
Read-Only accessible.

The Read-Only option is only a recommendation. Users can save
changes to a read-only file by giving it a different name or saving it in
a different folder.
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Mark a Workbook as Final

Open a File as Read-Only or Copy

1.

Choose Office Button>Open. The Open File dialog box
appears.

Locate and select the file you want to open.

Click the arrow on the Open button. A list of options
appears. (Figure 4-3).

Choose Open Read-Only or Open as Copy. The file
opens.

To save any changes to the file, you must choose
Homer>Save As and specify a different file name.

©)

If you open a file as a copy and do not use the Save As option, Excel
uses the filename “Copy (#) filename” where # represents the copy
number and filename is the current filename.

Mark a Workbook as Final

1.

Choose Office Buttont>Finishe>Mark as Final. The mes-
sage box seen in Figure 4-4 appears.

Click OK.

If you have not yet saved the file, the Save As dialog box
appears. Enter the filename and save the file. Otherwise,
Excel saves the file and the words Read-Only appear next
to the filename on the Title bar.

The Mark as Final feature is designed to prevent accidental changes
and is not permanent. If you find you need to make changes to the
workbook, choose Office Button=>Finish=>Mark as Final again fo
turn off the Read-Only function.

o |
2 x|
B o8
ey e -
P s
Chi| -5 il =3 =
o Ol s i
=4 £l Bl El
S OE = " 8\
- SoATEs Mottty Woun  mbes
Purdgets 06 Bucigats 2007
B OB - O/ o
. arg Tt Open Bead-Only
e Open as Copy
T Prre—
Open and Repair...

[ ST [ Cem ]

Figure 4-3: Different approaches fo opening your workbook.

Miciasalt Excal =]
_!B This werkbock vl be marked a3 final ard then saved.
o] Comm

Figure 4-4: Marking a workbook
as final makes it a read-only file.
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Chapter 4: Protecting Excel Data

Hide and Unhide Rows and Columuns

1.

Select the column or row headings you want to hide. If
you want to unhide rows or columns, select the row or
columns both before and after the hidden rows or
columns.

Choose Homer>Cells>FormatoHide and Unhide. A
menu of options appears.

You cannot hide selected cells; only entire columns or rows.

Make a selection. In Figure 4-5, notice that columns
D & E are hidden and seem to have disappeared.

Unlock Cells

40

Select the cells you want users to be able to modify.

Choose Homew Cells=>Format=>Cells, which displays
the Format Cells dialog box.

Click the Protection tab, as shown in Figure 4-6.
Deselect the Locked option.
Click OK.

Optionally, choose Homeco Cells=>Formate>Lock Cells. Because, by
default, Excel locks all cells, choosing this option turns the Lock Cells
option off. Click the option again to turn on the Lock Cells option.

T @0
T o (] (G " B
o T v
ey (B g E S -A B ER o s

) - g &
1 Jarary THG june  TOTALS

2 INCOME
13458 14938 18013
66250 73537 7826
11810 13109 14052

Repair Revenue 750 890 75
7 Referral Income 7600 8436 5042
3 3900 @ 3900
g 5 5 5
C 103793 110935 122633 131755
11

g Maintenance 1150
ng Maintenance 750

siness Liability Insurance 1835

310 310 180 160

667 667 667 667

°

[h OO s i)

Figure 4-5: Hide worksheet columns.
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Figure 4-6: Unlocked cells can be edited in a protected
worksheet.
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Protect Worksheets

Protect Worksheets

1.

Click the area on the sheet that you want to protect and
then choose Reviewr>Changes=>Protect Sheet. The Protect
Sheet dialog box appears, as shown in Figure 4-7.

Make sure the option Protect Worksheet and Contents
of Locked Cells is checked.

Optionally, in the Password to Unprotect Sheet text box,
type a password. For privacy reasons, only a series of
dots appears.

From the Allow All Users of the Worksheet To box,
select any options a user is allowed to change without
unprotecting the worksheet.

Deselecting the Select Locked Cells option doesn't allow an unau-
thorized user to even click a locked cell. All cells are considered
locked unless you unlock them, as you see in the next section.

Click OK.

If you generated a password, a Confirm Password dialog
box appears. Retype the password and then click OK
again.

In the protected worksheet, attempt to change the value
in a locked cell. Excel displays the error message shown
in Figure 4-8.

To unprotect the worksheet, choose Reviews>Changes=>
Unprotect Sheet.

Enter the password if prompted.

Protect Sheet 2] ]
7] Protect werksheet and contents of locked cols
Batomord 1o urerotact shast:

Alps ol o f Lhis wmimbsbue boi

Figure 4-7: Protect a worksheet against accidental or unwanted changes.

TSR ERET™ =3
The cell or chy ht i otected
i\

To modfy chast, frst
Changes grou). You may be prompted for & password,

et
Figure 4-8: Typing in a locked cell prompts an error message.

TEAM LinG

41



Chapter 4: Protecting Excel Data

Restrict User Data Entry

1.

42

In an unprotected worksheet, choose
Reviewr>Changesm>Allow Users to Edit Ranges. The
Allow Users to Edit Ranges dialog box appears.

Click New. The New Range dialog box, shown in
Figure 4-9, appears.

In the Title text box, type a short descriptive name, such
as Qty Shipped or Price, for the data entry area.

In the Refers To Cells box, enter the range you want
to allow users to edit. Begin the range with an equal (=)
sign.

Enter a password that the user must type to gain access
to the cell range. Passwords are optional, but without
one, any user can enter data into the range.

Click OK. The Confirm Password dialog box appears.

Retype the password and then click OK. The Allow Users
to Edit Ranges dialog box appears with the newly cre-
ated range. (See Figure 4-10.)

Choose one of the following:

e Click Protect Sheet to launch the Protect Sheet
dialog box. (See “Protect Worksheets” earlier in this
chapter.)

¢ Click Apply and add another cell range.

e Click OK to accept the changes and close the dialog
box, but not protect the worksheet.

©)

Excel doesn’t enable the feature unfil you protect the work-
sheet.

Allow Users to Edit Ranges (O[]
o ctactad

Tl Refers to cells b |

Dossge SOPA 080 [———

P 2 | oty |

|

:wm«ll o | [Lonca ][ e ]

Figure 4-10: This dialog box displuys restricted ranges.
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Inspect for Private Information

Enter Data in a Restricted Area

1.

4.

On a protected worksheet, in any cell with restricted
access, begin typing data. The Unlock Range dialog box
you see in Figure 4-11 appears.

Type the password. Passwords are case-sensitive.
Click OK. Excel allows access to the specific range.

Continue entering cell data as desired.

Inspect for Private Information

N N U S R

Save the Workbook.

Choose Office Button=>Finishe>Inspect Document.
The Document Inspector dialog box appears.
Deselect any option you do not want to check.

Click Inspect. Excel inspects the document for the
selected information.

When the inspection is complete, the Document
Inspector reappears with information as in Figure 4-12.

Click the Remove All button next to any option you
want removed. Excel removes the selected data. After
removing the data, the Remove All button next to the
option disappears.

Repeat Step 7 for any additional items you want to
remove.

Click Close and save your file.

Unlack Range
m A ool you are brying Lo change i passwond
protectad.

friter the passwond to changs ths cell:
(I

Figure 4-11: A password can be
required fo enter data into the range.
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Figure 4-12: Inspect your workbook for hidden or
personal information.
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Hide Cell Formulas

Select the cells containing formulas or information you
want to hide.

Choose Homer>CellsoFormatt>Cells. This displays the
Format Cells dialog box.

Click the Protection tab and select the Hidden option.

Click OK. In Figure 4-13, although you see the results of
the formula in cell F12, the formula bar does not dis-
play the actual formula.

Assign a File Password

1.

44

Choose Office Button=>Save As. The Save As dialog box
opens.

Click the Tools button and then select General Options.
The Save Options dialog box appears.

Type a password in the Password to Open text box if
you want users to enter a password before they can
open and view the workbook. (See Figure 4-14.)

Retype the password to open; then click OK. Retype the
password to modify; then click OK. Click Save.

Open the password protected file, which displays the
Password dialog box.

Type the Open password; then click OK.

If prompted, type the password to allow modifications
and click OK. The protected file opens.
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Figure 4-13: Keep cell data from appearing on the formula bar.
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Figure 4-14: Protecting a workhook from unauthorized viewing or modifications.
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Part |
Sprucing Up Your
Spreadsheet

T_he 5th Wave By Rich Tennant
®

ENNANT

“T’ve used several spreadsheet programs, but
this is the best one for designing quilt patterns.”
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Formatting Cells

Whoever said “Looks aren’t everything” wasn’t staring at an unformat-
ted Excel spreadsheet. Columns often aren’t wide enough, fonts are

too small to read, dates display in an unusual manner, and when columns
of data are stacked next to each other, sometimes the information overlaps.

Fortunately, Excel includes a plethora of features to make your data more
presentable and easier to read. In fact, it has so many appearance-altering
features, I had to break them up into two chapters! After you master the
Excel formatting features in this chapter, you can.

== Change the font type, size, and style of text, values, or dates.

== Change the alignment of data in a cell from the standard left-aligned
for text and right-aligned for values or dates.

w= Turn values into currency or percentages.
w= Create titles using the Excel Merge and Center button.

w= Change column width and row height.

| “*\apter

Getready to. ..

w= Format Values 48
e Adjust Column Width ........oooeeeeecccccceeene. 49
= Change Row Height 50
w= Align Data Horizontally & Vertically............ 51
w= (reate a Title by Merging Cells .................. 52
= Change Font Color 52
w= Select Font Attributes 53
w= Apply Cell Background Colors .................... 53
w= Wrap Text in a Cell 54
w= Rotate Text 54
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Chapter 5: Formatting Cells

Format Values

48

1.

Select the cells you want to format. You can select a few
cells, entire rows, entire columns, or the entire work-
sheet. (See Chapter 3 for information on selecting mul-
tiple cells.)

Choose Homer>Number>Number Format. A list of
options appears. Figure 5-1 shows values formatted in
various Excel styles. Notice the different dollar sign
placement in the Accounting and Currency types.

The Number group on the Ribbon also displays three icons you can
use to quickly format as Accounting, Percentages, or Comma. The
Accounting option has a drop-down list from which you can select dif-
ferent international currency symhols. Percentages add a percent sign
and no decimal points. The Comma option adds two decimal places
and a comma between the thousands. It does not include a dollar
sign.

To remove digits to the right of the decimal point, choose
Homer>Number=>Decrease Decimal. To add decimal dig-
its, click the Increase Decimal button. Each click adds or
removes a number to the far right of the decimal point
and rounds the value in the cell. See Figure 5-2.

If you see a cell with values displaying ####5#%#, you need to widen
the column width. See the next section.

Another method to select number formatting is using the Number
dialog box launcher, which displays the Format Cells dialog box.
Number format selections are on the Number tab.

Excel numbers can display up to 30 decimal places.

FLEC) " -
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Figure 5-1: Numeric values formatted with different styles.
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Figure 5-2: Easily add or remove decimal places.
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Adjust Column Width

Adjust Column Width

1.

To adjust the width of columns headings, highlight the
ones to be widened. If you want to adjust a single col-
umn, click any cell in that column.

If your worksheet contains many numbers, you can widen the
columns to make the worksheet less cluttered. Columns that espe-

cially need widening are those containing cells with truncated fext
entries or numbers that Excel shows as ######.

Choose a method to adjust column width:

To manually change the width of columns, position
the mouse pointer on the right boundary of the col-
umn heading until it turns into a double-ended
arrow. Drag until the column is the width that you
want. As you move the pointer, a balloon message
displays the new width. In Figure 5-3, I'm expanding
column A.

mum is 255 characers.

Excel displays cell width in characters and pixels instead of in
inches. The minimum column width is 0 characters and the maxi-

To set column width to a specific setting, choose
Homer>Cells>Formate>Width. The Column Width
dialog box, shown in Figure 5-4, appears. Type the
exact width you want; then click OK.

To automatically change the column width so it fits
the widest entry, double-click the boundary on the
right side of the column heading or choose Homer>

Cells=>Format=>AutoFit Selection. Excel sets the width

slightly larger than the longest entry in the column.

b e A W]

th O Gl |00 ). it

Figure 5-3: Manually changing column width.

The default column width is 8.43 based on the default 11-point Calibri
font. If you change the default font type or size, Excel may also change
the standard column width. You can manually set a default column width
by choosing Homec> CellseoFormate>Standard Width.

Colimn Widih (2]
Cohamwati 25|

o) o
Figure 5-4: Set a specific column width.
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Chapter 5: Formatting Cells

Change Row Height

50

Highlight the row headings whose height you want to
adjust. If you want to adjust a single row, click any cell
in that row.

2. Choose a method to adjust row height:

¢ To manually change the row height, position the
mouse pointer on the bottom boundary of the row
heading until it turns into a double-ended arrow.
Drag until the row is the height that you want. As
you move the pointer, a balloon message displays the
new height. In Figure 5-5, I'm increasing the height
of rows 1 and 2.

Excel displays row height in characters and pixels instead of in
@ inches.

e To set row height to a specific setting, choose Homer>
Cells>Formatr>Height. The Row Height dialog box,
shown in Figure 5-6 appears. Type the exact width
you want; then click OK.

e To automatically change the height of the row so it
fits the tallest entry in the row, double-click the
boundary on the bottom of the row heading or
choose Homer>Cellse>Format=>AutoFit. Excel exam-
ines the rows contents and sets the height slightly
larger than the tallest entry.

The default row height is 15 based on the default 11-point Calibri
font. If you change the default font type or size, Excel may also
change the standard row height. You cannot manually set a default
row height.
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Figure 5-5: Manually changing row height.
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Figure 5-6: Enter the desired row height for the selected rows.
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Align Data Horizontally and Vertically

Align Data Horizontally
and Vertically

1. Select the cells you want to align.

2. Choose Homer>Alignment; then, select one of these
alignment buttons:

Align Left: Horizontally aligns the data along the left
edge of the cell.

Center: Centers the data horizontally in the middle
of the cell. If you modify the column width, the data
remains centered to the new column width. Cells B4
through G4 are center-aligned in Figure 5-7.

Align Right: Horizontally aligns the data along the
right edge of the cell.

Values formatted as Accounting can only display as right-aligned.
You can change alignment on all other formatting styles.

Top Align: Aligns the data vertically along the top
edge of the cell.

Middle Align: Centers the data vertically in the cell.

Bottom Align: This is the default option and aligns
the data along the bottom edge of the cell. Notice the
heading in Figure 5-8. Row 1 shows a top vertical
alignment, whereas row 2 shows the default bottom
alignment.

Optionally, you can view additional alignment options and align both
the horizontal and vertical alignment at the same time using the

Format Cells dialog box. From the Home tab, click the Alignment
group dialog box launcher. If necessary, click the Alignment tab and
then set any desired alignment options; then click OK.
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Figure 5-8: Vertical cell alignment.
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Chapter 5: Formatting Cells

Create a Title by Merging Cells g G

1. Select the cell containing the data you want to merge . :
and the cells you want to include in the merge. The data - e
cell must be in the left cell of the selection and the other
cells cannot contain data. This is shown in Figure 5-9.

2. Choose Homer>Alignmentr>Merge and Center. All the
selected cells merge into one larger cell, and the data is
horizontally centered.

If you select cells vertically and choose the Merge and Center com-
mand, Excel merges the cells and vertically bottom-aligns the data.

After clicking Merge and Center, you can change the alignment.

Click the Merge and Center button again to unmerge the cells from A —— . (30 Gy
each other. Figure 5-9: Merging cells can create a fitle for your worksheet.
”'_l'JA'J g E 1 £ o
Change Font Color e T ke memie @ o o e 24 g
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1. Select the cells you want to format. T —c— T — = : —"
- B EEEEEEE| - - - - =
2. Choose Homer=>Font and click the Font Color drop- : il
down arrow to select a color. Again, Excel’s Live Preview ! -s_m[*!lllll
feature, as you see in Figure 5-10, shows you the selected : RS
cells in the new font colors. '
Click More Colors to display the Colors dialog box from which you
can select additional colors as well as create your own custom color.
Another method to select Font color is through the Font dialog box
launcher, which displays the Format Cells dialog box. Font color __
selection is on the Font tab. ol e e

52 Figure 5-10: Choosing a font color.
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Select Font Attributes

Select Font Attributes

Select the cells you want to format.

On the Home tab, open the Font drop-down menu and
select a font. As you hover your mouse over a font face,
Excel displays the selected cells in the different fonts.

From the Homer>Font group, click the Font Size arrow
and select a font size.

From the Home=>Font group, click an attribute such as
Bold, Italics, or Underline. (See Figure 5-11.)

Apply Cell Background Colors

1.

Select the cells to which you want to add background
color.

From the Home tab, in the Font group, click the down
arrow next to the Fill Color icon. A gallery of colors
appears. (See Figure 5-12.)

Select the cell background color you want.

Select No Fill to remove any cell background shading or choose
More Colors to create your own shading color.

A good combination to use with a black and white printer is a black
background and a white font color.
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Figure 5-11: Direct attention fo certain cells by changing font attributes.
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Chapter 5: Formatting Cells

Wrap Text in a Cell

Select the cells you want to format.

Choose Homer>Alignment=>Wrap Text. As in Figure 5-13,
if the selected text cells contain more text than will fit
the width of the cell, Excel displays it on multiple lines.
Notice that Excel automatically increases row height to
accommodate the additional text lines.

Rotate Text

54

Select the cells you want to format.

Choose Homer>Alignment>Orientation. A list of
options appears:

¢ Angle Counterclockwise: Angles the text in the cell
from left bottom to right top.

¢ Angle Clockwise: Angles the text in the cell from left
top to right bottom.

e Vertical Text: Centers the text and places one letter on
top of the other.

e Rotate Text Up: Places the text on the lower-right side
of the cell and runs it vertically up the cell.

e Rotate Text Down: Places the text on the lower-left
side of the cell and runs it vertically down the cell.

Choose an option. The selected cells take the rotation
you choose. In Figure 5-14, the cells are angled counter-
clockwise.
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Figure 5-14: Rotate cell data to add a special effect.
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Appluing Additional -
Formatting Options *\apter

In the previous chapter, you discovered many of the Excel features
designed to change the cell data appearance. In this chapter, you discover
a few more of the exciting Excel formatting utilities created especially to
make your worksheet more interesting and easier to read:

= Save time with the Mini Toolbar and the context-sensitive menu. Get ready to...
w= Liven up the worksheet with effective use of borders and lines. = [Jse the Mini Toolbar 56
w= Format cells containing dates and discover ways to use dates in w= Change the Default Font ...........cooccoee... 56
calculations. Ploce Bord {6l 5
)
> Reduce redundancy with the format painter. ace borders around Cells ................c.....
w=  Effectively use predefined styles and themes that carry a single design = Work with Date FOrMtS ... 5
through all office products. w= Use Dates in a Calculation............occcocn... 58
»= Specify conditional formatting to designate cell appearance if the cell = Copy Formatfing 59
value conditions are met.
w= Indent Data in Cells 59
w Use Cell Styles 60
w= Format Cells as a Table ............ccoovccccecne. 60
= Specify Conditional Formatting .................. 61
w= Add Data Visualizations.............ccoocccevrrene 62

TEAM LinG



Chapter 6: Applying Additional Formatting Options

Use the Mini Toolbar B ——

1. Right-click a cell or a group of cells. As you see in
Figure 6-1, the Mini Toolbar and short-cut contextual
menu appear.

The Mini Toolbar contains many of the formatting commands avail-
able on the Home tab, making it unnecessary for you to actually

switch to the Home tab.

2. Choose the formatting attribute you want to apply. The
cells take the selected attributes, and the Mini Toolbar
remains open for you to make additional selections. .,

1150 TI50 TS50 TI50

3. Click any cell to close the Mini Toolbar. g5 20 250 om0
Figure 6-1: Quickly choose formatting options.

Change the Default Font

1. Click the Office Button and then click Excel Options.

2. Ifitis not already displayed, click Personalize. (See
Figure 6-2.)

Click the Use This Font drop-down list.

4. Select the font type face you want to use in all new
workbooks.

5. Open the Font Size drop-down menu and select the font
size you want to use in all new workbooks. Click OK.

6. A message box appears. Click OK.

7. Exit and restart Excel. e [
Figure 6-2: Select the font you use most often.

56
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Work with Date Formats

Place Borders around Cells

1. To add a border, select the appropriate cells.

2. Choose Home>Font and then click the arrow next to
the Borders button. A variety of border options, as you
see in Figure 6-3, appears.

The Borders tooltip button may display Bottom Border, Top Border,
or whatever horder was last used.

3. Select the border you want. Excel applies the border to
the selected cells.

For more border styles, colors, and options, click the More Borders
option to open the Format Cells dialog box.

Work with Date Formats

1. Enter a date into a cell. Depending on what you type,
Excel probably displays the date in a different format.
Figure 6-4 illustrates some date examples.

Dates are actually numeric values, and you can use them in Excel
calculations. See the next section.

2. From the Home tab, click the Number dialog box
launcher, which displays the Format Cells dialog box.

3. Click the Date category. The right side of the screen dis-
plays a variety of different date formats.

4. Select a format for the selected cells.

Click OK.

Optionally, dick Short Date or Long Date from the Number Format drop-
down list in the Number group on the Home tab.

Harringten L -A" A
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'om Border

Top Barder

| Left Border

Right Border
No Border
All Borders

Qutside Borders

BHE B

Thick Box Border

Bottom Double Border

Thick Bottom Border
Top and Bottom Barder
Top and Thick Bottom Border

Top and Doyble Bottom Border

i I EEE

More Borders...

Figure 6-3: Creating border lines for cells.

| 971672006
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You enter Excel displays
916 16-Sep
“a/16/086 9/16/2006
9/16/2006 9/16/2006
Sep 16 I 16 Scr;l
Sept 16 16-Sep
September 16 16-5ep
Saptambar 16, 2006 16-5ep-06
9/16 9/16/2006  Short Date
af16 Saturday, September 16, 2006  Long Date

Figure 6-4: Excel automatic dute formats.
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Chapter 6: Applying Additional Formatting Options

Use Dates in a Calculation

1.

58

Enter a date into a cell. You can format the date any way
you want.

Enter another date into another cell.

To have the cell dynamically display the current date, enter
=Now ( ). To enter today’s date as a static entry, press Cirl+;
(semicolon). To enter the current time as a static value, press Cirl+:
(colon).

To find the difference between the two dates, create a
formula that subtracts one date from another. For exam-
ple, if you put the first date in cell A1 and the other date
in cell A2, then in cell A3 or wherever you want the dif-
ference to appear, enter =A1-A2. Excel returns a value,
but it is formatted in a date pattern rather than in a
numerical pattern (which is what you want). Your answer
probably looks something like what you see in Figure 6-5.

To calculate the number of days between a specific date and the
present time, enter the specific date in a cell such as A1 and then in
another cell enter the formula =A1-NOW().

With the answer cell (A3) selected, choose
Homew Font>Number Format.

Select Number. Excel changes the date value to a numer-
ical value. (See Figure 6-6.)

The reason Excel initially returned an unusual date is that dates are
really serialized values beginning with day 0 af December 31, 1899.
When you create a formula involving date formats, Excel naturally
returns a date format. In the Figure 6-6, the first formula resulted in
1/10/1900, which is 10 days after December 31, 1899. Therefore,
there are 10 days between the values in cells (4 andB4.

A B
+ Planting Record
2

Date Date
Typa & of Days

3 i Planted Germinated ¥
4  sunflower 5/1/2006 Sfil.lrlfl[)ﬁl 1/10/1900 |
5 Calendula 5/1/2006 5/15/2006 1/14/1%00
& Poppy 5/10/2006 5/28/2006 1/18/1900
7 Cormnflower 5/6/2006  5/18/2006 1/12/1900
& Marigold 41812006  4/25/2006 1/7/1900
9 Zinnia 412373006 5/ 22006 1/8/1800
10 Nasturtium 5/3/2006 5/13/2006 1/10/1%00

Figure 6-5: Calculate the difference between two dates.

A

B

Planting Record

Date Date

3 jiad Planted  Germinated ¥oiDaye

4 Sunflower 5/1/2006  5/11/2006 10
5 Calendula 5/1/2006 5/15/2006 14
& Poppy 5/10/2006 S5/28/2006 18
7 | Cornflower 5/6/2006  5/18/2006 12
& Marigold 4/18/2006  4/25/2006 7
4 Zinnia 472372006 5/2/2006 9
10 Masturtium 5/3/2006 5/13/2006 10

Figure 6-6: Change a date-formatted value to o numerical-

formatted value.
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Indent Data in Cells

S RITENI R ey P ;% .- & !.»_..._. .. _ 8
1. Click a cell containing formatting you want to copy. o e s o 9

2. Choose Homer>Clipboard=>Format Painter. The mouse L e L Ll P [ 8 [« - -
. . . . . . . \ ABC Produelion Company
pointer is a white plus sign along with a paintbrush like - 2007 Budsel ‘
the one you see in Figure 6-7.

3. Click or drag across the cells you want to format. Excel
immediately applies formats such as font, size, colors,
borders, and alignment.

Double-click the Format Painter fool to lock it in so you can paint
additional cells without having to reselect the tool. Click the Format
Painter fool again to unlock it.

To quickly copy the width of one column to another column, select the S tg———

heading of the first column, click the Format Painter tool, and then click ormat Painfer ool 1o duplicafe formunir; elecions '

the heading of the column where you want to apply the column width. p g )
(o FLE e - = =
Indent Data in Cells b e | e @ (o B D 5 p gy
ey (BRI BS-AEERRER G g S s 7 selllin
Select the cells you want to indent. TE— T L — i
. : ABC produelion Co
2. Choose Homer>Alignmentr>Increase Indent. Each Increase . = p;zo?;zgse.mpmg

Indent click adds a small amount of space between the
cell border and the data itself. (See Figure 6-8.) How
Excel indents depends on how you format the cell:

o If the data is left-aligned, Excel indents to the left.
e If the data is right-aligned, Excel indents to the right.

o [f the data is centered, with the first click, Excel
indents to the right; but subsequent clicks cause
Excel to move the data to the left.

Click the Decrease Indent button fo remove indentation. B Ll e——
Figure 6-8: Indenting helps set data apart from other cells.
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Chapter 6: Applying Additional Formatting Options

Use Cell Styles

Select the cells you want to format.

Choose Homer>Styles>Cell Styles. In Figure 6-9, you see
that Excel displays a gallery of predefined styles.

Select the style you want to use.

Format Cells as a Table

60

Click anywhere in the data you want to format as a table.

Choose Home= Stylese>Format as Table. A gallery of
Excel-themed formats appears. (See Figure 6-10.)

Themes are predefined style sets that appear across the entire Office
suite, providing consistency in your work appearance.

Select the table style and theme you want to use. The
Format as Table dialog box appears.

Confirm that the selected cells contain the data you
want to format.

If the top row of your selection contains the headers,
make sure the My Table Has Headers option is selected.

Click OK. Excel formats the table and applies filter
arrows to each header. (See Chapter 14 for information
about filtering.) The Table Tools Design tab appears.

[
g
;|

Guod. Bad and Neutral
Normal Good Neutral
Data and Model

Input

m
W
a

Note Output Warning Text
Titles and Headings

Heading 1 Heading 2 Heading 3 Heading 4
Sheet ... Tvotal

Themed Cell Styles

m Accentl - 20%  Accentl-40% [
m Accent2-20% Accent2-40% | LUCHTEER
Accent3 i Accents - 405
m Accentd - 20%  Accentd-40% |V

AccentS- 20%  AccentS- 40%

Accents - 40%
npi $37] [Emphasis 3
Huember
Comma Comma [0] Currancy Currancy [0]

Percent

Figure 6-10: Manage data better with an Excel table.
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Specify Conditional Formatting

Sp ec ify Co n ditio na ( F0 rm attin q To dear conditional formats, go to the Home tab and choose Stylesc>

Conditional Formatting=>Clear Rules=>Selected Cells.

1. Select the cells to which you want to apply conditional
formatting.

Reasons for using conditional formatting might include locating =y mauim
dates that meet a certain condition (such as falling on a Saturday -
or Sunday), specifying highest or lowest values in a range, or indi-
cating values that fall under or over a specified amount.

Tara i Than v} i ' " v =

2. Choose HomeStyles=>Conditional Formatting=
Highlight Cell Rules.

3. Select the criteria you want to use. Criteria options
include Greater Than, Less Than, Between, Equal To,
Text That Contains, A Date Occurring, and Duplicate
Values. A dialog box opens, where you can specify the
value. In Figure 6-11, in order to see which items went ; :
over budget, you use the Greater Than criteria. z =tre_ e T S

4. Enter the values you want to reference in the text box. Figure 6-11: Specifying conditions for formatting options.
The number of boxes depends on the criteria you
selected in Step 3. You can type a value here, such as o 4700
500, or you can reference a cell address such as F13. R

5. Click the drop-down arrow next to the format options ; 3
s0 you can specify the format options to employ if the ——— : - -

condition you specified is true. Live Preview shows you s Ak
what your data will look like. o

Click the Custom Format option, where you can create your own for-
mat, selecting from font styles and color, numeric and other for-
mats, borders, patterns, or background color.

6. Click OK. In Figure 6-12, you see formatting options
applied to seven cells that meet the specified criteria of
being greater than 0 (meaning, in this example, items
over budget).

| SE—— |
e 0 de it

7. Repeat Steps 2 through 6 to apply any additional Figure 6-12: In this example, conditional formatting options include
conditions. applying a font color change and a background color. TEAM LinG



Chapter 6: Applying Additional Formatting Options

Add Data Uisunalizations

1.

62

Select the cells to which you want to apply formatting.
Choose Homer>Stylese>Conditional Formatting.

Select from the following options. (Figure 6-13 shows
an example of all three data visualizations.)

e Data Bars: A gradient-style bar helps you see the
value of a cell relative to other cells. The length of the
data bar represents the value in the cell, so a longer
bar represents a higher value and a shorter bar repre-
sents a lower value. The data bars have six different
color options designed to match Excel themes.

e Color Scales: Designed to visually help you under-
stand your data, color scales compare a range of cells
by using two colors representing higher or lower val-
ues or three colors representing higher, middle, or
lower values. The color scale bars come in eight dif-
ferent color themes, including red, yellow, and green.
You can also create your own scheme by choosing
More Rules under the Color Scales options.

¢ Icon Sets: Icon sets help you classify data into three,
four, or five categories with each icon representing a
range of values such as higher, middle, and lower. As
shown in Figure 6-14, icon sets include arrows, traffic
lights, clocks, and even smiley faces.

The icon size you see depends on the cell font size. You may need
to adjust the column width to accommodate the icon.

To clear visualization formatting, select the formatted cells and then
choose Home=>Styles=>Conditional Formatting=>Clear Rules=>
Selected Cells.

oy a9
& T 7, e A ] g f B I o Ly Y
; B U T AL EEE R G .: f " 5 o !
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1 | 165 34 165
2 | 735 4 174
3| 398 3 398
1 1720 z Bt 1720
5 | 269 169 3 169
6 72 i 72 4 72
7 I 864 864 > 864
8 DATABARS COLOR SCALE ICON SET
9
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12
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Figure 6-13: Using data visualizations.
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Figure 6-14: Select the icon symbol you want to use
to represent your data.
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Designing with
Graphics | "%apter

Sometimes, even after adding font and style attributes to cell data, you
still want to call extra attention to specific areas. Maybe you'd like to
add an arrow to point to a specific area. What? You can’t draw a straight
line? That's not a problem because with Excel, you don’t have to be a gifted

artist to draw. Get ready to

Whether you want to draw circles, squares, lines, or arrows, Excel provides

tools to assist you, making the drawing process fun and easy. e [llustrate with ArTOWS .......oovveeeeseerrreerre 64
In this chapter, you discover how to: w= Draw Using Shapes 65
»= Draw arrows, shapes, and annotation boxes, plus add depth to your w= |nsert Saved Images 65
art using shading and dimension. w= Annotate with Text Boxes .............cccccocoe 66
- g:;ﬁlihlﬁ Ssrttll'a‘:[\;}onrfsk'l is a collection of ready-made, computerized e A Clip At 67
w= Insert a photograph or your company logo, making your viewers sit w= (reate WordArt 68
up and take notice of your worksheet. = Manipulate Graphics 69

w=  Ise WordArt, stylized text objects, which add pizzazz to your
worksheet. »= Crop an Image 70
g Manipqlate anfl manage al} the aboye mentiongd graphic ijects — = Flip an Object 70
by moving resizing, cropping, rotating,recoloring, and using many i Ml GRS 7
w= Control Object Order 72
= Group Objects Together ...........ccccooeeeeeeeene. 72
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Chapter 7: Designing with Graphics

llustrate with Arrows

1.

64

Choose InsertoShapes. The Shapes gallery, shown in
Figure 7-1, appears.

From the Lines category, select a line style. For this
example, I select an arrow. The mouse pointer turns
into a plus sign.

Click and drag the mouse in any direction. Begin wher-
ever you want the back end of the arrow to appear.

Release the mouse where you want the arrow head to
appear. A small thin arrow appears on the worksheet

with a circle at each end, indicating the arrow is

selected. (See Figure 7-2.)

While the arrow is selected, Excel displays an additional worksheet
tab called Drawing Tools Format.

Choose Drawing Tools Formatm>Shape Stylest>Shape
Outline. A list of options appears:

e Theme or Standard Colors changes the arrow line color.

e Weight displays a submenu, where you can select a
different line thickness.

e Dashes displays a submenu, where you can change
the line style from a solid line to a dotted, dashed, or
other style line.

e Arrows displays a submenu, where you can select dif-
ferent arrowhead styles and sizes.

Click anywhere in the worksheet to deselect the arrow.
Click the arrow again to reselect it.

Figure 7-1: The Shapes gulléry.
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Figure 7-2: A drawn selected arrow.



Insert Saved Images

Draw Using Shapes

§]) o

1. Choose Insert=>Shapes. The Shapes gallery appears. - Meceorrrm l Riseie &b
Select a shape. l R e —
. . - 1T |
2. Click and drag the mouse in any direction. Release the ot ' |

mouse. The shape appears on-screen with eight selection TR

handles around it, along with a rotation handle.

3. If you want the shape to contain text, with the shape

still selected, begin typing the desired text. Srasson
4. Choose Drawing Tools Format=>Shape Fill. A list of S 3000
options appears: 2B
e Theme or Standard Colors: Changes the interior color. T

e No Fill: Shape becomes an outline without interior
color.

ol IET— |
I fith O G s~ gl it

e Picture: Opens the Insert Picture dialog box, where
you can select an image to display inside the shape.

Revset Plcsain LA |

Petures * @-@ X

e Gradient: Displays a gallery of gradient fills.

o Textures: Shows a gallery of texture fills (see Figure 7-3). . H H

Insert Saved Images

1. Choose InserteolllustrationseoPicture. The Insert Picture

dialog box opens. U :
2. Locate and select the picture you want to place in the '_“J ==
worksheet. (See Figure 7-4.) Figure 7-4: Insert a logo or photograph.

3. Click Insert. Excel places the picture on the worksheet
with selection handles surrounding the image.

TEAM LinG



Chapter 7: Designing with Graphics

Annotate with Text Boxes

1.

66

Choose Insert>TextroText Box. The mouse pointer looks
like an upside-down cross.

Click and drag diagonally on the worksheet to draw the
box the approximate size you want. You can resize or
move it later if necessary. You see a text box like the one
shown in Figure 7-5. A blinking cursor appears inside
the text box.

Type the desired text.
Click outside of the text box to deselect it.

Right-click the text box and choose Format Shape. The
Format Shape dialog box (shown in Figure 7-6) opens.
In this dialog box, choose any of these formatting options:

e To add a background fill to the text box, click Fill and
select an option from the right side of the dialog box.

e To change the border that surrounds the text box,
click Line and choose a line option.

e To change the style of line surrounding the text box,
click Line Style and choose any desired options.

e To add a shadow around the text box, click Shadow
and then select an option from the Presets drop-
down list.

o Make the text box three-dimensional with choices in
the 3-D Format and 3-D Rotation sections.

¢ From the Text Box option, select Resize Shape to fit
text. As you add or remove text from the text box, the
box expands or contracts to fit around the text.

Click OK when you finish making your selections.
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Figure 7-5: Annotate cells with text hoxes.
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Figure 7-6: Format fext box text fo add emphasis.
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Add Clip Art

Add Clip Art

1.

Choose Insert>Illustrations=> ClipArt. The ClipArt task
pane appears, as shown in Figure 7-7.

In the Search For box, type a brief description of the
image type you want, such as food, buildings, animals,
or people.

From the Search In list, choose where you want Excel to
search.

e My Collections: Includes searching in your private
folders such as Favorites and My Documents.

e Office Collections: Includes clip art, organized by cat-
egory, installed with the Microsoft Office application.

e Web Collections: Includes clip art from the Microsoft
Office Online Web site.

Choose the type of image you want from the Results
Should Be drop-down list. Excel can locate clip art, pho-
tographs, movies, or sound files.

Click the plus sign next to any image type fo further define the
search options.

Click the Go button. Excel displays a number of images
representing the art you specified.

Select the desired image. Excel places the image onto
your worksheet, as shown in Figure 7-8.

For thousands of addifional pieces of free clip art, click Clip Art on
Office Online.

Click the Close button to close the Clip Art task pane.

i
J i [
®

(8] vparee dgs..,
% o wt on Ofen Crne
K T For finding dips

Figure 7-7: Searching
for dip art.
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Figure 7-8: Placing clip art onto your worksheet.
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Chapter 7: Designing with Graphics

Create WordArt

68

1.

Choose Insert>Text>WordArt. A gallery of options
appears.

Select a style. A box appears on the worksheet.

Type the text you want. (See Figure 7-9.) The text shrinks

to fit into the existing box, but you can resize it later.

Click the Drawing Tools Format tab.

To change the style of any or all of the WordArt, highlight the por-
tion you want to change and choose Drawing Tools Format>Quick
Styles to make a selection.

Use the tools in the WordArt group to modify the
WordArt text characteristics. All options include Live
Preview, so as you pause your mouse pointer over any
option, you see its effect on your WordArt object:

e Text Fill changes the text color, gradient, or pattern.
e Text Outline modifies the outer edges of the text.

o Text Effects applies special effects such as shadow,
reflection, rotation, and bevel.

To apply a background to the WordArt object, choose
Drawing Tools Format=>Shape Styles. Next, click the
More button. A gallery of themed styles appears. (See
Figure 7-10.)

Select a background option or click the Other Theme
Fills arrow to select from several gradient options.

To change multiple object characteristics, choose Drawing Tools
Format=>Shape Styles and then click the dialog box. The Format
Shape dialog box opens.

|/l";; gw-ows Wahly Badets 3007 - Mrasalt Esce Drameng Tock

It Pageloyest  Formolss  Dats Beees  Vew

i
|
|
$ 2880435 5 3197261 5 3548957
$ 66,250.00 5 73537.00 $ 8162600
S 1656250 5 18,384.2% § 2040650
$ 1181000 5 1310900 $§ 14551.00
5 75000 5 B90.00 5 900.00
11 Total Income $124,176.85 $137,892.86  5152,973.07
12
13
14
15
16
17
18
A0 ] st S | Shewtd 3 o —
Ry @ frib O G i~ i i+
. .
Figure 7-9: Add elaborate text with WordArt.
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Figure 7-10: Apply WordArt enhancements.
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Manipulate Graphics

Manipulate Graphics

1.

Select the object you want to modify. Selection handles
appear around the object. Figure 7-11 shows a selected
object.

Perform any of the following actions:
e Delete: Press the Delete key on the keyboard.

e Move: Position the mouse pointer over the object,
but not on the handles. Click and drag the object to
the desired location.

Optionally, nudge a selected object using the up, down, left, or right
arrow keys.

e Resize: To resize an object, position the mouse
pointer over one of the white selection circles and
drag the circle until the object reaches the desired
size. Use the top or bottom middle handle to resize
the object height. Use the middle left or right handle
to resize the object width. Use a corner handle to
resize both the height and width.

If you want fo constrain the sizing when resizing an object, hold
down the Shift key.

e Rotate Shape: Position the mouse over the green rota-
tion handle until the pointer turns into a circle. Then,
drag the green rotation handle until the object rotates
to the desired angle. (See Figure 7-12.) This does not
apply to arrows.

® Rotate Arrow: Drag either of the white selection han-
dles in the direction you want to rotate.

To constrain rotation fo 15-degree angles, press and hold the Shift key

while rotating the object.
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Figure 7-11: A selected object with eight selection handles and a rotation handle.
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Figure 7-12: Use the rotation handle to rotate shapes or other objects.
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Chapter 7: Designing with Graphics

Crop an Image

1. Choose Picture Tools Format=>Sizer>Crop.

2. Position the mouse over a corner of the image to display
crop handles. A crop handle looks like an upside-down
and backward letter L, as shown in Figure 7-13.

3. Click and drag a crop handle inward to crop out an area
of the image.

4. Release the mouse button. Excel crops the image.

Continue cropping other edges of the image, as needed. Figure 7-13: Removing undesired areas of a picture — in this

le, th the left.
6. Click the Crop button again to turn off the Crop tool. exampte, fhe car on fhe te

Flip an Object =

1. Select the object you want to flip. T F 5

2. Choose Picture Tools Format=>Arranger>Rotate. A menu :
of choices appears. As you pause your mouse over a 8 ORIGINAL IMAGE FLIPPED IMAGE
menu option, Excel previews the effect on the picture. >
(See Figure 7-14.) !

3. Select from the following options: =
e Rotate Right 90° 2
e Rotate Left 90° s
e Flip Vertical 5

18

e Flip Horizontal e = Py

Figure 7-14: Flippi ject.
Choose More Rotation options to display the Size and Properties gure pping an objec

dialog hox, where you can set many options precisely induding
size, rotation, and cropping.

70
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Align Multiple Graphics

|/l-'\. FEECE Mireslt Exce Drameng Too

Align Multiple Graphics e
’ y f [ e

8 C D E F G
NEW HOUSING SALES

1. Select the first object and then hold down the Ctrl key
and select any subsequent objects.

For assistance in selecting multiple objects, select one object and
then choose Drawing Tools Format=>Arrange=>Selection Pane.

sl

2. Choose Drawing Tools Format=>Arrange=>Align. A list of
options appears. (See Figure 17-15.)

3. Choose a menu option. Figure 7-16 shows three arrows s

16

aligned both center and middle. Some options include: n

18
15

e Align Left: Aligns two or more objects so their left )

edges are the same as the leftmost selected object. I e— = =

fy Capie @ i 0 G i) I—
e Align Right: Aligns two or more objects so their right Figure 7-15: Select an alignment option.
edges are the same as the rightmost-selected object.

¢ Align Top: Aligns two or more objects so their top O i O o e I o
edges are the same as the highest-selected object. s

=- -2
B - LY
. 888 -

n
8 C D E F G H
NEW HOUSING SALES

e Align Bottom: Aligns two or more objects so their bot-
tom edges are the same as the lowest-selected object.

=
foedmipeyaen®

e Snap to Grid: When active, using any of the align
options aligns the objects to the closest grid intersec-
tion. When Snap to Grid is turned on, nudging an
object with the arrow keys moves the object one grid-
line at a time. With Snap to Grid turned off, nudging
an object moves it one pixel at a time.

“imoe

13

14

e View Gridlines: Turns the gridline display off and on 2
in the Excel worksheet. =

18
19
20
2
Wb | Sheet! < Shewd Sheetd 7 ol | =
Ravdy | Captuct @ i 0 G i) o £+

Figure 7-16: Three arrows aligned center and middle.
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Chapter 7: Designing with Graphics

Control Object Order

Select the object you want to move.

Choose Drawing Tools=>Arranger>Bring to Front.
A menu of options appears.

Optionally, choose Send 1o Back to move a selected object behind
another one.

Choose Bring Forward or Bring to Front. The selected
object moves on top of the other object or objects. (See
Figure 7-17.)

Group Objects Together

1.

72

Select two or more objects.

An alternative way to select objects is to choose Homec Edifing=o>
Find and SelecicoSelect Objects. Next, use the mouse to draw an
imaginary box around the objects you want fo select. Click the
Select Objects option again to turn off the feature.

Choose Drawing Tools Format=>Arrange= Group. The
selected objects become one object with a single bound-
ary box around it. With grouped objects, any changes you
make affect the entire object. In Figure 7-18, you see the
rectangle, circle, and triangle grouped together as one.

When you group objects, you combine them; therefore, any changes
you make affect the entire object. Changes indude move, resize, flip,
rotate, crop and any style, shadow, or color changes. You can also
create groups within groups to help you build complex drawings.

You can ungroup a group of objects at any fime and then regroup
them later. To ungroup the object, choose Drawing Tools Formate>
Arrange=>Ungroup.

ORIGINAL ORIECTS OBIECTS AFTER CHANGING ORDER

% = ole

13
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15
16
17
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Figure 7-17: Rearranging the objecis so the red friangle is on top of the yellow circle.
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Figure 7-18: Combine muliiple objects info one.
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Managing Workbooks

Let/s begin by clearing up a couple of terms. A worksheet, sometimes
called a spreadsheet, is a collection of cells that can have more than 1
million rows down and more than 16,000 rows across. Each cell of each
sheet can contain more than 32,000 characters.

Secondly, a workbook is a collection of worksheets. By default, each time you
create a new Excel workbook, it contains three worksheets. Each workbook
however, can have an almost unlimited number of worksheets, limited only
by your computer memory. The resulting possible number of cells in a sin-
gle workbook is too huge to even dream about, but the fact remains you
could create a single huge workbook. Realistically, however, you'll probably
have a number of different workbooks, each with a number of worksheets.

Excel makes it easy to work with multiple worksheets. You can maneuver
between the sheets by clicking a sheet tab. It even provides navigation but-
tons for situations when you have a lot of tabs. This chapter is primarily
about working with multiple sheets. You discover how to insert, delete,
move, and copy worksheets, rename the tabs that reference them, and create
formulas that reference other worksheets or workbooks.

Finally, you discover how to create hyperlinks to jump to Web sites, other
cells, or workbooks and how to create an instant e-mail.

| “*\apter

Getready to. ..

w= |nsert Additional Worksheets .................... 74
w= Delete Worksheets 74
= Rename Worksheets 75
w= Copy Worksheets 75
= Move or Copy Worksheets to a

Different Workbook 76
w= Hide and Unhide Worksheets...................... 77
w= Change Worksheet Tab Colors ................... 77
w= Generate References fo Other

Worksheets 78
w= (ross-Reference Other Workbooks.............. 79
w= [nsert a Hyperlink 80
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Chapter 8: Managing Workbooks

Insert Additional Worksheets

1.

Choose Homer>Cellst>Inserte>Insert Sheet. Excel auto-
matically inserts a new blank worksheet on top of the
currently selected sheet. (See Figure 8-1.) Excel automat-
ically assigns the next number — such as Sheet4.

Click a different worksheet tab. That worksheet becomes
the current sheet.

If your workbook has more worksheets than you can see
at the bottom, click the First, Previous, Next, or Last
navigation buttons in the bottom-left corner of the
workbook.

Delete Worksheets

1.

74

Choose Homem>Cells>Delete>Delete Sheet. If any cells
in the selected sheet have data in them, a warning mes-
sage appears, as shown in Figure 8-2.

s A worksheet with no data in it will not display the warning message.

Click the Delete button.

Use caution when deleting worksheets. The Undo feature does not
work with the Delete Sheet function.

(cs =]
"L ® Caiien AT ([ e 1]
B . i Bom 97| oot m Table -
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Figure 8-1: Inserfing a new worksheet.

Miciasalt OMfice Excel =]
_& v et i th deletien. delets the data, pr
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Figure 8-2: Delete an unwanted worksheet.
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Copy Worksheets

Rename Worksheets

1. Click anywhere on the sheet you want to rename.

2. Choose Homer>Cellsw>Format>Rename Sheet. The
worksheet tab becomes highlighted. Leave it highlighted
so that you can replace it with a new name.

3. Type a unique name for the worksheet, as shown in
Figure 8-3. Remember that two worksheets in a single

workbook cannot have the same exact name. Press Enter
to accept the change.

Be descriptive, but keep the name short. When you have lots of

worksheets with long names, it can be more difficult to maneuver
from one to the next.

Copy Worksheets

1. Click anywhere on the worksheet you want to duplicate.

2. Choose Home=>Cellse>Format=>Move or Copy Sheet.
The Move or Copy dialog box appears.

Check the Create a Copy box. (See Figure 8-4.)

4. Select where in the order of the worksheets you want
the duplicate sheet placed.

5. Click OK. Excel duplicates the sheet and gives it the

same name as the copied sheet, plus numbers it
sequentially.

To change the worksheet tab order, drag the worksheet tabs left or
right.

FOO0D LERVICE
CRATION
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Figure 8-3: Rename a worksheet.
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Figure 8-4: Duplicating a worksheet.
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Chapter 8: Managing Workbooks

Move or Copy Worksheets
to a Different Workbook

1.

76

Open the workbook to which you will move the
worksheet.

Open the workbook that contains the worksheets you
want to move.

Click anywhere on the worksheet you want to move. If
you don't see the sheet you want, click the tab naviga-
tion buttons until you see it.

If you want to move or copy multiple worksheets, hold down the
Ctrl key and dlick additional tabs. If you want to move or copy all
the existing worksheets to another workbook, right-click a sheet tab
and choose Select All Sheets.

Choose Homer>FormatoMove or Copy Sheet. The
Move or Copy dialog box opens.

Click the To Book drop-down list as in Figure 8-5 and
select the workbook to which you want to move or copy
the sheets.

If you want to duplicate the sheets to the other work-
book, click the Create a Copy box.

Select where in the order of the existing worksheets you
want the moved sheet placed.

Click OK. Excel moves or copies the worksheets to the
other workbook. In Figure 8-6, the sheet named
Customer List was moved from the Customer Table
workbook to the Names and Address workbook.

Mave a1 Copy [2]%]

Mave selected cheats
To book:

(e bock) 5
[inew bock]

[posk

|

Ll gresie a copry
L] patch deestinstion theme

o] (o ]
Figure 8-5: Select another workbook.

If you chose to copy a sheet to another workbook in which a sheet has
the same name, Excel keeps the same name but adds a sequential num-
ber to the end.

You cannot copy or move a worksheet created in an Excel 2007 work-
book to one created in an earlier version of Excel.
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Figure 8-6: Move worksheets from one workbook to another.
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Change Worksheet Tab Colors

Hide and Unhide Worksheets o

1. Click anywhere on the worksheet that you want to hide.

2. Choose Home=Cells=oFormat>Hide & Unhide=>Hide oy e
Sheet. Excel hides the worksheet from view. All formula N .
references to a hidden worksheet are still valid even Figure 8-7: Select a worksheef to unhide.
when a worksheet is hidden.

When a worksheet with a colored tab is the current worksheet, Excel
does not display the tab color in full. It only displays a colored line under
the tab name. The tab becomes full color when the worksheet is not the
active one.

Optionally, right-click a worksheet tab and select Hide (or Unhide).

3. To unhide the worksheet, choose Choose Homer> e
Cells=>Format>Hide & Unhider>Unhide Sheet. A dialog gy
box, like the one in Figure 8-7, appears, listing all cur-
rently hidden worksheets in the active workbook.

4. Select the worksheet you want to unhide and click OK.

Change Worksheet Tab Colors

1. To recolor the tab of a worksheet, click anywhere in that
worksheet.

Theme Calors | ————
B EEEEEE .

0

2. Choose Home=>Cells=>Format=>Tab Color. The Tab
Color gallery that you see in Figure 8-8 appears.

3. Select a color.

Select No Color to remove a tab color.

=

it OF GO |nori - X i

Figur 8-8: Make certain worksheets easy to locate by changing their tab colors.
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Chapter 8: Managing Workbooks

Generate References
to Other Worksheets

1.

Select the cell into which you want to enter a reference.

2. Perform one of the following actions:

78

e To display a value located in another cell on the same
worksheet, type the equal sign and then the cell
address. For example, type =B45. If the value in
B45 changes, the cell with the reference to B45 also
changes.

e To display a value located in a cell on a different work-
sheet but in the same workbook, type the equal sign.
Next, click the worksheet tab containing the cell you
want to reference and then click the actual cell you
want to reference. Press the Enter key. Excel displays
the equal sign, the worksheet name, an exclamation
point, and the cell reference. (See Figure 8-9.)

¢ To include a cell located on a different worksheet but
in the same workbook in a formula, begin to type the
formula. In the place where you want to position the
distant cell reference, click the worksheet containing
the cell and then click the actual cell. Follow this
with the remainder of the formula. Figure 8-10 illus-
trates an example of a formula using a reference to a
different worksheet.

Formulas referencing other worksheets or other workbooks can
also be compound formulas or used in a function.

(g AL
e B . Bihconsmcnai famumng - o
1] 5% v e e i D
= g (B DeEH A EE AR N =1 Brer
=]
A B E ; B
2 15T QTR ZND QTR 3RD QTR 4THQTR TOTALS |
3 Auto Expense ">_".-1?.R¢ 5,597.69 3,767.84 20,394.72
4 Insurance 441999 4,465.50 4,509.69 3,035.50 16,430.67
S Supplies 1,949.31 1,969.38 1,988.87 133872 7.246.27
6 Taxes 6,003.89 6,065.71 6,125.73 4,123.27 22,318.60
T Utilities 207699 2,098.38 2,119.14 1,426.41 7,720.92
B Wages 7,085.89 7,158.85 7,229.69 4,866.35 26,340,78
9 TOTAL 27,022.41 27,300.66 27,570.80 18,558.09 100,451.96
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Figure 8-9: Creating u reference to another worksheet in the same workbook.
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Figure 8-10: Including a reference in a formula.
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Cross-Reference Other Workbooks

Cross-Reference Other Workbooks

1.

Open the workbook to which you will refer. For simplic-
ity sake, call this Workbook2.

Click the desired cell in the workbook where you want
to create a reference. Call this Workbookl.

In Workbook1, begin the formula or reference with an
equal sign.

If using a function or formula, enter any portion that
you want to precede the cross reference.

Click the cell that you want to reference from
Workbook2.

Finish the remainder of the formula or press the Enter
key. Excel displays the equal sign, an apostrophe, and
then the Workbook? filename in brackets followed by the
worksheet name, a closing apostrophe, an exclamation
point, and then, the absolute cell reference. For example,
[Sales.xls]January’! $E$ 10 refers to the value in cell E10

of the sheet January in the Excel file named Sales. See
Figure 8-11 for an example of a cross reference.

Excel uses absolute references (with dollar signs) when referring to
other workhooks.

e When you open a workbook containing a cross refer-
ence, Excel displays a message such as the one shown
in Figure 8-12, prompting you with a security alert
so it can determine whether to update the cross-
referenced cell. Click Enable Contents if you want
Excel to check the originating workbook for changes
to the referenced cell. You may see another confirma-
tion message.

(og' =
- [ - o
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E F G 4
1
2 | 15T QTR 2ND QTR 3RD QTR 4TH QTR TOTALS |
3 Income I 47,289.22 47,776.15 48,248.91 32,476.66 175,790.94
4 LESS: Expenses 27,022.41 2 27,570.80 18,558.09 100,451.96
5 NET PROFIT 20,266.81 20,678.10 13,918.57 75.338.97
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Figure 8-11: Create a reference to another workbook.
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3 Income | 47,289.22 47,776.15 48,248.91 32,476.66 175,790.94

4 | LESS: Expenses 27,022.41 27,570.80 18,558.09 100,451.96

5 MNET PROFIT 20,266.81 20,678.10 13,91B.57 75,338.97
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Figure 8-12: Updating a cross-referenced cell.
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Chapter 8: Managing Workbooks

Insert a Hyperlink T e L 4 ‘

1. Select a cell or graphic object then choose Inserte> yooays Spse
Links=>Hyperlink. The Insert Hyperlink dialog box, 22

Apple
shown in Figure 8-13, appears. o)

Dell 2219

2. Ifyou dicked a blank cell in Step 1, in the Text to Display L
box, you can type the text you want the cell to display. —
If you started with a cell already containing data or an - - -
object, you can change the displayed text. Figure 8-13: Creating  Hyperlink.

. 1 ion:
3. Selectan option Click the ScreenTip button fo enter text you want displayed, such as a

¢ If you want to link to a different file, locate and select prompt or hint that appears whenever the user pauses the mouse over
the filename. When the user clicks the link, the refer- the link.

enced file will open.
) ] To remove a Hyperlink, right-click the link and select Remove Hyperlink.
e If you want to link to a Web site, enter the Web

address in the Address text box. When the user clicks
the link, the Web browser opens to the referenced

Web page L Pilcs Ouats ;»;'[3'
¢ If you want to link to a different cell in the current - T i

workbook, click the Place in This Document button, T | Deeseentie ot - =1

then specify which worksheet and cell location you o | st :

want to reference. When the user clicks on this link, 9

he or she is redirected to the specified cell address. £

e If you want to send an e-mail when the link is
selected, click the E-mail Address button and then Figure 8-14: (reate an e-mail via an Excel Hyperlink.
enter the recipient’s e-mail address and a subject
(Figure 8-14). When the user clicks the link, the
user’s e-mail program starts, as you also see in
Figure 8-14.

4. Click OK.
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Changing Worksheet
Views

S

meone once wrote about the importance of seeing and being seen.
Although I'm sure that quote referred to people, it also can apply to

your Excel worksheets. You need to see them in many different contexts.
That's what this chapter is about — seeing your workbook from different
perspectives by using the following techniques:

Iy

-y

=

)

1)

=

Viewing alternatives such as zooming in or out, displaying page
breaks, or seeing the worksheet without the Ribbon and other screen
elements.

Splitting the screen to see multiple sections of a worksheet at the same
time or viewing multiple worksheets together.

Freezing portions of a worksheet so you can see category or row
headings.

Comparing two spreadsheets on the screen.

Creating templates that can bring consistency, such as the company
standards or personal preferences, to your workbooks.

Monitoring specific cells for changes.

Go ahead, take a look!

| “*\apter
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Chapter 9: Changing Worksheet Views

Zoom In or Out

1.

Choose View>Zoom. The Zoom dialog box appears.

Optionally, click the magnification box nexi to the Zoom controls.
The magnification box and the Zoom controls are located on the
status har.

2. Select a magnification percentage from the Zoom dialog

box as seen in Figure 9-1. A higher zoom setting makes
the text appear larger so you see less on the screen; a
lower setting shows more on the screen, but the data
appears smaller. Zooming does not affect the printed
data size. Click OK.

Use the Zoom Controls

1.

84

Click the Zoom In button on the Zoom Control. Excel
increases the magnification percentage by 10% for each
click of the Zoom In button. (See Figure 9-2.)

Click the Zoom Out button on the Zoom Control. Excel
decreases the magnification percentage by 10% for each
click of the Zoom Out button.

Click and drag the Zoom slider bar to the right. Excel
increases magnification.

Click and drag the Zoom slider bar to the left. Excel
decreases magnification.

@ gustem: | 150/ (%

o) o ]
Figure 9-1: Select a zoom percentage.

; Select the Custom option and enter your own setting from 10% to 400%.

050830 RAWDATA_  Aissmproes

& | @

Figure 9-2: Using the Zoom Controls.
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Change Worksheet Views

Change Worksheet Uiews

1.

Choose Viewr>Worksheet Viewst>Page Layout View. As
in Figure 9-3, the Page Layout view displays your work-
sheets on individual pages that correspond to printed
pages. A ruler appears on the top and in the header and
footer area. See Chapter 12 for more on headers and
footers.

Choose Viewr>Worksheet Views=>Normal. Excel returns
to the default Normal view, which shows one continu-
ous page of columns and rows.

Choose ViewsoWorksheet Viewse>Page Break Preview. A
Welcome to Page Break Preview dialog box appears.

Click OK. The Excel mode changes to Page Break
Preview, where Excel indicates page breaks with lines.
(See Figure 9-4.) You can click and drag these lines to
modify where pages break. See Chapter 12 for more on
using page breaks.

Choose View>Worksheet Views>Full Screen. You see
only the worksheet itself with its row and column head-
ings, worksheet tabs, and the title bar. The Ribbon,
Quick Access toolbar, and the Status bar are hidden.

Press the Escape key. Excel returns to Normal view.
On the Status bar, next to the Zoom Controls, you find three icons

you can use to quickly switch among the Normal, Page Layout View,
and Page Break Preview modes.

Sstiinll it
Resdy | @

Figure 9-4: Page Break Preview.
TEAM LinG
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Chapter 9: Changing Worksheet Views

Freeze Worksheet Titles

1. Choose what you want to freeze:

e Columns: Select the column to the right of the
columns you want to freeze. For example, click cell
B1 to freeze only column A.

® Rows: Select the row below the rows you want to
freeze. For example, click cell A4 to freeze rows 1, 2,
and 3.

e Columns and rows: Click the cell below the rows
and to the right of the columns you want to freeze.
For example, click cell B2 to freeze both column A
and row 1 (as shown in Figure 9-5).

Freezing panes only affects the current worksheet. If you want to
freeze other worksheets, you must select them individually and
freeze them.

2. Choose View>Windowr>Freeze Panes=Freeze Panes.

A thin black line appears to separate the sections. As
you see in Figure 9-6, as you scroll down and to the left,
row 1 and column A remain visible even though you
see rows 190 through 218 in the bottom section and
columns F through M on the right.

Normally when you press the Ctrl+Home key, Excel takes you to
cell A1. However, when Freeze Panes is active, pressing Ctrl+Home
takes you fo the cell just below and 1o the left of the column head-
ings. However, you can sfill use your arrow keys or dlick your mouse
to access any cell.

3. Choose ViewroWindowr>Freeze Panes=>Unfreeze Panes

86

to remove the freeze from row and column headings.

B - F H I 4 K
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Figure 9-5: Cells above and to the left of the current cell will be frozen.
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Figure 9-6: Keep fitles visible by freezing the panes.
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Arrange Windows

Split the Excel Screen

1.

4.

Click anywhere in a row and column where you want to
split your screen. This is usually somewhere around the
middle of the screen.

Choose Viewr>Window=>Split. Excel splits the window
horizontally into two or four panes each separated from
other panes by bars. Each pane has its own set of scroll
bars (see Figure 9-7).

Drag the horizontal split bar up or down or the vertical
split bar left or right to resize the window sections.

Optionally, double-click any part of the bars that divide the panes
to remove that particular split.

Choose ViewroWindow=>Split again to remove the split.

Arrange Windows

1.
2.

Open two or more workbooks.

Choose Viewr>Windowr>Arrange. The Arrange Windows
dialog box, shown in Figure 9-8, appears.

Make a selection:

e Tiled arranges the open workbook windows so they
do not overlap each other.

e Horizontal places the open workbook windows hori-
zontally on top of each other.

e Vertical lays the open workbook windows side by side.

e (Cascade arranges the windows so that they overlap
each other, keeping the title bar visible.

Click OK.

i O3 i =) ! it

worksheet

simultaneously.

Arrange Windows 63
arange

@]

) Hgrizonend

) ertical

) Cmeincle

[ wtncoves of activn workbook
o] (e ]

Figure 9-8: Arranging to see multiple worksheets.

s Maximize the workbook to return it to a larger size.
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Chapter 9: Changing Worksheet Views

Compare Worksheets

Open two workbooks.

Choose View>Window=>View Side by Side. The two
workbooks are split horizontally on the screen as shown
in Figure 9-9.

Scroll down or across a worksheet. Notice the other
worksheet scrolls simultaneously.

Choose ViewrpWindowr>Synchronous Scrolling to turn
off the option to scroll the worksheets independently.

Choose Views>Windowr>Reset Window Position, if
you want to reset the workbook windows to the posi-
tions they were in when you first started comparing
workbooks.

Choose View>Window=>View Side by Side to return the
windows to Normal mode.

Save as a Template

88

1.

Create an Excel workbook. Templates can store format-
ting, worksheet layouts, data, formulas, and much more.

Choose Office Buttont>Save As. The Save As dialog box
appears.

Type a name for the template in the File Name text box.

Choose Template from the Save As Type drop-down list.
Excel automatically saves the template in the default
template location (see Figure 9-10). Click Save and close
the workbook.

udy | Capileck @
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Figure 9-9: Comparing duta between two different workbooks.
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Create a Workbook from an Existing File

Open a Template

1. Choose Office Button=>New. The New Workbook dialog
box opens.

Using the Cirl+N shortcut doesn’t work here. It automatically cre-
ates a new standard blank worksheet, not one from a specially

@ saved template.

Click any category in the Microsoft Office Online area to view a
great collection of mostly free templates.

Click My Templates.

Click Create. The New dialog box displaying your cus-
tomized templates appears. (See Figure 9-11.)

4. Select the template you want to use.
Click OK.

Create a Workbook from
an Existing File

1. Choose Office Button=>New. The New dialog box opens.
Click New from Existing.

Click Create. The New from Existing Workbook dialog
box. shown in Figure 9-12, appears.

4. Locate and click the workbook you want to open.

Click Create New. Excel opens a copy of the workbook.
The filename in the title bar shows the same name as
the original with a number after it.

How %]
My Temglates.

g g @ @ [°°°

MG lvokng  Detsled  Madcaonloy GUWATERDY
Tracking e EPONSES

Prisveees nick valatle,

ok | coxel |

Figure 9-11: Create a new file based on a template.
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Figure 9-12: Use an existing file as a template.

When you choose to save the workbook, the Save As dialog box auto-
matically opens, prompting you for a filename.
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Chapter 9: Changing Worksheet Views

Monitor Cells in the Watch Window

1.

90

Choose Formulasw>Formula Auditing=Watch Window.
The Watch Window opens.

Click Add Watch. The Add Watch dialog box in Figure
9-13 appears.

Select the cell or cells you want to watch or manually
type the cell reference address.

Click Add. Excel adds the cells to the Watch Window,
including any values or formulas within the cells. If you
scroll away from the original cells, the Watch Window
always displays the cell contents. (See Figure 9-14.)

Repeat Steps 2 through 4 to add another watch area to
the Watch Window. You can add watches with cells on
the same worksheet, a different worksheet, or a different
open workbook.

As necessary, perform the following actions:

e To remove a cell from the Watch Window, click the
cell name and then click Delete Watch. Excel imme-
diately removes the cell from the window.

e To move the Watch Window, click and drag the win-
dow's title bar anywhere on-screen.

e To resize the columns within the Watch Window,
position the mouse pointer over a column in the
Watch Window and drag to resize the column.

When finished, click the Watch Window’s Close button.
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Figure 9-13: Add an area you want fo watch.
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Figure 9-14: The Watch Window stays active no matter what area of the workbook
you are using.
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Sorting Data

Sometimes worksheets become quite large, making locating particular
pieces of information time-consuming and difficult. If your data is in
an array, you may find the data easier to view if it is sorted in a particular
manner.

Perhaps you have multiple worksheets, and you want to locate every occur-
rence of a specific value. Or, maybe you're just a neat freak and want every-
thing to be in a particular order. Excel contains features to help your arrange
your worksheets in an easy-to-manage sequence.

In this chapter, you discover how to:

== Sort your data in ascending or descending order using either the tool-
bar or the Excel Sort dialog box.

m= Perform a secondary sort if the primary sort has multiple matches.
w= Sort data containing days of the week or month names.
m= Create a customized list of frequently used names or terms.

m= Tocate cells containing data you specify, whether the data is part of a
formula or a resulting cell value.

m= Quickly replace data containing certain information with another
specified set of data.

w= Locate all cells with a particular style of formatting and easily replace
them with a different format.

| “*lapter
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Chapter 10: Sorting Data

Use the Toolbar to Sort

1.

92

For the easiest sorting, create a list in contiguous order
and with headings specifying the contents of each col-
umn. Figure 10-1 illustrates an ideal data array.

In the column you want to sort by, click any cell con-
taining data.

If the data is in a connected list, you do not have fo select it first. If
it's not, you must first select the entire list. If Excel finds unselected
data in columns next to the selected data, it may prompt you for
more information.

@,

Choose Datam>Sort & Filter>Sort A to Z. (If the current
cell contains a value, the button says Sort Smallest to
Largest.) Excel sorts the entire list in ascending order.

Sorting text data in ascending order sorts text A-Z; sorting numeric
information in ascending order sorts low to high (1-10); and sort-
ing dates in ascending order places the earliest date first.

Excel sorts in the following pattern: numbers, spaces, special char-
acterswhichare | “#S% & ()*,./:; 2@ [\]"_"{|}~+
< = > and, finally, alphabetic letters.

@, @.

Choose Data=Sort & Filter=> Sort Z to A (or Largest to
Smallest). Excel sorts the entire list by descending order.
Figure 10-2 shows the Name column sorted in descend-
ing order (from highest to lowest).

If Excel incorrectly sorts a cell that contains a value, make sure the
cell is formatted as a number and not as text.

Sorfing fext data in descending order sorts text Z-A; sorting numeric
information in descending order sorts high to low (10-1); and sort-
ing dates in descending order places the latest date first.

@, @.

She ]

Favdy | Copitock @ it OF GO |nori -
Figure 10-1: Data for sorting.
(o 98 s
o T A | @ wng | = - A
a A L] L e i O ,_,‘--1-(}!
o | e S e o (T TS 0 Elreme - 2+ fane taai
Jih OO Gl |- .ﬂ‘-

Figure 10-2: A sorfed data array.
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Work with the Sort Command

g

Work with the Sort Command — =

1. Select or click in the list of data you want to sort.
Select only a single column of data if you want fo sort that column
independently of the rest of the data.

2. Choose Datar>Sort & Filter> Sort. The Sort dialog box
opens. (See Figure 10-3.)

Figure 10-3: The Sort dialog hox.

| Sont =3
3. If your data includes column headings, make sure the ydesieve | [ X poeiiovel | [ coprievet || ]3] [apsens..
My Data Has Headers option is checked. If the data %
doesn’t include column headings, deselect the option.

Excel does not include header rows in the sort process. .
o |

Figure 10-4: Select the sort column.

g

4. From the Sort By drop-down list, select the column by

hich . Fi 10-4.
which you want to sort. (See Figure 10-4.) Click the Options button if you want to make the sorting case-sensitive
5. From the Sort On drop-down list, choose Values. (I dis- (noncapitalized words before capitals).

cuss the other options later in this chapter.)

6. From the Order drop-down list, select how you want to Excel soris data in the following order: numbers, special characters, and
sort the data: finally alphabetic characters. Blanks are always placed lost.

e Choose A to Z or Z to A to sort text values.

e Choose Smallest to Largest or Largest to Smallest to
sort numeric data.

e Choose Oldest to Newest or Newest to Oldest to sort
by dates.

7. Click OK.

TEAM LinG



Chapter 10: Sorting Data

Sort by Multiple Criteria
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Select or click in the list of data you want to sort.

Choose Datar>Sort & Filter> Sort. The Sort dialog box
opens.

If your data includes column headings, make sure the
My Data Has Headers option is checked. If the data
doesn’t include column headings, deselect the option.

Although the most common sort is by rows (top to bottom), you can
also sort by columns (left fo right). In the Sort dialog box, dick the
Options button and then, under the Orientation section, choose Sort
left to right. Finally, click OK.

Set up the primary sort criteria as in the previous section.

Excel sorts dates formatted with slashes such as 11/22/68, as
numeric data. Dates with the day or month spelled out must be sorted
differently. See the later section, “Sort by Day, Month, or Custom
List.”

Click the Add Level button.

In the Then By section, select the secondary column you
want to sort by if two or more items are identical in the
first Sort By option. See Figure 10-5.

Select how you want to sort the second data criteria.
Repeat as needed.

To delete an entry, select the sort entry and choose Delete Level.
You must keep at least one sort entry in the list.

Click OK. Excel performs the sort process. Figure 10-6
illustrates data rows sorted first by State and then by City.

Figure 10-5: Select a second sort criteria.

During an Excel sort, apostrophes (‘) and hyphens (-) are ignored,
unless two text strings are the same except for a hyphen. In that situa-
tion, the text with the hyphen is sorted as the latter.

th O Gl |00 i,

Figure 10-6: A data array sorted by multiple criteria.
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Create a Customized List

Create a Customized List

1.

Choose Officer>Excel Options. The Excel Options dialog
box appears.

Choose Personalize

Click Edit Custom Lists. The Options dialog box opens.
Excel provides two ways to create a custom list:

A custom list can contain text or text mixed with numbers. Use cus-
tom lists to speed up data entry for commonly used terms such as
sales people, regions, or producis.

e To create a list from items you have already entered
into the worksheet, click the worksheet icon next to
the Import button. The Options dialog box collapses.
Highlight the worksheet cells containing your list and
then press Enter. The Options dialog box reappears.
Click the Import button. The data you selected
appears in both the List Entries box and the Custom
Lists box (see Figure 10-7).

e To type your own list without entering it into the
worksheet first, click New List from the Custom Lists
section. Type your list in the List Entries text box as
you see in Figure 10-8, separating each list item with
a comma, and then click the Add button.

Click OK twice.

You can now use the AutoFill feature with the custom list by typing
one list entry and using AutoFill to enter the other list entries. See
Chapter 2.

Opthons (E25]
Cushonm Lists
(Curstom sts: List grivies:
e L= ]
iy Aoy S Bl (T

sy, Febeisary, Merch, Agel | | ANDREW

Trpocet bt Froen cobe: JARA-A41S m [Cmeer ]

Figure 10-7: Create your own custom lists from
data in your worksheet.

To edit a custom list, from the Custom Lists tab select the list that you want
to edit. Make any changes in the List entries box and then dlick Add. To
delete a customized list, select the list and then click Delete. You cannot
edit or delete the Excel-provided fill series such as months and days.

Curstam Lists (2%
Cushonn Lists

Custem sts: List grivies:

HEW LIST R, Yebow, Greer, e, Wien, | [ am |
Sum, Mon, Tue, Wed, Thi, Fri, | |purple, Crange,| e
Sureday, Morelay, Tumcdey, Wes
Jan, P, Mar, Agr, My, 3, 1

sy, Febrssry, March, Apd
MRS, TIM, SPENCER, TAIN, ,

Paess Enter to saperate kst entries.

[rpcet bt e el [ [ tmeer

Figure 10-8: Manually create a customized list.
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Chapter 10: Sorting Data

Sort by Day, Month, or Custom List —

Custom fsts: Uit grivies:
WEW LIST

Sun, Mon, Tue Wed, Tha, Fri, =

Surwhav, Morslny, Tossely, Wed

1. Select or click in the list of data you want to sort.

2. Choose Datar>Sort & Filter> Sort. The Sort dialog box
opens.

3. Ifyour data includes column headings, make sure the PVt R I
My Data Has headers option is checked. If the data
doesn’t include column headings, deselect the option.

J

|

4. Select your first sort criteria field. Figure 10-9: Sorfing by weekday.

From the order drop-down list, select Custom List. The
Custom List dialog box appears. s By default, Excel sorfs days and months alphabefically, not by date.

6. Select the Custom List (see Figure 10-9) you want to
sort by.

Click OK. The Sort dialog box reappears.

Ramave Duplicates =3

To delete dupiente values, select one or more colemrs Bat contan ducicates.

8. Set up any secondary or additional sort criteria. ey —
Click OK. (Emeas ) [IEuesan]

Remove Duplicate Records
1. Select or click in the list of data you want to work with. . —
Figure 10-10: Let Excel find the duplicates for you.

2. Choose Data=m>Data Tools=>Remove Duplicates. The
Remove Duplicates dialog box appears. (See Figure
10-10.)

3. Check or uncheck the columns you want Excel to
examine.

4. Click OK. Excel looks for and removes duplicates. A
message tells you how many duplicates were removed
(if any) and how many unique values remain.

5. Click OK.
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Sort by Cell Format

Sort by Cell Format

1.

10.

Select or click in the list of data you want to sort.

Sorting by cell format is helpful when you have specified condi-
tional formatting conditions. It can sort all items meefing your con-
ditions to the top or bottom of the data table.

Choose Datar>Sort & Filter>Sort. The Sort dialog box
opens.

If your data includes column headings, make sure the
My Data Has Headers option is checked. If the data
doesn’t include column headings, deselect the option.

Select your first sort criteria field.

In the Sort On drop-down list, select one of the
following:

e Cell Color: Choosing this option sorts the cells based
on the cell background formatting.

e Font Color: Choosing this option sorts the cells
based on the font color of the cell contents, regard-
less of background formatting.

Click the Order drop-down list. Several options, includ-
ing Automatic and each color you used in your selected
field, appear.

Select the cell color or font color you want to sort by.

Choose whether you want the formatted cells to appear
at the top of the data range or at the bottom of the data
range. (See Figure 10-11.)

Add any additional sort criteria.

Click OK. In Figure 10-12 you see the data sorted with
the formatted cells at the top.

figure 10-11: Sort by formatting.

(o' =
= e
i ¢ - (| | P
o

e (BT U [E-(S-A EE AR

Figure 10-12: Data sorted by formatting.
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Search for Data

1.

98

Choose Homer>Editing=>Find & Select>Find. The Find
and Replace dialog box appears.

In the Find What box, enter the value or word you want
to locate.

Click the Options button and specify any desired
options. (See Figure 10-13.)

e Within: Search just the current worksheet or the
entire workbook.

o Search: Select whether to search first across the rows
or down the columns.

¢ Look In: Select whether you want to search through
the values or formula results, through the actual for-
mulas, or if you want to look in the comments.

e Match Case: Check this box if you want your search
to be case-specific (for example, BOBCAT instead of
BobCat or Bobcat).

e Match Entire Cell Contents: Check this box if you
want your search results to list only the items that
exactly match your search criteria.

Click Find Next. Excel jumps to the first occurrence of
the match (see Figure 10-14). If this is not the entry you
are looking for, click Find Next again. Excel advises you
if it does not locate the data you are searching for.

Click Close when you have located the entry you want.

| Find and Raplace e
|| Pt | Regice

Fidwhati | CASTLE T T

wilws | Seet s Cbestch gase

Ow
Searche (o Ry o] L Pt ente el cpnteces
Lookine [Formudas [ | ortren <<
|_Fdas | [ Embont | [ Gme |

Figure 10-13: The Find and Replace dialog box.

Find and Raplace -
|| Frd | mepiace

Fiued what: (CASTLE|

| Crtore 2>

|_Fea | [ Ebont | [ I

Figure 10-14: Excel finds data based on
search specifications.

Select Formulas when you are looking for a formula that references a
specific cell address.
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Locate Cells Based on Format

Find All Data Occurrences

1.

Choose Homer>Editing=>Find & Select>Find. The Find
and Replace dialog box appears.

In the Find What box, enter the value or word you want
to locate.

Click Options and specify any desired options.

Click Find All. The Find and Replace dialog box
expands, showing a list of each cell entry that contains
your data (see Figure 10-15).

Locate Cells Based on Format

1.

Choose Homew Editing=Find & Select=>Find. The Find
and Replace dialog box appears.

Click Options. Verify that these options are the ones you
want to use.

Click Format. The Find Format dialog box, shown in
Figure 10-16, appears.

Select any formatting options on which you want to
search. You can choose any combination of options.

Click OK. A preview of the formatting appears in the
Preview box.

In the Find What box, enter the value or word you want
to locate. Leave this blank if you want to locate only
cells with the specified formatting, regardless of the cell
contents.

Click the Find or the Find All button. Then click Close.

Find and Replace g
|| Fd | Reglace

Fpdwhat: | COMPUTER ]|

Cplorrs 3
[ Frgas | [ Brahest | [ cme ||

ok Sheet | fame | cel wahe -~
Verdors.alsx  Sheet] $E431 ADYANCED COMPUTER. SERYICES
Verdorsshz  Shesl §BEAT  ALAGKA COMPUITEN BRLCKERS

Verdrsshe  Sheetl §B457  ALITEK COMPUITERS INC.

Verdors.dy  Shest] 8490 AMERICANMICRO COMPUTER CENTER
Vercoes ulsx  Sheet] 84117 AP COMPUTER SERVICES LLC

Vendoesdsx  Sheat] 484124 ARGECY COMPUTER

Verkoesalx  Shest! §6145  ATLANTA COMPUTER SMES

Vendors. e Sheet] RIS DAGON COMPUTERS

Vendorsder  Shest] ZEE BENTZ COMPUTERS INC.

vandorsadex  Shestl SRS DLULSTAR COMPUTER CORPORATION
Vendors.slx  Sheetl SN CAND CCOMPUTERS

Verdors.ddsx  Sheet] $84336  CAPITAL COMPUTER GROUP, LLC

Verekes ks Sheal] fREITS  NERSES COMBUITER CORP.

Verdersahz  Sheel] 8§42 COMMENCE COMPUTER CORPORATION
Verdoes.ulx  Shest §B4E  COMPLITER CABLE STORE

Vendors.ade  Sheatl $E4447  COMPUTER CARE

Vendoes s Sheet] 4B4468  COMPUITER COMMODITIES

Wendorgdex  Theet! 04865 COMPUTER DISCOUNT WRARDHOUSE -
Vardee e hasrt ot FrwA TG e

1 »

|77 cobls) Found

Figure 10-15: Find All results.

Find Format (%]
Mearber | Abgreent | Fort Border Fil Protection
Ferd: Ford style Tan
Tatwma Bkl
Systen o~ [Regu ] -
gk 4
Trbten Pra Beld 1
T T e 1T e T 1
Termind 1z
"y Times New Roman ¥ 1. pe
\ebere o

v| | — ]
Elfeuts Prevmw

[ Rrbettecush

g AaBbCcYyZz

(o) (Cama ]

Figure 10-16: Find cells based on Format options.

| Choose Fecmat From ced... |
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Chapter 10: Sorting Data

Find and Replace U<
Use the Replace Command b=
1. Choose Homer>Editing=>Find & Select=>Find. The Find R =
and Replace dialog box appears with the Replace tab on G Ceer A (e [

top. (See Figure 10-17.) |
Figure 10-17: Exchange data with the Find

If you want to replace data in only certain cells, rows, or columns, and Replace feature.
select the desired area before you open the Find and Replace dio-

log box.

Miciosalt (Mfice Excel =]
_‘i‘_; Excel has comleted &5 sosech ond has made 368 replacoments,
=
In the Replace With box, enter the data with which you Figure 10-18: Making global replacements.
want to replace the found data.

In the Find What box, enter the data you want to locate.

If you want to look for data that also has specific formatting, click the
Format button and maich the formatting you are searching for.

4. Click Find Next to locate the first found occasion or
click Find All to display a list of all occurrences.

You can sort the results of a Find All search by clicking a column
heading. s Just s with the Find data, you can specify that the replacement data

must have specific formatting.

5. 1f you want to use the replacement data, click Replace.
Excel performs the replacement and locates the next
occurrence.

6. If you want to replace all occurrences at the same time,
click Replace All. Excel displays an information box, like
the one in Figure 10-18, indicating the number of
replacements made.

7. Click OK.
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Creating Charts

Whoever said a picture is worth a thousand words is most certainly
referring to a chart. Let’s face it. . . we like looking at pictures more
than we like looking at sheets of data. Charts, sometimes referred to as
graphs, provide an effective way to illustrate your worksheet data by making
the relationships between numbers easier to see. The chart turns numbers
into shapes and enables you to compare the shapes to each other.

If you've ever spent hours drawing a chart on graph paper, you'll really
appreciate the ease with which you can create dozens of different chart styles
using your Excel data. And you don't really have to draw a thing! With just a
few decisions on your part and a few clicks of the mouse, you have a two- or
three-dimensional illustration of your data.

Charts let you get your thoughts across with simplicity and strength and,
because different charts may cause you to draw varied conclusions, they also
prod you to ask questions about what you are seeing. Whatever the idea you
are trying to convey, charts make it easier.

In this chapter, discover how to
w= Quickly and easily create a chart
»= Modify a chart whether in appearance or content

w= ‘Work with a three-dimensional chart

| “*\apter

Getready to. ..

w= (reate a Basic Chart .......oooovvvveeeeee..ee. 102
w= |nsert a Chart 104
= Change the Chart Type .......oeeeeeecseeseeeee. 106
w= Adjust the Chart Location ...........ooc....... 106
w= Display a Chart Title ....ooooovrereeeneeeeeces 107
w= Cystomize the Chart Legend .................. 108
w= Add a Data Table 108
w= Show Data Labels 109
= Select a Chart Color Style .......eereernnnne... 109
= Change AXis OpHiONS ...........ceeeeeeennnnrrsen. 110
w= Enhance a 3-D Chart..................cnn........e. 1

w= Place a Picture in a Data Series
w= Adjust Chart Data

............... 112

112
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Chapter 11: Creating Charts

Create a Basic Chart

102

1.

Select the data (sequential or nonsequential) you want
to plot in the chart. See Figure 11-1 for an example of
sequential data selected for a chart.

Press the F11 key. Excel immediately adds a new sheet
called Chartl1 to your workbook with the data plotted
into a column chart. Each subsequent chart page is
numbered sequentially such as Chart2, Chart3, and so
forth. Figure 11-2 shows you the various elements that
can make up a chart.

Some newer keyhoards use a different function for the F11 key.
If your F11 key does not produce a chart, use the Insert fab as
explained in the next section.

Throughout this chapter you learn how fo edit the look and style of
a chart.

e Title: A descriptive name for the overall chart. By
default, titles are not added in a basic chart, but you
can add them later manually or by using the Chart
Wizard.

¢ X or Category axis: Column or row headings from
your selected data, which Excel uses for Category axis
names. In a column chart, the categories display
along the bottom. In other charts (such as a bar
chart), the category axis displays along the left side.

¢ X Axis Title: A descriptive name for the Category axis.
By default, a category label is not added in a basic
chart, but you can add one later manually or with the
Chart Wizard.

-

" A" | |GF
a2
P g (BT AEE W R o
- fore s — 5
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4 THIS YEAR LAST YEAR 2 YEARS

5 |SMITH 87.2 84.3 93.0

& |IONES 93.0 96.2 89.7

7 |ADAMS 120.1 103.7 112.4

8 |BAKER 104.0 102.1 - I

9 |ELLIS 71.0 98.0 104.2

10

11

12

13

14

15
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Figure 11-1: Select data for a chart.

Chart Title
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Create a Basic Chart

Y or Value axis: A scale representing the zero or the
lowest and highest numbers in the plotted data. The
Value axis is usually located on the left side on a col-
umn chart or on the bottom on a bar chart.

Y Axis Title: A descriptive name for the values. By
default, a value label is not added in a basic chart,
but you can add one later manually or by using the
Chart Wizard.

Legend: The box, usually located on the right, identi-
fies the patterns or colors that are assigned to the
chart data series. Notice in Figure 11-3 how the leg-
end explains that one shade of color represents
January, another shade is for February, and the third
color shade is for March.

Tick marks: The small extensions of lines that appear
outside of the gray area and represent divisions of the
value or category axis.

Gridlines: These lines extend from the tick marks
across the chart area to allow you to easily view and
evaluate data.

Series: Excel uses the worksheet cell values to gener-
ate the series. Each element, called a data marker,
represents a single worksheet cell value. Related data
markers make up a data series and have the same
pattern or color. In Figure 11-4, you can see the com-
parison of the data values to the y-axis and the series
values.

Plot area: The background that represents the entire
plotted chart area.

To delete this chart, right-click the Chart tab and select Delete. When
Excel asks for a confirmation, click Delete again.

Legend

Figure 11-3: A chart legend.

M. Chart] - Sheer

THIS YEAR LAST YEAR 2 YEARS

SMITH 87.1 84.3 93.0

IONES 93.0 962 897 |
ADAMS 120.1 1037 1124 |
BAKER 104.0 102.1 |
ELLIS 710 980 1042 |

Figure 11-4: Data displayed in a data series.
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Insert a Chart

104

1.

Select the data you want to plot in the chart.

Typically, if you are selecting values such as monthly figures, you
don't want to include totals in your chart.

Choose Insert=>Charts, and then select the arrow

beneath the chart style you want: Excel can create many

different chart types; each compares data in a different

manner. (See Figure 11-5.) Some of the most commonly

used chart types include the following:

e Column: Column charts compare values to cate-
gories using a series of vertical columns to illustrate
the series.

e Bar: Bar charts, like column charts, compare values to
categories, but use a series of horizontal bars to illus-

trate the series.

e Line: Line charts are similar to bar charts but use dots

to represent the data points and lines to connect the
data points.

e Pie: This chart compares parts to a whole. Usually a
pie chart only has one data series. Figure 11-6 illus-
trates data appropriate for a pie chart.

e Area: Area charts display the trend of each value, usu-

ally over a specified period of time.

e X.Y Scatter: These charts include two value axes, one
showing a set of numerical data along the x-axis and

the other showing data along the y-axis.

Figure 11-5: Seled the chart type uppropriuie for your data.

A B e D E F G H I ]
3 SMITH JONES ADAMS BAKER ELLIS
A |Sales 74 102 138 63 29
B
7
8 Sales

16
17
18
19

an.

Flgure ll 6 (reuieu pie chart from this data.

Click o chart type to see a sample and an explanation of the chart.
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Insert a Chart

e Surface: Shows trends in values in a continuous
curve.

e Doughnut: Displays data similarly to a pie chart; it
compares parts to a whole, but contains multiple
series.

e Stock: Stock charts are usually (but not exclusively)
used to illustrate the fluctuation of stock prices. In a
stock chart, the data order is very important and usu-
ally the row headings are High, Low, and Close; or
Open, High, Low, and Close. See Figure 11-7 for an
example of a stock chart.

e Radar: Displays changes in values relative to a center
point by comparing the cumulative values of multi-
ple data series.

e Bubble: These charts are similar to scatter charts, but
compare three sets of values by displaying a series of
circles.

e Cylinder, Cone, and Pyramid: Excel uses these three
chart types to create a column or bar chart using
three-dimensional cylindrical, conical, or pyramid
shapes.

Choose a chart subtype. Depending on the chart type,
some chart subtypes show the data series next to each
other; others show the data elements stacked on top of
each other. Some charts are two-dimensional, and oth-
ers are three-dimensional. As you see in Figure 11-8,
Excel creates the chart on the worksheet where your data
resides.

You'll soon discover how you can change the chart location to its
own sheet. But just in case you don't like your changes, make sure
to save your worksheet, which also saves your chart, before modi-
fying chart attributes.

[ I C D | & [T ) I3 1 7|
1 TODAY'S STOCKS
2 Migh  Low  Closs
i Microsoft 5.79
4 Apale 437
s Intat FER)
& Dell 219

Sheety ¥

Figure.l 1-7: A stock chart and it data.

The chart is a graphic object. See Chapter 7 to revisit how to resize or

delefe it.
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Figure 11-8: Creating an Excel chart.
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Chapter 11: Creating Charts

Change the Chart Type

1.

Click the chart to select it, whether it appears on its own
sheet or on a data worksheet. A Chart Tools tab with
three subtabs appears.

Choose Chart Tools Design=>Types>Change Chart Type.
The Change Chart type dialog box appears.

Select the different chart type and subtype you want.
(See Figure 11-9.)

Click OK. Excel modifies the existing chart.

Adjust the Chart Location

106

Click anywhere on the chart that you want to move.

On the Design tab, choose Locationm=>Move Chart. The
Move Chart dialog box appears. (See Figure 11-10.)

Select a location:

e New sheet: Creates a new worksheet and places the
chart on the sheet.

e Object in: Moves the chart to an existing sheet in the
workbook. Click the drop-down arrow to select the
worksheet to which you want to move the chart.

Click OK. Your chart is moved to the location you've
specified.

| Change Chan Typs =

3 Tercistes

[[smrage Tevoises.. | [[getes Detmircrat |

Figure 11-9: Selet a different chart type or subtype.

Move Chart (=]

Homte whrs you want the cht to be placed

_J?|| (2 Mew gheet: | Thart|

W] Ot on ]
|
Figure 11-10: Switch a chart from one location o the other.

To move the chart fo a different location on the current worksheet, posi-
tion the mouse over the edge of the chart and drag it to a new location.
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Display a Chart Title

Display a Chart Title

10.

Click anywhere on the chart you want to modify.

Click Chart Tools Layout=>Labels=>Chart Title. A list of
options appears:

e None: The default choice; it means you don't want to
display a title. Also use this option to remove a chart
title you don’t want.

e Centered Overlay Title: Centers the title over the
chart but retains the existing size of the chart.

e Above Chart: Centers the title over the chart but adds
room at the top so the title doesn’t interfere with the
chart itself.

Make a selection. A box with the words Chart Title (as
you see in Figure 11-11) appears on the chart.

Double-click the Chart Title and drag across the words
Chart Title. The words become highlighted.

Type the desired title. The text you type replaces the
words Chart Title.

Click anywhere outside of the chart title to deselect it.

Optionally, choose Chart Tools Layout=>Labels=>Chart
Title, More Title Options. The Format Chart Title dialog
box in Figure 11-12 appears.

Select Fill and then choose any desired background
options for the chart title. Excel’s Live Preview feature lets
you view various options without first selecting them.

Select Line, Line Style, and other title options, including
color, shadows, 3-D formatting, and much more.

Click OK.

|Chart Titie 1

Figure 11-11: Add a fitle to your chart.

Fatmat Chart Tl [2[%]

Fill

(=

figure 11-12: Select additional options for the chart fitle.

You can’t apply 3-D formatting or select a shadow if your fitle doesn't
have a border line around it.
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Chapter 11: Creating Charts

Customize the Chart Legend

1. Click anywhere on the chart you want to modify.
Click Chart Tools Layout=>Labels=>Legend.

Select a placement for the legend or click None to turn
off the chart legend. (See Figure 11-13.)

4. Click Chart Tools Layoutr>Labels>Legend=>More

Legend Options.

5. The More Legend Options box offers the same type of

formatting options as the Chart Title. Choose any
desired options. Click OK.

Add a Data Table

1. Click anywhere on the chart you want to modify.

Data fables can be added to charts on a regular worksheet, but it
isn't a common practice because the worksheet itself already dis-

plays the data.

2. Click Chart Tools Layoutr>Labels>Data Table. Options

108

include a choice not to show a data table, show a data
table but not show a chart legend, or to show a data
table and include the chart legend.

Make a Data Table selection.
Select the Show Data Table option.

Click OK. A data table, as seen in Figure 11-14, displays
at the bottom of the chart showing the actual values.

5
i

"
{El
k=

She

shign
Show Legend at Left
Show legend nd align

LEEEEE P

Figure 11-13: Placing the chart legend.

Data tables display the chart values in a grid beneath the chart. They
are very helpful if a reader needs to see exact values along with a
graphical display, such as when using a 3-D chart.

'GROWTH BY SALESREP|

Figure 11-14: Display the doo bl
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Select a Chart Color Style

Show Data Labels — =

1201

1. Click anywhere on the chart that you want to modify.

2. Choose Chart Tools Layout>Data Labels. A menu of
data label placement options appears.

100.0

3. Select a placement option. Figure 11-15 shows the data
labels with a placement of Outside End.

4. Choose Chart Tools Layout>Data Labelse>More Data
Label Options. The Format Data Labels dialog box
appears.

5. If you don’t want the data label to be the series value,
choose a different option from the Label Options area

(such as the series or category names). s s e . s
6. In the Number option, select a number style for the SN ey e e ——
data labels. Figure 11-15: Data Labels.

7. Select any additional options and then click OK.

Select a Chart Color Style Jasdldoodl Jond| T5all unl --

Click anywhere on the chart you want to modify. JonllJonl| Jenl| Jonl| Jonll Jend
2. Choose Chart Tools Design=>Chart Styles and click the dend Janl Jawld| Janld| dunl Janl
More but‘ton, which displays the Chart Styles gallery Jasl! Janll Jeul Jenll Jaul Jeul
seen in Figure 11-16. .
3. Select hart th Scroll d there” tth l‘ll ulll illj-lﬂﬂj .‘||H.| .-||I!-.|
. Select a chart theme. Scroll down . . . there’s more at the [
bottom. dand Janl Juwl Janl Janl Jasld

Figure 11-16: Select a chart color theme.
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Chapter 11: Creating Charts

Change Axis Options

1.

110

Click anywhere on the chart that you want to modify.
Choose Chart Tools Layout=>Labels=>Axis Titles.

Select Primary Horizontal Axis Title or Primary Vertical
Axis Title.

Choose an Axis title location. For the Horizontal axis,
your choice is only Below the Axis (or None). For the
Vertical axis, you have the option to rotate the title, run
it vertically along the axis, or run it horizontally. I don't
recommend the horizontal option because it takes up a
great amount of chart space. In Figure 11-17, you see
both a Vertical and a Horizontal Axis title.

Highlight the axis text and replace it with your desired
text.

Choose Chart Tools Layout=>Axes. Two options are
available:

e Axes: Choose this option to change the way Excel dis-
plays either the horizontal or vertical axis. You can
choose not to display an axis or you can change the
value representation along the vertical axis. Click the
More option to change choices such as axis-number
formatting. (See Figure 11-18.)

e Gridlines: Choose this option to change the way the
gridlines display along the chart background. You can
add, change, or remove horizontal or vertical grid-
lines. You can also select More Options to modify the
gridline color.

e GROWTH BY SALESREP I

MILLIONS

SALES REP

Bl Chart?  Shestl  Shestd  Gheerd feaciy  Shews ¢ ST S

Figure 11-17: For further information on your data, add an axis fitle.
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Figure 11-18: Changing axis options.
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Enhance a 3-D Chart

Enhance a 3-D Chart

Click anywhere on the 3-D chart you want to modify.

Choose Chart Tools Layout=>Background=>3-D View. The
Format Chart Area dialog box, shown in Figure 11-19,
appears. The options you see depend on the chart type.

From the 3-D Rotation option:

e Click the x-axis left or right rotation arrows or enter
the degree of left/right rotation (between 0 and 360)
you want for the chart in the Rotation box. This
rotates the pie slices left or right.

e Click the y-axis up or down rotation arrows or enter
the degree of up/down rotation.

e Click the Perspective up or down arrows to change
the “camera” view or the view from the top. You can
optionally type the elevation angle (between 10 and
80) in the Elevation text box.

From the 3-D Format option:

e Choose a Rotation Preset option to select a bevel
style for the top or bottom of the chart border.

¢ Change the thickness of the bars or height of pie
slices by entering a value (between 5 and 500) in the
Height box.

¢ Change the Depth option to deepen series bars and
the chart floor. This option does not apply to pie
charts. Values range from 0 - 2000.

Click Close. The chart appears on-screen, rotated to the
angles you selected. Figure 11-20 shows a 3-D pie chart
before and after changing the elevation and rotation.

Fatmat Chait Area 2%}
3-0 Rotation
¢ (8 (=]
/6 @
reoecee: 550 131 (@)
Text
DT DS BN
(o= )

.F.igure 11-19: Rotate a three-dimensional chart
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Figure 11-20: Enhance a pie chart.
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Chapter 11: Creating Charts

Place a Picture in a Data Series

1.

Right-click the series or data point you want to modify.
A shortcut menu appears.

Choose Format Data Series. The Format Data Series dia-
log box appears.

Click the Fill option. Fill options appear on the right
side. Select Picture or Texture Fill.

Click File. The Insert Picture dialog box appears.

Locate and select the picture you want to use. Click
Insert. The Format Data Series dialog box reappears.

Click OK. Figure 11-21 illustrates a pie chart where two
series were replaced with graphic images. Data labels
were also added for clarity

Adjust Chart Data
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Click anywhere on the chart that you want to modify.

Choose Chart Tools Design>Datam>Edit Data Source.
The Edit Source Data dialog box opens with the current
chart data selected in the worksheet (see Figure 11-22).

Click and drag in the worksheet to select the new data
range. The Edit Data Source dialog box collapses so you
can easily see your data.

Release the mouse button. The Edit Data Source box
reappears.

Click OK. The Edit Data Source dialog box closes.

Sales ]

Figure 11-21: Liven up charts with graphic images.

To quickly add or delete a series to a chart located on the same work-
sheet as the data, click anywhere on the chart that you want to edit.
Notice that Excel surrounds the chart with selection handles and marks
the source data in the worksheet with a colored border. Click and drag
the corner handle of the worksheet source range fo add or subtract cells.

A - Gl
. B C

1 SALESPERSON COMPARISON

THISYEAR  LASTYEAR TWO YEARS

5 SMITH 87.2 B43

o | JONES 93.0 96.2

5 [ADAMS 120.1 103.7

7 BAKER 104.0 102.1 -
8 ELLIS 71.0 98.0 104.2
9

SMITH JONES ADAMS BAKER ELLIS

Figure 11-22: Change the chart data selection.
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Printing Workbooks

LVhen you finish compiling your worksheet, you'll probably want to
print a hard copy or e-mail a copy to someone else. This chapter

shows you a number of Excel tools you can use to improve your document
layout, including headers, footers, page orientation, and margins.

Also, before you print or give your Excel file to someone else, you should
check it for spelling errors. You want to eliminate typos that scream to the
world, “I can’t spell.” Excel includes a built-in dictionary you can use to
check your workbooks for misspellings; however, it can’t read your mind.
If you type too instead of two, Excel probably won't indicate an error. But,
combine the spell check with careful proofreading, and it becomes a very
helpful tool.

When you are printing, Excel assumes you want to print the entire work-
sheet area unless you specify otherwise. You discover in this chapter how to
tell Excel exactly what you want to print. This chapter also includes these
topics:

m= Working with page breaks
w=  Adjusting the paper size

»= Making a worksheet fit when you must get a few last rows or columns
on a single page

»= Printing gridlines or row and column headings on the page, as well as
other options for printing your worksheet or chart

| “*\apter

Getready to. ..
= Spell Check

w= Preview Before Printing ....................
= Add a Manual Page Bredk ................
= Set a Specific Area fo Prinf ................

w= Adjust the Paper Orientation
and Size

= Make Worksheets Fit Better on a Page ....

= Specify Repeating Rows and Columns

w= Print Gridlines and Row and Column

Headings
w= Add a Standard Header or Footer ......
w= (reate a Custom Header or Footer......
w= Print Worksheets and Charts ..............
e E-Mail a Workbook
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Chapter 12: Printing Workbooks

Spell Check

1.

114

Choose Reviewr>Proofingm>Spelling. The Spelling dialog
box opens, and Excel highlights the cell where it finds
the first potential misspelling and also suggests possible
changes (as shown in Figure 12-1).

Spell Check reviews all cell values, comments, embedded charts,
text boxes, buttons, and headers and footers, but it does not check
profected worksheets, formulas, or text that results from a formula.

Select one of the following options:

e Change or Change All: Choose one of the sugges-
tions; then click Change to change just this spelling
mistake or select Change All if you think you made
the mistake more than once.

o AutoCorrect: Have Excel, in future workbooks, auto-
matically correct the mistake with the selected
replacement.

e Ignore Once: Click this button if you don’t want to
change the spelling of the highlighted instance.

¢ Ignore All: Click this button if you don’t want to
change the spelling of any identical instances.

e Add to Dictionary: Add a word, such as a proper
name or medical or legal term, to Excel’s built-in dic-
tionary so that Excel won't flag it as a potential error
in the future.

After you select an option, Excel proceeds to the next
error; when all potential mistakes are identified, Excel
asks you to click OK (as shown in Figure 12-2).

Spelling: English (1.5 [2[%]
it in [cionary:
Feburary fgrone Crce
ageeead |
[ ad o pxcronaey |
Sugpestion!
Frbruary.
Frbruarys | e |
| chagmay |
usecopet |
Dicgonary langusge: | Lrvghsh (U.5.) ]
Qericns... Cancel

Mictasalt Offico Fxcel o
The speling check is complete for the entire sheet.

o

Figure 12-2: The completed spell check message box.

Figure 12-1: Use the spell check to correct errors.
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Add a Manual Page Break

Preview Before Printing

1.

Click the Office Button.
Click the arrow next to Print and select Print Preview.

From the Print Preview screen (shown in Figure 12-3),
select from the following options:

e If you have multiple pages, click the Next Page or
Previous Page buttons to view additional pages.

e Click the Zoom button to enlarge the view. Click a
second time to reduce the view.

e Click the Print button to display the Print dialog box.

e Click the Page Setup button to display the Page Setup
dialog box.

e Click the Show Margins button to display the page
margins; then drag any margin line to manually set
margin sizes. Click the Margins button again to turn
off the margin lines.

Click the Close Print Preview button to return to
Normal view.

Add a Manual Page Break

1.

Click a cell in the row where you want the new page to
begin.

Choose Page Layoutr>Page Setupr>Breakst>Insert Page
Break. Dotted page break lines, similar to the ones
shown in Figure 12-4, appear.

e Sowmin i - it

Figure 12-3: Print Preview options.
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Figure 12-4: Insert a manual page break.
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Chapter 12: Printing Workbooks

Set a Specific Area to Print

1.
2.

Highlight the area you want to print. See Figure 12-5.

Choose Page Layoutr>Page Setup=Print Area=>Set Print
Area. Dotted lines appear around the print area. When
you print the worksheet, only the area contained within
the dotted lines prints. See “Print Worksheets or
Charts,” later in this chapter.

Adjust the Paper Orientation
and Size

116

Choose Page Layoutr>Page Setup~Orientation.

Select whether you want a Portrait or Landscape
orientation.

Choose Page Layout>Page Setup=Size. A drop-down
list of paper sizes appears.

Select a paper size. The paper size choices you see
depend on the printer you use. The two most common
US choices are Letter, which is 8.5 inches by 11 inches,
and Legal, which is 8.5 inches by 14 inches. (See Fig-
ure 12-6.)
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Figure 12-5: Specify a specific print area.
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Figure 12-6: Select a paper size.
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Set Page Margins

Make Worksheets Fit
Better on a Page

1. Choose Page Layout=>Scale to Fit.

2. Click the Scale to Fit dialog box launcher. The Page
Setup dialog box opens.

3. From the Scaling area, make a selection from the
options seen in Figure 12-7:

e Adjust To: Enlarge or shrink the printed font size by
setting a percentage option between 10 and 400.

e Fit To: Force Excel to a specified number of pages
wide and high.

Don't try to shrink the document oo much. Because Excel shrinks
the font, trying to fit too much on a page can make the document
typeface too small fo read.

4. Click OK.

Set Page Margins
1. Choose Page Layout>Page Setup=>Margins. Figure 12-8
shows a list of margin options.

2. Select from the margins options shown or choose
Custom Margins to open the Page Setup dialog box that
enables you to set your own margin options. Click OK.

From the Page Setup dialog box, click the option Horizontally and/
or the option Vertically in the Center on Page section to center the

worksheet on the page, regardless of the margins.

Page Setip (O] ]

Poge | Margem | MesderjFucter | hest

) Portrst | -Ar] 3 Landseacs

O adustro: (100 (% % nomal sae

= B o 1 T pogels) wide by |2 =
Papes sige! | Letter -
Print guallty: 600 dol- »

Fiust page rumber:  Fako

[Lgmt. | [Poeprenss | [ gooons.. |

[ J[ e ]

Figure 12-7: Squeeze your worksheet onto a specified number of pages.

Figure 12-8: Set worksheet page margins.

The default worksheet margins are the Normal setfings, which are .75
inch on both the top and bottom and .70 inch on the left and right sides.
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Chapter 12: Printing Workbooks

Specify Repeating Rows
and Columns

1. Choose Page Layoutr>Page Setup=>Print Titles. The Page
Setup dialog box opens.

2. On the Sheet tab, type a dollar sign ($) followed by the
row numbers or column letters you want to print as
titles in the Print Titles section. Entering $1:$1, as you
see in Figure 12-9, repeats row 1 at the beginning of
each page. Click OK.

Click the worksheet icon on the right to collapse the Page Setup dia-
log hox so you can select the rows or columns you want to incude.
Click the button again to return fo the Page Setup dialog box.

Print Gridlines and Row
and Column Headings

1. Choose Page Layout=>Sheet Options.
2. Choose from the following options:

e Gridlines>Print: Check this option to print the grid-
lines surrounding each cell in the worksheet.

e Headings=Print: Check this option to print the row
numbers or column letters around the worksheet.
Figure 12-10 illustrates a worksheet printed with grid-
lines and row and column headings.
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Figure 12-9: Select rows or columns fo repeat at the top of each puge.
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Figure 12-10: A printed worksheet with column and row headings and gridlines.
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View Other Header and Footer Options

Add a Standard Header or Footer

1.

Choose Viewr>Worksheet Viewse>Page Layout View.
You see the header area of your worksheet.

Choose Header & Footer Tools Design =>Auto Header or
Auto Footer. A list of predefined headers or footers
appears as you see in Figure 12-11.

Select the header or footer you want to use.

UView Other Header and
Footer Options

1.

Choose ViewsoWorksheet Viewse>Page Layout View.
Choose Header & Footer Tools Design.

From the Options group, select any of the options
shown in Figure 12-12:

e Different first page: If you choose this option, Excel
won't print the header or footer on the first page.

¢ Different odd and even pages: Choose this option if
you want a different header or footer for the odd-
numbered pages of the document.

e Scale with document: This option is selected by
default and tells Excel to use the same font size and
scaling as the worksheet. If you want the header and
footer font size and scaling independent of the work-
sheet scaling, clear this check box.

e Align with page margins: Choose this option to
align the header and footer with the left and right
margins of the worksheet.

£rfe:| )
ges

STATE P

..... Page 1580 EGEE

Figure 12-11: Insert the worksheet name in the header or footer.
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Figure 12-12: Additional Header and Footer options.
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Chapter 12: Printing Workbooks

Create a Custom Header or Footer

1.

2.

6.

120

Choose Viewr>Worksheet Viewst>Page Layout View.

Click Go To Footer to jump to the foofer area.

In any desired header or footer section, type the text
you want for the header (or footer). As you see in Fig-
ure 12-13, you can format the header and footer text
just as you would any cell data.

Click any options from the Header and Footer Elements
group:

e Page Number: Insert a code that indicates the page
number.

e Number of Pages: Insert a code that indicates the
total number of pages.

e Current Date or Current Time: Insert the print date
or time of day. See Figure 12-14.

e File Path, File Name, or Sheet Tab Name: Include
file information.

e Picture: Insert a graphic image such as a company
logo.

e Format Picture: Resize, rotate, or crop a header or
footer graphic image.

Click OK.
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Figure 12-13: Format header or footer fext.
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Figure 12-14: (reate a customized header or foofer.
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E-Mail a Workbook

Print Worksheets and Charts

1.

Choose Officer>Print. The Print dialog box, shown in
Figure 12-15 appears.

Optionally, print the worksheet immediately by clicking the Print
button on the Quick Access toolbar.

Choose from the following options:

e Name: Select a printer different than the default
printer.

e Print Range: Specify whether to print the entire

worksheet as determined by the print area or whether

to print only specific pages.
e Copies: Select the number of copies you want to print.

e Print What: Choose whether to print the current

worksheet, a preselected area, or the entire workbook.

Click OK.

E-Mail a Workbook

1.

Choose Officer>Send=>E-Mail. As you see in Figure 12-16,

your e-mail program launches with the worksheet as an
attachment.

Recipients must have Excel installed on their systems to open the
workbook file.

Enter the recipient e-mail information and any addi-
tional text in the body of the message.

Click Send.
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Figure 12-15: Select from a plethora of print options.
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Figure 12-16: E-mail Excel information to others.
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Part IV
nalyzing Data
with Excel

The 5th Wave By Rich Tennant
OrerErmar

“Our customer survey indicates 30% of our
customers think our service is inconsistent,
40% ould like a change in procedures, and

50% think it would be real cute if we all
wore matching colored vests.”
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Working with
Outlines

LVhen you are working with a large worksheet, it is sometimes difficult
to look at the big picture your data presents to you. You can use Excel
to automatically calculate subtotal and grand total values from rows con-
taining related data (sometimes called a database). When you create subto-
tals, Excel outlines the list so that you can display or hide the detail rows for
each subtotal.

A couple of other database terms you should become familiar with are fields
and records. Fields break down your database list into manageable pieces by
using Excel columns. For example, an address database might include fields
such as name, address, and phone number. Records are the rows containing
the individual pieces of information you enter. In an address database, for
example, a single row contains all the information about a specific person.

Before you use the subtotal function, you must first sort your list so that

the rows you want to subtotal are grouped together. You can then calculate
subtotals and perform other mathematical calculations for any columns that
contain numbers. You can also count the number of items in a selected
field.

If your data is not in a database format, you can still group sections to create
a quick way to display or hide them as necessary. Similarly to the way it does
subtotals, Excel displays groups in an outline format. In this chapter, I take a
look at the extensive subtotaling, grouping, and outlining features contained
in Excel. I also show you how to create a data entry form screen for faster
data entry. By default, Excel 2007 doesn’t include the Form command you
need for this, but I'll show you how to add it to your Quick Access toolbar.

| “*\apter
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Chapter 13: Working with Outlines

Add the Form Button

1.

Choose Office Buttonm>Excel Options.
Click Customization.

From the Choose Commands From drop-down list,
select Commands not in the Ribbon.

Click Form.

Click Add. Excel places the Form command in the right-
hand column. (See Figure 13-1.)

Click OK. Excel places the Form command in the Quick
Access toolbar.

Create a Data Entry Screen

1.

126

Enter the column headings for your database. When you
create the data entry screen, the column headings
appear as field names.

Click in any table heading cell and then choose Form
from the Quick Access toolbar.

Click OK if a message box appears. If you already
have records entered into the database, Excel does not
display the message box. Instead, Excel displays a data
form with the headings shown as field names. See
Figure 13-2.

Figure 13-1: Making the Form command accessible.
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Figure 13-2: Create a data form.
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Manage Records through the Form Screen

Enter the information for the first record and press the
Tab key to move from field to field (see Figure 13-3).

s Press Shift+Tab key to move back to the previous field.

Click New. Excel adds the record to the database and

displays another blank screen ready for the next record.

Click Close when you finish entering data.

You can reopen the database form at any time by clicking the Form
button on the Quick Access toolbar.

Manage Records through
the Form Screen

.

Choose Form from the Quick Access toolbar. The Form
window opens.

The active cell must be somewhere within the database headings or
@ data.

Click Find Next. The form displays the next record in
your database.

Click Find Prev. The previous record in your database
appears.

If you want to delete the current displayed record, click
the Delete button. The warning message you see in
Figure 13-4 appears.

Click OK if you want to delete the record. Use caution.
This action cannot be undone!

Click the New button to display a blank form where you can enter a new
record.

want to locate in the applicable field. Click Find Prev or Find Next o nav-
igate through the matches. Click the Criteria button again to change the
search criteria.

s To quickly look for specific records, click Criteria and then enter data you

Sheall (]%]
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Figure 13-3: Enter database records with a form.
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Figure 13-4: Delefing unwanted records.

TEAM LinG

127



Chapter 13: Working with Outlines

T —
Generate a Subtotal e
-
1. Sort the field to use for generating subtotals. For exam- S =
ple, if you want to know the total sales by salesperson, o 3
you sort by the salesperson field. See Chapter 10 for :’n';}:‘_;:‘,"'
sorting instructions. e =
.—iﬁ’ubwmmw:m
2. Choose Datar>Outliner>Subtotals. The Subtotal dialog )bk o
box appears. [T | |
3. Select the field you want to subtotal from the At Each Figure 13-5: Select fields to calwlate.

Change In drop-down list.

4. Select a function from the Use Function drop-down list. B e i it e & .
*cusn NI PR I
5. Select the fields you want to subtotal from the Add ey IR A EEAEE G g o =
Subtotal To drop-down list. (See Figure 13-5). You can £ e — = - —

select more than one field to subtotal. R

6. Check the Replace Current Subtotals box if you already
have previous subtotal calculations. Excel replaces the
previous subtotals with the new ones.

7. Check the Page Break between Groups box if you want
Excel to begin each subtotaled group on a new page.

8. Remove the check from the Summary below Data box if
you want Excel to place the subtotals at the top of each
group instead of under each group.

9. Click OK. Excel performs the subtotal. Figure 13-6
shows sales subtotaled by Name.

Capilock @ A 3 T it

Figure 13-6: A subfotaled worksheet.
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Control Individual Subtotals

Collapse Subtotal Headings

1.

2.

Create subtotals of your data (see the “Generate a
Subtotal” section, earlier in this chapter).

Hide and show data using the following methods:

e See only the grand total: Click the 1 on the subtotal
headings.

e See the subtotal categories and amounts (the detail
is hidden): Click the 2 on the subtotal headings
(the column on the left side of the worksheet).
(See Figure 13-7.)

e Show all the detail and subtotals: Click the 3 on the
subtotal headings. Excel displays the individual work-
sheet rows.

Control Individual Subtotals

1.

Create subtotals for your data (see the “Generate a
Subtotal” section, earlier in this chapter).

Click the Hide Detail button (minus sign) next to any
subtotal row. As shown in Figure 13-8, the selected
subtotal detail collapses. The detail data for Bear
Services is not lost, only hidden.

Click the Show Detail button (plus sign) next to any
subtotal row. The detail data for the selected row
appears.
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Figure 13-7: Collapse and expand entire subtotal sections.
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Figure 13-8: Collapse and expand individual sections.
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Chapter 13: Working with Outlines

Create Multiple Subtotals

1.

10.

130

From the Sort dialog box, first select the column to use
for generating primary subtotals and then the column for
generating secondary subtotals. For example, if you want
to subtotal sales by state and then by city, you first sort by
state and then by city. See the example in Figure 3-9.

Choose Data>Outliner>Subtotal to display the
Subtotals dialog box.

Select the primary field you want to subtotal from the
At Each Change drop-down list.

Select a function from the Use function drop-down list.
Use Count for this example.

Select the fields you want to subtotal from the Add
Subtotal To drop-down list.

You can select multiple fields to subtotal. For example, in a sales
tracking worksheet you might want to total the sale, the sales fax,
and the shipping amount.

Click OK. Excel summarizes the data by the first selected
field.

Choose Data=>Outliner>Subtotal. Excel again displays
the Subtotal dialog box.

Select the secondary field you want to subtotal, the type
of function, and the fields you want to subtotal. In this
example, I want a count of the City field.

Remove the check mark from the Replace Current
Subtotals box.

Click OK. Figure 13-10 illustrates the vendor list subto-
taled first by State and then by City.

As you perform additional subtotaling, Excel adds additional levels. In
Figure 13-10, four heading levels are displayed. Level 1 displays only
the grand totals, level 2 displays the count by State, level 3 shows the
count by City, and level 4 displays the detail.

[Son =3

[¥] My data has beaders

“yasaiel |[ X peimievel | L3 Gopyievel ;|{?;5__T][;mm m
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[T ——

Figure 13-10: Click the heading levels to expand or collupse the subtotals.
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Remove Subtotals

Copy Subtotals

1.

Hide any unwanted Detail buttons by clicking the
Expand or Collapse buttons.

Select the data you want to copy.

Choose Home=Find & Select=> Go To Special. The Go
To Special dialog box opens (see Figure 13-11).

Select the Visible Cells Only options. White lines appear
around the selected cells.

Click OK.

Choose Homew> Clipboard=>Copy. A marquee appears
around the selected cells.

Select the first cell of the group in which you want to
place the copied data.

Choose Homer>Clipboard=>Paste. Excel duplicates only
the subtotaled values, not the formulas or hidden cells.

Remove Subtotals

1.

Choose Datar>Outliner>Subtotals. The Subtotal dialog
box appears. (See Figure 13-12.)

Click Remove All. Excel removes all subtotal informa-
tion from the database, including the Expand and
Collapse icons from the left side of the worksheet. Your
data remains in the order you last sorted it.

Go Ta Spocial (2]
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() fgects
Ce ] [l ]

Figure 13-11: The Go To Special dialog box.
You can also use for the Go To Special box if you want fo select only cells
with constant values or only those containing formulas.
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Figure 13-12: Remove subtotals from the database.

The copy subtotal process also works if you have your data in outline
format. See more about outlining later in this chapter.
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Chapter 13: Working with Outlines

Use AutoOutline

1.

132

Choose Data>Outliner>Group>AutoOutline. Fig-

ure 13-13 illustrates a worksheet with outline headings
for both rows and columns. Row outline symbols are on
the left, and column outline symbols are at the top of
the worksheet

AutoOutline works by evaluating summary formulas that reference
cells in the detail cells. The summary formulas must be adjacent to
the detail. Based on the information in the summary functions, it cre-
ates all the possible outlines pertaining fo the layout of your data.

You can create and apply formatting to an outline before or after
you create the outline. See Chapter 5.

To expand the outline, click the Show Detail buttons to
the left of the rows or above the column headings. (See
Figure 13-14.)

To collapse the outline, click the Hide buttons to the left
of the rows or above the column headings.

When you print an outlined worksheet, Excel prints the worksheet
as it is shown on the screen. Hidden detail does not print.

To remove the AutoOutline, choose Data>Outline=>
Ungroup=Clear Outline.

To hide an outline without removing it, display all the data by dick-
ing the highest number in the outline symbols and then choose
Office=>Excel Options. From the Advanced tab, remove the check
from Show Outline Symbols if an outline is applied.

‘ tuaary Febiuary Mach  TOTALISTOTR  Apdl tay (="
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Figure 13-13: A worksheet with outline headings.
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Figure 13-14: Click the plus or minus buttons to hide or display parts of the
workbook. TEAM LinG



Remove Items from a Group

Form an Outline Group

1.
2.

3.

Highlight the rows that you want to group.

Choose Data=>Outline=>Group. In Figure 13-15, you see
all the file cabinets in the asset list grouped together.

Optionally, to create a group, select the rows or columns then press
Alt+Shift+right arrow.

Use the Hide or Show Detail buttons fo hide or display the group
detail.

Repeat Steps 1 and 2 until you have created all the levels
you want in the outline. A worksheet can have up to
eight outline levels.

Grouped areas cannot be immediately adjacent to other grouped
areas. If you create a group then create another group directly next
to it, Excel doesn't create two groups; it creates one larger group.

Remove Items from a Group

1.

Select the rows or columns you want to remove from
the group. If you want to remove an entire group, select
all the rows or columns in the group.

Choose Data>Outline=>Ungroup. Excel removes the rows
or columns from the group and if the rows or columns
you delete are in the middle of a group, Excel breaks the
group into two smaller groups. See Figure 13-16 where
the file cabinets are broken from one group into two
smaller groups.
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Figure 13-15: Create a manual group.
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Figure 13-16: Splitting up groups.
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Filtering Data

A fter you create an Excel database and assemble a large amount of data,
you probably want to analyze it. You may want to ask yourself ques-
tions about your data. “Who are my best customers?” “Which inventory
items are provided by a specific supplier and cost less than a certain
amount?” “Which employees work the least amount of hours?” Excel
includes several tools you can use to answer these questions and study your
data so you can make better decisions.

Filtering means that Excel can pull out specific records for review. This pro-
vides you with an easy way to break down your data into smaller, more
manageable chunks. Filtering does not rearrange your data; it simply tem-
porarily hides records you don’t want to review so you can clearly examine
those you do.

You can create your filtered database just by typing in the Excel screen. You
can also use an Excel data entry screen, but it isn't required.

This chapter is devoted to the different ways you can filter your data
including

w= Using AutoFilter, which allows you to select key pieces of data.
w= Selecting records by using more than one condition.
»= Displaying only the top x number of records.

w= Using multiple filtering to locate records that either match all criteria
or meet one or the other criteria.

== Performing advanced filtering to designate a specific area of your
worksheet to manage your criteria selections.

| “*\apter

Getready to. ..
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w= Remove Filtering 137
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w= Perform a Secondary Filter Selection ........138
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Chapter 14: Filtering Data

Create an AutoFilter

1.

2.

136

After clicking anywhere in your database, choose Datar>
Sort & Filter=>Filter. Excel displays a filter arrow in each
database column.

Optionally, choose Home=>Sort & Filter=>Filter.

In Chapter 4, you discovered you could choose HomecDStyles=>
Format as Table. After you selected a style, your table automatically
appeared with filter arrows.

The AutoFilter feature is unavailable for protected worksheets.

Click the arrow in the column heading from which you
want to find a common value. Excel displays a drop-
down list, which includes one of each unique entry (up
to 10,000 entries) in the selected column (as you see in
Figure 14-1).

Remove the check mark from Select All. All items
become unselected.

Click the entry you want to filter and then click OK.
Excel displays only the records that match your choice.
In Figure 14-2, for example, you see only the vendors
from Georgia.

The filter arrows on filtered columns take on a different appearance
to indicate that a filter is in use.

C
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INDIALR | Semasez
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Figure 14-2: Filter by state.
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Search for Blank or Non-Blank Cells

AutoFilter menu at the top of the list of values. Then, at the botfom of
the list, remove the check mark from (Blanks).

Re move Fl‘lterl‘n q S To filter for nonblank values, make sure Select All is chosen in the

1. From the column containing filtering, click the filter
arrow and choose Clear Filter from “field name” (see
Figure 14-3).

Optionally, click the Select All option. ‘ isias

2. Click OK. The filtering is removed from the selected
field.

3. When you finish filtering your data, choose Datar>Sort
& Filter=>Filter to turn off the AutoFilter.

e oo

Figure 14-3: Remove a filter.

Search for Blank or Non-Blank Cells Tl —

1. Make sure the AutoFilter option is on and your database 2 R S M e B g, e
columns contain filter arrows.

A B C D E |
2. Click the arrow in the column heading where you want -,%2-?."::@:& — . E—;:::.nm-::s — f':
to ﬁnd a blank cell' ::;- WIRING CONCEPTS, Inc CARMEL 46002
3. Remove the check mark from Select All. All items i
become unselected. Figure 14-4: Locate records with blank values.

4. Scroll to the bottom of the list and check the (Blanks) .
entry. It should be the only one selected. s You can turn the AutoFilter on and off as often as you need fo.

5. Click OK. Excel displays only the records with blank
cells in the column you selected (as you can see in
Figure 14-4).
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Chapter 14: Filtering Data

Perform a Secondary Filter Selection

1.

138

Make sure the AutoFilter option is on and your database
columns contain filter arrows.

Click the column arrow by which you want to filter data
first.

Choose the data you want to filter. In Figure 14-5, you
see only selections that display Atlanta in the City col-
umn. Note, however, that there is an Atlanta in GA, IN,
OH, and NY.

To further isolate specific items, click the filter arrow at
the top of another column.

Select the field by which you want to perform the sec-
ond filter. In Figure 14-6, the primary option was to fil-
ter by the city of Atlanta. I now apply the state of GA as
the secondary filter (because, in Step 3, four states had a
city named Atlanta).

Repeat Steps 4 and 5 to further filter by as many fields
as necessary.

When you're finished working with your filtered data,
choose one of these options:

e Return to the first filter: Click the second filter col-
umn arrow and choose a different second filter.

e Return to the first filter only: Click the second filter
column arrow and choose Clear Filter from “field
name.”

e Return to viewing all records: Choose Data=>Sort &
Filterr>Clear.
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Flgure 14-5: Select the first filfer.
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