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Introduction

M acromedia has always been known as a leading-edge design company.
Since it introduced Director more than a decade ago, Macromedia
has shrewdly developed products (like Fireworks and Dreamweaver) and
acquired products (such as Flash and FreeHand) geared toward turning
artists into developers. With its acquisition of Allaire, Macromedia added

a powerful technology platform to its suite of design-oriented products.
Macromedia Studio 8 integrates the Macromedia products into a single set
of Web development tools. The result? We've worked in Web development
since its inception, and we can honestly say that there’s never been a prod-
uct that is as well designed for Web designers as Macromedia Studio 8.

About This Book

Macromedia Studio 8 All-in-One Desk Reference For Dummies (we know, it’s a
mouthful) is designed to be a hands-on, easy-to-understand guide to the fea-
tures in all the Macromedia Studio products. The no-nonsense approach is
designed to help you begin to build Web sites by covering the basics in a
clear and concise fashion. The way we see it, you've got things to do, and
reading a book, even a clever one, takes up valuable time. The faster we can
help you do something or answer a question, the better.

There have been some changes in the latest version of Macromedia Studio 8
that are worth noting here. In Studio 8, FreeHand and ColdFusion have been
dropped from the product. However, we still cover them here because if you
have upgraded from a previous version of Studio, then you still have those
products on your computer. In addition, you can still download FreeHand
MX and the developer edition of ColdFusion from the Macromedia Web site.

How to Use This Book

You can use this book in a few different ways:

4+ As areference: If you already have a Web site and use Macromedia Studio,
this book can be a handy refresher for that thing you couldn’t quite
remember how to do. Whether it’s exporting graphics to Macromedia
Flash from FreeHand, or the right syntax for a query in ColdFusion, use
this book to fill in those gaps that we all have. . . . especially as we get older.
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Three Presumptuous Assumptions

4+ To guide you through building a Web site: Several authors contributed
to the creation of this book. All of us have a wealth of experience in the
process of building Web sites. In this book, we’ve tried to impart as much
of our collective knowledge about the processes and pitfalls of building
Web sites using these tools as we can.

4 To learn about the tools: In this All-in-One Desk Reference, each minibook
has at most 150 pages to cover a product or topic, which means that we
get right to the point and make the topics covered easy to understand.
We believe that this approach makes figuring out these products easier.

Three Presumptuous Assumptions

Before you dive into the book, we thought we should give you some advance
warning of our expectations. We know, you're the audience, so we shouldn’t
assume anything! But, just so you know where we’re coming from, here are
our three basic assumptions about you, the reader:

4 You're in a hurry. Frankly, if you wanted a more in-depth book, you’d
have picked up a regular For Dummies book on one or all of these prod-
ucts. Hence the no-nonsense, get it done, and keep on moving approach
you'’re gonna see inside this book.

4 You know something about Web development. This isn’t a book in
which we’ll spend a lot of time talking about HTML and how it works.
So you won't find a chapter anywhere in this book titled, “What the
Internet Is and How It Works.”

4+ You’'ll experiment on your own. The approach here is to give you quick,
useful examples of how things work across all these products. In some
cases, the examples can be fairly sophisticated. In most cases, though,
it’s the basics. Our hope is that you'll take those basic examples and build
your own, more complex ones on top of that, according to the complexity
of your site.

Macintosh versus Window's

Macromedia Studio is both a Windows and a Macintosh product. In this book,
you see us use the Windows commands, and the figures all show Windows XP.
If you are using Macromedia Studio on the Mac, you can still do everything
in Book VIl if you're using ColdFusion at your place of business or if your
Internet service provider (ISP) supports ColdFusion.

In general, you can convert between Windows (PC) and Macintosh key com-
mands by using the following equivalencies:
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4+ The Ctrl key on a PC is equivalent to the Command (88) key on a Mac.
4+ The Alt key on a PC is equivalent to the Option key on a Mac.
4+ The Enter key on a PC is equivalent to the Return key on a Mac.

How This Book Is Organized

Like all the All-in-One Desk References, this book’s chapters are organized
into minibooks. Most of the minibooks revolve around products, but one is
geared toward the Web development process. The following sections describe
each minibook in more detail.

Book I: An Introduction to Building Web Sites

Before we jump into the products in the Macromedia Studio suite, we want
to frame the conversation around how Web sites get built: things to consider,
organizing yourself, and so on. This minibook walks you through how to figure
out what it is you’re really building and how you should go about preparing
to build it.

Book 1I: Dreamweaver 8

Dreamweaver 8 is the crux of any Web development effort with Macromedia
Studio, so naturally, this is a good place to start. In this minibook, you get a
hands-on look at how you can use Dreamweaver to create and manage your
Web sites, whether they’re more design-oriented (with Macromedia Flash) or
technology-driven (with ColdFusion).

Book 11I: Fireworks 8

Whereas Dreamweaver is the tool that helps you manage your Web site,
Fireworks 8 is designed to spur your creative vision. This minibook shows you
how to use the variety of tools in this impressive program to bring the look and
feel of your site to life. It also shows you how to use Fireworks in conjunction
with the other Macromedia Studio products (such as Macromedia Flash)
effectively.

Book 1U: Flash 8

Macromedia Flash 8 is probably the most exciting of the Macromedia prod-
ucts. Flash delivers animation, sound, and interactivity to the Web like

no other product ever has. If you've ever wanted to find out how to use
this tool to add some new zeal to your Web site, then this is the minibook
for you!
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Icons Used in This Book

Book U-: Contribute 3

In this minibook, we introduce you to the newest member of the Macromedia
Studio family, Contribute 3. Designed as a collaborative tool that turns your
hard development work into an easy interface for non-techies to update and
publish content to the Web, Contribute puts the power of building Web sites
in the hands of the people you work with. In this minibook, you find every-
thing you need to know to get you and your collaborators up and running
with Contribute in no time flat.

Book Vl: FreeHand MX

This is the minibook for the true illustrators. Whether the final product is a

Flash-based or a traditional HTML-based site, FreeHand MX gives designers

the tools they need to create compelling imagery. In this minibook, you find
out how to turn your ideas into working graphical art to be used in a variety
of Web applications.

Book VII: ColdFusion MX 7 Developer Edition

ColdFusion, once left for dead by many in the industry, now appears well-
poised to lead mainstream Web development into the dynamic content arena.
In this minibook, you too can find out just how easy it is to use ColdFusion
to create dynamic Web sites.

Icons Used in This Book
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Along the way, when there’s something of interest to point out, we toss in one
of the icons you see in the left margin. When you see one, slow down for a
moment to check it out to see what’s up!

If there’s a way to make something easier, or a more commonly accepted
way of doing something, we tell you about it. This is the icon to look for!

When we really want to reinforce something, we throw in a Remember icon.

Pitfall ahead! That’s what this icon is all about. If something could cause
trouble, we let you know.
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Because we love technology, you have to forgive us for geeking out every
now and then. When we do, though, we let you know with this icon.

s UD-‘O This icon highlights new features in the Macromedia Studio 8 suite of
S“ products.

Where to Go from Here

If you've read this far, then you may actually be a candidate for reading this
book from cover to cover! From here, we suggest you dive right in to what-
ever section you're most interested in. Remember, all these minibooks are
self-contained and don’t require you to read the others. So have at it. It’s
buffet time, and your plate needs fillin’ up!
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Chapter 1: Why Build a Web Site?

In This Chapter

+~ Exploring the reasons that Web sites get built

v Finding your place on the Web

+ Understanding what drives people to the Web
 Investigating common types of Web sites

1 Getting ready to build a Web site

S) you want to build a Web site? Well, congratulations! If you're reading
this book, then you've probably already purchased a copy of Macromedia
Studio 8, and you're ready to dive right in. Macromedia Studio is a fantastic
tool that enables you to create a wide array of content and graphics to deploy
on a Web site that is dynamic and easy to maintain.

But software isn’t all you need in order to create a wonderful Web site. It also
takes creativity, a good eye, a well-thought-out plan, and some serious soul
searching about why you want to undertake this endeavor in the first place.
This chapter offers some insight into how sites get built, why they are cre-
ated, and who they are aimed at. So grab your pen and paper and get ready
to jot down your own ideas about the great site that you want to build.

Understanding Why People Build Web Sites

In the early days of the Internet, all Web sites generally looked the same and
served similar functions. Back then, an average Web site could be described
as a big online book with linked pages. In short, in its infancy, the Internet was
not all that interesting graphically and was severely lacking in interactive
sophistication.

All that has changed. Today’s Internet is a dynamic amalgam of text, graph-
ics, interactive tools, commerce, and communication. If you are part of

a business, an association, the government, or an academic institution,
chances are a Web site supports some or all of your group’s mission. But
not every venture requires a Web site, which naturally leads to the question,
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“Why build a Web site?” Most organizations and individuals establish a pres-
ence on the Internet for one or more of the following reasons:

+

<
<+
+

+

To sell a product or service directly online, as shown in Figure 1-1
To provide information or tools
To provide an extension of — or support for — products and services

To find other organizations or people to work in a particular area of
interest

To introduce and promote an organization and its mission

4+ To remain competitive with other organizations that are on the Internet

already
4+ To promote community development by bringing groups of people
together around ideas, people, or causes, either online or in person
4+ To share artwork, writing, or photographs
£1414 Inc. - Microsoft Internet Explorer (=%
Flle Edit View Favorites Tools Help [
Qo - - |x [&] @b POsut Spraons @ @) S L) B
Sl 48] Bt faems 415, camhome aqethasmramg i:| B s @85k o
415

Figure 1-1:
A common
product and
service—
style Web
site.

Finding Your Place on the Web

Before you begin to think about the kind of site you’re going to build
(either for yourself or for your organization), you should consider each
of the following questions carefully. Doing so can help you target your site
to an appropriate audience and prepare yourself for the work ahead.
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4+ Consider your content:

e What is the content going to be on your site? Is it unique?

How often will you be updating this content?

Are there any other sites that already do what you want to do? If so,
how will you differentiate your site?

Consider the early explosion of sites during the dot-com boom. At one
point, more than five pet sites were all trying to hawk their wares to users.
Only one survived, and that was because it was a traditional retailer first.
Market saturation is a sure way to spell doom for your venture, so be sure
to check out the competition first!

4 Select a format and interface:

In what formats will your content be delivered? Will you just use
text and graphics, or will you also need animation and/or forms
that respond to user input?

What are the technical requirements needed to view your content?
Will users need a video or audio player or plug-in? For example, to
view a Flash animation, users need the Macromedia Flash Player
plug-in. (Luckily, almost all users will have some version of the Flash
Player installed, and if they need a more recent version, they can
download it easily from www.macromedia.com.)

4+ Know your audience:

What audience or audiences are you trying to reach with this content?
Do they need or want it?

Is there any other place they can get this content already?

What are the demographics and technical capabilities of this audience?

If your site has more than one audience, are there differences between
them and do they need the content delivered differently? If so, you will
want to take advantage of ColdFusion’s dynamic scripting language
to deliver different content to different audiences.

4+ Manage your workload:

How much time and effort are you willing to give in order to support
this site?

Are other people working on the site with you?

e Who’s going to create the graphical design for the site? Of course, if

it’s you, you’ve got powerful tools at your disposal with Macromedia
Studio 8.

Are there any deadlines you need to keep in mind when developing
your site?

Book I
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These questions have no right or wrong answers. Instead, they’re designed
to help you formulate an idea of where you’re going when you’re building a
site. Frankly, if you’re building a personal site, then these questions are moot
to some degree because you can build whatever you want and it may not
matter whether someone else can read it or see it. Of course, if you're think-
ing about selling your new products on the Web, then these questions can
be critical to your overall business success, not just your Web site’s success.
For example, if you find that a number of other sites have similar products or
a similar focus to what you had in mind for your site, you may consider not
building a site at all or changing the focus of the products you are selling.

What Drives People to the Web

What kinds of services, you may be wondering, are people looking for on the
Internet? Eight or nine years ago, the Internet was largely a research medium,
meaning that people would hit the Internet to try to find information about
something fairly academic or obscure. This is not surprising, given that uni-
versities were the first groups to start putting their content online.

Today, the number of reasons people head to the Internet has grown dramat-
ically and includes the following:
4+ To research, compare, and purchase products

4+ To find and interact with other people (business colleagues, friends,
romantic interests)

4+ To get daily news and information delivered in real time

4+ To search for and find information about any topic or organization of
interest

4+ To deliver and promote their own messages and products to others on
the Web

4+ To watch or listen to events, online and otherwise, delivered in a variety
of audio and video formats

+

To educate themselves via online classes and enrollment in universities

+

To play games and entertain themselves

4+ To complete all sorts of personal and professional tasks that can now be
done securely online, such as online banking, personal finance, invest-
ing, tax submission, travel, donating, and procurement

These items run the gamut of professional and personal, and they cross demo-
graphic lines. What is common among most online users, though, is that they
begin their online usage with a focused purpose, and that focus then bleeds
over into surfing for things that interest them throughout the Web.
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Choosing the Right Type of Web Site

For all its diversity in content, the Internet really doesn’t have that many dif-
ferent types of Web sites. Why do so many Web sites look alike? The main
reason is that people want their sites to be easy to use, free (or close to it),
and similar to other sites they’ve seen or experienced. This has resulted in
the emergence of some standard types of Web sites. A number of compo-
nents for these sites can be found in ColdFusion. Where applicable, we've
noted it in the following list. The most common types of sites include

4 The Product Site: The most common type of site. Generally, the site offers
some basic information about a company, its products, staff members,
perhaps a product demo, and a way to contact the organization to get
more information. Examples of this kind of site would be www . symantec.
com, www . amf . com, and www.nadelectronics.com.

4+ The Commerce Site: A storefront on the Internet. Whether it’s a single
company that carries just its own specialized products or a retailer that
sells a wide array of products, these sites are geared toward selling
products and offering accessories to complement those products.
An example of this kind of site is www.macys . com. ColdFusion offers
tools that can help you add a shopping cart, a search function, and
more to your site easily.

4+ The Portal Site: A site that aggregates content from a wide variety of
sources. Portal sites tend to be rich in content and links but short on
graphics. The idea is to provide users with a launching pad to other
destinations on the Internet, though in recent years, many of these
portals are adding features to try to keep their users on their own site.
An example of this kind of site is www.yahoo . com. ColdFusion includes
robust search capabilities that enable you to have more content-rich
sites that are easily indexed and searched.

4+ The News Site: A site that, in general, mirrors an offline counterpart,
such as ABC News. These sites provide a lot of the same information
as their offline counterparts through the use of text, video, audio, and
graphics, and also provide services geared toward the online audience,
such as chat sessions, newsletters, and personalized content. An exam-
ple of this kind of site is www. cnn . com. ColdFusion includes tools for
adding chat to your site as well.

4+ The Application Site: A type of site that offers perhaps the greatest diver-
sity of all the sites. Application sites are geared toward a specific purpose,
such as banking, investing, automobile purchasing, travel planning, photo
galleries, event planning, or online greetings. Some of the commonalities
among these sites include user accounts, password protection, and the
widespread use of e-mail campaigns to try to keep users coming back.
Examples of this kind of site include www.egreetings. com, www.
imotors.com, and www.bankofamerica.com.
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Macromedia Studio 8: Your Ally in Development

4+ The Personal Site: Personal sites also offer a great deal of variety in their
design and function. Personal sites usually include some of the designer’s
work, opinions, and rants; links to other sites; and pictures. Examples of
this kind of site are www. loungeboy . com and www . katswindow.net.

Macromedia Studio 8: Your Ally in Development

After you've answered a number of the questions in the “Finding Your Place
on the Web” section, you may be wondering how you're going to build your
grand Web site. Well, don’t fret. With Macromedia Studio, you have the most
complete, user-friendly, and popular development suite on the market. Even
though professionals use these products all the time, the programs in the
Macromedia Studio suite are truly designed to empower the first-time Web
developer. With an array of tutorials, wizards, and interfaces that keep you
as distant from the code as you want to be, Macromedia Studio makes the
Herculean task of building powerful Web applications seem like just another
project.

The goal with Macromedia Studio is to help you, the developer, build
compelling and powerful Web sites in the shortest amount of time, while
simultaneously helping you alleviate cost and resource issues common to
Web development. Macromedia Studio includes several tools to help make
this happen:

4+ Dreamweaver 8: The premier tool for easily building Web pages. You can
use Dreamweaver to generate and edit ColdFusion code, which makes
developing dynamic Web applications much easier.

4+ Fireworks 8: A leading tool for the graphical development of a site.
Fireworks helps you design the look and feel of your site, as well as
prepare the graphics for inclusion in an HTML or CFML file.

4+ Flash 8: The world’s most popular tool for adding animation and sound
to Web sites. Flash will truly change the way any site works.

4+ Contribute 3: Collaborate with others and take all the development
hassle out of building (and maintaining) Web sites with Contribute.
Using this tool in combination with Dreamweaver will help you design
Web sites in such a way that just about anyone in your organization who
can use a word processing program will be able to add and modify con-
tent on the site.

This book includes information about two other Macromedia products you
may want to use in developing your site. Formerly part of the Studio suite,
they remain powerful tools for performing specialized site-building tasks:
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FreeHand MX: The Web developer’s best friend for creating complex
vector illustrations for use in Fireworks and Flash.

ColdFusion MX 7 Developer Edition: Give yourself the powerful tools
to add databases, connectivity to e-mail servers, and other dynamic ele-
ments to your site. ColdFusion allows you to take control of one of the
most powerful — but also easy to learn — scripting languages for the
development of compelling Web applications.

Before Vou Start: Things to Know

Hopefully, all this information hasn’t scared you into dropping this book and
deciding to open a lemonade stand instead. This last section is just a quick
check of some things you should be aware of before you jump into this ven-
ture called Web development:

<+

+*

Plan ahead. Building a Web site always takes longer than you think, so
give yourself more time than you originally planned for!

Get organized. Remember to categorize your content and use those cat-
egories as the initial architecture for your site when you’re doing the
user interface design.

Always do the user interface design before the graphics design. The user
interface design specifies how your site will work, while the graphical
design is the look and feel. If you do the graphics before the architecture
is done, you'll likely end up redoing a lot of your design after you've fig-
ured out how your site is going to work.

Not all browsers are the same. Internet Explorer and Netscape Navigator
are the two most common browsers, and in recent versions, they’ve
adopted the same standards. But there are still quirky differences between
the two browsers, and you have to check your work on both browsers.

Not all platforms are the same. If only they were! Explorer and Navigator
work slightly differently on the Mac, in Windows, and in Unix. If you're
developing on the PC, find a friend or a graphic designer with a Mac and
check your work on her system as well. Dreamweaver also includes some
tools to help you verify whether your site works the way you hope it does
on a variety of platforms.

Learn from sites you like. If you like the way a page looks — but can’t
imagine how such a design could have been translated to the Web —
you can view the source code in your browser to see how the page was
constructed. Seeing how other people have coded their pages can spur
you on to create your own unique designs.
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Before You Start: Things to Know

4+ Lots of stuff can be had for free. The Web is filled with geeks like us

who have made all sorts of crazy applications, like chat engines, bulletin
boards, and even wholesale applications. A lot of them can be had for
free or something close to it. This is where sites like www.google.com
and www . download. com can be your friends.

Old content equals a dead site. You have to be prepared to update your
site on a semi-regular basis. When content is stale, people will notice,
and they will stop coming.

If you build it, tell someone. It’s one thing to build a site. Site-search spi-
ders will eventually find you, but if you really want to be seen, then you
really need to promote yourself. When you’re done building, remember,
it’s time to start promoting.

Don’t be afraid to ask. Building sites can be fun, but it can be especially
frustrating if you can’t figure out how to do something. Well, here’s a
secret: Developers like to talk about what they do. So if you're stuck, try
finding a user group or searching the Web for an answer to your question.
Someone may have come across the problem before, and if they haven't,
then there are plenty of resources for the asking. Macromedia is also very
good about supporting these kinds of groups, so you can always check out
its Web site at www .macromedia . com for listings of developer resources.



Chapter 2: Developing
Web Content

In This Chapter

v Developing content: An overview

v+ Organizing your content
v~ Categorizing Web content
v Creating your content

v Prepping your content for the Web

One of the things you find out when you do Web development for a
living is that the Internet is all about repetition. No matter how many
sites you build, the discussion always begins with “So, what’s the content
gonna be for this site?” Usually, the response is a blank stare. Companies,
organizations, and individuals usually come to the conclusion that they need
a Web site long before they’ve thought about what should be on that site.

Some basic rules of content development are common to all Web sites.
This chapter gives you the basics to consider as you're doing perhaps the
most important part of building your Web site: contemplating, designing,
and creating your content.

Developing Content: A Four-Step Process

Developing your content strategy can be the best part of building a Web site
because it’s the one time you can sit around a table with your fellow colleagues
(or your trusty pet, if you're building a personal site) and truly be creative
about the kinds of things you want to represent you or your organization on
the Web.

Content development follows a fairly structured course in the modern world
of Web design. It usually includes the following four basic steps:

1. Brainstorm the types of information that you want to include on your
Web site.



18 Choosing and Organizing Content

2. Put that information into categories that make sense for the type of Web
site you're building and the way you want users to interact with the site.

3. Gather and create the content for the site.

4. Prepare your content for the Web.
A great temptation is to just start building a site the moment something cool
comes along, be it an idea, a graphic, or even words. The reason to do all this
planning before even cracking any HTML code in Dreamweaver or generating
any graphics in Fireworks is to make sure that you don’t get too far down the

path of development and suddenly find yourself painted into a corner, trying
to put content where it doesn’t really belong.

Choosing and Organizing Content

You may be wondering just what, exactly, is considered content. Here’s a
little content quiz consisting of three simple yes or no questions:
1. Is a mailing list sign-up form, as shown in Figure 2-1, considered content?
2. Is a downloadable file considered content?

3. Is a picture of a product, or even of your pet ferret, considered content?
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The answer to all these questions is yes. In practical terms, every single
thing you put on a Web site is considered content.

Classifying common types of Web content

The fact that everything is content doesn’t really help you get your site organ-
ized. Thankfully, while anything can be content, things tend to show up on
Web sites in some pretty common formats.

As you begin to think about what you want to put on your Web site, you
should also consider the different forms that you want that content to take.
To give you a kick-start, Table 2-1 includes the most common forms of con-
tent and the data that makes up that content.

Table 2-1 Common Types of Web Site Content

Content Type Data Commonly Associated with This Type of Content

Graphics GIF and JPEG files

Document Word, Excel, PowerPoint, FlashPaper, and Adobe Acrobat (PDF) files

Text HTML text

Audio WAV, AIFF, MP3, Real Audio, and Windows Media files

Video QuickTime, Real Video, Flash Video, and Windows Video files

Plug-ins Flash animations, QuickTime VR, IPIX, and other tools that allow users to
view video and graphic content beyond what basic HTML can support

Forms Elements within HTML designed either to submit information or to return

targeted content back to a user’s browser

Categorizing your content

In addition to organizing your content by its file type, assigning meaningful
categories to your content makes developing your site infinitely easier.
You can organize your content in any way that makes logical sense for

the site you’re building. Most of the time, a single piece of content can be
categorized in more than one way, so don’t worry about limiting yourself
to just one classification method.

The following list includes some of the most common ways to categorize
content:

4+ Organizing by concept: Although it varies from site to site, this method
entails organizing your site by the major thematic elements, as defined
by the content that you’re going to be putting up. An example of this is
organizing a company site around the various products it offers.
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Creating Content for the Web

Classifying by function: Functions are things you can do on a site and
can serve as organizing principles for your site. For example, a financial
services company may categorize its content around a series of investing
and banking tools. In fact, that financial services company may choose
to categorize its content not only by the tools on the site (functions) but
also by the various products it offers (concepts), which demonstrates
that there’s more than one way to slice content.

Categorizing by logical steps: Some sites dispense with the notion of
concepts or functions altogether and focus on tasks that get something
done. Online auto sites, for example, like to walk visitors through a series
of steps to find the car they’re looking for, offering related content at
appropriate points along the way.

Sorting by topics or keywords: Sites with a diverse array of content tend
to offer users a couple of ways of getting at information. Keywords (topics)
are a common way to associate content with more than one area of inter-
est. For example, a music store may organize its site by concepts such as
instruments, sheet music, and accessories, and sort the content by topics
such as pianos, drums, guitars, amplifiers, and flutes, to name just a few.

Arranging hierarchically: This method of categorization assumes that
some content elements are more important than others, which is reflected
in how the content is displayed on the site. Hierarchy is often used in
conjunction with another categorization scheme. To go back to the bank-
ing example for a moment, imagine that you’ve got your portfolio online.
Usually, your portfolio is organized by concept or function as well as by
hierarchy. The portfolio is given more prominence than the other prod-
ucts the bank sells because the folks at the bank know that the content
in the portfolio is more important to the user.

Grouping by type: As noted in the previous section, content type is the
other major way to categorize content. On a number of media sites, such
as the ABC News site (www . abcnews . com), you can easily find all the
video content in a single location, in addition to being able to get your
news by feature area.

Creating Content for the Web

If you've got the right tools, creating content for the Web is a breeze. And
because you've got a copy of Macromedia Studio 8, you've already got a host
of tools that can help you create all sorts of content for your site. To recap,
here is a list of some of the content you can create with the products in the
Macromedia Studio suite:

4+ Fireworks 8: Create quality photorealistic graphics that can be used in

Dreamweaver or Flash.
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4+ Dreamweaver 8: Create pages from basic HTML to complete database-
driven applications, as well as use the publishing tools to help you
maintain your site.

4+ Flash Pro 8: Create animations that bring your site to life.

4+ Contribute 3: Have nontechnical colleagues add and modify content
on the site in both the development and maintenance phases of the
Web site’s life.

Depending on your needs, you may also find these other Macromedia appli-
cations handy:

4 FreeHand MX: Make illustrations that can be used to create the look and
feel of your Web site or your Flash movie.

4 ColdFusion 7: Create dynamic, database-driven applications.

In addition to these tools, you’ll find that other non-Macromedia software
tools can be essential to generating and managing content:

4 Microsoft Word: Word is the most common word processor in the world
for a reason. When you’re creating text for Web sites, there’s still no better
tool than Word for quickly and easily creating text.

4 Adobe Acrobat: The Acrobat PDF format remains the downloadable doc-
ument format of choice in the Web world. If you're going to develop large,
professionally-designed text- and image-heavy documents for the Web,
then investing in the full version of Adobe Acrobat is worth the money.
PDF files ensure that your documents will always have the same look and
feel, regardless of what browser or platform users may have. Offering
PDF files for download will also make your users happy because they
only need to download the free Adobe Acrobat Reader to read your
PDF documents.

4+ Microsoft Excel: As a spreadsheet, Excel can serve two very useful pur-
poses: It can help you manage your content by providing you with a
nice tool to wrangle your categorized data, and it can also save data in
CSV format, which is the most common data format for importing into a
database. So, for example, if you are providing your users with a list of
the names and addresses of people in your association, then you might
consider providing the information in CSV format so that users can
import the contact information directly into their own address books.

4+ Microsoft Access (or equivalent): Access is a database. If you create an
e-commerce site, you'll find that your product data is best kept in a data-
base rather than in plain text. Access is the most commonly available
database (though not necessarily the most robust), and is easily com-
patible with ColdFusion.
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Prepping Content for the Web

When preparing your content for delivery to the Web, here are a few handy
tips to keep in mind:

4+ Have a plan. If you haven’t gone through the process of content devel-
opment outlined previously in this chapter, your content is likely to be
disorganized. Be sure you have an overview of your content, as well as
an outline that shows all the various formats that your content will take
and how you’re choosing to categorize it.

4+ Choose the right format. Take a long, hard look at your content. Are you
using the right format for certain types of content? Are your graphics in
acceptable formats, such as GIF and JPEG? Are your downloadable items
in PDF or FlashPaper format? Be sure you're using the commonly accepted
Web file formats, and if you’re not, be sure to create some text to explain
why you’re not using standard formats.

4+ Be consistent. The Web relies on developers being at least somewhat con-
sistent. So if you have a product data sheet available in PDF format, make
sure that your other documents are in PDF format. Similarly, try to stick
to the same audio and video formats. That way, when people get to your
site, they’ll know what to expect, and they’re not likely to get frustrated.

4+ Make your content easily digestible. One last thing to keep in mind:
Just because you’ve written the Great American Novel and you want to
put it on the Web doesn’t mean that you should just put the whole thing
up in one huge piece. The Web is made to deliver content in small chunks,
and the best sites give viewers the facts first and then let people delve
deeper at their leisure. Remember, people are busy, and they may just
need to get the facts quickly. For you as the developer, this means creating
highlights, summaries, thumbnails, or charts that provide an introduction
or an overview to your core content.



Chapter 3: Choosing the
Right Tools for the Job

In This Chapter

+* Developing a Web site with Dreamweaver

v~ Using Fireworks for design

v+ Animating with Flash

1 Creating illustrations with FreeHand

v+~ Using ColdFusion to add dynamic content

»* Maintaining your site with Contribute

ou've probably heard that old saying, “A craftsman never blames his

tools.” Nowhere is that saying more appropriate than with Macromedia
Studio 8. With six incredibly powerful tools at your fingertips, you can
create compelling and dynamic sites in no time flat.

Of course, even though a craftsman never blames his (or her) tools, a crafts-
man does need to know which tools to use for a given job, and sometimes,
in the world of Web development, that’s not always so clear. This chapter is
designed to clarify this issue by highlighting the dos and don’ts of each of
the Macromedia Studio products.

\\3
If you're already familiar with the products in Macromedia Studio, then just
take a gander at the following section and then head right to Book I, Chapter 4.

Before Vou Begin: When Not
to Use Macromedia Studio 8

Although you certainly can use Macromedia Studio for every bit of your site
development, some things are better done outside the tool suite:

4+ Content development and management: This is the process of develop-
ing the written content for the site, as well as managing the collection and
status of each piece of content on the site. Products like Microsoft Word,
WordPerfect, Microsoft Excel, and Microsoft Access are more appropriate
tools for this job.
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Using Dreamweaver 8 for Web Development

4+ Project management: This is the process of managing the steps of the
project from start to finish, as well as where and how to allocate resources
to the project. You may want to use Microsoft Project or Microsoft Excel to
manage your project.

Using Dreamweaver 8 for Web Development

\\3

No matter how graphics-intensive or dynamic you want your site to be,
you’ll always come back to the fact that you have to build your Web site with
something. In Macromedia Studio, Dreamweaver is the Web development
workhorse. You can use Dreamweaver, shown in Figure 3-1, for a host of
practical Web development tasks:

4+ Create and edit HTML or ColdFusion Markup Language code (or code
using ASP, JSP, XML, and the like). Dreamweaver 8’s Code Collapse and
Zoom features make editing code easier than ever.

4+ Create “Sites” — a confusing Dreamweaver term that means a location
either locally on your computer or on a remote server where you keep all
the content for your Web site. When your content is in a Dreamweaver
Site, you can set up page templates and run various reports on your site
content.

4+ Upload all your Web pages from your local computer to a Web server on
the Internet that houses (or hosts) your site.

4+ Set up connections between your Web site and a database to make the
site dynamic.

4+ Preview your work using Macromedia’s Preview in Browser tools before
you publish it on the Web.

4+ Review code for errors and badly formed code.

The best way to think of Dreamweaver is as the glue that binds your site
together. Other Macromedia products like Flash and Fireworks help to add
flair and pizzazz to your site, but to actually assemble and include the files
that these applications produce in your site requires the HTML and publish-
ing tools that only Dreamweaver offers.

Ultimately, most of your content ends up in an HTML or CFML (ColdFusion)
page (or, depending on your server technology or content distribution needs,
an ASP, JSP, XML, or other kind of page), so if you don’t have Microsoft Word or
WordPerfect, Dreamweaver can also be used to create content as you would
in a word processing program.



Figure 3-1:
Use Dream-
weaver for
many Web
development
tasks.

Designing with Fireworks 8
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Designing with Fireworks 8

Fireworks is easily the most versatile of all the tools in Macromedia Studio.
As shown in Figure 3-2, Fireworks is primarily geared towards creating the
graphical design of your site. With Fireworks, you can accomplish the follow-

ing tasks:

<+

using the Fireworks text and editing tools.

+

tons and banners.

screen during your graphics development.

Create graphical elements that make up the look and feel of your site by

Apply filters that create photo-quality effects for the imagery in your site.

Manipulate text to be used in graphical elements such as navigation but-
Use layers to manage the depth and positioning of elements on the

Slice up your page design into multiple images in preparation for integra-

tion into HTML using Dreamweaver. (See Book IIl, Chapter 6 for more
information about slices.)

Optimize the size and color of images on your site.

Book |
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Creating Animation with Flash 8
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These are just the core elements of Fireworks. In addition to being a powerful
graphics development tool, Fireworks also incorporates elements of FreeHand,

Dreamweaver, and even Flash, providing you with additional functionality,

such as the following:

4+ Creating vector images that can be used in Flash animations.

4+ Creating basic animations and publishing your images as a Flash movie.

4+ Creating image rollovers that are common to most sites nowadays using
the JavaScript scripting language.

4+ Generating the HTML to accompany your sliced images.

Creating Animation with Flash 8

After you've got a few Web sites under your belt, you may find that HTML
and graphics alone seem lifeless. Sure, they’re necessary, but soon you’ll



Figure 3-3:
Flash
changes
the way
you think
about a site.

Creating Animation with Flash 8

begin to wonder what else you can do to add some pizzazz to your
sites. That’s where Flash comes in. Enter Flash, which enables you to add
animation, sound, video, and interactivity to your site.

Flash, shown in Figure 3-3, can radically change the way your site works,
allowing you to create a more compelling user experience. Gone are the
boundaries created by HTML and limited graphics. Although you still need
help from the other Macromedia Studio products, you can think of Flash as
an entirely new development platform for building your site.

In order to view the Flash movies you create, visitors to your site will
need to have the Flash plug-in installed in their browser. Luckily, almost
everyone with a standard graphical Web browser like Internet Explorer,
Netscape Navigator, Firefox, or Safari has some version of the Flash plug-in
installed.
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28 Illustrating with FreeHand MX

Itustrating with FreeHand MX

Although many of the tools in FreeHand MX are identical to those you find
in Fireworks, FreeHand offers illustrators and Flash animation developers a
greater degree of control and integration in their work.

Some of the things that distinguish FreeHand (shown in Figure 3-4) from
Fireworks include the following:

4+ A wider array of line art creation and manipulation tools

4+ Greater control of styles

4+ Better color management tools

4 Increased integration with Macromedia Flash

4 More import and export options
These distinctions may seem a bit subtle, and to some degree they are —
that’s why FreeHand is no longer officially part of the Studio suite. However,
when you get down to the nuts and bolts of building Flash animations, you’ll

see that FreeHand provides nearly seamless integration with Flash, offering
you a more diverse palette for developing compelling animations.

Figure 3-4:
FreeHand
in action.
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Creating a Dynamic Site with ColdFusion 7 Book |

Static HTML only gets you so far with Web development. After you've built
that first-generation site, you may soon find that your Web site development
needs have grown and you require more from your development tools. What
do we mean by more? Well, imagine you want to do any of the following:

4+ Customize the content of a site based on how a visitor got there.

[x]
-
qop oy soysjooy
5

whiy ay Buisooyy

4+ Personalize the site by letting users choose their own content.

4+ Open a store on the Internet with a host of product information con-
tained in databases.

4+ Create interactivity in your site with the use of forms.
All these items go beyond what Dreamweaver or Flash can provide as devel-

opment tools. After you hit this proverbial Web development wall, it’s time
to turn to ColdFusion, which provides the following tools:

4+ A custom scripting language that enables you to query databases, create
and test variables, and extend the functionality of your site through the
use of specific ColdFusion tags and functions. For more information
about ColdFusion’s scripting language, be sure to check out Book VIL.

4+ An application server (a program on a computer that serves a specific
function) that reads the custom scripting language and turns it into HTML
that people can see in their browser.

4+ An administrative component that enables you to configure all the differ-
ent elements of your site, such as databases, virtual directories, log files
that capture site tracking information, and e-mail features.

Managing Your Site with Contribute 3

By adding Contribute to the Macromedia Studio family, Macromedia provided
developers with a new tool to help them manage the content on their sites.
Designed for the layperson, Contribute allows you to manage a handful of
Web development tasks quickly and easily, including:

4+ Creating and editing Web pages on a site

4 Adding images and links to a page

4+ Creating tables and text

4+ Publishing pages to a Web site

4+ As site administrator, setting access permissions for all the above
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Now, you may be thinking that sounds an awful lot like what you do

with Dreamweaver. In fact, Contribute, in a nutshell, is a tool that allows
nontechnical users to accomplish Dreamweaver-like tasks, including both
site development and site maintenance, without forcing them to muck with
(and possibly jeopardize) any of the underlying code structure of a Web site.

During the development phase, if your site has many pages that share an
identical design but need different content, the HTML developer can create
a Dreamweaver template of the design, and nontechnical colleagues can
create multiple pages based on the template using Contribute, each page
with its own content, but all with a protected common layout.

When the site is up and running, Contribute allows people with no knowledge
of HTML to make changes to content on the site. And built-in safeguards pre-
vent two (or more) people from making changes to the same page at the same
time, and security settings allow the site administrator to control access to
particular pages or sections of the site for groups or individual users.



Chapter 4: Best Practices
for Web Development

In This Chapter

+ Understanding the basic steps of Web development
1~ Setting your site requirements

+~ Ensuring a smooth Web site build

1~ Testing your site

v~ Involving the right people at the right time

Fle late-night, caffeine-fueled, build-it-as-you-go model of Web development
was fine when the industry was just getting started. However, Web devel-
opment today is a more standardized practice and is subject to repeatable
processes, just like other areas of software development. The result of the
growing maturity in the industry is a set of “best practices” for Web develop-
ment. Think of a best practice as an industry-accepted, commonly-agreed-upon
way of performing a task or set of tasks.

Certainly, you can still build a Web site in more than one way. Best practices
are designed just to give you some guidance in the following areas:

4+ Ensuring that the site is easy to build and maintain

4+ Helping you avoid doing unnecessary work on a site

4+ Confirming that your Web site is built according to industry standards
4+ Making certain that you involve the right people in the site development

at the right time

Each of the sections of this chapter deals with a common aspect of Web
development and provides you with the key points for making that part
of the development run smoothly.

You should be aware that these tips and suggestions are not absolutes.
Every site is a bit different, but you can use this chapter as a checklist

guide for the kinds of things you can do. Your site may require more or
less attention depending on your requirements.
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Additionally, this chapter is limited to the general best practices for develop-
ing sites. Each of the chapters within Book II through Book VII covers the best
way to perform operations with each of the individual Macromedia products.

Following the Best Path of Development

The early days of Web sites saw a wide variety of methods and approaches
to development, but today most common types of Web sites follow an
accepted path from start to finish. Building a Web site involves six basic
steps. The details within each step can be specific to the type of site you're
building — product site, e-commerce site, and so on — but the basic steps
remain the same.

Step one: Develop a site concept

Before you can build a site, you must have a mission and purpose for it.
This process involves asking yourself and your colleagues a number of
questions about whom you’re trying to reach and why. Book I, Chapter 1
includes more information on this process.

Step two: Define your requirements

After you've decided what your site is all about, you need to come up with
some basic requirements for the site. Requirements are the minimum standards
that the site must conform to. These requirements fall into the following
categories:

4+ Feature requirements: The basic set of site features and the functional-
ity those features need to have.

4 Technical requirements: The minimum technical specifications for the
site. Table 4-1 includes the common technical requirements for Web sites.

4+ Design requirements: The aesthetic and accessibility requirements for
the site. Design requirements may include things such as using the proper
corporate colors, and accessibility requirements generally include things
like adding a text-only version of a site so that it can be read by text read-
ers (such as browsers designed for the visually impaired).

Table 4-1 Common Technical Requirements for Web Sites
Requirement Best Practice Option

Screen resolution 800 x 600 pixels

Minimum browser support Internet Explorer 6.0 and Netscape Navigator 8
Use of Web safe colors only No longer required, as almost all monitors can

display 16-bit color
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Requirement Best Practice Option

Minimum connection speed 56 kilobits per second (Kbps)

File extensions Should still conform to the standard “dot and three
characters” (.htm, .cfm, .asp, . jsp)where
possible

Style sheets (Yes or No) Yes

Dynamic HTML (Yes or No) Yes

Web phone and PDA accessibility No

Database of choice Microsoft SQL Server

Step three: Generate content

During this step, you work to generate the various types of text, images, and
so on that will make up the content of your site. Book I, Chapter 2 covers the
details of generating content for Web sites.

Step four: Design the site

This step covers four different aspects of design, and in general, they follow
this sequence:

1. Complete the feature design.

In the second step of Web site development, you set out the requirements
for features on the site. Here, you get down to the nitty-gritty and design
exactly how those features will work. For example, if you want to collect
mailing list information, you need to articulate precisely how the infor-
mation is captured, what kind of response is sent to a user, and where
the captured information goes.

2. Work through the user interface design.

The user interface design is the way the site works, minus the aesthetics.
It includes the composition of pages and the structure and look of the
content, and it applies the logic of the feature design above.

3. Consider the graphics design.

After the feature and user interface design are complete, your site is
ready for the aesthetics. You may want to create graphics for logos,
icons, navigation, sidebars, backgrounds, and other site elements.

4. Complete the technical design of the site.

Truth be told, you can do the technical design after you complete the
user interface design, but usually it ends up being the last design step.
You must design the technical components that enable all the features
of the site to be realized.

Book I
Chapter 4
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Figure 4-1:
The typical
inverted L
shape of

a site's
navigation.

Step five: Build the site

After you've completed the design step, you're ready to start building the
site. This includes generating all the code, supporting databases, generating
HTML, and posting content. Building the site can take weeks, and you should
keep a number of basic rules of development in mind when building your site.
Here are the most critical ones:

4+ Work internally. Don’t do all your development work on the site for

everyone to see. Be sure to work on the site either internally (on your
corporate network or your personal machine) or on a different URL
than the final address. This way you can make all the mistakes you like
and the real world isn’t likely to see them.

Go wide, then deep. A good strategy is to always build the structure of
the site first, including the navigation, and then fill it in with the content
within individual sections. Figure 4-1 shows the navigational structure of
a typical site, with primary navigation running across the top and second-
ary navigation running down the left. Primary navigation allows visitors
to get to the main sections of the site, while secondary navigation allows
visitors to “drill down” to specific pages in the section.

Centralize your images. Centralizing your images makes finding images
and generating the proper code that much easier. The norm is to include

all images in a folder called images at the root level of your site.
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4+ Whenever possible, use relative paths. Using a relative path simply means Book |
that your links from one file to another within your site — HTML files, Chapter 4
images, PDFs, and so on — are relative to the location of the file you're

currently working on. This makes changing links and moving things around sSw
in folders that much easier. Dreamweaver defaults to using relative paths. g .8.
An absolute path (for example, http://www.mysite.com/section/ = 5'?
page.htm) includes the site’s URL, which is not only cumbersome but E o
also difficult to use during development. -§ §
4+ Keep filenames simple. Always keep your filenames in lowercase letters, g_ g

and don’t include spaces in filenames, folder names, or URLs. This ensures
that no matter what type of Web server your site is hosted on — Windows,
Macintosh, or Unix — the files can be read by any Web browser.

4 Use folders to segment your content. This provides your site with a struc-
ture that makes finding and managing your content and code easier.

4+ Always comment your code. Commenting code is a common software
development practice. As you're writing your code, you add comments
next to major features and functions so that someone else can understand
your work if you're not there to explain it to them. Browsers ignore com-
ments when displaying the page (but you can see comments, if they’re in
the code, by using your browser’s View Source command). If the code is
logically laid out with comments, managing it is much easier. Figure 4-2
shows what commented code looks like in Dreamweaver 8. HTML com-
ments always appear in this format: <! -- comment here -->.
JavaScript, ColdFusion, and other types of Web code each have their
own comment conventions.
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4+ Do everything you can to protect your applications. Hacking is serious
business, and the last thing you want to have happen is for your site to
be compromised. Here are just some of the things you can do to ensure
that your site is designed with security in mind:



36

Following the Best Path of Development

e Always use digital certificates when sending users private information
over the Internet. A digital certificate is a secure, encrypted digital key
that ensures that only the user’s Web browser and the server that
issued the key can see the data being transmitted back and forth.
You can find out more about digital certificates at www.verisign.com.

e If you're doing e-commerce, don’t use Microsoft Access. Access isn’t
nearly as secure as Microsoft’s SQL Server.

e Never query a database directly for a user’s private information, such
as username, password, or credit card numbers. With SQL, you can use
stored procedures to query a database and mask the code from poten-
tial hackers. While stored procedures are outside the scope of this
book, you can read more about them in Anthony T. Mann’s Microsoft
SQL Server 2000 For Dummies, published by Wiley Publishing, Inc.

e Always try to build your applications in three tiers. A three-tiered
application, the concept of which is shown in Figure 4-3, ensures that
the business logic for your site is separate from your display code
and your database logic. This is more secure, and it makes changing
components of your Web application easier because of the modular
nature of a three-tiered application.

In the three-tiered model, the Web browser can only talk to an inter-
mediary application or object (sometimes called a COM object) and
can only pass a finite set of variables to this intermediary. In turn,
the intermediary negotiates with the data layer to retrieve only the
specified information, which it passes back to the display layer. This
ensures that the end user can’t directly connect to the data layer.

4 Set up a mechanism for sharing files. When you’re working on the same
files with more than one person, set up a convention for sharing the files
so as to avoid overwriting each other’s work. Dreamweaver comes with
some source control tools that help in this process, as does Contribute,
but you may not want to rely just on their built-in protections. You should
have an agreed-upon procedure for working on the same files.

Step six: Test and deploy your site

Before you can launch your site, you need to test it. Although test plans vary
depending upon the sophistication of the site, here are four good things you
should do when testing your site:

4+ Check your site on multiple browsers. Testing your site on various
current and previous versions of browsers ensures that it works for the
largest possible number of users. You should also check on different plat-
forms as well (PC and Mac at the least). If you test on the latest version
of Internet Explorer, and on Netscape 4.x and 8.x, and Firefox, you can be
pretty sure how your site will look to almost everyone who visits it.
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Figure 4-3:
The three-
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You can find a wide variety of old versions of many browsers, including
Netscape Navigator and IE, at http: //browsers.evolt.org.

4+ Try your site with different Web connections of varying download
speeds. If you're building your site at work, you may have a very fast
Internet connection. Try viewing and navigating your site using a dial-up
56 Kbps connection to see how well your site loads at that speed. If pages
load within a few seconds, then your site is in good shape.

4+ Test all of your forms and features. Walk through each form, again prefer-
ably on multiple browsers and operating systems, to ensure that all your
tools and forms work properly.

4+ Enlist your friends and colleagues as site testers. The more people that
look at your site, the better. You're probably too close to the site by the
time you've finished it anyway, and fresh eyes can see things you can’t.
Also, other people are likely to give you good feedback on structure and
ease of use. Ask a friend with good language skills to proofread the site
for grammatical errors and misspellings.

Tier one Visual display layer (what the user sees)

Component layer
(includes the business
rules and logic for
communication with the
display layer and the
data layer)

Tier two

Data layer
(houses

: Tier three .
tiered model business

of develop-
ment.

critical
information)
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Getting the Right People at the Right Time

After you've finished testing your site, which generally takes at least a week,
you should give yourself at least another week to fix any problems you’ve
found during the testing phase.

When you're ready to roll out your site, a good idea is to do a soft launch first.
A soft launch is when you launch a site but don’t really tell anyone about it.
People who already know something about you or may be looking for your site
will start to check it out and may provide you with some additional feedback.
But you won’t be faced with a big barrage of people, and you’ll have a chance
to troubleshoot anything you may have overlooked in making the jump from
working on a site internally to having a site out there live for the real world.

Getting the Right People at the Right Time

If you're building a site on your own, then you are always the right person
at the right time. In most cases, however, you're building a site with a group
of people. Some of these people are site builders, and others are around to
approve content and give general direction. Keeping all the parts moving
smoothly can be tricky. The following sections help you get the right people
on board at the right time.

Building a team

Just how big is this project you're working on? How much money do you have
to spend? When do you need it done? The answers to these three questions
let you know just how many people you need to complete your site. If you
plan to assemble an internal team to build your site, these are the roles that
you absolutely need:

4+ Producer: Perhaps this is you. The producer (sometimes also referred
to as a Project Manager) manages all the internal and external resources
of the project. This means keeping the master budget and schedule, and
providing all the resources with their tasks and deadlines. Essentially, the
producer is the conduit that keeps the project moving from start to finish.

4 Programmer: Programmers come in all shapes and sizes. Some can
only do HTML, while others are adept at building all sorts of software
applications. If you've got a smaller project, you should only need one pro-
grammer (who might also go by the title Engineer or Integrator), but if your
project is larger, you should consider having an integrator for lower-level
HTML coding and a senior programmer for more complex coding tasks.

4+ Designers: Again, if you're building a smaller site, you can probably get
away with having a designer who does both user interface design and
graphical design. Alternatively, as the producer, you may be qualified
to handle the user interface duties as well as fill the feature design role.
The larger the site, the more you’d want to look at separate specialists
for user interface and graphical design.
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4+ Content Specialists: Generating content is always overlooked in building
a team. Whether you have a contract writer or someone internal to your
organization who excels at collecting and synthesizing data, it’s always a
good idea to have someone around dedicated to developing content for
the site.

4+ Quality Assurance: Someone’s gotta test the site, and as we mention pre-
viously, you're probably not the ideal person to do it. The best testers
are meticulous, accountant-types who like to poke and prod at things
and find holes. A lot of times, this function can be contracted out.

4+ Approvers: Unless you're building the site for yourself, then you’re prob-
ably accountable to someone. Those would be your approvers, and yes,
they’re an essential part of the team — ultimately, they are the ones who
give you the yea or nay on whether your site gets up on the Internet!

If you were to contract out these resources through a single firm or through
a variety of independent contractors, you'd still be looking for each of these
skill sets. The method of employment doesn’t really matter, though it’s
worth noting that it’s generally cheaper to contract the resources yourself.
Firms, on the other hand, offer complete teams, standardized processes, and
an existing code base (prewritten and tested code) that you don’t generally
get when you build an internal team from scratch.

Involving the vight people at the right time

Knowing when to get people involved can be tricky. Ideally, you’d want every-
one there all the time, but that can get expensive, so you want to get people
onboard at the right time for the right tasks. Table 4-2 includes many of the
key milestones in a Web development project and who you really need to
have involved during each part of the process.

Table 4-2 When to Involve People in the Web Development Process

Key Milestone Who's Involved

Site conceptualization Everyone

Requirements gathering Producer, designers, programmers, and approvers

Generating content Producer, content specialists, user interface designers, and
occasionally graphic designers and programmers

Feature design Producer, user interface designer, and programmers

User interface design Producer and user interface designer

Graphic design Producer, graphic designer, programmers, and approvers

Build phase Everyone

Test and deploy Producer, quality assurance, programmers, approvers, and

occasionally designers
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Chapter 1: Introduction
to Dreamweaver 8

In This Chapter

+~ Exploring the Dreamweaver 8 interface

1 Choosing between Design view and Code view

+* Choosing among Standard, Expanded Table, and Layout modes
» Examining your site with the Files panel

v+~ Exploring toolbar buttons

v~ Using panels and inspectors

v Getting help

If you’re looking for a Web design tool that’s both easy enough for begin-
ners and sophisticated enough for Web design gurus, you've come to
the right place. Dreamweaver 8 from Macromedia is a powerful program
that enables you to create almost any type of Web page. This chapter
covers the Dreamweaver basics and introduces you to some of the pro-
gram’s essential tools.

Dreamweaver is the industry standard for Web site design and production.
Whether you're interested in creating a site for fun, such as an online photo
album or a site devoted to one of your hobbies, or for business, such as an
online store, Dreamweaver’s flexible interface provides simultaneous graphi-
cal and HTML editing. In other words, using Dreamweaver, you can not only
lay out pages like an artist, you can also fine-tune the associated code like a
programmer. Additionally, Dreamweaver’s built-in FTP features enable you
to upload your site to the Web in a snap, so that you can share your master-
pieces with the world.

Exploring the Dreamweaver 8 Interface

With Dreamweaver 8, Macromedia continues the tradition of allowing you to
choose from two versions of the Dreamweaver workspace — Designer style
and HomeSite/Coder-Style — that debuted with Dreamweaver MX 2004. This
selection allows you, the developer, to work in an environment that is best
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suited to your personal development taste: one geared towards WYSIWYG
(what you see is what you get) development and one that is more code-
oriented.

Selecting a workspace on start-up

When you start Dreamweaver for the first time, you're asked to choose the
way you want your workspace set up, as shown in Figure 1-1. You have two
options:

Figure 1-1: (Wiorkspace Setup

Pleasze choose the waorkspace lapout you'ie most comfortable with. *You can swilch
Th e lapoutts leter in Preferences.

Workspace

Setup dialog
box appears &
when you _ = i iz2
start Dream- s P

weaver for
the first
time. ;

(%) Designer () HomeSite/Coder Style

4+ Designer: The WYSIWYG (What You See Is What You Get) interface,
which shows the page you are working on much like it would be in a
Web browser. This style is more appropriate for Web design novices
working on basic HTML pages.

4+ HomeSite/Coder-Style: The style that shows the page you are working
on as an editable text document, which is appropriate for experienced
coders and for pages on which you’re editing ColdFusion Markup
Language (CFML) or other dynamic code.

You can switch between the two styles, or even combine them, at the click
of a button. See the “Introducing the Document Window” section, later in
this chapter, for details. You might even consider switching back and forth
between modes as you're learning HTML as this is good way to see the
underlying HTML as it’s being generated.

Introducing the new Start page

After you've selected a workspace, when you launch Dreamweaver by double-
clicking its icon on the desktop or by selecting it from the Windows Start
menu, you'll see a Start page, as shown in Figure 1-2. The Start page allows
you to perform the following tasks with a single click of your mouse:



Figure 1-2:
The Start
Page gives
you one-
click access
to a variety
of options.
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Exploring the Dreamweaver 8 Interface

4 Open pages you’ve recently edited: Simply click the filename of the
page you want to open.

4+ Create a new page in one of nine formats: Simply click the type of page
you want to create, from basic HTML to ColdFusion (CFML) to CSS
(Cascading Style Sheets).

4 Create a new Dreamweaver Site: Click the Dreamweaver Site icon (in
the Create New column) to open the Site Definition Wizard, which guides
you through the process of setting up the directory location, FTP infor-
mation, server technology (if applicable), and more for your Web site. A
“site” in Dreameaver is a collection of Web pages, images, and tools that
allow you to more easily manage your Web sites. See Book II, Chapter 3
for more in-depth details on Dreamweaver Sites.

4+ Create a new page based on Dreamweaver’s built-in samples: Click an
option in the Create from Samples column to open the New Document
dialog box and choose from the preset formatting options for that type
of page.
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The Start page also gives you fast access to a quick tour and set of tutorials
for Dreamweaver, and to Macromedia’s Dreamweaver Exchange page, where
you can find lots of nifty widgets that extend Dreamweaver’s capabilities.
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If you find the Start page incompatible with your working methods, you can
prevent it from appearing in the future by selecting the Don’t Show Again
check box at the lower-left corner of the page.

Introducing the Document Window

Figure 1-3:
The

Design view
approxi-
mates what
your page
looks like
ina Web
browser.

Your primary workspace in Dreamweaver is the Document window, which
appears automatically when you open a page in Dreamweaver. In the
Document window, you construct your individual Web pages using panels
and dialog boxes to format your work. The three primary views in
Dreamweaver are as follows:

4+ Design view: The graphical view of your document, as shown in Fig-
ure 1-3. You can select this view by choosing View=>Design.

4+ Code view: This view shows the underlying code of your document. You
can select this view by choosing Viewr>Code.

4+ Split view: As you may expect, this is a split screen view that includes
both the Code and Design windows. You can select this view by choos-
ing View=>Code and Design.
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You can toggle between these views easily at any time by clicking their cor-
responding buttons at the top left of the Document window.

When you have several documents open in a site, you can select which doc-
ument you want to work on by clicking the document’s name at the top of
the Dreamweaver Document window. You can also click the Site tab in the
Files panel to work on an entire site.

\\3

The Insert bar sits directly underneath Dreamweaver’s main menu. It gives
you quick access to eight sets of buttons you can use to insert everything
from tables to Flash movies to form elements in your page. To select one of
the eight categories, click the Insert bar’s name (Common, Layout, and so

on) and choose a new category from the drop-down list. Book Il

Chapter 1

Choosing among Standard, Expanded
Table, and Layout Modes

When viewing your document in either Split or Design views, you can view
content using the Standard mode, the Expanded Table mode, or the Layout
mode. The Standard mode is the default (Figure 1-3 shows a page in Standard
mode in the Design view, with the Insert bar set to Common.). The Expanded
Table mode makes it easier for you to select tables and cells (though if you
want to resize the table or row or column, you need to do so in Standard
mode). The Expanded Table mode is most useful for editing existing tables.
The Layout mode provides a simpler interface for drawing and editing tables
and table cells.

g Janeamuieaiq
0} uonaNpoLu|

Two special tools are available only when working in Layout mode: the Draw
Layout Cell button and the Draw Layout Table button. A table created with
the Draw Layout Table tool is shown in Figure 1-4. Both of these tools can
help you generate tables or table cells quickly and easily in Dreamweaver,
and are described in more detail in Book II, Chapter 2.

To change to the Layout mode, select the Layout Insert bar at the top left of
the Document window and click the Layout Mode button, or choose View=>
Table Modew>Layout Mode, or use the keyboard shortcut Ctrl+F6. When you're
in Layout mode, press Ctrl+F6 or click the Layout Mode button to return to
Standard mode.

To change to Expanded Table mode, select the Layout Insert bar at the top
left of the Document window and click the Expanded Table Mode button at
the top of the Document window, or choose Viewr>Table Mode=>Expanded
Table Mode, or use the keyboard shortcut F6. When you're in Expanded
Table mode, press F6 or click the Expanded Table Mode button to return to
Standard mode. Note: None of the table modes are available in Code View.
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Figure 1-4:
Atable
drawn in
Layout
mode.

Examining Your Web Site with the Files Panel
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Examining Vour Web Site with the Files Panel

Dreamweaver offers Web developers the opportunity to work on individual
files that make up a Web site, as well as to manage their entire Web site, all
through the Dreamweaver interface. This concept is called, not surprisingly,
a Site; to avoid confusion, we call them Dreamweaver Sites. Dreamweaver
Sites can include the following elements:

4+ HTML, CFM, ASP, and other files that make up the code of the site

4+ Graphics, such as GIF and JPEG files

4 Documents, such as PDF and DOC files

4+ Directories (folders that might contain any of the above)
Dreamweaver Sites are initially viewable within the Files panel (which is open
by default; if the Files panel is not open, you can open it by pressing F8). To
expand the Files panel so it fills your screen, or to collapse the panel back to

panel size, click the Expand/Collapse button (the icon of the two-row, two-
column box with an arrow in the middle, at the right of the panel).

The Web site management tools for Dreamweaver Sites are designed to give
you total control over the way in which your Web site is built and maintained
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from your local computer. The key features of the Dreamweaver Site tools
include

4+ Asset management tools that help you manage all the files that make up
your site. For example, these tools keep track of all your files and the
links between files. Anytime you move a file, the tools will change the
related links in other files.

4+ Basic source control to ensure that files don’t get overwritten. These
tools lock files so that when you’re working on a particular file, others
on your team can’t edit that same file.

4+ Publishing tools that allow you to use FTP to upload the content from
your site locally to the remote server where the site is housed.

4+ Utilities that create site maps, check links, check the HTML code, and
run reports on who’s been working on what.

Dreamweaver Sites are covered in more detail in Book II, Chapter 3.

Exploring Toolbar Buttons

Dreamweaver provides you with a number of useful view buttons (shown in
Figure 1-5 and Figure 1-6) that you can use to see different views of your site
or to perform various functions. You can easily switch among views to exam-
ine your site in different ways. Each Dreamweaver view offers specialized
menus and tools to help you perform your work in that view. Certain views
are available for an individual document or page, whereas other views are
available for the entire site. At any time while you work, you can choose to
preview your site in target Web browsers, which enables you to see your site
from the user’s perspective.

Refresh button
Get File(s) button

Put File(s) button

Figure 1-5:
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Show Design View File Management  Visual Aids
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Figure 1-5 shows the following site-related buttons from the Files panel:
4+ Connect to Remote Host button: Connects your local computer and your
Web host, allowing you to transfer files between the two computers.

4+ Refresh button: Refreshes the panel’s view of files in the site if you've
made a change to filenames or file structures outside of Dreamweaver
while the program was open.

4+ Get File(s) button: Downloads (retrieves) documents and files from the
host.

4 Put File(s) button: Uploads (sends) documents and files to the host.
4 Check Out File(s) button: Locks files for editing by a single individual.

4+ Check In button: Replaces files on the server and makes them available
for editing by unlocking them.

4+ Expand/Collapse button: Makes the Site tab full-screen with remote and
local files side by side.

Figure 1-6 shows the following document-related buttons from the top of the
Document window:

4+ Show Code View button: Enables you to view the HTML page code
full-screen.

4+ Show Code and Design Views button: Allows you to view the HTML
page code and the Document window at the same time.

4+ Show Design View button: Enables you to view the Document window
full-screen.

4+ Check Browser Support button: Allows you to run a check on your code
for browser compatibility.

4+ Validate Markup: Allows you to run a check on your code to see if the
HTML code is well formed.

4+ File Management button: Click and then select Get to retrieve files from
the Web site host, or select Put to send files to the host.
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4 Preview/Debug in Browser button: Click and select to preview or debug
in your browser(s).

4+ Refresh button: Reloads your page so changes to the code are reflected
in the Design view.

4+ View Options button: Click to select options (such as Word Wrap in Code
View and the Ruler in Design view) to assist you in viewing your page.

4+ Visual Aids: Hides and shows the various visual cues available to you in
WBER the Split and Design views.
é«‘
Q
<« Some of these items may be unavailable, depending on what view you're in
and what you have selected in a document or panel. Book Il
Chapter 1

Using Panels and Inspectors

You can use Dreamweaver panels and inspectors to enter details about all
aspects of your Web site. These interfaces offer areas where you can add
and format page features, set up navigation and behaviors, and manage the
workflow of building your site.

g Janeamuieaiq
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Understanding the role of panels

A panel typically provides information about all instances of a particular
page feature. For example, the Layers panel lists information about all the
layers on the current page.

P The Tag Inspector panel gives you easy access to various properties and
behaviors specific to what object you have selected on your page. The Tag
Inspector panel updates continually, depending on what you have selected
on your page (if you have nothing selected on the page, the panel displays
properties and behaviors of the whole page itself, as shown in Figure 1-7).
Note that the Tag Inspector panel’s name reflects the HTML or CFML tag
being inspected.

To switch among tabs in a panel, just click the tab names.
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Getting Help

Working with the Properties panel

The Properties panel, like the Tag Inspector panel, changes based on the
individual document object you have selected on your page and contains
details on attributes of the object. For example, selecting text on a page
opens the Text Property inspector in the Properties panel, where you can
format the size, font, color, link, and other attributes of the text. (Figure 1-4
shows the Properties panel with a Layout Table selected.) To make certain
that the Properties panel is shown below the Document window, choose
Window=>Properties.

The Properties panel has a small down arrow in the lower-right corner, called
an Expander button. Click the button to enlarge the Properties panel to view
additional formatting options. In an expanded Properties panel, click the
small up arrow in the lower-right corner to collapse the panel.

Getting Help

Dreamweaver offers a variety of tools to help you find the answer to virtually
any question you have about the program. The Help tools provide basic
information for beginners, as well as advanced references detailing HTML
and JavaScript code.

You can get help by clicking the Help button — the small question mark —
in the top-right corner of some panels. Similarly, you can open the Options
menu in the top-right corner of any panel and select Help from the list.

You can also access help by using the Help menu located on the main menu.
Just choose Help and then you can select from a host of options. Some of the
more popular ones include

4 Getting Started and Tutorials: Gives you quick access to basic informa-
tion to get you up and running quickly, as well as to step-by-step tutori-
als where you can learn by doing.

4+ Using Dreamweaver: Provides definitions and itemized steps in per-
forming routine Dreamweaver tasks. It contains Help Contents, Index,
and Search categories.

4+ Using ColdFusion: Provides information about coding dynamic sites
using ColdFusion technology.

4+ Reference: Opens the Reference tab of the Code panel offering a
dictionary-style reference on CSS, HTML, Accessibility requirements,
Sitespring tags, and JavaScript. You can also access the Reference tab
of the Code panel by clicking the Reference button in the Document
window.
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4+ Extensions: Provides assistance in performing more advanced
Dreamweaver tasks, especially tasks involving the integration of adjunct
programs, such as Macromedia Flash, with Dreamweaver. This help
option contains nitty-gritty information about application programming
interfaces (APIs) — specific software interfaces that allow you to inte-
grate Dreamweaver with databases, the C and Java programming lan-
guages, and much more.

4+ Dreamweaver Documentation Center: Connects you to the Web,
where you can find constantly updated information on working with
Dreamweaver, answers to frequently asked questions, and program
extensions. You can also join a developer’s forum, where you can chat
with other Dreamweaver users to get (and give) help. Book II
Chapter 1
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Chapter 2: Creating
Basic Web Pages

In This Chapter

v~ Setting ruler and grid options in the Document window
1 Creating and opening pages

v~ Establishing page properties

+* Working with text

1 Working with images

» Adding links

+* Working with tables

1 Previewing your work

Fle most significant (and, fortunately, the easiest) process in building a
Web site is creating the individual pages that convey the site’s content.
Even if you plan on creating an ultrahip site chock full of animation and
interactive forms, you spend the vast majority of your site-building effort
constructing basic Web pages comprised of words and images. This chapter
shows you how to set up, add color, and name individual Web pages. You
also discover how to add basic elements such as text, graphics, and tables,
to your pages.

Setting Ruler and Grid Options
in the Document Window

Dreamweaver offers you complete control over how you work in the
Document window by providing two guide tools — rulers and a grid — to
help you lay out your work accurately. You can customize a variety of guide
tool attributes, such as ruler increments and grid snapping, to suit your per-
sonal preferences and speed Web page development.
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Setting Ruler and Grid Options in the Document Window

Here’s a brief look at all your options with rulers and grids:

4 Turning rulers on and off: Using rulers — both horizontal and
vertical — in the Document window can help you measure and position
page elements. Toggle the rulers on and off by choosing View=>Rulers=
Show or by pressing Ctrl+Alt+R.

4+ Moving and resetting the origin: By default, the origin, or (0,0) coor-
dinate, of a Dreamweaver ruler is set to the upper-left corner of the
Document window. You can reposition it to any coordinate in the
Document window by clicking the origin cross hairs and dragging them
to new coordinates, which can be useful if you want to use the rulers to
position elements of a table whose upper-left corner doesn’t sit at (0,0)
in the Document window. Reset the origin to its default position by
choosing View=>Rulers>Reset Origin.

Changing ruler measurement units: You can change the ruler’s measur-
ing increment by choosing View=>Rulers and then choosing Pixels, Inches,
or Centimeters.

4+ Viewing the grid: Dreamweaver provides a Document Window grid that
can assist you in visually positioning and aligning page elements. You
can toggle the grid on and off by choosing View=>Grid=>Show Grid or by
using the keyboard shortcut Ctrl+Alt+G. The grid is shown in Figure 2-1.

Activating and deactivating grid snapping: The Document window grid
offers a snapping feature that causes a layer or Layout table/cell to auto-
matically align precisely with the snap-to points you define, which can
be useful when you draw, resize, or move a layer (see Book II, Chapter 5
for the skinny on layers). You can toggle grid snapping on and off by
choosing View=>Grid=Snap to Grid.

Adjusting page size

When you design Web pages, you must con-
sider how your target audiences will view them.
People looking at your page may view it at any
number of screen resolutions from 640 x 480 to
1024 x 768 or beyond. Because pages appear dif-
ferently at different resolutions, Dreamweaver
offers you the ability to build your pages for a
variety of monitor resolutions. The higher the
resolution, the larger the workspace in your
Document window.

If you want to size your pages, you must be inthe
Design workspace, and your Document window

can't be maximized in the integrated workspace.
To size your pages, click the Window Size
Indicator (the height by width numbers and
downward-pointing arrow at the bottom-right of
the Document window) and select a standard
size — for example, 640 x 480 — from the drop-
down list. (The Selecting Edit Sizes option on the
drop-down list allows you to specify any height
and width dimensions you want.)
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Settings dialog box. To do so, open the Grid Settings dialog box by choosing
Viewr>Grid=>Grid Settings and change any (or all) of the attributes that
appear. When you finish, click the Apply button to view the effect of your
changes. Click OK to accept the changes and close the dialog box.

Creating and Opening Pages

You have several ways to create a new page in Dreamweaver:

4+ On the Start page, scan through the Create New column and click the
type of page you want to create from scratch.

4+ On the Start page, click one of the options in the Create from Samples
column to open the New Document dialog box and make a new page
with many common settings precoded.

4+ Choose Filec>New or use the keyboard shortcut Ctrl+N to open the New
Document dialog box, from which you can create pages from scratch or
from templates.
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Establishing Page Properties

To open an existing page, do any of the following:

4+ On the Start page, click the name of the page in the Open Recent column.
4+ Double-click the page’s filename in the Files tab of the Files panel.

4+ Choose File=>Open or use the keyboard shortcut Ctrl+O to summon the
Open dialog box, which you can use to browse to the page you want to
open.

Establishing Page Properties

\\3

The Page Properties dialog box provides you with control over how several
key page properties appear, including the title of the page, page background
color, link colors, and page margins. Selections apply only to the current
page, not to the entire site. Open a Page Properties dialog box similar to the
one shown in Figure 2-2 by choosing Modify=>Page Properties or by pressing
Ctrl+J. Then make changes to any of the following in each of the five cate-
gories (Appearance, Links, Headings, Title/Encoding, and Tracing Image):

4+ Page Font, Size, Text Color, Background Color, Background Image:
Choose a font or set of fonts from the Page Font drop-down list; add a
style (bold or italic) if desired. Click the Color box next to each property
and pick a color from the Web safe color palette that appears, or enter a
hexadecimal color code directly in any Color Code text field. You can
also customize your own colors by selecting the color wheel and entering
either RGB values or Hue, Saturation, and Luminosity values, as shown in
Figure 2-3. For more information about using colors for the Web, see Book
III, Chapter 2. Book III, Chapter 3 includes information on how to use the
color picker to select colors in both Dreamweaver and Fireworks. For
Background Image, click the Browse button to locate the image file that
you want to appear as the Document window background. If the image is
smaller than the available background area, the image is tiled (repeated in
a checkerboard fashion, like floor tiles) to fill the background.

Even if you choose to use a background image, select a complementary
background color — the color shows while the background image is
downloading.

4 Left Margin, Right Margin, Top Margin, and Bottom Margin: Enter a
number (in pixels) in these text fields to set up margins that affect how
your page appears in modern browsers. Enter a whole number for the
number of pixels of buffer space you want between the left, right, top,
and bottom edges of your document and the content of the document.
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4+ Link Font and Size, Color for Links, Rollover Links, Visited Links, and

+

Active Links: Choose a font or set of fonts from the drop-down list; add a
style (bold or italic) if desired. Click the Color box next to each property
and pick a color from the Web safe color palette that appears, or enter a
hexadecimal color code directly in any Color Code text field. You can also
customize your own colors (see the preceding point on Text Color).

Underline Style: Select an option from the drop-down list.

Heading Font, Sizes, and Colors: Choose a font or set of fonts from the
drop-down list; add a style (bold or italic) if desired. For as many of the
six standard HTML heading levels as necessary, select a font size. If you
choose a numeric value, the unit-of-measurement drop-down list to the
right becomes active so you can select an option. Click the Color box
next to each heading and pick a color from the Web safe color palette
that appears, or enter a hexadecimal color code directly in any Color
Code text field. You can also customize your own colors (see the preced-
ing point on Text Color).

Book I
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60 Working with Text

4+ Title/Encoding: Enter a page title in the text field. This title appears in the
title bar area of the window both during construction in Dreamweaver and
when the page is viewed in a Web browser. Select an Encoding format if
your site requires the use of non-Western fonts (Japanese or Cyrillic, for
example). If your site is in English, you can leave the setting at the default,
Western European.

4+ Tracing Image: Click the Browse button to locate the image file you want
to use as a guide for laying out your Web page in the Document window.
This feature is handy for developers who prefer to mock up a portion
of their Web page design in a graphics program and then re-create that
design in their Web pages. Tracing images appear in Dreamweaver only
as a pattern to help guide you in creating an actual Web page; the tracing
image never appears on the finished Web page.

4+ Image Transparency: Drag the slider to adjust the visibility level of the
tracing image. At 0 percent, the tracing image is invisible; at 100 percent,
the image is completely opaque.

Click the Apply button to view the effect of any property you change. Click
OK to accept your changes and close the Page Properties dialog box.

Working with Text

As we mention in Book II, Chapter 1, Dreamweaver has three different design
views: Design, Code, and Split (Code and Design). The following sections apply
when you’re working in the Design view or Split view of Dreamweaver. In these
views, you can enter and manipulate text on a Web page in Dreamweaver

by using similar procedures to those you use when working with a word-
processing document.

Adding, editing, and deleting text

To enter text on a page, click in the Document window and begin typing.
Your mouse pointer appears as a blinking cursor that moves along with the
text you enter. When you reach the end of a line, the text automatically wraps
to the next line. Dreamweaver automatically adds the associated code for
your new text in the HTML for the page.

To delete text from a page, in the Document window, select the chunk that
you want to delete and press Backspace or Delete on your keyboard.

You can also modify how text appears on a page by editing its font, size, color,
alignment, and other attributes. To modify text in the Document window,
click and drag to select the text you want to modify. The Properties panel
loads the Text Property inspector, as shown in Figure 2-4 (the Tag Inspector
panel also reflects the selection). If the Text Property inspector is not open,
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choose Window=>Properties to open it. In the Text Property inspector,
modify any of the following properties:

4+ Format: From the Format drop-down list, select a default text style.

Heading 1 is the largest style and Heading 6 is the smallest, but none

of the headings correlates with a specific pixel size unless you set it to
do so. Select Paragraph for the basic body text of your pages. Select
Preformatted if you want spaces, tabs, and new lines in a paragraph to
show up in a browser (ordinarily, when you add multiple spaces in a row
or tabs to your HTML — this is particularly obvious in the Dreamweaver
document’s Code view — they appear as single spaces in a browser).

 Properties E
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4+ Font: Select a font face from the Font drop-down list. Browsers show your

text formatted as the first font in your selection that resides on the user’s
computer. Choosing Edit Font List allows you to add additional fonts you
may have installed on your computer to the Font drop-down list.

Most computers will have standard fonts like Arial and Helvetica and
won’t have less common fonts like, say, Univers or Futura. If you use a
nonstandard font, and it’s not on the user’s machine, the layout could
look very different than you were planning.

Style: Dreamweaver has been updated to work better with CSS styles.
Styles defined within the document or in a linked stylesheet will be avail-
able from the Style drop-down list. You can also use the drop-down list
to attach a stylesheet and create and edit styles.

Size: Select a font size from the Size drop-down list. The options include
none (choosing this option displays text in the default size), specific
numbers, generic sizes XX-small to XX-large, and relative sizes Smaller
and Larger. If you select a number, the unit-of-measurement drop-down
list becomes available so that you can specify what the font size number
refers to (pixels, ems, and so on).

Color: Click the color box and select a text color from the Web safe color
palette that appears. Alternatively, you may enter a hexadecimal color
code directly in any color code text field. (To set the default text color
for a page, check out the “Establishing Page Properties” section, earlier
in this chapter.)

Book Il
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62 Working with Text

4+ Bold or Italic: Click the Bold button to make your selected text appear
in bold. Click the Italic button to italicize your selected text. You can
click either button or both.

4+ Alignment: Click an alignment button to align your text. Choices are
Left, Center, Right, and Justify.

4+ Link: Type a URL in this field to transform selected text into a hypertext
link. You can also use the Point to File tool to link to a file. To link to a
file using this tool, just follow these steps:

1.
2.

Open the Files panel by choosing Window~>Files or by pressing F8.

Open the Explorer to the folder location that includes the file you
want to link to by selecting the collapsing menu squares.

Alternatively, skip to Step 3 and hover your cursor over the folder
that contains the file; the folder will expand so you can select the file
within.

. Click and hold the Point to File button in the Text Property inspec-

tor and drag the pointer to the file you want to link to. Release the
mouse button when the pointer is over the file.

The Point to File button looks like a compass without the needle or a
clock face without hands or numbers. It’s located to the right of the
Links field.

When you’re dragging the button, a line appears from the origin
point to your cursor, as shown in Figure 2-5.

After you let go of the mouse button, the link to the file appears in
the Link text field. If you select the Link drop-down list, it shows you
your recent links as well.

4+ Target: If you are linking the selected text, you can specify how the
linked page will open when the user clicks the link by selecting one of
the following options from the drop-down list:

_blank: Opens the link in a new window.

_parent: Opens the link in the parent of the window that is cur-
rently open. If the window with the link in it is not in a frame, the
linked page opens in the same window as the link. If the link is in a
frame, the linked window will open in the parent frame or in the
parent window of the frame with the link. See Book II, Chapter 4 for
more information about frames.

_self: Opens the link in the currently opened window; this is the
default target.

_top: Opens the link in the top-level window, replacing any existing
frames.
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4+ List: Click the Unordered List button next to the Target field to transform
text into an unordered (bulleted) list; click the Ordered List button to
transform text into an ordered (numbered) list.

4+ Placement: Click the Text Outdent button you find next to the Ordered
List button to outdent (decrease the indent) the selected text; click the
Text Indent button to indent the selected text. If you outdent an item in a
bulleted or numbered list, the item will no longer be a list item.

Inserting a line break

When you want to start a new line in a word-processing program, you press
the Enter key. If you press Enter in Dreamweaver, you create a paragraph
break, which starts a new paragraph and creates a blank space between
paragraphs. If you want to start a new line directly under another line of text
and without the big space between lines, you need to insert a line break. In
Dreamweaver, you create a line break by choosing Insert>HTML=>Special
Characters=>Line Break or by pressing Shift+Enter. Alternatively, you may
click the Insert Line Break button from the HTML category of the Insert bar.
Dreamweaver places the cursor at the start of the next line and inserts the
line break HTML code.
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64 Working with Images

Working with Images

Aside from entering text, manipulating images on a Web page is probably the
most common Dreamweaver function you perform. You can add or delete an
image and modify its properties to create an aesthetically pleasing layout
that effectively conveys the information you want to deliver to the user.

A\
To see how to place an image on the background of your page, check out the
“Establishing Page Properties” section, earlier in this chapter.
Inserting an image
To insert an image on a page, follow these steps:
1. Choose Insert=>Image.
Alternatively, you can click the Insert Image button in the Common cate-
gory of the Insert bar.
2. In the Select Image Source dialog box that appears (shown in Fig-
ure 2-6), click the image you want to insert.
If the image is outside the folder that holds your HTML document, use
the Look In drop-down list to browse to the file you want.
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3. Click OK to insert the image.

Note: Every image you want to include on a Web page should reside
within the root folder of the current site (typically, you should have
your HTML files in the site root folder — the master folder that holds
everything on your site — and all your images in an images folder that’s
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Working with Images 05

also in the site’s root folder). If you attempt to insert an image from
another location, Dreamweaver asks whether you want to copy the
image to the current site root folder. Click Yes. In the Copy File As dialog
box, you can enter a new name for the image in the File Name text field,
or you can accept the current name and click the Save button.

Always be sure you have saved your HTML file at least once before you
insert an image into it. If your file isn’t saved, Dreamweaver won’t know
where to place the image in relation to the file. After you've saved the file in
a particular folder, the location is known and Dreamweaver can include the
correct relative location of the image.

Put a check in the Preview Images check box at the bottom of the Select
Image Source dialog box to view a thumbnail of the image before you select
it for insertion. The preview area also tells you the size of the image and the
expected download time.

Deleting or moving an image

To delete an image from a page, click the image in the Document window and
press the Delete key on your keyboard.

If you want to move the image from one place on the page to another, you
can click the image in the Document window, press Ctrl+X to cut the image,
click the spot on the page where you want to move the image, and press
Ctrl+V to paste the image. You can also move an image by clicking and drag-
ging it to a new location.

Modifying an image
You can modify how an image appears on a page by editing its size and align-
ment, adding a border, and changing other attributes.

To modify an image, click the image in the Document window to select it. If
the Image Property inspector does not appear, choose Window=>Properties
to open it.

To see all the options the Image Property inspector offers, click the down
arrow in the bottom-right corner of the Image Property inspector. (Clicking
the up arrow displays fewer options.)

You can do any of the following things to modify the way an image appears:

4+ Resize the image: Click and drag a sizing handle to change the dimen-
sions of the image. To resize the image maintaining the same propor-
tions, hold down the Shift key as you drag a sizing handle. You can also
resize the image by typing new pixel dimensions in the W and H text
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fields in the Image Property inspector. Click the Resample button to con-
form the resized image to the new dimensions (otherwise resizing in
Dreamweaver changes the dimensions in which the browser draws the
image, but leaves the image file itself untouched — and image quality
will suffer when the browser resizes the image).

If you want the resized image to look its best, you may be better off
resizing the image in Fireworks, because Fireworks gives you more con-
trol over the resizing process. To edit the image in Fireworks, select the
image and click the Fireworks button in the Edit section of the
Properties panel.

Align the image: In the Image Property inspector, click an alignment
button to position the image on the page (or within a cell if the image is
located in a table cell). Alignment button choices are Left, Center, and
Right. To align an image with special word wrapping, select one of the
alignment options, which are detailed in Table 2-1, from the Align drop-
down list that appears when you position your image near a bunch of text.

Add a border to the image: In the Image Property inspector, enter a
number in the Border text field to add a border of that thickness to the
image. Border thickness is measured in pixels.

Pad an image with spaces: In the Image Property inspector, enter a
number in pixels in the V Space (V for vertical) text field for the space
you want to appear between the top and bottom of the image and other
page elements; then enter a number in pixels in the H Space (H for hori-
zontal) text field for the space you want to appear between the image
and page elements on either side of the image.

Make the image a link: In the Image Property inspector, enter a URL in
the Link text field.

Specify alternative text for the image: In the Image Property inspector,
enter alternative text in the Alt text field. (Specifying alternative text
ensures that when viewers’ browsers don’t — or can’t — display the
image, some meaningful text appears instead, and also serves as an
alternative for sight-impaired visitors to your page.)

Name the image: In the Image Property inspector, enter a name in the
text field next to the thumbnail image. (Naming an image is important if
you want to refer to that image using a behavior or scripting language,
such as JavaScript, but is otherwise unnecessary.)

Edit the image: In the Image Property inspector, click the Edit button.

Dreamweaver allows you to optimize, crop, resample an image, adjust its
brightness and contrast, and sharpen it by using the buttons in the Edit
section of the Image Property inspector. If you want the most control
over the process of editing the image, click the Fireworks button to open
the image in Fireworks. You’ll have the choice of working directly with
the image or opening the source file the image came from. In most cases,



Working with Links 67

you maintain the highest image quality by manipulating the pre-optimized
source version of the image and then exporting it as a new GIF or JPEG.
If you don’t see the Fireworks icon in the Edit section of the Properties
panel when you select an image, you may have to set it (or another pro-
gram) as your primary image editor. See Book III, Chapter 8 for instruc-
tions on making Fireworks your primary image editor.

4+ Change the image file: In the Image Property inspector, enter a different
filename in the Src text field (or click the File Folder button to browse for
image files).

4 Add an image map: In Dreamweaver, you can add multiple hyperlinked
hotspots to images to create an image map. In the bottom left of the
Image Property inspector, you see an arrow pointer and some image
tools (a rectangle, circle, and free-form hotspot creator). With these
tools, you can create hotspots on your images, and you can specify the
following for each hotspot:

e The link location for the hotspot
¢ The target window for the link

e The alternate text for the hotspot

Table 2-1 Aligning an Image in Relation to Text
Alignment Option Effect on Image and Text Wrapping

Default Same as Bottom alignment

Baseline Same as Bottom alignment

Top Aligns the image top with the highest other inline element
Middle Aligns the image middle with the text baseline

Bottom Aligns the image bottom with the text baseline

Text Top Aligns the image top with the text top

Absolute Middle Aligns the image middle with the text middle

Absolute Bottom Aligns the image bottom with the bottom of the text descenders
Left Aligns the image flush left

Right Aligns the image flush right

Working with Links

Linking your page to other Web pages enables you to direct visitors to
related content on the Web. To insert a link, you must specify an image or
some text to serve as the link; you must also specify the link location to
which you want to send your visitors. The link can go to a page within your
site or to a page elsewhere on the Web.

Book Il
Chapter 2
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Inserting a link

To insert a link on a page, follow these steps:

1. Select the text or image you want to make into a link.

Doing so opens the Property inspector for your text or image. If the
Property inspector does not appear, choose Window=>Properties to
open it.

2. In the Link area of the Property inspector, enter the destination URL
of the link (text or image) that you created in Step 1.

The URL you specify can be any valid URL; for example, a Web page
within your own site (somePage.html), a page on the Web (http://
www . someSite.com/somePage.html), or even an e-mail address
(mailto:somebody@somewhere.com).

Alternatively, you may click the File Folder button you see in the
Property inspector to display the Select File dialog box. After you
browse your computer using the Select File dialog box and select a file,
click OK to make that file the target of a link.

To create an e-mail link quickly, click anywhere in your document and choose
Insertc>Email Link. Specifying the same value for the Text and E-mail fields
that appear allows folks who haven’t configured their Web browsers to
handle e-mail automatically to see the e-mail address on the page. Then,
they can copy and paste the e-mail address information into their e-mail
program of choice.

Deleting a link

To delete a link from text or an image without deleting the text or image
itself, follow these steps:

1. Select the text or image you want to remove the link from.

The Property inspector for your text or image opens. If the Property
inspector doesn’t appear, choose Window=>Properties to open it.

2. In the Property inspector, delete the URL from the Link text field.

Note that if you delete a linked image or linked text from a page, the link gets
deleted along with the text or image.

Using named anchors

When you want to create a navigational link that connects users not only to
a page, but also to a specific location on the page, you need to create a
named anchor. Named anchors are frequently used for jumping to exact
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positions within a large block of text so that users don’t have to scroll through
paragraph after paragraph to find the information they need. Named anchors
are especially useful when creating links from a directory or a table of con-
tents to the content it presents.

Inserting a named anchor
Place an anchor anywhere on your Web page as follows:

1. In the Document window, click at the position you want to insert the
named anchor.

2. Click the Named Anchor button on the Common category of the Insert
bar or choose Insert>"Named Anchor.

The Named Anchor dialog box appears, as shown in Figure 2-7. If the
Insert bar is set to a different category, click and hold the category name
and select Common from the drop-down list.

3. Type a name in the Anchor Name text field.

4. Click OK.
Figure 2-7: :Named Anchor @!
The Named Archor name; K 1
Anchor IEI
dialog box. [ b | |
<¥ It’s a good idea to insert the named anchor tag slightly above the actual posi-

tion where you want the link to target. Doing so gives your targeted content
a little padding on top. Otherwise, the top of your image or your first line of
text appears flush with the top of the browser window.

Linking to a named anchor

To link to a named anchor, follow the procedure outlined in the “Inserting a
link” section, earlier in this chapter, with the following modifications:

4+ Linking to a named anchor on the current page: In the Link text field
of the Property inspector, type a pound sign (#) followed by the anchor
name.

4+ Linking to a named anchor on a different page: In the Link text field of
the Property inspector, type the page’s URL followed by a pound sign
and then the anchor name.

Book

Chapter 2
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Be sure not to include any spaces in the names of anchors. These may not
be read by the various Web browsers.

Working with Tables

You can position objects (such as text blocks, images, or animations) rela-
tive to each other on a page in two basic ways:

4+ Using tables: A time-honored Web tradition for page layout, tables are
grids of cells defined by columns and rows. Cells can have set sizes and
alignments and may contain anything you can put on a Web page, includ-
ing other tables.

4+ Using layers: Layers can be positioned precisely, and in Dreamweaver,
layers are in some ways easier to use than tables. For instructions on
how to lay out your Web page with layers, see Book I, Chapter 5.

Adding a table to a Web page can help you lay out page elements more easily
in the Document window. Tables consist of as many holding areas, or cells,
as you want, and you can place virtually any Web element, such as text or an
image, into a cell. Cells are organized horizontally into rows and vertically
into columns. Dreamweaver provides you with complete control over the
size, position, color, and other attributes of your table. You can edit these
attributes at any time via the Table Property inspector.

Inserting a table

To insert a table into a Web page, just follow these steps:

1. Click in the document where you want the table to go.

2. Choose Insert->Table, use the keyboard shortcut Ctrl+Alt+T, or click
the Table button in the Common category of the Insert bar.

The Insert Table dialog box appears, as shown in Figure 2-8. If the Insert
bar is set to a different category, click and hold the category name and
select Common from the drop-down list.

3. Enter the number of rows and columns you want the table to have in
the corresponding Rows and Columns fields.

You can always add or remove rows or columns later.
4. Use the Table Width field to set a width for the table.

The width can be either a set number of pixels or a percentage of the
area that bounds the table (the page itself, or, if the table is nested in a
cell, that cell).



Figure 2-8:
Fill out the
Insert Table
dialog box
to create
atable.
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5. In the Border Thickness field, enter a number for how many pixels

thick you want the border of your table to be.

If you don’t want the table border to show (which you probably don't if
you’re using the table for page layout purposes), enter 0 (zero).

6. In the Cell Padding field, enter a whole number for the amount of

pixels you want between the border of the cell and the text or object
inside the cell.

The cell padding applies to the top, bottom, left, and right of the inside
of each and every cell.

7. In the Cell Spacing field, enter a number for the amount of pixels you

want between the cells.

The cell spacing applies to the whole table; you can’t have different cell
spacing for individual rows or columns.

8. If your table has a header row or header column (or both), click the

button (None, Left, Top, or Both) that represents the header structure
of your table.

The text in a header row has special formatting that you can define in a
stylesheet. If you're creating a table for layout purposes, you won’t want
a header row or column, so make sure None is selected.

9. In the Accessibility section of the Insert Table dialog box, enter a cap-

tion and summary for the table if you need to describe the table for a
sight-impaired audience.

If you're making the table for page layout purposes, leave these blank.

Insert Table @_
I Table size .
Rows: 3 Colurins: 3
Table width: 600 | |piccels X
Border thickness: 1 pizels
Cell padding: 0
Cell spacing: £
Header
B
H T H
Lt T Both
Accessivility
Caption:
Allgn caption; | default |~ Book Il
Sumnary: Chapter 2
e cancd ] |
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Figure 2-9:
A simple
table.

Working with Tables

10. Click OK.

The Insert Table dialog box disappears and the empty table appears in
your document.

An empty table is shown in Figure 2-9. To enter data into the table, just click
on an individual cell and enter the content you want in that cell. You can
modify any of the table’s attributes by selecting the table and changing the
attributes in the Properties inspector or the Tag Inspector panel.
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Deleting a table

To delete a table from a page, click the border of the table to select it and
then press the Backspace or Delete key. Dreamweaver removes the table
from your page and deletes the associated code in the HTML for the page.
Naturally, everything that was in the table is also deleted from the page.

Using layout tables

The use of tables is central to the traditional way of building great Web pages
(for information on laying out pages with layers, see Book II, Chapter 5).
What happens, though, when you want to put an image right smack in the
middle of a page, or when you want to have one column of information along
the right side of the page, and a square text block at the bottom of the page?
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You can nest tables, which involves building new tables inside cells of other
tables, but creating nested tables is complicated and not at all fun, especially
with complex pages.

Thankfully, Dreamweaver offers an easy way to work with complex tables
called layout tables. With a layout table, you tell Dreamweaver where you
want to put something on the screen, and the program generates all the
required tablework to make it happen.

To create a layout table, just follow these steps:

1. Click the Layout view button in the Layout category on the Insert bar. SRR

If the Insert bar is set to a different category, click and hold the category Chapter 2
name and select Layout from the drop-down list.

2. Click the Layout Table button (just to the right of the Layout view Q

button). s

o -

3. Click and drag the cross hair to create the layout table of your choice. ;,"‘a
<«

A light green table appears, as shown in Figure 2-10, with the dimensions @ %

you gave it.
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Previewing Your Work

4. To create individual cells within that table, click the Draw Layout Cell
button to the right of the Layout Table button and draw a cell any-
where within the table.

If you create a layout cell outside a layout table, Dreamweaver will
create both the cell and the table to support it. Note that you cannot
draw a new cell that overlaps an existing cell in the table.

If you create a layout cell, you can immediately edit the cell you created.
However, if you create a layout table, you either have to switch back to
Standard view to edit the single cell of that table or create a layout cell
within the table before you can edit the table.

Storing information in table cells

After you insert a table on a page, you can add or delete elements such as
text and images in the table cells:

4 Adding an image to a cell: To add an image to a table cell, click in a
table cell and choose Insertr>Image. Browse and select an image you
want to add to the cell and then click OK. (For more information on
inserting images, flip to the “Inserting an image” section, earlier in this
chapter.)

4+ Adding text to a cell: To add text to a table cell, click to position the
cursor in a table cell and type the text you want placed inside the cell.

4 Deleting an image from a cell: To delete an image from a table cell, select
the image and press Backspace or Delete.

4 Deleting text from a cell: To delete text from a table cell, select the text
and press Backspace or Delete.

Previewing Your Work

Whether you’re working in Code view or Design view, at some point you’ll
want to see the page as visitors to your site will see it: in a browser such as
Internet Explorer or Netscape Navigator. If you have two or more browsers
on your computer, you can preview your page in any of the browsers —
without leaving Dreamweaver — by using the Preview in Browser feature.

To preview your page in your primary browser, choose Filer>Preview in
Browserw>Browser Name or use the keyboard shortcut F12. The keyboard
shortcut for previewing in your secondary browser is Shift+F12.



Chapter 3: Creating and Using
Dreamweaver Sites

In This Chapter

v Defining a site in Dreamweaver 8

+* Whipping up your first site

v~ Establishing a remote connection

v~ Using advanced site options

v+~ Publishing and maintaining your site

v+~ Using source control

Dreamweaver 8 can be used to create many different kinds of Web
pages. During the course of building a Web site, you’ll add pages,
graphics, links, and all sorts of related information into a single location to
be posted eventually to a Web server on the Internet. After your site is com-
plete, you’ll probably want to make updates and fixes. Heck, you may even
be making more than one site at the same time!

To help facilitate management of your Web site (or sites), Dreamweaver
offers a suite of site management tools. These tools are collectively called a
Dreamweaver Site. This chapter explores how you can use these tools to
manage your Web site more easily.

Defining a Site in Dreamweaver 8

Figure 3-1 shows a typical relationship between where you build your Web
site (your desktop) and where the site actually lives on the Internet (a Web
server). Dreamweaver Sites facilitate getting all the correct information
from your desktop to the Web server and generally make the Web page cre-
ation process easier. Specifically, a Dreamweaver Site enables you to do
the following:

4+ Move files seamlessly back and forth between your local machine and
your Web server.

4+ Keep all your site files in a single location.
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Figure 3-1:
The desktop
in relation to
the Web
server.

4+ Generate pages for your site based on templates that you create.

4+ Run reports on the pages in your site to check links, page load, and
other key functions.

4+ Use source- and version-control to manage who works on what files and
when they do it, which can prevent team members from accidentally
overwriting each other’s work when building or maintaining a site
collaboratively.
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Creating Your First Site

If you're working with a set of files regularly in Dreamweaver, or if you're
managing several sites, you're likely to find using Dreamweaver Sites —
which are different from a traditional Web site — an efficient way of working.
You can create a site in Dreamweaver manually or by using a wizard, as the
following sections describe.

Creating a site manually

This section shows you how to create a Dreamweaver Site manually. The fol-
lowing steps walk you through inputting the minimum amount of information
that you need to enter to create your site. However, you can choose from a
number of other options, and they are covered in the “Using Advanced Site
Options” section, later in this chapter.

To create a basic site manually, follow these steps:

1. Choose Site->Manage Sites.

The Manage Sites dialog box appears. You can also open the Manage
Sites dialog box by choosing Manage Sites from the drop-down list in the
Files panel that shows the current site.



Figure 3-2:
Defining
your site.
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2. Click the New button.
A pop-up menu appears with the choices Site and FTP & RDS Server.
3. Select Site.

The Site Definition dialog box appears, opening to the Advanced tab by
default. The Local Info options, shown in Figure 3-2, appear by default.

Site Definition for Unnamed Site 1 %]
|
Basic | Advanced |

Cabegoey Lezal Info
Local Infa

Remate Info

Tesking Server

Cloaking

Design hotes

Site Layouk

File \:‘?x Co{mns [] Refresh lncal file list automatically
Contribute

Site name: | Unnammed Site 1

Local rook folder: | CriwerkingiUnnamed Sike 14 i |

Diefaut images Folder: i |

HTTP address: | hetp:]

This address enables the Link Checker to
detect HTTR links that refer o your own
b,

Cache: [#] Enable cache:

The cache mantans file and asset
informakion in the site, This speeds up the
#sset paned, link management, and Ste
Map Features,

’__Ok | Cancel“ ][ Help‘

4. Set the options for your site by filling out each of the following pieces
of information:

¢ Site Name: Choose a name that you can remember easily and that
applies to the function of the site.

¢ Local Root Folder: This is the location on your hard drive where you
want to store the files that make up your site. Again, you should title
the folder something intuitive and easy to remember. If you want to
browse for a folder, just click the folder icon to the right of the text
field.

¢ Refresh Local File List Automatically: When this option is selected,
Dreamweaver refreshes the list of files in your site every time you
copy a file into the site. The option is selected by default.

Sa)IS Janeamuweai(
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Creating Your First Site

¢ Default Images Folder: This is the standard directory for images
used on your site. Dreamweaver adds images here when you copy
image files into your site. A good practice is to name this folder
images (if your site is going to be hosted on a UNIX-based server,
you need to be consistent about using upper- and lowercase letters
in filenames and links to those files from your site). If you want to
browse for the directory, just click the folder icon next to the text
field.

e HTTP Address: This is the URL of your Web site. Dreamweaver uses
this to verify that links in your site are working properly.

¢ Enable Cache: Selecting this option speeds up Dreamweaver’s site
management tools and is required for the Assets panel to work. See
your documentation for information about using the Assets panel.

5. Click OK to create the site.

Dreamweaver creates a folder for your site if it doesn’t exist on your hard
drive, but it doesn’t create the images directory within that folder. Thus, it’s
always a good idea to create your folders on the hard drive first and then
create your site.

Creating a site using a wizard

You may think that using a wizard to create a site is easier, which is true

if you're creating a complex site. However, if you're creating a simple site
(one that you’ll be working on by yourself and that doesn’t employ a server
technology or testing server, for example), the manual route is the simpler
way to go.

To use the wizard, follow these steps:

1. Choose Site->Manage Sites.

The Manage Sites dialog box appears.
2. Click the New button.

A pop-up menu appears with the choices Site and FTP & RDS Server.
3. Select Site.

The Site Definition dialog box appears, opening to the Advanced tab
by default. (It just so happens that the Advanced tab has all the stuff
for defining your site manually, whereas the Basic tab holds the Site

Definition Wizard.)

4. Click the Basic tab to access the wizard, as shown in Figure 3-3.



Figure 3-3:
Step one of
the wizard.
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Site Definition for Unnamed Site 1 %]
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5. Enter a name for your site in the appropriate text field and then click
Next.

The Editing Files, Part 2 page of the wizard appears.

6. If your site is going to be dynamic, choose a server technology to
process Web pages before they’re sent to the user and then click Next.

Select a technology by selecting the Yes radio button and selecting your
Web serving technology from the drop-down list. Dreamweaver provides
you with several server options, including several flavors of ASP, plus
JSP, PHP, and (of course) ColdFusion. If you’re not using a server tech-
nology, select the No radio button.

7. In the new page that appears, choose how you want to edit your files
and then click Next.

If you have selected a server technology to use on the Editing Files,

Part 2 page, then on the Editing Files, Part 3 page you get the Dynamic
options shown in Table 3-1; if you’re not using a server technology, you
get the Static options. Click the radio button next to the option you want
to choose.
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Table 3-1 Site Editing Options

Dynamic  Static
Option Description Option Option
Edit and Test Locally Allows you to edit your files and test Yes No

them locally using ColdFusion (or
other technology) as your Web server.

Edit Locally, Then Upload  In this mode, you edit the files onyour ~ Yes Yes
to Remote Testing Server ~ computer and then manually upload

(Edit Local Copies on Your  them using Dreamweaver’s FTP tools

Machine, Then Uploadto  to move the files to a remote server.

Server When Ready)

Edit Directly on (Remote This option allows you to edit files Yes Yes
Testing) Server Using directly on a volume on your internal
Local Network network.

8. In the new page that appears, configure your testing environment and
then click Next.

Based on the editing and testing methodology you chose in Step 7, you
are asked to configure your testing environment. Here are the various
options:

¢ Edit and Test Locally: For this method, you are asked to provide the
local URL for testing. Usually, this is http://localhost/ folder,
where folder is the name of the root folder of your site.

In order to ensure that this method works properly, always make
sure that you create your site within the directory for http://
localhost on your hard drive. For most Windows 2000 or XP
computers, this location is C: \inetpub\wwwroot\ by default.

¢ Edit Locally, Then Upload to Remote Testing Server: If you select
this route, click Next to see a page where you can select a method
of connecting to the remote location for your site. Your options are
Local/Network, FTP, RDS (Remote Development Services, used in
conjunction with ColdFusion), and the always popular, “I'll set this
up later.” Figure 3-4 shows the Local/Network option.

e Edit Directly on (Remote Testing) Server Using Local Network: If
you’ve chosen this option, then you are asked for the URL of the
remote server, as shown in Figure 3-5, so that Dreamweaver knows
where to look to test your site. If you want to edit directly on the
remote testing server using FTP or RDS, click the Create an FTP or
RDS Server Connection text link on the first page of the wizard.



Figure 3-4:
Connecting
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local
network.
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Setting Up a Remote Connection

9. In the new page that appears, configure your file sharing options and
click Next.

Dreamweaver includes options for source control, which you can use to
prevent team members from overwriting each others’ work when col-
laborating. You can choose to enable it here by selecting the Yes radio
button. File sharing is discussed in more detail in the “Using Source
Control” section, later in this chapter.

10. Review your settings and click Done to set up your site.

The Site Definition dialog box closes. Click Done to close the Manage
Sites dialog box.

Setting Up a Remote Connection

After you create your site, either by using the wizard or by setting it up man-
ually, it’s a good idea to get connected to the place where the remote version
of your site (the one users will access via the World Wide Web) will live.
Dreamweaver can connect to a remote server in a variety of ways. The route
you choose depends largely on how you plan to build and maintain your
site. You have essentially three different scenarios:

4+ Creating and testing your site solely on your own computer: For exam-
ple, this may be the case if you're building your site for someone else,
say a client. Here the remote server is your computer — not all that
remote!

4+ Creating your site on your computer, but testing it somewhere else:
This is the most common situation. Dreamweaver has three different
delivery options for this scenario: FTP, Remote Development Services
(RDS), and local network connection.

4+ Creating and testing your site on a remote machine: In this case, the
options are the same as in the previous bullet. The only difference is
that when you’re editing, you're editing files directly on the remote loca-
tion, leaving nothing on your local machine.

In most cases, your remote location is at an externally hosted Internet service
provider (ISP). If you've got an account set up with an ISP, make sure to get the
following information, which is required for Dreamweaver to set up a connec-
tion to your remote Web server:

4 An IP address or a URL to be used when posting your files

4+ Afolder on the remote server where you are supposed to keep your site
files



Figure 3-6:
The Manage
Sites dialog
box.
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4+ A username for your account

4+ A password for your account
To set up a remote connection, follow these steps:

1. Choose Site=>Manage Sites to bring up the Manage Sites dialog box,
shown in Figure 3-6.
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2. Select your site from the list on the left and then click the Edit button.
The Site Definition dialog box appears, opening to the Advanced tab.
3. From the Category list on the left, select Remote Info.

Along the right side of the dialog box, the Local Info options are replaced
with the Remote Info options. If you haven’t set up a connection previ-
ously, all you see is the Access drop-down list.

4. Select an option from the Access drop-down list.
You can choose from several Access options in this list, including
e FTP: The industry standard, file transfer protocol.

e Local/Network: A location on your local (meaning office, home
office, or your own computer) network.

¢ RDS: ColdFusion’s Remote Development Services allows secure
remote access to files within a ColdFusion application server.

¢ SourceSafe Database: SourceSafe is Microsoft’s version control
application, which helps prevent the accidental overwriting of files
when you're collaborating with others to build the site. With
Dreamweaver, you can integrate SourceSafe and use it for your
version control.

e WebDAV: This stands for Web-based Distributed Authoring and
Versioning. Like SourceSafe, it’s a standard for version control and is
used with Web servers like Apache Web Server and Microsoft IIS.
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Figure 3-7:
Setting your
Firewall
preferences.

5. Fill out the appropriate information for the connection type you
selected.

Leave the source control settings alone for the moment, which are
described in the “Using Source Control” section, later in this chapter. The
following list describes the information needed for each connection type:

FTP: In addition to the four items we note at the beginning of this
section (host, folder, username, and password), you also need to
select the Passive FTP check box if you plan to use Passive FTP
(required for some servers). If there’s a firewall you need to work
through, you can click the Firewall Settings button to set the Firewall
preferences in the dialog box that appears, as shown in Figure 3-7.
Select the Use Secure FTP (SFTP) check box if you want to use
encrypted secure logins (again, not likely). After you've added the
necessary settings, you’re able to connect to your ISP.
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If you select Automatically Upload Files to Server on Save,
Dreamweaver will automatically make a connection to the remote
server and upload your file each time you save it.

Select the Enable File Check In and Check Out option if you're work-
ing in a collaborative environment and you want to ensure that other
team members can’t work on a file at the same time you’re working
on it. If you select this option, you need to add information that will
identify you to your collaborators.

Local/Network: Here you only need to specify the location of the
remote folder on the network or a local drive, which you can enter
manually or by clicking the folder icon to browse the network for the



Figure 3-8:
The
Configure
RDS Server
dialog box.
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folder location. You can also select the Refresh check box if you’d
like the list of files on your site to be automatically refreshed when a
new file is added.

e RDS: If you select RDS from the drop-down list, you need to click the
Settings button next to the list to configure the RDS connection, as
shown in Figure 3-8. To configure RDS, you need a host name (IP
address or URL), port number (the default is 80), the directory of the
site on the host, a username, and a password. If you don’t want the
password saved, then deselect the Save check box.

Configure RDS Server %]

Host name; | Test Site
Part: |80
Full Host Directory: | Ainstpubhwamroaty,

Usemame: | 2cowitt

Pascwaid | sesssesss Save
-
|

¢ SourceSafe: As with RDS, with SourceSafe you have to click the
Settings button next to the drop-down list. Then you specify the loca-
tion of the SourceSafe Database Path (a path to an . ini file, usually
on a network volume), the name of the project, a username, and a
password. If you don’t want the password saved, deselect the Save
check box.

e WebDAV: With WebDAYV, you must also click the Settings button next
to the drop-down list to configure the connection. You need the URL
of the connection, a username, a password, and an e-mail address. If
you don’t want the password saved, deselect the Save check box.

6. Click OK to put the changes into effect.

Using Advanced Site Options

If you used the wizard to create your site, you may have been struck by the
array of questions asked. That’s because you can configure a number of
advanced settings with Dreamweaver. Most of them you're not likely to need,
but just in case, we describe them in the following sections. You can access
all these options by selecting the name of the item in the Category list of the
Site Definition dialog box (refer to Figure 3-2).
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Figure 3-9:
Choosing
a testing
server.

Testing your server

Select Testing Server from the Category list on the Advanced tab of the Site
Definition dialog box to access the options for setting up your testing server.
If you're building a dynamic site, you need to have a Web server running that
can process the pages and render them as HTML. (For more on how this is
accomplished, see Book VII, Chapter 3.) To specify a Web serving technol-
ogy, do the following:

1. Select a Web server from the Server Model drop-down list, as shown
in Figure 3-9.

You have several options here; if you're working within the Macromedia
model, your selection is probably going to be ColdFusion.

Site Definition for Demosite %]
f
| Basic | Advanced |

Cabegory Testing Server

Local Info

Remate Info o :
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Cloaking =

Deslgn Motes Access: |ROS M|

Site Map Layout
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Contribute

URL prefiz: | http: fflocathost [

The URL Prefix Is the location of the ske's
root Folder on the tesbing server.

’__ QK | Cancel“ [ Help

2. Select an Access type.

You can choose FTP or Local/Network. If you chose RDS on the Remote
Info screen, you see an RDS option here as well. Choosing any of them
provides additional fields for you to fill out, as specified for each Access
type in the “Setting Up a Remote Connection” section, earlier in this
chapter. Choose None if you don’t want to use a testing server.

3. Click OK to save your settings.
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Cloaking

Cloaking is a handy and appropriately named feature in Dreamweaver Sites.
When enabled, cloaking allows you to hide different file types or folders from
Dreamweaver’s site tools. This can be especially helpful if you keep your raw
asset files (your source Fireworks PNGs, Flash FLAs, and so on) in the same
directory as the site itself, but you don’t want the files uploaded or down-
loaded, included in reports, or otherwise touched by various Dreamweaver
operations. To engage this feature, click the Advanced tab of the Site
Definition dialog box and select Cloaking from the Category list on the left.
Then select the Enable Cloaking and Cloak Files Ending With check boxes
and add the file extensions for the file types you want to mask. See the
online Help files for more details.

Using Design Notes

Design Notes aren’t really necessary unless you're collaborating on a site
with other people. In that case, Design Notes can be especially helpful. For
example, you can use Design Notes to let others know the status of a given
file. To engage Design Notes, click the Advanced tab of the Site Definition
dialog box, select Design Notes from the Category list on the left, and then
simply select the Maintain Design Notes check box. If you want to move the
notes to the server when the site is published so that other team members
can access them, select the Upload Design Notes for Sharing check box.

Setting up a site map

If you select Site Map Layout in the Category list in the Site Definition dialog
box, you can set up the specifics of how you’d like your site’s site map to
look. You can specify the following:

4 The home page for the site map, which can be different from the home
page (index.htm) of the site

4 The number and width of the columns of the map

4+ The labels for the site map icons

4+ Whether or not to display items marked hidden

4+ Whether or not to display dependent files

Selecting columns for the File view

For the File view, shown in Figure 3-10, you have six built-in columns to choose
from: Name, Notes, Size, Type, Modified, and Checked Out By. However, you
can also add and remove your own columns by clicking the (+) and (-) but-
tons, respectively. For a column you create, you can also specify the following:
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Figure 3-10:
The File
view.

4 The column name

4+ The column’s Design Note association, if its contents relate to a specific
Design Note

4 The text alignment for the column

4+ The option to show or not show the column in the File view (Note: The
Name column cannot be hidden or moved.)

4+ Whether or not to share the column so other workers on the site can
see it (Note: You must have Maintain Design Notes selected to share a
column.)

Enabling Contribute compatibility

To enable compatibility with Contribute, click the Advanced tab of the Site
Definition dialog box and select Contribute from the Category list on the left.
Select the Enable Contribute Compatibility check box if you plan to have
people maintain your site using Contribute. Selecting this option allows you
to perform many administrative functions related to Contribute (for exam-
ple, you can send Connection Keys based on your Dreamweaver Site setups).
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Publishing Your Site

Publishing Your Site
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After you've set up a remote site in a Dreamweaver Site, publishing your site
is a snap. To publish your site to a remote server, just follow these steps:

1. If the Files panel isn’t already open, open it by choosing Window=>
Files or by pressing F8.

2. On the File tab, click the Expand/Collapse button (the button on the
far right of the toolbar) to switch to File view mode.

This brings up the File view shown in Figure 3-11.

Macromadia Dreamweavar 1 - [Cnetpulwwwioot Studiof'indexhiml (XHTMLY

S

3. If you haven’t connected to the remote server since you launched
Dreamweaver most recently, click the Connection button at the left
of the Files panel toolbar to establish a connection with the remote
server.

4. Select a file and click the Put button on the toolbar (an upward point-
ing blue arrow) to copy a file from the local server to the remote
server, or click the Get button (a downward pointing green arrow) to
copy a file from the remote server to the local server.
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If you're copying files for the first time, simply select the site’s root
folder and click the Put button. To copy files from the Local to Remote
servers, or vice versa, you can also simply click and drag the elements
from local to remote, or vice versa. If you use this method, be careful to
place files in the correct folders.

P If you ever want to see what’s going on behind the scenes when you’re copy-
ing those files, just click the FTP button in the toolbar in File view. The
Results panel appears/expands and shows you the remote connections
being set and all the commands for the files being sent (the File view col-
lapses back to the Files panel as well).

Maintaining Your Site

After your site is built, you want to make sure that it continues running at
peak efficiency. To help in this effort, Dreamweaver offers some valuable
tools that can help you keep on top of the wide array of items that go into
keeping your site running smoothly. We describe the two basic types of
tools, reports and link checkers, in detail in the following sections.

Running reports

Reports encapsulate information about various aspects of your site at the
time the reports are run, giving you a snapshot of information such as which
files on your site are currently being worked on by different team members,
whether all the images on a selected page have Alt tags, and more. To run a
report in Dreamweaver, just follow these steps:

1. Choose Siter>Reports.

The Reports dialog box appears, as shown in Figure 3-12.
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Figure 3-12:
The Reports

dialog box. [ ree




Figure 3-13:
Filtering
results.
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2. Choose what you want to run the report against.

You can choose to run a report on the currently selected document, the
entire site, selected files in the site, or a folder within the site. Select one
of these options from the Report On drop-down list.

3. Select the reports you want to run by selecting the check box next to
their names.

You can run nine possible reports, across two categories:

¢ Checked Out By: This report tells you what files in source control
are currently being used by different members of the team. If you
want the report to show only which files are currently checked out
by a particular team member, click the Report Settings button at the
bottom of the dialog box while the report is selected and add an indi-
vidual’s name to the text field in the Checked Out By dialog box that
pops up.

¢ Design Notes: This report prints out all the Design Notes associated
with files on the site. To filter your results via the Design Notes
dialog box, shown in Figure 3-13, click the Report Settings button
while the Design Notes report is selected.
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¢ Recently Modified: This report shows which files have been modi-
fied within parameters you set by clicking the Report Settings button
and specifying in the Recently Modified dialog box.

¢ Combinable Nested Font Tags: This report details locations in the
code where overlapping Font tags could be merged. For example, if
you change the size of a block of text, your code might contain some-
thing like this:
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<FONT face="Arial"><FONT size="2">Some text.</FONT>
</FONT>

When it could and should be
<FONT face="Arial" size="2">Some text.</FONT>

Accessibility: If you run this report, the site files are scanned to find
places where the code is not ADA (Americans with Disabilities Act)
compliant. For more information about accessibility, browse to

the W3C Web Accessibility Initiative pages at www.w3 .org/WAT/
Resources/.

Missing Alt Text: This report looks for images to make sure they
have Alt text, which is both best practice and important for accessi-
bility (see the section on modifying an image in Book II, Chapter 2 for
a little info on Alt text).

Redundant Nested Tags: This report searches the code for locations
where extra tags can be eliminated.

Removable Empty Tags: If you're working in Design mode and moving
lots of things around, sometimes the underlying code can be left with
lingering, empty tags. This tool finds those empty tags.

Untitled Documents: This report searches for pages that may have a

filename but don’t have a title.

4. Click Run to run the reports.

The results appear in the Site Reports tab of the Results panel, as shown

in Figure 3-14.
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Checking links

In addition to the reports that help clean up your code, Dreamweaver can
also check the links on your site. To run the Link Check report, choose Siter>

Check Links Sitewide or press Shift+F8.

You see the results in the Link Checker

tab in the Results panel. The report shows broken links, external links, and

orphaned files.
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Using Source Control

Source control allows team members to check out a document in your site,
thereby locking it and making it uneditable by others until the team member
who checked it out checks it back in again. This process is intended to ensure
that files don’t get overwritten accidentally and that data doesn’t get lost
during the development process.

“\NG‘
QA !
&

In most large-scale software development projects, where multitudes of people
work on a single code-base, source control is critical. If your site requires that
more than three people work on the same pages and code, you should con-
sider taking advantage of this feature in Dreamweaver.

To set up source control, do the following:

1.

4.

Choose Siter>Manage Sites, select your site, and then click the Edit
button to open the Site Definition dialog box.

. Click the Advanced tab if it’s not already open and select Remote Info

from the Category list on the left.

. Set your source control options at the bottom of the screen.

When you enable file check in and check out, the following options
become available:

¢ Check out files automatically when you open a document within the
site.

¢ Provide your name and e-mail address for site reporting and informa-
tional purposes.

You must have selected an Access option on the Remote Info screen
before you can get the Check In/Check Out options to show up at the
bottom of the page. See the “Setting Up a Remote Connection” section,
earlier in this chapter, for more information about Access options.

Click OK to save your settings.

To work with a file after you’ve enabled source control, right-click the file
from the Files panel and select one of the following options:

+*
<+

+

Get: Retrieves the most recent version of the file and copies it locally.

Check Out: Makes your local version the only editable version of a docu-
ment and ensures that others can’t open and save the file.

Put: Copies the local version of your file to the remote location.

Check In: Puts your local version of the file on the server and unlocks it
so that others can check it out and work on it if necessary.
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Chapter b: Punching Up Your
Pages with Forms and Frames

In This Chapter

v Incorporating forms into your Web pages

1 Structuring your pages with frames

' wo Web page features, forms and frames, are also two of the most
advanced features. You use them in your Web pages to serve the follow-
ing functions:

4+ Forms: Enable you to gather information and feedback from the users
who visit your Web pages. Forms can consist of text fields, buttons,
check boxes, radio buttons, and drop-down lists, all of which enable the
user to enter information or to choose among options you present.

4+ Frames: Enable you to construct sophisticated navigational schemes
for your Web site. Frames are actually separate Web pages that are parti-
tioned off so that two or more can be displayed in the same browser
window at the same time. For example, one frame may be a navigational
page consisting of a list of links to other pages; that frame remains in
place in its portion of the browser window even when the user clicks a
link to display a different Web page in the other frame.

In this chapter, you see how to work with these powerful features in
Dreamweaver 8.

Incorporating Forms into Web Pages

Forms on the Web serve the same purpose as the paper-based forms you
fill out — they provide a structured format for gathering specific informa-
tion. The difference is that Web-based forms usually require less time for
keyboard-savvy users to fill out.

Dreamweaver offers you a number of handy tools for creating Web-based
forms that you can easily include on your Web pages. You can incorporate
everything from text fields to radio buttons, and create surveys, gather user
data, and conduct e-commerce.
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Figure 4-1:
The dashed
lines mean
you've
created
aform!

Incorporating Forms into Web Pages

Creating Web-based forms requires two steps:

1. Creating the form that users see and interact with, which we demon-
strate how to do using Dreamweaver in this chapter.

2. Creating the processing program that accepts and processes form
input, which we cover in more detail in Book VII, Chapter 4.

Adding a form

Before you can insert specific form objects such as check boxes on your Web
page, you must first add a form to the page so that the appropriate code is
added to the HTML.

To add a form to a page, click in the Document window where you want to
add the form and choose Insert>Form="Form, or click the Form button from
the Forms category on the Insert bar. (If the Insert bar is set to a different
category, click and hold the category name and select Common from the
drop-down list.)

Dreamweaver adds the form to the page as indicated by the red dashed
lines, and also adds the associated form tag to your HTML page code, as
shown in Figure 4-1. You can now insert form objects inside the red dashed
lines of the form.
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If you attempt to add a form object without first adding a form, a dialog box
appears, asking whether you want to add a form tag. Click Yes to add both
the form tag and the object to your page.

Specifying form properties

A form has six properties that you can set using the Form Property inspec-
tor: Form Name, Action, Method, Enctype, Target, and Class. Click the form
to open the Form Property inspector. (If the Property inspector does not
appear, open it by choosing Window=>Properties.) Then specify the follow-
ing properties:

4+ Form Name: Enter an alphanumeric name in the empty text field (the
name should start with a letter, but it can be made up of both letters
and numbers). The advantage of naming your form is that you can use
the name to reference the form in a scripting language that you use to
retrieve, store, and manipulate the form data.

4 Action: Enter the URL of the application document/file that processes
the form data. Alternatively, you can browse to the location by clicking
the folder and making a selection in the Select File dialog box.

You can select the following three common actions:

¢ Enter the URL of a ColdFusion page that evaluates the form after it’s
been submitted.

e Enter the JavaScript program that runs after the user submits the
form. The action appears as follows:

javascript: function()
Here, function refers to the name of your form-handling function.

e Enter amailto: address where the form data goes after the user
clicks the Submit button. Amailto: address appears similar to the
following:

mailto:worker@formhandling.com

4 Method: Select a method from the drop-down list for how the form data
passes to the processing entity that you specified in the Action field.
Choices are Default, GET, and POST. (Default and GET are the same.) GET
sends the form data by appending it to the URL that the Action specifies.
POST sends the form data as a separate entity. GET limits the amount of
data that can pass along, but POST does not.

In other words, if you were to choose GET, the URL sent to the server
might look something like http: //www.server.com/coldfusionpage
.cfm&bowlingballcolor=blue, with the form data stuck onto the
end. If you were to choose POST instead, the URL would just look some-
thing like http: //www.server.com/coldfusionpage.cfm.
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Most of the time, whether you choose GET or POST doesn’t really make
a difference. However, there are times when you may want to choose
one over the other. For example, for security purposes, you may not
want information, such as a credit card number, ever being shown in a
browser’s history. And if the user might choose to bookmark the URL,
whether or not to have all of the form data appear could affect your
decision. If the form data included secure user information (such as the
credit card example), then you probably wouldn’t want to have the form
data appear. However, if the form data includes search criteria, the user
might want to bookmark the URL complete with the search parameters.

Data received at the specified mailto: address is not formatted for
easy reading: It appears as strings of code with the form data embedded
within it. This may depend on the encoding option, which we are about
to discuss.

Enctype: This is an optional attribute. For enctype, your choices are
application/x-www-form-urlencoded (the default), and multipart/
form-data. application/x-www-form-urlencoded replaces all blank
characters in the text with a plus sign (+), and it replaces other nonprint-
ing characters with symbols and numbers. This is often necessary for
the server to interpret the information it is receiving — for example,
when you’ve used the GET method, the browser would not be able to
process a URL with blank spaces in it. Multipart/form-data does not do
this conversion, but instead transfers the information as a compound
MIME document. Multipart/form-data is the method that must be used if
you are using an <INPUT TYPE="file"> element in the form. Instead
of either of these two options, you can type in text/plain, which will also
send the data unencoded; however, this is not a W3C standard.

Target: This is also an optional attribute. If you do not specify a target,
the server will assume that you want any information that is sent back
to the browser (the URL of the response page, for example) sent to the
same window or frame that your original form is in. If you wish the form
submission’s results to appear in a different frame or window, you must
specify the name of the target window in this attribute.

Class: You can apply a CSS (Cascading Style Sheet) class to the form as
a whole and to some form elements in order to control how those form
elements appear in a browser. For example, you can specify the color of
a text field by assigning it a style. This attribute is also optional. For
details on using CSS style sheets, take a look at CSS Web Design For
Dummies, by Richard Mansfield (published by Wiley Publishing, Inc.).

Labeling form objects

Dreamweaver enables you to provide descriptors for form objects and provide
the user with directions about how to complete the information requested for
each option. To add descriptors to form objects, simply position your cursor
in the form and begin typing. Then insert the form object you want.
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Using text fields

Text fields are blank text boxes that you can insert in your form to hold
alphanumeric information that the user types. You can set up a text field to
hold a single line of text, multiple lines of text, or a password, as follows:

4+ Single line: Provides space for the user to enter a single word or short
phrase of text.

4+ Multi line: Provides space for the user to enter a longer string of text.
Appropriate for a comment box.

4+ Password: Provides space for the user to enter a password. An asterisk
or other placeholder appears in the text field for each character that the
user types to hide the password characters from anyone who might be
looking over the user’s shoulder.

To add a text field, follow these steps:

1. In the Document window, click where you want to add the text field
and choose Insert~>Form=>Text Field, or click the Insert Text Field
button on the Form category of the Insert bar.

If the Insert bar is set to a different category, click and hold the category
name and select Form from the drop-down list.

Dreamweaver adds a text field to your form and a Text Field Property
inspector appears. If the Text Field Property inspector does not appear,
choose Window=>Properties to open the inspector.

2. Fill in the following fields of the Text Field Property inspector to
define the parameters of the text field:

TextField name: Enter a name in the empty field. The field is refer-
enced by this name in the HTML page code.

Char Width: Enter a whole number for the approximate visible width
of the field. (The width is approximate because text characters

in your form are displayed differently according to users’ browser
settings.)

Max Chars: (Applies to Single line and Password fields only) Enter

a whole number to indicate the maximum number of characters that
the user can enter in the field. Max Chars can be different from Char

Width.

Num Lines: (Applies to Multi-line fields only) This specifies the height,
in lines, of the form element, and may be affected by the setting for
Wrap.

Type: Select a radio button for Single line, Multi-line, or Password.
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¢ Init Val: (Optional) Enter an alphanumeric word or phrase that occu-
pies the text field when the user first encounters the field. Users can
enter their own information over the Init Val. If you leave this attrib-
ute blank, the user will see a standard empty text field.

e Wrap: (Applies to Multi-line fields only) Select an option for text
wrapping from the drop-down list. Options consist of Default, Off,
Virtual, or Physical. Default and Off are the same and do not wrap
text until the user presses the Enter key. The Virtual option wraps
text on the user’s screen but not when the form is submitted. The
Physical option wraps text both on the user’s screen and when the
form is submitted.

¢ (lass: (Optional) You may assign a CSS class to a text field to affect
the appearance of the field or the text within it. For details on using
CSS style sheets, look up CSS Web Design For Dummies, by Richard
Mansfield (published by Wiley Publishing, Inc.).

Setting up buttons

After a user enters data into a form, the user must then perform some sort of
task to transmit the data from his or her computer to another computer that
can process the information. Dreamweaver offers you three buttons you can
use to activate your form: Submit Form, Reset Form, and None:

4 Submit Form: After the user clicks this button, the form data scoots off
to another computer based on the specified action. (You see how to set
the action of a form in the “Specifying form properties” section, earlier in
this chapter.)

4+ Reset Form: After the user clicks this button, it erases all data entered
into the form, resetting each form field to its initial value.

4+ None: After the user clicks this button, it executes the programming
function that the Web designer assigned to it (for example, performs a
mathematical calculation or sends the user to a different URL).

Follow these steps to insert a button into your form:

1. Click where you want to add the button in the Document window and
choose Insert>Form=>Button or click Insert Button on the Form cate-
gory of the Insert bar.

If the Insert bar is set to a different category, click and hold the category
name and select Form from the drop-down list.

Dreamweaver adds a button to your form and the Button Property
inspector becomes visible. If the Button Property inspector does not
appear, choose Window=>Properties to open the inspector.
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2. Fill in the following fields of the Button Property inspector to define
the parameters of the button:

¢ Button Name: Enter a name in the empty text field. This name identi-
fies the button in the HTML code.

e Label: Enter the text that you want to appear on the button.

e Action: Select a radio button to indicate the function of the button.
Choices consist of Submit Form, Reset Form, and None.

¢ Class: (Optional) You can assign a CSS style to affect the button’s
appearance (color, width, and the like).

You can create a graphical Submit button — a button created from a small
image — by choosing Insert>Formr>Image Field or by clicking the Image
Field button in the Form category of the Insert bar. Then browse to the
image file in your site or type the path to and name of the image file directly
into the File Name field.

Adding other form elements

In addition to the text fields and buttons, you can add a variety of form ele-
ments that help your users give you information. Figure 4-2 shows some of
the useful form elements you can add to your forms. To insert any of the ele-
ments you see in Figure 4-2, follow these steps:

1. Position your cursor in the area of the Document window where you
want to add the element.

2. Click the appropriate button in the Form category of the Insert bar
(see Figure 4-2) or choose Insert~>Form Objects~>Desired Form

Element.
Image Field File Field
Jump Menu Label
Figure 4-2: |
Form [ rorms ~ EEEEIEEEEEE T
elements. | |

Create Form List Menu Button Field Set

Text Field Radio Group

Hidden Field Radio Button

Text Area Check Box
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If the Insert bar is set to a different category, click and hold the category
name and select Form from the drop-down list.

Dreamweaver adds the element to your form and the appropriate
inspector appears. (If the appropriate inspector does not appear, open
it by choosing Windows=Properties.)

3. Fill in the fields of the inspector.

If you're adding a radio button group, jump menu, or image, a dialog box
will pop up and ask you for additional information. Fill in your choices
for each of these.

4. Click OK to apply your selections and close the dialog box.

Structuring Pages with Frames

Vs

Frames are divisions of a Web page that enable you to load information inde-
pendently into distinct regions of the browser window. Frames are useful if
you want to display certain information onscreen while changing other infor-
mation. You frequently see three-frame pages on the Web — the top frame
shows the site’s title graphic, the left frame shows the navigation bar, and
the large body frame changes to show the content that you select.

A special HTML page called a frameset defines the structure and formatting of
frames on your Web page. As you work with frames, be aware that you must
always save the frameset page to lay out the size, position, and borders of
your frames, along with the content that you want to display in each frame.
Keep in mind that different browsers may draw the frames slightly differently,
even if you specify exact pixel dimensions.

Adding frames

You can add a frame to a frameless Document window or to an existing
frame within the Document window. Adding a frame to an existing frame
divides that frame into two or more regions.

To add a frame, click the Document window or existing frame in the area
where you want to add the frame. Then click the Frames button in the Form
category of the Insert bar and choose from the list of options that pops up.
You can also get to an equivalent list (the same options, some with slightly
different names and no icons) by choosing Insertc> HTML>Framese>Frame
Option, where Frame Option is one of the choices detailed in Table 4-1.
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Table 4-1 Options for Creating Frames
Frame Option What It Does

Left Creates a vertical frame down the left side
Right Creates a vertical frame down the right side
Top Creates a horizontal frame across the top
Bottom Creates a horizontal frame across the bottom

Bottom and Nested Left

Splits the page in two — top and bottom — and creates a left
frame in the top frame

Bottom and Nested Right

Splits the page in two — top and bottom — and creates a right
frame in the top frame

Left and Nested Bottom

Splits the page in two — right and left — and creates a bottom
frame in the right frame

Right and Nested Bottom

Splits the page in two — right and left — and creates a bottom
frame in the left frame

Top and Bottom

Creates three frames

Left and Nested Top

Splits the page in two — right and left — and creates a top
frame in the right frame

Right and Nested Top

Splits the page in two — right and left — and creates a top
frame in the left frame

Top and Nested Left

Splits the page in two — top and bottom — and creates a left
frame in the bottom frame

Top and Nested Right

Splits the page in two — top and bottom — and creates a right
frame in the bottom frame

A third method of adding a frame is to drag the outer border of the current
frame or Alt+click in the inner border. You can then follow the steps in the
next section to modify this new frame.

Modifying frames

You use the Frame Property inspector to select the source page that appears

in a frame. You also use the Frame Property inspector to format the appear-
ance of an individual frame. To modify a frame, follow these steps:

1. If the Properties panel is not already open, open it by choosing
Window=>Properties or by using the keyboard shortcut Ctrl+F3.

2. In the Frames panel, Alt+click the frame that you want to modify the

attributes of.

Note: You can’t simply click a frame to open its associated Frame Property
inspector. If you click a frame, you're actually clicking the source page that
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resides in the frame — a process identical to clicking in the Document
window for that page. To select a specific frame, press the Alt key and
click in the frame. You see the Frame Property inspector for an individual
frame and the selected frame marked with a dashed line, as shown in

Figure 4-3.
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A Frame Property inspector appears for the selected frame. If the inspec-
tor doesn’t appear, open it by choosing Window=>Properties.
3. In the Frame Property inspector or the Attributes tab of the Tag
Inspector panel, enter a name for your frame in the Frame Name text
field.
This name is the name by which the frame is referenced in the Frames
panel, target drop-down lists, and the HTML page code.
“&N\BER The frame name must start with a letter and you should not use hyphens,
& spaces, or periods. You should also avoid using JavaScript-reserved

names, such as top. Although these words and symbols may be accepted,
if you are using any scripting (JavaScript, VBScript) to manipulate your
frames, the results may be inconsistent or wrong. It’s a good idea to get
into the habit of avoiding these words and characters. Word separation
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can be indicated by capitalization, and underscore characters can also
be used.

. In the src text field, enter the name of the source page whose content
you intend to display in the frame.

Alternatively, you can click the Src folder and browse to select the
source page.

. Select a scrolling option for your selected frame from the Scroll drop-
down list. The options are as follows:

¢ Yes: Adds scroll bars to the frame, whether they’re needed or not.

¢ No: Doesn’t add scroll bars to the frame, even if a scroll bar is needed
to display the entire frame.

¢ Auto: Places one or more scroll bars in the frame if the frame con-
tents exceed the frame boundaries.

e Default: Places one or more scroll bars in the frame, depending on
the user’s browser settings.

. Select the No Resize check box if you don’t want the user to be able to
resize the frame.

If you do want the user to be able to resize the frame, leave the check
box deselected.

. Format the frame border appearance by selecting a choice from the
Borders drop-down list:

¢ Yes: Creates a three-dimensional look for the borders. (This doesn’t
work in all browsers.)

e No: Creates a single-color flat look for the borders, or, if No is
selected for each of the frames in a frameset, no border appears.

e Default: Enables the user’s browser to set how borders appear.

. Select a border color for the frame by clicking the Border Color
swatch and selecting a color from the Color palette that appears.

Alternatively, you can enter a hexadecimal color code in the Border
Color text field. This doesn’t work in all browsers and is optional. If your
frames don’t have borders, the border color will not apply.

. Enter a number in pixels in the Margin Width and the Margin Height
text fields.

Margin Width specifies the horizontal standoff space between the frame
content and the frame border. Margin Height specifies the vertical stand-
off space between the frame content and the frame border. This is in
addition to any values that the page called into the frame already has
assigned.
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\\3

Deleting frames

To delete a frame, select the frame border and drag it to the edge of the
parent frame or to the edge of the Document window — whichever is closer.
If you only have two frames on the page, this action will result in a frameset
with only one page in it.

Saving frames

Saving a frame means that you're saving the HTML page from which the
source content of the frame originates. To save a frame, follow these steps:
1. Select the frame by clicking in it.
2. Choose File=>Save Frame.

3. The first time you save the frame, enter a name in the File Name text
field of the Save As dialog box that appears and then click the Save
button.

Future saves require that you complete only Steps 1 and 2.

Saving framesets

Saving a frameset means saving the layout of frame positions, frame names,
and border formatting on a page. Keep in mind that you must save individual
frames to save the content contained in those frames. To save a frameset,
follow these steps:
1. Select the frameset by clicking one of its borders.
2. Choose File=>Save Frameset.
Note: This will not work if the frameset is nested.

3. The first time you save the frameset, enter a name in the File Name
text field of the Save As dialog box that appears and then click Save.

Future saves require that you complete only Steps 1 and 2.
If you have made changes to individual frames — not just the frameset —

since your last save, Dreamweaver asks if you want to save individual
frames. Make sure that you do so.

Setting no-frames content

Text-based browsers and many older browsers frequently don’t support
frames and can’t correctly display pages that you create by using frames.



Figure 4-4:
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To help ensure that the maximum number of users can view your page cor-
rectly, Dreamweaver offers you a method for building no-frames pages as
companions to your frame-enabled pages. To create a no-frames page for
your current frameset, follow these steps:

1. Choose Modify-~>Frameset->Edit NoFrames Content.

A blank, NoFrames Content page appears in the Document window and
replaces your frame-enabled page, as shown in Figure 4-4.
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2. On the NoFrames Content page, insert the content that you want to
appear in NoFrames browsers.

This content can include text, images, and other page elements.

3. Return to your frame-enabled page by choosing Modify~>Frameset~>
Edit NoFrames Content.

Targeting content

You can set up a two-frame frameset in which you use the left frame for navi-
gation and the main frame to display any link that the user clicks in the navi-
gation frame. Simply set up the link to target the main frame as the location
where you want the selected HTML page to open.
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Set up a target by following these steps:

1. Select the text or image that you want to act as a link.

Doing so opens the associated Property inspector. If the inspector
doesn’t appear, open it by choosing Window=>Properties.

2. In the Link field, enter the name of the HTML source page that will
appear in the frame.

Alternatively, you can click the Link folder and browse to select the
source page.

3. From the Target drop-down list, select the target frame where the link
is to appear.

All available targets are listed in the drop-down list, as shown in Fig-
ure 4-5. These targets include the names of all frames that you set up
and also the following systemwide targets:

e _blank: Opens a new browser window and shows the link in that
window. The current window remains open.

e _parent: Opens the link in a window that replaces the frameset con-
taining the current page.
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e _self: Opens the link in the current frame. The linked page replaces
the page in the current frame. If you want the link to open in the cur-
rent frame, you can select _self or leave the Target area in the
Property inspector empty.

e _top: Opens the link in a window that replaces the outermost frame-
set of the current page. (Same as _parent, unless you're using
nested framesets.)

Targeting can work in more complicated framesets using the same basic
process. Whichever frame you target is the one that will update when the

user clicks a link targeting that frame.
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Chapter 5: Laying Out
Pages with Layers

In This Chapter

v Adding, selecting, and deleting a layer
+ Placing objects in a layer

+~ Changing layer properties

~ Nesting layers

T) lay out the content of your Web page precisely, you can use tables
(see Book II, Chapter 2), or you can use the latest and greatest layout
aid: layers. You can think of layers in Dreamweaver 8 as separate pieces of
transparent paper that you fill with content (images, text, and so on) and
shuffle, stack, position, and overlap until your Web page looks exactly the
way you want.

Dreamweaver layers use a now common companion to HTML called
Cascading Style Sheets (CSS) in order to place your content anywhere on
the screen. However, you should be aware that Cascading Style Sheets are
only supported in Internet Explorer and Netscape Navigator versions 4.0
and higher. For more information about Cascading Style Sheets, check out
CSS Web Design For Dummies, by Richard Mansfield (published by Wiley
Publishing, Inc.).

Before you begin working with layers, you may find it useful to have the
Design panel open to the Layers tab. To do this, choose Windowr>Layers
or, if you're in hurry, simply press F2.

Adding a Layer

Adding a layer to the workspace of your Document window, shown through
the drawing method in Figure 5-1, can be done using one of the following
two methods:

4+ Choose Insert~>Layout Objects->Layer. If there is nothing on the page
already, as in this case, a new layer appears in the upper-left corner of
your Document window.
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4 Click the Draw Layer button (just to the left of the Standard button)
on the Layout category of the Insert bar. (If the Insert bar is not set to
the Layout category, click the category name and choose Layout from
the drop-down list.) Position the cross hair cursor anywhere in your
Document window and click and drag until the layer obtains the dimen-
sions you want. Release the mouse button.
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P If you set a layer’s visibility to Hidden, it may be invisible in the Document

window. To see it, simply click the name of the layer in the Layers tab of the
Design panel. Now you can see the layer, even though its visibility remains
set to Hidden. See the “Changing the visibility of a layer” section, later in this
chapter, for details on Visibility settings.

Selecting a Layer

Selecting a layer enables you to identify which layer you want to affect when
executing a layer operation, such as moving or naming the layer. Use any of
the following methods to select a layer:
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4 In the Document window, click on the boundary of the layer. (Your
cursor will turn into a four-pointed arrow when you place it over a layer
boundary.)

4 In the Document window, click anywhere inside the layer. (Note: This
won’t work if the insertion point is already inside the layer you want to
select.)

4+ In the Layers tab of the Design panel, click the name of the layer.

Selection handles appear on the boundary of the layer to indicate that you
have selected it.

Deleting a Layer

\\3

Deleting a layer removes the layer, the layer’s contents, and the layer marker
from the Document window. To delete a layer, select the layer and press the
Delete or Backspace key.

Don’t delete a layer if you want to remove it from one page and add it to
another. Instead, cut the layer by choosing Edit=>Cut or by pressing Ctrl+X.
Open the page where you want to add the layer and choose Edit=>Paste or
press Ctrl+V.

Placing Objects in a Layer

To add an object to a layer, click inside the layer and follow the normal
procedure for adding the object. For instance, add text to a layer by clicking
inside the layer and typing text; add other objects to a layer by clicking
inside the layer and choosing Insert=>Object, where Object is the name of the
item you want to add to the layer.

Changing Layer Properties

You can change lots of properties of layers, including

4+ Background: You can add a background image or color to a layer.

4+ Name: Naming a layer can help you keep track of objects on a complex
page, and is necessary if you want to apply Behaviors to the layer.

4+ Alignment: You can align layers with each other.

4+ Visibility: Layers (and the objects on them) can be visible or invisible.
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4+ Position: Layers can be nested inside other layers; they can also be
stacked in different orders.

4+ Size: You can change the layer’s height and width.

4+ Location: You can move a layer to any location on a page.

We show you how to edit each of these layer properties in the following
sections.

Including a background image or color in a layer

By default, an unnested layer does not have a color or background image
and will just display what lies beneath it as if it was transparent. (A nested
child layer, if it’s empty, will show the color or background image of its parent.
For more about nested layers, see the “Nesting Layers” section, later in this
chapter.)

You can change the background of any layer by adding a background image
or color as follows:

1. Select the layer whose background you want to change.

If the Layer Property inspector does not appear, open it by choosing
Window=>Properties.

2. In the Layer Property inspector, change one of the following:

¢ Bg Image: Click the folder to the right of the text field and browse to
select a background image from the Select Image Source dialog box
that appears. Click the Select button to accept your image choice
and close the dialog box. The path to and name of the background
image appear in the Bg Image field and the image is added to the
background of the layer. Figure 5-2 shows a layer with a background
image.

¢ Bg Color: Click the color box (the little gray box with an arrow on it)
and select a color from the color palette that appears. Alternatively,
you can enter a hexadecimal number for a color in the Bg Color field.
The new color appears in the background of the selected layer.

Naming a layer

The first layer you add to a page is automatically named Layer1, the second
layer you add is named Layer2, and so on. You can change these default
number names to other names that help you more easily distinguish layers
when working with HTML and examining layers with the Layer Property
inspector or Layers tab of the Design panel.
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To name a layer using the Layers tab of the Design panel, follow these steps:
1. If the Layers tab of the Design panel is not already visible, choose
Windowr>Layers or use the keyboard shortcut F2.
2. Double-click the Name column for the layer whose name you want to
change.
The current name is selected.
3. Enter a new name for the layer.
Remember that layer names cannot contain spaces.
A\

Get in the habit of appropriately naming your layers as soon as you create
them. The name BlueprintimageMap helps you remember a layer’s content

much better than Layerl5.

Aligning layers

Aligning layers with each other can help you precisely lay out visual content
in the Document window. You can align the top, left, right, or bottom sides of

layers.
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Figure 5-3:
Setting your
default
preferences
for layers.

To align layers, select the layers you want to align by pressing and holding
the Shift key and then clicking each layer in the Document window. Choose
Modify=>Arrange=>Align and choose one of the following options from the
submenu:

4+ Left: Assigns the x-coordinate of the last selected layer to all selected
layers.

4+ Right: Aligns the right side of all selected layers with the right side of
the last selected layer.

4+ Top: Assigns the y-coordinate of the last selected layer to all selected
layers.

4+ Bottom: Aligns the bottom of all selected layers with the bottom of the
last selected layer.

4+ Make Same Width: Gives all the layers the same width as the last
selected layer.

4 Make Same Height: Gives all the layers the same height as the last
selected layer.

Changing the visibility of a layer

You can specify whether a layer is visible or hidden when a Web page

loads — first appears in the user’s browser window — and as a result of spe-
cific actions by the user. Visibility can change as many times as you want.
Visibility options consist of the following:

4 Default: The layer’s initial visibility is the default setting, which is visi-
ble. To edit layer default settings, choose Edit=>Preferences and the
Preferences dialog box (see Figure 5-3) appears, displaying the layer
default settings that you can change.

Preferences %)
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4+ Inherit: For a nested layer, the layer’s initial visibility is the same as the
visibility of its parent. For an unnested layer, selecting the Inherit option
causes the layer to appear as visible.

4+ Visible: The layer’s initial visibility setting is Visible.
4+ Hidden: The layer’s initial visibility is Hidden.

You can use either the Layer Property inspector or the Layers tab of the
Design panel to set layer visibility. By setting layer visibility, you can create
scripts that cause images to appear (or disappear) in response to user inter-
action. For example, you can create an image of a widget that appears on a
Web page after a user clicks a link marked, Click Here to See Our Top-of-the-
Line Widget!

To set the initial visibility of a layer via the Layer Property inspector, select
the layer in the Document window to open the Layer Property inspector.

If the inspector does not appear, open it by choosing Windowr>Properties.
Choose a visibility option from the Vis drop-down list.

Layering layers: Setting the z-index

The z-index of a layer indicates the layer’s position in a stack of multiple
layers. Z-indices are useful when you have a handful of layers — some con-
taining transparent portions, some of different sizes — stacked one on top of
the other. Changing the z-index of your layers lets you “shuffle” the layers —
much as you shuffle a deck of cards — to create interesting visual effects.

Z-indices are measured in whole numbers and do not have to be
consecutive — for instance, you can have three layers with z-indices of 1, 3,
and 7, respectively. The layer with the largest z-index sits on top of the layer
stack and the layer with the smallest z-index sits on the bottom of the layer
stack. Layers with larger z-indices obscure those with smaller z-indices. You
can change the z-index of a layer in either the Layer Property inspector or
the Layers tab of the Design panel.

To assign the z-index of a layer by using the Layer Property inspector, follow
these steps:
1. Select the layer to open the Layer Property inspector.

If the Layer Property inspector does not appear, open it by choosing
Window=Properties.

2. Enter a new number in the Z-Index field of the Layer Property
inspector.
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Changing Layer Properties

To assign the z-index of a layer using the Layers tab of the Design panel,
follow these steps:

1. If the Layers tab of the Design panel is not already visible, choose
Window=>Layers or use the keyboard shortcut F2.

2. Click the Z column for the layer whose z-index you want to change.
The current z-index is selected.

3. Enter a new z-index for the layer.

The new number appears in the Z column for the selected layer, as
shown in Figure 5-4.

4. Click anywhere outside the Z column or press the Enter key.

Note that you can have multiple layers at the same z-index.

Figure 5-4: |~ o ) =
Changing [ Preverk overisps
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To assign relative z-indices to layers by reordering layers in the Layers tab of

the Design panel, follow these steps:

1. Open the Layers tab of the Design panel by choosing Window=>Layers

or by using the keyboard shortcut F2.

The Layers tab lists layers in order of descending z-index. Nested layers
are listed in descending order within their parent layer.

2. Click the name of a layer for which you want to change the z-index.

3. Drag the layer name into a new list position and release the mouse
button.

As you drag, the selected layer is indicated by a thick line.

Figure 5-5 shows the effect of changing a z-index. In the top image, the z-index
of the bowling pins is higher than the starry background image. As a result,

the bowling pins are on top. Conversely, in the bottom image, the starry back-

ground image has the higher z-index value, and as a result, it’s on top of the
bowling pins. Dreamweaver reorders the list in the Layers tab and renumbers
layer z-indices to reflect your change. Also, Dreamweaver updates the associ-
ated code for the layers’ z-indices in the HTML source code for your page.



Figure 5-5:
The effect
of changing
z-indices.

A\
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Because you don’t have to number the z-index of layers consecutively, con-
sider leaving gaps between indices in case you later want to add new layers
into the middle of the stack. For instance, use only even numbers for your
indices so that you can easily sandwich a layer with an odd-numbered z-index
in between.

Moving a layer
You may want to move a layer to another location in the Document window
or to a position relative to the grid or to other objects.

To move a layer, select the layer in the Document window and then reposi-
tion your selection by using one of the following three methods:

4+ Click and drag the layer to a new location and release the mouse button.

4+ Press the arrow keys to nudge the layer up, down, left, or right one pixel
at a time. If you hold down the Shift key, every press of an arrow key
moves the layer by ten pixels.
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A\

4+ In the Layer Property inspector, enter a new value in the T (top) and L
(left) fields to indicate the pixel coordinates of the layer’s top-left corner.

When moving layers, you can choose to enable or prevent layer overlap,
depending on how you want the final image montage to appear. You enable
or prevent layer overlap by selecting or deselecting the Prevent Overlaps
check box in the Layers tab of the Design panel.

Resizing a layer
Resizing a layer means changing its height and width dimensions. To resize a
layer, select the layer and perform one of the following tasks:

4+ C(lick and drag a selection handle — one of the large dots on the layer
boundary — until the layer obtains the dimensions you desire.

4+ In the Layer Property inspector, enter a new width in pixels at the W
field and a new height in pixels at the H field. If the Layer Property
inspector does not appeatr, open it by choosing Window>Properties.

You can change the height and width dimensions of multiple layers at the
same time as follows:

1. Press and hold the Shift key while selecting each layer you want to
resize.

If the Multiple Layers Property inspector does not appear, open it by
choosing Window=Properties.

2. In the Multiple Layers Property inspector, enter a new width in pixels
in the W field and a new height in pixels in the H field.

Nesting Layers

A nested layer is a layer that has all of its HTML code lying within another
layer. The nested layer is often referred to as a child layer, whereas the layer
on which it depends is called the parent layer. A child layer can be drawn com-
pletely inside its parent (as shown in Figure 5-6), in an intersecting arrange-
ment with its parent, or completely unattached to its parent, depending on the
effect you want to achieve. A nested layer inherits the same visibility of its
parent and moves with the parent when the parent layer is repositioned in the
Document window. Some older versions of Netscape have issues with nested
layers, so try to avoid using them if there is a simpler way to accomplish the
same thing.
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Enabling nesting

To create nested layers in the Document window, you must first enable nest-

ing. To do so, follow these steps:

1. Choose Edit~>Preferences to open the Preferences dialog box, or use

the keyboard shortcut Ctrl+U.

. Select the Nesting check box.

. Click OK to close the Preferences dialog box.

U1 = W N

tab of the Design panel.

. In the Preferences dialog box, select Layers in the Category area.

. In the Document window, choose Window=>Layers to open the Layers

6. In the Layers tab, make sure that the Prevent Overlaps option is

deselected.

Creating a new nested layer

Use either of these methods to draw a nested layer after enabling nesting:
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4+ Click inside an existing layer and choose Insert=>Layout Objectst>Layer.
A child layer of default size appears inside the parent layer.

4+ Choose Layout Tools=>Draw Layer in the Layout category of the Insert
bar. Then click and drag your mouse in the parent layer, releasing the
mouse button when the layer has reached the dimensions you desire.

Nesting an existing layer

To change the nesting of an existing layer, follow these steps:
1. Open the Layers tab of the Design panel by choosing Window=>Layers
or using the keyboard shortcut F2.

2. In the Layers tab of the Design panel, press and hold the Ctrl key
while using the mouse to click and drag the intended child layer on
top of its new parent.

The child is in the correct position when you see a box appear around
the name of its intended parent layer.

3. Release the mouse button.
The new child-parent relationship is shown in the Layers tab of the
Design panel.

Dreamweaver draws the new child layer and updates the associated code for
changed layer-nesting in the HTML source code for your page.

Collapsing or expanding your view in the Layers tab

You can change how you view the names of nested layers in the Layers tab
of the Design panel by collapsing or expanding your view:

4+ To collapse your view: Click the minus sign (-) in front of a parent layer.
Names of nested child layers for that parent are hidden.

4+ To expand your view: Click the plus sign (+) in front of a parent layer.
Names of nested child layers appear underneath that parent layer.



Chapter 6: Using ColdFusion

MX 7 Developer Edition in
Dreamweaver 8

In This Chapter

v+~ Exploring how ColdFusion is integrated into Dreamweaver
v~ Using the Tag Editor and the Insert panel

v~ Viewing database connections

v~ Using the Bindings tabs to get dynamic data

v~ Taking a brief look at server behaviors and components

0ne of the biggest changes that came with the advent of Macromedia

Studio was the integration of ColdFusion into Dreamweaver. For years,
the two products had a symbiotic relationship, and as a result, their integra-
tion was an exceptionally smooth one. Dreamweaver was always better than
ColdFusion Studio as a graphical HTML editor. ColdFusion Studio and its
sister product, Macromedia HomeSite, were the better choices for the HTML
editor who preferred a code-friendly interface. This chapter provides the
lowdown on the features in Dreamweaver that bring ColdFusion to life.

< This chapter only covers the ColdFusion features that are available in

Dreamweaver. For a complete rundown of ColdFusion and how it works,

check out Book VIL.

Understanding the Integration of
ColdFusion and Dreamweaver

Previously, Dreamweaver was largely geared toward the basics of HTML
editing, such as creating and editing tables, graphics placement, text editing,
and some basic site management tools. With the integration of ColdFusion,
Dreamweaver became more robust, with a host of features that could make
your site more dynamic.

Before the original Dreamweaver MX arrived, ColdFusion was made up of
three components:
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4+ A Web-based application server that read HTML and ColdFusion code
and generated HTML for a browser to view.

4+ A scripting language that enabled users to perform a number of dynamic
functions, such as querying databases and personalizing Web pages
based on user input.

4+ A stand-alone development tool (ColdFusion Studio) that was used to
create ColdFusion code and manage some parts of the application server.

In Dreamweaver, you can find ColdFusion features in the following areas:

4+ Code view: Select Code view by choosing View=>Code. This is the devel-
opment view that was traditionally associated with ColdFusion Studio.
Figure 6-1 shows both the view from ColdFusion Studio 5 and the Code
view in Dreamweaver 8. You can see that a lot of the physical features
look the same.

4+ Insert bar: If you've used the previous version of Dreamweaver, you'll
notice a major interface change in the Insert function in Dreamweaver 8.
In an old version, there was an Insert panel that utilized tabs to jump
from section to section. In Dreamweaver 8, when you click the name at
the far left on the Insert bar, a listing of all the available sections (what
Macromedia calls “categories™) pops up. Scroll up or down and select a
name to see the buttons in that category of the Insert bar. You find
ColdFusion-specific functions in the Common, CFML, and Application
categories.

4+ Application panel: To bring up the Application panel, choose Window,
and then any of the following: Database, Bindings, Server Behaviors, or
Components. This brings up the Application panel with the appropriate
tab selected. Within the Application panel, you can configure databases,
set up links to your remote site, and create ColdFusion components.

4+ Code panel: The Code panel, not to be confused with Code view, pro-
vides some valuable reference information about your code. (The Code
panel is shown in Figure 6-2.) You can bring up the panel by choosing
either Snippets or Reference from the Window menu:

¢ Snippets tab: With the Snippets tab, you can create reusable chunks
(snippets) of code.

¢ Reference tab: The Reference tab gives you access to O’Reilly’s ref-
erence guides to HTML, JavaScript, and more, as well as guides to
ColdFusion, ASP, and JSP.

In previous versions of Dreamweaver, Code view also included a Tag Inspector,
which reviewed the quality of your HTML code. That function is still there,
though in Dreamweaver 8, this feature has been given its own floating panel.
You can still get to it by choosing Window=>Code Inspector.
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Figure 6-2:
The Code
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Using Features on the Insert Bar

\\3

When you have a ColdFusion page open, the Insert bar gives you access to a
number of ColdFusion features, and using those ColdFusion features is pretty
straightforward. Almost all the features include a Help button to explain to
you precisely what the feature does.

To insert a ColdFusion feature, follow these steps:

1. Select the category in the Insert bar for the element you want to
insert.

You can choose from four ColdFusion categories: Common, CFML
(ColdFusion Markup Language), CFFORM, and Application. The other
categories are for regular Dreamweaver features.

2. Click the icon of the feature you want to insert.

If the feature has parameters that need to be set, a dialog box will appear
that allows you to set all the parameters for the selected feature. Fig-
ure 6-3 shows a dialog box for a Cfquery tag (with Cfquery, you can
retrieve information from a database). For more information on how to
use all these features, check out Book VII.

If you move your mouse over an icon and keep it there, the name of the
feature appears over the icon, allowing you to see what function that
icon serves.

3. Enter all the pertinent information in the dialog box for the element
that you selected in Step 2.

Again, the information you must enter varies, depending on which tags
or elements you selected.

4. Click OK to insert the element.
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In Dreamweaver 8, the ColdFusion commands have been consolidated from
five tabs in the Insert panel to just four categories on the Insert bar. The
Common category includes a Tag Chooser button, from which you can select
ColdFusion CFML tags. Beyond that, all the ColdFusion features are either in
the CFML, CFFORM, or Application categories on the Insert bar.
The CFML category includes access to the largest number of CFML tags and
functions. Note that the last two icons in this category are entitled Flow and
Advanced. This is where buttons from the old CFML Flow and CFML Advanced
tabs landed. If you click these icons, you get pop-up menus, shown in Fig-
ure 6-4, which reveal a number of other functions that you can include in your
documents. Here’s a complete listing of the buttons in the CFML category:
4+ Server variables: Creates server variables
4+ cfquery: Creates a <CFQUERY> tag
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IR IR R R R

cfoutput: Creates a <CFOUTPUT> tag

cfinsert: Creates a <CFINSERT> tag

cfupdate: Creates a <CFUPDATE> tag

cfinclude: Creates a <CFINCLUDE> tag

cflocation: Creates a <CFLOCATION> tag

cfset: Sets the value of a variable

cfparam: Creates a parameter

Comment: Creates the comment arrows

Surround with #: Surrounds the selected text with # signs

cfscript: Creates a <CFSCRIPT> tag into which you can put ColdFusion
Script

Click the Flow icon to access the following features:

TR IR IR SR SRR R IR R R

<+

cftry: Creates a <CFTRY> tag
cfcatch: Creates a <CFCATCH> tag
cfthrow: Creates a <CFTHROW> tag
cflock: Creates a <CFLOCK> tag
cfswitch: Creates a <CFSWITCH> tag
cfcase: Creates a <CFCASE> tag
cfdefaultcase: Creates a <CFDEFAULTCASE> tag
cfif: Creates a <CFIF> tag

cfelse: Creates a <CFELSE> tag
cfelseif: Creates a <CFELSEIF> tag
cfloop: Creates a <CFLOOP> tag

cfbreak: Creates a <CFBREAK> tag

Click the Advanced icon to access the following features:

IR

cfcookie: Enables you to specify the parameters of creating a cookie
cfcontent: Enables you to specify how to create a content tag
cfheader: Enables you to specify the parameters of creating a header
ColdFusion Page Encoding: Sets your page encoding information
cfapplication: Enables you to specify your application parameters

cferror: Specifies error information
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4+ cfdirectory: Allows you to work with directories (create, delete, list, and

so on)
4+ cffile: Enables you to work with files (create, append, write, and so on)
4+ cfmail: Specifies how to send e-mail through ColdFusion
4+ cfpop: Specifies how to send messages through a POP server
4+ cfhttp: Specifies how to make an HTTP request
4+ cfhttpparam: Specifies how to set parameters for an HTTP request
4+ cfldap: Specifies how you can access an LDAP store
4+ cfftp: Specifies how to make an FTP request Book II
4+ cfsearch: Builds an interface to Verity to make searches Chapter &
4+ cfindex: Builds an interface to index a Verity search collection =5
4+ cfimport: Allows you to import a custom CF tag library or a JSP tag library Ly ]
4+ cfmodule: Allows you to specify a module g g g
4+ cfobject: Enables you to call a component = '§ §.
4+ cfchart: Specifies how to use ColdFusion’s charting features o=
4 More Tags: Brings up the Tag Chooser dialog box

Figure 6-5 shows the Application category of the Insert bar in Dreamweaver,
which allows you to access the following ColdFusion features:

4+ Recordset: Allows you to connect to and retrieve data from a database
and creates the <CFQUERY> tag for you

4+ Stored Procedure: Allows you to execute a stored procedure against an
SQL database and specify parameters to be passed as part of that call

Figure 6-5:
Getting at
the application [ @ | 4. - [ B | & B0 - G-y | @
Application

features.

4+ Dynamic Data: Creates either dynamic text or a table, or populates vari-
ous form elements with data from a database

4+ Repeated Region: Enables you to create a repeated region

4+ Show Region: Enables you to show or not show a specific area of con-
tent based on a set of criteria
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4+ Recordset Paging: Creates dynamic page-scrolling arrows for a recordset
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<+

Display Record Count: Shows how many records you have from a given
query — first, last, and total number

Master Detail Page Set: Creates a master detail page

Insert Record: Creates a form to insert a database record
Update Record: Creates a form to update a database record
Delete Record: Creates a form to delete a database record

User Authentication: Provides a series of tools to log a user in or out, or
to restrict access to a page

XSL Transformation: Allows you to lay out an XML document using the
XSLT scripting language

In addition to these three categories of the Insert bar, you can also access
the CFFORM category. Here, you can insert all of the CFFORM elements and
specify the parameters for each. For more information on how CFFORM
works, check out Book VII Chapter 7.

Editing a Tag

After you've inserted a tag into your ColdFusion code, you may need to edit
that tag later. You can edit the code directly or you can use the Tag Editor,
which provides a cleaner way to see all the parameters for your tag. (Note:
Not all tags have this option; if you don’t see Edit Tag in Step 3, then you
know the tag you're working with doesn’t support this feature.) To use the
Tag Editor, follow these steps:

1.

If necessary, switch to the Code view in the Document window by
choosing View=>Code.

2. Place your cursor anywhere in the opening tag you want to edit.

. Right-click and choose Edit Tag from the context menu.

The Edit Tag dialog box appears.

. Change the value in the dialog box and then click OK to update the tag.

The value changes, depending on which tag you're editing.

Getting Data from a Database

You can set up a database connection using the ColdFusion Administrator,
as described in Book VII, Chapter 6. Using the Dreamweaver interface, how-
ever, when you're in Code view, you can look directly into a database to see
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The artists
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the tables and columns that make up a database. More importantly, you can
then easily add those tables and columns to your ColdFusion code simply by
dragging them onto the screen. Here’s how:

1. Open the Application panel to the Databases tab by choosing

Windowr>Database.

You see a list of the databases on your testing server. For this example,
we use the cfcodeexplorer database, one of the sample databases that
comes with ColdFusion.

2. Click the plus (+) button next to the cfcodeexplorer database.

This shows you the views, tables, and stored procedures for the database.

3. Expand the artists table by clicking the plus (+) buttons next to the
first Tables and then the artists table.

All the columns in the table should now be visible, as shown in Figure 6-6.
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4. Click and drag the LastName column from the panel onto the work

area.

You see that this adds the column name to the work area.
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Figure 6-7:
Getting
names from
a database.

For the feature described in the previous steps to work, you need to have
an active testing server configured and you need to know the Remote Data
Services password for your testing server. Check out Book VII, Chapter 2 for
more information.

Now, by itself, this doesn’t really accomplish a whole lot. All you’ve really
done is drag a column name onto your work area. To really see this feature
in action, try adding the following code to your page, in between the <BODY>
tags:

<CFQUERY name="DatabaseTest" datasource="cfcodeexplorer">
select LastName from artists
</CFQUERY>

<CFOUTPUT query="DatabaseTest">
#lastname#<BR>
</CFOUTPUT>

Now, press the F12 key to preview the page in a Web browser and you see a
whole list of names, as shown in Figure 6-7. If you'd like, try adding some other
fields in the code between select and from, making sure that the fields are
all separated by commas. If you then add the field name to CFOUTPUT, sur-
rounded by pound signs (#), you see those fields displayed as well. For more
information on accessing data from a database using ColdFusion, check out
Book VII, Chapter 6.
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Figure 6-8:
The

Recordset
dialog box.
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The Bindings tab of the Application panel provides another interface to data
sources; for someone unaccustomed to working with ColdFusion, it is an easy
way to begin to understand CFML. Binding, in the Dreamweaver vernacular,
is just a link between the page and some other datasource that provides data
to the page. With this interface, you can build the same query we used in the
example in the previous section as follows:

1. Press Ctrl+N; in the New Page dialog box that appears, select Dynamic
Page and ColdFusion, and then click the Create button.

This creates a new ColdFusion document.

2. Save the document into a site that has a remote server configured to
see the sample ColdFusion databases.

3. Switch to the Bindings tab by choosing Window=>Bindings.

4. Click the plus (+) button and select Recordset (Query) from the drop-
down list.

The Recordset dialog box, shown in Figure 6-8, appears.

Recordset

Mame:

Data source:
User name:
Password:
Table:

Columns: (%)

Filter:

Sort:

Recordseti]

None

All

MNone

MNone

() Selected:
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5. Type a name, such as DatabaseTest, into the Name field.

6. Select cfcodeexplorer from the Data Source drop-down list.

You may also need to input the username and password for the testing
server. If you configured the remote testing server, you should know the
username and password. If not, you may need to check with your organi-
zation’s database administrator.
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7. Select the artists table from the Table drop-down list.

8. Select the radio button labeled Selected from the Columns option and

10.

11.

12.

choose LastName from the scroll list (it will show up when you select
the radio button).

. Leave the Filter and Sort fields set to None.

These two tools, which you should try as you get more comfortable with
using the Bindings tab, allow you to further refine and sort the data from
the artists table.

Click OK to add the Binding.

Dreamweaver adds a new record in the Bindings tab and the following
code to the Code view:

<CFQUERY name="DatabaseTest"

datasource="cfcodeexplorer">
SELECT LastName FROM artists
</CFQUERY>

This code tells the server to get all the last names from the artists table
in the cfcodeexplorer database. When the page is read, this query
retrieves the data and makes it available to be output.

To make the last names output when the page is loaded, click and
drag the LastName lightning bolt icon from the Bindings tab on the
Application panel to the Document window.

Dreamweaver creates the following code and adds it to your workspace:

<CFOUTPUT query="DatabaseTest">
#DatabaseTest .LastName#
</CFOUTPUT>

This tells ColdFusion to display the LastNames (all of them) when the
page is loaded.

Press F12 to preview the page.

When the page loads, you'll notice that the names are output one right
after another without anything in between them. You can add a line
break (<BR>) or a comma after #DatabaseTest . LastName#, and
ColdFusion will add the comma or line break after every record.

Queries are only one kind of Binding that Dreamweaver supports. You can
see all the others when you click the plus (+) button on the Bindings tab.

As you become more familiar with ColdFusion, you’ll no doubt want to use
some of these other kinds of Bindings, notably the Stored Procedure and the
Form, Session, Client, and Application variables.
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Introducing Server Behaviors and Components

The Server Behavior and Components tabs in the Application panel are
similar in both design and concept to the Bindings panel. The following sec-
tions cover them only cursorily, because to use these tools to their fullest
extent, you need an advanced working knowledge of ColdFusion and code
development.

Understanding server behaviors

Server behaviors are code elements that make a request to the ColdFusion
Server and receive some sort of data in return. If that sounds similar to the Book Il
preceding Bindings example, it is! You can do that Recordset example from
the earlier section, “Using the Bindings Tab,” from the Server Behaviors tab.
However, a number of more advanced server behaviors are beyond simple
queries that you can do from this tab. Table 6-1 describes each of the server
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Table 6-1 Server Behaviors s
==
Name Function
Recordset Makes a query to a data source
Stored Procedure Passes information to a Stored Procedure
CFParam Builds a <CFPARAM> tag
Repeat Region Allows you to create a repeated region
Recordset Paging Creates forward, backward, first, and last links for a
recordset
Show Region Shows a region of content based on preset conditions
Display Record Count Displays the record count for a recordset
Dynamic Text Displays dynamic text based on a query
Insert Record Inserts a record through a form
Update Record Updates a record through a form
Delete Record Deletes a record through a form
Dynamic Form Elements Creates form elements based on a corresponding query
and recordset
User Authentication Creates all the code necessary to add user authentication
to a site

Considering components

Components are reusable bits of ColdFusion code that can be used through-
out your Dreamweaver Site. Dreamweaver comes with a number of sample
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components to show you how they work. In practical terms, though, you
create your own components based on the needs of your Site.

Suppose that you're building a site that sells boxes online and you have a tool
that calculates the volume of the various types of boxes that you sell. Because
it’s used globally by the site, this tool shouldn’t be repeated in every single
ColdFusion page. Instead, it should be in an area where all pages can access
it and just pass along the value obtained by performing a calculation. If you
built it as a component, this calculator could be accessed anywhere. If there
are ever any changes to the tool (say you changed from cubic feet to cubic
meters), you'd only need to make the change once, instead of many times.

The Components tab provides developers with a framework for building
these kinds of tools. From this tab, you can specify the following for a new
component:

4 General information about the component (such as its name and where
it’s located)

4+ Properties of the component (queries, arrays, strings, and so on)

4+ The functions associated with the component

4+ The arguments (data) the component will accept from another page
or form



Chapter 7: Advanced Web
Page Design Techniques

In This Chapter

v Creating hotspots

1 Adding Flash text and button rollovers

v~ Adding a rollover behavior to an image
»” Creating a navigation bar

v+~ Inserting audio and video into your pages
+~ Using templates

v Validating your code

In previous chapters of Book II, we focus on providing a good working
knowledge of Dreamweaver 8. Now we need to spend some time looking
at the more advanced uses of Dreamweaver in Web development. In this
chapter, we show you how to make images a bit more striking and how you
can bring some other multimedia elements to life.

Creating Clickable Image Maps with Hotspots

You can designate certain areas of an image as hotspots — active areas that
a user can click to open a link to another Web page or activate some other
behavior. Hotspots can be shaped like rectangles, circles, or polygons (irreg-
ular objects). The coordinates of the hotspots are grouped into chunks of
HTML code called image maps.

Creating a hotspot

Check out Figure 7-1. It shows a typical navigation bar for a site as a single
JPEG image. The following procedure shows you how to create an image
map for part of that image by adding hotspots:

1. Select the image to which you want to add a hotspot.

The Image Property inspector appears. If the bottom half of the Image
Property inspector is not visible, click the Expander button, which is
the down arrow in the bottom-right corner.
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Figure 7-1:
A typical
JPEG
navigation
image.

2. In the Map area of the Image Property inspector, click the Hotspot
button for the shape you want to draw.

You can choose a rectangle, a circle, or a polygon. Your mouse pointer
becomes a cross hair cursor when you move it over the image.

3. Draw the hotspot according to the shape you select:

¢ Circle or rectangle: Click your cross hair cursor on the image and
drag diagonally to create a hotspot. Release the mouse button when
the hotspot reaches your desired dimensions. The area you draw is
highlighted light blue, and the Hotspot Property inspector appears.

¢ Polygon: Click your cross hair cursor on the image once for each
point. The area you draw is highlighted light blue and the Hotspot
Property inspector appears.

4. In the Hotspot Property inspector, supply the following information:
e Map: Enter a unique name for the image map.

e Link: Enter a URL or the name of an HTML file you want to open
when the user clicks the hotspot. Alternatively, you can click the
folder icon and browse to select the link from your files. Note:
Completing this field is optional. Instead, you may choose to attach a
behavior to the hotspot.

¢ Behaviors: To attach a behavior other than a link to the hotspot, open
the Behaviors tab of the Tag panel by choosing Windowr>Behaviors
or by using the keyboard shortcut Shift+F3. Then click the Add (+)
button in the Behaviors panel, which opens a pop-up menu of avail-
able behaviors, including Check Plugin, Play Sound, Popup Message,
Preload Images, and many others. Choose a behavior from the pop-up
menu, complete the information in the dialog box that appears for
your selected behavior, and click OK.

¢ Target: Complete this field if you entered a link in the Link field and
you want the link to open in a window or frame other than the one
you're linking from. Click the arrow and select from the drop-down
list a target window where you want your selected link to appear. You
can select from the following choices: _blank (opens the link in a
new window), _parent (opens the link in the parent of the currently
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opened window; if the currently opened window was opened from
another frame, the link will open in that frame), _self (the default;
opens the link in the currently opened window; not selecting a Target
produces the same effect), and _top (opens the link in the top-level
window, replacing frames, if any). If you have created frames, you
can also select a frame name from this list. (See Book I, Chapter 4 for
more information about frames.)

e Alt: Enter the text you want to show when the user moves the mouse
pointer over the hotspot. Alt text also makes information about the
hotspot accessible to vision-impaired users.

«p e Book Il
Modifying a hotspot Chapter 7
If you need to change the size or shape of a hotspot after you've created it,
or you need to change the link, target, or Alt information for the hotspot, use
the following procedure to edit the hotspot:

1. On an image in the Document window, click the hotspot you want to
modify.

The Hotspot Property inspector appears. If the inspector does not
appear, open it by choosing Window=>Properties.
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2. Edit the Link, Target, or Alt information you want to change in the
Hotspot Property inspector.

3. If you want to reshape or resize the hotspot, select the Arrow tool in
the Hotspot Property inspector and then click any handle of the
selected hotspot and drag the handle to a new location.

4. If you want to reposition the hotspot, select the Arrow tool in the
Hotspot Property inspector, click anywhere within the hotspot, and
drag it to a new location.

5. You can delete a hotspot by selecting it and pressing the Delete key on
your keyboard.

Adding Flash Text Rollovers

A text rollover is text that changes color when users move their mouse pointer
over it. (One color appears to “roll over” to the next color.) One way to
create text rollovers in Dreamweaver is by adding Flash text to your pages,
as described in the following section.

Flash text and Flash buttons are so named because Dreamweaver implements
these features using the same code that Macromedia Flash 8 (the animation
program included in the Macromedia Studio 8 suite) uses.
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Figure 7-2:
Choose how
you want
the text to
appear in
the Insert
Flash Text
dialog box.

Adding Flash text

To add hyperlinked Flash text that changes color when users roll their
mouse over it, follow these steps:

1. Click in the Document window where you want to add Flash text.

2. Choose Insert=>Media~>Flash Text.

Your page must be saved before you can insert Flash text. If the page
hasn’t been saved at least once, an alert pops up to remind you to save
the page so you can insert the Flash text.

3. In the Insert Flash Text dialog box, shown in Figure 7-2, select a font
from the Font drop-down list.

Insert Flash Text %]
r oK
Fork: | Arial w|  siet|30 )
BIEE= [_eonty |
| Cancel |
coke: M| 000000 Rolover color: || #CCeE99
| Help

e | | WANT dynamic text

[¥] show Fonit
e -
Target: E
By color: u
Save as: | textl,swf @

4. Enter a point size for your text in the Size text field.
5. If you want, you can also format the text.

You can click the Bold button and/or Italics button. You can also click an
alignment button. Alignment choices are Left, Center, and Right.

6. Select a Color (the initial color) and a Rollover Color (the color the
text changes to when users move their mouse pointer over it) by click-
ing the color swatch in each area and selecting a color from the color
palette that appears.
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7.

8.

10.

11.
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Enter your text in the Text field. Select the Show Font option if you
want to view the characters in the Text field in your selected font.

In the Link field, enter a URL or the name of the page you want to
appear when the user clicks the Flash text.

Alternatively, you can click the Browse button to select a page from your
files.

. In the Target area, click the arrow and select from the drop-down list

a target window where the linked page will appear.

If you have created frames, you can select a frame name from this list, or
you can select from the following choices:

e _blank: Opens the link in a new window.

e _parent: Opens the link in the parent of the currently opened
window.

e _self: Opens the link in the currently opened window; this is the
default. Leaving the Target area empty produces the same result.

e _top: Opens the link in the top-level window, replacing any existing
frames.

Select a Background color by clicking the Bg Color swatch and select-
ing a color from the color palette that appears, or type in a hexadeci-
mal number.

Your Flash text appears over the background color you choose.

Enter a name for your Flash text component in the Save As field or
click the Browse button to select a name from your files.

You must save Flash text with an . swf extension.

12. Click OK to create your Flash text and close the dialog box.

To preview the rollover effect of your Flash text, select the Flash object in

the Document window to open the Flash Text Property inspector. In the
Property inspector, click the Play button to view your Flash text as it will
appear in the browser window. Click the Stop button when you’re done.

Changing Flash text

You can change an existing Flash text object by simply double-clicking the
object in the Document window or by clicking the object and then clicking
the Edit button in the Property inspector. Doing so opens the Insert Flash
Text dialog box, where you can change various attributes of the object as we
describe in the previous section.

Book Il
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Adding Flash Button Rollovers

Figure 7-3:
Add an
interactive
button with
the Insert
Flash Button
dialog box.

Buttons that change appearance when users move their mouse pointer over
them — called button rollovers — are so popular that Dreamweaver gives you
a way to create them quickly and easily as Flash movies. To find out how to
create button rollovers using images and behaviors instead of Flash button
rollovers, see the “Inserting Image Rollovers” section, later in this chapter.
(Book III, Chapter 5 describes how to make rollovers in Fireworks 8 using
images and behaviors.)

Adding a Flash button

To add a Flash button, follow these steps:

1. Click in the Document window where you want to add a Flash button.

2. Choose Insert>Media=>Flash Button to open the Insert Flash Button
dialog box, as shown in Figure 7-3.

Your page must be saved before you can insert a Flash button. If the
page hasn’t been saved at least once, an alert pops up to remind you to
save the page so you can insert the Flash button.
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3. In the Insert Flash Button dialog box, scroll through the button selec-
tions in the Style list and click to select a style.

You can preview the style in the Sample area of the dialog box — just
point to the sample with your mouse to see the Flash button in action.



a\\J

Adding Flash Button Rollovers ’43

You can get new Flash buttons on the Macromedia Dreamweaver 8 Web
site by clicking the Get More Styles button in the Insert Flash Button
dialog box. A Web page on Macromedia’s site opens in your browser.
Select the Flash Media option from the Categories drop-down list and
scroll through the results as needed.

. If your selected button has a placeholder for text, enter the text that

you want to appear on the button in the Button Text field.

Text centers within the button automatically. Button size is fixed, though,
so you must make sure your text is brief enough to fit on the button.

5. Select a font for your Flash button text from the Font drop-down list.

6. Enter a point size for your text in the Size field.

7. In the Link field, enter a URL or the name of the page that you want to

10.

11.

appear when the user clicks the Flash button.

Alternatively, you can click the Browse button to select a page from your
files.

. From the Target drop-down list, select a target window where the

linked page will appear.

If you have created frames, you can select a frame name from this list, or
you can select from the following choices:

e _blank: Opens the link in a new window.

e _parent: Opens the link in the parent of the currently opened
window.

e _self: Opens the link in the currently opened window; this is the
default. Leaving the Target area empty produces the same result.

e _top: Opens the link in the top-level window, replacing any existing
frames.

. Select a Background color by clicking the Bg Color swatch and select-

ing a color from the color palette that appears.

Alternatively, you can enter a hexadecimal color code in the Bg Color
field.

Your Flash button displays with the background color you select.

Enter a name for your Flash button in the Save As field or click the
Browse button to select a name from your files.

The Flash button filename requires an . swf extension. Dreamweaver
will add the extension automatically if you don’t enter it.

Click OK to create your Flash button and close the dialog box.
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To see what a Flash button looks like in action, select the button in the
Document window to open the Flash Button Property inspector. In the
Property inspector, click the Play button to view your Flash button as it
appears in the browser window. Click the Stop button when you finish.

Changing a Flash button

To change an existing Flash button object, simply double-click the object in
the Document window, or click the object and then click the Edit button in
the Property inspector. Doing so opens the Insert Flash Button dialog box,
where you can change your button as we describe in the previous section.

Inserting Image Rollovers

WMBER
Q‘Q’
&

An image rollover (often just referred to as a rollover) is a behavior that
changes an image whenever users move their mouse pointer over the image.
Rollovers add interactivity to a Web page by helping users to see what parts
of the page are links to other Web pages.

A rollover is actually two images — one for normal display on a page (the
original image) and one that is slightly modified for display when the image
is rolled over (the rollover image). You can modify an image by changing the
color or position, adding a glow or a shadow, or adding another graphic —
such as a dog changing from sleeping to wide-awake. For a rollover to work
best, the normal and rollover states of the image should share the same
width and height.

As with all images, you can’t create the original image or the rollover image
directly in Dreamweaver; you must use an image-editing program, such as
Fireworks, to generate the images.

Insert a rollover by following these steps:
1. Click inside the Document window where you want to insert the

image rollover.

2. On the Common category of the Insert bar, click and hold the Image
button and select Rollover Image from the pop-up menu.

The Insert Rollover Image dialog box appears, as shown in Figure 7-4.
Alternatively, you can choose InsertbImage Objects>Rollover Image.

3. In the Insert Rollover Image dialog box, enter a unique name for the
rollover in the Image Name field, making sure there are no spaces in
the name.
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[ Insert Rollover Image @_
Image name: | back | & |
— Crignal image: | .. fimages/back-btn, gf | Browsa, | | Cancel |
Figure 7-4: Rollover image: | .. fimages/back-bir-r.gif | Browse... | L e J
Creating an [ Preoad roliover Image
. Akernate bext: | Back
Image When clicked, Go to URL: | start. hitml [Erowse... |
rollover. —
\‘&N\BER
& The rollover is referred to by this name in the HTML page code. Keep
in mind that this rollover name refers to the combined original image/
rollover image pair.
. Enter the name of the original image file in the Original Image field,
or click the Browse button to select an image from your files.
The original image appears on the page when the user’s mouse pointer
is not over the image.
. Enter the name of the rollover image file in the Rollover Image field,
or click the Browse button to select an image from your files.
The rollover image appears on the page when the user’s mouse pointer
is over the image.
. Select the Preload Rollover Image check box.
This feature makes the rollover action appear without delay to users as
they move the mouse pointer over the original image. It is selected by
default.
. Enter alternate text for the image to make it accessible to vision-
impaired visitors to your site.
This step is optional but recommended.
. If you want to make the rollover image a link, enter a URL of the page
in the When Clicked, Go to URL text field.
Alternatively, you can click the Browse button to select a page from your
files.
9. Click OK to accept your choices and close the dialog box.
P To check the rollover, preview your page in a browser by choosing Filew>

Preview in Browser or by clicking the Preview in Browser button, and then
use your mouse to point to the original image. You can also press F12 to pre-
view the rollover in the default preview browser. If you haven’t set a default
preview browser, you will have to do so using the Preview in Browser cate-
gory in Dreamweaver’s Preferences dialog box. See Dreamweaver’s help doc-
umentation for details.
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Setting Up a Navigation Bar

Figure 7-5:
From the
Insert
Navigation
Bar dialog
box, you
can create
an entire
navigation
bar.

A navigation bar is a group of buttons that users can access to move through-
out your Web site. Buttons within a navigation bar may present users with
options, such as moving backwards, moving forwards, returning to the home
page, or jumping to specific pages within the site.

Each button in a navigation bar possesses properties similar to a rollover in
that the button changes state — or appears differently — based on where the
user is positioning the mouse pointer. However, a navigation bar button can
possess as many as four different states:

4+ Up: The original state of the button

4+ Over: How the button appears when a user moves their mouse pointer
over it

+

Down: How the button appears as a user is clicking it

4 Over While Down: How the button appears when the user moves
their mouse pointer over it after clicking it and arriving on the page it
represents

A navigation bar differs from individual rollovers in that clicking a navigation
bar button in the Down state causes all other buttons in the bar to revert to
the Up state.

To create a navigation bar, just follow these steps:

1. Select the Navigation Bar button from the Common category of the
Insert bar or choose Insert=>Image Objects=>Navigation Bar.

Whichever method you choose, the Insert Navigation Bar dialog box
appears, as shown in Figure 7-5.
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. In the Insert Navigation Bar dialog box, enter a name for the first

button in the Element Name field.

The new button appears in the Nav Bar Elements field. Don’t use spaces
in the names of any of these elements.

. For each state of the button — Up Image, Over Image, Down Image,

and Over While Down Image — enter the name of the image file that
you want to use in the associated field.

Alternatively, you can click the Browse button for each field and select
an image from your files. You must supply the Up Image. All other states
are optional and can be left blank.

You don’t need to use all four navigation bar button states — creating
only Up and Down states works just fine.

. Enter alternate text for the image to make it accessible to vision-

impaired visitors to your site.

This step is optional but recommended.

. In the When Clicked, Go to URL text field, enter a URL or the name for

the page you want to appear when the user clicks the navigation bar
button.

Alternatively, you can click the Browse button to select a page from your
files.

. From the In drop-down list, select a target window where you want

the linked page to appear.

If you aren’t using frames, the only option is to use the Main window.

. Click the Add Item (+) button to add another navigation bar button.

Repeat Steps 2 through 6 to format the new button.

Note: You can remove any button already created by clicking its name in
the Nav Bar Elements field and clicking the Remove Item (-) button. You
can also reorder the sequence of the buttons as they will appear on the
page by clicking a button name in the Nav Bar Elements field and click-
ing the up or down arrow button.

. In the Options area, select the Preload Images check box if you want

the rollover effects to appear without delay when the user triggers
them.

. To set the current button to appear in the Down state when the user

first sees the navigation bar (which you might do to indicate that the
current page is the one represented by the button), select the Show
“Down Image” Initially check box in the Options area.

The Over While Down state works in combination with this option.
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10. Select Horizontally or Vertically from the Insert drop-down list to
position the navigation bar horizontally or vertically.

11. To set up the button images in a table format, select the Use Tables
check box.

This option is checked by default.
12. Click OK to accept your choices and close the dialog box.

To check the navigation bar, you must preview your page in a browser.
Choose Filem>Preview in Browser or click the Preview in Browser button and
use your mouse to point to the buttons.

<® To change elements of an existing navigation bar, choose Modify=>Navigation
Bar. The Modify Navigation Bar dialog box is nearly identical to the Insert
Navigation Bar dialog box shown in Figure 7-5, except that you can no longer
change the orientation of the bar or access the Use Tables check box.

Adding Audio and Uideo to Your Pages

You have two basic options, which are described in detail in the following
sections, for adding downloadable audio and video to your Web pages:

4+ Embedding: You can embed an audio or video file to display a playback
console on a Web page that users can use to play, rewind, and fast-forward
the media file. (You can also embed an audio file and make it invisible to
create a background audio effect.)

&,N\BEH Users must have an appropriate plug-in installed on their machines to
> play the embedded audio or video file. To ensure maximum compatibil-
ity, you may wish to use SWFs (check out Book V for more on SWFs) to
present audio and video.

4+ Linking: You can link to an audio or video file to give users the choice of
whether or not to view that media file.

vq‘\\\"‘G! Keep in mind that most audio and video files are large — large enough that
many folks impatiently click the Stop button on their browsers before a Web
page chock-full of audio or video effects has a chance to finish loading. Keep
the following basic rules in mind to help you use audio and video effectively
in your Web pages:

4+ Use audio and video only when plain text just won’t do.

4+ Keep your audio and video clips as short (and corresponding file sizes
as small) as possible.



Figure 7-6:
Selecta
media file
to import.
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Embedding an audio or video clip

You can embed an audio or video file by following these steps:

1.

2.

In the Document window, click the location in your page where you
want to add an embedded audio or video file.

Click and hold the Media button in the Common category of the Insert
bar and select Plugin from the pop-up menu, or choose Insert->Media=>
Plugin.

The Select File dialog box shown in Figure 7-6 appears.

URL

Select File (2]
Sedect fie name from: (%) File spsten Sites and Seavers... |

Loakin | 3 medis Y0 @ @
4] vete = lant i e 00|

File name: svelle - 1 want iy mumeny mp3

Files of type! | 201 Files (7] v Cancel |

Relativeto: | Document | indesx himl

() Data soueces

i

mediadsvale - | weant my rummy,mp3 Parameters. .

\\3

3.

In the File Name field in the Select File dialog box, enter the path or
browse to the audio or video file that you want to embed, and click OK.

If the file is outside your current root directory, Dreamweaver asks
whether you want to copy the file to your site’s root directory. Click Yes.

. In the Plugin Property inspector, size the Plugin placeholder to any

dimensions you prefer.

You can either enter a width and height in the W and H text fields in the
Plugin Property inspector, or you can drag a handle on the placeholder
to manually resize.

Test in all your target browsers (the browsers your users are likely to
view your site with) to ensure that users can view all the audio playback
controls or video area and controls.

You can click the Play button in the Plugin Property inspector to play your
media file without previewing your page in a browser.
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150 Adding Audio and Uideo to Your Pages

Embedding background music

Embedding background music (music that plays automatically after the
user opens a page) in your page can be controversial because users may
be unpleasantly surprised by audio when they are expecting silence, and

because users have no way to turn off the music from within the browser. If
you still want to embed background music in your page, follow these steps:

1.

In the Document window, click the location in your page where you
want to add an embedded audio file.

This should be an out-of-the-way location, like the bottom of your page,
so the embedded audio doesn’t create an awkward space in your design.

. Click and hold the Media button in the Common category of the Insert

bar and select Plugin from the pop-up menu, or choose Insert->Media~>
Plugin.

The Select File dialog box appears.

. In the File Name field in the Select File dialog box, enter the path to

the audio file that you want to embed, and click OK.

If the file is outside your current root directory, Dreamweaver asks
whether you want to copy the file to your site’s root directory. Click Yes.

. Enter a width and height of 2 in the W and H text fields in the Plugin

Property inspector.

5. Click the Parameters button to open the Parameters dialog box.

6. In the Parameters dialog box, click the Add (+) button to add a new

parameter.

7. Click in the Parameter column and type hidden.

8. Type true in the Value column.

Steps 7 and 8 hide the audio playback controls.

. Click OK to complete the process and close the dialog box.

Linking to an audio or video clip

A simple and relatively trouble-free way to include audio and video clips on a
Web page is to link the page to an audio or video file. Users can click the link
if they want to hear or watch the clip. This selection opens a player outside
the browser where the user can control playback.

You follow the same steps to create a link to an audio or video file that resides
in your root folder as you do to create a link to a Web page (see Book II,
Chapter 2); the only difference is that you specify a media file instead of a
URL for the link.
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Adding Other Media

Figure 7-7:
Your
embedded
media
options.

Dreamweaver enables you to easily insert a number of other multimedia for-
mats into your Web pages, including ActiveX, Java Applets, Macromedia
Flash, and Shockwave. After inserting any of these media formats, you can
set the control and playback features of the media in the Parameters dialog
box. Additionally, you can fine-tune the media action on your page by using
the Behaviors panel to create triggering actions that cause the media to play,
stop, and execute other functions.

Follow these directions to insert other media:
1. In the Document window, click the location in your page where you

want to add a multimedia file.

2. Click and hold the Media button in the Common category of the
Insert bar to view all the object types that you can insert, as shown
in Figure 7-7, and click the icon of the type of media file you want
to insert.

Alternatively, you can choose Insert>Media=>Media Type, where Media
Type is the type of media file you want to insert.

The Select File dialog box appears.
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’5 2 Using Dreamweaver 8 Templates

¢ For Applet, Macromedia Flash, and Shockwave files: In the File

Name field in the Select File dialog box, enter the path to the media
and click OK. Your file is inserted and the associated Property inspec-
tor appears. You can change the selected file in the Plugin Property
inspector by typing a new name in the File text field or by browsing
in the File folder to select a file (for Applets, use the Code text field).
Select the Embed check box if you want Netscape Navigator users to
have access to the Applet.

e For ActiveX: An ActiveX placeholder is inserted and the ActiveX
Property inspector appears. Enter the name of the ActiveX object
you want to play in the Class ID text field. Select the Embed check
box if you want Netscape Navigator users to have access to the
ActiveX object.

3. In the Property inspector for your selected media, enter dimensions
in the W and H text fields to size the Media placeholder to any dimen-
sions you choose.

4. In the Property inspector for your selected media, click the Parameters
button to open the Parameters dialog box, where you can add parame-
ters (like width, height, loop, and autoplay) appropriate to the selected
media type.

Using Dreamweaver 8 Templates

Dreamweaver comes with many built-in layouts that you can use to create
pages or Dreamweaver templates quickly. The layouts are predesigned pages
with placeholder content. Make a new page from a layout, replace the place-
holder content with real content, and voila — a professionally designed page!

To create a new page based on a built-in layout, just follow these steps:

1. Choose File=>New.
The New Document dialog box appears.
2. Select Page Designs in the Category list on the left.

The Page Designs appear in the middle column. Click any one to see a
preview in the Preview area, as shown in Figure 7-8.

3. When you’ve found the layout you want, select the Document option
in the lower-right corner and click the Create button.

An untitled HTML page opens in the Document window with placeholder
content that you can replace with real content.

If you wanted to create your own template based on the built-in layout,
you could select the Template option in the lower-right corner of the
New Document dialog box.



Figure 7-8:
The
Commerce:
Product
Details
layout is
selected.
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You don’t have to use a built-in layout to create a Dreamweaver template:
You can make a Dreamweaver template based on any Web page. One cool
thing about Dreamweaver templates is that if you make a whole bunch of
pages based on a template, you can change the template, and all the pages
based on it will be updated to match the template automatically. Another
cool thing is that you can make a template that other people can use in com-
bination with either Dreamweaver or Contribute to create new pages that
conform to the template’s design.

To create a Dreamweaver template based on an existing HTML page, just
follow these steps:
1. Choose File=>New.
The New Document dialog box appears, with the General tab selected.

2. Select Basic Page from the Category list on the left and then select
HTML Template from the list of Basic Pages that appears in the middle.

You can also select Template Page from the Category list and choose
HTML Template from the Template Page list that appears in the middle.

3. Create your page layout.

By default, nothing in the design of pages based on your template is
editable. You must create editable regions in order to make a useful
template.
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15 4 Using Dreamweaver 8 Templates

4. Click a table cell or other part of your layout that you want users to be

able to fill with content, and choose Insert~>Template Objects=>Editable
Region, or use the keyboard shortcut Ctrl+Alt+V.

The New Editable Region dialog box appears. If you have a placeholder
image already in the layout, you can right-click the image and choose
Templatesw>New Editable Region from the context menu that pops up, or
you can select the image and use the keyboard shortcut Ctrl+Alt+V.

5. Name the region and click OK.

You can use the default name Dreamweaver gives to the region, but it’s
better if you name the region to reflect the content that will go into it
(for example, name the region Product Description). Figure 7-9 shows a
template with three editable regions. Editable regions are bound by a
light blue box with the region name at the top left.
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6. Repeat Steps 4 and 5 until you have made editable regions out of all

the areas of the page that you want to be editable in new pages based
on the template.

Anything inside an editable region can be replaced in a page based on
the template; anything outside the editable regions is locked and can’t
be changed in pages based on the template.

7. Choose File>Save.

The Save As Template dialog box appears.

8. Choose the site the template belongs to from the drop-down list, enter a

name for the template in the Save As field, and click the Save button.



Figure 7-10:
Creating a
new page
based on a
template.
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The template will now be available to anyone who has access to the
Dreamweaver site, either through Dreamweaver or with Contribute.

You may turn any existing page into a template. Choose Filer>Save as
Template when the page is open. If you try to close the template without
having created editable regions (as described in the previous steps),
Dreamweaver gives you a warning message saying that the template does
not contain any editable regions. Click OK to close the warning dialog box,
create the editable regions in your template, and choose Filer>Save to save
your template.

To create an HTML page based on an existing user-created template, follow
these steps:

1. Click the Templates icon in the Assets tab of the File panel. All avail-
able templates for the selected site appear.

If the Files panel is closed, choose Windowr>Assets or use the keyboard
shortcut F11.

2. Right-click the template you want to create the new page from and
choose New from Template, as shown in Figure 7-10.

The page opens as an HTML page in the Document window.

Commands  Site  Window Halp

B R

B o v

& DREAMWEAVER'

Heatine: [ Siew [ Full Patty

Refiesh Site List
Recreare she llst

Create Hew
@ HTvL

@ ColdFusian
« PHP

Eué¢pgesak

Create from Samples
£ CBE Shie Sheets
) Framesats
i Paga Designs (S58)

Open a Recant tem
! Bluin®iembed g
@ Studiodllis2.cmm
& Blugiogiist oin

New Tamplate
R G

Apply @ ntitadFramasatd | atm) @ A5 vBEpt L Stanar Pages
: @ Sludiofifrarmaset? Al @ ASPMETCE ) Page Designs
Retathe G BlutioBrstisd- ' & JavaSierat
Dalste
{ladase Current Fage @ Sludlofframesethmnl @ ML
Update Site,.. w0 Blufinglesfmame Hml 1 HELT (Enir paga)
@ Studiadfrar bl @ C58
Copy to Ske 3

@ Bludioginde bl
O Gpen..

8 Drearenver Site
o Ware..

Locate in Site Extend

@) Draamwasver Sxhange

TakE @ (UIK 10N OF DreETIMEEUET Dreamweaver Developer Center »

Uit the Developer Certer for samples,
baoeials, and comELREY resources,

i -

= Find autharized frainirg

Learm shoust dacumenzation
resoures

d

Diont sk 2qain

Book Il
Chapter 7

sanbiuyaa]
ubisag afied
(3j\\ paoueApYy



156 Validating Your Code

Figure 7-11:
The
Templates
tab of the
New
Document
dialog box.

You can also create an HTML page based on a user-created template by
choosing File>New and choosing the template from the Templates tab of the
New Document dialog box. (When you select the Templates tab, the dialog
box’s title bar changes to read New from Template and the Templates options
appear, as shown in Figure 7-11.)
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Validating Your Code

Dreamweaver 8 has a built-in code validator. The validator checks your
HTML for errors (for example, unclosed <TD> tags or tags with invalid attrib-
utes, such as <FONT width=113>). If you work exclusively in Design view,
you may never need to use the validator. If you work in Code view, though,
and you are creating long, complex pages, you may find it worthwhile to run
the validator.

To validate your code (unless it’s XML), choose Filem>Check Pager>Validate
Markup. The Results panel opens and shows a list of warnings for any faults
in the code.

To validate XML code, choose Filec>Check Pager>Validate as XML. Because
XML has stricter requirements for well-formed code, you should take advan-
tage of Dreamweaver’s built-in validator if you're writing XML or XHTML.



Chapter 8: Integrating
Dreamweaver 8 with Other
Macromedia Products

In This Chapter

v~ Integrating Dreamweaver with Fireworks

+~ Integrating Dreamweaver with Macromedia Flash
+” Integrating Dreamweaver with ColdFusion

v~ Integrating Dreamweaver with FreeHand

+~ Integrating Dreamweaver with Contribute

Wth the release of the Macromedia Studio MX 2004 suite, Macromedia
brought Fireworks, Flash, Dreamweaver, ColdFusion, Contribute,
and FreeHand closer together than ever before. Macromedia Studio 8 con-
tinues this tradition of integration. The applications in the suite have
complementary — and in some cases overlapping — capabilities.

In order to take advantage of Dreamweaver’s integration with Fireworks and
Flash, you need to make sure Design Notes are enabled. Design Notes are
Macromedia Studio’s way of tracking changes and establishing links between
exported files (such as GIFs or JPEGs) and their source files (Fireworks PNG
files, for example).

By default, Design Notes are enabled when you establish a new Site. If you
disabled them and wish to re-enable them, just follow these steps:
1. In Dreamweaver, choose Siter>Manage Sites.
The Manage Sites dialog box appears.
2. Select the site by clicking it.
If you have a site open already, that site is already selected.
3. Click the Edit button.

The Site Definition dialog box opens.
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4. If the Site Definition dialog box opens with the Basic tab selected,
click the Advanced tab.

The Advanced options appear.
5. Select Design Notes in the Category list.
The Design Notes options appear.
6. Select the Maintain Design Notes check box, as shown in Figure 8-1.

The Maintain Design Notes option is selected by default, but it can be
toggled on and off in the Site Definition dialog box.
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7. If you’re working on the site with others, make sure the Upload
Design Notes for Sharing check box is selected.

The Upload Design Notes for Sharing option uploads your Design Notes
so that other people working on the site can have access to them. If
you’re the only person working on a site, you should deselect this
option to speed file transfers.

8. Click OK.
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Disabling Design Notes is simple: Just follow the preceding steps, but in
Step 6, deselect the Maintain Design Notes check box.

With Design Notes enabled, you can move seamlessly back and forth between
Dreamweaver and the other applications in the Macromedia Studio suite.

Integrating Dreamweaver with Fireworks

Fireworks is a Web design tool and Dreamweaver is an HTML editor, so you
may expect that the two applications complement each other well. In fact,
the two programs make a dynamite tag team. Book Il
Chapter 8
The phrase Roundtrip HTML refers to the basic interaction between Fireworks
and Dreamweaver. Essentially, if you generate your HTML in Fireworks and
edit the code in Dreamweaver, Fireworks recognizes the changes you make
in Dreamweaver. That goes for links, image maps, behaviors shared by both
programs, and edited HTML text. If you make radical changes to the overall
design of the page in Dreamweaver, however, Fireworks may not be able to
reconcile the HTML with the Fireworks PNG source file. In those cases,
Fireworks will overwrite your changed code with new code.

g Janeamweal(
Buneihayu|

In order to take advantage of Roundtrip HMTL, you need to establish a few
settings, both in Dreamweaver and in Fireworks. In Dreamweaver, you need
to define a local site (see Book II, Chapter 3) and make Fireworks your pri-
mary image-editing application. To find out how, read the next section.

Makmq FN’GWW’I(S your primary image edltor

If you installed Dreamweaver along with the rest of Macromedia Studio,
Fireworks is your primary image-editing application by default. However, if
you changed that default setting, here’s how to return to the setting of
Fireworks as your primary image-editing application:

1. In Dreamweaver, choose Edit~>Preferences or use the keyboard short-
cut Ctrl+U.
The Preferences dialog box appears.

2. Select File Types/Editors in the Category list.

The File Types/Editors options appear in the Preferences dialog box, as
shown in Figure 8-2.

3. Select the .png extension in the Extensions list.

The extension is highlighted.
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4. Click the plus (+) button above the Editors list.

If Fireworks is already listed in the Editors list, you don’t need to click
the plus (+) button.

5. If you need to add Fireworks to the Editors list, navigate to
Fireworks.exe on your hard drive and double-click it.

If Fireworks is now the only application listed in the Editors area, it’s the
primary editor by default (Primary is in parentheses next to Fireworks).

6. If you have more than one image editor in the Editors list, select
Fireworks in the list and click the Make Primary button.

7. Repeat Steps 3 through 6 for the .gif, .jpg, .jpe, and .jpeg
extensions.

8. Click OK.

You may need to set a few preferences in Fireworks as well. See Book III,
Chapter 8 for information on how to set Launch and Edit preferences in
Fireworks.

Working with tables

Taking advantage of Roundtrip HTML means more than just setting prefer-
ences: You also need to know which application is best to use for particular
types of changes. If you originally exported your HTML from Fireworks and
wish to make major structural changes to the table that constitutes your
HTML page, we recommend that you modify your original Fireworks PNG
source file and re-export the HTML from there rather than using Dreamweaver
to modify the code. Using Fireworks to change the table structure ensures
that the slices in your Fireworks PNG source file will correspond to the cells
in your HTML table.
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Here’s how to edit a table in Fireworks (provided the table was created when
you exported your page design as HTML from Fireworks) by launching it
from within Dreamweaver:

1. Select the table in Dreamweaver.
The Property inspector updates to display the parameters of the table.
2. Click the Fireworks Edit button in the Property inspector.

If need be, you can navigate to the source Fireworks PNG file from within
the Dreamweaver Property inspector. The source file opens in Fireworks.

3. Make edits to the slices or guides as necessary.
4. Click the Done button when you're finished editing.

The Fireworks window closes, and Dreamweaver updates the table and
images.

When you launch and edit a table in Fireworks, it may overwrite some
changes you may have made to the table structure in your Dreamweaver
code if the changes you made in Dreamweaver are substantial. A warning
notifies you when Fireworks will overwrite the existing Dreamweaver edits.

When you want to leave the table structure intact but need to rename or
reoptimize an image, you can launch Fireworks from a selected image rather
than a selected table. Editing a JPEG image from its Fireworks PNG source
file rather than editing and resaving the already optimized image ensures the
highest image quality.

To launch and edit a PNG source file from an optimized image placed in
Dreamweaver (to change graphic text in a JPEG image, for example), follow
these steps:

1. Click the optimized image in the Dreamweaver Document window.
The Property inspector updates to display image parameters.

2. Click the Fireworks Edit button in the Property inspector, as shown
in Figure 8-3, or right-click the optimized image and choose Edit with
Fireworks from the context menu that appears.

If Dreamweaver cannot locate the source Fireworks PNG file, you're
prompted to navigate to the source file. When you do, the source PNG
file opens in Fireworks. At the top of the Fireworks canvas, the words
“Editing from Dreamweaver” show that Roundtrip HTML is in effect.

Notice at the top left of the Property inspector that the Fireworks icon
and the designation FWw Image identify the selected image as one cre-
ated in Fireworks. Note also the Fireworks Src text field at the bottom
middle of the Property inspector, which shows the path and name of the
source Fireworks PNG file.

Book Il
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Fireworks Edit button

Figure 8-3: |
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3. Edit the image within the context of your overall page design.

The new version of the image will be exported at the specified settings,
which you may leave as is or change before clicking Done.

4. Click the Done button at the top left of the canvas.

The Fireworks window minimizes. When you look at the Document
window in Dreamweaver, you see the new image.

You can also launch and edit a GIF or JPEG image directly in Fireworks, though
it’s always best to edit from the source PNG when possible, both to preserve
image quality and to keep your source file in sync with your Web page. If you
don’t have a source PNG (or don’t need to keep your source design file up to
date) and you just want to tweak an image without changing its width and
height, you can do so easily as follows:

1. Double-click the image’s filename or corresponding icon on the Files
tab or Assets tab of the Files panel.
Fireworks launches and your image appears on the canvas.

2. Make changes to the image.

3. Export the updated GIF or JPEG from Fireworks by choosing File=>
Export or by using the shortcut command Ctrl+Shift+R.

If necessary, navigate to the folder in which you keep the optimized
images for your site. A prompt warns you that the file already exists.
Click OK to replace the existing file.

4. Close the file in Fireworks.

When you close the file in Fireworks, an alert asks if you want to save
changes to your file. If you want Fireworks to save the file as a PNG, click
Yes. Otherwise, click No.

You can add a Fireworks-generated table to an open Dreamweaver document
whether the document is blank or has code already in it:
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1. Choose Insert~>Image Objects>Fireworks HTML.
The Insert Fireworks HTML dialog box appears.

2. Type the pathname or click the Browse button and browse to the
Fireworks HTML file.

If the HTML file you select was not generated by Fireworks, an alert
informs you and you won’t be able to insert the HTML.

3. Select the Delete File after Insertion check box if you don’t need to
save the Fireworks-generated HTML.

Unless you want a backup copy of the HTML free from any edits you
might make in Dreamweaver, you can safely delete it. Book Il

4. Click OK. Chapter 8

If you want to nest tables but still use Roundtrip HTML, one way to do it is to
make a large table in Dreamweaver and insert Fireworks-generated tables in
the cells. Then, if you need to change one of the inserted tables, you can
select the table and edit it in Fireworks.

g 1aneamweal(
Buneibayu|

Integrating Dreamweaver with Macromedia Flash

Thanks to Dreamweaver’s Flash commands, you can create Flash buttons
and Flash text without actually having Macromedia Flash installed on your
computer. If you've installed Macromedia Studio, though, you’ll probably
prefer to create Flash movies in Macromedia Flash and let Dreamweaver
write the code to embed Flash SWF files in your HTML pages.

Inserting a Flash movie into
a Dreamweaver document

Inserting a Flash SWF movie into a Dreamweaver document is easy. Dream-
weaver offers easy access to many parameters of SWF movies directly from
the Property inspector, though you can’t edit a Flash SWF movie from within
Dreamweaver.

To insert an SWF file into an existing Dreamweaver HTML document, follow
these steps:
1. Click the spot in the page where you want the Flash movie to go.

2. Choose Insert->Media~>Flash (or use the keyboard shortcut Ctrl+Alt+F)
or click and hold the Media button in the Common category of the
Insert bar and choose the Flash icon.

The Select File dialog box appears.



’64 Integrating Dreamweaver with Macromedia Flash

Figure 8-4:
The Dream-
weaver
Property
inspector
for SWF
movies.

3. Navigate to the SWF file and double-click it or click it once and
click OK.

You can type the name of the file in the File Name text field instead, if
you prefer. The Select File dialog box closes and your SWF movie is
placed where the cursor was last active.

Working with the Property inspector

When an SWF file is selected in the Document window, the Dreamweaver
Property inspector (shown in Figure 8-4) gives you access to many parame-
ters for the display of the movie, including

4+ Width and Height: Unless specified otherwise here in the W and H
fields, the SWF will display at the dimensions you set in Macromedia
Flash’s Document Properties dialog box.

4+ Loop: You can toggle looping on or off by selecting or deselecting this
check box.

4+ Autoplay: You can toggle autoplay on or off by selecting or deselecting
this check box. When Autoplay is selected, the SWF starts automatically
when the HTML page loads in the user’s browser window.

4+ V Space and H Space: As with GIFs and JPEGs, you can set the vertical
and horizontal spacing to provide margins between SWFs and other con-
tent that occupies the same table cell.
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4 Quality: This drop-down list offers four options: High, Auto High, Auto
Low, and Low. The Low option sacrifices image quality to increase
smoothness in the flow of the animation.

4+ Scale: This drop-down list gives you three choices: Show All, No Border,
and Exact Fit.

4+ Align: This drop-down list offers access to all the options for aligning
the SWF within a table cell.
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4+ Background color (Bg): A background color chosen here overrides the
background color as set in Macromedia Flash’s Document Properties
dialog box.

The Property inspector also includes some other handy tools:

4+ The Flash Edit button: This button opens the source FLA file in the
Macromedia Flash application.

4+ The Reset Size button: This button restores the SWF to its original
dimensions.

4+ The Play button: This button allows you to see the SWF file in action
without opening the page in a browser window.

4 The Parameters button: This button allows you to customize parame-
ters passed to the SWF.

The Flash Edit button in the Property inspector is grayed out if you do not
have Macromedia Flash installed on your computer. When you want to edit
an SWF, you need to go back to the FLA source file to make your changes and
then re-export the SWF. This is true except when changing a link in an SWF
file, in which case Dreamweaver adds a Design Note to pass the new link to
the FLA source movie when you next launch and edit the FLA.

Editing a Flash movie in Dreamweaver

To edit a Flash movie from within Dreamweaver, just follow these steps:

1. Select the SWF file by clicking it in the Dreamweaver Document
window.

The Property inspector updates to display the Macromedia Flash param-
eters. (Refer to Figure 8-4.)

2. Click the Edit button in the Property inspector.

If necessary, navigate to the FLA source file in the Locate Macromedia
Flash Document File dialog box and double-click the FLA file or click it
once and then click the Open button.

The source file opens in Macromedia Flash. The designation “Editing
from Dreamweaver” confirms that Macromedia Flash was launched from
within Dreamweaver.

3. Edit the Flash movie source file.
4. Click the Done button at the top left of the Flash stage.

Macromedia Flash exports an updated SWF file to the proper directory,
saves the FLA file to its current directory, and closes. The new SWF file
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appears in the Dreamweaver Document window. If you changed the
dimensions of the Flash movie, click the Reset size button to update the
Dreamweaver code.

Editing a link in an SWF file in Dreamweaver

Editing a link in an SWF file is similar to editing a Flash movie, but you need
to set up a few things beforehand:

4+ Establish a home page and dependent pages in the Site Map.
4 Set the Site Map to display dependent files (as in Figure 8-5).

See the Dreamweaver Help files for details on setting up a Site Map.
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After you've done that, you can change a link in an SWF by following these
steps:

1. Right-click the link displayed under the SWF file in the Site Map and
choose Change Link from the context menu.

The Select HTML File dialog box appears.
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2. Navigate to the file to which you want to link and double-click it, or
type a URL into the URL text field.

3. Click OK.

You can also update a link in an SWF file while updating the same link in
other files by choosing Siter>Change Link Sitewide and inputting the old and
new links in the Change Link Sitewide dialog box that appears. Whether you
change the link only in the SWF file or in an SWF file as part of a sitewide
update, the FLA source file will not be updated until you launch and edit the
SWF from Dreamweaver.

Integrating Dreamweaver with ColdFusion

Dreamweaver fully absorbed ColdFusion in the sense that Dreamweaver
became the working environment for ColdFusion. In Book VII, we describe
how to set up your ColdFusion server as well as concepts in programming;
Book VII, Chapter 4 offers the information you need to write CFML
(ColdFusion Markup Language) using Dreamweaver.

Integrating Dreamweaver with FreeHand

Though you can publish FreeHand documents as HTML (complete with
embedded SWF movies, URL links, and Flash actions), FreeHand is not as
tightly integrated with Dreamweaver as Fireworks is.

FreeHand is primarily a print-oriented design application, so it’s no surprise
that it lacks the kinds of controls Fireworks offers for image slicing and
optimization.

In other words, if you're designing for the Web, you'll find Fireworks a much
better tool (not in the least for its solid integration with Dreamweaver). None-
theless, if you ever find yourself with an HTML file published by FreeHand,
rest assured that you can open and edit that file in Dreamweaver, as you can
with an HTML file created in any application.

Integrating Dreamweaver with Contribute

From the beginning, Contribute was built with Dreamweaver in mind. Now
with the release of version 2.0, Contribute has become more integrated with
the Macromedia Studio suite — and Dreamweaver in particular — than ever.
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See the section on enabling Contribute compatibility in Book V, Chapter 3 for
a quick discussion of what to do if you haven’t yet built your site and want
others to maintain it using Contribute.

If you've built a site already and want to be able to administer it without
leaving Dreamweaver, just follow these steps:

1.

9a.

9b.

Choose Siter>Manage Sites.
The Manage Sites dialog box appears.

. Select the site you want to administer and click Edit.

The Site Definition dialog box appears.

. Click the Advanced tab.

The Advanced options become available.

. Click Contribute in the Category list.

The Contribute options load in the main part of the dialog box.

. Select the Enable Contribute Compatibility check box if it’s not

already selected.

If you haven’t enabled Design Notes and Check In/Out, a dialog box
appears to alert you to that fact. Click OK to enable them. The
Contribute Site Settings dialog box appears.

. Enter your name and e-mail address in the Site Settings dialog box

and click OK.

The dialog box closes and new options appear in the Contribute page of
the Site Definition window.

. Enter the remote site root URL (for example, http: //www.loungeboy.

com) in the Site Root URL text field, if it’s not already there, and click
the Test button.

Dreamweaver confirms the URL is accurate by connecting to the site.

. Click the Administer Site in Contribute button.

Either the Administrator Password dialog box appears, or, if there’s no
administrator for the site yet, a Contribute dialog box appears that asks
if you want to be the administrator for the site.

If the Administrator Password dialog box appears, enter the password
and click OK.

If the Contribute dialog box appears, asking if you want to be the
administrator (and you do want to be the administrator), click Yes.



Figure 8-6:
The
Administer
Website
dialog box.
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The Administrator Password dialog box appears. Enter a password in
the New Password text field and re-enter it in the Confirm New Password
text field below. Then click OK. Note that passwords are case-sensitive.
(If the Contribute dialog box appears and you don’t want to be the
administrator, click No.)

Contribute opens in the background and the Administer Website dialog
box appears, as shown in Figure 8-6.
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10. Make any changes to the Administer Website settings and click OK.

The Administer Website dialog box closes, and Contribute closes. For
information on the Administer Website options, see Book V, Chapter 3.

11. Click OK in the Site Definition dialog box.

12. Click Done in the Manage Sites dialog box.

For more information on creating new pages in Contribute based on
Dreamweaver templates, see the section on creating a new page in Book V,

Chapter 2 and the section on using Dreamweaver templates in Book I,
Chapter 7.
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Chapter 1: Introduction
to Fireworks 8

In This Chapter

+~ Understanding the power of Fireworks 8
1 Touring the Fireworks 8 interface

v Checking your work over with a preview
v Creating a customized work environment
v~ Setting your preferences

1 Getting help when you need it

Freworks 8 is the latest version of a graphics creation and editing pro-
gram designed to streamline the process of making images for the Web.
In the days before the original version of Fireworks, making graphics for the
Web could be a frustrating and time-consuming process of trial and error.
Not only that, but the results often looked pretty bad.

With products like Fireworks, all that has changed. This chapter gives you
a brief introduction and tour of the product and shows you how to set up
Fireworks to fit your working style.

Understanding the Power of Fireworks

You can divide the basic process of making graphics for a Web site into two
major parts:

4 Creating the images: Drawing, importing, and manipulating pictures, as
well as designing the overall page layout on the Fireworks canvas

4+ Optimizing the images: Slicing the page layout into pieces, selecting the
proper compression format and level for each piece, and exporting the
individual pieces

Fireworks has two different tools that make the process of creating graphics
for a Web site easier: layers and slices. Layers are a mainstay of graphics
development tools, such as Photoshop and FreeHand, and animation pro-
grams, such as Macromedia Flash. Layers make creating and editing graphics
a simpler proposition. Slices, first introduced by Macromedia in the original
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version of Fireworks, offer an efficient way to divide a design into individually
optimized Web graphics. You can read more about both layers and slices in
the following sections.

Making designing easier with layers

We discuss layers in more detail in Book IIl, Chapter 5, but this section serves
as an introduction to the benefits of layers.

Layers act like transparent sheets that you can stack, one on top of the other.
You draw a separate element of the image on each transparency. Any area
where you haven’t put something remains transparent, so layers beneath
show through. In a typical file, you may have several text layers and many
layers of backgrounds, icons, lines, shapes, and so on.

If you ever make mistakes or change your mind about overall layout, text, or
graphical elements, layers can save you a lot of time as you design your site.
Suppose that you're doing calligraphy and illustration on fine paper. If you
mess up one part of the image, you often ruin the whole thing because you
only have one layer to work with — the paper. Short of cutting a piece out of
the paper, you probably can’t delete your mistakes. Layers offer a practical
approach to fixing your errors.

Using layers provides many benefits. Some of the most practical advantages
include the following:

4+ You can change any element of your design — text, bitmap, or vector
shape — without altering or destroying any other element.

4+ You can apply effects to layers that are grouped together, decreasing the
amount of time it takes to edit an image. (Of course, you can also apply
effects to individual layers.)

4+ You can easily move elements up and down in the stack of layers to
change the visual effect on the screen.

4+ You can test new designs and effects in a snap because you can very
easily hide and show elements of an image.

Creating slices

We discuss slices in more detail in Book IIl, Chapter 6, but here’s an introduc-
tion to the concept of slices. Imagine for a moment that you've created your
masterpiece design for a new Web site. Your Fireworks file may include a lot
of different kinds of imagery, including the following:

4 Animations

4+ Drawings



Figure 1-1:
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4+ Header graphics, such as banners
4+ Logos

4+ Navigation buttons

4+ Photos

Before you can create your Web page, you have to get all of these graphics
into a Web-friendly format, which is where slices come in. The idea is simple
and elegant: Include a special layer in the program that no one can ever
remove, where you can create guides as to how you want the images to be
“sliced” up into separate, individually optimized, and hyperlinked images.
Figure 1-1 shows that special layer, called the Web layer, and some slices in
action.
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Slices provide some key advantages over outmoded methods of creating
images for the Web:

4+ You can slice a design into more than one image at a time.

4 You can export multiple files in a single procedure.
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4+ You can control exactly where images are sliced, which helps prevent
you from making images with overlapping areas.

4 You have an increased ability to optimize image size (and thereby reduce
download time) by selecting the best optimization method for each slice.

Slices guarantee that the layout of your Web page appears nearly identical
on every user’s screen to the design that you create in Fireworks. (If you have
HTML text on your page, the appearance of that text may vary, depending on
which browser and platform the user views your page with.)

Taking a Quick Tour of the Fireworks 8 Interface

Figure 1-2:
The Start
Page,
welcoming
you to
Fireworks 8.

The Fireworks interface is set up to make accessing the tools quick and
intuitive. When you start Fireworks, it doesn’t create a new document
automatically — instead, you see the Start Page, as Figure 1-2 shows you.
From the Start Page, you get one-click access to

4 Create New: Click the Fireworks File link to open a new, blank image.

4+ Extend: Click the Fireworks Exchange link to browse to a part of the
Macromedia Web site that includes a lot of free, cool, downloadable
tools and graphical elements created by users like you.
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4+ Open a Recent Item: Just click the filename, or click the Open folder and
browse to a file to open the image in Fireworks.

4+ Information: Click the Take a Quick Tour of Fireworks link or the Learn
About Documentation Resources link to view basic tips and tutorials. Or
click the link to the Fireworks Developer Center, where you can find tuto-
rials, sample files, and feedback from other Fireworks users.

If you don’t want the Start Page to show up every time you launch Fireworks,
click the Don’t Show Again check box at the bottom-left corner of the page.

To create a new Fireworks file (called a PNG file), just follow these steps:

1. Choose Filec>New, or click the Fireworks File link on the Start Page.
The New Document dialog box appears.

2. Choose the canvas size for your document in the New Document
dialog box.

The default width and height are 660 x 440 pixels (or the dimensions of
the previous file that you created in Fireworks), and the default resolu-
tion is 72 pixels per inch. You can enter your own size in the fields pro-
vided and change the unit of measurement by selecting one from the
drop-down list. Leave the resolution at 72 pixels per inch unless you're
designing for some medium other than the Web, like print.

3. Select a color for the canvas.

The default canvas color is white, but you can choose a custom color
by selecting the Custom radio button and then using the eyedropper to
choose a color from the color picker. You can also choose to have a
transparent background by selecting the Transparent radio button.

4. Click OK to create your new Fireworks document.

When you click OK, your screen looks a lot like Figure 1-3.

The Tools panel: A bird’s-eye view

The panels along the left side of the screen are parts of the Tools panel, which
provides access to all the tools that you use to make and modify your graph-
ics. The Tools panel divides tools into groups based on their function:

4+ Select: Contains tools used to select an object, as well as tools used to
crop or otherwise manipulate the canvas.
4+ Bitmap: Stores tools used to paint, draw, fill, and so on.

4+ Vector: Contains tools used to create and manipulate vector graphics.
(See Book VI, Chapter 1 for more on vector graphics.)
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Figure 1-3:

The default
Fireworks 8
interface.
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4+ Web: Holds tools, such as the Slice tool, that are designed specifically
for getting images ready for the Web.

4+ Colors: Stows away tools that control the color(s) of objects.

4+ View: Holds tools that you can use to change your view of the canvas or
the screen.

An arrow at the lower-right corner of a tool’s icon indicates that the tool has
one or more specialized variations. You can click the arrow to activate a pop-
up menu that displays icons for the available variations.

The Tools panel: A bug’s-eye view

This section gives you the lowdown on the tools that you probably use the
most in the Tools panel. An arrow at the bottom right of the tool icon indi-
cates there are related tools available. Click the icon or the arrow to activate
a pop-up menu so that you can choose from all the available tools. When you
select a tool, you can also cycle through the related tools by pressing certain
keys on your keyboard (for example, select the Marquee tool and press M to
toggle through the Marquee tool options). The Tooltip for each tool includes
the key that you can press to cycle through the options on the tool.
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You get to see the tools in action in later chapters, but for now, here are the
highlights for each of the four key categories of drawing tools:

4+ Select: The following four tools (clockwise from top left) make up the
Select section of the Tools panel:

Pointer/Select Behind tool: Use the Pointer tool to select objects on
the canvas by clicking them or clicking and dragging an area that
encompasses them. Use the Select Behind tool when you want to
click an object on the canvas that other objects cover.

Subselection tool: Use the Subselection tool to select an individual
object from a group.

Crop/Export Area tool: Click the Crop tool and click-and-drag to
select an area on the canvas to crop an image. When you crop an
image, you discard everything outside the selected area from your
image. After you have selected the area that you want to keep,
double-click inside the area to crop. Use the Export Area tool to
create a new image from the area that you select. After you have
selected the area you want to export, double-click inside the area to
bring up the Export Preview window.

Scale/Skew/Distort tool: This tool is inactive (as indicated by the
dimmed icon) until you select an object on the canvas. Click this tool
and click and drag the transform handles at the corners of the object
to change its size and/or shape.

4+ Bitmap: The following ten tools (clockwise from top left) make up the
Bitmap section of the Tools panel:

Marquee/Oval Marquee tool: Click the Marquee tool and click and
drag to select a rectangular area on the canvas. If you want to select
a circle or oval area, use the Oval Marquee variation. When you select
an area, you select all objects that fall completely within the area.

Lasso/Polygon Lasso tool: Click the Lasso tool and click and drag on
the canvas to select everything within an irregularly shaped area of
the canvas. If the shape you want to select is made up of straight
lines, use the Polygon Lasso.

Brush tool: Click this tool to paint on the canvas. See Book III,
Chapter 3 for more information about the very versatile Brush tool.

Eraser tool: Click the Eraser tool to erase a swath through any
bitmap object on the canvas.

Rubber Stamp/Replace Color/Red Eye Removal tool: Click this tool
to copy a selected area of a bitmap to another spot on the canvas.
Alt+click the area that you want to copy, and then click and paint
where you want the copy to go. Use the Replace Color tool to swap
one color for another wherever you click and drag the Replace Color
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180 Taking a Quick Tour of the Fireworks 8 Interface

brush on the canvas. Simply click with the Red Eye Removal tool to
replace red with black wherever you click the canvas. Fireworks 8
has really improved the quality of these tools. These tools work better
in Fireworks 8 than in the previous version of the program.

Blur/Sharpen/Dodge/Burn/Smudge tool: Click this tool and click and
drag on the canvas to soften the focus of (Blur) or bring into focus
(Sharpen) an area of a bitmap image. Click the Dodge tool and click
and drag on the canvas to lighten an area of a bitmap image. Click
the Burn tool and click and drag to darken an area of a bitmap image.
Click the Smudge tool and click and drag on the canvas to smear a
part of an image into another part of the image, as if you were finger
painting. You can set the parameters for these tools in the Property
inspector.

Pencil tool: Click the Pencil tool and click and drag to draw single-
pixel-width lines. If you want control over the thickness and texture
of the line that you're creating, use the Brush tool.

Magic Wand tool: Click the Magic Wand and click a bitmap to select
neighboring areas of solid or similar colors in your image.

4+ Vector: The following six tools (clockwise from top left) make up the
Vector section of the Tools panel:

Line tool: Throw your ruler away! With the Line tool, you can draw a
straight line every time. You can adjust the line’s thickness, color,
and other parameters in the Property inspector.

Pen/Vector Path/Redraw Path tool: Click the Pen tool to create vector
graphics by drawing vector paths. You can use the Pen tool to select

points and let Fireworks connect the dots, or you can draw the shape
yourself with the Vector Path tool. You can use the Redraw Path tool

to change the shape of a vector graphic by clicking and dragging any
of the points that define the shape.

Text tool: Click this tool and click the canvas to place and edit text
on the canvas. See Book Ill, Chapter 3 for information on how to
make the most of the Text tool.

Knife tool: Click this tool and click and drag a line to cut vector paths
in two.

Freeform/Reshape Area/Path Scrubber (Additive)/Path Scrubber
(Subtractive) tool: Use the Freeform tool to reshape a vector path by
pushing or pulling the stroke instead of moving the individual points
that define it. Use the Reshape Area tool to pull a vector path as if
you grab it with your hand. Use the Path Scrubber tool to change the
color, thickness, and various other properties of the vector path. If
you have a graphics tablet, you can set the properties to vary based
on variations in the pressure or speed that you use in drawing.
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Taking a Quick Tour of the Fireworks 8 Interface 181

¢ Rectangle/Rounded Rectangle/Ellipse/Polygon tool: Create vector
shapes by clicking these tools and clicking and dragging on the
canvas.

4+ Colors: The Colors tools allow you to select and apply colors to lines,

objects, and anything else on your canvas. The two main Colors tools,
located in the top row of the section, are

¢ Eyedropper tool: Click this handy tool to select a color from the
swatches in the color picker or from any object on the canvas by
clicking when you place the Eyedropper on the color that you want.

¢ Paint Bucket/Gradient tool: Click this tool and then click a shape on
the canvas to fill the shape with a solid color (Paint Bucket) or gradi-
ent. For details about gradients, see Book IlI, Chapter 4.

Across the aisle: The right-side panels

Eight key panels appear on the right-hand side of the screen, opposite the
Tools panel. These panels include the following:

4+ The Optimize panel: This panel lets you set your export options (GIF or

JPEG, quality level, and so on). See Book III, Chapter 6 for more informa-
tion about the Optimize panel.

The Layers panel: This panel contains all your layer options and infor-
mation. The first layer is always the Web layer, which holds information
about the coordinates of the slices. (See Book IIl, Chapter 6 for more
about slices.)

The Frames and History panel: This panel gives you access to the
Frames area, where you can navigate easily among the frames in your
document. You use frames to make button rollovers and animations.
(See Book IlI, Chapter 5 for more details.) This panel also allows you to
view the History area, which is a list of your most recent actions.

The Assets panel: This panel provides a way to centralize and organize
links from Web objects to Web pages. Fireworks can actually generate
your entire Web page — images, code, and all.

The Auto Shape Properties panel: When you select an Auto Shape
object on the canvas, you get access to many of its special properties
via this panel, including Thickness and Roundness.

The Special Characters panel: The Special Characters panel gives you
easy point-and-click access to — you guessed it — special characters,
when you use the Text tool to add words to your design. Special charac-
ters include letters with accent marks, dollar and copyright symbols,
and the like.
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182 Viewing and Previewing Your Work

QuT0 4+ The Image Editing panel: The Image Editing panel collects the most-

S ) used tools from the Select and Bitmap sections of the Tools panel, along

S"UD‘ with some filters and menu commands, and lays them out for quick
access from the right side of the canvas.

& 10 4+ The Colors panel: The Colors panel, via its Mixer and Swatches tabs,

A 4 offers quick access to the tools that you can use to add and edit colors

S“U and gradients to objects on the canvas.

The Property inspector

The Property inspector is docked to the bottom of the Document window.
This panel changes automatically to reflect the settings for the currently
selected tool or object.

The Property inspector allows you to see and adjust the parameters of what-
ever object or tool you select. If you're working on a text layer, for example,
the Property inspector gives you immediate access to and complete control
over the font, size, color, and other attributes of the text. When you select a
shape, on the other hand, the Property inspector offers you easy access to
controls over the shape’s size, position on the canvas, color, texture, and
more.

\\J
If you ever want to hide all the panels temporarily, press F4 or the Tab key.
To make the panels visible, press F4 or the Tab key again.

Viewing and Previewing Vour Work

While you work, you view the canvas with Original view selected. The other
three view options at the top of the canvas allow you to preview what your
optimized images will look like as follows:

4 Original: This is the default view in which you create and edit your
design.

4+ Preview: This view shows you what the page will look like when it is opti-
mized for the Web, based on your current image optimization settings.

4 2-Up: This view offers previews of what optimized images will look like,
but with a little something extra: a side-by-side comparison of the origi-
nal image and an optimized version of the image, or two optimization
settings.

4+ 4-Up: By selecting the 4-Up view, you can preview the original image and
three different optimization settings at the same time. You can compare
how they look and how big the resulting image file is at each setting, as
well as how long the image takes to download at a particular modem
speed.
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Because every image compresses a little differently, you can never predict
exactly what an image may look like after you optimize it. The longer you
work with Fireworks, the better you get at narrowing the optimization options
before you preview; nevertheless, you may find it more efficient to preview
before you export. For more information about the purpose and art of image
optimization, see Book III, Chapter 6.

At the top right of the canvas is a feature that you may have met in the ori-
ginal Fireworks: a Quick Export button. The Quick Export button lets you
export files to, and even launch, other applications, such as Dreamweaver 8§,
Macromedia Flash 8, and FreeHand MX. The Quick Export button also gives
you export options for Macromedia Director Shockwave Studio, Adobe
Photoshop, and other programs.

Customizing Your Work Environment

\\3

During different phases of the design process, you may find that you refer to
some panels constantly but other panels not at all. Unless you have a gigantic
monitor set to a high resolution, you need to collapse some less-frequently
used panels to make room for more-frequently used ones.

Collapsing and expanding panels

Every panel’s name appears at the left on the top title bar in the panel. To the
left of the name sits a handy little arrow that points down to indicate that the
panel is expanded or points to the panel name if the panel is collapsed.

You can expand or collapse a panel in two ways:

4 C(lick the name of the panel.

4+ Click the arrow to the left of the panel name.

When the panel expands, it makes room for itself by forcing the panels below
it down — unless it’s a panel on the bottom, in which case it forces the panels
above it up. If your monitor doesn’t have enough room to show all the panels
open at once, Fireworks collapses the panel directly beneath or above the
one that you expand.

If you have a panel expanded but still can’t see quite enough of it, you can
drag the panel open wider or longer by clicking the left or bottom edge of
the panel and dragging it.

In addition to collapsing and expanding panels, you can also open and close
panels. Check out Table 1-1, which includes the key commands for closing
and opening panels.
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18 4 Customizing Your Work Environment

Table 1-1 Keyboard Shortcuts for Opening and Closing Panels
Panel Keyboard Shortcut ~ Panel Keyboard Shortcut

Tools Ctrl+F2 Styles Shift+F11

Properties  Ctrl+F3 Library F11

Optimize F6 Color Mixer  Shift+F9

Layers F2 Swatches Ctrl+F9

Frames Shift+F2 Info Alt+Shift+F12

History Shift+F10 Behaviors Shift+F3

To hide all panels at once, choose Windowr=>Hide Panels, or use the keyboard
shortcut F4.

Moving, docking, and grouping panels

When you open Fireworks for the first time, all the panels are docked and
grouped in the default configuration. (Refer to Figure 1-3 to see this default
configuration.) However, you can easily undock and move panels and put
them in custom groups.

To move a panel, follow these steps:

1. Click the gripper at the top left of the panel.

The gripper is made up of two parallel lines of dots at the top left, on the
panel’s title bar.

2. Drag the panel to the spot on the screen where you want it to go.
3. Release the mouse button.
You now see the panel in the position that you selected, in its own

window, as you can see in Figure 1-4.

When you move a panel, you automatically undock it, but you don’t automat-
ically dock it somewhere else when you release the mouse button. The panel
remains floating in the Fireworks window until you dock it. To dock a panel,
follow these steps:

1. Place your cursor over the gripper at the top left of the panel.

The gripper is made up of two parallel lines of dots at the top left, on the
panel’s title bar.



Figure 1-4:

An
undocked
panel.
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2. Drag the panel to a docking area.

A docking area is anywhere along the outer edge of the Document window
or adjacent to a docked panel. When you drag the panel over a docking
area, a rectangle appears on the screen to give you a preview of the
space that the panel occupies if you docked it there.

3. Release the mouse button.
The panel is docked in its expanded state.
Fireworks allows you the option to consolidate or group panels, which pro-

vides a nice way to put the panels that you like using together. To group a
panel with another panel, follow these steps:

1. Click the Panel Options icon (the three white lines and arrow) at the
top right of the panel that you want to add to a group.
The Panel Options menu appears.

2. Select the Group [Name of selected panel] With option.

An additional pop-up menu appears.
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186 Setting Fireworks Preferences

3. Choose the panel that you want to group the currently selected panel
with.

The panel that you add appears as a tab in the panel to which you
added it.

Follow these steps to remove a panel from a group, or just follow the first
three steps to close the panel group:
1. Click the tab of the panel that you want to separate from the group.
2. Click the Panel Options icon at the top right of the panel.
The Panel Options menu appears.
3. Select the Close Panel Group option.

This option closes not only the panel that you want to close, but also
any other panels in that group.

4. Reopen any panels from the group that you didn’t want to close by
clicking their names in the Window menu.

If you have moved your panels around and docked them to accommodate
a particular project or document, you can save your panel arrangement
by choosing Window=>Workspace Layouts=>Save Current and giving your
settings a name. You can then retrieve that layout set-up from the same
location.

\\J

Setting Fireworks Preferences

Setting preferences allows you to customize the way Fireworks handles cer-
tain basic functions and displays certain items. To edit Fireworks prefer-
ences, choose Edite>Preferences or use the keyboard shortcut Ctrl+U.

As you can see in Figure 1-5, the Preferences dialog box has five tabs:

4+ General
4+ Editing
4+ Launch and Edit
4+ Folders
4+ Import



Figure 1-5:
The
Preferences
dialog box.
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Setting General preferences

You can select the General tab on the Preferences dialog box and customize
the following settings:

4+ Undo Steps: Set the value from 0 to 999. This setting affects Edit=>Undo/
Redo and also increases the number of possible steps in the History
panel. Be aware, however, that the more Undo steps you allow, the more
memory Fireworks requires. You must close and relaunch Fireworks to
use the new setting.

4+ Color Defaults: Set the default colors for Stroke (a line or border), Fill
(the inside of a shape), and Highlight (the color that indicates what you
currently have selected). To apply the changes to the default Stroke and
Fill colors in the current document, you have to click the Set Default
Stroke/Fill Colors button in the Tools panel.

4+ Interpolation: Choose one of the four methods that Fireworks can use to
render a change to the image size:

¢ Bicubic Interpolation: The default method, generally yields the
highest-quality results

¢ Soft Interpolation: Blurs the image slightly

e Bilinear Interpolation: Gives a sharpness level somewhere in
between Bicubic and Soft

¢ Nearest Neighbor Interpolation: Sharpens edges

A check box new to Fireworks 8 lets you select Faster but Less Accurate
Resampling. This box is checked by default. For slower but more accu-
rate resampling, uncheck the box. For more details on changing image
size, see Book Ill, Chapter 2.
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188 Setting Fireworks Preferences

4+ Launch options: Select this check box if you want to see the Start Page
when you launch Fireworks; deselect the check box if you don’t want to
see the Start Page.

Editing just the way you want

Select the Edit tab to access these editing preferences in Fireworks:

4+ Delete Objects When Cropping: Leave this check box selected if you
want to delete objects and pixels that fall outside the area to which you
Ccrop your image.

4 Delete Paths When Converting to Marquee: Uncheck this box if you want
a path to remain on the canvas when you convert it to a marquee.

4 Brush-Size Painting Cursors: Select this check box if you want the cursor
size to represent the size of stroke that you are about to make.

4+ Precise Cursors: Select this check box if you prefer to use cross hairs as
a cursor rather than the custom cursors for each tool.

4+ Bitmap Option: Select the Turn Off “Hide Edges” check box if you always
want to see the path selection feedback of a selected object.

4+ Pen Tool Options: You have two options here:

¢ Select the Show Pen Preview check box if you want Fireworks to show
you what your path will look like (before you actually draw the line)
based on the position of your cursor.

e Select the Show Solid Points check box if you want selected points to
appear hollow and deselected points to appear solid.

4+ Pointer Tool Options: You have several options here:

e Select the Mouse Highlight check box if you want an object’s selec-
tion feedback (the box that indicates that an object has been selected)
to activate when you roll the cursor over that object.

e Select the Preview Drag check box if you want to see an object as
you drag it.

¢ Select the Show Fill Handles check box if you want to be able to drag
handles to change the position, width, skew, and rotation of a gradi-
ent fill.

¢ Set the value of the Pick Distance option from 1 to 10 to specify how
close in pixels your cursor needs to be to an object for you to select it.

¢ Set the value of the Snap Distance option from 1 to 10 to specify how
close to a grid or guide in pixels an object must be before the object
snaps to the grid or guide.
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Telling Fireworks how to play with others

You set the Launch and Edit preferences to specify how you want Fireworks
to act when it’s launched from within other applications in the Macromedia
Studio 8 suite.

The options are the same whether you choose options under When Editing
from External Application or When Optimizing from External Application:

4+ Ask When Launching: Select this option if you want Fireworks to ask
you whether or not to edit the PNG source file when you launch
Fireworks from within another application.

4+ Always Use Source PNG: Select this option if you want Fireworks
always to find the source PNG for editing an image from within another
application.

4+ Never Use Source PNG: Select this option if you never want Fireworks to
locate and make available for editing the source file for an image that you
are editing from within another application.

In most cases (with Macromedia Flash being an exception), if you edit an
image by launching Fireworks from within another application, Fireworks
attempts to locate the source PNG file for editing, regardless of the Launch
and Edit preferences.

Expanding your Folder options

Fireworks comes with its own effects, textures, and patterns, but the applica-
tion allows you to access additional materials for use in modifying bitmap
images. Select the Folders tab to gain access to the following:

4 Photoshop Plug-Ins: If you have Photoshop plug-ins that you want to be
able to use in Fireworks, select the Photoshop Plug-Ins check box. Use
the dialog box to browse to the folder that holds those plug-ins.

4+ Textures: If you have additional textures that you want to access from
within Fireworks, select the Textures check box. Use the dialog box to
browse to the folder that has the texture files.

4+ Patterns: If you have additional patterns that you want to access from
within Fireworks, select the Patterns check box. Use the dialog box to
browse to the folder that has the pattern files.

If you change these preferences, you need to quit and relaunch Fireworks for
the changes to take effect.

You can access the effects, textures, and patterns from the Property inspec-
tor when you select an object.
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190 Getting Help

Importing files in a useful form
Set the Import preferences to tell Fireworks how you want to convert
Photoshop (.psd) files for editing in Fireworks:

4+ Layers: You have three options under this heading:

¢ Convert to Fireworks Objects: Select this option if you want Fireworks
to make each Photoshop layer into an object on its own Fireworks
layer.

e Share Layer Between Frames: Select this check box if you want to
share each layer of the Photoshop file across all Fireworks frames.

¢ Convert to Frames: Select this option if you want Fireworks to import
each Photoshop layer as a Fireworks frame. This option can save you
a few steps if the Photoshop file has layers that correspond to anima-
tion frames or button states.

4+ Text: You have three options under this heading:

¢ Editable: Select this option if you want to edit text layers from the
Photoshop file using the Fireworks Text tool. The text may look
slightly different in Fireworks, though it’s close.

e Maintain Appearance: Select this option if you need the text in
Fireworks to look identical to the text in Photoshop but don’t have
to edit the text.

e Use Flat Composite Image: Select this check box if you want to
import the Photoshop file as a flattened, one-layer image.

Getting Help

Fireworks offers several forms of assistance to users. If you can’t find the
answer to your question in this book, you have several good options avail-
able to you:

4+ The Help menu: This menu offers links to appropriate parts of the
Macromedia Web site and an indexed, searchable online manual.

\P
) Press F1 to access the online manual at any time when you’re using

Fireworks. We always go to the online manual first when we need to
figure out how to do something in Fireworks.

4+ Fireworks tutorials: You can use either of two basic Fireworks tutorials,
one on Graphic Design Basics and the other on Web Design Basics. You
can download them from the Web by clicking the “Learn about docu-
mentation resources” link on the Fireworks Start page and then clicking
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the “Tutorials” link in the Macromedia Fireworks 8 Documentation sec-
tion at the top of the page. Then click the Download PDF link to down-
load the appropriate PDF and source files for your platform (PC or Mac).
The tutorials are quick, easy, and very helpful to the novice.

4 The installation CD-ROM: The CD-ROM from which you installed
Fireworks contains a couple of searchable, printable PDF files:

¢ Using Fireworks PDF: Offers the basics

¢ Extending Fireworks PDF: Describes how you can use JavaScript to
control every command and setting in Fireworks

You can copy the PDFs into the Fireworks folder on your hard drive so
that you don’t have to rummage around for the installation CD when you
have a question that this book and the Help menu can’t answer.

4+ Tooltips: Tooltips are built into the Fireworks user interface. Hover the
cursor over an interface element to see a brief description of the ele-
ment’s function or capabilities.

If none of these resources gives you an answer to your question, Macromedia
offers both free Web-based support (including online forums) and fee-based
support via e-mail and telephone.
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Chapter 2: Fireworks 8 Basics

In This Chapter

1 Creating a new Fireworks document
v Switching the view of your document
v~ Saving your documents

v Changing a document’s size

» Understanding color management

In this chapter, we introduce some of the basic processes of working with
Fireworks 8. If you're a regular computer user, many of these processes
are already second nature to you. We show you how to create and save a
Fireworks document, how to change the magnification of your document,
and how to change the size of your document. We also offer an introduction
to some issues regarding the way colors appear on the Web.

Creating a New Document

Before you can start creating or editing cool images with Fireworks, you
need to start the program and either create a brand-new blank document or
open an existing image that you want to change. You can open Fireworks in
several ways:

4 Select Fireworks 8 from the Start menu.

4 Click the Fireworks icon in your taskbar or double-click the icon on your
desktop, if you have either of those options available.

4+ Double-click the icon of an existing Fireworks PNG file.

4+ Double-click the icon of any image associated with Fireworks. (During
installation, you can choose which file types you want to associate with
Fireworks, including GIFs and JPEGs.)

No matter how you open Fireworks, you can create a new Fireworks docu-
ment by following these steps:
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Figure 2-1:
Setthe
canvas size
and canvas
colorinthe
New
Document
dialog box.

1. Choose File=>New or press Ctrl+N.

The New Document dialog box opens, displaying options for the size and
background color of your canvas, as well as the resolution of your docu-
ment, as Figure 2-1 shows you. The settings of the most recently opened
Fireworks document determine the default for all these settings. If you
want to use those settings, simply click OK. Otherwise, continue with
the following steps.

(&) wihite

New Document %]
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2. Type numbers in the Width and Height text fields to set the width and

height of your canvas; use the drop-down list to select whether you
want the width and height of the canvas measured in pixels, inches,
or centimeters.

If you're designing for the Web, pixels work best because pixels are the
basic display units on computer monitors. If you're designing for print,
inches or centimeters may work better.

You can use different units of measurement for the width and height,
although it would probably be more confusing than helpful.

. Set the canvas color.

The default canvas color is white. You can also set the canvas to be
transparent, which can be useful if you're making a graphic that you
want to have a transparent background. If you want your Web page to
use a particular color for the background, click the square to use the
eyedropper and choose a color from the color picker, as you can see in
Figure 2-2.

. Click OK.

Your canvas opens to the specified size and with the specified back-
ground color.
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Changing Views of Your Document

After you start adding stuff to your canvas, you may find that you want to
make adjustments too fine to eyeball with the canvas at 100-percent size.
Fireworks offers several ways for you to increase and decrease the magnifi-
cation of your canvas. Changing the magnification doesn’t affect your docu-
ment’s size, it just changes your view of it, as if you're looking at your
document through a magnifying glass.

To increase the magnification of the canvas so that you can make fine adjust-
ments, use one of the following methods:

+

+

Choose Viewr>Zoom In or press Ctrl+=. Repeat as necessary to achieve
the view that you want.

Choose Viewr>Magnification, and then select a magnification percent-
age greater than 100 percent. If you use this method, you can select
your magnification percentage directly, instead of stepping through each
level. Figure 2-3 shows this selection method.

Click the Magnification drop-down list at the bottom-right of the canvas
and select from the list of preset magnification levels.

Click the Zoom tool in the View section of the Tools panel, and then
click the canvas. If you press Ctrl+Z, you can click and drag the Zoom
tool to zoom in on the selected area of the canvas.

If your canvas is larger than the window in which you’re viewing it, you can
decrease the magnification of the canvas so that you can see the entire docu-
ment by using one of the following methods:

<+

<+

Choose View=>Zoom Out or press Ctrl+-. Repeat as necessary to
achieve the view you want.

Choose Viewr>Magnification, and then select a magnification percent-
age less than 100 percent. If you use this method, you can select your
magnification percentage directly, instead of stepping through each level.
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Figure 2-3:
Changing
the canvas
magnifi-
cation.

4+ Click the Magnification drop-down list at the bottom of the canvas and
select from the list of preset magnification levels.

4 Click the Zoom tool in the View section of the Tools panel, and then
hold down the Alt key and click the canvas. Notice that when you press
the Alt key while you have the Zoom tool over the canvas, the plus sign in
the tool changes to a minus sign to indicate that you can click to zoom out.

You can access several of the most common maghnification levels in one step
with the key commands listed in Table 2-1.

Table 2-1 Magnification Shortcuts
Magnification Percentage Key Combination

50% Ctrl+5

100% Ctrl+1

200% Ctrl+2

300% Ctrl+3

400% Ctrl+4

800% Ctrl+8

1600% Ctrl+6
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You may have read this advice elsewhere, but it bears repeating: Save early
and save often. We can’t think of anything worse than working for hours on
an image, getting it just perfect, and having a power outage or other mishap
wipe out all that work in one cruel second.

Spare yourself the frustration of losing your work and save your documents
often by choosing Filem>Save or by pressing Ctrl+S. When you save a file that
you create in Fireworks using this method, you save the file in the native
Fireworks file format, PNG.

When you open and edit a TIFF, BMP, WBMP, GIF, or JPEG, you can save as
that file type, instead of saving the edited file as a PNG. To exercise the
option, just save by choosing Filer>Save or by pressing Ctrl+S. If you've
added Fireworks-specific elements like slices or frames to your file, a dialog
box appears, asking how you want to save the file. If you save the file as its
original format, you lose any of those Fireworks-specific features.

You can still use the Undo command after you save, so it never really hurts to
save your document. However, if you want to preserve intermediate versions
of a document, you can save versions, instead of saving over your previous
work. If you want to try several different approaches to a design but don’t
want to clog one file with all of the approaches, use the Save As command
and name the file with a slight variation. (For example, if you named your file
homepage . png, you can name a second version homepage_v02 .png.) When
you choose Save As, any changes to the file since you last saved it are saved in
the new version of the file, not the old one.

To save a version of your document, follow these simple steps:
1. Choose Filez>Save or press Ctrl+S to save the file in its current state,
with its current name.
2. Choose Filer>Save As or press Ctrl+Shift+S.
The Save As dialog box appears, as you can see in Figure 2-4.
3. Type a new filename in the File Name text field.

If you have already named the file, the current name already appears in
the text field, so you need to modify the filename in order to save the
current version of the document.

4. If you're editing a non-PNG file and want to save the file in its original
format, use the Save As Type drop-down list to select the format.

5. Click Save.

The new version of the file is now open and ready for modification.
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Figure 2-4:
Use the
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command
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versions of
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Modifying Document Size

You can modify the size of your Fireworks document in two fundamentally
different ways. With these methods, you’re changing the actual dimensions
of the document, not just the magnification of the canvas:

4+ Changing the image size: When you change the image size, Fireworks
re-creates the entire document, including everything on the canvas, at a
different height and/or width.

Changing the canvas size: When you change the canvas size, you don’t
change the size of the objects on the canvas, you only change the size of
the space on which you put the material, as if you cut the top, bottom,
or sides off a printed picture (or pasted extra strips on, if you're increas-
ing the canvas size). You can use the crop tool to reduce the canvas size,
or you can use a dialog box to increase or reduce the canvas size.

Changing the image size

To change the image size of your document, you use the Image Size dialog
box, which you can access by choosing Modify=>Canvas=>Image Size. When
you change the image size of your document, you change the dimensions

of the canvas and of everything on the canvas. If you shrink your image,
Fireworks discards some of the data when it reorders the pixels to make the
image smaller.

If you increase the size of your image, Fireworks interpolates data, which
means it performs sophisticated calculations to decide what color of pixels
to add and where to add them in order to make a larger version of the image.
Although Fireworks interpolates smartly, you can’t avoid some amount of
distortion.
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Using the Image Size dialog box, you can choose which method Fireworks
uses to interpolate or resample pixels:

4+ Bicubic interpolation: Bicubic interpolation is the default method and
generally gives you the highest-quality results with the widest variety of
images by taking an average of the nearest 16 pixels in the original image
size to create a new pixel in the resized image.

4+ Bilinear interpolation: The bilinear method gives a sharpness level
somewhere in between Bicubic and Soft.

4+ Soft interpolation: This method blurs the image slightly. Why would you
want to slightly blur the resized image? Because resizing can result in
visual inconsistencies in the image called artifacts. Blurring the image
takes the edge off the artifacts, rather like a soft-focus lens makes a star-
let’s skin look smoother.

4+ Nearest-neighbor interpolation: This method sharpens edges, so it
works best on images that don’t have subtle gradients. If you use this
method on a bitmap of a sunset, for example, you'll get banding —
noticeable stripes of color instead of a smooth blending of colors.

When you shrink your image, Fireworks discards some pixels and replaces a
few to smooth out the resized image. If you have a 400 x 300 image that you
shrink to 240 x 180, and then you enlarge it back to its original size, the image
that you end up with doesn’t exactly match the original image. However, as
long as you don’t make extreme size changes, you may not notice much of a
difference.

If the Constrain Proportions check box is selected in the Image Size dialog
box, as it is by default, and you change the width in the Pixel Dimensions
part of the dialog box, the height in that part of the dialog box updates
automatically, as do the width and height in the Print Size part of the dialog
box. If you change the image resolution in the Print Size part of the dialog
box, the width and height in both Pixel Dimensions and Print Size update
automatically.

The Pixel Dimensions and Print Size widths and heights are identical, they’re
just being measured with different units. (In the Image Size dialog box, you
can set Pixel Dimensions and Print Size to use the same units of measure-
ment. See below to learn how.)

To change the image size of your document in order to display the image
online, follow these steps:
1. Choose Modify=>Canvas=>Image Size.

The Image Size dialog box appears, with the current image size and reso-
lution as the defaults, as you can see in Figure 2-5.
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Figure 2-5:
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2. Type new numbers in the width and height text fields in the Pixel

Dimensions part of the dialog box to set the new width and height
for your image; use the drop-down list to select whether you want
to change the width and height of the image based on pixels or
percentages.

If you're designing for the Web, you may want to use pixels because pixels
are the standard units of computer monitor display. If you're designing
for print, inches or centimeters may work better. If you want your new
image to have the same aspect ratio (the ratio of width to height, for
example, 4:3 for an image that is 400 x 300 pixels) as your current image,
leave the Constrain Proportions check box selected. A padlock icon at
the right indicates that Fireworks will constrain proportions.

If you want to stretch or squash everything in your image as if it’s being
reflected in a funhouse mirror, deselect the Constrain Proportions check
box and make sure that the new width and height dimensions don’t pre-
serve the aspect ratio of the old width and height. (You can make this
change most easily by changing only height or only width.)

You can use different units of measurement for the width and height,
although doing so doesn’t really give you any advantages.

. Select a method for resampling your image or leave it at the default.

You can read more about resampling settings (Bicubic interpolation or
Soft interpolation, for example) earlier in this section.

. Click OK.

The image resizes.

To change the image size of your document for the purpose of printing it,
follow these steps:
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1. Choose Modify= Canvas~Image Size.

The Image Size dialog box appears, with the current image size and reso-
lution as the defaults.

2. Set the image resolution in the Print Size section of the Image Size
dialog box.

Computer screen resolution is standardized at 72 dots per inch (dpi).
Most printers nowadays print at resolutions of anywhere from 300 dpi
to 2400 dpi. If you'’re designing for the Web and working with a resolution
of 72 dpi, changing the resolution here doesn’t increase the resolution
of any of your bitmaps (that’s kind of like trying to focus a photograph
after you've already taken it), but it ensures that the printout fills the

page properly.

3. Type new numbers in the width and height text fields in the Print Size
part of the dialog box; use the drop-down list to change the measure-
ment units, if you want.

If the Constrain Proportions check box is selected, as it is by default,
and you want the printed image to have the same aspect ratio as the
current image, skip this step and go on to Step 4. You can deselect the
Constrain Proportions check box and type new numbers in the Width
and Height text fields if you want to stretch or squish your image.

You can use different units of measurement for the width and height, Book Il
although doing so doesn’t give you any advantages. Chapter 2

4. Leave the Resample Image check box selected unless you want to I
change the image size by changing the image resolution. g

If you change the image resolution, you change the number of pixels 2—
per inch. =)

o

5. Click OK. .
(1]

«

The image resizes.

Changing the canvas size

Making the canvas size smaller is sort of like removing strips from the out-
side of a drawing or painting. Whatever is on those strips gets discarded
with the strips. In other words, when you reduce the canvas size, you essen-
tially crop or cut out a piece of the image.

To reduce the canvas size, follow these steps:

1. Choose Modify->Canvas~>Canvas Size.

The Canvas Size dialog box opens, as you can see in Figure 2-6. The
default width and height dimensions when the dialog box opens are the
current dimensions of the document.
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Figure 2-6:
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2. Type new numbers for the width and height in the text fields and
select the measurement units for the width and height.

You have the choice, as you do elsewhere, of pixels, inches, or
centimeters.

3. Select the anchor area.

Because you're cutting off part of your canvas, you have to set the anchor
to tell Fireworks which edges of the canvas to discard. You can click

One of the top three squares: Fireworks preserves the top and cuts
off any pixels below the height that you have set in the height text
field.

One of the middle three squares: Fireworks removes the top and
bottom of the existing document.

One of the bottom squares: Fireworks cuts off any pixels above the
height that you have set in the height text field.

One of the left three squares: Fireworks discards any pixels to the
right of the width that you have set in the width text field.

One of the middle three squares: Fireworks chops off the pixels on
either side of the width that you have set in the width text field.

One of the right three squares: Fireworks lops off everything to the
left of the width that you have set in the width text field.

4. Click OK.

The canvas resizes.

If you don’t know what dimensions you want your image to have, but you do
know which area of the current image you want to keep, you can reduce the
canvas size by using the Crop tool. See Book IIl, Chapter 1 for information
about how to use the Crop tool.
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Making the canvas size bigger is like sewing extra strips onto the outside
edges of a canvas. You add space to the canvas without changing the size of
anything already sitting on it.

To increase the canvas size, just follow these steps:

1. Choose Modify~>Canvas->Canvas Size.
A dialog box opens, showing the current document dimensions.

2. Type the new width and height in the width and height text fields and
select the measurement units for the width and height.

You can choose pixels, inches, or centimeters.
3. Select the anchor area.

Because you’re adding an area on to your canvas, you have to set the
anchor to tell Fireworks where to put the new area. You can click

¢ One of the top three squares: Fireworks adds the space to the
bottom of your current canvas.

¢ One of the middle squares: Fireworks adds equal space to the top
and bottom of your current canvas.

¢ One of the bottom squares: Fireworks adds space to the top of your
current canvas.

¢ One of the left three squares: Fireworks adds space to the right of
your current canvas.

¢ One of the center three squares: Fireworks adds equal space to the
left and right of your current canvas.

¢ One of the right three squares: Fireworks adds space to the left of
your current canvas.

4. Click OK.

The canvas resizes.

An Introduction to Color Management

The primary colors of light are Red, Green, and Blue (RGB). All the colors
that you see on a computer monitor are made up of varying amounts of
those three colors. When you work in FreeHand MX, you have the option to
design using CMYK colors (Cyan, Magenta, Yellow, and Black). CMYK is the
process used in traditional offset printing. If you're creating an image that
you want to use for printing, be sure to set a resolution of at least 300 dpi in
the Image Size dialog box before you put any bitmap objects in your Fireworks
document. Better yet, use FreeHand to make the image; you can import the
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image into Fireworks if you want to deploy it on the Web. (See Book III, Chap-
ter 8 for information about integrating Fireworks and FreeHand, and see
Book VI for more about how to use FreeHand.)

Because Fireworks is made for Web design, it only uses the RGB color spec-
trum; all its color options are combinations of red, green, and blue. The
following section explains how you use hexadecimal numbers to create dif-
ferent colors using the RGB color spectrum.

Hexadecimal numbers

When you design a Web page, you select a background color and HTML text
colors. In HTML, hexadecimal numbers — the # symbol, followed by six digits
(from 0 through 9) or letters (A through F) — specify colors. Zero represents
the bottom of the scale (zero luminosity) and F represents the top of the
scale (full luminosity).

The hexadecimal number’s six places operate as three pairs. The first pair
represents red, the second pair represents green, and the third pair repre-
sents blue. For example, to make the background color for your page white,
you write the following code:

<BODY bgcolor="#FFFFFF">

In order to make white, you need to set each color to its highest luminosity,
which is represented by the pair FF. If you want to put black text on your
page, you can use the following code:

<FONT color="#000000">text</FONT>

In order to make black, you need to set each color to its lowest luminosity,
which is represented by the pair 00. If you don’t understand the code in the
examples above, see Book Il on Dreamweaver 8.

The hexadecimal expression of a pure RGB red is #FF0000; a pure green is
#00FF00; and a pure blue is #0000FF. The number of possible colors can
boggle the mind: It’s in the millions. Only a small subset of those possible
colors works on the Web, though.

Web-safe colors

In the early days of the Web, many computer monitors could display only
256 colors. Because 40 of those colors were reserved for the computer’s
operating system or were otherwise off-limits, that left 216 colors available
for use on Web sites: the Web-safe colors. When you set your monitor’s reso-
lution to the 8-bit display option, your monitor can show only that old set of
256 colors. What happens when you look at an image that has colors that
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don’t fall into that set of 256? Your computer approximates the colors it can’t
display either by a process called dithering or by changing the colors to
ones that it can display.

Dithering is the process of combining two or more colors in order to mimic
another color. Offset printing uses a similar process in order to make many
colors out of the four CMYK ink colors. If you look at a color image in a news-
paper or magazine through a magnifying glass, you see that it’'s made up of

many little colored dots. Viewed from a certain distance, those tiny dots
blend together to form what looks like solid colors. For example, you may
see orange with your naked eyes, but if you look closely with a magnifying
glass, you see alternating yellow and magenta dots on that newspaper or

magazine page.

Variability and Web design

One of the most frustrating aspects of
Web design, especially for people trained
in print design, is that you can accurately con-
trol many design elements. Monitor settings
(both in terms of number of colors displayed
and pixel resolution) vary from user to user, and
colors on Macintosh monitors appear lighter
than they do on PC monitors. Users can change
the size of HTML text in their browsers, and
they can drag their browser windows as wide
or narrow as they see fit. Not only that, down-
load rates may be anywhere from about 5K per
second with a 56 Kbps modem, to 20 times that
or more with cable or DSL modems.

As a result, Web design always starts with a
consideration of the end user — the average
person wha's going to visit the site. If your Web
site’s audience is mostly college students who
have high-speed Internet access in their dorms,
or people working in large companies who have
high-speed Internet access at their desks, you
can get away with making image file sizes
larger. You also can assume those people have
their monitors set to 16-bit (thousands of colors)
or 24-bit (millions of colors) because it looks
better and all computers sold nowadays come
with video cards that can display at least 16-bit
color. What you know about your potential end

users affects your choices of colors for page
background, HTML text, and GIFs.

If you have a mix of business users and home
users, you have to make some compromises in
page width, image quality, and other things. If
your users are mostly older, you may want to
make your default text size a little bigger than
average, or you may simply want to design your
page to accommodate a larger text size. Always
try to choose a text color that contrasts fairly
sharply with the background color.

Web designers have a phrase that describes
what you want your design to do so that all users
can have a satisfactory experience on your site:
You want your design to degrade gracefully.
Where you don’t want to compromise quality or
remove features to bring every user’s experi-
ence down to the lowest common denominator,
make sure that users with the least fancy equip-
ment or with disabilities can still access your
important content. For example, blind users have
access to any text on your site via screen reader
software (which reads the text on your site
aloud) or Braille software and hardware. For
more information on accessibility issues and
standards, visit the World Wide Web Consortium
(W3C) Web site at www . w3 . org.

Book IlI
Chapter 2

saiseq g SHI0Mall4



206 An Introduction to Color Management

SMBER
&

When a computer dithers a color, it patterns two colors to create the illusion
of a third color. As with a color photo in a newspaper, this strategy works
only to a limited extent. If you look closely, you can see the pattern. If you
use the dithered color for a line or some small page element, you may not
really notice the dither. If, on the other hand, you select non-Web safe colors
for your page background and/or text colors, people who view your site
using a monitor set to 8-bit may have a difficult time trying to read the text
on your Web site.

If users have their monitors set to 16-bit and they’re looking at a 24-bit color,
they get a dithered color also, but the higher resolution of 16-bit versus 8-bit
means that the computer can choose closer colors, so the dither doesn’t
look as obvious.

The more colors that you have in your image, the larger the file size.

So do you want to use only Web safe colors when you design your Web site?
Isn’t that terribly limiting? After all, designers didn’t choose the Web safe
colors, and you can find some really ugly ones in the bunch!

Go ahead and use non-Web safe colors, but think about what you’re using
them for and whether the people visiting your site may only be able to see
them dithered.

In the early days of the Web, when most Web surfers had 8-bit monitors and
used early browsers, designers predithered all their images. That way, images
looked essentially the same to all users, whether the users had 8-bit displays
or 16-bit displays. Nowadays, browsers have become more sophisticated,
and average computer owners can afford monitors that display at 16-bit and
higher. As a result, designers have decided that in certain cases, it’s better to
allow inconsistency in the realm of display in order to offer higher image
quality to better-equipped users.

In keeping with tradition, though, Fireworks still uses the Web-safe color
palette as its default in the color picker.

In the next chapter, we get into the nitty-gritty of applying all this color stuff
to the reallife situations of choosing colors for page backgrounds, HTML
text, and the like.



Chapter 3: Working with Text,
Shapes, and Images

In This Chapter

v~ Entering and editing text
v+ Creating and changing shapes
+* Working with bitmaps

In this chapter, we explore the power that Fireworks 8 gives you to write
and edit text, make and manipulate vector shapes, and create and mutate
bitmap images. You may sometimes feel a little overwhelmed by the control
that you have with Fireworks. But Fireworks has a limited number of tools,
and the concepts behind the tools are simple. And whether you have a clear
idea about what you want or you're interested in experimenting, Fireworks
suits your needs.

Working with Text

Text is the most common element on most Web pages, much as text is the
most common element in magazines and newspapers. Unlike with printed
material, however, users can alter the size and appearance of HTML text to
a certain extent. Some of the most important decisions that you make in
building your Web site involve how you present text on the screen. In gen-
eral, a finished Web page has two kinds of text:

4+ HTML text: The text that you see on the Web page that you create with
HTML. This type of text is akin to the text in word-processing software,
such as Microsoft Word.

4+ Graphic text: The text that’s embedded in an image, such as a JPEG or a
GIF file. In other words, it’s a picture of text.

Which method of presenting text works better for you and people viewing
your Web site depends largely on the function of the text.

Some advantages of using HTML text include the following:

4+ HTML text is smaller (in kilobytes) and therefore loads faster in a user’s
Web browser.
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4 Visitors can vary the size of the text by changing settings in their
browsers.

4+ Special software and hardware (in the case of Braille) can make HTML
text available to visually-impaired users via audio or touch.

4+ Visitors to your site can select, copy, and paste HTML text into e-mails
or word-processing documents, which can help spread the word that
you're trying to get out via your Web site.

On the downside, HTML text can use only very basic fonts — those fonts
that all computers have, notably Arial and Times — and you can present
HTML text in only a limited number of ways.

Graphic text, in contrast, is much more visually dynamic than HTML text
because it’s part of an image. You commonly find graphic text used for but-
tons and banners, which need to grab the user’s attention. Some of the key
advantages to using graphic text include the following:

4+ You can create text using any font that you have installed on your
computer.

4+ You can apply a lot of different effects to text, like glows and shadows
(both conventional drop-shadows and the new shadow auto shapes).
See Book III, Chapter 4 for details. You can also run text along a path —
sideways, diagonal, or even curved! We show you how in the “Aligning
text along a path” section.

4+ You have greater control of things like leading (the spacing between
lines of text) and kerning (the spacing between letters).

Of course, using graphic text also has drawbacks. Users can’t copy and
paste text from graphic text, for example. Also, because the graphic text is
part of an image, the size (in kilobytes) of the text is larger than that of plain
HTML text.

Remember, always use an ALT tag for graphic text. The ALT tag says what
the graphic text says, so visually-impaired users have access to it.

Regardless of the kind of text that you want to create, Fireworks can help. The
following sections show how you can use the Fireworks text editing tools to
create text as part of an image, as well as export text in HTML format.

If you want to include your main HTML text in your Fireworks document, or
if you want to use placeholder text that you eventually replace with final
HTML text later in Dreamweaver, use the Fireworks text default, 12-point
Arial or Verdana (with no anti-alias), in your page design. Using one of those
settings gives you a good approximation of how the text looks on the HTML
page that you make from your design.
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Creating text with the Text tool

You can create text with Fireworks in a snap, which really helps you out
because you do a lot of text-creating when you make images and page mock-
ups. To create some text, just follow these three easy steps:

1. Select the Text tool by clicking the capital A in the Vector section of
the Tools panel.

An I-shaped pointer appears, as you can see in Figure 3-1.
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2. Move the pointer to the point on the canvas where you want to create
the text.
3. Click the canvas and type away.
You can always move the text later, as well as change its font or color. We
cover those details later in this chapter.
‘8\ 10
) If you need to insert a special character, like a dollar sign or letter with an

accent mark, simply place the cursor in the text block where you want the
8 character to go and click the character in the Special Characters panel.
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If the text you want to add already exists in a word-processing program,
open the text document, select the applicable text, and copy it. Then select
the Text tool in Fireworks, click the canvas, and press Ctrl+V to paste the
text. Your text appears in the default font.

If you're pasting text into your Fireworks document, set the width of the text
box before you paste the text in. The default Fireworks text box expands out-
ward to the right rather than downward. To set the width of the text box,
select the Text tool from the Tools panel and click and drag diagonally on
the canvas to create a text box of the right size. If your text is too long to fit
in the box that you create, the box expands downward automatically.

Selecting a font and changing its size

After you create a snippet of text, you can select it for editing in one of three
ways:

4+ After selecting the Text tool, select the text that you want to edit by
clicking and dragging to highlight just the desired text.

4+ Using the Pointer tool, double-click the text that you created. Doing so
activates the Text tool and makes the text available for editing.

4+ Using the Pointer tool, click the text that you created. Doing so selects
the entire text box. When you edit the text settings in the Property
inspector, Fireworks applies the changes to all the text in the box.

After you select text, the Property inspector switches automatically to show
the available text properties that you can apply to your selected text, includ-
ing bold, italic, various text alignments, and effects like drop-shadow and glow.

You can change your text to a different font in one of two ways:

4+ Choose a font from the drop-down list (the list displaying the default
font, Arial on the PC and Geneva on the Mac) in the Property inspector.
The drop-down list displays all the fonts that you have in your machine
in alphabetical order. As you scroll through the list, the list displays the
name of the selected font using the font face itself, so you can quickly
see what each font looks like. Figure 3-2 shows you what the Property
inspector looks like when you select text.

4+ Choose Text=>Font and then select from the list of fonts that appear on
the screen.

If you have tons of fonts and your favorite is way down on the list, you can
skip to it by clicking in the scrolling drop-down list in the Property inspector
and typing the first letter of the font name on your keyboard. This action
jumps you to the first font available with that letter. You can then press the



Figure 3-2:
The
Property
inspector
puts all your
text options
within one
click.

Figure 3-3:
Use the
handy size
slider to set
your font
size.
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down-arrow key to find the font that you're looking for. Press Enter to apply

the font to the selected text. Unfortunately, the Mac version doesn’t have this

feature.
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After you select a font, you can change its size in no time at all. You can
change a font size in Fireworks in one of two ways:

4+ Use the Size field: The Property inspector contains a field indicating the
current size of the font that you're working with. To change the text size,
simply type in the text field the point size that you want and press Enter.

4+ Use the Slider: Click and hold the arrow at the right of the Size field and
then slide it up. The text size increases. Similarly, slide it down and the
text size decreases (see Figure 3-3).

w Propertios
Text Al v = !
hel |40 =]

I U [ 100 | weral -
v T e v = = Pl 4
wilze | mie [0 [/ =(0 -
L HET Yol

tmoach rkedliss

] utn kem

v S

£ 1o vl =0 e

Adding a little color

By default, all text in Fireworks is black. Although black is handy and always
in fashion, you don’t want to use it for every occasion. You can pretty easily
change the font color in Fireworks. To change your color the basic way, just
follow these steps:
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Figure 3-4:
Use the
eyedropper
to choose a
colorin the
color picker.
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1. Select the Text tool and place the cursor next to the first word that

you want to change the color of. Click and drag until you select all the
text that you want to make a different color.

Alternatively, if you're using the Pointer tool, click the text to select it.

. Click the Color box to open the color picker.

The color picker appears on-screen, showing only Web safe colors by
default (see Figure 3-4). Your mouse pointer changes to an eyedropper
when you roll over the palette. (You can read more about the System
Color Picker, which offers other color options, later in this section.) You
can move the eyedropper anywhere within the Fireworks window.

Fil Options...

. Using the eyedropper, click a color.

The square now becomes the color that you select for your text. More
importantly, your selected text becomes that color, as well. If the text
appears to be a different color than the square, you still have the text
highlighted. Click anywhere on the canvas or click any tool to deselect
the text and see the color applied to the text.

If you don’t feel like moving your mouse all the way to the bottom of the
screen, you can also change the color of your font by using the Colors area
of the Tools panel or by using the new Colors panel. They work the same
way as the color picker in the Property inspector, so feel free to use whichever
one you find most convenient.

The color picker contains a number of different views. The default view uses
Web safe color cubes. You can switch views by clicking the right-facing trian-
gle in the top-right corner of the color picker and then selecting a new view
from the list that appears. The other views include the following:

4+ Swatches panel: Displays your saved colors. If you have any saved colors,

they show up here. If not, the panel displays the Web safe palette.

4+ Continuous tone: Shows the colors as they move from lighter to darker

left to right across the color picker. You can find all these colors in the
Web safe color cubes, just arranged differently.



Figure 3-5:
The System
Color Picker
offers more
options than
the color
picker.
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4 Windows OS: Shows the 217 Web safe colors that are also the Windows
operating system colors.

4 Mac OS: Shows the system colors for the Mac operating system.

4+ Grayscale: Provides a range of grays from light to dark. Be warned
though, only six grayscale colors are Web safe!

What if the color you want isn’t in the Web-safe palette? Well, thankfully,
Fireworks gives you a number of different coloring options. On the top of

the palette, you can find the System Color Picker (the color wheel near the
middle of the top of the color picker). You can click the System Color Picker
to see your other color options. The System Color Picker offers several other
ways for you to choose a color (as you can see in Figure 3-5):

4+ RGB values: Red, Green, and Blue make up all the colors that you can
see on-screen.

4+ Hue, Saturation, and Luminosity values: A different way of telling the
computer how to combine red, blue, and green.

4+ The color matrix: A visual representation of the Hue (the horizontal
axis), Saturation (the vertical axis), and Luminosity (the extra strip on
the right) values.
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Using the color matrix gives you the most flexibility in choosing a color
because you can visually pick precisely the color that you want. Here’s how
you use the color matrix to change the color of selected text:

1. Select the Text tool and place the cursor next to the first word that
you want to change the color of. Click and drag until you select all the
text that you want to make a different color.

Alternatively, if you're using the Pointer tool, click the text to select it.
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2. Click the Color box to open the color picker.

3. From the top middle of the color picker, select the System Color
Picker.

The Color dialog box appears, as you can see in Figure 3-5.

4. Place your cursor over the color that you want and click the mouse
button.

You see a cross hair where you click. At the center of the cross hair, you
can see the color that you choose. The higher you go in the matrix, the
more saturated the color becomes. If you want to make the color darker
or lighter, click the shade that you want in the Luminosity bar next to
the matrix, or click and move the slider to the right of the shade. At this
point, you still haven’t changed the color of the text on the canvas.

5. Click OK to apply the color to your text.
The text you selected on the canvas changes to the color that you
selected in Step 4.

If you want to use a color frequently, click the Add to Custom Colors button on
the lower right after you select your custom color. That way, whenever you
need to use that color, you can click its square in the color picker instead of
having to remember its RGB values or trying to find it in the color matrix.

Manipulating text

After you type or paste your text, you can change anything about it, from its
color to its position on the page. You change the color exactly the same way
that you apply the color in the first place, and you can just as easily edit,
move, and delete text.

Inserting text
To insert text, just follow these steps:
1. Choose the Text tool from the Tools panel.
An I-beam-shaped cursor appears.
2. Click the place in the text box where you want to add text.
A blinking vertical line indicates where you will insert your new text.

3. Start typing or paste text (Ctrl+V) that you have copied from elsewhere.



Figure 3-6:
Selecting
textin a text
box.

Deleting text

To delete text, do the following:
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1. Choose the Text tool from the Tools panel.

2. Click the place in the text box where you want to delete text.

3. Click and drag over the text you want to delete.

The selected text is highlighted, as you can see in Figure 3-6.
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