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Welcome to Microsoft Expression Web: Visual
QuickStart Guide. This brand-new program
offers a powerful array of visual tools for cre-
ating great looking sites while fully support-
ing Web-based standards. Standards may not
be sexy but they’re the driving force behind
so many of the collaborative “Web 2.0” sites.
As a collaborative tool, Expression Web helps
Web designers and coders work together.

Expression Web makes it easy for designers
to quickly design cool sites with tools that
feel familiar. Thanks to Expression Web’s
underlying standards, you can pass those
files over to coders, who can easily work on
them in the development tools they prefer.
When they’re done, they can pass the work
back to you and Expression Web without a
hitch. Seamless back and forth—without
your ever needing to touch the under-the-
hood coding. (If you want to crawl into the
XHTML, CSS, XML/XSLT, and schema, it’s
there. But the nice thing is that with
Expression Web you don’t have to.)
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Standards but Cool Too
Does all this talk about standards sound too
much like oat bran and vitamins? OK, let’s
cut to the chase: In my opinion, Expression
Web comes with the market’s best set of style
sheet tools—and I’ve long used Dreamweaver
for my own sites (Figure i.1). For example,
Expression Web lets you click and drag to
change the margins and padding of elements
in your layout (Figure i.2). Can’t figure out
why one of your style changes doesn’t seem to
stick? No need to dig through the W3C’s
specs for Cascading Style Sheets. Expression
Web’s CSS Properties tab shows you exactly
where the cascade of formatting rules is
thwarting your intentions (Figure i.3). Ever
tried to keep straight your internal and exter-
nal styles? Expression Web makes it a click-
and-drag affair (Figure i.4).
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Figure i.1 What you
see is what you get:
Quickly find and
apply a CSS style.

Figure i.3 The CSS Properties tab shows you
exactly where the cascade of formatting rules is
thwarting your styling intentions.

Figure i.4 Want to move internal styles to an external
style sheet? Again, it’s click and drag.

Figure i.2
Expression Web
offers click-and-
drag control over
padding and 
margins.



What About FrontPage?
If you’re one of the many people who built
your site using FrontPage, rest assured.
Expression Web can open FrontPage sites
without a hiccup. Because FrontPage uses so
many nonstandard tools and bots, however,
there will be migration issues. (For details,
see “Bite the Bullet” on page 26.) But
FrontPage veterans will quickly become
comfortable in Expression Web’s new digs. It
probably won’t be long before you start
depending on the new tools not found in
FrontPage. In fact, Expression Web is just the
first of a whole suite of new Web tools com-
ing from Microsoft in 2007. Expression Blend
uses Microsoft’s new .NET Framework 3.0 for
creating interactive designs. Expression
Design offers illustration and graphic design
tools for the Web and desktop. Expression
Media, based on iView MediaPro, helps you
manage your digital assets. Start with
Expression Web. Who knows where your
designs will take you.
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Using This Book
The key to this book, like all of Peachpit’s
Visual QuickStart Guides, is that word visual.
Using more than 600 screenshots, this book
guides you step by step through creating
your Web pages and site. Succinct captions
explain all of Expression Web’s major func-
tions and options. Ideally, you should be able
to quickly locate what you need by scanning
the page tabs, illustrations, and captions.
Once you find a relevant topic, dig into the
text for the details.

After showing you how to set up Expression
Web to match your own way of working, the
book gives you an overview of why you
should focus on building a Web site rather
than simply start making a single Web page.
A big part of that approach involves using
templates and CSS. I explain how you can
use both to create a site that can smoothly
grow larger over time—without drowning
you in the scut work of constantly updating
individual pages.

With that foundation under your belt, you
can quickly start adding text and images to
your pages and linking them together. Two
detailed chapters on CSS then walk you
through how to style and position all that
content to look terrific. By then, you’ll be
ready to dive into adding interactive behav-
iors and forms to give your site some polish.
Oh, and publishing it all for the world could-
n’t be simpler. Really.
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Tips
At the end of many tasks, you’ll find tips on
how to save time or use the many options
tucked into Expression Web. Other features
you’ll find throughout the book include:

◆ Code font: When a word or words appear
in code font, it’s used to indicate the lit-
eral text you need to type in to Expression
Web. For example: In the text window,
type http://localhost and press e .
Web addresses are also in code font.

◆ Menu commands and keyboard
shortcuts: Menu-based commands 
are shown as: Choose File > Open Site.
Keyboard-based shortcuts (when avail-
able) are shown in parentheses after the
first step in which they can be used. For
example: (cT) means that you can
press the c and T keys at the same
time to create a thumbnail version of 
an image.

◆ Cutouts in figures: Sometimes a
Expression Web dialog box is so big that
it can be hard to fit on the page with all
the other figures and still leave it large
enough to read. In those cases, I may trim
away all but a small piece of the dialog
box to save space (Figure i.5). Nothing
critical to understanding the step is ever
left out. And it sure beats running teeny,
tiny figures.

xiii
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Figure i.5
Sometimes a dialog
box will be trimmed
to fit in a figure, but
essential details are
always there.



Looking forward: Stay in touch
For Expression Web updates and patches,
make a point of regularly checking Expression
Web’s site: http://www.microsoft.com/
products/expression/.

This book’s companion Web site has lots
more tips and tricks based on real-world
tasks. As a brand-new program, Expression
Web has a big future ahead of it, and I’ll 
try to keep us all up to date on those
changes, large and small. So drop by
www.waywest.net/expression/ when you 
can. You’re also welcome to write me
directly at expression@waywest.net with
your own tips or—heaven forbid—any 
mistakes you may have spotted.

Good reading—and have a great Web site!
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Whether you’re running Windows XP or
Windows Vista, you’ll immediately recognize
many of the interface features of Microsoft
Expression Web. As with any program, 
however—especially a brand new one—
you’ll save yourself hours of later frustration
by taking a quick look now to get an overall
feel for Expression Web. So before you dive
into creating Web pages and Web sites, 
let’s explore its major windows, panes, and
toolbars.

1

Exploring
Expression Web
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Opening and Closing
Expression Web
For step-by-step information on creating
new Web pages and sites, see Chapter 2 on
page 15. For now, we’ll just open Expression
Web and take a look around.

To open Expression Web:

◆ Click the Start menu, and choose
Microsoft Expression Web from the pop-
up list (Figure 1.1). When the program
launches, a single blank page appears.
You can then begin adding items to that
page or open existing Web sites or pages.

To close Expression Web:

◆ Choose File > Exit. If you have not saved
all your pages, Expression Web will ask if
you want to save the changes. Click Yes to
save them, and the program will then quit.
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Figure 1.1 To open the program, click the Start menu
and choose Microsoft Expression Web.



Using the Main Window
Expression Web’s main window tidily dis-
plays most of the items you’ll need day to day
(Figure 1.2). In the center, the Editing win-
dow shows all your open documents,
arranged in tabs. Task panes and toolbars
flanking the Editing Window put your most
commonly used tools a click away. You also
can display or hide other panes and toolbars
as you need them.

◆ Web site files (upper left, Figure 1.2):
All of the current site’s files and folders
are displayed in the Folder List, one of
four default task panes. The folder and
page buttons in the pane’s title bar make
it simple to create new files right within
the main site folder.

(continued)
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Current CSS
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Figure 1.2 Expression Web’s main window includes most of the items you’ll need day
to day, with plenty of options for customization.
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◆ Editing window (center, Figure 1.2):
Tabs across the top denote open Web files
and sites, enabling you to jump from file
to file with a single click. As shown, the
window is set to Design view, which hides
all HTML and CSS coding. Code view
shows only coding, while Split view lets
you see both—an efficient compromise.

◆ Task panes (top right and bottom left,
Figure 1.2): By default, two task panes
run down the left of the Editing window
and two down the left. For more infor-
mation, see “Using the Task Panes” on
page 7.

◆ Status bar (bottom, Figure 1.2):
Running across the bottom of the win-
dow, the Status bar provides quick access
to many HTML and CSS settings. Visual
Aids help you work with usually hidden
aspects of your pages. (For more informa-
tion, see “Using the Visual Aids” on page
14.) Normally set to Auto with default
schemas of XTML 1.0 Transitional and
CSS 2.1 (the industry’s current best-com-
promise choices), the Style Application
can be changed with a double-click and
choosing Manual from the toolbar that
appears (Figure 1.3). Then you can dou-
ble-click the Standard button to reach
the Page Editor Options dialog box, where
you can choose other schemas (Figure
1.4). Click the button if you need to
change the standard width for your Web
pages. (For more information, see
“Setting Page Size” on page 6. The last
two items, the current HTML and CSS
schemas, show the settings in the Page
Editor Options dialog box.
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Figure 1.3 The Style Application, normally set to Auto,
can be switched to Manual using the toolbar’s drop-
down menu.

Figure 1.4 The Page Editor Options dialog box gives
you complete control over Expression Web’s default
settings.



To switch Editing window views:

◆ By default, Expression Web opens in the
Split view, with Code view at the top of
the Editing window and Design view at
the bottom (Figure 1.5). To switch out of
this combination view, click the Design or
Code buttons at the bottom-left of the
Editing window (Figure 1.2).

or

◆ Use the keyboard shortcuts cu

and cy to cycle to the view you
want.

or

◆ Choose View > Page, and make a choice
in the drop-down menu (Figure 1.6).

✔ Tip

■ Whether you’re a champion coder or
designer who hates to see all that wiring,
working in Split view helps you learn
exactly how the code and design ele-
ments fit together.

To switch among open pages:

◆ At the top of the Editing window, click
the tab of the page you want to see
(Figure 1.7). Or cycle through the tabs
using the keyboard shortcuts: ct

and cst .
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Figure 1.5 By default, Expression Web opens in the
Split view, with the Code view above the Design view.

Figure 1.7 In the Editing window, click the tab of the
page you want to see.

Figure 1.6 To switch your page
view, choose View > Page and
make a choice in the drop-
down menu.



Setting Page Size
Not so long ago, most Web designers built
their layouts around a standard page width
of about 750 pixels. As more and more home
users have shifted to higher-resolution moni-
tors, however, designers are shifting to a
standard page of about 960 pixels. Whatever
size you favor, Expression Web lets you easily
set the dimensions of your Web pages.

To change the page size view:

◆ At the bottom-right of the status bar,
click the and choose another setting
from the drop-down menu (Figure 1.8).
Or choose View > Page Size and pick 
a setting in the drop-down menu 
(Figure 1.9). Release the cursor and 
the new size is applied immediately.

To modify a page size:

1. At the bottom-right of the status bar,
click the and select Modify Page Sizes
in the drop-down menu (Figure 1.10). Or
choose View > Page Size > Modify Page
Sizes.

2. The Modify Page Sizes dialog box lists
Expression Web’s current page sizes.
Choose the listing you want to change,
and click Modify (top, Figure 1.11).

3. In the Page Size dialog box that appears,
use the Width and Height input boxes to
change the settings (bottom, Figure
1.11). Click OK to close the dialog box,
and then Click OK to close the Modify
Page Sizes dialog box as well. The new
size replaces the previously listed size 
in the Status bar’s drop-down menu
(Figure 1.12).

✔ Tip

■ You can return to the original settings
any time by clicking Reset in the Modify
Page Sizes dialog box (top, Figure 1.11).
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Figure 1.8 In the status bar, click the and choose
another setting from the drop-down menu.

Figure 1.9 You also can choose
View > Page Size and pick a set-
ting in the drop-down menu.

Figure 1.11 In the Modify Page Sizes dialog box,
choose a size in the list and click Modify (top). Use
the Width and Height boxes to change the settings,
and click OK to apply them (bottom).

Figure 1.10 To
change the avail-
able choices,
choose Modify
Page Sizes in the
drop-down menu.

Figure 1.12 The
new size replaces
the previously
listed size in the
drop-down menu.



Using the Task Panes
By default, Expression Web displays four task
panes: Folder List, Tag Properties, Apply
Styles, and Toolbox. You can, however, dis-
play any of the 18 task panes, resize them as
you please, and Expression Web will make
that arrangement your default setup the next
time the program opens.

Horizontal lines break the task panes drop-
down menu into four groups (not including
Reset Workspace Layout at the bottom
(Figure 1.13). By default, items grouped
together in the drop-down menu, such as
Apply Styles and Manage Styles, will appear
as separate tabs in the same pane. However,
you can drag any tab into a pane of its own.
(See “To rearrange task panes” on page 9.)

To open a task pane:

◆ From the Menu bar, choose Task Panes
and the drop-down menu highlights the
panes already open. To open another
pane, select it in the drop-down menu
(Figure 1.13). The selected pane appears,
or a tab for it is added to an existing pane
(Figure 1.14).

To close a task pane:

◆ Click the X button in the top-right corner
of any tab or pane. The pane closes
immediately.

✔ Tip

■ The Folder List pane can be toggled sepa-
rately from the other panes by choosing
View > Folder List or by pressing a1 .
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Figure 1.13 To open another
pane, choose Task Panes and
select it in the drop-down
menu.

Figure 1.14 The selected
pane appears, or a tab for it
is added to an existing pane.



To switch tabs within a pane:

◆ Click any visible tab to make it active in
the task pane, as indicated by the pane’s
title bar changing (Figure 1.15).

or

◆ If there are too many tabs within a task
pane to see the one you need, click either
arrow just below the title bar to scroll left
or right to reach the desired tab (Figure
1.16). Then you can click that tab to
make it active.
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Figure 1.15 Click any tab to make it active in the task
pane, as indicated by the title bar changing.

Figure 1.16 If the task pane has too many tabs to see
at once, use the arrows to scroll left or right.



To rearrange task panes:

◆ Click in the title bar of any task pane and,
without releasing your cursor, drag it any-
where on your screen to create a free-
standing task pane (Figure 1.17).

or

◆ Click in the title bar of any free-standing
task pane and, without releasing your
cursor, drag it to either side of the Editing
Window (Figure 1.18). As the free-
standing pane moves close to the nearest
docked pane, it snaps into the docked
pane (Figure 1.19).

or

◆ Right-click in the title bar of a docked
task pane, and choose Float from the
drop-down menu (Figure 1.20). The task
pane pops out of its docked position, sur-
rounded by a dark border (Figure 1.21).
You then can reposition and resize the
pane to suit your needs (Figure 1.22).
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Figure 1.17 To
create a free-
standing task
pane, click in
the pane’s title
bar and drag it
anywhere on
your screen.

Figure 1.22
You then can
reposition and
resize the pane 
as needed.

Figure 1.18 To redock a
freestanding task pane,
click in its title bar and,
without releasing your
cursor, drag it to either
side of the Editing
Window.

Figure 1.19 As a free-standing pane
moves toward a docked pane, it
snaps into the docked position.

Figure 1.20 Right-click in the
title bar of a docked task
pane, choose Float from the
drop-down menu, and…

Figure 1.21 …the task pane
pops out of its docked posi-
tion, surrounded by a dark
border.



To restore the default pane positions:

◆ Choose Task Panes, and in the drop-down
menu select Reset Workspace Layout
(Figure 1.23). Expression Web closes all
but the four default task panes and places
them back on each side of the Editing
window.

To expand or collapse docked task
panes:

◆ Click the small box button in the title bar
of any pane with a long list of items, and
the pane will expand to show more items
(left, Figure 1.24). Click the button again
to collapse a pane to its original compact
form (right, Figure 1.24).

or

◆ Right-click in the title bar of the pane,
choose Maximize from the drop-down
menu, and the pane expands to show
more items (left, Figure 1.25). Right-
click in the title bar again, choose Restore
from the drop-down menu, and the pane
collapses to its original compact form
(right, Figure 1.25).
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Figure 1.23 To restore the default
pane positions, choose Task
Panes and select Reset
Workspace Layout.

Figure 1.24 Click the small box button in
the title bar to expand a pane (left). Click
the button again to collapse a pane (right).

Figure 1.25 Right-click in the title bar and
choose Maximize to expand a pane (left).
Right-click in the title bar again and
choose Restore to collapse a pane(right).



✔ Tips

■ Expression Web’s Toolbox pane, which
contains more items than any other task
pane, offers a way to see more of its con-
tents without simply expanding it.
Instead, right-click in the pane’s title bar
and choose Icons Only from the drop-
down menu (left, Figure 1.26). The icons
require less display space than icons with
names, so you can see more at a glance
(right, Figure 1.26). When you first start
using Expression Web, you may need the
names to know what the icons represent.
But it doesn’t take long to learn them, at
which point you can switch to the more
compact Icons Only view.

◆ You can fine-tune your view of the
sprawling Toolbox pane as needed. Right-
click in the title bar and choose Collapse
All or Expand All to quickly compress or
expand all the Toolbox pane’s category
listings (Figure 1.27). To collapse a single
category, click the - left of the boldfaced
category name (left, Figure 1.28). The
listings disappear, leaving on the category
name (right, Figure 1.28). To reveal a 
single category’s listings, click the + .
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Figure 1.28 To collapse a single category,
click the - left of the bold-faced category
name (left). To reveal a single category’s
listings, click the + (right).

Figure 1.26 To see more of the Toolbox
pane without expanding it, right-click in
the title bar and choose Icons Only (left).
The icons take up less space, so you can
see more at a glance (right).

Figure 1.27 Right-click in the tool-
box’s title bar and choose Collapse
All or Expand All to quickly com-
press or expand all the Toolbox
pane’s category listings.



Using the Toolbars
Expression Web’s 11 toolbars offer quick
access to virtually every command you’ll ever
need. But having all of them visible at once
would be a mess, so only the Common tool-
bar appears by default and offers, as the
name suggests, the most commonly used
commands. Much like the task panes, the
toolbars can be repositioned and resized to
suit your needs. Individual toolbars are
explained throughout the book as the need
for them arises.

To add a toolbar

◆ From the Menu bar, choose View >
Toolbars and choose a toolbar from the
drop-down menu (Figure 1.29). The
selected toolbar appears docked above
the Editing window. (Toolbars already
open appear with a check on the left side
of the drop-down menu.)

✔ Tip

■ You also can open any toolbar by right-
clicking in the title bar of an already open
toolbar and making a choice in the drop-
down menu that appears.

To close a toolbar

◆ Click the X button in the top-right corner
of any toolbar. The toolbar closes imme-
diately.

or

◆ From the Menu bar, choose View >
Toolbars and choose a toolbar that’s
already checked in the drop-down menu
(Figure 1.30). Release your cursor and
the selected toolbar closes immediately.
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Figure 1.29 To add a toolbar, choose 
View > Toolbars and pick a toolbar in
the drop-down menu.

Figure 1.30 To close a
toolbar, choose View >
Toolbars and pick a
toolbar already checked
in the drop-down menu.



To move a toolbar

◆ Move your cursor to the left end of the
toolbar until it becomes a four-headed
arrow (top, Figure 1.31). Click and drag
the toolbar to its new position (bottom,
Figure 1.31), which can be a freestand-
ing box, a spot down the left-side of the
main window, or above or below its pres-
ent spot among the toolbars above the
Editing window. Release the cursor and
the toolbar stays in its new position.

To resize a toolbar

◆ Move your cursor to any edge of a toolbar
until the cursor becomes a two-headed
arrow (top, Figure 1.32). Click and drag
the arrow and then release the cursor to
enlarge or shrink that boundary of the
toolbar (bottom, Figure 1.32).

To redock a toolbar

◆ Click in the toolbar’s title bar or any 
blank area within the toolbar. When the
cursor becomes a four-headed arrow,
drag the toolbar toward the other tool-
bars docked above the Editing window
(top, Figure 1.33). As the freestanding
toolbar approaches the already docked
toolbars, it snaps into position (bottom,
Figure 1.33).
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Figure 1.31 To move a toolbar, move your cursor to the
left end of the toolbar until it turns becomes a four-
headed arrow (top). Then click and drag the toolbar to
its new position (bottom).

Figure 1.33 To redock a toolbar, click in the title bar
and drag the toolbar toward the others docked above
the Editing window (top). As the freestanding toolbar
approaches the already docked toolbars, it snaps into
position (bottom).

Figure 1.32 To resize a toolbar, move your cursor to
any edge of a toolbar until the cursor becomes a two-
headed arrow (top). Click and drag the arrow and then
release the cursor to enlarge or shrink that boundary
of the toolbar (bottom).



Using the Visual Aids
When you’re working in Design or Split view,
Expression Web offers you the option of dis-
playing normally invisible elements. For
example, it’s much easier to adjust your lay-
out when you can see the padding or margin
for a particular element. You can select
exactly which aids you want turned on and
then show or hide them all at once.

To show or hide the visual aids:

◆ From the Menu bar, choose View > Visual
Aids > Show (Figure 1.34). Repeat to
hide the aids.

or

◆ Use press c+/ to show or hide the
aids.

or

◆ In the Status bar, double-click Visual Aids
to switch from show to hide, or vice versa.

To turn on or off each visual aid:

◆ Once you activate the Visual Aids feature,
choose View > Visual Aids and click each
item you want made visible. You can turn
on (or off) multiple items with a click, 
as long as your cursor remains in the
drop-down menu (Figure 1.35). Move
your cursor out of the drop-down menu
area, and the aids you selected will turn
on or off.
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Figure 1.34 To show the visual aids, choose View >
Visual Aids > Show. Repeat to hide the aids.

Figure 1.35 To turn on or off each visual aid, choose
View > Visual Aids and click on each item you want
made visible.



No doubt you’re eager to begin creating Web
pages, but hold up. More than likely, your real
goal is to create a Web site of pages that
share a similar look and a common naviga-
tion system. And that’s a lot harder to do
using a one-page-at-a-time approach. So this
chapter starts by showing how to create a
blank, one-page site. Then the rest of the
chapter focuses on how to create a unified,
multiple-page site using Expression Web’s
templates, which are based on Cascading
Style Sheets (CSS). That approach offers two
bonuses: your pages display faster and more
reliably, plus it’s way easier to update them as
your site grows. For more information on
creating individual Web pages, see Chapter 3
on page 33.

15

Creating Sites
2
Creatin

g
 S

ites



To create a new blank Web site:

1. Choose File > New > Web Site 
(Figure 2.1).

2. In the New dialog box that appears,
General is automatically selected so in
the middle pane choose One Page Web
Site (or Empty Web Site) (Figure 2.2).

3. By default, Expression Web offers to save
the site at …\UserName\Documents\ and
name it My Web Sites (in Windows Vista)
or mysite (Windows XP). Instead, con-
sider clicking Browse and navigating to a
place outside the Documents folder, per-
haps on a separate hard drive (see “Where
to Save Local Sites?” on page 17). Once
you select or create a new folder in the
New Web Site Location dialog box, click
Open (Figure 2.3).
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Figure 2.1 To create a new blank Web
site, choose File > New > Web Site.

Figure 2.2 In the New dialog box that appears, select
General and choose One Page Web Site or Empty 
Web Site.

Figure 2.3 Once you select or create a new folder in
the New Web Site Location dialog box, click Open.



4. When the New dialog box reappears, the
path and folder are listed in the bottom
text box (top, Figure 2.4). Type the name
you want to use for the new site after the
backward slash, and click OK (bottom,
Figure 2.4).

5. A dialog box appears briefly while the 
site is generated (Figure 2.5). A Web 
Site tab then appears at the top of the
Editing Window, listing the site’s files—
in this case a single, blank home page,
default.htm (Figure 2.6). The same 
list also appears in the Folder List task
pane to the left. You now can add content
to the blank page or create more pages 
for the site.

Tip

■ To help you build a full-styled Web site
more quickly, Expression Web includes a
variety of CSS-based templates and style
sheets. For more information, see
“Creating Template-based Sites” on the
next page.
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Figure 2.4 When the New dialog box reappears, the
site’s path and folder are listed in the text box (top).
Add the name for the new site after the backward
slash, and click OK (bottom).

Figure 2.5 A dialog box appears briefly
while the site is generated.

Figure 2.6 The Web Site tab at the top of the Editing
Window lists the site’s files—in this case a single,
blank home page, default.htm.

Where to Save Local Sites?

Even though Expression Web offers to
save the local versions of your Web sites
within your profile directory
(…\UserName\Documents\), that doesn’t
mean it’s a good idea. Many Web pros pre-
fer to save their sites on a separate drive
or, at least, outside the UserName folder.
That way if the UserName directory, your
most-used directory, gets corrupted, your
Web files remain safe.



Creating Template-based
Sites
Using an Expression Web site template to
start your own Web site can save so much
time that it’s worth learning all the required
steps—picking a template, customizing the
template’s content, and then replacing the
site’s other pages with your own content. By
using a template, you can change sitewide
items, such as the masthead and navigation
links, in one place and have them automati-
cally updated on all your pages. Best of all,
behind the scenes Expression Web automati-
cally generates the necessary CSS files for
your site, ensuring uniform display in as
many Web browsers as possible (Figure 2.7).

To select and customize Web site
templates:

1. Choose File > New > Web Site.

2. In the New dialog box that appears, select
Templates in the left column and use the
middle list and right-hand Preview area
to find the template that best suits your
needs (Figure 2.8).

3. Click OK to select the site template. A
dialog box appears briefly while the site is
generated. A tab for the new template-
based site appears at the top of the
Editing Window, with all the site’s files
listed in the window and adjacent Folder
List (Figure 2.9).
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Figure 2.7 The bonus of creating 
template-based sites: Behind the
scenes, Expression Web automatically
generates all the necessary CSS files.

Figure 2.8 Select Templates in the left column and
then use the middle list and right-hand Preview area
to find the template that suits your needs.

Figure 2.9 The Editing Window’s site tab, along with
the adjacent Folder List, list all the files generated by
the template.



4. Double-click default.htm to open the
site’s home page. When the page opens,
some areas can be clicked, which means
their contents can be replaced with your
own headlines, text, or images (Figure
2.10). Other areas of the page, such as 
the site’s name and navigation bar, can-
not be clicked or changed directly
because they are shared by multiple 
pages (Figure 2.11).

5. To open these locked, sitewide areas,
double click the .dwt file (usually 
named master.dwt) in the Folder List
(Figure 2.12).

(continued)
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Figure 2.10 Selectable areas in the template-based
page can be replaced with your own headlines, text,
or images.

Figure 2.12 To open locked template areas, double-
click the .dwt file (usually master.dwt) in the 
Folder List.

Figure 2.11 Other 
areas of the template-
based page cannot be
clicked or changed
directly because they
are shared by multiple
pages.



6. When the template page opens, its 
contents can be clicked and changed
(Figure 2.13). Select and replace the 
elements used by multiple pages, such as
the site name and navigation labels, as
needed (Figure 2.14).

7. Right-click the tab of the .dwt (master)
page, and choose Save from the drop-
down menu (Figure 2.15). A status dia-
log box warns that several files will be
updated by saving your changes to the
master template page (top, Figure 2.16).
Since that’s exactly what you want to do,
click Yes and then click OK to close the
status dialog box (bottom, Figure 2.16).

8. Switch back to your home page by click-
ing its tab, and the changes in the tem-
plate page have been applied (Figure
2.17). The * in the page’s tab, however,
means the changes have not been saved,
so choose File > Save All. You now can
replace heads, text, and images on the
home page to suit your needs, as
explained in the next section “Replacing
Content in Template-based Sites.”
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Figure 2.13 Once open, all the template page’s con-
tents can be selected and replaced with your own
headings, text, and images.

Figure 2.17 Back in your home page, the template
changes appear in the updated masthead and naviga-
tion labels.

Figure 2.14 Changes in the template page to sitewide
items, such as the masthead and navigation labels,
are applied to all your pages.

Figure 2.16 Click Yes when a dialog box warns that the
template changes will update multiple pages (top).
Once Expression Web updates the pages, click Close
(bottom).

Figure 2.15 Right-click the tab of the .dwt (master)
page, and choose Save from the drop-down menu.



Replacing Content in
Template-based Sites
Once you customize the site-wide master
template (see page 18), you can very quickly
replace the content in any pages with your
own heads, text, and images. The image
inserted in step 6 was sized ahead of time for
the space. For more information on inserting
and sizing images, see Chapter 5 on page 77.

To replace template content 
with your own:

1. Double-click or click and drag to select a
heading in your template-based page
(Figure 2.18).

2. Type or paste in a heading of your own.

The styling of the template’s original
heading is applied automatically to your
own heading (Figure 2.19).

3. Select a paragraph of text in your tem-
plate page (Figure 2.20).

4. Type or paste in your own text.

The styling of the template’s original text
is applied (Figure 2.21).

5. Click an image in the template to select it
(Figure 2.22).

(continued)
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Figure 2.18 To
replace template-
based content with
your own, select a
heading.

Figure 2.19
Type or paste in a
heading of your
own, and the
styling of the tem-
plate’s original
heading is applied
automatically.

Figure 2.20
To replace text in 
template-based
page, just select
it…

Figure 2.21
…and type or 
paste in your own
text, which is 
automatically
styled to match
the template’s
original text. Figure 2.22 Click

an image to select
it in the template-
based page.



6. Choose Insert > Picture, and make a
source choice from the drop-down menu
(Figure 2.23).

7. Navigate to the image you want to use,
and click Insert (Figure 2.24).

8. Add a brief description to the Alternate
text field, and click OK (Figure 2.25).
Your image replaces the original image in
the template-based page (Figure 2.26).
Be sure to save your changes (cS).
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Figure 2.26 Your
image replaces
the original image
in the template-
based page.

Figure 2.23 Choose Insert > Picture, and
pick a source in the drop-down menu.

Figure 2.24 Navigate to the image you want to
use, and click Insert.

Figure 2.25 Add a brief description to 
the Alternate text field (and a long
description if you like), and then click OK.



Deleting or Adding Pages
to Template Sites
Naturally the site you create using
Expression Web’s templates won’t use the
exact number pages found in the prebuilt
site. Getting rid of unnecessary pages is sim-
ple enough. But a few extra steps are
required to ensure that any pages you add to
the site are still based on those templates
you’ve so carefully updated with your own
content.

To delete pages from your 
template-based site:

1. In the site’s Folder List pane, right-click
the page you don’t need and choose
Delete from the drop-down menu
(Figure 2.27).

2. When the Confirm Delete dialog box
appears, double-check that you’ve chosen
the right file and click Yes (Figure 2.28).
The selected file disappears from the
Folder List while its enclosing folder
remains (Figure 2.29).

Tip

■ To delete an entire folder of unneeded
pages and the folder holding them, right-
click the folder within the Folder List
pane and choose Delete from the drop-
down menu.
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Figure 2.27 In the site’s Folder List pane, right-
click the page you don’t need and choose Delete.

Figure 2.28 Double-check that you’ve chosen
the right file, and click Yes.

Figure 2.29 The selected file disappears
from the Folder List while its enclosing
folder remains.



To add template-based pages 
to your site:

1. In the site’s Folder List pane, right-click
the page whose basic elements you want
to use in a new page and choose New
From Existing Page from the drop-down
menu (Figure 2.30).

A new untitled page appears in the
Editing Window containing the same
content and formats as the template-
based page (Figure 2.31).

2. Choose File > Save, and the Save As dia-
log box appears, automatically opening to
show your site (Figure 2.32).

3. Navigate to the site subfolder where you
want to save the new page—typically the
same folder where the existing page
resides.
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Figure 2.30 To add template-based pages to your site,
right-click a page in the Folder List and choose New
From Existing Page.

Figure 2.31 A new untitled page appears containing
the same content and formats as the template-based
page.

Figure 2.32 Navigate to the site subfolder where you
want to save the new page.



4. Type a distinctive name in the File name
text box, and click Save (Figure 2.33).

The new page appears within the 
chosen folder in the Folder List pane
(Figure 2.34).

5. Now you can add content to the new
page while maintaining the formatting
and design of the previous page (Figure
2.35). Remember, if the Editing Window
tab displaying a file’s name includes *, you
need to save your changes.

Tip

■ Before creating a new page from an exist-
ing one, add any content to the first page
that you’ll also want to appear on the new
pages, such as shared headings.

25

Creating Sites
A

ddin
g

 Pag
es to

 Tem
plate S

ites

Figure 2.33 Give the new page a distinctive
name, and click Save.

Figure 2.34 The new page appears within the chosen
folder in the Folder List pane.

Figure 2.35 Now you can add content to the new page
while maintaining the formatting and design of the
previous page.



Importing a Web Site
If you’ve already built a Web site using
another program, Expression Web does not
force you to start from scratch. Instead you
can import the entire site, either from your
hard drive or where it’s posted on the 
Web. For anyone who created a site using
FrontPage, Microsoft’s previous Web-
creation program, this can be a life-saver.
(FrontPage site builders migrating to
Expression Web should read the Bite the
Bullet sidebar on this page.)
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Bite the Bullet

There’s good and bad news for anyone
who has a Web site built with FrontPage,
Microsoft’s previous Web-creation pro-
gram. The good news: Expression Web
will recognize many of the proprietary
FrontPage server extensions (FPSE) that
drove much of its behind-the-curtain
magic. Expression, for example, won’t
mess up the display of such extension-
based items as Shared Borders or
FrontPage Themes. But the bad news is
that you won’t be able to use Expression
to add those things to new pages. As a
result, your site over time may begin to
look like two people in a horse suit head-
ing in opposite directions.

The dilemma arises precisely because
Expression Web uses current Web stan-
dards and, so, avoids the sort of propri-
etary coding found in FrontPage. That
coding worked fine in Microsoft’s own
Internet Explorer browser, but many other
browsers couldn’t render it correctly.

To help FrontPage users recognize the
new terrain, Expression Web uses some 
of the same terms. But the coding driving
the new program is quite different. The
transition may be painful, but the best
long-term strategy probably boils down 
to abandoning those FrontPage bots 
and extensions. Bite the bullet now, and
later on you’ll be glad you did. For the 
latest details on making the switch, 
go to www.microsoft.com/products/
expression/ and search for “FrontPage
migration.” As helpful migration links
become available, I’ll also post them 
on this book’s companion site: 
www.waywest.net/expression/.

www.microsoft.com/products/expression/
www.microsoft.com/products/expression/
www.waywest.net/expression/
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Figure 2.36 To import a Web site, choose the Import
Web Site Wizard in the New dialog box.

Figure 2.37 The Import Web Site Wizard asks which
of five methods to use to import the Web site (top).
After making your choice, either enter a path or
Web address or click Browse to navigate to your
destination and click Next (bottom).

Figure 2.38 Browse to where the site should be
imported, or if a site is already open in Expression
Web, select Add to current Web site.

To import a Web site:

1. Choose File > New > Web Site.

2. In the New dialog box, choose General >
Import Web Site Wizard and click OK.
(Figure 2.36).

3. The Import Site Wizard starts by asking
you which method to use to import the
Web site (top, Figure 2.37). Click one of
the five radio buttons and then either type
the path or Web address or click Browse
to navigate to your destination. Click Next
to proceed (bottom, Figure 2.37).

4. Use the Browse button in the next dialog
box to pick where to import the site, or if
a site is already open in Expression Web,
select Add to current Web site. (Figure
2.38). Then click Next.

(continued)
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Figure 2.40 Once the
import begins, a progress
dialog box tracks the
download.

Figure 2.39 Choose how many levels below the
home page you want to import. Or limit the import
to a maximum size or only HTML and image files.

Figure 2.41 If you want to replace the
current site’s home page with that of the
imported site, click Yes.

Figure 2.42 Expression Web displays the imported
site’s home page and lists the rest of the site’s files in
the Folder List.

5. The next dialog box lets you control how
many levels below the home page you
want to import (Figure 2.39). Or you can
limit the import to a maximum size or
only HTML and image files. Click Next.

6. Click Finish in the final dialog box of the
Import Site Wizard and a progress dialog
box tracks the download (Figure 2.40).

7. Assuming you still want to replace the
current site’s home page with that of the
imported site, click Yes (Figure 2.41).

The imported site’s home page will open
in Expression Web with the rest of the
site’s files visible in the Folder List pane
(Figure 2.42). You now can update or
expand the site using Expression Web.



Working with Web Sites
To avoid breaking any of the links within
your Web sites, you should always use
Expression Web to close, open, rename, or
delete sites.

To close a Web site:

◆ After choosing File > Save All, choose 
File > Close Site (Figure 2.43).

The Web site closes, leaving an empty
Folder List and Editing Window 
(Figure 2.44).

Tip

■ You do not have to close one site to open
another. See the second Tip for “To open
a site” on the next page.
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Figure 2.43 To close a Web site
after saving your changes, choose
File > Close Site.

Figure 2.44 The Web site closes, leaving an empty
Folder List and Editing Window.



To open a Web site:

1. Choose File > Open Site (Figure 2.45).

The Open Site dialog box appears, listing
all the Web sites you’ve created using
Expression Web (Figure 2.46).

2. Select one in the right column, and 
click Open.

The selected site appears in the Editing
Window, with its path displayed across
the top of the window (Figure 2.47).

Tips

■ In step 2, if you double-click a Web site in
the list, Expression Web says “No items
match your search.” Always use the Open
button.

■ You can have multiple sites open at the
same time. After opening one site, repeat
steps 1 and 2, only this time navigating to
another Web site. Expression Web opens
each successive site in a separate window
(Figure 2.48).

■ To have Expression Web automatically
display the last opened site when it starts
up, choose Tools > Application Options.
In the dialog box that appears, check
Open last Web site automatically when
Expression Web starts.

■ To see only your recently opened Web
sites, in step 2, click the Web Sites button
in the left column of the dialog box. Or
choose File > Recent Sites and pick a list-
ing in the drop-down menu.
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Figure 2.45 To open a Web site,
choose File > Open Site.

Figure 2.46 The Open Site dialog box lists all
the sites you’ve created using Expression Web.

Figure 2.47 The site you select to open appears
in the Editing Window, with its path displayed
across the top of the window.

Figure 2.48 When opening multiple Web sites,
Expression Web opens each one in a separate
window.



To rename a Web site:

1. Open the site you want to rename and
choose Site > Site Settings (Figure 2.49).

When the Site Settings dialog box opens,
the current name is highlighted in the
Web name text box (top, Figure 2.50).

2. Type a new name and click OK to close
the dialog box and apply the change (bot-
tom, Figure 2.50).

The site’s name changes in the path
within the Editing Window as well as in
the Folder List (Figure 2.51).

To delete a Web site:

1. Open the site you want to delete. Right-
click its name in the Folder List pane, and
choose Delete from the drop-down menu
(Figure 2.52).

2. When the Confirm Delete dialog box
appears, make sure Delete this Web 
site entirely is selected and click OK
(Figure 2.53).

The selected site no longer appears in the
Folder List pane.

Tip

■ You cannot undo the deletion, so it might
be wise to let no-longer-needed sites sit
idle for a few days rather than deleting
them immediately—and regretting it
immediately as well.
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Figure 2.49 To rename 
an open Web site, choose
Site > Site Settings.

Figure 2.52 To delete a
open Web site, right-click
its name in the Folder
List pane and choose
Delete.

Figure 2.50 In the Site Settings dialog box, the
current name is highlighted (top). Type a new
name and click OK to apply the change (bottom).

Figure 2.53 Make sure Delete this Web site
entirely is selected and then click OK, and the site
will be deleted immediately.

Figure 2.51 The site’s name changes in the Editing
Window’s path as well as in the Folder List.



Switching the 
Web Site View
By default, Expression Web displays an open
Web site as a list of folders and files (Figure
2.54). However, depending on the task at
hand, you can switch your view of the Web
site to three other views. For more informa-
tion on the Remote Web Site choice, see
“Publishing the Site” on page 221.

To switch your Web site view:

◆ At the top of the Editing Window, click
the site’s tab. Then at the bottom of the
Editing Window, click the Remote Web
Site button to either set up the remote
publishing site or see the files you’ve
already uploaded (Figure 2.55).

or

◆ Click the site’s tab in the Editing Window
and then at the bottom click the Reports
button for a status list and possible prob-
lems with the site (Figure 2.56).

or

◆ In the Folder List pane, select a file for
which you want link information. At 
the top of the Editing Window, click the
site’s tab. Then at the bottom of the
Editing Window, click the Hyperlinks
button to see a diagram of all the
inbound and outbound links for the
selected file Figure 2.57).
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Figure 2.54
By default,
Expression Web
displays an
open Web site
as a list of fold-
ers and files.

Figure 2.56
Click the
Reports button
for a site status
list and possi-
ble problems.

Figure 2.55 Click the Remote Web
Site button to either set up a remote
site for publishing or see the files
already uploaded.

Figure 2.57 Click the Hyperlinks button to
see a diagram of all the inbound and out-
bound links for a particular Web page.



Having set up a Web site in Chapter 2, you’re
ready to create individual pages. This chapter
also covers other page basics, such as saving,
renaming, retitling, and deleting pages.
Finally, you’ll learn how to preview your
pages in a variety of Web browsers.
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Creating Web Pages
As in creating Web sites, you have two routes
to go: start from scratch with a blank page or
use a CSS-based template page. Depending
on the situation, you’ll probably do a little of
both. If you’ve created a lot of pages before,
starting with a blank page may be perfect for
your needs. If you’re looking to learn the ins
and outs of CSS, however, starting with one
of Expression Web’s CSS-based page tem-
plates can save time by giving you a jump
start. “To create a new CSS-based page” on
page 36 offers a quick overview; it’s covered
in depth in “Creating Layouts with CSS” on
page 145.

To create a new blank page:

1. Open the Web site in which you want 
to work, and choose File > New > Page
(Figure 3.1).

When the New dialog box appears,
HTML is selected automatically 
(Figure 3.2). (To change that, see 
last tip on the next page.)

2. Click OK, and a new blank Web page
appears in the Editing Window 
(Figure 3.3).
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Figure 3.2 HTML is selected automatically in the New
dialog box.

Figure 3.3 A new blank Web page appears in the
Editing Window ready for your content.

Figure 3.1 To create
a new blank page,
choose File > New >
Page.



✔ Tips

■ In step 1, if you want to use a standard,
HTML-based Web page, choose File >
New > HTML and a blank Web page
appears without going through the New
dialog box. Or if the Common toolbar is
visible, click the New button (Figure 3.4).

■ If you’re adding pages to an existing site,
you also can click the New button in the
Folder List’s title bar, which by default also
creates a new HTML page (Figure 3.5).

■ While you could create a free-standing
page without first opening a Web site,
you’ll avoid potential file chaos by work-
ing within an already created site—even
if it’s a site with just a single page.

■ In step 1, if you want to use a format
other than HTML, in the middle column
click another choice such as CSS. To
change the default format, click Page
Editor Options (Figure 3.2). Or choose
Tools > Page Editor Options. In the Page
Editor Options dialog box, click the
Authoring tab and use the Default
Document Type drop-down menu to
make a choice. Click OK to close the dialog
box and apply the change (Figure 3.6).
While you also can change the default
doc type declaration and schema here,
they really should be applied site-wide so
don’t change it from page to page within
a site. (The default schemas of XTML 1.0
Transitional and CSS 2.1 are your best
bets for new sites; you may have to
change it HTML 4.01 Transitional for
older sites laden with pre-XTML pages
that you have not yet updated.)
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Figure 3.5 A New button also
resides in the Folder List’s title bar.

Figure 3.6 The Authoring tab in the Page Editor
Options dialog box lets you change the default docu-
ment type used for new pages.1

Figure 3.4 You also can create a
new page by clicking the New
button in the Common toolbar.



To create a new CSS-based page:

1. Open the Web site in which you want to
work, and choose File > New > Page.

2. When the New dialog box appears, select
CSS Layouts in the left column and make
a choice in the middle column based on
the Preview area (Figure 3.7).

3. Click OK, and an untitled—and appar-
ently blank—page appears in the Editing
Window (Figure 3.8).

4. To really see what’s going on, turn on
Expression Web’s visual aids. Choose
View > Visual Aids > Show (c+)
(Figure 3.9), and then select all but the
two ASP.NET items in the drop-down
menu (Figure 3.10).

The previously blank page now shows a
rough version of the step 2 preview
(Figure 3.11).
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Figure 3.7 To create a new CSS-based page, select
CSS Layouts in the left column and make a choice in
the middle column based on the Preview area.

Figure 3.9 To see what’s going on in a
CSS-based page, choose View > Visual
Aids > Show.

Figure 3.10 In the Visual Aids drop-down
menu, select all but the two ASP.NET items.

Figure 3.11 The previously blank page now shows a
rough version of the step 2 preview. For an even bet-
ter sense of how the page works, switch to Split View
and turn on the CSS Properties task pane.

Figure 3.8
Underwhelming: 
a blank CSS-based
page with all 
the visual aids
turned off.



5. Now that you can see the page’s CSS-
based layout sections—known as divs—
in the Design and Code windows, you can
start adding content (Figure 3.12).

6. Be sure to save your changes. When you
do, Expression Web will ask you to name
and title the HTML page and its related
CSS file (Figure 3.13).

7. Though the page remains far from done,
press = to see how it looks at the
moment in your default Web browser
(Figure 3.14).

✔ Tips

■ In step 4, for a better sense of how the
page works, switch to Split View and turn
on the CSS Properties task pane.

■ For lots more detail on laying out pages
using CSS, including sources for other
CSS templates, see “Creating Layouts
with CSS” on page 145.
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Figure 3.12 Once you can see the page’s CSS-based
layout sections in the Design and Code windows, you
can start adding content.

Figure 3.13 Expression Web automatically generates a
companion CSS file for the page you create.

Figure 3.14 To see how the still rough CSS-based page
looks, take a quick peek using your Web browser.



Working with Web Pages
To avoid breaking any of the links among
your Web pages, use Expression Web (rather
than the Windows Explorer) to save, open,
change the name or title, or delete pages.

To save a Web page:

1. Choose File > Save (cS) or click the
Save button in the Common toolbar or
right-click the page’s tab and choose Save
from the drop-down menu (Figure 3.15).

2. If this is the first page you’ve saved to the
site, the Save As dialog box automatically
names the file default, making it the
site’s home page (Figure 3.16). (See sec-
ond tip.) The dialog box also automati-
cally titles the page Untitled1. If that’s
your intention, click Save and the file is
saved with that name and title and the
dialog box closes.

or

To give the file another name and title,
type the name in the File name text box
and click Change title (Figure 3.17).
When the Set Page Title appears, replace
the automatic title (top, Figure 3.18)
with the one you want to use (bottom,
Figure 3.18). Click OK to close the 
dialog box.
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Figure 3.16 If this is the first page you’ve saved to the
site, the Save As dialog box automatically names it
default, making it the site’s home page.

Figure 3.17 Use the File name field to rename the
page, and then click Change title.

Figure 3.18 Type a new title (top),
and click OK to close the dialog box
(bottom).

Figure 3.15 You
have at least
three ways to
save a page.



3. The Save As dialog box reappears with
your name and title choices in place
(Figure 3.19). Click Save to apply the
changes and close the dialog box.

The new name appears in the Folder List
and the open page tab (Figure 3.20).

✔ Tips

■ A page’s name is the file name in your
directory (for example, default.htm),
while the title is what your Web visitors
see in their browser’s title bar when they
open the page (Figure 3.21).

■ You can designate another file as a site’s
home page at any time. Right-click the
file in the Folder List, and choose Set as
Home Page in the drop-down menu
(Figure 3.22). Click Yes when the confir-
mation dialog box appears, and the
selected page is renamed default.htm
and the previous home page is named
default-old.htm (Figure 3.23).
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Figure 3.19 The Save As dialog box reappears with
your name and title choices in place. Click Save to
apply the changes and close the dialog box.

Figure 3.20 The new name appears in the Folder
List and the open page tab.

Figure 3.21 A page’s file name (top) is not
its title, which appears in the browser’s
title bar and page tab (bottom).

Figure 3.23 Click Yes when the confir-
mation dialog box appears (top). The
selected page is renamed default.htm
and the previous home page named
default-old.htm.

Figure 3.22 To designate
another file as the home
page, right-click it in the
Folder List and choose
Set as Home Page.



To open a Web page:

Do one of the following:

◆ To open a Web page in the same Web 
site, double-click its name in the Folder
List pane.

◆ To open a Web page in another Web site,
choose File > Open and then use the dia-
log box that appears to navigate to the
desired page.

To change a page’s name:

1. Click the file in the Folder List to select it.
Wait a beat and click it again to select its
name (Figure 3.24).

2. Use your cursor to select everything 
but the .htm suffix (left, Figure 3.25).
Type a new name (right, Figure 3.25).
Press E .

The new name is applied to the file
(Figure 3.26).
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Figure 3.24 Click once,
wait a beat, and click again
to select the file’s name in
the Folder List.

Figure 3.26 Press E
and the new name is applied
to the file.

Figure 3.25 Select everything but the .htm suffix (left),
then type a new name (right).



To change a page’s title:

1. Right-click a page in the Folder List, and
choose Properties from the drop-down
menu (Figure 3.27).

2. Select the title in the General tab of the
Properties dialog box (top, Figure 3.28).
Type a new title and click OK to apply the
change and close the dialog box (bottom,
Figure 3.28).

✔ Tip

■ If the Title column is turned on in the
Editing Window (click Reports tab > 
All Files), you can select the title in 
the column and type in a new title
(Figure 3.29).
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Figure 3.27
To change a
page’s title, 
right-click a page
in the Folder 
List and choose
Properties from
the drop-down
menu.

Figure 3.28 Select the title in the General
tab (top), type a new title, and click OK to
apply the change and close the dialog box
(bottom).

Figure 3.29 If the
Title column is
turned on in the
Editing Window,
you can select the
title there and type
a new title.



To delete a Web page:

1. In the Folder List, right-click the page
and choose Delete from the drop-down
menu (Figure 3.30).

2. An alert dialog box appears, asking if you
want to delete the page (Figure 3.31).
Click Yes, and the page is deleted from
the site.
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Figure 3.31 If you’re sure you want to
delete the page, click Yes.

Figure 3.30 To delete 
a page, right-click it 
in the Folder List and
choose Delete from the
drop-down menu.



Setting Other Page
Properties
Besides enabling you to change a page’s title,
the Page Properties dialog box controls many
other aspects of individual pages. You can set
a page’s background image, sound, and color.
You also can change the color of your text
and link colors—though you’re much better
off using CSS to set those aspects (see
“Creating Styles with CSS” on page 121).

To set page properties:

1. Open the page you want to change, and
choose File > Properties.

When the Page Properties dialog box
appears, the General tab opens by default.

2. Click the tab you want to use, and 
select the options you want to set
within that tab.

3. After making your choices, click OK to
close the dialog and apply the property
changes.

4. Save the page (cS). If you add an
image or sound file that’s not already 
part of the site, click OK when the Save
Embedded Files dialog box appears. To
see the result in your main Web browser,
press = .
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Page Properties

Of the six tabs in the Page Properties 
dialog box, General and Formatting get 
the most use.

◆ General controls the title (as explained
on page 41) (Figure 3.32). The Page
description and Keywords fields harken
back to the days when search engines
used this metadata to categorize your
pages. Nowadays, such engines just
search the body of your pages, but these
two items remain useful for pages you’re
migrating from FrontPage to Expression
Web. If you want to use a Background
sound, click that pane’s Browse button to
navigate to the sound file. Do not use the
Location path to move a page; just click
and drag it in the Folder List.

◆ Formatting controls the background
image, plus the color of the text and
hyperlinks. To add a background image,
select Background picture; select Make it
a watermark if you want the image to be
semitransparent (top, Figure 3.33).
Browse to the image you want to use, and
after you select an image, the Formatting
tab lists the image’s path (bottom, Figure
3.33). (To remove the image, select the
path and click Delete.) To change the
background, text, or link colors of a single
page, use the bottom Colors pane of the
Page Properties dialog box.
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Figure 3.32 Use the General tab in the Page Properties
dialog box to set the title, page description, keywords,
and background sound.

Figure 3.33 Use the Formatting tab in the Page
Properties dialog box to set the background image,
plus the colors of the background, text, and links.



◆ Advanced lets you set the margins for
that particular page, but again, it’s best to
handle this using CSS (see “Creating
Layouts with CSS” on page 145)

◆ Custom lets you create custom code
snippets based on system and user 
variables.

◆ Language controls both the page’s lan-
guage and HTML encoding (Figure
3.34). Together, they ensure that
Expression Web and your browser use the
appropriate character sets for the lan-
guage being used. In general, however,
this usually is handled by your computer’s
main settings.

◆ Workgroup is useful if you have a team
of people working on a site (Figure 3.35).
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Figure 3.34 The Language tab in the Page Properties
dialog box sets the language and encoding options.

Figure 3.35 If you have a team building a site, the
Workgroup tab helps you create categories, assign-
ments, and status flags.



Previewing Pages in a
Browser
Expression Web’s Design view does a pretty
good job of showing how your Web pages will
appear once published. But you should make
a habit of previewing the page in a variety of
Web browsers to spot inconsistencies from
browser to browser. By adding multiple
browsers to Expression Web’s built-in pre-
view list, you can quickly switch from one
preview to another. Windows Vista does not
support pre-7.0 versions of Internet Explorer,
so you’ll need an Windows XP machine to
preview pages in IE 6 and earlier. It’s a bother
but worth the effort since it’ll likely take sev-
eral years before most visitors upgrade to
Vista and IE 7.

To preview pages:

◆ Save any changes to your page (cS).
Choose File > Preview in Browser and
make a choice in the drop-down menu
(left, Figure 3.36). Or do the same with
the Preview button in the Common tool-
bar (right, Figure 3.36). The selected
browser launches and displays the
selected Web page.

✔ Tips

■ To designate any browser in the list as
your default choice, press s as you
select it in the drop-down menu. You can
then trigger a preview by that browser at
any time by pressing = . To designate
another browser as the default, repeat the
s-click in the list.

■ You also can preview any page by right-
clicking it in the Folder List and choosing
Preview in Browser from the drop-down
menu.
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Figure 3.36 To see any saved page in your Web browser,
choose File > Preview in Browser and make a choice in
the drop-down menu (left) or click the Preview button
in the Common toolbar (right).



To change the Web browser list:

1. Choose File > Preview in Browser > Edit
Browser List, or click the Common tool-
bar’s Preview button and choose Edit
Browser List.

2. Click Add in the Edit Browser List
(Figure 3.37).

3. In the Add Browser dialog box, click
Browse to navigate to the browser pro-
gram you want to add (top, Figure 3.38).

4. Once you find the program and click
Open, the Add Browser dialog box reap-
pears listing the path to the program.
Type a shorthand name and version into
the Name box, and click OK (bottom,
Figure 3.38).

5. When the Edit Browser List dialog box
reappears, the browser is added to the
list. Click OK to close the box and apply
the changes (Figure 3.39). For the dialog
box’s other options, see the Tips below.

✔ Tips

■ In step 4, select Automatically save page
before previewing to have Expression
Web automatically save your work before
you preview pages (Figure 3.39).

■ In step 4, select any of the three
Additional window sizes to add them to
the Preview drop-down menu choices
(Figure 3.39).

■ You can see a page previewed in multiple
browsers simultaneously. In step 4, just
select the checkboxes next to any of the
listed browsers (Figure 3.39). To trigger
the multiple displays, choose Preview in
Multiple Browsers in the Preview drop-
down menu (Figure 3.36).
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Figure 3.37 To include another Web
browser in your list, click Add.

Figure 3.38 Click Browse to navigate to the browser
program you want to add (top). Once you add the pro-
gram, the dialog box reappears listing the path to the
program. Type a shorthand name and version in the
Name box, and click OK (bottom).

Figure 3.39 The additional program
appears in the list. Checked browsers
automatically open whenever you
choose Preview in Multiple Browsers
(shown in Figure 3.36).
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On the surface, working with text in
Expression Web is very much like using any
word processing program. Unlike with word
processing, however, you should not format
your Web text (bold, italic, font size, and so
on) as you enter it. It’s true that in the early
days of the Web, you often applied font and
style tags in the same as-you-worked fashion
as word processing. Modern Web standards,
however, try as much as possible to separate
what the text says (its content) from how it
looks (its appearance or presentation).

That’s in part because a Web page may be
read on a cell phone screen or a page-sized
monitor. By separating content from presen-
tation, it’s much easier to create codes that
allow your Web pages to automatically
adjust to whatever reads them (including
text-to-speech programs for the visually
impaired).

Think instead of your text and headings as
you would an outline. Outlines seldom look
fancy. Instead, they focus on the sequence
and relative importance of different parts of
your information by using headings and
indents. For that reason, this chapter shows
you how to treat your text more like an out-
line. As for the business of formatting the
appearance of your text, see “Creating Styles
with CSS” on page 121.
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Entering and 
Selecting Text
The standard techniques you use in text-
editing programs—entering text, selecting,
moving, cutting, and copying—work simi-
larly in Expression Web.

To enter text on a Web page:

1. Open the Web page in which you want 
to work, and click where you want to
enter text.

A blinking vertical bar marks the text
insertion spot.

2. Start typing, and the text appears at the
insertion spot (Figure 4.1).

✔ Tip

■ Notice in the code window that
Expression Web automatically places 
the text inside an HTML paragraph 
tag (<p> </p>) (Figure 4.1). Called a 
container, this tag offers a stripped-down
example of how HTML works: An open-
ing tag marks (declares) the start of a 
particular code effect, and a closing 
tags marks where it ends. As you dive
deeper into Expression Web, you’ll see
how all HTML and CSS coding works 
the same way.

50

Chapter 4
En

te
ri

n
g

 a
n

d 
S

el
ec

ti
n

g
 T

ex
t

Figure 4.1 To enter text on a Web page, start typing
and the text appears at the insertion spot.



To select text on a page:

Do one of the following:

◆ Click and drag through the text you want
to select.

◆ Double-click a word to select it.

◆ Triple-click anywhere in a paragraph to
select it.

◆ Click at the beginning (or end) of the text
you want to select, and press csS

(or csA ) until you’ve selected all
the desired text.

◆ Move your cursor to the left end of a line,
and when it becomes an arrow, click to
select the entire line.

◆ Move your cursor to the left end of a line,
and when it becomes an arrow, double-
click to select the entire paragraph.
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To move text:

1. Select the text you want to move 
(Figure 4.2).

2. Click and drag the highlighted text to its
new location (Figure 4.3).

3. Release your cursor, and the selected text
moves to the new spot (Figure 4.4).

To cut or copy text:

1. Select the text you want to cut or copy.

2. Choose Edit > Cut (cX), or right-click
and choose Cut from the drop-down
menu.

The selected text is stored in the
Clipboard for pasting elsewhere.

or

Choose Edit > Copy (cC), or right-
click and choose Copy from the drop-
down menu.

The selected text is stored in the
Clipboard for pasting elsewhere.
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Figure 4.2 Select the text you want to move.

Figure 4.3 Click and drag the highlighted text to its
new location.

Figure 4.4 Release the cursor, and the selected text
moves to the new spot.



Pasting Text
Expression Web gives you two ways to 
paste text, each of which controls a different
aspect. The commonly used Paste command
(cV) includes options for controlling 
the style of the inserted text. Expression
Web’s Paste Text command, which has no
keyboard shortcut, includes options for con-
trolling the line breaks and white space of
the inserted text.

To paste text:

1. Make sure you’re in Design view. Click in
the page where you want to insert text
that you’ve cut from a Web page or from
another program, such as Microsoft Word.

2. Choose Edit > Paste (cV), or right-
click and choose Paste.

The stored text is pasted into the destina-
tion document at the insertion point and,
by default, retains the formatting of the
source document from where it’s cut or
copied. If you don’t want to keep the for-
matting, right-click the Paste Options
button that appears amid the inserted
text (Figure 4.5). Choose Remove
Formatting in the drop-down menu to
match the formatting of the destination
document (Figure 4.6). For more infor-
mation, see “Controlling Paste Styles” on
page 54.)

or

Choose Edit > Paste Text (Figure 4.7).
When the Paste Text dialog box appears,
pick one of the five choices (Figure 4.8).

The text is pasted based on your choice.
For more information, see “Controlling
Paste Line Breaks and White Space” on
page 54.

(continued)
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Figure 4.5 If you don’t want to keep the formatting of
the source document, right-click the Paste Options
button.

Figure 4.6 Choose Remove Formatting in the drop-
down menu (top) to match the formatting of the desti-
nation document (bottom).

Figure 4.8 When the Paste Text dialog box appears,
pick one of the five choices. (See Table 4.2.)

Figure 4.7 To control line breaks
and white space in the inserted
text, choose Edit > Paste Text.



✔ Tips

■ The Remove Formatting choice is very
handy when, for example, you’re copying
text from a Web page full of pre-CSS 
font tags.

■ The Paste Text dialog box’s no-line-
breaks choice saves time when copying
multiline text from tables into a page
without tables.

■ If the text you’re pasting from another
page has a format style that uses the
exact name as your destination page, the
Paste Options drop-down menu includes
the option of matching the destination
page’s style (Figure 4.9).
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Figure 4.9 If the source text includes a style with the
same name as your destination page, the drop-down
menu includes the option of matching the destination
page’s style.

Table 4.1

c h o o s e t o

Match Destination Formatting Preserve formatting of the destination page
Keep Source Formatting Preserve formatting of the source document
Remove Formatting Insert plain text
Keep HTML Only Preserve HTML coding copied from the source
Keep Text Only Insert plain text—same as Remove Formatting—except the Paste Text dialog box

appears, letting you control line breaks and white space (See Table 4.2 below.)

Controlling Paste Styles

Table 4.2

c h o o s e t o

Plain text Insert plain text with spaces replacing any line breaks in source text
One <pre> formatted paragraph Use <pre> (preformatted) tag to maintain all line breaks of source text
Many <pre> formatted paragraphs Use <pre> tag to maintain all line and paragraph breaks of source text
Normal paragraphs with line breaks Convert any lines breaks to <br> (line break) tag and any paragraph breaks to <p>

(paragraph) tag
Normal paragraphs without line breaks Do exactly that

Controlling Paste Line Breaks and White Space



To undo an action:

◆ Choose Edit > Undo, or press cZ .

The previous action is undone.

To redo an action:

◆ Choose Edit > Redo, or press cY .

The previous action is reapplied.

Tips

■ The Undo and Redo choices change in
the Edit menu depending on your previ-
ous actions.

■ If the Standard toolbar is visible, you can
use the drop-down menus of the Undo or
Redo buttons to choose how many
actions you want step backward or for-
ward (Figure 4.10).
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Figure 4.10 The Undo and Redo drop-down menus in
the Standard toolbar let you choose how many
actions to step backward or forward.



To add a line break:

Do one of the following:

◆ Click your cursor where you want the text
to break, and press sE .

The text breaks to a new line.

◆ Click your cursor where you want the text
to break, and choose Insert > HTML >
Break (Figure 4.11).

The text breaks to a new line.

◆ Click your cursor where you want the text
to break, and in the Toolbox task pane,
look in the HTML-Tags section and dou-
ble-click the Break button (Figure 4.12).

The text breaks to a new line.

To add a paragraph break:

◆ Click in the text where you want a new
paragraph to begin, and press E .

The cursor or text jumps to the next line
to start a new paragraph.

To show/hide line break and
paragraph marks:

◆ Click the Show All button in the Standard
toolbar (Figure 4.13). All the normally
hidden line break and paragraph marks
appear. To hide the marks, click the Show
All button again.

Just as you can show/hide various tool-
bars or task panes, click the arrow next to
the Show All button and use the drop-
down menu to turn on/off ten different
categories of marks (Figure 4.14).
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Figure 4.11 To add a line break, choose Insert >
HTML > Break.

Figure 4.12 You also can double-
click the Break button in the
Toolbox task pane.

Figure 4.13 To show line break
and paragraph marks, click the
Show All button in the Standard
toolbar. Click again to hide them.

Figure 4.14 You can
click the arrow next
to the Show All but-
ton’s and use the
drop-down menu to
turn on/off ten cate-
gories of marks.



Indenting Paragraphs
Indenting offers a quick way to structure
your text since indented items signal that
they are less important, or at least a subset, 
of the less-indented item above. It’s no won-
der that indenting plays a big role in creating
outlines, which like Web pages focus on the
structure of the information rather than its
appearance. Not to worry: Using CSS you can
control precisely how indented text looks.
But it’s a separate process covered in
“Creating Styles with CSS” on page 121. Here,
we just show you how to apply a basic indent.

To indent paragraph:

1. Click anywhere in a single paragraph 
(or click and drag to select multiple 
paragraphs).

2. Press t or the Increase Indent Position
button in the Common or Formatting
toolbars (Figure 4.15).

The selected paragraph(s) indents
(Figure 4.16). To further indent the text,
click the button again.

✔ Tip

■ Use the adjacent Decrease Indent
Position button to reduce the indent.
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Figure 4.15 The Increase Indent Position
button appears in the Common and
Formatting toolbars.

Figure 4.16 The selected paragraph indents by 40 
pixels.



To indent a paragraph’s first line:

1. Click anywhere in the paragraph, and
choose Format > Paragraph (Figure
4.17).

2. In the Paragraph dialog box, type a 
number in the Indent first line field or 
use the small arrows to select a number
(Figure 4.18).

The bottom Preview area shows the
effect.

3. When you’re satisfied, click OK to close
the dialog box and apply the indent
(Figure 4.19).
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Figure 4.17 To indent
just a paragraph’s first
line, choose Format >
Paragraph.

Figure 4.18 In the Paragraph dialog box, type a num-
ber in the Indent first line field. The Preview area at
the bottom shows the effect.

Figure 4.19 The first line of the selected paragraph
indents by the amount you select.



Aligning Text
Much like a word-processing program,
Expression Web can align selected text to
the left, the right, or center it. It also can jus-
tify the text, though that’s less commonly
used on the Web.

To align text:

◆ Click anywhere in a single paragraph (or
click and drag to select multiple para-
graphs), and click one of the alignment
buttons in the Common or Formatting
toolbars (Figure 4.20).

The selected paragraphs realign based on
your choice (Figure 4.21).

✔ Tip

■ Unlike the Common toolbar, the
Formatting toolbar includes a Justify but-
ton. Take care, however, that the Justify
button doesn’t spread out your words so
much that you wind up with unsightly
gaps in some of the paragraph lines.
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Figure 4.20 To align text, choose one of the alignment
buttons in the Common or Formatting toolbars.

Figure 4.21 The selected paragraph changes to a cen-
tered alignment.



Inserting Special HTML
Characters
HTML by necessity uses special codes to cre-
ate the sort of special characters taken for
granted in word processing.

To insert a special character:

1. Click in the text where you want to insert
the special character, and choose Insert >
Symbol (Figure 4.22).

2. In the Symbol dialog box use the Font
and Subset drop-down menus to find the
character you need (Figure 4.23). Or
make a selection in the Recently used
symbols bar. Click the character to select
it, and choose Insert.

The correct HTML code for the character
is inserted into your text.

✔ Tips

■ If you’re looking for such common punc-
tuation marks as dashes or ellipses, in
step 2 use the General Punctuation
Subset drop-down menu (Figure 4.23).

■ Over time, your most-used characters will
fill the Recently used symbols bar, reduc-
ing the need to dig through the Font and
Subset drop-down menus.
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Figure 4.22 Click in the text
where you want to insert
the special character, and
choose Insert > Symbol.

Figure 4.23 Use the Font and Subset drop-down
menus to find the character you need. Or make a
selection in the Recently used symbols bar.



To insert a horizontal line:

◆ Click in the text where you want to add
the line, and choose Insert > HTML >
Horizontal Line (left, Figure 4.24), or if
the Toolbox task pane is open, you can
click the Horizontal Line button found
under HTML > Tags (right, Figure 4.24).
The line appears on the page.

✔ Tips

■ To change the line’s properties, right-click
the line and choose Horizontal Line
Properties from the drop-down menu
(Figure 4.25). Use the Horizontal Line
Properties dialog box to change the width
(best done as a percent of the window
rather than an absolute value) (Figure
4.26). You also can change the line’s
height, alignment, and color. Click OK to
apply the changes.

■ If the Formatting toolbar is visible, you’ll
also find a horizontal line button in the
drop-down menu for the Outside Borders
button (Figure 4.27).
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Figure 4.26
Use the Horizontal
Line Properties dia-
log box to change
the line’s width,
height, alignment,
and color.

Figure 4.24 To insert a horizontal line, choose Insert >
HTML > Horizontal Line (left) or click the Horizontal
Line button in the Toolbox task pane (right).

Figure 4.27 In the Formatting toolbar you’ll also find a
horizontal line button in the drop-down menu for the
Outside Borders button.

Figure 4.25 To change a line’s properties,
right-click it and choose Horizontal Line
Properties in the drop-down menu.



Creating Headings
In some ways, headings are your most impor-
tant tool for guiding readers through your Web
pages. While paragraph-level text supplies the
content of your pages, it’s the headings that
give it structure. Properly functioning headings
enable readers to scan a page for a particular
topic—without needing to read any of the 
text details.

HTML offers six sizes of headings, with h1
being the largest and h6 the smallest. None
of the sizes come with a fixed value. Think
instead of h1–h6 headings as a way to clue
the reader about the relative importance of
one item to another. Save h1 for your most
important headings, for example, such as the
tops of pages. H2 and h3 then might be used
for subheadings, while h4 or h5 might mark
sections in your sidebars. The main thing: Be
consistent in using the sizes to structure
your content. As for making your headings
black or red, serif or sans serif , that’s best
done using CSS, as explained in “Creating
Styles with CSS” on page 121.

To create a heading:

1. Click anywhere in the text you want to
make into a heading (Figure 4.28).

2. Click the Style drop-down menu in the
Common or Formatting toolbar, and
choose a heading size (Figure 4.29).

The heading is applied to the text
(Figure 4.30).

✔ Tips

■ Headings apply to the whole paragraph,
so put the heading in its own short para-
graph of no more than two short lines.
Even shorter is better.

■ In step 2 if you change your mind about
your size choice, just select another
choice in the Style drop-down menu and
it is applied instead.
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Figure 4.28 Click anywhere in the line you
want to make into a heading.

Figure 4.30 The selected line turns into an 
h2-sized heading.

Figure 4.29 Click the Style drop-down menu in 
the Common or Formatting toolbar to choose a 
heading size.



Creating Lists
Lists come in two flavors: ordered (num-
bered) and unordered (bulleted). You can
change the defaults Expression Web uses for
lists (letters instead of numbers, square bul-
lets instead of round ones). For anything
fancier, however, you’re better off using CSS
to create sitewide styles for such lists. For
more information, see “Creating Styles with
CSS” on page 121.

To create a numbered list:

1. Select the lines you want numbered
(Figure 4.31).

2. Click the Numbering button in either 
the Formatting or Common toolbar
(Figure 4.32).

The lines are indented and numbered
(Figure 4.33).
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Figure 4.31 Select the lines you want numbered.

Figure 4.32 Click the Numbering button in either the
Formatting or Common toolbar.

Figure 4.33 The lines are indented and numbered.



To create a bulleted list:

1. Select the lines you want bulleted
(Figure 4.34).

2. Click the Bullets button in either the
Formatting or Common toolbar (Figure
4.35).

The lines are indented and bulleted
(Figure 4.36).
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Figure 4.34 Select the lines you want bulleted.

Figure 4.35 Click the Bullets button in either the
Formatting or Common toolbar.

Figure 4.36 The lines are indented and bulleted.



To create a definition list:

1. Place your cursor where you want the
first definition to appear.

2. Use the Style drop-down menu in the
Formatting or Common toolbar to
choose Defined Term (Figure 4.37).

3. Type your first term (Figure 4.38).

4. Press E , and the text is indented
and formatted as the definition of the
term above it (Figure 4.39).

5. When you finished entering the defini-
tion, if you want to add more terms, press
E again and the cursor jumps to a
new line and switches back to the
Defined Term format.

6. When you’re done adding terms, press
E twice and Expression Web
switches back to the normal body text
(Figure 4.40).

✔ Tip

■ You can type all the terms and definitions
and then format them line by line using
the Style drop-down menu. But it’s gener-
ally easier to switch to the Defined Term
format and type them all at once since all
the formatting is handled automatically.
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Figure 4.39 Press E , and the next block of text
is formatted as the definition of the term above it.

Figure 4.40 When you’re done adding terms, press
E twice and the text returns to the normal para-
graph formatting.

Figure 4.37 Place your cursor where you want the first
definition to appear, and then choose Defined Term
from the Style drop-down menu in the Formatting or
Common toolbar.

Figure 4.38 The Quick Tag
Selector at the top of the Editing
Window tells you that the line is
tagged as a defined term.



To end a list:

◆ To add more items to your list—whether
numbered, bulleted, or definition—press
E once and the cursor starts a fresh,
indented line where you may continue
typing (top, Figure 4.41). When you’re
done and want to return to the regular
paragraph formatting, press E
twice. The cursor skips a line and is no
longer indented (bottom, Figure 4.41).

To remove list formatting:

1. Select a single or multiple lines from
which you want to remove numbering or
bullets.

2. If the list is numbered, click the
Numbering button in either the
Formatting or Common toolbar.

The number formatting is removed.

or

If the list is bulleted, click the Bullets but-
ton in either the Formatting or Common
toolbar.

The bullet formatting is removed.
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Figure 4.41 To add more items to the list, press E
once and the cursor starts a fresh, indented line (top).
To return to the regular paragraph formatting, press
E twice (bottom).



To create a nested sublist:

1. Click at the end of the line in your list
where you want to create a sublist, some-
times called a nested list (Figure 4.42).

2. Press E , and then press t .

Expression Web starts a new sublist
using the same list formatting as the par-
ent list (Figure 4.43).

3. Add items to the sublist, pressing E
when you need to add a new line (Figure
4.44). (To reformat the sublist, see “To
reformat lists” on the next page.)

4. When you finish adding to the sublist,
click anywhere back in the main list. To
add items to the main list, click at the
end and press E to resume (Figure
4.45).

A new, nonnested item is added to the
list (Figure 4.46).
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Figure 4.42 Click at the end of the line in your list
where you want to create a sublist.

Figure 4.43 Press E , and then press t to start
a sublist with the same formatting as the parent list.

Figure 4.44 Add items to the sublist by pressing
E when you need to add a new line.

Figure 4.45 To add items to the main list, click at
the end and press E .

Figure 4.46 A new, nonnested item is added to
the list.



To reformat lists:

1. Select the list lines you want to reformat
(Figure 4.47).

2. Choose Format > Bullets and Numbering
(Figure 4.48).

The List Properties dialog box automati-
cally displays the tab whose format
matches the selection.

3. Pick a format, or click one of the other
tabs to find what you want (Figure 4.49).

4. Click OK, and the selected lines are refor-
matted (Figure 4.50).

✔ Tips

■ Reformatting leaves any nested lists in
their original format (Figure 4.51).

■ While the List Properties dialog box
includes an option to use your own cus-
tomized picture bullets, you’ll have more
flexibility if you leave the tab set to Use
current CSS style (Figure 4.52). That 
way you can create and update custom
bullets across your site. For more infor-
mation, see “Creating Styles with CSS” 
on page 121.
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Figure 4.48 Choose Format >
Bullets and Numbering.

Figure 4.47
Select the 
list lines 
you want to
reformat.

Figure 4.51
Reformatting
preserves any
nested lists in
their original
format.

Figure 4.50 The selected lines are
reformatted based on your choice in
the List Properties dialog box.

Figure 4.52 While the List Properties
dialog box lets you use customized
picture bullets, you’ll have more
flexibility if you leave the tab set to
Use current CSS style.

Figure 4.49 In the List Properties dialog
box, pick a format or click one of the other
tabs to find what you want.



Searching Text, Code, or
Tags
Beyond the standard find and replace func-
tions, you’d expect, Expression Web also lets
you search and replace bits of your code
across an entire Web site. That can be espe-
cially handy when trying to track down prob-
lems. The Find and Replace dialog box’s
many options make it easy to zero in on even
the tiniest bit of code across the largest of
sites. It also includes an option to search and
change just HTML tags.

To find text or code on a single page:

1. To search a single page, open it or select it
in the Folder List.

2. Choose Edit > Find (cF).

3. In the Find and Replace dialog box, type
what you’re searching for in the Find
what field or click the field’s drop-down
menu and choose an appropriate item
(Figure 4.53).

4. Use the Search options pane to specify
where to look, the direction of the search,
or such things as the case of the item.

5. If you click Find Next, the search item is
highlighted (Figure 4.54). The page re-
mains visible, enabling you to use the Find
Next button to move through the page.

or

If you click Find All, the first instance of
the search item is highlighted in the page
and the Find and Replace dialog box is
replaced by the Find pane listing all the
instances found. Click the Find pane’s
blue Next or Back arrows to continue
searching the page. To close the Find
pane, click the X in the pane’s title bar.

✔ Tip

■ The Split view lets you search for text or
code without having to change your view.
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Figure 4.53 In the Find and Replace dialog box, you
can use the Find what field’s drop-down menu or type
in your own text.

Figure 4.54 The search item is highlighted in
the page (top). Click the Next button to move
through the page.



To find text or code across the site:

1. Open the site you want to search, 
and select its name in the Folder List
(Figure 4.55).

2. Choose Edit > Find.

3. In the Find and Replace dialog box, type
in the Find what box the term you’re
searching for or use the field’s drop-down
menu to choose an appropriate item. If
necessary, use the Advanced pane to fur-
ther hone the search. Click Find All
(Figure 4.56).

A Find pane lists the search results 
by page, line number, and context
(Figure 4.57).

4. Click the Find pane’s blue Next result
arrow, and Expression Web automati-
cally opens the page containing the
search term and highlights it in context
(Figure 4.58).

5. Click the Find pane’s blue Next result
arrow to see the next instance of the
search term, or click the blue Back 
arrow to see the previous instance. To
close the Find pane, click the X in the
pane’s title bar.

✔ Tips

■ Since you selected the entire site in step
1, the Find where options in step 2 are
ignored (Figure 4.56).

■ In step 4, any pages not already open are
displayed automatically in the view last
used for that page, whether it’s Design,
Split, or Code.

■ You can search multiple pages without
searching the entire site. In step 1, 
c-click the pages in the Folder List
that you want to search and follow the
rest of the steps from there.
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Figure 4.55 To search an
entire site, select its
name in the Folder List.

Figure 4.57
A Find pane
lists the
search results
by page, line
number, and
context.

Figure 4.58
Click the Find
pane’s Next
arrow, and the
page contain-
ing the term
opens auto-
matically.

Figure 4.56 Type in the Find what box
the term you’re searching for, use the
Advanced pane to further hone the
search, and click Find All.



To find and replace HTML tags:

1. In the Folder List, select the entire site,
single page, or multiple pages (using 
c-click) in which you want to find 
a particular HTML tag, and choose 
Edit > Find.

2. In the Find and Replace dialog box, select
the HTML Tags tab. Set up what you
want to find and replace using the Find
tag, Replace action, and To drop-down
menus (Figure 4.59).

3. If you want, use the Find where section 
of the Search options pane to expand or
narrow the pages searched and the
Advanced section to further hone the
search. Since Expression Web cannot
undo a replace-all action, click Find All
(not Replace All).

4. When the Find pane displays the search
results, look through the Matched Text
column to see if Expression Web found
what you wanted. If you have any doubts,
select the page listing and click the blue
Next result arrow (Figure 4.60). The page
opens so that you can get a better look.

5. Once you’ve taken a good look at the
results, click the green arrow at the top 
of the Find pane (Figure 4.61).

The Find and Replace dialog box
reappears.

(continued)

71

Working with Text
S

earch
in

g
 Text, Co

de, o
r Tag

s

Figure 4.59 In the HTML Tags tab, set up what you
want to find and replace using the Find tag, Replace
action, and To drop-down menus.

Figure 4.60 When the Find pane displays the
search results, look through the Matched Text
column to see if Expression Web found what
you wanted.

Figure 4.61 Click the arrow at the top of the Find
pane to return to the Find and Replace dialog box.



6. (Optional) If necessary, you can adjust
the find and replace actions and then, 
if you’re being extra careful, select 
Find 2 in the Display results in section
(Figure 4.62). Click Find All again, and 
a second tab appears in the Find pane
(Figure 4.63). Switch between the two
tabs to compare the results. Repeat 
step 5 to return to the Find and Replace
dialog box until you’re satisfied with the
results. Then return to the Find and
Replace dialog box one last time.

7. Click Replace All in the Find and Replace
dialog box (Figure 4.64). Assuming
you’ve doubled-checked your work, click
Yes when the alert dialog box appears
(Figure 4.65).

Expression Web makes the replacements
and lists the actions in the Find pane
(Figure 4.66).

✔ Tips

■ If you’re familiar with regular expressions
and wild card searches, that option’s
available in the Advanced section of the
Find and Replace dialog box.

■ Click the HTML Rules button in the Find
and Replace dialog box if you want to add
customized rules for searching.
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Figure 4.62 You can adjust the find and replace
actions and display the results in a new pane by
selecting Find 2.

Figure 4.63 By switching the Find 1 and Find 2
tabs, you can compare the results of both
searches.

Figure 4.64 Since the action cannot be reversed,
make sure you’re ready before clicking Replace All.

Figure 4.65 Assuming you’ve doubled-
checked your work, click Yes.

Figure 4.66 Expression Web makes the replacements
and lists the actions in the Find pane.



Using Spell Check,
Thesaurus
Expression Web lets you check the spelling
on a single page or across an entire Web site.
You also can customize the spelling diction-
ary by adding words of your own. Finally, the
built-in thesaurus can be handy when you’re
hunting for just the right word.

To check spelling on a single page:

1. Open the page in which you want to
check the spelling. Choose Tools >
Spelling > Spelling (7 ), or click 
the Spelling button if the Standard 
toolbar is visible (Figure 4.67).

2. Expression Web highlights a possible
misspelling in the page while the Spelling
dialog box offers suggestions. If you want
to use a suggested word, click Change or
Change All if you want to fix every
instance of the word on that page
(Figure 4.68).

3. If you know the word’s spelled correctly—
perhaps it’s a trademark that Expression
Web doesn’t recognize—click Ignore or
Ignore All. You also can add terms to the
dictionary by clicking Add (Figure 4.69).

4. Once the spell check is done, click OK to
close the dialog box (Figure 4.70).
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Figure 4.67 To check the spelling of the
selected page(s), choose Tools > Spelling >
Spelling (top) or click the Spelling button in
the Standard toolbar (bottom).

Figure 4.68 Possible misspellings are highlighted
in the page while the Spelling dialog box offers
suggestions.

Figure 4.69 If you know the word’s spelled correctly—
perhaps it’s a trademark—you can add it to the
dictionary.

Figure 4.70 Once the spell check
is done, click OK to close the 
dialog box.



To check spelling on multiple pages:

1. In the Folder List select the entire site or
multiple pages (using c-click) in which
you want to check the spelling. Choose
Tools > Spelling > Spelling (7 ), or click
the Spelling button if the Standard tool-
bar is visible.

2. An alert dialog box asks you to confirm
whether you want to search multiple
pages or the whole site (Figure 4.71).
Click Start to close the dialog box and
begin the spell check.

3. When Expression Web displays the
results, look through the Misspelled
words column to quickly see what’s been
spotted (Figure 4.72).

4. Double-click a page to see the possible
misspellings in context. If you want to
use a suggested word, click Change or
Change All if you want to fix every
instance of the word on that page.

5. Once you’ve checked a page, Expression
Web asks if you want to see the next page
with misspellings (top, Figure 4.73).
Once you’ve checked all the pages,
Expression Web offers you to return you
to the original list of pages and words
(bottom, Figure 4.73).

6. After returning to the list of pages,
Expression Web displays which pages
have been fixed (Edited) and which have
not (Figure 4.74). If you’re done check-
ing all the pages, close the Spelling dialog
box by clicking the X in the upper-right
corner.
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Figure 4.71 An alert dialog box asks you to con-
firm if you want to search multiple pages or the
whole site before you click Start.

Figure 4.72 Look through the Misspelled words
column to quickly see what’s been spotted.

Figure 4.74 As you spell-check the listed pages,
Expression Web notes which have been fixed
(Edited) and which have not.

Figure 4.73 After
checking a page,
you can go to the
next page (top).
Once you’ve
checked all the
pages, you can
return to the origi-
nal list (bottom).



To change your spelling options:

1. Choose Tools > Spelling > Spelling
Options (Figure 4.75).

2. Look through the Spelling Options dialog
box’s choices and select those you want
to use, including Check spelling as you
type (Figure 4.76). To switch dictionar-
ies or use one you’ve customized, click
Custom Dictionaries.

3. In the Custom Dictionaries dialog box,
the default dictionary is highlighted
(Figure 4.77). To add or correct words
for this dictionary, click Edit Word List.
To switch to a new blank dictionary,
choose New. Click Add to navigate to a
supplemental or customized dictionary
of your own.

4. Choose OK to close the dialog box and
apply the dictionary changes.
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Figure 4.75 To change your spelling options,
choose Tools > Spelling > Spelling Options.

Figure 4.76 To switch dictionaries or use one
you’ve customized, click Custom Dictionaries.

Figure 4.77 To add or correct words for the default dic-
tionary, click Edit Word List. To switch to a new blank
dictionary, choose New or click Add to navigate to a
supplemental or customized dictionary.



To use the thesaurus:

1. In any open page, select a word and
choose Tools > Thesaurus (s7 )
(Figure 4.78).

2. The Thesaurus dialog box lists the word
on the left with its various meanings
(Figure 4.79). Select the correct meaning
at the bottom left, and then click any syn-
onym listed on the right. Choose Look Up
if you’re not sure what the synonym
means, or choose Replace and the
selected synonym replaces the original
word.

3. To close the dialog box, click Cancel or
the X in the upper-right corner.
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Figure 4.78 In any open
page, select a word and
choose Tools >
Thesaurus.

Figure 4.79 The selected word’s various meanings
appear at the bottom left. Pick one, and then click any
synonym listed on the right and choose Replace, or
Look Up if you’re not sure what the synonym means.



While headings and text establish the under-
lying order for your pages, it’s the images that
give them interest and pizzazz. The first sec-
tion of this chapter shows how to add and
position images. The second section explains
how to use Expression Web’s built-in Pictures
toolbar to adjust their appearance. To add
hyperlinked hotspots within images, see
“Creating an Image Hotspot” on page 115.
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Adding Images
Whether it’s click-and-dragging an image
right into a page, navigating through your
computer’s files, or pulling something
directly from a digital camera, Expression
Web makes quick work of adding images to
your pages.

To add an image:

1. Open a Web page, and click where you
want to insert an image. Choose Insert >
Picture, and make a source choice from
the drop-down menu (Figure 5.1).

2. Navigate to the image you want to use,
and click Insert (Figure 5.2).

3. Add a brief description of the image in
the Alternate text box and, if you like, a
more detailed one in the Long descrip-
tion box (Figure 5.3).

4. Click OK, and the image appears in the
page. If necessary, press E to add a
line break and bump the heading or text
to the next line (Figure 5.4).

5. Save the change (cS), and if you’re
adding an image not already included
among your Web site files, the Save
Embedded Files dialog box appears
(Figure 5.5). Click Change Folder to 
navigate to where on the site you want 
to save the image (see the sixth tip).

When you’re done click OK, and the
image is saved to your chosen folder.
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Figure 5.1 To add an image, choose Insert >
Picture, and pick a source.

Figure 5.2 Navigate to the image you want to use,
and click Insert.

Figure 5.3 Add a brief description in the
Alternate text box, and, if you like, a more
detailed one as well.

Figure 5.4 When the image appears in the
page, if necessary, add a line break to bump
the text to the next line.



✔ Tips

■ In step 1, if you have a digital camera or
scanner connected to your computer, you
can insert a picture directly from either
device. But in practice, such images will
be much larger than you’ll want to use in
a page. You’re better off importing those
images onto your hard drive and editing
them for size before inserting them into
your pages.

■ You also can use the Insert Picture 
from File button found in the Pictures,
Standard, and Common toolbars 
(Figure 5.6). The Pictures toolbar
includes the most used image tools, 
so you may want to turn it on: Choose
View > Toolbars > Pictures.

■ If the image has already been saved to
your site, you can click and drag it from
the Folder List pane onto the page
(Figure 5.7).

■ In step 2, you may find it easier to identify
the images you want if you switch your
folder view to Large or Extra Large Icons
(Figure 5.8).

■ In step 3, the alternate text applied to an
image can be read aloud by special pro-
grams used by the visually impaired. It
also helps visitors with slow connections
get some sense of a page’s images before
they finish downloading, since the text
appears instantly.

■ In step 5, keep your site files tidy by sav-
ing pictures to the main images folder
or—if you’re dealing with hundreds of
images—create a separate images folder
for each section of the site.

■ The image used in this example was sized
ahead of time for the space. For more
information, see “Resizing and
Resampling Images” on page 93.
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Figure 5.5 The Save Embedded Files dialog
box appears whenever you save new files to
your site.

Figure 5.6
The Insert
Picture from
File button is
found in the
Pictures,
Standard, 
and Common
toolbars.

Figure 5.7 Any image already in your site
files can be clicked and dragged from the
Folder List pane onto the page.

Figure 5.8 When navigating among files,
you may find it easier to spot an image by
switching your folder view to Large or Extra
Large Icons.



To move an image:

1. Click a picture to select it, and a series of
small, square handles appear on its cor-
ners and sides (Figure 5.9).

2. While still pressing your mouse button,
drag the cursor to where you want to
move the picture (Figure 5.10).

3. Release the cursor, and the picture moves
to the new spot (Figure 5.11).
Depending on how your text and head-
ings flow around the picture, you may
need to change the picture’s wrapping
style. (See “To set horizontal alignment”
on the next page.)
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Figure 5.9 Select a picture, and clickable
square handles appear on its corners and
sides.

Figure 5.10 While still pressing your
mouse button, drag the cursor to
where you want to move the picture.

Figure 5.11 Release the cursor, and the picture moves
to the new spot.



Aligning Images
Horizontal alignment, sometimes called
wrapping, controls how your pictures align
with items to the left or right. Vertical align-
ment, often just called alignment, controls
whether a picture sits at the same level,
above, or below the items on either side of 
it. Those items can be pictures or text.

To set horizontal alignment 
(wrapping style):

1. Double-click a picture (Figure 5.12).

2. When the Picture Properties dialog box
appears, select the Appearance tab. By
default, the Wrapping style is set to None
with no margins. Depending on how you
want text to wrap around the picture,
select Left or Right (Figure 5.13).

3. You also can set the picture’s (vertical)
alignment with the Alignment drop-
down menu. (For details, see “To set ver-
tical alignment” on the next page.)

4. Click OK to chose the dialog box and
apply your changes.

The text and picture readjust as specified
(Figure 5.14).

✔ Tips

■ If the Common or Formatting toolbar is
visible, you can click the alignment but-
tons to set the image’s wrapping style
(but not its vertical alignment).

■ You also can open the Picture Properties
dialog box by right-clicking a picture and
choosing Picture Properties in the drop-
down menu.

■ While the Picture Properties dialog box
includes boxes for setting margins, the
click-and-drag methods explained on
page 86 are much easier to use.
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Figure 5.13 Depending on how you want text to
wrap around the picture, select Left or Right in the
Picture Properties dialog box.

Figure 5.12 To set horizon-
tal alignment, double-click
a picture.

Figure 5.14 The text and picture
adjust as specified (left in this
example).



To set vertical alignment:

1. Double-click a picture, and when the
Picture Properties dialog box appears,
select the Appearance tab.

Naturally enough, the Alignment drop-
down menu is normally set to Default
(Figure 5.15).

2. Use the drop-down menu to make a
choice (Figure 5.16). Stick to using
Default, Top, Middle, and Bottom. The
other alignment choices are no longer
supported by modern Web browsers.

3. Click OK to chose the dialog box and
apply your changes.

The picture’s alignment with the adjacent
text readjusts based on your choice
(Figure 5.17).
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Figure 5.16 Use the drop-down menu to make a
choice. Stick to using Default, Top, Middle, and
Bottom.

Figure 5.15 Naturally enough, the vertical alignment
drop-down menu is normally set to Default.

Figure 5.17 The picture’s
vertical alignment with the
adjacent text readjusts
based on your choice 
(top in this example).



✔ Tips

■ The effect of your alignment choice
depends on the selected Wrapping style.
For example, compare Figure 5.17,
which has a top alignment with no wrap,
to Figure 5.18, which also has a top
alignment but a left wrap.

■ Take a look at Figures 5.19, 5.20, and
5.21, to get a sense of how the alignment
choices differ.
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Figure 5.19 Three images with the default vertical
alignment.

Figure 5.20 Three images with a top vertical alignment.

Figure 5.21 The left and right images have a top align-
ment; the middle image has a middle alignment.

Figure 5.18 Here a 
left wrap has been
added to the top
alignment example 
of Figure 5.17.



Adding Borders, Margins,
or Padding
If you find it hard sometimes to remember
what’s a border versus a margin or padding,
take a look at Figure 5.22. It appears in 
the New Style dialog box and offers a quick
visual primer on keeping them straight. 
To make things even easier, you can simply
click and drag to change margins and
padding. While you can adjust them for 
each picture, consider using CSS to create
several margin/padding styles, which then
can be applied to pictures across the site. 
For more information, see “Creating Styles
with CSS” on page 121.

To add borders to an image:

1. In Design or Split view, click the picture
to which you want to add a border
(Figure 5.23).

2. Choose Format > Borders and Shading
(Figure 5.24).

In the Borders and Shading dialog box,
the Borders tab is selected by default
(Figure 5.25).
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Figure 5.22 A handy graphic from the New Style dia-
log box shows the differences between borders, mar-
gins, and padding.

Figure 5.23 Select the image to which you
want to apply a border.

Figure 5.25 The Borders tab is selected
by default.

Figure 5.24 Choose Format >
Borders and Shading to reach
the Borders and Shading dia-
log box.



3. Make your Setting, Style, Color, and
Width choices based on what you see in
the Preview area (Figure 5.26). Click OK.

The dialog box closes, and the border is
applied (Figure 5.27).

✔ Tips

■ If you want to change the border, choose
Format > Borders and Shading again and
make new choices in the Borders and
Shading dialog box.

■ In the Borders and Shading dialog box,
select Default to immediately remove the
border entirely. If you just press B
to make the text box blank, the border
will not disappear.

■ If the Common toolbar is turned on, 
you can quickly add a 1-pixel-wide black
border around the entire image by click-
ing the Border button and selecting the
first button in the drop-down menu
(Figure 5.28).

85

Working with Images
A

ddin
g

 B
o

rders to
 an

 Im
ag

e

Figure 5.26 Make your Setting, Style, Color, and
Width choices based on what you see in the
Preview area.

Figure 5.27 The border choices made in step 3 applied
to the image.

Figure 5.28 You can quickly add a 1-pixel-wide black
border to an image by clicking the Picture toolbar’s
Border button and selecting the first button in the
drop-down menu.



To add margins to an image:

1. In Design or Split view, click the picture,
and at its corners you see thin, beige
lines. Move your cursor over any line, and
the cursor becomes a two-headed arrow
(Figure 5.29).

2. Click and drag the line to change the hori-
zontal margin, using the small margin size
box as a guide (Figure 5.30). Release the
cursor when you’re satisfied with the size.

3. Use the same method to adjust the verti-
cal margin if needed (Figure 5.31).
Release the cursor when you’re satisfied
(Figure 5.32).

4. Be sure to save your changes (cS).

✔ Tips

■ In step 1, if you see a four-headed arrow,
you need to move the cursor out from the
edge of the image until it becomes a two-
headed arrow.

■ Small diagonal lines fill the image’s mar-
gin area, giving you another way to gauge
its size.
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Figure 5.29 To add margins to an image,
click and drag the thin beige lines appearing
at the corners.

Figure 5.30 Click and drag the line to change the
horizontal margin, using the small margin size box
as a guide.

Figure 5.31 You can use the same method
to adjust the vertical margin.

Figure 5.32 Release the cursor when you’ve
adjusted the margins to your satisfaction.



To add padding to an image:

1. In Design or Split view, on the picture and
press s , and four, light-blue lines
appear inside the picture’s edge (Figure
5.33).

2. Click and drag any of the lines to add
padding to that side of the picture, using
the small padding size box as a guide
(Figure 5.34). Release the cursor when
you’re satisfied with the amount of
padding.

3. If you want to add padding to any side of
the picture, repeat step 2 (Figure 5.35).

4. Be sure to save your changes (cS).

✔ Tips

■ The light-blue padding lines actually
extend beyond the picture’s edge but are
harder to see there, especially against a
white page background.

■ If you have a hard time distinguishing the
light-blue padding lines from the light-
beige margin lines, select the picture and
press s two or three times. Expression
Web toggles between highlighting the
padding and margin lines.
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Figure 5.34 Click
and drag any of
the lines to add
padding to that
side of the picture,
using the small
padding size box
as a guide.

Figure 5.33 Click on the picture and
press s , and four, light-blue lines
appear inside the picture’s edge.

Figure 5.35 You can add padding to any
side of the image.



Editing Images
For major image editing, it’s best to use a dedi-
cated graphics program, but the Pictures tool-
bar can handle lots of simple editing tasks.
Whether you want to flip an image, adjust its
contrast, or make it black and white, the basic
steps remain the same. See “To make simple
image changes” on the next page. The rest of
the chapter explains more involved tasks:
cropping, resizing or resampling, making
thumbnails, and setting a transparent color.

When you edit an image, you have the option
of saving the changes as a new file or replac-
ing the original. To be extra safe, always keep
a duplicate of the original image stored out-
side your Web site. The Restore button,
explained first because it lets you undo edits,
quickly becomes one of your best safeguards
against mistakes.
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To make simple image changes:

1. In Design or Split view, click the picture
you want to change (Figure 5.36).

2. Click the appropriate button in the
Pictures toolbar (Figure 5.37). (See
“Picture Toolbar Options” below.)

The image in the Web page changes
based on your choice (Figure 5.38).

3. To save your changes, see “To save image
changes” on the next page.

To restore an edited image:

1. If after making an edit, you want to undo
the change, click the Restore button .

The image reverts to its appearance
before the most recent change.

2. Continue clicking the Restore button to
step backward through the changes made
since the last time the image was saved.

✔ Tip

■ The Restore button only works if you
have not saved the changes.
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Figure 5.37 Click the appropriate button in the Pictures
toolbar (in this case, the horizontal flip button).

Figure 5.36 To make
simple editing
changes, begin by
selecting the image.

Figure 5.38 The
image in the Web
page changes based
on your choice.

Table 5.1

U s e To

Insert a picture from your computer, digital camera, or scanner

Create smaller version of image linked to larger original (See “To create a thumbnail image” on page 95.)

or Rotate picture to left or right

or Flip picture horizontally or vertically

or Increase or decrease picture’s contrast

or Increase or decrease picture’s brightness

Crop picture (See “To crop an image” on page 92.)

Make one color in the picture transparent (See “To set transparency” on page 101.)

Make a picture black and white or wash out the color

Add a bevel around a picture

Resample a picture (See “Resizing and Resampling Images” on page 93.)

Create hyperlinked hotspots in picture (See “To create hotspots” on page 115.)

Restore image to its appearance before changes

Pictures Toolbar Options



To save image changes:

1. To save any changes you make to a pic-
ture, press cS . In the Save Embedded
Files dialog box, which lists all the files
you’ve changed, select an image to save
(Figure 5.39).

2. If you want to save the edited version 
as a new file, click Rename and type a
new name (leave the suffix .jpg as is)
(Figure 5.40). The pending Action listed
for the file changes from Overwrite to
Save (Figure 5.41). Click OK.

or

If you want to replace the original image
file with your changes, simply click OK.

3. Based on your choice in step 2, the edited
picture replaces the original or is saved as
a new file.
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Figure 5.39 The Save Embedded Files dialog box
lists all the files you’ve changed or added since
your last site-wide save.

Figure 5.41 Once you rename the file, the pending
Action changes from Overwrite to Save.

Figure 5.40 To save the edited version as a new file,
click Rename and type a new name (leave the suffix
.jpg as is).



✔ Tips

■ If you rename the edited image, that 
new file is added to the Folder List
(Figure 5.42).

■ Web sites often contain hundreds of
images, especially since you often 
need multiple sizes of the same image 
for different sections of your layouts. 
For that reason, naming an image
treefern_small.jpg, as Expression 
Web does, isn’t specific enough. If my
site’s page layouts typically need images
50, 100, and 288 pixels wide, I name the
images accordingly: treefern50.jpg,
treefern100.jpg, and treefern288.jpg.
I instantly know which version to grab
when navigating through file lists, and by
putting the number at the end of the
name, all those tree images are listed
together. When I need to generate a new
image size, this same scheme makes it
obvious that the original file is named
treefern.
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Figure 5.42 When you
rename an edited image, 
a new file is added to the
Folder List.



To crop an image:

1. In Design or Split view, click the picture
that you want to crop (Figure 5.43).

2. Click the Crop button in the Pictures
toolbar (Figure 5.44).

3. A dashed line appears in the picture,
marking the crop boundaries (Figure
5.45). Click and drag any of the small,
square handles to resize, and reposition
the crop boundaries (Figure 5.46).

4. Click the Crop button again, or double-
click any of the handles, or press E .

The picture is cropped to the boundaries
(Figure 5.47).

5. Save your changes (cS), as explained
in “To save image changes” on page 92.
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Figure 5.44 Click the Crop button in the Pictures
toolbar.

Figure 5.47 Click the Crop button
again, double-click any of the
handles, or press E , and
the crop is applied.

Figure 5.43
Click to select
the picture you
want to crop.

Figure 5.45
A dashed line
appears in 
the picture,
marking the 
crop boundaries.

Figure 5.46
Click and drag
any of the small,
square handles
to resize and
reposition the
crop boundaries.



Resizing and Resampling
Images
Whenever you insert an image on a page, 
its dimensions are automatically included in
the HTML coding. If you want to signifi-
cantly enlarge an image, you’ll get better
looking results going back to the original
image and using a dedicated graphics pro-
gram to create a new version for importing
to the site. However, if you only need to make
relatively minor size adjustments (10 percent
or less), you can just resize and resample the
original. Another way to deal with larger
images is to create a series of quick-to-down-
load thumbnail images that link to larger,
higher quality versions.

To manually resize and resample an
image:

1. In Design or Split view, click the picture
and then drag any of the square-shaped
along its edge to a new position 
(Figures 5.48 and 5.49).

2. Release the cursor.

The image assumes its new size 
(Figure 5.50).

3. To resample the resized image, click the
Resample button in the Pictures toolbar
(Figure 5.51). You also can click the
Picture Actions button at the image’s
lower right and choose Resample Picture
To Match Size (Figure 5.52).

The picture is resampled, though you
may not see a significant different.

4. Save your changes (cS) as explained
in “To save image changes” on page 90.
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Figure 5.48 To quickly resize an image, click
any of the square handles along the edge.

Figure 5.50 Release the cursor, and
the image assumes its new size.

Figure 5.51 To resample the resized image, click
the Resample button in the Pictures toolbar.

Figure 5.49 Click and
drag to resize the
image on the fly.

Figure 5.52 You also can click the button at the
image’s lower right and choose Resample Picture To
Match Size.



To precisely resize and resample 
an image:

1. In Design or Split view, double-click a pic-
ture. When the Picture Properties dialog
box appears, select the Appearance tab.

2. Select the Specify size checkbox, and in
the Width or Height text box type the
size (pixels or percent) you want (top,
Figure 5.53). If you also select Keep
aspect ratio, the number in the other
dimension text box automatically
changes in response to your entry to
maintain the image’s proportions (bot-
tom, Figure 5.53). Click OK.

The dialog box closes, and the image
changes to match the new dimensions.

3. To resample the image, click the
Resample button in the Pictures toolbar.
You also can click the Picture Actions
button at the image’s lower right and
choose Resample Picture To Match Size.

The picture is resampled to match the
new size.

4. Save your changes (cS), as explained
in “To save image changes” on page 90.

✔ Tip

■ In step 2, if you uncheck the Keep aspect
ratio checkbox, you can size the width
and height independently (Figure 5.54).
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Figure 5.53 To precisely resize an image, select the
Specify size checkbox and use the Width or Height
text boxes (top). If you select Keep aspect ratio, the
number in the other dimension text box automatically
changes in response to your entry to maintain the
proportions (bottom).

Figure 5.54 If you uncheck the Keep aspect ratio
checkbox, you can size the width and height inde-
pendently.



To create a thumbnail image:

1. In Design or Split view, insert the large
version of the image for which you want
to create a thumbnail and then click to
select the image (Figure 5.55).

2. In the Pictures toolbar, click the Auto
Thumbnail button (cT) (Figure 5.56).

The original image is replaced by a
thumbnail image (Figure 5.57).

3. Continue to add large, original images to
the page as needed, repeating step 2 with
each one (Figure 5.58).

4. Save your changes (cS), as explained
in “To save image changes” on page 90.

(continued)
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Figure 5.55 Insert and then select the large version of
the image for which you want to create a thumbnail.

Figure 5.56 In the Pictures toolbar, click the Auto
Thumbnail button (cT ).

Figure 5.57 The large, original image is replaced by a
thumbnail image.

Figure 5.58 Continue adding large images to the page
and converting them to thumbnails as needed.



5. To view the page of thumbnails in your
Web browser, press = .

Your default Web browser launches 
and displays the page of thumbnails
(Figure 5.59).

6. Click any thumbnail in your Web browser,
and the larger, original image is displayed
(Figure 5.60).

✔ Tips

■ You don’t need to create a page before-
hand to hold the larger image. Using
these steps, any image file in your Folder
List is served up to the browser from the
automatically linked thumbnail.

■ In step 2, you also can right-click the
large image and choose Auto Thumbnail
in the drop-down menu (Figure 5.61).
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Figure 5.59 To view the thumbnails page in your
Web browser, press = and click any image.

Figure 5.60 Your browser immediately retrieves and
displays the large, original image.

Figure 5.61 You also can right-click
the large image and choose Auto
Thumbnail in the drop-down menu.



To change the thumbnail default size:

1. Choose Tools > Page Editor Options.
Select the Auto Thumbnail tab to see the
default settings (Figure 5.62).

2. Use the Set drop-down menu to change
which aspect of the thumbnail’s size to
control (Figure 5.63). Type a number in
the Pixels box. If you want a border
applied, leave Border thickness selected
and type how many pixels wide it should
be. You also can add a beveled edge.

3. Click OK to close the dialog box and
apply the settings to future thumbnails.
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Figure 5.62 To see the default settings, select the Auto
Thumbnail tab in the Page Editor Options dialog box.

Figure 5.63 Use the Set drop-down menu to change
which aspect of the thumbnail’s size to control.



Setting Image Formats
Just two file formats are used for virtually all
Web images: GIFs and JPEGs. GIFs
(CompuServe’s Graphics Interchange
Format) work best for buttons, solid blocks
of color, and illustrations. JPEGs (originally
developed by the Joint Photographic Experts
Group) work best for photos since they can
display millions of colors in relatively com-
pact files. A third file format, PNG (Portable
Network Graphics) is slowly gaining accept-
ance now that version 4 and later Web
browsers support the format. PNG files 
compress images nicely without losing as
much information as a JPEG and sidestep 
an ongoing legal dispute over GIF rights.

By default, Expression Web saves photos as
JPEGs, with a quality level of 90, which is
fairly high. If you really need to shave some
bits off photo files, you could change them to
the PNG format or lower their default JPEG
quality to around 60 to 65, which still mostly
avoids adding jagged lines to the image. For
more information, see “To change format
defaults” on the next page. You also have the
option of changing those settings for a single
image. For more information, see “To change
a single image’s format” on page 100.

When using GIFs for buttons, it can be
handy to set a single color as transparent.
That enables you, for example, to create the
illusion of a round or irregularly shaped but-
ton by setting the color to match the page’s
background color. For more information, see
“To set transparency” on page 101.
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Figure 5.64 To change image format defaults, click the
File Type Settings button in the Pictures tab of the
Page Editor Options dialog box.



To change image format defaults:

1. Choose Tools > Page Editor Options >
Picture, and click the File Type Settings
button (Figure 5.64).

2. In the Picture File Type dialog box, use
the checkboxes to change your GIF
default and the text boxes for your JPEG
defaults (Figure 5.65).

3. Click OK to close the dialog box and
apply the settings to newly created
images (Figure 5.66).

✔ Tips

■ In step 1, if you want to save all your pho-
tos as PNG files instead of JPEGs, select
png in the second drop-down menu
(Figure 5.67).

■ In step 2, unless you’ll be creating lots of
GIF buttons with transparent edges to
show the background color, it’s best not
to select Transparent, since you can set
this feature individually in your images
(Figure 5.65).
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Figure 5.65 Use the checkboxes to change the 
GIF defaults and the text boxes to change the JPEG
defaults.

Figure 5.66 Click OK to close the dialog box, and the
settings are applied to any newly created images.

Figure 5.67 To save all your photos as PNG files instead
of JPEGs, select png in the second drop-down menu.



To change a single image’s format:

1. Double-click an image on a Web page to
open the Picture Properties dialog box.

2. Select the Appearance tab, and click
Picture File Type (Figure 5.68).

3. Select another format (Figure 5.69). You
also can change the quality level for a
JPEG file by unchecking the Use image as
is checkbox and then entering new set-
tings in the Quality and Progressive
passes text boxes.

4. Click OK to close the dialog box and
apply the settings to the selected image
(Figure 5.70). When the Picture
Properties dialog box reappears, click OK
to close it.
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Figure 5.68 To change a single image’s format,
click Picture File Type in the Appearance tab.

Figure 5.69 Select another format, or change the
quality level for a JPEG file by clearing the Use
image as is checkbox.

Figure 5.70 Click OK to close the dialog box and
apply the settings to the selected image.



To set transparency:

1. In Design or Split view, click to select the
picture to which you want to apply trans-
parency (Figure 5.71).

2. Click the Set Transparent Color button in
the Pictures toolbar (Figure 5.72).

3. If the selected image is formatted as a
JPEG, which doesn’t support trans-
parency, click OK when an alert dialog
box offers to convert the image to the GIF
format (Figure 5.73).

4. As you move the cursor arrow over the
selected image, it becomes a pencil eraser
(Figure 5.74). Click the eraser on the
color you want to become transparent.

The targeted color becomes transparent,
allowing the page’s background color to
show through (Figure 5.75).
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Figure 5.72 Click the Set Transparent Color button in
the Pictures toolbar.

Figure 5.73 If the selected image is formatted as a
JPEG, an alert dialog box offers to convert the image
to a GIF.

Figure 5.71 Select the picture
to which you want to apply
transparency to match the
page background.

Figure 5.74 Click the eraser on
the color you want to become
transparent.

Figure 5.75 The targeted color
becomes transparent, allow-
ing the page’s background
color to show through.
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The Web’s power springs from the user’s 
ability to jump from file to file anywhere in
the world. Hyperlinks make that possible.
Hyperlinks, or simply links, come in several
varieties: external links to anywhere in the
world, links to other spots in the same 
document, links to send email, and links
embedded in pictures. Expression Web
makes it easy to create them all. Changing
the default link colors, by the way, is covered
in “Creating Styles with CSS” on page 121.
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Adding Links
Some of your links will point to a file out 
on the Web. Many of your links will point 
to another page within your Web site.
Expression Web automatically creates
absolute links to those external Web files 
and a relative links to pages in your Web 
site. Absolute links always include the 
full URL, including the http protocol:
http://www.waywest.net/expression/.
Relative links include just the file name 
and enclosing folder: /ExamplePages/
creatinglinks.htm. The great advantage 
of relative links is that you can rearrange
your site as much as you like, and Expres-
sion Web keeps all your links intact.

To link to a page in your Web site:

1. Select the text you want to link, right-
click, and choose Hyperlink from the
drop-down menu (Figure 6.1).

2. By default, the Insert Hyperlink dialog
box shows your current site (Figure 6.2).
Use the center area to navigate to the 
target of your link, and once it’s selected,
click OK (Figure 6.3).

The dialog box closes, and the selected
text is linked to the other page 
(Figure 6.4).

✔ Tip

■ In step 1, you also can select the text and
click the Hyperlink button in the
Standard toolbar (Figure 6.5).
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Figure 6.1 Select the
text you want to link,
right-click, and choose
Hyperlink.

Figure 6.3 Use 
the center area to
navigate to the
target of your link,
and once it’s
selected, click OK.

Figure 6.2 By default, the Insert Hyperlink dialog box
shows your current site.

Figure 6.4 The selected text
is linked to the other page.

Figure 6.5 You also can select the text and click the
Hyperlink button in the Standard toolbar.

http://www.waywest.net/expression/


To link to a not-yet-created page:

1. Select the text you want to link, right-
click, and choose Hyperlink from the
drop-down menu.

2. Click the Create New Document button
in the Insert Hyperlink dialog box (top,
Figure 6.6). Name the new page, and 
if you don’t want to stop what you’re
doing, select Edit the new document 
later (bottom, Figure 6.6).

3. Click OK.

The dialog box closes, and the new 
blank page is created and added to the
Folder List.
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Figure 6.6 To link to a not-yet-created page, click the
Create New Document button (top). Name the new
page, and select Edit the new document later (bottom).



To link to an external Web page:

1. Select the text you want to link, right-
click, and choose Hyperlink from the
drop-down menu.

2. Click the Browse the Web button 
(Figure 6.7).

If it is not already running, your default
Web browser launches.

3. Surf to the page to which you want to
link, and press at .

The Insert Hyperlink dialog box reap-
pears with the page’s address inserted in
the Address text box (Figure 6.8).

4. Click OK.

The dialog box closes, and the selected
text is linked to the external Web address
(Figure 6.9).

✔ Tips

■ In step 2, if you know the Web address,
you can type directly in the Address text
box.

■ In step 3, you also can use the Address
drop-down menu to select recently vis-
ited Web pages (Figure 6.10).
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Figure 6.7 To link to an external Web page, click the
Browse the Web button.

Figure 6.8 After finding the page with your Web
browser, press at and its address appears in the
Address text box.

Figure 6.9 The selected text now
is linked to the external Web
address.

Figure 6.10 You also can use the Address drop-
down menu to select recently visited Web pages.



To change a link:

1. Right-click the linked text, and choose
Hyperlink Properties from the drop-down
menu (Figure 6.11).

2. In the Edit Hyperlink dialog box, surf to a
new site, navigate to another page, or use
the Address drop-down menu to make a
new choice.

3. Click OK.

The dialog box closes, and the selected
text is linked to your new address choice.

To remove a link:

1. Right-click the linked text. and choose
Hyperlink from the drop-down menu.

2. In the Edit Hyperlink dialog box, click
Remove Link (Figure 6.12).

The dialog box closes, and the selected
text is no longer linked.
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Figure 6.12 To remove a link, click Remove Link in the
Edit Hyperlink dialog box.

Figure 6.11 To
change a link, right-
click and choose
Hyperlink Properties.



To create an email link:

1. Right-click the linked text, and choose
Hyperlink from the drop-down menu.

2. In the Insert Hyperlink dialog box, click
E-mail Address (Figure 6.13).

3. Type a subject and an address; Expression
Web automatically includes mailto: at
the beginning (Figure 6.14).

4. Click OK.

The dialog box closes, and the selected
text is linked to the new email address.
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Figure 6.13 To create an email link, click E-mail Address
in the Edit Hyperlink dialog box.

Figure 6.14 Type a subject and an address; Expression
Web automatically includes mailto:.



Targeting Links
Normally when you click a hyperlink, your
Web browser replaces the current page with
the new page. You can, however, set the link
so that the new (target) page opens in a new
window. This can be useful for external links,
since your visitor can still see your site in the
original window.

To set a link target:

1. Right-click an existing text link, and
choose Hyperlink from the drop-down
menu.

2. In the Edit Hyperlink dialog box, click
Target Frame (Figure 6.15).

3. In the Target Frame dialog box, select
New Window (Figure 6.16).

4. Click OK.

The dialog box closes, and the Edit
Hyperlink dialog box reappears.

5. Click OK.

The Edit Hyperlink dialog box closes, and
the change is applied to the linked text.

✔ Tips

■ If your site uses frames, you also can
choose Same Frame or Parent Frame. But
many search engines have trouble reading
frames, so consider switching your site to
CSS positioning in the long run.

■ In step 3, if you want all your links to
open in a new window, select Set as page
default.
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Figure 6.15 To set a link target, click Target Frame in
the Edit Hyperlink dialog box.

Figure 6.16 Select New Window in the
Target Frame dialog box.



Adding ScreenTips
Expression Web calls them ScreenTips,
JavaScript call them tooltips; but whatever
their name, they’re a common sight on the
Web. Roll your cursor over a link on a Web
page, and a little tag appears that provides a
clue about the linked content. You don’t have
to create them of course, but they do help
visitors find their way around, so add them
when you can.

To add a ScreenTip:

1. Right-click an existing text link, and
choose Hyperlink from the drop-down
menu.

2. In the Edit Hyperlink dialog box, click
ScreenTip (Figure 6.17).

3. In the Set Hyperlink ScreenTip dialog
box, type the tip (Figure 6.18).

4. Click OK.

The dialog box closes, and the Edit
Hyperlink dialog box reappears.

5. Click OK.

The Edit Hyperlink dialog box closes, and
the change is applied to the linked text.

6. Press = to launch your default Web
browser, and roll your cursor over the text
to test the ScreenTip (Figure 6.19).

✔ Tip

■ ScreenTips work in most modern
browsers, not just Internet Explorer.
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Figure 6.17 Click ScreenTip in the Edit Hyperlink dia-
log box.

Figure 6.18 Add the tip text, and click OK.

Figure 6.19 In a Web browser,
roll your cursor over the text to
test the ScreenTip.



Adding Bookmarks
(Anchors)
Bookmarks, often called anchor links, let vis-
itors jump to specific spots, such as section
headings, in a long Web page. Creating
anchors is a two-step process: first you create
the bookmark itself (the anchor), and then
you create the hyperlink that points to the
bookmark.

To create a bookmark:

1. Select the text you want the reader to
jump to, that is, the target or destination.

2. Choose Insert > Bookmark (cG)
(Figure 6.20).

3. The Bookmark dialog box automatically
uses the selected text as the bookmark’s
name (Figure 6.21). If you prefer, type
another name.

4. Click OK.

The dialog box closes, and the selected
text is bookmarked, indicated by a
dashed underline (Figure 6.22). See the
next step to link to the bookmark.
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Figure 6.21 The Bookmark dialog box
automatically uses the selected text
as the bookmark’s name.

Figure 6.22 The bookmark
is underlined with dashes.

Figure 6.20 To create a book-
mark, select the text and
choose Insert > Bookmark.



To link to a bookmark:

1. Select the text you linked to a bookmark,
right-click, and choose Hyperlink from
the drop-down menu.

2. In the Insert Hyperlink dialog box, navi-
gate to the page containing the bookmark
(anchor). Select it in the main window,
and click Bookmark (Figure 6.23).

3. In the Select Place in Document dialog
box, select the bookmark you want to use
(Figure 6.24). In the example, there’s only
one, but you may have pages with multi-
ple bookmarks from which to choose.

4. Click OK.

The dialog box closes, and the Insert
Hyperlink dialog box reappears.

5. Click OK (Figure 6.25).

The Insert Hyperlink dialog box closes,
and the selected text is now linked to the
bookmark.
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Figure 6.24 Select
the bookmark,
and click OK.

Figure 6.23 To link to a bookmark, navigate to the
page and click Bookmark.

Figure 6.25 Click OK to close the dialog box and apply
the link.



To clear a bookmark:

1. Select the text you previously marked as 
a bookmark. Right-click, and choose
Bookmark Properties in the drop-down
menu (Figure 6.26).

2. Select the bookmark’s name, and click
Clear (Figure 6.27).

3. Click OK to close the Bookmark dialog
box.

The selected text is no longer book-
marked.
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Figure 6.26 To clear a bookmark,
right-click the text and choose
Bookmark Properties.

Figure 6.27 Select
the bookmark’s
name, and click
Clear.



Creating Image Links
You can link an entire image to a file, or you
can create what’s called a hotspot, which
links a defined area within the image to
another file. By putting multiple hotspots in
an image, you can create multiple links to
multiple files.

To link an entire image to a file:

1. Open the page containing the image you
want linked. Right-click the image, and
choose Hyperlink from the drop-down
menu (Figure 6.28).

2. In the Insert Hyperlink dialog box, navi-
gate to the page to which you want to
link, and click OK (Figure 6.29).

The dialog box closes, and the selected
image is linked to the selected page.
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Figure 6.28 To link an entire image to a file, right-click
the image and choose Hyperlink.

Figure 6.29 Navigate to the page to which you want
to link, and click OK.



To create an image hotspot:

1. Click the image in which you want to cre-
ate hotspots.

2. In the Pictures toolbar, click one of the
three hotspot buttons (rectangle, circle,
polygon) (Figure 6.30).

3. When you choose a shape, the cursor
arrow becomes a pencil, allowing you to
draw the hotspot’s boundary in the image
(Figure 6.31). Outline the boundary,
clicking whenever you need to change
direction.

4. Double-click when you finish outlining
boundary.

The Insert Hyperlink dialog box appears,
allowing you to navigate to the desired
file or bookmark (Figure 6.32). (For
more on using the dialog box, see “To link
to a page in your Web site” on page 104.)
In the example, the hotspot links to a
bookmark.

5. Click OK.

The dialog box closes, and the area is
linked to the file.

6. Repeat the steps to add multiple hotspots
linked to multiple files.

✔ Tips

■ Press q if you need to start over draw-
ing a polygon.

■ Hotspots cannot overlap or extend beyond
the image boundaries. For both reasons,
you may realize that the image itself needs
enlarging. Just grab one of the image’s han-
dles and drag it to give your hotspot more
room, and then reposition and resize the
hotspots as needed. If you wind up enlarg-
ing the image by more than 10 percent,
however, go back to your original and cre-
ate a fresh, larger version. Otherwise, the
image winds up looking fuzzy.
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Figure 6.31 When you choose a shape, the cursor
arrow becomes a pencil, allowing you to draw the
hotspot’s boundary.

Figure 6.32 Navigate to the desired file or bookmark
that you want linked to the hotspot.

Figure 6.30 To create an image hotspot, click one of
the three hotspot buttons in the Pictures toolbar.



To adjust a hotspot:

1. Select any handle along the hotspot’s
boundary (Figure 6.33).

2. Click and drag the handle to a new posi-
tion, and then release the cursor button
(Figure 6.34).

3. Continue adjusting the hotspot handles
as necessary until you’re done.

To find hotspot boundaries:

1. If you’re having trouble finding hotspots
within an image, select the image and
click the Highlight Hotspots button in
the Pictures toolbar (Figure 6.35).

The image disappears, enabling you to see
all the image’s hotspots (Figure 6.36).

2. Click the Highlight Hotspots button
again.

You return to the regular view of the
image, where you can then adjust the
boundaries as needed.

To change or delete a hotspot link:

1. Double-click the hotspot whose link
needs changing.

The Edit Hyperlink dialog box appears.

2. Navigate to your new link target file or
bookmark, or click Remove Link.

3. Click OK.

The Edit Hyperlink dialog box closes, and
the link is updated or removed.
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Figure 6.33 To adjust a
hotspot, select any han-
dle along the boundary.

Figure 6.34 Click and
drag the handle to a
new position.

Figure 6.35
To find hotspot
boundaries, click
the Highlight
Hotspots button
in the Pictures
toolbar.

Figure 6.36
The image disap-
pears, enabling
you to see all the
hotspots.



Using the Hyperlinks Tools
Switching to the Hyperlinks view enables 
you to quickly spot, and then repair, any 
broken links in your Web site. Always test
your links; nothing turns off visitors more
than broken links.

To use the Hyperlinks view:

1. With a Web site open, click the Web Site
tab at the top of the Editing window, and
then click the Hyperlinks button at the
bottom of the window.

2. For an overview of your site, click the
home page (default.htm in our example).

The Hyperlinks view displays every link to
and from the home page (Figure 6.37).

3. To examine a particular page, right-click
the page and choose Move to Center from
the drop-down menu (Figure 6.38).

The Hyperlinks view shifts the selected
page to the center and displays all its
links (Figure 6.39).

✔ Tip

■ If you’d rather see page titles instead of
file/path names, right-click the view win-
dow and choose Show Page Titles in the
drop-down menu (Figure 6.40). It also
helps you spot still-untitled pages.
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Figure 6.37 The Hyperlinks view displays every link to
and from a page.

Figure 6.38 To examine a particular page, right-
click the page and choose Move to Center.

Figure 6.39 The view shifts the selected
page to the center and displays its links.

Figure 6.40
To see page
titles instead 
of file/path
names, right-
click the view
window and
choose Show
Page Titles
(top). It also
helps spot still-
untitled pages
(bottom).



To check a single link:

◆ In the Hyperlinks view, right-click an
external link and choose Verify Hyperlink
from the drop-down menu (Figure 6.41).

If the link is broken, the arrow connect-
ing the file displays a break (Figure
6.42). To repair any problems, see “To fix
broken links” on page 120.

✔ Tip

■ You must be connected to the Internet to
verify external links.
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Figure 6.41 To check a single link, right-click it and
choose Verify Hyperlink.

Figure 6.42 If the link is broken, the arrow con-
necting the file displays a break.



To check a site’s links:

1. Choose Task Panes > Hyperlinks to dis-
play the Hyperlinks pane.

The Hyperlinks pane lists bad internal
links with a broken chain and unverified
external links with a question mark
(Figure 6.43).

2. Click the Verify Hyperlink button ( ) to
start the check.

3. In the Verify Hyperlinks dialog box, go
ahead and select Verify all hyperlinks
(Figure 6.44). Click Start.

4. After a brief pause while the links are
checked, the Hyperlinks pane summa-
rizes the status of the site’s links (Figure
6.45). To repair any problems, see “To fix
broken links” on the next page.
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Figure 6.43 The Hyperlinks pane lists bad internal
links with a broken chain and unverified external links
with a question mark.

Figure 6.45 The Hyperlinks pane summarizes the sta-
tus of the site’s links.

Figure 6.44
Select Verify all
hyperlinks and
click Start.



To fix broken links:

1. In the Hyperlinks pane, right-click a bro-
ken link and choose Edit Hyperlink in the
drop-down menu (Figure 6.46).

2. In the Edit Hyperlink dialog box, click
Browse to navigate to the link’s intended
target page (Figure 6.47).

3. Once you’ve selected the correct page, 
the Edit Hyperlink dialog box reappears.
Decide whether you want to fix the bro-
ken link in all pages (the default, and
most likely, choice) or only selected pages
(Figure 6.48). Click Replace.

After taking a moment to repair the link,
the Hyperlinks pane reappears and a pre-
viously broken internal link is removed
from the list (Figure 6.49).

or

When an external link is repaired, the
Hyperlinks pane displays a question mark
and lists its status as Unknown (Figure
6.50). Click the Verify Hyperlink button
( ) to run the Verify Hyperlinks dialog
box again. (See “To check a site’s links” on
the previous page.) After verifying the
link, the Hyperlinks dialog box replaces
the question mark with a checkmark
(Figure 6.51).

4. Continue working through the list until
you repair all the broken links.

✔ Tip

■ The bottom of the Hyperlinks pane tells
you when you’ve fixed all the broken links
(Figure 6.51).
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Figure 6.47 Click
Browse to navi-
gate to the link’s
intended target
page.

Figure 6.48 Once
you’ve selected
the correct page,
click Replace.

Figure 6.46 To fix a broken link in the Hyperlinks
pane, right-click it and choose Edit Hyperlink.

Figure 6.49 The previously broken internal
link is removed from the list.

Figure 6.50 When an external link is repaired,
the Hyperlinks pane displays a question
mark and lists its status as Unknown. Click
the Verify Hyperlink button.

Figure 6.51 After the link is verified, the
question mark is replaced with a checkmark.



Why all the fuss about Cascading Style Sheets?
Because, in theory, CSS lets you separate your
content from its design and layout. That
allows you to take the same information and
reformat it for different devices, from huge
computer monitors to tiny cell phones to
whatever’s invented next. “In theory” because
untangling content and design can get con-
fusing. Plus, unlike print design where you can
exert absolute control over how things look,
CSS deliberately cedes some of that control to
your visitors and their various Web browsers.
Striking the right balance can be tough, but
Expression Web makes it easier with some of
the best CSS tools found in any program.

After explaining these tools and the cascad-
ing aspect of CSS, this chapter shows you
how to create two types of styles: tag-based
and class-based. Tag-based styles, also
known as element-based styles, apply to a
specific HTML element, such as every h1
header or hyperlink. Class-based styles can
be applied even if there’s no HTML element
involved, such as making something red and
large. For that reason, class-based styles can
be used again and again in the same page. A
third type of style, ID-based styles, can be
applied only once per Web page. Commonly
used to style such items as columns and
footers in layouts, ID-based styles are cov-
ered in Chapter 8 on page 145.

121

Creating 
Styles with CSS

7
Creatin

g
 Styles w

ith
 CS

S



Using the CSS Tools
Expression Web comes loaded with tools to
make creating and managing CSS easy. The
Manage Styles task pane tab provides an at-
a-glance spot for creating and organizing
your styles (Figure 7.1). Its neighbor, the
Apply Styles task pane tab, includes thumb-
nail previews of each style (Figure 7.2). The
CSS Properties pane offers three ways to sort
your CSS tags: a summary of all tags in the
current selection, the cascade of which styles
are subordinate to others, and a list of all the
CSS rules, in alphabetical or categorical order
(Figure 7.3).
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Figure 7.1 The Manage Styles tab provides an at-a-
glance spot for creating and organizing your styles.

Figure 7.3 The CSS Properties pane offers several
ways to sort through all your CSS properties.

Figure 7.2 The Apply Styles tab includes
thumbnail previews of each style.

Show set
rules at top

Show all rules
affecting selection

Show by
alphabet

Show by
category

Tag
selected

All rules
applied

to tag

Every style 
uses one of
three selectors

Circled styles
used in
selected page



Two toolbars can be used for CSS-related
work as well, though I find the task panes
more convenient. The Style Application tool-
bar is used mainly if you want to build all
your CSS by hand in Manual mode (Figure
7.4). (If you’re not a CSS code jockey, stick
with the default Automatic mode.) The Style
toolbar includes drop-down menus for
applying classes and IDs, plus buttons to cre-
ate a style or attach style sheets (Figure 7.5).

Yet another CSS tool, the CSS Reports pane,
is covered separately on page 143.

To set up your CSS workspace:

1. Choose Task Panes, and make sure these
task panes are turned on: Tag Properties,
CSS Properties, Apply Styles, and Manage
Styles.

2. Choose View > Visual Aids, and make
sure that everything’s turned on, except
for the two ASP.NET choices.

3. Choose View > Quick Tag Selector.

You’re ready to start styling.

✔ Tip

■ To display the CSS-related toolbars,
choose View > Toolbars and pick Style
Application or Style.

To change CSS preferences:

1. Choose Tools > Page Editor Options.

2. Click the CSS tab, and take a look at
Expression Web’s default settings. If you
want to change any of them, use the
drop-down menus.
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Figure 7.4 The Style Application toolbar is used
mainly to build your CSS by hand.

Figure 7.5 The Style toolbar includes
drop-down menus for applying classes
and IDs.



How the Cascade Works
Why are they called cascading style sheets?
It’s because of the order in which the differ-
ent styles exert control over items. The cas-
cade runs, from top to bottom: external style
sheet, internal style sheet, inline style.

The closer a tag sits to an item, the more
precedence (or control) it has. So to put it
another way: If there’s no inline style for a
particular item, then any rules for that type
of item in the internal style sheet take com-
mand. If there are no rules for the item in the
internal style sheet, then the external style
sheet calls the shots. Used in combination,
this style cascade gives you site-wide powers
and single-paragraph precision.

The coding for the lowest level style type,
inline, affects only a single paragraph or
block. All the styling information sits within
the paragraph’s <p> and </p> tags. Internal
style sheets give you styling control for a
whole page. Its coding sits at the top of the
html page between the <head> and </head>

tags (Figure 7.6). External style sheets
enable you to control styles across multiple
pages or the entire site. As the name sug-
gests, its coding sits in a separate file and
controls any pages linked to it (Figure 7.7).

This chapter shows you how to create several
types of styles and apply them to a single
page. Some of those styles are then exported
to an external style sheet. This approach lets
you experiment on single pages before decid-
ing which to apply sitewide. Many Web vet-
erans, particularly those who know ahead of
time exactly what styles they want to apply,
prefer to code directly in an external style
sheet. If that’s your choice, jump straight to
“To create a blank external style sheet” on
page 138.
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Figure 7.6 An internal style sheet’s coding sits at the
top of the page between the <head> and </head> tags.

Figure 7.7 Pages using external style sheets include a
link to a separate file where all the styling codes reside.
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Creating Font Sets
It’s the way of the Web that it doesn’t matter
how many cool fonts you have on your com-
puter. What counts is what visitors to your
site have on their computers. The standard
workaround is to base your styles on specific
sets of fonts. By default, Expression Web
includes some very basic sets: a sans-serif, a
serif, and a typewriter-style monospace, each
of which includes some widely available
fonts. You can create your own sets, listing
left to right the order of the fonts to look for
on visitors’ computers. At the end of your list
always add the appropriate basic set. That
way, if your chosen fonts are not available,
your set list will call up the common fonts or
at least the appropriate typeface.

To create a font set:

1. Choose Tools > Page Editor Options, click
the Font Families tab in the dialog box,
and select (New Font Family) in the top
list (top, Figure 7.8).

2. In the Add font box, type the first few let-
ters of the font you want to use, and if it’s
on your computer, it automatically
appears. Click Add (top, Figure 7.8).

The font is added to the top list to start
your new set (bottom, Figure 7.8).

3. Continue building your set font by font,
by repeating step 2 until you’re done (bot-
tom, Figure 7.8).

(continued)
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Figure 7.8 To create a font set, select (New Font
Family) (top) and beginning adding to it one font at a
time (bottom).



4. Use the Move Up and Move Down but-
tons to put your most-used font sets
higher in the list (Figure 7.9). Click OK
to close the dialog box.

The next time you create a style, the 
font-family drop-down menu includes
your new sets in their new order 
(Figure 7.10).

✔ Tips

■ To add fonts to an existing set, select it in
step 2 and complete the rest of the steps.
You cannot, however, reorder the fonts in
the set.

■ In step 2, you can add a font not on your
computer by typing the full name. This is
useful if you expect most computers to
have that font installed—even if your
computer does not.
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Figure 7.9 Use the Move Up and Move Down buttons
to put your most-used font sets higher in the list.

Figure 7.10 The next time you create a style, the font-
family drop-down menu includes your new sets in
their new order.



Creating Tag-based Styles
Tag-based styles affect every instance of a
selected HTML element. Create an h1 CSS
style once, for example, and it’s applied to
every h1 on that page (or the site if it’s placed
in an external style sheet). This section walks
you through several types of elements, but
the same steps can be applied to any HTML
element.

To create heading-based styles:

1. Open any page in your Web site contain-
ing headings, and click the New Style 
button in the Manage Styles or Apply
Styles tab.

2. In the New Style dialog box, use the
Selector drop-down menu to choose h1
to set the appearance of every Heading 1
(Figure 7.11).

3. Use the Category choices and their
related properties to set the appearance
of your h1 headings (Figure 7.12). Click
OK at the bottom of the dialog box to
close it.

The Manage Styles tab adds the h1 style
to the Elements category, and any h1
items on the page assume the new style
(Figure 7.13).

4. Repeat steps 1 through 3 for any other
heading sizes you need.
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Figure 7.11 Use the Selector drop-
down menu to choose h1 to set the
appearance of every Heading 1.

Figure 7.12 Use the Category choices and their related
properties to set the appearance of your h1 heading.

Figure 7.13 Any h1 items on the page
assume the new style.



✔ Tips

■ Once you establish all your heading
styles, the appropriate style is automati-
cally applied whenever you resize a head-
ing (Figure 7.14).

■ If, as is common, you find yourself work-
ing on elements that are nested within
elements, use the Quick Tag Select to
click the right tag and immediately select
everything that belongs with that tag
(Figure 7.15).

■ While it’s common to set sizes based on
pixels, using keywords (xx-small through
xx-large) allows users to adjust, boost, or
reduce the overall size of text items as
needed. Instead of focusing on absolute
pixel control, concentrate on establishing
a clear hierarchy using the relative sizes of
elements.
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Figure 7.14 Once you establish all your heading
styles, the appropriate style is automatically applied
whenever you resize a heading.

Figure 7.15 Use the Quick Tag Select to immediately
select everything that belongs with that tag.



To style hyperlinks:

1. Open any page in your Web site contain-
ing links, and click the New Style button
in the Manage Styles or Apply Styles tab.

2. In the New Style dialog box, use the
Selector drop-down menu to choose
a:link to set the appearance of an unvis-
ited hyperlink (Figure 7.16).

3. Leave the Category set to Font, click the
color drop-down menu, and choose More
Colors (Figure 7.17).

4. In the More Colors dialog box, pick a
color and click OK (Figure 7.18).

5. When New Style dialog box reappears,
select none in the text-decoration col-
umn so that the links will not be under-
lined (Figure 7.19). Click OK at the
bottom of the dialog box to close it.

The Manage Styles tab adds an Elements
category listing the a:link style and any
links in the page assume the new style
(Figure 7.20).

(continued)
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Figure 7.17 Leave the Category set to Font, click the
color drop-down menu, and choose More Colors.

Figure 7.18 In the More Colors dialog box, pick a color,
and click OK.

Figure 7.19 Select none in the text-decoration column
so that the links will not be underlined.

Figure 7.16 Use the
Selector drop-down
menu to choose a:link
and set the appearance
of an unvisited hyperlink.

Figure 7.20 The
Manage Styles tab
adds an Elements
category listing
the a:link style
and any links in
the page assume
the new style.



6. Repeat steps 1 through 5, choosing
a:hover in step 2 and a different color in
step 4 (Figure 7.21). (It’s common to
leave hover links underlined.)

7. Repeat steps 1 through 5, choosing a:vis-
ited in step 2 and a third color in step 4
(Figure 7.22). Click OK to close the New
Style dialog box for the last time.

The Manage Styles tab lists all three link
styles (Figure 7.23). To export these styles
to an external style sheet, see page 141.
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Figure 7.21 Choose a different color (right) for the
a:hover link style and select underline.

Figure 7.22 Choose a third color for the a:visited link
style and reselect none again.

Figure 7.23 The Manage
Styles tab lists all three
link styles within the
Elements category.



Creating Class-based
Styles
In contrast to element-based styles, whose
use is tied to a specific tag such as h1, a
class-based style can be applied to anything.
Thanks to that flexibility, you’ll probably
change their appearance over time. For that
reason, try to name them based on their
function (.caption or .pullquote) rather
than their appearance (.thatcoolblue
ihatedaweeklater). See page 133 for how 
to rename a class-based tag without losing
its original links.

To create a class-based style:

1. Open the Web page in which you want to
create an internal style. In our example,
we’ve selected a paragraph we want to
style (Figure 7.24).

2. Click the New Style button in the Manage
Styles or Apply Styles tab (Figure 7.25).

3. By default, the New Style dialog box
names your first new style .newStyle1
and defines it in the current page 
(Figure 7.26). Give it a name of your
own, myStyle in this example.
(Expression Web automatically adds 
the beginning period to preserve the
class-based styling.)

4. Select the Font category and pick the
properties you want to use (Figure 7.27).
Set the properties for any other categories
as needed. Use the preview area to fine-
tune your choices, and click OK.

The new style appears in the Manage
Styles pane.

(continued)
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Figure 7.24 To create a class-based style in the exam-
ple, start by selecting a paragraph to style.

Figure 7.27 Select the categories you want to style,
and pick the properties for each.

Figure 7.25 Click the New
Style button in the
Manage Styles or Apply
Styles tab.

Figure 7.26 By default, the
New Style dialog box
names your first new style
.newStyle1 and defines it
in the current page.



5. To apply the style to the still unchanged
paragraph, right-click the new style in the
Manage Styles tab and choose Apply
Style from the drop-down menu (left,
Figure 7.28).

or

Switch to the Apply Styles tab and click
the new style (right, Figure 7.28).

The selection changes to reflect the new
styling, and the paragraph’s tag now
includes the style name <p.myStyle>
(Figure 7.29).

✔ Tips

■ Don’t use a number at the start of a style
name, such as .1stStyle. Expression Web
will create the style but will not let you
apply it.

■ In step 4, for such common settings as
Georgia, medium, and normal, just type
the first few letters. Expression Web sup-
plies the rest, eliminating the need to
constantly click the drop-down menus.

■ Internal style sheets are sometimes called
embedded styles because all the coding is
placed between the page’s <head> and
</head> tags.
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Figure 7.28 To apply a style, right-click it in the
Manage Styles tab and choose Apply Style (left) or
just click the new style in the Apply Styles tab (right).

Figure 7.29 The paragraph changes to reflect the new
styling, and its tag includes the style name.



To rename a class-based style:

1. In either the Apply Styles or Manage
Styles tabs, select the class-based style
you want to rename while updating all
references to it. Right-click it, and choose
Rename class “yourstyle” from the drop-
down menu (Figure 7.30).

2. Type the new name, and click OK
(Figure 7.31).

A status dialog box displays how many
style references have been updated. Click
OK to close the dialog box.

✔ Tip

■ If you rename a class-based style in the
Modify Style dialog box, any existing links
will break. Use that dialog box to change
the style’s properties, not its name.
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Figure 7.31 Type the new name, and click OK.

Figure 7.30
Select the style
you want to
rename without
breaking any
links, right-click
it, and choose
Rename class
“yourstyle.”



Creating Inline Styles
So you’ve set up your element-based and
class-based styles. But what if you have a sin-
gle paragraph you want to look a little differ-
ent from all the others? That’s where the
inline class comes in. See “How the Cascade
Works” on page 124 if you want to review
how inline styles interact with style sheets.

To create an inline style:

1. Click anywhere inside the paragraph or
block you want to style.

2. Click the New Style button in the Manage
Styles or Apply Styles tab (Figure 7.32).

3. In the New Style dialog box, select (inline
style), the very first item in the Selector
drop-down menu (Figure 7.33).

4. Select a category on the left, and use the
related drop-down menus to create a
style (Figure 7.34). Use the preview area
to gauge the effect, and click OK.

The dialog box closes, and the style is
applied to the selected paragraph or
block (Figure 7.35).

✔ Tip

■ Expression Web provides two other clues
that you’ve created an inline style: The
CSS Properties tab calls it that, and it
does not appear in the Manage Styles tab
(Figure 7.36).

■ Don’t confuse inline styles with inline ele-
ments, which are applied to just a few
characters or words within a paragraph.
An example of an inline element would
be <em> emphasized </em> word.
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Figure 7.34 Select a category on the left, and use
the related drop-down menus to create a style.

Figure 7.35 As the code at the top
shows, the inline style is added inside
the selected paragraph or block.

Figure 7.36 Two more clues that you’ve created an
inline style: The CSS Properties tab calls it that,
and it does not appear in the Manage Styles tab.

Figure 7.32 As with other
styles, the first step for cre-
ating an inline style is to
click the New Style button.

Figure 7.33 The difference
comes when you then select
(inline style) in the Selector
drop-down menu.



Copying and Changing
Styles
You can quickly create variations of a style by
copying it and changing a property or two.
Likewise, it’s easy to modify an existing style
as needed. In fact, it’s common to create a
class-based style and then realize that it’d
work well as an element-based style. A typi-
cal example might involve getting a para-
graph styled just so and then wanting to
apply it to all your paragraphs by converting
it to an element-based style (Figures 7.37
and 7.38).

If you accidentally apply a style or simply
change your mind, it’s easy to remove the
styling from that element without deleting
the style rule itself. Once a style’s deleted,
however, it’s gone. So you may want to hold
off a bit before deleting a style. You can
always remove it from an element without
deleting it entirely.

To copy and change a style:

1. In the Manage Styles tab, select the style
you want to duplicate and choose New
Style Copy from the drop-down menu
(Figure 7.39).

2. In the New Style dialog box, give the copy
a new name in the Selector text box, and
make any changes from the original style
(Figure 7.40).

3. Click OK.

The dialog box closes, and the modified
style is added to the Manage Styles tab
list (Figure 7.41).
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Figure 7.37 If you create a style that you really like…

Figure 7.38 …it’s easy to copy and apply elsewhere.

Figure 7.39 To copy and change
a style, select it in the Manage
Styles tab and choose New
Style Copy.

Figure 7.40 Give the
copy a new name in
the Selector text
box, and make any
changes from the
original style.

Figure 7.41 The modified
style is added to the
Manage Styles tab list.



To convert a style:

1. Right-click the class-based style that you
want to make into an element-based style
(Figure 7.42).

2. In the Modify Style dialog box, use the
Selector drop-down menu to choose the
element you want to style (the p tag in
this case) (Figure 7.43). Click OK.

The dialog box closes, and all instances of
that tag update automatically. The new
element-based style also is listed in the
Manage Styles tab.

✔ Tip

■ The original custom class-based style
remains, which you can delete or keep for
later use.
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Figure 7.43 Use the Selector drop-down
menu to choose the element you want
to style (the p tag in this case).

Figure 7.42 Right-
click the class-
based style that you
want to convert to
an element-based
style, and choose
the element in the
drop-down menu.



To remove a style:

1. Select the element whose style you want
to remove (Figure 7.44).

2. In the Apply Styles tab, click the Clear
Style button (Figure 7.45).

The style is removed from the selected
element (Figure 7.46).

To delete a style:

1. In the Apply Styles tab, right-click the
style you want to delete and choose
Delete from the drop-down menu
(Figure 7.47).

2. An alert dialog box asks you to confirm
the action. Click Yes.

The style is removed.
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Figure 7.44 Select the element whose style you want
to remove.

Figure 7.46 …and the style is removed.

Figure 7.45 In the Apply
Styles tab, click the Clear
Style button…

Figure 7.47 In the
Apply Styles tab,
right-click the style
you want to delete
and choose Delete.



Creating Style Sheets
Internal style sheets are created automati-
cally as you add styles to a Web page.
Because all the coding is placed in the header
section of the page, it applies only to that
page (Figure 7.48). An external style sheet
offers several advantages over each page 
carrying its own internal style sheet. The
external sheet lets you easily apply styles
across some or all of the pages in your Web
site. It also speeds downloads since the CSS
coding that would have been in each page’s
header is consolidated within the single
external style sheet.

To create a blank external style sheet:

Do one of the following:

◆ Click the New button in the Common or
Standard toolbars and choose CSS from
the drop-down menu.

◆ Choose File > New > CSS.

◆ Choose File > New, and in the New dialog
box, choose Page > General > CSS. Click
OK (Figure 7.49).

A blank, untitled CSS file opens in the
Editing window and is listed in the
Manage Styles tab (Figure 7.50). See 
“To save a blank style sheet” on the 
next page.
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Figure 7.48 Internal style sheets place all the style
coding in the header section of the page.

Figure 7.49 To create a blank external style sheet,
choose Page > General > CSS in the New dialog box.

Figure 7.50 A blank, untitled CSS file opens in
the Editing window (left), and is listed in the
Manage Styles tab (right).



To save a blank style sheet:

1. After a new, blank style sheet appears in
the Editing window (see previous task),
press (cS).

2. Use the Save As dialog box to navigate to
your current Web site (top, Figure 7.51).
Give the style sheet a distinctive name,
set the Save as type drop-down menu to
CSS Files, and click Save (bottom, Figure
7.51). (See tip below.)

The open page’s tab displays the new
name, as does its listing in the Manage
Styles tab (Figure 7.52).

✔ Tip

■ There’s no standard practice for naming
external style sheets. Common naming
schemes include main.css, style1.css,
global.css. To help me keep straight which
style sheets goes with which site, I name
the external style sheet after the site.
Hence, in step 2 above, wanderings echoes
the site’s name.
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Figure 7.51 To save a blank style sheet, use the Save As
dialog box to navigate to your current Web site (top).
Give it a distinctive name, set the Save as type drop-
down menu to CSS Files, and click Save (bottom).

Figure 7.52 The style sheet’s
new name appears in the
Manage Styles tab.



To attach a style sheet to pages:

1. Open the page to which you want to
attach an existing external style sheet.
(The style sheet can be blank, as
explained below).

2. If the style sheet resides in the same Web
site as the open page, click and drag it
from the Folder List onto the page
(Figure 7.53).

or

If the style sheet is stored outside the cur-
rent site, click the Attach Style Sheet but-
ton in the Apply Styles or Manage Styles
tabs (Figure 7.54). Use the Attach Style
Sheet dialog box to browse to the sheet
(Figure 7.55). Click OK.

The page’s Manage Styles tab now lists
the external style sheet (Figure 7.56).

✔ Tips

■ There are two ways to attach a style sheet
to multiple pages at once: c-click the
pages in the Folder List, and then click
the Attach Style button as explained in
step 2. Or when the Attach Style Sheet
dialog box appears in step 2, select All
HTML Pages.

■ The Attach Style Sheet dialog box offers
you the choice of attaching the style sheet
as a link or an import (Figure 7.55).
Links are more commonly used because
more browsers support them. Imports,
when placed inside a linked style sheet,
offer a way to serve newer browsers with-
out confusing older browsers. Older
browsers will use the basic linked sheet,
while newer browsers will import the
more detailed style sheet.

■ You also could attach a style sheet 
downloaded from one of the many 
Web sites that offer free example files.
(See www.csszengarden.com for lots of
inspiring, free samples.)
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Figure 7.53 If a style sheet resides in the same site as
the open page, click and drag it from the Folder List
onto the page.

Figure 7.55 Use the Attach Style Sheet dialog box
to link or import the style sheet.

Figure 7.56 The page links to an external style
sheet (left). The @layout.css signals that the
page will import the style sheet if needed (right).

Figure 7.54 If a style
sheet is stored outside
the current site, click
the Attach Style Sheet
button in the Apply
Styles or Manage
Styles tabs.

www.csszengarden.com


To move internal styles to an external
style sheet:

1. First attach an external style sheet to 
the current page (see previous page), and
then make sure that page’s Manage Styles
tab is open.

2. Click to select the internal styles you
want used in the external sheet, and drag
them onto the external sheet’s name (left,
Figure 7.57). (Use c-click to select
multiple internal styles.) Release the cur-
sor button.

The styles are added to the external 
style sheet and are no longer listed as
internal styles for the current page (right,
Figure 7.57).

3. To add internal styles from other pages to
the same external style sheet, attach the
external style sheet to each of those
pages. You can then click and drag styles
from each internal page to the external
style sheet (Figure 7.58).

✔ Tip

■ This method of adding internal styles
from multiple pages allows you to build a
master external style sheet very quickly.
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Figure 7.57 Select the internal styles you want used,
and drag them onto the external sheet’s name (left).
The styles are added to the external style sheet (right).

Figure 7.58 After attaching an external style sheet to
another page, you can drag still more internal styles
to the external sheet.



To detach an external style sheet from
a page:

1. Open the page from which you want to
detach an external style sheet.

2. In the Manage Styles tab, right-click the
external style sheet listing and choose
Remove Link from the drop-down menu
(Figure 7.59).

The link to the external style sheet is
removed and no longer appears in the tab
listing.

To detach an external style sheet from
multiple pages:

1. In the Folder List, c-click to select all
the pages from which you want to detach
an external style sheet (Figure 7.60).

2. Choose Format > CSS Styles > Manage
Style Sheet Links (Figure 7.61).

3. In Link Style Sheet dialog box, you have
the option of removing the link from 
all the site’s pages or of sticking with 
your selected pages only. Select the style
sheet you want to detach, and click
Remove (Figure 7.62). (In the example,
there’s only one link, but there could be
multiple sheets.)

The link to the external style sheet is
removed. Unless there are other links 
you want removed, click OK to close the
dialog box.
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Figure 7.61 …and then choose Format > CSS Styles >
Manage Style Sheet Links.

Figure 7.62 Select the style sheet you
want to detach, and click Remove.

Figure 7.59 To detach 
an external style sheet
from a page, right-click
the external style sheet
listing and choose
Remove Link.

Figure 7.60 To detach 
an external style sheet
from multiple pages, 
first c -click to select 
all the pages…



Solving CSS Problems
Expression Web’s CSS Reports pane helps you
trace CSS problems that could be hard to find
otherwise. It can check if you have unused
CSS styles, whether your pages include refer-
ences to styles that you’ve failed to create,
and mismatched references between your
pages and styles. The task pane can then help
you fix or delete the conflicts. Sometimes,
however, the easiest way to find a problem is
to use your eyeballs and the CSS Properties
task pane. This is especially true when trying
to sift through whether another part of a style
cascade is inadvertently affecting an item.
See “To track down CSS problems” on the
next page.

To run CSS reports:

1. Open your Web site, and choose Task
Panes > CSS Reports to display the CSS
Reports task pane.

2. Click the three-side arrow in the pane’s
upper left, select your report options in
the CSS Reports dialog box, and click
Check (Figure 7.63).

A list of possible problems is generated
(Figure 7.64).

3. Click the smaller blue arrow next to each
listing to see the coding that may be cre-
ating a problem (Figure 7.64).

or

Click the Style Sheet Links button to
inspect the style sheet controlling the
style (Figure 7.65).

4. Make changes as necessary and run the
report again until you’ve completed 
the fixes.

✔ Tip

■ An unused style isn’t really a problem. 
But if the report finds lots of them, delete
them to keep your site uncluttered.
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Figure 7.63 To run a CSS check, click the three-side
arrow in the CSS Report pane’s upper left, and select
your report options in the CSS Reports dialog box.

Figure 7.64 The pane displays a list of possible 
problems.

Figure 7.65 Click the Style Sheet Links button to
inspect the style sheet controlling the style.



To track down CSS problems:

1. Select the item containing a style that’s
not working as expected. In our example,
it’s a style for controlling image insets.
The image, which should be aligned with
the top of the adjacent text, sits too low
(right, Figure 7.66).

2. In the CSS Properties task pane, click the
Summary and Show set properties on top
buttons (left, Figure 7.66).

3. Look through the pane’s right column for
a property that could be causing the
problem. In the example, the clear prop-
erty is set to both.

4. If you suspect a particular property is
causing the problem, select another prop-
erty in the adjacent drop-down menu. In
our example, we’ve changed the clear
property to inherit (left, Figure 7.67).

If the problem doesn’t go away, reset the
property and try another item. In our
example, the change fixed the problem,
and the image now aligns with the top of
the text (right, Figure 7.67).
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Figure 7.66 The CSS Properties task pane is great for
tracking down problems like this image refusing to
align with the top of the adjacent text.

Figure 7.67 Changing the clear property from both to
inherit fixes the image alignment problem.



Cascading Style Sheets gives you so many
options for controlling position-related prop-
erties that it can be overwhelming when 
you first start. That’s especially true if you
previously depended on tables for layouts.
Whether it’s a paragraph, an image, or a page
division, CSS positioning treats all of these
elements like boxes. You saw a preview of this
box model working with image padding and
margins in Chapter 5. Take another look at an
image from that chapter to get a better sense
for how the box model works (Figure 8.1).
From the middle to the outside of the box,
you have: an element’s content, its surround-
ing padding, a border, and its margins. CSS
applies that same boxes-in-boxes approach to
position headers, sidebars, main columns,
and such within page layouts. Combined with
float and clear tags, which control how items
are placed side by side, you can create precise,
yet flexible, layouts for entire Web sites.

CSS layouts depend on two items working
hand in glove: div tags (short for page divi-
sions) and ID-based styles. Unlike the ele-
ment- or class-based styles used in the
previous chapter, ID-based styles can only be
applied once per Web page. That limitation
makes them ideal for styling such once-a-
page items as navigation bars, mastheads,
layout columns, and footers.
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Figure 8.1 CSS positioning depends on the box model
where each element is treated as a box positioned
inside another box.



Positioning Properties
By default, a Web page displays elements in
the natural top-to-bottom flow of its coding.
CSS gives you five settings, or properties, 
to control any element’s place in that flow:
absolute, fixed, relative, static, and inherit. 
To get a better sense of how each property
compares with the others, take a look at the
accompanying screenshots of the Editing
window and CSS Properties tab.

◆ Absolute: An absolutely positioned 
element is not confined by the page’s
code flow, and so, you can place it side-
by-side with another element (Figure
8.2). That’s because its position is dic-
tated by its relation to its parent box, the
body tag, which is usually pegged to the
page’s left-top corner (left, Figure 8.2).
If you insert an absolutely positioned 
element inside another absolutely posi-
tioned element, its position is dictated by
that parent element’s position (Figure
8.3). Be aware that absolutely positioned
elements do not automatically expand to
hold added content. That’s why creating
layouts with layers, which are absolutely
positioned by default, can cause unex-
pected problems in browsers if you aren’t
careful (Figure 8.4).
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Figure 8.2 An absolutely positioned element is placed
in relation to the page’s left, top corner (0,0). Here
absolute-A sits 100 pixels to the left and 50 pixels
from the top of that corner spot. Its position has no
effect on the static-A element.

Figure 8.3 Child and parent relationships:
absolute-B sits inside absolute-A, so its left-top
position of 50, 50 is based on absolute-A’s left-
top position of 300, 25.

Figure 8.4 Absolutely positioned elements may not
automatically expand to hold added content, which is
why using layers can create layout problems.



◆ Fixed: The position of a fixed object is
dictated by its relation to the browser
window rather than the page or other
objects. If you scroll the browser window
up or down, the fixed object stays in the
same place even as other page objects
move in and out of the window (Figures
8.5 and 8.6).

◆ Relative: A relatively position page ele-
ment remains part of a page’s code flow,
which means its placement will affect the
layout of other nearby elements. When
you move a relatively positioned element,
its x-y coordinates change relative to its
normal spot in the code flow (Figure 8.7).

◆ Static: A static object sits in the top-to-
bottom code flow of the page. You can
change its place in that flow (Figure 8.8).
However, you cannot move it to the side
of another element, since that falls out-
side the code flow (Figure 8.9). As
explained in the next section, that aspect
of positioning is controlled by the float
and clear tags.

◆ Inherit: If you set an element’s position-
ing to inherit, it simply uses the position-
ing of the enclosing parent element.
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Figure 8.7 With a relatively positioned element,
its left-top coordinates (141, 42) change relative
to its normal spot in the code flow, marked here
by the empty box.

Figure 8.5 A fixed
object’s position is
dictated by its rela-
tion to the browser
window, so it sits
in the same spot…

Figure 8.6 …even
as you scroll to the
bottom of the
page.

Figure 8.8 Static elements
can be reordered in the top-
to-bottom code flow, as
here where static-B has
been placed above static-A.

Figure 8.9 Static 
elements cannot be
moved out of the code
flow into a side-by-side
position.



Using the Float and 
Clear Tags
While absolute positioning is precise, it’s not
very flexible, as you saw in Figure 8.4. For a
more liquid layout that can accommodate a
variety of viewing devices, use the other four
positioning properties in combination with
the float and clear tags. Both tags can be
found in the Layout category of the New Style
and Modify Style dialog boxes (Figures 8.10
and 8.11). The float tag works similarly to the
wrapping styles that control how text flows
around images. If you apply a left float to an
element, for example, the element shifts to
the left side of its enclosing container, allow-
ing other elements to wrap down the right
side. Apply the clear tag to elements to con-
trol how they flow in response to nearby
floated elements. In effect, you can override
the default settings for where a new line
break falls amid elements running down the
side of a floated element.

Floating Properties
◆ Left: The element floats left, allowing

other elements to flow down its right side
(Figure 8.12).

◆ None: This is the default setting and
causes the element to sit right where it
falls in the flow. Other elements will not
wrap around it. Most browsers respond 
to a blank property box as if it’s set to
none. Some browsers, however, can’t 
read the blank. In those cases, select the
None setting so that the browser renders
the page properly.

◆ Right: The element floats right, allowing
other elements to flow down its left side
(Figure 8.13).

◆ Inherit: The element uses the float set-
ting of its enclosing parent element.
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Figure 8.12 Changing the float on Box A from None
(left) to Left (right) allows Box B to run down the right
side. Box C doesn’t shift right because Box B bumps it
far enough down the page to sit under Box A.

Figure 8.13 Box A floats to the right, allowing
Box B to run down its left side.

Figure 8.10 The float
tag can be applied in
four ways.

Figure 8.11 The clear
tag offers five posi-
tioning choices.



Clearing Properties
◆ Both: Apply this to an element when you

want to block floats on both sides. It
forces other elements to run above or
below it (Figure 8.14).

◆ Left: Apply this to an element to block
other elements from floating to its left.

◆ None: Apply this to an element when it’s
OK for other elements to float on either
side. As with float’s none setting, use none
when browsers don’t recognize the default
setting where the property box is blank.

◆ Right: Apply this to an element to block
other elements from floating to its right.

◆ Inherit: Apply this to an element to use
the clear setting of its enclosing parent
element.
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Figure 8.14 Top: Box D sits to the right
because Box B, which is floated left, is
deeper than Box C alone. Bottom:
Changing Box D’s clear tag from None
to Both forces D to run on a new line
because it blocks anything from run-
ning on either side of it.



Using the Positioning
Tools
Just as they did in formatting styles in
Chapter 7, the Apply Styles, Manage Styles,
and CSS Properties task panes play a big role
in CSS positioning. Set them up beforehand
to save yourself time.

To set up for positioning work:

1. Choose View > Ruler and Grid, and in the
drop-down menu, select Show Ruler and
Show Grid.

Horizontal and vertical rulers appear
along the top and left edges of the Editing
Window, which is marked off with a thin
line every 50 pixels.

2. Choose Task Panes, and make sure these
task panes are turned on: Tag Properties,
CSS Properties, Apply Styles, and Manage
Styles.

3. Choose View > Visual Aids, and make
sure that everything’s turned on, except
for the two ASP.NET choices.

4. Choose View > Quick Tag Selector.

You’re ready to start using CSS to posi-
tion items on your Web pages.

✔ Tip

■ In step 1, if you want to use a unit other
than pixels or change the grid spacing,
choose View > Ruler and Grid >
Configure, and make your changes.
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Yesterday’s Layout Tools:
Frames, Tables, and Layers

If you’re a fan of frames, layout tables, or
layers, maybe the headline seems harsh.
Back in the day, they filled a big gap in the
Web’s limited tool chest for creating half-
decent layouts. Their shortcomings—
framed pages cannot be bookmarked,
layout tables generate oodles of tiny,
transparent GIFs, and layers do not auto-
matically adjust to their contents—were
tolerated because there were few good
choices. But just as new browsers support
CSS positioning, and Expression Web is
replacing FrontPage, so are these former
layout stalwarts heading for the retire-
ment pasture.

If you built, and still maintain, frame-
based sites using FrontPage (or Dream-
weaver for that matter), you’ll find frames
work very similarly in Expression Web.
(You can reach them by choosing File >
New > Page > Frames Pages). Likewise,
FrontPage’s layout tables are tucked inside
Expression Web (Table > Layout Tables).

Despite its default placement next to the
Apply Styles and Manage Styles tabs, the
Layers tab should not play a big part in
your CSS positioning work. While they’re
easy to draw and position, layers depend
on absolute positioning and stacking,
which can quickly make a hash of your
layout. While layers still play a key role in
creating such things as rollover-triggered
navigation menus, you can create precise,
complex layouts without them—as
Expression Web’s own prebuilt CSS lay-
outs demonstrate in the next few pages.

Microsoft included all three tools to ease
your eventual transition to building Web-
standards-based pages using CSS. This
chapter aims to help you do just that.



Using Prebuilt CSS
Layouts
Using the prebuilt CSS layouts included with
Expression Web can spare you the inevitable
trial and error that comes with building your
own layouts from scratch. Be sure to open
the tools and views explained in “Using the
Positioning Tools” on the previous page.

To use prebuilt CSS layouts:

1. Choose File > New > Page.

2. In the New dialog box, select CSS Layouts
in the left column and use the middle list
and right-hand preview area to pick a
page layout (Figure 8.15). Click OK.

A new blank HTML-based page appears,
along with a related untitled CSS-based
page. In the example, the left-column
division has a fixed width while the other
divisions automatically match the page
width (Figure 8.16). Switch to the new
CSS file, and you can see that only three
of the six ID names (#container, #left_col,
and #page_content) start off with posi-
tioning properties (Figure 8.17).

3. Choose File > Save All.

4. Use the Save As dialog box to name 
and title the HTML page and its related
external CSS file. By default, the CSS 
file is automatically attached to the
HTML page. (In the example, we’ve
named them prebuiltlayout.htm and
prebuiltlayout.css.)

(continued)
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Figure 8.15 Select CSS Layouts in the left column and
use the middle list and right-hand preview area to
pick a layout.

Figure 8.16 The left_col division has a
fixed width while the other divisions
automatically match the page width.

Figure 8.17 In the CSS file, only three
of the six ID names (#container,
#left_col, and #page_content) start
off with positioning properties.



5. Add a bit of content to your page’s major
divisions—just a header or some text—to
make the otherwise collapsed divisions
easier to see (Figure 8.18).

6. Let’s customize the ID-based styles to 
get a sense of how just a few settings 
can affect the layout of the divisions.
Switch to the Manage Styles tab, right-
click #left_col, and choose Modify Style
(Figure 8.19).

7. In the Modify Style dialog box, boldfaced
categories already have a property. In the
#left_col example, Position is boldfaced
because it’s set to absolute with a width
of 200 (pixels) (Figure 8.20). Change the
width from 200 to 100, and click OK to
close the dialog box.

8. In the Manage Styles tab, right-click
#page_content, choose Modify Style, and
select the Box category (Figure 8.21).
Change the left margin from 200 to 100
and click OK to close the dialog box.

In the Web page, the left column and page
content divisions shift to narrow the left
column to half its original width, which
also is reflected in the summary view of
the CSS Properties tab (Figure 8.22).
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Figure 8.18 Add a bit of content to your page’s
major divisions to make the otherwise col-
lapsed divisions easier to see.

Figure 8.20 The #left_col division is preset to
a width of 200 pixels.

Figure 8.21 Change the left margin for
#page_content from 200 to 100 pixels.

Figure 8.22 The two layout divisions shift to 
narrow the left column to half its original width,
which also is reflected in the CSS Properties tab.

Figure 8.19 Right-click
#left_col, and choose
Modify Style.



9. As you did in Chapter 7, you can start
styling the look of the ID-based divisions
themselves, such as the borders (Figures
8.23). However, hold off styling the con-
tent of the divisions (heads, text, lists, and
so on) until you read “Using Contextual
Selectors” on page 154.

10. Continue using the Modify Style dialog
box to customize each division, paying
particular attention to the position-
related categories: Box, Position, and
Layout (Figures 8.24 and 8.25).

11. When you’re done, choose File > Save All
to preserve your changes to the HTML
and CSS files. To use the layout with
other pages, attach it to pages as you
would any external style sheet.

✔ Tips

■ The common naming convention for 
CSS files controlling layout is layout.css.

■ To keep things relatively simple, the
examples use just one CSS file. It’s 
common for commercial Web sites, 
however, to have multiple, interlocking
style sheets that use CSS coding hacks 
to work around the rendering problems
of older browsers. If you want to learn
more, dive in at these two great sites:
http://www.positioniseverything.net

and http://alistapart.com.
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Figure 8.23 You can start styling the look of each divi-
sion by changing properties such as the borders.

Figure 8.24 Naturally enough, the Position category
controls many of the CSS positioning properties.

Figure 8.25 The Layout category handles the float and
clear tags, which control side-by-side positioning of
elements.

http://www.positioniseverything.net
http://alistapart.com


Using Contextual
Selectors
As you saw in the previous section, the com-
bination of div tags and ID-based styles
enables you to create specific styles for your
divisions. With the addition of contextual
selectors, you can create styles that only
appear when particular tags are used in spe-
cific divisions. Want a specially styled h3
header for a sidebar but nowhere else? How
about a particular alignment-margin-
padding combination for paragraphs in your
main content division? Contextual selectors
let you do it—without cluttering up your
pages with lots of code. By moving the styles
to an external style sheet, you also can
quickly apply them to any pages laid out with
those same divisions.

To create contextual selectors:

1. Click New Style in the Manage Styles tab.
The New Style dialog box’s selector field
automatically generates a generic style
name (top, Figure 8.26).

2. Press B twice to get rid of that
name and the period in front of it. Now
type: #yourdivision_name(space)
class_name. In the example, it’s:
#page_content p to create a style that’s
applied automatically to any paragraphs
in the main page content area (bottom,
Figure 8.26).

3. Set properties in the various categories 
in the Modify Style dialog box to create
exactly the paragraph style you want
(Figure 8.27). Click Apply if you want to
see the effect and make adjustments, or
click OK to close the dialog box.

All the paragraph text in the division
assumes the new style, and the con-
textual ID-based style is listed in the
Manage Styles tab (Figure 8.28).
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Figure 8.26 To create a
contextual selector,
replace the generic
name (top) with your
own version of #your-
division_name(space)

class_name.

Figure 8.27 Click OK to close the dialog box, or click
Apply to see the setting’s effect and make adjustments.

Figure 8.28 All the paragraph text in the
division assumes the new contextual style,
which is listed in the Manage Styles tab.



4. Repeat steps 1 through 3 to create a con-
textual style for paragraphs used in
another page division.

In the example, a contrasting text style is
created for the left column (Figure 8.29).

5. Repeat steps 1 through 3, only this time
create contextual styles for the headers in
your divisions. In the example, they are:
#left_col h3 and #page_content h2

(Figure 8.30).

6. Click and drag the current page’s ID styles
to your external style sheet (Figure 8.31).
(See page 138, if you need information on
creating external style sheets.)

7. Choose File > Save All to preserve your
work.

✔ Tips

■ In step 2, if you reposition the New Style
dialog box on your screen, you’ll know the
exact ID name to type because all the IDs
can be seen in the Manage Styles tab.

■ Switch over to Code view for any of these
pages, and you’ll see that the element
tags remain clean and that all the styling
information sits in the external style
sheet (Figures 8.32 and 8.33).

155

Creating Layouts with CSS
U

sin
g

 Co
n

textu
al S

electo
rs

Figure 8.29 A contrasting p style is created
for the left_col division.

Figure 8.30 Here a specific h3 style is used
in the left column, and an h2 style for the
main page content.

Figure 8.31 Click and drag the current page’s
ID styles to your external style sheet.

Figure 8.33
All the contextual
styling informa-
tion for the h2 tag
sits in the exter-
nal style sheet.

Figure 8.32
Contextual selectors
don’t clutter up the h2
tag in the Code view.



Creating CSS Layouts
from Scratch
No matter how nice the prebuilt layouts may
be, at some point you may want to create
your own CSS-based layouts. Be sure to first
work a bit with the prebuilt CSS layouts to
get comfortable with the process. Our from-
scratch example is deliberately simple just to
get you going. It’s a two-step process: first
you create the ID-based styles you’ll want for
each division, and then you create the divi-
sions and pair them to those ID-based styles.
By the way, some of the example styles are a
bit garish so they show up better in the
black-and-white screenshots. For your own
examples, feel free to exhibit better taste.
Adjust your workspace as explained in “To
set up for positioning work” on page 150.

To create ID styles for a CSS layout:

1. Create a new blank HTML page 
(cN) and a new blank CSS file 
(File > New > CSS).

2. Save both pages, naming them
default.htm and layout.css.

3. Select the default.htm page, and click
Attach Style Sheet in the Manage Styles
tab. Use the Attach Style Sheet dialog 
box to navigate to the layout.css file
(Figure 8.34). Click OK.

The dialog box closes, and the page’s
Manage Styles tab now lists the external
style sheet (Figure 8.35).

156

Chapter 8
Cr

ea
ti

n
g

 C
S

S
 L

ay
o

u
ts

 f
ro

m
 S

cr
at

ch

Figure 8.34 Use the Attach Style Sheet dialog
box to navigate to the layout.css file.

Figure 8.35 Once
attached, the external
style sheet is listed in
the Manage Styles tab.



4. Click New Style in the Manage Styles tab.
The New Style dialog box’s selector field
automatically generates a generic style
name (top, Figure 8.36). Press B
twice to clear the field, and type: #con-
tainer. Select Existing style sheet in the
Define in drop-down menu and layout.css
in the URL box (bottom, Figure 8.36).

5. With the New Style dialog box still open,
set the Position category to position:
absolute, width: 100%, and height: 100%
(Figure 8.37). Set any other categories
and properties you need, but remember
that you also can add them later if
needed. (For help on setting the position-
related properties, see “Positioning
Properties” on page 146.) Click OK.

The #container ID now is listed in the
Manage Styles tab (Figure 8.38). Notice
that the red dot is not circled because the
ID has not been applied to a page yet.

(continued)
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Figure 8.37 Because the container division encloses
all the other page content, use the settings: position:
absolute, width: 100%, and height: 100%.

Figure 8.36 Replace the generic style name with:
#container (#yourDivisionName).

Figure 8.38 The #con-
tainer ID now is listed
in the Manage Styles
tab, though the dot is
not circled because the
ID has not been
applied yet.



6. Repeat steps 4 and 5 to add the other
division IDs you expect to need in your
layout. You’ll use them in the next task,
“To insert div tags and pair with ID
styles” (Figure 8.39).

7. When you’re done, choose File > Save All.
You can examine the properties for each
ID style by switching to the Apply Styles
tab or the style sheet (layout.css)
(Figures 8.40 and 8.41).

✔ Tips

■ In step 5, by defining the container div as
the page’s full width and height, it’s much
easier to insert the rest of the divs on the
page. The other advantage of putting all
the other div tags inside the container div
is that you can apply styles to all those
divs just by modifying the container’s
styles. (For more information, see “Using
Contextual Selectors” on page 154.)

■ In step 6, you do not need to do more
than create the IDs for now. Unlike the
example, you can do the detailed styling
at any time.
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Figure 8.40 The Apply
Styles tab offers visual
reminders of each
style, with the details
available with a cursor
roll over.

Figure 8.41 You 
also can inspect the
details of your styles
by switching to the
style sheet.

Figure 8.39 Create the
other ID-based styles you
expect to need in your
layout.



To insert div tags and pair with 
ID styles:

1. Click anywhere inside the HTML page
used in the previous task (default.htm).

2. Add a div tag to the page by choosing
Insert > HTML > <div> or double-click-
ing the div button in the Toolbox pane
(Figure 8.42). The div button also can be
found in the Common toolbar.

An empty division, marked by a dotted
border, appears across the top of the page
(left, Figure 8.43).

3. To select the div, click its box in the Design
window, or any part of <div></div> in the
Code window, or the <div> tag in the
Quick Tag Selector at the top of the
Editing window (right, Figure 8.43).

4. Switch to the Tag Properties pane, which
sits in the same task pane as the CSS
Properties pane, and click the blank col-
umn to the right of id. A list of the IDs
you previously created appears in the
drop-down menu (Figure 8.44). Choose
container, and press E .

The container id is applied to the div tag
in the Tag Properties pane, as well in the
Quick Tag selector and page views
(Figure 8.45). This step is the key to the
CSS and HTML files working in tandem.

(continued)
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Figure 8.42 To insert div tags, choose Insert >
HTML > <div> (left) or double-click the div button
in the Toolbox pane (right).

Figure 8.43 The empty division is marked
by a dotted border (left). To select the div,
click on it in the Design window, Code win-
dow, or the Quick Tag Selector at the top of
the Editing window (right).

Figure 8.45 The container id is applied to the
div tag in the Tag Properties pane as well in
the Quick Tag selector and page views.

Figure 8.44 To pair a div with an
ID-based style, make a selection
from the id drop-down menu in
the Tag Properties tab.



5. Using the Design or Code window, click
inside the container div. Repeat steps 2
through 4 to insert and ID the next divi-
sion for your page. In the example, it’s
div#masthead (Figure 8.46).

6. Because the masthead div now sits inside
the container div, use the Split view to
make it easier to keep the next div also
inside the container div. Click just before
the container div’s end tag </div>
(Figure 8.47).

7. Repeat steps 2 through 4 until you insert
divs to pair with all the IDs you generated
in “To create ID styles for a CSS layout”
on page 156.

8. Choose File > Save All to preserve your
work. You now can either go back and
further modify the styling for the IDs, 
add content to the divisions, or create
contextual selectors tied to those IDs as
explained on page 154 (Figure 8.48).

✔ Tips

■ If you’re working in Split view, changes
made in the Design view simultaneously
appear in the Code view. However,
changes made in Code view do not show
up in the Design view until you refresh
the view (5 ) or save the page (cS).

■ In step 5, you could insert the divs in any
order. But if you order them top-to-bot-
tom as they would appear on your page,
it’ll be easier for non-CSS browsers, such
as those in cell phones, to render the lay-
out correctly.

■ While the CSS Properties tab and Manage
Styles tab are your best tools for changing
a division’s positioning, the Positioning
toolbar can speed your work by providing
at-a-glance information about key aspects
of positioning (Figure 8.49).

160

Chapter 8
In

se
rt

in
g

 T
ag

s 
an

d 
Pa

ir
in

g
 w

it
h

 ID
St

yl
es

Figure 8.46 The masthead division should be
inserted inside the container division’s tag.

Figure 8.47 To insert another division inside
the container, click between the masthead’s
end tag (the first </div>) and the container’s
end tag (the second </div>).

Figure 8.48 The end result: a from-scratch CSS-based
layout, complete with contextual selectors.

Figure 8.49 The Positioning toolbar can speed your
work with key information about positioning.



One of the great advantages of Web pages
over printed pages is their ability to respond
to viewers’ actions. Triggered by a cursor
motion or click, buttons can change colors,
images swap out, and messages pop up. Of
course, such behaviors can cut both ways,
driving away instead of inviting visitors.
When used with restraint and clear purpose,
however, interactivity can beckon viewers to
stick around and further explore your site.
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Creating Interactive
Buttons
Expression Web makes it a breeze to gener-
ate professional looking buttons that inter-
act with the visitor’s cursor. Even better, you
can go back and edit their style and labels at
any time, and replacement images are gener-
ated automatically. If you’re looking to create
a row of buttons with the same look and
height, be sure to see “To duplicate interac-
tive buttons” on page 165

To add an interactive button:

1. In Design view, click on the page where
you want to add a button. Choose Insert >
Interactive Button (Figure 9.1).

2. In the Interactive Buttons dialog box,
pick a style from the middle Buttons list,
type a Text label, and click Browse
(Figure 9.2).

3. Navigate to the page to which you want
to link and type the text you want to 
display when a cursor hovers over the 
link (ditto for the Screen Tip button)
(Figure 9.3). Click OK. (If the label does-
n’t fit the size, see step 3 of “To edit an
interactive button” on page 164.)

4. When the Interactive Buttons dialog box
reappears with the link added, click the
Font tab (Figure 9.4).

5. In the Font tab, use the middle scroll
boxes to choose your font, its style, and
its size (Figure 9.5). (See second tip.)
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Figure 9.1 To add an interactive but-
ton, choose Insert > Interactive
Button.

Figure 9.2 Pick a
style from the mid-
dle Buttons list,
type a Text label,
and click Browse.

Figure 9.3 Navigate
to your target page,
add the text you
want to display
when a cursor 
hovers over the link,
and click OK.

Figure 9.4 When 
the Interactive
Buttons dialog box
reappears with the
link added, click the
Font tab.

Figure 9.5 Use the
middle scroll boxes
to choose your font,
its style, and its size.



6. In the bottom half of the dialog box, set
the colors you want the text to display
based on the visitor’s cursor action, plus
the text’s alignment. You can test the
hover and pressed color changes in the
top preview area (Figure 9.6).

7. Click the Image tab.

8. In the Image tab, you can enlarge or
shrink the button itself, either propor-
tionally or in just one dimension if you
uncheck the Maintain proportions box
(Figure 9.7). Change the background
color for the JPEG image if you want, or
select the second radio button if you’d
rather use a GIF image. Click OK.

9. The Save Embedded Files dialog box
shows where the new button images will
be saved (Figure 9.8). Since each button
generates three images, keep your images
folder uncluttered by clicking Change
Folder to create a buttons subfolder.
When the dialog box reappears, click OK.

The button appears in the page (Figure
9.9). Save your work and press = to
test it in your browsers (Figure 9.10).

✔ Tips

■ Unlike the Insert Hyperlink dialog box,
the Edit Hyperlink dialog box does not
have a Create New Hyperlink button
(Figure 9.3). So you’ll want to create a
destination page—a blank page will work
fine and not interrupt your work—before
you insert the button.

■ In step 5, don’t worry about which fonts
your site’s visitors have installed on their
machines. Since Expression Web creates
images of the buttons, you can go wild.
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Figure 9.6 Test the
hover and pressed
color changes using
your cursor in the
top preview area

Figure 9.7 In the
Image tab, you can
resize the button
proportionally or in
just one dimension if
you uncheck the
Maintain propor-
tions box.

Figure 9.8 The
Save Embedded
Files dialog box
lets you choose
where the new
button images will
be saved.

Figure 9.9
The button as 
it appears in 
the page’s 
navigation-bar
division.

Figure 9.10
Tested in the
browser, the
cursor rollover
displays the
text entered 
in step 2.



To edit an interactive button:

1. Right-click a button you want to change,
and choose Button Properties in the
drop-down menu (Figure 9.11).

2. When the Interactive Buttons dialog box
appears, use the Button tab to change the
button’s style, text label, or link (Figure
9.12). In the example, a new label is cut
off on both ends (Figure 9.13).

3. Click the Image tab.

4. In the Image tab, uncheck the Maintain
proportions box (top, Figure 9.14). Press
the up arrow for the Width box to grow
the label enough to show all the text (bot-
tom, Figure 9.14). (See the tip.)

5. If you want to change the font, switch to
the Font tab and make your changes.
Otherwise, click OK to close the dialog
box.

6. The Save Embedded Files dialog box
shows where the new button images will
be saved, and warns you which previous
images it will overwrite (Figure 9.15).
Click OK.

The button appears in the page. Save your
work and press = to test it in your
browsers.

✔ Tip

■ In step 4, if you increase either dimension
but don’t uncheck the Maintain propor-
tions box, the whole image grows. That
will create a height mismatch if the but-
ton is part of a row of buttons.
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Figure 9.11 To edit an interac-
tive button, right-click it and
choose Button Properties.

Figure 9.12 Use 
the Button tab to
change the button’s
style, text label, or
link.

Figure 9.13 The new
label is cut off on
both ends, so click
the Image tab.

Figure 9.14
Uncheck Maintain
proportions (top),
and press the up
arrow for the Width
box to grow the
label enough to
show all the text
(bottom).

Figure 9.15 The
Save Embedded
Files dialog box
warns you about
which previous
images it will over-
write.



To duplicate interactive buttons:

1. In Design view, right-click a button
whose appearance you want to duplicate
and choose Copy from the drop-down
menu (Figure 9.16).

2. Click on the page where you want to add
a matching button, typically in a row of
buttons. Right-click and choose Paste
from the drop-down menu (Figure 9.17).

A copy of the button is pasted into the
page, at which point you can right-click it
and choose Button Properties to edit the
label, link, and width (Figure 9.18).

✔ Tips

■ This is the quickest way to create
matching buttons because the Font 
tab in the Interactive Button dialog 
box doesn’t remember which font or 
size you used last.

■ You can paste a button on another page
as well, which makes it easy to populate
your site’s navigation bars (Figure 9.19).
Another option, of course, is to copy the
entire row of buttons and paste it else-
where, though it can be tricky making an
accurate selection and finding the precise
insert spot.
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Figure 9.16 Right-click a
button whose look you
want to duplicate, and
choose Copy.

Figure 9.17 Click where you want to
add a matching button (just right of
first button), and then right-click and
choose Paste.

Figure 9.18 Right-click the duplicated but-
ton, and choose Button Properties to edit
its label, link, and width.

Figure 9.19 Copying and pasting buttons makes it
easy to populate navigation bars, even when you
have to edit the labels and links.



Adding Behaviors to
Elements
Like interactive buttons, behaviors offer a
way to create pages that respond to your
users. Behaviors are driven by scripts that
have two parts: an action triggered by a spe-
cific event. An example might be a sound
that plays (the action) when a cursor rolls
over an image (the event) (Figures 9.20 
and 9.21). Behaviors can be applied to a 
variety of elements on the page, though 
not every behavior is possible with every 
element. For example, you cannot swap an
image for another unless you’ve selected 
an image as your element. While the exam-
ple below applies to swapping an image, the
steps are essentially the same for adding 
any behavior. See Table 9.1 on page 173 for 
a list of all the behavior choices. Beginners
can quickly create interactive jump menus.
With experience, you can combine behaviors
with layer visibility and CSS positioning to
create such advanced actions as fly out
menus. (For more information on fly out
menus, see the companion Web site at:
www.waywest.net/expression/.)

To add a behavior:

1. To open the Behaviors task pane, choose
Format > Behaviors or choose Task
Panes > Behaviors.

2. In Design view, click the element to
which you want to add a behavior.

The tag appears at the top of the
Behaviors task pane (Figure 9.22).

3. In the Behaviors task pane, click Insert
and choose an action from the drop-
down menu. In the example, it’s Swap
Image (Figure 9.23).
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Figure 9.20 The Behaviors
task pane’s Insert button
lists available actions for
the selected tag. Actions
inappropriate for the ele-
ment are dimmed.

Figure 9.21 Once you insert
an action for a selected 
element (div#masthead in
this example), use the
drop-down menu to pick a
triggering event.

Figure 9.22 The tag for any
selected element appears in
the Behaviors task pane.

Figure 9.23 In the Behaviors task pane,
click Insert and choose an action from
the drop-down menu.

www.waywest.net/expression/


4. A dialog box appears to set the details of
the action. Here, the Swap Images dialog
box asks you to browse to the image you
want to swap in (top, Figure 9.24). By
selecting Restore on mouseout event, the
swapped image appears only when a cur-
sor hovers over the spot (bottom, Figure
9.24). Click OK to close the dialog box.

The Behaviors task pane lists the event
and action now linked to that element. In
the example, the image swaps in another
image (the action) when the mouse
moves over the element (the event) and
restores the original (another action)
when the mouse moves out (another
event) (Figure 9.25).

5. Save your work, and test the page in a
browser (Figure 9.26).

✔ Tips

■ The Behaviors task pane lists events and
actions in the order they occur. In step 4,
the first event-action set (onmouseout
and image restore) comes first because
the page starts off that way. It’s only 
after that event that the second event-
action (onmouseover and image swap)
would occur.

■ If the event-action sets cannot be
reordered, the up and down arrows
remain dimmed.

■ The available behaviors for elements are
tied to the CSS schema you selected in
the Authoring tab of the Page Editor
Options dialog box. (Choose Tools > Page
Editor Options.)
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Figure 9.24 A dialog box lets you set the action’s
details. Here, the Swap Images dialog box asks you to
browse to the image you want to swap in.

Figure 9.26 An image swap behavior as tested
in the browser: The first image appears (top)
before the cursor rolls over the area, triggering
a swap to the second image (bottom).

Figure 9.25 The Behaviors
task pane lists the events
and actions linked to that
element.



To change a behavior:

Do one of the following:

◆ Double-click any listed action to open its
dialog box, where you can change the
action’s properties (Figure 9.27).

◆ Click the drop-down menu for any listed
event, choose a new event, and release the
cursor (Figure 9.28).

The new event replaces the original event
in the Behaviors task pane.

◆ Click any listed action, and click Delete at
the top of the Behaviors task pane (top,
Figure 9.29).

The action disappears from the Behaviors
task pane (bottom, Figure 9.29).
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Figure 9.27 To change
an action, double-click
any listing to open its
dialog box.

Figure 9.28 To change an
event, use the drop-down
menu to choose a new
event.

Figure 9.29 Select
an action in the
Behaviors task
pane, click Delete,
and it is removed.



To go to another Web page:

1. Select the page element you want to use.
In the Behaviors task pane, click Insert
and choose Go To URL (Figure 9.30).

2. When the dialog box appears, browse to
the URL you want to use (Figure 9.31).
Click OK to close the dialog box.

The action is added to the Behaviors task
pane with onmouseover as the default
event setting (Figure 9.32).

3. If you’d rather use another triggering
event, click the Events drop-down menu
to change it. In the example, onclick gives
the user more control than onmouseover.

4. Save your work and test the page in your
browsers.
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Figure 9.31 Browse to the URL you want to
use, and click OK to close the dialog box.

Figure 9.30 To go to another
Web page, click Insert and
choose Go To URL.

Figure 9.32 To change 
the default event for the 
Go To URL action, make
another choice in the 
drop-down menu.



To check the browser version:

1. Click anywhere in the page. In the
Behaviors task pane, click Insert and
choose Check Browser.

2. In the dialog box that appears, select a
browser from the first drop-down menu
and then a version in the second drop-
down menu (Figure 9.33).

3. Use the Browse button to set the first 
Go to URL text box to link to a page
designed to look best for the browser
selected in step 2.

4. Set the second Go to URL text box to link
to another page designed to work well
with all other browsers. Click OK to close
the dialog box.

The action is added to the Behaviors task
pane with onclick as the default event
setting.

5. If you’d rather use another triggering
event, select it from the Events drop-
down menu.

6. Save your work and test the page in your
browsers.
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Figure 9.33 Select a browser from the first drop-down
menu and then a version in the second drop-down
menu.



To check for media plug-ins:

1. Before adding the behavior, create or
import into your site the page containing
the video or sound file you want to offer
visitors. Back in your main Web page, add
a small button, image, or bit of text to
highlight the link to the media file. (Short,
obvious wordings such as Listen or Watch
get the job done).

2. In the Behaviors task pane, click Insert
and choose Check Plug-in.

3. In dialog box that appears, select a media
player plug-in from the drop-down menu
(Figure 9.34).

4. Use the Browse button to set the first Go
to URL text box to link to a multimedia
item designed to look best for the plug-in
selected in step 2.

5. Set the second Go to URL text box to link
to another page designed to work well
with all other media players. Click OK to
close the dialog box.

The action is added to the Behaviors task
pane with onmouseover as the default
event setting.

6. If you’d rather use another triggering
event, select it from the Events drop-
down menu.

7. Save your work and test the page in your
browsers.
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Figure 9.34 Select a media player plug-in from the
drop-down menu.



To create a popup message window:

1. Select the page element you want to use.
In the Behaviors task pane, click Insert
and choose Popup Message.

2. When the dialog box appears, type your
message (Figure 9.35). Click OK to close
the dialog box.

The action is added to the Behaviors task
pane with onmouseover as the default
event setting.

3. If you’d rather use another triggering
event, select it from the Events drop-
down menu.

4. Save your work, and test the page in your
browsers (Figure 9.36).

✔ Tip

■ If you absolutely must get visitors’ atten-
tion, this is your tool. Otherwise, use with
great restraint. A better option would be
to use a status bar text message, as
explained on the next page.
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Figure 9.35 To create a popup message window, type
your message.

Figure 9.36 Rolling the cursor over the Roman
Holiday heading triggers the popup message.



To create a status bar message:

1. Select the page element you want to use.
In the Behaviors task pane, click Insert
and choose Set Text > Set Text of Status
Bar (Figure 9.37).

2. When the dialog box appears, type your
message (Figure 9.38). Click OK to close
the dialog box.

The action is added to the Behaviors 
task pane with onlick as the default event
setting.

3. If you’d rather use another triggering
event, select it from the Events drop-
down menu.

4. Save your work, and test the page in your
browsers.
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Table 9.1

N a m e W h a t  i t  d o e s

Call Script Enables you to trigger a custom JavaScript created outside Expression Web.
Change Property* Enables you to change details of the behavior, depending on the behavior selected.
Change Property Restore Reverts to previous property, based on event you choose.
Check Browser Checks which browser and version the site’s visitor is using. Enables you to serve special pages,

including style sheets, based on those results.
Check Plug-in* Checks if site’s visitor has such things as Flash player installed. Enables you to serve different ver-

sions of pages based on those results.
Go To URL Opens a link in either the existing page or in a new window.
Jump Menu Enables you to create a drop-down menu of links that user can choose.
Jump Menu Go Based on selected event trigger, sends user to the selected URL in a specified jump menu.
Open Browser Window Enables you to open a new browser window, whose size and toolbars you specify.
Play Sound Based on selected event trigger, causes browser to play selected sound.
Popup Message Based on selected event trigger, causes browser to display a specific message in a popup window.
Preload Images Allows background loading of secondary images for image swaps (rollovers).
Set Text Displays specified text in a specific frame, layer, text field, or the status bar.
Swap Image Based on selected event trigger, replaces one image with another.
Swap Image Restore Restores the original image used before a Swap Image behavior replaced it.

*Requires Internet Explorer 5 or later, or Netscape 6 or later

Available behaviors

Figure 9.38 Type the message you want to appear in
the browser’s status bar.

Figure 9.37
An alternative
to popup 
windows: Click
Insert and
choose Set
Text > Set Text
of Status Bar to
create a status
bar message.



To open another browser window:

1. Select the page element you want to use,
typically a link or image. In the Behaviors
task pane, click Insert and choose Open
Browser Window.

2. When the Open Browser Window dialog
box appears, enter the URL or click
Browse to set the contents of the new
window (Figure 9.39).

3. Enter a window name and size. The win-
dow name does not appear in the new
window. It’s simply used as part of a gen-
erated script, so it cannot have any spaces
or nonstandard ASCI characters.

4. Select the attributes you want to appear
with the new window. At a minimum
include: Navigation toolbar, Scrollbars as
needed, and Resize handles. Click OK to
close the dialog box.

The action is added to the Behaviors 
task pane with onlick as the default event
setting.

5. If you’d rather use another triggering
event, select it from the Events drop-
down menu.

6. Save your work, and test the page in your
browsers (Figure 9.40).

✔ Tips

■ As with popup messages, this behavior
can test the patience of visitors if it sim-
ply bumps them into a whole new screen-
gobbling window. It’s more effective when
used for small windows showing such
things as a product detail or close-up
view of something on the original page.

■ Give your users a clue as to what will hap-
pen by adding an explanation in the
image’s alt text label (Figure 9.40).
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Figure 9.39 When setting another browser window to
open, keep it small using the width and height text
boxes. Always include resize handles so the user can
control the new window.

Figure 9.40 When a cursor rolls over the photo (lower
right), its alt text tells the user that a click will open a
new window (upper left).



Using Jump Menus
A jump menu is one of the most useful of the
many behaviors you can add to a page
because it gives your users a lot of naviga-
tional information in a small space. By click-
ing the menu, users can choose among a
variety of links to which they can jump
directly.

To insert a jump menu:

1. Click in the page where you want the
jump menu to appear. In the Behaviors
task pane, click Insert and choose Jump
Menu (Figure 9.41).

2. When the Jump Menu dialog box
appears, click Add (Figure 9.42).

3. In the Add Choice dialog box, type a
name for this first choice but leave the
Value field blank (Figure 9.43). (See the
first tip). Click OK.

(continued)
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Figure 9.41 Click in the page where you 
want the menu to appear (right), and choose
Jump Menu from the Insert drop-down menu
in the Behaviors task pane (left).

Figure 9.42 When the Jump Menu dialog box appears,
click Add to begin building the menu list.

Figure 9.43 For the menu’s first item, type a label to
orient the visitor but leave the Value text box blank.



4. When the Jump Menu dialog box
reappears, click Add again to continue
building the menu list. From here on 
out, however, click Browse to add URLs
for each item in the rest of the list
(Figure 9.44).

5. Once you finish the menu list, click 
OK to close the Jump Menu dialog box
(Figure 9.45).

The menu appears in the page, and
Expression Web automatically assigns it
an ID name. As you can see in the exam-
ple, the menu’s default width and font size
is too big for the layout (Figure 9.46).
While you could click and drag to reduce
the width, that doesn’t solve the font size
problem (Figure 9.47). Fortunately, that
ID makes the fix easy.
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Figure 9.44 Add URLs for each of your other jump
menu choices.

Figure 9.45 Once you finish building the menu list,
click OK.

Figure 9.46 The menu appears in the page, and
Expression Web automatically assigns it an ID name.
The menu’s default width and font size, however,
need to be adjusted.

Figure 9.47 You can click and drag to reduce
the width (left), but the font size is still too big
to fit (right).



6. Click New Style in the Manage Styles tab.
When the New Style dialog box appears,
type that exact ID name in the Selector
text box. In the example, the jump menu
is named #id1 (top, Figure 9.48).

7. Use the dialog box’s Font, Block, and
Position categories to restyle the menu
using a smaller font and narrower width
(Figure 9.48). Click OK to close the dia-
log box.

The ID-based style now appears in the
CSS Properties tab, and the layout
reflects the new styling (Figure 9.49).

8. Save your work, and test the menu in a
browser (Figure 9.50).

(continued)
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Figure 9.48 A better way: Create a new style
using the ID, and then reduce the font (top) and
the menu’s width (bottom).

Figure 9.49 Fixed: The menu now fits (right)
and the new ID-based style appears in the
CSS Properties tab (left).

Figure 9.50 The
jump menu in
action: The first
item (Quick
Choices) appears
without clicking
the menu, sparing
users the bother 
if the menu’s not
relevant to their
needs.



✔ Tips

■ In step 3, the jump menu’s first label is
what appears in the Web page. By using it
to describe the contents—and leaving
that line unlinked—you give readers a
clue about the menu’s purpose without
forcing them to click it.

■ In step 6, the process of naming and
styling IDs is exactly what you did in
Chapter 8 when pairing IDs with div tags.
For more information, see “To create ID
styles for a CSS layout” on page 156. Also,
it’s true that the number-based names for
the jump menu IDs are hard to remember,
but leave them be. Unfortunately, if you
rename them using the Modify Style dia-
log box, those IDs disappear—along with
your stylings for them.

■ In step 7, if you click Apply in the New
Style dialog box, the dialog box’s name
immediately becomes Modify Style. Don’t
be startled: all your styling information is
still right there.

■ If you need to change the jump menu’s
labels, order, or content, double-click its
name in the Behaviors task pane.
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Expression Web comes with two sets of table
tools, one for traditional tables containing
columnar data and the other for layout tables
containing page elements. This chapter
focuses on columnar tables since layout
tables are being supplanted by CSS. The shift
away from tables for layouts isn’t a passing
fad. Page-sized tables take longer to load than
CSS-based layouts. Plus, tables cannot be eas-
ily adjusted to accommodate small displays,
such as cell phones. It’s true that layout tables
let you line up everything on your page just
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Figure 10.1 Using the Tables toolbar lets you bypass many of menu com-
mands for building tables.

Insert Columns
Left or Right

Choose, Apply
Fill Color

Choose, Apply
AutoFormat Combo

Show/Hide
Layout Tool

Draw 
Layout Table

Draw
Layout Cell

Insert Rows
Above or Below

Merge/Split
Cells

Spread Evenly
Columns, Rows

Autofit to
Contents

Align Top,
Center, Bottom

Delete
Cells

so. But they completely entangle presenta-
tion (how the page looks) with its contents
(the information it contains). That guaran-
tees major headaches when you inevitably
need to redesign pages and update content.

If you prefer using tables for layouts instead
of CSS, see “ Using Layout Tables” on page
200. No matter which kind of tables you’re
creating, you’ll find the work goes more
quickly using the Tables toolbar (Figure
10.1). Turn on the toolbar by choosing
View > Toolbars > Tables.



Creating Tables
Tables make it easy to present related text or
images in a quick-to-scan form. With their
rows and columns composed of individual
cells, tables also lend themselves to clean-
looking border and color treatments.

To insert a table:

1. Switch to Design view, and click where
you want a table placed in the page.

2. Choose Table > Insert Table (Figure 10.2).

3. In the Insert Table dialog box (Figure
10.3), use the Size section to set how
many rows and columns you want for 
the table.

4. Use the dialog box’s Layout section to set
the table’s alignment, float, and cell
padding or spacing.

5. Check Specify width to set the width of
the entire table, and use the option but-
tons to choose whether the width should
be absolute (pixels) or relative to the
width of the visitor’s Web page (percent).
Use the same approach for Specify height.

6. Use the Borders area to pick a size for the
boundary around the outside of the table.
If you like, use the drop-down menu to
pick a color and click Browse to add a
background picture.
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Figure 10.2 To insert a table,
choose Table > Insert Table.

Figure 10.3 Use the Insert Table dialog box to set the
table’s size and layout.



7. Leave Enable layout tools unselected. (See
the first tip about the Set section.) When
you’re done, click OK (Figure 10.4).

A table using those settings appears on
the page (Figure 10.5).

✔ Tips

■ In the Set section, select Set as default for
new tables if that’s what you want. To avoid
constantly monkeying with the default
settings, however, consider inserting a
plain table. Then customize the tables
when needed as explained in “Formatting
Tables and Cells” on page 193.

■ For quick tables using the default set-
tings, click the Insert Table button in the
Standard toolbar and drag your cursor
into the pop-up table to choose how
many rows and columns you want
(Figure 10.6). Release the cursor, and a
table of that size is inserted into the page.

■ If you want a borderless table, set Border
size to 0 in the Insert Table dialog box.

■ To proportionately resize the table after
it’s inserted, press s and click-and-
drag any corner to reduce or enlarge the
boundary.
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Figure 10.4 Once you set all the properties for the
table, click OK to close the dialog box.

Figure 10.5 The inserted table’s width is 100 percent
of the page’s.

Figure 10.6 For quick tables, click the
Insert Table button in the Standard tool-
bar and drag your cursor to choose how
many rows and columns you want.



To add table text:

1. Click inside any table cell (Figure 10.7).

2. Start typing, and the cell grows to accom-
modate your text (Figure 10.8).

To add table images:

1. Click inside any table cell.

2. Click the Insert Picture from File button
in either the Standard or Pictures toolbar
(Figure 10.9).

3. When the Picture dialog box appears,
navigate to the image you want inserted.
For details, see “Adding Images” on page
78. Once you find the picture, click Insert.

4. In the Accessibility Properties dialog 
box, add alternate text for the image, and
click OK.

The image appears in the table cell, which
expands to accommodate its size
(Figure 10.10).

✔ Tip

■ Expression Web includes what it calls
AutoFit to automatically fit any material
inserted into a cell. First, make sure the
Tables toolbar is active, and then after
you’ve inserted an item, click the AutoFit
to Contents button (Figure 10.11).
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Figure 10.8 As you type, the cell grows to accommo-
date your text.

Figure 10.9 To add images to a table, click
the Insert Picture from File button.

Figure 10.10 When a picture is inserted, the table cell
expands to hold it.

Figure 10.11 If material inserted into a cell
doesn’t fit, click the AutoFit to Contents but-
ton in the Tables toolbar.

Figure 10.7 To add 
table text, just click
inside a table cell.



To add table captions:

1. Click anywhere inside the table, and
choose Table > Insert > Caption 
(Figure 10.12).

2. When the cursor appears, it is centered 
at the top of the table. Type your caption
(Figure 10.13).

3. Once you’ve entered the caption, you 
can change the font or size just like any
other text.

✔ Tip

■ You can have the caption appear beneath
the table, by right-clicking it and choos-
ing Caption Properties. When the
Caption Properties dialog box appears,
choose Bottom of table and click OK
(Figure 10.14). The caption will move to
the bottom.
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Figure 10.12 To add a caption, click inside the table,
and choose Table > Insert > Caption from the menu.

Figure 10.13 By default, captions are centered at
the top of tables.

Figure 10.14 Use the Caption Properties dialog
box to reposition captions beneath tables.



Selecting Table Elements
Unlike many Expression Web procedures,
selecting cells, rows, and columns within
tables isn’t always a click-and-drag affair.

To select a cell:

Do one of the following:

◆ Press a , and click inside any cell. The
cell is selected, denoted by its color
changing (Figure 10.15).

◆ Click anywhere in a cell, and choose
Table > Select > Cell (Figure 10.16).
The cell is selected, denoted by its color
changing.

To select multiple cells:

Do one of the following:

◆ To select adjacent cells, click and hold
your cursor in a cell and then drag the
cursor to select additional cells (Figure
10.17).

◆ To select nonadjacent cells, press a and
click inside any cell, release the cursor,
then press as , and click another
cell. Repeat until you’ve selected all the
cells you need (Figure 10.18).
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Figure 10.15 To select a cell, press a and click
inside the cell.

Figure 10.17 To select adjacent cells,
click the cursor in a cell and then drag
the cursor to select additional cells.

Figure 10.18 To select nonadjacent cells, press a
and click inside any cell and then press as
as you select other cells.

Figure 10.16 To select
any element of a
table, choose Table >
Select and make a
choice from the sub-
menu.



To select a row:

Do one of the following:

◆ Click anywhere in a row, and choose
Table > Select > Row (Figure 10.16).
The row is selected.

◆ Click and hold your cursor anywhere in a
row, and then drag the cursor to select
the rest of the cells in the row.

◆ Move the cursor to the left edge of a row
until it becomes an arrow, and then click
once. The row is selected (Figure 10.19).

To select a column:

Do one of the following:

◆ Click anywhere in a column, and choose
Table > Select > Column (Figure 10.16).
The column is selected.

◆ Click and hold your cursor anywhere in a
column, and then drag the cursor to
select the rest of the cells in the column.

◆ Move the cursor to the top edge of a col-
umn until it becomes an arrow, and then
click once. The column is selected
(Figure 10.20).

To select an entire table:

Do one of the following:

◆ Click anywhere in a table, and choose
Table > Select > Table (Figure 10.16).

The entire table is selected.

◆ Click anywhere in a table, and then use
the Quick Tag Selector to click on the
table tag (Figure 10.21).

The entire table is selected.
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Figure 10.19 To select a row, move the cursor to
the left edge until it becomes a black arrow. Click
once, and the row is selected.

Figure 10.20 To select a column, move the cursor
to the top edge until it becomes a black arrow.
Click once, and the column is selected.

Figure 10.21 You also can select a table by using the
Quick Tag Selector to click the table tag.



Changing Table Structure
You can go back and expand a table at any
time, whether it’s by adding a single cell, a
row or column, or even inserting another
table into the table.

To add cells:

1. Click in a cell next to where you want to
add a cell.

2. Choose Table > Insert > Cell to the Left 
or Cell to the Right (Figure 10.22).

Depending on your choice, a single cell 
is inserted into the table just left or right
of the selected cell (Figure 10.23).
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Figure 10.22 To add cells, choose Table > Insert > Cell
to the Left or Cell to the Right.

Figure 10.23 A single cell is inserted into the table left
of the selected cell.



To add rows:

1. Select a row next to where you want to
insert a new row.

2. Choose Table > Insert > Row Above 
or Row Below (Figure 10.24). Or if 
the Tables toolbar is active, click the 
Row Above or Row Below buttons
(Figure 10.25).

The row is inserted into the table 
(Figure 10.26).

✔ Tip

■ You also can insert multiple rows by
choosing Table > Insert > Rows or
Columns. In the dialog box that appears,
select the Rows radio button, set how
many rows to insert, and choose whether
to insert them above or below the
selected row (Figure 10.27).
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Figure 10.24 To add rows, choose Table > Insert > Row
Above or Row Below.

Figure 10.25 If the Tables toolbar is active,
you also can add rows by clicking the Row
Above or Row Below buttons.

Figure 10.26 A new row is inserted into the table.

Figure 10.27 Use the
Insert Rows or Columns
dialog box to set the
number and placement of
the rows you want added.



To add columns:

1. Select a column next to where you want
to insert a new column.

2. Choose Table > Insert, and then choose
Column to the Left or Column to the
Right (Figure 10.28). Or if the Tables
toolbar is active, click the Column to the
Left or Column to the Right buttons
(Figure 10.29).

The column is inserted into the table
(Figure 10.30).

✔ Tip

■ You also can insert multiple columns by
choosing Table > Insert > Rows or
Columns. In the dialog box that appears,
select the Columns radio button, set how
columns rows to insert, and choose
whether to insert them to the left or right
of the selected column (Figure 10.31).
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Figure 10.28 To add columns, choose Table > Insert >
Column to the Left or Column to the Right.

Figure 10.29 If the Tables toolbar is active, you
also can add columns by clicking the Column
to the Left or Column to the Right buttons.

Figure 10.30 A new column is inserted into the table.

Figure 10.31 Use the
Insert Rows or
Columns dialog box to
set the number and
placement of the
columns you want
added.



To delete any part of a table:

1. Select the parts of the table you want to
delete, whether it’s a cell, a single row, or
several rows or columns.

2. Choose Table > Delete Cells, or if the
Tables toolbar is active, click the Delete
Cells button (Figure 10.32). All the
selected cells are deleted.

✔ Tip

■ You also can right-click the selected part
of the table and choose Delete and a sub-
menu (Figure 10.33).
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Figure 10.32 To delete part of a table, select it, choose
Table > Delete and make a choice in the submenu
(left). You also can click the Delete Cells button in the
Tables toolbar (right).

Figure 10.33 You also can right-click the selected part
of the table and choose Delete and a submenu.



Splitting and Merging
Cells
While it’s easy to add or delete parts of a
table, sometimes you’ll want to create or
delete an individual cell and not affect the
overall dimensions of the rest of the table.
That’s where the ability to split a cell into two
cells, or merge several cells into a single cell,
becomes especially handy. You can, for exam-
ple, create a large cell in the center of a table
by merging several adjacent cells and avoid
messing up anything else in the table.

To split cells:

1. Click inside the cell you want to split.

2. Choose Table > Split Cells, or if the Tables
toolbar is active, click the Split Cells but-
ton (Figure 10.34).

3. When the Split Cells dialog box appears,
choose whether you want the selected
cell divided horizontally into rows or ver-
tically into columns (Figure 10.35).

4. Use the arrows, or enter numbers directly
in the text window, to set the Number of
rows or Number of columns you want the
cell split into. When you’re done, click OK
and the cell is split.

✔ Tip

■ You also can right-click the cell and
choose Modify > Split Cells from the
drop-down menu.
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Figure 10.34 To split a cell, click inside it and choose
Table > Modify > Split Cells (left), or click the Split
Cells button in the Tables toolbar (right).

Figure 10.35 Use the
Split Cells dialog
box to divide a cell
vertically into
columns or horizon-
tally into rows.



To merge cells:

1. Select the cells you want merged.

2. Choose Table > Merge Cells, or if the
Tables toolbar is active, click the Merge
Cells button (Figure 10.36). The selected
cells are combined into a single cell.

✔ Tip

■ You also can right-click the cell and
choose Modify > Merge Cells from the
drop-down menu.
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Figure 10.36 To merge cells, select them and choose
Table > Modify > Merge Cells (left) or click the button
in the Tables toolbar (right).



Evening Up Rows and
Columns
Inevitably as you work on a table, things get
messy. Fortunately, there’s an easy way to
tidy things up by making all your rows the
same height or all your columns the same
width. The process, by the way, initially
seems a bit backward because you select a
column to even up the row height and select
a row to even up the column width.

To make rows the same height:

1. Select a column containing a cell from
each uneven row.

2. Choose Table > Modify > Distribute Rows
Evenly (top, Figure 10.37). If the Tables
toolbar is active, you also can click the
Distribute Rows Evenly button (bottom,
Figure 10.37). The height of the rows is
evened up.

To make columns the same width:

1. Select a row containing a cell from each
uneven column.

2. Choose Table > Modify > Distribute
Columns Evenly (top, Figure 10.38). If
the Tables toolbar is active, you also can
click the Distribute Columns Evenly but-
ton (bottom, Figure 10.38). The width of
the columns is evened up.
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Figure 10.37 To make rows the same height,
choose Table > Modify > Distribute Rows
Evenly (top) or use the button in the Tables
toolbar (bottom).

Figure 10.38 To make columns the same width, choose
Table > Modify > Distribute Columns Evenly (top), or
use the button in the Tables toolbar (bottom).



Formatting Tables and
Cells
Once you’ve added a table to your page, put
some text and images into it, and perhaps
changed its structure, you’re ready for the
final step: formatting the full table and indi-
vidual cells. As you reposition or resize a
table, Expression Web automatically
attaches a class-based style to the table,
which you can style directly. By renaming
and further modifying this style, you make it
easy to reuse later with other tables.

To format tables:

1. Right-click the table, and choose Table
Properties (Figure 10.39).

2. When the Table Properties dialog box
appears (Figure 10.40), use the Layout
section to set the table’s alignment, width,
and the cell padding and spacing. The
Float drop-down menu lets you float the
table to the left or right of text that ordi-
narily would appear below the table. For
more information on floats, see “Using the
Float and Clear Tags” on page 148.

3. Use the dialog box’s Borders section to set
the table’s border. For details, see “To for-
mat table borders” on the next page.

4. If you want to apply the same color to
every cell in the table, use the pop-up 
box in the Background section to choose
your color.

5. Once you’re done, click OK, and the
changes are applied to your table.
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Figure 10.40 Use the Table Properties dialog box to
format any aspect of the selected table.

Figure 10.39 To 
format a table,
right-click it and
choose Table
Properties.



To format table borders:

1. Select the table to which you want bor-
ders applied, and then right-click and
choose Table Properties (Figure 10.39).

2. When the Table Properties dialog box
appears, use the Borders section to set
the Size (width) of your border (Figure
10.41). Use the Color pop-up box to pick
a color.

3. Once you set the width and color, click
OK or click Apply (right), and the border
changes are applied (left) (Figure 10.42).

✔ Tip

■ Use the Table AutoFormat icon in the
Tables toolbar to preview and modify a
variety of preformatted table settings
(Figure 10.43). Once you learn the
names of the preformatted choices, you
can reach them directly by clicking the
drop-down menu next to the Table
AutoFormat button (Figure 10.44).
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Figure 10.41 Use the Borders section the Table
Properties dialog box to set the size (width) and
color of your border.

Figure 10.42 Once you set the width and color,
click OK or click Apply (right) and the border
changes are applied (left).

Figure 10.43 Click the Table AutoFormat
button in the Tables toolbar to preview
the preformatted table choices.

Figure 10.44 Click the drop-down menu
in the Tables toolbar to quickly reach
Table AutoFormats.



To format tables using CSS:

1. Any repositioned or resized table auto-
matically has a class-based style attached
to it. To see its properties, roll your cursor
over the style name in the Manage Styles
tab or the CSS Properties tab. In the
example, it’s .style1 (Figure 10.45).

2. In the Manage Styles tab, right-click the
style, and choose Rename class in the
drop-down menu (Figure 10.46).

3. In the Rename Class dialog box, give the
class a new name that indicates its pur-
pose, such as .mainTablestyle in the
example (Figure 10.47). Click OK to
close the dialog box.

4. In the Manage Styles tab (or CSS Proper-
ties tab), right-click the renamed style
and choose Modify Style (Figure 10.48).

Use the categories in the Modify Styles
dialog box to make other changes to the
table’s style (Figure 10.49). When you’re
done, click OK to close the dialog box. For
more information on using the dialog
box, see Chapter 7 on page 121.
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Figure 10.45 To see the style proper-
ties attached to a table, roll the cursor
the style name in the CSS Properties
tab (or Manage Styles tab).

Figure 10.49 Use the categories in the Modify Styles
dialog box to make other changes to the table’s style.

Figure 10.46 In the
Manage Styles tab, right-
click the style and choose
Rename class in the drop-
down menu.

Figure 10.47 Give
the class a new
name that indicates
its purpose, such as
.mainTablestyle.

Figure 10.48 Right-
click the renamed
style, and choose
Modify Style.



To format cells:

1. Select the cell or cells you want to format,
and then right-click and choose Cell
Properties (Figure 10.50).

2. When the Cell Properties dialog box
appears (Figure 10.51), use the Layout
section to change the alignment and size
of the selected cell.

3. Check Specify width and Specify height 
if you want to set the cell’s dimensions.
Choose pixels to make either dimension
absolute or percent to make it relative 
to the size of the viewer’s Web browser
window.

4. If you want to have the selected cell span
more than one row or column, enter a
number in the Rows spanned window or
Columns spanned window.
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Figure 10.51 Use the Cell Properties dialog box to
change the cell’s alignment, size, and borders.

Figure 10.50 To format
selected cells, right-
click and choose Cell
Properties.



5. Use the Borders section to set the thick-
ness and color of the cell’s border and the
Background section for the color within
the cell. When you’re done making
changes, click OK (Figure 10.52)

The dialog box closes, and the changes
are applied to the selected cell(s) 
(Figure 10.53).

✔ Tip

■ In the Layout section, check Header cell 
if you want the selected cells to act as
labels for rows or columns within a table.
Expression Web makes the text in header
cells boldfaced. The No wrap option keeps
the selected cell’s text all on one line.

■ While the Cell Properties dialog box
offers the option of setting border colors
for individual cells, it’s more effective
visually to adjust borders for an entire
table. For details, see “To format table
borders” on page 194.

■ You may find it faster to use the Tables
toolbar to change a cell’s alignment 
or color.
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Figure 10.52 Once you’ve made your changes, click
OK to close the dialog box and apply the changes to
the cell.

Figure 10.53 The cell with the new formatting applied.



Adding Excel
Spreadsheets
There are two ways to display Excel spread-
sheet data in your Web pages. The first, as
explained below, simply creates a table based
on the Excel data at the time you import it.
In other words, it’s static data—not a “live”
spreadsheet that’s dynamically updated. The
second method serves up live data that
changes based on users’ input. Unfortu-
nately, it only works if your Web site’s host
service uses Active Server Pages (ASP) and
Microsoft’s Internet Information Services
(IIS). Because of that limitation, we don’t
cover serving dynamic pages. But it couldn’t
be simpler to serve up static Excel data.

To add static Excel data:

1. Use Excel to select and save just the por-
tion of the spreadsheet you need. Save the
spreadsheet in the standard .xls format
and close the document.

2. Back in Expression Web in Design view,
insert a single-cell table on the page.

3. Click inside the new table, and choose
Insert > File (Figure 10.54).

4. Use the Select File dialog box to browse
to the Excel document. (Be sure to set the
files type drop-down menu to All Files.)
Click Open.

A status dialog box appears briefly as
Expression Web translates the file from
the Rich Text Format (RTF) to HTML
(Figure 10.55). The data is inserted into
the Web page as a borderless table
(denoted by the dashed outlines).

5. Depending on the file, the headers and
column labels may be huge. To fix the
problem, leave the entire table selected
and use the Common toolbar’s Font Size
drop-down menu to select a smaller size
(Figure 10.56).
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Figure 10.55 A status dialog box
appears briefly as Expression
Web translates the file.

Figure 10.56 If the Excel headers and column labels
are too big, leave the entire table selected and use
the Common toolbar’s Font Size drop-down menu to
select a smaller size.

Figure 10.54 To add static Excel
data to a table, choose Insert >
File.



6. It’s common for spreadsheets to sprawl
much wider than a standard Web page.
To fix that problem, right-click the table
and choose Table Properties from the
drop-down menu.

7. Use the Table Properties dialog box to
change the width from pixels to percent
(Figure 10.57). Click OK to close the dia-
log box.

Save the page, and take a look in your
Web browsers (Figure 10.58). To further
format the spreadsheet, use any of the
methods explained earlier in the chapter.

✔ Tips

■ In step 3, you also can click and drag the
Excel file directly from its folder into the
Expression Web page (Figure 10.59).

■ You can easily reformat the borderless
Excel-based table into something more
Web-like. For details, see “Formatting
Tables and Cells” on page 193.

■ The example here uses Windows XP. In
theory, it should work the same way in
Windows Vista, though I could not get it
to work without an error message. But
here’s a workaround: copy the needed
range of cells in Excel and then paste
them directly into Expression Web.
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Figure 10.57 If the Excel data sprawls, use the Table
Properties dialog box to change the width from pixels
to 100 percent of the page width.

Figure 10.58 Before further formatting, take a look at
the spreadsheet in a Web browser.

Figure 10.59 You also can click and drag
the Excel file directly from its folder into
the Expression Web page.



Using Layout Tables
If you’re not quite ready to switch to using
CSS positioning for your layouts, layout
tables offer the most control for the greatest
number of Web browsers. Be sure to turn on
the Tables toolbar (View > Toolbars > Tables)
(Figure 10.60). The Layout Tables task pane
includes twelve prebuilt page-sized layout
tables to speed your work (Task Panes >
Layout Tables). You also have the option of
directly drawing a layout table.

To add a prebuilt layout table:

1. Switch to Design view, open a blank page,
and click the prebuilt layout you want to
use in the Layout Tables task pane
(Figure 10.61).

The layout table is inserted into the 
page with size labels marking each cell
(Figure 10.62).

2. To resize any cell, click the size label at its
side or top (Figure 10.63).
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Figure 10.61 Click the prebuilt lay-
out you want to use in the Layout
Tables task pane.

Figure 10.60 Before working with layout
tables, turn on the Tables toolbar (View >
Toolbars > Tables).

Figure 10.62 The layout table is inserted into
the page with size labels marking each cell.

Figure 10.63 To resize any cell, click the size label
at its side or top and make a choose in the drop-
down menu.



3. In the drop-down menu, choose Change
Row Height (or Change Column Width) if
you want to pick an exact value. Use the
dialog box to enter a new value (in pixels),
and click OK (Figure 10.64).

The row or column changes size 
(Figure 10.65).

or

In the drop-down menu, choose Make
Row (or Column) Autostretch to have the
cell automatically shrink or grow as its
content changes (Figure 10.66).

The row or column changes size 
(Figure 10.67).

4. Add your content to the layout 
(Figure 10.68).

✔ Tips

■ If at any point, the size handles disappear,
just click the Show Layout Tool button in
the Layout Tables task pane or the Tables
toolbar.

■ You can resize the rows and columns at
any time.
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Figure 10.64 Use the Row Properties or Column
Properties dialog boxes to set a precise pixel size.

Figure 10.65 The size label changes to reflect your
pixel entry.

Figure 10.66 Choose Make Row (or Column)
Autostretch to have the cell automatically
shrink or grow as its content changes.

Figure 10.67 With Autostretch applied,
the cell’s height shrinks to fit the content.

Figure 10.68 Once you finish sizing the layout, you
can begin adding images, text, and headers.



To draw a layout table:

1. Click on the page where you want to add
the table, and then click the Draw Table
button in the Tables toolbar or Tables
task pane.

2. A pencil icon appears on the page. Click
and drag the pencil until the dashed 
box is roughly the size of the table you
want, and release the cursor button
(Figure 10.69).

A layout table appears on the page with 
a dimension label attached to each side.
(Figure 10.70).

202

Chapter 10
D

ra
w

in
g

 L
ay

o
u

t 
Ta

bl
es

Figure 10.69 Draw a layout table by activating the
Show Layout Tool button (left) and dragging the 
pencil icon across the page (right).

Figure 10.70 A layout table appears on the page with
a dimension label attached to each side.



3. To resize the table, deactivate the Show
Layout Tool button by clicking it so that
the labels disappear from the table. Click
and drag any corner to resize the table
(Figure 10.71).

The table assumes its new size (Figure
10.72). If you want to add cells to the lay-
out table, see “To draw layout cells” on
the next page. Otherwise, add content to
your table.

✔ Tip

■ In step 3 if you need more precision, enter
a new width or height in the text boxes in
the Layout Tables task pane and press
E (Figure 10.73). The table
changes size (Figure 10.74).
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Figure 10.71 Deactivate the Show Layout Tool button
(left), and then click and drag any corner to resize the
layout table (right).

Figure 10.72 Once you release the cursor, the layout
table assumes its new size.

Figure 10.74 Press E and the layout table
change to its new size.

Figure 10.73 If you need more precision in resizing the
layout table, use the width or height boxes in the
Layout Tables task pane.



To draw layout cells:

1. Click to select the table in which you
want to add a cell. Click the Show Layout
Tool button to display the table’s dimen-
sion labels, and then click the Draw
Layout Cell button (Figure 10.75).

2. Move the cursor into the table where it
becomes a pencil icon (Figure 10.76).

3. To draw a single cell, click and drag the
pencil until the dashed box is roughly 
the size you want, and release the cursor
button.

A cell appears in the table (Figure 10.77).

or

To draw multiple cells, one after the
other, press and hold down c while you
draw each cell. Release the cursor button
once you draw the last cell.

The multiple cells appear in the table
(Figure 10.78).

204

Chapter 10
D

ra
w

in
g

 L
ay

o
u

t 
Ce

ll
s

Figure 10.76 Move the
cursor into the table
where it becomes a
pencil icon.

Figure 10.77 To draw a 
single cell, click and drag
the pencil until the dashed
box is roughly the size you
want and release the cursor
button.

Figure 10.78 To draw
multiple cells, one after
the other, press and
hold down c while
you draw each cell.

Figure 10.75 To further divide the layout table into
columns and rows, activate the Show Layout Tool and
click the Draw Layout Cell button.



4. To resize a cell, right-click it and choose
Cell Properties from the drop-down
menu (Figure 10.79). Use the Cell
Properties dialog box to precisely resize
the cell plus change any other cell proper-
ties as desired (Figure 10.80). Click OK
to close the dialog box and apply the
changes.

or

Deactivate the Show Layout Tool button
by clicking it so that the labels disappear
from the table. Move your cursor over the
row or column containing the cell. When
the cursor becomes a two-headed arrow,
click and drag the row or column to
resize it (Figure 10.81). Release the cur-
sor to apply the change.

5. Add your content to the layout.
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Figure 10.79 To resize a cell, right-click
it and choose Cell Properties from the
drop-down menu.

Figure 10.80 Use the Cell Properties dialog box to pre-
cisely resize a cell.

Figure 10.81 You also can resize a cell by turning off
the Show Layout Tool button (left) and then clicking-
and-dragging the cursor to change the column width
or row height (right).
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Forms enable you to collect information from
your users by presenting them with ques-
tions, option buttons, check boxes, and mul-
tiple-choice menus (Figure 11.1). You begin
by creating a form. All the fields you need to
collect information are inserted inside that
form. The last step involves setting how the
form results are saved on the server hosting
your Web site. For creating forms, you’ll use
the Form Controls section within the Toolbox
task pane (Figure 11.2). Open it by choosing
Task Panes > Toolbox and then expanding
the Form Controls section.
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Figure 11.1 Forms enable you to collect a variety of
information from your users.

Figure 11.2 The Form Controls section of the Toolbox
task pane contains all you need for creating forms.



Creating Forms
Creating the form itself is always your first
step, since it acts as the “container” for 
holding all the fields into which users enter
information.

To create a form:

1. Open an existing Web page, or create a
new page, and make sure you’re in Design
view. Click in the page where you want
the form inserted, and double-click the
Form button in the Toolbox task pane
(Figure 11.3).

The form, bounded by a dashed outline, is
inserted into the page (Figure 11.4).

2. Since all your fields must go inside the
form, click-and-drag the boundary to give
yourself plenty of working room (Figure
11.5). You’re now ready to add whatever
form fields you need. For details, see
“Adding Form Fields” on the next page.
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Figure 11.4 The form, bounded by a dashed
outline, is inserted into the page.

Figure 11.5 To give yourself some working
space, click and drag any handle on the form’s
side or corner.

Figure 11.3 To create a form,
double-click the Form button in
the Toolbox task pane.

Missing but Not for Long

A popular feature in FrontPage, built-in form validation, is not available in Expression Web. If
your site host uses Microsoft’s Internet Information Services (IIS), you can use Expression
Web’s ASP.NET controls, which include validators. You’ll find them at the bottom of the
Toolbox task pane.

For those running other server software, there is hope. Add-ins (also called add-ons or exten-
sions) make it possible to add extra features to Expression Web. Now that Expression Web is
released, third-party developers are scrambling to create such add-ins, including form valida-
tors. To find what’s available, type “Expression Web add-in” into your favorite search engine.



Adding Form Fields
Expression Web includes more than a dozen
form fields to give you lots of flexibility in
gathering information from your site’s visi-
tors. Of all the form fields (sometimes called
form controls), the text box is probably the
one you’ll use the most. While only the 
most commonly used fields are explained
here, the process for adding the other but-
tons works similarly.

To add a text box:

1. Click in the form where you want to add
the field, typically next to text you’ve
entered to identify the field for users
(Figure 11.6).

2. Double-click the Input (Text) button in
the Toolbox task pane (Figure 11.7).

3. When the one-line field appears in the
page, right-click it and choose Form Field
Properties from the drop-down menu
(ae) (Figure 11.8).

4. In the Text Box Properties dialog box,
Expression Web assigns the field an arbi-
trary name, such as Text1 (top, Figure
11.9). You don’t need to change it, since
it’s invisible to site visitors and used by
form-handling scripts. If you do change 
it, make sure the new name has no 
spaces and uses standard ASCI charac-
ters (bottom, Figure 11.9).

(continued)
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Figure 11.6 Create some text to
identify the field for the user, and
then click where you want to add
the accompanying text box.

Figure 11.9 Use the Text Box Properties dialog
box to give your field a name, initial value, size,
and password.

Figure 11.7 Double-click the
Input (Text) button in the
Toolbox task pane.

Figure 11.8 When
the one-line field
appears in the
page, right-click it
and choose Form
Field Properties.



5. If you want text to appear inside the one-
line box, such as “Enter your name here,”
type it in the Initial value text box. (See
the first tip below.)

6. If you want, set how many characters
wide the line should be, and enter a num-
ber for the field’s tab order within the
form. (See the second tip.)

7. If the field will be used for a password,
choose Yes; otherwise, leave it set to the
default No.

8. When you’re done, click OK.

The properties are applied to the one-line
text field (Figure 11.10).

✔ Tips

◆ In step 5, if you enter an Initial Value, you
can skip also adding a text label next to
the field. It makes for a cleaner, more
compact form. It also sidesteps the whole
issue of using Expression Web’s awkward
Label form button (Figure 11.11). The
button is meant to help voice browsers
figure out when text is serving as a label
for an adjacent field, but the feature still
has some kinks to work out.

◆ If you need to resize a text box, don’t
bother using the Text Box Properties dia-
log box. Just click the box and use one of
corner or side handles to enlarge or
shrink it.
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Figure 11.11 The awk-
ward Label form button
still has some kinks to
work out.

Figure 11.10 When you’re
done, the properties are
applied to the one-line
text field.



Adding a Text Area
While a text box contains only a single line of
text, a text area can be as large as you need.

To add a text area:

1. Click in the form where you want to add
the text area.

2. Double-click the Text Area button in the
Toolbox task pane (Figure 11.12).

3. When the field appears in the page, resize
it as needed by click-and-dragging any
side or corner handle.

4. Right-click the field, and choose Form
Field Properties from the drop-down
menu (ae).

5. In the TextArea Box Properties dialog
box, Expression Web assigns the field an
arbitrary name. If you change it, make
sure the new name has no spaces and
uses standard ASCI characters so it can
be used in scripts.

6. If you want text to appear inside the box,
such as “Enter your name here,” type it in
the Initial value text box (Figure 11.13).

7. If you aren’t happy with your initial sizing,
set the character width and line number
using the text boxes. Enter a number for
the field’s tab order within the form.

8. When you’re done, click OK.

The properties are applied to the text
area (Figure 11.14).

✔ Tip

◆ A class-based style tag automatically is
applied to a text area when you resize it
(Figure 11.14). That makes it easy to
rename the style, attach it to an external
style sheet, and apply it to other text areas
for a more uniform look (Figure 11.15).
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Figure 11.13 If you want text to appear inside
the box, type it in the Initial value text box.

Figure 11.14 A class-based style tag automatically is
applied to a text area when you resize it.

Figure 11.15 By renaming the style, you can apply it to
other text areas for a more uniform look.

Figure 11.12 To add a text
area, double-click the
Text Area button in the
Toolbox task pane.



Adding Group Boxes
Group boxes offer a way to gather a bunch of
buttons and labels into a single tidy box. This
can be especially handy for multiple check
boxes and option buttons, since you can eas-
ily move them while preserving their relative
positions.

To add a group box:

1. Click in the form where you want to add
the group box.

2. Double-click the Group Box button in the
Toolbox task pane (Figure 11.16).

3. When the group box appears in the page,
resize it as needed by click-and-dragging
any side or corner handle.

4. Right-click the box, and choose Group
Box Properties from the drop-down
menu (Figure 11.17).

5. In the Group Box Properties dialog box,
the box is labeled Group box (top, 
Figure 11.18). Unlike the field box
names, this name will be seen by users
and isn’t used by scripts, so give it a name
that lets your visitors know its purpose.
Choose an alignment, and click OK (bot-
tom, Figure 11.18).

The properties are applied to the group
box (Figure 11.19).

212

Chapter 11
A

dd
in

g
 G

ro
u

p 
B

ox
es

Figure 11.17 Right-click the box, and
choose Group Box Properties from
the drop-down menu.

Figure 11.18 A group box’s label will be
visible, so give it a name that lets your
visitors know its purpose.

Figure 11.16 To add a group
box, double-click the Group
Box button in the Toolbox
task pane.

Figure 11.19 Now
labeled, the group
box is ready to help
organize your
other fields.



Adding Check Boxes and
Radio Buttons
Unlike text boxes in which users can enter a
variety of information, check boxes and
option buttons have only two states: on
(checked) or off (not checked). The main dif-
ference between check boxes and radio
(option) buttons is that users can choose sev-
eral check boxes, while radio buttons force
users to make one choice among several.

To add a check box:

1. Click in the form where you want to add
the check box.

2. Double-click the Input (Checkbox) button
in the Toolbox task pane (Figure 11.20).

3. When the check box appears in the 
page, right-click it and choose Form 
Field Properties from the drop-down
menu (ae).

4. In the Check Box Properties dialog box,
the field is assigned an arbitrary name,
such as Checkbox1 (top, Figure 11.21). If
you change it, make sure the new name
has no spaces and uses standard ASCI
characters so it can be used in scripts.

5. The content of the Value field, which is
not seen by the user, cannot be left blank.
Type any word that helps you quickly
identify the response field (bottom,
Figure 11.21).

(continued)
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Figure 11.21 The content of the Value field, which is
not seen by the user, cannot be left blank.

Figure 11.20 To add a check
box, double-click the Input
(Checkbox) button in the
Toolbox task pane.



6. By default, the check box’s Initial state 
is Not checked. Choose Checked if 
you’re sure most users will want the 
box already selected.

7. Enter a number for the field’s tab 
order within the form, and click OK.

The properties are applied to the 
check box.

8. Because the check box is quite small, be
sure to label it. If you need more check
boxes, repeat the steps.

9. Once you’re done, take a look at the
check boxes in a Web browser and decide
if any need adjustment (Figure 11.22).
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Figure 11.22 As seen
in a browser, the
group box helps
organize multiple
check boxes.



To add radio (option) buttons

1. Click in the form where you want to add
the option button, typically next to text
asking users to choose among several
option buttons.

2. Double-click the Input (Radio) button in
the Toolbox task pane (Figure 11.23).

3. When the radio button appears in the
page, right-click it and choose Form Field
Properties from the drop-down menu
(ae).

4. In the dialog box, the field is assigned an
arbitrary name, such as Radio1 (Figure
11.24). If you change it, make sure the
new name has no spaces and uses stan-
dard ASCI characters so it can be used 
in scripts.

5. The content of the Value field, which is
not seen by the user, cannot be left blank.
Type any word that helps you quickly
identify the response field .

6. By default, the button’s Initial state is Not
selected. Choose Selected if you’re sure
most users will want the button already
selected.

7. Enter a number for the field’s tab order
within the form, and click OK.

The properties are applied to the radio
button.

8. Because the radio button is so small, type
a label next to it. If you need more check
boxes, repeat the steps.

9. Once you’re done, take a look at the radio
buttons in a Web browser, and decide if
any need adjustment (Figure 11.25).
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Figure 11.24 In the Option Button Properties dialog
box, the field is assigned an arbitrary Group name.
Value cannot be left blank.

Figure 11.25 Once you’re done, take a look
at the radio buttons in a Web browser.

Figure 11.23 To add
radio buttons, double-
click the Input (Radio)
button in the Toolbox
task pane.



Adding Submit and Reset
Buttons
After filling in a form’s various fields, users
need a way to send that information to your
server. That’s the job of the submit button.
The reset button, its natural opposite, cancels
those field submissions so users can start
over. Both are examples of push buttons,
sometimes called command buttons, because
they exist strictly to trigger an action.

To add a submit button:

1. Click in the form where you want to add
the submit button, typically at the bot-
tom of the form so that visitors don’t
click it until after they’ve finished filling
in your form.

2. Double-click the Input (Submit) button
in the Toolbox task pane (Figure 11.26).

3. When the button appears in the page,
right-click it, and choose Form Field
Properties from the drop-down menu.

4. In the Push Button Properties dialog box,
the field is assigned an arbitrary name,
such as Submit1 (top, Figure 11.27). If
you change it, make sure the new name
has no spaces and uses standard ASCI
characters so it can be used in scripts.

5. Like the group box label, the push button
value/label will be seen by users, so give it
a name that clues visitors in about what
to do. (Submit, the default, might make
perfect sense to us computer types, but
regular folks may find Send clearer.) (bot-
tom, Figure 11.27).

6. Leave the button type set to Submit, add
a number for the field’s tab order in the
form, and click OK.

The button appears in the form 
(Figure 11.28).
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Figure 11.27 Submit, the default, makes sense to com-
puter types, but regular folks may find Send clearer.

Figure 11.26 To add a submit
button, double-click the Input
(Submit) button in the Toolbox
task pane.

Figure 11.28 The submit but-
ton typically appears at the
bottom of the form.



To add a reset button:

1. Click in the form where you want to add
the reset, usually right next to the submit
button at the bottom of the form.

2. Double-click the Input (Reset) button in
the Toolbox task pane (Figure 11.29).

3. When the button appears in the page,
right-click it, and choose Form Field
Properties from the drop-down menu.

4. In the Push Button Properties dialog box,
the field is assigned an arbitrary name,
such as Reset1 (Figure 11.30). If you
change it, make sure the new name has
no spaces and uses standard ASCI char-
acters so it can be used in scripts.

5. Just like the submit button, the value/label
will be seen by users, so give it a name
that clues visitors in about what to do.

6. Leave the button type set to Reset, add a
number for the field’s tab order in the
form, and click OK.

The button appears in the form. Take a
look in a Web browser, and see if anything
needs adjustment (Figure 11.31).
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Figure 11.30 Just like the submit button, the
Value/label will be visible, so give it a name that
tells visitors what to do.

Figure 11.31 Take a look in a Web browser, and see if
anything needs adjustment.

Figure 11.29 To add a reset
button, double-click the Input
(Reset) button in the Toolbox
task pane.



Saving Form Results
To save all the data submitted from your
forms, you need to choose which form han-
dler to use. If you’ve been running FrontPage
and your Web site host still uses the
FrontPage server extensions, you don’t have
to change a thing. They should continue 
saving results to your choice of a file, an
email, or a database. If you’re starting fresh
with Expression Web, however, or want to
use a nonproprietary setup, you can save the
results using a variety of widely available 
custom scripts (API, CGI, and ASP). If that’s
alphabet soup to you, contact your Web site’s
host to see what’s best for your needs.

To save results if not using FrontPage
extensions:

1. In Design view, right-click your form and
choose Form Properties from the drop-
down menu (Figure 11.32).

2. In the Form Properties dialog box, 
choose Send to other and use the default
Custom ISAPI, NSAPI, CGI, or ASP Script
(Figure 11.33).

3. Use the Form properties section if you
want to give the form another name 
or if you want to set a target frame for 
the form.

4. Click Options to reach the Options for
Custom Form Handler dialog box
(Figure 11.34).

5. In the Action text box, type the URL
where you’ve stored your script. Leave
Method set to post and the Encoding
type text box blank.

6. Click OK to close the Options dialog 
box. Click OK to close the Form
Properties dialog box as well.

The settings are applied to the form.
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Figure 11.33 If you’re not using FrontPage extensions,
choose Send to other and use the default Custom
ISAPI, NSAPI, CGI, or ASP Script.

Figure 11.34 Click Options to reach the Options for
Custom Form Handler dialog box.

Figure 11.32 To con-
trol how form results
are saved, right-click
the form and choose
Form Properties.



To save results if using FrontPage
extensions:

1. In Design view, right-click the form and
choose Form Properties from the drop-
down menu.

2. In the Form Properties dialog box
(Figure 11.35), choose:
▲ Send to, and then use Browse to 

select a destination file on your server
or enter an email address. If you like,
you can save the results as a file and
as email. (For details see “FrontPage
Extension Options” below.)

▲ Send to database. Click the Options
button to set up the details of the
database. (For details see “FrontPage
Extension Options” below.)

▲ Send to other, and use the drop-down
menu to select a form handler (Figure
11.36) (For details see “FrontPage
Extension Options” below.)

3. Use the Form properties section if you
want to rename the form or if you want
to set a target frame for the form.

4. Assuming you’ve already set your options,
click OK to close the dialog box.

The settings are applied to the form.

FrontPage Extension Options

The Options button in the Form Properties
dialog box triggers different choices based on
what you do step 2 of “To save results if using
FrontPage extensions” above.

Send to File name: In the dialog box that
appears, click the File Results tab (Figure
11.37). Pick a file format using the drop-
down menu (Figure 11.38). Check Include
field names if you want to pair the values of
each form field with its name. Unless you
choose HTML, Latest results at end is
checked. To create a second results file, 
perhaps in another format, use the Optional
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Figure 11.35 Use the Form Properties dialog box to
choose whether form results are saved as a file,
email, database record, or customized data.

Figure 11.36 If using FrontPage extensions, you can
use the drop-down menu to select a form handler.

Figure 11.37
The File
Results tab
lets you set
the file’s
name, format,
and other
details of sav-
ing the data.

Figure 11.38
The File 
format drop-
down menu
offers nine
choices for 
formatting the
results data.



second file section to enter a new name or
browse to an existing file. Click OK to return
to the Form Properties dialog box.

Send to E-mail address: In the dialog box
that appears, click the E-mail Results tab
(Figure 11.39). Use the E-mail format drop-
down menu to choose a text format. Check
Include field names if you want to pair the
values of each form field with its name. By
default, the email’s subject line would be
Form Results, though you can type another
choice. In the Reply-to line text box, enter an
address for the sender of the email. Click OK
to return to the Form Properties dialog box.

Send to database: In the dialog box that
appears, click the Database Results tab to
configure your database connection (Figure
11.40). Click OK to return to the Form
Properties dialog box.

Send to other: One of two dialog boxes
appears, depending on your choice in the
Send to other drop-down menu (Figure
11.41). Configure as needed, and when
you’re done, click OK to return to the Form
Properties dialog box.
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Figure 11.39
The E-mail
Results tab
lets you set
the message’s
address, for-
mat, subject
line, and reply
address.

Figure 11.40
The Database
Results tab lets
you port the
form results to
an existing or
new database.

Figure 11.41 The Discussion and Registration
form handlers can be precisely configured for
your needs.



Two crucial steps remain before you actually
copy your local files to a Web server. First,
use Expression Web to check if any pages
have problems, such as broken hyperlinks or
slow-to-download files. Second, look at 
every page with a Web browser to check its
general appearance. When you’re ready to
publish, you’ll need to have an Internet
Service Provider (ISP) lined up to host your
site, unless you are copying the files to an
inhouse intranet.
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Checking Your Site
Expression Web’s reporting tools make it
much easier and faster to get your site ready
to publish. Instead of depending on your
Web browser to find every problem,
Expression Web provides a site summary of
possible problems. The reports feature also
lets you mark any pages on the site that you
do not want published yet, avoiding the all-
too-common problem of accidentally pub-
lishing pages prematurely.

To check and fix your site:

1. Choose Site > Reports > Site Summary, 
or click the Web Site tab and use the
drop-down menu just below it to select
Site Summary (Figure 12.1).

When the Site Summary appears in the
main window, it lists general site infor-
mation and any problems (Figure 12.2).

2. If the summary lists problems, such as
broken hyperlinks, double-click that 
line in the report to see a list of the prob-
lem pages.

3. To fix an individual page in the list, 
double-click it and the appropriate
dialog box appears, allowing you to fix
the problem (Figure 12.3).

4. Repeat steps 2 and 3 until you’ve fixed all
the problems.
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Figure 12.2 The Site Summary report provides a
detailed overview of your site’s problems. Double-
click any line for details.

Figure 12.3 Double-click a listing in the Broken
Hyperlinks report (left), and the Edit Hyperlink dialog
box appears (right), enabling you to fix the link.

Figure 12.1 To check for problems, choose Site >
Reports > Site Summary (left) or, if the Reports view is
visible, click the drop-down menu below the Web Site
tab and choose Site Summary (right).



✔ Tips

■ You can switch to Reports view any time
by clicking the Reports button at the bot-
tom of the main window (Figure 12.2).

■ To return to the Site Summary after
you’ve double-clicked to select an individ-
ual problem report, click the Web Site tab
and use the drop-down menu just below
it to select Site Summary.

■ If you want to check for a particular prob-
lem, such as slow pages, choose Site >
Reports > Problems and make a choice in
the submenu (Figure 12.4).

■ By default, any files placed inside hidden
folders (those preceded by an underscore)
will not appear in the Site Summary or
problem reports. To have those files show
up in reports, choose Site > Site Setting,
click the Advanced tab, and check Show
hidden files and folders (Figure 12.5).
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Figure 12.4 To examine a particular problem, choose
Site > Reports > Problems and make a choice in the
submenu.

Figure 12.5 To see hidden folders,
check Show hidden files and fold-
ers under the Advanced tab.



Marking Pages to Publish
Running a quick check of the publishing 
status of your site’s pages gives you a chance
to mark pages that are not yet ready for pub-
lic viewing. It also enables you to switch
pages you previously marked Don’t publish
to Publish if you have finished working on
them. Running the review doesn’t do any-
thing to actually prepare the pages for publi-
cation. It’s just meant to help keep you from
accidentally publishing pages prematurely 
by highlighting which pages are set to be
published.

To check or change a page’s
publishing status:

1. Choose Site > Reports > Workflow >
Publish Status, or if the Reports view 
is already visible, click the drop-down 
menu below the Web site tab and choose
Workflow > Publish Status (Figure 12.6).

Expression Web’s main window switches
to the Reports view and shows the pub-
lishing status of all your site’s files
(Figure 12.7).

2. If you spot pages whose status you want
to switch, click in the page’s Publish col-
umn and use the drop-down menu to
change the status (Figure 12.8).
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Figure 12.6 In the Reports view, click the
drop-down menu below the Web Site tab
and choose Workflow > Publish Status.

Figure 12.7 The Publish Status report shows which
Web pages are and aren’t marked for publishing.

Figure 12.8 Use the Publish column’s
drop-down menu to change a page’s
status.



✔ Tip

■ To change more than one page at a time,
press c as you click pages in the Publish
Status list or Folder List and then right-
click the selected pages and choose
Properties from the drop-down menu
(Figure 12.9). When the page’s Properties
dialog box appears, click the Workgroup
tab and, at the bottom, check (or uncheck)
Exclude this file when publishing the rest
of the Web (Figure 12.10). Click OK, and
the status changes are applied.
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Figure 12.9 To change the publishing status of
several pages, right-click them in the Publish Status
list or Folder List and choose Properties from the
drop-down menu.

Figure 12.10 Check (or uncheck) the
Exclude box to change the publishing
status of the selected pages.



Publishing to the Web
After you’ve fixed your Web pages and
marked which ones should be published, you
should preview them in several Web
browsers. Once you’ve fixed any problems
found in the browsers, you’re finally ready to
copy your Web site files from your local hard
drive to the Web server you’ll be using.
Before you start, you’ll need to know the
server address that you’ll be copying your
files to, plus a user name and password to
gain access to the server. Check with the Web
server’s administrator if you need help.

By the way, the publishing process includes
an option to create a backup of your local
site. In fact, making a backup site should be
the first thing you do before actually publish-
ing to the remote Web server. The steps are
nearly the same, so consider it a practice run.
Given how easy it can be to accidentally
overwrite your local Web site files with the
remote Web site’s files, making a backup site
first is always a smart move.

To set the publish destination and
options:

1. Open the Web site you want to publish,
and choose Site > Remote Web Site, 
or click the Remote Web Site button 
at the bottom of the main window
(Figure 12.11).

2. Within the Web Site window, click the
Remote Web Site Properties button
(Figure 12.12).
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Figure 12.11 To start the publishing process, choose
Site > Remote Web Site (left) or click the Remote Web
Site button at the bottom of the main window (right).

Figure 12.12 To add or change a publishing destina-
tion, click the Remote Web Site Properties button.



3. In the Remote Web Site Properties 
dialog box (Figure 12.13), do one of the
following:

▲ Choose FrontPage Server Extensions
if your remote Web server includes
the extensions. If you’re converting an
existing FrontPage site to Expression
Web, this will be your first choice.

▲ Choose WebDAV if your remote Web
server uses this common file checkout
system.

▲ Choose FTP if you are running a plain
vanilla Web server and want to move
files to it using the long-standing File
Transfer Protocol. This is the choice
Expression Web selects by default
since it’s likely to be the main choice
for everyone except those sticking
with FrontPage extensions.

▲ Choose File System if you want to
make a backup copy of your local Web
site before actually publishing it. The
backup copy can reside on your own
computer or another computer any-
where on the Internet.

4. Once you make your choice, type a URL
or local file path in the Remote Web site
location text window or click Browse to
navigate to a folder on the Web or an
internal server. Unless you want to
change the default settings in the other
two tabs, Optimize HTML or Publishing,
skip to step 7.

5. Click the dialog box’s Optimize HTML
tab, and if you like, select the first check-
box, When publishing, optimize HTML
by removing the following elements
(Figure 12.14). Then select any of the
other checkboxes to remove various cod-
ing items from your Web pages before
they are published. (See the tip.)

(continued)
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Figure 12.13 In the Remote Web Site Properties dialog
box, choose the server type that matches your Web
server setup.

Figure 12.14 Use the Optimize HTML tab to remove 
various coding items from your Web pages before 
they are published.



6. Click the dialog box’s Publishing tab, and
if you like, change the defaults for
whether all or just changed local pages
are published to the remote site (Figure
12.15). Use the Changes section to set
how Expression Web determines which
pages have changed

7. Once you’ve made your choices, click OK
to close the dialog box.

The Remote Web Site view reappears
with the files for the local Web site on the
left and the empty remote Web site on
the right (Figure 12.16). To publish the
site, see the next page.

✔ Tip

■ In step 5, you have the choice of optimiz-
ing the coding in your Web site by remov-
ing unnecessary HTML to help the pages
download more quickly (Figure 12.14).
Examples would be any white space
you’ve left in to make the code easier to
read or explanation comments you’ve
added for yourself or others creating the
site. Expression Web can strip out this
code for the remote site while preserving
it in your local site.
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Figure 12.15 Use the Publishing tab to choose whether
all or just changed local pages are published to the
remote site.

Figure 12.16 Before publishing, the Remote Web Site
view lists the local site files on the left and the empty
remote Web site on the right.



To publish your site:

1. At the bottom of the Web site window,
click the Remote Web Site button. In the
lower right of the main window, select
Local to remote and click Publish Web
site (Figure 12.17).

2. There is a brief pause as Expression 
Web compiles a list of the files that 
need to be uploaded to the Web server
(Figure 12.18).

3. When the Connect to dialog box appears,
type the user name and password that
your ISP or Web server administrator
assigned you (Figure 12.19).

4. After another pause (the time depends
on how many new pages you’re uploading
and your connection speed), Expression
Web begins copying your Web pages to
the Web server. Depending on your site
setup, a series of dialog boxes may appear.
Either click Ignore and Continue to
resume the publishing process or Cancel
to double-check your settings.

When the upload finishes and the Web
site window reappears, the files from 
the local site (on the left) have been
copied to the Web site (on the right)
(Figure 12.20).

5. Using the choices in the window’s lower
left, you can see a log of the files, see the
now-published site in your Web browser,
or see your remote site from within
Expression Web. Take a look at the site to
make sure everything looks right. If you
spot problems, fix the local version of the
page and upload it again. If everything
looks good, you’re done.

(continued)
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Figure 12.18 Expression Web com-
piles a list of the files that need to
be uploaded to the server.

Figure 12.20 After publishing, the Remote Web Site
view lets you compare what’s on the local and remote
Web sites.

Figure 12.19 When the Connect to dia-
log box appears, enter the user name
and password assigned to you by the
ISP or the server’s administrator.

Figure 12.17 To publish
your site, in the lower
right of the main window,
select Local to remote and
click Publish Web site.



✔ Tips

■ Depending on how your Internet con-
nection’s configured, you may need to
connect to your Web server before click-
ing the Publish Web site button in the
Remote Web Site view.

■ After the first time you publish your 
Web site, and assuming your remote Web
site settings remain the same, you can
save yourself some steps whenever you
need to update the Web server files. Just
choose File > Publish Site (Figure 12.21),
or click the Publish Web site button in
the Remote Web Site view. The site is
published without opening any dialog
boxes. If you need to change any publish-
ing settings, click the Remote Web Site
Properties button in the Remote Web 
Site view.

■ You can use the publishing process to
download files from the remote site 
to your local site (Figure 12.17). You 
also can select Synchronize, which puts
the most current version of each file on
both sites.

■ If you choose to overwrite pages already
on the Web site, Expression Web will
alerts you if that will change the site’s
navigation structure. You’ll have the
choice of leaving the structure as is,
replacing it with your changes, or merg-
ing both versions by using only the
newest pages.
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Figure 12.21 Once you pub-
lish a site, you can publish
further changes just by
choosing File > Publish Site.



* (asterisk), 20

A
absolute links, 104
absolute positioning, 146, 148, 150
actions

changing properties of, 168
choosing, 166
defined, 166
deleting, 168
setting details of, 167
viewing list of, 167

Active Server Pages, 198. See also ASP
Add Browser dialog box, 47
Add Choice dialog box, 175
add-ins, Expression Web, 208
Advanced tab, Page Properties dialog box, 45
aligning

images, 81–83
tables, 193
text, 59

alistapart.com, 153
Alternate text box, 78, 79
anchor links, 111. See also bookmarks
API scripts, 218
Apply Styles tab, 158
Apply Styles task pane, 7, 122, 150
ASP, 198, 218
aspect ratio, 94
ASP.NET, 36, 123, 150, 208
asterisk (*), 20
Attach Style Sheet button, 140
Attach Style Sheet dialog box, 140, 156

Authoring tab, Page Editor Options dialog 
box, 35, 167

Auto Thumbnail button/command, 95, 96
AutoFit to Contents button, 182
Autostretch commands, 201

B
background images, 44
backups, Web site, 226, 227
behaviors, 161–178

adding, 166–167
browser requirements, 173
changing, 168
examples of, 166
list of, 173
pros and cons of, 161
purpose of, 166
scripts for, 166

Behaviors task pane, 166
Bookmark dialog box, 111, 113
bookmarks

clearing, 113
creating, 111
linking to, 112

Border button, 85
borders

cell, 197
image, 84–85
table, 180, 193, 194

Borders and Shading dialog box, 84–85
box model, 145
Break button/command, 56
breaks, line/paragraph, 54, 56
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class-based styles
applying to text areas, 211
attaching to tables, 193, 195
creating, 131–132
naming/renaming, 131, 132–133, 195, 211
vs. other types, 121

clear tag, 148
clearing properties, 148, 149
Clipboard, storing text on, 52
Close Site command, 29
code

finding and replacing, 69–72
hacks, 153
optimizing, 227, 228

code font, xiii
Code view, 4, 5
Column Properties dialog box, 201
columnar tables, 179. See also tables
columns

evening up, 192
labeling, 197
resizing, 201
selecting, 185

command buttons, 216
commands, menu-based, xiii
Common toolbar

alignment buttons, 59
Border button, 85
Bullets button, 64
New button, 35
Numbering button, 63, 66
Preview button, 46
purpose of, 12
Save button, 38
Style menu, 65

companion Web site, xiv, 26, 166
CompuServe, 98
Confirm Delete dialog box, 31
Connect to dialog box, 229
containers, 50, 148, 157–160, 208
contextual selectors, 154–155
Copy command, 52, 165
Create New Document button, 105
Crop button, 92
cropping images, 92
CSS, 121–160

benefits of, 121
changing preferences for, 123
clearing properties, 149

broken links, 29, 117–120, 221, 222
Browse the Web button, 106
browsers. See Web browsers
bulleted lists, 63, 64, 68
Bullets and Numbering command, 68
Bullets button, 64, 66
Button Properties command, 164
buttons

alignment, 59, 81
command, 216
hotspot, 115–116
interactive. See interactive buttons
push, 216
radio, 213, 215
reset, 216, 217
submit, 216
using GIFs for, 98, 99

C
Call Script behavior, 173
Caption Properties dialog box, 183
captions, table, 183
Cascading Style Sheets. See CSS
cell padding, 180, 193
Cell Properties dialog box, 196, 197, 205
cell spacing, 193
cells

adding, 186
applying color to, 193
automatically fitting material in, 182
designating as header cells, 197
drawing layout, 204–205
formatting, 196–197
merging, 191
resizing, 200, 205
selecting, 184
setting border colors for, 197
splitting, 190
text wrapping in, 197

CGI scripts, 218
Change Column Width command, 201
Change Property behavior, 173
Change Property Restore behavior, 173
Change Row Height command, 201
character sets, 45
check boxes, 213–214
Check Browser behavior, 170, 173
Check Plug-in Behavior, 171, 173
child/parent relationships, 146
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Distribute Columns Evenly button/command,
192

Distribute Rows Evenly button/command, 192
div button, 159
div tags

browser considerations, 160
and contextual selectors, 154
defined, 145
inserting/pairing with ID styles, 159–160, 178
ordering of, 160
in prebuilt CSS layouts, 151–153
putting inside container div, 158

divs, 37. See also div tags
Documents folder, 16
Draw Layout Cell button, 204
Draw Table button, 202
Dreamweaver, x, 150
.dwt file, 19

E
E-mail Results tab, Saving Results dialog box, 220
Edit Browser List command, 47
Edit Hyperlink dialog box, 107, 108, 110, 120
Edit Word List button, 75
editing images, 88–92
Editing window

purpose of, 3
switching among open pages in, 5
switching views in, 5
tabs available in, 4

element-based styles, 121
elements, inline, 134
email links, 108
embedded styles, 132
Empty Web Site option, 16
encoding options, 45
events

defined, 166
replacing, 168
viewing list of, 167

Excel spreadsheets, 198–199
Exit command, 2
Expression Blend, xi
Expression Design, xi
Expression Media, xi
Expression Web

add-ins/extensions, 208
closing, 2
as collaborative tool, ix

coding hacks, 153
creating layouts with, 145–160. See also CSS

layouts
floating properties, 148
formatting tables with, 195
how it works, 124
meaning of acronym, 15
and older browsers, 153
and page margins, 45
and page properties, 43
positioning properties, 146–147
positioning tools, 150
setting up workspace for, 123
solving problems with, 143–144
tools for creating/managing, 122–123

CSS-based pages, 36–37
CSS-based templates, 17, 34
CSS layouts

creating from scratch, 156–160
creating ID styles for, 156–158
and div tags, 145
and ID-based styles, 145
naming, 153
using prebuilt, 151–153

CSS Layouts option, 36
CSS Properties tab, x, 146, 160, 195
CSS Properties task pane, 37, 122, 143, 144, 150
CSS Reports pane, 123, 143
csszengarden.com, 140
Custom Dictionaries dialog box, 75
Cut command, 52

D
dashed underline, 111
Database Results tab, Saving Results dialog 

box, 220
Decrease Indent Position button, 57
Default Document Type menu, 35
default.htm file, 17, 19, 39
Defined Term format, 65
definition lists, 65
Delete Cells button/command, 189
Design view, 4, 5, 46
destination document

matching style from, 54
pasting text into, 53

digital cameras, 79
Discussion form handler, 220
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Find and Replace dialog box, 69–72
fixed positioning, 147
Float command, 9
Float drop-down menu, 193
float tag, 148, 193
floating properties, 148
fly out menus, 166
Folder List command, 7
Folder List task pane, 3, 7, 91
folders, hidden, 223
font sets, 125–126
fonts, for interactive buttons, 162, 163
Form button, 208
form controls, 209
Form Controls section, Toolbox task pane, 207
Form Field Properties command, 209
form fields, 209–210
form handlers, 218, 219, 220
Form Properties dialog box, 218–219
form validation, 208
formatting

cells, 196–197
lists, 68
table borders, 194
tables, 193–197, 199
text, 44, 49

Formatting tab, Page Properties dialog box, 44
Formatting toolbar

alignment buttons, 81
Bullets button, 64
and heading sizes, 62
horizontal line button, 61
and image wrapping style, 81
Justify button, 59
Numbering button, 63, 66
Outside Borders button, 61
Style menu, 62, 65

forms, 207–220
adding check boxes to, 213–214
adding fields to, 209–210
adding group boxes to, 212
adding radio buttons to, 215
adding reset buttons to, 217
adding submit buttons to, 216
adding text areas to, 211
creating, 207, 208
purpose of, 207
saving results from, 218–220
validating, 208

Expression Web (continued)
creating links in, 103. See also links
CSS tools, 121–123. See also CSS
default image format, 98
and FrontPage, xi, 26. See also FrontPage
main window, 3–5
opening, 2
purpose of, ix
reporting tools, 222
style sheet tools, x. See also style sheets
table tools, 179. See also tables
task panes. See task panes
templates. See templates
toolbars. See toolbars
updates/patches, xiv
and Web-based standards, ix
Web site, xiv
working with images in, 77–101. See also

images
working with links in, 103–120. See also links
working with text in, 49–76. See also text

extensions
Expression Web, 208
FrontPage, 218, 219–220

external links, 106, 109, 118, 120
external style sheets, 138–142

and contextual selectors, 154–155
creating, 138
detaching from page(s), 142
vs. internal style sheets, 138
moving internal styles to, 141
naming, 139

Extra Large Icons view, 79

F
fields, form, 209–210
file formats, image, 98
File Results tab, Saving Results dialog box, 219
File System option, Remote Web Site Properties

dialog box, 227
File Transfer Protocol, 227
File Type Settings button, 98
files

avoiding accidental overwriting of, 226
displaying list of, 3
jumping among, 4
synchronizing, 230
uploading to server, 229–230
viewing hidden, 223
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hyperlinks. See also links
checking/fixing, 118–120
converting selected text to, 104
navigating to, 104
purpose of, 103
styling, 129–130
viewing diagram of, 32, 117

Hyperlinks button, 32
Hyperlinks pane, 119, 120
Hyperlinks view, 117

I
Icons Only view, 11
ID-based styles

creating, for CSS layouts, 156–158
inserting/pairing div tags with, 159–160, 178
vs. other types, 121
ways of using, 145

IE. See Internet Explorer
IIS, 198, 208
illustrations, 98. See also images
image formats, 98–101
image hotspots, 114–116
image links, 114–116
images, 77–101

adding borders to, 84–85
adding descriptions to, 78
adding padding to, 87, 145
adding to tables, 182
adding to Web pages, 78–79
addings margins to, 86
aligning, 81–83
background, 44
changing default format for, 99
changing format for, 100
creating thumbnails of, 95–97
cropping, 92
editing, 88–92
file-format considerations, 98
managing, 79, 91
moving, 80
naming/renaming, 90, 91
resampling, 93–94
resizing, 79, 91, 93–97
saving changes to, 90–91
setting transparency for, 101

images folder, 79
Import Web Site Wizard, 27–28

four-headed arrow, 86
FPSE, 26, 218, 219–220, 227
frame-based Web sites, 150
frames, 109, 150
FrontPage

built-in form validation, 208
layout tables, 150
maintaining frame-based sites created in, 150
migration issues, xi, 26, 44, 150
opening sites created in, xi
proprietary coding, 26
server extensions, 26, 218, 219–220, 227

FTP, 227

G
General tab, Page Properties dialog box, 44
GIFs, 98, 99, 150
Go To URL behavior, 169, 173
Graphics Interchange Format, 98. See also GIFs
graphics programs, 88
grid spacing, 150
Group Box button, 212
Group Box Properties dialog box, 212
group boxes, 212

H
h1-h6 headings, 62
header cells, 197
heading-based styles, 127–128
headings, 62
hidden files/folders, 223
horizontal alignment, 81
Horizontal Line Properties dialog box, 61
horizontal lines, 61
hotspots, 114–116
.htm files, 40
HTML

encoding, 45
files, 198
heading sizes, 62
optimizing, 227, 228
removing unnecessary, 228
special characters, 60–61
tags, 50, 71–72

HTML option, 34, 35
HTML Rules button, 72
http protocol, 104
Hyperlink Properties command, 107
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invisible elements, 14
ISP, 221, 229
iView MediaPro, xi

J
Joint Photographic Experts Group, 98
JPEGs, 98, 99, 100, 101
.jpg files, 90
Jump Menu behavior, 173, 175–178
Jump Menu dialog box, 175
Jump Menu Go behavior, 173
jump menus, 175–178
Justify button, 59

K
Keep HTML Only option, 54
Keep Source Formatting option, 54
Keep Text Only option, 54
keyboard shortcuts, xiii

L
Label form button, 210
Language tab, Page Properties dialog box, 45
Large Icons view, 79
launching program, 2
Layers tab, 150
layout tables, 200–205

adding cells to, 204–205
adding content to, 203, 205
adding prebuilt, 200–201
drawing, 202–203
pros and cons of, 150, 179, 200
resizing, 201, 203

Layout Tables task pane, 200–205
adding prebuilt layouts with, 200–201
drawing layout cells with, 204–205
drawing layout tables with, 202–203
purpose of, 200
resizing tables with, 203
Show Layout Tool button, 201

layout tools, 150
layouts

creating CSS, 156–160
prebuilt CSS, 151–153
yesterday's tools for, 150

line breaks, 54, 56
lines, horizontal, 61
linked style sheets, 140

importing Web sites, 26–28
Increase Indent Position button, 57
indenting

first line of text, 58
paragraphs, 57

inherit clearing property, 149
inherit floating property, 148
inherit positioning property, 147
inline elements, 134
inline styles, 134
Input (Checkbox) button, 213
Input (Radio) button, 215
Input (Reset) button, 217
Input (Submit) button, 216
Input (Text) button, 209
Insert Hyperlink dialog box, 104, 108, 112,

114–115
Insert Picture From File button, 79, 182
Insert Rows or Columns dialog box, 187
Insert Table button/command, 180, 181
Insert Table dialog box, 180
insertion spot, 50
interactive behaviors, 161–178

adding, 166–167
browser requirements, 173
changing, 168
examples of, 166
list of, 173
pros and cons of, 161
purpose of, 166
scripts for, 166

interactive buttons, 162–165
adding, 162–163
choosing font for, 162, 163, 164
choosing style for, 162, 164
choosing text color for, 163
copying and pasting, 165
creating destination page for, 163
duplicating, 165
editing, 164
resizing, 163, 164
saving, 163
testing, 163

Interactive Buttons dialog box, 162, 164
internal links, 120
internal style sheets, 132
Internet Explorer, 46, 110
Internet Service Provider, 221. See also ISP
intranets, 221
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Merge Cells button/command, 191
Microsoft

Expression Blend, xi
Expression Design, xi
Expression Media, xi
Expression Web. See Expression Web
FrontPage. See FrontPage
Internet Explorer, 46, 110
Internet Information Services, 198, 208
.NET Framework 3.0, xi
new Web tools, xi
Web site, xiv
Windows. See Windows

misspelled words, 73–75
Modify Page Sizes command, 6
Modify Page Sizes dialog box, 6
Modify Style dialog box

changing table's style with, 195
converting styles with, 136
creating paragraph styles with, 154
customizing divisions with, 152, 153
and float/clear tags, 148
and ID-based styles, 152, 178
renaming class-based styles with, 133

N
naming/renaming

class-based styles, 131, 132–133, 195, 211
CSS layouts, 153
external style sheets, 139
form fields, 209
group boxes, 212
images, 90, 91
reset buttons, 217
style sheets, 139
styles, 132
submit buttons, 216
Web pages, 37, 38, 40
Web sites, 16–17, 31

navigation bars, 165
navigation menus, rollover-triggered, 150
nested lists, 67, 68
.NET Framework 3.0, xi
New button, 35
New dialog box, 16, 34
New Style Copy command, 135
New Style dialog box, 84, 157
New Web Site Location dialog box, 16

links, 103–120
absolute vs. relative, 104
adding ScreenTips to, 110
avoiding broken, 29
to bookmarks/anchors, 112
changing, 107
creating, 104–106, 108, 114–116
displaying diagram of, 32, 117
email, 108
to external Web pages, 106
identifying/fixing broken, 117–120, 221, 222
image, 114–116
opening in new window, 109
to page in Web site, 104–105
removing, 107
styling, 129–130
targeting, 109
testing, 117–119
types of, 103

List Properties dialog box, 68
lists, 63–68

adding items to, 66
bulleted, 63, 64, 68
creating, 63–65, 67
ending, 66
nesting, 67
numbered, 63
reformatting, 68
removing formatting from, 66
types of, 63

M
mailto:, 108
main window, 3–5
Maintain Proportions box, 164
Make Column Autostretch command, 201
Make Row Autostretch command, 201
Manage Styles tab, 156, 160, 195
Manage Styles task pane, 122, 150
margins, 45, 86
master.dwt file, 19
Match Destination Formatting option, 54
media plug-ins, checking for, 171
menu-based commands, xiii
menus

fly out, 166
jump, 175–178
rollover-triggered navigation, 150
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Pictures toolbar, 115–116
Auto Thumbnail button, 95
Crop button, 92
editing images with, 88–89
hotspot buttons, 115–116
options available on, 89
Resample button, 93, 94
Set Transparent Color button, 101
turning on, 79

Play Sound behavior, 173
plug-ins, checking for media, 171
PNG files, 98, 99
Popup Message behavior, 172, 173
Portable Network Graphics files. See PNG files
positioning properties, 146–147
Positioning toolbar, 160
positioning tools, 150
positioniseverything.net, 153
Preload Images behavior, 173
Preview in Browser command, 46–47
Preview in Multiple Browsers command, 47
Problems submenu, 223
Properties command, 41, 43
Properties dialog box, 41
Publish Site button/command, 230
Publish Status report, 224
Publish Web site button, 229
publishing, 221–230

changing settings for, 230
checking/changing publishing status, 224–225
checking/fixing site prior to, 221, 222–223
hosting options, 221
making backup site prior to, 226, 227
marking pages for, 224–225
setting destination/options for, 226–228

Publishing tab, Remote Web Site Properties
dialog box, 228

punctuation marks, 60
Push Button Properties dialog box, 217
push buttons, 216

Q
Quick Tag Selector, 150, 159, 185

R
radio buttons, 213, 215
Recent Sites command, 30
Redo command, 55
Registration form handler, 220

New Window option, 109
numbered lists, 63
Numbering button, 63, 66

O
One Page Web Site option, 16
Open Browser Window behavior, 173, 174
Open button, 30
Open Site command, 30
Open Site dialog box, 30
Optimize HTML tab, Remote Web Site

Properties dialog box, 227
Option Button Properties dialog box, 215
ordered lists, 63

P
padding

and box model, 145
cell, 180, 193
image, 84, 87, 145
viewing, 14

Page command, 5
page divisions, 145. See also div tags
Page Editor Options dialog box, 4, 35, 97, 167
page margins, 45
Page Properties dialog box, 43–45
Page Size command, 6
Page Size dialog box, 6
page titles, 38, 39, 41
page views, switching, 5
pages. See Web pages
panes. See task panes
paragraph breaks, 56
Paragraph dialog box, 58
paragraph tags, 50
paragraphs

indenting, 57–58
starting new, 56

parent/child relationships, 146
Paste command, 53
Paste Options menu, 54
Paste Text command, 53–54
patches, program, xiv
photos, 98. See also images
Picture Actions button, 93
Picture command, 22
Picture File Type dialog box, 99, 100
Picture menu, 78
Picture Properties dialog box, 81–82, 94, 100
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Set as Home Page command, 39
Set Hyperlink ScreenTip dialog box, 110
Set Page Title dialog box, 38
Set Text of Status Bar behavior, 173
Set Transparent Color button, 101
Show All button, 56
Show command, 14
Show Layout Tool button, 202, 203, 204, 205
Show Page Titles command, 117
site files. See Web site files
Site Settings command, 31
Site Settings dialog box, 31
Site Summary report, 222–223
sites. See Web sites
Slow Pages option, 223
source document, cutting/copying text from, 53
special characters, 60
spell-check feature, 73–75
Spelling button/command, 73
Spelling Options dialog box, 75
Split Cells button/command, 190
Split Cells dialog box, 190
Split view, 4, 5, 69
spreadsheets, 198–199
Standard button, 4
Standard toolbar

File button, 79
Hyperlink button, 104
Show All button, 56
Spelling button, 73, 74
Undo/Redo menus, 55

standards, Web, ix
Start menu, 2
static positioning, 147
Status bar, 4
status bar messages, 172, 173
Style Application, 4
Style Application toolbar, 123
style sheets, 138–142

attaching to pages, 140
cascading, 124. See also CSS
creating, 138
detaching from pages, 142
downloading, 140
internal vs. external, 132, 138
linked vs. imported, 140
naming, 139
saving, 139

Style Sheets Links button, 143

regular expressions, 72
relative links, 104
relative positioning, 147
Remote Web Site button/command, 226
Remote Web Site Properties button, 226
Remote Web Site Properties dialog box, 227–228
Remove Formatting option, 53, 54
Remove Link button, 107
Rename Class dialog box, 195
renaming. See naming/renaming
reporting tools, 222
Reports button, 32, 223
Reports tab, 41
Reports view, 222, 223, 224
Resample button, 93, 94
Resample Picture To Match Size option, 93
reset buttons, 216, 217
Reset Workspace Layout command, 10
Restore button, 89
Rich Text Format files, 198
rollover-triggered navigation menus, 150
Row Properties dialog box, 201
rows

evening up, 192
labeling, 197
resizing, 201
selecting, 185

RTF files, 198

S
Save As dialog box, 38
Save button, 38
Save command, 38
Save Embedded Files dialog box, 43, 78, 90, 

163, 164
Saving Results dialog box, 219–220
scanners, 79
ScreenTips, 110
scripts, behavior, 166
search engines, 44, 109
Select File dialog box, 198
selecting

table elements, 184–185
templates, 18
text, 51

selectors, contextual, 154–155
server administrators, 226, 229
server extensions, FrontPage, 26, 218, 

219–220, 227
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resizing, 181
selecting elements in, 184–185
selecting entire, 185
setting height/width of, 180, 201
splitting/merging cells in, 190–191
using default settings for, 181

Tables toolbar, 179, 197
tag-based styles

creating, 127–130
vs. other types, 121

Tag Properties pane, 7, 159–160
Target Frame dialog box, 109
targeting links, 109
task panes, 7–11

closing, 7
collapsing, 10
expanding, 10
grouping of, 7
location of, 4
opening, 7
rearranging, 9
restoring default positions of, 10
switching tabs within, 8

template-based sites, 18–25
adding pages to, 24–25
creating, 18–20
deleting pages from, 23
replacing content in, 21–22

templates
CSS-based, 17
customizing, 19–20
purpose of, 18
replacing content in, 21–22
selecting, 18

text
adding line beaks to, 56
adding to tables, 182
aligning, 59
centering, 59
checking spelling in, 73–75
copying or cutting, 52
creating headings in, 62
creating lists in, 63–68
entering, 50
finding and replacing, 69–72
formatting, 49
indenting, 57–58
inserting horizontal line in, 61
inserting special characters in, 60

Style toolbar, 123
styles, 127–137

class-based. See class-based styles
converting to different type, 136
copying and changing, 135
creating, 127–134
deleting, 137
deleting unused, 143
embedded, 132
font considerations, 125
heading-based, 127–128
ID-based, 145
inline, 134
for interactive buttons, 162
naming, 132
organizing, 122
removing, 137
tag-based. See tag-based styles
types of, 121

sublists, 67
submit buttons, 216
Swap Image behavior, 167, 173
Swap Image Restore behavior, 173
Swap Images dialog box, 167
Symbol dialog box, 60
Synchronize feature, 230

T
Table AutoFormat button, 194
Table Properties dialog box, 181, 193, 194, 199
tables, 179–205

adding borders to, 180, 193
adding captions to, 183
adding cells to, 186
adding Excel data to, 198–199
adding images to, 182
adding rows/columns to, 187–188
adding text to, 182
applying color to, 193
changing structure of, 186–189
for columnar data, 179
creating, 180–183
deleting parts of, 189
evening up rows/columns in, 192
floating, 193
formatting, 193–197, 199
labeling rows/columns in, 197
for layouts, 179. See also layout tables
purpose of, 180
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V
Verify Hyperlink button/command, 118, 119, 120
Verify Hyperlinks dialog box, 119, 120
vertical alignment, 82
vertical bar, 50
views

page, 5
Web site, 32

Vista. See Windows Vista
visual aids

purpose of, 4
showing/hiding, 14
turning on/off specific, 14, 36

Visual Aids command, 14, 36
visually impaired

and alternate text for images, 79
text-to-speech programs for, 49, 79

W
W3C, x
watermarks, 44
waywest.net, xiv, 26, 166
"Web 2.0" sites, ix
Web-based standards, ix
Web browsers

adding to browser list, 47
checking version of, 170
and CSS, 153
and div tags, 160
and image file formats, 98
and interactive behaviors, 173
opening new window for, 174
previewing Web pages in, 37, 46–47, 221, 226
and ScreenTips, 110
setting default, 46
viewing image thumbnails in, 96

Web images, 98. See also images
Web pages, 33–47. See also Web sites

adding bookmarks to, 111–113
adding images to, 78–79
adding interactivity to, 161–178. See also

interactive behaviors
adding line/paragraph breaks to, 56
adding links to, 104–108
aligning images in, 81–83
aligning text in, 59
attaching style sheets to, 140
changing standard width for, 4

justifying, 59
moving, 52
pasting, 53–54
searching, 69–72
selecting, 51
showing/hiding hidden marks in, 56
undoing changes to, 55

Text Area button, 211
text areas, 211
Text Box Properties dialog box, 209, 210
text boxes, 209–210
text-editing programs, 50
text-to-speech programs, 49, 79
TextArea Box Properties dialog box, 211
thesaurus, 76
thumbnail images, 95–97
titles, Web page, 38, 39, 41
toolbars, 12–13. See also specific toolbars

adding, 12
closing, 12
moving, 13
opening, 12
redocking, 13
resizing, 13

Toolbars command, 12
Toolbox task pane

ASP.NET controls, 208
default display of, 7
Form button, 208
Form Controls section, 207, 208
Group Box button, 212
Input (Checkbox) button, 213
Input (Radio) button, 215
Input (Reset) button, 217
Input (Submit) button, 216
Input (Text) button, 209
Text Area button, 211
viewing more of, 11

tooltips, 110
transparency, setting image, 101
transparent GIFs, 99, 101, 150
trigger events. See events

U
Undo command, 55
unordered lists, 63. See also bulleted lists
updates, program, xiv
uploading files, 229–230
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uploading to server, 229–230
viewing hidden, 223

Web Site tab, 17
Web site templates. See templates
Web sites, 15–32. See also Web pages

avoiding broken links in, 29
checking spelling in, 73–75
closing, 29
creating new, 16–17
deleting, 31
designating home page for, 39
finding/replacing HTML tags in, 71–72
frame-based, 150
importing, 26–28
linking to pages in, 104–106
making backups of, 226, 227
naming/renaming, 16–17, 31
opening, 30
optimizing coding in, 228
overwriting pages on, 230
publishing. See publishing
saving, 16
searching text/code in, 70
switching view of, 32
template-based, 18–25
testing/fixing links in, 117–120

Web Sites button, 30
Web standards, 49
Web text, 49. See also text
WebDAV, 227
white space, 54, 228
wild card searches, 72
Windows Vista, 1, 46, 199
Windows XP, 1, 46, 199
word processing, 49. See also text
Workgroup tab, Page Properties dialog box, 

45, 225
wrapping style, 81, 83
www.csszengarden.com, 140
www.microsoft.com, xiv
www.positioniseverything.net, 153
www.waywest.net, xiv, 26, 166

X
.xls format, 198
XP. See Windows XP

Web pages (continued)
changing titles for, 38, 41
checking/changing publishing status of,

224–225
checking spelling in, 73–75
creating, 34–37
creating headings for, 62
creating lists in, 63–68
cutting/copying text on, 52
deleting, 42
designating as home page, 39
detaching style sheets from, 142
displaying Excel spreadsheet data in, 198–199
entering text in, 50
finding/fixing problems in, 221, 222–223
finding/replacing HTML tags in, 71–72
indenting paragraphs in, 57–58
inserting forms in, 208. See also forms
inserting horizontal lines in, 61
inserting special characters in, 60
linking to, 104–106
marking for publishing, 224–225
moving images in, 80
moving text in, 52
naming/renaming, 37, 38, 40
opening, 40
overwriting, 230
pasting text in, 53–54
positioning items in, 150
previewing in Web browsers, 37, 46–47, 

221, 226
saving, 38–39
searching text/code in, 69–72
selecting text in, 51
separating content from presentation in, 49
setting dimensions of, 6
setting margins for, 45
setting properties for, 43–45
switching among open, 5
uploading to Web server, 229–230

Web servers, 226, 227, 229–230
Web site files

avoiding accidental overwriting of, 226
displaying list of, 3
including images among, 78
jumping among, 4
synchronizing, 230
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