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INTRODUCTION

Because I’ve been the product manager of Adobe Illustrator, people frequently 

approach me who, prior to attending a demo or workshop on Illustrator, 

either thought they had no need for the program or were under the impres-

sion it is used only for designing logos. 

The truth is, Illustrator is essential to a broad range of professionals and 

hobbyists, and it has an incredible number of uses—so many that it’s hard 

to defi ne exactly what Illustrator does. Features such as transparency, 3D, 

Live Trace, Live Paint, gradient mesh, live effects, professional typography, 

Flash animation, and now multiple artboards and the Blob Brush tool have 

all redefi ned how people use Illustrator every day. It’s certainly not the same 

program it was 10 years ago.

My goal with this book is threefold: to teach new users how to take advan-

tage of the technology, to help experienced users learn about features that 

have changed, and to give power users the understanding they need to push 

themselves and produce reliable fi les. I love showing people all the cool 

and productive things you can do with the product, and nothing makes me 

happier than seeing a designer crank out a totally awesome design using 

Illustrator. Throughout this book, I share my thoughts, experiences, and 

knowledge about Illustrator so that you can have fun with it, sharpen your 

skills, and make it work for you.

xv
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THE MANY USES OF ILLUSTRATOR
Look all around you.

Billboards along the side of the highway, packages of cereal and other gro-

ceries at the supermarket, navigation icons on a website, posters announcing 

an exhibit at a museum, advertisements throughout magazines and newspa-

pers, logos and artwork on T-shirts and sportswear, animated cartoons and 

feature fi lms, user interfaces on your computer and cell phones…all of these 

and more are created with the help of Illustrator.

Illustrator is used by creative individuals who want to express their creativ-

ity in print, on the web, in video, and on wireless devices. The program is 

distributed in many different languages, and you can fi nd millions of 

Illustrator users across the globe. Of course, with such a diverse user base, 

Illustrator is used and applied in many ways. To get an idea of what I mean, 

take a look at how some creative professionals use Illustrator and how this 

book can help them.

Creative Genius: 
The World of Graphic Design
It’s diffi cult to defi ne the job of a graphic designer because the title encom-

passes so many different types of design. For the most part, graphic design-

ers specialize in a particular fi eld of design such as corporate, advertising, 

direct mail, or even typography. Graphic designers work on a variety of 

projects and usually have experience with several programs including Adobe 

Photoshop and Adobe InDesign or QuarkXPress.

For these kinds of users, Illustrator serves as a creative springboard for 

designs such as logos and type treatments, ad storyboards and campaigns, 

spot illustrations, maps, and general design elements. 

If you’re a graphic designer, you’ll fi nd the following chapters most helpful 

as you read this book:

• Chapter 1, “Creating and Managing Documents” (page 1)

• Chapter 4, “Creative Drawing” (page 93)

• Chapter 6, “Coloring Artwork” (page 165)

• Chapter 7, “Working with Live Effects” (page 219)
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• Chapter 8, “Working with Typography” (page 249)

• Chapter 12, “Working with Images” (page 375)

Telling a Story: Illustration and Animation
To an illustrator or animator, Illustrator is an empty canvas waiting to come 

alive. In a world of animated feature fi lms and TV shows, it’s easy to under-

stand the benefi ts of drawing characters and animations directly on a com-

puter. Its ability to repurpose art for almost any need makes Illustrator the 

perfect environment for creating animations and illustrations.

Adobe didn’t name its product Illustrator without reason. Artists create 

illustrations for children’s books, magazine covers and articles, packages, and 

a variety of other products, and they use Illustrator to take advantage of the 

high quality and precision available in the program. A variety of tools, such 

as gradient meshes, blends, and even 3D, allow illustrators to translate the 

images they see in their minds into reality. 

If you’re an animator or an illustrator, you’ll fi nd the following chapters 

most helpful as you read this book:

• Chapter 2, “Selecting and Editing Artwork” (page 27)

• Chapter 3, “Technical Drawing” (page 67)

• Chapter 4, “Creative Drawing” (page 93)

• Chapter 6, “Coloring Artwork” (page 165)

• Chapter 11, “Exploring the World of 3D” (page 333)

• Chapter 12, “Working with Images” (page 375)

• Chapter 13, “Web and Mobile Design” (page 413)

Interactive Experience: 
Interface and Web Design
Web designers have a language all their own, which includes acronyms such 

as HTML, XML, FXG, SWF, GIF, JPEG, PNG, and CSS. Illustrator sup-

ports these and other web-specifi c technologies, giving web designers access 

to the formats in which they need to deliver their designs. Taking advantage 
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of Illustrator’s object-based design environment, web designers can lay out 

precise navigation elements, buttons, and entire pages.

In today’s fast-paced world, everyone needs a presence on the web. How-

ever, businesses fi nd that they also need to provide content in print format. 

By creating art in Illustrator, web designers can easily use that art for both 

web and print layouts, thus reducing the need to re-create art for each 

medium. 

If you’re a web or interface designer, you’ll fi nd the following chapters most 

helpful as you read this book:

• Chapter 2, “Selecting and Editing Artwork” (page 27)

• Chapter 5, “Organizing Your Drawing” (page 133)

• Chapter 7, “Working with Live Effects” (page 219)

• Chapter 9, “Drawing with Effi ciency” (page 283)

• Chapter 12, “Working with Images” (page 375)

• Chapter 13, “Web and Mobile Design” (page 413)

Tomorrow’s Trends: 
Fashion and Apparel Design
If you’re thinking about bathing suits while it’s snowing outside, either 

you’re dreaming about going on vacation or you’re a fashion designer. What 

type of clothes you design may directly correlate to the seasons of the year, 

but designing apparel is also a highly creative fi eld that demands the most of 

a designer. The object-based approach to design in Illustrator makes it easier 

to work with body shapes, apparel guidelines, and product labels.

Fashion designers can create symbol libraries of repeating objects such as 

motifs, buttons, buckles, and zippers. Illustrator can also create pattern fi lls 

and simulate shading and realism using transparency effects. 

If you’re a fashion designer, you’ll fi nd the following chapters most helpful 

as you read this book:

• Chapter 2, “Selecting and Editing Artwork” (page 27)

• Chapter 3, “Technical Drawing” (page 67)

• Chapter 4, “Creative Drawing” (page 93)
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• Chapter 6, “Coloring Artwork” (page 165)

• Chapter 9, “Drawing with Effi ciency” (page 283)

• Chapter 12, “Working with Images” (page 375)

Thinking Outside the Box: Package Design
If you’re good at reading upside-down text, you just might be a package 

designer. That’s because most package designs are created fl at on one sheet, 

with different panels facing different directions. Once printed, the entire 

package is folded up so it appears visually correct. Package designers use 

Illustrator to defi ne spot colors, place images from Photoshop, and apply 

trapping settings—all in an effort to grab a potential buyer’s attention.

Because of production requirements, package designers often need to be 

able to make minute adjustments to colors and artwork. By building fi les 

in Illustrator, these designers can control nearly every aspect of the fi le and 

meet their deadlines.

If you’re a package designer, you’ll fi nd the following chapters most helpful 

as you read this book:

• Chapter 1, “Creating and Managing Documents” (page 1)

• Chapter 2, “Selecting and Editing Artwork” (page 27)

• Chapter 6, “Coloring Artwork” (page 165)

• Chapter 8, “Working with Typography” (page 249)

• Chapter 9, “Drawing with Effi ciency” (page 283)

• Chapter 11, “Exploring the World of 3D” (page 333)

• Chapter 12, “Working with Images” (page 375)

• Chapter 15, “Prepress and Printing” (page 499)

The Science of Design: Art and Print 
Production
Production artists are a separate breed (I would know—I’m one of the 

them); to them, everything in a fi le matters. Illustrator allows production 

artists to dig deep into graphics fi les and make the edits and changes that 
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are necessary to print a fi le correctly. Whether for producing or using spot 

colors, using overprint commands, using transparency fl attening, or gener-

ally cleaning up paths and shapes, production artists have come to rely on 

Illustrator. Because they can use it to open and edit EPS and PDF fi les (and 

many other fi le formats), Illustrator has become a utility that is a required 

tool for art production.

If you cringe at the thought of an RGB fi le with overprints, transparencies, 

and spot colors, then you’re certainly a production artist. You might not care 

much about how to create nice brush strokes, but you care about simplify-

ing paths so that they print faster. 

If you’re a production artist, you’ll fi nd the following chapters most helpful 

as you read this book:

• Chapter 1, “Creating and Managing Documents” (page 1)

• Chapter 5, “Organizing Your Drawing” (page 133)

• Chapter 6, “Coloring Artwork” (page 165)

• Chapter 9, “Drawing with Effi ciency” (page 283)

• Chapter 12, “Working with Images” (page 375)

• Chapter 14, “Saving and Exporting Files” (page 453)

• Chapter 15, “Prepress and Printing” (page 499)

Frame by Frame: Motion Graphics
In an industry where the term indie doesn’t refer to InDesign, the art of 

producing movies and motion graphics lives by its own set of rules. And 

although that is certainly true, Illustrator still plays a huge part in generat-

ing graphics that can help jazz up a corporate promotional video or create an 

intricate opening or credits sequence for a big-budget fi lm.

Illustrator’s artwork may be vector, but that allows for more options when 

used in a pixel-based video workfl ow. Used in tandem with applications 

such as Adobe After Effects, Adobe Premiere Pro, Apple Final Cut Pro, 

or even Apple iMovie, Illustrator adds an entire dimension to the motion 

graphics workfl ow. 

If you’re into motion graphics or video production, you’ll fi nd the following 

chapters most helpful as you read this book:
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• Chapter 1, “Creating and Managing Documents” (page 1)

• Chapter 5, “Organizing Your Drawing” (page 133)

• Chapter 8, “Working with Typography” (page 249)

• Chapter 9, “Drawing with Effi ciency” (page 283)

• Chapter 12, “Working with Images” (page 375)

• Chapter 13, “Web and Mobile Design” (page 413)

The Melting Pot of Design: 
Creativity for Everyone
If you didn’t identify with any of the titles I’ve listed so far, that’s okay. In 

fact, it’s nearly impossible to list all the kinds of people who use Illustrator 

every day. Because Illustrator has so many uses, the people who use it are 

very diverse. They may include doctors, lawyers, architects, signage and 

environmental designers, video and fi lm specialists, or even a restaurant 

owner who is designing a menu cover.

Just realize that Illustrator is for everyone who wants to express their cre-

ativity, and that makes for one big happy family!

Where Did Illustrator Come From?

Our past is what helps defi ne our future. Whether you’re new to Illustrator or a veteran who has been using it for 
years, it helps to better understand the history behind a product that helped redefi ne the graphics industry. 

In the 1980s, during a time when the personal computer was beginning to take the world by storm, Apple 
Computer introduced the Macintosh with an “aff ordable” laser printer called the Apple LaserWriter. What made 
the LaserWriter so remarkable wasn’t so much the price (about $7,000 at that time) as the technology that 
was hidden inside it—Adobe PostScript, a computer language that enabled the LaserWriter to print beautiful 
graphics.

John Warnock, one of the founders of Adobe Systems, invented PostScript and was trying to fi nd a way to 
make more money selling it. Although PostScript was cool, graphics still had to be created by entering line 
after line of computer code. John needed a way to have people create PostScript fi les visually, and that’s how 
Illustrator was born. In early 1987, using the Bézier curve as the basis for vector graphics, Adobe introduced 
Illustrator 1.1 with much success. Now, over 20 years later, Illustrator continues to thrive and help those in the 
design community innovate.
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WHEN SHOULD YOU USE
ILLUSTRATOR?
Good designers have many tools at their disposal. Especially in an environ-

ment where most designers have other powerful graphics applications, it 

can be diffi cult to choose which one to use for a particular task. For exam-

ple, a designer can apply soft drop shadows in Photoshop, Illustrator, and 

 InDesign—is one application any better than the others for this? 

How do you know when to use Illustrator? To answer the question directly, 

“Use Illustrator when it’s the right tool for the job.” 

In reality, using the right tool for the job is what this book is all about. When 

you understand the strengths (and weaknesses) of each program, you also 

understand when it’s best to use (or not to use) a particular application. As 

would be expected, every design or production task you are called upon 

to do will require a different technique, method, or feature. When you are 

comfortable with Illustrator, you’ll easily be able to look at any project and 

know how to go about implementing it.

WHAT’S NEW IN ADOBE
ILLUSTRATOR CS4?
Every time Adobe ships a new version of Illustrator, users get that mixed 

emotion of yearning for new cool and timesaving features while simultane-

ously worrying about what Adobe has changed about their favorite graphics 

program. Illustrator CS4 certainly doesn’t disappoint in either department, 

especially considering how Adobe has given Illustrator (and all the Adobe 

Creative Suite components, for that matter) a much-needed face-lift in the 

form of a new user interface.

Overall, you’ll fi nd that Adobe has made many changes throughout, and 

therefore, I cover all the new CS4 features in the context of this book. That 

way, you can read the book, learn the techniques, and use the knowledge 

that you’ve learned to quickly master Illustrator CS4. However, if you’re 

looking for a head start on learning about the new big features in CS4, 

here’s a list that will serve that purpose well and that will point you to where 

you will fi nd more detailed information in the book:
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• Multiple artboards. The number-one feature request, multiple art-

boards, has fi nally arrived in lllustrator. Notice the phrase is multiple 

artboards, not multiple pages—there’s a difference. Read about the 

new multiple artboards feature in Chapter 1, “Creating and Managing 

Documents.”

• Blob Brush tool. Illustrator CS4 sports a new brush tool, named Blob 

Blush. Based on the Calligraphic brush tool, the Blob Brush tool is 

pressure-sensitive, allowing you to draw expressive artwork with vari-

able thick and thins. Read about the new Blob Brush tool in Chapter 4, 

“Creative Drawing.”

• Transparent gradients. Illustrator CS4 features the ability to specify 

opacity values within gradients. In addition, new widgets make it pos-

sible to apply and modify gradients in context, without the need for 

panels. Learn more in Chapter 6, “Coloring Artwork.”

• Better clipping masks. Illustrator CS4 makes it easier to work with 

clipping masks by making it impossible to select art outside the masked 

area. Learn how to work with masks in Chapter 9, “Drawing with 

Effi ciency.”

• Improved Appearance panel. The most important panel in Illustra-

tor just got a whole lot better. The Appearance panel now lets you apply 

appearances as well as edit them. Learn more about the Appearance 

panel in Chapter 5, “Organizing Your Drawing.”

• Improved graphic styles. Illustrator CS4 adds signifi cant functional-

ity to graphic styles and makes it possible to apply multiple styles to a 

single object. Learn to take advantage of graphic styles in Chapter 9, 

“Drawing with Effi ciency.”

• Improved smart guides. Illustrator CS4 features improved smart 

guides, which help you quickly align objects to each other. Smart guides 

can do even more, which you can fi nd out when you read Chapter 1, 

“Creating and Managing Documents.”

• Improved isolation mode. Since it was introduced in lllustrator CS2, 

the isolation mode feature has gotten better in each subsequent edition. 

Illustrator CS4 continues this trend with the ability to isolate individual 

paths. Learn more in Chapter 5, “Organizing Your Artwork.”

• Easier-to-use alignment tools. Illustrator CS4 makes it easier to 

specify how objects should be aligned. You can fi nd more details in 

Chapter 2, “Selecting and Editing Artwork.”



INTRODUCTION  xxiv

HOW THIS BOOK IS ORGANIZED
Unlike most other books on Illustrator, this text isn’t formatted to systemat-

ically cover each menu, tool, panel, and feature. Rather, it is organized based 

on my years of personal experience teaching Illustrator. In this way, you’ll 

understand the important aspects behind the features before you actually 

use them. The way I see it, it’s like taking a class on skydiving—you spend 

a few hours on the ground learning all about the physics of the jump, and 

then you get on the plane. Once you’ve already jumped, it’s a bit too late to 

start learning.

Sprinkled throughout the book are recurring elements that help you with 

your learning experience: 

Sidebars. Most chapters in this book contain sidebars that discuss concep-

tual or physical differences between Illustrator’s features and technologies. 

These are meant to give you a deeper understanding of the tools you have 

at hand, and they will assist you in choosing the right tools or functions for 

the right tasks. 

Keyboard shortcuts. When keyboard shortcuts are included for Illustrator 

commands, the Macintosh shortcut appears fi rst, followed by the Windows 

shortcut in parentheses. 

Appendixes. You’ll also fi nd an appendix toward the end of this book cov-

ering application preferences, which serves as a great reference in case you 

ever need to know what a particular preference setting is. Illustrator CS4 

also features an updated user interface, consistent with almost all the appli-

cations across Adobe Creative Suite 4. You’ll fi nd a second, useful appendix 

available on the book’s registration page at www.peachpit.com/rwillcs4, 

which discusses the new user interface in detail, allowing you to customize 

Illustrator CS4 to your exacting needs. Also on the book’s registration page 

you’ll fi nd a link to additional materials and updates.

See the Pretty Art!
Being this is a full-color edition, and even more so, being that the title of 

this book includes the words real world, it is a perfect opportunity to use 

actual, real-world art to help illustrate the features and functionality of 

TIPS Tips appear 
throughout the book 

as well and off er bite-sized 
nuggets of information and 
resources where appropriate.

NOTES Notes appear 
in the margin, provid-

ing additional information on 
the topic.

www.peachpit.com/rwillcs4
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Illustrator. Even though I dabble a bit here and there in the world of illustra-

tion, my background has always been fi rmly seated in art production, not 

creative illustration. So, I turned to the one creative source I’ve come to 

embrace as the ultimate design resource: iStockphoto. Yes, I know the word 

photo appears in the name, but iStockphoto (www.istockphoto.com) sells 

royalty-free stock art that includes photographs, illustrations, Flash anima-

tions, and even video content.

What’s great about iStockphoto is that it’s a collaborative resource—anyone 

around the world can create art and sell it on iStockphoto. And as such, I’ve 

come to discover some incredibly talented artists and illustrators from all 

over the world. I’ve had the pleasure of actually meeting some of these art-

ists, and iStockphoto also maintains some pretty sweet discussion forums 

on its website where many like-minded creative pros exchange ideas not just 

on technical issues such as how to best take advantage of the Gradient Mesh 

feature in Illustrator but also on how to drive creative inspiration.

Most of the chapters throughout this book feature art from various 

iStockphoto users, and if you like any of the artwork or the illustration style 

you see in the book, you can head over to www.istockphoto.com and pur-

chase it or even contact the artists directly. Here’s a listing of the chapters 

and the artists featured throughout the book (the artist’s iStockphoto 

member name appears in parentheses):

• Chapter 1, “Creating and Managing Documents”: Julie Felton (jfelton)

• Chapter 2, “Selecting and Editing Artwork”: Simon Oxley (simonox)

• Chapter 3, “Technical Drawing”: John Woodcock (johnwoodcock)

• Chapter 4, “Creative Drawing”: Cheryl Graham (freetransform)

• Chapter 5, “Organizing Your Drawing”: Diane Labombarbe (diane555)

• Chapter 6, “Coloring Artwork”: Kemie Guaida Ortega (kemie)

• Chapter 7, “Working with Live Effects”: Che McPherson (chemc)

• Chapter 9, “Drawing with Effi ciency”: Jennifer Borton (bortonia)

• Chapter 13, “Web and Mobile Design”: Fanelie Rosier (absolutely_frenchy)

• Chapter 15, “Prepress and Printing”: Sam Posnick (sposnick)

www.istockphoto.com
www.istockphoto.com
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ADDITIONAL RESOURCES
This book is jam-packed with information about using Illustrator, but 

there’s always more to learn (I still learn new things all the time). With that 

in mind, here’s a collection of additional resources you will fi nd helpful in 

your quest to master Illustrator:

• The Real World Illustrator blog. An up-to-date companion to this 

book, the Real World Illustrator blog offers insights, tutorials, and 

interesting information about the use of Illustrator and other Adobe 

applications. Readers of the blog (and book) are welcome to submit 

questions and participate via commenting on the blog or by emailing 

rwillustrator@gmail.com. You can fi nd the Real World Illustrator 

blog at http://rwillustrator.blogspot.com.

• Adobe Community Help. With the release of Adobe Creative Suite 4, 

Adobe has created a new type of help resource, dubbed Adobe Com-

munity Help. You can access this resource by entering a topic in the 

Search fi eld in the Illustrator CS4 Application bar (at the top right of 

the screen) or directly on the Web at http://community.adobe.com/help/

illustrator/. The Adobe Community Help search engine will return 

results on the requested topic from internal Adobe documentation as 

well as third-party information in the form of published articles, blogs, 

and tutorials. These resources are moderated (I happen to be a modera-

tor for the Illustrator content) and are constantly updated to offer the 

most useful and accurate information.

• Adobe Illustrator user-to-user forum. An extremely valuable 

resource, Adobe’s user-to-user forum is a great place to ask questions, 

get advice from other Illustrator users, and share your own knowledge. 

The forum has a search function that acts as a tremendous resource as 

well. You can fi nd the forums for Illustrator (and all other Adobe appli-

cations) at www.adobeforums.com.

• Lynda.com. Although reading the written word is a fantastic way 

to learn new material, seeing something in action can also serve as a 

wonderful way to learn new techniques. I currently have several video 

training titles on Adobe Illustrator at www.lynda.com that present yet 

another dimension in learning how to make the most of Illustrator.

www.adobeforums.com
www.lynda.com
http://rwillustrator.blogspot.com
http://community.adobe.com/help/illustrator/
http://community.adobe.com/help/illustrator/


Chapter 
OneCreating and Managing 

Documents

An artist can have a collection of the best 

paints and brushes, but those tools aren’t 

worth much unless the artist has a canvas 

to paint on. Likewise, all the powerful tools 

and functions in Adobe Illustrator CS4 are 

meaningless until you have a document 

open on your screen. In the traditional sense, you can choose different types 

of paper to paint or draw on, all of which affect the overall appearance of the 

fi nal result. With Illustrator, the settings you specify for your document also 

control your fi nal result.

With the multiple artboards feature in Illustrator, creating and managing 

documents takes on new meaning. No longer limited to a single “page” 

metaphor, Illustrator documents can now manage overall concepts or even 

entire campaigns. Even more so than in previous versions, you have to 

strategize in advance to plan the best way to set up your document—a little 

bit of planning or forethought before you get started can have a huge impact 

later in your workfl ow. So, before learning how to use all the powerful 

drawing features in Illustrator, you’ll learn everything you need to know 

about setting up and managing your documents.

The artwork featured throughout this chapter comes from Julie Felton 

(iStockPhoto; username: jfelton).

1
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EXPLORING THE WELCOME SCREEN
Upon launching Illustrator, you are greeted with the welcome screen 

(Figure 1.1) that offers several options. You can either choose to open fi les 

you’ve recently worked on or choose to quickly create new documents by 

clicking a variety of new document profi les that are already set up for 

certain workfl ows (you’ll learn more about document profi les in just a bit). 

At the bottom of the welcome screen, you’ll fi nd a collection of helpful 

links. The bottom-right corner of the welcome screen is dynamic, and if 

you’re connected to the web, the content will vary.

Selecting the “Don’t show again” check box in the lower-left corner keeps 

the welcome screen from popping up every time you open Illustrator. You 

can always access the welcome screen from the Help menu.

When it was fi rst introduced several versions ago, the welcome screen wasn’t 

too useful. However, with the ability to quickly access recently used docu-

ments and the capability to add your own custom new document profi les, 

the welcome screen actually serves as a wonderful time-saver to just about 

any workfl ow.

Figure 1.1 The Illustrator 
welcome screen gives you 
several useful options, 
including the ability to open 
recent documents and learn 
about new features.

NOTE You can also 
open templates 

from the welcome screen. 
Templates are covered in 
detail later in the chapter.
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CREATING NEW DOCUMENTS
You can create a new document by clicking any of the new document pro-

fi les that appear in the Create New section of the welcome screen. A new 

document profi le stores several important document attributes, artboards, size, 

orientation, measurement units, color mode, raster effects, and Preview 

mode, making it easy to get started working on a new document for a 

specifi c workfl ow with one click of the mouse. New document profi les can 

also contain content, such as swatches, brushes, symbols, and graphic styles.

In addition to basic CMYK and RGB profi les, Illustrator features four new 

document profi les:

• Print. The Print profi le is optimized for quickly creating artwork 

that will be used for print purposes. The Color Mode option is set 

to CMYK, and the Raster Effects option is set to 300 ppi.

• Web. The Web profi le, optimized for web graphics, has Color Mode 

set to RGB, Raster Effects set to 72 ppi, and Units set to pixels.

• Mobile and Devices. The Mobile and Devices profi le is optimized 

for developing content that will appear on cell phones and handheld 

devices. Color Mode is set to RGB, Raster Effects is set to 72 ppi, and 

Units is set to pixels.

• Video and Film. The Video and Film profi le, used for creating docu-

ments that will be used in video and fi lm applications, includes an addi-

tional option to set Illustrator’s transparency grid. This makes it easier 

to preview the alpha settings. This profi le sets Color Mode to RGB, 

Raster Effects to 72 ppi, and Units to pixels.

When you choose a new document profi le from the welcome screen, 

Illustrator presents you with the New Document dialog box (Figure 1.2 
on the next page). You can also bypass the welcome screen altogether and 

create a new document simply by choosing File > New or by pressing the 

keyboard shortcut Command-N (Ctrl-N). Clicking the Advanced arrow 

button reveals additional options that you can set as you create your new 

document. Although choosing a new document profi le will automatically 

adjust some of these settings as necessary, you can always change them to 

suit your particular needs.

TIP Hold the Option 
(Alt) key when choos-

ing a new document profi le 
to quickly create a new fi le, 
skipping the New Document 
dialog box altogether. Alter-
natively, press Command-
Option-N (Ctrl-Alt-N) to 
quickly create a new docu-
ment based on the same 
settings as the last document 
created.

The New Document dialog 
box is “sticky,” which means it 
remembers the last settings 
you used. So if you create 
an RGB fi le to create a web 
graphic, the next time you 
create a new document, the 
dialog box will be set to RGB.
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Although you can adjust any of the settings you fi nd in the New Document 

dialog box even after you’ve already created a document, it’s always better to 

get them right before you get started. Here’s an overview of what each set-

ting means:

• Name. The Name fi eld simply lets you name your fi le before you even 

create it. Note that this setting doesn’t save your fi le yet but merely saves 

you one step later.

• New Document Profi le. The New Document Profi le pop-up menu 

allows you to choose from a variety of preset profi les. Choosing a 

setting can serve as a starting point to adjust other settings in the New 

Document dialog box.

• Number of Artboards. The Number of Artboards setting allows you 

to specify how many artboards your document will contain. A single 

Illustrator document may contain up to 100 artboards. A row of icons 

that appears to the right of this setting also allows you to control how 

artboards appear within your document (you’ll learn more about art-

boards and their specifi c settings later in this chapter).

• Spacing. The Spacing setting is available only when you have chosen to 

create more than one artboard; it determines the amount of space that is 

added between each artboard on the overall canvas.

• Rows. The Rows setting allows you to specify the number of rows your 

artboards have. This setting is available only when specifying more than 

one document and using a setup option that uses rows.

Figure 1.2 Clicking the 
arrow button next to 
Advanced lets you set 
additional options in the 
New Document dialog box.
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• Size. The Size pop-up menu is populated with standard sizes that are 

appropriate for the chosen new document profi le.

• Width, Height, and Orientation. The Width and Height settings 

allow you to customize the size of the document’s artboard. You can 

also choose between portrait (tall) and landscape (wide) orientations.

• Units. The Units setting determines the default general measurement 

system used in the document. You can choose to use points, picas, 

inches, millimeters, centimeters, or pixels.

• Bleed. The Bleed setting allows you to specify an area to extend artwork 

beyond the artboard boundary where necessary. Bleed settings are applied 

universally to all artboards in a single document (two artboards within a 

single Illustrator document cannot have two different bleed settings).

• Color Mode. Illustrator supports two color modes: CMYK, which is 

used for artwork that will appear on the printed page, and RGB, which 

is used for artwork that is destined to be displayed on a TV or computer 

screen. Refer to the “CMYK or RGB?” sidebar in this chapter for impor-

tant information on the differences between these two color modes.

• Raster Effects. The Raster Effects setting controls the resolution used 

when applying special effects such as soft drop shadows, glows, and 

Photoshop fi lters (such as the Gaussian Blur fi lter). Although you can 

change this setting within your document at any time, it’s important 

to understand the consequences of doing so. For detailed information 

about the Raster Effects setting, refer to the “Massaging Pixels in 

Illustrator” section and the “Illustrator Effects and Photoshop Effects” 

sidebar, both in Chapter 7, “Working with Live Effects.”

• Transparency Grid. The Transparency Grid setting is available only 

when you choose the Video and Film new document profi le. The grid is 

a checkerboard pattern that appears on your artboard to help you better 

identify the Opacity values of objects in your document. This makes it 

easier to understand how artwork in Illustrator will composite with 

other art or video content later in your workfl ow. Refer to the section 

“Setting Up Your Document” later in this chapter for more information.

• Preview Mode. The Preview Mode setting lets you to specify the initial 

preview setting that Illustrator uses when the new document is created. 

You can leave it set to Default (which is Illustrator’s normal preview 

setting), Pixel (for better representation of web and video graphics), or 

Overprint (for better representation of print graphics and spot colors).
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The New Document dialog box also has a Templates button. Clicking this 

button will direct you to a folder containing all the prebuilt templates that 

come with Illustrator. For more information on templates, refer to the sec-

tion “Working with Templates” later in this chapter.

CMYK or RGB?

CMYK stands for cyan, magenta, yellow, and black (black is called K because 
some printers refer to the black plate as the key plate). Mixing these colors 
creates a gamut (range) of colors. It’s easier to think of colors in CMYK because 
the mode seems to follow the rules we all learned in preschool. Mixing cyan 
and magenta (blue and red) makes purple, mixing yellow and magenta makes 
orange, and so on. Today’s printing presses use the four CMYK inks to produce 
printed material in color. For jobs you want printed, you should choose the 
CMYK color mode.

RGB stands for red, green, and blue and is used to display color on TV screens, 
computer monitors, and other electronic devices such as digital cameras. 
Unlike CMYK where you start out with a white sheet of paper and then add 
colors to get to black, RGB works in reverse. For instance, when your TV screen 
is off , it’s dark, and when you turn it on and add red, green, and blue, the 
cumulative eff ect is white. The RGB color mode has a signifi cantly larger gamut 
of colors than CMYK does, especially in the area of bright fl uorescent colors. 
For jobs you want displayed on the web or in video, RGB is the color mode you 
should choose.

When creating a new document in Illustrator, you can choose between the two 
color modes in the New Document dialog box. Illustrator conveniently indi-
cates the document’s color mode in the Document title bar. Since version 9, the 
artboard in all Illustrator documents is restricted to the use of only one color 
mode (previous versions allowed both CMYK and RGB elements to appear on 
the same artboard). For example, if you copy and paste an object from an RGB 
document into a CMYK document, Illustrator will convert the object to CMYK 
as soon as you paste it onto the artboard. 

In contrast, panels in Illustrator (Swatches, Color, Symbols, Brushes, Styles, and 
so on) can contain both CMYK and RGB content. Content from a new docu-
ment profi le is copied into each new fi le you create, so if you create a new web 
document, your Swatches panel will be fi lled with RGB colors. Although you can 
switch color modes at any time by choosing File > Document Color Mode, it’s 
important to realize you’re changing the color mode only of the document art-
board—not the content that already exists in your Swatches or Symbols panel.
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CMYK or RGB? (continued)

In a real-world workfl ow, it’s possible that you may create an RGB document 
but convert the document to CMYK at a later point in time. If that happens, 
each time you apply a swatch color from your Swatch panel (which still con-
tains RGB colors), Illustrator will be converting that RGB swatch to CMYK. If 
you ever see CMYK percentages with odd decimal values instead of whole 
numbers (Figure 1.3), there’s a good chance that your document either is set 
to RGB or started out as RGB and was converted to CMYK. Remember that 
each time you make a color conversion, color shifts can occur.

Figure 1.3 Odd CMYK 
breakdowns are almost 
always the result of an 
RGB conversion.

When opening Macromedia FreeHand fi les or older Illustrator fi les, you might 
see a dialog box telling you the fi le contains mixed color modes (Figure 1.4), 
and you can choose what color mode to convert to when opening the fi le.

Figure 1.4 Illustrator 
alerts you when opening 
a fi le that contains mixed 
color modes and asks you 
to choose the color mode 
to which you want to 
convert the fi le.

Creating Your Own New Document Profi les
The six profi les in Illustrator are quite generic, so you may fi nd it useful to 

create your own new document profi les to suit your own needs. The good 

news is that it’s easy to do—just follow these steps:

1. Create a document using an existing new document profi le. If you want 

your profi le to include the Transparency Grid setting, make sure you 

start with the Video and Film profi le.
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2. Once the new fi le is open, adjust your document settings to match your 

desired profi le. For example, use the View menu to choose the Preview 

setting, choose Effect > Document Raster Effects Settings to adjust the 

Raster Effects value, and use the Artboard tool to adjust your artboard(s).

3. Add any desired content to the Swatches, Brushes, Symbols, or Graphic 

Styles panels. You can also remove content you don’t want or need from 

these panels.

4. Choose File > Save, choose Format > Adobe Illustrator Document, 

and save the fi le in the following location on your computer (for U.S. 

English versions of Illustrator):

Mac: Username/Library/Application Support/Adobe/Adobe Illustrator 

CS4/en_US/New Document Profi les

Windows: C:\Documents and Settings\Username\Application Data\

Adobe\Adobe Illustrator CS4 Settings\en_US\New Document Profi les

New document profi les work on all platforms and can be easily distributed 

among an entire design group or company.

Setting Up Your Document
There was a time when the Document Setup dialog box was accessed quite 

frequently, but since most of the page and printing settings have been 

moved to the Print dialog box or into the Artboard tool itself, you don’t 

have to go to Document Setup nearly as often. That being said, it’s still 

helpful to know what options you have when working with a document. 

The Document Setup dialog box (Figure 1.5), which you can access by 

choosing File > Document Setup or by clicking the Document Setup 

button that appears in the Control panel when there is no active selection, 

is split into three groups of settings.

Bleed and View Options. This pane allows you to change some of the set-

tings you saw in the New Document dialog box, such as measurement units 

and bleed. To make changes to individual artboards, you can click the Edit 

Artboards button, which closes the Document Setup dialog box and puts you 

into Artboard Edit mode (see the section “Using Multiple Artboards” later 

in this chapter). Additionally, there’s a setting for how raster-based images 

appear when you’re in Outline mode. By default, images appear only as 

NOTE In previous 
versions, changing 

settings for the artboard, such 
as portrait and landscape, 
were found in the Document 
Setup dialog box. Those set-
tings are now changed with 
the Artboard tool.
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Figure 1.5 The Document 
Setup dialog box was 
redesigned in Illustrator 
CS4 to display all the 
options at a glance.

empty boxes in Outline mode for performance reasons, but with the Show 

Images In Outline Mode option activated, raster images are visible (in black 

and white) in Outline mode.

You can choose to have Illustrator highlight substituted fonts or glyphs, 

which can be helpful when opening fi les that other designers created. With 

these options activated, Illustrator highlights missing fonts in pink and 

missing glyphs in yellow so that you can quickly fi nd where these problem 

areas are in a fi le.

Transparency. This pane allows you to specify settings for the transpar-

ency grid (which you can turn on by choosing View > Show Transparency 

Grid). Similar to the transparency grid found in Photoshop, this checker-

board pattern makes it easy to identify transparent areas in a fi le. If your fi le 

is going to be printed on colored paper, you can also have Illustrator simu-

late that color onscreen by using the Simulate Colored Paper option.

In Chapter 15, “Prepress and Printing,” you’ll learn more about transpar-

ency and how it prints. For now, it’s important to know that a process called 

transparency fl attening has to occur to correctly process artwork with transpar-

ency in it. This fl attening process has many different options, all controlled 

by choosing from several different presets. Specifying a preset in the Trans-

parency section sets a default preset for your document that you use when 
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copying art with transparency to the clipboard or when exporting fi les to 

formats that don’t support transparency.

Type Options. This pane contains several important settings for how text 

is used in Illustrator. You can specify the language for the fi le and how 

double and single quote marks should appear when you type them in your 

document. There’s also an option to use typographer quotes, which means 

the correct curly quotes are automatically used instead of straight marks. 

Illustrator also allows you to defi ne the size and position percentages for 

creating superscript, subscript, and small-cap characters. However, if you’re 

using OpenType fonts, you can take advantage of the built-in support for 

these specifi c features, which we’ll cover extensively in Chapter 8, “Working 

with Typography.”

The fi nal option in the Type Options pane is for specifying how text is 

exported when you are saving to legacy fi le formats (any version prior to 

Illustrator CS). When you choose the Preserve Text Editability option, text 

is broken up into individual type objects. When you choose the Preserve 

Text Appearance option, all type objects are converted to vector outlines.

USING MULTIPLE ARTBOARDS
It took 14 versions, but fi nally the number-one feature request of all time—

multiple pages—has arrived in Illustrator. Actually, Adobe refers to them 

as multiple artboards, not multiple pages, and for good reason. Unlike dedi-

cated page-layout applications such as Adobe InDesign or QuarkXPress, 

Illustrator isn’t meant to be used for long publications or documents. In 

fact, anything that suggests the word page is not part of the Illustrator lexi-

con at all. Later in this chapter, we’ll discuss when it’s best to use Illustrator 

or when it’s best to use a dedicated page-layout application.

Before we get into the details of how to use multiple artboards, it’s impor-

tant to get a grasp of the capabilities and limitations of multiple artboards 

within Illustrator:

• Every Illustrator document consists of an overall canvas, measuring 

227.54 inches square. Artboards can live anywhere within this 

canvas area.

• A single Illustrator document can contain anywhere from 1 to 100 

artboards.
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• Each individual artboard can be of any size (within the limits of the 

overall canvas) or orientation (portrait or landscape).

• Artboards can be moved and positioned anywhere within the canvas 

and can also overlap each other.

• You can choose to print and export any specifi c artboard or a range 

of artboards. You can also instruct Illustrator to “ignore artboards,” 

treating all artboards as a single cumulative large one.

• Illustrator does not feature master pages, although you could use 

symbols to manage repeating artwork across multiple artboards.

• Each Illustrator document supports a single color mode (RGB or 

CMYK). You cannot have some artboards that use CMYK and 

others that use RGB.

A single Illustrator document can contain up to 100 artboards, but only one 

artboard can be active at any one time. To make it easier to navigate within 

your documents, you’ll notice the overall canvas is shaded a very light 

gray and that each artboard features a white background and a small drop 

shadow. Artboards are outlined with a gray border, and the active artboard 

can be easily identifi ed with a black border (Figure 1.6).

Figure 1.6 The active 
artboard is identifi ed 
with a black border. 
Other artboards display 
a gray border.

Active ArtboardCanvas
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Although it’s important to understand that there’s a concept of an active art-

board, you don’t really have to do anything specifi cally to make an artboard 

active, simply because Illustrator handles that for you. Whenever you click 

within the boundary of an artboard (or for example, when you click to select 

an object that sits on an artboard), that artboard automatically becomes active.

Having a single active artboard is necessary in order for some core Illustrator 

functions to work as you might expect them to work. For example, when 

you choose Window > Fit Artboard in Window (or press Command-0 

[Ctrl-0]), Illustrator adjusts the zoom level so that the active artboard fi lls 

the screen. Likewise, when you choose File > Save for Web & Devices, just 

the artwork on the active artboard is exported.

Navigating Within a Document
In previous versions of Illustrator, you spent your time panning and zoom-

ing around a single page within a document. With Illustrator CS4, you now 

might fi nd yourself struggling to navigate across many artboards within a 

single document. Fortunately, you can quickly move from one artboard to 

another in two ways:

• At the bottom of the document window, just to the left of the status bar, 

is an Artboard Navigation pop-up menu, which lists the numbers for 

each artboard in the document (Figure 1.7). You can either choose to 

jump directly to an artboard or use the First, Previous, Next, and Last 

buttons to move between artboards. When using any of these methods, 

Illustrator automatically changes the zoom level to Fit Artboard in 

Window and makes the requested artboard active.

• Choose Window > Navigator to open the Navigator panel (Figure 1.8). 

In the Navigator panel, you can drag the red box around to quickly pan 

around the entire document. You can also adjust the zoom slider at the 

bottom of the panel to zoom in and out. The Navigator panel gives you 

a great bird’s-eye view of all the artboards on your canvas and even dis-

plays the active artboard with a black outline.

TIP You can 
choose View > 

Fit All in Window (or press 
Command-Option-0 
[Ctrl-Alt-0]) to adjust your 
view so that all artboards 
are visible.

Figure 1.7 The Artboard 
Navigation pop-up menu 
gives you quick access to 
any artboard in your fi le 
(if you know them by 
their numbers).
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Naturally, you can always use the Hand and Zoom tools to navigate within 

your document. You can also use custom views in Illustrator to save and 

return to specifi c zoom settings. The custom views feature is covered later 

in this chapter.

Modifying Artboards
Although you can specify the number of artboards at the time you create a 

new document, you can also modify the number, the position, and the size 

of artboards at any time with the use of the Artboard tool (Shift-O). When 

the Artboard tool is active, Illustrator switches into Artboard Edit mode.

By default, artboards are highlighted, the rest of the canvas is darkened in 

Artboard Edit mode, and the active artboard appears with a dashed outline. 

Each artboard is identifi ed with a number, found in the upper-left corner of 

the artboard (Figure 1.9). Numbers are automatically assigned to artboards 

in the order in which you create them, and you can’t renumber artboards 

after they’ve been created, other than the tedious method of deleting and 

re-creating them in the order that you need.

Figure 1.8 The Navigator 
panel provides a bird’s-eye 
view of the canvas and gives 
you the ability to quickly move 
from one spot to another.

Figure 1.9 You can add, 
remove, and modify art-
boards when you’re in 
Artboard Edit mode.
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When you’re in Artboard Edit mode, you can modify the active artboard 

by moving it or by resizing it using any of the handles that appear along its 

perimeter. Add new artboards by clicking and dragging any empty area on 

the artboard, or hold the Shift key while dragging to create a new artboard 

within the boundaries of an existing one. As with regular objects in Illustra-

tor, you can also hold the Option (Alt) key while dragging an existing art-

board to duplicate it. To delete an active artboard, simply press Delete 

on your keyboard.

In Artboard Edit mode, the Control panel offers a range of settings to help 

you modify the artboards on the canvas. One of the most important settings 

is the Move/Copy Artwork with Artboard option (Figure 1.10). With this 

setting turned on (which is the default), any artwork that appears within the 

bounds of an artboard will move along with the artboard. Likewise, if you 

duplicate an artboard, the new artboard will also contain a copy of the asso-

ciated artwork. Turning the Move/Copy Artwork with Artboard option off 

lets you reposition artboards on the canvas without moving any artwork.

Another important setting in the Control panel is the Artboard Options 

button, which opens the Artboard Options dialog box (Figure 1.11). The 

following settings are present in this dialog box:

• Preset. The Preset pane of the Artboard Options dialog box allows you 

to choose from a list of preset artboard sizes (unfortunately, the list isn’t 

customizable), including the ability to automatically generate an art-

board size to match the artwork bounds of all art within the document 

or the bounds of any currently selected art. In addition, you can adjust 

the width, height, or orientation of the active artboard.

• Position. The Position pane of the Artboard Options dialog box enables 

you to specify the x and y coordinates for the active artboard. The coor-

dinates represent the exact center of the artboard, not the upper-left 

corner, so it may be somewhat diffi cult to position artboards precisely 

in this manner without the help of a calculator and some elementary 

mathematics skills.

NOTE The artboard 
number is used when 

navigating within a docu-
ment, when printing, and 
also when placing native 
Illustrator content into other 
applications, including 
InDesign and Adobe Flash 
CS4 Professional.

Figure 1.10 When Move/
Copy Artwork with Artboard 
is on, any artwork that falls 
within the boundaries of an 
artboard will move when 
the artboard is moved while 
in Artboard Edit mode.

WARNING If artwork is 
locked or hidden, that 

artwork will not move with 
its artboard, even if you have 
the Move/Copy Artwork with 
Artboard option turned on.
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• Display. The Display pane of the Artboard Options dialog box enables 

you to hide or show an artboard’s center mark, crosshairs, and video 

safe areas. In addition, you can set a ruler pixel aspect ratio. These set-

tings are useful if you’re working in video workfl ows.

• Global. The Global pane of the Artboard Options dialog box enables 

you to choose whether the canvas turns a dark gray when you’re in 

Artboard Edit mode and whether artboards are highlighted in a lighter 

color while you’re dragging them around on the canvas.

Some of the options in the Artboard Options dialog box are also listed 

directly in the Control panel when Illustrator is in Artboard Edit mode. 

Keep in mind that the X and Y coordinates, as well as the Width and Height 

values, all reference the center of each artboard. Unfortunately, there is 

no nine-point proxy (like that found in the Transform panel, for example) 

that lets you use values from a specifi c corner or edge of the artboard. You 

can, however, use the arrow keys on your keyboard to nudge an artboard’s 

position.

To exit Artboard Edit mode, simply press the Escape key on the keyboard or 

select any tool other than the Artboard tool.

Figure 1.11 The Artboard 
Options dialog box provides 
additional settings for each 
artboard.

TIP If precise 
positioning of art-

boards is important, you 
may fi nd it easier to skip the 
Artboard tool altogether. 
Use the Transform panel to 
accurately position regular 
rectangles, select the shapes, 
and choose Object > Convert 
to Artboards.
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Adding Bleed

To print art all the way to the edge of a sheet, also known as bleeding, a printer 
uses a larger-sized sheet than the fi nish size (trim size), and after printing, the 
printer cuts the paper down to size. Printers can’t print all the way to the edge 
of a page because a certain amount of space is needed for gripper space (space 
for the printing press to grab the sheet of paper). Additionally, if this space 
weren’t there, the ink could run off  the sheet and onto the press, causing 
smudging on other sheets.

When a printer trims the paper to the fi nal size, the paper may shift while 
being cut, and if your image comes only up to the border of the trim size, you 
might end up seeing a bit of white near the edge of the paper. To avoid this, 
printers need bleed, or extra image space. If the artwork extends beyond the 
edges of the trim size, even if the cutter is off  a bit, you’ll still get color all the 
way to the edge of your sheet.

As a designer, it’s important to leave enough room when you’re cropping pho-
tos or backgrounds to allow for bleed (Figure 1.12). You should speak to your 
printer if you have questions, but most printers ask for anywhere from .125 to 
.25 inch of bleed. If printers don’t have enough image space to add bleed, they 
may need to trim the paper to a slightly smaller size.

The Bleed setting is a document-wide setting and is not artboard-specifi c. 
In other words, all artboards within a single fi le all share the same bleed 
setting—individual artboards cannot feature diff erent bleed settings. You can 
adjust a document’s bleed settings by choosing File > Document Setup or by 
using the New Document dialog box when creating a new fi le. Bleed settings 
are honored when printing from Illustrator or when saving and exporting most 
fi le types.

Figure 1.12 

When a bleed 
value is specifi ed, 
Illustrator identi-
fi es the bleed area 
with a red border.

Artboard Edge

Bleed Line
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Handling Artboards and Legacy Workfl ows
It’s true that Illustrator CS4 is the fi rst version to support multiple artboards. 

But in previous versions of Illustrator, designers employed a variety of work-

arounds to simulate multiple pages. For example, many designers used the 

Page Tiling feature in the Print dialog box to simulate multiple pages in 

Illustrator. Some also used FreeHand, which has had support for multiple 

pages for the longest time. Wouldn’t it be nice if Illustrator could open all 

of those FreeHand and Illustrator fi les (Adobe refers to older Illustrator fi les 

as legacy fi les) and convert them to multiple artboards? Great news—that’s 

exactly what Illustrator does.

If Illustrator senses any kind of multiple page–compatible setting when 

opening legacy Illustrator fi les, the Convert to Artboards dialog box 

appears (Figure 1.13), offering the following options:

• Legacy Artboard. The artboard from the legacy document is con-

verted to a single artboard.

• Crop Area(s). Any crop area defi ned in the fi le is converted to an art-

board. If the fi le is an Illustrator CS3 fi le and multiple crop areas are 

present in the fi le, each crop area is converted to an artboard.

• Artwork Bounding Box. The bounding box of the artwork in the fi le 

is converted to a single artboard.

• Page Tiles. If the document has page tiles defi ned, each page tile is 

converted to an artboard.

Illustrator disables those options that aren’t applicable to the fi le you are 

opening, so you may fi nd that not all four options are available for every fi le.

TIP Illustrator can 
open native FreeHand 

fi les directly, so you don’t 
need to export them as 
 Illustrator or EPS fi les from 
FreeHand.

Figure 1.13 The Convert to 
Artboards dialog box helps 
you migrate legacy fi les to 
the new multiple artboards 
workfl ow.
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Using Multiple Artboard Strategies
Just because an Illustrator document can contain up to 100 artboards doesn’t 

mean it should. Taking a few moments to think about your task or project 

before you start will always help you make the right choice about how to 

build your document in the most effi cient manner. Now that you have a 

strong understanding of the multiple artboards feature in Illustrator, you 

can make informed decisions about when it’s best to work on a project in 

Illustrator and when it might be better to look toward a dedicated page 

layout application, such as InDesign.

Overall, two main factors will come into play when you decide how to best 

choose how to build your documents. Illustrator supports artboards that 

can be of any size or orientation. If you’re working on a project that requires 

assets of multiple sizes, Illustrator might be the right choice. On the other 

hand, InDesign maintains a signifi cant edge in the form of performance and 

long-document features. Remember that it’s always benefi cial to think of 

ways to use all the tools at your disposal to get your work done—you don’t 

always have to force one application to do everything.

VIEWING DOCUMENTS
As you’re working in Illustrator, you can choose to view your artwork in 

different ways, each offering different benefi ts. The most common view 

mode, Preview mode, allows you to create and edit art while seeing a close 

representation of what your art will look like when printed. In Outline 

mode, Illustrator hides all the pretty colors and effects and shows you just 

the vector geometry of the shapes in your document. Although it may 

be diffi cult to visualize what your fi le is going to look like when actually 

printed, Outline mode gives you the ability to easily see whether shapes are 

aligned correctly, and it gives you a better idea of the structure of the fi le 

(Figure 1.14). Think of Outline mode as an X-ray fi lm that a doctor reads. 

Although just black and white, an X ray reveals what’s going on behind the 

scenes. Just like a doctor reads an X ray, an experienced Illustrator user can 

sometimes get a better idea of how an Illustrator fi le is constructed when 

in Outline mode. You can toggle between Preview and Outline modes by 

pressing Command-Y (Ctrl-Y).
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Using Overprint Preview
For those in the print business, Illustrator has a special preview mode called 

Overprint Preview that you can access by choosing View > Overprint 

Preview. Overprinting is a process you use when creating color separations 

to control how certain colors interact with each other (we’ll cover overprint-

ing in detail in Chapter 15, “Prepress and Printing”). Because overprinting 

is an attribute applied only in the print process, designers traditionally 

struggle with proofi ng fi les that specify overprints. Illustrator’s Overprint 

Preview mode simulates overprints so that you can see how they will print 

(Figure 1.15). In truth, Overprint Preview is far more accurate than the 

regular Preview mode in Illustrator, especially when your fi le uses spot col-

ors (you’ll learn more about that in Chapter 6, “Coloring Artwork”). While 

Overprint Preview gives you the best possible representation of what your 

fi nal art is going to look like when printed, it is slower in redraw perfor-

mance than normal Preview mode.

Figure 1.14 The same 
artwork viewed in Preview 
mode (left) and Outline 
mode (right).

Figure 1.15 On the left, 
the vector shape’s fi ll is set 
to Overprint, as shown in 
the Appearance panel. On 
the right, with Overprint 
Preview turned on, you 
can see the eff ects of the 
overprint.
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Using Pixel Preview
Not to leave web designers out in the cold, Illustrator has another preview 

mode called Pixel Preview, which you can also access via the View menu. 

Illustrator, as a vector-based application, produces resolution-independent 

art. Most of today’s printers have high-resolution settings, and modern 

imagesetters use resolutions upward of 2500 dots per inch (dpi). For that 

reason, print designers aren’t worried about how good their artwork looks 

on their screen, because they know when output at high resolution, every-

thing will be perfect. Web designers, however, care very much about how 

their artwork appears on a computer screen because that’s exactly how peo-

ple view their designs. Pixel Preview renders artwork to the screen as pixels 

and shows how antialiasing affects the art (Figure 1.16). We’ll cover Pixel 

Preview and these web-specifi c issues in Chapter 13, “Designing for Web 

and Mobile Design.”

Using Rulers and Guides
Even though you can scale Illustrator artwork to virtually any size, it’s still 

important to be able to create artwork using exact and precise measurements. 

Package designers and technical illustrators are always careful about creating 

artwork to scale, and even designers need to know what size a logo or an 

illustration has to be.

Figure 1.16 In Pixel Preview 
mode, Illustrator displays 
artwork as it would display 
in a browser. Zooming in 
on your artwork reveals the 
actual pixels and the eff ects 
of antialiasing.
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Choose View > Show Rulers to display vertical and horizontal rulers 

along the left and top edges of your document window. You can Control-

click (right-click) a ruler to change its measurement system (Figure 1.17). 

Although the rulers can help identify the coordinates of objects that appear 

in a document, rulers also serve another function. You can click a ruler and 

drag a guide onto your artboard. A guide is a line that’s visible on your screen 

but not on the printed or exported art. Guides have “magnetic personalities,” 

and objects that are moved or drawn near them stick to them, helping align 

objects and create consistent art and layouts. Hold the Option (Alt) key while 

dragging to toggle between horizontal and vertical guides, and hold the Shift 

key to have a guide snap to the tick marks that appear on the ruler.

You can lock and unlock guides by choosing View > Guides. Unlocked 

guides act just like regular objects do, and you can reposition them to your 

liking. You can even use the x and y coordinates in the Control panel to 

precisely position guides. In addition, you can convert any path into a guide 

by choosing View > Guides > Make Guides (or by pressing Command-5 

[Ctrl-5]).

Using Smart Guides
In addition to normal guides, Illustrator has a useful feature called smart 

guides; these guides, which are turned on by default, offer a variety of 

onscreen feedback options while you work. You can toggle smart guides 

on and off by choosing View > Smart Guides (or by pressing Command-U 

[Ctrl-U]). As you move your cursor around on the screen and as you create 

and modify artwork, different smart guides appear and assist you as 

you work.

Figure 1.17 The ruler’s 
context menu lets you 
specify any of the mea-
surement systems that 
Illustrator supports.

TIP By default, guides 
span the entire canvas. 

If you drag out a guide while 
in Artboard Edit mode and 
move your cursor within the 
bounds of the active art-
board, the guide will span 
just that artboard.
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Illustrator features six types of smart guides, and each offers assistance in a 

specifi c way (Figure 1.18). Admittedly, when all six smart guides are being 

used, the “information overload” may be distracting or too much to bear. 

Thankfully, Illustrator allows you to keep things in your control via a 

dedicated Preferences panel that you can fi nd by choosing Illustrator > 

Preferences > Smart Guides (Edit > Preferences > Smart Guides).

Smart guides work just about everywhere in Illustrator—even in Artboard 

Edit mode. As you get used to smart guides, you’ll get a better feel for which 

of the six types are more important for the kind of work you do most often. 

Remember that you can always quickly toggle the feature on and off as you 

need it. The six kinds of smart guides in Illustrator are as follows:

• Alignment guides. Alignment guides appear when you move your 

cursor, helping you align objects in context while drawing, moving, or 

editing objects. In this way, you don’t have to perform additional align 

functions.

• Object highlighting. Object highlighting identifi es the underlying 

Bézier paths or original text or artwork when you mouse over objects 

that have live effects or envelopes applied to them.

• Transform tools. Transform tools are guides that appear when using 

any of Illustrator’s transform functions, such as Rotate or Scale.

• Construction guides. Construction guides appear as you’re drawing 

new shapes and identifying similar planes or angles with other objects. 

You can specify which angles are identifi ed using the pop-up menu, or 

you can choose Custom Angles and specify up to six custom angles.

• Anchor/path labels. Anchor/path labels identify anchor points and 

paths as you mouse over them.

• Measurement labels. Measurement labels help you identify the dimen-

sions of objects as you draw or modify them. They also identify an anchor 

point’s coordinates, if the Anchor/Path Labels option is also on.

TIP When smart 
guides are active with 

the Alignment Guides option 
turned on, object bounds 
snap to guides and to other 
objects, making it easier to 
position objects precisely.

Figure 1.18 The six types of 
smart guides (left to right): 
alignment guides, object 
highlighting, transform 
tools, construction guides, 
anchor/path labels, and 
measurement labels.
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Defi ning Custom Views
Sometimes you work on a document and then never see it again. Other 

documents contain artwork you constantly revisit. If those documents are 

complex or have many layers, you may fi nd you’re constantly panning and 

zooming to different parts of the document or that you’re always hiding and 

showing layers.

To navigate more easily, you can defi ne custom views, which allow you to save 

the view state of a document. To do so, use your Hand and Zoom tools to 

adjust your document to the desired view. Then, toggle the visibility of the 

layers to your liking. Finally, choose View > New View. Assign a name to 

the view, and click OK. You can repeat this as many times as you’d like to 

add multiple view settings to your document (Figure 1.19). Each view you 

create will appear listed at the very bottom of the View menu, and you can 

quickly “ jump” to a view by choosing it from that menu.

Custom views are saved with the document, so they will be available even 

after you’ve saved, closed, and reopened the document. Likewise, those 

views will also be available to anyone else who opens the fi le on their own 

computer.

Figure 1.19 Creating a 
new view makes it easy to 
quickly return to a specifi ed 
state of a document. In this 
example, several custom 
views have already been 
defi ned.
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WORKING WITH TEMPLATES
For repetitive work, use templates that allow you to set up a fi le with 

certain settings and attributes—even actual artwork and layers—to create 

more consistent fi les in less time. Illustrator templates are really just regular 

Illustrator fi les with one difference—you can’t save them. You can only per-

form a Save As function with them (so you don’t overwrite the template).

To create a template fi le, start by creating a new Illustrator document. Draw 

guides, add content, place artwork on the artboard, add layers, and adjust 

your document settings as you’d like them to appear in the template. When 

you’re ready to save your template, choose File > Save As, and specify the 

Illustrator Template (AIT) format in the dialog box. Template fi les contain 

a fl ag in them so that when they are reopened in Illustrator, they open as 

untitled documents.

Illustrator actually ships with hundreds of professionally designed templates, 

which you can access by choosing File > New from Template. The templates 

are stored in the Adobe Illustrator CS3/Cool Extras/en_US/Templates 

folder. You can also browse the template fi les using Adobe Bridge CS4 so 

you can see previews of what the templates contain. Before you wrinkle 

your nose about using “clip art,” you’ll be happy to know that Illustrator also 

includes an entire folder of blank templates (Figure 1.20). These blank tem-

plates have everything you need to quickly create print- or web-ready work.

NOTE If you’re a 
professional designer, 

you might not want to use 
any of Illustrator’s prefab tem-
plates, but it’s helpful to open 
the fi les and explore them to 
see how they were created. 
One of the best ways to learn 
is by reverse-engineering 
what someone else has done. 
One of the techniques you’ll 
learn in this book is how to 
pick apart an Illustrator fi le; 
Illustrator’s template fi les are 
perfect for this because they 
employ many diff erent 
features and techniques.

Figure 1.20 Illustrator’s 
blank templates, such as 
this one for stationery, 
already have artboards 
set up at standard sizes 
for you to use.
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New Document Profi les or Templates?

When you create a new Illustrator fi le, you’ll notice that several swatches, sym-
bols, brushes, and graphic styles are already present in the fi le. How did they 
get there? The answer is that they were copied from the fi le used to defi ne the 
new document profi le you chose when you created the fi le.

This means if you use certain swatches or symbols frequently, you can simply 
edit these new document profi les (or create your own custom ones), and you 
never have to load another library again. Although this is true, the more con-
tent you have in your new document profi le, the more content you will have in 
every fi le you create, making for larger fi les (which also take longer to open).

Templates, on the other hand, can also contain content. Additionally, template 
fi les are really full Illustrator fi les that can contain paragraph and character 
styles, artwork on the artboard, crop marks, layers, and more—something new 
document profi les can’t do. It may be more effi  cient to keep a small startup fi le 
but have a set of rich templates that you can open at any time to get a running 
start on your design work.

If you ever do edit your new document profi les (instead of creating your own 
new ones), be sure to fi rst create and save a backup of the existing fi les (save 
them somewhere where you can fi nd them and not accidentally delete them). 
This way, if you end up doing something crazy, you still have a way to return 
to the original default fi les. You can also simply delete a profi le from its folder, 
and Illustrator will automatically generate a new one in its place.

CREATING MEANINGFUL METADATA
If you go to any popular stock photo website, you can enter a keyword or a 

description for the kind of image you’re looking for and instantly see a list 

of images matching your criteria. Have you ever wondered how this works? 

How does a search engine know what the contents of a photograph are? 

The answer is metadata.

Metadata is information that describes a fi le, and it can be just about any-

thing. The creation date, author, creation application, keywords, and copy-

right information are all examples of metadata. Adobe applications use 

an XML-based standard called Extensible Metadata Platform (XMP) to 

store this metadata inside fi les. The metadata resides in an XML header at 

the top of each fi le, and Adobe applications can read this data.

TIP Using Adobe 
Bridge, you can even 

add metadata to a fi le with-
out having to open the fi le. 
Simply highlight a fi le in 
Adobe Bridge, and choose 
File > File Info. You can add 
metadata to multiple fi les 
simultaneously by highlight-
ing several fi les and then 
choosing File > File Info.
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In Illustrator, you can choose File > File Info to open the File Info dialog 

box, where you can enter a variety of metadata for your fi le (Figure 1.21). 

When you save the fi le, the metadata is embedded within the fi le.

Illustrator takes metadata a step further, because certain information is 

automatically added to each fi le as you save it. For example, each time you 

save your fi le, Illustrator adds a list of fonts, swatches, color groups, and 

color separation plates in the fi le’s metadata for you.

Figure 1.21 The File Info 
dialog box in Illustrator 
stores keywords and other 
metadata using the XML-
based XMP standard.



Chapter 
TWOSelecting and Editing Artwork

The tools you will employ most often 

when using Adobe Illustrator CS4 on a 

day-to-day basis are the selection tools. 

The power of Illustrator lies not just in creating graphics but more so 

in editing and manipulating them. To perform just about any function in 

Illustrator (or nearly any computer graphics program, for that matter), you 

need to select something fi rst. Without selections, Illustrator has no idea 

which of the objects in your document you want to modify.

Speaking of modifi cations, this chapter is full of them, in the form of tools 

and functions that affect vector paths. Experienced illustrators know that 

often the best way to create a complex shape is to start with a few simple 

shapes fi rst. A few quick edits will get you to your fi nal result much faster 

(and often with better results as well).

The artwork featured throughout this chapter comes from Simon Oxley 

(iStockphoto; username: simonox).

27
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SELECTING OBJECTS
If you’ve used Illustrator before, you’re familiar with the twins: the Selection 

tool and the Direct Selection tool (Figure 2.1). These tools have been given a 

variety of alternative names over the years (some of which can’t be printed 

in this book), including the black and white arrows or the solid and hollow 

arrows. In reality, there’s a third tool called the Group Selection tool, although 

it doesn’t get much exposure because of a certain keyboard shortcut that 

we’ll talk about shortly.

Making Selections
Before we talk about the tools themselves, the reason why there are two dif-

ferent selection tools, and when to use one over the other, let’s fi rst see how 

you can make a selection in Illustrator:

• The click method. To select an object, just click it with any of the 

selection tools. To select multiple objects, you can click a second object 

while holding the Shift key to add the second object to your selection. 

Shift-clicking an object that is already selected will deselect it.

• The marquee method. Another way to make selections is by creating 

a marquee, which is similar to drawing a rectangle, only with a selec-

tion tool instead of a shape tool. You start by clicking and dragging the 

pointer to specify a rectangular area, called a marquee. When you release 

the mouse button, any objects that fall within the boundaries of the 

marquee become selected (Figure 2.2).

Keep in mind that you can use a combination of both methods to make 

more effi cient selections. For example, say you want to select all the objects 

in a certain area except for one. You can use the marquee method to fi rst 

select all the objects and then Shift-click the object you don’t want in order 

to deselect just that object.

Figure 2.1 The dynamic 
duo, the Selection and 
Direct Selection tools, are 
also referred to as the black 
and white arrow tools.

NOTE In reality, the 
selection tools do more 

than just select objects. You 
can use them to move 
selected objects as well. 
Moving an object in Illustrator 
is actually considered a trans-
form function, so we’ll be 
talking about the Selection 
and Direct Selection tools 
later in this chapter as well.

NOTE The keyboard 
shortcut to quickly 

select all objects in a 
document is Command-A 
(Ctrl-A). You can also select all 
objects within the active art-
board by pressing Command-
Option-A (Ctrl-Alt-A).
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Sometimes, you don’t want the ability to select an object at all. Especially in 

complex fi les with many overlapping objects, it can be easy to accidentally 

select objects without realizing what you’ve done (until it’s too late, of course). 

Illustrator allows you to select an object and choose Object > Lock > 

Selection, which makes the object unavailable for editing. Unfortunately, 

it can be diffi cult to select objects that overlap each other (there’s no easy 

way to click through the stacking order of objects like you can using Adobe 

InDesign), so locking and unlocking objects becomes a frequent endeavor. 

Learning the keyboard shortcuts to lock (Command-2) [Ctrl-2] and unlock 

(Command-Option-2) [Ctrl-Alt-2] is a good idea. Alternatively, you can 

right-click an object and choose Select > Next Object Below from the con-

text menu (Figure 2.3).

Figure 2.2 Selecting 
multiple objects using the 
marquee method keeps you 
from having to Shift-click 
multiple shapes to select 
all of them.

NOTE The ability 
to isolate individual 

groups and objects in 
Illustrator makes it easier to 
select and work with complex 
illustrations. Chapter 5, 
“Organizing Your Drawing,” 
covers isolation in more 
detail.

Figure 2.3 It’s a bit clunky, 
but you can use a context 
menu to select objects that 
appear beneath others in 
the stacking order.
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Setting Your Selection and Anchor 
Display Preferences
When it comes to making selections, Illustrator offers a few ways to help 

you make selections through the Selection & Anchor Display panel in 

Preferences (Figure 2.4). You can fi nd a description for each of the settings 

in the Appendix, “Application Preferences.”

Here are a few options you can set in the Selection & Anchor Display panel 

in Preferences:

• You can set a tolerance for how close your cursor has to be in order 

to select an anchor point or an object. A higher pixel value will make 

it easier to select objects quickly, but a lower pixel value will give you 

far more accurate results, making it easier to select anchor points that 

appear very close to each other.

• The Object Selection by Path Only setting restricts Illustrator to select 

objects only when clicking their vector paths (not their fi lls).

• The Snap to Point setting determines the distance at which your cursor 

snaps to other objects or guides.

• You can control the size of anchor points and control handles. On 

high-resolution monitors, anchor points and control handles appear 

very small and are diffi cult to grab with the selection tools. Preference 

settings allow you to choose from three different sizes for both anchor 

points and control handles, making it easier on your eyes (and your 

sanity).

Figure 2.4 The Selection 
& Anchor Display panel 
in Preferences gives you 
greater control over how 
you make selections.

NOTE By default, the 
Object Selection by 

Path Only setting in Prefer-
ences is off , which allows you 
to select an object by clicking 
its path or anywhere within 
its fi ll area (if it has a fi ll attri-
bute applied). Although this 
is convenient, sometimes—
especially when you are 
working with complex 
artwork—this behavior makes 
it diffi  cult to select objects. 
Turning this preference on 
allows you to select objects 
only by clicking their vector 
paths, not their fi ll areas.
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• With the Direct Selection tool, Illustrator will highlight anchor points 

as you move the pointer over them. This can help you identify where 

the anchor points are and, more importantly, can make it easier to 

identify what you’re editing. You can set this behavior by selecting the 

“Highlight anchors on mouse over” check box.

Using the Direct Selection Tool
If there’s one aspect that confuses people most about Illustrator, it’s that it 

has two selection tools (the Pen tool doesn’t confuse people nearly as much 

is it frustrates them). Fear not, though, there’s a method to the madness—

and once you understand it, you’ll breathe easier. The good news is that 

whatever you learn here will apply to InDesign and Adobe Photoshop as 

well, because they use the same selection tools.

When you are using the Direct Selection tool, clicking the fi ll area of an 

object selects the entire object (unless the object’s fi ll is set to None or 

unless Object Selection by Path Only is turned on in Preferences). Clicking 

the vector path either selects a segment of the path (if you click between two 

anchor points) or selects the anchor point that you click.

If you hold the Option (Alt) key while clicking either the fi ll or the path of 

an object with the Direct Selection tool, it selects the entire object—just as 

the Selection tool does. So, with a single keyboard shortcut, you can make 

the Direct Selection tool act like its twin. If you are working with a group of 

objects, holding down Option (Alt) and clicking an object’s path once with 

the Direct Selection tool selects the entire object. Holding down Option (Alt) 

and clicking a second time selects all the objects in the group. If there are 

nested groups (groups within other groups), each additional Option (Alt) 

click results in the next level up in the hierarchy of the group being selected. 

If you ever want to select an entire group with one click, press the Command 

(Ctrl) key to temporarily switch to the Selection tool.

Once you master this method of using the Direct Selection tool while using 

the keyboard shortcuts, you’ll never think twice about the two selection 

tools again.

TIP If you have an 
object that is already 

selected, you can use the 
Direct Selection tool to click 
and release any anchor point 
to select it. You don’t need to 
deselect the entire object fi rst 
and then reselect just the 
desired anchor point.
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Selection Tool vs. Direct Selection Tool

At the simplest level, the Selection tool (the black, or solid, arrow) is used to 
select entire objects and groups. The Direct Selection tool, on the other hand, 
is used to select parts of objects or individual objects within a group. For 
example, if you draw a star shape and click it with the Selection tool, the entire 
star becomes selected. In contrast, if you click one of the points of the star 
with the Direct Selection tool, only that point becomes selected (Figure 2.5).

At fi rst, it sounds like life in Illustrator is all about constantly switching between 
these two tools. To make things a bit easier, when you have one selection 
tool active, you can press the Command (Ctrl) key to temporarily switch to 
the other selection tool. To make life even easier than that, you can learn how 
power users utilize modifi er keys with the Direct Selection tool effi  ciently; 
this practice practically negates the need for both the Selection tool and the 
Group Selection tool.

Figure 2.5 The object on 
the left is selected with the 
Selection tool. The object on 
the right is selected with the 
Direct Selection tool.

Using the Group Selection Tool
In reality, Illustrator has three core selection tools: the Selection tool, the 

Direct Selection tool, and the Group Selection tool. The Group Selection 

tool is useful for selecting groups of objects. As you will learn in Chapter 5, 

groups can be nested (meaning you can have groups within groups). Using 

the Group Selection tool, clicking an object once selects the object. Clicking 

the same object a second time selects the entire group to which the object 

belongs. Each successive click selects the next level up in the hierarchy.

Earlier we referred to Illustrator as having two selection tools because the 

Group Selection tool is rarely chosen. Why? It’s because of the keyboard 

shortcut that we mentioned. When the Direct Selection tool is active, press-

ing the Option (Alt) key toggles to the Group Selection tool, which is why 

you can then select entire objects.



SELECTING OBJECTS 33

Using Alternative Selection Techniques
Although most of the selections you make will incorporate the use of the 

Selection tool or the Direct Selection tool, sometimes you might need a 

more specialized selection tool. Illustrator can offer a helping hand in a 

variety of ways.

Using the Lasso and Magic Wand Tools

The Lasso tool and the Magic Wand tool fi rst appeared in Photoshop, but 

both made their way into the Illustrator toolset. Although they’re similar in 

concept to those found in Photoshop, remember that Illustrator is an object-

based program, so these tools select objects, not pixels.

The Lasso tool in Illustrator acts much like the Direct Selection tool in that it 

can select individual anchor points. Whereas a marquee is always limited to a 

rectangular shape, the specialty of the Lasso tool is that you can draw a mar-

quee in any free-form shape. Where you have many objects in close proximity 

to each other, the Lasso tool allows you to draw a custom marquee shape to 

select just the objects—or anchor points—you need (Figure 2.6).

Figure 2.6 Drawing a 
free-form marquee with 
the Lasso tool can be help-
ful when you are trying to 
make complex selections 
with art that is in close 
proximity to other art.

If you have several similarly styled objects in your document and you 

need to select them all, it can be tedious to manually select them using the 

click method. If they are scattered throughout the document, the marquee 

method won’t work for you either. In such cases, the Magic Wand tool 

allows you to click one object; when you do, any other objects in your fi le 

that have the same attributes as the object you clicked become selected as 

well. Not bad for one click, right? If you double-click the Magic Wand tool 

NOTE If you’re a 
production artist, the 

Magic Wand tool is invaluable. 
By setting a tolerance of .25 
point for the stroke weight 
and clicking a path with a 
.25-point stroke on your art-
board, you can select all 
paths in your document with 
a stroke weight between 
0 and .5 point, making it easy 
to set consistent hairline 
stroke widths.

NOTE Unlike the 
Selection and Direct 

Selection tools, the Lasso and 
Magic Wand tools can’t move 
objects; they can only select 
them.
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in the Tools panel, the Magic Wand panel appears; here you can specify 

which specifi c attributes you want the Magic Wand tool to pay attention to 

(Figure 2.7). The true power of the Magic Wand tool is that you can set a 

tolerance for each attribute. So if your document contains several objects 

colored a variety of shades of a color, you can still select them all with the 

Magic Wand tool by clicking a single object (Figure 2.8).

Figure 2.7 You can use the Magic 
Wand panel to specify tolerance 
levels for diff erent attributes.

Figure 2.8 With the Magic Wand 
tool, you can easily select a range 
of objects that share similar colors.

Selecting Similar Objects

Illustrator has a Select menu that contains a variety of selection-based func-

tions. You’ll fi nd some of the most useful ones in the Select > Same menu 

and the Select > Object menu. To use the Same functions, fi rst make a 

selection on the artboard with any of the selection tools in Illustrator. Then 

choose from the list of attributes to select objects based on that attribute 

(Figure 2.9). At any time, you can use the Object functions to select a certain 

kind of object in your fi le. You don’t need to have any objects selected fi rst 

in order to use the Select > Object functions.

Figure 2.9 The Control 
panel also contains a but-
ton that allows you to select 
similar objects. The button 
is available whenever you 
have an object selected.
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Saving Selections

Making complex selections can take time, and it can be tedious having to 

constantly make selections on objects as you are working on a design. To 

make life just a tad easier, you can save your selections and retrieve them 

later. Once you have made a selection using any of the methods mentioned 

earlier, choose Selection > Save, and give your selection a name. That selec-

tion then appears at the bottom of the Select menu, which you can access, 

or load, at any time. Because selections in Illustrator are object-based, a saved 

selection remembers objects even after they’ve been moved or modifi ed.

MAKING TRANSFORMATIONS
Drawing objects in Illustrator is only part of the design process. Once art is 

created, you can manipulate it in a myriad of ways. In Illustrator, the process 

of changing or manipulating a path is called a transformation, and transforma-

tions can include anything from simply moving an object to changing its 

size or rotation.

When you move a fi le, its x,y coordinates change, and Illustrator considers that 

a transformation. You can also move selected objects precisely by changing the 

x,y coordinates in the Control or Transform panel. Alternatively, double-click 

the Selection tool to open the Move dialog box, where you can specify values 

numerically as well (Figure 2.10). Clicking the Copy button in the Move dia-

log box leaves the original shape in place and moves a copy of it.

Of course, you can use the Selection tool to click and drag an object to reposi-

tion it manually. If you press and hold the Option (Alt) key while dragging, 

Illustrator moves a copy of the selection. If an object is fi lled with a pattern, 

Figure 2.10 The Move 
dialog box remembers the 
last move transform made, 
so you can move an object 
on your artboard and then 
open the Move dialog box 
to see how far you moved it.
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pressing and holding the tilde (~) key while dragging adjusts the positioning 

of the pattern without moving the object.

Using the Bounding Box
The bounding box allows you to perform several common transform func-

tions; you can do this by simply clicking an object using just the Selection 

tool. Once you’ve made a selection, you can click an object to move it, or 

you can click any of the eight handles that appear on the perimeter of the 

bounding box to scale or resize the selection (Figure 2.11). Holding the 

Shift key while resizing constrains proportion. If you place your pointer just 

outside the edge of a handle, you can rotate your selection. Hold the Shift 

key to constrain the rotation angle to increments of 45 degrees.

By default, Illustrator has the bounding box setting turned on. To turn it off, 

choose View > Hide Bounding Box (Command-Shift-B) [Ctrl-Shift-B].

The bounding box appears only when you select objects with the Selection 

tool. Although the bounding box is certainly useful, it can get in the way as 

well. Illustrator has a Snap to Point setting, where you can drag an object by 

an anchor point and easily align it to an anchor point in a different object. 

As your pointer approaches an anchor point, the object you are dragging 

snaps to it. When the bounding box is turned on, you can’t always grab an 

object by the anchor point because doing so allows you to scale the object 

instead. Your alternative is to either turn off the bounding box or use the 

Direct Selection tool (which many Illustrator users do anyway). An easy 

way to access the Direct Selection tool is to press and hold the Command 

Figure 2.11 The bounding 
box makes simple trans-
forms, such as scale and 
rotate, quick and painless.

TIP If you do turn off  
the bounding box 

function, you can still access 
similar functionality by using 
the Free Transform tool.
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(Ctrl) key when the regular Selection tool is active. Doing this will also 

make the bounding box temporarily disappear (until you release the 

Command [Ctrl] key).

Living by the Numbers with 
the Transform Panel
The Transform panel, which you can access by choosing Window > 

Transform, is a production artist’s best friend. In reality, it’s a panel that 

can be helpful to anyone. The Transform panel provides numeric feedback 

on the exact specifi cations of a selection. This includes x,y coordinates, 

width and height measurements, and rotate and shear values. You can also 

use the panel to make numeric changes to selected objects.

You can enter values using any measurement system, and you can even 

specify math functions. For example, you can change the x coordinate of an 

object by adding +.125 at the end of the value and pressing Return (Enter) 

or Tab. You can even mix different measurement systems, such as subtract-

ing points from millimeters. Use the asterisk for multiplication functions 

and the slash for division. If you press the Option (Alt) key while pressing 

Return (Enter) for a value, you’ll create a copy.

At the far left of the Transform panel is a 9-point proxy that corresponds to 

the eight points of an object’s bounding box and its center (Figure 2.12). 

The point you click is extremely important—not only for the Transform 

panel but for all transform functions. If you click the center point, the x,y 

coordinates you see in the Transform panel refer to the center point of your 

selection. Clicking a different point reveals the coordinates for that point 

of the selection. When specifying transformations such as width or height 

settings or rotation or skew values, the point you choose becomes the 

origin point—the point from which the transformation originates. Rotating 

an object from its lower-left corner yields very different results from that 

same rotation applied from its center point.

Figure 2.12 The 9-point proxy in the 
Transform panel enables you to set an 
origin point for a transformation. You 
can fi nd the proxy (also called a refer-
ence point) in numerous transform dialog 
boxes and in the Control panel as well.
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If you want to transform strokes and effects, choose the Scale Strokes & 

Effects option from the Transform panel menu, which stays on until you 

turn it off. From the same panel menu, you can also choose to fl ip objects 

on their horizontal or vertical axis.

Using Preview Bounds

One of the benefi ts of using Illustrator is that you can be extremely precise 
when drawing objects. The Control, Transform, and Information panels in 
Illustrator all provide exact feedback on coordinates, positioning, sizing, and 
more. By default, these panels use the actual vector path to determine these 
numbers, not the visual boundaries of the object. For example, you may have 
a shape that has a thick stroke or a scale eff ect applied to it that is not rep-
resented in the value you see in the Transform panel. When the Use Preview 
Bounds preference is turned on in the General panel in Preferences, all panels 
use the visual boundary of a fi le as the value, not the underlying vector path.

Working with the Transformation Tools
Illustrator contains specifi c tools for performing scale, rotation, refl ection 

(mirroring), and shearing (skewing). These specifi c tools allow you to 

perform transformation with precision and with more power than the 

bounding box or even the Control panel.

The four transformation tools—Scale, Rotate, Refl ect, and Shear—all work 

the same way. Here, we’ll discuss the Rotate tool specifi cally; you can apply 

the same techniques to the other tools.

To rotate an object, select it, and choose the Rotate tool (R). Take a look at 

the selection on your screen, and you’ll see a special icon that appears at its 

center. This icon, which looks like a small crosshairs, is your origin point 

(Figure 2.13). To perform a rotation, position your pointer a fair amount of 

space away from the origin point, and click and drag in a circular motion. 

You don’t have to click the object itself to perform the rotation. If you click 

too close to the origin point, you’ll fi nd that it is diffi cult to control the rota-

tion. The farther away you move your pointer from the origin point before 

dragging, the more leverage and control you have (Figure 2.14).

TIP To lock the pro-
portion of width and 

height values, click the link 
icon at the far right of the 
Transform panel. This allows 
you to specify just the height 
or the width of a selected 
object, and Illustrator 
scales the other value 
proportionally.
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While dragging with the Rotate tool, press the Shift key to constrain the 

rotation to 45-degree increments, press the Option (Alt) key to create a 

copy, and press the tilde key if your object is fi lled with a pattern and you 

want to rotate just the pattern.

The powerful part of using a transformation tool is that you have control 

over the exact placement of the origin point. For example, if you select an 

object and then switch to the Rotate tool, you’ll see the origin point, as we 

discussed earlier. At that time, you can click once anywhere on your screen 

to redefi ne that point elsewhere. If you then click and drag, Illustrator uses 

the repositioned origin point for the rotation. Alternatively, you can simply 

click and drag the origin point itself to any location on your screen.

The ability to reposition the origin point arbitrarily means you can specify 

an origin point that’s outside the boundaries of your object. When using the 

Transform panel, you can choose from only one of the nine preset options 

using the 9-point proxy.

You can also specify transformations numerically with any of the four trans-

formation tools (Scale, Rotate, Refl ect, and Sheer) by making a selection 

and double-clicking the desired transformation tool. One of the powerful 

features of opening the dialog box for a specifi c transformation tool is that 

when you enter a value, the next time you open the dialog box, that same 

value remains. Additionally, the dialog boxes for each transformation tool 

record the last transformation you performed with the tool. For example, if 

you use the Scale tool to manually resize an object, you can then open the 

Scale dialog box to see the exact percentage to which you scaled the object.

TIP With the Trans-
form Tools option 

turned on in the Smart Guides 
preferences, Smart Guides will 
display the rotation angle in 
real time as you apply the 
transformation.

Figure 2.13 The crosshairs cursor 
indicates the precise location of 
the transformation origin point.

Figure 2.14 When using the Rotate tool, click-
ing away from the origin point gives you better 
leverage, or control, for rotating your selection.
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Transforming Multiple Objects at Once
When you select several objects, Illustrator performs all transformations 

based on a single origin point. This behavior is certainly fi ne for some 

needs, but sometimes you want to have transformations applied to a range 

of objects, and you want those transformations to be applied using indi-

vidual origin points. For example, if you have several shapes selected and 

you want them each to rotate 45 degrees, you want each selected shape to 

rotate around its own center. For example, when you have several individual 

(ungrouped) shapes (Figure 2.15, left), selecting them all and rotating 

them forces all objects to share a single origin point (Figure 2.15, center). 

With the Transform Each function, you can then rotate the multiple objects 

around their own individual origin points (Figure 2.15, right).

The Transform Each function was designed specifi cally for applying trans-

formations across a range of objects, where each object maintains its own 

origin point. As an added bonus, the feature also contains something no 

other transformation tool has—a randomize function.

To use this feature, select a range of objects—even grouped objects—and 

choose Object > Transform > Transform Each to open the Transform 

Each dialog box. Selecting the Preview check box allows you to see the 

effects of the transformation before you apply it. Specify Scale, Move, 

Rotate, and Refl ect settings, and if you’d like, click the Random button 

so that each object gets a slight variation of the settings you specify.

By far, the most important setting you need to specify in the Transform 

Each dialog box is the origin point. Select a point from the 9-point proxy 

to defi ne the origin point for each selected object. Click OK to apply the 

transformations, or click the Copy button to create copies.

Figure 2.15 With the 
Transform Each function, 
you can rotate multiple 
objects around their own 
individual origin points.

TIP Even though the 
Transform Each func-

tion was created for applying 
transformations to multiple 
objects at once, it’s a great 
tool to use on single objects 
as well. This is especially true 
since the Transform Each dia-
log box allows you to specify 
multiple transformations in 
one step.
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Exploring the Power of the Transform 
Again Feature
The Transform Again feature builds on the power of the transformation 

tools you’ve learned. Illustrator always remembers the last transformation 

you applied, so choosing Object > Transform > Transform Again simply 

reapplies that transformation, even if you’ve selected a different object. The 

keyboard shortcut for this feature is Command-D (Ctrl-D); it’s a good idea 

to memorize it, because you’ll use it often.

This example illustrates the power of this feature. Draw a rectangle on your 

artboard. Choose the Selection tool, and drag the rectangle to the right while 

holding the Option (Alt) key, which creates a copy of the rectangle beside the 

original. Now apply the Transform Again command. Illustrator now repeats 

the last transformation, leaving you with three rectangles, evenly spaced.

The Transform Each dialog box allows you to apply multiple transforma-

tions in one step. Applying a Transform Again command after applying a 

Transform Each function simply duplicates those settings. The power to 

transform is now within you. Use it wisely.

EXPLORING THE PATHFINDER PANEL
The basic drawing tools (Rectangle, Ellipse, and so on) in Illustrator are 

great on their own, but you’ll often need to create shapes that are a bit more 

complex. Many times, it’s far easier to combine basic primitive shapes to 

create more complex ones. It can also be easier to edit existing shapes using 

new simple shapes rather than trying to adjust the anchor points of indi-

vidual paths.

The Pathfi nder panel, which you can open by choosing Window > 

Pathfi nder, contains two horizontal rows of buttons, each offering a differ-

ent type of function. The top row, shape modes, offers functions used to 

combine multiple selected shapes (Figure 2.16). The bottom row, 

pathfi nders, consists of functions that are used to split shapes apart in a 

variety of ways (Figure 2.17 on the following page).
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EXCLUDE

MINUS FRONT

INTERSECT

UNITE

FUNCTION PATH GEOMETRYRESULTING ARTORIGINAL ART

FUNCTION PATH GEOMETRYRESULTING ARTORIGINAL ART

CROP

TRIM

MERGE

DIVIDE

MINUS BACK

OUTLINE

Figure 2.16 The shape mode functions. Figure 2.17 The pathfi nder functions.

Combining Shapes with Shape Modes
To use any of the shape modes, select two or more objects in your docu-

ment, and click any of the shape mode buttons in the Pathfi nder panel. To 

create the cute clouds in Figure 2.18, for example, start with three ovals 

and a rectangle (A), use Unite to combine the three ovals (B), and then use 

Minus Front with the rectangle to complete the shape (C). Add sky for an 

added touch (D).

A B C D

The following are the four shape mode functions in the Pathfi nder panel:

• Unite. The Unite shape mode combines all the selected shapes and 

gives the appearance they were all joined together.

• Minus Front. The Minus Front shape mode combines all the selected 

shapes and then takes the top objects and removes them from the bot-

tommost object.

Figure 2.18 With shape 
modes, you don’t have to 
know how to draw complex 
art in order to create it.
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• Intersect. The Intersect shape mode combines all the selected shapes and 

displays only the areas in which all the objects overlap with each other.

• Exclude. The Exclude shape mode combines all the selected shapes and 

removes the areas in which the objects overlap each other.

By default, when you use any of the shape modes in the Pathfi nder panel, the 

resulting object is a new single path. But there’s some “hidden” functionality 

that allows you to use the shape modes to create something called a compound 

shape. A compound shape has the appearance of a single path, but the original 

paths that were used to create the fi nal shape are still present in the fi nal result 

(Figure 2.19). To create a compound shape, hold the Option (Alt) key while 

applying any of the shape mode functions from the Pathfi nder panel.

Compound shapes offer several signifi cant benefi ts over the default shape 

mode paths:

• Compound shapes are “live,” and each of the individual components 

can be edited independently.

• Compound shapes can be nested, much in the same way as groups can.

• Compound shapes can be applied to live text, symbols, and other 

complex objects.

• Compound shapes are compatible with the Shape Layers feature in 

Photoshop (see the sidebar “Illustrator Shape Modes and Photoshop 

Shape Layers”).

Once you’ve created a compound shape, you can “fl atten” it and reduce it to 

a path object by clicking Expand in the Pathfi nder panel. Additionally, you 

can release a compound shape by choosing Release Compound Shape from 

the Pathfi nder panel menu. Releasing compound shapes returns the objects 

to their individual states and appearances.

Figure 2.19 Even though 
the cloud has the appear-
ance of a single path, the 
individual shapes that were 
used to create the shape 
are still editable.

CAUTION The default 
behavior of the shape 

modes in the Pathfi nder panel 
has changed in Illustrator CS4. 
In previous versions, com-
pound shapes were created 
by default, and you were 
required to use the Option 
(Alt) key to created expanded 
paths. In Illustrator CS4, 
Adobe reversed the behavior 
so that now expanded paths 
are created by default, and 
you are required to use the 
Option (Alt) key to create 
compound shapes.
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Illustrator Shape Modes and Photoshop Shape Layers

If you’ve used Photoshop, you might be familiar with vector shape layers, which allow you to create vector-
based masks. Although Photoshop is primarily a pixel-based program, these shape layers, as Photoshop refers 
to them, allow you to create vector shapes within your Photoshop document. Upon close inspection, you’ll 
fi nd that to help you create more complex shapes, you can create shape layers in Photoshop using a variety 
of modes, including Add, Subtract, Intersect, and Exclude—the same functions (with similar names) in the 
Pathfi nder panel in Illustrator.

These objects are interchangeable between Illustrator and Photoshop, and they retain their shape mode set-
tings in the process as well. Create a compound shape in Illustrator, copy and paste it into Photoshop, and the 
compound shape becomes an editable vector shape layer. The same applies in reverse.

Changing Paths with Pathfi nders
To use any of the pathfi nder functions, select two or more objects in your 

document, and click any of the pathfi nder buttons in the Pathfi nder panel. 

The following are the six pathfi nder functions in the Pathfi nder panel:

• Divide. One of the most often-used pathfi nders, Divide takes all 

selected objects and breaks them apart into individual shapes based 

on their overlapping parts. Open paths act like knives and slice paths 

that intersect with them.

• Trim. The Trim pathfi nder removes all overlapping areas from the 

selected paths.

• Merge. The Merge pathfi nder removes all overlapping areas from 

the selected paths and joins all areas of the same color.

• Crop. The Crop pathfi nder takes the topmost selected object and 

removes all objects and areas beneath it that fall outside its path. Unfor-

tunately, this pathfi nder works on vector objects only, and you can’t use 

it to crop a raster image (you’ll need Photoshop for that). This function 

ignores strokes on objects, so it’s best to perform an Outline Path func-

tion before applying the Crop pathfi nder.

• Outline. The Outline pathfi nder converts the selected shapes to out-

lines and divides the lines where they intersect.
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• Minus Back. The Minus Back pathfi nder is similar to the Minus Front 

shape mode, but instead of using the top object to defi ne the subtracted 

area, the function uses the bottom object.

Once you’ve applied a pathfi nder function, you can choose Repeat Path-

fi nder from the Pathfi nder panel menu to apply the same effect again. In 

reality, it takes longer to access the panel menu than it does to just click 

the icon in the panel, so it pays to memorize the Command-4 (Ctrl-4) 

keyboard shortcut.

From the Pathfi nder panel menu, you can also choose Pathfi nder Options 

to open the Pathfi nder Options dialog box (Figure 2.20), where you can 

set the level of precision to use when applying pathfi nder functions (lower 

numbers may result in more complex paths). You can also specify that 

Illustrator should remove redundant points (always a good idea) and 

unpainted artwork when performing Divide or Outline functions.

ALIGNING OBJECTS
When working with a range of objects or anchor points, you will often want 

to align them evenly or distribute them across a specifi ed distance. Rather 

than being forced to fi gure out the math on your own and then manually 

move each object, you can apply the variety of functions that the Align 

panel contains to a range of objects in order to both align and distribute 

objects precisely (Figure 2.21). You can open the Align panel by choosing 

Window > Align.

Figure 2.21 The Align 
panel features plenty of 
options in the form of 
teeny icons.

Figure 2.20 The Pathfi nder 
Options dialog box off ers 
the ability to remove 
redundant anchor points.
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To align a range of objects or anchor points, select them, and click one of 

the Align Objects icons in the Align panel. Admittedly, these small icons 

can be hard to decipher, but if you move your pointer over them for a 

second, a tool tip pops up identifying the name of the function. The Align 

Objects functions also appear in the Control panel.

One thing that is somewhat vague when it comes to aligning objects, 

though, is, what exactly are you aligning your objects to? Illustrator offers 

three distinct options:

• Align to Selection. The Align to Selection option, which is the default 

setting, automatically takes one object from your selection and aligns 

all other objects in your selection to that object. Illustrator chooses an 

object based on the specifi c align function you apply. For example, if 

you use the Align Vertical Top function, Illustrator aligns all objects in 

your selection to the object that is at the top (Figure 2.22).

• Align to Key Object. The Align to Key Object feature was present 

in previous versions of Illustrator, but it required a “secret handshake” 

because there was no specifi c user interface for its use. You would use 

the Align to Key Object option when you wanted to align your objects 

to a specifi c object, within a selection, that you chose. Start by selecting 

your artwork (including the object that you want to align everything 

else to) with the Selection tool. Then, click the object once that you 

want all the other objects to align to (don’t Shift-click because this will 

deselect that object). A heavy blue outline identifi es the object as a key 

object (Figure 2.23). You can also change the key object simply by 

clicking any other object in your selection. Then, apply the desired align 

function from the Align or Control panel.

TIP By default, the 
align functions use the 

actual path of an object for 
calculating alignment. If you 
want Illustrator to factor in 
the actual appearance of 
the object (for example, 
stroke width), choose Use 
Preview Bounds from the 
Align panel menu.

Figure 2.22 The original 
selection (left) and the 
objects after they’ve been 
aligned with the Vertical 
Align Top option (right).
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Figure 2.23 A heavy blue 
outline clearly identifi es the 
key object you’ve chosen.

• Align to Artboard. The Align to Artboard option will align all your 

selected artwork to the active artboard. This function also works 

when you have just one object selected. To activate the Align to Art-

board option, use the pop-up widget in the Align or Control panel 

(Figure 2.24).

Figure 2.24 You can quickly 
choose options for aligning 
objects directly from the 
Control panel.

The align functions treat a group of objects as a single object, so performing 

an align function on a group won’t do anything unless you’re aligning it to 

the artboard. Of course, you can select multiple groups and align them as if 

each group were a single object.

DISTRIBUTING OBJECTS
The Align panel in Illustrator can do more than just align objects—it can 

also distribute objects. In fact, when it comes to distribution, Illustrator 

allows you to distribute the objects in your selection (Distribute Objects) or 

distribute the spacing that appears between each object (Distribute Spacing). 

Yes, there’s a difference. To take advantage of all that the Align panel has to 

offer, choose Show Options from the panel menu (Figure 2.25).

Figure 2.25 The fully expanded 
Align panel displays the 
Distribute Spacing options.
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Distribute Objects
The six buttons in the Distribute Objects section of the Align panel allow 

you to evenly distribute objects within a specifi ed area. But what is the spec-

ifi ed area? In the case of alignment, you are always aligning objects to another 

single key object (whether you defi ne one or not) or an artboard. But in 

order to distribute objects evenly, you need two key objects. By default, 

Illustrator picks the two objects that are the farthest apart from each other 

and uses those as key objects. The remaining objects within the selection 

are then evenly distributed between the two key objects. In Figure 2.26, for 

example, the dashed lines indicate the center of each object in their original 

location (left). After applying the Horizontal Distribute Center command, 

the objects on the far left and right remained in place, while the objects in 

between moved so that their centers were distributed evenly (right). The 

amount of space between the centers of all the objects is now consistent.

When using the Distribute Objects functions, you have no control over the 

distance between each object. If you fi nd you need to adjust the amount of 

space between the objects, you will have to adjust the position of the outer-

most two objects and try again. If you’re concerned about the amount 

of space that appears between the distributed objects (for example, you 

need .25" between each object), then you’ll want to learn how to use the 

Distribute Spacing functions.

Distribute Spacing
As any good designer knows, white space isn’t just an abstract—it actually 

exists—and to better understand what the Distribute Spacing functions 

do, you need to think about white space. That’s because the two Distribute 

Spacing functions in the Align panel apply an even amount of white space 

between each object in your selection (Figure 2.27).

Figure 2.26 An object 
before (left) and after (right) 
aligning with the Horizontal 
Distribute Center command.
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By default, Illustrator defi nes the outermost two objects in your selection as 

key objects and then evenly distributes the white space between each of the 

objects. If you want to specify the exact amount of white space that should 

appear between each object, you must fi rst manually defi ne a key object. 

Just like when using the align functions, you can defi ne a key object by 

clicking an object with the Selection tool after you’ve made your selection. 

Once a key object is active, you can specify a value in the fi eld in the 

Distribute Objects section of the Align panel.

WORKING WITH TOOLS OF MASS
DISTORTION
Illustrator has a plethora of tools that can help you create crisp, clean paths 

with extreme precision. But at times a design calls for something less 

perfect, and it is also appropriate to bend or stretch artwork to achieve a 

distorted effect. That’s where the distortion tools come into play.

Painting with Distortion: The Liquify Tools
In your average box of classic toys, you’d surely fi nd an Etch A Sketch, a 

Slinky, a collection of Tinkertoy parts, and, undoubtedly, a plastic egg fi lled 

with Silly Putty. For those not familiar with the popular toy, Silly Putty is 

this gooey plastic substance that looks much like a wad of chewing gum. 

Once you’ve fl attened the plastic, you can press it fi rmly on newsprint (we 

always used the comics section) to transfer the images or text to the plastic 

surface. Then the fun begins; you can pull and twist and stretch the plastic 

to distort the pictures or comics.

If you’ve missed out on all the fun over the years, fear not—you can perform 

the same distortion to your artwork using the suite of Liquify distortion tools 

in Illustrator (although your hands won’t smell of Silly Putty afterward). The 

Figure 2.27 After applying 
the Horizontal Distribute 
Space command to the 
original objects (left), the 
amount of white space 
that appears between the 
objects is consistent (right).

TIP Once you defi ne 
a key object, you can 

specify a Distribute Spacing 
value of 0, which will 
automatically “kiss fi t” your 
objects to each other.
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Liquify toolset includes the Warp, Twirl, Pucker, Bloat, Scallop, Crystallize, 

and Wrinkle tools (Figure 2.28). Each of these tools allows you to “paint” 

with distortion effects by simply clicking and dragging over vector art. The 

tools feature a brush size, which helps determine how large of an area is dis-

torted (Figure 2.29). You can change the brush size for any of the Liquify 

tools interactively by holding the Option (Alt) key while dragging with the 

tool. Adding the Shift key while dragging constrains the brush size to a per-

fect circle.

TOOL DISTORTED RESULTORIGINAL ART

BLOAT

TWIRL

PUCKER

WARP

CRYSTALLIZE

WRINKLE

SCALLOP

Figure 2.28 The Liquify 
tools appear grouped 
together in the Tools panel 
and off er a wide range of 
distortion eff ects.

Figure 2.29 Changing the 
size of a Liquify brush allows 
you to control how much 
of a selection becomes 
distorted with each drag 
of the mouse.
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You’ll have to be careful when using the Liquify tools, because they exhibit 

different behavior based on your selection. If you have artwork selected 

before you start dragging with a Liquify tool, only the selected art becomes 

distorted. However, if you have not made a selection, clicking and dragging 

with a Liquify tool distorts any path you touch.

The Liquify tools don’t work on live text (you’ll need to convert text to out-

lines fi rst), but the tools do work on embedded images. As you drag a Liquify 

tool over an embedded image, Illustrator creates a mesh that is used to distort 

the image beneath it. In fact, if you’ve created a gradient mesh object, using 

the Liquify tools on the mesh object produces interesting effects as well.

Double-clicking any of the Liquify tools in the Tools panel opens a dialog 

box offering a variety of settings (Figure 2.30). The top half of the dialog 

box features Global Brush Dimensions settings, which control the size 

(width and height), angle, and intensity of the tools. In addition, if you 

are using a pressure-sensitive tablet, you can choose to control the inten-

sity with pen pressure by selecting the Use Pressure Pen check box. Any 

changes you make to the Global Brush Dimensions settings are applied to 

all the Liquify tools.

The bottom half of the dialog box offers options for the specifi c tool that 

you double-clicked. Most tools offer Detail and Simplify settings, although 

the Wrinkle tool offers many additional options as well. The changes you 

make to each of these tool-specifi c settings affect only the tool you double-

clicked.

Figure 2.30 If you have a 
pressure-sensitive tablet, 
you can achieve greater con-
trol over the Liquify tools by 
selecting the Use Pressure 
Pen setting.
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Getting Into Shape: Envelope Distortion
Ever see those cartoons where one of the characters gets his head stuck in 

a glass jar? And remember that when he pulls his head out of the jar, his 

head is in the shape of the jar? Wouldn’t it be cool if you could do the same 

thing with your artwork? Well, you can, using the enveloping features in 

Illustrator.

An envelope is a regular vector shape that can contain other artwork. And any 

artwork that is contained inside the envelope becomes distorted to take on 

the shape of the envelope. As you will soon learn, envelopes use the mesh 

technology in Illustrator to distort artwork. In fact, these envelope meshes, as 

they are called, are identical to the gradient meshes you will learn about in 

Chapter 4, “Creative Drawing.”

You can create an Envelope distortion in Illustrator in three ways, and natu-

rally, each offers a slightly different approach and warrants its own benefi ts. 

As you learn about these three different types of envelopes, you will under-

stand when it’s best to use them for a specifi c project or desired result. You 

can fi nd these three methods in the Object > Envelope Distort menu; they 

are named Make with Top Object, Make with Mesh, and Make with Warp.

Using Method 1: Make with Top Object

A commonly used Envelope distortion technique in Illustrator is the Make 

with Top Object method. Creating an Envelope distortion using the Make 

with Top Object method is similar to creating a mask. A regular vector 

shape at the top of the stacking order acts as the envelope, and all selected 

artwork that appears beneath the envelope becomes distorted to fi t within 

the envelope shape. Here are the steps you’ll need to follow to perform this 

technique:

1. Select the shape you will be using as the envelope. You can use any 

vector object consisting of a single path as an envelope.

2. Choose Object > Arrange > Bring to Front. This ensures that the 

envelope is at the top of the stacking order.

3. Select both the artwork you want to distort and the vector shape that 

will become the envelope.
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4. Choose Object > Envelope Distort > Make with Top Object. The 

selected artwork becomes distorted to fi t within the envelope shape 

(Figure 2.31).

Once you’ve created an Envelope distortion, you can edit the envelope shape 

using your Direct Selection tool—just as you’d do with any other vector 

shape. As you adjust the shape of the envelope, the distorted artwork updates 

to match the edited shape (Figure 2.32). Pay close attention to the position of 

the control handles that appear on the anchor points of your envelope path, 

because they also affect how art within the envelope shape is distorted.

Using a distinct custom shape as a distortion envelope is useful for times 

when you need artwork to fi t within the confi nes of a specifi c shape. How-

ever, you’ll notice that although you can easily adjust the outside path to 

change the overall shape of the distortion, you have little control over how 

the artwork inside the envelope is distorted. To control distortion across the 

entire object, not just the edges, you need to employ one of the next two 

methods: Make with Mesh or Make with Warp.

Figure 2.31 The Make with 
Top Object command makes 
it easy to distort artwork to 
quickly add perspective.

Figure 2.32 Changing 
the shape of the envelope 
after you’ve applied the 
distortion makes it easy to 
tweak your distortion to 
perfection.

TIP You can also use 
the Mesh tool to add 

mesh points to envelopes you 
created using the Make with 
Top Object method.
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Using Method 2: Make with Mesh

When using the Make with Mesh method, Illustrator creates the envelope 

shape for you, so you don’t need to create a shape fi rst. The shape that 

Illustrator creates is a rectangle, so no immediate distortion is visible when 

you apply this kind of envelope. Once the envelope is created, you can edit 

the mesh points to control how the distortion affects the artwork. Editing 

an envelope mesh is identical to editing a gradient mesh.

To create an Envelope distortion using the Make with Mesh method, per-

form the following steps:

1. Select any artwork on your artboard. You can select multiple objects, 

and although you aren’t required to group them, you may want to do so 

to ensure easier editing later.

2. Choose Object > Envelope Distort > Make with Mesh.

3. In the Envelope Mesh dialog box, specify how many rows and col-

umns you want the mesh to be initially created with (Figure 2.33). It 

doesn’t matter whether you aren’t sure of the exact number of rows and 

columns at this point, because you are able to add mesh points later as 

needed. Click OK to apply the Envelope distortion.

4. Using the Mesh tool or the Direct Selection tool, move the individual 

mesh points and their control handles to apply distortion to your art-

work (Figure 2.34).

Figure 2.33 The Envelope 
Mesh dialog box gives you 
the ability to set how many 
mesh points appear initially 
in the envelope. Creating 
more rows and columns 
gives you additional control 
over the amount of distor-
tion you can apply.



WORKING WITH TOOLS OF MASS DISTORTION 55

Figure 2.34 Similar to working 
with a gradient mesh, adjusting 
the position and control handles 
of mesh points in an envelope 
mesh controls the distortion of 
the artwork.

If you want to add mesh points to your envelope, select the Mesh tool, and 

click anywhere within the selected envelope. Hold down the Option (Alt) 

key while clicking with the Mesh tool to remove mesh points.

Although you start with a rectangle mesh shape, moving the individual 

mesh points on the envelope gives you control over not just the outer edge 

of the distortion but also any points within the envelope shape. However, 

this method is harder to use only because you aren’t starting with a dis-

torted shape, just a grid of mesh points.

Using Method 3: Make with Warp

The Make with Warp method of applying Envelope distortion is nearly 

identical to the Make with Mesh method—only with a twist (sorry, couldn’t 

resist). Instead of starting with a rectangular-shaped mesh, Illustrator gives 

you the option of choosing from several preset shapes. Actually, they are the 

same presets as those found in the Warp effect.

Follow these steps to apply an Envelope distortion using the Make with 

Warp method:

1. Select any artwork on your artboard. You can select multiple objects, 

and although you aren’t required to group them, you may want to do 

so to ensure easier editing later.

2. Choose Object > Envelope Distort > Make with Warp.

TIP When you select 
art you’ve enveloped 

with a warp, you can adjust 
the warp settings directly 
from the Control panel.
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3. In the Warp Options dialog box that appears, choose a Warp style, and 

adjust the settings as necessary. Click OK to apply the Envelope distor-

tion (Figure 2.35).

4. Using the Mesh tool or the Direct Selection tool, move the individual 

mesh points and their control handles to apply distortion to your art-

work (Figure 2.36).

Overall, this third method of creating an envelope mesh is a combination 

of the fi rst two. You start with an initial distortion using a warp, and then 

you complete the distortion by editing the envelope as a mesh object. This 

method is useful for times when you want to use a warp shape but need 

the ability to tweak the distortion a bit—something that isn’t possible with 

the Warp effect. Refer to the sidebar “Envelopes vs. the Warp Effect” for an 

in-depth comparison of the Envelope and Warp effect distortion features.

Figure 2.35 Starting an 
Envelope distortion with 
a warp gives you a head 
start in getting the look 
you need.

Figure 2.36 Although the 
envelope starts out as a 
warp, you can add mesh 
points as needed to adjust 
the distortion to your liking.

TIP When a point 
type object is selected, 

you can quickly apply the 
Envelope Make with Warp 
function by clicking the 
icon that appears in the 
Control panel.
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Adjusting Envelope Distortion Settings

By default, Illustrator tries to create Envelope distortions as quickly as pos-

sible. Artwork that takes longer to distort, such as live effects, gradients, or 

patterns, is not distorted at all, and images or other complex artwork may 

not fi t perfectly within the envelope shape. Don’t assume that the Envelope 

distortion in Illustrator is below par; rather, select your envelope, and choose 

Object > Envelope Distort > Envelope Options. Alternatively, you can 

click the Envelope Options button that appears in the Control panel. This 

opens the Envelope Options dialog box, where you can adjust the settings 

that Illustrator uses to create Envelope distortions (Figure 2.37).

Figure 2.37 The Envelope 
Options dialog box gives 
you greater control over 
how Illustrator distorts art-
work within envelopes.

The following are the options you can set in the Envelope Options dialog box:

• Rasters. If your envelope contains a raster image, you can choose 

to turn antialiasing on or off. With antialiasing turned on, Illustrator 

produces smoother and nicer-looking art, at the expense of longer 

calculations and render times. When nonrectangular shapes are used 

as an envelope (as is usually the case), you can choose to have any raster 

art enclosed by a clipping mask or a transparency alpha channel.

• Fidelity. When Illustrator performs an Envelope distortion, it has to 

stretch or squeeze artwork to fi t within another shape. During this pro-

cess, Illustrator may make small adjustments to the art so that it doesn’t 

become overly complex. A higher-fi delity setting forces Illustrator to 

preserve the integrity of the artwork as much as possible, which may 

produce more anchor points but results in fi nal distorted art that closely 

matches the original. A lower-fi delity setting gives Illustrator more 

wiggle room to create fi les that print and save faster.
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• Distort Appearance. If the artwork you’re placing into an envelope con-

tains live effects or multiple fi ll or stroke attributes, those appearances 

become distorted by the envelope shape by default. You must deselect 

the Distort Appearance option if you want the Envelope distortion to be 

applied just to the vector paths.

• Distort Linear Gradients. If the artwork you’re placing into an 

envelope contains linear gradients, the gradient does not become dis-

torted by the envelope shape by default. You must select the Distort 

Linear Gradients option if you want the Envelope distortion to affect 

the gradient fi ll.

• Distort Pattern Fills. If the artwork you’re placing into an envelope 

contains a pattern fi ll, that fi ll does not become distorted by the enve-

lope shape by default. You must select the Distort Pattern Fills option if 

you want the Envelope distortion to affect the pattern.

Editing Envelopes and Their Contents

It is certainly no coincidence that many of the features in Illustrator exhibit 

live functionality, thus allowing you to perform edits without having to 

re-create art. Live effects, symbols, Live Trace, Live Paint, and Compound 

Shape modes are all examples of effects that are live and can be edited at any 

stage of the workfl ow. Envelope distortion is no exception. Once you apply 

an Envelope distortion using any of the three methods described earlier, you 

can continue to adjust either the envelope itself or the artwork it contains.

Illustrator manages the process of editing envelopes and their contents by 

giving you two distinct modes in which to work. At any one time, you can 

work with the envelope shape, or you can change modes and edit the con-

tents of the envelope. Unfortunately, Illustrator doesn’t clearly identify the 

difference between these two modes, so we’ll take a closer look at how you 

can edit Envelope distortions and the artwork within them.

When you fi rst create a new Envelope distortion, Illustrator is in the 

Edit Envelope mode. In this mode, you can select and edit the shape of 

the envelope, but you have no way to access the art that is distorted within 

the envelope. If you look at the Layers panel, you’ll notice an object named 

Envelope, but you won’t fi nd the distorted artwork listed anywhere 

(Figure 2.38).
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Figure 2.38 The Layers 
panel lists only one 
object on Layer 1—
the Envelope object.

To edit the contents of an envelope, select it on your artboard, and choose 

Object > Envelope Distort > Edit Contents, or press Command-Shift-V 

(Ctrl-Shift-V). Doing so puts Illustrator into the Edit Contents mode, 

where you can select the artwork and edit it as normal. In the Edit Contents 

mode, you cannot adjust, or even select, the envelope. If you look at the 

Layers panel, you’ll see that the Envelope object now contains a triangle 

to the left of its name, which you can click to reveal the objects contained 

within the envelope (Figure 2.39). This triangle is your only clue as 

to which mode you are in. If you see the disclosure triangle, you’re in 

Edit Contents mode, and if you don’t, then you are in Edit Envelope mode. 

If you are in Edit Contents mode and want to return to Edit Envelope 

mode, use the same keyboard shortcut mentioned earlier, or choose 

Object > Envelope Distort > Edit Envelope.

Figure 2.39 When 
you’re in Edit Contents 
mode, Illustrator 
reveals the artwork 
within the Envelope 
object on Layer 1.

Keep in mind that Illustrator maintains each Envelope distortion in your fi le 

as a separate entity. Therefore, it’s entirely possible to have one envelope in 

Edit Envelope mode and have another envelope in Edit Contents mode.

TIP When you’re edit-
ing the contents of an 

envelope, you might fi nd it 
easier to make edits to your 
art with Smart Guides turned 
on. The Object Highlighting 
feature of Smart Guides 
allows you to quickly fi nd and 
see the art you are editing.

NOTE You can also 
toggle between 

editing an envelope and its 
contents by clicking the Edit 
Envelope and Edit Contents 
buttons that appear in the 
Control panel. Alternatively, 
you can double-click an 
envelope with the Selection 
tool to toggle between the 
two editing modes.
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Releasing and Expanding Envelopes

At any time, you can select an existing envelope and choose Object > 

Envelope Distort > Release, which returns the artwork to an undistorted 

state. In addition, you can choose Object > Envelope Distort > Expand, 

which applies the Envelope distortion to the artwork itself. You can then 

edit the distorted paths freely, although you won’t be able to edit or change 

the Envelope distortion after this point.

Envelopes vs. the Warp Eff ect

After learning how to apply some of the Envelope distortion features—
especially the Make with Warp method—you may wonder how these kinds 
of distortions diff er from the Warp eff ect distortions covered in Chapter 7, 
“Working with Live Eff ects.”

Although it’s true that both the Warp eff ect and Envelope distortions are live in 
that you can edit them after you’ve applied them, they don’t behave the same 
way. The Warp eff ect, which appears in the Eff ect menu, exhibits the same 
behavior as any other live eff ect. That means you can apply the Warp eff ect to 
any object, to any group, or even to an entire layer. Because live eff ects appear 
listed in the Appearance panel, you can apply warps to individual parts of an 
object (that is, just to the stroke). In addition, you can save a warp in a graphic 
style so you can easily apply it to other objects.

On the other hand, Envelope distortions give you complete control over the 
shape of your overall distortion, and using mesh points, you can even control 
how the interior artwork is distorted. Overall, envelopes off er a level of control 
that is simply not possible with the Warp eff ect. After all, the Warp eff ect con-
tains only 15 shapes to choose from, and these cannot address every design 
need. Generally, the Warp eff ects are great for quick adjustments to artwork, 
whereas envelopes excel at distortions that require individual attention.

CREATING TRANSITIONS WITH
BLENDS
By defi nition, a blend is the result of two or more items that are combined. 

In Illustrator, a blend is a set of at least two objects that morph into each 

other. In an example where you are blending two objects, Illustrator gener-

ates new shapes that appear between the two objects, making it seem like 
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one of the objects is turning into the other. The iterations that are created 

between the two main objects (also referred to as key objects) are called steps, 

and as you’ll learn shortly, Illustrator gives you control over how many steps 

make up each blend (Figure 2.40).

Although at fi rst glance it may seem like creating blends is something 

reserved for highly specialized tasks, the reality is that you can use blends 

for many different reasons. In fact, back in the day, before gradients were 

introduced to Illustrator, blends were the only way you could create color 

gradations. Here’s a list of some other common uses for blends in Illustrator: 

• Creating shading effects. You can use blends to create photorealistic 

shading effects. Because blends can be created using any vector shape, 

you can create customized gradations not only in color but in shape as 

well (Figure 2.41). This gives blends a distinct advantage over gradients.

• Creating animations. When creating animations in Illustrator, you 

can use a blend to tween steps between objects, saving you from having 

to create the necessary keyframes yourself (Figure 2.42 on the follow-

ing page). Tweening is a term used in animation to defi ne the steps that 

appear when showing movement or one object morphing into another. 

Figure 2.40 A blend in 
Illustrator consists of key 
objects and blend steps. 
A straight line, called the 
spine, connects the key 
objects.

Figure 2.41 By blending 
two shapes, you can get 
realistic shading in a way 
that is not possible with 
linear or radial gradients.
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In Chapter 13, “Web and Mobile Design,” you will learn how to export 

animated SWF (Flash) fi les directly from Illustrator.

• Distributing objects. If you need to repeat art across an area or along 

the curve of a path, you can use a blend to evenly distribute a specifi c 

number of steps.

You can’t blend images or Area Type objects (text enclosed within a shape), 

but you can blend just about anything else—including symbols and groups. 

In fact, you can even blend between objects that have different Live Effects 

settings; Illustrator blends the settings of those effects as well. Blends are 

pretty powerful, but don’t worry, they are easy to work with.

Creating a Blend
If there were always just one way to perform a particular function in 

Illustrator, there would be less of a need for books like this one. But as 

you’ve seen up to this point in this book, Illustrator offers a variety of ways 

to perform tasks, each of which offers specifi c benefi ts. In the case of blends, 

Illustrator allows you to generate a blend from a menu item, or you can 

achieve fi ner control over the result of your blend using the Blend tool.

Using Method 1: Using the Blend Menu

Creating a blend using the Make command is the quickest way. You 

simply select at least two objects and choose Object > Blend > Make 

(Command-Option-B) [Ctrl-Alt-B]. Using this method, Illustrator takes 

Figure 2.42 By blending 
two symbols with diff erent 
opacity levels, Illustrator 
creates the necessary steps 
to create an animation.
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the bottommost object in your selection and creates a blend with the next 

object up in the stacking order.

Using Method 2: Using the Blend Tool

Creating a blend using the Blend tool takes a few extra clicks of the mouse 

but gives you the ability to control the blend in ways that the menu com-

mand can’t. You begin by selecting the objects you want to blend, and then 

you choose the Blend tool (W) from the Tools panel. Then, click an anchor 

point once in the fi rst object to defi ne where you want the blend to start, 

and click an anchor point in the second object where you want the blend to 

end. If you have more than two objects to blend, keep selecting an anchor 

point from each object until the blend is created.

Unlike the fi rst method where Illustrator created the blend based on stack-

ing order, this method allows you to control in which order key objects 

appear in the blend. Additionally, if you click an anchor point near the top 

of one object and then choose an anchor point toward the bottom of the 

next key object, Illustrator rotates and modifi es the intermediate steps of 

the blend to match the orientation of the anchor points.

Editing a Blend
Once you’ve created a blend, you can edit it in a variety of ways. It should 

come as no surprise to you at this point to learn that blends are live in 

Illustrator, meaning you can adjust them even after you apply the blend. 

To do so, using the Direct Selection tool, click a key object, and change 

its color, shape, position, attributes—whatever. When you do, Illustrator 

simply redraws the blend to incorporate the change.

You will notice that you can’t select or edit the intermediate steps that 

Illustrator creates to form the blend. This is an attribute of the live 

functionality of the blend—you can access the steps only by expanding 

the blend (see “Releasing and Expanding Blends” later in this chapter). 

However, you can control how Illustrator draws blend steps by selecting 

a blend and choosing Object > Blend > Blend Options.

In the Blend Options dialog box, you have two general settings:

• Spacing. The Spacing setting determines the number of blend steps 

that are created. When you choose Smooth Color, Illustrator creates as 

NOTE In case you’re 
ever playing some-

thing like the Adobe edition 
of Trivial Pursuit, you’ll fi nd 
this information helpful: The 
3D eff ect in Illustrator uses 
blends to create lighting and 
shading eff ects.

NOTE Illustrator can 
have a maximum of 

256 steps in a blend. The 
number of steps that appear 
in a blend has a direct impact 
on screen redraw speed, print 
performance, and fi le size.
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many steps as are necessary to display a smooth and gradual transition 

between key objects (Figure 2.43). The Specifi ed Steps setting allows 

you to defi ne exactly how many blend steps Illustrator creates. Using 

a higher number of steps results in a smoother transition, whereas a 

lower number allows you to see the individual steps in the blend. The 

Specifi ed Distance setting allows you to specify how far apart each step 

appears from the next. When you want to create shading techniques 

using blends, the Smooth Color option provides the best results. When 

creating steps for a Flash animation, specifying fewer steps will help 

playback performance.

• Orientation. The Orientation setting controls the baseline angle of 

each step in your blend. With the Align to Page setting, each blend step 

aligns parallel to the bottom of the page, even if the path is curved or 

diagonal. With this setting, all blends steps share the same orientation. 

In contrast, the Align to Path setting aligns the baseline of each blend 

step to the angle of the path. With this setting, you’ll see that each blend 

step has a different orientation (Figure 2.44).

Replacing the Spine of a Blend

As we briefl y mentioned earlier, you’ll notice a straight path that connects 

the key objects in a blend. This path is referred to as the spine of the blend. 

The individual steps that are created in a blend follow along the spine as 

Figure 2.43 The Blend 
Options dialog box off ers 
spacing and orientation 
options for blending.

Figure 2.44 On the left, the 
blend is set to the Align to 
Page option. The blend on 
the right is set to the Align 
to Path orientation option.
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they connect the two outer objects. The spine is an editable path, and you 

can use the Pen tool and the Direct Selection tool to edit the path if you 

want to alter the direction of the blend steps. In fact, the position of the 

control handles on a spine can control how the individual steps are distrib-

uted along the spine.

Additionally, you can perform a delicate operation—a spine transplant. 

You can draw any vector path, open or closed, and use it as the spine for 

an existing blend. To perform this surgery, select both the blend and the 

path you’ve created, and then choose Object > Blend > Replace Spine. 

Illustrator then uses the path you created as the spine for the blend, 

allowing you to customize how blend steps appear.

Reversing Blends

With a blend selected, you can choose Object > Blend > Reverse Spine to 

reverse the order of the key objects in your blend. This function is helpful 

when you want to fl ip the blend so that it travels in the opposite direction.

You can reverse the stacking order of the key objects in a blend by select-

ing the blend and choosing Object > Blend > Reverse Front to Back. This 

setting is especially useful for when you are using blends to create anima-

tions, which always travel in one direction. To have your animation play in 

reverse, you use this feature.

Releasing and Expanding Blends
As with Envelope distortions, you can select an existing blend and choose 

Object > Blend > Release, which removes the blend steps and returns 

the artwork to its original state (just the two original objects). In addition, 

you can choose Object > Blend > Expand, which applies the blend to the 

artwork itself, leaving the individual blend steps visible and available for 

editing. Once a blend has been expanded, it is no longer updated when the 

original two objects are edited.

There is yet another way to release a blend that is useful, especially when 

you’re creating frames for animations either that will be exported directly 

from Illustrator as SWF (Flash) fi les or that will be imported into video 

software such as Adobe After Effects, Adobe Premiere Pro, or Apple Final 

Cut Pro. This method actually expands the blend into its individual steps 
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and then places each step on its own layer. To release a blend in this way, 

you must follow these steps:

1. If it isn’t already open, choose Window > Layers to open your Layers 

panel.

2. In the Layers panel, highlight the blend object you want to release by 

clicking it once (Figure 2.45).

3. From the Layers panel menu (Figure 2.46), choose Release to Layers 

(Sequence), or choose Release to Layers (Build).

You should use the Sequence option when you want each layer to contain 

only one step, and you should use the Build option when you want to pro-

duce layers that add steps cumulatively to each layer that is created.

Figure 2.45 The Release 
to Layers command is a 
feature of the Layers panel, 
so selecting the blend on 
the artboard won’t help. You 
have to highlight the blend 
in the Layers panel.

Figure 2.46 Illustrator sup-
ports the ability to release 
artwork to layers using the 
Sequence or Build method.
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THREETechnical Drawing

In our experience, we’ve found that some people seem to 

“get” the concept of vector drawing immediately. Terms 

such as anchor points, control handles, and compound paths

all make perfect sense to these folks, and the Pen tool 

in Adobe Illustrator CS4 is a natural extension of their 

imagination and creativity. They spend as much time in 

Outline view as they do in Preview mode. These “people 

of the path,” if you will, possess an analytical view, and 

they can visualize the vector “building blocks” that make 

up an overall graphic.

In this chapter, we’ll focus on the paths and anchor 

points that make up a vector shape, and we’ll get a grasp 

of all the tools you can use to create and modify these 

paths. The good news is that Illustrator has plenty of tools and functions 

that can help you create your masterpiece—or just a rectangle if that’s what 

you need.

The artwork featured throughout this chapter comes from John Woodcock 

(iStockPhoto; username: johnwoodcock).

67
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DRAWING PRIMITIVE VECTOR
SHAPES
Illustrator contains a healthy set of primitive vector drawing tools. In this 

case, primitive doesn’t mean “something simple” as much as it means “acting 

as a basis from which something else is derived.” Artists are taught to sketch 

using primitive shapes, such as rectangles and ovals, so that they can build 

structure; you can certainly apply similar techniques to drawing with vector 

shapes in Illustrator. Instead of trying to draw complex shapes, try to visual-

ize how you can combine simple shapes in a variety of ways to create more 

complex ones (Figure 3.1).

Figure 3.1 Rather than draw com-
plex elements from scratch, you 
can draw elements from a tree, for 
example, from basic circles. You can 
make the overall shape by adding 
multiple circles to each other (left), 
and you can create the detail by 
subtracting circles from each 
other (right).

The primitive drawing tools in Illustrator are split up between those that 

create closed-path vector objects and those that create open-path vector 

objects. Additionally, these tools are interactive in that you can specify or 

control certain settings while drawing shapes. To take advantage of this 

functionality, you choose a tool and begin drawing. As you hold down the 

mouse button, you’re able to make changes to the shape you’re creating, but 

once you release the mouse button, you commit to the shape. Let’s explore 

how this works.

Using Closed-Path Shape Tools
The closed-path tools in Illustrator comprise the Rectangle, Rounded 

Rectangle, Ellipse, Polygon, and Star tools, and they are all grouped 

together in the Tools panel (Figure 3.2). To create any of these shapes, 

choose the desired tool, click the artboard, and drag outward. While drag-

ging the pointer, you can add commands to adjust the shape interactively. 

See Table 3.1 for a list of these interactive commands.

NOTE The Flare tool 
that is used to create 

vector-based lens fl are eff ects 
is also grouped with the 
closed-path shape tools. A 
valid question is why the Flare 
tool is located here, but it’s 
diffi  cult to come up with an 
acceptable answer. The Flare 
tool is covered in detail in 
Chapter 4, “Creative Drawing.”
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Figure 3.2 The closed-path 
shape tools are all grouped 
with the Rectangle tool in 
the Tools panel.

Table 3.1 Drawing with Closed-Path Shape Tools

Interactive 

Command Rectangle Tool

Rounded 

Rectangle Tool Ellipse Tool Polygon Tool Star Tool

Keyboard 

Shortcut

M N/A L N/A N/A

Shift Constrains all sides 
to be equal, resulting 
in a perfect square.

Constrains all sides to 
be equal, resulting in 
a perfect square with 
rounded corners.

Constrains all arc 
segments to be 
equal, resulting 
in a perfect circle.

Constrains the 
bottom side to 
be parallel to the 
constrain angle.

Constrains the 
bottom two points 
to be parallel to the 
constrain angle.

Option (Alt) Draws the shape out 
from its center point 
instead of its corner.

Draws the shape out 
from its center point 
instead of its corner.

Draws the shape out 
from its center point 
instead of its corner.

N/A N/A

Command 

(Ctrl)

N/A N/A N/A N/A Adjusts the inner 
radius of the shape.

Spacebar Allows you to 
reposition the 
shape on the 
artboard.

Allows you to 
reposition the shape 
on the artboard.

Allows you to 
reposition the shape 
on the artboard.

Allows you to 
reposition the 
shape on the 
artboard.

Allows you to 
reposition the shape 
on the artboard.

Tilde Creates multiple 
copies of the shape.

Creates multiple 
copies of the shape.

Creates multiple 
copies of the shape.

Creates multiple 
copies of the shape.

Creates multiple 
copies of the shape.

Up Arrow N/A Increases the corner 
radius value.

N/A Increases the 
number of sides.

Increases the number 
of points.

Down Arrow N/A Decreases the corner 
radius value.

N/A Decreases the 
number of sides.

Decreases the 
number of points.

Right Arrow N/A Turns on the rounded 
corners.

N/A N/A N/A

Left Arrow N/A Turns off  the rounded 
corners.

N/A N/A N/A

Moving the 

Mouse

N/A N/A N/A Moving the mouse 
in a circular motion 
rotates the shape.

Moving the mouse 
in a circular motion 
rotates the shape.
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Using Open-Path Shape Tools

The open-path tools in Illustrator comprise the Line Segment, Arc, Spiral, 

Rectangular Grid, and Polar Grid tools, and they are all grouped together 

in the Tools panel (Figure 3.3). To create any of these shapes, choose 

the desired tool, click the artboard, and drag outward. While dragging 

the pointer, you can add commands to adjust the shape interactively. See 

Table 3.2 for a list of these interactive commands.

Figure 3.3 The open-path 
shape tools are all grouped 
with the Line tool in the 
Tools panel.

Interactive 

Command

Line Segment 

Tool Arc Tool Spiral Tool Rectangular Grid Tool Polar Grid Tool

Keyboard 

Shortcut

\ (backslash) N/A N/A N/A N/A

Shift Constrains the 
path to angles 
in 45-degree 
increments.

Constrains the X and 
Y axes, creating a 
perfect quarter circle.

Constrains the 
path to angles 
in 45-degree 
increments.

Constrains the grid to a 
perfect square.

Constrains the grid to 
a perfect circle.

Option (Alt) N/A Draws the arc out 
from its center point 
instead of its corner.

Increases the 
length of the path.

Draws the grid out from its 
center instead of its corner.

Draws the grid 
out from its center 
instead of its corner.

Command 

(Ctrl)

N/A N/A Adjusts the decay 
of the path (making 
the winds of the 
spiral more drastic).

N/A N/A

Spacebar Allows you to 
reposition the 
path on the 
artboard.

Allows you to 
reposition the path 
on the artboard.

Allows you to 
reposition the path 
on the artboard.

Allows you to reposition 
the path on the artboard.

Allows you to 
reposition the path 
on the artboard.

Tilde Creates multiple 
copies of the path.

Creates multiple 
copies of the path.

Creates multiple 
copies of the path.

Creates multiple copies of 
the path.

Creates multiple 
copies of the path.

Up Arrow N/A Increases the slope of 
the curve to make it 
more convex.

Increases the num-
ber of segments in 
the spiral.

Increases the number of 
rows in the grid.

Increases the number 
of concentric dividers.

NOTE Even though 
they are grouped with 

the open-path tools, the Rect-
angular Grid and Polar Grid 
tools create a combination of 
both open and closed paths.

Table 3.2 Drawing with Open-Path Shape Tools
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Interactive 

Command

Line Segment 

Tool Arc Tool Spiral Tool Rectangular Grid Tool Polar Grid Tool

Down Arrow N/A Decreases the slope 
of the curve to make 
it more concave.

Decreases the 
number of 
segments in the 
spiral.

Decreases the number 
of rows in the grid.

Decreases the number 
of concentric dividers.

Right Arrow N/A N/A N/A Increases the number of 
columns in the grid.

Increases the number 
of radial dividers.

Left Arrow N/A N/A N/A Decreases the number of 
columns in the grid.

Decreases the number 
of radial dividers.

Moving the 

Mouse

N/A N/A Moving the mouse 
in a circular motion 
rotates the path.

N/A N/A

C and X Keys N/A C draws the arc as a 
closed shape instead 
of an open path.

N/A C skews the columns in 
the grid to the left; 
X skews the columns in 
the grid to the right.

C skews the 
concentric dividers 
toward the center; 
X skews away from 
the center.

F and V Keys N/A F fl ips the X and Y 
axes of the path.

N/A F skews the rows in the 
grid to the top; V skews 
the rows in the grid to the 
bottom.

F skews the radial 
dividers toward the 
left; V skews them to 
the right.

Drawing by Numbers

If you’re an aspiring artist, you can buy a paint-by-number kit that uses 

numbers to indicate where colors are supposed to go, taking the guesswork 

out of the design process. Although being free to create is certainly a good 

thing, you don’t want to be guessing when you’ve been asked to create a 

shape that’s an exact size. The methods of drawing we’ve discussed to this 

point are purely for those in a creative state of mind. As you create each 

shape, your mind is saying, “Yeah, that’s about right.” However, sometimes 

you are required to specify exact dimensions for shapes, and Illustrator can 

be precise up to four decimal places.

To create any shape numerically, select the tool you need, click the artboard 

once, and immediately release the mouse button. A dialog box appears, 

letting you specify exact values for the shape or path you want to create 

(Figure 3.4 on the next page). For most shapes, this action uses the point 

where you clicked the artboard as the upper-left corner of the shape. To 

draw a shape with its center point at the place you click, press the 

Option (Alt) key while clicking, and then drag.

Table 3.2 Drawing with Open-Path Shape Tools (continued)



CHAPTER 3: TECHNICAL DRAWING72

In Chapter 2, “Selecting and Editing Artwork,” we discussed how you can 

use the Control panel or the Transform panel to change an existing object’s 

dimensions numerically as well.

DRAWING AND EDITING FREE-FORM
VECTORS
Strip away the cool effects. Forget all the fancy tools. Ignore the endless 

range of gradients and colors. Look past the veneer of both print and web 

graphics. What you’re left with is the basis of all things vector—the anchor 

point. You can learn to master every shape tool in Illustrator, but if you 

don’t have the ability to create and edit individual anchor points, you’ll fi nd 

it diffi cult to design freely.

Illustrator contains a range of tools that you can use to fi ne-tune paths and 

edit anchor points. At fi rst, it might seem like these all perform the same 

functions, but upon closer inspection, you’ll fi nd each has its use.

Mastering the Pen Tool
Just the mention of the Pen tool sends shivers down the spines of designers 

throughout the world. Traditionally, the Illustrator Pen tool has frustrated 

many users who have tried their hand at creating vector paths. In fact, when 

the Pen tool was introduced in the fi rst version of Illustrator in 1987, word 

had it that John Warnock, the brain and developer behind Illustrator, was 

the only one who really knew how to use it. In truth, the Pen tool feels 

more like an engineer’s tool than an artist’s tool.

But don’t let this prevent you from learning to use it.

Learning how to use the Pen tool reaps numerous rewards. Although the 

Pen tool fi rst appeared in Illustrator, you’ll fi nd it in Adobe Photoshop CS4, 

Adobe InDesign CS4, Adobe Flash CS4 Professional, Adobe Fireworks CS4, 

Figure 3.4 Clicking a blank 
area on an artboard or 
the canvas with a shape 
tool allows you to specify 
numeric values and create 
a shape precisely.

TIP When drawing 
new paths with the 

Pen tool, it’s best to set your 
fi ll to None and your stroke to 
black. Otherwise, Illustrator 
will fi ll the path as you create 
it, making it diffi  cult to see 
your work.
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and even Adobe After Effects CS4; if you know how to use it in Illustrator, 

you can use it in all the other applications as well. You can use the Pen tool to 

tweak any vector path to create the exact shape you need, at any time. Addi-

tionally, if you give yourself a chance, you’ll see that there’s a method to the 

madness. After learning a few simple concepts, you’ll quickly realize that any-

one can use the Pen tool.

Usually, when new users select the Pen tool and try to draw with it, they 

click and drag it the same way they might use a normal pen on paper. They 

are surprised when a path does not appear onscreen; instead, several handles 

appear. At this point, they click again and drag; now a path appears, but it 

is totally not where they expect it to appear. This experience is sort of like 

grabbing a hammer by its head and trying to drive a nail by whacking it 

with the handle—it’s the right tool, but it’s being used in the wrong way.

While we’re discussing hammers, let’s consider their function in producing 

string art. When you create a piece of string art, you fi rst start with a piece 

of wood, and then you hammer nails part of the way into it, leaving each 

nail sticking out a bit. Then you take colored thread and wrap it around the 

exposed nail heads, thus creating your art. The design you create consists of 

the strands of colored thread, but the thread is held and shaped by the nails. 

In fact, you can say that the nails are like anchors for the threads.

When you’re using the Pen tool in Illustrator, imagine you’re hammering 

those little nails into the wood. In this situation, you aren’t drawing the 

shape itself; instead, you’re creating the anchors for the shape—the Bézier 

anchor points. Illustrator draws the thread—the path—for you. If you think 

about drawing in this way, using the Pen tool isn’t complicated at all. The 

hard part is just fi guring out where you need to position the anchors to get 

the shape you need. Learning to position the anchors correctly comes with 

experience, but you can get started by learning how to draw simple shapes 

(Figure 3.5).

TIP Holding the Shift 
key while you click 

with the Pen tool constrains 
paths to 45-degree incre-
ments. Additionally, you can 
choose View > Smart Guides 
to have Illustrator display 
helpful guides and hints as 
you move the pointer (see 
Chapter 1, “Creating and 
Managing Documents,” for 
more information about 
smart guides).

Figure 3.5 Even though it 
may appear complex at fi rst 
glance, this skyline is made 
up of of straight paths, 
curved paths, and combina-
tion paths—which consist 
of both straight lines and 
curves.
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Anatomy of a Vector Object

To truly comprehend how vectors work, you need a solid understanding of 
the terminology. Otherwise, the words are meaningless and don’t make sense 
when you try to apply techniques that use these terms. Overall, when working 
in Illustrator, there are two parts of an object that you’re concerned with. The 
vector path defi nes the object in a mathematical way using anchor points. This 
path doesn’t print. The appearance of a path determines how it will look when 
printed and is defi ned with attributes such as fi lls and strokes (Figure 3.6).

Figure 3.6 Vector graphics comprise of paths and appearances.

Drawing Objects with Straight Paths

Follow these steps to use the Pen tool to draw a straight path:

1. Select the Pen tool, and click the artboard once—do not click and drag.

Clicking once with the Pen tool creates a corner anchor point. This anchor 

point is the start point of your path.

Appearance

Fill

Stroke

Path

Smooth Anchor Point

Control Handle 
(aka Direction Handle)

Combination Point 
(aka Change-Direction Point)

Corner Anchor Point
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2. Now, move your pointer to where you want the end point of your path 

(Figure 3.7); click again to defi ne a second corner anchor point.

Figure 3.7 After you’ve 
clicked once to create the 
fi rst anchor point, move 
your pointer to the location 
where you want the second 
anchor point.

Once you create this second point, Illustrator automatically connects the 

two anchor points with a straight path, completing the line (Figure 3.8).

Figure 3.8 Clicking a 
second time creates the 
path between the two 
anchor points.

For now, the fi rst concept becomes clear: When you’re using the Pen tool, 

clicking—not dragging—is what defi nes a corner anchor point.

At this point, with your Pen tool still selected, Illustrator assumes you 

want to add points to your path. By clicking again, you can create a 

third corner anchor point, and if you do, Illustrator draws a path to 

connect the second anchor point to the newly created one (Figure 3.9).

Figure 3.9 Each successive 
click with the Pen tool con-
tinues to create additional 
path segments.

Admittedly, this behavior may prove confusing because you may have been 

expecting to start a new path rather than add to the existing one. To start a 

new path, you fi rst have to deselect the current path.
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Ending a Path

The easiest way to end a path is to click a blank area on the artboard while 

pressing the Command (Ctrl) key, which temporarily changes your tool to 

the Selection tool. Once you’ve deselected the path, you can click with the 

Pen tool to start drawing a new path.

So, now you understand the second concept: When drawing an open path 

with the Pen tool, each click adds another anchor point to the path until you 

deselect the path, which is how you indicate to Illustrator you’ve fi nished 

that path.

Drawing a Closed Path

You can indicate that you’ve fi nished drawing a path in another way—by 

drawing a closed path. Until now, you’ve been creating open paths, but now 

you can try to create a closed shape—in this case, a triangle, such as one that 

might appear to draw the top of a building:

1. With nothing selected, select the Pen tool, and click once to defi ne the 

fi rst anchor point of the triangle.

2. Move the pointer to another part of the artboard, and click again to 

defi ne the second point.

3. Now move the pointer once more, and click to defi ne a third anchor 

point (Figure 3.10).

A triangle has three sides, so you have all the anchor points you need, 

but at the moment, the object you’ve drawn is an open path.

4. To complete the shape, move the pointer so it rests directly on the 

fi rst anchor point that you defi ned, and click once to close the path 

(Figure 3.11).

At this point, if you click again elsewhere on the artboard, the Pen tool 

starts drawing a new path.

This brings you to the third concept: When you create a closed path, the next 

click with the Pen tool starts a new path.
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Figure 3.10 A triangle 
needs three anchor 
points; the third click 
creates two path 
segments.

Figure 3.11 Clicking 
the fi rst anchor point 
completes the shape. 
This is the shape after 
it has been closed.

If this sounds confusing, try it once or twice, which should help—especially 

if you pay attention to your Pen tool pointer. When you’re using the Pen 

tool, the pointer changes as you draw, helping you understand the three 

concepts you’ve just learned. When the Pen tool is going to start creating 

a new path, a small x appears at the lower right of the icon; when the Pen 

tool is going to add anchor points to an existing selected open path, no icon 

appears next to it; and when the Pen tool is going to close a path, a small o

appears at the lower right of the icon (Figure 3.12).

Drawing Objects with Curved Paths

The paths you’ve drawn up until this point were all made up of corner 

anchor points, which are connected with straight lines. Of course, you’ll 

also need to create paths with curved lines, like those used to defi ne the 

trees that appear in the skyline artwork; this section explains what you 

need to know.

Figure 3.12 The Pen tool 
subtly indicates which func-
tion it will perform.

NOTE By now, you 
understand the state-

ment we made earlier about 
how drawing the path is the 
easy part of using the Pen 
tool. The hard part is trying 
to fi gure out where to place 
the anchor points to get the 
path you want.

Clicking starts 
a new path.

Clicking removes an 
anchor point from 
an existing path.

Clicking adds a new 
anchor point and a 
segment to a path.

Clicking adds an 
anchor point to an 

existing path.

Clicking begins 
editing a selected 

open path.

Dragging changes 
the direction 
of the path.

Clicking closes 
an existing path.
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Curves are defi ned with direction handles that control how the paths between 

anchor points are drawn. When you want to draw a curved path, you follow 

the same basic concepts you learned for creating straight paths, with one 

additional step that defi nes the direction handles.

1. To draw a curved path, select the Pen tool, and make sure an existing 

path isn’t selected. Position your pointer where you want to begin your 

path, and then click and drag outward before releasing the mouse but-

ton (Figure 3.13).

This action creates a smooth anchor point where you fi rst clicked and 

defi nes direction handles at the point where you released the mouse.

2. Now position your pointer where you want the next anchor point to be, 

and click and drag once again (Figure 3.14).

Using the direction handles as guidance, Illustrator draws a curved path 

connecting the two smooth anchor points.

3. Move your pointer to another location on your artboard, and click and 

drag to create a third smooth anchor point.

4. Click and drag the fi rst anchor point to close the path (Figure 3.15).

Figure 3.13 Clicking and 
dragging with the Pen tool 
defi nes the smooth anchor 
point and, at the same 
time, lets you position the 
direction handles.

Figure 3.14 Clicking and 
dragging a second time 
completes a curved path 
segment between the fi rst 
two anchor points and 
defi nes the next curve 
that will be drawn.
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Figure 3.15 Clicking and 
dragging the fi rst anchor 
point completes the 
curved shape.

We can now defi ne a fourth concept: Clicking and dragging with the Pen tool 

creates a smooth anchor point and defi nes its direction handles.

Learning to anticipate how the placement of direction handles creates the 

path you want takes time, but you don’t have to get it right the fi rst time. 

Once you create a smooth anchor point, you can switch to the Direct 

Selection tool and click and drag the anchor point to reposition it (Figure 
3.16). Additionally, when you select a smooth anchor point at any time, the 

direction handles become visible for that anchor point, and you can use the 

Direct Selection tool to reposition those as well.

Figure 3.16 Using the 
Direct Selection tool, you 
can change the position 
of anchor points and direc-
tion handles to adjust a 
curved path.

Drawing Objects with Both Straight and Curved Paths

In the real-design world, shapes consist of both straight and curved lines. 

You can use the knowledge you’ve gained up to this point to create paths 

that contain a mixture of both corner and smooth anchor points. Basically, 

you know that clicking with the Pen tool produces a corner anchor point 

and a straight line, and you know that dragging with the Pen tool produces 

a smooth anchor point and a curved line.

TIP Even the most 
experienced Illustrator 

artists need to switch to the 
Direct Selection tool to tweak 
the curves they create, which 
can be time-consuming. To 
get around this, you can press 
the Command (Ctrl) key while 
the Pen tool is active to 
temporarily access the last-
used selection tool. While the 
Selection tool is active, click 
and drag the anchor points or 
direction handles to adjust 
the path, and then release the 
key to continue creating more 
points with the Pen tool.
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Try drawing a path with both types of anchor points:

1. Select the Pen tool, and make sure you don’t have an existing path 

selected (look for the small x icon on the Pen tool pointer). Click once 

to create a corner anchor point.

2. Move your pointer, and click again to create a straight line (Figure 3.17).

3. Move your pointer, and click and drag to create a smooth anchor point.

You now have a single path that consists of both a straight line and a 

curve (Figure 3.18).

You can use the Convert Anchor Point tool to convert a corner anchor point 

to a smooth anchor point, and vice versa. To do so, choose the Convert 

Anchor Point tool (which is grouped with the Pen tool), and apply the same 

concepts you’ve learned. Click an existing anchor point once to convert it to 

a corner anchor point, and then click and drag an existing anchor point to 

pull out direction handles and convert it to a smooth anchor point.

Figure 3.17 You can begin 
a new path by creating two 
corner anchor points to 
make a straight line.

Figure 3.18 Adding a 
smooth anchor point 
creates a single path with 
both straight and curved 
path segments.
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Changing Direction on a Path

As you were creating smooth anchor points, you may have noticed that 

when you are creating or editing direction handles, a mirror effect occurs. 

On a smooth anchor point, the direction points are always opposite each 

other, and editing one seems to affect the other. Remember that the direc-

tion handles control how the path passes through the anchor point, so the 

direction handles are always tangential to the curve (Figure 3.19).

Figure 3.19 With a smooth 
anchor point, the direction 
handles are always tangen-
tial to the curve of the path.

Creating a Combination Point

You can, however, change the direction of a path as it passes through 

an anchor point:

1. Use the Direct Selection tool to select a smooth anchor point.

2. Switch to the Convert Anchor Point tool, and click and drag one 

of the direction handles (not the anchor point).

In essence, this creates a combination point that you can then 

continue to edit with the Direct Selection tool (Figure 3.20).

Figure 3.20 Clicking and 
dragging a direction handle 
with the Convert Anchor 
Point tool creates a combi-
nation anchor point.
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Creating a Combination Point as You Draw

To make life easier, you can create combination points as you draw with 

the Pen tool:

1. Start by clicking and dragging to create a smooth anchor point.

2. Move your pointer to a different position, and click and drag again to 

create another smooth anchor point and, hence, a curved path.

3. Now, position your pointer directly on the second anchor point you just 

created. You’ll notice that the Pen tool icon shows a small inverted v in 

its icon.

4. Click and drag the anchor point while holding the Option (Alt) key to 

drag out a single direction handle (Figure 3.21).

5. Move your pointer to another location, and click again; you’ll see that 

you’ve created a combination point.

Converting Type to Outlines

Overall, using the Pen tool takes some getting used to, and if you’re going 

to use Illustrator often, it’s best to practice. One of the best ways to learn 

is to reverse-engineer one that has already been created. You might fi nd it 

useful to convert some type to outlines (select a type object and choose 

Type > Create Outlines) to see how the anchor points are positioned in 

those shapes. Try to re-create them on your own, and get a feel for when 

you need a corner anchor point and when you need a smooth anchor point. 

The more you use the Pen tool, the easier it will be to use.

Figure 3.21 As you’re draw-
ing a path with the Pen tool, 
you can create a combina-
tion point by clicking and 
dragging the last anchor 
point of the path while 
holding the Option (Alt) key.
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Adding and Deleting Anchor Points
Because anchor points are used to defi ne paths, you must add and delete 

points from a path to achieve the shapes you need. You may think you can 

select an anchor point with the Direct Selection tool and simply press the 

Delete key on your keyboard, but doing this deletes a portion of the path 

(Figure 3.22). Although this may be useful at times, what you really want 

is to keep the path but remove the anchor point.

To delete an anchor point from a path without deleting the path, select the 

Delete Anchor Point tool, and click the anchor point once that you want to 

remove. Likewise, you can switch to the Add Anchor Point tool and click a 

selected path anywhere to add a new anchor point to the path (Figure 3.23). 

As an alternative, you can click the Remove Selected Anchor Points button 

in the Control panel. Note that this button will not appear when all anchor 

points of a path are selected.

Illustrator tries its best to help you get your work done, but sometimes its 

overzealousness gets in the way. By default, when you move your pointer 

over an existing path with the Pen tool, Illustrator, thinking you want to add 

a point to the existing path, conveniently switches to the Add Anchor Point 

tool. Likewise, when you move your pointer over an existing anchor point, 

Illustrator switches to the Delete Anchor Point tool, thinking you want to 

remove that anchor point. This is great, unless you wanted to start drawing 

a new path with the Pen tool on top of an existing selected path. You can 

turn this feature off by selecting the Disable Auto Add/Delete option in the 

General panel in Preferences, which politely tells Illustrator, “Thanks, but 

no thanks.”

Figure 3.22 Using the 
Direct Selection tool to 
select and delete an anchor 
point (left) also deletes the 
connecting path segments 
(center). The Delete Anchor 
Point tool keeps the path 
closed but removes the 
anchor point (right).

Figure 3.23 The Add 
Anchor Point tool enables 
you to add new anchor 
points to an existing path.
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Using the Reshape Tool
Using the Direct Selection tool to select individual points on a path results 

in some anchor points moving while others remain stationary. In most 

kinds of path editing, this is the desired behavior, although it can result in 

paths that appear distorted. At times, you may want to stretch a path by 

moving selected points, but you may also want other points to move as 

necessary to maintain a nondistorted path appearance. The Reshape tool 

(Figure 3.24) is perfect for this task.

1. Select a path using the Selection tool, and then select the Reshape tool.

2. Click an anchor point or part of a path that you want to act as a focus 

point when you stretch the path. This way, you’ll have the most control 

over how this focused point is moved.

You can also hold the Shift key and select additional focus points (as 

well as drag to marquee-select additional anchor points).

3. Once you’ve selected your focus points, click and drag one of the focus 

points to reshape the path.

You’ll notice that as the points that are in focus move, other points 

in the path move as well to keep the general proportion of the path 

(Figure 3.25).

The Reshape tool also comes in handy when you want to quickly turn a 

straight path segment into a curved one. To do so, select the Reshape tool, 

and click and drag any straight line segment (Figure 3.26).

Figure 3.24 The Reshape 
tool is grouped with the 
Scale tool in the Tools panel.

Figure 3.25 When some 
anchor points on a path 
are selected (left), dragging 
with the Direct Selection 
tool moves all the anchor 
points as a single unit (cen-
ter). With the Reshape tool, 
the selected anchor points 
move in a proportionate 
manner (right).
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Figure 3.26 The Reshape 
tool lets you “pull out” a 
curve from a straight line 
segment.

Cutting Paths with the Scissors and 
Knife Tools
When editing paths, you might fi nd you need to cut or split a path at a certain 

point. With the Scissors tool selected, you can click any topmost vector path 

(selected or not) to cut the path. In essence, you create two anchor points by 

doing this. The Scissors tool can cut only one path at a time.

The Knife tool is much like the Scissors tool, but you cut or split a path by 

dragging the pointer across a path instead of clicking it. Whereas using the 

Scissors tool results in an open path, using the Knife tool results in at least 

two closed paths. The Knife tool cuts through multiple paths when noth-

ing is selected but cuts through only objects that are selected (even if those 

selected objects appear beneath other objects).

Using the Scissors or Knife tool is unwieldy at best, and you may fi nd that 

if you’re doing a lot of path editing, you’ll get better results by using the 

Pathfi nder functions or by using Live Paint groups (Live Paint groups are 

covered in Chapter 4).

CREATING COMPOUND PATHS
A compound path is a single path that consists of more than one path. That 

sounds like an oxymoron, no? Think of the letter o in the alphabet. It appears 

to be a large circle with a smaller circle cut out from its center. How is such 

a shape created with Illustrator? The answer is by drawing two circles and 

combining them to become a single compound path. You do this by choos-

ing Object > Compound Path > Create. The result is a shape with a hole 

cut out of the middle (Figure 3.27 on the next page). Compound paths are 

treated as one entity, and therefore, both paths that make up this compound 

path take on the attributes of the bottommost path. If your compound path 

TIP If you fi nd you 
need to cut through 

multiple paths at once, 
you should look into Rick 
Johnson’s Hatchet tool that 
is part of his Cutting Tools 
plug-in (http://rj-graffi  x.com/
software/plugins.html).

TIP Holding the 
Option (Alt) key while 

dragging with the Knife tool 
constrains the tool so that it 
draws straight lines only.

NOTE You can also 
use the Reshape tool 

across multiple selected 
paths.

http://rj-graffix.com/software/plugins.html
http://rj-graffix.com/software/plugins.html
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consists of multiple shapes, Illustrator does its best to fi gure out which paths 

become hollow and which appear solid.

Illustrator uses one of two methods to decide which paths of a compound 

shape are hollow and which are solid. The default method is the Non-Zero 

Winding Fill Rule method; Illustrator can also use another method, the 

Even-Odd Fill Rule method. You’ll fi nd both of these buttons in the 

Attributes panel, and you can click them when a compound path is selected 

on the artboard. By default, Illustrator uses Non-Zero Winding Fill Rule 

and makes the bottommost path clockwise and all the other selected paths 

counterclockwise. For a detailed explanation of these rules, refer to the 

sidebar “How Fill Rules Work.”

When you create a compound path and click Non-Zero Winding Fill Rule, 

you can manually reverse the path direction to control whether a shape is 

hollow or solid. Use the Direct Selection tool to select the path you need, 

and click the appropriate button in the Attributes panel (Figure 3.28).

Figure 3.27 An example 
of a compound path. The 
outer shape of the eye 
allows objects that appear 
behind it (the yellow rays) 
to be visible.

NOTE When a path 
reverses direction in 

a shape such as in a fi gure 
eight, it can never be all 
clockwise or counterclock-
wise. In such a case, the 
direction of the region(s) 
with the largest total area 
is what defi nes the result.

Figure 3.28 When using 
the Non-Zero Winding Fill 
Rule method for a com-
pound path, you can also 
click Reverse Path Direction 
On or Reverse Path Direction 
Off  to control which parts of 
a shape are solid or hollow.

Compound Path

Reverse Path Direction On

Reverse Path Direction Off 

Non-Zero Winding Fill Rule

Even-Odd Fill Rule
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How Fill Rules Work

More math! When you compare them to each other, Even-Odd Fill Rule seems more intuitive than the Non-Zero 
Winding Fill Rule, and it is easier to predict which areas will be fi lled and which areas will be hollow. Although 
you have more fl exibility with Non-Zero Winding Fill Rule—because you can manually control the result—this 
rule is more diffi  cult to understand, and the result is harder to predict.

With Even-Odd Fill Rule, every area inside an even number of enclosed areas becomes hollow, and every region 
inside an odd number of enclosed areas becomes solid (Figure 3.29). An enclosed area refers to an area enclosed 
by another path (or the loop of a path in a self-intersecting shape). The outermost enclosed area is always 1, 
and therefore a regular path is fi lled (it is enclosed by a single area, which is an odd number).

1

1
2

2

3

2

1

1

2

3

Figure 3.29 When using the Even-Odd 
Fill Rule method, Illustrator labels areas 
using odd and even numbers to deter-
mine hollow and solid areas.

In contrast, the Non-Zero Winding Fill Rule method takes into account the direction of a path: An area 
enclosed by a clockwise loop counts as +1, and an area enclosed by a counterclockwise loop counts as –1. 
When the sum of these counts is zero, that area becomes hollow. When it is anything else, that area becomes 
solid (Figure 3.30). Because you can manipulate the path direction to get diff erent results from the same 
shapes, Non-Zero Winding Fill Rule is more fl exible, but it’s an exercise of trial and error since you can’t see the 
direction of a path on the artboard.

+1

-1
0

0

-1

0

+1

+1

0

-1

Figure 3.30 When using Non-Zero 
Winding Fill Rule, Illustrator takes 
into account the direction of the path 
when it determines the hollow and solid 
areas of a compound path. The arrows 
indicate path direction.

Although the results in most cases are the same whether you use the Non-Zero Winding Fill Rule or Even-Odd 
Fill Rule setting, sometimes the result is diff erent (Figure 3.31).

1

2

1

2

1

2

1 2

Figure 3.31 Some compound paths 
appear diff erent, depending on the 
fi ll rule specifi ed, especially with self-
intersecting paths.

—Special thanks to Teri Pettit of the Adobe Illustrator team for helping explain these rules.
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PERFORMING ADVANCED PATH
EDITING
Editing paths by hand can be tedious, but it doesn’t always have to be. Many 

times, you’ll need to perform certain edits on vector paths, such as remov-

ing extra anchor points from a complex path or splitting larger shapes into 

smaller ones of equal size. Other times, you may need to create outlines of 

strokes, create duplicate paths at larger or smaller sizes, or simply clean up 

loose paths and objects in your fi le. The good news is that Illustrator has a 

variety of useful path functions you can use to perform these kinds of tasks.

You can fi nd the functions covered here in the Object > Path menu.

Working with the Join and Average 
Commands
When you have two anchor points, you can use the Join command to con-

nect the two points with a straight path. Although this sounds simple, you 

must meet certain requirements for the Join command to work:

• Only two anchor points can be selected. If you have three or more 

anchor points selected, the Join command will not work (see next 

bullet item for the one exception to this).

• If all the anchor points on an open path are selected, the Join command 

draws a straight line between the start and end anchor points to close 

the shape.

• The selected anchor points cannot belong to different groups.

• The selected anchor points cannot be part of a graph object.

If the two anchor points overlap each other exactly, Illustrator combines 

the two anchor points and gives you the option of converting the resulting 

single point to a smooth point or a corner point (Figure 3.32).

NOTE The Join com-
mand in Illustrator can 

connect only two anchor 
points at a time. If you need 
to join multiple anchor points 
or paths at once, you should 
take a look at Rick Johnson’s 
Concatenate plug-in 
(http://rj-graffi  x.com/
software/plugins.html).

Figure 3.32 When you 
are trying to join two over-
lapping anchor points, 
Illustrator off ers you the 
option of creating a corner 
anchor point or a smooth 
anchor point.

http://rj-graffix.com/software/plugins.html
http://rj-graffix.com/software/plugins.html
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The Average function allows you to select at least two anchor points and 

reposition them by evenly dividing the space between them. You can aver-

age anchor points horizontally, vertically, or both horizontally and vertically. 

There is no limit to how many anchor points you can average at once.

You can also select two anchor points and press Command-Option-Shift-J 

(Ctrl-Alt-Shift-J) to perform a combined Average and Join function in 

one step.

Using the Outline Stroke Command
The stroke of a path adds thickness to the appearance of the path, but it’s 

an attribute you can’t physically select and manipulate on the artboard. 

However, you can select a path with a stroke and choose Object > Path > 

Outline Stroke; when you do, the stroke of that path expands to become 

a fi lled shape that you can then edit with the Pen tool. This allows you to 

tweak the path to make it appear as if the “stroke” is thinner and thicker 

in different places.

Sometimes you might want to convert a stroke to an outline for production 

reasons. If you have a fi nal version of a logo, converting all strokes to fi lled 

paths assures that it will scale properly under all circumstances, because 

users may forget to turn on the Scale Strokes & Effects setting.

Similar to what happens with patterns, when you apply transformations to 

objects that have strokes or effects applied, the default behavior is that only 

the shape is transformed, not the strokes or the effects. Selecting the Scale 

Strokes & Effects option in the  General panel of Preferences changes the 

default behavior so that strokes and effects are transformed as well. You can 

also fi nd this setting in the Scale Options dialog box.

Exploring the Offset Path Function
One of the most useful path functions in Illustrator is Offset Path. When 

used, this function creates a new vector path that is offset a user-specifi ed 

amount from the selected object(s). The original selected path is not 

affected. If you think about it, it’s like a scaling function—you can offset 

paths to be larger or smaller. But if you’ve ever tried to scale objects that 

aren’t a perfect circle or a square, you’ll know that doing so creates a shape 

of a different proportion. If you want to create an object that is the same but 

NOTE Older versions 
of Illustrator allow you 

to use the Average command 
to easily align point text 
objects. Unfortunately, that 
functionality is not present in 
Illustrator CS4.

TIP You can use Off set 
Path with negative val-

ues as well, which allows you 
to create paths that are off set 
inside existing paths.
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that has its edges enlarged evenly across the entire object, choose Object > 

Path > Offset Path (Figure 3.33).

Figure 3.33 Scaling an 
object (left) just makes a 
shape larger in size, but 
using Off set Path (right) 
gives a diff erent result. The 
gray area indicates the result 
of the function in each case.

Offset Path always creates a new closed path, so when the function is 

applied to an open path, a new closed path appears. If your intention is to 

have just an offset path along one side of your path, you’ll have to manually 

delete the parts of the new offset path as needed (Figure 3.34).

Figure 3.34 When applied 
to an open path, the Off set 
Path command creates a 
new closed path.

Simplifying Vector Paths
Earlier in this chapter, you learned how to use the Remove Anchor Point 

tool to delete existing anchor points from a path. Although that tool is use-

ful for removing a point or two from a path here or there, it’s quite another 

story when you’re trying to remove a lot of anchor points from a path.

You may fi nd that some vector paths contain unnecessary anchor points. By 

unnecessary, we mean you might be able to create the same path with fewer 

anchor points. Too many unnecessary anchor points on a path translates 

into more complex fi les that take longer to print and that are more diffi cult 

to edit.

NOTE Illustrator CS3 
featured an annoying 

bug that added numerous 
unnecessary anchor points 
when the Off set Path and 
Outline Path functions were 
used. That problem has been 
corrected in Illustrator CS4.
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You’ll often come across this problem when you’re importing fi les from CAD 

applications or when you’re using vector tracing programs such as Adobe 

Streamline (the Live Trace feature in Illustrator, covered in Chapter 12, 

“Working with Images,” does not suffer nearly as much from this problem).

To reduce the number of anchor points on a path, select the path, and 

choose Object > Path > Simplify. You can use the Preview option to see 

the results as you change the settings. The Simplify dialog box also gives 

you real-time feedback on the number of anchor points on the original path 

and the number of points using the current Simplify settings (Figure 3.35). 

The dialog box also offers the following settings:

• Curve Precision. This controls how closely the simplifi ed path matches 

the curves of the original selected path. A higher Curve Precision set-

ting results in a path that more closely matches the original but that has 

fewer anchor points.

• Angle Threshold. The Angle Threshold setting determines the 

smoothness of corners. If the angle of a corner point is less than the 

Angle Threshold setting, the corner point is not changed to a smooth 

anchor point.

• Straight Lines. This setting forces the simplifi ed path to use only 

corner anchor points, resulting in a path that is far less complex. Of 

course, the path may not match the original that well, but this option 

may be useful in a creative mind-set.

• Show Original. With the Show Original option selected, Illustrator 

displays both the original path and the simplifi ed result, allowing you 

to preview the difference between the two.

Figure 3.35 When using 
the Simplify function, you 
can see real-time feedback 
on the number of reduced 
anchor points and the 
integrity of the shape of 
the path.
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Using the Split Into Grid Feature
The Rectangular Grid tool is great for creating quick grids for illustration 

purposes, but with it you lack fi ne control, especially if you want to create 

gutters—space that appears between columns and rows. The Split Into Grid 

feature in Illustrator takes an existing shape and splits it into a specifi ed 

number of equal-sized rectangles.

With any vector object selected, choose Object > Path > Split Into Grid to 

open the dialog box. Select the Preview check box so you can see the results 

as you enter the values. Add rows and columns as needed, and also specify a 

value for the gutter. Illustrator automatically calculates the width and height 

values for you as you change the other values. At the bottom of the dialog 

box is an Add Guides check box, which draws guides at the borders of the 

rows and the columns.

Removing Unnecessary Elements with 
the Clean Up Feature
While working on revision after revision of a fi le, your document may 

become littered with stray anchor points, empty text objects, or unpainted 

objects (those that have neither a fi ll nor a stroke applied). Having these 

objects present in a fi le can be problematic for a variety of reasons. Empty 

text objects may contain references to fonts, and you, thinking that those 

fonts aren’t there, may forget to include them when you send your source 

fi les to prepress. Additionally, stray points in a fi le can cause fi les to export 

with unexpected size boundaries and could lead to corrupt fi les.

Choose Object > Path > Clean Up, and select which of these elements 

you want to automatically remove from a fi le. Be aware that, to Illustrator, 

a stray point is a single anchor point with no path. Some designers use 

Scatter or Art brush art by using the Paintbrush tool to click just once to 

place a single instance of a brush. Running the Clean Up command to 

delete stray points deletes these brush objects from a fi le as well. In reality, 

it’s better to use symbols rather than brushes for these types of tasks, some-

thing we’ll discuss in Chapter 9, “Drawing with Effi ciency.”

TIP The Split Into Grid 
feature is wonderful for 

creating layout grids and for 
creating columns you might 
use to create tables.



Chapter 
FourCreative Drawing

In the previous chapter, we discussed 

technical drawing. On the other side of 

the spectrum is creative drawing, where 

the focus is on the appearance of the path. 

In creative drawing, you couldn’t care less 

about anchor points and control handles. 

The importance here is color, composition, 

texture, and feel.

Unfortunately, many people get caught up in the technical drawing aspect 

of Adobe Illustrator CS4. After experiencing frustration in the attempt to 

grasp the concept of the underlying vector graphics structure, they never 

realize there’s an entirely different side of Illustrator—a side that not only 

can be fun to use but that can also be rather addictive.

A huge part of drawing creatively in Illustrator is the Live Paint feature that 

was introduced in Illustrator CS2. Live Paint not only “breaks the rules” of 

vector graphics, but it adds an entire new dimension to drawing and editing 

in Illustrator, so much so that traditional technical folks may want to pay 

close attention to this chapter—there’s something here for everyone.

The artwork featured throughout this chapter comes from Cheryl Graham 

(iStockPhoto; username: freetransform).

93
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DRAWING WITH LIVE PAINT
Although you can appreciate the power and precision that vector graphics 

have to offer, you can also appreciate how easy it is to use pixel-based paint 

programs such as Adobe Photoshop CS4 or Corel Painter to easily apply 

color to artwork. In a paint program, you can perform fl ood fi lls, in which 

you choose a color and use a paint bucket–like tool to fi ll areas of the illus-

tration with color. When working with vectors, you know that you have 

to create distinct paths and shapes in order to apply a fi ll to add color. In 

other words, you can’t just apply a fi ll to any arbitrary area on your artboard; 

rather, you need to select a distinct object to which to apply the fi ll. This 

need to create distinct objects can make drawing in Illustrator seem 

nonintuitive or time-consuming at best.

Live Paint introduces a new concept of working with vector paths, where 

you can colorize vectors and edit them without having to follow the tradi-

tional vector rules we’ve been covering up to this point. This feature makes 

it a lot easier to draw (and edit) in Illustrator. Let’s take a closer look.

Using Live Paint to Color Paths
First let’s draw something using Live Paint so you can get a feel for what 

the feature is all about. Then we’ll discuss how the feature works, and at 

that point, you’ll better understand how to use it in a meaningful way. The 

art itself may not be that exciting to look at, but the concepts you learn will 

be priceless.

1. Using the Line Segment tool, draw two parallel vertical lines and two 

parallel horizontal lines to create a rough outline of a rectangle. It 

doesn’t matter if the lines or spacing aren’t perfect; for this exercise, 

you just want to make sure the lines cross each other (Figure 4.1).

Figure 4.1 Using the Line 
Segment tool, you can 
create a simple tic-tac-toe 
graphic.
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2. Select the four lines, and select the Live Paint Bucket tool. As you 

move your pointer over the four paths, the paths become highlighted 

(Figure 4.2).

3. Click once to create a Live Paint group.

4. Pick a fi ll color (a solid color, gradient, or pattern) from the Control 

or Swatches panel, and move your pointer over the center area of the 

four paths.

The enclosed area in the middle becomes highlighted in red, which 

indicates an area that you can fi ll with color (Figure 4.3).

Figure 4.2 If you have 
the Live Paint Bucket tool 
selected, Illustrator shows a 
tool tip to create a Live Paint 
group when your pointer 
passes over a valid selection.

Figure 4.3 Illustrator’s Live 
Paint Bucket tool highlights 
areas that can be fi lled as 
your pointer moves over 
them, even if the Live Paint 
groups aren’t selected.
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5. Click once with the Live Paint Bucket tool to fi ll the highlighted area 

(Figure 4.4).

The resulting behavior is very “Photoshopesque”—you’ve fi lled an area

that looks like it is enclosed on all sides, but you didn’t apply a fi ll to an 

actual object.

6. Select the Direct Selection tool, select one of the anchor points on one 

of the paths, and move it just a bit.

Notice that the color in the area updates to fi ll the center (Figure 4.5). 

If you move one of the paths far enough so that it no longer touches the 

other paths, you’ll fi nd that the fi ll color disappears, because there is no 

longer an enclosed area to fi ll (Figure 4.6).

Figure 4.4 With one click of 
the Live Paint Bucket tool, 
you can fi ll areas that appear 
to be enclosed, even though 
there isn’t an actual vector 
object there.

Figure 4.5 The fi ll areas in a Live 
Paint group update automatically 
when you’re moving the paths with 
the Direct Selection tool.

Figure 4.6 When editing the paths in 
a Live Paint group, creating an opened 
area results in the loss of the fi ll.
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Understanding Live Paint groups

Let’s take a moment to understand how Live Paint works. When you select 

several overlapping paths or shapes and click them with the Live Paint Bucket 

tool, you are creating a Live Paint group. This is a special kind of group in 

which the object stacking order is thrown out the window. All objects in a 

Live Paint group are seemingly combined onto a single fl at world, and any 

enclosed area acts as a closed shape, which can be fi lled with color.

Although clicking several selected paths with the Live Paint Bucket tool (K) 

is the easiest way to create a Live Paint group, you can also select several paths 

and choose Object > Live Paint > Make (or press Command-Option-X 

[Ctrl-Alt-X]) to create a Live Paint group. Once you’ve created a Live Paint 

group, however, you may fi nd that you want to add paths or shapes to the 

group. To do so, draw the new paths, and use the Selection tool to select the 

existing Live Paint group and the new paths. Then choose Object > Live 

Paint > Add Paths. The new paths will become part of the group, and any 

intersecting areas will act as individual areas that you can fi ll with color.

Live Paint groups can also use the isolation mode feature that enables you to 

draw objects directly in existing groups. Using the Selection tool, double-

click an existing Live Paint group to enter isolation mode, indicated by a gray 

bar that appears across the top of the document window. Now switch to any 

shape or path tool to add paths directly to the Live Paint group (Figure 4.7). 

This ability to add paths directly to a Live Paint group is extremely power-

ful because it allows you to defi ne regions for color in just a few quick steps. 

Using Pathfi nder fi lters to create multiple overlapping shapes is no longer 

required for such tasks. Exit isolation mode by pressing the Escape key.

Figure 4.7 In group isolation 
mode, you can draw new paths 
in an existing Live Paint group to 
instantly create additional regions 
that can be fi lled with color.

TIP If you move a path 
so that an enclosed 

painted area becomes 
unpainted, Illustrator doesn’t 
remember that the region 
was fi lled with a color prior to 
the edit. Moving the path to 
its original position will not 
bring back the fi ll; you’ll need 
to reapply the fi ll color.

TIP You can use the 
Live Paint Bucket tool 

to color multiple regions with 
a single color in one step by 
clicking one region and drag-
ging the pointer across addi-
tional contiguous regions.
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It’s important to understand that the geometry of the paths themselves 

defi ne the paintable regions. So if you wanted, you could set the stroke 

attributes for the additional paths to none (Figure 4.8).

Figure 4.8 Even though 
the strokes aren’t visible, 
they still allow you to fi ll the 
areas they defi ne.

In the Tools panel, double-click the Live Paint Bucket tool to change its 

behavior. By default, the Live Paint Bucket tool affects only the fi ll of a path, 

but you can also set the tool to apply color to strokes as well (Figure 4.9). 

The Pointer Watch Preview option refers to the three boxes that fl oat above 

the Live Paint Bucket tool pointer (Figure 4.10). These boxes represent 

swatches that appear in the Swatches panel, and when the Live Paint Bucket 

tool is active, you can press the arrow keys on your keyboard to select a 

color swatch. This allows you to choose colors and quickly fi ll areas without 

having to return to the Swatches panel. Additionally, you can specify the 

color that the Live Paint tool uses to highlight closed regions.

Figure 4.9 You can set the 
Live Paint Bucket tool to 
apply color to strokes in a 
Live Paint group as well.

TIP When using the 
Live Paint Bucket tool, 

you can press the Shift key to 
toggle between painting the 
fi ll and painting the stroke.

NOTE Unfortunately, 
the Live Paint feature 

doesn’t work with paths that 
have brush attributes applied. 
If you do try to turn paths 
with brushes into a Live Paint 
group, the appearance of the 
brush will disappear, leaving 
just the appearance of 
the stroke. The exception to 
this rule is Illustrator's new 
Blob Brush, covered later in 
this chapter.

Figure 4.10 The three 
colors that appear above 
the Live Paint Bucket 
tool represent the selected 
color in the Swatches 
panel and each swatch 
immediately to the left 
and right of that swatch.
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Dealing with Gaps in Your Artwork

Until now, all the regions you were fi lling with color were completely 

closed. But what happens if your paths don’t exactly meet each other? That’s 

where the Gap Detection feature can really make a difference. You need to 

choose Object > Live Paint > Gap Options to control the settings for this 

feature (Figure 4.11). If you don’t have any Live Paint groups selected when 

you choose this option, the settings you pick become the default settings 

for all new Live Paint groups. You can specify different gap options for each 

selected Live Paint group in a document as well.

With Gap Detection turned on, you can specify that paint will fi ll areas con-

taining small, medium, or large gaps (Figure 4.12). Additionally, you can 

specify an exact amount for how big a gap can be before Live Paint consid-

ers it an open area instead of a closed one. Illustrator previews gaps in the 

selected color, and you can also have Illustrator fi ll any gaps in an object 

with physical paths (Illustrator always uses straight paths to do so).

TIP If you want to sim-
ply see where gaps 

occur in your artwork, you 
can choose View > Show Live 
Paint Gaps, and Illustrator will 
preview those areas in red.

Figure 4.11 The Gap 
Options dialog box makes 
it possible to fi ll areas in a 
Live Paint group even if they 
aren’t completely enclosed.

Figure 4.12 Even though 
the paths don’t actually 
enclose the areas 
completely, you can still 
fi ll the areas with the Gap 
Detection feature.
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Releasing and Expanding Live Paint Groups
Live Paint groups can be expanded, at which time they behave like ordinary 

vector paths. The appearance of an expanded Live Paint group remains 

identical to the original, but it is split into multiple objects for both fi lls 

and strokes. This is similar in concept to expanding live effects. To expand 

a selected Live Paint group, either click the Expand button in the Control 

panel or choose Object > Live Paint > Expand.

From a production standpoint, you don’t need to expand Live Paint groups 

in order to prepare a fi le for print. Live Paint groups print perfectly, because 

Illustrator performs the necessary expansion of paths at print time (similar 

to live effects).

Additionally, you can choose Object > Live Paint > Release to return a 

Live Paint group to the original paths used to create it. Whereas expanding 

a Live Paint group results in objects being broken up in order to preserve 

appearance, releasing such a group preserves the geometry of the original 

paths, but the appearance or colors are lost.

Merging Live Paint Groups
If you have several separate Live Paint groups, you may want to combine 

them to edit them as one entire group. You can do so easily by selecting the 

different groups and clicking Merge Live Paint in the Control panel. Alter-

natively, you can choose Object > Live Paint > Merge. Just note that for 

Live Paint groups that consist of many complex paths, the Gap Detection 

feature impedes performance. You may experience better performance by 

splitting very large Live Paint groups into several smaller ones or by turning 

off Gap Detection.

Using Live Paint to Edit Paths
Live Paint allows you to apply attributes—such as fi lls and strokes—to 

paths based on their appearance as opposed to their actual makeup. It would 

be even nicer if you could actually edit your paths based on appearance 

as well, don’t you think? Adobe was apparently reading your mind and 

added another tool to the mix—the Live Paint Selection tool (Shift-L)—

NOTE The Live Trace 
feature in Illustrator 

can quickly convert traced 
vector art into Live Paint 
groups for easy coloring. 
Refer to Chapter 12, 
“Working with Images,” 
for more information.

TIP When working 
with Live Paint groups, 

you can use both the Direct 
Selection tool to edit the 
individual paths and the 
Live Paint Selection tool to 
edit, giving you the best of 
both worlds.
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that enables you to select portions of objects based on their appearance 

(Figure 4.13).

Figure 4.13 With the Live 
Paint Selection tool you can 
make selections based on 
the appearance of artwork, 
not the underlying vector 
construction of it.

Let’s work through an example:

1. Use the Line Segment tool to draw two perpendicular lines, creating 

an x.

2. Select both paths, and press Command-Option-X (Ctrl-Alt-X) or 

choose Object > Live Paint > Make to convert the two paths into 

a Live Paint group.

3. Select the Live Paint Selection tool, and click one of paths.

You’ll notice that you can select each segment of the line individually. 

What were two paths before are now four line segments (Figure 4.14).

Figure 4.14 Using the 
Live Paint Selection tool, 
you can select visual 
segments of a path.

4. With one segment selected, press the Delete key to remove that segment 

from the path.

5. Select another segment, and change its stroke (Figure 4.15).

Figure 4.15 In a Live Paint 
group, you can easily apply 
diff erent strokes to the 
segments of a path.
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The Live Paint Selection tool can also select Live Paint areas (fi lls). If you 

have two overlapping shapes in a Live Paint group, you can select the over-

lap and delete it (Figure 4.16). You can also double-click to select continu-

ous areas of similar attributes and triple-click to select similar attributes 

across the entire Live Paint group.

At the end of the day, Live Paint adds a more fl exible way to color and edit 

paths, and it also adds more value to the Pencil tool, because complete 

closed paths aren’t required. The important point to remember is that a Live 

Paint group is a group, and anything you can do with a group in Illustrator 

you can do with Live Paint groups as well. For example, you can add 

attributes such as strokes to the Live Paint group for interesting effects. 

Experimenting with the Live Paint feature certainly helps you when you’re 

editing paths, and the good news is that it’s a fun feature to use.

DRAWING WITH THE PENCIL TOOL
To draw with the Pencil tool, simply click and drag on the artboard. As 

you drag, you’ll see a light path trail the movement of your pointer 

(Figure 4.17). After you release the mouse button, Illustrator creates the 

anchor points necessary and creates a vector path for you (Figure 4.18).

Figure 4.16 The Live Paint 
Selection tool enables you 
to select any area of a Live 
Paint group.
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Figure 4.17 As you 
drag with the Pencil 
tool, a faint line traces 
the path of your 
pointer.

Figure 4.18 After you 
release the mouse but-
ton, Illustrator creates 
anchor points as neces-
sary and displays the 
drawn path. Depending 
on how well you 
control the mouse (or 
pressure-sensitive pen), 
the path may have a 
jittery appearance.

Because drawing with the Pencil tool relies on how steadily you handle your 

mouse or tablet pen, you can employ several tools and settings to help create 

better-looking paths.

The Smooth tool, which you’ll fi nd grouped with the Pencil tool in the 

Tools panel, is a tool you can use to iron out the wrinkles of any selected 

vector path. Select any vector path, and click and drag over it with the 

Smooth tool. Doing this repeatedly makes the vector path smoother and 

smoother. The angles in the path become smoother, and the path modifi es 

to match the contour of the direction in which you drag with the Smooth 

tool (Figure 4.19).

TIP Pressing the 
Option (Alt) key with 

the Pencil tool selected will 
temporarily switch to the 
Smooth tool.
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Double-clicking the Pencil tool or the Smooth tool opens the Pencil 

Tool Options dialog box, allowing you to specify that tool’s behavior 

(Figure 4.20).

Figure 4.20 Selecting the 
“Edit selected paths” option 
allows you to easily reshape 
or adjust existing paths.

The Pencil Tool Options dialog box offers the following settings:

• Fidelity and Smoothness. Available for both the Pencil and Smooth 

tools, the Fidelity setting determines how close the vector path is drawn 

in relation to the movement of your mouse or input pen. A lower 

Fidelity setting results in a path that more closely matches the exact 

movement of your mouse. A higher Fidelity setting results in a path that 

is smoother and less jittery but that may not match your stroke exactly. 

If you’re good with handling the mouse or if you’re using an input pen, 

you might go with a lower setting. If you have trouble controlling the 

mouse or pen precisely, you might benefi t from a higher Fidelity set-

ting. The Smoothness setting refers to how much smoothing Illustrator 

applies to paths as you draw them. The higher the Smoothness setting, 

Figure 4.19 Using the 
Smooth tool on a path can 
enhance its appearance.

NOTE If necessary, the 
Smooth tool removes 

excess anchor points.

TIP The preferences 
for the Pencil and 

Smooth tools are saved when 
you quit Illustrator so that you 
don’t have to set these for 
each new fi le you create 
or each time you launch 
Illustrator. If you trash your 
preferences fi le, however, 
you’ll need to reset these 
preferences to your liking.
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the fewer anchor points you’ll see on your paths. If you’re looking for 

more fl uid strokes, increasing the Smoothness setting will help.

• Fill new pencil strokes. By default, Illustrator creates paths drawn 

with the Pencil tool as paths with a stroke but no fi ll. Selecting this 

option gives you the ability to choose a fi ll color and create fi lled paths 

as you draw them with the Pencil tool. This setting is available for the 

Pencil tool only, not for the Smooth tool.

• Keep selected and Edit selected paths. With Illustrator’s default 

behavior, when you draw a path with the Pencil tool, the path becomes 

selected as soon as you complete it. You can change this behavior by 

deselecting the “Keep selected” option. When the “Edit selected paths” 

option is selected and your pointer is within the specifi ed number of 

pixels from an existing selected path, Illustrator allows you to modify 

the selected path by simply drawing over it with the Pencil tool. This 

can be helpful because it allows you to tweak a path to perfection as 

you are drawing it, almost as if you were using the Smooth tool. Where 

this gets in the way, however, is when you intend to draw a new path 

but inadvertently end up editing a path that is selected instead. This can 

happen often if you have the “Keep selected” option selected. Many 

designers prefer to deselect the “Keep selected” option but leave the 

“Edit selected paths” option selected. This way, if they do need to edit 

a path, they can Command-click (Ctrl-click) a path to select it; at this 

point, the “Edit selected paths” option lets them draw over it.

Pen Tool vs. Pencil Tool

In contrast to the Pen tool, the process of drawing with the Pencil tool mimics that of drawing with a real 
pen on paper. In reality, the Pencil tool is the exact opposite of the Pen tool. With the Pen tool, you defi ne 
the anchor points, and Illustrator completes the paths. With the Pencil tool, you draw the path, and Illustrator 
creates the anchor points for you.

If using the Pencil tool to draw paths sounds a lot easier than creating anchor points with the Pen tool, 
remember that the mouse isn’t the easiest tool to control when you’re trying to draw. Although the Pencil 
tool is easier to use to create paths, it’s not as easy to create exact or precise paths with it. However, if you 
have a pressure-sensitive tablet available, the Pencil tool is a bit easier to control.

For technical drawing and precise illustration work, including logo creation and letterforms, you’ll most likely 
fi nd that the Pen tool off ers the fi ne control you need. You’ll fi nd the Pencil tool useful when you’re working 
with creative illustrations, cartoons, and projects that require a more natural feel.

TIP Remember 
that you can use the 

Smooth and Path Eraser 
tools on any vector path in 
Illustrator—even those that 
were not created with the 
Pencil tool.
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UNLEASHING THE POWER
OF BRUSHES
Each version of Illustrator brings new features and tools to the hands of 

designers. Some are cool effects, and some add useful functionality. And 

every once in a while, a feature is introduced that is so unique and powerful 

that it changes everything. The brushes in Illustrator are such a feature.

The concept is simple: Instead of drawing a predictable, boring line using 

the Pencil tool, the Paintbrush tool can create fl ourishes, lines with tapered 

ends, and artsy elements that mimic the strokes you can create with Speed-

ball or calligraphy pens. More powerful than you might think, brushes sup-

port pressure-sensitive tablets and can even distribute art and patterns along 

a drawn path. By using brushes, you can streamline your work by creating 

complex artwork with just a few paths. Brushes are also easy to modify.

Under the hood, the Paintbrush tool functions exactly like the Pencil tool 

and allows you to click and drag to create a vector path. The difference is in 

the appearance of the path it creates. The Paintbrush tool applies predefi ned 

vector artwork to the paths you draw. When using a pressure-sensitive tab-

let, you can also control how the artwork is applied to the vector paths.

Exploring the Illustrator Brush Quartet
Illustrator has four kinds of brushes; each offers a different kind of behavior 

in which art is applied to a path:

• Calligraphic brush. The Calligraphic brush allows you to defi ne a nib,

or tip, of a pen. The art that is drawn with a Calligraphic brush takes 

into account the angle and shape of the nib, resulting in natural thicks 

and thins and variable thickness (Figure 4.21).
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• Scatter brush. The Scatter brush allows you to defi ne any vector art as 

a brush (except the ones listed in the sidebar “What’s in a Brush?”). The 

art that is drawn with a Scatter brush consists of copies of the art, scat-

tered across the vector path. You can control the way art is scattered in 

each brush’s settings (Figure 4.22).

Figure 4.21 With the help 
of a pressure-sensitive 
tablet, the Calligraphic 
brush can create strokes 
with natural thicks and thins 
to achieve a hand-drawn 
look and feel, as in this 
illustration of a skier.

Figure 4.22 You can use 
a Scatter brush to create 
consistent borders or to 
quickly fi ll an illustration 
with random art, such 
as the sparkles in this 
illustration.
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• Art brush. The Art brush allows you to defi ne any vector art as a 

brush (except the ones listed in the sidebar “What’s in a Brush?”). The 

art drawn with an Art brush is stretched across the entire length of the 

path, resulting in the controlled distortion of art along a vector path 

(Figure 4.23).

• Pattern brush. The Pattern brush allows you to specify up to fi ve 

already-defi ned patterns as a brush. The art that is drawn with a Pattern 

brush is distributed along a vector path based on the brush’s settings, 

resulting in perfect corners and art that is contoured to the vector path 

(Figure 4.24).

What’s in a Brush?

When you’re creating artwork that will be used to defi ne a brush, be aware that brushes cannot understand all 
kinds of vector objects. Brushes cannot contain gradients, mesh objects, bitmap images, graphs, placed fi les, 
or masks. For Art and Pattern brushes specifi cally, the artwork also cannot contain editable type objects. If you 
want to include these kinds of objects, you either need to expand them or convert them to outlines fi rst.

Figure 4.23 You can use an 
Art brush to apply artistic 
brush strokes or to stretch 
art along a path.

Figure 4.24 A Pattern brush 
can bend art to match the 
curve of a path and can also 
contain a variety of settings 
that change based on the 
makeup of the path.
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Applying Brush Strokes
To paint with a brush, choose the Paintbrush tool in the Tools panel, and 

then select a brush from the Brushes panel. You create brush strokes the 

same way you create paths with the Pencil tool, so once you’ve selected a 

brush to use, click and drag on the artboard to defi ne a path. When you 

release the mouse button, Illustrator applies the brush stroke to the newly 

created vector path (Figure 4.25). Illustrator also indicates the applied brush 

stroke in the Appearance panel, making it easy to identify when a particular 

brush has been used (Figure 4.26).

Figure 4.25 When you cre-
ate a brush stroke, a single 
vector path is defi ned, and 
the appearance of that path 
displays the brush art.

You don’t have to use the Paintbrush tool to apply a brush stroke to a vec-

tor path. Simply selecting a vector path and clicking a brush in the Brushes 

panel applies the brush to the selected path. The only benefi t you gain by 

using the Paintbrush tool is the ability to defi ne a brush shape using a 

pressure-sensitive tablet (see the sidebar “Can You Handle the Pressure?”).

Can You Handle the Pressure?

Illustrator has full support for pressure-sensitive pen tablets such as the line of Wacom tablets. You can set 
Calligraphic or Scatter brushes to use variable settings based on pressure, thus enabling you to easily draw 
lines of varying thickness or to apply diff erent scatter settings.

The natural lines you can achieve with a Calligraphic brush and a Wacom tablet are perfect for sketching or 
drawing in Illustrator. It would seem that the next logical step after creating a sketch with the Paintbrush 
tool is to convert the art to a Live Paint group to quickly colorize the art. Unfortunately, the Live Paint fea-
ture doesn’t support brushes, and converting a brushed path to a Live Paint group results in the loss of the 
appearance of the brush. Instead, you might try using the Blob Brush tool, covered later in this chapter.

When using either the Calligraphic or Scatter brush, Illustrator also supports Wacom’s 6D Art pen. You can fi nd 
a library of 6D Art pen brushes that is fi lled with 18 Calligraphic and 6 Scatter brushes by choosing Window > 
Brush Libraries > Wacom 6D Brushes > 6D Art Pen Brushes.

NOTE If you double-
click the Paintbrush 

tool, you’ll fi nd that the pref-
erences are identical to those 
of the Pencil tool.

Figure 4.26 By identifying 
the brush applied to a path, 
the Appearance panel gives 
yet another reason for why 
it should always be open 
and visible on your screen.



CHAPTER 4: CREATIVE DRAWING110

Defi ning a Calligraphic Brush
To defi ne a new Calligraphic brush, click the New Brush icon in the Brushes 

panel, or choose New Brush from the Brushes panel menu. Select New 

Calligraphic Brush in the New Brush dialog box, and click OK to open the 

Calligraphic Brush Options dialog box (Figure 4.27).

The Calligraphic Brush Options dialog box allows you to specify the shape 

and behavior of the nib using three settings:

• Angle. You can set the angle of a Calligraphic brush to a fi xed angle 

or to a random number. When the Roundness setting is set to 100%, 

the Angle setting does not produce any noticeable change in the shape 

of the brush. With pressure-sensitive tablets, you can set the angle to 

change based on pressure, stylus wheel, tilt, bearing, or rotation. When 

you’re not using the Fixed option, the Variation slider allows you to 

specify a range that the angle can change, which you can also see in the 

preview area of the dialog box.

• Roundness. You can set the roundness of a Calligraphic brush to a 

fi xed or random number. When the roundness is set closer to 100%, 

the tip of the nib becomes circular in shape (like a traditional ink pen). 

When the roundness is set closer to 0%, the tip of the nib becomes fl at 

(like a traditional calligraphy pen). With pressure-sensitive tablets, you 

can set the roundness to change based on pressure, stylus wheel, tilt, 

bearing, or rotation. When you’re not using the Fixed option, the 

Variation slider lets you specify a range that the roundness can change, 

which you can also see in the preview area of the dialog box.

Figure 4.27 The Calligraphic 
Brush Options dialog box 
lets you click and drag the 
nib shape in the preview 
area to defi ne its settings.
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• Diameter. You can set the diameter, or size, of a Calligraphic brush to 

a fi xed or random number. With pressure-sensitive tablets, you can set 

the diameter to change based on pressure, stylus wheel, tilt, bearing, or 

rotation. When you’re not using the Fixed option, the Variation slider 

allows you to specify a range that the diameter can change, which you 

can also see in the preview area of the dialog box.

Defi ning a Scatter Brush
To defi ne a new Scatter brush, start by creating the art for the brush on 

the artboard. Once it is complete, drag the artwork directly to the Brushes 

panel. Alternatively, you can select the art and click the New Brush icon 

in the Brushes panel or choose New Brush from the Brushes panel menu. 

Select New Scatter Brush in the New Brush dialog box, and click OK to 

open the Scatter Brush Options dialog box (Figure 4.28).

You can fi ne-tune the Scatter brush with the following settings:

• Size. The Size setting can be a fi xed or random number; this setting 

determines how big or small the art is drawn on the path, relative to 

the actual size of the art used to defi ne the brush. For example, if you 

create a design that is 1 inch tall and use it to defi ne a Scatter brush, a 

Size setting of 50% results in a Scatter brush that creates designs that 

are .5 inches tall. With pressure-sensitive tablets, you can set the size to 

change based on pressure, stylus wheel, tilt, bearing, or rotation. When 

you are not using the Fixed option, the two values determine the range 

that the size can change.

TIP When you’re using 
a pressure-sensitive 

tablet, giving the Diameter 
setting a variation based 
on pressure enables you to 
create strokes that appear 
thicker as you press harder. 
If you have Wacom’s 6D Art 
pen, it makes sense to set 
the angle to the pen’s 
Rotation attribute.

Figure 4.28 The Scatter 
Brush Options dialog box 
presents a plethora of 
settings you can use to 
create a wide variety 
of results.
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• Spacing. The Spacing setting can be a fi xed or random number; this 

setting determines the amount of space that appears between each 

instance of art that is drawn on the path. Higher values add more space 

between each copy of the art, and lower values make the copies of art 

appear closer together. With pressure-sensitive tablets, you can set the 

spacing to change based on pressure, stylus wheel, tilt, bearing, or rota-

tion. When you’re not using the Fixed option, the two values determine 

the range that the spacing can change.

• Scatter. The Scatter setting can be a fi xed or random number; this 

setting determines how far away each instance of art that is drawn 

deviates from the path. Negative values shift art lower and to the left 

of the path; positive values shift art higher and to the right of the path. 

With pressure-sensitive tablets, you can set the scatter to change based 

on pressure, stylus wheel, tilt, bearing, or rotation. When you’re not 

using the Fixed option, the two values determine the range that the 

scatter can change.

• Rotation. The Rotation setting can be a fi xed or random number; this 

setting determines the angle that each instance of art is drawn on the 

path. With pressure-sensitive tablets, you can set the rotation to change 

based on pressure, stylus wheel, tilt, bearing, or rotation. When you’re 

not using the Fixed option, the two values determine the range that the 

rotation can change.

• Rotation relative to. You can set the rotation so that it is relative either 

to the page, in which case all instances of the art appear consistent, or to 

the path, in which case all instances of the art rotate in accordance with 

the direction of the path (Figure 4.29).

Figure 4.29 Depending on 
your desired result, you can 
specify art to rotate in rela-
tion to the page (top) or the 
path (bottom).
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• Colorization. The Colorization option lets you choose from one of four 

settings. If you choose the None setting, the Scatter brush creates art in 

the same color that is used to defi ne it. If you choose the Tints setting, 

the Scatter brush creates art in varying tints of the current stroke color. If 

you choose the Tints and Shades setting, the Scatter brush creates art in 

varying tints of the current stroke color while preserving black objects. 

If you choose the Hue Shift setting, the Scatter brush creates art and 

changes the key color of the art to the current stroke color. To defi ne a 

key color, click the Eyedropper icon in the dialog box, and click part of 

the art in the preview area.

Defi ning an Art Brush
To defi ne a new Art brush, start by creating the art for the brush on the art-

board. Once it’s complete, drag the artwork directly into the Brushes panel. 

Alternatively, you can select the art and click the New Brush icon in the 

Brushes panel or choose New Brush from the Brushes panel menu. Select 

New Art Brush in the New Brush dialog box, and click OK to open the 

Art Brush Options dialog box (Figure 4.30).

Figure 4.30 The Art Brush 
Options dialog box gives 
you a visual preview of 
the direction of the art in 
relation to the path.
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You can fi ne-tune the Art brush with the following settings:

• Direction. The Direction setting determines the orientation of the 

art with respect to the path to which the brush is applied. A blue arrow 

appears in the preview area, allowing you to visually understand how 

the art will be drawn on a path.

• Width. The Width setting determines how big or small the art is drawn 

on the path relative to the actual size of the art that was used to defi ne 

the brush. For example, if you create a design that is 1 inch tall and use 

it to defi ne an Art brush, a Size setting of 50% results in an Art brush 

that creates designs that are .5 inches tall. When specifying width val-

ues, you can also choose to keep the artwork scaled in proportion.

• Flip. The Flip Along and Flip Across settings enable you to refl ect the 

artwork on both the horizontal and vertical axes.

• Colorization. The Colorization option lets you choose from one of 

four settings. When you choose the None setting, the Art brush cre-

ates art in the same color that is used to defi ne it. If you choose the 

Tints setting, the Art brush creates art in varying tints of the current 

stroke color. If you choose the Tints and Shades setting, the Art brush 

creates art in varying tints of the current stroke color while preserving 

black objects. If you choose the Hue Shift setting, the Art brush creates 

art and changes the key color of the art to the current stroke color. To 

defi ne a key color, click the Eyedropper icon in the dialog box, and click 

part of the art in the preview area.

Defi ning a Pattern Brush
To defi ne a new Pattern brush, it’s easier to fi rst defi ne the pattern swatches 

that will be used in the brush (defi ning pattern swatches is covered in Chap-

ter 6, “Coloring Artwork”). A Pattern brush can contain up to fi ve different 

pattern tiles, which are used for different parts of a path (see the “Pattern 

tiles” bullet in the following list). Once you’ve defi ned the necessary pattern 

swatches, click the New Brush icon in the Brushes panel, or choose New 

Brush from the Brushes panel menu. Select New Pattern Brush in the New 

Brush dialog box, and click OK to open the Pattern Brush Options dialog 

box (Figure 4.31).

TIP It’s always a good 
idea to learn from 

existing examples, and that 
goes for Pattern brushes too. 
You can fi nd a wide variety 
of Pattern brushes in the 
 Window > Brushes menu.
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The various settings of the Pattern Brush Options dialog box are as follows:

• Scale. The Scale setting determines how big or small the pattern 

swatch is drawn on the path, relative to the actual size of the art that 

was used to defi ne the pattern (by default, a Pattern brush applies art 

at the size the art was originally created). For example, if you create art 

that is 1 inch tall and use it to defi ne a pattern swatch, a Scale setting of 

50% results in a Pattern brush that creates tiles that are .5 inches tall.

• Spacing. The Spacing setting determines the amount of space that 

appears between each pattern tile that is drawn on the path. By default, 

all pattern tiles touch each other, and specifying higher values adds 

more space between them.

• Pattern tiles. A Pattern brush can use up to fi ve pattern tiles for the 

different parts of a drawn path. The side tile is used along the middle 

of the path, the outer and inner corner tiles are used whenever the path 

encounters a corner anchor point at 90 degrees, and the start and end 

tiles are used at the beginning and end of an open path. We’ll cover each 

tile type in detail later in this chapter. To set a tile, click the preview box 

above each tile, and choose from the list of defi ned pattern swatches 

that appears. Only pattern swatches from the current document appear 

in the list. It is not necessary to assign a pattern swatch to every tile in 

order to defi ne a Pattern brush. For example, some Pattern brushes do 

not have start or end tiles defi ned.

Figure 4.31 Though it 
might appear complicated 
at fi rst, the Pattern Brush 
Options dialog box makes 
it easy to defi ne powerful 
Pattern brushes.

TIP To create a dashed 
line on a rectangle 

that will always have perfect 
corners, create two pattern 
swatches, one for a dash and 
one for a corner. Then create 
a Pattern brush that uses the 
dash pattern as the side tile 
and the corner pattern as the 
outer corner tile, and choose 
the “Add space to fi t” option.
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• Flip. The Flip Along and Flip Across settings enable you to refl ect the 

pattern tiles on both the horizontal and vertical axes.

• Fit. The Fit setting, arguably one of most powerful settings among all 

the brushes, allows you to specify how pattern tiles are drawn on a path. 

The “Stretch to fi t” option modifi es the brush’s Scale setting to ensure 

a perfect fi t across the entire path, with no spaces between tiles. The 

“Add space to fi t” option modifi es the brush’s Spacing setting to ensure 

the tiles fi t evenly across an entire path. The “Approximate path” option 

actually changes the size of the path so that it fi ts to the size of the pat-

tern tiles.

• Colorization. The Colorization option lets you choose from one of 

four settings. When you choose the None setting, the Pattern brush 

creates tiles in the same color used when the pattern swatches are 

defi ned. If you choose the Tints setting, the Pattern brush creates tiles 

in varying tints of the current stroke color. If you choose the Tints and 

Shades setting, the Pattern brush creates tiles in varying tints of the 

current stroke color while preserving black objects. When you choose 

the Hue Shift setting, the Pattern brush creates tiles and changes the 

key color of the tiles to the current stroke color. To defi ne a key color, 

click the Eyedropper icon in the dialog box, and click part of the tile in 

the preview area (which is extremely diffi cult considering how small the 

previews for each tile are).

These next options let you defi ne the fi ve parts of a Pattern brush. Pattern 

brushes comprise up to fi ve different individual pattern tiles: side, outer 

corner, inner corner, start, and end. It’s rare you would defi ne a single 

Pattern brush with all fi ve of these types of tiles, though, because the corner 

tiles are mostly benefi cial when creating borders, which are closed paths and 

therefore have no need for start or end tiles. Likewise, Pattern brushes with 

start and end tiles are generally applied to open paths that may not require 

corner tiles.

• Side tiles. The most common type of tile used, the side tile simply 

repeats itself along the path to which it is applied (Figure 4.32).

NOTE Most of the 
information about 

 Pattern brushes here comes 
from the genius mind of 
Teri Pettit, one of the engi-
neers on the Illustrator team 
at Adobe. You can fi nd more 
detailed information from 
Teri on a variety of topics on 
her website at http://tpettit.
best.vwh.net/adobe/.

http://tpettit.best.vwh.net/adobe/
http://tpettit.best.vwh.net/adobe/
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• Outer corner and inner corner tiles. The terms inner corner and 

outer corner refer to the corners of a clockwise path. On such a path, the 

corners that point outward will use the outer corner tile, and the cor-

ners that point inward will use the inner corner tile. On counterclock-

wise paths, these roles will be reversed.

If a rectangle is created by dragging it from top left to bottom right, or 

vice versa, the top of the rectangle runs from left to right, and all cor-

ners will use the outer corner tile. If the rectangle is drawn by dragging 

between the top-right and bottom-left corners, then the bottom of the 

rectangle runs from left to right. Thus, the brush pattern as displayed 

along the top of the rectangle will be upside down, and all corners will 

use the inner corner tile (Figure 4.33).

Figure 4.32 This is a Pattern 
brush comprised of just a 
side tile (inset) to simulate 
stitching as it might appear 
on a baseball. The stitches 
follow the contour of the 
path and appear seamless.

Figure 4.33 The arrows that appear within the rectangles indicate the direction 
in which they were drawn, while the arrows that appear along the outside of the 
rectangles indicate the direction the paths run in. The rectangle on the left runs 
clockwise and uses the outer corner tile, while the rectangle on the right runs 
counterclockwise and uses the inner corner tile.
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• Start and end tiles. Start and end tiles appear, respectively, at the 

beginning and end of an open path. If a brush does not have start or 

end tiles defi ned, then the side tile will be used instead. Note that if 

a brush doesn’t have inner or outer corner tiles defi ned, those sections 

of the path will appear blank.

A few things are somewhat confusing with regard to how Illustrator 

displays pattern tiles in the user interface. For example, the tiles appear in 

one particular order when listed in the Pattern Brush Options dialog box 

(Figure 4.34), yet they appear listed in a completely different order when 

viewed in the Brushes panel (Figure 4.35). Although the order doesn’t 

really make a difference, it’s easy to get confused when you’re assigning 

patterns to each tile.

In addition, because of the way inner corner tiles are drawn along paths, 

they are fl ipped (or refl ected) –45 degrees, which means you need to com-

pensate for that when defi ning the artwork for such tiles. It gets confusing 

because the Brushes panel shows a preview of the tile as though it appears 

correct, but the same tile appears refl ected when viewed in the Pattern 

Brush Options dialog box (Figure 4.36). So that you remain sane, it’s best 

to draw your pattern art normally and simply refl ect it 45 degrees before 

defi ning it as a pattern.

Figure 4.34 The order 
in which Pattern brushes 
appear within the Pattern 
Brush Options dialog box. 
A diagonal line (slash) 
means there is no pattern 
specifi ed for that tile.

Figure 4.35 The order in 
which Pattern brush tiles 
appear within the Brushes 
panel.

Side Tiles Start 
Tile

End 
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Corner 

Tile

Inner 
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Modifying Brush Strokes
Double-click any brush in the Brushes panel to specify or change its settings. 

Alternatively, you can hold the Option (Alt) key while dragging vector art 

from the artboard onto an existing Art or Scatter brush to modify or replace 

the brush. When you do, a thick black line appears around the brush icon 

indicating that you are about to modify it.

When you’re about to modify a brush, Illustrator checks to see whether the 

existing brush has already been applied to objects in your document. If it 

fi nds such objects, Illustrator asks whether you want the existing paths to 

now take on the appearance of the modifi ed brush or whether you want to 

leave them intact (Figure 4.37). If you want to leave them intact, Illustrator 

makes the change just to the selected objects.

You can delete brushes from a document by dragging them to the trash can 

icon in the Brushes panel.

Figure 4.36 In the Pattern 
Brush Options dialog box, 
the inner corner tile appears 
fl ipped, compared to the 
same tile that appears in the 
Brushes panel (inset).

TIP If you want to 
modify only a single 

brush stroke within an entire 
document, you can do so 
either by selecting the path 
and clicking the Options of 
Selected Object button in 
the Brushes panel or by 
double-clicking the name 
of the brush in the 
Appearance panel.

Figure 4.37 Always watch-
ing what you’re doing, 
Illustrator alerts you if your 
edits will aff ect objects that 
have already been drawn.
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Expanding Brush Art
When you apply a brush stroke to a path, only the vector path is editable. 

The art that makes up the brush stroke cannot be edited or otherwise 

tinkered with. However, you can easily reduce any brush stroke to editable 

vector art by choosing Object > Expand Appearance. Doing so removes 

the link to the brush, and the path no longer updates if the brush swatch 

is updated (Figure 4.38).

Additionally, you can always access the original art that was used to create 

an Art, Scatter, or Pattern brush by dragging the brush from the Brushes 

panel to a blank area on the artboard.

DRAWING AND ERASING WITH EASE
The four brush types we’ve discussed to this point—Calligraphic, Art, 

Scatter, and Pattern—all work in the same way, in that they are applied 

as appearances along a path. You can apply these brushes directly with the 

Paintbrush tool and can even apply them to existing paths. If you make 

an adjustment to an underlying path, the appearance of the brush updates 

accordingly. Although this “live” behavior has many benefi ts, you don’t have 

access to the actual art that these brushes create until you expand them.

For certain types of illustration, the ability to fi ne-tune and edit brush strokes 

is very important. In fact, many illustrators in the past have used a variety of 

Calligraphic and Art brushes to create their art, only to expand the brushes 

and combine them with Pathfi nder commands so that they could edit the art 

NOTE Like swatches, 
brushes travel with a 

fi le, so you don’t need to 
expand a brush just because 
you’re sending a fi le to some-
one else. When you defi ne 
and use brushes, those 
brushes are saved in the 
fi le and are there until you 
manually delete them.

Figure 4.38 When viewed 
in Outline mode, brush 
strokes appear as open 
paths (left). Once expanded, 
the paths form closed 
shapes that can be edited as 
needed (center). In Preview 
mode, however, live and 
expanded brush strokes 
appear identical (right).
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more effectively. It’s easy to see how tedious this process can be. But more 

importantly, it breaks the fl ow of creativity from the designer.

The Blob Brush tool—new to Illustrator CS4—was added to give designers 

the freedom to express their creativity without getting lost in the technical 

details. At a basic level, the Blob Brush tool draws art that appears no dif-

ferent from that drawn with the Calligraphic brush. However, behind the 

scenes, the Blob Brush tool automatically expands the brush strokes as 

you draw them (Figure 4.39). At the same time, the Blob Brush tool intel-

ligently combines your brush strokes with underlying objects into single, 

easy-to-edit shapes—shapes that can easily be adjusted or modifi ed with 

the Eraser tool (Figure 4.40).

Figure 4.39 This fi gure 
illustrates how the Blob 
Brush tool can be used 
to create these strands of 
hair. As each brush stroke 
is added (left to right), the 
artwork is shown in Preview 
mode (top) and the result-
ing path geometry (bottom).

Figure 4.40 As a closed 
and fi lled path, the shape 
is easily modifi ed with the 
Eraser tool.

TIP Although “live” 
brushes in Illustrator 

don’t work with Live Paint 
(the brush appearance is lost 
when they are converted to 
Live Paint groups), objects 
drawn with the Blob Brush 
tool work extremely well 
with Live Paint.
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Using the Blob Brush Tool
Drawing with the Blob Brush tool is easy and fun. Start by selecting the 

Blob Brush tool (Shift-B) from the Tools panel (Figure 4.41), and then 

specify a stroke color (the Blob Brush tool paints using the stroke, not the fi ll, 

as you might think). Then, click and drag on the artboard. By default, as you 

overlap brush strokes, they automatically combine to create a single, unifi ed 

shape. To better qualify that statement, brush strokes are automatically com-

bined only if their attributes are alike. For example, if you’re painting with 

a specifi c shade of brown, only underlying objects that are also fi lled with 

that same color will be merged. Objects fi lled with other colors, however, 

are left untouched (Figure 4.42). This makes it easy to modify shapes with 

the Blob Brush tool, because you can draw over existing objects that have 

the same color attributes. Most important, this makes it possible for artists 

to make quick edits and adjustments without having to constantly lock and 

unlock complex overlapping objects.

Figure 4.41 The 
Blob Brush tool 
may have a funny 
name, but it’s a 
serious drawing 
tool.

Figure 4.42 As you 
draw with the Blob 
Brush tool, your 
stroke color deter-
mines which objects 
your brush strokes 
merge with, enabling 
you to perform edits 
on one shade of 
color without aff ect-
ing other objects 
with diff erent colors.

You can easily adjust the size of the Blob Brush tool by pressing the open 

and closed bracket keys, just as you might adjust a brush size in Photoshop. 

While the Blob Brush tool is selected, you can also press the Option (Alt) 

key to activate the Smooth tool, which you can use to smooth out the edges 

of selected shapes as you draw them. Using the Smooth tool to fi ne-tune 

paths drawn with the Blob Brush tool is important because the expanding 

NOTE Interestingly, 
the Blob Brush tool 

uses the stroke attribute to 
determine the color it paints 
with, but once you’ve painted 
a shape, the result is an object 
that is fi lled with that color 
and has no stroke.
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and merging that happens behind the scenes as you draw with the Blob 

Brush can result in paths with many anchor points. Remember that you can 

quickly select an object by pressing the Command (Ctrl) key to temporarily 

activate the last-used Selection tool.

To control the behavior of the Blob Brush tool, double-click the tool in the 

Tools panel to open the Blob Brush Tool Options dialog box (Figure 4.43). 

The bottom half of the dialog box looks exactly like the Calligraphic Brush 

Options dialog box—which is not a coincidence. In fact, as mentioned ear-

lier, the Blob Brush tool is based on the functionality of the Calligraphic 

brush (you can even select a saved Calligraphic brush in the Brushes panel 

and use it to paint with the Blob Brush tool).

The top of the dialog box offers the following settings:

• Keep Selected. With this option deselected (the default setting), paths 

that you draw with the Blob Brush tool will become deselected after 

you’ve released the mouse button or input pen. By selecting this option, 

the object will remain selected after you’ve drawn it, which would make 

it easier to immediately adjust the shape with the Smooth tool. In addi-

tion, the Keep Selected option could be useful when used in tandem 

with the Selection Limits Merge setting.

NOTE How does the 
Blob Brush tool work? 

As you paint with it, Illustrator 
applies the Expand command 
and performs a Pathfi nder 
Unite function with any 
overlapping paths that have 
similar attributes.

Figure 4.43 The Blob Brush 
Tool Options dialog box 
gives you complete control 
over the behavior of the 
Blob Brush tool.



CHAPTER 4: CREATIVE DRAWING124

• Selection Limits Merge. As you’ve learned, the Blob Brush tool auto-

matically merges new brush strokes with existing overlapping objects if 

those objects have similar attributes. For further control, the Selection 

Limits Merge option will allow the Blob Brush to merge new brush 

strokes only if the underlying objects have similar attributes and they 

are selected. Objects that are not selected, even if they share the same 

attributes of the brush, are not merged. In this way, you have further 

control over which brush strokes are merged and which are not.

• Fidelity and Smoothness. The Fidelity setting determines how close 

the vector path is drawn in relation to the movement of your mouse or 

input pen. A lower Fidelity setting results in a path that more closely 

matches the exact movement of your mouse. A higher Fidelity setting 

results in a path that is smoother and less jittery but that may not match 

your stroke exactly. If you’re good with handling the mouse or if you’re 

using an input pen, you might go with a lower setting. If you have 

trouble controlling the mouse or pen precisely, you might benefi t from 

a higher Fidelity setting. The Smoothness setting refers to how much 

smoothing Illustrator applies to paths as you draw them. The higher the 

Smoothness setting, the fewer anchor points you’ll see on your paths. If 

you’re looking for more fl uid strokes, increasing the Smoothness setting 

will help.

Using the Eraser Tool
The perfect companion to the Blob Brush tool is the Eraser tool (Shift-E). 

In fact, you’ll fi nd the Eraser tool right next to the Blob Brush tool, grouped 

with the Scissors and Knife tools (Figure 4.44). To use the Eraser tool, 

select it, and then click and drag over any object (or objects). If nothing is 

selected, the Eraser tool will erase all objects across all layers in your 

document, with the exception of locked objects and layers, of course. For 

more control, you can make a selection fi rst and then use the Eraser tool 

(Figure 4.45), at which time the tool will erase only those objects that are 

selected (leaving all other objects intact).
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Figure 4.44 The Eraser tool 
(not to be confused with the 
Path Eraser tool) is grouped 
with other tools that cut or 
sever paths.

Figure 4.45 By selecting an 
object, you can quickly erase 
parts of one path without 
aff ecting other paths. This 
illustration is also a great 
example of how you might 
use the Eraser tool in a cre-
ative way, by editing shapes 
and colored regions.

It’s important to realize that although the Eraser tool is cool and makes it 

seem effortless to quickly remove parts of an illustration, the tool still must 

abide by the general rules of how vector objects are drawn. This means if 

you try to erase part of a single closed path, the result will be two closed 

paths, not open ones. It’s easiest to see this when attempting to erase paths 

that contain strokes (Figure 4.46 on the next page). In addition, although 

you can certainly use the Eraser tool to erase portions of a stroke, the stroke 

attribute for each segment of the resulting path is reapplied (Figure 4.47 on 

the next page). In the latter case, you can get around this by fi rst choosing 

the Object > Path > Outline Stroke command before using the Eraser tool. 

The same applies when trying to erase paths with Calligraphic, Art, Scatter, 

and Pattern brushes applied. In fact, this behavior is why the Eraser tool and 

the Blob Brush go so well together—the Blob Brush tool creates expanded 

paths that can be erased easily with the Eraser tool.

TIP If you have a large 
area to erase, press the 

Option (Alt) key while drag-
ging with the Eraser tool to 
create a marquee area. Any-
thing that falls within the 
boundaries of the marquee 
will be erased.
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Once you get used to the behavior of the Eraser tool, it becomes a useful 

(and fun!) tool to use. Just as with the Blob Brush tool, you can adjust the 

size of the eraser by tapping the bracket keys on your keyboard. You can 

also double-click the Eraser tool in the Tools panel to open the Eraser Tool 

Options dialog box (Figure 4.48). You can manually adjust the numerical 

values for the angle and roundness of the Eraser tool, or you can click and 

drag the black dots and the arrow in the preview near the top of the dialog 

box to adjust those values visually. You can adjust the size of the diameter 

of the eraser as well.

By default, all the values are fi xed, meaning they remain consistent as you 

use the Eraser tool. However, you can choose to make the values random 

and select a variation for each setting. Even better, if you have a pressure-

sensitive tablet, you can choose other variables including Pressure. For 

example, setting Diameter to Pressure with a high Variation value gives 

you the ability to erase with more control and fl exibility.

Figure 4.46 Although you 
may initially expect the 
Eraser tool to simply remove 
an area from an object (left), 
the result will actually be 
two closed shapes (right).

Figure 4.47 If a stroke 
has the Round Cap option 
specifi ed, the Eraser tool 
may appear to create a clean 
break while you’re using 
it (left), but the result will 
be two paths, each with its 
own respective round cap 
appearance (right).

Figure 4.48 The Eraser 
Tool Options dialog box 
off ers similar controls to 
that found for the Blob 
Brush tool and the 
Calligraphic brush.

TIP If you have a 
Wacom tablet, you can 

take advantage of a natural 
drawing workfl ow. When 
drawing with the Blob Brush 
tool, you can fl ip the pen over 
to have Illustrator automati-
cally switch to the Eraser tool. 
Flip the pen back again, and 
you’re back to drawing with 
the Blob Brush tool.
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USING GRADIENT MESH
Gradients, which are covered in detail in Chapter 6, allow you to fi ll an object 

with gradations of color that blend into each other. Although these gradients 

are certainly useful, they are limited from a creative standpoint because they 

can be used only in linear or radial forms. In Illustrator 8, Adobe introduced 

a radical new feature called Gradient Mesh, an incredible tool that allows you 

to create gradients in any shape. The result is artwork that looks as if it had 

come right from Photoshop—yet all in vector form using the Gradient Mesh 

tool (Figure 4.49). And if you can achieve the appearance you’re looking for 

while keeping your fi le in vector form, you can keep your art completely scal-

able and editable throughout the design process. For example, changing one 

color in a gradient mesh is far easier than trying to replace a color that’s used 

in a Photoshop fi le.

However, the Gradient Mesh tool (U) isn’t the easiest feature to understand. 

Many people would like to use the feature, but they can’t fi gure out any 

consistent way to explain its behavior. This section will help you understand 

what a gradient mesh is and how it works.

Before you learn how to apply a gradient mesh, let’s talk about what a mesh 

is. A mesh is a grid consisting of multiple mesh points that act much like 

Figure 4.49 Illustrator 
Cheryl Graham uses the 
Gradient Mesh feature to 
create photorealistic clouds 
that are scalable to virtually 
any size.

TIP If you converted a 
path to a mesh object 

and then want to get the path 
back, you can select the mesh 
object and use the Off set Path 
function with a setting of 0. 
This creates a new path that 
you can edit and color as 
you want.
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smooth anchor points (Figure 4.50). You can adjust each of these points 

(and their control handles) to control the shape of the mesh. A mesh is really 

a special kind of construct or object in Illustrator, and it does not act like a 

regular path does. Mesh objects do not have normal fi ll or stroke attributes 

and can’t display certain kinds of live effects. Rather, you use mesh objects 

to contain two kinds of attributes in Illustrator: gradients and envelopes 

(envelopes were covered in Chapter 2, “Selecting and Editing Artwork”). 

When you’re using a mesh to defi ne a gradient, each mesh point determines 

a change in color, and the control handles for each point determine the way 

in which that color blends into other nearby colors.

You can create a gradient mesh object in Illustrator in two basic ways, and 

in both cases, you start by fi rst drawing a regular vector object. You don’t 

draw gradient mesh objects from scratch in Illustrator; you convert existing 

vector shapes to mesh objects. With a vector object selected, do one of the 

following:

• Choose Object > Create Gradient Mesh. This opens the Create Gradient 

Mesh dialog box, giving you the ability to specify the number of rows 

and columns in your mesh (Figure 4.51). If your original object already 

has a color applied to it, you can use the Appearance and Highlight 

options to shade the object with white.

Figure 4.50 A mesh is a 
grid that consists of mesh 
points and control handles.

NOTE You can use 
both process and spot 

colors in a gradient mesh, and 
the fi le will separate correctly 
when printed.

Mesh Points

Control Handles
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Figure 4.51 Choosing 
the number of rows and 
columns determines the 
number of mesh points 
in your mesh. You can 
always add or remove 
mesh points later.

• Select the Mesh tool from the Tools panel, and click anywhere within 

your vector path. Each click with the Mesh tool adds mesh points to the 

mesh object. You’ll also notice that as you add mesh points to an object, 

the paths connecting the mesh points match the contours of the object.

Once you have mesh points defi ned, you can switch to the Direct Selection 

tool and select each individual mesh point to adjust its position and its direc-

tion handles. With a mesh point selected, you can choose a color from the 

Swatches or Color panel to defi ne the color for that point. As needed, you 

can switch back to the Mesh tool and click to add mesh points. To remove a 

mesh point from a mesh object, hold the Option (Alt) while clicking a point 

with the Mesh tool.

ADDING PIZZAZZ WITH
THE FLARE TOOL
The Flare tool is really something spectacular, although it’s a one-trick pony. 

The tool is present in Illustrator to create fantastic lens fl ares of the likes 

you would normally create in programs such as Photoshop or Adobe After 

Effects CS4. However, the Flare tool creates these effects using only vector 

objects, not pixels, and Illustrator keeps them in an editable state, which 

makes them easy to adjust.

Drawing a Vector Lens Flare
Drawing a fl are with the Flare tool is basically a two-step process. First you 

defi ne where the highlight will go, and then you defi ne the angle of the 

light. In reality, though, many other little steps need to happen in between 

these two. To apply a lens fl are with the Flare tool, follow these instructions:

NOTE For additional 
inspirational examples 

of what you can do with 
gradient mesh, check out 
The Illustrator CS4 Wow! 
book by Sharon Steuer 
(Peachpit Press) and the 
online portfolio of 
Yukio Miyamoto (www.
bekkoame.ne.jp/~yukio-m/
intro/index.html).

TIP Because the Flare 
tool uses a variety of 

transparency blending 
modes, you may see odd 
results when adding fl ares 
that overlap areas with no 
background. Adding a white 
rectangle that fi lls your entire 
artboard and sending it to the 
back will help, or alternatively, 
you can create a mask that 
clips out the unwanted areas 
of the fl are (masks are cov-
ered in Chapter 9, “Drawing 
with Effi  ciency”).

www.bekkoame.ne.jp/~yukio-m/intro/index.html
www.bekkoame.ne.jp/~yukio-m/intro/index.html
www.bekkoame.ne.jp/~yukio-m/intro/index.html
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1. Select the Flare tool, which you’ll fi nd grouped with the closed-path 

shape tools (don’t ask why it’s there—just accept it; Figure 4.52).

2. Click and drag from the point where you want the center of the high-

light to be (Figure 4.53). Do not release the mouse button yet.

3. Press the up and down arrows to add and remove the number of rays 

in the lens fl are.

4. Release the mouse button.

Figure 4.52 The Flare tool 
is grouped with the closed-
path shape tools.

Figure 4.53 Clicking and 
dragging with the Flare tool 
is the fi rst step in creating a 
vector fl are.
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5. Click and drag to defi ne the lighting direction of the fl are. Do not 

release the mouse button yet (Figure 4.54).

6. Press the up and down arrows to add and remove the number of rings 

in the lens fl are.

7. Release the mouse to complete the lens fl are (Figure 4.55).

Figure 4.54 The second 
click and drag with the 
Flare tool defi nes additional 
options.

Figure 4.55 This is the fi nal 
lens fl are, after it has been 
applied.
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Editing a Vector Lens Flare
Even though it isn’t a live effect, once a fl are has been applied, it can still 

be edited—although not via the Appearance panel. To edit a fl are, follow 

these steps:

1. Select the fl are with the Selection tool.

2. Double-click the Flare tool in the Tools panel. The Flare Tool Options 

dialog box opens.

3. Specify any changes to the appearance of the fl are in the Flare Tool 

Options dialog box.

4. Click the Preview button, and you will see the changes apply to the 

fl are as you adjust the settings.

Although the Flare tool creates a cool effect, keep in mind that the trans-

parency features used could result in a fi le that might take a long time to 

process when printed. In addition, as with any “instant” design element, 

remember to use the Flare tool where the design warrants its use. It’s all 

too easy to get carried away by adding lens fl ares to everything you design.



Chapter 
FIVeOrganizing Your Drawing

Some people have clean, organized desks, 

whereas others have desks that are quite 

messy. Likewise, some designers organize 

their Adobe Illustrator CS4 fi les using 

groups and layers, while many do not. 

And just as there are benefi ts to keeping an 

orderly desk, there are advantages to using 

groups and layers for adding structure to 

your fi les. In Illustrator, not only do groups 

and layers offer a convenient way to manage 

objects in a fi le, but they can also control the appearance of your fi le. For 

example, applying a drop shadow to several objects that are grouped looks 

different from applying a drop shadow to those very same objects if they 

aren’t grouped. You may even fi nd that using groups and layers is necessary 

to create the art you need.

Speaking of the appearance of an object, you’ll spend a considerable amount 

of time with the Appearance panel in this chapter. The Appearance panel is 

arguably the most important panel in Illustrator, and you can apply the con-

cepts you learn in this chapter to just about every other feature in Illustrator.

The artwork featured throughout this chapter comes from Diane Labombarbe 

(iStockphoto; username: diane555).

133
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Selecting and Targeting

As you begin to learn about appearances in Illustrator, it’s important to understand what targets are. In Chapter 2, 
“Selecting and Editing Artwork,” you learned that you can select an object. However, when you apply an attribute 
to an object, such as a fi ll or a stroke, that attribute is applied to what Illustrator calls the target.

For the most part, selecting is an action that is used to defi ne a set of criteria that will be used for performing 
transformations. As you learned in Chapter 2, transformations consist of moving, scaling, rotating, skewing, 
and mirroring objects. You select objects because you want to move them from one side of your document 
to another, because you want to delete them, and so on.

Targeting, on the other hand, is an action that is used to defi ne a set of criteria specifi cally to apply an attribute 
such as a stroke, a fi ll, a transparency setting, or a live eff ect.

If you look at the Tools panel, though, you’ll fi nd a Selection tool, but you won’t fi nd a Targeting tool. Why? 
That’s because for the most part, Illustrator targets things for you automatically using something called smart 
targeting. When you select a path with the Selection tool, Illustrator automatically targets that path so you 
can apply attributes to it. When working with a single object, selecting and targeting are pretty much the 
same. However, when you start working with multiple objects, groups, and layers, it’s possible to have one 
item selected while something else is targeted. You’ll see clear examples of this later in this chapter when we 
discuss groups in Illustrator

UNDERSTANDING APPEARANCES
As we discussed in Chapter 3, “Technical Drawing,” a vector path can have 

certain attributes applied that defi ne the appearance of that path. When you 

print a fi le, you aren’t seeing the vector path; you’re seeing the appearance 

that was specifi ed for that path. An example of an attribute might be a par-

ticular fi ll or stroke. As you’ll learn later in this chapter, attributes can also 

be things such as drop shadows or 3D effects. In addition, you will learn 

that appearances are applied to something called a target. See the previous 

sidebar, “Selecting and Targeting,” for more information.

When you specify attributes, they appear listed in the Appearance panel. 

We know this sounds like a late-night infomercial, but if you keep only one 

Illustrator panel open on your screen while you’re working, make it the 

Appearance panel. In fact, the Appearance panel is probably the most impor-

tant panel in Illustrator—ever. To open the Appearance panel, choose 

Window > Appearance.
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Like X-ray vision, the Appearance panel enables you to look at your fi les and 

see how they were built or created. This panel also gives you access to every 

attribute of an object. And now in Illustrator CS4, you can also specify 

appearance attributes directly in the Appearance panel. But before we get 

ahead of ourselves, let’s start with the basics.

Understanding Attributes and 
Stacking Order
When a path is selected, the Appearance panel displays a thumbnail icon and 

the word Path, which is the target. The panel also lists, from the bottom up, 

the target’s opacity, its fi ll, and its stroke. To the left of each attribute are 

visibility icons (Figure 5.1). Clicking an attribute in the Appearance panel 

enables you to modify it, and clicking an attribute name that is underlined 

in blue opens the panel that controls all the settings for that attribute. For 

example, click anywhere to the right of the word Stroke to change its color 

or weight (Figure 5.2); click the word Stroke, and the Stroke panel appears, 

where you can specify cap, join, and dash settings (Figure 5.3).

Figure 5.2 Clicking to the right 
of an attribute gives you the 
ability to modify its settings.

Figure 5.3 If an attribute has a blue underline, 
clicking the attribute displays its respective panel 
or dialog box.

Target

Stroke

Fill

Opacity

Thumbnail

Visibility

Figure 5.1 The 
Appearance panel 
displays the attributes 
for the targeted item.
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The order in which the listed items appear in the Appearance panel isn’t 

arbitrary. From the bottom up, these attributes control the overall appear-

ance of the object. To better illustrate this important concept, let’s fi rst 

understand a core aspect of how vector objects are drawn in a document.

Objects are drawn in a hierarchy, determined by the order in which you 

create your art. For example, if you draw one shape and then draw a second 

shape, the second shape appears higher in the document’s hierarchy than the 

fi rst object. The easiest way to see this is to create two overlapping objects 

(Figure 5.4). In Illustrator, this hierarchy is called the stacking order. You can 

change an object’s place in the stacking order by selecting it and choosing an 

item from the Object > Arrange menu (Figure 5.5).

What most people don’t realize is that a single object also has a stacking 

order. By default, Illustrator defi nes an overall Opacity value for an object 

and then paints the fi ll and the stroke in that specifi c order. Why? One rea-

son could be that strokes are painted along the centerline of a path. That 

means if the weight of a path is set to 20 pt, the weight is distributed so that 

10 pts appear on both sides of the path (Figure 5.6). If Illustrator painted 

Figure 5.4 Modifying the 
stacking order allows you to 
overlap artwork in a variety 
of ways.

Figure 5.5 Choosing 
Object > Arrange > Bring 
to Front moves a selected 
object to the top of the 
stacking order.
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the fi ll after the stroke, the 10 pts of the stroke width that falls on the inside 

of the path would be covered or hidden by the fi ll (Figure 5.7).

What’s great about the Appearance panel is that not only can you use it to 

change the appearance of an attribute, but you can also use it to see the order 

that those attributes are applied in. Even better, you can change the stacking 

order. For example, dragging the Stroke attribute in the Appearance panel so 

that it appears listed beneath the Fill attribute instructs Illustrator to paint the 

Stroke attribute before it paints the fi ll (thus hiding half the weight of the 

stroke, as in Figure 5.7).

This ability to change the stacking order of attributes in an object’s painting 

order may not seem that exciting or useful right now, but it becomes quite 

important when we talk about groups and layers later in the chapter.

Figure 5.6 By default, the 
weight of a stroke is distrib-
uted along the centerline of 
the path.

Figure 5.7 By painting the 
stroke fi rst and the fi ll sec-
ond, the inner portion of the 
stroke becomes hidden by 
the fi ll.
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Targeting Attributes
Upon closer inspection of the Appearance panel, you’ll notice a disclosure 

triangle to the immediate left of the Stroke and Fill attributes. Clicking 

these disclosure triangles reveals an Opacity setting that lets you control the 

opacity of an object’s stroke and fi ll independently (Figure 5.8). In fact, a 

single path contains three Opacity settings by default: one for its stroke, one 

for its fi ll, and one for the overall object. When you apply an Opacity value 

to a single attribute, you’re targeting that specifi c attribute. And in case you 

were wondering, yes, it’s certainly possible to apply a 50% Opacity value 

to an object’s fi ll and also apply a 50% Opacity value to an overall object 

(resulting in a 25% opacity, if you think about it; see Figure 5.9).

Since it can be confusing at times, it’s important to realize that when you 

click an attribute in the Appearance panel, the attribute becomes highlighted 

to indicate that it is targeted. If you want to target the overall path or object, 

click the target that is listed at the top of the Appearance panel, near the 

Figure 5.8 Although the fi ll 
of this object has an Opacity 
setting of 50%, the stroke 
appears at 100% opacity.

Figure 5.9 Be aware of 
the accumulative eff ect of 
applying Opacity values to 
an overall object as well as 
to its attributes.
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thumbnail (Figure 5.10). Alternatively, you can click in the empty area that 

appears beneath all the attributes listed in the Appearance panel.

Figure 5.10 Clicking the 
target is a quick way to 
target the entire object, not 
just one of its attributes.

Applying Multiple Attributes
Objects that have a single fi ll and a single stroke are referred to as having 

a basic appearance. However, vector objects aren’t limited to just one fi ll and 

one stroke. In fact, a single object can contain as many fi lls or strokes that 

your creative mind craves. An object with more than just one fi ll or stroke is 

referred to as having a complex appearance.

To add an attribute to an object, click the Add New Stroke or Add New Fill 

button at the bottom of the Appearance panel (Figure 5.11). You can also 

target any existing attribute and click the Duplicate Selected Item button. 

Once you’ve added an attribute, you can change its place in the stacking 

order by dragging it above or beneath other attributes in the Appearance 

panel. You can also remove targeted attributes by clicking the Delete Selected 

Item button.

Figure 5.11 There’s no limit 
to how many fi lls or strokes 
you can add to an object in 
Illustrator.

Add New Stroke Add New Fill
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You may be wondering what good two fi lls or two strokes do in an object, 

because one always covers the one beneath it. Earlier, we discussed the 

ability to target a specifi c attribute so that you can apply settings to each 

individually. By applying different attributes to two different fi lls and by 

applying an overprint or an Opacity setting to the top fi ll, you can create 

some interesting effects (Figure 5.12).

Likewise, you can add numerous strokes, each with different widths, colors, 

and dash patterns, resulting in useful borders and effects (Figure 5.13). 

Although you can certainly use more traditional methods to simulate these 

effects by overlapping multiple objects on top of each other, adding multiple 

attributes to a single path means you have just one path to work with and 

edit (as opposed to multiple paths). Considering the Illustrator limitation 

of being able to edit only a single control handle of a single path at any one 

time, seemingly simple edits to multiple paths could prove extremely diffi -

cult and require much time and effort. Another benefi t, as you’ll learn about 

in Chapter 9, “Drawing with Effi ciency,” is the ability to turn complex 

appearances into graphic styles.

TIP To reduce a 
selected object to 

a single fi ll and a single 
stroke with those attributes 
set to None, click the 
Clear Appearance button 
at the bottom of the 
Appearance panel.

Figure 5.12 Combining 
two fi lls in a single object 
lets you create interesting 
eff ects, such as a pattern fi ll 
with an overlapping trans-
parent gradient fi ll.

NOTE Even if you 
don’t use the 

Appearance panel to add 
multiple Fill or Stroke attri-
butes to an object, you may 
work with someone else’s fi le 
that does contain a complex 
appearance. As such, it’s 
always important to use the 
Appearance panel when 
working in any document.
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New Art Has Basic Appearance

Ordinarily, Illustrator styles a newly drawn object based on the last object that was selected. For example, 
if you click an object with a black stroke and a yellow fi ll, the next object you draw will have a black stroke 
and a yellow fi ll. However, if you select an object with a complex appearance and then create a new shape, 
the default behavior is that Illustrator will not style the new object with the complex appearance. Instead, 
Illustrator uses the basic appearance of the previously selected object (Illustrator uses the topmost Fill and 
Stroke attributes and does away with any that appear beneath them in the appearance’s stacking order).

In the Appearance panel menu, you can deselect the New Art Has Basic Appearance setting (Figure 5.14), 
which instructs Illustrator to draw new shapes using the full complex appearance of any previously selected 
object. If you ever want to reduce an object to its topmost fi ll and stroke while removing all additional attri-
butes that appear underneath, you can choose Reduce to Basic Appearance from the same panel menu.

Figure 5.14 Selected by 
default, the New Art Has 
Basic Appearance set-
ting forces newly drawn 
objects to always have 
basic appearances.

Figure 5.13 Using overlap-
ping multiple strokes on a 
single object is one way to 
simulate stitching patterns.
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Expanding Appearances
You’ll notice that you can’t target a specifi c fi ll or stroke of an object from 

the artboard—the only place to access this functionality is through the 

Appearance panel. This makes the Appearance panel infi nitely important, 

but it may make you wonder how an object with a complex appearance will 

print. After all, how does the printer or export format know how to draw 

these multiple attributes on a single path?

The answer is that Illustrator breaks these complex appearances down into 

multiple overlapping paths—each path contains a basic appearance. This 

process, called expanding, doesn’t happen on your artboard—it happens in 

the print stream or the export process.

Sometimes you may want to manually expand your appearances to access the 

multiple attributes as individual objects on the artboard. To do so, choose 

Object > Expand Appearance. Remember that once you’ve expanded an 

appearance, you are dealing with a group of multiple objects, not a single 

object anymore (even fi lls and strokes are separated into individual objects). 

Each of the individual objects has a basic appearance, and you have no way 

to return to the original complex appearance.

ENHANCING APPEARANCES WITH
LIVE EFFECTS
Illustrator refers to effects as live effects. There are several reasons for this. 

First—and most important—any effect you apply from the Effect menu 

is added as an attribute in the Appearance panel. Second, all effects can 

be edited at any time, even after the fi le has been closed and reopened at 

another date. Finally, when an object’s path is edited, any effects that are 

applied to that object are updated as well. Because these effects are nonde-

structive, they are considered “live” and are always editable.

The way that Illustrator accomplishes this live behavior is by keeping the 

underlying vector object intact, while changing just the appearance of the 

object by adding the effect. Think of those 3D glasses you used to get at 

the movie theater. Without the glasses, the movie appears like any other, 

but once you don the glasses, the movie appears to be 3D. You can think of 

the Appearance panel as a pair of 3D glasses in this sense—once you add an 

NOTE Although some 
people don’t trust 

Illustrator and expand all 
appearances before sending 
fi nal fi les off  to print, we don’t 
condone such behavior. There 
is no risk in printing fi les with 
appearances—they print just 
fi ne. Additionally, expanding 
your appearances limits your 
options if you have to make 
a last-minute edit or if your 
printer has to adjust your fi le.



ENHANCING APPEARANCES WITH LIVE EFFECTS 143

effect, the object changes in appearance, but the original untouched vector 

paths remain beneath the hood (Figure 5.15).

You can choose from many live effects in Illustrator, including those that 

are vector-based (such as Scribble) and those that are raster-based (such as 

Gaussian Blur). For the purposes of understanding how these effects work 

and how they interact with the Appearance panel, we’ll discuss what is 

arguably the most commonly used live effect—Drop Shadow—in this 

chapter. The remainder of the live effects are covered in detail in Chapter 7, 

“Working with Live Effects.”

Applying a Live Effect
You can apply a live effect, such as a drop shadow, to a target in two ways: 

choose Effect > Stylize > Drop Shadow or click the Add New Effect 

button at the bottom of the Appearance panel and choose Stylize > Drop 

Shadow (Figure 5.16 on the next page). The Drop Shadow dialog box 

appears, where you can specify the exact settings for the drop shadow 

including the blending mode, opacity, offset (the distance between the 

object and its shadow), and blur amount (the softness of the shadow). 

Additionally, you can choose a color or darkness value for your drop shadow 

(Figure 5.17, also on the next page). Note that the dialog box has a Preview 

option, which, when selected, lets you see your shadow update as you make 

changes to the settings. Once you’re happy with the appearance of your 

drop shadow, click OK to apply it.

Figure 5.15 After a Warp 
eff ect has been applied, 
a vector shape appears 
distorted (left). When 
viewed in Outline mode, 
you can see the underlying 
vector shape still exists, 
unscathed (right).

TIP Just as adding a 
second fi ll or stroke cat-

egorizes an object as having a 
complex appearance, adding 
a live eff ect to an object also 
produces an object with a 
complex appearance.
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Now, let’s take a look at the Appearance panel. Note that the path is listed 

as the target, and then examine the attributes in the object itself. Reading 

from the bottom up (the order in which the attributes are drawn), you have 

the default transparency, the Drop Shadow effect you’ve just applied, the fi ll, 

and fi nally the stroke of the object (Figure 5.18). The drop shadow appears 

beneath the fi ll and the stroke of the object because it wouldn’t be much of a 

drop shadow if it were painted above the fi ll and stroke, would it?

Figure 5.16 You can apply 
live eff ects directly from the 
Appearance panel.

Figure 5.17 The Drop 
Shadow live eff ect gives you 
the ability to control all the 
specifi cs of creating a soft 
drop shadow.

TIP To choose a spot 
color for your drop 

shadow, you must fi rst defi ne 
the desired color as a swatch 
(covered in Chapter 6, “Color-
ing Artwork”). Click the color 
swatch in the Drop Shadow 
dialog box, and then click the 
Color Swatches button, where 
you’ll fi nd your custom color 
in the list of swatches.
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The truth is, you can use the Appearance panel to control exactly how and 

where your drop shadow—or any live effect—is painted. You can target 

the Fill or Stroke attribute in the Appearance panel and then add the drop 

shadow. In this way, you can add a live effect to just the fi ll or just the stroke 

of an object. If your object contains multiple fi lls or strokes, you can apply 

live effects to each of them individually (Figure 5.19). Even though you’ve 

already applied a live effect to an object, you can drag the effect within the 

Appearance panel to change its place in the stacking order or to apply it to a 

specifi c fi ll or stroke (Figure 5.20 on the next page).

Figure 5.18 By default, 
the Drop Shadow eff ect is 
added underneath the Fill 
and Stroke attributes in the 
stacking order.

Figure 5.19 You can apply 
live eff ects to fi lls or strokes 
of objects individually. Here, 
the drop shadow is applied 
just to the stroke of an 
object.
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Editing a Live Effect
One of the important benefi ts of live effects is that you can edit them at any 

time. Clicking the blue underlined name of an effect that is listed in the 

Appearance panel opens the dialog box for that effect, where you can view 

the current settings and change them at will (Figure 5.21). This may be 

confusing initially, because you’d think that in order to change an effect, 

you’d return to where you fi rst applied the effect (that is, the Effect menu). 

Doing so actually adds a second effect to the selected object (Figure 5.22). 

Illustrator allows you to apply an effect to an object as many times as you’d 

like, and in Chapter 7, you will explore when that might be benefi cial. The 

important thing to remember is that when you want to add a new effect 

to an object, you do so by using the Effect menu or by clicking the Add 

New Effect button. To edit an effect that already exists, click its name in the 

Appearance panel.

Figure 5.20 When drag-
ging an eff ect within the 
Appearance panel, black 
arrows indicate when you’re 
about to apply the eff ect to 
a specifi c fi ll or stroke.

TIP You can duplicate 
an eff ect by dragging it 

in the Appearance panel while 
holding the Option (Alt) key.

Figure 5.21 To edit an 
existing eff ect, click its 
name in the Appearance 
panel.



WORKING WITH GROUPS 147

Loading Attributes with the Eyedropper Tool

You can use the Eyedropper tool in Illustrator to load the attributes of existing 
objects quickly. This can be useful in two ways. First, if you already have an 
object selected when you click another object with the Eyedropper tool, your 
selected object changes to match the object you clicked. Second, you can click 
once with the Eyedropper tool to sample the attributes of an object, and you 
can then Option-click (Alt-click) to apply those attributes to other objects in 
your fi le without actually having to select them.

You can confi gure the Eyedropper tool to sample just the basic appearance 
of an object (the topmost fi ll and stroke) or complete complex appearances. 
To control what the Eyedropper tool can sample, double-click the tool in the 
Tools panel.

Shift-click with the Eyedropper tool to sample colors from the pixels of ras-
ter images (or even the visual appearance of vector objects). In this way, the 
Eyedropper tool works much like the one in Adobe Photoshop CS4.

WORKING WITH GROUPS
As we mentioned at the beginning of this chapter, creating groups is a way to 

organize the elements in a fi le. Most importantly, groups allow you to easily 

select or work with several objects that may belong to a single design element. 

You can also nest groups, meaning you can have groups within other groups. 

For example, you might have a logo that consists of an icon and a type treat-

ment that has been converted to outlines. You can group the objects that 

make up the icon, and you can put the items that make up the type treatment 

into a separate group. You can then create an overall larger group that con-

tains the other groups within it (Figure 5.23 on the next page).

Figure 5.22 If you try to 
edit an existing eff ect by 
choosing the item from 
the Eff ect menu, Illustrator 
informs you that you must 
edit existing eff ects through 
the Appearance panel.
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Nested group (hose)

Nested group (nozzle)

Nested group (drops)

Nested group (type)

Parent group

Nested group (nozzle/hose/drops)

When you think of groups in this way, it’s simply a matter of labeling 

certain objects that belong together. But in reality, a group is more than 

just a concept—a group is actually an entity itself. A group exists, just as an 

object does, only we don’t see it. Illustrator refers to a group as a container—

something that contains the objects within it. This introduces two impor-

tant concepts: The container itself can have attributes applied to it, and the 

container can affect the way the grouped objects interact with each other 

and other art elements in your fi le.

Adding a Soft Drop Shadow to a Group
Let’s take a look at a simple example using the Drop Shadow effect you just 

learned about in the previous section:

1. Start with a set of several overlapping shapes, and create an exact copy 

of that set of shapes.

2. Select one set of shapes, and choose Object > Group to create a group 

that contains the set of objects.

At this point, you’re looking at two design elements, each identical in 

appearance, but one is a group while the other is just several individual 

objects (Figure 5.24).

Figure 5.23 An example of 
a nested group structure.



WORKING WITH GROUPS 149

3. Using the Selection tool, select the set of individual objects, and look at 

the Appearance panel.

The target for your selection is listed as Path with Mixed Appearances

(because each shape is fi lled with a different color).

4. Select the grouped objects, and again, take a look at the Appearance 

panel. The target is now listed as Group.

This is actually the smart targeting in Illustrator at work—by selecting 

the group, Illustrator didn’t target the individual paths within the group; 

instead, the group becomes the target. When the group is targeted, the 

Appearance panel displays the word Contents, which are the paths that 

are found in the group (Figure 5.25).

Earlier in the chapter, you learned that appearances aren’t applied to a selec-

tion; rather, they are applied to the target. Keeping that in mind, let’s apply 

the Drop Shadow effect to these two sets of objects. Select each set of 

objects, and apply the Drop Shadow effect. You’ll notice that when the drop 

shadow is applied to the set of individual objects, each object appears with 

Figure 5.24 The design ele-
ments shown here are iden-
tical except for one fact: The 
elements on the right have 
been grouped.

Figure 5.25 When you 
select a group, Illustrator 
automatically targets the 
group. The elements within 
the group are referred to 
as the contents, which are 
listed in the Appearance 
panel.
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its own shadow. However, the grouped objects appear with a single uni-

fi ed drop shadow—as if all the objects were really one single shape (Figure 
5.26). This happens because the group was the target, so the drop shadow 

was added to the group, not to the paths. You can clearly see evidence of this 

by using the Direct Selection tool to select just one of the shapes within the 

group and then copying and pasting that shape into a new document. You’ll 

notice that in the new document the shape doesn’t have a drop shadow at all.

Let’s take this concept, that a group is a container, one step further. Say you 

have a group of objects and you apply a drop shadow. As you’ve already 

learned, the drop shadow is applied to the group. But what happens to the 

drop shadow if you then choose Object > Ungroup? By ungrouping the 

objects, you’re deleting the container. And it was the container that had 

the Drop Shadow effect applied to it, not the objects themselves. So if you 

ungroup the objects, the drop shadow simply disappears.

Adding a Stroke to a Group
To strengthen your understanding of how groups work in Illustrator, let’s 

explore another example using a group of objects. You already know that a 

group can have attributes applied to it, as evidenced by the drop shadow you 

applied earlier. You also know you can apply multiple attributes to objects. 

Using this knowledge, you can add a stroke to a group:

1. With the Selection tool, select the group, and take note that the group is 

the target in the Appearance panel.

2. Click the Add New Stroke button in the Appearance panel to add a 

stroke to the group, and just to make it easier to see, change the stroke 

weight to 4 pt.

Figure 5.26 Applying a 
drop shadow to individual 
objects (left) is diff erent 
from the same drop shadow 
applied to a group of 
objects (right).
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The stroke is applied across all paths within the group (Figure 5.27).

It’s interesting to note that all the objects in the group exhibit the appearance 

of the stroke, even objects that appear beneath other objects in the stacking 

order. A close examination of the stacking order in the Appearance panel 

reveals why: the contents of the group are drawn before the stroke is painted. 

At the group level, all objects are considered as they are combined (like you 

saw with the drop shadow example), so the stroke is applied equally to all 

paths. Dragging the stroke to appear beneath the contents in the Appear-

ance panel stacking order will result in a stroke that appears only around the 

perimeter of the group (Figure 5.28).

You can clearly see how groups can have attributes applied to them and 

how they can control how grouped objects interact with each other. In this 

context, you begin to see that grouping objects is more than just making 

Figure 5.27 When applied 
at the group level, a stroke 
appears across all the paths.

Figure 5.28 By adjusting 
the stacking order of the 
group, the stroke appears 
only along the perimeter 
of the group.
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fi les easier to manage. Creating groups can have a signifi cant impact on 

the appearance of your art. Likewise, simply ungrouping art can alter the 

appearance of your fi le completely.

The obvious questions you should be asking are “How do I know when 

I’m applying an attribute to an object versus a group?” and “How can I tell 

whether ungrouping something will alter the appearance of my fi le?” The 

answers lie in the all-important Appearance panel, which tells you what is 

targeted and what attributes and effects are applied (Figure 5.29).

Figure 5.29 When you 
select a single path within 
a group, the Appearance 
panel here tells you that 
the path is in a group that 
has a Stroke or Fill attribute 
applied to it.

Type as a Group

Type is a special kind of object in Illustrator—it’s actually a group. The Type object is the container, and the 
actual text characters are like the objects inside a group. You can see this by looking at—that’s right—the 
Appearance panel. Select a point text object with the Selection tool, and the Appearance panel shows 
Type as the target. Switch to the Type tool and select the text, and the Appearance panel shows Characters 
as the target.

When you select a Type object with a selection tool, the smart targeting in Illustrator automatically targets the 
Type container. You can see Characters listed in the Appearance panel, and double-clicking the Characters list-
ing automatically switches to the Type tool and highlights the text on your artboard (Figure 5.30). The target 
is now Characters, and you can see the Fill and Stroke attributes.

Figure 5.30 When a Type 
object is selected, the 
Appearance panel shows 
it as the container and the 
characters within it.

TIP The current target 
is also displayed on the 

far left side of the Control 
panel.
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USING ISOLATION MODE
Sometimes you’ll want to draw a new object and add it to an existing group. 

For example, say you have several elements in a group that has a drop shadow 

applied to it and you’d like to add another design element to that same group 

and have it take on the shadow as well. If you were to ungroup the existing 

elements, draw the new shape, and then reselect all the objects and create a 

new group, you would lose the appearance of the drop shadow (this would 

actually happen as soon as you ungrouped the elements). So, what you really 

want is a way to add elements to an existing group—without destroying 

the group. Thankfully, such a method exists in Illustrator, and it’s called 

isolation mode.

Using the example just discussed, you would use the following method to 

add a new element to an existing group:

1. Using the Selection tool, double-click any object in the group. This 

activates isolation mode, and it isolates the group. A gray bar appears 

across the top of the document window, and all other artwork in the fi le 

becomes dim, indicating that the group is now isolated (Figure 5.31).

NOTE Isolation mode 
is especially useful 

when you’re using Live Paint 
groups, which are covered in 
detail in Chapter 4, “Creative 
Drawing.”

Figure 5.31 When in iso-
lation mode, a gray bar 
appears across the top of 
the document window, 
and all other artwork on 
the artboard is dimmed. 
Any new artwork created 
is drawn directly into the 
isolated group.
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2. Draw a new element. Any new shapes or objects that are created now 

become part of the group.

3. Press the Escape key on the keyboard to exit isolation mode. Alterna-

tively, you can double-click any blank area on the artboard, or you can 

click any empty area in the gray bar at the top of the document window 

to exit isolation mode as well (Figure 5.32).

Figure 5.32 Icons in the gray bar (referred to as breadcrumbs) help identify where 
the isolation is in the document’s object hierarchy. Clicking the arrow moves you 
up the hierarchy one step at a time.

In reality, the usefulness of isolation mode extends far beyond working with 

groups. In Illustrator CS4, Adobe has extended the functionality of isolation 

mode so it works with individual paths as well. In fact, the whole point of 

isolation mode is to allow for a way to make quick edits in complex docu-

ments. If you have nested groups, each double-click isolates another level 

of the object hierarchy—even down to individual paths. In addition, when 

artwork is isolated, it temporarily pops to the front of the stacking order 

(until you exit isolation mode, when it returns to its place). This makes it 

easy to perform quick edits to just about any part of a complex illustration 

without having to constantly lock and unlock other objects that might get 

in the way. Isolation mode is also useful when working with masks, which 

we’ll cover in Chapter 9.

WORKING WITH LAYERS
Layers are nearly identical to groups in concept, but they offer more fl exibil-

ity and functionality. Whereas groups are used to combine design elements 

in a fi le, layers also allow you to organize and combine elements within a 

fi le. Just as groups can be nested within each other, so can layers. And just 

as groups are containers that hold contents within them, layers are con-

tainers as well. In addition, layers, just like groups, can also have attributes 

applied to them. As you explore the power of layers in this section, all of 

these concepts will come to light.

TIP The idea for isola-
tion mode came from 

Adobe Flash Professional, 
which can edit groups and 
symbols in the same manner.

TIP The General panel 
in Illustrator Prefer-

ences contains a setting to 
disable the ability to isolate a 
group by double-clicking it.
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The Signifi cance of Layers

Don’t be fooled into thinking that layers are just for making fi les neat and 
organized. Quite the contrary—a fi le that takes advantage of using layers 
can benefi t from many other features as well:

• Layer clipping masks. Illustrator has the ability to make the topmost 
object in a layer a mask for all items within that layer.

• PDF layers. Illustrator can export PDF fi les with layers intact, allowing 
users in Adobe Acrobat or Adobe Reader to interactively turn on and off  
those layers. Additionally, Adobe InDesign CS4 has the capability to con-
trol the visibility of PDF layers.

• Photoshop export. When exporting an Illustrator fi le to a PSD fi le, you 
can choose to have layers preserved, thus making your fi le easier to edit 
when you bring it into Photoshop.

• Transparency. Sometimes artwork with transparency can result in fi les 
that look less than perfect when printed on a high-resolution press—if 
the fi le is built in a certain way. Using layers can signifi cantly reduce the 
number of issues you might encounter when using transparency features.

• Animation. When creating art for frame-based animations, such as those 
used in GIF and SWF (Flash) animations, Illustrator layers serve as frames. 
Layers are also integral when you are creating art that will be animated in 
programs such as Flash and Adobe After Eff ects.

• Cascading Style Sheets (CSS). Illustrator layers can be exported as CSS 
layers when you’re creating web layouts and SVG graphics, allowing for 
greater fl exibility and better support for browser standards.

• Scalable Vector Graphics (SVG). Illustrator layers serve as basic build-
ing blocks when you’re creating fi les that are going to be saved as SVG. 
Providing structure for SVG fi les can help make it easier to animate and 
edit the SVG fi les in a web or wireless environment.

• Variables. The XML-based variables feature in Illustrator relies on the 
organization of layers in your document. Object visibility and naming 
conventions are all done through the Layers panel.

There are plenty of other good reasons to use layers in Illustrator, and you’re 
sure to fi nd yourself using layers more and more.
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Using the Layers Panel
You’ll start learning to use layers by taking a look at the Layers panel and 

learning some of its simple functions. Then you’ll put together everything 

you’ve learned in this chapter to take full advantage of the power found in 

the Layers panel.

By default, all Illustrator documents are created with a single existing layer, 

called Layer 1. The buttons across the bottom of the panel are used to acti-

vate clipping masks (which Chapter 9 will cover in detail), create new lay-

ers and new sublayers, and delete layers. To the left of each layer are two 

boxes—the box on the far left controls layer visibility, whereas the other box 

enables locking (Figure 5.33). The Layers panel menu contains duplicates 

of these functions, as well as some other functions that we’ll cover when we 

talk about animation in Chapter 13, “Web and Mobile Design.”

Double-clicking a layer enables you to specify several settings for that layer 

(Figure 5.34).

• Name. Every layer can have its own distinct name. Layer names are 

important when you’re creating SVG fi les and generally make fi les 

easier to work with. Naming layers is especially important when you’re 

designing templates. A fi le littered with layers named Layer 1, Layer 2, 

Layer 3, and so on, can make editing a challenging task.

Figure 5.33 All fi les are 
created with a blank layer 
in the Layers panel.

Layer Color

Visibility Icon

Lock Icon

Layer Name

Make/Release Clipping Mask

Create New Layer

Create New Layer
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• Color. This setting is a bit deceiving because it doesn’t add a fi ll color to 

the layer but instead defi nes the selection color used for the layer. When 

you select an object in Illustrator, the path of that object is highlighted 

so that you see what is selected. By assigning different colors to each 

layer, you can tell what objects belong to which layer by selecting the 

object and observing the highlight color. Setting a layer color to black 

or really light colors generally isn’t a good idea because you won’t be 

able to differentiate a selection from a regular path. A layer’s color also 

appears along the left side of the layer name in the Layers panel.

• Template. This setting is used specifi cally when you want to manually 

trace placed images. Setting a layer as a template automatically locks the 

layer, disables printing of that layer, and sets the Dim Images to setting 

to 50 percent. Although this makes it easier to see and draw over placed 

images, the new Live Trace feature makes this option less important.

• Show. This setting controls layer visibility (whether the art on a layer is 

shown or hidden) and performs the same function as clicking the vis-

ibility icon in the Layers panel.

• Preview. This setting controls the preview setting for the chosen layer. 

By default, Preview mode in Illustrator is turned on, but deselecting 

this option displays the layer in Outline mode.

• Lock. This setting controls layer locking and performs the same func-

tion as clicking the lock/unlock icon in the Layers panel. Locking a layer 

effectively prevents you from selecting any object on that layer.

• Print. By default, all layers in a fi le will print. However, Illustrator 

allows you to deselect this option to create a nonprinting layer. This 

can be useful when you want to add instructions to a template fi le or 

to explain how a fi le should be folded or printed but you don’t want 

those instructions to print. Layers that have the Print option deselected 

appear in italic in the Layers panel.

Figure 5.34 The Layer 
Options dialog box allows 
you to specify settings for 
each layer—most notably, 
the name of the layer.

TIP Option-click 
(Alt-click) the visibility 

icon of a layer to hide all 
other layers with one click. 
Option-click (Alt-click) once 
more to show all layers again. 
The same shortcut applies 
to the lock icon as well. To 
change layer visibility for 
multiple layers, you can click 
and drag across several layers.
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• Dim Images to. This option lets you defi ne an Opacity setting for how 

placed images appear on your screen. By making placed images dim, 

you can make it easier to manually trace them. This feature is often 

used in tandem with the Template function.

Confi guring the Layers Panel

The Layers panel in Illustrator displays more than just layers—it also displays all the objects in your fi le. 
Many people are confused and think that all elements displayed in the Layers panel are layers. (It’s called the 
Layers panel, so can you really blame them?) It’s actually pretty easy to determine what is a layer and what 
is an object—layers appear with a shaded gray background, and objects appear with a white background 
(Figure 5.35). This functionality that was added way back in Illustrator 9, and it allows a user to locate any 
object from the Layers panel.

Figure 5.35 In the Layers panel, 
objects have white backgrounds, 
and layers have gray backgrounds.

If you fi nd that the level of detail off ered by the Layers panel is beyond the needs of your simple design tasks, 
you can set the behavior of the Layers panel to match the functionality that existed prior to Illustrator 9. 
Choose Panel Options from the Layers panel menu, and select the Show Layers Only check box (Figure 5.36). 
This hides all objects from the Layers panel. Additionally, you can turn off  layer thumbnails (which will signifi -
cantly enhance performance). For documents that have lots of layers (such as maps, for example), you might 
also choose the Small option for Row Size. One caveat to these options is that they are document-specifi c, 
which means you need to change these settings for each document.

Figure 5.36 The Show Layers 
Only option keeps the Layers 
panel from displaying objects.
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Understanding Object Hierarchy
When a layer contains artwork, a disclosure triangle appears just to the left 

of the layer. Clicking this triangle reveals the contents of the layer within 

the Layers panel (Figure 5.37). Every object that appears in an Illustrator 

document appears listed in the Layers panel. As you learned earlier in this 

chapter, the order in which items appear has signifi cance—it indicates the 

stacking order, or object hierarchy, of the fi le. Objects that appear at the 

bottom of the Layers panel are drawn fi rst, and therefore they appear at 

the bottom of the object stacking order.

Figure 5.37 Clicking a 
disclosure triangle reveals 
the raw power of the Layers 
panel—the ability to view 
the entire object hierarchy 
of a fi le.

You can drag items listed in the Layers panel to adjust where they sit in the 

stacking order. Dragging an object from the bottom of the Layers panel to 

the top of the panel places that object at the top of the stacking order. It’s 

important to note that each layer and each group also maintain their own 

stacking orders. The Layers panel basically represents the stacking order of 

the entire fi le.

You can create nested layers by dragging one layer into another layer. You can 

do the same with groups, which makes it easy to organize your artwork even 

after the art is created. In fact, this method of dragging items within the 

Layers panel makes it possible to move objects from one group and place 

them into another group (Figure 5.38 on the next page). As you learned ear-

lier in this chapter, groups can have attributes applied to them; this becomes 

signifi cant because when you’re moving an object into a group that has an 

attribute applied to it, that object takes on the attributes of the group. The 

reverse applies as well, so simply moving an object from one layer to another 

or into or out of a group can change the appearance of the art in your fi le.

NOTE In the Layers 
panel, layers and sub-

layers appear with shaded 
backgrounds, and objects 
appear with white back-
grounds.
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Using Layers and Appearances
When an object is selected, a small colored square appears in the far right 

end of the Layers panel. Small squares indicate that an object is selected, 

and larger squares indicate that all objects on a layer are selected (layers with 

small squares indicate that only some elements on that layer are selected). 

You can move an object from one layer to another simply by dragging the 

square into the desired layer. Holding the Option (Alt) key while dragging 

the square moves a copy of the object into the desired layer.

If you take another look at the Layers panel, you’ll notice that to the right of 

every item listed is a small circle, called the target indicator (Figure 5.39). If 

you remember, we spoke earlier about how the target controls where attri-

butes are applied. If you take the same examples we used earlier, the ones of 

identical design elements of which one is grouped and one is not, you can 

clearly see how targeting works.

Figure 5.38 When you’re 
dragging layers in the Layers 
panel, black arrows on the 
left and right indicate that 
you’re moving a layer into 
another layer rather than 
above or below it.

Figure 5.39 The little circles 
that appear on the right 
side of each layer are target 
indicators.
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In the Layers panel, ungrouped design elements appear listed as separate 

paths, whereas the grouped design element appears as objects nested inside 

a group (Figure 5.40). When you select the fi rst design element, a double 

circle appears on each of the individual paths, indicating that those paths are 

targeted (Figure 5.41). Now select the grouped design element, and you’ll 

see that although the objects are selected, the group is targeted (Figure 5.42).

Figure 5.40 A quick look at 
the Layers panel reveals the 
hierarchy of the fi le. Layer 1 
contains four path objects 
and a group. The group con-
tains four path objects.

Figure 5.41 Selecting the 
path objects also targets 
the four individual paths. 
The large squares to the 
right indicate the objects 
are selected, and the small 
square to the right of the 
layer indicates that some 
objects on the layer, but not 
all of them, are selected.

Figure 5.42 When select-
ing the group, the smart 
targeting feature targets 
the group, not the objects. 
Notice the double circle 
target indicator appears 
only on the group, not the 
objects.
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Now add a drop shadow to each of the design elements. A quick glance at 

the Layers panel now shows that some of the target indicators are shaded 

or fi lled, whereas some of the target indicators are hollow (Figure 5.43). 

Hollow circles indicate that the item listed has a basic appearance, whereas 

fi lled circles indicate that a complex appearance exists on that object. Just by 

looking at the Layers panel, you can tell that the second design element has 

some kind of effect applied to the group. This is your fi rst indication that 

ungrouping such a group will result in a change in appearance—without 

having to even select it fi rst.

You can manually target groups or layers by clicking the target indicator 

for that object. For example, just as you learned how to apply a stroke to 

a group earlier in this chapter, you can click the target circle of a layer and 

then add a new stroke to that layer. By moving the Stroke attribute beneath 

the contents of the layer in the Appearance panel, all objects that appear on 

that layer will have a stroke at the perimeter. When you move a shape into 

such a layer, the object automatically appears to have a stroked appearance, 

and likewise, when you move an object out of the layer, that stroked appear-

ance disappears.

The important concept to remember is that taking a quick look at the Layers 

panel and scanning for fi lled target circles helps you fi nd complex appear-

ances in the fi le. In this way, you won’t accidentally change a fi le’s appear-

ance just by grouping or ungrouping objects. The Appearance panel is also 

useful in helping you understand how fi les are built because it displays how 

complex appearances were added to the fi le.

Figure 5.43 Shaded target 
indicators show where com-
plex appearances exist.

TIP Dragging a fi lled 
target circle from one 

layer or object to another 
eff ectively copies the complex 
appearance and applies it to 
the object to which you are 
dragging it.
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PUTTING IT ALL TOGETHER
The importance of the Appearance panel is obvious. Without it, you have no 

way to edit multiple attributes applied to an object, you have no way to edit 

attributes that are applied to groups or layers, and you have no way to edit 

the properties of a live effect.

The importance of the Layers panel is equally apparent. Without it, you have 

no way to understand the hierarchy of a fi le, and you have no warning as 

to when a simple action such as grouping or ungrouping will change a fi le’s 

appearance.

But it’s deeper than that. The Appearance panel is like the Matrix—you can 

look at it and see the underlying makeup of any Illustrator fi le. By using 

the Layers and Appearance panels together, you can quickly and effi ciently 

reverse-engineer any fi le you receive (Figure 5.44). If you’re a production 

artist who needs to know every detail about a fi le or if you’re trying to trou-

bleshoot a particular fi le, these two panels will be your best friends.

Throughout the chapters of this book, you’ll see how features such as 

clipping and opacity masks, envelope distortions, and placed images are 

all easily identifi ed in the Layers panel. You’ll also learn the importance of 

using layers when you’re creating content you’re planning to animate in 

Flash or with the SWF export feature in Illustrator.

Figure 5.44 Don’t trust 
everything you see on the 
artboard. By using both the 
Appearance panel and the 
Layers panel, you will be 
able to see exactly how any 
art was created and, most 
importantly, how to edit it 
quickly.
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Chapter 
SixColoring Artwork

At one time, Adobe Illustrator (back in version 1.1) was 

black and white only. Then, Illustrator 88 introduced 

color features. Of course, back then, few designers 

could even afford to buy a color monitor. Technology 

eventually caught up, and color plays a huge role in a 

graphic designer’s life today. The ability to add color 

and manipulate it, view it accurately on a monitor, and 

give life to artwork with color are abilities we take for 

granted; however, the challenges of working with color 

are still present.

In this chapter, you’ll learn about creating color in Adobe Illustrator CS4 

and applying it to your artwork, as well as a variety of ways to edit or modify 

colors.  Illustrator features a collection of powerful inspirational tools that 

you can use to develop color harmonies and custom color palettes; you’ll 

explore them in this chapter. Finally, you’ll discover how to trust the color 

that appears on your computer screen and learn to use various settings to 

simulate different color-viewing environments.

The artwork featured throughout this chapter comes from Kemie Guaida Ortega 

(iStockphoto; username: kemie).
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CREATING AND USING COLOR
IN ILLUSTRATOR
Whether you are working with graphics that are to be printed (which use a 

combination of cyan, magenta, yellow, and black, also known as the CMYK 

color model) or those that are to be displayed on computer screens, televi-

sions, or monitors (which use red, green, and blue, otherwise known as the 

RGB color model), you will always be specifying color as a combination of 

primary colors. When working in Illustrator, you’ll fi nd that, likewise, you 

defi ne colors by mixing values of CMYK or RGB.

Of course, you can defi ne and apply colors in plenty of ways. Some ways are 

more effi cient than others, and some offer specifi c benefi ts. More so, some 

color features in Illustrator apply specifi cally to certain kinds of workfl ows 

and may even be irrelevant to some users. For example, using spot colors 

(solid, colored inks) serves no real purpose in the world of web design, while 

web-safe colors don’t interest print designers in the least. But no matter 

what you’re using your colors for, you’ll fi nd that, for the most part, you’ll 

be creating and applying them via the Color panel and the Swatches panel 

(both available via the Window menu).

Using the Color Panel
The Color panel contains sliders that allow you to mix primary colors to 

create just about any custom color and apply it to your artwork. In fact, 

some graphics programs (such as Adobe FreeHand, for example) refer to 

this kind of panel as the Mixer. Think of it as a fi ne arts artist’s palette that 

contains the primary colors. By mixing these colors, you can achieve any 

of your color needs. The Color panel doesn’t store colors, so you can’t use it 

as a repository for frequently used colors (that function is relegated to the 

Swatches panel, which we’ll talk about shortly). However, any time you 

select an object, the Color panel will display the color values of that object. 

So, you can use it either to apply color or to modify an existing color 

(Figure 6.1).
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You can use the Color panel to specify colors using any of fi ve sets of sliders: 

Grayscale, RGB (Red, Green, Blue), HSB (Hue, Saturation, Brightness), 

CMYK (Cyan, Magenta, Yellow, Black), and Web Safe RGB (216 colors that 

won’t dither on a VGA monitor). To switch between these, either choose 

one manually from the Color panel menu or Shift-click the color ramp that 

appears toward the bottom of the Color panel.

The Color panel features fi ll and stroke indicators in the upper-left corner 

(similar to those found in the Tools panel). Clicking the fi ll indicator allows 

you to specify a color for the Fill attribute of a selection, and clicking the 

stroke indicator does the same for the Stroke attribute. To save time, press-

ing the X key on your keyboard toggles between the two attributes (Shift-X 

will swap the fi ll and stroke colors).

Although the Color panel doesn’t store colors, you’ll fi nd that the color 

ramp at the bottom of the panel contains one-click shortcuts to the None, 

Black, and White attributes. The keyboard shortcut for the None attribute 

is the slash (/). The Color panel also displays a color warning in the shape 

of a small 3D cube beneath the fi ll and stroke indicators when the chosen 

color is not a web-safe color. Clicking the cube snaps your current color to 

the closest web-safe color match. For more information on web-safe colors, 

refer to Chapter 13, “Web and Mobile Design.”

Using the Swatches Panel
The Swatches panel stores a collection of predefi ned colors, making it easy 

to apply specifi c colors to your document quickly. Think of the Swatches 

panel as a box of crayons. You just choose the color you need and use it. In 

Figure 6.1 By adjusting 
the sliders in the Color 
panel, you can mix any 
color you need.

Fill and Stroke Indicators

Color Warning

None Attribute

Color Ramp

White

Black
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fact, the Swatches panel stores more than just solid colors; it also stores the 

two other types of fi lls that Illustrator supports: gradients and patterns. If 

the Swatches panel seems a bit cluttered with all these types of swatches, 

you can click the Show Swatch Kinds icon at the bottom of the panel to 

limit the display to a specifi c swatch type (Figure 6.2).

You can create a new color swatch in Illustrator in several ways:

• Click the New Swatch icon in the Swatches panel.

• Choose New Swatch from the Swatches panel menu.

• Choose Create New Swatch from the Color panel menu.

• Drag a color from the fi ll and stroke indicators in the Color panel 

or the Tools panel to the Swatches panel.

• Drag a color from the Color Guide panel (the Color Guide panel 

is covered in detail later in this chapter).

Double-clicking a swatch opens the Swatch Options dialog box and lets 

you edit the swatch (Figure 6.3). By default, swatches are named by their 

color values; however, you can name your swatches as you like. You can also 

specify a color mode and a color type for your swatch (refer to the “Hitting 

the Color Swatch Trifecta” section for explanations of these types).

Figure 6.2 You can set the 
Swatches panel to display 
all kinds of swatches or just 
solid colors.
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For fi les that already contain artwork, you can automatically create swatches 

from the artwork. With no objects selected, choose Add Used Colors from 

the Swatches panel menu. If you want to add colors from a specifi c area in 

your document, select the objects desired, and choose Add Selected Color 

from the Swatches panel menu. All new colors that are added will appear as 

global process colors, which are described in the next section.

You can also customize the view of your Swatches panel. By default, the 

swatches appear as little squares called thumbnails. But if you prefer, you 

can also have your swatches display in List view, which displays a little 

square beside the name of the swatch (Figure 6.4). You can choose from a 

variety of thumbnail and list sizes by selecting an option from the Swatches 

panel menu.

Figure 6.3 The Swatch 
Options dialog box lets you 
quickly edit your swatch 
settings.

Figure 6.4 In List view, 
swatches appear listed by 
name.
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Hitting the Color Swatch Trifecta

It would be simple if Illustrator offered only one type of solid color swatch, 

but, alas, it actually offers three: process color, global process color, and spot 

color swatches. Each serves a specifi c purpose, and it’s important to under-

stand when each should be used.

Process colors. A process color is defi ned by a mixture of primary values. 

For color print work that is separated and printed using a four-color process 

(CMYK), for output to a color printer, or for web design and video work, 

you want to defi ne your swatches as process color swatches. Creating 

process color swatches allows you to easily apply set colors to art that you 

create in your document, but updating colors on existing objects is diffi cult. 

As you’ll see shortly, you’ll often want to look into using global process 

colors instead.

Global process colors. A global process color is the same as a process color 

with one main difference: The swatch is global in that if you ever update 

the swatch, all objects in the document that have that swatch applied update 

as well. Most production artists request that designers use global swatches 

because they are easier to manage in an entire document. To create a global 

process color swatch, select the Global option in the New Swatch dialog box 

or Swatch Options dialog box. In the Swatches panel, global process colors 

display with a small white triangle in their lower-right corners (Figure 6.5).

Spot colors. A spot color is a named color that appears on a custom plate 

during the color separation process. Instead of a printer breaking a color into 

cyan, magenta, yellow, or black, a spot color is a specifi c custom color ink 

Figure 6.5 It’s easy to 
identify a swatch by its 
appearance. Solid squares 
are process colors, squares 
with white corners are 
global process colors, and 
squares with white corners 
and dots are spot colors.

Process Color

Spot Color

Global Process Color
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that the printer creates for your print job. You might have a variety of rea-

sons for using a spot color in a document:

• Specifi c color. Not every color can be reproduced using CMYK, 

which in reality has a small gamut of color choices. A custom color 

can be a bright fl uorescent color, a color with a metallic sheen, or even 

one that involves specialized inks, such as the magnetic inks used on 

bank checks.

• Consistent color. Because process colors consist of a mixture of other 

colors, they can shift and appear differently, even on the same print job. 

When you’re dealing with a company’s corporate colors, you want to 

make sure color is consistent across all print jobs.

• Solid color. Process colors are formed by mixing inks in various per-

centages. Not only does this require perfect registration on a printing 

press (where all plates hit the same place on each sheet of paper), but 

the process can also reveal odd patterns in reproduction in some cases 

(called moiré patterns). Spot color inks don’t exhibit these issues and 

present a solid, clean appearance.

• Cheaper color. When you are performing a process color job, you’re 

printing with four different color inks. But if you are creating a busi-

ness card with black text and a red logo, it’s cheaper to print using black 

ink and a single red spot color instead. Sometimes working with two or 

three spot colors gives your design the color it needs while keeping the 

printing costs down.

• Something other than a “color.” Print designs can be extremely 

creative, using processes such as foil stamping, die cutting, spot varnish-

ing, or embossing. Even though these special effects don’t print in ink, 

they still need to be specifi ed to a printer. Spot colors allow you to easily 

defi ne areas of color that will ultimately be regions of a gloss varnish 

effect, a die stamp, and so on.

You can defi ne your own custom color (by choosing the Spot Color option 

in the Color Type pop-up menu), or you can choose a spot color from an 

existing library. Pantone libraries are the most common examples; they were 

created to help printers and designers standardize on colors by using a num-

bering system. To apply a color from a Pantone library, see “Working with 

Libraries” later in this chapter.



CHAPTER 6: COLORING ARTWORK172

Process and Global Process Swatches

At fi rst glance, it may seem diffi  cult to understand what the diff erence is 
between a process color and a global process color swatch. But once you 
understand what each has to off er, it’s easy to fi gure out when you should 
use each type of color swatch.

A process color swatch is simply a way to “memorize” the values for a particular 
color. The swatch contains the color breakdown (the individual values of each 
primary color), saving you from having to reapply multiple values to each 
object that you want to color in your document. To use it, you can select an 
object and then click a swatch to apply the chosen color to the object.

A global process swatch does the same thing but adds two main benefi ts in the 
way of productivity and creativity. First, when you select an object and then you 
choose a global process color swatch, an invisible “link” is created between the 
object and the swatch. This means if you ever modify the swatch (that is, edit 
its values), any objects in your document that you’ve already colored with that 
swatch will update as well. Second, global process colors show up in the Color 
panel with a tint slider, making it easy to specify diff erent shades of your color.

So when defi ning your swatches, be sure to select the Global check box in 
order to get the benefi ts of working with global process color swatches, 
including the ability to specify tint values.

Working with Groups of Color

As a designer, you may fi nd it easier to organize your swatches into groups 

(Figure 6.6). In this way, you can fi nd the colors you need quickly. More 

important, however, organizing colors into groups makes it easy to establish 

relationships between colors, which can be helpful when recoloring artwork 

using the Live Color feature (covered later in this chapter) or when using 

the Live Paint Bucket tool (covered in Chapter 4, “Creative Drawing”).

Figure 6.6 Grouping 
swatches makes it easy to 
organize colors.
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As with swatches, you can create a new group of swatches in several ways:

• With nothing selected, click the New Color Group icon at the bottom 

of the Swatches panel to create an empty color group. Drag existing 

swatches from the Swatches panel directly into or out of the group.

• Select multiple swatches in the Swatches panel using the Shift or 

Command (Ctrl) key, and then click the New Color Group icon at 

the bottom of the Swatches panel. The New Color Group dialog box 

appears so you can name your group. Click OK to create the group.

• Select multiple swatches in the Color Guide panel using the Shift or 

Command (Ctrl) key, and click the Save Color Group to Swatch Panel 

icon at the bottom of the Color Guide panel.

• With artwork selected on the artboard, click the New Color Group 

icon at the bottom of the Swatches panel. You can automatically convert 

all process colors to global process colors, as well as include specifi c 

swatches for tints of colors (Figure 6.7).

You can edit any single swatch within a group simply by double-clicking it. 

However, if you want to edit a group (and all the colors within it), you can 

either double-click the group’s folder icon that appears in the Swatches panel 

or select the group and click the Edit Color Group icon at the bottom of the 

Swatches panel. It’s best to edit color groups when no artwork is selected, or 

any changes you make will be applied to your selection.

You edit groups in the Edit Colors dialog box (Figure 6.8 on the next page). 

Saved color groups appear listed along the right side of the dialog box 

(you can click the disclosure triangles to reveal the individual colors within 

them). Clicking a color group maps the colors within the group onto the 

color wheel, and clicking a specifi c color within the group highlights that 

color on the wheel. You can make adjustments to your colors on the wheel 

Figure 6.7 With a single 
click, you can easily create 
a new group of swatches 
from colors that appear in 
a selection.

NOTE Swatch groups 
can contain only color 

swatches (process, global 
process, and spot) and not 
gradients or patterns.
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(refer to “Modifying Color” later in this chapter for detailed information on 

how to do this), and then you can save your changes or create entire new 

color groups using the icons at the top right of the Edit Colors dialog box 

(Figure 6.9). Click OK to exit the Edit Colors dialog box and return to 

your document.

Figure 6.8 You can use the 
Edit Colors dialog box to 
adjust colors within groups. 
Existing color groups appear 
on the right side of the 
dialog box.

Figure 6.9 You can modify, 
create, and delete groups 
easily within the Edit Colors 
dialog box.

Delete Color GroupSave Changes to Color Group

New Color Group
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Working with Libraries
Illustrator fi les can contain all kinds of attributes including colors, gradi-

ents, patterns, symbols, brushes, and graphic styles. You can save each of 

these attributes as libraries so that you can share them between Illustrator 

documents.

Illustrator makes the process of managing libraries easy by incorporating 

some features directly into the panels. At the bottom of the Swatches panel, 

click the Swatch Libraries Menu icon to see a list of libraries you can use 

(Figure 6.10). Choosing a swatch library opens a new panel containing 

those swatches. Applying any colors from a custom swatch library 

automatically adds those colors to the document’s Swatches panel.

Figure 6.10 You can 
load swatch libraries 
right from the Swatches 
panel. Libraries appear 
in hierarchical format 
according to how 
they’re organized within 
the Adobe Illustrator 
CS4/Presets/en_US/
Swatches folder.

NOTE Commercial 
color libraries such as 

Pantone, Toyo, and Trumatch 
appear listed in the Color 
Books submenu. You can get 
newer Pantone GOE libraries 
from www.pantone.com/
goefree.

www.pantone.com/goefree
www.pantone.com/goefree
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You can create your own custom library fi les by adding swatches to the 

Swatches panel and deleting any swatches you don’t want (choosing Select 

All Unused from the Swatches panel menu can help in that process). Then 

choose Save Swatch Library as AI, and name your library. Once saved, you 

can access your custom library by clicking the Swatch Libraries Menu icon 

(it will appear at the bottom of the list in a subfolder named User Defi ned). 

If you want to use your swatch library in Adobe Photoshop CS4 and Adobe 

InDesign CS4 as well, choose Save Swatch Library as ASE instead (Figure 
6.11). ASE stands for Adobe Swatch Exchange, and you can import those 

colors into Photoshop or InDesign (in all versions starting with CS2). Adobe 

Swatch Exchange currently supports only solid-color swatches, not gradi-

ents or patterns.

If you want a custom library to always appear on your screen each time you 

launch Illustrator, open the library, and choose Persistent from that library’s 

panel menu (Figure 6.12).

Figure 6.11 You can 
open an Adobe Swatch 
Exchange fi le with Illustrator, 
Photoshop, or InDesign.

Figure 6.12 Making a 
custom library persistent 
ensures it is always available 
on your screen.
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Finding Your Pantone Number

When you load a Pantone color library, you’ll fi nd that the library contains hundreds if not thousands of colors. 
So, how do you fi nd just the number of the color you need? From the library’s panel menu, choose Show Find 
Field. You can then type your Pantone number in the fi eld to jump directly to your number (Figure 6.13).

Figure 6.13 Once you 
choose Show Find Field 
from a Pantone color 
library’s menu, you can 
type a number to quickly 
fi nd the color.

But you may also fi nd that, at times, it seems impossible to type your number. For example, if you try entering 
485 for Pantone 485, you’ll fi nd that instead Illustrator takes you directly to Pantone 1485. To get Pantone 485, 
you will have to type a space before the numbers 485. Why? That’s a great question. I’m glad you asked.

Teri Pettit, an engineer on the Illustrator team at Adobe, off ers the following explanation:

“What the search command does is fi rst look for a swatch starting with the characters you type. For example, if 
you type lo, it will fi rst look for colors starting with lo, such as Loden Green. But if it fi nds none, it will then look 
for the fi rst swatch name containing lo and will match Yellow.

“Characters are concatenated into the search string if they occur within the double-click time. Otherwise, it 
starts over with a new string.

“Since the Pantone libraries are not sorted in numerical order but semialphabetically, if you are searching for 
something like 613, it will fi nd the substring match in Pantone 2613 before it will fi nd the one in Pantone 613. 
By typing ‘ 613’ (there’s a space before the 6), you prevent a match in 2613, and so on.”

ADDING COLOR WITH FILLS
AND STROKES
As you know, vector shapes are comprised of anchor points, which control 

how the paths that connect them are drawn. The fi ll of a vector object is the 

appearance of the area that is enclosed by its path. If the shape isn’t a closed 

path, the fi ll is defi ned by the existing path and is closed with a straight 

line connecting the start and end points (Figure 6.14 on the next page). 

The stroke of an object is the appearance of the vector path itself. Fills and 

strokes can have a variety of appearances, and vector objects can also contain 
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multiple fi lls and strokes—something you learned in Chapter 5, “Organizing 

Your Drawing.” All vector objects must have both a fi ll and a stroke color 

assigned, although that attribute can be set to None. Fills or strokes colored 

with None appear invisible and have no appearance. There’s also one addi-

tional attribute called Registration, which is basically the exact opposite 

of None. Registration is a color that appears on every plate when a fi le is 

color separated (see Chapter 15, “Prepress and Printing,” for details on color 

separations).

Applying Fills
There are three types of fi lls: solid colors, gradients, and patterns. Each of 

these fi ll types can be stored in the Swatches panel. The Swatches panel 

lets you view these attributes as thumbnails or as a named list, and you can 

apply these attributes to a selected object simply by clicking the swatches. 

Alternatively, you can apply fi ll colors directly via the Control panel and the 

Appearance panel.

The most common and simple form of a fi ll is a solid color, which applies a 

single fl at color to the appearance of the fi ll of a vector shape. For example, 

a rectangle can have a solid blue fi ll, a solid yellow fi ll, or any color of your 

choosing. Gradients and patterns are more complex fi lls, so let’s take a closer 

look at each of them.

Gradient Fills

Whereas a solid color fi ll consists of just one color, a gradient fi ll consists of 

solid colors that blend into each other. A gradient can contain as few as one 

color and as many as—well, let’s just say we stopped counting at 300. Linear

gradients start with a color on one end that gradually blends into a color on 

the other end (for example, from left to right). Radial gradients start with 

a color at the center and gradually blend into a color, radiating outward.

Figure 6.14 Open paths 
can have a fi ll applied, and 
Illustrator stops the fi ll by 
creating a boundary (no 
physical path is created).

NOTE Although they 
share a similar name, 

gradient fi lls and Gradient 
Mesh are two very diff erent 
things. For details on the 
Gradient Mesh feature in 
Illustrator, refer to Chapter 4.
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The Gradient panel (Window > Gradient) gives you complete control over 

the use and appearance of any gradient (Figure 6.15):

• Thumbnail. The thumbnail shows a preview of the current gradient. 

You can drag the thumbnail directly onto an existing object on your 

artboard to fi ll that object with the gradient, or you can drag the thumb-

nail into the Swatches panel to create a gradient swatch.

• Gradient Swatch menu. Instead of digging in the Swatches panel 

for a specifi c gradient, the Gradient Swatch menu displays all gradient 

swatches in a pop-up menu. You can also click the disk icon that appears 

in this menu to defi ne gradient swatches.

• Type. As described earlier, a gradient can be either linear or radial. 

Radial gradients can be distorted to create an oval shape (see “Aspect 

ratio” that follows).

• Reverse Gradient. Clicking the Reverse Gradient button reverses the 

order of all the color stops in a gradient (see “Gradient slider” that fol-

lows for information on color stops).

• Angle. This sets the direction of the gradient (only for linear gradients).

• Aspect ratio. This sets the difference between the width and height of 

the gradient circle (only for radial gradients).

• Gradient slider. The focal point of the Gradient panel, the gradient 

slider is composed of three elements: a slider that displays a preview 

of the gradient, color stops that defi ne the colors (and their position) 

Figure 6.15 Gradients can 
be defi ned and modifi ed in 
the Gradient panel.

Thumbnail Gradient Swatch Menu Type

Aspect Ratio

Color Stop

Opacity

Location

Midpoint Indicator

Reverse Gradient
Angle

Gradient Slider
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that appear in the gradient, and midpoint indicators that defi ne the 

point at which two colors meet (or blend) at exactly 50 percent of each 

color. Color stops are small boxes that appear beneath the slider, while 

midpoint indicators are diamonds that appear above the slider. Every 

gradient must contain at least two color stops (midpoint indicators are 

automatically added between every two color stops).

• Opacity. The Opacity value determines the transparency setting for a 

selected color stop.

• Location. The Location value represents the precise position of a 

selected midpoint on the gradient slider.

To create a gradient, drag colors from the Color, Color Guide, or Swatches 

panel directly onto the gradient slider. Dragging a color directly on top of 

an existing color stop changes the color of that color stop. Dragging a color 

onto the slider itself creates a new color stop (you can also click anywhere 

beneath the slider to add a new color stop). To remove a color stop from a gra-

dient, you can either select it and click the trash can icon in the Gradient panel 

or simply drag it off the gradient slider. You can also double-click a color 

stop to change its color and opacity (Figure 6.16). To swap colors between 

color stops, drag one color stop over another one while holding the Option 

(Alt) key. Drag midpoint indicators to the left or right to adjust how quickly 

one color blends into the other.

Admittedly, the practice of applying a gradient to an object on the artboard 

and then trying to adjust that gradient in the Gradient panel makes for a 

somewhat disconnected creative experience. It would be far better if you 

Figure 6.16 Double-
clicking a color stop lets 
you defi ne its color. The two 
icons that appear on the left 
of the pop-up panel let you 
choose colors via the Color 
panel and the Swatches 
panel.
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could edit a gradient’s settings directly on the object itself—which is exactly 

why the Gradient tool (G) allows you to do just that—edit gradients in con-

text, right on the artboard.

To modify a gradient, start by selecting an object and fi lling it with a gradi-

ent of your choice (or simply select an object that already has a gradient fi ll 

applied to it). Then, select the Gradient tool, and click and drag to defi ne the 

position of the fi rst color stop of the gradient. The point where you release 

the mouse button defi nes the position of the last color stop of the gradient 

(Figure 6.17).

What makes the Gradient tool so powerful is that you can begin or end a gra-

dient anywhere, even outside the boundaries of the object you have selected 

(Figure 6.18). Additionally, you can select multiple objects and apply a single 

gradient across all of them using the Gradient tool (Figure 6.19).

Figure 6.17 The Gradient 
tool makes it easy to apply 
gradients at an angle.

Figure 6.18 A gradient fi lls 
the distance from where you 
fi rst clicked to where you 
release the mouse button, 
even if those locations are 
beyond the boundaries of 
your selection.
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But even more exciting about editing gradients with the Gradient tool is 

how you can adjust all of a gradient’s attributes directly on the artboard. 

When you select an object that is fi lled with a gradient and you switch to 

the Gradient tool, Illustrator displays a fi ll path that shows the start and end 

points of the gradient (Figure 6.20). When you move your pointer over 

the fi ll path, it expands to reveal an entire functional gradient slider, or 

widget (Adobe refers to this as the Gradient Annotator, and you can control 

its appearance by choosing View > Hide/Show Gradient Annotator).

The settings and the experience of interacting with the gradient widget are 

different for linear and radial gradients, so we’ll explore each individually:

• Linear gradients. As with the Gradient panel, you can use the gradi-

ent widget to modify the position of color stops and midpoint indicators 

(Figure 6.21). Drag color stops off the gradient slider to delete them, 

add new color stops by clicking underneath the slider, and double-click 

Figure 6.19 The Gradient 
tool enables you to apply a 
single gradient across mul-
tiple objects.

Figure 6.20 Selected 
objects fi lled with gradients 
display a fi ll path when the 
Gradient tool is active.

Start Point (Origin)

Fill Path

End Point
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a color stop to change its color and opacity (Figure 6.22). Clicking and 

dragging the circle icon (the start point) allows you to reposition the 

origin of the gradient. As you do so, a dashed line appears indicating the 

center of the object, because a linear gradient always runs through the 

center of an object (Figure 6.23). Click and drag the diamond icon at 

the edge of the fi ll path (the end point) to adjust the length of the gra-

dient’s fi ll path. If you position your pointer just outside the diamond 

icon, you’ll see a rotation pointer appear, which you can then click and 

drag to adjust the gradient angle (Figure 6.24).

Figure 6.21 The linear gradi-
ent widget lets you modify the 
position of color stops directly 
on the artboard.

Figure 6.22 Double-clicking a color 
stop gives you the ability to change 
its color instantly.

Figure 6.23 Linear gradients 
always run through the center 
of an object, as indicated by a 
dashed line.

Figure 6.24 You can easily rotate 
a gradient visually instead of try-
ing to enter a value numerically in 
the Gradient panel.
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• Radial gradients. As with the Gradient panel, you can use the gradient 

widget to modify the position of color stops and midpoint indicators 

(Figure 6.25). Drag color stops off the gradient slider to delete them, 

add new color stops by clicking underneath the slider, and double-click 

a color stop to change its color and opacity. Clicking and dragging the 

circle icon (the start point) allows you to reposition the origin of the 

gradient. Click and drag the diamond icon at the edge of the fi ll path 

(the end point) to adjust the radius of the gradient. If you position your 

pointer just outside the diamond icon, you’ll see a rotation pointer appear, 

which you can then click and drag to adjust the gradient angle. You may 

ask what good rotating a radial gradient will do, because rotating a cir-

cular object doesn’t have any visible effect. Good question. The answer 

is that radial gradients can easily become elliptical (oval) gradients. 

Clicking and dragging the solid dot that appears along the circumference 

of the gradient (indicated by a dashed line) lets you adjust the aspect 

ration value of the gradient (Figure 6.26).

Pattern Fills

A pattern fi ll uses a repeating art element to fi ll the boundaries of a path or 

object. To defi ne a pattern, create just about any kind of art on your art-

board (including embedded raster images and text objects), and drag them 

into your Swatches panel, or choose Edit > Defi ne Pattern. You can apply 

pattern fi lls to objects the same way you apply solid color fi lls—by target-

TIP Gradient swatches 
let you quickly apply 

gradients to multiple objects, 
but they don’t retain position-
ing information. If you want 
to apply a gradient and its 
position as applied to the 
object to other object, you 
can create a graphic style 
(refer to Chapter 9, “Drawing 
with Effi  ciency”).

Figure 6.26 Applying an aspect 
ratio results in an elliptical gradient.

Figure 6.25 When using the radial gra-
dient widget, the dashed line visually 
describes the circumference (basically, 
the end point) of the gradient.
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ing the fi ll or stroke of a selection and choosing a pattern swatch from the 

Swatches panel. When objects are fi lled with patterns, you can choose to 

transform the patterns with the objects, or you can have Illustrator rotate 

just the objects but not the pattern fi ll.

The Art of Pattern Making

In reality, an entire book could be written on creating patterns, which is an art form in and of itself. The 
Illustrator Help fi les actually contain some great information on working with patterns. Creating perfect, 
repeating patterns that tile seamlessly can take a bit of advance planning, as well as trial and error.

When you drag artwork into the Swatches panel to create a pattern swatch, Illustrator uses the bounding area of 
the artwork that you selected as the boundary of the repeat area. In many cases, however, this default bounding 
box does not create a seamless pattern. To create a seamless pattern, you might have to position objects well 
inside the repeat area or even have artwork extend beyond the repeat area. To defi ne a repeat area for a pattern, 
draw a no-fi ll, no-stroke rectangle at the bottom of the stacking order. Even if there are objects that extend out-
side the rectangle, Illustrator will use that rectangle to defi ne the repeat area (Figure 6.27).

Repeat Area

Sometimes the best way to learn is to reverse-engineer existing artwork. To get a better feel for how repeats 
are designed, take a look at some of the patterns that come with Illustrator. Choose Open Swatch Library > 
Patterns from the Swatches panel menu to view some of these patterns. To access the art that was used to 
defi ne any pattern swatch, simply drag a swatch from the Swatches panel onto the artboard. For an inspira-
tional book on creating and using patterns, check out Von Glitschka’s Drip Dot Swirl (How, 2009).

Figure 6.27 Using a rectangle as the 
bottommost shape in your pattern art 
defi nes a repeat area (left), thus helping 
create a seamless pattern tile, as in this 
example from illustrator Von Glitschka.
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Applying Strokes
A stroke is the appearance of the vector path itself. You can specify a stroke 

color by choosing one from the Stroke pop-up menu in the Control or 

Appearance panel or by targeting the stroke using the fi ll/stroke indicator 

and then choosing a color from either the Color or Swatches panel. You can 

also choose from several different settings to control the appearance of a 

stroke, all of which are available in the Stroke panel:

• Weight. The thickness of a stroke is referred to as the stroke weight, and 

it is traditionally specifi ed in points (pts). Specifying a stroke weight of 

less than .25 point might be problematic for most printing presses.

• Miter limit. A stroke’s miter limit specifi es the appearance of corners 

that have very acute angles. If you fi nd that the corner of a stroke 

appears clipped, you can increase the miter limit to correct the appear-

ance (Figure 6.28).

• Cap. The cap setting is an attribute that affects the appearance of the 

start and end points of a stroke. Obviously, this setting applies to open 

paths only (although it can be applied to dashes as well, as you will 

soon see). You can choose between a Butt, Round, or Projecting cap 

(Figure 6.29).

• Join. A join attribute determines the appearance of a stroke as it passes 

through an anchor point. Miter, Round, and Bevel are the different 

options you can choose from (Figure 6.30).

Figure 6.28 The object on 
the left has an 18-pt stroke 
applied with a miter limit 
of 2, whereas the object on 
the right has an 18-pt stroke 
applied with a miter limit 
of 4.
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Aligning Strokes

By default, Illustrator paints a stroke on the center of a path. For example, 

if you specify a 10-pt stroke for an object, the result is 5 pts appearing on 

the outside of the path and 5 pts appearing on the inside of the path. In the 

Stroke panel, you can specify whether you want the entire stroke painted on 

the inside or outside of the vector path (Figure 6.31). This setting is avail-

able only for closed paths.

Figure 6.29 The cap setting 
defi nes how the start and 
end of a stroke appear. From 
the top, Butt, Round, and 
Projecting caps can also add 
to the length of a stroke.

Figure 6.30 The join setting 
defi nes the appearance of 
connecting straight anchor 
points. From left to right are 
examples of stroked paths 
with Miter, Round, and 
Beveled joins.

Figure 6.31 Use the Align 
Stroke options in the Stroke 
panel to specify whether a 
stroke should be painted on 
the center, inside, or outside 
of the path.

Projecting Cap

Round Cap

Butt Cap

Vector Path

Vector Paths End Here

Painted Stroke

Miter Round Bevel

Vector Path

Painted 
Stroke
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Using Dashed Strokes

Strokes don’t have to be solid lines. They can have a broken appearance 

resulting in dashed lines. The nice feature is, rather than just choosing a 

preset dashed line, you can specify exactly how the dashes should appear 

along a stroked path.

When specifying the appearance of a dash, you can specify the length of 

the dash and the length of the gap—the space that appears after the dash. 

The Stroke panel contains three sets of dash and gap settings. If you specify 

a dash without specifying a gap, Illustrator creates a gap equal to the size 

of the dash. For most standard dashed strokes, you will use only the fi rst 

dash and gap setting. However, you can use all three to create a sequence of 

dashes and gaps (Figure 6.32). When you specify the Round cap option for 

the stroke, a dash value of 0 results in a perfect circle, allowing you to create 

dotted lines.

One shortcoming of Illustrator is its inability to ensure that dashes set on 

strokes match up evenly on the corners of an object (Figure 6.33). This is 

because you can specify only absolute dash and gap settings, and those set-

tings don’t always match up exactly with the size of the object you’ve drawn. 

It’s interesting to note that InDesign does have the ability to stretch or adjust 

dashes and gaps to display consistent corners.

Figure 6.32 The ability 
to set custom dashes for 
a stroke lets you create a 
plethora of dashed strokes 
that you can use for a 
variety of tasks.

Weight: 2 pt; Dash/gap: 0 pt, 6 pt, 0 pt, 20 pt; 
Cap: Round

Weight: 6 pt; Dash/gap: 5 pt, 4 pt, 10 pt, 4 pt, 
5 pt, 20 pt; Cap: Butt

Weight: 1 pt; Dash/gap: 6 pt, 3 pt; 
Cap: Butt

Weight: 12 pt; Dash/gap: 1 pt, 10 pt; 
Cap: Butt

Weight: 5 pt; Dash/gap: 0 pt, 10 pt; 
Cap: Round
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Illustrator uses absolute 
values for dashes, it’s nearly 
impossible to get dashes to 
line up perfectly at the cor-
ners of a path.

GETTING INSPIRED WITH COLOR
When you’re working on creative projects, sometimes you are told which 

colors to use by the client directly (in the case of established corporate col-

ors), a creative director, or maybe even a fashion designer in Paris. Other 

times, you are totally free to dream up any color you’d like to use. Although 

freedom is nice, it also offers challenges. How do you choose from so many 

colors? How do you ensure that the colors you have chosen work well with 

each other? How can you quickly generate numerous color variations to play 

with and choose from?

Traditionally, designers could garner such inspiration by perusing maga-

zines or annuals or just by going for a walk and observing the outside world. 

Illustrator offers its own set of inspirational tools to help you choose the 

perfect colors for the task at hand through the Color Guide panel and some-

thing called Adobe Kuler (see the “Tapping In to a Community Around 

Color with Kuler” section).

Using the Color Guide Panel
Accessible via the Window menu, the Color Guide panel looks rather simple 

at fi rst glance. However, it’s a robust (and fun!) tool to use when you want 

to generate variations of colors as you work on your design (Figure 6.34 on 

the next page). As you are about to fi nd out, the Color Guide panel offers 

color suggestions that fi t your exacting needs.

TIP To get perfectly 
aligned corners with a 

dashed stroke, use a Pattern 
brush (covered in Chapter 4). 
You’ll fi nd a variety of 
dashed borders ready to 
use by choosing Window > 
Brush Libraries > Borders > 
Borders_Dashed.



CHAPTER 6: COLORING ARTWORK190

To use the Color Guide panel, start by choosing a color harmony rule from 

the pop-up menu at the top of the panel. Don’t worry if you aren’t famil-

iar with any of the harmony rules or their names. It really doesn’t matter, 

because each one is just a different method for how colors are generated 

and how they relate to each other (refer to the sidebar “Color Harmonies”). 

There’s no such thing as a right or wrong harmony rule—if you aren’t 

happy with the colors you’re seeing, just switch to a different rule.

Once you’ve selected a rule, click any swatch color in the Swatches panel, 

or mix a color using the Color panel. Alternatively, you can select an object 

and click the Set Base Color to the Current Color icon in the Color Guide 

panel. Instantly, the Color Guide panel will generate variations of color 

for you. If you like any colors you see, you can drag them right to your 

Swatches panel or even to an object on your artboard. Alternatively, you can 

select several colors and click the Save Color Group to Swatch Panel icon at 

the bottom of the Color Guide panel.

By default, the Color Guide panel offers tint/shade variations of your colors. 

However, you can view warm/cool or vivid/muted variations instead, if you 

prefer. To do so, choose the desired option from the Color Guide panel 

menu (Figure 6.35). And for specifi c control over how variations are created, 

choose Color Guide Options from the Color Guide panel menu. This in turn 

opens the Variation Options dialog box (we know, it should be named

Figure 6.34 The Color 
Guide panel off ers color 
suggestions.

Base Color Active Colors

Save Color Group to Swatches panel
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the Color Guide Options dialog box, right?). The Steps setting determines 

how many variations of color the Color Guide panel displays in each direc-

tion of your color (Figure 6.36). For example, if you have the Tints/Shades 

option selected, a value of four steps will generate four tints and four shades 

for a total of eight variations of your color (Figure 6.37). You can specify 

as few as three steps and as many as twenty. In addition, you can adjust the 

Variation slider to control how much of a difference there is between each 

color that is generated.

Figure 6.36 You can 
adjust the number of 
steps and the amount 
of diff erence between 
generated variations 
of color.

Figure 6.37 The Color 
Guide panel displays the 
active colors down the cen-
ter, with darker and lighter 
variations to the left and 
right, respectively.

Figure 6.35 The Color 
Guide panel off ers three 
methods for generating 
color variations.
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Color Harmonies

A color harmony (also referred to as a color rule) is a specifi c relationship between col-
ors. For example, the Complementary color harmony defi nes two colors that appear 
exactly opposite each other on the color wheel. Illustrator features 23 diff erent color 
harmonies that you can choose from, each containing between two and six colors 
(Figure 6.38).

When choosing color harmonies, try not to focus too much on their names. Instead, 
use this page as a visual reference to better understand what each one represents on 
the color wheel. There’s no such thing as a “good” or a “bad” harmony—choose the 
one that best fi ts the needs for a particular job or task. Better yet, experiment with a 
few of them until you fi nd what you want.

You can choose color harmonies from the Color Guide 
panel, from the Edit Colors dialog box, and from the 
Recolor Artwork dialog box.

Compound 2 High Contrast 1

Triad 2 Triad 3

Analogous Analogous 2

Complementary

Figure 6.38 Illustrator 
features 23 diff erent 
color harmonies, or 
specifi c defi ned rela-
tionships of colors.
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High Contrast 2 High Contrast 3 High Contrast 4 Pentagram

Tetrad Tetrad 2 Tetrad 3 Compound 1

Monochromatic Monochromatic 2 Shades Triad

Complementary 2 Split Complementary Left Complement Right Complement
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Limiting the Color Guide Panel
When expressing your creativity with color in Illustrator, the last thing you 

probably want to hear is how to impose limits. But on the contrary, carefully 

limiting the Color Guide panel can reap huge rewards. By default, the Color 

Guide panel offers suggestions of colors from a huge spectrum of color. But 

sometimes you’re forced to work within specifi c guidelines, or you need 

to work within a certain range of color. For example, a web designer may 

want to see only those color suggestions that are web-safe colors. A package 

designer working in a spot color workfl ow may want the Color Guide panel 

to offer suggestions from a Pantone library. Or a fashion designer may be 

limited to using only those colors available for a specifi c season or year.

The good news is that custom-fi tting the Color Guide panel to your exact 

needs is not only possible but it’s incredibly easy to do. Let’s take the exam-

ple of a web designer who wants to work within the web-safe color library. 

At the bottom-left corner of the Color Guide panel is an icon that allows 

you to limit the color group to colors that appear within a specifi c library 

(Figure 6.39). Click the icon, and choose the Web library. You’ll notice that  

Figure 6.39 You can limit 
the Color Guide panel to any 
custom library—even those 
you create on your own.
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the name of the chosen library now appears at the bottom of the Color 

Guide panel, indicating that the colors being suggested in the panel come 

from that library (Figure 6.40). Now, as you choose colors, the Color 

Guide panel can offer only those color suggestions that are web-safe colors.

Figure 6.40 A quick look 
at the Color Guide panel 
reveals the library of colors 
to which it is limited.

Use the same method to limit the Color Guide panel to a Pantone swatch 

library, and the Color Guide panel will be able to list only variations of color 

that are in the chosen Pantone library (Figure 6.41). This can be helpful if 

you’re working on a design that will be printed as a one- or two-color job. 

To release the limit, click the icon, and choose None from the top of the list.

Figure 6.41 Limiting the 
Color Guide panel to a 
Pantone library makes it 
easier to choose the right 
spot color for the job.

Tapping In to a Community Around 
Color with Kuler
As you know, color is subjective. What looks great to one designer may look 

awful to another. Likewise, some people might be really good at working 

with color, while others may be severely color-challenged. What would be 

wonderful for everyone would be some set of tools that designers could use to 

quickly generate palettes of color that look great while, at the same time, offer 

some way for designers to share their skills with others. The good news is that 

Adobe set out to deliver just that by creating a community of users who share 

a rather cool set of color tools, called Kuler (pronounced “cooler”).
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Using the Kuler Website

To access the Kuler website, visit http://kuler.adobe.com (Figure 6.42). Adobe 

actually refers to Kuler as a rich Internet application (RIA), and you need to 

have Flash Player 9 or newer to use it (the site will redirect you if you need 

to download a newer version of Flash Player). Although you can use parts of 

Kuler without logging in, you’ll get the full functionality by entering your 

Adobe ID. If you don’t already have one, an Adobe ID is free and allows 

you to post to the Adobe user-to-user forums, access free content from the 

Adobe Design Center, and purchase items through the online Adobe Store. 

If you’ve recently registered any Adobe software, you probably already have 

an Adobe ID. If not, you can click the Register link at the top right of the 

Kuler website.

What’s cool about Kuler is that, as part of the online community, you can 

view color themes that others have created, and you can even rate them. 

Themes are tagged with metadata, allowing you to easily search for colors 

(such as winter or chocolate). In fact, color themes are actually published 

as RSS feeds, allowing designers to search based on things like the most 

popular or the highest rated themes.

Figure 6.42 Free to all, 
Adobe Kuler can also gener-
ate themes of colors from 
photographs that you can 
upload or import directly 
from Flickr.

http://kuler.adobe.com
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Using the Kuler Panel in Illustrator

Although the Kuler website is nice and all, you still have to leave your 

design environment and use your web browser to fi nd your colors. That’s 

why Adobe took the next step and brought Kuler directly into Illustrator 

(it also exists in other Adobe Creative Suite CS4 components). Choose 

Window > Extensions > Kuler to open the Kuler panel (Figure 6.43), 

which gives you access to the themes within the online Kuler community.

Figure 6.43 With the Kuler 
panel, you can browse color 
themes directly from within 
Illustrator for instant color 
inspiration.

Click the pop-up menus at the top of the Kuler panel to display specifi c RSS 

feeds, such as highest rated, most popular, and so on. You can also specify a 

time constraint (such as list all newest themes within the past 7 days). Enter 

any keyword in the Search fi eld to fi nd Kuler themes that fi t your exact 

needs. If you fi nd a theme you like, then select it, and click the Add Selected 

Theme to Swatches icon at the bottom of the panel. Illustrator automatically 

adds the selected theme to your Swatches panel as a color group. Alterna-

tively, you can click the triangle to the far right of any theme to open it in 

Kuler directly (Illustrator launches your default web browser to do so).

The Kuler panel is also a two-way street, meaning that if you develop some 

colors you like while using Illustrator, create a group in your Swatches panel 

(of fi ve colors or less), and then click the Upload from Swatch Panel to 

Kuler Community button in the Kuler panel. Illustrator transfers your col-

ors to the Kuler website, where you can then add metadata tags and publish 

your theme.
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MODIFYING COLOR
When you’re faced with making changes to the color in your existing art-

work, you may fi nd that it is extremely time-consuming to do so. But the 

Live Color feature in Illustrator makes it easy to modify the colors in your 

document in a plethora of ways.

In reality, there isn’t a tool, function, or button in Illustrator that’s called 

Live Color (it’s more of a marketing term). Just about all the color editing 

you do will involve the Recolor Artwork dialog box. We’ll cover this dialog 

box in detail, but before we get started, it helps to think of Live Color as an 

engine in Illustrator—a powerful engine that allows you to take control over 

modifying colors throughout your document. This is especially true when 

you consider that this color engine is capable of modifying colors that may 

be contained within symbols, gradients, gradient mesh objects—anything 

with the exception of placed images.

Recoloring Artwork
The crown jewel of the Live Color feature set in Illustrator is the Recolor 

Artwork dialog box. With a few clicks, you can easily perform a number of 

tasks. Some examples are as follows:

• Swap colors that exist in your artwork.

• Adjust saturation, brightness, temperature, and luminosity values in 

your selected artwork.

• Generate color studies and variations of your artwork.

• Convert colored artwork to grayscale.

• Convert grayscale art to color.

• Convert process colors to spot colors, and vice versa.

• Intelligently reduce the number of colors used in your selected artwork.

As you dive into the Recolor Artwork feature in Illustrator, you should keep 

three important tips in mind:



MODIFYING COLOR 199

• Recolor Artwork works only on selected art. This allows you to specifi -

cally target the art you want to modify and can be especially important 

in documents that contain multiple artboards, where you might want to 

modify the colors on one artboard but not another. At the same time, 

this means that locked objects aren’t touched by the Recolor Artwork 

dialog box at all, so you’ll want to make sure you have your artwork 

selected as needed before you proceed.

• As you’ll learn, the Recolor Artwork feature is somewhat partial to col-

ors that live inside groups. Although you can access individual swatch 

colors from within the Recolor Artwork dialog box, it is far easier to 

work with colors in groups. With this in mind, you might consider cre-

ating groups of the colors that you plan on using before you open the 

Recolor Artwork dialog box.

• The Recolor Artwork dialog box is somewhat daunting. It contains 

many buttons and settings, and sometimes a seemingly small setting or 

icon can have a huge impact on the work you’re doing. That being said, 

there’s nothing to fear. Many of the functions in the Recolor Artwork 

dialog box perform the same type of edits, but just in different ways. In 

all likelihood, you’ll fi nd a part of the Recolor Artwork dialog box that 

you will use far more often than the rest of it. So if you don’t end up 

memorizing what every little button does, don’t worry.

OK, now that the ground rules are in place, let’s begin. Start by selecting 

your artwork on the artboard, and then click the Recolor Artwork icon in 

the Control panel (Figure 6.44). Alternatively, you can choose Edit > Edit 

Colors > Recolor Artwork. The Recolor Artwork dialog box appears, and 

you’ll immediately notice two tabs near the top of the dialog box: Edit and 

Assign (Figure 6.45). For the most part, the Edit tab is used to modify the 

colors that exist in your fi le (such as, change a color’s hue), while the Assign 

tab is used to apply completely new colors to your artwork (that is, reduce 

the number of colors used in a fi le). Let’s take a closer look at what these 

two functions do.

Figure 6.44 The Recolor 
Artwork icon appears in the 
Control panel whenever art 
is selected.

Figure 6.45 The Recolor 
Artwork dialog box features 
two tabs: Edit and Assign.



CHAPTER 6: COLORING ARTWORK200

Using the Edit Tab

At the center of the Edit tab in the Recolor Artwork dialog box is a color 

wheel. Each color in your selected artwork (or group, if you’re editing a color 

group) appears mapped to the color wheel as a small circle (Figure 6.46). 

The relationships between all the mapped colors are indicated by lines that all 

connect to each other through the center of the color wheel. Solid connector 

lines indicate that the colors are locked to each other, meaning that adjusting 

one color will adjust all others (while maintaining their relationship). Dashed 

connector lines indicate that the colors are independent, meaning they can 

be moved individually without affecting the others (Figure 6.47). You can 

toggle between locked and unlocked colors by clicking the Link/Unlink Har-

mony Colors icon. To add colors to your existing color group, click the color 

wheel anywhere with the Add Color tool. To remove a color, click its circle 

with the Remove Color tool.

The color wheel is based on the HSB color model, which is more easily 

understood as a wheel, compared to other models such as CMYK or RGB 

(Figure 6.48). In the HSB color model, the H value represents hue, or the 

actual color itself; the S value represents saturation, or the amount of color; 

and the B value represents brightness, or the lightness/darkness of the color 

(also referred to as the value of the color). You can adjust the mapped circles 

on the color wheel in Live Color for various results.

• Moving a circle in a clockwise or counterclockwise direction, around 

the center of the color wheel, adjusts the hue of that color.

NOTE When the 
Recolor Artwork dialog 

box opens, the Assign tab is 
active, but we’ll cover the 
details of the Edit tab fi rst.

Figure 6.46 Each color 
used in the selected art-
work appears mapped on 
the color wheel. One circle, 
larger than the rest, repre-
sents the base color.
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Figure 6.47 Dashed 
connector lines indicate 
colors that can be adjusted 
independently.

Brightness

Saturation

Saturation

Hue

Hue

Figure 6.48 The HSB color 
model is displayed as 360 
degrees of color.

Add Color Tool Remove Color Tool

Link/Unlink Harmony Colors
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• Moving a circle toward or away from the center of the color wheel 

adjusts the saturation of that color.

• Dragging the slider that appears directly underneath the color wheel 

adjusts the brightness of the entire wheel.

• Control-click (right-click) a color circle, and choose Select Shade to 

edit the saturation and brightness values of that color without changing 

its hue.

• Double-click a color circle to open the Color Picker.

By default, Illustrator displays a smooth color wheel, but you may prefer a 

segmented color wheel, showing clear distinctions of hue and saturation. 

Alternatively, you can view your selected colors as vertical color bars 

(Figure 6.49). These options are accessible via the three icons that appear 

to the lower left of the color wheel.

Although you can certainly have lots of fun dragging color circles all over 

the color wheel, it doesn’t make for the precise kinds of adjustments you 

may be used to doing in Illustrator. To achieve a higher level of precision, 

you’ll want to edit colors numerically. Click a color circle to select it, and 

then use the sliders and values that appear beneath the color wheel. These 

sliders are identical to those in the Color panel. You can switch between the 

TIP Clicking the little 
sun icon that appears 

above the brightness slider 
swaps the brightness and 
saturation settings, allowing 
you to use the slider to 
control saturation and the 
color circles to adjust 
brightness.

Figure 6.49 The Edit tab 
shown with a segmented 
color wheel (left) and 
vertical color bars (right).

Color Bars

Segmented Color Wheel

Smooth Color Wheel
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RGB, HSB, CMYK, web-safe RGB, Tint (for global process and spot 

colors), and Lab sliders. In addition, you can also choose a setting called 

Global Adjust that lets you edit all colors using the Saturation, Brightness, 

Temperature, and Luminosity sliders (Figure 6.50).

As with the Color Guide panel, you can also limit the Recolor Artwork 

dialog box to a specifi c library of colors (Figure 6.51). This extremely pow-

erful feature makes it possible to remap entire artwork or entire groups of 

color to a specifi c library of color…instantly. When you’ve completed editing 

your colors to your liking, click OK to return to your artboard.

As you experiment with the colors on the color wheel, you may fi nd that 

you’d like to undo the last adjustment you made. Unfortunately, there is no 

undo function in the Recolor Artwork dialog box. This is a huge oversight, 

Figure 6.50 The Global 
Adjust sliders let you modify 
colors similarly to how 
you might adjust colors in 
Photoshop.

Figure 6.51 Just as in the 
Color Guide panel, you can 
limit the colors that the 
Recolor Artwork feature can 
work with.
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and, it can be extremely frustrating to have to cancel the dialog box and start 

over again. Of some consolation is an icon at the top of the Recolor Artwork 

dialog box called “Get colors from selected art” (Figure 6.52). Clicking this 

icon resamples the selected artwork and remaps all the colors as they were 

when you fi rst opened the Recolor Artwork dialog box.

Understanding the Recolor Art Check Box

People often mistake the Recolor Art check box that appears at the lower-left 
corner of the Live Color dialog box as a preview option. But that isn’t the case 
at all. The Recolor Art check box does exactly what its name represents—it 
recolors any artwork you have selected (it’s dim if you launch the Live Color 
dialog box without any art selected). So, why is this setting useful? Well, it’s 
useful because you can turn it off . For example, you may want to start tweak-
ing the color of an illustration only to realize that you want to leave the color 
as it was before you started editing it. But at the same time, you like the color 
variations you created and want to save those colors as a new color group. By 
deselecting the Recolor Art box, the selected artwork remains untouched on 
your artboard, but you can still access and work with those colors in the Live 
Color dialog box.

Using the Assign Tab

The main part of the Assign tab is the list of current (or old) and new colors 

(Figure 6.53). Colors that exist within your selected artwork appear as wide 

bars along the left side, while the colors you are using to recolor your art-

work appear in shorter bars along the right side. Each bar sits in a color row, 

and if you follow the direction of the arrow, you’re indicating that the color 

Figure 6.52 Click the “Get 
colors from selected art” 
icon to load all colors from 
the selected art in your 
document as the active col-
ors and map them onto the 
color wheel. In the context 
of assigning colors, this acts 
much like a “reset” or “start 
over” button.

NOTE The quickest 
way to recolor your art-

work is to select any of the 
color groups listed on the far 
right side of the Recolor Art-
work dialog box. This is why it 
makes sense to defi ne color 
groups in the Swatches panel 
before you open the Recolor 
Artwork dialog box, if your 
workfl ow allows it.
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appearing in the wide bar becomes the color that appears in the short bar. In 

fact, the arrow controls the recoloring behavior, and clicking the arrow in a 

color row toggles the recoloring on and off for that color row (Figure 6.54). 

For example, you’ll notice that, by default, Illustrator preserves black and 

white colors in your artwork (meaning they aren’t recolored), so those colors 

will appear listed in color rows with the arrows turned off.

By default, when you fi rst open the Recolor Artwork dialog box to the 

Assign tab, Illustrator has no idea what you want to do with your colors. As 

such, Illustrator simply remaps each color to itself. This is why each color 

row features the same color in the Current and New columns.

Figure 6.53 The Assign tab 
seems a bit complex at fi rst 
glance, but it will quickly 
become your friend. The 
main section in the middle 
lists all the colors from the 
selected artwork on the left 
(wide bars) and all the colors 
they are being remapped to 
on the right (narrow bars).

Figure 6.54 Color rows 
help you easily recolor your 
artwork.

Color Row

Current Color Arrow New Color
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Deconstructing a Color Row

The color rows that appear in the Assign tab of the Recolor Artwork dialog box 
is really a lot like a mathematical formula, describing how recoloring will occur 
(Figure 6.55).

Figure 6.55 Color rows help you easily recolor your artwork.

Clicking the Color Reduction Options icon on the Assign tab of the Recolor 

Artwork dialog box opens the Recolor Options dialog box (Figure 6.56). 

The presets that appear in the pop-up menu at the top of the dialog box 

offer quick shortcuts to reducing artwork to one-, two-, or three-color jobs 

and to limiting the colors to a specifi c library of color. The Color Harmony 

preset sets the Colors value to Auto and results in the number of current 

colors listed in the dialog box to match the number of active colors in the 

chosen color harmony rule. This lets you easily experiment with different 

color harmonies, because each time you choose one, the number of current 

colors will automatically adjust to match the harmony. The others settings 

in the dialog box are as follows.

Figure 6.56 The Recolor 
Options dialog box gives 
you control over how your 
artwork is recolored.

Current Colors

Current colors that currently appear 
within the selected artwork.

New

New color that will appear 
in recolored artwork.

1)  All of the colors 
in this row...

2)  will change... 3)  to this 
color...

4)  using this 
colorization 
method.
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• Colors. You can manually set the number of colors to which you want 

to reduce your artwork.

• Limit to Library. You can limit new colors to a specifi c color library.

• Sort. You can choose to sort colors in the Assign tab using any of four 

different settings, or you can set it to None (where you can manually 

sort the colors yourself).

• Colorize Method. When reducing many colors to a single color, you 

must instruct Illustrator how to handle different shades of colors. The 

differences between the fi ve available options (Exact, Preserve Tints, 

Scale Tints, Tints and Shades, and Hue Shift) are illustrated in detail in 

the sidebar “Colorization Methods.”

• Preserve. You can select these options to preserve (leave untouched) 

artwork that is colored white, black, and/or gray.

To identify where a specifi c color appears in your artwork, highlight a color 

row, and then click the magnifying glass icon (Figure 6.57) at the lower 

right of the Assign tab in the Recolor Artwork dialog box. This reduces the 

opacity of all colors except for the selected color, making it easy to identify 

where the color is used. Shift-clicking multiple colors or rows will highlight 

all the selected colors at once.

Figure 6.57 Use the 
magnifying glass to quickly 
identify where colors appear 
in your artwork.

Magnifying Glass
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You can manually reduce colors by dragging the wide color bars from one 

row to another. Combining two or more colors in a single wide color bar 

instructs Illustrator to reduce those colors to one new color (Figure 6.58). 

You can double-click a small color bar to access the Color Picker. You can 

also choose a colorize method by clicking the far-right edge of a small color 

bar. Deselecting the Apply To All box will allow you to specify different col-

orize methods for each new color.

Icons that appear beneath the color bars allow you to randomly change color 

order and the saturation and brightness settings, as well as manage color 

rows. When you’ve recolored your artwork, click OK to apply the settings 

and return to the artboard.

Converting Art to Grayscale
Sometimes you might need to convert color artwork to shades of gray. Tra-

ditionally, such a task in Illustrator has always been diffi cult because colors 

can be present in symbols, patterns, gradients, gradient meshes, and so on. 

Editing all the colors in these separate places would normally take quite 

some time, but not with the help of the Live Color engine.

It’s important to realize that changing artwork from color into shades of 

gray isn’t necessarily automatic. In other words, you can take different roads 

to perform such a conversion, and depending on the artwork at hand, you 

may choose a particular method in order to achieve a desirable result. For 

example, if you’ve used Photoshop to convert color images into grayscale, 

you know you can simply change your color mode from RGB or CMYK to 

Figure 6.58 You can drag 
as many colors as you like 
to a color row to convert 
all those colors to one 
new color.
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Colorization Methods

When simply recoloring art, Illustrator takes one color and changes it to 
another. However, when reducing colors, you’re often taking many diff erent 
colors and asking Illustrator to represent all of those colors using a single color. 
Choosing a colorization method tells Illustrator how to use a single color to 
represent all the colors in a selected row. In these examples, a color illustration 
is reduced to one color (PANTONE Refl ex Blue). Various results are achieved as 
you select diff erent colorization methods (Figure 6.59).

Figure 6.59 Colorization methods.
Original art

Exact

Exactly replaces each current 
color with the specifi ed new 
color.

Preserve Tints

Replaces the darkest current color 
in the row with the specifi ed new 
color. Other current colors in the 
row are replaced with a propor-
tionally lighter tint. For spot or 
global colors, it applies the current 
color’s tint to the new color. This 
setting is best used when all the 
current colors in the row are tints 
of the same or similar global color. 
For best results, also select Com-
bine Tints in the Recolor Options 
dialog box.

Tints and Shades

Replaces the current color with the average lightness 
and darkness with the specifi ed new color. Current 
colors that are lighter than the average are replaced 
with a proportionally lighter tint of the new color. 
Current colors that are darker than the average are 
replaced by adding black to the new color.

Scale Tints (the default option)

Replaces the darkest current color in the 
row with the specifi ed new color. Other 
current colors in the row are replaced with 
a proportionally lighter tint.

Hue Shift

Sets the most typical color in the current colors row 
as a key color and exactly replaces the key color with 
the new color. The other current colors are replaced 
by colors that diff er from the new color in brightness, 
saturation, and hue by the same amounts that the 
current color diff ers from the key color.
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grayscale but that the result may not look that great. Seasoned users know 

they can use functions such as the Photoshop Channel Mixer or the Black 

and White adjustment command to garner more pleasing grayscale conver-

sions. Advanced users could probably rattle off several other methods as well.

In Illustrator, though, we’ve identifi ed four ways to convert artwork from 

color into grayscale. These methods all take advantage of the Live Color 

engine, so they work on any artwork in your Illustrator document with the 

exception of linked or embedded raster images (see the sidebar “Converting 

Raster Content to Grayscale” for more information on that).

• Use the Convert to Grayscale command. Select your color artwork, 

and choose Edit > Edit Colors > Convert to Grayscale (Figure 6.60). 

Using this method is obviously the fastest method, but the results aren’t 

always pretty. Different colors may convert to similar shades of gray, 

and often you’ll fi nd that this setting gives low-contrast results.

• Desaturate the art. Select your artwork, and click the Recolor Art-

work button in the Control panel. At the bottom of the dialog box, 

change the mode of the color adjustment sliders to Global Adjust. Drag 

Figure 6.60 The Convert 
to Grayscale function now 
works on all objects with the 
exception of placed images.



MODIFYING COLOR 211

the Saturation slider all the way to the far left (the setting should read 

-100). This method requires an extra click or two, but by desaturating 

the color in this way, your result will have more contrast.

• Use Adjust Color Balance. Select your artwork, and choose Edit > 

Edit Colors > Adjust Color Balance. In the Adjust Colors dialog box, 

choose Grayscale from the Color Mode pop-up menu, and select the 

Convert box. Adjust the Black slider until you get the desired result. 

This method is rather straightforward and gives you the freedom to 

adjust the density of the black values (Figure 6.61).

• Recolor the art using a Grayscale color group. When you create 

a new print document, you’ll notice that the Swatches panel already 

contains a color group labeled Grayscale, which contains 10 shades of 

gray. Select your artwork, and click the Recolor Artwork button in the 

Control panel. In the Live Color dialog box, click the Grayscale color 

group. This forces Illustrator to remap your existing colors to those 

colors of the selected group (Figure 6.62). Use the Assign tab in the 

Live Color dialog box to move colors around to control exactly the 

shade of gray to which each color will remap. For an even greater level 

of control, you can create your own Grayscale color group with values 

you specify. This method requires more interaction than the previous 

ones but yields the most control over the conversion.

Figure 6.61 The Adjust 
Color Balance function 
is great for making color 
adjustments, as well as 
making black and white 
adjustments.
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Converting Raster Content to Grayscale

Although the Live Color feature gives you plenty of options for converting color 
artwork to grayscale, what do you do when you also need to convert rasterized 
content—such as placed images—to grayscale?

If possible, you should convert your raster content to grayscale using 
Photoshop, which excels in editing bitmapped artwork. Don’t fool yourself into 
thinking that Illustrator can do it all. For best results, use the new Black and 
White adjustment feature in Photoshop. You can use the Edit Original feature 
in Illustrator (in the Links panel) to quickly open your image in Photoshop, 
make the change and save your fi le, and then return to Illustrator where the 
image will update itself. For detailed information on the Edit Original workfl ow, 
refer to Chapter 12, “Working with Images.”

If you absolutely must convert pixels from color to grayscale directly in 
Illustrator, select the image, and choose Object > Rasterize. From the Color 
Model pop-up menu, choose Grayscale. Make sure you specify an appropriate 
resolution, and click OK. As an alternative, you can choose Eff ect > Rasterize 
to apply the conversion in a reversible way.

Figure 6.62 By recoloring 
your artwork with a gray-
scale color group, you have 
complete control over the 
color conversion.
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Performing One-Click Color Fixes
Although the Live Color dialog box is certainly powerful, sometimes you 

might need to make a quick adjustment. If you select some artwork, you’ll 

fi nd a collection of functions available in the Edit > Edit Colors menu. 

These settings have actually been available in Illustrator for many versions 

now, but they were limited in that they worked only on certain basic vector 

objects (excluding gradients, patterns, symbols, gradient meshes, and so on). 

The functions you’ll fi nd here have all been retooled to use the Live Color 

engine and will work on everything with the exception of linked raster 

images. The functions (listed in the order in which they appear) are as fol-

lows: Adjust Color Balance, Blend Front to Back, Blend Horizontally, Blend 

Vertically, Convert to CMYK, Convert to Grayscale, Convert to RGB, 

Invert Colors, Overprint Black, and Saturate.

VIEWING COLOR ON THE SCREEN
There was a time when we were all trained never to trust the color we saw 

on our computer screens. The myth has always been that although color 

management exists, it doesn’t work. Some users even try to turn off color 

management (not something we suggest, even if it were possible, which it 

isn’t). The reality is that these days the color you see on our screens is gener-

ally better than it has been in the past. Color management settings that were 

once inconsistent (even among Adobe applications) are now in sync with 

each other. The result is a more reliable viewing experience.

This section of the chapter in no way, shape, or form attempts to explain 

how color management works. Likewise, it doesn’t explain how to ensure 

that your ink-jet printer and your computer screen look the same. The topic 

of color management really requires an entire book of its own. In fact, if 

you really want to learn everything there is to know about color manage-

ment, you should check out Real World Color Management, Second Edition, by

Bruce Fraser, Chris Murphy, and Fred Bunting (Peachpit Press, 2005). For 

the scope of this book, you’ll learn where to access your color management 

settings and how you can use some of the color management features in 

Illustrator to simulate your artwork as it might appear on specifi c devices.
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Controlling Color Management Settings
You can access the color management settings by choosing Edit > Color 

Settings. This opens the Color Settings dialog box, and if you installed 

Adobe Illustrator as part of Creative Suite, an icon and a message at the top 

of the dialog box will indicate whether your settings are in sync with other 

Adobe Creative Suite components (Figure 6.63).

Out of the box, Adobe has set all CS2, CS3, and now CS4 applications to 

use the North America General Purpose 2 color setting. This is actually 

a generic “middle of the road” setting, meant to be used by those who are 

cross-media designers, meaning those who often work with both RGB and 

CMYK documents. However, if you work specifi cally in the print fi eld or 

if you primarily work with video or the web, you might be better off using 

North America Prepress 2 or North America Web/Internet. If you aren’t 

sure, leave it set to the default setting.

Proofi ng Colors
One of the most powerful functions of color management is the ability 

to simulate the viewing of your artwork on other devices. If you have the 

profi le of another device, Illustrator can show you what your fi le will look 

Figure 6.63 The Color 
Settings dialog box informs 
you whether your color set-
tings are in sync with other 
Creative Suite components.

NOTE Selecting the 
Advanced Mode 

option in the Color Settings 
dialog box populates the 
Settings color with many 
additional color management 
settings.
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like when it’s displayed (or printed) on that device. Don’t worry about hunt-

ing down device profi les either—your system already contains many useful 

ones. Let’s take a closer look.

Choose View > Proof Setup > Customize to open the Proof Setup dialog 

box. From the Device to Simulate pop-up menu, choose a profi le. For 

example, you might use the Uncoated FOGRA29 profi le to simulate what 

your art might look like when printed in a newspaper (Figure 6.64). Select 

the Preview check box to see your artwork change in appearance as you 

select different profi les.

When your document is CMYK and you’re choosing a CMYK profi le, no 

color conversion occurs, and you can choose the Preserve CMYK Numbers 

option. Likewise, when viewing an RGB document and choosing an RGB 

profi le, you can choose Preserve RGB Numbers. The option is obviously 

not available when proofi ng with a device profi le that uses a different color 

model than the document (in such cases, a color conversion must take place, 

and there’s no way to preserve the numbers).

When proofi ng artwork on devices with smaller color gamuts, you must 

also choose a rendering intent. The most commonly used method, Relative 

Colorimetric, moves out-of-gamut colors to the closest possible color that 

will print on the device. It also adjusts other colors so that colors appear to 

be accurate. The Absolute Colorimetric setting adjusts only out-of-gamut 

colors and may result in posterization, where many shades of similar colors 

are used. The Perceptual method shifts colors so they appear correct rela-

tive to each other, but it may not represent colors as being the most accu-

rate match to the original values. The Saturation method enhances colors 

and makes them more vibrant and most suitable for business presentations 

where bright colors are more important than accurate colors.

Figure 6.64 The Proof 
Setup dialog box gives you 
the ability to specify what 
kind of device you want 
to simulate when proofi ng 
your artwork on your screen.

NOTE To actually 
assign a diff erent color 

profi le to your document 
(instead of just proofi ng it on 
your screen), choose Edit > 
Assign Profi le.
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For an accurate onscreen representation of your artwork, you can choose to 

simulate paper color (avoiding the problem of viewing too bright of a white 

screen) and black ink (if you fi nd the preview of black is too rich). Once 

you’ve specifi ed your proof settings, you can quickly preview your artwork 

on your screen by choosing the View > Proof Colors setting.

Previewing Contrast for Color Blindness
Although it’s certainly helpful to be able to proof colors onscreen as they 

might appear when output on different devices, it is also extremely helpful 

for designers to be able to visualize how other people may view their art and 

designs. For example, 7 percent of Americans are color blind (that’s more 

than 10.5 million people). When creating artwork that will be used as pub-

lic signage, how can a designer be sure that the art will be clearly visible to 

all—even those who don’t see with the same range of color as they do?

In the View > Proof Setup menu, you can choose to display the art on your 

screen as though it were being viewed by a color-blind person (Figure 6.65). 

Illustrator can simulate two types of color blindness, Protanopia and 

Deuteranopia (both variations of red-green color blindness). By ensuring a 

high enough level of contrast in your design, a larger audience will be able 

to understand and benefi t from your art.

Figure 6.65 Illustrator can 
simulate art as if it were 
being viewed by someone 
who is color-blind.
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Understanding Book Color
Although consistent color management settings will help ensure that your 

colors look the same in different software (Photoshop, Illustrator, InDesign, 

Acrobat, and so on), you may still experience colors that don’t match up cor-

rectly. This is usually something that happens when spot colors appear in 

your fi le, but the good news is that it’s easy to fi x.

The problem is that, by default, Photoshop displays spot colors using LAB 

values (which are bright, vibrant, and match their printed color better). 

The default setting for Illustrator and InDesign is to use CMYK values 

instead, which often results in muted colors, especially when compared to 

Photoshop. The thing is, both Illustrator and InDesign support the ability 

to use LAB values when displaying spot colors, so it’s simply a matter of 

turning the feature on. Before you do that, however, you need to under-

stand something called Book Color.

Book Color is a setting that fi rst appeared in Adobe CS2 components. You 

may notice that when double-clicking a spot color swatch to view its set-

tings, you’ll see that the color mode for the swatch is set to Book Color 

(Figure 6.66).

One of the reasons why designers use spot colors is simply because some 

colors aren’t reproducible in CMYK. Bright blues, purples, greens, and 

oranges are perfect examples. Pantone delivers an entire Microsoft Excel 

spreadsheet to Adobe that lists each Pantone color, along with their LAB 

color equivalents. Obviously, the LAB color values match closer to the 

real color. However, many designers specify Pantone colors, even though 

they will be printing their fi le on a press in a four-color process. Pantone 

Figure 6.66 A Pantone 
color swatch shows up in 
Illustrator as a Book Color.
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also delivers a Solid to Process library that specifi es the CMYK values of 

Pantone colors. Obviously, the latter is far less accurate and results in color 

shifts.

Since you now know that Photoshop uses LAB values to display spot colors 

on your screen and that Illustrator and InDesign use CMYK values for the 

same, you can begin to understand why spot colors viewed in Photoshop 

look different.

So, what does all this have to do with Book Color? Ordinarily, you can 

defi ne a color swatch in Illustrator using CMYK values or LAB values, but 

not both. But a Book Color is special and can contain both CMYK and LAB 

information within it. By defi nition, a Book Color swatch contains both 

the CMYK and LAB values specifi ed by Pantone. The question is, how 

does Illustrator determine when to preview the colors using the LAB values 

instead of the CMYK ones?

The answer is an odd one, only because of the name of the feature you 

need to use: Overprint Preview. If you choose View > Overprint Preview 

in Illustrator (or in InDesign or Acrobat, for that matter), the LAB values 

generate the onscreen preview. The regular preview settings use the CMYK 

values. In this way, you can preview the more vibrant LAB values on your 

screen, but if you ever decide later in your workfl ow to convert your 

Pantone color to CMYK, you’ll get the exact CMYK values you expect 

(otherwise you’ll get a LAB-to-CMYK version).

Likewise, if you’d like more accurate colors when printing composite 

proofs from Illustrator, select the Simulate Overprint check box in the 

Print dialog box.



Chapter 
SevenWorking with Live Eff ects

So far, we’ve only scratched the surface with the kinds 

of effects Adobe Illustrator CS4 has to offer. Soft 

drop shadows (which we discussed in Chapter 5, 

“Organizing Your Drawing”) are certainly cool, but 

they are only a small sampling of live effects in 

Illustrator, which include 3D effects, warp distor-

tions, and a wide range of pixel-based Adobe 

Photoshop CS4 effects.

As you read this chapter, remember that you can 

apply live effects to fi lls and strokes individually, as 

well as to objects, groups, and layers. You apply all live effects via the Effect 

menu or the Appearance panel, and once applied, they appear listed in the 

Appearance panel and can be edited or deleted at any time. Additionally, you 

can apply multiple live effects to a single target.

It’s also important to realize you can apply live effects to type without 

needing to convert to outlines. As you make changes to the text, the 

applied effect updates. 

The artwork featured throughout this chapter comes from Che McPherson 

(iStockPhoto; username: chemc).

219
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COMBINING FEATURES AND EFFECTS
New features aren’t added haphazardly in Illustrator. Rather, each new 

feature is carefully thought out in regard to how it might interact with exist-

ing features in Illustrator. One of the most powerful things you can do with 

live effects in Illustrator is apply several of them to a single object or, even 

better, use effects in combination with other features, such as transparency 

and blends (Figure 7.1).

When using Illustrator, you should always be asking yourself “what if” 

questions. For example, you know that you can apply transparency to 

objects in Illustrator, so what if you applied transparency to a 3D effect? 

Would you be able to see through the 3D object? (We’ll discuss how to do 

just that in Chapter 11, “Exploring the World of 3D.”) Experimenting in 

Illustrator is a great way to discover new techniques and creative ideas. The 

worst that can happen is you get something that doesn’t look that great; 

the Undo function serves nicely at this point.

Throughout this chapter, we ask “what if” questions and explore the ways 

that live effects integrate with other Illustrator features. These questions 

are answered with advice on how to get the most out of Illustrator. More 

importantly, the “what if” scenarios will open your eyes to the power of the 

Illustrator live effects.

DECONSTRUCTING THE
EFFECT MENU
The Effect menu is basically split into four main sections. The section at 

the very top contains two settings: Apply Last Effect and Last Effect. The 

former allows you to duplicate the last effect you applied, including all its 

settings; the latter opens the dialog box for the last effect you applied so you 

can choose different settings. The next section of the Effect menu is some-

thing called Document Raster Effects Resolution, which we’ll get to in a 

Figure 7.1 You don’t have 
to be a high roller to see 
the benefi ts of combining 
features in Illustrator. This 
example uses the 3D eff ect 
with artwork mapping, 
transparency, and blends.

NOTE The eff ects are 
listed in this chapter 

in the order in which they 
appear in the Eff ect menu. 
The 3D eff ect is covered in 
its entirety in Chapter 11.
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moment. The remaining two sections are Illustrator Effects and Photoshop 

Effects; each section contains a collection of effects in those two categories. 

For the most part, Illustrator effects are Illustrator-specifi c features, whereas 

Photoshop effects are a collection of fi lters taken from Photoshop (see the 

sidebar “Illustrator Effects and Photoshop Effects” later in this chapter).

Is It Vector, or Is It Raster?
You already know that a live effect is simply an appearance that is added to 

an object, meaning the underlying vector object exists in your document 

in its original state. As you change the underlying object, the appearance 

updates to refl ect that change. If you want to lock in an appearance, you need 

to choose Object > Expand Appearance to alter the actual vector paths, at 

which point the effect is no longer live and can’t be edited.

Some effects, such as Drop Shadow, are raster-based. Even though this 

effect appears grouped in the Illustrator Effects section, when the appear-

ance is expanded, the drop shadow becomes a raster image (Figure 7.2). 

The same applies when you print a fi le, because all effects are expanded 

when they are sent to the printer (your fi le remains in an unexpanded state, 

however, allowing further editing).

Figure 7.2 Many of the 
Stylize eff ects, including 
Drop Shadow, produce 
raster-based results, even 
though they are listed in the 
Illustrator Eff ects section of 
the Eff ect menu.
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The following features appear in the Illustrator Effects section of the Effect 

menu; these produce raster images when output or expanded:

• 3D Extrude & Bevel and 3D Revolve, when raster images or gradients 

are present in mapped artwork

• Rasterize

• Stylize > Drop Shadow

• Stylize > Feather

• Stylize > Inner Glow

• Stylize > Outer Glow

Each of these is covered in detail later in this chapter and in Chapter 11.

Massaging Pixels in Illustrator
If it is true that some effects in Illustrator produce a rasterized result, who 

determines the resolution of those rasters? When you work in Photoshop, 

you can’t even create a new fi le without fi rst defi ning its resolution. But with 

Illustrator, which is vector-based, you don’t think much about resolution. So 

the question is, what determines the resolution of these raster-based effects? 

To fi nd the answer, choose Effect > Document Raster Effects Settings.

The Document Raster Effects Settings dialog box is where you can specify 

the resolution for raster-based effects. In fact, the dialog box offers all the 

necessary settings for determining how raster-based effects eventually print 

(Figure 7.3).

The Document Raster Effects Settings dialog box gives you seven options: 

• Color Model. Depending on the document’s Color Model setting to 

which your fi le is set, you’ll see either CMYK, Grayscale, and Bitmap 

or RGB, Grayscale, and Bitmap listed here. This is because a document 

cannot contain both CMYK and RGB elements. This setting can be 

extremely useful, because it allows you to change the color model of an 

object (even an image) as a live effect, which can always be edited. For 

example, you can turn a colored object into grayscale as an effect.

TIP Refer to 
Chapter 15, “Prepress 

and Printing,” for more 
information on what 
happens when you print 
Illustrator fi les.

NOTE When you 
choose to save a fi le as 

EPS, all eff ects are expanded, 
and any raster-based eff ects 
are rasterized. This means 
Illustrator EPS fi les can con-
tain raster content and can’t 
be scaled infi nitely when 
placed in other applications. 
See Chapter 14, “Saving 
and Exporting Files,” for 
information.
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• Resolution. This setting determines the resolution at which raster-

based effects (both the Illustrator effects mentioned earlier and the 

Photoshop effects) are rendered. You can also specify this resolution 

setting in the Raster Effects pop-up menu (under Advanced) when you 

create a document using a new document profi le. The default resolution 

setting in Illustrator is 300 ppi for print documents and 72 ppi for web, 

mobile, and video documents. The Resolution setting has a direct bear-

ing on the performance of Illustrator, and just as in Photoshop, working 

at higher resolutions means more number crunching for your computer 

and more time for you to stare at your screen watching the progress bars 

slowly creep along. This is an extremely important setting and should 

not be overlooked. See the sidebar “Illustrator Effects and Photoshop 

Effects” later in this chapter for details on whether you need to change 

this setting before or after you create your fi le.

• Background. You can choose whether the resulting raster has a trans-

parent background or a white background. If your effect overlaps other 

objects, you probably want to use the Transparent setting (Figure 7.4
on the next page), although remember that the fi le still needs to be fl at-

tened (see Chapter 15 for more information on transparency fl attening).

Figure 7.3 When using 
live eff ects, choosing 
the right settings in the 
Document Raster Eff ects 
Settings dialog box is key 
to achieving the best results 
from your fi les.
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• Anti-alias. You can defi ne whether the raster image is antialiased. 

Antialiasing slightly blurs color boundaries to avoid the appearance of 

jagged edges. For more information on antialiasing, refer to Chapter 13, 

“Designing for Web and Mobile Design.”

• Create Clipping Mask. This setting creates a clipping mask around 

the area of a shape so you can have it blend into a background (raster 

images are always rectangular and may block out objects that appear 

behind them). This setting won’t work well for objects that have Drop 

Shadow, Feather, and Glow effects applied, because clipping masks have 

hard edges. You don’t need this setting if you specify the Transparent 

option for the background.

• Add: x Around Object. This is a very important setting. When certain 

effects, such as Feather or Gaussian Blur, are applied, the resulting raster 

image has a soft edge. To ensure that this soft edge fades into the back-

ground correctly, you must make the bounding box of the raster image 

larger than the actual object. If you don’t, the fade stops abruptly, and 

you see a visible line where it ends. By default, Illustrator adds 36 points 

(.5 inch) of space around an object, but if you have a large blur setting, 

you may need to increase this amount (Figure 7.5).

Figure 7.4 In this example, 
the artwork on the left 
used the White setting for 
Background, whereas the 
artwork on the right used 
the Transparent setting.

Figure 7.5 On the left 
is a circle with a 60-pixel 
Gaussian Blur eff ect applied. 
With the default of Add: .5 
Space Around Object, the 
blur is visibly clipped. On 
the right, that same blur 
appears correctly with the 
Add: 1.5 Around Object 
setting.
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• Preserve spot colors. If your artwork contains spot colors and you 

want to prevent those from being converted to process colors, this set-

ting instructs Illustrator to preserve those spot colors, employing over-

printing where necessary. Refer to Chapter 15 for more information on 

overprinting.

Any live effects you apply in your document will use the settings in the 

Document Raster Effects Settings dialog box, and you can’t have different 

settings for different effects. Well, you can, sort of—just not in any way that 

Adobe intended, though. All live effects update when you make a change 

in the Document Raster Effects Settings dialog box, but once you expand a 

live effect, that object no longer updates when you change the settings. So if 

you need to use different settings for different objects, then apply an effect 

to one object, use the Object > Expand Appearance function to expand the 

effect, lock in the document raster effects settings for that effect, and fi nally 

apply a different setting to another object. Of course, once you expand an 

effect, you have no way to go back and perform edits on it.

CONVERT TO SHAPE: CHANGING
FOR THE BETTER
The Convert to Shape effect takes the fi ll of your targeted selection and 

converts it to a rectangle, a rounded rectangle, or an ellipse. When you fi rst 

see this effect, you might scratch your head thoughtfully and ask yourself, 

“Well, if I had wanted a rectangle, wouldn’t I have drawn the shape that 

way in the fi rst place?” This is a good question if your object has only one 

fi ll, but if you’ve added multiple fi lls, you will realize that you can apply the 

Convert to Shape effect on just one of them, which means you can have a 

single shape with fi lls that have different shapes. This effect is particularly 

useful for text objects and for groups and layers as well.

Applying the Convert to Shape Effect
To apply any of the three Convert to Shape effects, target the fi ll of an 

object, group, or layer, and choose Effect > Convert to Shape > Rectangle. 

Although you can choose between the Rectangle, Rounded Rectangle, and 

Ellipse options, it doesn’t matter which one you choose because the ensuing 
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Shape Options dialog box allows you to easily switch between the three dif-

ferent shapes via a pop-up menu at the top of the dialog box (Figure 7.6).

The Shape Options dialog box gives you two options for specifying the size 

of the targeted fi ll:

• Absolute. The Absolute setting allows you to defi ne a specifi c width 

and height for the fi ll shape, which can be completely different from the 

size of the object’s actual path.

• Relative. The Relative setting allows you to defi ne a specifi c amount 

that is added to the object’s actual size. For example, if the object’s 

actual path is 4 x 4 inches and you use a relative setting with the Extra 

Width and Extra Height settings set to .5 inch, the shape effect produces 

a shape that is 4.5 x 4.5 inches. The Relative setting is useful when you 

want to create a shape that changes when the original object changes 

(see the following “What If…You Apply the Convert to Shape Effect to 

Text?” section).

When you choose the Rounded Rectangle setting from the Shape pop-up 

menu, you can also specify a corner radius for the fi ll shape.

What If…You Apply the Convert to Shape 
Effect to Text?
A practical use for the Convert to Shape effect is to create a background for 

an object that dynamically adjusts itself as you change the object. A good 

example is when you want to create a button that has text inside it. Using 

Figure 7.6 It doesn’t 
make a diff erence which 
shape you choose from the 
Convert to Shape submenu, 
because you get a chance 
to change your mind in the 
Shape Options dialog box.
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the Convert to Shape effect, you can have Illustrator automatically resize the 

button as you change the text within it. Here are the steps required to create 

this dynamic shape:

 1. Choose the Type tool, and click a blank area on the artboard to create a 

Point Type object.

 2. Using your keyboard, type Dynamic.

 3. Set your text to 12-point Myriad Roman.

 4. Switch to the Selection tool, and select the Type object.

 5. Open the Appearance panel, and from the panel menu, choose 

Add New Fill.

 6. In the Appearance panel, drag the fi ll you just created so it appears listed 

beneath the characters in your Type object (Figure 7.7).

 7. With the new fi ll highlighted in the Appearance panel, choose a color 

from either the Control panel, the Color panel, or the Swatches panel.

At this stage, you won’t see the color change in your text, because the 

fi ll you are coloring appears beneath the characters in the Type object.

 8. With the colored fi ll still highlighted in the Appearance panel, choose 

Effect > Convert to Shape > Rounded Rectangle.

 9. In the Shape Options dialog box that appears, choose the Relative 

options, and specify 4 pt for Extra Width and 2 pt for Extra Height.

10. For the Corner Radius, specify a value of 2 pt, and click OK to apply the 

effect (Figure 7.8).

Figure 7.7 Move the fi ll you 
created so it appears below 
the characters in the Type 
object.
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11. Switch to the Type tool, and edit the text.

You will notice that as you change the text, the colored background 

expands or contracts as necessary to match the text.

As always, a little bit of experimenting not only gets you more comfortable 

with these kinds of effects but also helps you think of ways you can get your 

work done faster and more effi ciently (which is a good thing).

CROP MARKS: CUT HERE, PLEASE
When preparing custom art for a printer, you often need to indicate where 

the printer should trim the paper. Especially when you’re printing several 

items on a single large sheet (sometimes referred to as ganging up), a printer 

needs to know how and where to cut the sheet of paper. Traditionally, 

designers create crop marks, a series of lines just outside the boundary of the 

artwork that indicate where the paper should be trimmed (Figure 7.9).

Instead of drawing these lines manually, you can use the Crop Marks effect 

to have Illustrator draw them automatically. To apply the effect, select an 

object or a group, and choose Effect > Crop Marks. Illustrator automatically 

adds trim marks around the boundary of the artwork. Since Crop Marks 

is a live effect, as you move or update your artwork, the trim marks update 

accordingly.

In a real-world workfl ow (that’s what this book is all about, isn’t it?), apply-

ing the Crop Marks effect to your actual artwork probably makes little 

sense, for a variety of reasons. Often, the trim area doesn’t end exactly 

where the artwork does. For example, artwork may be centered on a larger 

sheet of paper, with white space intended to be around it. Alternatively, if 

artwork needs to print to the edge of the paper, you need to specify bleed, 

or extend the artwork beyond the boundary of the trim marks.

Figure 7.8 The second fi ll 
you created now acts like a 
background for the text.

TIP Visit http://
rwillustrator.blogspot

.com/2007/11/ask-mordy-
rounding-some-corners.html 
for a tutorial on creating more 
complex autoresizing  buttons.

NOTE The lines that 
the Crop Marks eff ect 

creates are .3 pt in weight 
and are colored with the 
Registration swatch so that 
the marks appear on each 
plate when the fi le is color 
separated.

http://rwillustrator.blogspot.com/2007/11/ask-mordyrounding-some-corners.html
http://rwillustrator.blogspot.com/2007/11/ask-mordyrounding-some-corners.html
http://rwillustrator.blogspot.com/2007/11/ask-mordyrounding-some-corners.html
http://rwillustrator.blogspot.com/2007/11/ask-mordyrounding-some-corners.html
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The solution is to draw a rectangle and apply the Crop Marks effect to 

the rectangle, not to your actual artwork. In this way, you can still make 

changes or adjustments to your artwork without moving the trim marks. 

In addition, as with any other effect, you can choose Object > Expand 

Appearance to convert the crop marks to editable artwork as needed.

DISTORT & TRANSFORM:
TRANSFORMING YOUR DESIGN
Throughout your design process, you are constantly making changes to 

your artwork. Sometimes you need to alter paths by distorting them, and 

other times you need to transform them using functions such as Scale or 

Rotate. Illustrator features a variety of these functions as live effects, which 

makes it easy to perform tweaks or changes to these settings as necessary.

Distortion Effects
Illustrator features six different distortion effects, each providing a differ-

ent type of look and feel. Distortion effects in particular are useful when 

applied to strokes or fi lls individually, and this is especially true when you’re 

Figure 7.9 Crop marks indi-
cate where a printer should 
trim the sheet of paper after 
it has been printed.
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building complex appearances that contain multiple fi lls and strokes. You 

can fi nd each of the effects listed here by fi rst choosing Effect > Distort & 

Transform and then choosing one of the distortion effects:

• Free Distort. The Free Distort effect displays your art with a rectan-

gular bounding box. You can drag any of the four corners to stretch or 

apply a distortion (Figure 7.10). This is useful if you want to add per-

spective to make art appear as if it has a vanishing point, although the 

3D Rotate effect offers similar functionality in that regard.

• Pucker & Bloat. The Pucker & Bloat effect offers a slider that applies 

distortion to your objects by spiking paths. When you’re looking for a 

really funky shape, this distortion effect probably fi ts the bill.

• Roughen. The Roughen effect allows you to take straight paths and 

make them appear as if they just experienced an earthquake (Figure 
7.11). The Roughen dialog box offers the ability to adjust size and 

detail; you can also specify whether you want the result to have smooth 

(rounded) or corner (straight) path segments.

Figure 7.10 The Free 
Distort eff ect lets you 
stretch artwork to apply 
perspective or distortion.

Figure 7.11 You can use 
the Roughen eff ect to create 
torn paper eff ects or simply 
to apply an uneven look to 
vector art.
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• Tweak. At fi rst, the Tweak effect appears to be similar to the Pucker & 

Bloat distortion, but the Tweak effect adjusts control points in addition 

to anchor points on paths. The result is a path that is far less predictable.

• Twist. The Twist effect allows you to twist art from its center using a 

specifi ed angle.

• Zig Zag. The Zig Zag effect is similar to the Roughen effect, but it 

creates methodical zigzag patterns on selected objects.

Illustrator also has other distortion tools and effects. The Warp effect, 

covered later in this chapter, provides a way to stretch art using predefi ned 

warp styles. We covered other distortion features such as envelopes and the 

Liquify set of tools in Chapter 2, “Selecting and Editing Artwork.”

Transform Effect
If you want to rotate or scale an object on your artboard, using the 

Transform effect is overkill. Rather, the Transform effect is useful when 

you want to apply transformations to parts of an object. For example, you 

might scale two different fi lls within the same object so they are different 

sizes. To do so, apply the Transform effect by choosing Effect > 

Distort & Transform > Transform.

The Transform Effect dialog box is actually identical to the one that appears 

when you use the Transform Each function (which we covered in Chapter 2). 

However, the Transform Effect dialog box has one huge addition—the ability 

to specify copies (Figure 7.12).

Figure 7.12 The Transform 
Eff ect dialog box mimics the 
Transform Each dialog box, 
and it includes the ability 
to set the number of copies 
you want transformed.
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Transforming Objects with Eff ects

Because we’re on the topic of transformations, we’ll discuss a few concepts you should be aware of when per-
forming standard transformations on the artboard—specifi cally when scaling or rotating objects that have live 
eff ects applied to them.

By default, when you scale an object on the artboard, Illustrator does not scale the values that you may have 
specifi ed for any live eff ects applied to that object. For example, if you specify a 30-pixel Gaussian Blur eff ect 
and then scale that object 200 percent, the Gaussian Blur is still set to 30 pixels. 

If you’re using one of the Illustrator live eff ects (see the sidebar “Illustrator Eff ects and Photoshop Eff ects” later 
in this chapter), you can choose to scale an object’s live eff ect attributes. To do so, select the Scale Strokes & 
Eff ects setting, which you can fi nd in the General panel of Preferences or by double-clicking the Scale tool in 
the Tools panel.

It’s also important to realize that the values of certain eff ects have limits. For example, you can’t set a Gaussian 
Blur to anything greater than 250 pixels. Even if you have Scale Strokes & Eff ects selected, you can scale your 
artwork only up to the limit, at which point Illustrator just uses the maximum value it allows. If you need to 
scale objects to extremely large sizes (for creating signs or banners, for instance), you fi rst have to expand the 
eff ect and then scale it as you would any object.

Finally, the values that are specifi ed in the dialog boxes of live eff ects are relative to the rulers of your docu-
ment. In many cases, modifying your object may cause unexpected results. For example, say you apply a drop 
shadow to an object and specify an off set that sets the shadow down and to the right. If you rotate the object 
180 degrees on your artboard (eff ectively turning it upside down), the drop shadow still displays at the lower 
right of the object. To get the correct appearance, you need to edit the drop shadow eff ect and set the off set 
so that the drop shadow now falls up and to the left, or even better, you can convert your artwork to a symbol 
before applying the transformation. Alternatively, you can expand the eff ect before you perform the rotation. 
This issue requires special attention from printers, who often compose fi les or create work and turn layouts for 
their presses. Drop shadows in Adobe InDesign CS4 suff er from the same symptoms.

PATHS: DRAWING OUTSIDE
THE LINES
At some point, editing vector paths is something that just about every 

Illustrator user has to come to terms with. However, sometimes performing 

these edits makes sense as a live effect, which allows the paths to be updated 

easily. Specifi cally, three path functions—Offset Path, Outline Object, and 

Outline Stroke—are available as live effects. You can fi nd all these effects by 

choosing Effect > Path and then selecting the required function.
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For the most part, these effects are useful when you apply them to Type 

objects. The Outline Object effect is particularly useful for using text in a way 

that normally requires the text to be outlined into vector paths. In addition, 

the Offset Path effect can be helpful when you’re trying to create type effects 

in tandem with the Pathfi nder effects, as described in the next section (see 

“What If…You Combine Offset Path and Pathfi nder Effects on a Group?”).

PATHFINDER: CREATING
COMPLEX SHAPES
The Pathfi nder effects are identical to those in the Pathfi nder panel (covered 

in Chapter 2), only here they are applied as live effects. Before you question 

the reason for making these available as live effects, remember that you can 

apply live effects to groups and layers. Applying these effects to type objects 

may also prove useful.

The following Pathfi nder commands are available as live effects: Add, 

Intersect, Exclude, Subtract, Minus Back, Divide, Trim, Merge, Crop, 

Outline, Hard Mix, Soft Mix, and Trap. Refer to Chapter 2 for details 

on each of these functions.

To apply any of the Pathfi nder effects, make a selection, choose Effect > 

Pathfi nder, and select the Pathfi nder function you need.

What If…You Combine Offset Path and 
Pathfi nder Effects on a Group?
A design may sometimes call for artwork to be outlined with a single line 

that encompasses all the objects. The Offset Path function is perfect for this, 

but the effect outlines each object that appears in the group, resulting in a 

mess of paths that overlap each other. If you were to expand the appearance 

of the overlapping paths, you might use the Pathfi nder Unite or Add func-

tion to create a single unifi ed shape, but if you do, any change to the group 

will mean you’ll have to repeat the steps all over again. This is where a 

Pathfi nder live effect can be really helpful.

TIP You can also use 
the Outline Object 

eff ect to help add strokes to 
images. Refer to Chapter 12, 
“Working with Images,” for 
details.

NOTE The Hard Mix 
and Soft Mix com-

mands, which combine the 
appearance of overlapping 
colors, are available only as 
live eff ects. They are not avail-
able through the Pathfi nder 
panel.
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Follow these steps to learn how you can apply both the Offset Path and 

Pathfi nder effects to a group:

1. Choose the Selection tool, and select any group of objects.

2. From the Appearance panel, choose Add New Stroke.

3. With the new stroke highlighted in the Appearance panel, choose 

Effect > Path > Offset Path.

4. In the Offset Path dialog box that appears, specify a value (this 

example uses 4 pt), and click OK to apply the effect (Figure 7.13).

5. With the new stroke still highlighted in the Appearance panel, 

choose Effect > Pathfi nder > Add. The effect is applied immediately 

(Figure 7.14).

6. With the Selection tool, double-click any object in the group to isolate 

it. Notice that as you move objects around in the group, the outline 

updates accordingly.

Figure 7.14 The Pathfi nder 
Add function combines all 
the individual paths created 
with the Off set Path eff ect, 
resulting in a single 
combined outline.

Figure 7.13 Adding an 
Off set Path eff ect to the 
new stroke you created 
adds an outline around 
the artwork.
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RASTERIZE: CREATING VECTORS
THAT ACT LIKE PIXELS
Illustrator has a Rasterize command in the Object menu that gives you the 

ability to rasterize any object in Illustrator. The Rasterize effect in the Effect 

menu gives you the same functionality—but as a live effect. When you 

think about it, the result of applying this effect is a bit of an oxymoron: The 

object is a vector, yet it appears and acts like a raster image.

To apply the Rasterize effect, select an object, and choose Effect > Rasterize. 

The options that appear in the Rasterize dialog box are similar to those in 

the Document Raster Effects Settings dialog box, and you can even choose 

to have the Rasterize dialog box pick up the resolution settings from that 

dialog box by selecting the Use Document Raster Effects Resolution radio 

button (Figure 7.15).

You might want to use the Rasterize effect for several reasons. For example, 

you might want to disable antialiasing on small text so that it appears easier 

to read when displayed on a website (you can fi nd more information on this 

in Chapter 13). In addition, you can use the Rasterize effect to change the 

color model of selected artwork (see the following “What If …You Apply 

the Rasterize Effect to a Raster Image?” section).

Figure 7.15 To ensure a 
consistent overall appear-
ance, you might want to 
have the Rasterize eff ect 
in the Rasterize dialog box 
share the same resolution 
setting as in the Document 
Raster Eff ects Settings 
dialog box.



CHAPTER 7: WORKING WITH LIVE EFFECTS236

What If…You Apply the Rasterize Effect to a 
Raster Image?
It doesn’t take a whole lot to realize that the Rasterize effect can turn vector 

elements into raster elements, but have you ever thought about the possibil-

ity of applying the Rasterize effect to a placed raster image in Illustrator? 

Not only is it possible, but it’s extremely useful as well. Besides the obvious 

ability to temporarily downsample high-resolution fi les to a lower resolu-

tion for faster processing, the Rasterize effect has the ability to change color 

modes. That means you can place a full-color photo into a layout but use 

the Rasterize effect to change the image to grayscale. Of course, since it’s a 

live effect, you can always switch it back to color at any time.

In addition, you can use this method of converting images to grayscale 

for when you want to convert an entire fi le to grayscale—including both 

raster and vector objects. In such a case, you may fi nd it easier to apply the 

Rasterize effect at the layer level, where all items on a layer can be converted 

to grayscale.

STYLIZE: NOW YOU’RE STYLIN’!
The group of Stylize live effects gets a bit more visibility than other effects 

for one main reason: the celebrity factor. Among the different effects 

you’ll fi nd in the Stylize submenu is the rock star of all live effects, the 

Drop Shadow effect. Although there’s nothing that special about the Drop 

Shadow effect per se, it seems designers these days are trying to fi nd untold 

ways to add drop shadows to their artwork. We don’t discriminate between 

different live effects (we’re an equal-opportunity educator), and the reality 

is, plenty of other useful effects appear in the Stylize submenu, including 

Add Arrowheads, Feather, Inner and Outer Glow, Round Corners, and the 

sleeper live effect of the year—Scribble.

The Add Arrowheads Effect
If you need to add arrowheads to the end of paths for creating diagrams or 

callouts, use the Add Arrowheads live effect. With any path selected, choose 

Effect > Stylize > Add Arrowheads. In the Add Arrowheads dialog box, 

you can specify 27 different types of arrowheads for both the start and end 

NOTE The Drop 
Shadow live eff ect is 

covered in Chapter 5.
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of your path (Figure 7.16). A helpful Preview check box makes it easy to see 

the results of the effect on your artboard as you experiment with different 

arrowhead styles.

Figure 7.16 The Add 
Arrowheads dialog box 
off ers a variety of styles, 
although, unfortunately, 
there’s no way to defi ne 
or create your own.

Illustrator uses the stroke width of your path to determine the size of the 

arrowhead, but you can adjust the size to perfection by using the Scale set-

ting at the bottom of the dialog box. You’ll also notice that the arrowheads 

always match the orientation of the path, so if you adjust the path after 

you’ve added the effect, the arrowhead updates accordingly.

The Feather Effect
Vector paths are known for their clean, crisp edges, but at times, you want a 

softer edge to your objects. That’s where the Feather effect can help. Choose 

Effect > Stylize > Feather, and specify an amount to determine how soft 

of an edge you want your shape to have (Figure 7.17). You can even apply a 

Feather effect directly to a placed photograph.

NOTE It’s interesting 
to note that the Add 

Arrowheads eff ect works on 
both open and closed paths. 
The fi lter is also a great way 
to quickly fi gure out the 
direction of a path.

TIP Try using a Feather 
on an object you’re 

using as an opacity mask; this 
allows you to create a mask 
with soft edges.

Figure 7.17 If you thought 
soft edges were for pixel-
based programs only, think 
again. The Feather live eff ect 
can add that perfect touch 
to vector art.
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The Inner Glow and Outer Glow Effects
As a variation to the Drop Shadow effect, Illustrator also offers Inner Glow 

and Outer Glow effects. You can fi nd both of these effects in the Effect > 

Stylize submenu.

The Inner Glow effect adds a soft glow to the inside area of an object. From 

the Inner Glow dialog box, you can choose the Center option that starts the 

glow from the center of the object and extends it toward the edges, or you 

can choose the Edge option that begins the glow in the opposite direction—

from the edge toward the center of the shape (Figure 7.18). The Outer 

Glow effect adds a soft glow to the outside edges of an object.

The Round Corners Effect
The Rounded Rectangle tool is so year 2000. Welcome to today’s fast-paced 

world where you can add rounded corners to any object, no matter how 

many corners the object has (Figure 7.19). When you select an object and 

choose Effect > Stylize > Round Corners, you can use the Preview check 

box to experiment with different Radius settings until you get just the look 

you need. Of course, you can always change the Radius setting because it’s a 

live effect.

TIP Glow eff ects can 
sometimes appear too 

soft for your needs. To beef 
up a glow eff ect, try applying 
two or three glow eff ects to 
the same object.

Figure 7.18 Depending on 
the desired eff ect, you can 
specify an Inner Glow eff ect 
to start from the center 
(left wing) or the edge 
(right wing).

Figure 7.19 The usefulness 
of the Round Corners eff ect 
becomes apparent when 
you apply it to objects with 
many corners.
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Unfortunately, you can’t specify which corners of your object will get 

rounded—the Round Corners effect rounds all corners. If you want only 

some corners to be rounded in your object, you need to apply the Round 

Corners effect and then expand the effect so that you can manually adjust 

each corner as necessary.

The Scribble Effect
If there’s one thing you can count on with vector graphics, it’s clean, sharp 

edges. However, sometimes a design calls for something a little bit less tech-

nical and more natural. The Scribble effect in Illustrator is perfect for this 

task. And, as you will see, the power of the Scribble effect lies in its abil-

ity to randomize individual attributes, giving the effect a truly natural and 

hand-drawn appearance. One of the nicest aspects of the Scribble effect is 

its ability to draw outside the lines. In fact, what the Scribble effect really 

does is convert your object into one long stroke (Figure 7.20).

To apply the Scribble effect, select an object, and choose Effect > 

Stylize > Scribble to open the Scribble Options dialog box. The dialog 

box contains fi ve main settings that control the overall appearance of the 

Scribble effect. Some of the settings also have a Variation slider, allowing 

the scribble appearance to vary throughout your object.

As you will quickly fi nd out, making even small adjustments to the Scribble 

effect settings can have a large impact on the appearance of the object. 

TIP For an interesting 
eff ect, try applying the 

Round Corners eff ect to type.

TIP The Scribble eff ect 
looks simple at fi rst 

glance, but refer to “What If…
You Apply the Scribble Eff ect 
to Multiple Fills?” later in this 
chapter to see how powerful 
the eff ect can be.

Figure 7.20 Here, using one 
of the many settings in the 
Scribble eff ect, the object’s 
appearance is converted to 
one long stroke.
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Using a combination of different settings, you can also achieve a variety of 

different styles for your scribble. To illustrate this, Adobe added a pop-up 

menu at the top of the dialog box that contains different presets (Figure 
7.21). Switch between the different presets to see the ways you might use 

the Scribble effect. Unfortunately, you cannot defi ne your own presets. 

However, you can always save your Scribble setting as a graphic style once 

you’ve applied it to an object.

Although it may seem a bit daunting at fi rst, the different settings in the 

Scribble Options dialog box are rather straightforward:

• Angle. The Angle setting defi nes which direction the stroke will travel. 

Click and drag the dial to adjust the setting, or enter a value manually in 

the fi eld.

• Path Overlap. The Path Overlap setting defi nes how far the stroke 

overlaps the edge of the object’s path. You can also set this to a negative 

value, which effectively defi nes how close the stroke can come to the 

edge of an object’s path. You can also set a variation, which allows the 

Path Overlap setting to randomly change throughout the object within 

the value you defi ne (Figure 7.22).

Figure 7.21 The variety of 
presets helps you quickly 
learn the diff erent types of 
styles you can achieve with 
the Scribble eff ect.
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• Stroke Width. The Stroke Width setting defi nes the thickness of the 

stroke that Illustrator uses to create your Scribble effect. Unfortunately, 

this setting does not have a variation slider.

• Curviness. The Curviness setting defi nes how much a stroke loops 

when it changes direction. A very small number produces more of a 

straight zigzag effect with pointy ends, while a larger number produces 

loose changes in direction with loopy ends (Figure 7.23). You can also 

defi ne a Variation value so that this setting appears differently through-

out the object.

• Spacing. The Spacing setting defi nes how dense the strokes appear. 

Again, this setting has a Variation slider, which allows the Scribble 

effect to vary the spacing throughout the object.

Figure 7.23 Smaller 
Curviness settings create 
sharp lines (left), while 
higher values create a more 
freestyle appearance (right).

Figure 7.22 Adding a variation to the Path Overlap setting allows the Scribble eff ect 
to draw outside the lines using a natural technique.
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What If…You Apply the Scribble Effect 
to Multiple Fills?
Adding a Scribble effect to an object can certainly give it a hand-drawn look 

and feel, but sometimes you need something more than just strokes travel-

ing in the same direction. Combining multiple fi lls—each with a different 

Scribble effect setting—can produce crosshatching effects that produce 

wonderful patterns, textures, and edges. Here’s how it is done:

1. Select any path.

2. With the object selected, open the Appearance panel, and target the fi ll 

by clicking it.

3. From the Add New Effect button on the Appearance panel, choose 

Stylize > Scribble to open the Scribble Options dialog box.

4. Choose Default from the Setting pop-up menu, and make the following 

adjustments: set Path Overlap to 0 pt, and set the variation to 5 pt. For 

Line Options, change Stroke Width to .5 pt, set both the Curviness and 

Variation settings to 0, and specify .5 pt for the Spacing attribute with a 

1 pt variation. Click OK to apply the effect (Figure 7.24).

5. With the fi ll still highlighted, click the Duplicate Selected Item button 

in the Appearance panel to create a second fi ll with the same attributes 

as the fi rst.

6. Double-click one of the Scribble effects listed in the Appearance panel 

(it doesn’t matter which one) to edit the effect.

Figure 7.24 Applying the 
Scribble eff ect to the but-
terfl y gives it an interesting 
appearance.
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7. Change the Angle setting to 130 degrees, and click OK to apply the edit 

(Figure 7.25).

SVG FILTERS: APPLYING
TECHNICAL EFFECTS
Scalable Vector Graphics (SVG) is a vector-based fi le format that can be 

used for displaying graphics on the web and on handheld devices. We 

discuss SVG graphics in detail in both Chapter 13 and Chapter 14, but you 

can apply certain effects to graphics that are saved in the SVG format. These 

effects, called SVG fi lter effects, are really XML-based instructions that are 

applied when the SVG graphic is rendered in a web browser or viewer. As a 

result, these effects are useful only when applied to graphics that will even-

tually be saved as SVG.

Illustrator ships with a collection of 18 SVG fi lter effects, although if you 

know how to code them yourself, you can also write your own. To apply an 

SVG fi lter effect, select an object, and choose Effect > SVG Filters > Apply 

SVG Filter. Once the Apply SVG Filter dialog box is open, you can click a 

fi lter from the list and click OK. Alternatively, you can highlight a fi lter and 

click the Edit SVG Filter button to modify the selected fi lter effect, or you 

can click the New SVG Filter button to create a new SVG fi lter effect from 

scratch. Additionally, you can delete selected fi lters by using the trash can 

icon in the Apply SVG Filter dialog box.

Figure 7.25 Adding a 
second fi ll with another 
Scribble eff ect gives the 
shape a lattice-like appear-
ance. Notice the crosshatch 
eff ects around the edges of 
the shape as well.

NOTE For information 
on how to create your 

own SVG fi lter eff ects (and 
download existing code), visit 
www.w3.org/TR/SVG/fi lters.
html.

www.w3.org/TR/SVG/filters.html
www.w3.org/TR/SVG/filters.html
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Illustrator can also import SVG fi lters. To do so, choose Effect > SVG 

Filters > Import SVG Filter. In the dialog box, open an SVG fi le with a 

fi lter effect in it; when you do, Illustrator will import that fi lter into your 

current fi le.

WARP: CHOOSING YOUR
DISTORTION
The Warp effect is one of several distortion functions in the Illustrator arse-

nal. You can use Warp to apply any of 15 different preset distortions to any 

object, group, or layer.

To apply a Warp effect, make a selection, and choose Effect > Warp > Arc. 

Even though all 15 warp styles are listed in the submenu, you don’t have to 

worry about choosing the right one just yet—the Warp Options dialog box 

lets you choose from any of the preset warp styles.

When the Warp Options dialog box appears, select the Preview check box 

so you can preview your warp on your artboard as you adjust the settings. 

Click the Style pop-up menu to choose from the list of warp styles: Arc, 

Arc Lower, Arc Upper, Arch, Bulge, Shell Lower, Shell Upper, Flag, Wave, 

Fish, Rise, Fisheye, Infl ate, Squeeze, and Twist. Little icons appear to the 

left of each warp style to help you visualize what each one does, although 

trial and error probably works better (Figure 7.26).

NOTE SVG eff ects 
should be the last 

eff ects applied in the stacking 
order when multiple eff ects 
are being specifi ed; other-
wise, the SVG eff ect will end 
up being rasterized.

Figure 7.26 The little icons 
that appear to the left of 
each Warp eff ect help you 
understand what each 
option does.
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Once you’ve chosen a warp style, you can specify whether the warp is 

applied horizontally or vertically, and you can adjust how slight or extreme 

the warp is applied by adjusting the Bend slider. Also, you can use the 

Horizontal and Vertical sliders to apply additional distortion to your 

selection.

Warp effects are particularly useful when applied at the group or layer level, 

where you might often add or remove elements from the group. For example, 

you might apply a Warp effect to a logo to show movement or excitement. If 

you applied the Warp effect at the group level, adding new art to the group 

will automatically cause the new art to take on the same Warp effect.

APPLYING PHOTOSHOP EFFECTS
The effects we have discussed to this point are considered Illustrator effects, 

and for the most part, they are vector in nature and make adjustments to 

vector paths (with the obvious exception of the Rasterize effect and most of 

the Stylize effects).

However, Illustrator also has the ability to apply a variety of purely pixel-

based effects to any object, group, or layer. These effects are grouped in the 

Photoshop Effects section of the Effect menu. The same rules as to how 

effects are applied through the Effect menu and edited via the Appearance 

panel apply to these effects as well.

In truth, the Photoshop effects in the bottom portion of the Effect menu 

are really Photoshop fi lters. You can copy Photoshop fi lters and plug-ins 

into the Illustrator Plug-ins folder (found in the same folder in which the 

Illustrator application fi le appears), and they appear listed in the Effect 

menu as well.

At fi rst, it may seem unnatural to fi nd that you can apply a Gaussian Blur 

or Unsharp Mask effect in Illustrator, but you’ll quickly fi nd that you can 

achieve wonderful designs and cool effects by employing Photoshop fi lters 

such as Crystallize and Mezzotint. Some of the graphic styles libraries 

that ship with Illustrator employ a variety of these effects, and by reverse-

engineering them, you can learn how to use them.

NOTE Refer to 
Chapter 2 for detailed 

information on the other dis-
tortion features in Illustrator, 
as well as a sidebar of those 
features as they compare to 
the Warp eff ect. 

NOTE Be aware that 
copying objects with 

below-the-line eff ects from 
one document to another 
may cause the appearance 
of the eff ect to change if 
the two fi les have diff erent 
resolution settings.
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Illustrator Eff ects and Photoshop Eff ects 

At fi rst glance, it may appear that the Illustrator eff ects are purely vector in nature and the Photoshop eff ects 
are raster-based ones, but this isn’t true. Eff ects such as Feather and Drop Shadow, which appear in the Stylize 
submenu, are listed as Illustrator eff ects, and they produce raster content. So, what then is the distinction 
between Illustrator and Photoshop eff ects?

The diff erence is relatively simple yet absolutely critical: resolution.

At the beginning of the chapter, you learned how the Document Raster Eff ects Settings dialog box determines 
the resolution at which eff ects are rasterized when the document is either fl attened or printed. But the setting 
is also important for determining the appearance of some eff ects. Let’s take a look at an example:

1. Open the Document Raster Eff ects Settings dialog box, set the resolution to 72 ppi, and click OK.

2. Draw two identical shapes.

3. Apply a Feather eff ect to one shape (an Illustrator eff ect) and a Gaussian Blur eff ect to the other 
(a Photoshop eff ect), and then observe the results (Figure 7.27).

Figure 7.27 Shown are 
identical shapes with a 
Feather eff ect applied (left) 
and a Gaussian Blur eff ect 
applied (right). You can 
see that both appear to be 
somewhat similar.

4. Now open the Document Raster Eff ects Settings dialog box, change the resolution to 300 ppi, and click 
OK. Observe the results of the eff ects (Figure 7.28).

Figure 7.28 The shape with the 
Feather (left) remains unchanged 
in appearance, but the shape with 
the Gaussian Blur (right) now has a 
harder edge than it did before the 
change in resolution.

You’ll notice that the appearance of the Gaussian Blur eff ect has changed, but the Feather eff ect remained 
the same. This happens because the Gaussian Blur eff ect (and all Photoshop eff ects, for that matter) uses 
absolute measurements to calculate the eff ect. You’ll notice the Gaussian Blur eff ect dialog box specifi es 
the blur value in pixels (Figure 7.29). Changing the resolution—the number of pixels in your fi le—changes 
the appearance in pixels (Figure 7.29). Changing the resolution—the number of pixels in your fi le—
changes the appearance of your eff ect. In contrast, the Feather eff ect—and all Illustrator eff ects—uses 
relative units to calculate the eff ect (Figure 7.30). The Feather dialog box specifi es the feather value in inches 
(or whatever measurement system you’ve chosen in preferences), so when you change the resolution setting, 
Illustrator simply adjusts the number of pixels it uses in the eff ect, as needed. 

(continues)
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Illustrator Eff ects and Photoshop Eff ects (continued)

Figure 7.29 The Gaussian 
Blur eff ect uses pixels to 
calculate the eff ect.

Figure 7.30 The Feather eff ect uses 
relative units (in this case, inches) to 
calculate the eff ect.

Overall, we refer to Photoshop eff ects as below-the-line eff ects because they appear below the divider line 
in the Eff ect menu (Figure 7.31). When using below-the-line eff ects, it’s best to ensure that your document 
raster eff ects settings are correct before you begin working on your design. Otherwise, the appearance of 
your artwork will change when you adjust it later (or if your printer adjusts it). If you use above-the-line eff ects 
(Illustrator eff ects), you can get better performance by leaving the document raster eff ects settings at a lower 
resolution until you are about to send the fi le out for high-end output.

Figure 7.31 All eff ects 
that appear below the line 
are considered Photoshop 
eff ects and are resolution-
dependent.
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A Gallery of Effects
Going through each Photoshop effect listed in the Effect menu is beyond 

the scope of this book, but one feature that really makes it easy to experi-

ment with a wide range of Photoshop effects is the Effects Gallery. If you’re 

familiar with the Photoshop Filter Gallery feature, you’ll fi nd that the 

Effects Gallery is the same. Once you’ve targeted an object, group, or layer, 

choose Effect > Effects Gallery, which opens the Filter Gallery dialog box. 

The dialog box is split into three main sections: a preview on the left, a list 

of the different effects you can apply in the center, and the parameters for 

the selected effect on the right (Figure 7.32).

To preview different effects, click an effect in the center area (expand the 

folders to see the individual effects), and adjust the settings at the upper 

right of the dialog box. Once you’ve found the effect you like, click the 

OK button to apply it.

Figure 7.32 You can spend 
hours going through the 
eff ects in the Filter Gallery 
dialog box.



Chapter 
EightWorking with Typography

Though a picture speaks 1,000 words, you still need 

to type words every once in a while. Adobe Illustra-

tor CS4 has very powerful typography features, which 

we’ll cover in detail later in this chapter. Illustrator is a 

top-notch illustration tool, but it is also capable of set-

ting professional-level type—its typography features 

are on par with those found in the award-winning 

Adobe InDesign. And although InDesign shines when 

it comes to setting pages and pages of type, Illustrator 

is the program of choice for creative uses of type. 

Graphical applications, such as putting type on a path, putting it around 

a circle, putting it inside a shape, and wrapping it around an object, are 

all quick and easy tasks in Illustrator.

In this chapter, in addition to the creative uses of type, we’ll explore some 

important technologies, such as Unicode compliance, as well as some of the 

newer typography features found in Illustrator. Toward the end of the chapter, 

we’ll discuss a very important side effect of all this new technology—

backward compatibility with previous versions of Illustrator.

249
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WORKING WITH TEXT OBJECTS
For now, it’s suffi cient for you to learn about the two kinds of type objects 

that Illustrator can create: point text and area text. Naturally, each has its 

own benefi ts. Point text gets its name from the fact that it is anchored, so to 

speak, by a single point you create when you fi rst click with the Type tool. 

Point text is fi ne if you want to enter just a few words or so. The problems 

are that the type doesn’t wrap automatically and that many typographic 

controls are not available to you. Area text is contained by a text frame or 

shape and behaves more like the text you create in a page layout program 

like InDesign. This is the kind of text object you’ll want to use for longer 

chunks of type.

Working with Point Type
The simplest form of text in Illustrator is point type, which you can create 

by choosing the Type tool and clicking any blank area on your artboard. 

Once you’ve defi ned a point at which to start typing, you can enter text 

on the artboard. Point type doesn’t have defi ned boundaries, so text never 

wraps automatically, although you can press Return (Enter) to manually 

type on a new line. When you use point type, the paragraph alignment 

settings (left, right, and center) refer to the single point that you created 

when you fi rst clicked with the Type tool (Figure 8.1).

Although point type is easy to create, many of the powerful text features 

that Illustrator has, including the Adobe Every-line Composer, text thread-

ing, and the ability to set text in columns, are not available. However, if 

you want to place text in numerous areas of an illustration (such as callouts, 

maps, graphs, and so on), point type is the way to go.

NOTE Illustrator can 
also create another 

other kind of type—path 
type, which is explained 
later in this chapter.

Figure 8.1 Point type aligns 
diff erently depending on 
the paragraph alignment 
options you set for the text.
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Working with Area Type
As with most page-layout applications, you can also place text within a 

frame, although with Illustrator, any vector object can serve as a text frame. 

Area type is text that is enclosed within the confi nes of a vector shape 

(Figure 8.2). To create an Area Type object, you can either use the Area 

Type tool to click an existing vector shape or use the Type tool to click 

inside any closed vector shape (Figure 8.3). Alternatively, you can click 

and drag a blank area of the artboard with the Type tool to create an Area 

Type object.

Multiple Area Type objects can be linked to have a single story fl ow across 

them called a thread of text. Text fl ows from line to line automatically within 

an Area Type object, and more advanced paragraph settings such as columns, 

Figure 8.2 Area type is 
enclosed within a frame.

Figure 8.3 As you drag the 
Type tool over an object 
that can become a text 
frame, Illustrator displays 
the tool icon in parentheses.
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composition, hyphenation, and indents are available. We’ll cover text thread-

ing and the advanced text features that are available later in the chapter.

Area type might take an extra click or two to create, but for uniform layouts 

and longer runs of copy, you’ll want to use it.

Converting Text to Editable Vectors
In Chapter 3, “Technical Drawing,” you learned about the primary shape 

tools in Illustrator. The characters in both Point Type and Area Type objects 

are vector shapes too, but they can’t be edited as regular vector shapes can 

because you can’t access their anchor points or direction handles. In essence, 

text is a special kind of vector object. Fonts have specifi c information built 

into them, called hinting, which modifi es character shapes slightly based on 

the size in which text is printed. For example, a lowercase e character has 

a small hole in the middle, and at really small point sizes, that hole might 

appear to close up or fi ll in when printed. Font hinting adjusts the size of 

that hole to be slightly larger at smaller point sizes.

You can select any text object and choose Type > Create Outlines to con-

vert text into regular, editable vector shapes. Doing so allows you to per-

form edits on the actual shapes of the characters (for example, extending an 

ascender or removing the dot from an i ) but results in the loss of any font 

hinting (Figure 8.4).

Where possible, it’s always best to leave text in an editable state and avoid 

converting it to vector outlines. In this way, you’ll be able to make edits 

easily, and you’ll preserve font information. However, sometimes it’s a good 

idea to convert text to outlines, such as when you’ve created artwork that 

will be distributed or used in many different places (logos are good exam-

ples). In this way, you don’t need to worry about passing font fi les around 

(which has legal ramifi cations anyway—something we’ll discuss later in 

the book).

Figure 8.4 Converting text 
to outlines (right) gives you 
unlimited freedom to edit 
the vector paths (left).
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Why Text Looks “Fatter” When Converted to Outlines

You might notice that when you convert text to editable vector outlines, the appearance of that text is bolder 
than text that is not outlined. There are actually two main reasons behind this (both technical in nature):

• The loss of hinting makes certain features potentially inconsistent. For example, letter strokes that you 
expect to be the same width might turn out to be diff erent widths depending on how they fall on the grid 
of the output device. Slight diff erences can get magnifi ed unexpectedly, such as rounded letters going 
below the baseline. This happens because the information that makes the outlines round consistently to 
the pixel grid has been lost.

• The change in the fi ll algorithm combines with the lack of hinting to make the letters look fatter. Font 
rasterizing uses a fi ll algorithm that turns on a pixel only when the center of the pixel is within the glyph 
outline (center-scan). Graphics rasterizing uses a fi ll algorithm that turns on a pixel when any part of 
the pixel is within the graphic outline (overscan). Given that the outline is no longer being rounded to 
pixel boundaries at key points, the rendering will generally be at least 1 pixel thicker and occasionally 
2 pixels thicker.

Of course, how much diff erence this makes depends on the size and style of the type and especially on the 
resolution of the output device. At 2,400 dots per inch (dpi) with typical text sizes, the eff ect is pretty subtle. 
At 600 dpi with 6-point text, the eff ect is quite obvious.

Special thanks to Thomas Phinney of Adobe for providing this information.

GETTING GLOBAL TEXT SUPPORT
WITH UNICODE
When you use your keyboard to type words on your computer, each charac-

ter you type is stored on your computer by a number. Every font also has a 

number assigned to each of its characters. This method of mapping charac-

ters to numbers is called character encoding. The idea is that when you type 

an a, your computer matches up its code with the code in the selected font, 

and an a shows up on your screen. Simple, right?

The problem is that not every computer uses the same encoding system. 

For example, Mac and Windows use different character encodings. Operat-

ing systems in different languages and countries around the world also use 

a variety of encodings. Confl icts also exist in that one system may encode a 

certain character with a number, whereas another system may have a com-

pletely different character encoded for that same number. Because there are 

NOTE Besides Unicode 
support, Illustrator also 

has fantastic support for 
Asian languages and type 
features such as Mojikumi, 
Kinsoku, and composite fonts. 
To activate these extended 
features in the English-
language version of Illustrator, 
turn on Show Asian Options 
in the Type panel 
of Preferences.
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so many different ways of encoding characters, you can run into a situation 

where you create a fi le on one computer, and simply opening that same fi le 

on a different computer results in words not appearing correctly. If you’ve 

ever typed something on Windows and transferred it to a Mac and noticed 

that certain characters appear as question marks, appear as weird boxes, or 

disappear completely, you can now understand why that happened.

In 1991, a standard was formed called Unicode, which, as its name implies, 

is a single encoding that can be used to describe every single character, in 

any language, on any computer platform. The text engine that was intro-

duced in Illustrator CS uses Unicode, and if you use Unicode-compliant 

fonts to create your documents, you can pass your documents across the 

world and have them display correctly on any computer.

UNDERSTANDING THE WAY
OF THE FONT
Have you heard about the latest reality show? Ten designers have to create a 

logo, but fi rst they have to get their fonts to work on their computers. Seri-

ously, though, we’d think that in a day and age where we can put people on 

the moon and do just about anything wirelessly, we would have fi gured out 

the whole font thing by now. As you will soon learn, different font formats 

are available, and each offers different capabilities. In addition, Illustrator is 

specifi cally sensitive to corrupt fonts, and although a bad font may work in 

other applications, it can cause problems in Illustrator. Several font manage-

ment utilities are available, including Suitcase, Font Reserve, FontExplorer, 

and Font Agent, and each of these has components to help you identify and 

repair problematic fonts.

More importantly, different font formats are available. As a designer, you 

may be familiar with PostScript Type 1 fonts, TrueType fonts, or Multiple 

Master fonts. Adobe reduced support for Multiple Master fonts with the 

release of Illustrator CS, and although those fonts might still work in 

Illustrator today, there’s no way to take advantage of the extended technol-

ogy that they were meant to bring. TrueType fonts aren’t used as much in 

print workfl ows because when they were fi rst introduced, they weren’t as 

reliable as PostScript Type 1 fonts (although nowadays, those problems no 

longer exist). Because of this, PostScript Type 1 fonts have always been per-

ceived as being higher-quality fonts.

NOTE For more 
information on 

the Unicode standard, 
visit www.unicode.org.

TIP If you fi nd that 
Illustrator is crashing 

frequently, the cause might 
be a corrupt font. By turning 
off  all fonts and activating 
them one by one, you 
can help troubleshoot 
these issues and locate a 
problematic font.

www.unicode.org
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Another font type, called OpenType, has introduced a new era in working 

with fonts, bringing extended functionality and even higher quality to the 

desktop.

What’s Your Type?

We once had a bumper sticker that declared, “Whoever dies with the most fonts wins.”  There’s nothing a 
designer loves more than a unique font that no one else has. At the same time, with so many fonts out there, 
you want to make sure you’re using high-quality fonts. These days, fonts come in several formats:

• PostScript Type 1. Originally developed by Adobe, PostScript Type 1 fonts consist of a printer or outline 
font, a screen or bitmap font, and usually a font metrics fi le (an .afm fi le). Type 1 fonts have been consid-
ered the high-quality standard over the years, although OpenType is changing that.

• TrueType. Originally developed by Apple and Microsoft, the intent of TrueType was to overtake the Type 1 
font standard. A TrueType font consists of a single fi le. TrueType fonts have traditionally been prevalent on 
Windows computers.

• Multiple Master. Originally developed by Adobe, Multiple Master fonts were intended to give the 
designer creative freedom to scale fonts to custom widths and weights. They are actually a fl avor of Type 
1 fonts. Some Multiple Master fonts also allow designers to scale serifs as well. Adobe has since dropped 
development and support for this format.

• OpenType. Originally developed by Adobe and Microsoft, the intent of OpenType is to create a universal 
font format that includes the benefi ts of Type 1 and TrueType font technologies. In fact, an OpenType font 
can contain either Type 1 or TrueType outlines. An OpenType font is Unicode compliant, is cross-platform, 
and consists of a single font fi le.

Introducing OpenType
Although PostScript Type 1 fonts are great, they have some issues and 

limitations that make them diffi cult to use. For one, Type 1 fonts are not 

Unicode compliant. Second, Type 1 fonts are platform dependent, which 

means that if you have the Mac version of a font, you can use that font only 

on a Mac. You need to purchase a Windows version of a Type 1 font to use 

it on a Windows computer. Additionally, a Type 1 font consists of two fi les: 

a screen font and a printer font, both of which you must have to correctly 

print a fi le. If you forget to send either of these fi les to a printer, the fi le 

won’t print. Finally, a Type 1 font is limited to 256 glyphs per font. A glyph

is a specifi c graphical representation of a character. For a given character, 

there may be a default glyph and then alternates. For example, a ligature is 

NOTE At one time, 
Adobe off ered certain 

fonts in “expert” collections; 
these were created because 
the type designer wanted to 
create additional glyphs and 
characters but ran out of 
space. Creating an expert 
version of the font gave the 
designer another 256 glyphs 
to work with.
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a glyph that represents multiple characters. Although the English language 

doesn’t usually require that many glyphs, some languages, such as Chinese, 

Japanese, and Korean, are severely affected by this limitation.

OpenType fonts address all these limitations and offer extended function-

ality. OpenType fonts are Unicode compliant, are platform independent 

(you can use the same font fi le on both Windows and Mac), and consist of 

a single font fi le (both printer and screen fonts are embedded into a single 

fi le). In addition, OpenType can contain more than 65,000 glyphs in a single 

font. With the 256-glyph limit gone, type designers can create fonts with 

extended character sets that include real small caps, fractions, swash charac-

ters, and anything else they dream up.

The good news is that you already have OpenType fonts! Illustrator 

(whether you bought it separately or as part of the Adobe Creative Suite 4 

family) automatically installs more than 100 OpenType fonts on your com-

puter. You can quickly identify OpenType fonts in two ways: a green O icon 

appears to the left of their font names when you’re scrolling through the 

font menu (Figure 8.5), and they end in the letters Std (standard) or Pro.

OpenType Pro fonts contain extended character sets.

NOTE OpenType fonts 
work with applications 

that don’t support OpenType, 
but those applications see 
only the fi rst 256 glyphs in 
that font.

Figure 8.5 The WYSIWYG 
font menu in Illustrator not 
only displays a preview of 
the font but also displays 
icons to identify the font 
type—this is especially help-
ful when you have multiple 
versions of a font. OpenType Font

TrueType Font

PostScript Type 1 Font
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OpenType + Illustrator = Intelligent Fonts

Although the technological benefi ts of OpenType fonts are nice, they are 

just half the story. From a design perspective, OpenType fonts also offer 

superior typographical functionality through something called automatic 

glyph replacement.

To best describe what automatic glyph replacement is, we’ll use ligatures 

as an example. A ligature is a special combination of characters that don’t 

ordinarily look that great when they appear together. For example, common 

ligatures include fi and fl where the lowercase f collides with or overlaps the 

following i or l character. So, type designers create a new glyph, called a 

ligature, which somehow connects the two letters and makes them aestheti-

cally pleasing (Figure 8.6).

The way ligatures are traditionally applied, a designer locates two characters 

that appear together, and if the font has a ligature for that character pair, the 

designer manually deletes the two characters and replaces them with the 

ligature character. Besides the extra time it takes to make this switch, this 

method has two issues. First, a spell checker will fi nd errors when ligatures 

are used, because the spelling checker sees a ligature and not two separate 

letters. Second, if you change the font of your text to a typeface that doesn’t 

have a ligature, you end up with a garbage character where the ligature was.

Automatic glyph replacement is when Illustrator automatically inserts a liga-

ture for you, as you type, when you’re using an OpenType font. Illustrator 

watches as you enter text, and if it fi nds a ligature in the font you are using 

for the characters you type, it automatically swaps the individual characters 

for the ligature. But that isn’t even the cool part. Even though the ligature 

appears on your screen and prints, Illustrator still sees it as two separate 

characters (you can even place your cursor between the two characters). 

That means if you run the spelling checker, you won’t get a spelling error, 

and you won’t run into issues if you change fonts. If the font you switch to 

doesn’t have a ligature, the individual characters are displayed.

Figure 8.6 An f and an i 
character as they appear 
together in a word (left) 
and appearing combined 
as a ligature in the same 
word (right).
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What’s astounding is that if you take into account that each OpenType font 

can contain up to 65,000 glyphs, you’ll realize that this functionality goes 

way beyond simple ligatures. Many OpenType fonts can also automatically 

replace fractions, ordinals, swash characters, real small caps, discretion-

ary ligatures, contextual alternates, and more. Of course, the beauty of this 

functionality is that it happens automatically, so you don’t have to even 

search through a font to fi nd these special characters.

Using the OpenType Panel

Although automatic glyph replacement is nice, giving a computer program 

total control over how your text appears is something that should exist only 

in the movies. In real life, a designer has complete control over a project. 

Choose Window > Type > OpenType to open the OpenType panel where 

you can specify exactly where and how Illustrator replaces glyphs. When 

you select text that is styled with an OpenType font, you can use the eight 

icons at the bottom of the panel to turn on and off the automatic glyph 

replacement for each kind of feature (Figure 8.7). If icons appear dimmed, 

the font you have selected doesn’t contain those kinds of glyphs.

OpenType sets perfect fractions because each typeface can contain all 

10 numbers at normal, numerator, and denominator sizes.

The nice aspect of using the OpenType panel is that you can experiment 

with different type treatments simply by toggling a few of the panel icons. 

You can still use Type 1 and TrueType fonts with Illustrator, of course, and 

you can even mix them within the same document, but the OpenType 

panel works with OpenType fonts only.

Figure 8.7 With text 
selected, clicking the diff er-
ent icons in the OpenType 
panel gives you instant 
feedback about the diff erent 
glyphs available in a particu-
lar OpenType font.

NOTE OpenType 
features can also be 

set within paragraph and 
character styles, which are 
covered later in this chapter.
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Finding Glyphs and Fonts
If you are trying to fi nd a specifi c glyph in a font, it is usually a tiresome 

game of trying to fi nd the right keystroke combination. If you’ve ever run 

your fi ngers across the keyboard, typing every key just to fi nd where the 

square box is in the Zapf Dingbats typeface (it’s the lowercase n, by the 

way), you know what we mean.

The reality is, because a font can have up to 65,000 glyphs, it can be almost 

impossible to fi nd the glyph you need. More to the point, how do you even 

know what glyphs are in a font to begin with? The answer is that you use 

the Glyphs panel.

You can see a graphic representation of all the glyphs in any font installed on 

your computer by opening the Glyphs panel (choose Type > Glyphs).

You can resize the Glyphs panel by dragging from the lower-right corner. 

By clicking the two icons at the bottom-right side of the panel, you can 

make the previews bigger and smaller. You can choose any font (even non-

OpenType ones) from the pop-up menu at the bottom of the panel, and 

you can use the pop-up menu at the top of the panel to show only specifi c 

kinds of characters in a chosen font. If your cursor is in a text object on your 

artboard, double-clicking any icon in the Glyphs panel places that glyph in 

your text. If an icon contains a small black arrow in its lower-right corner, 

that indicates alternative glyphs for that character (Figure 8.8).

Figure 8.8 OpenType 
fonts can contain a variety 
of glyphs for each charac-
ter, including small caps, 
old style, numerator, and 
denominator versions.
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Using the Find Font Dialog Box
Knowing what fonts are used in your document is important when you’re 

sending fi les out for others to use, especially printers. Sometimes it might 

be necessary to switch fonts, either when you want to replace a Type 1 font 

with an OpenType version or when you are missing fonts and want to sub-

stitute them for ones you have installed on your computer.

Choose Type > Find Font to open the Find Font dialog box where you 

can see a list of all fonts used in an open document. An icon at the far right 

of each listing identifi es the type of font. Fonts in this list don’t appear in 

alphabetical order. Rather, they appear according to where they appear fi rst 

in the document’s object stacking order.

The bottom portion of the dialog box allows you to replace fonts with those 

that already exist in the document or with those that are installed on your 

computer (Figure 8.9). You can also use the check boxes to fi lter the kinds 

of fonts you want to see listed. If your system contains many fonts, dese-

lecting some of the options that appear at the bottom of the dialog box will 

limit the results you see in the Find Font dialog box, making it easier to 

make font choices and changes.

Figure 8.9 The Find Font 
dialog box is great for 
replacing fonts, but it’s 
even better for quickly 
seeing all the fonts used 
in a document.
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Earlier in the chapter, we defi ned OpenType, Type 1, and TrueType fonts. 

Here’s a description of the remaining options found in the Find Font dialog 

box:

• Roman. Roman doesn’t mean “not italic,” as in the face. Roman here 

instead refers to the language or character set. Fonts that use alphanu-

meric characters are roman fonts.

• CID. CID fonts are basically the opposite of roman fonts. CID is short 

for Character IDentifi er. CID fonts were developed for Asian markets and 

languages such as Chinese, Japanese, and Korean (what Adobe often 

refers to as CJK). CID fonts are usually several fonts “sewn” together 

because many Asian fonts contain far more than 256 glyphs (the limit 

with PostScript Type 1 fonts). OpenType fonts and something called 

composite fonts (available only when using Asian fonts in Illustrator) have 

replaced much of the need for CID fonts these days.

• Multiple Master. Multiple Master fonts are a special fl avor of Type 1 

PostScript and were originally developed to allow designers to inter-

actively scale fonts on horizontal and vertical axes. This would give a 

great amount of control to designers to customize a font as needed, but 

the need for this kind of control never really materialized. The features 

available in OpenType fonts are far more important to designers. Adobe 

has not made Multiple Master fonts for some time now.

• Standard. Standard fonts are fonts that are installed and used by the 

operating system.

SPECIFYING CHARACTER AND
PARAGRAPH OPTIONS
Just about all the text settings you would expect to fi nd in a page layout 

program are present in Illustrator. You can fi nd these settings in the Control 

panel when you select the Type tool or in the Character and Paragraph pan-

els, both of which you can open by choosing the Window > Type menu.

Using the Character Panel
The Character panel allows you to specify the font family and font style 

(italic, bold, and so on) as well as the settings for type size and leading 

(pronounced ledding, which controls the vertical distance from one baseline 
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to the next). You can also specify kerning, which is the amount of space that 

appears between text characters (see the sidebar “Optical Kerning”), and 

tracking, which is the amount of space that appears between characters over 

a range of text (entire words, paragraphs, and so on).

Horizontal and vertical scaling can make type appear narrower or wider, 

although most designers avoid these settings because they can distort text. 

Use the condensed or extended versions of fonts instead, if they are avail-

able. You can apply the Baseline Shift setting to individual characters and 

use it to adjust where the selected text sits relative to the baseline of the 

type object. The Character Rotation setting allows you to rotate individual 

characters within a text string, although you should be aware that you’ll 

most likely need to perform manual kerning when you use this setting. You 

can specify whether you want selected text underlined or crossed out (the 

strikethrough feature), and you can also choose from the Language pop-up 

menu to tell Illustrator what language the selected text is (Figure 8.10). 

This is helpful for hyphenation and spelling dictionaries (discussed later in 

this chapter).

Figure 8.10 When creating 
multilingual documents, 
choosing a language for 
text tells Illustrator which 
spelling and hyphenation 
dictionaries to use.
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Optical Kerning

Getting just the right kerning is critical when you’re working with logos and headlines; it can often mean the 
diff erence between text that is easy to read and text that is diffi  cult to understand. Kerning is usually set in a 
typeface automatically and described in a metrics fi le that identifi es the amount of space each letter has. Some 
font designers also include kerning pairs, which are letters that have natural white space between them when 
set side by side (the letters V and A are the most commonly used example of this).

Illustrator has a setting in the Kerning fi eld of the Character panel called Optical, which performs kerning auto-
matically. Rather than using metrics tables to defi ne the space between letters, Illustrator looks at the actual 
glyph shapes and kerns the characters as they appear to the eye (Figure 8.11). Using optical kerning has two 
immediate benefi ts.

Figure 8.11 The word on the top is set to Auto kerning and 
is using metrics to determine kerning. Notice the open space 
between the m and the u and how the u almost touches the 
base of the s. The word on the bottom is set to Optical kerning. 
Notice how the letters appear evenly spaced.

First, you can apply optical kerning to any text in your fi le—even body copy or the 4-point legal text that 
appears at the bottom of an advertisement. Although designers spend time kerning logos and headlines, 
it’s too time-consuming to kern all the text in your fi le. With optical kerning, you can kern all the text in your 
document with a single click. You can even specify optical kerning in a character or paragraph style.

Second, kerning applied by hand is good only for the typeface you’ve chosen. Once you change your text to 
use a diff erent typeface, you need to redo the kerning. When using optical kerning, Illustrator automatically 
makes adjustments because it is always using the visual appearance of the text to do the kerning.

Of course, you can always override or make additional adjustments to optically kerned text. Once you’ve speci-
fi ed optical kerning to text, you can kern that text as you would normally. Generally, for well-designed fonts, 
metrics kerning is superior to optical. But optical kerning is very useful for poorly made fonts (almost every 
shareware font, for instance). It’s also handy for specifi c pairs that the type designer might have missed.

In one case, optical kerning can work against you, and that’s when you’re using the underscore character to 
create fi elds when you’re designing forms. With optical kerning turned on, the underscore characters won’t 
touch each other; the result is what appears to be a dashed line. However, you can select the underscore 
characters and change the kerning to the Auto setting to get the appearance of a solid line (Figure 8.12).

Figure 8.12 The top line is set to Auto kerning, and 
the underscore characters appear as one line. The 
bottom line is set to Optical kerning, and the under-
scores appear as a dashed line.
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Using the Paragraph Panel
The Paragraph panel allows you to choose between seven different ways to 

align your text. You can also specify left, right, and fi rst-line indents and add 

space before or after paragraphs. There’s also a check box to enable/disable 

hyphenation for the selected paragraph(s).

Through the Paragraph panel menu, you can also choose to use the Adobe 

Single-line Composer or the Adobe Every-line Composer to determine how 

line breaks are specifi ed in a paragraph of text (see the “Adobe Single-Line 

Composer vs. Adobe Every-Line Composer” sidebar).

Setting Tabs
To create tab settings in Illustrator, select a Path Type or Area Type object, 

and choose Window > Type > Tabs. Clicking the magnet icon at the far 

right of the panel aligns the panel with your selected text. Choose between 

one of the four kinds of tabs (left, center, right, and decimal), and click 

the ruler to add a tab. As you drag a tab on the ruler, a vertical line appears 

onscreen to help you visualize where the tab stop will be (Figure 8.13). You 

can add multiple tabs on a single line (if you can fi nd a page big enough), 

and to delete a tab, you simply drag it off the ruler. Clicking a tab selects 

it, and you can specify an exact coordinate for it if you don’t have a steady 

hand. Additionally, you can specify any character as a leader; doing so fi lls up 

the space between tabs with the specifi ed character.

Figure 8.13 Setting tabs 
in previous versions of 
Illustrator was never fun. 
Now, it’s easy to align tabs 
perfectly.
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Adobe Single-Line Composer vs. Adobe Every-Line Composer

When good designers talk about setting a nice paragraph of text, they refer to the color of the type. In this case, 
they aren’t referring to black, blue, or yellow. Rather, they are talking about how readable the text is, which is 
heavily infl uenced by the spacing that appears between letters and words and by how text is broken from line 
to line. It is especially common to see rivers in justifi ed text, which are areas of white space that seem to con-
nect from line to line so that your eyes see them when you are looking at the paragraph.

Using a technology that fi rst appeared in InDesign, Illustrator off ers two “engines” that you can use to compose 
a paragraph of text. The Adobe Single-line Composer looks at each line as it fl ows text into an Area Type object. 
Based on hyphenation and justifi cation settings, as well as on font and point size, the Single-line Composer 
determines how many words can fi t on each line. It does so by looking at the fi rst line, fl owing the text, then 
moving on to the next line, and so on. Once a line of text has been set, it’s as if Illustrator isn’t even aware of its 
existence. Sometimes, the result is a line that doesn’t fi t right. As a designer, you might look at such a line and 
manually break it diff erently by adding a forced line break somewhere in the paragraph in an attempt to create 
better spacing.

In contrast, the Adobe Every-line Composer looks at the entire paragraph as it fl ows text into an Area Type 
object. As it composes type, Illustrator analyzes the previous lines and sees whether it can get better spacing, 
fewer hyphens, and so on. The result is a paragraph of text (shown on the right in Figure 8.14) that has supe-
rior color and that requires less manual work from the designer.

Figure 8.14 The paragraph 
on the left was set using 
the Single-line Composer, 
and the paragraph on the 
right, which has fewer spac-
ing problems and a more 
even look, was set using the 
Every-line Composer.

Keep in mind that with the Every-line Composer, adding a manual line break might result in text refl owing 
above your cursor, not just after it. This happens because Illustrator is relentless in trying to set the perfect 
paragraph of text; by making a forced line break, you’ve changed the layout of the paragraph. If you are 
manually breaking lines in a paragraph of text, you should consider using the Adobe Single-line Composer.
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DEFINING TEXT STYLES
Sure, there are lots of text settings, and having to constantly choose between 

them can make design work boring and time-consuming. Have no fear, 

though, because paragraph and characters styles can get you back to having 

fun designing in no time. As with page layout applications, you can defi ne a 

style that stores paragraph- and character-based settings that you can apply 

to selected text with the click of a button. In Chapter 9, “Drawing with 

Effi ciency,” you’ll learn how to create graphic styles, which are similar in 

concept.

To defi ne a paragraph or character style, you can use one of two methods. 

The fi rst is what some call the “show me” way, where you style text on your 

artboard in the usual way. Once you have your text styled the way you want, 

you select the text and click the New Style button in either the Paragraph 

Styles or Characters Styles panel. This way is more visual and allows you to 

experiment with ideas before committing to creating a particular style. The 

second way is the “fl ying blind” method, where you create a new style and 

then double-click the style name in the panel to defi ne the settings for that 

style (Figure 8.15). This way is useful when you already have a pretty good 

idea of what settings you want to defi ne in the style.

Everything we’ve discussed in this chapter with regard to styling text can 

be stored as an attribute in a paragraph or character style. Once a style is 

defi ned, you can apply the style to selected text just by clicking the style 

name in the Character Styles or Paragraph Styles panel. To modify a style, 

double-click its name, and when you’ve made changes, any text that has 

that style applied in your document is updated with the changes.

NOTE Some people 
who use page layout 

programs refer to paragraph 
styles as text style sheets.

TIP If a style appears 
with a plus sign after 

its name, the selected text 
contains an override, or a set-
ting that doesn’t match the 
style. Pressing the Option (Alt) 
button while clicking the style 
name clears the override.

Figure 8.15 When fl y-
ing blind, you can quickly 
specify font style settings in 
the Paragraph Style Options 
dialog box.
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WORKING WITH AREA TYPE
Earlier in this chapter, you learned the differences between point type and 

area type (or point text and area text). Because area type has more structure 

than point type, you will fi nd that area type has many features that you 

would expect to fi nd in a page layout application. For example, an Area Type 

object can contain multiple columns of text within a single frame and can 

fl ow text from one frame to another, which is called text threading.

Creating and Editing Text Threads
Text that fl ows across multiple type objects is called a text thread. In previ-

ous versions of Illustrator, this was called linking text boxes and was diffi cult 

to work with. Taking a note from its sister application InDesign, Illustrator 

makes it possible to easily manage text threads.

An Area Type object always displays two boxes on its path, one located at 

the upper left of the object, called the in port, and one located at the lower 

right, referred to as the out port (Figure 8.16). Text fl ows into an Area Type 

object through the in port and exits the object via the out port. The ports 

themselves are also used to control text threads.

Figure 8.16 Every Area 
Type object in Illustrator has 
an in port and an out port.

Out PortIn Port
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To create a new text thread, you must fi rst have an existing text object to 

work with.

1. First, either use the Type tool to drag out an Area Type object or click 

any closed vector path with the Type tool to convert the shape to an 

Area Type object.

2. Switch to the Selection tool, and select the Area Type object.

With the object selected, you’ll see the in and out ports, which will both 

be empty (colored white). An empty in port indicates the beginning of 

the story, and an empty out port indicates the end of a story.

3. Using the Selection tool, click the Area Type object’s out port, and 

you’ll notice your cursor changes to the place text icon.

4. At this point, you can either click an existing closed vector path or click 

and drag an empty area on the artboard to create a second Area Type 

object. The two objects are now linked together.

You can see that the objects are linked because the out port of the fi rst 

object and the in port of the second object are fi lled with a blue arrow. 

A line connects the two ports so that you can easily identify the direc-

tion of a thread when the Area Type objects are selected (Figure 8.17). 

To turn this preview off, choose View > Hide Text Threads.

Figure 8.17 A blue arrow 
and a connecting line help 
identify the direction of a 
text thread.
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You can add as many objects to a text thread as you’d like. To remove an 

object from a text thread, simply select it, and press the Delete key on your 

keyboard. Illustrator automatically updates the thread in the remaining 

objects for you. To add a new Area Type object in the middle of an existing 

thread, you can always click the out port (even though it has a blue arrow in 

it) and drag out a new text object, which will be inserted into the thread.

Because Area Type objects are enclosed areas, a fi nite amount of text can 

fi t within them. Overset text is what happens when you have an Area Type 

object that has more text than it can handle and doesn’t have another text 

object to link to. An object’s out port displays a red plus sign to indicate 

where overset text exists (Figure 8.18). When working with objects that 

contain overset text, you can either edit the text so that there are fewer 

words, enlarge the Area Type object to allow for more text, or create a 

thread and link the object with other text objects.

Transforming Type

When you have the bounding box option turned on (View > Show Bounding Box), you can use the Selection 
tool to resize text objects, but there’s a diff erence between transforming Point Type and Area Type objects in 
this way. When you are working with a Point Type object, the bounding box that appears around the text gives 
the illusion of an Area Type object (without in and out ports). When you use the Selection tool to scale the 
Point Type object by dragging any of the eight handles, the text scales in size as well. If you hold the Shift key 
while scaling, the text will scale in proportion.

In contrast, when you select an Area Type object with the Selection tool, you can click and drag any of the 
eight handles to resize the text frame, but the text that resides inside the Area Type object will not be scaled. 
Of course, you can always use the Scale tool to apply the transform to the text as well.

TIP You can also 
extend a text thread 

from the beginning of a story 
by clicking the empty in port 
and then drawing a new Area 
Type object.

Figure 8.18 A production 
artist never wants to see 
one of these. The plus sign 
in the out port indicates that 
there is overset text, and it 
could mean text refl ow has 
occurred.

Overset Text
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Setting Area Type Options
One of the benefi ts of working with area type is that you can easily defi ne 

the area in which the text will be contained. You can also specify many dif-

ferent settings as to how text will fi ll this defi ned area, which you can access 

by selecting an Area Type object and choosing Type > Area Type Options.

In the Area Type Options dialog box, you can adjust the overall width and 

height of the Area Type object, as well as specify both rows and columns. 

The Gutter value determines the amount of space that appears between each 

row or column. The Inset Spacing setting determines the amount of space that 

appears between the border of the actual Area Type object and where the 

text begins. You can think of it like margins that are specifi c to this Area 

Type object. You can also choose from a variety of settings to determine 

where the fi rst baseline is calculated. By specifying a text fl ow, you can also 

control whether text fl ows from column to column or from row to row. 

Click the Preview button so that you can preview the changes you make 

before you apply them.

Achieving Perfect Alignment
As designers, we are extremely particular about the appearance of the art 

we create. Setting type can present a designer with a variety of challenges 

because each character of each font is different. Even though a column of 

text is set to be justifi ed, that doesn’t mean that, from a visual perspective, 

it will appear so. Punctuation and special characters can present optical 

illusions and make text appear as though it is set incorrectly, even though 

mathematically it is set correctly. Because of these issues, a designer might 

struggle to align text so that punctuation marks sit just outside the actual 

margin of text to ensure a clear line that the human eye can follow.

However, this sort of struggling is no longer necessary because Illustrator 

has two features that take care of these optical issues. With an Area Type 

object selected, you can choose Type > Optical Margin Alignment to have 

Illustrator make sure that margins on both sides of an Area Type object 

are visually straight from a design perspective (not a mathematical one). 

Additionally, you can select an Area Type object and choose Window > 

Type > Paragraph to open the Paragraph panel. Then, choose Roman 

Hanging Punctuation from the Paragraph panel menu to force all 
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punctuation marks such as commas, periods, and quote marks to appear out-

side the margin of the text at the beginning and end of a line (Figure 8.19).

PUTTING TYPE ON A PATH
Having text follow along a path is nothing new to Illustrator users. How-

ever, if you’ve used Illustrator before, you’ll fi nd that since Illustrator CS, 

type on a path is implemented quite differently than in previous versions—

to the point where it might even seem like a new feature.

To make it easier to learn how to use this feature, you will start by creating 

type on an open path. After you’ve done this, you will understand how to 

perform the same function on a closed path (a closed path is continuous).

1. Using your tool of choice, create an open path, or you can select an 

open path that already exists on your artboard.

2. Choose the Type tool, and move your cursor so that it touches the path 

and changes to the Type on a Path tool icon, with a line through the 

icon.

3. Click the path to create a Type on a Path object.

This action removes any strokes from the path, but you can apply them 

to the path again later if you want. At this point, you’ll see the blinking 

text insertion cursor, and you can enter or copy text onto the path.

4. Now switch to the Selection tool, and select the path with the text on 

it (you can click either the path or the text).

Figure 8.19 The Roman 
Hanging Punctuation 
setting makes creating 
great-looking text almost 
too easy.

NOTE Everything 
you’re learning about 

type on a path here can be 
applied to InDesign as well, 
because the functionality is 
identical to Illustrator.
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As you look at the selection, you’ll notice a vertical line with a small 

white box on the left, a line at the center, and a small white box and a 

line on the far right (Figure 8.20).

The small boxes should look familiar to you—they are in and out ports. 

The ports are there because Illustrator treats type on a path like area type. 

The two vertical lines that appear on either end defi ne the boundary, or the 

start and end points, of the text. The line in the center determines the cen-

ter point between the start and end points and allows you to specify which 

side of the path the text sits on.

You can use the in and out ports to thread text across multiple Path Type 

objects, and you can even create a thread of text that includes both Path Type 

and Area Type objects (très cool). By dragging the start and end points, you 

can defi ne the area of the path that can contain text. For example, you can 

have a long path but have text appear on just a small portion of that path 

(Figure 8.21). If you think about it, adjusting the start and end points on 

a Path Type object is akin to adjusting the width of an Area Type object. 

You can also drag the middle line to either side of the path to fl ip the text.

Figure 8.20 A Path Type 
object is similar to an Area 
Type object in many ways.

Figure 8.21 By moving the 
position of the start and end 
points, you can control the 
portion of the path that can 
contain text.

In Port

Start Point Center Point End Point

Out Port
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Working with Path Type with Closed Paths
Now that you understand how path type works, you’re ready to learn how 

to work with path type on a closed path. When you convert a path to a Path 

Type object, the point at which you click the path becomes the start point. 

On an open path, you can easily see the start and end points because they 

are on opposite sides of the path. However, when you are working with a 

closed path, the point you click becomes the start point and the end point.

If, for example, you want to place text on a circle, click the top of the circle 

to create the start point and the end point; if you center your text, it actu-

ally aligns to the bottom of the path (Figure 8.22). To get text to align to 

the top center of a circle, either click at the bottom of the circle when you’re 

creating the Path Type object or adjust the start and end points so that the 

center of the text rests at the top of the circle (Figure 8.23).

Setting Path Text Options
Positioning text on a path—especially a curved path—can be diffi cult 

because the spacing can look irregular. However, you can adjust the 

spacing and other settings by selecting the Path Type object and 

TIP To convert a 
closed path to a Path 

Type object, you have to hold 
the Option (Alt) key while 
clicking the path with the 
Type tool. Or you can simply 
use the Type on a Path tool.

Figure 8.22 At fi rst placing text on a 
circle seems nonintuitive—clicking at 
the top of a circle centers your text at 
the bottom of the circle.

Figure 8.23 Changing the position of the 
start and end points can make it easier to 
center text at the top curve of a circle.



CHAPTER 8: WORKING WITH TYPOGRAPHY274

choosing Type > Type on a Path > Type on a Path Options. The following 

settings are available in the Type on a Path Options dialog box:

• Effect. The Effect setting controls the orientation of the text relative 

to the path. Prior to Illustrator CS, all Type on a Path objects used the 

Rainbow setting, which rotated each character to be tangent to the path. 

Illustrator now allows you to also choose from Skew, 3D Ribbon, Stair 

Step, and Gravity (Figure 8.24).

• Align to Path. The Align to Path setting determines which part of the 

text actually lines up with and touches the path. You can choose from 

Baseline (the default), Ascender, Descender, and Center (Figure 8.25).

Figure 8.24 Listed here are 
the fi ve eff ect settings you 
can use with path type.

Figure 8.25 Listed here are 
the four align settings you 
can use with path type.

Baseline

Center

Ascender

Descender

Rainbow

Skew

3D Ribbon

Stair Step

Gravity
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• Spacing. You can use the Spacing setting to help get consistent spacing 

between characters on curved paths (the setting doesn’t do much on 

straight paths). Where paths make sharp curves, the spacing between 

characters could appear at odd angles or with inconsistent spacing. 

Specifying a higher spacing value brings characters closer to each other 

and corrects the spacing issues.

• Flip. The Flip setting allows you to control the side of the path on 

which the text appears.

If you want to apply an appearance to the path itself on a Path Type object, 

click just the path with the Direct Selection tool (it might be easier to do 

this while you are in the Outline view mode). You can then apply attributes 

to the path as you would normally. To offset text from the path itself, use 

the Baseline Shift setting; however, if you’re working with wavy or curved 

paths, using one of the Align to Path settings offers better results because it 

takes advantage of the Spacing setting.

WRAPPING TEXT AROUND OBJECTS
Graphic layouts sometimes call for text wrapping around the perimeter of 

other objects. Because the wrap is an attribute of the object, not the text, 

you’ll fi nd the Text Wrap option listed in the Object menu. You can specify 

text wraps for individual objects or for groups. Similar to what you learned 

about groups in Chapter 5, “Organizing Your Drawing,” applying a text 

wrap to an entire group allows you to specify one text wrap setting for the 

entire group. Choosing several objects and then applying a text wrap simply 

applies an individual text wrap to each selected object. Once you’ve made a 

selection, choose Object > Text Wrap > Make.

Unlike layout applications such as InDesign, the text wrap functionality 

in Illustrator doesn’t allow you to edit the text wrap in the form of a path. 

You can specify only the offset value, which you can access by selecting 

the object with the wrap and choosing Object > Text Wrap > Text Wrap 

Options.

A text wrap’s boundary is defi ned by the object’s appearance, not its vector 

path. If you have live effects applied to an object, a text wrap that is applied 

to that object will follow the appearance.

TIP Older versions of 
Illustrator required 

that you apply a text wrap by 
selecting both the text and 
the object. Doing this in 
Illustrator now creates a wrap 
around both the text and the 
object, so make sure you 
have just the object selected.
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Once a text wrap has been applied to an object, any area text that appears 

below it in the stacking order will wrap around the object (Figure 8.26). 

Point type is not affected at all by text wraps. To remove a text wrap, 

select an object that has an existing text wrap already applied, and choose 

Object > Text Wrap > Release.

EDITING TEXT
There’s a saying that goes “The written word is forever,” but obviously that 

saying was meant to be applied after the client had already reviewed the job. 

As a designer, making text edits is a part of life. Illustrator does have several 

features that make an author’s alterations (AAs) a bit easier to digest, includ-

ing a powerful fi nd-and-replace function and a spectacular spelling checker.

Using Find and Replace
Illustrator may be a single-page-per-document application, but a fi nd-and-

replace feature can still be helpful when you’re making specifi c edits across 

large amounts of text. Choose Edit > Find and Replace to search across all 

text within a single Illustrator document. The arrows at the end of both the 

Find and Replace With fi elds allow you to specify special characters includ-

ing tab characters and nonbreaking hyphens (Figure 8.27).

Figure 8.26 Illustrator 
off ers a simple text wrap 
feature. For more sophisti-
cated text wraps, InDesign 
is a good alternative.
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Displaying Invisible Characters
When performing text edits, it can be helpful to identify where nonvisible 

characters appear. You can make spaces, tabs, soft and hard returns, and 

end-of-story markers visible by choosing Type > Show Hidden Characters. 

When visible, these characters display in blue icons.

Checking Spelling
We’re sure that you’ve never sent a job off for printing or uploaded a web 

page with a typo in it. But just in case, it never hurts to learn how to check 

your spelling, especially since the spelling checker in Illustrator is quite the 

linguist—it speaks many languages.

You can specify what language a selected string of text is by choosing from 

the pop-up menu that appears at the bottom of the Character panel. You 

can also specify the language within a character or a paragraph style sheet. 

When the spelling checker encounters text that is specifi ed as Spanish, it 

uses its Spanish dictionary to check the spelling, and it does the same for 

any other language that you’ve specifi ed.

To run the spelling checker, choose Edit > Check Spelling, and click the 

Start button. Illustrator starts suggesting corrections for misspelled words; 

Figure 8.27 You don’t have 
to remember special codes 
to fi nd special characters. 
Illustrator provides you with 
a list of common characters 
for search-and-replace 
functions.
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you can also choose to ignore them or add a word to the dictionary in 

Illustrator (Figure 8.28).

WORKING WITH LEGACY TEXT AND
BACKWARD COMPATIBILITY
After reading this chapter, you’ll probably agree it’s obvious that the text 

features that appear in the next-generation text engine in Illustrator are 

powerful tools that bring a professional level of typography into the hands 

of users such as yourself. Beyond that, the advanced technology that enables 

Unicode and OpenType support and features such as optical kerning means 

you can rely on consistent type today and in the future.

All this functionality comes at a price, though, when you consider backward 

compatibility with versions of Illustrator that use the older text engine. At 

the end of the day, the text engine that appeared in Illustrator CS wasn’t just 

an enhancement—it was a new feature.

When you have a particular feature in a new version—say symbols in 

Illustrator 10—you can use this feature in that version, but you can’t export 

that fi le to an older version and expect to edit it, right? For example, you 

Figure 8.28 The spelling 
checker in Illustrator can 
prove to be helpful, even for 
documents that contain a 
small amount of text.
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can’t create a symbol in Illustrator 10, save the fi le as an Illustrator 8 fi le, 

open it in Illustrator 8, and expect to edit the symbol. This is because the 

symbol feature doesn’t exist in version 8. The visual appearance is correct, 

but the art isn’t editable as a symbol anymore.

Because of the huge advancement in technology of the text engine intro-

duced in Illustrator CS, text isn’t compatible with versions of Illustrator 

before Illustrator CS. You can think of this as a line drawn in the sand, 

with Illustrator CS4, CS3, CS2, and CS on one side and all older versions 

(Adobe calls these legacy versions) on the other.

Opening Legacy Illustrator Files in 
Illustrator CS4
Let’s take a common design scenario. You launch Illustrator CS4 and open 

a fi le that contains text that was created in a legacy version of Illustrator 

(say Illustrator 10). When you open the fi le, you’re presented with a warning 

dialog box that states the following: “This fi le contains text that was created 

in a previous version of Illustrator. This legacy text must be updated before 

you can edit it.” The dialog box presents you with three options:

• Update. Clicking the Update button converts all the legacy text in your 

fi le so it is compatible with the new text engine. This process may result 

in some of your text refl owing and displaying different line breaks and 

kerning. However, sometimes no refl ow occurs at all. Because this hap-

pens as you open the fi le, you won’t see the refl ow or kerning changes 

happen if they do, so if text placement is critical, you should avoid click-

ing this button (you’ll see how you can update the text manually later). 

The only time it makes sense to click Update is when you know you 

will be changing or deleting the text anyway.

• Cancel. In essence, clicking Cancel is like saying, “I always wanted to 

be a welder anyway.” Cancel simply closes the fi le, and Illustrator for-

gets this little incident ever happened.

• OK. If you click OK, the fi le opens, and none of the legacy text is 

affected at all—the fi le opens just as it did in Illustrator 10. The catch 

is, you can’t edit the legacy text, which appears in the document much 

like a placed fi le—in a box with an x through it. You can print the fi le 

perfectly and make edits to other art in the fi le, but Illustrator treats the 
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text as a foreign object, which cannot be edited. However, you can convert 

individual legacy text objects to the new text engine as you need to, as 

you will soon learn.

Basically, if you are opening a fi le where you know you will be changing or 

deleting the text, clicking Update is the best way to go because you don’t 

care whether the text refl ows. If, however, you just want to open a fi le so 

that you can print it or if text placement is important (which it usually is), 

clicking the OK button is the smart choice.

Updating Legacy Text in an Open Document
If you choose to open a legacy Illustrator fi le by clicking OK, the fi le opens, 

but each text object is not editable until you convert it to the new text engine 

(Figure 8.29). You can do so on an object-by-object basis by selecting the 

Type tool and clicking a legacy text object, at which time Illustrator presents 

you with another dialog box that offers three options (Figure 8.30):

• Copy Text Object. Clicking the Copy Text Object button converts 

the legacy type to the new text engine, and therefore the text is edit-

able. Some refl ow may occur in the conversion, but Illustrator creates a 

copy of the legacy text on a locked and dimmed layer beneath the new 

converted text. If the new text does actually refl ow, you can see the dif-

ference between the new text and old text, which is on the layer beneath 

it. You can then adjust the new text to perfectly match the legacy text.

• Cancel. Clicking Cancel leaves the legacy text as a foreign object—

it can be printed but not edited.

• Update. Clicking Update converts the text to the new text engine so 

that you can edit it. However, a copy of the legacy text is not created, 

so if the text does refl ow, you might not be able to tell.

Figure 8.29 A legacy text 
object is not editable, and it 
appears much like an image 
does.
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For converting tag lines, logotype, and other sensitive type treatments, 

clicking the Copy Text Object button is obviously the best. However, if 

you have a lot of text objects to convert, it can take a long time to ensure 

that all the text matches the legacy document (although depending on the 

task, you might not have a choice). The Update option can be useful if you 

want to make an edit to just a few lines of text and the refl ow there won’t 

make a difference anyway.

You may fi nd that when you’re updating text, no signifi cant refl ow occurs. 

If, after updating several text objects, you decide to convert all the legacy 

text at once, you can choose Type > Legacy Text > Update All Legacy 

Text. Additionally, you can select several legacy text objects on your art-

board and choose Type > Legacy Text > Update Selected Legacy Text. 

Both of these options perform the same function as clicking the Update 

button, but they apply to multiple legacy text objects at once.

If you do click the Copy Text Object button so that you can see whether 

there is text refl ow, remember that the copy of the legacy text that was 

created will still print. Once you have matched the new text to the legacy 

text, you must delete the legacy text copy either by removing it manually 

from the Layers panel or by choosing Type > Legacy Text > Delete Copies.

In Illustrator CS4, there is a new Type on a Path text engine. If you want 

to edit type on a path that was created in Illustrator CS, CS2, or CS3, you 

need to choose Type > Type on a Path > Update Legacy Type on a Path. 

If you click Update when opening legacy fi les with type on a path, that 

type will automatically be updated to the Illustrator CS4 text engine. If 

you didn’t click Update upon opening the legacy fi le, you can, of course, 

choose the Update Legacy Type on a Path command at any point prior to 

your editing.

Figure 8.30 Trying to edit 
legacy text with the Type 
tool results in another 
dialog box.

TIP When opening 
fi les that were created 

in previous versions of 
Illustrator (what Illustrator 
refers to as legacy fi les), you 
might have to adjust text 
objects. To prevent you from 
accidentally overwriting your 
original fi les, Illustrator tacks 
on “converted” to your fi le 
name when it opens legacy 
fi les. You can disable this 
behavior in the General panel 
of Preferences, although we 
don’t suggest it.
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Saving Illustrator CS4 Files to Illustrator 
Legacy Versions
It’s said that sticking your hand into a thorn bush isn’t painful because the 

thorns are shaped facing in toward the center of the bush. It’s pulling your 

hand out of the thorn bush that causes the wound. With Illustrator, moving 

text from legacy versions to the CS versions is a straightforward transition. 

However, trying to move text from the CS versions of Illustrator so that it is 

compatible with legacy versions can be painful.

Based on a preference in your Document Setup dialog box, either the text 

is broken up into individual Point Type objects (the default setting) or 

the text is converted to outlines. You can change this setting by choosing 

File > Document Setup and in the Type Options area choosing Preserve 

Text Editability or Preserve Text Appearance in the Export pop-up menu. 

In Chapter 14, “Saving and Exporting Files,” you will learn how to create 

fi les that are compatible with legacy versions of Illustrator.

Basically, you can’t do much to avoid this issue. Some scripts (such as 

Rick Johnson’s excellent Concat Text script, which you can fi nd at http://

rj-graffi x.com/software/scripts.html) allow you to select broken-up text and 

combine it into a single string of editable text. Although these scripts will 

help, they certainly aren’t a solution. If you’re creating a fi le that must have 

editable text that you can use in a legacy version of Illustrator, you might 

consider creating your fi le in Illustrator CS4 but saving it in Illustrator 10 

format and adding the text using version 10.

NOTE Type on a path 
created in Illustrator 

CS4 with the new type on a 
path text engine and saved in 
Illustrator CS, CS2, or CS3 may 
cause the appearance and 
positioning of the text to not 
be preserved, because the 
type will be rendered with the 
engines for those particular 
older versions.

http://rj-graffix.com/software/scripts.html
http://rj-graffix.com/software/scripts.html


Chapter 
NineDrawing with Effi  ciency

Take a moment to think about the true strength of 

what a computer offers a designer. Is it fancy draw-

ing tools? Is it cool special effects? Is it the speed at 

which you can create art? Maybe. But that’s all on 

the surface. In truth, you may fi nd that a designer 

can draw something with a pencil and paper in half 

the time it would take to draw it using a computer. 

The real benefi t of using a computer to designers is 

that once they have created a design on a computer, they can edit it at will. 

When you’re working with a deadline, it’s far easier to make a small edit to 

a fi le than to have to redraw the whole design from scratch.

As you build fi les in Adobe Illustrator CS4, you’ll fi nd you can accomplish 

a particular task in several ways. Your job is to fi nd the most effi cient way 

to create the art you need, which doesn’t necessarily always mean the fastest 

way. You might be able to create two identical Illustrator fi les: in one, the 

fi le is huge, takes a long time to print, and is diffi cult to edit or update; the 

other is created using different features or techniques and results in a leaner, 

cleaner, and more editable fi le.

You already know about groups, layers, and live effects—all of which you 

can use to build more effi cient objects. In this chapter, you’ll learn to take 

advantage of other features such as symbols, graphic styles, and masks. In 

addition, you’ll learn some automation techniques that can mean the dif-

ference between being home in time for dinner with the family and pulling 

another all-nighter at the offi ce when that deadline looms.

The artwork featured throughout this chapter comes from Jennifer Borton 

(iStockphoto; username: bortonia).
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SAVING SPACE AND TIME
WITH SYMBOLS
Sometimes, a project calls for a range of repeating design elements. For 

example, when creating a map of a park, you might use icons to indicate 

restrooms or picnic areas. And when designing an item of clothing, you 

might draw the same button in several places. Illustrator has a feature 

called symbols that was created specifi cally to manage repeating graphics 

in a document.

You can think of a symbol as a master art item, which is defi ned once per 

Illustrator document. Once you’ve created a symbol, you can place mul-

tiple instances of it within a document. Each instance is simply an alias, or a 

placeholder, that points to the original defi ned symbol. Using symbols in a 

document offers several benefi ts. First, if you edit or modify a symbol, all 

instances of that symbol are automatically updated as well. Second, because 

Illustrator stores only a single copy of a symbol per document, you can take 

advantage of smaller fi le sizes. Smaller fi le sizes translate to faster open and 

save times, faster print times, and faster server transfer times.

Designers who create certain kinds of web graphics can also take advantage 

of using symbols. In Chapter 13, “Web and Mobile Design,” we’ll discuss 

how you can use symbols to generate smaller fi le sizes when creating SWF 

(Flash) fi les.

Working with Symbols and Instances
Defi ning a symbol is quick and easy. Select any artwork on your artboard, 

and drag it to the Symbols panel. Even faster, select your artwork, and press 

the F8 key. The Symbol Options dialog box appears, giving you the oppor-

tunity to name the symbol (Figure 9.1). Ignore all the other settings in the 

Symbol Options dialog box, because they apply only to those symbols that 

will eventually be brought into Adobe Flash CS4 Professional (we cover 

these Flash-specifi c settings in detail in Chapter 13).

TIP Before you start a 
new fi le or project, take 

a few moments to think 
about the art you will use and 
how you plan on creating the 
fi le. Taking a few minutes to 
plan allows you to understand 
the kinds of features you 
need to use, and this plan-
ning can save you a signifi -
cant amount of time should 
you need to make changes to 
the fi le later.
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Unlike with brushes, which are limited in the kinds of artwork they can 

contain, you can use any kind of artwork to defi ne a symbol with the 

exception of place-linked images (for more information on linked images, 

see Chapter 12, “Working with Images”). Embedded images, objects with 

live effects applied, and even editable text can be stored inside a symbol 

in Illustrator. Once you’ve defi ned a symbol, your artwork is stored in the 

Symbols panel, and a symbol instance is placed on your artboard in its stead. 

Like brushes, symbols belong to the Illustrator document and travel with 

it, meaning anyone who opens your document will always see the symbols 

listed in the Symbols panel. Copying an instance from one document to 

another automatically copies the symbol as well.

You can drag additional instances from the Symbols panel to your artboard, 

or you can select a symbol in the panel and click the Place Symbol Instance 

button to add an instance to the center of your screen (Figure 9.2). Once 

it’s on the artboard, you’ll notice that a symbol instance doesn’t give you 

access to the actual artwork because it is simply a placeholder (Figure 9.3 
on the next page). However, you can use any of the transformation tools and 

functions in Illustrator with symbol instances. For example, you can scale or 

rotate a symbol instance as necessary. Additionally, you can specify transpar-

ency features and even apply live effects to symbol instances. You can place 

as many symbol instances in a document as you desire, and you can scale or 

transform each instance differently.

Figure 9.1 The Symbol 
Options dialog box gives 
you the ability to name 
your symbol as you create 
it, making it easier to refer-
ence later.

TIP Although you can’t 
include linked images 

in a symbol, you can include 
embedded images. Because 
you can use symbols many 
times in a document with no 
adverse eff ect on fi le size, it 
makes sense to think about 
creating symbols from an 
embedded image if you need 
to use them often in a fi le.

Figure 9.2 You can use the 
Place Symbol Instance but-
ton to place symbols in the 
center of your screen.



CHAPTER 9: DRAWING WITH EFFICIENCY286

At any time, you can select a symbol instance on the artboard and click the 

Break Link button in the Control panel. Alternatively, you can click the 

Break Link to Symbol button in the Symbols panel. This action expands

the symbol instance on the artboard, allowing you to access and edit the 

individual components (Figure 9.4). However, the artwork is no longer 

an instance, and it loses any connection with the symbol that is defi ned in 

the Symbols panel. The symbol itself remains untouched, and any other 

instances that exist on your artboard still reference the original symbol.

Figure 9.3 Even though 
a symbol may consist of 
many individual objects, it is 
treated as a single object on 
the artboard.

Figure 9.4 Once you break 
the link between the symbol 
and a particular instance of 
it, you can edit the artwork 
freely, although the art no 
longer has any association 
with the symbol.
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Replacing Symbols

If you think about it, a symbol instance is really just a container that references 

real artwork that resides in the Symbols panel. With this fundamental under-

standing, it should be possible to take a symbol instance that references one 

symbol and change it so it references a different symbol that you’ve defi ned. 

In Illustrator, the ability to switch an instance to point to a different symbol 

is called replacing symbols.

To replace a symbol instance, select it on the artboard, and then choose 

another symbol from the Replace Instance with Symbol pop-up menu in 

the Control panel. Alternatively, you can select the symbol instance on the 

artboard and click the symbol in the Symbols panel that you want to replace 

it with. With both the symbol instance on your artboard and the new 

symbol in the Symbols panel selected, choose Replace Symbol from the 

Symbols panel menu. The selected symbol instance updates accordingly. 

When replacing symbol instances, any transformations or effects you’ve 

applied to any individual instances will remain intact.

Modifying Symbols and Instances

Before you modify a symbol, it’s important to understand a key concept: 

editing a symbol causes any instances of that symbol that appear in your 

document to update. The easiest way to edit a symbol is to simply double-

click it, which isolates the symbol (just as with isolation mode as you 

learned in Chapter 5, “Organizing Your Drawing”). Alternatively, you can 

double-click any symbol icon in the Symbols panel. You’ll experience a dif-

ferent behavior depending on whether you double-click a symbol instance 

on the artboard or a symbol in the Symbols panel. Let’s take a look at the 

difference:

• Double-clicking a symbol instance on the artboard. When you 

double-click a symbol instance on the artboard, Illustrator dims all 

other artwork in your fi le, and you can edit your symbol in the context 

of your entire document (Figure 9.5 on the next page).

• Double-clicking a symbol in the Symbols panel. When you double-

click a symbol in the Symbols panel, Illustrator hides all other artwork 

in your fi le and displays just the symbol artwork, in the middle of your 

document window (Figure 9.6, also on the next page).
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When a symbol is redefi ned, all instances on the artboard that reference the 

symbol are updated to refl ect the change. Any attributes or transformations 

that were applied to the instances are preserved.

Figure 9.5 Double-clicking 
a symbol instance on the 
artboard tells Illustrator you 
want to edit your symbol art 
in the context of the other 
art on your page. As you 
edit your symbol, you’ll see 
the other art in the back-
ground.

Figure 9.6 Double-clicking 
a symbol in the Symbols 
panel tells Illustrator you 
want to edit the symbol 
without anything else 
getting in the way. All other 
art disappears, allowing you 
to focus just on the symbol 
artwork.
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Using Symbols in Different Ways

When you take a moment to think about your project before you start work-

ing on it, you might be able to determine whether using symbols will benefi t 

you. Here are several ways symbols can help build better fi les:

• Although Illustrator doesn’t use master pages, symbols can act like 

miniature “master art elements” in a fi le. For example, when creating 

several different ideas for a packaging concept, use symbols as the base 

for each design (that is, ingredients, nutrition information, weight, and 

so on). Updating a symbol then instantly updates all the designs in the 

fi le at once.

• Create symbol libraries to store commonly used logos and icons. 

(You learned how to create custom libraries in Chapter 6, “Coloring 

Artwork.”)

• Create symbol libraries to store collections of fashion elements, such 

as buttons, zippers, or labels, or to store other specifi c art elements, 

such as architectural elements or cartography symbols.

• Using symbols is required in order to perform certain features in 

Illustrator, including mapping artwork onto the surfaces of 3D objects. 

Chapter 11, “Exploring the World of 3D,” covers this functionality.

Of course, you can use symbols in Illustrator in plenty of other ways. The 

next section deals with some special tools created specifi cally for working 

with symbols: the Symbolism tools.

Having Fun with the Symbolism Tools
So, you’ve been reading along and totally get the benefi ts of using symbols 

where possible to create more effi cient fi les. Say, for example, you are going 

to create an illustration of a plate of sumptuous salad (true, an oxymoron). 

You create some symbols of toppings, including onions, cheese, croutons, 

and maybe some pepper and a lemon wedge (Figure 9.7 on the next page). 

One by one, you drag out symbol instances and scale and rotate each 

topping to achieve a more natural look (Figure 9.8, also on the next page). 

As you drag out yet another symbol instance, you think, “There’s got to be 

a better way to do this!” The good news is, there is. The great news is, the 

better way is extremely fun!

NOTE You can nest 
symbols, meaning 

you can place one symbol 
inside another symbol. To 
edit nested symbols, keep 
double-clicking each symbol 
to drill down further within 
the symbol.
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In the Tools panel, you’ll fi nd the Symbol Sprayer tool. Hidden beneath it, 

you’ll fi nd seven more tools; together, these tools are referred to as the 

Symbolism tools (Figure 9.9). The reason for the name is that these tools 

all work using symbols, and not by any coincidence, the tools all begin with 

the letter s. (See? Adobe actually does pay attention to detail.)

Figure 9.7 With all your 
salad toppings defi ned as 
symbols, you’re ready to 
start garnishing.

Figure 9.8 Dragging and 
positioning individual 
symbol instances can be 
tedious.
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Creating a Symbol Set

The Symbol Sprayer tool lets you easily add multiple symbol instances to a 

document. Select the Symbol Sprayer tool from the Tools panel, and then 

click any symbol in the Symbols panel. Because the Symbol Sprayer tool 

works only with symbols, it’s important to fi rst select a symbol to work 

with—otherwise the Symbol Sprayer won’t work. Click and drag on the 

artboard, and you’ll begin to see the Symbol Sprayer adding symbols to your 

page (Figure 9.10). When you release the mouse button, a single outline 

appears around the perimeter of the symbols. What you have created is a 

symbol set, which is a collection of symbol instances (Figure 9.11 on the next 

page). If you switch to the Selection tool, you’ll fi nd you can’t select the indi-

vidual symbol instances, but you can move the entire symbol set as a whole.

Figure 9.9 The Symbolism 
tools all appear grouped 
in the Tools panel with the 
Symbol Sprayer tool.

Figure 9.10 As you click 
and drag with the Symbol 
Sprayer tool, instances 
appear to fl ow onto your 
artboard.
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Although it may seem silly that you can’t select individual instances within 

a symbol set, that notion quickly changes when you realize that the Symbol 

Sprayer tool is interactive. Select the symbol set, and switch back to the 

Symbol Sprayer tool. If you click and drag, the Symbol Sprayer tool adds 

more symbol instances to the set. If you press the Option (Alt) key while 

dragging, you remove symbols from the set. In addition, the Symbol Sprayer 

tool has support for pressure-sensitive tablets, so the harder you press, the 

faster the instances appear.

It’s certainly fun to spray symbols all over your document, but you can con-

trol the individual symbols that appear inside a symbol set. To do this, you 

need to employ the Symbolism tools.

Using the Specialized Symbolism Tools

Once you’ve created a symbol set with the Symbol Sprayer tool, you can 

switch to any of the other Symbolism tools to adjust the symbols within the 

set. It’s important to realize that symbol sets are intended to create a natural 

collection of symbol instances. You’ll fi nd that you can’t position symbol 

instances precisely with the Symbolism tools. On the contrary, the Symbol-

ism tools are meant to offer Illustrator users a more free-fl owing style, and 

it almost feels as if you are suggesting a particular movement or behavior to 

symbol instances rather than performing a defi nitive action on them. As you 

Figure 9.11 Once you 
release the mouse button, 
the symbol instances 
appear united in a single 
symbol set.

TIP You can add 
diff erent symbols to 

the same symbol set. Once 
you’ve created a symbol set 
using one symbol, choose 
another symbol from the 
Symbols panel, and add more 
symbols to your symbol set. 
You can add as many diff erent 
kinds of symbols as you want 
to a symbol set.
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try each of these tools, you’ll get a better feel for how they function and for 

how you might be able to use them for your projects.

For each of these tools, you’ll notice that a circle appears, which indicates 

the diameter of the tool’s area of infl uence (Figure 9.12). You can make this 

area larger or smaller by pressing the bracket keys ([ ]) on your keyboard 

(similar to the Photoshop keyboard shortcut for changing brush size).

• Symbol Shifter tool. The Symbol Shifter tool moves symbol instances 

around. Clicking and dragging this tool pushes symbols in the direc-

tion of your pointer. If you hold the Shift key while dragging, Illustrator 

brings the symbol instances from the back of the symbol set’s stacking 

order to the front.

• Symbol Scruncher tool. The Symbol Scruncher tool moves symbol 

instances closer together, making the appearance more dense. Click-

ing and dragging with the Symbol Scruncher tool causes instances to 

become attracted to your pointer and to slowly gravitate toward it. If 

you hold the Option (Alt) key while dragging, the reverse effect applies, 

and instances move farther away from your pointer.

• Symbol Sizer tool. The Symbol Sizer tool scales symbol instances 

within a symbol set. Clicking and dragging with the Symbol Sizer tool 

causes instances to become larger. If you hold the Option (Alt) key 

Figure 9.12 You can resize 
the circle area, which indi-
cates the tool’s area of 
infl uence, to be bigger or 
smaller.

TIP Although the 
Symbolism tools aren’t 

meant to work on just one 
symbol instance at a time, you 
can make your area of infl u-
ence small enough that you 
can aff ect a much smaller area 
or even individual symbols.
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while dragging, the reverse effect applies, and instances become smaller 

(Figure 9.13).

• Symbol Spinner tool. The Symbol Spinner tool rotates symbol 

instances. Clicking and dragging with the Symbol Spinner tool causes 

instances to rotate toward the direction of your pointer. As you drag, 

arrows appear that indicate the direction in which the instances will 

rotate (Figure 9.14). Instances that appear closer to the center of the 

area of infl uence rotate at a lesser rate than objects toward the edges 

of the area of infl uence.

Figure 9.13 The Symbol 
Sizer tool allows you to 
interactively scale the 
symbol instances within 
a symbol set.

Figure 9.14 When dragging 
with the Symbol Spinner 
tool, arrows appear, helping 
you get an idea of how the 
instances will rotate.
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• Symbol Stainer tool. The Symbol Stainer tool applies color tints to 

symbol instances (Figure 9.15). To use the Symbol Stainer tool, you 

must fi rst select a fi ll color from either the Control, Swatches, or Color 

panel. Once a color is selected, clicking and dragging with the Symbol 

Stainer tool gradually tints the symbol instances. If you hold the Option 

(Alt) key while dragging, the reverse effect applies, and the instances 

will gradually return to their original colors.

• Symbol Screener tool. The Symbol Screener tool applies opacity to 

symbol instances. Clicking and dragging with the Symbol Screener tool 

causes instances to become transparent. If you hold the Option (Alt) key 

while dragging, the reverse effect applies, and instances become more 

opaque.

• Symbol Styler tool. The Symbol Styler tool applies graphic styles to 

symbol instances. To use the Symbol Styler tool, you must fi rst select 

an existing named graphic style from the Graphic Styles panel. Once 

you’ve selected a style, click and drag with the Symbol Styler tool to 

gradually add appearances from the style to the symbol instances. If 

you hold the Option (Alt) key while dragging, the reverse effect applies, 

and the instances gradually return to their original appearances. Note 

that using this particular tool can result in extremely slow performance, 

especially with complex symbols.

Figure 9.15 Here in the 
fi nished salad, the Symbol 
Stainer tool was used to 
create the various shades 
of color in the cheese 
toppings.
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Switching Symbolism Tools

When using the Symbolism tools, you’ll often fi nd yourself jumping from one 
Symbolism tool to another. You can either tear off  all the Symbolism tools to 
access them easier, or you can use a special context-sensitive menu. If you’re 
on a Mac, with any of the Symbolism tools selected, press Control-Option, 
and click. If you’re on Windows, press Alt, and right-click to access a circular 
contextual menu that contains all the Symbolism tools (Figure 9.16). Move 
your pointer over the tool you want, and release the keys to switch to the 
Symbolism tool you have chosen.

Figure 9.16 The Symbolism 
contextual menu makes it 
easy to switch between the 
tools.

Double-click any of the Symbolism tools to see the options for the entire 

Symbolism toolset (Figure 9.17). The Intensity setting controls how quickly 

the Symbolism tools work, and choosing Pressure for the Intensity setting 

if you have a pressure-sensitive tablet makes it easier to control the fl ow of 

symbols and the edits you make to them.

TIP If you add multiple 
symbols to a single 

symbol set, using any of the 
Symbolism tools aff ects only 
the symbol that is currently 
selected in the Symbols panel. 
If no symbols are selected in 
the Symbols panel, the tools 
applies to all the symbols.

Figure 9.17 In one dialog 
box, you can set the behav-
ior and view options for all 
the Symbolism tools.
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Expanding a Symbol Set

You can reduce a symbol set to a group of individual symbol instances by 

selecting the symbol set and choosing Object > Expand. Although the 

Symbol Sprayer works only with symbol sets, the remaining Symbolism 

tools work on individual symbol instances. You can also select several 

symbol instances and use a Symbolism tool to adjust them all at once. Still, 

you’ll fi nd that most times, you’ll be using the regular Scale and Rotate tools 

to adjust individual symbol instances, and you’ll be using the Symbolism 

tools for when you’re working with symbol sets.

Scatter Brush vs. Symbol Sprayer

You may be wondering why there’s a Symbol Sprayer tool in Illustrator, since you know that in Chapter 4, 
“Creative Drawing,” we discussed the Scatter brush that allows you to distribute graphics along a path.

Although the concept of creating multiple copies of art is common between the two, the diff erences end 
there. A Scatter brush is limited by what can be defi ned as a brush, whereas you have far fewer limitations 
when you are defi ning symbols. Additionally, using a Scatter brush to add many shapes to a fi le increases 
fi le size and adds complexity to the fi le. The Symbol Sprayer tool can spray hundreds of symbols onto a 
page without you having to worry about fi les getting too big.

Of course, you can adjust symbol sets that are created with the Symbol Sprayer tool using a range of Symbolism 
tools. This allows you to tweak a design until you’re happy with the results. In contrast, when using a Scatter 
brush, you’ve already specifi ed the settings of the brush before you’ve created the path. However, a Scatter 
brush can follow a specifi c path, whereas the Symbol Sprayer tool is harder to control if you need art placed 
at specifi c intervals.

LOOKING BEHIND THE MASK
When we refer to masks, we’re not talking about the kind you wear during 

Mardi Gras. Masking in Illustrator is a way to defi ne parts of your artwork 

as being hidden from view. Rather than having to delete unwanted parts of 

your art, you can use a vector shape to defi ne an area that acts like a win-

dow: Anything that appears within the borders of the shape is visible, and 

anything that falls outside its boundaries is not visible. The main benefi t 

derived from using masks is that you aren’t deleting anything from your fi le, 

and once a mask is created, it’s possible to change the mask or the artwork 
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behind it, as well as reposition the mask to show or hide different parts of 

your artwork.

When you use masks in a fi le and are required to make changes, you’ll never 

have to re-create art that you’ve already deleted. Instead, everything you 

create is always in the fi le, and you simply choose what is or isn’t visible. 

Additionally, a mask allows you to instantly clip parts of an image or an 

object. By using a mask, you can do with one click what might take tens of 

clicks if you use pathfi nder functions to chop up and delete parts of objects. 

Of course, you can’t remove parts of some kinds of objects at all, such as 

placed images, in which case masking is required anyway.

You can create three kinds of masks in Illustrator, each with its own ben-

efi ts. A clipping mask allows you to specify a certain vector shape as a mask 

for other individual or grouped objects. A layer clipping mask allows you to 

specify a certain vector shape as a mask for all the objects within the same 

layer. An opacity mask allows you to use the luminance value of any object to 

create a mask for other individual or grouped objects. As you will see, this 

last type of mask—one of the most well-hidden features of Illustrator—is 

also the most powerful.

Creating Clipping Masks
A common use of clipping masks is showing only a portion of a placed image. 

For example, page layout applications such as Adobe InDesign CS4 allow you 

to place images into a frame. By resizing the frame and positioning the image 

within the frame, you can “crop” an image so that only a portion is visible. 

Being that Illustrator allows you to place images directly on the artboard 

(without requiring a frame), you must use a mask to achieve the effect of 

cropping an image in Illustrator.

Clipping masks are used on all kinds of art in Illustrator—not just placed 

images. For example, you might create an interesting background design 

(made of multiple elements) in Illustrator and want to have this background 

appear within a specifi c shape or area.

In reality, a clipping mask can consist of any vector object, including editable 

text. To create a clipping mask, you fi rst move the object that will become 

the mask to the top of the object stacking order (Figure 9.18). Then, you 

select both the path that will be the mask and the art you want to appear 

inside the mask (which will become the contents of the mask). Choose 

CAUTION Because 
Illustrator creates a 

group when creating a clip-
ping mask, all artwork is 
brought into the topmost 
layer. If you want to preserve 
the layer structure within 
masked artwork, you might 
want to look at “Organizing 
Masking with Layer Clipping 
Masks,” the next section in this 
chapter.

TIP When working 
with images, Illustrator 

provides a quick way to create 
a mask. Select the image, and 
then click the Mask button in 
the Control panel.
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Object > Clipping Mask > Make (or press Command-7 [Ctrl-7]), and only 

the art that falls within the boundaries of the mask object remains visible 

(Figure 9.19).

When you click a mask to select it, just the mask itself becomes selected, and 

you can move it around your artboard, just like any object. But at times, you 

may want to reposition the art within the mask, or you may want to edit 

either the mask itself or the artwork within the mask. You can take several 

routes to do these tasks.

Figure 9.18 Placing the 
text at the top of the stack-
ing order is the fi rst step in 
using the text as a mask.

Figure 9.19 Once the mask 
is created, the artwork is vis-
ible only through the text. A 
soft drop shadow was then 
added to the text for eff ect.
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When you fi rst create a mask, Illustrator automatically assumes you want to 

edit the mask, so the Edit Clipping Path option is active. However, once the 

mask is already created and you’ve deselected it, the behavior is different in 

the following ways:

• Although you don’t see it happen, when you create a clipping mask, 

Illustrator automatically creates a group. Double-clicking with the 

Selection tool isolates this group, giving you access to the mask (mov-

ing it won’t move the masked artwork along with it) and to the actual 

masked artwork as well. This method isn’t as easy to do when you’re 

using live editable text as a mask only because double-clicking a text 

object automatically switches you to the Type tool because Illustrator 

thinks you want to edit the text. But the method works wonderfully 

for any other type of mask object. If your masked artwork contains 

nested groups, you can continually double-click to isolate groups and 

artwork in the hierarchy. Once you’re done editing the contents of your 

mask, press Escape to exit isolation.

• When a clipping mask is selected, the Control panel displays two icons 

on the left side of your screen. Clicking the Edit Clipping Path button 

enables you to edit the mask, without touching the contents within the 

mask. Clicking the Edit Contents button enables you to edit the image, 

without touching the mask (Figure 9.20).

Organizing Masking with Layer 
Clipping Masks
A layer clipping mask is similar to a clipping mask, with one main differ-

ence: Instead of using a shape to mask other selected objects or group of 

objects, it uses one shape to mask an entire layer. In reality, layer clipping 

masks are far easier to control and work with because you aren’t constantly 

selecting and deselecting objects to defi ne what is or what isn’t in a particu-

lar mask. Instead, you use the Layers panel, which you use to organize your 

artwork anyway, to create these kinds of masks. In fact, when creating a 

NOTE Illustrator CS4 
features new clipping 

mask behavior in that masked 
artwork doesn’t get in the 
way when trying to make 
selections. Only artwork that 
is visible will be accessible 
with the Selection tool.

TIP Of course, you 
can always use the 

Direct Selection tool to 
select and edit a mask or 
its contents individually.

Figure 9.20 Clicking Edit 
Contents in the Control 
panel makes it easy to 
edit or adjust the art that 
appears within the mask. Edit Clipping Path Edit Contents
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clipping mask, you don’t need to have any art selected on your artboard at 

all, because the mask is an attribute of the layer.

To create a layer clipping mask, place the vector object that will be your 

mask at the top of the layer’s stacking order. Click the layer name in the 

Layers panel once, which selects the layer (you don’t want to target the layer; 

just highlight it in the panel). Then, click the Make/Release Clipping Mask 

button at the bottom of the Layers panel (Figure 9.21). The topmost object 

in your layer now becomes a mask for all objects in that layer. The mask 

appears listed in the Layers panel with an underline, giving you a visual 

indication of its behavior (Figure 9.22).

With layer clipping masks, you can easily drag items into a masked layer to 

have them affected by the mask, and vice versa. To release a layer clipping 

mask, select the layer, and click the Make/Release Clipping Mask button.

Working with layer masks has an added benefi t. As we mentioned earlier, 

when you create a regular clipping mask, Illustrator automatically creates 

a group that contains the mask and art within it. In Chapter 5, you also 

learned that a group in Illustrator is like a container that stores all objects 

within it. Because of this behavior, objects that reside within a group must 

always live within the same layer. That means if you have artwork that 

appears across several layers and you choose to mask that artwork with 

a clipping mask, you will lose all your layers. That’s because in order to 

NOTE A clipping mask 
uses the vector path as 

the boundary for the mask, 
even if the object has an 
appearance applied to it. If 
you want the appearance to 
become the mask, you’ll need 
an opacity mask, covered 
later in this chapter.

NOTE Because of 
an apparent bug, 

releasing a layer clipping 
mask from the Layers panel 
also releases all layer clipping 
masks and clipping masks 
within any sublayers, forcing 
you to reapply the masks. 
Let’s hope Adobe fi xes this 
issue in the future.

Figure 9.21 To create a layer clipping 
mask, select the layer fi rst, and then 
defi ne the mask.

Figure 9.22 If you see something 
listed in the Layers panel with an 
underline, you know that object is 
a clipping mask.
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create the group with the mask, Illustrator has to bring all the artwork to 

the topmost layer. When using layer masks, however, you can organize 

nested layers to easily mask the artwork you want, while preserving your 

entire layer structure in your fi le.

Seeing Through Objects with Opacity Masks
When you’re creating clipping and layer clipping masks, the vector path of 

the mask is what defi nes the boundary of what is visible and what is not. 

Additionally, anything that falls inside the mask area is completely visible, 

and anything that falls outside that area is completely hidden. Opacity 

masks bring a whole new level of functionality to Illustrator because in 

addition to using the vector path itself as the mask, the visual appearance 

of the mask defi nes what is shown and what is hidden.

If you’ve used Photoshop before, you’re familiar with something called an 

alpha channel. In reality, an alpha channel in Photoshop is just like a mask, 

where the color black represents areas of the image that are visible and the 

color white represents areas of the image that are hidden. With an alpha 

channel, however, you can also specify a color of gray that translates to part 

of an image that’s partially visible. In fact, alpha channels support up to 256 

levels of gray, which translate to up to 256 levels of visibility in such a mask. 

Because of this functionality, users can specify masks with soft edges and 

fades when they use Photoshop. Each pixel of the mask can represent a dif-

ferent opacity value. Opacity masks in Illustrator can take advantage of that 

same functionality.

When you use an object as an opacity mask, the vector path is not the 

only thing that determines what it shown and what is hidden—the visual 

makeup of the object determines the mask as well. Opacity masks support 

256 levels of gray, meaning you can create a soft-edged mask in Illustrator. 

In the next section, you’ll see how this works by using a gradient as an 

opacity mask.

Creating an Opacity Mask

For this exercise, imagine you want to create some artwork that fades from 

100-percent color to none. Once the artwork is created, draw a rectangle 

that covers the entire art, and set its fi ll to a regular default black-to-white 

linear gradient. You now have the original artwork and a rectangle (which 
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will become the mask) stacked on top of each other, with the gradient vis-

ible on top (Figure 9.23). If you were to create a regular clipping mask now, 

the path of the gradient-fi lled rectangle would defi ne the mask. But by using 

an opacity mask, the gradient (or more specifi cally, the appearance) defi nes 

the mask.

Use the Selection tool to select both the artwork and the rectangle, and open 

your Transparency panel (Window > Transparency). You will see a thumb-

nail of your selection in the Transparency panel (Figure 9.24). If you don’t 

see the thumbnail, choose Show Thumbnails from the Transparency panel 

menu. Finally, choose Make Opacity Mask from the Transparency panel 

menu (Figure 9.25 on the next page). The result is a mask that uses the 

values of the gradient to defi ne which parts of the object are visible below it—

resulting in artwork that effectively fades to transparent (Figure 9.26, also on 

the next page).

Figure 9.24 A thumbnail of 
your selected art is visible in 
the Transparency panel.

Figure 9.23 On the left is 
the original artwork. On the 
right is the same artwork 
with the gradient-fi lled 
rectangle placed above it.
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Editing an Opacity Mask

Once you’ve created the opacity mask, you can use the thumbnails in the 

Transparency panel to work with both the mask and the artwork beneath it. 

Instead of one thumbnail as you saw before, there are now two thumbnails: 

The one on the left is the artwork, and the one on the right is the mask. To 

edit the artwork, click the left thumbnail. If you look at your Appearance 

panel, you’ll notice that the object you have selected is a normal path that 

has a solid fi ll attributed to it. The name of the path displays with a dashed 

Figure 9.25 The Make 
Opacity Mask feature, 
one of the most powerful 
commands in Illustrator, is 
hidden (masked, if you will) 
in the Transparency panel 
menu.

Figure 9.26 Once the 
opacity mask is applied, 
the artwork fades to 
transparent.
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underline in both the Appearance panel and the Layers panel, indicating that 

it has an opacity mask applied (Figure 9.27). At this point, the mask is not 

editable, and it can’t even be selected.

Figure 9.27 A target with 
a dashed underline quickly 
identifi es an object that has 
an opacity mask applied 
to it.

Clicking the right thumbnail selects the mask, allowing you to edit its 

attributes (Figure 9.28). Take a look at the Layers panel; doing so reveals 

something very interesting. Instead of displaying all the layers and objects 

in your fi le, when you click the mask thumbnail, the Layers panel switches 

to display just the opacity mask (Figure 9.29). The title bar of your docu-

ment also indicates you are editing the opacity mask and not the art. These 

visual indications help you easily identify when you are editing art and when 

you are editing an opacity mask. To return to artwork-editing mode, simply 

click the left thumbnail icon again.

When you are editing either the artwork or the opacity mask, using the 

Selection tool to move items will result in both the artwork and the mask 

moving together. The reason for this is that, by default, a mask and its 

artwork are linked with each other, indicated in the Transparency panel by 

TIP Shift-click the 
mask icon to temporar-

ily disable the opacity mask. 
Option-click (Alt-click) to 
display just the contents of 
the mask.

TIP Clicking the Invert 
Mask button reverses a 

mask, and rather than having 
the color black appear as 
transparent, black represents 
areas that are opaque. The 
Transparency panel menu 
also has an option to set all 
new masks to be created so 
that they are inverted.

Figure 9.29 The Layers panel 
off ers a visual cue to indicate when 
you are editing an opacity mask.

Figure 9.28 Clicking a thumbnail 
in the Transparency panel tells 
Illustrator what you want to edit. A 
black outline around the thumbnail 
indicates which one is selected.
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a link icon that appears between the two thumbnail icons (Figure 9.30). 

Clicking the link icon allows you to move the mask and artwork indepen-

dently of each other, and clicking between the thumbnails toggles the link 

behavior.

Figure 9.30 Clicking the 
link icon between the 
thumbnails allows you to 
move the art and the mask 
independently.

Clipping Masks and Opacity Masks

When do you use an opacity mask instead of a clipping mask? One certainly doesn’t replace the other, because 
each mask has specifi c benefi ts. A clipping mask uses the actual path of the vector object to defi ne the clip-
ping area. This means a clipping mask always has a hard vector edge. In contrast, an opacity mask uses the 
actual appearance of a shape as the mask, meaning you can create masks with soft edges or diff erent levels 
of opacity. Additionally, opacity masks are controlled via the Transparency panel, making it easier to choose 
when you want to work with the mask or the artwork behind the mask. Of course, using an opacity mask 
means you’re using transparency in your fi le, which requires fl attening. When you’re creating fi les for certain 
workfl ows that become complicated when you use transparency eff ects, using a clipping mask is benefi cial. 
For more information about transparency and fl attening, see Chapter 15, “Prepress and Printing.”

Taking Opacity Masks to the Next Level

Because opacity masks are “hidden” deep within the Transparency panel, 

they don’t get much publicity. However, they are really one of the most 

sophisticated features you’ll fi nd; they offer a wide range of functionality. 

If you truly understand that opacity masks are just levels of gray that deter-

mine visibility, you can use these to achieve effects that you once thought 

were possible only in Photoshop. Take photographs, for example. By using 

a vector object with a Feather live effect applied to it, you can create a soft-

edged vignette for a placed photograph right in Illustrator. Additionally, you 

can use placed images themselves as opacity masks. Think about scanning 

interesting textures and using them to mask vector artwork.
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USING GRAPHIC STYLES
You probably already have a sense of how powerful appearances and live 

effects are. However, if you have several objects in your fi le to which you 

need to apply the same appearance, it can be ineffi cient to do this manually, 

all through the Appearance panel. Additionally, if you ever needed to update 

the appearance you applied, you would need to do so for each object indi-

vidually. Graphic styles can help.

A graphic style is a saved set of attributes, much like a swatch. When you 

apply a style to an object, that object takes on the attributes that are defi ned 

in the style. At any time, you can redefi ne the attributes of a particular style, 

and when you do, any objects in your fi le that already have that style applied 

are updated as well. The best part about graphic styles is how easy they are 

to use. And you’ll never guess which panel plays an integral part in creating 

graphic styles—that’s right, the Appearance panel.

Defi ning a Graphic Style
As we mentioned, a graphic style is a saved set of attributes. You know that 

the Appearance panel lists all attributes, so you already understand the fi rst 

step in creating a graphic style—specifying the attributes you want defi ned 

in the style. Once you’ve specifi ed stroke and fi ll settings and added live 

effects to an object, click the New Graphic Style button in the Graphic 

Styles panel (Figure 9.31). Alternatively, you can drag the target thumbnail 

from the Appearance panel and drop it on the Graphic Styles panel. Double-

click a style in the Graphic Styles panel to give it a name (which is always 

helpful). If you Option-click (Alt-click) the New Graphic Style button, you 

can defi ne a new style and give it a unique name in a single step.

Figure 9.31 Once you’ve 
specifi ed your attributes in 
the Appearance panel, you 
can use the Graphic Styles 
panel to create a 
new graphic style.



CHAPTER 9: DRAWING WITH EFFICIENCY308

Notice that when you apply a graphic style to an object in your fi le, the 

Appearance panel identifi es the target and the style that is applied. This makes 

it easy to quickly see which style is applied to an object (Figure 9.32).

Editing a Graphic Style
Editing a graphic style is an exercise that involves both the Appearance panel 

and the Graphic Styles panel, so it makes sense to position them side by side. 

You don’t need to have an object selected in order to modify an existing 

graphic style, but if you do have an object selected, you’ll be able to preview 

the changes you’re making to the style.

In the Graphic Styles panel, click the style you want to edit. The Appearance 

panel lists all the attributes for the selected style. You can modify the style 

by adding attributes, by deleting existing ones, or by changing the paint 

order by dragging attributes in the Appearance panel. Once you’re happy 

with the modifi cations, choose Redefi ne Graphic Style from the Appearance 

panel menu to update the style (Figure 9.33).

Figure 9.32 When a 
graphic style is applied, the 
Appearance panel helps you 
easily identify the target and 
the applied style.

Figure 9.33 Once you’ve 
modifi ed the attributes, you 
can update the style, which 
updates all other objects 
that have the style applied.
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Any objects in your fi le that have that particular style applied then immedi-

ately update to refl ect the modifi cations. Alternatively, you can Option-drag 

(Alt-drag) the target thumbnail on top of the existing style in the Graphic 

Styles panel.

Adding a Graphic Style to an Object
Normally, when you apply a graphic style to an object (or a group or a layer, 

for that matter), the attributes specifi ed in the graphic style replace the cur-

rent attributes applied to the target. However, you can also add the attributes 

from a graphic style to a target. For example, if a graphic style contains just 

a drop shadow effect, adding this graphic style would simply add the drop 

shadow without removing any other effects that might have already been 

applied to the object. To do this, press the Option (Alt) key while applying 

the style.

For some inspiration on how to implement graphic styles in this way, Adobe 

has added some additional content with this specifi c functionality in mind. 

Choose Window > Graphic Style Libraries, and explore the Additive for 

Blob Brush and Additive libraries.

USING AUTOMATION WITH
ILLUSTRATOR
With today’s “need it now” mentality, we’ve been thrust into an era where 

deadlines and delivery dates are shorter than ever—at the same time, 

we’re being asked to perform twice as much work. If you take a moment 

to read just about any press release and marketing document produced by 

companies in the high-tech industry, you’ll fi nd promises of faster per-

formance and higher productivity with each new software release. Even 

hardware items such as the TiVo and the Apple iPod speak of our need for 

on-demand content.

The good news is that Illustrator supports several techniques for streamlin-

ing workfl ow through automation—in essence, you can have Illustrator do 

all the hard work for you while you take a few moments to grab some lunch 

(but who takes lunch anymore?).

TIP To see a preview 
of how text will look 

when a graphic style is 
applied, choose Use Text for 
Preview from the Graphic 
Styles panel menu.
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Although automation may sound like a scary technical word, it doesn’t have 

to be. Illustrator supports automation via two methods:

• Actions. This feature allows you to record specifi c steps that you can 

then reproduce by simply clicking a button. For example, an action may 

contain the steps necessary to select all text objects in an open docu-

ment and rasterize them at a specifi c resolution. Actions are simple to 

record and don’t require any code-writing knowledge. However, not 

every feature in Illustrator is actionable, so there’s a limit to what an 

action can do.

• Scripting. Scripting is essentially a programmatic way to interact with 

an application. Instead of clicking with a mouse or pressing a few keys 

on your keyboard to control Illustrator, you use a script—a set of com-

mands instructing Illustrator what to do. Because these commands can 

contain math and logic, a script can create artwork based on variables. 

For example, a script might draw a graph in which numbers greater 

than a certain amount appear in black and numbers less than that appear 

in red. Most Illustrator functionality is available through scripting (sig-

nifi cantly more so than with actions), but to write a script, you need 

to know a scripting language. Illustrator supports AppleScript (Mac), 

VBScript (Windows), and JavaScript (cross-platform). The good news is 

that you don’t need to know how to write scripts in order to use them 

(that is, you can have someone write a script for you).

Recording and Playing Actions
Recording an action is very simple and straightforward in Illustrator; play-

ing back an action is even easier. To access the list of preset actions via the 

Actions panel, choose Window > Actions. The 22 actions in Illustrator are 

grouped within the Default Actions set. In addition, you can also create 

your own sets and actions.

To create a new set and an action within it, follow these steps:

1. Choose Window > Actions to open the Actions panel (Figure 9.34).

2. Click the Create New Set button at the bottom of the Actions panel. 

Give your set a unique name, and click OK.
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3. Click the Create New Action button at the bottom of the Actions panel. 

When you do, Illustrator prompts you to name the action you’re about 

to record. Choose the set you just created, and if you’d like, choose a 

function key so that later you can perform the action using a keystroke. 

When you’re done, click OK.

At this point, you’ll notice that the red recording icon at the bottom of 

the Actions panel is highlighted, indicating that recording has begun. 

4. Perform the steps you want to record in Illustrator.

You can see each step being added as a line item to your action as you 

perform it. If a step doesn’t appear in your action, it is probably because 

the function you performed is not actionable.

5. Once you have completed the steps for your action, click the Stop 

Recording button. At this point, the action is complete.

6. To play back your action—or any other one—highlight it in the Actions 

panel, and click the Play Current Selection button. If you assigned a 

keystroke to your action, you can play it back by pressing the correct key 

combination on your keyboard.

Once you’ve recorded an action, you can also modify individual steps by 

double-clicking them, or you can delete those steps by dragging them to the 

trash can icon. Highlight a specifi c item by clicking it in the Actions panel, 

and choose any of the Insert commands in the Actions panel menu to add 

specifi c menu commands, stops, or paths to your action as well. You can 

also save and load entire sets of actions from the Actions panel menu.

Figure 9.34 You’ll fi nd the 
Default Actions set in the 
Actions panel. You can also 
create your own custom sets.

TIP To apply actions 
with a single click, you 

can activate Button mode in 
the Actions panel. Choose 
Button Mode from the 
Actions panel menu.

Action Set

Stop Playing/Recording

Action

Begin Recording

Play Current Selection

Create New Set

Create New Action

Delete Selection
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Scripting in Illustrator
You can script in Illustrator using AppleScript, Visual Basic Scripting 

Edition (VBScript), or JavaScript. Actually, Illustrator uses a language called 

ExtendScript, which is an Adobe fl avor of JavaScript. You can fi nd resources 

for this language, such as scripting dictionaries and sample scripts, in the 

Adobe Illustrator CS4/Scripting folder.

In general, ExtendScript is used to drive functionality within Illustrator. 

For example, you might use an ExtendScript script to reverse the direction 

of a selected vector path. In contrast, AppleScript or VBScript can drive 

functionality that uses different applications. For example, an AppleScript 

script might pull data from an external fi le or from the web, use that data 

to generate a graphic, and then export that graphic in a specifi ed format and 

email it.

Each sample script included with Illustrator contains either separate PDF 

fi les describing how the script works or comments embedded directly in 

the script. You can open and view a script using a script editor or any text-

editing applications, such as BBEdit, TextEdit, or TextPad.

USING AUTOMATION WHEN
RELEASING FINAL FILES
Sending a fi le to a print service provider for fi nal printing comes with the 

anxiety of not knowing whether everything in the fi le is okay and whether 

the printed results will come back as you envision them. A good designer 

knows that sending a fi le that’s free of problems, and that includes all the 

necessary support fi les, is critical to success.

Using some of the automation features we mentioned earlier in this chapter, 

along with some sample actions and scripts that ship with Illustrator, you 

can make it a whole lot easier to release fi nal fi les.

Cleaning Up Messy Files
When you create a new Illustrator fi le, any swatches, brushes, symbols, and 

graphic styles that are present in the new document profi le used to create 

the fi le are added to the new fi le. Even if you never use these items to create 
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artwork, your fi le contains this extraneous material. It’s also normal for you 

to add and remove elements as you are working on a design concept. When 

it comes time to release a fi nal version of your artwork, all these extra ele-

ments are still present.

Although in theory nothing is wrong with having extra items in a fi le, 

experience tells a different story. In such cases, fi les can become corrupt, 

or art elements can be accidentally changed. In addition, a fi le with unused 

swatches or symbols can add to confusion if a printer needs to edit the fi le 

as it goes to press. These extra and unnecessary elements also bloat fi le size, 

causing longer save and open times.

Once a fi le has been deemed fi nal, you can quickly remove all unused items 

using one of the preset actions in Illustrator. With the Illustrator docu-

ment open, choose Window > Actions to open the Actions panel. From the 

Default Actions set, click the one named Delete Unused Panel Items, and 

then click the Play button at the bottom of the panel.

Generating a List of Used Items
It’s always helpful to provide your print service provider with as much infor-

mation as possible about any fi le you are sending. Some designers print a list 

of all the fi les used; others mark up printouts with callouts and swatch chips.

Illustrator can help save time with a script called Analyze Documents, 

which is installed by default in the Scripting/Sample Scripts/AppleScript 

(Sample Scripts/Visual Basic Scripts) folder. You can run the script by 

simply double-clicking it. The script prompts you with a dialog box asking 

you to identify a folder that contains Illustrator fi les. The script works on 

multiple fi les at one time. The Analyze Documents script then opens each 

fi le in the selected folder and generates a new document that lists every 

font, gradient, spot color, and placed image used in all the fi les.

The new fi le that is created is called DocumentReporter.ai, and you can 

format it to your specifi cations once the script has fi nished running.

Collecting Necessary Support Files
One of the most requested features for Illustrator is a command that collects 

all place-linked images and fonts, making it easy to send a fi le and all neces-

sary support fi les so that someone else can work on or print the fi le.



CHAPTER 9: DRAWING WITH EFFICIENCY314

Although Illustrator doesn’t have a Collect for Output feature like 

QuarkXPress does or a robust Package command similar to that in 

InDesign, Illustrator does come with a script called Collect for Output, 

which you can fi nd in the Scripting/Sample Scripts/AppleScript (Sample 

Scripts/Visual Basic Scripts) folder. If you think you will use this script 

often, you might consider placing a copy in the Adobe Illustrator CS4/

Presets/en_US/Scripts folder. That way, the script will appear in the File > 

Scripts menu within Illustrator.

Upon running the Collect for Output script, Illustrator copies the open 

Illustrator fi le and all place-linked images and places them in a new folder 

on your desktop. Unfortunately, the script won’t collect fonts, although you 

can use the Analyze Documents script mentioned earlier to generate a list 

of fonts that are used in your document to assist in collecting the fonts you 

need manually.



Chapter 
TenDrawing with Data

We are bombarded with information on a daily basis. 

Whether it is from BlackBerry devices, newspapers, 

the Internet, magazines, outdoor advertising, television, 

or radio, we can absorb only a limited amount. At the 

same time, certain bits of information require a degree 

of focus and attention for us to process and really 

understand them.

Aware of the challenges, designers often turn to graphs 

or charts to present complicated information in a 

simpler manner. Also known as an infographic, a well-

designed graph presents key data points in a visually stimulating way that 

quickly conveys a message to the reader. Graphs are often used in annual 

reports, business or sales presentations, and magazine or newspaper articles.

Using graphs is a great way to communicate numeric information in a 

visual and graphical manner; when you use such a way to represent your 

data, you can turn a jumble of numbers into compelling data points. The 

important part is to remember that a graph is meant to communicate infor-

mation. As you’ll see in this chapter, Adobe Illustrator CS4 offers many 

ways to control a graph’s appearance, and it can be all too easy to get caught 

up in making a graph look so pretty that the reader misses its entire point.

315
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EXPLORING THE ANATOMY
OF A GRAPH
Before we get into the specifi cs of creating and editing graphs, let’s fi rst 

explore how Illustrator constructs them.

A graph can consist of several different elements, including the chart itself, 

a value and category axis, and a legend. These elements are each created as 

individual groups so that they can be managed and selected easily with the 

Group Selection tool. A graph in Illustrator is a special kind of parent group 

that comprises individual groups (Figure 10.1). Depending on the settings 

you use, a graph can have all or just some of these groups.
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As long as the special parent group contains the elements, you can make 

edits to the graph data or the settings of the graph itself, and Illustrator 

updates the graph accordingly. However, if you remove the parent group 

(by choosing Object > Ungroup), the individual elements act like regular 

vector objects, and you can no longer edit the graph data. (See the section 

“Ungrouping a Graph” later in the chapter, where we discuss under what 

circumstances you would want to ungroup a graph.)

NOTE Graphs and 
charts are often used 

as interchangeable terms. 
Throughout this chapter, 
however, we refer to the 
numerical elements as 
charts and the entire overall 
graphic as graphs.

Figure 10.1 A graph in 
Illustrator consists of 
many diff erent parts.

TIP Because a graph is 
a group, all that you’ve 

learned so far about how 
groups work and how you 
can apply eff ects to groups 
applies to graphs as well.

Value Axis Chart Legend Legend Values

Category ValuesCategory Axis
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CREATING A GRAPH IN ILLUSTRATOR
Creating a graph in Illustrator involves specifying a size for your graph (much 

like drawing a rectangle) and the data for the graph. Creating a graph is as 

simple as the following steps:

1. Select one of the nine graph tools in the Tools panel (Figure 10.2), 

and click your artboard once. This opens the Graph dialog box where 

you must fi rst specify the size for the graph and then click OK. Alter-

natively, you can click and drag with the graph tool on the artboard to 

generate a size for the graph on the fl y.

Figure 10.2 The nine diff er-
ent graph tools are grouped 
together in the Tools panel.

The size you specify is the area that is enclosed within the value and the 

category axis (or the X and Y axes). This size won’t necessarily be the 

fi nal size of all the elements in the graph because items such as values 

and legends appear outside the boundaries of the two axes.

2. Once you’ve specifi ed the size of your graph, Illustrator opens the 

Graph Data window, in which you can enter the data for your graph.

Refer to the options in the “Specifying Graph Data” section for detailed 

information about the settings in the Graph Data window and the dif-

ferent ways you can format your data.

3. When you’re done, click the Apply button, and close the Graph Data 

window.

TIP If you aren’t sure 
which type of graph 

you want to use, you can 
choose any type in which to 
enter your data. You can 
always change between types 
after you’ve created the graph.
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Choosing a Graph Type
Creating a graph in Illustrator is much like following a recipe. You take 

a few numbers here, take a few values there, and toss them together, and 

Illustrator produces a functional visual representation of your data. In the 

world of graphs, you can present data in many different ways. Illustrator has 

nine different ways; each of these is called a graph type. Refer to Table 10.1 

for more specifi c examples of these graphs and how they compare.

• Column graph. A column graph presents a single group of data as a 

series of vertical columns; it is often used to compare a range of values.

• Stacked column graph. A stacked column graph presents multiple 

groups of data as a series of vertical columns. Multiple values are accu-

mulated and stacked on top of each other. Stacked column graphs are 

used to compare a range of values and also to indicate how individual 

data points may have contributed to the overall totals.

• Bar graph. A bar graph presents a single group of data as a series 

of horizontal bars; it is identical to the column graph, but it is in a 

horizontal format.

• Stacked bar graph. A stacked bar graph presents multiple groups of 

data as a series of horizontal bars. Multiple values are cumulated and 

added to the ends of the bars. The stacked bar graph is identical to the 

bar graph type, but it is in a horizontal format.

• Line graph. A line graph presents multiple groups of data as a series 

of connected lines. Line graphs are often used to show continuous 

measurements or trends over time.

• Area graph. An area graph is similar to a line graph, but the areas 

created by the lines are fi lled in, thus offering a visual representation 

of volume. This presents a cumulative value of the areas as well.

• Scatter graph. A scatter graph maps multiple data points as individual 

dots, which makes it possible to chart trends and compare nonlinear 

data points.

• Pie graph. A pie graph presents a single group of data points as slices or 

wedges of a circle. Pie charts are generally used to show percentages or 

to show how a whole is broken up into individual parts.

• Radar graph. A radar graph, also called a web or polar graph, plots data 

points in a circular pattern, which reveals values with overlapping areas.

TIP By default, 
Illustrator creates 

graphs using diff erent shades 
of gray, which isn’t exactly 
exciting when it comes to 
making important presenta-
tions. Instead of trying to 
come up with colors that 
work well together, remem-
ber that you have the 
Illustrator Color Guide and 
its Live Color feature at your 
disposal. Refer to Chapter 6, 
“Coloring Artwork,” for more 
information on recoloring 
artwork.
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Table 10.1 Examples and Uses of Graph Types

Graph Type Description Example

Column graph This column graph displays how many pitches of 
each kind were thrown in a baseball game.
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Stacked Column 

graph

This stacked column graph displays the same 
information as in the previous graph, but now you 
can also view how many pitches of each kind were 
thrown for a ball or a strike.
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Bar graph This bar graph also displays how many pitches of 
each kind were thrown in a baseball game.
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graph

This stacked bar graph displays the same information 
as in the bar graph, but now you can also view how 
many pitches of each kind were thrown for a ball or 
a strike.
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 (continues)
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Graph Type Description Example

Line graph This line graph displays ticket sales across a range 
of several months. The graph shows growth in ticket 
sales over time, and the weekend games draw larger 
crowds.
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Area graph This area graph displays the same data as in the 
previous line graph, but here you can see the total 
cumulative attendance of both weekday and 
weekend ticket sales.

0

10000

20000

30000

40000

50000

60000

70000

80000
Weekday

Weekend

AugustJulyJuneMayApril

Scatter graph This scatter graph compares the ages of hitters with 
the number of home runs they hit. The chart shows 
data for three diff erent decades, and the data reveals 
a peak in home runs hit by hitters aged 30 to 35.

20 30 40 50 60 70 80
20

25

30

35

40
1990’s

1980’s

1970’s

Pie graph This pie graph breaks down the type of tickets sold at 
a baseball game. You can clearly see that the majority 
of tickets sold are from advanced sales.
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Group Sales

Advanced Sales

Season Tickets

Radar graph This radar graph compares the sales of beer and soda 
over the course of a nine-inning baseball game. The 
graph reveals that beer sales spike between the third 
and fi fth innings, whereas soda sales peak between 
the seventh and ninth innings.
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Table 10.1 Examples and Uses of Graph Types  (continued)
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Specifying Graph Data
When you create a graph in Illustrator, you are presented with the Graph 

Data window, which is the life and soul of a graph (Figure 10.3). After all, 

without any data, Illustrator can’t draw a meaningful graph. If you’ve ever 

seen a spreadsheet before (such as in Microsoft Excel), you’ll recognize the 

vertical columns and horizontal rows of cells where you can specify data. 

You can click and drag the vertical lines to adjust the width of each row. 

This won’t have any effect on the appearance of your graph, but it will allow 

you to view all your data if it extends beyond the boundary of each cell.

If you’ve already created a graph and you’ve closed the Graph Data window, 

you can always reopen this window for further data editing. To do so, with 

a graph selected on your artboard, just choose Object > Graph > Graph 

Data; the Graph Data window will appear.

Across the top of the Graph Data window are several items. A fi eld where 

you can enter data for a selected cell (to select a cell, simply click it) appears 

along the entire top left side. Along the top right of the window are the 

following six icons that offer additional functionality:

• Import Data. Illustrator allows you to import data from an external 

fi le by clicking the Import Data icon. Illustrator presents you with a 

Figure 10.3 The Graph 
Data window contains the 
values that determine how a 
graph is drawn.

Data Entry Field Cell Import Data

Transpose Row/Column Revert

Switch X/Y Cell Style

Apply
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system dialog box that allows you to choose a fi le to use. The fi le you 

choose must be a tab-delimited text (TXT) fi le. Unfortunately, 

Illustrator does not allow you to import Excel fi les directly. If you 

have data that already exists in an Excel fi le, you can save the Excel fi le 

as a tab-delimited text fi le that you can then import into Illustrator. 

Alternatively, you can also copy and paste data from Excel right into 

the Graph Data window.

• Transpose Row/Column. When you click the Transpose Row/

Column icon, the data that is already entered in the Graph Data win-

dow is swapped so that rows become columns and columns become 

rows. This is useful for when you either enter data incorrectly or want 

to experiment with a different graph result.

• Switch X/Y. When editing graph data for a scatter graph, the Switch 

X/Y icon allows you to swap the X and Y axes. The icon is disabled for 

all other graph types.

• Cell Style. By default, each cell in the Graph Data window is wide 

enough to display seven digits, and each value is shown with two 

decimal places. By clicking the Cell Style icon, you can change both 

the column width and the number of decimals. This setting applies 

to all the cells in the Graph Data window (you can’t apply different 

settings to individual cells).

• Revert. Clicking the Revert icon returns the graph data to the values 

specifi ed when you last clicked the Apply button.

• Apply. The Apply button takes the values specifi ed in the Graph Data 

window and generates or updates your selected graph.

Formatting Data in the Graph Data Window
Almost as important as the data itself is the way you actually enter it into the 

Graph Data window. The graph type you choose and the way in which you 

format the values in the cells of the Graph Data window are the two items 

that most impact how Illustrator draws your graph.

For example, if you just specify numeric values in the Graph Data window, 

Illustrator draws the graph correctly, but people who read your graph may 

not understand its signifi cance. For a graph to be effective, a reader needs to 

understand what the values mean. One way to help a reader make sense of 
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a graph is by adding labels that identify what a particular axis or data point 

represents.

In the Graph Data window, you can specify labels simply by entering the 

text of the labels in the cells. If Illustrator sees a value that contains letters 

instead of numbers, it assumes the cell contains a label, and not a numeri-

cal value that affects the graph itself (Figure 10.4). To specify a number as 

a label (for example, a year such as 2009), you must enclose it in quotation 

marks (“2009”).

CUSTOMIZING GRAPHS
Once you’ve created a graph, you can edit it and customize it to fi t your 

needs. At any time, you can select a graph and open the Graph Data window 

where you can change the data. When you check the Apply button, your 

graph updates to refl ect the new data.

However, there can be more to a graph than just the data itself. For exam-

ple, a graph has a category axis, a value axis, a legend, and other elements. 

To make adjustments to these settings, select a graph on the artboard, 

and choose Object > Graph > Type to open the Graph Type dialog box. 

Figure 10.4 These two 
graphs represent the same 
data, but the bottom one 
has a legend and category 
labels added to make the 
meaning of the graph 
immediately apparent.

TIP Working with data 
and labels can get con-

fusing at times, but don’t get 
frustrated. Keep your Graph 
Data window open, and use 
the Apply button to quickly 
see the results of how Illustra-
tor draws your graph. You can 
then make quick adjustments 
to the data as needed.



CHAPTER 10: DRAWING WITH DATA324

Depending on the type of graph that you have chosen, the Graph Type dia-

log box offers several panels with specifi c options (Figure 10.5).

Using Graph Designs
Purely from a numbers point of view, bars, lines, and squares get the point 

across when you’re creating a graph. However, there’s plenty of room for 

creativity when you’re drawing graphs as well. Sometimes, a graphic can add 

a really nice touch to the overall appearance of a graph, and it can even make 

it easier to pick up on key data points.

In Illustrator, custom art that is used instead of bars to display values in a 

graph is called a graph design. For the most part, graph designs behave much 

like patterns do. First you defi ne a graph design. Once defi ned, you can 

apply the graph design to a graph in your document. Illustrator supports 

two kinds of graph designs: a Column graph design, which is used for 

drawing columns in column graphs, and a Marker graph design, which is 

used for drawing markers in line or scatter graphs.

Creating a graph design

Here are the steps you need to follow to create a graph design:

1. Select the art on your artboard you’d like to use as a graph design. You 

can use most Illustrator objects in a graph design, with the exception of 

editable text or placed images—although you can use symbols.

Figure 10.5 Illustrator 
off ers additional settings 
for how graphs appear 
through the Graph Type 
dialog box. Each graph type 
maintains options specifi c 
to its type of graph.

TIP There’s also plenty 
of good information 

on creating graph designs in 
Illustrator Help.

NOTE The Graph 
Data window must 

be closed in order to defi ne 
or apply graph designs.
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2. Choose Object > Graph > Design to open the Graph Design dialog box.

3. Click the New Design button, and then click the Rename button so 

you can give your graph design a unique and recognizable name 

(Figure 10.6). Click OK.

Applying a graph design

Now that you’ve created a graph design, here are the steps you need to 

follow to apply the graph style to your graph:

1. Select the graph object on the artboard.

2. If you’re working with a column graph, choose Object > Graph > 

Column. From the Graph Column dialog box, choose a column design 

and a column type (Figure 10.7).

Figure 10.6 Here we’ve 
defi ned a graph design 
using a drawing of a 
baseball.

Figure 10.7 On the left is the Graph Column dialog box where we used the baseball 
design for the columns of the graph. On the right is the fi nished graph.
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3. If you’re working with a line or scatter graph, choose Object > 

Graph > Marker. From the Graph Marker dialog box, choose a 

marker, and click OK.

Instantly Colorizing a Graph
When generating graphs in Illustrator, each series of data is displayed as 

varying shades of gray by default. Although gray charts don’t make for very 

exciting presentations, it’s easy to use the color features in Illustrator to 

quickly apply visually appealing colors to your graphs.

1. Create your graph. Follow the instructions in this chapter to create a 

chart with your data. If you already have a graph that you’ve created, 

open the fi le (Figure 10.8).

2. Create groups of colors. Recoloring artwork is a lot easier when you use 

color groups. You can load existing color groups from the color libraries 

that ship with Illustrator, or you can create your own using the Color 

Guide or Adobe Kuler. Add each new color group to your Swatches panel 

Figure 10.8 When you 
create a graph, the data 
is initially represented in 
diff erent shades of gray.
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(Figure 10.9). Refer to Chapter 6 for more information on creating 

color groups, accessing libraries, and using the Color Guide panel 

or Kuler.

3. Recolor your graph. Select the graph in your document, and choose 

Edit > Edit Colors > Recolor Artwork. Then, click any of the color 

groups that appear on the right side of the Recolor Artwork dialog box 

(Figure 10.10). Click different color groups to see what they look like. 

If you want to recolor the black elements in your graph as well, deselect 

Preserve Black in the Recolor Options dialog box (refer to Chapter 6 

for details). Click OK when you’ve found the colors that work best for 

your graph.

Figure 10.9 You can add 
color groups to your docu-
ment’s Swatches panel from 
custom libraries or directly 
from the Kuler panel.

Figure 10.10 Clicking 
a color group automati-
cally assigns colors from 
the group to the diff erent 
shades of gray in the graph.
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Graphs That Reset to Shades of Gray

Graphs seemingly have a tendency of defaulting their appearance to shades of gray when the graph data is 
updated. At times, you might customize the appearance of a graph by adjusting colors and the like, and those 
settings remain intact after you’ve updated the graph data. Yet, other times, the graph defaults to shades of 
gray. Why does this happen?

Believe it or not, there’s a reason behind everything, and in this case, Teri Pettit, a developer on the Illustrator 
team who worked on the graph feature, was kind enough to provide the following explanation:

“Editing objects inside graphs is sort of like having action recording turned on, with the actions being 
stored with the graph instead of in a separate fi le. Whenever you change the graph data or graph attributes, 
Illustrator fi rst creates a new default graph at the location that the graph was fi rst created, as if you had just 
dragged out the graph tool and entered the data. Then all the ‘graph actions’ (edit history) that were recorded 
since the beginning of time (that is, since the creation of that graph, including any previous graph it was dupli-
cated from) get played back, complete down to the transforms that moved that graph to where it is now.

“Just as not every edit you can do in Illustrator is recordable by actions, not every edit you can do in Illustrator 
is recordable by graphs. In fact, many fewer are recordable by graphs. So for the most part, if the edit is per-
formed by a feature that was introduced after Illustrator 5, either it entirely ignores graphs or in some cases the 
edit is performed but is not recorded. This is because most of the features added since Illustrator 6 abide by 
diff erent rules internally.

“Sometimes even when some changes are recordable, if other changes are made that are not recordable, the 
act of making the nonrecordable changes will make some of the recorded changes no longer work. (They are 
still remembered, but they fail to apply, like playing back an action that can’t fi nd the right kind of selection 
anymore.) When that happens, you can get your graphs reverting to default shades of gray.

“The safest way to make sure your edits to graphs ‘stick’ is to confi ne yourself to editing them using the parts 
of the application that were available in Illustrator 5. For example, scale objects with the Scale tool instead 
of the bounding box, the Transform panel, or the Transform Each command, and apply paint styles with the 
Swatches panel or the Color panel instead of dragging and dropping color onto objects.

“If you want to apply live eff ects to graph columns in a way that gets remembered, you have to make a named 
style and then apply that named style to the graph columns.

“Another good tip to follow is to not try to keep making new graphs by duplicating the same old template 
graphs for years and years and modifying them. Since the edit history is forever, it can get pretty crafty after 
editing a graph hundreds of times. If all you are going to change is graph data, that’s fi ne, since data changes 
aren’t recorded as a graph edit. But if you are going to be setting up diff erent column styles and text styles 
and graph style attributes and transformations, it is cleaner to start fresh than to make extensive edits to an 
old graph.”

Thanks for the detailed explanation, Teri! You can fi nd more wisdom from Teri on her website at 
http://tpettit.best.vwh.net/adobe/.

http://tpettit.best.vwh.net/adobe/


RAISING THE BAR WITH GRAPHS 329

Ungrouping a Graph
At any time, you can decide to ungroup your graph, although if you do so, the 

graph is reduced to regular vector objects and is no longer editable as a graph 

object. Designers may ungroup a graph once they know the numbers won’t 

change anymore. Once ungrouped, a designer can edit the objects freely.

RAISING THE BAR WITH GRAPHS
You can take advantage of the graph feature in Illustrator in numerous ways. 

Once you’ve created a graph, you can use the Direct Selection tool to select 

individual parts of a graph and apply different fi ll or stroke attributes (by 

default, Illustrator generates graphs using different shades of gray). You can 

also apply other Illustrator features, such as live effects (like 3D or Scribble) 

or transparency. You can even use graph elements as masks for photographs.

In addition, you can use an Illustrator graph as a guide for more customized 

artwork (Figure 10.11). For example, you may want to create an intricate 

infographic using customized shapes. By creating a simple graph with real 

data, you can draw artwork in scale to depict numeric data in a visual way. 

Just always remember that the ultimate job of a graph is to convey informa-

tion, so avoid adding unnecessary “noise” to a graph.

TIP In the Adobe 
Illustrator CS4/Cool 

Extras/en_US/Sample Files /
Graph Designs folder, you’ll 
fi nd four fi les that contain 
predefi ned graph designs and 
samples of diff erent graphs.

TIP If you spend a lot 
of time creating graphs 

and charts, you can learn a lot 
from arguably the best in the 
business—Edward Tufte. You 
can fi nd lots of great informa-
tion and also purchase his 
wonderful books at his web-
site, www.edwardtufte.com.

Figure 10.11 Graphs don’t 
have to be boring. Use 
the Illustrator feature set 
and your creativity to cre-
ate graphs that demand 
 attention.

www.edwardtufte.com
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If bringing data into Illustrator isn’t your cup of tea, you can use Excel to 

generate a graph, which you can then save as PDF from Excel (if you have 

Acrobat installed on your computer, you have a utility called PDFMaker 

available from within Microsoft Offi ce). Once you’ve created the PDF, open 

it in Illustrator, where you can customize it as needed (you won’t be able to 

edit the graph data, however).

COMBINING MULTIPLE GRAPH TYPES
When comparing data, it can be helpful to employ a combination of graph 

types to display different data points. For example, you might want to dis-

play one set of data as a Column graph but another set of data as a Line 

graph. To better compare the two data points, you might overlay the Line 

graph over the Column graph to attempt to discover a trend. You can do 

this easily in Illustrator, so let’s explore the thinking behind it, as well as the 

steps it takes to create it.

The obvious theme in this chapter so far has been around baseball, so we’ll 

continue with that example. It might be interesting to compare the number 

of home runs a player hits over the course of many seasons to the number of 

strikeouts that a player has had over the same period of time. Such an analy-

sis may reveal a trend (for example, as home runs go up, perhaps strikeouts 

also go up, and so on), and we’ll want an easy way to look at both the home 

run data and the strikeout data. Let’s create a chart that displays batting sta-

tistics of Barry Bonds when he was with the San Francisco Giants. Here are 

the steps we’ll follow to create such a chart:

1. Select the Column Graph tool, and drag out a wide rectangle. This 

opens the Graph Data window, where you can enter the data.

2. Finding batting statistics for Barry Bonds isn’t very diffi cult with the 

help of Google, or you can simply copy the values from Figure 10.12.

Remember that to create the years as labels and not data, you must 

enclose the numbers that represent the years in quotation marks.
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Figure 10.12 The Graph 
Data window, with the 
labels and data specifi ed.

3. Click Apply in the Graph Data window.

This applies the data and draws the graph (Figure 10.13). The graph 

doesn’t look very charming at the moment, and because there are so 

many years, the labels across the bottom of the graph overlap each other, 

but don’t worry. We’ll make everything look fabulous soon enough. 

This, by the way, is one of the reasons why it’s never a good idea to have 

a client sit with you while you work (you can just hear them saying “But 

I don’t want the chart to be colored gray…”).

Now we’ll specify a different type of graph to offset the different sets of 

data. Although the Column format works well for the number of strike-

outs, the Line format would be better for displaying the home runs.

Figure 10.13 Illustrator 
displays the graph, with the 
values and the legend.
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4. Select the Group Selection tool, and click the legend twice next to the 

word Home Runs (Figure 10.14). This selects the data range for the 

home runs.

5. Double-click the graph tool in the Tools panel, which opens the Graph 

Type dialog box. Select the Line option for the Graph Type, and click 

OK. This redraws the home-runs data as a Line graph but keeps the 

strikeouts data as a Column graph (Figure 10.15).

6. At this point, the data is complete and formatted as needed. Using 

graphic styles and paragraph styles, you can quickly adjust the appear-

ance of the fi nal graph (Figure 10.16).
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With the graph in fi nal form, the strikeouts and the home runs are easy to 

observe separately and can be compared to each other as well.

Figure 10.14 Using the 
Group Selection tool to click 
the legend twice will select 
that entire data series in the 
graph.

Figure 10.15 The graph 
now correctly displays each 
data series with a diff erent 
graph type.

Figure 10.16 With the help 
of a few graphic styles and 
paragraph styles, the fi nal 
graph is complete.

200620052004200320022001200019991998199719961995199419931992199119901989198819871986



Chapter 
ElevenExploring the World of 3D

You already know that in the arena of computer graphics, 

there are two playing fi elds: pixel-based graphics and vec-

tor-based graphics. It just so happens that in the world of 

3D, there is also an important distinction between pixels 

and vectors. When you think about 3D, imagery like that 

seen in blockbuster Hollywood movies and in animated 

feature fi lms comes immediately to mind. The tools used 

to create these realistic images are incredibly sophisti-

cated (and expensive), and they render shading, surface 

textures, and refl ections using pixels. In contrast, the 3D 

feature in Adobe Illustrator CS4 uses vector artwork to 

generate not just the 3D geometry of an object but also 

the lighting and shading.

This distinction is important, because you will fi nd that in no way does 

Illustrator replace applications like Autodesk 3ds Max or Maya. In fact, as 

you’ll soon learn, the 3D feature in Illustrator has its share of limitations. At 

the same time, the vector-based 3D functionality in Illustrator is extremely 

powerful—and useful—once you learn its strengths.

At fi rst blush, you can think about how 3D in Illustrator can assist with 

product packaging mock-ups and help give a logo that added touch. But 

the real power of 3D is how it can be applied to everyday creative tasks. 

Throughout this chapter, the creative side of 3D will become readily 

apparent.

333
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3D IN ILLUSTRATOR: WHAT IT IS
AND WHAT IT ISN’T
Few features in Illustrator are as fun to use as the 3D effect. You might want 

to clear your calendar for a few days so you have time to explore all the cool 

functionality you’re about to discover.

However, before you tie a bungee cord to your ankles and jump into the 

spectacular world of 3D, it’s important to realize just what the 3D effect in 

Illustrator is capable of and what its limitations are. In this way, you’ll get a 

better idea of what you can realistically expect from the 3D effect:

• The 3D effect in Illustrator is real 3D. Unlike 3D plug-ins or other 

vector-based applications that have 3D features (such as Macromedia 

FreeHand or CorelDRAW), the 3D effect in Illustrator isn’t some 

cheesy feature. Rather, Illustrator does real 3D rendering in a true 3D 

environment. Although the artwork that appears on the artboard is 2D, 

within the Effect dialog box the artwork exists in a 3D space where you 

can rotate and view it from any angle (Figure 11.1).

Figure 11.1 Once you’ve 
applied a 3D eff ect to a 
shape, you can choose to 
view it from any angle.
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• The 3D effect in Illustrator is vector-based. Illustrator applies 3D 

effects to vector objects, and the result is a vector object. Lighting and 

shading take place through the use of blends (more detail on this later). 

Illustrator does not use ray tracing—a pixel-based rendering technique 

that can create shading and lighting with refl ections and refractions.

• The 3D effect in Illustrator supports artwork mapping. The 3D 

effect has the ability to map 2D artwork onto the surface of 3D objects. 

Artwork that will be mapped onto a 3D surface must fi rst be defi ned as 

an Illustrator symbol.

• The 3D effect in Illustrator is self-contained. Because 3D in 

Illustrator is an effect, it applies to particular objects you have selected. 

Each object is treated as a separate entity and lives in its own individual 

3D world. This means separate 3D objects cannot interact with or 

intersect each other (like a rod that pierces a sphere). Additionally, each 

object maintains its own vanishing point. This limitation makes it diffi -

cult to create 3D compositions in which multiple objects share the same 

vanishing point (although using groups can make a difference).

• The 3D effect in Illustrator is proprietary. The 3D effect is an 

internal feature and is applicable only within Illustrator. You cannot 

export 3D geometry from Illustrator (although you can export the 2D 

representation of that artwork), and you cannot import 3D geometry 

from CAD or 3D modeling applications (such as Maya or even Google 

SketchUp). This also means the 3D support in Adobe Photoshop CS4 

Extended doesn’t work with 3D art made from Illustrator.

• The 3D effect in Illustrator is a live effect. As a live effect, the 3D 

features in Illustrator abide by the same rules as other effects. This 

means you can apply 3D effects to groups (which is important, as you’ll 

see later), you can save them as graphic styles, you can edit them easily, 

and you can expand them.

Many different uses come to mind when we think about using the 3D 

effect in Illustrator. Drawing boxes and bottles for product packaging 

concepts and mock-ups, as well as text headlines or logos with added 

dimension, are some examples. However, as you will see, the 3D effect in 

Illustrator can also serve in an extremely creative fashion. As you explore 

the different capabilities of the 3D effects, try to envision how you might 

use them to create illustrations or design elements. We will help by offering 

examples along the way, providing a spark for your creativity.

NOTE Because 
Illustrator does real 

3D rendering, performance is 
commensurate with system 
resources.
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LOOKING INSIDE THE 3D EFFECT
The 3D feature in Illustrator is extremely deep and comprises four compo-

nents, each serving a different purpose:

• Extrude & Bevel. The extrude effect adds dimension to an object by 

extending it and giving it depth. Although 2D objects have an X axis 

and a Y axis, an extruded object also adds a Z axis. A simple example is a 

square with just one side (front) that becomes a cube (Figure 11.2) with 

six sides (front, back, top, bottom, left, and right). A bevel is a chiseled 

effect you can add to the surface of an extruded object (Figure 11.3).

• Revolve. The Revolve effect adds dimension to an object by defi ning 

an axis and then revolving the shape around that axis. A simple example 

is a rectangle with just one side (front) that becomes a cylinder (Figure 
11.4) with three surfaces (side, top, and bottom).

Figure 11.2 When you start 
with a regular square (left), 
adding an Extrude eff ect 
results in a six-sided cube 
(right).

Figure 11.3 Bevels can 
add a chiseled appearance 
to an extruded object.

Figure 11.4 When you start 
with a regular rectangle 
(left), adding a Revolve 
eff ect results in a three-
sided cylinder (right).
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• Rotate. The Rotate effect doesn’t add dimension at all but simply allows 

you to rotate your object in 3D space (basically an extrude without the 

depth added). This allows you to apply perspective to an object using a 

3D reference (Figure 11.5).

• Artwork mapping. Artwork mapping is a feature used to render 2D 

artwork onto the surface of a 3D object (Figure 11.6).

Naturally, each of these four components is a full-blown feature and 

requires its own detailed instructions. However, before we get to that, 

you need to learn some general information about how the 3D effect in 

Illustrator works.

Using Fills and Strokes and the 3D Effect
To harness the depth of the 3D effect in Illustrator, you have to learn what 

makes the effect tick. The way in which you create and edit your vector 

shape affects how the 3D settings are applied to that shape. For example, 

take two identical shapes: One has a stroke applied, and the second has 

Figure 11.5 When you 
start with a regular square 
(left), adding a Rotate eff ect 
results in a shape that 
appears to have the 
perspective of 3D (right).

Figure 11.6 Once you’ve 
created regular artwork 
(left), you can map it onto 
the surface of a 3D object 
(right).

NOTE Illustrator allows 
artwork mapping 

only on objects with the 3D 
Extrude & Bevel or 3D Revolve 
eff ect applied. The 3D Rotate 
eff ect does not support 
artwork mapping.
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the stroke set to None (Figure 11.7). When the same 3D Extrude effect is 

applied to both objects, each assumes a different appearance (Figure 11.8).

Here’s what happens: Right before Illustrator applies 3D to an object, the 

effect breaks apart the elements internally and applies the 3D effect to each 

of the elements. When you have an object that has just a fi ll applied, the fi ll 

itself is extruded, and the extruded areas are shaded in the same color as the 

fi ll. However, if a stroke is applied to the object as well, Illustrator extrudes 

the fi ll and the stroke, and the appearance of the extruded areas shows the 

stroke color, not the fi ll color.

In fact, when you have a stroke applied, Illustrator is really extruding two 

separate objects—the fi ll and the stroke around it (Figure 11.9). If you 

change the Fill setting to None, you’ll be able to see right through the mid-

dle of the object, because then Illustrator is extruding only a stroke, not a fi ll 

(Figure 11.10).

Figure 11.7 These shapes 
are identical with the excep-
tion of the 1-point stroke 
applied to the one on the 
left.

Figure 11.8 The extruded 
area of the shape on the left 
takes on the appearance of 
the object’s stroke, whereas 
the shape on the right uses 
the appearance of the fi ll.

Figure 11.9 When an 
object with a fi ll and a 
stroke is extruded, you 
can think of the stroke 
as a slipcase for the fi ll.
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Another side effect to applying a 3D effect to an object with a stroke applied 

pertains to artwork mapping. You already know that artwork mapping 

allows you to apply 2D art to the surface of any 3D object. We’ll discuss 

exactly how artwork mapping is applied later in the chapter (see the section 

“Mapping Artwork to 3D Surfaces”), but one of the main tasks you’ll need 

to do with artwork mapping is choose on which surface of a 3D object you 

want your mapped artwork to appear (you can apply artwork to multiple 

surfaces, as you will learn later).

When you apply an Extrude effect to a rectangle with just a fi ll, the result is 

a 3D object that has six surfaces. However, if you apply a stroke to that rect-

angle, the result is a 3D object with 16 surfaces. This is because Illustrator 

counts all the surfaces generated by the fi ll as well as those generated by the 

stroke (the surfaces that appear along the inside of the stroke, even though 

they are not visible, are still counted as surfaces). Because of this, it can be 

diffi cult to choose from the numerous surfaces to fi gure out which one you 

want the artwork mapped onto.

Of course, sometimes you will want to apply a stroke to an object with a 3D 

effect, such as with extruded text. By adding a stroke to your text object, 

you can create text that is fi lled with one color but that is extruded using a 

different color (Figure 11.11). Chances are you won’t be mapping artwork 

onto your text, so this example is a good use of a stroke on a 3D object.

Figure 11.10 When no fi ll is 
present, Illustrator extrudes 
only the stroke, resulting in 
a hollow shape.

Figure 11.11 When 
extruding text, adding a 
stroke allows you to create 
a powerful contrast to the 
extruded eff ect.



CHAPTER 11: EXPLORING THE WORLD OF 3D340

In review, feel free to use strokes on your objects if you need them to 

achieve the look you want. However, be aware that adding strokes slows 

performance and makes artwork mapping a confusing process because of 

all the extra surfaces.

Editing a 3D Effect
Because 3D is a live effect in Illustrator, you can make edits to the original 

vector shape on the artboard, and the 3D effect updates accordingly. You 

can also change the color of the object, and the 3D effect automatically 

updates as well, including the shading of the object.

You know that you can click an effect listed in the Appearance panel to 

edit 3D effects that have already been applied to artwork. However, it’s 

important to remember that the artwork that appears on your artboard after 

you’ve applied a 3D effect is 2D. If you want to rotate a 3D object, don’t do 

it on the artboard using the usual transformation tools. Rather, click the 

3D effect in the Appearance panel, and rotate the object in the 3D Options 

dialog box. Changing the artwork on the artboard produces undesirable 

results (Figure 11.12). For more information on transforming artwork that 

has live effects applied, see the sidebar “Transforming Objects with Effects” 

in Chapter 7, “Working with Live Effects.”

Figure 11.12 What started 
as a water bottle (left) may 
not appear the same when 
you rotate it on the artboard 
(right). To rotate the bottle 
in 3D, you have to edit the 
3D eff ect.
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Applying the 3D Extrude & Bevel Effect
Now that you generally understand how the 3D effect works in Illustrator, 

you will learn how to apply the effect, determine all its settings, and, per-

haps most importantly, study a few practical examples of how you might use 

such an effect.

As we defi ned earlier, the Extrude & Bevel effect adds depth to an object. 

To apply this effect, select a vector object on the artboard, and choose 

Effect > 3D > Extrude & Bevel to open the 3D Extrude & Bevel Options 

dialog box. First, select the Preview check box in the dialog box so you can 

see what the 3D effect looks like as you adjust the settings. If you don’t have 

a large screen, it helps to position your artwork on one side of the screen 

before you apply the effect and to move the 3D Extrude & Bevel Options 

dialog box (when it opens) to the other side so you can see the preview on 

the artboard (Figure 11.13).

At this point, you are ready to begin experimenting with the settings in the 

dialog box. To make the feature more approachable, Adobe splits the dialog 

box into two parts. By default, only half the settings appear in the dialog 

box. By clicking the More Options button, you can expand the dialog box 

to show all the settings we will be talking about here (Figure 11.14).

Figure 11.13 Especially on 
smaller screens, it helps to 
keep your art positioned 
on the left side of the 
screen so you have room to 
preview the art while you 
make adjustments in the 
3D Extrude & Bevel Options 
dialog box.
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The 3D Extrude & Bevel Options dialog box is divided into three sec-

tions—Position, Extrude & Bevel, and Surface—each covering a different 

aspect of 3D.

Specifying the Position settings

The Position section of the 3D Extrude & Bevel Options dialog box lets 

you rotate your object within 3D space (on its X, Y, and Z axes) in order to 

control the view of your object. In 3D applications, the term camera is used 

to defi ne the view of the object (as if you were seeing the object through the 

lens of a camera; Figure 11.15).

The most distinctive element in the 3D Extrude & Bevel Options dialog 

box is what Adobe engineers affectionately call the track cube—a visual rep-

resentation of the position of your 3D object. The track cube acts much like 

a trackball, only it isn’t round (and hence it’s called the track cube). To adjust 

the position of your 3D object, simply click and drag the track cube. As you 

adjust the position, a wireframe preview appears on your screen, indicating 

how the object will appear (Figure 11.16). When you release the mouse, a 

full preview, with shading, appears.

Figure 11.14 By clicking 
the More Options button, 
you can expand the 3D 
Extrude & Bevel Options 
dialog box to see all the 
available settings.

NOTE You’ll always 
have to select the 

Preview check box when 
you open the dialog box. 
Adobe chose this behavior 
for performance reasons.

NOTE Most 3D appli-
cations allow you to 

change the position of the 
objects and the camera in a 
scene. Because each 3D eff ect 
lives within its own 3D world, 
the camera in Illustrator is 
always stationary, and you are 
adjusting the position of the 
object only.
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The track cube is more than just fun to play with—it also has some pretty 

cool functionality. The sides of the cube are shaded in different colors to 

help you easily identify the position of your object: The front side is blue, 

the back is a dark gray, the top and bottom are light gray, and the left and 

right sides are a neutral gray.

Figure 11.15 The Position 
setting allows you to rotate 
the view of an object, as 
if you were looking at the 
object through the lens of a 
camera.

Figure 11.16 As you adjust 
the track cube, a wireframe 
preview shows you what 
your art will look like.
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In addition, as you move your pointer over the edges of each side, you’ll 

notice the edges highlight in red, green, and blue (Figure 11.17). Clicking 

and dragging these highlighted edges constrains the object to rotate along 

only one axis, making it easier to control the position of your object. Hold-

ing the Shift key while dragging the track cube simulates a rotation of the 

fl oor beneath the object, and dragging the outer ring of the track cube 

constrains the rotation in the other direction.

Along the right side of the track cube are three values representing the 

three axes that a 3D object needs. Each axis can have a value of –180 to 180 

degrees (for a total of 360). You’ll notice that the highlighted, colored track 

cube edges match the color shown for the icon in each of these three axes.

Appearing directly above the track cube is a pop-up menu that lists preset 

positions from which you can choose. Choosing one of these presets posi-

tions your object in a variety of different views. Unfortunately, you cannot 

defi ne your own presets here, but these presets can make it easy to apply 

consistent views throughout your artwork (Figure 11.18).

Last, you can add perspective to your object by dragging the Perspective slider. 

This setting mimics the natural lens distortion that occurs if you move your 

object closer to the lens of the camera (Figure 11.19). If you hold the Shift 

key while adjusting the slider, you will see your preview update in real time 

(system performance permitting). Using the Shift key to generate real-time 

previews actually works when using any slider in the 3D dialog box.

Figure 11.17 Moving your 
pointer over the edges of 
the track cube allows you to 
adjust one axis at a time.

NOTE Illustrator uses a 
track cube instead of a 

trackball because it is diffi  cult 
to diff erentiate between the 
multiple sides (front, back, 
and so on) of the 3D object 
using a sphere as a reference.
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Figure 11.18 Choosing one 
of the preset position set-
tings in Illustrator can make 
it easy to position several 
objects with the same view, 
such as when you are creat-
ing isometric art.

Figure 11.19 Adjusting the 
Perspective slider can add 
natural distortion to your 
object.
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You will notice that as you increase the Perspective value, your 3D object 

becomes darker. Think about it: As you move an object closer to the lens 

of a camera, less light is available to refl ect off the object, and the object 

becomes darker. Soon we’ll talk about surface and lighting options, which 

you can use to adjust the lighting of the object.

Specifying the Extrude & Bevel settings

The Extrude & Bevel section of the 3D Extrude & Bevel Options dialog 

box allows you to defi ne the depth of your object as well as how the edges 

of your 3D object appear, also known as the bevel.

To adjust the depth of your object, enter a numeric value, click and drag the 

Extrude Depth slider, or enter a value in the fi eld. If you hold the Shift key 

while adjusting the slider, you can preview the Extrude Depth setting in real 

time. The values used for the Extrude Depth settings are shown in points, 

although you can specify values in inches or any other format, and Illustra-

tor will do the conversion for you. You can specify an extrude depth up to 

2,000 points (a tad more than 27.75 inches). Speaking of measurements, 

when you’re trying to create package mock-ups, it’s always a good idea to 

work at actual size or in scale to ensure that your 3D object is proportioned 

correctly.

By default, Illustrator creates closed extruded objects from fi lled paths. 

However, you can also specify the extrude setting you want to use so it 

shows only the extrusion and not the actual face or back of the shape. 

Toggling between the two Cap settings lets you control whether your 

objects have a solid or hollow appearance (Figure 11.20).

When you extrude an object, you can almost think of copying your object, 

offsetting the copy from the original, and then connecting the two with 

TIP While the 3D 
Extrude & Bevel 

Options dialog box is open, 
press the Option (Alt) key, 
and the Cancel button turns 
into a Reset button. Clicking 
the Reset button resets the 
values in the dialog box so 
you can start fresh.

TIP When you specify 
a bevel, sometimes you 

might see rendering errors 
caused by self-intersecting 
paths. You can usually allevi-
ate the problem by specifying 
a smaller bevel size, using a 
less complex bevel, or adjust-
ing the position or perspec-
tive settings.

Figure 11.20 The Cap 
setting appears as two icons. 
The shaded icon indicates 
the selected setting.
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straight lines (Figure 11.21). A bevel is defi ned when you connect the two 

shapes with a line that is not straight, and therefore, the extrusion follows 

the direction of the line (Figure 11.22).

Figure 11.21 A normal 
extrude is created by con-
necting the front and back 
faces of an object with a 
straight line.

Figure 11.22 An extrude 
with a bevel is created by 
connecting the front and 
back faces of an object with 
a line that is not straight.

Illustrator provides 10 bevels, which you can choose from the Bevel pop-up 

menu. The Height setting controls the size of the bevel. You can also choose 

whether you want the bevel to be subtracted from the size of the original 

shape or whether you want it added to the shape (Figure 11.23).

Figure 11.23 Toggling 
between Bevel Extent In and 
Bevel Extent Out options 
can aff ect the overall size of 
your object.
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Specifying the Surface settings

The fi rst two settings of the 3D Extrude & Bevel Options dialog box, Posi-

tion and Extrude & Bevel, defi ne the actual geometry of the shape. The 

Surface section enables you to control the appearance of the surface of your 

object. This includes the type of shading used, and it indicates how light 

will interact with the object. If you talk to photographers, they will tell you 

that, above all, lighting is of utmost importance. As you’ll fi nd out, the same 

is true with 3D.

You may have noticed that when you fi rst selected the Preview check box 

to see what your 3D effect looks like on the artboard, the object changed 

somewhat in color. For example, if your original object was fi lled with a 

bright yellow color, the object might now show a darker, muddy yellow 

color instead. By default, 3D objects in Illustrator are rendered with a single 

light source from the upper right and are shaded by adding black to the 

original fi ll color, giving a darker appearance.

Using the Surface pop-up menu, you can choose from one of four options 

to specify the type of surface you want your 3D object to have. The surface 

type you choose also defi nes what other surface settings are available for 

your object and ultimately how you see the fi nal 3D object (Figure 11.24).

Figure 11.24 From left to 
right, this art demonstrates 
examples of Plastic Shading, 
Diff use Shading, No 
Shading, and Wireframe.
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The four surface settings are as follows:

• Plastic Shading. You use the Plastic Shading setting when you want 

your object to have a highly refl ective surface, such as glass or metal. 

This shading option lets you adjust and control a lighting highlight on 

the object.

• Diffuse Shading. You use the Diffuse Shading setting when you want 

your object to have a matte surface, such as paper or wood. This shad-

ing option does not have a highlight setting.

• No Shading. The No Shading option disables shading completely and 

renders each side of your object using the solid color defi ned for the 

object. Granted, this option doesn’t leave your object with a 3D appear-

ance, but if your intent is to expand the 3D effect so that you can edit 

the geometry of the shape, this setting could be helpful.

• Wireframe. The Wireframe surface setting removes all fi lled areas, or 

walls, from your object and displays the object’s 3D wireframes. The 

result is technical and rather cool, and it is useful for creating design 

elements. The rules that make up the wireframe are set to .25 point in 

width and cannot be changed without fi rst expanding the 3D effect.

On the left side of the Surface section of the dialog box is a lighting sphere, 

which is used to control how light is directed at your 3D object. A small 

white circle indicates the light source, and you can drag it to control the 

direction of the light (Figure 11.25). As you move the light source, you can 

hold the Shift key to see the shading preview in real time. To add lights (you 

can add up to 30 of them), click the New Light icon that appears directly 

below the sphere, and to delete a selected light, click the Delete Light icon. 

You can also send lights behind an object by clicking the Move Selected 

Light to Back of Object icon.

Figure 11.25 You can drag 
lights across the sphere to 
adjust the shading of the 3D 
object.
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To the right of the lighting sphere are fi ve settings that defi ne how the 

surface and the lighting interact with each other. Depending on the surface 

option you select, you may see all or only some of these options:

• Light Intensity. The Light Intensity setting controls the strength, 

or brightness, of the selected light. Think of this setting as a dimmer 

switch—the closer the value is to 100, the brighter the light; the closer 

the value is to 0, the dimmer the light. You can use this setting to 

apply different intensity values for each selected light.

• Ambient Light. The Ambient Light setting is a general lighting setting 

that affects the entire surface of the object. By default, this is set to 50%, 

which is a neutral setting. Think of this setting as a global lightness/

darkness setting for the object itself, not for the individual lights.

• Highlight Intensity. The Highlight Intensity setting controls the con-

trast or transition between the surface and the highlight. Higher values 

produce sharper highlights, indicating a more refl ective surface, like 

glass. This highlight setting is applied globally to all highlights on the 

object (you can’t set this differently for different lights). This setting is 

available only when you choose the Plastic Shading option.

• Highlight Size. The Highlight Size setting controls the size of the 

highlights on a 3D object. This highlight setting is applied globally to 

all highlights on the object (you can’t set this differently for different 

lights). This setting is available only when you choose the Plastic 

Shading option.

• Blend Steps. The Blend Steps setting is an extremely important 

setting, and therefore, it’s diffi cult to understand why it appears listed 

at the bottom of the dialog box, grouped with other lighting settings 

and seemingly hidden. Illustrator uses blends to create shading, not 

gradients (blends are covered in depth in Chapter 2, “Selecting and 

Editing Artwork”). A blend consists of a start object and an end object, 

with multiple “steps” in between. If there are too few steps in a blend, 

you can see the individual steps, which results in shading that appears 

posterized and not smooth (Figure 11.26). By default, Illustrator speci-

fi es 25 blend steps, which is fi ne for viewing art on a computer screen 

or for printing smaller 3D shapes; however, for the best results in a 

high-resolution print workfl ow, a blend step setting of 200 or more is 

necessary. The reason why the default setting in Illustrator is set to 25 
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is strictly for performance reasons. A higher Blend Steps setting results 

in much slower 3D performance, so it’s a good idea to work with the 

default setting and then increase it right before you send your fi nal fi le 

to the printer.

Illustrator also offers a pop-up menu from which you can choose a shading 

color. By default, Illustrator adds black to your object to simulate shading; 

however, you can choose Other and pick any color from the Color Picker or 

from existing swatches in your document to use as a shading color instead. 

If you use colors other than black for shading, the result will be as if you 

were casting a colored light on your object.

Using Spot Colors in 3D Objects

If your object is fi lled with a spot color and if you use black or a spot color 

as your shade color, selecting the Preserve Spot Colors option causes the 

overprint function to be utilized when you’re creating blends for shading. 

The result is an object that prints and separates correctly using the spot 

colors. You may have to view your fi le with Overprint Preview selected 

if you want to preview the art correctly on your screen.

Figure 11.26 Without 
enough steps in a blend, 
you can see “stair-stepping” 
side eff ects (referred to 
as banding) rather than a 
smooth transition of color.

TIP If you want to use 
gradients to do your 

own shading (which 
decreases fi le size when 
you’re exporting art to Flash), 
choose the No Shading 
option, expand the appear-
ance of the object, and then 
manually fi ll the shapes with 
gradients.
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Creating 3D Geometry—Draw Visible Faces

Although it’s true that the 3D feature in Illustrator is doing real 3D render-

ing in a 3D world, that’s true only while a 3D effect dialog box is open on 

your screen. Once you click OK, Illustrator creates a 2D representation of 

that graphic and displays it on your artboard (the artboard is only 2D). If 

you want to view your object differently, you can always edit the effect by 

clicking it in the Appearance panel, at which time the dialog box opens. At 

this point, you’re in the 3D world again, where you can rotate the object in 

space and then click OK to create the 2D representation that is displayed on 

the artboard.

Because Illustrator knows that the end result will be a 2D drawing, it saves 

processing time by calculating and drawing only the visible sides of an 

object. For example, if you were to create a rectangle and extrude it to create 

a cube, at any one time you would be able to view only three of the six sur-

faces. You can see this for yourself by following a few quick steps to expand 

the appearance of a 3D object:

1. Using the Rectangle tool, draw a 2-inch square.

2. Give the square a solid color fi ll of choice and a stroke of None.

3. Choose Effect > 3D > Extrude & Bevel.

4. Leave the position set to Off-Axis Front, set Extrude Depth to 2 inches, 

and click OK to apply the effect.

5. Choose Object > Expand Appearance to expand the 3D effect.

6. Deselect the object so nothing is selected.

7. Switch to the Direct Selection tool, and move each panel of the 

cube. You’ll see that only the visible surfaces of the cube are there 

(Figure 11.27).

Figure 11.27 A regular 
square (left), with an Extrude 
eff ect applied (center), and 
then expanded with the 
front face removed (right).
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Creating 3D Geometry—Draw Hidden Faces

Sometimes, however, you might want the full geometry of the 3D object ren-

dered. For example, if you wanted to expand the cube you created to modify 

the 3D object on your own, you might want all the surfaces to be available. 

For this reason, Illustrator includes the Draw Hidden Faces option, which 

forces Illustrator to render the entire object, even the surfaces that aren’t 

visible. Again, you can easily see the difference by following a few short 

steps using the Draw Hidden Faces option:

1. Using the Rectangle tool, draw a 2-inch square.

2. Give the square a solid color fi ll of choice and a stroke of None.

3. Choose Effect > 3D > Extrude & Bevel.

4. Leave Position set to Off-Axis Front, and set Extrude Depth to 

2 inches.

5. Click the More Options button in the 3D Extrude & Bevel Options 

dialog box, and select the Draw Hidden Faces check box.

6. Click OK to apply the 3D effect.

7. Choose Object > Expand Appearance to expand the 3D effect.

8. Deselect the object so nothing is selected.

9. Switch to the Direct Selection tool, and move each panel of the cube. 

You’ll see that all the surfaces of the cube are there, even those hidden 

from view (Figure 11.28).

As you learn more about the 3D effect, you’ll fi nd the Draw Hidden Faces 

option has other uses as well.

Figure 11.28 A regular 
square (left), a regular 
square with an Extrude 
eff ect applied with Draw 
Hidden Faces selected 
(center) and then expanded, 
and with the front face 
removed (right).
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Creating a Photorealistic Button

Now that you’ve learned the different settings for the 3D Extrude & Bevel 

effect, it’s time to put that knowledge to good use. In this exercise, you will 

create a realistic button (the kind you would fi nd sewn to a shirt), but don’t 

worry—you don’t need to know how to draw. The Illustrator 3D effect 

allows you to create this button easily by drawing simple shapes.

  1. Using the Ellipse tool, create a .25-inch circle.

  2. Fill the circle with a color of choice, and set the Stroke setting to None.

  3. With the circle selected, double-click the Selection tool in the Tools 

panel to open the Move dialog box.

  4. Specify a Horizontal value of .375 inch and a Vertical value of 0, and 

click the Copy button. This gives you two buttons.

  5. Now, select both circles, and double-click the Selection tool to open 

the Move dialog box again.

  6. This time, specify a Horizontal value of 0 and a Vertical value of 

.375 inch, and click the Copy button. You now have four circles 

(Figure 11.29).

 7. Select all four circles, and click the Unite button in the Pathfi nder 

panel. This combines the four circles into a single shape.

  8. Using the Ellipse tool, create a 2-inch circle.

  9. Give the large circle the same fi ll as the other small ones and a stroke 

of None.

10. With the large circle selected, choose Object > Arrange > Send to Back.

11. Using the Selection tool, select all fi ve circles, and open the Align panel.

Figure 11.29 Once you’ve 
created the duplicates, you 
should see four circles.
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12. Click the Horizontal Align Center button once and the Vertical Align 

Center button once. Because you combined the four smaller circles 

with the Unite function, they are centered nicely within the larger circle 

(Figure 11.30).

13. With all fi ve circles still selected, open the Pathfi nder panel, and click 

the Minus Front button. This “cuts” the smaller circles out from the 

larger one, allowing you to see through the button. This action also 

combines all fi ve circles into a single path, allowing you to apply a single 

3D effect to all the circles at once (Figure 11.31).

Figure 11.30 All the circles, 
centered, now make up the 
shape of a button.

Figure 11.31 Once you’ve 
subtracted the smaller 
circles from the larger one, 
you’re left with the art 
that you will use to create 
a button.
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14. With the button artwork selected, choose Effect > 3D > Extrude & 

Bevel, and select the Preview check box.

15. Set Extrude Depth to .25 inches, and set the bevel to Rounded.

16. Adjust the position to your liking, and click OK to apply the effect 

(Figure 11.32).

Because 3D is applied as a live effect, you can change the color of the button 

simply by applying a different fi ll color to the shape. Additionally, you can 

click the effect in the Appearance panel to edit it and change the position of 

the button so you can view it from virtually any angle (Figure 11.33). This 

is a great example of how you can use the 3D Extrude & Bevel effect in a 

creative way, allowing you to easily create design elements that might other-

wise be diffi cult to draw.

Figure 11.32 A wireframe 
preview allows you to posi-
tion your 3D object with 
precision.

Figure 11.33 Once you’ve 
created the button in 3D, 
you can change its fi ll color 
and position so you can 
view it from any angle.
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Applying the 3D Revolve Effect
As we briefl y discussed earlier, the Revolve effect adds dimension to an 

object by rotating a 2D shape around an axis. To apply this effect, select a 

vector object on the artboard, and choose Effect > 3D > Revolve to open 

the 3D Revolve Options dialog box. First, select the Preview check box in 

the dialog box so you can see what the 3D effect looks like as you adjust the 

settings. If you don’t have a large screen, it helps to position your artwork 

on one side of the screen before you apply the effect and to position the 3D 

Revolve Options dialog box, when it opens, to the other side so you can see 

the preview on the artboard.

At this point, you are ready to begin experimenting with the different set-

tings in the dialog box. As with the 3D Extrude & Bevel Options dialog 

box, the 3D Revolve Options dialog box has a More Options button, which 

expands the dialog box to reveal all the settings for the feature (Figure 11.34).

The fully expanded 3D Revolve Options dialog box is divided into three 

sections: Position, Revolve, and Surface. The Position and Surface sections 

are identical to those in the 3D Extrude & Bevel Options dialog box, so we 

will focus on just the Revolve section here.

Figure 11.34 Similar to the 
3D Extrude & Bevel Options 
dialog box, you can expand 
the 3D Revolve Options 
dialog box to reveal more 
options.
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Specifying the Revolve Settings

The Revolve section of the 3D Revolve Options dialog box allows you to 

defi ne exactly how your object will appear when revolved around an axis. 

Before we discuss the settings, it’s important you fi rst understand how the 

3D Revolve effect in Illustrator works. By default, the leftmost point of the 

selected object becomes a vertical axis for the effect. An object can have only 

one axis, and the axis is always vertical. Unfortunately, Illustrator doesn’t 

preview or show you this axis onscreen, so think of it as an imaginary axis 

(Figure 11.35).

Now that you understand how the 3D Revolve effect works, you can learn 

how to use the remaining settings in the Revolve section of the dialog box:

• Angle. The Angle setting determines how far around the axis the art-

work travels. By default, the angle is set to 360, which creates a shape that 

goes completely around the axis, resulting in a closed shape. Smaller val-

ues result in an object that seems to have a piece missing (Figure 11.36). 

You may fi nd the Angle setting useful when you want to create a cutaway 

view to the inside of an object or when you want to display just a portion 

of an object, like a single slice of pie (Figure 11.37).

Figure 11.35 By default, 
the 3D Revolve eff ect in 
Illustrator uses the leftmost 
side of an object as the 
vertical axis.

Figure 11.36 Using a large 
Angle setting can leave you 
with almost an entire pie…

Imaginary Axis
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• Cap. Similar to the Cap setting in the 3D Extrude & Bevel Options 

dialog box, here you can toggle between objects that have either a solid 

appearance or a hollow appearance.

• Offset. The Offset setting is specifi c to the invisible axis. An Offset 

value repositions the axis and effectively allows you to revolve an object 

from a point other than its leftmost edge. The result is an object that is 

hollow (Figure 11.38). In addition, you can specify whether the axis is 

offset from the left or right side of the object.

Drawing a sphere

Now that you’ve learned how the 3D Revolve effect works, you can learn 

how to create a simple object—a sphere (Figure 11.39).

Figure 11.37 …or you can 
be left with just a small slice 
of pie with a small Angle 
setting.

Figure 11.38 Adding an 
Off set value to the 3D pie 
results in a pie that resem-
bles a Danish pastry with a 
hollow center.

Figure 11.39 From left 
to right: creating a circle, 
deleting an anchor point 
to create a semicircle, and 
applying a 3D Revolve eff ect 
to create a sphere.
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1. Using the Ellipse tool, draw a 2-inch circle.

2. Give the circle a fi ll of choice and a stroke of None.

3. Select the Direct Selection tool, and deselect the circle.

4. Then select just the left anchor point of the circle by clicking it once.

5. Once the anchor point is selected, press the Delete key on your key-

board to remove the selected anchor point and the paths connected 

to it. You will be left with half a circle.

6. With the semicircle selected, choose Effect > 3D > Revolve. The 

default settings are fi ne for this exercise.

7. Click OK to apply the effect.

The most important part of this exercise was deleting half the circle. As we 

mentioned earlier, the left side of the object is what defi nes the invisible axis 

on which the object revolves. If you were to apply a 3D Revolve effect to a 

full circle, the result would be quite different (Figure 11.40). In fact, apply-

ing the 3D Revolve effect with an offset value specifi ed would produce a 

doughnut shape, which is nice but not what you intended (Figure 11.41). 

Getting hungry?

Figure 11.40 It’s important 
to pay attention to where 
the vertical axis is. With a 
semicircle (left), the vertical 
axis is positioned to create 
a sphere. With a full circle 
(right), though, the vertical 
axis is positioned to create a 
doughnut shape.

Figure 11.41 Starting with 
a full circle (left) and speci-
fying an off set for the axis 
(center) results in a dough-
nut shape (right).
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Drawing an Exercise Barbell

To get your mind off food for a while, here’s a little mental exercise that uses 

the 3D Revolve effect and incorporates the use of groups—an extremely 

important aspect of creating complex 3D shapes (see the sidebar “The Impor-

tance of Applying 3D Effects to Groups” later in this chapter). In this 

example, you will create a group of shapes that will result in a great-looking 

barbell. Again, you don’t want to focus on drawing a barbell as much as try-

ing to build the shapes that will eventually help the Illustrator 3D feature 

draw it for you (it’s always preferable to let the computer do all the hard work 

while you relax and rack up the billable hours).

To create the barbell, perform the following steps:

1. Choose View > Show Rulers, and drag out a vertical guide (anywhere 

on your screen is fi ne).

Although creating a guide isn’t necessary, you will fi nd that this vertical 

guide will help you visualize where the invisible axis will be. In addi-

tion, the guide will help you align the objects so they are all aligned to 

the same left edge.

Remember when you used ordinary circles to create a button using the 

Extrude effect? Well, this time, you’re going to use ordinary rectangles 

to create your barbell.

2. Use the Rectangle tool to create a rectangle with a width of .25 inches 

and a height of 3.25 inches.

3. Give the rectangle a fi ll of 60K and a stroke of None. This shape will be 

the handle for your barbell.

4. Position the rectangle so that its left edge touches the vertical guide you 

created in the previous step (Figure 11.42).

Figure 11.42 Aligning the 
rectangle to a guide will 
help you visualize where the 
vertical axis will be.
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  5. Create a second rectangle with a width of 1.25 inches and a height of 

.25 inches.

  6. Give the rectangle a fi ll of 25K and a stroke of None. This shape will 

be one of the weights that appear on your barbell.

 7. Choose the Selection tool, and select both rectangles.

  8. Then, click the larger rectangle once, and open the Align panel.

  9. Click the Horizontal Align Left button once and the Vertical Align 

Bottom button once.

10. Then select just the smaller rectangle, and double-click the Selection 

tool in the Tools panel to open the Move dialog box.

11. Specify a value of 0 for Horizontal and .25 inch for Vertical, and click 

OK (Figure 11.43).

12. Select the small rectangle, and double-click the Selection tool to open 

the Move dialog box.

13. Specify a value of 0 for Horizontal and .375 inch for Vertical, and click 

the Copy button. You will now see two stacked rectangles. These will 

be the weights that appear on one side of the barbell.

14. To create the weights that will appear on the opposite side of the 

barbell, select both small rectangles, and open the Move dialog box 

once again.

Figure 11.43 The fi rst two 
rectangles are in position. 
Notice how they both are 
aligned to where the vertical 
axis will be.
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15. Enter a value of 0 for Horizontal and 2.125 inches for Vertical, and click 

the Copy button. You now have all the shapes necessary to create your 

3D shape (Figure 11.44).

Figure 11.44 All the neces-
sary shapes are now created 
and aligned correctly.

16. Use the Selection tool to select all the objects, and choose Object > 

Group. This will allow the 3D effect to treat all the objects as one unit 

so they all share a single vertical axis.

17. With the group selected, choose Effect > 3D > Revolve, and select the 

Preview check box.

18. Edit the position of the object to your liking using the track cube, and 

then click OK to apply the effect (Figure 11.45).

Figure 11.45 Adding a 
Perspective setting can 
add a touch of realism to 
your barbell. Try adding 
more lights and increasing 
the highlight intensity and 
blend steps to get a more 
metallic look.
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The most important part of this exercise is to try to visualize where the 

invisible axis is. When you think of a barbell, you may think of it as you 

normally see it—lying on the ground in a horizontal format. Because the 

Illustrator Revolve effect always uses a vertical axis, you had to think of the 

barbell as standing on its side. Once it’s created, you can use the track cube 

to rotate it into any position or orientation you need.

The examples you’ve tried so far should help fuel your creativity and give 

you the information you need to create complex 3D objects on your own.

The Importance of Applying 3D Eff ects to Groups

When applying any 3D eff ect, it’s important to understand its limitations so you can fi gure out how to make it 
do what you want. Previously in this chapter, we stated that the Illustrator 3D eff ects have two main limitations: 
3D objects cannot intersect each other, and each 3D object lives in its own 3D world. Hence, each object main-
tains its own individual vanishing point or invisible axis. Basically, multiple objects in your document cannot 
share a single vanishing point, share the same perspective, or revolve around the same axis.

If you were paying attention in Chapter 5, “Organizing Your Artwork,” you remember that eff ects produce a 
diff erent appearance when applied at the group or layer level instead of at the object level. Because 3D is a 
live eff ect, the same rules for how groups work apply here as well. If you apply a 3D eff ect at the group level, 
all objects inside that group can share the same vanishing point or perspective.

In the example of the barbell you just created, you were able to create a single axis that all the objects shared 
by grouping all the objects together before applying the 3D eff ect. Had you selected the objects in the fi le and 
applied the 3D Revolve eff ect without fi rst creating a group, the result would be diff erent and not what you 
would expect (Figure 11.46).

Figure 11.46 If you take the same barbell 
example but skip the step that collects all 
the shapes within a single group, the result 
is quite diff erent.
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Applying the 3D Rotate Effect
The Revolve effect doesn’t add dimension to an object. Rather, the effect 

allows you to position a 2D object in a 3D space. Basically, the 3D Rotate 

effect does the same as the 3D Extrude effect without adding any depth. To 

apply this effect, select a vector object on the artboard, and choose Effect > 

3D Rotate to open the 3D Rotate Options dialog box. The settings for this 

3D effect are identical to those we’ve already discussed, although take note 

that the 3D Rotate effect is limited to far fewer options (Figure 11.47). 

Most notably, you can specify only the Diffuse Shading or No Shading 

option, there are no bevels, and there is no support for artwork mapping 

(which we’ll cover next).

The 3D Rotate effect can be useful for applying distortion to artwork, such 

as making artwork look as if it’s mounted on a billboard. It also enables you 

to add perspective to your artwork.

Figure 11.47 Although 
there is a More Options 
button in the 3D Rotate 
Options dialog box, you’ll 
fi nd it doesn’t really off er 
that much.



CHAPTER 11: EXPLORING THE WORLD OF 3D366

Mapping Artwork to 3D Surfaces
One of the features that really sets the Illustrator 3D effect apart from the 

3D effects in other vector applications is the ability to map 2D artwork onto 

the surface of a 3D object. This method of combining 2D and 3D graphics 

is called artwork mapping.

So that you understand what artwork mapping really is, let’s take a closer 

look at a 3D cube. As we discussed earlier in the chapter, a 3D cube has six 

surfaces. Each of these surfaces is treated as a separate entity, and artwork 

mapping is the process of placing artwork on these surfaces (Figure 11.48).

You need to know a few facts before working with artwork mapping:

• Artwork must fi rst be defi ned as a symbol before it can be mapped to a 

3D surface. This is actually pretty cool because as you modify a symbol, 

you will see it automatically update on any 3D surfaces. Refer to 

Chapter 9, “Drawing with Effi ciency,” for detailed information on how 

to create and modify symbols.

• You can’t map (wrap) a single symbol across multiple surfaces of a 3D 

object. If your 3D object has multiple surfaces, you can map symbols 

to each side individually (Figure 11.49).

Figure 11.48 Starting 
with a normal square, a 3D 
Extrude eff ect produces a 
cube with six surfaces. When 
2D artwork is placed onto 
these surfaces, the result is 
a 3D object with artwork 
mapping.

Figure 11.49 To create the 
appearance of artwork that 
wraps around multiple sides 
of an object, you have to 
create multiple symbols 
and map each section 
separately.
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• When rendering a 3D object, Illustrator uses corner anchor points to 

defi ne a new surface. Smooth anchor points will not defi ne a new surface. 

When drawing your art, carefully specifying where corner or smooth 

anchor points appear on your path gives you greater control over how 

many surfaces are created and where they appear (Figure 11.50).

• Stroked objects make things more complicated. As you learned earlier 

in the chapter, objects with fi lls and strokes applied result in an object 

that has many more surfaces, which makes it diffi cult to work with. 

When you’re creating a 3D object that will have artwork mapped to it, 

it’s best to avoid using stroked paths.

• Although the 3D effect in Illustrator produces vector results, some-

times the 3D effect has to rasterize mapped artwork. If your mapped 

artwork contains gradients or raster images (such as those placed from 

Photoshop), Illustrator renders them at the resolution that is set in the 

Figure 11.50 By using cor-
ner anchor points at certain 
points on the path of this 
profi le of a water bottle, you 
can specify several surface 
areas to which you can 
map art.



CHAPTER 11: EXPLORING THE WORLD OF 3D368

Document Raster Effects Settings dialog box. Even if your mapped art 

contains a high-resolution Photoshop fi le, Illustrator resamples it to 

match the resolution set in the Document Raster Effects Settings dialog 

box. For best results, make sure the resolution setting in this dialog box 

is high enough for your output needs. Refer to “Massaging Pixels in 

Illustrator” in Chapter 7 for more information about the settings in this 

dialog box.

Specifying Mapped Artwork
To map artwork onto the surface of a 3D object, you must fi rst apply a 3D 

effect to an object. Then, from either the 3D Extrude & Bevel Options dia-

log box or the 3D Revolve Options dialog box, click the Map Art button to 

open the Map Art dialog box (Figure 11.51). If the Preview check box in 

the resulting Map Art dialog box isn’t selected, select it so you can see what 

your mapped artwork will look like as you adjust it.

Before you can map art onto your object, you have to choose onto which 

surface of the object you want to place your artwork. At the top of the 

Map Art dialog box, the buttons with arrows allow you to navigate or step 

through each of the surfaces of your object. As you step through each sur-

face, Illustrator displays the selected surface in the center of the Map Art 

dialog box. In addition, Illustrator tries to help you identify the selected 

surface by highlighting it with a red outline on the artboard (Figure 11.52). 

Depending on the color of your object, this red outline could be helpful, or 

it could be barely visible.

Figure 11.51 The Map Art 
button appears directly 
below the Cancel button in 
the 3D Revolve Options or 
3D Extrude & Bevel Options 
dialog box.
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The surface that appears in the Map Art dialog box is shaped as if it is laid 

fl at. You’ll notice as you step through the different surfaces on your object 

that some show a light gray background whereas others show a dark gray 

background. Some surfaces may even show a background that is dark gray 

only in certain areas. This is Illustrator letting you know which surfaces, or 

which parts of a surface, are not visible or are hidden from view (Figure 
11.53). As you would expect, if you choose to use the track cube to view 

your object from a different perspective, the shaded surface areas in the Map 

Art dialog box update accordingly.

Once you’ve chosen the surface you want to map art onto, use the Symbol 

pop-up menu to choose a symbol. The selected symbol appears on the sur-

face area in the Map Art dialog box with a bounding box. You can drag the 

symbol to position it to your liking on the surface, and you can also drag the

Figure 11.52 Illustrator 
tries to help you iden-
tify each of the surfaces, 
although the alignment of 
the red outlines isn’t always 
perfect on the artboard.

Figure 11.53 This surface, 
which is the section that 
connects the body and 
neck of the water bottle, 
has both shaded and non-
shaded sections.

TIP It’s easier if you 
create your symbols at 

the correct size before you 
map them to a surface; this 
way, you won’t have to worry 
about getting just the right 
size or position in the Map Art 
dialog box.
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handles to resize it (Figure 11.54). As you adjust the position of the symbol, 

you will see the preview update on the actual 3D object on the artboard. 

Alternatively, you can use the Scale to Fit button at the bottom of the Map 

Art dialog box to have Illustrator resize your symbol to fi t to the surface, 

although it does so nonproportionally.

Once you’re happy with the size and position of your symbol on the selected 

surface, use the arrows at the top of the dialog box to navigate to another 

side to map additional symbols, as needed. At any time, you can click the 

Clear button to remove a symbol from a selected surface, or you can click 

the Clear All button to remove symbols from all surfaces at once.

By default, Illustrator calculates shading and lighting only for the actual sur-

face of a 3D object, not artwork that is mapped to a 3D surface. Illustrator 

does this purely for performance reasons. We mentioned earlier that 

Illustrator uses blends to calculate shading, and the process of breaking 

down intricately mapped artwork and shading each element with blends 

takes quite a bit of processing. However, to get a realistic appearance, most 

likely you will want your mapped artwork to be shaded, even if it takes a 

bit longer to do so. Selecting the “Shade Artwork (slower)” check box forces 

Illustrator to shade both the surface of your object and the mapped artwork. 

Figure 11.54 You can move 
and rotate a symbol so that 
it appears as you need it to 
on the surface of the object.

NOTE A surface can 
contain only one sym-

bol. If you want multiple art 
items to appear on a single 
surface, you have to defi ne 
a single symbol with all the 
elements in it.
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This setting applies to the entire object, and you don’t need to turn it on for 

each individual surface.

The last setting in the Map Art dialog box is the Invisible Geometry check 

box; invisible geometry is a slightly technical phrase. When this option is 

selected, Illustrator hides the actual 3D object on your artboard and displays 

just the mapped artwork. The result is a symbol that appears to fl oat in space. 

A good example of when this setting might be useful is when you want to 

make text appear as if it were wrapped around a sphere (Figure 11.55).

When you’re happy with your artwork mapping settings, click OK to accept 

the settings in the Map Art dialog box, and then click OK to close the 3D 

dialog box.

What If…You Add Transparency to 3D?
Throughout this entire book, you’ve seen how transparency is integrated 

into the Illustrator feature set with features such as soft drop shadows and 

opacity masks. You might ask yourself, “What if I added transparency to a 

3D object?” After all, wouldn’t it be cool to make a 3D object that was also 

transparent so that you could see right through to the back of the object?

Have no fear—as if the 3D effect weren’t cool enough, you can also create 

transparent 3D objects—but you’ll have to address two issues in order to get 

transparency and 3D to work together.

Figure 11.55 You can map 
artwork around a sphere 
(left), and by using the 
Invisible Geometry option in 
the Map Art dialog box, you 
can hide the sphere leaving 
just the artwork (right).
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Applying Transparency

As you learned earlier in the chapter, before Illustrator applies a 3D effect to 

an object, it breaks the object down into its components (fi lls and strokes). In 

that process, transparency attributes are tossed out, and just the appearance 

remains. For example, if you set an object to 50% opacity, the 3D effect sets 

the object to a 50% tint of that color, but you won’t be able to see through to 

what’s behind the object. The trick is that you have to sneak transparency into 

the 3D effect without letting the effect know about it. You can accomplish this 

in one of two ways:

• If you have a single object that you’re working with, you can target 

just the fi ll of the object in the Appearance panel and then change the 

Opacity value (Figure 11.56).

• Alternatively, you can create a group (you can create a group of one 

object, if you’d like). If transparency is applied to any object within a 

group, that transparency makes it through the 3D effect unscathed.

Drawing Hidden Sides

Another useful nugget of information that you learned earlier is that, by 

default, Illustrator renders only the parts of a 3D object that are visible. To 

speed up the rendering process, Illustrator doesn’t bother drawing the sides of 

a 3D object that are hidden from view. Well, this presents a problem if you’re 

creating an object that is transparent and you expect to see through the front 

of the object to the back side. After all, if Illustrator isn’t drawing the hidden 

side of an object, how does Illustrator know what the back side of the object 

looks like? The answer is that you have to force Illustrator to draw the hidden 

NOTE If your symbol 
contains transparency 

or overprint settings, those 
will not interact with the 3D 
object itself. For example, if a 
symbol uses a blending mode 
and you mapped that symbol 
to a 3D object, you wouldn’t 
see the symbol multiplying 
with the 3D shape, because 
the appearance is limited to 
the symbol itself.

Figure 11.56 When you’re 
using the Appearance panel, 
targeting the fi ll allows you 
to apply transparency to just 
the fi ll and not the entire 
object.
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sides—you do this by turning on the Draw Hidden Faces option in the 3D 

Extrude & Bevel Options or 3D Revolve Options dialog box.

Once you’ve addressed the issues of transparency and hidden sides, you’ll 

end up with a 3D object that is truly transparent (Figure 11.57). Adding 

transparency to 3D objects opens new doors to creativity, such as when 

creating transparent glass bottles and vases. And don’t forget to throw some 

artwork mapping in there as well. If you map art to a transparent 3D object, 

you’ll be able to see through to the art on the other side. Now you’ve got to 

admit—that’s pretty freakin’ cool, no?

What If…You Blend 3D Objects?
In Illustrator, you can select two objects and choose the Object > Blend > 

Make feature to morph one vector shape into another. This technique, cov-

ered in Chapter 2, can be useful for a variety of tasks including shading, 

special effects, and object distribution. However, what if you created a blend 

using two 3D objects? Would the 3D effect morph as well, along with the 

blend?

The answer is, yes, it will! If you apply a 3D effect to an object and then 

duplicate that object (so you have two identical objects), you can create a 

blend between them. Because 3D is a live effect, you can edit the 3D effect 

of one of the objects and change the position so you’re viewing the object 

Figure 11.57 This martini 
glass is transparent, allowing 
you to see what is inside.
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from a completely different angle. The blend will then update—and gener-

ate the intermediate steps (Figure 11.58).

Not impressed? Well, in Chapter 13, “Web and Mobile Design,” you’ll learn 

how to use blends to create instant Flash animations that you can put on 

your website. That means you can create a box and have it rotate in space. 

Hey, wait—don’t go running off to that chapter yet—we still have plenty of 

cool stuff to cover here.

What If…You Apply a 3D Effect to a Graph?
In Chapter 10, “Drawing with Data,” you learned that a graph consists of a 

group of objects. And because a 3D effect applied at the group level results 

in all the objects in that group sharing the same effect, what happens if you 

apply a 3D Extrude effect to a graph? The answer is that you get a powerful 

way to present numbers in an eye-catching manner (Figure 11.59). And if 

you add transparency to a 3D graph—well, you can see where that might 

lead.

At the end of the day, the 3D effect in Illustrator has many creative uses. 

Now that you understand everything there is to know about 3D in 

Illustrator, the only limit is your own imagination.

Figure 11.58 By creating 
a blend between spheres 
with mapped artwork, you 
can create the illusion of the 
sphere rotating.

Figure 11.59 Adding 
3D eff ects to just about 
anything, such as graphs, 
for example, can turn 
something ordinary into 
something unique and 
attention-grabbing.



Chapter 
TwelveWorking with Images

There’s no velvet rope barring entry to the Adobe 

Illustrator exclusive vector graphics club. Pixels 

are always welcome inside. In fact, you’ve already 

learned how certain live effects use pixels to pro-

duce their appearance. In Illustrator, vectors and 

pixels peacefully coexist, and you can benefi t by 

combining both vectors and pixels (such as adding 

a soft drop shadow to text). You shouldn’t feel you 

have to choose only one graphic type or the other.

Although Illustrator does have the ability to sup-

port pixels in some ways (as you’ll see throughout 

this chapter), it in no way replaces the need for applications such as Adobe 

Photoshop CS4. Quite the contrary; in this chapter, you’ll see how you can 

bring pixel-based images from Photoshop into Illustrator documents. You 

will also learn how both Photoshop and Illustrator can work together by 

enabling you to share editable content between them. You can then focus 

on producing the kinds of graphics you need by relying on the strengths of 

each of these powerful applications.

So, turn up the music and feel the pulsing beat of vectors dancing with pix-

els, because this chapter will also cover the Illustrator ability to assimilate 

pixels and convert them into vector paths using a feature called Live Trace.

375
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PLACING RASTER-BASED FILES
When creating designs and layouts in Illustrator, at times you will need to 

incorporate raster-based content, such as photographs. Naturally, these images 

are neither created nor edited in Illustrator—raster-based applications such 

as Photoshop take care of doing that. However, you can place raster-based 

content into your Illustrator fi le. In fact, Illustrator works very much like a 

page layout application in this way.

When you place an image, Illustrator can incorporate that image in the fi le 

in two ways. In the fi rst technique, Illustrator places a preview of the image 

on your artboard, but the image fi le itself is not incorporated into the 

Illustrator fi le. The image fi le exists as an external reference, separate from 

the Illustrator fi le. This technique is referred to as place-linking because the 

image fi le is linked to the Illustrator document. If you were to misplace 

the linked fi le, Illustrator would not be able to print the image.

In the second technique, Illustrator places the actual image fi le in the 

Illustrator document and incorporates the image into the Illustrator fi le. 

This is referred to as place-embedding, where the image becomes part of 

the Illustrator fi le.

You can choose which technique you want to use when you physically 

place the fi le. For a detailed explanation of the numerous benefi ts and 

caveats of using each technique, refer to the sidebar “Place-Linked Files 

and Place-Embedded Files.”

Placing an Image
You can place a raster fi le into an Illustrator document using one of three 

methods. You can either place a fi le, open it directly, or drag it right onto 

your artboard. Each method has its own benefi ts; your task is to determine 

which one you will use.

Method One: Placing a File

When you already have a fi le open and you need to place an image into your 

document, this method offers the most options and is one of the most com-

monly used ways to place a fi le:
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1. From an open document, choose File > Place, and navigate to a raster 

fi le on your hard drive or server.

2. In the Place dialog box are three check boxes (Figure 12.1). Select one 

of the following options:

• Select the Link check box to place-link the fi le (deselecting the 

Link check box place-embeds the fi le).

• Select the Template check box to have the image automatically 

placed on a template layer.

• Select the Replace check box to have the image replace one that 

is already selected on the artboard.

3. Click the Place button to place the fi le into your document.

Method Two: Opening a File

Choose File > Open, choose a raster fi le on your hard drive or server, and 

then click the Open button. Illustrator creates a new letter-sized document 

and places the image in the center of it. When you’re opening a raster fi le in 

this way, the image is always place-embedded in your Illustrator document. 

The document takes on the color mode of the image.

Method Three: Dragging a File

From Adobe Bridge, from the Finder on Mac OS, or from any Windows 

Explorer window, drag a raster fi le right onto your Illustrator artboard. 

You can also select multiple fi les and place them all at once (Figure 12.2). 

Using this method, Illustrator place-links the fi les. To place-embed images 

while dragging them into your document, hold the Shift key while 

dragging the images.

TIP See “Using 
Template Layers to 

Manually Trace” later in this 
chapter for more information 
on creating a template layer.

Figure 12.1 When placing a 
fi le, you can control whether 
an image is place-linked by 
selecting the Link check box 
in the Place dialog box.

Figure 12.2 When you’re 
dragging several images at 
once from Bridge, an icon 
indicates the placement 
of multiple fi les into your 
Illustrator document.
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Place-Linked Files and Place-Embedded Files

When placing an image into Illustrator, you can choose to have the image 
linked to your document or embedded within it. Each method has its own 
benefi ts, and which you choose depends on your needs and your workfl ow.

When you place-link an image, a preview of the image appears in your layout, 
but the actual image exists in a completely separate fi le. At all times, Illustrator 
needs to know where this fi le is. Otherwise, Illustrator won’t be able to print 
the fi le correctly. In fact, if you were to save your Illustrator fi le and send it off  
to someone else (such as a service provider, for example), you would have to 
send the external linked image along with the fi le. If you have several linked 
images in your document, you have to keep track of many fi les. In contrast, 
a place-embedded fi le exists in your Illustrator document, and therefore, 
the original external image that you placed is no longer required. When you 
send the document to another user, the image travels along with the single 
Illustrator fi le.

Images—especially high-resolution ones—feature hefty fi le sizes. When you 
choose to embed a placed image, the fi le size of the image is added to the size 
of your Illustrator fi le. For example, if your Illustrator fi le is 1 MB in size and you 
place-embed a 30 MB image into your document, the size of your Illustrator 
document grows to 31 MB. When you place-link an image, however, the fi le is 
never added to your document, so the Illustrator fi le stays at 1 MB.

Although managing multiple fi les and fi le size is an issue that will aff ect your 
decision to link or embed image fi les, one of the main reasons you will choose 
to link a fi le rather than embed it is so you can easily update the image when 
necessary. When you place-link a fi le, the image you see in your layout is a 
preview of the fi le that really exists elsewhere. When you make an adjustment 
to the original image (say, in Photoshop), the preview in your layout updates 
to refl ect those changes. Illustrator even has a feature called Edit Original 
that assists in this process of updating linked images (see “Managing Placed 
Images” later in this chapter). However, if you place-embed an image, you can 
no longer update that image easily.
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Placing Native Photoshop Files (PSD)
Typically, the interchange fi le formats for images that are used in print 

design layouts are TIFF or EPS, but Illustrator allows you to place native 

Photoshop fi les (PSD) as well.

Generally, placing a native Photoshop fi le isn’t any different from placing 

any other fi le. Illustrator enjoys a wonderful relationship with Photoshop, 

however, and you can take advantage of extended functionality when plac-

ing Photoshop fi les.

If the PSD fi le you are placing contains Photoshop layer comps, Illustrator 

presents you with the Photoshop Import Options dialog box, where you can 

choose which layer comp will be visible in the fi le from the Layer Comp 

pop-up menu (Figure 12.3). Select the Show Preview check box to see 

what the layer comp looks like before you place the fi le. You can also choose 

whether Illustrator or Photoshop controls how layer visibility is updated 

by choosing from the When Updating Link pop-up menu. The Photoshop 

Import Options dialog box offers additional options, which are covered later 

in this chapter in the “Working with Adobe Photoshop” section.

TIP Illustrator CS4 
can also place layered 

TIFF fi les.

NOTE The Layer Comps 
feature in Photoshop 

allows you to create named 
sets of visible layers. For more 
information on the Layer 
Comps feature, refer to 
Photoshop Help or Real World 
Adobe Photoshop CS4 by 
David Blatner and Conrad 
Chavez (Peachpit Press).

Figure 12.3 The Photoshop 
Import Options dialog box 
lets you control the appear-
ance of your Photoshop fi le 
before you place it into your 
document.
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Unfortunately, once you place an image into an Illustrator document, you 

don’t have any way to access the Photoshop Import Options dialog box to 

change to a different layer comp. To work around this apparent oversight, 

you can use the Relink function, which effectively places the fi le again and 

opens the dialog box (see “Managing Placed Images” for information on 

relinking fi les).

Working with Placed Images
Once you’ve placed an image into an Illustrator document, the image acts 

like a single rectangular shape that can be transformed (moved, scaled, 

rotated, sheared, and refl ected). You can apply opacity and blending mode 

values from the Transparency panel, and you can also apply many different 

live effects to a placed image, including Feather and Drop Shadow.

Sometimes a design calls for showing only a portion of a placed image. 

Programs such as Photoshop (which can crop images) and page layout 

applications such as Adobe InDesign CS4 (which use picture frames) are 

able to display only portions of an image. Illustrator, however, has no such 

tool or functionality. To have only a portion of an image display on your 

artboard, you have to create a mask (Figure 12.4). (See Chapter 9, 

“Designing with Effi ciency,” for more information on creating masks.)

You can also apply color to certain kinds of placed images. Illustrator lets 

you apply either a solid process or a spot color to a 1-bit TIFF image or to 

NOTE For a detailed 
description of the dif-

ferent fi le formats and their 
benefi ts and roles in a design 
workfl ow, refer to Chapter 14, 
“Saving and Exporting Files.”

Figure 12.4 Using a 
clipping mask, you can 
display just a portion of 
a placed image.
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any image that uses the grayscale color model. Simply select the image on 

the artboard, and choose a fi ll color as you would for any vector object.

Using Template Layers to Manually Trace
Sometimes you may want to place an image into Illustrator—not as a design 

element but rather as a design guide. For example, you might sketch an idea 

for a design on paper and then scan that sketch into your computer. Then, 

you would place that scan into your Illustrator document as a guide for 

drawing fi nal shapes with the Illustrator vector tools. Alternatively, you may 

place a map into Illustrator so that you can create your own customized 

directions to an event.

In these cases, you may not actually want to trace the scan exactly as it 

appears (using the Live Trace feature in Illustrator, covered later in this 

chapter, might be a better choice for such a task), but rather, you may just 

want the image to act as a reference. To prevent the image from getting in 

the way of your design, you might want to adjust the opacity of the image 

(Figure 12.5). Additionally, you may want to lock the image so that you 

don’t move it accidentally.

Rather than going through the process of adjusting and locking images, 

Illustrator has a way to manage this process in a more dignifi ed manner—

using a template layer. Once a template layer has been created, the image on 

that layer automatically becomes locked, and the opacity level of the image 

is set to 50%. You can select the Template option at the bottom of the Place 

dialog box when placing an image to have the image automatically appear 

on a template layer, or you can double-click any layer and select the 

Template option in the Layer Options dialog box (Figure 12.6 on the 

next page).

NOTE Template layers 
are not to be confused 

with Illustrator templates, 
which are actual Illustrator 
fi les that contain elements 
already inside them. 
Illustrator templates are 
covered in Chapter 1, 
“Creating and Managing 
Documents.”

Figure 12.5 Drawing on 
top of an image at full 
strength may be diffi  cult 
(left). Placing an image on 
a dimmed template layer 
allows you to trace over the 
image with ease (right).
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Adding Keylines to Placed Images

Often, when you place a photograph in an Illustrator document, you want to create a keyline, or an outline 
around the photo. It’s important to understand that a placed image is not a vector object and, hence, can’t 
have a fi ll or stroke. So, you’ll need to create another vector object to contain your stroke. Rather than create 
this new shape on your own, there are two methods you can use: have Illustrator automatically create a mask 
for the image or use an eff ect to convert the bounds of the object into a vector object.

To add a keyline using a mask, follow these steps:

1. Choose File > Place, and pick an image to place into your Illustrator document. You can either link or 
embed the image. Once you’ve chosen the image, click the Place button.

2. The image is selected (or if your image already exists in your document, select it), so you’ll see the Mask 
button in the Control panel. Click it. This creates a mask at the exact bounds of the image.

3. Press the D key for Default. This gives the mask a black 1-point stroke. Feel free to adjust the stroke per 
your design needs (who uses a 1-point stroke anyway?).

An additional benefi t to this method of using a mask is that you now have the elements in place to simulate 
a “frame and image” paradigm like InDesign uses. Once you’ve created your mask, you can decide to “crop” 
your image by double-clicking the photo. This will put you into isolation mode. Now click the frame edge and 
resize at will. When you’re done, double-click outside the image to exit isolation mode and continue working. 
This method works wonderfully when you’re using the Selection tool (black arrow) and have the Bounding Box 
option selected (in the View menu).

To add a keyline using a live eff ect, follow these steps:

1. Choose File > Place, and pick an image to place in your Illustrator document. You can either link or embed 
the image. Once you’re chosen the image, click the Place button.

2. With the image selected, open the Appearance panel, and click Add New Stroke. You won’t see the stroke 
appear just yet, but don’t worry, it will show up in the next step.

3. With the stroke highlighted in the Appearance panel, choose Eff ect > Path > Outline Object. The stroke will 
appear around the boundary of the photograph.

To make the live eff ect easier to apply in the future, defi ne a graphic style. For details on graphic styles, refer to 
Chapter 9.

Figure 12.6 The Template 
option appears in the Layer 
Options dialog box and 
applies to a single layer.
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MANAGING PLACED IMAGES
Whether the images you place in a fi le are linked or embedded, it’s important 

to be able to track where those images came from and to access additional 

information about the images. To manage all the placed images in your doc-

ument, choose Window > Links to open the Links panel.

By default, the Links panel lists all the images in your document. However, 

from the Links panel menu, you can specify that the Links panel should 

display only missing, modifi ed, or embedded images (Figure 12.7). In addi-

tion, you can choose to have the Links panel list images sorted by name (fi le 

name), kind (fi le type), or status (up-to-date or modifi ed).

Double-clicking any fi le listed in the Links panel opens a Link Information 

dialog box, offering additional information about the image. Besides listing 

the fi le size of the image, the Link Information dialog box also gives you the 

location of the image (the fi le path) and detailed scaling and rotation infor-

mation (Figure 12.8 on the next page).

Figure 12.7 Icons in the 
Layers panel indicate addi-
tional information about 
the images that are placed 
in your document. No icon 
indicates a place-linked fi le.

Missing Image

Linked Image

Embedded Image

Modifi ed Image

Relink

Go to Link

Edit Original

Update Link
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Along the bottom of the Links panel are four buttons (Figure 12.7) that 

allow you to perform certain functions with the images in your document. 

To use these functions, fi rst highlight an image in the Links panel, and then 

click the desired button:

• Relink. The Relink button allows you to replace one image with a 

different one. When you click the Relink button, the Place dialog box 

appears, allowing you to choose another fi le, which replaces the selected 

image. You can use Relink either to swap high-resolution fi les for low-

resolution ones or to replace FPO (For Position Only) placeholder 

images with fi nal copies. Additionally, you can use the Relink function 

and choose to replace your fi le with the same image (replacing it with 

itself), which allows you to access different Place settings or to replace 

an embedded image that was updated.

• Go to Link. The Go to Link button adjusts the view setting of your 

document window so that the highlighted image in the Links panel is 

centered on your screen. In addition, the image becomes selected. This 

makes it easy to quickly fi nd an image, and it is especially useful in 

documents that contain many placed images.

• Update Link. The Update Link button allows you to update place-

linked images when Illustrator detects that external fi les have been 

modifi ed outside of Illustrator. Images that have been modifi ed appear 

with a yellow warning icon in the Links panel. The Update Link button 

is dim when an embedded image is chosen.

• Edit Original. You can click the Edit Original button when you want 

to modify a place-linked image in the image’s creator application. When 

you highlight an image in the Links panel and click Edit Original, 

Figure 12.8 Double-
clicking a listing in the 
Links panel opens Link 
Information, a dialog 
box containing useful 
information about the 
linked image.

NOTE Refer to the 
Appendix, “Application 

Preferences,” for information 
on the Update Links setting in 
the File Handling & Clipboard 
panel in Preferences that 
controls whether Illustrator 
updates modifi ed fi les 
automatically or manually.
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Illustrator launches the application that was used to create the fi le (or 

that is set to open fi les of that type on your system) and then opens the 

fi le for you. Once you perform any necessary edits on the fi le, simply 

save and close it and return to Illustrator, where the image updates 

accordingly. The Edit Original button is dim when you highlight an 

embedded image.

Additional Links Panel Functionality
In addition to the functions in the Links panel that we’ve already discussed, 

you can take advantage of several important settings in the Links panel 

menu (Figure 12.9).

Here are a few of the options:

• Placement Options. When you relink or replace a fi le, you can use 

the Placement Options setting to defi ne how an image appears once it 

has been placed into your document. By default, Illustrator preserves 

Figure 12.9 The Links panel 
menu grants you access to 
additional features for work-
ing with placed images.
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any transforms you’ve applied to the image that you’re replacing, but 

you can also choose from four other settings. A helpful illustration in 

the Placement Options dialog box explains what each setting does 

(Figure 12.10).

• Embed Image. If you have a place-linked image in your document, 

you can select the image in the Links panel and choose the Embed 

Image option from the Links panel menu to embed that image in 

your fi le.

• Link File Info. Images and fi les can contain metadata (refer to 

Chapter 1 for more information), and at times, you may need to view 

the metadata of images you’ve placed into your document. For example, 

you may want to know whether you have the rights to reproduce the 

image or whom you need to credit for using an image. The Link File 

Info option in the Links panel menu allows you to view the placed 

image’s metadata (you won’t be able to edit it, however).

• Panel Options. Always trying to accommodate, Illustrator lets you 

customize the Links panel by choosing Panel Options from the Links 

panel menu. You can choose to display images in a thumbnail size, or 

if you prefer, you can eliminate thumbnails altogether (Figure 12.11), 

which is useful when you have many placed images in your document. 

Figure 12.10 Each setting 
in the Placement Options 
dialog box off ers an illustra-
tion and a description for 
what it does.

NOTE Illustrator 
supports linked 

DCS 2.0 fi les that interact 
with transparency.
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Additionally, you can choose the Show DCS Transparency Interactions 

option to have Illustrator alert you when placed Desktop Color Separa-

tions (DCS) 1.0 fi les interact with transparency in your document. This 

setting results in slower performance, though.

Getting Faster Access to Image Settings 
with the Control Panel
Although the Links panel offers a single location from which to track 

information about your placed images, you can also use the Control panel 

to quickly access certain settings and features that pertain to a selected 

image. The Control panel displays the fi le name, the color mode, and the 

resolution of a selected image. In addition, for linked images, the Control 

panel offers options to embed or edit the fi le via the Edit Original feature, 

which was discussed earlier in the chapter. You can also click the image’s fi le 

name in the Control panel to access additional features in the Links panel 

(Figure 12.12).

Figure 12.11 With thumb-
nails turned off , the Links 
panel can display more 
items in less space—perfect 
for documents with lots of 
placed images.

TIP When you select 
an image on your art-

board, a Mask button appears 
in the Control panel, making 
it easy to quickly apply a 
mask and crop the image. 
Refer to Chapter 9 for more 
information on using masks.

Figure 12.12 Clicking the 
fi le name of a linked image 
in the Control panel off ers 
a shortcut to several often-
used functions.
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Using the Document Info Panel

The Links panel isn’t the only place where you’ll fi nd information about 
place-linked and place-embedded images. You can choose Window > 
Document Info to open the Document Info panel that off ers information 
on a lot more than just images. In fact, the Document Info panel can 
prove quite useful for providing document information on a variety of 
attributes and settings (Figure 12.13).

By default, the Document Info panel shows information about only 
those objects that are selected on the artboard. To fi nd out information 
about all the objects in a fi le, deselect the Selection Only option in the 
Document Info panel menu.

To fi nd out information about certain aspects of an Illustrator document, 
choose from one of these settings in the Document Info panel menu:

• Document. The Document setting displays the color mode for your 
document, along with a listing of other important document settings 
such as text editability and color profi le.

• Objects. This setting displays the total number of objects in your fi le, 
broken down by object type. This setting off ers a quick way to fi nd 
out how many linked or embedded images you have in your document, 
how many objects are colored with spot colors, or how many transparent objects there are.

• Graphic Styles. To see a list of all the graphic styles that are used in your document, as well as to how 
many objects each style is applied, choose this setting.

• Brushes. The Brushes option lists all the brushes used in your document.

• Spot Color Objects. This setting lists the spot colors used in your document.

• Pattern Objects. The Pattern Objects option lists all the patterns used in your document. This is especially 
helpful because it includes patterns that are used inside complex appearances and Pattern brushes.

• Gradient Objects. This setting lists all the gradients that are used in your document.

• Fonts. The Fonts option lists all the fonts used in your document.

• Linked Images. The Linked Images option lists all the linked images that appear in your document, along 
with information about each image.

• Embedded Images. The Embedded Images setting lists all the embedded images that appear in your 
document, along with information about each image.

• Font Details. The Font Details option lists information about the fonts used in your document. This is 
helpful when you want to quickly fi nd out whether you are using OpenType, TrueType, or PostScript fonts 
in your document.

You can save all the information listed in the Document Info panel by choosing Save from the Document Info 
panel menu. A text fi le is created that contains the information for all the items just outlined.

Figure 12.13 The Document Info 
panel provides detailed informa-
tion on just about anything you 
could ask for about your fi le, 
including linked images.
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CONVERTING RASTERS TO VECTORS
USING LIVE TRACE
Certain Illustrator features, such as Pathfi nder, are incredibly useful and, as 

a result, are used many times a day. Features such as 3D are also extremely 

cool, but they aren’t used as often. Every once in a while, a feature comes 

along in Illustrator that is cool and fun to use but that is also practical enough 

that you use it on a regular basis. The Illustrator Live Trace is such a feature.

The concept is simple enough: Take a raster-based image, and convert it 

into a vector-based image. You would want to do this to get around the 

limitations of a raster-based fi le. For example, if you want to scale artwork 

up in size or if you want to edit the artwork easily and use spot colors, you 

want to work with a vector-based fi le.

Separate applications (such as Adobe Streamline) and Illustrator plug-ins 

(such as Free Soft’s Silhouette) have the ability to convert raster content 

into vectors, but Live Trace is a far step above and beyond what those tools 

are capable of doing. One of the main reasons for this is because of how 

Live Trace works.

Live Trace uses a two-step process when converting rasters to vectors. In 

the fi rst step, Live Trace conditions the raster image for optimal tracing. This 

means Illustrator makes adjustments to the raster image, such as adjust-

ing contrast or blurring jagged edges. In the second step, Live Trace draws 

vector paths, creating highly accurate vector art (Figure 12.14 on the next 

pages). Although the tracing is theoretically done at that point, Illustrator 

retains a link to the original raster image so you can adjust the tracing set-

tings. As you update the different raster conditioning and vector tracing 

settings, you can preview the results immediately. This makes it easy to get 

just the right tracing result that suits your needs best.
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ORIGINAL SCAN ORIGINAL SCAN ENLARGED 300%

CONDITIONED IMAGE CONDITIONED IMAGE ENLARGED 300%

TRACED RESULT TRACED RESULT ENLARGED 300%

Figure 12.14 The Live Trace 
feature in Illustrator starts 
with the original raster 
image (left), conditions the 
image (center), and then 
converts it to clean vectors 
(right).
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(continues)
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Tracing an Image
Tracing an image is simple. Select any raster image in your Illustrator docu-

ment, and click the Live Trace button in the Control panel. Alternatively, 

you can choose Object > Live Trace > Make. This action traces the image 

using the Illustrator default trace preset. Illustrator comes with 14 tracing 

presets, each optimized for different kinds of images and desired result. 

Once the image is traced, it maintains a live link to the raster image, and 

you can customize the tracing settings. For example, once the image is 

traced, the Control panel changes to refl ect different settings, including a 

Preset pop-up menu (Figure 12.15). Choose from any of the different 

Illustrator presets to see a different traced result on your screen.

If you know which tracing preset you want to use before you trace your 

image, you can select it directly by clicking the upside-down triangle that 

appears just to the right side of the Live Trace button and choosing it from 

the pop-up menu (Figure 12.16).

Figure 12.16 It doesn’t look like a pop-up 
menu, but it is. Clicking the upside-down tri-
angle lets you apply a specifi c tracing preset 
when you fi rst choose to trace an image.

As long as Illustrator maintains a live link to the raster image, you won’t be 

able to edit the actual vector paths that were created during the tracing pro-

cess. In order to do so, you either have to expand the traced object or con-

vert it to a Live Paint group. We discuss both of these options later, but for 

now, we’ll focus on how to customize the tracing settings so that you can 

get the best results from the Live Trace feature.

Figure 12.15 The Preset 
pop-up menu in the Control 
panel lets you quickly exper-
iment with diff erent tracing 
presets.

NOTE If you’re happy 
with the traced results, 

there’s no need to expand the 
object. Illustrator can print 
the vector paths just fi ne (it 
expands the paths in the print 
stream).
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Exploring the Live Trace Preview Options
Once you’ve traced an image, Illustrator displays the traced result on your 

artboard so you can see the results. However, Illustrator offers a variety 

of settings that you can use to control how both the raster image and the 

traced vector result appear on your artboard.

When a traced image is selected on the artboard, the Control panel updates 

to contain two icons that, at fi rst glance, look like triangles. Upon closer 

inspection, you’ll notice that one icon features a jagged edge; this icon is 

used to control how the raster image is previewed. The icon on the right, 

which has a smooth edge, is used to control how the traced vector result is 

previewed (Figure 12.17).

Previewing the Original Raster Image

In the Control panel, the jagged triangle on the left controls how the raster 

image is viewed. Click the icon once, and choose from one of the following 

four available settings (Figure 12.18):

• No Image. This setting completely hides the raster image from the 

screen (and is the default setting).

• Original Image. This setting displays the original raster image in your 

document, which can be useful when you’re comparing the original 

image to the traced result.

• Adjusted Image. This setting displays the raster image as it appears 

after Live Trace has applied the raster conditioning adjustments. This 

preview mode is great for seeing how Live Trace works, and it makes it 

easier to preview any adjustments you make to the raster image settings.

Figure 12.17 Once you’ve 
traced an image, you can 
use the two icons in the 
Control panel to control 
how the artwork appears 
on the artboard.

Raster Image Preview Setting

Vector Result Preview Setting
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ORIGINAL IMAGE ADJUSTED IMAGE TRANSPARENT IMAGE

ORIGINAL IMAGE ADJUSTED IMAGE TRANSPARENT IMAGE

ORIGINAL IMAGE ADJUSTED IMAGE TRANSPARENT IMAGE

• Transparent Image. This setting displays a dimmed preview of the 

bitmap image beneath the traced result, letting you see the traced results 

as compared to the original raster image.

Previewing the Traced Vector Result

In the Control panel, the smooth triangle on the right controls how the 

traced vector result is viewed. Click the icon once, and choose from one of 

the following four available settings (Figure 12.19 on the next page).

Figure 12.18 You can pre-
view the raster image with 
the Original Image setting 
(left), the Adjusted Image 
setting (center), or the 
Transparent Image setting 
(right). The No Image option 
is not shown for obvious 
reasons.
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TRACING RESULT OUTLINES OUTLINES WITH TRACING

TRACING RESULT OUTLINES OUTLINES WITH TRACING

TRACING RESULT OUTLINES OUTLINES WITH TRACING

• No Tracing Result. This hides traced vector objects from the screen.

• Tracing Result. This setting displays the vector result of the tracing 

(the default).

• Outlines. This setting highlights the actual Bézier paths that were 

created when the image was traced.

• Outlines with Tracing. This highlights the Bézier paths as semitrans-

parent, enabling you to compare fi lled areas of the traced vector result 

with the original image. The color of the outlines will match the color 

specifi ed for guides in the Guides & Grid panel in Preferences.

Figure 12.19 You can pre-
view the vector result with 
the Tracing Result setting 
(left), the Outlines setting 
(center), and the Outlines 
with Tracing setting (right). 
The No Tracing Result 
option is not shown.
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Tweaking to Get the Perfect Trace
What makes the Live Trace feature a joy to use is the ability to make adjust-

ments to the settings while you see the results update on your screen. Aside 

from the presets you can apply, Illustrator contains a dialog box chock-full 

of settings you can use to ensure that you get the results you need from the 

Live Trace feature.

To access these settings, select a Live Trace object, and click the Tracing 

Options dialog box button in the Control panel. Alternatively, you can 

choose Object > Live Trace > Tracing Options. Once the Tracing Options 

dialog box appears on your screen, you’ll notice that it’s split into several dif-

ferent sections (Figure 12.20).

First, a Preview check box appears on the far right of the dialog box, which 

allows you to see results update as you make changes to the different set-

tings. Next, directly underneath the Preview check box is a list of important 

details about your traced object. The values for the number of paths, anchor 

points, colors, distinct closed areas, and image resolution update as you 

adjust the settings in the dialog box. Keeping an eye on these values helps 

you make decisions as you edit your trace settings. At the top of the dialog 

box is a Preset pop-up menu, similar to what you see in the Control panel 

when you have a Live Trace object selected. Stepping through the different 

presets in the Tracing Options dialog box allows you to see the settings for 

each of the presets.

Figure 12.20 The Tracing 
Options dialog box off ers a 
smorgasbord of settings to 
achieve the perfect trace.
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The rest of the Tracing Options dialog box is separated into three sections 

called Adjustments, Trace Settings, and View. The View section allows you 

to specify how the traced object appears on your artboard, as discussed in 

the earlier “Exploring the Live Trace Preview Options” section.

The following “Modifying the Raster Adjustments” and “Adjusting the 

Vector Trace Settings” sections will help you clearly understand the two-step 

process that the Live Trace feature performs when converting raster images 

into vector form.

Modifying the Raster Adjustments

The Adjustments settings on the left side of the Tracing Options dialog box 

apply to the raster conditioning that occurs before the image is traced:

• Mode. Live Trace converts a bitmap image to either 1-bit black and 

white, 8-bit grayscale, or 8-bit color, which you can choose from the 

Mode pop-up menu.

• Threshold. The Threshold setting determines the boundaries between 

pixels when using the Black and White trace setting. For example, in a 

gray bitmap, a high Threshold setting results in more gray pixels becom-

ing black vector objects and thus a heavier appearance. In that same 

image, a low Threshold setting results in more gray pixels ignored, mak-

ing for more white-colored objects and an overall lighter or more delicate 

appearance (Figure 12.21). Too low of a Threshold setting may also 

result in a loss of image detail. The Threshold setting is also available in 

the Control panel when a Black and White Live Trace object is selected.

• Palette. By default, Illustrator uses the selective color reduction method 

to choose the best colors to fi t the image (based on the Max Colors 

value, also set in this dialog box). However, you can choose specifi c col-

ors that Illustrator should use when tracing your image. To do so, you 

must fi rst load a custom swatch library (Window > Swatch Libraries). 

When a custom swatch library is opened in your document, the Palette 

pop-up menu displays all the loaded custom libraries (Figure 12.22 
on page 400). Live Trace then uses the colors that appear within the 

custom swatch library that you choose.
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ORIGINAL IMAGE

THRESHOLD: 80 THRESHOLD: 110 THRESHOLD: 128 THRESHOLD: 150

THRESHOLD: 200 THRESHOLD: 230 THRESHOLD: 238 THRESHOLD: 242

THRESHOLD: 50

ORIGINAL IMAGE

THRESHOLD: 90 THRESHOLD: 110 THRESHOLD: 128

THRESHOLD: 150 THRESHOLD: 165 THRESHOLD: 200 THRESHOLD: 235

Figure 12.21 Making adjustments to the Threshold setting can have a large impact on 
the overall appearance of the traced result. Here are examples of an image with a vari-
ety of diff erent Threshold settings.
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• Max Colors. The Max Colors setting determines the maximum num-

ber of colors that can be used in the fi nal traced result. This setting is 

not available for the Black and White Mode setting or when you choose 

a custom color palette. Live Trace uses the selective color reduction 

method to reduce the number of colors in the raster image to match 

this setting during the conditioning process. The Max Colors setting is 

also available in the Control panel when a Grayscale or Color Live Trace 

object is selected.

• Blur. The Blur setting applies a Gaussian Blur to the image, which 

helps remove noise from the raster image. This reduces the number of 

anchor points in the tracing result, especially when you are tracing pho-

tographic images.

• Resample. The Resample setting lets you change the resolution of the 

bitmap image to help obtain a better traced result. Resampling a high-

resolution image to a lower resolution greatly enhances the speed per-

formance of Live Trace.

Adjusting the Vector Trace Settings

The Trace Settings are on the right side of the Tracing Options dialog box 

apply to the actual tracing of the image and determine how the fi nal vector 

paths are drawn.

• Fills. When you have Fills selected, Live Trace creates closed and fi lled 

vector paths for all resulting vector objects. Fill tracing produces results 

that more closely match the original image, including variable-width 

lines that are common in marker or ink renderings (Figure 12.23). 

Figure 12.22 Loading sev-
eral custom libraries lets you 
quickly experiment with a 
variety of color schemes.

TIP Select the Output 
to Swatches option to 

have Illustrator add each color 
that is used during the tracing 
process as a global process 
color in your Swatches panel.
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Fill tracing also results in more complex vectors because it needs more 

anchor points.

• Strokes. With the Strokes setting selected, Live Trace creates stroked 

open paths for all areas that fall within the Max Stroke Weight setting. 

Areas that exceed this setting result in unfi lled areas outlined with a 

1-point stroke. Stroke tracing results in paths with fewer anchor points 

(Figure 12.24).

• Max Stroke Weight. The Max Stroke Weight setting determines the 

heaviest stroke weight Live Trace can use when tracing the image. This 

setting is available only when you use the Strokes trace setting.

Figure 12.23 When you 
choose the Fills setting, the 
traced paths appear with 
thick and thin edges, closely 
matching the original 
image.

Figure 12.24 When you 
choose the Strokes setting, 
the traced paths appear 
consistent, which results in 
a less complex traced image 
overall.
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• Min Stroke Length. The Min Stroke Length setting determines the 

shortest path that Live Trace can use when tracing the image. This set-

ting is available only when you use the Strokes trace setting.

• Path Fitting. Path Fitting determines how closely Live Trace follows 

the shape of the original raster image. A lower Path Fitting setting 

results in paths that closely match the original raster image yet might 

also reveal imperfections or irregular paths that aren’t smooth. A higher 

setting produces smoother paths with fewer anchor points but might 

not match the raster image as closely (Figure 12.25).

• Minimum Area. The Minimum Area setting sets a threshold for how 

large a section of the raster image has to be in order to be traced into a 

vector object. By setting a minimum area, you can have the Live Trace 

feature trace only those areas of pixels that meet a minimum size. For 

example, if Minimum Area is set to 9 pixels, Live Trace ignores regions 

of pixels that are less than 3 x 3 pixels in size.

• Corner Angle. The Corner Angle setting defi nes the sharpness of the 

angles used in the resulting vector objects. This setting is measured in 

degrees, not pixels. If you think of 0 degrees as perfectly fl at and 180 

degrees as a hard corner (rather than a rounded one), anything sharper 

than the Corner Angle setting (the default is 20) is converted to a cor-

ner anchor point rather than a smooth anchor point.

• Ignore White. White areas in a trace are fi lled with the color white 

by default. This means that if you position your traced artwork over a 

background, the white areas will block out the background. If you’d like 

your trace to treat white areas as being fi lled with the None attribute, 

you can select the Ignore White setting. In this way, backgrounds will 

show through the nonblack areas of your traced artwork.

Editing Live Trace Paths
Once you’ve achieved a trace result that you’re satisfi ed with, you might 

want to edit the Bézier paths, either to delete portions of the image or to 

apply your own colors, gradients, or patterns. To edit the vector paths of the 

traced object, you will need to either expand the trace or convert the traced 

object to a Live Paint group.

TIP The Minimum 
Area setting is also 

available in the Control panel 
when you have a Live Trace 
object selected.

TIP Once you’ve speci-
fi ed your settings in 

the Tracing Options dialog 
box, you can click the Save 
Preset button to defi ne your 
own tracing presets.
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ORIGINAL SCAN ENLARGED 300% PATH FITTING: 1 pixel

PATH FITTING: 2 pixels PATH FITTING: 4 pixels

PATH FITTING: 6 pixels PATH FITTING: 8 pixels

Figure 12.25 This fi gure 
shows examples of a variety 
of Path Fitting settings for 
the same image. Notice how 
the paths get smoother as 
the number is increased 
but that the result doesn’t 
match the original sketch 
as much.
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Expanding a Live Trace Object

With a Live Trace object selected, click the Expand button in the Control 

panel. Alternatively, you can choose Object > Live Trace > Expand. You 

can then use the Direct Selection tool to edit anchor points and Bézier paths 

(Figure 12.26). At this point, the traced object is no longer linked to the 

original raster image, and you can no longer adjust the traced result using 

any of the Live Trace options.

Converting Traced Images to Live Paint Groups

In Chapter 4, “Creative Drawing,” you learned about the Illustrator Live 

Paint feature, which allows you to apply fi ll attributes to areas, even if they 

aren’t fully enclosed shapes. If you’ve traced an image because you want to 

fi ll regions of the image with color, converting the Live Trace object to a 

Live Paint group makes a lot of sense.

With a Live Trace object selected on the artboard, click the Live Paint button 

that appears in the Control panel. This action expands the traced object and 

converts all the resulting vector objects into a Live Paint group in a single 

step. You can then use the Live Paint Bucket tool to fi ll your art with color 

without any additional steps (Figure 12.27). For more information on Live 

Paint groups, refer to Chapter 4, “Creative Drawing.”

NOTE If you select 
both the Fills and 

Strokes options, Live Trace 
converts the raster to a vector 
using a combination of both 
stroked and fi lled paths.

Figure 12.26 Once you’ve 
expanded a Live Trace 
object, you can edit the 
paths as you would with 
any vector object.

TIP You can press 
Option (Alt) while click-

ing the Live Trace button or 
when choosing a Live Trace 
preset from the Control panel 
to both trace and expand an 
image in one step.

NOTE For perfor-
mance reasons, Gap 

Detection is turned off  for 
Live Paint groups that are 
created directly from a Live 
Trace object. You can turn 
Gap Detection on manually, 
or you can create smaller Live 
Paint groups to get better 
performance.



EXPLORING AN ALTERNATIVE TO TRACE: OBJECT MOSAIC 405

EXPLORING AN ALTERNATIVE TO
TRACE: OBJECT MOSAIC
As you’ve learned so far, the Live Trace feature in Illustrator offers a cre-

ative way to stylize photographic content. Another way to generate stylized 

artwork using photographic content as a source is a feature called Object 

Mosaic. The feature takes any embedded rasterized content and converts it 

to a matrix of vector rectangles that resemble mosaic tiles.

To use the feature, select an embedded image, and choose Object > Create 

Object Mosaic, which opens the Object Mosaic dialog box (Figure 12.28
on the next page). You can specify a new size for the fi nal result, and you 

can also specify the number of tiles the feature should use. The larger the 

number of tiles you choose, the more detail you’ll get in your result (think 

smaller mosaic tiles). If you want the tiles to be perfectly square, you can 

enter a value for either the width or the height for the number of tiles and 

then click the Use Ratio button. Specifying a value for Tile Spacing will 

simulate grout, or the space that appears between each tile.

Figure 12.27 What started 
out as a pencil sketch 
quickly turns into fi nal art 
when you combine the Live 
Trace and Live Paint features 
in Illustrator.
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The Constrain Ratio setting allows you choose which value the Use Ratio 

button uses, and you can choose to end up with a color or a grayscale ver-

sion of your art. Selecting the Resize Using Percentages option lets you 

specify a new size for your overall result in the form of percentage values 

instead of absolute values. If you have no need for the original embedded 

image after you’ve applied the Object Mosaic function, you can select the 

Delete Raster option.

TURNING VECTORS INTO RASTERS
It’s easy to see the benefi ts of converting raster images into vector-based art-

work to allow for better scaling and editing. Interestingly enough, Illustrator 

can also perform the transition in reverse—converting vector-based artwork 

into rasterized art. Sometimes this is done to achieve a special effect where 

you might want to see a pixelated image (Figure 12.29). Alternatively, you 

might start with a gradient mesh object that you then rasterize and convert 

back to vectors using Live Trace to achieve a posterized graphic effect.

Figure 12.28 The Object 
Mosaic feature converts 
raster-based images to tiles 
of color squares.
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To convert vector artwork to pixels, select the art, and choose Object > 

Rasterize, which opens the Rasterize dialog box. You’ll fi nd you can choose 

from a variety of settings when rasterizing artwork (Figure 12.30).

• Color Model. Depending on the document color mode setting to which 

your fi le is set, here you’ll see CMYK, Grayscale, and Bitmap, or you’ll 

see RGB, Grayscale, and Bitmap. This is because a document cannot 

contain both CMYK and RGB elements. This setting can be extremely 

useful because it lets you change the color model of an object (even an 

image). For example, you can convert colored objects to grayscale.

Figure 12.29 Rasterizing 
text at an extremely low 
resolution can add an 
interesting design element 
to your layout.

Figure 12.30 The Rasterize 
dialog box should look 
familiar—it’s nearly identical 
to the Rasterize Eff ect 
dialog box.
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• Resolution. Here in the Rasterize dialog box, the default resolution is 

set to 300 ppi, which is usually suffi cient for print-related artwork. If 

you want all your artwork in your document to appear consistent, you 

can also specify that the Resolution setting should match the setting in 

the Document Raster Effects Settings dialog box.

• Background. You can choose whether the resulting raster will have a 

transparent background or a white background. If your effect overlaps 

other objects, you probably want to use the transparent setting, although 

remember that the fi le still needs to be fl attened (see Chapter 15, 

“Prepress and Printing,” for more information on transparency 

fl attening).

• Anti-aliasing. You can defi ne whether the raster image will be 

antialiased. Antialiasing slightly blurs color boundaries to avoid the 

appearance of jagged edges. For more information on antialiasing, refer 

to Chapter 13, “Web and Mobile Design.”

• Create Clipping Mask. This creates a clipping mask around the area 

of a shape so that you can have it blend into a background (raster images 

are always rectangular in shape and may block out objects that appear 

behind them). This setting won’t work very well for objects that have 

Drop Shadow, Feather, or Glow effects applied, because clipping masks 

have hard edges. This setting is not necessary if you specify the 

Transparent option for the Background.

• Add X Around Object. Depending on the kind of artwork you 

are rasterizing, you may experience some clipping when the artwork 

becomes rasterized. This is especially possible when rasterizing objects 

that have soft edges, such as Feather effects, applied. Specifying extra 

space around the object results in a larger raster image, but that incor-

porates all the artwork.

• Preserve Spot Colors. If your artwork contains spot colors, selecting 

this option will preserve the spot colors in the resulting raster image.

WORKING WITH ADOBE PHOTOSHOP
Photoshop is the sister application of Illustrator, and throughout this entire 

book, we have discussed how both Illustrator and Photoshop are different. 

Yet, at the same time, they have a lot in common. For one, they are both 
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Adobe products, and therefore, they share similar user interfaces and many 

of the same tools and panels. At a much deeper level, however, they share 

common technology. For example, both applications use the Adobe Color 

Engine, an Adobe shared component used for color management. Both 

Illustrator and Photoshop also use the Adobe Text Engine, which makes it 

possible for both applications to exchange text easily and share many of the 

same text features.

At the end of the day, a graphics professional can gain a tremendous amount 

of power from using both of these applications. Rather than trying to force 

one of these powerhouse applications to do everything, you can take advan-

tage of the benefi ts that each application offers and use both to complete 

your work.

Whether you’re starting in Illustrator and then bringing your art into 

Photoshop for fi nishing touches, or whether you’re starting in Photoshop 

and then bringing your designs into Illustrator, both applications can work 

together in many ways. For the remainder of this chapter, we explore how 

you can use both Illustrator and Photoshop in your workfl ow.

Going from Illustrator to Photoshop
When you want to bring art from Illustrator into Photoshop, you can open 

an Illustrator fi le directly in Photoshop, but doing so results in a single fl at 

image that isn’t editable. Instead, consider exporting a native Photoshop fi le 

from Illustrator directly; this preserves certain elements in an editable form. 

Using the Export command in Illustrator results in a Photoshop fi le that 

you can edit far more easily when you open it in Photoshop.

To export a Photoshop fi le from Illustrator, choose File > Export, and 

choose Photoshop (.psd) for the fi le format.

When exporting a PSD fi le, you can choose between CMYK, RGB, and 

Grayscale color models, and you can specify a resolution for your fi le. If 

you choose to export a fl at image, all Illustrator layers are fl attened into a 

single nontransparent layer (what Photoshop calls the Background layer). 

Alternatively, you can choose the Write Layers option, which preserves the 

Illustrator layering where possible. You can also choose to preserve text 

and other native elements.
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The following is a list of the attributes that can be preserved when Illustrator 

exports a native Photoshop fi le; see “The Adobe Photoshop (.psd) Format” 

in Chapter 14, “Saving and Exporting Files,” for additional details:

• Layers. Any layers that you’ve created, and the names of those layers, 

are preserved when you open the fi le in Photoshop. By carefully creat-

ing a layer structure in Illustrator, you can take advantage of greater 

editability when the fi le is opened in Photoshop.

• Vectors. If you used the shape modes in the Pathfi nder panel to cre-

ate compound shapes, these objects are converted to Photoshop shape 

layers, which are editable vectors in Photoshop. If you want a path to 

be preserved as a vector shape, you must apply a shape mode to it in 

order to preserve it as a vector in Photoshop. If you have a single shape 

that you want to preserve as a vector, select the shape, and choose Make 

Compound Shape from the Pathfi nder panel menu.

• Text. Illustrator preserves text objects so that they are editable when the 

fi le containing them is opened in Photoshop.

• Transparency. If you’ve applied opacity values or blend modes from 

the Transparency panel in Illustrator, those values are also preserved 

when the fi le is opened in Photoshop.

• Masks. If you create clipping masks in your fi le, those masks are pre-

served and show up in Photoshop as layer masks. Because masks allow 

you to work in a nondestructive fashion, you can create fi les that are 

more fl exible in your workfl ow.

• Slices. If you create web slices in your Illustrator fi le, those slices appear 

when the fi le is opened in Photoshop. Additionally, any optimization 

settings that you’ve applied to your slices, including settings that you’ve 

applied from the Save for Web dialog box, are preserved and can be 

edited once the fi le is opened in Photoshop.

Illustrator does its best to keep elements editable during the export process. 

However, if you fi nd that certain elements are not being preserved, the 

cause may be that preserving editability would change the appearance of the 

artwork. Try rearranging the layers in Illustrator to avoid issues where art-

work appearance is dependent upon the interaction of multiple layers.

TIP Often, layers are 
combined because 

overprint commands are 
applied to some objects on 
those layers. Targeting each 
layer and checking the Isolate 
Blending option in the 
Transparency panel can help 
keep the layers from merging 
on export.
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Copying and Pasting Between Illustrator and 

Photoshop

Copying and pasting art between Illustrator and Photoshop works extremely 
well. You can copy text freely between the two applications, and when you 
paste art from Illustrator into Photoshop, you can paste the art as a Photoshop 
smart object that preserves editability in Photoshop. In fact, when you paste 
art from Illustrator in Photoshop, you are presented with a dialog box asking 
whether you want the art to be pasted as pixels, a path, a shape layer, or a 
smart object.

Going from Photoshop to Illustrator
When you open a native Photoshop fi le or place-embed one into an existing 

document, Illustrator prompts you with the Photoshop Import Options dia-

log box, asking how you want the Photoshop fi le to be placed (refer back to 

Figure 12.3). You can select the Flatten Photoshop Layers to a Single Image 

option, or you can select the Convert Photoshop Layers to Objects option, 

in which case Illustrator tries to keep as many of the elements in the 

Photoshop fi le editable as possible.

The following are the attributes you can preserve when Illustrator embeds a 

native Photoshop fi le using the Convert Photoshop Layers to Objects option 

in the Photoshop Import Options dialog box:

• Layers. Any layers you’ve created, and the names of those layers, are 

preserved when you open the fi le in Illustrator. If you’ve created groups 

of layers in Photoshop, those groups show up in Illustrator as sublayers, 

thus preserving the hierarchy of the fi le.

• Vectors. If you’ve created vector shape layers in Photoshop, those layers 

are converted into editable compound shapes when the fi le is opened in 

Illustrator.

• Text. Text objects that appear in the fi le are editable when the fi le is 

opened in Illustrator.
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• Transparency. If you’ve applied opacity values or blend modes from 

the Layers panel, those values are preserved when you open the fi le in 

Illustrator as well. Because Photoshop applies these settings at the layer 

level, you may fi nd that these transparency settings are applied to the 

layer that an object is on rather than to the object itself.

• Masks. If you create layer masks in your Photoshop fi le, those masks 

are preserved and show up in Illustrator as opacity masks. Additionally, 

the boundaries of the fi le become a layer-clipping mask, acting almost 

like crop marks.

• Slices. If you create web slices in your Photoshop fi le, those slices 

appear when you open the fi le in Illustrator. Additionally, any optimiza-

tion settings that you’ve applied to your slices, including settings that 

you’ve applied from the Save for Web dialog box, are preserved and can 

be edited once the fi le is opened in Illustrator.

• Image Maps. If you’ve assigned a URL to a web slice, that URL is also 

preserved when the fi le is opened in Illustrator.

Illustrator does its best to keep elements editable during the embedding pro-

cess. For example, if you have a text object with a drop shadow that overlaps 

a background, Illustrator keeps the text editable and also places the drop 

shadow on a separate layer, allowing you to position the text and the drop 

shadow without affecting the background beneath it. If you fi nd that certain 

elements are not being preserved, the cause may be that preserving editability 

would change the appearance of the artwork. Try rearranging the layers in 

Photoshop to avoid issues where appearance is dependent upon the interac-

tion of multiple layers.



Chapter 
ThirteenWeb and Mobile Design

There’s no question that Illustrator suffers from schizo-

phrenia. One moment it’s a print-based application with 

spot colors and crop marks, and the next it’s a web-based 

application with HTML slices and Adobe Flash CS4 

Professional symbols. And that’s okay, because as design-

ers living in the 21st century, we all suffer from the same 

schizophrenia. This is because we are called upon to 

create art that will be used in many different ways—most 

notably in print, on the web, and even now on handheld 

mobile devices such as cell phones. Even if you are 

living in a print- or web-centric world, others may use 

and repurpose the art you create. That’s where Illustrator 

excels—in repurposing artwork for a variety of uses.

In this chapter, we focus on web and mobile technologies 

and understanding how web browsers and mobile devices display graphics. 

Illustrator and Flash work hand in hand, giving designers new options for 

working between these powerful applications. We’ll discuss these features 

and how you can use your favorite design application—Illustrator—to create 

quality web graphics with ease.

The artwork featured throughout this chapter comes from Fanelie Rosier 

(iStockphoto; username: absolutely_ frenchy).

413
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The Role of Illustrator in Web Design

Before we dive into the world of web design, it’s important to realize where 
Illustrator fi ts in when it comes to creating web graphics. There’s certainly more 
to creating a website than drawing pretty pictures. Software, such as Adobe 
Dreamweaver CS4 or Microsoft FrontPage, is dedicated to creating and main-
taining websites, and in no way does Illustrator replace those applications.

You can use Illustrator to design how a web page looks (by creating a composi-
tion), but you wouldn’t normally use Illustrator to create an HTML-based web 
page. Similarly, you wouldn’t use Illustrator to manage a multipage website 
because Illustrator lacks the toolset to do so.

The strength of Illustrator is in designing web interfaces and the navigation 
bars, buttons, individual web graphics, and general artwork that appear within 
a web page. You can place elements such as these that you design in Illustrator 
into Dreamweaver or any other application you use to create your web pages. 
Alternatively, you can create graphics in Illustrator, which you can then bring 
into Adobe Photoshop CS4 or Flash as well, if your workfl ow requires it.

TWO APPROACHES TO WEB DESIGN
Throughout this book, you have been learning how to create vector-based 

artwork. You’ve even learned how to use the Illustrator Live Trace feature, 

which converts pixel-based images into Bézier paths. So, it’s with a large 

spoonful of irony that we inform you how important pixels are in the world 

of web graphics.

Unlike printed artwork that is produced with imagesetters or digital presses 

that are capable of resolutions upward of 3,000 dots per inch (dpi), artwork 

that is created for the web is always viewed on a computer screen, usually 

at 72 pixels per inch (ppi). Features that a print designer might be used to, 

such as working with high-resolution images, choosing spot colors, or care-

fully calculating where fold lines or trim lines will be, are of no concern to 

someone who is designing a website.
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However, don’t be fooled into thinking that web designers have it easier 

than print designers. A web designer faces plenty of challenges—issues that 

never cross the minds of print designers. For example, because people view 

websites on computer screens, a designer has no way of knowing what size 

a viewer’s screen is. Especially now, when you have Internet kiosks and 

web-capable cell phones, it is important for web designers to create their art 

so that it can be displayed on virtually any device.

With that in mind, ultimately two mainstream workfl ows exist when you 

think about Illustrator and the web:

• Pixel-based graphics. The most common image fi le formats in use 

on the web today are raster-based images. Illustrator can generate these 

formats easily, and you can place these images directly into CSS and 

HTML layouts. Whether you’re creating artwork that will be displayed 

directly on the web, or whether you’re bringing artwork into Photoshop 

or Dreamweaver, your ultimate goal will be to ensure a seamless trans-

lation from the vector-based world in Illustrator to the raster-based 

image fi le format you need. The fi rst half of this chapter will primarily 

deal with creating pixel-based web graphics.

• Vector-based graphics. Through the use of extended technologies 

that have become standard parts of today’s most popular web browsers 

(such as Adobe Flash Player), vector-based graphics play a large role in 

web design as well. Whether you’re looking to export SWF fi les directly 

for the web from Illustrator or whether you’re going to bring your art-

work into Flash for additional interactive work, keeping the structure 

of your artwork intact is key. The second half of this chapter will deal 

primarily with creating vector-based web graphics.

Finally, although print and web technologies are different, it’s important not 

to lose sight of your goal as a designer—to communicate a message in an 

effective manner. The same rules of design that apply to the print world also 

apply to artwork destined for the web. If you keep this at the forefront of your 

mind and if you follow the advice and techniques revealed throughout the rest 

of this chapter, you’re sure to create effective and compelling web graphics.
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MAXIMIZING IMAGE QUALITY
ON THE WEB
In the business world, there’s a saying that goes like this: “We offer excel-

lent service, exceptional quality, and cheap prices—pick any two out of 

the three.” You can apply a similar saying to web graphics; it would sound 

something like this: “There’s color, quality, and fi le size—pick any two out 

of the three.”

With web graphics, there’s a delicate balance between the way an image 

looks when viewed on a computer screen and the time it takes to down-

load the image so that the user can view it. No matter how good the image 

looks, if viewers have to wait too long for a graphic to appear on their 

screens, their patience runs out, and they click to some other website in the 

blink of an eye. In general, there is a direct correlation between the detail 

and number of colors in an image and the size of the fi le. A fi le with many 

colors may have a large fi le size, but an image with a small fi le size may not 

have enough colors or detail to look good. As a designer, your job is to fi nd 

a happy medium—an image that looks good and is small enough that it 

downloads quickly. Luckily, you have Illustrator on your side, which has the 

tools you’ll need to get results.

Three issues affect the overall appearance of web graphics—dithering, 

antialiasing, and compression. We mentioned earlier how computers dis-

play different colors. Higher-end graphics cards allow computers to display 

many millions of colors, whereas lower-end cards restrict the display to a far 

smaller number of colors. Therefore, the following question arises: “If you 

create multicolored artwork on a high-end machine (which most designers 

use), what happens when that graphic is displayed on a low-end machine 

that can’t display all of those colors?” The answer is dithering.

Dithering
Dithering is a process in which a computer simulates a color that it doesn’t 

have by mixing colors it does have. For example, if you have a set of paints, 

you might have only a few colors, but you can create more colors by mixing 

the paints. Although the dithering concept is nice in theory, the results are 

not always great. The problem is that a computer can’t mix colors within a 

NOTE Although the 
argument can be 

made that fi le size isn’t that 
important anymore because 
of the growing population of 
broadband Internet installa-
tions, remember that many 
people still have slower dial-
up connections (especially 
outside the United States). 
In addition, handheld wireless 
devices and web-based 
cell phones are becoming 
increasingly popular, and 
those devices have much 
slower download capabilities.
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single pixel, so the dithering process creates a pattern of different-colored 

pixels in an effort to appear as another color. Many times, this pattern is vis-

ible and can give an odd appearance to a graphic (Figure 13.1). In fact, the 

entire concept of using a web-safe color is to ensure that you’ll be using a 

color that won’t dither. As you’ll see later in the chapter, Illustrator contains 

certain settings that can control how dithering is applied to a graphic.

Antialiasing
The second issue that arises with screen-rendered graphics has to do with 

the low resolution that a monitor uses—in most cases, 72 ppi. At such a low 

resolution, the eye actually sees pixels, and curved edges display with jagged 

edges (often referred to as jaggies). To make graphics look better onscreen, 

computers use a method called antialiasing to slightly blur the edges of bound-

aries between colors. The result is an image that looks smooth instead of 

jagged (Figure 13.4). As you’ll see shortly, antialiasing can have a tremen-

dous impact on the fi nal appearance of your web graphics.

Figure 13.1 The image on 
the left has been enlarged 
to show the eff ects of dith-
ering. Notice the pattern 
of pixels that are visible 
where colors blend into 
one another. The same art-
work on the right, however, 
exhibits no dithering.

Figure 13.4 Pictured here 
are identical designs. The 
object on the right has 
antialiasing turned on, 
resulting in a smoother 
appearance onscreen.
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Understanding and Using Web-Safe Colors

Most designers have a swatch book by their side—such as a Pantone book—that helps them choose colors to 
use in a design. And even though color management technologies have been getting better over the years, 
most people still don’t trust the color they see on their computer screens. If you’re designing web graph-
ics, though, you don’t have much of a choice because the computer screen is the delivery medium for your 
artwork. Therefore, it’s entirely possible that you can choose a nice yellow color on your screen, but when 
someone views your website on a diff erent computer, that color might appear green or orange. So, what’s a 
designer to do?

With a little bit of information and some simple math, it’s possible to narrow the number of colors that you 
might use to ensure your color looks decent on someone else’s computer screen. Although all types of com-
puters and graphics cards exist, the minimum number of colors that all systems support is 256 (also referred 
to as VGA). However, not all computer systems use the same set of 256 colors. In fact, Windows-based comput-
ers use a diff erent system set of colors than Mac-based computers (not surprising). The good news is that of 
these two mainstream systems, only 40 colors are diff erent, which leaves 216 common colors. This means if a 
designer were to use one of these 216 colors, referred to as web-safe colors, they would be assured that their 
artwork would display properly on just about any computer.

Illustrator can help you choose from these web-safe colors in several ways. First, you can load a custom library 
that contains all 216 web-safe colors by choosing Window > Swatch Libraries > Web. Illustrator also features a 
library called VisiBone2 that displays web-safe colors in a more intuitive way (Figure 13.2). Alternatively, you 
can choose Web Safe RGB from the Color panel menu, which allows you to choose web-safe colors by using 
the color ramp, by using the RGB sliders, or by directly entering their hexadecimal values. If you are using the 
regular RGB sliders in the Color panel, Illustrator lets you know when a color is not a web-safe color by display-
ing a small cube under the color icon. If you click the cube, Illustrator chooses the closest web-safe color for 
you (Figure 13.3).

Figure 13.2 When the 
panel is resized cor-
rectly so that there are 
white swatches in each 
of the four corners, the 
VisiBone2 panel dis-
plays the 216 web-safe 
colors in a way that 
closely matches a color 
wheel, making it easier 
to use when designing.

Figure 13.3 A small cube in the 
Color panel indicates when a 
chosen color is not a web-safe 
color. You can have Illustrator snap 
to the closest web-safe color by 
clicking the cube.

Cube

(continued on next page)
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Understanding and Using Web-Safe Colors (continued)

As if that weren’t enough, you can also take advantage of the Color Guide panel’s ability to work within a spe-
cifi c library of colors. By clicking the icon in the lower-left corner of the Color Guide panel, you can choose to 
limit the Color Guide panel to suggesting web-safe colors only.

In reality, choosing a web-safe color may not be that important anymore, considering that just about all mod-
ern computer systems sold today support a minimum of millions of colors, and hence, the chance of your 
color being dithered and looking really bad is small. If your graphics are being developed for websites geared 
toward people or services in third-world countries, where hardware isn’t as up-to-date, choosing a web-safe 
color may still be a good idea.

Compression
The last—and possibly the most important—attribute of a web graphic 

is its fi le size. Anyone can create great-looking graphics with large, high-

resolution images, but a web designer has to deliver the best possible graphics 

using low-resolution images that download fast.

For the most part, web designers can save fi les in a variety of fi le formats, 

each of which uses compression techniques to help reduce fi le size. In gen-

eral, fi le formats use one of the following two types of compression: lossless 

and lossy. Lossless compression reduces fi le size without any loss in image 

quality or image detail. In contrast, lossy compression reduces fi le size by 

sacrifi cing image data, resulting in images that have less detail. As with just 

about anything else in life, a designer is faced with making decisions based 

on which attributes are most important on an image-by-image basis. In the 

next section, you’ll learn about all the different fi le types Illustrator can use 

and the compression techniques these fi le types use.
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CREATING PERFECT WEB GRAPHICS
If you’re a parent, you might identify with the following analogy: A child is 

up at night coughing. To remedy the situation and assure a good night’s sleep 

(for both the child and the parent), a parent might offer some cough medi-

cine to the child. But we all know that the child wants nothing to do with 

the foul-tasting cough medicine, right? So, the parent attempts the ultimate 

marketing ploy: covering the medicine with some tasty ice cream, whipped 

cream, and rainbow sprinkles. Yummy, right? Although it may look like a 

delicious ice cream dessert, it’s still the icky cough medicine at the core.

When Illustrator was fi rst created in 1987, the web, as we know it today didn’t 

even exist. So, it’s fair to say that Illustrator was built as a print-based applica-

tion, fi lling the needs of print designers around the world. As time went on 

and our world changed, Illustrator got more features to help us do our work. 

When designers needed to create web graphics, Illustrator got more features 

to help in that area, but those features were just the fancy toppings that were 

added on top of the medicine—a core graphics engine that was primarily 

built on creating high-end print-based graphics. This is especially true in the 

area of antialiasing, which as you learned previously in this chapter is a tech-

nology employed to make graphics look good onscreen. Ultimately, when 

creating pixel-based web graphics, you have to fi nd a way to make all the 

web-based features of Illustrator (the sweet toppings) play nice with the high-

end print functions that Illustrator has always had (the medicine).

To clarify, Illustrator is not a lousy pixel-based web design tool. Quite the 

contrary—the Illustrator object-based drawing model offers tremendous 

benefi ts over other applications traditionally used in web design (such as 

Photoshop, for example). However, getting the quality output you expect 

from Illustrator may require more attention to some seemingly subtle details.

Antialiasing and the Pixel Grid
High-end print graphics are often rasterized at resolutions that exceed 

2400 dots per inch, producing razor-sharp curves and lines in your artwork. 

As you learned earlier in this chapter, onscreen graphics are rendered at 

resolutions far lower than that—enough so that the human eye can easily 

identify the individual pixels in a fi le. To prevent artwork from displaying 

with jagged edges onscreen, artwork is antialiased—the edges are slightly 
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blurred—resulting in a smooth appearance. But antialiasing is a double-edged 

sword, because it can produce side effects that can make artwork look worse 

instead of better. One such example is that when edges are blurred, contrast 

and detail are lost. This is especially true for small text that may even be 

unreadable when antialiasing is applied. However, another antialiasing side 

effect requires a closer look at how Illustrator draws graphics.

Although you don’t see it, an invisible pixel grid exists in Illustrator. By 

default, when you draw or create graphics, Illustrator snaps the paths you 

create to this invisible pixel grid. If you choose View > Pixel Preview to 

turn on Pixel Preview mode, you’ll notice another setting in the View menu 

that wasn’t there before: Snap to Pixel (Figure 13.5 on the next page). Why 

does Illustrator automatically align your graphics to this invisible pixel grid? 

The answer is antialiasing, but to understand the answer, let’s take a closer 

look at a pixel.

On a computer screen, a pixel represents the smallest element that can be 

drawn. A pixel is either on or off. In other words, you can’t have a computer 

screen draw only half a pixel. In addition, a pixel can display only a single 

solid color. Knowing this, if you were able to align a graphic so that its path 

edge was aligned right in the center of a pixel, how would a computer screen 

display the edge of the artwork? Would it fi ll the entire pixel, resulting in art-

work that would be slightly larger than you specifi ed? Would it leave the pixel 

empty, resulting artwork that would be slightly smaller than you specifi ed? 

What Is the Resolution of Onscreen Graphics?

Most people think of web graphics as 72 ppi, but the reality is that many of today’s modern displays are closer to 
120 ppi. The Apple iPhone features a “high-resolution” display, weighing in at 163 ppi. In reality, a web designer 
can’t specify artwork in terms of measurements like inches. If you think about it, a laptop computer with a 15” 
screen might be set to a resolution of 1024 x 768, 1344 x 840, or 1440 x 900. Obviously, the screen itself always 
stays at 15” (it would be quite a trick otherwise), but the pixels just change in size. Web graphics display larger at 
lower-resolution settings and appear smaller on a user’s computer screen as the screen’s resolution increases.

For this reason, web designers don’t focus on measurements like inches, and they don’t care about resolution. 
Most important to a web designer are pixel dimensions. Ad banners are specifi ed at an amount of pixels in 
width and an amount of pixels in height (such as 468 x 60). When creating web graphics in Illustrator, your best 
friend is the Transform panel or the Width and Height settings found in the Control panel, because they off er a 
precise way to enter exact pixel dimensions.
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Actually, none of this happens. Instead, antialiasing tries to simulate a half-

fi lled pixel by blurring the pixels near the edge. So, in reality, your graphic 

does get a bit larger, but it may appear to be smaller because of the visual 

effect of the blurring. In either case, the result is a web graphic that doesn’t 

look that great. More important, it doesn’t match the exact pixel dimensions 

you may have already specifi ed.

To circle back to the pixel grid we spoke of earlier, Illustrator automatically 

snaps art to whole pixels to prevent this issue from happening. In theory, if 

your art always lined up to the grid, you never see blurry edges with extra 

pixels added, and your artwork would also match the dimensions you’ve 

specifi ed. All of this is necessary because Illustrator was built for graphics 

that will print at extremely high resolutions, so snapping artwork to a grid 

that small wouldn’t be visible at all. But with web graphics, Illustrator has to 

Figure 13.5 When Pixel 
Preview mode is active, the 
Snap to Pixel command 
appears in the View menu.
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make sure its resolution-independent art lines up perfectly with the larger 

and more visible pixels present in web graphics.

Exploring an Example: Fat Gray Lines

Although the extra work that Illustrator does behind the scenes to ensure 

that graphics look wonderful is commendable, it’s actually less than perfect. 

First, for an entire object to snap to this pixel grid, the overall dimensions of 

the art must be whole pixels. Otherwise, some edges may line up perfectly 

and appear clean and sharp, while other edges of the object appear with 

blurred edges. It may be easy to create a rectangle measuring in full pixels, 

but that may not be the case for creative art. In addition, adding a stroke to 

an object can throw an entire object out of whack. A quick example easily 

illustrates this:

1. Create a new document using the Web profi le.

2. Choose View > Pixel Preview to turn on Pixel Preview mode. 

Make sure that the Snap to Pixel option in the View menu is active.

3. Choose View > Show Grid. This turns on the grid feature in 

Illustrator, which allows you to better visualize the invisible pixel 

grid. However, you’ll also need to change the settings of the grid 

to better represent the pixel grid.

4. Choose Illustrator > Preferences > Guides & Grid (Edit > 

Preferences > Guides & Grid) to open the Guides & Grid panel of 

Preferences. Set “Gridline every” to 72 px and Subdivisions to 72 

(Figure 13.6). Click OK. At this point, every square on the grid now 

represents a pixel. To make things easier to see, zoom in to maybe 1200%.

Figure 13.6 Figuring a base 
of 72 ppi for web graphics, 
setting up a grid with 72 
subdivisions gives you one 
grid square per pixel.
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5. Using the Rectangle tool, draw a rectangle on the artboard. Specify a 

fi ll of red and a stroke of none. You can clearly see that the boundary of 

the rectangle aligns precisely with the pixels on the grid (Figure 13.7). 

Use the Selection tool to move the rectangle around, and you’ll fi nd the 

shape snaps directly to the grid.

6. Apply a 1-pt black stroke to the rectangle. Instead of a nice 1-pixel black 

border, the rectangle now appears with an odd 2-pixel border that con-

sists of a variety of shades of gray (Figure 13.8).

Figure 13.7 With the grid 
visible, you can clearly see 
where the path edge lines 
up with the pixels.

Figure 13.8 Because of the 
pixel grid and the antialias-
ing, a 1-pixel black stroke 
appears as a fat gray stroke.
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When you add the 1-pt stroke, Illustrator paints that stroke along the center 

of the path. But since the path is aligned perfectly to the grid, the stroke 

weight is distributed a half pixel on both sides of the path. Since you already 

know that pixels can contain only one solid color, the antialiasing that 

Illustrator applies to the art results in a 2-pixel fat gray line (Figure 13.9).

When you hear web designers talk, many say they use Photoshop or Adobe 

Fireworks CS4 to create their web graphics, not Illustrator. More often than 

not, the reason behind their decision is because of the antialiasing issues we 

have covered here. But it’s not all bad—Illustrator offers tremendous value 

to web designers, and in my humble opinion, it’s foolish to overlook some 

of the great benefi ts of using Illustrator for web design work. After all, we 

still have plenty of chapter left. With that in mind, there are workarounds 

to everything; sometimes you just need a little more effort and attention 

to detail.

Taking Charge of Antialiasing—and Your Art

Now that you’re aware of the problems with antialiasing, what can you do 

about them? Although there’s no single answer (each workfl ow will have its 

own solutions), you might fi nd this list of solutions helpful:

• Avoid using strokes. As you’ve clearly seen, adding strokes really 

exposes the antialiasing shortcomings of Illustrator. Although you can 

certainly use the settings in the Stroke panel to align a stroke to the 

inside or outside of a path, odd antialiasing artifacts occur even with 

those settings. Instead, it’s better to use the Object > Path > Outline 

Stroke command to convert stroked objects to fi lled paths that you can 

then easily align to the pixel grid.

Figure 13.9 This is a perfect 
example of how valuable 
the Pixel Preview feature 
is in Illustrator. On the 
left, in Preview mode, the 
stroke around the rectangle 
appears normal. On the 
right, in Pixel Preview mode, 
you can clearly see the 
eff ect of the antialiasing.
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• Disable antialiasing for specifi c objects. You may fi nd that for some 

artwork it is benefi cial to turn off antialiasing altogether. Although you 

can’t disable antialiasing as a general document setting, you can disable 

antialiasing on an object-by-object basis. To do so, make a selection, and 

choose Effect > Rasterize. Choose 72 ppi for the Resolution setting, 

choose None for the Anti-aliasing setting, and click OK. With Pixel 

Preview turned on, you will clearly see the difference between objects 

that do and do not have antialiasing applied.

• Set text in Photoshop. Where possible, you might consider bringing 

artwork into Photoshop, specifi cally where type is concerned (you can 

even copy and paste text directly from Illustrator into Photoshop). While 

Illustrator features just a single antialiasing algorithm for text, Photoshop 

offers fi ve settings (None, Sharp, Crisp, Strong, and Smooth). Depend-

ing on the chosen font, the size, and the application of the text, you 

might fi nd that one of the antialiasing settings produces the best result.

• Think about Fireworks. Okay, so this is less of a solution and more 

of general advice: If you fi nd yourself doing a lot of web graphics and if 

you’re having diffi culty getting your art to play nice with antialiasing, 

Fireworks might be a great application for you to use. If you purchased 

Illustrator as part of Adobe Creative Suite 4, you already own a copy of 

Fireworks, which was built from the ground up to produce web graph-

ics. As an added bonus, Fireworks can easily import Illustrator artwork, 

preserving layers, editable text, and more.

SLICING UP THE WEB
The process of preparing graphics for display on the web is called 

optimization. This process entails choosing how artwork is exported from 

Illustrator, what fi le formats are being used, and what settings are being 

used for each fi le type. One way to optimize web graphics is to use a 

technique called web slicing. In simple terms, web slicing is the process of 

cutting a large image into several smaller images, which is desirable for 

various reasons.

First, there’s user perception. If you try to load a web page that has a single 

large image on it, the user sits there impatiently waiting for it to download 
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and appear on the page. But when an image is sliced into smaller parts, each 

smaller image loads faster, and as a result, it seems like the image itself is 

loading faster.

Second, you can use different fi le formats for each image slice, which can 

save some valuable fi le size space, resulting in a faster-loading graphic over-

all. As you’ll see in the section “Exporting Pixel-Based Images with Save 

for Web & Devices,” these settings directly impact the fi nal fi le size of your 

total image.

Slicing is also helpful if parts of a graphic need to be updated often. Instead 

of always creating larger images, you can update just part of the image. 

Swapping out a slice or two can be more effi cient than having to work with 

one large, bulky fi le all the time.

Finally, because each slice is its own image, you can assign a link (a URL) 

to it, effectively making it a button. When someone clicks a sliced part of 

an image, they are linked to another web page. Of course, you can specify 

other functionality for such a button (or slice) as well.

Any Way You Slice It…
Illustrator offers two ways to create web slices. The more traditional way 

is to draw them yourself, but Illustrator can also create slices from objects 

automatically using a feature called object-based slicing. Let’s explore both 

methods.

Once your artwork is created, you can choose the Slice tool from the 

Tools panel and click and drag in your document window. When you do, 

Illustrator draws rectangular regions—slices—and each appears with a 

number that identifi es it (Figure 13.10 on the next page). As you create 

slices, other dimmed slices might appear automatically in the document. 

These are called auto slices. Slices that you create are called user slices.

Because the overall image has to be rectangular (for an explanation, see the 

sidebar “Web Slices = HTML Tables”) and all the slices must be rectangles 

as well, Illustrator creates slices as necessary (Figure 13.11, also on the 

next page). As you continue to create slices, Illustrator updates the auto 

slices accordingly.
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Figure 13.10 Create slices 
where it makes sense to do 
so to allow for interactivity 
or future editing.

Figure 13.11 As you draw 
slices with the Slice tool, 
Illustrator creates other 
slices to fi ll out the rest of 
the document.

User Slices

Auto Slices
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Web Slices = HTML Tables

So, what exactly happens when you create a slice? Illustrator splits a single 
graphic into multiple images. It creates an HTML table, with each cell of 
the table containing one of these slices, or pieces of the image. In this way, 
when you display the web page in a browser, all the sliced-up images appear 
together, almost like a puzzle. This is an important concept to keep in mind 
because you can create only rectangular slices.

Another thing to keep in mind is that when an Illustrator document contains 
multiple artboards, each artboard maintains its own set of slices by default. In 
essence, this means each artboard results in a separate HTML table.

When you draw a slice with the Slice tool, Illustrator is really drawing a 

rectangle with no fi ll and no stroke and making it a slice (Figure 13.12). 

When you want to edit the slice, you can use the Slice Select tool to change 

the boundaries of the slice.

Figure 13.12 Slices you 
create with the Slice tool 
appear listed in the Layers 
panel. They are special 
rectangles that have their 
Fill and Stroke attributes 
set to None.

However, Illustrator also has a different kind of slice. Instead of creating 

graphics and drawing slices over them, you can apply a slice as an attribute 

to a selection—something Illustrator calls an object-based slice. To apply this 

kind of slice, make a selection, and then choose Object > Slice > Make. 

Illustrator uses the bounds of your selected artwork as the area for the 

object-based slice. Using this method, if you make an edit to your graphic, 

the slice updates automatically along with it.

If you want to hide all the little squares and numbers that indicate slices on 

your screen, you can do so by choosing View > Hide Slices.
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Editing Slice Attributes
You can specify certain attributes for a slice. Remember that a slice is really a 

cell in an HTML table. So, for example, a slice can have its own background 

color or URL link. Once a slice has been defi ned using either of the two 

methods described earlier, you can select it with the Slice Select tool. To 

edit the attributes of a slice, select a slice, and choose Object > Slice > Slice 

Options to specify a URL and alternative (Alt) text, which is used for acces-

sibility (Figure 13.13). When you specify text as an object-based slice, you 

can also set the slice to be an HTML slice (rather than an image slice). In that 

case, Illustrator exports the text as editable HTML instead of as a graphic.

HTML text slices might not show up in a browser exactly as you see them 

in Illustrator. Although bold or character attributes are preserved, exact 

fonts and sizing depend on the browser used. The browser ignores other 

text features, such as kerning and baseline shift.

Once you have created all your slices, you can choose individual fi le formats 

and additional settings by using the Save for Web & Devices feature, which 

we discuss in detail right about…now.

EXPORTING PIXEL-BASED IMAGES
WITH SAVE FOR WEB & DEVICES
At one time, saving a graphic for use on the web was a diffi cult task that 

involved saving an image, opening it in a web browser, and then repeating 

that process again and again. The Save for Web & Devices feature in 

Figure 13.13 The Slice 
Options dialog box gives 
you the ability to assign 
specifi c URLs and additional 
information for each slice in 
your document.

NOTE When exporting 
fi les in the Photoshop 

fi le format, you can preserve 
slices defi ned in Illustrator. 
Refer to Chapter 14, “Saving 
and Exporting Files,” for more 
details.
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Illustrator—which is also found in Photoshop—lets you speed up the process 

of optimizing and saving web graphics.

Once you’re ready to export a fi nal version of your web graphic, choose 

File > Save for Web & Devices to open the Save for Web & Devices dialog 

box. The dialog box, which fi lls up most of your screen, is split into sev-

eral sections (Figure 13.14). Along the far left are several tools you can use 

within the Save for Web & Devices dialog box. In the center, a preview pane 

lets you view up to four versions of your art. The upper-right side offers a 

variety of export formats and their settings, and the lower-right side offers 

a trio of panels that control color, image size, and layer settings. Along the 

bottom of the dialog box are zoom controls, color information, and a 

Preview in Browser button.

Figure 13.14 The Save for Web & Devices dialog box is almost an entire application within itself.

Zoom Color Information Preview in Browser

Color, Image Size, and Layers Panels

Preview Pane Export Formats and Settings
Save for Web & 
Devices tools
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Let’s take a closer look at each of the sections of the Save for Web & Devices 

dialog box:

• Save for Web & Devices tools. The Save for Web & Devices dialog 

box has its own set of tools, which is the fi rst indication that this feature 

is above and beyond just a simple dialog box. The Hand tool lets you 

pan the view of your artwork; it is especially useful when you are view-

ing your art at higher zoom levels. The Slice Select tool enables you to 

select a particular slice with which to work. The Zoom tool allows you 

to change the zoom setting of your artwork, and the Eyedropper tool 

allows you to sample color from an image that appears in the preview 

pane. In addition to the icon that indicates the eyedropper color (you 

can click it to open the Color Picker), there’s also a button that toggles 

slice visibility on and off.

• Preview pane. The preview pane is the main feature of the Save for 

Web & Devices dialog box. By clicking any of the four tabs, you can 

choose to view your original art (as it appears on the Illustrator art-

board), an optimized version of your art (based on the current fi le set-

tings chosen), and 2-up and 4-up versions of your art. Using the 2-Up 

and 4-Up tabs, you can easily compare different fi le settings or how an 

optimized fi le looks compared to its original version. Illustrator displays 

useful information below each preview, including fi le size and estimated 

download times, making it easy to fi nd just the right fi le type for your 

image (Figure 13.15).

Figure 13.15 Besides being 
able to preview the results 
of diff erent fi le and 
compression settings, you 
can also view fi le size and 
estimated download times.
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• Zoom control. The zoom control allows you to easily choose from a 

preset zoom level to view your artwork. Alternatively, you can enter any 

number in the Zoom fi eld.

• Color information. As you move your pointer over artwork in the 

preview pane, the Save for Web & Devices dialog box provides feed-

back for colors in real time. This is helpful if you want to confi rm color 

information or if you want to sample a specifi c color from an image.

• Preview in Browser icon. The Preview in Browser icon is a huge 

time-saver. Although you get a beautiful preview of your artwork in 

the preview pane of the Save for Web & Devices dialog box, it can 

be useful at times to see what your artwork looks like in an actual 

web browser. This is especially useful for when you want to preview 

SWF animations, because those do not preview in the Save for Web & 

Devices dialog box. Clicking the icon previews the selected artwork in 

your computer’s default web browser. Clicking the arrow opens a list of 

installed browsers that you can choose from, or you can edit the list of 

browsers to customize it to your needs.

The two remaining sections feature the group of three panels and the ability 

to choose from different fi le types.

Choosing the Right Image File Type
Overall, the main benefi t of using the Save for Web & Devices feature is the 

ability to compare the fi nal results of multiple fi le formats and choose the 

one that fi ts best for a particular use. To make the right decision, you have 

to understand the differences between each of these fi le formats and what 

their strengths and weaknesses are. Here we’ll discuss the pixel-based GIF, 

JPEG, PNG, and WBMP formats. We’ll discuss the vector-based SWF and 

SVG formats later in the chapter.

Choosing the GIF File Format

A common image fi le format used on the web is the Graphics Interchange 

Format (GIF). The format was developed by the people at CompuServe, 

one of the pioneers of the Internet and the web, though you hardly hear that 

name mentioned today (it’s amazing how fast things change). Recognizing 

the need to send graphics fi les across modem connections (which in those 
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days were quite slow), they developed the GIF fi le format that can contain a 

maximum of 256 colors and uses a lossless method of compression. A GIF 

tries to save space by looking for large areas of contiguous solid color; this 

makes the format perfect for logos, backgrounds, text headlines, and the like. 

However, the 256-color limit and the limited compression for images with a 

lot of detail make the GIF fi le format a bad choice for photographic content.

The GIF fi le format supports other features, including the ability to control 

the exact number of colors present in the fi le and the ability to specify trans-

parency for a single color of the fi le.

When you choose the GIF fi le format in the Save for Web & Devices dialog 

box, you have the following settings available:

• Color settings. The Color Table settings enable to you to specify 

exactly how many colors the GIF will contain. Lower numbers of colors 

result in smaller fi le sizes but could also result in lower-quality images. 

Because a GIF can contain a maximum of 256 colors, you can choose 

from several color-reduction algorithms, including the Restrictive 

option that chooses only web-safe colors.

• Dithering. The Dither settings control what method of dithering is 

used when the image calls for a color that isn’t available in the reduced 

set of colors or when the image is displayed on a computer screen that 

doesn’t support enough colors to display the image.

• Transparency. The Transparency setting enables to you to defi ne 

colors that will display as transparent in a browser. For example, if you 

want to place a logo on a colored background, you can specify the back-

ground color of the GIF to be transparent; doing so causes the back-

ground color in the browser to show through those transparent areas. 

The edges where color meets the transparent edge are usually white 

when displayed in a browser, and specifying a matte color that matches 

the background ensures that the edges of your art blend seamlessly into 

the background (Figure 13.16).

• Interlacing. An interlaced image loads gradually in a web browser, 

fi rst in a low resolution and then in a higher resolution in a second and 

third pass. This allows the image to appear in the browser immediately 

so that viewers can get an idea of what the page will look like, and then 

after a few seconds, the higher-quality image appears. Turning interlac-

ing off means the image won’t display on a web page until the entire 

image has downloaded.

NOTE GIF fi les can 
also contain multiple 

images or frames for creating 
an animation, although 
Illustrator doesn’t support the 
creation of animated GIF fi les.
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• Web Snap. By specifying a value in the Web Snap fi eld, you can have 

Illustrator ensure that a certain percentage of the colors used in the 

graphic are actually web-safe colors.

Choosing the JPEG File Format

JPEG (pronounced “jay-peg”) stands for Joint Photographic Experts Group, 

and it was created to allow photographers to share images using a standard 

fi le format. JPEG fi les can contain millions of colors and use a lossy com-

pression method. Digital images usually contain more color information 

than the human eye can see or detect, and by throwing out some of that 

extra information, JPEG images can achieve amazing fi le size savings. For 

example, a 10 MB photograph can easily be compressed into a JPEG that’s 

less than 1 MB.

Because the JPEG format supports millions of colors (as opposed to only 

256 in a GIF), it’s the perfect format to use for photographs or images with 

complex colors and gradient fi lls. However, JPEG fi les do not support trans-

parency as GIF fi les do.

When you choose the JPEG fi le format in the Save for Web & Devices 

dialog box, you can choose from the following settings:

• Compression/Quality. The Quality settings enable you to specify how 

much information is thrown out of a fi le when the fi le is compressed. 

The settings are actually a bit confusing in the way they are presented 

Figure 13.16 The image 
on the left was saved with a 
matte setting that matched 
the background on which 
the art would eventually 
appear. The image on the 
right used the default matte 
setting of white.
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in the dialog box. You might think that a setting of Maximum would 

mean the highest compression with a smaller resulting fi le size, but 

that’s incorrect. To prevent confusion, it’s best to think of these settings 

as quality settings. A setting of Maximum means the best quality of an 

image, meaning less information is being tossed from the image. The 

result is a better-looking image that is larger in fi le size. Alternatively, 

you can specify numerical values in the Quality fi eld. A setting of 100 

is the same as choosing the Maximum setting.

• Blur. One of the most noticeable side effects of compression in a JPEG 

fi le is artifacts or stray pixels that appear in the image. Specifying a blur 

amount can help cover up those artifacts.

• Matte. The Matte setting enables you to specify a color for the 

edge of the graphic, thus allowing it to blend smoothly into colored 

backgrounds.

• Progressive. The Progressive setting allows a JPEG image to load 

gradually in a browser, similar to the interlacing setting that is available 

for GIF images.

Choosing the PNG File Format

The PNG (pronounced “ping”) format was developed mainly as an alterna-

tive to GIF. Shortly after GIF became popular on the web, the Unisys cor-

poration, which developed the compression algorithm used in GIF, tried to 

collect royalties on its technology from those who used GIF. To get around 

the legal issues, an open standard called Portable Network Graphic (PNG) 

was developed. The PNG format uses lossless compression and can support 

millions of colors. Instead of allowing you to specify a single color as being 

transparent, the PNG format also supports 256 levels of transparency, simi-

lar to alpha channels in Photoshop.

Older web browsers require a special plug-in to view PNG fi les, although 

most newer browsers can display them natively. PNG fi les also might not 

be compatible with some handheld devices and cell phones. PNG fi les come 

in two varieties, 8-bit and 24-bit. The different optimization settings for 

PNG-8 are identical to those found for GIF, mentioned previously.
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Choosing the WBMP File Format

The Wireless Bitmap (WBMP) fi le format is a format that is optimized for 

wireless devices that have slow connections and limited display capabilities. 

These devices are quickly fading because newer phones are being introduced 

constantly, and cell phones are the largest-selling consumer electronic devices 

worldwide. WBMP fi les are black-and-white images (color isn’t supported) 

and are optimized via a dithering setting.

Specifying Additional Image Settings
In addition to choosing a fi le format, the Save for Web & Devices feature 

in Illustrator lets you control how colors, image sizes, and layers are treated 

when saving your fi les. You can fi nd these settings within the three panels 

that appear at the lower-right side of the Save for Web & Devices dialog box.

Color Table

The Color Table panel lists all the colors contained within the selected 

slice. Colors that appear with little diamond icons are web-safe colors 

(Figure 13.17). Using the Eyedropper tool to sample colors, you can click 

the Maps Selected Colors to Transparent icon beneath the panel to specify 

a color that will appear as transparent (when saving to fi le formats that 

support transparency).

Figure 13.17 Illustrator 
indicates web-safe colors 
in a color table with tiny 
diamond-shaped icons.



CHAPTER 13: WEB AND MOBILE DESIGN438

Image Size

The Image Size panel gives you feedback on the actual size of the selected 

slice, and it also lets you specify new sizes, although it’s always better to 

make changes to image size on the Illustrator artboard before launching 

the Save for Web & Devices dialog box. Of importance are the Anti-Alias 

button and Clip to Artboard check box. By default, Illustrator antialiases 

artwork that is exported from the Save for Web & Devices dialog box and 

exports artwork based on the art’s bounding box or your artboard setting. 

To have the Save for Web & Devices dialog box honor the artboard size, 

you can select the Clip to Artboard setting.

Layers

If you specifi ed layers in your Illustrator document, you have the option of 

exporting those layers as CSS layers by selecting the Export as CSS Layers 

option in the Layers panel in the Save for Web & Devices dialog box. 

Cascading Style Sheets (CSS) lets you take advantage of absolute positioning 

and overlapping objects within a web page. Although the technical aspects 

of CSS are beyond the scope of this book, it’s important to realize that CSS 

has become a standard, especially when you’re generating content that will 

be displayed on a wide range of devices.

If you choose to export Illustrator layers as CSS layers, you can choose 

whether each top-level layer in your document should be exported as visible 

or hidden (Figure 13.18). Alternatively, you can specify that certain layers 

aren’t exported at all.

Figure 13.18 CSS layers 
that are exported as hid-
den can be activated via 
JavaScript on the server 
using Dynamic HTML.
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ADDING INTERACTIVITY AND
CREATING ANIMATIONS
Although it’s nice to admire graphics on a web page, nothing is quite like a 

graphic that invokes action on the viewer’s part. It is those images that move 

with animation or that contain clickable hotspots that can take a viewer to 

additional content that make the web such an exciting medium. Although 

Illustrator isn’t a replacement for an application such as Flash, you can still 

create web graphics that come to life using your favorite vector graphics 

application.

Creating Image Maps
On the web, a designer’s job is far more than just creating a pretty graphic. 

Rather, a graphic must draw a viewer to action. The action could be as 

simple as switching to a different page or as signifi cant as generating a sale. 

In Illustrator, you can assign a URL to an object, which results in an image 

map. An image map is a region or portion of a graphic on which a viewer 

can click.

To create an image map, follow these steps:

1. Select an object on your artboard, and choose Window > Attributes to 

open your Attributes panel.

2. Once the panel is open, choose Rectangle or Polygon from the Image 

Map pop-up menu (Figure 13.19). For objects that are rectangular, 

choose the Rectangle option. For images that fi t any other shape, choose 

the Polygon option.

3. Once you’ve chosen an image map type, enter a URL in the fi eld below 

the pop-up menu. For the best results, enter the complete URL, includ-

ing the http://.

Figure 13.19 Older 
browsers supported only 
rectangular image maps, 
but just about all of today’s 
browsers support polygonal 
image maps.
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Illustrator keeps track of all the URLs you enter, so if you’re applying 

the same URL to multiple objects in your document, you can choose 

the correct URL from the URL pop-up (Figure 13.20). To test a URL 

to see whether it is correct, click the Browser button; when you do, 

Illustrator launches your system’s default browser and navigates to the 

chosen URL.

Animation: Making It Move
There’s no question that adding motion to web graphics enhances their 

appearance and ability to garner the attention of viewers. Illustrator can 

build frame-based animations quite easily, although if you’re looking for a 

high-end animation tool, you’d best look elsewhere. The techniques we dis-

cuss here are indicative of the simple animations you can create quickly and 

easily with Illustrator. You might still want to look to Flash and Adobe After 

Effects CS4 for more complex work.

The key to creating great animations in Illustrator is to use layers carefully. 

Illustrator doesn’t have an animation panel or a timeline. Rather, Illustrator 

treats each top-level layer in your document as a frame in your animation. 

As you build your animation with each new layer, keep in mind the advice 

you’ve learned, especially with regard to using symbols (Figure 13.21). 

Illustrator allows you to create blends between symbols and even create 

objects with live effects applied. Refer to Chapter 2, “Selecting and Editing 

Artwork,” for detailed information on creating blends.

Once you’ve created the art for your animation, choose File > Export, and 

choose the Flash (SWF) fi le format. When you select the AI Layers to Flash 

Frames setting, your resulting SWF fi le plays through each layer sequen-

tially. Setting the animation to loop causes the animation to repeat endlessly 

(always fun!). Refer to Chapter 14 for information on the settings found in 

the Flash (SWF) Export dialog box.

Figure 13.20 Once you’ve 
entered a URL in the 
Attributes panel, Illustrator 
remembers it so you can 
easily apply it to other 
objects in your document.

NOTE Animation in 
SVG is not directly sup-

ported in Illustrator. To add 
animation to SVG fi les, you 
can add the code by hand 
once you’ve exported the SVG 
from Illustrator, or you can 
use an SVG animation appli-
cation, such as Ikivo Animator 
(www.ikivo.com).

www.ikivo.com
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Figure 13.21 In this illustra-
tion, the heart shape was 
defi ned as a symbol and 
then used in a blend with a 
custom spine. The symbol 
on the top was then set to 
0% opacity, resulting in a 
blend that makes the heart 
appear to fade out as it 
moves toward the top.

DESIGNING SPECIFICALLY FOR FLASH
After reading this chapter, you’ve undoubtedly realized that you can use 

Illustrator to create interactive SWF fi les. However, if you’re looking to 

develop truly interactive websites, interfaces, and experiences, you’ll soon 

fi nd that the Illustrator capabilities top out rather quickly. Flash is the appli-

cation you want to use to create truly interactive and engaging content.

However, many Flash professionals use Illustrator to design their artwork 

and then bring that artwork into Flash, where they add the interactivity. Both 

Illustrator and Flash are vector-based applications, and many designers are 

familiar with the design environment and powerful design features found in 

Illustrator. In addition, it’s easy to create mock-ups and PDF fi les to submit 

to clients for approval from Illustrator. The challenge, however, is fi nding a 

way to bring rich Illustrator content into Flash while keeping features such as 

artwork, text, gradients, masks, and symbols in an editable state.
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The good news is that if you’re using Illustrator and Flash, you can easily 

move your artwork between the two—all while keeping the fi delity of your 

content. In fact, if you know that your artwork will end up in Flash, you can 

save valuable time by taking advantage of certain features in Illustrator. Let’s 

take a look at some of these features.

Working with Symbols
In Chapter 9, “Designing with Effi ciency,” you learned how to both defi ne 

and edit symbols. When working with Flash, creating symbols is extremely 

important because they allow you to easily add interactivity and make global 

changes, all while keeping fi les sizes small and manageable.

When you defi ne a new symbol in Illustrator (F8), you’re presented with 

the Symbol Options dialog box (Figure 13.22), which offers three settings. 

These settings don’t have any effect on the symbol within Illustrator and are 

useful only when you bring the symbol into Flash.

• Type. Flash uses several types of symbols for different tasks. You can 

wait until you bring your symbol from Illustrator into Flash to deter-

mine what kind of symbol it should be, or to save time, you can specify 

the symbol type at the time you fi rst defi ne the symbol in Illustrator. A 

Graphic symbol is used for static artwork, while a Movie Clip symbol 

can contain interactivity within it.

• Flash Registration. The Flash Registration setting lets you defi ne an 

origin point for the symbol. This origin point is used when you apply 

transformations in Flash or when ActionScript commands are applied 

to the symbol. This setting is similar to what you learned in Chapter 2 

with the Transform panel.

Figure 13.22 The Symbol 
Options dialog box gives 
you the ability to name the 
symbol and to apply certain 
Flash-specifi c settings.
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• Enable Guides for 9-slice scaling. Flash has the ability to scale sym-

bols in a special way to prevent distortion. For example, you can specify 

that only parts of a symbol scale, while other parts don’t. To control 

exactly how symbols scale, select the “Enable Guide for 9-slice scaling” 

option in the Symbol Options dialog box, and then click OK. Then, 

double-click the symbol to edit it, at which time you’ll see a series of 

guides appear (Figure 13.23). Use the Selection tool to position the 

guides as desired, and the symbol will scale appropriately when trans-

forms are applied to it in Flash.

In addition, you can name each symbol instance that you place on your 

artboard. Giving an instance a name lets you reference that instance from 

within ActionScript code in Flash. When any symbol instance is selected on 

your artboard, you can give it a name in the fi eld that appears in the Control 

panel (Figure 13.24).

Figure 13.23 The “Enable 
Guide for 9-slice scaling” 
option lets you control 
which parts of a symbol 
scale and which don’t. If you 
think about the artwork as 
being divided up by a tic-
tac-toe board, the corner 
and center areas don’t scale, 
while the center-top and 
center-side areas do.

Figure 13.24 Applying 
instance names in Illustrator 
can save plenty of time 
later in your workfl ow, after 
bringing your art into Flash.
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Working with Text
As you learned in Chapter 8, “Working with Typography,” Illustrator 

has sophisticated type controls and features. However, when developing 

Flash content, text can also be interactive. Rather than waiting to add that 

interactivity in Flash, you can specify interactive text for Flash right in 

Illustrator. Choose Window > Type > Flash Text to defi ne text destined 

for Flash as either static, dynamic, or input text (Figure 13.25). Static text 

doesn’t change within the Flash fi le, while you can change dynamic text 

using ActionScript. Input text is used when building things such as Flash 

forms, where a user would be asked to enter custom information.

Bringing Your Artwork into Flash
Once you’ve created your artwork in Illustrator, you need a reliable way to 

bring your graphics into Flash. In previous versions of both Illustrator and 

Flash, this was anything but easy. However, in the CS4 versions of these 

components, it’s actually quite easy.

To quickly move individual pieces of art, you can simply copy and paste from 

Illustrator into Flash. Any defi ned symbols will be retained, as well as text and 

other settings. However, you may want to bring an entire Illustrator fi le into 

Flash, preserving layers and document structure as well. To do so, save your 

fi le as a native Illustrator document (.ai), because Flash CS4 Professional 

is able to read native Illustrator fi les. From Flash, choose File > Import to 

Stage, and choose the Illustrator fi le you saved. An import dialog box will 

appear listing each object in your fi le. The import dialog box offers many 

options, including the ability to choose from multiple artboards, to keep text 

editable, and to convert objects to movie clip symbols on the fl y.

Figure 13.25 The Flash 
Text panel gives you control 
over how text objects in 
Illustrator will behave when 
brought into Flash.



EXPORTING VECTOR-BASED IMAGES WITH SAVE FOR WEB & DEVICES 445

EXPORTING VECTOR-BASED IMAGES
WITH SAVE FOR WEB & DEVICES
Earlier in the chapter, we covered the pixel-based fi le formats that are avail-

able for export in the Save for Web & Devices dialog box. Here, we present 

the two vector-based formats: SWF and SVG.

Choosing the SWF File Format
Shockwave Flash (SWF) is a popular web-based fi le format that supports 

both vectors and rasters. This Flash fi le format has become extremely popu-

lar because of its capability to contain interactive or animated content. You 

can use Illustrator to generate a SWF fi le that you want to upload directly 

to a website or to create art for import into the Adobe Flash application for 

further editing.

When you choose the SWF fi le format in the Save for Web & Devices dialog 

box, you can choose from the following settings:

• File options. You can create SWF fi les in one of two ways: AI File to 

SWF File that creates a single SWF fi le that contains all your Illustrator 

artwork and AI Layers to SWF Frames where each layer is converted 

into a keyframe, resulting in a single animated SWF fi le. Additionally, 

you can choose the Protect File option to prevent others from opening 

the resulting SWF fi le. The Text as Outlines option converts all text to 

outlines (so no font fi les are necessary), and you can make the fi le size 

smaller by choosing the Compressed option. The Curve Quality setting 

controls the fi delity of curved paths.

• Appearance. When using transparency or other special effects in 

Illustrator, you can choose Preserve Appearance, which fl attens any 

effects as necessary, or you can choose the Preserve Editability Where 

Possible option if you plan on opening the fi le in Flash to edit it. This 

way, you can make additional tweaks to the artwork if you need to do so.

• Animation settings. If you choose the AI Layers to SWF Frames 

option, all layers in your Illustrator fi le become keyframes and play 

as an animation when the SWF fi le is viewed in a web browser. The 

Frame Rate setting controls the speed at which the animation plays 

(you can’t control the timing of individual frames like you can in a GIF 

TIP The Flash (SWF) 
Export dialog box 

off ers additional options for 
creating SWF fi les that are not 
present in the Save for Web & 
Devices dialog box. For 
detailed information about 
the Flash format and these 
additional settings, see 
Chapter 14.
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animation), and the Looping option forces the animation to repeat con-

tinuously. You can fi nd more information about creating animated SWF 

fi les in the earlier “Animation: Making It Move” section).

Choosing the SVG File Format
Scalable Vector Graphics (SVG) is an XML-based fi le format that is used 

primarily on the web and has recently become more popular in creating 

content for cell phones and handheld wireless devices.

Most web browsers require a special plug-in to view SVG fi les. Because 

SVG fi les are text-based, they can be edited easily, even after they have been 

exported and uploaded to a web server. Because of this ability, SVG fi les 

are used in data-driven, server-based workfl ows where customized content 

is a necessity.

When you choose the SVG fi le format in the Save for Web & Devices dialog 

box, you can choose from the following settings:

• DTD. The DTD setting (which stands for document type defi nition) is 

akin to the version of SVG with which your fi le is compatible. Because 

SVG is an open standard, additional specifi cations are revised and 

approved. If you save an SVG fi le with a particular DTD, it means your 

fi le will be compatible with any device that supports that DTD. Newer 

specifi cations usually support more functionality than the older ones 

did. SVG Tiny (also referred to as SVG-t) is a subset of SVG used for 

displaying content on SVG-enabled cell phones. SVG Basic is another 

subset used for displaying content on PDAs.

• Fonts. When text is present in your fi le, you can specify the Adobe 

CEF type, which results in better-looking text when your fi le is viewed 

with the Adobe SVG Viewer, but which may not be supported with 

other SVG viewers. SVG creates more compatible text, but this text may 

not be as readable at smaller font sizes. Alternatively, you can convert all 

text to outlines, which increases fi le size.

• Images. When you save a fi le in SVG, you have the ability to embed 

any images within the SVG fi le (making for larger but self-suffi cient 

fi les), or you can choose to create smaller SVG fi les by using the 

Link option.

TIP You can fi nd more 
information on SVG at 

www.svg.org and www.adobe.
com/svg.

www.svg.org
www.adobe.com/svg
www.adobe.com/svg
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• CSS Properties. You can format SVG code in a variety of ways, and 

the CSS Properties setting lets you determine how object attributes are 

coded in the fi le. For the most part, this setting affects the performance 

of your fi le when viewed.

• Decimal Places. Illustrator allows you to specify how precisely vec-

tor paths are drawn. You may choose a value from 1 to 7, where higher 

numbers result in better-looking paths at the expense of fi le size and 

performance.

• Encoding. When you save an SVG fi le that contains text, you can 

specify a character encoding, including ISO-8859-1 (suitable for Euro-

pean languages) and 8- or 16-bit Unicode (suitable for more complex 

languages).

• Optimize for Adobe SVG Viewer. If people will be using the Adobe 

SVG Viewer to view your SVG fi les, you can select this option that 

takes advantage of proprietary optimizations that exist in the Adobe 

SVG Viewer, including faster rendering of SVG fi lter effects.

USING ADOBE DEVICE CENTRAL
Although most web graphics today are viewed on computer screens, it is 

becoming more and more popular to view web content on web-capable cell 

phones. Especially with the release of devices such as the Apple iPhone, you 

can be sure that any graphics you create for the web will also be viewed on 

handheld devices. So although the Save for Web & Devices feature is nice 

on its own, it really doesn’t give you a good idea what your artwork will 

look like when viewed on a mobile phone.

Included with Adobe Illustrator CS4 (or any of the myriad of Adobe 

Creative Suite 4 choices) is a component called Adobe Device Central CS4, 

which enables you to preview and test your artwork as it would appear and 

run on a mobile device.

Adobe Device Central is really a full-blown application on its own and 

therefore is beyond the scope of this book. With regard to Illustrator, you 

can perform two specifi c functions with the assistance of Adobe Device 

Central: You can create a new document at the proper size for a specifi c 

mobile devices or a group of devices, and you can preview or test content 

on a mobile device or a group of devices.
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• Creating a Mobile and Devices document. From the Illustrator 

welcome screen, you can click the Mobile and Devices document pro-

fi le. This launches Adobe Device Central where you can choose which 

devices you want to design content for. Upon choosing a single device 

profi le (or a range of device profi les), you can click the Create button, 

found at the lower-right corner of the Adobe Device Central window 

(Figure 13.26). A new Illustrator document will then automatically be 

created at the correct size.

• Testing mobile content. To see what your web graphics will look like 

on a mobile device, click the Device Central button that appears in the 

lower-right corner of the Save for Web & Devices dialog box in Illustrator. 

Adobe Device Central launches, and you can preview and test your con-

tent on the devices that you specify (Figure 13.27).

One important thing to keep in mind is that Adobe Device Central is 

geared specifi cally for previewing and testing Flash Lite content. Flash Lite 

isn’t a plug-in that runs in a web browser (like Adobe Flash Player does). 

Rather, Flash Lite is a runtime that runs directly on the phone (almost like 

an operating system). As such, Adobe Device Central provides information  

Figure 13.26 Once you’ve 
selected a device profi le in 
Adobe Device Central, you 
can choose to create a new 
Illustrator document.

NOTE Flash Lite 3, 
which is the latest 

available version at the time 
of the printing of this book, 
supports Flash Player 7 (and 
ActionScript 2.0), so when 
you export content from 
Illustrator, make sure you 
don’t specify a later version 
of Flash Player compatibility.
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only on phones that support Flash Lite. In the United States, for example, 

Verizon is the only carrier that supports such phones (and its selection of 

supported devices is limited). Flash Lite–enabled phones are popular in 

Europe and Asia. That being said, Adobe Device Central still provides valu-

able information about a phone’s screen resolution and browser capabilities 

that can be useful for any kind of graphics creation.

How Popular Is Flash Lite?

Flash content can be displayed only on a mobile device that supports it. Although Adobe will advertise that 
millions of handsets around the world support Flash Lite, that statement won’t mean much to those living in 
the United States, where limited availability of Flash-enabled phones means only a small segment of users will 
be able to view the content you create.

But that may change. Adobe has been instrumental in the formation of a collaboration called the Open Screen 
Project (www.openscreenproject.org), which is focused on delivering a consistent viewing experience across 
all kinds of devices and screens. A large part of Adobe’s participation in this group was the decision to drop 
licensing fees for installing Flash Lite on mobile devices (previously, handset manufacturers such as Nokia had 
to pay fees to Adobe per device the software was installed on). Adobe’s hope is that without the barriers of 
licensing fees, Flash Lite will gain adoption in more markets, including the United States.

Figure 13.27 More than 
just a preview, the Emulator 
panel allows you to click 
the buttons of the phone 
and see how your artwork 
responds to user interaction.

www.openscreenproject.org
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FUTURE WEB WORKFLOWS
One of the most exciting things about the web is how quickly the technol-

ogy changes, bringing new capabilities on what seems like a daily basis. 

Admittedly, this is also one of the most frustrating things about the web, 

because it’s a constant struggle to keep up. However, it’s easy to see the ben-

efi ts of keeping abreast with technology, especially in web design. Although 

markup languages like CSS and XML were nice things to have just a few 

years ago, in today’s Google-based world where search engine optimization 

(SEO) is something every website administrator needs to think about, 

Web 2.0 standards are essential.

Likewise, Adobe has been pushing its own web-based solutions—to the 

point where these solutions extend beyond the web itself, and directly onto 

your desktop. Normally, you use a web browser to view web content. But 

these days, content from the web appears all around us—be it a stock quote 

on your mobile phone, a notifi cation about a canceled fl ight via an email or 

text message, or a weather forecast in a widget or gadget on your computer’s 

desktop.

Instead of developing “websites” where content is displayed within the 

confi nes of a web browser, web developers are building interactive experi-

ences that play directly on your desktop (sometimes referred to as rich Inter-

net applications). Adobe Integrated Runtime (AIR) is a platform that Adobe 

created to allow web developers to deliver these applications with a consis-

tent experience across any computer platform (Mac OS, Windows, Linux, 

and at some point, mobile devices as well). Although AIR applications 

can be developed using just about any modern web technology (HTML, 

JavaScript, and so on), developers can also use Flash or Adobe’s Flex frame-

work. However, although designers are comfortable within the design 

environment of programs such as Photoshop, Illustrator, or Fireworks, 

developers live within the advanced coding environments found within 

Flash and Flex Builder. As such, there is sometimes a disconnect between 

the design and development phases of a web project.

Illustrator CS4 features a new fi le format in its Save As dialog box, called 

FXG. The speculation is that FXG will become an interchange format to 

allow graphics to pass between Illustrator and future applications that will 

be built specifi cally for both designers and developers. In this way, you 

can design elements within your familiar design applications and yet still 
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develop the code necessary to make a website or a rich Internet application 

fully functional.

At the time of the writing of this book, Adobe has publicly shown one 

such designer/developer application—“Adobe Flash Catalyst.” In this 

application, Adobe displays the ability to import FXG graphics into Flash 

Catalyst, where each of those graphics can be quickly converted to func-

tional Flex code. Similar to the Edit Original workfl ow we discussed in 

Chapter 12, “Working with Images,” you can edit a graphic in Illustrator 

and that graphic updates automatically in Flash Catalyst, where the 

underlying Flex code updates automatically as well.

Illustrator CS4, Photoshop CS4, and Fireworks CS4 can already create 

FXG artwork, and for more information on saving FXG fi les from 

Illustrator, refer to Chapter 14. For more information on Flash Catalyst, 

visit http://labs.adobe.com.

http://labs.adobe.com
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Chapter 
FourteenSaving and Exporting Files

The task of saving and exporting your Adobe 

Illustrator CS4 fi les is obviously very impor-

tant. Illustrator is a fantastic utility that can 

open a wide variety of fi le types, including 

EPS and PDF. Additionally, you can use Illustrator to save and export fi les 

in just about any format you need, including SWF and FXG. If you aren’t 

familiar with these fi le types, it’s okay, because that’s what this entire 

chapter is about.

With so many fi le formats to work with, how do you know which format 

to use when you’re saving or exporting a fi le? How do you know what each 

fi le format supports and what they are each used for? Throughout this chap-

ter, you will learn the strengths and weaknesses of each fi le format and see 

examples of when to use or not use each.

453

Native Data PostScript
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SAVING FILES FROM ILLUSTRATOR
When you save a document from Illustrator using any of the fi le formats 

found in the Save or Save As dialog box, you are able to reopen that fi le 

and edit it as needed. When you do, all native information, by default, is 

preserved in the fi le. For example, if you save a fi le as an EPS document, 

you can reopen the EPS fi le in Illustrator and make edits to the fi le with 

no loss of functionality or editability. Adobe calls this round-tripping, and 

working in this way has many benefi ts.

If you create a fi le in Illustrator but you need to place it into a 

QuarkXPress document, you’ll learn that you can create an EPS fi le. 

Because an Illustrator EPS fi le is round-trippable, you can place the EPS 

fi le into your QuarkXPress layout, yet you can edit that same EPS fi le in 

Illustrator if you need to make changes.

As you will fi nd out, Illustrator accomplishes this by using what engineers 

call dual-path fi les. This means a single fi le contains two parts in it: One 

part contains the EPS data that QuarkXPress needs; the other contains the 

native Illustrator information that Illustrator needs. As we explore the dif-

ferent formats and their settings, this dual-path concept will become clear.

The Native Illustrator (.ai) Format
By default, when you choose to save a new fi le, the fi le format setting is 

Adobe Illustrator Document. Whenever you create documents, it’s best to 

save them as native Illustrator fi les, because they will always contain rich 

and editable information.

Up until Illustrator 8, the native fi le format for Illustrator was PostScript 

(EPS), but for a variety of reasons, with the release of Illustrator 9, Adobe 

changed the native fi le format to use the PDF language. In fact, Adobe is 

quick to tell you that a native Illustrator fi le can be opened and viewed in 

Adobe Acrobat or the free Adobe Reader. Adobe also advertises that you 

can place native Illustrator fi les directly into Adobe InDesign layouts. It 

makes sense when you think about it, because if the native fi le format for 

Illustrator is using the PDF language, then placing it in InDesign is similar 

to placing a PDF fi le in InDesign.

In reality, though, the native fi le format is a special fl avor of the PDF 

language—a fl avor that only Illustrator can understand. Certain constructs 

NOTE The latest 
version of QuarkXPress 

available at the time of 
the printing of this book, 
version 8, features the ability 
to place native Illustrator fi les 
in addition to EPS fi les. See 
the section “Print Workfl ows” 
later in this chapter for more 
information.

NOTE When creating 
documents that you 

plan to use as a base for other 
fi les, you may choose to save 
your fi le as an Illustrator 
Template (.ait). Details on this 
format appear in Chapter 1, 
“Creating and Managing 
Documents.”
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exist in Illustrator that do not exist in the PDF language, such as live blends, 

Live Paint effects, and live effects (these effects are all expanded when printed 

or translated to regular PDF). You can think of the native fi le format for 

Illustrator as a superset of the PDF language. If this is the case, however, 

how is InDesign or Acrobat able to import and display native Illustrator 

fi les? That’s where the dual-path concept comes in.

When you save a native fi le, Illustrator embeds two fi les—a native Illustrator 

fi le (.ai) and a standard PDF fi le (Figure 14.1). When you place the native 

Illustrator fi le into InDesign, the application sees the PDF portion and uses 

that for display and printing. When you reopen the fi le in Illustrator, the 

application sees the native Illustrator portion and uses that for editing. In the 

end, everyone is happy, and you get to work with a single fi le.

To save your fi le as a native Illustrator fi le, choose File > Save, and choose 

Adobe Illustrator (ai) from the format pop-up menu. When you click Save, 

you are presented with the Illustrator Options dialog box where you can 

specify settings for how your fi le should be saved. These are described in 

the section “Native Illustrator File Format Settings.”

Legacy Illustrator Formats

Illustrator CS4 allows you to save your fi le so that it is compatible with a 

variety of previous versions of Illustrator. Obviously, the older the version 

you specify, the less editable your fi le will be. Specifi cally, you should be 

aware of three distinctions:

• Adobe Illustrator CS4 is the fi rst version to support multiple artboards. 

If you save your fi le to any previous version of Illustrator, you can 

choose to either combine all artboards into one or save individual fi les.

Figure 14.1 When you save 
a native Illustrator fi le, you’re 
really saving two fi les. The 
PDF fi le that is created with 
the native Illustrator fi le is 
PDF 1.5, which preserves 
transparency.

NOTE The two fi les in 
an Illustrator fi le print 

and display the same and are 
identical except the native 
Illustrator version maintains 
more editability in the 
Illustrator environment.

Native Data PDF 1.5
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• Adobe introduced a new text engine in Illustrator CS. If you save your 

fi le to any version prior to Illustrator CS, your text is either broken 

apart or converted to outlines. For more details, see “Saving Illustrator 

CS4 Files to Illustrator Legacy Versions” in Chapter 8, “Working with 

Typography.”

• Adobe introduced transparency features in Illustrator 9. If you save your 

fi le to any version prior to Illustrator 9, transparency fl attening will 

occur, resulting in a document that may be extremely diffi cult, or even 

impossible, to edit. For more details, see “Learning the Truth About 

Transparency” in Chapter 15, “Prepress and Printing.”

Your fi le will print or display correctly when you’re saving to older versions 

because appearance is always maintained. However, you are limited in what 

kinds of edits you can make in your fi le. For this reason, we recommend you 

always save a native CS4 version of your fi le to keep on your computer or 

server for editing purposes. If someone else requests a fi le from you that is 

compatible with a previous version of Illustrator, send them a copy of your fi le.

Native Illustrator File Format Settings

A variety of settings are available in the Illustrator Options dialog box 

(Figure 14.2), and depending on your needs for each particular workfl ow, 

you can adjust these settings.

Figure 14.2 The Illustrator 
Options dialog box allows 
you to specify which version 
of Illustrator you want your 
fi le to be compatible with, 
among other settings.
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• Version. The Version pop-up menu allows you to choose which ver-

sion of Illustrator you want your fi le to be compatible with. See the 

previous section, “Legacy Illustrator Formats,” in this chapter for more 

information.

• Fonts. When you’re saving a fi le, any fonts you use are embedded in the 

PDF portion of the fi le. This allows other applications to print the fi le 

without requiring the fonts. However, you still need the fonts installed 

if you are going to reopen the fi le in Illustrator. This setting is disabled 

when the Create PDF Compatible File option is deselected (see the next 

description). At the 100% setting, Illustrator embeds only those char-

acters of a font that are necessary to print the text in your document. 

Using a setting much lower (such as to 0%) embeds the entire font, 

resulting in a larger fi le. Fonts with permission bits turned on cannot 

be embedded (see the sidebar “Font Embedding and Permissions” later 

in this chapter).

• Create PDF Compatible File. The Create PDF Compatible File 

option embeds a full standard PDF 1.5 fi le in your Illustrator document. 

As just mentioned, this allows applications such as Acrobat or InDesign 

to read and place native Illustrator fi les. Deselecting this option effectively 

cuts your fi le size in half and also reduces how long it takes to save an 

Illustrator fi le (Figure 14.3). If you use Illustrator for all your work and 

print directly from Illustrator, you can select this option to enhance per-

formance and to create smaller fi le sizes, but be aware that you won’t be 

able to place your fi le into an InDesign layout. Even if you do deselect 

this option, you can always reopen the fi le in Illustrator and resave the 

fi le with the option selected.

Figure 14.3 When you have 
the Create PDF Compatible 
File option deselected, only 
the native Illustrator portion 
is saved with the fi le, cut-
ting save time and fi le size 
in half. The result, however, 
is a native fi le that cannot 
be placed into another 
 application.

Native Data
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• Include Linked Files. When you select the Include Linked Files 

option, any place-linked fi les are embedded in your document. 

Although this means you can send the fi le to someone without requir-

ing any external links, it also means you can’t easily update linked 

graphics anymore. This option also increases fi le size because the 

images are now included in the fi le.

• Embed ICC Profi les. The Embed ICC Profi les option includes any 

color profi les (including those from placed images) in your document.

• Use Compression. The Use Compression option employs compres-

sion algorithms to your fi le to try to reduce fi le size.

• Save each Artboard to a Separate File. If you choose anything other 

than Illustrator CS4 in the Version pop-up menu, this setting will 

appear. If your fi le contains multiple artboards, you can have Illustrator 

create individual fi les for each artboard (or a specifi ed range of artboards). 

Alternatively, leaving this option deselected will result in all your 

artboards being combined into a single large artboard, which would 

be compatible with previous versions of Illustrator.

• Transparency. When you’re saving to an Illustrator 8 or Illustrator 3 

format, transparency fl attening must occur in documents that contain 

transparency effects. You can choose to discard the transparency effects 

completely (which preserves path geometry), or you can choose to pre-

serve the appearance of your fi le. You can also choose from the list of 

available transparency fl attener presets. For more information on which 

fl attener preset to use, refer to Chapter 15.

The Encapsulated PostScript (.eps) Format
When Adobe introduced PostScript to the world, it forever changed the face 

of design and publishing. Since desktop publishing became a buzzword, 

the format in which designers and printers exchanged fi le information was 

always EPS. To this day, EPS is a reliable, universal format that can be used 

to reproduce graphics from just about any professional (and even some non-

professional) graphics applications.
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PostScript doesn’t support transparency, so if your fi le contains any trans-

parency effects, those effects are fl attened when the document is saved as 

EPS (see Chapter 15). However, you can still reopen and edit the native 

transparency in Illustrator CS4 because Illustrator also uses a dual path 

when saving EPS fi les. An Illustrator CS4 EPS fi le has two portions in it: a 

native version for editing in Illustrator and an EPS version that other appli-

cations, such as QuarkXPress, use (Figure 14.4).

To save your fi le as an EPS fi le, choose File > Save, and from the pop-up 

menu choose Illustrator EPS. When you click Save, you are presented with 

the EPS Options dialog box where you can specify settings for how your 

fi le should be saved, as described later in the section “EPS File Format 

Settings.”

Legacy EPS Formats

As with native fi les, Illustrator allows you to save your fi le so that it is 

compatible with a variety of versions of Illustrator EPS. This setting affects 

both the native portion and the EPS portion of the fi le. When you save a fi le 

that is compatible with an older version of Illustrator, both the native data 

and the PostScript are written so they are compatible with that version 

(Figure 14.5 on the next page). Obviously, the older the version you specify, 

the less editable your fi le is. The same rules mentioned for native Illustrator 

fi les apply here (with regard to versions that result in loss of text and trans-

parency editability), and it always makes sense to save an Illustrator CS4 

EPS for your own needs and deliver older or legacy EPS versions for others, 

as needed.

Figure 14.4 When you save 
a document as an EPS fi le, 
Illustrator also embeds a 
native version of the fi le so 
that you can reopen and 
edit the fi le in Illustrator 
with no loss in editability.

Native Data PostScript
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Note that with the inclusion of multiple artboards in Illustrator CS4, you 

now have the additional option of Use Artboards in the Save dialog box. 

For details, see the sidebar “Saving and Exporting Artboards” later in this 

chapter.

EPS File Format Settings

A variety of settings are available in the EPS Options dialog box 

(Figure 14.6), and depending on your needs for each particular 

workfl ow, you can adjust these settings:

• Version. The Version pop-up menu allows you to choose which version 

of Illustrator EPS you want your fi le to be compatible with. See the pre-

ceding section, “Legacy EPS Formats,” for more information.

• Preview. The Preview setting lets you choose from different options 

for embedding a preview in your EPS fi le. Because most programs can’t 

display PostScript on your computer screen, a low-resolution preview 

is stored along with the fi le so that programs such as QuarkXPress or 

Microsoft Word can give you a visual representation of what the fi le will 

look like in your layout.

• Transparency. If your fi le contains transparency, your fi le must be 

fl attened so that it can be saved in PostScript and printed from another 

application (remember, the version you choose determines whether the 

native portion of the fi le, which Illustrator reads when it reopens the 

fi le, still contains editable, unfl attened data). Although you can choose 

different transparency fl attener presets from the pop-up menu, it almost 

always makes sense to choose the High Resolution setting, because 

you’ll always want to get the best possible results when printing the 

EPS fi le from other applications (see “Choosing File Formats Based 

on Workfl ow” later in this chapter).

Figure 14.5 When you 
save a fi le in Illustrator 8 EPS 
format, the native portion 
of the fi le is also saved in 
Illustrator 8 format, which 
doesn’t support transpar-
ency. Even if you reopen 
the fi le in Illustrator CS4, 
any transparency that was 
in the fi le is fl attened.

Native Data  PostScript
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• Embed Fonts. When this option is selected, any fonts used are embed-

ded in the EPS portion of the fi le. This allows other applications to 

print the fi le without requiring the fonts. However, even with the set-

ting selected, you still need the fonts installed if you are going to reopen 

the fi le in Illustrator. Fonts with permission bits turned on can’t be 

embedded (see the sidebar “Font Embedding and Permissions” later in 

this chapter).

• Include Linked Files. Selecting the Include Linked Files option embeds 

any place-linked fi les in your document. Although this means you can 

send the fi le to someone without requiring any external links, it also 

means you can’t easily update linked graphics anymore. This option also 

increases fi le size because the images will now be included in the fi le.

• Include Document Thumbnails. Use this option if you want to be 

able to see a preview of your fi le in the Open and Place dialog boxes in 

Illustrator.

• Include CMYK PostScript in RGB Files. This setting allows you to 

maintain RGB colors in your Illustrator fi le but have the EPS portion 

of the fi le converted to CMYK so other applications that don’t support 

RGB can still print the fi le correctly.

• Compatible Gradient and Gradient Mesh Printing. If you experi-

ence problems printing EPS fi les saved from Illustrator on older print 

devices, try selecting this option.

• Use Printer’s Default Screen. This instructs the PostScript to use the 

line screen of the default setting of the printer.

• Adobe PostScript. Use this pop-up menu to write the EPS fi le as 

PostScript LanguageLevel 2 or LanguageLevel 3. Illustrator uses 

LanguageLevel 2 as the default setting in order to create a fi le that is 

compatible with a wider range of devices, but LanguageLevel 3 offers 

certain benefi ts such as smooth shading technology to prevent banding 

in gradients.
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The Portable Document Format (.pdf)
Walk up to just about anyone on the street these days and ask them about 

Adobe. Most will reply, “Oh, sure, I have Adobe on my computer.” What 

they are probably referring to is the free Adobe Reader fi le viewer, which 

enables just about anyone to view and print PDF fi les. Now that Reader has 

reached a billion downloads worldwide, PDF fi les are ubiquitous and have 

become a standard format used not only by designers and printers but also 

by governments and enterprise corporations.

Over the past few years, PDF has become the format of choice for both 

printers and designers, replacing EPS and other formats. There are several 

reasons for this, including the following:

• Smaller fi le sizes. PDF supports a variety of image compression tech-

niques, resulting in smaller fi le sizes. In addition, users can easily create 

low-resolution fi les to send to clients for review and can create high-

resolution fi les to send to printers for high-quality output.

Figure 14.6 The EPS 
Options dialog box off ers a 
variety of settings to choose 
from when you’re saving an 
EPS fi le, including the type 
of preview you want saved 
in the fi le.
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• A free universal viewer. Reader is free and available for nearly every 

computer platform, including Palm-based handheld devices. This 

means a designer can deliver a PDF fi le and be assured that anyone can 

view the fi le correctly.

• Ability to embed fonts. A PDF fi le is a single, self-contained fi le that 

includes all necessary images and fonts. This makes it easier to distrib-

ute and reduces the chance of error.

• Easy to create. Designers can easily create PDF fi les from any Adobe 

application. Additionally, Adobe supplies a utility called PDFMaker, 

which comes with Acrobat, that enables users to instantly create PDF 

fi les from Microsoft Offi ce documents or AutoCAD fi les. Note that 

PDFMaker was dropped for the Mac in Acrobat 9. A PDF virtual 

printer also enables a user to create a PDF fi le simply by printing a fi le 

from any application.

• Security. PDF fi les can contain multiple levels of security that can 

restrict functionality such as printing or editing. This ensures the integ-

rity of a fi le and gives designers the ability to protect their work.

By default, a PDF saved from Illustrator is also a dual-path fi le, containing 

both PDF data and native Illustrator data (Figure 14.7). In fact, if you think 

about it, saving a native Illustrator fi le and an Adobe PDF fi le is quite simi-

lar. When you save a PDF fi le from Illustrator, though, you can control a 

variety of settings in the resulting PDF data of the fi le.

To save your fi le as a PDF fi le, choose File > Save, and select Adobe PDF 

from the pop-up menu. When you click Save, you are presented with the 

Save Adobe PDF dialog box where you can specify settings for how your 

fi le should be saved.

TIP You can instruct 
clients or users to 

download the free Reader at 
www.adobe.com/products/ 
acrobat/readstep2.html. 
Reader is available for Mac, 
Windows, Unix, and a variety 
of mobile platforms.

Figure 14.7 If you’ve ever 
heard that Illustrator creates 
large PDF fi les, it’s prob-
ably because by default 
Illustrator embeds a native 
version of the fi le along with 
the PDF data, resulting in a 
PDF fi le that appears twice 
as large.

PDF Native Data

www.adobe.com/products/acrobat/readstep2.html
www.adobe.com/products/acrobat/readstep2.html
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Different Uses of PDF Files

Before we discuss all the different options available when saving a PDF fi le, 

it’s important to realize that PDF fi les have many uses. For example, you 

might create a PDF fi le to send to a client so that they can approve a design, 

or you might create a PDF fi le to send to a printer for fi nal output. Alterna-

tively, you might even create a PDF fi le to upload to a website so that any-

one can view the content. Each of these PDF fi les serves a different purpose, 

and therefore each can have very different settings. Just because you create a 

PDF fi le doesn’t mean you can use it for any and all purposes.

Instead of having to manually specify PDF settings each time you want to 

create a fi le for a specifi c purpose, Illustrator offers to let you create Adobe 

PDF presets, which capture all the settings a PDF can have. At the top of 

the Save Adobe PDF dialog box, a pop-up menu lets you choose from some 

presets that ship with Illustrator (Figure 14.8), or you can defi ne your own 

by clicking the Save Preset button at the bottom left of the dialog box.

NOTE PDF presets are 
similar to Distiller Job 

Options, which are simply a 
captured set of PDF settings.

Figure 14.8 Illustrator ships 
with several predefi ned 
PDF presets. If you’re using 
other Adobe Creative Suite 4 
components, any PDF preset 
you save in Illustrator also 
becomes available in all the 
other applications.
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Acrobat Version Compatibility

When PDF was fi rst introduced, it had limited support (spot colors weren’t 

supported until version 1.2), but as each new version of Acrobat has been 

introduced, Adobe has updated the PDF language specifi cation (called 

PDFL for short) to include more advanced functions and to feature new 

capabilities.

Adobe released PDFL version 1.3 when it introduced Acrobat 4.0, which 

was the fi rst mainstream version of Acrobat and the free Reader. With each 

new version of Acrobat, Adobe has also revised the PDFL version (Acrobat 

5 = PDF 1.4, Acrobat 6 = PDF 1.5, and so on), although trying to remem-

ber all of these different numbers can prove quite confusing. An easy way 

to fi gure it out is to remember that if you add up the numbers in the PDFL 

version, it equals the corresponding version of Acrobat (1+4 = 5).

In any case, when you save a PDF fi le from Illustrator, you can specify 

which version of Acrobat you want your fi le to be compatible with in the 

Save Adobe PDF dialog box (Figure 14.9). Although saving a fi le using a 

newer version compatibility setting offers more options when saving, 

anyone who wants to view that PDF fi le needs to use a newer version of 

Acrobat or Reader to see and print the fi le correctly.

Figure 14.9 The Save 
Adobe PDF dialog box off ers 
a plethora of settings for 
creating PDF fi les for a wide 
variety of purposes. The 
Compatibility setting deter-
mines the version of Acrobat 
that the resulting PDF fi le 
needs to display and print 
correctly.
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The most important point to remember is that from a print perspective, 

there’s a line in the sand between PDF 1.3, which doesn’t support transpar-

ency, and all later PDF versions, which do support live transparency 

(Table 14.1). See “Choosing File Formats Based on Workfl ow” later in 

this chapter to learn when to use each version.

Table 14.1 Acrobat Version Compatibility

Version  PDFL  Transparency  Main Features 

of Acrobat Version Support Introduced

Acrobat 4 PDF 1.3 No  Smooth shading, digital signatures

Acrobat 5 PDF 1.4 Yes  Transparency, XML tagging, and 
metadata

Acrobat 6 PDF 1.5 Yes  Layers, JPEG2000 compression

Acrobat 7 PDF 1.6 Yes  Object-level metadata, AES encryption

Acrobat 8 PDF 1.7 Yes  Enhanced 3D support, PDF packages

The PDF/X Standard

Imagine the following scenario: A designer submits a PDF fi le to a printer 

for fi nal printing. When the job is complete, the designer is horrifi ed to fi nd 

that the wrong fonts printed and that the colors weren’t anywhere near close 

to those that appeared on the screen when the designer designed the job. 

How did this happen? After all, didn’t the printer say they accept PDF fi les? 

For designers, and especially for printers, this is a scenario that unfortu-

nately happens too often.

This happens because PDF is a “garbage in, garbage out” fi le format. What-

ever you put into it, that’s what you can expect to get out of it. If you don’t 

embed your fonts when you create a PDF fi le, a printer can’t print your fi le 

unless they also have your fonts. If you embed RGB images when a printer 

needs CMYK, you will see color shifts in your output (some devices may 

not print RGB images at all).

With so many other possible things that could go wrong with a PDF fi le, 

printers and publishers realized that they needed a way to ensure that a PDF 

fi le meets certain requirements before it is submitted for fi nal printing or 

publication.
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Understanding Supported PDF Standards in Illustrator

Because PDF fi les have so many uses and because each workfl ow is diff erent, many PDF standards exist. The 
following is an explanation of what each standard is and what each is best used for:

• PDF/X-1a:2001. The PDF/X-1a standard was defi ned to allow for the reliable exchange of fi les between 
designers and printers or publishers. The standard, which was fi rst defi ned in 2001 (which is where it gets 
its name), is based on PDF 1.3 and therefore doesn’t support transparency. When you save a PDF/X-1a fi le 
from Illustrator, a transparency fl attener preset is used to fl atten the transparency in the fi le. A PDF/X-1a-
compliant fi le must also have all fonts embedded in the fi le. If your fi le uses a protected font that cannot 
be embedded (see the sidebar “Font Embedding and Permissions” later in this chapter), Illustrator can’t 
create a valid PDF/X-1a fi le. Additionally, PDF/X-1a fi les are CMYK and spot only (any RGB information 
is converted to CMYK). For ad submission or for sending fi nal fi les to a printer for off set printing, PDF/
X-1a:2001 is the preferred choice.

• PDF/X-3:2002. In recent years, print service providers have been adopting color management technolo-
gies to off er better color matching. Rather than converting images to CMYK early in the process, in a 
color-managed workfl ow you can have images remain in RGB and tag them with profi les that allow color 
integrity to be preserved from proof to fi nal print. Because PDF/X-1a doesn’t support RGB or embedded 
color profi les, PDF/X-3:2002 was created to allow for these variables. If you or your printer are using a 
color-management workfl ow, you might consider using PDF/X-3:2002.

• PDF/X-4:2008. Once a fi le has been fl attened, a printer can’t do much in the way of making changes to 
that fi le. More important, a printer sometimes can’t trap fi les that have already been fl attened. Although 
PDF/X-1a and PDF/X-3 don’t allow transparency constructs in the fi le, the PDF/X-4 standard is based on 
PDF 1.5 and allows transparency. This gives the printer the ability to choose a fl attener setting and to 
make late-stage edits. In any case, it’s best to speak with your printer before using the newer PDF/X-4:2008 
standard.

See “Choosing File Formats Based on Workfl ow” later in this chapter for additional examples of when you 
would want to submit a PDF fi le using one the standards listed here. You can fi nd more information about the 
various versions of PDF/X at www.pdf-x.com.

One way to do that was by providing designers with a detailed list of the 

settings they needed to use whenever they created a PDF fi le. Although this 

was a nice idea in concept, printers and publishers soon realized that design-

ers use a variety of different programs, and each has different ways of creat-

ing PDF fi les. They also realized this meant that each time a new version of 

software was introduced, a designer would need to learn new settings.

Instead, an International Organization for Standardization (ISO) standard 

was created, called PDF/X. A PDF/X fi le is not a new kind of fi le format 

but rather a regular PDF fi le that simply meets a list of predefi ned criteria. 

Now, when a designer submits a PDF/X fi le for fi nal printing, a printer 

www.pdf-x.com
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can assume that the fi le meets the minimum requirements to reproduce it 

correctly.

By choosing a standard from the Standard pop-up menu in the Save Adobe 

PDF dialog box, you are embedding an identifi er in the PDF fi le that says, 

“I am a PDF/X-compliant fi le.” Certain scripts and prefl ight utilities can 

read these identifi ers and validate PDF/X-compliant fi les in a prepress or 

publishing workfl ow. See the sidebar “Understanding Supported PDF 

Standards in Illustrator” for an explanation of the different kinds of PDF/X 

versions.

General PDF Settings

The General panel of the Save Adobe PDF dialog box contains several 

important settings that determine how your PDF fi le is saved:

• Preserve Illustrator Editing Capabilities. The Preserve Illustrator 

Editing Capabilities option embeds a full native Illustrator fi le in your 

PDF fi le. This allows Illustrator to reopen and edit the fi le with no loss 

in editability. This option is turned on in the default preset, but turning 

this option off effectively cuts your fi le size in half and also reduces how 

long it takes to save a PDF fi le (Figure 14.10). If you want to send a fi le 

to a client for approval, for example, you can select this option to create 

a smaller PDF fi le (which is also not as editable should they try to open 

it in Illustrator). If you do deselect this option, make sure to always save 

a copy of your fi le, because you won’t be able to reopen the smaller PDF 

and edit it as a fully editable fi le.

• Embed Page Thumbnails. With the Embed Page Thumbnails option 

selected, Illustrator creates thumbnails for each page. You can display 

these in Acrobat by choosing to view the Pages tab. Be aware that the 

thumbnails increase the fi le size somewhat, however.

Figure 14.10 By turning 
off  the Preserve Illustrator 
Editing Capabilities option, 
you can create a PDF fi le 
that is smaller and suitable 
for posting to the web or 
sending via email.

PDF
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• Optimize for Fast Web View. Selecting the Optimize for Fast Web 

View option enables streaming, allowing those who view the fi le online 

to view parts of the document while other parts are still loading.

• View PDF after Saving. It’s always a good idea to take a look at a PDF 

on your screen to make sure it’s okay before you release it to a printer or 

to a client. Selecting the View PDF after Saving option launches Acrobat 

and opens the fi le after the PDF fi le is created.

• Create Acrobat Layers from Top-Level Layers. If you choose 

to save your fi le with Acrobat 6 (PDF 1.5), Acrobat 7 (PDF 1.6), or 

Acrobat 8 (PDF 1.7) compatibility, you can have Illustrator convert all 

top-level layers to PDF layers. You can view a document with PDF 

layers in either Acrobat or the free Reader, versions 6.0 and newer 

(Figure 14.11). In addition, Acrobat layers can be turned on and off 

when the PDF is placed in an InDesign CS2, CS3, or CS4 document.

Figure 14.11 When a fi le 
is opened in Acrobat or 
Reader, the viewing of layers 
can be toggled on and off .
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PDF Compression Settings

The Compression panel of the Save Adobe PDF dialog box offers a vari-

ety of settings for compressing the images and art that appear in your fi le 

(Figure 14.12). One of the benefi ts of using PDF is that you can specify a 

variety of image settings for each need. For example, when you send a fi le 

to a client for review, you want to create a small fi le that transmits quickly 

via email and might set all images to resample at 72 ppi. However, that same 

fi le, when transmitted to the printer for fi nal output, needs to contain 

high-resolution images, which you might set to at least 300 ppi.

When you create a PDF, Illustrator has the ability to resample an image. 

Resampling is a method used to change the resolution of a raster image. 

Although upsampling adds new pixels to a fi le, downsampling removes pixels 

from a fi le, resulting in a lower resolution and a smaller fi le size. Obviously, 

downsampling an image results in loss of image detail and is therefore 

inappropriate for fi nal output to a printer.

• Resampling settings. Illustrator can apply different settings to raster 

images that appear in your fi le, according to image type and resolution. 

Figure 14.12 The 
Compression panel of the 
Save Adobe PDF dialog box 
lets you determine which 
image types will be resam-
pled, as well as choose the 
compression method in 
which to do so.
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You can specify these settings for color, grayscale, and monochrome 

bitmap images. More importantly, you can defi ne a threshold for 

when images will be resampled. The Do Not Downsample option 

leaves images at their native resolutions. Alternatively, you can choose 

from three different types of downsampling (Average, Bicubic, and 

Subsampling), which reduce the resolution of any raster images in your 

fi le according to the threshold settings. The fi rst value is for the resolu-

tion to which you want images to be downsampled. The second value 

determines which images in your fi le get downsampled. For example, if 

you set the fi rst value to 72 ppi and the second value to 150 ppi, then any 

image in your fi le that exceeds 150 ppi is downsampled to 72 ppi. How-

ever, if your fi le contains an image that’s set to 100 ppi, that image is not 

downsampled and remains at 100 ppi because it falls below the threshold.

• Compression and Image Quality. In addition to resampling raster 

images, PDF also uses compression techniques to further reduce the 

size of a fi le. Different methods are used for compression, or you can 

choose None to disable compression completely (see the sidebar 

“Compress This”).

• Compress Text and Line Art. To achieve smaller fi le sizes, select 

the option to compress text and line art. This uses a lossless method 

of compression and doesn’t sacrifi ce quality in your fi le.

Compress This

Getting smaller fi le sizes comes at a cost. That cost is the quality of the image after it has been compressed. 
As we discussed in Chapter 13, “Web and Mobile Design,” there are two types of compression algorithms: lossy 
compression, which results in smaller fi les at the expense of image detail, and lossless compression, which 
doesn’t make fi les quite as small but loses no information in the process.

When saving PDF fi les from Illustrator, you can choose no compression, JPEG compression, JPEG2000 com-
pression (both JPEG compression types are lossy), or the lossless zip compression method. When using lossy 
compression, you can also choose an image quality setting to control how much information or detail is lost in 
the compression process. The Maximum setting preserves the most information in the fi le, while the Minimum 
setting sacrifi ces quality for a smaller fi le size.
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PDF Marks and Bleeds Settings

The Marks and Bleeds panel of the Save Adobe PDF dialog box 

(Figure 14.13) is strikingly similar to the Marks and Bleeds panel 

you’ll fi nd in the Print dialog box. Here you can specify whether your 

PDF should have printer’s marks and whether the document will have 

bleed space added. If you already set a bleed setting when you created

 your document or in the Document Setup dialog box, you can set Use 

Document Bleed Settings to use those values.

PDF Output Settings

The Output panel of the Save Adobe PDF dialog box (Figure 14.14) gives 

you control over what color space your PDF is saved in and whether you 

want to include image color management profi les in your PDF. Addition-

ally, you can specify color management settings for fi les that will be saved 

using one of the PDF/X standards.

NOTE The Bleed set-
tings you specify in the 

Marks and Bleeds panel 
defi ne the bleed box values 
in the resulting PDF.

Figure 14.13 The Marks 
and Bleeds panel of the 
Save Adobe PDF dialog box 
lets you create PDF fi les with 
crop marks automatically. 
Additionally, the Bleeds set-
tings make it easy to turn 
bleed on or off  depending 
on to whom you are send-
ing the PDF fi le.
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• Color. When you create a PDF fi le, you can specify a color conver-

sion for the fi le. In the Color Conversion pop-up, you can choose No 

Conversion, in which case the color values and color space will remain 

untouched, or you can choose Convert to Destination and choose from 

the Destination pop-up options to convert the color values or color 

space using a color profi le of your choice. You can also specify when 

Illustrator will include color profi les in the PDF fi le.

• PDF/X. When you create a PDF/X fi le, you must specify a color profi le 

intent; with PDF/X-1a, this is usually set to SWOP. You can also choose 

to mark the fi le as being already trapped, which is useful in workfl ows 

where trapping may occur in the RIP. If you trapped a fi le in Illustrator 

(either manually or via a plug-in such as Esko-Graphics’ DeskPack), 

identifying the fi le as already trapped prevents the fi le from being 

trapped again in the RIP.

Figure 14.14 The Output 
panel of the Save Adobe 
PDF dialog box gives you 
the ability to convert all 
objects to a specifi c color 
space. For example, when 
saving a PDF/X-1a fi le, 
any linked RGB images 
are converted to CMYK 
automatically.
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PDF Advanced Settings

The Advanced panel of the Save Adobe PDF dialog box (Figure 14.15)

allows you to specify how fonts are embedded in your PDF fi le and how 

transparency is fl attened, if necessary.

• Fonts. By default, Illustrator embeds subsets of fonts when saving a 

PDF fi le. A subset simply means that Illustrator includes only the parts 

of a font that are required to view and print the text you have in your 

document. If a font is protected, however, Illustrator does not embed 

the font. See the sidebar “Font Embedding and Permissions” for more 

information.

• Overprint and Transparency Flattener Options. If your document 

contains overprint settings, you can choose to preserve or discard them. 

Additionally, if your fi le contains transparency, you can choose a trans-

parency fl attener preset to control how the transparency is fl attened. For 

more information on both overprinting and transparency, see Chapter 15. 

It’s important to note that these two settings are applicable only when 

you’re saving a PDF fi le with Acrobat 4 (PDF 1.3) compatibility because 

all other versions support transparency and don’t require fl attening.

Figure 14.15 The Advanced 
panel of the Save Adobe 
PDF dialog box allows you 
to specify a transparency 
fl attener preset when saving 
to PDF 1.3 (all other versions 
support live transparency).
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Font Embedding and Permissions

Using fonts these days isn’t the same as it was several years ago. Designer, meet 
lawyer. Lawyer, meet designer. There are some legal restrictions when it comes 
to using fonts, and depending on the licensing agreement that comes along 
with the fonts you own, you may be limited in how you can use your fonts.

Generally, a font can have two kinds of embedding permissions. Preview and 
Printing permissions give the owner of the font the rights to use the font in a 
design and distribute the fi le with the font embedded so that others can view 
and print the document as well. Editing permissions give the owner the same 
rights as Preview and Printing permissions, but others who receive the fi le with 
the fonts embedded may also make edits and changes to the fi le.

Even though most fonts possess one of these two permissions (which are 
specifi ed in the font licensing agreement), they usually aren’t enforced in 
any way. A font vendor expects a user to abide by the terms specifi ed in its 
license agreement. For example, a font may have Preview and Printing per-
missions (the more stringent of the two settings), but you may still be able to 
embed that font in a PDF fi le. This means someone using Acrobat Professional, 
or another product that can edit PDF fi les (including Illustrator), can make 
changes to the document, which would violate the license agreement.

To prevent unauthorized use, some font vendors protect their fonts by speci-
fying that their fonts can’t be embedded at all. These fonts are referred to as 
protected fonts. If an Adobe application encounters such a font, the application 
does not embed the font in a PDF fi le, honoring the rights of the font vendor. 
Obviously, if a designer is using a protected font and wants to send a PDF 
fi le with the fonts embedded to a publication, this can pose a problem. The 
only solution is for the designer to contact the font vendor and request an 
extended license that allows the font to be embedded. Alternatively, you may 
be able to convert the text to outlines before saving the fi le.

Unfortunately, Illustrator doesn’t off er any way to easily tell whether a font 
is protected (InDesign does). Once you create a PDF, you can open the fi le in 
Acrobat and use the Document Properties setting to make sure your fonts are 
embedded.

PDF Security Settings

In today’s world, security has become a priority—not only in airports but 

with regard to electronic communications and documentation as well. One 

of the benefi ts of using PDF fi les is the ability to password-protect them so 

that you can control who can view or edit your fi le.
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The Security panel of the Save Adobe PDF dialog box (Figure 14.16) allows 

you to specify two kinds of passwords to protect the content of your PDF fi le:

• Document Open Password. A document open password, also 

referred to as a master password, controls who can open your PDF fi le. 

If a user attempts to view the PDF, they are prompted for a password. 

Upon entering the password, the user is able to view the fi le. The fi le 

will not open if the password is incorrect.

• Permissions Password. A permissions password controls what a user 

can do with a PDF fi le once it is open on their screen. For example, a 

user who has the Professional version of Acrobat or a variety of Acrobat 

plug-ins, such as Enfocus PitStop, has the ability to edit a PDF fi le. Even 

if a fi le has a master password, once a user opens the fi le, they are free 

to do with the fi le as they please. By specifying a permissions password, 

you can restrict what a user can do with a fi le, even once they’ve opened 

the fi le in Acrobat Professional. For a detailed explanation of the different 

permissions settings, see the sidebar “Did You Ask for Permission?”

Figure 14.16 The Security 
panel of the Save Adobe 
PDF dialog box allows 
you to choose a password 
that will restrict how your 
PDF fi le can be viewed or 
printed.
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Did You Ask for Permission?

Illustrator provides a range of permissions settings that give you control over the kinds of actions a user can 
take with your PDF fi le once they’ve opened it. You can fi nd these options in the lower portion of the Security 
panel in the Save Adobe PDF dialog box:

• Printing. Choosing None disallows the printing of your fi le. Users are able to view the fi le in its entirety 
on their computer screens, but their Print command is dimmed (Figure 14.17). Choosing High Resolution 
enables full printing of the fi le. When using a compatibility setting of Acrobat 6 or newer, you can also 
choose the Low Resolution setting, which forces all pages to print only as raster images at 150 dpi.

Figure 14.17 If you use 
a permissions password 
to restrict printing, a user 
without the password is 
able to view the document 
but is not able to print the 
PDF fi le.

• Changing/editing. Choosing None disallows all editing of your fi le. Users are able to view the fi le in its 
entirety on their computer screens, but all of Acrobat’s editing tools are disabled. You can choose from four 
additional settings to restrict specifi c types of edits. For example, by choosing the Filling in Form Fields 
and Signing setting, you allow users to fi ll out PDF form fi elds and to digitally sign the fi le, but this setting 
disables all other editing features.

• Copying. If you want to prevent users from copying content from your PDF fi le and pasting that data 
into other applications, deselect the “Enable copying of text, images, and other content” option. However, 
realize that by doing so, you may aff ect the accessibility of your document, especially for users who are 
visually impaired—those who rely on screen readers to speak the content of fi les. These screen readers 
copy the text and paste the data into an application that reads the words to the user. When you select the 
option to enable text access to screen readers, Acrobat allows the copying of text if it senses that the appli-
cation that’s copying the data is a screen reader. Additionally, you can enable a user to copy the metadata 
from a fi le.
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The Flex Exchange Graphic (.fxg) Format
FXG (formerly known as MXML) is an interchange format created by 

Adobe to move fi les between applications, such as Illustrator, Adobe Flash 

CS4 Professional, Adobe Fireworks CS4, and Flex Builder. The main use 

for this format will most likely be to move graphics from these applications 

to a forthcoming product from Adobe, named Adobe Flash Catalyst. At 

the time of the printing of this book, details on this new application are 

slim, but the goal is to create a workfl ow that will allow both designers and 

developers to collaborate easily to develop graphically rich Internet experi-

ences and applications. Since an FXG fi le can be saved with native data 

(Figure 14.18), designers and developers should be able to easily round-trip 

their fi les between traditional design applications (such as Illustrator and 

Fireworks) and traditional developer applications (such as Flex Builder).

You can select several settings in the FXG Options dialog box (Figure 14.19):

• Use Artboards. In the initial Save dialog box, choose to save the fi le 

with multiple artboards left intact. If deselected, the fi le will be saved 

with all artwork on a single artboard. For details, see the sidebar 

“Saving and Exporting Artboards” later in this chapter.

• Version. At this point in time, FXG 1.0 is the only available version.

• Preserve Illustrator Editing Capabilities. This option embeds a full 

native Illustrator fi le in your FXG fi le. This allows Illustrator to reopen 

and edit the fi le with no loss in editability. This option is selected by 

default. If you decide to deselect this option, make sure to save a copy 

of your fi le for future editability needs.

Figure 14.18 FXG fi les 
can also contain native 
Illustrator content, allowing 
for round-tripping between 
Illustrator and the applica-
tion you’re placing the FXG 
fi le into.

Native Data FXG
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• Clip Content to Active Artboard. This option trims your art 

and exports only the portion that is within the bounds of the active 

artboard.

• Include Unused Symbols. Keep this option deselected (the default) 

if you want Illustrator to not include unused symbols in your Symbols 

panel. See Chapter 9, “Drawing with Effi ciency,” for detailed informa-

tion on using symbols.

• Downsample Linked Images (72 ppi). If you have linked raster 

images in your fi le that are higher in resolution than 72 ppi, this option 

downsamples those links to 72 ppi—standard screen resolution.

• Maintain Editability (Convert to FXG). This option converts 

applied fi lters (which are also supported by the FXG format), text, 

and gradients in your artwork to the FXG format in order to preserve 

future editability. Keep in mind that selecting this option may sacrifi ce 

the preservation of the visual appearance of the artwork and text for 

editability.

Figure 14.19 FXG fi les are 
designed to be used by rich 
Internet applications.
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• Preserve Appearance (Rasterize). If the preservation of the visual 

appearance of applied fi lters, text, and gradients is crucial, select this 

option to do so, at the expense of a larger fi le size.

• Preserve Appearance (Create Outline). This option preserves the 

appearance of your text by converting the live type to vector outlines. 

As a bonus, your fi le size will be smaller than if you chose to rasterize 

the text.

• Preserve Appearance (Expand). To preserve the appearance of your 

fi ltered artwork, this option will expand or convert into multiple vector-

based objects.

• Show Code and Show Preview. Clicking these buttons launches a 

text editor or an FXG Viewer window, respectively, and allows you to 

preview the code and the fi le before you save the fi le.

The Scalable Vector Graphics 
(.svg, .svgz) Format
SVG is an XML-based fi le format that is used primarily on the web and 

has recently become more popular in creating content for cell phones and 

handheld wireless devices. For more information about how SVG is used, 

refer to Chapter 13. The SVGZ format is simply the SVG format zipped 

(compressed).

A variety of settings are available in the SVG Options dialog box, and 

depending on your needs for each particular workfl ow, you can adjust these 

settings. Click the More Options button in the SVG Options dialog box to 

see the full list of available settings (Figure 14.20).

• SVG Profi les (DTD). This setting is akin to the version of SVG that 

your fi le is compatible with. Because SVG is an open standard, addi-

tional specifi cations are revised and approved. If you save an SVG fi le 

with a particular DTD, it means your fi le will be compatible with any 

device that supports that DTD. Newer specifi cations usually support 

additional functionality than the older ones did. SVG Tiny (also referred 

to as SVG-t) is a subset of SVG used for displaying content on SVG-

enabled cell phones. SVG Basic is a subset of SVG used for displaying 

content on PDAs.

NOTE For more 
information on the 

SVG specifi cation and SVG-
enabled cell phones, visit 
www.svg.org.

www.svg.org
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• Fonts. When text is present in your fi le, you can specify the Adobe 

CEF type, which results in better-looking text when your fi le is viewed 

with the Adobe SVG Viewer but may not be supported with other SVG 

viewers. The SVG creates more compatible text, but it’s text that may 

not be as readable at smaller font sizes. Alternatively, you can convert all 

text to outlines, which increases fi le size.

• Images. When you save a fi le in SVG, you have the ability to embed 

any images in the SVG fi le (making for larger but self-suffi cient fi les), or 

you can choose to create smaller SVG fi les by using the Link option.

Figure 14.20 The SVG 
Options dialog box off ers 
a variety of settings that 
allow you to fi ne-tune SVG 
fi les, including a button 
that launches Adobe Device 
Central, which allows you to 
preview your fi le on a vari-
ety of handheld devices and 
cell phones.
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• Preserve Illustrator Editing Capabilities. The Preserve Illustrator 

Editing Capabilities option embeds a full native Illustrator fi le in your 

SVG fi le (Figure 14.21). This allows Illustrator to reopen and edit the 

fi le with no loss in editability. This option is deselected by default, but 

selecting this option effectively doubles your fi le size. If you leave this 

option deselected, make sure to always save a copy of your fi le because 

you won’t be able to reopen the SVG fi le and edit it as a fully editable fi le.

• CSS Properties. You can format SVG code in a variety of ways, and 

the CSS Properties options allow you to determine how object attri-

butes are coded in the fi le. For the most part, these options affect the 

performance of your fi le when viewed.

• Decimal Places. Illustrator allows you to specify how precisely vec-

tor paths are drawn. You can choose a value from 1 to 7, where higher 

numbers result in better-looking paths at the expense of fi le size and 

performance.

• Encoding. When you save an SVG fi le that contains text, you can 

specify a character encoding, including ISO-8859-1 (suitable for 

European languages) and 8- or 16-bit Unicode (suitable for more 

complex languages).

• Optimize for Adobe SVG Viewer. If people will be using the Adobe 

SVG Viewer to view your SVG fi les, you can select this option, which 

will take advantage of proprietary optimizations that exist in the Adobe 

SVG Viewer, including faster rendering of SVG fi lter effects.

• Include Adobe Graphics Server data. If you’ve defi ned variables 

in your Illustrator fi le (using the Variables panel), selecting this option 

includes those variables in the fi le. This enables access to variable 

content when the SVG fi le is used as a template with Adobe Graphics 

Server or via Java or ECMAScript otherwise.

Figure 14.21 Similar to 
a PDF fi le, Illustrator can 
embed a native version of 
the fi le in an SVG document 
to assure editability when 
the SVG is reopened in 
Illustrator.

NOTE For more 
information on 

Adobe Graphics Server, visit 
www.adobe.com/products/
server/graphics/main.html.

Native Data SVG

www.adobe.com/products/server/graphics/main.html
www.adobe.com/products/server/graphics/main.html
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• Include Slicing Data. If you’ve specifi ed web slices and optimization 

settings in your Illustrator document (using the Slice tool or the Object > 

Slice > Make function), selecting this option preserves the slice infor-

mation in the fi le, making it available to other applications.

• Include XMP. Selecting this option includes XMP metadata with the 

fi le, specifi ed in the File > File Info dialog box. This results in a larger 

fi le size.

• Output fewer <tspan> elements. This option, selected by default, 

helps create smaller fi les, at the risk of text shifting slightly. If you notice 

errors in the way the text is displayed in your fi nal SVG fi le, try dese-

lecting this option.

• Use <textPath> element for Text on Path. If your document con-

tains text on a path, you can select this option to use the <textPath> 

function in SVG to display that text. Otherwise, Illustrator writes each 

character as a separate <text> element in your fi le, making for a larger 

(although more precise) SVG fi le.

• Show SVG Code and Web Preview. Clicking either of these buttons 

launches a web browser and allows you to preview the code and the fi le 

itself before you save the fi le.

EXPORTING FILES FROM
ILLUSTRATOR
Illustrator is a robust application that supports a wide range of fi le formats. 

Although Illustrator does a great job opening just about any graphic fi le 

format, it can also export fi les in different fi le formats for a plethora of uses. 

To export a fi le from Illustrator, choose File > Export, and then choose 

from one of the many formats listed in the pop-up list in the Export dialog 

box. Each of these formats is listed in the following sections, with descrip-

tions of their settings as well as when you might want to use them.

Remember that when exporting, it is expected that some level of formatting 

or editability will be lost, so always save a native Illustrator version of your 

fi le before you export to another format.
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Saving and Exporting Artboards

One of the most highly requested features in Illustrator has fi nally arrived in Illustrator CS4—multiple art-
boards (see Chapter 1). And just as you can create single fi les with multiple artboards, so can you save and 
export fi les with them as well.

Choose File > Export, and choose your desired fi le format. In the Export dialog box, select Use Artboards 
(Figure 14.22), and specify All or a range of artboards to export. When Range is selected, Illustrator will export 
separate fi les for each artboard specifi ed. File names will be appended with a 01, 02, 03, and so on. If the Use 
Artboards option is not selected and your fi le contains multiple artboards, a single fi le will be exported with 
the artboards converted to a single, “conjoined” artboard (Figure 14.23).

With the Save and Save As commands, the Use Artboards option is automatically selected for the native Adobe 
Illustrator, Adobe Illustrator Template, PDF, SVG, and SVGZ fi le formats. You have the option of selecting or not 
selecting the option with the EPS and FXG fi le formats.

Figure 14.22 Choose 
to export, or not export, 
multiple artboards.

Figure 14.23 Illustrator 
then creates a separate fi le 
from each artboard (left) or 
a single fi le from multiple 
artboards (right).
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The Bitmap (.bmp) Format
Bitmaps are raster-based fi les and are often used in older computer applica-

tions. The bitmap format is also used by some applications for displaying 

logos or bar codes.

When exporting a bitmap, you can choose one of three different color 

models: RGB, Grayscale, or Bitmap. Bitmap creates a fi le that contains 

only black-and-white pixels (Figure 14.24). Additionally, you can specify 

the resolution for your image and choose whether to antialias the art.

The Targa (.tga) Format
The Targa fi le format is a raster-based image format used mainly in video 

applications. For example, you might use the Targa fi le format to add 

Illustrator artwork as masks in Adobe Premiere Pro CS4.

When exporting a Targa fi le, you can choose one of two color models: RGB 

or Grayscale. Additionally, you can specify the resolution for your image 

and choose whether to antialias the art.

The Portable Network Graphic 
(.png) Format
The PNG fi le format (pronounced “ping”) was originally formed as an open 

standard format to replace the need for the GIF image fi le format, because 

of legal complications with those who developed the compression technol-

ogy used in the GIF format.

Figure 14.24 Many applica-
tions (including Illustrator 
and QuarkXPress) allow 
you to change the color of 
a bitmap fi le that uses the 
Bitmap color model.
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As you learned in Chapter 13, you can also create PNG fi les from Illustrator 

using the Save for Web & Devices feature. However, the PNG format also 

appears as an export format because the Save for Web & Devices feature is 

hardwired at 72 ppi. To export a PNG fi le at any other resolution, you need 

to use the PNG export function.

The PNG format is a raster-based image format and is used for web design, 

for icon and interface design, and as a general image exchange format. In 

fact, the Apple operating systems Tiger and Leopard (Mac OS X versions 

10.4 and 10.5) create a PNG fi le when you take a screen shot. PNG fi les 

can support 24-bit color, but more importantly, the format also supports 

256-level alpha channels for transparency, meaning you can give images soft 

edges that fade to transparent (unlike the GIF format, which supports one-

color transparency only).

When exporting a PNG fi le, you can specify your image resolution as well 

as the background color. You can choose a transparent background, or you 

can choose Other to select a color from the Color Picker (Figure 14.25). 

Additionally, you can choose to turn on antialiasing and interlacing.

Figure 14.25 You can 
specify any color as a back-
ground color for a PNG fi le, 
including transparency.
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Exporting Art for Use in Microsoft Offi  ce Applications

One of the most diffi  cult things to do is create artwork in a professional design application (such as Illustrator) 
and have that same artwork display and print reliably in a business application such as Microsoft PowerPoint. 
Finding the right fi le format for this workfl ow is diffi  cult because JPEG images don’t support transparent back-
grounds and EPS fi les don’t display well onscreen. In addition, EPS fi les require the use of a PostScript printer, 
which most business professionals do not have.

After much research, the folks on the Adobe Illustrator development team discovered that the PNG format was 
perfect for placing art from Illustrator into Microsoft Offi  ce documents. Because the format supports transpar-
ent backgrounds and displays beautifully on computer screens, a PNG fi le set to a resolution high enough to 
also print well, resulting in great-looking art in Offi  ce documents.

To save time and make it easier to quickly export a fi le from Illustrator to use in Microsoft Offi  ce, choose 
File > Save for Microsoft Offi  ce. Illustrator saves your fi le as a PNG fi le set to 150 ppi with antialiasing turned 
on. Once you’ve created the PNG fi le, you can place it into any Microsoft Offi  ce application by choosing the 
Insert Picture function in Microsoft Word, Microsoft Excel, or Microsoft PowerPoint (Figure 14.26).

Figure 14.26 To place a 
PNG fi le into a Microsoft 
Offi  ce document, choose 
Insert > Picture > From File 
when in Word, Excel, or 
PowerPoint, and locate the 
fi le on your computer or 
server.

Because of a bug in the Mac version of Microsoft Offi  ce, transparency in a PNG fi le does not appear correctly 
at the default view setting (it does appear correctly when viewed in full-screen mode and when printed). For 
this reason, the Save for Microsoft Offi  ce command sets the background color to white instead of transparent. 
If you are placing your art into Microsoft Offi  ce for Windows, you can create a PNG with a transparent back-
ground by using the PNG Export function.
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The AutoCAD Drawing (.dwg) and 
AutoCAD Interchange File (.dxf) Formats
The DWG and the DXF fi le formats are both used for exchanging fi les with 

computer-aided design (CAD) applications. These formats can be especially 

helpful when you want to send Illustrator artwork to architects, interior 

designers, or industrial designers. Both formats support vector and raster 

elements.

When exporting a DXF or a DWG fi le (they both use the same export dia-

log box; Figure 14.27), you can specify the version of AutoCAD you want 

your fi le to be compatible with and the number of colors in the resulting 

fi le. If your fi le contains raster elements (or if vector elements need to be 

rasterized), you can choose to have them embedded as either bitmap or 

JPEG fi les.

TIP If you need some 
of the functionality that 

CAD applications have, you 
might look into the CAD tools 
plug-in from Hot Door, avail-
able at www.hotdoor.com.

Figure 14.27 Illustrator 
uses the same export 
options dialog box for both 
DXF and DWG formats.

www.hotdoor.com
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Additionally, you can choose to export only the artwork that you currently 

have selected on the artboard. Selecting Alter Paths for Appearance modifi es 

paths, if necessary, so that they appear when opened in a CAD application. 

Additionally, you can outline all text to avoid the need to send fonts.

The Windows Metafi le (.wmf ) and Enhanced 
Metafi le (.emf ) Formats
The Windows Metafi le (WMF) and Enhanced Metafi le (EMF) formats 

were developed to move graphics between applications on the Windows 

platform. These two formats support both vector and raster elements but 

are severely limited with regard to the kinds of art they can reliably display 

and print (EMF is slightly better). Both formats can create only straight 

vector lines, not curved ones. To make up for this, curved lines appear as 

numerous tiny straight paths, which results in large fi les with many anchor 

points. If possible, avoid using these formats for anything other than simple 

artwork. You can’t specify any additional options when exporting WMF or 

EMF fi les.

The Flash (.swf ) Format
SWF is a popular web-based fi le format that supports both vectors and 

rasters. The Flash fi le format has become extremely popular because of its 

capability to contain interactive or animated content. You can use Illustrator 

to generate a SWF fi le that you want to upload directly to a website, use in a 

Flex framework rich Internet application (RIA), or even place into InDesign 

for creating interactive PDF fi les.

The SWF Options dialog box contains “ just a few” options for creating the 

SWF fi les that are right for you (Figure 14.28). Along the right side of the 

dialog box are options to save presets of SWF output settings, to preview 

your SWF in your default web browser, and to preview your SWF using 

Adobe Device Central. The SWF Options dialog box is actually split into 

two separate panels labeled Basic and Advanced, which you can access by 

clicking their respective buttons that appear underneath the Cancel button 

along the right side of the dialog box.
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Basic Options

The options in the Basic panel of the SWF Options dialog box are general 

settings that apply to most SWF fi les:

• Export As. You can export Illustrator fi les in one of four ways: AI File 

to SWF File, which creates a single SWF fi le that contains all your 

Illustrator artwork; AI Layers to SWF Frames, where each layer is 

converted into a key frame, resulting in a single animated SWF fi le; 

AI Layers to SWF Files, where each layer in your Illustrator document 

is exported as a separate SWF fi le (useful when you are creating Flash 

scenes); and AI Layers to SWF Symbols.

• Version. You can export a SWF that is compatible with any available ver-

sion of Flash Player. The default is Flash Player 9, which many believe is 

present on more than 90 percent of computers that access the Internet.

• Options. A variety of general settings appear in this section. You can 

choose to export your SWF at the exact size of your artboard or active 

crop area. If your fi le contains artwork that may not translate to the 

SWF format perfectly, you can select Preserve Appearance to expand or 

rasterize those areas to ensure the integrity of the appearance of your 

art. Compressing a fi le will result in a smaller SWF. You can choose to 

include all symbols in your resulting SWF (even if they aren’t used on 

the artboard), have your text converted to outlines, and ignore kerning 

that you may have applied to text. You can also choose to enclose 

metadata (from information you’ve entered using the File > File Info 

Figure 14.28 The Flash 
export dialog box in 
Illustrator has so many 
options that there’s a Basic 
button and an Advanced 
button that are used to tog-
gle between two full panels.
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function) and protect the resulting SWF fi le from being opened in Flash 

by applying a password.

• Curve Quality. This setting controls the quality level for curved paths 

in the resulting SWF fi le.

• Background Color. This setting allows you to specify a background 

color for the SWF fi le.

• Local playback security. You can choose whether the SWF fi le can 

access local or network fi les only.

Advanced Options

The options found in the Advanced panel of the SWF Options dialog box 

are settings that apply to rasterized portions of a fi le and animated content:

• Image Format. If there is raster content in your fi le (or if fl attening 

requires that content becomes rasterized), you can choose how those 

images are stored in your SWF fi le—either using a lossless format or 

a lossy format. If you choose the lossy format, which is JPEG, you can 

choose a JPEG quality and the Baseline setting. You can also choose 

the resolution you want your raster content to use (usually 72 ppi).

The remainder of the options present in the Advanced panel of the 

SWF Options dialog box are specifi c to animated SWF content. There-

fore, they are available only when choosing the AI Layers to SWF 

Frames option in the Export As pop-up menu in the Basic panel of the 

dialog box.

• Frame Rate. This setting controls how fast the animation plays and is 

measured in frames per second (although in the context of Illustrator, 

they are actually layers per second). A lower value will slow down the 

animation, while a higher value will cause the animation to play faster.

• Looping. Selecting this option causes the animation to repeat itself 

endlessly.

• Animate Blends. If your Illustrator fi le contains any blends, select-

ing this option will automatically animate those blends in the resulting 

SWF fi le. This setting allows you to keep blends live and editable in your 

Illustrator fi le and still get the desired animated result. Otherwise, you 
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would have to use the Release to Layers function in your Illustrator fi le 

to manually create the content necessary to create an animation. You can 

choose to have blends animate either as a sequence (each frame appears 

individually, one after the other) or as a build (each frame appears succes-

sively, adding to the previous one).

• Layer Order. By default, Illustrator animates layers from the bottom 

up, but you can alternatively select the Top Down option.

• Export Static Layers. Static layers are those that appear in every frame 

of the animation. If you select this option, you can Command-click 

(Ctrl-click) any layers that you want visible throughout the entire ani-

mation. For example, if you had an animation of a bird fl ying across a 

cloudy sky, you might set the layers that contain the sky and cloud 

elements to export as static layers.

For an in-depth discussion of how you can create great-looking SWF fi les, 

including adding interactive hotspots and animations, refer to Chapter 13.

The Joint Photographic Experts Group 
(.jpg) Format
An extremely popular raster-based format, JPEG fi les are used mainly for 

exchanging photographic content and artwork. Although the JPEG format 

is used heavily in web design, it is also the format of choice for the elec-

tronic delivery of stock photographs and for digital cameras. One of the rea-

sons why JPEG is used for these tasks is because the JPEG format can take 

advantage of compression algorithms that can dramatically reduce fi le size. 

For example, a high-resolution image that is normally 10 MB in size might 

be only 1 MB in size when saved as a JPEG.

However, the JPEG format uses a lossy compression algorithm, and some-

times a JPEG fi le may exhibit artifacts or loss in detail because of this com-

pression (Figure 14.29). A lower compression setting enhances image detail, 

at the cost of a larger fi le size.

Although you can save JPEG fi les from the Save for Web & Devices feature 

in Illustrator, you can do so only at 72 ppi. Using the JPEG Export function, 

you can specify a custom resolution for your fi le, which allows you to create 

high-resolution fi les.
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Besides choosing an image compression level for your fi le, you can also 

specify the RGB, CMYK, or grayscale color model. Format methods deter-

mine how the image appears when viewed in a web browser. If you choose 

the Baseline setting, the image loads completely and is then displayed at full 

resolution. The Progressive setting (similar to interlacing) allows the image 

to appear immediately at a lower-quality setting; it then appears in full qual-

ity once the entire image is loaded (the number of scans determines how 

many passes are done until the fi nal image is previewed).

Illustrator also gives you the options of antialiasing the art, embedding a 

color profi le, and including a client-side or server-side image map. Refer to 

Chapter 13 for more information on how to defi ne image maps and the dif-

ferences between client-side and server-side image maps.

The Macintosh PICT (.pct) Format
Much like the WMF and EMF formats, the PICT format was developed 

to move fi les between applications on the Macintosh platform. The format 

Figure 14.29 When saving 
a fi le as a JPEG, using the 
Maximum setting results in 
a fi le with fewer artifacts, 
but doing so also results in a 
larger fi le size.
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supports both vector and raster elements. You can’t specify any additional 

options when exporting a PICT fi le.

The Adobe Photoshop (.psd) Format
As you learned in Chapter 12, “Working with Images,” you can export an 

Illustrator fi le as an Adobe Photoshop CS4 fi le and preserve vital information 

in the fi le. This makes it easy to start work on a design piece in Illustrator 

and then bring it into Photoshop to add the fi nishing touches. Bringing 

Illustrator art into Photoshop is also useful when you’re creating art that 

you plan to use for websites. In this way, you have high-quality artwork in 

Illustrator that can easily be repurposed for print, and you can add rollovers 

and interactivity using Photoshop or even Fireworks or Flash for the website.

When exporting a PSD fi le, you can choose between the CMYK, RGB, 

and grayscale color models, and you can specify a resolution for your fi le. 

If you choose to export a fl at image, all Illustrator layers are fl attened into 

a single nontransparent layer (what Photoshop calls the Background layer). 

Alternatively, you can select the Write Layers option that preserves layering 

in Illustrator where possible (Figure 14.30). You can also choose to preserve 

text and other native elements, such as compound shapes and web slices 

(see Chapter 12 for a complete list of the attributes that can be preserved 

between Illustrator and Photoshop).

Figure 14.30 By choosing 
to write layers, you gain the 
ability to export a fi le that 
preserves live text, layers, 
transparency, and mask 
eff ects, and more.
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The Tagged Image File Format (.tif)
The TIFF format is widely used in graphics applications. Completely raster-

based, a TIFF is a lossless image format. High-resolution fi les can be quite 

large, but image integrity is maintained. TIFF fi les are generally supported 

by print, video, and 3D-rendering applications.

When exporting a TIFF, you can choose one of three different color mod-

els: RGB, CMYK, or grayscale. Additionally, you can specify the resolution 

for your image and choose whether to antialias the art. Selecting the LZW 

Compression option results in a smaller fi le (the compression is lossless). 

You can also specify a platform-specifi c byte order (for better compatibility 

with Windows systems), and you have the ability to embed color profi les 

when you’re working in a color-managed workfl ow.

The Text Format (.txt)
Sometimes you just need to export the text in a fi le so you can use it in 

another application or for another purpose that Illustrator can’t handle. You 

can export text to be compatible with a specifi c platform, or you can export 

text in Unicode, which is platform independent.

CHOOSING FILE FORMATS BASED
ON WORKFLOW
So many different fi le formats exist that it’s often diffi cult to know which 

one to use for each situation. Of course, every workfl ow demands special 

attention, and there are always exceptions and special cases. However, for 

the most part, you can follow certain rules now that you really understand 

what each fi le format is capable of doing.

Print Workfl ows
When working in print workfl ows, designers traditionally use page layout 

applications such as QuarkXPress or InDesign, using fi le formats such as 

EPS and PDF.
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Traditionally, EPS is used for moving fi les from Illustrator into page layout 

applications. However, with the ability to use transparency effects in your 

Illustrator fi les, the limitations of EPS become apparent. For example, as 

a designer, you know that Illustrator creates vector-based fi les that can be 

scaled infi nitely because they are resolution independent. You have always 

been able to save a fi le as an EPS from Illustrator, place it into an applica-

tion such as QuarkXPress, scale that artwork at will, and never worry about 

resolution or the quality of the resulting printout.

However, as you will discover in Chapter 15, the process of transparency 

fl attening may convert some vector content in your fi le into raster images, 

which are resolution dependent. Because an EPS contains fl attened infor-

mation, you can’t assume that an EPS fi le can be scaled infi nitely in a 

QuarkXPress layout anymore. In fact, you have to think of an EPS fi le from 

Illustrator as you would an EPS fi le saved from Photoshop—you need to 

limit how much you can enlarge a graphic.

Although this is a concern only when your fi le contains transparency effects, 

keep in mind that many effects in Illustrator introduce the need for fl atten-

ing (these are discussed in detail in Chapter 15).

On the other hand, native Illustrator fi les (that contain PDF 1.5 by default) 

have the ability to preserve live transparency, and therefore, fl attening 

doesn’t occur. When you save your fi le as a native Illustrator fi le, you can 

still scale that fi le infi nitely, after it has been placed into a page layout appli-

cation. But this has a catch—you need a page layout application that can 

fl atten that transparency when it prints your fi le. That means InDesign. 

Refer to Table 14.2 for a list of suggested fi le formats, based on the page 

layout application you’re using.

Table 14.2 Suggested File Formats

 When Transparency  When Transparency 

Application Is Present Is Not Present

 EPS, Native AI (Quark Version 8), 
QuarkXPress PDF/X-1a (PDF 1.3) EPS, PDF/X-1a (PDF 1.3)

InDesign Native AI, PDF 1.4 EPS, Native AI, PDF 1.4

NOTE As of the print-
ing of this book, the 

latest version of QuarkXPress, 
version 8, has the ability to 
place native Illustrator fi les 
(.ai). However, according to 
initial tests, Illustrator fi les 
with complex transparency 
do not print correctly when 
printed from QuarkXPress 8. 
The recommendation is still 
to use the EPS fi le format 
when placing art into 
 QuarkXPress.
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Web Workfl ows
The choices are much easier to make for web designers. This is not because 

there are any fewer fi le types to choose from but is mainly because the use 

of fi le types is usually dictated by the technology being used. For example, 

if you want to create animated content, you know you’re using a GIF fi le 

or a Flash fi le. Some sites are restricted as to what kinds of formats are sup-

ported (for example, not every web browser can display SVG fi les), so a 

designer is usually at the mercy of technology when it comes to deciding on 

a fi le format.

However, much can be done to a fi le before a fi nal GIF or JPG is created. 

Therefore, you may fi nd it benefi cial to create your artwork in Illustrator 

and then export it as a Photoshop fi le, which you can then edit and work on 

in other applications, such as Photoshop or even Fireworks, Flash, or Adobe 

Dreamweaver CS4.

Other Workfl ows
Of course, other workfl ows exist, including video, industrial design, archi-

tecture and engineering, fashion design, environmental design—the list 

goes on. With the information you now have about what each fi le format is 

used for, you should be able to develop a workfl ow that works for you.
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Chapter 
FifteenPrepress and Printing

Nothing is more frustrating than spending hours 

designing the perfect piece of art only to have it come 

back from the printer not looking the way you expected 

it to look. Many times, we take printing for granted 

and assume that whatever we design will reproduce in 

print the exact way we see it on our computer screens. 

Achieving consistent color across multiple devices is 

one challenge (which good color management strategies 

can help control). Even more challenging are features 

such as transparency, live effects, and overprint settings; 

these can turn what seems like an ordinary print job 

into a weekend-long nightmare.

In reality, you need to think about printing when you fi rst start working 

on a design. If you work with a printer regularly, the printer will help you 

fi gure out things in advance, including spot colors, page settings, folds, and 

a host of other issues. Although you certainly don’t always have the luxury 

of knowing who the printer is before a job gets started, you can still spend 

a few moments at the onset of a project carefully reviewing the details; this 

alone can make a huge difference. Every job has its own specifi c require-

ments, and you should always feel comfortable asking an experienced 

printer or production artist for advice.

Whether you’re a designer, a prepress operator, or a printer, this chapter is 

for you. This chapter discusses everything you need to know about printing 

fi les, using transparency, and using overprints—and it leads you to expect 

the best results every time.

The artwork featured throughout this chapter comes from Sam Posnick 

(iStockphoto; username: sposnick).

499



CHAPTER 15: PREPRESS AND PRINTING500

PRINTING FROM ADOBE
ILLUSTRATOR CS4
Printing a fi le should be a straightforward experience, but it wasn’t always that 

way in Adobe Illustrator. Prior to Illustrator CS, getting a fi le to print cor-

rectly often meant opening the Page Setup dialog box, the Document Setup 

dialog box, and the Print dialog box. When Adobe released Illustrator CS, 

however, it updated the Illustrator printing engine and interface and mod-

eled them after the Print dialog box in Adobe InDesign. Ever since that 

version, you can go directly to the Print dialog box and control all your 

print specifi cations in one place.

Because every print job is different and has specifi c requirements, the con-

tents of this chapter are organized to match the order in which print features 

appear in the Print dialog box. In this way, you can read the chapter now 

and use it as a handy reference later.

Exploring the General Print Panel
While you’re designing a job, printing quick and accurate proofs to your 

laser or ink-jet printer is just as important as printing fi nal output to an 

imagesetter. For this reason, you’ll fi nd that Adobe put many often-used 

settings in the General panel of the Print dialog box (Figure 15.1). This 

way, you can quickly print consistent and accurate fi les from Illustrator 

without having to dance between multiple dialog boxes or panels. At the top 

of the Print dialog box you’ll fi nd a pop-up to choose from predefi ned print 

presets (you’ll learn more about print presets later in this chapter), a pop-up 

to choose which printer you want to print to (extremely useful for those 

who have several different printers at their disposal), and a pop-up to choose 

a PostScript Printer Defi nition (PPD) fi le.

A PPD fi le contains specifi c information about a printer, including media 

dimensions, color information, and printer-specifi c settings such as resolu-

tion. Illustrator makes an educated guess about the right PPD fi le for your 

selected printer, although you can override it and choose your own if you 

want (however, if you’re not familiar with PPD fi les, it’s best to leave this 

setting alone). You can choose a PPD only when an Adobe PostScript 

device is selected as your printer.

TIP One of the options 
available in the Printer 

pop-up is Adobe PostScript 
File, which allows you to print 
your document as a Post-
Script fi le that can then be 
downloaded directly to a 
printer or converted to PDF 
using Acrobat Distiller.
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Along the left side of the Print dialog box is a list of all the panels you can 

choose from to specify a range of print options. Beneath the list of panels is 

a print preview that gives you a better idea of what will print. But this is no 

ordinary print preview—it’s interactive. You can drag the artwork around in 

the preview to determine which part of the paper the art will print on. By 

holding the Shift key while dragging, you can constrain movement to the 

X or Y axis; by double-clicking the preview, you can reset the positioning to 

the default. As you specify changes in the Print dialog box, such as adding 

trim marks, you’ll see those changes appear in the preview as well.

Setting Basic Print Options

As in just about any other program, in the Print dialog box you can specify 

the number of copies as well as the range of pages (or artboards) you want 

to print. This is especially handy now that Illustrator bestows multiple art-

boards to its faithful users. When you specify a range of artboards, use a 

comma as a separation device and a hyphen to indicate a continuous string 

Figure 15.1 The General 
panel in the Print dialog 
box contains the most often 
used print settings.

NOTE The items we’ve 
discussed to this point 

appear across the top and 
along the left side of the Print 
dialog box and are always vis-
ible no matter which panel of 
the dialog box is active.
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of artboards. For example, you can specify a range of 1-3, 6, which will print 

artboards 1, 2, 3, and 6 (Figure 15.2).

In addition to page range, you can specify the following options when print-

ing your artboards:

• Reverse Order. This option prints your last artboard fi rst and your 

fi rst artboard last.

• Ignore Artboards. If you do not select this option, Illustrator will 

print each of the artboards in your document. If you select this option, 

Illustrator will not print separate pages for each artboard. Instead, 

Illustrator will treat all artwork as one single large artboard (determined 

by the total bounding area of all the art), as shown in Figure 15.3.

Figure 15.2 If your docu-
ment contains multiple art-
boards, you can click the left 
and right arrows under the 
preview to view how each 
page will print.

Figure 15.3 You can choose 
to print each artboard sepa-
rately or ignore artboards 
altogether.

Print Each Artboard Separately Ignore Artboards
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• Skip Blank Artboards. If you have artboards that haven’t been fi lled 

with artwork yet, save paper by selecting this option.

In the Media section of the dialog box, you can specify the size of the paper 

on which you want to print. The items that appear in this pop-up menu are 

defi ned by the PPD fi le that is chosen for your printer. If your printer sup-

ports it, you’ll also have the ability to defi ne custom media sizes; being able 

to do so is extremely useful with large-format ink-jet printers or for printing 

to imagesetters or platesetters. Additionally, you can choose an orientation 

to fl ip a page on its side. Changing the orientation can be extremely impor-

tant when printers want to choose which side of a sheet the press will grip. 

It can also be useful when printing to a large-format printer that uses rolls 

of paper, enabling you to save paper by positioning your document to use 

the larger side of the roll.

You can use the Print Layers pop-up menu to specify which kinds of layers 

will or won’t print: Visible & Printable Layers, Visible Layers, or All Layers. 

Additionally, you can set a custom scale size at which to print your fi le. The 

Do Not Scale option prints your fi le at actual size, the Fit to Page option 

reduces or enlarges your artwork so that it fi lls the entire size of the output 

media, and the Custom Scale setting lets you specify any scale size for the 

height or the width. The Placement option lets you reposition your artwork 

on the artboard either by entering values in the X and Y fi elds or by manu-

ally dragging your artwork in the preview window.

Using Page Tiling

Page tiling was initially added to Illustrator to let users print a single large 

fi le across several smaller pages. This allowed a designer to assemble a large 

document at the actual size using a printer with smaller media sizes. How-

ever, over the years, designers learned to use this feature to create a single 

large artboard, using the tiled areas as a substitute for multiple pages. For 

example, setting up a document at 11 x 17 inches with page tiling would 

result in two 8.5 x 11 inch pages. Now, of course, with the arrival of mul-

tiple artboards, this workaround is unnecessary.
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You can now choose from two page tiling settings (Figure 15.4):

• Tile Full Pages. The Tile Full Pages option divides a single artboard 

into multiple sections, or tiles. Each tile matches the media size you 

choose in the General panel of the Print dialog box, and Illustrator cre-

ates as many of those tiles as necessary to cover the entire document. 

Tile Full Pages also allows you to specify an Overlap value in case your 

printer doesn’t print to the edge of each sheet.

• Tile Imageable Areas. The Tile Imageable Areas option divides a 

single artboard into multiple tiles. Tiles match the media size you 

choose in the General panel of the Print dialog box where possible, 

and Illustrator creates custom-sized tiles as necessary to tile the entire 

document.

To tile a document with multiple artboards, you must select the Ignore 

Artboards option.

Because tiling is something you might want to set in your document before 

you even start working on your design, be aware of the Done button that 

appears at the bottom of the Print dialog box. Clicking Done keeps the set-

tings you’ve made in the Print dialog box and returns you to the document 

for further editing and designing without actually printing the fi le. Although 

it may seem odd to open the Print dialog box to specify tiling settings, 

remember that the main reason for tiling in Illustrator is specifi c to printing.

TIP When you’re using 
Tile Full Pages or Tile 

Imageable Areas, each tile is 
assigned a number, and you 
can specify which tiles you 
want to print by entering a 
tile number in the Page 
Range fi eld in the General 
panel of the Print dialog box.

Figure 15.4 Tiling enables 
you to print large artwork 
on smaller sheets of paper 
that you can then assemble 
manually.
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Exploring the Marks and Bleed Print Panel
When printing a page for fi nal output, you need to add page marks and 

bleeds to help printers print the job correctly on press. Trim marks tell a 

printer where to cut the paper, registration marks help a printer align each 

separated plate correctly, color bars help a printer calibrate color correctly on 

press, and page information makes it possible for printers to easily identify 

each separated plate (Figure 15.5).

Of course, you don’t always need all this information on each printout, so 

you choose them individually (for example, on a one-color job, registration 

marks aren’t necessary). Additionally, you can choose between Roman- and 

Japanese-style trim marks. The trim mark weight determines the width of 

Figure 15.5 A printer uses 
a variety of printer marks 
to help ensure that the job 
prints correctly.

NOTE Page marks 
print outside the mar-

gins of the artboard (or wher-
ever you’ve defi ned a crop 
area), so you need to make 
sure the media size you’ve 
chosen in the General panel 
of the Print dialog box is large 
enough to include the page 
marks. If you select the Fit to 
Page option, Illustrator scales 
the entire document to 
ensure that the trim marks 
print on the chosen page.

Page Information Registration Marks

Trim Mark Color Bars
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the strokes used to create trim marks, and the offset determines how far 

from the page the trim marks will appear.

When you have artwork that extends beyond the boundary of a page, you 

can specify a bleed setting to ensure that the printable area of the page 

includes the extra bleed area. When the bleed settings are set to zero, even if 

you’ve extended artwork beyond the boundary of the artboard, the art clips 

to the edge of the artboard. Additionally, if you specify a bleed setting, you’ll 

need to print to a paper size large enough to display the page size and the 

bleed as well. For more information on bleeds, see the sidebar “Adding Bleed” 

in Chapter 1, “Creating and Managing Documents.” If you’ve already speci-

fi ed a bleed setting in the New Document or Document Setup dialog box, 

you can select Use Document Bleed Settings to apply those settings here.

Exploring the Output Print Panel
The Output panel in the Print dialog box is a prepress operator’s dream 

come true. With the ability to specify color separations and control the 

behavior of inks, a print service provider can output Illustrator fi les with 

confi dence.

Illustrator supports three printing modes, each of which is used for a differ-

ent workfl ow (Figure 15.6):

• Composite. When you choose the Composite setting, Illustrator sends 

a single composite of the artwork, with all colors appearing on the same 

page, to the printer or raster image processor (RIP). This is the setting 

you would use to create any kind of black-and-white or grayscale print-

out, as well as any color proof printout.

• Separations (Host-Based). When you choose the Separations (Host-

Based) setting, Illustrator (the host) separates the artwork into the 

required number of plates (specifi ed in the Document Ink Options 

settings mentioned shortly) and sends each plate to the printer or RIP 

as a separate page. This is the setting you use if you want to proof color-

separated artwork. A prepress operator or printer also uses this setting 

to create fi nal fi lm or plates from your artwork.

• In-RIP Separations. When you choose the In-RIP Separations setting, 

Illustrator sends a single composite of the artwork to the RIP so that 

the RIP can perform the color separation instead of Illustrator. All 

NOTE A raster image 
processor is the soft-

ware in a printer, imagesetter, 
or platesetter that converts all 
art into dots so that it can be 
printed.
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the Document Ink Options and separation-specifi c settings become 

available so that you can still control the inks that will print on the 

composite. This is the setting you use if you want to take advantage 

of proprietary trapping, screening, and separations software present in 

your RIP.

Specifying Color Separations
If you choose either of the two separations print modes, you can specify 

additional options for how the color separation will print.

You can choose to print with the right reading emulsion up or down, and 

you can choose whether to print a positive or negative image. You’ll notice 

that as you choose these settings, the interactive print preview updates to 

show you how the art will print. You can also choose a printer resolution 

Figure 15.6 Printing a com-
posite is perfect for proofi ng 
(top). Printing separations is 
required for printing colors 
on a printing press (four 
underlying pages).



CHAPTER 15: PREPRESS AND PRINTING508

setting; these settings are specifi c to the printer to which you’ve chosen to 

print. This information comes from the PPD fi le chosen for your printer 

or RIP.

If your fi le contains spot colors, you can convert them all to separate as pro-

cess colors by selecting the Convert All Spot Colors to Process option. This 

option is even available when you’re printing composite proofs.

When you select the Overprint Black option, all objects that are colored 

100% K overprint. See “Understanding Overprints” later in this chapter for 

more information about overprinting.

In the Document Ink Options section of the Output panel, you can specify 

which plates are sent to the printer and which settings each plate uses 

(Figure 15.7). Colors that appear with a printer icon on the far left print. 

To prevent an ink color from printing, click the printer icon to remove it. 

Inks that appear with a four-color icon separate as process colors. Inks that 

appear with a solid color icon print to their own plates as a spot (custom) 

color. Clicking a solid color icon causes just that color to separate as a pro-

cess color. Additionally, you can specify custom Frequency, Angle, and Dot 

Shape settings for each ink.

Figure 15.7 The diff erent 
icons that display in the 
Document Ink Options sec-
tion of the Output panel 
indicate how the inks print.

Spot Color 
Converted to 

Process

Spot Color

Ink Will Not Print

Process Ink



PRINTING FROM ADOBE ILLUSTRATOR CS4 509

Previewing Separations Before You Print

The great news is that Illustrator CS4 has added a Separations Preview panel. The bad news is that you won’t 
be getting much more than a bare-bones implementation of this productive feature. Like the panels found 
in InDesign and Acrobat, the Separations Preview panel in Illustrator enables you to preview individual color 
separations for both process and spot colors (Figure 15.8) onscreen. Choose Window > Separations Preview to 
open the panel, and then select Overprint Preview to turn the feature on. Then, simply click the display or hide 
icon (eye) of your desired color to view or hide that plate. However, that’s where the similarities stop. Illustrator 
doesn’t “sense” what colors are actually being used in the document. For example, if you add fi ve Pantone 
spot colors to your fi le but use only one, all fi ve are listed in the Separations Preview panel, even though you 
didn’t use the other four. In addition, you do not have options for viewing ink coverage percentages, areas 
with varnishes, and other valuable print settings that you fi nd in the Separations Preview panels in InDesign 
and Acrobat.

Figure 15.8 The Separations Preview panel lets you view each color plate onscreen.
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Exploring the Graphics Print Panel
The settings in the Graphics panel of the Print dialog box are mainly for 

specifying options for your print device.

Prior to the release of Illustrator CS, the Document Setup dialog box con-

tained an Object Resolution setting that determined the fl atness setting for 

Bézier paths at output time. In Illustrator CS, CS2, CS3, and CS4, the fl at-

ness setting is set by default, based on information from the selected PPD 

fi le. You can override this setting and use the slider to sacrifi ce path quality 

for print performance (although it’s best to leave this setting alone).

By default, Illustrator downloads subsets of fonts to the printer when you 

print a fi le. Downloading a subset simply means that Illustrator sends only 

the parts of a font that are required to print the text in your document. For 

example, if you have the word me in your document, Illustrator sends only 

the letters m and e to the printer instead of the entire font (this practice speeds 

up print times). You can override this behavior and choose Complete, which 

forces Illustrator to download the entire font to the printer at print time. 

Alternatively, you can choose not to download any fonts at all. You choose 

this option if you have fonts installed in your printer (some printers can 

contain hard drives and store fonts internally).

By default, Illustrator chooses a PostScript language level that your selected 

printer will support. LanguageLevel 3 PostScript can print documents with 

transparency more reliably, and it also contains smooth shading technology 

that helps prevent banding from appearing in gradients. Additionally, you 

can choose to send data to the printer in ASCII or in the default binary 

format.

As discussed in Chapter 7, “Working with Live Effects,” the resolution at 

which live effects are rasterized is determined by the setting in the Docu-

ment Raster Effects Settings dialog box. Here in the Graphics panel of the 

Print dialog box, Illustrator displays the current setting in that dialog box, 

allowing you to double-check to make sure the setting is indeed correct 

for printing (Figure 15.9). Illustrator won’t allow you to change the set-

ting from the Print dialog box because changing the resolution setting may 

change the appearance of your artwork. To change the resolution setting, 

click the Done button in the Print dialog box, and choose Effect > 

Document Raster Effects Settings. You can then return to the Print dialog 

box to print your fi le.

TIP If you have prob-
lems printing Illustrator 

fi les to older print devices, try 
selecting the Compatible 
Gradient and Gradient Mesh 
Printing options.
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Exploring the Color Management 
Print Panel
The topic of color management really requires a book of its own. In fact, if 

you really want to learn everything there is to know about color manage-

ment, you should check out Real World Color Management, Second Edition, by

Bruce Fraser, Chris Murphy, and Fred Bunting (Peachpit Press, 2005).

However, within the scope of this book (the one you are reading now), are 

some brief explanations for the settings found in the Color Management 

panel of the Print dialog box:

• Document Profi le. The Document Profi le setting displays the color 

profi le that is currently embedded (or assumed) in the fi le. If you didn’t 

manually choose one, the profi le you see here is the profi le that is cho-

sen in the Color Settings dialog box.

• Color Handling. The Color Handling setting allows you to determine 

whether Illustrator will perform any necessary color adjustments (based 

on the chosen printer profi le) or whether your printer will handle any 

required conversion on its own. Unless you are working within a pro-

prietary workfl ow system, you should always let Illustrator determine 

colors, not the printer.

• Printer Profi le. When the Color Handling option is set to Let 

Illustrator Determine Colors, the Printer Profi le setting lets you specify 

a profi le for your printer. This gives Illustrator the information it needs 

to change colors so they look correct on your printer. If the Color 

Handling option is set to Let PostScript Printer Determine Colors, 

the Printer Profi le setting is not applicable.

Figure 15.9 Although you 
can’t change the Document 
Raster Eff ects Resolution 
setting from the Print dialog 
box, the Graphics panel 
does alert you to the current 
setting in case you need to 
make a change.
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• Rendering Intent. If some colors in your document cannot be repro-

duced on a given output device, the colors are considered out of gamut

and must be converted to colors that will reproduce on the output 

device. There are different methods for converting these colors, and 

the Rendering Intent setting determines the method used. The most 

commonly used method, Relative Colorimetric, moves out-of-gamut 

colors to the closest possible color that will print on the device. It also 

adjusts other colors so that colors appear to be accurate. The Absolute 

Colorimetric setting adjusts only out-of-gamut colors and may result 

in posterization, where many shades of similar colors are used. The 

Perceptual method shifts colors so that they appear correct relative to 

each other, but it may not represent colors as being the most accurate 

match to the original values. The Saturation method enhances colors 

and makes them more vibrant and most suitable for business presenta-

tions where bright colors are more important than accurate colors.

• Preserve CMYK Numbers. The Preserve CMYK Numbers setting 

is active only when Color Handling is set to the Let PostScript Printer 

Determine Colors option. With Preserve CMYK Numbers active, color 

values will remain untouched in native artwork and text components of 

your fi le.

Exploring the Advanced Print Panel
The Advanced panel in the Print dialog box gives you control over impor-

tant settings such as overprinting and transparency fl attening.

If your document contains overprint settings, you can choose from one of 

three settings to control overprint behavior:

• Preserve. The Preserve option leaves all overprints intact in your fi le.

• Discard. The Discard option strips your fi le of any overprint com-

mands. Those who have proprietary production systems or advanced 

trapping software in their RIPs will fi nd this option useful. Rather than 

use a designer’s overprint settings, the trapping software applies and 

determines all overprint behavior instead.

• Simulate. The Simulate option, available only when printing composite 

proofs, simulates overprints in the printout, giving the correct appear-

ance of the fi nal output in the proof.

NOTE The Print as 
Bitmap option is 

available for non-PostScript 
printers only and rasterizes 
all artwork in your fi le for 
printing.
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If your document contains transparency, you can choose from a list of pre-

defi ned transparency fl attener presets. Illustrator ships with three presets 

called Low Resolution, Medium Resolution, and High Resolution, but you 

can also defi ne your own custom option for your particular print session by 

choosing Edit > Transparency Flattener Presets. For detailed information 

about what these settings are used for and what the differences between 

them are, see the section “Learning the Truth About Transparency” later in 

this chapter.

Defi ning Print Presets
As you’ve undoubtedly seen, the Print dialog box in Illustrator contains a 

plethora of settings, and going through each panel to make sure the set-

tings are correct is an exercise in patience. Print presets allow you to capture 

all the options set in the different Print dialog box panels so that you can 

easily retrieve those settings at any time. To create a print preset, click the 

Save Preset button (the disk icon) at the top right of the Print dialog box; to 

manage your presets, choose Edit > Print Presets. Print presets are saved in 

XML and are cross-platform, so you can import and export them and dis-

tribute them among others.

LEARNING THE TRUTH ABOUT
TRANSPARENCY
Illustrator contains several features that use transparency, including the 

ability to specify blending modes and opacity masks with the Transparency 

panel and via effects such as Feather and Drop Shadow. Transparency as a 

feature in Illustrator (and InDesign as well) requires closer attention when 

it comes to printing documents. In fact, Illustrator, InDesign, and Adobe 

Acrobat all use the same methods to print with transparency, so the con-

cepts you learn here apply to all those applications as well.

Although you may have heard that printing with transparency is problem-

atic, the reality is that a lot has changed since transparency was fi rst 

introduced in Illustrator 9. Once you understand what happens to a fi le with 

transparency and you learn about a few simple settings, you won’t have to 

worry about running into printing issues when you’re using transparency 

features.

NOTE See “Under-
standing Overprints” 

later in the chapter to learn 
more about overprints.

NOTE If you delete 
your application prefer-

ences, you won’t lose your 
saved print presets.
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In truth, transparency has always been around—in raster form—in Adobe 

Photoshop. The only difference now is that you can apply these effects in 

vector form and still edit them late in your workfl ow. At the end of the day, 

these transparency effects will become rasterized, leaving you with the same 

result as if you had done everything in Photoshop. In any case, let’s take a 

closer look at what transparency is and how it works.

Understanding Transparency Flattening
Let’s start with a simple fact: PostScript doesn’t understand transparency. As 

you probably know, PostScript is the language that printers and RIPs speak. 

Native transparency is understood only by PDF language version 1.4 or 

newer (fi rst present in Acrobat 5 and Illustrator 9).

To print objects with transparency, Illustrator must “translate” any transpar-

ent artwork into a language that PostScript understands. This translation 

process is called transparency fl attening.

The process of fl attening is simple, and Illustrator follows two cardinal rules 

when performing fl attening on a fi le:

1. All transparency in the fi le must be removed.

2. In the process of performing rule #1, the appearance of the fi le cannot 

change.

Both of these rules are followed during the fl attening process, with no 

exception. Obviously, all transparency has to be removed because PostScript 

doesn’t know what transparency is. Additionally, if removing the transpar-

ency would result in your fi le changing in appearance, that would mean you 

could design something in Illustrator that couldn’t be printed, which doesn’t 

make sense either. If you think about it, if you’re removing transparency 

from the fi le and you’re also keeping the visual appearance of the object, 

something has to give, and that something is the editability of your fi le. 

Let’s take a look at an example of this.

Flattening Artwork

Let’s try an example of fl attening:

1. Draw two different-colored circles, one overlapping the other.

2. Set the top circle to Multiply (Figure 15.10).

NOTE If you’ve used 
Photoshop before, 

you may be familiar with the 
term fl attening, which com-
bines all layers in a document. 
Although similar in concept, 
transparency fl attening is 
diff erent.
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The nice feature of transparency is that you can move the top circle 

around or change its color, and any overlapping areas will simply mul-

tiply. The problem is that PostScript doesn’t know what transparency 

is and doesn’t know how to print that overlapping area, so transparency 

fl attening is required.

3. Select both circles, choose Object > Flatten Transparency, and click OK 

(don’t worry about the dialog box, which we’ll get to later).

The fi le is now fl attened. Does it look any different? It can’t, because of 

rule #2, but the fi le now no longer contains any transparency and can 

be printed on a PostScript device. The difference is that the fi le is no 

longer editable as it was before it was fl attened. Upon selecting the cir-

cles, you’ll fi nd that the two transparent circles have now been broken 

up into three individual opaque shapes (Figure 15.11).

This fl attening process happens every time you print something with trans-

parency. However, the fl attening happens in the print stream, not to your 

actual Illustrator fi le. When you choose to print a fi le, Illustrator fl attens a 

copy of your fi le and sends the fl attened fi le to the printer, while leaving 

your document intact. It wouldn’t be good if simply printing a fi le rendered 

it uneditable. In our example, we specifi cally fl attened the fi le using the 

Figure 15.10 By setting the 
top circle to the Multiply 
blending mode, you can 
see through it to the circle 
below, even with Opacity 
set to 100%.

Figure 15.11 Once the 
objects are fl attened, the 
artwork is split up into 
individual opaque pieces, 
called atomic regions.
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fl atten transparency function to see the results, but under normal circum-

stances, you would not fl atten the transparency manually—Illustrator would 

do that for you automatically at print time.

So, when you print a fi le with transparency, this fl attening process occurs so 

that a PostScript printer can print the fi le correctly, and this process happens 

on the way to the printer, so your Illustrator fi le is not affected in any way.

This example of the two overlapping circles is a simple case of fl attening. 

However, other examples can display certain side effects. Let’s explore such 

a case.

Flattening with Rasterization

Let’s create another example:

1. As in the previous example, create two overlapping circles.

2. Set the top circle to Multiply.

3. Fill each circle with a linear gradient, but in one of the circles, apply the 

gradient on a 45-degree angle.

The result is two circles with gradients, but the area in which these two 

shapes overlap appears as two gradients traveling in different directions 

(Figure 15.12).

When this fi le is fl attened, you know that the result will be three sepa-

rate shapes as in the previous example; however, this example is a bit 

different. Although gradients can be preserved in vector form, there’s 

no way to describe a crisscross gradient, like you see in the overlapping 

area, as a vector. Because of rule #2, Illustrator is not allowed to change 

NOTE Flattening also 
happens whenever 

you save or export your fi le 
to a format that doesn’t 
understand transparency. 
For example, EPS (which is 
PostScript) and PDF 1.3 do 
not support transparency.

Figure 15.12 This fi gure 
shows two overlapping 
circles, each fi lled with 
a gradient on a diff erent 
angle.
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the appearance of your fi le during fl attening, so the only course of action 

Illustrator can take is to turn that overlapping area into a raster image.

4. Select both circles, choose Object > Flatten Transparency, and click OK.

You’ll fi nd that although the fi le looks the same, it now consists of two 

vector shapes and a raster image in the middle. Illustrator creates a vec-

tor mask for the middle shape so that the fi le will print correctly (raster 

images are always rectangular in shape). It’s important to point out that 

Illustrator didn’t raster the entire fi le; it merely rasterized the portion of 

the fi le that could not be preserved in vector form (Figure 15.13).

At this point, a question should be forming in your mind: If part of the fi le 

is now a raster image, what is the resolution of that raster? Patience, young 

Padawan; we’ll get to that soon. Here’s a review of what you’ve learned to 

this point:

• Transparency fl attening is required to correctly print a fi le with trans-

parency to a PostScript device.

• Transparency fl attening happens automatically, in the print stream, 

when you print a fi le with transparency from Illustrator, InDesign, 

Acrobat, or Adobe Reader.

• Transparency fl attening may cause certain parts of a vector fi le to 

become rasterized to prevent a fi le from changing in appearance.

Using the Two Levels of Rasterization

In the previous example, where two vector shapes resulted in a portion 

of that fi le becoming rasterized, Illustrator had no choice but to rasterize 

Figure 15.13 Where 
appearance can’t be 
preserved in vector form, 
Illustrator converts parts 
of a fi le into a raster.
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the middle region because there was simply no other way to preserve the 

appearance in vector form. This is one level of rasterization.

However, in some cases a second level of rasterization may occur, even if 

the appearance of a fi le could be preserved in vector form. Before printing 

a fi le, Illustrator analyzes the entire document and looks for complex regions

containing many overlapping objects (which would result in a large number 

of atomic regions). Illustrator may then choose to rasterize those complex 

regions for performance reasons. Although we’ve been trained to think vec-

tor objects are simpler than their bitmapped counterparts, try to imagine an 

Illustrator graphic fi lled with many overlapping objects with transparency 

applied (Figure 15.14). Although it may seem like only several objects at 

fi rst glance, once those objects are broken up into atomic regions, you may 

be looking at thousands of vector shapes, which can take a long time to pro-

cess and print (Figure 15.15). In those cases, Illustrator can save precious 

RIP and processing time by rasterizing these complex regions.

Figure 15.14 Using the 
Symbol Sprayer tool, you 
can easily create a fi le that 
contains many overlapping 
shapes. You can also make 
some of these symbols 
transparent with the 
same tool.
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As far as the fi rst level of rasterization goes, you really have no choice but 

to allow Illustrator to rasterize objects where it needs to do so. What you 

can do, however, is learn how to build fi les that work around this issue (see 

“Understanding Object Stacking Order and Transparency Flattening” later 

in this chapter). With regard to the second level of rasterization, you can 

control how liberal Illustrator is when looking for complex regions. In fact, 

you can even disable this second level of rasterization altogether. Finally, 

with either level of rasterization, Illustrator always gives you total control 

over how these areas are rasterized.

Understanding the Transparency Flattener Settings

As mentioned earlier in this chapter, Illustrator has three transparency fl at-

tener presets that you can choose from in the Advanced panel of the Print 

dialog box. These settings control how fi les with transparency are fl attened 

at print time. To access these settings, choose Edit > Transparency Flattener 

Presets, and click the New button to defi ne a new preset. Let’s explore 

the settings in the Transparency Flattener Preset Options dialog box 

(Figure 15.16).

Figure 15.15 Even though 
you may have started with a 
small number of objects, the 
resulting number of atomic 
regions can be extremely 
large because of fl attening.
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• Raster/Vector Balance. This slider is what controls how liberal 

Illustrator is when looking for complex regions to rasterize (what we 

defi ned previously as the second level of rasterization). A number closer 

to zero (0) gives Illustrator more freedom to rasterize at will, resulting 

in faster print times. Moving the slider closer to 100 results in fewer ras-

terized areas but longer print times. At the 100 setting, Illustrator does 

not rasterize any parts of the fi le for performance reasons, effectively 

disabling the second level of rasterization. The High Resolution fl at-

tener preset uses this setting. In cases where fi les are taking extremely 

long to print (or crashing the RIP altogether), adjusting this slider to a 

slightly lower setting helps.

• Line Art and Text Resolution. In cases where Illustrator is going to 

rasterize line art or text, you can specify a resolution that results in good-

looking, sharp output. You’ll notice that the High Resolution fl attener 

setting specifi es a resolution of 1200 ppi, ensuring that text elements and 

vector objects still have nice, clean, sharp edges in fi nal output.

• Gradient and Mesh Resolution. Because gradients and meshes are 

continuous tones in nature, they don’t require a resolution as high as 

line art or text. In fact, anything twice your line screen is probably 

getting thrown out anyway. Therefore, Illustrator uses this setting to 

rasterize elements that can afford to be set at a lower resolution. You’ll 

notice that the High Resolution fl attener preset uses a value of 300 ppi.

• Convert All Text to Outlines. In cases where text is going to be raster-

ized, chances are that the rasterized text looks a bit chunkier than regular 

vector text. To compensate for this, you can turn on this option to con-

vert all text to outlines, giving a consistent chunkier look to all of your 

text. If you use the method described later in this chapter to move text 

onto its own layer, you’ll rarely need to concern yourself with this setting.

Figure 15.16 You can 
defi ne your own custom 
fl attener settings, or your 
printer or service provider 
can defi ne them for you.

NOTE The two resolu-
tion settings in the 

fl attener controls are used 
whenever vector objects are 
forced to become rasters 
during the fl attening process. 
However, live eff ects, such as 
Feather and Drop Shadow, 
use the Document Raster 
Eff ects Resolution setting to 
determine their resolutions.
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• Convert All Strokes to Outlines. Similar to the previous setting, this 

compensates for disparity between vector and rasterized strokes by con-

verting all strokes to outlines.

• Clip Complex Regions. We mentioned that Illustrator can look for 

complex areas of a fi le and rasterize them for performance reasons. 

However, we know that raster images are always rectangular in shape, 

which means it’s possible for “innocent” parts of your fi le to become 

rasterized simply because they fall into the rectangular bounding box 

of the area that is complex. More often than not, this results in stitching,

or noticeable boxes and color shifts. The Clip Complex Regions option 

avoids this issue by creating a clipping mask around any rasterized com-

plex region (so the rectangular-shaped raster is masked by the vector 

outline of the object). As you can probably understand, this makes for 

even more complex fi les and can result in longer print times as well. 

This option is turned on by default but isn’t applicable in the High 

Resolution preset because no complex regions are rasterized at all with 

that setting (because it has a Raster/Vector Balance setting of 100).

Understanding Object Stacking Order and 
Transparency Flattening

When rasterization occurs during transparency fl attening, the last thing you 

want to see turning into a raster is text. That’s because you always want text 

to be clean and sharp in your printouts. Even at the High Resolution setting, 

where text is rasterized at 1200 ppi, that resolution is still less than half of 

what most imagesetters set text with—usually upward of 2400 ppi.

Although it’s true that under certain circumstances rasterization must occur 

in order to print a fi le and maintain its appearance, the way you build your 

fi les can affect how often this happens. Let’s look at a simple example that 

clarifi es this:

1. Draw a circle, and add a drop shadow to it by choosing Effect > 

Stylize > Drop Shadow.

As you learned in Chapter 8, “Working with Typography,” the Drop 

Shadow effect is a raster-based effect, and when transparency is fl at-

tened, the drop shadow becomes rasterized.
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2. Switch to the Type tool, create some text, and position the text near the 

drop shadow (Figure 15.17).

3. With the text still selected, choose Object > Arrange > Send to Back.

4. Now select both the circle and the text, choose Object > Flatten 

Transparency, and click OK.

Upon close inspection, you’ll see that a portion of the text was raster-

ized. This happened because the text was below the drop shadow in 

the stacking order, and to maintain the fi le’s appearance when the drop 

shadow was rasterized, Illustrator had to include part of the text in the 

drop shadow’s bounding area (Figure 15.18).

Figure 15.17 Placing text 
near an object is common, 
especially when you’re add-
ing captions or credit text 
near photographs.

Figure 15.18 To maintain 
the appearance of the fi le, 
Illustrator rasterized the text 
that was behind the drop 
shadow.
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5. Choose Edit > Undo to go back to the version before you applied the 

Flatten Transparency function, and select the text object.

6. Choose Object > Arrange > Bring to Front.

7. Select the circle and the text, choose Object > Flatten Transparency, 

and click OK.

In this case, the text, which was above the drop shadow in the stacking 

order, was not affected at all and was not rasterized (Figure 15.19).

When using transparency features in Illustrator (or InDesign, for that mat-

ter), it’s important to make sure that text always appears above objects with 

transparency to avoid unwanted rasterized text issues. Of course, some 

designs call for text to appear beneath transparent objects, and in those 

cases, you don’t have much of a choice.

Does My File Contain Transparency?
Not every document needs fl attening—only those with transparency 

in them. The tricky part is that transparency can be introduced into an 

Illustrator document in several ways:

• You apply a blending mode or an Opacity value other than 100% in 

the Transparency panel.

• You apply the Effect > Stylize > Drop Shadow feature.

• You apply the Effect > Stylize > Feather feature.

Figure 15.19 If the text 
appears above the shadow 
in the stacking order, the 
text is not rasterized 
during fl attening.
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• You apply the Effect > Stylize > Outer Glow feature.

• You apply the Effect > Stylize > Inner Glow feature.

• You apply any “below-the-line” Photoshop effect from the Effect menu.

• You place a PDF fi le that contains transparency.

• You place a native Photoshop fi le or layered TIFF that contains 

transparency.

It would be helpful to know whether the document you’re working on 

uses transparency or is even going to require any of the two levels of ras-

terization we spoke of earlier. You can use the Flattener Preview panel 

(Window > Flattener Preview) to tell whether a document has transparency 

effects in it, as well as to preview areas that will become rasterized in the 

fl attening process.

By clicking the Refresh button in the panel, Illustrator highlights specifi c 

areas in your fi le in red, indicating where rasterization will occur. You can 

enlarge the panel to see a larger image, and you can also click inside the 

preview area of the panel to zoom in closer to see more detail. From the 

Highlight pop-up menu, you can choose from a variety of items that 

Illustrator will preview. If all the items listed in your Highlight pop-up 

are dim, that indicates your fi le doesn’t have transparency present, and no 

fl attening is necessary to print your fi le (Figure 15.20). For example, when 

you choose Transparent Objects, Illustrator shows you where all objects that 

use transparency are on your page—although those regions may not neces-

sarily become rasterized. We also mentioned earlier that Illustrator looks for 

complex areas of a document; you can see where those areas are by choosing 

Rasterized Complex Regions in the pop-up menu (Figure 15.21). Addition-

ally, the All Affected Objects option shows you all the objects that may not 

be transparent themselves but that interact with transparency in some way. 

(Like with the example we mentioned earlier with the drop shadow and 

the text, the text itself doesn’t have transparency applied to it, but if the text 

appears below the drop shadow, the text must become rasterized to preserve 

the appearance.)

To take advantage of all that the Flattener Preview panel can offer, adjust 

the different fl attener settings, and preview the results—making changes or 

adjustments where necessary—all before you actually print the fi le. As an 

aside, InDesign and Acrobat Pro also contain a similar Flattener Preview 

panel and identical fl attener settings (in fact, it’s the same underlying code).
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Figure 15.20 If your fi le 
contains no transparency, 
you don’t have to worry 
about the eff ects of 
fl attening.

Figure 15.21 You can 
use the Flattener Preview 
panel to identify areas that 
Illustrator deems as complex 
regions, giving you a heads 
up for what areas will be 
rasterized.
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What Kind of RIP Are You Using?

To throw yet another variable into the mix, the kind of printer or RIP you use can also render diff erent results. 
For the most part, any Adobe PostScript LanguageLevel 3 device should be able to handle transparency 
without issue. Specifi cally, PostScript version 3015 (which appears in the latest versions of RIPs) has enhanced 
functionality to process fi les that have been fl attened. It’s important to remember that fl attening has to occur 
for any RIP to understand how to print transparency. If your RIP can process PDF fi les, that doesn’t necessarily 
mean it can process PDF fi les with transparency in them. If you’re in doubt, check with your RIP manufacturer 
to fi nd out whether transparency fl attening can occur inside the RIP or whether you need to print fi les from an 
Adobe application to fl atten them.

Some older print devices are confused by the eff ects of fl attening. For example, a Scitex Brisque RIP (since 
acquired by Creo and now Kodak) looks at jobs that are printing and splits up the vector and raster elements 
onto two “layers.” The rasterized content prints on a continuous tone (CT) layer at a lower resolution (such as 
300 dpi), and line art prints on a separate vector layer at a much higher resolution (such as 2400 dpi). Because 
fl attening could cause a vector object to be rasterized, the RIP sees that raster only as a CT image and prints it 
at the lower resolution. This might cause text that is rasterized to print with noticeably jagged edges. There’s 
an update available for Brisque RIPs to address this issue, but that doesn’t automatically mean everyone who 
owns a Brisque has installed the update (or knows it exists).

Rampage RIPs also experience similar issues, although turning off  the dual-mode setting addresses the problem.

The best advice in any case is to talk with your printer. For any big job, most printers will be happy to run a test 
fi le for you to make sure everything will print correctly. Taking advantage of these opportunities will surely 
save you headaches when press deadlines loom. Adobe also has free specialized training materials for print 
service providers if your printer needs more information (located online at http://partners.adobe.com/public/
asn/psp/detail.html).

Printing with Confi dence
You can avoid accidents by learning to anticipate possible problems. Now 

that you’re aware of how transparency works, here are a few ways to ensure 

that you get the results you expect when you’re printing from Illustrator:

• Use the right fl attener presets—Low Resolution, Medium Resolution, 

and High Resolution. For quick proofs to your laser printer, you can 

use the Low Resolution or Medium Resolution setting, but when you’re 

printing to a high-end proofer or imagesetter, use the High Resolution 

setting. You’ll fi nd the Transparency Flattener settings in the Advanced 

panel of the Print dialog box.

http://partners.adobe.com/public/asn/psp/detail.html
http://partners.adobe.com/public/asn/psp/detail.html
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• To avoid text becoming rasterized, create a new layer in your Illustrator 

fi le, and place all your text on that layer. As long as you keep that text 

layer as the top layer in your document, you won’t have to worry about 

chunky or pixelated text because of rasterization.

• A potential problem is that even if you, as a designer, are aware of trans-

parency, plenty of printers aren’t. If you are sending a fi le and aren’t sure 

who will be printing it or what they will be using to print it, you might 

consider sending the fi le as a PDF/X-1a fi le. See Chapter 14, “Saving 

and Exporting Files,” for more information about PDF/X.

If you’d like an easy way to remember the important steps to get great 

results when printing, a small transparency checklist (Figure 15.22,

courtesy of Design Responsibly), is available when you register at 

www.peachpit.com/rwillcs4.

Figure 15.22 The transpar-
ency checklist off ers a few 
quick reminders to help 
ensure your fi le prints 
correctly.

Designing with transparency allows you to design creations that were pre-

viously prohibitive and diffi cult to implement, thus allowing you to save 

valuable time while being even more creative. Now that you know how 

transparency works and what’s necessary to use it in your workfl ow, give 

it a test drive. You’ll be happy you did.

www.peachpit.com/rwillcs4
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UNDERSTANDING OVERPRINTS
Hang around a print shop long enough, and you’ll hear the term overprint. In 

the world of prepress, overprinting is a way to control how color-separated 

plates interact with each other. A printing press imprints each color on a 

piece of paper, one after the other, as it runs through the press. Because 

of this process, you need to consider certain issues when making color 

separations.

For example, say you design some blue text over a yellow background. 

When those colors are separated and printed on press, the blue and yel-

low mix, resulting in green text on a yellow background. Therefore, under 

normal conditions, when pages are separated, color that appears underneath 

other objects is removed so that the color on top is unaffected. In this exam-

ple, the blue text removes, or knocks out, the yellow background underneath 

it, allowing the blue to appear correctly when printed.

Overprinting, on the other hand, is a method of overriding a knockout and 

forcing overlapping colors to mix on press. In our example, setting the blue 

text to overprint means that the yellow background still appears behind it, 

and the result on press is green text on a yellow background (Figure 15.23).

Figure 15.23 The text on 
the left, by default, knocks 
out the background behind 
it. The text on the right is 
set to overprint, and the 
background behind it is 
unaff ected.

Knockout

Blue Plate Yellow Plate Blue Plate Yellow Plate

Overprint
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Why Overprint?
You’d want to apply an overprint when you specifi cally want to mix colors 

on press. Some designers who work with low-budget jobs that print in two 

or three spot colors can simulate other colors by mixing those spot colors. 

Before transparency rolled around, designers would also specify overprints 

to simulate objects being transparent; you could also simulate shadows or 

shading by overprinting with black over other elements.

Overprinting is also essential when you’re creating plates for custom dyes 

and varnishes. For example, if you want to create a spot varnish for a par-

ticular photo, you need to create a spot color called Varnish and set it to 

overprint, because this allows the photo that appears beneath it to print 

(otherwise, the varnish knocks out the photo).

You can easily specify overprinting from the Attributes panel (Window > 

Attributes). With an object selected, you can force the fi ll, the stroke, or both 

to overprint. Remember that Illustrator also allows you to specify whether a 

stroke is painted in the centerline, inside, or outside a path, and you should 

be aware that if you overprint a stroke that’s on the inside or the centerline 

of a path, the stroke also overprints the fi ll of that object.

Trapped in a Corner

Those who work in packaging rely on using overprints all the time for creating 
traps—colors that share borders with other colors that overlap slightly. This is 
because the materials that are used for many packages and the printing pro-
cesses used (called fl exographic printing, or fl exo for short) don’t always result 
in perfect printing. Remember that the requirements for printing a couple 
hundred brochures and printing several million containers of milk can be quite 
diff erent. The next time you see a bag of potato chips or a bottle of soda, take 
a close look at the label; you’ll be able to see the overprint traps. These are 
usually created in Illustrator by setting just the stroke to overprint.
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Handling the Limitations of Overprints
Let’s get technical for a moment. You’ll encounter some limitations when 

it comes to using overprints. First, whereas one color plate can overprint 

another, an overprint cannot overprint its own plate. For example, if you 

have a color that contains cyan and you set it to overprint over a background 

that contains cyan, you won’t get an overprint on the cyan plate.

Second, sometimes users specify overprinting for objects colored white. 

Usually, white is always a knockout (because it lets the white paper show 

through), and setting a white object to overprint would kind of defeat the 

purpose. However, these things do happen accidentally. You might have a 

logo that you created that’s colored black and that you’ve set to overprint. 

Then you might come upon a situation where you need a reverse (white) 

version of the logo, so you might just open the fi le, color it white, and save 

it with a different name, forgetting that you set the fi ll to overprint. This 

would most likely result in the fi le not printing properly, because either the 

white overprints (making it entirely transparent) or the RIP doesn’t process 

the fi le correctly.

Previewing Overprints
Because overprints are really PostScript commands that you use when 

you’re printing color separations, you’ll always have a problem with display-

ing overprints onscreen or when you’re printing composite proofs to show 

a client. In the past, the only real way to proof overprints was by printing 

separations and creating a matchprint proof or by investing in expensive 

prepress plug-ins. More often than not, a designer would show a proof to 

a client and say, “It won’t look like this when it’s actually printed.” If only 

there were a better way…

Illustrator offers that better way. By choosing View > Overprint Preview, 

you can actually see on your monitor what the effects of overprint com-

mands are. Additionally, in the Output panel of the Print dialog box, the 

Simulate Overprint option, when activated, prints composites as they will 

look with overprints applied. This is perfect for showing clients exactly what 

they are going to get. The Simulate Overprint option is also available in the 

Advanced panel of the PDF dialog box, so you can even show your client an 

accurate proof via PDF. You disable Simulate Overprint when you choose to 

print separations—it’s available only when you’re printing composites.
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Although overprints are useful (and essential in some workfl ows), our 

advice is to talk to your printer before you use them, because some printers 

prefer to specify overprints themselves.

Handling Transparency Effects That 
Disappear or Print as White Boxes
Has the following scenario ever happened to you?

You create some artwork that contains two spot colors (let’s say Pantone 

Blue 072 and Red 032). The logo has a drop shadow behind it, and you’ve 

correctly set the Illustrator Drop Shadow effect to use the Blue 072 spot 

color, not black. On the Illustrator artboard, the logo appears correctly 

against the spot color background (Figure 15.24).

Figure 15.24 In Illustrator, 
the Drop Shadow eff ect 
appears correctly against 
the spot color background.

Then you save the art as a PDF/X-1a fi le because it will be used in an ad 

and you want to make sure it will print correctly. Or you save your docu-

ment using Acrobat 4 (PDF 1.3) compatibility. Alternatively, you save your 

fi le as an EPS fi le because maybe you’re required to place this logo into a 

QuarkXPress document. The point here to focus on is that you’re saving 

your fi le to a fl attened format.
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The “problem” is that when you open the PDF in Acrobat or Reader, or 

when you place the fi le into QuarkXPress or InDesign and print the fi le to 

your laser or ink-jet printer, it comes out looking incorrect—either the drop 

shadow disappears completely (Figure 15.25) or a white box appears where 

the transparent effect should blend into the background (Figure 15.26).

Figure 15.25 When saving 
the fi le from Illustrator CS4 
and viewing or printing the 
art outside of Illustrator, the 
transparency eff ect seems 
to disappear.

Figure 15.26 When saving 
the fi le from Illustrator CS4 
and viewing or printing the 
art outside of Illustrator, a 
white box appears around 
the transparency eff ect.
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The key items to focus on here are that you have used a transparent effect 

and you’ve used a spot color. Now, you’ll know what’s happening and what 

the solution is.

When you have a transparent effect, the result is a mixture of the inks. In 

this case, the shadow, which is Pantone Blue 072, blends right into the Red 

032 background. By default, when one color sits on top of another color, a 

knockout occurs, as we discussed earlier in this chapter. In other words, the 

area beneath the top shape is removed from the lower object. Otherwise, 

the top color will print on top of the bottom color when the paper is run 

through the printing press, causing the two inks to mix. In the case of the 

red and blue colors, the result would be purple in appearance. However, in 

this case, where you want the drop shadow to blend into the background on 

press, you have to override that knockout by specifying an overprint.

The thing is, Illustrator already knows this, so no action is required on 

your part. When you print your fi le from Illustrator, all these settings are 

done automatically, so your fi le looks great when you print it—either as a 

composite or as separations. The same applies when you save your fi le from 

Illustrator as a native Illustrator fi le and place it into InDesign or when you 

create a PDF with Acrobat 5 compatibility (PDF 1.4) or newer.

But when you save your fi le to a format that doesn’t support transparency, 

Illustrator has to fl atten the transparency. And in that process, Illustrator 

realizes that in order to preserve the spot colors so that they print in separa-

tions correctly, the drop shadow must be set to overprint the background 

color (in Illustrator CS4, the spot color is set to overprint instead).

The problem is that overprint commands are honored only when you print 

your fi le as separations. When you are previewing your document onscreen 

or when you are printing a composite proof of your fi le, the overprint com-

mands aren’t used, and either the result will be white where overprinting 

should occur or the transparency effect will simply disappear. The fi le will 

print correctly when you print as separations, because, at that time, the over-

prints are honored (as they should be).

NOTE Some RIPs have 
built-in settings to 

ignore overprints in fi les and 
instead use their own settings 
for overprints. This often 
results in output that isn’t 
desirable. You can easily fi x 
these issues by instructing 
the RIP to honor the over-
prints in your fi les. For exam-
ple, Rampage RIPs have a 
setting called Preserve 
Application Overprint that, 
when activated, results in 
perfect output.
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The good news is that this issue is easy to solve when using InDesign, 

Acrobat, or Reader:

• In InDesign, choose View > Overprint Preview. This will allow you to 

view overprints on your screen. When printing composite proofs, select 

the Simulate Overprints box in the Output panel of the Print dialog box 

to get the correct appearance in your printouts.

• In Acrobat or Reader, click the Overprint Preview button in the Page 

Display panel in Preferences to view the fi le correctly on your screen. 

When printing composite proofs, choose Print, and then click the 

Advanced button. Then select the Simulate Overprinting box in the 

Output section of the dialog box. The fi le will then print with the 

correct appearance.

TIP If you’re using 
QuarkXPress (at least 

up through version 8.0), 
though, you really don’t have 
an option, because that pro-
gram doesn’t allow you to 
simulate overprint commands 
when printing composite 
proofs. One workaround is to 
create two versions of your 
fi le: one that uses spot colors 
that will separate correctly 
when you print separations 
and another version where 
you’ve converted your spot 
colors to process colors. When 
you convert to process colors, 
you don’t need the overprints, 
and the fi le will print with the 
correct appearance on a com-
posite proof.



Appendix         Application Preferences

Adobe Illustrator CS4 has many different settings, or preferences, that control 

the program’s behavior. You can fi nd these settings on the 12 panels of the 

Preferences dialog box. On Mac OS, you can open the Preferences dialog 

box by choosing Application > Preferences or by pressing Command-K. 

On Windows, you can open the Preferences dialog box by choosing Edit > 

Preferences or by pressing Ctrl-K.

In general, the preferences in Illustrator are application-based, meaning they 

aren’t saved in each Illustrator document but rather in Illustrator’s applica-

tion preferences fi le (see the sidebar “The Illustrator Preferences File”). This 

means if you open an Illustrator fi le that was created on another computer 

with different preferences, your own preferences don’t change.

535
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The Illustrator Preferences File

Each time you quit or close Illustrator, it writes the latest preferences you’ve specifi ed along with information 
about which panels are open and their locations on your screen.

When things go awry in Illustrator (frequent crashing, missing tools or panels, and so on), the culprit can often 
be a corrupt preferences fi le. In such cases, the cure is to delete the preferences fi le (when no preferences fi le is 
present at launch time, Illustrator generates a new one).

You can delete the preferences fi le automatically by pressing Command-Option-Shift (Ctrl-Alt-Shift) while 
launching Illustrator. Keep the keys pressed until you see the splash screen appear. Alternatively, you can man-
ually delete the fi le, which you can fi nd in the following location:

Mac OS: Username/Library/Preferences/Adobe Illustrator CS4 Settings/en_US/Adobe Illustrator Prefs

Windows: Documents and Settings\Username\Application Data\Adobe\Adobe Illustrator CS4 Settings\
en_US\ AIPrefs

If you make many changes to your preferences fi le, you’ll lose the changes when you delete your preferences 
fi le. For this reason, you might consider making a copy of your fi le for safekeeping. If you ever need to delete the 
preferences fi le, simply use the copy you’ve created. Or if you’re really brave, you can manually edit the fi le in just 
about any text editor.

THE GENERAL PANEL
The General panel of Preferences is pretty much a melting pot of settings 

(Figure A.1). These settings are also the ones that alter the behavior of 

Illustrator the most.

Figure A.1 The General 
panel in Preferences off ers 
quick access to settings such 
as Keyboard Increment.



THE GENERAL PANEL 537

Keyboard Increment. When moving artwork around on your screen, 

using the mouse or even a pressure-sensitive pen doesn’t always give you the 

control you need. The Keyboard Increment setting determines the distance 

a selected object moves when you tap any of the four arrow keys on your 

keyboard. Some call this the nudge amount. Don’t be fooled into thinking 

that this setting should always be as small as possible. When you’re working 

with a grid or in scale (designing fl oor plans, schematics, and so on), it can be 

extremely helpful to set your keyboard increment to a specifi c value (such as 

.25 inch). In this way, you can easily tap an arrow two times and know you’ve 

moved the object exactly .5 inch. It’s no coincidence that when you open the 

Preferences dialog box, the Keyboard Increment value is highlighted. Power 

users know they can quickly press Command-K (Ctrl-K), enter a value, press 

Enter, and then nudge their objects precisely.

Constrain Angle. When you draw objects in Illustrator, the objects are 

aligned to the Constrain Angle setting, which is normally set to 0 degrees. 

However, sometimes you’ll want to draw your document on a specifi c angle, 

and changing the Constrain Angle preference affects all tools and modifi er 

keys in Illustrator.

Corner Radius. When you’re creating a shape with the Rounded Rectangle 

tool, this setting defi nes the default corner radius for the rounded corners. 

This preference sets the default behavior, which you can easily override on 

a per-object basis in the Rounded Rectangle tool dialog box.

Disable Auto Add/Delete. Illustrator tries its best to help you get your 

work done, but sometimes its overzealousness gets in the way. By default, 

when you move your pointer over an existing path with the Pen tool, 

Illustrator thinks you want to add a point to the existing path and con-

veniently switches to the Add Anchor Point tool. This is great, unless, of 

course, you wanted to start drawing a new path with the Pen tool. Turning 

this preference on politely tells Illustrator, “Thanks but no thanks.”

Use Precise Cursors. Some tool icons in Illustrator are cute, such as the 

Symbol Sprayer and Smudge tools, but they can be hard to position pre-

cisely. Even with the Pen tool, it can be hard to know exactly where the real 

tip of the pointer is. When Use Precise Cursors is active, all pointers are 

replaced by a simple X icon, which clearly defi nes the spot you’re clicking. 

You can toggle this setting by pressing the Caps Lock key on your keyboard.
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Show Tool Tips. Illustrator has a lot of icons—tiny chicklet icons, as we 

like to call them. Sometimes it’s hard to know what a tool or button is just 

by looking at it, so if you hold your pointer over the icon for a second, a 

little window pops up identifying the name of the feature. These are called 

tool tips, and they are turned on by default. Although they are helpful, some 

people think they get in the way, which is why this preference lets you dis-

able tool tips.

Anti-aliased Artwork. Computer screens are low-resolution devices 

(generally between 72 and 130 ppi), so artwork may appear jagged onscreen. 

This is especially true with the sharp vector shapes you create with Illustrator. 

Although the fi les print fi ne, looking at jagged artwork all day may cause 

eyestrain and doesn’t accurately display the way the graphics will eventually 

print. This option (on by default) applies antialiasing to the Preview mode 

so your art onscreen appears clean and smooth. Antialiasing is always turned 

off in Outline view mode. Note that this setting affects how the art appears 

onscreen only and does not in any way affect how the art prints.

Select Same Tint %. Illustrator has a feature that allows you to select all 

objects that are fi lled or stroked with the same color. When you use this 

feature, all objects fi lled with tint percentages of that same color are also 

selected. This preference setting selects only those objects that are fi lled 

with the same tint percentages of that color (resulting in fewer objects 

being selected).

Append [Converted] Upon Opening Legacy Files. When you open fi les 

that were created in previous versions of Illustrator (what Illustrator refers 

to as legacy fi les), you may have to adjust text objects. To prevent you from 

accidentally overwriting your original fi les, Illustrator tacks on the word 

[converted] to your fi le name when it opens legacy fi les. For more informa-

tion about text and legacy fi les, see Chapter 8, “Working with Typography.”

Double Click To Isolate. On by default, this option makes it possible to 

double-click an object to isolate it for editing. With this option turned off, 

you can still isolate a selection, but you have to either select Enter Isolation 

Mode from the panel menu in the Layers panel or click the Isolate Selected 

Object icon on the Control panel.

Use Japanese Crop Marks. Illustrator allows you to create simple crop 

marks automatically by choosing Effect > Crop Marks. If you want 
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something more than the standard marks, you can turn on this preference. 

At the very least, people who see your fi les will know you’re serious about 

crop marks.

Transform Pattern Tiles. When you apply transformations (such as Scale 

or Rotate) to objects that are fi lled with patterns, the default behavior is that 

only the shape is transformed, not the pattern fi ll. Turning this preference 

on changes the default behavior so that pattern fi lls are transformed as well. 

Note that this preference sets the default behavior, which you can easily 

override as you need to by using the setting in the Scale tool dialog box or 

by pressing the tilde key (~) during a manual transform function.

Scale Strokes & Effects. Similar to patterns, when you apply scale transfor-

mations to objects that have strokes or effects applied, the default behavior is 

that only the shape is transformed, not the strokes or the effects. Turning 

this preference on changes the default behavior so that strokes and effects 

are transformed as well. Note that this preference sets the default behavior, 

which you can easily override as you need to by using the setting in the 

Scale tool dialog box.

Use Preview Bounds. One of the benefi ts of using Illustrator is that you 

can be extremely precise when drawing objects. The Control, Transform, 

and Info panels all provide exact feedback on coordinates, positioning, sizing, 

and more. By default, these panels use the actual vector path to determine 

these numbers, not the visual boundaries of the object. For example, you 

may have a shape that has a thick stroke or a scale effect applied to it, which 

is not represented in the value you see in the Transform panel. With the Use 

Preview Bounds preference activated, all panels use the visual boundary of 

a fi le as the value, not the underlying vector path.

Reset All Warning Dialogs. Throughout the daily use of Illustrator, 

you’ll no doubt meet a variety of warning dialog boxes. Sometimes these 

are helpful, and sometimes they can be quite annoying and you’ll wish bad 

things upon them. You’ll fi nd that most of these dialog boxes contain a 

“Don’t show again” check box, which you can use to tell Illustrator that a 

simple beep would be just fi ne, thank you. Clicking Reset All Warning 

Dialogs brings back any warning dialog boxes that you asked Illustrator 

not to show again.
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THE SELECTION & ANCHOR
DISPLAY PANEL
If you’re having trouble selecting individual anchor points or if you are 

coming from Macromedia FreeHand and are used to seeing anchor points 

and control handles displayed a bit differently, the Selection & Anchor 

Display panel in Preferences is for you (Figure A.2). The Object Selection 

by Path Only setting, which at one time appeared in the General panel, 

now appears here.

Tolerance. The Tolerance setting determines how close your pointer has to 

be to an object in order to select it. Using a lower number means you’ll have 

to position your pointer perfectly in order to make a selection (good for very 

precise work where there are many anchor points within a small area), while 

higher numbers allow for faster and easier selections.

Object Selection by Path Only. When working in Preview mode, 

Illustrator allows you to select an object by clicking its path or anywhere 

within its fi ll area (if it has a fi ll attribute applied). Although this is conve-

nient, sometimes—especially when you’re working with complex artwork—

this behavior makes it diffi cult to select objects. Turning this preference on 

allows you to select objects only by clicking their paths, not their fi lls.

Snap to Point. As you drag objects around the page, you’ll notice that your 

pointer snaps to the anchor points of other objects and to guides as well. 

Figure A.2 The Selection 
& Anchor Display panel in 
Preferences enables you to 
control settings used when 
you select and edit paths.
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The Snap to Point value determines how close your pointer has to be to 

another object in order for it to snap to it.

Anchors. Illustrator offers three ways to display anchor points. The differ-

ence between each size may be subtle here, but this setting can help make 

Illustrator seem more familiar to FreeHand users.

Handles. Illustrator offers three different ways to display control handles. 

The difference between each of the three may be subtle, but this setting can 

mean all the difference to those who might be used to seeing handles in a 

different way, as in FreeHand.

Highlight anchors on mouse over. On by default, this setting highlights 

anchor points as you mouse over them. This happens even if the objects are 

not selected. They can be either very helpful, such as when you’re editing 

paths, or very annoying, which explains the preference setting.

Show handles when multiple anchors are selected. In previous versions 

of Illustrator, you were able to see only the control handles of one anchor 

point or path segment at a time. With this preference turned on, you can 

view control handles even with multiple anchor points selected. Note that 

you edit only one control handle at a time.

THE TYPE PANEL
Illustrator has a variety of preference settings that apply specifi cally to work-

ing with typography and text (Figure A.3).

Figure A.3 The Type panel 
in Preferences enables you 
to activate the WYSIWYG 
(what you see is what you 
get) Font menu.
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Keyboard shortcut increments. Keyboard shortcut junkies know they 

can perform a variety of tasks without ever reaching for the mouse. This 

is never truer than when you are working with type, when your hands are 

already on the keyboard. Therefore, you can set the keyboard increments 

for changing size/leading, baseline shift, and tracking here.

Type Object Selection by Path Only. Similar to the Object Selection by 

Path Only setting, this one refers to text objects only. With this preference 

on, you can select a text object by clicking only its baseline.

Show Asian Options. Illustrator is extremely popular in Japan and in other 

Asian countries; therefore, it has some features, such as Warichu, Kinsoku, 

Mojikumi, Tsume, Aki, and composite fonts, that are used specifi cally in 

those locales. These features are hidden from view by default, but turning 

this preference on makes them visible in the user interface.

Show Font Names in English. When working with foreign or non-English 

fonts, you can use this option to specify that the fonts are listed in the Font 

menu using their English names.

Number of Recent Fonts. As you work, Illustrator takes note of the fonts 

you use and puts copies of them at the top of your Font menu. When you 

have hundreds of fonts installed, this is easier than scrolling through an 

entire list to fi nd a particular one. You can have Illustrator track anywhere 

from 1 to 15 of the most recent fonts you’ve used. If you need more than 15 

recent fonts, you might want to look into taking a course in graphic design.

Font Preview. Illustrator has a WYSIWYG Font menu that allows you to 

preview what each font looks like directly within the scrolling Font menu. 

You can choose between Small, Medium, and Large preview sizes. There 

is a slight performance hit that comes with using this feature, and this pref-

erence setting can enable or disable the preview altogether. One valuable 

aspect of the font preview is that it also displays an icon indicating whether 

a font is TrueType, PostScript, Multiple Master, or OpenType.

Enable Missing Glyph Protection. Turning this setting on gives Illustra-

tor the ability to substitute a glyph or a character where the desired glyph is 

not available (because either the current font or the font you just switched to 

doesn’t support that glyph).

Use Inline Input for Non-Latin Text. Some operating systems support 

non-Latin languages by forcing you to enter text into a separate system-level 

dialog box. Turning this option on will allow you to set such text directly in 

Illustrator.
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THE UNITS & DISPLAY
PERFORMANCE PANEL
How do you measure performance? You won’t fi nd the answer here, but you 

will fi nd settings for how your rulers appear and how to speed up screen 

redraw (Figure A.4).

Units. Illustrator can use different measurement systems for different uses. 

These preferences let you specify default measurements for general items 

(rulers and coordinates, sizes and values for objects and drawing tools, and 

so on), stroke width and dash settings, and Roman and Asian type specifi ca-

tions (size, leading, and so on). Note that these are all used to set the default 

measurements in Illustrator, but at any time you can always enter a value 

to have Illustrator do the conversion for you. So if your document is set 

to inches, you can still specify a 4p9 rectangle (see the next paragraph for 

information about such measurements).

Numbers Without Units Are Points. When you’re using picas and points, 

the standard notation is to enter the number of picas, the letter p, and the 

number of points (such as 12p6). If your value is only points, you enter 

something like p6 to indicate 6 points instead. With this option turned on, 

simply typing 6 means 6 points (as opposed to 6 picas).

Figure A.4 The Units & 
Display Performance panel 
in Preferences lets you easily 
switch between a variety of 
measurement settings.
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Identify Objects By. Illustrator has the ability to generate templates with 

XML-based variables, which are useful for generating graphics fi les auto-

matically using scripts or the Adobe Graphics Server (a separate server-based 

product). Some of these templates require that all variables be defi ned using 

valid XML names. By default, Illustrator uses the object name to defi ne vari-

ables, but you can specify that Illustrator should use valid XML IDs instead.

Display Performance. Do you have an ancient video card in your com-

puter? Or are your fi les so complex that even the fastest of computers begs 

for mercy when trying to redraw your screen? The Hand Tool slider allows 

you to dial in the performance you need when scrolling with the Hand tool. 

With the slider closer to Full Quality, your graphics will look better while 

scrolling, at the expense of a slower redraw. You can drag your slider toward 

Faster Updates for better performance, but you won’t get great-looking art 

until you let go of the mouse button after scrolling.

THE GUIDES & GRID PANEL
Illustrator allows you to defi ne guides, which you drag out from either the 

horizontal ruler or the vertical ruler (View > Show Rulers). These guides 

act like magnets, helping you draw or position elements on your page. 

In reality, you can turn any vector shape into a guide by selecting it and 

choosing View > Guides > Make Guides. Additionally, Illustrator has a 

grid feature that makes your artboard appear almost as if it were a sheet of 

graph paper. Objects can snap to this grid, making it easy to visually align 

items in a layout.

You set the appearance of guides and the grid using the Guides & Grid 

panel in Preferences (Figure A.5). Some people prefer solid lines for guides, 

whereas others prefer dotted lines. You can also choose the color used for 

the guides. Additionally, you can set the number of grid lines and subdivi-

sions that appear in the grid. For example, a web designer might specify a 

grid line at every 10 pixels with 10 subdivisions, which would make it pos-

sible to zoom in and view artwork on a pixel-by-pixel basis.
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THE SMART GUIDES PANEL
In addition to normal guides, Illustrator has a useful feature called smart 

guides; these guides offer a variety of pointer feedback options while you 

work. You can activate this feature by choosing View > Smart Guides. 

The Smart Guides panel allow you to control the behavior of this feature 

(Figure A.6).

Figure A.5 The Guides & 
Grid panel in Preferences 
lets you change the color 
and appearance of grid 
lines.

Figure A.6 The Smart 
Guides panel controls the 
settings for the useful smart 
guides feature.
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Aside from choosing the color in which smart guides appear, the Display 

Options section of the Smart Guides preferences panel lets you enable or 

disable any of the six kinds of smart guides.

Alignment Guides. Alignment guides appear when you move your cursor; 

they help you align objects in context while drawing, moving, or editing 

objects. In this way, you don’t have to perform additional align functions.

Object Highlighting. Object highlighting identifi es the underlying Bézier 

paths or original text or artwork when you mouse over objects that have live 

effects or envelopes applied to them.

Transform Tools. Transform tools are guides that appear when using any 

of transform functions in Illustrator, such as Rotate or Scale.

Construction Guides. Construction guides appear as you’re drawing new 

shapes and identifying similar planes or angles with other objects. You can 

specify which angles are identifi ed using the pop-up list, or you can choose 

Custom Angles and specify up to six custom angles.

Anchor/Path Labels. Anchor/path labels identify anchor points and paths 

as you mouse over them.

Measurement Labels. Measurement labels help you identify the dimen-

sions of objects as you draw them.

The Snapping Tolerance setting at the bottom of the panel allows you to 

specify how close your cursor needs to be to an object for smart guides 

to kick in. Smart guides are covered in detail in Chapter 1, “Creating and 

Managing Documents.”

THE SLICES PANEL
When creating art for the web, you can use web slicing to assist in optimiz-

ing your images. The Slices panel offers settings for how the slice regions 

are displayed on your screen (Figure A.7). In Preferences, you can defi ne 

how these slices are indicated on the Illustrator artboard.
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THE HYPHENATION PANEL
Straightforward in its implementation, the Hyphenation panel in Preferences 

allows you to choose the default language (which you can override by using 

the pop-up list in the Character panel) and hyphenation exceptions; it also 

allows you to add new words to the dictionary (Figure A.8).

Figure A.7 The Slices 
preferences panel.

Figure A.8 The 
Hyphenation panel in 
Preferences lets you add 
new words to the diction-
ary in Illustrator for better 
hyphenation.
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THE PLUG-INS & SCRATCH
DISKS PANEL
From an architectural standpoint, Illustrator has a core engine, and the rest 

of the application is built using plug-ins, which are stored in the Plug-ins 

folder. Additionally, third-party plug-ins such as MAPublisher and CAD-

tools are stored in this folder. The Additional Plug-ins Folder preference 

allows you to also specify additional folders where plug-ins might be stored 

(Figure A.9).

Just as you did in math class, Illustrator uses a scratch pad to save work 

while performing normal functions. Sometimes, in really complex fi les, 

Illustrator may need a lot of space. You can specify a hard drive or volume 

that Illustrator should use as a scratch disk to perform these functions. By 

default, your startup disk is your scratch disk, but you can change to a disk 

with more free space if you’d like. You can also specify a second scratch 

disk should Illustrator ever run out of room on the fi rst one.

THE USER INTERFACE PANEL
Illustrator contains a panel-based user interface that is consistent with other 

components of the Adobe Creative Suite 4 family. The User Interface panel 

in Preferences lets you confi gure how the user interface looks and how it 

works when you use it (Figure A.10).

Figure A.9 The Plug-ins 
& Scratch Disks panel in 
Preferences lets you specify 
multiple disks for memory-
intensive operations.
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Brightness. Some people work in a brightly lit studio, while others work 

in dark or dimly lit rooms. People who do certain types of work, such as 

video or prepress production, may also prefer to work in darker environments 

so that they can better focus on their work. In these dark environments, the 

panels in the interface can be bright enough to be a distraction. To allow 

these users to better focus on the art on their screens, the user interface has 

a Brightness slider. Sliding the triangle to the right will make the back-

grounds in the panels brighter; sliding the triangle to the left will result in 

a dark gray background in the panels.

Auto-Collapse Icon Panels. When a panel is collapsed, you can click its 

icon to open the panel as you need it. With the Auto-Collapse Icon Panels 

setting turned on, a panel will return to its collapsed, iconic state after 

you’ve clicked elsewhere on your screen. Turning the setting off means 

a panel will stay open and return to its collapsed, iconic state only if you 

click its icon again.

Open Documents As Tabs. The user interface in Illustrator allows docu-

ments to be displayed as individual windows or as tabs in a single overall 

window. This setting lets you enable or disable the tabs feature.

Figure A.10 The User 
Interface panel in 
Preferences lets you control 
settings for how the new 
CS4 interface looks and 
works.
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THE FILE HANDLING & 
CLIPBOARD PANEL
The File Handling & Clipboard panel includes settings for how Illustrator 

handles certain fi les as well as settings for how art is copied to the clipboard 

for pasting into other applications (Figure A.11).

Use Low Resolution Proxy for Linked EPS. When you place-link an 

EPS fi le into Illustrator, whether it is an Adobe Photoshop CS4 EPS fi le or 

any other generic EPS fi le, the preview that’s displayed on your screen can 

be either the low-resolution preview that’s embedded in the EPS fi le or a 

high-resolution version that Illustrator parses from the PostScript data in 

the actual EPS fi le. By default, Illustrator ships with this preference setting 

turned off, so a high-resolution fi le is used, resulting in a much better-

looking preview on your screen. In addition, this high-resolution data is 

used when exporting your fi le in pixel-based formats (PSD, TFF, JPEG); 

however, screen redraw is slower, and the fi le size increases. On a separate 

note, when you’re using the Live Trace feature with place-linked EPS fi les, 

the resolution of the image that Live Trace can detect depends on this 

setting as well. When the option is selected, Live Trace sees the 72 ppi 

preview fi le and traces that. By turning this setting off, Live Trace can 

detect the full resolution of the fi le and use it to trace the image.

Figure A.11 The File 
Handling & Clipboard panel 
in Preferences allows you 
to determine how graphics 
are copied and pasted into 
other applications.
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Update Links. When you place-link a fi le into Illustrator, the Links panel 

maintains the link information about that fi le. Because the fi le is external, 

you can edit that fi le easily by using the Edit Original feature, found in 

either the Links panel or the Control panel. When the default Ask When 

Modifi ed setting is used, if you edit a linked fi le outside Illustrator and 

return to the Illustrator document, you’ll get a dialog box telling you that 

the fi le was updated, with an option to update the link. Alternatively, you 

can choose to manually update links yourself through the Links panel, or 

you can set Illustrator to automatically update all links as they happen.

Clipboard on Quit. Today’s modern operating systems use an effi cient 

method to copy and paste data using the system’s clipboard, called promising.

Rather than copy art in a variety of formats to the clipboard (which would 

take time), applications promise to deliver art when pasted. Then, when you 

paste the art, the operating system goes back to the application you copied 

from and gets the data. The problem is, if you’ve quit the program since you 

performed the copy function, the operating system can’t fulfi ll its promise. 

So when you quit an application, it copies whatever was promised to the 

clipboard (which explains why sometimes it takes a while for an application 

to actually quit). The Clipboard on Quit preference allows you to deter-

mine which fi le formats are used to copy art to the clipboard when you quit 

Illustrator. By default, both the PDF and the Adobe Illustrator Clip Board 

(AICB) options are selected, which gives you the most options. Unless you 

have a specifi c reason, we suggest you leave both of these selected at all 

times. In general, the PDF option supports native transparency and is PDF 

1.6, whereas the AICB is fl attened data and is PostScript.

THE APPEARANCE OF BLACK PANEL
In an effort to display graphics on your screen or proofs that closely match 

what you will see on a printed sheet, Illustrator includes a setting specifi -

cally for how the color black is displayed or printed (Figure A.12). You 

can choose to have your blacks display accurately, in which case black will 

appear closer to a dark gray color (closer to what you might see on news-

print), or you can choose to display rich blacks, in which case your blacks 

will be much darker. Note that these settings are not color management 
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settings and don’t affect your fi nal separated output. These settings affect 

only your screen display or output to an RGB device.

Figure A.12 The 
Appearance of Black panel 
in Preferences allows you to 
achieve more accurate color 
results on your screen.
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text, 270–271

text to path, 274

alpha channels, 302

Ambient Light setting, 350

Analyze Documents, 313

anchor points

adding/deleting, 83

Join and Average commands, 
88–89

mesh points and, 128

Selection and Anchor Display 
panel, 540–541

setting display preferences, 
30–31

simplifying vector paths, 
90–91

working with Pen tool, 72–82

anchor/path labels

defi ned, 22

smart guide preferences, 546

Angle setting

3D Revolve Options, 358

Calligraphic Brush Options, 
110

Gradient panel options, 179

Scribble Options, 240

Angle Threshold, 91

Animate Blends setting, 491–492

animations

exporting SWF fi les, 445–446

with layers, 155

SWF Options, 491–492

transitions with blends, 61–62

web and mobile design, 
439–441

antialiasing

artwork, 538

defi ned, 417

Document Raster Effects 
Settings, 224

pixel grid and, 420–426

PNG fi les, 486

Rasterize options, 408

Numbers
3D (three-dimensional), 

333–374

3D Revolve effect, 357–364

3D Rotate effect, 365

adding transparency to, 
371–373

applying to graphs, 374

blends, 373–374

editing effect, 340

Extrude & Bevel effect. see
Extrude & Bevel effect

fi lls and strokes with effect, 
337–340

in Illustrator, 334–335

looking inside effect, 336–337

mapping artwork to surfaces, 
366–368

mapping artwork with 
symbols, 289

overview, 333

specifying mapped artwork, 
368–371

A
Absolute Colorimetric setting

Color Management options, 
512

defi ned, 215

Absolute shapes setting, 226

Acrobat and PDF compatibility, 
465–466

actions

cleaning messy fi les, 312–313

recording and playing, 310–
311

active artboards, 10–12

Add Arrowheads effect, 236–237

Add X Around Object setting

Document Raster Effects 
Settings, 224

Rasterize options, 408

adding

anchor points, 83

attributes, 139–141

Disable Auto Add/Delete 
setting, 537

live effects, 146

objects to text thread, 269

Adjust Color Balance setting, 211

Adjusted Image setting, 394

Adjustments tracing settings, 
398–400

Adobe Acrobat and PDF 
compatibility, 465–466

Adobe Bridge, 25

Adobe Device Central, 447–449

Adobe Fireworks, 426

Adobe Flash Catalyst, 451

Adobe Integrated Runtime (AIR), 
450

Adobe Kuler

coloring graphs, 326–327

defi ned, 195–197

Adobe Photoshop. see Photoshop

Adobe PostScript setting, 461

Adobe Reader

fi le saving, 462–463

overprints and handling 
transparency, 534

Adobe Single-line Composer vs. 
Every-line Composer, 265

Adobe Swatch Exchange, 176

Advanced Print panel, 512

ai (Adobe Illustrator fi les), 
433–458

AIR (Adobe Integrated Runtime), 
450

AIT (Adobe Illustrator Template), 
24

aliases, 284

alignment

guides, 22

objects, 45–47

smart guides, 546

strokes, 187
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exporting PSD fi les, 410

graphic styles, 307–309

importing PSD fi les, 411–412

loading with Eyedropper tool, 
147

working with groups, 147–152

auto slices, 427

AutoCAD fi le exporting, 488–489

Auto-Collapse Icon Panels 
setting, 549

automatic glyph replacement, 257

automation

effi cient drawing with, 309–
312

when releasing fi nal fi les, 
312–314

Average command, 88–89

B
backgrounds

applying Convert to Shape, 
226–228

confi guring Layers panel, 158

Document Raster Effects 
Settings, 223–224

Rasterize options, 408

SWF color options, 491

backward compatibility, 278–282

banding, 351

bar graphs, 318–319

barbell, exercise, 361–364

basic appearance, 139

Bevel effect. see Extrude & Bevel 
effect

Bevel joins, 186–187

Bitmap (BMP) fi les

exporting, 485

printing as, 512

Blatner, David, 379

bleed

adding, 16

document set-up, 8–9

Marks and Bleed Print panel, 
505–506

PDF saving, 472

settings, 5

area of infl uence, 293

Area Type

defi ned, 250

text objects, 251–252

working with, 267–271

arrowheads, adding, 236–237

Art brush

defi ned, 108

defi ning, 113–114

artboards

aligning to, 47

FXG Options, 478–479

legacy workfl ow and, 17

modifi cation, 13–16

navigation, 12–13

saving and exporting, 484

strategies, 18

artwork, 27–66

aligning objects, 45–47

alternative selection 
techniques, 33–35

antialiasing and, 425–426

bring to Flash, 444

coloring. see coloring artwork

Direct Selection tool, 31–32

distributing objects, 47–49

Envelope distortion, 52–60

Group Selection tool, 32

Liquify tools, 49–51

mapping. see mapping artwork

overview, 27

Pathfi nder panel, 41–45

selecting objects, 28–29

setting preferences, 30–31

transformations, 35–41

transitions with blends, 60–66

turning into symbol, 284

Artwork Bounding Box setting, 
17

Aspect Ratio setting, 179

Assign tab, 204–208

attributes

Appearance panel, 134–142

applying transparency to 3D, 
372

Attributes panel, 439–440

editing slice, 430

Appearance of Black panel, 
551–552

appearances

defi ning opacity masks, 
302–303

distorting, 58

editing 3D, 340

enhancing with live effects, 
142–147

exporting SWF fi les, 445

Extrude and Bevel surface 
settings, 348–351

FXG Options, 480

graphic styles and, 307–309

live effects. see live effects

putting it all together, 163

understanding, 134–142

using layers and, 160–162

Append [Converted] Upon 
Opening Legacy Files  
 setting, 538

AppleScript, 312

application preferences, 535–552

Appearance of Black panel, 
551–552

File Handling & Clipboard 
panel, 550–551

General panel, 536–539

Guides & Grid Panel, 544–545

Hyphenation panel, 547

overview, 535

Plug-ins & Scratch Disks 
panel, 548

Selection and Anchor Display, 
30–31

Selection and Anchor Display 
panel, 540–541

Slices panel, 546–547

Smart Guides panel, 545–546

Type panel, 541–542

Units and Display Performance 
panel, 543–544

User Interface panel, 548–549

Apply icon graphing options, 322

Apply Last Effect setting, 220

Arc tool, 70–71

area graphs, 318, 320
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color bars

defi ned, 505

recoloring with Edit tab, 202

Color Guide panel

defi ned, 189–193

limiting, 194–195

web-safe colors, 418–419

Color Handling setting, 511

color harmony rules

Color Guide panel, 190

defi ned, 192–193

color management

printing, 511–512

settings, 214

Color Model setting

Document Raster Effects 
Settings, 222–223

Rasterize options, 407

color modes

CMYK or RGB, 6–7

settings, 5

color of the type, 265

Color panel, 166–167

Color Picker, 208

color rows, 205–206

Color setting

GIF fi les, 434

Layers panel, 157

color stops, 180

Color Table panel, 437

color-blindness, 216

coloring

3D objects, 351

Appearance of Black panel, 
551–552

Bitmap fi les, 485

with Blob Brush tool, 122

dithering, 416–417

Gradient Mesh tool, 127–129

graphs, 326–328

with Live Paint, 94–102

overprints, 528–534

PDF output settings, 473

placed images, 380–381

PNG fi les, 486

Save for Web & Devices, 433

characters

defi ned, 152

displaying invisible, 277

encoding, 253–254

text styles, 266

typography, 261–265

charts vs. graphs, 316

Chavez, Conrad, 379

cheaper color, 171

Check Spelling dialog box, 
277–278

CID (Character IDentifi er) fonts, 
261

clean-up

Clean Up feature, 92

messy fi les, 312–313

Clip Content to Active Artboard 
setting, 479

Clipboard on Quit setting, 551

Clipboard panel, 550–551

clipping masks

creating, 224

defi ned, 298–300

vs. opacity masks, 306

organizing masking with layer, 
300–302

Rasterize options, 408

working with placed images, 
380–381

closed paths

aligning strokes, 187

drawing with Pen tool, 76–77

Eraser tool, 125–126

Offset Path function, 89–90

putting type on, 273

shape tools, 68–69

CMYK (cyan, magenta, yellow, 
and black)

Book Color, 217–218

Color Management options, 
512

coloring artwork, 166

EPS Options, 461

process colors, 170

proofi ng colors, 215

RGB or, 6–7

Collect for Output, 313–314

blends

adding to 3D, 373–374

Blend Steps setting, 350–351

SWF Options, 491–492

transitions with, 60–66

Blob Brush tool, 121–124

Blur setting

JPEG fi les, 436

Tracing Options, 400

BMP (Bitmap) fi les

exporting, 485

printing as, 512

Book Color, 217–218

bounding boxes, 36–37

breadcrumbs, 154

Bridge, 25

brightness

Extrude and Bevel surface 
settings, 348–351

recoloring with Edit tab, 
200–203

user interface preferences, 549

browser graphics previewing, 433

brushes. see Paintbrush tool

Brushes setting, 388

Bunting, Fred, 213, 511

Butt caps, 186–187

button exercise, 354–356

C
Calligraphic brush

Blob Brush tool and, 123

defi ned, 106–107

defi ning, 110–111

camera in 3D Extrude and Bevel 
Options, 342–346

Cap setting

3D Revolve Options, 359

stroke options, 186

Cascading Style Sheets (CSS). 
see CSS (Cascading Style 
Sheets)

Cell Style icon, 322

Character IDentifi er (CID) fonts, 
261
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construction guides

defi ned, 22

preferences, 546

containers, 148–150

contents, group, 149

contrast previewing, 216

control handles

defi ned, 74

sizing, 30

Control panel, Live Trace. see
Live Trace

Convert Anchor Point tool, 80

Convert to Artboards dialog 
box, 17

Convert to Shape effect, 225–228

converting to grayscale

defi ned, 208–212

working with Rasterize, 236

copying

between Illustrator and 
Photoshop, 411

permissions, 477

corner anchor point

converting to smooth, 80

defi ned, 74

mapping artwork to 3D, 367

Corner Angle setting, 402

Corner Radius setting, 537

corner rounding, 238–239

corrupt fonts, 254

Create Acrobat Layers from Top-
Level Layers setting, 469

Create Clipping Mask setting

Document Raster Effects 
Settings, 224

Rasterize options, 408

Create PDF Compatible File 
setting, 457

creative drawing

applying brush strokes, 109

brush quartet, 106–108

defi ning Art brush, 113–114

defi ning Calligraphic brush, 
110–111

defi ning Pattern brush, 
114–119

defi ning Scatter brush, 
111–113

modifying artboards, 13

open-path shape tools, 70–71

Outline Stroke, 89

Pathfi nder, 233

scripting, 310

selecting objects, 28

smart guides, 21

switching views, 18

Transform Again feature, 41

viewing artboards, 12

community, Kuler, 195

compatibility. see support

Compatible Gradient and 
Gradient Mesh Printing 
setting, 461

complex appearance

defi ned, 139–141

layers and appearances, 162

with live effects, 143

complex regions

clipping, 521

defi ned, 518

complex shapes, 233–234

Composite setting, 506

compound paths, 85–87

compound shapes, 43

compression

defi ned, 419

exporting JPEGs, 492–493

Illustrator fi le format options, 
458

JPEG fi les, 435–436

PDF fi les, 470–471

PNG fi les, 436

TIFF fi les, 495

computer screens

resolution, 421

viewing color on, 213–218

web-safe colors, 418–419

computer-aided design (CAD) 
fi les, 488–489

computers, Mac. see Mac 
computers

conditioning raster-based images, 
389–392

consistent color, 171

Constrain Angle setting, 537

coloring (continued)

specifying separations, 507–
509

Symbol Stainer tool, 295

Tracing Options, 398–400

web-safe, 418–419

coloring artwork, 165–218

applying fi lls, 178–185

applying strokes, 186–189

Assign tab, 204–208

Color Guide panel, 189–193

Color panel, 166–167

converting to grayscale, 
208–212

Edit tab, 200–204

with fi lls and strokes, 177–178

Kuler, 195–197

libraries, 175–177

limiting Color Guide panel, 
194–195

one-click color fi xes, 213

overview, 165

recoloring artwork, 198–199

Swatches panel, 167–174

viewing on screen, 213–218

Colorization setting

Art Brush Options, 114

Pattern Brush Options, 116

Scatter Brush Options, 112

Colorize Method setting, 207

Colors setting, 207

columns

graphs, 318–319

transposing, 322

combination points

creating, 81–82

defi ned, 74

combining shapes, 42–44

commands

bounding boxes, 36–37

Clean Up, 92

closed-path shape tools, 69

collecting necessary support 
fi les, 313–314

Convert to Grayscale, 210

Direct Selection tool, 31

Join and Average, 88–89
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dialog boxes (continued)

EPS Options, 460–462

Eraser Tool Options, 126

Filter Gallery, 248

Find Font, 260–261

FXG Options, 478–480

Gap Options, 99

Graph Type, 324

Illustrator Options, 456–458

JPEG Options, 492–493

Layer Options, 382

Map Art, 368–371

Move, 35

new documents, 4–7

opening legacy fi les, 279–280

Paragraph Style Options, 266

Pattern Brush Options, 115, 
119

Pencil Tool Options, 104

Photoshop Export Options, 
494

Photoshop Import Options, 
379–380

Place, 377

Placement Options, 385–386

PNG Options, 486

Print. see printing

Proof Setup, 215

Rasterize, 235, 406–408

Recolor Artwork. see
recoloring artwork

Recolor Options, 206

Reset All Warning Dialogs 
setting, 539

Save Adobe PDF. see PDF 
(Portable Document 
Format) fi les

Save for Web & Devices, 430–
438, 445–447

Scatter Brush Options, 111

Scribble Options, 240

Shape Options, 226

Simplify settings, 91

Slice Options, 430

SVG Options, 480–483

Swatch Options, 169

SWF Options, 489–492

Decimal Places setting

exporting SVG fi les, 447

SVG Options, 482

Default Actions set, 310–311

deleting

anchor points, 83

brushes, 119

Disable Auto Add/Delete 
setting, 537

vs. masking, 297

objects from text thread, 269

unused elements before 
printing, 312–313

depth settings, 346

desaturating art, 210–211

design, web and mobile. see web 
and mobile design

Deuteranopia, 216

devices

Adobe Device Central, 447–
449

mobile design. see web and 
mobile design

SVG fi lters, 243–244

viewing color on, 214–216

dialog boxes

3D Extrude and Bevel 
Options. see Extrude & 
Bevel effect

3D Revolve Options, 357–364

3D Rotate Options, 365

Add Arrowheads, 237

Art Brush Options, 113

Artboard Options, 14–15

Blend Options, 63–64

Blob Brush Tool Options, 123

Calligraphic Brush Options, 
110

Check Spelling, 278

Color Settings, 214

Convert to Artboards, 17

Document Raster Effects 
Settings, 222–225

Drop Shadow, 144

DXF/DWG Options, 488

Edit Colors, 174

Envelope Options, 57

drawing and erasing, 121–126

expanding brush art, 120

Flare tool, 129–130

Gradient Mesh, 127–129

Live Paint, 94–102

modifying brush strokes, 119

overview, 93

Pencil tool, 102–105

Crop Areas setting, 17

Crop Marks

live effects, 228–229

Use Japanese Crop Marks 
setting, 538–539

Crop pathfi nder, 44

cropping with masks, 298

Crystallize tool, 50

CSS (Cascading Style Sheets)

with layers, 155

Save for Web & Devices image 
settings, 438

SVG fi les, 447

SVG Options, 482

cursors

Selection and Anchor Display, 
30

Use Precise Cursors setting, 
537

Curve Precision, 91

Curve Quality setting, 491

curved paths

drawing straight and, 79–80

drawing with Pen tool, 77–79

Curviness setting, 241

custom dashes, 188–189

custom libraries, 194–195

custom views, 23

cyan, magenta, yellow, and black 
(CMYK). see CMYK (cyan, 
magenta, yellow, and black)

D
darkness settings, 348–351

dashed strokes, 188–189

data, drawing with. see drawing 
with data
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understanding appearances, 
134–142

working with groups, 147–152

drawing with data, 315–332

applying 3D to graphs, 374

combining graph types, 
330–332

creating graphs, 317–323

customizing graphs, 323–329

graph anatomy, 316

overview, 315

raising bar with graphs, 
329–330

drawing with effi ciency, 283–314

automation, 309–312

automation when releasing 
fi nal fi les, 312–314

clipping masks, 298–300

graphic styles, 307–309

layer clipping masks, 300–302

masking, 297–298

opacity masks, 302–306

overview, 283

symbolism tools, 289–297

symbols, 284

symbols and instances, 284–
289

drawing, 3D. see 3D (three-
dimensional)

drawing, creative. see creative 
drawing

drawing, technical. see technical 
drawing

Drip Dot Swirl (Glitschka), 185

Drop Shadow

adding to group, 148–150

applying, 143–146

raster-based effects, 221–222

Stylize effects, 236

DTD (document type 
defi nition), 446, 480

dual-path fi les, 454

DWG (AutoCAD Drawing) fi les, 
488–489

DXF (AutoCAD Interchange) 
fi les, 488–489

Document Ink Options, 508

Document Open Password, 476

Document Profi le setting, 511

Document Raster Effects Settings

dialog box, 222–225

mapping artwork to 3D, 368

Document setting, 388

document type defi nition 
(DTD), 446, 480

documents

artboard and legacy 
workfl ow, 17

artboard modifi cation, 13–16

creating new, 3–7

exporting. see exporting

meaningful metadata, 25–26

multiple artboard strategies, 18

multiple artboards, 10–12

navigation, 12–13

overview, 1

profi les, 7–8

saving. see saving

set-up, 8–10

templates, 24–25

viewing, 18–23

welcome screen, 2

Double Click To Isolate setting, 
538

downloading

font subsets, 510

optimization with slicing, 
426–427

downsampling

Downsample Linked Images 
setting, 479

PDF compression settings, 
470–471

drawing objects

Pathfi nder panel, 41–45

using Preview Bounds, 38

drawing organization, 133–163

isolation mode, 153–154

layers, 154–162

live effects, 142–147

overview, 133

putting it all together, 163

dialog boxes (continued)

Symbol Options, 285, 442–
443

Symbolism Tools Options, 
296

Tracing Options, 397–402

Transform Each, 40

Transform effect, 231

updating legacy text in open 
document, 280–281

Warp Options, 244

Diameter setting, 111

Diffuse Shading setting, 349

Dim Images to setting, 158

dimension with 3D Revolve, 
357–364

Direct Selection tool

defi ned, 31–32

drawing with Pen tool, 78

editing clipping masks, 300

Reshape tool and, 84

direction handles

changing path, 81

defi ned, 78

Direction setting, 114

Disable Auto Add/Delete setting, 
537

disabling antialiasing, 426

Discard setting, 512

Display pane, 15

Display Performance, 543–544

distortion

3D Rotate effect, 365

Envelope distortion, 52–60

Liquify tools, 49–51

live effects, 229–232

Warp effect, 244–245

distributing objects

overview, 47–49

transitions with blends, 62

dithering

defi ned, 416–417

GIF fi les and, 434

WBMP fi les, 437

Divide pathfi nder, 44–45

Document Info panel, 388



INDEX 559

FXG Options, 480

Live Paint groups, 100

Live Trace objects, 404

raster-based effects, 221–222

symbol sets, 297

symbols, 286

exploring world of 3D. see 3D 
(three-dimensional)

Export Static Layers setting, 492

exporting

3D geometry, 335

BMP fi les, 485

choosing formats based on 
workfl ow, 495–497

DWG/DXF fi les, 488–489

expanding appearances, 142

fi les from Illustrator, 483–484

to Flash, 440

JPEG fi les, 492–493

with layers, 155

PICT fi les, 493–494

pixel-based images to web, 
430–438

PNG fi les, 485–487

PSD fi les, 409–410, 494

saving and, 453

SWF fi les, 489–492

Targa fi les, 485

text fi les, 495

TIFF fi les, 495

vector-based images to web, 
445–447

WMF/EMF fi les, 489

ExtendScript, 312

Extensible Metadata Platform 
(XMP), 25–26

Extrude & Bevel effect

creating hidden faces, 353

creating photorealistic button, 
354–356

creating visible faces, 352

defi ned, 336

overview, 341–342

Position settings, 342–346

settings, 346–347

spot colors, 351

surface settings, 348–351

Embed Page Thumbnails setting, 
468

embedded images

importing PSD fi les, 411–412

managing, 383–388

place-embedding, 376–378

as symbols, 285

embedding fonts

in Adobe Reader, 463

permissions and, 475

EMF (Enhanced Metafi le) fi les, 
489

Enable Guides for 9-slice scaling 
setting, 443

Enable Missing Glyph Protection 
setting, 542

enclosed areas, 87

encoding

characters, 253–254

SVG fi les, 447

SVG Options, 482

end tiles, 118

ending paths, 76

Enhanced Metafi le (EMF) fi les, 
489

Envelope distortion, 52–60

envelope meshes, 52

EPS (Encapsulated PostScript) 
fi les

preferences, 550

print workfl ows, 495–496

saving, 458–462

saving in, 222

Eraser tool

Blob Brush tool and, 121

using, 124–126

Even-Odd Fill Rule, 86–87

Every-line Composer vs. Single-
line Composer, 265

Exact colorization method, 209

Exclude shape mode, 43

exercise barbell, 361–364

expanding

appearances, 142

blends, 65–66

brush art, 120

envelopes, 60

E
Edit Original button, 384–385

Edit tab, 200–204

editing

3D effect, 340

advanced path, 88–92

artboards, 13–16

artwork. see artwork

blends, 63–65

clipping masks, 299–300

color groups, 173–174

converting text to vectors, 
252–253

Envelope distortion, 58–59

FXG Options, 478–479

gradient fi lls, 181–182

graphic styles, 308–309

graphs, 323–329

live effects, 146–147

Live Trace paths, 402–405

opacity masks, 304–306

with Pencil tool, 105

permissions, 477

recoloring with Edit tab, 
200–204

Save Adobe PDF options, 468

slice attributes, 430

SVG Options, 482

symbols, 287–288

text, 276–278

using Live Paint, 100–102

vector lens fl ares, 132

Effect menu, 220–225

Effect setting, 274

Effects Gallery, 248

effects, 3D. see 3D (three-
dimensional)

effects, live. see live effects

effi cient drawing. see drawing 
with effi ciency

Ellipse tool

creating realistic button, 354

defi ned, 68–69

Embed Fonts setting, 461

Embed ICC Profi les setting, 458

Embed Image setting, 386
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EPS Options, 461

Illustrator fi le format options, 
457

PDF advanced settings, 
474–475

SVG fi les, 446

SVG Options, 481

Type preferences, 542

typography, 254–261

foreign objects, 280

formats

data in Graph Data window, 
322–323

designing for Flash, 441–444

exporting fi les. see exporting

fonts, 254–261

image. see images

optimization with slicing, 427

saving fi les. see saving

web design graphics, 415

web options, 433–437, 445–
447

frames

Area Type, 251–252

Frame Rate setting, 491

Fraser, Bruce, 213, 511

Free Distort effect, 230

free-form vectors

adding/deleting anchor points, 
83

cutting paths, 85

Pen tool, 72–82

reshape tool, 84–85

FreeHand fi les, 17

full page tiling, 504

functions

Adjust Color Balance, 211

aligning objects, 45–47

Links panel, 383–388

Offset Path, 89–90

path effects, 232–233

Pathfi nder panel, 41–45

transformations, 35–41

FXG (Flex Exchange Graphic) 
fi les

defi ned, 450–451

saving, 478–480

converting text to editable 
vectors, 253

Fill Rules, 86–87

with Live Paint, 94–99

paths, 182

Pencil tool, 105

targeting attributes, 138–139

Tracing Options, 400–401

Filter Gallery dialog box, 248

fi lters, SVG, 243–244

Find and Replace, 276–277

Find Font dialog box, 260–261

Fireworks, 426

Flare tool

closed-path shape tools, 68

defi ned, 129–130

Flash

designing for, 441–444

fi le exporting, 489–492

Flash Catalyst, 451

Flash Lite, 448–449

Flash Registration setting, 442

fl attening transparency

overprints and handling 
effects, 531–534

PDF advanced settings, 474

previewing, 523–526

printing, 519–521

printing with confi dence, 
526–527

SWF fi les, 491

transparency, 514–523

Flex Exchange Graphic (FXG) 
fi les

defi ned, 450–451

saving, 478–480

fl exographic printing, 529

Flip setting

Art Brush Options, 114

Pattern Brush Options, 116

Type on a Path Options, 275

focus points, 84

fonts

in Character panel, 261–262

Document Info panel, 388

downloading subsets, 510

embedding, 463

Eyedropper tools

loading attributes with, 147

Save for Web & Devices, 432

F
faces

hidden, 353

transparency to 3D, 372–373

visible, 352

Feather effect

defi ned, 237

Document Raster Effects 
Settings, 224

Fidelity setting

Blob Brush Tool Options, 124

Envelope Options, 57

Pencil tool, 104–105

File Handling & Clipboard panel, 
550–551

File options, 445

fi les

compression, 419

exporting. see exporting

image. see images

legacy. see legacy fi les

saving. see saving

saving Illustrator CS4 fi les 
to Illustrator legacy 
versions, 282

using automation when 
releasing fi nal, 312–314

web format options, 433–437

Fill attribute, 144–146

fi lls

with 3D effect, 337–340

adding, 139–141

applying, 178–185

applying Scribble to multiple, 
242–243

applying transparency to 3D, 
372

coloring artwork with, 
177–178

Convert to Shape effect, 
225–228
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guides, smart. see smart guides

Gutter value, 270

H
Hand tool, 432

handles

bounding boxes, 36–37

Selection and Anchor Display 
options, 541

Height setting

defi ned, 5

Extrude and Bevel, 347

hidden faces

applying transparency to 3D, 
372–373

creating, 353

hierarchy. see stacking order

Highlight anchors on mouse 
over, 541

Highlight Intensity setting, 350

Highlight Size setting, 350

hinting, 252

hollow appearance, 346

hotspots, 439

HSB (hue, saturation, brightness) 
color model, 200–203

HTML (HyperText Markup 
Language) tables, slices as, 
429

hue

colorization method, 209

recoloring, 200–203

hue, saturation, brightness (HSB) 
color model, 200–203

HyperText Markup Language 
(HTML) tables, slices as, 
429

Hyphenation panel, 547

I
Identify Objects By preference, 

543

Ignore Artboards setting, 502

Ignore White setting, 402

The Illustrator CS4 Wow! Book 
(Steuer), 129

graphic images. see images

graphic styles

defi ned, 307–309

Document Info panel, 388

Symbol Styler tool, 295

Graphics Interchange Format 
(GIF) fi les, 433–435

Graphics Print panel, 510–511

graphics, web. see web and mobile 
design

graphs

anatomy, 316

applying 3D to, 374

combining types, 330–332

creating, 317–323

customizing, 323–329

overview, 315

raising bar with, 329–330

grayscale

coloring graphs, 326–328

converting artwork to, 208–
212

grids

antialiasing and pixel, 420–426

Gradient Mesh tool, 127–129

Rectangular Grid tool, 70–71

Split Into Grid feature, 92

groups

applying transparency to 3D, 
372

clipping masks, 298, 300

creating complex shapes with 
Pathfi nder, 233–234

drawing exercise barbell, 
361–364

graph anatomy, 316

Group Selection tool, 32

isolation mode, 153–154

vs. layers, 154

Live Paint, 97–98. see also Live 
Paint groups

organizing your drawing, 
147–152

recoloring, 199

working with color, 172–174

grouting, 405

Guides & Grid Panel, 544–545

G
ganging up, 228

Gap Detection feature

defi ned, 99

Live Paint groups and, 404

Gaussian Blur

Document Raster Effects 
Settings, 224

transforming objects with, 232

General panel preferences, 
536–539

General Print panel, 500–504

geometry, 3D, 352–353

GIF (Graphics Interchange 
Format) fi les, 433–435

Glitschka, Von, 185

Global Adjust setting, 203

Global pane, 15

global process colors

defi ned, 170

vs. process colors, 172

global text support, 253–254

glow effects, 238

glyphs

automatic replacement, 
257–258

defi ned, 255

fi nding, 259

Type preferences, 542

Go to Link button, 384

Gradient Annotator, 182–183

Gradient Mesh

defi ned, 127–129

EPS Options, 461

Gradient Objects setting, 388

Gradient Slider setting, 179–180

Gradient Swatch menu, 179

gradients

3D shading, 351

defi ning opacity masks, 
302–303

EPS Options, 461

fi lls, 178–184

in Swatches panel, 168–169

Transparency Flattener Preset 
Options, 520

Graph Data window, 321–323
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joins

commands, 88–89

setting, 186–187

Joint Photographic Experts 
Group (JPEG)

exporting, 492–493

web format options, 435–436

JPEG (Joint Photographic 
Experts Group)

exporting, 492–493

web format options, 435–436

K
Keep Selected option

Blob Brush Tool Options, 123

defi ned, 105

kerning

defi ned, 262

optical, 263

key objects

aligning to, 46–47

blends, 61

distribution, 47–49

Keyboard Increment setting, 537

Keyboard shortcut increments, 
542

keyboard shortcuts

closed-path shape tools, 69

Color panel, 167

Direct Selection tool, 31

open-path shape tools, 70–71

pathfi nders, 45

selecting objects, 28–29

symbolism tools, 293

keylines, 382

Knife tool, 85

knockouts, 528

Kuler

coloring graphs, 326–327

defi ned, 195–197

L
LAB values, 217–218

labeling

anchor/path, 22

Include CMYK PostScript in 
RGB Files setting, 461

Include Document Thumbnails 
setting, 461

Include Linked Files setting

EPS Options, 461

Illustrator fi le format options, 
458

Include Slicing Data setting, 483

Include Unused Symbols setting, 
479

Include XMP setting, 483

InDesign

defi ned, 18

overprints and handling 
transparency, 534

print workfl ows, 495–496

saving Illustrator fi les, 454–455

infographic, 315

inner corner tiles, 117

Inner Glow effect, 238

In-RIP Separations, 506–507

Inset Spacing setting, 270

instances

defi ned, 284

designing for Flash, 443

symbols and, 284–289

Intensity setting, 296

interactivity, 439–441

interlacing

GIF fi les, 434

PNG fi les, 486

Intersect shape mode, 43

invisible axis, 361–364

invisible characters, 277

invisible geometry, 371

isolation mode

editing symbols, 287

Live Paint, 97

organizing your drawing, 
153–154

J
jaggies, 417

Japanese crop marks setting, 
538–539

JavaScript, 312

Illustrator effects vs. Photoshop 
effects, 246–247

Illustrator Template (AIT), 24

Image Format setting, 491

image maps

importing PSD fi les, 412

web design, 439–440

Image Size panel, 438

images, 375–412

additional settings, 437–438

Adobe Photoshop, 408–412

converting rasters to vectors 
using Live Trace, 
389–392

editing Live Trace paths, 
402–405

exporting. see exporting

getting perfect trace, 397–402

Live Trace preview options, 
394–396

managing placed, 383–388

maximizing quality on web, 
416–419

Object Mosaic, 405–406

overview, 375

placing raster-based fi les, 
376–382

Raster, 236

saving. see saving

SVG Options, 481

symbols. see symbols

tracing, 393

turning vectors into rasters, 
406–408

web format options, 433–437, 
445–447

importing

3D geometry, 335

images from Photoshop, 
411–412

Import Data icon, 321–322

SVG fi lters, 243–244

in ports

putting type on path, 272

text threading, 267–269

Include Adobe Graphics Server 
data setting, 482
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distort and transform, 229–232

overview, 219

Pathfi nder, 233–234

paths, 232–233

Photoshop, 245–248

Rasterize, 235–236

Stylize, 236–243

SVG fi lters, 243–244

Warp, 244–245

working with, 142–147

working with placed images, 
380–381

Live Paint

Blob Brush tool and, 121

drawing with, 94–102

Live Paint Bucket tool, 95–98

Live Paint groups

converting traced images to, 
404–405

releasing/expanding and 
merging, 100

understanding, 97–98

Live Paint Selection tool, 100–
102

Live Trace

converting rasters to vectors 
using, 389–392

editing paths, 402–405

getting perfect trace, 397–402

Live Paint and, 100

preview options, 394–396

tracing images, 393

Local playback security, 491

Location value, 180

Lock setting, 157

locked colors, 200

locked objects, 29

Looping setting, 491

lossless compression

defi ned, 419

PDF settings, 471

TIFF fi les, 495

lossy compression

defi ned, 419

exporting JPEGs, 492–493

PDF settings, 471

web-safe colors, 418–419

licensing, 475

ligatures

defi ned, 255–256

OpenType fonts, 257–258

Light Intensity setting, 350

lighting

adjusting with Position 
settings, 346

Extrude and Bevel surface 
settings, 348–351

mapped artwork, 370–371

Limit to Library setting, 207

line art

PDF compression settings, 
471

Transparency Flattener Preset 
Options, 520

line graphs, 318, 320

Line Segment tool, 70–71

linear gradients

distorting, 58

widget, 183

Link File Info function, 386

linked images

FXG Options, 479

managing, 383–388

place-linking, 376–378

preferences, 551

symbols and, 285

linking text boxes, 267

Links panel, 383–387

Liquify tools, 49–51

Live Color

converting art to grayscale, 
208–212

defi ned, 198

one-click color fi xes, 213

recoloring with Edit tab, 
200–204

live effects, 219–248

3D. see 3D (three-dimensional)

combining features and, 220

Convert to Shape, 225–228

Crop Marks, 228–229

deconstructing Effect menu, 
220–225

data in Graph Data window, 
322–323

smart guide preferences, 546

languages

global text support with 
Unicode, 253–254

Hyphenation panel, 547

scripting, 312

Type preferences, 542

Lasso tool, 33–34

Last Effect setting, 220

layer clipping masks

defi ned, 298

organizing masking with, 
300–302

layer comps, 379–380

layers

animation, 440

exporting PSD fi les, 410

General Print options, 503

importing PSD fi les, 411

organizing your drawing, 
154–162

Save Adobe PDF options, 469

Save for Web & Devices image 
settings, 438

SWF Options, 492

working with placed images, 
381–382

leaders, character, 264

leading, 261

Legacy Artboard setting, 17

legacy fi les

artboard and workfl ow, 17

backward compatibility, 
278–282

EPS, 459–460

preferences, 538

saving Illustrator, 455–456

lens fl ares, 129–130

libraries

coloring artwork with, 175–
177

limiting Color Guide panel, 
194–195

limiting Recolor Artwork 
panel, 203

symbol, 289
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saving and exporting, 484

strategies, 18

using, 10–12

multiple attributes, 139–141

multiple fi lls, 242–243

Multiple Master fonts, 254–255, 
261

multiple objects, 40

Murphy, Chris, 213, 511

N
Name setting

defi ned, 4

Layers panel, 156

navigation, artboard, 12–13

nested groups, 147–148

nested layers, 159–160

nested symbols, 289

New Art Has Basic Appearance 
setting, 141

New Document Profi le menu, 4

new documents

creating, 3–7

profi les, 7–8

set-up, 8–10

vs. templates, 25

nib, 106

No Image setting, 394

No Shading setting, 349

No Tracing Result setting, 396

Non-Zero Winding Fill Rule 
method, 86–87

nudge amount, 537

Number of Artboards setting, 4

Number of Recent Fonts 
setting, 542

numbers

data in Graph Data window, 
322–323

drawing by, 71–72

editing colors numerically, 
202–203

Pantone color, 177

Transform panel, 37–38

Numbers Without Units Are 
Points preference, 543

menus

Blend, 62–63

deconstructing Effect, 220–
225

Gradient Swatch, 179

Links panel, 385

Pre-set pop-up, 393

Swatch Libraries, 175

View, 422

Merge pathfi nder, 44

merging Live Paint groups, 100

mesh points, 127–128

meshes

Envelope distortion, 52–60

Gradient Mesh tool, 127–129

Transparency Flattener Preset 
Options, 520

metadata

linking placed image, 386

meaningful, 25–26

SVG Options, 483

methods

colorization, 209

creating blends, 62–63

Envelope distortion, 52–60

image placing, 376–382

proofi ng colors, 215

selection, 28–29

Microsoft Offi ce, 487

Min Stroke Weight setting, 402

Minimum Area setting, 402

Minus Back pathfi nder, 45

Minus Front shape mode, 42

Miter joins, 186–187

mixing color, 166–167

Miyamoto, Yukio, 129

Mobile and Devices

document, 448

profi le, 3

mobile design and web. see web 
and mobile design

Mode setting, 398

moiré patterns, 171

mosaic tiles, 405–406

multiple artboards

legacy workfl ow and, 17

modifi cation, 13–16

navigation, 12–13

M
Mac computers

exporting art for Microsoft 
Offi ce, 487

PICT fi les, 493–494

web-safe colors, 418

Magic Wand tool, 33–34

Maintain Editability setting, 479

Make with Mesh method, 54–55

Make with Top Object method, 
52–53

Make with Warp method, 55–56

managing color. see color 
management

mapping artwork

to 3D surfaces, 366–368

applying strokes and fi lls to 
3D, 339–340

defi ned, 337

Illustrator support, 335

specifying, 368–371

with symbols, 289

Marks and Bleeds

PDF settings, 472

Print panel, 505–506

marquee method, 28

masks

clipping, 298–300

creating clipping, 224

exporting PSD fi les, 410

importing PSD fi les, 412

keylines, 382

layer clipping, 155

layer clipping masks, 300–302

opacity, 302–306

overview, 297–298

working with placed images, 
380–381

master art elements, 289

master passwords, 476

Matte setting, 436

Max Colors setting, 400

Max Stroke Weight setting, 401

measurement labels

defi ned, 22

preferences, 546

Media, print options, 503
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Transparency Flattener Preset 
Options, 520–521

output

collecting necessary support 
fi les, 313–314

Output Print panel, 506–507

PDF settings, 472–473

Output fewer <tspan> elements, 
483

Overprint Preview

Book Color, 218

using, 19

overprints

PDF saving, 474

prepress and printing, 528–534

overset text, 269

P
page information, 505

page tiling

Convert to Artboards options, 
17

General Print options, 503–
504

pages vs. artboards, 10

Paintbrush tool

applying brush strokes, 109

creative drawing, 121–126

defi ning Art brush, 113–114

defi ning Calligraphic brush, 
110–111

defi ning Pattern brush, 
114–119

defi ning Scatter brush, 111–
113

with distortion, 49–51

drawing and erasing, 120–126

expanding brush art, 120

exploring, 106–108

modifying brush strokes, 119

Palette setting, 398

Panel Options, 386–387

panels

Actions, 310–311

Align, 45–47

Appearance, 134–142

Opacity value

Gradient panel options, 180

targeting attributes, 138–139

Open Documents As Tabs 
setting, 549

open paths

defi ned, 125–126

shape tools, 70–71

Open Screen Project, 449

OpenType fonts

introducing, 255–256

plus Illustrator, 257–258

optical kerning, 263

optimization, 426

Optimize for Adobe SVG Viewer 
setting

exporting SVG fi les, 447

SVG Options, 482

Optimize for Fast Web View 
setting, 469

Options setting, 490–491

organizing your drawing. see
drawing organization

orientation

Blend Options, 64

defi ned, 5

General Print options, 503

origin points, 37

Original Image setting, 394

out of gamut, 512

out ports

putting type on path, 272

text threading, 267–269

outer corner tiles, 117

Outer Glow effect, 238

Outline mode

brushes in, 120

viewing documents, 18

Outline Object function, 232–233

Outline pathfi nder, 44–45

Outline Stroke command, 89

Outline Stroke function, 232–233

outlines

adding keylines to placed 
images, 382

FXG Options, 480

preview settings, 396

text, 252–253

O
object highlighting

defi ned, 22

preferences, 546

Object Mosaic, 405–406

Object Selection

alternative selection 
techniques, 33–35

Direct Selection tool, 31–32

Group Selection tool, 32

overview, 28–29

Selection and Anchor Display, 
30–31

Object Selection by Path Only 
setting

defi ned, 30

preferences, 540

object-based slicing, 427–429

objects

3D. see 3D (three-dimensional)

adding graphic styles to, 309

aligning, 45–47

distributing, 47–49

stacking order, 135–137

technical drawing. see technical 
drawing

text, 250–253

transformations, 35–41

transforming with effects, 232

understanding hierarchy, 
159–160

wrapping text around, 275–276

Objects setting, 388

Offset Path function

combining with Pathfi nder, 
233–234

defi ned, 89–90

as live effect, 232–233

Offset setting, 359

one-click color fi xes, 213

online Kuler community, 195–
197

opacity. see also transparency

applying to 3D, 371–373

exporting PSD fi les, 410

Symbol Screener tool, 295

opacity masks, 298, 302–306
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saving overview, 462–463

security, 475–477

settings, 468–469

PDF/X standard

defi ned, 466–468

output settings, 473

PDFL version 1.3, 465–466

Pen tool

adding/deleting anchor points, 
83

Direct Selection, 31

mastering, 72–82

vs. Pencil tool, 105

Pencil tool, 102–105

Perceptual method, 215

permissions

embedding fonts and, 475

PDF security, 476–477

perspective

with 3D Rotate effect, 365

adjusting with Position 
settings, 344–345

applying with Rotate effect, 
337

drawing exercise barbell, 363

Pettit, Teri, 116, 177, 328

photographs. see images

photorealistic button, 354–356

Photoshop

alpha channels, 302

antialiasing and, 426

Book Color, 217–218

converting raster content to 
grayscale, 212

exporting with layers, 155

placing native image fi les, 
379–380

shape modes vs. shape layers, 
44

working with images, 408–412

PICT fi les, 493–494

pictures. see images

pie graphs, 318, 320

pixel grid, 420–426

Pixel Preview

antialiasing and, 421–426

using, 20

paths

adding/deleting anchor points, 
83

advanced editing, 88–92

applying strokes, 186–189

changing with Pathfi nders, 
44–45

closed. see closed paths

coloring with Live Paint, 
94–99

compound, 85–87

cutting, 85

editing Live Trace, 402–405

editing with Live Paint, 
100–102

Fill Rules, 86–87

live effects, 232–233

putting text on, 271–275

replacing blend spines, 64–65

transformations, 35–41

working with Pen tool, 72–82

working with Pencil tool, 
102–105

working with Reshape tool, 
84–85

Pattern brush

defi ned, 108

defi ning, 114–119

pattern fi lls

defi ned, 184–185

distorting, 58

Pattern Objects setting, 388

Pattern tiles setting

Pattern Brush Options, 115

preferences, 539

patterns, 168–169

PDF (Portable Document 
Format) fi les

Acrobat compatibility, 465–466

advanced settings, 474–475

compression, 470–471

different uses, 464

layers, 155

Marks and Bleeds, 472

native Illustrator fi les, 454–458

output, 472–473

PDF/X standard, 466–468

panels (continued)

Attributes, 439–440

Character, 261–262

Color, 166–167

Color Guide, 189–193

distributing objects, 47–49

Document Info, 388

exploring Pathfi nder, 41–45

Flash Text, 444

Glyphs, 259

Gradient, 179

Graphic Styles, 307–309

Kuler, 197

Layers, 156–158

limiting Color Guide, 194–195

Links, 383–387

Live Trace Control. see Live 
Trace

OpenType, 258

Paragraph, 264

Preferences. see application 
preferences

Print. see printing

Selection and Anchor Display, 
30–31

Stroke, 186–189

Swatches, 167–174

Transform, 37–38

Transparency, 303–306

Pantone color libraries

Book Color, 217–218

defi ned, 176–177

limiting Color Guide panel, 
194–195

paragraph options

text objects, 250–252

text styles, 266

typography, 261–265

passwords, 476–477

pasting, 411

Path Fitting setting, 402–403

Path Overlap setting, 240

Pathfi nder

exporting PSD fi les, 410

live effects, 233–234

panel, 41–45
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Layers panel, 157

previewing

3D Extrude and Bevel effect, 
341–342

color separations, 509

contrast for color blindness, 
216

documents, 18

fonts, 542

Live Trace options, 394–396

Overprint Preview, 19

overprints, 530–531

pixel grid, 421–426

Pixel Preview, 20

SVG Options, 483

transparency fl attening, 
524–525

Use Preview Bounds setting, 
539

primitive vector shapes, 68–72

print designers vs. web designers, 
414–415

print graphics for web design, 
420–426

Print profi le, 3

Print setting, 157

Printer Profi le setting, 511

printing, 499–534

Advanced Print panel, 512

choosing formats based on, 
495–496

Color Management Print 
panel, 511–512

color separations, 507–509

with confi dence, 526–527

Crop Marks, 228–229

defi ning print presets, 513

does fi le contain 
transparency?, 523–526

EPS Options, 461

expanding appearances, 142

General Print panel, 500–504

Graphics Print panel, 510–511

Marks and Bleed Print panel, 
505–506

Output Print panel, 506–507

overprints, 528–534

overview, 499

posterization

Color Management options, 
512

defi ned, 215

PostScript

saving EPS fi les, 458–462

transparency and, 514

Type 1 fonts, 254–255

PPD (PostScript Printer 
Defi nition) fi les, 500

preferences, application. see
application preferences

prepress and printing. see printing

Preserve Appearance settings, 480

Preserve CMYK Numbers 
setting, 512

Preserve Illustrator Editing 
Capabilities setting

FXG Options, 478–479

Save Adobe PDF options, 468

SVG Options, 482

Preserve setting

Advanced Print options, 512

Recolor Options, 207

Preserve Spot Colors setting

Document Raster Effects 
Settings, 225

Rasterize options, 408

Preserve Tints colorization 
method, 209

presets

defi ning print, 513

PDF, 464

Pre-set menu, 393

Preset pane, 14

Pressure setting, 296

pressure-sensitive pen tablets, 109

Preview and Printing 
permissions, 475

Preview Bounds, 38

Preview in Browser icon, 433

Preview mode

brushes in, 120

settings, 5–6

viewing documents, 18

Preview pane, 432

Preview setting

EPS Options, 460

pixels

creating vectors that act like, 
235–236

exporting to web, 430–438

massaging in Illustrator, 
222–225

turning vectors into, 406–408

vs. vectors in 3D, 333

web design, 415

place-embedding

defi ned, 376–378

PSD fi les, 411–412

place-linking

defi ned, 376–378

EPS Options, 461

Illustrator fi le format options, 
458

preferences, 551

Placement Options, 385–386

placing raster-based fi les

managing, 383–388

overview, 376–382

Plastic Shading setting, 349

playing actions, 310–311

Plug-ins & Scratch Disks panel, 
548

PNG (Portable Network 
Graphic) fi les

exporting, 485–487

web format options, 436

point type, 250

points, anchor. see anchor points

polar graphs, 318

Polar Grid tool, 70–71

Polygon tool, 68–69

Portable Document Format 
(PDF) fi les. see PDF 
(Portable Document 
Format) fi les

Portable Network Graphic 
(PNG) fi les

exporting, 485–487

web format options, 436

Position pane, 14

Position settings

3D Revolve Options, 357

Extrude & Bevel effect, 
342–346
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vs. Split Into Grid feature, 92

red, green, and blue (RGB). see
RGB (red, green, and blue)

Reduce to Basic Appearance 
setting, 141

reference points, 37

Refl ect tool, 38–39

registration marks, 505

Relative Colorimetric, 512

Relative setting, 226

releasing

blends, 65–66

envelopes, 60

Live Paint groups, 100

Relink button, 384

Rendering Intent setting, 512

replacing symbols, 287

resampling

PDF compression settings, 
470–471

Tracing Options, 400

Reset All Warning Dialogs 
setting, 539

reshape tool, 84–85

resolution

antialiasing and pixel grid, 
420–426

Document Raster Effects 
Settings, 223

Illustrator effects vs. 
Photoshop effects, 
246–247

PNG fi les, 486

preferences, 550

printing with confi dence, 526

Rasterize options, 408

Transparency Flattener Preset 
Options, 520

Reverse Gradient setting, 179

Reverse Order setting, 502

reversing blends, 65

Revert icon, 322

Revolve effect, 3D, 336, 357–364

RGB (red, green, and blue)

Book Color, 217–218

CMYK or, 6–7

coloring artwork, 166

EPS Options, 461

Raster Effects setting, 5

raster-based effects, 221–222

raster-based fi les

converting with Object 
Mosaic, 405–406

exporting, 485–486

exporting JPEGs, 492–493

managing placed, 383–388

placing, 376–382

rasterization

fl attening transparency with, 
516–519

FXG Options, 480

live effects, 235–236

rasters

converting to grayscale, 212

converting to vectors, 389–392

Envelope Options, 57

mapping artwork to 3D, 
367–368

Transparency Flattener Preset 
Options, 520

turning vectors into, 406–408

ray tracing, 335

Reader

fi le saving, 462–463

overprints and handling 
transparency, 534

Real World Adobe Photoshop CS4 
(Blatner and Chavez), 379

Real World Color Management, 
Second Edition (Fraser, 
Murphy and Bunting), 
213, 511

realistic button, 354–356

recoloring artwork

Assign tab, 204–208

converting to grayscale, 
211–212

Edit tab, 200–204

graphs, 326–328

overview, 198–199

recording actions, 310–311

Rectangle tool

creating 3D geometry, 352–353

defi ned, 68–69

Rectangular Grid tool

defi ned, 70–71

printing (continued)

permissions, 477

process colors, 170

transparency fl attening, 
514–523

transparency truth, 513–514

using automation when 
releasing fi nal fi les, 
312–314

process colors

defi ned, 170

vs. global process colors, 172

profi les

Color Management options, 
512

creating, 7–8

new documents, 3–7

new documents vs. templates, 
25

Progressive setting, 436

Projecting caps, 186–187

promising, 551

proofi ng colors, 214–216

proprietary nature of 3D effects, 
335

Protanopia, 216

protected fonts, 475

PSD fi les

exporting, 494

placing, 379–380

Pucker and Bloat effect, 230

Pucker tool, 50

Q
QuarkXPress

overprints and handling 
transparency, 534

print workfl ows, 495–496

saving from Illustrator, 454

R
radar graphs, 318, 320

radial gradients

defi ned, 178

widget, 184
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Screener tool, Symbol, 295

screens, computer. see computer 
screens

Scribble effect

applying to multiple fi lls, 
242–243

defi ned, 239–241

scripting

defi ned, 310

using automation when 
releasing fi nal fi les, 
313–314

Scruncher tool, Symbol, 293

seamless patterns, 185

security

PDF fi les, 463

PDF settings, 475–477

SWF Options, 491

segmented color wheel, 202

Select Same Tint % setting, 538

selected artwork, 199

Selection and Anchor Display 
panel, 30–31, 540–541

Selection Limits Merge, 124

Selection tool, 32

selections

aligning to, 46

objects. see Object Selection

vs. targeting, 134

separations

Output Print options, 506–507

specifying color, 507–509

sets

actions, 310–311

graphic styles as attribute, 307

sets, symbol

creating, 291–292

expanding, 297

working with symbolism 
tools, 296

shading effects

3D Rotate Options, 365

blending 3D objects, 373–374

Extrude and Bevel surfaces, 
348–351

mapped artwork, 370–371

transitions with blends, 61

saving, 453–483

choosing formats based on 
workfl ow, 495–497

in EPS, 222

EPS fi les, 458–462

exporting and, 453

FXG fi les, 478–480

Illustrator CS4 fi les to 
Illustrator legacy 
versions, 282

native Illustrator fi les, 434–458

PDF Acrobat compatibility, 
465–466

PDF advanced settings, 
474–475

PDF compression, 470–471

PDF fi le uses, 464

PDF fi les, 462–463

PDF Marks and Bleeds, 472

PDF output, 472–473

PDF security, 475–477

PDF settings, 468–469

PDF/X standard, 466–468

selections, 35

SVG fi les, 480–483

Scalable Vector Graphics (SVG). 
see SVG (Scalable Vector 
Graphics) fi les

Scale setting, 115

Scale Strokes & Effects setting, 
539

Scale Tints colorization method, 
209

scaling

with bounding boxes, 36–37

characters, 262

designing for Flash, 443

symbol instances, 293–294

symbols, 285

tool, 38–39

Scallop tool, 50

Scatter brush

defi ned, 107

defi ning, 111–113

vs. Symbol Sprayer, 297

scatter graphs, 318, 320

Scatter setting, 112

Scissors tool, 85

proofi ng colors, 215

web-safe colors, 418–419

RIA (rich Internet application), 
196, 450

rich Internet application (RIA), 
196, 450

rivers in text, 265

Roman fonts, 261

Rotate effect, 3D, 336, 365

Rotate tool, 38–39

rotation

3D Extrude and Bevel 
Options, 342–346

with bounding boxes, 36–37

characters, 262

Scatter Brush Options, 112

symbol, 285

Symbol Spinner tool, 294

with Transform Each, 40

Roughen effect, 230

Round caps, 186–187

Round Corners effect, 238–239

Round joins, 186–187

Rounded Rectangle tool, 68–69

Roundness setting, 110

round-tripping, 454

rows

settings, 4

transposing, 322

rulers, 20–21

S
Same functions, 34

saturation

converting to grayscale, 
210–211

method, 215

recoloring with Edit tab, 
200–203

Save each Artboard to a Separate 
File, 458

Save for Web & Devices

exporting pixel-based images, 
430–438

exporting vector-based images, 
445–447
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Rasterize options, 408

stacked bar graphs, 318–319

stacked column graphs, 318–319

stacking order

attributes and, 135–137

with clipping masks, 299

isolation mode, 154

SVG fi lters, 244

transparency fl attening and, 
521–523

working with groups, 151

Stainer tool, Symbol, 295

Standard fonts, 261

Star tool, 68–69

start tiles, 118

steps, blending, 61

Steuer, Sharon, 129

stitching, 521

storage with symbols, 289

Straight Lines, 91

straight paths

drawing curved and, 79–80

drawing objects with, 74–76

strokes

with 3D effect, 337–340

adding, 139–141

adding to group, 150–152

antialiasing and, 425

applying, 186–189

Blob Brush tool, 122

coloring artwork with, 177–
178

Drop Shadow and, 144–146

mapping to 3D, 367

path effects, 232–233

Scale Strokes & Effects setting, 
539

Scribble Options, 241

Tracing Options, 401–402

Transparency Flattener Preset 
Options, 521

understanding appearances, 
134–142

Styler tool, Symbol, 295

styles, graphic. see graphic styles

styles, text, 266

Stylize, 236–243

SVG Options, 483

web and mobile design, 
426–430

smart guides

application preferences, 
545–546

defi ned, 21–22

Transform Tools, 39

smart targeting, 134

smooth anchor points

converting to corner, 80

defi ned, 78

mapping artwork to 3D 
surfaces, 367

Smooth tool, 103–105

Smoothness setting, 124

Snap to Point setting

defi ned, 30

preferences, 540–541

Soft Drop Shadow, 148–150

solid appearance, 346

solid color, 171

Sort setting, 207

Spacing setting

Blend Options, 63–64

defi ned, 4

Pattern Brush Options, 115

Scatter Brush Options, 112

Scribble Options, 241

Type on a Path Options, 275

specifi c color, 171

Specifi ed Distance setting, 64

Specifi ed Steps setting, 64

spelling, 277–278

spheres, 359–360

spines, 64–65

Spinner tool, Symbol, 294

Spiral tool, 70–71

Split Into Grid feature, 92

Spot Color Objects setting, 388

spot colors

Book Color, 217–218

defi ned, 170–171

Extrude & Bevel effect, 351

limiting Color Guide panel, 
195

preserving, 225

shapes

3D. see 3D (three-dimensional)

converting to, 225–228

creating complex with 
Pathfi nder, 233–234

drawing primitive vector, 
68–72

modes, 41–44

Shear tool, 38–39

Shifter tool, Symbol, 293

Shockwave Flash (SWF) fi les

designing for Flash, 441–444

exporting, 445–446, 489–492

Show Asian Options setting, 542

Show Code and Show Preview 
setting, 480

Show Font Names in English 
setting, 542

Show handles when multiple 
anchors are selected, 541

Show Layers Only setting, 158

Show Original setting, 91

Show setting, 157

Show SVG Code and Web 
Preview option, 483

Show Tool Tips setting, 538

side tiles, 116–117

Silly Putty, 49

similar object selection, 34

Simplify dialog box, 91

Simulate setting, 512

Single-line Composer, 265

Sizer tool, Symbol, 293–294

sizing

anchor points and control 
handles, 30

bevel, 347

General Print options, 503

highlights on 3D objects, 350

Scatter Brush Options, 111

Size setting, 5

Skip Blank Artboards setting, 503

Slice Select tool, 432

slices

exporting PSD fi les, 410

importing PSD fi les, 412

Slices panel, 546–547
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Transparency Flattener Preset 
Options, 520

transparency fl attening and 
stacking order, 521–523

text fi les, 495

text threading

with Area Type, 267–269

putting type on path, 271–272

<textpath> elements, 483

three-dimensional (3D). see 3D 
(three-dimensional)

Threshold setting, 398–399

thumbnails

customizing Links panel, 
386–387

EPS Options, 461

gradient fi lls, 179

Save Adobe PDF options, 468

in Swatches panel, 169

TIFF (Tagged Image File Format) 
fi les, 495

tiles

Object Mosaic, 405–406

page, 503–504

Pattern Brush Options, 
116–119

Tints and Shades colorization 
method, 209

Tints/Shades options, 190–191

Tolerance setting, 540

tools

artwork. see artwork

coloring artwork. see coloring 
artwork

creative drawing. see creative 
drawing

graphing. see graphs

Save for Web & Devices, 432

Show Tool Tips setting, 538

symbolism, 289–297

technical drawing. see technical 
drawing

typography. see typography

web slicing, 429

Trace, Live. see Live Trace

Tracing Options dialog box, 
397–402

Tracing Result setting, 396

symbols

animation, 440

designing for Flash, 442–443

instances and, 284–289

mapping artwork to 3D 
surfaces, 366–368

saving space and time with, 
284

specifying mapped artwork, 
368–371

symbolism tools, 289–297

T
tables, 92

tabs

opening documents as, 549

settings, 264

Tagged Image File Format (TIFF) 
fi les, 495

Targa fi les, 485

target indicator, 160

targeting

attributes, 138–139

vs. selecting, 134

technical drawing, 67–92

adding/deleting anchor points, 
83

advanced path editing, 88–92

compound paths, 85–87

cutting paths, 85

overview, 67

Pen tool, 72–82

primitive vector shapes, 68–72

reshape tool, 84–85

technical effects, 243–244

templates

layers, 381–382

Layers panel, 157

in welcome screen, 2

working with, 24–25

testing mobile content, 448

text. see also typography

antialiasing and, 426

importing PSD fi les, 411

PDF compression settings, 471

printing with confi dence, 527

support

3D, 335

Acrobat and PDF 
compatibility, 465–466

collecting necessary fi les, 
313–314

Illustrator fi le format options, 
457

surfaces

3D Revolve Options, 357

applying strokes and fi lls to 
3D, 339–340

Extrude & Bevel effect, 
348–351

mapping artwork to 3D. see
mapping artwork

SVG (Scalable Vector Graphics) 
fi les

with layers, 155

saving, 480–483

web format options, 446–447

SVG (Scalable Vector Graphics) 
fi lters, 243–244

Swatch Exchange, 176

Swatches panel

defi ned, 167–174

libraries, 175–177

web-safe colors, 418–419

SWF (Shockwave Flash) fi les

designing for Flash, 441–444

exporting, 445–446, 489–492

Switch X/Y icon, 322

Symbol Screener tool, 295

Symbol Scruncher tool, 293

symbol sets

defi ned, 291–292

expanding, 297

working with symbolism 
tools, 296

Symbol Shifter tool, 293

Symbol Sizer tool, 293–294

Symbol Spinner tool, 294

Symbol Sprayer, 297

Symbol Sprayer tool, 290–292

Symbol Stainer tool, 295

Symbol Styler tool, 295
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U
underscore characters, 263

ungrouping

defi ned, 150

graphs, 329

layers and appearances, 162

Unicode, 253–254

Unite shape mode, 42

Units and Display Performance 
panel, 543–544

Units setting, 5, 543

unlocked colors, 200

unlocking objects, 29

updating

converting legacy fi les, 279–
280

global process colors, 170

legacy text in open document, 
280–281

optimization with slicing, 427

preferences, 551

Update Link button, 384

upsampling, 470–471

Use <textpath> element for 
Text on Path, 483

Use Artboards setting, 478

Use Compression setting, 458

Use Inline Input for Non-Latin 
Text setting, 542

Use Japanese Crop Marks setting, 
538–539

Use Low Resolution Proxy for 
Linked EPS setting, 550

Use Precise Cursors setting, 537

Use Preview Bounds setting, 539

Use Printer’s Default Screen 
setting, 461

User Interface panel, 548–549

user slices, 427

V
vanishing points, 335

Variation Options, 191

VBScript (Visual Basic Scripting 
Edition), 312

vector graphics, 94

Transparent Image setting, 395

Transpose Row/Column icon, 
322

traps, 529

trim marks

defi ned, 228–229

Marks and Bleed Print panel, 
505–506

Trim pathfi nder, 44

TrueType fonts, 254–255

<tspan> elements, 483

Tufte, Edward, 329

Tweak effect, 231

tweening, 61–62

Twist effect, 231

Type object, 152

Type Object Selection by Path 
Only setting, 542

Type options

defi ned, 10

preferences, 541–542

Type setting

designing for Flash, 442

Gradient panel options, 179

types, 82

typography, 249–282

applying Convert to Shape, 
226–228

Area Type, 267–271

characters and paragraph 
options, 261–265

designing for Flash, 444

editing, 276–278

exporting PSD fi les, 410

fonts, 254–261

global text support with 
Unicode, 253–254

legacy text and backward 
compatibility, 
278–282

overview, 249

putting on path, 271–275

text objects, 250–253

text styles, 266

wrapping text around objects, 
275–276

tracing, manual, 381–382

track cube, 342–346

tracking, 262

Transform Again feature, 41

Transform Each function, 40

Transform effect, 231–232

Transform Pattern Tiles setting, 
539

transform tools

defi ned, 22

smart guide preferences, 546

transformations

editing 3D, 340

live effects, 229–232

making, 35–41

symbol, 285

type, 269

working with placed images, 
380–381

transitions with blends, 60–66

transparency

3D and, 371–373

Acrobat and PDF 
compatibility, 466

Advanced Print options, 512

does fi le contain?, 523–526

in EPS fi les, 459

EPS Options, 460

exporting PSD fi les, 410

Flare tool, 129

fl attening, 514–523

format options, 458

formats and printing, 496

GIF fi les and, 434

importing PSD fi les, 412

layers, 155

opacity masks, 302–306

overprints and handling, 
531–534

PDF advanced settings, 474

PNG fi les, 486

printing with confi dence, 
526–527

truth about, 513–514

Transparency Grid setting

defi ned, 5

document set-up, 9–10
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overview, 413

slicing, 426–430

two approaches, 414–415

web graphs, 318

Web profi le, 3

web slices. see slices

Web Snap setting, 435

web-safe colors, 418–419

weight setting, 186

welcome screen, 2

widgets, gradient, 182–184

Width setting

Art Brush Options, 114

defi ned, 5

Windows computers, 418

Windows Metafi le (WMF) fi les, 
489

Wireframe setting, 349

Wireless Bitmap (WBMP) fi les, 
437

WMF (Windows Metafi le) fi les, 
489

workfl ows

choosing formats based on, 
495–497

future, 450–451

web design, 414–415

world of 3D. see 3D (three-
dimensional)

wrapping symbols, 366

wrapping text, 275–276

Wrinkle tool, 50–51

X
XMP (Extensible Metadata 

Platform), 25–26

Z
Zig Zag effect, 231

Zoom control, 433

with Device Central, 447–449

document set-up, 8–9

documents, 18–23

placed images, 384

previewing. see previewing

Save Adobe PDF options, 469

SVG Options, 482

in Swatches panel, 169

visible faces, 352

Visual Basic Scripting Edition 
(VBScript), 312

Vivid/Muted options, 190–191

W
Wacom tablets, 109

Warm/Cool options, 190–191

warning dialogs setting, 539

Warnock, John, 72

Warp tool

defi ned, 50–51

vs. Envelope distortion, 60

live effects, 244–245

Make with Warp method, 
55–56

WBMP (Wireless Bitmap) fi les, 
437

web and mobile design, 413–451

Adobe Device Central, 447–
449

display, 243–244

exporting pixel-based images, 
430–438

exporting vector-based images, 
445–447

Flash, 441–444

formats based on workfl ow, 
497

future workfl ows, 450–451

graphics, 420–426

image quality, 416–419

interactivity and animation, 
439–441

vector lens fl ares, 129–130

vector paths

clipping masks vs. opacity 
masks, 306

layer clipping masks, 300–302

simplifying, 90–91

vector shapes

adding color, 177–178

drawing, 68–72

vector-based images

exporting to web, 445–447

web design, 415

vectors

3D based, 335

converting rasters to, 389–392

converting text to editable, 
252–253

creating to act like pixels, 
235–236

exporting PSD fi les, 410

Feather effect, 237

fl attener options, 520

free-form. see free-form 
vectors

importing PSD fi les, 411

objects, 134–142

vs. pixels in 3D, 333

vs. rasters, 221–222

turning into rasters, 406–408

Version setting

EPS Options, 460

FXG Options, 478

Illustrator fi le format options, 
457

SWF Options, 490

Video and Film profi le, 3

View PDF after Saving setting, 
469

viewing

3D Extrude and Bevel 
Options, 342–346

in Adobe Reader, 463

color on screen, 213–218
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