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Introduction

Welcome to the second edition of Windows XP All-in-One Desk
Reference For Dummies — the no-bull, one-stop Windows reference
for the rest of us. Microsoft has made many changes to Windows XP since it
first rolled off the assembly line in October 2001. Most important: Massive
security changes — and even a few improvements — to make it harder for
the bad guys to take over your computer, turn it into a zombie, clobber your
files, and/or make it spew infected messages to every e-mail address stored
in every nook and cranny of your PC.

While the online world has grown fangs since the halcyon days of October
2001, the world of entertainment has blossomed. Windows XP — particu-
larly the Windows Media Player, support for digital cameras and cam-
corders, and the special-purpose/extra-cost Windows XP Media Center
Edition — expanded to fill the void, dragging millions of new PC users,
kickin’ and screamin’ and rockin’ and rollin’, into the 21st century.

With all the bad press that Microsoft has drawn (and, in many cases,
earned), it’s easy to lose sight of one key fact: Windows XP is the first PC
operating system that works. At least, most of the time, on most PCs, run-
ning most kinds of applications. It’s the closest thing we humans have ever
had to a universal experience: Taxi drivers in Hong Kong swear at Windows
XP with as much fervor as sheepherders in Estonia; hagglers sipping coffee
in a souq in Kuwait talk about the latest Windows XP worms with the same
awe and worry as hagglers downing lattes in Manhattan.

We're all in this big, leaky boat together. Sobering thought, that.

About This Book

Windows XP All-in-One Desk Reference For Dummies, 2nd Edition, takes you
through the Land of the Dummies — with introductory material and stuff
your grandmother could (and should!) understand — and then continues
the journey into more advanced areas, where you can really put Windows to
work every day. I don’t dwell on technical mumbo-jumbo, and I keep the baf-
fling jargon to a minimum. At the same time, though, I tackle the tough prob-
lems you're likely to encounter, show you the major road signs, and give you
a lot of help where you’ll need it the most.
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Conventions

Whether you want to set up a quick, easy, reliable network in your home
office or you want to cheat at Solitaire, this is your book. Er, I should say
nine books. I've broken the topics out into nine different minibooks so you’ll
find it easy to hop around to a topic — and a level of coverage — that feels
comfortable.

I didn’t design this book to be read from front to back. It’s a reference. Each
chapter and each section is meant to focus on solving a particular problem
or describing a specific technique. Sections toward the beginning of a chap-
ter are more tutorial. Sections near the end of a chapter take the bull by the
horns and squeeze.

Windows XP All-in-One Desk Reference For Dummies, 2nd Edition, should be
your reference of first resort, even before you consult Windows XP’s Help
and Support Center. There’s a big reason why: Windows Help was written by
hundreds of people over the course of many, many years. Some of the mate-
rial was written ages ago, and it’s confusing as all get-out, but it’s still in
Windows Help for folks who are tackling tough “legacy” problems. Some of
the terminology in the Help files is inconsistent and downright misleading,
largely because the technology has changed so much since some of the arti-
cles were written. The proverbial bottom line: I don’t duplicate the material
in the Windows XP Help and Support Center, but I will point to it if I figure
it’'ll help you.

Conventions

[ try to keep the typographical conventions to a minimum:

4+ The first time a buzzword appears in text, [ italicize it and define it
immediately. That makes it easier for you to glance back and re-read the
definition.

4+ When I want you to type something, I put the letters or words in bold.
For example: “Type William Gates in the Name text box.” If you need to
press more than one key on the keyboard at a time, I add a plus sign
between the keys’ names. For example, “Press Ctrl+Alt+Delete to initiate
a Vulcan Mind Meld.”

4+ Iset off Web addresses and e-mail addresses in monospace. For exam-
ple, my e-mail address is woody@AskWoody . com (true fact), and my Web
site is at www.AskWoody . com (another true fact).

There’s one other convention, though, that I use all the time. I always,
absolutely, adamantly include the filename extension — the period and
(usually) three letters at the end of a filename, such as .doc or .vbs or
.exe — when talking about a file. Yeah, | know Windows XP hides filename
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extensions by default, but you can and should go in and change that. Yeah,
I know that Bill G. hisself made the decision to hide them, and he won't back
off. (At least, that’s the rumor.)

[ also know that hundreds — probably thousands — of Microsoft employees
passed along the ILOVEYOU virus, primarily because they couldn’t see the
filename extension that would've warned them that the file was a virus. Uh,
bad decision, Bill.

(If you haven’t yet told Windows XP to show you filename extensions, take a
minute now and hop to Book I, Chapter 3, and get Windows XP to dance to
your tune.)

What Vou Don’t Have to Read

Throughout this book, I've gone to great lengths to separate out the
“optional” reading from the “required” reading. If you want to learn about a
topic or solve a specific problem, follow along in the main part of the text.
You can skip the icons and sidebars as you go, unless one happens to catch
your eye.

On the other hand, if you know a topic pretty well but want to make sure
you’ve caught all the high points, read the paragraphs marked with icons
and make sure that information registers. If it doesn’t, glance at the sur-
rounding text.

Sidebars stand as “graduate courses” for those who are curious about a spe-
cific topic — or stand knee-deep in muck, searching for a way out.

Foolish Assumptions

[ don’t make many assumptions about you, dear reader, except for the fact
that you're obviously intelligent, well-informed, discerning, and of impecca-
ble taste. That’s why you chose this book, eh?

Okay, okay. Least [ can do is butter you up a bit. Here’s the straight scoop. If
you’ve never used Windows before, bribe your neighbor (or, better, your
neighbor’s kids) to teach you how to do three things:

4+ Play Solitaire

4+ Get on the World Wide Web

4+ Shut down Windows and turn off the computer
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Organization

That covers it. If you can play Solitaire, you know how to turn on your com-
puter, use the Start button, click, drag, and double-click. After you're on the
Web, well, heaven help us all. And if you know that you need to click Start in
order to Stop, you're well on your way to achieving Dummy Enlightenment.

And that begins with Book I, Chapter 1.

Organization

Windows XP All-in-One Desk Reference For Dummies, 2nd Edition, contains
nine minibooks, each of which gives a thorough airing of a specific topic. If
you’re looking for information on a specific Windows XP topic, check the
headings in the Table of Contents or refer to the Index.

By design, this book enables you to get as much (or as little) information as
you need at any particular moment. Want to know how to jimmy your
Minesweeper score to amaze your boss and confound your co-workers?
Look at Book I, Chapter 6. Worried about cookies? Try Book IV, Chapter 3.
Also by design, Windows XP All-in-One Desk Reference For Dummies, 2nd
Edition, is a reference that you reach for again and again whenever some
new question about Windows XP comes up.

Here are the nine minibooks, and what they contain:

Book I: A Windows XP Overview: What Windows can and can’t do. What’s
inside a PC, and how does Windows control it? Do you really need Windows
XP? How do you upgrade? What is activation, and why you should be con-
cerned? Adding users — with a particular nod to security. Manipulating files.
Using the Windows taskbar and shortcuts. Getting help. Performing
searches. Cheating at the Windows games. Burning CDs. The care and feed-
ing of hard drives. Using the built-in applications for word processing and
image manipulation. How is Windows XP Professional different from
Windows XP Home?

Book II: Customizing Your Windows eXPerience: Personalizing the desktop
with themes, colors, backgrounds, and the like. Avoiding Active Desktop.
Mouse Pointers. Screen Savers. ClearType. Changing the Start menu. Using
the Quick Launch toolbar. Dealing with the Security Center: Windows
Firewall, Windows Update, and adding antivirus software.

Book III: Windows XP and the Internet: Expanding your reach through the
Internet with dial-up, DSL, or cable modems. Outlook Express: Your tool for
managing e-mail and newsgroups. Chatting and more with Windows
Messenger.
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Book IV: Adventures with Internet Explorer: Working with Internet
Explorer. Working with Web pages intelligently. E-mailing, saving, and print-
ing Web pages. Using the History folder. Maintaining favorites. Searching.
Personalizing Internet Explorer. Speeding it up. The truth about cookies.

Book V: Connecting with Microsoft Network: MSN Explorer for busy people.
Using Passport to get an ID and set your password. Setting up your own
home page. E-mail and newsgroups.

Book VI: Adding and Using Other Hardware: Cameras, scanners, printers,
audio, memory, memory sticks, monitors, and more. Choosing the right
products and getting them to work.

Book VII: Joining the Multimedia Mix: Windows Media Player, Windows
Movie Maker, digital cameras, camcorders, and other video devices. Ripping
from audio CDs. Burning your own CDs. Digital licensing. Printing and shar-
ing pictures.

Book VIII: Windows Media Center: What is it, really? How to pick a good
Windows Media Center PC. Installation and set up. Running MCE for you
and me.

Book IX: Setting Up a Network with Windows XP: Concepts behind peer-to-
peer and client/server networking. How to build your own network quickly,
easily, and reliably. Wi-Fi and other ethereal wireless topics. Protecting your
network and your privacy.

Some of the points in Windows XP All-in-One Desk Reference For Dummies,
2nd Edition, merit your special attention. I set those points off with icons.

When I'm jumping up and down on one foot with an idea so absolutely cool

[ can’t stand it anymore, that’s when I stick a Tip icon in the margin. You can
browse through any chapter and hit the very highest points by jumping from
Tip to Tip.

Pssssst. Want to know the real story? Not the stuff Microsoft’s Marketing
Droids want you to hear, but the kind of information that’ll give you some
insight into this lumbering beast in Redmond? You'll see it all next to this
icon, and on my eponymous Web site.

You don’t need to memorize the stuff marked with this icon, but you should
try to remember that there’s something special lurking about.
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Achtung! Cuidado! Thar be tygers here! Any place you see a Warning icon,
you can be sure that I've been burnt — badly — in the past. Mind your fin-
gers. These are really, really mean suckers.

Okay, so I'm a geek. [ admit it. Sure, I love to poke fun at geeks. But 'm a
modern, new-age sensitive guy, in touch with my inner geekiness. Sometimes
[ just can’t help but let it out, ya know? That’s where the Technical Stuff icon
comes in. If you get all tied up in knots about techie stuff, pass these by.

(For the record, [ managed to write this whole book without telling you that
an IP Address consists of a unique 32-bit combination of network ID and host
ID, expressed as a set of four decimal numbers with each octet separated by
periods. See? [ can restrain myself sometimes.)

Where to Go from Here

That’s about it. Time for you to crack the book open and have at it.

Don’t forget to bookmark my Web site, www.AskWoody . com. It’ll keep you up
to date on all the Windows XP news you need to know — including notes
about this book, the latest Windows bugs and gaffes, patches that are worse
than the problems they’re supposed to fix, and much more — and you can
submit your most pressing questions, for free consultation from The
Woodmeister hisself.

See ya! woody@AskWoody.com
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Chapter 1: Introducing Windows XP

In This Chapter

1+ Where Windows XP fits into The Grand Scheme of Things
+» What Windows can (and can’t) do for you

v Dissecting your computer

v~ Installing and activating Windows XP

v+ Getting help

So you're sitting in front of your computer, and this thing called Windows
XP is staring at you. The screen you see — the one with the peoples’
names on it — is called a Welcome screen, but it doesn’t say “Welcome” or
“Howdy” or even “Sit down and get to work, bucko.” It says only that you
have to click your user name in order to start, but you don’t have any idea
what a user name is, why you have to have one, what Windows has to do
with anything, and why in the %$#@! you can’t bypass all this garbage, log
on, and get your e-mail.

Good for you. That’s the right attitude.

Someday, | swear, you’ll be able to pull a PC out of the box, plug it into the
wall, turn it on, and get your e-mail — bang, bang, bang, just like that, in ten
seconds flat. If you want the computer to do something, you'll say, “Computer,
get me my e-mail,” just like Scotty in the Star Trek movies.

No matter what anyone may tell you, computers are still in their infancy.
Maybe my son will see the day when they’re truly easy to use, when the
marketing hype about “intuitive” and “seamless” and “user friendly” actually
comes true. [ doubt that I will.

In the meantime, those of us who are stuck in the early 21st century have to
make do with PCs that grow obsolete before you can unpack them, software
that’s so ornery you find yourself arguing with it, and Internet connections
that surely involve turtles carrying bits on their backs.

Windows XP is one of the most sophisticated computer programs ever
made. It cost more money to develop and took more people to build than
any previous computer program, ever. So why is it so blasted hard to use?
Why doesn’t it do what you want it to do the first time? For that matter, why
do you need it at all?

That’s what this chapter is all about.
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What Windows Does (And Doesn’t Do)

Someday, you'll get really, really mad at Windows. I guarantee it. When

you feel like putting your fist through the computer screen, tossing your
Windows XP CD in a bonfire, or hiring an expensive Windows expert to drive
out the devils within (insist on a Microsoft Certified System Exorcist, of
course), read through this section. It may help you understand why and how
Windows has limitations. It also may help you communicate with the geeky
rescue team that tries to bail you out, whether you rely on the store that
sold you the PC, the smelly guy in the apartment downstairs, or your eight-
year-old daughter’s nerdy classmate.

Hardware and software

At the most fundamental level, all computer stuff comes in one of two fla-
vors: either it’s hardware, or it’s software. Hardware is anything you can
touch — a computer screen, a mouse, a CD. Software is everything else:
e-mail messages, that letter to your Aunt Martha, pictures of your last vaca-
tion, programs like Microsoft Office. If you have a roll of film developed and
put on a CD, the shiny, round CD is hardware — you can touch it — but the
pictures themselves are software. Get the difference?

Windows XP is software. You can’t touch it. Your PC, on the other hand, is
hardware. Kick the computer screen and your toe hurts. Drop the big box on
the floor and it smashes into a gazillion pieces. That’s hardware.

Chances are very good that one of the major PC manufacturers — Dell,
HP/Compagq, IBM, Gateway/eMachines, Toshiba, Sony, and the like — made
your hardware. Microsoft, and Microsoft alone, makes Windows XP. The PC
manufacturers don’t make Windows. Microsoft doesn’t make PCs, although it
does make other kinds of hardware — video game boxes, keyboards, mice,
and a few other odds and ends.

‘&QN\BER When you first set up your PC, Windows had you click “I accept” to a licens-
Y ing agreement that’s long enough to wrap around the Empire State Building.
If you're curious about what you accepted, a printed copy of the End User
License Agreement is in the box that your PC came in or in the CD packaging
(if you bought Windows XP separately from your computer). If you can’t find
your copy, choose Start>Help and Support. Type eula in the Search text box
and press Enter.

When you bought your computer, you paid for a license to use one copy of
Windows on the PC that you bought. The PC manufacturer paid Microsoft a
royalty so that it could sell you Windows along with your PC. You may think
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that you got Windows from, say, Dell — indeed, you may have to contact Dell
for technical support on Windows questions — but, in fact, Windows came
from Microsoft.

Now you know who to blame, for sure.

Why do PCs have to run Windows?

The short answer: You don’t have to run Windows on your PC.

The PC you have is a dumb box. (You needed me to tell you that, eh?) In
order to get the dumb box to do anything worthwhile, you need a computer
program that takes control of the PC and makes it do things such as show
Web pages on the screen, respond to mouse clicks, or print résumés. An
operating system controls the dumb box and makes it do worthwhile things,
in ways that mere humans can understand.

Without an operating system, the computer can sit in a corner and count to
itself, or put profound messages on the screen, such as Non-system disk
or disk error. Insert system disk and press any key when
ready . If you want your computer to do more than that, though, you need
an operating system.

Windows is not the only operating system in town. The single largest com-
petitor to Windows is an operating system called Linux. Some people (I'm
told) actually prefer Linux to Windows, and the debates between pro-
Windows and pro-Linux camps can become rather heated. Suffice it to say
that, oh, 99 percent of all individual PC users stick with Windows. You proba-
bly will, too.

A terminology survival kit

Some terms pop up so frequently that you'll find it worthwhile to memorize
them, or at least understand where they come from. That way, you won’t be
caught flatfooted when your first-grader comes home and asks if he can
download a program from the Internet.

If you really want to drive your techie friends nuts, the next time you have a
problem with your computer, tell them that the hassles occur when you're
“running Microsoft.” They won’t have any idea if you mean Windows, Office,
Word, Outlook, or any of a gazillion other programs.

A program is software (see preceding section) that works on a computer.
Windows, the operating system (see preceding section), is a program. So are
computer games, Microsoft Office, Microsoft Word (which is the word

Book |
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processor part of Office), Internet Explorer (the Web browser in Windows),
the Windows Media Player, those nasty viruses you've heard about, that
screen saver with the oh-too-perfect fish bubbling and bumbling about, and
SO on.

A special kind of program called a driver makes specific pieces of hardware
work with the operating system. For example, your computer’s printer has a
driver; your monitor has a driver; your mouse has a driver; Tiger Woods has
a driver. Several, actually, and he makes a living with them. Would that we
were all so talented.

Sticking a program on your computer, and setting it up so that it works, is
called installing.

When you crank up a program — that is, get it going on your computer —
you can say you started it, launched it, ran it, or executed it. They all mean the
same thing.

If the program quits the way it’s supposed to, you can say it stopped, finished,
ended, exited, or terminated. Again, all of these terms mean the same thing.
If the program stops with some sort of weird error message, you can say it
crashed, died, cratered, croaked, went belly up, GPFed (techspeak for “gener-
ated a General Protection Fault” — don’t ask), or employ any of a dozen col-
orful but unprintable epithets. If the program just sits there and you can’t
get it to do anything, you can say the program froze, hung, stopped respond-
ing, or went into a loop.

A bug is something that doesn’t work right. (A bug is not a virus! Viruses work
right far too often.) Admiral Grace Hopper often repeated the story of a moth
being found in a relay of an ancient Mark Il computer. The moth was taped into
the technician’s log book on September 9, 1947, with the annotation “1545
Relay #70 Panel F (moth) in relay. First actual case of bug being found.”

The people who invented all of this terminology think of the Internet as being
some great blob in the sky — it’s “up,” as in “up in the sky.” So if you send
something from your computer to the Internet, you're uploading. If you take

something off the Internet and put it on your computer, you're downloading.

And then you have wizards. Windows comes with lots of ’em. They guide you
through complex procedures, moving one step at a time. Typically, wizards
have three buttons on the bottom of each screen: Back, Next (or Finish), and
Cancel (see Figure 1-1). Wizards remember what you’'ve chosen as you go
from step to step, making it easy to experiment a bit, change your mind, back
up, and try a different setting, without getting all the check boxes confused.

That should cover about 90 percent of the buzzwords you hear in common
parlance.
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Where Windows Has Been

Unlike Windows Me (which is a barely warmed-over remake of Windows 98)
and Windows 2000 (which should’ve been called Windows NT 5.0), Windows
XP is quite different from any operating system that has come before. To
understand why Windows XP works so differently, you need to understand
the genetic cesspool from which it emerged.

Let’s start at the beginning: Microsoft licensed the first PC operating system,
called DOS, to IBM in late 1981. MS-DOS sold like hotcakes for a number of
reasons, not the least of which is that it was the only game in town. None of
this sissy graphical stuff; DOS demanded that you type, and type, and type
again, in order to get anything done.

The vise of Windows

The ’Softies only started developing Windows in earnest when the company
discovered that it needed a different operating system to run Excel, its
spreadsheet program. Windows 1.0 shipped in November 1985. It was slow,
bloated, and unstable — some things never change, eh? — but if you wanted
to run Excel, you had to have Windows.

Excel 2.0 and Windows 2.0 shipped in late 1987. This breathtaking, revolu-
tionary new version of Windows let you overlap windows — place one
window on top of another — and it took advantage of the PC/XT’s advanced
computer chip, the 80286. Version 2.1 (also called Windows 286) shipped in
June 1988, and some people discovered that it spent more time working than
crashing. My experience was, uh, somewhat different. Windows 286 came on
a single diskette.
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Windows 3.0 arrived in May 1990, and the computer industry changed for-
ever. Microsoft finally had a hit on its hands to rival the old MS-DOS. When
Windows 3.1 came along in April 1992, it rapidly became the most widely
used operating system in history. In October 1992, Windows for Workgroups
3.1 (which I loved to call “Windows for Warehouses”) started rolling out,
with support for networking, shared files and printers, internal e-mail, and
other features you take for granted today. Some of the features worked.
Sporadically. A much better version, Windows for Workgroups 3.11, became
available in November 1993. It caught on in the corporate world.
Sporadically.

eNTer NT

At its heart, Windows 3.x was built on top of MS-DOS, and that caused all
sorts of headaches: DOS simply wasn’t stable or versatile enough to make
Windows a rock-solid operating system. Bill Gates figured, all the way back
in 1988, that DOS would never be able to support an advanced version of
Windows, so he hired a guy named Dave Cutler to build a new version of
Windows from scratch. At the time, Dave led the team that built the VMS
operating system for Digital Equipment Corp’s DEC computers.

When Dave’s all-new version of Windows shipped five years later in August
1993, Windows NT 3.1 (“New Technology”; yes, the first version number was
3.1) greeted the market with a thud. It was awfully persnickety about the
kinds of hardware it would support, and it didn’t play games worth squat.

NT and the “old” Windows

For the next eight years, two entirely different lineages of Windows co-existed.

The old DOS/Windows 3.1 branch became Windows 95 (shipped in August
1995, “probably the last version of Windows based on DOS”), Windows 98
(June 1998, “absolutely the last version of Windows based on DOS, for
sure”), and then Windows Me (Millennium Edition, September 2000, “no,
honest, this is really, really the last version of Windows based on DOS”).

On the New Technology side of the fence, Windows NT 3.1 begat Windows
NT 3.5 (September 1994), which begat Windows NT 4.0 (August 1996). Many
companies still use Windows NT 4 for their servers — the machines that
anchor corporate networks. In February 2000, Microsoft released Windows
2000, which confused the living daylights out of everybody: In spite of its
name, Windows 2000 is the next version of Windows NT and has nothing at
all in common with Windows 98 or Me.

Microsoft made oodles of money milking the DOS-based Windows cash
cow and waited patiently while sales on the NT side gradually picked up.
Windows NT 5.0, er, 2000 still didn’t play games worth squat, and some
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hardware gave it heartburn, but Windows 2000 rapidly became the operating
system of choice for most businesses and at least a few home users. Still is,
for many of them.

Merging the branches

Windows XP — in my opinion, the first must-have version of Windows since
Windows 95 — officially shipped in October 2001. Twenty years after
Microsoft tiptoed into the big time with MS-DOS, the Windows XP juggernaut
blew away everything in sight.

Some people think that Windows XP (the XP stands for eXPerience, accord-
ing to the marketing folks) represents a melding or blending of the two
Windows lineages: a little Me here, a little 2000 there, with a side of 98.

Ain’t so. Windows XP is 100 percent, bona fide NT. Period. Not one single
part of Windows Me — or any of the other DOS-based Windows versions, for
that matter, not to mention DOS itself — is in Windows XP. Not one.

That’s good news and bad news. First, the good news: If you can get Windows
XP to work at all on your old computer, or if you buy a new PC that’s designed
to use Windows XP, your new system will almost certainly be considerably
more stable than it would be with Windows Me or any of its progenitors. The
bad news: If you know how to get around a problem in Windows Me (or 98 or
95), you may not be able to use the same tricks in Windows XP. The surface
may look the same. The plumbing is radically different.

Windows XP evolves

The original Windows XP, for all its faults, came shining through as a work-
horse of the first degree. If you could get it installed, it almost always worked
right. Microsoft waited nearly a year — until September 2002 — to release its
first Service Pack, a massive collection of 300 bug fixes and security patches
to the original version of Windows XP.

Actually, Microsoft released two “Service Pack 1” versions, and therein lies
a legal story of clashing titans, Microsoft and Sun. The original version of
Windows XP didn’t include Sun’s programming language, Java (otherwise
known as JVM, or the Java Virtual Machine), which is used on many Web
sites. Sun was miffed: In order to run Java programs on Web pages, original
Windows XP users had to download and install a copy of Java, separately,
and Sun felt (rightly) that Microsoft was using its monopoly on the desktop
to hinder the spread of Java. After a series of legal wranglings that made the
Keystone Cops look staid, Microsoft decided to put Java in Service Pack 1,
and the version of SP1 that went out in September 2002 included Java. Sun
was miffed again — something about oral orifices on gift horses, I think. Back
to court. In February 2003, Microsoft released Service Pack 1a, which only

Book |
Chapter 1

dX SMOpUIpy
Buianponu|



16

The Future of Windows

differed from Service Pack 1 in that it didn’t include Java. If you wanted Java,
you had to download it from www. java.com. ’Course that happened eons
(well, okay, 14 months) before Microsoft agreed to pay Sun $2 billion to
settle all its open disputes and improve “interoperability” between Sun and
Microsoft products — including Java and Windows. Go figger.

Microsoft continued to improve on Windows XP, with new versions of
Windows Media Player, Windows Movie Maker, Windows for telephones,
Windows for toasters, Windows for telephones attached to toasters with
integrated roasters and coasters and more. But, hands down, the most
impressive new product to come out of Redmond in the post-Windows XP
era has to be Windows XP Media Center Edition, a program that runs on top
of Windows XP and gives you tremendous control over your television,
cable, satellite, stereo system — everything for the couch potato except the
couch.

Simultaneously, black-hat cretins all over the world discovered that PCs
attached directly to the Internet running Windows XP had “Kick Me” signs
posted all over them. Microsoft responded with security patches and
patches to patches and patches to patches to patches. Bill stopped all the
work at Microsoft to run a month-long “security lockdown.” The net result:
more patches and patches to patches and . . . well, you get the idea.

Thus, nearly two years after Service Pack 1, Windows XP users got treated to
Service Pack 2, a huge roll-up of new features and patches, and patches dis-
guised as features. Some things never change.

The Future of Windows

When Windows XP got beaten to a pulp by a few dozen relentless virus and
worm writers, and courts around the world found Microsoft guilty of all
manner of egregious behavior, the company’s tune changed quickly. We
stopped hearing so much about Microsoft’s breast-beating plans to dominate
every nook and cranny of computerdom. In some cases — Microsoft’s deci-
sion to stop keeping financial information in .NET Passports, for example —
Microsoft stopped sounding so much like a convicted monopolist bull in a
china shop and more like a socially responsible, trustworthy team player.

[ remain skeptical.

The next version of Windows, code-named Longhorn, remains a great
unknown. This much is certain: It will be very different from the Windows XP
you know today. Between a new user interface, bolted-to-the-walls security,
greatly improved storage and retrieval capabilities, searching and indexing
from the get-go, DVD support par excellence, and a new communications
subsystem, Longhorn improvements look great. On paper.
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At the same time, Microsoft is moving out of the business of selling software Book I
into the business of renting it — and charging for the “glue” that binds com- Chapter 1
panies, individuals, buyers, and sellers together. Whether either of those
shifts makes the lives of Windows users easier remains to be seen. But the
profitability of it all beckons, loud and clear.

Now’s a great time to dig into Windows XP and get to know it. Future ver-
sions of Windows may well seem anticlimactic, compared to this one.
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Here’s how it usually goes. You figure you need to buy a new PC. So you
spend a couple of weeks brushing up on the details — bits and bytes and
kilobytes and megabytes and gigabytes — and comparison shopping. You
end up at your local Computers Were Us shop, and this guy behind the
counter convinces you that the absolutely best bargain you’ll ever see is sit-
ting right here, right now, and you’d better take it quick before somebody
else nabs it.

Your eyes glaze over as you look at yet another spec sheet and try to figure
out one last time if a RAM is a ROM and how a CD-R differs from a CD-RW
and whether you need a DVD-R or DVD+R. In the end, you figure the guy
behind the counter must know what he’s doing, so you plunk down your
plastic and pray you got a good deal.

The next Sunday morning you look in the paper and discover you could’ve
bought twice as much machine for half as much money. The only thing you
know for sure is that your PC is hopelessly out of date, and the next time
you’ll be smarter about the whole process.

If that describes your experiences, relax. It happens to everybody. Take
solace in the fact that you bought twice as much machine for the same
amount of money as the poor schmuck who went through the same process
last month.

In this section, I try to give you just enough information about the inner work-
ings of your PC so that you can figure out what you have to do with Windows.
The details will change from week to week. But these are the basics.

Inside the big box

The big box that your computer lives in is sometimes called a CPU, meaning
Central Processing Unit (see Figure 1-2). Right off the bat, you’re bound to
get confused, unless somebody clues you in on one important detail: The
main computer chip inside that big box is also called a CPU. I prefer to call
the big box “the PC” because of the naming ambiguity, but you have proba-
bly thought of a few better names.
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Monitor

l

Floppy drive

Figure 1-2:
The big box.

Keyboard

The big box contains many parts and pieces (and no small amount of dust
and dirt), but the crucial, central element inside every PC is the motherboard
(see Figure 1-3). Attached to the motherboard you’ll find

4+ The processor or CPU: This gizmo does all the computing. It’s probably
from Intel or AMD or one of their competitors. People who sell comput-
ers rate the processors by speed, measured in MHz (megahertz) or GHz
(gigahertz, 1 GHz = 1,024 MHz). Windows XP runs like a slug on anything
slower than 300 MHz or so.

QNG/ If you're buying a new computer, the speed really doesn’t mean much,
unless you’re designing airplane wings, reshooting Jurassic Park, or you
play a lot of games on your PC. Ignore the salesperson. If you want to
improve Windows XP performance, your money should go to more
memory (see next) or a fast Internet connection.

4+ Memory chips and places to put them: Memory is measured in MB
(megabytes). Windows XP runs on a machine with 64MB — I've done
it — but you usually want 256MB or more. Most computers allow you to
add more memory to them, and boosting your computer’s memory to
512MB from 256MB makes it much snappier, especially if you run
memory hogs such as Office, PageMaker, or Photoshop. If you leave
Outlook 2003 open and work with it all day, and run almost any other
major program at the same time, 512MB will make a big difference.

4+ Lots of other stuff: You’ll never have to play with this other stuff, unless
you’re very unlucky.
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Memory slots

Card slots

Figure 1-3:

The
motherboard
sits in the
middle of

it all.

Expansion slots

Never let a salesperson talk you into eviscerating your PC and upgrading the
CPU: A 2.0 GHz PC doesn’t run a whole lot faster than a 1.6 GHz PC. Memory
upgrades don’t mean much beyond 512MB: You'll see a noticeable improve-
ment in performance up to the 512MB mark, especially if you run multiple
memory-hungry applications at the same time (I won’t mention Office 2003
by name), but very little improvement beyond that. Instead of nickel-and-
diming yourself to death on little upgrades, wait until you can afford a new
PC, and give away your old one.

P If you decide to get more memory, have the company that sells you the
memory install it. The process is simple, quick, and easy — if you know what
you’re doing. Having the dealer install the memory also puts the monkey on
their back if a memory chip doesn’t work or a bracket gets snapped.

What you see, what you get

The computer monitor or screen — you may think of it as a hoity-toity TV —
uses technology that’s quite different from what you have in your television
set. ATV scans lines across the screen from left to right, with hundreds of
them stacked on top of each other. Colors on each individual line vary all
over the place. The near-infinitely variable color on a TV combined with a
comparatively small number of lines makes for pleasant, but fuzzy, pictures.

By contrast (pun absolutely intended, of course), a computer monitor works
with dots of light, called pixels. Each pixel can have a different color, but the
maximum number of different colors that can appear on the screen at one
time is limited. As a result, computer monitors are much sharper than TV

Book |
Chapter 1

dX SMOpUIpy
Buianponu|



20 Anatomy of a Computer

tubes, but if the number of on-screen colors is restricted, pictures shown on
the monitor won'’t look as good as they would on a TV set.

VQ“\NG! Although it’s theoretically possible to use a TV set as a makeshift computer
monitor, the result leaves much to be desired. So-called scan converters allow
you to plug a TV set into the back of your computer, but text ends up so
murky that it’s hardly readable. Very expensive converters sharpen text —
but in the end usually cost more than the price of a new monitor.

LCD monitors or flat screens hold many advantages over traditional monitors:
The lines are always straight; the units don’t weigh much, they’re small and
they don’t use much electricity; and they don't flicker like fireflies in heat.
On the other hand, the flatties are expensive; individual pixels on an LCD
screen can and do go black and stay that way forever; and a high-quality well-
adjusted traditional monitor can always deliver a better, richer picture — if
you're snooty about that kind of thing.

Most people set up Windows XP to run at 1024 x 768 pixels — that is, their
monitors show 1024 pixels across the screen, with 768 running up and
down — on 17 inch or smaller conventional monitors or 15-inch LCD moni-
tors. Some folks have screens (and eyes!) that are good enough to run 1280 x
1024. Others limp along at 800 x 600. The more pixels you can cram on a
screen — that is, the higher the screen resolution — the more information
you can pack on the screen. That’s important if you commonly have more
than one word-processing document open at a time, for example. At 800 x
600, two open Word documents placed side by side look big but fuzzy, like
viewing them through a dirty magnifying glass. At 1280 x 1024, those same
two documents look sharp, but the text may be so small that you have to
squint to make it out.

A special-purpose computer stuck on a board called a graphics adapter cre-
ates everything that’s shown on your computer’s screen. The graphics
adapter has to juggle all the pixels and all the colors — so if you're a gaming
fan, the speed of the adapter’s chip can make the difference between a
zapped alien and a lost energy shield. People who sell graphics adapters for
home and office rate them in accordance with both their resolution and their
color depth, and the two are interrelated: A graphics adapter that can handle
1024 x 768 pixels on the screen with 64,000 colors showing simultaneously
may be able to show 1280 x 1024 pixels, but only 256 simultaneous colors.

If you don’t like the graphics adapter that shipped with your computer, you
can always buy a new one. But beware of one big potential problem. The
drivers that ship with new graphics adapters — the programs that allow
Windows XP to control the graphics adapter — are notorious for being
buggy and unstable. Think twice before buying a new graphics adapter, and
always update the driver to the latest version by following the instructions
on the manufacturer’s Web site: Don’t bother installing the software that
came on the CD in the box.
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Computer monitors are sold by size, measured diagonally, like TV sets. Just
like TV sets, the only way to pick a good computer screen over a run-of-the-
mill one is to compare them side by side or to follow the recommendation of
someone who has.

Managing disks

Your PC’s memory chips hold information only temporarily: Turn off the
electricity, and the contents of main memory goes bye-bye. If you want to re-
use your work, keeping it around after the plug has been pulled, you have to
save it, typically on a disk. The following are the most common types of
disks:

4+ Floppies: The 1.44MB floppy disk drives that were ubiquitous on PCs for
many years are becoming an endangered species — most new PCs
(especially laptops) no longer come with floppy disk drives. Still, it’s
going to make more than a few silver bullets and strands of garlic to get
rid of them completely.

You probably know how to put a floppy disk into a drive (right-side up
with the slidey-metal-thing pointing into the PC). You may not know how
to get a recalcitrant floppy out of the drive. Sometimes the slide starts
bowing, and the floppy hangs when you press the eject button. If that
happens to you, get a long pair of thin tweezers — stamp collector’s
tongs work great — turn off your PC, unplug it, grab the diskette
between the prongs of the tweezers and gently pry the diskette out. You
have to get the tweezers all the way down beyond the tip of the slide, so
longer is definitely better.

4+ Hard drives: Get the biggest, cheapest one(s) you can; electronic pic-
tures swallow up an enormous amount of space. While it’s generally true
that more expensive hard drives seem to be more reliable than cheaper
ones, objective numbers are hard to come by, and individual results will
vary all over the place. Speed doesn’t matter much, and the technology
(ATA, EIDE, SCSI) matters even less.

If you buy a new hard drive, have the dealer install it. You have to worry
about lots of permutations and combinations, and it simply isn’t worth
the effort. Life’s too short.

4+ CD and DVD drives: Of course, these drives work with CDs and DVDs,
which can be filled with data or contain music or movies. Although
Windows XP will play an audio CD automatically, you may have to jump
through some extra hoops to get it to play DVDs. See the section on
“Multimedia galore,” later in this chapter, for details.

4+ CD-R drives: These drives let you create (burn) your own CDs. After you
burn a CD in a CD-R drive, you generally can’t reburn it. If you can get
Windows XP to reburn a CD, you might not be able to play the reburned
disc in a CD player — or even in another PC. Caveat burnor.
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4+ CD-RW drives: These drives not only allow you to burn CDs; they’re also
reusable. The CD-RW drive, in conjunction with CD-RWs, lets you burn
and reburn to your heart’s content.

Most older audio CD players — like the one you probably have in your
car or your home stereo — will play only CDs that are burned with a
CD-R drive. You can’t reburn audio CDs.

4 CD-R/CD-RW drives: Many drives nowadays can create both CD-Rs and
CD-RWs, just to confuse everybody. You need CD-Rs if you're going to
burn audio CDs. You probably want CD-RWs for everything else, even
though the blank discs themselves cost more than blank CD-Rs.

4+ DVD-RW/DVD+RW drives: If you think the CD terminology is confusing,
wait till you look at DVDs. The DVD world is divided into two camps:
DVD-R (“DVD slash R”), which uses one method for encoding and read-
ing data; and DVD+R (“DVD plus R”), which uses a completely different
(and incompatible) method.

If you're going to buy a DVD recorder, get one that’ll burn both DVD-RW
and DVD+RWs. That gives you the option of creating “-R” discs if you
need to play them in a “-R only” player. In general, when burning DVDs
for use on other PCs, buy the cheapest discs you can find that don’t turn
themselves into pixie dust. When burning DVDs for use in a commercial
DVD player, use brand name discs and DVD+R.

4+ USB Flash Drive: Treat them like lollipops. Half the size of a pack of gum,
and able to hold an entire PowerPoint presentation or two or six, flash
memory should be your first choice for external storage space or for
copying files between computers. Pop one of these guys in a USB slot
(see the next section) and suddenly Windows XP knows it has another
drive — except this one’s fast, portable, and incredibly easy to use. Make
sure you get USB 2.0 support, and only pay for password protection if
you need it. The rest of the “features” are just, uh, Windows dressing.

This list is by no means definitive: There are Jaz disks, Zip drives, and
recordable media that sing till the cows come home.

Making PC connections

Your PC connects to the outside world using a bewildering variety of cables
and connectors. The most common are as follows:

4+ USB (Universal Serial Bus) cables: These cables have a flat connector
that plugs into your PC. The other end is usually shaped like a D, but dif-
ferent pieces of hardware have different terminators. (“I'll be back . ..”)
USB is the connector of choice for just about any kind of hardware —
printers, scanners, MP3 players, Palm/pocket computers, portable hard
drives, even mice. If you run out of USB connections on the back of your
PC, get a USB hub with a separate power supply and plug away.
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4+ RJ-45 connectors: These are the most common kind of network connec-
tors. They look like overweight telephone plugs (see Figure 1-4). One
end plugs into your PC, typically into a NIC (Network Interface Card, pro-
nounced “nick”), a network connector on the motherboard, or a network
connector on a card that slides into a port (a so-called “PC Card” or
“PCMCIA Card”). The other end plugs into your network’s hub (see
Figure 1-5), switch, or possibly into a cable modem, DSL box, router, or
other Internet connection-sharing device.

Figure 1-4: % =\ -
LA NN\
connector.

Figure 1-5:
A network Hub
hub.

4+ PS/2 or mini-DIN connectors: These are round connectors with six pins
and a plastic hump that prevents you from getting the connector twisted
around in the wrong direction (see Figure 1-6). Ancient technology that
works great. Commonly found on keyboards and mice.

If you have a mouse and a keyboard, both with PS/2 connectors, but
your PC sports only one PS/2 slot, not to worry! Most cable manufactur-
ers have Y connectors that allow you to attach two PS/2 devices to a
single port. Surprisingly, both the mouse and the keyboard can co-exist
with nary a hiccup. Try www.cablestogo.com.

C‘B

Figure 1-6:
APS/2or
mini-DIN
connector.
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Figure 1-7:
A simple
connec-
tion for
speakers.

4+ Parallel and serial ports: These are the long (parallel, 25-pin, with 13
pins on top and 12 on the bottom) and short (serial, 9-pin, five on top
and four on the bottom) connections on the back of your computer. The
serial port is notoriously slow, and both kinds sometimes fall apart —
which is particularly disconcerting when you unscrew a connector and a
nut falls off inside your computer. If you have a choice, choose USB.

Futzing with sound

If you plug your computer’s speakers directly into the back of the PC, the
whole process won'’t strain any little gray cells (see Figure 1-7).

To sound card

To your speakers

Most Windows XP users care about sound, and many find that tiny, tinny
speakers meticulously paired with an underaspirated amp sound about as
bad as Leonard Nimoy singing The Star Spangled Banner. (No offense,
Leonard, okay?)

Chances are pretty good that you are running Windows XP on a PC with at
least a little oomph in the audio department. If so, you have to be concerned
about four different sound jacks because each one does something different.
Your machine may not have all four. (Are you feeling inadequate yet?) Here’s
how they are usually marked, although sometimes you have to root around
in the documentation to find details:

4+ Line in: A stereo input jack. Feeds a stereo signal into the PC. Not used
very often, but it can be handy if you need to record a radio program or
digitize something on audio tape.
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4+ Mike in: Almost exclusively used for voice-recognition systems, where you
speak into the microphone and the computer attempts to convert your
speech into text. There are lots of gotchas, particularly when selecting
microphones. See www.woodyswatch.com/office/archtemplate.
asp?v6-n30 for details.

4+ Line out: A stereo output jack that bypasses the computer’s internal
amplifier. This is the source for the highest-quality sound your computer
can produce.

4+ Headphone or speaker out: Goes through the internal amplifier. Use this
jack for headphones or speakers, but avoid it in all other situations.

PC manufacturers love to extol the virtues of their advanced sound systems,
but the simple fact is that you can hook up a rather plain-vanilla PC to a
home stereo and get great sound. Just connect the “line out” jack on the
back of your PC to the “Aux in” jack on your home stereo. Voila’

Do You Need Windows XP?

A\

If you haven’t yet decided whether Windows XP or Windows XP Media
Center Edition is worth the plunge, this section should help you make up
your mind.

You can safely skip this section, unless you have to justify the upgrade to the
boss — or your spouse. Trust me. You want Windows XP — and you may
want the Media Center, too. Read on to find out why:.

It just works

In the vast majority of cases, Windows XP works far more reliably than any
other version of Windows. One of the main reasons why: Windows XP suc-
cessfully protects itself from programs that try to overwrite its crucial files.
The end — or at least the severe curtailing — of “DLL hell,” where incompati-
ble versions of programs overwrite each other, goes a long way toward
increasing Windows XP’s reliability.

Although rooting around inside Windows XP is certainly an order of magni-

tude more complex than in Windows 98 or Me, you’re much less likely to dig
into the bowels of Windows XP, unless you’re running some really weird, rel-
atively old hardware or trying to coax a hopelessly ancient game into action.

Multimedia galore

If you want to use your computer for music, pictures, video, and the like,
Windows XP has plenty of good news for you: Microsoft finally gets it. Well,
more than it used to, anyway.
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Workgroups and domains

When you attach computers to each other (that
is, you network them), you can choose from two
inherently different ways to go. In a client/
server network, which Microsoft calls a
domain, one computer (the server) controls
access to all the others (the clients). On the
other hand, in a peer-to-peer network, which
Microsoft calls a workgroup, all of the comput-
ers are equal, with no single computer stand-
ing out above all the rest.

Client/server networks abound in large compa-
nies, where central control is crucial. Network
Administrators set up security rules, grant
access where needed, allow new users to get
onto client PCs, and generally ride herd on the
entire network. Usually the server(s) hold
important corporate files and backup copies of
key files on the client computers. Usually the
major networked printers hang off of the

server(s). Usually all Internet access goes
through the server(s). Usually.

Peer-to-peer networking, on the other hand,
doesn't get hung up in the kind of security and
central administration that client/server net-
works take for granted. For example, a typical
user on a peer-to-peer network can share a
disk drive so that anybody on the network can
see it. On a client/server network, you'd have to
call in the Network Administrator.

At the risk of over-simplifying, peer-to-peer
networking works best in homes and small
offices where security isn't a major concern.
Client/server networking works best in larger
companies with significant security needs —
and a budget to match. Network Administrators
don’t come cheap.

One of the most controversial parts of Windows XP is its limited support
(some would say “lack of support”) for the MP3 audio format. A lot of misin-
formation is floating around about Windows XP and MP3, so let me set the

record straight:

4+ If you have MP3 files, Windows XP will play them, no hassle, no sweat.
You can e-mail MP3 files, burn CDs and DVDs full of them, copy and
trade them to your heart’s content, and Windows XP helps you every

inch of the way.

4 On the other hand, if you are trying to convert audio CD tracks to MP3
format (a process called ripping), Windows XP won’t help much — for
many reasons, but two stand out:

e Microsoft would have to pay a royalty for the technology that allows
audio CD tracks to be converted to MP3. Microsoft doesn’t want
to pay a royalty for every copy of Windows XP that’s sold, so it
doesn’t ship fully functional MP3 ripping technology in the box
with Windows XP. You have to pay extra for it, find the ripper some-
where else and install it on your machine, or get the ripper some
other way — perhaps along with your MP3 player.
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e Microsoft has no incentive for building MP3 ripping technology into
Windows XP. Some wags (this one included) feel that Microsoft
could’ve done something more to support MP3 ripping if it wanted to
badly enough. But it doesn’t want to. Microsoft wants the world to
change to its own WMA audio file format for a bunch of reasons, not
the least of which is the fact that WMA discourages piracy.

4+ No matter where you stand on the ethical questions surrounding piracy,
Microsoft can clearly make a lot of money helping companies sell (non-
pirated) music files. It doesn’t make squat from pirated copies.

Windows XP does not include DVD support, straight out of the box. Again,
licensing considerations take the brunt of the blame. Unless DVD playback
software came with your DVD player or PC, you have to find, pay for, and
install DVD playback software before Windows XP will play DVDs.

Windows XP also includes digital camera support that’s automatic, full-
featured, and probably better than the software that shipped with your
camera. Add the slide show feature built into Windows Explorer, and digital
imaging takes a giant leap forward.

Easy multiuser support
Windows XP/Home makes setting up multiple users on the same machine
very easy:

4+ Each user can have his or her own password or decide not to use a pass-
word at all.

4+ With Windows XP/Home, you don’t have to memorize user names or
passwords: one click and you're in.

4+ You can switch among users quickly and easily. So if your daughter
wants to check her Hotmail quickly while you go get a sandwich, all it
takes is a click.

4+ Your programs keep running when you switch users, unless you specifi-
cally close them down.

Windows XP/Pro, straight out of the box, retains the old you-gotta-know-
yer-user-id-and-password-to-get-in bias, and it won’t allow you to switch
quickly between users, but in a corporate environment with centralized
access controls, that makes sense. (You can change Windows XP/Pro to
make it act like Windows XP/Ho me, though — and you can add some pass-
word restrictions to Windows XP/Home accounts.)
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Making networks easy

Windows XP finally delivers on Microsoft’s promise to make simple network-
ing simple. That’s no small accomplishment, as anyone who’s struggled with
assembling and maintaining a network can readily attest. In most cases, put-
ting together a small network of Windows XP, 2000, Me, and 98 PCs is as easy
as connecting the wires and running a wizard. Really.

The good news extends well beyond the mechanics of pulling together a net-
work. Windows XP makes sharing an Internet connection among many
machines easy, whether they're running Windows XP, 2000, Me, or even
lowly Windows 98. Sharing a printer with any other computer on a network
takes a few clicks. Sharing a disk drive takes even less effort.

Do you need Windows XP/Pro?

Windows XP/Pro costs a whole heckuvalot more than Windows XP/Home,
but for many folks, both at home and at the office, Windows XP/Home beats
the pants off Windows XP/Pro. The arguments, both, uh, Pro and Con, may
get esoteric and techie very quickly. What’s a Dummy to do?

Fortunately, the situation isn’t nearly as difficult as you may think. In most
situations, if you get to pick the version of Windows XP that’s right for

you, you want Windows XP/Home. If somebody else makes the decision —
presumably a corporate IT department or some such — they probably
choose Windows XP/Pro, simply because it fits into the existing PC network
better.

You should buy Windows XP/Pro if

4+ You want to set up a secure, client/server network (see sidebar
“Workgroups and domains”). If you think Windows XP/Pro itself is expen-
sive, wait until you see the bill for this one.

4+ Your company wants you to use Windows XP/Pro. They probably have
good reasons to spend the extra bucks, mostly centered around secu-
rity, central administration, and automated backup.

4+ While you're on the road, you need to dial into your computer at work
and use it directly from your laptop. That demands a feature called
Remote Desktop, which runs only with Windows XP/Pro.

4+ The machine you're currently using runs Windows 2000 Pro (or Windows
NT 4), and you want to upgrade it directly to Windows XP, carrying
across all of your settings.

You can upgrade directly from Windows 98 or Windows Me to either
Windows XP/Home or Windows XP/Pro, and bring all of your settings with
you. See the next section, “Upgrading to Windows XP — A Brain Transplant.”
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Windows XP/Pro comes in handy in a corporate environment in a few minor Book |
ways. For example, it handles Roaming Profiles, which let you log onto any Chapter 1
computer on the network and retrieve your settings, and it has built-in secu-
rity hooks that let you get at folders even when the server is not working
(so-called Offline Folders) — but none of the other Windows XP/Pro features
are show stoppers.

What about Windows XP Media Center?

If you're an inveterate toy freak, you don’t need me to answer that question.
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But if you're kind of sitting on a fence, and you don’t want to throw away a
few thousand bucks on some piece of technology that’s sure to be obsolete
in a couple of years, consider this:

4+ Windows XP Media Center Edition (affectionately known as MCE) is a
program that runs on top of Windows XP. That means MCE inherits all of
the truly rich capabilities of Windows XP itself, including the Windows
Media Player, which is a crucial component of MCE.

In the same breath, it also means that MCE inherits all of the problems in
Windows XP itself, and adds another layer of bugs and potential security
problems. A quick glance through Microsoft’s Knowledge Base will rap-
idly confirm that even MCE gets the buggy blues.

4+ Some people love the MCE approach — a keyboard and TV-style remote,
typically sitting on a couch or coffee table, that let you get at the more
common multimedia capabilities functions quickly and easily. It’s a great
way to drive a big screen TV. Some people would rather just sit at their
PC to watch a movie, or prop a portable up on the coffee table and get
rid of the software middleman.

4+ On the other hand, Microsoft’s marketing clout means that all sorts of
new features — particularly the kind that require cooperation with satel-
lite and cable TV companies — are sure to appear on MCE systems at
the earliest possible instant. With MCE, you’re driving the best, and the
rest of the industry knows it.

No matter how you look at it, Windows XP Media Center Edition is still in its
infancy. Unlike many other Microsoft products, though, this youngster
appears to be here to stay.

Upgrading to Windows XP — A Brain Transplant

If your current machine runs Windows 98 or Me, you can upgrade to
Windows XP by simply starting Windows, inserting the Windows XP CD
into the CD drive, and following the instructions.
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If you decide that Windows XP isn’t your cup of tea, you can remove it and
restore your old Windows 98 or Me system, intact. Here’s how:

1. Choose Start=>Control Panel.

2. Click Add and Remove Programs.

3. Click Windows XP, and then click Add/Remove.

4. Pick the option to Uninstall Windows XP, and click Continue.

If your current machine runs Windows NT 4 or Windows 2000, you can
upgrade to Windows XP/Pro directly with the CD. However, you will not be
able to automatically uninstall Windows XP and revert to NT 4 or 2000.

QNG/ If your current machine runs Windows 95 or NT 3.x, you won'’t be able to
upgrade. Your only option is to erase Windows from your hard drive (never a
simple proposition) and perform a clean install from scratch (see the sec-
tion, “Considering a clean install,” for sobering enlightenment). Chances are
good that your Windows 95 or NT 3.x system isn’t powerful enough to run
Windows XP very well anyway. It’s far better to wait until you can afford a
new PC that comes with Windows XP preinstalled.

Windows Upgrade Advisor/Hardware

Compatibility List

Before you upgrade an existing PC to Windows XP, you should check the
machine to make sure there are no known problems. Microsoft distributes a
program called the Windows XP Upgrade Advisor that reaches into the
innermost parts of your PC and reports on potential problems with the
upgrade. You can download the Windows XP/Home Upgrade Advisor from
www.microsoft.com/windowsxp/home/howtobuy/upgrading/advisor.
asp. The Windows XP/Pro advisor is at www.microsoft.com/windowsxp/
pro/howtobuy/upgrading/advisor.asp. You may also find a copy of both
advisors on a free CD at your friendly local computer shop.

Microsoft used to publish a master list of all hardware that’s passed muster
for Windows XP — a so-called Windows Hardware Compatibility List — but
that useful tool has been supplanted by a piece of marketing fluff called the
Windows Catalog (www.microsoft.com/windowsxp/pro/upgrading/
compat.mspx). The Windows Catalog consists of paid advertising, which is
worse than useless. (The same could be said, in spades, about Windows
Marketplace.) Read the fine print at the bottom of the page: “The Windows
Catalog is provided for informational purposes only and Microsoft makes no
representations and warranties, either expressed, implied, or statutory,
regarding the products, manufacturers, compatibility of the products avail-
able within, or the Windows Catalog.” What a crock.




\NG/
s

\\J

Upgrading to Windows XP — A Brain Transplant 3 1

There’s a tremendous, unbiased list of Windows XP compatibility problem
reports covering every imaginable piece of hardware and software available
at www.ntcompatible.com/compatibility.html. In spite of its name, the
NT Compatible Web site deals with Windows NT, 2000, and XP.

Considering a clean install

Windows XP is an enormously complex program. In the best of all possible
worlds, if you upgrade from your current version of Windows — be it 98, Me,
NT 4, or 2000 — to Windows XP, the upgrade routines successfully grab all of
your old settings, get rid of the extraneous garbage that’s floating around on
your old machine, and install a stable, pristine copy of Windows XP, ready
for you to take around the block.

Unfortunately, the world is not always a pretty place, and your hard drive
probably looks like a bit-strewn sewer. Historically, Windows has been
considerably less stable for upgraders than for those who perform a clean
install — wiping out the contents of the hard drive and starting all over again.
All the flotsam and jetsam left from an old version of Windows invariably
mucks up the works with the new version.

A clean install is not for the faint of heart. No matter how hard you try, you
will lose data, somewhere, somehow — it always happens, even to those of
us masochists who have been running clean installs for a decade. If you
value everything on your computer, go for the simple upgrade. If you want
your PC to run smoothly, think about a clean install.

The following is my general procedure for a clean install, on computers that
can start from the CD drive, in very broad terms:

1. Download and install Revelation from SnadBoy software at www .
snadboy . com (see Figure 1-8).

Use Revelation for a few days (or weeks!) to retrieve any passwords that
you may have stashed away.

2. Make sure that you have current CDs for all the software that you
normally use.

If the programs require passwords/installation keys, you need the pass-
words, too.

3. Back up everything. Twice.

If you have a Windows XP computer handy, and you can attach it to the
PC that you're upgrading through a network or a direct-connect cable,
you may want to try a Vulcan Mind Meld, er, the Windows XP Migration
Wizard. Use it to transfer all your files and settings over to the other PC,
temporarily. Follow the instructions in the next section, “Using the
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Figure 1-8:
SnadBoy's
Revelation
lets you see
passwords
that appear

the screen.

Migration Wizard,” to pick up the settings before you perform the
upgrade and stick them on the temporary machine. Then follow the
instructions again to move them from the temporary PC back to your
(freshly upgraded) original PC.

B3 SnadBoy's Revelation =B =]
‘Crcled +' Cursor
D e s @ Check For Update | bout Exit |
Tosk B\t Ieier Caclas: Fanson [ avalabie] oy to cpboard
& Status Length of avalable text 0

Revelation idle.

I Reposition Revelation out of the way when dragging ‘circled + [ Always on top
I Wfhen mivimized, pul in System Tray I™ Hide How to' instiuetions

How to

1] Left click and diag [whie holding down the left mouse button] the ‘circled +

2] Az pou drag the 'circled +' cursor over diferent fields on vanous windows, the text in the field
undes the cursor will be displayed in the 'Text of Window..." box.

3] Releaze the left mouse button when pou have revealed the text you desire.

NOTE - If the field containg bext hidden by asterisks [or some other characher), the actual text wil be
showr |n zome cazes the tewt may actually be astensks.

NOTE - Mot ol of the fields that the cursor passes aver will have text that can be revealed. Check
the status bght for availablity of text.

Brighl green = test avalable [See Length of e’ in Stalus area)
Bright red = no text available

4. Insert the Windows XP installation disc in the CD drive, and then
choose Start~>Shut Down to go through a full shut down.

Windows XP may offer to install itself while you’re trying to shut down.
If it does, click Cancel. Power off the PC and wait at least a full minute.

5. Turn the power on.

If the PC is capable of starting (“booting”) from the CD, you see a line on
the screen that says something like Press any key to boot from CD.
Press the Enter key.

6. Go through the steps indicated by the installer to delete the primary
partition.

That wipes out all the data on the hard drive.

7. Pick your jaw up from the floor, kick yourself twice for being so obsti-
nate, pat yourself on the back for starting out fresh, and follow
through with the rest of the installation.

Windows XP does a good job of taking you through the steps. Just follow
along. The only really tricky part of the installation: Windows XP has to
restart your PC early in the installation process. When that happens,
you’ll probably get that Press any key to boot from the CD mes-
sage again. This time — the second time you see the message — ignore
it. Let Windows XP start itself from the hard drive.
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Clean installs rate right up there with root canals and prostate exams.
Nobody in their right mind will try one, unless they really want to make sure
that Windows will run smoothly. That said, I try to perform a clean install on
all of my systems at least once a year. It can make a big difference.

Using the Migration Wizard

Windows XP’s Files and Settings Transfer Wizard (better known as the
Migration Wizard) makes transferring certain kinds of settings and data files
between two computers comparatively easy. It sounds great and works
well, as long as you don’t expect too much. You need to be aware of several
limitations:

4+ The PC you're transferring files and settings “to” must be running
Windows XP. If at all possible, it should be connected to the PC that you're
transferring settings “from.” The “from” PC can be running Windows 95,
98, Me, NT 4, 2000, or XP.

The Files and Settings Transfer Wizard can send a humongous amount of
data from one PC to another. You can schlep diskettes from one machine
to another, if you have a few spare hours (or days). Far better, though, is
if you can get both PCs talking to each other on a network. Failing that,
you can buy a special cable called a “Serial PC to PC Transfer Cable” that
plugs into the serial slots on both PCs (the slots you may be using for
printers). The wizard will work with any of ’em.

4+ The wizard can’t install your old programs on your new PC. You have to
do that yourself, manually, one at a time, generally from the original CDs
that the programs came on.

If you use the Files and Settings Transfer Wizard but you don’t install all
of your old programs on your new PC, weird things may happen on the
new PC. You may double-click on a file in Windows Explorer, for example,
and have Windows XP say that it can’t find the program associated with
the file. Outlook may have trouble displaying a file attached to a message.
Nothing earth-shattering will happen, mind you, but it can be annoying.

4+ The wizard picks up only data files and some Windows Registry entries.
That means you can’t expect it to pull across all of your passwords, and
some copy-protection schemes (on games, for example) may go haywire.

On the plus side, though, the Files and Settings Transfer Wizard doesn’t pick
up much of the garbage that seems to accumulate in every Windows PC, which
means you can use it without gumming up your new computer. Too much.

Here are the kinds of things you can expect to go across in a transfer:
4+ Data files from your Windows desktop, the My Documents folder (includ-

ing My Pictures and My Music, if you have those in the My Documents
folder), and the Shared Desktop and Documents folders.
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4+ Other files scattered around your hard drive(s), as long as Windows rec-
ognizes them as common data files.

The Files and Settings Transfer Wizard really chooses which files to
transfer based on the filename extension. It looks for filename exten-
sions that are commonly associated with data files, such as .doc or
.Jpg. See the section on showing filename extensions in Book I,
Chapter 3 for a lengthy tirade on this topic.

4+ Settings for Windows (desktop, screen savers, taskbar options, and the
like), Windows Explorer, Internet Explorer (including your list of
Favorites), and Outlook Express.

4+ All of your Microsoft Office settings.
To use the File and Settings Transfer Wizard, follow these steps:

1. Make sure Windows XP is up and running on the “to” PC.

Get your hardware installed, set up your users, and run Windows XP
long enough to be familiar with it.

2. Log on the “to” PC as the user who’s supposed to receive all the files
and settings from the “from” PC.

If both the “to” and “from” PCs are connected to your network, choose
Start=>My Network Places or Start>My Computer to make sure that the
network connection is up and kicking. If they aren’t connected to the
same network, get a Serial PC to PC Transfer Cable and attach it to the
serial ports on both PCs.

3. Choose Start->Files and Settings Transfer Wizard, if it’s on the Start
menu.

If it isn’t, choose Start=>All Programs=>Accessories=System Tools=>
Files and Settings Transfer Wizard.

4. Follow the steps in the wizard (see Figure 1-9).

The exact steps vary depending on the method you're using to transfer
the data. If you have many large documents or picture files, plan on
spending a few hours. If you're transferring by diskette, don’t be sur-
prised if it takes a day.

If you perform a scorched-earth clean install of Windows XP (see the preced-
ing section), you can use the Files and Settings Transfer Wizard twice to drag
most of your data (but none of your programs!) through the upgrade, even
though you delete everything on your hard drive in the process of upgrad-
ing. All it takes is an intermediary machine running Windows XP that holds
your settings while the old PC is wiped clean. For the first run of the Files
and Settings Transfer Wizard, use the intermediary machine as the “to”
machine. Then upgrade the old PC. Finally, run the Files and Settings
Transfer Wizard again, this time using the intermediary machine as the
“from” machine. Works like a champ.
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When you buy a copy of Windows XP in a shrink-wrapped box, you're
allowed to install it on one — and only one — PC.

When you buy a new PC with Windows XP preinstalled, Windows stays with
the PC. You can’t transfer Windows XP from the original, bundled machine
to a different machine. Microsoft uses a technique called “BIOS locking” to
make sure that the copy of Windows XP that ships with a PC stays tied to
that specific PC, forever and ever. See Fred Langa’s expose at www. Tanga.
com/newsletters/2001/2001-09-10.htm for a detailed explanation of
what’s involved.

There are some ifs, ands, and buts floating around (for example, what if you
upgrade to Windows XP and the next day your PC suddenly dies?), but in
general, you can’t copy Windows XP and pass around pirate CDs to your
buddies or install a single copy on all the machines in your home. If you have
three PCs, and you want to run Windows XP on all of them, you have to buy
three copies of Windows XP, either in shrink-wrapped boxes or preinstalled
on new machines.

Corporate licenses are a little different. I talk about them at the end of this
section.

Windows XP enforces this one-Windows-one-PC licensing requirement with a
technique called Windows Product Activation, or WPA. Here’s how WPA
works:

1. The Windows XP installer makes you type the unique 25-character
code that’s printed on the case of your Windows XP CD.
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Figure 1-10:
The
Windows
Product
Activation
Wizard.

Product Activation

Later, the Product Activation program looks at various serial numbers
inside your PC — the processor, network card, and disk drives, among
others — mixes them together, and produces a second 25-character
code that identifies your PC. Those 50 characters, taken together, are
called the Installation ID.

2. When you activate Windows XP (see Figure 1-10), you give Microsoft
that 50-character Installation ID.

Microsoft checks to see whether anybody else has submitted the
25-character code from the case of the Windows XP CD.

¢ If nobody else has activated that 25-character code from the CD case,

or if the 25-character code has been activated with that specific
Installation ID (which means you activated this particular copy of
Windows XP from the same PC twice), Microsoft sends back a
42-character Confirmation ID. Both the Installation ID and the
Confirmation ID are stored on your PC.

If that 25-character code has already been used on a different PC,
though, you get a polite message on your machine saying,
According to our records, the number of times that you
can activate Windows with this product key has been
exceeded. Please enter a different product key, and
then click Retry. You're given further instructions for contacting
Microsoft, if you feel the need.

B, Activate Windows

Let's activate VWindows

To help redu it Y, ur copy of Windows n fivation over the
Internetis guick an

You don’t need to give your name or other personal information when you activale Windows.
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3. Every time Windows XP starts, it recalculates the 25-character code
that’s based on the various serial numbers inside your PC.

If the code matches the one that’s stored on your PC, and the
Confirmation ID is good, Windows takes off.

4. On the other hand, if the recalculated 25-character code doesn’t
match your original code, pandemonium breaks loose.

Your hard drives start spinning at twice their normal speed, your key-
board gets short-circuited with your PC’s power supply, and the local
constabulary receives an urgent fax from Redmond with a preapproved
no-knock search warrant. Okay, okay. 'm exaggerating a little bit. Here’s
what really happens:

¢ If Windows decides that you've only made a few changes to your
PC — replaced a hard drive, say, or even changed the motherboard —
it lets you start Windows anyway.

e On the other hand, if Windows determines that you've made too
many changes, it refuses to start and insists that you contact
Microsoft for a new Confirmation ID. That starts the activation cycle
all over again. Microsoft has full details at www.microsoft.com/
piracy/basics/activation and www.microsoft.com/technet/
prodtechnol/winxppro/evaluate/xpactiv.mxpx.

If you bought your PC with Windows XP preinstalled, it was activated before
you ever got it.

If you bought and installed Windows XP yourself, though, the activation time
clock takes over. From the day you install Windows XP, you have 30 days to
activate it. Windows tries to get you to activate it while you’re installing.
Failing that, it continues to remind you, relentlessly, as the 30 days tick away.
Reinstalling Windows XP won’t bypass the activation requirement.

Activating via the Internet makes the whole process of generating, sending,
and receiving ID codes invisible: All you know is that the process worked,
and you can continue to use the software you bought. If you activate by tele-
phone, though, you have to be sitting at your computer with your Windows
XP installation CD handy. You get to read a bunch of numbers to the rep on
the other end of the phone line, and she reads a bunch of numbers back to
you so that you can type them into the WPA Wizard.

Surprisingly, Windows XP still works a little bit, even after the activation
period has expired, and even though it won’t start. For example, a modem
attached to a PC that hasn’t been activated can still dial out, if it’s set up for
Internet Connection Sharing.
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Figure 1-11:
You can
(and should)
activate
without
registering.

As the Activation Wizard screens emphasize (see Figure 1-11), activation is
not the same as registration. When you activate Windows XP, your computer
sends Microsoft a 50-character Installation ID — and nothing else. When you
register Windows XP, you send Microsoft your name, address, telephone
number, and any other information that the screens can extract from you.

Activation is a given: You have to activate Windows XP or it dies.
Registration, on the other hand, is entirely optional — and basically useless
for Dummies everywhere. (What? You think Microsoft wants your mailing
address to send you a product recall? A birthday card? Sheeesh.) You have
no reason in the world to register Windows XP. Don’t do it.

Big companies with big bucks don’t have to put up with Windows Product
Activation. (One guess why.) Any company that buys Windows XP via a site
license — that is, buys many copies at a time — gets a special version that
doesn’t require activation.

If you hear rumors on the Internet about a key that magically bypasses
Windows Product Activation, chances are very good that it’s a corporate key
that somebody is passing around the Net. Microsoft can, and has, blocked
access to Service Packs and updates for people who used the most widely
available and well-known pirated keys. (Don’t confuse these hamfisted,
widely disseminated pirate keys with the results of “keygen” programs,
which produce unique, untraceable, fully functional keys. Big difference.)
Cracking Windows XP is illegal, immoral, and fattening. Don’t do it.

B, Activate Windows

Register with Microsoft?

While you are
ragister your c

Registration is optional and is not required to activate Windows.

n, with your consent, nofify you of product updates, new products,

youl are activating VWinde

To continue, click Mext
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What if the Wheels Fall Off? Book

Chapter 1
So what should you do if Windows XP dies?

4+ If you got Windows XP bundled with a new PC, scream bloody murder at
the vendor who sold you the %$#@! thing. Don’t put up with any talk
about “it’s a software problem; Microsoft is at fault.” If you bought
Windows XP with a new PC, the company that sold you the machine has
full responsibility for making it work right.
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4+ If you upgraded from Windows 98 or Windows 98 SE to Windows XP, you
can always uninstall Windows XP and go back to your old operating
system, as unpalatable as that may seem. Follow the instructions in the
section, “Upgrading to Windows XP — A Brain Transplant.”

4+ If you upgraded from Windows NT 4 or 2000 and you didn’t go through a
clean install, try that. You don’t have much to lose, eh? Follow the
instructions in the section, “Considering a clean install.”

4+ If you've done a clean install and Windows XP still falls over and plays
dead, man, you have my sympathies. Check with your hardware manu-
facturer and make sure you have the latest BIOS version installed. (Make
sure you get an instruction book; changing the BIOS is remarkably easy,
if you follow the instructions.) Hit the newsgroups online, check out the
NT Compatible Web site, wew.ntcompatible.com/compatibility.
htm1, or drop by my WOPR Lounge, www.wopr.com/Tounge, to see if
anybody there can lend a hand. If all else fails, admit defeat, and reinstall
your old operating system. Again, life’s too short.
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Chapter 2: A Windows XP
Orientation

In This Chapter

1+ Logging on

v Adding users

+* Moving around the desktop

1 Working with windows (that’s “windows” with a wittle w)

Fis chapter explains how to add new users, and how to find your way
around the Windows windows. If you're an old hand at Windows, you
know most of this stuff — such as mousing and interacting with dialog
boxes — but I bet some of it will come as a surprise. If you're new to
Windows, this is the place where you start paying your dues. In particular,
you find out things such as how to add and delete users, and why you may
want to avoid Microsoft Passport. Not to worry. When you get past the ter-
minology, the concepts won’t hurt a bit.

Most of all, you need to understand that you don’t have to accept all of the
defaults. What'’s best for Microsoft isn’t necessarily best for you, and a few
quick clicks can help make your PC more usable, more secure, and more . . .
yours.

Controlling Who Gets On

Windows XP assumes that, sooner or later, more than one person will want
to work on your PC. All sorts of problems crop up when several people
share a PC. I get my screen set up just right, with all my icons right where

[ can find them, and then my son comes along and plasters the desktop with
a shot of Alpha Centauri. He puts together a killer teen Media Player playlist,
and “accidentally” deletes my Grateful Dead playlist in the process.

It’s worse than sharing a TV remote.

Windows helps keep peace in the family — and in the office — by requiring
people to log on. The process of logging on (also called signing on) lets
Windows keep track of each person’s settings: You tell Windows who you
are, and Windows lets you play in your own sandbox.



42 Controlling Who Gets On

@‘“\NG! Having personal settings that activate when you log on to Windows XP isn’t
S heavy-duty security, at least in the Home version of Windows XP. (Windows
XP/Pro beefs up security substantially, particularly if you’re connected to a
big corporate network, but makes you jump through many more hoops.) In
Windows XP/Home, your settings can get clobbered, and your files deleted,
if someone else tries hard enough. But as long as everybody sharing the PC

cooperates, the Windows XP logon method works pretty darn well.

The Welcome screen

When it’s ready to get started, Windows XP greets you with a Welcome
screen — variously called a “Logon screen” or a “Signon screen” as well —
like the one shown in Figure 2-1. The screen lists all the users who have been
signed up to use the computer. It may also show a catch-all user called
“Guest.” (I guess that sounds better than “Other” or “Hey, you!”)

Duangkhae

—_— I n "
Figure 2-1:
The
Welcome
screen To begin, click your user name
helps
Windows
keep users
from
bumping
into each
other. [®) Turn off Justin's Laptop

You can set up a Guest account to grant very limited capabilities to anyone
who hasn’t been formally set up on that specific PC. (I explain how to set up
the Guest account and new users in the next section, “Adding users.”) Unless
you assign a password to a specific account, nothing prevents a guest —
friend, foe, or mother-in-law — from clicking on one of the other icons and
logging on under an assumed identity: In general, Windows XP/Home relies
on the gentlemanly conduct of all participants to keep its settings straight.

And if you can’t rely on gentlemanly conduct, you need to set up a password.
I talk about how you do that in the section, “Changing user settings.”
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Adding users ookt
After you log on by clicking your name on the Welcome screen, you can add P
more users quite easily. Here’s how:
>
(=}
1. Choose Start=>Control Panel->User Accounts. = §
= Q.
You see the User Accounts window, as shown in Figure 2-2. s g
=2
T
[ User Accounts == =]
: File Edit View Favorites Tools Help i i
Q Back = ] - ) ssarch Foders | [T1:]w
[ Address O User Accounts v| e
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\f. Appearance and Themes

Figure 2-2: Learn About ® 5]
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account

maintenance

in the User

Accounts J 93
screen.

2. Click the task marked Create a New Account.
3. Enter an account name and click Next.

You can give a new account just about any name you like: first name, last
name, nickname, titles, abbreviations. No sweat. Even weird punctuation
marks make it past the Windows censors: The name “All your base@!"”
works fine.

4. Tell Windows if you want the account to be a Computer Administrator
account or a Limited account. Click Create Account.

The choice of Administrator versus Limited account status isn’t nearly
as straightforward as Microsoft’s description would lead you to believe.
[ have the whole skinny in the section, “Using account types,” later in
this chapter, but [ swear by this easy litmus test: If the person who will
be using this account is gullible or new to the seamier side of Windows,
give ’em a Limited account.

You're done. Rocket science. The name now appears on the Welcome
screen.
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Figure 2-3:
Turn on the
Guest
Account
from this
User
Accounts
screen.

The Guest account is a special Limited account that comes in handy if many
different people need to use a computer, but you don’t want any of them to
be able to get at important information — or run potentially destructive pro-
grams. To make the Guest account available on your computer

1. Choose Start=>Control Panel=>User Accounts.
You get the User Accounts dialog box in Figure 2-2.

2. In the lower-right corner, click the icon that says User Accounts.

Windows shows you a User Accounts dialog box with all of the users
listed (see Figure 2-3).

3. If the Guest account is off, click the Guest icon.
Windows asks if you want to turn on the Guest account.

4. Click the button marked Turn On the Guest Account. Then click the X
button to close the User Accounts window.

From that point, Windows will show “Guest” as an account on the
Welcome screen.

If you only have a few people who sporadically use your PC, take the time to
set up Limited accounts for each of them. That way, your PC will save their
settings and make them available the next time each person logs on. But if
you have more than a handful of guests, enable the Guest account, and have
all of them use the Guest account.

€1 User Accounts ==
€

Learn About
|2] User accounts
7] User account Eypes

2| Switching users
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Don’t enable the Guest account unless you need it. One more account is just Book |

one more potential hole for a slobbering cretin virus writer to exploit. Chapter 2
Changing user settings oz
If you pick an account from the User Account screen, which you bring up by ) 5
choosing Start=>Control Panel=>User Accounts, Windows immediately pres- s g
ents you with five options. (See Figure 2-4.) Click on any of these options to g ;
begin the chosen task. Here’s what the options entail: o

4 Change the name: Modifies the name displayed on the Welcome screen
and at the very top of the Start menu, while leaving all other settings
intact. Use this option if you want to change the name on the account
only — for example, if “Bill” wants to be called “William.”

Gives the user a new picture 1D

Changes the user's name

-L User Accounts -

o]
(]

Related Tasks ;
What do you yant to change about

Creaks anew account Duangkhae's pccount?

Change the name Duangkhae
Computer adrinistratoe
B Create a pasaword

Charge the picture. —

Change another account

harge the account type ——

B Delete the accourt

Figure 2-4:
Maintain
another
individual’s
account.

Deletes the account

Makes this user enter a password
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4+ Create a password: Requires users to enter a password whenever they
start Windows. They can’t get past the Welcome screen (using their own
account) without it. This is a weird setting because you can change it for
other people: You can force “Bill” to use a password when none was
required before. Worse, you specify the initial password when you set up
an account this way, so Bill would have to pry the password out of you
before he can log on.

Passwords are cAse SenSitive — you must enter the password, capitals
and all, precisely the way it was originally typed. If you can’t get the
computer to recognize your password, make sure the Caps Lock key is
off. That’s the number one source of logon frustration.

If you decide to put a password on your account, take a couple of min-
utes to run the Forgotten Password Wizard (choose Start=>Help and
Support and type forgotten password wizard). This nifty little program
creates a diskette that you can use to unlock your password and get into
your account, even if your precocious seven-year-old daughter changed
it to MXYPLFTFFT. You have to run the wizard just once; the diskette it
creates will always unlock your account.

4+ Change the picture: Changes the picture that appears next to the user’s
name on the Welcome screen, the Start menu, and in the User Accounts
areas. You can choose a picture from any of the common file types: GIF,
BMP, JPG, or PNG. Windows offers a couple dozen pictures to choose
from, but you can reach out and grab any picture, anywhere. If you pick
a big picture, Windows automatically scales it down to size.

4+ Change the account type: Lets you change accounts from Computer
Administrator to Limited and back again. The implications are some-
what complex; [ talk about them in the next section.

4+ Delete the account: Allows you to deep-six the account, if you're that
bold (or mad, in all senses of the term). Windows offers to keep copies
of the deleted account’s My Documents folder and desktop, but warns
you quite sternly and correctly that if you snuff the account, you take
along all the e-mail messages, Internet Favorites, and other settings that
belong to the user. Definitely not a good way to make friends.

Okay, I fibbed — you can’t make all of those changes to other peoples’
accounts if you're a lowly Limited user. In fact, you must be a designated
Computer Administrator before Windows grants you such power. But therein
lies a different, muddled story, which I relate to you in the next section.

Using account types

All Windows XP/Home users can be divided into two groups: the haves and
the have-nots. The haves are called Computer Administrators. The have-nots
are called Limited. That’s it. “Limited.” Kinda makes your toes curl just to
think about it.
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A Limited user, running his Limited account, can only do, uh, limited things:

4+ Run programs that are installed on the computer (but he can’t install
new programs)

4 Use hardware that’s installed on the computer (but he can’t install new
hardware)

4+ Create and use documents/pictures/sounds in his My Documents/
My Pictures/My Music folders, as well as in the PC’s shared folders

4+ Change his password or switch back and forth between requiring a pass-
word for his account and not requiring one

4+ Change the picture that appears next to his name on the Welcome
screen and the Start menu

On the other hand, Computer Administrators can change anything, any-
where, at any time, with the sole exception of getting into folders marked
Private. Computer Administrators can even change other users’ passwords —
a good thing to remember if you ever forget your password.

In order to mark a folder as Private — and thus keep other users from get-
ting into it — you must be using the Windows NT file system, known as
NTFS. If Windows XP was installed on your computer when you bought it,
chances are good that it’s using NTFS. If you upgraded from Windows 98 or
Me to Windows XP/Home, though, there’s a very big chance you aren’t using
NTFS. To find out if you're using NTFS, and to mark a folder as Private if it’s
possible, follow the steps detailed in Book I, Chapter 3, in the section about
making a folder private.

When you install Windows XP/Home, every account that’s set up is consid-
ered a Computer Administrator account. It may appear at first blush as if
every account should have Computer Administrator privileges. Ain’t so. If
you start Windows XP with a Computer Administrator account, and you acci-
dentally run a virus or a worm or some other piece of bad computer code,
you can Kiss your keister goodbye. On the other hand, if you start Windows
XP with a Limited account and then launch a worm, the amount of damage
the worm can do is, uh, limited by the restrictions on your account. In most
cases, that means the malware can delete files in My Documents, and proba-
bly in Shared Documents, but that’s just about the extent of the damage — in
particular, the virus can’t install itself into the computer, so it won’t run over
and over again, and it may not be able to replicate. Poor virus.

Most experts recommend that you use a Limited account for daily activities,
and only switch to an Administrator account when you need to install soft-

ware or hardware, or get at files outside the usual shared areas. Most experts
ignore their own advice: It’s the old do-as-I-say-not-as-I-do syndrome. It’s also
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Figure 2-5:
When you
bring up
your
account,
you have
the choice
of hitching
up to
Microsoft
Passport.

a bit of a head-in-the-sand approach, because viruses and other malware can
clobber stuff, even if you're running as a Limited user.

The best compromise I've found: Use Limited accounts for people who are
most likely to shoot themselves in the foot.

Avoiding Microsoft Passport

On the surface, Microsoft Passport dazzles as a wonderful idea: It’s a central
location where you can put all the consumer-related information you’ll need
to interact with vendors over the Web, not to mention chat with other
people using Windows Messenger, download stock prices, customize
weather forecasts, send and receive e-mail using Microsoft’s own Hotmail
e-mail service, open a bank account, trade stock, and on and on.

If you choose Start=>Control Panel=>User Accounts and then select your own
account in the User Account screen, you have the option of signing up for
Microsoft Passport — or linking your local PC to your existing Passport — as
shown in Figure 2-5.

How much do you trust Microsoft to protect your privacy? That seems to be the
root question when any discussion of Microsoft Passport hits the ether.
Most people don’t trust Microsoft much farther than they can throw a cow.
(With a tractor and two barns attached.)
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On the face of it, the Passport seems innocuous: Type in your name, pick an
ID and a password, and these wonderful features become available. Beneath
the surface, though, you have to realize that Microsoft holds the keys to all
of the Passport data. If you trust Microsoft (in this case, I do), the only real
problem with Passport is a growing sense of Big Brother’s imminent arrival.
If you don’t trust Microsoft, don’t give your personal information — even
something as simple as a list of your favorite stocks.

On the other hand, if you don’t sign up for Passport, you can’t use Windows
Messenger for instant chatting, can’t use Hotmail for e-mail on the Web, can’t
ask someone to take over the controls at your computer and help you with
Remote Assistance, can’t put Microsoft’s dubious stock ticker on your
Windows desktop, and on and on.

What’s a person to do?

Many folks strike a balance between privacy and convenience by getting a
Passport, but being very vigilant about the kinds of information they hand
over to Microsoft’s ever-expanding database. You may find that a workable
solution, too. Just be aware that Passport data collection can be a two-way
street: If you use a Passport to get onto a site, there’s a chance that the site
will send gathered information back to Microsoft. I don’t mean to make you
paranoid, but almost anything that you enter on any Web page hooked up to
Passport could end up sitting in a Microsoft database.

I cover Microsoft Passport extensively in Woody’s Windows Watch (my free
e-mail newsletter, www.woodyswatch.com), and each time I learn something
new about Passport, the new info seems to fall into the Big Brother category.
If you decide to use Passport, understand that Microsoft will hold any infor-
mation you enter. And make sure you stay on top of the latest developments
with Passport. It’s another one of those areas that requires constant vigilance.

Don’t be too surprised if you see reference to “.NET Passport” and maybe
“Windows Passport” in various trade publications. Passport has gone
through more skin changes than a rattler. Version 1.1 shipped in the original
Windows XP, but Version 2.0 came online shortly afterward, and then there
was Version 3.0 and . . . well, you get the idea. The Passport Privacy Policy
has been updated almost every month for years. No matter what you call

it — Microsoft Passport, Windows Passport, .NET Passport — and no matter
what version you're using, the basic idea behind Passport hasn’t changed.

At any rate, if you want to sign up for Microsoft Passport and have your
account on your PC linked to that big MS Passport logbook in the sky, follow
these steps:

1. Choose Start=>Control Panel=>User Accounts.

2. Choose your own account.

Book |
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3. Click Set Up My Account to Use a .NET Passport.

You are transported to Microsoft’s Web site, where you can consummate
the relationship.

Deleting yourself
AHA! I bet you saw it.

Did you compare Figure 2-4 to Figure 2-5? Bonus Dummies Merit Points if you
noticed the subtle difference. (One hundred Dummies Merit Points are
redeemable for one Severe Bragging Right at any local Dummies store. Tell
’em Woody sent ya.)

You can’t delete your own account.

Windows has to protect itself. Every PC must have at least one user signed
up as Computer Administrator. If Windows XP lost all of its Administrators,
no one would be around to add new users or change existing ones, much
less to install programs or hardware, right?

Although you and I could probably think of a few dozen ways to ensure that
a PC always has at least one Computer Administrator, Microsoft has chosen
a rather straightforward approach. First, you can’t turn yourself into a
Limited user if you're the only Computer Administrator left. Second, you
can’t delete your own account.

Betwixt the two of those requirements, Windows XP is assured of always
having a minimum of one Administrator available at its beck and call.

The Basics

As soon as you log onto the computer, you're greeted with an enormous
expanse of near-nothingness, cleverly painted with a pretty picture of a
wheat field. Or is it Bill Gates’ front yard? Hard to tell.

The desktop

Your Windows destiny, such as it is, unfolds on the computer’s screen. The
screen that Windows shows you every time you start is called the desktop,

although it doesn’t bear much resemblance to a real desktop. Try putting a
pencil on it.

The first time you start Windows, your desktop looks something like the one
shown in Figure 2-6.
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Figure 2-6:

The bone-

stock

Windows

XP/Home

desktop.
Programs sit  The Windows System status information
behind here taskbar

The current time, if you set the clock right

Although the number and appearance of objects scattered on your computer
monitor varies depending on who sold you the computer and what was
included when you bought it, chances are pretty good that you have only a
few pictures — they’re called icons — sitting on the desktop. In Figure 2-6,
one icon appears, the Recycle Bin icon, where Windows sticks everything
you’'ve thrown away.

P Your desktop probably looks different from the one in Figure 2-6. For one

thing, you're bound to have a handful of icons sitting around. If you bought a
new computer with Windows XP preinstalled, chances are good that the
manufacturer sold some desktop real estate to a software company or an
Internet Service Provider. (Oh yeah, the AOLs and Nortons of the world com-
pensate the Dells and HPs for services rendered.) If you see an icon you
don’t like, right-click it and choose Delete. Good riddance to bad rubbish.
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Yeah, yeah, [ know. The terminology stinks: The Windows desktop doesn’t
look like a desktop. And calling those little pictures “icons” seems a bit, uh,
iconoclastic, given that real icons are exquisite objets d’art, rendered in paint
on wood. The price of progress, I guess.

When you get past the verdant fields rolling across your screen, the rest of
the desktop isn’t very inspiring, although plenty of surprises await as you
begin clicking:

4+ Windows taskbar: Runs all along the bottom of the screen, keeps you
posted on what your computer is doing — which computer programs
are running, where you're visiting on the Internet, and almost anything
else that requires your attention.

4+ Notification area: Also known to techies as the system tray. This area sits
on top of the taskbar on the right side and tells you the time, but it also
lets you know what Windows is doing behind the scenes. For example, if
you're using a modem to connect to the Internet, little modem lights down
here reassure you that the connection hasn’t frozen. Other tiny icons in
the notification area may control your speaker volume or tell you if you're
logged on to Windows Messenger.

4+ Start button: Located in the lower left of the desktop. This button gives
you access to everything your computer can do. Click it and you see the
Start menu — menu being geekspeak for a list of things that you can
click. Look for all the details in Book I, Chapter 3.

The Windows desktop looks simple enough, but don’t fool yourself:
Underneath that calm exterior sits the most sophisticated computer pro-
gram ever created. Hundreds of millions of dollars went into creating the illu-
sion of simplicity — something to remember the next time you feel like
kicking your computer and screaming at the Windows gods.

Mousing

Your computer’s mouse serves as the primary way of interacting with
Windows, but you already knew that. You can click on the left mouse button
or the right mouse button, or you can roll the wheel in the middle (if you
have one), and the mouse will do different things, depending on where you
click or roll. But you already knew that, too.

P If you're left handed, you can interchange the action of the left and right
mouse buttons — that is, you can tell Windows XP that it should treat the left
mouse button as if it were the right button, and the right button as if it were
the left. The swap comes in handy for some left-handers, but most southpaws
[ know (including my son) prefer to keep the buttons as is, because it’s easier
to use other computers if your fingers are trained for the “normal” setting.
To switch left and right mouse buttons, follow these steps:
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1. Choose Start=>Control Panel=>Printers and Other Hardware->Mouse.
2. Click the Buttons tab.

3. Select the Switch Primary and Secondary Buttons check box.

4. Click OK.

Matking the mouse behave
Here are a few important rodent things you may not know:

4 To move an item on the Windows desktop — a process called dragging —
click the left button, move the mouse, and then release the button. On
laptops with a touch pad, you can tie your fingers up in knots trying to
replicate the click-move-release shuck 'n’ jive. Chances are good that the
touch pad recognizes a swift tap as the beginning of a drag. Check the
documentation and practice a bit.

Windows has a feature called ClickLock that can come in handy if you
have trouble holding down the left mouse button and moving the mouse
at the same time — a common problem for laptop users who have fewer
than three hands. When Windows uses ClickLock, you hold down the
mouse button for a while (you can tell Windows exactly how long) and
Windows “locks” the mouse button. To turn on ClickLock

1. Choose Start=>Control Panel=>Printers and Other
Hardwarer>Mouse.

2. On the Buttons tab, select the Turn on ClickLock check box.

3. Immediately click the Settings button and adjust the length of time
you need to hold down the mouse button for ClickLock to kick in.

Note that you can test the ClickLock time length setting by clicking next
to Settings for ClickLock and dragging the box around.

4+ You can roll over items on the desktop too quickly! When you're
spelunking around Windows XP trying to get a feel for what’s happening,
go slowly. The word for it is hovering — that’s when you let the mouse
pointer sit in one place for a few seconds. You'll be surprised at how often
Windows flashes information on the screen in response to hovering.

4+ Although almost everyone catches on to single-clicking, given a few tries,
many people have trouble with double-clicking, and here’s the reason
why: Windows ain’t that smart. If you click twice, Windows has to figure
out if you wanted to make two single-clicks or one double-click — and
that’s surprisingly difficult. Windows watches as you click. You have to
click twice, quickly and without moving the mouse in between clicks, for
Windows to identify the two clicks as a double-click. If you have trouble
getting Windows to recognize your double-clicks, you’re probably moving
the mouse just a bit too far between the clicks for a double-click to “take.”

Book |
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Q"N\BER
& If you have consistent problems with Windows recognizing your double-
clicks, try adjusting the double-click speed:

1. Choose Start>Control Panel=>Printers and Other Hardware-~>Mouse.
2. Click the Buttons tab.

3. Double-click the folder on the right side, as a test to see how much
leeway Windows gives you.

4. Adjust the Double-click speed slider as needed to suit your
leisurely lifestyle.

4+ The best way to get the feel for a new mouse? Play one of the games that
ships with Windows. [ recommend Minesweeper and Solitaire. Try click-
ing in unlikely places, double-clicking, or right-clicking in new and differ-
ent ways. Bet you’ll discover several wrinkles, even if you're an old hand
at the games.

Inside the computer, programmers measure the movement of mice in units
called mickeys. Nope, I'm not making this up. Move your mouse a short dis-
tance and it has traveled a few mickeys. Move it to Anaheim, and it’s put on a
lot of mickeys.

Pointers on pointers

When you move the mouse around on your desk, the pointer (also called the
cursor) on the screen moves around in concert. Table 2-1 shows the pointers
you encounter most often when using Windows. Click one of the mouse but-
tons while the pointer is sitting on something and it may (or may not) react.

Table 2-1 Standard Windows Mouse Pointers

When a Pointer It Means And Windows Is Trying

Looks Like This to Tell You This
Normal The mouse is ready for action. Move it

[}S around the screen, and point and click to get

work done.
Hot Windows has found a “hotspot” — a hyper-
‘{E’} linkin geekspeak — and if you click while

this pointer is showing, you are transported
to the linked location.

Ready to resize Hold down the left mouse button and move
I the mouse forward and backward on your
desk (“up” and “down” as you're looking at
the Windows desktop) to make a window
taller or shorter.
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When a Pointer
Looks Like This

It Means

And Windows Is Trying
to Tell You This

+—F

Ready to resize

Same as the preceding pointer, except it
makes the selected window fatter or skinnier
as you move the mouse left and right.

SV

Expand or shrink to fit

Click and drag on a window's corner, and the
picture expands or shrinks to fit.

8

Kinda busy

You can keep doing whatever you're doing,
but Windows may be a bit slow because it's
working on something else. If Windows gets
to be too slow, grab a latte.

Za

Out to lunch

Windows is really, really busy and doesn’t
want to be disturbed. You may be able to
move the pointer around a bit, but you won't
get much done.

_|_

Pick a pic

Windows expects you to draw or choose a
part of a picture (for example, if you're
selecting Uncle Ernie’s head for cropping).
When the pointer is like this, click in the
upper-left corner of the picture, hold down
the mouse button, and release it when you
get to the lower-right corner.

Move

Instead of resizing the selected area (see the
preceding), you move the entire selected
area, all at once.

%

Help

Click on something to get help. If you don't
want help, press Esc on the keyboard and
the pointer returns to normal.

—

Text allowed

Click when the mouse pointer looks like an I-
beam and you can type text where you
clicked.

Y

No way

Windows shows you this pointer if you're
trying to do something that can’t be done —
trying to move a printer into a word-
processing document, for example.

One other thing to note is what’s called skid pads. If you see a faint stair-step
triangle in the lower-right corner of a window, you can probably use the four
resizing arrows to make the window larger or smaller.

If Windows shows you one of its “busy” pointers, you go out to have a latte,
and lunch, and run through a quick 18 holes, and come back only to discover
that the busy pointer is still there, chances are pretty good that Windows is
hung. (That’s a technical term, okay? Don’t laugh. You can also say that
Windows went belly up or that it crashed or froze or died or bit the big one.)
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If Windows hangs, hold down the Ctrl key and, without letting go of it, press
the Alt key and, without letting go of the preceding two, press the Del key.
(That’s called a three-finger salute or a Vulcan Mind Meld.) The Windows Task
Manager appears, and you can (usually) use it to close down whatever is
ailing Windows.

If you encounter one of the resizing pointers while working with a picture,
remember that different programs use the resizing pointers differently: Some
may cut off (“crop”) parts of a picture as you resize it, while others may
stretch or shrink the picture as you drag. Usually, you can use some combi-
nation of the Shift and Ctrl keys to convince the program to behave itself:
Hold down the Ctrl key while resizing, for example, and the program may
start stretching the picture instead of cropping it. Experiment. If all else fails,
you can always start over again.

The point where typed text gets inserted onto the screen is called the inser-
tion point (more rocket science). Various word processors show the inser-
tion point differently, but Word uses a solid vertical line. Don’t be too
surprised if some old cuss — yours truly included — calls the insertion
point a “cursor.” That’s a throwback to the Cro-Magnon days when word
processors worked more like typewriters, and the blinking cursor kept track
of where text would go.

Using the right button

Windows XP allows you to right-click just about anywhere and choose from a
context-sensitive list of actions to be performed on the item you’ve clicked.
For example, you can right-click on a disk drive and choose to search the
disk drive; you can right-click on a printer and make the printer stop print-
ing. The choices that appear when you right-click on an item are called a
shortcut menu (sometimes also called a right-click menu or a context menu). In
Figure 2-7, you can see an example of the context menu that appears when
you right-click on a blank portion of the Windows desktop.

Figure 2-7:
The right-
click
shortcut
menu for the
Windows
desktop,
with
Microsoft
Office
installed.
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Mice need to be cleaned! If you start having problems with a sluggish

mouse — one that jumps, stalls, or doesn’t move around the screen the way
it should — you should immediately turn the beast upside down and clean
it. If you see a rubber ball, pop the lid off, take out the ball, blow on it, and
clean off the roller contacts inside (you may need a cotton swab and some
isopropyl alcohol). Regardless of whether the mouse has a ball, the feet need
to be cleaned from time to time — use your fingernails and scrape gently.

Windows

Most of the time that you spend working with Windows is spent working
with, uh, windows. The kind with the little “w” — the rectangles that appear
all over your screen. Each part of a window has a name and a specific
function.

Many people spend most of their time on the computer working in Word
2003, which is the word processor in Office 2003 and the word processor
used by Outlook 2003 for composing e-mail messages. You may have a copy
of it on your machine. Look at Figure 2-8 for an overview of the components
of the Word 2003 window, and what they represent.

Main menu Elevator Restore
(also called

The window title Title bar a thumb) Minimize | Close
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A few details worth noting

4+ The window title appears both in the title bar — that is, the bar across
the top of the window — and (usually) in the Windows taskbar, way
down at the bottom of the screen. That makes it easy for you to identify
which window is which and to switch among them by clicking on the
taskbar. (I say “usually” because sometimes the boxes in the taskbar get
stacked up; see the section on the Windows taskbar in Book I, Chapter 3.)

4 Clicking the Minimize button makes the window disappear but leaves
the title down in the Windows taskbar, so you can bring the window
back with just a click.

4+ Clicking the Restore button “restores” the size of the window. That is, if
the window doesn’t take up the whole screen and you click the restore
button, it expands to take up the full screen. On the other hand, if the
window is taking up the whole screen and you click on the restore
button, it reduces in size to occupy a portion of the screen. I have no
idea why that’s called restoring.

4+ Clicking the X button removes the screen entirely — even from the
Windows taskbar — most commonly by shutting down the program
that’s using the window.

Many windows can be resized by clicking and dragging an edge or a corner.
See the preceding section on “Mousing” for details.

Dialog boxes

When the computer interacts with you — that is, when it has a question to
ask, or when it needs more information in order to complete a task — it usu-
ally puts a dialog box on the screen. A dialog box is nothing more or less
than a window that requires your attention.

Figure 2-9 shows a dialog box that illustrates how the various standard
Windows components can be used to extract information from unsuspecting
Dummies.

Each of the parts of a window has a name:

4+ Title: A dialog box’s title appears at the top of the dialog box, but the
title rarely appears in the Windows taskbar. This is one of the ways that
a dialog box is different from a garden-variety window (see the preced-
ing section): You can usually hop directly to a regular ol’ window by
clicking in the taskbar. To find a lost dialog box, you frequently have to
hunt around.
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Those “things” that appear on dialog boxes are called controls. (Sounds a
whole lot better than “things,” true?) Windows comes with many con-
trols, and most of the controls you see from day to day are drawn from
the standard control toolbox. Standard controls are a real boon to us
Dummies because they work the same way, all the time, no matter where
you are in Windows.

4+ The X (Close) button: The X button almost always appears on a
dialog box, but the other two buttons that you often see on a regular
window — Restore and Minimize — rarely show up on dialog boxes.
Clicking the X button almost always makes the dialog box go away.

4+ Tabs: Those funny-looking index tabs (usually just called tabs) are sup-
posed to remind you of filing tabs. Click on a tab, and you bring up a
whole bunch of settings, which are usually related — at least, some pro-
grammer somewhere thought they were related.

P You can usually hop from one part of a dialog box to the next by press-
ing the Tab key. Press Shift+Tab to move backward. If you see an under-
lined letter in a dialog box — called an accelerator key — hold down the
Alt key and press the letter, and you go directly to that location. In some
dialog boxes, pressing Enter is the same as clicking OK (unless you’ve
used the Tab key to move around). In other dialog boxes, though, press-
ing Enter doesn’t do anything.
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4+ Spinners: These are almost always placed right next to numbers, with
the number hooked up so that it increases when you click the up arrow
and decreases when you click the down arrow. Sometimes you can
bypass the spinner entirely, select the number, delete it, and type what-
ever you want.

4+ Drop-down lists: These lists come in two different flavors. With one
kind, you're limited to the choices that appear in the drop-down list: If
the item you want is in the list, you just pick it; if the item isn’t there,
you’re up the ol’ creek without a paddle. The other kind of drop-down
list lets you type in whatever you want if your choice doesn’t appear in
the list. Programmers hate that kind of drop-down list because it lets
you do things like order anchovies and pepper sauce on your bagels.

4+ Check boxes: Check boxes let you say “yes” or “no,” independently, to a
whole bunch of choices; if you see a bunch of check boxes, you can pick
one or none or all of ’em. Option buttons, on the other hand, only let you
choose one out of a group — no more, no less.

Back in the good old days (he says, stroking his long, white beard),
option buttons were called radio buttons. They act like the buttons on a
radio: Push one, and a station plays; push a different button, and a differ-
ent station kicks in. You can’t have two different buttons pushed in at
the same time. Old-fashioned radios had mechanical buttons that would
pop in and out, reminiscent of the way Windows radio buttons work. But
you aren’t old enough to remember those old radios, are you? Me neither.

4+ Command buttons: These buttons tell the dialog box to get on with it.
Click a command button, and the dialog box does something.

Usually it’s pretty obvious when you can change things in a dialog box: Text
that can’t be changed generally appears against a gray background, for exam-
ple, whereas text that can be changed frequently appears on a white back-
ground. Unfortunately, programmers aren’t the most consistent folks in the
world, and sometimes what you see on the screen is a bit, uh, nonstandard.
Utterly random, in some cases.

Files and folders

“What’s a file?” Man, [ wish I had a nickel for every time I've been asked that
question.

Afile is a, uh, thing. Yeah, that’s it. A thing. A thing that has stuff inside of it.
Why don’t you ask me an easier question, like “What is a paragraph?” or
“What is the meaning of life, the universe, and everything?”

A file is a fundamental chunk of stuff. Like most fundamental chunks of stuff
(say, protons, or Congressional districts, or ear wax), any attempt at a defini-
tive definition gets in the way of understanding the thing itself. Suffice it to
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say that a Word document is a file. An Excel workbook is a file. That photo-
graph your cousin e-mailed you the other day is a file. Every track on Nine
Inch Nails’ latest CD is a file, but so is every track on every audio CD ever
made. Trent Reznor isn’t that special.

File and folder names can be very long, but they can’t contain the following
characters:

/N k2>

Files can be huge. They can be tiny. They can even be empty, but don’t
short-circuit any gray cells on that observation.

Three things I know for sure about files:

4+ Every file has a name.

4+ Files — at least, files that aren’t empty — contain bits, the 1s and 0s that
computers use to represent reality (a tenuous concept under the best of
circumstances).

4+ Windows lets you work with files — move them, copy them, create them,

delete them, and group them together.

Folders hold files and other folders. Folders can be empty. A single folder can

hold millions — yes, quite literally millions — of files and other folders.
Three things I know for sure about folders:

4+ Every folder has a name.
4+ Windows creates and keeps track of a whole bunch of folders, like

e The My Documents folder for each user on the PC. That’s where
Windows and Microsoft Office usually put new documents that you
create.

¢ The My Pictures and My Music folders inside each user’s My
Documents folders. Windows — including the Media Player — tend
to store your pictures and music files in these folders.

¢ The Shared Documents folder, which includes Shared Pictures and
Shared Music folders, to make it easy to share documents, pictures,
and music with other people who use your PC or other people on a
network, if you have one. For more info on sharing documents, see
Book I, Chapter 3.

4+ Windows lets you move, copy, create, delete, and put folders inside of
other folders.

Book |
Chapter 2
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If you set them up right, folders can help you keep track of things. If you toss
your files around higgledy-piggledy, no system of folders in the world will help.

To look at the files and folders on your machine that you're most likely to
bump into, choose Start=>My Documents. You see something like the list
shown in Figure 2-10.

The picture of My Documents that you see in Figure 2-10 comes from a part
of Windows called Windows Explorer, which can help keep your files and
folders organized. Many of the things that you can do in Windows Explorer,
you can also do elsewhere. For example, you can rename files in the Open
dialog box in Word by choosing File>Open — but it’s hard to beat the way
Windows Explorer enables you to perform powerful actions quickly and
easily. I talk about Windows Explorer in Book I, Chapter 3.

N If you're looking at My Documents on your computer, and you can’t see the
period and three-letter ends of the filenames (such as .doc and . x15s) that
are visible in Figure 2-10, don’t panic! You need to tell Windows to show
them — electronically knock Windows upside the head, if you will. I explain
how in Book I, Chapter 3 in the section about showing filename extensions.
Current folder Look on network Folders inside current folder
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Chapter 3: Running Windows
from Start to Finish

In This Chapter

v Showing filename extensions
v Taking control of your files
1 Getting to know a button named Start

v Logging off

In this chapter, I explain how to get Windows kick-started, and what you
should (and shouldn’t!) do to tell the beast where you want it to go.
Admit it. The first time you were told that you had to click the Start button
in order to tell your computer to stop, you felt like you’d fallen down the
rabbit hole, didn’t you?

Windows XP ships with built-in networking, and if you have a network, you
should be concerned about who can get at the files on your computer. This
chapter tells all, cutting through the techie bafflegab in a way that you can
understand.

This chapter includes the most important tip I have to offer new Windows
users, a tip that will pay for this book, all by itself, if it keeps you from get-
ting infected by just one virus. Details are in the later section, “Showing file-
name extensions.” Read it. Believe it. Tell your friends about it. Tattoo it on
the inside of your eyelids.

Starting with the Start Button

Microsoft’s subverting the Rolling Stones classic Start Me Up for advertising
may be ancient history by now, but the royal road to Windows XP still starts
at the Start button. Click it, and you get the Start menu, which looks some-
thing like the one shown in Figure 3-1.

The Start menu looks like it’s etched in granite, but it isn’t. You can change
almost anything on it:
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Figure 3-1:
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Start menu.
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4+ To change the name or picture of the current user, see Book I, Chapter 2.

4+ To remove a program from the “pinned” programs list or the recently
used programs list, right-click on it and click Remove from This List.

4 To add a program to the “pinned” programs list, use Windows Explorer
to find the program (see the section, “Using Windows Explorer,” later in
this chapter), right-click on the program, and click Pin to Start Menu.

If you bought a new computer with Windows XP preinstalled, the people
who make the computer may have sold one of the spots on the Start menu.
Think of it as an electronic billboard on your desktop. Nope, I'm not exagger-
ating. | keep expecting to bump into a Windows XP machine with fly-out Start
menu entries that read, oh, “Surveys have shown=>Near and far=>That
people who drive like crazy=>Are>Burma Shave.” You can always delete
those pesky Start menu billboards by right-clicking on them and choosing
Remove from This List.

Don’t expect a whole lot of consistency in the way adjacent Start menu items
behave.
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You may expect that the recently used program part of the Start menu would
list the programs you’ve used most recently. And it does. Sorta. Partly. Now
and then. Microsoft stacks the deck, so MSN Explorer (which connects to
Microsoft’s for-pay MSN service) may stay on the list a whole lot longer than
other programs.

Some programs are more equal than others, eh?

Internet

Windows XP ships with Internet Explorer 6 (IE6), Microsoft’s flagship Web
browser. To bring up IE6, choose Starte>Internet/Internet Explorer, and you’ll
be surfing on the Web, as shown in Figure 3-2.

Internet Explorer is so important that I devote Book IV to it.
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E-mail
Windows XP ships with a versatile e-mail program called Outlook Express.
Outlook Express also handles newsgroups, the places on the Internet where

people can freely exchange ideas, gossip, tips, and fertilizer. Choose Start>
E-mail/Outlook Express and it appears, as shown in Figure 3-3.

v?‘“\NG! If you bought a PC with Microsoft Office installed, you are undoubtedly using
5 Outlook — which, in spite of the sound-alike name and superficial similari-
ties in appearance, is very different from Outlook Express. Trying to under-
stand Outlook by reading about Outlook Express is like trying to understand
cars by reading about incarnation. This Dummies book covers Outlook
Express. It doesn’t cover Outlook. No way, no how. (If you want more infor-
mation about Outlook, check out Outlook 2003 For Dummies by Bill Dyszel,
published by Wiley Publishing, Inc.)
Outlook Express lets you compose and read e-mail messages. It also has an
address book and a program for reading Internet newsgroups. I talk about
Outlook Express at length in Book Ill, Chapter 3.
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Media Player

Windows XP includes Microsoft’s Media Player, a multifaceted tool for play-
ing, organizing, ripping, and burning audio and video files.

If you're new to the topic, don’t be flummoxed. The terminology is a bit
obtuse, but if you've lived with computers for more than a few days, you're
already accustomed to clear-as-mud jargon. Here are the biggies:

4+ MP3: A way of storing digital music that’s become very popular because
it allows you to squeeze big audio files into tiny MP3 files, without much
degradation in sound quality. MP3 stands for MPEG3, but nobody cares
about that anyway. My son insists that MP3 means “Mario Party 3.” It
does.

4+ WMA: Microsoft’s challenger to MP3 (short for Windows Media Audio).
A typical WMA file is about half the size of a corresponding MP3, so you
fit about twice as many songs into the same amount of room. In addition,
music publishers can use WMA to limit the number of times a file is
copied or the period of time a WMA track can be played. Copyright
protection is the number-one reason why music publishers love WMA,
and the number-one reason why many normal folks aren’t really happy
about it.

4+ Ripping: The process of converting audio CD tracks into MP3 or WMA
format computer files. You stick an audio CD into your PC, and Windows
Media Player (or another ripper) pulls the audio tracks off the CD and
converts them into MP3 or WMA files.

4 Burning: What you do when you create — or write to — a CD. It’s also
what you do if you are trying to make a living from music that’s being
ripped off by copyright abusers.

Choose Start=>Windows Media Player (or Start=>All Programs=>Windows
Media Player), and you see the odd-shaped amoeba shown in Figure 3-4.

My Documents, My Pictures, My Music

Figure 2-10 in Book I, Chapter 2 shows you the contents of my My
Documents folder. (I guess that makes it a list of my My Documents docu-
ments, right?) Windows Explorer lets you look at your folders in various
ways, called views, and you can switch from view to view depending on what
you’re trying to do, your mood, or the phase of the moon.

The view shown in Figure 2-10 in Book [, Chapter 2 is called Tiles view; it is,
at once, the most visually impressive and the most cumbersome view
Windows offers. If you get tired of seeing those big icons and you choose

Book |
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Viewr>Details, you get the succinct list shown in Figure 3-5 (alternatively, you
can click the Views button and choose a view from the list that appears).

Figure 3-4:
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The following are the views you can use:

4+ Thumbnails: Shows small versions (called thumbnails) of graphics files,
along with a few surprises: tiny pictures of the first slide in PowerPoint
presentations, small pictures of enclosed graphic files on file folders,
even album cover art on identified My Music albums.

4+ Tiles: Gives large icons but makes no attempt to show you a small ver-
sion of picture files. Documents are identified by what application
“owns” them and how big they are.

4+ Icons: Trims down the large size of the Tiles but sacrifices document
details.

4+ List: Simply lists filenames. This view is a good choice for looking at fold-
ers with lots and lots of files.

4+ Details: Shows filenames, sizes, and types. In most folders, the Details
list also includes the date when the file was created, but for music and
pictures, artist names and titles appear.

In Details view, you can sort the list of files by clicking on one of the
column headings — name, size, and so on. You can right-click on one of
the column headings and click More to change what the view shows (get
rid of Type, for example, and replace it with Author).

4+ Filmstrip: Shows thumbnails of pictures across the bottom of the screen,
with a Play button below the selected picture, as shown in Figure 3-6.
(This view is available only in picture folders.)

Within the My Documents folder sit two more folders that you can get to
directly from the Start menu. If you choose Start=>My Pictures, the Windows
Explorer appears with the My Pictures folder open. Choose Viewr>Filmstrip
and your pictures look like the ones shown in Figure 3-6.

Double-click on a picture and it appears in the Windows Picture and Fax
Viewer. At that point, you can easily zoom in and out on the picture, print it,
copy it to a floppy, or even change the picture.

If you choose Start=>My Music, and then choose Views>Thumbnails, you see
the My Music folder (shown in Figure 3-7), which appears with its own spe-
cial set of actions in the pane on the left.

If you use the Windows Media Player to rip audio CDs, it places all the songs
from a single CD into a folder, tucks each of those folders into a big folder for
each artist, and puts the artists’ folders into My Music. The covers appear,
up to four on a folder, when you use Thumbnail view.

Book |
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My Recent Documents

Windows keeps track of documents as you open them, maintaining a list of
documents that you have opened most recently. Taking a leaf from the “HUH?”
School of Computer Design, Microsoft’s Usability Lab decided that Windows
XP/Pro users should see the list on the Start menu, whereas Windows XP/Home
users should not. If you like, you can tell Windows that you want to be able
to get at that list. Here’s how:

1. Right-click Start and click Properties.
2. Click the Customize button.

3. Click the Advanced tab.

4. Select the List My Most Recently Opened Documents check box, and
then click OK twice.
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Windows Media Player
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When the Most Recently Opened Documents list is enabled, an entry called
My Recent Documents appears on your Start menu. If you choose Start~
My Recent Documents, Windows presents you with a list of the 15 docu-
ments that you opened most recently (see Figure 3-8). If you want to open a
listed document again, pick it from the list, and Windows does the rest.
Take this list with a grain of salt. Windows doesn’t always get all of the files
listed correctly.
\\J

If you want to wipe out the list of files that you've opened recently — hey,
ain’t nobody’s business but your own — try this:

1. Right-click Start and choose Properties.

2. Click the Customize button.

3. Click the Advanced tab.

4. Click Clear List, and then click OK twice.

All of the entries in your My Recent Documents menu disappear.
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My Computer

Choose Start>My Computer, and Windows shows you the highest level of
folders on your machine, in addition to a list of all the drives (see Figure 3-9).
You can use this bird’s-eye view to “drill down” to various nooks and crannies
in your folders and in the folders of all the other people who use your PC.
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For a traditional (that is, pre-Windows XP) view of the contents of your com-
puter that enables you to easily navigate down to the lowest level, click the
Folders icon. You see all of your folders and how they’re interrelated in the
pane on the left (see Figure 3-10).

Click the Folders icon to see the full hierarchy of folders
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Control Panel

The inner workings of Windows XP reveal themselves inside the mysterious
(and somewhat haughtily named) Control Panel. Choose Start=>Control
Panel to plug away at the innards (see Figure 3-11).

I cover various Control Panel components (they’re called applets) at various
points in Windows XP All-in-One Desk Reference For Dummies, but the lion’s
share of the discussion appears in Book I, Chapter 7.

The main components of the Control Panel are as follows:

4+ Appearance and Themes: Change what your desktop looks like —
wallpaper, colors, mouse pointers, screen saver, icon size and spacing,
and so on. Set screen resolution (for example, 1024 x 768 or 800 x 600)
so that you can pack more information onto your screen — assuming
your eyes (and screen) can handle it. Make the Windows taskbar hide
when you’re not using it, and change the items on your Start menu.
Change what Windows Explorer shows when you’re looking at folders.
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Figure 3-11:
The Control
Panel.
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4+ Printers and Other Hardware: Add or remove printers and connect to

other printers on your network. Troubleshoot printers. Set up and
modify Windows faxing. Install, remove, and set the options for scanners
and digital cameras. Control the options on mice, game controllers, joy-
sticks, and keyboards. Set up dialing rules and other modem arcana.

If you use a modem for your Internet connection, Windows faxing may
not do what you expect. You may have to disconnect from the Internet
before you send or receive a fax, for example. Many people use J2 fax
(www. j2.com) because it treats faxes like e-mail. Outbound faxes are
converted to e-mail on your PC using J2’s programs, and then they are
sent to J2, which routes the fax to a local fax machine at your destina-
tion, thus bypassing long-distance telephone charges. Inbound faxes get
delivered to your e-mail inbox.

Network and Internet Connections: Set up a network. Configure
Internet Explorer and its startup page, history files, cookies,
AutoComplete, and so on. Set up Internet connections, particularly if
you’re sharing an Internet connection across a network, or if you have a
cable modem or DSL.

User Accounts: Add or remove users from the Windows welcome
screen. Enable the “Guest” account (see Book I, Chapter 2). Change
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account characteristics, such as the picture, password requirement,
direct connection with .NET Passport, and so on.

4+ Add or Remove Programs: Add and remove specific features in some
programs (most notably Windows XP).

4+ Date, Time, Language, and Regional Options: Set the time and date —
although double-clicking the clock on the Windows taskbar is much
simpler — or tell Windows to synchronize the clock automatically. Here
you can also add support for complex languages (such as Thai) and
right-to-left languages, and change how dates, times, currency, and num-
bers appear.

4+ Sounds, Speech and Audio Devices: Control volume, muting, and so on,
but those functions are usually better performed inside the Windows
Media Player. You can also choose a Sound scheme, which is something
like a desktop theme, except that it involves the pings and pongs you
associate with Windows events (for example, the music that plays
when Windows starts, or the cling! you hear when you try to click on
something you shouldn’t). Speech choices cover only text-to-speech
output — the “Danger, Will Robinson!” voice you hear when the com-
puter tries to read something out loud.

4+ Accessibility Options: Change settings to help you see the screen, use
the keyboard or mouse, or have Windows flash part of your screen when
the speaker would play a sound.

4+ Performance and Maintenance: Use an enormous array of tools for
troubleshooting and adjusting your PC, and making it work when it
doesn’t want to. Unfortunately, it also includes all the tools you need to
shoot yourself in the foot, consistently and reliably, day in and day out.
Use this part of Control Panel with discretion and respect.

Help and Support

Windows XP includes an online help system that’s quite good in places,
marginal in some areas, and very, uh, in tune with the Microsoft Party Line
everywhere. To bring up the system, choose Start>Help and Support. The
Help system (shown in Figure 3-12) connects to the Internet, if possible, and
updates its “hot topics” list.

[ cover the Help system inside and out in Book I, Chapter 4.

Search

Windows XP jumbles an odd assortment of “searchables” in the Search fea-
ture. Choose Start=>Search and you see what I mean (see Figure 3-13). I talk
about Search extensively in Book I, Chapter 5.
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Run

Harkening back to a kinder, gentler age, where you had to type (and type and
type and type) to get anything done at a computer, the Run box lets you type
program names and have Windows run the programs. It also recognizes Web
addresses.

What's that I hear? Scoffing? Perhaps a little snort and a rejoinder about
buggy whips and five-cent cigars? Oh ye of little faith!

Here. Try this. Choose Start=>Run, type calc (see Figure 3-14), and press Enter.
I defy you to find a quicker, easier way to run the Windows calculator.

Okay, okay. That calc thing isn’t much more than a parlor trick that you can
try at home. In fact, the Run box is pretty thoroughly outdated and something
you don’t want to use on a regular basis. You may find unusual situations
where you need it, but with any luck you’ll never encounter one of them.
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All Programs

Almost all of the programs on your computer are accessible through the All
Programs menu. To see it, choose Start=>All Programs. Figure 3-15 shows you
what the Games folder in All Programs looks like.
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Figure 3-15:
The Games
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the Start
menu’s All
Programs
menu.

Those right-pointing arrowheads that you can see to the right of Accessories,
Games, Microsoft Office Tools, and Startup in Figure 3-15 simply indicate that
you have more choices to make. You can let your mouse pointer hover over
an arrowhead-endowed Start menu entry and the pop-out menu appears. Or
if you're the impatient type, you can click on the menu entry to make the
pop-out appear faster.

Are you an inveterate Windows 98/Me/NT/2000 user who misses her old
Start menu — the single-column menu, with its little icons, that automati-
cally tucked away menus items you didn’t use very often? You can bring the
old buzzard back to life, if you insist, and have it replace this new-fangled
version of the Start menu. Here’s how:

1. Right-click Start and click Properties.
2. Click the Start Menu tab.

3. Choose the button marked Classic Start Menu and click OK.

Personally, | prefer the new Start menu to the old one, but it’s nice to
know that you can go back to the classic version, if you like.
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Organizing the contents of the All Programs menu is very easy: Chapter 3
4+ To copy or move an item on the All Programs menu to a different loca- I
tion on the All Programs menu, right-click it, drag it to the new location 23
(you can navigate anywhere on the menu, even into the pop-out menus), % =)
release the right mouse button, and choose Copy or Move. 2=
S =
4+ To sort all of the items on the All Programs menu alphabetically (with I §-
folders sorting higher than programs), right-click on any folder or pro- 73 5

gram and choose Sort by Name.

Getting Around

Your PC is a big place, and you can get lost easily. Microsoft has spent hun-
dreds of millions of dollars to make sure that Windows points you in the
right direction and keeps you on track through all sorts of activities.

Amazingly, some of it actually works.

Using Windows Explorer

If you're going to get any work done, you have to interact with Windows. If
Windows is going to get any work done, it has to interact with you. Fair 'nuff.

Computer geeks refer to the way Windows interacts with people as the
human interface. As far as I'm concerned, that jargon’s more than a little pre-
sumptuous. We poor, downtrodden Windows victims should refer to people-
machine interactions as the stupid computer interface. About time to put the
horse before the cart, sez I.

Now that you have the terminology turned right-side-out, you can easily
understand where Windows Explorer fits into the Grand Scheme of
WinThings. Windows Explorer lies at the center of the stupid computer inter-
face. When you want to work with Windows — ask it where it stuck your
wedding pictures, show it how to mangle your files, tell it (literally) where to
go — you usually use Windows Explorer.

If you choose Starte>My Documents or Starte>My Computer or Start>My
Pictures or My Music or My Network Places, Windows Explorer jumps to
your command like an automated bird dog, pointing at whatever location
you selected. When you run a search with Start=>Search, Windows Explorer
takes the reins.

This book is littered with pictures of Windows Explorer. If you look through
this chapter, you see Windows Explorer in many of its guises: working on the
My Documents folder (refer to Figures 3-5, 3-17, 3-18), My Pictures (refer to
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Figure 3-6), My Music (refer to Figure 3-7), My Computer (refer to Figures 3-9
and 3-10), and viewing the results of a search (refer to Figure 3-13).

Windows Explorer takes a snapshot of your hard drive and presents that snap-
shot to you. If the contents of the hard drive change, the snapshot is not auto-
matically updated, which can be a real problem. Say you’re using Windows
Explorer to leaf through the files in My Documents. You suddenly realize that
you need to write a letter to your Aunt Emma, so you start Word and write the
letter, saving it in My Documents. If you switch back to Windows Explorer,
you may not be able to see the letter to Aunt Emma: The snapshot may not
be updated. Disconcerting. To force Windows Explorer to update its snap-
shot, you can close it down and start it again, or you can press F5.

The following are some Windows Explorer high points:

4+ The name of the current folder appears in the title bar. If you click
once on a file or folder, details for the selected file or folder appear in
the Details box in the lower-left corner. If you double-click on a folder, it
becomes the current folder. If you double-click on a document, it opens.
(For example, if you double-click on a Word document, Windows fires up
Word and has it start with that document open and ready for work.)

4+ Almost any actions that you want to perform on files or folders show up
in the File and Folder Tasks list in the upper-left corner of Windows
Explorer. Provided you know the secret, that is! You have to click once
on a folder before the list of folder actions becomes visible; and you
have to click once on a file before you can see the list of file actions. So if
you're trying to copy a file, and you don’t see Copy File in the list of File
and Folder Tasks, click the file you want to copy first. When you do,
Copy This File shows up in the list of Tasks.

4+ You can open as many copies of Windows Explorer as you like. That
can be very helpful if you're scatterbrained like me . . . er, if you like to
multitask, and you want to look in several places at once. Simply choose
Start=>My Documents (or My Computer, whatever), and a totally inde-
pendent copy of Windows Explorer appears, ready for your finagling.

Creating files and folders

Usually, you create new files and folders when you’re using a program; you
make new Word documents when you’re using Word, say, or come up with a
new folder to hold all of your offshore banking spreadsheets when you’re
using Excel. Programs usually have the tools for making new files and folders
tucked away in the Filez>Save and Filem>Save As dialog boxes. Click around a
bit and you'’ll find them.

But you can also create a new file or folder directly in My Documents quite
easily, without going to the hassle of cranking up a 900-pound gorilla of a
program:
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1. Move to the location where you want to put the new file or folder.

For example, if you want to stick a new folder called Revisionist Techno
Grunge in your My Music folder, choose Start>My Documents and
double-click on the My Music folder. (If you want to show off, you could
just choose Starte>My Music, which does the same thing.)

2. Right-click a blank spot in your chosen location.

By “blank”  mean “don’t right-click on an existing file or folder,” okay? If
you want the new folder or file to appear on the desktop, right-click any
empty spot on the desktop.

3. Choose New (see Figure 3-16) and pick the kind of file you want to
create.

If you want a new folder, click Folder.

4. Windows creates the new file or folder and leaves it with the name
highlighted, so that you can rename it by simply typing.

Arrange Icons By k
Refresh

D Eolder

Shortout

Froperties
fj Eriefcase

%4 Bitmap Imaps

Ej Microsoft Word Document:

@ Microsoft Access Application

2] Microsoft PowesPoint Fresenitation
=l Test Document

&) Wave Sound

@ Microsoft Excel Workshest

B3 winzip File

Modifying files and folders

Modifying files and folders is easy — rename them, delete them, move or
copy them — if you remember the trick: Click once and wait.

The whole world’s in a rush. When I'm learning something new, I tend to try
a lot of different things all at once, and that plays havoc on computers.
They’re only human, ya know? When it comes to working with files and fold-
ers, it’s important that you wait for the computer to catch up with you. In
particular, when you’re trying to rename, move, copy, or delete a file, click
once and wait while the computer figures out what you can do and shows
you the legal choices in the File and Folder Tasks area.

If you double-click on a file, Windows interprets your action as an attempt to
open the file and start working on it. Double-click on a Word document, for
example, and Word springs to life with the document loaded, ready to rumble.
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If you simply click a file, though — just click once, and wait a second until
the computer catches up — Windows offers a whole range of options for
your consideration. In Figure 3-17, I clicked once on a Word document, and
Windows gave me all sorts of choices in the File and Folder Tasks area, over
on the left.

If you want to copy or move more than one file (or folder) at a time, select
all of the files (or folders) before choosing the action in the File and Folders
Tasks area. To select more than one file, hold down the Ctrl key while click-
ing, or click and drag around the outside of the files and folders to “lasso”
them. You can also use the Shift key if you want to choose a bunch of
contiguous files and folders — ones that are next to each other. Click the
first file or folder, hold down the Shift key, and click the last file or folder.
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The options for folders (see Figure 3-18) are a little bit different from those
for files. In particular, Windows allows you to share a folder but not a file —
Windows isn’t set up to share individual files. Windows allows you to print a
file but not all the files in a folder; to print all the files in a folder, you have to
go into the folder and print each file individually. But even though the details
are ever-so-slightly different, the principle remains the same: If you want to
muck around with folders or files, click once and wait.

Click once and wait is, far and away, the easiest way to rename, move, copy,
delete, e-mail, or print a file. It’s also the least error-prone because you can
see what you're doing, step by step.
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Showing filename extensions

I've been fighting Microsoft on this topic for many years. Forgive me if | get a
little, uh, steamed — yeah, that’s the polite way to put it — in the retelling.

Every file has a name. Almost every file has a name that looks more or less
like this: Some Name or Another.ext.

The part to the left of the period — Some Name or Another, in this
example — generally tells you something about the file. The part to the
right of the period — ext, in this case — is called a filename extension, the
subject of my diatribe.

Filename extensions have been around since the first PC emerged from the
primordial ooze. They were a part of the PC’s legacy before anybody ever
talked about “legacy.” Somebody, somewhere decided that Windows wasn’t
going to show filename extensions any more. (My guess is that Bill Gates
himself made the decision, about five years ago, but it’s only a guess.)
Filename extensions were considered dangerous: too complicated for the
typical user; a bit of technical arcana that novices shouldn’t have to sweat.

Garbage. Pure, unadulterated garbage.

The fact is that nearly all files have names like Letter to Mom.doc or
Financial Projections.x1sor ILOVEYOU.vbs. But Windows, in its infi-
nite wisdom, shows you only the first part of the filename. It cuts off the file-
name extension. So you see Letter to Mom, without the . doc (which brands
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the file as a Word document), Financial Projections without the . x1s (a dead
giveaway for an Excel spreadsheet), and ILOVEYOU without the . vbs (which
is the filename extension for Visual Basic programs). Table 3-1 lists many
common filename extensions.

Table 3-1 Common Filename Extensions

Extension Type of File

bas*, bat, exe, com, dll, vb, Different kinds of programs

vbs, vbe, js, jse

xt, asc Text

cpl, ini, inf, msi, pif, reg, scr System files

chm, hip, hta, htm, html| HTML files, typically for Web sites, Help, or formatted
e-mail

avi, bmp, gif, jpg, wmf, mpg Various kinds of graphic files

mp3, wav, wma, mid Sound files

doc, dot Microsoft Word

xls, xla, xIt Microsoft Excel

ppt, pot Microsoft PowerPoint

pst Microsoft Outlook

* ltalicized names indicate file types that have been used to propagate viruses and other malware. This
is far from an exhaustive list, and the guys in black hats are finding new approaches every day.

Every time you see a file mentioned in Windows, you see a little icon next to
the filename. For example, Word documents have an icon that looks like a
sheet of paper with a flying W on top. Excel worksheets sport grids with a
big X. PowerPoint presentation icons look like Pac Man in drag, but you get
the point. (Take a close look at Figure 3-17, and you’ll see what I mean.) The
icon is directly tied to the filename extension. All . doc files have the flying W
icon. All . x1s files get grids with Xs. All . ppt files get Pac Man. Uh, Pac Men.
Whatever. Graphics files — .gif and . jpg and . bmp among others — some-
times use a small rendition of the picture inside for the icon.

I really hate it when Windows hides filename extensions, for four big reasons:

4+ If you can see the filename extension, you can usually figure out what
kind of file you have at hand (refer to Table 3-1). That can be really
important when, for example, you get an e-mail message with a file
called ILOVEYOU attached to it. Millions of people — even experienced
Microsoft geeks, who should know better — received bogus messages,
opened the ILOVEYOU file, and got infected with the ILOVEYOU virus.
Many of those people would’ve been tipped off if they had told Windows
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that they wanted to see the full filename, ILOVEYOU. vbs. Bagle and
Netsky brought the world’s e-mail to a grinding halt by spewing plausible-
sounding files with hidden filename extensions.

4+ It’s almost impossible to get Windows to change filename extensions if
you can’t see them. For example, while writing this book, I wanted to
create a new text file called White.htm.Icouldn’t do it. Finally, I had to
haul in Windows Notepad and use an undocumented trick in the Save
dialog box to get the extension changed. (I typed “White.htm” with
quotes. Really intuitive, huh?)

4+ Microsoft Outlook forbids you from sending or receiving specific kinds
of files, based solely on the filename extension. If you can’t see the file-
name extension, you don’t stand a snowball’s chance of figuring out why
Outlook is being so draconian.

4+ You bump into filename extensions anyway. No matter how hard Microsoft
wants to hide filename extensions, they show up everywhere — from the
Readme. txt files mentioned repeatedly in Microsoft’s official documen-
tation, to discussions of . jpg file sizes on Web pages, and a gazillion
places in between.

To make Windows show you filename extensions, curl your right hand into a
ball, extend your index finger, and stick your thumb straight up in the air.
Point your index finger at your computer’s screen, make your eyes bulge
waaaaay out like Jim Carrey, and shout as hysterically as you can, “Show me
filename extensions, sucka, or I'm gonna getcha!”

Oops. Wait a second. I got carried away a bit. Sorry. To make Windows show
you filename extensions, follow these steps:

1. Bring up Windows Explorer (by, say, choosing Start->"My Documents).
2. Choose Tools=>Folder Options and click the View tab.

You see the Folder Views Advanced Settings dialog box, as shown in
Figure 3-19.

3. Deselect the Hide Extensions for Known File Types check box.

4. Click the Apply to All Folders button at the top of the dialog box, click
Yes, and then click OK.

While you're here, you may want to change two other settings if you can
avoid the temptation to delete or rename files that you don’t understand.
Select the Show Hidden Files and Folders option button if you want Windows
to show you all of the files that are on your computer. Also consider dese-
lecting the Hide Protected Operating System Files (Recommended) check
box. Sometimes you really need to see all of your files, even if Windows
wants to hide them from you.
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Sharing folders

Sharing is good, right? Your mom taught you to share, didn’t she? Everything
you need to know about sharing you learned in kindergarten — like how you
can share your favorite crayon with your best friend and get back a gnarled
blob of stunted wax, covered in mysterious goo.

Windows XP/Home supports four kinds of sharing. Unfortunately, “sharing”
means different things in different contexts, and the devil (as you surely
know by now) can be in Windows’ details. Here’s a quick guide to the four
kinds of sharing that you find lurking in various parts of Windows, how to
make them work, and what they really entail.

Sharing on one computer

The simplest form of sharing is with other people who use your computer:
They log on with a user name that’s different from yours, and you want them
to be able to get a specific file or folder. In fact, in Windows XP/Home, just
about anybody can get to any of your files, at any time. Sharing with other
people on your computer is more about making it easy for them to find the
files they need, as opposed to preventing them from seeing files that they
shouldn’t see. Thus, I think of this simple approach to sharing as “sticking
your file or folder in a place where other people may think about looking for
it.” It’s all about location, location, location.

Windows has a folder called Shared Documents that looks and acts a lot like
My Documents. Inside Shared Documents, for example, you find folders
called Shared Music and Shared Pictures.
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The Shared Documents folder has three cool but minor characteristics that
make it a special place:

4+ Windows Explorer makes it easy to get to the Shared Documents folder
with a link to Shared Documents in the Other Places box on the left side
of the screen. You can see it in Figures 3-5, 3-9, and 3-17. A Shared Music
link shows up on the left when you're in My Music (refer to Figure 3-7),
and Shared Pictures appears in My Pictures, too (refer to Figure 3-6). You
get the idea.

4+ The Shared Documents folder is shared across your network (if you
have one). I talk about sharing among computers on a network in the
next section.

4+ Limited users, such as the Guest account, can get into the Shared
Documents folder but not into other My Documents folders (see the sec-
tion about using account types in Book 1, Chapter 2 for details).

Aside from those three minor points, the only real advantage to putting a file
or folder in Shared Documents is the location: People may think to look
there when they go rooting around looking for stuff.

To put a file or folder in the Shared Documents folder — and thus make it
“shared” in this sense of the term — you have to physically move it. The fol-
lowing is the easiest way to do that:

1. Bring up Windows Explorer (choose, say, Start=>"My Documents), and
click on the files and/or folders that you want to put in the Shared
Documents folder.

2. In the File and Folder Tasks box on the left, click Move This File or
Move This Folder.

3. In the Move Items dialog box (see Figure 3-20), pick a location in or
under the Shared Documents folder where you want the chosen files
and/or folders to go.

To see the folders inside another folder, click the plus sign (+). Click the
folder where you want to move the document or folder.

4. Click the Move button.

The Windows XP documentation suggests that you click and drag the file(s)
and/or folder(s) that you want to share to the Shared Documents folder in
the Other Places box on the left of the Windows Explorer screen. I strongly
recommend that you not follow those instructions. Dropping the files in the
wrong “Other” place is too easy. More than that, using drag and drop gives
you no opportunity to see any folders that may be sitting underneath the
Shared Documents folder. That’s a sure way to stack tons of unrelated files in
one messy folder. It’s also an invitation to disaster — or at least massive con-
fusion — if Windows encounters duplicated folder names.
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Navigate to the Shared Documents folder, and click Move

After you move the file or folder, you may have a hard time finding it! For
example, if you use Word to create a document and you then move the docu-
ment to the Shared Documents folder, Word isn’t notified that the file has
been moved. In Word, if you choose File and then click the name of the docu-
ment, Word won’t be able to find it. Ditto if you use Word’s Task Pane to try
to open the document. The only way you can open the document from
within Word is to choose File>Open and browse to the file’s new location in
the Open dialog box.

Sneak-in-any-time-you-like sharing

The Windows Shared Documents approach to sharing files on a single
computer works, but it really doesn’t do much, particularly in Windows
XP/Home where any user (except a Limited user; see Book I, Chapter 2) can
get into any folder (except those marked Private; see the section, “Making a
folder private,” later in this chapter) with a couple of clicks.

I get a big kick out of Microsoft’s description of the Shared Documents folder,
in the Windows Help file. It goes like this: “Billy can put his homework in
Shared Documents so that Dad can check his work. And Mom can put digital
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pictures from the family vacation in Shared Pictures so that the whole family Book |
can see them.” Gawrsh. I can smell the bread baking in the oven. Or is that Chapter 3
the family cat frying in the microwave? BILLLLYYYYYY!

= >
Time for a dose of reality here, folks. If Billy is using Word to type up his S §
homework, he’ll probably save the work in his My Documents folder. (In fact, %é
if Billy’s as smart as I think he is, he’ll use a separate folder inside of My 2=
Documents for each class’s assignments.) Dad won’t have any problem o 5
finding the homework file. All he has to do is choose Startc>My Computer, 2.2

-

double-click Billy’s Documents, and double-click the homework file.

Mom can put the family photo album in Shared Pictures if she wants, but
Billy and Dad can find the pictures almost as easily in Mom’s My Pictures
folder. Again, they only have to choose Start>My Computer, double-click
Mom’s Documents, and double-click Mom’s Pictures, and they’re in like
Flynn.

Q&N\BEH Unless you take very specific steps to make a folder private (described in
& the upcoming section, “Making a folder private”), any file you put on a com-
puter running Windows XP/Home is immediately and easily available to
anyone who can stumble up to the mouse. Other people who use your com-
puter may take a gander inside the Shared Documents folder to find what
they’re looking for, but Shared Documents is only a convenient dumping
ground. There’s no security, no privacy, no way, no how.

Sharing on your network

This is real sharing.

Windows XP lets you identify specific folders (or entire disk drives) that are
to be shared with other people on your network. You can also tell Windows
whether those other people should be able to only read the files in the fold-
ers, or whether they are also allowed to change the files.
¢MBER
Windows XP does not allow you to share individual files across a network.
You can either share a folder (which may include other folders and certainly
includes files), or you can share an entire drive. But single files won’t work.

With Windows XP/Home, the sharing choices are quite straightforward: A
folder (or drive) is either shared or it isn’t. A shared folder (or drive) can be
read-only or read-write. That’s it. Anybody on the network can get at a
shared folder or drive. There’s no additional authorization, no secret pass-
word, no clandestine handshake, no list of who can get in and who can’t.

In Windows XP/Pro, security options are legion — and chances are very
good that you have little choice about security settings. That’s why there are
Network Administrators, eh?
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Windows sets up the Shared Documents folder, detailed in the preceding two
sections, for network sharing. So any files or folders that you move into the
Shared Documents folder are “automagically” shared across the network —

you needn'’t lift a finger.
Swer
s Before you try to share a folder or drive on your network, you have to set up
the network. D’OH! For instructions, see Book IX, Chapter 2.

If you don’t mind lifting a finger once or twice, you can easily share a folder
on your network:

1. Bring up Windows Explorer (for example, choose Start->My
Documents).

2. Right-click on the folder that you want to share, and choose Sharing
and Security.

3. In the folder’s Properties dialog box (see Figure 3-21), select the Share
This Folder on the Network check box.

Wow Properties 2]
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Local sharing and securky
1 Toshae this folder with olher users of this computer

:})‘ oy, diagit bo the Shared Documen)s folder.
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ooy pou have access, select the followng check box,

Metwaik sharing and zecuriy

W Toshae this folder with both network uzers and cther
L) uzers of this computer, select the first check box below
—— = 7 andlype a share name.

. [+] Share this fcider on the netck.
Figure 3-21:
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4. Type a name that other people on the network will find enlightening.

Officially, that name is known as a share name, but any ol’ moniker will
work.

5. If you want to give read-write access to every Tom, Dick, and Harry
who can get on the network, select the Allow Network Users to
Change My Files check box.
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Click OK, and the shared folder becomes accessible from all the computers
on your network. For example, if [ choose Starte>My Network Places on

a computer connected to the computer that holds the folder shown in
Figure 3-21, Windows Explorer lets me get into the newly shared folder, as
shown in Figure 3-22.
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en you share a folder on your network, all of the files and folders inside
shared folder are shared, too.

The process for sharing an entire drive is only slightly more difficult, but
considerably more intimidating, than sharing a folder:

1.

2.

Choose Start=>My Computer to bring up My Computer in Windows
Explorer.

Right-click the drive that you want to share.

Note that you can share CD drives, floppy disk drives, and just about
any kind of drive.

Choose Sharing and Security.

Windows responds with a rather odd statement: To protect your
computer from unauthorized access, sharing the root of a
drive is not recommended. If you understand the risk but
still want to share the root of the drive, click here.
(Bafflegab alert: The root of a drive is the whole drive, including all the
folders on the drive.)

Setting up an entire drive for sharing (by right-clicking the drive choosing
Sharing and Security) elicits a message from Windows about “the risk” of
sharing an entire drive. Somewhat predictably, I've never found an expla-
nation of “the risk” or its presumably dire consequences in any Windows
documentation. Suffice it to say that granting access to an entire drive lets
anybody on your network get at everything on the drive. If you're sharing
your C: drive, granting access to the drive probably includes the Windows
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folder (which contains Windows itself), the Program Files folders (which
contain most of the programs on your computer), settings for every-
body on the computer — the whole enchilada.

4. Click If You Understand the Risk but Still Want to Share the Root of
the Drive, Click Here.

5. Select the Share This Folder on the Network check box. Type a name
for the drive that’s intelligible to other people.

If you want to give everyone on the network write access, select the
Allow Network Users to Change My Files check box. Click OK and the
drive becomes accessible from anywhere on the network.

P When sharing CD drives, Jaz drives, and even floppy disk drives, including a
description of the drive in the share name is often a good idea. That way,
you know what the drive can handle before you try to use it, so you won’t
find yourself frustrated by repeated attempts to, oh, transfer a 2.3MB photo
to a 1.44MB floppy disk drive.

“Sharing” files on the Internet

When you put a file on the Internet, Microsoft calls it “sharing” sometimes
(see, for example, the Windows Help file on sharing) and “publishing” other
times (see the Windows Explorer File and Folder tasks box). I call it “stor-
ing.” There’s a difference, but I'll spare you the semantic argument.

Once upon a time, you could grab free storage space on the Internet and
park your files indefinitely: The companies that provided the free space also
ran advertisements to defray the costs. Alas, like so many other good ideas
that failed to meet the reality test, free Internet storage space seems to have
gone the way of the Tyrannosaurus Rex. Now, while you may be able to find
a “free” trial offer, in the end, you have to pay.

The files you store on the Internet can be for your use only. Or you can give
your friends and neighbors your site ID and password, and they can get at
your files, too. That’s where “sharing” comes into the picture: Store a file on
the Internet, give your buddy a password, and he can retrieve the file and
stick it on his computer.

Sharing a file on the Internet — I call it “storing” a file on the Internet — has
nothing to do with making your own Web site or cranking out a home page.
The sharing that’s accessible from Windows Explorer (Windows also calls it
“publishing”) is nothing more or less than the ability to store a file on the
Internet, much the same way as you would store the file on your own hard
drive — except that a several billion people can get at it, if they know the
password. To see if there are any low-cost alternatives accessible from
Windows XP, click Start>My Network Places and in the task pane on the left,
click Add a Network Place. You will probably be directed to MSN and offered
a free trial, but there may be other options.
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Matking a folder private

Under the right circumstances, Windows XP/Home allows you to designate
certain folders as Private. Private folders aren’t accessible to anyone other
than their owner.

In order to mark a folder as private, you must meet the following criteria:

4+ You must be using NTFS (the Windows NT File System) on the drive
that contains the folder. NTFS contains numerous security enhance-
ments that weren’t around in earlier Windows file systems. If you bought
your PC with Windows XP preinstalled, it’s likely (but not certain!) that
you're using NTFS on all of your drives. If you upgraded from Windows
NT or Windows 2000 to Windows XP, it’s likely (but again, not certain)
that all of your drives use NTFS. If you upgraded from Windows 98 or
Me, you probably aren’t using NTFS.

To see whether a drive uses NTFS, choose Start=>My Computer. Right-
click on the drive and pick Properties. The File System entry near the

top of the Properties dialog box should say NTFS. If it says FAT-32, you
won’t be able to mark a folder as private.

4 The folder has to be one of your folders. You can mark My Documents
as private, or you can mark any folder inside of My Documents (such as
My Pictures or My Music) as private. You can also mark any folder inside
your branch of the Documents and Settings folder. When you mark a
folder as private, every folder inside of that folder automatically
becomes private.

4 You should assign a password to your account. Windows allows you to
mark a folder as private even if you don’t have a password-protected
account, but it warns you that you're trying to do something very silly. If
your account is not password protected, anybody can pretend to be you
when they log on and simply open the private folder.

4 As soon as you have a password, you should run the Forgotten
Password Wizard and create a diskette that allows you to log on to the
PC if you forget your password! Make sure the diskette is stored in a
secure place. For more information on passwords and the Forgotten
Password Wizard, see the section about changing user settings in Book I,
Chapter 2.

Windows taskbar

If you have more than one program running, the fastest way to switch from
one program to another is via the Windows taskbar, as shown in Figure 3-23.

With a few small exceptions, each running program carves out a chunk of
space on the Windows taskbar. If more than one copy of a program is running
(not an unusual state of affairs for Windows Explorer, among others) or if a
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Figure 3-23:
The
Windows
taskbar
makes
switching
among
programs
easy.
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program has more than one file open (common in Word, for example) and
Windows runs low on real estate in the taskbar area, the chunks are grouped
together, with the number of open documents in front of the program name.

If you click on the button marked 4 Microsoft Word (as shown in Figure 3-23),
for example, you see a list of the four documents that Word currently has
open. Click on one of those documents, and Word comes up with that docu-
ment loaded for bear.

R Khun
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@ Bio Funny doc

@ Things I Wish I Knew Befor

o T 4 Microsoft Word

Word has four documents open

Internet Explorer has two Web pages open

Windows Explorer is looking at My Computer

The Windows taskbar has many tricks up its sleeve, but it has one capability
that you're likely to need. Auto-Hide lets the taskbar shrink down to a thin
line until you bump your mouse pointer way down at the bottom of the
screen. As soon as your mouse pointer hits bottom, the taskbar pops up.
Here’s how you teach the taskbar to Auto-Hide:

1. Right-click an empty part of the taskbar.

Usually the area immediately to the right of the Start button is a good
place.

2. Click Properties.
The Taskbar tab should be visible.
3. Select the Auto-Hide the Taskbar check box, and then click OK.

If you don’t want to hunt around for the mouse — or if your mouse has sud-
denly gone out to lunch — Windows XP has a feature called Coolswitch that
lets you switch among running programs, while (insert your best W.C. Fields
impression here) your fingers never leave your hands . . . er, your fingers
never leave the keyboard. Wink, wink. Just hold down the Alt key and press
Tab. When you get to the program you want, release the Alt key. Bam!
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Shorteuts

Sometimes life’s easier with shortcuts. (As long as the shortcuts work,
anyway.) So, too, in the Windows XP realm, where shortcuts point to things
that can be started. You may set up a shortcut to Word and put it on your
desktop. Double-click on the shortcut, and Word starts, the same way as if
you chose Start=>All Programs=>Microsoft Word.

You can set up shortcuts that point to the following:

4 Programs, of any kind
4+ Web addresses such as www.woodyswatch.com/signup

4+ Documents, spreadsheets, databases, PowerPoint presentations, and
anything else that can be started in Windows Explorer by double-
clicking on it

4+ Specific chunks of text inside documents, spreadsheets, databases,
presentations, and so on (they’re called scraps)

4+ Folders (including the weird folders that are inside digital cameras),
even the Fonts folder and others that you may not think of

4+ Drives (hard disk drives, floppies, CDs, Jaz drives, the works)

4 Other computers on your network, and drives and folders on those
computers

4 Printers (including printers attached to other computers on your net-
work), scanners, cameras, and other pieces of hardware

4+ Dial-up network connections
Shortcuts can do many amazing things. For example, you can set up a short-
cut to a specific network printer on your desktop. Then, if you want to print

a file on that printer, just drag the file onto the shortcut. Windows XP takes
care of all the details.

There are many different ways to create shortcuts.

Say you use the Windows calculator all the time, and you want to put a short-
cut to the Windows calculator on your desktop. Here’s an easy way to do it:
1. Right-click any blank spot on the desktop.
2. Choose New->Shortcut.
The Create Shortcut Wizard appears (see Figure 3-24).
3. Click Browse.

4. In the Browse for Folder dialog box, click My Computer, click the C:
drive, click Windows, and then click system32.
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Figure 3-24:
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Scroll way down to calc.exe (if you haven’t told Windows that you
want to see filename extensions, you see only “calc” — follow the
instructions in the earlier section, “Showing filename extensions,” to get
full filenames showing).

5. Click calc.exe and click OK.

6. Click Next, type a good, descriptive name like Calculator, and click
Finish.

Any time you double-click the Windows Calculator shortcut on your desk-
top, the Calculator comes to life.

You can use a similar procedure for setting up shortcuts to any file, folder,
program, or document on your computer or any networked computer.

Often, the hardest part about setting up a shortcut is finding the program
that you want the shortcut to refer to. In the preceding example, you saw
how the Windows Calculator is located in the system32 folder, which in turn
sits inside the Windows folder (techie shorthand is C: \Windows\system32).
Many other Windows programs are in the system32 folder. If you're looking
for the Microsoft Office XP programs, they’re probably in C:\Program
Files\Microsoft 0ffice\0fficel0, while Office 2000 programs are most
likely in C:\Program Files\Microsoft Office\0ffice. The Fonts folder
sits in C: \Windows. In general, if you're looking for programs, your best bet
is to look in the Program Files folder first and then in Windows.

You have many other ways to skin the shortcat . . . uh, skin the shortcut cat.
When you’re working in Windows Explorer, you can right-click many types of
files and folders, drag them to new locations — other folders, the desktop,
even the Start menu or the Quick Launch Toolbar — release the mouse
button, and click Create Shortcuts Here.
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Quick Launch Toolbar

While the taskbar can get cramped at times,
many Dummies are willing to give up a little bit
of taskbar room for a fancy one-click program
launcher called the Quick Launch Toolbar. The
Quick Launch Toolbar sits next to the Start
button (see the following figure), and you can
fill it with a handful of little icons that will start
your favorite programs.

Click for more Quick Launch programs

Start Internet Explorer

Start Outlook
Start Word

The Quick Launch Toolbar may already be visi-
ble on your machine, depending on how it was
set up. If it isn't visible, you have to turn it on
manually. To turn on the Quick Launch Toolbar,
follow these steps:

1. Right-click a blank part of the taskbar.

The area immediately to the right of the
Start button is a good place.

2. Click Properties.
You should see the Taskbar tab.

3. Selectthe Show Quick Launch check box,
and then click OK.

The Quick Launch Toolbar first appears with
three icons: Internet Explorer, Show the
Desktop, and Windows Media Player. If you've
installed Microsoft Office, Outlook probably
shows up as an icon in the Quick Launch
Toolbar, too.

You can add or delete icons on the Quick
Launch Toolbar — and resize the toolbar, too, if

you know the trick. Here's how to do both at the
same time, after you use the preceding steps to
show the Quick Launch Toolbar:

1. Right-click a blank part of the taskbar, and
deselect the Lock the Taskbar check box.

That allows you to resize the Quick Launch
Toolbar.

2. Bring up Windows Explorer (choose
Start=>My Computer, for example) and find
a program, document, or other file that you
want to put on the Quick Launch Toolbar.

Hint: if you have Office 2003 installed,
Word is probably C: \Program Files\
Microsoft Office\Officell\
winword.exe.

3. Click the file that you want to put on the
Quick Launch Toolbar and drag the icon to
your preferred location on the Quick
Launch Toolbar.

4. Right-click the new icon, and click
Rename.

Whatever name you type appears above
the icon when you hover your mouse over
the icon.

5. Repeat Steps 3 and 4 as many times as you
like, to bring in as many Quick Launch
Toolbar items as you like.

6. When you're done, click and drag the “per-
forated” line at the right edge of the Quick
Launch Toolbar, resizing it to take as much
(or as little) room as you like. Then right-
click a blank part of the taskbar and select
the Lock the Taskbar check box.

Judicious use of the Quick Launch Toolbar can
save you gobs of time.
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Q\g,p& STy, Believe it or not, Windows thrives on shortcuts. They’re everywhere, lurking

just beneath the surface. For example, every single entry on the Start menu
is a (cleverly disguised) shortcut. The icons in the Quick Launch Toolbar
are all shortcuts. Most of Windows Explorer is based on shortcuts —
although they’re hidden away where you can’t reach them. So don’t be
afraid to experiment with shortcuts. In the worst-case scenario, you can
always delete them. Doing so gets rid of the shortcut, but doesn’t touch the
original file at all.

Here’s yet another way to create a shortcut. Say you want to put a shortcut
to a network printer on your desktop. Try this:
1. Choose Start>Control Panel and click Printers and Other Hardware.
2. Click View Installed Printers or Fax Printers.

3. Right-click the printer that you want to be shortcutted. (Uh, the
printer you want the shortcut to go to? The shortcuttee? Somebody
run and get me the Funk and Wagnalls.)

4. Click Create Shortcut.

Windows displays the dialog box shown in Figure 3-25. You'll find that
“Create Shortcut” is a common option when right-clicking almost any-
thing in Windows XP.

5. Click Yes, and the shortcut that you wanted appears on your desktop.

Figure 3-25:

The quick

way to put

a shortcut 9 | Windows cannot creste a shorkcuk here,
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printer vee J[_me |

on your

desktop.

Recycling

When you delete a file, it doesn’t go to that Big Bit Bucket in the Sky. An
intermediate step exists between deletion and the Big Bit Bucket. It’s called
purgatory — oops. Wait a sec. Wrong book. (Existentialism For Dummies, any-
body?) Let me try that again. Ahem.

The step between deletion and the Big Bit Bucket is called the Recycle Bin.
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Figure 3-26:
The Recycle
Bin, where
all good files
go when
they kick the
bucket.
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Recycling

When you delete a file or folder on your hard drive — whether by selecting
the file or folder in Windows Explorer and pushing the Delete key, or by
right-clicking and choosing Delete — Windows doesn’t actually delete any-
thing. It marks the file or folder as being deleted but, other than that, doesn’t
touch it at all.

Files and folders on floppy drives, and on network drives, really are deleted
when you delete them. The Recycle Bin doesn’t work on floppies or on
drives attached to other computers on your network.

That’s a good news/bad news state of affairs.

The good news: If you ever accidentally delete a file or a folder, you can
easily recover the “deleted” file from the Recycle Bin.

The bad news: All of those deleted files take up space on your hard drive.
The space won'’t be reclaimed until you go through the steps necessary to
empty the Recycle Bin — and thus truly delete the files.

To rummage around in the Recycle Bin, and possibly bring a file back to life,
double-click the Recycle Bin icon on the Windows desktop. Windows
Explorer takes you to the Recycle Bin, as shown in Figure 3-26.

To restore a file or folder (sometimes Windows calls it “undeleting”), click on
the file or folder, and then click Restore This Item in the Recycle Bin Tasks
box in the upper-left corner. You can select a bunch of files or folders by
holding down the Ctrl key as you click.
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To reclaim the space being used by the files and folders in the Recycle Bin,
click Empty the Recycle Bin in the Recycle Bin Tasks box. Windows asks if
you really, really want to get rid of those files permanently. If you say yes,
they’re gone. Kaput. Curtains. You can never get them back again.

After you empty the Recycle Bin, the deleted files and folders are perma-
nently gone. If you've been keeping backups, though, you might be able to
resurrect an old file or folder. See the section on backup in Book I, Chapter 7.

Last things last, [ always say.

Windows XP/Home allows you to have more than one person logged on to a
PC simultaneously. That’s very convenient if, say, you're working on the
family PC checking Billy’s homework when you hear the cat screaming
bloody murder in the kitchen, and your wife wants to put digital pictures
from the family vacation in the Shared Pictures folder while you run off to
check the microwave.

The ability to have more than one user logged onto a PC simultaneously is
called Fast User Switching, and it has advantages and disadvantages:

4 On the plus side: Fast User Switching lets you keep all of your programs
going while somebody else pops onto the machine for a quick jaunt on
the keyboard. When they’re done, they can log off, and you can pick up
precisely where you left off before you got bumped.

4 On the minus side: All of the idle programs left sitting around by the
inactive (“bumped”) user can bog things down for the active user. You
can avoid the overhead by logging off before the new user logs on.

If you want to disable Fast User Switching, choose Start=>Control Panel and
click User Accounts. In the lower-right corner, click the icon marked User
Accounts. At the bottom of the Pick a Task list, click Change the Way Users
Log On or Off. Then deselect the Use Fast User Switching check box.

You probably won’t be surprised to find that you have to click Start in order
to log off or switch users. Simply choose Start=>Log Off, and then click
Switch User or Log Off.

To further confuse matters, many computers — especially portables — can
go into Hibernate or Standby mode (variously called Suspend, or Suspend to
File, or any of a handful of out-to-lunch synonyms). The primary differences
between the two modes are as follows:

4 In Standby mode, the PC shuts off the monitor and hard drives but keeps
everything in memory so it can “wake up” quickly.
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4 In Hibernate mode, the PC shuts off the monitor and hard drives and
shuffles a copy of everything in memory to the hard drive before going
night-night. It takes longer to wake up from Hibernate mode because the
contents of memory have to be pulled in from the hard drive.

If your portable runs out of power while in Standby mode, you're up the
creek without a paddle. If it’s in Hibernate mode (and Hibernate mode is
working properly — not always a given!), running out of juice poses no prob-
lem at all: Plug the PC back into the wall and it comes out of Hibernate mode,
brings its memory back from the hard drive, and picks up where you left off.

Not all computers support Standby mode or Hibernate mode. Some older
computers don’t handle either mode. Other computers can do both. If you
have a choice, the guidelines are quite simple:

4+ If there’s any chance that your PC will run out of power while in Standby
mode, don’t use it. Hibernate instead.

4+ If you have to bring your machine back up quickly (say, for a presenta-
tion, or to take sporadic notes), use Standby mode.

To go into Standby or Hibernate mode, choose Start>Turn Off Computer.
You see a dialog box with the recommended mode as your first option
(see Figures 3-27 and 3-28).

Turn off computer

Turn off computer

Cancel
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If your PC supports both Standby and Hibernate mode, hold down the Shift
key while the Turn Off Computer dialog box is on the screen. Windows
obliges by changing back and forth between Standby and Hibernate.

You should always turn your computer off the “official” way, by choosing
Start>Turn Off Computer=Turn Off. If you just flip the power switch off,
Windows can accidentally zap files and leave them unusable. Windows
needs time to make sure that everything is in order before turning the lights
off. Make sure it gets the time it needs by using the official method for shut-
ting down.



Chapter 4: Getting Help
with Windows XP

In This Chapter

+* Windows XP Help: A resource of first resort
1+ Remote Assistance
1 Searching for help in all the right places

+* More help when you’re ready to give up

' hink of this chapter as help on Help. When you need help, start here.

Windows XP ships with acres and acres — and layers and layers — of Help.
Some of it works well. Some of it would work well, if you could figure out
how to get to the right help at the right time.

This chapter tells you when and where to look for help. It also tells you
when to give up and what to do after you've given up. Yes, destroying your
PC is an option. But you may have alternatives. No guarantees, of course.

This chapter also includes detailed, simple step-by-step instructions for
inviting a friend to take over your computer, via the Internet, to see what is
going on and lend you a hand while you watch. I believe this Remote
Assistance capability is the most powerful and useful feature ever built into
any version of Windows.

This chapter shows you what you can do when you're ready to tear your
hair out.

Meet the Help and Support Center

When you choose Start>Help and Support Center, Windows XP presents
you with a wide array of choices. Many of the top-level choices that you see
in Figure 4-1 “drill down” to the same bits of information; by giving you
many different ways to get to that information, Microsoft hopes to make
finding what you need easier for you, even if you don’t know the answer to
your question in advance — a common problem in all versions of Windows
Help.
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— Tutorials and troubleshooters

— Tutorials Support groups
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— Mostly tasks

The Help and Support Center gives you only the Microsoft Party Line. If a big
problem crops up with Windows XP, you find only a milquetoast report here.
If you want searing insight or unbiased evaluations, look elsewhere. Like, oh,
in this book, for example.

Windows Help morsels fall into several categories:

4+ Overviews, articles, and tutorials: Explanatory pieces aimed at
giving you an idea of what is going on, as opposed to solving a specific
problem.

4 Tasks: Step-by-step procedures for solving a single problem or changing
a single setting.

4+ Walkthroughs: Marketing demos . . . uh, multimedia demonstrations of
capabilities that tend to be, uh, light on details and heavy on splash.

4+ Troubleshooters: Take you through a series of (frequently complex)
steps to help you identify and resolve problems.
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The Help and Support Center exists primarily to reduce Microsoft’s support
costs, which is both good and bad. Microsoft has tried hard to enable you to
solve your own problems. That’s good. At the same time, Microsoft has
made it pretty difficult to figure out how to pick up the phone and chat with
somebody in Product Support Services. That’s bad. I spill the beans — and
give you some much better alternatives — at the end of the section, “How to
Really Get Help,” later in this chapter.

The Help and Support Center window puts a happy face on an otherwise
sobering (and bewildering!) topic. After you click past the sugarcoating, you
find a few gotchas that you should know about:

4+ Few Dummies will want to jigger with the Search Options, except to
increase the number of hits that are reported (see the later section,
“Running an Effective Search”). The Help and Support Center already
looks in all the places it can; your only options are to cut off certain
types of searches entirely — and any limitations you apply carry for-
ward to the next search.

4+ Live, one-on-one support from Microsoft is notoriously uneven. One day
you get a support rep who can solve your problem in the blink of an eye.
The next day you spend hours on hold, only to be told that you need to
reformat your hard drive and reinstall Windows. If you get bumped up to
“Level 2” live support, you're more likely to find someone who knows
what he or she is doing, but you have to persist to “Level 3” before you
get to talk to a real, live, breathing guru. Few customers have the
patience or the savvy to convince Microsoft product support droids to
escalate their problem to Level 3.

4+ When Troubleshooters work, they work well, but they cover only the
most basic problems and the most direct solutions.

4+ Although Remote Assistance is a great idea, in practice the idea has
plenty of problems: Both you and your assistant have to be connected
to the Internet (or to the same local network); you should probably
establish a telephone connection prior to setting up the session; and if
firewalls exist between you, Remote Assistance might not work at all.
See the section, “Connecting to Remote Assistance,” later in this chapter,
for lots of details.

4+ Windows newsgroups on the Internet are unmoderated, which means
anybody can post anything. Many well-meaning support group partici-
pants dole out utterly execrable advice.

4+ Sometimes Windows Updates are worse than the problem they’re sup-
posed to fix. I usually wait for an update to be in general circulation for
at least a week before I apply it to my machine. That way, Microsoft has
a chance to withdraw or reissue problematic updates (of which there
are many). And [ wait at least a month to apply hardware driver updates,
unless they solve a specific problem that’s been killing me.
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4+ The Hardware and Software Compatibility lists leave much to be desired.
If a piece of hardware or software that you want to buy appears on the
list, it’s probably at least a little bit compatible. If it isn’t on the list, you
can’t really draw much of a conclusion.

It never hurts to run a System Restore checkpoint when Windows is firing on
all cylinders. The worst possible time to create a checkpoint? When your
system has gone to the dogs. Right now, while you're thinking about it and
Windows makes you smile from ear to ear, follow the instructions in Book I,
Chapter 7 to run a checkpoint. That way, when the inevitable falling out
occurs, you'll have something to fall back on.

How to Really Get Help

You use the Help and Support Center when you need help and support,
right? Well, yes. Sorta.

In my experience, the Help and Support Center works best when

4+ You want to learn about what functions big pieces of Windows perform,
and you aren’t overly concerned about solving a specific problem (for
example, “What is Windows Media Player”?).

4+ You have a problem that’s easy to define (“My printer won’t print”).

4+ You have a pretty good idea of what you want to do, but you need a little
prodding on the mechanics to get the job done (“How do I change my
desktop’s picture?”).

The Help and Support Center won’t do much for you if you have only a
vague idea of what’s ailing your machine, if you want to understand enough
details to think your way through a problem, if you're trying to decide on
what hardware or software to buy for your computer, or if you want to know
where the XP bodies are buried.

For all of that, and much more, you need an independent source of informa-
tion. Like this book, for example.

My Web site, www.AskWoody . com, can come in handy, especially if you're
trying to decide whether you should install Microsoft’s latest security patch
of a patch of a patch. AskWoody.com answers questions, too! Drop by from
time to time to see what’s happening.

If you can’t find the help you need in the Help and Support Center or at
AskWoody.com, expand your search for enlightenment in this order:
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4+ Far and away the best way to get help involves simple bribery. Buttonhole

a buddy who knows about this stuff, and get her to lend you a virtual
hand. Promise her a beer, a pizza, a night on the town — whatever it takes.
If your friend knows her stuff, it’ll be cheaper and faster than the alterna-
tives. If you can cajole your machine into connecting to the Internet —
and get your friend to also connect to the Internet — Windows XP makes
it easy for a friend to take over your computer while you watch with a fea-
ture called Remote Assistance, which I discuss in the next section,
“Connecting to Remote Assistance.”

If your buddy is off getting a tan at Patong beach, you may be able to
find help elsewhere on the Internet. See the section, “Getting Help on the
Web,” later in this chapter.

If all else fails, you can try to contact Microsoft by e-mail. You may qual-
ify for free e-mail support using something called Microsoft Online
Assisted Support. The best way to find out if you qualify, and connect
with a support droid if you do, is to jump through the prescribed hoops:

1. Choose Start=>Help and Support.

2. Under the Ask for Assistance list, click Get support, or find infor-
mation in Windows XP newsgroups.

3. In the Support box, click Get Help from Microsoft.

4. You connect to Microsoft’s support site on the Internet, and at that
point, you have a chance to review what support is available to
you and how much it will cost.

As a last resort, you can try to contact Microsoft by telephone. Heaven
help ya.

Microsoft offers support by phone — you know, an old-fashioned voice call —
but some pundits (including yours truly) have observed that you’ll probably
have more luck with a psychic hotline. Be that as it may, the telephone
number for tech support in the USA is (425) 635-3311; in Canada, it’s (905)
568-4494.

Connecting to Remote Assistance

Raise your hand if you've heard the following conversation:

Overworked Geek, answering the phone: “Hi, honey. How’s it going?”

Geek’s Clueless Husband: “Sorry to call you at work, but I'm having trou-
ble with my computer.”

OG: “What kind of trouble?”

GCH: “I clicked on the picture and it went into Microsoft, you know, and
[ tried to look at this report my boss sent me, but the computer said it
couldn’t.”
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OG: “Huh?”

GCH: I'm sure you've seen this a hundred times. I clicked on the picture
but the computer said it couldn’t. How do I look at the report?”

OG: “Spfffft!”

GCH: “What’s wrong? Why don’t you say anything? You have time to help
the other people in your office. Why can’t you make time for me?”

OG wonders, for the tenth time that day, how she ever got into this
bloody business.

At one time or another you may have been on the sending or the receiving
end of a similar conversation — probably both, come to think of it. In the
final analysis, one thing’s clear: When you’re trying to solve a computer
problem — whether you’re the solver or the solvee — being able to look at
the screen is worth ten thousand words. Or more.

Windows XP includes a feature called Remote Assistance that lets you call
on a friend to take over your PC. The interaction goes something like this:

1. You create a special message inviting your friend to take over your
computer and fix the problem.

2. You send the message to your friend, either by standard e-mail, via
MSN Messenger or Windows Messenger, or by giving your friend a file.

3. Your friend receives the message and responds by clicking on a spe-
cific link.

4. Your PC displays a message saying that your friend wants to take over.

5. If you give the go-ahead, your friend takes complete control of your
machine. You watch as your friend types and clicks, just as you would
if you knew what the heck you were doing. Your friend solves the
problem as you watch.

6. Either of you can break the connection at any time.

The thought of handing your machine over to somebody on an Internet con-
nection probably gives you the willies. 'm not real keen on it either, but
Microsoft has built some industrial-strength controls into Remote Assistance.
If you like, you can limit your friend to simply observing, instead of taking
over the controls of your computer. You can also require your friend to type
in a password before the session gets started. And you can put a time limit on
the invitation: If your friend doesn’t respond within an hour, say, the invita-
tion gets cancelled.

Plenty of pitfalls lurk around the edges of Remote Assistance, but it mostly
rates as an amazingly useful, powerful capability. The following are among
the potential problems:
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Both of you have to be connected to the Internet, or to the same local
network. If you can’t get connected to the Internet — especially if that’s
the problem you’re trying to solve — you’re outta luck.

If you have a dial-up Internet connection, you have to stay connected
from the time you create the invitation through the time you send the
invitation, while your friend responds, and all the way until the time that
the Remote Assistance session ends. You can’t hop on the Internet, send
an invitation, break your Internet connection, and then dial back an hour
later to get the Remote Assistance session going.

Both of you have to be running Windows XP or some other operating
system that supports Remote Assistance.

One of the following must be true so that you can send the invitation,
and your friend can use the invitation to get connected to your PC:

¢ Both of you have to be logged on to MSN Messenger or Windows
Messenger.

* You must be able to send, and your friend must be able to receive,
e-mail with an attachment that includes a hot link.

¢ You must be able to send a file to your friend — possibly over a net-
work or by simply handing your friend a floppy.

If a firewall is between either of you and the Internet, it may interfere
with Remote Assistance. Windows Firewall (the firewall that’s included
in recent versions of Windows XP) doesn’t intentionally block Remote
Assistance, but other firewalls may. If you can’t get through, either con-
tact your system administrator, or dig into the firewall’s documentation,
and unblock “Port 3389” — that’s the communication channel Remote
Assistance uses.

You — the person with the PC that’s going to be taken over — must initiate
the Remote Assistance session. Your friend can’t tap you on the shoulder,
electronically and say something like (with apologies to Dire Straits): “You
an’ me, babe, how ’bout it?”

When you’re ready to set up the connection for Remote Assistance, here’s
what you need to do:

1. Make sure your friend is ready.

Call him or shoot him an e-mail and make sure he’s going to have his PC
on, connected to the Internet, and running Windows XP. Also, make sure
that he will have MSN Messenger or Windows Messenger cranked up,
will be checking e-mail frequently, or will be waiting for you to hand him
a file or make one available on your network.

Make sure you can contact your friend using your selected method: If
he’s going to use MSN Messenger or Windows Messenger, make sure
you’re able to send messages back and forth; if you're using e-mail, make
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sure he’s in your Address Book and send him a test message to make
sure you have his e-mail address down pat; if you're going to send a
diskette by carrier pigeon, make sure the pigeon knows the route and
has had plenty of sleep.

2. When you contact your friend, make up a password and give it to him.

It doesn’t have to be fancy — a single letter or number will do — and it
shouldn’t be a password you use for anything else. It’s a one-timer that
will be valid only for this single Remote Assistance session.

3. Get on the machine that will be zombified (the one that your Remote
Assistance friend will take over), and make sure it’s connected to the
Internet.

4. Choose Start->Help and Support to bring up the Help and Support
Center (refer to Figure 4-1).

5. Under the Ask for Assistance list, click Invite My Worthless Brother-In-
Law to Rummage Through All Of My Secret . . . wait a sec . . . click
Invite a Friend to Connect to Your Computer Using Remote Assistance.

6. In the Remote Assistance pane, click Invite Someone to Help You.

7. You have three choices for notifying your assistant, as shown in
Figure 4-2.

A. If your assistant has MSN Messenger or Windows Messenger running,
and you have decided to contact each other that way, sign in to
Messenger. You have to pick your friend’s e-mail address and then
click Invite This Person.

B. If your assistant is waiting for an e-mail message from you, type his
address in the space provided and click Invite This Person.

It’s important that you send a Remote Assistance invitation to the right
person. You don’t want to invite just anybody to take over your PC, eh?
Because the potential security exposure is so great, [ strongly recom-
mend that you add your helper to your Address Book and test the
Address Book entry a couple of times by sending trial messages before
crunch time. Then use the Address Book to send your invitation.

C. If your assistant expects to get a file from you (and this option really
isn’t any more advanced than the other two, in spite of what the
option says), click Save Invitation As a File (Advanced).

8. The Remote Assistance program asks you to type your name, to set a
time limit for the invitation to expire (recommended: one hour), and
to type a password (no limitation on length or form). If you’re commu-
nicating via e-mail, you’re also allowed to type a message to your
friend. Just follow the easy steps.

When the Remote Assistance program finishes, one of three things hap-
pens, depending on how you’re communicating with your friend:
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A. If you're using MSN Messenger or Windows Messenger, your friend
(who'’s identified in the Windows interactions as, ahem, the Expert)
receives a computer-generated instant message inviting him to help
you, much like the message shown in Figure 4-3.
& Duangkhae - Conversation
Fi= Edit Wiew Help
To: Duangkhae <sh
& Mever give outyour password or credit
card number in an instant message
canvarsation.
B4 Duangkhae is imviting you to start using
Femote Azsistance. Do you want to Accept
(&lt+T) or Dedine (At+0) the invitation?
Figure 4-3:
Windows
Messenger-
based
invitation By miee () Bock
to offer
Remote
Assistance.

Last message received on 7/11/2001 at 5:36 PM.
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Figure 4-4:
E-mail
security
halts your
attempt to
send a
message to
your helpful
friend.
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B.

If you're using e-mail, the Remote Assistance program generates an
e-mail message destined for your friend. You probably get an e-mail
warning message like the one shown in Figure 4-4, saying that some
renegade program (like, uh, Windows) is trying to send an e-mail
message on your behalf. Just click the Send button.

OT.EIT.DK Express ! E|g]

.
4

i

Ta

Subject:

A& program is attempting to send the following e-mail
mezzags on your behalf:

woodyEimsn com

YOU HAVE RECENVED A BEMOTE ASSISTANCE |

“Woul pou like to sand the meszage?

Serd Do Mot Send

If you create a Remote Assistance invitation that goes out via e-mail,
using this B procedure, your e-mail program may not send the invita-
tion automatically. As soon as you click Send, you should immedi-
ately start your e-mail program (choose Start=>E-mail) and make sure
that the invitation isn’t languishing in your Outbox.

. If you're working with a file, you need to tell Windows where to put

the file called RAInvitation.msrcincident. The file easily fits on a
diskette, or you may want to save it on a network drive. That’s the
file you should deliver to your friend.

9. Your friend, the Expert, has to initiate the Remote Assistance session.
The method for starting the session varies depending on how he got
your invitation:

A. If you're using MSN Messenger or Windows Messenger, your friend

B.

can start helping you by clicking Accept (refer to Figure 4-3).

If you're using e-mail, your friend receives a message that looks like
the one in Figure 4-5. To initiate the Remote Assistance session, he
must open the attached document and respond Yes to the Remote
Assistance request shown in Figure 4-6.

If your friend opens the file RAInvitation.msrcincident, he sees
the message shown in Figure 4-6. Clicking Yes initiates the Remote
Assistance session.
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¥ | YOU HAVE RECEIVED 4 REMOTE ASSISTANCE INVITATION FROM: Duangkhae - Message (Plain Text)  [2)[5][5]
File
CoRely fyReplytodl GEFoward S B ¥ Y X 4 -9 - 8 [0),

Toi
Ce:

From:

Subject: YU HAVE RECEIVED 4 REMOTE ASSISTANCE INVITATION FROM: Duzngkhas
Attachments: ) rcBuddy.MsRelncdent (1 KE)

Edit  Wew Jrsert  Fomst  Tools  Ackions  Help =

suancgehae <shicadd@hobmail.com ) Sent: Wed 7/11/2001 5:40 FM
woody@msn, com

Duangkhae would like your assiscance.h personal message may be included helow, o

YTou can easily provide assistance from your computer by following the instructions
at:

http://windows.mwicrosoft.com/Remoteissiscance/en/ B htm

10.

. cCaution:
Figure 4-5:
. * Aoeept invitations only from people you know and trust.
The E'mall * E-mmil messages can contain viruses or other harmful attachments.
message * Berfore opening the accachment, review che securicy precaucions and information at
the sbove address.
sent to your
riend the Personal message:
f 1 Woody - Could you help me figure out how Co you the spray can in Windows Painc?
helper. Thanks. Add.... 7
) @ Remote Assistance
Figure 4-6:
TO Startthe Remate Assistance Invilation
emote From: | Duangihae
R Expires an: | Wednesday, Juby 11, 2001 £:40:00 PM
ASSI§tance Do yiou weark Eo connect ba Duangkhas's compuber now?
session,
your friend
clicks Yes.
vQ‘t\\Nt;.r If your friend attempts to open the file RAInvitation.msrcincident

and gets an error message saying that he must choose a program to
open the file, he’s not using Windows XP. As of this writing, only
Windows XP can initiate a Remote Assistance session. At some point in
the future, Microsoft possibly will make Remote Assistance available
with other operating systems. For the latest information, choose
Start=>Help and Support, and type Remote Assistance in the Search
text box.

After your friend, the Expert, initiates a Remote Assistance session,
you need to allow him onto your machine.

After he does his part (by clicking Accept in an Instant Message or click-
ing Yes in the Remote Assistance request), you see the message shown
in Figure 4-7.
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Figure 4-7: @ Remote Assistance

Ac ce pt or Woody has accepbed your Remote Assistance invitation and is ready to
re] e ct the connack ko your computer,
Remove Do you wank bo let this person view your screen and chak with you?
Assistance
session.
11. Click Yes and two things happen simultaneously.
First, your computer sprouts a Remote Assistance dialog box, like the
one shown in Figure 4-8.
Second, your friend’s computer — which is to say, the “Expert’s” com-
puter — receives a Remote Assistance dialog box that looks a little bit
like yours, but it also has a viewing box that displays everything on your
screen. (See Figure 4-9.)
12. 1If your friend wants to take control of your PC, he needs to click the
Take Control icon in the upper-left corner of the Remote Assistance
window.
If he does that, your machine warns you that the “Expert” is trying to
take control, displaying the dialog box shown in Figure 4-10.
Instant messaging history
é_REInDlB Assistance
[ hat History
Duangkhas says:
‘Woady, can you shaw me how
the spray pant toal in findows
Part works?
‘Woody (Expert) savs: . .
sl o S 80 Stop "Expert" control
can start Paint and run it theough
Ibs paces?
Duangkhas says:
G0 ahead.
Figure 4-8: . .
Audio quali
The Remote . quality )
Assistance | Disconmect Permanently break the connection
control
dia|og bOX Message Entry
that appears [ |
on your
machine.

Type messages for your "Expert" here
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‘Woody is conmected to
gkha=.

The connection status &

Figure 4-9: Screen View Oriy
The Remote
Assistance

Woody, shoi Frow Eh
C_Ontr0| Spray ;al;?-‘bovmn WI:::I?\:S ;:nt ?
dialog box sty
that appears Woady (Expert) says:

e

E [ of your m Y, 50
Ofl'l yOl;II' c:n start Paint :nd run it through
friend’s Its paces?
machine
. khas 3
includes a P
window that < 8

Message Entry
shows 2 EENEEEEEENEEEN
everything T T T
on your ; For Help, chck Help Topics on the Help Men
desktop.
Type messages for your "Novice"
Scroll to see the entire "Novice" desktop
13. When you (the “Novice”) have given your blessing, your friend
(the “Expert”) sees the message shown in Figure 4-11 on his screen.
Figure 4-10: ance -- Web Page Dialog
You must W;Q.dy would fke bo share cortrcd of your computer o help sohee the
problem,

give your Doy wish to let Woody share control of your computer?
permission
before your
friend can

e Itis recommended that vou and Woody do not use
the mouse &t the same time. You can monitor &l
ackivity and stop contral ak any time by pressing the

take control F

of your | \ ESC key. Note that using any key sequerce or
combination induding the ESC key will also stop
computer. coriral,
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WING/
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Figure 4-11:
You friend is
in the
driver’s
seat.

After a Remote Assistance session is under way and you’ve released control
to your friend, your friend can do anything to your computer that you can
do. Anything at all. Both of you have simultaneous control over the mouse
pointer. If either or both of you type on the keyboard, the letters appear on-
screen. You can stop your friend’s control of your computer by pressing the
Esc key.

Your friend can rest assured that this is a one-way connection. He can take
control of your computer, but you can’t do anything on his computer. He can
see everything that you can see on your desktop, but you aren’t allowed to
look at his desktop at all. Whoever said life was fair?

All good things come to an end, or at least that’s what I've been told. Remote
Assistance sessions end when one or the other participant clicks the
Disconnect icon, closes the Remote Assistance dialog box (for example, by
clicking the X in the upper-right corner), or when the Internet connection
goes away.

A Remote Assistance -- Web Page Dialog

i Yo nowe are sharing control of Duangkhas's computer, Click in Duangkhae's
screen bo get starked,

Control will reburn to Duangkhae IF you press the ESC key, or ary key
sequence of combination including the ESC key (such as ESC+TAR)

Running an Effective Search

Windows Help has been set up for you to jump in, find an answer to your
problem, resolve the problem, and get back to work.

Unfortunately, life is rarely so simple. So, too, with Help. Chances are good that
you won't dive into Help until you're feeling very lost. And once you're there,
well, it’s like the old saying, “When you’re up to your <insert favorite expletive
here> in alligators, it’s hard to remember that you need to drain the swamp.”

Windows Help has a few tools that should help you to stay organized — to
keep your <expletive> from being overwhelmed by ’gators — if you make a
conscientious effort to learn about them and put them to use.

Understanding search limitations

If you're looking for sophisticated search capabilities, Windows Help isn’t
going to impress you. It has no natural language feature, so you can’t ask a
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question such as “How do I install a digital camera?” and expect a decent
response. All searches are for keywords. The words you type are the words
that Windows Help uses.

Still, Windows Help has some flexibility and built-in know-how, as displayed
in Table 4-1.

Table 4-1 Windows Help Search Combinations

If You Search for This Help Returns This

mouse keyboard All entries referring to either mouse or keyboard

mouse and keyboard All entries that refer to both mouse and keyboard

mouse not keyboard Entries that refer to only mouse, and do not refer to keyboard

When Windows Help searches the Knowledge Base, it doesn’t seem to recog-
nize the “not” command mentioned in Table 4-1. For example, searching the
Knowledge Base for “start menu” and “start not menu” returns the same
results. Looks like a bug to me.

Setting search options

The Windows XP Help and Support Center gives you surprisingly few
options for controlling the destiny of your searches.

Although your choices are few, two Search changes make sense for most
Dummies:

1. Choose Start>Help and Support.
2. Click the Options icon in the upper-right corner of the screen.
3. In the Options box, click Set Search Options.

You see the Set Search Options pane, as shown in Figure 4-12.

4. If you want Windows Help to show you more than 15 results from
each of its searches — a choice that slows down searches but
increases your chances of finding an answer you need — consider set-
ting the Return Up To XX Results Per Provider to 50.

5. If you dislike the way Windows Help highlights all the “matched”
words when it shows you the results of a search, deselect the Turn On
Search Highlighting check box.

[ hate search highlighting: Looking at a Help page with the same word
highlighted over and over again gives me a headache. This one change
makes all the difference between a useful Help search capability and a
garish overblown sideshow, far as I'm concerned.

Book |
Chapter 4
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Figure 4-12:
Slim pickins
for search
options.

6. Click the X (Close) button in the upper-right corner to leave the Help
and Support Center.

Your new settings are saved.

Collapsing the view

After you find the help you're looking for, you frequently want to keep the
Help text in front of you, but you couldn’t care less about the search pane,
the index, or any of those fancy icons.

If you click the Change View icon, Windows Help retracts all of the unneces-
sary pieces, leaving the screen refreshingly uncluttered. Compare Figure 4-13
to Figure 4-12.

When you want the Search text box back, just click the Change View icon
again, and Windows Help returns to its usual out-of-the-shell configuration.

Keeping your Favorites

Compared to Internet Explorer, Windows Help maintains a very unsophisti-
cated list of Favorites. You have a couple ways to use Favorites:

@ Help and Support Center

@Back A | _,.l\J ij Index '“}I'ngurtas {9“20& ESWt | Cotions

search NG 5 @ Help and Support Center
Sek s2arch options Win “P Home Edition
e RS EES R
-~
[ Change Help and Suppart Center Set search options
opkions

[ Set search options

Find hizlp and Infoemation from dfferent sources. To change the scope of your s2arch, select one o
more providers from the followng list,

Returnupto [50  resuts per provider,

1 Turn on search highlighe.

Suggested Topics
Displays resudbs of the highest possible relevance. Search matches the terms you byped against
Eerms that the author of 5 docurment defines 2 keywords For that document. Selecting this
aption makes It possible for you ta limik your search to the specific Help category of the current
Eapic.

[¥] Full-test Search Matches
Displays documents whaose texk contains the berm(s) you typed.

[T search im title only
[ Match similar words

[¥] Microsoft Knowledge Base
Displays relervant topics or articles Fram the Microsoft Knowledge Gase Web site. The Knowledge
Base is & source of bechnical support information and self-help bools Far Micrasoft praducts,
Select a product or bopic
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Windows [] search in tite orly
Help pulls ] mstch simias wends
in all the Microsoft Knowledge Base
unnecessa ry Displays relevant topics or articles from the Microsoft Knowledge Base 'Web site, The Knowledge
Base is & source of technical support information and self-help tools for Microsoft products,
appendages. Select a prociuct or topic
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4+ When you bump into a Help topic that you want to be able to find again,
click the Add to Favorites icon (to the left of the Change View icon in
Figure 4-14).

4+ To bring up your list of Favorites, click the Favorites icon at the top of
the Help window.

@ Help and Support Center

Favorites ‘c’)Hstorz ESU.DWE i] Ciptions:

search NG > @ Help and Support Cente

on

= Brint, .. 5 Locate in Contents

™ .
Favorites T Add to Favorites Chargs View

Microsoft Setup Troubleshooter
List of troubleshooters

Home and Small Office Networking
Traubleshooker

Microsoft Hardware Troubleshoober
Microsoft Mukimedia znd Games

A~
My
List of troubleshooters Loy
The fallowing troubleshooters are available in Windows, You can start
& troubleshooter by clicking the narme in the left colurmn of the table.

and r PY
Troubleshooter  related to:

Figure 4-14:

Trobboah cotir System setup Installing and setting up Windows,
WIndOWS Startup/Shutdown  Starting and shutting down your computer,
H I ’ Microsoft Hardware Troubleshaoter Display Wideo cards and wideo adapters, including
elps your computer screen, outdated or
fot incompatible video drivers, and incorrect
UnSOphIStI- settings for your video hardware.
cated list of Home networking  Setup, Internst connections, sharing files and
printers.
Favorites. Display Hardware Disk drives (including CD-ROM and DVD

drives), game controllers, input devices (such ~
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S

When you’re running through a Troubleshooter that shuts down Windows,
the Troubleshooter text warns you that a restart is imminent. Adding the
Troubleshooter to your Favorites list before Windows shuts down is always
a good idea, in case Windows Help has trouble finding its way back.

Hopping to the Table of Contents

Introducing one of Windows XP Help’s great unsung features: the ability
to jump from a Help topic straight to the topic’s location in the Table of
Contents.

What? You say you haven’t seen the Help Table of Contents? Oh ye of little
faith! There’s a good reason why you haven’t seen it. Microsoft goes to great
lengths to hide it in Windows XP. Earlier versions of Windows made it very
easy to leaf through the Table of Contents — there was a little Contents tab,
prominently displayed in the Help panel, which brought up the TOC. Not so
in Windows XP.

If you want to look at the Windows XP Table of Contents, you must first
search for a topic using the techniques outlined in this section or find a
topic in the Index (see the next section, “Working through the index”) before
you can jump to the Table of Contents. That’s a lot like requiring you to pull
a book off a library shelf before you're allowed to look at the card catalog,
but sometimes Windows works in mysterious ways.

When you’ve found a topic that interests you, simply click the Locate in
Contents button to jump to the TOC. If Help is kind enough to let you into
the TOC at that point (and it may block your attempt, saying the topic is
only available from Search or the Index), you can leaf through related topics.

If you try to use Windows XP’s Help to get help on, uh, Windows XP Help,
you’re in for a merry ride. For example, if you search for the topic “Getting
Help,” you'll find an eloquent discourse on the virtues of Windows Help’s
Contents tab. Of course, Windows XP Help doesn’t have a Contents tab. A
foolish consistency is the hobgoblin of little minds, eh?

Working through the index

Just as this book has an index, so, too, does the Windows Help and Support
Center. To find the index, click the Index icon. The index appears, as shown
in Figure 4-15.

The Windows Help index is quite thorough but, like any index, relies heavily
on the terminology being used in the Help articles themselves. That leads to
frequent chicken-and-egg situations: You can find the answer to your ques-
tion quite readily if you, uh, know the answer to the question. Or if you know
the terminology involved (which is nearly the same thing, eh?).



Figure 4-15:
The Help
index.
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Generally, typing keywords in the Search text box is the best way to
approach a problem, but the index comes in handy from time to time. Don’t
hesitate to use it.

Getting Help on the Web

S

Of course, the single greatest source of information about Windows XP is the
single greatest source of information about everything — the Web. The
Windows Help and Support Center weaves in and out of the Web in a multi-
tude of ways.

Whenever you use the Windows Help and Support Center to search for an
answer to a question, it’s vitally important that you get hooked up to the
Web. Microsoft posts answers to its most-often-asked questions. Thousands
of 'Softies are actively involved in keeping the answers as accurate as time
and corporate discretion permit.

The following are the best sources I've found for Windows Help and
information:

4+ The Microsoft Knowledge Base: This is the mother lode, the source of
information that all of Microsoft’s tech support people use. Find it at
http://search.support.microsoft.com/kb/c.asp.

4+ AskWoody.com: The Knowledge Base shows you Microsoft’s Official
Party Line. www.AskWoody . com gives you the rest of the story.

Book |
Chapter 4
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4+ Google: Type in the key words of your question, and you can usually
find an answer — although you may have to wade through a lot of chaff.
As with any search engine, it works better if you already know the
answer to your question. Check it out at www.google.com.

4+ Windows newsgroups: These are a great source of information, but you
have to remember that not everybody posting to the newsgroups knows
whereof they speak. To get there, choose Start=>Help and Support and in
the Ask for Assistance corner, click on Get Support or Find Information
in Windows XP Newsgroups. Then in the Support box, click Go to a
Windows Web Site Forum.

4+ The Windows Update site: You can get to this site by choosing
Startc>Help and Support and, in the Pick a Task list, clicking Keep Your
Computer Up-To-Date with Windows Update.

4+ Product Support Options: If you're curious about the tech support avail-
able directly from Microsoft, what you qualify for, and how much it will
cost, hit http://support.microsoft.comand search for Product
Support Options.

4+ User Web sites: Several free user-helping-user Web sites focus on Windows
problems (and even a few solutions!). My site, the WOPR Lounge (www .
wopr.com/1lounge), draws thousands of people every day.



Chapter 5: Searching Vour
Machine and Beyond

In This Chapter

v Secrets for powerful searches on your computer
v Automatic Indexing Service — less wait, more weight
1 Search Companion strategy: Throw Rover a bone

+~ Best ways to search the Web

C omputers store lots and lots of stuff. As long as you’re churning out

the stuff, life goes along pretty easily. Sooner or later, though, the time
comes when you have to find some stuff — the right stuff — and that’s when
the stuff hits the fan.

Windows XP includes a powerful search feature with a cute name — Search
Companion — and a cloying mascot, a mutt called Rover.

This chapter explains how to make Rover sit up, heel, fetch, and . . . play
dead.

P If you want to understand how Windows performs searches, you have to be
able to see filename extensions — the short (usually three-letter) part of
each file’s name following the period that identifies the file’s type, such as
.doc and . jpg. Windows XP does not show you filename extensions unless
you specifically tell it to. In order to make heads or tails out of anything in
this chapter, make Windows show you filename extensions by following the
steps outlined in Book I, Chapter 3.

Exploring the Search Companion

If you choose Start=>Search, you bring the Search Companion to life, with
Rover (see Figure 5-1) sitting ever-so-patiently at the bottom of the pane, tail
wagging, waiting to help you fetch whatever you like.

Rover exists solely to reduce your anxieties: a nice, cuddly pooch to reassure
you that Windows XP is so friendly and helpful. Rover just wants to roll over
and get scratched like a, well, like a companion. C’'mere Rover. Good boy.
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Very few options
All do basically the same thing
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Doggie training school

(Re) Introducing Rover

search.msn.com

Windows Help and Support Center

Of course, Microsoft knows very well that if you're searching for something,
you’re probably in a panic — a file isn’t where you put it, you need it now,
and you’re about ready to scream bloody murder at the stupid computer or
commit some heinous act.

If you can’t find a file or a folder, you crank up Search Companion. You prob-
ably figured that out. Search Companion also claims that it looks for comput-
ers, people, and places on the Internet. It does. Sorta.

You may not know that Search Companion can be jimmied to bypass
Microsoft’s proprietary Internet search site, http://search.msn.com—a
trick that makes Internet searching a lot faster and more powerful. Details
are in the section, “Searching the Internet,” later in this chapter.
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Exploring the Search Companion

If the Search Companion screen shown in Figure 5-1 looks familiar, it should. Book |
In fact, Search Companion is a pane inside Windows Explorer. You can see Chapter 5
the striking similarities as shown in Figure 5-2.

What you can find

When you bring up the Search Companion by choosing Starte>Search (refer
to Figure 5-1) or clicking the Search icon in any Windows Explorer window
(refer to Figure 5-2), Rover offers to search for the following:

puokag
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4+ Pictures, music, or video: Choosing this option leads Rover (see Figure
5-3) to ask whether you want to limit your search to Pictures and Photos,
Music, and/or Video. You can select as many check boxes as you like; if
you don'’t select any, Windows assumes that you want to search for all the
categories. Windows then runs a full search (as described in a section
later in this chapter, “Looking for Files and Folders”) but narrows down
the search to files with specific filename extensions, as shown in Table 5-1.

Note that the contents of the file don’t matter: Windows XP doesn’t look
inside the file to see if it contains, oh, a JPEG image, for example. The
Search Companion cares about only the filename extension.

4+ Documents (word processing, spreadsheet, and so on): Like the
Pictures, Music, or Video option, choosing Documents leads to a full
search, limited to the specific filename extensions shown in Table 5-1.

4+ All files and folders: This leads to the full search described in the later
section, “Looking for Files and Folders.”
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Figure 5-3:
Narrowing
down the
search
based on
filename
extensions.
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Use advanced search
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Back ] [ Search

4 Computers or people: The computer side of this search (assuming you

leave the computer name box empty) is identical to choosing Start>My
Network Places and clicking View Workgroup Computers.

The people side of the search leads to your Outlook Express (not Outlook)
Address Book. From there, you can also use OE’s crude interface to look in
the Bigfoot, VeriSign, or WhoWhere directories.

Don’t bother using Start>Search to find people on the Internet. As of this
writing, none of the three options work very well: The VeriSign directory is
very tiny, the Bigfoot directory doesn’t seem to be hooked up to Windows,
and the WhoWhere link seems to be broken, too. If you're serious about
finding somebody on the Web, use Internet Explorer to go to one of the
standard search engines: www.anywho.com works well, as do people.
yahoo.comand www.whowhere.lycos.com.

4+ Information in Help and Support Center: This option opens up the

Help and Support Center, precisely the same as if you had chosen
Start=>Help and Support Center. See the preceding chapter for full
details.

Table 5-1 Filename Extensions in Search

Choose This Type of File And Windows Limits the Search to Files with These Common

Filename Extensions™

Pictures and Photos ANI, ART, BIT, BMP, CDR, CGM, CMP, DIB, EPS, GIF, JPG, TIF,

PCX, PNG, PS, WMF

Music AIF, AIFF, ASF, CDA, FAR, MID, MP3, RAM, RMI, WAV, WMA
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Choose This Type of File And Windows Limits the Search to Files with These Common Book |
Filename Extensions* I

Video ASF, ASX, AVl, MMM, MPG, WMV

Documents ASC, ASP, AW, CHI, CHT, DBF, DOC, DOT, HTM, HTML, MDB,

MSG, 0BD, PDD, PQT, PPS, PPT, PUB, RTF, SAM, TIF, TXT, WRI,
XLA, XLL, XLS, XLT

*This list is far from exhaustive; yes, TIF appears in two lists
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The Search Companion also allows you to search the Internet. I go into details
about this option in the section, “Searching the Internet,” later in this chapter.

What you can’t find

Surprisingly, Windows XP Search Companion doesn’t search Outlook or
Outlook Express e-mail messages unless you turn on the Indexing Service
(discussed in the section, “Indexing service,” later in this chapter). If you
want to look for text in a message, or even a message Subject line, Windows
XP can’t do it.

Office XP and Office 2003 — specifically Word 2002 and 2003 — can reach
inside Outlook e-mail messages and search for text, Subject lines, senders,
receivers, and the like. Word also supports AND/OR search arguments, nar-
rowing searches to specific Outlook folders, and much more. If you have Office
XP or Office 2003, you should use this vastly more powerful search tool:

\\J

1. Start Word 2002 (the version of Word in Office XP) or Word 2003.

2. In Word 2002, if the task pane isn’t visible on the right side of the
screen, bring it up by choosing View=>Task Pane. Click the down-
arrow to the right of the task pane title and select Search.

If you're using Word 2003, choose Filew>File Search.

3. If Basic Search appears in the title, click Advanced Search at the
bottom of the task pane.

The Advanced Search task pane appears. (See Figure 5-4.)

4. To restrict the search to specific Outlook folders, pick a folder from
the Search In drop-down list.

5. Select Outlook Items/E-mail Messages from the Results Should Be
drop-down list.

6. Put together your search criteria in the upper part of the task pane,
and click the Search button.

Office XP and 2003 can use Windows XP’s Indexing Service to great effect.
See the “Indexing service” section, later in this chapter, for details.
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Phrasing a search query

You have two different, almost mutually exclusive, ways to ask a computer
to look things up:

4+ Keyword searches: These searches take the words you specify and look
for those words. In some cases, keyword searches can be augmented by
the qualifiers LIKE, AND, or NOT. So you may have the Search Companion
look for files with the names blue or dolphin, and you get back a list of
files with either blue or dolphin, or both, in their names.

4 © Advanced Search * x
Search for:
Property: | Text or property -
Condition: |includes -
Walue:
Figure 5-4: ® and O or
If you need Remave Remaove All
to search
for Outlook
e-mail
messages, J
our onl
Zhoice '
is the Other Search Options:
Word 2002 Search in:
(Oﬁice XP) Selected locations A
or Word Results should be:
2003 Selected File types -
Advanced Seetalso
Search task B Basic Search
pane. @ Find in this document...

4+ Natural language searches: These searches, on the other hand, expect
you to ask a question in the form of a question (with apologies to Alex
Trebek). Thus, you might ask your computer, What color are dolphins?
and get back a list of Web sites that discuss dolphins’ colors.

Windows XP’s Search Companion combines both search methods, but in a
very specific way. If you're looking for Web sites, you're expected to ask a
question — that is, Windows uses a natural language search approach when
going out to the Internet. For everything else, you should type only keywords.

It’s an odd dichotomy that you may find irritating, or confusing, or both.
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Looking for Files and Folders Chamtr’s

Maybe you need to find all of the handouts you typed for your Porcine
Prevaricators seminar. Maybe you remember that you have a recipe with tar-
ragon in it, but you can’t remember where in the world you put it. Maybe
you accidentally moved or deleted all of the pictures of your trip to Cancun,
or Windows Media Player suddenly can’t find your MP3s of the 1974 Grateful
Dead tour.
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Good. You're in the right place.

People generally go looking for files or folders on their computers for one of
two reasons. Perhaps they vaguely remember that they used to have some-
thing — maybe a Christmas letter, a product description, or a great joke —
and now they can’t remember where they put it. Or they have been playing
around with Windows Explorer, and whatever they thought was sitting in a
specific place isn’t there anymore.

In either case, the solution is to make Windows XP do the work and go
searching for your lost files or folders.

If you choose Start=>Search, the Search Companion dog Rover (refer to
Figure 5-1) gives you a chance to narrow down your search, in advance, by
choosing Pictures, Music, or Video, or Documents. If you know in advance
what kind of file you’re looking for, those choices can hone in on specific file
types (refer to Table 5-1). If you don’t know exactly what you're looking for,
though, it’s just as easy to go straight to the full-fledged search — the choice
marked All Files and Folders.

Rover the Searching Agent

First things first: You can get rid of the dog. Banish him to the doghouse.
Trade him in for a newer model — or at least a different one. You can simply
tell him to get lost. He won’t mind. Here’s how:

1. Bring up the little mutt by choosing Start->Search (see Figure 5-1).
2. Click Change Preferences at the bottom of the screen.

You see the question “How Do You Want To Use Search Companion?” in
the screen that appears.

3. To completely rid yourself of the critters, click Without an Animated
Screen Character.

4. If you think you have a tiny chance of finding a character more to
your liking, click With a Different Character, and peruse the ensuing
rogues’ gallery.
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Do you really, really need to get a life? Here’s how to tell. Click on Rover (or
whichever cloying character you have chosen as your Search Companion),
and then click Do a Trick. Go ahead. I dare ya.

Those little Search Companion characters — they’re called Agents — are
stored in ACS files. If you search for *. acs files (see “Using wildcards” later

in this chapter), you can find a handful of them scattered in various places on
your hard drive. If you come across other ACS files — Office XP and 2003 have
a bunch of them, for example, probably tucked away in hidden folders — and
put the files in the \Windows\srchasst\chars folder, they are available for
you to choose as an alternative to Rover.

Making the most of simple searches

Can you remember what’s in the file you're looking for? Can you remember
at least part of the file’s name? Nine times out of ten, that’s all you need.

Forgive me if you've read this already, but you absolutely must make
Windows XP show you filename extensions — the characters following the
period toward the end of the filename, such as .exe or .bat. Read up on file-
name extensions, and why they’re so important to see, in Book I, Chapter 3.
Then follow the steps listed there to tell Windows XP to show you filename
extensions.

The best approach to performing a simple search depends on whether you
know for an absolute, dead-certain fact what kind of file you're dealing with.
The following sections describe how it works in the best of all possible worlds.

Searching for pictures, music, or video

Here’s what to do if you know for an absolute, dead-certain fact that the file
you want is a picture, photo, music file, and/or video:

1. Choose Start~>Search.

You see Rover (refer to Figure 5-1) or something like him (or, if you're
lucky, nothing at all!).

2. Click Pictures, Music, or Video.
You see the Search pane (refer to Figure 5-3).
3. Pick the kind of file you’re looking for.

If you know anything at all about the file, type it in the text box marked
All or Part of the File Name. Windows is a whole lot smarter than this
dialog box would have you believe. For example, if you search for Music
files and you type Ludwig in the box, Windows will find Beethoven’s 9th
Symphony, even though Ludwig doesn’t appear in the filename. Try it.
You'll see.
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\
) All of the advanced search options described in the section, “Digging

deeper with advanced searches,” are available by choosing Use
Advanced Search Options.

4. If you don’t find the file you want, crank up the Windows Media
Player and see whether you can find it from there. I talk about
Windows Media Player in Book VII, Chapter 1.

Searching for a document
Here’s what to do if you are absolutely, completely certain that the file you

want is a document — which is to say a text file (with the . txt filename
extension), Word document (. doc), Excel workbook (. x1s), PowerPoint pres-
entation (.ppt or .pps), or one of the other documents listed in Table 5-1:

1. Choose Start->Search.

2. Click Documents (Word Processing, Spreadsheet, and so on).

You see the pane shown in Figure 5-5.

search by any or all of
the criteria below.

Last time it was modified:
(%) Don't remember
) within the last week
) Past manth

() within the past year

All or part of the dacument
name:

‘ou may also want ko...

Use advanced search
opkions

— ’ Back ] [ Search
Figure 5-5:
Tell Rover to
search for
documents.

3. Tell Rover how to narrow down the search.

If you can remember the last time that the document was modified —
not created or opened, but changed — select the appropriate option
button. There’s no wiggle room. If you select the Within the Last Week
option button, and you last modified the file eight days ago, it won’t
show up in the search.

Book |
Chapter 5
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If you can remember any part of the filename, type it in the text box. The
Search Companion matches any file with a name that includes the char-
acters you've typed. (See Table 5-2.)

Table 5-2 Simple Filename Matches

Type This And You Will Match But You Will Not Match
a a.xls b.xTs

bug bed bug.txt abu ghanim.txt
add madden.ppt dad.ppt

wood woody .doc woo.doc

1.
2.

3

Search Companion recognizes the key words OR and AND. If you type
new or recent in the All or Part of the Document Name box, Rover
brings back files such as new pictures.jpgand recent songs.mp3.If
you type two words in the All or Part of the Document Name box, Rover
assumes you mean AND.

The search for filenames is quite literal, and filename extensions are
included if you have Windows show filename extensions. So if you show
filename extensions and you enter txt, you see all of your . txt text files.

All of the advanced search options described in the section, “Digging
deeper with advanced searches,” are available by choosing Use
Advanced Search Options.

. If you don’t find the file you want, try the option called Change File

Name or Keywords (see Figure 5-6). This option enables you to easily
switch over to searching for text inside the documents (see Figure 5-7).

Searching for All Files and Folders

If you aren’t absolutely, totally, utterly certain that you want to find a pic-
ture, photo, music file, video, or document, it’s best to tell Rover to fetch
everything matching your criteria, and sift through the results yourself.
Here’s how:

Choose File=>Search.

Click All Files and Folders, and go for a full-fledged search.
When you do, you get the search pane shown in Figure 5-8.
Help Rover find your file.

The filename part of the search is identical to the details I discussed

in Table 5-2. If you have filename extensions showing, and you type doc
in this text box, for example, you get a list of all the . doc files on your
computer.
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The A Word or Phrase in the File text box jumps through some interest-
ing hoops. If you type a single word, Search Companion looks for that

word, of course. If you type a phrase like back in a minute, Search

Companion looks for that precise phrase, with spaces and punctuation

exactly the way you specify.

Book |
Chapter 5
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Figure 5-8:
The full-
fledged
search.

WING/
&

Search Companion also looks for information attached to a file — infor-
mation you may not see if you open the file. It’s called metadata, and |
gave you an example of a metadata search earlier when I said that Search
would find Beethoven’s 9th if you look for Ludwig. Media files usually
have metadata attached to them with information about the content.
Microsoft Office documents always have metadata attached to them. You
can see Office metadata by bringing up the Office application (such as
Word, Excel, or PowerPoint) and choosing File>Properties. The file’s
metadata appears on the tabs marked Summary and Custom.

Search by any or all of
the criteria below.

All or part of the file name:

i |
A word or phrase in the File:

I Sangkran | |

Laok in:

!»' Local Hard Drives (C:; % |

When was it

>
*

..

modified?
What size is it? ¥
More advanced ®
options

Back ] [ Search

The Look In drop-down list enables you to pick the starting point of the
search. If you want to search your entire network (a process that could
take many hours!), click the down-arrow and choose Browse=>My
Network Places>Entire Network.

Windows XP warns you not to share an entire hard drive (see Book I,
Chapter 3) for several reasons, and this is a big one: Searching every
shared hard drive on your network is as simple as firing up Search
Companion and choosing Look In/Entire Network. And you can search
for anything.
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4. Click the Search button and the Search Companion returns the names
of files that match all of your criteria. (In geek terms, they’re “ANDed”
together.)

If you tell Rover that you want to see files with woody in all or part of
the filename, with the phrase blew it again in the file, Search Companion
returns only files with names that match AND contain the indicated
phrase. So a file named woodrow.doc containing the phrase “blew it
again” wouldn’t make the cut. Nor would a file called woody . txt with
the text “blewit agin.”

That’s the lowdown on simple searches. Much more power awaits, in the
next parts of this chapter.

Using wildcards

Windows XP’s Search Companion lets you use wildcards, which are symbols
that substitute for letters. The easiest way to describe a wildcard is with an
example. ? is the single-letter wildcard. If you tell Rover to look for files
named d?g.txt, the mutt dutifully retrieves dog. txt and dug. txt (if you
have files with those names), but it doesn’t retrieve drag.txt or ding. txt.
The ? matches one — and only one — character in the filename.

Search Companion recognizes two wildcards. ? matches a single character,
and * matches multiple (zero or more) characters. (See Table 5-3.)

Table 5-3 Wildcards for Filenames

This Matches This But Not This

d?g.txt dog.txt,dug.txt drag.txt,ding.txt
ne*w.mp3 new.mp3,neosow.mp3 ne.mp3,new.doc

Wildcards work with only file and folder names. The A Word or Phrase in the
File text box (refer to Figure 5-8) does not recognize wildcards.

Digging deeper with advanced searches

The full-fledged search dialog box (refer to Figure 5-8) has three buttons:
When Was It Modified?, What Size Is It?, and More Advanced Options.

If you click the (inappropriately named) When Was It Modified? button, you
have a chance to specify when the file you're looking for was last changed
(in computerese, modified means changed). As you can see in Figure 5-9,

Book |
Chapter 5
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Figure 5-9:
Narrow
your search
based on
the date that
the file was
last
changed,
created, or
opened.

though, you aren’t limited to the modified date. In fact, Search Companion
searches for files based on the date that they were created or last opened
(accessed in computer lingo) as well.

If you click the What Size Is It? button, Search Companion lets you pick the
file size. In my experience, people are amazed at how big files get, so if you
use this option, allow yourself lots of breathing room on the high side.

Finally, the More Advanced Options selection (see Figure 5-10) holds six
possibilities:

4 Type of File lists all of the filename extensions that your computer recog-
nizes, except that you don’t get to see the filename extensions; you have
to make do with the hokey names. If you have Microsoft Office installed,
the list of types starting with “Microsoft” goes on forever (my list in
Office XP includes one called Microsoft FrontPage Dont Publish — an
all-time classic). If you know the filename extension that you're looking
for, this is the worst place to tell Search Companion what kind of file you
want, because the hokey names can be so ambiguous. Instead, if you
know the filename extension that you want, use a wildcard search using
the filename extension in the All or Part of the File Name text box (for
example, enter *.mpeg to find all the .mpeg files, or *.ani to find all the
.ani files).

I |-
A word or phrase in the

7 —

[ Songkran |

¥hen was it a
modified?

() Dor't rememnber

() within the last week
) Past manth

() within the past year
(%) Specify dates
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to 7l15f2001 ¥ | v

’ Back H Search ]
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4+ Select the Search System Folders check box, and Search Companion
looks in the Windows, Documents and Settings, and Program Files
folders.

4 Select the Search Hidden Files and Folders check box, and Search
Companion looks in any files or folders that are marked Hidden.

Hidden files and folders aren’t really hidden. They’re just marked a cer-
tain way so that Windows Explorer won’t show them — unless you tell
Windows Explorer to show hidden files and folders. To hide a file or
folder, choose Start=>My Documents to start Windows Explorer. Right-
click on the file or folder, and click Properties. At the bottom of the
Properties dialog box, in the Attributes area, select the Hidden check
box. Now your file or folder is hidden from view. To make Windows
Explorer show hidden files and folders, follow the steps described in
Book I, Chapter 3.

4 Selecting the Search Subfolders check box tells Search Companion that
you want to look in the folder specified in the Look In drop-down list, as
well as in all folders inside of that folder. You almost always want to have
this check box selected.

4 In spite of what you read in other books, the Case Sensitive check box
has nothing to do with filenames. If you select this check box, Search
Companion matches the case of the text you type in the A Word or Phrase
in the File text box. So if you type Blue Mango in the box and check this
box, Search Companion looks for the text “Blue Mango” inside files, but
passes on both “blue Mango” and “BLUE mango.”

Filenames are never case sensitive. Ever. My Documents and my docu-
ments always refer to the same folder.

4 Select the Search Tape Backup check box only if you are using Windows
XP’s Backup feature.
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Figure 5-11:
If you've
read this far,
you're an
advanced
user.

If you’ve managed to read to this point, you're probably serious about
searching. Good on ya, as they say Down Under. If you want the Search
Companion to cut to the chase and stop bothering you with the “helping”
screens that divert you to searching for specific kinds of files, do this:

1. Choose Start=>Search and bring up Rover and the Search Companion
(refer to Figure 5-1).

2. Click Change Preferences.

3. Click Change Files and Folders Search Behavior.

4. Click Advanced — Includes Options to Manually Enter Search
Criteria. Recommended for Advanced Users Only (see Figure 5-11).

After you change to Advanced, the Search Companion always starts up,
ready to perform a full-fledged search (refer to Figure 5-8).

Choose the default files
and folders search
behavior.

() standard - includes
step-by-step options
that help you refine
wour search

(%) Advanced - includes
options to manually
enter search
criteria.
Recommended for
advanced users
only

[ K ] ’ Cancel

Saving a search

Do you find yourself repeating the same searches over and over again?
Maybe you need to look in BearShare’s Download folder to see if those

MP3s have finally arrived. Or you want to look at a list of invoices for your
number-one customer. Only a real dummy would do the same thing over and
over again when the computer can do the work. A For Dummies dummy, on
the other hand, knows that he can save and reuse searches ’til the cows
come home.

If he reads this book, anyway.
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Here’s how you save and reuse a search: Book |
Chapter 5
1. Choose Start>Search to bring up the Search Companion.

2. Set up your search.

In Figure 5-12, for example, I've instructed Rover to fetch all the MP3 files
in the My Music folder that are less than a week old.

3. Click the Search button and run the search.
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This is the trick. It doesn’t matter whether or not you really want to run
the search. You have to if you're going to save the search to use in the
future.

4. Choose Filer>Save Search.

Windows XP offers to save a file called Files named @.mp3.fnd or
something equally obtuse. (See Figure 5-13.)

5. Navigate to a convenient location (if you put the search on your desk-
top, it’'ll always be handy); give the search a more descriptive name, if
you like; and click Save.

6. Any time you want to run the saved search, double-click the FND file
and click the Search button. Voila!

search by any or all of the ~
criteria below. i

Al or part of the file name:
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i |
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Figure 5-13:
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Indexing sevvice

If you choose Change Preferences in any of the Search Companion dialog
boxes, you see an option called With Indexing Service (For Faster Local
Searches). Click that line and you see a Search Companion dialog box —
select Yes, Enable Indexing Service to turn on a feature called Indexing
Service.

Indexing is a fancy way for computers to scan documents, build and store
indexes, and then retrieve documents based on the indexes in response to
your searches. Sounds difficult? In principle, it’s pretty simple: The com-
puter waits until you aren’t doing anything; then it starts looking, methodi-
cally, at every file on your hard drive(s). Say the computer’s looking at a file
called Woody da Dummy.doc. Inside the file, the computer discovers the
words “jumping jack flash.” It builds an index entry that says, among other
things, “the word jumping is in Woody da Dummy.doc.” Then it builds
another index entry that says, “the word jack is in Woody da Dummy.doc.”
And so on. When you ask for all the files that contain the word jack, the
Indexing Service realizes immediately that Woody da Dummy.doc should be
included on the list.
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In practice, indexing is one whole heckuvalot more difficult than you may
imagine. The biggest problem Microsoft had, for years, was the intrusiveness
of the bloody indexer: You'd be typing along, pause a few seconds to think,
and WHAM! All of a sudden this crazy program had taken over your machine.
Resume typing, and you had to wait an eternity to regain control of your PC.
I'm very happy to say that, in Windows XP (and only Windows XP, in my
eXPerience), indexing finally works.

If it’s turned on, Windows XP Indexing Service hooks into Microsoft Office XP
and Office 2003. So if you perform a search in Office, what you see is what
Windows XP delivers.

[ have had no end of problems getting Windows XP to use the index created
by the Indexing Service: There’s an entire section of my book Windows XP
Timesaving Techniques For Dummies (Technique 19) published by Wiley
Publishing, Inc. that shows you how to determine if the Indexing Service
saves time — indeed, if Windows XP itself will even use the index. As far as
I'm concerned, the only reason you would want to turn on the Indexing
Service is to speed up searches inside Office XP and/or Office 2003, or if
you’re willing to jump through the extra hoops involved in working with the
Computer Management Console (see later in this section). If you don’t
search in Office very much, and you don’t want to force yourself to use the
Computer Management Console, turning on the Indexing Service is a waste
of your time.

You can really get your hands dirty with complex searches, providing that
the Indexing Service is running. For example, in Figure 5-14, [ use the NEAR
operator to ask the Indexing Service to return a list of all files where the
word read appears within 50 words of the word write.

To find out more about the Indexing Service’s query language and to run a
query, follow these steps:

1. To start the Windows Computer Management Console, choose
Start=>Control Panel, click Performance and Maintenance, click
Administrative Tools, and then double-click Computer Management.

2. In the Computer Management Console, in the left pane, double-click
on Services and Applications. Then click to expand Indexing Service;
then System; then Query the Catalog.

3. Now you can run your search, or you can get help by choosing
Action~>Help and then clicking Indexing Service in the Help system.

Book |
Chapter 5
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Searching the Internet

If you tell Rover to search the Internet, he tells you to type your question in
a complete sentence. Click the Search button, and the Search Companion
steers you directly to — you guessed it — Microsoft, Rover’s master. In
Figure 5-15, you can see that the typed question What is the sound of one
hand clapping? was transformed by the Search Companion into sound
one hand clapping, and then it was sent directly to search.msn.com.

Nothing is particularly bad about search.msn.com, but I find it annoying.
For example, when I ran the search in Figure 5-15, MSN Search hit me with a
pop-up ad (you can see the message that a pop-up ad was blocked in the
screen shot if you squint real hard). The fact that Microsoft hit me with a
pop-up ad makes my blood boil — but the fact that Internet Explorer’s pop-
up blocker caught it gives me some hope. Talk about Microsoft’s left hand
not knowing what the right hand is clicking. . . .

As far as I can tell, all the people who live in Redmond, Washington (the
home of Microsoft) have cable modems or DSL in their offices and homes,
and they aren’t particularly concerned about how much, uh, offal gets
shoved down their data pipes. If you happen to live just about anywhere
else in the world, though, you may think differently.
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Automatically send your
search bo cther ssarch

The good news is that you can easily banish search.msn.comto the same
doghouse that Rover vacated and have your Internet searches use a Web site
that doesn’t bury half its screens in ads. Here’s how:

1. Choose Start=>Search to bring up the Search Companion (refer to
Figure 5-1).

2. Click Change Preferences.

3. Click Change Internet Search Behavior.

4. Pick the Web-based search engine that you like best, and click OK.
In Figure 5-16, I chose Google.

After you change your default search engine, every time you ask Search
Companion to search the Internet, it uses the engine you've chosen. See
Figure 5-17 and note how little useless information appears on the screen
with a Google search. No pop-up, either. Wonder why I switched?

Web-based search engines change every day. | have no guarantee that my
search engine of choice now will be the same six months from now. If you
use the Search Companion to perform searches on the Web, be sure to check
every few months to see whether a competing Web-based search engine
works better than the one you’re using.
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If you're serious about searching on the Web, Rover and the Search
Companion will irritate you sooner or later. To go directly to the Web and
take it on, mano a mano; see Book IV, Chapter 3.



Chapter 6: Getting the
Basic Stuff Done

In This Chapter

v Cheating at the Windows games (I know that’s what you’re looking for)

v+ Burning your CDs without singeing your fingers

1 Taking control of your PC, using Task Manager, when a program goes
haywire

v ... And lots of boring stuff you need to know anyway

ou bought your PC to get things done, right? I guess it depends on what

you mean by “things.” Certainly you need to know how to write a letter,
even if you don’t have Microsoft Office installed on your PC. Draw pictures.
You should figure out how to use the Windows Calculator program, even if
the thought of employing a $2,000 tool to solve a $2 problem leaves you feel-
ing a little green.

Hey, I have to talk about that stuff somewhere.

On a somewhat less mundane level, this chapter also contains Windows
game “cheats.” Amaze your friends! Strike terror into the hearts of your ene-
mies. They’ll cheer or they’ll weep when you show them Minesweeper
scores that look like the national debt of a small country.

This chapter also digs into the truly cool Windows XP support for
burning CDs.

Beating Windows Games

A\

You really bought this book because you heard it had all the game cheats,
didn’t you? C’'mon, admit it.

What? Your boss doesn’t like you playing games on the company PC?
Remind her that Windows games are, singularly, the best way to brush up
on your mousing skills, take your mind off work for a brief spell, and take a
break from all the typing. How do you spell Repetitive Motion Syndrome?

Windows XP ships with 11 games, many of which are quite good.
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Figure 6-1:
Windows
Solitaire, the
mother of all
Windows
games.

Solitaire

Venerable classic Solitaire, the oldest Windows game of all (see Figure 6-1) —
dating back to the prehistory of Windows 3.0, with a copyright that reaches
back to 1981, for heaven’s sake — still captures the hearts and spare cranial
cycles of millions. To get it going, choose Starte>All Programs=>Games=
Solitaire. But you’ve probably done that a hundred times already, haven’t
you?

If you don’t know the rules for Solitaire in general, ask the guy sitting next to
you on your next flight. The Windows version of Solitaire
4+ Won't let you pull a card from inside a stack.

4 Lets you undo only your last move. If you flip over a card that’s face-
down in one of the stacks, you can’t undo the flip.

4+ Restricts you to putting Kings in open stacks.
Scoring a Solitaire game makes cricket look like child’s play. To get the full

details on Standard and Vegas scoring, choose Help=>Contents, and then
navigate to Solitaire>Choose a Scoring System.

Choose Gamer>Deck to change the card back

Click the deck to deal

Options

Draw Sconng
Obrawlre (3 Standaid
() Draw Theee () Vegas

H
[<] Timed game SaHoce

Skatus bar
[] Outline cragging

Drag and drop cards to move them

Some decks show animations
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Figure 6-2:
FreeCell
should
stimulate a
few more
gray cells.
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One little cheat works if you have Solitaire set up to turn over three cards at

a time. To make it turn over just one card, press Ctrl+Alt+Shift and click the
deck. This is a particularly valuable cheat if you're using Vegas scoring. (Vegas
rules let you go through the deck three times if you have Solitaire set to turn
over three cards at a time, but you can go through only once if Solitaire is set
to turn over one card at a time.) If you use the Ctrl+Alt+Shift trick and turn
over one card at a time, you can go through the entire deck three times — a
real boon for Vegas scorekeeping.

FreeCell

FreeCell, Microsoft’s first Solitaire variant, mimics the card game of the same
name. To get it going, choose Start=>All Programs=>Games=>FreeCell (see
Figure 6-2).

The first page of the FreeCell Help file tells you that “It is believed (although
not proven) that every game is winnable.”

Ah, what fools these mortal Help files be.

Park your cards here Stack the cards in order here

< FreeCell Game #9274 E [z
Cards Left: 45

2
Be o |
0e o |
a2
Toa o]
6o o
4
ina
v v

Add cards to the stacks

Any card can go in an open slot

Book |
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FreeCell lets you replay the same hands, over and over, by assigning num-
bers to specific starting card combinations. To play hand number 50,000, for
example, choose Games>Select Game, type 50000, and click OK. That’s a
nifty trick if you want to play the same hand at home and then do it again at
work, or if you want to challenge a friend on a different machine to a duel.

All of the games numbered from 1 to 32000 are winnable, except for game
11982. Yes, there are people who study these things. No, they don’t have
lives. See www. freecell.org for details.

While a game is in progress, press Ctrl+Shift+F10. You receive one of the fun-
niest dialog boxes in Windows (see Figure 6-3). If you click Abort and then
click any card, you win immediately. Sorta. The cards are stacked in the cor-
rect slots, but not in the right order. Your score is updated to reflect a win.

FreeCell has two symmetric hands that you’ll want to take a look at. Choose
Games=>Select Game, and then type either -1 or -2. The first option, -1, gener-
ates two rows for each suit, one of which runs A-3-5-7-9-J-K, from top to
bottom; the other runs Q-10-8-6-4-2. The second option, -2, also generates
two rows for each suit, but this time they run A-K-Q-J-10-9-8 and 7-6-5-4-3-2.

a\\S
Figure 6-3: User-Friendly User Interface |‘g|
Click Abort Choose Abort o Win,
. -] Retry ko Lose,
to win at f'} or Ignore ko Cancel.
FreeCell
every time. | abort ) mety | [ 1onore
WNG/
&

Oh. I better mention one tiny, little detail, before you defenestrate this book —
that is, throw it out a convenient window. Both the -1 and -2 games are impos-
sible to win. You can’t beat either of them.

FreeCell keeps track of how many hands you’ve won and lost, and how long
your current winning (or losing) streak may be. To get to the scores, choose
Gamer>Statistics. You see a list like the one shown in Figure 6-4.

Ah, but there’s another trick — one | bet you’'ve never heard about, no
matter how much you love FreeCell. If you aren’t afraid of getting your
hands a little dirty, you can jigger your own statistics. Amaze your family
and friends. Confuse your foes. Make your boss think that you have an IQ
in the upper triple digits. Yes, you can do it.

FreeCell stores its scores in the Windows Registry. By switching a few num-
bers in the Registry, you can have FreeCell say that you’ve won thousands of
hands, and lost few (or none!). How do you think I got the 511-hand winning
streak shown in Figure 6-4?



Figure 6-4:
Perfect
scores in
FreeCell are
only a hack
away.
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FreeCell Statistics
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& Towr (8] wins REG_BINARY #f 01 00 00
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To set your own scores in FreeCell, you have to go into the Windows Registry.
No doubt you've been warned from the day you were born that the Registry is
a dangerous, scary place. Balderdash. In fact, 99 percent of the Registry hacks
that are published in the magazines and books don’t do much in Windows XP.
They aren’t worth the effort. That’s why you won’t see any hacks in this book.
Except for the game hacks. They work great.

You can set each of the four scores in FreeCell — Total Won, Total Lost, Streak
Wins, and Streak Losses — to any number between 0 and 4,294,967,295. You
can also tell FreeCell whether your streak is a winning streak or a losing
streak. Follow these easy steps:

1. Choose Start->Run.

2. Type regedit in the Open text box and click OK.

You see the Windows Registry Editor, the High Priest of Windows XP. |
can see the beads of sweat on your forehead already. No, this isn’t a
scary place. At least, not that scary. Just be careful while you're here.
Follow my instructions. Don’t go changing anything willy-nilly, okay?

3. Choose Edit=>Find.
The Find dialog box appears.

4. In the Find What text box, type FreeCell (no space; capitalization
doesn’t matter) and press Enter.

The Registry Editor moves to a location that looks a lot like the place
shown in Figure 6-4. This is where the FreeCell settings live.

Book |
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5. To see how the Registry entries work, change FreeCell’s Total Won
number to 511. On the right side of the screen, double-click on the
line marked won.

The Edit Binary Value dialog box appears.
6. Press Del on your keyboard four times.

That should wipe out any value that’s currently sitting in the Value data
box. (See Figure 6-5.)

Edit Binary Value

Walue name:
wan

Walue data:

Figure 6-5:
Use this
dialog box
(carefully!)
to change
values in the
Registry.

oooo

7. Type 010000 and press Enter.

In case you were wondering, ff010000 is the value 511, written in a
weird way. Table 6-1 gives you a bunch of common values, and their
equivalents in FreeCell notation. The Registry Editor shows that you
have changed the value of won to 511, er, ff010000. Great!

The weird notation used by FreeCell is called little-endian hexadecimal.

If you want to add more values to Table 6-1, you can. Convert the deci-
mal number you want to 8-digit hexadecimal (using, say, the Windows
Calculator program, discussed in the later section, “Calculating”). Take the
last pair of hex digits and make them the first pair of the FreeCell value.
Take the next-to-last pair and make them the second pair in the FreeCell
value, and so on. Example: 511 in decimal is 00 00 01 ff in hexadecimal,
so the FreeCell value for 511is ff 01 00 00. Try it. You'll see.

8. Choose Start=>All Programs->Games->FreeCell to crank up FreeCell,
choose Gamer>Statistics to bring up the Statistics dialog box, and
verify that FreeCell honestly believes that you have won 511 hands!

9. Go back to the Registry Editor and change the values for Total Lost
(Registry key 10st), Streak Wins (key wins), and Streak Losses (key
losses). Use Table 6-1 to pick some common values.

10. Tell FreeCell that your current streak is a winning streak.
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To do so, double-click stype (Streak Type, eh?), press Del four times,
type 01000000, and press Enter. (If you want to make FreeCell think
you’re on a losing streak, type 00000000.)

11. Choose File-Exit to get out of the Registry Editor.

Table 6-1 Values for FreeCell Registry Hacking
Number What You Should Enter Number What You Should Enter
0 00000000 255 000000
1 01000000 256 00010000
2 02000000 257 01010000
3 03000000 511 ff010000
10 0a000000 512 00020000
" 0b000000 1000 8030000
15 0f000000 1001 €9030000
16 10000000 10,000 10270000
17 11000000 100,000 a0860100
100 64000000 1,000,000 4042000
101 65000000 1,000,000,000 00ca9a3b
254 fe000000 4,294,967,295 ffffffff

Spider Solitaire

When you get the hang of it, Spider Solitaire is every bit as addictive as the
two older Windows Solitaire siblings. Get Spider going by choosing Start=>All
Programs=>Games~>Spider Solitaire.

The easiest way to learn Spider Solitaire is to start with a single suit —
Spider gives you that option when you start. Basically, you have to move
cards around in descending order (see Figure 6-6), and you can mix and
match suits to your heart’s content (pun intended). When you have a
descending sequence (K to A) in a single suit, the entire sequence gets
removed. When you get stuck, click the spider card deck and Spider Solitaire
deals another row of cards.

Spider Solitaire stores its scores in the Windows Registry, just like FreeCell.
You can use a technique very similar to the one [ describe in the preceding
section to hack the Registry and change your scores — it’s almost identical
to the method for Minesweeper as well. Look for the Registry values under
HKEY_CURRENT_USER\Software\Microsoft\Spider. One bit of warning:
Make sure that Spider Solitaire is not running when you change the Registry.
Spider has a nasty habit of resetting Registry values when it finishes, regard-
less of whether you want it to or not.
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Figure 6-6:
Spider
Solitaire
allows

you to mix
suits in
intermediate
steps, but
ultimately
you have to
match them
to win.
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Spider Solitaire has a boss button — push the Esc key when the boss comes
by and Spider quickly minimizes itself.

Minesweeper

One of the most absorbing, simple games ever created — and a longtime per-
sonal favorite of Bill Gates — is Minesweeper, which has been around since
the days of Windows 3.1.

The concept is pretty simple: Click on a square and a number appears, indi-
cating the number of adjacent squares that contain mines (see Figure 6-7).
Click on a square that contains a mine and you lose. Play against the clock.

If you've never tried Minesweeper, you're in for a treat — even inveterate
computer game-haters take a liking to this one.

Minesweeper holds oodles of options:

4 Click Game and choose from Beginner (a 9 x 9 box playing field with 10
mines), Intermediate (a 16 x 16 field with 40 mines), and Expert (16 x 30
with 99 mines). Minesweeper automatically keeps high-score figures for
each.
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4+ Alternatively, you can choose Gamer>Custom and tell Minesweeper how Book |
many squares you want to see and how many mines should be scattered Chapter 6
on the field.

4+ If you think a square contains a mine, and you want to, uh, remine your-
self of that fact, right-click on the square. A flag appears, warning you that
once upon a time, you thought a mine might be here. Right-click on the
same square a second time, and you see a question mark — probably to
remind you that you once thought there was a mine here, but now you're
not so sure, and maybe you really ought to click on the sucker to see
whether it blows up. Right-click on the square a third time, and it goes
back to normal.
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Whenever you want to see the best times and who holds the records, choose
Gamer>Best Times. The Fastest Mine Sweepers dialog box, shown in Figure 6-7,
appears.

The number of seconds since your first click
The number of unflagged mines on the playing field

Click to start a new game

o = 51X
[ ] ©l i
=T 0 CEE] ]
1A1[A1EA[1 (3 | I | |
[ [ 2 11 | |
| fafi2]1{d]1 _|_| | |
R r{_ 2 5 ] et ot e e e e =
1003 1l 5 Tl
11 did I
Figure 6'7: j Beginres: & zeconds Duangkhae -_-
| fiate: 3 seconds dJustin
Th_e Expert j Expert: 1 seconds \»\-’Zody :
Mine- _ CT =
| Reset S [ild il
sweeper j | Sl Beoiet Lo ) =
i 7 =] N P
playing field. El | 5
Three of the adjacent squares hold mines
Yes, you can hack the scores
P There was a well-known cheat for Minesweeper that used to work in older

versions of Windows, but doesn’t appear to work in Windows XP. (At least,
we here at Dummies Central can’t get it to work.) Maybe you’ll be luckier. In
older versions, any time Minesweeper is running, you can type xyzzy and
press Ctrl+Enter. From that moment on, every time you put the mouse over a
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“good” square — one that doesn’t contain a mine — Minesweeper flashes a
tiny, tiny, single white dot in the far upper-left corner of the Windows desk-
top. And every time you put the mouse over a “bad” square, Minesweeper
puts a single black dot in the far upper-left corner. You may have to change
your background or wallpaper to see it, but it’s there. Click when you see the
white dot, and you’ll win every time.

Earlier versions of Minesweeper had a “stop-the-clock” cheat: Start the clock
by clicking on a square; then hold down both mouse buttons and the Esc key
at the same time. That stopped the clock. Unfortunately, that cheat doesn’t
work in Windows XP either. At least, [ couldn’t get it to work.

Oh yes, you can hack the Windows Registry to set the fastest Minesweepers
names and times for the statistics dialog box shown in Figure 6-7. Here’s how:
1. Make sure Minesweeper is not running.
2. Choose Start=>Run.
3. Type regedit in the Open text box and click OK.

That brings up the Windows Registry Editor and, as I warn in the section
on FreeCell, you have to be careful while you're here. Follow my instruc-
tions. Don’t go changing anything willy-nilly.

4. On the left side of the screen, click the + boxes and navigate to
HKEY_CURRENT_USER=Software->Microsoft~>winmine.

5. On the right side of the screen, double-click the line marked Namel.
You see a dialog box called Edit String, like the one shown in Figure 6-8.
6. Type a new name in the Value Data text box.

The new name shows up in the Fastest Mine Sweepers dialog box as the
fastest minesweeper in the Beginner category.

7. Double-click the line marked Timel, click Decimal, enter the Beginner
category winner’s time (in seconds), and click OK.

8. Repeat the process for Name?2 and Time2 (for the Intermediate winner)
and Name3 and Time3 (for the Expert winner).

9. Choose Start=>All Programs->Games=>Minesweeper to get
Minesweeper going, and click Game~>Best Times to bring up the
Fastest Mine Sweepers dialog box and bask in the glory!

10. Get out of the Registry Editor by choosing File->Exit.

You don’t want to leave the Registry Editor open any longer than
necessary.
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Hearts
If you know how to play Hearts, the Windows one-player version will help

you hone your skills. Windows XP plays a mean game of Hearts. Choose
Start=>All Programs=>Games=Hearts to get it going.

T
“l

he people who wrote the Hearts program insist that the computer doesn’t
ook” at your cards — or any other player’s cards — when deciding what to

play.

B

elieve it or not, you can cheat at Hearts and make Windows show you the

contents of all your opponents’ hands (see Figure 6-9). Follow these steps:

1. You have to run Hearts on your computer at least once before you can
make the changes necessary to cheat. If you’ve never run Hearts, choose
Start=>All Programs=> Games=>Hearts, enter your name, and click OK.

2. Choose Start=>Run.
3. Type regedit in the Open text box and click OK.

That brings up the Windows Registry Editor and, as [ warn in the section
on FreeCell, you have to be careful while you're here. Follow my instruc-
tions. Don’t go changing anything you aren’t supposed to be changing.

4. On the left side of the screen, click the + boxes and navigate to HKEY_
CURRENT_USER=Software=>Microsoft=>Windows= CurrentVersion-
Applets=>Hearts.
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Game Help
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Figure 6-9:
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5. Choose Edit=>New=String Value.
The Windows Registry creates a new value called, imaginatively, New
Value #1, and highlights the new value so that you can change its name.
6. Type ZB and press Enter twice.
7. In the Value Data box, type 42, and press Enter.
Your Registry should have a new string value called ZB, with a value of
42, as shown in Figure 6-10. (Douglas Adams fans may pause to ponder
whether Zaphod Beeblebrox and the ultimate answer to Life, the
Universe, and Everything may have a bearing on this setting.)
8. Move back to Hearts (or start it if it isn’t running by choosing
Start=>All Programs—>Games->Hearts). Press Ctrl+Alt+Shift+F12 all at
the same time.
Your opponents’ cards are now visible. To hide them, press
Ctrl+Alt+Shift+F12 again.
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9. Choose File->Exit to get out of the Registry Editor.

You don’t want to leave the Registry Editor open any longer than
necessary.

Hearts has a boss button — push the Esc key when the boss comes by and
Hearts quickly minimizes itself.

Pinball

Although it will never come close to the real thing, Windows 3D Pinball -
Space Cadet (that’s the official name) does have some good graphics, decent
sound, and “nudge” features that make it fun.

The game itself is far more complex than it appears at first blush. You're
trying to advance from Space Cadet to Fleet Admiral by completing mis-
sions. Full details appear in the Pinball Help file, which you can see by
choosing Help=>Help Topics.

When you start Pinball for the first time, you have to hold down the spacebar
on the keyboard to launch the ball, which isn’t the least bit obvious. After
you're over that hump, though, the game is pretty easy: The left flipper is the
Z key and the right flipper is the / key.

Several locations on the Internet claim to have trainers for Space Cadet. A
trainer alters the program itself to give you extra capabilities. The Space
Cadet trainers all claim to give you more than three balls — the major
restriction in the game.

You can hack the Windows Registry to change Pinball scores and winners’
names, but the technique is substantially more difficult than that for FreeCell,
Spider Solitaire, or Minesweeper. Look in the Registry key HKEY_CURRENT_
USER=Softwarer>Microsoft>Plus! oPinball=>Space Cadet. The big trick: The
key called Verification is supposed to contain the sum of all the high scores,
plus the sum of the ASCII values of each character in all the names. (What’s an
ASCII value? If you have to ask, you don’t want to know. Trust me.) Good luck.

Pinball also has a boss button — push the Esc key when the boss comes by
and in a split second, Pinball minimizes itself and turns off the sound.

Internet games

The five Internet games offered for free in Windows XP — Backgammon,
Checkers, Hearts, Reversi, and Spades — all connect to Zone.com (http://
zone.msn.com), a gaming site on the Web. It probably won'’t surprise you
one little bit to discover that Zone.com is actually part of MSN.com, which
(surprise!) is a division of Microsoft.

Book |
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Many corporate Internet firewalls block access to Zone.com. Can’t imagine
why, can you?

The Internet games have three big selling points: They're free; they hook you
up with other players from all over the world, automatically, with no hassle;
and they’re decent (if uninspiring) versions of the games advertised.

The Internet games have one big disadvantage: They’re really just ads.
Microsoft wants you to play the games so that you’ll be tempted to sign up
for a Zone.com membership. When you have a (free) membership, Microsoft
tries to get you to pay for the more sophisticated games. Nothing is inher-
ently wrong with Zone.com, mind you, but you have many choices for online
games. If you think you may be interested, start with the Multiplayer Online
Games site, www.mpogd. com, or use any common Web search site to look for
online games.

Burning CDs

Windows XP includes simple, one-click (or two- or three-click) support for
creating CDs. You need a CD recorder (a CD-R or CD-RW drive) to make your
own CDs, of course, but most PCs these days have them built in. For those
stuck in a PC time warp, if you buy a cheap CD-RW drive that attaches to
your PC via a USB cable, your most difficult job will be pulling it out of the
Styrofoam padding. See Book VI, Chapter 1, for more about installing exter-
nal devices.

Understanding CD-R and CD-RW

Before you burn a CD, you should understand the fundamental differences
between CD-R and CD-RW, the two most popular technologies. Most CD writ-
ers these days can burn both CD-Rs and CD-RWs. You have to choose the
kind that suits your situation:

4 CD-Recordable (CD-R): These discs can be played in audio CD players,
but they cannot be erased. You can record to a CD-R more than once
(up to its capacity) if you use multisession. See www.roxio.com/en/
support/cdr/multisession.html for more information.

4+ CD-Record/Write (CD-RW): These discs can be erased, and the erased
area can be rewritten with new stuff. The downside is that these discs
will not work in some audio CD players (particularly older ones). See
www.roxio.com/en/support/cdr/howrecworks.html for more
information.
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Both CD-Rs and CD-RWs can hold data or music. Both CD-Rs and CD-RWs can
be recorded multiple times, until they run out of space. Both CD-Rs and
CD-RWs can hold 74 minutes of music or 650 MB of data. Some CD-Rs can go
all the way up to 80 minutes of audio, or 700 MB of data. (Yeah, yeah. Some
CD-Rs are supposed to go way beyond that, but I don’t trust 'em, and you
shouldn’t, either.)

DVD is not the same as CD-R or CD-RW. You can’t create DVDs using a CD-R
or CD-RW drive; to burn a DVD, you must have a DVD burner.

Some drives are combo drives, meaning that they will read DVD/CD/CD-R/CD-
RW and write CD-Rs and CD-RWs; however, you can’t burn a DVD with these
drives. DVD recorders are available but there are two competing of formats
that aren’t always compatible. Fortunately, the DVD burners available nowa-
days are almost always capable of burning in both formats; see
www.cdburner.ca/dvd-format-faq.htmfor more information.

Burning with Windows

The first time you try to burn a CD with a new CD writer, work with data files
instead of picture files or music. Start out with the easiest possible scenario
(simple data files) before you work your way up to the most complex (audio
CDs). That increases your chances of finding and solving problems when
they’re easiest to tackle.

When you have a CD-R or CD-RW drive installed and working, transferring
your files to CD couldn’t be simpler. Note: If you want to copy music files,
don’t follow these instructions. Use the Windows Media Player (WMP). I tell
you how to use Windows Media Player in Book VII, Chapter 1. WMP has all
sorts of bells and whistles that are specific to music, and it does a fine job of
burning music CDs with all the ancillary information about artists, titles, and
so on.

Follow these steps to burn a CD with data files:

1. Locate the files (picture, data, program, and so on) you want to burn
to the CD by choosing Start->My Documents, Start=>My Pictures,
Start->My Computer, or Start->My Network Places.

Yes, you can pull files off your network.
2. Select the files that you want to put on the CD.
All of the standard selection methods work:
e (Click once on a file to select it, or Ctrl+click to select multiple files.

¢ C(Click on one file, hold down the Shift key, and click on a different file
to select all the files in between.

Book |
Chapter 6

auoQ yms
aiseg ay) humap



760 Burning CDs

\\J

¢ Lasso a bunch of files and/or folders by clicking and dragging a box
around them.

e Press Ctrl+A to select all the files or folders sitting inside a folder.

You may want to switch views so that you can see more files at once
when selecting them. Choose Viewr>List to see the largest number of
files at once.

. After you select the files that you want to have transferred to your CD,

you need to tell Windows where you want to put them:

e If the Copy to CD command is available in the task pane on the left —
it is available if you are inside a folder that holds pictures (as shown
in Figure 6-11) — click Copy to CD.

e If the Copy to CD command is not available — which means that the
current folder has documents and data files, for example — click
Copy This File (or Copy This Folder, or Copy Selected Items, mutatis
mutandis), and pick the CD-R drive as the destination.

Each time you click Copy to CD, Windows copies the files you have
selected into a temporary storage area, waiting for you to transfer the
files, en masse, to the blank CD. As the files are being copied, Windows
puts a CD-R icon in the notification area, near the time in the lower-right of
the screen, with a balloon that says You have files waiting to be
written to the CD. To see the files now, click this balloon.

. Continue selecting files in this manner until you have all the files you

want.

. When you’re done gathering files, click the balloon in the lower-right

corner of the screen to see Windows’ collection of files that are wait-
ing to be burned on the CD.

Alternatively, choose Start=>My Computer and navigate to the CD-R
drive. You see the files you’'ve chosen, grayed out to indicate that they’re
in a temporary waiting area (see Figure 6-12).

. Make sure that you want to burn all the chosen files. If you change

your mind about any of them, just click on the file or folder and
press Del.

You can move files around to different folders while in the temporary stor-
age area, rename them — just about anything. When you have everything
set up the way you want it, click Write These Files to CD in the CD Writing
Tasks pane. Windows starts the CD Writing Wizard (see Figure 6-13).

. Follow the wizard, inserting a CD when prompted (see Figure 6-14).

When the CD Writing Wizard is done, your files have been transferred to
the CD. Probably. At least, that’s the theory.
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° Immediately after the CD has been burned, take the CD out of the burner,

and try to read it on a different machine. (If you have no other machine, take
it out of the drive and try to read it on the same machine.) If you do this
immediately, and the CD is screwed up, hopefully you can remember which
files were supposed to be on it, and you should have a relatively easy time
reconstructing the CD and burning a new one.

Using the Free Word Processors
That Come with Windows XP

If you’re serious about word processing, you undoubtedly have Microsoft
Word (and probably even Microsoft Office) installed already. Word is a great
program — and one that will serve you well, along with the other useful
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programs in the Office suite. Personally, I've been swearing at Office for Book I
almost a decade — my first four books were about it. Chapter 6

On the other hand, if you only mess around the periphery of word process-
ing, with an occasional letter to Mom or a diatribe to the local newspaper,
you’ll be relieved to know that Windows XP includes two programs that you
can use for simple word processing. While WordPad and Notepad are not
word processing powerhouses like Word, they can help a little bit — as long
as you don’t have any great expectations, anyway.
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Running Notepad

Reaching back into the primordial WinOoze, Notepad was conceived,
designed, and developed by programmers, for programmers — and it shows.
Although Notepad has been vastly improved over the years, many of the old
limitations still pertain. Still, if you want a fast, no-nonsense text editor (cer-
tainly nobody would have the temerity to call Notepad a word processor),
Notepad’s a decent choice.

Notepad understands only plain, simple, unformatted text — basically the
stuff you see on your keyboard. It wouldn’t understand formatting like bold
or an embedded picture if you shook it by the shoulders, and heaven help ya
if you want it to come up with links to Web pages.

Q&N\BEH On the other hand, Notepad’s shortcomings are, in many ways, its saving

& graces. You can trust Notepad to show you exactly what’s in a file — charac-
ters are characters, old chap, and there’s none of this frou-frou formatting
stuff to munge things up. Notepad saves only plain, simple, unformatted text;
if you need a plain, simple, unformatted text document, Notepad’s your tool
of choice. To top it off, Notepad’s fast and reliable. Of all the Windows pro-
grams I've ever met, Notepad is the only one I can think of that’s never
crashed on me.

To start Notepad, choose Start=>All Programs=>Accessories=>Notepad, or
double-click on any text (. txt) file in the Windows Explorer. You see some-
thing like the file shown in Figure 6-15.

Notepad can handle files up to about 48MB in size. (That’s not quite the size
of the Encyclopedia Britannica, but it’s close.) If you try to open a file that’s
larger, a dialog box suggests that you open the file with a different editor.

When you first start Notepad, it displays a file’s contents in the 10-point
Lucida Console font. That font was chosen by Notepad’s designers because
it’s relatively easy to see on most computer monitors.

Just because the text you see in Notepad is in a specific font, don’t assume
for a moment that the data in the file itself is formatted. It isn’t. The font you
see on the screen is just the one Notepad uses to show the data. The stuff
inside the file is plain-Jane, unformatted, everyday text.
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B test.txt - Notepad
Fie Edit Format ‘iew Help
LOG A~

10:00 aM 10/28/2001
working with windows =P, I discovered a previously unknown version of ©
10:03 aM 10,/29/2001
Yes, I'm certain I have it now. with this information 1 shall rule the
11:10 AM 10/30/2001

Figure 6-15:
Notepad in

its initial Wow all I have to do is short all the microsoft shares I can possibly a

form. v
< >

I just re-tried my idea from yesterday, and it works perfectly. I can d

10:19 P 11/10/2001

P If you want to change the font that’s displayed on the screen, choose
Format=>Font and pick from the offered list. You don’t need to select any text
before you choose the font because the font you choose is applied to all the
text on the screen — and it doesn’t affect the contents of the file at all.

If you look at Figure 6-15, you'll notice that text extends way off the right side
of the screen. That’s intentional. Notepad, being ever-true to the file it’s
attached to, skips to a new line only when it encounters a line break — usu-
ally that means a carriage return (or “Enter key”), which typically occurs at
the end of every paragraph.

N Notepad allows you to wrap text on-screen, if you insist, so that you don’t
have to go scrolling all the way to the right to read every single paragraph.
To have Notepad automatically break lines so that they show up on the
screen, choose Format>Word Wrap.

Notepad has one little trick that you may find amusing — possibly worth-
while. If you type .LOG at the beginning of a file, Notepad sticks a time and
date stamp at the end of the file each time it’s opened.

Writing with WordPad

If you really want and need formatting — and you're too cheap to buy
Microsoft Word — Windows XP’s WordPad will do. If you've been locked
out of Word by Microsoft’s nefarious Office (De)Activation Wizard, you’ll
no doubt rely on WordPad to keep limping along until Microsoft can reacti-
vate you.

QWNG/ If you find yourself reading these words because Office has slipped into

Y “reduced functionality mode” (gawd, I love that phrase!), take heart, but be
forewarned: If you aren’t careful, you can really clobber your Word files by
saving them with WordPad. If you have to edit a Word 97, 2000, 2002, or 2003
document with WordPad, always follow these steps:
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1. Make a copy of the Word document, and open the copy in WordPad. Book |

Do not edit original Word documents with WordPad. You'll break them as Chapter &

soon as you save them. Do not open Word documents in WordPad, think-
ing that you’ll do a Save As and save with a different name. You’ll forget.

2. When you get Word back, open the original document, choose
Toolsw>Compare and Merge Documents. Pick the WordPad version of
the document, and click Merge.
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The resulting merged document probably looks like a mess, but it’s a start.

3. Use the Revisions Toolbar (which is showing) to march through your
original document and apply the changes you made with WordPad.

This is the only reliable way I know to ensure that WordPad doesn’t acci-
dentally swallow any of your formatting.

WordPad works much the same as any other word processor, only less so.
Its feature set reflects its price — you can’t expect much from a free word
processor. That said, WordPad isn’t encumbered with many of the confusing
doodads that make Word so difficult for the first-time e-typist, and it may be
a decent way to start learning how simple word processors work.

To get WordPad going, choose Start=>All Programs=>Accessoriess>WordPad
(see Figure 6-16).

Like a Word document or a text file, Rich Text Format (RTF) is another type

of file. RTF documents can have some simple formatting, but nothing nearly
as complex as Word 97, for example. Many word-processing programs from

many different manufacturers can read and write RTF files, so RTF is a good
choice if you need to create a file that can be moved to a lot of places.

If you're just starting out with word processing, keep these facts in mind:

4+ To format text, select the text you want to format; then click the format-
ting you want from the toolbar, or choose Format=Font.

4+ To format a paragraph, you can simply click once inside the paragraph and
choose the formatting from the toolbar, or choose Formatr>Paragraph.
Alternatively, you can select all the text in the paragraph, or in multiple
paragraphs, before applying the formatting.

4+ General page layout (such as margins, whether the page is printed verti-
cally or horizontally, and so on) is controlled by settings in the Page Setup
dialog box. To get to the Page Setup dialog box, choose Filem>Page Setup.

4+ Tabs are complicated. Every paragraph starts out with tab stops set
every half inch. You set additional tab stops by choosing Format=>Tab,
but the tab stops you set up work only in individual paragraphs: Select
one paragraph and set a tab stop, and it works only in the selected para-
graph; select three paragraphs and set the stop, and it works in all three.



166 Using the Free Word Processors That Come with Windows XP

Figure 6-16:
WordPad
working on
a Word 2000
document.

Print Setup is under here

Separate options

Put a picture in a document Paragraph formatting

Fie Edit View Insert Formab  Help

D &1 M &
And w | 13w |[Westemn v | BlsUu B 22 =
g...,_..1 ....... R R Y TR (O R

Tustin| fisst wisited Thailand in March 1990, just befoze he tumned two years pld. He's spent four of b
the phst s Chustmases in Thailand. He lsamed to speal That ot the same fne he leamed to speak
Engtsh. Although he’s lost a lot of what he onee knew about Thai, his intohation and cadence - two

key eloments of spealing That propedy - are vastly supenor to mine.

Justin at “Jam es Bond Tsland ™ Phang-1Mga, southem Thaland

Justiq has traveled all over Thailand, from the hughest mountain in the nosth to the dense jungles in

the squth, and he's traveled ovedand from Thalland to both Butma (br, Myanmad) and Lacs,

croesing by ferry over the Mekong River. He's seen much, much more of Thailand than most Thais.
For Help, |press F1

Character ("font") formatting

WordPad treats tabs like any other character: A tab can be copied,
moved and/or deleted, sometimes with unexpected results. Keep your
eyes peeled when using tabs and tab stops. If something goes wrong, hit
Edit=>Undo immediately and try again.

WordPad lacks many of the features that you may have come to expect
from other word processors: You can’t even insert a page break, much less
a table. If you spend any time at all writing anything but the most straight-
forward documents, you’ll outgrow WordPad quickly.

Taming Character Map

Windows XP includes a utility called Character Map that may prove a life-
saver if you need to find characters that go beyond the standard keyboard
fare — “On Beyond Zebra,” as Dr. Seuss once said. Using the Character Map,
you can ferret odd characters out of any font, copy them, and then paste
them into whatever word processor you may be using (including WordPad).
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Windows ships with many fonts — collections of characters — and several
of those fonts include many interesting characters that you may want to use.
To bring up the Character Map, choose Start=>All Programs=>Accessoriesw
System Tools=>Character Map. You see the screen shown in Figure 6-17.

You can use many characters as pictures — arrows, check marks, boxes, and
so on — in the various Wingdings fonts (see Figure 6-18). Copy them into
your documents, and increase the font size as you like.

Downloading document viewers

Although it won’t compensate for a locked-out copy of Office, Microsoft has
quite a number of free file viewers and format converters. You can’t use a
viewer to edit documents or even print them, but you will be able to see
what the file contains.

&,N\BEH The Word 97/2000 file viewer, in particular — a program called wd97vwr32.
& exe — allows you to view any Word 97 or Word 2000 document. It also
makes an attempt at showing Word 2002 (the version of Word in Office XP)
and Word 2003 documents, but Microsoft won’t guarantee that you’ll see
everything. You don’t have to buy anything; the viewer is free.
Click a character to see an enlarged view
Select a font
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As of this writing, Microsoft distributes free document viewers for the follow-
ing files:

4+ Word 97 and 2000 documents. This viewer also works with most Word
2002 (“Word XP”) and 2003 documents.

4+ Excel 97 and 2000 spreadsheets. The viewer works with most Excel
2002 and 2003 spreadsheets, but you should be very cautious about
trusting it with critical data.

4+ PowerPoint 97, 2000, and 2002 (“PowerPoint XP”) presentations.
Think of this viewer as a slide show program that lets you see the pres-
entation, regardless of whether you have a copy of PowerPoint installed.
This is the only viewer that Microsoft has upgraded in recent years, and
it may not show PowerPoint 2003 presentations properly.

O0Y¥Cgy,  Why hasn’t Microsoft updated the viewers? A more cynical soul than I would
note that Microsoft doesn’t make any money with the file viewers — so why
should they give a hairy rat’s patootie? If you really, really need an accurate
viewer for Office XP or Office 2003 files, get a free 30-day evaluation version of
the software, and let it expire. You'll be left with a bloated but accurate viewer.

To see the viewers that are available and download any viewers you or your
friends may want, go to www.microsoft.com/office/000/viewers.asp.

Calculating

Windows XP includes a very capable calculator. Actually, it contains two
very capable calculators. Before you run out and spend twenty bucks on a
scientific calculator, check out the two you already own!
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To run the calculator, choose Start=>All Programs=>Accessoriest>Calculator.
You probably see the standard calculator.

To use the calculator, just type whatever you like on your keyboard, and
press Enter when you want to carry out the calculation. For example, to cal-
culate 123 times 456, type 123 * 456 and press Enter.

The following are several calculator tricks:

4+ You can use your mouse to “press” the keys on the calculator — an
approach that’s very slow and quite error prone.

4+ Nope, an X on the keyboard doesn’t translate into the times sign. I don’t
know why, but computer people have had a hang-up about this for
decades. If you want “times” you have to press the asterisk on the key-
board — the * or Shift+8 key.

4+ You can use the number pad, if your keyboard has one, but to make it
work you have to get “Num Lock” going. Try typing a few numbers on
your number pad. If the calculator sits there like a dodo and doesn’t
realize that you're trying to type into it, press the Num Lock key. The cal-
culator should take the hint.

Of all the applications in Windows, you’d think that the %$#@! calculator
would let you select the number in the read-out window so that you could
copy it or paste over it, using any of the Windows-standard methods. Huh-
uh. No way. Calculator limits you to copying the entire contents of the read-
out (with Edit=>Copy or Ctrl+C) or overwriting all of the read-out (with
Edit=>Paste or Ctrl+V). The calculator doesn’t even have the usual File menu,
so you can save anything, print anything (like an audit tape), or even per-
form a File=>Exit. Ahhhh! Don’t get me started.

If you need to do some fancy-shmancy calculatin’, choose Viewr>Scientific to
bring up the scientific version of the Windows Calculator program, shown in
Figure 6-19.

The scientific calculator slices and dices and cooks dinner, too. For details
on all of the options, choose Help=>Help Topics.

If you're hacking your Windows games, especially FreeCell, the way I explained
in the “FreeCell” section of this chapter, you should know how to use the sci-
entific calculator to convert decimal numbers to hexadecimal, the same way
as those guys in white lab coats. Here’s how:

1. Select the Dec option button so that the calculator knows you’re
typing a decimal number.

2. Type in the number.
3. Select the Hex option button.

That’s all there is to it. Tough, huh?

Book |
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I suppose you could always toss your tie over your shoulder, moan and groan
about how hard converting these stupid numbers is, and then gnash your teeth
a bit as you click. It would certainly impress the boss. Or the neighbors. The
gnashing teeth would go a long way to cover that hex-eating grin on your face.
And I bet you always thought computer science was a difficult subject.
Painting

Nobody would ever mistake Windows Paint for a real graphics program. It’s a
just-barely-good-enough application for manipulating existing pictures, and it
helps you convert among the various picture file formats (JPEG, GIF, and so
on), but it’s certainly no competition for a real drawing tool like CorelDraw or
a photo-editing tool like Microsoft Photo Editor or Adobe Photoshop.

That said, you can have a lot of fun with Windows Paint. To bring it to life,
choose Start=>All Programsr>Accessories>Paint. You see a screen like the
one shown in Figure 6-20.

Opening, saving, and closing pictures in Paint is a snap; it works just like any
other Windows program. Scanning pictures into Paint goes like a breeze
(choose Filec>From Scanner or Camera). Where you're bound to get in the
most trouble is in free-form drawing, which can be mighty inscrutable until
you understand the following:

4 You select a line color (used by all of the painting tools as their primary
color) by clicking the color on the palette (near the bottom of the window).

4+ You select a fill color (used to fill the inside of the solid shapes, such as
the rectangle and oval) by right-clicking the color.

4 Many of the painting tools let you choose the thickness of the lines they
use — in the case of the spray can, you can choose the heaviness of the
spray — in the box that appears after you select the tool.
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Figure 6-20:
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General rules for editing are a lot like what you see in the rest of Windows —
select, copy, paste, delete, and so on. The only odd editing procedure I've
found is for the free-form selection tool. If you click on this tool and draw an
area on the picture, Paint responds by selecting the smallest rectangle that
encloses the entire line that you've drawn. It’s . . . different.

You can specify the exact size of your picture by choosing Imager>Attributes.

Free-form drawing
Click eyedropper; then click picture to select color
Select by drawing a line

Select by drawing a rectangle

s IEEEFFENEETENN
R Il | (el e

Help, clhck Help Topics onijthe Help Meanu,

Available colors

Current line color and fill color

Draw a straight line

Type text over the top of the picture
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Getting Older Programs to Work

Figure 6-21:
The Program
Compatibility
Wizard
tricks old
programs
into
cooperating
with
Windows
XP.

Program compatibility rates as one of the big nightmares in Windows XP.
So many programs have been written for the PC, for so many years,

that Windows XP has absolutely no way to handle all of them in all
circumstances.

The designers of Windows XP knew that they could never be all things to all
people, so they built a very tricky safety net into Windows XP. In essence,
Windows XP can behave to a remarkable extent like any earlier version of
Windows. So if you have a program that worked under Windows 95, say, and
it doesn’t work under Windows XP, you can tell Windows XP to pretend like
it’s Windows 95, and see if the offending program can be tricked.

The Program Compatibility Wizard doesn’t work all the time, but it does
trick squirrelly programs frequently enough to make the process worth a try.
It makes Windows XP act like Windows 95, 98, Me, NT 4, or 2000. Follow
these steps to use the Program Compatibility Wizard:

1. Choose Start=>All Programs=>Accessories=>Program Compatibility
Wizard.
You awaken the wizard, as shown in Figure 6-21.

2. The wizard searches for programs on your hard drive (or on CD) and
asks you to pick the program that’s giving you problems.

@ Help and Support Center

*

search NN > @ Help and Support Center

Home Edkion

ek 5 1 0p

Program Compatibility Wizard
‘Welcome to the Program Compatibility Wizard
I you are experiencing problems with a program that worked correctly on an earlier version of \Windows, this

wizard helps you select and test compakibiity s=things that may fie those problams,

Caution: It is recommended that you do not use this wizard for older vinus detection, backup, or system
programs.,

T continue, click Mext,

[Mext > Cancel
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3. The wizard then wants to know which version of Windows the program Book |
is expecting. Chapter 6

This can be a bit of a turkey shoot. I have a trash can full of programs
that never ran under any version of Windows, despite advertising to the
contrary. But if you ever got the program to run under any earlier ver-
sion of Windows, start with that version.

4. The wizard wants to know if the program was designed to run with
specific color settings (256 colors) or screen resolutions (640 x 480 or
800 x 600).

It also allows you to turn off Windows XP themes — the fancy graphics
that Windows XP uses to make it look different from earlier versions of
Windows. In my eXPerience, it doesn’t hurt to turn themes off on any
program that’s hiccupping with Windows XP.

auoQ yms
aiseg ay) humap

5. Try to run the program.

If it works, the wizard enables you to easily have those settings kick in
every time you run the program. If it doesn’t work, the wizard offers to
try other settings.

V.Q‘“\NG! Ultimately, if the program doesn’t work, you’re up a creek, unless you can
convince the program manufacturer that Windows XP compatibility is the
most important “new” feature that they can add to their product. (Which
it is.)

Using Sneaky Key Commands

Windows XP includes two well-buried key commands that everyone should
know about. Neither of the key combinations works if your machine is hope-
lessly frozen, but in most normal circumstances, they should help a lot,
especially if a program isn’t behaving the way it should.

Conjuring up the Task Manager

Windows XP has a secret command post that you can get to if you know the
right handshake. Uh, key combination. Whatever. The key combination
works all the time — unless Windows is seriously out to lunch — as long as
you'’re a designated Administrator. If you use Windows XP/Home, you proba-
bly are an Administrator. If you use Windows XP/Pro, you probably are not.
(For a discussion of Administrators, see the section on using account types
in Book I, Chapter 2.)
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Figure 6-22:
Task
Manager
gives you
absolute
control over
the running
applications.

To bring up the Task Manager, hold down the Ctrl, Alt, and Del keys simulta-
neously. Task Manager should appear with a list of all the applications that
are currently running (see Figure 6-22).

With Task Manager, you can do the following:

4+ Click an application, and then click the End Task button to initiate an
orderly shutdown of the application. Windows tries to shut down the
application without destroying any data. If it’s successful, the application
disappears from the list. If it isn’t successful, it presents you with the
option of summarily executing the application (called End Now to the less
imaginative) or simply ignoring it and allowing it to go its merry way.

8 Windows Task Manager

Fi= Options View ‘Windows Shut Down  Help
Applications | Processes | Performance | Metworking | Lisers
Task Stabus
ﬂ Microsoft Office Application Recovery Funning
@Documsntl = Microsoft Word Running
aNmeSwewer Running
) Stark Meru Running
£ >
EndTask | [ swichTo | [ newTask.. |
Processes: 25 CPU Usage: 0% Commit Charge: 106352K | 6334

4+ Click an application, and then click Switch To, and Windows brings up the
switched-to application. This is very convenient if you find yourself stuck
somewhere — in a game, say, that won'’t “let go” while it’s taken control of
your system — and you want to jump over to a different application.

4 Click Shut Down on the menu bar. From that point, you can switch users,
log off, hibernate, restart, or completely shut down the computer.

This is an orderly shutdown, so if you have an application that’s hung so
badly that it won’t terminate itself, you have to tell Windows XP to End Now
and risk losing all the unsaved data in the application.

Task Manager goes way beyond application control. For example, if you have
a somewhat dominant techie gene (it runs in the family), you may be tickled
to watch the progress of your computer on the Performance monitor, which
is in the Task Manager on the Performance tab (see Figure 6-23).
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Switching coolly

Windows includes a quick, easy way to switch among running applications
without diving for the mouse to click on the Windows taskbar. It’s known as
the CoolSwitch (yes, that’s the technical term for it), and it works on any
computer, any time, unless Windows is totally out to lunch.

B Windows Task Manager

Figure 6-23: File Options View Shut Down  Hel
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and some i e AR
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. . . Zommit Charge (K] garnel Mamory (£
Imagine in Tord 104344 Tota 27860
Lirniz [RELLE Pagad L0z
your worst Peck 195244 Norpaged sa6s
nightmares.
Frocesses: 25 TP Lisage: Fa%k Commit Charge: 104344 | 6334
Which happens sometimes.
To use the CoolSwitch, hold down the Alt key and press Tab. You see some-
thing like the screen shown in Figure 6-24.
A very important,
top-secret project
PowerPoint
Figure 6-24: i =
The = ||
Windows XP
CoolSwitch, | [Minesweeper

Windows Explorer with My Music open

As you press Tab over and over again, Windows cycles through the running
programs. When you arrive at the program that you want to run, simply let
go of the Alt key, and the selected program comes to life.

Cool, eh?
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Chapter 7: Maintaining
Vour System

In This Chapter

v Keeping track of the programs installed on your PC

v+ Using Windows Messenger and MSN Messenger — or zapping them
both

v Working with disks
v Scheduling boring things so that your computer does them automatically

v~ Storing more and spending less with Zips

Into every Windows XP’s life a little rain must fall.

Or something like that.

Microsoft claims it has sold more than 200 million copies of Windows XP.
With two major service packs under its belt, every nook and cranny of
Windows XP has been exercised thoroughly — by 200 million ex post facto
beta testers. That’s the main reason why Windows XP has a well-deserved
reputation for working pretty darn well, on almost all computers.

Still, Windows XP is a computer program, not a Cracker Jack toy, and it’s
going to have problems. The trick lies in making sure you don’t have prob-
lems, too.

This chapter takes you through all of the important tools you have at hand
to make Windows XP do what you need to do, to head off problems, and to
solve problems as they (inevitably!) occur.

Windows Update — the big, complicated system that (usually) helps your
system reach out to Microsoft’s computers, and then retrieve and apply
security patches — falls under the Security Center umbrella and, as such, is
discussed in Book II, Chapter 5.
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Installing and Removing Programs
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Figure 7-1:
Add or
remove
programs.

Windows only lives to serve — or so I'm told — and, more than anything,
Windows serves programs. Most of us spend our time working inside pro-
grams such as Outlook or Word or PageMaker. Windows acts as traffic cop
and nanny, but doesn’t do the heavy lifting. Programs rule. Users rely on
Windows to keep the programs in line.

Windows XP includes a one-stop shopping point for adding and removing
programs. To get to it, choose Start=>Control Panel=>Add or Remove
Programs. You see the Add or Remove Programs dialog box, as shown in
Figure 7-1.

When Windows talks about changing programs, it isn’t talking about making
minor twiddles — this isn’t the place to go if you want Microsoft Word to
stop showing you rulers, for example. Add or Remove Programs is designed
to activate or deactivate big chunks of a program — graft on a new arm or
lop off an unused head (of which there are many, particularly in Office). If
you look at Figure 7-2, you can see the kind of grand scale I'm talking about:
In Add or Remove Programs, you may tell Excel that you want to use its
Analysis ToolPak add-in for financial analysis. Similarly, you may use Add or
Remove Programs to completely obliterate Office’s Speech Recognition capa-
bilities. That’s the kind of large-scale capability I'm talking about.

Windows XP itself doesn’t do much in Add or Remove Programs. The main
function of Windows is as a gathering point: Well-behaved programs, when
they’re installed, are supposed to stick their uninstallers in Add or Remove
Programs. That way, you have one centralized place to look when you want
to get rid of a program. Microsoft doesn’t write the uninstallers that Add or
Remove Programs runs; if you have a gripe about a program’s uninstaller,
you need to talk to the company that made the program.
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Several school-of-hard-knocks comments pertain:

4+ In practice, you should never use Add or Remove Programs to add pro-
grams. If you want to install a program, do what savvy Dummies always
do: Put the CD in the CD drive and follow the instructions. It’s a whole
lot easier that way.

4+ You rarely use Add or Remove Programs to remove parts of a program.
Either you try to add features in a program that you forgot to include
when you originally installed the program — most commonly with
Office — or you want to delete a program entirely, to wipe its sorry tail
off your hard drive.

Why sweat the small stuff? When you install a program, install all of it.
Even Office 2003, in all its bloated glory, only takes up 600MB if you
install every single far-out filter and truculent template — 800MB if you
get suckered into installing the Outlook 2003 Business Contact Manager.
With hard drives so cheap they’re likely candidates for landfill, it never
pays to cut back on installed features to save a few megabytes.

4+ Many uninstallers, for reasons known only to their company’s program-
mers — [ won’t mention Adobe by name — require you to insert the pro-
gram’s CD into your CD drive before you uninstall the program. That’s
like requiring you to show your dog’s vaccination records before you
kick it out of the house.
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When you start a program’s uninstaller, you're at the mercy of the unin-
staller and the programmers who wrote it. Windows doesn’t even enter into
the picture.

Installing and Removing Parts of Windows

Most people never use big parts of Windows XP. Some parts are made with
very specific functions in mind and, with two exceptions, the average Person
on the Street rarely encounters the requisite specific situations.

Thank heaven.

The two exceptions? Fax support and automatic backup in Windows. Neither
gets installed unless you make the trek to retrieve it. Fax is relatively simple
and benign; I talk about it here. Backup is much meaner; [ talk about it in the
“Backup/Restore” section, later in this chapter.

Windows’ support for faxing has never been great. Although it’s theoretically
possible for you to get the Windows fax application working, one great
Achilles’ heel hampers you: If you have just one modem and it’s connected
to the Internet, you can’t use it to send or receive faxes! Funny how
Microsoft glosses over that detail, eh?

The smartest Dummies | know don’t try to use Windows for faxing. Instead,
they have a standalone fax machine (connected to its own telephone line, of
course), or they use a fax service such as j2 Messenger (www. j2.com). j2’s
software lets you send faxes as easily as you print: Choose Filec>Print=>Send
with j2 Messenger, and the program turns your fax into an e-mail message.
When you send the message to j2 headquarters — along with all your other
e-mail — it’s routed to a location close to the recipient, converted into a fax
and then actually faxed for you, generally at a fraction of the cost for a long-
distance phone call. j2 also offers inbound fax delivery: Your correspondent
sends a fax to a specific phone number, the fax is converted to e-mail, and
the e-mail is sent to you — all within a matter of seconds.

If the preceding caveat hasn’t warned you off, here’s how you install the
Windows fax software. The same general procedure works for installing
other obscure parts of Windows:

1. Choose Start>Control Panel->Add or Remove Programs to bring up
Add or Remove Programs.

2. Click Add/Remove Windows Components to bring up the Windows
Components Wizard (see Figure 7-3).
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Find the component that you want to add.

In this case, because you're trying to add fax support, select the Fax
Services check box. In general, you may have to click on a likely sound-
ing component, and then click the Details button to see which subcom-
ponents are available.

Insert the CD that Windows came on so that Windows can pull the
component off the CD and install it on your PC.

You may be required to restart Windows. In any case, by the time the
wizard is done, your new component should be available and ready
to use.

If you performed a typical installation of Windows XP/Home, the following
list covers the components that you installed and have available:

<+
+

All the Accessories and Utilities are installed.

Fax Services aren’t installed. Follow the preceding instructions to install
Windows faxing, but make sure you understand the limitations.

Indexing Service is installed.

The only Management and Monitoring Tools available are for an obscure
Internet network management standard called SNMP, or Simple Network
Management Protocol. You can look up SNMP in the Windows Help and

Support Center, but if you need to look it up, you probably don’t need it.

Internet Explorer and MSN Explorer are installed. You can get rid of them
here, if you really want to.
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If you read the fine print, you’ll discover that Add/Remove Windows
Components isn’t really offering to remove Internet Explorer. This option,
ahem, “Adds or removes access to Internet Explorer from the Start menu
and the desktop.” In other words, you can get rid of the shortcut to IE
from the Start menu (Windows XP, as it ships in plain-vanilla systems,
doesn’t have a shortcut to IE on the desktop) using this option. Not
exactly what you expected, eh? Windows relies on IE for all sorts of serv-
ices, including the ability to interpret formatted e-mail messages, and
many more. You can no more uninstall [E than you can uninstall your
cerebral cortex — no matter what the courts say.

4+ Under Networking Services, you can add three subcomponents — RIP
Listener, which works with NetWare’s Router Information Protocol
Version 1; Simple TCP/IP Services, an obscure group that includes Quote
of the Day; and Universal Plug and Play support, which comes into ques-
tion only if you have UPnP devices installed (confusingly, UPnP isn’t
related to Plug 'n Play, the industry-wide standard for identifying
hardware).

4 Other Network File and Print Services includes support for only UNIX
(and Linux) computers to print on printers connected to your PC.

4+ The software to automatically Update Root Certificates (digital security
certificates for Microsoft products) is installed and running.

4+ Windows Messenger — Microsoft’s instant messaging/chat program — is
installed by default, and runs incessantly. See the section on chatting
with Windows Messenger in Book Ill, Chapter 4 for more information.

Maintaining Disks

E pur, si muove.
Even so, it does move.

Galileo, to his inquisitors, April 30, 1633

Disks (floppies, hard drives, and other types of storage media) seem to
cause more computer problems than all other infuriating PC parts com-
bined. Why? They move. And unlike other parts of computers that are
designed to move — printer rollers and keyboard springs and mouse balls,
for example — they move quickly and with ultra-fine precision, day in and
day out.

I go into details about the various kinds of disks and their plusses and
minuses in the section on managing disks in Book I, Chapter 1. If you're unfa-
miliar with the inner workings of the beasts, that’s a good place to start.
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Like any other moving mechanical contraption, an ounce of disk prevention
is worth ten tons of cure. Unlike other moving mechanical contraptions, a
good shot of WD-40 usually won’t cure the problem.

Formatting: NTFS versus FAT32

If you’ll forgive a slightly stretched analogy, the surface of a floppy diskette
or the surface of the platters inside a hard drive is a lot like a blank audio
cassette tape. You know, the kind you can buy for 29 cents at a discount
store. The surface of a floppy diskette is coated with some sort of magnetic
gunk that somehow magically stores electrical impulses, holds onto them,
and then spits them back when you want them.

Audio cassette tapes are amazingly forgiving — ever turn one into an accor-
dion with a lousy capstan? — but diskettes and hard drives generally aren’t
so forgiving. Disks try to pack a lot of data into a small space, and because of
that, they need to be calibrated. That’s where formatting comes in.

When you format a disk, you calibrate it: Mark it with guideposts that tell the
PC where to store data and how to retrieve it. Every floppy diskette and
every hard drive has to be formatted before it can be used. Chances are
good that the manufacturer formatted your disk before you got it. That’s
comforting, because every time a disk gets reformatted, everything on the
disk gets tossed out, completely and irretrievably. Everything.

If you feel like you have to completely wipe out everything on a disk (even
a USB flash drive or Compact Flash card) and start over, you can reformat it
in one of two ways:

4+ Choose Start>My Computer to bring up Windows Explorer, right-click
on the drive you want to reformat, click Format, and click Start. As long
as you're a designated Administrator (see the section on using account
types in Book I, Chapter 2), you receive the dialog box and warning
shown in Figure 7-4.

4+ Reformat your hard drive as part of a complete (re)installation of
Windows XP. See the section on considering a clean install in Book I,
Chapter 1 for details.

Reformatting a hard drive really does obliterate everything. You not only
lose your documents, pictures, programs, and e-mail messages; if they’re on
the zapped hard drive, you also lose all of your settings, your passwords,
and anything you’ve done to customize Windows. It’s a drastic step.
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The primary choice you have to make when formatting or reformatting a
hard drive — or even buying a preformatted hard drive — is which of the
two competing file systems you should employ:

4+ FAT32: Stands for 32-bit File Allocation Table, as if that means anything
to an honest chap. FAT32 is the old DOS/Windows 98/Me method for
storing data on a hard drive. You may want to use FAT32 if you have disk
utility programs that you absolutely have to run that absolutely require
FAT32 (check the manufacturer’s Web site). You may also want to stick
with FAT32 if you intend to run two different versions of Windows on the
same machine (a process called multiple booting, which, thankfully, is
way beyond the scope of this book), or if you find yourself occasionally
using an ancient emergency Windows 95/98/Me boot diskette to bring an
old system back to life: They understand only FAT.

If you really want to use one PC to start up with many different operating
systems — Windows 95, 98, Me, NT 3.51, NT 4, 2000, Linux, whatever —
start with the instructions at www.microsoft.com/windowsxp/pro/
using/howto/gettingstarted/multiboot.asp.
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4+ NTFS: Stands for Windows NT File System. NTFS isn’t quite as Neolithic
as FAT32. NTFS includes built-in support for security and compression.
It’s the file system of choice in almost all circumstances.

As long as you're a designated Administrator (see Book I, Chapter 2 on using
account types), formatting a drive for NTFS is as simple as choosing NTFS in
the File System drop-down list in the Format dialog box. You can also con-
vert an existing FAT32 drive or partition (part of a drive) to NTFS by using an
arcane command called convert. For details, search the Windows Help and
Support Center for convert ntfs. Windows has no analogous command to con-
vert NTFS drives (or partitions) to FAT32.

If you install Windows XP on a PC that’s running Windows 98 or Me,
Windows offers you an opportunity to change any existing FAT32 drives (or
partitions) to NTFS. Unless you have a very specific reason for sticking with
FAT32, letting the system convert the drive is a good idea.

If you have a big hard drive, you may be forced to use NTFS. Windows XP
won’t format a hard drive larger than 32GB for FAT32. Windows has good rea-
sons for this restriction, but the upshot is that really big drives need NTFS.

Performing periodic maintenance

Hard drives die at the worst possible moment. A hard drive that’s starting to
get flaky can display all sorts of strange symptoms: Everything from long,
long pauses when you're trying to open a file to completely inexplicable
crashes and other errors in Windows itself.

Windows XP comes with a grab bag of utilities designed to help you keep your
hard drives in top shape. One of them runs automatically every time your
system shuts down unexpectedly, like when the dog finally bites through the
power cord: The next time you start your system, Windows scans your hard
drives to see whether any pieces of files were left hanging around.

You can spend a lot of time futzing around with your hard drives and their
care and feeding if you want, but as far as I'm concerned, just three utilities
suffice: Check Disk, Cleanup, and Disk Defragmenter. You have to be a desig-
nated Administrator (see the section on using account types in Book I,
Chapter 2) to get them to work.

Running an error check

If a drive starts acting weird — for example, you get errors when trying to
open a file, or Windows crashes in unpredictable ways — run the Windows
error-checking routines.

Book |
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If you're an old hand at Windows — or an even older hand at DOS — you
probably recognize the following steps as the venerable CHKDSK routine, in
somewhat fancier clothing.

Follow these steps to run Check Disk:

1. Choose Start->My Computer.
2. Right-click the drive that's malfunctioning and click Properties.
3. On the Tools tab, click Check Now.

The Check Disk dialog box appears (see Figure 7-5).

4. In most circumstances, you want to select the Scan for and Attempt
Recovery of Bad Sectors check box, and then click the Start button.

If you don’t want to sit and wait and wait and wait for Windows to finish,
you probably want to select the Automatically Fix File System Errors
check box, too.

As long as you aren’t using any files on the hard drive that Windows is scan-
ning, Windows performs the scan on the spot and reports back on what it
finds. If you are using files on the hard drive, however — and that always
happens if you're scanning the drive that contains Windows itself —
Windows asks whether you want to schedule a scan to run the next time you
restart your machine. If you say yes, you have to turn the computer off and
then turn it back on again before Windows runs the scan. (Note that merely
logging off isn’t sufficient.)
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Scheduling cleanups

In addition to running an error check from time to time, I use the Windows
Task Scheduler to periodically go through and remove temporary files that I
don’t need, with a utility called Cleanup. I tell you how to do that in the sec-
tion, “Scheduling Task Scheduler,” later in this chapter.

Defragmenting a drive

Every week or so (or whenever I'm thinking about it), I run the Windows Disk
Defragmenter on all my hard drives. This is quite different from the Check
Disk routine (refer to Figure 7-5), which concentrates on the surface of the
hard drive and whether it has been corrupted. Files become fragmented —
scattered in pieces all over a hard drive — when Windows dynamically cre-
ates and deletes files. Having many fragmented files on a hard drive tends to
slow down processing because Windows has to jump all over to reassemble
a file when you ask for it. Windows Disk Defragmenter focuses on putting the
pieces of files back together, in contiguous slots, so that Windows doesn’t
have to scamper all over the hard drive to read an entire file. To run the
defragmenter, follow these steps:

1. Turn off your antivirus program, and any other programs that might
be running.

AV programs are notorious for gumming up defrags. Any program that
goes out to your hard drive can interrupt the defrag.

2. Choose Start=>All Programs=>Accessories=>System Tools=>Disk
Defragmenter.

Alternatively, you can navigate to the drive in question, right-click it,
click Properties, click Tools, and click Defragment Now (refer to
Figure 7-5).

3. Click the drive that you want to work on, and then click Analyze.
Windows XP checks to be sure that the files are put together properly,

and then it advises you about whether a defragmentation run is worth-
while (see Figure 7-6).

4. To run the defragmenter, click the Defragment button.

5. Break out that novel you’ve always wanted to read. This can take a
long, long time.

While Windows is defragmenting, it keeps you posted on its progress at
the bottom of the Disk Defragmenter window (see Figure 7-7), but don’t
be surprised if the “percent complete” figure freezes for a while and then
jumps inexplicably.
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Figure 7-6:
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Use those three tools regularly — Check Disk, Cleanup, and Disk
Defragmenter — and your hard drives will thank you. Profusely.
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Backup/Restore

Windows XP/Pro comes with a very thorough (and very complex) backup
and restore capability called Automated System Recovery, or ASR. The
Backup part of ASR works through a wizard. If your computer is hooked up
to a Big Corporate Network, and all the pieces are in place and working prop-
erly, the Restore part can kick in, at your command, when you reboot the
computer — even if your system was so thoroughly messed up you had to
replace the hard drive.

If you think you're going to click a couple of times and get automatic back-
ups from Windows XP, you're in for a very rude awakening. While working
with ASR isn’t as complex as, say, setting up and maintaining a Big Corporate
Client/Server Network, mastering ASR will certainly take you more than a
day, assuming you already have a Ph.D. in Computer Science. Check the
Windows XP Help and Support Center for the topic ASR and you’ll see why.

Earlier versions of Windows let you boot your PC with a special diskette
called an Emergency Repair Disk (or Emergency Boot Disk in very early ver-
sions). Windows XP doesn’t have an ERD. All of the functions of the old ERD
have been subsumed by ASR. Yes, that means you can’t boot to Windows XP
directly from diskette anymore.

In general, if Windows won’t boot at all, you need to haul out your installa-
tion CD and boot from the CD. If your computer won’t boot from a CD, for
whatever reason, Microsoft has a set of seven diskettes that will let you start
your computer, and get you to the point where you can run Windows from
the CD. See www.bootdisk.com for details.

If you're using Windows XP/Pro and you need automatic backups through
your Big Corporate Network (you probably do!), and your network isn’t
already set up to handle backups, your only realistic choice is to bring in
somebody who knows ASR and have them configure it for you. Usually, the
designated stuckee is your favorite whipping boy, the Network Administrator.
ASR kinda goes hand in hand with other Big Corporate Network chores.

What if you're using Windows XP/Home? Ah, have I got a gotcha for you.

Back in the weeks leading up to Windows XP’s release, Microsoft announced
that it would ship ASR and its backup subsystem with Windows XP/Pro, but
would not include any sort of automatic backup with Windows XP/Home.
That brought a hailstorm of criticism from two different perspectives: the
“XP/Home users need backup just as much as XP/Pro users” contingency
and the “Windows has always had a backup routine even if nobody ever
used it” contingency. Both contingencies won.
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Microsoft does, indeed, ship ASR Backup with Windows XP/Home — if you
know where to find it. Except, uh, well, er, there’s no ASR Restore to go along
with it. That makes Windows XP/Home’s backup just about as useful as a
Ferrari Testarossa with no wheels. Or a transmission, engine, seats, or brakes.

If you really, really want to install ASR Backup (better known as NTBackup)
in Windows XP/Home, even though there’s no built-in restore, put the
Windows XP/Home CD in a convenient drive and wait for the Welcome to
Microsoft Windows XP screen. Choose Browse this CD=>Valueadd=>MSFT>
NTBACKUP. Make sure you read (and understand!) the warning in the file
readme.txt before running the installer.

TEC/, ",

Scheduling Task Scheduler

Windows XP has a built-in scheduler that runs just about any program
according to any schedule you specify — daily, weekly, monthly, middle of
the night, on alternate blue moons.

The scheduler comes in handy in two very different situations:

4+ When you always want to do something at the same time of day.
Perhaps you always want to dial up the Internet at 6:15 every morning,
so that your machine is connected by the time you drag your sorry tail
into your desk chair. Or maybe you want to run a PowerPoint presenta-
tion every morning at 7:30, so that your boss hears the tell-tale sounds
as she walks by your cubicle. (And who said Dummies aren’t Devious?)

4+ When you want to make sure that the computer performs some mun-
dane maintenance job when it won’t interfere with your work time.
Thus, you may schedule disk cleanups every weekday at 2:00 in the
afternoon because you know you’ll always be propped up in the mop
closet taking a snooze.

P Any discussion of scheduled tasks immediately conjures up the old ques-
tion, “Should I leave my computer running all night, or should I turn it off?”
The fact is that nobody knows which is better. You can find plenty of argu-
ments on both sides of the fence. Suffice it to say that your computer has to
be on (or suspended) for a scheduled task to run, so you may have to leave
your computer on at least one night a week (or a month) to get the mainte-
nance work done.

QNING/ You find absolutely no debate about one “should I leave it on” question,

Y though. Everybody in the know agrees that running a full surface scan of your
hard drive daily is a bad idea. (Specifically Check Disk, see the “Performing
periodic maintenance” section, earlier in this chapter.) A full scan simply
inflicts too much wear and tear on the hard drive’s arms. It’s kind of like forc-
ing yourself to fly every morning just to keep your shoulders in shape.
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One of the most important uses of the Task Scheduler is driving a Windows Book I
file cleanup program called, imaginatively, Cleanup. I talk about it earlier in Chapter 7
this chapter in the section, “Maintaining Disks.” Here’s how to get Cleanup

scheduled — and how to use the Task Scheduler in general:

1. Make sure you have at least one user set up with Administrator privi-
leges and a password.

wa)shg anop
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The Task Scheduler requires that you supply it with a user name that
has a password, and a password that’s valid at the time Task Scheduler
runs. If you change the password in Windows, you have to go back into
the Task Scheduler and change the password there. Otherwise, the
scheduled task won’t run, and you may not find out about it until
months later.

To set up an account with a password, see Book [, Chapter 2. For a quick
overview of the problem, see http://support.microsoft.com/
?kbid=311119. For several solutions, see Windows XP Timesaving
Techniques For Dummies, Technique 21, written by yours truly and
published by Wiley Publishing, Inc.

2. Choose Start=>All Programs=>Accessories->System Tools=>Scheduled
Tasks to get the Task Scheduler going.

Yes, your instincts are correct if you looked at the Scheduled Tasks win-
dows and thought that something appeared familiar. All of Windows XP’s
Scheduled Tasks appear in a folder called Scheduled Tasks. The tasks
themselves are just files, and the Add Scheduled Task icon is just a wizard.
If you ever need to look at the Scheduled Tasks on a PC connected to your
network, look for the Scheduled Tasks folder.

3. Double-click the icon marked Add Scheduled Task.

The Scheduled Task Wizard appears with a frou-frou introductory
screen.

4. Click Next.

You see a list of some available programs, as shown in Figure 7-8.

Does the list in Figure 7-8 look like an odd assortment of programs? It is.
The Scheduled Task Wizard takes all the programs listed on the Start
menu, alphabetizes them, and throws them all in this list. Literally. If you
want to schedule a program that isn’t on the Start menu, you have to
click the Browse button.

5. In this example, assume that you want to schedule regular Disk
Cleanup runs, so click Disk Cleanup, and then click Next.

You can tell Windows how frequently you want to run Disk Cleanup by
selecting one of the Daily, Weekly, Monthly, and so on option buttons in
the window that appears.
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6. Click Next again, and you can set the exact schedule — which days,
what times.
7. Click Next again, and the Scheduled Task Wizard asks you to provide
security information (see Figure 7-9).
Scheduled Task Wizand

Entes the name and passwond of & user. The task will

i as il it were started by that uses,
Figure 7-9:
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sufficient
authority to
run it
manually. cBack || Mea> | [ Cancel

This is an important screen because it reinforces the point that you
aren’t given any special security privileges just because you're schedul-
ing a program. The program runs only if you have the authority to make
it run. (See the section on using account types in Book I, Chapter 2.)

*x

In the very last step, you can set Advanced Properties for the sched-
uled task.

The advanced properties include telling Windows XP what to do if the
task takes a verrrry long time to complete; whether the task should go
into hibernation if something else happens on the computer (presum-
ably you’re awake in the wee hours, banging out an assignment); and
whether Windows should wake up the computer if it’s hibernating or run
the task if the PC is using batteries at the time.
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The Windows Disk Cleanup program has a handful of settings that you may
want to twiddle (see Figure 7-10). The System Schedule Wizard doesn’t have
any way to allow you to pick and choose your options for a scheduled pro-
gram. The solution? Run Disk Cleanup once by hand (choose Start=>All
Programs=Accessories=>System Tools=>Disk Cleanup). Disk Cleanup remem-
bers the settings that you applied when you ran it manually, and it uses
those settings every time you run it with the Task Scheduler. Many other
Windows programs work the same way.
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inover a week,
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Zipping and Compression

Windows XP supports two very different kinds of file compression. The dis-
tinction is confusing but important, so bear with me.

File compression reduces the size of a file by cleverly taking out parts of the
contents of the file that aren’t needed, storing only the minimum amount of
information necessary to reconstitute the file — extract it — into its full, orig-
inal form. A certain amount of overhead is involved because the computer
has to take the time to squeeze extraneous information out of a file before
storing it, and then the computer takes more time to restore the file to its
original state when someone needs the file. But compression can reduce file
sizes enormously. A compressed file often takes up half its original space —
even less, in many cases.

How does compression work? That depends on the compression method
you use. In one kind of compression, known as Huffman encoding, letters
that occur frequently in a file (say, the letter e in a word-processing
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document) are massaged so that they take up only a little bit of room in the
file, while letters that occur less frequently (say, x) are allowed to occupy
lots of space. Instead of allocating eight 1’s and 0’s for every letter in a docu-
ment, say, some letters may take up only two 1’s and 0’s, while others could
take up 15. The net result, overall, is a big reduction in file size. It’s compli-
cated, and the mathematics involved get quite interesting.

Windows XP’s two file compression techniques are as follows:

4+ Files can be compressed and placed in a “Compressed (zipped) Folder,”
with an icon to match.

4+ Files, folders, or even entire drives can be compressed using NTFS’s
built-in compression capabilities.

For a description of NTFS, see the “Formatting: NTFS versus FAT32” section,
earlier in this chapter.

Here’s where things get complicated.

NTFS compression is built into the file system: You can use it only on NTFS
drives, and the compression doesn’t persist when you move (or copy) the
file off the drive. Think of NTFS compression as a capability inherent to the
hard drive itself. That isn’t really the case — Windows XP does all the
sleight-of-hand behind the scenes — but the concept will help you remember
NTFS compression’s limitations and quirks.

Although Microsoft would have you believe that “Compressed (zipped)
Folder” compression is based on folders, it isn’t. A “Compressed (zipped)
Folder” is really a file — not a folder — but it’s a special kind of file called a
Zip file. If you've ever encountered Zip files on the Internet (they have a file-
name extension of . zip and they’re frequently manipulated with programs
such as WinZip, www.winzip.com), you know exactly what I'm talking about.
Zip files contain one or more compressed files, and they use the most
common kind of compression found on the Internet. Think of “Compressed
(zipped) Folders” as being Zip files, and if you have even a nodding acquain-
tance with ZIPs, you’ll immediately understand the limitations and quirks of
“Compressed (zipped) Folders.” Microsoft calls them “Folders” because
that’s supposed to be easier for users to understand. You be the judge.

If you have Windows show you filename extensions — see my rant about that
topic in the section on showing filename extensions in Book I, Chapter 3 —
you see immediately that “Compressed (zipped) Folders” are, in fact, simple
Zip files.
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Table 7-1 shows a quick comparison of NTFS compression and Zip

195

compression.

Table 7-1 NTFS Compression versus “Compressed
(Zipped) Folders” Compression

NTFS Zip

Think of NTFS compression as a feature of
the hard drive itself.

Zip technology works on any file, regardless
of where it is stored.

The minute you move an NTFS compressed
file off an NTFS drive — by, say, sending a
file as an e-mail attachment — the file is
uncompressed, automatically, and you can't
do anything about it: You'll send a big,
uncompressed file.

You can move a “Compressed (zipped)
Folder” (actually a Zip file, with a .ZIP file
name extension) anywhere, and it stays
compressed. If you send a Zip file as an
e-mail attachment, it goes over the ether as
a compressed file. The person receiving the
file can view it directly in Windows XP, or he
can use a product such as WinZip to see it.

Alot of overhead is associated with NTFS
compression: Windows has to compress
and decompress those files on the fly,
and that sucks up processing power.

Very little overhead is associated with Zip
files. Many programs (for example, antivirus
programs) read Zip files directly.

NTFS compression is great if you're running
out of room on an NTFS formatted drive.

“Compressed (zipped) Folders” (that is to
say, Zip files) are in a near-universal form
that can be used just about anywhere.

You have to have Administrator privileges
in order to use NTFS compression.

You can create, copy, or move Zip files just
like any other files, with the same security
restrictions.

You can use NTFS compression on entire
drives, folders, or single files. They cannot
be password protected.

You can Zip files or folders, and they can be
password protected.

If you try to compress the drive that contains your Windows folder, you
won’t be able to compress the files that are currently in use by Windows.

To use NTFS compression on an entire drive, follow these steps:

1. Make sure that you are a full-fledged Administrator (see Book I,

Chapter 2).

2. Choose Start=>"My Computer and right-click the drive that you want
to compress. Click Properties and then click the General tab (see

Figure 7-11).
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If the drive is formatted with NTFS (see the section, “Formatting: NTFS
versus FAT32,” earlier in this chapter), you see a check box saying
Compress Drive to Save Disk Space. Select this check box.

Windows asks you to confirm that you want to compress the entire
drive. Windows takes some time to compress the drive — in some cases,

To use NTFS compression on a folder or single file, follow these steps:

Make sure that you are a full-fledged Administrator (see Book I,

Navigate to the folder or file you want to compress (for example,
choose Start=>My Documents or Start=>My Computer). Right-click on
the file or folder you want to compress. Click Properties and click the

. Select the Compress Contents to Save Disk Space check box, and then

To uncompress a file or folder, go back into the Advanced Properties

Figure 7-11:
NTFS Diive Disk Clearup
Compression
is available [¥] Compress drive to save disk space
Only on [¥] &llows Indexing Service to indsx this dizk for fast file searching
drives
formatted
for NTFS. [ ok ] l Cancel J l pyy
3.
4. Click OK.
the estimated time is measured in days. Good luck.
1.
Chapter 2).
2.
Advanced button on the General tab.
The Advanced Properties dialog box appears.
3
click OK.
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dialog box (right-click the file or folder, click Properties, and then click
Advanced) and deselect the Compress Contents to Save Disk Space
check box.
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To use Zip compression, er, “Compressed (zipped) Folders,” you must first
create a Zip file, er, a “Compressed (zipped) Folder.” Here’s how:

1. Choose Start->My Documents to navigate to the folder that you want
to contain your new Zip file.

2. Right-click in any convenient empty location within the window and
choose New~>Compressed (Zipped) Folder.

Windows responds by creating a new Zip file, with a . z1ip filename
extension, and placing it in the current folder.

The new file is just like any other file — you can rename it, copy it, move
it, delete it, send it as an e-mail attachment, save it on the Internet, or do

anything else to it that you can do to a file. (That’s because it is a file.)

3. To add a file to your “Compressed (zipped) Folder,” simply drag it
onto the zipped folder icon.

4. To copy a file from your Zip file (uh, folder), double-click the zipped
folder icon, and treat the file the same way you would treat any “regu-
lar” file (see Figure 7-12).

I8 New Compressed (zipped) Folder.zip
File Edk Wiew Favorltes Took  Help o

Qe - () (T O search [ Foders

{#1 Extract all files

| Other Places

) Woody's Documents
(=) My Documenits

) Shared Documents

N My Netwoek Places

Details

5. To copy all of the files out of your Zip file (folder), click Extract All
Files in the Folder Tasks pane.

You see the Windows XP Compressed (zipped) Folders Extraction
Wizard (see Figure 7-13), which guides you through the steps.

The Compressed (zipped) Folders Extraction Wizard places all the copied

files into a new folder with the same name as the Zip file — which confuses
the living bewilickers out of everybody. Unless you give the extracted folder
a different name from the original Compressed (zipped) Folder, you end up
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Figure 7-13:
To copy all
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Zip file,
“extract”
them using
this wizard.

with two folders with precisely the same name sitting on your desktop. Do
yourself a huge favor and feed the wizard a different folder name while
you're extracting the files.

Nico Mak’s WinZip compression utility runs rings around Windows XP’s
built-in “Compressed (zipped) Folder” features. Check out www.winzip.com
for details.
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Creating Checkpoints and System Restore

A\

Ever get the feeling that things were going right?

Moments later, did you get the feeling that something must be wrong
because things are going right?

Now you understand the gestalt behind System Restore. If you take a snap-
shot of your PC from time to time, when things are going right, it’s relatively
easy to go back to that “right” time when the wolves come howling at the,
uh, Gates.

Windows XP automatically takes System Restore snapshots — called check-
points — when it can tell that you're going to try to do something compli-
cated, such as install a new network card. Unfortunately, Windows can’t
always tell when you’re going to do something drastic — perhaps you have a
new CD player and the instructions tell you to turn off your PC and install
the player before you run the setup program. So it doesn’t hurt one little bit
to run checkpoints from time to time, all by yourself.
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Here’s how to generate a System Restore checkpoint: Book |
Chapter 7
1. Wait until your PC is running smoothly.

No sense in having a checkpoint that propels you out of the frying pan
into the fire, eh?

2. Make sure you're set up as an Administrator (see Book I, Chapter 2).
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3. Choose Start=>All Programs->Accessories->System Tools->System
Restore.

You get to choose between setting up a checkpoint and restoring to an
earlier checkpoint.

4. Select the Create a Restore Point option (see Figure 7-14) and click
Next.

5. Type a descriptive checkpoint name (such as Things Are Finally
Working Okay) and click Create.

Windows automatically brands the checkpoint with the current date and
time.

6. Windows creates a restore point with little fanfare and lets you go on
your merry way.

& System Restore

Welcome to System Restore

Yiou can use System Restore to unda harmful changes to
your computer and restore its settings and performance, 2 ~
System Restore reburns your computer to an earlier time Tobeging selectthe bask that you wank by pesfoem:
(caled a restore poirk) withauk causing you to lose recant
work, such as saved documents, e-mal, or history and ) Restore my compliter to an eatlier time
Farvorites lists.

Any changes that System Restore makes to your computer
are campletely reversible.

‘our computer automaticaly creabes reskore points {called
system chedkpaints), but you can also use Syskem Restore
to create your own restore paints. This is useful iF you are
abouk to make a major change to your system, such as
Instaling & new program or changing wour regstry,

Syskem Restore Settings

Figure 7-14:
Windows
XP creates
checkpoints
on demand.

To conkiue, select an option, and then clck Next.
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Figure 7-15:
Choose the
checkpoint
that you
need.

If you ever need to restore your computer to a previous state, follow these
steps:
1. Save your work and then close all running programs.

System Restore doesn’t muck with any data files, documents, pictures,
or anything like that. It only works on system files. Your data is safe.

2. Choose Start=>All Programs=>Accessories—>System Tools=>System
Restore.

3. Select the Restore My Computer to an Earlier Time option and click
Next.

4. Select the date and specific checkpoint that you want to restore to
(see Figure 7-15).

5. Windows shuts down, restarts, and restores itself to the point you
chose.

System Restore is a nifty feature that works very well.
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1. On this calendar, click a bold date. 2. On this list, click a restore point.
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Chapter 8: Focusing on Window's
XP/Professional

In This Chapter

v Determining if you need Windows XP/Pro

v Finding out what to do if you have Windows XP/Pro and you want
Windows XP/Home

v Finding out what to do if you have Windows XP/Home and you need
Windows XP/Pro

1+ Taking advantage of Windows XP/Pro’s features

Wth certain specific exceptions (for example, the discussion of
client/server networking in Book IX, Chapter 1), Windows XP All-in-

One Desk Reference For Dummies, 2nd Edition, is aimed directly at the
Windows XP/Home user.

Why? With few exceptions, Windows XP/Pro has nothing to offer the garden-
variety Dummy. Hey, you can throw away that extra hundred bucks if you
want to. But I'd much rather that you spent it on something worthwhile —
like, oh, a copy of Windows XP Timesaving Techniques For Dummies (written
by yours truly and published by Wiley Publishing, Inc.), for example. Not
that I'm biased or anything.

This chapter looks at the exceptions — why you may want to pay extra for
Windows XP/Pro, and what to do with Windows XP/Pro if you get it, either
voluntarily or by corporate edict.

Differentiating Windows XP/Pro
and Windows XP/Home

On the surface, Windows XP/Home and Windows XP/Pro look very different.
Just from the get-go, the installers make different assumptions about the kind
of network that you want to establish. Windows XP/Home sports a friendly
point-and-click Welcome screen, while Windows XP/Pro requires you to log
on — and that, in turn, means you have to know your logon L.D. and pass-
word before you can even begin. In Windows XP/Home, you can easily switch
among multiple users on the same machine. In Windows XP/Pro, switching
users is about as easy as switching offices at CIA headquarters.
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Underneath the surface, though, the products are remarkably similar.
Almost all of the features in Windows XP/Pro are also in Windows XP/Home,
and they behave in precisely the same way. Even the CDs for Windows XP/
Home and Windows XP/Pro are very nearly identical — only a handful of
files differ. Windows XP/Pro users can even tell Windows to use the easy
Welcome screen and fast user switching, if they’re so inclined, providing the
PC isn’t connected to a Big Corporate Network.

That’s not accidental. Microsoft designed it that way, at least for this version
of Windows. Redmond’s Product Managers used to promise us that some
future version of Windows would provide “more value” for the Windows
XP/Pro sucker, er, purchaser than the Windows XP/Home purchaser. But for
now the pickins are slim indeed, and Microsoft seems to have its hands full
just plugging the security holes.

Weighing the advantages of Windows XP/Home

Windows XP/Home’s main advantage lies more in what it doesn’t have than
in what it does have, if ya know what I mean.

Windows XP/Home assumes that you don’t want or need a lot of file protec-
tion. Windows XP/Home won'’t tie into a sophisticated corporate security
system. It doesn’t recognize the heavy-duty security built into Windows NT
Server or Windows 2000 Server or Windows Server 2003.

Starting with Windows 2000 Advanced Server, Big Corporate Network secu-
rity comes in the guise of the Active Directory, a comprehensive tool for
managing computers on a client/server network, as well as managing users,
system resources (such as printers and Internet connections), and the inter-
actions among all of the pieces. Active Directory is a world unto its own,
with so many technical nooks and crannies that it has spawned an entirely
new breed of Network Administrators, charged specifically with the care and
feeding of the AD beast.

On the flip side, most small business users don’t want or need the overhead
inherent in a heavy-duty security system — Network Administrators don’t
come cheap, and do-it-yourself network administration rates right up there
with do-it-yourself proctology. Home users almost never want to subject
themselves to the extra hassle.

Windows XP/Home’s lessened security requirements buy you a lot of extra
goodies. The following are features that you will find in Windows XP/Home,
but won’t find in Windows XP/Pro:

4+ Simple logon via the point-and-click Welcome screen.

4+ No need to memorize a user name or password, unless you really want
to (see Book I, Chapter 2).
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4+ Fast switching among users, so that you can let little Billy surf the
Internet real quick while you run and check on the cat.

If you have a Windows XP/Pro system that is not connected to a client/
server network (that’s a Big Corporate Network, or a “domain” in Microsoft
parlance), you can make Windows XP/Pro treat users just like Windows
XP/Home. Choose Starte>Control Panel=>User Accounts=>Change the Way
Users Log On or Off. Using the settings in the User Accounts dialog box, you
can tell Windows to use the Windows XP/Home-style Welcome screen,
and/or allow fast switching among users.

All of the added Windows XP/Pro security comes via client/server network-
ing — which Microsoft calls a domain. For much more information about
client/server and domains, see Book IX, Chapter 1.

Of course, the other big advantage to Windows XP/Home is the price. If
you’re buying Windows in a shrink-wrapped package off the shelf, Windows
XP/Home costs about a hundred dollars less than Windows XP/Pro. If you're
buying a new PC, Windows XP/Home may be free, while Windows XP/Pro —
if it’s available at all — costs a pretty penny or two or ten. Thousand.

Have you ever seen those signs from the PC manufacturers that say, “We rec-
ommend Windows XP/Pro”? I've seen them on Web sites, in computer shops,
in newspaper ads, even on billboards. You know why the manufacturers rec-

ommend Windows XP/Pro? Because they make more money selling it!

Weighing the advantages of Windows XP/Pro

If you need Windows XP/Pro, you probably already know it — or somebody
in your company has told you, in no uncertain terms, that you need it,
bucko, so you better get with the system.

There’s a reason why corporate IT folks can be so, uh, insistent (that’s the
polite term, anyway) about you installing Windows XP/Pro. They're con-
cerned about security, and for good reason. If you run Windows XP/Home on
your PC, and you manage to get hooked into the Big Corporate Network —
you know, the one that runs on the Big Corporate Server — you and your PC
represent a significant security risk.

Here’s a common high-risk security scenario (computer security types love
to use the term scenario, so 'm humoring them):

1. You install Windows XP/Home on your portable computer; then you
lug that computer into the office and plug it into the Big Corporate
Network.

2. You get onto the Big Corporate Network using, say, the technique
described in the section, “Converting Windows XP/Home to Windows
XP/Pro,” later in this chapter.

Book |
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3. You use your itty-bitty portable’s modem to dial out to the big, bad
Internet, and you don’t use the Windows Firewall. Ba-da-bing, ba-da-
boom, you’ve opened a hole into your company’s network.

That kind of security breach is hardly unique to Windows XP/Home — it’s
been around for a long time — but the widespread availability of Windows
XP/Home and its simple networking setup makes it a big, big target. Security
folks, understandably, don’t like having machines on “their” network that
poke gaping holes in their carefully crafted protection plans.

Security concerns go beyond simple modem back doors. Windows XP/Pro
sports all sorts of security features that Windows XP/Home can’t match:

4 Full integration with Active Directory: That means, with Windows XP/Pro,
you can use Active Directory on the Big Corporate Network to control
who uses your PC and what they can do on your PC (and on the network
as a whole) — and official Network Administrators are in charge of the
whole shootin’ match.

4+ Domains: Even if your company doesn’t use Active Directory, Windows
XP/Pro takes full advantage of the features Microsoft builds into all of its
client/server networks (domains). Lots of capabilities are associated
with domains, including the ability to predefine access privileges for
groups of users and assign each individual user to a specific group.

With Windows XP/Pro, if you have the Network Administrator’s blessing,
you can control access to individual files. With Windows XP/Home, the
lowest-level control is for entire folders.

4 Encryption: Windows XP/Pro lets you encrypt individual files and
folders using the NTFS file system’s built-in encryption routines (for a
description of NTFS, see Book I, Chapter 2). Windows XP/Home lets you
mark folders as Private, thus making it difficult for other people to get at
them, but encryption goes one step further by scrambling the contents.
NTFS encryption is notoriously difficult to crack.

Windows XP/Pro’s file encryption capability strikes a resounding chord
with many portable PC users who are concerned about losing their
portables and having all of their data accessible to the cretin who ran
away with the machine. If you carry around sensitive data, and you don’t
want to encrypt individual files (using, say, the Microsoft Office encryp-
tion routines), Windows XP/Pro may be a good choice, based on this one
feature alone.

Windows XP/Pro also includes a couple of features that are lacking in
Windows XP/Home and that make it easier to use in a corporate (read:
client/server) environment:



Differentiating Windows XP/Pro and Windows XP/Home 205

4+ IntelliMirror: This feature makes it easy (well, at least possible) for Book I
Network Administrators to push installations of operating systems — Chapter 8
force networked computers to install specific pieces of software.

IntelliMirror allows push installs of entire operating systems, compo-

nents, some applications, and their upgrades, onto all PCs connected to o= sl

the Big Corporate Network. = 22

I3 =

V?‘“\NG" If everybody comes into the office one morning and discovers that, oh, s 3 a

S Word doesn’t work right, chances are pretty good that somebody in IT 838
~

pushed upgrades onto all the machines. Microsoft Office patches, in par-
ticular, are notorious for not working right the first time.

4+ Roaming User Profiles: Windows configures itself to your preferences,
no matter which PC you use on the network.

Finally, Windows XP/Pro has a grab bag of additional features that a few
users may want:

4+ Remote Desktop: This feature allows you to take over your office com-
puter while you’re on the road. The computer at the office has to be run-
ning Windows XP/Pro — Windows XP/Home won’t cut the mustard. The
computer that’s traveling can be running just about any version of
Windows, from Windows 98 on.

If you're seriously considering Remote Desktop (see the Windows Help
and Support Center topic Remote Desktop), make sure you take a look at
Remote Assistance (see Book I, Chapter 4). Although the two are inher-
ently different — for example, you have to explicitly initiate a Remote
Assistance session from the “zombie” computer; and you have to have
someone physically present on the zombie computer to click a couple
of buttons — in many respects they accomplish the same thing. Remote
Assistance is much, much easier to install and use. It’s also arguably
more secure. Remote Desktop requires Windows XP/Pro on the zombie
computer — and any version of Windows can reside on the “controller” —
and Remote Assistance requires Windows XP (Home or Pro) on both
computers.

4+ Personal Web Server: This feature lets you build a Web site on your
Windows XP/Pro machine. (It’s actually Internet Information Services
version 5.1.) Anyone who has access to the files on your machine will be
able to view your personal Web pages using a browser, just as if they
were on the Internet.

4 Dual-CPU Support: If you own a computer with two CPU chips, you need
to run Windows XP/Pro if you want to take advantage of both of them.
Windows XP/Home uses only one chip, no matter how many chips you
have installed.

4 Multilingual User Interface: Only Windows XP/Pro can have its language
changed on the fly, so you can see dialog boxes in different languages.
Or so 'm told.
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v«{\\\\NG! If you want to upgrade your current Windows 2000 PC to Windows XP — that
is, install Windows XP on top of Windows 2000 and carry along all of your
settings and applications — you have to pay for Windows XP/Pro. Windows
XP/Home won'’t install over the top of Windows 2000, although it will install
over Windows 98 or Me. I give full details in Book I, Chapter 1.

Making a buying decision
Want to know which version of Windows XP to buy? Here’s Woody'’s Tried-
and-True Quick Windows XP/Pro/Home Decision Tree For Dummies:

4+ If you're going to install Windows XP on a computer that will be attached
to a Big Corporate Network, chances are awfully good that the Network
Administrator will insist that you use Windows XP/Pro. Do it.

4+ If you decide that you really have to set up your own Big Corporate
Network — with all the security capabilities that entails — don’t buy
Windows XP/Pro or Windows XP/Home just yet. Do yourself a favor and
hire a Network Administrator with Active Directory experience and a
long list of satisfied customers to scope out your situation before you
open that particular vein and let it bleed. Uncle BillyJoeBob down at the
local Computers Were Us shop doesn’t make the grade.

\\J

You should consider becoming your own Network Administrator only if
you seriously wish to pursue a new full-time career — and you have a
very high tolerance for pain. It helps to have several screws loose, too.

4+ If you're going to install Windows XP on a portable computer and you're
worried about somebody walking away with the computer and the data,
get Windows XP/Pro and immediately encrypt your sensitive folders.
(You need to be using the NT File System, NTFS, in order to encrypt a
drive. See the discussion in Book I, Chapter 2.)

To encrypt the My Documents folder with Windows XP/Pro, choose
Start>My Documents. On the left in the task pane, click Share This
Folder. On the General tab, click Advanced. Then select the Encrypt
Contents to Secure Data check box.

4+ If you need to be able to connect to your office computer while you're
on the road, and nobody’s around to push a couple of keys while you’re
gone (to get Remote Assistance going), you probably want Remote
Desktop. Go ahead and buy Windows XP/Pro.

4+ If the PC you're using right now has Windows 2000 or Windows NT 4
installed on it, and you want to upgrade to Windows XP over the top of
the old Windows, you need Windows XP/Pro because Windows XP/Home
won’t do the upgrade. Be very wary of this approach, though, because
in-place upgrades are notoriously fragile.

4 Look hard at the list of Windows XP/Pro features in the section,
“Weighing the advantages of Windows XP/Pro.” If you find a feature
that you absolutely can’t live without, get Windows XP/Pro.
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In the vast majority of cases, you either connect to a Big Corporate Network Book |
and will thus require Windows XP/Pro, or you’ll be happy as a dog in a Chapter 8
butcher shop with Windows XP/Home.
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What? You got the wrong version of Windows XP? 828

Don’t worry. Happens all the time. Keep on reading to find out what to do.

Converting Windows XP/Home to Windows XP/Pro

By far the most common mismatch arises when someone (I'll raise my hand
here) buys Windows XP/Home for a particular machine, but decides he
should’ve bought Windows XP/Pro.

If you really need Windows XP/Pro and all that it contains, Microsoft will sell
you an upgrade kit, complete with CD, that fills in the gaps. Check with your
friendly local ye olde software shoppe.

In many cases, though, all you really need is a Windows XP/Home machine
that can get at stuff stored on the Big Corporate Network. If that’s the case,
not to worry. Have I got a trick for you — all it takes is a logon I.D. and pass-
word for the Big Corporate Network.

Say you have a portable PC that’s running Windows XP/Home, and you want
it to do double duty. At home — or, say, in a small field office — you want it
to run on the regular, old, everyday Windows XP/Home network. But when
you plug it into the docking station at the main office, you want to use the
portable to get into your Big Corporate Network.

No problem. Here’s my favorite way to do it:
1. Warn your Network Administrator that you’re going to be sticking a

Windows XP/Home machine on the Big Corporate Network.

2. Get the PC working on the home (or field office) peer-to-peer network
(which Microsoft calls a workgroup).

That may involve installing Windows XP/Home or customizing it. Follow
all the steps for installing a network in Book IX, Chapter 2.

3. When the PC is working with the home or field office network, bring
it into the main office and fire it up.

4. Attach the PC to the Big Corporate Network.

You probably plug in a cable or a card or both.
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Figure 8-1:
Getting to
the Big
Corporate
Network
from a
Windows
XP/Home
PC.

5. Choose Start->My Network Places.

6. Click View Workgroup Computers.

7. In the Other Places pane, click Microsoft Windows Network.
8. Choose the Big Corporate Network.

In Figure 8-1, I chose the client/server network called Sabai. The alterna-
tive, Mshome, is the default Windows XP/Home peer-to-peer network.

9. Windows requires you to enter a valid 1.D. and password for the Big
Corporate Network. Enter it, click OK, and you’re in (see Figure 8-2).

In some cases, this little trick may be all you need to run Windows XP/Home
on your Big Corporate Network.

Converting Windows XP/Pro to Windows XP/Home

What if you bought Windows XP/Pro and all you want is Windows XP/Home?

Hey, that’s easy, too. You can’t get your money back, but you can readily con-
vince a Windows XP/Pro machine to look and act pretty much like a
Windows XP/Home machine.

The standard XP/Home network (a peer-to-peer
workgroup in Microsoft parlance)
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Figure 8-2:
The com-
puters on
the Sabai
client/server
network, as
viewed from
a Windows
XP/Home
PC.

Changing Your Mind 209

27 Sabai [‘;]@EJ

File Edit View Favorkes Tooks Help i

@Back = > ? / Search i Folders E‘v

Network Tasks A0 g_guellzzuo

wf Add 3 retwork place

& Visw network connections f

’ Inspircapro

3 Set up a home or small 5 Firee
office network. :

,t’ Wiew workgroup computers

Other Places
Y Microsoft Windows
Nebwork
o My Computer
(L) My Documents
|3 Shared Dacuments

g Brinters and Faxes

Details ¥

You may want to change two cosmetic differences between Windows
XP/Home and Windows XP/Pro:

4+ Windows XP/Home shows the Quick Launch Toolbar; Windows XP/Pro
does not. (The Quick Launch Toolbar is a bunch of little icons immedi-
ately to the right of the Start button.) For instructions on how to show
the Quick Launch Toolbar, see Book I, Chapter 3.

4 Windows XP/Pro puts an item called My Recent Documents on the Start
menu; Windows XP/Home does not. See Book II, Chapter 2, if you want to
turn it off.

If you install Windows XP/Pro rather blindly — or if you bought a new PC
with Windows XP/Pro preinstalled — it may think that it should belong to a
network called Workgroup. Unless you’ve changed the settings, Windows
XP/Home computers think that they belong to a network called Mshome.

Here’s how to convince a default Windows XP/Pro machine to look for a
Windows XP/Home network:

1. Choose Start=>Control Panel.

2. Click Performance and Maintenance; then click System.

3. On the Computer Name tab (see Figure 8-3), click Change.

4. In the Computer Name Changes dialog box that appears, select the
Workgroup option button and type in the Windows XP/Home (peer-to-
peer workgroup) network’s name.

Book |
Chapter 8
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Figure 8-3:
Tell
Windows
XP/Pro to
attach the
PCto a
different
network by
going
through the
Computer
Name tab.

Unless you’ve gone to Herculean lengths to change it, the name is

Mshome (see Figure 8-4).
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5. Click OK twice. Book |

Chapter 8
The PC takes a few minutes to get its bearings, but if you have a peer-to- apter

peer network running, you should be able to verify the change by choos-
ing Start=>My Network Places.

FE7
Sg8
You can use this same technique to switch a Windows XP/Pro machine back § g @,
to a Big Corporate Network. When you get to the Computer Name Changes s a
dialog box shown in Figure 8-4, simply select the Domain option button. D E S

v?‘“\NG! Even though it may not appear to be that way, the Computer Name text box
in the Computer Name Changes dialog box (refer to Figure 8-4) is case sensi-
tive. If you're trying to get connected to a domain called Sabai and you type
SABAI, Windows XP won'’t be able to find it — at least, it didn’t on my net-
work. That’s true, even if the name appears as all-caps in the dialog box.

Installing Windows XP/Pro

Installation of Windows XP/Pro proceeds almost identically to installation of
Windows XP/Home, with one key difference. (I discuss installing Windows
XP/Home at length in Book I, Chapter 1.)

The key difference: During installation, you encounter a dialog box that asks,
“Do You Want to Make This Computer a Member of a Domain?” Although it
may not be immediately obvious, you have three choices:

4+ Select the No, This Computer Is Not on a Network or on a Network with-
out a Domain check box. That sets the computer up for peer-to-peer
(workgroup) networking. See Book IX, Chapter 2 for details.

4 Select the No, This Computer Is Not on a Network or on a Network with-
out a Domain check box and type a name in the Make This Computer a
Member of the Following Workgroup text box. This choice sets up the
computer for peer-to-peer networking on the network that you pick. If
you want the Windows XP/Pro machine to get along with a typical
Windows XP/Home network, type MSHOME in that text box.

4+ Select the Yes, Make This Computer Part of the Following Domain check
box and type a domain name into the indicated text box.

If you choose to make your computer part of a domain, Windows XP/Pro
asks you to supply an Administrator I.D. and password for the domain. If you
can do that, Windows XP/Pro reaches out to the server adds you to the
network — er, domain.
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Figures 8-5 and 8-6 show a newly installed Windows XP/Pro machine called
INSPIRONPRO that has added itself to the Active Directory on a server run-
ning Windows 2000 Advanced Server.

P If you're installing Windows XP/Pro on a PC that’s connected to a Big
Corporate Network, try to con the Network Administrator into looking over
your shoulder at the very end of the installation. She’ll be able to provide
the appropriate logon 1.D. and password at the key moment, so that your
machine gets added to the network with a minimum of fuss and bother.
Saying “please” works wonders. Bribery works better.
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Chapter 1: Personalizing
YVour Desktop

In This Chapter

v~ Finding the real story on how Windows puts together your desktop
v Taking control of each desktop level
1 Seeing why you’re better off ignoring some of the fancy stuff

v~ Establishing a Super Boss Key — a key combination that immediately
starts a screen saver

v Making your folders stand out

It’s your desktop. Do with it what you will.

I've never bumped into a complete description of how the Windows desktop
gets tossed together, so you Dummies go to the head of the class. You may
think it’d be easy for a computer to slap windows on the screen, but it isn’t.
In fact, Windows XP uses seven separate layers to produce that Windows
eXPerience — and you can take control of every layer. [ show you how in
this chapter.

[ also include a discussion of Desktop Themes, backgrounds in Windows
Explorer, and custom pictures for folders. Pretty cool stuff, especially when
you see CD album covers plastered on My Music folders.

Most importantly, I include instructions for creating a Super Boss Key in the
section called “Selecting Screen Savers.” When you press a key combination
that you choose — say Alt+F10 — a Windows screen saver immediately
springs into action. If you've ever been surprised when the boss walked in
as you were dusting off your résumé, day trading, or playing a mean game
of Minesweeper, you now know how to cover your tracks. You're welcome.

Recognizing Desktop Levels

The Windows XP desktop — that is, the stuff you see on your computer
screen — consists of seven layers (see Figure 1-1).
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For a quick change of pace, Desktop Themes change all seven layers, all at
once. | talk about Desktop Themes in the section, “Using Desktop Themes,”
later in this chapter.

Here are the seven settings that control how Windows dishes up your
desktop:

4 At the very bottom, the Windows desktop has a base color, which is a
solid color that you see only if you don’t have a background picture
or if your chosen background doesn’t fill up the entire screen. Most
people never see their Windows base color because the background
usually covers it up. I tell you how to set the base color and all of the
other Windows colors — for dialog boxes, the taskbar, the works — in
the section, “Setting Colors in Windows XP.”

4+ Above the base color lives the Windows background. (Microsoft used to
call it wallpaper, and you’ll see that name frequently.) You may be famil-
iar with the rolling hills background — the one Microsoft calls Bliss —
because it’s the one that ships with Windows XP.
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The people who sold you your computer may have ditched Microsoft’s
Bliss background and replaced it with some sort of dorky ad. I tell you
how to get rid of the ad and replace it with a picture you want in the sec-
tion, “Picking a Background.”

4+ On top of the background, Windows lets you put pictures, Web pages,
and just about anything you can imagine. Microsoft even has a little
stock ticker and weather map that you can download and stick in this
layer. This is the so-called Active Desktop layer and, by and large, it’s a
disaster. [ tell you why in the section, “Avoiding the Active Desktop.”

4+ Windows puts all of its desktop icons on top of the Active Desktop layer.
Bone-stock Windows XP includes only one icon — the Recycle Bin. If you Book Il
bought a PC with Windows XP preinstalled, chances are good that the Chapter 1
manufacturer put lots of additional icons on the desktop, and you can
easily get rid of them. I tell you how in the section, “Controlling Icons.”

4+ Above the icons you (finally!) find the program windows — the ones that 5 ‘..?
actually do work. You know, little things like Word, Excel, and the Media = §
Player. a2

Z N

4+ Then you have the mouse, which lives in the layer above the program S 3

windows. The complete lowdown on standard mouse pointers — how
they work and what they do — appears in the section on pointers in
Book [, Chapter 2. If you want to change the picture used for the pointer,
[ talk about fancy mouse pointers in the section, “Changing Mouse
Pointers,” later in this chapter.

4+ At the very top of the desktop food chain sits the screen saver. The
screen saver kicks in only if you tell Windows that you want it to appear
when your computer sits idle for a spell. I talk about that beast in the
section, “Selecting Screen Savers.”

If you have more than one user on your PC, each user can customize every
single part of the seven layers to suit his or her tastes, and Windows XP
remembers every setting, bringing it back when the user logs on. Much
better than getting a life, isn’t it?

Setting Colors in Windows XP

Windows XP ships with three designer color schemes: Blue (the default
scheme, which you probably use), Olive Green (which looks just as bad as
you might imagine), and Silver (rather, uh, self-consciously techno-blah). To
change color schemes, follow these steps:

1. Right-click any empty part of the Windows desktop and choose
Properties.

The Display Properties dialog box appears.
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2. Click the Appearance tab (see Figure 1-2).

3. From the Color Scheme drop-down list, choose Default (blue), Olive
Green, or Silver, and then click OK.

Windows changes the base color — that is, the color of the Windows
desktop when no background appears or the background doesn’t fit (see
the section, “Picking a Background”) — as well as the title bar color of
all windows and dialog boxes, the color of the Windows taskbar, menu
highlight colors, and a dozen other colors scattered in various places
throughout Windows.

You aren’t confined to Microsoft’s three-color world. In fact, you can pick
and choose many different Windows colors, individually, although some of
them appear on-screen only if you tell Windows to use the Windows Classic
Style of windows and buttons — the old-fashioned pre-XP style, where win-
dows had squared off edges and OK buttons weren’t so boldly sculpted.

If you're terribly nostalgic for old-fashioned Windows windows, choose
Windows Classic Style from the Windows and Buttons drop-down list shown
in Figure 1-2.

If you ever need to shoot pictures of the computer’s screen, you will proba-
bly want to get rid of the distracting background and turn the desktop itself
white. (That’s how all the screens shown in the figures in this book were
shot.)

To set the desktop’s base color to white — regardless of whether you use
Windows XP Style or Windows Classic Style windows and buttons — follow
these steps:

1. Right-click any empty part of the Windows desktop and choose
Properties.
The Display Properties dialog box appears.

2. Click the Appearance tab (see Figure 1-2).

3. Click Advanced.
You see the Advanced Appearance dialog box, as shown in Figure 1-3.

4. Make sure that Desktop appears in the Item drop-down list; then click
the down-arrow under Color 1, and click the white color swatch in the
upper-left corner.

5. Click OK twice.

Your desktop base color is now set to white, although you may have to
change (or get rid of) your background in order to see it. I talk about
strangling and axing the background in the next section. Stand back,
Lizzie Borden.
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The Advanced Appearance dialog box (refer to Figure 1-3) seems to be
saying that you have to use Windows Classic windows and buttons in

order to see changes made in the Advanced Appearance dialog box. At

least, I think that’s what the dialog box says. (Sometimes this computer
gobbledygook really confuses me.) Read it and see what you think. Anyway,
if you're spooked and think that you have to switch back to the old Windows
Classic windows and buttons in order to change your base color, not to
worry: Just follow the steps and you’ll be fine. Trust me.
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Picking a Background

Windows XP, straight out of the box, ships with a picture of rolling verdant
hills as the background. This background is peaceful and serene — Microsoft
calls it “Bliss” — and it’s booooooooring.

If you bought a PC with Windows XP preinstalled, chances are very good
that the manufacturer has replaced Bliss with a background of its own
choosing — maybe the manufacturer’s own logo or something a bit more
subtle, like “Buy Wheaties.” Don’t laugh. The background is up for sale. PC
manufacturers can include whatever they like. You probably have an AOL
icon on your desktop. Same thing. Guess who bought and paid for that?

There’s nothing particularly magical about the background. In fact, Windows
XP will put any picture on your desktop — big one, little one, ugly one, even
a picture stolen straight off the Web. Here’s how:

1. Right-click on any empty part of the Windows desktop and choose
Properties.

The Display Properties dialog box appears.
2. Click the Desktop tab.

In the Background box, Windows XP lists pictures from the Windows
folder and the My Pictures folder. (It also lists Web pages — files with
HTM or HTML as filename extensions — in both of those folders.)
Windows ships with lots of pictures in the Windows folder.

3. Scroll through the Background box and pick the picture you want.

If you don’t see the picture you're looking for — surprisingly, pictures in
the Shared Pictures folder aren’t included in this list, for example —
click the Browse button and go find the picture. A preview of the picture
appears in the little screen in the dialog box.

4. If your picture is too big to fit on the screen, you need to tell Windows
how to shoehorn it into the available location. If your picture is too
small to cover up the entire screen, you need to tell Windows what to
do with the extra room. You do both in the Position drop-down list, as
described in Table 1-1.

Table 1-1 How Windows Resizes Desktop Pictures

Position If the Picture If the Picture
Is Too Big Is Too Small

Center Windows carves a piece out of Windows puts the picture in the center
the middle of the picture and of the screen and fills the unoccupied

puts it on the screen. part of the screen with the base color. *
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Position If the Picture If the Picture
Is Too Big Is Too Small

Tile Windows takes a suitably sized Windows puts one copy of the picture
piece out of the upper-left corner  in the upper-left corner of the screen,
of the picture and uses it as the and then “tiles” (repeats) additional
background. copies of the picture to fill up the

remainder of the screen.

Stretch Windows squishes the pictureto  Windows stretches the picture so that

fit the dimensions of the screen. it fits. Think Torquemada — it looks

If you're working with a photo, the  awful with a photo.
effect is almost always horrible.

* See the discussion of base color in the section, “Setting Colors in Windows XP.”

Selecting None for a background means that you don’t want Windows XP
to use a background at all: It should let the base color show through,
unsullied.

5. If you tell Windows to put your too-small picture in the Center of the
screen in the Position drop-down list, you can use the Color box as a
quick way to set the base color.

6. Click the Apply button.

Windows changes the background according to your specifications but
leaves the Display Properties dialog box open so that you can change
your mind.

7. Click OK.
The Display Properties dialog box disappears.

Many people are mystified by the Color box on the Display Properties dialog
box because it doesn’t seem to do anything. In fact, Color kicks in only when
you choose Center for the Position and when the picture you've chosen as a
background is too small to occupy the entire screen.

Changing the base color in the Advanced Appearance dialog box (see
Figure 1-3) also changes the color on the Desktop tab and vice versa.

Windows XP lets you right-click a picture — a JPG or GIF file, regardless of
whether you’re using Windows Explorer or Internet Explorer — and choose
Use as Desktop Background. When you do that, the picture appears as the
background, with Position set to Stretch (if the picture is too big for the
screen) or Tile (if the picture is not too big for the screen).

Book I
Chapter 1
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Avoiding the Active Desktop

You can read all the way through the Windows XP help files and never find
a single mention of “Active Desktop,” although it’s featured prominently in
Windows 98, Me, and 2000 product literature — touted as one of the big rea-
sons to upgrade to those old dinosaurs, in fact.

There’s a reason why. Active Desktop, introduced years ago in Internet
Explorer 4, has a reputation for sucking up computer power and crashing
Windows, inexplicably and unpredictably, with gleeful abandon. Believe me,
you’ve never seen a program as gleeful as Active Desktop about crashing
Windows 98.

Microsoft has completely abandoned the terminology, but the technology
remains in Windows XP. And if you use it right, you’ll discover that it isn’t as
bad as it used to be.

[ believe Alexander Pope called that “damning with faint praise.”

The concept is simple enough: Windows XP lets you put pictures and Web
pages (even tiny Web pages, called live content) on top of your desktop back-
ground but underneath the Windows icons. In practice, you shouldn’t have
any problem at all putting static things — such as a picture, a calendar, or
other stuff that doesn’t change — on top of the background. But you're beg-
ging for trouble if you toss “live” things — such as stock market tickers — in
there.

Static material sitting on top of the desktop’s background doesn’t make
many demands on Windows. Live things can tie up your PC, your Internet
connection, and your life. If you want live content — news feeds, weather
updates, commodities prices, Webcam shots of corn growing in Kansas —
open up Internet Explorer and work directly with the source.

To put items on top of your desktop’s background but underneath the icons,
follow these steps:

1. Right-click any open space on the desktop and choose Properties.

2. In the Display Properties dialog box, click the Desktop tab, and then
click the Customize Desktop button.

The Desktop Items dialog box appears.
3. In the Desktop Items dialog box, click the Web tab (see Figure 1-4).

Although the check box is marked Web Pages, in fact you can put any
picture or Web page (including any HTML file located on the Web or on
your hard drive) in the Active Desktop layer. The way you do it is a little
strange.
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4. Add the picture or Web page to the Web Pages list. Then select the
check box next to the picture or page, and Windows actually adds
it to the Active Desktop.
For example, My Current Home Page appears as one of the options in
the Web Pages list, but it isn’t actually shown on top of your desktop
background because the check box in Figure 1-4 isn’t checked.
Confusing? You bet it is.
5. Add new pictures or Web pages to the Web Pages list by clicking the
New button.
You see the New Desktop Item dialog box, as shown in Figure 1-5.
V?‘“\NG! You can follow the New Desktop Item dialog box’s suggestion and click
Visit Gallery, but be forewarned: The mini-Web pages Microsoft offers in

the Microsoft Desktop Gallery are very limited — the stock ticker and
weather map you can see in Figure 1-1, plus a sports news page and a
satellite tracker — and they haven’t been updated in years. That’s
because they’re “live content” and live content drags down your PC’s
performance and makes it less stable. Don’t go there.

6. Click Browse and navigate to any pictures that you want to put on top

of your desktop background. (Pictures are fine: They’re static and
won’t hurt anything.)

7. When you’re done gathering all the pictures you want, go back to the
Desktop Items dialog box (refer to Figure 1-4), select the check boxes

in front of any pictures that you definitely want to put on the desktop,

and click OK twice.
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When you get back to the desktop, you see a weird window with your

picture inside of it — a window that’s quite unlike any you've ever seen
(see Figure 1-6). You may have to hover your mouse near the top of the
picture to coax Windows into showing you the window’s gray top part.

. If you get tired of the picture, click the X in the upper-right corner

of the window, as shown in Figure 1-6, or navigate back to the Web
Pages list (see Step 5 in this list) and deselect the check box in front
of the picture’s name.

If you remove an Active Desktop picture by clicking the X in the upper-
right corner of the weird window, the only way to bring the picture back
is by bringing up the Web Pages list in the Desktop Items dialog box and
select the check box in front of the picture’s name.

If you select the Lock Desktop Items check box in the Desktop Items dialog
box (refer to Figure 1-4), Windows won’t show the gray top part of any of the
weird windows in the Active Desktop, even if you hover your mouse near the
top of the pictures ’til the cows come home. Without the gray top part show-
ing, you can’t move or resize any of the weird Active Desktop windows, so
they stay put.

Controlling lcons

Windows XP sticks icons above the Active Desktop items (see the preceding
section, “Avoiding the Active Desktop”) but below are the real, working
windows — the ones you use every day to get things done.

Windows XP, straight out of the box, ships with exactly one icon: the Recycle
Bin. Microsoft found that most people appreciate a clean desktop, 